Safety Guidelines

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices referring to property damage only have no safety alert symbol. The notices shown below are graded according to the degree of danger.

**Danger**
indicates that death or severe personal injury will result if proper precautions are not taken.

**Warning**
indicates that death or severe personal injury may result if proper precautions are not taken.

**Caution**
with a safety alert symbol indicates that minor personal injury can result if proper precautions are not taken.

**Caution**
without a safety alert symbol indicates that property damage can result if proper precautions are not taken.

**Notice**
indicates that an unintended result or situation can occur if the corresponding notice is not taken into account.

If more than one degree of danger is present, the warning notice representing the highest degree of danger will be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property damage.

Qualified Personnel

The device/system may only be set up and used in conjunction with this documentation. Commissioning and operation of a device/system may only be performed by qualified personnel. Within the context of the safety notices in this documentation qualified persons are defined as persons who are authorized to commission, ground and label devices, systems and circuits in accordance with established safety practices and standards.

Prescribed Usage

Note the following:

**Warning**
This device and its components may only be used for the applications described in the catalog or the technical description, and only in connection with devices or components from other manufacturers which have been approved or recommended by Siemens. Correct, reliable operation of the product requires proper transport, storage, positioning and assembly as well as careful operation and maintenance.

Trademarks

All names identified by ® are registered trademarks of the Siemens AG.
The remaining trademarks in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability

We have reviewed the contents of this publication to ensure consistency with the hardware and software described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the information in this publication is reviewed regularly and any necessary corrections are included in subsequent editions.

Siemens AG
Automation and Drives
Postfach 4948
90437 NÜRNBERG
GERMANY

Copyright © Siemens AG 2006
ASE005767200-01
Siemens AG 2006
Technical data subject to change.
Preface

Purpose of the Manual
This manual provides the information necessary to use the PCS 7/505 OS Symbols and Faceplates.

Required Basic Knowledge
Readers are presumed to be knowledgeable in the use of PCS 7.

Where is this Manual valid?
This manual is valid for the software package PCS 7/505 OS Option for V6.1.

Training Centers
Siemens Technical Training Center provides extensive training for all levels of plant personnel to ensure optimal performance from PCS 7 control systems. Classes include extensive hands-on activities using appropriate equipment, making the training directly and immediately applicable.
On-line information is available: http://www.sea.siemens.com/sitrain
Siemens also offers a number of training courses to familiarize you with the SIMATIC S7 automation system. Please contact your regional training center or our central training center in D 90327 Nuremberg, Germany for details:
Telephone: +49 (911) 895-3200.
Internet: http://www.sitrain.com
# Preface

## A&D Technical Support

Worldwide, available 24 hours a day:

![World Map with locations](image)

<table>
<thead>
<tr>
<th>United States: Johnson City, TN</th>
<th>Worldwide: Nürnberg</th>
<th>Asia / Australia: Beijing</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Technical Support and Authorization</strong></td>
<td><strong>Technical Support</strong></td>
<td><strong>Technical Support and Authorization</strong></td>
</tr>
<tr>
<td>Local time: Monday to Friday 8:00 AM to 5:00 PM</td>
<td>24 hours a day, 365 days a year</td>
<td>Local time: Monday to Friday 8:00 AM to 5:00 PM</td>
</tr>
<tr>
<td>Telephone: +1 (423) 262 2522 or +1 (800) 333-7421 (USA only)</td>
<td>Phone: +49 (180) 5050-222</td>
<td>Phone: +86 10 64 75 75 75</td>
</tr>
<tr>
<td>Fax: +1 (423) 262 2289</td>
<td>Fax: +49 (180) 5050-223</td>
<td>Fax: +86 10 64 74 74 74</td>
</tr>
<tr>
<td>Mail to: <a href="mailto:techsupport.sea@siemens.com">techsupport.sea@siemens.com</a></td>
<td>E-Mail: <a href="mailto:ad.support@siemens.com">ad.support@siemens.com</a></td>
<td>Mail to: <a href="mailto:ad.support.asia@siemens.com">ad.support.asia@siemens.com</a></td>
</tr>
<tr>
<td>GMT: -5:00</td>
<td>GMT:+1:00</td>
<td>GMT:+8:00</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Local time: Monday to Friday 8:00 AM to 5:00 PM</td>
<td>Local time: Monday to Friday 8:00 AM to 5:00 PM</td>
<td>Local time: Monday to Friday 8:00 AM to 5:00 PM</td>
</tr>
<tr>
<td>Phone: +49 (180) 5050-222</td>
<td>Phone: +49 (180) 5050-223</td>
<td>Phone: +49 (180) 5050-223</td>
</tr>
<tr>
<td>Fax: +49 (180) 5050-223</td>
<td>Fax: +49 (180) 5050-223</td>
<td>Fax: +49 (180) 5050-223</td>
</tr>
<tr>
<td>Mail to: <a href="mailto:ad.support@siemens.com">ad.support@siemens.com</a></td>
<td>Mail to: <a href="mailto:ad.support@siemens.com">ad.support@siemens.com</a></td>
<td>Mail to: <a href="mailto:ad.support.asia@siemens.com">ad.support.asia@siemens.com</a></td>
</tr>
<tr>
<td>GMT: +1:00</td>
<td>GMT: +1:00</td>
<td>GMT: +8:00</td>
</tr>
</tbody>
</table>

Automation and Drives Service and Support International

[http://www.siemens.com/automation/service&support](http://www.siemens.com/automation/service&support)

The languages of the SIMATIC Hotlines and the authorization hotline are generally German and English.
# PCS 7/505 OS Setup Guide

## 1 Introduction

1.1 Software Installation Overview ................................................................. 1-2

## 2 Install the Software

2.1 Install the Operating System ................................................................. 2-1
2.2 Install Third Party Software ................................................................. 2-1
2.3 Install PCS 7 Software ........................................................................ 2-1
2.4 Install PCS 7/505 OS Software ............................................................. 2-3
2.5 Install PCS 7/505 OS Software Hot Fixes/Service Packs .................. 2-5
2.6 Install Authorizations ......................................................................... 2-6
2.7 Install Complete .................................................................................. 2-6

## 3 Update a project from V6.0 to V6.1

3.1 Create a new project in SIMATIC Manager ........................................ 3-1
3.2 Create New Folders on the Primary and Standby Servers and All Clients .. 3-6
3.2.1 Configure the Stations .................................................................... 3-7
3.3 Update a project from V6.0 to V6.1 ..................................................... 3-20
3.3.1 Import a current WinCC project into SIMATIC Manager ............... 3-21

## 4 Create a New OS Project

4.1 Create a new project in SIMATIC Manager ........................................ 4-1
4.2 Create New Folders on the Primary and Standby Servers and All Clients .. 4-5
4.2.1 Configure the Stations .................................................................... 4-6
4.3 Start DBA for new projects ................................................................. 4-17
4.4 Run OS Project Editor (optional) ........................................................ 4-17
4.5 Edit Each Graphic ............................................................................ 4-17
4.6 Lifebeat Monitoring Setup .................................................................. 4-18
4.7 Time Synchronization Setup ............................................................... 4-23
4.8 Configure Alarm Logging ................................................................. 4-23
4.9 Configure Tag Logging ..................................................................... 4-23
4.10 Create Trends (if adding the Trend Object to a Graphic) .................... 4-23
4.11 Configure User Administrator ............................................................ 4-23
4.12 Generate Server Data ....................................................................... 4-24
4.13 Configure LMHOSTS and HOSTS Files ............................................ 4-24
4.14 Configure WinCC Project Network Settings ...................................... 4-25
4.15 Client Project Setup .......................................................................... 4-26
4.15.1 Assign OS Server ........................................................................ 4-26
4.15.2 Configure a Standard Server ........................................................ 4-26
4.15.3 Configure Preferred Server .......................................................... 4-26
4.15.4 Lifebeat Monitoring Setup ............................................................ 4-27
4.15.5 Configure Area Display in Runtime .............................................. 4-28
4.15.6 Configure User Administrator ........................................................ 4-28
4.15.7 Create Runtime Trends (archive or online trends) ....................... 4-28
4.16 Download the Projects ..................................................................... 4-29
4.16.1 Download all projects at the same time ......................................... 4-30
4.16.2 Download the project to the Primary Server ................................ 4-30
4.16.3 Download the project to the Standby Server ................................ 4-31
4.16.4 Download the project to the Client Station ................................... 4-31
4.17 Project Activation Sequence ............................................................. 4-32
4.18 Restarting an OS Server ................................................................. 4-32
## Contents

5 Download the Changes  
5.1 Overall Steps .................................................................................................... 5-1  
5.2 Making Changes to the Controller Configuration ............................................. 5-1  
5.3 Making additional Changes to the DBA Configuration ..................................... 5-3  
5.4 Modify the project in WinCC ............................................................................. 5-4  
5.5 Download changes ........................................................................................... 5-5  

6 Modify Faceplates and Symbols  
6.1 Faceplate Procedure ........................................................................................ 6-2  
6.2 Symbol Procedure ............................................................................................ 6-3
1 Introduction

The purpose of this document is to outline the steps required to set up a PCS 7 system and a corresponding PCS 7 project that communicate to SIMATIC 505 Controllers. Project development is done on an OS Engineering Station using WinCC Explorer. This document is based on the architectural layout below.

---

Note
For further information on a specific topic in this document, refer to the documentation on the PCS 7 CD set, the WinCC Information System or in the documentation folder Start >Siemens >Documentation >English on the hard drive.

---

![Architecture Diagram](image-url)
# 1.1 Software Installation Overview

**Notes**
- Administrator rights are required to install the software. In addition, disable any virus protection software that is currently running.
- All computers on the network must have the same user accounts and passwords.
- Skip steps 1-3 if PC was installed by Siemens.

<table>
<thead>
<tr>
<th>Step #</th>
<th>Installation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Install the Windows Operating system</td>
</tr>
</tbody>
</table>
| 2      | Install Microsoft hot fixes and service packs.  
**Note:** Contact Siemens for appropriate hot fixes and service packs |
| 3      | Install Microsoft SQL server 2000 with SP3a. |
| 4      | For each network card installed other than the CP1613, verify connectivity (from one or more other computers, ping this computer using the IP address of each installed network card). |
| 5      | Setup Windows user accounts. Each computer should have an administrator account. All other users (for example, Operators) should be members of the power users group. The user who is going to have access to PCS 7 must be the current, logged on user when PCS 7 is installed. |
| 6      | Install one or two CP1613 cards in each server and engineering station.  
(Refer to the PCS 7/505 Channel Guide for further details).  
Not applicable for Client Station. |
| 7      | Make an image of the PC. This will allow you to return to this point in the installation if necessary. If this is an update from V6.0 to V6.1, make a backup of your current WinCC and DBA projects. |
| 8      | Install PCS 7 OS Software. |
| 9      | Install PCS 7/505 OS Software. |
| 10     | Install PCS 7/505 OS option hot fixes or service packs.  
**Note:** Contact Siemens for appropriate hot fixes and service packs |
| 11     | Install authorizations and licenses. |

**Note**
The installation of some components automatically reboots the computer.  
Following the reboot, log on again as the PCS 7 user.
2 Install the Software

Note
If you are updating an existing installation, please review section three prior to installing any software.

2.1 Install the Operating System
Refer to the following references for detailed installation instructions:

From the PCS7 Installation DVD (PCS7 Toolset v6.1 with SP1), find
Manuals > English > PCS 7 – PC Configuration and Authorization.PDF

Please review installation instructions in both readme files:

- From the root directory of the PCS 7 Installation DVD (PCS7 Toolset v6.1 with SP1), find the file PCS7-Readme.wri. Note: If the logon name of the user who performed the installation of PCS 7 differs from the operator of the PCS 7 software, pay particular attention to the "OPC - Settings under Windows 2000" section of this document.

- From the PCS 7 Installation DVD (PCS7 Toolset v6.1 with SP1), find Manuals > English > PCS 7 System Documentation Readme.wri

Additional information: Start > Simatic > Information > English

2.2 Install Third Party Software
Third party software (e.g. Microsoft Office, PC Anywhere, Virus software etc...) should be installed prior to installing PCS 7. Refer to the PCS 7-Readme.wri and PC Configuration and Authorization. PDF file for further information.

2.3 Install PCS 7 Software
Refer to the following references for detailed installation instructions:

From the PCS7 Installation DVD (PCS7 Toolset v6.1 with SP1), find Manuals > English > PCS 7 – PC Configuration and Authorization.PDF

Please review installation instructions in both readme files:

- From the root directory of the PCS 7 Installation DVD (PCS7 Toolset v6.1 with SP1), find the file PCS7-Readme.wri

- From the PCS 7 Installation DVD (PCS7 Toolset v6.1 with SP1), find Manuals > English > PCS 7 System Documentation Readme.wri
Install the Software

Note
Select the appropriate software packages during PCS 7 software installation.
Use the following as a guide:

- Engineering Node - Select PCS 7 Engineering
- OS Servers - Select OS Server
- OS Clients - Select OS Client (All clients must be upgraded to PCS 7 V6.1 SP1 to communicate with PCS 7/505 OS Option)

Archive Server – There are no PCS 7/505 OS Option software components that need to be installed on the Archive Server. However, the Archive Server must be at PCS 7 V6.1 SP1.
2.4 Install PCS 7/505 OS Software
This section outlines the PCS 7/505 OS software installation procedure.

Note
Prior to installing this software, log on with Administrator rights and disable any virus protection software that is currently running. In addition, this software should be installed after all other PCS 7 software has been installed. Refer to the readme file on the installation CD for more information.

1. Insert the PCS 7/505 OS Option Version 6.1 into the CD-ROM drive. The setup program will autostart. The Welcome dialog box opens.

2. Click the Next button to continue. The Readme dialog box opens.

3. To view the readme file, click the Yes, I want to read the readme file button. Click the Next button to continue. The Software license agreement dialog box opens.
4. Read the license agreement. Click the **Yes** button to continue. The **User registration** dialog box opens.

5. Enter **Name**, **Company** and **ID no**. The ID number can be found on the Certificate of License that comes with the software or on the Authorization disk. Click the **Next** button to continue. The **Target drive** dialog box opens.

6. Select the same target drive that was used for the PCS 7 installation. Click the **Next** button to continue. The **Packages** dialog box opens.
7. Select a suitable package for the computer on which this installation is occurring by clicking the appropriate check box.

8. Click the **Next** button. The **Components** dialog box opens.

9. Click the **Next** button to accept the default settings. The installation should install all selected components.

10. Click the **Finish** button.

### 2.5 Install PCS 7/505 OS Software Hot Fixes/Service Packs

Contact Siemens for appropriate hot fixes and service packs and the instructions used to install them.
2.6 **Install Authorizations**

1. Insert the Authorization floppy disk that came with your software into drive 'A'.
2. From the Windows taskbar, select **Start>SIMATIC>License Management>Automation License Manager**.
3. Double-click the 'A' drive.
4. Select all of the authorizations.
5. Transfer the authorizations from the floppy to the target drive.
6. Remove the floppy disk from drive 'A'.

2.7 **Install Complete**

Next Step: Create a project using SIMATIC Manager.

If this is an update from V6.0 to V6.1, go to section 3. Otherwise, skip section 3 and go to section 4.
3 **Update a project from V6.0 to V6.1**

**Note**
OS Project development is done on the OS Engineering Station using SIMATIC Manager. This project will be downloaded to the system's single server or redundant server pair and the clients. The sample project below assumes a single project with a redundant server pair and one client.

3.1 **Create a new project in SIMATIC Manager**

1. Open SIMATIC Manager, Start > SIMATIC > SIMATIC Manager
   The PCS 7 Wizard: 'New Project' dialog box opens.

**Note**
Press the F1 function key for help on each screen of the PCS 7 New Project Wizard, or press the Help button.
2. Select a project type. For example, select the **Single Project** radio button.

   **Multiproject with project and master data library** – select this option if you want to distribute project engineering across multiple engineering stations.

   **Single Project** – select this option when project engineering will be performed from a single engineering station.

3. Click the Continue button.
   The Which CPU will you use in your project? dialog box opens.

4. Click the **Continue** button to accept the default. (Choices here are only relevant to S7 projects.)
   The **Which objects will be used in the project?** dialog box opens.
- In the **Plant Hierarchy** area, the **Number of levels** should be configured when using S7-400 controllers in the same OS project as 505 controllers. It should be set to the same value used in DBA.

- In the **AS objects** area, clear **CFC chart** and **SFC chart** check boxes. These are only relevant to S7 projects.

- In the **OS objects** area, select the **PCS 7 OS** check box, and the appropriate system type.

  **Single-user System** – a single PC station will be created with an OS project.

  **Multi-user System** – two PC stations will be created, an OS server project, and an OS client project.

  **Multi-user system redundant** – three PC stations will be created, two OS server projects and an OS client project.

---

**Note**

For SIMATIC Batch options, a SIMATIC Batch check box will also appear in the OS Objects area. It is not necessary to check this box for SIMATIC Batch, even if you are installing the Batch option.
5. Click the Continue button.
The Where do you want to save the multiproject or the project? dialog box opens.

- In the **Directory name** box, enter a directory folder name or accept the default. This is the folder name for the directory under which the client/server projects will be created.

**Note**

Do not use the same directory as the existing project.

- In the **Storage location** box, enter a path or accept the default. This path is where the directory folder will be located. This is the path for the master project on the engineering station.
6. Click the Make button. The Message Number Assignment Selection dialog box opens.

7. Accept the default. Click the OK button. The project is created. This setting applies to projects that include S7-400 controllers and does not apply to messages created by DBA.
3.2 Create New Folders on the Primary and Standby Servers and All Clients

Shared folders on the servers and clients are needed to store the project created on the Engineering Station. When the project is downloaded, it will be transferred from the Engineering Station to these folders. You cannot configure your stations in SIMATIC Manager until these folders are created and properly set up. Follow these steps to create and set up these folders, if they don’t already exist.

1. Using Windows Explorer, create a new folder such as ‘PROJECT’ on one of the drives of the Primary and Standby servers, as well as all clients. The client and server projects created on the Engineering Station shall be downloaded to this folder on each node. If desired, you may create a ‘Projects’ folder under \Program Files\Siemens\Step7\s7proj\ for your projects. However, the name of the folder and where you place it is up to you.

2. Setup sharing on the newly created PROJECT folder. Right-click the PROJECT folder and select Sharing… The PROJECT properties dialog box opens.

3. Select the Sharing tab, select the Share this folder radio button.

4. Click the Permissions button. The Permissions window opens. Select Everyone, and then click the Full Control check box in the Allow column.

5. Click OK to close the Permissions window.

6. Click the OK button to close the Project Properties dialog box.
3.2.1 Configure the Stations

Configuring the stations identifies which computers are the server or client stations, and the path to which the project will be downloaded.

The following stations are shown in the SIMATIC Manager component view:

- SIMATIC PC Station (1) – Primary OS server
- SIMATIC PC Station (2) – Standby OS server
- SIMATIC PC Station (3) – Client

1. Close the plant view.
2. Expand the tree view for each station in the Component view.
3.2.1.1 Primary Server

1. In the Component view, right-click **SIMATIC PC Station(1)**, and select **Object Properties**. The **Properties – SIMATIC PC Station** dialog box opens.

2. In the **General** tab, enter the computer name of the primary computer in both the **Name** and **Computer name** fields. These names must be entered in ALL CAPS. Click the **Ok** button.
3. In the Component view, below the WinCC Application, right-click **OS(1)**, and select **Object Properties**. The **Properties** dialog box opens.

![Properties - OS (1) dialog box](image)

- **Name:** Your Project Name
- **Path:** S7_Pro6_Pj\OS(1)
- **Plant path:**
- **Storage location of the project:** C:\Program Files\SIEMENS\STEP7\S7_Pro6\S7_Pj
- **Author:** Your Engineering Station Name
- **Created:** 6/27/2008 9:03 AM
- **Last changed on:** 6/27/2008 9:07 AM
- **Comment:**

---

**Update a project from V6.0 to V6.1**

PCS 7/505 OS Setup Guide
A5E00767200-01 3-9
4. From the **General** tab, in the **Name** field, rename the OS(1) to the existing Server Project Name.  
   **Important Note:** If the OS name is not the same, two mcp files will be created in the new project.  
   In the **Author** field, enter your Engineering Station Name.

5. Click the Target OS and Standby OS Computer tab

---

**Note**

This step can be deferred until the OS servers and clients are actually set up and connected to the network. This must be completed before starting Download the Projects.
6. Press the **Search** button. The **Select target OS** dialog box opens.

![Select target OS dialog box]

**Note**

It is important to have only one mapped drive to any target directory. Multiple mapped drives to the same location can cause download errors.

7. Click the **Network** button to browse and map to the shared project folder on OS Server. If a mapped drive already exists, select it from the available drives listed in the **Load In** list box. This is the path to the folder on your primary server where you will store and operate the project. **Note:** This folder must already exist on the primary and standby servers and be shared. This folder’s permissions should be set to **Full Control** for **Everyone**. Refer to section **Create New Folders on the Primary and Standby Servers and All Clients** in this document. Click the **OK** button.

8. Click the **OK** button.
3.2.1.2 Standby Server

1. In the Component view, right-click SIMATIC PC Station(2), and select Object Properties.

2. In the General tab, enter the computer name of the standby computer in both the Name and Computer name fields. These names must be entered in ALL CAPS. Click the Ok button.
3. In the Component view, below the WinCC Application, right-click **OS(1)_StBy**, and select **Object Properties**. The default project name of Primary Server/Project Name_StBy must be used. The **Properties** dialog box opens.
4. Click the Target OS and Standby OS Computers tab.

![Standby OS properties: OS(t)_stby dialog box](image)

**Note**

This step can be deferred until the OS servers and clients are actually set up and connected to the network. This must be completed before starting Download the Projects.

5. Press the **Search** button. The **Select target OS** dialog box opens.

![Select target OS dialog box](image)
Note
It is important to have only one mapped drive to any target directory. Multiple mapped drives to the same location can cause download errors.

6. Click the Network button to browse and map to the shared project folder on OS Server. If a mapped drive already exists, select it from the available drives listed in the Load In list box. This is the path to the folder on your standby server where you will store and operate the project. This path must include the network name of the target computer.
   Note: This folder must already exist on the primary and standby servers and be shared. This folder’s permissions should be set to Full Control for Everyone. Refer to section Create New Folders on the Primary and Standby Servers and All Clients in this document. Click the OK button.

7. Click the OK button.
3.2.1.3 Client Station

Note: If your client is not the same computer as your OS Engineering Station, then perform the following steps.

1. In the Component view, right-click SIMATIC PC Station(3), and select Object Properties.

2. In the General tab, enter the computer name of the client computer in both the Name and Computer name fields. These names must be entered in ALL CAPS. Click the Ok button.

3. In the Component view, below the WinCC Application, right-click OSC(3), and select Object Properties. The Properties dialog box opens.
4. From the **General** tab, in the **Name** field, rename the OSC(3) to the existing client project name. **Important Note:** If the OS name is not the same, two mcp files will be created in the new project.
5. Click the **Target OS** tab.

6. Press the **Search** button. The **Select target OS** dialog box opens.

**Note**

This step can be deferred until the OS servers and clients are actually set up and connected to the network. This must be completed before starting Download the Projects.

**Note**

It is important to have only one mapped drive to any target directory. Multiple mapped drives to the same location can cause download errors.

7. Click the **Network** button to browse and map to the shared project folder on OS Server. If a mapped drive already exists, select it from the available
drives listed in the Load In list box. This is the path to the folder on your client server where you will store and operate the project. This path must include the network name of the target computer.

**Note:** This folder must already exist on the primary and standby servers and be shared. This folder’s permissions should be set to Full Control for Everyone. Refer to section Create New Folders on the Primary and Standby Servers and All Clients in this document. Click the OK button.

8. From the Component view, add and configure additional clients, servers, and server pairs as needed. You can add up to a total of 32 clients and 12 server pairs.
3.3 Update a project from V6.0 to V6.1

The procedure below is based on a project developed using the symbols and faceplates provided with PCS 7/505 OS V6.0 or V6.0 SP1.

PCS 7 V6.1 added new functionality to the standard symbols/block icons and faceplates. The PCS 7/505 OS V6.1 standard symbols/block icons and faceplates were updated to include this new functionality. If you have custom symbols/block icons and faceplates in your V6.0 project, you may want to modify these to include this new functionality. This should be completed before updating your project with DBA. Below is a list of the new functionality:

Symbols/Block Icons

- Block icon full name field is back lit when navigating to a picture from Loop-In-Alarm.
- The Alarm Group Display was replaced to support Alarm Lock.
- A new attribute was added to define where the faceplate opens.

Faceplates

- The Alarm Group Display was replaced to support Alarm Lock.
- The Alarm Lock icon was added.
- Increase/decrease buttons added for Controller Output and Setpoint changes.
- New attributes were added to define faceplate operation as 1-step or 2-step. 1-Step does not provide a confirmation dialog box.
- The Push Pin icon was added to keep the faceplate open when a new picture is opened.

Contact Siemens for guidance on whether your custom symbols/block icons and faceplates can support the new V6.1 functionality and how to make the necessary modifications.
3.3.1 Import a current WinCC project into SIMATIC Manager

1. Using the SIMATIC Manager project created in Section 3.1, verify that the name of the Server OS is the same name as the OS in your existing WinCC project.

2. From the Windows start menu, select Start > Simatic > WinCC > Tools > Project Duplicator. The WinCC Project Duplicator dialog box opens.

3. Browse to existing server or client WinCC project in the Select the source project that is to be duplicated field.

4. Click the Save As button. The Saves a WinCC project window opens.

5. Browse to the new SIMATIC Manager OS project folder, and enter the same file name as your current WinCC project name. Click the Save button.

6. The message The “project” already exists. Do you want to replace it? opens. Click the Yes button.

7. The message The project already exists! Do you want to overwrite the project? opens. Click the Yes button.

8. Confirm file replace, click yes to all.

9. Confirm folder replace, click yes to all. The Copying progress bar opens. When the copy is complete, the former WinCC project will be embedded in a SIMATIC Manager project.

10. Repeat steps 4 through 9 for all primary server and client projects.

11. Open the new OS project and re-run the OS project editor for server and client projects.

12. Select START > SIMATIC > DBA > PCS 7 DBA

13. Select File > Open. Browse to the existing V6.0 DBA project and Open.
14. The following dialog is displayed, “This DBA project was not created with the same version of the DBA Utility that you are using. Do you want to convert the DBA project to current version?” Click **OK**.

15. Select the **PC Station View** tab in the lower window.

16. Select the Server OS, right-click, and **Edit Object Properties**.

17. For the Offline MCP file, browse to the new Server OS, and click **OK**.

18. Recompile DBA.

19. Select **File > Save Project As**, and browse to the new project folder. You will be prompted that the file already exists, do you want to replace. Click **OK**.

20. Update the block icons.

   - From WinCC Explorer, open Graphic Designer on the ES station.
   - Open any PDL file in the project.
   - In the Dynamic Wizard section, select the 'Picture Functions' tab and double click on 'Update of the picture objects'.
     **Note:** Template Picture and Control File fields should not exceed 256 characters when running the 'Update of the picture objects' wizard.
   - Follow the prompts to update all pictures in the project or the active picture. In this case, select the 'yes, all pictures' radio button. Click the **Next** button to continue.
   - The Options dialog box is displayed. In the 'Please specify the name of the template picture' field, click the ellipse (...) button and select @@505Typicals.pdl.
   - Do not change the 'Please specify a name for the control file' field.
   - Click the **Next** button, then the **Finish** button to continue.
   - All graphic windows that contain the modified block icons should be updated.
   - If problems occur, refer to the **ChangeObjects.log** file.
   - Close WinCC.

**Note**

Additional recommendations

- Make a copy of the @@505Typicals.pdl file (and/or other project specific typical files) and place it in a separate directory on the hard drive. This eliminates the possibility of @@505Typicals.pdl being overwritten if you upgrade to a new version of the PCS 7/505 OS Options down the road. Currently, you have to manually create the @@505Typicals.pdl. This may not be the case in the future.

- Copy the @@505Typicals.pdl to the \Program Files\SIEMENS\WINCC\options\pdl\faceplatedesigner_v6 directory. In doing so, whenever a new project is created, the @@505Typicals.pdl file is automatically copied to the GraCS file of the new project.
21. Return to SIMATIC Manager, Component view. Right-click on WinCC Application > Primary Server project, and select Generate Server Data. After an hourglass is displayed, a message box appears to report Server data are generated successfully. Click OK.

22. Right-click on each client project, and select Assign OS Server. Select the appropriate project check box. Click OK. The Assigning OS Server to... progress message box appears. When the procedure is completed, click OK.

---

**Note**

If the selected project is reported as unknown, clear the unknown project check box. Click OK. Select Assign OS Server to select the appropriate project check box.

---

23. Download the project to your servers and client using SIMATIC Manager. Any further changes to the project can be downloaded using SIMATIC Manager.
4 Create a New OS Project

Note
OS Project development is done on the OS Engineering Station using SIMATIC Manager. This project will be downloaded to the system’s single station, single server or redundant server pair and the clients. The sample project below assumes a single project with a redundant server pair and one client.

4.1 Create a new project in SIMATIC Manager

1. Open SIMATIC Manager, Start > SIMATIC > SIMATIC Manager
   The PCS 7 Wizard ‘New Project’ dialog box opens.

Note
Press the F1 function key for help on each screen of the PCS 7 New Project Wizard.

PCS 7 Wizard: 'New Project'

You can create PCS7 projects very quickly using the PCS7 Assistant. You can then start programming charts and displays immediately.

- Multiproject with project and master data library
- Single Project

Click on 'Continue' to create your project.

Display Wizard when starting the SIMATIC Manager.

< Back  Continue >  Make  Cancel  Help

Preview>>
Create a New OS Project

2. Select a project type. For example, select the **Single Project** radio button.

   **Multiproject with project and master data library** – select this option if you want to distribute project engineering across multiple engineering stations.

   **Single Project** – select this option when project engineering will be performed from a single engineering station.

3. Click the **Continue** button.

   The **Which CPU will you use in your project?** dialog box opens.

4. Click the **Continue** button to accept the default. (Choices here are only relevant to S7 projects.)

   The **Which objects will be used in the project?** dialog box opens.
- In the **Plant Hierarchy** area, the **Number of levels** should be configured when using S7-400 controllers in the same OS project as 505 controllers. It should be set to the same value used in DBA.

- In the **AS objects** area, clear **CFC chart** and **SFC chart** check boxes. These are only relevant to S7 projects.

- In the **OS objects** area, select the **PCS 7 OS** check box, and the appropriate system type.
  
  **Single-user System** – a single PC station will be created with an OS project.
  
  **Multi-user System** – two PC stations will be created, an OS server project, and an OS client project.
  
  **Multi-user system redundant** – three PC stations will be created, two OS server projects and an OS client project.

5. Click the **Continue** button.

The **Where do you want to save the multiproject or the project?** dialog box opens.
Create a New OS Project

- In the **Directory name** box, enter a directory folder name or accept the default. This is the folder name for the directory under which the client/server projects will be created.

- In the **Storage location (path)** box, enter a path or accept the default. This path is where the directory folder will be located. This is the path for the master project on the engineering station.

6. Click the **Make** button. The **Message Number Assignment Selection** dialog box opens.

7. Accept the default. Click the **OK** button. The project is created. This setting applies to projects that include S7-400 controllers and does not apply to messages created by DBA.
4.2 Create New Folders on the Primary and Standby Servers and All Clients

Shared folders on the servers and clients are needed to store the project created on the Engineering Station. When the project is downloaded, it will be transferred from the Engineering Station to these folders. You cannot configure your stations in SIMATIC Manager until these folders are created and properly set up. Follow these steps to create and set up these folders, if they don’t already exist.

1. Using Windows Explorer, create a new folder such as ‘PROJECT’ on one of the drives of the Single Station, Primary and Standby servers, as well as all clients. The client and server projects created on the Engineering Station shall be downloaded to this folder on each node. If desired, you may create a ‘Projects’ folder under \Program Files\Siemens\Step7\s7proj\ for your projects. However, the name of the folder and where you place it is up to you.

2. Setup sharing on the newly created PROJECT folder. Right-click the PROJECT folder and select Sharing... The PROJECT properties dialog box opens.

![PROJECT Properties dialog box](image)

3. Select the Sharing tab, select the Share this folder radio button.

4. Click the Permissions button. The Permissions window opens. Select Everyone, and then click the Full Control check box in the Allow column.

5. Click OK to close the Permissions window.

6. Click the OK button to close the Project Properties dialog box.
4.2.1 Configure the Stations

Configuring the stations identifies which computers are the server or client stations, and the path to which the project will be downloaded.

The following stations are shown in the SIMATIC Manager component view:

- SIMATIC PC Station (1) – Primary OS server
- SIMATIC PC Station (2) – Standby OS server
- SIMATIC PC Station (3) – Client

1. Close the plant view.
2. Expand the tree view for each station in the Component view.

![Diagram showing the SIMATIC Manager component view with stations](image-url)
4.2.1.1 Primary Server

1. In the Component view, right-click SIMATIC PC Station(1), and select Object Properties. The Properties – SIMATIC PC Station dialog box opens.

2. In the General tab, enter the computer name of the primary computer in both the Name and Computer name fields. These names must be entered in ALL CAPS. Click the Ok button.

3. In the Component view, below the WinCC Application, right-click OS(1), and select Object Properties. The Properties dialog box opens.

4. From the General tab, in the Name field, rename, as desired, the OS(1) to Your Project Name. In the Author field, enter your Engineering Station Name.
5. Click the **Target OS and Standby OS Computer** tab

![Target OS and Standby OS Computer Tab](image)

**Note**

This step can be deferred until the OS servers and clients are actually set up and connected to the network. This must be completed before section Download the Projects.
Create a New OS Project

6. Press the **Search** button. The **Select target OS** dialog box opens.

![Select Target OS Dialog](image)

**Note**
It is important to have only one mapped drive to any target directory. Multiple mapped drives to the same location can cause download errors.

7. Click the **Network** button to browse and map to the shared project folder on OS Server. If a mapped drive already exists, select it from the available drives listed in the **Load In** list box. This is the path to the folder on your primary server where you will store and operate the project. **Note:** This path must include the network name of the target computer. **Note:** This folder must already exist on the primary and standby servers and be shared. This folder’s permissions should be set to **Full Control** for **Everyone**. Refer to section **Create New Folders on the Primary and Standby Servers and All Clients** in this document. Click the **OK** button.

8. Click the **OK** button.
4.2.1.2 Standby Server

1. In the Component view, right-click SIMATIC PC Station(2), and select Object Properties.

2. In the General tab, enter the computer name of the standby computer in both the Name and Computer name fields. These names must be entered in ALL CAPS. Click the Ok button.

3. In the Component view, below the WinCC Application, right-click OS(1)_StBy, and select Object Properties. The default project name of Primary Server/Project Name_StBy must be used. The Properties dialog box opens.

4. Click the Target OS and Standby OS Computers tab.
Create a New OS Project

Note
This step can be deferred until the OS servers and clients are actually set up and connected to the network. This must be completed before section Download the Projects.

5. Press the Search button. The Select target OS dialog box opens.
Create a New OS Project

Note
It is important to have only one mapped drive to any target directory. Multiple mapped drives to the same location can cause download errors.

6. Click the Network button to browse and map to the shared project folder on OS Server. If a mapped drive already exists, select it from the available drives listed in the Load in list box. This is the path to the folder on your standby server where you will store and operate the project. This path must include the network name of the target computer.  
   Note: This folder must already exist on the primary and standby servers and be shared. This folder’s permissions should be set to Full Control for Everyone. Refer to section Create New Folders on the Primary and Standby Servers and All Clients in this document. Click the OK button.

7. Click the OK button.
4.2.1.3 **Client Station**

**Note:** If your client is not the same computer as your OS Engineering Station, then perform the following steps.

1. In the Component view, right-click **SIMATIC PC Station(3)**, and select **Object Properties**.

2. In the **General** tab, enter the computer name of the client computer in both the **Name** and **Computer name** fields. These names must be entered in ALL CAPS. Click the **Ok** button.

3. In the Component view, below the WinCC Application, right-click **OSC(3)**, and select **Object Properties**. The **Properties** dialog box opens.

4. From the **General** tab, in the **Name** field, rename, as desired, the OSC(3) to the client project name.
Create a New OS Project

5. Click the **Target OS** tab.

6. Press the **Search** button. The **Select target OS** dialog box opens.
Create a New OS Project

Note

This step can be deferred until the OS servers and clients are actually set up and connected to the network. This must be completed before section Download the Projects.
Note
It is important to have only one mapped drive to any target directory. Multiple mapped drives to the same location can cause download errors.

7. Click the **Network** button to browse and map to the shared project folder on OS Server. If a mapped drive already exists, select it from the available drives listed in the **Load In** list box. This is the path to the folder on your client server where you will store and operate the project. This path must include the network name of the target computer.  
   **Note:** This folder must already exist on the primary and standby servers and be shared. This folder’s permissions should be set to **Full Control for Everyone**. Refer to section **Create New Folders on the Primary and Standby Servers and All Clients** in this document. Click the **OK** button.

8. From the Component view, add and configure additional clients, servers, and server pairs as needed. You can add up to a total of 32 clients and 12 server pairs.
4.3 Start DBA for new projects

Refer to the DBA help or PDF file for details:

Start >SIMATIC >Documentation >English >PCS 7/505 DBA Help or PCS 7
PCS 7/505 DBA PDF, section Project Setup>Creating or Opening a DBA
project.

4.4 Run OS Project Editor (optional)

If you want to change your layout, screen resolution, monitor configuration,
message configuration, message display, area, runtime window, or basic data,
run the OS project editor from WinCC Explorer. When configuring servers that
will not be used as clients, it is recommended to use the SIMATIC server layout.

4.5 Edit Each Graphic

Customize the graphics for your process including the addition of Trend Objects
to graphics.
4.6 Lifebeat Monitoring Setup

Important Note
Integration of the PCS 7 Options Lifebeat Monitoring Symbols with SIMATIC PCS 7 Version 6.1 requires a one-time manual procedure. This step is performed after installing (or reinstalling) PCS 7 Options software.

1. Open the OS server project in SIMATIC Manager. From the Component view, WinCC Application, right-click Primary OS object and select Open Object. Your project opens in WinCC Explorer.

2. Click the Graphics Designer icon in the left pane of the WinCC Explorer window.
   In the right pane, a list of picture files (with .PDL filename extensions) appears. In the right pane, select and right-click the file @@505ConfigTypicals.PDL. From the drop-down menu, select Open picture. The Graphics Designer program opens the picture for editing.

3. Select all the symbols on the @@505ConfigTypicals.pdl. From the program menu bar, select:
   Edit>Select All
   Edit_Copy

4. Close the graphic. If asked whether to save changes, select No. The file closes.

5. Open the @@ConfigTypicals.pdl. Paste the 505 symbols onto the @@ConfigTypicals.pdl by clicking on the blank space to the right of the PCS7 symbols and selecting Edit_Paste. While the symbols remain selected, move the entire selection to the right (if necessary) so that they are distinct from the original PCS7 symbols.

Note
If you intend to create future projects (such as client stations), at the same time, you should also copy the 505 Symbols from the @@505ConfigTypicals.pdl and paste them into the ProgramFiles\SIEMENS\WINCC\options\pdl\base_Data_Pool\@@ConfigTypicals.PDL.

6. Select File_Close, then Save. A Performance Warning dialog box opens, cautioning you that the file contains cyclic triggers. You can safely ignore this warning and click the OK button. Close Graphic Designer.
7. In the left pane of WinCC Explorer, right-click **Lifebeat Monitoring**. Click Open.
Create a New OS Project

The **Lifebeat Monitoring** window opens.

8. In row one, double-click the cell under **Device Name**. Enter the name of the controller that you want monitored, make sure this is the name of the controller defined in your DBA project.
9. Double-click the cell under **Device Type**, and select the controller type from the drop-down list.

10. Double-click the cell under **Connection**, and select **PLC505**.
11. Repeat steps 8-11 for each controller that you want monitored.

12. Under the Device positioning in the system configuration section, select automatic.

13. Select a **Monitoring Cycle time**. The default is 10 seconds.

14. When complete, select the **Update** button. The following dialog box is displayed.

15. Click the **Yes** button. When complete, the **Lifebeat Monitoring** dialog box may appear indicating that the CCLBMRTServer.exe could not be entered into the start up list of the server computer <computername>.

16. This message can be safely ignored. Click the **OK** button to continue.

17. Click the **Close** button to close the Lifebeat Monitoring window.

18. The system may respond with the following message “The process picture has not been updated, do you want to update before closing?” Click **Yes**.

19. The following dialog box may be displayed. Click **Yes**.

20. The following dialog box is displayed. Click **OK**.

21. To configure Lifebeat Monitoring to view the health of other system resources such as computers, for example OS Servers and the Archive Server, refer to **Start > SIMATIC > WinCC > WinCC Information System > Options > Options for Process Control > Lifebeat Monitoring > How to configure lifebeat monitoring with OPC connection.**
4.7 Time Synchronization Setup
For Clients and Server PCs:
For further information, please refer to the help file Start > SIMATIC > WinCC > WinCC Information System > Options > Options for Process Control > Time Synchronization

4.8 Configure Alarm Logging
For further information, please refer to the help file Start > SIMATIC > WinCC > WinCC Information System > Working with WinCC > Setting Up an Alarm System > Alarm Logging

4.9 Configure Tag Logging
For further information, please refer to the help file Start > SIMATIC > WinCC > WinCC Information System > Working with WinCC > Archiving Process Values

4.10 Create Trends (if adding the Trend Object to a Graphic)
For further information, please refer to the help file Start > SIMATIC > WinCC > WinCC Information System > Working with WinCC > Archiving Process Values > Output of Process Values > Process Value Output in Process Screens

4.11 Configure User Administrator
For further information, please refer to the help file Start > SIMATIC > WinCC > WinCC Information System > Working with WinCC > Setting up User Administration
4.12 Generate Server Data

From the Component view in SIMATIC Manager, right-click the primary OS server project, and select Generate Server Data.

When the procedure is complete, The server data are generated successfully dialog box opens.

Perform this procedure for each primary OS server.

4.13 Configure LMHOSTS and HOSTS Files

All PCS 7 stations should be entered in the LMHOSTS and HOSTS files (in %windir%\system32\drivers\etc directory). These files should be copied to each of the PCS 7 station computers.

For additional information, the following URL is accurate for NT/Win2k, but not for XP or Win2k3:

4.14 Configure WinCC Project Network Settings

If the PC (computer) has more than one network adapter, configure WinCC for the network adapter it will be using.


2. Select the appropriate network adapter. Click OK. The message box Network communications need to be initialized opens. Click Yes.

The WinCC Communications Configurator configures WinCC to use different network speeds

- To start, click Start > SIMATIC > WinCC > Tools > Communication Configurator.
  - Slide bar should be set to reflect network speed
  - “Server Pings Client” should be set unless there are dial-up clients
  - Settings should only be changed if CCAgent, CCClient, and CCServer processes have been (manually) stopped.

Note
Refer to WinCC Help for additional details regarding WinCC Communication Configurator.
4.15 Client Project Setup

Close the OS project in WinCC.

4.15.1 Assign OS Server

1. From the Component view in SIMATIC Manager, right-click OS Client and select Assign OS server... The OS server assignment window opens.

2. Check the project check box for each server as needed, and click OK. A progress bar indicating the status opens. When the procedure is complete, The Procedure was completed without error message is displayed.

3. Click the OK button.

4.15.2 Configure a Standard Server

Note

The "Standard Server" represents the Server or Server pair that will store all operator actions and Runtime Trends. If a Standard Server is not configured, operator actions will be stored on the local machine instead of on the "Server". In addition, any Runtime Trends created will only be viewable from the client on which they are created.

Open the client project. From the Component view in SIMATIC Manager, right-click on the OS client project and select Open Object. Set up a standard server for Alarms and SSM.

1. Right-click on Server Data.
3. Click on the Symb. Computer Name field next to the Alarms Component. From the drop-down list, select the package that is the server for this client and is providing alarms for the client you are currently configuring.
4. Repeat step 3 for the SSM component.
5. Click the OK button.

This step can also be performed on the client after downloading the project to redefine the standard server for a particular client station. This customization will be overwritten during a subsequent download.

4.15.3 Configure Preferred Server

For further information, please refer to the help file Start > SIMATIC > WinCC > WinCC Information System > Configurations > Multi-User Systems > Client Configuration > Configuring a Preferred Server

This step can also be performed on the client after downloading the project to customize the preferred server connection for a particular client station. This customization will be overwritten during a subsequent download.
4.15.4 Lifebeat Monitoring Setup

1. Open the client project. From the Component view in SIMATIC Manager, right-click on the OS client project and select Open Object. The project opens in WinCC Explorer.

2. Right-click Lifebeat Monitoring and select Open. The Lifebeat Monitoring window is displayed.

3. Set the Device positioning in the system configuration to automatic. Select a Monitoring Cycle time, and then click the Update button.

4. When complete, the system configuration section will update. See the Lifebeat Monitoring window below.
Create a New OS Project

5. Lifebeat Monitor setup on the client is complete. Click the Close button to close Lifebeat Monitoring.

4.15.5 Configure Area Display in Runtime

For further information, please refer to the help file Start > SIMATIC > WinCC > WinCC Information System > Working with WinCC > Documentation of Configuration and Runtime Data > Runtime Documentation > Changing Output Options in Runtime

This step can also be performed on the client after downloading the project to customize the area display for a particular client station. This customization will be overwritten during a subsequent download.

4.15.6 Configure User Administrator

For further information, please refer to the help file Start > SIMATIC > WinCC > WinCC Information System > Options > Web Navigator > Web Navigator Documentation > Function Overview > Configuration of the User Administration

This step can also be performed on the client after downloading the project to customize user administration for a particular client station. This customization will be overwritten during a subsequent download.
4.15.7 Create Runtime Trends (archive or online trends)

For further information, please refer to the help file Start > SIMATIC > WinCC > WinCC Information System > Options > Options for Process Control > Process Control Runtime > Trend Systems > Configuring Online Trends (Runtime)

This step can be performed on the client after downloading the project.

---

**Note**

This customization will not be overwritten during a subsequent duplication. It is important to note that Runtime Trends created from a client application are not viewable from a server being used as a client. Any Runtime Trends created on the OS Server being used as a client are not viewable from a client connected to the OS server.
4.16 Download the Projects

Note
Only download the project to the client if the client is not the same computer as your OS Engineering Station. All stations to which you will download the project must have WinCC shut down.

4.16.1 Download all projects at the same time

1. From Component view, right-click the project name and select PLC > Compile and Download Objects…. The Compile and Download Objects window opens.

2. Check the Download check box for each client and server project name.

3. Select each project, and click Edit. Ensure that the Entire WinCC Project radio button is selected for each project.

Note
Do not check any Compile check boxes. Doing so will overwrite your DBA compile with incorrect data. The compile check boxes only apply to S7 projects.

4. Click the Test button, to ensure that all settings are valid.

5. Click the Start button.
Download each project separately:

4.16.2 **Download the project to the Primary Server**
1. From SIMATIC Manager component view, right-click the Primary Server OS (PC Station 1), and select **PLC > Download**.
2. Ensure that **The Entire WinCC Project** radio button is selected.
3. Click **OK** to download the project.
4. A success window is displayed. Click **OK** to acknowledge that the download has completed.

4.16.3 **Download the project to the Standby Server**
1. From SIMATIC Manager component view, right-click the Standby Server OS (PC Station 2), and select **PLC > Download**.
2. Ensure that **The Entire WinCC Project** radio button is selected.
3. Click **OK** to download the project.
4. A success window is displayed. Click **OK** to acknowledge that the download has completed.

4.16.4 **Download the project to the Client Station**
1. From SIMATIC Manager component view, right-click the Client Station OS (PC Station 3), and select **PLC > Download**.
2. Ensure that **The Entire WinCC Project** radio button is selected.
3. Click **OK** to download the project.
4. A success window is displayed. Click **OK** to acknowledge that the download has completed.
4.17  **Project Activation Sequence**

**Note**
Projects can be automatically activated when the operating system starts using the AutoStart Utility. For more information, refer to the help file within WinCC Explorer. Or to FAQ ID: [19249315](#)

1. Activate the project on the primary server.
2. Wait four minutes for the project to fully start.
3. Activate the project on the backup server.
4. Wait four minutes for the project to fully start.
5. Activate the project on the client.

4.18  **Restarting an OS Server**

Wait five minutes prior to reactivating the WinCC runtime of an OS Server associated with a redundant pair to ensure that all synchronization activities will start-up properly.
5 Download the Changes

This section describes how to make changes to an existing project from the Engineering Station, and then downloading those changes into the servers and client. These changes may include:

- Making changes to a Controller program.
- Making changes to the plant view in DBA.
- Making changes to the project in SIMATIC Manager.
- Making changes to the project in WinCC.

5.1 Overall Steps

1. Make changes. Ensure that DBA changes have been compiled.
2. Download changes to your stations.

5.2 Making Changes to the Controller Configuration

1. Make any required changes to controller programs. Anytime you make changes to an existing controller configuration, DBA detects the changes and shows the AS Source Node that represents the controller as “(changed)”:  

![AS View Diagram]

2. Right-click the changed AS Source Node and select Update Controller Objects from the menu.
The AS Objects panel in the lower-right quadrant of DBA is updated to reflect the changes made from the controller. The Status column indicates which objects have been added, deleted or modified since the last time the controller objects were updated.

### Note

**Update Controller Objects** changes the status column in the details pane to indicate which AS Objects have been modified since the last update. This is a visual status indication of what has changed in the controller. This column reflects the status information from the current Update Controller Objects when run multiple times between DBA compiles to the OS project. To ensure the accuracy of the OS compile, DBA retains the status of all changed objects no matter how many times Update Controller Objects is run.

Use DBA to modify the Plant View to reflect the new AS object changes:

- **AS objects marked as Deleted** should be Unassigned from the currently assigned folder in the Plant View.

- **AS Objects marked as Add** should be assigned to a folder in the Plant View. You may wish to make additional changes to the attributes of the new objects, such as Alarm Priority. See Object Attributes section of the DBA Help File for more details.

- For **AS Objects marked as Modified**, no action is required. The changes will be made automatically in the PCS 7 OS Project the next time you perform a “Compile”. Note that DBA color codes all modified AS Objects as green in the Plant View, indicating that there has been a change to the object that has not been compiled to the WinCC project.
5.3 Making additional Changes to the DBA Configuration

1. Use DBA to make any additional changes desired, such as
   - Fine-tuning of the Plant View assignments
   - Renaming folders or graphic files assigned to folders
   - Editing of AS Object attributes such as Symbol Names and Alarm Priorities (see DBA Help File, section Object Attributes, for more details)

2. The server project to which you are compiling must not be in runtime on this station.

3. From DBA, select Compile and choose the Changes option on the compile dialog box:
5.4 Modify the project in WinCC

1. On the OS Engineering Station, start WinCC Explorer and open the OS Server project.
2. Make any new changes to the project that you need (for example, create new graphics, modify existing graphics, etc.).

---

**Note**

All changes must be made on the OS Engineering Station to preserve the Changes Only download. Changes made on another station cannot be downloaded to the other stations via SIMATIC Manager. These changes would have to be downloaded manually. Changes made on any station other than the Engineering Station will require a full download when future changes are made.
5.5 Download changes

You can only download changes when all stations have PCS 7 activated. Unlike downloading the entire project, you do not need to explicitly request a download to the Standby Server. The download to the Primary Server will automatically include the Standby Server. You will not explicitly see the changes downloaded to the Client, this download is done in the background.

1. From SIMATIC Manager component view, right-click the Primary Server OS (PC Station 1), and select PLC > Download.
2. Ensure that the Changes radio button is selected.
3. Click OK to download the project.
4. A success window is displayed indicating a successful download to the Primary Server. Click OK to acknowledge that the download has completed.
5. The project is now automatically downloaded to the Standby Server.
6. A success window is displayed indicating a successful download to the Standby Server. Click OK to acknowledge that the download has completed.
7. Deactivate PCS 7 on the Primary Server.
8. Wait five minutes.
9. Reactivate PCS 7 on the Primary Server.
10. After fifteen minutes, look in the Process Alarms screen on the Primary Server for the “Sync Start/Finish” message. If the message is not there, continue checking the process alarms screen until the message appears.
11. Once the synchronization has completed, deactivate PCS 7 on the Standby Server.
12. Wait five minutes.
13. Reactivate PCS 7 on the Standby Server.
14. After fifteen minutes, look in the Process Alarms screen on the Primary Server for the “Sync Start/Finish” message. If the message is not there, continue checking the process alarms screen until the message appears.
15. The changes are now fully downloaded.
6 Modify Faceplates and Symbols

The following procedure describes the recommended steps for creating PCS 7 customized faceplates and symbols based on those delivered in the standard PCS 7/505 Option product. The procedure clones an existing faceplate and symbol so that you can customize them as you wish. **The PCS 7 Faceplate Designer utility should not be used.** Select a standard faceplate that is most like the one you wish to create.

---

**Note**

This procedure assumes you have selected the 505_LOOP faceplate and symbol and that you want to create a CUSTOM1 faceplate and symbol from them.

If the new faceplate you are creating is for a specific WinCC project, use the files that are in the GraCS folder of the WinCC project. If the new faceplate is for all future WinCC projects, use the files from the `SIEMENS\WINCC\options\pdl\FaceplateDesigner_V6` folder. Future projects get their faceplates and symbols from this `SIEMENS\WINCC\options\pdl\FaceplateDesigner_V6` folder.
6.1 **Faceplate Procedure**

1. Using the WinCC Graphics Designer, open the following PDL files, and use the **File->Save As** menu option to save a copy of the file under a new name.

<table>
<thead>
<tr>
<th>Original File Name</th>
<th>New Customized File Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>@PG_505_LOOP.pdl</td>
<td>@PG_CUSTOM1.pdl</td>
</tr>
<tr>
<td>@PG_505_LOOP_OVERVIEW.pdl</td>
<td>@PG_CUSTOM1_OVERVIEW.pdl</td>
</tr>
<tr>
<td>@PG_505_LOOP_STANDARD.pdl</td>
<td>@PG_CUSTOM1_STANDARD.pdl</td>
</tr>
<tr>
<td>@PG_505_LOOP_VIEWLIST.pdl</td>
<td>@PG_CUSTOM1_VIEWLIST.pdl</td>
</tr>
<tr>
<td>@PL_505_LOOP.PDL</td>
<td>@PL_CUSTOM1.PDL</td>
</tr>
</tbody>
</table>

2. All references to the old 505_LOOP type in the new files need to be changed to reference the new CUSTOM1 type. These changes are made in WinCC Graphics Designer by opening the PDL file, and modifying the reference using the object’s property dialog box.

The following table lists all of the references that must be changed.

<table>
<thead>
<tr>
<th>PDL FileName</th>
<th>Object Name</th>
<th>Property Name</th>
<th>Attribute Name</th>
<th>New Entry Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>@PG_505_LOOP.pdl</td>
<td>@Faceplate</td>
<td>Texts</td>
<td>FirstView</td>
<td>@PG_CUSTOM1_STANDARD</td>
</tr>
<tr>
<td>@PG_505_LOOP.pdl</td>
<td>ViewList</td>
<td>Miscellaneous</td>
<td>Picture Name</td>
<td>@PG_CUSTOM1_VIEWLIST.pdl</td>
</tr>
<tr>
<td>@PG_505_LOOP.pdl</td>
<td>BlockType</td>
<td>Output/Input</td>
<td>Output Value</td>
<td>CUSTOM1</td>
</tr>
<tr>
<td>@PL_505_LOOP.pdl</td>
<td>OverviewWindow</td>
<td>Miscellaneous</td>
<td>Picture Name</td>
<td>@PG_CUSTOM1_OVERVIEW.pdl</td>
</tr>
<tr>
<td>@PL_505_LOOP.pdl</td>
<td>View1</td>
<td>Miscellaneous</td>
<td>Picture Name</td>
<td>@PG_CUSTOM1_STANDARD.pdl</td>
</tr>
<tr>
<td>@PL_505_LOOP.pdl</td>
<td>BlockType</td>
<td>Output/Input</td>
<td>Output Value</td>
<td>CUSTOM1</td>
</tr>
</tbody>
</table>

The result is a clone of the 505_LOOP faceplate that is named CUSTOM1.

To modify the faceplate for your needs, the objects on the new PDL files can now be added/deleted/modified as appropriate. See help while in Graphics Designer.
6.2 Symbol Procedure

1. Using the WinCC Graphics Designer, open up the @@505Typicals.PDL file.

2. Save this under the new name @505Typicals.PDL.

3. Make a copy of the @505_LOOP/1 object and name it @CUSTOM1/1.

4. Using the property dialog box for the new @CUSTOM1/1 object, change all references to the old 505_LOOP type to reference the new CUSTOM1 type.

5. The following properties must be changed:

<table>
<thead>
<tr>
<th>Property Name</th>
<th>Attribute Name</th>
<th>New Entry Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customized Object</td>
<td>Object Name</td>
<td>@CUSTOM1</td>
</tr>
<tr>
<td>UserDefined2</td>
<td>Type</td>
<td>@CUSTOM1/1</td>
</tr>
<tr>
<td>UserDefined2</td>
<td>Servername</td>
<td>PCS7 CUSTOM1 Control</td>
</tr>
</tbody>
</table>

The result is a new symbol that will be used for the new CUSTOM1 type.