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Указания по технике безопасности 

Данное руководство содержит указания, которые вы должны соблюдать для обеспечения 
собственной безопасности, а также защиты от повреждений продукта и связанного с ним 
оборудования. Эти замечания выделены предупреждающим треугольником и представлены, в 
соответствии с уровнем опасности следующим образом: 

 

!  
Опасность 
указывает, что если не будут приняты надлежащие меры предосторожности, то это приведет к 
гибели людей, тяжким телесным повреждениям или существенному имущественному ущербу. 

 

!  
Предупреждение  
указывает, что при отсутствии надлежащих мер предосторожности это может привести к 
гибели людей, тяжким телесным повреждениям или к существенному имущественному ущербу. 

 

!  
Осторожно 
указывает, что возможны легкие телесные повреждения и нанесение небольшого 
имущественного ущерба при непринятии надлежащих мер предосторожности. 

 
 Осторожно 

указывает, что возможно повреждение имущества, если не будут приняты надлежащие меры 
безопасности. 

  
 Замечание 

привлекает ваше внимание к особо важной информации о продукте, обращении с ним или к 
соответствующей части документации. 

Квалифицированный персонал 

К монтажу и работе на этом оборудовании должен допускаться только квалифицированный 
персонал. Квалифицированный персонал – это люди, которые имеют право вводить в действие, 
заземлять и маркировать электрические цепи, оборудование и системы в соответствии  со 
стандартами техники безопасности. 

Надлежащее использование 

Примите во внимание следующее: 
 

!  
Предупреждение 
Это устройство и его компоненты могут использоваться только для целей, описанных в 
каталоге или технической документации, и в соединении только с теми устройствами или 
компонентами других производителей, которые были одобрены или рекомендованы фирмой 
Siemens.  
Этот продукт может правильно и надежно функционировать только в том случае, если он 
правильно транспортируется, хранится, устанавливается и монтируется, а также 
эксплуатируется и обслуживается в соответствии с рекомендациями. 

Товарные знаки 

SIMATIC®, SIMATIC HMI® и SIMATIC NET® - это зарегистрированные товарные знаки SIEMENS AG.  

Некоторые другие обозначения, использованные в этих документах, также являются 
зарегистрированными товарными знаками; права собственности могут быть нарушены, если они 
используются третьей стороной для своих собственных целей. 
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Обзор продукта
Предисловие
S7-PLCSIM позволит Вам выполнить и протестировать Вашу программу на имитаторе
программируемого логического контроллера (ПЛК), который установлен на Вашем
компьютере или программаторе (например, PG 740). Поскольку имитатор функционирует
совместно с программным обеспечением STEP 7, нет необходимости подключаться к
какому либо оборудованию S7 (ЦПУ или модулям ввода/вывода). С помощью имитатора
ПЛК S7 Вы можете протестировать и отладить программы для ЦПУ S7-300 и S7-400, а
также для WinLC.
S7-PLCSIM обеспечивает простой интерфейс для мониторинга и модификации различных
параметров, используемых программой (например логических, таких как включено -
выключено). Пока программа выполняется на имитаторе ПЛК, Вы также можете
использовать различные приложения STEP 7. Следовательно, Вы можете использовать
такие инструменты, как таблица переменных (VAT) для наблюдения и модификации
переменных.

Характеристики S7-PLCSIM
S7-PLCSIM поддерживает следующие функции:
Область памяти Описание
Таймеры: от T 0 до T 511.
Меркеры: 131 072 бит (16 Кбайт) памяти
Общая адресуемая
память входов/выходов

131 072 бит (16 Кбайт) памяти входов/выходов

Область отображения
процесса (устанавли-
вается, обновление
каждый цикл)

Максимум 131 072 бит (16 Кбайт)
Установлено 8192 бит (1024 байт)

Локальные данные
(Устанавливается)

Максимум 64 Кбайт
Установлено 32 Кбайт

Логические блоки и
блоки данных:

2048 функциональных блоков (FB) и функций (FC) и
4095 блоков данных (DB)

Системные
функциональные блоки
(SFB):

SFB0, SFB1, SFB2, SFB3, SFB4, SFB5, SFB8, SFB9,SFB12,
SFB13, SFB14, SFB15, SFB16, SFB19, SFB20, SFB21, SFB22,
SFB23, SFB32, SFB33, SFB34, SFB35, SFB36 и SFB37.
Заметьте, что SFB12, SFB13, SFB14, SFB15, SFB16, SFB19,
SFB20, SFB21, SFB22 и SFB23 это NOP (не выполняют никаких
операций). Вам не нужно модифицировать программу, чтобы
вызвать NOP.

Системные функции
(SFC):

SFC0, SFC1, SFC2, SFC3, SFC4, SFC5, SFC6, SFC7, SFC9,
SFC10, SFC11, SFC13, SFC14, SFC15, SFC17, SFC18, SFC19,
SFC20, SFC21, SFC22, SFC23, SFC24, SFC25, SFC26, SFC27,
SFC28, SFC29, SFC30, SFC31, SFC32, SFC33, SFC34, SFC35,
SFC36, SFC37, SFC38, SFC39, SFC40, SFC41, SFC42, SFC43,
SFC44, SFC46, SFC47, SFC48, SFC49, SFC50, SFC51, SFC52,
SFC54, SFC55, SFC56, SFC57, SFC58, SFC59, SFC60, SFC61,
SFC62, SFC64, SFC65, SFC66, SFC67, SFC68, SFC69, SFC79,
SFC80, SFC81 и SFC90.
Для  SFC26 и SFC27, S7-PLCSIM поддерживает только
входной параметр 0.
Заметьте, что SFC7, SFC11, SFC25, SFC35, SFC36, SFC37,
SFC38, SFC48, SFC60, SFC61, SFC62, SFC65, SFC66, SFC67,
SFC68, SFC69 и SFC81 это NOP (не выполняют никаких
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операций). Вам не нужно модифицировать программу, чтобы
вызвать NOP.

Организационные блоки
(OB):

OB1 (цикл),
от OB10 до OB17 (прерывания по времени дня),
от OB20 до OB23 (прерывания с задержкой),
от OB30 до OB38 (циклические прерывания),
от OB40 до OB47 (аппаратные прерывания),
OB70 (ошибка резервирования ввода/вывода),
OB72 (ошибка резервирования ЦПУ),
OB73 (ошибка резервирования коммуникаций),
OB80 (ошибка времени),
OB81 (ошибка питания),
OB82 (диагностическое прерывание),
OB83 (прерывание вставки/удаления),
OB84 (аппаратная ошибка ЦПУ ),
OB85 (ошибка класса приоритета),
OB86 (неисправность стойки),
OB87 (коммуникационная ошибка),
OB90 (фоновый OB),
OB100 (теплая перезагрузка),
OB101 (горячая перезагрузка),
OB102 (холодная перезагрузка),
OB121 (программная ошибка) и
OB122 (ошибка доступа).
Заметьте, что  OB81, OB84, OB87 и OB90 это NOP (не
выполняют никаких операций). Вам не нужно модифицировать
программу, чтобы вызвать NOP.

Дополнительно S7-PLCSIM обеспечивает следующие возможности:
Кнопка включения или выключения имитатора на SIMATIC Manager. Нажмите на кнопку
имитатора, чтобы открыть программное обеспечение S7-PLCSIM вместе с имитатором
ЦПУ. Когда S7-PLCSIM работает, любая новая связь происходит автоматически.
Имитатор  ПЛК выполняет программы для каждого модуля ЦПУ S7-300 или S7-400.
Вы можете создать «видимый объект», что обеспечивает доступ к области памяти входов
и выходов, аккумуляторам и регистрам имитируемого ПЛК. Вы имеете доступ к памяти и в
символической форме
Вы можете выбрать время выполнения автоматически или установить его вручную. Вы
можете устанавливать таймеры индивидуально или все вместе.
Вы можете изменить рабочий режим ЦПУ (STOP, RUN и RUN-P) как на реальном ЦПУ.
Дополнительно  S7-PLCSIM обеспечивает свойство Stop, чтобы немедленно остановить
ЦПУ без привязки к состоянию программы.
Вы можете записать ряд событий (манипуляция областями памяти входа и выхода,
сумматорами, регистрами) и воспроизвести запись в режиме автоматического
тестирования программы.
Вы можете использовать все инструменты STEP 7 для мониторинга и изменения
деятельности имитатора ПЛК. Хотя имитатор ПЛК существует полностью в программном
обеспечении (не требует аппаратного обеспечения), STEP 7 работает так, как если бы
имитатор ПЛК был частью аппаратного обеспечения, с несколькими отличиями.
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Что нового в версии 5.0 S7-PLCSIM
Здесь приведены новые возможности версии 5.0 S7-PLCSIM.

Запись/воспроизведение тестирования
Запись Вашего взаимодействия с S7-PLCSIM позволяет просмотреть, как Вы изменяли
величины данных входа, выхода и внутренние ячейки памяти и сбрасывали таймеры. Вы
можете затем воспроизвести в S7-PLCSIM запись теста функционирования Вашей
программы.

Вертикальный битовый видимый объект
Вертикальный формат показывает абсолютный или символьный адреса каждого бита. Вы
определяете тип памяти для переменных:
Вход
Выход
Внутренняя память

Новые типы данных
Два новых типа данных доступны в S7-PLCSIM:
Строковый
DT (DATE_AND_TIME)

Поддержка OB102 (холодная перезагрузка), отказоустойчивой
H- системы
S7-PLCSIM обеспечивает следующие функции ПЛК:
OB102 (холодный рестарт)
отказоустойчивая H-система (OB70, OB72, OB73, SFC14, SFC15, SFC90, SFB8, SFB9)
S7-PLCSIM функционирует самостоятельно и может быть использован  для имитации
резервных OB, соответствующих конфигурации обычных, но не H -станций SIMATIC.
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Быстрый старт
Если Вы начинаете работать в S7-PLCSIM, следующие процедуры помогут Вам начать
работу. Режим имитации доступен из SIMATIC Manager.
1. Откройте  SIMATIC Manager.

2. Нажмите на  или выберите команду меню Options > Simulate Modules (Опции >
Имитация модулей). Этим действием открывается приложение S7-PLCSIM с
видимым объектом CPU (со значением, по умолчанию, адреса MPI 2).

3. Из SIMATIC Manager управляйте проектом S7_ZEBRA. Этот проект поставляется с
программным обеспечением STEP 7, версии V 5.x и выше (файл проекта
ZEN01_09_STEP7_Zebra).

4. С помощью проекта S7_ZEBRA управляйте папкой Blocks (блоки). (Смотрите SIMATIC
Manager Help для обзора объектов STEP 7.)

•  Из SIMATIC Manager нажмите на  или выберите команду меню PLC >
Download (ПЛК > Загрузить) для загрузки блоков программы в имитатор ПЛК.

•  На вопрос «хотите ли Вы загрузить системные данные?», выберите No (Нет), если
Вы не хотите загрузить аппаратную конфигурацию в имитатор ПЛК, или Yes (Да)
для загрузки аппаратной конфигурации (например, для использования часового
меркера).

1. Из приложения S7-PLCSIM создайте дополнительные «видимые объекты» для
наблюдения информации в имитаторе ПЛК:

•  Нажмите на  или выберите команду меню Insert > Input Variable (Вставить >
Входные переменные). Появляется видимый объект IB0 (входной байт 0).

•  Нажмите на  или выберите команду меню Insert > Output Variable (Вставить >
Выходные переменные) для того, чтобы отметить второй видимый объект QB0
(выходной байт 0).

•  Нажмите на  или выберите команду меню Insert > Timer (Вставить > Таймер)
три раза для того, чтобы пометить три видимых объекта. Наберите 2, 3 и 4 (для
таймеров T 2, T 3 и T 4) в соответствующих текстовых боксах, нажимая клавишу
Enter (Ввод) после каждого ввода.

2. Выберите в S7-PLCSIM меню PLC и убедитесь, что пункт Power On (Питание
включено) отмечен значком (• ).

3. Выберите в меню команду Execute > Scan Mode  (Выполнить > Режим циклов) и
убедитесь что значком (• ) отмечено Continuous Scan (Циклическая работа).

4. Переключите имитатор ЦПУ в режим RUN, отметив бокс выбора RUN или RUN-P.
5. Отметьте бит 0 в IB0, чтобы имитировать вход 0.0 и посмотрите на эффект на

таймере и на QB0.

6. Нажмите на  или выберите команду меню File > Save PLC As...(Файл >
Сохранить ПЛК как…) для сохранения  текущего режима имитатора ПЛК как нового
файла.
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Использование STEP 7 для мониторинга имитатора
Вы можете также использовать инструменты STEP 7 для мониторинга имитатора
Вашей программы:

1. Когда у Вас есть созданный видимый объект (пункт 7, выше), войдите в SIMATIC
Manager

2. Нажмите на  или выберите View > Online (Вид > Подключено), чтобы
включить режим online.

3. Выберите объект «Blocks» в проекте ZEBRA и откройте FC1. Это действие
загружает редактор «LAD/STL/FBD».

4. Если имитатор ЦПУ в режиме RUN и Вы включаете бит 0 в IB0 (пункт 10, выше),
войдите в окно приложения «LAD/STL/FBD» и выберите Debug > Monitor
(Отладка > Наблюдение), чтобы наблюдать влияние этих изменений в Вашей
программе.
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Отличия от реального ПЛК S7
Имитатор ПЛК обеспечивает следующие функции, которых нет в реальном ПЛК:
Команда Stop останавливает имитатор ЦПУ и позволяет возобновить программу с того
места, где она была остановлена.
Вы можете изменить рабочий режим (RUN, RUN-P и STOP) как на реальном ЦПУ. Однако,
в отличие от реального ЦПУ, установка имитатора ЦПУ в режим STOP не позволяет
изменить состояние выходов.
Любые изменения, которые Вы делаете в видимом объекте, немедленно сохраняются в
ячейках памяти. ЦПУ не дожидается начала или конца цикла для обновления данных.
Выполнение контрольных функций позволяет Вам выбрать, как будет выполнена
программа на ЦПУ:

•  Одиночный цикл выполняется программой для одного цикла и затем ждет начала
следующего цикла.

•  Непрерывное функционирование выполняется программой как на реальном ПЛК:
начало нового цикла следует сразу же за концом предыдущего.

Вы можете позволить таймеру выполняться автоматически или можете устанавливать
каждую величину вручную. Также Вы можете сбросить все или отдельные таймеры.
Вы можете вручную привести в действие прерывания OB: от OB40 до OB47 (аппаратные
прерывания), OB70 (ошибка резервирования входов/выходов), OB72 (ошибка
резервирования ЦПУ), OB73 (ошибка резервирования связи), OB80 (ошибка времени),
OB82 (диагностическое прерывание), OB83 (вставка/удаление модуля), OB85 (ошибка
программной последовательности) и OB86 (неисправность стойки).
Область отображения процесса и периферийная память: Когда Вы делаете изменения
входной величины в видимом объекте, S7-PLCSIM немедленно копирует их в
периферийную память. Это значит, что при записи периферийной входной величины в
регистр образа процесса в начале следующего цикла,  изменения не будут потеряны.
Соответственно, когда Вы изменяете выходную величину, она немедленно копируется в
периферийную память выхода.

Цикл работы

Стартовая программа

…
Передайте значения области отображения

выходов в модули
Опросите входы  от модулей и обновите
данные в области отображения входов
Выполните пользовательскую программу

(OB1  и все блоки, вызываемые в ней)
…
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S7-PLCSIM также отличается от реального ПЛК следующим:
Буфер диагностики: S7-PLCSIM не поддерживает запись в диагностический буфер всех
сообщений об ошибках. Например, не могут имитироваться неисправность батареи в ЦПУ
или ошибка EPROM. Однако, имитируется большая часть ошибок входа/выхода.
Переключение рабочих режимов (например, из RUN в STOP) не переключает
входы/выходы в «безопасный» режим.
Не поддерживаются функциональные модули (FM).
Связь между равноправными узлами (между двумя ЦПУ S7-400 в одной стойке) не
поддерживается.
Имитатор ПЛК отображает четыре аккумулятора, как в ЦПУ S7-400. В специальных
случаях поведение программы, выполняемой на S7-PLCSIM с четырьмя аккумуляторами
может отличаться от поведения той же программы на ЦПУ S7-300, который использует
только два аккумулятора.

Различия входов/выходов
Многие ЦПУ в семействе S7-300 имеют автоконфигурацию входов/выходов: как только
модуль вставляется в физический контроллер, он автоматически распознается ЦПУ.
Невозможно повторить автоконфигурацию с помощью имитатора ПЛК. Если Вы загрузите
программу в S7-PLCSIM из ЦПУ S7-300 с автоконфигурацией входа/выхода, системные
данные не включат конфигурацию входа /выхода. Следовательно, когда Вы используете
S7-PLCSIM с программой S7-300, если Вы хотите определить, какие модули установлены
в доступном ЦПУ, Вы должны вначале загрузить аппаратную конфигурацию.
Загружая аппаратную конфигурацию в S7-PLCSIM, Вы можете создать проект для одного
из ЦПУ S7-300 без автоконфигурации входа/выхода, такого как S7-315-2DP, S7-316-2DP
или S7-318-2. Поместите копию Вашей аппаратной конфигурации в этот проект и
загрузите аппаратную конфигурацию в S7-PLCSIM. Один раз проделав это, Вы можете
загрузить программные блоки из любого проекта S7 и входы/выходы будут
поддерживаться корректно.
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Основное окно S7-PLCSIM
Основное окно S7-PLCSIM включает рабочее пространство, строку заголовка, строку
состояния, кнопки управления окном, меню S7-PLCSIM и панель инструментов.
Рабочее пространство S7-PLCSIM – место, где Вы размещаете различные типы видимых
объектов для наблюдения и модификации данных в имитируемом ПЛК.
Чтобы открыть имитируемый ПЛК, щелкните на кнопке Simulation On/Off  (Имитация

вкл./выкл.)  в панели инструментов (команда меню Options > Simulate Modules
(Опции > Имитация модулей)) в SIMATIC Manager. Запускается S7-PLCSIM и
загружается видимый объект CPU для имитируемого ПЛК.
Вы можете, таким образом, создать новый имитируемый ПЛК, или открыть один из ранее
сохраненных.
Для создания нового ПЛК для имитации, выберите команду меню File > New PLC (Файл >
Новый ПЛК).
Для открытия ранее сохраненного ПЛК, выберите команду меню File > Open PLC...(Файл
> Открыть ПЛК…).
Чтобы ближе познакомиться с S7-PLCSIM, используйте процедуры описанные в
«Быстром старте».
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Рабочие режимы ЦПУ
Режим RUN-P
ЦПУ выполняет программу и позволяет Вам изменять программу и ее параметры. Для
того, чтобы использовать инструменты STEP 7 для изменений любых параметров
программы, пока она выполняется, Вы должны перевести ЦПУ в режим RUN-P. Кроме
того, Вы можете использовать видимые объекты, создаваемые с помощью S7-PLCSIM
для изменения любых данных, используемых программой.
Режим RUN
ЦПУ выполняет программу: опрашивание входов, выполнение программы и затем
обновление выходов. Вы не можете загрузить любую программу или использовать
инструменты STEP 7 для изменения параметров (таких как входные величины), если ЦПУ
находится в режиме RUN. Кроме того, Вы можете использовать видимые объекты,
создаваемые с помощью S7-PLCSIM для изменения любых данных, используемых
программой.
Режим STOP
ЦПУ не выполняет программу. В отличие от режиме STOP реального ЦПУ, выходы не
устанавливаются в предопределенные безопасные значения но остаются в состоянии, в
котором они были, когда  ЦПУ перешел в STOP. Вы можете загрузить программу в ЦПУ,
если он находится в режиме STOP. Переход из режима STOP в RUN вызывает
выполнение программы, начиная с первой команды.
Режимы работы ЦПУ, индикаторы ЦПУ и кнопка Clear/Reset (Сброс памяти) показаны на
видимом объекте ЦПУ. Вы можете установить режим работы ЦПУ, используя
переключатель режимов. Вы можете приостановить выполнение имитируемой программы
ПЛК, если ЦПУ находится в режимах RUN или RUN-P.
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Индикаторы ЦПУ
Видимый объект CPU воспроизводит индикаторы, которые соответствуют светодиодам на
реальном ЦПУ:
SF (системная неисправность) сигнализирует, что ЦПУ встретил системную ошибку,
приведшую к изменению рабочего режима.
DP (распределенная периферия или удаленные ввод/вывод) показывает состояние связи
с распределенным (удаленным) входом/выходом.
DC (обеспечение питанием) показывает выключено или включено питание ЦПУ.
RUN показывает, что ЦПУ находится в режиме RUN.
STOP  показывает, что ЦПУ находится в режиме STOP.

Области памяти
Вы имеете доступ к данным в ПЛК S7 адресуясь к определенным областям памяти. Эти
области выполняют специальные функции:
PI (периферийный вход): обеспечивает прямой доступ к входным модулям.
I (вход): обеспечивает доступ к области отображения входов. Эти величины обновляются
ЦПУ в начале каждого цикла CPU.
PQ (периферийный выход) обеспечивает прямой доступ к выходным модулям. Эти
значения обновляются ЦПУ в конце каждого цикла ЦПУ.
Q (выход): обеспечивает доступ к области отображения выходов.
M (меркеры): обеспечивает хранение данных, используемых внутри программы.
T (таймер): обеспечивает хранение таймеров.
C (счетчик): обеспечивает хранение счетчиков.
У Вас также есть доступ к данным, хранящихся в блоках данных (DB).



Основные задачи

11
S7–PLCSIM
C79000–G7000–C201–02

Основные задачи
Запуск имитатора
Есть несколько возможностей начать работу в S7-PLCSIM:
Из стартового меню Windows, выбрав команду меню Simatic>STEP 7>S7-PLCSIM
Simulating Modules.
С панели инструментов SIMATIC Manager, нажав кнопку Simulation On/Off (Имитация

вкл/выкл)  или выберите команду меню Option > Simulate Modules (Опции >
Имитировать модули).
Создать короткий путь к программному файлу.
([CD]:\Siemens\PLCSIM\s7wsi\s7wsvapx.exe, где [CD] – диск, где установлена программа).

Когда кнопка Simulation On/Off (Имитатор вкл./выкл.) нажата  , любая новая связь
автоматически подключается к имитатору ПЛК. Любая загружаемая программа попадает
в имитатор ПЛК, если адрес MPI имитатора ПЛК совпадет с адресом, установленным в
проекте STEP 7. Если Вы нажмете кнопку Accessible Nodes (Доступные узлы), окно
Accessible Nodes (Доступные узлы) покажет адрес созданного Вами имитатора  ПЛК.

Когда кнопка имитатора отжата  , любая связь устанавливается с реальным ПЛК.
Если Вы нажмете на кнопку Accessible Nodes (Доступные узлы), окно Accessible Nodes
(Доступные узлы) покажет сеть реальных ПЛК.
После запуска S7-PLCSIM Вы можете открыть имитируемый ПЛК или монитор
имитируемых программ. Вы можете продолжить имитацию ПЛК, пока Вы не закончите
сессию имитации.
Замечания
Режим имитатора недоступен, если у Вас есть соединение с реальным ПЛК.
Вы можете активировать одновременно только один имитатор ПЛК.
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Использование Помощи
У Вас есть доступ к помощи S7-PLCSIM через меню Help (Помощь), или любым из
следующих способов:

Вы  можете получить помощь об объектах окна S7-PLCSIM. Нажмите на кнопку Help 
на панели инструментов и затем щелкните на объекте.
Вы можете получить помощь о любом окне диалога или сообщении об ошибке. Нажмите
на кнопку Help в окне диалога или сообщения или нажмите F1.
Окно Help обеспечивает следующие кнопки и таблицы:

Кнопки помощи
Кнопки Hide/Show (Скрыть/показать)
Переключает видимость области поиска (содержание, указатель и таблица поиска). Для
уменьшения общего размера окна помощи, Вы можете скрыть область поиска; когда Вы
будете искать новые заголовки, нажмите на кнопку Показать для восстановления области
поиска.
Кнопка Back (Назад)
Если Вы смотрите более чем один раздел, эта кнопка позволит Вам вернуться к
предыдущему разделу(ам).
Кнопка Print (Печать)
Позволяет Вам посылать выбранный раздел или целую книгу, к любому установленному
принтеру.

Кнопка меню команд Options (Опции)
Hide/Show tabs (Скрыть /Показать область поиска): Переключает отображение
содержания, указателя и страницы поиска. Для уменьшения общего размера окна
помощи, Вы можете скрыть область поиска, когда Вы готовы искать новые разделы,
нажмите на кнопку Show (Показать) для восстановления область.
Back (Назад): Если Вы смотрите более чем один раздел, эта кнопка позволит Вам
вернуться к предыдущему разделу(ам).
Forward (Вперед): Если Вы перемещались назад в последовательности
просматриваемых разделов, эта кнопка позволит Вам перемещаться вперед, пока Вы не
достигните точки, где Вы были, перед началом движения назад.
Home: Загружает Вам web страницу, которая определена как Home page для S7-PLCSIM
Online Help.
Stop (Стоп): Позволяет Вам остановить браузер при получении большого количества
информации во время загрузки текущей страницы помощи. Эта команда будет полезной,
если страница содержит большое количество информации (например, большой
графический файл), что является причиной долгой загрузки страницы.
Refresh (Обновление): обновляет вывод текущей страницы помощи.
Internet Options (Опции интернет): Позволяет Вам задать опции для браузера Internet.
Print (Печать): Позволяет Вам послать выбранный раздел или целую книгу на любой
подключенный принтер.
Seach Highlight Off / Seach Highlight On (Выключить/включить подсветку искомых
слов): переключает подсветку разделов, которые содержат выражения, которые Вы
определили в поле поиска. Подсветка цветом позволяет Вам точно увидеть, где
появляется искомый термин.
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Страницы браузера помощи
Contents tab (Страница содержания)
Выберите эту страницу, чтобы видеть содержание системы помощи. Щелкните дважды на
иконку книги, чтобы раскрыть ее и просмотреть заголовки, которые она содержит.
Index tab (Указатель)
Выберите эту страницу, чтобы увидеть алфавитный список индексированных ключевых
слов для системы помощи.
Страница Seach (Поиск)
Выберите эту страницу и напечатайте выражения, которые Вы хотите найти. Затем
нажмите на кнопку List Topics (Список разделов), чтобы увидеть, содержит ли раздел
заданный Вам термин. Выберите раздел из списка и нажмите на кнопку Display (Показать)
для просмотра. По умолчанию, искомое выражение будет подсвечиваться в каждом
месте, при появлении в разделе, облегчая нахождение термина. Вы можете переключать
подсветку перед показом раздела, используя кнопку Опции.
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Как открыть имитатор ПЛК
Когда Вы открываете S7-PLCSIM, имитатор открывает новую, безымянную имитацию
ПЛК. Если это Ваше первое использование S7-PLCSIM, Вы видите только видимый
объект CPU; в другом случае S7-PLCSIM показывает видимые объекты предыдущей
рабочей сессии.
У Вас есть два пути:
Вы можете начать работать в S7-PLCSIM, используя новый имитатор ПЛК.
Вы можете открыть сохраненный ранее имитатор ПЛК, используя команды File > Recent
Simulation (Файл > Последняя имитация) или File > Open PLC... (Файл > Открыть ПЛК
…) для того, чтобы выбрать нужный файл *.PLC. Работа, которую Вы выполняли в ПЛК
(например, загруженная программа или аппаратная конфигурация или присвоение
значений в видимых объектах) сохраняются в файле имитатора. Таким образом, когда Вы
откроете имитатор, Вам не нужно будет повторять эти шаги. Вы можете начать работу с
того места, где остановились в прошлый раз.
После того, как Вы решите с чем работать – со старым имитатором или новым, Вы
можете добавить или изменить видимый объект в S7-PLCSIM. Если предыдущая версия
открыта, Вы можете ее закрыть. Вы можете использовать панель инструментов или меню
View (Вид) и Insert (Вставить) для того, чтобы добавить новый видимый объект. Вы
можете использовать команду меню File > Open Layout (Файл > Открыть компоновку),
чтобы выбрать одну из предыдущих версий, если Вы хотите хранить их более, чем одну.
Изменения в Вашей предыдущей версии не изменят информацию в Вашей программе;
они влияют только на способ, которым отображается информация.

Замечание
Когда Вы откроете новый или сохраненный имитатор ПЛК, любой просматриваемый
объект, который показан в S7-PLCSIM, автоматически закроется. Если Вы хотите открыть
ранее сохраненную версию, а также новый или ранее сохраненный имитатор ПЛК,
откройте имитатор ПЛК прежде, чем сохраненную версию.

Чем отличаются файлы *.PLC  и *.LAY?
Файлы *.PLC используется для хранения информации о работе, которую Вы выполняли
на ЦПУ с видимыми объектами (т.е. на имитаторе ПЛК). В него также записываются
изменения, которые Вы делаете в данных: если Вы присваиваете значение некоторой
переменной в памяти, используемой любым видимым объектом, эти изменения
записываются в файл *.PLC.
A файлы *.LAY используются для хранения предыдущей компоновки Вашего рабочего
пространства в S7-PLCSIM. Если Вы располагаете Ваши просматриваемые объекты в
определенном порядке и хотите сохранить этот порядок для будущей работы, сохраните
компоновку перед тем, как Вы закроете S7-PLCSIM. В следующий раз, когда Вы откроете
S7-PLCSIM, видимые объекты будут показаны в нужном порядке. (Однако, если Вы
откроете новый или сохраненный имитатор ПЛК во время Вашей текущей работы, S7-
PLCSIM автоматически закроет Вашу компоновку. Если Вы хотите использовать
предыдущую компоновку с имитатором ПЛК, который Вы хотите открыть, откройте еще
раз файл *.LAY.)
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Открытие компоновки
Для возврата к предыдущей компоновке видимых объектов в S7-PLCSIM, выберите
команду меню File > Open Layout...(Файл > Открыть компоновку).
Компоновка существует просто для расположения видимых объектов. Другими словами,
файл * .LAY сохраняет только позицию и выбранный формат данных видимых объектов;
значение данных, показанных в видимых объектах, не сохраняется, как часть компоновки.
Когда Вы работаете в S7-PLCSIM, Вы можете открыть файлы *.PLC и *.LAY (если у Вас
есть предыдущий имитатор и компоновка видимых объектов). Это не взаимно
исключающие действия; Вы не обязаны выбрать что-то одно. Однако, более эффективно
открытия имитатора ПЛК (файл *.PLC) до открытия компоновки (*.LAY), потому что
каждый раз, когда Вы открываете новый или сохраненный имитатор ПЛК, S7-PLCSIM
автоматически закрывает открытую компоновку. Вы можете, таким образом, сохранить
компоновку, сохранить имитируемый ПЛК и закрыть имитируемый ПЛК.
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Выбор опций циклического режима выполнения
S7-PLCSIM предлагает следующие возможности для выполнения имитируемой
программы:
Однократное выполнение программы: ЦПУ выполнит один цикл, и затем будет ждать,
когда Вы решите выполнить следующий. Каждый цикл состоит из чтения ЦПУ
периферийных входов (PI), выполнения программы, и, затем, записи результатов в
периферийные выходы (PQ). ЦПУ затем ждет, когда Вы начнете следующий цикл

(используйте команду меню Execute > Next Scan) или нажмите  .
Циклический режим: ЦПУ выполняет одно полный цикл и затем начинает другой. Каждый
цикл состоит из чтения ЦПУ периферийных входов (PI), выполнения программы, и затем
запись результатов на периферийные выходы (PQ).

Для того, чтобы выбрать режим однократного выполнения, нажмите на  или выберите
команду меню Execute > Scan Mode> Single Scan (Выполнить > Режим циклического
функционирования > Однократное выполнение).
Это позволяет Вам просмотреть изменения при каждом цикле. Несмотря на то, что
реальный ЦПУ может работать быстрее, чем редактор может показывать данные,
возможность однократного выполнения программы позволяет Вам фиксировать
состояние программы от одного цикла к другому.

Для того, чтобы выбрать режим циклического выполнения, нажмите на  или выберите
команду меню Execute > Scan Mode > Continuous Scan (Выполнить > Режим
циклического функционирования > Циклическое выполнение). (Режим по умолчанию
- циклическое выполнение.)
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Изменения рабочего режима ЦПУ
Вы можете изменить рабочий режим ЦПУ. Имитатор  ПЛК реагирует на изменения
рабочего режима так же, как реальный ПЛК. Окно видимого объекта имитатора ПЛК
показывает текущий рабочий режим. Для того, чтобы изменить рабочий режим, отметьте
нужный бокс выбора в видимом объекте ПЛК или используйте команду меню Execute >
Key Switch Position > [mode] (Выполнить > Позиция переключателя режимов >
[режим]).
Рабочие режимы на имитаторе функционирует подобно переключению режимов на
реальном ЦПУ: если Вы используете инструменты STEP 7 для изменения рабочего
режима или если ЦПУ автоматически изменяет режим (например, встретится сбойная
ситуация, по которой ЦПУ из режима RUN перейдет в STOP), боксы выбора видимого
объекта имитатора ЦПУ не изменятся. Изменится индикатор, имитирующий светодиод, но
не бокс выбора, имитирующий переключатель. Будет сообщение об изменении рабочего
режима ЦПУ, возможно имеются ошибки в программе.
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Управление программой имитатора
Вы можете отобразить различные типы видимых объектов, которые позволяют Вам
управлять и модифицировать программу, выполняемую на имитаторе ПЛК.
Следующие семь видимых объектов активируются через меню Insert (Вставка):
Входная переменная: позволяет Вам иметь доступ к данным, сохраненным в области
памяти входов (I). Значение адреса по умолчанию 0 байт 0 (IB0).
Выходная переменная: позволяет Вам иметь доступ к данным, сохраненным в области
памяти выходов (Q). Значение адреса по умолчанию 0 байт (QB0).
Меркеры: позволяет Вам иметь доступ к данным, сохраненным в области меркеров (M).
Значение адреса – это байт 0 (MB0).
Таймер: позволяет иметь доступ к таймерам, используемым программой. Значение
таймера по умолчанию T 0.
Счетчик: позволяет иметь доступ к счетчикам, используемым программой. Значение
счетчика по умолчанию C 0.
Групповой: позволяет Вам иметь доступ к любой области памяти в имитаторе ЦПУ,
включая блок данных (DB).
Вертикальные биты позволяют Вам видеть символические или абсолютные адреса
каждого бита, наблюдать т модифицировать данные. Вертикальные биты могут
использоваться для побитового показа переменных периферийных входов и выходов,
областей отображения входов и выходов, меркеров и переменных в блоках данных.
Вы можете использовать адресацию для любых из перечисленных объектов.
Следующие три видимых объекта активируются меню View (Вид):
Аккумуляторы: позволяют Вам отобразить данные в различных аккумуляторах в
имитаторе  ЦПУ, а также слово состояния и адресные регистры. Видимый объект
отображает четыре аккумулятора, размещая четыре аккумулятора ЦПУ S7-400.
Программа для ЦПУ S7-300 использует только два сумматора.
Регистры блоков: позволяют Вам отображать содержание адресных регистров блоков
данных в имитаторе ЦПУ. Также показывают номер выполняемого логического блока и
номер предыдущего логического блока, с номером выполняемой инструкции (счетчика
адреса, или SAC).
Стеки: позволяют отображать сохраненные данные в аппаратных стеках и стеке команды
MСR в имитаторе ПЛК.
Вы также можете одновременно управлять приложениями в программе STEP 7
«LAD/STL/FBD»:

1. В SIMATIC Manager, переключиться в режим Online, нажав на  или подав команду
View > Online.

2. Управлять папкой «Блоки» в проекте S7_ZEBRA и открывать FC1.
3. Приложение «LAD/STL/FBD» показывает программу, которая выполняется имитатором
ПЛК. Используйте команды меню для просмотра инструкций.
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Использование управления ползунком
Управление ползунком позволяет Вам имитировать величины, которые изменяются
постепенно или имеют заданный диапазон, такие как аналоговые величины. Вы можете
использовать управление ползунком для следующих видимых объектов:
Входная переменная
Выходная переменная
Меркер.
Вы можете получить доступ к области памяти, используя адреса или символические
адреса. Чтобы определить управление ползунком для одного из переменных видимых
объектов, Вы выбираете формат представления ползунка из выпадающего списка Select
Numeric Format (Выбор численного формата). Также Вы выбираете, представлять ли
величины как двоично-десятичные (положительные целые), целые (положительные и
отрицательные целые), или действительные числа. Опции выбора определяются
размером памяти, к которой осуществляется доступ.
Байт (B): двоично-десятичный
Слово (W): двоично-десятичный и целый
Двойное слово (D): двоично-десятичное, целое и действительное.
Чтобы изменить положение индикатора управления ползунком, Вы можете использовать
либо мышь, либо клавиши управления курсором. Изменение позиции индикатора меняет
величину переменной, хранящейся в ячейке памяти. Вы также можете вести заданную
величину в поле “Величина”.
Также Вы можете конфигурировать минимальную и максимальную величину для
управления ползунком. Выбор диапазона значений не влияет на величину, которая может
храниться в переменной: минимальная и максимальная величина влияет только на
значение, которое вводится или показывается ползунком. Выбор диапазона величины
обеспечивает следующие выгоды:
Вы можете имитировать заданный диапазон значений; например, диапазон величины,
которая будет сгенерирована определенным аналоговым модулем.
Ограничивая диапазон значений минимумами и максимумами, Вы обеспечиваете лучшую
разрешающую способность для ввода данных ползунком. Вы можете ввести точную
величину в поле “Величина” в видимом объекте.
Чтобы выбрать минимальное значение ползунка, выберите Min из отображаемой
величины выпадающего списка Min или Max видимого объекта. Затем введите числовое
значение для минимума в поле Min.
Чтобы выбрать максимальное значение ползунка, выберите Max из отображаемой
величины выпадающего списка Min или Max видимого объекта. Затем введите числовое
значение для минимума в поле Max.
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Использование S7-PLCSIM для отладки Вашей программы
S7-PLCSIM имеет следующие особенности, чтобы помочь Вам отладить Вашу программу:
Команда Pause (Приостановить) сразу же останавливает имитатор ЦПУ и позволяет Вам
возобновить выполнение программы с той команды, на которой программа была
остановлена.
Любые изменения, которые Вы делаете в видимом объекте, сразу же обновляют
содержимое области памяти. ЦПУ не ожидает начала или конца цикла для обновления
изменяемых данных.
Опции управления исполнением позволяют выбрать, как ЦПУ выполнит программу:

•  Однократный цикл выполняет программу один раз, а затем ждет начала
следующего цикла.

•  Непрерывный цикл выполняет программу подобно реальному ПЛК: начало нового
цикла немедленно следует за концом предыдущего.
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Использование OB прерываний в Вашей программе
Вы можете использовать S7-PLCSIM, чтобы проверить, как ваша программа управляет
различными OB прерываний. S7-PLCSIM поддерживает следующие:
OB40 – OB47 (аппаратные прерывания)
OB70 (ошибка резервирования входов/выходов) {только для систем 417-H}
OB72 (ошибка резервирования ЦПУ) {только для систем 417-H}
OB73 (ошибка резервирования коммуникаций) {только для систем 417-H}
OB80 (временная ошибка)
OB82 (диагностическое прерывание)
OB83 (вставка/удаление модуля)
OB85 (ошибка класса приоритета)
OB86 (неисправность стойки)

Чтобы выбрать нужное OB, используйте команду меню Execute > Trigger Error
OB…(Исполнить > Включить OB ошибки …), и введите требуюмую информацию в
диалоговом окне. Когда Вы щелкните на кнопке “OK” или “Apply” («Применить»),
имитируемый ПЛК сгенерирует соответствующее событие и исполнит программу в
связанном с событием OB. OB, которое доступны для включения из меню Trigger Error OB
(Включение OB ошибок), зависят от конфигурации входов/выходов имитируемого ПЛК.

Конфигурирование входов/выходов
Если Ваш проект соответствует любому из следующих описаний, Вы можете внести
изменения и загрузить модифицированную конфигурацию оборудования в S7-PLCSIM:
Проект S7-300  с любым ЦПУ, кроме  315-2 DP, 316-2 DP или 318-2
Проект S7-400, который использует распределенные входы/выходы, а не модель ЦПУ,
которая явно поддерживает распределенный ввод/вывод.
Для того, чтобы имитировать OB прерываний, Вы должны загрузить аппаратную
конфигурацию, которая содержит Ваши входы/выходы. В некоторых случаях Ваши
входы/выходы автоматически включаются в данные системы, которые STEP 7 загружает
в S7-PLCSIM; в других случаях Вы можете изменить конфигурацию на одну из данных.

ЦПУ S7-300
ЦПУ S7-300 такие, как S7-315-2DP, S7-316-2DP и S7-318-2, загружают конфигурацию
входов/выходов; все другие ЦПУ S7-300 автоматически конфигурируют входы/выходы,
совпадающие с физическими входами/выходами, установленными в стойку. Проекты, уже
сконфигурированные для одного из ЦПУ, названных выше, не требуют изменений
конфигурации аппаратуры.
Для других ЦПУ Вы должны скопировать Вашу аппаратную конфигурацию и поместить
данные в проект для ЦПУ, в котором нет автоконфигурации входов/выходов, а именно, в
проекты S7-315-2DP, S7-316-2DP или S7-318-2. Когда Вы загрузите информацию о
входах/выходах из проекта, Вы можете имитировать прерывание OB в S7-PLCSIM (а S7-
PLCSIM  также умеет находить любые ошибки входов/выходов, которые содержит
программа).

ЦПУ S7-400
Если Вы используете CP с входами/выходами PROFIBUS-DP Вы не можете загрузить
конфигурацию входов/выходов и использовать ее для имитации прерывания OB в S7-
PLCSIM. Однако, Вы можете скопировать Вашу конфигурацию входов/выходов во второй
проект и заменить CP S7-400 на модель ЦПУ S7-400 (такую, как ЦПУ 416-DP), которое
явно поддерживает DP. Загрузив Вашу аппаратную конфигурацию из второго проекта в
S7-PLCSIM, Вы можете имитировать прерывание OB и находить ошибки входов/выходов.
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Модификация Вашей аппаратной конфигурации
Для того, чтобы имитировать управление прерываниями OB в Вашей программе, Ваша
конфигурация входов/выходов должна использовать ЦПУ 315-2 DP, ЦПУ 316-2 DP, ЦПУ
318-2 или ЦПУ S7-400, которые прямо поддерживают распределенную периферию (DP).
S7-PLCSIM поддерживает только одну мастер-систему DP; Вы не можете использовать
конфигурацию аппаратуры с более чем одной мастер-системой. Если Ваш ЦПУ не
относится к перечисленным Выше типам, используйте следующие процедуры для
создания и модификации копии Вашей аппаратной конфигурации.
1. Вставьте новую станцию SIMATIC для сохранения модифицированной конфигурации,
которую Вы собираетесь создать. Дайте ей имя, например SIM_IO.

2. Выберите Вашу станцию.
3. Откройте аппаратную конфигурацию Вашей станции.
4. Копируйте  центральную стойку из Вашей аппаратной конфигурации.

 Внимание
Запомните, что следует только копировать, не вырезайте из конфигурации Вашего
оригинального проекта в конфигурацию проекта SIM_IO. Если Вы вырежете пункты из
своей оригинальной конфигурации, то ваше аппаратное обеспечение больше не будет
работать с реальными приложениями.
5. Текущая аппаратная конфигурация Вашей станции открыта, вернитесь к станции

SIM_IO и откройте ее аппаратную конфигурацию.
6. Скопируйте из Вашей оригинальной конфигурации в конфигурацию SIM_IO
центральную стойку.

7. Редактируйте в конфигурации SIM_IO центральную стойку, чтобы заменить ЦПУ:
Если  установлено ЦПУ S7-300, замените его на ЦПУ 315-2 DP, ЦПУ 316-2 DP или ЦПУ
318-2.
Если установлено ЦПУ S7-400, замените его на ЦПУ, который поддерживает DP.
(Дополнение «DP» должно появиться в имени выбранной Вами модели.)
Замечание
Когда Вы вставите новый ЦПУ в центральную стойку, аппаратная конфигурация STEP 7
выдаст серию сообщений, побуждающих Вас назначить сеть. Если ваш оригинальный
проект не сетевой, ответьте «нет» на этот запрос. Аппаратная конфигурация STEP 7
показывает сообщение «Не могу назначить сеть PROFIBUS мастеру DP.» Поскольку Вы
не нуждаетесь в сети PROFIBUS, это сообщение не имеет для Вас значения.
7. Если ваша конфигурация изначально использует CP для DP связи, удалите CP из

конфигурации SIM_IO.  CP не нужен после того, как Вы поместите ЦПУ с DP в
конфигурацию.

8. Если Вы имеете в своей оригинальной конфигурации стойки расширения или slaves
PROFIBUS, скопируйте их в конфигурацию SIM_IO.

9. Тщательно проверьте адреса, назначенные STEP 7 модулям в конфигурации SIM_IO
и сделайте необходимые изменения.

10. Сохраните и закройте конфигурацию SIM_IO.
11. Закройте оригинальную конфигурацию.
После того, как Вы сделали требуемые изменения, Вы можете загрузить измененную
конфигурацию в S7-PLCSIM.
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Загрузка модифицированной конфигурации
После того, как Вы создали конфигурацию входов/выходов, которую можно использовать
в S7-PLCSIM, Вы можете загрузить окончательные  системные данные.
1. В окне SIMATIC Manager, войдите в проект SIM_IO и там откройте папку blocks (блоки).
Отображаются объект системных данных и блок OB1.

2. Удалите блок объекта OB1 из проекта SIM_IO. Это даст уверенность в том, что Вы не
сможете случайно загрузить в S7-PLCSIM пустой OB1 из проекта.

3. Загрузите Вашу аппаратную конфигурацию в S7-PLCSIM.

Замечание
Не важно, загрузите Вы Ваши программные блоки перед тем, как загрузить  аппаратную
конфигурацию SIM_IO или наоборот. Тем не менее, если Вы загружаете программные
блоки после загрузки аппаратной конфигурации SIM_IO, убедитесь в том, что на запрос
«Хотите ли Вы считать системные данные?» Вы ответили «Нет». Если Вы случайно
загрузили системные данные из Вашего первоначального проекта, аппаратная
конфигурация перепишется.

Сброс памяти ЦПУ
Для сброса памяти имитируемого ЦПУ выберите команду меню PLC > Clear/Reset (ПЛК >
Очистить/Сбросить), или нажмите на кнопку MRES (Сброс памяти) на видимом объекте
ЦПУ. Это действие сбрасывает память, удаляя блоки программы и конфигурацию
аппаратуры.
Когда Вы выполняете очистку/сброс памяти, ЦПУ  автоматически переходит в режим
STOP.

Переустановка таймеров
Диалоговое окно Reset Timers (Переустановка таймеров) позволяет Вам переустановить
все или некоторые таймеры используемые в программе, в значения по умолчанию.
Выбор «All Timers (Все таймеры)» сбрасывает все таймеры в Вашей программе; Вы
можете также выбрать сброс отдельных таймеров.
Для переустановки всех таймеров в Вашей программе, используйте кнопку Reset Timers

(Переустановка таймеров)  в панели инструментов.
Для переустановки отдельных таймеров, используйте кнопку Reset Timers (Переустановка

таймеров)  в видимом объекте для нужного таймера..
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Использование символьной адресации
Для использования символьной адресации в Вашей имитируемой программе:
1. Выберите команду меню Tools > Options > Attach Symbols... (Инструменты

> Опции > Присоединить символику…). Эта команда вызовет окно диалога.
2. Просмотрите  таблицу символов STEP 7, чтобы найти необходимые.
3. Нажмите кнопку «OK».
4. Создайте видимый объект для переменных, которым Вы хотите присвоить символьную
адресацию.

5. Включите символы для всех видимых объектов, выбрав команду меню Tools >
Options > Show Symbols (Инструменты > Опции > Показать символику). Для того,
чтобы скрыть символы, повторите команду.

Для видимого объекта Vertical Bits (Вертикальные биты), битовые значения показываются
вертикально, а символические или абсолютные адреса показаны за каждым битом. Для
остальных видимых объектов, символьные подсказки доступны для полей адреса.
Укажите поле мышью, чтобы увидеть символический адрес и закомментируйте (отделите
двоеточием)  в окне подсказки.

Конфигурирование адреса MPI
Используйте окно диалога MPI адресов (команда меню PLC > MPI Address... –
ПЛК > Адрес MPI), чтобы сконфигурировать имитируемый ПЛК для заданного адреса
узла сети. Новые адреса сохранятся с конфигурацией имитатора ПЛК , когда Вы
используете команды меню Save PLC (Сохранить ПЛК) или Save PLC As...(Сохранить
ПЛК как).
Убедитесь, что адреса узлов для программы offline соответствуют адресам узлов
программы имитатора ПЛК.

Когда кнопка Simulation On/Off (Имитатор вкл./выкл.)  на панели инструментов
SIMATIC Manager  включена, нажмите на кнопку Accessible Nodes (Доступные узлы),
показывающую Вам какой  имитатор ПЛК открыт.
Замечание
Вы не можете изменить адреса узлов для имитатора ПЛК, пока Вы используете
приложение STEP 7 для мониторинга программы. Закройте эти приложения перед тем,
как изменить адреса узлов.
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Использование Записи/Воспроизведения
Диалоговое окно Запись/Воспроизведение позволяет Вам записывать или
воспроизводить последовательности изменения данных.

Для доступа к этому окну выполните одну из команд:
Выберите команду меню Tools > Record/Playback (Инструменты > Запись /
Воспроизведение)

Нажмите на кнопку  Record/Playback (Запись/Воспроизведение) 
Комбинация клавиш Alt + F5 переключает отображение кнопки Record/Playback
(Запись/Воспроизведение).
В этом разделе обсуждается следующее:

� Как записать или воспроизвести файл событий
� Советы по устранению проблем

Как записать или воспроизвести файл событий

Нажмите на кнопку New Event File (Новый файл событий)  для создания нового
файла событий.

Нажмите на кнопку Open Event File  ( Открыть файл событий)  для обнаружения и
открытия существующего файла.

Нажмите на кнопку Save Event File (Сохранить файл событий) , чтобы сохранить
события, которые Вы записали.

Нажмите на кнопку  Play (Проигрывание)   для воспроизведения существующей
записи.

Нажмите на кнопку  Record (Запись)  для начала записи последовательности
событий. Используйте видимый объект имитатора для включения и выключения bits или
присвоения данным значений. Записывающее устройство захватит любые изменения,
сделанные в области памяти.

Нажмите кнопку  Pause (Пауза)  для временной остановки записи или
воспроизведения. Для записи это удобно, если Вы не закончили запись событий, а Вам
нужно выполнить некоторое действие (например, добавить новый объект, или ответить
на звонок по телефону ), нет причин делать долгий перерыв в записи. Stop позволяет Вам
минимизировать время задержки между файлами, которые Вы записываете, в отличие от
кнопки Delta (Приращение) влияет  на общую скорость воспроизведения записи.

Нажмите на кнопку  Stop (Стоп)  для того, чтобы остановить запись или
воспроизведение событий.

Кнопка Delta (Приращение)  позволяет Вам выбрать скорость перед тем, как Вы
воспроизведете запись. Ваш выбор влияет на длительность всего воспроизведения.
Однако, относительные временные интервалы между событиями сохранятся даже тогда,
когда время воспроизведения уменьшится или увеличится выбором Delta.
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Есть два пути проверки успешности записи или воспроизведения:
Проверьте панель статуса в диалоговом окне Запись/Воспроизведение, чтобы увидеть
идет ли запись, воспроизведение или простой.
Взгляните на панель заголовка диалогового окна Запись/Воспроизведение. Оно покажет
величину, которая увеличивается каждый раз, когда Вы записываете или воспроизводите
событие.
Если Вы удовлетворены записью, не забудьте сохранить ее с помощью кнопки Save Event
File перед закрытием S7-PLCSIM.

Устранение неисправностей
Проблема Решение
Я пытался записать
события, но когда я
их проиграл, ничего
не произошло

Измените режим S7-PLCSIM STOP на RUN.
Вы можете воспроизводить события в режиме STOP, при
гарантии, что они были записаны в режиме RUN. Все события,
воспроизводимые в режиме STOP, имеют нулевую величину
приращения Delta. Поэтому, когда Вы проигрываете запись, все
события, которые Вы записали за один цикл, отображаются так
быстро, как будто они произошли одновременно.

Кнопка Play  не
активна и я не могу
воспроизвести
запись.

Вы должны открыть  файл событий перед тем, как его
воспроизвести. Используйте кнопку Open Event File для выбора
и открытия файла событий.

Я записал последо-
вательность
событий, а затем
закрыл S7-PLCSIM.
Через некоторое
время открываю S7-
PLCSIM и не могу
найти файла
событий.

Если Вы закрыли S7-PLCSIM без сохранения записанных
событий, Ваша работа потеряна. Используйте кнопку Save Event

File  перед закрытием S7-PLCSIM.

Я записал
последовательность
событий, но когда
попытался
воспроизвести их,
ничего не
получилось.

Проверьте строку состояния диалогового окна Запись /Воспро-
изведение, чтобы увидеть, какой режим включен. Если это Вос-
произведение, посмотрите на панель заголовка, чтобы увидеть
номер записи. Когда файл воспроизводится, счетчик на панели
заголовка показывает количество воспроизведений. Заметьте,
что если Вы начали запись, но не сразу начали переключать
события, воспроизведение начнется с задержкой. Когда Вы
воспроизводите запись, первое событие начнется через это же
время. Вы можете проверить файл событий, чтобы убедиться,
что события записаны правильно. Вы можете настроить

скорость воспроизведения, используя кнопку Delta 
(Приращение).

Я не могу вспомнить,
какой файл событий
содержит
последовательность
событий, которую я
хочу проиграть.

Вы можете использовать длинные, описательные имена
файлов, чтобы облегчить узнавание. Если необходимо, Вы
можете использовать текстовый редактор для проверки ваших
файлов и определения нужного. По умолчанию  файлы событий
хранятся в C:\Siemens\Step7\S7wsi\S7EVENTS. Однако если Вы
заменили версию 3.0 или 4.0 S7-PLCSIM, место сохранения по
умолчанию - C:\Siemens\STEP7\S7wsi\S7EVENTS.
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Я изменил один бит,
но когда я воспроиз-
вел запись, изменил-
ся весь байт.

Если переменная входа, переменная выхода, меркер,
обобщенная переменная или вертикальные биты показывают
только один бит (т.е., Q0.0, биты), изменение бита записывается
правильно, поскольку оно выполнено в отдельном бите. Однако,
если видимый объект показывает все 8 бит (т.е., QB0, биты),
изменения одного бита записываются, как изменения значения
байта, вместо изменения в бите. Поэтому, возможно, что во
время воспроизведения  записи, остальные биты в байте
выглядят как изменения (например, флага процесса, булевских
входов), когда на самом деле они не могли возникнуть во время
работы реального ПЛК.

Я пытаюсь записать
файл в режиме
Single Scan, но
записывающее
устройство не
функционирует так,
как я думал.

Есть несколько типов записи файлов с видимым объектом CPU
в режиме Single Scan:
Вы не можете начать запись в режиме Single Scane, не нажав

Next Scan  для приращения счетчика циклов. Первый файл
событий Вашей записи должен иметь величину Delta 1 или
выше. Величина Delta основана на номере цикла, с
предыдущего файла (который будет, когда Вы нажмете на
кнопку Record). Однако, если Вы начали запись в режиме Single
Scan, не выполняйте истекший цикл. Вы должны выполнять
пошагово.
Когда Вы записываете события в режиме Single Scan, они
должны иметь значение Delta ноль (потому что они происходят в
том же цикле). Поэтому когда Вы воспроизводите запись, все
события, которые Вы записали в течение одного цикла,
показываются в той  последовательности, в которой они
появляются. Для того, чтобы обеспечить различное время
задержки между событиями, Вы должны нажать на кнопку Next
Scan или переключаться между режимами Continuous Scan  и
Single Scan для каждого события.

Мой файл событий
содержит немецкую
мнемонику, хотя в
STEP 7 я выбрал
международную

Файлы, записанные в немецкой мнемонике, в S7-PLCSIM  не
используют настройки  STEP 7. Вы можете игнорировать это
явление.
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Мониторинг цикла
Это диалоговое окно позволяет Вам включать или отключать управление циклами
(сторожевой таймер) и устанавливать максимальное время цикла для имитатора.
Максимальное время цикла это максимальное время процесса, включающего полный
цикл выполнения пользовательской программы S7в OB1 и время обновления
соответствующих входов/выходов. Если превышено заданное время, ЦПУ переходит в
режим STOP.
Поскольку выполнение программы может быть медленнее в S7-PLCSIM, чем на реальном
ЦПУ (особенно, когда приложения выполняются в высшем приоритете), задержка
времени может создавать проблемы. Это окно диалога делает возможным включить или
выключить мониторинг времени цикла без изменения программы для целевого ПЛК.
Заметьте, что окно диалога не отражает управления установкой времени в аппаратной
конфигурации, и любые изменения влияют только на имитатор.
Если выбрано «Включить управление циклами», Вы можете установить время
управления для любой величины от 1 секунды (1000 мс) до 1 минуты (60000 мс)
включительно. Значение времени управления по умолчанию 20000 мс.

Сохранение макета
Для сохранения текущей компоновки видимых объектов S7-PLCSIM, выберите команду
меню File > Save Layout (Файл > Сохранить компоновку). Компоновка – просто
расположение видимых объектов. Другими словами,файл * .LAY сохраняет только
позицию и выбранный формат данных видимых объектов; значение данных, показанных в
объекте просмотра, не сохраняются как часть компоновки.
Вы можете сохранить файлы компоновки (файл *.LAY) и имитатора ПЛК (файл *.PLC),
когда Вы работаете: они не взаимно исключающиеся.
Для информации о том, что сохранилось при сохранении имитатора ПЛК  (файл *.PLC),
посмотрите Запись имитатор ПЛК.
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Сохранение имитатора ПЛК
Вы можете хранить текущее состояние в имитатор ПЛК:
Используйте команду меню File > Save PLC (Файл > Сохранить ПЛК) для сохранения
конфигурации ПЛК в текущем файле.
Используйте команду меню File > Save PLC As... (Файл > Сохранить ПЛК как …) для
сохранения конфигурации ПЛК в новом файле.
При сохранении ПЛК сохраняются следующие элементы:
Программа
Аппаратная конфигурация
Выбранный режим  (позиция переключателя) для рабочего режима ЦПУ, а именно, RUN-
P, RUN или STOP
Опции управления (циклическая работа, однократное выполнение)
Состояние входов/выходов
Значение таймеров (T - память)
Символьные адреса
Состояние питания: включено/выключено
Когда Вы открываете имитатор ПЛК, независимо от того, новый ли это имитатор или
сохраненный, имитатор ПЛК находится в режиме STOP.
Если Вы сохранили имитатор ПЛК в режиме RUN или RUN-P, когда Вы его откроете, в
окне видимого объекта будет сохранен ваш выбор, но индикатор ЦПУ покажет режим
STOP. Для того, чтобы перевести имитатор ПЛК в режим RUN или RUN-P, Вы должны
использовать бокс выбора в видимом объекте CPU или команду меню Execute > Key
Switch Position (Выполнить > Положение переключателя режимов) для
переключения имитатора ПЛК от режима STOP к режимам RUN или RUN-P.
Если Вы присоединили символику, когда сохраняли имитатор ПЛК, сохранятся
символьные адреса. Однако, значение по умолчанию, когда Вы откроете имитатор, не
покажет символьных адресов. Для того, чтобы показать символьные адреса, используйте
команду меню Tools > Options > Show Symbols (Инструменты > Опции > Показать
символику).
Для того, чтобы сохранить конфигурацию видимых объектов, используйте команду меню
File > Save Layout (Файл > Сохранить компоновку).
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Закрытие имитируемого ПЛК
Выберите команду меню File > Close PLC (Файл > Закрыть ПЛК) , чтобы закончить
имитацию программы. Эта команда закрывает видимый объект CPU и все открытые
видимые объекты.
Закрытие программы имитатора может вызвать ошибку в приложениях, которые на
данный момент соединены с имитатором. Закрытие имитируемого ПЛК не заканчивает
сессию имитации. Вы можете либо выйти из  S7-PLCSIM, либо открыть другой
имитируемый ПЛК.

Окончание работы имитатора
После сохранения любого имитатора ПЛК или конфигурации, следует проделать
следующие шаги для выхода из S7-PLCSIM:
1. Закройте все STEP 7 программы, вовлеченные в имитацию.
2. Выберите команду меню File > Exit (Файл > Выйти).
Выход из S7-PLCSIM, подобно закрытию имитатора ПЛК, может привести к  ошибкам в
приложениях, подключенных к имитатору.
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Видимые объекты
Видимые объекты S7-PLCSIM
S7-PLCSIM предусматривает ряд видимых объектов, которые позволяют Вам наблюдать
и модифицировать  различные компоненты имитируемого ПЛК. Это следующие видимые
объекты:
CPU (ЦПУ)
ACCUs & Status Word (Аккумуляторы и слово состояния)
Block Regs (Регистры блоков данных)
Stacks (Стеки)
Input Variable (Входные переменные)
Output Variable (Выходные переменные)
Bit Memory (Меркеры)
Timers (Таймеры)
Counters (Счетчики)
Generic Variable (Обобщенные переменные)
Vertical Bits Variable (Вертикальные биты)
Вы можете использовать в видимых объектах символическую адресацию. Если она
используется, для всех полей видимых объектов доступны всплывающие боксы
подсказок, которым назначены символы. Вы можете указывать на поле видимого объекта
мышью, чтобы увидеть ее символический адрес и комментарий (отделенный двоеточием)
в боксе подсказок.
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Видимый объект «CPU (ЦПУ)»
Этот видимый объект представлен, по умолчанию, когда Вы открываете новый имитатор.
Этот видимый объект позволяет Вам просматривать состояние и изменять рабочий
режим имитатора ЦПУ. Управление рабочим режимом ЦПУ на видимом объекте похожа
на действие переключателя режимов на реальном ЦПУ: если Вы используете
инструменты STEP 7 для изменения рабочего режима, или если режим изменяется
автоматически, например, при ошибках, послуживших причиной перехода ЦПУ из RUN в
STOP, изменится индикатор RUN/STOP, но не положение переключателя. Вас должно
беспокоить изменение рабочего режима, возможно в программе имеется ошибка. Кнопка
«MRES» позволяет Вам сбросить память и удалить блоки имитатора ПЛК.

Видимый объект «ACCUs & Status Word»
Для того, чтобы добавить видимый объект к имитатору, проделайте следующее:
Выберите команду меню View > Accumulators (Вид > Аккумуляторы).

Нажмите на кнопку  CPU Accumulators (Аккумуляторы ЦПУ) 
Этот видимый объект позволяет Вам управлять информацией, которую ЦПУ использует
для выполнения программы:
Аккумуляторы: у Вас есть доступ к содержимому аккумуляторов ЦПУ. Видимый объект
показывает 4 аккумулятора, предоставляемых ЦПУ S7-400; программы для ЦПУ S7-300
используют только два аккумулятора.
Слово состояния: у Вас есть доступ к битам слова состояния.
Адресные регистры: у Вас есть доступ к содержимому двух адресных регистров (AR1 и
AR2). Эти адресные регистры используются для косвенной адресации данных.

Видимый объект «Block Regs (Регистры блоков)»
Для того, чтобы добавить видимый объект к имитатору, проделайте следующее:
Выберите команду меню View > Block Registers (Вид > Регистры блоков)

Нажмите на кнопку  Block Registers (Регистры блоков) 
От видимый объект позволяет Вам следить за содержащимся в регистрах блоков адресах
открытых блоков данных (DB1 и DB2). Он также показывает номер текущего и
предыдущего логических блоков, с номером инструкции (пошаговый адресный счетчик,
или SAC) для каждого блока.

Видимый объект «Stacks (Стеки)»
Для того, чтобы добавить этот видимый объект в имитатор, проделайте следующее:
Выберите команду меню View > Stacks (Вид > Стеки)

Нажмите кнопку Nesting Stacks (Вложенные стеки) 
Этот видимый объект позволяет Вам управлять информацией, которая хранится в
следующих стеках ЦПУ:
Аппаратный стек имеет семь входов. Для каждого входа аппаратный стек хранит режим
RLO и бит OR слова состояния. Ввод в аппаратный стек делается для каждой инструкции,
которая начинается новой логической строкой. Такая инструкция: И (A), И-НЕ (AN), ИЛИ
(O), ИЛИ-НЕ (ON), Исключающее ИЛИ (X) и Исключающее ИЛИ - НЕ (XN).
MCR стек имеет восемь уровней вложения для команды группового реле (MCR). Каждый
уровень показывает статус RLO бита для MCR (инструкция, которая открывает  область
MCR).
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Видимый объект «Input Variable (Входная переменная)»
Для того, чтобы добавить этот видимый объект в имитатор, проделайте следующее:
Выберите команду меню Insert > Input Variable (Вставить > Входная переменная).

Нажмите на кнопку  Insert Input Variable (Вставить входную переменную) . Этот
видимый объект позволяет Вам наблюдать и изменять следующие данные:
Периферийные входные переменные: у Вас есть доступ к периферийному входу (PI)
области памяти ЦПУ.
Переменные области отображения входов: у Вас есть доступ к области отображения
входов (I) памяти ЦПУ. ЦПУ перепишет периферийные переменные PI в область
отображения входов I в начале каждого цикла. Если Вы измените величину памяти I,
имитатор немедленно скопирует измененную величину в периферийную область. Таким
образом, изменения не потеряются, когда периферийная величина перепишется на
следующем цикле.
ЦПУ немедленно реагирует на любые изменения, сделанные в видимом объекте. (Любые
изменения, сделанные с помощью таблицы переменных в STEP 7, дают эффект
правильного времени в ЦПУ: входы читаются в начале цикла и выходы переписываются в
конце.)

Видимый объект «Output Variable (Выходная переменная)»
Для того, чтобы добавить этот видимый объект в имитатор, проделайте следующее:
Выберите команду меню  Insert > Output Variable (Вставить > Выходная переменная)

Нажмите кнопку Insert Output Variable (Вставить выходную переменную) .
Этот видимый объект позволяет Вам следить и исправлять следующие данные:
Периферийные (внешние) переменные выхода: у Вас есть доступ к периферийным
выходам (PQ) области памяти ЦПУ.
Переменные области отображения выходов процесса: у Вас есть доступ к области
отображения выходов (Q) памяти ЦПУ. В течение рабочего цикла, программа вычисляет
выходные переменные и помещает их в область от отображения выходов процесса. В
конце рабочего цикла, оперативная система прочитает вычисленные выходные величины
из этой области и перешлет их на управляющие выходы. Область отображения выходов
процесса отображает первые 512 байт периферийной памяти выходов.
ЦПУ немедленно реагирует на любые изменения, сделанные в видимом объекте. (Любые
изменения, сделанные с помощью таблицы переменных STEP 7, дают правильный
эффект времени в ЦПУ: входы читаются в начале цикла и выходы переписываются в
конце.)
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Видимый объект «Bit Memory (Меркеры)»
Для доступа к видимому объекту проделайте следующие действия:
Выберите команду меню Insert > Bit Memory (Вставить > Меркеры)

Нажмите кнопку Insert Bit Memory (Вставить меркеры) 
Этот видимый объект позволяет Вам наблюдать за меркерами и управлять ими: у Вас
есть доступ к хранению переменных в области меркеров (M) ЦПУ.
Область меркеров (M) обеспечивает хранение промежуточных результатов, вычисляемых
программой. Вы определяете, формат доступа к данным.
Вы можете выбрать числовой формат данных меркеров, а также использовать
символическую адресацию, если Вы присоединяете к имитатору символику. Вы также
можете наблюдать меркеры в вертикальном виде.

Видимый объект «Timers (Таймеры)»
Для того, чтобы добавить видимый объект к имитатору, проделайте следующее:
Выберите команду меню Insert > Timer (Вставить > Таймеры)

Нажмите кнопку Insert Timer (Вставить таймеры) 
Этот видимый объект позволяет Вам наблюдать и изменять таймеры, используемые
программой. Видимый объект «Таймер» показывает имя таймера, текущую величину
времени и базу таймера.

Замечание
Если Вы изменяете временную базу, текущее значение таймера также изменяется, в то
время как показанное значение остается прежним. Причина в том, что фактическое
значение таймера – произведение показанной величины и базы времени. Например, если
показание таймера T 0 - 600, а база времени – 10  мс, это представляет 6 секунд. Если
Вы изменяете основу времени на 100 мс, то фактическое значение таймера  становится
60 секунд (600 * 100 мс = 60 секунд).
Сбросите все таймеры Вашей программы, используя кнопку на панели инструментов

Reset Timers (Сбросить таймеры) .
Сбросьте отдельный таймер, используя кнопку Reset Timers (Сбросить таймеры) на

видимом объекте таймера .
Вы можете использовать символическую адресацию, если присоедините символику.
Кроме того, Вы можете сконфигурировать таймеры на автоматическое и ручное
исполнение через команды меню Execute (Выполнить).

Видимый объект «Counter (Счетчик)»
Для того, чтобы добавить видимый объект к имитатору, проделайте следующее:
Выберите команду меню Insert > Counter (Вставить > Счетчик)

Нажмите кнопку Insert Counter (Вставить счетчик)  (или  в мнемонике SIMATIC)
Этот видимый объект позволяет следить и изменять счетчики, используемые Вашей
программой. Он открывается, по умолчанию, как C 0.
Вы можете выбрать числовой формат счетчика, а также Вы можете использовать
символическую адресацию, если Вы подключаете к имитатору символику.
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Видимый объект «Обобщенная переменная (Generic
Variable)»
Для того, чтобы добавить этот видимый объект к имитатору, проделайте следующее:
Выберите команду меню Insert > Generic (Вставить > Обобщенная переменная)

Нажмите кнопку Insert Generic Variable (Вставить обобщенную переменную) 

Этот видимый объект позволяет Вам следить и изменять следующие данные:
Периферийные (внешние) переменные входа и выхода: у Вас есть доступ к
периферийным областям памяти входов (PI) и выходов (PQ) ЦПУ.
Области отображения входов и выходов: у Вас есть доступ к областям отображения
входов (I) и выходов (Q) ЦПУ. ЦПУ перепишет память PI в память I в начале каждого
цикла. Если Вы измените переменную памяти I, имитатор немедленно сделает копию в
периферийную область. Таким образом, изменения не пропадут, когда периферийная
величина перепишется в область отображения входов при следующем цикле.
Меркеры: у Вас есть доступ к переменным, которые хранятся в области меркеров (M)
ЦПУ.
Таймеры и счетчики: у Вас есть доступ к таймерам и счетчикам, используемым
программой.
Блоки данных: у Вас есть доступ к данным, которые хранятся в блоках данных
программы.
ЦПУ немедленно реагирует на любые изменения, сделанные в просматриваемом
объекте. Любые изменения, сделанные с помощью таблицы переменных STEP 7, дают
правильный эффект времени в ЦПУ: входы читаются в начале цикла и выходы
переписываются в конце.
Вы можете выбрать числовой формат данных для обобщенной переменной, а также
использовать символическую адресацию, если к имитатору присоединена символика.
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Видимый объект  «Vertical Bits (вертикальные биты)»
Для того, чтобы добавить видимый объект к имитатору, проделайте следующее:
Выберите команду меню Insert > Vertical Bits (Вставить > Вертикальные биты)
Нажмите кнопку Insert Vertical Bits (Вставить вертикальные биты)
Видимый объект вертикальные биты позволяет Вам видеть символические и абсолютные
адреса каждого бита, наблюдать и изменять следующие данные:
Периферийные (внешние) переменные входа и выхода: у Вас есть доступ к
периферийным областям памяти входов (PI) и выходов (PQ) ЦПУ.
Области отображения входов и выходов: у Вас есть доступ к областям отображения
входов (I) и выходов (Q) ЦПУ. ЦПУ перепишет память PI в память I в начале каждого
цикла. Если Вы измените переменную памяти I, имитатор немедленно сделает копию в
периферийную область. Таким образом, изменения не пропадут, когда периферийная
величина перепишется в область отображения входов при следующем цикле.
Меркеры: у Вас есть доступ к переменным, которые хранятся в области меркеров (M)
ЦПУ.
Блоки данных: у Вас есть доступ к данным, которые хранятся в блоках данных
программы.
ЦПУ немедленно реагирует на любые изменения, сделанные в просматриваемом
объекте. Любые изменения, сделанные с помощью таблицы переменных STEP 7, дают
правильный эффект времени в ЦПУ: входы читаются в начале цикла и выходы
переписываются в конце. Вы можете использовать символическую адресацию, если к
имитатору присоединена символика.
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OB ошибок и прерываний
Обзор
S7-PLCSIM поддерживает следующее OB ошибок и прерываний:
от OB40 до OB47 (аппаратные прерывания)
OB70 (ошибка резервирования входов/выходов) {только для 417-H}
OB72 (ошибка резервирования ЦПУ) {только для 417-H}
OB73 (ошибка резервирования коммуникаций) {только для 417-H}
OB80 (временная ошибка)
OB82 (диагностическое прерывание)
OB83 (вставка/удаление модуля)
OB85 (ошибка класса приоритета)
OB86 (неисправность носителя модулей)
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Аппаратное прерывание (OB40-OB47)
Это окно диалога позволяет Вам проверить загруженные Вами в программу OB от OB40
до OB47.
Заметьте, что до доступа к этому OB (команда меню Execute > Trigger Error OB > I/O
Redundancy Error (OB70)...(Выполнить > Включение OB ошибок > Ошибка
резервирования входов/выходов (OB70)…)), Вы должны выполнить необходимую
модификацию Вашей аппаратной конфигурации и загрузить Вашу  конфигурацию
входов/выходов.
Параметры, которые Вы выбрали  в окне диалога, посылаются следующим переменным,
при вызове OB:
Параметр Переменная Тип данных Описание
Адрес модуля OB4x_MDL_ADDR WORD Логический базовый адрес

модуля, включающего
прерывание: первый вход,
или любой; в ином случае,
первый  адрес выхода.
Пример: PIB 0

Статус модуля OB4x_POINT_ADDR DWORD
(Hex)

Для цифровых модулей
набор битов с состояниями
входов модуля. (бит 0
соответствует первому
входу).
Для аналоговых модулей,
CP или IM: статус
прерывания модуля.
Пример: 00A21234

OB прерывания
(только для
чтения)

OB4x_OB_NUMBR BYTE Номер OB (от 40 до 47).

Для более подробной информации, смотрите:
STEP 7 Помощь по организационным блокам OB4-OB47 (Help STEP 7)
Simatic S7. Системные и стандартные функции для S7-300 и S7-400. Справочное
руководство.
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Ошибка резервирования вход/выходов (OB70)
Это диалоговое окно позволяет Вам проверять ошибки резервирования PROFIBUS-DP и
может быть использовано только для ЦПУ H-системы.
Заметьте, что до доступа к этому OB (команда меню Execute > Trigger Error OB > I/O
Redundancy Error (OB70)...(Выполнить > Включение OB ошибок > Ошибка
резервирования входов/выходов (OB70)…)), Вы должны выполнить необходимую
модификацию Вашей аппаратной конфигурации и загрузить Вашу  конфигурацию
входов/выходов.
Параметры, которые Вы выбрали в окне диалога, передаются следующим переменным
при вызове OB:
Параметр
(Вход/Выход)

Переменная Тип
данных

Описание

Класс события OB70_EV_CLASS BYTE Коды классов событий:
B#16#72: приходящее событие
B#16#73: уходящее событие

Код ошибки OB70_FLT_ID BYTE Код ошибки (возможные значения):
B#16#A2
B#16#A3

Вы должны также ввести значения для DP Master Base Address (базовый адрес мастера
DP), DP Master System ID (номер мастер-системы DP), DP Slave Base Address (базовый
адрес DP-Slave’а) и DP Station Number (номер станции DP) .Каждое поле требует
совпадения с величинами, присвоенными в аппаратной конфигурации проекта STEP 7,
который Вы имитируете.
DP Slave Base Address (базовый адрес DP-Slave’а), DP Station Number (номер станции
DP) и выбор входов/выходов доступны только при кодах ошибки 0xA3.
Для более подробной информации, смотрите:
STEP 7 Помощь по организационным блокам OB70 (Help STEP 7)
Simatic S7. Системные и стандартные функции для S7-300 и S7-400. Справочное
руководство.
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Ошибка резервирования ЦПУ (OB72)
Коды ошибки OB72_FLT_ID показывают, какая ошибка вызвала OB72:

OB72_FLT_ID Стартовое событие OB72
B#16#01 Потеря резервирования (1 из 2) вследствие запуска ЦПУ
B#16#02  Потеря резервирования (1 из 2) вследствие перехода в STOP в резерве,

запущенном пользователем
B#16#03 H-система (1 из 2) переключилась в резервный режим
B#16#20 Ошибка при сравнении RAM
B#16#21 Ошибка при сравнении выходного значения образа процесса
B#16#22 Ошибка при сравнении битов памяти, таймеров или счетчиков
B#16#31 Переключение на резервное master-устройство вследствие отказа

master-устройства
B#16#33 Переключение на резервное master-устройство вследствие

вмешательства оператора
B#16#34 Переключение на резервное master-устройство вследствие проблемы

соединения
B#16#35 Переключение на резервное master-устройство, запущенное SFC90

"H_CTRL".
B#16#40 Ошибка синхронизации в программе пользователя из-за истекшего

времени ожидания
B#16#41 Ошибка синхронизации в программе пользователя из-за ожидания в

различных точках синхронизации
B#16#42 Ошибка синхронизации в операционной системе из-за ожидания в

различных точках синхронизации
B#16#43 Ошибка синхронизации в операционной системе из-за истекшего времени

ожидания
B#16#50 Нет модуля синхронизации (SYNC)
B#16#51 Изменение в модуле синхронизации без включения питания
B#16#52 Модуль синхронизации удален/вставлен
B#16#53 Изменение в модуле синхронизации без сброса
B#16#54 Модуль синхронизации: номер стойки назначен дважды
B#16#55 Ошибка модуля синхронизации/устранена
B#16#56 В модуле синхронизации установлен запрещенный номер стойки
B#16#C1 Прерывание обновления
B#16#C2 Прерывание попытки обновления, потому что время мониторинга

было превышено во время n-й попытки (1 <= n <= максимально
возможный количества попыток обновления, после прерывания
из-за того, что время мониторинга было превышено)

Для более подробной информации, смотрите:
STEP 7 Помощь по организационным блокам OB72 (Help STEP 7)
Simatic S7. Системные и стандартные функции для S7-300 и S7-400. Справочное
руководство.
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Ошибка резервирования связи (OB73)
Это окно диалога позволяет Вам проверять, когда впервые теряется резерв в
отказоустойчивой связи S7 и существует только для H CPU .
Заметьте, что для доступа к этому окну (команда меню Execute > Trigger Error OB >
Communication Redundancy Error (OB73)...), Вы сначала должны выполнить
необходимую модификацию Вашей конфигурации и загрузить Вашу конфигурацию
входов/выходов.
Параметры, которые Вы выбрали в окне диалога, будут переданы следующим
переменным, когда OB вызван:

Для более подробной информации, смотрите:
STEP 7 Помощь по организационным блокам OB73 (Help STEP 7)
Simatic S7. Системные и стандартные функции для S7-300 и S7-400. Справочное
руководство

Параметр Переменная Тип данных Описание
Error Event Class
(Класс события)

OB73_EV_CLASS BYTE Возможные величины
B#16#73 (потеря
избыточности в связи) или
B#16#72 (проблема
исключения)

Error Code
(Код ошибки)

OB_73_FLT_ID BYTE Возможная величина
B#16#E0
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Временная ошибка (OB80)
Это окно диалога позволяет Вам проверять программу, которую Вы загрузили в OB80
(ошибка времени). Параметры, которые Вы выбрали в этом окне, будет посланы
следующим переменным, когда вызван OB:
Параметр Переменная  Тип данных Описание
Cycle time exceeded
(Превышение
времени цикла )

OB80_FLT_ID BYTE Код ошибки:
B#16#05

Requested OB is still
being processed
(Затребованный OB
еще исполняется.)

OB80_FLT_ID BYTE Код ошибки:
B#16#02

OB call buffer overflow
for the current priority
class (Переполнение
буфера вызовов OB
для текущего класса
приоритета)

OB80_FLT_ID BYTE Код ошибки:
B#16#07

Expired time of day
interrupt:
- Due to a time jump

- On return in to run
after hold
( Просрочено
прерывание по
времени дня:
-Из-за скачка
времени
- Возвращение к
выполнению после
останова)

OB80_FLT_ID

OB80_FLT_ID

BYTE

BYTE

Код ошибки:
B#16#05
Код ошибки:
B#16#06

 Для более подробной информации, смотрите:
STEP 7 Помощь по организационным блокам OB80 (Help STEP 7)
Simatic S7. Системные и стандартные функции для S7-300 и S7-400. Справочное
руководство
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Диагностическое прерывание (OB82)
Это окно диалога позволяет Вам проверять программу, которую Вы загрузили в OB82
(диагностическое прерывание).
Заметьте, что для доступа к этому окну (команда меню Execute >Trigger Error OB >
Diagnostic Interrupt (OB82)...), Вы должны сначала выполнить некоторую модификацию
Вашей конфигурации оборудования и загрузить Вашу конфигурацию входов/выходов.
Тесты по умолчанию: (необязательно) в этом боксе, выберите из выпадающего списка
установки условий неисправности для автоматического теста.
Для всех условий неисправности класс событий (OB82_EV_CLASS) устанавливается в
B#16#39 (приходящее события) а OB82_FLT_ID, использует код ошибки B#16#42. Если не
будут выбраны условия ошибки (модуль исправен), класс событий установлен в B#16#38
(уходящие события).
Параметры, которые Вы выбрали в окне, будут посланы следующим переменным, когда
вызван OB :

Адрес модуля
Адрес модуля – логический базовый адрес модуля, включающего прерывание. Это адрес
его первого входа, если не оговорено иначе, в противном случае это первый выход.
(Пример: PIB0).
Параметр Переменная Тип данных
Адрес модуля OB82_MDL_ADDR INT
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Условия ошибок
Module defect (read-only) (Дефект модуля
(только чтение))

OB82_MDL_DEFECT BOOL

Internal fault (Внутренняя неисправность) OB82_INT_FAULT BOOL
External fault (Внешняя неисправность) OB80_EXT_FAULT BOOL
Channel fault (Неисправность канала) OB82_PNT_INFO BOOL
External voltage failed (Падение внешнего
напряжения)

OB82_EXT_VOLTAGE BOOL

Front panel connector unplugged (Не вставлен
фронт –штекер)

OB82_FLD_CONNCTR BOOL

Module not configured (Модуль не
сконфигурирован)

OB82_NO_CONFIG BOOL

Incorrect parameters on module (Неправильные
параметры модуля)

OB82_CONFIG_ERR BOOL

Channel information exists (Информация канала) OB82_MDL_TYPE BYTE
User information exists (Информация
пользователя)

OB82_MDL_TYPE BYTE

Diagnostic interrupt from substitute
(Диагностическое прерывание от субмодуля)

OB82_MDL_TYPE BYTE

Submodule missing or has an error (Субмодуль
отсутствует или неисправен)

OB82_SUB_MDL_FAULT BOOL

Communication problem (Проблемы связи) OB82_COMM_FAULT BOOL
Operating mode is STOP (Рабочий режим – СТОП) OB82_MDL_STOP BOOL
Watchdog timer responded (Сработал контроль
времени)

OB82_WTCH_DOG_FLT BOOL

Internal power supply failed (Отказ внутреннего
источника питания)

OB82_INT_PS_FLT BOOL

Battery exhausted (Разрядилась батарея) OB82_PRIM_BATT_FLT BOOL
Entire backup failed (Выход из строя всего
резервирования)

OB82_BCKUP_BATT_FLT BOOL

Expansion rack failure (Выход из строя стойки
расширения)

OB82_RACK_FLT BOOL

Processor failure (Выход из строя процессора) OB82_PROC_FLT BOOL
EPROM fault (Сбой СППЗУ) OB82_EPROM_FLT BOOL
RAM fault (Сбой ОЗУ) OB82_RAM_FLT BOOL
ADC/DAC error (Ошибка АЦП /) OB82_ADU_FLT BOOL
Fuse tripped (Выход из строя плавкого
предохранителя)

OB82_FUSE_FLT BOOL

Hardware interrupt lost (Потеряно аппаратное
прерывание)

OB82_HW_INTR_FLT BOOL

Для более подробной информации, смотрите:
STEP 7 Помощь по организационным блокам OB82 (Help STEP 7)
Simatic S7. Системные и стандартные функции для S7-300 и S7-400. Справочное
руководство



 ОВ ошибок и прерываний

S7–PLCSIM
C79000–G7000–C201–02

45

Прерывание при вставке/удалении модуля (OB83)
Это окно диалога позволяет Вам проверять программу, которую Вы загрузили в OB83
(Прерывание при вставке/удалении модуля).
Заметьте, что для доступа к этому окну (команда меню Execute >Trigger Error OB >
Insert/Remove Module Interrupt (OB83)...), Вы должны сначала загрузить сделать
некоторые изменения конфигурации Вашего оборудования  Вашу конфигурацию
входов/выходов.
Для всех условий неисправности класс событий (OB83_EV_CLASS) установлен в B#16#39
(приходящие события). Если условия ошибки не будут выбраны (Module OK – модуль
исправен), класс события установится в B#16#38 (уходящее событие).
Параметры, которые Вы выбрали в окне, будут переданы следующим переменным при
вызове OB :
Параметр Переменная Тип

данных
Переменная /
Описание

Module removed or not responding
(Модуль удален или не отвечает)

OB83_FLT_ID BYTE B#16#61

Module inserted:
module type OK (Модуль вставлен:
Тип модуля OK)

OB83_FLT_ID BYTE B#16#61

Module inserted:
incorrect module type
(Модуль вставлен:
Неправильный тип модуля)

OB83_FLT_ID BYTE B#16#63

Module inserted:
ID cannot be read
(Модуль вставлен:
ID не читается)

OB83_FLT_ID BYTE B#16#64

Module inserted:
in module parameter
assignment
(Модуль вставлен:
ошибка в назначении
параметров модуля )

OB83_FLT_ID BYTE B#16#65

Module address
(Адрес модуля)

OB83_MDL_ADDR WORD Логический базо-
вый адрес модуля,
который включил
прерывание: пер-
вый вход, или дру-
гой, если указано; в
ином случае,
первый адрес
выхода.
Пример: PQW 0

Для более подробной информации, смотрите:
STEP 7 Помощь по организационным блокам OB83 (Help STEP 7)
Simatic S7. Системные и стандартные функции для S7-300 и S7-400. Справочное
руководство
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Ошибка класса приоритета (OB85)
Это окно диалога позволяет Вам проверять программу, которую Вы загрузили в OB85
(ошибка класса приоритета). OB85 автоматически включается, когда возникает ошибка,
если операционная система поддерживает блок (код ошибки B#16#A3).
Заметьте, что события B#16#A1, B#16#A2, B#16#B1 и B#16#B2 должны генерироваться
другими средствами; например, удалением одного из блоков Вашей программы.
Параметры, которые Вы выбрали в окне диалога, будут посланы следующим
переменным, когда вызван OB :
Параметр Переменная Тип

данных
Значение

Integrated function
(Встроенная функция):
No error resolution
(Нет сообщения об ошибке)
Block not loaded
(Блок не загружен)
Area length error
(Ошибка размера области)
Write protect error
(Ошибка в связи с защитой от записи)

OB85_Z1 WORD

W#16#0100

W#16#0101

W#16#0102

W#16#0103
IEC timer (IEC таймер):
No error resolution
(Нет сообщения об ошибке)
Block not loaded
(Блок не читается)
Area length error
(Ошибка длины области)
Write protect error
(Ошибка в связи с защитой от записи)

OB85_Z1 WORD
W#16#0200

W#16#0201

W#16#0202

W#16#0203
Для более подробной информации, смотрите:
STEP 7 Помощь по организационному блоку OB85 (Help STEP 7)
Simatic S7. Системные и стандартные функции для S7-300 и S7-400. Справочное
руководство
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Неисправность стойки (OB86)
Это окно диалога позволяет Вам проверять программу, загруженную в OB86
(Неисправность стойки).
Заметьте, что для доступа к этому окну (команда меню Execute > Trigger Error OB >
Rack Failure (OB86)...), Вы должны сначала сделать некоторые изменения Вашей
конфигурации аппаратуры и загрузить Вашу конфигурацию входов/выходов. (Смотрите
Загрузку системных данных в S7-PLCSIM.)
Для всех условий неисправности класс событий (OB86_EV_CLASS) установится в
B#16#39 (приходящие события). Если условия ошибок не будут выбраны (Rack Return,
Rack Return with Discrepancy, DP Station Return и DP Station OK), класс событий
установится в B#16#38 (уходящие).
Две таблицы в окне диалога обеспечивают следующие возможности:

Таблица неисправностей стойки расширения
Параметры, которые Вы выбрали в этой таблице, будут переданы следующим
переменным при вызове OB:
Параметр Переменная Тип

данных
Значение

IM address (Адрес
интерфейсного модуля)

OB86_MDL_ADDR WORD Адрес интерфейсного
модуля, к которому
подключена стойка
расширения.

Failure (Неисправность) OB86_FLT_ID BYTE B#16#C1
Return (Возврат) OB86_FLT_ID BYTE B#16#C1
Return with discrepancy
(Возврат с расхождениями)

OB86_FLT_ID BYTE B#16#C2

Operational again but
Error (Восстановление
стойки расширения, но
ошибка при
назначении параметров
модуля)

OB86_FLT_ID BYTE B#16#C6

Rack Status (Состояние
стойки)

OB86_RACKS_FLTD ARRAY
OF
BOOL

Показывает состояние
21 стойки расширения,
соединенной с интер-
фейсным модулем. В
массиве Вы должны
выбрать стойку с
нужными условиями.
Green = исправно
Red = ошибка
Gray = не
сконфигурировано
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Таблица DP неисправностей
Эта таблица позволяет Вам проверять системные неисправности DP и увидеть состояние
DP при различных условиях ошибок. Параметры, которые Вы выбрали в этой таблице,
будут при вызове OB переданы следующим переменным:
Параметр Переменная Тип

данных
Значение

Subnet (Подсеть) OB86_MDL_ADDR WORD Логический базовый
адрес мастера DP
системы.

Failure of DP master system
(Неисправность мастера DP
системы)

OB86_FLT_ID BYTE B#16#C3

Station failure (Неисправность
станции)

OB86_FLT_ID BYTE B#16#C4

Station fault (Сбой станции) OB86_FLT_ID BYTE B#16#C5

Station return (Возвращение
станции)

OB86_FLT_ID BYTE B#16#C4

Station OK (Станция исправна) OB86_FLT_ID BYTE B#16#C5
Station operational
again but error (Станция
восстановлена, но имеется
ошибка)

OB86_FLT_ID BYTE B#16#C7

Station return with
Discrepancy (Станция
восстановлена с
несоответствиями)

OB86_FLT_ID BYTE B#16#C8

Status DP (Состояние DP) OB86_FLT_ID ARRAY
OF
BOOL

Показывает состояние
126 DP станций. В этом
массиве Вы должны
выбрать rack с
нужными условиями.
Green = Good
Red = Fault
Gray = Not configured

Для более подробной информации, смотрите:
STEP 7 Помощь по организационному блоку OB86 (Help STEP 7)
Simatic S7. Системные и стандартные функции для S7-300 и S7-400. Справочное
руководство
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Справочные данные
Панели инструментов S7-PLCSIM
S7-PLCSIM имеет панели инструментов, изображенные ниже. Чтобы скрыть или показать
любую панель можно использовать команду View > Toolbars (Вид > Панели
инструментов). Чтобы получить контекстную помощь щелкните на любую кнопку из
любой следующей панели инструментов или справьтесь в соответствующем пункте меню.
Standard (Стандартная)
Стандартная панель инструментов содержит отдельные команды из меню Файл,
Редактор, Вид и Окно, также как помощь типа «Что это?».

Insert (Вставка)
Панель инструментов Insert (Вставка) содержит отдельные команды из меню вставки и
меню View (Вид)

CPU mode (режим ЦПУ)
Панель инструментов режима ЦПУ содержит отдельные команды из меню Execute
(Выполнить).

Record/Playback (Запись/Воспроизведение)
Кнопка панели инструментов Record/Playback (Запись/Воспроизведение)
файлов также доступна из меню Tools (Инструменты).

Клавиши быстрого доступа
Вы можете переключить вид любой из этих панелей инструментов, одновременно
нажимая клавишу Alt и функциональную клавишу. Доступны следующие комбинации
быстрого доступа.
ALT +  F1  переключает отображение панели инструментов Standard (стандартной).
ALT +  F2 переключает отображение панели инструментов Insert (вставки)
ALT +  F3 переключает вид панели инструментов CPU Mode (Режим ЦПУ)
ALT +  F4 закрывает S7-PLCSIM/
ALT +  F5 переключает вид панели инструментов Record/Playback
(Запись/Воспроизведение).
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Меню S7-PLCSIM
S7-PLCSIM включает следующие меню для исполнения операций с имитируемым ПЛК

•  File (Файл)
•  Edit (Правка)
•  View (Вид)
•  Insert (Вставка)
•  PLC (ПЛК – программируемый логический контроллер)
•  Execute (Исполнение)
•  Tools (Инструменты)
•  Window (Окно)
•  Help (Помощь)
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Меню File (Файл)

Команда New PLC (Новый ПЛК )

Нажмите на  или выберите команду меню File > New PLC (Файл > Новый ПЛК) для
создания нового имитатора ПЛК.

Команда Open PLC (Открыть ПЛК)
Для того, чтобы найти и открыть существующий (сохраненный) имитатор ПЛК, нажмите на

 или выберите команду меню File > Open PLC.... (Файл > Открыть ПЛК)

Команда Close PLC (Закрыть ПЛК)
Выберите команду меню File > Close PLC (Файл > Закрыть ПЛК) для того, чтобы
закрыть текущий открытый имитатор ПЛК. Эта команда закрывает видимый объект CPU и
все открытые видимые объекты.
Закрытие имитатора вызывает ошибку в приложениях, которые в данный момент
подключены к нему.

Команда Save PLC (Сохранить ПЛК)

Нажмите на  или выберите команду меню File > Save PLC (Файл > Сохранить ПЛК)
для сохранения текущего состояния имитатора ПЛК.

Команда Save PLC As …(Сохранить ПЛК как …)
Нажмите на или выберите команду меню File > Save PLC As …(Файл > Сохранить ПЛК
как…)для сохранения текущего состояния имитатора ПЛК в новом файле.

Команда Open Layout (Открыть компоновку)
Чтобы открыть ранее сохраненную в S7-PLCSIM компоновку видимых объектов, выберите
команду меню File > Open Layout.... (Файл > Открыть компоновку)
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Команда Close Layout (Закрыть компоновку)
Для того, чтобы закрыть текущую компоновку видимых объектов S7-PLCSIM, выберите
команду меню File > Close Layout (Файл > Закрыть компоновку).

Команда Save Layout (Сохранить компоновку)
Для сохранения текущего компоновки видимых объектов S7-PLCSIM, выберите команду
меню File > Save Layout (Файл > Сохранить компоновку).

Команда Save Layout As …  (Сохранить компоновку как …)
Для сохранения текущего компоновки видимых объектов S7-PLCSIM под новым именем,
выберите команду меню File > Save Layout (Файл > Сохранить компоновку как…).

Команда Recent Simulation (Последние имитации)
Используйте команду меню File > Recent Simulation (Файл > Последние имитации) для
вывода списка из четырех последних используемых программ. Выберите файлы 1, 2, 3
или 4 из этого списка.

Команда Recent layout (Последние компоновки)
Используйте команду меню File > Recent Layout (Файл > Последние компоновки) для
вывода списка из четырех последних используемых программ. Выберите файлы 1, 2, 3
или 4 из этого списка.

Команда Exit (Выход)
Выберите команду меню File > Exit (Файл >  Выход) для того, чтобы закрыть имитатор
ПЛК  и выйти из приложения S7-PLCSIM.
Выход из S7-PLCSIM даст результат ошибки в приложениях, которые на данный момент
соединены с имитатором.
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Меню Edit (Правка)
Меню Edit (Правка) S7-PLCSIM содержит следующие команды:

Команда Undo (Отменить)
Чтобы отменить последнее выполненное действие выберите команду меню Edit > Undo
(Правка > Отменить). Команда Undo (отменить) применима только к редактируемым
полям типа текст/число и к командам меню Edit (Правка), Insert (Вставка), и Window
(Окно).
Команда Undo (Отменить) также доступна из меню, вызванного по правой кнопке мыши
для любого редактируемого текстового поля.

 Команда Cut (Вырезать)

Выберите команду Edit > Cut (Правка > Вырезать) или щелкните мышью на кнопку ,
чтобы удалить выбранный текст и поместить его в буфер обмена.

 Команда Copy (Копировать)

Выберите команду Edit > Copy (Правка > Копировать) или нажмите на кнопку  для
копирования выбранного текста и помещения его в буфер обмена.

 Команда Paste (Вставить)

Выберите команду Edit > Paste (Правка > Вставить) или нажмите на кнопку  для
вставки содержимого буфера (которое было перед этим туда вырезано или скопировано)
в место, указанное курсором.
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Меню View (Вид)
Меню View (Вид) S7-PLCSIM содержит следующие команды:

 Команда Accumulators Command

Выберите команду меню View > Accumulators (Вид > Аккумуляторы) или нажмите на 
для создания видимого объекта ACCUs & Status Word (Аккумуляторы и Слово состояние).
Этот видимый объект позволяет Вам наблюдать аккумуляторы, биты слова состояния и
адресные регистры.

 Команда Block Registers (Регистры блоков)
Выберите команду меню View > Block Registers (Вид > Регистры блоков) или нажмите на

  для создания видимого объекта Block Regs (Регистры блоков) чтобы иметь
возможность наблюдать содержание регистров адресации блоков данных (DB1 и DB2).
Этот визуальный объект показывает также номер текущего и предшествующего
логического блока, вместе с номером команды (счетчик адреса команды или SAC - step
address counter) для каждого блока.

 Команда Stacks (Стеки)

Выберите команду меню View > Stacks (Вид > Стеки) или нажмите на    для создания
видимого объекта Stacks (Стеки), чтобы иметь возможность  чтобы  иметь возможность
наблюдать аппаратный стека и стек команды MCR.

Команда Toolbars... (Палитры инструментов)
Выберите команду меню View > Toolbars... (Вид > Палитры инструментов…) для выбора
палитры инструментов S7-PLCSIM, которую Вы хотите отобразить. В диалоговом окне
панели инструментов, отметьте палитры, которые Вы хотите отобразить:
Standard (Стандартная)
Insert (Вставить)
CPU Mode (Режим ЦПУ)
Record/Playback Files (Запись/Воспроизведение файлов)

Команда Status Bar (Строка состояния)
Выберите команду меню View > Status Bar (Вид > Строка состояния) для переключения
включить/выключить строки состояния S7-PLCSIM. Строка состояния, как показано ниже,
появляется в нижней части окна S7-PLCSIM и содержит информацию и сообщения,
помогающие в использовании S7-PLCSIM.

Команда Always On Top (Всегда поверх)
Выберите команду меню View > Always On Top (Вид > Всегда поверх) или нажмите на

  для вывода окна S7-PLCSIM поверх окон  любых других выполняющихся
приложений. Повторите действие для возвращения S7-PLCSIM в нормальное состояние
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Меню Insert (Вставить)
Меню Insert (Вставить) S7-PLCSIM содержит следующие команды:

 Команда Input Variable (Входная переменная)
Нажмите на  или выберите команду меню Insert > Input Variable (Вставить >
Входная переменная) для создания видимом объекта  который позволяет Вам
наблюдать и изменять переменные в области памяти входов. Этот видимый объект
открывается по умолчанию с адресом  IB0.

Команда Output Variable (Выходная переменная)
Нажмите на  или выберите команду меню Insert > Output Variable (Вставить >
Выходная переменная) для создания видимого объекта, который позволяет Вам
наблюдать и модифицировать переменные в области памяти выходов (Q). Этот видимый
объект открывается по умолчанию с адресом QB0.

Команда Bit Memory (Меркер)
Нажмите на  или выберите команду меню Insert > Bit Memory (Вставить > Меркер)
для создания видимого объекта , который позволяет Вам наблюдать и модифицировать
переменные в области памяти меркеров (M). Этот видимый объект открывается по
умолчанию с адресом MB0.

Команда Timer (Таймер)

Нажмите на  или выберите команду меню Insert > Timer (Вставить > Таймер) для
создания видимого объекта, который позволяет Вам наблюдать и модифицировать
таймеры, используемые в программе. Этот видимый объект открывается по умолчанию с
адресом T0.

Команда Counter (Счетчик)

Нажмите на  (  - в немецкой мнемонике) или выберите команду меню Insert >
Counter (Вставить > Счетчик) для создания видимого объекта, который позволяет Вам
наблюдать и модифицировать счетчики, используемые в программе. Этот видимый
объект открывается по умолчанию с адресом C 0.

Команда Generic (Обобщенная переменная)

Нажмите на или выберите команду меню Insert > Generic (Вставить >  Обобщенная
переменная) для создания видимого объекта, который позволяет Вам наблюдать и
модифицировать любую переменную, используемую в программе, например в областях
памяти входов (I) или выходов (Q). Вы также можете получить доступ к данным,
хранящимся в блоках данных (DB).

Команда Vertical Bits (Вертикальные биты)

Нажмите на или выберите команду меню Insert > Vertical Bits (Вставить >
Вертикальные биты) для создания видимого объекта, показывающего  символические
или абсолютные адреса, следующие вертикально по одному биту и позволяющие Вам
наблюдать и модифицировать любые переменные используемые в программе, например
в областях памяти входов (I) или выходов (Q). Вы также можете получить доступ к
данным, хранящимся в блоках данных (DB).
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Меню PLC (ПЛК)
Меню S7-PLCSIM PLC (ПЛК) содержит следующие команды:

Команда Power On (Питание включено)
Выберите команду меню PLC > Power On (ПЛК > Питание включено) для имитации
включения питания на ПЛК.

Команда Power Off (Питание выключено)
Выберите команду меню PLC > Power Off (ПЛК > Питание выключено) для имитации
выключения питания на ПЛК

Команда Clear/Reset (Сброс памяти)
Выберите команду меню PLC > Clear/Reset (ПЛК > Сброс памяти) или нажмите кнопку
"MRES" на видимом объекте CPU, для удаления блоков, сброса памяти и удаления
конфигурации оборудования из имитируемого ПЛК.
Если Вы выполнили сброс памяти, CPU автоматически переходит в режим STOP.

Команда MPI Address... (Адрес MPI)
Выберите команду меню PLC > MPI Address... (ПЛК  > Адрес MPI) для изменения
сетевого адреса имитируемого ПЛК. Новый адрес сохранится в конфигурации
имитируемого ПЛК, после подачи команды Save PLC или Save PLC As... .
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Меню Execute (Выполнить)
Меню Execute (Выполнить) S7-PLCSIM содержит следующие команды

Команды переключателя режимов
Выберите команду меню Execute > Key Switch Position и установите имитируемый
режим работы ПЛК: RUN-P, RUN или STOP. Кроме того, Вы можете изменить режим
отметив соответствующий бокс выбора на видимом объекте CPU.

Команды переключателя типа рестарта
Выберите команду меню Execute > Startup Switch Position (Выполнить >
Переключатель типа рестарта) и установите свойства рестарта, которые Вы хотите
сымитировать при переходе из режима STOP в режим RUN:
Warm Start (Теплый рестарт) операционная система вызовет OB100;
Hot Start (Горячий рестарт) операционная система вызовет OB101;
Cold Start (Холодный рестарт) операционная система вызовет OB102.

Команды режима циклов
Вы можете выбрать один из двух вариантов выполнения имитирующей программы:
однократное или циклическое выполнение.

Команда Single Scan  (Однократное выполнение)

Нажмите на  или выберите команду меню Execute > Scan Mode > Single Scan
(Выполнить > Режим циклов > Однократное выполнение) для установки ЦПУ на
однократное выполнение программы. ЦПУ выполнит полную программу однократно,
затем будет ждать следующего цикла.

Команда Continuous Scan  (Циклическое выполнение)

Нажмите на  или выберите команду меню Execute > Scan Mode > Continuous Scan
(Выполнить > Режим циклов > Циклическое выполнение) для установки ЦПУ для
выполнения программой циклической работы (таким образом, чтобы OB1 выполнялось
ЦПУ). ЦПУ выполнит программу, когда рабочий режим будет RUN, и остановит при
режиме STOP.
Цикл начнется чтением периферийных входов (PI) и обновлением регистра отображения
входов (I).  ЦПУ выполнит инструкции программы и обновит области памяти. Цикл
завершится записью из регистра отображения выходов (Q) в память периферийных
выходов (PQ).

Команда Next Scan  (Следующий цикл)

Нажмите на  или выберите команду меню Execute > Next Scan (Выполнить >
Следующий цикл) для требования выполнения имитатором ЦПУ следующего цикла
(если имитатор установлен на однократное выполнение).

Команда Pause (Пауза)

Нажмите на  или выберите команду меню Execute > Pause (Выполнить > Пауза)
для того, чтобы моментально остановить выполнение программы в имитаторе ПЛК без
изменения данных (таких, как состояние выходов). Для  продолжения выполнения
программы отключите функцию Pause. Программа начнет свое действие с того места, где
была остановлена.
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Если приложение STEP 7 соединено с имитатором ПЛК, использование паузы может
привести к превышению времени в системе связи и к ее обрыву. Если это случилось,
выключите паузу и переустановите связь с приложением STEP7.
Команда Automatic Timers (Выполнить > Автоматические таймеры)
Выберите команду меню Execute > Automatic Timers (Выполнить > Автоматические
таймеры) для установки ЦПУ на автоматическое выполнение таймеров в программе.
Команда Manual Timers (Выполнить > Ручные таймеры)
Выберите команду меню Execute > Manual Timers (Выполнить > Ручные таймеры),
чтобы обеспечить Вам возможность ввода отдельных значений или сброса таймеров в
программе. Для того, чтобы вернуться к автоматическому выполнению выберите команду
Execute > Automatic Timers (Выполнить > Автоматические таймеры).

Команда Reset Timers… (Сбросить таймеры …)
Команда Execute > Reset Timers… (Выполнить > Сбросить таймеры …)
открывает диалоговое окно, позволяющее загрузить таймерные величины для любого
или всех таймеры, используемые программой как значения по умолчанию. Вы можете
сбросить все или отдельный таймеры программы.

Для перезагрузки всех таймеров Вашей программы используйте кнопку  на панели
инструментов Reset Timers.

Для перезагрузки конкретного таймера используйте кнопку  на видимом объекте для
таймера.

Команда Trigger Error OB (Включить OB прерываний)
Используйте команду меню Execute > Trigger Error OB (Выполнить > Включить OB
прерываний) для того, чтобы проверить, как Ваша программа поддерживает различные
OB прерываний.
Команда Scan Cycle Monitoring...(Наблюдение времени цикла)
Команда меню Execute > Scan Cycle Monitoring... … (Выполнить > Наблюдение
времени цикла) открывает диалоговое окно, позволяющее Вам разрешить или запретить
контроль времени цикла (таймер превышения времени цикла) и установить
максимальное время цикла (в миллисекундах) для имитации. Максимальное время цикла
это максимальное время одного полного цикла вычислений пользовательской программы
OB1 и обновления соответствующих входов/выходов. Если это время превышено,
имитатор ПЛК переходит в STOP.
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Меню Tools (Инструменты)
Меню S7-PLCSIM Tools (Инструменты) содержит следующие команды:

 Команда Record/Playback (Записать/Воспроизвести)

Нажмите на  или выберите команду Tools > Record/Playback (Инструменты >
Записать/Воспроизвести) для записи или воспроизведения последовательности событий.
Комбинация клавиш Alt + F5 включает отображение кнопки палитры инструментов
Record/Playback
(Записать/Воспроизвести).

Команда Options (Опции)
Меню команда Tools > Options включает следующие опции:
Attach Symbols (Присоединить символику... )...
Show Symbols  (Показать символы)
Reference Data (Справочные данные)
Symbol Table (Таблица символов)
Команда Attach Symbols (Присоединение символики... )
Выберите команду меню Tools > Options > Attach Symbols... (Инструменты > Опции >
Присоединить символику) для использования символьной адресации в Вашей
программе. Эта команда меню вызовет окно диалога, где Вы сможете выбрать таблицу
символов STEP 7.
Когда Вы выберете необходимые символику, Вы можете использовать опции
Show Symbols, > Reference Data и Symbol Table.
Команда Show Symbols  (Показать символы)
Выберите команду меню Tools > Options > Show Symbols (Инструменты > Опции >
Показать символы) для показа символов, используемых в Вашей программе. Чтобы
убрать символику выберите команду снова.
Эта команда меню доступна только тогда когда таблица символики STEP 7 присоединена
к имитируемой программе с использованием опции Attach Symbols (Присоединить
символику) .
Команда Reference Data (Справочные данные)
Выберите команду меню Tools > Options > Reference Data (Инструменты Опции >
Справочные данные) для того, чтобы открыть приложение Reference Data
(Справочные данные) STEP 7. Вы можете использовать это приложение для отладки
имитируемой программы.
Эта команда меню доступна только тогда, когда символьная таблица STEP 7
присоединена к имитируемой программе с использованием опции Attach Symbols...
(Присоединить символику).
Команда Symbol Table (Таблица символов)
Выберите команду меню Tools > Options > Symbol Table (Инструменты Опции >
Таблица символов) для того, чтобы открыть редактор символов STEP 7 и увидеть
таблицу символов, присоединенную к данный момент к программе.
Эта команда меню доступна только тогда когда таблица символики STEP 7 присоединена
к имитируемой программе с использованием опции Attach Symbols (Присоединить
символику).
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Меню Window (Окно)
Меню команд S7-PLCSIM Window (Окно) содержит следующие команды:

 Команда Cascade (Каскад)
Для расположения видимых объектов с взаимным перекрытием и сдвигом (начиная с

левого верхнего угла окна S7-PLCSIM), нажмите на  или выберите команду меню
Window > Cascade (Окно > Каскад).

 Команда Tile Ordered (Разделить окно)
Для расположения видимых объектов S7-PLCSIM одно к другому, с видимым объектом

CPU вверху слева, нажмите на  или выберите команду меню Window > Tile Ordered
(Окно > Разделить окно).

Команда Arrange Icons (Распределить иконки)
Команда меню Window > Arrange Icons (Окно > Распределить) распределяет
минимизированные видимые объекты (иконки видимых объектов) вдоль нижнего края
окна S7-PLCSIM.

Команда 1, 2, 3... 9
Вы можете активировать открытый видимый объект выбрав его в выпадающем
алфавитном списке в меню Window (Окно). Выберите номер соответствующего видового
объекта. Текущий активный видимый объект отмечен в списке. Если Вы открыли более 9
видимых объектов, вы можете выбрать More Windows... (Еще окна…) для вывода
диалогового окна с полным списком.
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Меню Help (Помощь)
Меню S7-PLCSIM Help (Помощь) содержит следующие команды:

Команда Contents... (Содержание)
Команда меню Help > Contents...(Помощь > Содержание) открывают экран Contents
(Содержание) помощи S7-PLCSIM.
В таблице содержания вы можете открыть любую книгу и щелкнуть на любом заголовке
чтобы вывести помощь по S7-PLCSIM.

Команда Introduction (Введение)
Команда меню Help > Introduction (Помощь > Введение) открывает раздел помощи,
который дает общий обзор S7-PLCSIM и задачи, которые Вы можете решить с ним.

Команда Getting Started (Быстрый старт)
Команда меню Help > Getting Started (Помощь > Быстрый старт) открывает раздел
помощи, позволяющий Вам начать работу с S7-PLCSIM.

Команда Using Help (Использование помощи)
Команда меню Help > Using Help (Помощь > Использование помощи) предоставляет
информацию о использовании встроенной системы помощи, необходимую, если Вы не
имеете опыта работы с программами Microsoft Windows. Система помощи Windows
обеспечивает Вас руководством в использовании программ..

Команда About... (О программе)
Команда Help > About...(Помощь > О программе) дает Вам информацию о версии
программного продукта и авторских правах.

 Кнопка Help (Помощь)
Чтобы получить информацию о элементах интерфейса S7-PLCSIM, используйте
следующий прием:

1. Нажмите  . Курсор мыши примет форму знака вопроса .
2. Щелкните в той части окна, по которой Вы хотите получить больше информации. S7-
PLCSIM покажет раздел помощи по этому элементу.
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Числовые форматы S7-PLCSIM
Справьтесь в этой таблице о используемых числовых типах данных и форматах ,
используемых S7-PLCSIM.

Тип данных Размер данных Пример
Bits Bit, Byte _  off   on
Binary Byte, Word 10010011
Decimal Byte, Word, Double Word 232
Hex (Hexadecimal) Byte, Word, Double Word 9A
S7 Format Byte, Word, Double Word dw#16#09A2FF23
Integer Word, Double Word 632, –2370
BCD (Binary-coded Decimal) Word, Double Word 400
Real Double Word 1.234567e+123
Char (Character) Byte, Word, Double Word  'C', 'AB'
String 254 символа 'This is a string'
DT (DATE_AND_TIME) 8 Bytes 1993-12-25-8:01:1

Заметьте: Формат DT не
поддерживает миллисекунд.

S5TIME Word 3m5s30ms
Date Word 1998-06-18
Time Double Word

9h26m53s703ms
TOD Double Word 9:26:53.702
Slider: Dec: Byte, Word, Double

Word

Slider: Int: Word, Double Word

Slider: Real: Double Word
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Поиск и устранение неисправностей
Проблема Коррекция/Возможные причины:

Определите, что ЦПУ в режиме STOP или RUN-P.
Как на реальном ЦПУ, Вы не можете загрузить Вашу
программу, если имитатор ЦПУ в режиме RUN.

Если ваша программа содержит Блок системных данных
(SDB), убедитесь, что ЦПУ в режиме STOP. Как на
реальном ЦПУ, Вы можете загрузить SDB только когда
ЦПУ в режиме STOP.
Замечание
Если видимый объект CPU в режиме RUN-P, STEP 7
подскажет Вам, что нужно перейти в режим STOP для
загрузки аппаратной конфигурации.

Ваша программа не
загружается в имитатор ЦПУ.

Убедитесь, что ЦПУ  и программа используют нужные
адреса узлов.
Как с реальной сетью MPI, адреса узлов, определенных
для программы, должны соответствовать адресам узлов
ЦПУ.

Когда Вы пытаетесь закрыть
имитатор ЦПУ, появляется
сообщение, что соединение
открыто.

Если Вы пытаетесь закрыть имитатор ЦПУ, пока один из
инструментов STEP 7 (например, S7 состояние)
управляется программой, STEP 7 сообщает Вам об
отсутствии связи инструментов STEP 7 с имитатором
ЦПУ. Всегда отключайте инструменты STEP 7, выключая
управление состоянием программы или закрыв
инструменты перед закрытием имитатора ЦПУ.

S7-PLCSIM приложение не
отвечает и появляется
надпись «locked
up.(заблокировано)»

Проверьте текущий режим. S7-PLCSIM может написать
locked up, когда установлен режим Stop или однократное
выполнение.

Вы ввели периферийную
переменную и получили
ошибку «Invalid Address»
(неправильный адрес), даже
если адрес правильный.
или Вы получили ошибку
периферийного доступа в
Вашей программе, даже если
проект S7-300 содержит
правильную конфигурацию.

Только ЦПУ S7-315-2DP, S7-316-2DP и S7-318-2
загружают конфигурацию входов/выходов. Если Вы
загружаете Вашу программу из другого ЦПУ S7-300,
системные данные не включают конфигурацию
входов/выходов. Возникнет ошибка, когда Вы
попытаетесь обратиться к периферийным
входам/выходам в S7-PLCSIM.
Для ее корректировки создайте S7-315-2DP, S7-316-2DP
или S7-318-2 проект и поместите копию Вашего
аппаратного обеспечения туда. Загрузите аппаратную
конфигурацию из S7-315-2DP, S7-316-2DP или S7-318-2 в
S7-PLCSIM.
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Таблица символов, команда ( меню инструменты) - Symbol table command (tools menu), 61
Таймеры - Timers, 10, 18, 35, 36, 57, 59
Таймеры видимый объект - Timer view object, 34
Таймеры, сброс - Timers resetting, 23
Теплый рестарт, команда (меню выполнить) - Warm start command (execute menu), 59
Типы данных - Data types, 3
У
Устранение проблем - Troubleshooting Tips general, 65
Устранение проблем записи/воспроизведения - Troubleshooting Tips record/playback, 25
Ф
Файл, меню - File menu, 53
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Аккумуляторы и слово состояния, видимый объект - ACCUs & status word view object, 32
Формат данных - Data formats, 64
Формат числовых данных - Numeric data formats, 64
Форматы S7 - S7 format, 64
Форматы числовых данных - Formats numeric data, 64
Х
Характеристики S7-PLCSIM - Features of S7-PLCSIM, 1
Холодный рестарт, поддержка - Cold restart support, 3
Ц
Целое - Integer, 64
Циклическая работа - Continuous Scan, 16, 20, 59
Циклическая работа – Scan continuous, 6, 16, 20
Циклический режим, команда (меню выполнить) - Scan mode command (execute menu), 59
Циклического режима выбор опций - Scan mode options selecting, 16
ЦПУ - CPU, 9
ЦПУ S7-300 - S7-300 CPUs, 21, 22, 37
ЦПУ S7-400 - S7-400 CPUs, 21, 22, 37
ЦПУ, видимый объект - CPU view object, 4, 9, 32
Ч
Числовой формат - Numeric Format, 19
Числовой формат ползунка - Numeric format slider control, 19
Что нового в S7-PLCSIM V 5.0 - What's new in S7-PLCSIM V 5.0, 3
Ш
Шестнадцатеричный -Hexadecimal (Hex), 64
C
C (счетчик - counter), 10
D
DATE_AND_TIME (DT), 64
DP индикатор - DP indicator, 10
DP ошибки, страница - DP failure tab, 48
DT (DATE_AND_TIME), 64
I
I (вход), 10
I/O (вход/выход), 6
L
LED, (светодиод) 10
Locked-up S7-PLCSIM, 65
M
M (меркер), 10
MCR, 32
Меню выполнить -Menus execute, 59
MRES, 23, 32, 58
Мониторинг времени цикла - onitoring the scan cycle, 28
O
OB  ошибок резервирования коммуникаций - OB communication redundancy error (OB73),42
OB аппаратных прерываний - OB hardware interrupt (OB40-OB47), 38
OB временной ошибки -OB time error (OB80), 43
OB диагностических прерываний - OB diagnostic interrupt (OB82), 44
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OB ошибки носителя - OB rack failure (OB86), 48
OB ошибки приоритета класса - priority class error (OB85), 47
OB ошибки резервирования входов/выходов - OB I/O redundancy error (OB70), 39
OB ошибок Error OBs
OB ошибок резервирования ЦПУ - OB CPU redundancy error (OB72), 40
OB пользовательских прерываний - OB using interrupts, 21, 37
OB прерывания вставки/удаления модуля - OB insert/remove module interrupt (OB73), 46
OB102, 3
OB40 to OB47, 21, 37, 38
OB40-OB47 (аппаратное прерывание), 38
OB70 (ошибка резервирования входов/выходов), 39
OB70, 21, 37, 39
OB72 (ошибка резервирования CPU), 40
OB72, 21, 37, 40
OB73 (ошибка резервирования коммуникаций), 42
OB73, 21, 37, 42
OB80 (временная ошибка), 43
OB80, 21, 37, 43
OB82 (диагностическое прерывание), 44
OB82, 21, 37, 44
OB83 (вставки/удаления модулей прерывание), 46
OB83, 21, 37, 46
OB85 (ошибка класса приоритета), 47
OB85, 21, 37, 47
OB86 (ошибка стойки), 48
OB86, 48
OBs, 39, 48
P
PI (peripheral input), 10
PQ (периферийные выходы), 10
Q
Q (выход), 10
R
RUN command (execute menu), 59
RUN, 9, 10
RUN-P command (execute menu), 59
S
S5TIME, 64
S7-PLCSIM
S7-PLCSIM, видимые объекты -  view objects, 31
S7-PLCSIM, меню - menus, 52
S7-PLCSIM, модификация аппаратной конфигурации - modifying your hardware
configuration, 22
S7-PLCSIM, палитры инструментов -  toolbars, 51
S7-PLCSIM, характеристики - features, 1
S7-PLCSIM, числовые форматы данных - numeric data formats, 64
SF индикатор - indicator, 10
SIMATIC manager, 4
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STOP команда (меню выполнить), 59
STOP, 9, 10
T
T (таймер), 10
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