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Safety Guidelines 

This manual contains notices intended to ensure personal safety, as well as to protect the products and 
connected equipment against damage. These notices are highlighted by the symbols shown below and 
graded according to severity by the following texts: 

 

!  
Danger 
indicates that death, severe personal injury or substantial property damage will result if proper 
precautions are not taken. 

 

!  
Warning 
indicates that death, severe personal injury or substantial property damage can result if proper 
precautions are not taken. 

 

!  
Caution 
indicates that minor personal injury can result if proper precautions are not taken. 

 
 Caution 

indicates that property damage can result if proper precautions are not taken. 
 

 Notice 
draws your attention to particularly important information on the product, handling the product, or to a 
particular part of the documentation. 

Qualified Personnel 

Only qualified personnel should be allowed to install and work on this equipment. Qualified persons 
are defined as persons who are authorized to commission, to ground and to tag circuits, equipment, and 
systems in accordance with established safety practices and standards. 

Correct Usage 

Note the following: 
 

!  
Warning 
This device and its components may only be used for the applications described in the catalog or the 
technical description, and only in connection with devices or components from other manufacturers 
which have been approved or recommended by Siemens. 
 
This product can only function correctly and safely if it is transported, stored, set up, and installed 
correctly, and operated and maintained as recommended. 

Trademarks 

SIMATIC®, SIMATIC HMI® and SIMATIC NET® are registered trademarks of SIEMENS AG.  

Third parties using for their own purposes any other names in this document which refer to trademarks 
might infringe upon the rights of the trademark owners. 
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Проектирование системы последовательного 
управления на примере сверлильного станка 

Приглашаем в пример для новичков S7-GRAPH  
Потратив один час для работы с примером для начинающих, Вы узнаете, как 
создать последовательную систему управления для автоматизации 
сверлильного станка, описанную здесь. 

  
Вы сначала узнаете, как эффективно спроектировать последовательную 
систему управления и далее шаг за шагом выполните в SIMATIC Manager 
Менеджере и в S7- GRAPH задачи, необходимые для:  

• создания системы последовательного управления,  

• загрузки ее в CPU и 

• проверки. 

Правильный пример программы поставляется с S7-GRAPH, как проект, 
названный "ZEn02_01_S7GRAPH_Drill".  
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Требования 
Чтобы запрограммировать и проверить пример "сверлильный станок", Вам 
потребуется следующая аппаратура и программное обеспечение: 

• Программатор или PC с  

-  стандартным пакетом STEP 7 и дополнительным пакетом 
S7-GRAPH  

-  соединением MPI с программируемым логическим контроллером 

• Программируемый логический контроллер (в нашем примере S7-300) 
содержащий: стандартную рейку, источник питания 24V, CPU 314, и 
модуль входов/выходов (8DI + 8DO) 

• В качестве замены PLC можно использовать дополнительный пакет S7 
"PLC Simulation" 

Последовательность создания системы последовательного управления  
Блок схема иллюстрирует последовательность создания системы 
последовательного управления для примера сверлильного станка: 

 

Создайте таблицу  
символов  

Определите стру кту ру после-
довательности и сигналы 
системы 

Создайте проект в  
SIMATIC Manager 

Создайте секвенсор: 
•  создайте и откройте в  SIMATIC

Manager FB1 на языке S7 Graph 
•  Запрограммиру йте секвенсор

Запрограммиру йте  OB1 с  
вызовом FB1 и соотвестству -
ющий экземпляр DB (DB1) 

Загру зите в  SIMATIC Manager пример 
программы (DB1, FB1, OB1) в CPU и 
проверьте секвенсор 

Символьное 
программиро-

вание 

да 

нет 
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Технологическая задача и функциональная диаграмма 

Задача 
Требуется запрограммировать последовательную систему управления, чтобы 
автоматизировать сверлильный станок. Работу сверлильного станка 
показывают технологический чертеж и последовательность процесса в виде 
функциональной диаграммы. 

Технологический чертеж сверлильного станка 
Сверлильный станок имеет следующие элементы: 

• Мотор сверла с сигналами обратной связи для включенного и 
выключенного состояния 

• Кнопка пуска и переключатель охлаждения 

• Насос охлаждения с сигналом обратной связи о достижении давления 
охладителя  

• Устройство зажима с сигналом обратной связи о достижении усилия 
зажима 

• Каретка  перемещения вверх и вниз сверла с ограничивающими ключами 

 

Подъем сверла
Мотор сверла включен 
Сигналы обратной связи: 

- Сверло включено 
- Сверло выключено 

Насос охлаждения включен 
Сигнал обратной связи 
Достигнуто давление 

Пуск 

Сигнал обратной связи: 
Достигнуто заданное усилие зажима 

Верхний концевик 

Включение охлаждения 

Мотор сверла

Каретка 

Устройство зажима Насос охлаждения 

Опускание сверла 

Нижний концевик 
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Начальное состояние 
Начальное состояние сверлильного станка определено следующим образом: 

• Мотор сверла и насос охлаждения выключены 

• Каретка сверла в верхней позиции  

• В устройстве зажима нет заготовки 

Функциональная диаграмма – Последовательность сверления 
Последовательность сверления может быть разбита на следующие разделы: 

• Установка заготовки (вручную) 

• Если необходимо, устанавливается ключ охлаждения (в зависимости от 
материала) 

• Запуск установки кнопкой пуска (мотор сверла включается) 

• Зажим заготовки с заданным давлением 

• Запуск мотора охлаждения (если выбрано охлаждение) 

• Опускание сверла и каретки в нижнюю целевую позицию (сверление) 

• Выдержка 0.5 сек в нижней целевой позиции (сверление) 

• Подъем сверла с кареткой в верхнюю целевую позицию  

• Освобождение заготовки, выключение мотора и насоса охлаждения 

• Удаление заготовки (вручную) 

 

Мотор
Вкл. 

Выкл. 

Каретка
вверх 

вниз 

Элемент Состояние

Зажим Вкл. 

Выкл. 

Пуск 
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Выбор структуры секвенсора 

До создания программы секвенсора, Вы должны выполнить концептуальную 
стадию разработки, разбив операцию сверления на отдельные шаги. Основой 
для разработки концепции служат технологический чертеж и диаграмма. 

Разделение процесса сверления на отдельные шаги – Структура секвенсора 
Процесс сверления описывается S7-GRAPH в виде секвенсора. Секвенсор 
представляет последовательность простых шагов и условий, которые 
управляют переходами от одного простого шага к следующему. Чтобы 
определить структуру секвенсора, выполните следующее: 

1. Разбейте процесс сверления на шаги и определите порядок шагов 
(например, "шаг S2 следует за S1" или "за шагом S3 следует или шаг S4 
или S7"). 

2. Определите действия, которые должны выполняться для каждого шага 
(например, на шаге S1 действие "Подготовка сверления" или на шаге S3 
действие  "Выключение мотора сверла"). 

3. Далее для каждого шага решите, какие условия должны выполняться, 
чтобы процесс мог перейти к следующему шагу (например, для T1 условие 
"Станок включен – нажата кнопка пуска" или для T5 условие "Сверло в 
нижней позиции"). 
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T2

S2

T8

T3

T7

S3

S1

T4

T1

T6

S7

S4

Станок готов  (начальный шаг) 

Зажим заготовки

Включение мотора сверла 

Включение насоса охладителя 

Опу скание сверла (начало сверления) 

Начала программы сверления 
(нажата кнопка пу ска) 

Заготовка зажата с заданным 
усилием 

Мотор сверла запущен с заданной 
скоростью (без охлаждения) 

Достигну то давление охладителя  

Сверло в  нижней позиции

Мотор сверла запущен с заданной 
скоростью (с охлаждением)

S5

S6

T5

T6

S1

Подъем сверла

Отпу скание заготовки, выключение 
motorсверла и насоса

Сверло в  верхней позиции

Заготовка освобождена, насос  
охладителя и мотор сверла   
выключены. Пау за 500 мс

S = шаг 
T = переход 

Монитор зажима 
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Определение сигналов системы 

Когда Вы разделите операцию сверления на отдельные шаги, Вы должны 
определить входные и выходные параметры для каждого шага. Основой для 
проектирования служат технологический чертеж и функциональная 
диаграмма. 

Определение входов и выходов 
Перепишите входы и выходы сверлильного станка в виде таблицы.  

Если Вы хотите программировать в символьном виде, введите 
соответствующие символьные имена (например, вход I 0.4 "Cl_press_ok") для 
абсолютных входов и выходов и любые комментарии, которые делают Вашу 
программу проще для понимания (например "Достигнуто требуемое усилие 
зажима заготовки"). 

Для примера сверлильного станка, принято, что ключи и контакторы 
управляются через входы и выходы цифрового вход-выходного модуля 
программируемого контроллера S7-300. Вход-выходной модуль имеет 8 
входов и 8 выходов. По умолчанию входы и выходы для модуля, 
вставленного в 4 слот, имеют адреса: от I 0.0 до I 0.7 и от Q 0.0 до Q 0.7. 

 
Абсолютные 
адреса 

Символьные  
адреса 

Пояснение 
 

Входы в программе (I)  
I 0.0 Dr_mot_running Сигнал обратной связи о вращении мотора 

сверла с заданной скоростью  
I 0.1 Dr_mot_stopped Сигнал обратной связи о останове мотора сверла 
I 0.2 Drill_down Нижний концевик сверла 
I 0.3 Drill_up Верхний концевик сверла  
I 0.4 Cl_press_ok Сигнал обратной связи о достижении заданного 

усилия зажима заготовки  
I 0.5 Coolant_sel Включение охлаждения (в зависимости от 

заготовки) 
I 0.6 Cool_press_ok Сигнал обратной связи о достижении заданного 

давления охладителя   
I 0.7 Start_button Кнопка включения 
Выходы в программе (Q)  
Q 0.0 Dr_mot_on Включение мотора сверла 
Q 0.1 Cool_pump_on Включение насоса охладителя (в зависимости от 

заготовки) 
Q 0.2 Lower_drill Опускание сверла и каретки до нижней позиции  
Q 0.3 Raise_drill Подъем сверла и каретки до верхней позиции  
Q 0.4 Clamp_workp Зажим заготовки до заданного усилия 
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Создание проекта в SIMATIC Manager 

Создание проекта  
Проекты для систем последовательного управления не отличаются от других 
проектов STEP 7. 

Для создания нового проекта в SIMATIC Manager, выполните описанные ниже 
шаги: 

1. Выберите команду меню File > New [Файл > Новый].  

2. Назовите проект "Drill". 

Вставка программы S7  
В этом примере, конфигурация аппаратуры не требуется, так как 
используется адресация вход-выходного модуля в слоте 4 по умолчанию. 
Следовательно, Вы можете в SIMATIC Manager непосредственно вставить 
программу S7 в папку проекта. Программа S7 служит папкой для блоков 
программы пользователя, исходных файлов и символики. Выполните 
следующее: 

1. Выберите проект "Drill". 

2. Выберите команду меню Insert > Program > S7 Program [Вставить > 
Программа > Программа S7]. 

3. Назовите программу S7 "Drill Program". 

Папки для исходных файлов, блоков и символика создаются автоматически 
при вставке программы S7. В папке блоков создается также пустой OB1. 
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Создание таблицы символов 

Программируя в  STEP 7, Вы работаете с такими адресами как сигналы на 
входах и выходах, меркеры, счетчики, таймеры, блоки данных и 
функциональные блоки. Вы имеете доступ к этим адресам в Вашей 
программе в абсолютном виде (например, I1.1, M2.0, FB21). 

Вы можете сделать программу значительно яснее и проще для чтения, 
используя вместо абсолютных адресов символы (например, Motor_A_on). 
Чтобы использовать символы, Вы должны ввести имя, абсолютный адрес, 
тип данных и комментарий для каждого используемого адреса. 

Как только Вы определили символ, он может использоваться всюду в 
пользовательской программе программируемого модуля. 

Создание таблицы символов  
Если Вы хотите писать Вашу пользовательскую программу символьные 
адреса, желательно создать таблицу символов сейчас.  

1. Откройте символьную таблицу в папке "Drill Program" двойным щелчком на 
"Symbols". 

2. Отредактируйте таблицу как показано ниже.  

3. Сохраните символьную таблицу, используя команду меню Table > Save 
[Таблица > Сохранить]. 

Строки с 1 по 14 используются для символьного представления входов и 
выходов. Записи с 15 по 18 дают символьное представление блоков.  
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Создание FB S7-GRAPH и программирование секвенсора 

Создание FB на языке S7-GRAPH  
FB на языке S7-GRAPH должен содержать секвенсор. Для создания FB 
S7-GRAPH, выполните следующее: 

1. Откройте в SIMATIC Manager папку "Blocks" в "Drill Program". 

2. Выберите команду меню Insert > S7 Block > Function Block [Вставить > Блок 
S7 > Функциональный блок]. 

3. Выберите в диалоге "Properties [Свойства]" в качестве языка "S7-GRAPH".  

Результат: В папке "Blocks" создан пустой FB с номером по умолчанию 1. 

Программирование секвенсора  
После запуска редактора S7-GRAPH двойным щелчком на FB1 система 
вставляет первый шаг (начальный шаг) и первый переход. Структуру 
желательно создавать при уровне отображения "Sequencer". Для 
отображения условий и действий, вызовите команду меню View > Display 
With > Conditions and Actions [Вид > Показывать с…  > Условия и 
действия]. 

Используя мышь и палитру инструментов "Sequencer", расположенную слева, 
Вы можете разместить все требуемые шаги и переходы, альтернативную 
ветвь и скачок с конца секвенсора к его началу. Есть два способа сделать 
это, и оба показаны здесь. 

Способ 1: "Прямой"  
1. Выделите переход 1 и нажимайте мышью кнопку  

  insert step + transition [вставить шаг и переход] 
пока Вы не получите шаг и переход 6. 

2. Выделите шаг 3 и нажмите кнопку 

  open alternative branch [открыть альтернативную ветвь].  
Открывается альтернативная ветвь для обслуживания охлаждения. Ветвь 
начинается с перехода 7.  

3. Выберите мышью кнопку  

   insert step + transition [вставить шаг и переход],  
и вставьте шаг 7 (S7) и переход 8 (T8).  

4. Выберите кнопку 

  close alternative branch [закрыть альтернативную ветвь] 
и выберите затем переход 3. 

5. Теперь завершите структуру секвенсора, выбрав сначала переход 6 и 
нажав на кнопку  

   insert jump [вставить скачок], 
а затем выбрав шаг 1. 



Проектирование системы последовательного управления на примере сверлильного станка  

Начало работы с S7-GRAPH для S7-300/400 Программирование последовательных систем управления  
A5E00290666-01 13 

Способ 2: "Перетаскивание" 
1. Возвратитесь в SIMATIC Manager и создайте функциональный блок FB2 в 

папке "Blocks" как описано выше. Опять выберите в качестве исходного 
языка "GRAPH". 

2. Запустите редактор S7-GRAPH двойным щелчком на FB2 в папке "Blocks". 

3. Выберите команду меню Insert > Drag-and-Drop [Вставить > 
Перетащить]. 

4. Используя мышь, выберите кнопку 

  insert step + transition [вставить шаг и переход] 
и затем щелкайте на последнем появляющемся переходе, пока не 
получите шаг и переход 6. 

5. Выберите кнопку  

   open alternative branch[открыть альтернативную ветвь] 
и откройте альтернативную ветвь для охлаждения щелчком на шаге 3. 
Ветвь открывается переходом 7.  

6. Используя мышь, выберите кнопку  

  insert step + transition [вставить шаг и переход],  
для вставки шага 7 (S7) и перехода 8 (T8).  

7. Выберите кнопку  

   close alternative branch [закрыть альтернативную ветвь] 
и выберите сначала переход 8, а затем переход 3. 

8. Теперь завершите структуру секвенсора, используя кнопку  

 insert jump [вставить скачок] 
и выбрав сначала переход 6 и затем шаг 1. 

 
 Замечание 

Закройте FB2 до программирования действий шагов. Вы создали этот FB 
только для того, чтобы ознакомиться со вторым способом создания структуры 
секвенсора. При закрытии FB, ответьте на все вопросы "No". В дальнейшем 
Вы будете работать только с FB1. 
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Программирование действий шага  

Существует также два способа для программирования шагов и переходов: 
прямой и перетаскивание. Процедура, описанная ниже, предполагает, что 
Вы выбрали команду меню Insert > Drag-and-Drop [Вставить> 
Перетаскивание]:  

1. Выберите команду меню Insert > Action [Вставить > Действие].  
Результат: курсор мыши примет показанный ниже вид: 

 
2. Вставьте пустую строку действия, щелкая на поле действия. 

3. Введите действия. 

Действие состоит из команды и адреса операнда. Для программы сверления, 
в шагах необходимы четыре различных команды: 

• S Установить выход 

• R Сбросить выход 

• N Установка без сохранения: Пока шаг активен, операнд 
устанавливается в 1. 

• D Задержка: Операнд устанавливается в 1 спустя определенное 
время после активации шага и сбрасывается при деактивации шага. 

Программирование переходов 

Логические команды "нормально разомкнутый контакт", "нормально 
замкнутый контакт" и "компаратор" используются в переходах для условий, 
разрешающих шаг. Для программирования переходов: 

1. Установите вид "LAD" и нажимайте соответствующие кнопки в панели 
инструментов "LAD/FBD" 

  вставка нормально открытого контакта 

  вставка нормально закрытого контакта  

  вставка компаратора 

2. Позиционируйте символы в соответствующие точки щелчком на линии 
перехода. В любой момент Вы можете выйти из режима вставки, нажав 
клавишу ESC. 

3. Введите адреса. Щелкните на метке - заполнителе "??.? " требуемого 
текстового поля. Затем введите абсолютный или символьный адрес 
(например, I 0.7, "Start_switch"). 

4. Если требуется, Вы можете ввести комментарии к секвенсору. В 
представлении "sequencer", поле комментария располагается в верхнем 
левом углу и может быть открыто щелчком мыши на нем. 
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Следующий рисунок показывает законченный секвенсор. 

GRAPH: Programming s7 Sequential Control Systems - Drill\...
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При программировании сравнения (компараторов), Вы можете использовать 
вместо адресов системную информацию о шагах. Используются следующие 
обозначения: 

• Имя_шага.T: текущее или последнее время активности шага 

• Имя_шага.U: текущее или последнее время активности шага с вычетом 
времени нарушений 
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Программирование мониторинга 

Для программирования мониторинга: 

1. Дважды щелкните на шаге 2 для замены вида отображения "sequencer 
[секвенсор]" на вид "single step [отдельный шаг]". 

2. Выбрав в палитре инструментов "LAD/FBD" кнопку 

 вставьте компаратор  

3. Разместите компаратор в соответствующей позиции строки супервизора и 
введите необходимое время мониторинга. 
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Выбор стандартного функционального блока 

Выполнение FB S7-GRAPH  
Возможны два варианта для создания FB S7-GRAPH. 

• Полный код: 
Для каждого FB S7-GRAPH весь требуемый код включается в FB. Если Вы 
имеете различные FB S7-GRAPH, это приводит к значительному 
увеличению объема требуемой для программы памяти. 

• Использование стандартной FC: 
Для сокращения требований к памяти, S7-GRAPH имеет альтернативное 
решение: Использование стандартной FC, содержащей основную часть 
кода для всех FB. Эта FC автоматически копируется в Ваш проект при 
выборе соответствующей опции. FB созданные по этому методу будут 
значительно меньше.  

Для нашего примера используйте настройку компилятора "Full code [Полный 
код]".  

Наиболее подходящая FC зависит от характеристик Вашего CPU. Выберите 
одну из следующих стандартных FC: 
 

Номер FC  Функционирование 

FC72 По умолчанию, Вы работаете с FC72. Помните, что Ваш CPU должен быть способен к 
обработке блоков, размером больше 8 килобайт.  

FC70/FC71 Эти две FC, размером меньше 8 килобайт, могут быть загружены в небольшой 
центральный процессор. FC70 использует диагностические возможности SFC17/18 и 
может быть использована только на CPU, имеющих эти функции. Если Ваш CPU не 
имеет этих функций, Вы должны использовать FC71 и не имеете возможностей 
диагностики.  
Если Вы хотите проверить, поддерживает или нет Ваш CPU эти SFC, выберите в 
SIMATIC Manager команду меню PLC > Obtainable Nodes [PLC > Доступные узлы] 
или нажмите соответствующую кнопку в панели инструментов. Откройте папку 
"Blocks" а программе S7. 

FC73 Этот блок занимает менее 8 кбайт памяти и может выполняться на всех CPU.  
Использование этого FC значительно уменьшает требования к объему памяти для 
FB S7-GRAPH. Вы должны также выбрать опцию "Interface Description: Memory 
minimized [Описание Интерфейса: минимизация памяти]" в установках блока.  
Однако действует следующее ограничение: Созданные блоки не имеют возможности 
диагностики 
Когда Вы контролируете последовательную систему управления, Вы будете видеть, 
что состояние отображается только для выбранного активного элемента. 
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Установка свойств выполнения 
Выберите команду меню Options > Block Settings  [Возможности > 
Установки блока] и установите на закладке Compile/Save 
[Компиляция/Сохранение] как FB S7-GRAPH должен работать со 
стандартными FC. Введите номер FC в соответствии с возможностями 
Вашего CPU. 

Блок автоматически копируется в пользовательский проект, если Вы выбрали 
FC70/71, FC72 или FC73 и функции  с таким номером нет в Вашем проекте. 
Если Вы хотите использовать другой номер для стандартного блока, Вы 
должны копировать и перенумеровать его самостоятельно. 

Сохранение и закрытие секвенсора 

Когда Вы сохраняете и закрываете секвенсор, он автоматически 
компилируется. 

1. Выберите команду меню File > Save [Файл> Сохранить]. 

Результат: открывается диалоговое окно "Select Instance DB [Выбрать 
экземпляр DB]" с заданным по умолчанию экземпляром DB (DB1). 

2. Подтвердите параметры настройки, нажав "OK". 

Результат: Экземпляр блока данных автоматически создается в папке 
"Blocks". 

 
 Заметьте 

Предупреждение "S1 without content [S1 без содержания]" в результатах 
компиляции означает, что в шаге 1 не запрограммировано никакого действия.

 

3. Чтобы закрыть программу секвенсора, выберите команду меню File > 
Close [Файл > Закрыть]. 
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Подключение секвенсора к программе STEP 7  

Программирование OB1 
Программа последовательного управления для сверления вызывается в 
организационном блоке OB1 . Вы можете создать OB1 в LAD, FBD, STL или 
SCL (здесь он создан на LAD). Запрограммируйте OB1, как показано на 
следующей диаграмме. Выполните следующее: 

1. Откройте в SIMATIC Manager папку "Blocks" в программе S7 "Drill Program". 

2. Запустите редактор LAD/STL/FBD двойным щелчком на OB1.  

3. Через меню команд View [Вид], выберите язык программирования LAD. 

4. Выберите сегмент 1 и вставьте вызов секвенсора, двойным щелчком на 
FB1 (Seq_drill) в каталоге элементов. 

5. Напечатайте над боксом для FB1имя соответствующего экземплярного 
блока данных (IDB_Seq_drill). 

6. Выберите входной параметр INIT_SQ, вставьте нормально открытый 
элемент в панели инструментов "LAD" и подпишите его M0.0 ("INIT_SQ"). 
Используя этот параметр,  Вы сможете в интерактивном (online) режиме 
устанавливать секвенсор в начальное состояние (в примере шаг 1). 

7. Выберите команду меню File > Save [Файл > Сохранить] и закройте 
организационный блок командой меню File > Close [Файл > Закрыть]. 

 
 Замечание 

Все другие параметры блока можно проигнорировать для этого примера. 
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Загрузка программы в CPU и проверка секвенсора 

Загрузка пользовательской программы 
Чтобы загрузить программу в CPU, необходимо в SIMATIC Manager загрузить 
все ее блоки (DB1, FB1, OB1, FC70/71, FC72 и/или FC73) в CPU 
программируемого контроллера. Выполните следующее:  

1. Откройте в SIMATIC Manager программу S7 "Drill Program" и выберите 
папку "Blocks". 

2. Выберите команду меню PLC > Download [PLC > Загрузить]. 

 
 Предупреждение 

Лучше загружать блоки S7-GRAPH в режиме STOP, поскольку при 
последующей загрузке экземпляра DB, секвенсор автоматически 
устанавливается в начальное состояние. 

Вы должны загружать блоки S7-GRAPH в режиме RUN-P только, если 
секвенсор находится в начальном состоянии или состоянии OFF. Если Вы 
загружаете блоки секвенсора в другом состоянии, например, перезаписывая 
старый блок, могут возникнуть проблемы синхронизации секвенсора с 
процессом. 

Проверка пользовательской программы  
Для проверки пользовательской программы, Вы должны иметь интерактивное 
(online) соединение с CPU. 

1. Откройте в SIMATIC Manager окно проекта. 

2. Откройте секвенсор, дважды щелкнув на FB1.  

3. Выберите команду меню Debug > Monitor [Отладка > Наблюдение]. 

Результат: Отображается состояние программы (активен начальный 
шаг). Активные шаги отображаются цветом. 

 
 Предупреждение 

Контроль времени запрограммирован в шаге 2. Если время активности шага 
превышает сконфигурированное в условии супервизора время наблюдения 
(500 мс), система обнаруживает ошибку супервизора и шаг с ошибкой 
подсвечивается красным. Если появляется ошибка, Вы должны сначала 
удовлетворить условия следующего перехода. Используя функцию PG 
Debug > Control Sequencer [Отладка > Управление секвенсором] Вы 
можете ввести квитирование (см. также "Управление секвенсором"). 

Это не применимо к пальчиковому режиму, так как условие, разрешающее 
шаг, должно быть удовлетворено, и квитирование получено в пределах 
одного цикла. 
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Проверка: Управление секвенсором 

Управление секвенсором это тестовая функция, с которой Вы можете 
проверить секвенсор S7-GRAPH во всех режимах. Все установки и вводы 
диалогового окна имеют тот же эффект, что и выбор соответствующих 
параметров FB.  

Вводы в диалоговом окне "Control Sequencer [Управление секвенсором]" 
могут отличаться от использованных при компиляции секвенсора установок. 
Установки диалогового окна имеют приоритет. 

Диалоговое окно "Control Sequencer [Управление секвенсором]"  
Диалоговое окно "Control Sequencer [Управление секвенсором]" используется 
как для отображения текущих установок, так и для ввода установок для 
изменения текущего состояния.  

Если Вы квитируете ошибку, инициируете секвенсор, или хотите переключить 
шаг в ручном режиме, вызовите диалоговое окно командой меню Debug > 
Control Sequencer [Отладка > Управление секвенсором]. 

Квитирование 
Если выбрана опция "Acknowledge errors [Квитирование ошибок]", Вы 
квитируете ждущее обработки сообщение об ошибке кнопкой "Acknowledge 
[Квитирование]". Этим способом, Вы можете квитировать вызванное 
нарушение, например, превышение  сконфигурированного контрольного 
времени в шаге 2.  

Однако обратите внимание, что прежде, чем Вы признаете ошибку, Вы 
должны удостовериться, что диспетчерское управление или условия 
супервизора или самоблокировки, которые вызвали ошибку, больше не 
выполняются. 

После того, как произошла ошибка, Вы можете разрешить следующий шаг в 
секвенсоре, удовлетворяя условия, разрешающие шаг, потому что условия, 
разрешающие следующий шаг, имеют приоритет над супервизором в цикле, в 
котором Вы квитируете. Однако квитирование ошибки обязательно. 

Если ошибка была вызвана потому, что время активации без нарушений 
stepname. U превысило заданное контрольное время, Вы можете 
переключить шаг секвенсора, нажав кнопку "Acknowledge [Квитирование]". 

Это возможно, потому что переменная Step name. U устанавливается в "0", 
когда Вы квитируете. 

Инициализация 
Кнопкой "Initialize [Инициализировать]" Вы можете полностью перезапустить 
секвенсор с шага, заданного начальным. 
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Установка режима 
Отметьте бокс выбора, чтобы установить нужный режим секвенсора 

Вы можете, например, запустить секвенсор в ручном режиме вместо 
автоматического. В ручном режиме, Вы можете активировать или 
деактивировать любой шаг. Следуйте за шагами, приведенными ниже: 

1. Введите номер шага, который Вы хотите обработать, в поле "Step number 
[Номер шага]" или просто щелкните на требуемом шаге. 

2. Выберите действие, которое Вы хотите выполнить с шагом: 

- Активировать Выбранный шаг активируется, даже если 
предшествующий переход не разрешен. 

- Деактивировать Выбранный шаг деактивируется. 

Заметьте, что прежде чем активировать шаг, Вы должны деактивировать 
текущий активный шаг, поскольку только один шаг может быть одновременно 
активен в линейной последовательности. Другими словами, Вы сможете 
активировать шаг только тогда, когда деактивируете текущий активный шаг. 

Когда Вы устанавливаете новый режим, исходный режим выделен жирным. 
Когда Вы управляете секвенсором в ручном режиме, Вы можете вернуться в 
автоматический, закрыв окно "Control Sequencer [Управление секвенсором]". 

Изменение секвенсора 

Часто, первоначальная программа должна изменяться и модифицироваться. 
Это применимо и к нашему примеру. Сконфигурированное контрольное 
время шага 2 слишком мало и программа зависает при этом шаге. 
Следующий раздел показывает, как сделать требуемые изменения. Они 
выполняются сначала в автономном (offline) режиме. 

Изменение контрольного времени 
Сконфигурированное контрольное время шага 2 равно 500 мс. Чтобы 
увеличить время установки переменной "Cl_press_ok", измените контрольное 
время на  5 с,  как описано ниже: 

1. Дважды щелкните на 2 для изменения вида отображения "sequencer" на 
вид "single step [отдельный шаг]". 

2. Закройте контроль состояния, выбрав команду меню Debug > Monitor 

[Отладка > Монитор] или нажав кнопку:   . 

3. Введите контрольное время 5 с. 

4. Сохраните секвенсор командой меню File > Save [Файл > Сохранить], при 
этом секвенсор будет перекомпилирован. 
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Загрузка измененного секвенсора 
Как только Вы скомпилировали секвенсор, Вы должны загрузить ее в CPU. Вы 
можете загрузить секвенсор в SIMATIC Manager или в редакторе S7-GRAPH. 
В редакторе S7-GRAPH, выполните следующее:  

1. С открытым FB, выберите команду меню PLC > Download  [PLC> 

Загрузка] или нажмите кнопку Download [Загрузка] . Появится 
диалоговое окно "Download [Загрузка]". 

2. Примите значения по умолчанию, нажимая "OK". 

3. Подтвердите перезапись существующих блоков. 

Включение экземпляра DB 
Если Вы не очистили установленное по умолчанию свойство "Include Instance 
DB [Включая экземпляр DB]", S7- GRAPH проверяет, был ли экземпляр DB, 
изменен, с момента последней загрузки и должен ли, он быть заменен. 
Разрешается выбор опции "Download with Instance DB [Загрузка с 
экземпляром DB]" в диалоговом окне "Download [Загрузка]". 

Иначе, S7- GRAPH не проверяет экземпляр DB и предоставляет Вам решить, 
надо ли загрузить образец DB снова. Опция "Download with Instance DB 
[Загрузка с экземпляром DB]" в диалоговом окне "Download" не выбирается. 

Перезапуск состояния 
Чтобы снова обеспечить способность контроля или управления секвенсором, 
перезапустите контроль состояния, выбрав команду меню Debug > Monitor  

[Отладка> Монитор] или выбрав кнопку Monitor   . 
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