WinCC/Audit - Installation Notes
WinCC/Audit - Release Notes
WinCC/Audit - Documentation

Printout of the Online Help
Legal information

Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are graded according to the degree of danger.

<table>
<thead>
<tr>
<th>Notice</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>DANGER</strong></td>
<td>indicates that death or severe personal injury <strong>will</strong> result if proper precautions are not taken.</td>
</tr>
<tr>
<td><strong>WARNING</strong></td>
<td>indicates that death or severe personal injury <strong>may</strong> result if proper precautions are not taken.</td>
</tr>
<tr>
<td><strong>CAUTION</strong></td>
<td>indicates that minor personal injury can result if proper precautions are not taken.</td>
</tr>
<tr>
<td><strong>NOTICE</strong></td>
<td>indicates that property damage can result if proper precautions are not taken.</td>
</tr>
</tbody>
</table>

If more than one degree of danger is present, the warning notice representing the highest degree of danger will be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property damage.

Qualified Personnel

The product/system described in this documentation may be operated only by personnel qualified for the specific task in accordance with the relevant documentation, in particular its warning notices and safety instructions. Qualified personnel are those who, based on their training and experience, are capable of identifying risks and avoiding potential hazards when working with these products/systems.

Proper use of Siemens products

Note the following:

<table>
<thead>
<tr>
<th>Notice</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WARNING</strong></td>
<td>Siemens products may only be used for the applications described in the catalog and in the relevant technical documentation. If products and components from other manufacturers are used, these must be recommended or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and maintenance are required to ensure that the products operate safely and without any problems. The permissible ambient conditions must be complied with. The information in the relevant documentation must be observed.</td>
</tr>
</tbody>
</table>

Trademarks

All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability

We have reviewed the contents of this publication to ensure consistency with the hardware and software described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the information in this publication is reviewed regularly and any necessary corrections are included in subsequent editions.
# Table of contents

## 1 WinCC/Audit - Installation Notes

- 1.1 Scope of delivery ............................................. 5
- 1.2 Licenses ......................................................... 5
- 1.3 Installing Audit ................................................. 7
- 1.4 Upgrading Audit ............................................... 8
- 1.5 User authentication .......................................... 9

## 2 WinCC/Audit - Release Notes

- 2.1 Notes on Audit ................................................ 11
- 2.2 New functionalities ......................................... 13
- 2.3 Service and Support ........................................ 14
  - 2.3.1 Warnings .................................................. 14
  - 2.3.2 Customer support ....................................... 17
  - 2.3.3 Support Request ......................................... 18

## 3 WinCC/Audit - Documentation

- 3.1 Using Audit ..................................................... 21
- 3.2 Important information about the Audit Viewer ....... 22
- 3.3 Approved configurations ................................. 22
  - 3.3.1 Local WinCC scenario ............................... 22
  - 3.3.2 WinCC remote scenarios ......................... 23
- 3.4 Audit basics .................................................... 27
  - 3.4.1 Logon ........................................................ 27
  - 3.4.2 Changing the interface language ............... 28
  - 3.4.3 Audit components ..................................... 28
  - 3.4.3.1 Audit Editor .......................................... 28
  - 3.4.3.2 Audit Viewer .......................................... 31
  - 3.4.3.3 Audit Viewer Control ............................ 36
  - 3.4.3.4 Audit Document Control and Project Versioning ...................................................... 36
- 3.5 Basic procedure .............................................. 39
  - 3.5.1 Working with WinCC/Audit ....................... 39
  - 3.5.2 Working with the Audit Viewer ................. 43
  - 3.5.3 Working with Document Control and Project Versioning .......................................... 45
- 3.6 Working with Audit ......................................... 47
  - 3.6.1 Configuring the Audit Trail database ............ 47
  - 3.6.1.1 Audit Trail multi project database ....... 47
  - 3.6.2 Monitoring a WinCC project with Audit ...... 48
  - 3.6.2.1 Making Audit settings ......................... 49
  - 3.6.2.2 Specify WinCC components for auditing 49
  - 3.6.2.3 Activate document monitoring ............... 51
<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.6.2.4</td>
<td>Monitoring user actions with Audit</td>
<td>52</td>
</tr>
<tr>
<td>3.6.2.5</td>
<td>Monitoring GMP tags with Audit</td>
<td>61</td>
</tr>
<tr>
<td>3.6.2.6</td>
<td>Monitoring electronic signature with Audit</td>
<td>63</td>
</tr>
<tr>
<td>3.6.3</td>
<td>Saving and versioning WinCC project data</td>
<td>67</td>
</tr>
<tr>
<td>3.6.3.1</td>
<td>Enable Document Control</td>
<td>69</td>
</tr>
<tr>
<td>3.6.3.2</td>
<td>Configuring the version number</td>
<td>70</td>
</tr>
<tr>
<td>3.6.3.3</td>
<td>WinCC project files</td>
<td>72</td>
</tr>
<tr>
<td>3.6.3.4</td>
<td>Saving and versioning external data</td>
<td>77</td>
</tr>
<tr>
<td>3.6.3.5</td>
<td>WinCC projects</td>
<td>77</td>
</tr>
<tr>
<td>3.6.4</td>
<td>Viewing audit trails in the Audit Viewer</td>
<td>80</td>
</tr>
<tr>
<td>3.6.4.1</td>
<td>Viewing audit trails in the Audit Viewer</td>
<td>80</td>
</tr>
<tr>
<td>3.6.4.2</td>
<td>Displaying exported audit trails</td>
<td>81</td>
</tr>
<tr>
<td>3.6.4.3</td>
<td>Audit Trail queries</td>
<td>82</td>
</tr>
<tr>
<td>3.6.5</td>
<td>Displaying audit trails in the Audit Viewer Control</td>
<td>84</td>
</tr>
<tr>
<td>3.6.5.1</td>
<td>Audit Viewer Control in the Graphics Designer</td>
<td>84</td>
</tr>
<tr>
<td>3.6.5.2</td>
<td>Configuring the Audit Viewer Control</td>
<td>84</td>
</tr>
<tr>
<td>3.6.5.3</td>
<td>Displaying audit trails in the Audit Viewer Control</td>
<td>86</td>
</tr>
<tr>
<td>3.6.6</td>
<td>Backup and restore database</td>
<td>87</td>
</tr>
<tr>
<td>3.6.7</td>
<td>Writing Audit Trails from external applications into Audit database</td>
<td>89</td>
</tr>
<tr>
<td>3.6.8</td>
<td>Viewing Audit Trails in Information Server</td>
<td>98</td>
</tr>
<tr>
<td>3.6.9</td>
<td>Exporting audit trails to a CSV file</td>
<td>104</td>
</tr>
<tr>
<td>3.6.10</td>
<td>Data conversion</td>
<td>104</td>
</tr>
<tr>
<td>3.6.11</td>
<td>Connecting Audit to Report Designer</td>
<td>105</td>
</tr>
<tr>
<td>3.7</td>
<td>Migration</td>
<td>107</td>
</tr>
<tr>
<td>3.7.1</td>
<td>Migrating audit data</td>
<td>107</td>
</tr>
<tr>
<td>3.7.2</td>
<td>Viewing Audit V7.2 multi-project database</td>
<td>108</td>
</tr>
<tr>
<td>3.7.3</td>
<td>Migrating Document Control and Project Versioning</td>
<td>109</td>
</tr>
<tr>
<td>3.7.4</td>
<td>Migrating user administration</td>
<td>109</td>
</tr>
<tr>
<td>3.7.5</td>
<td>InsertAuditEntry</td>
<td>109</td>
</tr>
</tbody>
</table>

Index | 111
1.1 Scope of delivery

Components of Audit V7.5

Audit V7.5 contains the following components:

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
<th>Requires a WinCC installation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audit Runtime (RT)</td>
<td>Record events from the WinCC configuration and WinCC Runtime and save them as Audit Trails.</td>
<td>Yes</td>
</tr>
<tr>
<td>Audit Viewer</td>
<td>Show exported Audit Trails and Audit Trails from a database.</td>
<td>No</td>
</tr>
<tr>
<td>Audit Document Control and Project Versioning</td>
<td>Save and version WinCC project data.</td>
<td>Yes</td>
</tr>
<tr>
<td>Audit Editor</td>
<td>Specify Audit configurations.</td>
<td>Yes</td>
</tr>
</tbody>
</table>

1) Refer to the system requirements of WinCC.

Additional software

In addition to Audit V7.5, the DVD includes:

<table>
<thead>
<tr>
<th>Program</th>
<th>Description</th>
<th>Requires a WinCC installation</th>
</tr>
</thead>
<tbody>
<tr>
<td>SIMATIC Automation Licence Manager V6.0 SP1</td>
<td>Managing SIMATIC licenses.</td>
<td>No</td>
</tr>
</tbody>
</table>

1.2 Licenses

Introduction

Audit V7.5 is protected by license and can be used with full functionality only with valid licenses. The licenses are delivered via a USB stick together with the ordered software package. To activate the software, the license on the USB stick must be transferred to your hard drive. The license transfer must be completed with the Automation License Manager. If you attempt to transfer the license by other means (for example, Windows Explorer), the license becomes unusable.
## Licenses

Audit provides the following licenses:

<table>
<thead>
<tr>
<th></th>
<th>WinCC Audit RC</th>
<th>WinCC Audit RT</th>
<th>WinCC Audit ChangeControl CC</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Version</strong></td>
<td>7.5</td>
<td>7.5</td>
<td>7.5</td>
</tr>
<tr>
<td><strong>License type</strong></td>
<td>Single</td>
<td>Single</td>
<td>Single</td>
</tr>
<tr>
<td><strong>Validity</strong></td>
<td>Unlimited</td>
<td>Unlimited</td>
<td>Unlimited</td>
</tr>
<tr>
<td><strong>Usage</strong></td>
<td>A PC with WinCC Configuration (Audit full installation).</td>
<td>A PC on which only Audit Runtime is running (installation of individual Audit components).</td>
<td>A PC on which the WinCC configuration changes are activated and recorded (Audit full installation).</td>
</tr>
</tbody>
</table>

### Note

**Setting up PC for central Audit Trail multiproject database**

A PC on which only the Audit Trail multiproject database has to be stored does not require a WinCC and Audit license.

The following installations are required:
- WinCC minimum installation
- Audit Runtime installation

## Functions

The following functions are executed with the licenses:

<table>
<thead>
<tr>
<th>Functions</th>
<th>WinCC Audit RC</th>
<th>WinCC Audit RT</th>
<th>WinCC Audit ChangeControl CC</th>
</tr>
</thead>
<tbody>
<tr>
<td>WinCC Project Versioning and WinCC Document Control.</td>
<td>X</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Configure tracking of changes in WinCC configuration.</td>
<td>X</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Configure tracking of changes in WinCC Runtime.</td>
<td>X</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Saving changes in WinCC configuration to a database.</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Saving changes in WinCC Runtime to a database.</td>
<td>X</td>
<td>X</td>
<td>-</td>
</tr>
</tbody>
</table>
Missing licenses

The following limitations apply if not all Audit licenses are installed:

<table>
<thead>
<tr>
<th>Missing licenses</th>
<th>Effects</th>
</tr>
</thead>
<tbody>
<tr>
<td>WinCC Audit RC</td>
<td>Effect on the Audit configuration:</td>
</tr>
<tr>
<td>WinCC Audit ChangeControl CC</td>
<td>The Audit components are opened write protected.</td>
</tr>
<tr>
<td>WinCC Audit RT</td>
<td>Effect on the Audit Runtime:</td>
</tr>
<tr>
<td></td>
<td>WinCC demo mode is activated if a connection to the Audit Trail Database has been created previously in a WinCC project and if tracking of changes has been configured. The changes are, however, still recorded in the Audit Trail Database.</td>
</tr>
</tbody>
</table>

Installing licenses

Use the Automation License Manager (ALM) for installation of licenses.

For the installation of licenses, the following requirements must be met:

- Audit installation is complete.
- The storage medium containing the licenses must not be write protected.
- Do not install the licenses on a compressed drive.

Note

The licenses remain installed on the system even after uninstalling Audit.

1.3 Installing Audit

Introduction

During installation, select the individual Audit components you want to install on your PC. For a full installation, select all Audit components.

The Audit Viewer is the only Audit component which does not require a WinCC installation. This means you can install the Audit Viewer on any computer in the network.

Uninstalling

To uninstall WinCC/Audit, select all entries that start with "SIMATIC WinCC/Audit" under "Control Panel > Programs and Features".

Requirement

- WinCC V7.5 Update 2 is installed, except for the Audit Viewer installation.
1.4 Upgrading Audit

Note

Hardware and software requirements

It is recommended to install WinCC V7.5 Update 2 to use Audit V7.5.

For hardware and software prerequisites to install Audit V7.5, refer WinCC Information System > Installation Notes > WinCC installation requirements.

All WinCC advanced options follow the same requirements as WinCC.

Procedure

1. Insert the Audit DVD into the DVD drive.
2. Run the setup.
3. Select the desired setup language.
4. Follow the instructions of the installation wizard.
   Read the License Agreement and the Open Source License Agreement.
5. Select the components for your installation.
   Previously installed components are displayed with a blue check mark.
6. Confirm your entries.
7. Start installation.
8. To complete the installation, reboot the system.

Result

Audit V7.5 is installed on the PC.

1.4 Upgrading Audit

Introduction

You can upgrade to Audit V7.5 through an upgrade installation. You need to upgrade licenses of Audit prior to V7.5 to the current version.

If you currently have Audit V7.2 or higher installed on your system, you can perform the upgrade installation.

Upgrade preparation

Backing up a WinCC project

Make a backup copy of your project before upgrading Audit.
Restart PC before installing the update
Restart the PC before installing the update to Audit V7.5.

Procedure to upgrade licenses
1. Open Automation License Manager.
2. Transfer the upgrade license keys to the drive where the current version licenses are available.
3. In the menu bar, select "License Key > Upgrade". This operation will merge the old license and the upgrade license into one new license. Hence, three new licenses will be created.

1.5 User authentication
A user authentication is executed by the "SIMATIC Logon" program when you open the following Audit components:
- Audit Editor
- Audit Document Control and Project Versioning

The program checks if the user is a member of the "SIMATIC HMI AUDIT" user group. For users to have access to all functions of Audit component functions, they need to be registered as members of the "SIMATIC HMI AUDIT" user group. The user group is created locally with the Audit installation in the Windows user and group management.

The Audit components are opened in read-only mode in the following situations:
- SIMATIC Logon is not installed.
- The user is not a member of the "SIMATIC HMI AUDIT" Windows user group.
- The authentication process is canceled by the user.

For additional information, refer to the SIMATIC Logon help.
1.5 User authentication
2.1 Notes on Audit

Content

These release notes contain important information.

The statements in these Release Notes supersede the instructions in the manuals and in the online help.

Read these release notes carefully as they contain useful information.

General information

Migration of V7.3 to V7.5

If you migrate from WinCC/Audit V7.3 to 7.5, all files must be checked in advance by Audit DCPV.

Text Library

Note the following behavior during auditing when you work with the Text Library:

- A text is entered in any language column in an existing text line.
  The Audit Trail entry includes the language of the modified language column in the Text Library as "Target Name".

- A new text line and a text is entered in any language column.
  The Audit Trail entry contains the language that is the first position in the text library as "Target name" in the menu bar under "View > Input language".

- An existing text line is copied. A new text line is created during pasting.
  The Audit Trail entry contains the language that is the first position in the text library as "Target name" in the menu bar under "View > Input language".

Report Designer

If you are using a WinCC project with Audit V7.3 and want to open and use the WinCC project with Audit V7.5, you must re-configure the print jobs. The name of the report layouts have changed.

Procedure

1. In the WinCC Report Designer, select the print job that you have used in Audit V7.3.
2. Select the "Properties" option from the shortcut menu.
3. Select the new layout file in the "General" tab.
4. Click "OK" to confirm your entries.

**Migration**

The migration of Audit configurations and Audit trails from Audit V7.2, V7.3 and V7.4 single project database to Audit V7.5 is supported.

**Audit Editor**

**Changing GMP tags in the tag management**
If you rename a GMP tag in the tag management, the renamed GMP tag is not updated in the Audit Editor under "GMP tags (RT)".
Delete the renamed GMP tag under GMP tags (RT) in the Audit Editor and create a new GMP tag.

**Working with "GMP tags (RT)"**
Undo/Redo does not work under "GMP tags (RT)" in the Audit Editor.

**Undo/Redo**

In the Audit Editor, the Undo/Redo function is not possible for some configurations.

**Audit Viewer**

**Changing the values in the "Maximum record count to display in grid" column**
If you change the values under "Maximum record count to display in grid" in the settings in the Audit Viewer, this change is not performed.
Select the "Refresh" button on the toolbar in the Audit Viewer to display the changed values.

**Changing entries in "Date & Time"**
If you change the "Date & Time" values in with an exported XML file, the changed values are highlighted in red after importing.

**Value change as numerical code**
When an audit saves an event to the Audit Trail Database, the values in the columns "Old Value" and "New Value" are partially displayed as numerical code.
This is true for texts, for example, which are selected from a list or when using hotkeys.
Audit Document Control and Project Versioning

Archiving closed WinCC projects
The following requirements apply to archiving closed WinCC projects:

- Versioning must be configured before archiving.
- The WinCC projects must be located on the same PC on which Audit Document Control and Project Versioning is started.

Restore previous versions
When you delete project files in your WinCC project, you can only restore these files if the original project files are still available.

Multi-user project and client without their own project
Audit Document Control and Project Versioning is not approved for a multi-user project or client without their own project.

2.2 New functionalities

Audit Editor

Support for tracking DCF (distribution file) file type
Audit shall track DCF file type available in a WinCC project.

New WinCC component to configure text and graphics
A new WinCC component “Text and graphic lists” is added to the Audit Editor.

Audit Viewer and Audit Viewer Control

Trail record count in status bar
The status bar in the Viewer control displays information about the current page number, total number of pages and total number of trail records in the database.

Title of Audit Viewer Control
The title of the Audit Viewer Control can be changed/renamed during creation.

User queries
User queries can be created, executed and viewed for exported audit files.

ID column in Audit trails
The ID column is now hidden by default as the values in the column are not continuous and are not related to Audit trails.
Print configuration in Runtime
The Print configuration is now enabled in the Runtime.

Audit Document Control and Project Versioning

Tracking corrupted configuration file
A popup dialog now appears when the user launches DCPV for a project with an altered Project Versioning file. This allows the user to either restore the current Project Versioning file or retain the altered file.

Viewing file types
It is now possible to view all the listed file types supported by DCPV and their statuses in the table area under the "Document Control" root node. This is also applicable for the nodes under it.

You can perform operations like "Check In", "Check Out", "Copy", "Paste" and so on, at "Document Control" root node and at every subsequent node.

General

Interface language
The interface language of Audit Editor, Viewer and DCPV when launched depends on the user interface language of WinCC Explorer.

Electronic signatures
Electronic signatures are introduced to track critical actions that require clearance from personnel and audit trails are generated for these actions. The users are configured and the signatures are password protected.

User operator messages
The comments entered in the window dialog for the C script function "GCreateMyOperationMsg" is also stored in Audit Trail DB.

2.3 Service and Support

2.3.1 Warnings

Safety information

Warning notice system
This manual contains notices you must observe to ensure your personal safety and to prevent damage to property. Notices referring to your personal safety are highlighted in the manual by
a safety alert symbol; notices referring to property damage only have no safety alert symbol. The warning notices shown below are graded according to the degree of danger.

| DANGER | indicates that death or severe personal injury will result if proper precautions are not taken. |
| WARNING | indicates that death or severe personal injury may result if proper precautions are not taken. |
| CAUTION | indicates that minor personal injury may result if proper precautions are not taken. |
| NOTICE | indicates that property damage may result if proper precautions are not taken. |

Note indicates important information about the product and its use or a specific section of the documentation to which you should pay particular attention.

If more than one degree of danger is present, the warning notice representing the highest degree of danger will be used. A warning notice of injury to persons with a safety alert symbol may also include a warning relating to property damage.

Qualified personnel

The product/system described in this documentation may be operated only by personnel qualified for the specific task in accordance with the relevant documentation, in particular its warning notices and safety information. Qualified personnel are those who, based on their training and experience, are capable of identifying risks and avoiding potential hazards when working with these products/systems.

Proper use

Note the following:

<table>
<thead>
<tr>
<th>WARNING</th>
<th>Proper use of Siemens products</th>
</tr>
</thead>
</table>

Siemens products may only be used for the applications described in the catalog and in the relevant technical documentation. If products and components from other manufacturers are used, these must be recommended or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and maintenance are required to ensure that the products operate safely and without any problems. The permissible ambient conditions must be adhered to. The information in the relevant documentation must be observed.
Trademarks

All names identified by ® are registered trademarks of Siemens AG. The remaining names in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Security information

Siemens provides products and solutions with industrial security functions that support the secure operation of plants, systems, machines and networks.

In order to protect plants, systems, machines and networks against cyber threats, it is necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial security concept. Siemens’ products and solutions only form one element of such a concept.

Customers are responsible for preventing unauthorized access to their plants, systems, machines and networks. Systems, machines and components should only be connected to the enterprise network or the Internet if necessary and only to the extent necessary and with appropriate protective measures (e.g. use of firewalls and network segmentation) in place.

Additionally, Siemens’ guidance on appropriate security measures should be taken into account. For more information about industrial security, please visit

- AUTOHOTSPOT

Siemens’ products and solutions undergo continuous development to make them more secure. Siemens strongly recommends applying product updates as soon as they are available and always using the latest product versions. Using versions that are obsolete or are no longer supported can increase the risk of cyber threats.

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed under

- AUTOHOTSPOT

Disclaimer of liability

We have reviewed the contents of this publication to ensure consistency with the hardware and software described. However, since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the information in this publication is reviewed regularly and any necessary corrections are included in subsequent editions. Suggestions for improvement are welcomed.

Information in the online documentation is more binding than that in the manuals and PDF files. Observe the Release Notes and Installation Notes. Information in the Release Notes and Installation Notes is more binding than that in the manuals and online help.

Copyright © Siemens AG 2017

All rights reserved

The reproduction, transmission or use of this document or its contents is not permitted without express written authorization. Offenders will be held liable for payment of damages. All rights, including rights created by patent grant or registration of a utility or design, are reserved.

Siemens AG
2.3.2 Customer support

Customer Support and Technical Support

You can reach the SIMATIC hotlines at the times specified in the following table. The SIMATIC hotline employees speak German and English. The Authorization hotline offers French, Italian or Spanish customer support in addition to German and English.

Technical support

<table>
<thead>
<tr>
<th>Service</th>
<th>Customer hotline employees speak German and English.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Nuremberg (GMT +1:00)</td>
<td>Service Monday - Friday, 8:00 to 17:00 (CET/CEST)</td>
</tr>
<tr>
<td>Phone</td>
<td>+49 (0)911 895 7222</td>
</tr>
<tr>
<td>Fax</td>
<td>+49 (0)911 895 7223</td>
</tr>
<tr>
<td>E-mail</td>
<td><a href="https://support.industry.siemens.com/My/ww/en/requests">https://support.industry.siemens.com/My/ww/en/requests</a></td>
</tr>
</tbody>
</table>

An overview of the Technical Support is available at the following URL:


Automation Value Card (AVC)

The Automation Value Card (AVC) provides extended Technical Support and is available 24 hours every day of the week. Information on the AVC can be found at the following URL:


SIMATIC Customer Online Support

Service and Support

An overview of the support offering for our products is available at the following URL:

- https://support.industry.siemens.com/

In Product Support, for example, you will find downloads of firmware updates, service packs and useful utilities.

Online Help is available so that you can successfully use the Support offering. Open the Online Help by selecting the corresponding button on the Internet site or at the following URL:

The app is available for mobile Siemens Support:

- https://support.industry.siemens.com/cs/sc/2067

**WinCC FAQs**

WinCC Online Support with information on FAQs (Frequently Asked Questions) may also be found at the following URL:


**Technical Forum**

The Technical Forum supports exchange with other SIMATIC users. It is available at the following URL:

- https://support.industry.siemens.com/tf/

**Technical documentation for SIMATIC products**

You can find a guide to the technical documentation provided for individual SIMATIC products and systems at the following URL:


**Contact person database**

To contact your local agent, search our contact database at the following URL:

- http://w3.siemens.com/aspa_app/

**Product Information**

**SIMATIC WinCC**

Go to the following URL for additional information about WinCC products:

- http://www.siemens.com/wincc

**SIMATIC Products**

Go to the following URL for additional information about SIMATIC products:

- http://www.siemens.com/simatic

### 2.3.3 Support Request

Dear customer

In order to provide you with fast and effective support, please complete the "Support Request" form online on the Internet. Describe the problem in as much detail as possible. We would appreciate if you would provide us with all project data, so that we can reproduce the error situation or shorten the turn-around time.

Before filling out the support request, check whether your configured quantity structure is within the range of tested quantity structures (see topic "Performance Data").
Support Request form

The Support Request form is available at the following URL:

- http://www.siemens.com/automation/support-request

When filling out the report, you will be guided through several steps, which will ask about all required information.

A detailed description of the Support Request can be found at the following URL:


Procedure

1. Open the "Support Request" form using the link on the Internet. Step 1 "Select product" is displayed:

2. Enter the project name in the "Product/Order number" box. Upper/lower case is not relevant. Search for parts of the product name or enter the full product name in the correct order. You can e.g. search for the following terms:
   - "WinCC Runtime"
   - "WinCC DataMonitor"
   - "wincc webnavigator"
   - "Connectivity"
   The found products are offered in the "Product selection" field.

3. Select the desired product and click on "Next" to switch to step 2 "Select use case".

4. Select a use case or describe your specific use case in the "Other use case" field.

5. Press "Next" to switch to step 3 "Our solutions".
   Suggested solutions and FAQs for the selected key words are listed.
   Once you have found a suggested solution for your problem, you can close the form in the browser.
   If you did not find any applicable suggested solutions, press "Next" to switch to step 4 "Describe problem".

6. Describe your problem as exactly as possible in the "Details" field.
   Pay particular attention to the following questions and comments. Please also check the WinCC installation and configuration with regard to the following references.
   If you have any idea what has caused the error, please let us know. No detail should be omitted, even if you consider it unimportant.
   - Was the configuration data created with older WinCC versions?
   - How can the error be reproduced?
   - Are other programs running simultaneously with WinCC?
   - Have you deactivated the screen saver, virus checker and power management function?
   - Search the computer for log files (WinCC\Diagnose\*.log, drwatson.log, drwtsn32.log).
   The log files are needed for error analysis. Thus, be sure to send the log files as well.

7. Use the "Search" button to upload your affected project and the log files (e.g. as a Zip file) to the Support Request.
   Press "Next" to switch to step 5 "Provide contact information".
8. Enter your contact information.
   Read the privacy notice and choose whether your personal data should be permanently
   saved.
   Press "Next" to switch to step 6 "Summary & Send".

9. Press the "Print" button if you would like to print the support request.
   You close the support request by clicking the "Send" button.
   Your data will be transmitted to Customer Support and processed there.

Thank you for your cooperation. We hope that we can be of assistance in solving your problems.

Your WinCC Team
3.1 Using Audit

Introduction

WinCC/Audit is a WinCC option for monitoring WinCC configurations and user activities in WinCC Runtime.

Components of Audit

Audit contains the following components:

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audit Editor</td>
<td>Specify Audit configurations.</td>
</tr>
<tr>
<td>Audit Runtime (RT)</td>
<td>Record events from the WinCC configuration and WinCC Runtime and save them as Audit Trails.</td>
</tr>
<tr>
<td>Audit Viewer Control</td>
<td>Show exported Audit Trails and Audit Trails from a database.</td>
</tr>
<tr>
<td>Audit Viewer</td>
<td>Display audit trails from a database in WinCC Runtime.</td>
</tr>
<tr>
<td>Audit Document Control and Project Versioning</td>
<td>Save and version WinCC project data.</td>
</tr>
</tbody>
</table>

Using Audit

Audit records WinCC engineering changes and user actions in runtime in so-called audit trails (audited events). The Audit Viewer allows the specific display and analysis of audit trails.

The document control allows the document management of WinCC screens, C and VBS functions, reports and user documents. You can use project versioning to archive complete WinCC projects and restore project versions.

Application examples

Audit supports operation and maintenance for the following users:

- Operators of validated plants in the pharmaceutical industry.
- Tracking & tracing for plant operators, for example, in the food and beverage industry.
- Serial equipment manufacturer with different versions of a central project.
- OEMs who maintain plants for their customers worldwide.
- Users who need to ensure gapless recording of operator actions for the purpose of traceability.
- Users who need to implement the requirements of the FDA (Food and Drug Administration).
3.2 Important information about the Audit Viewer

The Audit Viewer requires special Windows rights.

The Windows user using the Audit Viewer must be a member of the user group "SIMATIC HMI".

If WinCC is installed on a PC in addition to the Audit Viewer, the user group exists already.

"Standalone" Audit Viewer

The Audit Viewer can also be used as a "stand-alone installation" on a PC without WinCC.

The "SIMATIC HMI" user group is created locally with this installation in the Windows user and group management.

Note

The Windows user performing the Audit installation is automatically registered as a member of the "SIMATIC HMI" user group.

Additional Windows user using the Audit Viewer must be subsequently registered as members of the user group.

After registration in the user group, the Windows user has to log on again in Windows.

3.3 Approved configurations

3.3.1 Local WinCC scenario

A PC on which a WinCC project is running and Audit is installed is not connected to any other PC. The Audit trails are written to a local multiproject database or a remote multiproject database.

Note

Database location with local WinCC scenarios

The database location does not play a role in the following scenario. The configuration graphic is therefore shown with a simplified display. Depending on the scenario, multiple databases may be available.
3.3.2 WinCC remote scenarios

Introduction

A PC on which a WinCC project is running and Audit is installed is connected to other PCs. WinCC and Audit are also installed on the other PCs. The remote scenarios are than as follows. The Audit trails are written to a local multiproject database or a remote multiproject database.

Note

Database location in remote scenarios

The database location does not play a role in the individual scenarios. The configuration graphics are therefore shown with a simplified display. Depending on the scenario, multiple databases may be available.

Note

Combination of remote scenarios

A combination of the individual remote scenarios is possible.

Remote configuration:

The WinCC project that is located on the file server is opened via the Engineering Station (ES). The project type plays no role in this. All events executed on the ES are recorded by the file server and written to the Audit Trail database.
3.3 Approved configurations

Multi-user project and client without own project

The WinCC project located on the server is opened via the client. All events that are executed on the client are recorded by the server and written to the Audit Trail database.
Audit Document Control and Projekt Versioning

Audit Document Control and Project Versioning has not been approved for a multi-user project or client without its own project.

A client with its own project

A client project with its own configuration is running on the client. The events triggered by the client via `InsertAuditEntryNew` and configuration changes are recorded by the client and written to the Audit Trail database. The runtime events triggered by the client are recorded by the server and written to the Audit Trail database.

Redundancy

A WinCC project is running redundantly on two PCs. To generate a redundancy, the WinCC project is duplicated using the WinCC Project Dublicator. Each PC records its events and writes the events to the Audit Trail database. A multiproject database is recommended for both WinCC projects.
Engineering scenario

A WinCC project is running on a Engineering Station (ES). The project is transferred to an Operator Station (OS) via the WinCC Project Duplicator or complete loading in SIMATIC Manager. The division of Engineering and Runtime takes place on two PCs. The Engineering Station records all configuration changes and writes these to the Audit Trail database. The Operator Station records all events via InsertAuditEntryNew and Runtime and writes the events to the Audit Trail database.
3.4 Audit basics

3.4.1 Logon

Introduction

Logging on in Audit is performed through an authentication in "SIMATIC Logon". Each Audit user has the same rights. The following audit components require authentication:

- Audit Editor
- Audit Document Control and Project Versioning

If you do not authenticate yourself, the Audit components are opened read-only. This means that not all of the Audit functions will be available.

You can authenticate yourself later via the shortcut menu in Audit Editor.

You can authenticate yourself later via the menu bar in Audit Document Control and Project Versioning.

Requirement

- "SIMATIC Logon" is installed on your computer.
- You are a member of the "SIMATIC HMI AUDIT" user group.

Procedure

1. Open the desired audit component.
   A SIMATIC Logon dialog appears.
2. Enter your user name and password.
3. Confirm your entries with "OK".

Result

You have authenticated yourself and can use all Audit functions.
3.4.2 Changing the interface language

The interface language of Audit Editor, Viewer and DCPV when launched depends on the user interface language of WinCC Explorer.

To change the interface language, select "Options > Language" in the WinCC Explorer menu bar.

Audit Viewer, and Audit Document Control and Project Versioning

The user interface of the Audit Viewer, and Audit Document Control and Project Versioning can also be set in the respective editors.

To change the interface language, select "Options > Language" in Viewer/DCPV editor menu bar.

3.4.3 Audit components

3.4.3.1 Audit Editor

Function

You can use the Audit Editor to define the activities you would like to audit in your WinCC project:

- Activities in the individual WinCC components
- Activities in user and configuration files
- Runtime operation of objects

The settings in the Audit Editor are made with check boxes that you can select or clear.

The server of the Audit Trail database is also selected in the Audit Editor. The audit trails are stored in the Audit Trail database.

The configuration changes within the Audit Editor are also saved as audit trails in the Audit Trail database.

Open Audit Editor

When you open a WinCC project after installing the Audit Editor, the Audit icon appears in the navigation area. Double-click the Audit icon or open the Audit Editor from the shortcut menu.
The Audit Editor has the following layout:

1. **Menu bar:**
   The menu bar contains commands to perform common functions in the Audit Editor.

2. **Navigation area:**
   The navigation area displays the objects of the Audit Editor in a tree view.

3. **Table area:**
   The table area displays the data records of the objects that are selected in the navigation area.
   In quick search, you search the table area for entries.

4. **"Properties" window:**
   The "Properties" window displays the properties of a data record.

5. **Navigation bar:**
   In the navigation bar, you switch between the WinCC editors.

6. **Status bar:**
   The status bar shows the various states of the Audit Editor.
Menu commands in the menu bar

The menu bar contains some of the commands that you can call in the Audit Editor. Commands that you cannot use in the current situation are disabled (displayed in gray). Commands that you can call from the shortcut menu are described in the individual sections in which they are used.

The following tables show the commands in the menu bar and the associated functions:

The "File" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Documentation - Setup</td>
<td>No function.</td>
</tr>
<tr>
<td>Project Documentation - Preview</td>
<td>No function.</td>
</tr>
<tr>
<td>Project Documentation - Print</td>
<td>No function.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the Audit Editor.</td>
</tr>
</tbody>
</table>

The "Edit" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Copies the text of the selected object.</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes the text of the copied object.</td>
</tr>
<tr>
<td>Undo</td>
<td>Undoes an action.</td>
</tr>
<tr>
<td>Redo</td>
<td>Redoes the last action.</td>
</tr>
<tr>
<td>Import</td>
<td>Imports the Audit settings from a .txt or .xlsx file.</td>
</tr>
<tr>
<td>Export</td>
<td>Exports the Audit settings into a .txt or .xlsx file.</td>
</tr>
</tbody>
</table>

The "View" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input language</td>
<td>No function.</td>
</tr>
<tr>
<td>Color scheme</td>
<td>Changes the color setting in the Audit Editor.</td>
</tr>
</tbody>
</table>

The "Tools" menu includes the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macros</td>
<td>Opens a dialog box in which you can create macros.</td>
</tr>
<tr>
<td>Visual Basic Editor</td>
<td>Opens the Visual Basic Editor.</td>
</tr>
</tbody>
</table>
The "Help" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents and Index</td>
<td>Opens the online help of the Audit Editor.</td>
</tr>
<tr>
<td>Info about WinCC Configuration Studio</td>
<td>Opens an information window for the WinCC Configuration Studio.</td>
</tr>
</tbody>
</table>

3.4.3.2 Audit Viewer

Function

The Audit Viewer is a viewer program for audit trails. You can view following with the Audit Viewer:

- Audit trails that are saved in an Audit Trail database
- Exported audit trails

You can limit your Audit Trail views using pre-defined queries. You can create and save your own queries.

Open Audit Viewer

Open the Audit Viewer by double-clicking on the Audit Viewer icon on your desktop. As an alternative, open the Audit Viewer via the Windows Start menu or "Apps".

Opening the Audit Viewer in the WinCC Explorer

When you open a WinCC project after installing the Audit Viewer, the Audit icon appears in the navigation area. Open the Audit Viewer from the shortcut menu.
Layout

The Audit Viewer has the following layout:

1. **Menu bar:**
   - The menu bar contains commands to perform special functions in the Audit Viewer.

2. **Toolbar:**
   - The toolbar contains buttons to perform special functions in the Audit Viewer.

3. **Navigation area:**
   - The navigation area displays the objects of the Audit Viewer in a tree view.

4. **Table area:**
   - The table area displays the data records of the objects that are selected in the navigation area.
   - In quick search, you search the table area for entries.
Menu commands in the menu bar

The menu bar contains most of the commands that you can use in the Audit Viewer. Commands that you cannot use in the current situation are disabled (displayed in gray). Commands that you can call from the shortcut menu are described in the individual sections in which they are used.

The following tables show the commands in the menu bar and the associated functions:

The "File" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update server data</td>
<td>Updates the data of the server.</td>
</tr>
<tr>
<td>Update view</td>
<td>Refreshes the view in the table area.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the contents of the category or query that is selected in the navigation area.</td>
</tr>
<tr>
<td>Print configuration</td>
<td>Opens a dialog box in which you can specify the columns for printing.</td>
</tr>
<tr>
<td>Export to CSV file</td>
<td>Exports the selected audit trails to a CSV file.</td>
</tr>
<tr>
<td>Show Audit File</td>
<td>Displays a selected Audit file in the Audit Viewer.</td>
</tr>
<tr>
<td>Recent Servers</td>
<td>Lists the servers already in use.</td>
</tr>
<tr>
<td>Recent Files</td>
<td>Opens a list of recently opened files.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the Audit Viewer.</td>
</tr>
</tbody>
</table>

The "Queries" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Query</td>
<td>Creates a new query.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected query.</td>
</tr>
<tr>
<td>Rename</td>
<td>Renames the selected query.</td>
</tr>
<tr>
<td>Run</td>
<td>Executes the selected query.</td>
</tr>
</tbody>
</table>
The "Options" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Language</td>
<td>Changes the user interface language of the Audit Viewer.</td>
</tr>
<tr>
<td>Settings</td>
<td>The following settings can be made:</td>
</tr>
<tr>
<td></td>
<td>• Maximum number of data records that can be saved in the table area.</td>
</tr>
<tr>
<td></td>
<td>• Path to the user-defined queries.</td>
</tr>
</tbody>
</table>

The "Help" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents and Index</td>
<td>Opens the online help of the Audit Viewer.</td>
</tr>
<tr>
<td>About</td>
<td>Opens an information window for the Audit Viewer.</td>
</tr>
</tbody>
</table>

Buttons in the toolbar

The toolbar in the Audit Viewer contains the following functions:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Tooltip</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Update server data</td>
<td>Updates the data of the server. Updates user queries.</td>
</tr>
<tr>
<td></td>
<td>Update view</td>
<td>Refreshes the view in the table area.</td>
</tr>
<tr>
<td></td>
<td>New Query</td>
<td>Creates a new query.</td>
</tr>
<tr>
<td></td>
<td>Delete</td>
<td>Deletes the selected query.</td>
</tr>
<tr>
<td></td>
<td>Run</td>
<td>Executes the selected query.</td>
</tr>
<tr>
<td></td>
<td>First page</td>
<td>Navigates to the first page to display Audit Trails.</td>
</tr>
<tr>
<td></td>
<td>Next page</td>
<td>Navigates to the next page to display Audit Trails.</td>
</tr>
<tr>
<td></td>
<td>Previous page</td>
<td>Navigates to the previous page to display Audit Trails.</td>
</tr>
<tr>
<td></td>
<td>Last page</td>
<td>Navigates to the last page to display Audit Trails.</td>
</tr>
<tr>
<td></td>
<td>Settings</td>
<td>The following settings can be made:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Maximum number of data records that can be displayed in the table area (100 to 50000 records).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Path to the user-defined queries.</td>
</tr>
<tr>
<td></td>
<td>Close result view</td>
<td>Closes the result view in the table area after executing a query.</td>
</tr>
<tr>
<td></td>
<td>Export to CSV file</td>
<td>Exports the selected audit trails to a CSV file.</td>
</tr>
<tr>
<td></td>
<td>Print configuration</td>
<td>Opens a dialog box in which you can specify the columns for printing.</td>
</tr>
</tbody>
</table>
Meaning of the columns

Audit trails have a defined structure that is displayed in the Audit Viewer.

<table>
<thead>
<tr>
<th>Column header</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID (hidden)</td>
<td>ID of the recorded audit trails. The numbering is not sequential and does not impact audit trails.</td>
</tr>
<tr>
<td>Project ID (hidden)</td>
<td>Audit ID of the audited WinCC project.</td>
</tr>
<tr>
<td>Project Name</td>
<td>Project name of the audited WinCC project.</td>
</tr>
<tr>
<td>Audit Type</td>
<td>Area from which the event originates.</td>
</tr>
<tr>
<td>Category ID</td>
<td>Change category</td>
</tr>
<tr>
<td>Subcategory ID</td>
<td>Subcategory of the change.</td>
</tr>
<tr>
<td>Target ID (hidden)</td>
<td>ID from a WinCC database.</td>
</tr>
<tr>
<td>Target Name</td>
<td>Name of the changed element.</td>
</tr>
<tr>
<td>Specific Change ID</td>
<td>Type of change made.</td>
</tr>
<tr>
<td>Modification ID</td>
<td>Performed change.</td>
</tr>
<tr>
<td>Old Value</td>
<td>If a data change was made, the old value is displayed here.</td>
</tr>
<tr>
<td>New Value</td>
<td>If a data change was made, the new value is displayed here.</td>
</tr>
<tr>
<td>Date Time</td>
<td>Date and time information (UTC) when the change was made.</td>
</tr>
<tr>
<td>Time Zone Offset</td>
<td>Time difference to Coordinated Universal Time (UTC).</td>
</tr>
<tr>
<td>Windows User</td>
<td>Name of the Windows user who performed the change.</td>
</tr>
<tr>
<td>Application User</td>
<td>Name of the application user who performed the change.</td>
</tr>
<tr>
<td>Computer Name</td>
<td>Computer name on which the change was made.</td>
</tr>
<tr>
<td>Operator Message ID</td>
<td>Message number</td>
</tr>
<tr>
<td>Reason</td>
<td>Comments or further information about the event.</td>
</tr>
</tbody>
</table>

Migrated audit trails are displayed in the following columns:

<table>
<thead>
<tr>
<th>Column header</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Legacy Project GUID</td>
<td>Project ID of the audited WinCC project prior to V7.5.</td>
</tr>
<tr>
<td>Legacy Database Name</td>
<td>WinCC database name of the previous version of V7.5.</td>
</tr>
<tr>
<td>Legacy Application Name</td>
<td>Name of the application of the previous version of V7.5.</td>
</tr>
<tr>
<td>Legacy Table Name</td>
<td>Name of the SQL table of the previous version of V7.5.</td>
</tr>
<tr>
<td>Legacy Field Name</td>
<td>Field name of the previous version of V7.5.</td>
</tr>
<tr>
<td>Legacy Event Type</td>
<td>Performed change of the previous version of V7.5.</td>
</tr>
<tr>
<td>Legacy Event Item</td>
<td>Changed item of the previous version of V7.5.</td>
</tr>
</tbody>
</table>
3.4.3.3 Audit Viewer Control

Function

The Audit Viewer Control is an ActiveX control that is embedded in the Graphics Designer as an OCX file.

You can use the Audit Viewer Control in a process picture (.pdl) to view the stored audit trails and evaluate them in Runtime. The user interface is identical to the one in Audit Viewer. There is no menu bar, only the toolbar with a reduced number of icons. Exported audit trails cannot be displayed in the Audit Viewer Control.

You can find additional information under:
- Audit Viewer (Page 81)

3.4.3.4 Audit Document Control and Project Versioning

Function

Audit Document Control and Project Versioning contains the following functions:

- Versioning of projects and files
- Checking in and checking out individual files
- Restoring previous versions

All activities performed in Audit Document Control and Project Versioning can be saved as audit trails in the Audit Trail database. They first have to be configured in the Audit Editor.

Opening Audit Document Control and Project Versioning

When you open a WinCC project after installing the Audit Document Control and Project Versioning, the Audit icon appears in the navigation area. Open Audit Document Control and Project Versioning in the shortcut menu, or double-click the Audit DCPV icon on your desktop.

As an alternative, open Audit Document Control and Project Versioning with the Windows Start menu or "Apps".

Opening Audit Document Control and Project Versioning in the Audit Editor

You can also open the Audit Document Control and Project Versioning from the Audit Editor:

1. In the Audit Editor, click "Document Control and Project Versioning" under "Audit Settings" in the navigation area.
2. Select "Open" from the shortcut menu.
Audit Document Control and Project Versioning has the following layout:

1. **Menu bar:**
   The menu bar contains commands to perform special functions in the Audit Document Control and Project Versioning.

2. **Toolbar:**
   The toolbar contains buttons to perform special functions in the Audit Document Control and Project Versioning.

3. **Navigation area:**
   The navigation area displays the objects of the Audit Document Control and Project Versioning in a tree view.

4. **Table area:**
   The table area displays the data records of the objects that are selected in the navigation area.
   In quick search, you search the table area for entries.
Navigation bar:
The navigation bar shows the editor you are in.

Status bar:
The status bar displays various information about the Audit Document Control and Project Versioning.

Menu commands in the menu bar

The menu bar contains most of the commands that you can use in the Audit Document Control and Project Versioning. Commands that you cannot use in the current situation are disabled (displayed in gray). Commands that you can call from the shortcut menu are described in the individual sections in which they are used.

The following tables show the commands in the menu bar and the associated functions:

The "Document" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Document Control</td>
<td>Activates the document control.</td>
</tr>
<tr>
<td>Disable Document Control</td>
<td>Deactivates the document control.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes Audit Document Control and Project Versioning.</td>
</tr>
</tbody>
</table>

The "Project" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Archive Project</td>
<td>Archives a WinCC project.</td>
</tr>
<tr>
<td>Current Project History</td>
<td>Displays the project history of the current WinCC project.</td>
</tr>
<tr>
<td>Complete Project History</td>
<td>Displays the project history of all archived WinCC projects.</td>
</tr>
</tbody>
</table>

The "Label" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply Label</td>
<td>Opens a dialog box to apply a label.</td>
</tr>
<tr>
<td>View Label</td>
<td>Displays all applied labels.</td>
</tr>
</tbody>
</table>

The "Options" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Login</td>
<td>Login of the user.</td>
</tr>
<tr>
<td>User Logout</td>
<td>Logout of the user.</td>
</tr>
<tr>
<td>Language</td>
<td>Changes the user interface language of Audit Document Control and Project Versioning.</td>
</tr>
</tbody>
</table>
The "Help" menu contains the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents and Index</td>
<td>Opens the online help of Audit Document Control and Project Versioning.</td>
</tr>
<tr>
<td>About</td>
<td>Opens an information window for Audit and Project Document Versioning.</td>
</tr>
</tbody>
</table>

Buttons in the toolbar

The toolbar in Audit Document Control and Project Versioning contains the following functions:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Tooltip</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>🌐</td>
<td>Enable Document Control</td>
<td>Activates the document control.</td>
</tr>
<tr>
<td>🌐</td>
<td>Disable Document Control</td>
<td>Deactivates the document control.</td>
</tr>
<tr>
<td>📦</td>
<td>Archive Project</td>
<td>Archives a WinCC project.</td>
</tr>
<tr>
<td>📡</td>
<td>Current Project History</td>
<td>Displays the project history of the current WinCC project.</td>
</tr>
<tr>
<td>🌱</td>
<td>Complete Project History</td>
<td>Displays the complete project history of all archived WinCC projects.</td>
</tr>
<tr>
<td>✉️</td>
<td>Apply Label</td>
<td>Opens a dialog box to apply a label.</td>
</tr>
<tr>
<td>📝</td>
<td>View Label</td>
<td>Displays all applied labels.</td>
</tr>
<tr>
<td>⚒️</td>
<td>User Login</td>
<td>Login of the user.</td>
</tr>
<tr>
<td>⚒️</td>
<td>User Logout</td>
<td>Logout of the user.</td>
</tr>
<tr>
<td>🌡️</td>
<td>Show system pictures (@-prefix)</td>
<td>Show WinCC project files that have the &quot;@&quot; prefix.</td>
</tr>
<tr>
<td>🌡️</td>
<td>Hide system pictures (@-prefix)</td>
<td>Hide WinCC project files that have the &quot;@&quot; prefix.</td>
</tr>
<tr>
<td>🗑️</td>
<td>Show deleted files</td>
<td>Show WinCC project files that were deleted.</td>
</tr>
<tr>
<td>🗑️</td>
<td>Hide deleted files</td>
<td>Hide WinCC project files that were deleted.</td>
</tr>
<tr>
<td>🌐</td>
<td>Close result tab</td>
<td>Closes the &quot;Compare Result&quot; tab.</td>
</tr>
<tr>
<td>🌐</td>
<td>Help</td>
<td>Opens the online help of Audit Document Control and Project Versioning.</td>
</tr>
</tbody>
</table>

3.5 Basic procedure

3.5.1 Working with WinCC/Audit

Procedure

In Audit Editor, the direct help for the selected field is available in the "Properties" window.
To manage and monitor a WinCC project or project data in Audit, follow the steps of the procedure.

You must be authenticated to work with the Audit Editor.

**Note**

**WinCC Audit ChangeControl CC license**

If you have installed only the WinCC Audit ChangeControl CC license, the Audit Editor includes only the "WinCC Configuration" and "WinCC Documents" components under "Audit Settings".

---

**Step 1: Connect the Audit Trail server**

1. To display the Audit Trail servers, click "Select Audit Trail server" in the navigation area.
2. Select the Audit Trail server on which the Audit Trail Database is located or is going to be created.
   
   To do so, select the entire table row.
3. Select "Select Server" in the shortcut menu.

**Step 2: Specify WinCC components for auditing**

1. Click "Audit Settings" in the navigation area.
2. In the "WinCC Configuration" line, select the check box in the "Activated" column.
3. To specify the monitoring for individual WinCC components, click "WinCC Configuration" under "Audit Settings" in the navigation area.
4. Select or clear the check box for the respective component in the "Activated" column.
   
   To activate or deactivate all components, select the column "Activated" and select "Select all" or "Deselect all" in the shortcut menu.

**Step 3: Activate document monitoring**

Activate the "WinCC Documents" component under "Audit Settings".

The following events are saved in the Audit Trail database for the monitored documents:

- Create
- Edit
- Delete

**Step 4: Activate electronic signature**

Activate the "Electronic Signature (RT)" component under "Audit Settings". This begins the monitoring of electronic signature messages and are written to the Audit trail database.

Make sure "Alarm Logging Runtime" is activated in the startup list in the computer properties before you activate electronic signature in Audit Editor.
Step 5: Enable document control and archive WinCC projects

1. To open the editor, under "Audit Settings" in the navigation area select the "Open" command in the shortcut menu of "Audit Document Control and Project Versioning".
2. Log in with your user name and password.
3. In the open editor, select "Document > Enable document control".
4. Configure the versioning number in the "Version configuration" dialog box.
5. Select the required category under "Document Control" in the navigation area. The WinCC files are listed in the table area and can be checked in or out.
6. To create a WinCC project, select "Project > Archive Project" in the menu bar. You can display all WinCC projects and project versions. To do so, select "Project > Complete project history" in the menu bar.

You can find additional information under:

- Working with Document Control and Project Versioning (Page 45)

Use the Audit Editor again for the following steps.

Step 6: Activate User Archive Runtime for auditing

Requirements for step 6: You are using the WinCC option "User Archive".

To monitor the value change in the user archives, activate the "User Archive (RT)" component under "Audit Settings".

Step 7: Monitoring user actions

Activate the "User Actions (RT)" component under "Audit Settings".

The following actions are audited:

- Messages
  - Standard operator messages that are output with process picture operations if the "Operator Message" property is activated or a direct connection is configured.
  - User operator messages which are triggered by message tags, C script or VB script (standard "GCreateMyOperationMsg" function or "HMI.HMI Runtime.Alarms" method).
  - System events (e.g., login, logout, login failed)
  - Messages from the message number range from 1900000 to 1901000

- Scripting
  - InsertAuditEntryNew
    Audit saves all events directly to the Audit Trail Database with the "InsertAuditEntryNew" function.
Step 8: Activate / deactivate the "Operator Message" and "Operator Activities Report" property

You can activate or deactivate the property "Operator Message" and "Operator Activities Report" for specific graphic objects. You activate or deactivate the properties in the Graphics Designer or in the Audit Editor as follows:

1. Activate the "User Actions (RT)" component under "Audit Settings".
2. Select "Audit Settings > User Actions (RT)" in the navigation area.
3. Select the required process pictures in the table area.
4. Select the required process picture under "User actions (RT)" in the navigation area.
5. In the table area, activate or deactivate the required option for the displayed objects.
   To apply the change, click on another area in the navigation area or close the Audit Editor. These settings are applied to the object properties in the Graphics Designer.
   When you change the setting in the Graphics Designer, the option is also activated or deactivated in the Audit Editor.

Note
Update view

When a new process picture is created or new objects are inserted in a process picture, the view is not automatically updated in the Audit Editor.

To update the view, follow these steps:

- Display new process picture: Select the "Refresh" command in the "User Actions (RT)" shortcut menu.
- Display new object in the process picture: Right-click the modified process picture under "User Actions (RT)".

Additional information can be found in the Audit documentation and the WinCC documentation.

Step 9: Monitor GMP tags in Runtime

1. Click "Audit Settings" in the navigation area.
2. Select the check box for the "GMP tags (RT)" component in the "Activated" column of the table area.
3. Select "GMP tags (RT)" in the navigation bar.
4. Select "Add GMP tag" in the shortcut menu.
5. Select the tag you require.
6. Confirm your selection with "OK".
   Your selection is display in the table area.
7. Activate the tags that you want to audit.
Step 10: Displaying Audit Trails

1. Select the command "Open Audit Viewer" in the "Audit" shortcut menu of the WinCC Explorer or click the "Audit Viewer" desktop icon.

2. In the table area, select the server with the required Audit Trail database under "Audit DB" in the open viewer.
   To do so, select the entire table row.

3. Select "Select Server" in the shortcut menu.

4. To limit the display to specific events, for example, use the offered queries or create your own query.

You can find additional information under:
- Working with the Audit Viewer (Page 43)

Step 11: Configuring Audit Viewer Control for display in WinCC Runtime

To display the content of the Audit Trail Database in WinCC Runtime, add the "Audit Viewer Control" in a process picture in the WinCC Graphics Designer.

Notes on the Audit Editor

Compared to the default behavior of the WinCC Configuration Studio, the Audit Editor has the following modified behavior:

<table>
<thead>
<tr>
<th>Navigation</th>
<th>Entry</th>
<th>Behavior in the Audit Editor</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu bar</td>
<td>View &gt; Input language</td>
<td>No function</td>
</tr>
<tr>
<td>Table area, e.g., Audit Trail Server</td>
<td>&quot;Delete&quot; shortcut menu</td>
<td>No function</td>
</tr>
<tr>
<td>Table area: Selected row or column</td>
<td>&quot;Cut&quot; / &quot;Paste&quot; shortcut menu</td>
<td>No function</td>
</tr>
<tr>
<td>Table area: Selected row or column</td>
<td>&quot;Find and replace&quot; shortcut menu</td>
<td>&quot;Find&quot; can be used. No function: &quot;Replace&quot;</td>
</tr>
<tr>
<td>Table area</td>
<td>Automatic continuation (&quot;drag-down&quot;)</td>
<td>No function</td>
</tr>
</tbody>
</table>

3.5.2 Working with the Audit Viewer

Procedure

To display the events saved in the Audit Trail database in the Audit Viewer, follow the steps in the procedure.
Step 1: Connect the Audit Trail database

1. In the navigation area, select "Audit DB".
2. In the table area, select the server with the required Audit Trail Database.
   To do so, select the entire table row.
3. Select "Select Server" in the shortcut menu.
   The selected Audit Trail server with the connected database is displayed under "Audit DB" in the navigation area.

Step 2: Display audit trails

1. Click the connected server with the Audit Trail database under "Audit DB" in the navigation area.
   You can see the events of the Audit Trail database in the table area.
2. To configure the number of displayed rows, select "Options > Settings" in the menu bar.
3. To display the events in a sorted manner, select the required category below the Audit Trail database.

Step 3: Filter audit trails with user queries

1. Select "Audit DB > <Audit Trail Server\Database> > Query > User Query" in the navigation area.
2. In the shortcut menu, select "New Query".
3. Define your query in the table area.
   The next field to be processed is always identified by an asterisk. The Audit Viewer supports you in creating the query using drop-down lists in the fields.
4. Select your created query in the navigation area.
5. Select "Run" in the shortcut menu.

Notes on the Audit Viewer

Compared to the default behavior of the WinCC Configuration Studio, the Audit Viewer has the following modified behavior:

<table>
<thead>
<tr>
<th>Navigation</th>
<th>Entry</th>
<th>Behavior in the Audit Viewer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table area: Selected row or column</td>
<td>&quot;Delete&quot; shortcut menu</td>
<td>No function</td>
</tr>
<tr>
<td>Table area: Selected row or column</td>
<td>&quot;Cut&quot; / &quot;Paste&quot; shortcut menu</td>
<td>No function</td>
</tr>
<tr>
<td>Table area: Selected row or column</td>
<td>&quot;Find and replace&quot; shortcut menu</td>
<td>&quot;Find&quot; can be used. No function: &quot;Replace&quot;</td>
</tr>
<tr>
<td>Table area</td>
<td>Automatic continuation (&quot;drag-down&quot;)</td>
<td>No function</td>
</tr>
</tbody>
</table>
3.5.3 Working with Document Control and Project Versioning

Procedure

To create and manage file versions and project versions, follow the steps of the procedure.
You must be authenticated to work with Audit Document Control and Project Versioning.

Step 1: Enable document control and configure versioning
2. Configure the versioning number in the "Version Configuration" dialog box.
The files included in the open WinCC project are checked in and must be checked out for editing.

Step 2: Check out file
1. Select the required category under "Document Control" in the navigation area.
2. In the table row, select the file you want to check out.
3. Select "Check Out" in the shortcut menu.
4. You have the option to enter a comment and confirm with "Check out".

Step 3: Check in file
1. Select the required category under "Document Control" in the navigation area.
2. In the table row, select the file you want to check in.
3. Select "Check In" in the shortcut menu.
4. Enter a comment or apply the existing comment.
5. Confirm with "Check in" to apply the automatically incremented version number.
   If you want to continue versioning with a new, higher-level segment, deactivate the "Automatic versioning" option and select the corresponding segment.

Step 4: Archiving and versioning an open WinCC project
1. Select "Project > Archive Project" in the menu bar.
2. Make sure that the "Archive Current Project" option is activated.
   If versioning has not been configured yet, the "Version configuration" dialog opens.
   Configure the versioning.
3. Enter a comment.
4. Confirm with "Archive" to apply the automatically incremented version number.
   If you want to continue versioning with a new, higher-level segment, deactivate the "Automatic versioning" option and select the corresponding segment.
Step 5: Archiving and versioning a closed WinCC project

Requirement: The version configuration for the closed WinCC project has already been completed.

1. Select "Project > Archive Project" in the menu bar.
2. Deactivate the "Archive Current Project" option and navigate to the storage path of the required WinCC project.
3. Enter a comment.
4. Confirm with "Archive" to apply the automatically incremented version number. If you want to continue versioning with a new, higher-level segment, deactivate the "Automatic versioning" option and select the corresponding segment.

Step 6: Restore version

1. For example, to restore an archived project version, selected your required project in the navigation area under "Project versioning".
2. Select the table row of the required version.
3. Select "Restore" from the shortcut menu.
4. Select the storage location and confirm with "OK".

Notes on Audit Document Control and Project Versioning

Compared to the default behavior of the WinCC Configuration Studio, the Audit Document Control and Project Versioning editor has the following modified behavior:

<table>
<thead>
<tr>
<th>Navigation</th>
<th>Entry</th>
<th>Behavior in Audit Document Control and Project Versioning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table area: Selected row or column</td>
<td>&quot;Delete&quot; shortcut menu</td>
<td>No function</td>
</tr>
<tr>
<td>Table area: Selected row or column</td>
<td>&quot;Cut&quot; / &quot;Paste&quot; shortcut menu</td>
<td>No function</td>
</tr>
<tr>
<td>Table area: Selected row or column</td>
<td>&quot;Find and replace&quot; shortcut menu</td>
<td>&quot;Find&quot; can be used. No function: &quot;Replace&quot;</td>
</tr>
<tr>
<td>Table area: Selected row or column</td>
<td>&quot;Configuration dialog&quot; shortcut menu</td>
<td>Same behavior as the &quot;Check Out and Edit&quot; function.</td>
</tr>
<tr>
<td>Table area: Double-click selected row</td>
<td>-</td>
<td>Same behavior as the &quot;Check Out and Edit&quot; function.</td>
</tr>
<tr>
<td>Table area</td>
<td>Automatic continuation (&quot;drag-down&quot;)</td>
<td>No function</td>
</tr>
</tbody>
</table>

Tracking corrupted configuration file

A popup dialog appears when the user launches DCPV for a project with an altered Project Versioning file. This allows the user to either restore the current Project Versioning file or retain the altered file.
Viewing file types
It is now possible to view all the listed file types supported by DCPV and their statuses in the table area under the “Document Control” root node. This is also applicable for the nodes under it.

You can perform operations like "Check In", "Check Out", "Copy", "Paste" and so on, at "Document Control" root node and at every subsequent node.

3.6 Working with Audit

3.6.1 Configuring the Audit Trail database

3.6.1.1 Audit Trail multi project database

Overview
Every Audit project can store the Trails either by creating a new multi project database or connecting to the existing multi project database.

- A PC can have multiple multi project databases.
- Databases in a machine cannot have the same name.
- The database names that exist in a machine are displayed during selection of the Audit Trail Server.

The database name is case sensitive and usage of ‘.’ is also supported. The list of invalid characters that are not supported during the creation of the multi project database are given below:

- . , ; : ! ? "
- + = / \ @ * &
- [ ] { } < >

If there is no network connection between the PCs over a certain period, your audit data is not lost. Audit stores the audit trails in a local cache. When the network connection is re-established, the audit trails are automatically transferred to the multi project database.

You can also set up a central Audit multi project database on a PC on which there is no WinCC project. At least a minimal installation of WinCC and Audit Runtime must be installed on this PC.

Note
Switching the Audit Trail multi project database to another Audit Trail multi project database
If you switch from one Audit Trail multi project database to another Audit Trail multi project database, your recorded audit trails are not transferred.
3.6 Working with Audit

 Requirement

- Audit is fully installed and licensed.
- A network connection is available.

 Procedure

1. Open the WinCC project that you want to audit.
2. Open the Audit Editor and authenticate yourself.
3. In the navigation area, select "Select Audit Trail Server". The table area displays all Audit Trail servers on which at least Audit Runtime is installed.
4. Select the table row of the desired Audit Trail server and right click to enter the desired database name. The "Multi Project Database Name" dialog box opens.
5. Enter the database name.

 Result

Your PC is connected to the desired Audit Trail server to a multi project database.

 Note

Modifying the trails in the database
It is highly recommended not to manipulate the database for audit trails.

3.6.2 Monitoring a WinCC project with Audit

Specify the components that you want to audit in the Audit Editor.
All settings in the Audit Editor are also saved as audit trails in the Audit Trail database.
If you have not yet configured an Audit Trail database and have already made settings in the Audit Editor, these activities are not audited.
First, configure the Audit Trail database to record future activities in the Audit Editor in the Audit Trail database.

You can find additional information under:

- Configuring the Audit Trail database (Page 47)
3.6.2.1 Making Audit settings

Introduction
Specify what you want to monitor with Audit in the Audit Editor under "Audit Settings". To enable the settings, select the check boxes.

<table>
<thead>
<tr>
<th>Audit settings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WinCC configuration</td>
<td>Monitor a WinCC configuration in Audit.</td>
</tr>
<tr>
<td>WinCC documents</td>
<td>Monitor changes to the WinCC project files.</td>
</tr>
<tr>
<td>User archives (RT)</td>
<td>Monitor changes within a user archive, such as value changes.</td>
</tr>
<tr>
<td>User Actions (RT)</td>
<td>Monitor user actions in WinCC Runtime.</td>
</tr>
<tr>
<td>GMP tags (RT)</td>
<td>Good Manufacturing Practice: Monitor GMP relevant user actions in WinCC Runtime.</td>
</tr>
<tr>
<td>Electronic Signature (RT)</td>
<td>Monitor electronic signature relevant user actions.</td>
</tr>
</tbody>
</table>

Requirement
- Your WinCC project is open.
- The Audit Editor is open and you have authenticated yourself.

Procedure
1. Click "Audit Settings" in the navigation area.
2. Select the check box for the respective component in the "Activated" column. To activate or deactivate all components, select the "Activated" column and then select "Select all" in the shortcut menu.

Result
You have made the Audit settings. You can deactivate the respective components by clearing the check box in the "Activated" column.

In the next step, you specify which WinCC editors or WinCC components are to be monitored.

3.6.2.2 Specify WinCC components for auditing

Introduction
Specify the WinCC components that you want to monitor in the Audit Editor.

Select the following WinCC components:
- WinCC Project Properties
- Computer Properties
- Tag Management
3.6 Working with Audit

- Alarm Logging
- Tag Logging
- Text Library
- User Administration
- User Archives
- Report Designer
- Redundancy
- Time Synchronization
- Picture Tree Manager
- Horn
- Lifebeat monitoring
- Text and graphics lists

1) Only the configuration is monitored, not the data input.

---

**Note**
Audit does not monitor Tags Simulation and Cloud Connector Editors.

---

**Requirement**

- Your WinCC project is open.
- The Audit Editor is open and you have authenticated yourself.
- Activate the "WinCC Configuration" component under "Audit Settings".

**Procedure**

1. Click "WinCC Configuration" under "Audit Settings" in the navigation area.
2. Select the check box for the respective WinCC component in the "Activated" column. To activate or deactivate all WinCC components, select the "Activated" column and then select "Select all" in the shortcut menu.
Result

You have specified the WinCC components for auditing. To deactivate the selected WinCC components, deselect the check box in the "Activated" column.

Note

Tracking multiuser engineering changes

To track multiuser engineering changes, "WinCC Configuration" and "WinCC Documents" must be selected in "Audit Settings" along with "WinCC Project Properties" under "Audit Settings > WinCC Configuration".

Note

Monitoring the "Floating-point number 32-bit IEEE 754" data type

Audit DB stores the accurate value of the associated datatype.

In case of the "Floating-point number 32-bit IEEE 754" data type, the value is defined by IEEE. Hence, the entered value and the stored value can differ in accordance to the IEEE standard.

For high accuracy requirements, usage of "Floating-point number 64-bit IEEE 754" is recommended.

3.6.2.3 Activate document monitoring

Introduction

When you activate document monitoring, all activities in user and configuration files are recorded as an events in the Audit Trail database.

Audit monitors the following:

- Creation of a document
- Changes to a document
- Deletion of a document

Overview

The following table shows the user and configuration files for which document monitoring can be performed:

<table>
<thead>
<tr>
<th>User files and configuration files</th>
<th>Formats, file types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer properties</td>
<td>Gracs.ini</td>
</tr>
<tr>
<td>Picture files</td>
<td>PDL</td>
</tr>
<tr>
<td>Menus and toolbars</td>
<td>MTL</td>
</tr>
<tr>
<td>Report layouts</td>
<td>RPL</td>
</tr>
<tr>
<td>C scripts</td>
<td>PAS (actions)</td>
</tr>
<tr>
<td></td>
<td>FCT (project functions)</td>
</tr>
</tbody>
</table>
### Requirement

- Your WinCC project is open.
- The Audit Editor is open and you have authenticated yourself.

### Procedure

1. Click “Audit Settings” in the navigation area.
2. Select the check box for the “WinCC Documents” component in the “Activated” column of the table area.

### Result

You have activated document monitoring. You can deactivate the document monitoring by clearing the check box in the “Activated” column.

### See also

[Saving and versioning external data](Page 77)

### 3.6.2.4 Monitoring user actions with Audit

#### User actions monitored with Audit

Audit allows you to monitor user activity in WinCC Runtime.

Audit monitors the following actions:

- **Messages**
  - Standard and user operator messages
  - Messages from a message number range
  - System events
- **Scripting**
  - InsertAuditEntryNew
Standard operator messages

Standard operator messages are messages that are pre-defined in a WinCC project in Alarm Logging by default.

Standard operator messages have the following properties:

- Message class: System, without acknowledgment
- Message type: Operator message
- Message number: 12508141

You can trigger a standard operator message for a process picture operation via:

- "Operator message" property
- Direct connection

"Operator message" property

You can enable the "Operator message" property for a required object in the Graphics Designer.

You can enable the "Operator message" property for the following object types:

- I/O field
- Text list
- Combo box
- List box
- Check box
- Radio box
- Slider

Message number 12508141 is generated when the configured object is operated in WinCC Runtime.

Audit stores this event in the Audit Trail database.

"Operator activities report" property

In addition to "Operator Message" property, you can set the "Operator Activities Report" property for the following object types:

- I/O field
- Text list
- Combo box
- List box
- Slider

When the configured object is operated in WinCC Runtime, the operator is prompted to enter a comment regarding the change. Message number 12508141 is generated with the comment.
Audit stores this event in the Audit Trail database.

**Direct connection**

For all other types of objects in the Graphics Designer, there is no "Operator message" or "Operator activities report" property. Set an action with a direct connection to a tag for the desired object. Select the "Operator message" option in the direct connection dialog.

Message number 12508141 is generated when the configured object is operated in WinCC Runtime.

Audit stores this event in the Audit Trail database.

**User operator messages**

User operator messages are messages that you create in Alarm Logging.

Audit monitors user operator messages with the following properties:

- Message class: System, without acknowledgment
- Message type: Operator message
- Message number: any

You can trigger a user operator message for a process picture operation via:

- Message tag
- C script function "GCreateMyOperationMsg"
- VB script function "HMIRuntime.Alarms"

You can find additional information in the WinCC Information System under Working with WinCC*.

The message number of the created user operator message is generated when the configured object is operated in WinCC Runtime.

Audit stores this event in the Audit Trail database.

**Message tag**

Assign a "Message tag" to the user operator message. Connect the required object to the message tag in Alarm Logging.

**C script function "GCreateMyOperationMsg"**

Define an action with a C script for a desired object in the Graphics Designer. Use the "GCreateMyOperationMsg" function. The comments entered in the window dialog for "GCreateMyOperationMsg" function is also stored in Audit Trail DB.
Example for "GCreateMyOperationMsg"

GCreateMyOperationMsg(0x00000001, 1, lpszPictureName, lpszObjectName, 15, 1, 2, "mycomment");

VB script function "HMIRuntime.Alarms"

Define an action with a VB script for a desired object in the Graphics Designer. Use the "HMIRuntime.Alarms" function.

Example for "HMIRuntime.Alarms"

'VBS360
Dim MyAlarm
Set MyAlarm = HMIRuntime.Alarms(1)
MyAlarm.State = 5 "hmiAlarmStateCome + hmiAlarmStateComment"
MyAlarm.Comment = "MyComment"
MyAlarm.UserName = "Hans-Peter"
MyAlarm.ProcessValues(1) = "Process Value 1"
MyAlarm.ProcessValues(4) = "Process Value 4"
MyAlarm.Create "MyApplication"

Messages from a message number range

Audit monitoring messages from 1900000 to 1901000.

Message numbers from 1900000 to 1900050

The message numbers 1900000 to 1900050 are reserved for WinCC options and add-ins. This includes, for example, the electronic signature.

These message numbers cannot be edited.

The message numbers from 1900010 to 1900015 are related and reserved for Audit.

You can find additional information in the WinCC Information System under:

- "Working with WinCC > Structure of the User Administration > Central user administration with SIMATIC Logon".

Message numbers from 1900051 to 1901000

Audit controls messages with message numbers from 1900051 to 1901000 of any message type.

You can trigger a message for a process picture operation via:

- Message tag
- C script function "GCreateMyOperationMsg"
- VB script function "HMIRuntime.Alarms"
System events

System events are messages that are pre-defined in a WinCC project in Alarm Logging by default.

System events have the following properties:

- Message class: System, without acknowledgment
- Message type: Process control system

Audit monitors the system events:

<table>
<thead>
<tr>
<th>Message number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1008000</td>
<td>Connection to chipcard-terminal has been interrupted</td>
</tr>
<tr>
<td>1008001</td>
<td>Incorrect login name/password</td>
</tr>
<tr>
<td>1008002</td>
<td>Invalid login name/password by chipcard</td>
</tr>
<tr>
<td>1008003</td>
<td>Manual login</td>
</tr>
<tr>
<td>1008004</td>
<td>Login by chipcard</td>
</tr>
<tr>
<td>1008005</td>
<td>Manual logout</td>
</tr>
<tr>
<td>1008006</td>
<td>Logout by chipcard</td>
</tr>
<tr>
<td>1008007</td>
<td>Automatic logout by timeout</td>
</tr>
<tr>
<td>1008008</td>
<td>Notification of service user/group '@102%s@' in effect</td>
</tr>
<tr>
<td>1900010</td>
<td>Audit: Provider service not started.</td>
</tr>
<tr>
<td>1900011</td>
<td>Audit: Provider service started.</td>
</tr>
<tr>
<td>1900012</td>
<td>Audit: Trail service not started.</td>
</tr>
<tr>
<td>1900013</td>
<td>Audit: Trail service started.</td>
</tr>
<tr>
<td>1900014</td>
<td>Audit: @1%s@: Provider service is not available.*</td>
</tr>
<tr>
<td>1900015</td>
<td>Audit: @1%s@: Trail service is not available.*</td>
</tr>
</tbody>
</table>

* % - Name of the computer associated to the affected Audit Provider Service.

InsertAuditEntryNew

"InsertAuditEntryNew" is a script function that is used in an object in the Graphics Designer. When the object is operated in WinCC Runtime, the event is immediately saved in the Audit Trail database.

InsertAuditEntryNew functions

Use the following InsertAuditEntryNew functions:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>InsertAuditEntryNew.fct</td>
<td>Function for C script.</td>
</tr>
<tr>
<td>InsertAuditEntryNew.bmo</td>
<td>Function for VB script.</td>
</tr>
</tbody>
</table>
**InsertAuditEntryNew in the Script Editor or in the Graphics Designer**

**C Editor/Graphics Designer**
You can find the InsertAuditEntryNew function in the navigation area under "Standard Functions > Options".

**VBS Editor/Graphics Designer**
You can find the InsertAuditEntryNew function in the navigation area under "Standard Modules".

**Note**

**Regenerating the header**
If the "InsertAuditEntry" function is not visible, you need to re-generate the header in the C Editor.

**Example of a simple script**

**Comment in Runtime**
You can use a script to decide whether to open a comment dialog in runtime or use the comment directly from the scripting.

When a comment dialog is used, the user is prompted to enter a comment in runtime. Enter "1" after the "Comment" parameter to do this.

To use the comment directly from the script, write a comment at the "Comment" parameter and enter "0" after the parameter.

The following table shows the various script options and the view in Audit Trail:

<table>
<thead>
<tr>
<th>Comment</th>
<th>Show in Audit Trail</th>
<th>Example script</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show comment dialog in Runtime.</td>
<td>The comment entered in the dialog is recorded in Audit Trail.</td>
<td>&quot;Comment&quot;, 1</td>
</tr>
<tr>
<td>Use comment from script.</td>
<td>The comment entered for the &quot;Comment&quot; parameter is recorded in Audit Trail.</td>
<td>&quot;Comment&quot;, 0</td>
</tr>
</tbody>
</table>

**C script: InsertAuditEntryNew.fct**

```c
char* szBuf = (char*)SysMalloc(128);
InsertAuditEntryNew("old Value","new Value","Comment", 0, szBuf);
SysFree(szBuf);
```

**VBS script: InsertAuditEntryNew.bmo**

```vbs
InsertAuditEntryNew "old Value", "new Value", "Comment", 0
```
Monitoring user actions with Audit

Introduction
Monitor user activities in WinCC Runtime.
You can find additional information under:

- User actions monitored with Audit (Page 52)

Requirement

- Your WinCC project is open.
- The required configurations have been made in the Alarm Logging or Tag Logging, for example, system events have been enabled, operator messages have been configured, etc.
- "Alarm Logging Runtime" is enabled under "Computer Properties > Startup" in the WinCC Explorer.
- The Audit Editor is open and you have authenticated yourself.

Procedure

1. Click “Audit Settings” in the navigation area.
2. Select the check box for the "User Actions (RT)" component in the "Activated" column of the table area.

Result
You have select the "User Actions (RT)" component. You can deactivate the component by re-selecting the check box in the "Activated" column.

Activate / deactivate the Operator Message and Operator Activities Report property

Introduction
Audit provides an additional function for the activation and deactivation of the "Operator message" and "Operator activities report" property for the standard operator messages.
You get an overview of all of the Audit Editor process pictures and their configured objects in your WinCC project.
You can find additional information under:

- Standard operator messages (Page 53)
Requirement

- Your WinCC project is open.
- "Alarm Logging Runtime" is enabled under "Computer Properties > Startup" in the WinCC Explorer.
- The Audit Editor is open and you have authenticated yourself.

Procedure

1. Click "Audit Settings" in the navigation area.
2. Select the check box for the "User Actions (RT)" component in the "Activated" column of the table area.
3. Select "User Actions (RT)" in the navigation area.
   The table area shows all process pictures that have been created in the open WinCC project. If a newly created process picture does not appear in the table area, select the "Refresh" command in the "User Actions (RT)" shortcut menu.
4. Select the process picture that contains the object type of a standard operator message.
   The activated process picture is displayed under "User Actions (RT)" in the navigation area.
5. Select the process picture in the navigation area.
   The configured objects in the process picture are displayed in the table area.
6. Select or clear the check boxes of the "Operator message" and "Operator Activities Report" column.
   If a newly created object does not appear in the Audit Editor, right-click on the change process picture under "User Actions (RT)".
   To apply the change in the check box, click on another area in the navigation area or close the Audit Editor.

If no object type of a standard operator message is present in the process picture, this option has no effect.

---

Note

**Saving an open PDL in the Graphics Designer**

If the PDL is open in the Graphics Designer when a change is being made in the Audit Editor, save the picture to keep the changes.

---

Result

These changes are transferred and saved in the PDL.
Enabling/disabling electronic signature using Audit

Introduction
Audit allows you to manage the electronic signature for an already configured PDL in Graphic Designer.

Procedure
You can enable/disable the electronic signature for a given object in a PDL as follows:
1. Click "Audit Settings" > "User Actions".
   The PDLs are listed below.
2. Select the required PDL.
3. Select/unselect the "Electronic Signature" check box.

Result
You have activated electronic signature for a PDL through Audit Editor.

See also
Activating electronic signature in Audit (Page 63)

Managing authorized users for electronic signature

Introduction
Audit allows you to manage the authorized users of electronic signatures for a PDL.
Procedure

1. Click "Audit Settings" > "User Actions". The PDLs are listed below.
2. Select the required PDL.
3. In the "Authorized Users" column, click the "..." option. The "electronic signature - Configuration" dialog box appears.
4. Select the desired user from the drop-down list in the "User" column. If you are using SIMATIC Logon, the drop-down list only contains SIMATIC Logon users. If the column is not active, click on the empty row in the "Group" column. The operator "and" is displayed in the "Logic operator" column and the user list is activated in the "User" column.
5. If you are using the WinCC/Audit option, you can select user groups or multiple users. Link the users and user groups using "and" or "or". You can group the rows in the "Group" column.
6. If you are using the WinCC/Audit option, you can use the "Retroactively" option to specify that the signature is requested after the operation.
7. Click "OK" to close the dialog. The selected user names and link parameters are shown in the "Authorized Users" column.

Result

The changes are transferred to the PDL automatically and Audit stores this event in the Audit Trail database.

For more information on managing authorized users for electronic signature in an object, refer to WinCC Information System > Working with WinCC > Structure of the User Administration > Configuring an electronic signature.

See also

Activating electronic signature in Audit (Page 63)

3.6.2.5 Monitoring GMP tags with Audit

Introduction

By activating the GMP tags (RT), user actions that are relevant for the quality of the process are monitored in WinCC Runtime. The requirements for Good Manufacturing Practice (GMP) are met.

Requirement

- Your WinCC project is open.
- The Audit Editor is open and you have authenticated yourself.
Procedure

1. Click "Audit Settings" in the navigation area.
2. Select the check box for the "GMP tags (RT)" component in the "Activated" column of the table area.
3. Select "GMP tags (RT)" in the navigation area.
4. Select "Add GMP tag" in the shortcut menu.
   You can also drag-and-drop from the WinCC "Tag Management" editor window to "GMP Tags (RT)" editor window. Refer the section Drag-and-drop tags below to drag-and-drop tags from WinCC "Tag Management" editor window.
5. Select the tag you require.
   Note
   The selected GMP tags should belong to the localhost node.

6. Confirm your selection with "OK".
   Your selection is display in the table area.
7. Activate the tags that you want to audit.

Note
Selecting large number of tags
To select large number of tags from the tag browser to the "GMP Tags (RT)" folder, drag-and-drop the selected tags onto "GMP Tags (RT)" folder.

Drag-and-drop tags
This section describes an example how to drag-and-drop a tag from WinCC "Tag Management" window to "GMP tags (RT)" node in Audit Editor.
1. In WinCC Explorer, open "Tag Management". Re-scale the "Tag Management" window to half the screen size.
2. Open "Audit Editor > Audit Settings > GMP Tags (RT)". Re-scale the "Audit Editor" window to half the screen size.
3. Place "Tag Management" window and "Audit Editor" window beside each other.
4. Select a tag from "Tag Management" window and drag-and-drop the tag onto "Audit Editor". Selection of multiple tags is also possible.
3.6.2.6 Monitoring electronic signature with Audit

Activating electronic signature in Audit

Introduction

An electronic signature allows you to identify the personnel responsible for any critical action ranging from a change of a record to the approval and release of the process result.

The signature is always associated with an action made by the configured user and is authenticated with a password.

If the user is not authorized or enters an incorrect password, the action is not performed.

The user can be a WinCC User Administrator or a SIMATIC Logon user.

Requirement

- Electronic signature is configured in WinCC. You can also configure electronic signature with SIMATIC Logon.

Note

To configure an electronic signature, refer to WinCC Information System > Working with WinCC > Structure of the User Administration > Configuring an electronic signature.

To configure an electronic signature using SIMATIC Logon, refer to WinCC Information System > Working with WinCC > Structure of the User Administration > How to configure an electronic signature with SIMATIC Logon.

- "Alarm Logging Runtime" is activated in the startup list in the computer properties of WinCC Explorer.

- Audit is fully installed and licensed.

Procedure

1. Click "Audit Settings" in the navigation area.

2. Select the check box for the "Electronic Signature (RT)" component in the "Activated" column of the table area.

Result

You have activated electronic signature in Audit. You can also de-activate the electronic signature monitoring by clearing the check box in the "Activated" column.
Single user sign-in

Introduction

A critical action can be protected using electronic signature for a single user.

Requirement

- Electronic signature is configured in WinCC with a single user for "Immediately" condition. You can also configure electronic signature with SIMATIC Logon.
- "Alarm Logging Runtime" is activated in the startup list in the computer properties of WinCC Explorer.
- Audit is fully installed and licensed.
- Electronic signature is activated in the "Audit settings".

Procedure

To use single user sign-in, do the following:

1. In Runtime, select the object.
   The "electronic signature - Configuration" dialog with a list of authorized users opens.
   
   **Note**
   If you are using SIMATIC Logon, the drop-down list only contains SIMATIC Logon users. If you use WinCC user administrator, only those users are listed.

2. Select the user.
   The "Electronic Signature - Identification" dialog opens.

3. Enter the password to identify the authorized user.
   The user also has the option to enter a comment which is saved with the triggered system message.

4. Click "OK" to close the dialog.
Result

Operation
The action is executed as the authorized user has signed-in.

System messages
The system messages document all authentication attempts.
The messages for all authentication attempts are also written to Audit trail database with unique operator message IDs.

Multiple users sign-in

Introduction
You can assign multiple users’ electronic signatures for authorizing a critical action. User can belong to the same group or different groups.

Requirement
- Electronic signature is configured in WinCC with multiple users selected for "Immediately" condition. You can select user groups or multiple users. Link the users and user groups using "and" or "or". You can group the rows in the "Group" column. You can also configure electronic signature with SIMATIC Logon.
- "Alarm Logging Runtime" is activated in the startup list in the computer properties of WinCC Explorer.
- Audit is fully installed and licensed.
- Electronic signature is activated in the "Audit settings".

Procedure
To use multiple users sign-in, do the following:
1. In Runtime, select the object.
   The "electronic signature - Configuration" dialog with a list of authorized users opens.
2. Select the user.
   The "Electronic Signature - Identification" dialog opens.
3. Enter the passwords to identify each authorized user and click "OK".
   The user also has the option to enter a comment which is saved with the triggered system message.
   Depending on the "and" or "or" condition used while configuration, the signatures will be required.
4. Click "OK" to close the dialog after all the signatures are entered.

Result
The action is executed since the authorized users have signed-in.
System messages
The system messages document all authentication attempts.

The messages for all authentication attempts are also written to Audit trail database.

Retroactive sign-in

Introduction
You can perform minor/major actions in Runtime but the authorized users will need to confirm the actions later using their electronic signatures. The "Retroactively" option can be applied for both single and multiple users' authorization.

Requirement
- Electronic signature is configured in WinCC with single/multiple users selected for "Retroactively" condition. In the case of multiple users, link the users and user groups using "and" or "or". You can group the rows in the "Group" column. You can also configure electronic signature with SIMATIC Logon.
- "Alarm Logging Runtime" is activated in the startup list in the computer properties of WinCC Explorer.
- Audit is fully installed and licensed.
- Electronic signature is activated in the "Audit settings".

Procedure
1. In Runtime, select the object. The "electronic signature - Configuration" dialog with a list of authorized users pops up.
2. To select the users, do the following:
   - In case of a single user, click "OK" and continue with the action. A message is sent to the "WinCC ESig Control" indicating pending signature.
   - In case of multiple users, sign in with at least one user and then click "OK" to execute the action. The other users can sign in later.

Note
"WinCC ESig Control" displays pending signatures and name of the personnel with the message ID 1900004.

Result
The action is executed without authorization signatures.
The signatures can be entered later in the "WinCC ESig Control".
All notifications related to pending signatures are stored in "WinCC ESig Control" to keep track of the personnel who have not signed.

**System messages**
The system messages document all authentication attempts.
If you use the "WinCC/Audit" option, the messages for all authentication attempts are also written to Audit trail database.

### 3.6.3 Saving and versioning WinCC project data.

**Introduction**
Audit Document Control and Project Versioning allows you to back up your WinCC project files and archive your WinCC projects.
To back up your WinCC project files, you first need to enable document control.
When you enable document control or archive an open project the first time, you must set the version number.

**Principle of document control**
You can perform the following functions after enabling document control:
- Check in WinCC project files
- Check out WinCC project files
- Restore WinCC project files
- Compare WinCC project files with each other
- Labeling WinCC project files
When you enable document control, all WinCC project files are automatically checked into your open WinCC project.

**Note**
**Restoring WinCC project files**
Restoring overwrites the current version with the new version.

**Editing and creating files in WinCC**
To edit a file, you must first check it out in Audit Document Control and Project Versioning. Only then can the file be edited with the appropriate WinCC editors.
When you create a new file, the file is displayed as "Unversioned" in the Audit Document Control and Project Versioning. Check in the file to save it.
All check-in operations as well as file restorations are displayed in the file history.

**NOTICE**

**Loss of data with deactivation of the document control**

When you deactivate document control, all archived WinCC project files are lost.

### Changing computer properties

If you want to change the computer properties when document control is activated, you need to check out the "GraCS.ini" file in the navigation area under "Document Control > Computer". Only then can you make changes in the "Graphics Runtime" and "Runtime" tabs.

### User and configuration files

The following table shows the user and configuration files for which document control can be performed:

<table>
<thead>
<tr>
<th>User files and configuration files</th>
<th>Formats, file types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer properties</td>
<td>Gracs.ini</td>
</tr>
<tr>
<td>Picture files</td>
<td>PDL</td>
</tr>
<tr>
<td>Menus and toolbars</td>
<td>MTL</td>
</tr>
<tr>
<td>Report layouts</td>
<td>RPL</td>
</tr>
<tr>
<td>C scripts</td>
<td>PAS (actions)</td>
</tr>
<tr>
<td></td>
<td>FCT (project functions)</td>
</tr>
<tr>
<td>VB Scripts</td>
<td>BAC (actions)</td>
</tr>
<tr>
<td></td>
<td>BMO (project modules)</td>
</tr>
<tr>
<td>Miscellaneous files</td>
<td>Custom files that are stored in the project path under &quot;Misc Docs (Document Control)&quot;).</td>
</tr>
<tr>
<td>Process Historian Ready</td>
<td>CFG</td>
</tr>
</tbody>
</table>

1) You can find additional information under:

- [Saving and versioning external data](#) (Page 77)

### Principle of project versioning

You can perform the following actions using project versioning:

- Archive WinCC projects
- Restore WinCC projects

### Note

**Restoring WinCC projects**

Restoring copies the selected version of the archived WinCC project to the destination path.
Storage paths of archive files

**Archive files of the WinCC project files**

When a WinCC project file is checked in, Audit creates a compressed GZ file and stores it in the "Document Control" folder. This folder is created automatically in your WinCC project folder.

**Archive files of the WinCC projects**

When a WinCC project is archived, Audit creates a compressed GZ file and stores it locally in the following path:

- `<Public Documents>\Siemens\Audit\AuditDCV`

You can navigate to another archive path when archiving a WinCC project.

<table>
<thead>
<tr>
<th>NOTICE</th>
</tr>
</thead>
</table>

**Data loss when changing archive files**

When you make changes to the archive files, data loss will occur. This means it is no longer possible to restore the WinCC project files or WinCC projects in Audit Document Control and Project Versioning.

You may not make the following changes:

- Delete
- Rename
- Move

See also

- WinCC project files (Page 72)
- WinCC projects (Page 77)

### 3.6.3.1 Enable Document Control

#### Introduction

If you enable document control, you will be prompted once to configure the version number.

First read the following section carefully:

- Configuring the version number (Page 70)

#### Requirement

- Your WinCC project is open.
- Audit Document Control and Project Versioning is open and you have authenticated yourself.
3.6 Working with Audit

Procedure

1. Select "Document > Enable Document Control" from the menu bar or click on the "Enable document control" icon in the toolbar.
   The "Version configuration" dialog opens.  
2. Select the version mask and the special characters.  
3. Confirm your entries with "OK".

Result

All the files in your WinCC project are automatically checked in according to the versioning mask in Audit Document Control and Project Versioning.

3.6.3.2 Configuring the version number

Introduction

In Document Control and Project Versioning, you define the version number that is used with every versioning of files and projects. The version number consists of 4 segments. When a file is checked in or when a project is archived, the segments of the version number are incremented, depending on which version mask you have selected.

Note

The versioning is configured only once for each WinCC project and cannot be changed.

Define version mask

When you enable document control, you are prompted to configure the version number. Select from the following version masks:

<table>
<thead>
<tr>
<th>Version mask</th>
<th>Definition</th>
</tr>
</thead>
</table>

File versioning

File versioning depends on your open WinCC project. Document Control and Project Versioning displays all existing files in the project. If you have not enabled document control, you will see your files in the table area with the "Unversioned" status. If you enable document control via the menu bar, you are prompted to configure the version number. When the configuration is complete, all WinCC files are checked in automatically. The end segment of each file gets the number 1.

If you check in a file again, the segment of the file version is increased. You can select which segment of the file version should be increased.
Examples with version mask PP.PP.DD.DD:

<table>
<thead>
<tr>
<th>Example</th>
<th>Old version</th>
<th>New version</th>
</tr>
</thead>
<tbody>
<tr>
<td>The end segment of the file version is incremented during check in.</td>
<td>0.0.0.1</td>
<td>0.0.0.2</td>
</tr>
<tr>
<td>The front segment of the file version is incremented during check in.</td>
<td>0.0.0.1</td>
<td>0.0.1.0</td>
</tr>
<tr>
<td>The WinCC project was archived. A virtual check in of the files took place through the archiving. The file has the same version as the WinCC project. After you check out of the file and then check it back in, the file version starts again at 1.</td>
<td>0.0.0.5</td>
<td>0.1.0.0</td>
</tr>
<tr>
<td></td>
<td>0.1.0.0</td>
<td>0.1.0.1</td>
</tr>
<tr>
<td>Multiple files with different version number are checked in at the same time.</td>
<td>File_xy: 0.0.0.4</td>
<td>File_xy: 0.0.0.5</td>
</tr>
<tr>
<td></td>
<td>File_yz: 0.0.0.8</td>
<td>File_yz: 0.0.0.9</td>
</tr>
</tbody>
</table>

**Maximum number of file versions reached**

When all segments of the file versions have reached 99, you must archive the WinCC project again. The file version starts again at 1 when it is checked in again.

When a file is checked out and a new project version is archived, the file remains checked out. After the file is checked in again, it gets the new version number.

You can find additional information under:

- [WinCC project files](Page 72)

**Project versioning**

Project versioning depends on your open WinCC project.

When you archive the project for the first time, the segment of the project version starts at 1. You can select which segment of the project version should be increased.

Examples with version mask PP.PP.DD.DD:

<table>
<thead>
<tr>
<th>Example</th>
<th>Old version</th>
<th>New version</th>
</tr>
</thead>
<tbody>
<tr>
<td>The end segment of the project version is incremented during check in.</td>
<td>0.1.0.0</td>
<td>0.2.0.0</td>
</tr>
<tr>
<td>The front segment of the project version is incremented during check in.</td>
<td>0.2.0.0</td>
<td>1.0.0.0</td>
</tr>
</tbody>
</table>

**Maximum number of project versions reached**

When all segments of the project versions have reached 99, you must save the WinCC project with a new name using the Project Duplicator. Then, archive the WinCC project again in Document Control and Project Versioning. The project version starts again at 1.

You can find additional information under:

- [WinCC projects](Page 77)
3.6.3.3 WinCC project files

Checking out project files

Requirement

- Your WinCC project is open.
- Audit Document Control and Project Versioning is open and you have authenticated yourself.
- Document control is enabled.
- The version number has been configured.

Procedure

1. Select the category of your required file under "Document Control" in the navigation area.
2. Select the row of the file you want to check out in the table area.
3. Select "Check Out" in the shortcut menu to check out the file.
4. To check out the file and immediately begin editing with the associated application, select "Check Out and Edit" in the shortcut menu.
5. Enter a checkout comment if you wish.

Result

Your file is checked out. The status of the file in the Audit Document Control and Project Versioning is "Checked out". The user who authenticated the Audit Document Control and Project Versioning appears in the "Checked out by" column.

Check in project files

Requirement

- Your WinCC project is open.
- Audit Document Control and Project Versioning is open and you have authenticated yourself.
- Document control is enabled.
- The version number has been configured.

Procedure

1. Select the category of your required file under "Document Control" in the navigation area.
2. In the table area, select the row of the file you want to check in.
3. Select "Check In" in the shortcut menu.
4. To use the checkout comments for the check in, leave the "Continue with the existing check out comment" check box selected.

5. To use a different comment for checking in, clear the "Continue with the existing check out comment" check box and enter a comment. The check-in comment is mandatory.

6. To begin or increase the file version with the last defined segment, leave the check mark in the "Automatic versioning" check box.

7. To begin or increase the file version with another segment, clear the check mark in the "Automatic versioning" check box. Select your required segment under "Increase segment version".

8. Click "Check in".

---

**Note**

**Preventing unauthorized access to a WinCC file**

Check the file back in immediately after editing. This will prevent unauthorized persons from making changes to the checked-out file.

---

**Result**

Your file is checked in. The status of the file in the Audit Document Control and Project Versioning is "Checked in". You can find the check-in comment in the file history.

**View File History**

**Requirement**

- Your WinCC project is open.
- Audit Document Control and Project Versioning is open and you have authenticated yourself.
- Document control is enabled.

**Procedure**

1. Select the category of your required file under "Document Control" in the navigation area.
2. Select the row of the file for which you want to display the file history.
3. Select "View History" from the shortcut menu.

**Result**

The file history shows the user who checked in or restored the file. In addition, the check-in date is displayed with the time and comment.
Restoring previous versions of archived project files

Introduction

If you have a versioned a WinCC project file, it is possible to restore a previous version.

**NOTICE**

Do not delete project files

If you delete the project files in your WinCC project, you cannot restore the project files in Audit Document Control and Project Versioning.

To be able to restore deleted project files, create a local backup of your WinCC project.

Connections and dynamization in the restored project files

When you restore a previous version, connections to existing tags may no longer available, for example.

Reconfigure the connections if necessary.

Requirement

- Your WinCC project is open.
- Audit Document Control and Project Versioning is open and you have authenticated yourself.
- Document control is enabled.

Procedure

1. Select "Document Control" in the navigation area.
2. In the table area, select the row of the file whose previous version you want to restore.
3. Select "View History" from the shortcut menu.
4. Select the row of the previous version in the table area.
5. Select "Rollback" in the shortcut menu.
6. Enter a mandatory comment.
7. To begin or increase the file version with the last defined segment, leave the "Automatic versioning" check box selected.
8. To begin or increase the file version with another segment, clear the check mark in the "Automatic versioning" check box. Select your required segment under "Increase segment version".
9. Click "Rollback".
### Note

**Rollback of files**

To rollback files like MCP, PDL, Global Scripts, etc, WinCC Runtime has to be restarted to avoid unexpected behaviour. It is also required to open the script file, compile and save after a file is rolled back.

### Result

You have restored the previous version. In the file history, you can see the version from which the file was restored in the comment column.

### Comparing file versions with one another

#### Introduction

You have the option to compare file versions with each other. Using this function, you see whether substantive changes have been made (binary comparison). The following files are available for comparison:

**Picture files (.pdl)**

<table>
<thead>
<tr>
<th>Column header</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object type</td>
<td>Object type in which a change was made.</td>
</tr>
<tr>
<td>Modification type</td>
<td>Performed change.</td>
</tr>
<tr>
<td>Property Name</td>
<td>Object property in which a change was made.</td>
</tr>
<tr>
<td>Event Name</td>
<td>Event in which a change was made.</td>
</tr>
<tr>
<td>Value change</td>
<td>If the check box is selected, a value change was made.</td>
</tr>
<tr>
<td>Changing the dynamization</td>
<td>If the check box is selected, a change of dynamization was made.</td>
</tr>
<tr>
<td>Trigger types</td>
<td>If the check box is selected, a trigger type was used.</td>
</tr>
</tbody>
</table>

**C scripts (.pas, .fct) and VB scripts (.bac, .bmo)**

<table>
<thead>
<tr>
<th>Column header</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object type</td>
<td>Object type in which a change was made.</td>
</tr>
<tr>
<td>Modification type</td>
<td>Performed change.</td>
</tr>
<tr>
<td>Action element</td>
<td>Action element in which a change was made.</td>
</tr>
<tr>
<td>Trigger types</td>
<td>If the check box is selected, a trigger type was used.</td>
</tr>
</tbody>
</table>
Requirement

- Your WinCC project is open.
- Audit Document Control and Project Versioning is open and you have authenticated yourself.
- Document control is enabled.

Procedure

1. Select picture files or scripts in the navigation area.
2. Select the row of the desired file in the table area.
3. Select "View History" from the shortcut menu.
4. In the table area, select the row of the versions that you want to compare with each other.
5. Select "Compare" from the shortcut menu.

Note

Comparing PDL files

Invalid entries appear in the "Compare Result" tab when you compare PDL files for the following configurations:

- The "Symbol Properties" of an SVG object
- The attributes of the Dataset object
- Animation dynamization

Select project files

Introduction

You have the option to label your project files. An interim version of all project files is saved by the labeling.

Note

Checked-out project files

When project files are checked out and you perform labeling, the local changes are lost.

Requirement

- Your WinCC project is open.
- Audit Document Control and Project Versioning is open and you have authenticated yourself.
• Document control is enabled.
• All project files are checked in.

Procedure

1. Select "Label > Apply Label" in the menu bar or click the icon on the toolbar.
   The "Label Options" dialog box opens.
2. Enter a label name.
3. Enter a comment.
   The comment is mandatory.
4. Click the "Apply Label" button.

3.6.3.4 Saving and versioning external data

Once document control is enabled for a WinCC project, Audit creates the "Misc Docs (Document Control)" folder in the WinCC project directory. In this folder, you can save files that are not contained in your WinCC project.

By saving them to the "Misc Docs (Document Control)" folder, the files become visible under "Document Control" in the navigation area. Check in the file to save it.

You can version the files exactly as do WinCC project files.

You can find additional information under:

• WinCC project files (Page 72)

3.6.3.5 WinCC projects

Archiving and versioning an open WinCC project

Introduction

The WinCC projects must be located locally on the PC on which Audit Document Control and Project Versioning is started.

Requirement

• Your WinCC project is open.
• Audit Document Control and Project Versioning is open and you have authenticated yourself.

Procedure

1. Select "Project > Archive Project" in the menu bar.
2. Make sure that the "Archive Current Project" option is activated.
3. If you want a different archive path, select it using the button.

4. Enter a comment.

5. To begin or increase project file version with the suggested segment, leave the "Automatic versioning" check box selected.
   To begin or increase the project version with another segment, clear the check mark in the "Automatic versioning" check box. Select your required segment under "Increase segment version".

6. Click "Archive."
   The WinCC project is automatically closed and re-opened after archiving.

Result

The archived project is displayed in the navigation area below the "Project Versioning" entry.

Archiving and versioning a closed WinCC project

Introduction

The WinCC projects must be located locally on the PC on which Audit Document Control and Project Versioning is started.

Requirement

- Audit Document Control and Project Versioning is open and you have authenticated yourself.
- The versioning of the closed WinCC project is configured.

Procedure

1. Select "Project > Archive Project" in the menu bar.
2. Deactivate the "Archive Current Project" option and navigate to the storage path of the required WinCC project.
3. If you want a different archive path, select it using the button.
4. Enter a comment.
5. To begin or increase project file version with the suggested segment, leave the "Automatic versioning" check box selected.
   To begin or increase the project version with another segment, clear the check mark in the "Automatic versioning" check box. Select your required segment under "Increase segment version".
6. Click "Archive."

Result

The archived project is displayed in the navigation area below the "Project Versioning" entry.
There are two views for project versioning:

<table>
<thead>
<tr>
<th>Views</th>
<th>Description</th>
<th>Navigation</th>
</tr>
</thead>
</table>
| Current Project History | Project history of the currently open WinCC project.                      | • Menu bar > "Project > Current Project History"
|                      |                                                                             | • Select "Project Versioning" in the navigation area                                       |
| Complete Project History | Project history of all archived WinCC projects.                           | • Menu bar > "Project > Complete Project History"
|                      |                                                                             | • Select the required project in the navigation area under "Project Versioning"           |

Both views show which user archived the project and under which storage path it is located. In addition, the archive date is displayed with the time and comment.

Restoring previous versions of archived projects

Introduction

If you have versioned a WinCC project, it is possible to restore a previous version.

Requirement

- Your WinCC project is open.
- Audit Document Control and Project Versioning is open and you have authenticated yourself.
- The version number has been configured.

Procedure

1. Select your required project in the navigation area under "Project Versioning".
2. Select the row of the previous version in the table area.
3. Select "Restore" from the shortcut menu.
   A dialog box opens.
4. Select the storage location.
5. Confirm your entries with "OK".
3.6.4 Viewing audit trails in the Audit Viewer

3.6.4.1 Viewing audit trails in the Audit Viewer

Introduction

You can view the audit trails from an Audit Trail multi-project database. The audit trails of an Audit Trail multi-project database can contain different project IDs, since several WinCC projects use this database.

The project ID is changed in the following scenarios:

- Copying and pasting the WinCC project to a different storage location.
- Moving the WinCC project to a different storage location.
- Saving the WinCC project with the Project Duplicator (with or without a name change of the WinCC project).
- Restoring an archived WinCC project in Audit Document Control and Project Versioning.

<table>
<thead>
<tr>
<th>ID</th>
<th>Project ID</th>
<th>Project Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0327F613-AABE-4007-89A3-70880CSA862</td>
<td>all</td>
</tr>
<tr>
<td>2</td>
<td>0327F613-AABE-4007-89A3-70880CSA862</td>
<td>all</td>
</tr>
<tr>
<td>3</td>
<td>0327F613-AABE-4007-89A3-70880CSA862</td>
<td>all</td>
</tr>
<tr>
<td>4</td>
<td>2BCD92D8-56F8-4FB9-8B82-37C8153D0E41</td>
<td>all</td>
</tr>
<tr>
<td>5</td>
<td>2BCD92D8-56F8-4FB9-8B82-37C8153D0E41</td>
<td>all</td>
</tr>
<tr>
<td>6</td>
<td>585EFB90-C51C-4954-8CB7-D62031E416C0</td>
<td>all</td>
</tr>
<tr>
<td>7</td>
<td>585EFB90-C51C-4954-8CB7-D62031E416C0</td>
<td>all</td>
</tr>
<tr>
<td>8</td>
<td>585EFB90-C51C-4954-8CB7-D62031E416C0</td>
<td>all</td>
</tr>
<tr>
<td>9</td>
<td>585EFB90-C51C-4954-8CB7-D62031E416C0</td>
<td>all</td>
</tr>
<tr>
<td>10</td>
<td>585EFB90-C51C-4954-8CB7-D62031E416C0</td>
<td>all</td>
</tr>
<tr>
<td>11</td>
<td>585EFB90-C51C-4954-8CB7-D62031E416C0</td>
<td>all</td>
</tr>
</tbody>
</table>

Requirement

- The Audit Viewer is open.

Display Audit Trails

1. In the navigation area, select "Audit DB". The table area displays all Audit Trail servers to which an Audit Trail database is connected.
2. Select the required row of the Audit Trail server.
3. Select "Select Server" in the shortcut menu. The selected Audit Trail server with the created database is displayed under "Audit DB" in the navigation area. The table area shows all stored audit trails.
4. Open the section of the navigation area below the Audit Trail server with the created database.
   Categories which you can use to browse the Audit Trail database are shown.

5. Select the desired category to view the audit trail.

**Update view**

**View of the server data**

1. In the navigation area under "Audit DB", select the connected Audit Trail server with the created database.

2. Select "Refresh server data" in the context menu.
   Alternatively, click the "Update server" icon in the toolbar.

**View of the categories**

1. Select the desired category in the navigation area below the connected Audit Trail server with the created database.

2. Select "Update view" in the context menu.
   Alternatively, click the "Update view" icon in the toolbar.

**Viewing corrupted Audit trails**

Whenever the Audit Trail record has been manipulated, the Audit Viewer displays all affected audit trails with a red background.

If the corrupted Audit trail is related to electronic signature, you need to validate the Audit trail to display correct information of the corrupted data. To do this, right-click on the Audit trail and select "Validate eSignature". If the "Validate eSignature" option is disabled, it means that the data is corrupted for reasons other than electronic signature.

### 3.6.4.2 Displaying exported audit trails

**Introduction**

You can view exported audit trails in the Audit Viewer.

The Audit Viewer can read the following file formats:

<table>
<thead>
<tr>
<th>File format</th>
<th>Product</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>XML</td>
<td>Audit</td>
<td>V7.2 or higher</td>
</tr>
<tr>
<td>TXT</td>
<td>WinCC flexible</td>
<td>2008 or later</td>
</tr>
<tr>
<td>CSV</td>
<td>WinCC flexible</td>
<td>2008 or later</td>
</tr>
<tr>
<td>RDB</td>
<td>TIA</td>
<td>V12 or later</td>
</tr>
</tbody>
</table>
If a file is stored with a certificate, a prompt for authentication appears when you attempt to open
the file. If you are not able to authenticate, the file will not be opened.

**Note**

**Audit trail manipulations**

If there is suspicion that an export XML file has been manipulated, the Audit Viewer displays all
audit trails of the XML file with a red background.

**Requirement**

- The Audit Viewer is open.

**Procedure**

1. In the navigation area, select "Audit File".
2. Select "Show Audit File" from the shortcut menu.
   A query dialog opens.
4. Click "Open".
5. If the file is stored with a certificate, follow the authentication.

**Result**

The selected file appears under "Audit File" in the navigation area. The content of the file is
displayed in the table area.

### 3.6.4.3 Audit Trail queries

**Introduction**

You can use Audit Trail queries to browse and filter your stored audit trails. You can perform the
following queries:

<table>
<thead>
<tr>
<th>Audit Trail queries</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WinCC Configuration</td>
<td>Shows all audited changes in WinCC Configuration</td>
</tr>
<tr>
<td>WinCC Runtime</td>
<td>Shows all audited changes in WinCC Runtime</td>
</tr>
<tr>
<td>Document Control</td>
<td>Shows all audited changes in Project Versioning and Document Control</td>
</tr>
<tr>
<td>Audit Editor</td>
<td>Shows all audited changes in the Audit Editor</td>
</tr>
</tbody>
</table>
| User queries          | Shows all generated user queries
                       | You can define user queries. These queries are not case-sensitive. |
Requirement

- The Audit Viewer is open.
- The database containing the stored audit trails is selected or the exported Audit file is open.

Procedure for user queries

1. In the navigation area, go to "Audit DB > Audit Trail server with the database > User Queries" to create queries for existing Audit file.
   To create queries for the imported Audit file, go to "Audit File > Exported file > User Queries".
2. In the shortcut menu, select "New Query".
   A new query is created under "User queries". Enter an appropriate name for the query.
3. Define the query in the table area.
4. Select "Run" from the shortcut menu of the query.

Note

Validating a user query

The "Validate" command in the shortcut menu of the query has no function.

Note

"Refresh" query

There will be no conflicts caused due to changes made to a query within the Viewer and Runtime. If one user create/edit a query Q1 in Runtime, only he will be eligible to make changes (if he is the first one to modify the query) and this change reflects when he saves it. However, the second user trying to access the same query Q1 at the same time via the Viewer can edit Q1 but will be unable to save the modifications, a message will be displayed mentioning that another user is editing Q1. Clicking "Refresh" button updates the query in the respective window.

Result

You view the filtered audit trails under "<Query> - Result" in the table area. The result tab always displays the last ran query. You may use the "Close result tab" button in the toolbar to close the displayed result tab manually.
3.6.5 Displaying audit trails in the Audit Viewer Control

3.6.5.1 Audit Viewer Control in the Graphics Designer

Introduction

When you install Audit, the Audit Viewer Control is automatically registered and displayed in the "ActiveX Controls" of the Graphics Designer.

Note

Adding Audit Viewer Control manually

If the Audit Viewer Control is not displayed and you want to manually add it, follow these steps:
1. Open the "Controls" tab and select the entry "Add/Remove" in the shortcut menu of the "ActiveX Controls" folder.
   The "Select OCX Controls" dialog opens.
2. Activate the "WinCC Audit Viewer Control" control in the "Available OCX Controls" area and confirm with "OK".
   The "WinCC AuditViewer Control" is displayed in the "Controls" tab of the "ActiveX Controls" folder.

3.6.5.2 Configuring the Audit Viewer Control

Introduction

To assign parameters for the Audit Viewer Control, enter the Audit Viewer Control in your process screen. To open the Properties window, double-click the Audit Viewer Control.

Title

A default title name is generated when you create the Audit Viewer Control. Click the "Title" textbox to rename and edit the title. Alternatively, navigate to "Object Properties > Properties > Control Properties > Caption" and double-click the existing title to enter a new title.

Audit Trail server name

Specify the Audit Trail server name on which the Audit Trail database is located. To specify the Audit Trail server name, follow these steps:
- Manual input
- Selecting a listed distributed server by double-clicking
- Selecting a local server:
  - Activating a "local server"
  - Select sever by double-clicking
Database name
If you have entered the Audit Trail server manually, also select the required name of the Audit Trail multi-project database.

Maximum record count
Specify the maximum number of Audit Trails that the Audit Viewer Control is to display.

User-defined storage location
Select a storage location in which the user queries are to be stored.

Operator authorization
Select the authorization of the Audit Viewer Control user. Multiple selections are not possible.

Note
For more information on authorizations, refer to the WinCC help at:
- Working with WinCC > Setting up a User Admin > Managing Authorizations > Overview of Authorizations

Print configuration
Specify the required columns for the printing of the Audit Trails. Print configuration is enabled in Runtime also.

Print Preview
The "Print Preview" option allows you to view how the Audit Trails looks like before printing.
To view output of the data grid:
1. In Audit Viewer window, in the navigation area select database of the connected Audit Trail server.
2. Click "File > Print Preview".
   The "Print Preview" window appears.
3. You can navigate through the pages by using "Next Page", "Prev Page" options. You can also "Zoom in" and "Zoom out". Use "Two Page" to view two pages simultaneously.
4. Click "Print" to print the page.
   The "Print Preview" option is also available for User Queries. After you run the query, click "Print Preview" from the "File" menu.

Display
The "Display" attribute specifies whether an object in the PDL file has to be displayed during the Runtime or not.
Select "Yes" to display the object in Runtime and select "No" to not display the object in Runtime.

Note

The Audit Viewer's "Display" attribute when dynamized with C/VB Script, the feature of the "Display" property is not applicable during Runtime.

3.6.5.3 Displaying audit trails in the Audit Viewer Control

Introduction

You can browse the stored audit trails of an Audit Trail database in WinCC Runtime.

Audit Trail queries

You can use Audit Trail queries to browse and filter your stored audit trails.

You can find additional information under:

- Audit Trail queries (Page 82)

Requirement

- The Audit Viewer Control is configured.
- WinCC Runtime is active.

Procedure

1. In the navigation area under "Audit DB", click the Audit Trail server with the created database.
   The table area shows all stored audit trails.
2. Open the section of the navigation area below the Audit Trail server with the created database.
   Categories which you can use to browse the Audit Trail database are shown.
3. Select the desired category to view the audit trails or run a query.

Result

The audit trails are displayed in the table area.
3.6.6 Backup and restore database

Backup database

You can have a backup of the database of your Audit project trails.

Procedure

1. In the Audit Editor, select "Select Audit Trail Server" in the navigation area.
2. Select the entire row of the required database.
3. Right click on the selected row, a list of options appear.
4. Select "Backup Database" option, "Backup Database" window opens.

Note

The "Backup Database" option is enabled only when the selected database is currently connected to the Audit trail Server.
5. Click "..." to browse the desired location to save the database file.

6. Enter a desired file name and click "Save".

![Save As window](image)

The saved back up file is of the type DB - Microsoft SQL Server WinCC Backup with .mdfbak extension.

**Restore database**

To restore a database, you need to create a new Audit project with all the configurations and settings completed in Audit Editor. Follow the procedure given below to restore a database.

**Procedure**

1. In the navigation area of Audit Editor, select "Select Audit Trail Server".
2. Connect to the required database by selecting the Server.
3. Select the entire row of the required database.
4. Right click on the selected row, a list of options appear.

**Note**

The "Restore Database" option is enabled only when the selected database is currently connected to the Audit trail Server.

5. Select "Restore Database" option, "Restore Database" window opens.
6. Click "..." to browse the location of the saved backup database file.
7. Select required backup file and click "Open".
8. Click "OK".

Note
The remote backup/restore of database is not supported.

Result
All Audit Trails saved in the back up file is restored in the new project and can be viewed in the Audit Viewer.

3.6.7 Writing Audit Trails from external applications into Audit database

Introduction
Other third party applications can also write Audit Trails into audit database using an Application Programing Interface (API) called IAuditTrailAPI. The API provides functions to create and store Audit Trail records into the Audit Trail Database. The functions of IAuditTrailAPI interface are:
1. Enumerate list of available trail servers.
2. Establish connection with a specific Trail Server.
3. Insert specific tracking objects into the connected Trail Server database.
4. Query a subset of stored tracking objects, applying a specific filter selection.
5. Enable disconnection of the current connected Trail Server.

Refer the example given below to know how to initiate the interface.

```c
#include "CCAuditTrailAPI.h"
#include "CCAuditTrailAPI_i.c"
CComPtr <IAuditTrailAPI> pIAuditTrailAPI;
HRESULT hr = CoCreateInstance(CLSID_CCAuditTrailAPI, NULL, CLSCTX_ALL, IID_IAuditTrailAPI, (VOID**)&pIAuditTrailAPI);
```
The functions of the interface are:

1. HRESULT GetTrailServerList ([out] VARIANT* pvaServerList); //Enumerates all the available Trail Database per Machines
   **Parameters**

   **Parameter** | **Description**
   |----------------|
   pvaServerList | List of available trail servers and databases as VARIANT with bi-dimensional SAFEARRAY of BSTR.

   The following example shows how to use it.
   ```cpp
   if (pIAuditTrailAPI)
   {
       CComVariant svaServerList;
       hr = pIAuditTrailAPI->GetTrailServerList(&svaServerList);
       if (SUCCEEDED(hr) && svaServerList.parray)
       {
           for (LONG nServer = 0; nServer < svaServerList.parray->rgsabound[0].cElements; nServer++)
           {
               CComVariant vaComputerName;
               CComVariant vaDSN;
               LONG lDimension [2] = {0, 0}; lDimension[0] = 0;
               lDimension[1] = nServer;
               hr = SafeArrayGetElement(svaServerList.parray, lDimension, &vaComputerName);
               if (SUCCEEDED(hr) && (VT_BSTR == vaComputerName.vt))
               {
                   lDimension[0] = 1;
                   hr = SafeArrayGetElement(svaServerList.parray, lDimension, &vaDSN);
                   if (SUCCEEDED(hr) && (VT_BSTR == vaDSN.vt))
                   {
                       //..
                   }
               }
           }
       }
   }
   ```

2. HRESULT Connect ([in] VARIANT* pvaServer); //Establish a connection with the specified Trail Server
   **Parameters**

   **Parameter** | **Description**
   |----------------|
   pvaServer | Trail servers and databases to be connected as VARIANT with SAFEARRAY of BSTR.

   The following example shows how to use it.
   ```cpp
   CComVariant vaComputerName (L"<ComputerName>");
   CComVariant vaDSN (L"<DatabaseName>");
   CComVariant svaServer;
   SAFEARRAYBOUND rgsabound [1];
   LONG lIndex = 0;
   ```
rgsabound[0].llbound = 0;
rgsabound[0].cElements = 2;
VariantInit(&svaServer);
svaServer.vt = VT_ARRAY | VT_BSTR;
svaServer.parray = SafeArrayCreate(VT_VARIANT, 1, rgsabound);
lIndex = 0;
HRESULT hr = SafeArrayPutElement(svaServer.parray, &lIndex,
&vaComputerName);
lIndex = 1;
hr = (SUCCEEDED(hr)) ? SafeArrayPutElement(svaServer.parray,
&lIndex, &vaDSN) : hr;
if (SUCCEEDED(hr))
{
    hr = m_pIAuditTrailAPI->Connect(&svaServer);
    if (SUCCEEDED(hr))
    {
        //...
    }
}

Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pbstrProjectGUID</td>
<td>Project GUID of the stored tracking object (The GUID must correspond to an opened project)</td>
</tr>
<tr>
<td>pbstrProjectName</td>
<td>Project name of the stored tracking object</td>
</tr>
<tr>
<td>pbstrOSUser</td>
<td>OS User name that has performed the operation</td>
</tr>
<tr>
<td>pbstrApplicationUser</td>
<td>Application User name that has performed the operation</td>
</tr>
<tr>
<td>pbstrComputerName</td>
<td>Computer name where the change took place.</td>
</tr>
<tr>
<td>nTargetID</td>
<td>Specific Target ID</td>
</tr>
<tr>
<td>nChangeID</td>
<td>Specific Change ID</td>
</tr>
<tr>
<td>nModificationID</td>
<td>Specific Modification ID</td>
</tr>
<tr>
<td>pbstrOldValue</td>
<td>Old value of the stored tracking object</td>
</tr>
<tr>
<td>pbstrNewValue</td>
<td>New value of the stored tracking object</td>
</tr>
<tr>
<td>pbstrComments</td>
<td>Comments associated to the tracking object</td>
</tr>
</tbody>
</table>

The following example shows how to use it.

```c
if (pIAuditTrailAPI)
{
    CComBSTR bstrProjectGUID (L"{00000000-0000-0000-0000-000000000000}"); //The GUID must correspond to an opened project CComBSTR bstrProjectName (L"ProjectName");
    CComBSTR bstrOSUser (L"WindowsUser");
    CComBSTR bstrApplicationUser (L"AppUser");
    CComBSTR bstrComputerName (L"ComputerName");
    CComBSTR bstrTargetName (L"TargetName");
    CComBSTR bstrChangeID (L"ChangeID");
    CComBSTR bstrOldValue (L"OldValue");
    CComBSTR bstrNewValue (L"NewValue");
    CComBSTR bstrComments (L"Comment");
    INT iTargetID = 0;
    INT iModificationID = 0;
    HRESULT hr = pIAuditTrailAPI->InsertAuditEntry(&bstrProjectGUID, &bstrProjectName, &bstrOSUser, &bstrApplicationUser, &bstrComputerName, &bstrTargetName, &bstrChangeID, &bstrOldValue, &bstrNewValue, &bstrComments);
}```
if (SUCCEEDED(hr))
{
    //..
}
}
4. **HRESULT GetAuditEntries ([in] BSTR* pbstrFilter, //Retrieves a list of Tracking Objects that accomplish the supplied filter [out] VARIANT* pvaTrackingObjectList);**

**Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pbstrFilter</td>
<td>Filter in XML format with the information needed to retrieve the Data (the example shown the format)</td>
</tr>
<tr>
<td>pvaTrackingObjectList</td>
<td>List of Tracking objects as VARIANT with a bi-dimensional SAFE-ARRAY with all data.</td>
</tr>
</tbody>
</table>

The following example shows how to use it.

```cpp
cComBSTR bstrFilter (L"");
bstrFilter += L"<Filter>
";
bstrFilter += L"<DataSource>
";
bstrFilter += L"DataSourceName"; //Name of Data Source used in the Connection function
bstrFilter += L"</DataSource>
";
bstrFilter += L"<From>
";
bstrFilter += L"CL_TRAILDATA"; //Keep this field fixed
bstrFilter += L"</From>
";
bstrFilter += L"<Select>
";
bstrFilter += L"*"; //Keep this field fixed
bstrFilter += L"</Select>
";
bstrFilter += L"<Where>
";
bstrFilter += L"ID > 0"; //Use this field to manage the output using the normal condition in SQL considering the table fields
bstrFilter += L"</Where>
";
bstrFilter += L"<RecordCount>
";
bstrFilter += L"10"; //Number of Records to retrieve
bstrFilter += L"</RecordCount>
";
bstrFilter += L"<OrderByClause>
";
bstrFilter += L"ID DESC"; //Order used in the database query
bstrFilter += L"</OrderByClause>
";
if (pIAuditTrailAPI)
{
    CComVariant svaResult;
    HRESULT hr = pIAuditTrailAPI->GetAuditEntries(&bstrFilter, &svaResult);
    if (SUCCEEDED(hr) && svaResult.parray)
    {
        LONG lDimension [2] = {0, 0};
        for (INT nSize = 0; nSize < svaResult.parray->rgsabound[0].cElements; nSize++)
        {
            _variant_t vaTrackingID;
            _variant_t vaProjectID;
            _variant_t vaProjectName;
            _variant_t vaDateTime;
            _variant_t vaTimeZoneOffset;
            _variant_t vaWindowsUser;
            _variant_t vaApplicationUser;
```
_variant_t vaComputerN;
_variant_t vaCategoryID;
_variant_t vaSubCategoryID;
_variant_t vaTargetID;
_variant_t vaTargetName;
_variant_t vaSpecificChangeID;
_variant_t vaModificationID;
_variant_t vaOldValue;
_variant_t vaNewValue;
_variant_t vaOperatorMsgID;
_variant_t vaReason;
_variant_t vaAuditType;
_variant_t vaLegacyProjectGUID;
_variant_t vaLegacyDatabaseName;
_variant_t vaLegacyApplicationName;
_variant_t vaLegacyTableName;
_variant_t vaLegacyFieldName;
_variant_t vaLegacyEventType;
_variant_t vaLegacyEventItem;
VariantInit(&vaTrackingID);
VariantInit(&vaProjectID);
VariantInit(&vaProjectName);
VariantInit(&vaDateTime);
VariantInit(&vaTimeZoneOffset);
VariantInit(&vaWindowsUser);
VariantInit(&vaApplicationUser);
VariantInit(&vaComputerN);
VariantInit(&vaCategoryID);
VariantInit(&vaSubCategoryID);
VariantInit(&vaTargetID);
VariantInit(&vaTargetName);
VariantInit(&vaSpecificChangeID);
VariantInit(&vaModificationID);
VariantInit(&vaOldValue);
VariantInit(&vaNewValue);
VariantInit(&vaOperatorMsgID);
VariantInit(&vaReason);
VariantInit(&vaAuditType);
VariantInit(&vaLegacyProjectGUID);
VariantInit(&vaLegacyDatabaseName);
VariantInit(&vaLegacyApplicationName);
VariantInit(&vaLegacyTableName);
VariantInit(&vaLegacyFieldName);
VariantInit(&vaLegacyEventType);
VariantInit(&vaLegacyEventItem);
vaTrackingID.vt = VT_UI8;
vaProjectID.vt = VT_BSTR;
vaProjectName.vt = VT_BSTR;
vaDateTime.vt = VT_DATE;
vaTimeZoneOffset.vt = VT_R4;
vaWindowsUser.vt = VT_BSTR;
vaApplicationUser.vt = VT_BSTR;
vaComputerN.vt = VT_BSTR;
vaCategoryID.vt = VT_UI2;
vaSubCategoryID.vt = VT_UI2;
vaTargetID.vt = VT_UI2;
vaTargetName.vt = VT_BSTR;
vaSpecificChangeID.vt = VT_BSTR;
vaModificationID.vt = VT_BSTR;
vaOldValue.vt = VT_BSTR;
vaNewValue.vt = VT_BSTR;
vaOperatorMsgID.vt = VT_UI8;
vaReason.vt = VT_BSTR;
vaAuditType.vt = VT_BSTR;
vaLegacyProjectGUID.vt = VT_BSTR;
vaLegacyDataBaseName.vt = VT_BSTR;
vaLegacyApplicationName.vt = VT_BSTR;
vaLegacyTableName.vt = VT_BSTR;
vaLegacyFieldName.vt = VT_BSTR;
vaLegacyEventType.vt = VT_BSTR;
vaLegacyEventItem.vt = VT_BSTR;

lDimension[1] = nSize;
for (INT nPos = 0; nPos < 26; nPos++)
{
    lDimension[0] = nPos;
    switch (nPos)
    {
        case 0 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaTrackingID); break;
        case 1 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaProjectID); break;
        case 2 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaProjectName); break;
        case 3 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaDateTime); break;
        case 4 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaTimeZoneOffset); break;
        case 5 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaWindowsUser); break;
        case 6 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaApplicationUser); break;
        case 7 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaComputerN); break;
        case 8 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaCategoryID); break;
        case 9 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaSubCategoryID); break;
        case 10 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaTargetID); break;
        case 11 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaTargetName); break;
        case 12 : hr = SafeArrayGetElement(svaResult.parray,
            lDimension, &vaSpecificChangeID); break;

    }
case 13 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaModificationID); break;
case 14 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaOldValue); break;
case 15 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaNewValue); break;
case 16 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaOperatorMsgID); break;
case 17 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaReason); break;
case 18 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaAuditType); break;
case 19 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaLegacyProjectGUID); break;
case 20 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaLegacyDataBaseName); break;
case 21 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaLegacyApplicationName); break;
case 22 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaLegacyTableName); break;
case 23 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaLegacyFieldName); break;
case 24 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaLegacyEventType); break;
case 25 : hr = SafeArrayGetElement(svaResult.parray, lDimension, &vaLegacyEventItem); break;
default :
}  
if (FAILED(hr))
{
    break;
}
}  
if (SUCCEEDED(hr))
{
    //Use the data in the variant variables
    VariantClear(&vaTrackingID);
    VariantClear(&vaProjectID);
    VariantClear(&vaProjectName);
    VariantClear(&vaDateTime);
    VariantClear(&vaTimeZoneOffset);
    VariantClear(&vaWindowsUser);
    VariantClear(&vaApplicationUser);
    VariantClear(&vaComputerN);
    VariantClear(&vaCategoryID);
    VariantClear(&vaSubCategoryID);
    VariantClear(&vaTargetID);
    VariantClear(&vaTargetName);
    VariantClear(&vaSpecificChangeID);
    VariantClear(&vaModificationID);
    VariantClear(&vaOldValue);
    VariantClear(&vaNewValue);
VariantClear(&vaOperatorMsgID);
VariantClear(&vaReason);
VariantClear(&vaAuditType);
VariantClear(&vaLegacyProjectGUID);
VariantClear(&vaLegacyDataBaseName);
VariantClear(&vaLegacyApplicationName);
VariantClear(&vaLegacyTableName);
VariantClear(&vaLegacyFieldName);
VariantClear(&vaLegacyEventType);
VariantClear(&vaLegacyEventItem);
if (FAILED(hr))
{
    break;
}
}

5. HRESULT Disconnect (); // Establish a connection with the specified Trail Server
   Parameters: Not required
   The following example shows how to use it:
   if (pIAuditTrailAPI)
   {
       HRESULT hr = pIAuditTrailAPI->Disconnect();
       if (SUCCEEDED(hr))
       {
           //..
       }
   }

3.6.8 Viewing Audit Trails in Information Server

Creating Audit Trails Report using Information Server

   Introduction
   Audit supports creation of reports in the SIMATIC Information Server.

   Requirement
   Activate the WinCC project in Runtime.

   Procedure
   1. Connect to the home page of the Information Server and login.
   2. Click "Administration > Configuration".
3. Enter "wincc" as the data source in "SQL instance" and click "Select Projects". The desired project is listed.

4. Click "Reporting" tab to view all the available templates of the Audit under "Reporting templates > Templates > Public > Audit".
5. Open the "Messages sorted by timestamp" template and provide the necessary details to create the report for the selected project.
Select the desired "Project, ServerName, and ServerInstance".
Select the time range.
Select the desired Audit DB and Audit Server name.
In "Select Info" column, group and filter the columns based on the available context information.
Enter the "Footer Information" and image name in "Header Back Image" and "Logo Image" fields. The images should be available in the SQL Server Reporting Services. To add images in SQL Server Reporting Images folder, provide server name, create folder, and add images. The images should be in .png format.
6. Click "Show Preview".
7. Click "Create report". The report for Audit trails is generated.

**Viewing Audit Trails Report using Excel add-in**

You can view the Audit trail report in Microsoft Excel using Excel add-in. The Excel add-in uses Information Server as the data source. Use Report templates from the Information Server as template in Excel. Report templates can also be stored locally.
① Creates Audit report based on the time range.
② Inserts the selected presets and generates a report.
③ Connects to Excel add-in.
3.6.9 Exporting audit trails to a CSV file

Introduction
You can export filtered audit trails to a CSV file.

Requirement
- The Audit Viewer is open.

Procedure
1. Perform a query or select a category.
2. In the menu bar, select "File > Export". A query window opens.
3. Select the storage location.
4. Click "Export".

3.6.10 Data conversion

Introduction
You have the option of converting data in order to use your stored audit trails in another system. The Audit Editor allows you to export entries from a limited time range or a complete Audit Trail database.

To export a limited time range, specify a start date and an end date with the time information.

If you want to export the complete Audit Trail database, you do not need to specify a start date and end date with time information.

For additional protection you can attach a certificate to the export. To use this function, the certificate must be stored in the Windows certificate memory.

Requirement
- Your WinCC project is open.
- The Audit Editor is open and you have authenticated yourself.

Procedure
1. Open the shortcut menu under "Audit Trail" in the navigation area.
2. Click "Export Database". A query window opens.
3. Select a storage location using the "..." button under "Select file".
4. If you want to use a certificate, enable the "Use certificate" option and select a certificate using the "..." button.

5. To apply a date and time filter, select the "Use date filter" option under "Date filter". Enter the required information.

6. To export the complete Audit Trail database, select the "Do not use date filter" option under "Date filter".

7. Confirm your entries with "OK".

Result

The Audit Trail database is exported as an XML file.

3.6.11 Connecting Audit to Report Designer

Introduction

The newly created Audit database is not automatically configured to the Report Designer. The layouts in the Report Designer have Audit database names such as CC_AUDIT_DATABASE and AUDIT_DATABASE_MP. Replace the database name with the new database name to print reports.

Requirement

A configured Audit database.

Procedure

1. In the WinCC Explorer navigation window, go to "Report Designer > Layouts". The list of layouts displays.

2. Select "Language neutral" and the data window displays a list of layouts related to Audit.

3. Double-click the appropriate layout in the data window. The "Report Designer Layout – […]" window opens.
4. Right-click the table available in the workspace and select "Properties". The "Object Properties" dialog box displays.

5. Select "Connect" tab and double-click the "Database link" property. The "Database Connection" dialog opens.

6. Under "ODBC Data Source", unselect the "Tag" checkbox.

7. From the drop-down list above the checkbox, select the appropriate WinCC project.

8. Select the "Tag" checkbox once again to disable this drop-down list.
9. In the "SQL statement" display area, replace the database name "CC_AUDIT_DATABASE" with the new database name as shown in the image.

10. Click the "Test SQL Statement" tab to check.

11. If no errors are found, click "Close". If error appears, re-check the database name and repeat steps 9 and 10.

12. Close the "Data Connection" dialog box.

13. Click "Save".

Result

The Audit database is linked to the Report Designer. Navigate to "Print jobs" to preview the report.

3.7 Migration

3.7.1 Migrating audit data

Introduction

If you are already using Audit V7.2/V7.3/V7.4/V7.4 SP1, you can migrate your Audit configurations and your saved Audit Trails to Audit V7.5.

Note

Migration of Audit V7.2/V7.3/V7.4/V7.4 SP1 databases

You can migrate the following from your Audit V7.2/Audit V7.3/Audit V7.4 single project database to Audit V7.5:

- Audit configuration
- Audit trails

You can migrate the following from your Audit V7.2/Audit V7.3/Audit V7.4/Audit V7.4 SP1 multiproject database to Audit V7.5:

- Audit configuration

One-time migration

Migration can only be started once. If you do not perform the migration, the option is not offered again.

If you reject a migration step, you will not have the opportunity to repeat this step.
Migrating audit configurations and audit trails

Migrating multiproject database

Follow the procedure to migrate a multiproject database:

1. Open your WinCC project.
2. Open the Audit Editor and authenticate yourself.
   A prompt appears asking whether you want to migrate the Audit configuration of the previous version.
3. Confirm with "Yes".
4. Connect to the Audit Trail database below "Select Server".
   A prompt appears asking whether you want to migrate the Audit database of the previous version.
5. Confirm with "Yes".

Migrating single project database

Opening a project connected to a single project database in Audit V7.5 will be converted into a multiproject database. Audit Editor auto-detects for single project database and initiate data migration.

Follow the procedure to migrate a single project database:

1. Open Audit Editor. A dialog box opens to inform that the project configuration is of type single project database and it is not supported in this version. You need to create a multiproject database for data migration.
2. Click "OK".
3. Create a new multiproject database or select an existing multiproject database in Audit Editor. A dialog box opens to inform that the Audit database will be changed to a multiproject database.
4. Click "Yes". This migrates data from the single project database to the new multiproject database. You can view the saved Audit Trails in Audit Viewer.

Result

Your configuration settings are migrated in the Audit Editor. The stored audit trails of the previous version are migrated to the current Audit Trail database. Some of the values are shown in the columns whose names start with "Legacy".

3.7.2 Viewing Audit V7.2 multi-project database

Introduction

You have two options for displaying the Audit Trails of an Audit V7.2 or Audit V7.3 multiproject database.
WinCC and Audit V7.2 or Audit V7.3 are installed on your PC

1. In Audit Editor V7.2, export the audit trails from the multiproject database.
2. Upgrade to WinCC V7.5 and Audit V7.5.
3. View the exported audit trails in the Audit Viewer V7.5.

3.7.3 Migrating Document Control and Project Versioning

The archive of the Document Control and Project Versioning of Audit V7.2, Audit V7.3, Audit V7.4 and Audit V7.4 SP1 cannot be migrated to Audit V7.5.

After Audit V7.5 has been installed, you must set up the Document Control again:

- Enable the Document Control in the Audit Document Control and Project Versioning. This checks-in and saves all the WinCC project files of your opened WinCC project.
- Archive your WinCC project in the Audit Document Control and Project Versioning.

You can find additional information under:
- Archiving and versioning WinCC project data (Page 67).

3.7.4 Migrating user administration

The user group "SIMATIC HMI AUDIT" remains available in Audit V7.5. All users can authenticate themselves in the Audit Editor and Audit Document Control and Project Versioning, provided they are members in the user group "SIMATIC HMI AUDIT".

You can find additional information in the installation notes under:
- User authentication (Page 9).

3.7.5 InsertAuditEntry

Introduction

If you use the "InsertAuditEntry" function of Audit V7.2 in a WinCC project, you can continue to use the function with Audit V7.5.

It is not necessary to change your scripts.

Some of the values from the "InsertAuditEntry" will be displayed in the Audit Trail database in columns whose names begin with "Legacy".

InsertAuditEntryNew

For all new WinCC projects, use the "InsertAuditEntryNew" function.
You can find additional information under:

- **InsertAuditEntryNew** (Page 56)

**InsertAuditEntry in the Script Editor or in the Graphics Designer**

**C Editor/Graphics Designer**
You can find the InsertAuditEntry function in the navigation area under "Project Functions".

---

**Note**

**Regenerating the header**

If the "InsertAuditEntry" function is not visible, you need to re-generate the header in the C Editor.

---

**VBS Editor/Graphics Designer**
You can find the InsertAuditEntry function in the navigation area under "Project Modules".
Index

C
Customer support, (See support)

E
Error report, (See support)

F
FAQ, (See support)

O
Online support, (See support)

S
Support, 17, 19
Support Request, 19

T
Technical support, (See support)