SIMATIC

Function modules
FM 451 First Steps in Commissioning

Getting Started
Safety Guidelines

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are graded according to the degree of danger.

**DANGER**
indicates that death or severe personal injury will result if proper precautions are not taken.

**WARNING**
indicates that death or severe personal injury may result if proper precautions are not taken.

**CAUTION**
with a safety alert symbol, indicates that minor personal injury can result if proper precautions are not taken.

**CAUTION**
without a safety alert symbol, indicates that property damage can result if proper precautions are not taken.

**NOTICE**
indicates that an unintended result or situation can occur if the corresponding information is not taken into account.

If more than one degree of danger is present, the warning notice representing the highest degree of danger will be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property damage.

**Qualified Personnel**

The device/system may only be set up and used in conjunction with this documentation. Commissioning and operation of a device/system may only be performed by qualified personnel. Within the context of the safety notes in this documentation qualified persons are defined as persons who are authorized to commission, ground and label devices, systems and circuits in accordance with established safety practices and standards.

**Prescribed Usage**

Note the following:

**WARNING**
This device may only be used for the applications described in the catalog or the technical description and only in connection with devices or components from other manufacturers which have been approved or recommended by Siemens. Correct, reliable operation of the product requires proper transport, storage, positioning and assembly as well as careful operation and maintenance.

**Trademarks**

All names identified by ® are registered trademarks of the Siemens AG. The remaining trademarks in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

**Disclaimer of Liability**

We have reviewed the contents of this publication to ensure consistency with the hardware and software described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the information in this publication is reviewed regularly and any necessary corrections are included in subsequent editions.
# Table of contents

1. Introduction ................................................................. 5
2. Requirements ................................................................. 7
3. Installing the configuration package on the PG .................. 9
4. FM 451, installing and wiring ........................................... 11
5. FM 451, programming .................................................... 13
6. FM 451, testing ............................................................. 15
7. Integration in the user program ......................................... 17
8. Diagnostics ................................................................. 19
9. Example ........................................................................ 21
Table of contents
Introduction

This Getting Started is intended to lead you through the five steps in commissioning a fully functional application. Based on a practical example, it shows you how to execute a motion via channel 1, and introduces the basic functions of FM 351 hardware and software, and shows you how to determine and test application-specific parameters. The references to the manual should give you an initial overview of the information it contains.

It will take between 1 and 2 hours to work through the example, depending on your experience.
Requirements

Hardware and software requirements:

- An S7-400 station, consisting of a power supply module and a CPU.
- STEP 7 (≥V4.02) is properly installed on your PG. Note, however, that the instructions below are based on STEP 7 (V5.0)
- You have configured a project for the S7-400 station.
- The PG is connected to the CPU.
- You have an FM 451 module and its configuration package, an external 24 V DC power supply, an encoder, a drive, and all necessary accessories such as front connectors and wiring material.
- You installed hardware limit switches and EMERGENCY OFF switches to protect your operating personnel and the plant.
Installing the configuration package on the PG

Place the CD into the CD drive.

In Windows, run the software setup dialog by double-clicking "Add/Remove Programs" in the "Control Panel".

Click Install... on the CD in the directory start FMx51\Disk1 and follow the instructions issued by the installation program.
Installing the configuration package on the PG
FM 451, installing and wiring

FM 451, installing and wiring

Switch off the power supply, then set the mode selector switch of the CPU to STOP.

Hook the FM 451 onto the designated slot of the rack, tilt it downwards, and screw it into place. You can find a detailed explanation in the manual.

Wire the front connector as in the following image. You can find the complete allocation of the front connector in the manual.

K1 = direction positive
K2 = direction negative
K3 = rapid speed
K4 = creep speed
L1 = hardware limit switch left
L2 = hardware limit switch right

Figure 4-1 Circuit diagram FM 451

Insert the wired front connector into the FM 451 and secure it with the screws.

Connect the encoder to the d-sub socket “ENCODER CH1.” To do this use a if possible a cable set plug-in cable. You can find the complete allocation of the d-sub socket in the manual.

Test:

Switch on the power supply module, and the external 24 V DC power supply.

The red LED EXTF of the FM 451 lights up briefly. The LED INTF remains lit, because the FM 451 is not yet set up in HW Config.
Open your project in SIMATIC Manager.

Open the "HW Config" configuration table in your project.

In the hardware catalog, select the FM 451 with the correct order number, then drag-and-drop it to the relevant slot of your hardware configuration. Note down the module address. You will need this value when you integrate the module in your user program.

Double-click this FM 451 to open the "Positioning module – [FM 451 FIX. SPEED (slot) (parameter assignment) -- Project name\station name]" window in the configuration tool.

Select the following settings on the programming interface (leave all other settings unchanged, because they are not initially required for commissioning):

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel</td>
<td>1</td>
</tr>
<tr>
<td>System of units</td>
<td>mm</td>
</tr>
<tr>
<td>Drive Control mode</td>
<td>1</td>
</tr>
<tr>
<td>Target range</td>
<td>1,000 mm</td>
</tr>
<tr>
<td>Monitoring time</td>
<td>2,000 ms</td>
</tr>
<tr>
<td>Stationary range</td>
<td>1,000 mm</td>
</tr>
<tr>
<td>Stationary speed</td>
<td>30,000 mm/min</td>
</tr>
<tr>
<td>Switchover difference plus</td>
<td>&gt; Switch-off difference plus:</td>
</tr>
<tr>
<td>Switchover difference minus</td>
<td>&gt; Switch-off difference minus:</td>
</tr>
<tr>
<td>Switch-off difference plus</td>
<td>&gt; 1/2 x target range</td>
</tr>
<tr>
<td>Switch-off difference minus</td>
<td>&gt; 1/2 x target range</td>
</tr>
</tbody>
</table>

After you have successfully completed your basic program, determine the appropriate plant-specific values of the plus and minus switchover / switch-off differences, and then adapt the parameters to suit your system requirements.

Axis: Linear axis/ rotary axis: application-specific

Software limit switches: application-specific

End of the rotary axis: application-specific

Encoder: Encoder type: Select the encoder you are using.

All further encoder settings are device- and plant-specific.
Accept the FM 451 parameters in your configuration by selecting File > Save, then close the configuration tool with File > Close.

Save your project configuration data by selecting Station > Save and Compile.

When the CPU is in STOP, select PLC > Download to module to download the configuration data.

The data are now transferred directly to the CPU and FM 451. The INTF LED of FM 451 goes dark. As long as all configuration data remain backed up in CPU memory, the CPU always transfers these to FM 451 at each STOP to RUN transition.
In HW Config, once again double-click the FM 451 to open the "Positioning module -- [FM 451 FIX. SPEED (slot) (parameter assignment) -- Project name\station name]".

Click **Test > Commissioning** to open the commissioning screen form [FM 451 FIX. SPEED (slot) (commissioning) -- Project name\station name].

Select "Mode", then select "Jog" to enter the required velocity (rapid speed or creep speed.)

Click "On" at "Drive enable." This action highlights the "Start enable" entry in green color on the commissioning screen form. If you have not wired the enable input at FM 451, select "Additional Test functions", set the "Function switch" option "Do not evaluate enable input", and then click "Apply."

Click DIR_M or DIR_P: The drive will keep moving as long as you press the mouse button. You can now monitor the setpoint and actual value of the velocity.

**Note:**

The actual value changes according to the directional input DIR_M (move in minus direction) or DIR_P (move in plus direction.) If the count direction is not correct, select "Edit parameters" to open the "Encoder" dialog box, then change the count direction from "Normal" to "Inverted." Download your changes to the CPU and FM 451 by selecting **PLC > Download channel > 1**. The actual value of the rapid and creep speed shows you whether or not the digital outputs of FM 451 are properly wired.

Any errors detected in this test are reported at the "Error" display. Acknowledge those operating errors by selecting **Test > Error evaluation**, and then continue testing.

In the next step, adapt the switchover / switch-off differences to correct your positioning parameters.

Select "Mode", then select "Incremental Absolute Approach", and then enter the value 255 at "Incremental Dimension Number": The view shows you the "incremental dimension," "switchover difference" and "switch-off difference" fields. Enter a positive positioning target value at the "Incremental Dimension" field. Enter the value set in the drive screen form at the "switchover difference" and "switch-off difference" fields. Make sure the incremental dimension is higher than the switchover and switch-off difference.

At "Additional Test Functions", select "Set Reference Point", enter the reference point 0.000 mm, and then click "Apply." This action synchronizes the axis. The system returns the message "Channel Synchronized."

Select "Additional Test Functions > Function Switches > Do Not Evaluate Enable Input", and then click Apply.

Set drive enable: The system returns the message "Start enabled." Click "Start" to position the axis to the default incremental dimension. The "Distance to go" and "Position reached -- Stop" displays indicate the positioning accuracy.
You can improve positioning accuracy by reducing or increasing the switchover and switch-off differences. You also obtain the "Position reached -- Stop" message by increasing the target range. Adjust those parameters until you receive the "Position reached -- Stop" message and the actual positioning value is close enough to being equal to the incremental dimension. Note down the values you have thus determined for the positive switchover / switch-off differences.

Select a negative incremental dimension to determine the negative switchover and switch-off differences.

Select **Change Parameters For > Drive**, open the drive parameter view, then enter the determined values at the relevant parameters.

Click **File > Save** to save your settings, then exit the configuration software by clicking **File > Exit**.

Save your project configuration data by selecting **Station > Save and Compile**.

Set the CPU to STOP, then download your configuration to the CPU by selecting the **PLC > Download to Module** command.
Integration in the user program

In SIMATIC Manager, select File > Open... > Libraries to open the FMx51LIB library.

Copy FC0, FC1 and UDT1 from the blocks container of the FMx51LIB library to the "Blocks" container of your project.

Select Insert > S7 Block > Data Block to insert DB 1, and Insert > S7 Block > Organization Block to insert OB 100 in "Blocks" container of your project.

Open DB 1, then program it with the help of its assigned user-specific UDT1. This is how you generate the channel DB.

Open View > Data View. Select the "Actual value" column, then set the decimal address at parameter MOD_ADDR, and channel number 1 at the CH_NO parameter in DB 1.

Select File > Save to save your DB1, and exit the DB editor by clicking File > Exit.

Next, open OB100 and OB1 in your project and call FC0 in OB100, and FC1 in OB1. Program those FCs accordingly (see the manual):

OB 100:
CALL FC 0
DB_NO := 1

OB 1:
CALL FC 1
DB_NO := 1

RET_Val := MW0

Save OB100 and OB1 by clicking File > Save.

In your project, select the FC0, FC1, DB1, OB1 and OB100 blocks.

Download your program to the CPU by selecting PLC > Download.

Test:
Use the "Monitor and modify variables" function to monitor the selected channel.

In the symbol editor, assign DB1 a symbol named "ABS."

Select the "Blocks" container of your project. Insert variable table VAT1 by clicking Insert > S7 Block > Variable Table, and then confirm your entries with OK.

Open variable table VAT1, then make the entries in the "Symbol", "Display format" and "Modify value" columns:
Integration in the user program

<table>
<thead>
<tr>
<th>Address</th>
<th>Symbol</th>
<th>Display format</th>
<th>Status value</th>
<th>Modify value</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>DB1.DBX 22.3</td>
<td>ABS.OT_ERR</td>
<td>BIN</td>
<td>0</td>
<td>0</td>
<td>Operating error</td>
</tr>
<tr>
<td>DB1.DBX 14.3</td>
<td>ABS.OT_ERR_A</td>
<td>BIN</td>
<td>0</td>
<td>0</td>
<td>Acknowledge operating error</td>
</tr>
<tr>
<td>DB1.DBX 15.0</td>
<td>ABS.START</td>
<td>BIN</td>
<td>0</td>
<td>0</td>
<td>Start positioning</td>
</tr>
<tr>
<td>DB1.DBX 15.1</td>
<td>ABS.STOP</td>
<td>BIN</td>
<td>0</td>
<td>0</td>
<td>Stop current motion</td>
</tr>
<tr>
<td>DB1.DBX 15.2</td>
<td>ABS.DIR_M</td>
<td>BIN</td>
<td>0</td>
<td>0</td>
<td>Direction minus</td>
</tr>
<tr>
<td>DB1.DBX 15.3</td>
<td>ABS.DIR_P</td>
<td>BIN</td>
<td>1</td>
<td>1</td>
<td>Direction plus</td>
</tr>
<tr>
<td>DB1.DBX 15.7</td>
<td>ABS.DRV.EN</td>
<td>BIN</td>
<td>1</td>
<td>1</td>
<td>Enable drive</td>
</tr>
<tr>
<td>DB1.DBX 34.2</td>
<td>ABS.EI_OFF</td>
<td>BIN</td>
<td>1</td>
<td>1</td>
<td>Do not evaluate enable input</td>
</tr>
<tr>
<td>DB1.DBB 16</td>
<td>ABS.MODE_IN</td>
<td>DEC</td>
<td>1</td>
<td>1</td>
<td>Requested mode: 1 = jogging</td>
</tr>
<tr>
<td>DB1.DBB 17</td>
<td>ABS.MODE_TYPE</td>
<td>DEC</td>
<td>1</td>
<td>1</td>
<td>Start velocity in jogging mode</td>
</tr>
<tr>
<td>DB1.DBD 26</td>
<td>ABS.ACT_POS</td>
<td>DEC</td>
<td></td>
<td></td>
<td>Current axis position</td>
</tr>
</tbody>
</table>

Save variable table VAT1 by clicking **Table > Save**.

Go online by selecting **PLC > Connect to > Configured CPU**.

Set monitoring mode by selecting **Variable > Monitor**.

**CAUTION**

In the next two test steps you will start the drive.

Options of stopping the drive again:

- Reset the direction modify value to zero and activate it
- Reset the drive enable modify value to zero and activate it
- Set the CPU to STOP

Set the CPU to RUN-P.

Select **Variable > Activate Modify Values** to validate the modify values.

This starts the drive. At the "Status value" column, you can now monitor the actual position value ACT_POS.
Diagnostics

Errors may occur due to improper operation, faulty wiring, or inconsistent parameters. The manual describes how to analyze such errors and messages.
Project "zEn18_01_FMx51" contains further examples for your orientation; you can adapt those project templates to suit your application.