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This entry originates from the Siemens Industry Online Support. The conditions of
use specified there apply (http://www.siemens.com/terms_of_use).

Security
notes

Siemens offers products and solutions with industrial security functions which
support the secure operation of plants, solutions, machines, devices and/or
networks. They are important components in a comprehensive industrial security
concept. The Siemens products and solutions continue to be developed under
this aspect. Siemens recommends that you keep yourself regularly informed
about product updates.
For the safe operation of Siemens products and solutions it is necessary to take
appropriate security measures (cell protection concept, for example) and to
integrate each component in an overall industrial security concept which is state
of the art. This should also cover the third-party products used. Additional
information about Industrial Security is available here:
http://www.siemens.com/industrialsecurity.
In order to keep yourself informed about product updates, we recommend
subscribing to our product-specific newsletter. Additional information about this is
available at:
http://support.industry.siemens.com/.

Question
What information is available about licenses for WinCC (TIA Portal)?

Answer
Follow the instructions and notes listed in this document for a detailed answer to
the above question.

http://www.siemens.com/terms_of_use
http://www.siemens.com/industrialsecurity
http://support.industry.siemens.com/
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1 General Information about Licenses
1.1 License, Certificate of License and License Key

Below are explanations of the terms used.
· License

A license is granted as the authorization to utilize products. A license consists
of the CoL and the License Key, which represent the authorization for
utilization.

· CoL- Certificate of License:
The CoL is a confirmation in writing (evidence) of the license.
It documents the owner of the license in the legal sense and contains the
license number for unique identification of the license.

· License Key
The License Key is the "technical representation" of the license
("electronic license stamp").

· Authorization
The Authorization is the predecessor of the License Key.
Authorizations are not used any more in WinCC (TIA Portal). This is why the
topic of "Authorization" will not be dealt with any further. Information about this
is available in Entry-ID 27005215

Note CoL
You receive the license in paper form. The license authorizes you to install on a
computer and use the version of WinCC (TIA Portal) purchased.

License Key
You receive the License Key on a separate, copy-protected USB stick.

1.2 Why Do You Need Licenses?

You need a License Key in the following cases.
· To use the WinCC (TIA Portal) Engineering System
· To use the options of the WinCC (TIA Portal) Engineering System
· To use the WinCC (TIA Portal) Runtime
· For using options of WinCC (TIA Portal) Runtime on PC-based operator panels
· For using options on non-PC-based operator panels.

http://support.automation.siemens.com/WW/view/en/27005215
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1.3 Available License Types

The WinCC (TIA Portal) Engineering System uses the following license types.
· Demo License
· Floating License
· Trial License
· Single License
· Upgrade License
· Power Pack
· Unlock Copy License (UCL)

Descriptions of the license types
Demo License
Utilization of the software with this license is limited to:
· The number of operating hours specified in the contract.
· The number of days from first use specified in the contract.
· Up to the expiry date specified in the contract.

Floating License
· Standard license for WinCC (TIA Portal) Engineering System.

This license has a limited duration.
· You can use this license locally or through the network on any computer.
· Can be upgraded.

Trial License
· One-off, limited duration standard license.
· You can install and use this license locally on any computer.

Single License
· All licenses for WinCC (TIA Portal) Runtime and Runtime options are "Single

Licenses". These licenses have a limited duration and can only be installed
and used locally.

· Can be upgraded.

Upgrade License
With the Upgrade License you can do the following, for example:
· Switch from an old version to a new version

(the requirement here is that the new version is already installed).
· Extend the quantity framework.
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Power Pack
Power Pack permits you to make the following upgrades:
· From a smaller to a greater edition of WinCC Engineering System.
· To a Runtime system with a larger quantity framework.
For this a Power Pack includes a special license for switching to utilization of a
higher level of WinCC.

Unlock Copy License (UCL)
· The UCL is an add-on based on standard products (with authorization) which

replaces the authorization query of copy-protected programs with a customer-
specific entry; the UCL therefore overrides the copy protection.

· The customer-specific entry is displayed in a splash screen each time the
software is started and can also be read out from "Help/Info".

· The UCL is a customer-specific production.

1.4 Online Software Delivery

Online Software Delivery – by download to the automation software.
The link below provides information on the topic of
"Downloading automation software and licenses".
http://www.siemens.com/tia-online-software-delivery

http://www.siemens.com/tia-online-software-delivery
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2 Options and Services in WinCC (TIA
Portal)
Below is a list of options and services available for WinCC (TIA Portal). You need
licenses to use these options and services.
This list is divided into the separate WinCC (TIA Portal) products.

WinCC Basic, Comfort and Advanced (Engineering System)
Table 2-1

No. Option WinCC
Basic

WinCC
Comfort

WinCC
Advanced

1. -- -- -- --

WinCC operator panels and WinCC Runtime Advanced
Table 2-2

No. Option Operator
panel

WinCC Runtime Advanced

1. WinCC Sm@rtServer X X
2. WinCC Audit X X
3. WinCC Recipes -- X
4. WinCC Logging -- X
5. SIMATIC Logon X X
6. WinCC Control Development -- X

WinCC Professional and WinCC Runtime Professional
Table 2-3

No. Option WinCC
Professional
(Engineering

System)

WinCC Runtime Professional

1. WinCC Server / WinCC Client -- X
2. WinCC Web Navigator -- X
3. WinCC Recipes -- X
4. WinCC Logging -- X
5. WinCC Data Monitor -- X
6. SIMATIC Logon -- X
7. WinCC Control Development -- X
8. WinCC Redundancyy -- X
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3 License Transfer
3.1 Which Software is Needed?

The Automation License Manager (ALM) software is required for handling the
License Keys.
The Automation License Manager is installed automatically by default with the
software. Alternatively you can download the software in Entry-ID 114358.

3.2 How Do You Transfer License Keys?

The Automation License Manager provides the following options for transferring
License Keys:
1. Drag and drop.
2. Cut and paste.
3. Menu command "License Keys > Transfer".

Note Refer to Entry-ID 19109408 for which transfer and connection options are
available for the separate operator panels.

http://support.automation.siemens.com/WW/view/en/114358
http://support.automation.siemens.com/WW/view/en/19109408
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3.3 Transfer License Keys to an Operator Panel

You can find out below how to transfer a license key from a PC to a TP1200
Comfort Panel, by way of example.

Note The operator panel used determines which connection types are supported.

Table 3-1

No. Action Screen

1. Connect operator panel with the
configuration computer

Use a cable corresponding to the selected
transfer to connect the operator panel to the
configuration computer.
In this example it is a PROFIBUS cable.

2. Settings on the Operator Panel

Set the relevant transfer type on the
operator panel. This must match the
settings in the ALM described below (Link).

Then set the operator panel to Transfer
Mode.

3. Open the Automation License Manager
(Windows XP Professional)

Open the Automation License Manager by
means of
"Start > Programs > Siemens Automation >
Automation License Manager".

4. Connect the operator panel with the
Automation License Manager

· Select the menu command
"View > Administration".

· Go to
"Edit > Connect Target System >
Connect Panel" to get to the "Connect
Target System" menu.
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No. Action Screen
"Connect Target System" menu screen

· Device type:
Here you select the relevant operator
panel. In this case the "TP1200
Comfort".

· Connection:
In the drop-down list box you select the
connection type. In this example
"MPI/PROFIBUS".
Make sure that the transfer setting
matches the target device.

· MPI/DP address:
Here you specify the MPI/DP address
of the operator panel.

· Confirm the inputs with the "OK"
button.
This establishes a connection between
the ALM and the operator panel.

Note
When the connection to the operator panel
has been established, the operator panel is
displayed in the navigation area. If this is
not the case, then please refer to the
information at this Link.

5. Display available licenses

· Mark the drive where the license is
located.
In this example drive "C:\".

· In the Object area on the right you have
a display of all the available licenses on
drive "C:\".

6. Transfer licenses

· In the Object area you mark one or all
the licenses that you wish to transfer to
the operator panel.

· Drag-and-drop the marked license to
the operator panel displayed in the
navigation area.

The license is transferred to the operator
panel.
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No. Action Screen

7. Overview of licenses available on the
operator panel

To check, you mark the operator panel in
the navigation area.
In the Object area on the right you get a
display of the license just copied.
This concludes the license transfer.

You can close the ALM again.
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3.4 Transfer License Keys back from an Operator Panel

You can find out below how to transfer a license key from a TP1200 Comfort
Panel, by way of example, back to a PC.

Note The operator panel used determines which connection types are supported.

Table 3-2

No. Action Screens

1. Connect operator panel with the
configuration computer

Use a cable corresponding to the selected
transfer to connect the operator panel to the
configuration computer.
In this example it is a PROFIBUS cable.

Note
The operator panel used determines which
connection types are supported.

2. Settings on the Operator Panel

Set the relevant transfer type on the
operator panel. This must match the
settings in the ALM described below (Link).

Then set the operator panel to Transfer
Mode.

3. Open the Automation License Manager
(Windows XP Professional)

Open the Automation License Manager by
means of
"Start > Programs > Siemens Automation >
Automation License Manager".
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No. Action Screens

4. Connect the operator panel with the
Automation License Manager

· Select the menu command
"View > Administration".

· Go to
"Edit > Connect Target System >
Connect Panel" to get to the "Connect
Target System" menu.

"Connect Target System" menu screen

· Device type:
Here you select the relevant operator
panel. In this case the "TP1200
Comfort".

· Connection:
In the drop-down list box you select the
connection type. In this example
"MPI/PROFIBUS".
Make sure that the transfer setting
matches the target device.

· MPI/DP address:
Here you specify the MPI/DP address
of the operator panel.

· Confirm the inputs with the "OK"
button.
This establishes a connection between
the ALM and the operator panel.

Note
When the connection to the operator panel
has been established, the operator panel is
displayed in the navigation area. If this is
not the case, then please refer to the
information at this Link.

5. Display available licenses

· In the navigation area you mark the
operator panel where the license is
located.

· In the Object area on the right you have
a display of all the available licenses on
the operator panel.

https://support.industry.siemens.com/cs/ww/en/view/88633853
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No. Action Screens

6. Transfer licenses

· In the Object area you mark one or all
the licenses that you wish to remove
from the operator panel.

· Drag-and-drop the marked license to
the drive in the navigation area where
the license is to be stored.

The license is transferred from the operator
panel.

7. Overview of licenses available on the
drive

To check, in the navigation area you mark
the drive where the license is located. In
this example drive "C:\".
In the Object area on the right you get a
display of all the available licenses.
This concludes the license transfer.

You can close the ALM again.
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4 License Key (License) Backup
4.1 Which Software is Needed?

License Keys for software and operator panels can be backed up using the
Automation License Manager (ALM).
Follow the instructions in section 3.4 to backup the license keys of an operator
panel.

4.2 When Do You Have to Back Up License Keys?

You must save the License Keys under the following circumstances:
· When you install a new operating system on a PC.
· Before you format the hard disk on a PC.
· Before you compress the hard disk on a PC.
· Before you restore the hard disk on a PC.
· When you start an optimization program that moves fixed blocks on a PC.
· Before you run a backup / restore procedure on an operator panel.
· Before you do a "Reset to factory settings" on an operator panel.

4.3 Backup and Restore on an Operator Panel

You do a backup or restore on an operator panel
· With ProSave
· Directly on the operator panel

With a backup you can do a complete save including licenses and use "Restore" to
transfer them back again to the operator panel.
How to do a backup and restore is described in Entry-ID 28928853.

http://support.automation.siemens.com/WW/view/en/28928853


5 License Upgrades

16
Licenses

V1.1, Entry ID: 74796111

5 License Upgrades
If you need to upgrade a license key to use a new software version, then you must
also use the
Automation License Manager (ALM).

Note You cannot install upgrade license keys during Setup.

5.1 Requirements for an Upgrade

For upgrading a license key you need
· Of the software version to be upgraded:

– The CoL (Certificate of License) and the License Key
· Of the target version (operator panel):

– The CoL and the Upgrade License Key

Note Please note that both the "old" License Key as well as the upgrade itself must be
stored on the hard disk of the computer on which the upgrade is to be made.

5.2 Upgrading using the ALM

The procedure is described taking the example of an upgrade from WinCC V11
Comfort to WinCC V11 Advanced.

Note When you upgrade the license to a new version, the "old" license is overwritten.

Table 5-1

No. Action Screens

1. Open the Automation License Manager
(Windows XP Professional)

Open the Automation License Manager by
means of
"Start > Programs > Siemens Automation >
Automation License Manager".
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No. Action Screens

2. Storage location of the license

Select the menu command
"View > Administration".

Select the storage location in the navigation
area where the license key to be upgraded
is located.
In this case "C:\".

In the Object area on the right you get a
display of the available licenses.
In this example:
· WinCC Comfort
· WinCC Advanced Power Pack

Note
The "WinCC Advanced Power Pack"
upgrade was transferred previously from the
USB stick to the hard disk.

3. Execute an upgrade

· In the Object area you select the
license key that is to be upgraded. In
this example the "WinCC Comfort"
license.

· Execute the menu command
"License Key > Upgrade".
The upgrade is now made.

4. The old License Key has now been
replaced. Now only the new license key is
visible.

In this example:
"WinCC Advanced Combo".

This completes the upgrade.

Note If there is only one option for upgrading, then the upgrade is made without any
other displays or prompts.

If other upgrade options are found, the "License Key Upgrade" dialog opens.
Select the upgrade to be made and click on the "Upgrade" button.
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6 Tips and Tricks
6.1 How Do You Repair a Defective License?

A license is deemed to be defective in the following cases:
· If the License Key can no longer be accessed in the storage location.
· If the License Key disappears when being transferred to the target drive.
You can use the Automation License Manager to repair a defective License Key.
For this, use the "Restore" function or the "Restore Wizard" of the
Automation License Manager.
You must get in touch with Customer Support if you want to restore a license. More
information on this topic is available in Entry-ID 772175.

Note The Runtime software runs perfectly even if the license is missing or defective.
The system displays a message at short intervals informing you of the
unlicensed mode.

6.2 Why is a License Invalid After Changing Time Zones?

The installed license no longer functions if you switch from a time referred to a full
hour to a time not referred to a full hour.
Example: You switch the time zone from GMT +3:00 hours to GMT +3:30 hours.
Remedy:
Uninstall the License Key with a time zone setting that was set before you installed
the License Key and reinstall the License Key with the new time zone setting.

6.3 Why are License Keys Not Recognized?

In this case, the reason might be an upgrade license. You might have installed the
License Key, but have not yet made an upgrade. Help on this topic is available
under "Upgrading Licenses".

6.4 Where is the "Old" License Key Located after an
Upgrade?

If you want to upgrade an existing system, you can purchase an upgrade. When
you make an upgrade, the existing License Keys are replaced by the new
License Keys of the upgrade.

6.5 How Do You Retrieve a Lost License Key?

You must make sure that you have the CoL in order to receive a new License Key.
This is evidence that you are the owner of the license in the legal sense.

http://support.automation.siemens.com/WW/view/en/772175
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You must get in touch with Customer Support if you want to restore a license. More
information on this topic is available in Entry-ID 772175.

6.6 Can You Copy Licenses for Backup?

A License Key cannot be copied. The copy-protection procedure used prevents the
copying of License Keys.

http://support.automation.siemens.com/WW/view/en/772175
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