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Safety Guidelines
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level of danger:

Danger
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indicates that unwanted events or status can occur if the relevant information is not observed.

Note
draws your attention to particularly important information on the product, handling the product, or to a
particular part of the documentation.

Qualified Personnel
Only qualified personnel should be allowed to install and work with this software. Qualified personnel
within the meaning of the safety notices of this documentation are persons capable of giving due
consideration to safety engineering standards when using this software on systems.

Correct Usage
Note the following:

Warning
The equipment may be used only for the applications stipulated in the catalog and in the technical
description and only in conjunction with other equipment and components recommended or approved
by Siemens.
Startup must not take place until it is established that the machine, which is to accommodate this
component, is in conformity with the guideline 98/37 ECC.
Faultless and safe operation of the product presupposes proper transportation, proper storage, erection
and installation as well as careful operation and maintenance.

Trademarks
The registered trademarks of the Siemens AG can be found in the preface. The remaining trademarks
in this publication may be trademarks, whose use by third parties for their own purposes could violate
the rights of the owner.
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Preface

Purpose

This document forms part of the documentation package for the ProTool CS
configuration software. It provides all information required for the creation and
configuration of projects.

Documentation

• ProTool User Manual (this document)
The User Manual is supplied in a printed version and addresses
development engineers. It contains configuration basics, details on
configurable objects as well as samples.

• Installation guide
The Installation Guide is supplied in a printed version. It addresses system
administrators who want to install the ProTool CS configuration software on
a PC.

• ProAgent/PC and ProAgent/MP User Manual
The printed version of this User Manual is supplied with ProAgent/PC and
ProAgent/MP. It addresses systems engineers who want to configure
system-specific process diagnostics for error detection an troubleshooting
routines.
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Notation

Different font formats simplify orientation within the text:

"Messages" dialog box Names of dialog boxes, fields and buttons are shown in
quotation marks.

"System" > "ProTool" Menu items are shown in quotation marks. Successive
submenus/options are separated by arrows. The complete
route to the menu option in question is always shown.

History of the documentation

This documentation describes the configuration of graphics displays with
ProTool.

The various issues of the documentation correspond to the following product
versions:

Issue 07/94 Valid for ProTool versions up to and including version 1.31

Issue 09/95 Extensions and editorial revisions.
Valid for ProTool version 2.0 or higher.

Issue 09/96 Inclusion of OP 37.
Applies to ProTool 2.5 and higher.

Issue 04/97 Extensions and inclusion of TP 37.
Software runs under Windows 95.
Applies to ProTool 3.0 and higher.

Issue 10/97 Extensions and inclusion of OP 27 and TP 27.
Software runs under Windows 95 and Windows NT 4.0 and higher.
Valid for ProTool version 4.0 or higher.

Issue 07/98 Extensions and revisions to software interface.
Valid for ProTool version 5.0 or higher.

Issue 01/99 Extensions and editorial revisions of the manual.
Software runs under Windows 95, Windows 98, Windows NT 4.0
and higher.
Valid for ProTool 5.1 or higher

Issue 12/99 Software runs under Windows 95/98, Windows 2000 and Windows
NT 4.0 and higher.
Valid for ProTool 5.2 or higher

Issue 12/01 Valid for ProTool 6.0 or higher

Trademarks

The following names are registered trademarks of the Siemens AG:

• SIMATIC®

• SIMATIC HMI®

• SIMATIC Multi Panel®

• SIMATIC Multifunctional Platform®

• SIMATIC Panel PC®

• HMI®

• MP 270®

• ProAgent®

• ProTool®

• ProTool/Lite®

• ProTool/Pro®
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Customer and Technical Support

Available worldwide 24 hours!

Johnson City
Nuernberg

Singapore

SIMATIC Hotline

Worldwide (Nuernberg)

Technical Support

(FreeContact)

Local Time: Mo. - Fr. 7:00 AM -
5:00 PM

Telephone: +49 (180) 5050-222

Fax: +49 (180) 5050-223

E-mail: techsupport@
ad.siemens.de

GMT: +1:00

Worldwide (Nuernberg)

Technical Support

(charged, only with SIMATIC Card)

Local Time: Mo. - Fr. 0:00 to 24:00

Telephone: +49 (911) 895-7777

Fax: +49 (911) 895-7001

GMT: +01:00

Europe/Africa (Nuernberg)

Authorization

Local Time: Mo. - Fr. 7:00 AM -
5:00 PM

Telephone: +49 (911) 895-7200

Fax: +49 (911) 895-7201

E-mail: authorization@
nbgm.siemens.de

GMT: +1:00

America (Johnson City)

Technical Support and
Authorization

Local Time: Mo. - Fr. 8:00 to 19:00

Telephone: +1 423 461-2522

Fax: +1 423 461-2289

E-mail: simatic.hotline@
sea.siemens.com

GMT: -5:00

Asia/Australia (Singapore)

Technical Support and
Authorization

Local Time: Mo. - Fr. 8:30 to 17:30

Telephone: +65 740-7000

Fax: +65 740-7001

E-mail: simatic.hotline@
sae.siemens.com.sg

GMT: +8:00

The languages spoken by the SIMATIC Hotlines are generally German and
English, the Authorization Hotline is also provided in French, Italian and
Spanish.
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Other support

In the case of technical queries, please contact the Siemens representatives in
the subsidiaries and branches responsible for your area.

SIMATIC Customer Support Online Services

• General information on SIMATIC products is available on the Internet under
http://www.ad.siemens.de/simatic

• Helpful up-to-date product information and downloads are found on the
Internet under

– http://www.ad.siemens.de/simatic-cs or

– on the Bulletin Board System (BBS) in Nuremberg (SIMATIC Customer
Support Mailbox), dial-in number +49 (911) 895-7100.
Dial in to the Mailbox using a modem up to V.34 (28.8 kbps) with the
parameters set to:
– 8,N,1,ANSI.
– You can also dial in per ISDN (x.75, 64 kbps).

• You can find your local partner for Automation & Drives in our Partner
Database on the Internet under

– http://www3.ad.siemens.de/partner/search.asp

Up-to-date information on ProTool

• You can obtain general information on ProTool on the Internet URL

– http://www1.ad.siemens.de/hmi/html_00/products/software/pro_tool/inde
x.htm or

– http://www1.ad.siemens.de/hmi/html_76/products/software/pro_tool/inde
x.htm (English).

• The ProTool Online Support with information on FAQs (Frequently Asked
Questions), spare parts as well as Tips & Tricks is also found on the
Internet. Available downloads are, for example, Firmware Updates, Service
Packs or helpful applications.
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SIMATIC HMI-documentation

This manual is part of the SIMATIC HMI documentation. The table below
shows where to find what information.

Documentation Target Group Content

Getting Started

Brief instructions

New users This documentation guides you step by step
through configuring

a screen with different objects,
a change of screens,
a message.

This documentation is available for
text-based displays
graphics displays
Windows-based systems

ProTool Configuring
Windows
-based systems

User's Guide

Programmers Provides information about working with the
configuration software. It contains

information about installation,
background to configuration,
detailed description of configurable objects
and functions.

This document applies to Windows-based
systems.

ProTool Configuring
Graphics Displays

User's Guide

Programmers Provides information about working with the
configuration software. It contains

information about installation,
background to configuration,
detailed description of configurable objects
and functions.

This document applies to graphics-based
display units.

ProTool Configuring
Text Displays

User's Guide

Programmers Provides information about working with the
configuration software. It contains

information about installation,
background to configuration,
detailed description of configurable objects
and functions.

This document applies to text-based display
units.

ProTool

Online Help

Programmers Provides information on the configuration
computer during a ProTool session. Online
Help contains

direct Help
extensive instructions and examples
detailed information
all information from the User's Guide

ProTool/Pro
Runtime

User's Guide

Commissioning
technicians,
users

Describes how to install the ProTool/Pro RT
visualization software and commissioning and
operation of the software on Windows-based
systems.
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Documentation Target Group Content

Software Security

Commissioning
instructions

Commissioning
technicians,
users

The ProTool/Pro Runtime visualization
software is protected against unauthorized
use. These instructions contain information
about installing, repairing and uninstalling
user authorization.

Example application

Commissioning
instructions

New users ProTool is supplied with a number of
specimen configurations together with the
corresponding PLC programs. This
documentation describes how you

load the examples onto the operating unit and
the PLC,
run the example and
how you can extend the connection to the
PLC for your application.

SIMATIC Panel PC
670
Equipment Manual

SIMATIC Panel PC
870
Equipment Manual

SIMATIC Panel PC
IL
Equipment Manual

Commissioning
technicians,
users

Describes the computing unit and the control
unit of the SIMATIC Panel PC 670.

Equipment Manuals:
MP 270
MP 270B/OP
270/TP 270
MP 370
TP 170B/OP 170B
TP 170A
TP 070

Commissioning
technicians,
users

Describes the hardware and operation of
Windows-based devices in general:

installation and commissioning,
device description,
operation,
connection of PLC, printer and configuration
computer,
maintenance and servicing.

OP 37/Pro
Equipment Manual

Commissioning
technicians,
users

Describes the hardware, installation and
incorporation of extensions and options for the
OP 37/Pro.

TP 27, TP 37
Equipment Manual

OP 27, OP 37
Equipment Manual

OP 25, OP 35, OP
45
Equipment Manual

OP 7, OP 17
Equipment Manual

OP 5, OP 15
Equipment Manual

TD17 Equipment
Manual

Commissioning
technicians,
users

Describes the hardware and operation of the
devices in general:

installation and commissioning,
device description,
connection of PLC, printer and configuration
computer,
operating modes,
operation,
description of supplied standard screens and
their usage,
installation of options,
maintenance and replacement of spare parts.
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Documentation Target Group Content

OP 3
Equipment Manual

Commissioning
technicians,
users,
programmers

Describes the hardware of the OP 3, its
general operation and how to connect it to the
SIMATIC S7.

PP7, PP17
Equipment manual

Commissioning
technicians,
users

Describes the hardware, installation and
commissioning of Push-Button Panels PP7
and PP17.

Communication

User's Guide

Programmers Provides information about connecting text-
and graphics-oriented operating units to the
following PLCs:

SIMATIC S5,
SIMATIC S7,
SIMATIC 500/505,
drivers for other PLCs.

This documentation describes:

the configuration and parameters required to
connect the devices to the PLC and the
network, as well as

the user data areas used for exchanging data
between the operating unit and the PLC.

Communication for
Windows-based
Systems

User's Guide

Programmers Provides information about connecting
Windows-based systems to the following
PLCs:

SIMATIC S5,
SIMATIC S7,
SIMATIC 500/505,
SIMATIC WinAC,
SIMOTION,
drivers for other PLCs.

This documentation describes:

the configuration and parameters required to
connect the devices to the PLC and the
network,

the user data areas used for exchanging data
between the operating unit and the PLC.

Other PLCs

Online Help

Programmers Supplies information about connecting the
operating units to PLCs such as

Allen-Bradley,
GE Fanuc,
LG (Lucky Goldstar) GLOFA GM,
Mitsubishi,
Modicon Modbus,
OMRON,
OPC,
Telemecanique.

The relevant online Help is installed at the
same time as the drivers are installed.
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Documentation Target Group Content

ProAgent for OP

User's Guide

ProAgent/MP and
ProAgent/PC

User's Guide

Programmers Supplies the following information about the
ProAgent software package (process
diagnostics):

configuring system-specific process
diagnostics,

determining process errors, finding the cause
of an error and troubleshooting,

customizing the supplied diagnostic screens
to satisfy your own requirements.
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1 What is ProTool?

Configuring graphics displays

ProTool is an innovative configuration software package for the whole SIMATIC
HMI family. You use the same configuration software to configure all the devices in
the family. Regardless of the device for which you are creating your project,
ProTool always presents you with the same, familiar user interface.

Example of the structure

OP37

PLC

PC

ProTool

Example of PC as configuration computer and OP 37 as operating unit

ProTool is easy to use

ProTool is a Windows application for Windows 95, Windows 98, Windows 2000
and Windows NT. The fully graphical user interface allows you to create object-
oriented, symbol-based projects easily by mouse click. No special programming
knowledge is required. You can continue to use the Windows applications with
which you are familiar to transfer graphics to your project, for example.
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ProTool is versatile

The editors provided in ProTool can be called simultaneously. You can also open
different projects, even those of different devices, simultaneously and transfer data
via the clipboard from one project to another.

ProTool can also be integrated in the SIMATIC STEP 7 configuration software,
thus allowing you to select SIMATIC STEP 7 symbols and data blocks as tags in
ProTool. This not only saves you time and money but also eliminates the possibility
of errors made when entering the same data several times.

You fill find more information about the configuration of ProTool with SIMATIC
STEP 7 at "Configuring with ProTool integrated in SIMATIC STEP 7".

Offline configuration

With ProTool you create and edit your projects offline. The device need not yet be
available at this time. The configuration computer displays the configured project
data as displayed later on the device.

On completion of configuration you can download the executable project file from
the configuration computer to the device.
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1.1 Overview of the documentation

The SIMATIC HMI documentation is made up of a combination of manuals,
instructions and online Help in keeping with the range of target groups. This
chapter provides a broad outline.

1.1.1 ProTool for the whole SIMATIC HMI device family

The SIMATIC HMI device family

The SIMATIC HMI device family is a complete family of text displays, operator
panels, touch panels and Windows-based systems for efficient machine operation
and monitoring. The performance and convenience of the devices are finely tuned
to suit the individual demands made of them.

SIMATIC HMI operating units

The great advantage is that you configure all the devices with the same
configuration software.
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1.1.2 ProTool for Windows-based systems

Devices

The "ProTool - Configuring Windows-Based Systems" documentation tells you how
to configure the following devices:

• Panels
– TP 170A
– TP 170B
– TP 170B Color
– TP 270 (6" and 10")
– OP 170B
– OP 270 (6" and 10")

• Multi Panels
– MP 270B
– MP 270B TOUCH
– MP 270
– MP 370
– MP 370 TOUCH

• Panel PCs
– FI 25
– FI 45
– PC 670 10’’
– PC 670 12’’
– PC 670 15’’
– PC 670 12’’ TOUCH
– PC 670 15’’ TOUCH
– PC 870 12"
– PC 870 15"
– PC 870 15" TOUCH
– PC IL 70 12" TOUCH
– PC IL 70 15" TOUCH

• SINUMERIK Panels
– OP 010
– OP 012
– OP 015

• SIMOTION Panels

• PC
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Example: MP 370
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1.1.3 ProTool for graphics displays

Devices

The "ProTool - Configuring Graphics Displays" documentation tells you how to
configure the following operating units:

• Graphics-oriented operator panels
– OP 27
– OP 37

• Touch panels
– TP 27-6
– TP 27-10
– TP 37

• C7 devices
– C7-626 (OP 25 with integrated S7-CPU)

Example: TP 37
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1.1.4 ProTool for text-based displays

Devices

The "ProTool - Configuring Text-Based Displays" documentation tells you how to
configure the following operating units:

• Text-oriented operator panels
– OP 3
– OP 7
– OP 17

• Text displays
– TD 17

• C7 devices
– C7-621 (OP 3 with integrated S7-CPU)
– C7-623 (OP 5 with integrated S7-CPU)
– C7-624 (OP 15 with integrated S7-CPU)
– C7-633 (OP 7 with integrated S7-CPU)
– C7-634 (OP 17 with integrated S7-CPU)

Example: OP 7
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2 First steps in ProTool

Here you learn how to start ProTool, configure graphics-based systems, and what
you should look out for while you are configuring.

2.1 Starting ProTool

Starting ProTool

After ProTool has been installed, you will find a folder on the Start menu called
Simatic, containing the following icons:

ProTool Pro CS v. 6.0

Calls online Help.

Starts the configuration software.

Shows late-breaking information on the configuration software.

Starts Setup in order, say, to change the ProTool language or to add a
component.

ProTool Pro RT v. 6.0

Copies the compiled project file in compressed form.

Starts the runtime software.

Shows late-breaking information on the runtime software.

Starts the simulation software.

Starts the Loader.
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2.2 Configuring graphics displays

Getting Started

If you are not all that familiar with the ProTool visualization software, we would
recommend you read the short guide and get started with ProTool with the help of
the example. The printed version is enclosed with the manual.

Requirements for working with the brief introduction

To do the exercises for ProTool in this brief introduction, you require

• a PC as a configuration computer

• The ProTool software package

• An operating unit, such as the OP 27 or TP 37

Other documents on ProTool

You will find the electronic manuals on the installation CD at:
Docs\..\UsersManual_Graph. pdf

You can find all the information contained in this manual in ProTool's online Help.
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2.3 Notes on the configuration computer

Notes on the configuration computer

So that you can work as efficiently as possible when you are configuring, give due
consideration to the following notes for your configuration computer:

• Close applications
Close all other programs. In this way more main memory will be available for
ProTool.

• Configurations on a local drive
Do not start projects from networks, but from your local drive. Network access
times are frequently too long.

• Available disk storage
Your drive should have free disk storage space. Take note of Microsoft's
recommendations for the Windows system in this respect.

• More working memory
Memory requirements rise in proportion to the number and size of the screen
objects you are using. An increase in available main memory reduces
processing times considerably.

• System resources
Make sure when you are working with ProTool that you have 20 to 40 MB of
main memory available and at least 65% free system resources. You will find
information on this topic in Explorer by choosing "Help" > "About". Increase the
size of your main memory with additional RAM or virtual memory, as
necessary. Additional system resources are released by closing other
applications.

• Environment tag TEMP
In Windows, a temporary file is created for files when they are opened and
processed. You decide where this temporary file is stored by means of the
TEMP environment tag.
The path of the TEMP environment tag is normally set in the autoexec.bat
file. If the TEMP environment tag is not placed in the autoexec.bat system
file, the temporary file is stored in the local Windows directory.
If an error message is issued by ProTool that indicates an error upon write
access, the storage space on the drive might be too small for the temporary
file.
In Windows 2000, the environment variable "TEMP" is set at "Start" >
"Settings" > "Control Panel" > "System" > "Advanced" tab > "Environment
variables" button.
In Win NT 4.0, you set it at "Start" > "Settings" > "Control Panel > "System",
"Environment" tab.
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3 ProTool integrated in SIMATIC STEP 7

Requirements

If the PLC you are using is a SIMATIC PLC and you have installed STEP 7
configuration software on your system, you can integrate ProTool in SIMATIC
STEP 7.

Advantages of STEP 7 integration

With integrated configuration, you access the database that you created when you
configured the PLC in SIMATIC STEP 7. You then have the following advantages:

• You can use SIMATIC Manager as a central point for creating, editing and
managing ProTool projects.

• The communication parameters of the PLC are created as default values when
you create your ProTool project and reset when SIMATIC STEP 7 is changed.

Example of the "Driver Parameters" dialog box with STEP 7 integration: network
parameters and parameters of the peer are set as default values.
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• When configuring tags and area pointers, you can directly access the STEP 7
data in ProTool. Simply select the STEP 7 icon in the ProTool tag dialog box to
which you wish to connect a tag. Changes to the symbol table in SIMATIC
STEP 7 are updated in ProTool.

• You assign symbolic names once only and use them in SIMATIC STEP 7 and
ProTool.

For this purpose, you must assign as name to a DB (data block) in the
SIMATIC STEP 7 symbol table. If this is not the case, this DB is not offered for
selection in the ProTool "Tags" dialog box.

• ALARM_S messages configured in SIMATIC STEP 7 are supported by
ProTool and can be output to the operating unit.

Switching STEP 7 integration from ProTool

When you have integrated your ProTool installation in SIMATIC STEP 7, you can
choose "File" from the ProTool menu and then the option "ProTool-Integration in
STEP 7". This means that you can integrate ProTool to SIMATIC STEP 7 or
operate it on its own. ProTool is automatically restarted following a change of the
integration mode.

Integration of ProTool in SIMATIC STEP 7 is still possible in "ProTool Setup",
irrespective of this.

In integrated mode, you can also make a copy of individual projects outside STEP
7 so that they be processed on their own (stand-alone) in ProTool (for example, on
a different configuration computer).

Integrating individual ProTool projects and copy outside STEP 7

Stand-alone ProTool projects cannot be opened directly in SIMATIC Manager. To
include projects like this in a STEP 7 project, they have to be integrated.

To do this, choose in ProTool the "File" > "Integrate in STEP 7-Project" option from
the menu.

If, conversely, you wish to edit projects that were integrated in SIMATIC STEP 7 as
stand-alone projects in ProTool without SIMATIC STEP 7 being available, you
must first unintegrate the projects.

To do this, choose in ProTool the "File" > "Copy outside STEP 7-Project" option
from the menu.

Note

When you open a stand-alone project, there can no longer be automatic
synchronization of the database between SIMATIC STEP 7 and ProTool. You
therefore have to ensure that the shared database is resynchronized (for example,
by re-integrating) if changes are made to the STEP 7 program.
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3.1 How to start ProTool in SIMATIC STEP 7

General

There are two ways in which you can start ProTool in SIMATIC STEP 7:

• By means of SIMATIC Manager

• Directly in Windows

Starting ProTool with SIMATIC Manager

Procedure:

1 Start SIMATIC Manager.

2 Select a STEP 7 project, or create a new STEP 7 project.

3 Choose the "Paste" > "Station" > "SIMATIC OP" option from the menu, and
enter a name for the ProTool project.

4 Start ProTool by double-clicking the ProTool project. Then select the
operating unit for the project.

Starting ProTool in Windows

Start ProTool directly under Windows. Choose "File" > "New" from the menu to
open a dialog box in which you can select a STEP 7 project and create a ProTool
project in it. You then select the operating unit.

Example of the "New" dialog box for integrating STEP 7
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4 Creating and editing projects

Here you obtain an overview over:

• the ProTool project structure

• the procedure for creating a project

• copying objects

• displaying project information
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4.1 Fundamental considerations when creating a project

Objective

You want to operate and monitor a machine or process. To do this, you map the
machine or process on the operating unit as accurately as is necessary.

System configuration

Communication takes place between the operating unit and the machine or
process by means of "tags" via the PLC. The value of a tag is written to a memory
area (address) on the PLC, from where it is read by the operating unit.

The following diagram provides an overview of the fundamental structure:

A typical structure

Before you begin

If you are creating a project for the first time, note the following recommendations:

• Use the standard screens from the standard projects.

• When creating a new project, you can select a "standard project" for your
system (operating unit and PLC) in the "project assistant".

• At ...\ProTool\Samples you will also find the example project "Quickmix",
which is implemented for various operating units and PLCs.

• Consider also whether you can use parts of existing projects. Message text
and graphics are suitable for this, for example.

• In the case of operating units from a single device family, it is also possible to
copy entire project sections via the Clipboard.

• The fixed window in the source and destination projects should be the same
size.
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Note

The prerequisite for successful copying between projects is that the system limits
of the operating unit for which you want to use the copied sections must not be
exceeded.
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4.2 Defining an operating philosophy

Basic procedure

Consider which process values or states of the machine you want to display on the
operating unit or work with and which object types you will have to configure for the
purpose.

1. Create a user interface

Screens are the central components of the project, with which you visualize the
states of the machine or process and create the prerequisites for operating the
machine or process.

Example of screen creation

You can create a number of screens with display elements and controls - for
switching between screen,for example - for the user interface with which the
operator is subsequently faced on the operating unit.

2. Process data entry and transfer

In order to enter process data or set new values, you configure input/output fields,
for example. This is also possible as a symbolic display.

3. Report process states

To acquire and log process and operating states on the operating unit or to archive
them, configure messages.
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4. Defining communication areas

A defined address area on the PLC for data interchange with the operating unit is
addressed by means of an area pointer.

The number of area pointers available varies depending on the selected operating
unit
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4.3 Components of a ProTool project

What objects are there in ProTool?

When you open a new or an existing project, the project window opens.

The project window displays the object types you can configure on the left and the
different objects on the right. The objects that you can configure depend on the
type of the operating unit.

The various objects are linked directly in ProTool with the tool required to edit
them.

What is displayed in the project window?

The project data of a ProTool project is stored in the form of objects. The objects in
a project are arranged in a tree structure.

The "Project" window displays object types that belong to the project and you can
configure for the selected operating unit. The project window is comparable with
Windows Explorer. The object types contain objects with properties that can be set.

The project window is structured as follows:

• The title bar contains the project name.

• Depending on the operating unit, the configurable object types are displayed in
the left half of the window and the objects you create in the right half.

Example of a project window with tags

Note

If you maximize the project window, tabs are displayed for the open windows along
the bottom border to enable you to change easily from one window to another.
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4.4 Objects in the project window

Object symbol Object type Object name
(default)

ProTool project PRO1

Screens PIC_1

Messages "---"

Recipes STRUCT_1

Tags VAR_1

PLCs PLC_1

Text or graphic
lists

LIST_1

Graphics GRAPHIC_1

Trends CURVE_1

Area pointers ---
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4.5 Steps to be taken when creating a project

Basic procedure

1. Create a new project ("File" > "New" or "File" > "Open").
Choose "File" > "New" to create a new project. The project assistant guides
you through a number of selection dialogs.

2. Select your PLC.
Select a driver for your PLC. Only those drivers with which the operating unit
can be run are displayed.

3. Use a standard project.
Select a "standard project" in order to use it as a basis.

4. The project assistant asks you whether you want to enter any more information
about the project in the "summary". Click the "Create" button to open the
project window.

5. Define communication areas (project window: "Area Pointers").
Define share communication areas (area pointers) so that specific functions
such as the "bit message procedure" or "synchronous data record transfer" can
be used.

6. Create your project.
This is the most involved part of the work. You can approach it in one of two
ways: either you create all the individual parts first and then link them to form a
meaningful structure (the bottom > up approach), or you begin by designing a
structure and then fill it with the individual elements (the top > down approach).
As a general rule, perform the following steps for this:
Create a user interface with display elements and controls.
Configure tags to allow data exchange with the PLC.
Configure messages to receive information about the machine status or the
process.
Partition the display on the operating unit

7. In addition, you can configure additional objects, such as recipes, depending
on the operating unit.
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4.6 PLC drivers

Available PLC drivers

Select the PLC driver with the project assistant in the "Select PLC" dialog box.

You can also define or later edit the parameters there if you select PLC
"Properties" in the project window.

Note

You will find information about the various PLC drivers at "Start" > "SIMATIC" >
"ProTool V6.0" > "ProTool Information System" in the topic "Process
communication".

You can select the following drivers for devices with a graphics display:

SIMATIC S5 - AS511

SIMATIC S5 - FAP

SIMATIC S5 - L2-DP

SIMATIC S7-300/400

SIMATIC S7-200

SIMATIC 500/505

Allen-Bradley DF1

Allen-Bradley DH485

GE Fanuc SNP/SNPX

FREE SERIAL

MITSUBISHI FX

Modicon Modbus

OMRON Hostlink / Multilink

Telemecanique Uni-Telway

Repercussions for tags

The address depends on the PLC you are using. The way in which the address of
a tag with a PLC connection is displayed depends on the PLC you selected.

You select the available data types and data formats in the "Tags" dialog box at
"Type" or "Format".

You will find an overview of the available data types and data formats that you can
select for the PLC driver concerned in the "Communication" user's manual.
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4.7 Area pointers

What are area pointers for?

A defined address area on the PLC for data interchange with the operating unit is
addressed by means of an area pointer.

You create area pointers in the project window at "Area pointers". You can edit
area pointers with all the commands available in the shortcut menu for example,
copy and then paste in another project.

What area pointers are available?

The number of area pointers available varies depending on the selected operating
unit

For information on how large the area pointers should be when you create them,
and the structure they have to have, refer to the "Communication" user's manual.

The overview below lists the various area pointers and what they are used for. The
area pointers are sorted in alphabetical order.

Area pointers Explanation

User version The user version identifies the version of the project. A
version check is performed on the PLC by means of
this area pointer.

Event messages You can configure an event message for each bit in
this data area. The bits are assigned to the message
numbers in ascending order.

As soon as the PLC sets a bit in this data area, the
operating unit recognizes that the assigned event
message has "arrived". Conversely, the operating unit
interprets the message as "departed" after the bit is
reset on the PLC.

Screen number In this data area the operating unit stores information
on the current screen. You can evaluate this
information in the PLC program to call another screen,
for example.

Data mailbox The data mailbox is a data area on the PLC. It is used
as intermediate storage to download data records from
the operating unit to the PLC. The data mailbox
contains only the values of the tag. The addresses are
not transferred.

Function keyboard The operating unit transfers keystrokes of the function
keys via this data area. You can evaluate this
information in the PLC program in order to indicate
incorrect operation by means of a message, for
example.

Trend request The PLC can use this area pointer to determine which
trend is currently being displayed on the operating unit.
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Area pointers Explanation

Trend transfer area 1 This data area is used to trigger trends. As soon as the
PLC program sets the bit assigned to the trend and the
trend communication bit in the trend transfer area, the
operating unit detects the trigger and, depending on
the configuration, reads out either a value or the entire
buffer.

Trend transfer area 2 This data area is required when you configure trends
with a switch buffer. The data area is structured in the
same way as the "trend transfer 1" data area.

LED assignment The PLC can use this area pointer to drive the light-
emitting diodes on the function keys of the operating
unit.

OP Acknowledgement The operating unit uses this area pointer to indicate to
the PLC which alarm messages have been
acknowledged on the operating unit.

PLC Acknowledgement Messages can be acknowledged from the PLC using
this area.

Interface area The interface area is the interface between PLC
program and operating unit. It contains data and
pointers to areas required for exchanging data
between the PLC and the operating unit.

Alarm messages You can configure an alarm message for each bit in
this data area. The bits are assigned to the message
numbers in ascending order.

As soon as the PLC sets a bit in this data area, the
operating unit recognizes that the assigned alarm
message has "arrived". Conversely, the operating unit
interprets the message as "departed" after the bit is
reset on the PLC.

System keyboard The operating unit transfers keystrokes of the system
keys via this data area. You can evaluate this
information in the PLC program in order to indicate
incorrect operation by means of a message, for
example.
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4.8 Screen partitioning on the operating unit

Subdividing the display into several areas

Depending on the operating unit for which you create your project, you can
partition the display into different areas. These areas are for displaying screens,
messages and icons for function keys, for example.

Where do you set the areas?

Choose "System" > "Screen/Keys" to set the areas. The settings made here apply
to the whole project, so set the areas before you begin configuration.

The example below shows one possible way of partitioning the display:

Example of OP 27 display partitioning

Basic area

The basic area covers the whole screen. All the other areas are superimposed on
parts of the basic area. The position and size of the basic area cannot be changed.
Screens are configured in the basic area. The contents of the basic area thus
change depending on the screen that is called.
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Fixed window

The fixed window is a window that is always displayed. It uses up part of the basic
area. The fixed window can be enabled or disabled at "Screen/Keys". If it is
switched on, it is displayed during screen configuration and thus reduces the size
of the area available for screens. The size of the fixed window can be changed, but
its position is always the same at the top of the screen. The fixed window is
configured with the "Screens" editor.

Message indicator

The message indicator is a symbol indicating alarm messages that are still
applicable on the operating unit. You can enable and disable the message
indicator by choosing "System" > "Screen/Keys". You cannot change the size, but
you can the position.

The message indicator can be used with touch devices.

Message area

The message area is the area in which messages are displayed on the operating
unit. By choosing "System" > "Screen/Keys", you can set separately for alarm and
event messages whether they are displayed on the message line or in a message
window.

• Alarm message window: The alarm message window is the window in which
alarm messages appear. The window only opens when there is an alarm
message. When you acknowledge the alarm message, the window closes
again. The display of alarm messages cannot be switched off. Either an alarm
message window or a message line must be configured. The position and size
of the alarm message window cannot be configured.

• Event message window: The event message window is the window in which
event messages appear. The window is only displayed when called. You can
enable and disable the event message window by choosing "System" >
"Screen/Keys" from the menu. The height of the window can be set to one or
two lines, depending on the device type. The position can also be changed.

• Message line: The message line is the area in which alarm and event
messages are displayed. In the case of touch panels, only event messages are
displayed in the message line. You can enable and disable the message line
by choosing "System" > "Screen/Keys" from the menu. The height of the
message line can be set to one or two lines, depending on the device type.
The position can also be changed.

Icons (OP only)

Icons can be placed on the display for soft keys (keys assigned local functions).
This is only possible for the "Fx" keys arranged around the display.

To find out how to assign keys "globally" or "locally", refer to "Function keys".
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Dynamic position (OP 35/37 only)

The message and help text windows are positioned dynamically as a function of
the cursor position so as not to cover up input fields that are currently being edited.
You can enable and disable this function by choosing "System" > "Screen/Keys"
from the menu.



Release 12/01 Creating and editing projects

ProTool User Manual How to configure graphics-based units
A5E00149244 4-15

4.9 Configuration notes for touch panels

Screen partitioning basics

Before you start setting touch panel controls, you should give a thought to the
basic partitioning of a screen. Give consideration to where messages and input
windows will be opened in order to prevent unintentional overlapping of buttons
and input fields.

Dimension the controls, such as buttons, large enough for them to be operated
properly. For display elements, such as output fields, use font sizes that are large
enough to allow comfortable reading.

The figure shows an example of screen partitioning on the TP 37.

Example of screen partitioning on the TP 37
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Touch grid

Enable the display of the touch grid with the symbol illustrated or by
choosing "View" > "User Interface". To do this, activate the "Display touch
grid" check box.

The touch grid designates the smallest possible spacing between two
points which the touch panel detects as single dots when its screen is
touched. The display grid makes it easier for you to position the controls.

You can place controls anywhere within the touch grid. The grid is not
visible on the operating unit.

Invisible buttons

If you use invisible buttons in your project, you should enable the display of
invisible buttons while configuring.

To do this, select the symbol illustrated or choose "View" > "Interface" from
the menu. Select the "Display invisible buttons" check box in the open
dialog box.

Global buttons

Buttons and their assigned functions are available only locally on the screen
concerned. Therefore, position buttons which you want to be available globally in
every operating situation in the fixed window of the TP.

Overlapping controls

Mutual overlapping of controls is not allowed. Since overlapping controls may
result in undefined operating states, they are reported as errors when the project
file is compiled.
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4.10 Editing projects

Here you will learn:

• How to convert existing projects. For example, you can convert a project for a
specific graphics display to a project for another graphics display to use it as a
basis for a new project.

• How to copy objects within a project and from one project to another.

• How to undo and redo actions.
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4.10.1 Convertible projects

Conversion options in ProTool

You can convert a ProTool project that you created for an OP x5 operator panel
into a project for an OP x7. This also applies to projects for the corresponding "C7
devices".

Note

With ProTool 6.0 you can also convert projects for graphics displays to projects for
Windows-based systems. You will find more information about converting projects
in the documentation called "Configuration support for upgrading - migration to
Windows-based devices" [Projektierungsunterstützung für Umsteiger - Migration zu
Windows-basierten Geräten].

You can convert the following projects:

Source Objective

OP 5 > OP 7

OP 15C > OP 17

OP 25 > OP 27

OP 35 > OP 37

Note

Take note of the system limits of the device when you convert projects.

Settings for conversion

You can influence the conversion result by choosing "File" > "Convert" > "Settings".

• Smoothing
If the "Smooth" setting is enabled, an anti-alias filter for replacing missing
pixels due to interpolation is used when increasing or decreasing the size of a
graphic. This setting results in softer transitions in photo-realistic displays. In
the case of drawings, the display quality is enhanced when decreasing the size
of graphics in particular, since the complete screen information is retained.

• Converting resolution
Select this setting if you would like to convert projects between different
operating units having different resolutions or display sizes..
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4.10.2 Copying objects: Between projects and within a project

Principle

You can cut or copy selected parts of your project and paste them from one project
to another via the Clipboard. For example you can copy text and fields from the
alarm message editor to the event message editor, or graphic elements from one
screen to another.

A requirement for successfully copying from one project to another is that the
system limits of the destination project are exceeded.

You can also copy objects between projects with different resolution. If the
destination system uses a lower resolution than the source system, then the icons
of soft keys, for example, are cleanly adjusted to the new resolution by an anti-
aliasing mechanism.

Preparations for new projects

Before starting to copy objects from an existing project, you should without fail
carry out the following global settings in the new project. This will ensure that no
loss of data occurs due to different settings during copying.

• At "System" > "Screen/Keys", adjust the partition of the screen display to that
in the source project.

• Make the option for Full Screen mode the same as in the source project by
choosing "System" > "Settings" from the "View" menu.

• Make the name and driver of the "PLC" the same as in the source project.

• Make the language settings the same as in the source project by choosing
"System" > "Language Assignment".

Pasting objects in the destination project

To paste objects from the Clipboard to the destination project, choose "Edit" >
"Paste" from the menu.
The object is pasted from the Clipboard to the destination project. If there is
already an object of the same name in the destination project, the object is pasted
under a new name.

Note

With "Paste", ProTool always checks the lower-level objects (such as the limit
value tags of a tag which has been copied) to ensure that existing objects are
reusable.

If there is already an object of the same name in the destination project, the object
to be pasted will be renamed if necessary. It is given the next available name in the
destination project.



Creating and editing projects Release 12/01

ProTool User Manual How to configure graphics-based units
4-20 A5E00149244

Example:

Tag VAR_4 will be renamed VAR_11 if tags VAR_1 through VAR_10 already exist
in the destination project.

What is copied?

You can copy the following via the Clipboard:

• All objects listed in the project window, such as screens, text or graphic lists,
tags etc.

• Objects from screens (trends, fields, graphics etc.) in the screen editor.

• Messages and objects from messages (message text, fields, Help text etc.) in
the message editor.

• Area pointers

• Global and local function key assignments

An object is copied complete with its attributes and all cross-referenced objects.
Special situations encountered during copying are reported in the "system
message window" at "Clipboard". This gives you information about any objects that
have not been copied or renamed, for example.

Special situation with screens

If the object to be copied refers to a screen that does not exist in the destination
project, the underlying screen is not copied; instead a blank screen is created as a
dummy if the destination project does not contain a screen that can be reused.

This ensures that you will not copy the complete source project by mistake along
with the start screen.

Afterward, when you paste the screen via the Clipboard, the dummy screen in the
destination project will be automatically replaced by the proper screen.

Special feature with tags

Perform the steps listed below so that tags with a PLC connection can be inserted
completely in the destination project when copying from one project to another:

• Assign a self-explanatory symbolic name for the PLC in the source project and
do not use the system default setting (for example, PLC_1).

• Copy the PLC object to the destination project first so that it is present in both
projects with identical parameters. The copy the tags belonging to this PLC.

Special feature of recipes

With Windows-based systems, you can also copy recipes via the Clipboard. You
will find more information about this at "Compatibility of recipes".
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What is not copied?

These objects are not copied:

• Objects that are unknown in the destination project (such as functions or
command buttons when copying from TP 170 to OP 170)

• Character sets

• In the case of multilingual projects, only the languages available in the
destination project are copied. No new languages will be created. If necessary,
create them before copying.

• Settings at "System" - for example, Language Assignment or Full Screen
mode.
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4.10.3 Replacing a project and project parts

Purpose

If you would like to introduce new or updated standard components (say, from
ProAgent) of one project in your project, you can do so with the ProTool's Replace
function.

Replacing a complete project

By choosing "File" > "Insert/Replace" > "Settings" from the menu, you can set the
object types which should be taken into account when replacing whole projects.
For this, select the "Replace whole projects" option and then select the object
types.
The settings will be saved in the project concerned; if this project is used as a
source project for the substitution, the settings are taken input.

If you choose "File" > "Insert/Replace" > "Start" from the menu,

Using the object name, a check is made for all the objects present in the source
project as to whether an object having the same name is already present in the
destination project.

If there is no such object present, a new object is created with the name used in
the source file. If the object is already present in the destination project, it will be
replaced by the object in the source project.

Object linking is not changed by the substitution; merely the contents of the object
are inserted and additional linking added.

Should errors occur in the project during the substitution operation,

Replacement of a complete project cannot be undone.

Note

PLCs are not replaced as a general rule.

Replacing objects

You ca also copy individual project objects from a source project and paste them in
another project with the Replace function:

• Choose "Edit" > "Insert/Replace" from the menu to replace the objects in an
object group from the project window (such as screens)

• By choosing "Replace" from the shortcut menu of an object, only the selected
object is replaced

To do this, choose "File" > "Insert/Replace" > "Settings" from the menu and select
the "Replace individual objects" option. Then select the object types which you
want to be taken into account in the substitution. The settings for replacing
individual objects are common to all projects.
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Example

An archive is configured for the tag which you copied to the Clipboard in the source
project. If you have selected "archive" as the object type in the "Setting Replace"
dialog box, the archive is replaced in the destination project.

Object linking is not changed by the substitution; merely the contents of the object
are inserted and additional linking added. All the objects referenced by the inserted
objects are also pasted in the destination project.

Should errors occur in the project during the substitution operation, they are
reported in the same way as other errors when the project is compiled.

The replacement of individual objects can be undone. Further, Replace is
supported differently by various objects, including between projects of different
types; thus, for example, you can paste objects from a graphics project in a
Windows-based project.

Note

You cannot insert more objects with Replace than the number allowed by the
quantity structure of the destination project.

If the destination project has a smaller range of functions than the source project, it
is possible that not all objects will be applied.

Object attributes that have not been defined in the source project will be assigned
default values in the destination project.
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4.10.4 Undoing and redoing actions

Purpose

During configuration, it may become necessary to cancel actions which have been
performed, or to reconstruct actions which have been discarded. The two
commands "Undo" and "Redo" on the "Edit" menu are used for this purpose.

• Undo
The "Undo" command (key combination Ctrl + Z) cancels the last action
performed. If you keep selecting the command, you can cancel up to 30
successive modifications.

• Redo
The "Redo" command (key combination CTRL+ Y) revokes the last action
canceled, thus restoring the status before the last "Undo" command was
executed.

Principle

Each active editor (project window, screen editor, drivers) has its own undo history.
Thus, for example, if three screens are opened at the same time, three separate
Undo Histories will be created. When a screen is closed, the actions listed in the
accompanying History are deleted. When the project is saved, all the Undo
Histories for the current project are deleted.

The last recorded action is displayed in abbreviated form in the menu. The tooltips
contain detailed texts for the "Undo" and "Redo" buttons and for the status bar.

Example of menu

Undo:

CTRL + Z

VAR_5 edited

Redo:

CTRL+ Y

PIC_2 edited

Example of tooltip/status bar

Undo: property edited of tag VAR_5

Redo: contents edited of screen PIC_2

Until the corresponding undo history is deleted, deleted objects in the cross-
reference continue to be listed as used objects. The status of these objects is
shown in brackets after each object - for example, PIC_5 (deleted).
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General Information

The commands "Undo" and "Redo" only work with actions taken since the last time
the project was saved. If, for example, you move a screen object and then save
your project, you cannot later cancel this action.

These are some of the rules that apply to "Undo/Redo":

• Settings in dialog boxes (properties of a field) can only be canceled in their
entirety. It is not possible to open the dialog box and discard individual entries.

• With multilevel dialog boxes, only changes to the primary object are recorded.
Modifications to underlying objects, or creations or deletions cannot be
reversed.

Example (project window):
"Edit Tag" > "Edit Limit Value Tag"
You can only undo changes to the tag here.

• "Undo/Redo" is special to ProTool. With a project integrated in SIMATIC STEP
7, the Undo buffer cannot be accessed by a higher-level SIMATIC Step 7 Undo
Manager.
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4.10.5 Undoing the last action

Possible procedures

To cancel your last action in ProTool, choose one of the three following options:

• Choose "Edit" > "Undo" from the menu. The last action that can be undone
(canceled) is shown in abbreviated form after the menu command. A longer
description is given in the status bar.

• Click the "Undo" button on the toolbar. This opens a tooltip which shows
you the last action that can be undone (canceled). You are given the same
information in the status bar.

• Press the CTRL and Z keys simultaneously. In contrast to the first two options,
you are not given any feedback about which action has been canceled.

If you keep executing the "Undo" command, you can successively cancel all the
recorded modifications.

4.10.6 Redoing the last action

Possible procedures

To restore your last canceled action in ProTool, choose one of the three following
options:

• Choose the "Edit" > "Redo" command from the menu The last undone action is
shown in abbreviated form after the menu option. A longer description is given
in the status bar.

• Click the "Redo" button on the toolbar. This opens a tooltip which shows
you the last canceled action. You are given the same information in the status
bar.

• Press the CTRL and Y keys simultaneously. In contrast to the first two options,
you are not given any feedback about which action has been restored.

If you keep executing the "Redo" command, you can successively restore all the
recorded cancellations.
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4.11 Retrieving project information

Tools

The following tools are available to you for displaying or storing information on a
project.

• Cross references

• Project information

4.11.1 Display in "Cross-Reference" window

Usage

When you have to add to or modify a project and need to check where and how a
particular object is being used in your project, you open the "Cross-Reference"
window.

You select an object in this window, and all the references to this object in the
project are then displayed to you.

Example from a project

You open the "Cross-Reference" window by choosing the "View" > "Cross-
Reference" option from the menu. The active object is displayed with a red border
around it.

The selected object is at the uppermost level, and all the objects in which the
selected object is used appear under it.

The cross-reference list also contains objects in the current Undo history (undo and
restore actions). The status of these objects is shown in brackets after each object
- for example, PIC_5 (deleted).

Note

You can use the "Cross-Reference" window efficiently for troubleshooting.
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4.11.2 Display at "Project Information"

Usage

To obtain information about a project when projects change or are adapted, open
the "Project Information" dialog box. To do so, choose "File" > "Project Information"
from the menu.

The "Project Information" dialog box displays general "project data" and the
"memory requirements" for the project. Project information is spread according to
subjects over three tab controls:

• General

• Description

• Statistics

Example relating to the "Statistics" tab
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General

The "General" tab shows information on the device type, project name, path name
of the stored project file and person who created the project. You fill in the "Created
by" field and all the other fields are updated automatically by ProTool when the
project is saved.

Description

The "Description" tab contains an input field for the project description. Here you
can enter any information you like that are important for your project.

Statistics

The "Statistics" tab shows when the project was created, modified, generated and
downloaded, the ProTool version last used to edit the project and the memory
required by the project after it has been downloaded to the flash memory on the
operating unit. The memory requirement is determined and displayed after every
download operation.
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4.12 Example of creating projects

These examples show you how to create a project for an OP 37, and how you
convert one project for an OP 25 to another.

4.12.1 How to create an OP 37 project

Objective

You want to create a project for an OP 37 and the SIMATIC S7-300 or SIMATIC
S7-400 PLC.

Procedure

Procedure:

1
Click on this button or choose "File" > "New".

This opens the project assistant. You are guided through four dialogs (steps 2
through 5), to create a new project.

2 In the "Select Device" dialog box at "Graphics-based operator panels", select
an "OP 37".

Click the "Next" button.

3 In the "Select PLC" dialog box, enter the name of the PLC.

From the list below this, select the driver you want to use for communication
between the operating unit and the PLC.

4 Click the "Parameters" button to set the driver parameters Click the "Next"
button.

You can also set the driver parameters later on.

5 In the "Standard projects" dialog box, select "Use standard project". This puts
you on the standard project.

6 Double-click the left mouse button in the project window on "Area pointers" to
configure the "Event messages" communication area.

Select this at "Type" and then click OK.

7 Enter the following values in the "Event Message" dialog box:
DB: 70

Length: 4

Confirm by clicking "OK". You can then configure 64 event messages.

This data block must also be available in your PLC program.

8 Choose "System" > "Screen/Keys" to partition the OP display.

9 For "Alarm/Event Mess.", select the setting "Window/Window" so that both
event and alarm messages are displayed simultaneously on screens.
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Procedure:

10 Select the "message area" using "Active" and, holding down the mouse
button, position it in the screen layout. This completes the subdivision of the
OP display.

11 Proceed to configure the event messages. If you enter more than 64
messages, only messages 0000 to 0063 can be output on the operating unit.

12 Save your project with "File" > "Save".

4.12.2 How to convert an OP 25 project

Objective

To convert an OP 25 project to an OP 27 project, proceed as follows.

Procedure

Procedure:

1 Open the existing OP 25 project.

2 Choose "File" > "Convert" from the menu.

3 Enter a name for the new project.

4 OP 27 is selected as the device type as no other conversions are possible.

5 Click "Save". If you confirm the prompt that appears in response to this, the
project is converted and the OP 27 project window opens.
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5 Configuration techniques

In this chapter you will learn how to:

• Create screens

• Configure controls and display elements

• Use tags

• Configure messages

After that we will show you, for example, how to:

• Use functions

• Create recipes

• Assigning operator authorization

• Create multi-lingual projects
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5.1 Screens

Example

Screens are an image of the process. You can display processes on screens and
specify process values. The figure below shows an example of a mixing unit for
producing different juices. Ingredients are filled into a mixer from different tanks
and then mixed. The liquid levels in the tanks and in the mixer are displayed. The
intake valves can be opened and closed by means of the operating unit. The motor
for the mixer can be turned on and off in a similar manner.

Example of a Screen: Mixing Station

Components of a screen

A screen can consist of static and dynamic components. Static components
include text and graphics. Dynamic components are linked to the PLC and
visualize current values from the PLC memory. Visualization may take place in the
form of alphanumeric displays, trends and bar graphs. Dynamic components are
also inputs made by the operator on the operating unit and written to the PLC
memory.

The connection to the PLC is established by means of tags.
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Screen editor

Screens are created with a separate editor in ProTool. The operating unit is
displayed when you call the screen editor. Open the screen editor by:

• double-clicking on "Screens" in the left half of the project window to create a
new screen

• double-clicking in the right half of the project window on an existing configured
screen to open the screen for editing.

You can zoom this display in and out in stages by choosing "View" > "Zoom" from
the menu. If, for example, you wish to edit details you can do it much more simply
by zooming in on them.

Screens are stored under a symbolic name. You enter a name by choosing "Edit" >
"Properties" from the menu. This name has to be specified when you edit,
reference or delete the screen. In addition, screens are numbered automatically.

Start screen

Declare one screen in every project as the "start screen". The start screen is the
screen that is displayed after the operating unit has started up.

Fixed window

The fixed window is the window that is always flush with the top border of the
operating unit screen. By choosing "System" > "Screen/Keys" from the menu, you
can open and close the fixed window and adjust its height by dragging with the
mouse. Since the contents of the fixed window do not depend on the current
screen, you can output important process tags or the date and time to it, for
example.

You configure the contents of the fixed window in the screen editor. To access the
fixed window, click it with the mouse.

Soft keys/buttons

Soft keys are function keys with screen-dependent assignment. Buttons are virtual
keys on the touch-sensitive screen of the touch panel. You can configure both soft
keys and buttons for specific screens. When configuring, you assign functions to
these controls. You can illustrate the task of a control by means of a graphic or
text.

You can use soft keys and buttons to open another screen, turn a motor on and off
or display the message buffer, for example.
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Select screen

Every configured screen has to be integrated into the control process so that it can
be opened at run time on the operating unit. The "Select Screen" function is
available for this purpose. You an assign this function to an input field, a function
key or a button, for example. You specify the name of the screen as the parameter.

This means that a screen can be displayed by means of an input field or a function
key or button.

With input fields, soft keys and buttons, the function can be used only locally on
that screen. Should you wish the function to be available globally, you have to
configure the function on a Kx function key on the operating unit or on a button
positioned in the fixed window on the TP.
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5.1.1 Screen objects in ProTool

Introduction to screen objects

Screens consist of individual objects. There are different types of object, which you
can use at will when configuring a screen. "At will" means that you determine the
number and type of the objects, as well as their position and size.

Available screen objects

ProTool presents you with the following object types:

Screen object Name Description

Text With the text box you can configure static text:
various kinds of formatting are possible. Text can
be shown in a wide range of fonts. Text can be
entered over several lines and aligned vertically or
horizontally.

Character
graphics

By using character graphics, you can compose
graphics from the individual characters contained
in a symbol font.

If you use character graphics instead of graphics,
the memory requirement for your project file will be
reduced significantly.

Graphics With the graphic field, you can use graphics from
other graphics programs in your project.

Input/output
field

With the input/output field, you can enter or display
process values directly. Different display formats -
for example, decimal and binary - are possible.
There are a large number of formatting options,
such as colors, flashing, etc.

Symbolic
input/output
field

Instead of the numerical value of a tag, a "text" or a
"graphic" is displayed to make the current status
more comprehensible to the operator.

The assignment between the values of the tags
and the text or graphics is configured in a text or
graphic list (text list or graphic list).

For example, instead of the numerical values 0 and
1, the phrases Motor Off and Motor On are
displayed.

Trend view A trend view contains the settings for the
coordinate system - for example, the X and Y axes.
You can display several trends in one trend view.

Bar graph Bar graphs display a value from the PLC as a
rectangular area. Bar graphs are practical for
displaying fill levels, for example.
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Screen object Name Description

Button (touch
panels)

Buttons are objects that trigger a function by using
a touch-sensitive screen. You can configure the
function triggered. Buttons can be freely labeled
with text or a graphic.

"Set/Reset
Bit" button
(touch panels)

Button with a fixed function: to set or reset a bit in a
tag.

"Select
Screen"
button (touch
panels)

Button with a fixed function: to select a different
screen.

Light indicator
(touch panels)

Button with a fixed function: light indicators show
the status of a defined bit, for example, by
changing color or by a flashing text.
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5.1.2 Custom project user interface in ProTool

Custom configuration user interface

To configure display elements and controls in a user-friendly manner, you can
create the configuration user interface in ProTool so that it satisfies your
requirements.

Select "View" > "User Interface" from the menu while the screen is open. You can
perform the following settings in the "Interface" dialog box:

• At "Zoom", set the zoom factor of the current screen in percent.

• At "Field grid", set the density of the grid on the current screen.

• At "Display", select whether and how you want to have the grid displayed.

• At "Color setting", set the intensity and contrast of screen objects.

• Check the settings with the "Display Changes" button. If the settings are as you
want them to be, exit from the dialog box by clicking OK.

Note

You can perform the zoom functions in conjunction with CTRL and the numeric
keypad, too:
CTRL + "+": Zoom in
CTRL + "-":
CTRL + "*":

For touch panels only;

• At "Buttons", select whether you want to display the touch grid and/or invisible
buttons.
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5.2 Display elements

Purpose

You use display elements to monitor the machine or the system on the operating
unit. You can display current information, such as actual values from the PLC,
process and operating modes and malfunctions, on the operating unit as a
numerical value, in plain language or as a graphic.

Overview

There are essentially two types of display element available for the different tasks:

• Static display elements
Static display elements are pieces of text and graphics that are not linked to
the PLC. They do not react to user inputs and cannot be modified at run time
on the operating unit. Use static display elements, for example, for system
screens or for textual or graphic explanations for controls and dynamic display
elements. Static display elements are - Static text - Graphics - Character
graphics

• Dynamic display elements
Dynamic display elements can be linked to the PLC by means of tags. They
visualize current values from the PLC in alphanumeric or graphic form.
Dynamic display elements can change their display spontaneously at run time
on the operating unit without the operator intervening. Use dynamic display
elements for all tasks associated with monitoring the process, a machine or the
system. Dynamic display elements are - Output fields - Trend view - Bar
graphs - Light indicators
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5.2.1 What is static text?

Purpose

Static text is text that is not linked to the PLC. It cannot be modified at run time on
the operating unit. Use static text (on one or two lines) to explain segments of a
configured screen - for example, for labeling controls and dynamic display
elements.

You can configure static text separately for any language available on the
operating unit.

Character sets

Different fonts are available to indicate the relative importance of text strings on a
screen by means of the font or the font size. All the characters in the font must be
of the same width. This requirement is not met by all fixed-pitch fonts - for example,
Courier.

You can set up to four different fonts for the operating unit. Three fonts are
language dependent, one font is language independent.

• Language dependent fonts
With language dependent fonts, you can use different characters for every
language available on the operating unit. By default, ProTool fonts are included
in the scope of supply. But you can any Windows font, provided that it is a
fixed-pitch font.

• Language independent font
The same language independent font is used in all languages. By default, the
symbol set is preset. The symbol set is used for character graphics.

Configure static text by selecting the button illustrated or by choosing
"Insert" > "Text" from the menu.
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5.2.2 What are character graphics?

Purpose

Character graphics are static display elements that are not linked to the PLC. It
cannot be modified at run time on the operating unit. By using character graphics,
you can compose graphics from the individual characters contained in a symbol
font. An example of character graphics is illustrated below.

If you use character graphics instead of graphics, the memory requirement for your
project file will be reduced significantly.

Configure character graphics by selecting the button illustrated or by
choosing "Insert" > "Character Graphics" from the menu.

Line characters

Complete symbol packages are available for user-friendly drawing of polylines. The
symbol packages contain symbols for all representations of paths such as
horizontal and vertical lines, corners, crosses and bifurcations. The scope of supply
contains three fixed symbol packages the line characters single, bold and
double. You can customize four other symbol packages (USER 1 through USER
4) to meet your requirements.
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5.2.3 Graphics

Purpose

Graphics are static display elements that are not linked to the PLC. They cannot be
modified at run time on the operating unit. Use graphics, for example, for displaying
your system or as explanatory symbolism for dynamic display and controls

Creating graphics

ProTool features an option of embedding external graphic editors via the OLE
interface. In this way you can create graphics with your usual applications without
having to become familiar with a new graphics program.

ProTool displays every graphic you are using as a bitmap, irrespective of whether
you create the graphic with a pixel-oriented graphics program - for example, Paint -
or with a vector-oriented graphics program. Vector graphics are converted into
pixel graphics before being displayed in ProTool.

Configure graphics by selecting the symbol illustrated or by choosing
"Insert" > "Graphic" from the menu.

Color presentation on the operating unit

With pixel graphics, if you notice differences between the colors displayed on the
operating unit and those configured in ProTool, proceed as follows:

On the configuration computer, choose on the Start menu "Settings" > "Control
Panel" > "Display" and on the "Settings" tab, select at "Colors" the setting "True
Color".

Retain this setting for configuring and compiling the project.

Smooth display

If the "Smooth" setting is enabled, an anti-alias filter for replacing missing pixels
due to interpolation is used when increasing or decreasing the size of a graphic.
This setting results in softer transitions in photo-realistic displays. In the case of
drawings, the display quality is enhanced when zooming out of graphics in
particular, since the complete screen information is retained.
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5.2.4 What are output fields?

Purpose

Output fields display current values from the PLC on the operating unit. The values
may be output optionally in numerical, alphanumeric or symbolic form.

Numerical and alphanumeric output

Output fields for numerical or alphanumeric values show the value as a number or
as text. A numerical value, for example, is the number 80 as the actual value of a
temperature. An example of an alphanumeric value is the text string Valve_12.

Output fields for numeric and alphanumeric values are configured on the
open screen on the "Screen Objects" toolbar by choosing the illustrated
button or at "Insert" > "Input/Output Field".

Symbolic output

Output fields for symbolic values do not display the true value but, optionally, a text
string or a graphic from a text or graphic list. For example, you can store the two
states of a valve in a text list or in a graphic list. When the valve is open, the output
field then points, for example, to the text string OPEN or to a corresponding graphic.

By using output fields for symbolic values, you eliminate misinterpretations on the
part of the operator to a large extent, since a symbolic value often presents a state
more lucidly than an abstract numerical value, for instance.

Output fields for symbolic values are configured on the open screen on the
"Screen Objects" toolbar by choosing the illustrated button or at "Insert" >
"Text or Graphic List".
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5.2.5 What are trend views?

Purpose

A trend view is a dynamic display element. Trend views make possible a
particularly lucid form of continuous display of process data on the operating unit.

You can display several different trends simultaneously in one trend view on the
operating unit.

Configure a trend view by selecting the button illustrated or by choosing
"Insert" > "Trend View" from the menu.
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5.2.6 What are bar graphs?

Purpose

A bar graph is a dynamic display element. Bar graphs display a value from the PLC
as a rectangular area. This means that you can tell at a glance on the operating
unit how far the current value is from the limits or whether a specified setpoint has
been reached. Bar graphs can be used to display fill levels or quantities, for
example.

Configure bar graphs by selecting the symbol illustrated or by choosing
"Insert" > "Bar Graph" from the menu.

Settings

Bar graphs are linked to the PLC by means of a tag. Apart from this tag, which
contains the value that is required to be displayed, you can define other tags in
order, for example, to visualize when a limit value has been reached or to display
or hide the bar field.

You can freely define the direction, scaling, bar and background color and also
labeling of the Y axis. You can also display upper and lower limit value lines for
indicating limit values.

The following figure shows a bar that is updated vertically and has limit value lines
drawn on it.

Bar graphs with limit value lines
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5.2.7 What are light indicators?

Purpose

A light indicator is a dynamic display element on a touch panel. Light indicators
indicate the state of a defined bit - for example, by means of a change of color or
by flashing text. Light indicators are shown with a simple border for visual
distinction of buttons which you can press.

Configure light indicators by selecting the symbol illustrated or by choosing
"Insert" > "Light Indicator" from the menu.
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5.3 Controls

Purpose

You use controls on the operating unit to intervene directly in the process. They are
used, for example, to specify setpoints, trigger functions, open screens and

Overview

The following "controls" are available in ProTool for the different tasks:

• Input fields

• Input/output fields

• Function keys and soft keys

• Buttons

Dynamic attributes

Note

To many flashing and transparent objects can have a negative impact on the
screen change frequency and updates.
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5.3.1 What are input fields?

Purpose

In input fields you enter values on the operating unit that are transferred to the
PLC. The values may be input optionally in numerical, alphanumeric or symbolic
form. If you define limit values for the input field tag, you can reject inputs on the
operating unit that are outside the specified range of values.

Numerical and alphanumeric input

In input fields for numerical and alphanumeric values you enter the value one
character at a time on the operating unit. A numerical value, for example, is the
number 80 as the setpoint for a temperature. An example of an alphanumeric
value is the text string Valve_12.

Input fields for numeric and alphanumeric values are created on the open
screen on the "Screen Objects" toolbar by choosing the illustrated button
or at "Insert" > "Input/Output Field".

Symbolic input

In input fields for symbolic values you do not enter the value one character at a
time but select this value on the operating unit from a text list. During configuration
you assign symbolic text on the text list to every value of a tag. In this way, for
example, you can turn a motor on and off by means of the two entries ON and OFF.

By using input fields for symbolic values, you prevent misinterpretations to a large
extent, since the operating unit accepts only the configured values on the text list.

Input fields for symbolic values are created on the open screen on the
"Screen Objects" toolbar by choosing the illustrated button or at "Insert" >
"Text or Graphic List".
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5.3.2 What are combined input/output fields?

Principle

Combined input/output fields display current values from the PLC on the operating
unit. You can also enter values that are transferred to the PLC at the same time.
The values may be input and output optionally in numerical, alphanumeric or
symbolic form. During input, the value you want to be output is not updated on the
operating unit.

If you define limit values for the input/output field tag, values that are outside the
specified range can be:

• Rejected upon input

• Displayed in a different color, for example, when read out.

Combined input fields are created on the open screen on the "Screen
Objects" toolbar by choosing the illustrated button or at "Insert" >
"Input/Output Field".

Input fields for symbolic values are created on the open screen on the
"Screen Objects" toolbar by choosing the illustrated button or at "Insert" >
"Text or Graphic List".
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5.3.3 What are function keys?

Principle

A function key is a key on the operating unit for configuring a function assignment.
You can assign one or more functions to any function key in ProTool. The functions
are triggered as soon as the key is pressed.
The function key assignment may be locally or globally significant.
You can assign a password level to function keys in order to prevent operation by
unauthorized persons.

Global assignment

Globally assigned function keys always trigger the same function, irrespective of
the current control situation. You can the open a specific screen, for example,
display queued messages or print the contents of the screen.

By using globally assigned function keys, you cut your configuration effort
considerably since you do not have to assign individual functions to global keys on
every screen.

Assign function keys globally by choosing "System" > "Screen/Keys" from
the menu. To do this, click in the Screen/Keys dialog box on one of the
keys "K1" through "Kx" or "F1" through "Fx". You can specify the functions
you have assigned to specific keys on the operating unit by means of
labeling strips.

Note

By choosing "System" > "Screen/Keys you can specify global settings for keys that
apply to all screens. The icons appear in each configured screen provided the
settings are not subsequently overwritten by an individual screen. In that case, the
changes apply only to that particular screen.
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Local assignment

Locally assigned function keys trigger different actions on the operating unit
depending on the screen. A function key whose assignment may vary from screen
to screen is referred to as a "soft key".

Assign soft keys locally in the screen editor. To do so, click in the screen
on one of the keys "F1" through "Fx", which are arranged directly around
the operating unit screen. You can assign an icon that illustrates the soft
key function by means of text or a graphic to any soft key.

You can also assign soft keys globally. A global assignment is active on all screens
to which you do not assign a screen-specific function. Use globally assigned soft
keys, for example, to change from any screen to the same system screen.

Note

Do not assign functions that have to be permanently available on the operating unit
to soft keys.

Displaying assignments

You can see in the "Screen/Keys" dialog box and in the screen editor how your
configured soft keys are assigned:

Inhibited

Assigned locally

Assigned globally

Assigned locally and globally

Depending on whether it is a case of function keys, soft keys or soft keys with
LEDs, the display can vary slightly from the representation.
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5.3.4 What are buttons?

Requirements

Buttons can only be configured for touch panels. Before you start configuring
buttons, you should give a thought to the basic partitioning of the touch panel
screen (refer to "Configuration notes for the touch panels").

Purpose

A button is a virtual key on the touch panel screen to which you can assign one or
more functions. You operate a button by touching the touch-sensitive screen. You
can customize the user interface by means of buttons.

You can assign a password level to buttons in order to prevent operation by
unauthorized persons.

Labeling

You can label buttons statically or dynamically with text or graphics.

• Static labeling
When configuring the button enter a text or select a graphic. This type of
labeling is static, which means that it is not changed on the touch panel.

• Dynamic labeling
When configuring the button, select a text or graphics list and an associated
"index tag". The value of the index tag determines which list element is
displayed on the button at run time.

Operation

Pressing or releasing a button triggers the functions that you set for these events.

To prevent the triggering of a function of a button that has been pressed by
mistake, move your finger from the button while still keeping the button pressed.
This process is not interpreted as a click event.

Check-back indication upon operation

When the button is pressed and released, it is animated by a change in border
color as is usual in Windows. Invisible buttons do not provide an optical checkback
indication upon operation.

Invisible buttons

Invisible buttons are transparent buttons that are not displayed upon the operating
unit. If you place invisible buttons on graphics, you can operate parts of the graphic
- for example, a motor or a valve - by touching the touch panel.
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Buttons with a freely definable function

You can create on an individual basis, using a button with freely definable
function, all the buttons that you need for operating the TP. Create buttons
by selecting the symbol illustrated or by choosing "Insert" > "Button" from
the menu.

Buttons with fixed functions

ProTool features predefined buttons that can be operated and have the following
functions for quick and efficient configuration of standard functions for touch
panels:

• "Set/Reset Bit" button

• "Select Screen" button

"Set/Reset Bit" button

With the "Set/Reset Bit" button you can set or reset a bit in a tag. The bit
function is triggered as soon as you touch the button. On doing so, the bit
in set in the tag, for example. Press the button a second time to reset the
bit.

Create the button by selecting the symbol shown or by choosing "Insert" >
"Set/Reset Bit" from the menu.

Depending on the tag type and on the settings in the option buttons at "bit
function", one of the following functions is automatically assigned to the button:

Setting Function for BOOL
tag type

Function for KF/INT
tag type

Condition

Set Set Bit Set Bit in Word Press button

Reset Reset Bit Reset Bit in Word Press button

Set/Reset Set/Reset Bit Set/Reset Bit in Word Press button

Set on Pressing
Button

Set Bit on Pressing
Button

Press/release
button

"Select Screen" button

With the "Select Screen" button you can select a different screen on the
touch panel. The Select Screen function is triggered and the
corresponding screen is displayed as soon as you click the button.

Create the button by selecting the symbol illustrated or by choosing "Insert"
> "Button" from the menu.

Note

Do not assign functions that have to be permanently available on the operating unit
to soft keys.
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5.3.5 Using buttons as direct keys

Purpose

You can also configure buttons on the TP as direct keys in order to allow keyboard
shortcuts without the usual delays caused by communications. Shortcuts are, for
example, a condition for typewriter mode.

Direct key types

Basically, you can configure two different types of direct key:

• PROFIBUS direct keys

• direct keys for controlling the direct key module

Simultaneous use of PROFIBUS direct keys and direct keys for the direct key
module is not possible within the same project.

PROFIBUS direct keys

With PROFIBUS direct keys, you set bits on the TP directly in the I/O area of the
SIMATIC S7. The bit area is set in SIMATIC STEP 7. The bit is set when the direct
key is touched and reset when the key is released or when you quit the screen.

Requirements

1. At the time your project is generated, ProTool is installed and integrated.

2. During operation the Touch Panel is connected to a SIMATIC S7 via the
PROFIBUS-DP.

3. You have defined the bit area for direct keys in SIMATIC STEP 7 (you will find
configuration tips in the "Communication Manual").

If all these requirements have not been fulfilled, ProTool interprets the configured
button as a direct key for driving the direct key module. The number of PROFIBUS
bits that can be manipulated by means of direct keys depends on the touch panel:

Panel No. of Bits

TP 37 40 (0...39)

TP 27 24 (0...23)
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Direct keys for the direct key module

You can use these direct keys to drive the outputs (ports) of the optional direct key
module at the back of the TP. The port is set when the direct key is touched and
reset when the key is released or when you quit the screen.

Requirements

The TP is equipped with a direct key module and the requirements for PROFIBUS
direct keys are not met. The number of ports that can be configured depends on
the touch panel:

Panel No. of Ports

TP 37 16 (1...16)

TP 27 8 (1...8)
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5.4 Tags

Purpose

Since tags are the most important means of communication between the operating
unit and the PLC and for exchanging data, a detailed explanation is presented here
of what tags are and what types of tag are used in ProTool.

Definition

A tag has a symbolic name and a defined data type. The value of the tag changes
while the PLC program is being executed.

Tags with a PLC link are referred to as global tags. Tags without a PLC link are
known as local tags.

• Global tags

A tag with a PLC link occupies a defined memory address on the PLC, to which
read and write access is possible from both the operating unit and the PLC.

• Local tags

Local tags are not connected to the PLC. They are available only on the operating
unit. You create local tags, for example, so that the operator can enter limit values
on the operating unit.

Tag types

ProTool supports the following internal tag types (but these are not available on
every PLC):

Data type Bit System Range of Values

INT 16 bit - 32768 through 32767

UINT 16 bit 0 through 65535

LONG 32 bit - 2147483648 through
2147483647

ULONG 32 bit 0 through 4294967295

FLOAT 32 bit Upper limit: ± 3.402823 e+38

Lower limit: ± 1.175495 e-38

BOOL true (1), false (0)

STRING 1 to 80 bytes

ARRAY tags This tag type combines a random
number of tags of the same type to
form a total, which can be handled
as a whole.
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5.4.1 Properties of tags

Tag definition (Section A)

To define a tag, set the properties of the tag in the "Tag" dialog box.

The figure shows an example of the "Tag" dialog box for SIMATIC S7 integrated in
SIMATIC STEP 7.

"Tag" dialog box for the SIMATIC S7

The available data types and data formats depend on the PLC you selected. You
choose at "Type" in the "Tag" dialog box between "Format" and "Decimal places".

Updating tags (Section A)

The acquisition cycle determines the time interval in which the value of a tag is
updated on the operating unit.

• If 0 is entered for the acquisition cycle, the tag is updated only when a screen
is opened and then not updated any more until the screen is opened again.

• If a value > 0 is entered for the acquisition cycle of a tag, the tag is updated
periodically in the specified time and also when the screen is opened.

The acquisition cycle is a multiple of the "standard clock pulse", which you
configure for every PLC in the "PLC" dialog box. You globally modify the
acquisition cycles for all the tags of a project by setting the standard clock pulse.
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Array tags

An array tag represents a number of tags of the same type with consecutive
memory addresses. If you wish to define an array tag, enter the number of
elements in the array in the "Tag" dialog box at "Number of elements".

The system default setting is 1, in other words, the tag is not defined as an array.

The maximum number of elements in an array is 640.

Application example:
You can use array tags for history trends, for instance.

Address (Section B)

The address determines the memory location of a global tag on the PLC. The
address therefore depends on the PLC you are using.

The display of the address depends on the PLC you selected. This section of the
"Tag" dialog box adjusts dynamically to the programmable address areas.

ProTool integrated in SIMATIC STEP 7 (Section C)

If you have installed ProTool integrated in SIMATIC STEP 7, you can access the
"STEP 7" symbol table directly in the "Tag" dialog box. The symbol table is
displayed in the "Symbols" floater when you select the "With symbol" check box.
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5.4.2 Updating tags

Tag options

On the "Options" tab of the "Tags" dialog box, you set how often the values of tags
are transferred between the operating unit and the PLC and updated

• Write Directly (system default setting)
After being entered on the operating unit, the tag value is written directly to the
PLC address.

• Write Indirectly (only on SIMATIC S5 and SIMATIC S7)
With write indirectly, the tag value is written on the PLC to an address area
known as the "data mailbox". In order to ensure the coordinated execution of
the transfer and prevent unwanted overwriting of the tag value in the data
mailbox, bits are set in the interface area. The value can be fetched by the PLC
program from the data mailbox at the appropriate time. By selecting "Write
indirectly", you can configure up to three "IDs" for every tag, which are likewise
written to the data mailbox. You will find further information in the
"Communication User's Guide".

• Read Continuously
The tag is updated continuously, even if it is not on the open screen. This is
important with trends, for example, since a trend is normally required to be
plotted even if the screen is not selected.

Note

Use the "Read Continuously" option only for tags that you want to have updated
continuously. Otherwise you might unnecessarily degrade the performance of your
system.

• ONLINE
If you select ONLINE (default setting), the tag is serviced by the PLC during
operation. If you deselect ONLINE, the tag is disconnected from the PLC
during operation. You can use this, for example, if you are taking only parts of
the system into operation.
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5.4.3 Examples of configuring tags

By means of an example, we show you here how to set the acquisition cycle and
the basic clock cycle of tags and convert tags automatically with the help of
functions.

5.4.3.1 How to set the acquisition cycle and the standard clock pulse

Increasing the acquisition cycle and the standard clock pulse

System default setting: standard clock pulse 500 ms, acquisition cycle 1 s.

Set the standard clock pulse in the "PLC" dialog box. If you increase the standard
clock pulse to 1000 ms, the acquisition cycle for all tags is increased to 2 s.

Note

In order not to overtax communication between the PLC and the operating unit, the
times you set for the standard clock pulse should not be too short. This would
mean that other processes, such as the updating of trends or the execution of PLC
jobs, would take considerably longer.
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5.4.3.2 Tag scaling

Configuring functions

The scaling of tags is configured as a function for a tag. The following functions are
available for this:

• Scaling Linear 1 and Scaling Linear 2

• Scaling Square 1 and Scaling Square 2.

If you configure no scaling, the tag value on the PLC corresponds to the tag value
on the operating unit.

Linear scaling

Scaling can be configured for any tag in the form
y = a*x + b.

• X = displayed value/input value
The Y value read from the PLC undergoes linear scaling before being
displayed on the operating unit as the X value. Inputs X on the operating unit
undergo scaling before being written to the PLC as the Y value.

• Y = displayed value/input value
The X value read from the PLC undergoes linear scaling before being
displayed on the operating unit as the Y value. Inputs Y on the operating unit
undergo scaling before being written to the PLC as the X value.

Example

You have configured 3 as the value of a and 6 as the value of b. The value 21 is
transferred from the PLC. It is included in the scaling function: 21 = 3 * X + 6. This
results in 5 being the value for X. This is the value displayed on the operating unit.

Square scaling

Scaling can be configured for any tag in the form:
y = a * x^2 + b * x + c.

• X = displayed value/input value
The Y value read from the PLC undergoes square scaling before being
displayed on the operating unit as the X value. Inputs X on the operating unit
undergo scaling before being written to the PLC as the Y value.

• Y = displayed value/input value
The X value read from the PLC undergoes square scaling before being
displayed on the operating unit as the Y value. Inputs Y on the operating unit
undergo scaling before being written to the PLC as the X value.

Example

You have configured a value of 2 for a, and a value of 2 for b and 6 for c. A value
of 71 is transferred from the PLC. They are included in the scaling function: 71 = 2
* X^2 + 3 * X + 6. This results in 5 being the value for X. This is the value displayed
on the operating unit.
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5.4.4 Details on configuring tags

At "Details" you will find more information on the subject of tags.

5.4.4.1 Decimal places with tags

Number of decimal places as a function of the PLC

The following list shows the possible number of decimal places of the different
types as a function of the PLC selected:

SIMATIC S5 0 to 4 KF

0 to 6 KG

0 to 8 DF

--- DH, KH, KM, KC, KY, KT, KZ, BCD4

SIMATIC S7 0 to 2 CHAR, BYTE

0 to 4 INT, WORD

0 to 6 REAL

0 to 8 DINT, DWORD

--- BOOL, STRING, Timer, Counter

SIMATIC S7-NC 0 to 4 INT_16, UINT_16

0 to 6 FLOAT

0 to 8 INTEGER, LONG, UINT32, DOUBLE

--- BOOL, CHAR, STRING

SIMATIC 500/505 0 to 4 +/- INT, INT

0 to 6 REAL

0 to 8 +/- DOUBLE, DOUBLE

--- BIT, ASCII

No PLC 0 to 4 INT, UINT

0 to 6 FLOAT

0 to 8 LONG, ULONG

--- BOOL, STRING
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5.4.4.2 Address and type of a tag

Dependence of tags on the PLC

The address and the data type (the data format) of a tag depends on the PLC.

Note

You will find information about the various PLCs at "Start" > "SIMATIC" > "ProTool
V6.0" > "ProTool Information System" in the topic "Process communication".

Available PLCs

SIMATIC S5 - AS511

SIMATIC S5 - DP

SIMATIC S7-300/400

SIMATIC WinAC

SIMATIC S7-200

SIMATIC 500/505

SIMATIC 500/505-DP

SIMOTION

OPC (Client/Server)

Allen-Bradley DF1

Allen-Bradley DH485

LG GLOFA-GM

MITSUBISHI FX

MITSUBISHI Protocol 4

Modicon Modbus

Telemecanique Uni-Telway

GE Fanuc SNP/SNPX

Omron Host-Link
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5.5 Multiplexing

Purpose

When multiplexing, you assign several tags to trends, bar graphs or input/output
fields, not just one. Assignment depends on the value of an index tag. A tag,
selected at run time, is assigned to each of the index tag values.

Using the index tag, you can control all the tags of a screen, for example. This
spares you the trouble of configuring several screens for similar applications.

Applications

You can multiplex the following objects:

• Bar graph

• Trends

• Trend tags

• Input/output fields
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5.5.1 Multiplexing a bar graph

Purpose

When you configure a bar graph, you define in advance the tag from which you
want the values to be read and displayed on the operating unit. If you multiplex bar
graphs, the assignment of the bar graph to a tag is not static but depends on the
value of an index tag. This allows you to determine several tags whose values are
displayed, depending on the situation, as bar graphs at runtime.

Principle

Selection of the tags is controlled by means of the index tag. Every index tag value
has assigned to it a tag, with values read and displayed. The figure shows the
principle of multiplexing bar graphs by means of three examples.

Multiplexing bar graphs (principle)

In the bar graph shown, the contents of tanks T1, T2 or T3 are displayed on the
operating unit as a function of the index tag value VAR_S1. The tank contents are
read from tags VAR_1 through VAR_3.
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5.5.2 Multiplexing trends

Purpose

When you configure a trend view, you determine in advance the trends that you
want to have displayed on the operating unit. If you multiplex trends, selection of
the trends is not static but depends on the value of an index tag. This allows you to
determine which trends are shown in the different situations at run time.

Principle

Selection of the trends is controlled by means of the index tag. A trend is assigned
to every index tag value. The figure illustrates the principle of multiplexing trends.

Multiplexing trends (principle)

Temperature values Temp1 through Temp3 are stored in DB 10 on the PLC at
addresses DW 37, DW 39 and DW 41. Tags Var1 through Var3 are configured for
these addresses. A trend buffer is created for every single tag on the operating
unit. The size of the trend buffers depends on the configured number of
samples/max. The value of index tag Var_A determines the buffer from which the
values come for the trend view you want to have displayed.

With this type of multiplexing, all the trends are up to date in the background.
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5.5.3 Multiplexing trend tags

Purpose

The standard case is to set up a separate trend buffer for each trend to be
displayed on the operating unit.

When trend tags are being multiplexed, different trend tags write to a shared trend
buffer, depending on the value of an index tag. In other words, a trend view
displays a trend whose values are read by different tags belonging to the trend
buffer.

This allows you to determine which trends should be shown in the different
situations at run time. At the same time, you save storage space on the operating
unit by using a common trend buffer.

Principle

Every value of the index tag is assigned a trend tag which writes to the trend
buffer. The figure illustrates the principle of multiplexing trend tags.

Multiplexing trends (principle)

Temperature values Temp1 through Temp3 are stored in DB 10 on the PLC at
addresses DW 37, DW 39 and DW 41. Tags Var1 through Var3 are configured for
these addresses. The value of index tag Var_A determines which tag writes values
to the trend buffer.

With this type of multiplexing, it is possible to display a larger number of process
values as a trend, since separate trend buffers are not created for every trend.
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5.5.4 Multiplexing input/output fields

Basic procedure

When you configure input or output fields, you define in advance the tag in which
inputs are applied and from which values required to be output are read. If you
multiplex input and output fields, the assignment to a tag is not static but depends
on the value of an index tag. This allows you to determine several tags whose
values can be displayed, depending on the situation, in an output field at run time
or entered in an input field and modified.
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5.5.5 Examples of multiplexing

This example shows you how to multiplex a bar graph.

5.5.5.1 How to multiplex bar graphs

Objective

In the following example, three values of index tag VAR_S1 are assigned tags
VAR_1 through VAR_3. The PLC is a SIMATIC S7.

Procedure

Procedure:

1 On the "General" tab, click the "Multiplex" button.

2 Configure index tag Var_S1. The value of the index tag determines at run
time which tag is selected as the bar graph.

Select this button at index tag.

In the "Tag" dialog box, enter the symbolic name Var_S1 and the following
values.

Type: INT

DB: 15

DBW: 0

PLC: PLC_1

VAR_S1 assumes the values 0, 1 or 2. Each of these three values is now
assigned a separate tag.

3 Configure the multiplex tags VAR_1, VAR_2 and VAR_3:

Select this button at Multiplex tag.

In the "Tag" dialog box, enter the symbolic name Var_1 and the following
values:

Type: INT

DB: 16

DBW: 1

PLC: PLC_1

Then click the "Add" button. Tag VAR_1 is accepted into the list and VAR_S1
is assigned to the value (index) 0 of the index tag.

Repeat this step with Var_2 and Var_3.

4 Confirm by clicking OK. A small cross now appears on the "Multiplex" button
to indicate that multiplexing is being used. The index tag is specified instead
of the tag.
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5.6 Text or graphic lists

Purpose

Text or graphics are often more meaningful than abstract values. For example, the
pieces of text full and empty or two graphic symbols present the state of a tank
more lucidly than the corresponding numerical values. Which is why ProTool gives
you the opportunity to configure text or graphic lists.

These text or graphic lists are lists in which you assign an element from the list to
each tag value.

Usage

With text or graphic lists, for example, you can label buttons dynamically, display
text or graphics in output fields and select texts for input in input fields. To a large
extent, this eliminates misinterpretations in the display and operator errors during
input.

You will find further information on using text or graphic lists on a screen in the
topics dealing with input fields, output fields and buttons.

Text list

A text list assigns text to every value of a tag. At run time, the tag value determines
which text is selected from the list and displayed, for example, in an input/output
field on the operating unit.

To create a new text list, select the button illustrated on the toolbar.

Note

The configurable range of values in a text list ranges from 0 to 32767 for a
maximum of 3500 different blocks of text.

Graphic list

A graphic list assigns a graphic to every value of a tag. At run time, the tag value
determines which graphic is selected from the list and displayed, for example, in an
output field on the operating unit.

To create a new graphics list, select the button illustrated on the toolbar.
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5.7 Creating Graphics

Purpose

Graphics are static display elements that are not linked to the PLC. They cannot be
modified at run time on the operating unit. Use graphics, for example, for displaying
your system or as explanatory symbolism for dynamic display and controls

Creating graphics

ProTool features an option of embedding external graphic editors via the OLE
interface. In this way you can create graphics with your usual applications without
having to become familiar with a new graphics program.

ProTool displays every graphic you are using as a bitmap, irrespective of whether
you create the graphic with a pixel-oriented graphics program - for example, Paint -
or with a vector-oriented graphics program. Vector graphics are converted into
pixel graphics before being displayed in ProTool.

Configure graphics by selecting the symbol illustrated or by choosing
"Insert" > "Graphic" from the menu.

Color presentation on the operating unit

With pixel graphics, if you notice differences between the colors displayed on the
operating unit and those configured in ProTool, proceed as follows:

On the configuration computer, choose on the Start menu "Settings" > "Control
Panel" > "Display" and on the "Settings" tab, select at "Colors" the setting "True
Color".

Retain this setting for configuring and compiling the project.

Smooth display

If the "Smooth" setting is enabled, an anti-alias filter for replacing missing pixels
due to interpolation is used when increasing or decreasing the size of a graphic.
This setting results in softer transitions in photo-realistic displays. In the case of
drawings, the display quality is enhanced when zooming out of graphics in
particular, since the complete screen information is retained.
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5.8 Trends

Usage

• Real-time trend
With a realtime trend only one trend value at a time is read from the PLC for
each time unit (clock pulse) and added to the trend displayed on the operating
unit. Real-time trends are suitable for displaying slow, continuous patterns.

• Pattern trend
With a pattern trend, all trend values are read simultaneously from the PLC
and displayed as a trend on the operating unit by setting a trigger bit. Pattern
trends are suitable for displaying rapid changes if the trend variation, seen in
its entirety, (profile) is more interesting than individual values.

Trigger

The trigger type defines how trend data is read in:

• Clock trigger (as function of time)
In the case of a clock trigger, the data that has to be acquired in the trend is
read from the PLC in a fixed, adjustable time slot. To do this, select "Read
Continuously" on the "Options" tab when configuring the tag. If the configured
number of samples has been reached, the oldest value is overwritten by every
new one. By means of the specified time slot and the number of samples you
want to have displayed, you set the period of time that has to be covered by
the trend data. This type of trigger is suitable for "real-time trends".

• Bit trigger (event triggered)
With a bit trigger, the data that have to be acquired on the trend are read in
upon being triggered by an event. The event is triggered by the PLC as a result
of setting a defined bit. There are two options for reading in trend data: -
Single-value acquisition Only one value is read from the PLC each time a bit is
set. Single-value acquisition is suitable for displaying "real-time trends". -
Buffered data acquisition Buffered data are read out from the PLC as an entire
block every time a bit is set. Buffered data acquisition is suitable for displaying
"history trends".
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Communication areas for bit-triggered trends

For you to be able to configure bit-triggered trends, you have to set communication
areas at "Area Pointers" in the project window and create them on the PLC. The
operating unit and the PLC communicate with each other via these areas:

• Trend request area
This area can be used by the PLC to evaluate which trend is currently being
displayed on the operating unit.

• Trend transfer area 1
This area is used to trigger the trends.

• Trend transfer area 2
This area is required only for trends that you configure with a switch buffer.

A specific trigger bit is assigned to every trend in all bit areas. If, for example, you
have assigned trigger bit 4 to a trend, that trend will be identified by bit 4 in all bit
areas.

Switch buffer

A switch buffer is a second buffer which you can create for a pattern trend. While
the operating unit is reading the trend values from buffer 1, the PLC can already
write the new values to buffer 2. When the operating unit is reading buffer 2, the
PLC is writing to buffer 1. The switch buffer prevents the PLC from overwriting
values while the operating unit is reading the trend.

Switch buffer: reading and writing trend values simultaneously
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5.8.1 Details for configuring trends

Here you will find more information about configuring trends.

5.8.1.1 How a bit trigger works

Principle

When a screen containing a trend view with one or more bit-triggered trends is
opened on the operating unit, the operating unit sets the bits assigned to the
individual trends in the "trend request area" in each case. From the bits set, the
PLC can evaluate which trends are currently being displayed on the operating unit.

If the PLC program now sets both the bits assigned to the trends and the trend
communication bit in the "trend transfer area", the operating unit detects the trigger.
It resets the trend bits and the "trend communication bit" and, depending on the
configuration, reads out one value or the entire buffer.

As soon as the conditions for a new trigger have been met, the PLC program sets
the trend bits and the trend communication bit again.

Once the screen has been deselected, the operating unit resets the bits set in the
trend request area.

Define the trend request area and trend transfer area in the project window at
"Area pointers". You will find a description of these data areas in the
"Communication Manual".

Note

The position of the communication bit in the trend transfer area depends on the
PLC you set. Do not use this bit for the identification of bit-triggered trends.
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5.8.1.2 Array tags for history trends

Principle

You can configure array tags for history trends. You use the number of elements to
set the size of the trend buffer. This number has to be identical to the number of
samples you set for the trend.

The history trend is represented by the array tag. If you use this array tag in a
recipe, you can save the history trend to a data medium on the operating unit and
read it back in, just like you would with any other data record.

Constraint

The data types "Byte" and "Char" are not allowed in array tags for history trends.

5.8.1.3 Interrupting the recording of trend data

Principle

If you interrupt operation of the operating unit while clock-triggered trends are
being recorded, the X axis with the time label is updated immediately upon
restarting. The trend values are, however, updated at the configured clock-pulse
rate and therefore temporarily do not correspond to the time values displayed.

For this reason, the vertical bar displayed on the screen is shown in the trend view
when plotting restarts. The bar represents the time of interruption and migrates
continuously at the configured clock-pulse rate out of the trend view.

Interrupted trend plotting



Release 12/01 Configuration techniques

ProTool User Manual How to configure graphics-based units
A5E00149244 5-45

5.9 Messages

To display process and operating states or to acquire and log process data on the
operating unit that you obtain on the process from the PLC, configure "messages".

Messages are initiated by the PLC and can be displayed on the operating unit.

5.9.1 Displaying operating and process states

What do you use to display operating and process states?

To display process and operating states or to acquire and log process data on the
operating unit that you obtain on the process from the PLC, configure "messages".

Messages are initiated by the PLC and can be displayed on the operating unit.

There are the following message types in ProTool:

• Event messages: Display routine operating and process states and processes.

• Alarm messages: Display critical or hazardous operating and process states
and require operating personnel to react by issuing an "acknowledgement".

• System messages: Display states and errors of the operating unit, the PLC or
the communications between them. They are issued by the operating unit or by
the PLC.

For what purpose do you use messages?

The messaging system is responsible for the following tasks:

• Reporting events or states that might occur on the system or in the process:
– A state is reported immediately after its occurrence.
– The messages are presented to the operator as a function of their
significance (priority).

• Support when troubleshooting error conditions: - Messages provide detailed
information on the causes of errors (diagnostics) The process might be
influenced as a result of the message.

• Reporting: The message events are output to a printer.
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5.9.2 The components of a message

Message structure

A message consists of:

• Message number

• Message text

• A message tag

• Help text

The following messages are displayed on the operating unit but cannot be edited in
ProTool:

• The message number cannot be modified in system messages, standard
diagnostic results (S7 system messages) and NC alarms. (Only with OP 7 and
OP 17).

• Message numbers of user defined diagnostic results can be freely defined in
SIMATIC STEP 7 within certain limits.

• The message number is assigned to Alarm_S messages in SIMATIC STEP 7.

Message number

The message number is used to reference a message. In ProTool, you have a free
choice of message number (within the range 0 to 2000) and message text.

Message text

Message text contains the description of a message. The length of the message
text depends on the operating unit. The number of characters per line is marked by
this character (A) at the top border of the window during configuration.

By choosing "Edit" > "Style" from the menu, you can select the following styles, for
example, for the message text, depending on the operating unit: flashing,
underscore, italic.

Note

You can also configure operator instructions as a message.
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Message tags

A message can contain output fields with tags. They are also referred to as
"message tags".

By choosing "Edit" > "Style" from the menu, you can select from the following
styles for output fields, depending on the operating unit: flashing, underscore, italic.

Insert an output field by selecting the symbol illustrated.

Note

The values of message tags are updated in the message buffer when messages
are active or are cleared, but not when messages are acknowledged.

Help text

Help text containing further details on a message can be configured for every
message. Help text is displayed for the operator in a separate window on the
operating unit by pressing the "HELP" key.

Enter Help text by selecting the button illustrated or by using the menu
command "View" > "Help Text".

Other message components

When configuring message views for certain devices, other message components
can be displayed - for example, details of the error location (on the PLC).
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5.9.3 Message properties

Configurable properties

You can configure the following parameters for messages:

• Priority

• Acknowledgement group

• Print

• Port / relay

Priority

High-priority messages are displayed before low-priority messages on the
operating unit. The lowest priority is 1.

• If several messages having the same priority are waiting to be displayed, the
most recent (last) is displayed.

• If several unacknowledged alarm messages having the same priority are
waiting to be displayed, you can choose whether the most recent (last) or the
oldest (first) should be displayed.

Configure the priority in the "Attributes" dialog box for every single message. Set
the sort criterion by choosing "System" > "Messages" > "Settings" from the menu.

Acknowledgement group

Alarm messages can be assigned to acknowledgement groups. Configure the
assignment to an acknowledgement group for every single message. If you
acknowledge an alarm message in one acknowledgement group, all the alarm
messages in that group are acknowledged simultaneously ("group
acknowledgement").

Print

If you select "Print", the message event (active, cleared, acknowledged) is logged
automatically on the printer if you selected "Print upon Message Event" after
choosing "System" > "Messages" > "Settings" from the menu.

Configure printing in the "Attributes" dialog box for every single message.



Release 12/01 Configuration techniques

ProTool User Manual How to configure graphics-based units
A5E00149244 5-49

port / relay

If you select "Relay", the "active" message event automatically drives the relay on
the operating unit.

If you select "Port", the "active" message event automatically drives a port on the
operating unit. For this you have connect a "direct key module" (DKM) to the
operating unit.

You can configure the following ports for the different operating units:

OP 25, OP 27, TP 27 ports 1 to 8
OP 35, OP 37, TP 37 ports 1 to 16
Windows-based systems ports 1 to 16

Configure port/relay in the "Attributes" dialog box for every single message.
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5.9.4 Acknowledging messages

Principle

An alarm message can be acknowledged either by the operator on the operating
unit or by the PLC program. By acknowledging an alarm message, the operator
confirms that he has taken note of the message.

Single acknowledgment and group acknowledgment

When you configure messages, you can set whether the operator as to
acknowledge each message singly or whether the acknowledgement will apply to a
group of messages. The use of acknowledgement groups is practical in particular
for messages having the same cause – for example, the message of the initial
error and consequential errors.

Assigning acknowledgement groups

In the Attributes dialog box of the message editor, you can combine messages to
form acknowledgement groups by assigning them the same number at
"Acknowledgement".

You can allocate the messages to one of up to 16 acknowledgement groups.

The value 0 or a blank "Acknowledgement" field signifies that an acknowledgement
applies only to that alarm message (single acknowledgment).
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5.9.5 Driving a port/relay

Driving a relay

If you have selected"Relay" for a message, the relay connected to the operating
unit is driven.

The relay is energized upon the occurrence of the arrive event.

The relay is deenergized in the case of

• event messages: Cleared Message Event.

• alarm messages: Acknowledged Message Event.

Driving a port

If you have activated "Port" for a message, the port connected to the operating unit
is driven - in other words, 24 V DC are applied.

The port is energized upon the occurrence of the arrive event.

The port is disabled again upon the occurrence of

• event messages: Cleared Message Event.

• alarm messages: Acknowledged Message Event.
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5.9.6 Settings for message classes

Properties of message classes

You can configure the following parameters for message classes:

• acknowledgement

• printout

acknowledgement

Alarm messages have to be acknowledged. Alarm messages are displayed until
they have been acknowledged.

• Single acknowledgement: When you acknowledge a message, only that
particular message is acknowledged.

• Group acknowledgement: When you acknowledge a message belonging to an
acknowledgement group, all the queued messages of this group are
acknowledged, too.

printout

Printing is enabled or disabled by selecting the "Print" attribute, or is enabled when
the message buffer overflows. The messages are printed on a printer attached to
the operating unit.

Configure your printout by choosing "System" > "Messages" > "Settings" from the
menu.
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5.9.7 System messages

Displaying system messages

System messages are always implemented on the operating unit and cannot be
configured in ProTool. They are displayed in a process window.

What is reported?

A system message consists of a "message number" and "message text". The
message text may contain internal system tags that provide further details on the
cause of an error message.

System messages provide information on operating unit operating states. The
wealth of possible system messages ranges from notes to serious errors.

Note

You will find a list of system messages of the operating units, their causes and, if
possible, remedial action in an appendix to the equipment manuals and the
"Communication User's Guide".

Displaying system messages

At "System" > "Messages" > "System Messages" you set the system messages
you want to have displayed on the operating unit and for how long.

Note

The 0 setting means the display is static. The process window is not closed until
you press ESC.
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5.9.8 Logging messages

Enabling and disabling message logging

To log messages on the printer, select the "Print" check box in the "Attributes -
Message" dialog box. The messages are logged when their status changes (active,
cleared, acknowledged).

By choosing "System" > "Messages" > "Settings" from the menu, you can select
the following settings for message logging:

• "Message event"
Message logging is activated for those message events for which the attribute
"Print" has been selected.

• "Buffer overflow"
When the specified remaining buffer capacity is reached, all messages are
printed irrespective of whether printing is enabled or not. The message buffer
is then deleted.

• "Off"
Message logging is disabled.

You use the "Message Log ON/OFF" function to enable and disable printing of
messages
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5.9.9 Configuring printers for the operating unit

Printer for logging

Attach a printer to your operating unit to log process states or process data reports.

For this you can configure one or more printers.

• In ProTool, some printers in the list box have already been defined.
Parameters have already been assigned to these printers.

• You can add more "new printers" to the list box in ProTool. You have to enter
the specific control characters contained in the printer manuals concerned for
these printers.

Perform the settings for the printers and the interface parameters by choosing
"System" > "Printer" from the menu.

Note

Use the Z_PRINTER standard screen that is part of the standard configuration.
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5.9.10 Displaying messages on the operating unit

Displaying messages

Messages are displayed in special process windows.

Set the properties of the following objects by choosing "System" > "Screen/Keys"
from the menu:

• Message window/message line: Messages are output here.

• Message indicator: The message indicator indicates that alarm messages are
waiting or have to be acknowledged. The message indicator is used for
acknowledging messages on touch panels.

Sort criterion for alarm messages

If several unacknowledged alarm messages of the same priority are queued, select
the sort criterion by choosing "System" > "Messages" > "Settings" from the menu:

First The first (oldest) alarm message is displayed first.

Last The last (most recent) alarm message is displayed first.

If you configure the function Alarms - Display First/Last you can change
the sort order on the operating unit.

Note

This function has already been implemented on the System Settings standard
screen of the standard project (Refer to "Standard screens")

Standby message

The "standby message" is a special event message. The standby message is the
event message having message number 0. It is displayed on the message line
when no other messages are queued on the operating unit.

Note

The standby message can have only message text and output fields containing the
date and time.
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5.9.11 Contents of message buffers

Definition

A message buffer is a buffered memory area in the operating unit RAM in which
message events are stored in chronological order. It takes the form of a FIFO
buffer with a specified size and does not have to be explicitly configured.

The size of the message buffer is 512 message events.

Data storage in message buffer

Every message event is stored with the following information:

• Message number

• Identification of the event ("K" for Active, "G" for Cleared, "Q" for
Acknowledged)

• Time stamp consisting of date and time

• Acknowledgement group "QGR" (with alarm messages only)

• Message text

• Value of the message tag at the time of arrival or departure

Example

Below is an example of output from the message buffer to the printer:

0010 G 11:58:08 27.03.98 QGR02
Boiler pressure too high: 7.9 bar

0029 Q 11:40:47 27.03.98 QGR00
Oil supply shut off.

0029 KQ 11:38:09 27.03.98 QGR00
Oil supply shut off.

0010 Q 11:35:18 27.03.98 QGR02
Boiler pressure too high: #### bar

0010 KQ 11:34:26 27.03.98 QGR02
Boiler pressure too high: 12.7 bar

If a message contains process values, then those values that were available when
the message event arrived or departed are stored in the message buffer. In the
case of the "acknowledged" message status, the operating unit does not acquire
any current process values. The characters ### stand for the value.
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Behavior on overflow

Choose "System" > "Messages" > "Settings" from the menu to select whether an
overflow warning should be output when the specified remaining buffer capacity is
reached.

Before the messages are deleted, they are output to the printer. This applies to all
messages even if they are not marked with the "Print" attribute.

Using a standard screen

The following functions have already been implemented on the standard screen
known as "Edit Message" (Z_MESSAGES):

• Display event and alarm buffers

• Print event and alarm buffers

• Delete event and alarm buffers

• Display event and alarm pages

• Open event message window
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5.9.12 Type of message view (message window or message line)!

Type of message view

Set display of messages on the operating unit by choosing "System" >
"Screen/Keys" from the menu. Choose between the following combinations:

Window - window

Event messages and alarm messages are
displayed in separate message windows. The
alarm message window opens automatically
whenever an alarm message arrives; enable
and disable the event message window by
choosing the function "Event Window".

Window - line

An alarm message is displayed in the
message window, whereas an event message
is displayed on the message line. The
message line is visible at all times. The alarm
message window opens automatically
whenever an alarm message arrives.

Window - off

An alarm message is displayed in the
message window. Event messages are not
displayed.

Line - line

(except touch panels)

The message line is visible at all times. Any
alarm messages or event messages that are
issued are displayed on the message line
according to their priority.

Graphics display units:

If no message is pending, the standby
message – if configured – is displayed.

Dynamic positioning (OP 35, OP 37 only)

You can activate "dynamic positioning" by choosing "System" > "Screen/Keys"
from the menu.

This causes the position of the message and Help text windows to be changed
dynamically as a function of cursor position so that input fields just undergoing
editing are not concealed.
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5.9.13 What does the message indicator show?

Displaying the message indicator

Set display of the message indicator on the operating unit by choosing "System" >
"Screen/Keys" from the menu. The message indicator indicates that alarm
messages are waiting.

• As soon as an alarm message is waiting, an alarm message window and the
message indicator are displayed.

• As soon as at least one unacknowledged alarm message is queued, the
message indicator flashes.

Message indicator on touch panels

On touch panels, the message indicator is an "operable button" and is used to
acknowledge alarm messages. It cannot be hidden for that reason.

The message indicator may assume two states:

• Flashing: As soon as at least one unacknowledged alarm message is queued.

• Static: When all queued alarm messages have been acknowledged but at least
one of them is not yet cleared.
Not until all acknowledged messages have departed is the message indicator
hidden. In this way it is not possible fore you to forget queued alarm messages.

If the alarm message window is shown on top, the alarm message page is opened
by touching the message indicator.

At each touch you can toggle between the alarm message buffer and the alarm
message page.
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5.9.14 Communication areas for messages

Communication area required for operating unit/PLC communication

For communication between the operating unit and the PLC to function properly,
establish an assignment to the following communication areas in the project
window of your ProTool project at "Area Pointers": "Event messages" and/or
"Alarm messages".

These areas are imperative if you configure event messages and alarm messages.

They must be chosen at least large enough for a bit to be available for every
configured message. If the communication area is not made large enough, a
warning will be issued during compilation of the project.

If you wish, you can create the following communication areas:

• PLC Acknowledgement

• OP Acknowledgement

Optional communication areas: Acknowledgement areas for messages

If the PLC is required to send an acknowledgement automatically, create the
following acknowledgement areas in the project window at "Area Pointers".

• "PLC Acknowledgement"
The acknowledgement bit is set by the PLC program and thus causes
acknowledgement of the corresponding alarm message to be displayed on the
operating unit.

• The "PLC Acknowledgement" acknowledgement area
– must be contiguous with the associated alarm message area
– must have the same acquisition cycle as the alarm message area
– must not be longer than the associated alarm message area.

• "OP Acknowledgement"
The operator acknowledges an alarm message on the operating unit and thus
sets the acknowledgement bit of this alarm message on the PLC. When he
does so, the entire acknowledgement area is transferred to the PLC. The "OP
Acknowledgement" acknowledgement area must not be longer than the
associated alarm message area.
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5.9.15 Message procedures:

Message procedures in ProTool

The message procedure identifies the transfer path of messages and thus also the
parameters of the messages.

ProTool supports two message procedures:

• The message bit procedure
This is the default message procedure in ProTool. The operating unit detects
the messages by setting a corresponding bit on the PLC.

• The ALARM_S message number procedure

5.9.15.1 Message bit procedure

Principle

With the message bit procedure, the operating unit detects the arrival, departure or
acknowledgement of a message by setting a bit in the address area, the bit being
assigned by choosing "System" > "Area Pointers" from the menu to the
event/alarm message area.

The setting, resetting and acknowledging of the bit is known as a "message event".

Active (K) The message bit has been set and the message is
waiting to be displayed.

Cleared (G) The message bit has been reset because the cause that
gave rise to the message no longer exists.

Acknowledge (Q) With alarm messages only:

The operator (or the PLC) acknowledges the message to
confirm that note has been taken of the message.

The message events have been acquired by the operating unit and time stamped.

The operating unit automatically enters all message events in the message buffer.
In this way the message events can be viewed at a later time again.
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Communication areas for messages

The display of messages on the operating unit is initiated by the PLC by a bit being
set on it in a defined communication area.

You can see which communication areas for messages have to be created on the
PLC in the following figure:

Displaying messages
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5.9.15.2 Message number procedure ALARM_S

Overview

This chapter gives detailed information on the ALARM_S message number
procedure.

It will show you how ALARM_S differs from the message bit procedure (refer to
"Message bit procedure") and how the system behaves in the event of critical
bottlenecks.

Requirements

You can only configure ALARM_S messages to be displayed on the operating unit
if you are using a SIMATIC S7 PLC and ProTool has been integrated into SIMATIC
STEP 7.

Note

For a SIMATIC PLC, configuration of ALARM_S messages is considerably simpler
if you have installed S7-PDIAG.

What is ALARM_S?

ALARM_S is a message number procedure. The message numbers are issued
automatically during the configuration process in SIMATIC STEP 7. The numbers
are used as the basis for the specific assignment of the correct message text.

When a fault arises, the operating unit receives a message containing the
message number. On the basis of the number, the corresponding message text is
identified and displayed.

The S7 CPU stores not only the status of the message (arrived, departed,
acknowledged) but also the time. This information is not discarded immediately
after the messages have been sent either, so individual network components (for
example, operating units) can log on later and update.

Advantages of ALARM_S

As compared with the message bit procedure, ALARM_S has the following
advantages:

• ALARM_S is an active message procedure. When a message is issued, the
CPU actively notifies all networked units. The operating unit is relieved of the
task of continually polling the message area.

• The process data always precisely reflect the situation at the time of the
message. This cannot be guaranteed with the message bit procedure.

• The time stamp precisely indicates when an event occurred even if the
operating unit is not connected until a later time.
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Display classes

Individual messages can be assigned different display classes in SIMATIC STEP
7. When configuring in ProTool, you then can then choose a specific selection of
display classes for an operating unit. In that way you can distribute the messages
selectively between different display units.

Priorities

You can assign the messages different priorities when configuring ALARM_S
messages as well.

Note

Make sure that you assign messages that can bring about consequential errors a
higher priority than the consequential errors themselves.

Types of ALARM_S messages

With message configuration in SIMATIC STEP 7, there are two types of ALARM_S
messages: alarm messages and event messages.

Note

You can configure in SIMATIC STEP 7 whether an ALARM_S message needs to
be acknowledged or not.

Configuring ALARM_S messages

ALARM_S messages are configured in SIMATIC STEP 7, not in ProTool. The
advantage of this is that the messages are generated system-wide and only have
to be created once.
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5.9.15.3 Display classes

What are display classes?

An S7 CPU always issues ALARM_S messages to all stations that are logged in.
However, it may be that you do not want to display all messages on a particular
operating unit in order to avoid a torrent of messages, for example. In that case,
specific messages could be displayed just on a control desk, for example.

In order to be able to control the display of messages so selectively, in SIMATIC
STEP 7 each message can be assigned what is termed a "display class". In all,
there are 16 display classes (display classes 0 to 15).

Example:

Messages that are to appear on the machine might be assigned display class 1,
those that are to appear on the control desk, display class 2.

The various operating units then only analyze those messages that belong to
specific display classes. Any other ALARM_S messages are immediately
discarded.

Display classes determine which groups of messages are to be displayed on the
OP
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Specifying display classes

The display class to which an ALARM_S message belongs is set when you
configure the message in SIMATIC STEP 7. For a more detailed description of the
procedure please refer to the SIMATIC STEP 7 documentation on message
configuration.

If you do not specify a display class in SIMATIC STEP 7, the message concerned
is automatically assigned to display class 0.

Selecting display classes

In ProTool you must specify which display classes are to be displayed on the
operating unit being configured.

You make your selection by choosing "System" > "Messages" > "Settings" from the
menu. You will find a detailed description in "Setting the message procedure and
selecting the display classes".

If you do not make a selection, all display classes (display classes 0 to 15) are
displayed as the default.
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5.9.15.4 Setting the message procedure and selecting the display classes

Principle

To specify the message procedure(s) you are intending to use, go to the "Message
Settings" dialog box. To access this dialog box, choose "System" > "Messages" >
"Settings" from the menu.

"Message Settings" dialog box

Select the required message procedures from the lower part of the dialog box.
Once you have selected "ALARM_S", you can use the "Alarm_S" button to set the
messages that will be displayed on the operating unit.

Note

If ALARM_S is the only message system you selected in ProTool for a project, the
entries for event messages and alarm messages will no longer be offered in the
ProTool project window.



Release 12/01 Configuration techniques

ProTool User Manual How to configure graphics-based units
A5E00149244 5-69

Selecting display classes

When you click the "Alarm_S" button, the "SIMATIC S7 ALARM_S" dialog box
opens.

"SIMATIC S7 ALARM_S" dialog box

In this dialog box you can set, individually for each PLC on your system, the
messages to be displayed on the operating unit. By default, all messages are sent.

Note

By carefully targeting your selection to specific display classes, you can restrict the
display on the configured operating unit to very specific messages. Other
messages can then be displayed on another device, such as a control desk.

The left-hand column of the dialog box shows you a list of all the PLCs on your
system. For each PLC you can cause the operating unit to display no messages, a
selection of messages or all messages.
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When you click the "Details" button, the "Display Classes" dialog box opens.

"Display Classes" dialog box

Display classes will have been defined when the PLC was being programmed in
SIMATIC STEP 7. At the same time each message will have been assigned to one
or other of these display classes.

You can now select individual display classes and define which messages will be
displayed on the operating unit.
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5.9.15.5 Configuring ALARM_S messages

Configuring messages in SIMATIC STEP 7

ALARM_S messages are configured in SIMATIC STEP 7, not in ProTool, as a
matter of policy. The advantage of this is that blocks of message text can be used
on different display devices but only have to be created once.

When configuring messages in SIMATIC STEP 7, you can either enter simple
unformatted text or make use of the option for device-specific message
configuration. Depending on the display unit in question, you can then specify such
effects as flashing text and define additional information.

The following options are available for configuring ALARM_S messages in
SIMATIC STEP 7:

• Configuration using S7-PDIAG

• Configuration in S7-GRAPH

• Call these via SFC17, SFC18

Note

Graphics display devices do not support tags with text lists which you can
configure in SIMATIC STEP 7 under "Reporting system errors".

You can find detailed reference information about the procedure in online Help for
SIMATIC STEP 7 and in the relevant option packages.
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5.9.15.6 Incorporating ALARM_S messages

Principle

With message configuration in SIMATIC STEP 7, the stored blocks of text and
attributes are placed in a database shared by ProTool. During the process of
compiling the project, ProTool automatically imports the necessary data and
subsequently downloads it to the operating unit.

Configuring and downloading ALARM_S messages

It is therefore important that the shared database is always up to date during the
compilation process and that data synchronization is active. To ensure this, select
the two options "ALARM_S" and "ProAgent" by choosing "File" > "Compile" in the
"Compilation Settings" dialog box.
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5.9.15.7 Updating the operating unit

Principle

Since the S7 CPU stores the message information when a fault occurs, individual
network stations (an OP, for example) can log on at a later date and obtain an
update.

However, the S7 CPU only stores information about pending messages. Once all
events (arrival, departure, acknowledgement) have occurred, the message is
deleted from the CPU.

When obtaining an update, therefore, the operating unit processes any missing
events automatically if a message is not known to the PLC but the arrival and
acknowledgement events are not entered on the operating unit.

The events are not entered in the message buffer in that case, however.

Events processed in this way are identified on the operating unit by displaying the
message status symbols in inverse type thus:

Automatically processed events
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5.9.15.8 Resource consumption of messages

ALARM_S messages

ALARM_S messages are configured in SIMATIC STEP 7. The data is then stored
in a shared database, imported during the process of compiling the ProTool project
and finally downloaded to the operating unit. That means that ALARM_S
messages use up resources on the operating unit.

Economizing on storage space

There are basically two ways in which you can economize on storage space on the
operating unit:

• The following applies to all message procedures: the shorter the message text,
the less storage space will be required.

• To economize on storage space on the operating unit of Windows-based
systems, you can also deselect the SFM" check box in the "Message Settings"
dialog box (choose "System" > "Messages" > "Settings" from the menu).
Messages of this type will then not be transferred by the PLC.

You will find more information in the topic called "System limits". This section
contains information about the memory requirement of projects, on the basis of
which you can assess whether or not the memory of your operating unit is large
enough for the intended project.

Note

In SIMATIC STEP 7 there are restrictions regarding the number and size of tags
that can be used within a message. For more precise details, please consult your
SIMATIC STEP 7 documentation.
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5.9.15.9 Communication sequence in the event of ALARM_S messages

Logging On For ALARM_S

More than one station (for example, more than one OP, PU, etc.) on a network can
log on for ALARM_S messages. Each station that wants to display ALARM_S
messages logs on to the CPU for ALARM_S.

MPI network

The number of nodes that can log on to a CPU for ALARM_S depends on the
CPU. You will find further information on this in the equipment manual for the S7
CPU.

When a message event occurs

When a message-triggering event occurs, the CPU actively sends telegrams to
that effect to all stations that have logged on. The message number identifies the
corresponding message text that has previously been downloaded to the operating
unit.

This means that the CPU does not have to be actively scanned for messages by
regular polling as was the case with the message bit procedure. The operating unit
and network are completely relieved of that burden on the system.

Time stamp

With the ALARM_S procedure, the time stamp is not issued by the operating unit
but by the CPU. The messages are stored in chronological order on the basis of
their time stamp in the message buffer on the operating unit – even if they originate
from different CPUs.

Information stored

The CPU stores not only the time of the message but also the status (active,
cleared, acknowledged) and any process parameters. That information is retained
until a message has been completely processed - in other words, until it has
arrived, departed and been acknowledged. On the operating unit, the information in
the message buffer is kept even longer.
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Restarting the S7 CPU

When S7 CPUs are restarted, it is possible - though dependent on the hardware
configuration of the CPUs - that the CPU will delete all queued ALARM_S
messages.

Note

Earlier versions of S7-300 CPUs cannot report this restart to the operating units
concerned. As a consequence, messages are shown as being queued on the
operating unit even though the CPU has deleted them already.
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5.9.15.10 Acknowledging ALARM_S messages

ALARM_S messages requiring acknowledgement

When a message is acknowledged by a station on the network, the CPU is
immediately notified. The CPU then distributes the acknowledgement to all
connected stations. It is only to this message that the operating unit responds - in
other words, only at this point does it enter the acknowledgement in the message
buffer.

Note

The CPU issues a time stamp for the acknowledgement event but does not store it.
Later, it is no longer possible to determine if and when a message has been
acknowledged.

ALARM_S messages not requiring acknowledgement

Certain ALARM_S messages are configured as alarm messages but do not require
explicit acknowledgement by the user; the CPU acknowledges such a message
automatically when it arrives.

Message overload on the operating unit

In the event of a communication bottleneck in the CPU (multiple arrival and
departure of an ALARM_S message could not be acquired), a message might be
displayed as not acknowledged on the operating unit even though it has been
acknowledged in the CPU already.

The problem occurs only if simultaneously with a message

• A communication bottleneck occurs in the CPU.

• The message in the CPU arrives.

• The message is acknowledged by the operating unit.

The operator must then acknowledge the messages several times on the operating
unit.
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5.9.15.11 Printing ALARM_S messages

Principle

You specify which messages are to be output to a printer in the usual way in
ProTool by choosing "System" >"Messages" > "Settings" from the menu.

Message Logging

If you do not perform device-specific message settings in SIMATIC STEP 7, all
message events will always be logged directly on the attached printer.

If you configure device-specific messages, you can specify separately for each
message whether it is to be logged or not.

Messages are always printed in the order in which they are sent by the CPUs. This
is also the case with every synchronization.

Note

If there are several CPUs in a network, this means that messages need not always
be received in chronological order by the operating unit.
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5.9.16 Examples of configuring messages

These examples show you:

• How to configure an alarm message.

• How to create message areas for different devices.

• How system messages might appear, depending on the operating unit.

• The contents of the export file for event messages.

5.9.16.1 How to configure alarm messages

Objective

You want to set the alarm message area first and configure an alarm message with
a SIMATIC 300 or a SIMATIC 400 PLC.

Procedure

Procedure:

1 Left double-click in the project window on "Area pointers" to create the alarm
message area. The "Area Pointers" dialog box is opened.

2 Here you select the "Alarm Messages" area pointer. Click OK.
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Procedure:

3 The "Alarm Messages" dialog box is opened. Enter the following at "Address":
DB: 10

DW: 2

Length: 2

PLC: PLC_1

You have then created an alarm message area for 32 alarm messages.

4 Confirm all settings by clicking OK.

5 Double-click the Alarm Messages window to open it.

Position the cursor at message No. 2.

6 Enter the following message: Motor temperature too high

7 Set the following in the "Attributes" window:
Priority: 1

Acknowledgement: 7

Print: �

The figure shows the configured alarm message:
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5.9.16.2 "Edit Message" standard screen on the TP 27

Default functions

The following functions have already been implemented on the standard screen
known as "Edit Message"(Z_MESSAGES):

"Edit Message" standard screen

Icon Implementation Name of Function

Open event message window Event Window

Open event buffer Display Messages

Open event message page Display Messages

Delete event buffer Events - Delete Buffer

Print event buffer Print messages

Open alarm buffer Display Messages

Open alarm message page Display Messages
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Icon Implementation Name of Function

Delete alarm buffer Alarms - Delete Buffer

Print Alarms Buffer Print messages
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5.9.16.3 Message areas for SIMATIC S5

Memory on a SIMATIC S5

The message area is defined in memory words - for example:

FW 50
Length 2

5.9.16.4 Message areas for SIMATIC S7

Data words on a SIMATIC S7

The message area is defined in a data block - for example:

DB 70
DBW 0
Length 4
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5.9.16.5 How to move alarm messages to the background

Constraint

Note

These instructions apply to touch panels only in order to ensure that all buttons are
usable.

Purpose

If a large number of alarm messages are queued and you do not want to have
them acknowledged before the machine can be taken from a possibly critical
system state, you can move the alarm message window to the background.

Procedure

Procedure:

1 Touch the ESC button in the alarm message window.

You can now operate the remaining screen objects again.

2 To place the alarm messages in the foreground again, touch the message
indicator.

If a new alarm message is waiting, the alarm message window is similarly
displayed in the foreground.
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5.9.16.6 How to select a printer on the operating unit

Basic procedure

The basic procedure is explained, taking the OP 27 and the standard configuration
OP27.pdb as an example. To do this, create the standard screen as the printer
screen first and then select the corresponding printer.

Creating the standard screen

Procedure:

1 Open the standard configuration available for your operating unit and PLC.

2 Copy standard screen Z_PRINTER to your current project.

3 If you wish to make printed copies, copy standard screen Z_HARDCOPY as
well.

If you wish to use a color printer, copy standard screen Z_COLOR too.

4 If you do use neither Z_HARDCOPY nor Z_COLOR, open screen
Z_PRINTER and modify the screen.

5 Remove the "Select Screen" function, with which you branch to these
screens, from the two function keys "Fx" and "Fy" and delete the two icons.

Selecting a printer on the operating unit

Procedure:

1 Configure an input field on a screen and select "Text" at "Display". A new list
box is displayed.

2 At "Text or graphic list - Text", select the Z_OP_PRINTER list.

3 At Tag, configure a type INTEGER local tag not having a link to the PLC.

4 Confirm your input by clicking OK.

You can now select a printer on the operating unit from the text or graphic list.



Configuration techniques Release 12/01

ProTool User Manual How to configure graphics-based units
5-86 A5E00149244

5.9.16.7 Example of a system message

SIMATIC OP

The system messages of the operating unit are read out.

Some system messages expect confirmation or a decision by the operator - for
example:

557 Save data record?
0 Yes / 1 No

You decide on how you want to proceed by entering 0 (Yes) or 1 (No).
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5.9.16.8 Event messages export file

Structure

Below you can see how the export file of the illustrated event messages is
structured:

SIMATIC ProTool/Pro B5.0.0.20 d 16.06.98 11:31:20

Legend:

:N: = Number

:T: = Text

:I: = Help text

:A: = Attributes

:V: = Tag

:L: = Text lists

Pieces of text may be distributed over several ':T:' lines,

Help text may be distributed over several ':I:' lines.

In message text (:T:), the following control characters are possible:

'\n' = New line

'\b' = Flash (Start/End)

'\u' = Underscore (Start/End)
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'#' or '&' = Placeholders for message tags

The following identifications are used in the attribute line:

Px = Priority x

Ax = Output (port number) x

R+- = Relay ON (+) or OFF(-)

D+- = Print (+) or do not print (-)

:N: 0001

:T: "Tank1 empty:####"

:A: P1 A0 D+ R-

:V: "Z_BAUDR" Dd TO

. . .

:N: 0005

:T: "Mixer full, \n"

:T: "Valves of Tanks 1 to 3 closed"

:A: P1 A0 D- R-
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5.10 Functions

Basic principle

In ProTool you can link "events" (such as "Key pressed") with predefined functions.
If the event occurs during operation, the function executes a specific action on the
operating unit or the PLC.

For example, the "Select Screen" function on the operating unit opens a particular
project screen.

Triggering a function

Areas of application

In general, you can use functions to:

• Set up the project for specific processes (for example, to switch from one
screen to another)

• Control the process (for example, to set a bit in order to switch on a motor with
it)

• Use features of the operating unit (for example, to display or print out the
message buffer)

• Perform system settings online on the operating unit (for example, change
modes)

In most cases you can configure the behavior of the functions precisely by means
of parameters. If you wish to initiate several actions, you can also combine different
functions.
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Configuration

You configure functions on the "Functions" tab in the "Properties" dialog box of the
object in question.

In addition, you can define global entry points (for example, for change of screens,
buffer overflow and change of password) for many operating units by choosing
"System" > "Functions" from the menu.

5.10.1 Events for triggering functions

Necessity

The execution of a function is always linked to a specific event. The function is only
triggered when this event occurs.

The events that can be linked to a function depend on the type of the function.
Many functions are only effective with certain specific events.

Examples of events

Examples of events that can trigger functions are the events "press key" and
"release key". In the case of the former, the function is executed the moment a
particular function key is pressed; in the latter case, it is executed the moment the
function key is released again.

Object-linked functions

Functions and events are generally linked to a specific object. The following
objects can be linked to functions, for example:

• Function keys, soft keys and buttons

• Screen objects

• Screens

• Tags

Functions with tags are triggered only if the tag is displayed on the screen (default)
or "Read Continuously" is selected on the "Options" tab in the Properties dialog
box for the tag.

A function which you have configured for an internal tag (without PLC connection)
whose value is modified by another function is not executed.Functions are
executed only as a result of changes of values triggered by the PLC.

Note

Depending on the operating unit, it might not be possible to configure functions for
all these objects.
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Global functions

You can also link some functions to global, object-independent events - for
example:

• Changing screen

• Buffer overflow

• Change of password

The configurable global events depend on the operating unit:

You will find a detailed description of all the permissible events in online Help
under the keyword "Configurable events".
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5.10.2 Function parameters

Necessity

Many functions can only execute one particular action. For example, the Events
- Delete Buffer function empties the buffer for event messages.

Function without input parameters

However, many functions can also work in various ways.

Input parameters

Imagine that you want to open another screen using a key on the operating unit. To
do this, you configure the Select Screen function. However, your project will
generally have several screens. Which of these screens should ProTool open?

You therefore have to give the function more information. This is done using
parameters. For the Select Screen function, you specify as a parameter the
name of the screen to be opened, for example.

Another example is the Language function. In this case, the parameter you specify
is the language to be set.

Function with input parameters

Some functions require a single parameter; others require several.
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Output parameters

Some functions write the result of their execution (i.e. the current status) to a tag.
You can then further evaluate the value of this tag, for example in order to display
a setting-dependent text on the operating unit.

An example is the Mode function. You specify a code for the operating mode as the
input parameter, and the function supplies the same code in a tag as the output
value. The value of the tag lets you display the current operating mode by means
of a text list, for example.

Note

Output parameters cannot be configured for all operating units.

Function with input and output parameters

Special case: program-controlled behavior

In the case described above, the behavior of the functions does not change at run
time. However, in the case of some operating units and some functions, you can
also pass the value of a tag as an input parameter. The behavior of the function
can thus be controlled by the program.

General principle

The following figure illustrates the principle of how a function works:

How a function works

An input parameter is specified for the function. This can be either constant or read
from a tag. The tag may be local or it may have a connection to the PLC. If there is
a connection to the PLC, the value is set by the process. The result of the function
is written to a tag, which itself can either be local or have a connection to the PLC.
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5.10.3 Combining multiple functions

Multiple functions with one object

You can also assign an event several functions. The functions are then initiated
one after the other. You set the order in which this occurs in the "Functions" dialog
box during configuration. You can change the order of the functions by using the
"Up" and "Down" buttons.

Multiple functions with one object

Note

If the list of functions also contains functions which expect an input ("... Do you
want to delete, Yes/No"), they are enabled only if no other functions waiting for an
input are active.
A check is made repeatedly for every event to determine whether functions that are
waiting for an input are still active. If this is the case, processing of the list of
functions is discontinued and a message is issued as follows: "Function temporarily
unavailable".

Example

The functions Set Bit when Key is Pressed (event: press key and release key) and
Alarms - Delete Buffer (event: press key) are configured in this order on a key.

When the key is pressed, the bit is set first, and this is followed by the function
Alarms - Delete Buffer being triggered. When the key is released, the
system detects that the function Alarms - Delete Buffer is still active,
because it is waiting for an input from the operator: "... Do you want to delete,
Yes/No". It refuses to continue processing the function list and the bit cannot be
reset.

Remedy

To avoid this reaction, configure the function Alarms - Delete Buffer for the
event release key. As a result, with press key only the Set Bit when Key
is Pressed function is triggered. With release key, the list of functions is
processed, since no input is expected.
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5.10.4 Buttons with fixed functions

Default buttons in ProTool

When you configure a touch panel, ProTool offers a selection of different buttons
that are already assigned frequently used functions:

• Set/Reset Bit and Set/Reset Bit in Word

• Select Screen

• Light Indicator

You will find detailed information on this in "Buttons".

Note

Instead of using these buttons, you can use a normal button and configure the
function you require manually.
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5.10.5 Displaying date and time

Principle

The date and time are displayed and changed using functions on the operating
unit. There is a function available for Date Display/Edit and a function for Time
Display/Edit in each case.

Configure these functions with tags that do not have a connection to the PLC. You
can only use one tag to which the date or time are linked in each project. If you use
more than one tag for this, they are not updated when the date and time are set or
changed.

Weekday

You can set the current date and time in a standard screen on the operating unit. In
contrast, you can only set and read the day of the week by means of PLC job no.
15. Before it is read for the first time, the day of the week must be set by means of
a PLC job.

You will find a complete list of PLC jobs in "PLC jobs".
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5.10.6 Example of configuring a function

This example shows you how to configure the "Mode" function with parameters so
that "Online" and "Offline" modes can be set with function keys. In addition, the
result of the operation will appear on the operating unit.

5.10.6.1 How to change the operating mode with a current display

Objective

The following example using the Mode function illustrates how you configure
functions with parameters. You also see how the result appears on the operating
unit.

You want to set the Online and Offline operating modes by means of two
function keys. You want the text Online Mode and Offline Modes to appear
on the operating unit.

Configure the functions

Procedure:

1 Create and open the screen in which the switchover and display take place.

2 Click the function key that you want to use to enable the Online operating
mode.

The "Function Key" dialog box appears.

3 Select the "Functions" tab.

4 Select the "Display Selectable Functions" check box to open the "Select
Object" window.

5 Select the Mode function in the "Toggle" function group.
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Procedure:

6 Click the "Add" button.

The "Parameters" dialog box appears.

7 Select the Operating Mode (Key) parameter from the list, and enter the
value 0 in the input field under the list.

This parameter controls the behavior of the "Mode" function, so the mode
changes to Online mode.

8 Select the Operating Mode (Field) parameter from the list.

Here you specify a tag to which ProTool assigns the value of the current
operating mode at run time (0 for Online mode, 1 for Offline mode).

This tag subsequently controls the display.

9 Click the arrow pointing to the right under the list, and choose the "New"
menu command from the shortcut menu that appears.

The "Tag" dialog box appears.

10 Configure the following values for the tag:

Name: Operating Mode

PLC: <No PLC>

Type: INT

Decimal places: 0

11 Click OK to close the "Tag" and "Parameters" dialog boxes.

The function then appears in the "Selected Functions" list.

12 Click OK to close the "Function Key" dialog box.

Your configuration of the function for enabling the Online operating mode is
thus complete.
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Procedure:

13 Right-click the function key and select "Copy".

This copies the properties of the function key you have just configured.

14 Using the shortcut menu, paste the copied function key properties to the
second function key.

15 Click the second function key and, in the Parameters dialog box of the
"Operating Mode" parameter, change the value to 1.

For the second parameter, select the tag created for the first function in step
10: Operating Mode.

In the next step you create an output field whose contents change dynamically
depending on the Operating mode tag. The user can thus read on the operating
unit at any time which operating mode is currently set.

Configure the display

Procedure:

1 Insert an input/output field in the screen.

The "Input/Output Field" dialog box appears.

2 Perform the following settings on the "General" tab:

Usage: Tag

Field type: Output

Representation: Text

3 At "Tag", select the previously configured Operating Mode tag.

4 Click the arrow pointing to the right under "Text or Graphic List", and choose
the "New" menu command from the shortcut menu that appears.

The "Text or Graphic List" dialog box appears.
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Procedure:

5 Call the text or graphic list status and create a text or graphic list with the
data:

Type: Decimal

Value: 0 Text: Online mode

Value: 1 Text: Offline mode

6 Click OK to exit all the dialog boxes.

Result

At run time, the operator can use the two configured function keys to set the
operating mode and read the current operating mode on the display.
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5.10.6.2 How to display and change the date on the operating unit

Objective

You will find below an example of how the date can be displayed and changed on
the operating unit. To do this, you create an input/output field in a screen. You
configure the Date Display/Edit function for the tag of the field.

Procedure

Procedure:

1 Create an input/output field.

The "Input/Output Field" dialog box appears.

2 Select "Input/Output" at "Field Type".

3 Select "String" at "Representation".

4 Specify 10 for the "field length" (MM.DD.YYYY for the date format).

5 Create a new tag by clicking the button with the arrow pointing to the right at
"Tag".

6 Choose the "New" option from the shortcut menu that appears.

The "Tag" dialog box appears.
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Procedure:

7 Set:

"Name": Date

"PLC": <No PLC>

"Type": STRING

"Length": 10

8 Select the "Functions" tab.

9 Select, if appropriate, the "Display Selectable Functions" check box.

10 In the Select Function window, select the Date Display/Edit function at
"Date/Time".

11 Click "<< Add" to transfer the selection to the list of "selected functions".

12 Exit all open dialog boxes by clicking OK.

The date is then displayed in this field on the operating unit during operation
and can be edited.

Note

If you want to display the date in another field, you use the Date tag for this as
well.
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5.11 Recipes

Purpose

The purpose of recipes is to transfer a group of related data to the PLC, as a whole
and synchronously.

Recipe and data record

The terms "recipe" and "data record" are defined below using the example of a
bottling plant for a fruit juice system:

Recipe and data record illustrated by analogy with a filing cabinet

• "Recipe"
Recipes correspond to the drawers of the filing cabinet in the figure (for
example, Orange or Lemon). The reference value fields (tags) that belong to
the recipe are defined in the recipe. You use the recipe to define the data
structure in your ProTool project. You cannot change this structure
subsequently on the operating unit. You can configure up to 255 recipes in
ProTool.

• "Data record"
Data records correspond to the filing cards in the drawers of the cabinet (Drink,
Juice and Nectar). A data record contains the values for a recipe. You create,
delete and modify data records on the operating unit. You can create up to 500
data records for a recipe.
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Example of a recipe

The filling station above is used to produce orange drink, orange juice and orange
nectar. The mixing proportions for each of these are different. The ingredients are
always the same.

Let us assume that a recipe called "Mixture" is created, containing the following
data structure:

Tag Designation

Var_23 Name

Var_11 l orange

Var_7 l water

Var_19 kg sugar

Var_21 g flavor

The tag designations Name, l orange, g flavor etc. are known as "entry
names". The entry names are displayed as well on the operating unit. Tag Var_11,
for example, can thus be identified as the tag designating the mixture ingredient
orange.

The data records contain the values for the different drink types. The data records
could be as follows, for example:

Data record
name

Orange drink
value

Orange juice
value

Orange nectar value

Name "Drink" "Juice" "Nectar"

l orange "90" "95" "70"

l water "10" "5" "30"

kg sugar "1,5" "0,5" "1,5"

g flavor "200" "100" "400"

Same tags in screens and the recipe

For each ingredient (orange, water, etc.) there is a separate screen in the above
example, containing a supply tank, valves, an overview of the quantities used and
other information. The screens contain input fields that allow you to set the various
supply quantities for the mixer. You can thus enter the mixing proportions screen
by screen. The mixer is then started. This process is repeated for each drink type.

If the tags of the input fields are formed into a recipe, you can store finished
mixtures for the different drink types by creating data records on the operating unit.
The figure below shows how to use the same tags in screens and in the recipe.
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To produce a specific drink type, the corresponding data record is transferred to
the PLC. All tags are thus assigned the required values at the same time.

Same tags in screens and the recipe

Note

If you use a tag in a recipe that is also assigned to an output field in the screen, the
PLC may overwrite the current value.
This situation occurs, for example, when data records are transferred from the data
medium to the PLC. The tags are updated in the operating unit, and the values are
then transferred to the PLC. In the meantime, however, the PLC could have
updated the output field tag. In this case, the value of the PLC is transferred, not
the value of the data record.
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5.11.1 Configuring a recipe

Identifying a recipe on the operating unit

You create a recipe in your project with a symbolic name. You also use this
symbolic name to select the recipe on the operating unit. The recipe also receives
a number, but this is only valid during configuration.

You can change the recipe's name and number. In the project window, open the
"Recipe" dialog box by double-clicking, and then click the "Properties" button.

Identifying the recipe on the PLC

Three identifiers are available for identifying recipes on the PLC. You enter the
identifiers on the "Options" tab in the "Recipe" dialog box. The identifiers are user-
definable. ProTool automatically enters the number of the recipe in the first
identifier. The identifiers are written to the data mailbox when a data record is
transferred from the operating unit to the PLC and can be evaluated by the PLC.

Identifying a data record

You create a data record on the operating unit with a symbolic name. This name is
only relevant on the operating unit. When a data record is transferred, only the data
and the identifiers of the recipe are transferred. Apart from the identification of the
recipe, the PLC has no special way of identifying the data record. If you want to
identify the data record on the PLC, you create in the recipe a tag that contains the
name of the data record.

Tags in recipes

Tags that you use in recipes must have an address on the PLC and the Write
Directly attribute. Only these tags will be transferred to the PLC when a data
record is transferred. Tags without an address are not transferred. You set the
attributes in the "Tag" dialog box on the "Options" tab.

There is no point in using the tag types Timer and Counter in recipes.

Standard screens for recipes

The standard screens Z_RECORD_1 and Z_RECORD_2 are available so that you
can create, save and transfer data records on the operating unit. These screens
exist in the standard project but are not yet integrated. Integrate the standard
screens in your project by assigning the "Select Screen" function to a function key,
for example. Specify the standard screen Z_RECORD_1 or Z_RECORD_2 as a
parameter. If you want to use both standard screens, assign each one to a function
key.

You only need the Z_RECORD_2 standard screen if you want to transfer current
data directly between the operating unit and the PLC.
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Text or graphic list for recipes

When you create the first recipe, a text or graphic list with the designation
Z_RECIPES is created automatically. This text or graphic list is used in the
supplied standard screens for data records. The sequence in which the recipes are
entered in the text or graphic list is determined by the recipe number or the recipe
name. You also see this sequence on the operating unit when you select a recipe.

Data mailbox

To transfer data records, you must set up a data mailbox on the PLC and set it in
your project, in the project window, at "Area Pointers". The operating unit writes the
identifiers and the length of the data record to the data mailbox. The data mailbox
must therefore be at least five words long. The figure below shows its structure.

Structure of the data mailbox

Defining the structure of a recipe

When you have completed your project, you should define the structure of the
recipe. To do this, click the "Properties" button in the "Recipe" dialog box. When
you define the structure, you write-protect the recipe. This imposes restrictions on
the changes you can make to the structure. Tags can still be deleted, but this
leaves gaps in the structure. You can only add new tags at the end of the structure.

If you define the structure of the recipe, you can continue to use data records that
you created on the operating unit.

Using symbols

If you also save the symbolic names of the tags in the data record when you create
data records, you can still load data records on the operating unit after a change to
the recipe structure. To do this, click the "Properties" button in the "Recipe" dialog
box and select the "Use symbols" check box.

Note

If you have selected the "Use symbols" check box in your recipe, the tag names
must not be more than 12 characters long for reasons associated with the system.
Tag names that are too long have to be adjusted accordingly.

If you do not select the "Use symbols" check box, only the values are saved. The
symbolic names of the tags are not saved in the data record. If the recipe structure
is changed subsequently, values are interpreted incorrectly.
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5.11.2 Transferring data records

What you must bear in mind

Note

When data records are transferred from the data medium to the PLC, the data is
initially written to the tags in the working memory of the operating unit. From there
it is written to the PLC. If you have configured the Read Continuously attribute
for the tags to be transferred, or if the tags are configured as actual values in the
current screen, it may be possible for the tags to be overwritten with current values.
In this case, it is not the data read that has been read that is transferred from the
data medium to the PLC; instead, is the data that has been updated in the
meantime.

How to create data records and transfer them to the PLC is described in detail in
the manual of your operating unit.

Transferring data records when working on the operating unit (standard case)

The transfer of data records from the operating unit to the PLC and vice versa is
the standard case. The special cases are described in the "Communication User's
Manual". We recommend that you only transfer data records by using the operating
unit. To do this, use the standard screen Z_RECORD_1.

Setting the transfer mode

The selection of the transfer mode depends on the operating unit and the PLC
used:

• Direct transfer: When a data record is written, the data record tags are written
directly to the defined addresses. In direct reading, the tags are transferred
from the system memory of the PLC to the operating unit.

• Indirect transfer: All the tags of the data record are written to the PLC's
Clipboard. Set the direct transfer mode.

Creating data records

Data records can only be created on the operating unit and saved on a data
medium there. The data medium that can be used depends on the operating unit.
The standard screen Z_RECORD_1 uses the Z_MEMORY text or graphic list, which
contains the assignment of data medium and value:
0: FLASH
1: Module
2: Floppy disk
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Synchronization during transfer

An essential feature of recipes is that the data are transferred with synchronization
and uncontrolled overwriting of the data is thus prevented. In order to ensure
coordinated operation when data records are transferred, bits are set in the control
and acknowledgment area of the interface area.

The interface area for the SIMATIC PLCs is described in the "Communication
User's Manual". For non-SIMATIC PLCs, the interface area is described in
"Communication areas for non-SIMATIC PLCs".

Transferring data records by means of a PLC program

PLC job

You can transfer data records from the PLC to the operating unit and the other way
round by means of PLC jobs "69" and "70". However, the PLC job only writes to the
tags or reads from them. The data record cannot be saved on the data medium or
read from the data medium directly using a PLC job. You have to use the operating
unit for this.

Function

ProTool offers functions for:

• Reading data records from the PLC and saving them to a data medium on the
operating unit

• Reading data records from the data medium and transferring them to the PLC

Assign a function like this to a tag. The parameters of the function contain recipe
names and data record names. Assign the parameters of the function initially from
the PLC. If the value of the tag is changed by the PLC, the function is triggered.
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5.12 Prompting the operator

Purpose

In addition to the option of customizing the user interface of your operating unit to
make it easier for you to use, ProTool features other options for supporting and
prompting you on your operating unit as a function of the situation. This means you
can implement mechanisms and decision-making aids that can prevent possible
incorrect operations on the operating unit.

ProTool makes the following methods available for the implementation of operator
prompting:

• Providing Help text

• Assigning icons to local function keys

• Hiding screen objects

• Assigning dynamic attributes

• Evaluating key operation

• Driving light-emitting diodes

• Assigning operator authorization
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5.12.1 Help information on the operating unit

Purpose

Help text provides additional information and operator instructions on screens,
input and output fields, and buttons and messages to the operator at run time. Help
text provides additional information that can be defined for screens, input/output
fields, buttons and messages when configuring with ProTool. For example, Help
text may be in the form of the permissible range of values for an input field or the
cause and elimination of a malfunction in the case of an alarm message. Help text
is displayed on the operating unit in the language you set.

You configure Help text on the "Help Text" tab in the "Properties" dialog box of the
object in question.

In addition to Help text, you can configure tooltips, which are displayed at run time,
for some devices and screen objects.

Displaying Help text on the operating unit

• Operator Panels
The availability of Help text is indicated on the operating unit by the lit "HELP"
LED. On touch panels, the "HELP" button is displayed. The configured Help
text can be output by pressing the "HELP" key.

• Detailed information about activating Help texts is given in the equipment
manual for your operating unit.

5.12.2 Icons for local function keys

Purpose

Icons are fixed-size pixel graphics that are placed in the immediate vicinity of
screen-specific function keys (soft keys). This means that you can illustrate the
function of a locally assigned function key. Icons can only be assigned to soft keys
that border on the screen of the operating unit.

You can prevent incorrect operation of a key to a large extent by means of an
informative icon.
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5.12.3 Showing and hiding objects

Purpose

ProTool features an option of displaying and hiding controls and display elements
at run time. For example, you can hide an output field on the operating unit when
the actual value is within the specified setpoint range.

Alternatively, display an input field only when an operator input is expected for the
control in a specific situation for example, during startup. The user interface of your
operating unit remains neat and tidy in this manner.

Index tag

You can either link display and hiding to a constant range of values or to the tag of
an input/output field, for instance. You can influence several input/output fields
simultaneously by using a separate tag.

If you use a tag with PLC connection to enable and disable, you can activate
certain project versions for different operating units from the PLC.

5.12.4 Dynamic attributes

Purpose

To draw the operator's attention on the operating unit to specific situations for
example, specified limit values have been reached or exceeded you can configure
attributes for input and output elements. This means that you can dynamically
modify the foreground and background colors, for example, of an input/output field
at run time as a function of the value of a tag, or you can enable or disable flashing
for the text that is being displayed.

Index tag

You can either link the specified attributed directly to the tag of an input/output
field, for instance, or you can define a separate index tag for it. You can influence
several input/output fields simultaneously with a separate index tag.
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5.12.5 Evaluating key operation

Purpose

Keystrokes executed on the operating unit can be transferred to and evaluated by
the PLC. This means, for example, that you can issue a message that will draw the
operator's attention to the incorrect operation of a key.

Requirements

For the PLC to be able to evaluate whether and, possibly, which key has been
operated on the operating unit, you have to create specific data areas on the PLC
and specify them in your project, in the project window, at "Area Pointers". These
are the two data areas "system keyboard assignment" and "function keyboard
assignment", depending on which keys you wish to evaluate. You set the
assignment of the function keys to the bits in the function keyboard assignment
when you configure the function keys.

You will find a description of the keyboard assignments for the different operating
units in the "Communication User's Manual".

You will find more information on communication by your operating unit with a non-
SIMATIC PLC in "Keyboard assignment of the operating unit".

5.12.6 Light-emitting diodes on the operating unit

Purpose

The light-emitting diodes (LEDs) on the function keys of the operator panel can be
driven on the PLC. By means of a light-emitting or flashing LED, you can indicate
to the operator that, for example, the device is expecting a certain function key to
be operated.

Requirements

For the PLC to be able to drive the LEDs, you have to create the "LED assignment"
data area on the PLC and specify it in your project, in your project window, at "Area
pointers". Set the assignment of the individual LEDs to the bits in the LED
assignment when you configure the function keys.

You will find a description of the LED assignment and the LED functions for the
different operating units in the "Communication User's Manual".

You will find more information on communication by your operating unit with a non-
SIMATIC PLC in "LED assignment of the operating unit".
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5.12.7 Assigning operator permissions

Purpose

ProTool allows you to use a password to prevent controls such as input fields and
function keys from being used by those unauthorized to do so. This means that
when you are creating your project you can restrict the use of functions that relate
to security to specific people or groups of operators. Important parameters and
settings can thus only be changed by authorized personnel.

The access protection that you configure allows you to guard against incorrect
usage and increase the security of the system or machine.

Password hierarchy

During the configuration phase you can assign operator authorization to specific
groups. At run time, individuals can be allocated to one of these groups, as
appropriate, and they thus automatically receive the access rights of that group.

ProTool provides hierarchically organized password levels from level 0 to 9. If a
user is assigned password level 4, for example, this user is authorized to execute
the functions of password levels 0 to 4.

• Password level 0
Password level 0 is the default in ProTool. Use this lowest level in the
hierarchy for functions that have little or no effect on the operational sequence.
These are generally functions that do not required any input, such as the
display of messages. You do not have to enter a password on the operating
unit in order to execute functions with password level 0.

• Password levels 1 to 8
Assign functions to password levels 1 to 8 according to their importance.
Before you execute these functions, the operating unit prompts you to enter a
password.

• Password level 9
The authorization to execute functions at password level 9 is granted only to
the system administrator or service engineer. He has access to all the
functions of the operating unit.

You define the password of the system administrator by choosing "System" >
"Settings" from the menu. The default setting is 100. You can modify this setting on
the operating unit at run time.

You can find more information on password administration in the "equipment
manual" for your operating unit.
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Logging into and out of the operating unit

• When you call a password-protected operation, the operating unit automatically
prompts you to enter an appropriate password. In order to eliminate the
possibility of unauthorized persons gaining access, a password level greater
than 0 should not remain active on the operating unit for any length of time.

• If you do not do anything on the operating unit for a configured period of time
(logout time), the operating unit automatically resets the current password level
to 0. You set the logout time by choosing "System" > "Settings" from the menu.
The system default setting is 5 minutes.

Note

Irrespective of operating a password-protected control, you can log on or off at any
time by configuring the Logon_User or Logoff_User functions.

Setting the password level on the operating unit

The following PLC jobs are available for setting a defined password level on the
operating unit:

• You can use PLC job 23 to set a password level of your choice on the
operating unit from the PLC in order to allow access by a defined user group,
for example.

• You can use PLC job 24 to reset the password level back to 0 from the PLC.

You will find a list of all possible PLC jobs with job numbers and parameters in PLC
jobs in alphabetical order and PLC jobs in numerical order.
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5.13 Configuring in foreign languages

This chapter shows you what you need to know in order to create a project with a
user interface in a foreign language.

You can create a monolingual or a multilingual project. In a multilingual project you
can decide:

• Whether to make several languages available on an OP and provide the user
with a key for switching between them.

• Whether to download only one language to a specific OP.

5.13.1 System requirements for foreign languages

Principle

Depending on your Windows language, you can configure nearly all foreign
languages without having to perform changes to you Windows configuration.

The exceptions are languages with special fonts such as Greek, Polish, Russian,
Slovenian, Czech and Hungarian. To use these languages, you must enable
language support in Windows 98 ("Clipboard" > "Software" > "Windows Setup" >
"Language Support" > "Details"). This is not necessary in Windows NT.

Alternatively, you can install Windows completely in one of these languages.

Note

The ProTool installation CD-ROM contains support for other languages not
supplied as standard with Windows such as Albanian, Bulgarian, Romanian,
Turkish, etc. in the directory WINLANGS. More detailed information is provided in
the file MULLANGO.INF.

To create projects in Asian languages, you require an Asian Windows system. You
will find detailed information in "Requirements for configuring in Asian Languages".
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5.13.2 Languages in ProTool

User interface language and project languages

ProTool makes a distinction between two language levels:

• The "user interface language" in ProTool
This is the language in which the menu and dialog box text blocks are
displayed when you configure in ProTool/Pro CS. The user interface language
is selected from ProTool's Setup.

• The "project languages"
These are the languages in which the blocks of text in your project appear on
the operating unit. You can create the project in any language available in
Windows on the configuration computer.

The two language levels are completely independent of each other. For example,
you can create French projects with an English ProTool, or English projects with a
French ProTool.

Multi-lingual projects

If you want your project to run in different languages, store all language-dependent
objects in the desired languages in the project. This applies, for example, to:

• Event messages

• Alarm messages

• Screens

• Recipes

• Text lists

• Help texts

• Reports

You can store text for any project in as many project languages as you like. When
creating your configuration, however, note that the languages supported at run
time depend on the operating unit.

You cannot edit system messages in ProTool. They have been stored for every
operating unit for a number of languages already. If you are configuring a language
for which no system messages are available, all the system messages will appear
in English.

Editing language

The project language in which you edit text at any given time on the configuration
computer is the "editing language".

The toolbar and the status bar show the current editing language setting.
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Reference language

One of the project languages can be used as the "reference language". You can
first create all the blocks of text in the Reference language and then use them as a
basis for other translations when you enter your translated text directly into the
project.

When you are configuring, you can toggle between the reference language and the
editing language you have set.

Online languages on the operating unit

You can even download several of these project languages simultaneously to the
operating unit, depending on the operating unit. For the operator to be able to
toggle between these languages, you must provide him with a suitable control.

When creating your configuration, note that the languages supported at run time
depend on the operating unit.

Language levels in ProTool

Exchanging text with translators

If you wish to send the blocks of text in the reference language for translation, you
can export all blocks of text in a project from ProTool. The translator can edit the
blocks of text outside ProTool, either in Excel, for example, or a text editor. The
translated blocks of text are then imported into your ProTool project and
automatically inserted at the correct places.
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5.13.3 Languages of standard projects and system messages

Standard projects

The following languages are supplied in the standard projects supplied as part of
the package:

• German

• English

• French

• Italian

• Spanish

• Chinese (PRC)

• Chinese (Taiwan)

• Korean

• Japanese

Should you wish to configure another language, you have to add it yourself and
also translate the pieces of text in the standard projects.

System messages

You cannot edit system messages in ProTool. They have been stored for every
operating unit for a number of languages already. If you are configuring a language
for which no system messages are available, all the system messages will appear
in English.

System messages for your operating unit are available in the following languages:

• Chinese (PRC)

• Chinese (Taiwan)

• Danish

• German

• English

• Finnish

• Flemish

• French

• Greek

• Italian

• Korean

• Norwegian

• Polish
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• Portuguese

• Russian

• Swedish

• Spanish

• Czech

• Turkish

• Hungarian

When you configure another language, all the system messages appear in English.
You cannot edit system messages in ProTool.
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5.13.4 Language dependent fonts

Fonts available in ProTool

In ProTool, at "System" > "Fonts", you can select four different fonts, which are
available to you on each screen:

• One language independent font.

• Three language dependent fonts

Setting fonts

The "language independent font" is available in all languages. The language
independent font is the default symbol. The symbol set is used for character
graphics.

The fonts have to be a fixed-pitch font. This means that each letter is the same
width. A letter "i" requires just as much space as an "m".

The "language dependent fonts" can vary from language to language. This is
always necessary when certain language dependent special characters are not
contained in the ANSI code.

The language dependent fonts change automatically:

• When you change the editing language in ProTool.

• When the operator changes from one language to another on the operating
unit.
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5.13.5 Language dependent keyboard assignment

Language dependence

The characters on a PC keyboard are language dependent. For example, no
German or French special characters are available on an English keyboard.
Further, the letters are arranged somewhat differently.

As soon as you change the editing language in ProTool, it modifies the assignment
of your keyboard to the layout of the foreign language concerned.

On-screen keyboard

In order to facilitate the assignment of the characters printed on your keyboard and
those actually entered, ProTool displays a language-dependent on-screen
keyboard. You can see on the on-screen keyboard where the deviating characters
are located.

There are two options to choose from for entering a language-specific character:

• Orientate yourself on the on-screen keyboard and enter the character on the
keyboard of the configuration computer.

• Click your mouse to enter the character directly via the on-screen keyboard.

Example of language-dependent on-screen keyboard with French as the editing
language

The on-screen keyboard is hidden automatically as soon as you reset the editing
language back to the current Windows language. You can also enable and disable
display of the on-screen keyboard by choosing "View" > "Keyboard".

Note

You can only use the on-screen keyboard if the corresponding keyboard layout has
been installed under Windows. Enable the keyboard at "Start" > "Settings" >
"Control Panel" > "Keyboard". If you have not done it, ProTool will resort to the
international (US) layout.
For entering Asian characters,
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5.13.6 Reference text

Principle

When you create a project for several languages, you normally configure all the
pieces of text in your native tongue first.

If you then change the editing language to enter text in a foreign language, all the
text fields appear blank again.

ProTool features a user-friendly reference text function so that you have a basis for
your translations. In dialog boxes and in screen editors, you can display an
additional window with blocks of reference text in the original language.

Reference text

In the editor you can insert the translation of the blocks of text in the reference
window text without having to switch from one language to another.

Note

Text can be exported by choosing "Edit" > "Language" > "Export" from the menu or
by using the shortcut menu in the project window. The blocks of text can be
translated independently of ProTool in this way, too, and then imported in your
project.



Configuration techniques Release 12/01

ProTool User Manual How to configure graphics-based units
5-124 A5E00149244

5.13.7 Steps to creating a multilingual project

Scenarios

The basic approach is identical no matter whether:

• You configure a project in a language other than that of your ProTool
installation. (Example: you have ProTool in German and would like to create a
French project.)

• You want to sell a project to several countries, in the language of the countries
concerned. (Example: you are sending a machine to Germany, England and
France. You want all pieces of text to be displayed on the operating unit in the
language of the countries concerned.)

• You supply a project to a multilingual country. (Example: you are selling a
machine to Switzerland. You want the operator to be able to choose between
German, French and Italian on the operating unit.)

In any case, you should always attempt to create and test the project in one
language first. This language then acts as your reference language for the
translations.

Steps

Configuring in foreign languages consists of the following specific work steps:

1. Satisfy the necessary system requirements.

2. Define the configured languages (choose "Edit" > "Language" > "Select" from
the menu).

3. Select a language as the first editing language (choose "Edit" > "Language" >
"Select" from the menu). Create and test the complete project in this language
first, before proceeding to translate all the pieces of text together later.

4. Set the font (choose "System" > "Fonts" from the menu).

5. Configure a language switch (only if you want to offer several languages
simultaneously on one operating unit).

6. Translate the pieces of text. If you want to enter blocks of text in a foreign
language, switch the "editing language" (choose "Edit" > "Language" > "Select"
from the menu). You select the language in which you have created the project
to be your "reference language" (likewise option "Edit" > "Language" >
"Select"). You can now have reference language text displayed and enter the
text in the editing language.
If you want to send text for translation, you can export it in csv format (choose
"Edit" > "Language" > "Export" on the menu). After being translated external to
ProTool, you can accept them into your project (choose "Edit" > "Language" >
"Import" from the menu).

7. Select the languages to be downloaded to a specific operating unit (choose
"System" > "Language Assignment" from the menu). You can select up to
three languages simultaneously.
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8. Compile the project.

9. Download the project to the operating unit.

Note

Avoid moving fields in event messages and alarm messages when you modify a
project that has been created in several languages. Since there is no permanent
assignment between the field and its position within the text, you should move the
pieces of text – if necessary – instead of the fields.
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5.13.8 Exchanging text with translators

Editing blocks of text external to ProTool

If you configure a project in several languages, the simplest approach is to create
and test the complete project in one language first.

You can then pass all the blocks of text to translation and, after that, include the
translated text in your project.

The advantages of this procedure are as follows:

• The workload of the configuration engineer is reduced, since he only has to
create the user interface in a language familiar to him.

• The translator can edit the blocks of text outside ProTool, either in Excel or a
text editor.

• The translated blocks of text will be complete and consistent.

Scope of text export/import

Using the ProTool's text export/import function, you can export and import blocks of
text for the whole project, text from specific editors or text of separate objects. The
scope of export/import depends on the command:

• Export/import blocks of text for the complete project.
When you issue a command to export/import text by choosing "Edit" >
"Language" > "Export" or "Import" on the menu, all blocks of text for the
complete project are exported or imported. The import operation cannot be
undone. But you can remove all blocks of text in a language from the project by
deleting that language. You will find detailed information by referring to
"Deleting a project language".

• Export/import blocks of text of a certain editor or object.
You can start exporting/importing text in the project window by means of the
shortcut menu (right-click) of the editors and objects. Only those blocks of text
can be exported or imported that belong to the selected editor or object. A text
import operation started from the shortcut menu can be undone.

Exporting different text types

When exporting, you can select the types of text you would like to export:

• Text visible on the screen (such as labeling, names)
It is stored in the file called "Labeling.csv".

• Info text (such as Help text for screen objects and messages)
It is stored in the file called "InfoHelptext.csv".

• Message text (event messages and alarm messages)
It is stored in the file called "MessageText.csv".

• Other text (message settings, text lists)
It is stored in the file called "MiscText.csv".
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The default setting is export of all text types.

The classification of the text types is done in accordance with the requirements that
have to be taken into account in translation. For example, the placeholders have to
be preserved in message text, and when text visible on the screen is translated it
might be necessary to take the limited

Importing text

You can insert translated blocks of text in your project by choosing "Edit" >
"Language" > "Import" or by using the shortcut menu of the editors and objects in
the project window. The individual blocks of text are automatically assigned to the
objects in the project.

Note

You can undo an import of alarm message text.

To view imported text in foreign languages, set the editing language to the
language concerned.

• If you did not specify a target language for the translation when you exported
the text, you must specify the language into which the text was translated when
you import it.

• If this language is not available as a "configured language" in your project, it is
created automatically.

Note

Remember not to change or add text manually in the time between exporting and
importing the text but to have these changes translated in good time. Manually
changed or added text will be overwritten by the text in the import file on being
imported.
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5.13.9 Requirements for configuring in Asian languages

Asian Windows system

A requirement for creating a project with Asian blocks of text is an Asian Windows
system or Windows 2000 multilingual as the operating system. The necessary
character sets can only be accessed in these Windows systems.

To assist you with entering Asian characters, the "Input Method Editor" (IME) is
available on such systems, and you can use it to define text as phonetic
transliterations, for example. ProTool's on-screen keyboard is therefore not made
available.

Even the compilation must be carried out on an Asian Windows system, otherwise
the project language will be ignored during compilation.

Under certain conditions, it is possible to download projects in which an Asian
project language has been selected, on a non-Asiatic Windows system.

For this, the *.fud or *.fwd file created during compilation on an Asian Windows
system has to be available in the same directory as the *.pdb project file. The
*.pdb project file can only be opened before the download operation, but not
modified any more.

Note

Many projects are multilingual and use, for example, English in addition to an Asian
language. In such cases you can first create and test your project on a non-Asiatic
Windows system. Not until it is completed do you change to an Asiatic system, on
which you configure and compile the Asiatic text and perform the download
operation.

You can work most efficiently if you have both an Asian and a non-Asian Windows
system installed on your computer or if you work on a network with different
computers for the languages concerned.
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5.13.10 Constraints on projects in Asian languages

Supported languages

Chinese (PRC), Chinese (Taiwan), Korean and Japanese are the languages
currently supported.

Configuration memory

Use different character sets as sparingly as possible in a project. Every character
set you use reduces the amount of memory available for projects. Every font size
you load is a separate character set.

64 kB of configuration memory are available per character set, which approximates
to 1900 different Chinese characters, for example. If you configure more different
Chinese characters, you obtain an error message during compilation to the effect
that the maximum number of characters has been exceeded. At the same time, a
list of the most infrequently used characters in the project is output.

Special characters

Special characters are ASCII characters higher than 127 – for example, ã, ±, ä,è, ó.

If you use a non-Chinese character set in text in an Asian Windows system, you
should not configure any special characters, because they are not displayed
correctly in a large number of cases.

Messages

All system messages are also available in Asiatic languages.

Message number, message status (active, cleared, acknowledged), date/time and
acknowledgement group remain in alphanumeric characters in Asian projects and
cannot be displayed in Asian characters.

Messages created with Asian characters cannot be exported or imported with ProTool.

Print jobs on the operating unit

When using an Asian language, all the print jobs are output in graphics mode to
the operating unit printer.

Field length

Field lengths depend on the width of the characters used. With Asiatic character
sets, the number of configurable characters in fields can be reduced as a result of
the double character width.

Standard projects

Standard projects and examples are also available in Asiatic languages.
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6 Testing projects

Principle

Once you have completed your entire project or self-contained parts within it, the
"test phase" starts.

The following steps must be taken:

1. Compile your project: Your project is transformed into a file that is capable of
running on the operating unit.

2. Download your project: The project is downloaded to the operating unit. You
have to perform some settings for this.

3. Test your project: Should you find other errors, troubleshoot them and start
again at step 1.

Note

If you are using a SIMATIC S5 or S7, configure "Status/Force" in order to test
specific tags in the PLC program.
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6.1 Transferring the executable project file

Basic procedure

To download the project file, you have to do the following:

1. Set the transfer mode.

2. Select an interface on the configuration computer.

3. Select a storage medium on the operating unit.

4. Download the project file.

Special features

These deviations from the basic procedure are only to be carried out the first time:

• Download mode: The first download is always a "serial download".

• Firmware: Before a compiled project file can be downloaded to the operating
unit for the first time, the firmware of the operating unit is downloaded
automatically. A corresponding status message is issued.

Download not possible

If no connection to the operating unit can be established, a status message to this
effect is output. Check the physical connection between the operating unit and the
configuration computer.

Note

The project file must not be downloaded directly from the configuration computer to
the module, but must first be loaded into the flash memory on the operating unit,
since the memory organization of the two storage media differs. If the project file
were to be downloaded directly to the module and then loaded into the flash
memory on an operating unit, error states can result.
In the DRAM the data are lost when the operating unit is switched off.
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6.2 Peculiarities of MPI download

Requirements

• MPI download is possible with the following operating units: all graphics
displays and OP 3, C7-623, and C7-624.

• An MPI module is required on the configuration computer.

• The configuration computer and operating unit are connected physically to the
MPI network.

• An MPI network can only be set up with a SIMATIC S7 PLC.

Setting the MPI address on the operating unit

If you have downloaded the compiled project file for the first time, and serially at
that, the operating unit has the configured MPI address.

To carry out an "MPI download", the standard screen "System Settings" must be
configured in the project and the "MPI Download" operating mode must be
selected.

Multiple operating units in the MPI configuration

If you want to integrate multiple operating units in the MPI configuration, you can
only do it successively.

1. Connect the first operating unit physically.

2. Change to serial transfer mode, and download first the firmware and then the
compiled project file.

3. Then connect the next operating unit physically, and so on.

Note

If you were to connect several operating units physically and then download the
project, this would lead to an address conflict. All the operating units would have
the same default MPI address, namely 1 which is not permissible in the MPI
configuration.



Testing projects Release 12/01

ProTool User Manual How to configure graphics-based units
6-4 A5E00149244

6.3 Directly accessing values on the PLC (Status/Force tag)

Purpose

At runtime you can directly access the connected PLC (SIMATIC S5 and SIMATIC
S7) from the operating unit to read and write values. This means you can monitor
and change the PLC operands easily on the operating unit without having to
connect a programming device or PC to the PLC as well.

This is very advantageous particularly during the testing and commissioning phase
of your project.

Requirements

In order to be able to access values on the PLC directly at runtime, the following
requirements must be met:

• The connected PLC must be a SIMATIC S5 or SIMATIC S7

• You must have integrated the two standard screens "Status Tag" and/or "Force
Tag" in your project.

Standard screens

The programming device function "STATUS TAG" is called in the standard screen
"Status Tag". This allows you to monitor PLC operands on the operating unit. Write
access is not possible in this screen.

The programming device function "FORCE TAG" is called in the standard screen
"Force Tag". This allows you to monitor and change PLC operands on the
operating unit.

You will find detailed descriptions about working with the two standard screens in
the "equipment manual" for your operating unit.
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6.4 Troubleshooting

If error messages are issued in the course of working with your project, such as
when you are compiling or downloading your project, you will learn here how you
take remedial action.

6.4.1 Error messages during compilation

Possible messages

While the ProTool compiler is compiling a project, status messages on the
progress of the compilation process are output to a window.

The following messages make a check of your project necessary:

• Notes: It is possible that logical operations in the project are either not correct
or do not exist. Check the project for logical relationships in accordance with
the messages. The compilation process has been properly completed.

• Warnings: The project contains errors that might result in incomplete display on
the operating unit. The full compilation process has been completed.

• Errors: Correct the errors listed and recompile the project. The compilation
process is not completed.
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6.4.2 Error messages while downloading

Possible problems while downloading

While a project is being downloaded to the operating unit, status messages on the
progress of the compilation process are output to a window.

If problems occur while the project is being downloaded to the operating unit, the
cause in the majority of cases is too high a baud rate or the simultaneous use of
other drivers on the configuration computer for example, when connected to a
network.

The most common causes of discontinuation of the download process are listed
below.

Downloading is aborted after a line Error message

Possible Cause Action

The connecting cable is too long. Select a lower baud rate.

The connecting cable is poorly shielded or
spurious signals are imported onto the cable
by other devices.

Select a lower baud rate.

Computer performance is inadequate. Select a lower baud rate.

Another driver is running in the background for
example, with networking.

Select a lower baud rate.

Downloading stops and crashes

Possible Cause Action

Computer performance is inadequate. Select a lower baud rate.
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The transfer aborts and a message reporting a compatibility contention is issued

Possible Cause Action

Contention between the versions of the
used configuration software and the
operating system of the operating unit.

Synchronize the operating system of the
operating unit with the version of the
configuration software you are using.
The files for updating the operating unit
will be found on the ProTool installation
CD-ROM in the Images directory.

The precise procedure is described in
the equipment manual concerned.

Downloading does not take place

Possible Cause Action

Connection to the operating unit cannot
be established (message in the system
message window).

Check the physical connection between
the configuration computer and the
operating unit.

The standard communication driver is
not entered in the Windows device
manger.

Check the device status of the COM
port in the Properties window of the
device manager.

Interrupt problems.

Various modules are using the same
interrupt.

Modify the configuration of your
computer or install ProTool on a stand-
alone computer.

Other programs block the interface for
example, STEP 5.

Exit from the programs and reboot your
computer, if necessary.
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7 Documenting and managing projects

This chapter details the multiplicity of functions offered by ProTool for printing out,
documenting and managing and archiving your project data.

7.1 Printing project data

Print function

ProTool provides a comprehensive printout function that can be accessed by
choosing "File" > "Print" from the menu. It provides detailed lists for documenting
all project-relevant data such as screens, messages, tags, symbol tables, etc.

Print function in ProTool

In this way it provides the facility for documenting your complete project. An up-to-
date printout can also be very helpful while you are configuring.

Note

When configuring, as an alternative to the printout function, there is also the user-
friendly cross-reference function offered by ProTool.
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Chapter

ProTool subdivides printouts into chapters arranged by subject according to object
types. For example, one chapter contains all the definitions on the subject of
screens, another contains a list of all the tags and yet another a list of all the
defined text or graphic lists.

You can print several chapters at once or just print single chapters.

Reports

ProTool offers you the facility of customizing printouts to suit your individual
requirements.

• You can limit a printout to single chapters or single pages.

• You can set the order in which the chapters appear.

• You can decide which data you want to output within a chapter.

• You can set margins, define your own headers and footers and embed your
own graphic in the cover.

These definitions are stored in a "report". Frequently required reports have been
defined in ProTool in advance. But you can also create your own reports, as you
wish. All reports are common to all projects.

Every time you want to print, you choose the report with which you would like your
output to conform.
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7.2 Project management with integrated operation

ProTool integrated in SIMATIC STEP 7

If you are working with ProTool integrated in SIMATIC STEP 7, use SIMATIC
Manager to manage your projects. You can then copy, move, back up and restore
your projects in the same way as you have been used to from SIMATIC STEP 7.
For further information refer to the documentation on SIMATIC Manager.

Note

ProTool's Project Manager is not available to you in the event of integrated
operation. ProTool data can no longer be viewed independently in this event, since
the data is always linked to a SIMATIC STEP 7 project. It therefore has to be
managed and backed up using this application.
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7.3 Managing projects in stand-alone operation

Project Manager

If you installed ProTool as a "stand-alone" application – in other words, if you are
not operating it under SIMATIC STEP 7 – there is a user-friendly project manager
integrated in ProTool instead of SIMATIC Manager. You can use it to manage your
projects in a user-friendly way.

Usage

With Project Manager, it is simple for you to:

• Archive projects (Backup), using more than one floppy disk too

• Restore archived projects (Restore)

• Open projects

• Delete projects

Backup and restore

The Backup and Restore functions are not possible between devices of different
types.

Backup and Restore are directly possible on the operating units. Refer to your
equipment manual for further information.
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Call

You start Project Manager by choosing "File" > "Project Manager" from the menu.
When you call Project Manager for the first time, the "Find" dialog box is displayed
initially. Here you choose the drives and directories which have to be searched for
ProTool files. Only those projects that are located within these directories are
displayed by Project Manager.

"Find" dialog box

After you have selected the appropriate directories, or when you call Project
Manager later again, the Project Manager window proper appears.
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Display

Project Manager

In the left segment of the Project Manager you will see a hierarchical structure of
all the projects located in the directories in which Project Manager searched. Here
you can select a project in order to open it, delete it or back it up.

In the center segment of the window you will find detailed information on the
project highlighted on the list.

Using the buttons in the area on the right, you can extend the list of scanned
directories ("Find" button), have the directories searched again ("Update" button)
and have the list sorted by different project data such as "project name", "device
type", "date created", etc. ("Sort" button).
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7.4 Constraints with printing

Printer drivers

Note the following constraints with certain printer drivers:

• It might not be possible to print the project with CANON drivers. Printing will be
discontinued in this case.

• With the Apple laser printer, the first line is not printed. This problem does not
occur with drivers for the HP LaserJet III, PostScript or PostScript printers.

ASCII character set

With some printers, it is not enough simply to set the ASCII character set in the
project. Make sure the ASCII character set is set on the printer too.
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7.5 Example of documenting a project

This example shows you how to create a customized printout.

7.5.1 How to create a customized printout

Objective

You wish to print all the data in your project. Unlike the default setting, you do not
want the ProTool graphic but your company logo, which you have already used in
your project under the name of LOGO, to be printed on the cover sheet. You want to
leave a margin for handwritten comments on the right side of the printout.

Procedure

Procedure:

1 Open the project from which you wish to print data.

2 Choose "File" > "Print" from the menu.

3 In the "Print" dialog box at "Reports", choose the Complete report. You will
now see the individual chapters in the "Contents" list in the order in which
they will later be output.
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Procedure:

4 Click the "Preview" button. The print preview shows you how your printout will
look later. You want to replace the graphic on the first page (cover) with your
company logo. You want the right border to be much wider.

5 Exit from the preview by clicking the "Print" button.

6 To perform the changes you require, click the "Reports" button.

The "Reports" dialog box is opened.
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Procedure:

7 To modify the margin, click the "Page" button.

8 Enter the value you require for the right border at "Right" - for example, 3 for
3 cm. If you like, you can specify a piece of text here for the headers and
footers at the same time.

9 Confirm your input by clicking OK. You are now back in the "Reports" dialog
box.

10 To modify the definition for the cover sheet, select the entry Cover Sheet in
the "Contents" list and click the "Parameters" button.

11 In the "Cover Sheet" dialog box, select the graphic called LOGO with your
company logo at "Graphic".

12 Click OK twice until you are back in the "Print" dialog box.

13 Finally, click the OK button to start the printing process.
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8 Tips for efficient configuration

Here you can obtain useful tips on how to design your configuration in ProTool
even more efficiently.

8.1 Optimizing performance

Principle

If you want to optimize performance to the maximum possible while the operating
unit is operating, the best way to achieve this is by having the best possible setting
for the "update time and acquisition cycle".

The acquisition times specified for the area pointers and the acquisition times of
the tags are important factors for the update times that can actually be achieved.

The following applies to calculation of the update time:

Update time = acquisition cycle plus transfer time plus processing time.

You achieve optimum update times by taking the following points into account
while you are configuring:

• Create the different data areas as small as possible and as large as necessary.

• Define contiguous data areas where they belong. The actual update time
improves if you create one large area instead of several small ones.

• If you select too small an acquisition cycle, it has an adverse degrades overall
performance. Set the acquisition cycle in line with the update rate of the
process values.

Example:
The temperature variation of a furnace, for example, is considerably less dynamic
than the variation in speed of an electric drive.

The guide figure for the acquisition cycle is approx. 1 second.

• If necessary, dispense with the cyclic download of user data areas (data entry
cycle 0) to improve update times. Instead, use PLC jobs to download user data
areas spontaneously.

• Place all message or screen tags in a data area.

• For the operating unit to be able reliably to detect changes on the PLC, the
changes must be queued during the actual acquisition cycle.
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8.2 Making optimum use of graphics

Optimizing graphic applications

It may take a relatively long time to load and save projects, especially if you use a
large number of Designer, Corel Photo Paint or Corel Draw graphics.

• Save As
Save at "Save As ..." from time to time. This optimizes data storage and makes
the *.pdb file smaller.

• Graphics editor
Avoid large numbers of Designer, Corel Photo Paint and Corel Draw graphics.
Program sections of these editors are used when graphics are processed.
Some of these editors are very slow. The best times are achieved with Paint.

• Reduce the color depth
The memory requirements for graphics increases in proportion to the number
of colors you use. Therefore use only the absolutely essential color availability
in your graphics.

Efficient creation of graphics

To create graphics as efficiently as possible, take the following recommendations
into consideration:

• Use pixel graphics primarily in those cases where the size of the window is
fixed, as with icons for soft keys or buttons, for example.

• You should use vector graphics for graphics whose size has to be
subsequently modified.

• Always create your graphics with the same aspect ratio as the clicked and
dragged field in ProTool. In doing so, it should be borne in mind that a graphic
having a size of, say, 10 cm × 20 cm cannot be displayed faithfully from a pixel
point of view in a field of 1 cm × 2 cm. Information is lost in such a case.
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8.3 Creating graphics

Efficient creation of graphics

The following tips are designed to help you create graphics as efficiently as
possible:

• Use pixel graphics primarily in those cases where the size of the window is
fixed, as with icons for soft keys or buttons, for example.

• You should use vector graphics for graphics whose size has to be
subsequently modified.

• If you use the same graphic in different sizes, more than one graphic has to be
created for it in ProTool. ProTool cannot scale to several sizes from one
graphic. Duplicate the graphic in this case and store it in different sizes.

• Always create your graphics with the same aspect ratio as the clicked and
dragged field in ProTool. In doing so, it should be borne in mind that a graphic
having a size of, say, 10 cm × 20 cm cannot be displayed faithfully from a pixel
point of view in a field of 1 cm × 2 cm. Information is lost in such a case.
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8.4 Libraries in ProTool

Purpose

Libraries are collections of preconfigured screen objects. They add to the number
of screen objects available and enhance the effectiveness of your configuration by
repeated and multiple use of "finished parts".

Standard libraries

Once ProTool is installed, the following libraries are available to you in the
\Library directory:

File name Content Suitable for
devices

Bmp-Graphics.lib Technical standard symbols All

Vector-Graphics.lib Pipes, pumps, tanks and
valves

All Windows
systems, except
TP 170 A

Touch-Switches.lib Buttons TP 27, TP 37

TP 170A-TOUCH-Switches.lib Buttons All Windows
systems,
specifically touch
devices, such as
TP 170 A, TP 170
B, TP 270

You can add further libraries to this directory yourself and then use them in
ProTool. Files must be of the *.lib type and have the same format as a ProTool
library.

Managing libraries

As soon as you open a screen in a project, you have access to the menu
options under "Edit" > "Libraries" and to the icon button.

Once you open the first library, the library window on the screen is active. The first
library opened and all those subsequently opened are shown together here, as a
tree structure.
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The following functions are available to assist you in managing your libraries:

• Adding a library: You insert a file (of the *.lib type or in ProTool library
format) in the \Library directory. Use the "New" option on the shortcut menu
to create a new, empty library. Save a library under a different name and then
edit it.

• Renaming or deleting a library: Use the Windows functions in Explorer of the
library.

• Deleting library objects or folders: Use the shortcut menu of the library.

• Restructuring a library: Edit the overview by dragging with the Windows
functions. Use "New Folder" on the shortcut menu to add a new folder. To
rename folders or library objects, click twice or press "F2".

Note

You cannot edit a write-protected library.

Editing library objects

You cannot edit library objects directly, you can only edit them in a project.

Paste the object in question to a screen in your project, edit it there and move it
back to the associated library. Delete the original object and give the one you have
just added the same name as the old one.
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8.5 Using a tag in several fields

Background

If you use a tag on the operating unit in an input field and simultaneously in an
output field, this may result in unexpected display behavior. The value of the tag at
this address can be modified both by the PLC and by means of an input on the
operating unit.

Example:
You enter a new value on the operating unit. The output field is updated
immediately with the new value. In the meantime, a value is read from the PLC
which is still the old value. The old value is then displayed briefly in the output field
and in the input field. While that is happening, the new value is being transferred to
the PLC. The new value is then displayed in both fields upon the next update.

Action

We recommend for this reason that you configure different tags for the input field
and the output field.
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8.6 Tags with configured decimal places

Special features when inputting limit values

Limit values for tags are entered without a point. The constant for the limit value is
interpreted differently, depending on whether decimal places have been specified
for the tag.

The number of specified decimal places determines how many places of the limit
value are interpreted as decimal places.

The table shows an example.

Decimal places Limit Value Entered Interpreted by
ProTool

0 2275 2275

1 2275 227,5

2 2275 22,75
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8.7 Tips on touch panels

Special points about configuring touch panels

The following tips apply specifically to projects that you create for touch panels:

• Input fields and input/output fields are touch-sensitive on TPs. Select for the
field a background color that differs from that of the current screen. In this way
the touch-sensitive are on the TP can be recognized by the size of the colored
field.

• Always dimension input fields and input/output fields as a multiple of the touch
grid. If, for example, you are using the 8 × 8 character set and position two
input fields or two input/output fields within a grid line, then one of the two fields
cannot be operated on the TP.

• Help text is particularly helpful with input fields and input/output fields, since the
assignment of input field to input window on the TP is not directly evident from
the position of the input window.

• The touch panel display a maximum of 26 characters in the input field for
symbolic values. You should therefore avoid long text entries in your text list.
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A Standard screens reference

Screens in standard projects

The "standard projects" supplied with ProTool contain various screens that have
already been configured; these are called standard screens. The names of the
screens all start with the character "Z_. You can use standard screens in your
projects without changing them or you can customize them to suit your
requirements.

The following table shows the applications implemented in the different standard
screens.

Note

Many of the screens and functions listed below are not available for all operating
units.

Screen Name Usage Constraints

Z_BACKUP Archive data (backup)

Read in archived data (restore)

Z_FORCE Force VAR

Z_MESSAGES Edit messages such as

Open event message window

Open event buffer/event message
page

Delete event buffer

Open alarm buffer/alarm message
page

Delete alarm buffer

Z_PASSWORD Assign and modify password

Log in

Z_PRINTER Set printer and printer parameters.

On the OP 27 and the TP 27m you
can go from this screen to the
following standard screens:

Z_HARDCOPY

Z_COLOR

Z_HARDCOPY Set parameters for Print Screen
(ASCII/graphic)

OP 27 and TP 27
only

Z_COLOR Clear individual colors or modify color
assignments for printing

OP 27 and TP 27
only

Z_RECORD 1 Basic functions for using data records
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Screen Name Usage Constraints

Z_RECORD 2 Extended functions for using data
records

Z_SETTINGS General System settings such as

mode change

language switch

screen blanking

enter date and time

display first/last alarm message

message logging ON/OFF

buffer overflow warning ON/OFF

acoustic signal (for TPs)

contrast (for TPs)

calibration (for TPs)

Z_STATUS Status tag for PLC diagnostics

Z_SYSTEM_MEN Overview screen for standard
screens.

You can go from this screen to the
following standard screens:

Z_PASSWORD

Z_PRINTER

Z_STATUS

Z_SETTINGS

Z_MESSAGES
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B Communication areas for non-SIMATIC PLCs

Non-SIMATIC PLCs

This description applies to communication with the following PLCs:

• Allen-Bradley

• Mitsubishi

• Modicon

• Omron

• Telemecanique

The data areas for the SIMATIC PLCs are described in the "Communication User's
Manual".

The operating unit and the PLC communicate with each other via these data areas:

• Interface area

• Keyboard assignment

• LED assignment

The data areas are only required if you want to use the corresponding functions on
your operating unit. Create the required data areas on the PLC, and enter them as
area pointers in your project, in the project window, at "Area pointers".

The table provides you with an overview of which user areas are in principle
possible with which operating unit.

Device-specific user data areas:

User data area Operating Unit

Event messages OP 25, OP 27, OP 35, OP 37, TP 27, TP 37

Alarm messages OP 25, OP 27, OP 35, OP 37, TP 27, TP 37

PLC jobs OP 25, OP 27, OP 35, OP 37, TP 27, TP 37

Recipes OP 25, OP 27, OP 35, OP 37, TP 27, TP 37

System keyboard assignment OP 25, OP 27, OP 35, OP 37

Function keyboard assignment OP 25, OP 27, OP 35, OP 37

LED assignment OP 25, OP 27, OP 35, OP 37

Date and time OP 25, OP 27, OP 35, OP 37, TP 27, TP 37

User version OP 25, OP 27, OP 35, OP 37, TP 27, TP 37

Screen number OP 25, OP 27, OP 35, OP 37, TP 27, TP 37

User version OP 25, OP 27, OP 35, OP 37, TP 27, TP 37

Trend request area OP 25, OP 27, OP 35, OP 37, TP 27, TP 37

Trend transfer area OP 25, OP 27, OP 35, OP 37, TP 27, TP 37
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Structure of the interface area for non-SIMATIC PLCs

Use of the interface area

The interface area is required when you use the functions for the following:

• Sending PLC jobs to the operating unit

• Comparing the date and time between the PLC and the operating unit

• Checking the version number

• Editing recipes (downloading data records)

• Detecting the startup of the operating unit in the PLC program

• Determining the operating mode of the operating unit in the PLC program

• Determining the life bit of the operating unit in the PLC program

Setting up the interface area

Set the interface area in the project window at "Area pointers". The area must also
exist on the PLC. The figure below shows the structure of the interface area.

Structure of the interface area in data words

Note

You will find a description of the interface area for SIMATIC PLCs in the
"Communication User's Manual".
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Control and acknowledgement bits for non-SIMATIC PLCs

Count direction of the bits

The count direction of the bits in a data word depends on the PLC. Each data word
is shown below in two figures. In the explanation of the bits, the bit number is
represented as follows depending on the count direction:

• From right to left (right > left), beginning with 0: without bracket

• From left to right (left > right), beginning with 1: with bracket

Structure of the control and acknowledgement bits

One word each is available in the interface area for the control and
acknowledgement bits:

• "Word n+0"
Contains the control bits. These are written by the PLC and read by the
operating unit.

• "Word n+6"
Contains the acknowledgement bits. These are written by the operating unit
and read by the PLC.

The figures below show in detail the structure of the control and acknowledgement
bits for different count directions.

Control and acknowledgement bits for the count direction right > left
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Control and acknowledgement bits for the count direction left > right

Operating unit startup

"Bit 0 (16) in acknowledgement bits":

1 = Operating unit has started up

0 = Operating unit is starting up

The bit is set by the operating unit on completion of startup.

Operating unit operating mode

"Bit 1 (15) in acknowledgement bits":

1 = operating unit is offline

0 = operating unit is in normal mode

The bit is set if the operating unit is switched offline by the operator. When the
operating unit is online, the bit is at 0.

Life bit

"Bit 2 (14) in acknowledgement bits":

The purpose of the life bit is to detect any interruption of the connection from the
operating unit to the PLC immediately. The operating unit inverts the life bit in the
interface area at regular intervals.
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Synchronizing the download of data records

• Control bits:
"Bit 10 (6)"
1 = Data record/tag has an error
0 = No evaluation has taken place

"Bit 9 (7)"
1 = Data record/tag is error-free
0 = No evaluation has taken place

• Acknowledgement bits:
"Bit 9 (7)"
1 = Data transfer completed
0 = No evaluation has taken place

"Bit 8 (8)"
1 = Data mailbox is inhibited
0 = Data mailbox is free

The control and acknowledgement bits in the interface area synchronize the
transfer of data records. By default the transfer is initiated by the operator at the
operating unit.

Download from the operating unit to the PLC

The sequence described below indicates how the operating unit sets the
synchronization bits and how the PLC program must respond to it.

1. The operating unit checks bit 8 (8) of the acknowledgement bits. If the bit is set
to 1 (data mailbox inhibited), the transfer is terminated with a system error
message. If the bit is set to 0 (data mailbox free), the operating unit sets the bit
to 1.

2. The operating unit enters the identifiers in the data mailbox.

3. In the case of a data record to be transferred "indirectly" (not with text-based
displays), the values of the tags are written to the data mailbox.

In the case of a data record to be transferred "directly", the tag values are
written to the configured address.

4. The operating unit sets bit 9 (7) of the acknowledgement bits to 1 (data transfer
terminated).

5. Acknowledge in the PLC program whether or not the transfer was error-free:

Error-free: control bit 9 (7) is set to 1
Failed: control bit 10 (6) is set to 1

6. The operating unit resets bits 9 (7) and 8 (8) of the acknowledgement bits.

7. Reset control bits 10 (6) and 9 (7) in the control program.

Note

You will find a description of the control and acknowledgement bits for SIMATIC
PLCs in the "Communication User's Manual".
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Data areas in the interface area for non-SIMATIC PLCs

Overview

The PLC triggers an action on the operating unit via the job mailbox. All the other
bytes are areas to which the operating unit writes data. These areas can be
evaluated by the PLC program.

Job mailbox

Word n+2 to n+5:

You can transfer PLC jobs to the operating unit via the job mailbox and thus trigger
actions on the operating unit.

The job mailbox consists of four words. The job number is in the first word of the
job mailbox. The job parameters (up to 3) are entered in the subsequent words.

The figure below shows the structure of the job mailbox.

Structure of the job mailbox

If the first word of the job mailbox is not equal to zero, the operating unit evaluates
the PLC job. The operating unit then sets this data word to zero again. For this
reason the parameters must be entered in the job mailbox first, followed by the job
number.

You will find a list of all possible PLC jobs with job numbers and parameters in
"PLC jobs in alphabetical order" and "PLC jobs in numerical order".

Version number

Word n+8:

The operating unit enters the version number of the driver in word n+8. You can
evaluate the version number in the PLC program.
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Date and time

Time: Word n+9 to n+11
Date: Word n+12 to n+14

PLC job 41 allows you to initiate the transfer of the date and time from the
operating unit to the PLC.

The figure below shows the structure of the data area. All the information is BCD-
encoded.

Structure of the "time" and "date" data areas

Note

You will find a description of the interface area for SIMATIC PLCs in the
"Communication User's Manual".

In order to be able to verify that the date and time have been transferred, you
should set the data words to 0 before sending off the PLC job.
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Keyboard assignment of the operating unit for non-SIMATIC PLCs

Usage and prerequisite

Keystrokes executed on the operating unit can be transferred to and evaluated by
the PLC. This means, for example, that you can issue a message to notify the
operator of incorrect usage of a key.

In order to be able to do this, you must set up corresponding data areas known as
assignments in the PLC and specify them as "area pointers" during configuration.

Note on the touch panel

Area pointers for the keyboard and LED assignments are not supported for touch
panel configuration.

Download

The keyboard assignments are downloaded spontaneously to the PLC. The
download takes place whenever a change is registered on the operating unit. It is
therefore not necessary to configure a polling time.

In the case of operating units with a graphical display, a maximum of two
simultaneously depressed keys are transferred.

The following applies to the keys of the operating unit (except to SHIFT):
For as long as the key is held down, the relevant bit in the keyboard assignment
has a value of 1. Otherwise, it has a value of 0.

Note

If the operating unit is switched off or disconnected from the PLC with a key held
down, the corresponding bit in the keyboard assignment remains set.

System keyboard assignment

The system keyboard assignment is a data area with a fixed length of three data
words. In order to be able to use the system keyboard assignment, you must set
up a data area of the type "system keyboard" in your project at "Area Pointers".

Precisely one bit in the system keyboard assignment is assigned to each key on
the system keyboard on a fixed basis. The figures below show the keyboard
assignments for units OP 25/OP 27 and OP 35/OP 37.
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Keyboard assignment for the OP 25/OP 27

Keyboard assignment for the OP 35/OP 37

Note

Unused bits cannot be overwritten by the user program.

Keyboard communication bit

The keyboard communication bit is a control bit. Each time the keyboard
assignment is transferred from the operating unit to the PLC, it is set to 1 and
should be reset by the user program after evaluation of the data area.

Regular reading of the communication bit makes it possible in the user program to
establish whether the assignment of the system keyboard has been transferred
again.
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Function keyboard assignment

The assignment of the function keyboard can be subdivided into up to 8 separate
data areas. The total length of these data areas must not exceed 8 data words. In
order to be able to use the function keyboard assignment, you must set up a data
area of the type "function keyboard" in your project at "Area Pointers".

Key assignment

Set the assignment of the individual keys to the bits of the data areas when you
"configure the function keys". For each key you specify the number in the
assignment area.

Keyboard communication bit

The highest bit in the last data word of "each" data area is the keyboard
communication bit. This is a control bit. Each time the keyboard assignment is
downloaded from the operating unit to the PLC, the keyboard communication bit is
set to 1. After the data area has been evaluated by the user program, the keyboard
communication bit should be reset.

Regular reading of the communication bit makes it possible in the user program to
establish whether a block has been downloaded again.

Note

You will find a description of the keyboard assignment for SIMATIC PLCs in the
"Communication User's Manual".
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LED assignment of the operating unit for non-SIMATIC PLCs

Usage

The light-emitting diodes (LEDs) on the function keys of the operating unit can be
driven on the PLC. This makes it possible, for example, for a key LED to show the
operator which key to press in a particular situation.

Data areas

The LED assignment can be subdivided into up to 8 separate data areas. The total
length of these data areas must not exceed 16 data words. In order to be able to
use the LED assignment, you must set up a data area of the type "LED
assignment" in your project at "Area Pointers".

Polling time

If you specify a polling time of 0 for a data area, this is not downloaded cyclically to
the operating unit. You must then use "PLC job" No. 42 to drive the LEDs.

LED assignment

Set the assignment of the individual LEDs to the bits of the data areas when you
"configure the function keys". For each LED you specify the number of the
assignment area and the bit number in this area.

Bit number n in the following tables designates the first of two successive bits that
control a total of four different LED states.

Bit n + 1 Bit n LED function

0 0 Off

0 1 Flashing at approx. 2 Hz

1 0 Flashing at approx. 0.5 Hz

1 1 On continuously

LED function for the right > left count direction

Bit n + 1 Bit n LED function

0 0 Off

0 1 Flashing at approx. 0.5 Hz

1 0 Flashing at approx. 2 Hz

1 1 On continuously

LED function for the left > right count direction
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Note

You will find a description of the LED assignment for SIMATIC PLCs in the
"Communication User's Guide".
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C Libraries in ProTool

Purpose

Libraries are collections of preconfigured screen objects. They add to the number
of screen objects available and enhance the effectiveness of your configuration by
repeated and multiple use of "finished parts".

Standard libraries

Once ProTool is installed, the following libraries are available to you in the
\Library directory:

File name Content Suitable for
devices

Bmp-Graphics.lib Technical standard symbols All

Vector-Graphics.lib Pipes, pumps, tanks and
valves

All Windows
systems, except
TP 170 A

Touch-Switches.lib Buttons TP 27, TP 37

TP 170A-TOUCH-Switches.lib Buttons All Windows
systems,
specifically touch
devices, such as
TP 170 A, TP 170
B, TP 270

You can add further libraries to this directory yourself and then use them in
ProTool. Files must be of the *.lib type and have the same format as a ProTool
library.

Managing libraries

As soon as you open a screen in a project, you have access to the menu
options under "Edit" > "Libraries" and to the icon button.

Once you open the first library, the library window on the screen is active. The first
library opened and all those subsequently opened are shown together here, as a
tree structure.
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The following functions are available to assist you in managing your libraries:

• Adding a library: You insert a file (of the *.lib type or in ProTool library
format) in the \Library directory. Use the "New" option on the shortcut menu
to create a new, empty library. Save a library under a different name and then
edit it.

• Renaming or deleting a library: Use the Windows functions in Explorer of the
library.

• Deleting library objects or folders: Use the shortcut menu of the library.

• Restructuring a library: Edit the overview by dragging with the Windows
functions. Use "New Folder" on the shortcut menu to add a new folder. To
rename folders or library objects, click twice or press "F2".

Note

You cannot edit a write-protected library.

Editing library objects

You cannot edit library objects directly, you can only edit them in a project.

Paste the object in question to a screen in your project, edit it there and move it
back to the associated library. Delete the original object and give the one you have
just added the same name as the old one.
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How to work with the SIMATIC HMI Symbol Library

Purpose

From the SIMATIC HMI symbol library, it is easy to paste the most varied screen
objects into your screen.

Pasting an object

To paste an object from the SIMATIC HMI symbol library, perform the following
steps:

Procedure:

1 Open the screen in question.

2

On the "Screen objects" toolbar, click on the adjacent button and then in the
screen, at the place where you want the object to appear.

The "Symbol Library" dialog box opens.

3 On the "Symbols" tab, select the topic subject concerned at bottom left, at
"Category" and, on the right, select the screen object you require.

4 On the "Style" tab, set the characteristics you require for the object that has to
be pasted.

The foreground color cannot be changed in the "Shaded" Foreground mode

5 On the "Color" tab, set the colors for the foreground and background, as well
as for flashing, as required, and for the upper and lower limits being
exceeded (of a configured tag).

6 Select the "Attributes" tag if you want to modify the foreground and
background colors, for example, in Runtime, or to enable and disable
flashing.

If you have enabled flashing on the "Color" tab and on the "Attributes" tab,
flashing enabled at "Set color" will be ignored.

7 Select the "Functions" tab if you want to trigger a function when selecting or
exiting the symbol (not useful on key-operated devices).

To make this clear to the operator, you can select the "Display mouse pointer"
check box on the "Style" tab. The lightning symbol then appears next to the
cursor in ProTool/Pro RT.

8 Select the "Position" tab to set the position of the symbol exactly to the pixels.
On this tab you set whether the position is static or it is dynamically modified
in Runtime.

9 Select the "Name" tab if you want to assign the symbol a specific name. You
can use this name as a parameter, for example in functions that refer to the
symbol.

10 Assign a password level to the symbol on the "Enable" tab, as necessary, to
enable data entry only by authorized persons.
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Procedure:

11 Similarly, set on the "Enable" tab, as necessary, the conditions under which
you want the symbol to be displayed or hidden in Runtime.

12 Confirm by clicking OK.

The symbol from the library is now included in the screen, with the settings
you selected.
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D HMI System Messages

In this chapter

This chapter contains a selection of important HMI system messages for Windows–
based systems. The table indicates when the messages occur and how they, or
their cause, can be cleared. Not every message is relevant for each operating unit.

HMI system message parameters

The HMI system messages may contain parameters which are not decoded for the
user but which are relevant in respect of the cause of an error since they provide a
reference to the source code of the runtime software. These parameters are issued
according to the text “Error code:”.

Notice

HMI system messages are issued in the language currently set on the operating
unit.

Procedure in the case of “internal errors”

Please proceed as follows in the case of all system messages related to “internal
errors”:

Start up the operating unit again.

Download the configuration again.

Switch the operating unit off, stop the PLC and then restart both.

If the error occurs again, please contact the SIMATIC Customer Support. Make
reference to the specified error number and message tags.

Number Effect/Cause Remedy

10000 The print job could not be started or
was terminated for an unknown reason.

The printer is incorrectly configured.

Or: There are no rights for a network
printer available.

Check the printer settings
and cable connections.

If a fault occurs repeatedly,
contact the hotline.

10001 No printer has been installed or no
standard printer configured.

Install a printer and/or mark
one as standard printer.

10002 The intermediate buffer for printing
graphics is full. Up to two graphics can
be buffered.

Do not issue print jobs so
quickly in succession.

10003 Graphics can be buffered again. -
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10004 The intermediate buffer for printing lines
in text mode (e.g. messages) is full. Up
to 1000 lines can be buffered.

Do not issue print jobs so
quickly in succession.

10005 Lines of text can be buffered again. -

10006 The Windows print system reports an
error. For information on the cause,
refer to the text printed and, if available,
the error number.

Printing is not performed or it is
incorrect.

Repeat the action, if
necessary.

20010 A fault has occurred in the script line
called in from the specified script.
Execution of the script function was,
therefore, terminated.

In this case, it is advisable to check any
previous system messages too.

Select the specified script
line in the configuration.

Check tags, whether the
types used are permissible.

Check Functions, whether
the number and types of
parameter are correct.

20011 An error has occurred in a script called
in by the script specified. Execution of
the script function– has, therefore, been
terminated in the subscript.

In this case, it is advisable to check any
previous system messages too.

Select the scripts from the
configuration which are
called in directly or indirectly
via the specified script.

Check tags, whether the
types used are permissible.

Check Functions, whether
the number and types of
parameter are correct.

20012 Inconsistent configuration data is
present. Therefore, the script could not
be created.

Compile the configuration
again.

20013 VBScript.dll is not correctly installed.
Therefore, no scripts can be executed.

Re–install ProTool/Pro RT.

20014 A value is returned by the script
function which is not written in any
configured return tag.

Select the specified script in
the configuration.

Check whether the script
name has been assigned a
value.

20015 Too many scripts have been triggered
in quick succession.

If more than 20 scripts are queued to
be processed, any subsequent scripts
are rejected.

In this case, the script indicated in the
message is not executed.

Check where the scripts are
being triggered from.

Extend the times, e.g. the
polling time of the tags,
which trigger the scripts.

30010 The tag could not accept the function
result, e.g. in the case of exceeding the
value range.

Check the tag type of the
function parameter.
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30011 A function could not be executed
because the function was assigned an
invalid value or type in the parameter.

Check the parameter value
and tag type of the invalid
parameter.

If a tag is used as a
parameter, check its value.

40010 The function could not be executed
since the parameters could not be
converted to a common tag type.

Check the parameter types
in the configuration.

40011 The function could not be executed
since the parameters could not be
converted to a common tag type.

Check the parameter types
in the configuration.

50000 The operating unit receives data faster
than it is capable of processing.
Therefore, no further data is received
until the data currently available has
been processed. Data exchange then
resumes.

-

50001 Data exchange has been resumed. -

60000 This message is generated by the
function “Display system messages”.
The text to be displayed is transferred
to the function as a parameter.

-

60010 The file could not be copied in the
direction defined because one of the
two files is currently open or the
source/target path is not available.

It is possible that the Windows NT user
has no access rights to one of the two
files.

Restart the function or check
the paths of the
source/target files.

Using Windows NT with
NTFS: The user executing
ProTool/Pro RT must be
granted access rights for the
files.

60011 An attempt was made to copy a file to
itself.

It is possible that the Windows NT user
has no access rights to one of the two
files.

Check the path of the
source/target file.

Using Windows NT with
NTFS: The user executing
ProTool/Pro RT must be
granted access rights for the
files.

70010 The application could not be started
because it could not be found in the
path specified or insufficient memory
space was available.

Check whether the
application exists in the
specified path or close other
applications.
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70011 The system time could not be modified.
The error message only appears in
connection with area pointer Date/Time
PLC. Possible causes:

- an impermissible time was transferred
in the PLC job,

- the Windows NT user has no user
rights to modify the system time.

If the first parameter in the system
message is displayed with the value 13,
the second parameter indicates the
byte containing the incorrect value.

Check the time which is to
be set.

Under Windows NT: The
user executing ProTool/Pro
RT must be assigned the
rights to modify the system
time from Windows NT
(administration/user
manager, guidelines).

70012 An error occurred when executing the
function Exit Runtime with the option
Exit also Windows.

Windows and ProTool/Pro RT are not
terminated.

A possible cause is that other
applications cannot be terminated.

Terminate all applications
currently running.

Then terminate Windows.

70013 The system time could not be modified
because an invalid value was entered.
Incorrect separators may have been
used.

Check the time which is to
be set.

70014 The system time could not be modified.
Possible causes:

- an impermissible time was transferred

- the Windows NT user has no user
rights to modify the system time,

- Windows rejects the setting request.

Check the time which is to
be set.

Under Windows NT: The
user executing ProTool/Pro
RT must be assigned the
rights to modify the system
time from Windows NT
(administration/user
manager, guidelines).

70015 The system time could not be read
because Windows rejects the reading
function.

-

70016 An attempt was made to select a
screen by means of a function or job.
This is not possible because the screen
number specified does not exist.

Or: a screen could not be generated
due to insufficient system memory.

Check the screen number in
the function or job with the
screen numbers configured.

Refer the number to a
screen, if necessary.

70017 Date/Time is not read from the area
pointer because the address set in the
PLC is either not available or has not
been set up.

Change the address or set
up the address in the PLC.

70018 Acknowledgement that the password
list has been successfully imported.

-
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70019 Acknowledgement that the password
list has been successfully exported.

-

70020 Acknowledgement for activation of
message recording.

-

70021 Acknowledgement for deactivation of
message recording.

-

70022 Acknowledgement to starting the Import
Password List action.

-

70023 Acknowledgement to starting the Export
Password List action.

-

70027 Backing up the RAM file system has
been started.

-

70028 Backing up of the RAM file system has
been completed successfully.

The files from the RAM have been
copied in the Flash memory. Following
a restart, these saved files will be
copied back in the RAM file system.

-

70029 Backup of the RAM file system has
failed.

No backup copy of the RAM file system
has been made.

Check the settings in the OP
Properties dialog and save
the RAM file system using
the Save Files button in the
Persistent Storage tab
control.

70030 The parameters configured for the
function are faulty.

The connection to the new PLC was not
established.

Compare the parameters
configured for the function
with the parameters
configured for the PLC and
correct them as necessary.

70031 The PLC configured in the function is
not an S7 PLC.

The connection to the new PLC was not
established.

Compare the S7 PLC name
parameter configured for the
function with the parameters
configured for the PLC and
correct them as necessary.

80001 The archive specified is filled to the size
defined (in percent) and must be stored
elsewhere.

Store the file or table by
executing a ‘move’ or ‘copy’
function.

80002 A line is missing in the specified
archive.

-

80003 The copying process for archiving was
not successful.

In this case, it is advisable to check any
subsequent system messages, too.

-
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80006 Since archiving is not possible, this
causes a permanent loss of the
functionality.

In the case of databases,
check whether the
corresponding data source
exists and start up the
system again.

80009 A copying action has been completed
successfully.

-

80010 Since the path was incorrectly entered
in ProTool, this causes a permanent
loss of the functionality.

Configure the path for the
respective archive again and
restart the system when the
full functionality is required.

80012 Archive values are stored in a buffer. If
the values are read to the buffer faster
than they can be physically written (e.g.
using a hard disk), overloading may
occur and recording is then stopped.

Archive less values.

Or increase the recording
interval.

80013 The overload status no longer applies.
Archiving resumes the recording of all
values.

-

80014 The same action was triggered twice in
quick succession. Since the process is
already in operation, the action is only
carried out once.

-

80016 The archives are separated by the
function Close archive and the
incoming entries exceed the defined
buffer size.

All the jobs in the buffer are deleted.

Reconnect the archives.

80017 The incoming entries cause the defined
buffer size to be exceeded. This can be
caused, e.g. by several copying actions
being activated at the same time.

All the copy jobs in the buffer are
deleted.

Terminate the copy process.

80018 All the archives are reconnected by
means of the DB layer, e.g. after
executing the function Open_archive.

Values are then written back into the
tables.

-
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80019 All the archives are separated from the
DB layer and all connections
terminated, e.g. after executing the
function Close_archive.

Values are temporarily buffered and
written in the tables when the
connection is re–established.

There is no connection to the storage
medium and a change can take place.

-

80020 The max. number of simultaneously
activated copy actions has been
exceeded.

Copying is not executed.

Wait until the current copying
actions have been
completed and restart the
last copy action.

80021 An attempt was made to delete an
archive which is still involved with a
copy action.

Deletion has not been executed.

Wait until the current copying
action has been completed
and restart the last action.

80022 An attempt was made to start a
sequence archive, which is not a
sequence archive, from an archive
using the function
Start_sequence_archive.

No sequence archive is created.

Check the project for the
following:

- the function
Start_sequence_archive is
correctly configured.

- the variable parameters are
being correctly provided at
the operating unit.

80023 An attempt was made to copy an
archive to itself.

The archive is not copied.

Check the project for the
following:

- the function Copy_archive
is correctly configured.

- the variable parameters are
being correctly provided at
the operating unit.

80024 The function Copy_archive is
configured not to permit copying when
the target archive already contains data
(Parameter: Write mode).

The archive is not copied.

Modify the function
Copy_archive in the project,
if necessary.

Before initiating the function,
delete the target archive.

80025 The copy action is interrupted.

Data written up to this point is retained.
Deletion of the target table (if
configured) is not executed.

The cancellation is documented by an
error entry $RT_ERR$ at the end of the
target table.

-
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80026 The message is issued after all the
archives have been successfully
initialized. Values are written in the
archives from this moment on. Prior to
this, no values are archived even
though the runtime software is
operating.

-

80027 The internal Flash memory has been
specified as the memory location for an
archive. This is not permissible.

No values will be archived for this
archive and the archive will not be
created.

Configure ”Storage Card” as
the memory location or a
network path.

80028 The message serves as a status
acknowledgment that initialization of the
archives is currently running. No values
are archived until system message
80026 is issued.

-

80029 The number of archives specified in the
message could not be initialized.
Initialization of the archives has been
completed.

The faulty archives are not available for
archiving jobs.

Evaluate the additional
system message, related to
this message, which is also
issued.

Check the configuration, the
ODBC (Open Database
Connectivity) and the
specified drive.

80030 The structure of the table(s) available
does not match the archiving structure
expected.

The archiving process is stopped for
this archive.

Delete the existing tables
manually, in advance.

80032 Archives can be configured with a
function trigger. This is triggered as son
as the archive is full. If runtime is
started and the archive is already full,
the trigger function will not be initiated.

The archive specified no longer
archives data since it is full.

Stop the runtime, delete the
archive and restart the
runtime again.

Or:

Configure a button in the
runtime which contains the
same actions as the function
trigger and press it.

110000 The operating mode status has been
changed. The operating mode is now
offline.

-

110001 The operating mode status has been
changed. The operating mode is now
online.

-
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110002 The operating mode status has not
been changed.

Check the connection to the
PLCs.

Check whether the address
area for the area pointer
“Coordination” in the PLC is
available.

110003 The operating status of the PLC
specified is changed by the function
Connect/Disconnect PLC.

The operating mode is now offline.

-

110004 The operating status of the PLC
specified is changed by the function
Connect/Disconnect PLC.

The operating mode is now online.

-

110005 An attempt was made to use the
function Connect/Disconnect PLC to
switch the specified PLC to operating
mode online although the entire system
is in operating mode Offline. This
switch–over is not permissible.

The PLC remains in operating mode
offline.

Switch the complete system
to operating mode online and
execute the function again.

110006 The Colorado system has been
extended by the addition of the User
Version area pointer.

If the user version is not correct, the
runtime is stopped.

Check the user versions.

Either the wrong version was
entered in the PLC or
configuration or the wrong
configuration was started for
the PLC user version.

120000 The trend is not displayed because an
incorrect axis to the trend, or incorrect
trend, has been configured.

Change the configuration.

120001 The trend is not displayed because an
incorrect axis to the trend, or incorrect
trend, has been configured.

Change the configuration.

120002 The trend is not displayed because the
tag assigned tries to access an invalid
PLC address.

Check whether the data area
for the tag exists in the PLC,
the configured address is
correct or the value range for
the tag is correct.

130000 The action was not executed. Close other applications.

Delete files no longer
required from the hard disk.

130001 The action was not executed. Delete files no longer
required from the hard disk.
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130002 The action was not executed. Close other applications.

Delete files no longer
required from the hard disk.

130003 No target data carrier is inserted. The
process is stopped.

Check, for example,
whether:

- access has been made to
the correct data carrier

- the data carrier has been
inserted

130004 The target data carrier is write–
protected. The process is stopped.

Check whether access has
been made to the correct
data carrier. Remove the
write protection.

130005 The file is write–protected. The process
is stopped.

Check whether access has
been made to the correct file.
Modify the file attributes, if
necessary.

130006 No access to file is possible. The
process is stopped.

Check, for example,
whether:

- access has been made to
the correct file

- the file exists

- a different action prevents
simultaneous access to the
file

140000 Online connection to the PLC has been
successfully established.

-

140001 Online connection to the PLC has been
disconnected.

-

140003 No tag updating or writing is executed. Check the connection and
whether the PLC is switched
on.

Check the parameter
definitions in the Control
Panel using “Set PU/PC
interface”.

Restart the system.

140004 No tag updating or writing is executed
because the access point or the
subrack configuration is incorrect.

Check the connection and
whether the PLC is switched
on.

Check the access point or
the subrack configuration
(MPI, PPI, PROFIBUS) in
the Control Panel with “Set
PU/PC interface”.

Restart the system.
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140005 No tag updating or writing is executed
because the address of the operating
unit is incorrect (possibly too high).

Use a different operating unit
address.

Check the connection and
whether the PLC is switched
on.

Check the parameter
definitions in the Control
Panel using “Set PU/PC
interface”.

Restart the system.

140006 No tag updating or writing is executed
because the baud rate is incorrect.

Select a different baud rate
in ProTool/Pro (according to
subrack, profile,
communication peer, etc.).

140007 No tag updating or writing is executed
because the bus profile is incorrect

(see %1).

The following parameters could not be
entered in the registry:

1: Tslot

2: Tqui

3: Tset

4: MinTsdr

5: MaxTsdr

6: Trdy

7: Tid1

8: Tid2

9: Gap Factor

10: Retry Limit

Check the user defined bus
profile.

Check the connection and
whether the PLC is switched
on.

Check the parameter
definitions in the Control
Panel using “Set PU/PC
interface”.

Restart the system.

140008 No tag updating or writing is executed
because the configuration data is
incorrect:

The following parameters could not be
entered in the registry:

0: General errors

1: Incorrect version

2: Profile cannot be entered in the
registry.

3: Sub–network type cannot be
entered in the registry.

4: Target rotation time cannot be
entered in the registry.

5: Highest address (HSA) incorrect.

Check the connection and
whether the PLC is switched
on.

Check the parameter
definitions in the Control
Panel using “Set PU/PC
interface”.

Restart the system.
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140009 No tag updating or writing is executed
because the module for the S7
communication was not found.

Re–install the module in the
Control Panel using “Set
PU/PC interface”.

140010 No S7 communication peer could be
found because the PLC is switched off.

DP/T:

The option “Is not active as the only
master” is set in the Control Panel
under “Set PU/PC interface”.

Switch the PLC on.

DP/T:

If only one master is
connected to the network,
deactivate the option “Is not
active as the only master” in
“Set PU/PC interface”.

If the network has more than
one master, switch this
master on. Do not modify
any settings here, otherwise
a bus fault may occur.

140011 No tag updating or writing is executed
because communication is interrupted.

Check the connection and
that the communication peer
is switched on.

140012 There is an initialization problem (e.g.
when ProTool/Pro RT has been
terminated in the Task Manager).

Or: another application (e.g. STEP7,
WINCC) is active with different bus
parameters and the driver cannot be
started with the new bus parameters
(e.g. baud rate).

Restart the operating unit.

Or start ProTool/Pro RT first
and then the other
applications.

140013 The MPI cable is not plugged in and,
thus, there is no power supply.

Check the connections.

140014 - Modify the operating unit
address in the configuration
in PLC.

140015 Incorrect baud rate

Or: incorrect bus parameter (e.g. HSA)

Or: OP address HSA

Or: incorrect interrupt vector (interrupt
does not arrive at the driver)

Correct the incorrect
parameters.

140016 - Change the interrupt
number.

140017 - Change the interrupt
number.

140018 The consistency check was deactivated
by Simotion Scout.

Only one appropriate note appears.

Activate the consistency
check with Simotion Scout
again and load the
configuration in the project
once more.
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140019 Simotion Scout loads a new project in
the PLC.

Connection to the PLC is interrupted.

Wait until the end of the
reconfiguration.

140020 The version in the PLC and that in the
configuration (FWD file) do not match.

Connection to the PLC is interrupted.

Remedy:

- Load the current version in
the PLC using Simotion
Scout.

- Generate the anew project
using ProTool CS, end
ProTool RT and start with
the new configuration.

150000 No more data is read or written.

Possible causes:

- The cable is defective.

- The PLC does not respond, is
defective, etc.

- Connection is established via the
wrong interface.

- The system is overloaded.

Check that the cable is
plugged in, the PLC is
operational, the correct
interface is used.

Reboot the system if the
system message is
displayed continuously.

150001 Connection is re–established because
the cause of the interruption has been
eliminated.

-

160000 No more data is read or written.

Possible causes:

- The cable is defective.

- The PLC does not respond, is
defective, etc.

- Connection is established via the
wrong interface.

- The system is overloaded.

Check that the cable is
plugged in, the PLC is
operational, the correct
interface is used.

Reboot the system if the
system message is
displayed continuously.

160001 Connection is re–established because
the cause of the interruption has been
eliminated.

-

160010 There is no connection to the server
because the server identification (CLS–
ID) cannot be established.

Values cannot be read or written.

Check the access rights.

160011 There is no connection to the server
because the server identification (CLS–
ID) cannot be established.

Values cannot be read or written.

Check, for example,
whether:

- the server name is correct

- the computer name is
correct

- the server is registered
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160012 There is no connection to the server
because the server identification (CLS–
ID) cannot be established.

Values cannot be read or written.

Check, for example,
whether:

- the server name is correct

- the computer name is
correct

- the server is registered

Information for experienced
users:

Interpret the value from
HRESULT.

160013 The specified server was started as
InProc Server. This has not been
released and may possibly lead to
incorrect behavior because the server
is running in the same process area as
the ProTool/Pro RT runtime software.

Configure the server as
OutProc Server or Local
Server.

160014 Only one OPC server project can be
started on a PC/MP. An error message
appears when an attempt is made to
start a second project.

The second project has no OPC server
functionality and cannot be located as
an OPC server from external sources.

Do not start a second project
with OPC server functionality
on the computer.

170000 1) S7 diagnostics messages are not
displayed because it is not possible to
logon to the S7 diagnostics with this
unit. The service program is not
supported.

-

170001 1) The S7 diagnostics buffer cannot be
displayed because communication with
the PLC has been switched off.

Switch the PLC online

170002 1) The S7 diagnostics buffer cannot be
displayed because reading in the
diagnostics buffer (SZL) was terminated
due to an error.

-

170003 1) The display of an S7 diagnostics
message is not possible. An internal
error %2 has been reported.

-

170004 1) The display of an S7 diagnostics
message is not possible. An internal
error with error class %2, error number
%3 has been reported.

-

170007 1) It is not possible to read in the S7
diagnostics buffer (SZL) because it was
terminated with an internal error with
error class %2 and error code %3.

-
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1) The optional parameter %1 at the start

of the message may contain an
identification for the S7 connection
when several S7s are in parallel
operation and are connected to
diagnostics equipment.

180000 A component/OCX receives
configuration data with a version
identification which is not supported.

Install a newer component.

180001 The system is overloaded because too
many actions have been activated
simultaneously.

Not all the actions can be executed,
some are rejected.

Remedy:

- Increase the configured
cycle times or basic clock.

- Generate the messages
slower (polling).

- Trigger the scripts and
functions at greater intervals.

- If the message appears
more frequently:

Restart the operating unit.

180002 The screen keyboard could not be
activated.

Possible causes:

- The screen keyboard is not generally
supported under Windows 95.

- The file “TouchInputPC.exe” was not
registered due to an incorrectly
executed Setup.

If Windows 95 is not
available:

Install the runtime software
again.

190000 It is possible that the tag will not be
updated.

-

190001 The tag is updated following an error
status after the cause of the last error
state has been eliminated (return to
normal operation).

-

190002 The tag is not updated because
communication to the PLC has been
switched off.

Switch on communication via
the function “Set Online”.

190004 The tag is not updated because the
configured address is not available for
this tag.

Check the configuration.

190005 The tag is not updated because the
configured PLC type does not exist for
this tag.

Check the configuration.

190006 The tag is not updated because it is not
possible to map the PLC type in the tag
type.

Check the configuration.
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190007 The tag values are not modified
because the connection to the PLC has
been terminated or the tag is offline.

Switch Online or re–establish
connection to the PLC.

190008 The threshold values configured for the
tag have been violated, e.g. by

- an entered value,

- a function,

- a script.

Observe the configured or
current threshold value of the
tag.

190009 An attempt has been made to assign a
value to a tag which is outside the value
range permitted for this type.

E.g. a value of 260 entered for a byte
tag or a value of –3 for a signless word
tag.

Observe the value range for
the tag type.

190010 The tag is described with values too
often (e.g. in a loop triggered by a
script).

Values are lost because the maximum
of 100 event have been stored in the
buffer.

Increase the time interval
between the multi–writing
tasks.

190011 Possible causes:

- The value entered could not be written
to the configured PLC tag because it
was either above or below the value
range.

- The input is rejected and the original
value is reset.

Ensure that the value
entered is within the value
range of the PLC tags.

190011 Possible causes:

- Connection to the PLC has been
interrupted.

Check the connection to the
PLC.

190012 It is not possible to convert a value from
a source format to a target format, e.g.:

- A value should be assigned to a
counter which is outside the valid,
PLC–dependent value range.

- A tag of the type Integer should be
assigned a value of the type String.

Check the value range or
type of the variable.
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190100 The area pointer is not updated
because the configured address for this
area pointer is not available.

Type:

1 Event messages

2 Alarm messages

3 PLC acknowledgment

4 Operating unit acknowledgment

5 LED assignment

6 Trend request

7 Trend transfer 1

8 Trend transfer 2

No.:

is the consecutive number displayed in
ProTool/Pro.

Check the configuration.

190101 The area pointer is not updated
because it is not possible to map the
PLC type in the area pointer type.

Parameter type and no.:

See message 190100

-

190102 The area pointer is updated following
an error status after the cause of the
last error state has been eliminated
(return to normal operation).

Parameter type and no.:

See message 190100

-

200000 Coordination is not executed because
the address configured in the PLC does
not exist/has not been set up.

Change the address or set
up the address in the PLC.

200001 Coordination is not executed because
the address configured in the PLC
cannot be written.

Change the address or set
up the address in the PLC in
an area which can be
written.

200002 Coordination is not carried out at the
moment because the address format of
the area pointer does not match the
internal storage format.

Internal error

200003 Coordination can be executed again
because the last error status has been
eliminated (return to normal operation).

-

200004 It is possible that coordination is not
executed.

-
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200005 No more data is read or written.

Possible causes:

- The cable is defective.

- The PLC does not respond, is
defective, etc.

- The system is overloaded.

Check that the cable is
connected and the PLC is in
order.

Reboot the system if the
system message is
displayed continuously.

210000 Jobs are not processed because the
address configured in the PLC does not
exist/has not been set up.

Change the address or set
up the address in the PLC.

210001 Jobs are not processed because the
address configured in the PLC cannot
be written to/read from.

Change the address or set
up the address in the PLC in
an area which can be written
to/read from.

210002 Commands are not executed because
the address format of the area pointer
does not match the internal storage
format.

Internal error

210003 The job mailbox is processed again
because the last error status has been
eliminated (return to normal operation).

-

210004 It is possible that the job mailbox is not
processed.

-

210005 A PLC job was triggered by an
impermissible number.

Check the PLC program.

210006 A fault occurred while attempting to
execute the PLC job. The PLC job is,
therefore, not executed.

Observe the subsequent/previous
system message, if appropriate.

Check the parameter types
in the PLC job.

Compile the configuration
again.

220000 2) - -
2) A WinCC channel provides the

message texts via an interface. This
text is issued via this message.
ProTool/Pro RT has no influence on
this texts.

220001 The tag is not downloaded because the
associated channel/the unit does not
support downloading the data type
bool/bit.

Change the configuration.

220002 The tag is not downloaded because the
associated channel/the unit does not
support downloading the data type
byte.

Change the configuration.

220003 The associated driver could not be
uploaded. It is possible that the driver is
not installed.

Install the driver by re–
installing ProTool/Pro RT.
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220004 Communication is terminated and no
update is executed because the cable
is not connected or is defect etc.

Check the connection.

220005 Communication is running. -

220006 The connection is established to the
specified PLC at the specified interface.

-

220007 The connection to the specified PLC at
the specified interface is disconnected.

Check that:

- the cable is plugged in

- the PLC is OK

- the correct interface is used

- the configuration is OK
(interface parameters,
protocol settings, PLC
address).

Reboot the system if the
system message is
displayed continuously.

220008 The PLC driver cannot access the
specified interface or open it. It is
possible that another application is
using this interface or an interface is
used which is not available on the
target device.

There is no communication with the
PLC.

Terminate all the programs
which access the interface
and reboot the computer.

Use another interface which
is available in the system.

230000 The value entered could not be
accepted. The entered value is rejected
and the previous value is specified
again.

Either the value range has been
exceeded or impermissible characters
were entered.

Enter a permissible value.

230002 Since the current password level is
inadequate or the password dialog box
was closed with ESC, the entry is
rejected and the previous value is
specified again.

Activate an adequate
password level using Login.

230003 Changeover to the specified screen is
not executed because the screen is not
available/configured. The current
screen remains selected.

Configure the screen.

Check the selection function.

240000 3) Runtime is operating in Demo mode.

There is either no Stopcopy license or it
is defect.

Load the license.
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240001 3) Runtime is operating in Demo mode.

Too many tags are configured for the
installed version.

Load an adequate license /
powerpack.

240002 3) Runtime is operating with a time–limited
standby authorization.

Restore the full
authorization.

3) The specified text comes from the
component resources.

240003 Authorization cannot be executed.

ProTool/Pro RT is running in Demo
mode.

Restart ProTool/Pro RT or
reinstall it.

240004 Error during reading the standby
authorization.

ProTool/Pro RT is running in Demo
mode.

Restart ProTool/Pro RT,
install the authorization or
repair the authorization (see
Commissioning Instructions
Software Protection).

250000 The tag in the specified line in
Status/Control is not updated because
the address configured for this tag is
not available.

Check the set address and
then check that the address
has been set up in the PLC.

250001 The tag in the specified line in
Status/Control is not updated because
the PLC type configured for this tag is
not available.

Check the set address.

250002 The tag in the specified line in
Status/Control is not updated because
it is not possible to map the PLC type in
the tag type.

Check the set address.

250003 No connection could be established to
the PLC. The tags will not be updated.

Check the connection to the
PLC. Check that the PLC is
switched on and online is
activated.

260000 A password has been entered which is
unknown to the system. Therefore, the
lowest password level has been set.
This corresponds to the status following
Logout.

Enter a known password in
the password input field (with
corresponding level).

260001 A password has been entered whose
assigned level does not permit
execution of the function.

The password level currently set is
displayed for information purposes.

Modify the password level in
the password input field
enter a password with a
sufficiently high level.

260003 The user has logged off from the
system. If the password level is 0, no
user is logged on.

-



Release 12/01 HMI System Messages

ProTool User Manual How to configure graphics-based units
A5E00149244 D-21

Number Effect/Cause Remedy

270000 A tag is not displayed in the message
because it attempts to access an invalid
address in the PLC.

Check whether the data area
for the tag exists in the PLC,
the configured address is
correct or the value range for
the tag is correct.

270001 There is a unit–dependent limit as to
how many messages may be queued
simultaneously in order to be displayed
(see GHB). This limit has been
exceeded.

The display no longer contains all the
messages.

However, all the messages are
recorded in the message buffer.

-

270002 Messages are displayed from an
archive are displayed for which there is
no data in the current project.

Placeholders are issued for the
messages.

Delete older archive files, if
necessary.

270003 The service cannot be set up because
too many devices was to set up this
service.

A maximum of four devices can
execute this action.

Connect fewer operating
units which want to use the
service.

280000 Connection is re–established because
the cause of the interruption has been
eliminated.

-

280001 No more data is read or written.

Possible causes:

- The cable is defective.

- The PLC does not respond, is
defective, etc.

- Connection is established via the
wrong interface.

- The system is overloaded.

Check that the cable is
plugged in, the PLC is
operational, the correct
interface is used.

Reboot the system if the
system message is
displayed continuously.

280002 A connection is used which requires a
function module in the PLC.

The function block has replied.
Communication can now proceed.

-



HMI System Messages Release 12/01

ProTool User Manual How to configure graphics-based units
D-22 A5E00149244

Number Effect/Cause Remedy

280003 A connection is used which requires a
function module in the PLC.

The function block does not reply.

Check that the cable is
plugged in, the PLC is
operational, the correct
interface is used.

Reboot the system if the
system message is
displayed continuously.

The remedy is dependent on
the error code:

1: The function block must
set the COM bit in the
response container.

2: The function block may
not set the ERROR bit in the
response container

3: The function block must
respond within the specified
time (timeout)

4: Establish an online
connection to the PLC

280004 The online connection to the PLC has
been interrupted. There is no data
exchange at present.

Check the PLC parameters
in ProTool Pro: baud rate,
block length, station address.

Check that the cable is
plugged in, the PLC is
operational, the correct
interface is used.

Reboot the system if the
system message is
displayed continuously.

290000 The tag could not be read or written. It
is assigned the start value.

The message can be entered in the
message buffer for up to four more
failed tags, if necessary. After that, the
message number 290003 is issued.

Check in the configuration
that the address has been
set up in the PLC.

290001 An attempt has been made to assign a
value to a tag which is outside the value
range permitted for this type.

The message can be entered in the
message buffer for up to four more
failed tags, if necessary. After that, the
message number 290004 is issued.

Observe the value range for
the tag type.
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290002 It is not possible to convert a value from
a source format to a target format.

The message can be entered in the
message buffer for up to four more
failed tags, if necessary. After that, the
message number 290005 is issued.

Check the value range or
type of the variable.

290003 This message is issued when message
number 290000 is triggered more than
five times.

In this case, no further individual
messages are generated.

Check in the configuration
that the tag addresses have
been set up in the PLC.

290004 This message is issued when message
number 290001 is triggered more than
five times.

In this case, no further individual
messages are generated.

Observe the value range for
the tag type.

290005 This message is issued when message
number 290002 is triggered more than
five times.

In this case, no further individual
messages are generated.

Check the value range or
type of the variable.

290006 The threshold values configured for the
tag have been violated by values
entered.

Observe the configured or
current threshold value of the
tag.

290007 There is a difference between the
source and target structure of the
recipe currently being processed. The
target structure contains an additional
data record tag which is not available in
the source structure.

The data record tag specified is
assigned its start value.

Insert the specified data
record tag in the source
structure.

290008 There is a difference between the
source and target structure of the
recipe currently being processed. The
source structure contains an additional
data record tag which is not available in
the target structure and therefore
cannot be assigned.

The value is rejected.

Remove the specified data
record tag in the specified
recipe from the project.

290010 The storage location configured for the
recipe is not permitted.

Possible causes:

Impermissible characters, write
protected, data medium full or does not
exist.

Check the path specification
configured.
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290011 The data record specified by the
number does not exist.

Check the source for the
number (constant or variable
value).

290012 The recipe specified by the number
does not exist.

Check the source for the
number (constant or variable
value).

290013 An attempt was made to save a data
record under a data record number
which already exists.

The process is not executed.

Remedy:

- Check the source for the
number (constant or variable
value).

- Delete the data record
beforehand.

- Change the function
parameter

“Overwrite”.

290014 The file specified to be imported could
not be found.

Check that:

- Check the file name.

- Ensure that the file is in the
specified directory.

290020 Acknowledgement that downloading of
data records from operating unit to PLC
has started.

-

290021 Acknowledgement that downloading of
data records from operating unit to PLC
has been completed without any errors.

-

290022 Acknowledgement that downloading of
data records from operating unit to PLC
has been terminated due to an error.

Check the configuration:

- have the tag addresses
been set up in the PLC?

- does the recipe number
exist?

- does the data record
number exist?

- has the function
parameters ”Overwrite”?

290023 Acknowledgement that downloading of
data records from the PLC to the
operating unit has started.

-

290024 Acknowledgement that downloading
data records from the PLC to the
operating unit has been completed
without any errors.

-
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290025 Acknowledgement that downloading of
data records from the PLC to the
operating unit has been terminated due
to an error.

Check the configuration:

- have the tag addresses
been set up in the PLC?

- does the recipe number
exist?

- does the data record
number exist?

- has the function
parameters ”Overwrite”?

290026 An attempt has been made to
read/write a data record although the
data mailbox is not free at present.

This error may occur in the case of
recipes for which downloading with
synchronization has been configured.

Set the data mailbox status
to zero.

290027 No connection to the PLC can be
established at present. Therefore, the
data record can neither be read nor
written.

Possible causes:

No physical connection to the PLC (no
cable plugged in, cable is defect) or the
PLC is switched off.

Check the connection to the
PLC.

290030 This message is issued after
reselecting a screen that contains a
recipe display in which a data record
has already been selected.

Reload the data record from
the data medium or retain
the current values.

290031 While saving, it was detected that a
data record with the specified number
already exists.

Overwrite the data record or
cancel the process.

290032 While exporting data records, it was
detected that a file with the specified
name already exists.

Overwrite the file cancel the
process.

290033 Confirmation request before deleting
data records.

-

290040 A data record error with error code %1
has occurred which cannot be
described in more detail.

The action was canceled.

It might be that the data mailbox has
not been installed correctly on the PLC.

Check that the data carrier,
the data record, the data
mailbox and, if necessary,
the connection to the PLC.

Trigger the action again after
waiting a short period.

If the error occurs again,
please contact the Customer
Support. Specify the error
code displayed.
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290041 A data record or file cannot be saved
because the data medium is full.

Delete files no longer
required.

290042 An attempt was made to execute
several recipe actions simultaneously.

The last action was not executed.

Trigger the action again after
waiting a short period.

290043 Confirmation request before storing
data records.

-

290044 The data store for the recipe has been
destroyed and will be deleted.

-

290050 Acknowledgement that the exportation
of data records has started.

-

290051 Acknowledgement that the exportation
of data records has been completed
successfully.

-

290052 Acknowledgement that the exportation
of data records has been terminated
due to errors.

Ensure that the structure of
the data records on the data
medium and the current
recipe structure on the
operating unit are identical.

290053 Acknowledgement that the importation
of data records has been started.

-

290054 Acknowledgement that the importation
of data records has been completed
successfully.

-

290055 Acknowledgement that the importation
of data records has been terminated
due to errors.

Ensure that the structure of
the data records on the data
medium and the current
recipe structure on the
operating unit are identical.

290056 The value in the specified line/column
could not be read/written without errors.

The action was canceled.

Check the specified
line/column.

290057 The tags of the recipe specified have
been switched from operating mode
“offline” to “online”.

Each modification of a tag in this recipe
is now immediately transferred to the
PLC.

-
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290058 The tags of the recipe specified were
switched from operating mode “online”
to “offline”.

Modifications to tags in this recipe are
no longer immediately transferred to the
PLC but must be transferred there
explicitly by means of downloading a
data record, if necessary.

-

290059 Acknowledgement that the specified
data record has been stored
successfully.

-

290060 Check–back message that the data
record memory has been successfully
erased.

-

290061 Check–back message, that erasing the
data record memory was aborted with
errors.

-

290068 Request to confirm whether all data
records in the recipe should be deleted.

-

290069 Request to confirm whether all data
records of all recipes should be deleted.

-

290070 The data record specified is not
contained in the import file.

Check the source of the data
record number or data
record name

(constant or tag value).

300000 Process monitoring (e.g. using PDiag or
S7–Graph) has been incorrectly
programmed: More messages are
queued than specified in the technical
data of the CPU. No further ALARM_S
messages can be managed by the CPU
and reported to operating systems.

Change the CPU
configuration.

310000 An attempt is being made to print too
many protocols simultaneously.

Since only one protocol can be printed
at a time, the print job is rejected.

Wait until printout of the last
active protocol has been
concluded.

Repeat the print job, if
necessary.

310001 An error occurred on triggering the
printer. The protocol is either not
printed or printed with errors.

Evaluate the additional
system message, related to
this message, which is also
issued.

Repeat the print job, if
necessary.
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320000 The movements have already been
indicated by another device.

The movements can no longer be
served.

Select the movements on the
other display units and select
the movement screen on the
required display unit.

320001 The network is too complex.

The defective operands cannot be
displayed.

Display the network in AWL.

320002 No diagnostics–capable alarm
messages have been selected.

The units related to the alarm
messages could not be selected.

Select a diagnostics–capable
alarm message in the
message screen
ZP_ALARM.

320003 No alarm messages exist in respect of
the selected unit.

No network can be displayed in the
detail display.

Select the defective unit in
the general view screen.

320004 The required signal statuses could not
be read by the PLC.

The defective operands cannot be
established.

Check the consistency
between the configuration on
the display unit and the PLC
program loaded.

320005 The project contains ProAgent
partitions which are not installed.

No ProAgent diagnostics can be
performed.

In order to run the project,
install the ProAgent option
packet.

320014 The selected PLC cannot be evaluated
for ProAgent.

The message display configured with
the Evaluate_message_display_fault
function could not be found.

Check the parameters of the
Evaluate_message_dis-
play_fault

function.
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E Abbreviations

Overview

The meanings of the abbreviations used in this documentation are as follows:

ANSI American National Standards Institute

AS 511 Protocol of the PU interface on the SIMATIC S5

ASCII American Standard Code for Information Interchange

CPU Central Processing Unit

DP Distributed I/O

HMI Human Machine Interface

LED Light-emitting diode

MPI Multipoint Interface (SIMATIC S7)

OLE Object Linking and Embedding

OP Operator panel

PC Personal computer

PU Programming unit

RAM Random access memory: memory with random access
(working memory)

PLC Programmable logic control

TP Touch panel

PRC People's Republic of China



Abbreviations Release 12/01

ProTool User Manual How to configure graphics-based units
E-2 A5E00149244



Release 12/01 Index

ProTool User Manual How to configure graphics-based units
A5E00149244 I-1

Index
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Abbreviations............................................... E-1
acknowledgement .............................5-52, 5-77
Acknowledging ALARM_S messages........5-77
Acknowledging messages.................5-50, 5-77
acquisition cycle tag ...................................5-29
Address ......................................................5-32
Address of tags...........................................5-32
ALARM_S...................................................5-64

Acknowledgement ..................................5-77
Communication process .........................5-75
Configure message text..........................5-71
Display classes .......................................5-66
Print messages .......................................5-78
Set...........................................................5-68
Update ....................................................5-73

ALARM_S messages .................................5-71
ALARM_S-messages .................................5-72
AM ............................................................... E-1
ANSI ............................................................ E-1
Anti-alias.................................. 4-18, 5-11, 5-40
Area ............................................................4-10
Area pointers ..............................................5-61
Array ...........................................................5-44
Array tags ...................................................5-26
Array tags for history trends .......................5-44
Array tags for pattern trends.......................5-44
ASCII ........................................................... E-1
Asian languages............................5-128, 5-129
Assigning icons for local function

keys.......................................................5-111
Assigning icons to function keys ..............5-111
Assigning operator permissions ...............5-114

B

Bar graph
Multiplexing (example)............................5-38

Bit trigger ................................. 5-13, 5-41, 5-43
Button .........................................................5-21

Light indicator .........................................5-15
Select Screen .........................................5-21
Set/Reset Bit ...........................................5-21
Touch panel ............................................5-21
Using as direct keys................................5-23

Buttons with fixed functions........................5-95

C

Changing the operating mode with
a current display (example) .................... 5-97

Character sets .......................................... 5-121
Language dependent............................ 5-121

Clock trigger ......................................5-13, 5-41
Color............................................................. 5-7
Combine multiple functions ........................ 5-94
Combined input/output fields...................... 5-18
Combining multiple functions ..................... 5-94
Communication ............................................B-1
Communication areas for messages ......... 5-61
Communication areas for non-SIMATIC

PLCs .................................................B-1, B-3
Interface area............................................B-2
Keyboard assignment...............................B-8
LED assignment .....................................B-11

Communication sequence in the event of
ALARM_S messages ............................. 5-75

Compilation .................................................. 6-5
Complete devices......................................... 1-3
Components of a ProTool project ................ 4-6
Configuration .......................................2-3, 5-68

Selecting display classes........................ 5-68
Configuration notes for touch panels ......... 4-15
Configuration requirements in Asian

languages ............................................. 5-128
Configuration software ................................. 1-1
Configure printers....................................... 5-55
Configuring a multilingual project ............. 5-124
Configuring alarm messages

(example)................................................ 5-79
Configuring color change ......................... 5-112
Configuring controls ................................... 5-16
Configuring display elements ....................... 5-8
Configuring dynamic attributes................. 5-112
Configuring operator prompting ............... 5-110
Configuring with ProTool integrated in

SIMATIC STEP 7...................................... 3-1
Constraints ................................................... 7-7
Constraints on projects in Asian

languages ............................................. 5-129
Constraints with printing............................... 7-7
Control and acknowledgement bits ..............B-3
Control and acknowledgement bits

for non-SIMATIC PLCs.............................B-3
Convert a project ........................................ 4-18
Convertible ................................................. 4-18
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CPU ............................................................. E-1
Create a project ............................................4-8
Creating a customized printout

(example) ..................................................7-8
Creating area pointers................................4-10
Creating graphics (Tips) ...............................8-3
Creating icons for function keys ...............5-111
Cross-Reference ........................................4-27
Cross-reference (overview) ........................4-27
Custom project user interface in

ProTool .....................................................5-7

D

Data ............................................................5-32
Data areas for non-SIMATIC PLCs......B-1, B-3

Interface area........................................... B-2
Keyboard assignment .............................. B-8
LED assignment .................................... B-11

Data areas in the interface area .................. B-6
Data areas in the interface area for non-

SIMATIC PLCs......................................... B-6
Data mailbox.............................................5-106
Data record...............................................5-103

Create ...................................................5-108
Definition ...............................................5-103
Identify ..................................................5-106
Transfer.................................................5-108

Decimal places of tags .................................8-7
Decimal places with tags............................5-31
Device overview for ProTool ........................1-3
Device type.................................................4-28
Direct transfer

Data records: ........................................5-108
Directly accessing values on the PLC..........6-4
Discard .......................................................4-26
Display........................................................5-96
Display actual values..................................5-12
Display classes...........................................5-66

Select ......................................................5-68
Display in ....................................................4-27
Display messages on the operating

unit .................................................5-56, 5-59
Displaying and changing the date

on the operating unit (example) ............5-101
Displaying date ...........................................5-96
Displaying messages ........................5-45, 5-59
Displaying messages on the

operating unit ..........................................5-56
Displaying operating and process

states ......................................................5-45
Displaying time ...........................................5-96
Displays

Actual values...........................................5-12

Download .....................................................6-3
MPI............................................................6-3

Download the project file ..............................6-2
Downloading.................................................6-6
Downloading the executable project file.......6-2
Drive a port or relay....................................5-51
Drive ports ..................................................5-23
Driving the LED ........................................5-113
Dynamic attributes....................................5-112

E

Edit Message standard screen on the TP 27
(example)................................................5-81

Editing language.......................................5-117
EM ................................................................E-1
Enter setpoints ..................................5-17, 5-18
Error messages during compilation..............6-5
Error messages while downloading .............6-6
Evaluating key operation..........................5-113
Evaluating key operation of function keys 5-113
Evaluating key operation of system keys .5-113
Event messages export file (example) .......5-87
Events for triggering functions....................5-90
Exchanging text with translators ..............5-126

F

Fields ............................................................5-2
Fields flashing ..........................................5-112
Fixed window................................................5-2
Flashing......................................................B-11
Force VAR....................................................6-4
Foreign languages....................................5-117

Export/import ........................................5-126
System requirements............................5-116

Function key ...............................................5-19
Function parameters ..................................5-92
Functions....................................................5-89

Example.......................................5-97, 5-101

G

Getting started in ProTool ............................2-2
Global function key.....................................5-19
Graphic displays...........................................1-3
Graphic lists................................................5-39
Graphics ............................................5-11, 5-40

Bar graph ................................................5-14
Character graphics .................................5-10
Trends.....................................................5-41
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H

Hiding objects ...........................................5-112
HMI .............................................................. E-1

I

Import
Text for translation ................................5-126

Incorporating ALARM_S messages in
ProTool ...................................................5-72

Indirect transfer
Data records: ........................................5-108

Information about the project......................4-28
Input............................................................5-18
Input field

Multiplexing.............................................5-37
Input/output fields .......................................5-18
Instance DB..................................................3-1
Integrated operation .....................................7-3
Interface area .............................................. B-2

Control and acknowledgement bits ......... B-3
Data areas ............................................... B-6

Interrupt ......................................................5-44
Data plotting on trends............................5-44

Interrupt data plots on trends .....................5-44
Invincible buttons.................................5-7, 5-21

K

Keyboard assignment...............................5-122
Language dependence.........................5-122

Keyboard assignment of the operating unit. B-8
Keyboard assignment of the operating unit

for non-SIMATIC PLCs ............................ B-8

L

Labeling function keys..............................5-111
Language dependence.............................5-122

Character sets ......................................5-121
Keyboard assignment ...........................5-122
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