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Siemens Industry Online Support 
This entry is taken from Siemens Industry Online Support. The following link takes 
you directly to the download page of this document: 
http://support.automation.siemens.com/WW/view/en/67688155 
 
 
 
 

http://support.automation.siemens.com/WW/view/en/67688155�
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Warranty and Liability 
 

Note The application examples are not binding and do not claim to be complete 
regarding configuration, equipment and any eventuality. The application 
examples do not represent customer-specific solutions. You are responsible for 
ensuring that the described products are used correctly. These application 
examples do not relieve you of your responsibility to use sound practices in 
application, installation, operation and maintenance. When using these 
application examples, you recognize that we will not be liable for any 
damage/claims beyond the liability clause described. We reserve the right to 
make changes to these application examples at any time and without prior 
notice. If there are any deviations between the recommendations provided in this 
application example and other Siemens publications (e.g. catalogs), the contents 
of the other documents shall have priority. 

 
We do not accept any liability for the information contained in this document. 
Any claims against us – based on whatever legal reason – resulting from the use of 
the examples, information, programs, engineering and performance data etc., 
described in this application example shall be excluded. Such an exclusion shall 
not apply in the case of mandatory liability, e.g. under the German Product Liability 
Act (“Produkthaftungsgesetz”), in case of intent, gross negligence, or injury of life, 
body or health, guarantee for the quality of a product, fraudulent concealment of a 
deficiency or violation of fundamental contractual obligations (“wesentliche 
Vertragspflichten”). The damages for a breach of a substantial contractual 
obligation are, however, limited to the foreseeable damage, typical for the type of 
contract, except in the event of intent or gross negligence or injury to life, body or 
health. The above provisions do not imply a change in the burden of proof to your 
disadvantage. 
 
It is not permissible to transfer or copy these application examples or excerpts 
thereof without express authorization from Siemens Industry Sector. 
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1 Automation Task 
 

1.1 Overview 

Background 
Users of station control systems (SAS, Station Automation System) increasingly 
demand the application of standardized communication protocols to enable 
combining various devices and systems independent of the manufacturer. 
In power generation and supply in particular, but also in many process automation 
applications of medium voltage switchgear, standard IEC 61850 has established 
itself. Standardized communication and engineering is the key to interoperability 
here. 
The technology component SIMATIC PCS 7 PowerControl supports precisely this 
standard  - IEC 61850 (Using the IEC 61850 protocol). 

Integration of protective gear 
Protective gear is used for controlling, switching, measuring and automating of 
electrical installations and networks. This refers to intelligent devices, so-called 
"Intelligent Electronic Devices" (IED), which record abnormal operating states and 
errors and automatically react accordingly. 
In the case of an error, only the affected plant sections are switched off. This is 
achieved by safe, fast and selective switching-off, diagnosing and reporting of 
failed plant sections. 
 
Figure 1-1: Configuration 

 
 

This protection technology is generally used in supply networks > 1 kV. The 
relevant variables are recorded indirectly with current and voltage transformers. 
The active elements used are circuit-breakers and protective gear. 
In low voltage networks, the plant protection is generally realized by means of 
fuses and circuit-breakers. 
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Task of the protective gear 
The task of protective gear is to allow operational over-current yet prevent undue 
loads on lines and devices. Due to hazardous effects in the case of a short-circuit, 
the affected equipment must be switched off within the shortest of time. 
Otherwise, an error should only disrupt the supply for as few consumers as 
possible. Therefore, the protective devices within the network must detect the error, 
switch off by themselves or send trigger commands to the respective switches. The 
protective devices should be set in such a way as to allow for selective switch-off. 
 
 

1.2 Requirements 

Apart from the high requirements for local automation, many SIMATIC PCS 7 
projects also have the option to integrate and monitor the medium voltage 
switchgear, which supplies the power, into a total automation solution. In order to 
fulfill this requirement, the new technology component SIMATIC PCS 7 
PowerControl was developed. It enables integrating switchgear for the power 
supply using the IEC 61850 communication protocol in the familiar look&feel of 
SIMATIC PCS 7. 
In an electrical switchgear, the electrical power is distributed or transformed. 
Loads/consumers are bundled in load groups. The network nodes designed as 
busbars use switchgear to connect incoming and outgoing lines, the so-called 
branches. When designing such a switchgear, the change of the network topology 
for failures, such as enabling and grounding of operating tools for maintenance 
works must also be considered. 
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2.1 Automation of electrical switchgear with PowerControl 
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2 Solution 
2.1 Automation of electrical switchgear with PowerControl 

Systems for automating electrical switchgear for the power supply of the process 
were in the past strictly separated from systems for process automation. SIMATIC 
PCS 7 PowerControl now enables combining the process automation and the 
automation of electronic switchgear for medium voltage in the range of 4 to 30 kV 
in a control system. 
Figure 2-1: Combination of control system and power management 

 
 
For switchgear automation, i.e. for protection, control measuring and monitoring 
tasks in the electronic power transmission and distribution, “Intelligent Electronic 
Devices” (IEDs) are used, e.g. SIPROTEC switchgear or interoperable “third-party” 
devices. These can also be integrated homogenously into the SIMATIC PCS 7 
process control system via the Ethernet TCP/IP communication protocol 
IEC 61850. 
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2.1.1 Application of the SIPORTEC 7SJ80 protective device 

The SIPROTEC Compact 7SJ80 can, for the line protection of high and medium 
voltage networks, be used with grounded, low-resistance grounded, isolated or 
compensated starpoint design. As a supplement for transformer differential 
protection, the IED fulfils all tasks of a reserve protection. 
 
SIPROTEC Compact 7SJ80 offers flexible protection functions. For fulfilling 
individual requirements, up to 20 additional protection functions can be added to 
the already existing protection functions. This enables realizing, for example, a 
frequency change protection or a reverse power protection. 
 
Figure 2-2: SIPROTEC protection device 7SJ80 

 
 
The protection device supports the control of the circuit-breaker as well as further 
switchgear and automation functions. The integrated programmable logic (CFC) 
enables the user to add own functions for automating his switchgear (interlocking). 
Users can furthermore create user-definable messages. 
LEDs to be assigned by the user and a six-line display provide for a unique and 
clear display of the process states. The up to 9 function keys enable quickly and 
safely reacting in each situation which guarantees high operational safety. 
 

Note Further information is available via the Siemens internet page: 

Protection device SIPROTEC 7SJ80 

 

http://www.energy.siemens.com/hq/de/automatisierung/stromuebertragung-verteilung/schutz/siprotec-compact/ueberstromzeitschutz/�
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2.1.2 Using the IEC 61850 protocol 

The IEC 61850 standard of the International Electrotechnical Commission (IEC) 
describes an Ethernet-based substation automation protocol (transmission 
protocol) for the protection and process control of electrical switchgear of medium 
and high voltage technology (station automation). 
 
The IEC 61850 protocol contains more comprehensive definitions than other 
protocols and is aimed at: 
• interoperability between devices from different manufacturers 
• long-term investment security 
• efficient exchange of object-oriented data models between engineering 

systems 
The standard has been defined in collaboration with manufacturers and users to 
provide a uniform, future-proof basis for protection technology, communication and 
control of switchgear. IEC 61850 has established itself as the worldwide 
communication standard on the automation of switchgear marked. 
 

Note More information is available via the IEC 61850 website. 

 
 
 

2.2 Advantages of PCS 7 PowerControl 

The automation based on SIMATIC PCS 7 PowerControl has decisive advantages 
compared with previous automation solutions. 
The homogenous user interface for process automation and station automation 
simplifies the operation and at the same time reduces the risk of operating errors in 
the overall system. 

Cost reduction 
• Only one system for automation and switchgear 
• No cabling between automation and switchgear necessary 
• Investment security through standardization 

Reduction of operational costs 
• Fewer operating staff due to one system for the process and energy sections 

of the plant 
• Simplified maintenance through a uniform General view 
• Higher availability due to fewer components  –  Lower life cycle costs 

http://www.tissues.iec61850.com/default.mspx�
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2.3 Typical fields of application 
Table 2-1 

Industry Task 

Chemical industry 

Food & 
Beverages 

Water 

Glass / Solar 

Pharmaceutical 
industry 

Oil & Gas 

Cement 

• Reliable and operationally safe power supply 
• Load shedding at power cuts 
• Preventing peak loads 
• High energy consumption → Energy saving 
• Electrical energy = Raw material, management 

of energy 
• Optimizing the production 



2 Solution 
2.4 Hardware and software components used 
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2.4 Hardware and software components used 

The document on hand was generated using the following components: 

Hardware components 
Table 2-2 

Component MLFB/order number 

IPC 547D 6ES7660-3AC11-2CA0 
SIPROTEC 7SJ80x 7SJ8031-1EA96-3FB3 
Power supply  

Software components 
Table 2-3 

Component MLFB/order number Note 

SIMATIC PCS 7 V8.0 SP1 6ES7658-5AX08-0YA5  
SIMATIC PCS 7 
PowerControl OS 
Engineering V8.0 SP1 

6ES7658-7LX08-0YA5 Engineering expansion 

SIMATIC PCS 7 
PowerControl OS Runtime 
V8.0 SP1 

6ES7658-7MX08-0YA0 OS expansion 

 
 
 

Note For configuring the SIPROTEC 7SJ80 protection device the DIGSI software is 
used in addition. In our text example, DIGSI is operated on one computer 
together with SIMATIC PCS 7. 

Generally, however, we recommend installing both software components on a 
separate PC each. 

 



2 Solution
2.5 Objective of this documentation
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2.5 Objective of this documentation 

This document describes the simple application of PCS 7 PowerControl and the 
integration of the SIPROTEC 7SJ80 protection device in the SIMATIC PCS 7 
process control system. 
Furthermore, changes in the application are explained to you using the 
PC_FEEDER example project. 
 

Main contents of this document 
This document deals with the following main points on the topic of PCS 7 
PowerControl: 
• Configuration and settings 
• Commissioning 
• Changes in the application 
 

Validity 
SIMATIC PCS 7 V8.0 Upd1 or higher and SIMATIC PCS 7 PowerControl V8.0 SP1 
 

Assumed knowledge 
Basic knowledge of SIMATIC PCS 7 and DBA engineering is assumed. 
 



3 Installation 
3.1 Hardware installation 
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3 Installation 
This chapter describes which hardware and software components have to be 
installed. It is also important to read the descriptions, manuals and any delivery 
information supplied with the products. 

3.1 Hardware installation 

 

Hardware installation 
The figure below shows the hardware setup of the application. 
 
Figure 3-1: IPC 547D and SIPROTEC 7SJ80 protection device 

 

NOTICE The setup guidelines for SIPROTEC protection devices must generally be 
followed. For respective information see manual: 
7SJ80xx Manual V4.6 A4 

 

http://www.energy.siemens.com/ecc_pool/SIPROTEC/2c1f6be1-ab79-4f47-8a74-5ef528503b4b/7SJ80xx_Manual_A4_V040301_de.pdf�
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3.2 Installation of the PCS 7 PowerControl software 

 

Hardware requirements 
The PowerControl software is a technology component for the SIMATIC PCS 7 
process control system and can therefore only be operated on devices which meet 
the hardware requirements of PCS 7. 
The requirements are described in the readme file of the PCS 7 software. In 
contrast to the PCS 7 readme file, however, a storage capacity of 4 GB is required 
for large projects with more than 7500 process objects for the ES station. The 
virtual main memory should at least have 4GB. 
 

Software requirements 
A SIMATIC PCS 7 V8.0 Upd.1 installed and licensed according to the respective 
station type is required. 

Runtime environment 
Running PCS 7 PowerControl V8.0 SP1 requires, apart from PCS 7 V8.0 Upd.1, 
one of the following operating systems: 
• Microsoft Windows XP Professional SP3 (32Bit) 
• Microsoft Windows Server 2003 SP 2 Standard Edition (32Bit) 
• Mircosoft Windows Server 2003 R2 SP2 Standard Edition (32Bit) 
• Microsoft Windows 7 Ultimate SP1 (32Bit) 
• Microsoft Windows 7 Ultimate SP1 (64Bit) 
• Microsoft Windows Server 2008 SP2 Standard Edition (32Bit) 
• Microsoft Windows Server 2008 R2 SP1 Standard Edition (64 Bit) 

Communication 
For the communication, the object oriented IEC 61850 protocol is used. "TCP/IP" is 
used as basic transmission protocol and the client - server communication is based 
on the "MMS" standard (Manufacturing Messaging Specification). 
Furthermore, two "Peer-to-Peer" services are used for the real-time 
communication, which are based on the Ethernet protocol. 



3 Installation 
3.2 Installation of the PCS 7 PowerControl software 
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Installation 
The following table shows the installation steps to be performed. 
Table 3-1: PCS 7 TeleControl installation steps 

Step Action 

1.  Installation of the operating system 
2.  Installation of “third party” software 
3.  Installation of SIMATIC PCS 7 
4.  Installation of SIMATIC PCS 7 PowerControl 
5.  Installation of the authorizations and licenses 

 
The following figure shows the package selection of the PCS 7 PowerControl 
setup. 
Figure 3-2: PCS 7 PowerControl installation dialog 

 
 
 

Note The “PowerControl Setup Guide” documentation is referred to for a detailed 
description. 



3 Installation
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3.3 Functional expansion through PowerControl 

SIMATIC PCS 7 PowerControl expands the familiar engineering and the process 
management functions of the control system. 
Specific function and performance characteristics of PCS 7 PowerControl are: 

Engineering 
• Object library with function blocks, symbols and faceplates 
• Object-oriented type/instances concept 
• Automatic generation of the objects for the operator station 
• Integration of new IEDs through the import of the IEC 61850 device description 

(ICD) 
 

Process management 
• Faceplates for SIPROTEC protection devices in SIMATIC PCS 7 APL style 
• Uniform behavior for alarms, messages, operator control and monitoring 
• Diagnostics functionality for each IED 
 



4 Configuration and Settings 
4.1 Configuring the ES/OS station 
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4 Configuration and Settings 
4.1 Configuring the ES/OS station 

4.1.1 Creating a SIMATIC PCS 7 project 

A new project is created in the SIMATIC Manager. A PC station is configured in 
this project. 

SIMATIC Manager 
1. Create a new project in the SIMATIC Manager via "File > New…". 
2. Assign a project name and specify the storage path for the project. 

 
 
3. Configure a SIMATIC PC station in the project via context menu command 

"Insert New Object > SIMATIC PC Station". 
 

Figure 4-1: SIMATIC PCS 7 project with PC station 

 



4 Configuration and Settings
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4. Configure the SIMATIC PC station via HW Config, as familiar with PCS 7, 

using a WinCC application. 

 
 
5. Assign meaningful names for the OS application, for example,  

“OS_PowCon_01”. 

 
 

6. In the Component view of the project you go to the Plant View. Here you call 
the Plant Hierarchy of the folder structure via "Options > Plant Hierarchy > 
Settings". 



4 Configuration and Settings 
4.1 Configuring the ES/OS station 
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7. Make your selections regarding the representation of the Plant Hierarchy. The 

checkbox "Derive picture hierarchy from the plant hierarchy" must remain 
active in order to display the picture of the PH on the OS. 

 
 

WinCC Explorer 
8. For a more consistent later configuration, it is recommended to open the OS 

application and creating at least one process archive value in the Tag Logging 
configuration. 

 



4 Configuration and Settings
4.1 Configuring the ES/OS station
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9. The process value archive can be simply and quickly created with the "Archive 

wizard". 

 
 
10. Subsequently, you open the OS project editor in the WinCC Project Editor. It is 

used to make the basic configuration of the OS. Simply confirm the basic 
settings by pressing the "OK" button. 

 
 

This completes the configuration of the SIMATIC PCS 7 project. 



4 Configuration and Settings 
4.2 Configuration of the SIPROTEC protection device 
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4.2 Configuration of the SIPROTEC protection device 

The individual configuration and settings of the SIPROTEC devices are performed 
with the DISGI 4 software. The configuration is performed offline. The created data 
are subsequently loaded via the respective interfaces of the SIPROTEC 
protection device. 

4.2.1 Creating a project 

An individual project must be created in the SIMATIC Manager for the SIPROTEC 
protection device. 
 

Note The protection device cannot be integrated into the already created PCS 7 
project. 

 
1. Create a new project in the SIMATIC Manager via "File > New…". 
2. Assign a project name and specify the storage path for the project. 

 
 

 
Figure 4-2: PCS 7 project for the protection device 

 
 



4 Configuration and Settings
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4.2.2 Creating and managing the protection device 

SIPROTEC protection devices are added to the project structure from the device 
catalog. 
1. In the project structure you select the "Devices" folder. 
2. The device catalog is called up via the context menu "Add new project > 

SIPROTEC device". 
3. Select protection device "7SJ801" from the catalog. 

 
 

4. Drag the IED to the "Devices" folder in the project tree via drag&drop. 
5. In the following dialog you need to set the device parameters according to the 

MLFB ordering number. 

 
 

6. For the "Port B" parameter settings you press the "L…" button on the right. For 
"Port B" you need to select the IEC61850 protocol. 

 
 



4 Configuration and Settings 
4.2 Configuration of the SIPROTEC protection device 
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7. Within the IEC 61850 network each station requires a unique name. This name 

is assigned by you in the properties dialog of the SIPROTEC device. 

 
 

In the SIMATIC Manager, the created SIPROTEC device is now shown in the 
Component view. 
 

Figure 4-3: Configured protection device in the Component View 

 



4 Configuration and Settings
4.2 Configuration of the SIPROTEC protection device

  

SIMATIC PCS 7 PowerControl 
V 1.0, Entry ID: 67688155 25
 

C
op

yr
ig

ht
 ©

 S
ie

m
en

s 
A

G
 2

01
3 

A
ll 

rig
ht

s 
re

se
rv

ed
 

4.2.3 Create IEC station 

All SIPROTEC devices created in a project are combined in a so-called IEC61850 
station. 
 
1. In the SIMATIC Manager you create a IEC61850 station: 

 
 
2. The protection device must now be assigned to the IEC61850 station. To do 

this, open the Properties dialog of the station. 

 
 
3. In the upper part, all pending stations are displayed. These must now be 

adopted in the list of actual stations. Mark the protection device 7SJ801 and 
press the “Add” button. 
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4. Acknowledge your selection with the "OK" button. 

 
 
5. In the next step the network address for the protection device must be 

assigned. Open the IEC61850 station. Double-clicking the station opens the 
"DIGSI system configurator". 

6. The network is established here and the IP address for the SIPROTEC 
protection device is set. 

 
 
7. Close the configuration. 
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8. Open the Properties dialog of the IEC61850 station again. Select the "Update" 

tab. 

 
 
9. Press the "Update all parameter sets" button to map data to the IEC object. 
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4.2.4 Loading the configuration to the protection device 

The configured settings are now transferred to the protection device. SIPROTEC 
7SJ80 must be initialized for this. 
The initialization gives the protection device its own identity. This transfers the 
parameter settings and assigns the TCP/IP a unique address. The initialization is 
performed via the appropriate USB interface of the protection device. 
 
1. Select the protection device in the SIMATIC Manager. 
2. Call the "Initialize device…" command via the context menu. 

 
 

3. A new protection device is not automatically detected. Therefore, you need to 
select the IED via the "Select a device…" button. 

4. Select your respective protection device by means of the MLFB number. 

 
 

5. Press the “OK” button to initialize the SIPROTEC 7SJ80. 
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4.2.5 Testing the operability 

After transferring the parameters, the protection device is accessible via the set IP 
address in the network. 
The diagnostic functions can be used during commissioning via the website which 
provides the Ethernet EN100 module. 
 
1. For calling the website, you enter the IP address into the address line of the 

Internet Explorer. At the end of the IP address you enter the suffix "/home". In 
this example, the entry reads: "http:192.168.1.150/home" 

2. Confirm your input with "Enter" key. 
 

Figure 4-4: Website of SIPROTEC 7SJ80 

 
 
A wide range of information on protective devices can be called up via the left hand 
navigation. 
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4.2.6 Exporting the protection device description 

For the OS configuration described in the following chapter, the so-called device 
description ICD (IED Configuration Description) of the SIPROTEC device is 
required. 
It is created with DIGSI and stored in an XML file. The basis is the “Substation 
Configuration Description Language” (SCL). 
 

Note It is recommended to save the device description file in a sub-directory of 
the SIMATIC PCS 7 project (e.g. SIPROTEC). DBA in particular always 
requires access to the data (next chapter). Furthermore, this archives the 
data consistently. 

 
1. Select the protection device in the SIMATIC Manager. 
2. Select the "Export device…" command via the context menu. 
3. Create the storage location and assign a meaningful file name. Select "*.icd" 

as the file name. 

 
 

4. Click "OK" to generate the device description. 
5. The following query once more points out the storage path of the device 

description. 
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4.3 Configuring the PCS 7 PowerControl functions via the 
DBA tool 

The Data Base Automation (DBA) engineering software generates, in conjunction 
with a library (OS symbols, OS faceplates, OS diagnostic view), the OS database 
with picture hierarchy, tags, alarms, alarm messages as well as the specific 
faceplates and block symbols. 
The desktop of the DBA tool is divided into 4 areas: 

– Plant View – Generating the Plant Hierarchy (PH) and assigning  
the AS instances 

– Object Editor: configuring the OS instances 
– Physical objects (IED) 
– AS Object Editor: configuring the IED instances 

 
Figure 4-5: DBA tool 
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4.3.1 Creating the DBA project 

1. Start DBA configuration tool via "START > Programs > Siemens Automation > 
SIMATIC > DBA > PCS 7 DBA". 

2. Select "File > New Project…". 

 
 

3. Save your newly created DBA project via "File > Save Project As…". 
 

Note Saving should be repeated from time to time, since the DBA changes in the 
project are not saved automatically. 

 

Add PC station 
4. Go to the "PC Station View" tab. 
5. There you enter a PC station into the project. Call the context menu of the 

project and select "Add PC Station". 

 
 

6. Assign a computer name for the PC station. 
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Add OS application 
7. Add a PCS 7 OS application to the PC station. Call the context menu of the 

station and select "Add Application". 

 
 

8. In the dialog window which opens, you select the "PCS 7 OS" application of 
type Server/Single Station. 

 
 

9. Acknowledge your selection with the "OK" button. 
10. The OS application can also be renamed. 
11. In the Value field of the “Offline MCP File“ you enter the mcp-project file 

including the path (connection with the configured OS project) of the respective 
project. 
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12. In the next step you trigger reading the OS project. Select the OS application in 

the DBA tool and select the “Refresh OS Cache” command from the context 
menu. 

 
 
13. Confirm the following dialog box with “Yes”. 
14. After reading the OS project, the process value archive created in the PCS 7 

project must be selected in the Value field of the “Tag Logging Archive”. To do 
so, open the drop-down menu: 
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Set PH 
15. The project-specific settings of the Plant Hierarchy are made via the Properties 

of the DBA project. Select “File > Properties...”. 
16. In the “Properties” dialog box you select the “Hierarchy” tab. 

 
 

Note The settings for the PH must match those of the configuration in the Plant 
Hierarchy view of the SIMATIC Manager (see page 20). 
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4.3.2 Creating a technology object 

Creating IED in DBA 
To create a new protection device, the "AS View" tab must be selected. 
1. In the window for physical objects you call up the context menu. 
2. Select the "Add AS Source Node…" command. 

 
 
3. In the "AS Node Name" field you enter the name of the protection device 

7SJ80. The fields for identification are filled by the .icd file, which you select via 
the "…" button, and must not be changed. 

 
 

Note Select the .icd file, which you have created at 4.2.6 Exporting the protection 
device description. 
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4. Acknowledge the "Configure Connection" button to enter the TCP/IP address 

of the SIPROTEC 7SJ80. 

 
 

5. Confirm you entry with the "OK" button. 
 

Note The parameter settings (via the "Configure Parameters" button) can be retained 
without changes. 

 
6. The ICD files are read after pressing the "OK" button. This may take some time 

depending on scope and size. 
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Creating a technology object (instance) 
The technology object is created in the DBA using the "Create New AS Object”. 
When reading the .icd file, the DBA checks which technology objects can be 
applied to the IED and offers them in a selection. 
7. Mark the protection device (AS View) and select the "Create New AS Object…" 

command via the context menu. 

 
 
8. Select instance editor of the protection device from the tree structure. This 

maps the whole IED in an object. As instance type you select "PC_FEEDER" 
from the selection list. Then complete with the "Execute" button. 

 
 
9. The created IED instance has now been created in the AS Object Editor. 
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4.3.3 Creating a Plant Hierarchy 

For the PCS 7 OS the picture hierarchies are automatically created on the basis of 
the Plant Hierarchy created in DBA. 
The folders of the hierarchy are assigned to an existing OS. DBA creates a picture 
for each folder. 

Plant area 
Below, the plant area to be output later in the OS is created first. 
1. Mark the DBA project in the "Plant View". 
2. Call up the "Add Folder" command via the context menu to create an 

appropriate folder structure for the plant areas. 

 
 
3. The system automatically generates the respective area picture. 
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Object assignment 
The AS objects from the AS Objects view are assigned to the plant area in the OS 
area object view. 
4. Drag the AS objects to the respective folder in the PH via drag&drop. 

 
 

Note Objects marked green and areas point to changes in the project. These must still 
be compiled and adopted in the OS project. 

 

OS assignment 
The created plant areas of the PH must be assigned to the OS. 
5. Select the new plant area in the "Plant View". 
6. Select the "Edit Folder Properties…" command from the context menu. 
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7. Select the OS in the subsequent dialog. 

 
 

Compiling the DBA project 
Now, the project can be compiled and be used for a preliminary test in Runtime. 
This writes the DBA configuration to the OS. 
8. Select "Run > Start Compilation" via the menu. 

 
 
9. In the compilation dialog, the options can be adopted without changes. Press 

the "Compile" button. 

 
 

Note The protocol of the compilation can be saved after completion. Click the button 
“Save” button. 

 
10. If the compilation was completed without errors, the OS can be adopted to 

Runtime.
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5 Starting the Application 
 
After the project was compiled in the DBA, the configured symbols are available in 
the respective process image and are generally functional. 
1. Open the OS in the SIMATIC Manager. 
2. Press the "Run" button in the WinCC Editor. 
3. Open the existing faceplates. 
 

Figure 5-1: OS Runtime 
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The PC_FEEDER object is used for all inputs or outputs of a busbar. It can also be 
configured as individual circuit-breaker, ground electrode or isolator. Furthermore, 
it is used for switchable machine contactors. 
 



6 Changes in the Application 
6.1 Power direction display 

 

44 
SIMATIC PCS 7 PowerControl 

V 1.0, Entry ID: 67688155 
 

C
op

yr
ig

ht
 ©

 S
ie

m
en

s 
A

G
 2

01
3 

A
ll 

rig
ht

s 
re

se
rv

ed
 

6 Changes in the Application 
 
For project-specific adjustment of symbols and faceplates, there are some 
attributes which should be checked and, if necessary, be adjusted. The process 
picture must be opened in "WinCC Graphics Designer" and the properties of the 
respective symbols be displayed. 

6.1 Power direction display 

There is the option of displaying the power direction in the switchgear by means of 
a direction arrow. It is configured with the attributes “DirectionUp” (power direction 
up) and “DirectionDown” (power direction down). 

Table 6-1 

No Action 

1 Open the project screen in the "WinCC Graphic Designer". 

 
2 If the attributes for "DirectionUp" and "DirectionDown" each have been set to "Yes" in the Object 

Properties… 

 



6 Changes in the Application
6.1 Power direction display

  

SIMATIC PCS 7 PowerControl 
V 1.0, Entry ID: 67688155 45
 

C
op

yr
ig

ht
 ©

 S
ie

m
en

s 
A

G
 2

01
3 

A
ll 

rig
ht

s 
re

se
rv

ed
 

No Action 

3 …the power direction display in OS Runtime will point up as well as down. 

 
4 For a downward current flow display, the "DirectionDown" attribute is assigned with "Yes" and 

"DirectionUp" with "No".  

 
5 

 

 
 

Note If both attributes are configured to “No”, the power direction arrow is hidden. 
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6.2 Hiding non-existent values 

All technology objects have the option of hiding certain values. This functionality is 
controlled via the internal WinCC tag “Status5”, whose start value can be 
configured in the DBA. 
Each hidden value in the faceplate is assigned a bit in the “Status5 tag”. If the 
respective bit is set to 0, the value is hidden in the faceplate. 
The default value of “Status5” is 0xFFFFFFFF. This means, that all values 
assigned to "Status5", are shown in the faceplate. 
The assignment of the values to the bits of the “Status5 tags” is available in the 
Appendix (7.2 Assigning the "Status5" tag). 
 

Note In the DBA tool, an input of the hexadecimal values is not possible. These must 
be converted into the appropriate decimal value and be entered as such. 

 
Figure 6-1: Status5 in the DBA Project Editor 

 
 

Table 6-2 

No Action 

1 In the faceplate, various power, current and voltage value fields are displayed. These connected 
with the “Status5” tag. 
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No Action 

2 When changing the default value in the DBA tool… 

 
3 … the faceplate of the protection device shows that not all values are displayed anymore. 

 
4 In the following example, a simple input/output field was configured in the Graphic Designer. This 

I/O field is connected with the "Status5 tag". 
Input "0" forces a total hiding, "1" leads to unhiding the values. 

 

 
 

Note Each change in the DBA tool must be transferred to the OS via a "Compile". 
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6.3 PC_FEEDER switch representation 

 
The PC_FEEDER faceplate offers a flexible representation of the switches (e.g. 
circuit-breaker, ground electrode, isolator). Up to 5 switches can be represented 
dynamically in 6 fields. 
The representation occurs using randomly combinable symbols (see Appendix), 
which are aligned in 6 fields (field 1-6). 
Additionally, there are 4 fields (field 7-10), which form the connection between 
fields 1-6. 

Configuration fields 
The figure below shows the arrangement of the fields in relation to the switch 
representation. 
Figure 6-2: Configurations fields for PC_FEEDER 

 
 
The “Field_XX_Code” symbol attributes are used for configuring the fields in which 
the symbols are displayed. Only the two-digit symbol codes are entered (7.1 
Symbols/Codes). 

Configuration of the switches 
The following switches can be configured in PC_FEEDER: 
• Q0 (e.g. circuit breaker) 
• Q1 (e.g. isolator) 
• Q2 (e.g. additional isolator) 
• Q8 (e.g. ground electrode) 
• Q9 (e.g. additional ground electrode) 
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Switches can only be represented in the fields 1-6. In the fields it is possible to 
display and configure up to two switches (Figure 6-2: Configurations fields for 
PC_FEEDER: Feld_03 – Circuit-breaker/isolator combination). 
 

Table 6-3 

No Action 

1 Open the project screen in the "WinCC Graphics Designer". 

 
2 Select the properties dialog of “PC_FEEDER”. The assignment of the switches to the fields is configured 

with the symbol attributes “QX_Field” and “QX_SubField”, which exist for each of the 5 switches. 
“QX_Field” describes the number of the field in which the switch is located (possible values: 1-6). 
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No Action 

3 If attribute “QX_Field” is configured to 0, this switch is not displayed in the faceplate (no display of the 
position and no control). 

 
4 “QX_SubField” represents one of both “sub-fields” of “QX_Fields”. This is required in order to represent 

two switches in one field. 
“QX_SubField“ can ONLY take on value 1 or 2. If, for example, the circuit-breaker (Q0) and the isolator 
(Q1) are displayed in field 3, the configuration must be as follows: 
• Q0_Field   3 
• Q0_SubField  1 
• Q1_Field   3 
• Q1_SubField  2 
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No Action 

5 This means, that both switches are represented in field 3. Q0 is assigned the sub-field 1 (switch 1), Q1 the 
sub-field 2 (switch 2). 
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6.4 Labeling the fields and switches of PC_FEEDER 

 
Table 6-4 

No Action 

1 Open the project screen in the "WinCC Graphics Designer". Select the Properties dialog of PC_FEEDER. 

 
2 Using the “FieldDescriptor_XX” symbol attributes, the label of fields 1-6 can be configured. 
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No Action 

3 Using the DBA attributes “QX_DESC” the names of the individual switches are configured in the faceplate. 

 

 
 



Appendix 
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7 Appendix 
 

7.1 Symbols/Codes 

 

Symbol codes for PC_FEEDER 
Table 7-1 

Symbol Code Remark 

 

00 

Empty field 

 

01 

Circuit-breaker with isolator and carriage (2 
switches) 

 

02 

Circuit-breaker 

 

03 

Isolator and ground electrode (2 switches) 

 

04 

Isolator 

 

05 

Simple connection 

 

06 

Isolator 

 

07 

Isolator 

 

08 

Ground 

 

09 

 

 

10 

Isolator (with carriage) 
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Symbol Code Remark 

 

11 

Ground 

 

12 

Isolator with carriage and ground (2 switches!) 

 

13 

Generator 

 

14 

Motor 

 

Symbol codes for connections 
Table 7-2 

Symbol Code Remark 

 00 Empty field 

 01 1 connection under field 5 (for field 10) 

 02 Connection between 2 rows (for field 8,9,10) 

 03 Connection via field 1 and 2 (for field 7) 

 04 Connection between 2 rows (for field 8,9) 

 05 Connection via field 1 (for field 7) 

 06 Connection via field 1 (for field 7) 

 07 Connection (for field 8,9,10) 

 08 Connection between 2 rows (for field 8,9) 

 09 Connection between 2 rows (for field 8,9) 

 10 Connection via field 1 and 2 (for field 7) 
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7.2 Assigning the "Status5" tag 

PC_FEEDER 
Table 7-3 

Bit… Feature Remark 

0 I_A Current phase 1 

1 I_B Current phase 2 

2 I_C Current phase 3 

3 U_A Voltage phase 1 – Ground 

4 U_B Voltage phase 2 – Ground 

5 U_C Voltage phase 3 – Ground 

6 U_AB Voltage phase 1 – Phase 2 

7 U_BC Voltage phase 2 – Phase 3 

8 U_CA Voltage phase 3 – Phase 1 

9 U Voltage 

10 P Power 

11 Q Wattless power 

12 S Apparent power 

13 F Frequency 

14 PF Cosinus Phi 

15 WpForw Power counter P Forward 
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8 Glossary 
 

DBA 
DataBase Automation – Engineering Tool for integrating different protocols in 
PCS 7 

ICD 
IEC 61850 Device Description – Standardized device descriptions which are 
integrated for the engineering of switchgear automation in the system. 

IEC 
International Electrotechnical Commission – Commission based in Geneva for 
standards in the field of electrical engineering and electronics. 

IED 
Intelligent Electronic Device – For switchgear automation, i.e. for protection, 
control, measuring and monitoring tasks in electronic power transmission and 
distribution, Intelligent Electronic Devices (IEDs) are used. 

WinCC 
Windows Control Center – PC-based process visualization system of Siemens. 
WinCC is used as Human Machine Interface (HMI) in the process control system 
SIMATIC PCS 7. 
 



Related Literature 
 

 

58 
SIMATIC PCS 7 PowerControl 

V 1.0, Entry ID: 67688155 
 

C
op

yr
ig

ht
 ©

 S
ie

m
en

s 
A

G
 2

01
3 

A
ll 

rig
ht

s 
re

se
rv

ed
 

  

9 Related Literature 
 
The following list is by no means complete and only provides a selection of 
appropriate information. 
 

Table 9-1 

 Topic Title 

\1\ Link to this document http://support.automation.siemens.com/WW/view/en/67688155 
\2\ Industry Online Support http://support.automation.siemens.com 
\3\ IEC 61850 http://www.tissues.iec61850.com/default.mspx 
\4\ SIMATIC PCS 7 

PowerControl 
www.siemens.com/simatic-pcs7/powercontrol 

\5\ Protection technology http://www.energy.siemens.com/hq/en/automation/power-
transmission-distribution/protection/siprotec-compact/overcurrent-
protection/7sj80.htm 

 
 
 

10 History 
 

Table 10-1 

Version: Date: Revisions  

V1.0 02/2013 First release 
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