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DANGER  
indicates that death or severe personal injury will result if proper precautions are not taken. 
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CAUTION  
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CAUTION  
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NOTICE  
indicates that an unintended result or situation can occur if the corresponding information is not taken into 
account. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
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label devices, systems and circuits in accordance with established safety practices and standards. 

Prescribed Usage 
Note the following: 

WARNING  
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recommended by Siemens. Correct, reliable operation of the product requires proper transport, storage, 
positioning and assembly as well as careful operation and maintenance. 

Trademarks 
All names identified by ® are registered trademarks of the Siemens AG. The remaining trademarks in this 
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owner. 

Disclaimer of Liability 
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Preface 

New functionality in SIMATIC iMap V3.0 SP1 
The following new developments in configuring, commissioning and testing systems are 
available in SIMATIC iMap V3.0 SP1: 
● Complex data types that can contain further complex date types, such as 

multidimensional arrays and structures of arrays and structures, are supported for 
devices in PROFINET Runtime version V2.3 and higher. 
Starting in SIMATIC iMap STEP 7 AddOn V3.0 SP4, PROFINET interfaces and 
PROFINET components of such devices can be created.  

● Maintenance states of the PROFINET devices as from PROFINET Runtime Version V2.3 
are displayed as icons in the online view. 

● SIMATIC iMap can be executed under MS Windows Vista. 
● Version numbers for functions can be specified when creating the PROFINET component 

and are displayed in SIMATIC iMap in the properties of the PROFINET component. 
● Generation of the PROFINET devices without proxy functionality can be accelerated 

optionally. 
● Typical values and absolute limits are displayed at power and utilization parameters of 

the devices as from PROFINET Runtime Version V2.3. 

Purpose of the Manual 
This manual offers support for systems engineering and commissioning in SIMATIC iMap.  
It is intended for engineers working in the area of project planning, commissioning and 
servicing of automation systems with Component Based Automation.  
We advise you to read the "Getting Started with SIMATIC iMap" documentation. It offers you 
a comfortable introduction to working in SIMATIC iMap. 

Scope of the manual 
The manual is valid for the software package SIMATIC iMap V3.0 SP1 or higher. 

Basic knowledge requirements 
This manual requires general knowledge of automation engineering.  
Users should also be familiar with the operation of computers or auxiliary programming 
equipment similar to PCs (e.g., programming devices) operating under the operating system 
platform Windows 2000, XP or Vista. As the use of SIMATIC iMap on SIMATIC devices is 
based on the STEP 7 basic software, you should also know how to handle the basic 
software as described in the "Programming with STEP 7" manual. 
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Guide 
The structure of this manual is based on three subject areas. 
● Chapter 1 offers an overview of the overall concept, and of the product structure of 

Component Based Automation. 
● Chapter 2 describes the software installation 
● Chapters 3 to 6 describe the work in SIMATIC iMap 
● The appendix contains a summary of all control elements as reference. 
● Important terms are explained in the glossary. 
● The index contains important key words, which allow quick access to associated text 

passages. 

Position in the information landscape 
This manual is part of the SIMATIC iMap documentation package. The documentation is 
installed with the software and includes the electronic manuals in PDF format: 
● Getting Started in SIMATIC iMap  

Brief introduction to working with Component Based Automation and SIMATIC iMap. 
● Configuring Plants in SIMATIC iMap – the current manual  

Contains detailed information and instructions for systems engineering and 
commissioning with the help of SIMATIC iMap. 

● Creating PROFINET components  
Contains detailed information and instructions on the the creation of PROFINET 
components in STEP 7, and on applications for SIMATIC devices in Component Based 
Automation. 

● Commissioning systems, tutorial  
Contains examples and step-by-step instructions, starting with the creation of PROFINET 
component, and concluding with the commissioning of the entire system. 

The entire documentation is included in your SIMATIC iMap software as basic help in HTML 
format. 
For general information on PROFINET and PROFINET CBA , refer to the PROFINET 
system description. This manual is included in the SIMATIC Manual Collection.  

Notes  
The next sections provide a guideline to the 
● Creation of PROFINET components in STEP 7 
● Configuring of systems in SIMATIC iMap 
● Commissioning of systems in SIMATIC iMap 
Each section contains a "thread" that leads you through all the manuals of Component 
Based Automation and SIMATIC iMap dealing with the relevant topic. The chapters are 
organized based on the order of the tasks to perform.  
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Notes on the creation of PROFINET components in STEP 7 
Readership: Systems and mechanical engineers 

 
 Chapter  
Manual Required Optional Header 

 1 Getting Started - Introduction  
 2 Step 1: Defining PROFINET components 

Getting Started 
with SIMATIC iMap 

 3 Step 2: Creating PROFINET components in 
STEP 7  

1.1  Basic procedure 
1.3  Creating projects in STEP 7 
1.4.1  Properties of the PROFINET interfaces 
 1.4.2 Using the PROFINET interface editor 
1.4.3  Creating PROFINET interfaces 
 1.4.4 Changing PROFINET interfaces 
1.6.1  Creating PROFINET components in SIMATIC 

Manager 
 1.7 Importing PROFINET components into a 

library 
 1.8 Modifying PROFINET components 

Creating 
PROFINET 
components 

 2 SIMATIC devices as PROFINET components 
Commission 
systems, tutorial 

 2 Part 1: Creating PROFINET components 

Notes on the configuration of systems in SIMATIC iMap  
Readership: Plant designers 

 
 Chapter  
Manual Required Optional Header 

 1 Getting Started - Introduction  Getting Started 
with SIMATIC iMap  4 Steps 3 to 6: Configuring plants in SIMATIC 

iMap 
 1 Component Based Automation - overview  
2  Installing SIMATIC iMap 
3.1  Running SIMATIC iMap 
 3.3 Operating philosophy 
4.1  Basic procedure in system engineering 
4.2.1  Creating a new project 
4.2.2  Opening and closing the project 
4.3.2  Creating a new library 
4.3.3  Opening and closing libraries 
4.3.4  Importing PROFINET components 

Configuring 
systems 

4.4.1  Integrating PROFINET components in a 
SIMATIC iMap project 
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 Chapter  
Manual Required Optional Header 

4.4.2  Connecting devices in the network view  
4.4.2.4  Assigning addresses  
4.4.3  Interconnecting technological functions 
 3.3.3 Reading and editing properties 
4.4.4  Utilization check 
 4.4.1.2 Creating nested charts  
 4.5 Working with modified PROFINET 

components  
 4.5.2 Replacing instances  
4.2.5  Generating the Project 
 4.2.7 Documenting and printing a project 
4.2.4  Saving and backing up project data 
 4.3.6 Backing up and restoring libraries 
 5.11.1 Creating OPC symbol files 
 3.3.2 Step 2: Configuring system no. 1 in SIMATIC 

iMap 
 3.4.2 Step 2: Configuring system no. 2 in SIMATIC 

iMap 

Commission 
systems, tutorial 

 3.5.2 Step 2: Configuring system no. 3 in SIMATIC 
iMap 

Notes on system configuration in SIMATIC iMap  
Readership: Plant operators 

 
 Chapter  
Manual Required Optional Header 

 1 Getting Started - Introduction  
 5 Step 7: Generation and download 
 6 Step 8: Diagnostics 

Getting Started 
with SIMATIC iMap 

 7 Step 9: Visualizing process data  
2  Installing SIMATIC iMap 
3.1  Running SIMATIC iMap 
 3 Operating SIMATIC iMap 
 4 Configuring systems 
5.1  Basic commissioning procedures 
 5.2 Overview of the online functions 
5.3  Downloading programs and interconnections 
5.4  Diagnostics information in the online view 
5.5  Analyzing PROFINET components 
5.6  Checking availability of the devices 

Configuring 
systems 

5.7  Comparing online and offline data 
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 Chapter  
Manual Required Optional Header 

5.8  Viewing and setting online values in the plant 
view 

5.9  Online test using the tag table 
 5.10 Online device analysis 
5.12.1  Special features of systems containing 

SIMATIC devices 
5.12.2  Online operation of SIMATIC devices 
 5.12.3 Editing instances in STEP 7 

Commissioning 
systems, tutorial 

 3 Part 2: Systems commissioning 

Conventions 
Menu commands are written in bold letters, for example. Project > Save. 
Placeholders are set in angled brackets, for example: <file name>. 

Further assistance 
If you have any questions relating to the products described in this manual, and do not find 
the answers in this documentation, please contact your Siemens partner at our local offices.  
● SIMATIC partners (http://www.siemens.com/automation/partner)  
● Component Based Automation (http://www.automation.siemens.com/cba)  

See also 
SIMATIC Technical Support (Page 259) 

http://www.siemens.com/automation/partner
http://www.siemens.com/automation/partner
http://www.automation.siemens.com/cba
http://www.automation.siemens.com/cba


Preface  
  

 Configuring Plants in SIMATIC iMap 
8 Configuration Manual, 01/2008, A5E00716614-02 



 

Configuring Plants in SIMATIC iMap 
Configuration Manual, 01/2008, A5E00716614-02 9 

Table of contents 
 Preface ...................................................................................................................................................... 3 
1 Component Based Automation - overview............................................................................................... 13 

1.1 PROFINET CBA - concept...........................................................................................................13 
1.2 PROFINET components ..............................................................................................................16 
1.3 Technological functions ...............................................................................................................21 
1.4 Devices of PROFINET components ............................................................................................22 
1.5 New engineering concept with SIMATIC iMap ............................................................................27 
1.6 User documentation for SIMATIC iMap and Component Based Automation..............................31 

2 Installing software.................................................................................................................................... 33 
2.1 Prerequisites ................................................................................................................................33 
2.2 Installing .......................................................................................................................................34 
2.3 Authorization ................................................................................................................................36 

3 Operating SIMATIC iMap......................................................................................................................... 39 
3.1 Starting SIMATIC iMap ................................................................................................................39 
3.2 Help functions in SIMATIC iMap..................................................................................................41 
3.3 Operating philosophy ...................................................................................................................42 
3.3.1 Objects and object hierarchy .......................................................................................................42 
3.3.2 Editing objects..............................................................................................................................45 
3.3.3 Reading and editing properties ....................................................................................................48 
3.4 Windows and views .....................................................................................................................49 
3.4.1 SIMATIC iMap user interface.......................................................................................................49 
3.4.2 Representation and navigation ....................................................................................................51 
3.4.3 Chart view ....................................................................................................................................54 
3.4.4 Plant view.....................................................................................................................................56 
3.4.5 Network view................................................................................................................................57 
3.4.6 Project view..................................................................................................................................59 
3.4.7 Menu bar ......................................................................................................................................61 
3.4.8 Project tree...................................................................................................................................61 
3.4.9 Library window .............................................................................................................................63 
3.4.10 Preview window ...........................................................................................................................64 
3.4.11 Information window ......................................................................................................................67 
3.4.11.1 Output window .............................................................................................................................67 
3.4.11.2 Output window, "Online/Offline comparison" tab .........................................................................69 
3.4.11.3 Output window, "Utilization" tab ...................................................................................................69 
3.4.11.4 Diagnostics window .....................................................................................................................70 
3.4.11.5 Diagnostics window, "Functions" tab ...........................................................................................70 
3.4.11.6 Diagnostics window, "Device" tab................................................................................................72 
3.4.11.7 Variable table ...............................................................................................................................74 
3.5 Setting up and starting additional tools........................................................................................75 



Table of contents  
  

 Configuring Plants in SIMATIC iMap 
10 Configuration Manual, 01/2008, A5E00716614-02 

4 Systems engineering ............................................................................................................................... 77 
4.1 Basic procedure for configuring the plant ................................................................................... 77 
4.2 Working with projects .................................................................................................................. 78 
4.2.1 Creating a new project ................................................................................................................ 78 
4.2.2 Opening and closing the project ................................................................................................. 79 
4.2.3 Protect project ............................................................................................................................. 82 
4.2.4 Saving and archiving a project .................................................................................................... 83 
4.2.5 Generating the Project ................................................................................................................ 86 
4.2.5.1 Generating the Project ................................................................................................................ 86 
4.2.5.2 Generation status........................................................................................................................ 90 
4.2.5.3 Check consistency of the generated project ............................................................................... 91 
4.2.6 Structuring projects ..................................................................................................................... 92 
4.2.6.1 Data storage in SIMATIC iMap ................................................................................................... 92 
4.2.6.2 Grouping projects........................................................................................................................ 95 
4.2.7 Project logging ............................................................................................................................ 99 
4.2.8 Print Project............................................................................................................................... 100 
4.2.9 Exporting and importing projects .............................................................................................. 101 
4.3 Working with libraries ................................................................................................................ 102 
4.3.1 Library types.............................................................................................................................. 102 
4.3.2 Create new library ..................................................................................................................... 104 
4.3.3 Opening and closing libraries.................................................................................................... 104 
4.3.4 Importing PROFINET components ........................................................................................... 106 
4.3.5 Administering PROFINET components in libraries................................................................... 107 
4.3.6 Archiving and retrieving libraries............................................................................................... 108 
4.4 Working with instances of PROFINET components ................................................................. 110 
4.4.1 Structuring plants ...................................................................................................................... 110 
4.4.1.1 Inserting instances of the PROFINET components in a SIMATIC iMap project....................... 110 
4.4.1.2 Creating nested charts .............................................................................................................. 113 
4.4.1.3 Structuring functions in the plan hierarchy................................................................................ 114 
4.4.2 Coupling devices and assigning addresses.............................................................................. 115 
4.4.2.1 Connecting devices in the network view................................................................................... 115 
4.4.2.2 Check consistency of the runtime versions............................................................................... 117 
4.4.2.3 Addresses of PROFINET devices............................................................................................. 118 
4.4.2.4 Assigning addresses ................................................................................................................. 120 
4.4.2.5 Configuring PROFINET IO properties....................................................................................... 121 
4.4.3 Interconnecting functions .......................................................................................................... 123 
4.4.3.1 Interconnecting Technological Functions.................................................................................. 123 
4.4.3.2 Working with interconnections .................................................................................................. 125 
4.4.3.3 Hiding and showing connectors ................................................................................................ 127 
4.4.3.4 Interconnection with constant values ........................................................................................ 129 
4.4.3.5 Configuring substitute values.................................................................................................... 132 
4.4.3.6 Moving interconnections ........................................................................................................... 134 
4.4.3.7 Transfer properties.................................................................................................................... 135 
4.4.3.8 Setting the transfer properties of interconnections ................................................................... 137 
4.4.4 Checking the utilization of the devices...................................................................................... 141 
4.4.4.1 Utilization test ............................................................................................................................ 141 
4.4.4.2 Parameters of limit values......................................................................................................... 143 
4.4.4.3 Performance parameters of PROFINET devices...................................................................... 143 
4.4.4.4 Utilization parameters of the PROFINET devices..................................................................... 145 
4.4.4.5 Device parameters .................................................................................................................... 146 
4.4.4.6 General interconnection-specific parameters ........................................................................... 147 
4.4.4.7 Parameters for acyclic remote interconnections....................................................................... 149 
4.4.4.8 Parameters for cyclic remote interconnections......................................................................... 153 



 Table of contents 
  

Configuring Plants in SIMATIC iMap 
Configuration Manual, 01/2008, A5E00716614-02 11 

4.4.4.9 Error messages for interconnections with cyclic transfer...........................................................155 
4.5 Working with modified PROFINET components........................................................................155 
4.5.1 Editing PROFINET components ................................................................................................155 
4.5.2 Replacing instances...................................................................................................................156 
4.6 Editing in the manufacturer-specific programming and configuration tool.................................160 

5 Commissioning and online operation..................................................................................................... 163 
5.1 Basic commissioning procedures ..............................................................................................163 
5.2 Overview of the online functions ................................................................................................164 
5.3 Download ...................................................................................................................................166 
5.3.1 Download concept .....................................................................................................................166 
5.3.2 Program downloads ...................................................................................................................168 
5.3.3 Download of interconnections....................................................................................................174 
5.3.4 Download to PROFIBUS devices ..............................................................................................176 
5.4 Diagnostics information in the online view.................................................................................178 
5.5 Analyzing PROFINET components............................................................................................182 
5.6 Checking device availability .......................................................................................................185 
5.7 Comparing online and offline data .............................................................................................188 
5.8 Displaying and setting online values in SIMATIC iMap .............................................................190 
5.9 Online testing with the variable table .........................................................................................193 
5.9.1 Creating a variable table ............................................................................................................193 
5.9.2 Variablen online beobachten und steuern .................................................................................196 
5.10 Online device analysis ...............................................................................................................199 
5.11 Accessing information variables ................................................................................................201 
5.11.1 Create OPC symbol file .............................................................................................................201 
5.11.2 OPC information variables in SIMATIC iMap.............................................................................203 
5.12 Plants with SIMATIC devices.....................................................................................................207 
5.12.1 Special features of systems containing SIMATIC devices ........................................................207 
5.12.2 Online operation of SIMATIC devices........................................................................................211 
5.12.3 Processing instances with STEP 7 ............................................................................................212 
5.12.4 Set the PG/PC interface.............................................................................................................215 
5.12.5 Assigning the PG/PC .................................................................................................................217 
5.12.6 Set up the OPC server...............................................................................................................221 

6 Special PROFINET component types.................................................................................................... 223 
6.1 Overview - special PROFINET components..............................................................................223 
6.2 Multifunction components ..........................................................................................................224 
6.2.1 Properties of the multi-function components .............................................................................224 
6.2.2 Using multi-function components in the SIMATIC iMap project ................................................225 
6.3 Singleton components ...............................................................................................................228 
6.3.1 Properties of singleton components ..........................................................................................228 
6.3.2 Integrating Singleton components in the SIMATIC iMap project ...............................................230 
6.4 PROFINET components with HMI units ....................................................................................232 
6.5 Off-the-shelf PROFINET components .......................................................................................234 
6.5.1 IE/PB link....................................................................................................................................234 



Table of contents  
  

 Configuring Plants in SIMATIC iMap 
12 Configuration Manual, 01/2008, A5E00716614-02 

A Appendix................................................................................................................................................ 237 
A.1 Menu commands....................................................................................................................... 237 
A.2 Toolbar ...................................................................................................................................... 246 
A.3 Actions....................................................................................................................................... 247 
A.4 Naming conventions.................................................................................................................. 250 
A.4.1 Naming conventions in SIMATIC iMap ..................................................................................... 250 
A.4.2 Naming conventions for PROFINET components .................................................................... 252 
A.5 File types................................................................................................................................... 254 
A.6 Data types of connectors .......................................................................................................... 255 

B Abbreviations......................................................................................................................................... 257 
C Technical Support SIMATIC .................................................................................................................. 259 

C.1 SIMATIC Technical Support...................................................................................................... 259 
 Glossary ................................................................................................................................................ 261 
 Index...................................................................................................................................................... 269 



 

Configuring Plants in SIMATIC iMap 
Configuration Manual, 01/2008, A5E00716614-02 13 

Component Based Automation - overview 1
1.1 PROFINET CBA - concept 

PROFINET 
PROFINET is the open Industrial Ethernet standard for automation.  
The PROFINET standard defines a manufacturer-independent communication and 
engineering model. PROFINET is implemented within the TIA framework based on two 
automation concepts:  
● PROFINET IO - for communication between a PROFINET IO controller and PROFINET 

IO devices. 
● PROFINET CBA.(Component Based Automation) - for machine-to-machine 

communication (between PLCs and intelligent field devices.) 

PROFINET IO 
Within the PROFINET framework, PROFINET IO represents a communication concept for 
the implementation of distributed applications based on the integration of field devices 
operating on Industrial Ethernet. 

PROFINET CBA 
PROFINET CBA represents an automation concept in modular systems engineering, based 
on ready-to-use components. PROFINET CBA incorporates the communication between the 
PLC and intelligent field devices (machine-to-machine communication) at unit level. 
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New automation concept with Component Based Automation  
The diagrams below demonstrate how automation solutions are being transformed as a 
result of Component based Automation.  

 
Figure 1-1 Previous automation concept with modular systems engineering 



 Component Based Automation - overview 
 1.1 PROFINET CBA - concept 

Configuring Plants in SIMATIC iMap 
Configuration Manual, 01/2008, A5E00716614-02 15 

 
Figure 1-2 New: Modular concept with distributed intelligence 

The objective in Component Based Automation is the integration of self-contained 
technological modules as standardized automation components, namely the PROFINET 
components in large-scale systems. Component Based Automation is implemented on the 
one hand by the PROFINET standard for automation devices, and on the other by 
engineering tools such as SIMATIC iMap.  

Product range for PROFINET CBA  
The range of products for Component Based Automation based on the PROFINET standard 
always comprises: 
● PROFINET devices that conform to the PROFINET specification (CPU 317-2 PN/DP, for 

example)  
● SIMATIC iMap, the engineering tool for Component based Automation, for configuring 

plants, and integrating vendor-specific programming, configuration and diagnostic tools. 
In addition, a wide range of existing automation and field devices from various vendors can 
be used as PROFINET components. 
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1.2 PROFINET components 
The mechanical, electrical and electronic parts of a programmable controller that perform a 
specific technological function within the automation system or production process, 
combined with the associated control program, form an independent technological module. If 
this technological module meets the communication requirements of the PROFINET 
specification, it is possible to create a PROFINET component from it in an engineering 
system.  

() 

+ 

+ 

 
Figure 1-3 Creating a PROFINET component from a technological module 

PROFINET components are modular hence they can easily be assembled and reused. This 
greatly simplifies the process of configuring automation systems.  
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PROFINET Component  
A PROFINET component incorporates all the hardware configuration data, the module 
parameters and the associated user program. The PROFINET component is made up of: 
● one or several (optional) technological (software) functions, and 
● the associated device. 
The technological function of the component comprises the interface to other PROFINET 
components in the form of interconnectable inputs and outputs.  
The device is the representation of the physical programmable controller or field device, 
including any peripheral devices, sensors and actuators, the mechanical system and the 
device's firmware.  

How are PROFINET components created? 
The programmable controller or field device of the PROFINET component is configured and 
programmed using the configuration and programming tool supplied by the device 
manufacturer. A PROFINET component is then created from the configuration of the 
programmable controller and its user program, e.g. using a menu command. The device's 
functionality is also encapsulated with the application-specific programs. External 
applications can only access the technological interfaces (component interfaces) required for 
the interaction within the machine or system, diagnostics, visualization, and for vertical 
integration.  

PROFINET Component Description (PCD) 
The technological interfaces of the PROFINET components are described in XML (Extended 
Markup Language) and saved to an PCD (PROFINET Component Description) file. XML 
allows you to display information in a platform and vendor-independent format. A 
specification of the PCD file structure is given in the PROFINET engineering model.  
The PROFINET component can incorporate information on the hardware configuration and 
on the user program, if necessary, in a device specific form. 

Properties of PROFINET components 
● Modularization and reusability 

The concept of the PROFINET component allows extensive modularization of automation 
systems. PROFINET components can be reused as often as necessary in different 
automation systems.  

● Constant communication by support for the PROFINET specification 
Regardless of their internal functionality, each PROFINET component presents a uniform 
interface for communication with other components via Industrial Ethernet or PROFIBUS. 
The PROFINET specification describes the open communication interface for 
PROFINET-compliant devices.  
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● Cross-vendor engineering 
The technological functions of individual devices are programmed in the vendor-specific 
engineering tools. The the cross-plant interconnection of technological functions however 
vendor-independent engineering tools are used, e.g. SIMATIC iMap. They allow products 
from different vendors to be incorporated into PROFINET communication. Thus, all field 
device and programmable controller vendors have to do is extend their programming and 
configuration tools to allow them to be linked to the device-neutral engineering tool (e.g. 
SIMATIC iMap).  

Programmable and fixed functionality 
In an intelligent device, the application-specific functionality is defined by the user program 
that is downloaded to the device. More simple devices, such as drives or field devices, do 
not have their own user programs. The functionality of such devices is integrated into the 
firmware. We therefore differentiate between PROFINET components 
● with programmable functionality 

The component has its own user program that can be downloaded from SIMATIC iMap to 
the device. 

● with fixed functionality 
The component does not have its own user program. 

Libraries, classes and instances 
You can store PROFINET components in a SIMATIC iMap library and use them again. A 
PROFINET component forms a class, i.e. a template for one or several instances, and 
describes the internal structure of those instances. The insertion of a PROFINET component 
from a library in a SIMATIC iMap project generates an instance of the PROFINET 
component in the project, i.e. an application of this component class. Each instance is 
assigned additional properties, for example, a name and address. One or more instances of 
a PROFINET component can be inserted in a project.  
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The figure below shows some of the PROFINET components and their instances in the 
windows and views of SIMATIC iMap. 

 
Figure 1-4 Representation of a PROFINET component in SIMATIC iMap 

 
Legend  
1 Library - PROFINET compoenets "Coordinator" (type) 
2 Plan view - "Coordinator" function (instance) 
3 Plant view - "Coordinator" function (instance) 
4 Network view - device "CPU 317-2 PN_DP" (instance) 
5 Project tree, plant tree - "Coordinator" function (instance) 
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SIMATIC iMap represents the classes and instances of a PROFINET component in different 
forms:  
● The PROFINET component (class) is represents as library element. 
● This instance of a PROFINET component is represented in different views: the 

technological functions in the chart and plant views, and devices in the network view. 
● The assignment of PROFINET components to the associated instances is represented in 

the project view (see diagram below). 

 
Figure 1-5 Project view in SIMATIC iMap 

See also 
Technological functions (Page 21) 
Devices of PROFINET components (Page 22) 
New engineering concept with SIMATIC iMap (Page 27) 
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1.3 Technological functions 

Definition of a technological function 
One or several technological functions of a PROFINET component comprise the application-
specific functionality of an automation or field device, and the technological interfaces for the 
communication with other PROFINET components.  

Technological interface 
The technological interface defines the connections - i.e. the inputs and outputs - of the 
PROFINET component. The connections represent the external communication interface 
that is accessed via Ethernet or PROFIBUS. Every connection is characterized by the 
following features, as defined in the user program for the PROFINET component:  
● Direction 

Each connection represents an input (consumer), or an output (provider.)  
● Interconnectibility in SIMATIC iMap 

Inputs and outputs that are visible in SIMATIC iMap may be interconnected.  
Non-interconnectable connections are not represented graphically in SIMATIC iMap. 
They can be accessed via other communication mechanisms, e.g. OPC (OLE for Process 
Control), and are generally used for operator control and process monitoring. 

● Name  
Any connection names can be selected, provided it conforms to the naming conventions 
and is no more than 24 characters long. 

● data type 
A data type, e.g. BOOL, I1 or U2, is defined for each connection. Complex data types, 
such as arrays and structures, are also supported.  

● Value 
The actual value of a connection can be viewed online in SIMATIC iMap in runtime. 
Online values of non-interconnected inputs may also be modified. 
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Representation of technological functions 
The technological functions of a plant are represents by blocks with interconnectable 
inputs (1) and outputs (2.) Interconnections are visualized by connecting lines (3.) 

 
Figure 1-6 Interconnected technological functions 

Interconnections 
In SIMATIC iMap, an interconnection is the connection between an output and an input. An 
output can be interconnected to one or more inputs. Once the interconnections have been 
downloaded to the programmable controllers, the corresponding communication links are 
automatically established between senders and receivers.  

1.4 Devices of PROFINET components 

Devices in PROFINET components 
The device is the part of the PROFINET component that contains the hardware-specific data 
for that component.  
In Component Based Automation, a device is a representation of the physical device for 
which the PROFINET component was created. Such devices include programmable 
controllers, intelligent field devices and peripheral, hydraulic and pneumatic devices.  

Devices and network types  
PROFINET communication takes place via Industrial Ethernet. Existing PROFIBUS systems 
can easily be integrated in the PROFINET communication with the aid of the proxy concept 
(see figure "Devices and network types").  
The main feature of a device is that it is integrated into the PROFINET communication via an 
Ethernet or PROFIBUS. We differentiate between the following types of device downstream 
of the bus connections: 
● PROFINET devices 

A PROFINET device always has an Ethernet connection. A PROFINET device may also 
have a PROFIBUS connection, and thus act as a master with proxy functionality.  

● PROFIBUS devices 
A PROFIBUS device has just one PROFIBUS connection and is always a slave. It cannot 
participate directly in PROFINET communication, and must always be integrated via a 
PROFIBUS master with proxy functionality. 
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The figure below shows the devices and network types. 

 
Figure 1-7 Devices and network types  

The PROFINET device with proxy functionality is a proxy for PROFIBUS devices on 
Industrial Ethernet. The proxy functionality allows a PROFIBUS device to communicate with 
all participants in the PROFINET communication, as well as with its own master.  
PROFINET IO systems and further devices on Industrial Ethernet (such as HMIs) may be 
integrated in PROFINET components. Although SIMATIC iMap does not visualize these 
objects graphically, these can be configured in object properties dialogs. 
PROFIBUS devices may be connected to the local PROFIBUS of another PROFINET device 
(see below, "Examples - PROFINET and PROFIBUS devices".) This way already existing 
PROFIBUS configurations can be integrated in PROFINET components. The local 
PROFIBUS of a device is not visible in SIMATIC iMap. 
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Representation of Devices 
The figure below shows a practical example of the instances of PROFINET and PROFIBUS 
devices in the network view of SIMATIC iMap. 

 
Figure 1-8 Example: Representation of the devices in the SIMATIC iMap network view 

Table 1-1 Key 

Symbol Meaning 
1 PROFINET device with proxy functionality 
2 PROFINET device without proxy functionality 
3 PROFIBUS devices 
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Examples - PROFINET and PROFIBUS devices 
The table below shows the supported hardware configurations for PROFINET components, 
and the representation of the devices in SIMATIC iMap 

 
Designation Example configuration  Representation in SIMATIC iMap  
PROFINET device 
with proxy 
functionality 

  
PROFINET device 
with proxy 
functionality and 
local PROFIBUS 

 

PROFINET device 
without proxy 
functionality  

  
PROFINET device 
(with local 
PROFIBUS) without 
proxy functionality 
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Designation Example configuration  Representation in SIMATIC iMap  
PROFINET device 
with integrated 
PROFINET IO 
system 

 

 
 

PROFINET device 
with internal HMI on 
Industrial Ethernet 

 

 
 

PROFIBUS device 
(DP slave on 
PROFIBUS)  

 

 
 

Supported transfer types 
Data transfer types supported in PROFINET CBA: 
● Acyclic transfer of engineering data, and of data which are not time-sensitive 

(configuration and diagnostics data, for example.) Acyclic data transfer is based on the 
TCP/IP protocol.  

● Cyclic transfer of time-sensitive process data (user data.) Cyclic data transfer is routed 
across a separate real-time channel (real-time communication on Industrial Ethernet).  
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1.5 New engineering concept with SIMATIC iMap 

Device-independent engineering concept 
In SIMATIC iMap, PROFINET offers you a standardized manufacturer-independent 
engineering interface for the configuration of PROFINET applications. This allows the 
comfortable integration of devices and components of different manufacturers simply in your 
plant via PROFINET.  
SIMATIC iMap lets you join distributed automation applications in a graphical format, and 
visualize these on the entire system. All of the required PROFINET components are 
available in a standardized format in the form of library elements.  
The communication connections between the devices do not need to be programmed, but 
can be configured graphically as interconnection lines.  
SIMATIC iMap can download the instances of the PROFINET components, and their 
associated interconnections to devices of the plant. In the commissioning phase, and while 
the plant is in operation, you can use SIMATIC iMap to poll process and diagnostics data of 
the devices, and modify parameters and project data for testing purposes.  
In addition to the technological plant view, SIMATIC iMap supports the integration of 
manufacturer-specific, proprietary programming and configuration tools for automation 
devices and intelligent field devices. 

SIMATIC iMapCross-vendor
engineering

Plant view

Manufacturer-specific configuring and programming

Devices
 

Figure 1-9 SIMATIC iMap engineering concept 
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The basic engineering procedure 
The following steps must be carried out in order to structure and operate an automation 
system using SIMATIC iMap:  
1. Planning the plant 

The plant planner defines the following aspects: 
– Which functions are needed 
– Which programmable controllers and field devices are to be used 
– Which functions can be combined to create reusable technological modules 
– NEW for Component Based Automation:  

 Technological interfaces and interaction between PROFINET components, plus 
variables for diagnostics and visualization. 

2. Creating PROFINET Components 
The systems and mechanical engineer creates the PROFINET component using the 
manufacturer-specific configuration and programming tool by: 
– Configuring and programming the hardware 
– Creating the description of the component interface 
– Creating the user program 
– Overall test of the technological module 
– Creating the PROFINET component (XML file and associated data) 
– Optional: Importing the PROFINET component into a SIMATIC iMap library. 

3. Configuring the plant in SIMATIC iMap 
The plant configuration engineer creates the project in SIMATIC iMap by:  
– If necessary: Importing the new PROFINET component into the (project) library 
– Structuring plants 
– Inserting the PROFINET Components into the Project 
– Networking the devices in the network view 
– Assigning the device addresses (IP address and/or PROFIBUS address) to the 

devices (this step is device-specific) 
– Interconnecting the technological functions in the plant view 
– Modifying the properties of the devices and functions 
– Checking the configuration 
– Documenting and archiving the project. 
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4. Commissioning and testing the plant 
The plant operator is responsible for the following tasks: 
– Commissioning individual devices 
– Downloading project data to the devices in the plant 
– If necessary: Reworking devices and technological functions in the manufacturer-

specific engineering tool 
– Testing the plant 
– Creating the symbol data for OPC access 

5. Operating the plant 
– Monitoring and modifying process data online (vertical integration) 
– Diagnosing faults in the plant 
– Operator control and process monitoring 
– Carrying out maintenance and modifications 

Support by SIMATIC IMap  
SIMATIC iMap provides the following support for plant engineering: 
● Storage of in-house and off-the-shelf PROFINET components in libraries: 

Libraries are used to administer PROFINET components that you create yourself or 
purchase. The content of these libraries can be configured as required. 

● Structuring the plants in the chart view: 
In the chart view, you can define the plant structure by inserting charts and functions. 

● Interconnection of technological functions in the plant view: 
In the plant view, you can position and interconnect technological functions graphically, 
and easily check and modify their properties.  

● Networking devices in the network view: 
In the network view, you can link devices graphically to a PROFIBUS or Ethernet subnet, 
and assign the corresponding addresses.  

● Online monitoring and control of variables: 
You can access the process data online at any time. To do this you use a variable table, 
incorporating HMI devices such as WinCC Flexible or ProTool/Pro into your plant or using 
OPC-based client programs.  

● Diagnosing PROFINET devices and technological functions: 
The separate diagnostic window constantly displays the current status of PROFINET 
devices and technological functions. An online-offline comparison allows you to 
determine whether programs and/or interconnections need to be downloaded. 

● Representation of the project in a hierarchical tree structure: 
All parts of the plant needed for easy navigation and other administration functions within 
the project are clearly displayed. 
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● Automatic creation of the plant documentation: 
Full documentation of the configured plant, including all devices, technological functions 
and their connectors, plus a graphical representation of the networking and 
interconnections can be created automatically in SIMATIC iMap. 

● Checking the configuration: 
You can check the configuration in SIMATIC iMap with reference to the device-specific 
performance parameters even before you generate the project. 

● Looking up the device's online data: 
The online device analysis allows you to look up the online data for individual devices for 
testing and diagnostic purposes. 

manufacturer-specific configuration and programming tools 
SIMATIC iMap provides the following functions for integrating manufacturer-specific 
configuration and programming tools: 
● Software for creating PROFINET components for SIMATIC devices in STEP 7. 
● Access to manufacturer-specific tools for configuring and diagnosing devices. 

Transparent data access 
PROFINET communication supports access to process data from different levels of the 
plant. Due to the integration of PROFINET, users can now implement standard 
communication and IT mechanisms such as OPC or XML in automation technology. This 
means that office-bound company managers can directly access the data from PROFINET 
devices at the control and production levels.  

 
Figure 1-10 Access to process data 
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1.6 User documentation for SIMATIC iMap and Component Based 
Automation 

User documentation  
The SIMATIC iMap and PROFINET documentation is broken down into various activities and 
target groups. The contents contain different levels of information. 

 
Manual Type of description Contents Target group 
Getting Started 
with SIMATIC 
iMap 

Brief introduction  • Creating PROFINET components with STEP 7 
• Configuring plants with SIMATIC iMap 
• Online Monitoring and Diagnostics with SIMATIC iMap 

Beginners  

Creating 
PROFINET 
Components  

Extensive 
description and 
instructions  

• Creating PROFINET components with STEP 7 
• Using SIMATIC Devices as PROFINET components 

Systems 
engineers  
Mechanical 
engineers 

Introduction • Component Based Automation 
• SIMATIC iMap 
• PROFINET components 

Beginners 
Plant planners 

• Installing SIMATIC iMap 
• Working with SIMATIC iMap 
• Configuring plants 

Plant designers 

• Commissioning plants 

Configuring 
Plants 
with SIMATIC 
iMap - manual 

Comprehensive 
description and 
instructions  

• Online Operation and Diagnostics 
Plant operators 

Commissioning 
Systems 
 - Tutorial 

Detailed step-by-
step instructions 
with reference to an 
example 

• Creating PROFINET components with STEP 7 
• Configuring plants with SIMATIC iMap 
• Commissioning Plants with SIMATIC Devices 

All 

Options for accessing the user documentation 
You can call up documentation about SIMATIC iMap: 
● To view the various documents in PDF print format, select Start > Program files > 

Component Based Automation > Documentation > SIMATIC iMap > ... on the Windows 
task bar. 

● In SIMATIC iMap, you can open the complete documentation as online help using the 
Help > Help Topics menu command. 

Additional information 
For general information on PROFINET, refer to the PROFINET System Description. 
The associated product documentation contains information on related topics, e.g. 
descriptions of individual devices. 
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Installing software 2
2.1 Prerequisites 

Hardware Requirements 
The computer on which SIMATIC iMap is installed must have at least the following 
configuration: 
● Pentium processor, 1 GHz or higher 
● RAM: 512 MB or more 

General software requirements 
● Operating system: 

SIMATIC iMap V3.0 SP1 is released only for the operating systems 
– MS Windows 2000 Professional + SP4, or 
– MS Windows XP Professional + SP1 and higher 
– MS Windows Server 2003 + SP1 and higher 
– MS Windows Vista 32 Business or Ultimate 

● Microsoft Internet Explorer V6.0 SP1 or higher, depending on the operating system 
Is required in order to open SIMATIC iMap project documentations (HTML). 

● Acrobat Reader V5.0 and higher, depending on the operating system 
Is required in order to open the electronic manuals (PDF). 

Recommendation:  
We recommend that you also install the Microsoft Windows security patches.  
Required authorizations under MS Windows 2000, XP and Server 2003: 
● You need administrator rights for the installation of SIMATIC iMap. 
● You need at least main user rights to operate SIMATIC iMap. 
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Software requirements for SIMATIC devices 
If you are using PROFINET components of SIMATIC devices, you will also need the 
following software packages: 
● STEP 7 V5.3 + SP3 and higher, or 
● STEP 7 Professional V5.3 SP3 and higher 
● STEP 7 V5.4 and higher, or 
● STEP 7 Professional V5.4 and higher 
● Software required for the SIMATIC devices used: 

 
Device/Function Software required 
WinAC PN  WinAC PN V1.1 and V4.1 and higher 

SIMATIC NET IE SOFTNET-S7 V6.2 SP1 and higher 
HMI Process Visualization ProTool/Pro Configuration V6.0 + SP2 and higher 

WinCC flexible 2005 V1.1 SP1 and higher 
Access to process varaibles by means of 
OPC 

SIMATIC NET PN OPC-Server V7.0 and higher 

Access to non-interconnectable process 
variables via OPC  

SIMATIC NET IE SOFTNET-S7 V7.0 and higher 
SIMATIC NET PN OPC-Server V7.0 and higher 

You may need further software packages, depending on the modules and devices used. For 
information on component requirements, refer to the relevant product description. 

 

 Note 
SIMATIC iMap can be used without being integrated in STEP 7. 

 

2.2 Installing 

Installation units of SIMATIC iMap 
● SIMATIC iMap - the engineering tool for configuring PROFINET CBA communication. 

Lets you to configure and interconnect existing PROFINET components and use some of 
the online and diagnostic functions.  
SIMATIC iMap STEP 7 AddOn is required to perform device-specific functions, such as 
generating the SIMATIC iMap project, downloading a program, or reading device-specific 
diagnostics data. 

● SIMATIC iMap STEP 7 AddOn - the optional software for creating PROFINET 
components in STEP 7. 
This installation unit contains the link to STEP 7 needed to define PROFINET interfaces 
and create PROFINET components. It also supports the execution of device-specific 
functions in SIMATIC iMap. 
The installation unit requires STEP 7. 

The installation units can be installed separately.  
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Requirement 
The conditions described in the "Requirements" section must be fulfilled. 

 

 Note 
SIMATIC iMap may not be installed on a network drive. 
Select a folder on the local hard disk drive. 

 

To install SIMATIC iMap 
1. Insert the SIMATIC iMap CD into the CD-ROM drive. 

Continue at step 4 if the Setup program starts automatically. Otherwise, continue from 
step 3. 

2. Select the CD-ROM drive in Windows Explorer. 
3. Double click on the setup.exe file to start the setup program. 
4. Run the necessary setup programs in the order specified by clicking on the relevant 

buttons. 
During installation you are requested to install the license key. Following instructions in 
the "Authorization" section. 

 

  Note 
Perform a restart if the setup program requests it after it has been executed. 

Please follow the notes on installing and using SIMATIC iMap in the readme file, which is 
also on the CD-ROM. 

See also 
Authorization (Page 36) 
Prerequisites (Page 33) 
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2.3 Authorization 
A product-specific authorization (use permission or license key) is needed in order to use the 
SIMATIC iMap engineering software. The full scope of SIMATIC iMap functionality is only 
available if the system detects the required authorization on the PG/PC hard disk drive.  

Authorization on USB stick 
For authorization, you need the USB stick containing the license key, which is included in the 
scope of delivery. This contains the actual authorization. Automation License Manager is 
required to view, install and remove the authorization. This program is included on your 
SIMATIC iMap V3.0 SP1 CD-ROM.  

 

 Note 
For the SIMATIC iMap engineering software you will receive a license key on USB stick. 

 
CAUTION  
Follow the instructions in Automation License Manager > Disk1 > ALM-Readme.wri on the 
CD-ROM. If you do not follow these instructions, you risk losing the authorization 
permanently. 

 
You can also use SIMATIC iMap without the authorization to get to know the user interface 
and range of functions. However, you can only really use the program with the authorization 
installed. If you have not installed the authorization, you will be prompted at regular intervals 
to install it.  

If you lose your authorization ... 
An authorization can be lost if a hard disk fault occurs, for example, and you are unable to 
uninstall the authorization from the defective hard drive.  
If you lose the authorization, you can access the emergency authorization. This is also on 
the USB stick. This emergency authorization allows you to continue to use the software for a 
limited period. In this case, the time remaining until the authorization expires is shown on 
start-up. You should obtain a replacement for the lost authorization during this period. To do 
this, contact your local SIEMENS dealer.  

 

 Note 
The time limit for the emergency authorization starts to run when you install the 
authorization, even if SIMATIC iMap is not started. The time limit will not stop even if you 
write the authorization back to the USB stick. 
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Installing Automation License Manager 
Automation License Manager is required to view, install and remove the authorization. This 
program is included on your SIMATIC iMap V3.0 SP1 CD-ROM. SIMATIC iMap Setup offers 
this program as an option and installs it if selected.  

 

 Note 
The path of the Automation License Manager program:  
Start > SIMATIC > License Management > Automation License Manager. 

 

Running the authorization at initial installation 
You should run the authorization when a message prompts you to do so during the initial 
installation of SIMATIC iMap. The procedure is as follows:  
1. Insert the data medium with the authorization when you are prompted to do so. 
2. Then confirm the prompt. 
3. The authorization is transferred to a physical drive. 

Running the authorization at a later date 
If you start SIMATIC iMap and there is no authorization installed, a message to this effect 
appears. You can run Automation License Manager to install the authorization at a later time. 
The Help for this program contains detailed information on the procedure.  

 

 Note 
The authorization will not work unless you are approved for write access on a local hard 
drive. 
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Operating SIMATIC iMap 3
3.1 Starting SIMATIC iMap 

Requirement 
SIMATIC iMap must be installed on your PC/programming device. 

Starting SIMATIC iMap 
There are two ways to start SIMATIC iMap: 
● In the Windows taskbar click on the Start / Programs / Component Based Automation / 

SIMATIC iMap command or 

● Double-click on the iMap icon on your desktop . 
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Result 
The SIMATIC iMap user interface is opened: 

 
Figure 3-1 Start SIMATIC iMap: User interface 

See also 
SIMATIC iMap user interface (Page 49) 
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3.2 Help functions in SIMATIC iMap 

Online help 
SIMATIC iMap's built-in help system provides targeted information for the points in the 
program at which you need help. You can thus quickly and efficiently access the information 
you need. The ways in which you can obtain help for each procedure are described below. 

Via the "?" menu 
● Help: displays information about the selected object or on the active dialog box or 

window. 
● Help Topics: opens the online help for "Component Based Automation and SIMATIC 

iMap". You can then use the Content, Index and Find tabs to navigate within the online 
help. 

● Getting Started: describes the first steps that you have to carry out to create a working 
application. 

● About: opens an information box listing the most important properties of the installed 
software version. 

In dialog boxes 
In all dialog boxes containing a "Help" button, you can click on this button to obtain a 
description of the dialog box. 

In messages 
In all message boxes containing a "Help" button, you can click on this button to obtain a 
detailed description of the message. 

Via the F1 function key 
Use the F1 function key to move directly from your current working context to the point in the 
online help that describes this aspect. For example, if there is a dialog box on screen, a 
description of this dialog will be called.  

In the status bar 
The status bar displays a short help text that describes the selected command from the main 
or pop-up menu (opened by clicking the right mouse button).  

Via the Tooltip texts 
If you move the cursor slowly over a button in the toolbar, a brief description appears for a 
short time.  
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SIMATIC iMap documentation 
You can call up documentation about SIMATIC iMap:  
● To view the various documents in PDF print format, select Start > Program files > 

Component Based Automation > Documentation > SIMATIC iMap > ... on the Windows 
task bar. 

● In SIMATIC iMap, you can open the complete documentation as online help using the 
Help > Help Topics menu command.  

 

3.3 Operating philosophy 

3.3.1 Objects and object hierarchy 

Simple operation  
SIMATIC iMap's graphical user interface is designed to be as straightforward and intuitive to 
use as possible. It therefore contains objects with which you are familiar from your daily 
work: devices, functions and charts. 

Object-oriented operation 
In the SIMATIC iMap user interface, objects are represented by graphical symbols. You can 
open and edit the objects by selecting the symbols. In most cases, when you work with 
SIMATIC iMap you will use the normal Windows conventions.  

Object hierarchy 
Projects have a hierarchical structure in SIMATIC iMap. At the bottom of the object hierarchy 
are the instances of the technological functions and devices, which are automatically set up 
as soon as PROFINET components are inserted in a project. The project can be structured 
subordinate charts which in turn include charts and functions. 
The plan view shows the technological hierarchy of the plant. It shows the charts and 
instances of the functions in a tree structure. 
The "plant tree" and "network tree" views are automatically created in the project tree. The 
charts and technological functions are listed under "plant tree", while the devices with their 
network connectors can be found under "network tree". When opening a chart in the project 
tree, the objects already contained in that chart are displayed, similarly as in Windows 
Explorer. 
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Example: Object hierarchy 

 
Figure 3-2 Project tree, example of an object hierarchy 

Object properties 
Objects have properties such as addresses and connectors. Once you have selected an 
object, you can open a dialog box using the Properties shortcut menu, for example, in order 
to make certain object-specific settings.  
Specific properties or states are displayed directly at the objects by text or symbols. An 
overview of symbols and their meaning is available in the appendix.  
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Associated objects 
The associated objects in a SIMATIC iMap project are: a PROFINET component and its 
instances (devices and optionally technological functions). A simple double-click on a single 
object selects the associated objects from all views. The following diagram show how they fit 
into the project.  

 
Figure 3-3 Representation of a PROFINET component in SIMATIC iMap 

 
Legend  
1 Library - PROFINET components "Coordinator" (type) 
2 Plan view - "Coordinator" function (instance) 
3 Plant view - "Coordinator" function (instance) 
4 Network view - device "CPU 317-2 PN_DP" (instance) 
5 Project tree, plant tree - "Coordinator" function (instance) 
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3.3.2 Editing objects 

Basic actions 
Certain basic actions for objects are the same for all objects. These basic sequences of 
actions are summarized below. In the following chapters of this manual, we have assumed 
that you already know how to use them when we describe individual procedures.  
You can carry out certain actions on each object, e.g. Copy, Cut, Paste. When you select an 
object, the commands that you can carry out on that object are displayed in the shortcut 
menu. Illegal menu commands are grayed out. If you attempt to carry out an illegal action, 
you will be stopped and the cursor will change into a Stop sign.  
The usual sequence of actions for handling objects is as follows:  
● Create the object 
● Select the object 
● Perform actions with the object 

Creating objects  
With SIMATIC iMap you can create new libraries, projects and charts. Use the following 
menu commands to create objects: 
● Library > New 
● Project > New 
● Insert > New chart 
The PROFINET components themselves are created with a device-specific programming 
and configuring tool, e.g. STEP 7 and can be inserted or copied into the library with the 
menu command Library > Import components. 
Instances of the PROFINET components are inserted in the project by drag & drop or by 
copying. 

Selecting objects - Multiple selection 
You can select multiple objects (multiple selection) in all views. To do so, press the left 
mouse button and draw a lasso around the relevant objects.  
The multiple selection function only allows the selection of objects which are of the same 
type, and not nested within the hierarchy. Example: only the technological functions and 
charts in the plant view. Objects are selected in the following order: If the lasso contains 
complete technological functions and charts, these objects will be selected. If this is not the 
case, any complete connections that they contain are selected. If there are no connections, 
then any interconnections that they contain are selected.  

 

 Note 
Tip: You can also make multiple selections with the left mouse button by holding down the 
"Shift" or "Ctrl" key at the same time. 
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Opening objects 
In SIMATIC iMap you can open libraries, projects and charts. These objects are opened 
using the following menu commands: 
● Library > Open 
● Project > Open or by double clicking a SIMATIC iMap project file (extension.cbp) 
● Edit > Open Selected Chart or by double clicking on the chart. 
Once you have opened an object, you can then create or modify its content. You cannot, 
however, open projects that are currently in use.  

Cutting, pasting and copying 
Most objects can be cut, pasted and copied as is usual under Windows. The associated 
menu commands can be found in the Edit menu and the shortcut menus that you access by 
clicking the right mouse button. 
You can also drag & drop objects to copy or move them. If you attempt to drop the object at 
a destination that is not permitted, the cursor changes into a Stop sign.  
The nested hierarchy of a chart is always included when you cut or copy it. This feature 
opens extensive options of reusing system units you already developed.  
Copied and cut functions or charts can only be pasted into charts (not in the network view.)  
You can only cut, copy and paste complete instances (see "Editing function units of 
multifunction components".) 

 

NOTICE  
When pasting cut instances, you may loose configuration data such as interconnections, 
chart assignments, or master / slave connections on PROFIBUS. You thus need to 
reassign such data separately.  

 

Moving objects 
In SIMATIC iMap, you can move the following objects using Drag&Drop:  
● Devices in the network view from one Ethernet or PROFIBUS network to another. 
● Technological functions in the plant view. 
● Charts within the chart view, plant view or project tree. 

Deleting objects 
You can delete both folders and objects. When you delete a chart, you also delete all the 
objects contained in that chart.  
The project tree and the SIMATIC iMap net, plant and project views are different 
representations of the same project. If an object is removed from one of the windows, it 
automatically disappears from the other windows.  
You can only delete complete instances (see "Editing function units of multifunction 
components".) 
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CAUTION  
The deletion operation cannot be reversed. If you might need an object again, then you 
should archive the entire project first. 
When you delete an object, you also delete the corresponding interconnections of the 
technological functions! It may therefore be necessary to reconnect the inputs and outputs 
to other technological functions. 

 

Accessing iMap libraries and projects 
SIMATIC iMap libraries and projects behave just like normal documents. You can open, 
modify, save and archive them in SIMATIC iMap.  

 

NOTICE  
The content of a SIMATIC iMap project folder must only be edited with SIMATIC iMap.  
If you change the project data using Windows Explorer, for example, it may no longer be 
possible to open the project in SIMATIC iMap. 

 
The actual project folder may be renamed, moved, copied or deleted in Windows Explorer, 
however. 
You cannot access several SIMATIC iMap projects at the same time.  

Deleting SIMATIC iMap libraries and projects 
You can delete SIMATIC iMap libraries and projects by deleting the relevant folders from the 
file system in Windows Explorer.  

Processing function units of multifunction components 
The actions listed below are always performed for all instances of multifunction components, 
regardless whether you selected all function units: 
● Copy 
● Paste 
The actions listed below are always performed for all instances of multifunction components, 
you always have to select all function units: 
● Cut 
● Deleting 
Refer to chapter "Special PROFINET component types" for more information on multi-
function components. 
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Setting object properties 
Object properties are the data of an object that define its behavior. The Properties shortcut 
menu opens the dialog box in which you can read or set the properties of the highlighted 
object. 

 

 Note 
If you change the settings of objects, e.g. interconnections, offline in SIMATIC iMap, they do 
not take immediate effect on the plant. These changes will not become active until you 
download the data to the target system.  

 

Renaming objects 
In SIMATIC iMap you can change the names of technological functions, devices and charts. 
The names of PROFINET components in the libraries cannot be changed, however. 
The instances of technological functions and devices are assigned the names of the 
PROFINET component class by default. If several instances of a PROFINET component are 
used, then the name is supplemented by a consecutive number, regardless of which level of 
the hierarchy the component is located, e.g. Processing_1.  
When a new chart is inserted, it is called "New Chart" by default. A second chart is called 
"New chart_1", and so on. 
The following options are available for renaming: 
● Edit the name directly on the object. 
● Highlight the desired object and select Edit > Properties.... Change the name in the dialog 

box and click on the "OK" button. When you close the Properties dialog, the object is 
renamed and appears with the new name. 

3.3.3 Reading and editing properties 

Properties - Overview 
In SIMATIC iMap you can view and, if necessary, modify the properties of the following 
objects: 
● Project 
● Instance 
● Chart 
● Interconnection 
● Connection 
● library 
● PROFINET component 
A description of the properties can be found in the context-sensitive help for the "Properties" 
dialog boxes. 
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To modify the properties of objects: 
Procedure: 
1. Open the required window. 
2. Select the object, and then select one of the following menu commands: 

– Edit > Properties from the menu bar or 
– Properties from the shortcut menu. 

The "Properties" dialog box is opened. 
3. Modify the desired properties and click "Accept" to confirm your changes. 
4. Close the dialog box: 

– Click on OK if you want your changes to take effect 
– Click "Cancel" if you want to cancel all your changes. 

Tip: Direct input of the properties 
You can edit certain properties directly at the object, for example, object names and IP 
addresses. You can select PROFIBUS addresses directly from a list in the network view. 
In order to reach the direct input mode, select the desired object and click on the area that 
you would like to change, e.g. the names, the IP addresses or the PROFIBUS address. The 
field can be edited and you can enter the property directly.  

3.4 Windows and views 

3.4.1 SIMATIC iMap user interface 

Structure  
The SIMATIC iMap user interface is made up of various windows and views that can be 
opened and closed as required by clicking on the icons in the toolbar, if necessary.  
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Table 3-1 SIMATIC iMap user interface 

No. Window Icon 
1 Chart view (always opened)  
2 Plant view, network view or project view (always open)  
3 Project tree 

 
4 Information window 

 
5 Library window 

 
6 Preview window (can only be opened in conjunction with the library window) 

 
7 Menu bar (see description in the appendix)  
8 Toolbar (see description in the appendix)  
9 Arrow keys for showing and hiding views  
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Working with SIMATIC iMap 
Depending on which window is active, various actions can be carried out. Features used in 
Windows applications are available here: 
● Menu commands (menu bar, shortcut menus or icons in the toolbar), 
● Drag & drop, 
● Keyboard input 

Calling help 
To call up help about a window in the user interface, click in the window and press function 
key F1. 

See also 
Basic procedure for configuring the plant (Page 77) 
Network view (Page 57) 
Library window (Page 63) 
Diagnostics window (Page 70) 
Preview window (Page 64) 
Project tree (Page 61) 
Plant view (Page 56) 
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3.4.2 Representation and navigation 
This chapter describes the navigation possibilities in SIMATIC iMap.  
The windows and views of SIMATIC iMap offer various representations of the SIMATIC iMap 
project. The interface can be flexibly adapted by means of  
● opening and closing the windows and views 
● Hiding and showing the status bar and the toolbars 

Opening and closing windows 
The options for opening or closing a window are as follows: 
● Select the menu command View > <Window name>, e.g. View > Library window, or 
● press the symbol for the desired window. 

Hiding and showing the status bar and the toolbars 
● Select the menu command View > Toolbars, in order to hide and show the toolbars. 
● Select the menu command View > Status bar, in order to hide and show the status bar. 

Showing and hiding views 
The window of the working area comprising plan view and plant view / network view / project 
view can not be closed. You can however choose whether you wish to have just one or both 
views open. Use the arrow keys to alternate between showing and hiding one of the views:  

Table 3-2 For arrow keys are located on the work area: 

Representatio
n 

Layout Opened views Effect 

 
 

Separating line between the 
chart view and plant view / 
network view / project view 

Both Close one of the views 

 
 

Bottom edge of the work area Only the chart view Open the plant view 
/network view / project 
view  

 
 

Top edge of the work area Only the plant view / 
network view / 
project view  

Open plant view 

Showing and hiding content 
In order to show or hide content or levels of the hierarchical structure you have the following 
possibilities: 
● Menu commands, e.g. View >...> Show all levels/Hide all levels 
● graphic symbols (+/- or arrows) directly on the objects 
● Double-click an object or a chart 
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Navigation help "Go to" 
To navigate directly to a specific window or object, use the men command Edit > Go to >. 
The offered objectives are dependent on the selected object type.  
If you select a specific object (function or device) and choose the menu command Go to with 
a window as a destination, then the desired window is opened and the associated object 
selected. E.g.: If you select a function in the plan view and then select Go to > Project view , 
the project view opens and the function of the respective instance selected.  

Finding objects  
With the Edit > Find... menu command you can find all the objects that have specific 
characteristics or properties e.g. 
● objects the names of which include a specific string of characters 
● functions with connectors that can be hidden 
● highlighted interconnections 
● functions that have no chart assigned to them 
The objects found are then listed in the task window, "General" tab. By double-clicking an 
entry in the task window, the respective object is selected in the various windows and views. 

Highlighting associated objects 
Once you have highlighted an object, you can double-click on that object or use the Edit > 
Select in all Windows menu command to highlight all the associated objects (PROFINET 
component, device and technological function, if applicable) in the other windows as well.  
Example: Double-click on the technological function of an instance in the chart view selects 
the following objects: 
● in the library: the PROFINET component the instance of which contains the selected 

function, 
● in the project view: the function at the instance of the PROFINET component, 
● in the plant view and in the plant tree of the project tree: the same technological function, 
● in the network tree of the project tree and in the network view: the associated device. 
Tip: Always select the source object from the chart view, for it will then remain visible, and 
you can navigate to the associated objects in the other windows and views. 
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3.4.3 Chart view 

Description 
The plan view contains the plan hierarchy of the plant with all the functions and charts. The 
plan hierarchy is represented as a tree structure. By showing and hiding levels you can 
reduce or expand the representation as you wish. With the "Go to" command you can also 
simply navigate through large plan hierarchies. Multiple selection as well as operation via 
menu commands, shortcut menus, mouse and keyboard enables a comfortable handling of 
the objects.  

 
Figure 3-4 Plan view 

Table 3-3 Key 

1 Main chart (plant chart)  
2 subordinate charts 
3 Functions 
4 Arrow keys for showing and hiding levels 
5 Arrow keys for hiding and showing the plan view in the work area 
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Actions 
The main actions available in the plan view are as follows: 
● Set up, structure and change the plan hierarchy of the plant by copying, inserting, moving 

and deleting functions and charts. 
● Inserting instances of PROFINET components from the libraries 
● Inserting and deleting new charts. 
● Copying individual functions from the project view to the chart hierarchy by means of 

drag-and-drop. 
● Explicitly removing unused functions from the chart hierarchy. The application status of 

the functions is indicated in the project view. 
● Finding associated objects in other windows and views. 
● Displaying and modifying properties of instances. 
● Downloading interconnections and programs to the destination devices of the plant 
● Comparing online with offline data 
● Diagnosing technological functions. 
● Printing charts. 

Reference to other windows and views 
When you insert the instance of a PROFINET component in the chart view, the associated 
objects are automatically shown in the various windows and views: 
● the instance in the project view 
● the function in the plant view, and in the plant tree of the project tree, and 
● the device in the network view, and in the network tree of the project tree. 
Originating from an object selected in the chart view, you can change directly to the 
associated object in another window by selecting Go to from the shortcut menu. 



Operating SIMATIC iMap  
3.4 Windows and views 

 Configuring Plants in SIMATIC iMap 
56 Configuration Manual, 01/2008, A5E00716614-02 

3.4.4 Plant view 

Description 
In the plant view, the instances of the inserted PROFINET components are visible as 
technological functions. The interconnections, i.e. the logical data connections between two 
or more technological functions, are represented by lines. These lines cannot be 
manipulated. Lines which cannot be displayed, for example, due to a lack of space are 
replaced by "continuation" connectors.  

 
Figure 3-5 Plant view 

 
1 Technological function of the instance 
2 Chart 
3 Interconnections 
4 Inputs 
5 Outputs 
6 Continuation connectors 

Actions 
The main actions available in the plant view are as follows: 
● Inserting instances of PROFINET components from the libraries 
● Displaying and modifying properties of instances. 
● Creating and deleting interconnections 
● Displaying and modifying properties of connectors 
● Downloading interconnections and programs to the devices of the plant 
● Inserting and deleting new charts. 
● Printing charts. 
● Set and display online values 
● Comparing online and offline data 
● Diagnosing technological functions and interconnections 
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Reference to other windows and views 
If, in plant view, the instance of a PROFINET component is inserted, the associated objects 
are automatically displayed in the various windows and views: 
● the instance in the project view 
● the function in the plant view, and in the plant tree of the project tree, and 
● the device in the network view, and in the network tree of the project tree. 
From a highlighted object in the plant view you can use the Go To shortcut menu to jump 
directly to the associated object in one of the other windows. 

See also 
SIMATIC iMap user interface (Page 49) 
Interconnecting Technological Functions  (Page 123) 

3.4.5 Network view 

Description 
In the network view the instances of inserted PROFINET components are displayed as 
objects with one or more network connectors. They are designated as "Devices" in the 
network view. The devices each have IP and/or PROFIBUS addresses. 
The Ethernet is created as a green line and the PROFIBUS network as a violet horizontal 
line when a PROFINET component of a PROFIBUS master with proxy functionality is 
inserted from a library. Possible insertion positions are highlighted in color. 

 
Figure 3-6 Network view 
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Actions  
The main actions available in the network view are as follows: 
● Inserting PROFINET components from the libraries. 

Note: When inserting in the network view the associated functions cannot be assigned 
charts and are therefore not visible in the plant view. Instances of functions that are not 
assigned charts are designated "unused" and are only visible in the project view. Unused 
functions can be assigned in the plan hierarchy at a later time. 

● Moving, copying, cutting or deleting devices. 
● Displaying and modifying properties of instances. 
● Inserting, cutting, moving and deleting Ethernet nodes. 
● Coupling uncoupled PROFIBUS devices to a PROFIBUS network. 
● Assigning addresses. 
● Downloading programs and interconnections to all or just the selected devices. 
● Printing the network view. 
● Online monitoring and diagnostics of devices. 
● Comparing online and offline data. 

Reference to other windows and views 
If a PROFINET component is inserted in the network view, the instance is automatically 
displayed in the project view. 
From a highlighted object in the network view you can use the Go To shortcut menu to jump 
directly to the associated object in one of the other windows. 

Uncoupled PROFIBUS devices 
Uncoupled PROFIBUS devices are saved in the network view above a separating line in the 
following cases:  
● when pasting the component into the chart view, or plant view, or project view, 
● if no PROFINET component with proxy functionality has been inserted yet or 
● when the instance of the PROFINET device with proxy functionality to which is was 

connect was deleted. 
Uncoupled PROFIBUS devices can, for example: be coupled by drag & drop to a 
PROFIBUS network.  

See also 
Connecting devices in the network view (Page 115) 
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3.4.6 Project view 

Description 
The project view represents the association between the PROFINET components in the 
library and the inserted instances - functions and devices. The instances present in the 
project plus the integrated HMI devices (if present) and their generation status are displayed 
for every PROFINET component.  
The information is shown in table format (see diagram below).  

 
Figure 3-7 Information in the project view 

Legend - project view 
 

 Column Contents 
1 Components Name, version and date of creation of the 

PROFINET component 
2 Generation status of the instance Graphical representation (symbol) 
3 Devices Icon and name of the device 
4 Functions Icon and name of the technological function 
5 Generation status of the HMI module Graphical representation (symbol) 
6 HMI Integrated HMI module  
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Icons for generation status and usage 
 

Icon Generation status of the 
instance 

Meaning 

 
Generated The generation was successful. 

 
Not generated Generation is required 

 
Symbol Using the function in the chart 

hierarchy  
Meaning 

 
In use The function is assigned to a chart 

 Not in use The function is not assigned to a chart 

Tip: The generation status and usage are indicated as tooltips.  

Actions 
You can carry out the following actions in the project view: 
● Cutting, copying or deleting instances 
● Replacing instances 
● Looking up and modifying properties 
● Assigning functions to a chart (in the chart view or plant tree) with drag-and-drop, and 

thus marking it "in use." 
● Showing/hiding instances 

Showing/hiding instances  
You can show and hide information about instances as follows: 
● Selected components using the menu commands: 

– View > Project view > Show instances or 
– View > Project view > Hide instances 

● or the commands of the shortcut menu 
– Show instances or 
– Hide instances 

● If nothing is marked, the command of the shortcut menu refer to all instances of the 
project: 
– Show all instances or 
– Hide all instances 

● By clicking on the arrow symbols in the component column. 

See also 
Generation status (Page 90) 
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3.4.7 Menu bar 
The menu bar contains the menu commands for SIMATIC iMap. A brief description of the 
selected menu command is displayed on the SIMATIC iMap status bar. A summary of all the 
menu commands can be found in the appendix. 

3.4.8 Project tree 

Description 
In the project tree, the objects in the project are shown hierarchically. The project tree has 
two parts:  
● The plant tree - corresponds to the plant view 
● The network tree - corresponds to the network view 

 
Figure 3-8 Project tree 

The technological functions of the instances are displayed in the plant tree and the devices 
in the network tree when PROFINET components are inserted into the project. Subordinate 
charts are also displayed hierarchically in the plant tree. Instances of PROFINET 
components that do not contain a technological function, e.g. the IE/PB link, are only 
displayed in the network tree. 
The plant tree contains the designation of each function, while the network tree contains the 
designation of the device, e.g. BM 147.  
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Changing the view of the project tree 
You can use the View > Project tree >... menu command to:  
● display additional information about the objects and 
● show/hide hierarchical levels. 

Actions  
The main actions available in the project tree are as follows: 
● Navigating between different charts. 
● Moving, copying, inserting and deleting objects. 
● Looking up and modifying properties. 
● Downloading programs and interconnections to the devices of the plant. 
● Comparing online and offline data. 
● Creating and opening subordinate charts in the plant tree. 

Reference to other windows and views 
Any changes in the arrangement of objects in the network tree are automatically applied to 
the network view, and vice versa. 
Any changes in the arrangement of objects in the plant tree are automatically applied to the 
plant view, and vice versa. 
When you insert the instance of a PROFINET component into the SIMATIC iMap project, the 
technological function is automatically displayed in the plant tree and the device in the 
network tree. 
Double-clicking on an object in the project tree highlights all the associated objects in the 
other windows.  

See also 
SIMATIC iMap user interface (Page 49) 
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3.4.9 Library window 

Description 
Libraries contain the reusable PROFINET components for configuring the plant. They enable 
the structured storing of PROFINET components.  
The library window includes the project library and optionally one or more further global 
libraries. The project library is assigned to the most recently opened project. It is 
automatically opened, saved and closed together with the project.  
The PROFINET components from a library can be displayed with large or small icons or as a 
list with or without detailed information via the View pop-up menu.  

 
Figure 3-9 Library window 

Actions 
You can carry out the following actions in the library window: 
● Creating, opening and closing libraries. 
● Importing PROFINET components from the file system into a library. 
● Inserting instances of the PROFINET components from a library into the SIMATIC iMap 

project. 
● Cutting or copying PROFINET components and pasting them into other libraries. 
● Displaying the properties of a PROFINET component. 
● Upgrading PROFINET components. 

 

  Note 
Libraries are stored in the file system as folders. From there they can be moved, copied, 
inserted or deleted. Libraries which are deleted in Explorer can no longer be opened via 
SIMATIC iMap. 
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Reference to other windows  
If a PROFINET component is selected in the library window, information on this component 
is displayed in the preview window.  

 
Figure 3-10 Preview window 

See also 
Preview window (Page 64) 
Library types (Page 102) 

3.4.10 Preview window 

Description 
This preview window displays information regarding the PROFINET component selected in a 
library.  
The library window must be open in order to open the preview window. 
Tip: The name of the current tab is indicated as Direct Help. 
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"General" tab 
This tab includes general information on the PROFINET component selected in a library, like 
component type, version and runtime version.  
Double-click on the "Documentation" link to open the documentation for the PROFINET 
component. The link is only displayed if the component contains a documentation link.  

 
Figure 3-11 Preview window, General tab 

"Function" tab 
This tab displays the technological function of the PROFINET component selected in a 
library.  

 
Figure 3-12 Preview window, Function tab 
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"Device" tab 
This tab displays the device for the selected PROFINET component in the bus connectors. 

 
Figure 3-13 Preview window, Device tab 

"HMI" tab 
This tab displays information regarding the HMI units of the selected PROFINET 
components (if available). 

Actions 
You can carry out the following actions in the preview window: 
● In the "General" tab: Open the documentation stored for a PROFINET component (if 

available). 
● On the "Function" tab: Display the technological function. 
● On the "Device" tab: Display the device. 
● On the "HMI" tab: Display the HMI units. 

Reference to other windows and views 
The preview window can only be opened if the library window is open. The preview window 
is closed when the library window is closed. 
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3.4.11 Information window 

Description 
The information window displays diagnostics information and information about current 
actions in SIMATIC iMap. The appropriate tab is opened automatically when new information 
arises about an action.  

 
Figure 3-14 Information window 

Content of the information window 
The information window contains two tabs: 
● Edition 

The output window displays information about current actions in SIMATIC iMap. 
● Diagnostics 

In the diagnostics window diagnostics information is displayed in online mode. In addition 
you can edit the variable table of the project under the "Variable table" tab and monitor 
variables online. 
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3.4.11.1 Output window 

Description 
The output window displays information about current actions in SIMATIC iMap. 
The appropriate tab is opened automatically when new information arises about an action.  

Content of the output window 
The following messages are automatically displayed on the tabs in the output window: 

 
Tab Contents 
General Status and progress of the action, plus any errors that occur while 

running commands, such as Open and Save, Download or Online 
Connection. 
Results when searching for objects. 

Generate Generation status and progress 
Online/Offline comparison Result of the online/offline comparison of programs and 

interconnections 
Utilization Result of the utilization check for devices and functions 

The "Reference object" column lists the names of the objects to which the messages relate.  
 

 Note 
The old content of the output window is not automatically deleted when new messages are 
displayed. 

 

Editing the content 
You can edit the content of the output window as follows: 
● Use the Edit > Output window > Copy All menu command to copy all the messages in 

text format to the clipboard so that they can be further edited, e.g. by pasting them into a 
text editor. 

● Use the Edit > Output window > Delete All menu command to delete all the messages. 

Reference to other windows 
Double-click on a reference object to highlight the associated object in the relevant view. 

See also 
Explanation of the error numbers 
Generating the Project (Page 86) 
Diagnostics window (Page 70) 
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Output window, "General" tab 
Displays information about actions, such as opening or creating projects and libraries in 
SIMATIC iMap. This output window tab opens automatically when new information arises 
about such actions. 

Output window, "Generate" tab 
Displays the progres and any errors during generation of the project. This output window 
opens automatically when a project is generated. 

See also 
Generating the Project (Page 86) 

3.4.11.2 Output window, "Online/Offline comparison" tab 

Output window, "Online/Offline comparison" tab 
Displays the results of the online-offline comparison of programs and/or interconnections. 
This output window tab opens automatically when you run an online-offline comparison. 

3.4.11.3 Output window, "Utilization" tab 

Output window, "Utilization" tab 
Displays the results of the utilization check (Page 141) of the configured devices and 
functions. This output window tab opens automatically when new information arises about 
such actions.  
Here you will find the following information: 
● Additional error messages for interconnections with cyclic transfer (Page 155) 
● A list of the utilization parameters  with actual values and limits. The utilization 

parameters can be subdivided into the following parameter groups: 
– Device parameters (Page 146)  
– General interconnection-specific parameters (Page 147)  
– Parameters for acyclic remote interconnections (Page 149)  
– Parameters for cyclic remote interconnections (Page 153)  

See also 
Utilization parameters of the PROFINET devices (Page 145) 
Performance parameters of PROFINET devices (Page 143) 
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3.4.11.4 Diagnostics window 

Description 
Diagnostic information on process variables and on faults in technological functions, devices 
and interconnections is displayed on three tabs in the diagnostic window. The three tabs in 
the diagnostic window are:  
● Functions 
● Devices 
● Variable table - described in a separate section. 
To display the diagnostic information on the "Functions" and "Devices" tabs, select the 
Online > Monitor menu command. 

See also 
Variable table (Page 74) 

3.4.11.5 Diagnostics window, "Functions" tab 

"Functions" tab 
All the malfunctions are displayed in the left-hand window. The right-hand window contains: 
● Detailed information on the selected object 
● or a reference to the associated faulty device 
● or buttons for download or call for the help. 

 
Figure 3-15 Diagnostics window, Functions tab 
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Actions 
You can perform the following actions: 
● Trace and analyze errors 
● Read troubleshooting information, for example, download required. 
● Open the cross references to faulty devices or functions in window on the right side as 

required. 
● On the right window, click a button as required: 

 
Button Action 
Diagnostics Calls device-specific diagnostics 
Download Downloading the interconnections 
Help Calls the help 

Reference to further windows and views 
An error reported in the diagnostics window is identified by a diagnostic symbol on the 
affected object in all views. 
Double-click the faulty function on the diagnostics window to display the affected 
technological function in the chart view and plant view. 
Double-click on a faulty device in the diagnostic window to the affected device in the network 
view. 
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Example of faults in technological functions 
The following diagram illustrates technological functions for which the interconnections will 
have to be downloaded. The right-hand window shows which interconnections have to be 
downloaded for the selected function. If you click on the "Download" button, the 
interconnections are downloaded to the destination system. 

 
Figure 3-16 Diagnostics window: Example of errors at technological functions  
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3.4.11.6 Diagnostics window, "Device" tab 

"Device" tab 
Information on all faulty devices is displayed in the left-hand window. The right-hand window 
contains: 
● Detailed information (including causes and remedies) on the selected object 
● or a reference to the associated faulty functions 
● or buttons for calling up help or device-specific diagnostics. 

 
Figure 3-17 Diagnostics window, Devices tab 

Actions 
You can perform the following actions: 
● Trace and analyze errors 
● Read troubleshooting information, for example, download required. 
● Open the cross references to faulty devices or functions in window on the right side as 

required. 
● On the right window, click a button as required: 

 
Button Action 
Diagnostics Calls device-specific diagnostics 
Download Downloads the interconnections 
Help Calls the help 

Reference to further windows and views 
An error reported in the diagnostics window is identified by a diagnostic symbol on the 
affected object in all views. 
Double-click the faulty function on the diagnostics window to display the affected 
technological function in the chart view and plant view. 
A double-click on the faulty device in the diagnostic window displays the affected device in 
the network view. 
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3.4.11.7 Variable table 

Diagnostics window, "variable table" tab 

Description 
The variable table is used in SIMATIC iMap for online monitoring and control of variables 
during the plant testing and commissioning phase. It has its own online mode that can be 
switched on and off independently of the online monitoring in the plant and network views. 
The variable table contains the data for the connectors of the SIMATIC iMap project to be 
monitored. You can enter the connectors directly or use drag-and-drop to insert them from 
the plant view into the variable table. 
Individual columns in the variable table can be shown / hidden using the View > Variable 
table >... menu command or with the Columns >... shortcut menu. 
The following diagram shows a variable table in the online view. 

 
Figure 3-18 Diagnostics window, "Variable table" tab 

Actions 
You can carry out the following actions in the variable table: 
● Adding, copying, deleting and sorting entries 
● Changing the display format 
● Show and hide columns 
● Monitoring and controlling all or just selected variables online 
● Editing control values and transferring them to the devices of the plant for testing 

purposes. 
● Importing and exporting data 

Reference to other windows 
The Go to > plant view: Function connection command of the shortcut menu selects the 
corresponding connection in the plant view. 
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3.5 Setting up and starting additional tools 

Setting up and starting tools 
You can configure SIMATIC iMap so that you can start any software tool with a menu 
command, e.g. in order to edit data from the current project.  

To set up a new tool: 
1. Select the Options > Customize menu command and open the "Tools" tab 
2. Click on the "New Entry" button. 
3. In the "Name" box, enter the name under which the program is to be called in SIMATIC 

iMap. 
4. In the "Command" box, enter the path of the program or click on the "Browse" button to 

select the program from the file system. You can select the following: 
– the actual program (e.g. winword.exe) or 
– a file (e.g. <document>.doc) to be opened with this program. 

5. Click on "OK" or "Accept" to confirm your input. 
Result: The program is added to the list of tools that can be called directly in SIMATIC iMap. 

 
Figure 3-19 Setting up tools 
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 Note 
You can use the buttons in the Customize dialog to move or delete entries in the tools list.  

 

To start a tool you have set up: 
You can only call tools that are entered under "Tools" in the settings.  
To start a tool, select the Options > Tools > ... menu command. 
Result: The called program is started. 
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Systems engineering 4
4.1 Basic procedure for configuring the plant 

Requirements 
The following requirements must be fulfilled before you can configure a plant using SIMATIC 
iMap: 
● SIMATIC iMap must be installed on your PC/programming device. 
● The device-specific configuration and programming tool, e.g. STEP 7, is installed on your 

PC/programming device (optional). Depending on the type of device, this software is 
needed in order to carry out certain actions, e.g. Generate. 

● The necessary PROFINET components must have been created. 

Basic procedure 
1. Start SIMATIC iMap 
2. Create or open a project. 
3. The options are as follows, depending on whether the PROFINET components have 

already been imported into a destination library: 
– If yes, then open the library with the PROFINET components. 
– If not, import the PROFINET components into the project library or into another library. 

4. Insert instances of the PROFINET components into the SIMATIC iMap project. 
5. Couple devices in the network view. 
6. Assign IP and/or PROFIBUS addresses to the devices. 
7. Arrange and interconnect technological functions in the plant view. 
8. Check the configuration (utilization) of the devices and functions (optional). 
9. Generate a SIMATIC iMap project. 
10. Document a SIMATIC iMap project (optional). 
11. Print a SIMATIC iMap project (optional). 
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Further optional tasks 
Tasks you can perform at any time: 
● Modify properties (optional). 
● Editing PROFINET components (optional) 
● Replace instances (optional). 
● Archive a SIMATIC iMap project and library (optional). 
● Exporting and importing project descriptions 

4.2 Working with projects 

4.2.1 Creating a new project 
A new SIMATIC iMap project is always opened when you open SIMATIC iMap. You can edit 
and save this project or open an existing project for editing. 

How to create a new SIMATIC iMap project 
The options for creating a new SIMATIC iMap project are as follows: 
● Restart SIMATIC iMap or 
● Select the Project > New menu command. 
A new SIMATIC iMap project opens in both cases. The associated project library is opened 
in the library window. 
The SIMATIC iMap project is stored in a folder. 

 

NOTICE  
The content of a SIMATIC iMap project folder must only be edited with SIMATIC iMap.  
If you change the project data using Windows Explorer, for example, it may no longer be 
possible to open the project in SIMATIC iMap. 

 
The actual project folder may be renamed, moved, copied or deleted in Windows Explorer, 
however. 

 

 Note 
In SIMATIC iMap, you can only edit one project at a time. If you wish to edit several projects 
at the same time, then you must start several instances of SIMATIC iMap. 
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4.2.2 Opening and closing the project 

Requirement 
A new, empty SIMATIC iMap project is always opened when you open SIMATIC iMap. You 
can open a different project at any time, provided that this project was saved in SIMATIC 
iMap. 
In SIMATIC iMap, only one project may be open at any given time. When you open a new 
project, the current project is closed and you are prompted to save any changes you have 
made in the current project. 

 

 Note 
A SIMATIC iMap project cannot be open in two SIMATIC iMap applications concurrently. 

 

To open a project in SIMATIC iMap 

 
Figure 4-1 Open the SIMATIC iMap project 
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1. Select the Project > Open... menu command. 
A dialog box for browsing the file system for existing projects opens. Look for a project file 
with the extension .cbp. 

2. Select the project folder from the "Search in" box. The box beneath displays only 
directories and files of the desired file type - SIMATIC iMap project. 

3. Select the file name with the extension .cbp. 
The file name is displayed in the "File name" box. 

4. If the selected project is password-protected, enter your password in the "Password" box. 
5. Click "Open." 
Result: The project is opened in SIMATIC iMap.  
Tip: The "File name" drop-down list contains the most recently opened SIMATIC iMap 
projects. 

 

 Note 
You can also open a project by double clicking a SIMATIC iMap project file (extension .cbp).

 

To close a project in SIMATIC iMap  
To close a project in SIMATIC iMap, you can either: 
● Exit SIMATIC iMap, 
● Create a new project or 
● Open another project. 
Each of these options closes the current project. If you have made any changes to the 
current project or to the project library, you are first prompted to save these changes. A 
dialog box with the following selection options opens:  
● "Yes" to save the changes to the current project before closing 
● "No" to close the current project without saving 
● "Cancel" to cancel the operation and return to the current project. 

 

  Note 
Changes that have to be saved with the project include the following: 
• Changes to the project library 
• Changes to the varaible table 
• Changes to the OPC prefix 
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Projects from the previous versions 
The way in which data is stored in the latest version of SIMATIC iMap has changed, and is 
no longer compatible with the previous versions. 
If you want to edit a project that was created in SIMATIC iMap V1.2 or V2.0, you will have to 
convert the data storage system to the current version. The associated SIMATIC iMap library 
of version V1.2 must be open to be able to convert the PROFINET components used from 
the version V1.2.  

To open a project in the V1.2 version 
1. Start SIMATIC iMap. 
2. Use the Library > Open... menu command to open the library that was used for the 

project from the V1.2 version. 
3. Open the project using the Project > Open... menu command. 
Result: The project is converted to the new version of the data storage system, and the 
PROFINET components used are imported into the project library.  

 

 Note 
After conversion, the project can no longer be opened with the earlier version of SIMATIC 
iMap. 
Tip: 
Save a backup copy of the project you still want to open in an earlier version of SIMATIC 
iMap before you run it in the current version. With version V1.2 projects you should also copy 
the library with the necessary PROFINET components.  
Tip: 
A backup copy of the original project is generated in the folder containing the converted 
project. The folder is called "V20backup" or "V12backup". If you still want to keep the project 
open with the earlier version of SIMATIC iMap then use this copy. 
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4.2.3 Protect project 

Effect of the project protection 
You can assign a password to your SIMATIC iMap project to protect it against unauthorized 
access. The password together with the level of protection is defined in the project properties 
and must be entered when you open the project. 
You can choose one of the following levels of protection for a SIMATIC iMap project: 

 
Project protection Meaning 
No protection No password is required to open and change the project. 
Write protection A password is required to change the project. A protected 

project will be opened read only if you do not enter the 
password, i.e. you can not edit the configuration data and 
properties.  
When a project is write-protected, all the views have a gray 
background in SIMATIC iMap. 

Read protection A password is required to open the project. If the correct 
password is not entered, the project will not open. 

How to define the security level of a project  
1. Open the project properties using the Project > Properties menu command. 
2. On the "Project security" box, set the "Change security level" check box 
3. Select the "Write protection" or "Read protection" option. 
4. Assign a password as required. Type the password into the "New password" box, then 

repeat it in the "Confirm" box. 
5. Confirm your entry with "OK" or "Accept". 

How to change the project password  
1. Open the project properties using the Project > Properties menu command. 
2. Make sure you have set the "Change security level" check box at the "Project security" 

field, and either the "Write protection" or "Read protection" option. If not, select one of 
those security levels. 

3. On the "Project security" box, set the "Change password" check box 
4. To change an existing password, enter the old password in the "Old password" box. Then 

enter the new password in the "New password" box and then repeat it in the "Confirm 
password" box. 

5. Confirm your entry with "OK" or "Accept". 
 

  Note 
The project security settings are retained in your project backup and restore files. 
The project's security settings are not applied to the project description after an export. 
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To cancel the password protection: 
To cancel the password protection for a project: 
1. Open the project properties using the Project > Properties menu command. 
2. On the "Change security level" area in the "Project security" field, set the "No protection" 

option. 
3. Enter the old password in the "Old password" box. 
4. Confirm your entry with "OK" or "Accept". 

Possible actions on a write-protected SIMATIC iMap project 
If a SIMATIC iMap project is write protected, neither the configuration data nor the project 
properties can be altered. However, the following actions are possible: 
● Online and diagnostics functions, e.g. online device analysis, online - offline comparison 

or monitoring varaible table online 
● Downloading Programs and Interconnections 
● Check the utilization 
● Consistency check 
● Re-edit components 
● Check the properties 
● Documenting and printing a project 
● Display and navigation functions 

4.2.4 Saving and archiving a project 

Data storage of a SIMATIC iMap project 
A SIMATIC iMap project is created in the form of a directory tree, and can be stored as an 
archive file. 
If you save it, all the files belonging to the SIMATIC iMap project are stored in a separate 
folder. You are prompted to enter the path when you save the project for the first time. You 
can enter any name for the project file. It is automatically assigned the extension cbp. The 
project file is stored together with other project data in a folder of the same name. 
If you archive it, all the project data is stored in an archive file. You can assign a user-
specific file name. It is automatically given the extension .arp. 

 

 Note 
Use the Options > Customize menu command to define, on the "Directories", a storage 
location that will be suggested by default when you open, save or archive projects. 
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How to save a SIMATIC iMap project  
The options for saving a project in SIMATIC iMap are as follows:  
● Select the Project > Save menu command to save the current project under the same 

name. The old project is overwritten. 
● Select the Project > Save As... menu command to save the current project under a 

different name. The old project remains unchanged. You can enter any path and name 
for the new project. 

If you save a project with a new name, it retains its password protection. The project library 
is saved together with the project. 

To archive the currently opened SIMATIC iMap project  
 

 Note 
The last stored version of the currently opened project is archived. If there are unsaved 
changes in the project, you will be prompted to save them first before archiving. 

 
To archive the project that is currently opened, proceed as follows:  
1. Select the Project > Archive > Open project menu command. 

A dialog box for selecting the storage location opens.  
2. In the "Archive iMap project library as" dialog box, select the folder in which the archive 

file is to be stored. 
3. Accept the name suggested in the "File name" box, or enter a different name for the 

archive file, then click "Save." 
Result: The archive file is created and the result is signaled on screen. The project library is 
archived together with the project. 

To archive a stored SIMATIC iMap project  
To archive any SIMATIC iMap project, proceed as follows:  
1. Ensure that the project is not opened in SIMATIC iMap. 
2. Select the Project > Archive > Stored project menu command. 

A dialog box for browsing the file system for existing projects opens. Look for a project file 
with the extension .cbp. 

3. Select the project folder from the "Search in" box. The box beneath displays only 
directories and files of the desired file type - SIMATIC iMap project. 

4. Select the file name with the extension .cbp. 
The file name is displayed in the "File name" box. 

5. Click "Open." 
A dialog box for selecting the storage location opens.  

6. In the "Archive iMap project library as" dialog box, select the folder in which the archive 
file is to be stored. 
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7. Accept the name suggested in the "File name" box, or enter a different name for the 
archive file, then click "Save." 

Result: The archive file is created and the result is signaled on screen. The project library is 
archived together with the project. 

 

 Note 
The backup file of a project retains its project security. 

 

How to restore a SIMATIC iMap project  
 

 Note 
You can only retrieve projects that were archived with SIMATIC iMap.  

 
To retrieve a project, proceed as follows:  
1. Select the Project > Retrieve... menu command. 

This opens a dialog box where you can run a search in the file system for existing archive 
files.  

2. Select an archive file (.arp file). There are two options: 
– Search for the required archive file in the "Search in" field, or 
– Select the most recently archived projects from the "File name" drop-down list. 

3. Click "Open." 
A dialog box for selecting the target folder opens.  

4. Select the folder to which you wish to save the retrieved project and click "OK". 
Result: The project folder is created in the specified destination folder and the result is 
signaled on screen. 
 

See also 
Generating the Project (Page 86) 
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4.2.5 Generating the Project 

4.2.5.1 Generating the Project 

Generating projects in SIMATIC iMap 
You need to generate a project before you can download its data to the devices of the plant. 
When you generate the project in SIMATIC iMap, the current project data of all instances of 
PROFINET components of the SIMATIC iMap project are prepared for a device-specific 
shadow project to allow a download to the destination devices of the plant.  
To generate project data in SIMATIC iMap, you require the manufacturer-specific 
configuration and programming tool for the configured devices, for,example, STEP 7 for 
SIMATIC automation devices. A separate generating process is required for each integrated 
manufacturer-specific configuration and programming tool. The current version of SIMATIC 
iMap supports the following generation processes: 
Menu command Device type 
Project > Generate > Control unit > Control units of the SIMATIC automation devices 
Project > Generate > HMI unit > HMI unit of the SIMATIC automation devices 

Unless expressly stated, the descriptions in the next sections apply to the generation of 
control units of SIMATIC automation devices. A description of the HMI units can be found 
under "Special PROFINET component types, PROFINET components with HMI units". 

The shadow project 
The shadow project contains the device-specific data of the controller units of the project. 
The shadow project does not contain any HMI units and singleton components (see the 
chapter "Special PROFINET component types"). 
The shadow project is created based on the component projects of the project library when 
the SIMATIC iMap project is initially generated. All changes in the SIMATIC iMap project, 
such as the IP or PROFIBUS addresses, will be applied to the shadow project when you 
generate the project.  
The shadow project is required for the program download. 

 

 Note 
The Project > Save command does not update the shadow project. 

 
CAUTION  
The shadow project may not be modified directly using the manufacturer-specific 
configuration and programming tool (STEP 7, for example)! 
Changes to the shadow project may lead to data inconsistency in the SIMATIC iMap 
project, and thus prevent a download. 
Possible remedies: 
• Regeneratethe SIMATIC iMap project. 
• Create new PROFINET components based on the modified shadow project, and replace 

the old instances. 
Select the Edit > Consistency check > Generate project command to compare the current 
shadow project with the corresponding component project(s). The result of the consistency 
check is shown in the task window. 
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Actions applied when the project is generated 
The following actions in SIMATIC iMap are applied when the project is generated: 
● Cut, paste or delete instances and interconnections 
● Replacing instances 
● Pasting new instances into the project 
● Changing instance properties such as names or addresses 
● Changes to the device networking, such as connecting and disconnecting PROFIBUS 

devices. 
 

  Note 
Any such changes in the project can not be downloaded to the devices of the plant unless 
you have generated the control units in the project.  
View the generating status to determine whether a generation is required. The generation 
status of the instance of a PROFINET component is displayed in the project view and in 
the Properties dialog box of the instance. The generation status "generated" means that a 
download to the corresponding devices of the plant is possible.  

Actions not transferred when the project is generated 
● Changes made at device-specific data of the shadow project using one of the Edit > 

Special... menu commands. Download those changes to the devices in the plant using 
the manufacturer-specific configuration and programming tool. 

● Changes in the graphic layout, such as the position in the chart or plant views. 

Requirement 
Before you generate a project, make sure the necessary manufacturer-specific configuration 
and programming tool, e.g. STEP 7, is installed on the computer. 

How to generate changes made in the control units of the project  
Select Project > Generate > Control unit > Changes only to generate only the project delta 
data. The messages indicating generation progress and errors are output to the "Generate" 
tab in the task window. 
The shadow project is created based on the component projects of the library (libraries) 
when you initially execute this command. . The shadow project is updated with the delta data 
at each further call of this command.. 
If the generation was successful, the "generated" generation status is assigned to all project 
components. The program is ready for download. The generation status can be viewed in 
the project view (green icon), or at the instance properties.  
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To regenerate the control units of the project 
If the generation of a SIMATIC iMap project fails because the shadow project contains 
corrupted or inconsistent data, for example, you need to create a new shadow project. The 
new shadow project is generated based on the component projects for the PROFINET 
components of the library (libraries.)  
Select Project > Generate > Control unit > All new. If the project is already generated, a 
message is output to indicate the effects of the command. Acknowledge this message by 
clicking "Yes" if you want to generate new data.  
The messages indicating generation progress and errors are output to the "Generate" tab in 
the task window. 
Result: The shadow project is once again generated based on the PROFINET component 
projects of the project library. The generated new shadow project does not contain changes 
made using the manufacturer-specific configuration and programming tool. As an option, a 
backup copy will be generated of the old shadow project (controller element) to let you trace 
any changes compared to the new shadow project. 

Backup copy of the shadow project 
To generate a backup copy of the shadow project (controller element) when you generate 
project again:  
1. Select Project > properties to open the "Special" tab. 
2. On the "Generate all" input box, set the "Always create backup copy of the controller unit" 

option, then confirm your setting with "OK" or "Accept." 

Result 
A backup copy of the shadow project (controller element) will be created in the project folder 
when you regenerate the project. 

Accelerated regeneration for PROFINET devices without proxy functionality  
You can optionally specify that the control units of the PROFINET devices without proxy 
functionality are not copied into the shadow project when the project is regenerated. Proceed 
as follows: 
1. Select Project > properties to open the "Special" tab. 
2. On the "Regenerate all" box, set the "Accelerated generation for PROFINET devices 

without proxy functionality" option, then confirm with "OK" or "Accept." 
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Result 
Regeneration of the project is accelerated. The resulting shadow project is smaller and thus 
requires less storage space. 

 

 Note 
After a changeover between "normal" generation and accelerated generation, the next 
generation of the project is always carried out as a regeneration. 

 
 Note 

The generated control units are required for the download to the target devices and for the 
execution of device-specific functions (Edit > Special > menu command.)  
If the "Accelerated generation for PROFINET devices without proxy functionality" option is 
activated, execution of the Download and  Edit > Special > menu commands can take 
slightly longer, since temporary STEP 7 projects have to be created.  
No consistency check is carried out for the instances of such devices because there is no 
comparison data in the shadow project. 

 

Canceling generation 
it may take a longer time to generate a large-scale project. You can cancel the generation of 
deltas at any time by clicking "Cancel" on the message box, and continue at a later time. Any 
data already generated are retained after you cancelled the operation. 
At the next call of the Project > Generate > Control unit > Changes only command, the 
system generates only the new, modified and raw data of the project elements. 

Generating the HMI unit 
The HMI units of the instances are generated using the Project > Generate > HMI units 
command.  
For further information, refer to "Special PROFINET component types, PROFINET 
components with HMI units". 

See also 
Saving and archiving a project (Page 83) 
Generation status (Page 90) 
Check consistency of the generated project (Page 91) 
Data storage in SIMATIC iMap (Page 92) 
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4.2.5.2 Generation status 

Status of the shadow project 
The shadow project is generated in SIMATIC iMap based on the PROFINET component 
projects of your project.  
The generation status of a PROFINET component instance is indicated on the "Instance" tab 
in the Properties. Select the technological function or device, and then select the 
Properties... shortcut menu.  

 
Generation status Meaning Action 
Not generated The shadow project is not yet 

generated, or it does not yet 
contain the instance 

Generating the project 
only the deltas 
all new 

Generated The shadow project is 
generated and contains the 
instance. The instance 
properties and the STEP 7 
shadow project are consistent. 

No action required 

Inconsistent / modified The instance properties were 
modified and are now 
inconsistent with the shadow 
project. 

Generating the project 

Generation not possible The instance properties contain 
illegal values (ambiguous 
address, for example) which 
prevent generation. 

Eliminate the error(s), and then 
once again generate the project 

Graphical representation of the generation status 
The generation status of an instance is represented graphically in the project view (see 
"Windows and views, project view"). 
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4.2.5.3 Check consistency of the generated project 

Consistency check of the generated project, definition 
The consistency check of a generated project comprises a comparison between device-
specific data of the shadow project and the data of the original component project. This 
allows you to identify changes made in the shadow project using the manufacturer-specific 
configuration and programming tool.  
The result of the consistency check is indicated on the "General" tab of the task window. 

Items checked 
The consistency check of the generated project for SIMATIC automation devices is carried 
out with the help of STEP 7. In doing so, the program blocks of the station in the shadow 
project are compared with those of the original component project in the SIMATIC iMap 
library. The check determines whether program blocks have been added, removed or 
changed in the shadow project.  

 

 Note 
If the "Accelerated generation for PROFINET devices without proxy functionality" option is 
activated, no consistency check is carried out for the instances of such devices, because no 
data were copied into the shadow project for these devices. 

 

Requirements 
● The manufacturer-specific configuration and programming tool (STEP7, for example) is 

installed on the PG/PC. 
● The project is generated, i.e. the generation status of the instances to include in the 

consistency check is created. 

How to check consistency of the generated project 
1. Select the instances to be checked from the plant view or network view. 
2. Select Edit > Check consistency > Generated project.  
The system checks consistency of the generated project and outputs the results in the 
"General" tab of the task window. 
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4.2.6 Structuring projects 

4.2.6.1 Data storage in SIMATIC iMap 
The SIMATIC iMap data storage comprises in particular the following types of folder:  
● PROFINET components 
● SIMATIC iMap libraries 
● SIMATIC iMap projects 
The section below describes the storage structure of these folders.  

Project structure for PROFINET components  
Within its life cycle, a PROFINET component may handle various classes of projects, with 
contents and structures defined in manufacturer-specific configuration and programming 
tools for the component. We distinguish between the following project classes: 
● The basic project, for example a STEP 7 project, forms the source for the creation of the 

PROFINET component using manufacturer-specific configuration and programming tools.  
● The component project is a copy of the basic project which is assigned to the completed 

PROFINET component. It is saved to a compressed file in the folder of the PROFINET 
components in the file system, or to a library. The component project forms the basis for 
the revision of PROFINET components.  

 
Figure 4-2 Project structure for PROFINET components 
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Storage structure of PROFINET components 
A PROFINET component consists of a folder which contains: 
● The XML file (PCD file) which contains the description of the PROFINET component. The 

system searches for this XML file when importing to a library. 
● The icon files 
● The compressed component project (copy of the relevant element from the basic project) 
● The documentation link file (optional.) 
The folder name is derived from the name, the identification (class ID) and the version 
number of the PROFINET component.  

Storage structure of the SIMATIC iMap libraries 
A SIMATIC iMap library is created in folder format. The important part is the library file of the 
same name and file name extension *.cbl which must be specified when the library is 
opened. A library also contains the PROFINET components folder. 

Storage structure of SIMATIC iMap projects 
The SIMATIC iMap project represents the working project which contains the configured 
PROFINET component instances and their interconnections for a specific plant.  
A SIMATIC iMap project is created as a folder. The important part is the project file of the 
same name and file name extension *.cbp which must be specified when you open the 
project. A project folder also contains: 
● Configuration data for the inserted instances of the PROFINET components 
● the project library 

– visible as a separate folder if the project is open 
– not visible (compressed) if the project is closed. 

● one or more shadow projects, created when the SIMATIC iMap project is generated. 
● the variable table, if one was created. 
The shadow project contains the device-specific data of the SIMATIC iMap project. The 
shadow project is created based on the component projects of the project library when the 
SIMATIC iMap project is initially generated. The shadow project is required for the program 
download.  
The shadow project is created device-specific or manufacturer-specific. For example, the 
HMI units of a SIMATIC iMap project form a separate shadow project. 



Systems engineering  
4.2 Working with projects 

 Configuring Plants in SIMATIC iMap 
94 Configuration Manual, 01/2008, A5E00716614-02 

Further object classes and file types 
The following object classes and file types are used in SIMATIC iMap: 
● Archive files 
● Project documentation 
● Variable tables 
● OPC symbol files 
● Online device analyses 
● Revised component projects 
● Project descriptions 
SIMATIC iMap provides default storage locations for all file and folder types used. The 
descriptions of file types used are available in the appendix. 

Default storage paths 
Select Options > Settings to open the "Directories" tab where you can view the default 
folders used as storage locations for the file types used in SIMATIC iMap. The system 
suggests those storage locations before you create, save and select the corresponding file 
types. 
Click "Modify" to change the paths.  
These settings apply to all SIMATIC iMap projects. 

Archiving in the current project folder 
The following objects can be archived in the current project folder: 
● Variable tables 
● Project documentation 
● OPC symbol files 
● Online device analyses 
● Project descriptions 
In order to store specific objects in the current project folder, enter the string "$PRJ\" as the 
storage location. A subdirectory can be specified optionally. 

See also 
Special features of systems containing SIMATIC devices (Page 207) 
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4.2.6.2 Grouping projects 

Interconnecting connections with external projects 
SIMATIC iMap supports interconnecting of connections to several external projects. This 
creates interconnections between technological functions located in different projects.  

 
Figure 4-3 Interconnection with external projects 

The interconnection source is an output in the source project, and the destination is an input 
in the destination project. An interconnection between two projects is always configured at 
the input (receiver) of the destination project. 
You have several options of creating interconnections to external projects  
● using drag-and-drop 
● using menu commands 

 

  Note 
In the utilization check of the devices, the outgoing interconnections with external projects 
are not taken into consideration. Only the incoming interconnections of external projects 
in the destination project are included. 
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Requirements 
● In the source project, the device must have assigned an IP address to the instance to be 

interconnected with external projects. If the source connection is on a PROFIBUS device, 
the associated PROFINET device with proxy functionality must have an IP address. 

● Only when creating interconnections to external projects using drag-and-drop: 
The connections to be interconnected with external projects must be available in the chart 
interface of the main chart (plant chart) of the relevant project.  
For each connection to be interconnected: select the connection, and set the "In chart 
interface" option from the shortcut menu. If the connection is located in a nested chart, 
repeat this procedure until the connection is contained in the chart interface of the plant 
chart. 

How to create interconnections with external projects using drag-and-drop: 
1. Start SIMATIC iMap twice. 
2. Open the destination and source projects in separate SIMATIC iMap applications. 

Arrange the windows on the PC/PG desktop so that both are visible. 
3. In plant view, open the chart interface of the plant chart in both projects. Confirm this 

operation by clicking the "Open chart one level up" icon. 
4. In the source project, select the output to be interconnected, hold down the left mouse 

button and drag an interconnection to the input of the destination project. 
Result: The input is marked interconnected with external projects. 

5. Select the device or the technological function which contains the input which is 
interconnected to external projects. 

6. Download the interconnection to the device using the Download Selected Device > 
Interconnections only command. 
Result: This downloads the interconnection, and generates the communication 
connection to the partner device in the source project. In SIMATIC iMap, you can then 
monitor online delta values at the connections which are interconnected to external 
projects in the source and destination project. 
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How to create interconnections with external projects using menu commands 
1. In SIMATIC iMap, open the destination project which contains the input you want to 

interconnect with an external project. 
2. From the plant view, select the input to be interconnected with an external project, or 

select External interconnection from the shortcut menu. 
3. On the "Properties - External interconnection" dialog box, enter the following data from 

the source project in the "From" input box (see the example below): 
– the IP address, 
– the name of the PROFINET device, 
– the name of the technological function, 
– the name of the source output for the interconnection 

4. Define the transfer parameters for the interconnection in the "Transfer parameters" input 
box. You can either accept the defaults or edit the parameters. 

5. In the "Substitution value" input box, configure a substitution value for the interconnection. 
6. Click "OK" or "Apply" 

Result: The input will be assigned the interconnection data, and the connection is added 
to the chart interface of the plant chart and marked as external interconnection. 

7. Select the device or the technological function that contains the input which is 
interconnected to external projects. 

8. Download the interconnection to the device using the Download Selected Device > 
Interconnections only command. 
Result: This downloads the interconnection, and generates the communication 
connection to the partner device in the source project. In SIMATIC iMap, you can then 
monitor online delta values at the connections which are interconnected to external 
projects in the source and destination project. 
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Example: Interconnection with external projects 
The diagram below shows the data of the connection in the source project that you must 
enter using the Edit > Interconnect externally menu command when you create the 
interconnection to external projects. 

 
Figure 4-4 Configuring an interconnection with external projects 

See also 
Library types (Page 102) 
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4.2.7 Project logging 

Content of the project documentation 
You can create a documentation containing the following information on a SIMATIC iMap 
project: 
● General project data such as the name, path and creation date 
● All the technological functions and nested charts of the plant chart, including their 

interconnections 
● All PROFINET and PROFIBUS devices of the network chart 
● The PROFINET components used as library elements, including their instances (devices 

and functions), in the project 
● Optional - descriptions of the interconnectable and non-interconnectable connections of 

the technological interfaces 
● Optional - graphical representations of all charts (network chart, plant chart, and nested 

charts) 

How to create the project documentation 
1. Select the Project > Documentation command. 
2. On the "Create Project Documentation" dialog box, set the options for the information to 

be transferred to the documentation. 
3. If necessary, click "Modify" to change the path of the project documentation. 
4. Click "OK." 
Result: The most current version of the project is documented. The project documentation is 
stored as a collection of HTML files together with the associated graphics files (icons, etc.) in 
the folder.  
The project documentation is structured as an online document, rather than as a template for 
printing. Use the menu command Project > Print to print the project data. 

 

 Note 
The project documentation is recreated whenever you call the Project > Documentation 
menu command.  
You can display stored project documentation versions by opening the HTML file directly in 
an HTML browser. 
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4.2.8 Print Project 

General print settings 
Select Options > Settings, then select the "Print" tab to define the settings for printing all 
views. 
● Views to print 
● Zoom ratio 
Those settings apply to all SIMATIC iMap projects. You can define separate settings for 
each print job (Project > Print >All views, "Settings tab".) 

To set up the page for printing: 
Select the Project > Page Setup menu command to make the following settings for printing 
the current window: 
● Paper size and source 
● Orientation: Portrait or landscape format 
● Width of the page margins 

To set up the header and footer 
To set up the headers and footers of the hardcopy: 
1. Select the Project > Headers and Footers menu command. 

A dialog box for setting the header and footer opens. 
2. Enter the content of your header and footer. You can edit the "Left", "Middle" and "Right" 

input boxes. The field buttons can be used to automatically insert field functions, such as 
the project name or page. 

3. Specify the font and point size, if necessary. 
4. You can specify the type of separating lines to be inserted between adjacent pages and 

for the lines in the header and footer. 
5. Click on "OK" to accept the settings. 

To print the project: 
● Select Project > Print > Active view to outputs a selected view of the work area in the 

current project to the printer. The active window is printed with the current zoom factor. 
● Select Project > Print > All views to print all views of the work area in the current project. 

This outputs the plant view to the printer, including all nested charts Adapt the current 
zoom ratios on the "Settings" tab as required. 

Large projects are printed on several pages. 
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Tip: Showing page margins 
Select View > Chart view/Plant view/Network view/Project view > page margins, or Options > 
Settings > "Print" tab to output the page margins in the selected view. This provides a 
preview of the printed area. 

4.2.9 Exporting and importing projects 

Data exchange between SIMATIC iMap and other applications 
SIMATIC iMap provides import and export functions for exchanging configuration data 
between SIMATIC iMap and other configuration tools. The data are exchanged using a 
project description file in XML format. 
The export function saves all files belonging to the SIMATIC iMap project to a separate 
folder. You can enter a user-specific storage path and name for the project description file. 
The export file is automatically assigned the extension .cbi.  

 

 Note 
Select Options > Customize. In the "Directories" tab, you can accept the default storage 
location proposed by the export and import function. 

 

How to export a SIMATIC iMap project: 
1. Open the SIMATIC iMap project. 
2. Select Project > Export. 
3. In the "SIMATIC iMap project description export to" dialog, define the path and name of 

the project description file. 
Search for the required folder in the "Find in" input box as required. 

4. Click "Save". 

Result 
The folder with the project data and project description file will be created. 

 

 Note 
The project security setting is not applied to the exported project description. 
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How to import a SIMATIC iMap project: 
1. Open the required SIMATIC iMap project as the basis for an import. 
2. Select Project > Import. 

This opens a dialog box where you can search the file system for existing project 
descriptions in the exchange format. Search for a project description file with the 
extension *.cbi. 

3. Select the export folder from the "Find in" box. The search result box below shows only 
the folders and files of the project description.file type. 

4. Select the file name with the extension .cbi. 
The file name is displayed in the "File name" box. 
Tip: The "File name" drop-down list contains the most recently opened SIMATIC iMap 
project descriptions 

5. Click the "Open" button. 

Result 
The current instances and interconnections are deleted from the project. The configuration 
data of the imported project are inserted in the current project, including all properties and 
interconnections. The PROFINET components will be inserted into the project library.  

 

 Note 
The generation status of imported instances is based on data of the current project, and is 
retained in the import file, provided the instances of the imported project correspond with 
those of the current project. When SIMATIC iMap projects were edited in other configuration 
tools, this feature is useful to minimize computing time required for generation before you 
download the imported configuration data to the destination devices of the plant  

 

4.3 Working with libraries 

4.3.1 Library types 

Project libraries and global libraries 
There are two types of library in SIMATIC iMap: 
● Project library which is contained in a SIMATIC iMap project and is opened, closed, 

archived and retrieved automatically with the project. The project library contains all the 
PROFINET components the instances of which are contained in the project. The 
information needed to generate the project is thus available.  

● (Global) library that can be opened, closed, archived and retrieved using menu 
commands. The global library contains PROFINET components that can be used in 
several projects.  
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In the following descriptions, the global library is simply called the "library". 
When a PROFINET component is inserted into the project from a global library, it is 
automatically inserted into the project library as well. 

 
Figure 4-5 Example: Project library and global libraries 

Comparison between project and global libraries 
 
Property/Action with the project library with global libraries 
Create automatically with the project  independently of the project, using the Library 

> New... menu command 
Name Project library any 
Open / Close automatically with the project  separately from the project, using the Open 

library... or Close library menu command 
Import PROFINET 
Components 

• automatically when the PROFINET 
component is inserted into the project from 
a global library or 

• using the Library > Import components 
menu command 

using the Library > Import components menu 
command 

Number of open libraries exactly one  any 
Copy PROFINET 
component 

any any 

Delete PROFINET 
component 

only possible if there is no instance of the 
PROFINET component in the project 

any 

Archive / Retrieve automatically with the project using the Library > Archive... or Library > 
Retrieve... menu command 
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4.3.2 Create new library 

Data storage of SIMATIC iMap libraries 
In the SIMATIC iMap library window, you can open, close or create any number of shared 
libraries in any project you are editing. 
Shared libraries can only be created, opened, closed, backed up and restored using the 
menu commands. 
The libraries are created as folders in SIMATIC iMap. When you create a new library, the 
system generates a new library file with the extension .cbl. You can assign this file a user-
specific name. The file is stored in a folder of the same name. You can select a user-specific 
path.  
You can also archive an existing library. In this case, the entire content of the library is saved 
in an archive file with the extension .arl. You can assign a user-specific path and name to the 
archive file.  

How to create a new library: 
1. In SIMATIC iMap, select the Library > New... command. 

This opens a dialog box for searching the file system. 
2. Select the folder in which the library is to be created from the "Search in" box. 
3. Enter the name of the library in the "File name" input box. The name is automatically 

assigned the extension .cbl. 
4. Click "Save". 
Result: The shared library is created and opened. 

See also 
Library types (Page 102) 
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4.3.3 Opening and closing libraries 

Requirement 
The library must have been created in SIMATIC iMap. 

How to open an existing library 
1. In SIMATIC iMap, select the Library > Open... command. 

This opens a dialog box where you can run a search in the file system for existing 
libraries.  

2. Select the library folder from the "Search in" box. The search result box below shows only 
the folders and files of the SIMATIC iMap library file type. 

3. Select the file name with the extension .cbl. 
The file name is displayed in the "File name" box. 

4. Click "Open." 
Result: The library is opened in the SIMATIC iMap library window. 
Tip: The "File name" drop-down list contains the most recently opened SIMATIC iMap 
libraries. 

How to close a library  
1. Click in the library you want to close. 
2. You can then either: 

– Click the cross (X) on the top right-hand corner of the library, or 
– Select Library > Close, or 
– Select Close library from the shortcut menu. 

Libraries from earlier versions 
A library created on an earlier version of SIMATIC iMap is automatically converted to the 
data storage system of the current version when you open it.  

 

 Note 
A converted version V1.2 library can no longer be opened in SIMATIC iMap V1.2. 
Tip: 
Save a backup copy of the project you still want to open in the earlier version V1.2 of 
SIMATIC iMap before you run it in the current version. 

 

See also 
Data storage in SIMATIC iMap (Page 92) 
Library types (Page 102) 
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4.3.4 Importing PROFINET components 

PROFINET components in libraries 
A PROFINET component must be located in a library before it can be inserted into a 
SIMATIC iMap project. Instances of the PROFINET component can then be inserted from 
this library into the project. 
When you create a PROFINET component, you can define whether it should be stored in the 
file system or imported into an existing global library. If a PROFINET component was 
created in the file system, then it can subsequently be imported into a library in SIMATIC 
iMap. 

Unique identification of PROFINET components 
PROFINET components are uniquely identified by the identification (ID) and the version 
number. Both the ID and the version number are displayed in the "Properties" dialog for the 
PROFINET component. 

 

 Note 
PROFINET components cannot be overwritten by importing into a library. If the library 
already contains a PROFINET component with the same version number and identification 
(ID), then the selected component will not be imported.  

 

Requirement 
The PROFINET component must have been created using the vendor-specific configuration 
and programming tool, e.g. STEP 7, and must have been stored in the file system. 

To import a PROFINET component into a library:  
1. Click on the library into which you wish to import the PROFINET component. 
2. Select the Library > Import PROFINET components menu command. 

A dialog box for browsing the file system for existing PROFINET components opens. The 
system searches for the associated XML files. 

3. Select an XML file. 
Tip: Click on the down arrow in the "File name" box to display a list of the most recently 
opened XML files. 

4. Click on "Open" to import the selected PROFINET component. 
Result: The selected PROFINET component is imported and the component's icon appears 
in the library. 
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4.3.5 Administering PROFINET components in libraries 

Processing possibilities in the library 
You can edit PROFINET components contained in one or more libraries in the following 
ways: 
● Move from one library to another 
● Cut 
● Copy 
● Paste cut or copied PROFINET components 

To move a PROFINET component: 
You can move a PROFINET component from one library to another: 
● Using drag & drop 
● By cutting and pasting 

To delete a PROFINET component  
You can delete a PROFINET component from a library:  
● Using the "Delete" key 
● Using the Edit > Delete menu command. 
PROFINET components can only be deleted from the project library if they are not being 
used in the project. 

Copying, cutting and pasting PROFINET components  
You can use the following menu commands: 
● Edit > Copy - Copies the selected PROFINET component to the clipboard. 
● Edit > Cut - Cuts the selected PROFINET component and places it on the clipboard. 
● Edit > Paste - Inserts the clipboard contents. 
The commands are also available in the pop-up menu, depending on which window is active. 
 

See also 
Library types (Page 102) 
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4.3.6 Archiving and retrieving libraries 
The next section only deals with shared libraries. The project library is always automatically 
archived and restored together with the project. 

Data storage of shared SIMATIC iMap libraries 
A shared SIMATIC iMap library is created in the form of a directory tree, and can be stored 
as an archive file. 
When you archive a shared library, all PROFINET component data will be backed up to an 
archive file. You can assign a user-specific file name. It is automatically assigned the 
extension .arl. 

 

 Note 
Select Options > Customize, then select the "Directories" tab to accept the default storage 
location for shared libraries when you create, open or archive shared libraries.  

 

How to archive a shared library  
1. Select the Library > Archive... command. 

This opens a dialog box where you can run a search in the file system for existing 
libraries. Search for a file with the extension .cbl. 

2. Select the library folder from the "Search in" box. The search result box below shows only 
the folders and files of the SIMATIC iMap library file type. 

3. Select the file name with the extension .cbl. 
The file name is displayed in the "File name" box. 

4. Click "Open." 
A dialog box for selecting the storage location opens.  

5. On the "Archive iMap library as..." dialog box, select the folder for the archive file. 
6. Accept the name suggested in the "File name" box, or enter a different name for the 

archive file, then click "Save." 
Result: The archive file is created and the result is output to the screen. 
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How to retrieve a library  
 

 Note 
You can only retrieve libraries that were archived with SIMATIC iMap.  

 
To retrieve a library, proceed as follows:  
1. Select the Library > Retrieve... menu command. 

This opens a dialog box where you can run a search in the file system for existing archive 
files.  

2. Select an archive (.arl file). There are two options: 
– Search for the required archive file in the "Search in" field, or 
– Select a file from the list of most recently archived libraries from the "File name" field. 

(Click on the down arrow in the "File name" box to display a list of the most recently 
archived libraries.) 

3. Click "Open" to select the archive file. 
A dialog box for selecting the target folder opens.  

4. Select the folder to which you wish to save the retrieved library and click on "OK". 
Result: The library folder is created in the specified target folder and the result is signaled on 
screen. 

See also 
Library types (Page 102) 
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4.4 Working with instances of PROFINET components 

4.4.1 Structuring plants 

4.4.1.1 Inserting instances of the PROFINET components in a SIMATIC iMap project 

Instances of a PROFINET component 
A PROFINET component forms a class, i.e. a template for one or several instances, and 
describes the internal structure of those instances. The insertion of a PROFINET component 
from a library in a SIMATIC iMap project generates an instance of the PROFINET 
component in the project, i.e. an application of this component class. Each instance is 
assigned additional properties, for example, a name and address. One or more instances of 
a PROFINET component may be inserted into a project.  
The association of all instances to the original PROFINET component is derived from the 
instantiation, and can be checked in the instance properties by defining the ID and version 
number of the corresponding component.  

Options of inserting an instance in the SIMATIC iMap project 
You can insert the instance of a component in one of the following windows: 
● Chart view 
● Plant view 
● Network view 
● Project view 
● Project tree (plant tree and network tree). 
In all cases the entire instance is inserted, i.e. both the technological function (if available) 
and the associated device.  
You can insert instances of components without technological functions in one of the 
following windows: 
● Network view 
● Project view 
● Network tree 

Requirements 
● The PROFINET components that you want to insert into your project must be contained 

in a library in SIMATIC iMap. 
● The chart view of the project is open. 



 Systems engineering 
 4.4 Working with instances of PROFINET components 

Configuring Plants in SIMATIC iMap 
Configuration Manual, 01/2008, A5E00716614-02 111 

How to insert the instance of the PROFINET component into the project:  
1. Select the PROFINET component from the library. 
2. Insert it in a chart in the chart view. There are several options: 

– Drag-and-drop 
– Copy and Paste menu commands 

Result 
The technological function of the component, if it contains any, appears in the chart view, in 
the plant view, in the project view and in the plant tree of the project tree. The associated 
device appears in the network view, in the project view and in the network tree of the project 
tree. The diagram below shows the presentation of a component instance in SIMATIC iMap. 

 
Figure 4-6 Instance of a PROFINET component in the SIMATIC iMap project  
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The association between PROFINET components and their instances is represented in the 
project view (see diagram below).  

 
Figure 4-7 PROFINET components and their instances in the project view 

Representation of technological functions 
The representation of instances of the technological functions differs based on the window in 
which they have been inserted. The instance of a technological function is only visible in the 
chart view, plant view and plant tree of the project tree if it is assigned to a specific chart in 
the chart hierarchy, for example, the plant chart.  
Functions inserted in the network view or network tree of the project tree can not be 
assigned to a chart. Function instances not assigned to any charts are identified by the "Not 
in use" attribute, and are only visible in the project view. Unused functions can be integrated 
in the plant hierarchy at a later time by means of drag-and-drop.  

Tip 
Always insert instances of the PROFINET components in the chart view, the plant view or in 
the plant tree of the project tree. That way you immediately arrange them in the plan 
hierarchy and they are then visible in all windows. 

See also 
Interconnecting Technological Functions  (Page 123) 
Connecting devices in the network view (Page 115) 
Importing PROFINET components (Page 106) 
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4.4.1.2 Creating nested charts 

subordinate charts 
Nested charts are used to create a hierarchical structure for your plant, just like a directory 
tree in the file system.  
Nested charts are displayed differently in the individual windows of SIMATIC iMap: 
● In the chart view and in the plant tree of the project tree, a chart is shown as a folder that 

can include the functions and other nested charts. The contents can be shown or hidden 
with the help of the symbols (+, -, arrow). 

● In the plant view, a nested chart is represented as technological function with a chart 
interface for creating interconnections. The chart interface contains the inputs and 
outputs of the technological functions contained in the nested chart, which can be 
interconnected extend beyond the chart limits.  

To create a nested chart 
1. Open the chart view or the plant view of the project. 
2. if the chart view is active, select a chart such as the plant chart. 
3. Select the Insert > New chart menu command. 

The new chart is inserted and displayed in the chart view, in the plant view as well as in 
the plant tree of the project tree. 

4. Name the nested chart 
– using the editable name field in the plant view, or 
– using the "Properties" dialog 

5. Open the parent chart by double-clicking it (in the plant view), or by selecting the Open 
chart command from the shortcut menu. 

6. Insert the instances of the desired PROFINET components from the library and 
interconnect them. 

When you return to the parent chart, the plant view represents the nested chart as a 
technological function with the defined chart interface.  

To move technological functions to a new chart: 
To create a new nested chart based on several technological functions: 
1. Select the technological functions. 
2. You have several options: Select: 

– Edit > Move to new chart, or 
– the "Insert in new chart" toolbar icon, or 
– the Move to new chart command from the shortcut menu. 

Result: A new nested chart is created, and the selected technological functions are moved to 
this chart. Any existing interconnections between charts are automatically inserted into the 
chart interface. 
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Working with nested charts 
You can work with nested charts just as though they were technological functions, i.e. they 
can be interconnected, moved, deleted, cut and copied. Make allowances for their special 
features when using multifunction components (see "Using multifunction components in a 
SIMATIC iMap project") 
The content and connections of a nested chart can be modified as required. 
It is not possible to download a selected nested chart to all devices. To carry out a specific 
download, you must select individual objects. If you download to all devices in the plant, 
those devices whose functions are contained in the nested chart are included in the 
download. 

To assign connections to the chart interface: 
In order to interconnect functions beyond the chart limits, you must assign the desired 
connections to the chart interface.  
Proceed as follows for each connection that should be included in the chart interface:  
Select the connection, and activate the option In chart interface from the shortcut menu. If 
the connection is already contained in the chart interface, this is indicated by a tick in the 
shortcut menu.  

Result 
The connection is displayed in the chart interface and can be interconnected with functions 
outside of the chart. 

Tip: Navigation aid 
Select a connection of a nested chart, then select Go to > Plant view: Function connection, 
in order to reach the associated connection of the technological function. 

4.4.1.3 Structuring functions in the plan hierarchy 

Assigning functions to the chart hierarchy  
The chart hierarchy of the SIMATIC iMap project consists of charts and functions of the 
instances, and is visualized in the chart view and plant view of the project tree.  
The instance of a technological function is only visible in the chart view, plant view and plant 
tree of the project tree if it is assigned to a specific chart in the chart hierarchy, for example, 
the plant chart. Function instances not assigned to any charts are identified by the "Not in 
use" attribute, and are only visible in the project view. 
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How to assign unused functions to a chart 
1. Open the project view. This view shows the function of instances which are not assigned 

to any chart (not in use.) 
2. Select the required functions, then drag-and-drop these to a chart in the chart view, plant 

view or plant tree. 
Result: The functions are marked with the "in use" attribute and are only visible in the chart 
view, plant view or plant tree. 

How to remove a function from the chart hierarchy 
Select the required function from the chart view, plant view or plant tree, then select Remove 
from chart hierarchy from the shortcut menu.  
Result: The function is only visible in the project view, and is assigned the "not in use" 
attribute. 

4.4.2 Coupling devices and assigning addresses 

4.4.2.1 Connecting devices in the network view 

Arrangement of the devices in the network view 
The devices in the network view are always arranged according to the following rules: 
● PROFINET devices with Ethernet connection are automatically connected to the vertical 

Ethernet bus. 
● PROFIBUS devices are connected to the PROFIBUS of the DP master by means of drag-

and-drop. 

Changing the networking 
You can make the following changes to the networking:  
● Coupling a free-standing PROFIBUS device to a PROFINET device with proxy 

functionality. 
● Moving and copying the PROFIBUS devices to the same or another PROFIBUS. In this 

case, remember that the PROFIBUS addresses on a PROFIBUS must not be assigned 
more than once. 

● Moving and copying PROFINET devices as required on the vertical or horizontal Ethernet 
bus. PROFINET devices with proxy functionality can only be coupled to the vertical 
Ethernet bus. PROFINET devices without proxy functionality may be coupled and moved 
both on the vertical Ethernet and on the horizontal Ethernet nodes. 
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To insert an Ethernet node: 
Select Insert > New Ethernet branch to create a new horizontal Ethernet branch in the 
network view. Several PROFINET devices without proxy functionality may be coupled to it 
(see diagram below). 

 
Figure 4-8 Ethernet node in the network view 

Explicit positioning of devices  
You can drag-and-drop devices to specific positions on the network view. The possible 
insertion positions are indicated in color. 

Positioning devices automatically  
Devices you insert in the chart view, instead of placing these by drag-and-drop to specific 
positions on the network view/tree, are placed automatically: 
● PROFINET devices are automatically connected to the vertical Ethernet bus. 
● New PROFIBUS devices (DP slaves) will not be connected (in the top section of the 

network view, as shown in the diagram below), and must be placed at a later time. 

 
Figure 4-9 Non-connected PROFIBUS devices 
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Tip: Check consistency of the runtime versions 
Select Edit > Check consistency > Runtime versions to check whether the PROFINET 
devices with proxy functionality and the corresponding PROFIBUS devices are compatible 
with the PROFINET runtime versions.  

See also 
Check consistency of the runtime versions (Page 117) 
Performance parameters of PROFINET devices (Page 143) 
Assigning addresses  (Page 120) 
Utilization test (Page 141) 

4.4.2.2 Check consistency of the runtime versions 

PROFINET runtime version 
The PROFINET runtime version identifies the version of PROFINET functionality in the 
firmware of the PROFINET device.  
The PROFINET runtime version of a PROFINET device with proxy functionality is of 
particular significance to the connected PROFIBUS devices. The proxy device must support 
specific functions such as connections of the data type STRUCT or multifunction 
components to allow the use of this functionality by the connected PROFIBUS devices.  

Items checked 
The system checks whether the PROFINET devices with proxy functionality and the 
connected PROFIBUS devices are compatible with the PROFINET runtime versions.  

How to check consistency of the runtime versions 
Select Edit > Check Consistency > Runtime versions.  
Result: The system checks consistency of the runtime version and outputs the results in the 
"General" tab of the task window. 



Systems engineering  
4.4 Working with instances of PROFINET components 

 Configuring Plants in SIMATIC iMap 
118 Configuration Manual, 01/2008, A5E00716614-02 

4.4.2.3 Addresses of PROFINET devices 

Address types 
PROFINET devices may have the following addresses, depending on the bus connections 
used: 

 
Bus connection Address 
Ethernet IP address of PROFINET devices 
PROFIBUS One or several PROFIBUS addresses for PROFINET 

devices with proxy functionality 
Internal PROFINET IO system IP addresses for PN IO controllers and PN IO devices 

SIMATIC iMap does not visualize internal PROFINET IO systems. You can configure the 
names and IP addresses of the PN IO controller and PN IO devices at the instance 
properties. 

IP address and subnet mask 
The IP address and the subnet mask each consist of four decimal numbers with a range of 
values from 0 to 255. The decimal numbers are each separated by a dot.  

Example: 
 

IP address  192.168.0.20 
Subnet mask 255.255.255.0 

The IP address consists of  
● The address of the (sub)net 
● The address of the node (generally called the host or network node) 
The subnet mask separates these two addresses. It determines which part of the IP address 
the network addresses and which part of the IP address is addressed by the node.  
In binary format, the 4 decimal numbers of the subnet mask must contain a continuous 
sequence of 1s from the left and a continuous sequence of 0s from the right. The bits set for 
the subnet mask determine the network part of the IP address.  
As a rule:  
● The network address is obtained by an AND combination of IP address and subnet mask. 
● The node address is obtained by an AND-NOT combination of IP address and subnet 

mask. 
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Relationship between the IP address and the default subnet mask  
There is a convention concerning the assignment of IP address areas and the "default 
subnet masks". The first decimal number (from the left) of the IP address determines the 
structure of the default subnet mask with regard to the number of "1" values (binary) as 
follows:  

 
IP address  IP address (bin.)  Address 

class  
Default subnet 
mask  

1.0.0.0 to 126.255.255.255 0xxxxxxx.xxxxxxxx....  A  255.0.0.0  
128.0.0.0 to 191.255. 255.255 10xxxxxx.xxxxxxxx...  B  255.255.0.0  
192.0.0.0 to 223.255.255.255 110xxxxx.xxxxxxxx...  C  255.255.255.0  

 
 

 Note 
Only class A, B or C IP addresses are permitted. 

 

Example: IP address and subnet mask 
 

Addresses Example 
IP address 141.30.0.5 
Subnet mask 255.255.0.0 
Subnet 141.30 
Host 0.5 

Decimal and binary representation of the subnet mask in the above example:  
255.255.0.0 = 11111111.11111111.00000000.00000000 
Significance: The first 2 bytes of the IP address determine the subnet - i.e. 141.30. The last 
two bytes address the node, i.e. 5.  

Network node 
You will need a network node (router) if you want the device to be able to communicate with 
other devices outside its own subnet. In this case, you will have to enter the router address 
for each node on the subnet. The structure of your plant will determine whether you use a 
network node or not. The address is specified by the network administrator or plant operator.  
The IP address of a node on the subnet and the address of the network node (router) must 
only differ at the points at which the subnet mask is set to "0". 

PROFIBUS address 
The PROFIBUS address is entered as a decimal number with the value range from 1 to 125. 
The current value range depends on the respective module. 
PROFINET devices with several PROFIBUS connections are assigned a PROFIBUS 
address on each DP master system. 
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4.4.2.4 Assigning addresses 

Addresses of PROFINET and PROFIBUS devices  
The devices are assigned their IP and/or PROFIBUS addresses in the “Properties“ dialog 
boxes, or directly at the objects in the network view. IP addresses and subnet masks must 
be assigned in order to be able to establish online connections with devices of the plant.  

 

 Note 
The IP address and subnet mask assigned in SIMATIC iMap to a PROFINET device must 
match the setting at the device of the plant, for the device could otherwise not be accessed 
online in SIMATIC iMap. 
When use a network node: The IP address of the device and the IP address of the network 
node must belong to the same subnet. 

 

Requirement 
The IP addresses and associated subnet masks have to be assigned to the devices of the 
plant using manufacturer-specific configuration tools. They are generally defined by the 
network administrator.  

Assigning addresses using the properties dialog box 
1. Select the desired device or the associated function in one of the windows. 
2. Open the object properties 

– using the Properties shortcut menu or 
– using the Edit > Properties menu command. 

3. Enter the addresses required for the device type on the Addresses" tab. 
– IP address and subnet mask: 

Enter the IP address and subnet mask to be assigned to the device at the node (e.g. 
via the manufacturer-specific configuration and programming tool). 

– PROFIBUS address: 
Enter the PROFIBUS address to be assigned to the device, e.g. using the DIP 
switches. The default is the PROFIBUS address defined when the PROFINET 
component was created. If this is already in use, then the lowest free address on the 
PROFIBUS becomes the default. 
At PROFINET devices with proxy functionality and several PROFIBUS connections, 
you can enter one PROFIBUS address for each DP master system. 

4. When using a network node set the "Network node, use router" option and enter the IP 
address of the router in the “Address“ input box. 

5. Confirm your input by clicking on the 
– "OK" button to accept the input and close the dialog box 
– "Accept" button to accept the input and leave the dialog box open. 

Result: The assigned addresses are displayed on the device in the network view. 
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How to edit the addresses directly at the object in the network view 
● To edit the IP address of a PROFINET device, select the relevant device, and then click 

the IP address. This opens the display field for editing, and you can enter the required 
address. 

● To edit the PROFIBUS address of a PROFINET device, select the relevant device, and 
then click the address. This opens a list where you can select the new PROFIBUS 
address. 

See also 
Addresses of PROFINET devices (Page 118) 

4.4.2.5 Configuring PROFINET IO properties 

What are internal PROFINET IO systems? 
Internal PROFINET IO systems may be integrated in PROFINET components, for example, 
if the PROFINET device is also a PROFINET IO controller.  
SIMATIC iMap does not visualize internal PROFINET IO systems and the corresponding IO 
devices. However, you can edit these objects in the instance properties dialog, and then use 
SIMATIC iMap to download your configuration data to the devices. 

Fundamental procedure when configuring an internal PROFINET IO system 
1. Assigning PROFINET IO system names in SIMATIC iMap. 
2. Assigning IP addresses of the PROFINET IO devices in SIMATIC iMap. 
3. Assigning device names to the target devices of the PROFINET IO system. 
4. Generating projects in SIMATIC iMap (see chapter "Generating the project"). 
5. Downloading configuration data from SIMATIC iMap into the target device. 

Device name within the internal PROFINET IO system 
The names of the devices in the internal PROFINET IO system comprise the following: 
<device name>.< PROFINET IO system name> 
The device name is defined using the manufacturer-specific configuration tool (STEP 7, for 
example), and can not be edited in SIMATIC iMap. You can automatically or manually assign 
the PROFINET IO system names in SIMATIC iMap.  
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Assigning PROFINET IO system names in SIMATIC iMap. 
1. Select the device of instance function of which you want to edit the internal PROFINET IO 

system, then select Properties... from the pop-up menu. 
2. Open the "Internal IE devices" tab. 
3. In order to be able to automatically assign the PROFINET IO system names, activate the 

option "Assign name automatically". 
Result: The system name is generated based on the IP address of the PROFINET IO 
controller, and appended to the device name. This gives the PROFINET IO devices clear 
names throughout the system. 

4. To enter the system name manually, reset the "Assign name automatically" option, and 
then type in the required name in the "PROFINET IO system name" input box. 
Result: The system name is appended to the device name.  

 

  Note 
You must ensure that the devices in the internal PROFINET IO system receive clear 
names throughout the system. 

Assigning IP addresses of the PROFINET IO devices in SIMATIC iMap. 
The PROFINET IO controller is automatically assigned the IP address of the instance. 
Assign the IP addresses to PROFINET IO devices manually or automatically. 
1. Select the device of instance function of which you want to edit the internal PROFINET IO 

system, then select Properties... from the shortcut menu. 
2. Open the "Internal IE devices" tab. 
3. To assign the IP addresses automatically to all PROFINET IO devices, click "Assign new 

addresses automatically." 
Result: The PROFINET IO devices are assigned IP addresses that are derived from the 
IP address of the PROFINET IO controller. The last digit will be incremented by the count 
of 1. You can edit those IP addresses at any time. 

4. To manually assign an IP address to a PROFINET IO device, enter the relevant address 
directly in the corresponding "IP address" input box. 

Assigning device names to the target devices of the PROFINET IO system. 
You can assign clear names to the PROFINET IO devices directly from SIMATIC iMap:  
1. Ensure that the generate status of the instance in SIMATIC iMap is "generated". If 

necessary, generate the project. 
2. In the network view or project view, select the device of the instance and choose Special 

> Assign device names from the pop-up menu. 
3. The shadow project is opened in the manufacturer-specific configuration tool, e.g. STEP 

7. 
4. Assign the PROFINET IO devices the device names that have been configured in 

SIMATIC iMap. 
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Downloading configuration data from SIMATIC iMap into the target device 
When the program is downloaded, the configuration data of the PROFINET IO system (the 
IP addresses of the PROFINET IO devices) is downloaded from SIMATIC iMap into the 
PROFINET IO controller and then automatically assigned to the PROFINET IO devices 
(refer to chapter "Downloading programs"). 

4.4.3 Interconnecting functions 

4.4.3.1 Interconnecting Technological Functions 

Interconnection - Definition 
An interconnection is represented by a line which connects the input of a technological 
function with the output of another technological function.  

Interconnection rules 
● An interconnection can only be set up between an output and an input. An output can be 

interconnected with several inputs, whereas an input can only be interconnected with one 
output. 

● The two connections of an interconnection must be of the same data type, for example, 
both of the type I2 or R4. 
Connections with composite data types must be of the same type, i.e. arrays and 
structures must be of the same syntax.  

Requirement 
The technological functions to be interconnected are inserted in the project. 
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How to interconnect the instances of technological functions:  
1. Open the plant view. 
2. Click a connection. The connection changes color, and the shape of the cursor also 

changes. 
3. There are two options: 

– Hold down the mouse button and drag the connection to the destination connection, or 
– click the mating connection of the interconnection. 

With this procedure, those connections that are suitable for the data type of the technological 
functions are always highlighted in color.  

 
Figure 4-10 Interconnecting technological functions 

The interconnection appears between the two connections as a line or in the form of 
continuation connections (see below "Displaying the interconnection lines"). 

Tip: Multiple interconnections 
Used to connect several inputs to one output:  
● Hold down the CTRL key and select the required inputs. 
● Release the CTRL key and select the output to be interconnected. 
Result: All the selected inputs are interconnected to this output. 

See also 
Moving interconnections (Page 134) 
Interconnection with constant values (Page 129) 
Setting the transfer properties of interconnections (Page 137) 
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4.4.3.2 Working with interconnections 

General rules for handling interconnections 
The deletion of the instance of a technological function includes all its associated 
interconnections.  
Moving a technological function also alters the path of the associated interconnections. 
If the the line path can not be calculated, for example due to lack of space, only the two ends 
of the interconnection, known as continuation connectors, are visualized. Continuation 
connectors with identical numbers represent an interconnection.  
The line color of a selected interconnection changes. You can delete a selected 
interconnection, or view and edit its properties. 

Visualization of interconnection lines 
Select the View > Plant view > Display Interconnection Lines command to show or hide the 
interconnection lines.  
In order to improve efficiency when working in the plant view, you can disable the 
interconnection lines temporarily by clearing the check mark at the menu command. The 
result is, only the end points of the interconnections are visualized as continuation 
connectors. This visualization mode reduces load on computer resources required for the 
dynamic calculation of lines, and thus allows you to quickly move and interconnect 
technological functions. 

 
Figure 4-11 Visualization of interconnection lines 
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Figure 4-12 Visualization of continuation connectors 

Recalculation of interconnection lines 
Select the View > Plant view > Recalculate interconnection lines , or press the F5 function 
key to recalculate the interconnection lines and to optimize their visualization.  

Highlighting interconnections 
● Select the interconnections you want to highlight in the plant view, then select Highlight 

interconnections from the shortcut menu. 
● To highlight interconnections with specific transfer properties in the plant view, select the 

functions and charts, then select Edit > Plant view > Highlight interconnections >, and 
finally select the required property. Options: 

 
Property Description 
 > Selected Highlights all selected interconnections 
> Cyclic > All transfer rates /fast /medium 
/slow 

Highlights all cyclic interconnections with the 
corresponding transfer rates of selected functions and 
charts 

> Acyclic > All scan rates /fast /medium 
/slow 

Highlights all cyclic interconnections with the 
corresponding scan rate of selected functions and 
charts 

Result: In both versions, the selected interconnections are indicated in the plant view by a 
thicker line, or continuation connectors and bold numbers.  
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Selecting interconnections 
To select interconnections with specific properties in the plant view, select the functions and 
charts, then select Edit > Plant view > Select interconnections >, and finally select the 
required property. Options: 

 
Property Description 
 > All Includes all interconnections of selected functions and 

charts 
> Cyclic > All transfer rates /fast /medium 
/slow 

Includes all cyclic interconnections with the 
corresponding transfer rates of selected functions and 
charts 

> Acyclic > All scan rates /fast /medium 
/slow 

Includes all acyclic interconnections with the 
corresponding scan rate of selected functions and 
charts 

> Highlighted  Includes all highlighted interconnections of selected 
functions and charts 

Result: The required interconnections are highlighted (transformation of the line colors or 
continuation connectors), and thus prepared for further editing, for example, deleting or 
moving.  

4.4.3.3 Hiding and showing connectors 

Visible and hidden connections 
Connections which are not interconnected, and connections interconnected with constant 
values, can be visualized (made visible) or hidden (concealed) in the plant view. By hiding 
the connections you do not require you can simplify the representation of functions in the 
plant view and interconnecting.  
Options of of hiding connections: 
● Identify selected connections for hiding. Options: 

– Identification by function 
– Identification in the "Properties" dialog of the instance or of the individual connection 

The marked connections are represented in the plant view in white font. You can hide 
the connections at a later time. 

● Hiding and showing the identified connections of a function. Options: 
– Hiding and showing the function 
– Set the hide and show option in the "Properties" dialog box of the instance 
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How to identify the connections for hiding directly at the function: 
1. Open the plant view 
2. Select the relevant connections of a function, then select the Hide option option from the 

shortcut menu 
Result: The selected connections are shown in white font, and can be hidden at any time. 

Tip 
The Edit > Plant view > Select connections > menu command can be used to select the 
desired connections (see below) 

How to identify the connections for hiding in the "Properties" dialog box of the instance 
1. Select the function or the device of the instance, and then select Properties... from the 

context menu. 
2. Activate the "Can be hidden" option and confirm by clicking the "OK" or "Accept" button. 

Result: When the dialog box is closed the connection is shown in white font and can be 
hidden at any time. 

How to hide and show connections directly at the function: 
1. Open the plant view. 
2. Select a function where the connections are identified for hiding. 
3. Select the shortcut menu Hide connections 
Result: The connections identified for hiding are hidden. 

How to hide and show connections in the "Properties" dialog: 
1. Select the function or the device of the instance, and then select Properties... from the 

context menu. 
2. On the "Properties" dialog box, select the "Connections" tab. 
3. Select any connections required from the IO list, or reset the identifier ("Set hide option 

for selected connections" check box.) 
4. Set the "Hide connections with hide option in the plant view" check box. 
5. Click "OK" or "Apply" 

Result: The marked connections will be hidden when you close the dialog box. 
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Selecting connections 
To select connections with specific properties in the plant view, select the functions and 
charts, then select Edit > Plant view > Select connections >, and finally select the required 
property. The following possibilities are available to you: 

 
Property Description 
 > All Includes all interconnections of the selected functions 

and charts in the selection 
>Not interconnected Includes all connections that are not connected of the 

selected functions and charts in the selection 
> Interconnected Includes all the interconnected connections of the 

selected functions and charts in the selection 

Result: The required connections are highlighted (the connection colors change) and thus 
prepared for further editing, for example, hiding.  

4.4.3.4 Interconnection with constant values 

Constant values at technological inputs 
Some technological functions require a constant value to be applied at an input, in order to 
test the function, for example. This value can be set using SIMATIC iMap. 

Rules 
In SIMATIC iMap, only inputs can be interconnected with constant values. This is not 
possible with outputs. 

Requirement 
The input may not be interconnected otherwise. If this is the case, the existing 
interconnection must first be deleted. 

To interconnect an input with a constant value 
1. Select the input so that the mouse pointer with the interconnection icon appears. 
2. Select Interconnect Constants from the shortcut menu. 
3. Enter the desired value in the "Interconnection with Constant Value" dialog box and click 

on the "OK" or "Accept" button. 
The input is identified by a constant icon, and the value of the constant is displayed at the 
input. 
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Example 
The selected input is interconnected with the value 30. 

 
Figure 4-13 Interconnection with a constant value 

How to modify the interconnection with a constant value 
1. Select the constant icon of the input. 
2. Open the interconnection properties. 
3. Enter the required value in the Constant Value" input box of the "Interconnection with 

Constant Value" dialog box. 
4. Click on the "OK" or "Apply" button. 
The changed value is displayed at the input. 

Constant values for composite data types 
With composite data types such as arrays or structures you can enter constant values for 
each individual element.  
With arrays, you can also enter the same constant value for all the elements in the array. To 
do this, enter the required value in the "Constant value" input box and click on the "for all 
array elements" button. 
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Example: Constant values for a connection of the type STRUCT 
The following diagram shows how to enter a constant value for a structure element of the 
type UI1 (byte): 

 
Figure 4-14 Interconnecting with constant values for a connection of the data type STRUCT 

How to delete an interconnection with a constant value: 
1. Select the constant icon of the input. 
2. Select the Delete Interconnection command from the shortcut menu. 
The constant icon disappears. The input can be interconnected again. 
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4.4.3.5 Configuring substitute values 

Substitute values 
If a fault occurs on a device such that the values that are sent via its interconnections are no 
longer valid, then the recipient switches to substitute values.  

 
Figure 4-15 Example - Substitute values 

In SIMATIC iMap, there is a default substitute value for every interconnection. This may be 
the last known value or a user-defined value.  

 

 Note 
Substitute values can only be configured for interconnections between PROFINET devices. 
If a PROFIBUS device is involved, then only substitute value 0 may be used.  
 Exception: The "1.1.2000" is always used as the substitute value for connections of the type 
DATE. 

 

How to change the default substitute value of an interconnection  
1. Select the interconnection from the plant view. 
2. Select Properties from the pop-up menu. 
3. In the "Properties" dialog box, activate the required option in the "Substitute value" box. If 

you wish to activate a specified value as the substitute value, then enter the required 
value. 

4. Click on the "OK" or "Accept" button to confirm the changes. 
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5. Select the function with the affected input (on the recipient side) and select Download 
Selected Device > Interconnections only from the context menu to download the newly 
configured interconnection to the associated device. 

 
Figure 4-16 Example - Changing substitute values 

Result: The change takes effect immediately. If there is already a fault on the device, you 
can monitor the modified substitute value online. 

Substitute values for composite data types 
With composite data types such as arrays or structures you can enter a user-defined 
substitute value for each individual element.  
With arrays, you can also enter the same user-defined substitute value for all the elements in 
the array. To do this, enter the required value in the "User-defined value" box and click on 
the "for all array elements" button. 



Systems engineering  
4.4 Working with instances of PROFINET components 

 Configuring Plants in SIMATIC iMap 
134 Configuration Manual, 01/2008, A5E00716614-02 

4.4.3.6 Moving interconnections 
In SIMATIC iMap, the end point of an interconnection can be moved onto a connection of 
another technological function.  

Rules for moving interconnections 
The target connection to which the end point of an interconnection is to be moved must fulfill 
a number of conditions. These conditions depend on the number of end points to be moved. 
● Some or all of the end points of the interconnections of a technological function can only 

be moved onto connections of the same type (input or output), same name and same 
data type of another technological function. 

● There are two ways to move the interconnection at an individual end point: 
– to a connection of the same type (input or output), data type, and technological 

function (the latter does not require identical connection names), or 
– to a different technological function. In this case, the technological function at the 

destination must contain a connection of the same type (input or output), name and 
data type. 

● If the end point is an input, it can only be moved to an unconnected input. An output can 
be moved to an interconnected output. 

● Interconnections cannot be moved beyond chart limits. The source and destination must 
be located in the same chart. 

● The configured substitution values are applied to the interconnections. 
● Interconnections with configured substitution values can not be moved from a PROFINET 

device to a PROFIBUS device, if those values are unequal to default values. 

How to move several interconnections: 
1. Select: 

– the entire technological function to move all interconnections, or 
– to move only the connections of the interconnections. 

2. Select the Move Interconnections command from the shortcut menu. The technological 
functions at the destination of the selected interconnections are highlighted in color when 
the mouse pointer moves over these objects. 

3. Click the technological function at the destination of your interconnections. 
4. Confirm the prompt with "Yes" to move the interconnection. 

Result: the interconnections are moved to suitable connections in the new technological 
function. 

Interconnections without suitable destinations will not be moved, and remain at their original 
technological function. 

How to move a single interconnection 
1. Select the connection of the interconnection to move. 
2. Select the Move Interconnections command from the shortcut menu. The possible 

destinations of the interconnection, i.e. the connections or technological functions, will be 
highlighted in color when you move the mouse pointer over these objects. 

3. Click the destination connection for the interconnection. 
Result: the end point of the interconnection is moved to the destination connection. 
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4.4.3.7 Transfer properties 

Interconnections with local communication partners 
Interconnections with local communication partners are:  
● Interconnections between two PROFIBUS devices on the same PROFIBUS 
● Interconnections between a PROFIBUS device and the corresponding PROFINET device 

with proxy functionality 
● Internal device interconnections 

Interconnections with remote communication partners 
Interconnections with remote communication partners are routed across Industrial Ethernet.  

Features of PROFINET communication  
In SIMATIC iMap, the following PROFINET communication properties can be assigned to 
interconnections: 
● Transfer mode 
● Transfer rate and scan rate (Quality of Service) 

Transfer mode 
PROFINET communication on Industrial Ethernet supports the following transfer modes: 
● Cyclic transfer of time-sensitive process data 

Data are transferred cyclicly; changed values will be ignored.  
● Acyclic transfer, for example, of engineering data and of data which are not time-

sensitive. 
The data are scanned cyclicly, i.e. checked for changes. The data are only transferred if 
changed.  
The data are scanned on the transmitter side of the interconnection (output of a 
technological function.) 

The supported transfer modes represent device properties. They can be derived from the 
properties of the relevant PROFINET component. 
 

 

 Note 
Always transfer time-sensitive process data in cyclic mode. 
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Quality of Service (QoS)  
A QoS is defined for both transfer modes:  
● Transfer rate (cyclic):  

In cyclic transfer mode, the transfer rate represents the interval between two successive 
transfers of a parameter, for example, 32 ms.  

● Scan rate (acyclic):  
In acyclic transfer mode, the scan rate represents the interval between two successive 
checks for changes in data on provider side, for example, 200 ms. The scan interval is 
usually equivalent to the maximum time expiring prior to the transfer of deltas. 
This time may be exceeded as a result of overload or communication errors. If errors 
persist, a substitution value is applied on receiver (consumer) side after 20 x <scan 
interval>. 

Scan rate and transfer rate values 
Three rate levels are defined for both transfer modes:  
● fast - high rate 
● medium - medium rate 
● slow – low rate 
A transfer value can be set centrally for each rate level: 
● Between 1 ms and 512 ms (cyclic) 
● Between 1 ms and 1000 ms (acyclic) 

Project settings 
Properties of the SIMATIC iMap project (Project > properties, "Interconnections" tab) users 
can set: 
● Default transfer properties for new interconnections. – Apply to all new interconnections 
● Time values for the rate levels. – Apply to all instances of the SIMATIC iMap project. 
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Example 
The diagram below shows the transfer properties settings of the project as an example: 

 
Figure 4-17 Transfer properties of the project 

All subsequently created interconnections will have these preassigned properties assigned 
to them. 

4.4.3.8 Setting the transfer properties of interconnections 

Central settings and individual adaptations 
Every interconnection has a transfer mode and a transfer value assigned to it in SIMATIC 
iMap. The following is defined centrally in the project settings: 
● The default setting for new interconnections. 
● The precise transfer values for the frequency levels "fast", "medium" and "slow" in 

milliseconds for all interconnections. 
You can change the transfer mode and the frequency level "fast", "medium" or "slow" in the 
properties of the individual interconnections. 



Systems engineering  
4.4 Working with instances of PROFINET components 

 Configuring Plants in SIMATIC iMap 
138 Configuration Manual, 01/2008, A5E00716614-02 

 

 Note 
The transfer properties (transfer mode, transfer frequency and scanning frequency) are only 
of relevance for interconnections to remote communication partners via Industrial Ethernet. 
During a download, interconnections are checked, however, regardless of whether they are 
remote interconnections or not. The transfer properties must therefore still be specified at the 
configuration stage for internal device interconnections and interconnections within a proxy 
system.  

 
 Note 

Interconnections with cyclical transfer only work between communication partners that are 
on the same subnet.  

 

How to define the transfer properties for the interconnections of the entire project 
1. Select the Project > Properties menu command. 
2. Open the "Interconnections" tab. 
3. In the "Default setting for the new interconnections" box, select: 

– the transfer mode "acyclical" or "cyclical" and 
– the frequency level "fast", "medium" or "slow". 

These settings will apply to all subsequently created interconnections. 
4. In the "Transfer frequency (cyclical)" box, select the transfer values for the three 

frequency levels. There are two options: 
– Select the required value from the drop-down list or 
– drag the pointer onto the required value. 

5. In the "Scanning frequency (acyclical)" box, select the transfer values for the three 
frequency levels (as in step 4). 

6. Click on the "OK" or "Accept" button to confirm your input. 
The settings in step 4 and 5 apply to all the interconnections in the project with the 
corresponding transfer mode and frequency level. These values are retained in SIMATIC 
iMap until they are changed again.  
You can change the transfer properties of individual interconnections via the interconnection 
properties. 
Tip: The transfer properties of a highlighted interconnection are also displayed as a tooltip. 
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To change the transfer properties of an interconnection 
1. Select the interconnection in the plant view and select the Edit > Properties menu 

command. 
2. In the "Properties" dialog box select: 

– the transfer mode "acyclical" or "cyclical" and/or 
– the frequency level "fast", "medium" or "slow". The precise transfer value in 

milliseconds for this transfer mode and frequency level can be taken from the project 
settings. 

3. Click "OK" or "Accept" to confirm. 

Example: Transfer properties for the entire project 

 
Figure 4-18 Transfer properties for the entire project 
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Example: Transfer properties of an interconnection 

 
Figure 4-19 Transfer properties of an interconnection 

See also 
Interconnecting Technological Functions  (Page 123) 
Transfer properties (Page 135) 
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4.4.4 Checking the utilization of the devices 

4.4.4.1 Utilization test 

Application 
PROFINET devices with runtime version V2.0.0.0 or higher dispose of performance 
parameters (Page 143) that describe the PROFINET communication properties of the 
devices.  
The performance parameters allow users to the test working load on devices in the 
configuration phase in SIMATIC iMap. The results show at an early stage whether the 
devices are capable of meeting requirements of your SIMATIC iMap project without causing 
any runtime errors in the plant as a result of overload.  
In the configuration phase, you can debug the system before you generate the project if this 
check returns values which are incompatible with performance parameters. 

Items checked  
Items checked in the configuration phase: 
● Violation of any performance parameters at the devices, for example, the maximum 

number or transfer values of interconnections. 
● Support of configured transfer properties of the interconnection (cyclic transfer, for 

example) at the device. 
● Only for PROFIBUS devices: Compatibility of the PROFIBUS device and of the 

corresponding PROFINET device with proxy functionality, with the PROFINET runtime 
version. 

The performance parameters are available in the "Device" tab of the PROFINET component 
properties. Select the PROFINET component from the library window then select Properties 
from the context menu.  

Rules 
You can only test PROFINET devices. 
At PROFINET devices with proxy functionality, the utilization check relates to the entire 
proxy system, which consists of the actual device and any connected PROFIBUS devices. 



Systems engineering  
4.4 Working with instances of PROFINET components 

 Configuring Plants in SIMATIC iMap 
142 Configuration Manual, 01/2008, A5E00716614-02 

How to test the working load on PROFINET devices 
1. Select the PROFINET devices to test from the network view. 
2. Select the Test utilization command from the context menu. 

Result: The test is carried out, and the results are output to the output window, "Utilization 
(Page 145)" tab. 

3. If the test returns overload: Debug the configuration data of the devices and the 
interconnections, or modify the networking of the devices. 

 

  Note 
In the utilization check of the devices, the outgoing interconnections with external projects 
are not taken into consideration. Only the incoming interconnections of external projects 
in the destination project are included. 

Tip: Detailed information 
To view detailed results, select the "Utilization" tab of the task window and then click the "+" 
symbols.  
Result: All the performance parameters are listed including current and limit 
(Page 143) values (actual/typical/max. or actual/typical/min.) 

Tip: Locating the objects 
If the utilization test discloses any violation of limit values, the relevant object will be 
identified by a warning icon in the "Reference object" column. Double-click the reference 
object to select the relevant object to check and correct its properties right away 

Tip: Test the online utilization 
The Online > Online device analysis command returns the online data of a specific 
PROFINET device, including a comparison between online configuration data and 
performance parameters (see "Online device analysis (Page 199)".) 

See also 
Parameters of limit values (Page 143) 
Online device analysis (Page 199) 
Connecting devices in the network view (Page 115) 
Transfer properties (Page 135) 
Setting the transfer properties of interconnections (Page 137) 
Performance parameters of PROFINET devices (Page 143) 
Utilization parameters of the PROFINET devices (Page 145) 
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4.4.4.2 Parameters of limit values 

Typical and absolute limits 
There two different types of limits at the parameters of the PROFINET devices. 
● Typical limits 

On the basis of these values it is possible to determine whether excessive demands 
would be placed on a device. If the configuration remains below or, respectively, above 
the typical limit at each individual parameter, it is ensured that the plant will definitely run 
stable and free of errors. However the reverse is not true: If one or even several typical 
limits are exceeded, the plant may still functions stably and error-free. But this cannot be 
guarantee in every case. 

● Absolute limits  
The maximum or minimum limits may not be exceeded or underpassed respectively 
under any circumstances. If only one parameter lies above the maximum limit, the device 
cannot fulfill the configured requirements. In this case, the configuration cannot be 
downloaded to the target device 

 

  Note 
The differentiation between typical and maximum limits is only supported for devices of 
PROFINET Runtime Version V2.3 and higher.  

Displaying the limit values 
The typical and maximum limits are displayed as follows: 
● Both the typical and the absolute limits are displayed if available in the properties of the 

PROFINET component (performance parameters (Page 143)). 
● In the utilization check (Page 141) of the current configuration (utilization parameters 

(Page 145)) the actual values, the typical and the maximum limits are displayed in as far 
as available. 

● The maximum/minimum limits and the online actual values of a device are displayed at 
the online device analysis (Page 199). 

 

4.4.4.3 Performance parameters of PROFINET devices 

Performance parameters of PROFINET devices  
PROFINET devices with PROFINET runtime version 2.0 or higher are assigned specific 
performance parameters which are vital to PROFINET communication. From PROFINET 
Runtime Version 2.3 and higher both the typical and the maximum limits (Page 143) are 
displayed, if available. 
These performance parameters are available in the "Performance parameters" tab under the 
PROFINET component properties. Select the PROFINET component from the library 
window, then select Properties from the context menu.  
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PROFINET performance parameters 
 

Parameter Description 
General limits*) 
Number of remote 
interconnection partners 

Maximum number of communication partners (devices) via 
industrial Ethernet. 

Number of functions (proxy) Maximum number of technological functions. For PROFINET 
devices with proxy functionality, this incorporates the functions of 
the coupled PROFIBUS devices. 

Total of all connections (proxy) Maximum number of connections for the technological functions. 
For PROFINET devices with proxy functionality, this incorporates 
the functions of the coupled PROFIBUS devices. 

Number of PROFIBUS devices 
(proxy) 

Maximum number of PROFIBUS devices connected to the 
PROFINET device with proxy functionality. 

Total data length of all incoming 
connections (proxy) 

Maximum total data length of all incoming connections in bytes. 

Total data length of all outgoing 
connections (proxy) 

Maximum total data length of all outgoing connections in bytes.**)

Number of local interconnections Maximum number of interconnections: 
• between PROFIBUS devices on the same PROFIBUS 
• between the PROFIBUS device and the corresponding 

PROFINET device with proxy functionality 
• on the same device (internal) 

Total data length of all local 
connections (proxy) 

Maximum total data length of all internal and PROFIBUS 
interconnections in bytes. 

Data length per connection Maximum total data length per connection in bytes. 
Remote interconnections with acyclic transfer*) 
Scan rate - minimum scan 
interval 

Minimum time interval of the scan rate in milliseconds. 

Number of incoming 
interconnections 

Maximum number of interconnected inputs. 

Number of outgoing 
interconnections 

Maximum number of interconnected outputs.**) 

Total data length of all incoming 
interconnections 

Maximum total data length of all incoming connections in bytes. 

Total data length of all outgoing 
interconnections 

Maximum total data length of all outgoing connections in bytes.**)

Remote interconnections with cyclic transfer*) 
Transfer rate - minimum transfer 
rate  

Minimum time interval of the transfer rate in milliseconds. 

Number of incoming 
interconnections 

Maximum number of interconnected inputs. 

Number of outgoing 
interconnections 

Maximum number of interconnected outputs.**)  

Total data length of all incoming 
interconnections 

Maximum total data length of all incoming connections in bytes. 

Total data length of all outgoing 
interconnections 

Maximum total data length of all outgoing connections in bytes.**)

Data length per connection Maximum total data length per connection in bytes. 

*) Applicable to PROFINET devices with proxy functionality: including the connected 
PROFIBUS devices (see the rule below.)  
 **) Outputs with multiple interconnections with remote partners are counted accordingly. 
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Rule 
The performance parameters of PROFINET devices with proxy functionality apply to the 
entire proxy system, which consists of the actual device and the connected PROFIBUS 
devices. 

See also 
Utilization test (Page 141) 
Transfer properties (Page 135) 

4.4.4.4 Utilization parameters of the PROFINET devices 

Options of scanning utilization parameters 
In the case of the utilization check (Page 141), all the parameters with their current values 
and limits are listed in the information window. Exceeded and undershot utilization 
parameters are identified by a warning symbol in the information window. The quantitative 
deviations can be seen from the Actual/Max and Actual/Min values. 

 

 Note 
For devices from PROFINET Runtime Version V2.3 and higher a difference is made 
between typical and maximum limits (Page 143) if available.  

 

Validity of the utilization parameters 
The parameters listed below apply to: 
● a PROFINET device without proxy functionality or 
● the entire proxy system of a PROFINET device with proxy functionality. 

Descriptions of the utilization parameters 
The utilization parameters can be subdivided into the following parameter groups: 
● Device parameters (Page 146) 
● General interconnection-specific parameters (Page 147) 
● Parameters for acyclic remote interconnections (Page 149)  
● Parameters for cyclic remote interconnections (Page 153)  
The "Remedy" column contains possible remedies in the event that utilization parameter 
limits are exceeded or undershot. 
<Actual> represents a current actual value, while <Min> and <Max> are limit values. 
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 Note 
In the utilization check of the devices, the outgoing interconnections with external projects 
are not taken into consideration. Only the incoming interconnections of external projects in 
the destination project are included. 

 
 Note 

With the utilization check of the devices the interconnections with uncoupled PROFIBUS 
devices are taken into consideration as remote interconnections. 

 

See also 
Error messages for interconnections with cyclic transfer (Page 155) 
Setting the transfer properties of interconnections (Page 137) 
Transfer properties (Page 135) 

4.4.4.5 Device parameters 

Utilization parameters: Device parameters 
These utilization parameters apply to the entire proxy system of the PROFINET device with 
proxy functionality. 

 
Parameter Meaning  Remedy 
Number of coupled 
PROFIBUS devices 

Number of PROFIBUS devices that are coupled to the 
PROFINET device with proxy functionality.  
This includes DP slaves on the local PROFIBUS. 

Reduce the number of 
coupled PROFIBUS devices. 

The number of functions on 
DP master and DP slaves 

Number of technological functions. For PROFINET devices 
with proxy functionality, this incorporates the functions of the 
coupled PROFIBUS devices 

Reduce the number of 
functions. 

Total of all connections of 
DP master and DP slaves  

Total number of connections for the technological 
function(s). For PROFINET devices with proxy functionality, 
this incorporates the functions of the coupled PROFIBUS 
devices. 

Reduce the number of 
coupled PROFIBUS devices. 

Maximum data length for 
arrays and structures for DP 
master and DP slaves  

Total data length for arrays and structures in bytes (see 
"Connection data types"). For PROFINET devices with 
proxy functionality, this incorporates the functions of the 
coupled PROFIBUS devices. 
Possible cause:  
 The data length of at least one connection of a coupled 
PROFIBUS device is too long for this master 

Couple the PROFIBUS 
device to another PROFINET 
device with proxy 
functionality. 
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Parameter Meaning  Remedy 
Total data length of all inputs 
of DP master and DP slaves 

Total data length of all inputs of the technological function(s) 
in bytes (see "Connection data types"). For PROFINET 
devices with proxy functionality, this incorporates the 
functions of the coupled PROFIBUS devices. 

Total data length of all 
outputs of DP master and 
DP slaves 

Total data length of all outputs of the technological 
function(s) in bytes (see "Connection data types"). For 
PROFINET devices with proxy functionality, this 
incorporates the functions of the coupled PROFIBUS 
devices. 

Memory requirement for type 
descriptions of all 
connections of DP master 
and DP slaves 

This parameter comprises the memory required for the 
description of the data types of all connections. This 
memory is required in addition to the working data (sum of 
the data lengths of all inputs and outputs). 

Reduce the number of 
coupled PROFIBUS devices. 

 

See also 
Utilization parameters of the PROFINET devices (Page 145) 

4.4.4.6 General interconnection-specific parameters 

Utilization parameters: General interconnection-specific parameters 
These parameters are independent of the transfer mode. 

 
Parameter Meaning  Remedy 
Number of internal device 
and PROFIBUS 
interconnections for master 
and slaves  

Number of interconnections: 
• between PROFIBUS devices on the same 

PROFIBUS 
• between PROFIBUS devices and the 

associated PROFINET device with proxy 
functionality 

• on the same device (internal) 
Number of internal device 
and PROFIBUS 
interconnections for master 
and slaves 

Total data length in bytes for all connections with 
the following interconnections: 
• between PROFIBUS devices on the same 

PROFIBUS 
• between PROFIBUS devices and the 

associated PROFINET device with proxy 
functionality 

• on the same device (internal) 

If necessary, reduce the number of 
internal device interconnections and 
PROFIBUS interconnections. 
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Parameter Meaning  Remedy 
Number of interconnections 
with constants of master and 
slaves 

Number of interconnections with constants. For 
PROFINET devices with proxy functionality, this 
incorporates the functions of the coupled 
PROFIBUS devices. 

Total data length of all 
interconnections with 
constants of DP master and 
DP slaves  

Total data lengths of all interconnections with 
constants. For PROFINET devices with proxy 
functionality, this incorporates the functions of the 
coupled PROFIBUS devices. 

Reduce the number of 
interconnections with constants. 

Number of remote 
interconnection partners of 
DP master and DP slaves 

Number of remote communication partners (via 
Industrial Ethernet). 

Reduce the number of remote 
communication partners of the device

Utilization due to the number 
of device relationships 
between DP master and DP 
slaves as well as between 
remote interconnection 
partners 

This parameter shows the utilization (as a 
percentage) in relation to the number of directed 
communication relationships between the device 
and its communication partners, in both the local 
and the remote proxy system.  
All interconnections in a direction – e.g. from 
outputs of device A to inputs of device B – are 
regarded as directed communication relationships 
between devices A and B. All interconnections in 
the other direction – from outputs of device B to 
inputs of device A – are regarded as another 
directed communication relationship between 
devices A and B.  

Reduce the number of directed 
communication relationships of the 
device.  
It is not sufficient simply to remove 
some of the interconnections that 
form a directed communication 
relationship. All the interconnections 
in the same direction between two 
devices must be removed in order to 
remove a directed communication 
relationship between these devices. 

 

See also 
Utilization parameters of the PROFINET devices (Page 145) 
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4.4.4.7 Parameters for acyclic remote interconnections 

Utilization parameters: Parameters for acyclic remote interconnections  
Parameters for interconnections with acyclic transfer to remote communication partners. For 
PROFINET devices with proxy functionality, this incorporates the interconnections of the 
coupled PROFIBUS devices. 

 
Parameter Meaning  Remedy 
Minimum interval for 
scanning frequency  

Minimum time interval for the scanning frequency 
with frequency level "fast" in milliseconds 

Increase the minimum interval for the 
scanning frequency for frequency level 
"fast" in the project settings. 

Incoming interconnections: Interconnection at the inputs of technological function(s) 
Number  Number of incoming interconnections. For 

PROFINET devices with proxy functionality, this 
incorporates the interconnections of the coupled 
PROFIBUS devices. 

Total data length  Sum of the data lengths of all connections with 
incoming interconnections in bytes. For 
PROFINET devices with proxy functionality, this 
incorporates the interconnections of the coupled 
PROFIBUS devices. 

• Reduce the number of incoming 
interconnections with acyclic 
transfer to remote communication 
partners or 

• use interconnections with cyclic 
transfer, if necessary. 

Distribution by frequency:  This parameter is represented as follows: 
• OK - if the distribution of interconnections by 

frequency level is OK. 
• With a warning symbol - if the distribution of 

interconnections by frequency level is not 
suitable. 

The following parameters show whether the 
performance parameters are exceeded or 
undershot by the configuration of the 
interconnection for each frequency level. 

If a warning symbol appears on the 
line: 
• Determine the frequency level at 

which at least one device parameter 
limit value is exceeded or undershot 
by the associated configured value 
and 

• distribute the incoming remote 
interconnections for the affected 
frequency level to other frequency 
levels or 

• use interconnections with cyclic 
transfer, if necessary. 

Device parameter:  
 fast (<Min> ms);  
 interconnections: <Max>; 
 Total data length: <Max> 
byte 

Device performance parameters (limit values) for 
the frequency level "fast": 
• The minimum time interval for the scanning 

frequency with frequency level "fast" in 
milliseconds 

• The maximum number of incoming 
interconnections with frequency level "fast" 

• The total data length of all inputs with 
interconnections of frequency level "fast" in 
bytes. 

These lines never contain a warning; 
they are used for breakdown purposes 
only. The potential overload is 
highlighted in the "Distribution by 
rate..." line. 
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Parameter Meaning  Remedy 
Configured:  
 fast (<Actual> ms);  
 interconnections: <Actual>; 
Data length: <Actual> byte 

Current configured values for incoming 
interconnections with frequency level "fast":  
• The configured time interval for the scanning 

frequency with frequency level "fast" in 
milliseconds 

• The current number of incoming 
interconnections with frequency level "fast" 

• The current total data length of all inputs with 
interconnections of frequency level "fast" in 
bytes. 

These lines never contain a warning; 
they are used for breakdown purposes 
only. The potential overload is 
highlighted in the "Distribution by 
rate..." line. 

Device parameter:  
 medium (<Min>ms);  
 interconnections: <Max>; 
 Data length: <Max> byte 

Device performance parameters (limit values) for 
the frequency level "medium": 
• The minimum time interval for the scanning 

frequency with frequency level "medium" in 
milliseconds 

• The maximum number of incoming 
interconnections with frequency level 
"medium" 

• The total data length of all inputs with 
interconnections of frequency level "medium" 
in bytes. 

These lines never contain a warning; 
they are used for breakdown purposes 
only. The potential overload is 
highlighted in the "Distribution by 
rate..." line. 

Configured:  
 medium (<Actual>ms);  
 interconnections: <Actual>; 
Data length: <Actual> byte 

Current configured values for incoming 
interconnections with frequency level "medium":  
• The configured time interval for the scanning 

frequency with frequency level "medium" in 
milliseconds 

• The current number of incoming 
interconnections with frequency level 
"medium" 

• The current total data length of all inputs with 
interconnections of frequency level "medium" 
in bytes. 

These lines never contain a warning; 
they are used for breakdown purposes 
only. The potential overload is 
highlighted in the "Distribution by 
rate..." line. 

Device parameter:  
 slow (<Min> ms);  
 interconnections: <Max>; 
 Data length: <Max> byte 

Device performance parameters (limit values) at 
"slow" rate level: 
• The mimimum interval for a scan rate at 

"slow" rate level in ms 
• The maximum number of incoming 

interconnections with frequency level "slow" 
• The total data length of all inputs with 

interconnections of frequency level "slow" in 
bytes. 

These lines never contain a warning; 
they are used for breakdown purposes 
only. The potential overload is 
highlighted in the "Distribution by 
rate..." line. 

Configured:  
 slow (<Actual>ms);  
 interconnections: <Actual>; 
Data length: <Actual> byte 

Current configured values for incoming 
interconnections with frequency level "slow":  
• The configured interval for a scan rate at 

"slow" rate level in ms 
• The current number of incoming 

interconnections with frequency level 
"medium" 

• The current total data length of all inputs with 
interconnections of frequency level "slow" in 
bytes. 

These lines never contain a warning; 
they are used for breakdown purposes 
only. The potential overload is 
highlighted in the "Distribution by 
rate..." line. 
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Parameter Meaning  Remedy 
Outgoing interconnections: Interconnection at the outputs of technological function(s) 
Number  Number of outgoing interconnections. For 

PROFINET devices with proxy functionality, this 
incorporates the interconnections of the coupled 
PROFIBUS devices. 

Total data length  Sum of the data lengths of all connections with 
outgoing interconnections. For PROFINET 
devices with proxy functionality, this incorporates 
the interconnections of the coupled PROFIBUS 
devices. 

• Reduce the number of outgoing 
interconnections with acyclic 
transfer to remote communication 
partners or 

• use interconnections with cyclic 
transfer, if necessary. 

Distribution by frequency: This parameter is represented as follows: 
• OK – if the distribution of interconnections by 

frequency level is OK. 
• With a warning symbol - if the distribution of 

interconnections by frequency level is not 
suitable. 

The following parameters show whether the 
performance parameters are exceeded or 
undershot by the configuration of the 
interconnection for each frequency level. 

If a warning symbol appears on the 
line: 
• Determine the frequency level at 

which at least one device parameter 
limit value is exceeded or undershot 
by the associated configured value 
and 

• distribute the outgoing remote 
interconnections for the affected 
frequency level to other frequency 
levels or 

• use interconnections with cyclic 
transfer, if necessary. 

Device parameter:  
 fast (<Min>ms);  
 interconnections: <Max>; 
 Data length: <Max> byte 

Device performance parameters (limit values) for 
the frequency level "fast": 
• The minimum time interval for the scanning 

frequency with frequency level "fast" in 
milliseconds 

• The maximum number of outgoing 
interconnections with frequency level "fast" 

• The total data length of all outputs with 
interconnections of frequency level "fast" in 
bytes. 

These lines never contain a warning; 
they are used for breakdown purposes 
only. The potential overload is 
highlighted in the "Distribution by 
rate..." line. 

Configured:  
 fast (<Actual> ms);  
 interconnections: <Actual>; 
Data length: <Actual> byte 

Current configured values for outgoing 
interconnections with frequency level "fast":  
• The configured time interval for the scanning 

frequency with frequency level "fast" in 
milliseconds 

• The current number of outgoing 
interconnections with frequency level "fast" 

• The current total data length of all outputs with 
interconnections of frequency level "fast" in 
bytes. 

These lines never contain a warning; 
they are used for breakdown purposes 
only. The potential overload is 
highlighted in the "Distribution by 
rate..." line. 
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Parameter Meaning  Remedy 
Device parameter:  
 medium (<Min> ms);  
 interconnections: <Max>; 
 Data length: <Max> byte 

Device performance parameters (limit values) for 
the frequency level "medium": 
• The minimum time interval for the scanning 

frequency with frequency level "medium" in 
milliseconds 

• The maximum number of outgoing 
interconnections with frequency level 
"medium" 

• The total data length of all outputs with 
interconnections of frequency level "medium" 
in bytes. 

These lines never contain a warning; 
they are used for breakdown purposes 
only. The potential overload is 
highlighted in the "Distribution by 
rate..." line. 

Configured:  
 medium (<Actual> ms);  
 interconnections: <Actual>; 
Data length: <Actual> byte 

Current configured values for outgoing 
interconnections with frequency level "medium":  
• The configured time interval for the scanning 

frequency with frequency level "medium" in 
milliseconds 

• The current number of outgoing 
interconnections with "medium" rate level. 

• The current total data length of all outputs with 
interconnections operating at a "medium" rate 
level in bytes. 

These lines never contain a warning; 
they are used for breakdown purposes 
only. The potential overload is 
highlighted in the "Distribution by 
rate..." line. 

Device parameter:  
 slow (<Min> ms);  
 interconnections: <Max>; 
 Data length: <Max> byte 

Device performance parameters (limit values) at 
"slow" rate level: 
• The minimum interval for a scan rate at "slow" 

rate level in ms 
• The maximum number of outgoing 

interconnections at "slow" rate level. 
• The total data length of all outputs with 

interconnections of the "slow" rate level in 
bytes. 

These lines never contain a warning; 
they are used for breakdown purposes 
only. The potential overload is 
highlighted in the "Distribution by 
rate..." line. 

Configured:  
 slow (<Actual> ms);  
 interconnections: <Actual>; 
Data length: <Actual> byte 

The current number of outgoing interconnections 
with "slow" rate level.  
• The configured interval for a scan rate at 

"slow" rate level in ms 
• The current number of outgoing 

interconnections with "medium" rate level. 
• The current total data length of all outputs with 

interconnections of operating at a "slow" rate 
in bytes. 

These lines never contain a warning; 
they are used for breakdown purposes 
only. The potential overload is 
highlighted in the "Distribution by 
rate..." line. 

 

See also 
Utilization parameters of the PROFINET devices (Page 145) 
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4.4.4.8 Parameters for cyclic remote interconnections 

Utilization parameters: Parameters for cyclic remote interconnections of DP master and DP slaves 
Parameters for interconnections with cyclic transfer to remote communication partners. For 
PROFINET devices with proxy functionality, this incorporates the interconnections of the 
coupled PROFIBUS devices. 

 
Parameter Meaning  Remedy 
Minimum interval of the 
transfer rate  

Minimum time interval for the transfer rate at "fast" 
level in ms 

Increase the minimum interval for the 
transfer rate at the "fast" rate level in 
the project settings. 

Minimum interval of the 
transfer rate 

Maximum time interval for the transfer rate at 
"slow" level in ms 

Reduce the minimum interval for the 
transfer rate at the "slow" rate level in 
the project settings. 

Maximum data length for 
arrays and structures for DP 
master and DP slaves 

Maximum data length for arrays and structures in 
bytes. For PROFINET devices with proxy 
functionality, this incorporates the functions of the 
coupled PROFIBUS devices. 
Possible cause:  
 The data length of at least one connection of a 
coupled PROFIBUS device is too long for this 
master 

Couple the PROFIBUS device to 
another PROFINET device with proxy 
functionality. 

Configured transfer rates Values of the configured transfer rates for this 
project  

You can edit the transfer rate interval 
settings in the project properties. 

Incoming interconnections: Interconnection at the inputs of technological function(s) 
Number  Number of incoming interconnections. For 

PROFINET devices with proxy functionality, this 
incorporates the interconnections of the coupled 
PROFIBUS devices. 

Total data length  Sum of the data lengths of all connections with 
incoming interconnections. For PROFINET 
devices with proxy functionality, this incorporates 
the interconnections of the coupled PROFIBUS 
devices. 

• Reduce the number of incoming 
interconnections with cyclic 
transfer to remote communication 
partners 

• Use interconnections with acyclic 
transfer, if necessary. 

Configured distribution to 
transfer rates 

The following parameters comprise the current 
configuration data for incoming interconnections 
with cyclic transfer, distributed to rate levels. 

Number of interconnections Number of incoming interconnections at the 
corresponding rate level. 

Data lengths Number of incoming interconnections at the 
corresponding rate level in [bytes]. 

Limits are not indicated, and remedies 
are thus not required. 

Total number of data packets Total number of incoming data packets • Reduce the number of incoming 
interconnections with cyclic 
transfer to remote communication 
partners 

• Use interconnections with acyclic 
transfer as required. 

Number of data packets per 
minimum interval of the 
transfer rate  

Number of incoming data packets within the 
minimum transfer rate interval. 

Reduce the number of 
interconnections operating at a "fast" 
transfer rate in the project. 
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Parameter Meaning  Remedy 
Number of bytes per 
minimum transfer rate 
interval 

Number of incoming bytes within the minimum 
transfer rate interval. 

Reduce the number of 
interconnections operating at a "fast" 
transfer rate in the project. 

Outgoing interconnections: Interconnection at the outputs of technological function(s) 
Number Number of outgoing interconnections. For 

PROFINET devices with proxy functionality, this 
incorporates the interconnections of the coupled 
PROFIBUS devices. 

Total data length  Sum of the data lengths of all connections with 
outgoing interconnections in bytes. For 
PROFINET devices with proxy functionality, this 
incorporates the interconnections of the coupled 
PROFIBUS devices. 

• Reduce the number of outgoing 
interconnections with cyclic 
transfer to remote communication 
partners or 

• use interconnections with acyclic 
transfer, if necessary. 

Configured distribution to 
transfer rates 

The following parameters comprise the current 
configuration data for outgoing interconnections 
with cyclic transfer, distributed to rate levels. 

Number of interconnections Number of outgoing interconnections at the 
corresponding rate level. 

Data lengths Number of outgoing interconnections at the 
corresponding rate level in [bytes]. 

Limits are not indicated, and remedies 
are thus not required. 

Total number of data packets Total number of outgoing data packets • Reduce the number of outgoing 
interconnections with cyclic 
transfer to remote communication 
partners 

• Use interconnections with acyclic 
transfer as required. 

Number of data packets per 
minimum interval of the 
transfer rate  

Number of outgoing data packets within the 
minimum transfer rate interval. 

Reduce the number of 
interconnections operating at a "fast" 
transfer rate in the project. 

Number of bytes per 
minimum transfer rate 
interval 

Number of outgoing bytes within the minimum 
transfer rate interval. 

Reduce the number of 
interconnections operating at a "fast" 
transfer rate in the project. 

Dynamic load distribution Result of the test of time-based requirements of 
the distribution of outgoing data to several data 
packets for the various remote communication 
partners. This also includes any reserved transfer 
resources for an integrated PROFINET IO 
controller. 

• Reduce the number and transfer 
rate of outgoing interconnections 
with cyclic transfer to remote 
communication partners 

• Use interconnections with acyclic 
transfer as required. 

 

See also 
Utilization parameters of the PROFINET devices (Page 145) 
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4.4.4.9 Error messages for interconnections with cyclic transfer 

Error messages for interconnections with cyclic transfer 
 

Error message Remedy 
The device does not support remote 
interconnections with cyclic transfer. 

• Replace the device with one with Runtime version 2.0 or 
later that supports cyclic transfer or 

• Use interconnections with acyclic transfer 
The capacity limit for remote 
interconnections with cyclic transfer 
between <Device 1> and <Device 2> 
with a transfer rate of <nn> ms was 
exceeded. 

Reduce the data volume transferred between the specified 
interconnection partners at the specified rate level, i.e.: 
• Reduce the number of interconnections to remote 

partners 
• Redistribute the relevant remote interconnections to 

other rate levels or 
• Use the interconnections with acyclic transfer. 

The connection <name> cannot be 
interconnected remotely in cyclic 
transfer mode due to its data length. 

Use interconnections with acyclic transfer, if necessary. 

See also 
Utilization parameters of the PROFINET devices (Page 145) 

4.5 Working with modified PROFINET components 

4.5.1 Editing PROFINET components 
You can edit PROFINET components directly using a SIMATIC iMap library. This creates a 
copy of the component project in the directory defined under Options > Customize. You can 
edit the copy using the manufacturer-specific configuration and programming tool and then 
use it as the basic project for creating the re-edited PROFINET component. 
The copy of the component project is uniquely identified by the ID and version of the original 
PROFINET component.  

To re-edit a PROFINET component in SIMATIC iMap 
1. Highlight the PROFINET component to be modified in the library. 
2. Select the Re-edit component command from the context menu. 
3. In the "Re-edit PROFINET component" dialog, select the directory in which you want to 

create a copy of the component project. Click the "Modify" button to search the file 
system for the directory. 
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4. Click "OK." 
If you do not yet have a copy of the component project, a copy is created and is opened 
for editing in the manufacturer-specific configuration and programming tool.  
If the selected directory already contains a copy of the component project, you are asked 
whether you want to overwrite this copy. Result: 
– Click on "Yes" to create a copy of the current component project in the specified 

directory and open it for editing in the manufacturer-specific configuration and 
programming tool. The existing copy will be overwritten in the process. 

– Click "No" to open the existing copy of the component project for editing in the 
manufacturer-specific configuration and programming tool. 

5. Make the necessary changes to the copy of the component project. 
6. Create a new version of the PROFINET component and import the newly created 

PROFINET component into a SIMATIC iMap library. You can then use the component in 
SIMATIC iMap projects. 

7. If necessary, replace any instances of the earlier version of the PROFINET component 
with instances of the modified component (see "Replacing instances"). 

 

  Note 
The uniquely defined storage location for the modified component project makes it easier 
to make changes to PROFINET component. The next time you edit the PROFINET 
component, you will be reminded that an earlier copy already exists (if appropriate). 

See also 
Generating the Project (Page 86) 
Moving interconnections (Page 134) 
Replacing instances (Page 156) 
Data storage in SIMATIC iMap (Page 92) 

4.5.2 Replacing instances 
In SIMATIC iMap, you can easily replace the instance of a PROFINET component with the 
instance of another PROFINET component. In this way, you can quickly incorporate changes 
to PROFINET components into existing SIMATIC iMap projects.  

Rules for replacing instances 
Rules for replacing an instance: 
● The device of the instance to be set and that of the destination components must have 

the same network connections. E.g. a PROFINET device with Ethernet connection 
cannot be replaced by a PROFIBUS device (DP slave) and vice-versa. 

● It is not possible to replace a PROFINET device with proxy functionality with a device 
lacking proxy functionality. However, the other way round this is possible. 
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● Internal DP slaves on the local PROFIBUS of a new device must be assigned PROFIBUS 
addresses other than those of the already connected PROFIBUS devices. 

● A sufficient number of PROFIBUS addresses must be available at the new device, in 
order to be able to integrate the connected PROFIBUS devices in the replacement 
device. 

● The device can only be replaced with a PROFINET device with proxy functionality if the 
device to be replaced is connected to the vertical Ethernet bus, but not to any Ethernet 
branch. 

● The object name (function or device name) of the instance to be replaced may not 
exceed the maximum permitted length for object names of the destination component (for 
example, max. 16 characters for PROFINET components created in SIMATIC iMap 
V1.2.) Open the properties dialog box of the instance to be replaced, and assign a name 
with a valid length to the function and the device. 

What happens during replacing? 
The configured properties of the old instances, such as IP or PROFIBUS addresses, are 
transferred to the new instances.  
Interconnections will be transferred as far as possible, if the connections of the technological 
function are of the same type (input or outout), name and data type. Any configured 
substitution values and transfer properties of the interconnections will also be applied.  

 

NOTICE  
The instance will always be replaced, irrespective of any differences in technological 
functions between the new instance and the new component.  
Interconnections may be lost when you replace the instances, if the new technological 
functions do not contain all connections of the replaced technological functions. 

 
Detailed information on the replacement of special components with internal PROFINET IO 
system or IO devices, for example, is available (see below.) For further information on the 
replacement of multifunction components, refer to the chapter "Using multifunction 
components in a SIMATIC iMap project." 

Requirement 
The new component must be available in the project library. Import the new component into 
the project library if it is not already available.  
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How to replace the instance of a PROFINET component  
1. Select either: 

– the component to replace from the project view, or 
– the instance or instances to be replaced. You can select these objects from the project 

tree and in the work area. 
2. Select Replace from the context menu. The "Replace instances" dialog box opens. 
3. If necessary, change the number of selected instances to replace. Identify the required 

instances in the "Instances" input box. 
4. Define the new component under "Replace by". You can either accept the default 

component and its version, or select a different component or version from the drop-down 
lists. 

5. Click "Details" to read additional information on the replacement of a specific instance 
(see "Reading replacement details".) 

6. Click on the "Replace" button. 
Result: The selected instances will be replaced with those of the selected new 
component.  
The interconnections are transferred to the new instances in conformity with the 
connections. 

7. Check the replaced instances: 
– to ensure that all the necessary interconnections are present and 
– to ensure that the substitute values and transfer properties of the interconnections are 

configured correctly. 
8. Check the configuration of the replaced instances using the Edit > Verify utilization menu 

command (optional). 
9. Generate the project using the Project > Generate > Changes only menu command. 
10. Use the Download Selected Device > All menu command to download all the 

programming and configuration data to the target system. 

Tip: Replace with drag-and-drop 

To replace an individual instance:  
Select the destination component from the library, press and hold the "ALT" key, and then 
drag-and-drop it to the instance you want to replace in your project. Answer "Yes" when you 
are asked whether you really want to replace the instance. Then carry out steps 6 to 9 as 
described above. 

To replace a group of instances of a component:  
1. Open the project view. 
2. Select the destination component from the library, press and hold the "ALT" key, and then 

drag-and-drop it to the component in the project view. Confirm the prompt to replace the 
instance(s) by clicking "Yes." Next, go to step 6 to 9 as described earlier. 
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Requesting replacement details 
Detailed information on the replacement of special components with internal PROFINET IO 
system or IO devices can be viewed by clicking the "Details" button of the "Instances" dialog 
box: 
The "Replacement details" dialog box shows you how the elements of the instances are 
handled when you replace it. Options for specific objects, symbolic representation: 

 
Symbol Description 

 
 

Replacing an object with a new object.  
The properties of the old object are trasferred to the replacement object.  

 
 

The replacement action adds an object.  
You may need to assign new configuration data if you add new objects. 
For example: When adding an internal PROFINET IO system, or an internal IO device, 
always assign IP addresses to those devices. 

 
 

The replacement action removes an object.  
Certain project data and interconnections may be lost if you remove any objects.  
For example: by removing a PROFIBUS connection, you also disconnect any connected 
PROFIBUS devices. However, those PROFIBUS devices will be retained in the 
SIMATIC iMap project, and must be reconnected. 

 
 

 Note 
Internal IE devices 
In the case of instances with internal PROFINET IO systems or internal IE devices, these 
components are then only replaced if the new PROFINET component represents the product 
of a revised old. In this case, also the configuration data, like for example, IP addresses of 
the PROFINET IO devices are transferred to the new instance. If not (i.e. no revision), the 
old elements will be replaced with the new ones.  

 
 Note 

Several PROFIBUS connections 
In the case of instances with several PROFIBUS connections, any coupled PROFIBUS 
devices are then only transferred to the new instance if the numbers of the PROFIBUS 
connections agree. If this is not the case, any PROFIBUS devices that are connected will 
become uncoupled. However, these PROFIBUS devices will be retained in the 
SIMATIC iMap project, and must be reconnected or deleted. The number of a PROFIBUS 
connection can be established or checked when creating the PROFINET components in the 
SIMATIC Manager under the "DP subnets" tab. 
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 Note 
Recommendation 
With the help of "Replacement details", check which changes are made at the new 
instances, and then configure the element properties as required after the replacement. 

 

See also 
Editing PROFINET components  (Page 155) 
Moving interconnections (Page 134) 

4.6 Editing in the manufacturer-specific programming and configuration 
tool 

SIMATIC iMap allows you to call applications from the manufacturer-specific programming 
and configuration tool directly at an instance within the project. You can then read or edit the 
device-specific data, for example. Device-specific diagnostics information is of particular 
importance, and can be viewed this way. 

Access to the manufacturer-specific programming and configuration tool 
Options of opening the manufacturer-specific programming and configuration tool in 
SIMATIC iMap: 
● Editing the instance of a technological function 
● Editing the instance of a device 
Based on the selected objects, you can open various applications of the manufacturer-
specific engineering tools to edit relevant elements of the instance. 

Requirement 
The SIMATIC iMap project is generated. 
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How to edit objects in the manufacturer-specific programming and configuration tool: 
1. Select the object to be edited: 

– the instance of the technological function 
– the instance of the device 

2. Select Edit > Special using one of the available commands. Those commands are 
device-specific. The menu is grayed out if there is nothing to edit, or if nothing has been 
generated yet. 

3. Save your changes, and then download these delta data directly to the PLC using the 
configuration and programming tools. 

 

CAUTION  
 

When editing in the manufacturer-specific configuration and programming tool, always 
avoid inconsistency or any other errors in the edited component or shadow project  
If any errors are found, you may once again have to generate the SIMATIC iMap 
project. 

CAUTION  
 

If you regenerate the iMap project using the Project > Generate > Control unit > All 
menu command, any changes you have made using the manufacturer-specific 
configuration and programming tool will be lost. However, the system will create an 
optional backup copy of the old shadow project. 
In SIMATIC iMap, you can not undo any changes made using the manufacturer-specific 
configuration and programming tool. 

CAUTION  
 

If the "Accelerated generation for PROFINET devices without proxy functionality" option 
is activated, a temporary project is created at the instance of such a device for the 
execution of the Edit > Special > menu command. Changes that you made using the 
manufacturer-specific configuration and programming tool are not retained, because the 
temporary object is deleted. 
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Commissioning and online operation 5
5.1 Basic commissioning procedures 

Requirements 
Requirements of plant commissioning: 
● The device-specific configuration and programming tools, such as STEP 7, are installed 

on your PC/programming device. Depending on the type of device, this software is 
required to perform certain actions, for example, a program download. 

● The project has been generated without errors in SIMATIC iMap. 
● All device configuration data are prepared (generated) for the download. 
● The devices are connected via Industrial Ethernet or PROFIBUS. 
● The devices are switched on. 
● The PC/programming device running SIMATIC iMap is connected to the devices at the 

plant via Ethernet. 

Basic procedure 
1. Start SIMATIC iMap 
2. Open the project. 
3. Download the programs and interconnections to the devices. 
You can then use the following test and diagnostic functions (optional): 
● Monitoring and analyzing the plant in online mode 
● Testing and controlling using the variable table 
● IViewing and setting online values 
● Performing an online device analysis 
● Checking accessibility of the devices 
● Comparison of the online and offline data of programs and interconnections 
● Performing a device-specific diagnosis 
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5.2 Overview of the online functions 

Requirement 
SIMATIC iMap must be connected to the plant via Ethernet to allow monitoring of devices in 
online mode. Both PROFINET and PROFIBUS devices (via a PROFINET device with proxy 
functionality) are available online. 

SIMATIC iMap in the online and offline views 
SIMATIC iMap is opened in the offline view by default (no connections to any devices.)  
You can enable and disable online mode for various SIMATIC iMap views. 
● Variable table - by clicking the "Monitor variables online" icon, or by selecting the Online > 

Variable table > Monitor variables menu command. 
● You can open all other views of the work area, and the "Functions" and "Devices" 

variable of the diagnostics window by clicking the "Online monitoring", or by selecting 
Online > Monitor.  

 
Figure 5-1 SIMATIC iMap in the online view 
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 Note 
You may only use one SIMATIC iMap application tomonitor a plant in online mode. 
An enabled online view for a plant in more than one SIMATIC iMap applications will cause 
additional processor load on the plant PLCs. 

 

Online functions 
SIMATIC iMap supports the following functions for starting, controlling and monitoring the 
plant in RUN:  
Online monitoring mode enabled 
● Diagnostics of devices, functions and interconnections 
● Download of interconnections to the devices of a plant 
● Viewing and setting online values 
● Viewing the module status (depending on the device type) 
● Viewing the process state (depending on the device type) 
Online monitoring mode disabled 
● Comparison between online and offline data of interconnections and programs 
● Download of programs and interconnections to the devices of a plant. 
● Checking availability of the devices 
Independent of the online view: 
● Device-specific diagnostics using the manufacturer-specific configuration and 

programming tool. 
● Online device analysis 

Optional actions in the online view 
If Online monitoring is enabled, certain actions which modify the project are disabled, i.e. 
copy, paste, delete and interconnect operations. Generation, logging, archiving an retrieving 
are also disabled in the online view. 
Actions such as viewing (not changing) properties, printing the contents of the current 
window and the Edit > Special... menu command are also disabled in the online view. 
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5.3 Download 

5.3.1 Download concept 

Download options  
The term "download" refers to the download of data from SIMATIC iMap to an automation 
device or field device. You can download the following data to the devices of the plant from 
SIMATIC iMap: 
● Program 

Download the user program, including all device-specific data such as the hardware and 
network configuration. The manufacturer-specific configuration and programming tool, for 
example STEP 7, is required for the program download. 
In a program download, you can either include the entire program, or only the modified 
blocks.  
Advantage: If only program changes are downloaded, blocks that you haven´t changed 
will not be overwritten, so that any actual values that may be saved in the target system 
are maintained. 

● Interconnections 
Download of interconnection data to the corresponding devices of the plant. 
Interconnections may be downloaded from SIMATIC iMap without using the 
manufacturer-specific configuration tool.  

● All 
Downloads the program and interconnections to the devices of the plant. This action also 
requires the manufacturer-specific configuration and programming tool. 

Download options, depending on the selected objects: 
 

Selection Download option Menu command 
for the entire project Main menu 

Online > Download all instances > 
• all > All 
• program only > Program only > All  

> Program only > Deltas only 

Not selected 

• only interconnections > Interconnections only 
for selected instances  Main menu 

Online > Download selected instances > 
• all > All 
• program only > Program only > All  

> Program only > Deltas only 
• only interconnections > Interconnections only 
 Shortcut menu 

Download selected instances > 
• all > All 
• program only > Program only > All  

> Program only > Deltas only 

One or 
several 
instances  

• only interconnections > Interconnections only 
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NOTICE  
The user program may be overwritten in the destination system concerned if you set the 
wrong IP addresses. 

 
 Note 

Make sure the program and interconnections are downloaded to the device from only one 
SIMATIC iMap application at any given time. 

 
 Note 

Instances of singleton components are excluded from the program download. The program 
download can only be carried out using the manufacturer-specific configuration tool.  

 

Purpose of the download  
 

Download... Selected device to 
SIMATIC iMap  

Plant device as destination for the download 

Program PROFINET device Corresponding PROFINET device 
 PROFIBUS device Corresponding PROFIBUS device 
Interconnections PROFINET device Corresponding PROFINET device 
 PROFIBUS device Corresponding PROFINET device with proxy 

functionality 
 
 

 Note 
You may need to perform additional steps to save the download data to non-volatile memory 
of the device, depending on the device type.  
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Examples: Download required 
 

Example Representation 
Function, 
interconnection 
download required 

 
Device, interconnection 
download required 

 

See also 
Program downloads (Page 168) 
Download of interconnections (Page 174) 

5.3.2 Program downloads 

Situations requiring a program download 
You can determine whether a program download is necessary by carrying out an online-
offline comparison. A program download is required in the following situations: 
● When a device is being commissioned 
● After connecting or disconnecting PROFIBUS devices 

This scenario requies a program download to the associated PROFINET device with 
proxy functionality, and to all intelligent PROFIBUS devices associated with the proxy 
system. 

● After replacing instances 
Caution: After you replaced a PROFIBUS device, always download a program to the 
associated PROFINET device with proxy functionality, and to the destination device of 
the replaced instance. 
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Download actions 
Most automation devices require additional actions to be carried out prior to and after the 
program download. 
● Stopping the devices prior to program download 
● Restarting the devices after program download 
SIMATIC iMap opens a download manager to supports you in selecting the device and in the 
download.  

 
 

You can open a full list of optional actions by clicking "Extras."  
The pre- and post-download actions for each device are visualized symbolically.  
All download actions performed for the devices can be saved, and thus reused as a basis for 
further downloads.  

Download requirements 
● The PG/PC is connected to the plant via Ethernet. 
● The devices must be available on the bus. 
● All instances of the PROFINET components selected for the program download must 

have been assigned the "generated" status in their properties. You may have to generate 
the SIMATIC iMap project.  

● Online monitoring mode must be disabled in SIMATIC iMap. 
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  Note 
Recommendation: Before downloading, check the device utilization (with the Edit > Verify 
utilization menu command) to ensure error-free loperation of the plant. 

How to download programs 
To download programs to the chosen devices, select the instances of the devices for the 
download, then select one of the following commands from the pop-up menu: 
● Online > Download all instances > Program only > All, to download all programs to all 

devices of the plant 
● Online > Download all instances > Program only > Deltas, to download the delta data to 

all devices of the plant 
● Online > Download all instances > All, to download all programs and interconnections to 

all devices of the plant 
To download the programs to selected instances: Select the instances of the devices for the 
download, then select one of the shortcut menu commands listed below: 
● Download selected instances > Program only > All, to download all programs to the 

devices 
● Download selected instances > Program only > Deltas, to download only the program 

deltas to the devices 
● Download selected instances > All, to download all programs and interconnections to the 

devices 
The download dialog box will always be opened. It lists either the selected or all devices, and 
the selected action corresponds with the menu command called. Procedure: 
1. Click "Execute" to immediately execute the selected action for the marked devices, or go 

to the steps outlined below:: 
2. Optional: Activate the option "Note list to continue later", in order to save the states of the 

devices after the desired actions have been carried out. The list of devices contains the 
status of the executed download actions (success or failure), and can be used as a basis 
for further download. 
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3. Optional: Set the "Show only selected objects" to reduce the size of the list. 

 
 

4. Optional: Click "Extras" to open a list of optional actions, then select an action for the 
selected devices. 
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5. Click "Execute". 
Result: The "Download - Stop" dialog box of the devices opens, except if you selected the 
"Download interconnections" action. 

6. Delete any relevant devices from the list by deleting their identifier from the first column, 
then click "Next." 
Result: The selected devices will be stopped. Next, the download is started automatically, 
if one of the download actions is selected.  
The "Download - Start devices" dialog box opens when the program download is 
successfully completed. This dialog lists all devices you can restart after the program 
download is successfully completed.  

7. Option of the "Download - Start devices" dialog box: 
– Delete any relevant devices from the list by deleting their identifier from the first 

column. You can restart those devices at any later time. 
– Change the start sequence using the arrow keys. 

8. Press "Next" button to start the selected devices. 
Result: The devices will start.  
The download dialog remains opened and shows information regarding the executed 
actions as a symbol with tool tip. 
The "General" tab of the task view returns information about the progress, termination of 
the action, or possibly error messages.  

9. Click "Close" to close the download dialog box. 
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Resuming a download 
If in the download dialog you have activated the option "Note list to continue later" prior to 
closing, the device list will be saved and you can carry out further download actions at a later 
point, e.g. after remedying any errors. 
Select Online > Continue download. The download dialog box shows the list of devices you 
saved, including information about previous download actions (success or failure.)  

 

NOTICE  
The list records already started or executed download actions. This must not be confused 
with the current status of the devices. 

 
You can continue with further downloads for the listed devices. 

See also 
Download concept (Page 166) 
Editing in the manufacturer-specific programming and configuration tool (Page 160) 
Download of interconnections (Page 174) 
Analyzing PROFINET components  (Page 182) 
Comparing online and offline data  (Page 188) 
Generating the Project (Page 86) 
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5.3.3 Download of interconnections 

Scenarios requiring a download 
Interconnections can be downloaded to the target devices later if required, e.g. in order to 
test the PROFINET communication between the components. 
The instances for which interconnections have to be downloaded are identified by a vertical 
arrow and are listed on the "Functions" tab in the diagnostics window (see diagram). 

 
Figure 5-2 Download required 
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Download requirements 
● The PG/PC is connected to the plant via Ethernet. 
● The devices must be available on the bus. 

 

  Note 
Recommendation: Check the utilization of device resources before you start the 
download action (select Edit > Check utilization) in order to ensure error-free operation of 
your plant. 

CAUTION  
 

The interconnections are downloaded to the target system regardless of the operating 
status or level of protection on the target system. Plant safety should be verified in 
particular by checking all settings, such as function names and IP addresses. This also 
applies to the "Download" button in the diagnostics window. 
Select the Online > Online-offline comparison >... menu command to determine the 
differences between the SIMATIC iMap project (offline) and the plant (online). 

How to download interconnections 
● Select Online > Download all instances > Interconnections only, to download the 

interconnections to all devices of the plant 
or  
● Select the instances of the devices for which the download is performed, then select 

Online > Download selected instances > Interconnections only to download the 
interconnections to the devices. 

Result: The interconnections are downloaded to all or selected devices of the plant. The task 
view returns information about the progress, termination of the action, or possibly error 
messages.  

Downloading the program and interconnections  
The program and interconnections can be downloaded in the same action. To do so, select: 
● Online > Download all Instances > All to download both programs and interconnections to 

all the devices of the plant. 
● Online > Download selected instances > All, to download all programs and 

interconnections to selected devices. 
This opens the download dialog box. Continue as for a program download (see the chapter 
"Program download".) 
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Downloading interconnections in online mode 
Provided online monitoring is enabled, the "Functions" tab of the dialog box returns all 
functions requiring a download of interconnections. A "download" button willl be offered in 
the right section of the dialog box when you select one of those functions, as in the example 
below: 

 
Figure 5-3 Example: Functions - Download required 

Click "Download" to transfer the interconnections to the relevant device of the PLC. 

See also 
Download concept (Page 166) 
Program downloads (Page 168) 

5.3.4 Download to PROFIBUS devices 

Actions triggered by a download to PROFIBUS devices  
The download to the PROFIBUS devices always takes place via a PROFINET device with 
proxy functionality (see figure).  
● The interconnections of PROFIBUS devices are downloaded to the associated 

PROFINET device with proxy functionality, where they are stored. 
● When the program is downloaded, part of the configuration data for the coupled 

PROFIBUS devices is stored on the associated PROFINET device with proxy 
functionality. If you download programs to selected devices, you must first of all download 
the program to the PROFINET device with proxy functionality and then carry out the 
program download to the coupled PROFIBUS devices. 
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Figure 5-4 Download to PROFIBUS devices 

 

NOTICE  
 

When you download the program to a PROFINET device, both the interconnections of 
the actual PROFINET device and the interconnections of any coupled PROFIBUS 
devices are deleted. 
You will then have to download the interconnections to all devices of the DP master 
system. 

When using a router 
When the engineering PC and the PROFINET device with proxy functionality are located in 
different subnets, a router must be used. In this case, for the program download in coupled 
PROFIBUS devices (S7 slaves), a PG / PC assignment in the shadow project is required.  
Procedure: 
1. If necessary, generate the controller unit of the SIMATIC iMap project. 
2. Select a device in the network view of SIMATIC iMap and then choose Special > 

SIMATIC Manager from the pop-up menu. The shadow project is opened in the SIMATIC 
Manager. 

3. Choose Add > PG / PC and open the properties of the PG / PC object and configure a 
new PG / PC assignment including router. 

The it is possible to download the program to the coupled PROFIBUS device (S7 slaves). 
 

NOTICE  
After a regeneration of the controller unit (Project > Generate > Controller unit > All new) 
the PG / PC object is deleted from the shadow project and you must reconfigure the PG / 
PC assignment. 
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5.4 Diagnostics information in the online view 

Introduction 
The active Online view in SIMATIC iMap returns diagnostics information in text-based or 
graphic format.  
● the availability and status of PROFINET communication partners, 
● the status of interconnections and online values, and 
● the operating status of the devices (depending on the device type) 
Diagnostics information in graphic format:  
● Icons at the objects, for example, "Download of interconnections required", or 
● Object colors, for example, black interconnection lines indicate the error-free state of the 

interconnection. 

Online-offline comparison 
SIMATIC iMap allows you to compare the online and offline interconnection and program 
data. The task view and diagnostics view return the result of an online/offline comparison in 
plain text. 

Status of the PROFINET communication partners 
With respect to PROFINET communication, the nodes may assume certain states which are 
visualized in SIMATIC iMap by means of symbole and diagnostics messages, for example: 
● whether the devices are available online (configuration check) 
● whether a diagnostic messages is available at the devices, 
● whether an interconnection download is required, 
● whether diagnostic information is available at all, 
● whether interconnections are disrupted, 
● whether a PROFIBUS device is connected to the associated PROFINET device with 

proxy functionality. 
The plant view also indicates the validity of online values. 
The network view also indicates the operating state of the devices. 
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Diagnostics symbols 
 

Symbol Error message Meaning 

 
 

Configuration check The connection to the device can not (yet) be established, the 
device is not (yet) available, or the function is not available at the 
destination device. 

 
 

Device diagnostics or 
error 

• On devices in the network view: Device-specific diagnostics 
data available. Click the "Diagnostics" button in the right-
hand pane of the diagnostics window to view the diagnostics 
information. 

• At a nested chart in the plant view: Error at one or several 
functions within the chart. 

 
Not connected The PROFIBUS device is not connected to the PROFINET 

device with proxy functionality, is not switched on, or is in STOP.

 
No information 
available 

The device can be accessed, but its state can not be determined 
(may apply to a DP slave, for example, if the DP master is in 
STOP.) 

 
Download required Interconnections download required. 

 
Interconnection error At least one interconnection to the device is disrupted. 

 
Maintenance required  Maintenance information: The respective component has to be 

replaced within a foreseeable period 

 
Maintenance 
demanded  

Maintenance information: The respective component has to be 
replaced within a short period 

No icon   The device or function are OK 
 
 

 Note 
If several diagnostic states occur simultaneously for a device, the icon with the highest 
urgency is displayed, for example when two PROFIBUS devices with differing maintenance 
information are coupled to a device with proxy functionality. 

 

Normal and inverted representation 
The icons are output in normal or inverted mode to the views of the work area.  
● The normal representation (black icon on yellow background) applies to the currently 

visualiued instance, for example, a device in the network view, or a technological function 
in the plant view.)  

● The inverted representation (yellow symbol on gray background): Diagnostic symbols of 
the technological functions ("Interconnection erroe", for example) are visualized in 
inverted mode at the devices in the network view, whereas diagnostics symbols of the 
devices are inverted at the technological functions .  

In the project view, the diagnostic symbols are output in normal mode at the device or 
technological function. 
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Device operating states 
The current operating state of a device is visualized by a symbol in the SIMATIC iMap online 
network view.  

 
Symbol Operating state 

 
RUN 

 
STOP 

 
STARTUP 

 
DEFECTIVE 

The system also indicates whether the PROFIBUS devices are connected to the PROFIBUS 
master: 

 
Symbol State 

 
Connected to the PROFINET device with proxy functionality 

 
Not connected 

Status of the interconnections 
The status is indicated by the color of the interconnection line:  

 
Color of the 
interconnection line 

Meaning 

Black  the interconnection is OK 
Blue  the interconnection has been selected 
Red  Interconnection error (the error is usually found at the technological function 

output of the transmitting station.) 
Gray  no information about the interconnection available (the device is unavailable, 

or a download is required, for example) 

Diagnostic messages in the diagnostics view 
The active SIMATIC iMap online view outputs current messages to the "Functions" and 
"Devices" tabs of the diagnostics view. 
● The "Functions" tab returns diagnostic messages about the faulty technological functions 

and interconnections, such as a list of the functions for which an interconnections 
download is required. 

● The "Devices" tab returns diagnostic messages about the devices, such as a list of faulty 
or unavailable devices. 

The left-hand pane shows the faulty devices or functions, sorted by error class. Unavailable 
devices are visualized in a hierarchic order by DP master systems, thus allowing quirck 
identification of all the DP slaves assigned to a DP master.  
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The right-hand pane outputs information about the highlighted faulty instance, based on the 
error class, and provides download buttons, and device-specific diagnostics and help 
functions.  

 

 Note 
When a PROFINET device with proxy functionality (DP master) fails or is unavaulable, the 
system does not output detailed diagnostic messages for the connected PROFIBUS devices. 

 

Examples 
 

Example Representation 
Diagnostics view, 
"Functions" tab 

 
Diagnostics view, 
"Devices" tab 

 
 

See also 
Program downloads (Page 168) 
Comparing online and offline data  (Page 188) 
Displaying and setting online values in SIMATIC iMap (Page 190) 
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5.5 Analyzing PROFINET components 

Basic diagnostics procedures 
The functions for a diagnosis of PROFINET components in SIMATIC iMap are generally 
based on the sequence described below, an can be used to perform specific actions. 
1. Activate the online view by clicking the "Online connection" icon, for example. 
2. Open the "Devices" tab in the diagnostics view. 

Result: The left-hand pane outputs diagnostic information about the devices in a dynamic 
tree structure.  
The absence of diagnostic information indicates that the error-free operation of the plant's 
devices. Next, continue at step 4.  

3. Any diagnostics information at the "Devices" tab can be processed by selecting the 
device, and following the detailed information and troubleshooting options output in the 
right pane. Eliminate any faults. Click the offered button to view device-specific 
diagnostics data, for example. 
Order: First, process the devices in the "Configuration check" category. As long as the 
check of device configuration is not completed successfully, it is not possible to run 
PROFINET diagnostics for that device. You can then continue by processing the 
remaining devices in any order. 

4. Check the entries on the "Functions" tab. If no function erros are listed, you may assume 
error-free operation of the plant. 

5. Process any diagnostics information returned at the "Functions" tab by selecting the 
function, and following the detailed information and troubleshooting options in the right 
pane. Eliminate any faults. Click the offered button to download the interconnections, for 
example. 
Order: First, process the functions of the "Configuration check" category. As long as the 
fucntion check is not completed successfully, it is not possible to run PROFINET 
diagnostics for that function. You can then continue by processing the remaining 
functions in any order. 

The tables below provide a summary of the common diagnostic scenarios for devices and 
functions, and the troubleshooting options. 
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Diagnostics scenarios at the devices 
The various diagnostic scenarios for devices are described in the table below. 

 
Diagnostic scenario Possible causes Possible remedies 

 
Configuration check 

• Communication error, for example, cable 
break, cable not connected 

• The device is switched off 
• The device has not been started, or is not 

initialized 
• The device is not a PROFINET device 
• Hardware configuration error (different 

configuration) 
• The program has not been downloaded 

yet 
• Wrong device or function downloaded 
• Different ID or the version of the 

components online and offline 

• Compare the online / offline congfiguration 
of the programs and interconnections in 
order to find any error sources. 

• Check the communication connections 
• Eliminate the error 
• Switch on or restart the device 
• Check the IP addresses and subnet masks 
• Check the PROFIBUS addresses 
• Check the hardware configuration 
• Download the program to the target device 

 
Device diagnostics 

• Program error 
• The device is in STOP 

• Call device-specific diagnostics by clicking 
the "Diagnostics" button.  

• Eliminate the error 
• Download the program to the device 

 
Not connected 

• PROFIBUS cable not connected or 
defective 

• PROFIBUS device not switched on or in 
STOP 

• Check the PROFIBUS cable 
• Switch on the PROFIBUS device 
• Switch the PROFIBUS device to RUN 

 
No information available 

• Error or STOP state at the associated 
PROFINET device with proxy 
functionality. 

• The program has not been downloaded to 
the PROFIBUS device 

• Switch on the PROFINET device, or switch 
it to RUN 

• Eliminate any errors at PROFINET device. 
• Download the program to the PROFIBUS 

device 

 
Maintenance required  

Maintenance information The respective component has to be replaced 
within a foreseeable period 

 
Maintenance demanded  

Maintenance information The respective component has to be replaced 
within a short period 

 
 

NOTICE  
When you activate the online view, all configured devices will be initially assigned to the 
"configuration check" category, and remain present until the first check is successfully 
completed. If this test does not return any differences between the configured device and 
plant data, the device will be cleared from the category. The time it takes to run this 
operation may differ, depending on the plant size and PC used. 
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Diagnostic scenarios at technological functions 
The table below describes the various diagnostic scenarios at the technological functions. 

 
Diagnostic scenario Possible causes Possible remedies 

 
Configuration check 

• The device is switched off 
• The device has not been started, or is 

not initialized 
• The program has not been downloaded 

yet 
• No or a different technological function 

found in the PLC 
• Different ID or the version of the 

components online and offline 

• Check the communication connections 
• Eliminate the error 
• Switch on or restart the device 
• Download the program to the target device 

 
at the nested chart in the 
plant view 

• The chart contains at least one faulty 
function 

• Open the chart to check the functions. 

 
Download required 

• Differences in interconnection data 
between SIMATIC iMap and the device.

• Download the interconnections to the device 
Click the "Download" button 

 
Interconnection error 

• Error at the communication partner of 
the device, or th epartner station is not 
available. 

• Incompatible transfer properties of the 
interconnections (transfer mode or 
transfer rate) 

• Check the communication connections 
• Check and correct the interconnection 

properties 
• Compare the online data with offline data of 

the interconnections, and 
• eliminate the error 

 

See also 
Comparing online and offline data  (Page 188) 
Program downloads (Page 168) 
Displaying and setting online values in SIMATIC iMap (Page 190) 
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5.6 Checking device availability 

Requirement 
Your PG/PC must be connected to the plant via Ethernet in order to check availability of the 
devices. 

Available device 
A device of the plant must be accessible via PROFINET communication mechanisms in 
order to download the interconnections or monitor variables.  
SIMATIC iMap supports a number of options of checking the online availability of a 
PROFINET device. 
● If online monitoring mode is enabled 

– The availability of devies is indicated in graphic format in the views of the work area: 
Available devices are represented in darker mode, whereas non-available devices are 
represented in lighter and identified by a diagnostics icon. 

– The "Devices" tab of the diagnostics view returns a list of the unavailable devices. 
● If the online monitoring mode is disabled, you can use the menu commands to view the 

availability status of individual devices. 

How to check availability of a device: 
1. Disable the "Online connection" optio by selecting the Online > Monitor command, for 

example. 
2. Select the instance you want to test. You can also select multiple objects. 
3. Select: 

– Check availability from the shortcut menu or 
– the Online > Check availability command. 

Result: The system checks the online availability of the devices and outputs the results at the 
"General" tab of the task window. 
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Possible messages 
 
Message Possible causes Remedies 
Node at IP address 
<IP_Address> is not available 

• The physical connection to the device has failed or 
is not available. 

• The device is not switched on 
• For PROFIBUS devices: The associated PROFINET 

device with proxy functionality is not accessible or is 
in STOP. 

Any any PROFIBUS devices connected to the 
PROFINET device with proxy functionality will also be 
unavailable. 

• Check the connection or 
cable 

• Switch on the device 
• Check the PROFINET 

device with proxy 
functionality (DP master) 

The PROFINET access to the 
device at <IP_address> has 
failed 

The device is physically connected, but not ready for 
operation (in STOP, for example)  

Switch the device to RUN 

The logic device <device 
name> (proxy at <IP address>) 
is available, but the physical 
device is not. 

Only for PROFIBUS devices:  
• The PROFINET configuration data for the device are 

available at the associated PROFINET device with 
proxy functionality, but the connection between the 
DP master and DP slave has failed, or 

• the PROFINET configuration data has not been 
downloaded. 

• Check the PROFIBUS 
connection between the DP 
master and DP slave. 

• Download the program 

Different identification of the 
components 

The component detection (ID) in the target device 
(online) does not tally with the offline (in SIMATIC iMap) 
saved configuration data 

• Download the program 

Different version of the 
components 

The component version in the target device (online) 
does not tally with the offline (in SIMATIC iMap) saved 
configuration data 

• Download the program 

The device <Device name> is 
available 

  

Logic device 
The logic device is an element of the runtime software which handles PROFINET 
communication at a device, and is addressed in online monitoring mode by SIMATIC iMap. 
The PROFINET configuration data of a component downloaded to the device are assigned 
to this logic device.  

 

 Note 
The logic device of a PROFIBUS device is available at the associated PROFINET device 
with proxy functionality.  
The reason of a logic device of a PROFIBUS device being reported available, although 
represented differently in the online view, may have the following background: 
Although the PROFINET configuration of the PROFIBUS device is OK, the physical device 
of the DP slave is not available because the connection to the DP master (associated 
PROFINET device with proxy functionality) has failed, for example. 
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Examples: Availability  
 

 
Figure 5-5 Representation in the network view 

 

 
Figure 5-6 Message in the task view 
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5.7 Comparing online and offline data 

Comparison options  
If SIMATIC iMap is connected to a device of the plant via Ethernet, you can perform an 
online / offline comparison of one or several instances. This compares the online 
configuration data of the plant with offline data of the SIMATIC iMap project. You can 
compare the following data in SIMATIC iMap:  
● Interconnections only – connectors and interconnections of technological functions 
● Program only – all blocks in the user program, including all device-specific data such as 

the hardware and network configurations. 

Online/offline comparison of interconnections 
The purpose of an online / offline comparison of interconnections is to compare online and 
offline data of the technological functions and of their interconnections. Items checked: 
● Added or removed interconnections 
● Different transfer properties, for example, the transfer mode and transfer rate. 
● Inputs and outputs added or removed from the technological function 
● Different data types of the connectors 

 

  Note 
The online and offline data of interconnections are not automatically compared before 
their download, because this would inevitably result in longer execution times. For safety 
reasons, we therefore urgently advise you to run a comparison prior to the download in 
order to avoid any runtime errors. 

Requirements 
● Your PC/PG must be connected to the plant via Ethernet. 
● The SIMATIC iMap project must have been generated before you can compare online 

and offline programs. 
● Online monitoring mode must be disabled in SIMATIC iMap. 

How to compare programs 
1. Select one or several instances. 
2. Select the Online/Offline comparison > Program only command from the shortcut menu.  
The result of the comparison is output to the "Online/offline comparison" tab of the task 
window. 
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Example: Comparing programs 
Comparing the program code and configuration data prior to online monitoring. Devices at 
which differences were found are identified by a STOP symbol. 

 
Figure 5-7 Online/offline comparison of programs 

How to compare interconnections: 
1. Select one or several instances. 
2. Select the Online/Offline comparison > Interconnection only command from the shortcut 

menu.  
The result of the comparison is output to the "Online/offline comparison" tab of the task 
window. 
The "Functions" tab of the diagnostics view may return additional error messages about 
failed interconnections. 
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Example: Comparing interconnections 
The diagram below shows that different interconnection partners require an interconnection 
download. 

 
Figure 5-8 Online/offline comparison of interconnections 

5.8 Displaying and setting online values in SIMATIC iMap 

Online values of PROFINET variables 
The online values of PROFINET variables are current values at the connectors of 
technological functions.  
In the Online view of SIMATIC iMap you can: 
● monitor selected online values at the connectors of technological functions, 
● set online values of individual inputs once in order to test a PROFINET component in the 

commissioning phase, for example, 
● monitor and set online values in the variable table (see section entitled "Online testing 

with the variable table). 
The procedure for displaying and setting online values in the plant view is described below. 
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Requirements 
SIMATIC iMap must be connected to the plant online ("Online connection" button pressed).  

How to display online values: 
1. Select the required connectors of the technological function(s) from the plant view. 
2. Select the Online > Display Online Values menu command or Display Online Values from 

the pop-up menu. 
Result: The online values of the connectors are displayed in the plant view. 
The online values are updated dynamically.  
 

 

CAUTION  
Network load on the Industrial Ethernet and in the devices of the plant. 
Additional communication functions for monitoring connectors are performed on the 
Industrial Ethernet.  
You should note, however, that the network load can be affected both by the number of 
connectors to be monitored and by the frequency with which the values change. 
Remedy: Individually select the connectors whose values you wish to monitor online. 

 
 Note 

The display of online values of the type array and struct is limited. No more than 16 elements 
can be displayed via tooltips. Larger arrays and structures must be displayed via the variable 
table. 

 

Validity of online values 
The validity of displayed online values is indicated by different colors. 

 
Color of the online value Significance: the value ... 
Black is valid 
Red is invalid (e.g. due to a fault or immediately after setting, if the 

online value has not yet been confirmed in the target system) 
Red with question mark has not yet been confirmed or the device is not (yet) accessible 
Red with exclamation mark cannot be monitored because there are no free resources on the 

device 
Gray is uncertain (the validity cannot be determined) 
Gray italic is a substitute value 



Commissioning and online operation  
5.8 Displaying and setting online values in SIMATIC iMap 

 Configuring Plants in SIMATIC iMap 
192 Configuration Manual, 01/2008, A5E00716614-02 

Example: Displaying online values 

 
Figure 5-9 Displaying online values 

To set an online value:  
1. Select the desired input of a technological function in the plant view. 
2. Select the Online > Display Online Value menu command. 

Result: The online value of the connector is displayed. 
3. Click on the value or select the Online > Set Online Values menu command. 

Result: Depending on the data type of the connector either  
– A selection box with the permitted values, e.g. True and False for the data type BOOL, 

or 
– an edit box for all other data types is displayed. 

4. Select the required value or enter it in the edit box and press Enter to confirm. 
Result: The entered value must be confirmed by the device in the plant. It can then change 
to black, red or gray (see above "Validity of the Online Values").  
If the device cannot be accessed online or if a fault has occurred, the set value is not 
confirmed. In this case, the last known value is displayed as red or as a red question mark. 
The value remains constant as long as this input is not interconnected or modified by the 
user program of the technological function. If the input is interconnected via SIMATIC iMap, 
the online value can be modified via the interconnection. 
 

 

 Note 
Online values of the data type Array and Struct cannot be set. You should use the variable 
table for these values. 

 
Tip: You can also interconnect inputs to constant values for testing purposes.  
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Example: Setting online values 
Setting a BOOL-type input. 

 
Figure 5-10 Setting online values 

See also 
Interconnecting Technological Functions  (Page 123) 
Interconnection with constant values (Page 129) 
Setting the transfer properties of interconnections (Page 137) 
Diagnostics information in the online view (Page 178) 
Overview of the online functions (Page 164) 
Creating a variable table  (Page 193) 

5.9 Online testing with the variable table 

5.9.1 Creating a variable table 

Structure of the variable table 
The variable table contains the variables of the connections to be tested online.  

Table 5-1 Structure of the variable table 

Column Meaning 
No. Line number 

 
 

Automatically displays whether the entry is deactivated, connected 
online or inaccessible. 

Device Here you can enter the device name or select it from a list. 
Function Here you can enter the function name or select it from a list. 
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Column Meaning 
Connection Here you can enter the connection name or select it from a list. 
Type The data type of the connection is displayed here. 
Format Here you can select the display format for the online value. 

<Automatic> means the default format, e.g. decimal for I1, I2, UI1, R4 
or True/False for BOOL. 

Online value Displays the online value when the variable is connected online. 
Control value Here you can enter control values for inputs. You can transfer these 

values to the plant at any time to set the relevant online values. 
Comment A comment is entered here. 

Select the Columns command from the pop-up menu to show or hide individual columns. 

How to insert entries 
1. Open the "Variable table" tab in the diagnostics window. 
2. Select the required connections or technological functions from the plant view and drag 

them into the variable table. 
Result: An entry is completed in the variable table for every inserted connection. For arrays 
and structures, you can expand and shrink the lines that make them up. 
Other options:  
● Enter data directly into the "Function" and "Connection" boxes or 
● Select the function and connection from the drop-down list. 
The other fields are filled in automatically. 

Rule 
The variable table can contain up to 50 entries. 
Invalid entries (e.g. unknown name for functions or connections) are displayed in red. 
Variables with invalid fields cannot be monitored. 
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Example: Variable table 
The following variable table contains the connections for the "Coordinator" function. 

 
 

Moving entries 
You can move selected entries within the variable table using drag-and-drop 

How to sort the entries  
You can sort the entries by clicking on the required column header. 

How to save the variable table  
The variable table is always saved together with the SIMATIC iMap project. If you wish to 
save a variable table within the file system, to test another project, for example, then you will 
have to export it. 

How to export the variable table  
1. Select the Options > Export Variable table menu command. 
2. In the "Export Variable table" dialog, select a directory from the "Search in" box. 
3. In the "File name" box, enter a file name or select a name from the list. 
4. Click on the "Save" button. 
Result: The current variable table is stored in the file system. The file name always has the 
extension .CBV 
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How to import a variable table  
By importing, you can copy a variable table from the file system into the currently opened 
SIMATIC iMap project. 

 

 Note 
The existing entries are overwritten when you import the variable table. We recommend that 
you use the Options > Export Variable table menu command to back up the current variable 
table, if necessary, before importing.  

 
Procedure: 
1. Select the Options > Import Variable table menu command. 
2. Select the required variable table from the "Import variable table" dialog. Look for a file 

name with the extension .CBV. 
3. Click "Open." 
Result: The entries in the imported variable table are copied to the variable table for the 
project. 

Default storage location for variable tables 
Use the Options > Customize menu command on the "Directories" tab to define a directory 
for storing variable tables. This directory will be suggested when you import and export 
variable tables. 
 

5.9.2 Variablen online beobachten und steuern 

Overview 
You can use the variable table to test the plant by: 
● monitoring selected variables in online mode, and 
● assigning control values to selected variables in the test phase. 
You can only monitor variables if their entries are activated in the variable table. You can 
exclude selected variables from monitoring by disabling their corresponding entries in the 
variables table. 
The variable table lets you monitor variables in online mode, regardless whether or not 
Online monitoring is enabled in the plant view or network view. You can monitor the selected 
or all active variables in the variable table. 
You can enter control values for selected input variables. You can then assign those control 
values to the variables for test purposes, and thus replace their current online values. 
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Disabling and enabling entries 
New entries are active. You must explicitly disable entries to exclude these from monitoring. 
To disable entries:  
1. Open the "Variable table" tab in the diagnostics window. 
2. Select the entries. Press the CTRL or Shift key at the same time to select several entries. 
3. Select the Deactivate command from the shortcut menu. 
Result: The selected entries are identified with a cross symbol. The associated variables can 
no longer be monitored.  
To be able to monitor those variables again, you must first enable the entries. To do this, 
select the Reactivate command from the shortcut menu. 
In the example below, entries no. 2 and 6 are disabled. 

 
Figure 5-11 Example: Deactivating entries of the variable table 

Requirement 
Your PG/PC must be connected to the plant via Ethernet in order to monitor variables and 
set online values. 

How to start monitoring using the variable table: 
1. Open the "Variable table" tab in the diagnostics window. 
2. Select: 

– the Online > Variable table > Monitor all variables command, or click the "Monitor 
variables online" icon to monitor all active variables, or 

– select the required entries, and then select the Monitor command from the shortcut 
menu to monitor only the selected variables. 

Result: All or the selected entries are identified by a "Monitor" icon (eye glasses) in the 
second column, and the current online variable values are indicated at the "Online value" 
column. The online values are visualized in the defined format. "<Automatic>" means the 
default output format, i.e. decimal for I1, I2, I4, UI1, UI2, UI4, R4 or True/False for BOOL. 
The system does not ouput the online values of deactivated entries. 
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Variables of unavailable devices are identified by a separate symbol (eye glasses with a 
cross).  
The validity of indicated online values is visualized in color, as the online values in the plant 
view (see "Diagnostics information in the online view"). 

Example - Online variable table 
The diagram shows: 
● Substitute values are displayed for the variables number 2 and 6. 
● All other variables are monitored. 

 
 

How to exit monitoring mode  
● Once again, select the Online > Variable table > Monitor all variables command again, or 

click the "Monitor variables online" icon again in order to stop monitoring of all variables. 
● Select the required entries from the variable table, and then select the Stop Monitoring 

command from the shortcut menu to stop monitoring of the selected variables. 

How to transfer control values  
At the input variables, you can enter control values for use as online test values. Online 
values can not be set at outputs. 
Procedure: 
1. Open the "Variable table" tab in the diagnostics window. 
2. Enter the control values in the fields of the "Control value" column. In doing so, note that 

the values in the display format are interpreted, e.g. if hexadecimal is set for a variable in 
the "format" field, then you must also enter the control value in hexadecimal. 

3. Select the variables in order to set their online values. 
4. Select the Monitor command from the pop-up menu to start monitoring those variables. 
5. Select the Transfer control value command from the shortcut menu, or click the "Transfer 

control value" button. 



 Commissioning and online operation 
 5.10 Online device analysis 

Configuring Plants in SIMATIC iMap 
Configuration Manual, 01/2008, A5E00716614-02 199 

Result: The control values are transferred to the plant and appear in the field of the "Online 
value" column.  
Online values are not set for deactivated entries and variables of unavailable devices. 

 

 Note 
If the controlled variables are interconnected... 
The control values will only be transferred to the plant if the interconnections are configured 
to support acyclic transfer. Variables with interconnections for cyclic transfer can not be 
controlled using the variable table. 

 
 Note 

If the same variable is selected more than once for the transfer of control values, the 
operation and the transfer of control values will be cancelled and an error message will be 
output. 

 

How to copy the online value of a variable: 
Select the Copy online value command from the shortcut menu to copy the online value of a 
variable.  
Result: The online value is copied to the clipboard. 

Tips 
You can always enter control values, regardless whether or not variable monitoring is 
enabled in the variable table. You can not enter any values if the entries are deactivated and 
invalid: 

5.10 Online device analysis 

Content of the online device analysis 
If SIMATIC iMap is connected to the devices of the plant via Industrial Ethernet, you can look 
up specific online information about the devices for testing and diagnostic purposes. The 
online device analysis returns the following information: 
● Performance parameters for the device (see "Performance parameters of PROFINET 

devices") 
● Configuration data for the device and the associated technological function (if present) 
● For PROFINET devices with proxy functionality only: the configuration data for the 

coupled PROFIBUS devices (devices and technological functions). 
● Diagnostic information, e.g. error statistics and timeouts 
The online device analysis can only be run for one PROFINET device. The online data for 
the PROFIBUS devices is recorded together with the data for the associated PROFINET 
device with proxy functionality. 
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Storing the online device analysis 
The information from the online device analysis is stored in HTML format in a separate 
folder. Using the Options > Customize menu command you can define a default path on the 
"Directories" tab. 

Requirement 
SIMATIC iMap must be connected to the target device via Industrial Ethernet.  

How to look up the online data for a device 
1. Highlight a device in the net view. 
2. Select the Online > Online device analysis... menu command. 
3. The IP address of the device is displayed in the "IP address" box in the "Online device 

analysis" dialog. If this is not the case, enter the IP address of the device to be analyzed. 
4. If necessary, click on the "Modify" button and change the path. 
5. Click on the "OK" button. 
Result: The current version of the online device data is stored in the folder in the form of 
several HTML files. 

 

 Note 
The information is updated for the specified IP address whenever you call the Online > 
Online device analysis... menu command.  
You can display stored versions of the online device analysis by opening the HTML files 
directly in an HTML browser. 

 

See also 
Parameters of limit values (Page 143) 
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5.11 Accessing information variables 

5.11.1 Create OPC symbol file 

OPC symbol file 
SIMATIC iMap supports the creation and analysis of an OPC symbol file for the current 
project using the client programs of SIMATIC NET PN OPC server. The OPC symbol file is 
created for the entire SIMATIC iMap project, and saved to a user-specific folder.  
Options: You can define the scope of the OPC symbol file you created, i.e. only the HMI 
variables, only the MES variables, or all variables of the project. When you create the 
PROFINET components in the manufacturer-specific engineering tool, the variables will be 
identified as HMI or MES variables. 

Requirement 
The SIMATIC iMap project is generated. If the project contains any objects at which the 
"generated" status is not set, you will not be able to create an OPC symbol file. 

Name length of the OPC information variables 
The name of an OPC information variable consists of the following elements: 
● Optionally one or more chart levels 
● Function name 
● I/O name 
● Structure component name (only with composite data types) 
● One separator each between the individual names 

 

  Note 
The name of an OPC information variable may contain a maximum of 255 characters. If 
this length is exceeded for one of the OPC information variables, the OPC symbol file 
cannot be created. 
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How to create the OPC symbol file for the project 
1. Select the menu command 

– Options > Create OPC symbol file > All in order to generate an OPC symbol file for all 
(HMI and MES) variables of the project. 

– Options > Create OPC symbol file > HMI only in order to generate an OPC symbol file 
for all HMI variables of the project. 

– Options > Create OPC symbol file > MES only in order to generate an OPC symbol 
file for all MES variables of the project. 

The "Create OPC symbol file" dialog opens. 
2. Optional: Enter a user-specific character string in the "Prefix" box. You need the prefix in 

order to identify OPC information variables uniquely in all projects. Any changes to the 
prefix are stored in the project. 

3. The current path of the OPC symbol file is indicated in the "Save As" field. Accept the 
settings, or click the "Modify" button to select a different path. You can select another 
folder, or enter a different file name. 

Result: The OPC symbol file with the extension .sti is saved to the selected folder. 
 

 Note 
Use the Options > Customize command to define a folder for the OPC symbol files. This 
folder will be suggested as default whenever you search for the storage location. 
Select the Project > Properties command, "Special" tab to define the OPC prefix.  

 
The created OPC symbol files can be implemented in the configuration data of SIMATIC 
NET PN OPC server. 

 

CAUTION  
Network load on Industrial Ethernet and at the devices of the plant. 
Monitoring of connections, including monitoring using OPC, requires the execution of 
additional communication functions on Industrial Ethernet.  
Note that network load may be influenced by the number of monitored connections, and by 
the rate of values changes. 
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5.11.2 OPC information variables in SIMATIC iMap 

Syntax 
At the OPC interface, process variables are identified by a unique name, namely the runtime 
name (OPC item ID.) The OPC item ID consists of: 
<protocol ID>:[<connection name>]<variable name> 
Significance of the elements in PROFINET: 
● The protocol ID specifies the protocol used to access the process variable. The protocol 

ID "PN" is implemented for the PROFINET protocol. 
● The connection name specifies the connection or device which can be reached using the 

variable: 
● The variable name is the symbolic name of the variable. 

Symbolic access to variables 
The browser (symbol file configuration of SIMATIC NET, for example) outputs the process 
variable symbols in the following hierarchical order: 
[<project_prefix>] [<Chart>] <function> <variable> 
Whereby: 

 
Element Description 
<project_prefix> user-specific ID used in all projects 
<chart> nested chart 

nested charts are optional, and may have multiple layers. 
<Funktion> Name of the technological function 
<variable> Name of the input or output 

Variable types for PROFINET 
In PROFINET, we distinguish between three types of variables: 
● Process variables 
● System variables 
● Device-specific information variables 

Process variables 
Process variables are assigned to the IO of technological functions. Syntax of the runtime 
name of a process variable: 
PN:[aaa.bbb.ccc.ddd|<devicename>|<funcname>]<variable> 
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Designation Description 
aaa.bbb.ccc.ddd • The IP address of PROFINET devices 

• At PROFIBUS devices the IP address of the master (proxy) 
<devicename> Name of the configured device in iMap 
<funcname> Name of the technological function in iMap 
<variable> Name of the input or output of the technological function 

Access security of process variables 
Process variables for inputs are assigned the read and write attribute. 
Process variables for outputs are read only. 

 

 Note 
If the variables are interconnected... 
You can only write variables if their interconnections are configured for cyclic transfer mode. 

 

Example – process variables 
Representation of process variables in the SIMATIC NET symbol file configuration 

 
Figure 5-12 Example – process variables 

System variables 
Those information variables are located in the browser's "&System" folder. They apply to the 
entire plant. 

 
Variable symbol Runtime name Meaning 
&localhost PN:[SYSTEM]&localhost() 

 
Name of the host computer 

&version PN:[SYSTEM]&version() Version of the PROFINET core 
server 
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Example - system variables 
Representation of system variables in the SIMATIC NET symbol file configuration 

 
Figure 5-13 Example - system variables 

Device-specific information variables 
Those information variables are located in the "&DeviceChart" folder, and are assigned to 
the various devices. 

 
Variable symbol Runtime name Meaning 
&statepath PN:[aaa.bbb.ccc.ddd|<devicename>]&statepath()  Status of the connection in string 

format  
&statepathval PN:[aaa.bbb.ccc.ddd|<devicename>]&statepathval() Status value of the connection 

&statepath() 
Returns the state of a communication connection to a partner device in string format. 
Return values: 
● DOWN - connection not up 
● UP - connection is up 
● RECOVERY - Connection is being recovered 
● ESTABLISH (reserved for future enhancements) 
Data types: 

 
OLE data type Visual Basic type 
VT_BSTR String 
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&statepathval() 
Returns the state of a communication connection to a partner station 
Return values: 
1 - Connection not up 
2 - Connection is up 
3 - Establishing connection 
4 (reserved for future upgrades) 
Data types: 

 
OLE data type Visual Basic type 
VT_UI1 Byte 

Example - device-specific information variables 
Representation of device-specific variables in the SIMATIC NET symbol file configuration 

 
Figure 5-14 Example – device-specific information variables 

See also 
Create OPC symbol file  (Page 201) 
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5.12 Plants with SIMATIC devices 

5.12.1 Special features of systems containing SIMATIC devices 

SIMATIC devices in SIMATIC iMap projects  
To observe when using SIMATIC devices as PROFINET devices in a project: 
● Plant commissioning demands specific software requirements and settings in STEP 7. 
● STEP 7 provides a number of special options for editing PROFINET components of 

SIMATIC devices. 
● The SIMATIC iMap online view provides device-specific online functions and diagnostics 

functions. 
● Allowances must be made for specific features when downloading programs to SIMATIC 

device. 
● The OPC server must be configured in order to monitor variables via OPC. 

Plant commissioning requirements  
● STEP 7 is required on your PG/PC in order to: 

– generate the project 
– download device-specific data (programs) to the devices 
– edit the PROFINET components of the SIMATIC iMap project in STEP 7 
– to compare the online and offline data of the programs 

● The associated optional packages for configuring and programming specific to the 
devices used must be installed. 

● SIMATIC NET Softnet IE PG is required to allow OPC access to process variables. 
● The devices of the plant must have been assembled, wired, networked, and started up 

correctly. All the necessary addresses, such as the IP address, subnet mask, router 
address and PROFIBUS address, must have been assigned using the device-specific 
resources, e.g. using STEP 7 via MPI. You will find the necessary information in the 
associated product documentation. 

● To access PLCs in SIMATIC iMap, configure a PG/PC interface, and then assign your 
engineering system to the configured PG/PC. In this way, you can transfer default 
settings to the installed interfaces of your created system during the configuration 
process. (In this situation, interfaces are module parameter settings on the PG/PC). The 
steps are as follows: 
– Set the PG/PC interface 
– Assigning the PG/PC - only for particular device types such as drives 
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Data storage - the STEP 7 shadow project 
When you generate a SIMATIC iMap project with PROFINET components of SIMATIC 
devices for the first time, a common STEP 7 project is formed from all the component 
projects (control units) in the shadow project. The STEP 7 shadow project is located in the 
SIMATIC iMap project directory under Step7\Shadow. It contains a station for each 
component with programmable functionality in the SIMATIC iMap project. PROFIBUS 
devices with fixed functionality are assigned to the station of the DP master system 
concerned. 
The PROFINET devices without proxy functionality at accelerated regeneration are excepted 
(see below). 
The following figure shows the different ways to use the STEP 7 projects in SIMATIC iMap. 
(Information on data storage of the singleton projects can be found under "Properties of 
singleton components"). 

 
Figure 5-15 Data storage with STEP 7 projects 

All changes to PROFINET components, e.g. IP addresses or PROFIBUS addresses, are 
transferred to the STEP 7 shadow project whenever the SIMATIC iMap project is 
regenerated.  



 Commissioning and online operation 
 5.12 Plants with SIMATIC devices 

Configuring Plants in SIMATIC iMap 
Configuration Manual, 01/2008, A5E00716614-02 209 

The shadow project is automatically opened for editing in SIMATIC iMap whenever the Edit 
> Special > SIMATIC Manager menu command is called for a technological function or 
device.  

 

CAUTION  
The shadow project may not be modified directly under STEP 7! 
Changes to the shadow project may lead to inconsistent data in the SIMATIC iMap project, 
preventing any further program downloads. 
Possible remedies: 
• Regenerating a project 
• Edit > Re-edit component menu command from the modified shadow project to create a 

new PROFINET component 
 

CAUTION  
Changes that you make to the shadow project in STEP 7 are ignored when you generate 
with SIMATIC iMap, and may therefore be overwritten.  

 

Generating the project 
The Project > Generate > Control unit > Changes only menu command only generates the 
changes. If this is not possible because the S7 program or the hardware or network 
configuration contains incorrect or inconsistent data, for example, then the STEP 7 shadow 
project must be fully regenerated.  
When you select the Project > Generate > Control unit > All menu command a new STEP7 
project is created, and all the stations of the associated component projects from the library 
are added to the library once more.  

 

CAUTION  
Any changes you have made to the shadow project using STEP 7 will be overwritten by the 
newly generated shadow project. The system generates a backup copy of the old shadow 
project as required to let you trace any changes in the new shadow project. 
Tip: Select Edit > Edit component to make any relevant changes at the component type, 
rather than at the shadow project. 

 
The new shadow project is always called "Shadow". An extension is appended to the name 
of the copy of the old shadow project. 

Accelerated regeneration for PROFINET devices without proxy functionality 
When this option is active in the properties of the project, the control units of the PROFINET 
devices without proxy functionality are not copied into the shadow project when the project is 
regenerated. 
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Tip: Check consistency of the generated project 
Select Edit > Check consistency > Generated project to perform a consistency check in 
order to locate any differences between the blocks of the station in the shadow project and 
the blocks of the corresponding component project.  

 

 Note 
The following devices are not taken into consideration in the consistency check: 
• Any local DP slaves 
• PROFINET devices without proxy functionality if the "Accelerated generation..." option is 

active. 
 

Simultaneous actions with STEP 7 access  
 

 Note 
Simultaneous actions with STEP 7 access to a PG/PC are not supported. Actions in 
SIMATIC iMap with active STEP 7 application, for example: 
• Generating the Project 
• Program download 
Always make sure only one STEP 7 application is active on the PG/PC at any given time. 

 

See also 
Set the PG/PC interface (Page 215) 
Online operation of SIMATIC devices (Page 211) 
Processing instances with STEP 7 (Page 212) 
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5.12.2 Online operation of SIMATIC devices 

Special features of SIMATIC devices  
The following online functions are provided for SIMATIC devices: 
● Online/offline comparison of STEP 7 data 
● Device-specific diagnostics with STEP 7 

Online-offline comparison of the Programs 
The Online-offline comparison of the program data for SIMATIC device compares the blocks 
of the associated STEP 7 shadow project with the online blocks. The result of the 
comparison is displayed is displayed on the "Info" tab in the diagnostic window.  

 

 Note 
In the online / offline comparison of the programs, any existing local DP slaves are not taken 
into consideration.  

 

Device-specific diagnostics 
You can call the device-specific diagnostics as follows:  
● If there is a diagnostic message for a device, you can click on the "Diagnostics" button in 

the right-hand part of the diagnostic window to call up device-specific diagnostics. 
● You can use the Edit > Special > menu command to call up the available device-specific 

diagnostic functions, e.g. "Module state" or "Diagnose hardware", in STEP 7. 

Program download 
 

 

NOTICE  
Program downloads can only be carried out when the devices are in the STOP operating 
state. 

 
The devices must be in the STOP operating state while the program is downloaded. If this is 
not the case, the devices attempt to switch to STOP when one of the following menu 
commands is called: 
● Download all Instances > All / > Program only 
● Download selected instances > All / > Program only 
Before the program is downloaded, you are asked whether the device should be switched to 
STOP. You may also have to press the operating mode switch, and possibly enter a 
password, depending on the type of device, and the currently set level of protection. 
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Once the program has been downloaded to a device, you are asked whether you wish to 
switch the device to RUN. If you click on "Yes" to confirm, this occurs automatically. If you 
click on the "No" button, the device remains set to STOP, and can subsequently be switched 
to RUN.  
Tip: Permanently storing the downloaded data 
With some devices in SIMATIC iMap, once you have downloaded the program you must call 
the Special > Copy RAM to ROM menu command in order to transfer the data to the ROM 
area of a device. This means that the data is retained even after the power is switched off. 

PROFIBUS device inputs 
When a PROFINET device acting as a PROFIBUS master is switched to the STOP 
operating state, the inputs of the technological functions of the associated PROFIBUS 
devices are set to zero (safe state).  

See also 
Generating the Project (Page 86) 

5.12.3 Processing instances with STEP 7 

Introduction 
If you have created a PROFINET component using STEP 7, you can call certain STEP 7 
applications from SIMATIC iMap, e.g. SIMATIC Manager or HW Config, in order to modify 
the S7 program or parameter settings for a module. In doing so you edit the associated 
STEP 7 shadow project.  

 

CAUTION  
When you edit the STEP 7 shadow project, you must make sure that no inconsistencies 
occur in the configuration data, since this can lead to inconsistencies in the SIMATIC iMap 
project and to communication faults in the system. 

 
In SIMATIC iMap you can edit the instances of PROFINET components using STEP 7 in the 
following ways: 
● Modify a function in the SIMATIC iMap project. 
● Modify a device in the SIMATIC iMap project. 
The available editing functions are device-specific, i.e. different menu commands can be 
called for each type of device. The following descriptions contain the generally accessible 
editing functions.  
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Special editing functions for SIMATIC devices 

Table 5-2 Editing functions 

Edit > Special > menu 
command 

Meaning 

SIMATIC Manager Opens the shadow project in SIMATIC Manager. 
Monitor variable Opens variable table VAT1 for the station in the shadow project. 

You can enter the variables of the technological function (from the 
interface DB) to be monitored in the variable table, for example. If a 
variable table called VAT1 already existed when you created the 
PROFINET component, it is opened at the first call, otherwise the 
VAT1 table in the shadow project is originally empty.  

Program Opens the program folder for the associated module in SIMATIC 
Manager. You can open the blocks, sources and symbol table for 
editing. 

Compare blocks Runs an online-offline comparison of the program blocks, i.e. 
compares the blocks in the target system (online) with the blocks in 
the SIMATIC iMap shadow project (offline). 

 

Table 5-3 Editing devices 

Edit > Special menu command Meaning 
SIMATIC Manager Opens the shadow project in SIMATIC Manager. 
Hardware configuration Opens the station's hardware configuration (offline, on the PG/PC). 
Network configuration Opens the network configuration (Netpro) for the station 
Module state Displays the current state of the module. The "Module State" tab 

opens in the online view. 
Diagnose hardware Opens the hardware setup for the station that can be accessed 

online in diagnostic mode. 
Clear / Reset Clears / Resets the device. 
Operating state  Displays the current operating state of the module. You can then 

modify the module's operating state in the "Operating state" dialog. 
Assigning the PG/PC Opens the "Assign PG/PC" DIALOG BOX 
Copy RAM to ROM Copies the content of the RAM memory of the current module to the 

ROM area (only for modules that support this functionality). 
Download user program to 
memory card 

Downloads the generated user program to the CPU's memory card 
(only for modules that support a memory card).  

Set Time of Day Allows you to set the time on the module. 
Assigning device names Only for PROFINET IO controllers: Offers the possibility of 

assigning PROFINET IO devices the device names that have been 
configured in SIMATIC iMap. With the subsequent program 
download from SIMATIC iMap to the PROFINET IO controller, the 
PROFINET IO devices are assigned the IP addresses by means of 
these device names. 

Compare blocks Runs an online-offline comparison of the program blocks, i.e. 
compares the blocks in the target system (online) with the blocks in 
the SIMATIC iMap shadow project (offline). 
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Requirements 
The following software must be installed on your computer in order to edit instances of 
PROFINET components using STEP 7: 
● STEP 7 basic package with the necessary optional packages 
● SIMATIC iMap STEP 7 Add-on 
The project must have been saved and generated in SIMATIC iMap (Project > Generate > 
menu command). 

How to edit a function or device 
1. Select the function or device in the SIMATIC iMap project. 
2. Select Edit > Special >from the pop-up menu using one of the available commands. 
3. Save any changes and close STEP 7. 
4. Select the device from the net view. 
5. Select the menu command Download selected instances > Program only menu command 

to download the program to the target system. 
 

  Note 
If you modify the interface DB and download it to the device from STEP 7, you must 
make sure that all associated PROFINET blocks with the attribute CBA_... are 
downloaded as well, otherwise run-time errors may occur in the program. 

CAUTION  
 

The shadow project is overwritten when you regenerate the SIMATIC iMap project using 
the Project > Generate > Control unit > All menu command. The system will optionally 
generate backup copy of the old shadow project in the same folder. You can use this 
copy to update any changes that you made in the shadow project using special editing 
functions.  

Tips 
Re-editing PROFINET components 
To ensure that you do not lose changes you have made to the shadow project, we 
recommend that you create a copy of the component project using the Edit > Re-edit 
component menu command, and then accept the changes in this copy and create a new 
version of the PROFINET component. 
Program download from STEP 7 
After a special editing function the program download can alternatively be carried out from 
STEP 7. This is particularly recommended if only blocks have been altered, because the 
device does not have to be switched to STOP for this. 
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5.12.4 Set the PG/PC interface 

Application 
You must establish a connection from STEP 7 to the Ethernet in order to download programs 
or use certain online functions on the SIMATIC devices in the plant. In STEP 7, you must set 
up the PG-PC interface as follows: 
● To TCP/IP if all remote devices in the plant can be accessed via Ethernet or 
● To "PC internal" (local computer) if a WinLC PN is installed there. 
In this way you can access all the SIMATIC devices, whether they are on the Ethernet or 
PROFIBUS or are on a local PG/PC, e.g. a WinLC PN.  

Set the PG/PC Interface to TCP/IP 
Proceed as follows: 
1. Select Start > SIMATIC > STEP 7 > Set PG-PC interface. 
2. On the "Access path" tab in the "Set PG-PC interface" dialog, select 

S7ONLINE (STEP 7) from the "Application access point" box. 
3. In the "Interface parameter settings used" box, select "TCP/IP..." with the associated 

network adapter. 
4. Click on "OK" to confirm your settings. 
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Figure 5-16 Set the PG/PC Interface to TCP/IP 

Setting the PG/PC interface to local computer 
If a WinLC PN representing part of the SIMATIC iMap project is installed on the local 
computer, this WinLC PN takes over communication with the PROFINET communication 
partners. The procedure is as follows: 
1. Select Start > SIMATIC > STEP 7 > Set PG-PC interface. 
2. On the "Access path" tab in the "Set PG-PC interface" dialog, select 

S7ONLINE (STEP 7) from the "Application access point" box. 
3. Select "PC internal (local) from the "Interface parameters settings used" box. 
4. Click on "OK" to confirm your settings. 
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5.12.5 Assigning the PG/PC 

Note 
The PG/PC assignment in SIMATIC iMap is automatically performed during the initial 
generation and anytime the project is newly generated. The PG / PC assignment is 
necessary so as to be able to carry out the program download to the intelligent PROFIBUS 
devices. 
In special cases it may not be possible to automatically assign the PG/PC, for example: 
● When several network cards are installed in the PG/PC or 
● When the TCP/IP protocol is not set at the PG/PC interface S7ONLINE (STEP 7) 
● In the plant there are special types of device e.g. SIMOTION devices, Micromaster drives 

or starter components as intelligent DP slaves. 
In such situations, an error message will be output to the task window during generation, and 
you need to assign the PG/PC as described in the section below. 
The PG/PC assignment is not necessary when you are using a local WinLC PN which 
contains a network card in its configuration. 

How to assign the PG/PC interface to the SIMATIC iMap project 
 
Task Procedure 
1. Open the SIMATIC iMap project. Select any device from the SIMATIC iMap net view, then select Special > 

Assign PG/PC from the pop-up menu.  
If this menu command is not available, select Special > SIMATIC Manager from the pop-up menu, add a PG / 
PC object in the shadow project and open its properties.  

2. In the "Properties - PG / PC" dialog box, "Interfaces" tab, press "New" and then select "Industrial Ethernet" 
from the selection list. 

 
 
Click on the "OK" button to confirm your entry. 
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Task Procedure 
3. In the "Properties - Ethernet Interface" dialog, enter the IP address and the subnet mask of the local computer 

and select the Ethernet subnet. 

 
 

4. Click on the "OK" button to confirm your entry. Result: The newly configured interface is displayed in the 
"Interfaces" tab. 

 
 



 Commissioning and online operation 
 5.12 Plants with SIMATIC devices 

Configuring Plants in SIMATIC iMap 
Configuration Manual, 01/2008, A5E00716614-02 219 

Task Procedure 
5. In the "Assignment" tab, mark the Ethernet interface you have just configured in the "Configured interfaces:" 

selection field below "Not assigned". In the "Interface parameter settings on the PG/PC:" select  
TCP/IP -> <network card used> 
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Task Procedure 
6. Confirm by clicking on the "Assign" button. 

Result: The assigned interface is displayed in the "Assigned" field. 
Activate the option "S7ONLINE access". 

 
 
The assignment becomes effective by clicking on "OK". 

 
 

NOTICE  
After a regeneration of the controller unit (Project > Generate > Controller unit > All new) 
the PG / PC object is deleted from the shadow project and you must reconfigure the PG / 
PC assignment. 
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5.12.6 Set up the OPC server 

OPC symbol file 
You create the OPC symbol file for the plant in SIMATIC iMap under Extras > Create OPC 
symbol file >. The OPC symbol file <projectname>.sti is created and stored in a directory of 
your choice: 

Setting up the OPC server 
How to set up the OPC server 
1. Run the following command: Start > Simatic > SIMATIC NET > Set PC station. The 

configuration console opens. This is used to make your new OPC symbol file known to a 
SIMATIC NET OPC server. 

2. In the left window open the folder "Applications > OPC settings". 
3. Open the OPC protocol selection dialog box and select the following protocols: 

– PROFINET – always 
– S7 – for non-connectable connectors of programmable PROFIBUS devices (intelligent 

DP slaves) only. 
4. Click on the "Accept" button. 

Open the "Symbols" folder. Select the active symbol file (<projectname>.sti, see above). 
Use the "Edit list" icon in order to find the file. 

5. Click on the "Extended symbols" button and select the module for the TCP/IP protocol on 
your PG/PC from the "PROFINET" box. 

6. Click on the "Accept" button. 
The OPC server is now set up on your PG/PC, and you can visualize process data with 
reference to the OPC symbol data using an OPC client such as the OPC Scout. 
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6.1 Overview - special PROFINET components 

PROFINET component types 
The current version of SIMATIC iMap supports the following PROFINET component types: 
● Standard PROFINET components - as described above 
● Multifunction components 

The technological interface of a multi-function component is divided over several part 
functions.  

● Singleton components 
In SIMATIC iMap, the device-specific configuration and programming data for these 
PROFINET components is held and edited in the STEP 7 basic project, rather than in the 
common shadow project. This component type allows you to incorporate hardware 
configurations with SIMATIC devices that were previously not supported into PROFINET 
communication.  

● PROFINET components with HMI unit – this component type allows the integration of 
special HMIs in PROFINET communication. WinCCFlexible V1.0 or higher is required to 
create those PROFINET components and edit these in SIMATIC iMap.  

The special features of working with these special component types are described below. 

Special PROFInet component types 6
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6.2 Multifunction components 

6.2.1 Properties of the multi-function components 

Multi-function component 
The technological interface of a multi-function component is divided in several part functions. 
The part functions form the technological function of the component type. 

Advantages 
The division of large technological interfaces with several hundred connectors over several 
subfunctions offers the following advantages: 
● Clearer display in SIMATIC iMap 
● Better structuring possibilities of the plant in SIMATIC iMap on account of the flexible 

arrangement and, if necessary, division of the part functions over several charts. 

Structure of a multi-function component 
Compared to PROFINET components with just one function, the PROFINET interface of a 
multi-function component is divided into several part functions. Each instance includes all 
part functions that are shown and handled individually in SIMATIC iMap.  
The user program including the hardware configuration data however continues to form one 
unit. Therefore, the device-specific actions, like for example generating, as well as all online 
and diagnostics commands always refer to the complete instance. 
Multifunction components must be programmable, i.e. thes can only be created based on the 
data of controllers or intelligent DP slaves. 
Multi-function components can be either standard or Singleton components.  

Number of functions per device 
The maximum permitted number of subfunctions of a multi-function component depends on 
the component type:  
● With standard components with programmable functionality, up to 7 subfunctions are 

permitted. 
● With standard components with fixed functionality, a maximum of 1 function is permitted. 
● With singleton components, the maximum permitted number of subfunctions is variable, 

depending on the device type. 
In all cases, the entire PROFINET interface may not exceed the performance parameters of 
the device with reference to the number of connectors and the maximum data length. 



 Special PROFInet component types 
 6.2 Multifunction components 

Configuring Plants in SIMATIC iMap 
Configuration Manual, 01/2008, A5E00716614-02 225 

The maximum permitted number of subfunctions is a technical datum of the PROFINET 
CBA-compliant devices and is displayed in SIMATIC iMap for the following actions: 
● Check utilization, device parameter "Number of functions on master and slaves" 
● Online device analysis, parameter "Number of operable functions" 

 

  Note 
Multi-function components with proxy functionality 
For PROFINET devices with proxy functionality, this incorporates the functions or 
subfunctions of the coupled PROFIBUS devices.  
Example: 
The multifunction components of a CPU 319-3 PN/DP with proxy functionality has 4 
functions. A maximum of 30 subfunctions are allowed for this device. A maximum of 26 
PROFIBUS devices can therefore each be coupled to a function. The number of 
PROFIBUS devices which can be coupled to it is reduced accordingly if one or more of 
these instances also contain several subfunctions. 

6.2.2 Using multi-function components in the SIMATIC iMap project 
This chapter describes the special features in applications with multifunction components in 
SIMATIC iMap.  

Selecting and editing function units 
The actions in SIMATIC iMap outlined below always refer to all function units of an instance:  
● Actions at objects, for example: Cut, Delete, Copy, Paste 
● Generating the Project 
● Download 
● Online and diagnostics functions: 

– Online/Offline comparison 
– Consistency check 
– Utilization test 

● Creating OPC symbol files 

Exceptions: 
● Moving objects between charts 
● Removing objects from the chart hierarchy 
● Assigning objects to a chart 
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Edit and Delete 
Select all function units of an instance which are already assigned to a chart in order to 
delete or cut the instance.  

Assigning objects to a chart 
Function units of the instances of a multifunction component can be moved separately 
between different charts in the chart or plant views using the drag-and-drop function, or by 
selecting the Edit > Move to new chart command. On the other hand, you may also delete 
specific function units from the chart hierarchy by selecting Edit > Remove from chart 
hierarchy.  

Function units outside the chart hierarchy 
Function units not assigned to a chart are only visualized in the project view (see the chapter 
"Project view".) They can not be interconnected 

Function units of a PROFINET component 
Options of viewing the function units of a PROFINET component: 
● In the library: Open the preview window, select the "Function"  tab, and the select the 

PROFINET component from the library. 
The preview window offers all function units in a selection list and visualizes the selected 
fucntion units.  

● In the project view: If the project already contians an instance, all function units will be 
listed in the "Instances, functions" column. Function units assigned to a chart are 
identified by a check mark, and those without assignment by a vertical dash. 

● In the chart view: Select a function unit, then select Go to > Chart view: All function 
units... 
Result: All function units of the instance will be marked in the chart view. This action may 
change the zoom ratio accordingly. Unused function units are not indictaed in the chart 
view, but rather in the project view.  
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Example - Representation of a multifunction component in SIMATIC iMap 
The next example shows a multifunction component and its instance in the chart and project 
views of SIMATIC iMap. 

 
 

Replacing function units of an instance 
Function units of the instances multifunctions components are only replaced if the new 
PROFINET component represents the product of a revised old component. If so, the 
interconnections will be included in the transfer to the relevant function units of the new 
instance (if the connection names and data types are identical.) If not (i.e. no revision), the 
old fucntion units of the instance will be replaced with the new ones.  
New function units are not yet assigned to a chart. Assign the new replacement function 
units to a chart and interconnect these as requried.  
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6.3 Singleton components 

6.3.1 Properties of singleton components 

What are singleton components? 
Singleton components are PROFINET components for which the device-specific data is 
stored and handled separately. The device-specific configuration information and program 
data is located in the STEP 7 basic project for the PROFINET component, rather than in the 
common shadow project. 

Advantages in use 
The use of singleton components has the following advantages: 
● Because the device-specific configuration and program data are stored separately, 

Singleton components in SIMATIC iMap are excluded from certain time-consuming 
functions such as generation or program downloads, and thus do not affect the 
processing time of the overall project. 

● Singleton components may have default names and addresses. Thus, these properties 
do not have to be configured for instances of Singleton components in SIMATIC iMap. 

● Special hardware configurations with SIMATIC device that were not supported in 
PROFINET components in the past can now be incorporated into PROFINET 
communication as Singleton components. 

● Singleton multi-function components may contain more than 7 subfunctions. The 
maximum number of subfunctions depends on the device type. 
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Separate storage of the singleton components 
Singleton components do not have a STEP 7 component project but rather only the STEP 7 
basic project (singleton project). For this reason, the following actions in SIMATIC iMap are 
performed directly in the Singleton project and not through the shadow project: Generation, 
program downloads and revision of the singleton component. This concept is illustrated in 
the figure below. 

 
Figure 6-1 Actions in the basic project of the singleton component 

Rule 
Singleton components can only be created for PROFINET devices without proxy 
functionality. Thus, singleton components have only one bus connection on the Industrial 
Ethernet. 
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Special hardware configurations 
The Singleton concept allows special hardware configurations with SIMATIC devices to be 
incorporated into the PROFINET communication, such as: 
● Integration of process diagnostics 
● Configurations with function modules (FM) 
● Configurations with several central modules (multi-computing) 
● Integration of connections to other stations via ISO protocol 

6.3.2 Integrating Singleton components in the SIMATIC iMap project 

SIMATIC iMap project  
You can insert singleton components into a SIMATIC iMap project one or more times 
depending on the project settings: 
How to set the project properties 
Select the Project > Properties menu command and, in the "Use of singletons" box on the 
"Special" tab, select the 
● Once option if you only want one instance per project, or 
● Multiple option if several instances per project are to be permitted. 

Editing in SIMATIC iMap 
In SIMATIC iMap, you can carry out all the same actions on singleton components as on 
standard components, with the following exceptions: 
● Changing the properties of the instance when more than one instance is permitted in the 

SIMATIC iMap project. If only one instance is permitted in the project, you cannot change 
the name and address(es) of the instance. 

● Generating and downloading the program 
Instances of the singleton components are neither included when the SIMATIC iMap is 
generated (Project > Generate > menu command), nor in the program download (Online 
> Download... > All/Programs only menu command.)  

● Editing in the vendor-specific programming and configuration tool (see below). 
 

  Note 
If an action is not supported for singleton components, the corresponding menu 
commands are not available (grayed out). Otherwise a message will appear in the 
information window or in a separate message window. 
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Modifying properties 
The following properties of the instance cannot be modified for singleton components that 
may only have one instance in a SIMATIC iMap project: 
● Name of the technological function 
● Name of the device 
● IP address and subnet mask 
For the instance, the properties are taken from the basic project of the singleton component. 
To modify these properties, you will have to recreate the singleton component and insert it 
into the SIMATIC iMap project, e.g. by replacing the old instance. 

Editing in the vendor-specific tool 
Use the Edit > Special > menu command to directly call up the vendor-specific configuration 
and programming tool, e.g.SIMATIC Manager, from SIMATIC iMap. Some functions, such as 
"Diagnose hardware", are not available using the Edit > Special > command. These have to 
be called up from inside the tool. 

Notes on editing with STEP 7 
The following actions must be carried out directly in the STEP 7 basic project for the 
singleton component: 
● Open the STEP 7 basic project - using the File > Open menu command in SIMATIC 

Manager. 
● Modify the hardware configuration - in HW Config 
● Modify the S7 program - in the relevant block editor. 
● Compile configuration information - in HW Config using the Station > Save and Compile 

menu command. 
● Download the program - in SIMATIC Manager using the  Target system > Download 

station to PG menu command. 
● Look up device-specific diagnostic information - in SIMATIC Manager using the Target 

system > Diagnostics/Settings > menu command. 
 

  Note 
Notes on the program download 
When you create the singleton component from the basic project in STEP 7, the system 
data blocks (SDB) for PROFINET communication are created as well. 
Once you have created the singleton components, you must download the blocks from 
the program folder to the device. In SIMATIC Manager, this is done using the Target 
system > Download station to PG menu command. 
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6.4 PROFINET components with HMI units 
This section provides an overview of the use of PROFINET components with HMI units in 
SIMATIC iMap. A detailed description can be found in the user documentation for WinCC 
Flexible V1.0.  

Requirement 
You require a PG/PC with at least 1 GB RAM to create PROFINET components with HMI 
unit and to configure these in SIMATIC iMap. 
WinCC Flexible is needed in order to create, configure, generate and download PROFINET 
components with HMI units.  

Creation  
PROFINET components with HMI units are created using the WinCC Flexible Component 
Merger function. 

Use in SIMATIC iMap 
PROFINET components with HMI units are used just like standard components in SIMATIC 
iMap. They first have to be imported into a SIMATIC iMap library, and can then be inserted 
into projects.  
The HMI units of a PROFINET component are handled in a special way in SIMATIC iMap: 
● Generate - using the Project > Generate > HMI units menu command. 
● Edit - using the Edit > Special menu command. 

Representation of HMI units  
The properties of the PROFINET component in the library will show whether a PROFINET 
component has HMI units. The HMI parts are listed on the tab of the "Properties" dialog and 
on the "HMI" tab in the preview window. 
The HMI units of the instances are displayed in the project tree and in the project view (see 
example in the diagram below). 
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Figure 6-2 Representation of the HMI units in the project view and project tree 

How to generate the HMI units of the project 
To be able to download the configuration data for the HMI units to the target system, this 
data must first be generated.  
● Changes to the HMI units are generated using the Generate > HMI units > Changes only 

menu command. 
● The HMI units of all instances are generated using the Generate > HMI units > All menu 

command. 
The generated data is stored in a separate shadow project. 
You can then download the configured HMI units. 

 

 Note 
The link to WinCC Flexible is needed in order to generate and download the configuration 
data for the HMI units in SIMATIC iMap. 
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6.5 Off-the-shelf PROFINET components 

6.5.1 IE/PB link 

IE/PB Link, network transition Industrial Ethernet - PROFIBUS DP 

Off-the-shelf PROFINET components 
SIMATIC iMap is supplied with off-the-shelf PROFINET components for the IE/PB Link for 
different transmission speeds. 
The off-the-shelf PROFINET components are to be found in the \Step7\S7CbaCompProj 
folder. You will have to import them into a SIMATIC iMap library (Library > Import 
Component menu command) before they can be used in SIMATIC iMap. 

Application 
The IE/PB Link is a network transition that interconnects the two types of network: Industrial 
Ethernet (factory level) and PROFIBUS (cell level). 

Function in the PROFINET environment 
IE/PB Link is a PROFINET device, and is represented accordingly in the SIMATIC iMap net 
view. 
The IE/PB Link acts as a DP master on the PROFIBUS interface. The IE/PB Link provides 
the connection to coupled PROFIBUS devices for the PROFINET devices connected to the 
Ethernet. For the coupled PROFIBUS devices, the IE/PB-Link is a DP master with proxy 
functionality. 

Representation in SIMATIC iMap 
The PROFINET component of the IE/PB Link has fixed functionality, but has no 
technological function. The PROFINET component of the IE/PB link is supplied ready for use 
in the SIMATIC iMap system library. It is not necessary to create a component in STEP 7 for 
the IE/PB Link. 
● Net view in SIMATIC iMap 

In the net view, the IE/PB Link is represented as a component that links the Ethernet and 
PROFIBUS. The IE/PB Link can be selected and configured from this view. 

● Plant view in SIMATIC iMap 
IE/PB Link is neither visible in the plant view, nor can it be instantiated. 
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Network connectors 
The PROFINET components of the IE/PB link have two network connectors: 
● a connector to PROFIBUS as the DP master and 
● a connector to the Industrial Ethernet 

 
Figure 6-3 Network connectors of the IE/PB link 

Special Features  
● Range of functions as a DP master 

The IE/PB Link supports operation with DP standard slaves (DP V0). Acyclical services 
(reading and writing records) are not supported. 

● Substitute values for DP slaves under PROFINET 
When it acts as a DP master under PROFINET, the IE/PB Link is configured to apply 
substitute values. 
If the IE/PB Link detects that a connected (interconnected in PROFINET) DP slave has 
failed, it sets the inputs interconnected with this DP slave to the substitute value "0". 
Lifestate monitoring allows this PROFINET component to detect if the input values 
supplied are substitute values. 

Example 

Table 6-1 PROFINET components of IE/PB Link, representation in SIMATIC iMap  

Technological function PROFINET device 
None  

 
 

 



Special PROFInet component types  
6.5 Off-the-shelf PROFINET components 

 Configuring Plants in SIMATIC iMap 
236 Configuration Manual, 01/2008, A5E00716614-02 



 

Configuring Plants in SIMATIC iMap 
Configuration Manual, 01/2008, A5E00716614-02 237 

Appendix A
A.1 Menu commands 

Overview 
Menu commands can be used to create and edit selected objects (e.g.charts, functions and 
libraries). They are accessed via the menu bar, in the shortcut menu or as an icon on the 
toolbar.  
The menus on the menu bar of the SIMATIC iMap user interface are explained briefly below. 
This description may differ slightly from the actual application, but any differences will be 
updated in the next version. 

Project menu 
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Menu command Description 
New Creates a new project. Before it is opened, the currently open project is 

closed. 
Open... Opens an existing project. Before a new project is opened, the currently open 

project is automatically closed. 
Save Saves the current project. 
Save as... Saves the current project under a new name. 
Archive > Open project Archives the currently opened project. 
Archive > Stored projects Archives a stored project. 
Retrieve... Retrieves an archived project. 
Import... Imports a project desription to the current project. 
Export... Generates a project descriptoin for the current project. 
Generate > Control unit > Changes only Saves the current project, and generates the delta data of the controller units, 

i.e. the delat data will be synchronized with the shadow project.  
This is required in order to use the online functionality (download and 
diagnostics). 

Generate > Control unit > All Saves the current project, and generates the controller units, i.e. it generates 
the shadow project based on the PROFINET components of the library. 

Generate > HMI units > Changes only Saves the current project and generates the changes to the HMI units.  
Generate > HMI components > All new" Saves the current project and generates new HMI units 
Page setup... Defines the page margins and other layout options. 
Headers and footers... Displays the settings for the header and footer of a printout. 
Print > Active view... Prints the current view 
Print > All views... Prints the network view and all charts in the plant view. 
Documentation... Creates the documentation for the current project. 
Properties... Opens a dialog box that shows the project properties. There, you can define 

the security level and a password for the project, including the general transfer 
properties of the interconnections with remote partners. 

Recent projects  Lists the recently opened projects.  
Exit Exits SIMATIC iMap. If the edited project has not yet been saved, you are 

prompted to save it. 
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Edit menu 

 
 
 
Menu command Description 
Cut Deletes selected objects from the project and copies these to the clipboard.  
Copy Copies the highlighted objects to the clipboard. 
Paste Inserts the clipboard contents. 
Deleting Deletes selected objects from the project. 
Select all Highlights all the objects in the current window.  
Undo selection Deselects the selected objects.  
Select in all Windows Transfers the current selection to all other windows. 
Open selected chart Opens the selected chart. 
Open parent chart Opens the chart one level up. 
Go to > <view/window/tree> Lets you navigate between windows and views. 
Go to > Chart view All function units Marks all function units of the instance in the chart view. 
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Menu command Description 
Go to > Chart view Interconnected 
functions 

Marks all functions in the chart view which are interconnected with selected 
functions. 

Find... Searches for objects in the project. 
Replace... Replaces selected instances with the instances of a target component. 
Plant view > In chart interface Transfers the selected connections to the chart interface. 
Plant view > Interconnect constants Sets a constant value at the input. 
Plant view > Interconnect externally Interconnects the input with an external output. 
Plant view > Move interconnections Moves the interconnections of technological functions 
Plant view > Select connections > All Selects all the connections of the complete chart or of the selected functions. 
Plant view > Select connections > Not 
interconnected 

Selects all the connections that are not interconnected of the complete chart 
or of the selected functions. 

Plant view > Select connections > 
Interconnected 

Selects all the interconnected connections of the complete chart or of the 
selected functions. 

Plant view > Select interconnections  Selects all interconnections, or interconnections with specific properties. 
Plant view > Highlight interconnections Highlights all interconnections which are assigned the selected properties in 

the open chart, for example, acyclic mode at slow scan rate. 
Variable table > Deactivate Deactivates monitoring of the selected tags. 
Variable table > Reactivate Reactivates monitoring of the selected tags. 
Variable table > Delete control value Deletes the selected control values from the variable table 
Variable table > Complete structure Lists all the structure elements up to the selected connection. 
Output window > Copy all Copies all the messages in text format to the clipboard. 
Output window > Delete all Deletes all messages from the output window. 
Special > Calls up functions or dialogs associated with the vendor-specific programming 

/ configuration tool, e.g. SIMATIC Manager, module status. 
Properties... Displays the properties of the selected object. 
Check consistency > Generated project > 
All instances 

Compares the shadow project with the component project of all instances. 

Check consistency > Generated project > 
Selected instances 

Compares the shadow project with the component project of selected 
instances. 

Check consistency > Runtime versions The system checks whether the PROFINET devices with proxy functionality 
and the connected PROFIBUS devices are compatible with the PROFINET 
runtime versions. 

Check the utilization Compares configuration requirements with the performance parameters of 
selected devices.  

Remove from chart hierarchy Removes selected objects from the chart hierarchie, and deletes their 
interconnections. 

Move to new chart Adds a chart to the project and moves selected objects to this chart.  
Re-edit component... Defines where the copy of the component project is to be stored. Opens 

SIMATIC Manager in order to re-edit the PROFINET component. 
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View menu 

 
 
 
Menu commands Description 
Toolbars Shows or hides the toolbar.  
Status Bar Shows or hides the status bar. 
Project tree Shows/hides the window with the plant and net tree. 
Diagnostics window Shows or hides the diagnostic window. 
Information window Shows or hides the information window.  
Library window Shows or hides the library window. 
Preview Shows or hides the component preview window.  
Project tree > Plant tree > Shows auxiliary data of the functions, such as integrated devices, the 

component type, or HMI modules. 
Project tree > Net tree > Shows auxiliary data of the functions, such as integrated functions, the 

component type, or HMI modules, or the bus system. 
Project tree > Show layers Shows all nested layers of selected objects.  
Project tree > Hide levels Hide all nested layers of selected objects.  
Plant view > Recalculate interconnection 
lines 

Refreshes the interconnection lines. 

Plant view > Display interconnection lines Shows or hides the interconnection lines. 
Plant view > Dot screen Shows or hides the dot screen in the plant view. 
Plant view >Page margins Hides or shows the page margins of the printed copy. 
Network view > Page margins Hides or shows the page margins of the printed copy. 
Project view > Show instances Shows all instances of the component type. 
Project view > Hide instances Hides all instances of the component type. 
Project view > Page margins Hides or shows the page margins of the printed copy. 
Project view > Show header Hides or shows the header in the project view. 
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Menu commands Description 
Chart view > Show all layers Shows all nested layers of selected charts.  
Chart view > Hide all layers Hides all nested layers of selected charts.  
Chart view > Page margins Hides or shows the page margins of the printed copy. 
Variable table > Shows / hides the columns of the variable table. 
Zoom > Allows you to change the size of the view of the projects in the plant view, 

project view or network view. 

Insert menu 

 
 
 
Menu commands Description 
New chart Inserts a new chart into the project and moves selected objects into this chart, 

if necessary. 
New Ethernet node Inserts a new Ethernet node. 

Online menu 

 
 
 
Menu commands Description 
Monitor Activates / deactivates the online connection between SIMATIC iMap and the 

devices of the plant. Activating the online connection does not result in a 
download. "Monitor" must be activated for the diagnostics. 

Download all Instances > 
All 

Downloads the interconnections and programs to all the devices of the plant.  

Download all Instances > 
Program only 

Downloads all programs, or only the delta data to the devices of the plant.  

Download all Instances > 
Interconnections only 

Downloads the interconnections to all the devices of the plant. 
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Menu commands Description 
Download selected instances > All Downloads the programs and interconnections to the selected devices. 
Download selected instances > Program 
only 

Downloads all programs, or only the delta data to selected devices of the 
plant.  

Download selected instances > 
Interconnections only 

Downloads only the interconnections to the selected devices. 

Continue download Opens the Download dialog box with the list of devices saved last. 
Online/Offline comparison > All Runs an online-offline comparison for the programs and interconnections of 

the selected devices. 
The results are output to the output window. 

Online/Offline comparison > Programs 
only 

Runs an online-offline comparison for the programs of the selected objects.  
The results are output to the output window. 

Online/Offline comparison > 
Interconnections only 

Runs an online-offline comparison for the interconnections of the selected 
objects.  
The results are output to the output window. 

Check accessibility Checks the availability of selected devices and outputs the results to the 
output window. 

Online device analysis... Returns online device information for an IP address as an HTML file. 
Variable table > Monitor all tags Activates online monitoring with the variable table.  

The result appears in the diagnostic window. 
Variable table > Monitor selected tags Activates online monitoring of the selected tags.  

The result appears in the diagnostic window. 
Variable table > Stop monitoring selected 
tags 

Deactivates online monitoring of the selected tags. 

Variable table > 
Transfer selected control values 

Transfers the control values of the selected tags to the plant. 

Variable table > Copy online value Copies the online value of the select tags to the clipboard.  
The value can be entered as a control value, for example, via the Paste 
shortcut menu. 

Plant view > Display online values Shows / hides the current values of the selected connections. 
Plant view > Set online values Changes the current value of the selected connection. 
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Library menu 

 
 
 
Menu commands Description 
New... Opens a dialog box where you can create a new shared library, for example, 

for a project or new actions.  
Open... Opens a dialog box where you can select a shared library. 
Close Closes the active shared library. 
Select components that are not used Selects all the components of the project library that are not used. 
Archive... Opens a dialog box where you can backup a shared library. 
Retrieve... Opens a dialog box where you can select an archived shared library. 
Import components... Imports an existing PROFINET component from a folder to a library. 
View > Changes the view of the PROFINET components in the selected library. 
Auto arrange Automatically arranges the representation in the library window. 
Properties... Opens the properties dialog box for the selected library. 
Recent libraries Opens a list of recently opened shared libraries.  
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Options menu 

 
 
 
Menu commands Description 
Customize ... Modifies the customize general tab in SIMATIC iMap. 
Language > Changes the language of the SIMATIC iMap user interface. 
Create OPC Symbol File > Creates an OPC symbol file for the entire project.  
Import variable table... Imports a saved variable table into the diagnostic window. 
Export variable table... Saves a variable table as a cbv file. 
Update variable table Updates the variable table view. 
Tools... Opens the programs that are defined under "Settings". 

menu 

 
 
 
Menu commands Description 
Help F1 Opens the online help for the current window 
Help Topics Opens the online help for "Component Based Automation and SIMATIC 

iMap". 
Getting Started  Opens the introduction to SIMATIC iMap. 
About Provides information on the current software version and copyright. 
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A.2 Toolbar 

Toolbar buttons 
The toolbar buttons are designed in particular for working in SIMATIC iMap. They 
correspond with the following menu commands:  

Table A-1 Buttons the SIMATIC iMap toolbar 

Icon  Description Menu command 

 
New project Project > New 

 
Open Project Project > Open... 

 
Save project Project > Save 

 
Generating the Project Project > Generate >Control unit > Deltas only 

 
Print Project > Print > All Charts 

 
Cut Edit > Cut 

 
Copy Edit > Copy 

 
Paste Edit > Paste 

 
Open parent chart Edit > Open parent chart 

 
Insert chart Insert > New chart  

 
Move to new chart Edit > Move to new chart 

 
Interconnection lines on/off View > Plant view > Display Interconnection Lines 

 
Online monitoring Online > Monitor 

 
Monitor variables online Online > Variable table > Monitor all variables 

 
Transfer control value Online > Variable table > Transfer control value 
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Icon  Description Menu command 

 
Open Help Help > Help Topics 

 
Project view  View > Project view 

 
Information window  View > Information window 

 
Library window  View > Library window 

 
Preview  View > Preview 

 
Zoom in  View > Zoom > Zoom in 

 
Zoom out  View > Zoom > Zoom out 

 
Entire content  View > Zoom > Entire content 

 
Normal  View > Zoom > 100% 

 
Previous View > Zoom > Previous 

 

A.3 Actions 

Which actions do you want to carry out? 
The table below lists actions supported in SIMATIC iMap, including a description of how and 
when you can perform such actions. The corresponding objects are listed in alphabetical 
order. 
Objects to be processed usually have to be selected. 

Table A-2 Actions in SIMATIC iMap 

Which object? Which action? In which window? How? 
Addresses Assign Plant view, network view, 

project view, project tree 
Edit > Properties > Addresses tab 

Plant Arrange Chart view Arranging the charts and functions 
layout using drag-and-drop 

Connections Show and hide Plant view Click the connection and hide/show 
it with right-click. 

Utilization Check Network view Edit > Check utilization 
create Library Library > New  Library 
Archive  Library > Archive 
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Which object? Which action? In which window? How? 
Retrieve  Library > Retrieve 
Close Library Library > Close 
Open Library Library > Open 

Library window Display SIMATIC iMap View > Library window. 
Diagnostics window Display SIMATIC iMap View > Diagnostic window 
Download Run SIMATIC iMap Online > Download... 
Documentation of 
PROFINET components 

Open Preview Info tab > Documentation 

Documentation for SIMATIC 
iMap 

Open Desktop Start / Programs / Component 
Based Automation / Documentation

Inputs / Outputs interconnecting  Plant view Click the input to interconnect, and 
then click the corresponding output.

Properties Monitor / modify Plant view, network view, 
project view, project tree 

Edit > Properties... 
Project > Properties 

Error diagnosing Diagnostics window Online > Monitor 
Information window Display  View > Information window 
Instance replacing Plant view, network view, 

project view, project tree 
Edit > Replace 

Internal PROFINET IO and 
Industrial Ethernet devices 

Configuring Plant view, network view, 
project view, project tree 

Edit > Properties 

IP address Assign Plant view, network view, 
project view, project tree  

Edit > Properties > Addresses tab 

Consistency of the 
generated project 

Check Plant view, network view Edit > Check consistency > 
Generated project  

Check consistency of 
runtime versions 

Check Plant view, network view Edit > Check consistency > 
Runtime versions 

Multifunction component Insert in project Library Drag and drop  
Edit > Paste 

Print Network view Project > Print Chart 
zoom Network view View > Zoom 

Nested chart Creating Plant view Insert > New chart 
Online device analysis Run SIMATIC iMap Online > Online device analysis 

Display Plant view Online > Monitor 
Online > Plant view > Show online 
value 

set Plant view / Variable table Select connection 
Online > Plant view > Set Online 
Values 

copy Variable table Online > Variable table > Copy 
online value 

Online value 

Paste Variable table Edit > Paste 
PROFIBUS address Assign Plant view, network view, 

project view, project tree 
Edit > Properties > Addresses tab 

PROFINET component Import to a library Library Library > Import components 
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Which object? Which action? In which window? How? 
Insert in project Library Drag and drop  

Edit > Paste 
Create SIMATIC Manager Edit > Create PROFINET 

component 
Rename Library Not supported 
re-edit Library, Project view Edit > Re-edit component... 
Move From library to library Drag and drop  

Edit > Copy / Edit > Paste 
Archive SIMATIC iMap  Project > Archive 
Retrieve  Project > Retrieve 
documenting  Project > Document 
Print  Project > Print 

(Keyboard: Ctrl + P) 
Export  Project > Export 
Generate  Project > Generate 
Import  Project > Import 
Open  Project > Open 

(Keyboard: Ctrl + O) 
Save  Project > Save / 

Project > Save as  
(Keyboard: Ctrl + S) 

Project 

Deleting Windows Explorer Del key 
Project tree Display SIMATIC iMap View > Project tree 
Technological function Rename All views Edit > Properties > General tab 

Display SIMATIC iMap View > Diagnostic window > 
Variable table tab 

Monitor SIMATIC iMap Online > Variable table > Monitor 
variables 

 Variable table 

Import / Export SIMATIC iMap Options > Import / Export variable 
table 

Create Plant view Click the input to interconnect, and 
then click the corresponding output.

Highlight Plant view Click the interconnection and 
highlight it with right-click. 

Deleting Plant view Highlight the line, the press DEL. 
Insert in all projects  Click the entry, then select right-

click > External interconnection 

Interconnections 

Move Plant view Select connection  
Edit > Plant view > Move 
Interconnections  
Left-click the new connection 

Preview Display SIMATIC iMap If the library is open: View > 
Preview 

Paste SIMATIC iMap Options > Customize > Tools tab Tools 
use SIMATIC iMap Options > Tools... 
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 Note 
Overview of the most important actions 
This table shows a list which is restricted to the most important actions and corresponding 
objects. 

 

A.4 Naming conventions 

A.4.1 Naming conventions in SIMATIC iMap 

Naming conventions in SIMATIC iMap 
Naming rules:  

File and folder names 
A file or folder name may not contain any of the following characters: 
 \ / : ?" * < > | 

Project names 
Same as file names, but also not allowed are: , ;= 

Library names 
Same as file names. 

Object names 
The following naming conventions apply to SIMATIC iMap projects, libraries, technological 
functions, devices and charts. 
● The names may not be blank. 
● Space characters are not allowed as first and last characters of the name. 
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Additional conventions for names of technological functions, devices, charts, PN IO system names, 
and Ethernet branches 

● Name length: The maximum length of the object names of technological functions and 
devices is defined in the PROFINET component. Object names of charts and Ethernet 
nodes may have a maximum length of 32 characters in SIMATIC iMap. 

● Unambiguousness: The names of functions, devices, charts, Ethernet branches and PN 
IO systems must be unique within their category in an iMap project. No distinction is 
made between upper and lower case. 

● Legal characters All characters of the ISO 8859-1 (ISO-Latin-1, corresponds with 
UNICODE Codes 1-255) font, except the illegal characters. 

● Illegal characters: All non-printable characters (code 0 to 31, and 127 to 159 to ISO 8859-
1, including the exclamation mark (!, code 33.) 

● Additional illegal characters for devices and technological functions in PROFINET 
components created in STEP 7: 

 
Code  (appearance, English Unicode name) 
34  (",QUOTATION MARK) 
38  (&, AMPERSAND) 
42  (*, ASTERISK) 
43  (+, PLUS SIGN) 
44  (,, COMMA) 
46  (., FULL STOP) 
47  (/, SOLIDUS) 
96  (`, GRAVE ACCENT) 
124  (|, VERTICAL LINE) 
180  (´ ACUTE ACCENT) 
Those restriction do not apply to Singleton components. 

Additional conventions for PN IO system names 
The name of a PN IO system consists of one or more parts separated by dots. Each part 
consists of 1 to 63 characters and may only consist of characters, digits and the minus sign 
(-). Special characters, such as umlauts, ß and characters accent are not permitted.  
Each name part must start with a character and may not end with a minus sign.  
The total character length is limited to 240 characters. 
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Examples - invalid PN IO system names: 
 

name_1.x Underscore is forbidden 
name..y Two succeeding dots (would correspond to a number part 

having the length 0) 
Name.-xyz Name part begins with a - 
name.xyz- Name part ends with a - 
name.1a Name part begins with a digit 

Examples - valid PN IO system names: 
 

name.abc-123.xyz Each name part begins with a character, the minus sign is located 
within the name part 

a Shortest possible system name, one name part consisting of one 
character (has to be a character) 

 

A.4.2 Naming conventions for PROFINET components 

Naming conventions for PROFINET components 
Naming conventions to be observed:  

File and folder names 
A file or folder name may not contain any of the following characters: \ / : ?" * < > | 

Names of PROFINET components, technological functions and devices 
● The names may not be blank. 
● Space characters are not allowed as first and last characters of the name. 
● Name length: The names may not exceed a length of 24 characters. 
● All printable characters from ISO 8859-1 (ISO Latin 1) are allowed except the following 

characters: 
 

Characters  English Unicode Name 
! EXCLAMATION MARK 
" QUOTATION MARK 
& AMPERSAND 
* ASTERISK 
+ PLUS SIGN 
, COMMA 
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Characters  English Unicode Name 
.  FULL STOP (= PERIOD) 
/ SOLIDUS (= SLASH) 
: COLON 
; SEMICOLON 
< LESS-THAN SIGN 
= EQUALS SIGN 
> GREATER-THAN SIGN 
? QUESTION MARK 
[ LEFT SQUARE BRACKET(= OPENING SQUARE BRACKET) 
\ REVERSE SOLIDUS (= BACKSLASH) 
] RIGHT SQUARE BRACKET (= CLOSING SQUARE BRACKET) 
^ CIRCUMFLEX ACCENT 
` GRAVE ACCENT 
| VERTICAL LINE (= VERTICAL BAR) 
´ ACUTE ACCENT 

 
 

 Note 
The € character is not allowed because it is not included in the ISO Latin 1 set. 

 

Connector names  
● Characters allowed in connector names (to ISO 10646-1): 

Letters A to Z and a to z, digits 0 to 9, and the underscore character "_". 
● The first characters of a connector name must be a letter (not underscore or a number.) 

Connectors with names beginning with an underscore cannot be assigned a 
PROFINET CBA characteristic, such as "Connectable". 

● The length of a connector name may not exceed 24 characters. 
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A.5 File types 

Overview of the file types in SIMATIC iMap 
The following table shows the file name extensions for the file types used in SIMATIC iMap.  

 
File type Extensio

n 
Created with the menu command...* In ... 

Project CBP Project > Save or  
Project > Save As 

the project folder of the 
same name 

Library CBL Library > New or  
Library > Create New Library 

the library folder of the 
same name 

Project library CPL is automatically created and opened with 
the project 

the \projlib subfolder of the 
project folder 

Archived project ARP Project > Archive any folder in the file system 
Archived library ARL Library > Archive any folder in the file system  
PROFINET 
components 

XML Edit > Create PROFINET component in 
the device-specific configuration and 
programming tool, e.g. STEP 7 

the component folder  
- in the file system or 
- in a library 

Variable table CBV Options > Export Variable table any folder in the file system 
Project 
documentation 

HTML Project > Document any folder in the file system 

Online device 
analysis 
information 

HTML Online > Online device analysis any folder in the file system 

OPC symbol file STI Options > Create OPC symbol file any folder in the file system 
Project 
description 

CBI Project > Import any folder in the file system 

 
 

 Note 
In SIMATIC iMap you can use the menu command Options > Customize, "Folder" tab, to 
define a folder for every file type that will always be suggested when you create, save and 
select this file type. 

 
 
* Menu command in SIMATIC iMap, unless otherwise specified.  
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A.6 Data types of connectors 

Data types, data lengths and ranges of values for connections 
A PROFINET data type conforming to Microsoft© OLE 2.0 is assigned to every S7 data type. 
The following table show the permissible S7 data types for PROFINET CBA and the 
corresponding PROFINET data types as well as the data lengths and value ranges.  

Table A-3 Data types for PROFINET CBA 

PROFINET 
data type 

S7 data type Data length in 
bytes 

Range of values 

BOOL BOOL  2  TRUE / FALSE 
I1 CHAR 1  -128 to +127 
UI1 BYTE 1  0 to 255 
R4 REAL 4 -3.402823 E+38 to -1.175495 E-38 

0 
1.175495 E-38 to +3.402823 E+38 

I2 INT 2  -32.768 to +32.767 
UI2 WORD 2  0 to 65.535 
I4 DINT 4  - 2.147.483.648 to +2.147.483.647 
UI4 DWORD 4  0 to 4.294.967.295 
DATE DT (DATE_AND_TIME) 8 01.01.1900 00:00:00 to 31.12.9999 

00:00:00*) 
BSTR STRING 4 + 2 * number of 

characters 
 Character string 

ARRAY ARRAY Number * data 
type length 

Multidimensional, from the data types 
listed here**) 

STRUCT STRUCT or UDT Sum of the data 
type lengths 

Combined from the data types listed 
here**) 

*) There may be restrictions in the range of values, depending on the type of device e.g. for 
SIMATIC devices this would be: 01.01.1990 00:00:00 to 31.12.2089 23:59:59.  
**) Maximum of 6 dimensions. The maximum length depends on the amount of memory in 
the device 
***) Maximum 8-level structures. The maximum length depends on the amount of memory in 
the device.  

Data types supported in PROFINET runtime version V2.0.0.0 or later 
The following data types are supported by PROFINET devices in runtime version V2.0.0.0 or 
later: 
● Data type STRUCT with all simple data types, including STRING 
● Data type ARRAY with the data types BOOL, REAL, DATE_AND_TIME, STRING 
● User-defined data types (UDT) with all simple data types, including STRING 
Earlier Runtime versions do not support these data types. 
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Data types supported in PROFINET runtime Version V2.3.0.0 or higher 
The following data types are supported by PROFINET devices in runtime version V2.3.0.0 or 
higher: 
● STRUCT/UDT data type with all the data types listed above 
● ARRAY data type, multidimensional, with all the data types listed above 
Earlier Runtime versions do not support these data types. 
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Abbreviations B
Abbreviations 
 

Abbreviation Explanation 
CBA Ccomponent Based Automation 
COM Component Object Model  
DCOM Distributed Ccomponent Object Model 
HMI Human Machine Interface  
IE Industrial Ethernet 
IRT Isochronous Realtme 
MES Manufacturing Engineering System 
MAC Medium Access Control 
OLE Object Linking and Embedding 
OPC OLE for Process Control 
PB PROFIBUS 
PCD PROFINET Ccomponent Description 
UDT User-defined Data Type 
PN PROFINet 
QoS Quality of Service 
TIA Totally Integrated Automation 
UNC Uniform Naming Convention 
URL Uniform Resource Locator 
XML EXtended Markup Language 
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Technical Support SIMATIC C
C.1 SIMATIC Technical Support 

SIMATIC Technical Support 
You can contact Technical Support for all A&D products: 
● via the Internet using the Support Request:  

http://www.siemens.com/automation/support-request 
● E-mail: adsupport@siemens.com 
● Phone: +49 (0) 180 5050 222 
● Fax: +49 (0) 180 5050 223 
Further information about our technical support is available in the Internet at 
www.siemens.com/automation/service  

Service & Support on the Internet 
In addition to our documentation, we offer a comprehensive knowledge base online on the 
Internet at:  
http://www.siemens.com/automation/service&support 
There you will find: 
● The latest product information, FAQs, downloads, tips and tricks. 
● Our newsletter, providing you with the latest information about your products. 
● A Knowledge Manager to find the right documents for you. 
● Our bulletin board, where users and specialists share their knowledge worldwide. 
● your local contact partner for Automation & Drives in our Partner Database 
● Information about field service, repairs, spare parts and lots more under "Services" 

http://www.siemens.com/automation/support-request
mailto:adsupport@siemens.com
http://www.siemens.com/automation/service
http://www.siemens.com/automation/service&support
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Additional Support 
Please contact your local Siemens representative and offices if you have any questions 
about the products described in this manual and do not find the right answers. 
Find your contact partner at: 
http://www.siemens.com/automation/partner 
A signpost to the documentation of the various SIMATIC products and systems is available 
at: 
http://www.siemens.de/simatic-tech-doku-portal 

Training center 
SIEMENS offers a range of courses to help you to get started with your S7-300 Automation 
System. Please contact your local Training Center, or the Central Training Center in 
Nuremberg, D -90327 Germany. 
Phone:  +49 (911) 895-3200 
http://www.sitrain.com 

See also 
Preface (Page 3) 

http://www.siemens.com/automation/partner
http://www.siemens.de/simatic-tech-doku-portal
http://www.sitrain.com
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Glossary 

Basic project 
Project folder in the manufacturer-specific configuration tool which is used to create a 
PROFINET component. Example: STEP 7 basic project 

Chart 
In SIMATIC iMap: Folder which contains the technological functions and their 
interconnections. The chart is used to structure the plant. We distinguish between the plant 
chart and nested charts. 

Chart interface 
The chart interface of a nested chart contains the IO of its technological functions which can 
be interconnected beyond the chart boundaries. 

Chart view 
In SIMATIC iMap: representation of the chart hierarchy of the plant, including all function 
instances and charts. 

Chart, nested 
In SIMATIC iMap: a nested chart may be located on any lower level in the plant view's 
hierarchy. It may contain technological functions and further nested charts. 

Component Based Automation 
→ PROFINET CBA  

Component project 
Contains manufacturer-specific project data of the PROFINET component, for example, as 
STEP 7 project. 

Continuation connector 
Graphical representation of the end point of an interconnection. SIMATIC iMap represents 
interconnections in the form of lines or continuation connectors. 
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Device 
Within the context of PROFINET, "device" is the generic term for: 
● Automation systems (e.g. PLC, PC) 
● Field devices (for example, PLC, PC, hydraulic devices, pneumatic devices), and 
● active network components (e.g. switches, gateways, routers) 
In PROFINET CBA: part of the PROFINET component that contains the hardware-specific 
data for that component.  
In SIMATIC iMap, a device is considered the software representation of the physical device 
for which the PROFINET component was created. It is represented in the network view of 
SIMATIC iMap as an object with one or several bus connections.  
The main feature of a device is that it is integrated into the PROFINET communication via 
Industrial Ethernet or PROFIBUS. We differentiate between the following types of devices 
based on their bus connectors: 
● PROFINET devices 
● PROFIBUS devices 

Device instance 
→ Instance 

fixed functionality 
→ Functionality, fixed 

Function instance 
→ Instance 

Functionality, fixed 
A PROFINET component with fixed functionality does not contain an inherent user program. 

Functionality, programmable 
A PROFINET component with programmable functionality contains an integrated user 
program. 

Instance 
The instance of a PROFINET component represents the use of a component type in a 
SIMATIC iMap project. The instance comprises the function and device instances. 
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Interconnection 
General: Logic link of data between two objects.  
In SIMATIC iMap: Logical link between two technological functions. An output is always 
connected to an input of the same data type. SIMATIC iMap represents interconnections in 
the form of lines or continuation connectors. 

Interconnections with local communication partners 
Interconnections with local communication partners are:  
Interconnections between two PROFIBUS devices on the same PROFIBUS 
Interconnections between a PROFIBUS device and the associated PROFINET device with 
proxy functionality 

Interconnections with remote communication partners 
Interconnections with remote communication partners are routed across Industrial Ethernet.  

Interface DB 
Component Based Automation Data block in STEP 7 which describes the IO of the 
technological function.  

Library 
In SIMATIC iMap: Folder which contains reusable PROFINET component types. There are 
two types: the project library, and the shared library. 

MAC address 
Each PROFINET device is assigned a worldwide unique device identifier in the factory. 
 This device ID has a length of six byte and represents the MAC address (MAC = Medium 
Access Control.) The MAC address consists of: 
● 3 bytes for the manufacturer ID, and 
● 3 bytes for the device ID (consecutive number). 
The MAC address is usually printed on the front panel of the device.  
For example: 08-00-06-6B-80-C0 

Multi-function component 
The technological interface of a multi-function component is divided in several part functions. 
The part functions form the technological function of the component type. 

nested chart 
→ Chart, nested  
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Network view 
Representation of devices and networks (Ethernet, PROFIBUS) in SIMATIC iMap. 

PCD 
→ PROFINET Component Description 

Plant chart 
In SIMATIC iMap: the plant chart represents the highest layer in the hierarchy of the plant 
view. It contains all technological functions, the nested charts and their interconnections  

Plant view 
Representation of technological functions of the automation system and their 
interconnections in SIMATIC iMap. The plant view shows one chart. 

PROFIBUS device 
In PROFINET CBA: A PROFIBUS device has just one PROFIBUS connector and is always 
a slave. It can not directly participate in PROFINET communication, and must be integrated 
using a PROFIBUS device with proxy functionality. 

PROFINET 
PROFINET is the open Industrial Ethernet standard for automation.  
The PROFINET standard defines a manufacturer-independent communication and 
engineering model. PROFINET is implemented within the TIA framework based on two 
automation concepts:  
● PROFINET IO - for communication between a PROFINET IO controller and PROFINET 

IO devices. 
● PROFINET CBA.(Component Based Automation) - for machine-to-machine 

communication (between PLCs and intelligent field devices.) 

PROFINET CBA 
PROFINET CBA represents an automation concept in modular systems engineering, based 
on ready-to-use components. PROFINET CBA incorporates the communication between the 
PLC and intelligent field devices (machine-to-machine communication) at unit level. 

PROFINET component 
Software representation of a technological module with defined functionality. An automation 
system consists of several PROFINET components.  
A PROFINET component always comprises one or several technological functions and the 
corresponding device. 
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PROFINET Component Description 
The PROFINET component description refers to components you have generated in the 
engineering system (for example STEP 7.) The PCD is an XML file that you can import into 
SIMATIC iMap so that you can configure the PROFINET CBA communication. 

PROFINET controllers 
Controller which may be a PROFINET component (CBA) and also supports PROFINET IO. 

PROFINET device 
A PROFINET device always has at least one Industrial Ethernet port. A PROFINET device 
may feature one or several PROFIBUS connectors, and thus act as a master with proxy 
functionality. 

PROFINET device with proxy functionality 
The PROFINET device with proxy functionality is a proxy for PROFIBUS devices on 
Industrial Ethernet. The proxy functionality allows a PROFIBUS device to communicate with 
all participants in the PROFINET communication, as well as with its DP master.  
A device featuring only a local (internal) PROFBUS represents a DP master to the local DP 
slaves.  

programmable functionality 
→ Functionality, programmable 

Project library 
Element of a SIMATIC iMap project which is automatically opened, closed, archived or 
retrieved alongside with the project file. The project library contains all PROFINET 
components whose instances reside in the project.  

Project tree 
In SIMATIC iMap: hierarchic representation of the SIMATIC iMap project. The representation 
comprises two elements: 
- the plant tree, which contains the technological functions. This element can be structured in 
a hierarchy using nested charts. The plant element always contains the plant chart and may 
contain any number of nested chart levels. 
- the network tree, which contains the devices. The tree represents a hierarch view of the 
slaves connected to a PROFIBUS master. 

Project view 
Representation and assignment between PROFINET components and their instances in a 
SIMATIC iMap project. 
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Proxy functionality 
see PROFINET device with proxy functionality 

Proxy system 
Consists of a PROFINET device with proxy functionality all all its connected PROFIBUS 
devices 

Scan rate 
In acyclic transfer mode, the scan rate represents the interval between two successive 
checks for changes in data on provider side, for example, 200 ms. The scan interval is 
usually equivalent to the maximum time expiring prior to the transfer of deltas. 

Shadow project 
Folder to which manufacturer-specific project data are saved when configuration data are 
generated in SIMATIC iMap. 

Shared library 
Library the SIMATIC iMap user can open, close, archive and retrieve from an archive. A 
shared library contains PROFINET components which can be used in several projects. 

SIMATIC iMap 
PROFINET CBA engineering tool for the configuration, commissioning, and monitoring of 
modular distributed automation systems. It is based on the PROFINET standard. 

SIMATIC iMap STEP 7 AddOn 
Optional software for SIMATIC iMap integration in STEP 7. 

Singleton component 
In SIMATIC iMap, the device-specific configuration and programming data of a PROFINET 
component which are retained and edited in the STEP 7 basic project, rather than in the 
common shadow project. This component type allows you to incorporate hardware 
configurations with SIMATIC devices that were previously not supported into PROFINET 
communication. 
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Technological function 
General: Task or partial task within a technological process, such as measuring, motor 
control, positioning. A technological function can be implemented by hardware, for example 
an FM, or by software, for example, a loop control block.  
Component Based Automation The technological functions of a PROFINET component 
comprise the application-specific functionality of an automation or field device, and the 
technological interfaces for the communication with other PROFINET components.  
A technological function is visualized in the plant view of SIMATIC iMap as block with IO. 

Transfer rate 
In cyclic transfer mode, the transfer rate represents the interval between two successive 
transfers of a parameter, for example, 100 ms. 
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Index 

A 
Accelerated generation, 161 
Accelerated regeneration, 209 
Access to process data, 30 
Acyclic transfer, 26, 135 
Additional Support, 260 
Archiving in the current project folder, 94 
ARRAY, 255 
Arrow keys, 52, 54 
Assigning device names, 213 
Assigning device names to the target devices of the 
PROFINET IO system., 122 
Available device, 185 

B 
Basic project, 92 
BSTR, 255 

C 
Canceling generation, 89 
Changing names directly at the object, 43 
Chart interface, 113, 114 
Check availability, 185 
Commissioning, 207 

Requirements, 207 
SIMATIC devices, 207 

Communication partner 
Local, 135 
remote, 135 

Component Based Automation, 14 
Component project, 92 
composite data types, 130, 133 

Interconnect Constants, 133 
Interconnecting constants, 130 

Configuration check, 183 
Configuring substitute values, 132 

 
 
 
Connection, 21 

Data type, 21 
Input, 21 
interconnectable, 21 
Name, 21 
non-interconnectable, 21 
Output, 21 

Consistency check, 210 
Generated project, 91 
local DP slaves, 210 
of the generated project, 91 
Runtime versions, 117 
Runtime versions, 117 

Constant values 
interconnecting, 129 

Consumer, 21 
Continuation connector, 56 
Continuation connectors, 125 
Copy, 46 
Copying online value, 199 
Cut, 46 
cyclic transfer, 135 
Cyclic transfer, 26 

D 
Data access, 30 
Data storage, 208 

SIMATIC iMap, 92 
STEP 7, 208 

Data transfer types, 26 
Data types, 255 
DATE, 255 
Deleting 

iMap library, 47 
iMap project, 47 

Device, 17 
Device-independent engineering concept, 27 
Device-specific diagnostics, 211 
Diagnostics 

device-specific, 211 
Diagnostics window, 70 
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direct entry, 49 
Disabling and enabling entries, 197 
Displaying online values, 191 
Documentation (Preview window), 64 
Documentation for SIMATIC iMap, 42 
Double-click, 53 
Download, 166 

Destinations, 167 
Download to PROFIBUS devices, 176 
Drag & drop, 46 

E 
Editing a component, 209 
engineering concept 

Basic Procedure, 28 
device-independent, 27 

Ethernet node 
Paste, 116 

F 
File types, 93, 254 
Finding objects, 52 
fixed functionality, 18 
Function key F1, 41 
functionality 

fixed, 18 
programmable, 18 

G 
Generating SIMATIC iMap projects, 86 
Generating the Project, 209 
Generation status, 87, 90, 169 

Graphical representation, 90 
Global library, 102 
Go to, menu command, 52 

H 
Hide levels, 52 
Highlighting interconnections, 126 
HMI units, 232 
Hotline, 259 
HTML help for SIMATIC iMap, 42 

I 
I1, 255 
I2, 255 
I4, 255 
Icon, 246 
ID, 110 
Information window, 67 

Edition, 67 
Insert new Ethernet node, 116 
Inserting PROFINET components, 111 
Instance 

PROFINET components, 18 
Instance of a PROFINET component 

Replacing, 157 
Instances of the PROFINET components, 44 
interconnecting 

constant value, 129 
Multiple, 124 

Interconnecting technological functions, 124 
Interconnection, 123 
Interconnection lines 

recalculation, 126 
visualizing, 125 

Interconnections, 22, 56 
Creating, 124 
internal, 144 
Moving, 134 
Rules, 123 
with external projects, 95 

Interconnections with external projects, 95 
Internal device interconnections, 144 
Internal IE devices 

replacing, 159 
Internal PROFINET IO system 

replacing, 159 
Internet, 259 
IP address, 118, 120 

L 
Layout of objects, 62 
library 

Global, 102 
Library 

Close, 105 
Open, 104 
Open earlier version, 105 

Library window, 63 
Limit 

Absolute (max/min), 143 
Typical, 143 
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local communication partners, 135 
local DP slaves 

Consistency check, 210 
Online/offline comparison of programs, 211 

Logic device, 186 

M 
Maintenance information, 179, 183 
Maintenance demanded, 179, 183 
Maintenance required, 179, 183 
manufacturer-specific configuration and programming 
tools, 30 
Master with proxy functionality, 22 
Menu commands, 237 
Modified PROFINET components, 156 
Monitor variables online, 196 
Multifunction component 

Function units, 227 
Multifunction components, 223 

Editing, 47 
Function units, 47 

Multifunction components 
Applications in SIMATIC iMap, 225 

Multiple interconnections, 124 
Multiple selection, 45 

N 
Naming conventions, 250, 252 

PROFINET components, 252 
SIMATIC iMap, 250 

nested chart, 113 
Chart interface, 113 
Creating, 113 

Network chart, 61 
Network node, 119 
Network tree, 61 
Network types, 22 
Network view, 57 

O 
Object hierarchy, 42 
Object properties, 43, 48 
Object-oriented operation, 42 
objects 

Deleting, 46 
Editing, 45 
finding, 52 
highlighting associated objects, 53 

Moving, 46 
Rename, 48 

Offline view, 164 
Online device analysis, 199 
Online help, 41 
Online help for SIMATIC iMap, 42 
Online values 

Validity, 191 
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