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Additional Support
For questions about the system, please contact your Siemens sales partner.

Support
Our Customer Support Center provides a 24-hour service.
Siemens AG
Customer Support Center
Humboldtstrasse 59
90459 Nuremberg
Germany
E-mail: support.energy@siemens.com

Training Courses
Inquiries regarding individual training courses should be addressed to our Training Center:
Siemens AG Phone: +49 (911) 433-7415
Siemens Power Academy TD Fax: +49 (911) 433-7929
Humboldtstrasse 59 E-mail: poweracademy@siemens.com
90459 Nuremberg Internet: www.siemens.com/poweracademy
Germany

Software, System Configurator, Manual 3
E50417-H1140-C520-B1, Edition 06.2019

mailto:support.energy@siemens.com
mailto:poweracademy@siemens.com
http://www.siemens.com/poweracademy


4 Software, System Configurator, Manual
E50417-H1140-C520-B1, Edition 06.2019



Open Source Software

The product contains, among other things, Open Source Software developed by third parties. The Open
Source Software used in the product and the license agreements concerning this software can be found in the
Readme_OSS. These Open Source Software files are protected by copyright. Your compliance with those
license conditions will entitle you to use the Open Source Software as foreseen in the relevant license. In the
event of conflicts between Siemens license conditions and the Open Source Software license conditions, the
Open Source Software conditions shall prevail with respect to the Open Source Software portions of the soft-
ware. The Open Source Software is licensed royalty-free. Insofar as the applicable Open Source Software
License Conditions provide for it you can order the source code of the Open Source Software from your
Siemens sales contact - against payment of the shipping and handling charges - for a period of at least 3 years
since purchase of the Product. We are liable for the Product including the Open Source Software contained in
it pursuant to the license conditions applicable to the Product. Any liability for the Open Source Software
beyond the program flow intended for the Product is explicitly excluded. Furthermore any liability for defects
resulting from modifications to the Open Source Software by you or third parties is excluded. We do not
provide any technical support for the Product if it has been modified.
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Overview IEC 61850
The IEC 61850 standard has been defined in cooperation with manufacturers and users to create a uniform,
future-proof basis for the protection, communication, and control of substations.
The advantages of using this protocol are as follows:

• Interoperability: With IEC 61850, you will not encounter protocol diversity and integration problems.

• Simpler Engineering: From engineering to implementation, from operation to service, it saves time and
costs on configuration, commissioning and maintenance.

• Reduction of costs: IEC 61850 replaces wiring among feeders, control switches, and signaling devices.

• Reliability: It uses only one communication channel for all the real time data synchronized using
Ethernet.

The IEDs (Intelligent Electronic Devices) communicate with each other through a high-speed messaging tech-
nique called GOOSE (Generic Object-oriented Substation Event) messaging. On the occurrence of any status
change, an IED multicasts a high-speed GOOSE message, which typically contains the status of binary inputs,
trip signals, or status of primary equipment (for example, circuit breaker). They are all grouped in a dataset.
GOOSE is based on repetitions for a high reliability and for monitoring purposes of the communication link.
The IEC 61850 Edition 2 has been published to address certain issues such as interoperability and extensions
of data models and functions for the use in the following new areas or domains:

• Distributed Energy Resources

• Power Quality

• Hydropower and Wind Power
The IEC 61850 Edition 2 also supports new engineering possibilities, for example, for the SED file for GOOSE
intersubstation communication and the use of the functional product naming ldName.
The IEC 61850 part 6 Amendment 1 of Edition 2 has been published in 2018; the other parts of IEC 61850 are
about to be published as well.
The part 6 defines the SCL: Configuration description Language, and the new amendment addresses the
following issues:

• Clarifying ambiguous points

• Correcting technical Issues

• Extending the IED service capabilities

• Defining the Later Binding full support

• Specifying upgrading and downgrading conversion rules to address the mixed version projects
An Edition 2.1 station is capable of hosting Edition 1, Edition 2 and Edition 2.1 devices. An Edition 2 station is
reduced to Edition 1 and Edition 2 devices, and an Edition 1 station to Edition 1 devices. The highest the SCL
configuration description language, the better and unambiguous is the system configuration.
It is to note that now a device can be described with a newer SCL version, wherein, an Edition 1 device can be
described (ICD, IID file) using the SCL syntax of Edition 2.1.

1.1

Introduction
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Overview System Configurator
The standard IEC 61850 System Configurator tool is designed to:

• Replace DIGSI 4 V4.89 System Configurator

• Replace DIGSI 5 V6.0 integrated System Configurator

• Can be used with all Siemens IED tools like DIGSI 4, DIGSI 5, ReyDisp Manager, SICAM I/O Mapping tool,
and SICAM ToolBox II

• Use as a vendor-neutral tool for IEC 61850 interoperable projects

• Reduce the engineering effort using fewer interfaces between software products
The IEC 61850 System Configurator performs the following operations defined in IEC 61850-6 standard:

• Integrating and managing IEDs

• Configuring network

• GOOSE engineering

• Report engineering

• Process bus engineering

• Export of SCL files

• Import SCL files

• Protocol mapping for IEC 60870-5-104 according to IEC 61850-80-1

1.2

Introduction
1.2 Overview System Configurator
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Starting IEC 61850 System Configurator
You have the following options to start the IEC 61850 System Configurator:

Start from the Windows Start Menu
To start the IEC 61850 System Configurator from the Windows Start menu, proceed as follows:
² Select Start > All Programs > Siemens Energy > IEC 61850 System Configurator > IEC 61850 System

Configurator.
The IEC 61850 System Configurator opens.

Multiple IEC 61850 System Configurator Windows
You can open multiple instances of IEC 61850 System Configurator. This is only applicable for IEC 61850
System Configurator V5.40 and later.

ii
NOTE
You cannot open multiple instances of the same project.

Start from DIGSI 4
To start the IEC 61850 System Configurator from DIGSI 4, proceed as follows:
² In the DIGSI 4 window, right-click the station you want to open in the IEC 61850 System Configurator and

select Open Object.
- or -

2.1

Working with IEC 61850 Station
2.1 Starting IEC 61850 System Configurator
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[sc_DIGSI4, 1, en_US]

Figure 2-1 Starting IEC 61850 System Configurator – DIGSI 4

² Select the station and press Ctrl+Alt+O on the keyboard.
- or -

² Double-click the station you want to open in the IEC 61850 System Configurator.
The IEC 61850 System Configurator window opens with the selected station.

Start from DIGSI 5
To start the IEC 61850 System Configurator from DIGSI 5, proceed as follows:
² In the DIGSI 5 window, select the station you want to open and click  in the IEC station editor.

- or -

² Right-click the station you want to open in the IEC 61850 System Configurator from the project tree and
select Export changes to IEC 61850 System Configurator.

Working with IEC 61850 Station
2.1 Starting IEC 61850 System Configurator
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[sc_DIGSI5, 1, en_US]

Figure 2-2 Starting IEC 61850 System Configurator – DIGSI 5

The IEC 61850 System Configurator window opens with the selected station.

Start from Reydisp Manager
To start the IEC 61850 System Configurator from Reydisp Manager, proceed as follows:
² In the Reydisp Manager window, right-click the station you want to open and click 61850 Station >

System Configurator.
- or -

² Double-click the station you want to open.

- or -

² Double-click System Configurator in the Station Configuration section.

Working with IEC 61850 Station
2.1 Starting IEC 61850 System Configurator
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[sc_Reydisp_Manager, 1, --_--]

Figure 2-3 Reydisp Manager

The IEC 61850 System Configurator window opens, displaying the selected station.

Working with IEC 61850 Station
2.1 Starting IEC 61850 System Configurator
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Creating the IEC Station
To create an IEC Station, proceed as follows:
² Open the IEC 61850 System Configurator.

² Click Station > New on the menu bar.
- or -

² Click  on the toolbar.

- or -

² Press Ctrl+N on the keyboard.
The New IEC 61850 station dialog is displayed.
² Enter the project name and navigate to the location where you want to create the station and click Open.
IEC 61850 Edition choices dialog is displayed.

ii
NOTE
The length of the Project name is limited to 100 characters and the length of the Path is limited to
140 characters.

² Select either Edition 1, Edition 2, or Edition 2.1 and click OK.
The station is created.

ii
NOTE
IEC station can be created from the IED tool directly.

2.2

Working with IEC 61850 Station
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Opening the IEC Station
To open an IEC Station, proceed as follows:
² Open the IEC 61850 System Configurator.

² Click Station > Open in the menu bar.
- or -

² Click  in the toolbar.

- or -

² Press Ctrl+O on the keyboard.
Open IEC 61850 station dialog is displayed.
² Navigate to the station project folder and select the .scd file.

² Click Open.
The IEC Station is opened.
It can be started from an IED tool (for example, DIGSI4 and DIGSI5, ReyDisp manager, and so on) with a project
or directly from the stand-alone.

ii
NOTE
You can also open an IEC station using the following options:

• Drag and drop the SCD file on to the IEC 61850 System Configurator window.

• Double click the SCD file.

• Open from the IED tools (for example, DIGSI 4, DIGSI 5, and Reyrolle).

• Select the recently used IEC station from the Station menu. A maximum number of 5 recent
IEC stations that you have worked on are displayed in the Station menu.

2.3

Working with IEC 61850 Station
2.3 Opening the IEC Station
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Saving the IEC Station
To save the IEC Station, proceed as follows:
² Click Station > Save in the menu bar.

- or -

² Click  in the toolbar.

- or -

² Press Ctrl+S on the keyboard.
The IEC station is saved.
It is independent from the IED tool configuration backup and must be archived independently.

2.4

Working with IEC 61850 Station
2.4 Saving the IEC Station

24 Software, System Configurator, Manual
E50417-H1140-C520-B1, Edition 06.2019



Renaming the IEC Station
To save the station with a different name, proceed as follows:
² Click Station > Save as in the menu bar.
The IEC 61850 station save as dialog is displayed.
² Navigate to the location where you want to save the station, enter the name to save the station, and click

Open.
The station is saved with the new name and then this station is opened in the IEC 61850 System Configurator.

2.5

Working with IEC 61850 Station
2.5 Renaming the IEC Station
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Closing the IEC Station
To close the IEC station, proceed as follows:
² Click Station > Close.
If there are any unsaved changes, a dialog is displayed.
² Click Yes to save the changes or click No to discard the changes.
The IEC station is closed.

2.6

Working with IEC 61850 Station
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Archiving a Project
To archive a project, proceed as follows:
² Click Station > Archive in the menu bar.

The Archive project dialog is displayed.

² Navigate to the location where you want to save the project, enter the name to save the project, and
click Save.
The project is archived successfully as an .sz file.

ii
NOTE
When an older version of a station is opened, it is automatically archived before it is upgraded to the latest
version of the station. It is archived in the Archive folder which is located in the project folder. Information
about the older version of the station is added to the History section in the SCD file.

2.7

Working with IEC 61850 Station
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Retrieving a Project
To retrieve a project, proceed as follows:
² Click Station > Retrieve in the menu bar.

The Retrieve archived project is displayed.

² Navigate to the folder and select the archived project (.sz file).

² Click Open.
The Browse For Folder dialog is displayed.

² Navigate to the folder and select a folder to retrieve the archived project.

² Click OK.
The project is retrieved and opened in the IEC 61850 System Configurator.

2.8
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Sorting the Column Content
You can sort the content of the column in alphabetically ascending or descending order.
To sort the content of tables, proceed as follows:
² Select a column as reference.

² To sort the column content in ascending or descending order, click the header of the unsorted column.
The selected column and the rest of the column content is sorted alphabetically in ascending or descending
order.

ii
NOTE
You can sort the column content in the following views:

• Devices view

• Network view

• Reports and logs view

• Protocol mapping view

2.9
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Filtering the Views
The columns in the GOOSE view, SMV view, Reports and logs view, and Protocol mapping view can be filtered
at different levels.
The following filter options are available for the protocol mapping:

• Custom

• None

• Reset All
By default, the filter option is not selected.
To filter the signals based on the IED, proceed as follows:
² Click  to view the filter options.

² Select either none, custom or a specific IED from the list box in the IED column.
The column is filtered based on the selected filter option.
The Reset All filter option resets all the filters in that view.
The none filter option clears the filter for the selected column. Selecting the specific device lists items related
only to that device and the selected item is displayed as the column header. For custom filter, refer to Custom
Filter, Page 30.

ii
NOTE
You can filter all the columns (IED, LD, LN, DO, DA, CDC, Description, CASDU, IOA and TI) in the protocol
mapping editor as mentioned in the preceding section.

Custom Filter
To customize the filter, proceed as follows:
² Select the custom filter option from the list box.
The Custom Row Filter dialog is displayed.

[sc_custom row filter, 2, en_US]

Figure 2-4 Custom Row Filter

² Click the list box to select the condition.

² Enter the value in the text box for that condition.
You can use and or or condition to add another condition for the custom filter.

2.10
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[sc_custom row filter, values, 2, en_US]

Figure 2-5 Sample Custom Row Filter - Condition and Value

ii
NOTE
The following shortcuts can be used while working on custom filters:

• contains: *<text>*

• begins with: <text>*

• ends with: *<text>

² Click OK to add the filter or click Cancel to discard the custom filter.
For additional information about the custom filter conditions and explanation, refer to 8.4.7.4 Custom Filter.
To filter non-blank columns, proceed as follows:
² In the Custom Row Filter dialog, select the does not equal option from the list box.

² Press Spacebar on the keyboard to enter a space as the value in the text box.

² Click Ok.
The non-blank columns will be filtered.

Working with IEC 61850 Station
2.10 Filtering the Views

Software, System Configurator, Manual 31
E50417-H1140-C520-B1, Edition 06.2019



Devices View

Opening the Devices Editor

To open the Devices editor in other cases, proceed as follows:
² Click View > Devices on the menu bar.

- or -

² Click Devices on the IEC 61850 System configurator bar.
- or -

² Press Ctrl+1 on the keyboard.
Devices editor is displayed and it consists of the following windows:

• IEDs

• Properties
For additional information on these windows, refer to 8.4.1.1 Devices Editor.

Adding the Devices (ICD, IID, and SCD) to the Station

To add devices (ICD, IID, or SCD) to the station, proceed as follows:
² Select the IEC station in the Devices editor.

² Click Station > Import on the menu bar and select Add IEC 61850 device(s) from the submenu option.
- or -

² Right-click the station and select Add IEC 61850 device(s) from the context menu.
The Importing IEC 61850 device description(s) dialog is displayed.
² Navigate to the folder and select the SCD file or ICD/IID file(s).

² Click Open.
The status report dialog is displayed. If there are no validation errors, the device is successfully added to the
station.

ii
NOTE
The SCL edition of the ICD/IID/SCD files has to be lower or belong to the station edition.

ii
NOTE
The ICD files of Client , PC, Router, SNTP, and Switch are available under ICD folder in the IEC 61850 System
Configurator installation path.
(For example, C:\Program Files (x86)\Siemens Energy\IEC 61850 System Configurator V5.xx\ICD).

ii
NOTE
You can export the IEC 61850 station configuration from DIGSI 5 to the IEC 61850 System Configurator,
even if there is an opened instance of the IEC 61850 System Configurator tool.

Updating the Devices

To reimport the devices with its updated SCL, proceed as follows:

2.11
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² Select the IEC Station in the Devices editor.

² Click Station > Update on the menu bar and select Update IEC 61850 device(s) from the submenu
option.
- or -

² Right-click the station and select Update IEC 61850 device(s) from the context menu.
The Importing IEC 61850 device description(s) dialog is displayed.
² Navigate to the folder and select the files.

² Click Open.
The device is updated successfully, if there are no validation errors listed in the status report.

ii
NOTE
If the device is not part of the station and if you try to update that device, Device not found warning
message is displayed in the status report.

Renaming the Device TEMPLATE

To rename the device imported via ICD named TEMPLATE, proceed as follows:
² Select the device from the Devices editor.

² Double-click the device TEMPLATE and enter a unique IED name.

² Press Enter or click anywhere outside the box.
The new name for the device TEMPLATE is accepted and is displayed in the IEDs Editor.

ii
NOTE
Special characters are not allowed in the Name text box according to IEC 61850-6 scheme.

Removing the Devices

To remove the devices from the station, proceed as follows:
² Select the device from the IEC station.

² Right-click the device and select Delete from the context menu.
- or -

² Click Edit > Delete on the menu bar.
- or -

² Click  on the toolbar.

The selected device is removed from the IEC station including its communication links (for example, GOOSE).

ii
NOTE
The IEDs added by the IED tool (DIGSI4 and DIGSI5, ReyDisp manager) can be removed by that IED tool
only.

2.11.4

2.11.5
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Copying the GOOSE and Reports Datasets across IEDs

ii
NOTE
IEDs are configured as typicals and instantiated several times. It is then useful not to re-engineer all the
IEDs manually.

To copy all the GOOSE and reports datasets across IEDs, proceed as follows:
² Select an IED from the Devices editor.

² Right-click the IED and select the Copy option from the context menu.
- or -

² Click Edit in the menu bar and select the Copy option.
- or -

² Press Ctrl+C on the keyboard.

² Right-click the IED from the Devices editor where you want to paste the GOOSE and reports datasets and
select Paste.

The GOOSE and reports datasets gets pasted to the IED.

ii
NOTE
The elements (LD, LN, DO, DA) which are not copied to the IED are displayed in the status report. If the
dataset cannot be created, either the device does not have the service capability or it already contains the
maximum number of datasets allowed.

2.11.6
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Substation View

Overview of Substation Editor

In the Substation editor, you can structure and view the topology of the substations present, if necessary, by
adding or deleting a substation and child nodes. You can configure LNodes at any level in the substation using
the available devices and specify the relevant properties.
Each substation can have several kinds of child nodes.You can add new substations to the existing structure or
delete the existing substations.

Opening the Substation Editor

To open the Substation editor, proceed as follows:
² Click View > Substation on the menu bar.

- or -

² Click Substation on the IEC 61850 System configurator bar.
- or -

² Press Ctrl+2 on the keyboard.
Substation editor is displayed and it consists of the following windows:

• Substation

• Source catalog

• Properties
For additional information on these windows, refer to 8.4.2.1 Substation Editor.

Inserting and Deleting a Substation

Inserting a Substation
To insert a substation, proceed as follows:
² Select the IEC 61850 station.

² Right-click the station and select Substation from the context menu.
A substation is added to the station.

ii
NOTE
The mandatory child nodes, Voltage level and Bay are automatically inserted when a substation is created.

Deleting a Substation
To delete a substation from the Topology window, proceed as follows:
² Select the substation in the Topology window.

² Right-click the substation and select Delete from the context menu.
The Delete items dialog is displayed.
² Click Yes to delete the substation or No to abort the operation.

2.12
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ii
NOTE
The Delete option for substation is disabled if there is only one substation available.

Renaming the Substation

To change the name of the substation, proceed as follows:
² Select the substation in the Topology window.

² Enter the name for the substation in the Name text box in the Properties window.

² Press Enter on the keyboard or click outside the text box.

ii
NOTE
Special characters are not allowed in the Name text box according to IEC 61850-6 scheme.

Adding and Deleting Nodes

Adding Nodes
To add a node for a station in the Substation window, proceed as follows:
² Select the substation element.

² Right-click the substation element and select the node type from the context menu.
The selected node type is added to the substation element.
The following node types are available for the respective substation element:
Substation Element Available Node Type
Substation • PowerTransformer

• VoltageLevel
PowerTransformer Transformer Winding
VoltageLevel • Bay

• PowerTransformer
Transformer Winding Terminal
Bay • ConnectivityNode

• ConductingEquipment
– Circuit Breaker
– Disconnector
– Voltage Transformer
– Current Transformer
– Generator
– Motor

• Function (not allowed in Edition 1 projects)

2.12.4

2.12.5

Working with IEC 61850 Station
2.12 Substation View

36 Software, System Configurator, Manual
E50417-H1140-C520-B1, Edition 06.2019



Substation Element Available Node Type
Function • ConductingEquipment

– Circuit Breaker
– Disconnector
– Voltage Transformer
– Current Transformer
– Generator
– Motor

• SubFunction
ConductingEquipment • Terminal

• Subequipment

Deleting Nodes
To delete a node from a station in the Substation window, proceed as follows:
² Select the node in the Topology window.

² Click Edit on the menu bar and select Delete from the menu option.
- or -

² Click  from the toolbar.

- or -

² Right-click the node and select Delete from the context menu.
- or -

² Press Delete on the keyboard.
The Delete items dialog is displayed.

² Click Yes to delete the node or No to abort the operation.

ii
NOTE
The delete option is unavailable if the node is a mandatory element.

Configuring the LNodes

Linking the Logical Node to the LNode
To link the logical node to the LNode, proceed as follows:
² Select the logical node in the Source catalog.

² Hold down the SHIFT key and the down arrow to select multiple logical nodes.

² Hold down the mouse button and drag the logical node to the target LNode in the Topology window.
If insertion is not allowed at this position, the mouse pointer changes to a crossed-out circle.

² Release the mouse button at the permissible position
The linked LNode path displays the IED name > LD Name > Logical node name.

ii
NOTE
To link the LNode and logical node in the Topology window, they should belong to the same LN Class.
To add preconfigured LNodes, drag and drop the Logical node on to the conducting equipment.

2.12.6
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Unlinking the Logical Node from the LNode
To unlink the logical node from the LNode, proceed as follows:
² Select the LNode to be unlinked in the Topology window.

² Right-click the LNode and select Unlink from the context menu.
After unlinking, the path corresponding to the LNode displays as <Not Connected>.

Replacing the Existing Configuration
To replace the existing configuration in the Topology window, proceed as follows:
² Select the logical node in the Source catalog.

² Hold down the mouse button and drag the logical node to the LNode to be changed in the Topology
window.
If insertion is not allowed at this position, the mouse pointer changes to a crossed-out circle.

² Release the mouse button at a permissible position.
The Replace configuration dialog is displayed.
² Click Yes to replace the existing configuration and No to abort the operation.

Working with IEC 61850 Station
2.12 Substation View

38 Software, System Configurator, Manual
E50417-H1140-C520-B1, Edition 06.2019



Network View

Overview of the Network Editor

In the Network Editor, you can structure the communication network of the IEC 61850 station, if necessary, by
adding or deleting a subnet. You can assign existing users to these subnets and specify the addressing and
relevant properties.
When you open a station for the first time, the network structure of the station consists of one or more
subnets. This contains the access points of all the devices that you assigned to the station as participants, that
is, what you see are not the devices, but the access points to these devices. Each device can have several
access points, which can be assigned to different subnets. The part of the name of an access point is the
device name, which you have assigned within the project. Therefore, it is easy to find the individual devices in
the network structure. You can add new subnets to the existing structure or delete the existing subnets.

Opening the Network Editor

To open the Network editor, proceed as follows:
² Click View > Network on the menu bar.

- or -

² Click Network on the IEC 61850 System configurator bar.
- or -

² Press Ctrl+2 on the keyboard.
Network editor is displayed and it consists of the following windows:

• Subnets

• Properties
For additional information on these windows, refer to 8.4.3.1 Network Editor .

Inserting and Deleting a Subnet

Inserting a Subnet
To insert a subnet, proceed as follows:
² Select the station in the Subnets window.

² Click Insert on the menu bar and select Subnet from the menu option.
- or -

² Click  on the toolbar.

- or -

² Right-click the station and select insert Subnet from the context menu.
This operation adds the subnet to the station.

Deleting a Subnet
To delete a subnet from a station in the Subnets window, proceed as follows:
² Select the subnet in the Subnets window.

² Click Edit on the menu bar and select Delete from the menu option.
- or -

2.13
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² Click  from the toolbar.

- or -

² Right-click the subnet and select Delete from the context menu.
- or -

² Press Delete on the keyboard.
The Delete items dialog is displayed.
² Click Yes to delete the subnet or No to abort the operation.

ii
NOTE
Only empty subnets can be deleted.

Moving the Access Point

Most IEDs contain a single access point. Some physical devices like SIPROTEC 5 can support several communi-
cation modules with IEC 61850. Access points can be moved from one subnet to another subnet either using
the drag and drop or the cut and paste option. Moving access points does not change the IP address of the
access point. To allow GOOSE configuration, access points must be in the same network.
To move an access point using drag and drop, proceed as follows:
² Select the access point in the Network editor.

² Drag it onto the Subnet for which this access point has to be assigned.

ii
NOTE
The access point with ServerAt of the same IED have to be in different subnets.

To move an access point using cut and paste, proceed as follows:
² Right-click the access point and select Cut from the context menu.

² Right-click the subnet to which you want to paste the access point and select Paste from the context
menu.

Addressing the Access Points

Overview
The IP address of an access point must be unique within a subnet. You can enter the IP address manually in
the Properties window of an access point, or you can use the automatic addressing function with consecutive
IP addresses.

Manual Addressing
To assign the IP address manually, proceed as follows:
² Select the access point in the Network editor.

² Enter the IP address in the Properties window in the IP address field.
The IP address and Standard Gateway have the x.y.y.x (where, x = 1 to 254 and y = 0 to 254) format,
whereas Subnet mask has the x.y.y.z (where, x = 1 to 255, y = 0 to 255, and z = 0 to 254) format.
However, it must be noted that not every possible combination within the value range is permissible. For
all the non-permissible exceptions, an error message is displayed as a tooltip in the Properties windows
for IP address.

2.13.4

2.13.5

2.13.5.1

2.13.5.2

Working with IEC 61850 Station
2.13 Network View

40 Software, System Configurator, Manual
E50417-H1140-C520-B1, Edition 06.2019



ii
NOTE
Gateway can be 0.0.0.0 or blank.

Automatic Addressing
To assign the IP address automatically, proceed as follows:
² Select the subnet with the access points to be automatically addressed in the Network Editor.

² Enter a valid IP address in the Properties window as a start value in the IP start address field.

ii
NOTE
During automatic addressing, the IP start address is assigned to the access point displayed in the top posi-
tion within the subnet. All other access points contain IP addresses which are assigned in ascending order
from the start address.

² Click Edit on the menu bar and select Automatic addressing.
- or -

² Click  on the toolbar.

- or -

² Right-click the subnet and select AutomaticIPaddressing from the context menu.
- or -

² Press Shift+Ctrl+A on the keyboard.
If the access points of the subnet concerned already have valid IP addresses or the access point has an invalid
IP address, Overwriting existing IP addresses dialog is displayed.
² Click Yes to overwrite the existing IP address or click No to abort the operation.

ii
NOTE
Automatic addressing is not applicable to the devices added through SED import.

Specifying the Timer Server

All the devices must be synchronized to a uniform time base to ensure the timely accurate acquisition and
documentation of events. To realize this, you need a reliable time source as well as a mechanism to make this
time available to each other. A timer is used as a time source and the mechanism is called as Network Time
Protocol (NTP).
You can integrate several timers into your Network editor as devices. One of the timers is specified as a first
timer (primary timer) with the additional timer as the second timer. If the first timer fails, the second timer
becomes active. You can operate your network with only one timer, however, redundancy is no longer
ensured.

ii
NOTE
Initially the timer is available in the New devices folder. The timer option is enabled in the Properties
window once it is assigned to a subnet.

To specify the timer in the Properties window of the station, proceed as follows:
² Select the timer from the Subnets window.

2.13.5.3
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² In the Properties window, set the value to Yes for Use as a timer parameter in the Siemens Parameter
for SIPROTEC group. This type of configuration is enabled for EN100 modules only.

To list the timers in the Properties window of the IEC 61850 station, proceed as follows:
² Select IEC 61850 station.

² In the Properties window, select one option each for Primary clock master and Second clock master
from Parameter group.

If you select the same timer for First timer and Second timer, Select a timer for SIPROTEC devices dialog is
displayed. Click OK to update the timer to the latest modification.
Following cases are encountered with respect to the number of available timers:

Case 1: No Timer is Available within the Station
A message is displayed in timer boxes as No timer available for Primary clock master and No second timer
available for Second clock master. No selection is possible in such case.

Case 2: One Timer is Available within the Station
The name of the timer is displayed in the Primary clock master box. In the Second clock master box, you will
receive No second timer available message. No selection is possible for the Second clock master in such
case.

Case 3: Two Timers Available within the Station
You have to determine one of the two timers as the Primary clock master and the other timer as the Second
clock master. Click on one of the two timer boxes if you want to change this assignment. Select the name of
the other timer from the list box. If you have changed the assignment for the first timer for instance, the
assignment for the second timer is changed automatically and vice versa.

Case 4: More than Two Timers Available within the Station
You have to determine one of the timers as the Primary clock master and another timer as the Second clock
master.
If you want to assign the second clock master timer to the Primary clock master, the assignment for the
second clock master timer is changed to primary clock master timer automatically and vice versa.
If you want to assign the unassigned timer to any of the clock master, select the timer from the list box.

Working with IEC 61850 Station
2.13 Network View

42 Software, System Configurator, Manual
E50417-H1140-C520-B1, Edition 06.2019



GOOSE View

Overview of the GOOSE Communication

Devices often have to exchange data with other devices. In IEC 61850, this cross-communication is referred to
as GOOSE: Generic Object Oriented Substation Event. GOOSE is a process that transmits event information
quickly between various participants.
Siemens GOOSE application is used to display GOOSE messages related to the same functionality in the same
folder for a clearer overview and to provide an easy way to configure global parameters between several
GOOSE ControlBlocks.

Opening the GOOSE Editor

To open the GOOSE Editor, proceed as follows:
² Click View > GOOSE on the menu bar.

- or -

² Click GOOSE editor on the IEC 61850 System configurator bar.
- or -

² Press Ctrl+3 on the keyboard.
GOOSE editor is displayed and it consists of the following windows:

• GOOSE messages

• Source catalog

• Destination catalog

• Properties
For additional information on these windows, refer to 8.4.4.1 GOOSE Editor.

Adding and Deleting the GOOSE Application

Adding a GOOSE Application
To add GOOSE application for a station in the GOOSE editor, proceed as follows:
² Select the IEC 61850 station.

² Click Insert > GOOSE application on the menu bar.

² Click  on the toolbar.

² Right-click the station and select GOOSE application from the context menu.
A GOOSE application is added to the station.

Deleting a GOOSE Application
To delete GOOSE application from a station in the GOOSE editor, perform any of the following:
² Select the GOOSE application and click Edit > Delete from the menu bar.

- or -

² Select the GOOSE application and click  on the toolbar.

- or -

² Right-click the GOOSE application and select Delete.
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- or -

² Select the GOOSE application and press Delete on the keyboard.
Delete items dialog is displayed.
² Click Yes to delete the GOOSE application or No to abort the operation.

ii
NOTE
Some GOOSE applications cannot be deleted, because of the service restrictions or capabilities of certain
datasets assigned to them.

Renaming the GOOSE Application

Renaming a GOOSE Application in the GOOSE Message Editor
To rename the GOOSE application in the GOOSE message editor, proceed as follows:
² Select the GOOSE application you want to rename.

² Double-click the GOOSE application.
- or -

² Press F2 on the keyboard.

² Enter a new name for the GOOSE application.

² Press Enter on the keyboard.
The new name for the GOOSE application is applied.

Renaming a GOOSE Application in the Properties Window
To rename a GOOSE application in the Properties window, proceed as follows:
² Select the GOOSE application that you want to rename in the GOOSE message editor.

² Enter a new name for the GOOSE application in the Name text box of the Properties window.

² Press Enter on the keyboard or click outside the text box.
The new name for the GOOSE application is applied.

ii
NOTE
The Name must start with a letter and can only consist of letters, numbers, and underscore (_).

Selecting or Creating a Communication Profile

The communication profile decides at which time interval a GOOSE message is repeated with a spontaneous
change or in the cyclical operation. A GOOSE application is assigned a communication profile with a low
communication rate by default (PriorityLow). For third-party devices, this is set to PriorityDetailedSettings.
The following option is available for changing the communication profile:
² You can select one of the three predefined communication profiles: PriorityLow, PriorityMedium, or

PriorityHigh.

ii
NOTE
Set the communication profiles in a targeted manner. Only select a communication profile with a high
communication rate for time-critical events. If you assign a high communication rate to all GOOSE applica-
tions together, this can result in the loss of overall system performance.

2.14.4

2.14.5

Working with IEC 61850 Station
2.14 GOOSE View

44 Software, System Configurator, Manual
E50417-H1140-C520-B1, Edition 06.2019



Selecting a Predefined Communication Profile

² Select the GOOSE application from the GOOSE editor.

² In the Properties window, select the name of the desired communication profile from the GOOSE
parameters group.

The values for Minimum monitoring time and Maximum monitoring time are updated accordingly for the
following communication profiles:
Communication Profile Minimum Monitoring Time Maximum Monitoring Time
Priority Low 10 ms 2000 ms
Priority Medium 4 ms 1000 ms
Priority High 1 ms 500 ms

ii
NOTE
It is possible to use a user-defined communication profile.

ii
NOTE
All GOOSE connections within a GOOSE application use the same communication profile. It is therefore
recommended to combine GOOSE connections in different GOOSE applications according to their priority.
By default, all GOOSE datasets within the GOOSE application inherits the global settings. It is however
possible to customize it for the each GOOSE control block.

Adding and Deleting the Datasets

Datasets can be added to the GOOSE application and deleted from the GOOSE application.

Adding a Dataset
To add a dataset, proceed as follows:
² Select a signal from Source catalog window.

- or -

² Press the SHIFT key continuously as well as the down arrow to select multiple signals.

² Drag and drop the signals to the GOOSE application or station.

ii
NOTE
A GOOSE control block is created automatically with the GOOSE dataset.

ii
NOTE
The maximum permissible dataset size is based on its service capabilities.

Deleting a Dataset
To delete a dataset from a GOOSE application, proceed as follows:
² Select the dataset from a GOOSE application.

² Click Edit > Delete from menu bar.
- or -

² Click  on the toolbar.
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- or -

² Right-click the dataset and select Delete from the context menu.
- or -

² Press Delete on the keyboard.
Delete items dialog is displayed.
² Click Yes to delete the dataset or click No to abort the operation.

Renaming the Dataset

Following the insertion, the name of the dataset consists of a hierarchical path name and a consecutively
numbered name such as Dataset_1, Dataset_2, and so on. You can change the path name and the name of
the dataset independently.

Changing the Name of the Dataset
To change the name of the dataset, proceed as follows:
² Select the dataset from the GOOSE messages window.

² Enter the name for the dataset in the Name text box in the Properties window.

ii
NOTE
Special characters are not allowed in the Name text box according to IEC 61850-6 scheme.

² Press Enter on the keyboard or click outside the text box.
The entered name is accepted in the GOOSE messages window.

Moving the Dataset

To move the dataset from one GOOSE application to another, proceed as follows:
² Select the dataset from the GOOSE messages window.

² Drag and drop the dataset from one GOOSE application to another GOOSE application.
- or -

² Cut the dataset from the GOOSE application. You can perform this operation in any of the following
ways:
- Select Edit > Cut on the menu bar.
- Select  on the toolbar.
- Right-click the dataset and select Cut from the context menu.

² Select the GOOSE application where you want to move the dataset.

² Paste the dataset to the selected GOOSE application. You can perform this operation in any of the
following ways:
- Select Edit > Paste on the menu bar.
- Select  on the toolbar.
- Right-click the GOOSE application where you want to move the dataset and select Paste from the
context menu.

The dataset is moved to the selected GOOSE application.

2.14.7
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Adding a Signal to the Dataset

To add additional signals to the created dataset, proceed as follows:
² Select additional signals from the Source catalog window.

² Press the SHIFT key continuously as well as the down arrow to select multiple signals.

² Drag and drop the signal to the GOOSE dataset.

ii
NOTE
Drag and drop of a data object to the GOOSE application level creates a new dataset. To improve the band-
width, drag and drop the data object directly to an existing dataset.

For additional information on changing signal properties, refer to 7.17 GOOSE Link.

Changing the Properties of a GOOSE Control Block

To change the properties of a GOOSE control block, proceed as follows:
² Select the Dataset from the GOOSE Editor whose properties you want to set.

² In the Properties window, click  for Configuration in the Parameter group.

Configuration dialog is displayed.
² Change the settings to meet your requirements.
For additional information on changing the configuration of the Dataset, refer to 7.16 Dataset.

ii
NOTE
For inherited attributes that have been changed, an information is displayed that there is a difference from
the GOOSE application.

Selecting or Deselecting a Dataset for the Subnet

Each subnet is displayed as a column in the GOOSE editor. You can select on which subnet the IED should
send the GOOSE telegram. The available options depend on which subnet the IED access point is configured.
You can select several subnets if the same GOOSE telegram is available on several communication modules.
To perform this, the access point of the IED has to be connected with the concerned subnet.

• In the Network view, the Ethernet interface is connected with the subnet concerned.

• At least one GOOSE application exists in the GOOSE editor.

Selecting or Deselecting a Dataset for a Subnet

² Open the GOOSE editor that contains the dataset in GOOSE messages window.

² If you want to select the dataset for a subnet, select the check box in the cell linking the dataset line and
the subnet column.
By default, the subnet used by the first access point of the IED is selected.

² If you want to deselect the dataset from a subnet, clear the check box in the cell linking the dataset line
and subnet column.

2.14.9
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Copying a GOOSE Dataset across IEDs

ii
NOTE
IEDs are usually configured as typicals and instantiated several times. It is then useful not to re-engineer all
the IEDs manually.

To copy the GOOSE dataset across IEDs, proceed as follows:
² Select the GOOSE dataset in the GOOSE editor.

² Right-click the dataset and select Copy from the context menu.
- or -

² Click Edit on the menu bar and select Copy option.
- or -

² Press Ctrl+C on the keyboard.

² Right-click the GOOSE application in the GOOSE messages window or the device in the Source catalog
where you want to paste the dataset and select Paste GOOSE Configuration.

The Paste GOOSE Configuration dialog is displayed.
² Select the Target IED and the Logical Device (LD) correspondingly from the list box.

ii
NOTE
The Target IED is displayed in the Paste GOOSE Configuration dialog, if you paste the dataset in the
Source catalog.

² Click Paste.

ii
NOTE
The GOOSE control blocks are copied and the MAC addresses are incremented.

Copying all GOOSE Datasets across IEDs

ii
NOTE
IEDs are configured as typicals and instantiated several times. It is then useful not to re-engineer all the
IEDs manually.

To copy all the GOOSE datasets across IEDs, proceed as follows:
² Select an IED from the Source catalog.

² Right-click the IED and select the Copy option from the context menu.
- or -

² Click Edit in the menu bar and select the Copy option.
- or -

² Press Ctrl+C on the keyboard.

² Right-click the IED from the Source catalog where you want to paste the GOOSE datasets and select
Paste.

The GOOSE datasets get pasted to the IED.
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Generating the GOOSE Connection

A GOOSE link consists of a signal as the source and at least a Logical node or a Data object as the destination.
Links are always created within GOOSE applications.
For linking a source signal to a target node, the following rules apply:

• You can connect one source signal to several destination nodes.

• A signal can only be used in precisely one GOOSE application as a source signal.

• The source signal and the destination node must always be located on different devices. You cannot
connect a source signal to a destination node from the same device.

The links are also grouped into datasets within a GOOSE application.
You can connect a source signal to a destination node manually in the GOOSE editor by drag and drop if the
CDC (Common Data Class) matches. This is applicable only to EN100. Other devices are mapped at LN level
and thus no CDC check is performed. The mapping is then done at the data attribute group level which usually
consists of the following:

• Status stVal and quality q

• Selected position stSled and quality q

• General trip and quality q

• Measurement mag.f and quality q

ii
NOTE
The field Name (ldName) is enabled for Edition-2 stations if the IED defines the appropriate service capabili-
ties.
When the IED publisher uses the ldName for the published dataset, the GOOSE subscriptions can be config-
ured based on the service capabilities of the IED subscriber.

To connect a source signal to a destination signal manually, proceed as follows:
² Select a destination signal in the Destination catalog.

² Hold down the mouse button and drag the selection onto the line containing the source signal in the
GOOSE editor.

If insertion is not allowed at this position, the mouse pointer changes to a crossed-out circle and the corre-
sponding message is displayed in the tooltip.

ii
NOTE
For devices with EN100 and later binding, insertion is allowed at DA group level and for other devices,
insertion is allowed at DO level and dataset level.
If the signal is inserted at dataset level, then the selected destination signal will be connected for all the
source signals of the dataset.
To subscribe the SIPROTEC 5 or Edition 2.1 later binding data object, both the publisher and the subscriber
must have the same basic type attribute in the data object.

² Release the mouse button at a permissible position.
The selected destination signals are connected to the source signals.

ii
NOTE
If the selected destination signal cannot be connected to the source signal or if it has already been
connected, change the selection.

2.14.14
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ii
NOTE

GOOSE links of subscriber type are represented by  and GOOSE links of publisher type are represented by
 in the GOOSE messages window.

ii
NOTE
To support the plug and play feature, the destination signals will not be deleted if the configured destina-
tion signals do not have a publisher IED in the station. If you want to delete the configured destination
signal, click the  button to remove it from the device.
When the publisher IED is imported to the station, the configured destination signals will be automatically
mapped to the publisher configuration.

Copying the GOOSE Subscribers across IEDs

ii
NOTE
Central functions may require several IEDs to subscribe to the same GOOSE signals.

To copy all the GOOSE subscriptions across IEDs, proceed as follows:
² Select an IED/LD/LN from the Destination catalog.

² Right-click the IED/LD/LN and select the Copy option from the context menu.
- or -

² Click Edit in the menu bar and select the Copy option.
- or -

² Press Ctrl+C on the keyboard.

² Right-click the IED/LD/LN from the Destination catalog where you want to paste the GOOSE subscrip-
tions and select Paste.

The GOOSE subscriptions get pasted to the IED.

ii
NOTE
You can copy and paste only at the same level. For example, if you copy an IED, it can only be pasted onto
another IED.
While copying, all the sublevels below the copied IED/LD/LN are also copied.
If the subscribers are copied from SIPROTEC 5 or third-party devices, they cannot be pasted to a SIPROTEC 4
device.
If a signal is not pasted, it is displayed in the reporter window.
Later binding subscribers cannot be copied.

Changing the GOOSE Connection

Various options are available for changing an existing GOOSE connection in the GOOSE editor.

• You can connect the same source signal to multiple destination nodes.

• You can replace the current destination node with another destination node in the case of a source signal
that has already been connected.
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Connecting a Source Signal to an Additional Destination Node

² Select the new destination node in the Destination catalog.

² Hold down the mouse button and drag the destination node to the GOOSE connection to be changed in
the GOOSE messages window.

If insertion is not allowed at this position, the mouse pointer changes to a crossed-out circle.
² Release the mouse button at a permissible position.
The selected destination node is also connected to the source signal.

Replacing Existing Destination Nodes with a Different Node

² Select the new destination node in the Destination catalog.

² Hold down the mouse button and drag the destination node to the GOOSE connection to be changed in
the GOOSE messages window.

If insertion is not allowed at this position, the mouse pointer changes to a crossed-out circle.
² Release the mouse button at a permissible position.
A confirmation prompt is displayed.
² Click Yes.
The selected destination node replaces the existing node.

ii
NOTE
If you click No in the confirmation prompt, the destination node is added to the source signal.

Deleting a GOOSE Connection
To delete a GOOSE connection from a dataset, proceed as follows:
² Select the GOOSE connection from the dataset.

² Click Edit > Delete from the menu bar.
- or -

² Click  in the toolbar.

- or -

² Right-click the GOOSE connection and select Delete from the context menu.
- or -

² Press Delete on the keyboard.
The Delete items dialog is displayed.
² Click Yes to delete the GOOSE connection or click No to cancel the operation.

ii
NOTE

Once the destination signal is configured, the corresponding signal is marked with a red cross ( ) in the
Destination catalog indicating that it cannot be configured as a destination signal again.

ii
NOTE
Only the devices with GOOSE capabilities are displayed in the catalogs.
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ii
NOTE
If you delete a configured destination node for a later binding device, its predefined data objects and data
attributes are also deleted. To restore the predefined configuration, update the device.

Creating a GOOSE Configuration via a Predefined Configuration

To create a GOOSE configuration via a predefined configuration, proceed as follows:
² Select a station from the GOOSE messages Editor.

² Right-click the station and select GOOSE Application from Template > VoltageControlParallelMaster-
Follower from the context menu.
The GOOSE configuration is created in the station.
The configuration is created from the predefined XML file and from the substation configuration.

To create a substation configuration, proceed as follows:
² In the Substation view, create a substation.

For more information on creating a substation, refer to 2.12.3.1 Inserting a Substation.

² Right-click the Bay node and select Function from the context menu.
A function is created under the bay node.

² You can double-click the newly created function and rename it to VoltageControlParallel.
² Drag and drop the ATCC LN from the Source catalog to the newly created function.

The IED from which the ATCC LN was configured, will become a publisher.

² Right-click the newly created function and select Sub Function from the context menu.
A subfunction is created under the function.

² If you want, you can double-click the newly created subfunction and rename it to Proxies.

² Drag and drop the ATCC LN from the Source catalog to the newly created subfunction.
The IED from which the ATCC LN was configured, will become a subscriber.

To create a predefined substation configuration, proceed as follows:
² In the Substation view, select any node.

² Right-click the selected node and select Templates > <Template name> from the context menu.
The respective configuration will be created according to the predefined XML file under the selected
node.

² Drag and drop the ATCC LN from the Source catalog to the function.
The IED from which the ATCC LN was configured, will become a publisher.

² Drag and drop the ATCC LN from the Source catalog to the subfunction.
The IED from which the ATCC LN was configured, will become a subscriber.

Reassigning the Virtual MAC Address

To reassign virtual MAC address, proceed as follows:
² Select an IEC 61850 station from GOOSE messages editor.

² Right-click the IEC 61850 station and select Reassigning virtual MAC addresses from the context
menu.
- or -

² Click  on the toolbar.

- or -

2.14.17
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² Click Edit menu and select Reassigning virtual MAC addresses from the menu option.
Overwrite existing MAC addresses dialog is displayed.
² Click Yes to reassign the virtual MAC address for all GOOSE messages of the station or click No to abort

the operation and then click OK.

ii
NOTE
Reassigning virtual MAC address allows all the addresses to be unique and changes the MAC address for
other station devices. It also increases the performance at GOOSE subscriber side.

ii
NOTE
Reassigning virtual MAC address is not applicable for devices imported through SED.

Selecting the Dataset for SED Export

With files in SED format (System Exchange Description), you can exchange information among several
IEC 61850 stations. If a dataset and the signals contained within it should be part of an SED export, select the
dataset for the SED export.
² Select the dataset from the GOOSE application in the GOOSE editor.

² Select Yes from the list box for Include in SED export in the Parameter group in the Properties window.
The dataset is included in the export file during an SED export.

ii
NOTE
An Edition 2 station can export an Edition 1 or 2 SED file, but an Edition 1 station can only export an
Edition 1 SED file.

GOOSE Supervision

IEC 61850-7-4 Edition 2 introduced the LN (logical node) LGOS to analyze the subscription state of a published
GOOSE indication.

Configuring GOOSE Supervision while Creating the Subscriber
To create the GOOSE supervision while configuring the subscriber device with LGOS capability, proceed as
follows:
² Select a destination signal in the Destination catalog in the GOOSE editor.

² Drag and drop the selected destination signal onto the line containing the source signal in the GOOSE
editor.

The Subscriber device is configured with the GOOSE supervision reference under the available free LN LGOS.
² Select the GOOSE link.
The supervision information is displayed in the properties of the GOOSE link. Under GOOSE Supervision, the
Hierarchical path displays the supervision path in the following order:
Devicename/LDInst/LNPrefix+LGOS+LNInst

2.14.19
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[sc_iec_gooselink_properties, 1, en_US]

The configured LGOS is marked with a red cross in the destination catalog. Selecting the marked LGOS, you
can view the Supervised GSEControl and Supervised dataset values for the configured subscriber device in
the properties of the Supervised GOOSE table.

ii
NOTE
If no free LGOS is available, you can create a new LGOS for SIP5 devices up to the maximum allowed capa-
bility. For third-party devices, an automatic creation of a new LGOS logical node is not possible.

Configuring GOOSE Supervision at Station Level
To create the GOOSE supervision for all configured subscription devices with LGOS capability, proceed as
follows:
² Open the GOOSE editor.

² Right-click the station and select Create Supervision from the context menu.
The GOOSE supervision is configured for all GOOSE links with LGOS capability. Selecting the Dataset, the
supervision path under GOOSE Supervision is displayed in the Table with IED and GOOSE supervision path
in the properties.

[sc_iec_station_properties, 1, en_US]

The used LGOS is marked with a red cross in the Destination catalog. Selecting this marked LGOS, you can
view the Supervised GSEControl and Supervised dataset values for the configured subscriber device in the
properties of the Supervised GOOSE table.
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[sc_iec_LGOS_properties, 1, en_US]

ii
NOTE
If no free LGOS is available, you can create a new LGOS for SIP5 devices up to the maximum allowed capa-
bility. For third-party devices, an automatic creation of a new LN LGOS is not possible.
A warning message is displayed in the Report window for the subscription without supervision capability.

Modifying GOOSE Supervision
To modify the configured GOOSE Supervision LGOS, proceed as follows:
² Open the GOOSE editor.

² Select the GOOSE link.
- or -

² Select the dataset.
The supervision information is displayed in the properties of the GOOSE link or the dataset.
Selecting GOOSE link, the Hierarchical path under GOOSE Supervision displays the supervision path in the
following order:
Devicename/LDInst/LNPrefix+LGOS+LNInst

[sc_iec_LGOS_modify_GOOSElink, 1, en_US]

Selecting the dataset, the supervision path under GOOSE Supervision is displayed under Table with IED and
GOOSE supervision path in the properties.
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[sc_iec_LGOS_modify_dataset, 1, en_US]

² Open the list box for the Hierarchical path under GOOSE Supervision in the properties of the GOOSE
link to view and select the available LGOS.

The GOOSE supervision is configured to the newly selected LGOS and the old LGOS supervision is set to free.

Unlinking GOOSE Supervision for a GOOSE Link
To unlink the GOOSE supervision for a subscriber, proceed as follows:
² Open the GOOSE editor.

² Right-click the GOOSE link.

² Select the option Unlink Supervision from the context menu.

² Click Yes.
The GOOSE supervision is removed for the subscriber device. The indication Not configured is displayed in the
text box for the Hierarchical path under GOOSE Supervision. The red cross is removed for the respective LGOS
LN in the Destination catalog.

ii
NOTE
The option Unlink Supervision is not available for the GOOSE link for the subscriber device without LGOS
capability or if the LGOS is not configured.

Unlinking GOOSE Supervision for a Dataset
Unlink the GOOSE supervision for a subscriber, proceed as follows:
² Open the GOOSE editor.

² Right-click the dataset.

² Select the option Unlink Supervision from the context menu.

² Click Yes.
The GOOSE supervision is removed for all subscribers. The indication Not configured is displayed in the text
box for all parameters under Table with IED and GOOSE supervision path in the properties. The red cross is
removed for the respective LGOS LNs in the Destination catalog.
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ii
NOTE
The option Unlink Supervision is not available for the dataset even if one of the subscriber devices has the
LGOS capability or if the LGOS is configured.
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SMV View

Overview of Sample Value Communication

IEC 61850 uses the sampled value (SMV) to transmit the sampled measured values between the merging unit
and the bay devices.

Opening the SMV Editor

To open the SMV editor, proceed as follows:
² Click View > SMV on the menu bar.

- or -

² Click SMV on the IEC 61850 System configurator bar.
- or -

² Press Ctrl+4 on the keyboard.
SMV editor is displayed and it consists of the following windows:

• SMV messages

• Source catalog

• Destination catalog

• Properties
For additional information on these windows, refer to 8.4.5.1 SMV Editor.

Adding and Deleting the SMV Application

Adding an SMV Application
To add an SMV application for a station in the SMV Editor, proceed as follows:
² Select the IEC 61850 station.

² Click Insert > SMV application from the menu bar.

² Click  in the toolbar.

² Right-click the station and select SMV application from the context menu.
An SMV application is added to the station.

Deleting an SMV Application
To delete an SMV application from a station in the SMV Editor, proceed as follows:
² Select the SMV application and click Edit > Delete from the menu bar.

- or -

² Select the SMV application and click  in the toolbar.

- or -

² Right-click the SMV application and select Delete from the context menu.
- or -

² Select the SMV application and press Delete on the keyboard.
The Delete items dialog is displayed.

2.15
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² Click Yes to delete the SMV application or No to cancel the operation.

ii
NOTE
An SMV application cannot be deleted, if any dataset assigned to it has service capabilities enabled.

Renaming the SMV Application

To rename the SMV application in the SMV messages window, proceed as follows:
² Select the SMV application you want to rename.

² Double-click the SMV application.
- or -

² Press F2 on the keyboard.

² Enter a new name for the SMV application.

² Press Enter on the keyboard.
The new name for the SMV application is applied.

Renaming the SMV Application in the Properties Window
To rename the SMV application in the Properties window, proceed as follows:
² Select the SMV application in the SMV messages window that you want to rename.

² Enter a new name for the SMV application in the Name text box of the Properties window.

² Press Enter on the keyboard or click outside the text box.
The new name for the SMV application is applied.

ii
NOTE
The Name must start with a letter and can only consist of letters, numbers, and underscore (_).

Adding and Deleting the Datasets

Datasets can be added to the SMV application and deleted from the SMV application.

Adding a Dataset
To add a dataset, proceed as follows:
² Select a signal from the Source catalog window.

² Drag and drop the signals on to the SMV application or station.

ii
NOTE
An SMV control block is created automatically with the SMV dataset.

ii
NOTE
The maximum number of datasets and SMV control blocks which can be created is defined by the service
capabilities of the IED.
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Deleting a Dataset
To delete a dataset from an SMV application, proceed as follows:
² Select the dataset from an SMV application.

² Click Edit > Delete from the menu bar.
- or -

² Click  on the toolbar.

- or -

² Right-click the dataset and select Delete from the context menu.
- or -

² Press Delete on the keyboard.
The Delete items dialog is displayed.
² Click Yes to delete the dataset or click No to cancel the operation.

Renaming the Dataset

To rename the dataset, proceed as follows:
² Select the dataset from the SMV messages window.

² Enter the name for the dataset in the Name text box in the Properties window.

ii
NOTE
Special characters are not allowed in the Name text box according to IEC 61850-6 scheme.

² Press Enter on the keyboard or click outside the text box.
The entered name is accepted in the SMV messages window.

Moving the Dataset

To move the dataset from one SMV application to another, proceed as follows:
² Select the dataset from the SMV messages window.

² Drag and drop the dataset from one SMV application to another SMV application.
- or -

² Cut the dataset from the SMV application. You can perform this operation in any of the following ways:
- Select Edit > Cut from the menu bar.
- Select  in the toolbar.
- Right-click the dataset and select Cut from the context menu.

² Select the SMV application where you want to paste the dataset.

² Paste the dataset to the selected SMV application. You can perform this operation in any of the following
ways:
- Select Edit > Paste from the menu bar.
- Select  in the toolbar.
- Right-click the SMV application where you want to paste the dataset and select Paste from the context
menu.

The dataset is moved to the selected SMV application.
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Adding a Signal to the Dataset

To add signals to the created dataset, proceed as follows:
² Select signals from the Source catalog window.

² Press the SHIFT key continuously as well as the down arrow to select multiple signals.
- or -

² Hold Ctrl and select the desired signals from the Source catalog window.

² Drag and drop the signal to the SMV dataset.

ii
NOTE
Dragging and dropping of a data object to the SMV application level creates a new dataset. To improve the
bandwidth, drag and drop the data object directly to an existing dataset.

For additional information on changing signal properties, refer to 7.17 GOOSE Link.

Changing the Properties of an SMV Control Block

To change the properties of an SMV control block, proceed as follows:
² Select the Dataset from the SMV editor whose properties you want to set.

² In the Properties window, click  for Configuration in the Parameter group.

Configuration dialog is displayed.
² Change the settings to meet your requirements.
For additional information on changing the configuration of the Dataset, refer to 7.16 Dataset

Selecting or Deselecting a Dataset for a Subnet

In the SMV editor, there is an SMV messages window containing a column with the name of the subnet for
every subnet that has been assigned within the Network view. Each column contains check box for each
dataset. With this check box, you specify whether a dataset and the signals contained within it should be
transmitted over the subnet. Only complete datasets can be selected or deselected and not individual signals.
If the check box is selected, the dataset is transmitted via the subnet. If the check box is cleared, the dataset is
not transmitted via the subnet.
So to select a subnet for a dataset, the following prerequisites must be fulfilled:

• In the Network view, the Ethernet interface is connected with the subnet concerned.

• At least one SMV application exists in the SMV editor.

Selecting or Deselecting a Dataset for a Subnet

² Open the SMV editor that contains the dataset in SMV messages window.

² Select the check box in the cell linking the dataset line and the subnet column, to select the dataset for a
subnet,

By default, the subnet used by the first access point of the IED is selected.
² If you want to deselect the dataset from a subnet, clear the check box in the cell linking the dataset line

and subnet column.
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Generating the SMV Connection

An SMV link consists of a signal as the source and at least a Logical node or a Data object as the destination.
Links are always created within SMV applications.
For linking a source signal to a target node, the following rules apply:

• You can connect one source signal to several destination nodes.

• A signal can only be used in precisely one SMV application as a source signal.

• The source signal and the destination node must always be located on different devices. You cannot
connect a source signal to a destination node from the same device.

• The access point of the source and the destination devices should be in the same subnetwork.
The links are also grouped into datasets within an SMV application.
You can connect a source signal to a destination node manually in the SMV Editor by drag and drop if the CDC
(Common Data Class) matches. Other devices are mapped at LN level and thus no CDC check is performed.
The mapping is then done at the data attribute group level which usually consists of the sampled value
instMag.f and of the quality q.

ii
NOTE
When the IED publisher uses the ldName for the published dataset, the SMV subscriptions can be config-
ured based on the service capabilities of the IED subscriber.

To connect a source signal to a destination signal manually, proceed as follows:
² Select a destination signal in the Destination catalog.

² Drag the selected destination signal onto the line containing the source signal in the SMV editor.
If insertion is not allowed at this position, the mouse pointer changes to a crossed-out circle and the corre-
sponding message is displayed in the tooltip.

ii
NOTE
For devices with later binding, insertion is allowed at data attribute group level and for other devices, inser-
tion is allowed at data object level and at dataset level.

² Release the mouse button at a permissible position.
The selected destination signals are connected to the source signals.

ii
NOTE
If the selected destination signal cannot be connected to the source signal or if it has already been
connected, select another signal.

ii
NOTE

SMV links of subscriber type are represented by  and SMV links of publisher type are represented by 
in the SMV messages window.

ii
NOTE
To support the plug and play feature, the destination signals will not be deleted if the configured destina-
tion signals do not have a publisher IED in the station. If you want to delete the configured destination
signal, click the  button to remove it from the device.
When the publisher IED is imported to the station, the configured destination signals will be automatically
mapped to the publisher configuration.

2.15.11
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Changing the SMV Connection

Various options are available for changing an existing SMV connection in the SMV editor.

• You can connect the same source signal to multiple destination nodes.

• You can replace the current destination node with another destination node in the case of a source signal
that has already been connected.

Connecting a Source Signal to an Additional Destination Node

² Select the new destination node in the Destination catalog.

² Hold down the mouse button and drag the destination node to the SMV connection to be changed in the
SMV messages window.

If insertion is not allowed at this position, the mouse pointer changes to a crossed-out circle.
² Release the mouse button at a permissible position.
The selected destination node is also connected to the source signal.

Replacing Existing Destination Nodes with a Different Node

² Select the new destination node in the Destination catalog.

² Hold down the mouse button and drag the destination node to the SMV connection to be changed in the
SMV messages window.

If insertion is not allowed at this position, the mouse pointer changes to a crossed-out circle.
² Release the mouse button at a permissible position.
A confirmation prompt is displayed.
² Click Yes.
The selected destination node replaces the existing node.

ii
NOTE
If you click No on the confirmation prompt, the destination node is added to the source signal.

ii
NOTE
Once the destination data-object signal is configured, the corresponding signal is marked with a crossed-
out symbol in the Destination catalog indicating that the connection is established and that it cannot be
configured as a destination signal again.
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Reports and Logs View

Overview of Reports and Logs

Devices support data transmission between server and client in the form of reports and logs.
A report is comparable to indications list. Changes to indications or measured values, for example, by raising
or clearing protection trigger are immediately transmitted from the server to the client. Therefore, the client
does not have to make cyclical queries in the server as is the case in serial protocols. Instead, the client is auto-
matically informed about an event.
You can use Report and logs Editor to add datasets. Datasets group individual signals together. The signals
combined in datasets can subsequently be assigned to various report control blocks. It is possible to assign one
dataset to several report control blocks.

ii
NOTE
This editor is for the use of static reporting. By default, dynamic reporting is commonly used in Siemens
portfolio. This does not require any engineering in Reports and Logs editor.

Opening the Reports and Logs Editor

To open the Reports and logs editor, proceed as follows:
² Click View > Reports and logs on the menu bar.

- or -

² Click Reports and logs editor on the IEC 61850 System Configurator.
- or -

² Press Ctrl+5 on the keyboard.
Reports and logs editor is displayed and it consists of the following windows:

• Applications

• Dataset content

• Report and Log control blocks

• Source catalog

• Clients

• Properties
For additional information on these windows, refer to 8.4.6.1 Reports and Logs Editor.

Adding and Deleting the Datasets

Adding a Dataset

² Select a device in Applications window in the Reports and logs editor.

² Click Insert > Dataset on the menu bar.
- or -

² Click  on the toolbar.

- or -

² Right-click the device and select insert dataset from the context menu.

2.16
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This inserts the empty dataset to the device.

Deleting a Dataset

² Select the dataset from Applications window in the Reports and logs editor.

² Click Edit > Delete on the menu bar.
- or -

² Click  on the toolbar.

- or -

² Right-click the dataset and select Delete from the context menu.
- or -

² Press Delete on the keyboard.
Delete items dialog is displayed.
² Click Yes to delete the selected dataset or click No to abort this operation.

Renaming the Dataset

Following the insertion, the name of a dataset consists of a hierarchical path name and a consecutively
numbered name such as Dataset_1,Dataset_2, and so on. You can change the path name and the name of the
dataset independently.

Changing the Hierarchical Path
To change the hierarchical path for the dataset, proceed as follows:
² Select the dataset in the Applications window in Reports and logs editor.

² Select the desired path from the Hierarchical path list box.
To do this, open a logical device (LD) within the list box and then double-click the name of a logical node
(LLN0).
The selected path is accepted in the Applications window.

Changing the Name of a Dataset
To change the name of a dataset, proceed as follows:
² Select the dataset in the Applications window in Reports and logs editor.

² Enter the name for the dataset in the Name text box in the Properties window.

² Press Enter on the keyboard or click outside the text box.
The entered name is accepted in the Reports and logs editor.

ii
NOTE
Special characters are not allowed in the Name text box according to IEC 61850-6 scheme.

Adding a Signal to the Dataset

Datasets group individual signals. You can add the same signal to several different datasets. However, you
cannot add a signal to a dataset more than once.
To add a signal using drag and drop option, proceed as follows:
² Select a signal from the Source catalog.

2.16.4
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² Hold down the mouse button and drag the selection to the name of the dataset in the Applications
window or on to the Dataset content window.

ii
NOTE
If you want to drag the signal from Source catalog to Dataset content window, select the dataset from
the Applications window before you perform this action.

For additional information on property values of a dataset, refer to 7.16 Dataset.

Adding or Deleting a Report Control Block

To generate and send a report at runtime, add a report control block for the datasets.

Adding a Report Control Block
To add a report control block, proceed as follows:
² Select a dataset under a device which has the Insert report button enabled from the Project tree

window in the Reports and logs Editor.

² Right-click the selected dataset or the Dataset content window or the Report and Log control blocks
window and select Insert report from the context menu.
- or -

² Click  on the toolbar.

- or -

² Click Insert > Insert report from the menu bar.
A new report is configured according to the selected dataset and added to the Report and Log control blocks
window. The name consists of a hierarchical path name and a consecutively numbered default name.
To use the signals in more than one client, several Report Control Blocks are required. The report control
blocks can be new or you can instantiate it by setting the maximum value in the Supported clients property
field.

Deleting a Report Control Block
To delete report control block from Report and Log control blocks, proceed as follows:
² Select the report control block to be deleted from Report and Log control blocks window.

- or -

² Right-click the selected report control block and select Delete from the context menu.

² Click Edit > Delete from the menu bar.
- or -

² Click  on the toolbar.

- or -

² Press Delete on the keyboard.
Delete items dialog is displayed.
² Click Yes to delete the report control block or click No to cancel this operation.

Adding or Deleting a Log Control Block

To generate and send a log at runtime, add a log control block for the datasets.

2.16.6
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Adding a Log Control Block
To add a log control block, proceed as follows:
² In Reports and logs editor, in the Project tree, select a dataset under a device which has the Insert log

button enabled.

² Right-click the selected dataset and select Insert log from the context menu.
- or -

² Right-click in the Dataset content window and select Insert log from the context menu.
- or -

² Right-click in the Report and Log control blocks window and select Insert log from the context menu.
- or -

² Click  in the toolbar.

- or -

² Click Insert > Insert log from the menu bar.
A log is configured according to the selected dataset and displayed in the Report and Log control blocks
window. The name consists of a hierarchical path name and a consecutively numbered default name.

ii
NOTE
You cannot create a log control block in the following cases:

• If the ConfLogcontrol or the maximum attribute is not present in the service section.

• If the ConfLogcontrol maximum is 0 in the service section.

• If the log control block has reached its maximum count.

Deleting a Log Control Block
To delete a log control block from the Report and Log control blocks, proceed as follows:
² Select the log control block to be deleted from the Report and Log control blocks window.

² Click Edit > Delete from the menu bar.
- or -

² Click  in the toolbar.

- or -

² Right-click the log control block that you want to delete and select Delete from the context menu.
- or -

² Press Delete on the keyboard.
The Delete items dialog is displayed.
² Click Yes to delete the log control block or click No to cancel this operation.

Changing the Properties of a Report

To change the properties of a report, proceed as follows:
² Select the report control block whose properties you want to change in the Reports and Log control

blocks window.

² Select the properties required for sending a report in the Trigger options group in Properties window.

2.16.8
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For additional information on selecting trigger options and optional fields for sending a Report, refer to
7.23 Report Control Blocks.

Changing the Properties of a Log

To change the properties of a log, proceed as follows:
² Select the log control block whose properties you want to change in the Reports and Log control blocks

window.

² Select the properties required for sending a log in the Trigger options group in the Properties window.
For additional information on selecting trigger options and optional fields for sending a log, refer to 7.24  Log
Control Blocks.

Set Parameter Report as Buffered or Unbuffered

The IEC 61850 distinguishes between buffered reports and unbuffered reports. For a buffered report, if the
connection between the server and client is interrupted, changes of indications are saved in the device. Once
the connection is restored, these indications are transmitted to the client with a time stamp.
For an unbuffered report, the changes are lost if the connection is lost. If there is a constant connection
between the client and server, both behaviors appear identical from the user view.
You select as an option in Properties window whether a report is buffered or unbuffered in the applicable
report control block. After inserting a new report control block, the buffered option is set to No by default.
To activate the buffer option in the Properties window, proceed as follows:
² Select the report from the Report and Log control blocks for which you want to activate the buffer

option.

² Select Yes for the Buffer indications in Parameter group in the Properties window.
The Identify information report as buffered dialog is displayed for the devices dependent on the services
section.
² Click OK.

² Enter the buffering time in ms for Buffer time.

² Press Enter or click outside the entry field.
If the value entered is permissible, it is accepted. If the entered value is outside the permissible value range, an
error message is displayed. In this case, correct your input.

Adding the Clients to the Report Control Block

To add clients to the report control blocks, proceed as follows:
² Select the Reports and logs editor.

² Select the dataset from the Applications window.

² Select the logical node from the Clients window.

² Drag and drop the logical node on to the report control in the Report and Log control blocks window.
This operation adds the client to the report control.

2.16.9
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Copying all the Reports and Datasets across IEDs

ii
NOTE
IEDs are configured as typicals and instantiated several times. It is then useful not to re-engineer all the
IEDs manually.

To copy all the reports and datasets across IEDs, proceed as follows:
² Select an IED from the Project tree.

² Right-click the IED and select the Copy option from the context menu.
- or -

² Click Edit in the menu bar and select the Copy option.
- or -

² Press Ctrl+C on the keyboard.

² Right-click the IED from the Project tree where you want to paste the report datasets and select Paste.
All the reports and the associated datasets get pasted to the IED.

2.16.12
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Protocol Mapping View

Overview of Protocol Mapping

The IEC 61850 standard is extended in IEC 61850-80-1 by the assignment of IEC 61850 data model to IEC
60870-5-104. The mapping is done in the IEC 61850 System Configurator.

Opening the Protocol Mapping Editor

To open the Protocol mapping editor, proceed as follows:
² Click View > Protocol mapping on the menu bar.

- or -

² Click Protocol mapping on the IEC 61850 System configurator bar.
- or -

² Press Ctrl+6 on the keyboard.
Protocol mapping editor is displayed along with its elements.
For additional information on the elements of Protocol Mapping editor, refer to 8.4.7.3 Protocol Mapping.

ii
NOTE
If the IED has the signals that are part of static dataset or dynamic reporting with subset of SICAM, only
those signals are displayed in the Protocol mapping window.

Inserting and Deleting the Address

Inserting the T104 Mapping Address
You can insert the T104 address for the data attribute in the protocol mapping window.
To insert the T104 address, proceed as follows:
² Select a row or multiple rows for which you need to add the address in the Protocol mapping editor.

² Click Edit > Insert T104 Address on the menu bar.
- or -

² Click  on the toolbar

- or -

² Right-click a selected row and select Insert T104 Address from the context menu.
This operation adds the T104 mapping address for that data attribute.
The default values for T104 mapping address are as follows:
Elements Default Value
Casdu 1
CASDU1 1
CASDU2 0
IOA No default value.
IOA1 The IOA1, IOA2, and IOA3 value depends on the IOA value.
IOA2
IOA3
Ti No default value. The Ti value depends on the CDC and DA type.
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ii
NOTE
The appropriate T104 address cells (Casdu, IOA, Ti, CASDU1, CASDU2, IOA1, IOA2, and IOA3) are edit-
able.

Deleting the T104 Mapping Address
You can delete the T104 address for the data attribute in the protocol mapping window.
To delete the T104 address, proceed as follows:
² Select a row or multiple rows with T104 address that you want to delete from the Protocol mapping

editor.

² Click Edit > Delete T104 Address on the menu bar.
- or -

² Click  on the toolbar.

- or -

² Right-click a selected row with T104 address and select Delete T104 Address from the context menu.
The Delete items dialog is displayed.

² Click Yes to delete the rows or No to abort the operation.

Inserting T104 Mapping Address in Bulk

ii
NOTE
You can insert the T104 mapping address either with the same value or with the given value.

Inserting T104 Mapping Address with the Same Value
To insert the T104 mapping address in multiple cells in CASDU and IOA columns with the same value, proceed
as follows:
² Select the continuous cells in the CASDU (also CASDU1 and CASDU2) or IOA (also IOA1, IOA2, and IOA3)

column.

² Right-click the cell and select Fill in with the same value from the context menu.
The selected cells are filled with the 1st cell value.

Inserting T104 Mapping Address with the Given Value
To insert the T104 mapping address in multiple cells in CASDU and IOA columns with the given value,
proceed as follows:
² Select the continuous cells in the CASDU (also CASDU1 and CASDU2) or IOA (also IOA1, IOA2, and IOA3)

column.

² Right-click the cell and select Fill in with given value from the context menu.
The Set given value dialog is displayed.
² Enter the value and click Apply.
The cells are filled with the given value.
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ii
NOTE
The value range for any cell in CASDU is between 0 and 65535.
The value range for any cell in IOA is between 0 and 16777215.
The value range for any cell in CASDU1, CASDU2, IOA1, IOA2, and IOA3 is between 0 and 255.

Incrementing the T104 Mapping Address Automatically

To autoincrement the T104 mapping address, proceed as follows:
² Select the continuous cells in the CASDU (also CASDU1 and CASDU2) or IOA (also IOA1, IOA2, and IOA3)

column.

² Right-click the cell and select Auto increment from the context menu.
The Set autoincrement value dialog is displayed.
² Enter the Start value and Increment value.
The first cell is filled with the start value. The following cells takes the value of the previous cell incremented
by the given increment value. This is applicable for all the cells in the selection.

ii
NOTE
If the value exceeds the range, the subsequent cells are not populated.
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Adjusting the View of Editor

Modifying the Window Size

You can adjust the size of all the windows that are part of the editor.
To modify the size of the window, proceed as follows:
² Move the mouse pointer until you reach the separating line.

² Click the Separating line and with the mouse button pressed, drag it to the left or right.

² Release the mouse button when you reach the desired width or length.

Showing or Hiding the Windows

To hide the window in editor, proceed as follows:
² Click the pin on the right top corner of the window.
The window is minimized.
² To view the window, click the minimized window and click the pin in the right top corner of the window.

ii
NOTE
The settings are saved in the project and they are used when the project is opened again.
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SCL-Files Comparator
This feature is used to compare SCL files and IEC 61850 project archives, to analyze the differences between
them.
To compare the 2 files, proceed as follows:
² Click Tools > SCL files comparator in the menu bar.

The SCL files comparator dialog is displayed.
If a project is already opened, its SCD path is displayed in the SCL file Old field.

[sc_SCL_comp, 2, en_US]

Figure 2-6 SCL Comparator - Open Project

² Click .
The Select file to compare dialog is displayed.
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[sc_SCL_Select_file, 1, en_US]

Figure 2-7 SCL-File Select

² Navigate to the desired location and select the file.
The supported file types are *.cid, *.icd, *.iid, *.scd, *.sed, *ssd, and *.sz

² Click Open.
The file name is displayed in the SCL file Old field.

² Repeat these steps for the file in the SCL file New field.

[sc_SCL_Compare, 2, en_US]

Figure 2-8 SCL Comparator
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² Click Compare.
The SCL files comparator window is displayed.

[sc_SCL_Result, 3, en_US]

Figure 2-9 SCL-File Comparison

The SCL files comparator window displays the comparison result between the 2 SCL files, side by side.

SCL-Files Comparator Window Toolbar
The toolbar contains commands that are frequently required for your work.
Field/Icons Name Description

Open Opens the SCL files comparator dialog

Refresh Refreshs the window, to display the changes made in the files

Expand all Expands the selected node

Collapse all Collapses the selected node

Client update Displays the comparison result of devices that require updates in SICAM

Subscriber
update

Displays the comparison result of subscriber devices that require updates

SCL-Files Comparator Window Indicators
The different indicators are used to indicate the difference between the 2 compared files.
Indicator Description

Attribute modified

Attribute added/Attribute deleted

No icon Content modified
Node added/Node deleted

Nodes in sync
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Indicator Description
The tooltip of this icon displays the compliance percentage between the 2 SCL
files. It also displays the Matching, Missing, and Added data models (LN, LD,
DO, DA) and the following communications of the IEDs:

• GOOSE
• GOOSE attributes
• SMV
• SMV attributes
• Report
• Report attributes
• LD name
SICAM client update required

Subscriber device update required

SICAM client update recommended
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Export and Import

ii
NOTE
Save the station before starting any exports.

3.1 Exporting Data 80
3.2 Importing Data 84

3
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Exporting Data

Exporting IEC 61850 Documentation as XML Data

To export IEC 61850 documentation as an XML data, proceed as follows:
² Click Station > Export from the menu bar and select IEC 61850 documentation as XML file from the

submenu options.
- or -

² Press Ctrl+M on the keyboard.
The Documentation-IEC61850-Station dialog is displayed.
² Navigate to the location and enter the name for the XML file.

² Click Save.
The station information is saved as an XML file in the preferred location and can be opened by any Web
browser.

ii
NOTE
Keep the XSLT and the CSS file in the same location as the XML file to display them in the Web browser.

Exporting IEC 61850 Station (SCD, SED, SSD)

To export the IEC 61850 station, proceed as follows:
² Click Station > Export from the menu bar and select IEC 61850 station from the submenu options.

The Export IEC Station dialog is displayed.

² Enter a File name.

² Click , browse, and select a File path.

² Select a File type from the list box.

ii
NOTE
To export an IEC station as a configured communication description, refer to 3.1.4 Exporting a Configured
Communication Description .

² Select the SCL schema (SCL 2003, SCL 2007B, SCL 2007B4) from the list box.

ii
NOTE
The default SCL schema is based on the station edition.

² You can enter a comment for future reference, in the Comment field.

² Click Export.
The station is exported to the preferred location.
The exported SCD file can be imported to other applications like SICAM PAS.

ii
NOTE
Edition 1 and Edition 2 SCD files can be exported from the Edition 2.1 station to support backward compati-
bility of mixed substations.

3.1

3.1.1

3.1.2
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Exporting IEC 61850 Station with an Alternative Text
When you export the station with an alternative text, the source language is English because of non-cyrillic
alphabets, which are potentially not supported by some of the IEC 61850 clients.
To export the IEC 61850 station with an alternative text, proceed as follows:
² Click Station > Export from the menu bar and select IEC 61850 station with alternative text from the

submenu options.
The Export IEC 61850 station dialog is displayed.
² Navigate to the location and enter the file name for the station.

² Click Save.
The station is exported in the English language and to the preferred location.

ii
NOTE
This feature is available only in Russian and Chinese in DIGSI 4 and if it is activated in DIGSI 5.

Exporting IEC 61850 Device Configuration (CID, ICD, IID)

To export the device configuration, proceed as follows:
² Select one or multiple devices from the Devices editor.

² Click Station > Export on the menu bar and select Export IEC 61850 device configuration from the
submenu options.
- or -

² Right-click a selected device and select Export IEC 61850 device configuration from the context menu.
- or -

² Press Ctrl+G on the keyboard.
The Export IEC Station dialog is displayed.
² Enter a File name.

² Click , browse, and select a File path.

² Select a File type from the list box.

² Select the SCL schema (SCL 2003, SCL 2007B, SCL 2007B4) from the list box.

ii
NOTE
The default SCL schema is based on the project edition.

² You can enter a comment for future reference, in the Comment field. The comment can be viewed in the
HiItem section in the History of the SCD file.

While exporting the files, if a duplicate of a file is already available in the destination folder, the Rename/
Replace file dialog is displayed.

3.1.3
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[sc_Replace_File, 1, en_US]

Figure 3-1 Replace File

You can select whether you want to rename the file, replace the existing file, or skip the file.

ii
NOTE
If multiple files have the same name, they cannot be renamed. Instead, a suffix _1 is added to the file
name.

² Select the option Do this action for all other files to repeat the selected action for the rest of the files.

² Click OK.
The device configuration is exported to the preferred location.

Exporting a Configured Communication Description

A Configured Communication Description file contains the following configured elements:

• Substation

• Description

• GOOSE engineering

• Reports and logs engineering

• Protocol mapping for IEC 60870-5-104

• Process bus engineering
The file also contains the needed IEDs with required data type templates and logical node type definitions.
To export the IEC 61850 station via a Configured Communication Description file, proceed as follows:
² Click Station > Export from the menu bar and select IEC 61850 station from the submenu options.

The Export IEC Station dialog is displayed.

² Enter a File name.

² Click , browse, and select a File path.

3.1.4
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² Select Configured Communication Description for the File type.

² Select the SCL schema (SCL 2003, SCL 2007B, SCL 2007B4) from the list box.

² You can enter a comment for future reference, in the Comment field.

² Click Export.
The Configured Communication Description file is exported to the entered location.

Exporting Simulation List for SICAM PTS

To export simulation list for SICAM PTS as a CSV file, proceed as follows:
² Click Station > Export in the menu bar and select Simulation list for SICAM PTS as CSV file from the

submenu options.
The Exporting SICAM PTS Telegram File dialog is displayed.
² Navigate to the location and enter the name for the CSV file.

² Click Save.
The station information is saved as a CSV file in the preferred location and can be imported to SICAM PTS.

CDC Default Values

Name Default Values
SPS 1
DPS 2
INS Starts with 1 and increments by 1
ENS Ignore
ACT 1
ACD 1
MV (i) Starts with 1 and increments by 1
MV (f) Starts with 2 and increments by 0.01
CMV (i) Starts with 1 and increments by 1
CMV (f) Starts with 2 and increments by 0.01
SAV Ignore
SPC 1
DPC 2
INC Starts with 1 and increments by 1
ENC Ignore
BSC Ignore
ISC 1
BCR Ignore
ASG Ignore
ING Ignore
APC (i) Starts with 1 and increments by 1
APC (f) Starts with 2 and increments by 0.01
BAC (i) Starts with 1 and increments by 1
BAC (f) Starts with 2 and increments by 0.01
SEC Ignore
WYE Down to SDO
DEL Down to SDO
SEQ Down to SDO
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Importing Data

Importing SCD, SED, or SSD files

To import SCD, SED, or SSD files to IEC 61850 System Configurator, proceed as follows:
² Click Station > Import on the menu bar and select IEC 61850 station from the context menu.

² Click Yes to save the station in the IEDs editor or click No to proceed without saving.
The Import IEC 61850-Station dialog is displayed.
² Browse for the location and select the SCD, SED, or SSD file to import and click Open.
The IEC 61850 station is imported successfully.

ii
NOTE
The station edition should be higher or equal to the edition of the SCL files. Edition 1 and Edition 2.1 of an
SED file can be imported to a station Edition 2, but an Edition 2 and Edition 2.1 of an SED file cannot be
imported to a station Edition 1 because the SED functionality do not exist in Edition 1.
Creating or modifying a dataset and configuring the destination is dependent on the SED engineering
rights. It is recommended to use the master project to change published indications.

Adding Devices using Import

To add devices (ICD, IID, or SCD) to the station using Import option, refer to 2.11.2 Adding the Devices (ICD,
IID, and SCD) to the Station.

Updating Devices using Import

To reimport the device with its updated SCL, refer to 2.11.3 Updating the Devices.

Adding Substation using SSD Import

To add substation (SSD) to the IEC 61850 System Configurator, proceed as follows:
² Open the IEC 61850 System Configurator and select the station.

² Click Station > Import on the menu bar and select IEC 61850 station from the context menu.
If the station in the IEDs editor is not saved, a Save dialog is displayed.
² Click Yes to save the station in the IEDs editor or click No to proceed without saving.
The Import IEC 61850-Station dialog is displayed.
² Browse for the location and select the SSD file to import and click Open.
The substation is imported successfully.

ii
NOTE
If the substation is already a part of the station, Substation already exists warning message is displayed in
the status report.

Updating Substation using SSD

To reimport the substation with its updated SCL, proceed as follows:
² Open the IEC 61850 System Configurator and select the IEC Station.

3.2

3.2.1

3.2.2

3.2.3

3.2.4

3.2.5

Export and Import
3.2 Importing Data

84 Software, System Configurator, Manual
E50417-H1140-C520-B1, Edition 06.2019



² Click Station > Import on the menu bar and select Update Substation (SSD) from the submenu option.
- or -

² Right-click the station and select Update Substation (SSD) from the context menu.
- or -

² The Update Substation(s) dialog is displayed.

² Navigate to the SSD that you want to update and select that SSD.

² Click Open.
The substation is updated successfully, if there are no violations listed in the status report.

ii
NOTE
If the substation is not part of the station and if you try to update that substation, Substation does not
exist warning message is displayed in the status report.

SICAM SPE file

To import SCD or SED file to the IEC 61850 System Configurator, proceed as follows:
² Click Station > Import on the menu bar and select SICAM SPE File from the context menu.

² Browse for the location and select the SPE file to import and click Open.
The dynamic report configuration is imported successfully to the station devices.

Import Configuration

To update the configuration from the SSD file to the station, proceed as follows:
² Select the IEC station in the Devices editor.

² Right-click the station and select Import Configuration from the context menu.
The Import configurations dialog is displayed.
² Navigate to the folder and select the SSD file.

² Click Open.
The status report dialog is displayed. If there are no validation errors, the device updates the substation,
GOOSE engineering, and the reports and logs engineering to the station.

ii
NOTE
Only the device with a matching IP address can be updated with the SSD configuration.

3.2.6

3.2.7
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Overview
The IED log collection feature is used to check, monitor, and collect logs of an IED configured in the IEC 61850
network topology (for example, SIPROTEC, Reyrolle, SICAM) and of an external switch (for example,
RuggedCom, Scalance) using SNMP and/or HTTP.

Prerequisite for IED Log Collection
The network settings of the Ethernet card must be configured to communicate with IEDs.

Prerequisite for IED Log Collection via SNMP
The IEDs must support SNMP v1, v2, or v3. They should be configured to accept SNMP requests from the PC on
which the IEC 61850 System Configurator is running.
Configuration of RuggedCom ROS IEDs:
# SNMP Access,,,,,

snmpV3AccessCfg,,,,,

Group,SecurityModel,SecurityLevel,ReadViewName,WriteViewName,NotifyViewName

privategroup,snmpV2c,noAuthNoPriv,allOfMib,V1Mib,allOfMib

publicgroup,snmpV2c,noAuthNoPriv,allOfMib,noView,noView

# SNMP Users,,,,,

snmpV3UsersCfg,,,,,

Name,IP Address,Auth Protocol,Priv Protocol,Auth Key,Priv Key

private,,noAuth,noPriv,AF942EA1603201808E0138E133D850639FD4F180F632FBE5E3C057AD9
C18E100,AF942EA1603201808E01

38E133D850639FD4F180F632FBE5E3C057AD9C18E100

public,,noAuth,noPriv,AF942EA1603201808E0138E133D850639FD4F180F632FBE5E3C057AD9C
18E100,AF942EA1603201808E013

8E133D850639FD4F180F632FBE5E3C057AD9C18E100

# SNMP Security to Group Maps,,

vacmSecurityToGroupCfg,,

SecurityModel,Name,Group

snmpV2c,private,privategroup

snmpV2c,public,publicgroup

Prerequisite for IED Log Collection via HTTP
HTML logs are collected based on a predefined set of Internet pages, known for Siemens products, and typi-
cally used for diagnostics:
Internet Pages Description
home Contains operational information and internal error messages
printf Shows information of system behavior being produced from operation time
fehler Contains internal error messages
fecst Shows relevant information of Ethernet
sntp Contains information about the settings and about the condition of the time synchroni-

zation
rstp Contains information about the settings and about the condition of the network redun-

dancy
dnp Contains information about the settings and about the condition of the DNP protocol
startuplog Contains information about the run-up behavior and about the configuration settings

respecting network and GOOSE parameters

4.1
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Internet Pages Description
seclog Contains information about Client-Server connection and DIGSI accesses
gooseoplog Contains information about GOOSE operations
hsrprp Contains information about the settings and about the conditions of the HSR and of the

PRP protocols
modstatus Contains information about firmware update
memstatistic Contains information about memory statistics
health Contains information on the state of the modules and protocols
module Contains information about module configuration
network Contains information about network configuration and status
iec61850 Contains information about IEC 61850 configuration and status
goose Contains information about GOOSE operations
SUP_1 Contains diagnostic data about SUP serial
Modbus Contains information about Modbus configuration and status
IEC60870-5-104 Contains information about the configuration and status of IEC 60870-5-104
prp Contains diagnostic data about PRP
hsr Contains diagnostic data about HSR
DNP30_1 Contains information about configuration and status of DNP
T103_1 Contains information about configuration and status of IEC 103

IED Logs Collection
4.1 Overview
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Collecting the Diagnostic Logs for Devices Available in the Station

ii
NOTE
Save the station before collecting the diagnostic logs.

To collect the diagnostic logs from the devices available in the station via NetView, proceed as follows:
² Click Tools > Collect device logs > Diagnostic logs in the menu bar.

- or -

² In the Network view, right-click the station and select Collect diagnostic logs from the context menu.
A default browser and a command prompt window open.

The diagnostic logs are collected from the devices that are present in the station and are stored in the project
location (<Project Folder>\Logs\Diagnostic_YYMMDD_HHmmss\Logs\<Device Type>).

ii
NOTE
You can find the location of the collected diagnostic logs in the status report.
You can find the names of the not collected diagnostic logs in the ErrorLog_HTML_download.txt file in
the following location:
<Project Folder>\Logs\Diagnostic_YYMMDD_HHmmss

² To stop the collection of the diagnostic logs by NetView, close the command prompt window.

4.2
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Collecting the Diagnostic Logs for Devices Not Available in the
Station
To collect the diagnostic logs from the external devices not available in the station via NetView, proceed as
follows:
² Click Tools > Collect device logs > Diagnostic logs for external devices.

The Collect device logs dialog is displayed.

² Navigate to the desired location and select the desired TXT file.

ii
NOTE
For each device, a separate line must be entered in the TXT file. Each line must follow one of the following
structures:

• IP;name;gateway;subnetmask;model;manufacturer;type;access point name

• IP;;;;;;

• IP

Access points are written in the TXT file for SIPROTEC 5 firmware V7.00 and higher, for versions older than
V6.20, this field is empty.
To make sure that all the values of the switches are displayed in the output HTML pages, replace type with
switch on each line where a switch is parameterized.

² Click Open.
A default browser and a command prompt window open.

The diagnostic logs configured in the selected TXT file are collected from the devices.
The diagnostic logs are collected and stored in the same location as the selected TXT file
(<TXT file location>\Diagnostic_YYMMDD_HHmmss).

ii
NOTE
You can find the location of the collected diagnostic logs in the status report.

² To stop the collection of the diagnostic logs by NetView, close the command prompt window.

4.3
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Display of Collected Data
The NetView Internet page contains the polled SNMP values, which can be viewed via the default Web
browser.

[sc_Netview, 2, en_US]

Figure 4-1 NetView

On the left side of the HTML page, you can find a navigation bar. This bar contains links to pages belonging to
the different Subnets.
On the right side of the HTML page, you can find the following:

• The HTML pages with the SNMP values of the different IEDs are displayed. The IEDs are sorted in
ascending order according to their IP address.

• A legend providing the meaning of the different colors used to identify the possible issues of the IEDs, for
example, IP IED not pingable, no SNMP answer.

ii
NOTE
Due to the settings of the JavaScript and Cookies of the Web browser, the layout of the HTML pages will
vary.

ii
NOTE
If the number of IEDs is too much for the current hardware configuration, you can delete some of the IEDs
or collect the data on a more powerful hardware configuration.

You can place your mouse pointer over a column heading to get a more detailed description of certain SNMP
variable points.

[sc_Netview_counter, 1, en_US]

Figure 4-2 Column Tooltip

4.4
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For some SNMP variables, certain limits are defined. If no limit is defined for a variable or if its value is within
the defined limit, the cell is displayed in green color. If a value is not within the defined limit, the cell is
displayed in yellow color. You can place your mouse pointer over a cell to see if it has a defined limit or what
the defined limit is.

[sc_Netview_Limit, 1, en_US]

Figure 4-3 SNMP Limits

Accessing the Listed IEDs
You can access the listed IEDs via the IP address of the SIPROTEC IEDs. For SIPROTEC IEDs, it is a hyperlink to
the homepage of the corresponding IED. For non-SIPROTEC IEDs, it is just a hyperlink to the IP of the IED.

[sc_Netview_Hyperlink, 1, en_US]

Figure 4-4 IP-Address Hyperlink

RSTP Status
On the RSTP Status page, the columns NeighbourPortA and NeighbourPortB display the IED-Name of the
IEDs instead of the macAddress.

[sc_Netview_MAC_add, 1, en_US]

Figure 4-5 IED-Name Instead of macAddress
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The sysName is marked in yellow if the IED-Name of the IED is not part of the sysName.
As SNMPv1 is less secure than SNMPv2 and SNMPv3, the snmpV is marked yellow if the IED can only commu-
nicate with SNMPv1.

[sc_Netview_Mark_Yellow, 1, en_US]

Figure 4-6 IED Marked Yellow
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Advanced Features
• Conversion of an SCD file to an editable TXT file as input for NetView

When an SCD file is used, a new file inputfileToTxt.txt will be created and stored in the output directory.
It contains all the information stored in the SCD file and is needed to run the function again after editing
the TXT file.

• Saving and restoring the current scroll position
For each page, the current scroll position (horizontally and vertically) is saved in a cookie. If you reload or
revisit the page, the last scroll position is recalled via JavaScript.
If the cookies and/or JavaScript is not activated in your Web browser, this feature will not work. At each
reload, the page will be displayed from the top.

• Creation of a log file with changed values between 2 SNMP polling cycles
A log file is created when certain SNMP-requested values change during the execution of the application.
A log is created containing the changes made to the preconfigured SNMP variables. The values which are
not equivalent to the values in the polling request are listed as displayed in the following table.

IP IEDName OID DateNew TimeNew ValueNew DateOld TimeOld ValueOld
192.168.0.93 G7SJ6236 linkUp-

Chan1
12.07.2011 15:55:21 1 12.07.2011 15:54:30 2

192.168.0.93 G7SJ6236 linkUp-
Chan1

12.07.2011 15:56:03 2 12.07.2011 15:55:21 1

Attributes frequently changing (for example time stamp, number of IP packets) are not logged. To check
whether an attribute is logged or not, place your mouse pointer over the heading of a column in the HTML
output of NetView.

[sc_Netview_Help_Msg, 1, en_US]

Figure 4-7 Tooltip for Log File

The log file is stored in the output directory as a comma-separated value file (CSV). If the log file reaches more
than 65 000 lines, additional log files are created (for example log1.csv, log2.csv) in the output directory.

ii
NOTE
Depending on the language of your operating system, either , (comma, English operating system) or ;
(semicolon, German operating system) is used to separate the values in the log file.

• Creation of a log file with errors which occurred while downloading HTML diagnostic pages

• Possibility to reboot or reset all EN100 Internet pages

[sc_Netview_EN100, 1, en_US]

Figure 4-8 Reboot or Reset of EN100 Internet pages

4.5
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NetView Command-Line Options
To get an online help message with all optional commands to pass to the application, proceed as follows:

• Open a command-line window.
Type NetviewCS.exe –h and press Enter.
All the optional commands to pass to the application will be displayed in the command-line window.

[sc_Netview_Cmds, 1, en_US]

Figure 4-9 Command-Line Options
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Advanced Settings
To configure NetView, proceed as follows:
² Navigate to the NetView folder in the installation path

(for example: C:\Program Files (x86)\Siemens Energy\IEC 61850 System Configurator V5.xx\Configurator
\NetView).

² Right-click the NetView.exe.config file and open it with a text editor (for example, Notepad).

² Edit the RefreshTime value and the ConnectionTimeOut value as desired.
RefreshTime is the interval after which the diagnostic logs are collected. It is measured in seconds.
ConnectionTimeOut is the period after which the IEC 61850 station stops trying to connect with
NetView. It is measured in milliseconds.

² Save your changes and close the text editor.
The NetView.exe.config file contains a key and a corresponding value. The key contains the name of the
page, which has to be downloaded from the device. The value contains the name, which will be given to the
downloaded page.

4.6
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Integration of IEC Browser
The IEC browser is a tool used to view the IEC 61850-compliant servers over a TCP/IP connection. The IEC
browser consists of a tree structure of 2 folders, namely Online and Offline.
For more information on the IEC browser, refer to the online help by pressing F1 while working with the
IEC browser.

Displaying IEC Data

To view the IEC data of the devices available in the station via the IEC browser, proceed as follows:
² Click Tools > Display IEC data in the menu bar.

The Siemens IEC-Browser dialog is displayed.

[sc_iec_browser, 1, --_--]

Figure 4-10 IEC Browser

The dialog displays an online mode of the tree structure of the devices in the station connected to a server.
To view the online IEC data, proceed as follows:
² In the Network view, you can select multiple access points which are connected to the server.

² Right-click one of the selected access points and select View online data from the context menu. For
each device selected, a Siemens IEC-Browser dialog is displayed with the online data for each access
point.

Exporting Online Data

To create a snapshot of the current device data, proceed as follows:
² In the Network view, select the station.

- or -

² Select multiple access points from the station.

4.7

4.7.1

4.7.2
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[sc_iec_browser_acesspoint, 1, en_US]

Figure 4-11 Selecting Access Point in the IEC Browser

² Right-click the selected station or one of the selected access points and select Export online data from
the context menu.
The Siemens IEC-Browser dialog is displayed. A snapshot of the current device data is saved as a CSV file
and is stored in the project folder (<Project Folder>\Logs\IECData).

ii
NOTE
The Export online data and View online data context-menu options are enabled only for devices for
which a Server or a ServerAT is configured.

Exporting Asset Information

To export an XML file which contains the asset information, proceed as follows:
² In the Device view, right-click a station and select Export asset information from the context menu.

The AssetManagement folder is displayed with the newly created XML file.
The XML file (<station name>_yyyyMMdd_HHmmss.xml) is created and stored in the project folder
(<Project Folder>\Logs\AssetManagement).

ii
NOTE
XML files which are not created and IEDs files are not available are displayed in the reporting dialog.

4.7.3
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Uploading Firmware

ii
NOTE
This feature is available only for EN100 V4.09 to V4.29 modules.

Use the NetView diagnostic logs to find the current firmware version of the device.
For more information on NetView, refer to 4 IED Logs Collection.

• Select a device or multiple devices.

• Right-click a selected device and select Upload firmware from the context menu.
The Upload firmware window opens.

[sc_Firmware_Update, 1, en_US]

Figure 5-1 Firmware Upload

• Click  to select a PCK file.

• Navigate to the desired location and select the Pck file.

• Click Open.
The Pck is selected and displayed in the Pck file field.

• Click Upload.
The Pck file starts uploading the firmware information to the devices.
The upload status of each device is displayed in the Upload status column.
The Reboot option is enabled only after the firmware is uploaded to all the devices.

5
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• Select the devices in the Reboot column and click Reboot.
The firmware for the selected devices is upgraded.
Once the new firmware is uploaded to a device, reboot to complete the firmware-upgrade process.

ii
NOTE
The status report displays the parameters (for example, IP address) displayed in the EN100 firmware upload
dialog.

Uploading Firmware
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Print Setup
Before you print an overview of the Devices, Network, GOOSE, SMV, Report and logs or Protocol mapping,
set up the printer. Specify the printer to be used and other printer-specific settings. To do this, proceed as
follows:
² Click Station > Print in the menu bar or press Ctrl+P on the keyboard.
Print dialog is displayed.
² Select the name of the printer to be used for printout from the Name list box.

² Click Properties.
The printer-specific dialog for setting various printer parameters is displayed.
Adapt the values to your requirements if necessary and close the dialog. This is an optional step.
² Select the Number of copies of each screen page that are to be printed in the Copies box.

² Click OK to save the settings.

6.1
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Print Preview
Before printing, you can check the expected print results using the print preview.

Opening the Print Preview Window
To open the print preview window, click Station > Print preview. The tree structure for Devices, Network,
GOOSE, SMV, Reports and logs, or Protocol mapping is displayed depending on the current workspace.

Changing the Display Mode

With  button in the toolbar, you can select the display mode of the existing pages.
For example, 1, 2*2, 3*3, or 4*4 pages can be displayed simultaneously.

Changing the Display Scale

Select  in the toolbar. A list box is displayed from which you can select a defined degree of scaling. The
Auto setting causes the scaling of the displayed pages to adapt to the current window size.

ii
NOTE
Magnify the view and Shrink the view has no influence on the print results.

Closing the Print Preview
Click Exit in the toolbar or click Close.

Printing the Views

To print the views, select the view and click  on the toolbar. During printing, the settings you have specified
during the printer setup are used.

6.2
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Printing the Displayed Information
To print the displayed information, proceed as follows:
² Select the view. For example, Devices, Network, GOOSE, SMV, Report and logs or Protocol mapping.
If the displayed information is to be printed without further checking, perform any of the following:
² Click Station > Print on the menu bar.

- or -

² Click  on the toolbar.

- or -

² Press Ctrl+P on the keyboard.
The Print dialog is displayed.
² Click OK.
The view is printed.

6.3
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Properties

ii
NOTE
The description of the devices added through IED tool (for example, DIGSI4 and DIGSI5) is not editable.

7.1 Station 108
7.2 Devices 110
7.3 Substation 112
7.4 Power Transformer 113
7.5 Transformer Winding 114
7.6 Voltage Level 115
7.7 Bay 116
7.8 Conducting Equipment 117
7.9 Sub-equipment 118
7.10 Function 119
7.11 LNode 120
7.12 Access Point 121
7.13 New Devices Folder 124
7.14 Subnet 125
7.15 Application 128
7.16 Dataset 130
7.17 GOOSE Link 134
7.18 SMV Link 135
7.19 DA Group 136
7.20 Logical Device 137
7.21 Logical Node 138
7.22 Data Object 139
7.23 Report Control Blocks 140
7.24 Log Control Blocks 142
7.25 Client 144
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Station

[sc_station, properties, 4, en_US]

Figure 7-1 Properties Window for IEC 61850 Station

Group: Identification

Property Description
Name This field represents the name, which you have assigned to the station

within your DIGSI project. This name is identical to the name displayed in
the tree structure of the Subnets window. You can change this name
only in the DIGSI Manager.

Type The type Station cannot be changed.
Edition This field represents the edition selected for this IEC 61850 station.
SclRelease This field is the combination of version, revision, and release of the SCL

file.
Header id This field represents the header ID of an SCD file. The SCD header ID is

used within an SED file to identify the owner project of an IED.

Group: Parameter

Property Description
Primary clock master This field represents the name of the timer, which is currently configured

as the first timer. By clicking the arrow button on the right border, you
open a list box to select another timer as the first one. The entry in this
field is also influenced by the number of timers within a station and the
selection of the second timer. If no timer is available within the station,
the entry No timer available is displayed in this field.

Secondary clock master This field represents the name of the timer, which is currently configured
as the second timer. By clicking the arrow button on the right border,
you open a list box where you can select another time as the second one.
The entry in this field is also influenced by the number of timers within a
station and the selection of the first timer. If there is no timer or no
second timer is available within the station, the entry No timer available
or No second timer available is displayed in the field.

7.1
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Group: Siemens Parameter for SIPROTEC

Property Description
First GOOSE MAC address This field represents the starting address of the GOOSE MAC Address.

This is the lowest MAC address that the GOOSE application in the station
will have with automatic incrementation of MAC addresses.

Last GOOSE MAC address This field represents the end address of the GOOSE MAC address. This is
the highest MAC address that the GOOSE application in the station will
have with automatic incrementation of MAC addresses.

First application number This field represents the start of GOOSE application number. This is the
lowest application ID that the GOOSE application in the station can have.

Last application number This field represents the end of GOOSE application number. This is the
highest application ID that the GOOSE application in the station can
have.

First SMV MAC address This field represents the starting address of the SMV MAC Address. This is
the lowest MAC address that the SMV application in the station will have
with automatic incrementation of MAC addresses.

Last SMV MAC address This field represents the end address of the SMV MAC address. This is the
highest MAC address that the SMV application in the station will have
with automatic incrementation of MAC addresses.

Properties
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Devices

[sc_devices, properties, 6, en_US]

Figure 7-2 Properties Window for Device

Group: Identification

Property Description
Name This field represents the name of the access point, including the corre-

sponding device.
Name in manager The displayed device name corresponds to the name that is assigned to

the device in the DIGSI project.
Type This field indicates the type of the access point. The type cannot be

changed.
Description This field represents the description of the device.
Device type This field represents the type of the device.

For example, 7SJ6.
Configuration version This field represents the version of the device.
Manufacturer This field represents the device manufacturer.
Owner This field represents the owner project of this IED that is the Header id of

the SCD file of the project, which has the right to use the IED tool for
this IED.

EngRight This field represents the engineering right transferred by an SED file
(only fix, dataflow) or the current state in an SCD file.

Original Scl Version This field represents the original SCL schema version of the IED.
Original Scl Revision This field represents the original SCL schema revision of the IED.
GOOSE Supervision Capability This field indicates whether the GOOSE supervision for the device is

enabled or not.
If the value is set to True, it indicates that the GOOSE supervision capa-
bility is enabled for the device.
If the value is set to False, it indicates that the GOOSE supervision capa-
bility is not enabled for the device.

7.2
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Group: Siemens Parameter

Property Description
Date Modified This field represents the last time stamp in UTC format about when the

IEC 61850 was edited. It is displayed in MMDDYYYY HH:MM:SS.
IED Tool Identifier This field represents the IED tool with which the device was configured.

ii
NOTE
The Owner attribute is editable for devices added to the station through SED import, which are not part of
this station.

ii
NOTE
The description for the devices added through the IED tool (for example, DIGSI4 and DIGSI5) has to be
edited in the IED tool.
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Substation

[sc_Substation, 1, en_US]

Figure 7-3 Properties Window for Substation

Group: Identification

Property Description
Name This field represents the name of the substation.
Description This field represents the description of the substation.
Node Type This field represents the node type of the selected element in the

Topology.
The Node Type cannot be changed.

Comment This field is reserved for a multiline comment. Click inside the box and
click the arrow button on the right border. A list box is displayed where
you can view and edit the entire text for substation.

7.3
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Power Transformer

[sc_Power transformer, 1, en_US]

Figure 7-4 Properties Window for Power Transformer

Group: Identification

Property Description
Name This field represents the name of the power transformer.
Description This field represents the description of the power transformer.
Node Type This field represents the node type of the selected element in the

Topology.
The Node Type cannot be changed.

Comment This field is reserved for a multiline comment. Click inside the box and
click the arrow button on the right border. A list box is displayed where
you can view and edit the entire text for Power Transformer.

Type This field represents the type of power transformer used.
The Type cannot be changed.

Virtual This field indicates whether the subequipment (for example phase CT)
exists.
If the value is set to false, the subequipment exists in the station.
If the value is set to true, the subequipment does not exists in the
station, but its values are calculated.

7.4
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Transformer Winding

[sc_Transformer winding, 1, en_US]

Figure 7-5 Properties Window for Transformer Winding

Group: Identification

Property Description
Name This field represents the name of the transformer winding.
Description This field represents the description of the transformer winding.
Node Type This field represents the node type of the selected element in the

Topology.
The Node Type cannot be changed.

Comment This field is reserved for a multiline comment. Click inside the box and
click the arrow button on the right border. A list box is displayed where
you can view and edit the entire text for transformer winding.

Type This field represents the type of transformer winding used.
The Type cannot be changed.

Virtual This field indicates whether the subequipment (for example phase CT)
exists.
If the value is set to false, the subequipment exists in the station.
If the value is set to true, the subequipment does not exists in the
station, but its values are calculated.

Group: Terminals

Property Description
Name This field represents the name of the terminal.
Description This field represents the description of the terminal.
Connectivity Node This field represents the referenced connectivity node of the terminal.

The connectivity node has to be in the following format: Substation-
Name/VoltageLevelName/BayName/ConnectivityNodeName.

7.5
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Voltage Level

[sc_Voltage level, 1, en_US]

Figure 7-6 Properties Window for Voltage Level

Group: Identification

Property Description
Name This field represents the name of the voltage level.
Description This field represents the description of the voltage level.
Node Type This field represents the node type of the selected element in the

Topology.
The Node Type cannot be changed.

Comment This field is reserved for a multiline comment. Click inside the box and
click the arrow button on the right border. A list box is displayed where
you can view and edit the entire text for voltage level.

Group: Parameter

Property Description
Voltage This field represents the voltage of the voltage level.

This property is editable. By clicking the arrow button on the right
border, you open a text box where you can view and edit the value and
the units.

7.6
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Bay

[sc_Bay, 1, en_US]

Figure 7-7 Properties Window for Bay

Group: Identification

Property Description
Name This field represents the name of the bay.
Description This field represents the description of the bay.
Node Type This field represents the node type of the selected element in the

Topology.
The Node Type cannot be changed.

Comment This field is reserved for a multiline comment. Click inside the box and
click the arrow button on the right border. A list box is displayed where
you can view and edit the entire text for Bay.

Group: Connectivity Node

Property Description
Path Name This field represents the Connectivity Node path present under the Bay.

7.7
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Conducting Equipment

[sc_Conducting equipment, 1, en_US]

Figure 7-8 Properties Window for Conducting Equipment

Group: Identification

Property Description
Name This field represents the name of the conducting equipment.
Description This field represents the description of the conducting equipment.
Node Type This field represents the node type of the selected element in the

Topology.
The Node Type cannot be changed.

Comment This field is reserved for a multiline comment. Click inside the box and
click the arrow button on the right border. A list box is displayed where
you can view and edit the entire text for conducting equipment.

Type This field represents the type of conducting equipment used.
The Type cannot be changed.

Group: Terminals

Property Description
Name This field represents the name of the terminal.
Description This field represents the description of the terminal.
Connectivity Node This field represents the referenced connectivity node of the terminal.

The connectivity node has to be in the following format: Substation-
Name/VoltageLevelName/BayName/ConnectivityNodeName.

7.8
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Sub-equipment

[sc_Subequipment, 1, en_US]

Figure 7-9 Properties Window for Sub-equipment

Group: Identification

Property Description
Name This field represents the name of the sub-equipment.
Description This field represents the description of the sub-equipment.
Node Type This field represents the node type of the selected element in the

Topology.
Comment This field is reserved for a multiline comment. Click inside the box and

click the arrow button on the right border. A list box is displayed where
you can view and edit the entire text.

Phase This field represents the phase to which the subequipment belongs.
For example, A, B, C, N (neutral), all (all three phases), none (default,
not phase-related).

Virtual This field indicates whether the subequipment (for example phase CT)
exists.
If the value is set to false, the subequipment exists in the station.
If the value is set to true, the subequipment does not exists in the
station, but its values are calculated.

7.9

Properties
7.9 Sub-equipment

118 Software, System Configurator, Manual
E50417-H1140-C520-B1, Edition 06.2019



Function

[sc_Function, 1, en_US]

Figure 7-10 Properties Window for Function

Group: Identification

Property Description
Name This field represents the name of the function.
Description This field represents the description of the function.
Node Type This field represents the node type of the selected element in the

Topology.
The Node Type cannot be changed.

Comment This field is reserved for a multiline comment. Click inside the box and
click the arrow button on the right border. A list box is displayed where
you can view and edit the entire text.

Type This field represents the type of function used.
The Type can be edited.

7.10
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LNode

[sc_LNode, 1, en_US]

Figure 7-11 Properties Window for LNode

Group: Identification

Property Description
Node Type This field represents the node type of the selected element in the

Topology.
Prefix This field represents the prefix of the name of the LNode. The whole

name of the LNode consists of three parts namely Prefix, Group, and
Instance.

LN class This field represents the class of the LNode.
LN Inst This field represents the instance number of the LNode.
IED Name This field represents the name of the device to which the LNode is

configured.
LD Inst This field represents the instance name of the logical device to which

the LNode is configured.
For example, CTRL, DR, MEAS, and PROT.

Description This field represents the description of the LNode.
Comment This field is reserved for a multiline comment. Click inside the box and

click the arrow button on the right border. A list box is displayed where
you can view and edit the entire text.

7.11
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Access Point

[sc_accesspoint, properties, 3, en_US]

Figure 7-12 Properties Window for Access Point

Group: Identification

Property Description
Name This field represents the name of the access point, including the corre-

sponding device.
Name in manager The displayed device name corresponds to the name that is assigned to the

device in the DIGSI project.
Type Type of the access point. The type cannot be changed.
Comment This field is reserved for a multiline description of the access point. By

clicking the arrow button on the right border, you open a list box where you
can view and edit the entire text.

Device type This field represents the type of the device.
For example, 7SJ6.

Configuration version This field represents the version of the device.
Manufacturer This field represents the device manufacturer.
Owner This field represents the owner project of this IED that is the Header id of the

SCD file of the project, which has the right to use the IED tool for this IED.
EngRight This field represents the engineering right transferred by an SED file (only

fix, dataflow) or the current state in an SCD file.

7.12

Properties
7.12 Access Point

Software, System Configurator, Manual 121
E50417-H1140-C520-B1, Edition 06.2019



Group: Parameter

Property Description
IP address This field represents the current IP address of the access point. You can edit

this address manually. The IP address and the standard gateway have the
format x.y.y.x (where x = 1 to 254, y = 0 to 254), subnet masks have the
format x.y.y.z (where x = 1 to 255, y = 0 to 255, z = 0 to 254).
However, it must be observed that not every possible combination is
permitted within the value range. Non-permissible exceptions are automati-
cally rejected by the IEC 61850 System Configurator with a corresponding
message. The field display is updated as soon as the Automatic addressing
function is used.

Subnet mask The subnet mask allows two nodes communicating with each other to
recognize whether they are in the same or in different subnets. This
however requires that the IP addresses have been assigned consistently. The
preset subnet mask 255.255.255.0 can usually be retained for operation
with only one subnet.
However, the preset value can also be changed. The IP address and the
standard gateway have the format x.y.y.x (where, x = 1 to 254, y = 0 to
254), subnet masks have the format x.y.y.z (where, x = 1 to 255, y = 0 to
255, z = 0 to 254).

Standard Gateway The standard gateway is the transition from one subnet to another defined
as the standard. Such a transition is handled as a usual node and is therefore
also identified by a unique IP address. If nodes with a router function are
available within the network, their IP addresses are listed in a list box. You
can open this box by clicking the arrow button on the right border of the
input field.
You can also enter an IP address manually in this field. The IP address and
the standard gateway have the format x.y.y.x (where, x = 1 to 254, y = 0 to
254), subnet masks have the format x.y.y.z (where, x = 1 to 255, y = 0 to
255, z = 0 to 254).
However, it must be observed that not every possible combination is
permitted within the value range. Not permissible exceptions are automati-
cally rejected by the IEC 61850 System Configurator with a corresponding
message.

Device-device communication This field represents the GOOSE capability of the device. The values for this
property can be None, Client, Server, or Both.

Vertical communication This field represents whether the device allows a vertical communication
with other devices. The display of data objects is correspondingly adjusted in
the GOOSE, SMV, and Reports and logs view in the Source catalog and
the Destination catalog.

Timer function This field represents whether the device can be used as a timer. The prop-
erty values are either True or False.

Router function This field represents whether the device can be used as a router. The prop-
erty values are either True or False.
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Group: Siemens Parameter for SIPROTEC

Property Description
Use as a timer This field represents whether a timer is configured as the first or the second

timer, or is not used if two or more timers are available within a station.
This property is not relevant for devices without a timer functionality. The
entry function No is displayed for such devices. By clicking the arrow button
on the right border, you can open a list box to specify the timer status. The
number of possible options depends on the number of timers within a
station:
One timer: option Yes (first timer)
Two timers: additional option Yes (second timer)
At least three timers: additional option No.
If you change any setting, the IEC 61850 System Configurator automatically
adjusts the status of other timers.

Message buffering This is applicable for EN100 devices only.
Here you can specify the memory requirements for message buffers.
Dynamic reporting requires additional memory.
Select Only static reporting if you configure the reporting exclusively in the
IEC 61850 System Configurator. The memory requirements for message
buffers are optimized.
Select Dynamic and static reporting if the plant is connected to a control
system that supports dynamic reporting, such as SICAM PAS.
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New Devices Folder

[sc_new devices, 2, en_US]

Figure 7-13 Properties Window for New Devices Folder

Group: Identification

Properties Description
Type This field represents the name of the folder. Name of the folder cannot be

changed.

7.13
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Subnet

[sc_subnet, properties, 2, en_US]

Figure 7-14 Properties Window for Subnet

Group: Identification

Property Description
Name The IEC 61850 System Configurator assigns the word Subnet as the

name in connection with consecutive numbering. You may change the
preset name in this field. The name entered in this field is applied to
the tree structure in the Subnets window.

Description Enter a short single-line description in this field. This is optional.
Comment This field is reserved for a multiline description. By clicking the arrow

button on the right border, you open a list box where you can view and
edit the entire text.

Type The type Subnet cannot be changed.

7.14
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Group: Parameter

Property Description
IP start address Enables you to use the function of automatic addressing of all access

points within the current subnet by entering a valid IP address as start
value in this field. The IP address and the Standard Gateway have the
format x.y.y.x (where x = 1 to 254, y = 0 to 254), subnet masks have
the format x.y.y.z (where x = 1 to 255, y = 0 to 255, z = 0 to 254).
However, it must be observed that not every possible combination is
permitted within the value range. Non-permissible exceptions are auto-
matically rejected by the IEC 61850 System Configurator with a corre-
sponding message. During the automatic addressing, this IP start
address is assigned to an access point displayed at the highest level
within the subnet. All other access points are assigned IP addresses,
which are allocated in ascending order starting from the start address.

Subnet mask The subnet mask allows two nodes communicating with each other to
recognize whether they are in the same subnet or in the different
subnet. This however requires that the IP addresses have been assigned
consistently. The preset subnet mask 255.255.255.0 can usually be
retained for operation with only one subnet. However, the preset value
can also be changed. The IP address and the standard gateway have
the format x.y.y.x (where x = 1 to 254, y = 0 to 254), subnet masks
have the format x.y.y.z (where x = 1 to 255, y = 0 to 255, z = 0 to 254).
The entry Device-dependent indicates that devices with different
subnet masks are used in this subnet. If you try to select one subnet
mask for all devices, a warning is displayed by the IEC 61850 System
Configurator. Confirming this warning with OK overwrites the settings
of all devices of the subnet with the subnet mask.

Standard Gateway The Standard gateway is the transition from one subnet to another
defined as the standard. Such a transition is handled as a usual node
and is therefore identified by a unique IP address. If nodes with a router
function are available within the network, their IP addresses are listed
in a list box. You can open this box by clicking the arrow button on the
right border of the input box. You can also enter an IP address manually
in this field. The IP address and the standard gateway have the format
x.y.y.x (where x = 1 to 254, y = 0 to 254), subnet masks have the
format x.y.y.z (where x = 1 to 255, y = 0 to 255, z = 0 to 254).
However, it must be observed that not every possible combination is
permitted within the value range. Non-permissible exceptions are auto-
matically rejected by the IEC 61850 System Configurator with a corre-
sponding message.
The entry Device-dependent indicates that different standard gate-
ways are used in this subnet. If you try to select one standard gateway
for all devices, a warning is displayed by the IEC 61850 System Config-
urator. Confirming this warning with OK overwrites the settings of all
devices of the subnetwork with the standard gateway.

Baud rate This field represents the data transmission rate on the bus. The factory-
preset value of 100 Mbit/s should not be changed, since no higher
transmission rate is possible in connection with IEC 61850 at the
moment.

Type This field describes the type of the bus protocol. The factory default is
MMS/TCP. You cannot use any other bus protocol at the moment,
which is why you should not change this value.

Properties
7.14 Subnet

126 Software, System Configurator, Manual
E50417-H1140-C520-B1, Edition 06.2019



Group: Estimated bandwidth

Property Description
GOOSE bandwidth For any subnetwork, GOOSE bandwidth displays an estimation of the

consumed GOOSE information capacity in metric multiples of bits per
second.

SMV bandwidth For any subnetwork, SMV bandwidth displays an estimation of the
consumed SMV information capacity in metric multiples of bits per
second.

ii
NOTE
By default, the unit for GOOSE bandwidth and SMV bandwidth is Mbits/s.
If the baud rate is set for the subnetwork, the unit for the bandwidth is same as that of the baud rate. In
this case, the bandwidth also displays the percentage of the set baud rate.
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Application

[sc_goose application, 2, en_US]

Figure 7-15 Properties Window for GOOSE Application

Group: Identification

Property Description
Name The IEC 61850 System Configurator assigns the word GOOSE Application

as the name in connection with consecutive numbering. You may
change the current name in this field.

Description Enter a short single-line description in this field, if necessary.
Comment This field is reserved for a multiline description. Click inside the box to

enter the text or to edit it.
Type The displayed type (for example, Siemens GOOSE application) cannot

be changed.

GOOSE application have the following additional properties when compared to SMV application:

Group: Parameter

Property Description
Application ID This field represents a number as the unique marking of the GOOSE

application. You can change this number.
When you change the value, ensure the uniqueness of the number. If
the Application ID is not unique, a warning message, Elements of type
'ApplicationID' have to be unique is displayed in the reporter window.

7.15
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Group: GOOSE Parameters

Property Description
Communication profile With this list box, you select a communication profile. A communication

profile is a group of settings with which you can set the resending of
GOOSE messages. The following settings are part of this group:

• Minimum monitoring time
• Maximum monitoring time
• VLAN ID
• VLAN Priority
You can select one of the three standard profiles PriorityLow, Priority-
Medium, or PriorityHigh. Alternately, you can set the four parameters
stated directly and store a combination of settings from the communica-
tion profile.
If you select a communication profile, the preceding four parameters are
automatically updated to the values defined in the profile.

Minimum monitoring time This field represents a value for the minimum time in milliseconds. If a
value or the status of a value has changed spontaneously within a
GOOSE frame, the frame will be transmitted again after expiry of this
time.

Maximum monitoring time This field represents a value for the maximum time in milliseconds. The
maximum time is the distance between two telegram communications
in the stationary condition. The interruption of the communication can
then be detected by the recipient.

VLAN ID This field represents the number of the virtual LAN (VLAN) in the
network. Enter another value for the VLAN number if necessary.

VLAN Priority This field gives the priority of the GOOSE message within the VLAN.
Enter another value for the priority if necessary. The least VLAN priority
and the highest VLAN priority is 0 and 7 respectively.

ii
NOTE
For SMV editor, only Name, Description, and Comment properties are applicable.
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Dataset

[sc_iec_station_properties, 1, en_US]

Figure 7-16 Properties Window for Dataset

Here, you can edit the property values of a Dataset.
Group Property Description
Identification Name This field represents the current name of the dataset.

Enter another name for the dataset if necessary.
If you modify the name in the entry field, the modified
name is displayed in all the windows that contain this
dataset.

Type Type Dataset cannot be changed.
Hierarchical Path This list box is used to modify the current hierarchical

path of the dataset. The hierarchical path is equivalent
to the path in the Source catalog tree. This path
consists of the IEC 61850 name of the device, the
name of the logical device (LD) and the name of the
logical node (LN).

Parameter Configuration This field represents the number of GSE controls of the
dataset and further setting options. Click the button on
the right border. Configuration window for dataset is
displayed.
For more information on configuring a dataset, refer to
2.14.10 Changing the Properties of a GOOSE Control
Block.

Include in SED export This field is displayed only for GOOSE.
If you select Yes, the dataset is added to the other
project data on SED export. All the information
contained in the dataset is exported in an SED format.
If you select No, the dataset is not added to other
project data on SED export.

Subset for SICAM This field is displayed only for Reports and logs.
If you select Yes, SICAM imports only the information
in the marked dataset. If you select No (standard
mode), SICAM always imports the complete informa-
tion.

Table with IED and
GOOSE supervision
path

Device name This field displays the overview of all configured
GOOSE supervision for the selected GSE control block.
The text Not configured is displayed for the device if
the GOOSE supervision is not enabled.

7.16
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GOOSE Control Block Attributes
Here, you can edit the attributes of GOOSE control block.
Attribute Description
Name This field represents the name of the GOOSE control block.

This field can be edited.
Application ID This field represents an integer value as the unique marking of the

GOOSE application. This value can be changed.
The application ID is displayed as a decimal value, but saved as a hexa-
decimal value in the SCL file according to IEC 61850-6.
When you change the value, ensure the uniqueness of the number. If
the Application ID is not unique, a warning message Elements of type
'ApplicationID' have to be unique is displayed in the reporter
window.

MAC address This field represents the recommended multicast addressing to
increase the overall performance of the multicast message reception
(MAC hardware performing the filtering). This value can be changed.
When you change the value, ensure the uniqueness of the address. If
the MAC address is not unique, a warning message Elements of type
'Mac Address' have to be unique is displayed in the reporter window.

Config revision This field represents the number of times that the configuration of the
dataset is changed.

Monitoring
time

minimum This field represents the first retransmission time in milliseconds after a
spontaneous change of a signal within a GOOSE dataset.

maximum This field represents the maximum time in milliseconds for the two
telegram communications in the stationary condition.
The interruption of the communication is ascertained by the recipient
after twice the time set in this field.

VLAN ID This field represents the number of the virtual LAN (VLAN) in the
network. You can enter another value for the VLAN number if neces-
sary. The VLAN number is part of the communication profile.
The VLAN ID is displayed as a decimal value, but saved as a hexadec-
imal value in the SCL file according to IEC 61850-6.

Priority This field represents the priority of the GOOSE message within the
VLAN. You can enter another value for the priority if necessary. The
VLAN-Priority is part of the communication profile.
The VLAN-Priority is displayed as a decimal value, but saved as a hexa-
decimal value in the SCL file according to IEC 61850-6.

ii
NOTE
The SCD file is corrupted if the station has errors. For example, a GOOSE control block with the same name.

SMV Control Block Attributes
Here, you can edit the attributes of SMV control block.
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Attribute Description
Name This field represents the name of the multicast sample value control

block.
Application ID/SMV ID This field represents the integer value/string as the unique marker of

the SMV application.
The application ID/SMV ID is displayed as a decimal value, but saved as
a hexadecimal value in the SCL file according to IEC 61850-6.
When you change the value, ensure the uniqueness of the number. If
the Application ID is not unique, a warning message Elements of type
'SmvID' have to be unique is displayed in the reporter window.

Config revision The field represents the number of times that the configuration of the
dataset is changed. On any configuration changes, the value is incre-
mented by 10 000 to distinguish this from the online configuration
changes where the value is incremented by 1.

MAC address This field represents the recommended multicast addressing to
increase the overall performance of the multicast message reception
(MAC hardware performing the filtering). This value can be changed.
When you change the value, ensure the uniqueness of the address. If
the MAC address is not unique, a warning message Elements of type
'Mac Address' have to be unique is displayed in the reporter window.

VLAN ID This field represents the number of the virtual LAN (VLAN) in the
network. You can enter another value for the VLAN number if neces-
sary. The VLAN number is part of the communication profile.
The VLAN ID is displayed as a decimal value, but saved as a hexadec-
imal value in the SCL file according to IEC 61850-6.

Priority This field represents the priority of the SMV message within the VLAN.
You can enter another value for the priority if necessary. The VLAN
priority is part of the communication profile.
The VLAN priority is displayed as a decimal value, but saved as a hexa-
decimal value in the SCL file according to IEC 61850-6.

smpRate This field represents the sample rate. The unit of the value depends on
the value of the smpMod.

nofASDU This field represents the total number of Application Service Data
Units.

smpMod This field represents if the sample rate is defined in any of the
following units.

• samples per nominal period
• samples per second
• seconds per sample
If none of the mentioned units are specified, the default value,
samples per period is considered.

SMV options refreshTime This field represents the boolean value and if it is set to true, the
refreshTime attribute (time of refresh activity) is included in the SMV
telegram.

sampleRate This field represents the boolean value and if it is set to true, the
smpRate and smpMode from the instance of MSVCB is included in
the SMV telegram.

dataSet This field represents the name of the dataset.
security This field represents the boolean value and if it is set to true, the

security attribute (reserved for digital authentication) is included in
the SMV telegram.

multicast This field represents the boolean value and if it is set to true, the
transmission of the sampled value uses multicast.

Properties
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ii
NOTE
The SCD file is corrupted if the station has errors. For example, a dataset or SMV control block with the
same name.

Properties
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GOOSE Link

[sc_iec_gooselink_properties, 1, en_US]

Figure 7-17 Properties Window for GOOSE Link

Group: Identification

Property Description
Name This field represents the name of the source object.

This name cannot be changed.
Type For GOOSE editor, the type GOOSE link cannot be changed.
Hierarchical path This field represents the hierarchical path of the GOOSE link. This path

consists of the following:

• IEC 61850 name of the device
• Name of the logical device (LD)
• Name of the logical node (LN)
This path cannot be changed.

Property Description
FC/DA mapping This field represents the FC/DA mapping of the source object.

To change the mapping, select the values from the list box and click
outside the field.
With the FC/DA mapping option, you decide which data attributes of a
data object are to be included in the dataset. Check box is available at
FC as well as DA level.
You can select or clear the individual data attributes (DA Group) or
entire functional groups of the data attributes (FC Group).

ii
NOTE
The FC/DA mapping can be changed only when the destination signal is not configured to the source
signal. If the destination signal is configured, the FC/DA mapping option in the Properties window under
the Parameter group is disabled.

Group: GOOSE Supervision

Property Description
Hierarchical path This list box is used to represent and modify the configured GOOSE

supervision path. This path consists of the IEC 61850 name of the
device, the name of the logical device (LD), and the name of the
configured LGOS logical node (LGOS LN).

7.17
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SMV Link

[sc_iec_smvlink_properties, 1, en_US]

Figure 7-18 Properties Window for SMV Link

Group: Identification

Property Description
Name This field represents the name of the source object.

This name cannot be changed.
Type For the SMV editor, the type SMV link cannot be changed.
Hierarchical path This field represents the hierarchical path of the SMV link.

This path consists of the following:

• IEC 61850 name of the device
• Name of the logical device (LD)
• Name of the logical node (LN)
This path cannot be changed.

Property Description
FC/DA mapping This field represents the FC/DA mapping of the source object.

To change the mapping, select the values from the list box and click
outside the field.
With the FC/DA mapping option, you decide which data attributes of a
data object are to be included in the dataset. The check box is avail-
able at the FC level as well as at the DA level.

ii
NOTE
The FC/DA mapping can be changed only when the destination signal is not configured to the source
signal. If the destination signal is configured, the FC/DA mapping option in the Properties window under
the Parameter group is disabled.

7.18
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DA Group

[sc_da group, 2, en_US]

Figure 7-19 Properties Window for DA Group

Group: Identification

Property Description
Name This field represents the name of the DA group.
Type Type DA group cannot be changed.

7.19
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Logical Device

[sc_source catalogue ld, 3, en_US]

Figure 7-20 Properties Window for Logical Device

Group: Identification

Property Description
Instance This field represents the instance name of the logical device. For

example, CTRL, DR, MEAS, and PROT.
Name (ldName) This is the name of the logical device. You can enter a name for the

logical device in this entry field, which is transmitted when communi-
cating with other devices. This name must be in accordance with the
IEC 61850-7-1 and IEC 61850-7-2 standard and it must be unique
within the subnetwork. You can edit the IED, if it is Edition 2 and its
service capabilities allow it. If the ldName is not unique, an appro-
priate error message is displayed in the tooltip. The ldName must not
contain more than 64 characters.
If there is no name added for ldName, a unique communication name
is automatically used. This communication name consists of the device
name and the instance of the logical device.

Type Type Logical device cannot be changed.
Description This field represents the description of the logical device. For example,

Control, Disturb Rec, Measurement, and Protection.
Comment This field is reserved for a multiline description. Click inside the box

and click the arrow button on the right border. A list box is displayed
where you can view and edit the entire text for logical device.

ii
NOTE
The description for the devices added through the IED tool (for example, DIGSI4 and DIGSI5) is not editable.

7.20
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Logical Node

[sc_iec_LGOS_properties, 1, en_US]

Figure 7-21 Properties Window for Logical Node

Group: Identification

Property Description
Prefix This field represents the prefix of the name of the logical node. The

whole name of the logical node consists of three parts namely Prefix,
Group, and Instance.

LN class This field represents the class of the logical node.
Instance This field represents the instance number of the logical node.
Type Type Logical node cannot be changed.
Hierarchical path This field represents the hierarchical path of the logical node. This path

consists of the IEC 61850 name of the device, the name of the logical
device (LD), and the name of the logical node (LN).

Description This field represents the description of the logical node.
Description can be edited only for the IEDs that are imported
manually.

Comment This field is reserved for a multiline description. Click inside the box
and click the arrow button on the right border. A list box is displayed
where you can view and edit the entire text for logical node.

Group: Supervised GOOSE

ii
NOTE
This property is available and displayed only for LN LGOS.

Property Description
Supervised GSEControl This field represents the supervised GSE control path of the LGOS

logical node (LN LGOS). The text Not configured is displayed if the
GOOSE supervision is not enabled.

Supervised dataset This field represents the supervised dataset path of the LGOS logical
node (LN LGOS). The text Not configured is displayed if the GOOSE
supervision is not enabled.

ii
NOTE
The description for the devices added through the IED tool (for example, DIGSI4 and DIGSI5) is not editable.

7.21
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Data Object

[sc_source catalogue do, 3, en_US]

Figure 7-22 Properties Window for Data Object

ii
NOTE
The source path is displayed only for the Destination catalog.

Group: Identification

Property Description
Name This field represents the current name of the data object.
Type Type Data object cannot be changed.
Hierarchical path This list box displays the current hierarchical path of the data object.

This path consists of the IEC 61850 name of the device, the name of
the logical device (LD), the name of the logical node (LN), and the
name of the data object.

Source Path This field represents the path of the configured publisher. This path
consists of the IEC 61850 name of the device, the name of the logical
device (LD), the name of the logical node (LN), and the name of the
data object.

Preferred Service Type Preconfigured service type indicating a expected service for the data-
flow configuration.

Preferred LN Preconfigured LN class indicating an expected publisher LN class
containing the data object indicated by the preferred DO.

Preferred DO Preconfigured DO name to indicate the expected publisher and DO
name and CDC.

Preferred DA Preconfigured attribute indicating the expected publisher attribute. If
configured, any bound attribute must match the data type specified
by the preferred DO, CDC, and preferred DA value.

7.22
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Report Control Blocks

[sc_report control, 3, en_US]

Figure 7-23 Properties Window for Report Control Blocks

Group: Identification

Property Description
Name This field represents the current name of the report control block. If

you change the name, the name in the IEC 61850 reports and logs
window also changes.

Type Type Report-Control cannot be changed.
Hierarchical path This list box is used to change the current hierarchical name of the

report control block and its datasets. This path consists of the
IEC 61850 name of the device, the name of the logical device (LD),
and the name of the logical node (LN). The preferred LN is LLN0.

Group: Parameter

Property Description
Integrity This field represents the time period in milliseconds for generating an

integrity report. An integrity report consists of the values of all
members of the related dataset.
Ensure that the Trigger options property, Period is set to Yes.

Supported clients This field represents the total number of clients that can connect to
this report control block.

7.23
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Property Description
Buffer time This entry field contains a value for the buffering time in milliseconds.

The buffering time specifies how long the device buffers the data
before transmitting it to the client.

Buffer indications If you select Yes, the device stores all datasets of the report in the
event of connection failure. When the connection is resumed, the
device transmits the report to the client and deletes the buffered data.

Config revision This field contains the configuration number of the report control
block. After creating a new report control clock, the number is equal
to 1. Then the number is incremented with each change to the config-
uration of the report control block. You can also modify the configura-
tion number manually. To do this, enter an integer value into the
field. In this way, you overwrite the internally assigned configuration
number.

Report ID This field contains a unique name for the report control block. It is the
default hierarchical path of the report control block.

Group: Trigger Options

Property Description
Data change If you select Yes, a data modification causes a report to be trans-

mitted.
Quality change If you select Yes, a quality modification causes a report to be trans-

mitted.
Data update If you select Yes, a data update causes a report to be transmitted.

Unlike the Data change option, the report is also transmitted if the
data have remained the same but have been regenerated or
refetched.

Period If you select Yes, the device periodically transmits the dataset after
expiration of the integrity period.

General interrogation If you select Yes, a single general interrogation is performed after
activation of the reporting. This option is available only for Edition 2.

Group: Optional Fields

Property Description
Sequence numbering If you select Yes, the report is transmitted with its sequence number.
Time stamp If you select Yes, the report is transmitted with its timestamp.
Dataset If you select Yes, the report is transmitted with its dataset name.
Reason for inclusion If you select Yes, the report is transmitted with its reason for inclu-

sion.
Data references If you select Yes, the report is transmitted with its data references.
Entry ID If you select Yes, the report is transmitted with its entry ID.
Config references If you select Yes, the report is transmitted with its config references.
Buffer Overflow If you select Yes, the report is transmitted with its buffer overflow.

The buffer overflow is available only for Edition 2.

Properties
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Log Control Blocks

[sc_log control, 1, en_US]

Figure 7-24 Properties Window for Log Control Blocks

Group: Identification

Property Description
Name This field represents the current name of the log control block. If you

change the name, the name in the IEC 61850 reports and logs
window also changes.

Description This field specifies the description of the log.
Log Name This field represents the relative name of the log within its configured

or corresponding LN.
Type The type Log control cannot be changed.
Hierarchical path This list box is used to change the current hierarchical name of the log

control block. This path consists of the IEC 61850 name of the device,
the name of the logical device (LD), and the name of the logical node
(LN).

Group: Parameter

Property Description
Integrity This field represents the time range in milliseconds for generating an

integrity report. An integrity report consists of the values of all
members of the related dataset.
Ensure that the Trigger options property, Period is set to 1.

Buffer time This field contains a value for the buffering time in milliseconds. The
buffering time specifies how long the device buffers the data before
transmitting it to the subscribers (client).

Log enable This field indicates the logging status.
If the value is set to Yes, remote logging is disabled.
If the value is set to No, remote logging is enabled.

Reason code If the value is set to Yes, the reason code for the event trigger is
included in the log.

7.24
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Group: Trigger Options

Property Description
Data change If you select Yes, a data modification causes a log to be transmitted.
Quality change If you select Yes, a quality modification causes a log to be trans-

mitted.
Data update If you select Yes, a data update causes a log to be transmitted. Unlike

the Data change option, the log is also transmitted if the data have
remained the same but have been regenerated or refetched.

Integrity scan If you select Yes, an integrity scan causes a log to be transmitted.
General interrogation If you select Yes, the device periodically transmits the dataset after

the integrity scan.

Properties
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Client

[sc_clients report, 3, en_US]

Figure 7-25 Properties Window for Client

Group: Identification

Property Description
Type Type Client cannot be changed.
Hierarchical path This list box displays the current hierarchical name of the client.

This path consists of the IEC 61850 name of the device, the
name of the logical device (LD), and the name of the logical
node (LN).

Description This column specifies the description of the client.

7.25
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Menu Bar

[sc_menubar, 2, en_US]

Figure 8-1 Menu Bar

The menu bar contains commands that are frequently required for your work.

Station Menu

The Station menu performs all the station operation for IEC 61850 System Configurator.
Field Description
New This option is used to create a new IEC station in the IEC 61850 System Configu-

rator.
For additional information on creating a new station, refer to 2.2 Creating the IEC
Station.

Open This option is used to open the SCD as IEC station in the IEC 61850 System Configu-
rator.
For additional information on opening the station, refer to 2.3 Opening the IEC
Station.

Close This option is used to close the IEC station in the IEC 61850 System Configurator.
For additional information on closing the station, refer to 2.6 Closing the IEC
Station.

Save This option is used to save all the data of an IEC 61850 station in the IEC 61850
System Configurator. The name and path of this file are automatically assigned.
For additional information on saving the IEC station, refer to 2.4 Saving the IEC
Station.

Save as This option is used to save all the data of an IEC station in the IEC 61850 System
Configurator to a different location.
For additional information on saving the station in the different location and with
the different name, refer to 2.4 Saving the IEC Station.

Import This option is used to import the station, add IEC 61850 devices, and update the IEC
61850 devices.
For additional information on import, refer to 1 Introduction.

Export This option is used to export the documentation as an XML file, the IEC 61850
station, IEC 61850 station with alternative text, and IEC 61850 device configuration.
For additional information on export, refer to 1 Introduction.

Update This option is used to reimport the devices with the updated SCL file.
For additional information on update, refer to 2.11.3 Updating the Devices.

Collect logs This option is used to collect diagnostic logs from the devices.
For additional information on collecting diagnostic logs, refer to 4.2 Collecting the
Diagnostic Logs for Devices Available in the Station.

Archive This option is used to archive the current project.
For additional information on archiving a project, refer to 2.7 Archiving a Project.

Retrieve This option is used to retrieve an archive project.
For additional information on retrieving a project, refer to 2.8 Retrieving a Project.

Print This option is used to print the current view.
For additional information on print, refer to 6.3 Printing the Displayed Information

8.1

8.1.1
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Field Description
Print preview This option is used to display the objects as it is printed. In print preview, you cannot

edit the objects.
For additional information on print, refer to 6.2 Print Preview

Exit This option is used to close all the windows of IEC 61850 System Configurator and
exit the IEC 61850 System Configurator. You can also press Alt+F4 on the keyboard.

ii
NOTE
Import and Export menu options are enabled only for the Devices view.

Edit Menu

The Edit menu options are based on the selection in the IEC 61850 System configurator bar.
Field Description
Undo This option is used to undo the last editing step. This option is enabled as soon as

you have carried out at least one action that can be undone.
You can also press Ctrl+Z on the keyboard to undo the last editing step.

Redo This option restores the last undone editing step. This button is active as soon as
you have undone at least one editing step.
You can also press Ctrl+Y on the keyboard to restore the last undone editing step.

Cut This option copies a marked element or a value to the clipboard. The element or
value is deleted at the actual position as soon as you insert the element or value
at another location with the Paste command. This option is active as soon as a
suitable element or value is marked.
You can also press Ctrl+X on the keyboard to copy an element or a value to the
clipboard.

Copy This option copies a marked element or value to the clipboard. With the Paste
command, you insert the copy of the element or value at another location
without deleting the original object. This option is enabled as soon as a suitable
element or value is marked.
You can also press Ctrl+C on the keyboard to copy the marked element or value
to the clipboard.

Paste This option inserts the content of the clipboard at another permissible location.
The option is enabled if at least one element or value is located in the clipboard.
You can also press Ctrl+V on the keyboard to insert the content of the clipboard
at another permissible location.

Delete This option deletes the marked elements or values. This option is active as soon
as a suitable element or value is marked.
You can also press Delete on the keyboard to delete the marked element or value.

Insert Comment This option is used to enter a name and a comment. This comment can be viewed
in the HiItem section in the History of the SCD file. This information can be used
for future reference of who made which configuration changes.
You can also press Ctrl+Shift+I on the keyboard to view the Insert comment
dialog.

Automatic IP addressing This option assigns consecutive IP addresses to all access points within the
selected subnet.
The address range starts with the IP start address which is entered in the subnet
Properties window. This option is active if a subnet is selected. The IEC 61850
System Configurator issues a warning before existing IP addresses are over-
written. Confirming this warning with OK overwrites the IP addresses of all access
points within the subnet.

8.1.2
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Field Description
Reassigning virtual MAC
address

This option reassigns the IP address to all the GOOSE messages of the station.
The starting point of the address is same as the address entered in the Properties
window of the station.

Insert Menu

The Insert menu options are available only for Network, GOOSE, and Reports and logs editors.
Field Description
SubNetwork This is used to insert a Subnet type element into the network structure. This

option is enabled after the IEC 61850 Station is selected.
GOOSE application This is used to insert a GOOSE application. This option is enabled after the IEC

61850 station is selected.
Dataset This is used to insert a dataset. This option is enabled after the device is selected

in the Applications window.
Report This is used to insert a report to a particular dataset. This option is enabled after

dataset is selected.

View Menu

The View menu options are based on the selection in the IEC 61850 System configurator bar.
Field Description
Devices This option is used to open the Devices editor in the IEC 61850 System Configu-

rator.
Substation This option is used to open the Substation editor in the IEC 61850 System Config-

urator.
Network This option is used to open the Network editor in the IEC 61850 System Configu-

rator.
GOOSE This option is used to open the GOOSE editor in the IEC 61850 System Configu-

rator.
SMV This option is used to open the SMV editor in the IEC 61850 System Configurator.
Reports and logs This option is used to open the Reports and logs editor in the IEC 61850 System

Configurator.
Protocol mapping This option is used to open the Protocol mapping editor in the IEC 61850 System

Configurator.
IEC 61850 System config-
urator bar

This option is used to view or hide the IEC 61850 System configurator bar.
For additional information on IEC 61850 System configurator bar, refer to 8.2 IEC
61850 System Configurator Bar (Navigation Bar).

Toolbar This option is used to view or hide the toolbar in the IEC 61850 System Configu-
rator.
For additional information on Toolbar, refer to 8.3 Toolbar.

Status bar This option is used to view or hide the status bar.
Report This option is used to view the report dialog. This dialog consists of the following:

information about every action, indications about IEC 61850 update, indications
about Open IEC 61850 System Configurator, indications about IEC 61850, indica-
tions about import device (XML), action for IEC 61850 System Configurator and
messages for modem status indications.

Applications This option is used to view or hide the Application window.
For additional information on Application window, refer to 8.4.6.2 Project Tree.

Properties This option is used to view or hide the Properties window.

8.1.3
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Field Description
Sources This option is used to view or hide the Source catalog.

For additional information on Source catalog, refer to 8.4.4.3 Source Catalog.
Destinations This option is used to view or hide the Destination catalog.

For additional information on Destination catalog, refer to 8.4.4.4 Destination
Catalog.

Clients This option is used to view or hide Clients window.
For additional information on Clients window, refer to 8.4.6.6 Clients.

Restore standard This option is used to align all the windows in a standard way (default).
Once this operation is performed, the settings are saved in the project and is used
when the IEC 61850 System Configurator is opened again.
To modify the window size, refer to 2.18.1 Modifying the Window Size.

Option Menu

The IEC 61850 System Configurator user interface is available in various languages. You can select one of
these languages as the user interface language. The designations of all device-independent operating
elements and information are then displayed in the selected language.

ii
NOTE
If the IEC 61850 System Configurator is opened via the IED tool, the language option is disabled, it will
have the same language as the IED tool.

Tools Menu

The Tools menu options are based on the selection in the IEC 61850 System configurator bar.
Field Description
SCL files comparator This option opens the SCL files comparator, which is used to compare SCL files

and IEC 61850 project archives, to analyze the differences between them.
Collect device logs This option opens NetView, which is used to collect the diagnostic logs from the

devices which are available and not available in the station via a TXT file.
Display IEC data This option opens the IEC browser, it is a tool used to view and export IEC data.

Help Menu

Field Description
Help topics This option is used to view the help topics. This option is not available now and it

behaves similar to Using help option.
About This option displays the information about IEC 61850 System Configurator.

For example, Version of the application, Revision, Copyright, and License.
Check for new version This option is used to check if the version of the application is up-to-date. If the

version is not up-to-date, click the link to download the latest version of the applica-
tion.
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IEC 61850 System Configurator Bar (Navigation Bar)

[sc_system configurator bar, 3, en_US]

Figure 8-2 IEC 61850 System Configurator Bar

Tabs Description
Devices Click Devices in the IEC 61850 System configurator bar to display the Devices editor.
Substation Click Substation in the IEC 61850 System configurator bar to display the Substation

editor.
Network Click Network in the IEC 61850 System configurator bar to display the Network

editor.
GOOSE Click GOOSE in the IEC 61850 System configurator bar to display the GOOSE editor.
SMV Click SMV in the IEC 61850 System configurator bar to display the SMV editor.
Reports and logs Click Reports and logs in the IEC 61850 System configurator bar to display the

Reports and logs editor.
Protocol mapping Click Protocol mapping in the IEC 61850 System configurator bar to display the

Protocol mapping editor.

8.2
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Toolbar
Name Field/Icons Description
New Allows you to create a new IEC 61850 station in the IEC

61850 System Configurator.
Open Allows you to open the saved IEC 61850 station.

Save Allows you to save all data of an IEC 61850 station in a station
description file. The name and path of this file are automati-
cally assigned.

Print Allows you to print the current view. View can be Network,
GOOSE or Reports and logs.

Undo Allows you to undo the last editing step. This button is active
as soon as you have carried out at least one action that can be
undone.

Redo Allows you to restore the last undone editing step. This
button is active as soon as you have undone at least one
editing step.

Cut Allows you to copy a marked element or value to the clip-
board. The element or value is deleted at the actual position
as soon as you insert the element or value at another location
with the Paste command. This button is active as soon as a
suitable element or value is marked.

Paste Allows you to insert the content of the clipboard at another
permissible location. This button is active as soon as at least
one element or value is located in the clipboard.

Delete Allows you to delete marked elements or values. This button
is active as soon as a suitable element or value is marked.

Insert Comment Allows you to insert a comment, for your future reference of
who made which configuration changes.

Automatic IP Addressing Allows you to assign consecutive IP addresses to all access
points within the selected subnet. The address range starts
with the IP start address, which is entered in the Subnet Prop-
erties. This button is active if a subnet is selected. The IEC
61850 System Configurator issues a warning before existing
IP addresses are overwritten. Confirming this warning with
OK overwrites the IP addresses of all access points within the
subnet.

SubNetwork Allows you to insert a subnet type element into the network
structure. This button is activated after the icon for the IEC
61850 station is selected.

GOOSE application Allows you to insert a new GOOSE application in the GOOSE
editor. This button is activated after the icon for the IEC
61850 station is selected.

Reassigning virtual MAC
addresses

Allows you to reassign the virtual MAC address.

Expand Allows you to maximize the view of the tree structure for the
selected access point. All levels from the access point to the
data objects are displayed thus. This button is activated if a
maximized view is possible.

Collapse Allows you to minimize the view of the tree structure to the
highest level. As a result of this, only the names of access
points are displayed. This button is activated if the view can
be minimized.

8.3
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Name Field/Icons Description
Dataset Allows you to insert the dataset in the Reports and logs

editor.
Report Allows you to insert a report control block for the datasets.

Insert T104 Address Allows you to insert T104 address in the Protocol mapping
window.
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Editors

Devices

Devices Editor

[le_devices editor, 4, en_US]

Figure 8-3 Devices Editor

(1) Menu bar
(2) Toolbar
(3) IEDs
(4) Properties
(5) Description Pane
(6) IEC 61850 System configurator bar
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IEDs

[sc_IEDs, 4, en_US]

Figure 8-4 IEDs – Editor of the Devices

The IEDs window consists of the following elements:
Element Description
Name This column represents the name of the IED in that station.
IED Description This column represents the names of associated devices for all access points in the

manner in which they were named in the DIGSI Manager.

Properties
This window shows features and related values of the element, which you have selected in the Devices
window. For some features the values can be changed, while for others they are only displayed.

• For additional information on the elements of IEC 61850 station, refer to 7.1 Station.

• For additional information on the elements of IEDs, refer to 7.2 Devices.
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Substation

Substation Editor

[le_substation editor, 2, en_US]

Figure 8-5 Substation Editor

(1) Menu bar
(2) Toolbar
(3) Single-line configuration
(4) Source catalog
(5) Description Pane
(6) Properties
(7) IEC 61850 System configurator bar
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Single-line Configuration

[sc_Substation, topology, 2, en_US]

Figure 8-6 Single-line Configuration - Topology

The Single-line configuration window consists of the following elements for the Topology tab:
Elements Description
Name This field represents the name of the nodes in the topology.
Path This field displays the path of configured LNodes in the format

IEDName/LogicalDevice/LogicalNode.
For the LNodes that are not configured, it displays <Not Connected>.
For all the other nodes, it displays * if the node or its child nodes have
configured LNodes under them.

Comment This field displays the multiline comment that you enter in the proper-
ties window.

Source Catalog

[sc_Source catalogue, substation, 3, en_US]

Figure 8-7 Source Catalog

The Source catalog window consists of the following elements:
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Element Description
Name This column specifies the data objects with icons and names in the form

of a hierarchical tree structure. The highest level is represented by the
IEDs available in the station. Each IED is functionally subdivided into
several logical devices and each logical device is subdivided into logical
nodes.

Description This column specifies the corresponding description of source objects.

Properties
This window shows features and related values of the element, which you have selected in the Substation
window. For some features the value can be changed, while for others they are only displayed.

• For additional information on the elements of IEC 61850 station, refer to 7.1 Station.

• For additional information on the elements of the substation, refer to 7.3 Substation.

• For additional information on the elements of the power transformer, refer to 7.4 Power Transformer.

• For additional information on the elements of the transformer winding, refer to 7.5 Transformer
Winding.

• For additional information on the elements of the voltage level, refer to 7.6 Voltage Level.

• For additional information on the elements of the bay, refer to 7.7 Bay

• For additional information on the elements of the conducting equipment, refer to 7.8 Conducting Equip-
ment.

• For additional information on the elements of the subequipment, refer to 7.9 Sub-equipment.

• For additional information on the elements of the function, refer to 7.10 Function.

• For additional information on the elements of the LNode, refer to 7.11 LNode.
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Network

Network Editor

[le_network editor, 3, en_US]

Figure 8-8 Network Editor

(1) Menu Bar
(2) Toolbar
(3) Subnets
(4) Properties
(5) Description Pane
(6) IEC 61850 System configurator bar

Subnets
This window shows you the current network structure. You can add new subnets or delete the existing ones.
The access points of the existing users can be distributed among the individual subnets with drag and drop
(mouse) or cut and paste (mouse and keyboard or mouse or keyboard).
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[sc_subnets, 2, en_US]

Figure 8-9 Subnets - Network Editor

The Subnets window consists of the following elements:
Element Description
Name This column specifies the network structure with icons and names in the form of a

hierarchical tree structure. At the top of the tree structure, there is an icon for the
IEC 61850 station. This icon is followed by the subnets, which contain the access
points of the individual users.
A level of the structure can be displayed or hidden by clicking on the corresponding
arrow head.
The displayed designations correspond to the names currently entered in the Prop-
erties window.

Name in manager This column specifies the names of associated devices for all access points in the
manner in which they were named in the DIGSI Manager.

IP address This column specifies the IP addresses of access points currently visible in the
network structure. The IP addresses correspond to those specified in the Properties
window.

Properties
This window shows features and related values of the element which you have selected in the Network
window. For some features the values can be changed, while for others they are only displayed.

• For additional information on the elements of IEC 61850 station, refer to 7.1 Station.

• For additional information on the elements of New Devices, refer to 7.13 New Devices Folder.

• For additional information on the elements of the Subnet Folder, refer to 7.14 Subnet.

• For additional information on the elements of the Device, refer to 7.12 Access Point.
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GOOSE

GOOSE Editor

[le_GOOSE editor, 4, en_US]

Figure 8-10 GOOSE Editor

(1) Menu bar
(2) Toolbar
(3) GOOSE messages
(4) Properties
(5) Source catalog
(6) Destination catalog
(7) Description Pane
(8) IEC 61850 System configurator bar

GOOSE Messages

[sc_goose messages, 2, en_US]

Figure 8-11 GOOSE Messages Window

The GOOSE window consists of the following elements:
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Element Description
Source This column specifies the source objects with icons and names in the form of a hier-

archical tree structure. The tree structure is in the form of Access point > Logical
device > Logical node > Data object.
The level of the structure can be displayed or hidden by clicking on the corre-
sponding arrow head.
The displayed designations correspond to the names currently entered in the Proper-
ties window.

CDC This column specifies the Common Data Class.
Description This column specifies the description of the source signal.
Destination This column specifies the destination object.
Description This column specifies the description of the destination signal.

ii
NOTE
In the GOOSE messages window, the column next to the Description represents the name of the subnet.
For example, if there are three subnets in the Network editor, the three columns after the Description
column represent the subnets name.

Source Catalog

[sc_source catalogue, 5, en_US]

Figure 8-12 Source Catalog - GOOSE Editor

In this window, you select a data object, which serves as the source of the interconnection.
The Source catalog window consists of the following elements:
Element Description
Name This column specifies the data objects with icons and names in the form of a hier-

archical tree structure. The highest level is represented by the access points of the
currently selected subnet. Each access point is functionally subdivided into several
logical devices.

CDC This column specifies the Common Data Class.
Description This column specifies the corresponding description of source objects.
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Destination Catalog

[sc_destination catalogue, 6, en_US]

Figure 8-13 Destination Catalog - GOOSE Editor

In this window, you select a data object, which serves as the destination of the interconnection.
The Destination catalog window consists of the following:
Element Description
Name This column specifies the data objects with icons and names in the form of a hier-

archical tree structure. The highest level is represented by the access points of the
currently selected subnet. Each access point is functionally subdivided into several
logical devices.

CDC This column specifies the Common Data Class.
Description This column specifies the corresponding description of the destination objects.

The following filters are available only in the Destination catalog:

• Configured: This filter is used to list the data objects that are configured to be subscribers in the GOOSE
and SMV view.

• Not Configured: This filter is used to list the data objects that are not configured to be subscribers in the
GOOSE and SMV view.

ii
NOTE
For an Edition 2 station, the device is displayed only if the GOOSE attribute value is true under ClientSer-
vices in the Services section.

Properties
This window shows features and related values of the element which you have selected in the GOOSE
messages, Source catalog and Destination catalog.

• For additional information on the elements of IEC 61850 station, refer to 7.1 Station.

• For additional information on the elements of GOOSE application, refer to 7.15 Application.
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• For additional information on the elements of a Dataset, refer to 7.16 Dataset.

• For additional information on the elements of GOOSE-link, refer to 7.17 GOOSE Link.

• For additional information on the elements of DA group, refer to 7.19 DA Group.

• For additional information on the elements of Device in Source catalog, refer to 7.2 Devices.

• For additional information on the elements of Logical Device, refer to 7.20 Logical Device.

• For additional information on the elements of Logical node, refer to 7.21 Logical Node.

• For additional information on the elements of Data object, refer to 7.22 Data Object.

SMV

SMV Editor

[le_smv editor, 4, en_US]

Figure 8-14 SMV Editor UI

(1) Menu bar
(2) Toolbar
(3) SMV messages
(4) Properties
(5) Source catalog
(6) Destination catalog
(7) Description Pane
(8) IEC 61850 System configurator bar
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SMV Messages

[sc_smv messages, 3, en_US]

Figure 8-15 SMV Messages Window

The SMV messages window consists of the following elements:
Element Description
Source This column specifies the source objects with icons and names in the form of a hierarch-

ical tree structure. The tree structure is in the form of Access point > Logical device >
Logical node > Data object.
The level of the structure can be displayed or hidden by clicking on the corresponding
arrow head.
The displayed designations correspond to the names currently entered in the Properties
window.

CDC This column specifies the Common Data Class.
Description This column specifies the description of the source signal.
Destination This column specifies the destination object.
Description This column specifies the description of the destination signal.

ii
NOTE
In the SMV messages window, the column next to the Description represents the name of the subnet.
For example, if there are three subnets in the Network editor, the three columns after the Description
column represent the subnets name.
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Source Catalog

[sc_smv source catalogue, 5, en_US]

Figure 8-16 Source Catalog - SMV Editor

The Source catalog window consists of the following elements:
Element Description
Name This column specifies the data objects with icons and names in the form of a hierarchical

tree structure. The highest level is represented by the access points of the currently
selected subnet. Each access point is functionally subdivided into several logical devices.

CDC This column specifies the Common Data Class for SAV type.
Description This column specifies the corresponding description of source objects.
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Destination Catalog

[sc_smv destination catalogue, 5, en_US]

Figure 8-17 Destination Catalog - SMV Editor

The Destination catalog window consists of the following elements:
Element Description
Name This column specifies the data objects with icons and names in the form of a hierarchical

tree structure. The highest level is represented by the access points of the currently
selected subnet. Each access point is functionally subdivided into several logical devices.

Description This column specifies the corresponding description of the source objects.

Properties
This window shows the features and related values of the element, which you have selected in the SMV
messages, Source catalog, and Destination catalog.

• For additional information on the elements of IEC 61850 station, refer to 7.1 Station.

• For additional information on the elements of SMV application, refer to 7.15 Application.

• For additional information on the elements of a Dataset, refer to 7.16 Dataset.

• For additional information on the elements of the SMV Link, refer to 7.17 GOOSE Link.

• For additional information on the elements of Device in Source catalog, refer to 7.2 Devices.

• For additional information on the elements of Logical Device, refer to 7.20 Logical Device.

• For additional information on the elements of Logical node, refer to 7.21 Logical Node.

• For additional information on the elements of Data object, refer to 7.22 Data Object.
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Reports and Log Control Blocks

Reports and Logs Editor

[le_reports and logs editor, 4, en_US]

Figure 8-18 Reports and Logs Editor

(1) Menu bar
(2) Toolbar
(3) Project tree
(4) Dataset content
(5) Report and Log control blocks
(6) Properties
(7) Source catalog
(8) Clients
(9) Description Pane
(10) IEC 61850 System configurator bar
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Project Tree

[sc_applications, 3, en_US]

Figure 8-19 Project Tree Window - Reports and Logs

This window shows you the reports and log datasets for each IED in that station.
The Project tree window consists of the following:
Element Description
Name This column specifies the name of the IED in that station.

Dataset Content

[sc_dataset content, 2, en_US]

Figure 8-20 Dataset Content - Reports and Logs

The Dataset Content window consists of the following:
Element Description
Name This column specifies the name of the signals added to the dataset that is selected

in the Applications window.
CDC This is the Common Data Class.
Description This column shows the corresponding description of the signals added.
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Reports and Logs Control Blocks

[sc_report and log control blocks, 2, en_US]

Figure 8-21 Report and Logs Control Blocks

Reports and logs control blocks window consists of the following:
Element Description
Name This column specifies the name of the report that is created for a particular

dataset.
Description This column specifies the corresponding description of the report control block for

which the report is requested.

Source Catalog

[sc_reports and logs source, 4, en_US]

Figure 8-22 Source Catalog - Reports and Logs

The Source catalog window consists of the following:
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Element Description
Name This column specifies the data objects with icons and names in the form of a hier-

archical tree structure. The highest level is represented by the access points of the
currently selected subnet. Each access point is functionally subdivided into several
logical devices.

CDC This column specifies the Common Data Class.
Description This column specifies the corresponding description of source objects.

Clients

[sc_clients, 4, en_US]

Figure 8-23 Clients - Report and Logs

The Clients window consists of the following:
Element Description
Name This column lists the names of the clients added in the station.
Description This column shows the corresponding description of the clients.

Properties
This window shows features and related values of the element which you have selected in the Applications
window. For some features the values can be changed, while for others, it is only meant for displaying.

• For additional information on the elements of IEC 61850 station, refer to 7.1 Station.

• For additional information on the elements of IEDs, refer to 7.2 Devices.

• For additional information on the elements of a Dataset, refer to 7.16 Dataset.

• For additional information on the elements of a Dataset entry, refer to 7.17 GOOSE Link.

• For additional information on the elements of Reports, refer to 7.23 Report Control Blocks.

• For additional information on the elements of Logical Device, refer to 7.20 Logical Device.

• For additional information on the elements of Logical node, refer to 7.21 Logical Node.

• For additional information on the elements of Data object, refer to 7.22 Data Object.

• For additional information on the elements of the client, refer to 7.25 Client.
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Protocol Mapping

Protocol Mapping Editor

[le_protocol mapping editor, 3, en_US]

Figure 8-24 Protocol Mapping Editor

(1) Menu bar
(2) Toolbar
(3) Project tree
(4) Protocol mapping
(5) Properties
(6) IEC 61850 System configurator bar
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Project Tree

[sc_protocol mapping table, 3, en_US]

Figure 8-25 Project Tree

This window shows you the current network structure reduced to the subnet. The Project Tree window
consists of the following:
Element Description
Name This column specifies the name of the IED in that station.

Protocol Mapping

[sc_protocol mapping window, 3, en_US]

Figure 8-26 Protocol Mapping Window

The Protocol Mapping window consists of the following elements:
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Element Description
Topology Path This column specifies the topology paths corresponding to the LN mentioned in

the LN configuration. If the LN is not configured in the substation topology, the
path is empty.

IED This column specifies the name of all the devices available in the station.
LD This column specifies the name of all the logical devices available in the devices.
LN This column specifies the name of the logical node based on the logical devices

listed in the LD column.
DO This column specifies the data objects corresponding to the logical nodes in the

LN column.
DA This column specifies the data attribute for each data object in the DO column.
CDC This column specifies the Common Data Class.
Description This column specifies the corresponding description of Protocol mapping objects.
casdu This column specifies the common address of ASDU (T104 address).
ioa This column specifies the information object address (signal information).

The IOA value of each address is one unit more than the highest IOA value of the
previously added address.

ti This column specifies the type of the signal.

Custom Filter

[le_Custom filter, 1, en_US]

Figure 8-27 Custom Row Filter - Elements

(1) Cell
(2) Text box
(3) AND or OR
(4) OK
(5) Cancel

This dialog is used to generate a user-defined filter with which you can filter the column contents. A filter
consists of one or more expressions linked with logical operators.
The explanation for the elements in the Custom filter dialog is as follows:
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Element Explanation
Cell Use this list box to select a condition for an expression.

You can select any of the following conditions:

• Equals
• Does not equal
• Is greater than
• Is greater than or equal to
• Is less than
• Is less than or equal to
• Begins with
• Does not begin with
• Ends with
• Does not end with
• Contains
• Does not contain

Text box Use this text box to define a value for an expression. The value corre-
sponds to the values that can occur in the column to be filtered.

AND or OR Select one of the logical operators AND and OR with which you wish to
combine two expressions. If a filter consists only of a single expression,
you do not have to select a logical operator.

OK This button is used to apply the created filter and close the dialog. The
display of the content is updated based on the created filter. This button
remains inactive until you create at least one expression.

Cancel This button is used to abort the filter creation and close the dialog.

Properties
This window shows features and related values of the elements that you have selected in the Project tree
window.

• For additional information on the elements of IEC 61850 station, refer to 7.1 Station.

• For additional information on the elements of IEDs, refer to 7.2 Devices.
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Trace Logs and Crash Dump
The trace logs and crash memory dump allow significantly to reduce the analysis time in customer projects. It
details the customer logs and thus facilitates reproducibility by Siemens support. In case of fatal application
error, it also provides advanced details to Siemens support.

Crash Dump
When there is a fatal error or when the application crashes, a crash dump file is created with the name
SysconCrashDump_yyyyMMdd_hhmmss in %ALLUSERSPROFILE%\Siemens Energy\IEC61850SystemConfi-
gurator\SysconCrashDump directory. At any point of time, maximum of two files are available in that direc-
tory. The latest file overwrites the oldest file when there are two dump files in the directory.

ii
NOTE
To launch IEC 61850 System Configurator, there must be at least 1 GB of free physical memory (Operating
System installation drive). Once the IEC 61850 System Configurator is launched, if the memory becomes
less than 1 GB and if a crash occurs, a log file (.txt) is created. The Not enough memory to create crash
memory dump message is logged in the text file.

Customer Logs and Developer Logs
When the user encounters an abnormal behavior because of the issues in the application, the log files can be
viewed to analyze the workflow and then send the logs to the customer support for further analysis.

Customer Logs
All the critical messages pertaining to the actions performed by the user are logged in SysconCustomerTra-
ceLog_yyyyMMdd_hhmmss.csv file in %ALLUSERSPROFILE%\Siemens Energy\IEC61850SystemConfigu-
rator\SysconCustomerTraceLog directory. These logs contain only the Error level category and the maximum
size of the file is 10 MB. At any point of time, maximum of five files are available in the SysconCustomerTra-
ceLog directory.

Developer Logs
All the detailed messages pertaining to the actions performed by the user are logged in SysconDeveloperTra-
ceLog_yyyyMMdd_hhmmss.csv file in ALLUSERSPROFILE%\Siemens Energy\IEC61850SystemConfigurator
\ SysconDeveloperTraceLog directory. These logs contain messages from all the categories and the maximum
size of the file is 10 MB. At any point of time, maximum of five files are available in the SysconDeveloperTra-
ceLog directory.

ii
NOTE
Customer log is a subset of developer log.

User can switch between developer logs and customer logs by changing the value of TraceLevelSwitch in
C:\Program Files (x86)\Siemens Energy\IEC 61850 System Configurator V5.20\Configurator
\IEC61850Conf.exe.config file. For customer logs, the TraceLevelSwitch value is 1 and for developer logs, it
is 4.

ii
NOTE
By default, the TraceLevelSwitch value is set to 1. It will be changed temporarily only in agreement with
Siemens customer support.

A.1

Appendix
A.1 Trace Logs and Crash Dump

176 Software, System Configurator, Manual
E50417-H1140-C520-B1, Edition 06.2019



System Implementation Conformance Statement (SICS)
ICD Import and IID Import along with their Usage Supported or not? Value or Comments

S11 IED data model Y
S12 Predefined data sets Y
S13 Predefined control blocks Y
S14 Refuse import if SCL version/revi-

sion/release is higher than
supported by SCT.

Y

S15 Import up to maximum supported
SCL version and revision

Y 2003, 2007, 2007B

S16 Substation bay template with LN
links, if it exists

Y

S17 Reuse already imported DataType-
Templates for identical types

Y

S18 Keep attributes and elements of
unknown XML name spaces
outside Private elements for SCD
export

Y

S19 Import the defined single line
layout coordinates

Y

S110 Import of IID file; update configura-
tion values and setting values,
modify data model

Y Configuration values and
setting values are not
displayed and therefore not
changed.

S111 Imports SCL in UTF-8 coding Y
Communication Engineering

S21 Configure (edit) IED names Y
S22 Create and configure Subnetworks

and IED communication addresses
Y Except OSI address parameters

S23 Create or import client IEDs, master
clocks, switches, and routers

Y

S24 Create and configure physical
connection attributes

S25 Configure ldName values Y
S26 Configure ldInst and LN prefixes, if

the IED allows
Y

Data Flow Engineering
S31 Configure control blocks Y
S32 Create control block types or

instances, if IED capabilities allows
Y

S33 Create data sets, if IED capability
allows

Y

S34 Modify predefined or created data
sets

Y

S35 Manage control block confRev Y
S361 Allocate control block instances to

clients and define data destinations
(ClientLn element, IEDName
element) for all types of data flow
related control blocks

Y

A.2

Appendix
A.2 System Implementation Conformance Statement (SICS)

Software, System Configurator, Manual 177
E50417-H1140-C520-B1, Edition 06.2019



S362 Allocate Logs to Log control blocks
if the IED capabilities allow this

Y

S37 Edit Input sections in LNs Y
S381 Create Input section from config-

ured data set flow for GOOSE and
SV services

S382 Create Input section from config-
ured data set flow for report service

S38 Create Input section from config-
ured data set flow

Y

S39 Provide source control block refer-
ence for signals in Input section

Y

SCD Substation Section Handling
S41 Import Substation section from SSD

or SCD file
Y

S42 Edit or create substation section Y
S43 Bind logical nodes from IEDs to

substation section
Y

S44 Create bay instances from IED or
ICD substation templates

Y

S45 Edit or create substation topology
connections between primary
equipments

Y

S46 Edit substation element names and
desc attributes.

Y

S47 Edit Equipment terminals (name
attribute of the Terminal element)

Y

S48 Edit or create the Function,
SubFunction, or GeneralEquipment
naming hierarchies

Y Only Edit or create function
and general equipment are
supported.

SCD Modifications
S51 Handle SCD Header revision and

version; mark an SCD file change
by a new revision or version indica-
tion

Y Automatically increment

S52 Set configuration values (attributes
with fc=CF, DC)

S53 Set Parameter (Setting DATA,
fc=SP) values, also for different
setting groups

S54 Add or modify layout coordinates
S55 Show IED service or engineering

capabilities to engineer
Y

S56 Interpret IED capabilities and
prohibit unsupported usage

Y

S57 Editing of data attributes valKind
property

S58 Handle SCD Header revision history
with a new entry for each new
version or revision.

Y

SCD Export
S61 Previous version(s) and revision(s)

export
Y
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S62 Highest supported version/revision/
release export

Y

S63 Version ________ export
S64 Restore imported private sections Y
S65 Export restructured DataTypeTem-

plate types (keeping all instance-
related information and all private
information constant).

Y

S66 Keep type identifiers in DataType-
Template section. It is unique even
if on ICD import the same ID is used
in different ICD files for different
type structures.

Y

S67 Export SCL in UTF-8 coding Y Only UTF-8 is supported
SCD Import

S71 Previous version(s) latest revision
import

Y

S72 Highest supported version/revision/
release import

Y

S73 Reserved
S74 Add new bays or equipment in

substation section
Y

S75 Add links from substation section
to IEDs

Y

S77 Update IED configuration values Y
S78 Update IED setting DATA values Y
S79 Add new IEDs Y

SED Handling
S81 Export SED for selected dataflow

IEDs
Y Dataflow is always set to fix

S82 Import SED with exported part Y
S83 Prohibit editing of IEDs exported

with dataflow right (inclusive
Substation section links and
communication addresses)

Y Dataflow is always set to fix

S84 Import SED for usage in own
project; export modified SED back
to the source project

Y

S85 Import or merge Substation section
part from SED

Y SED contains only GOOSE data
and not the substation data

S86 Import or merge Communication
section part from SED

Y

Y represents that it is supported by IEC 61850 System Configurator.
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Exporting and Importing an SED File
To export an SED file which includes GOOSE datasets from one project to another project, proceed as follows:
² Open the IEC 61850 System Configurator.

Ensure that the GOOSE datasets are configured.
For more information on configuring GOOSE datasets, refer to 2.14.1 Overview of the GOOSE Communi-
cation.

² Select the desired GOOSE dataset to be exported from the project.

² In the Properties window, set the value of the Include in SED export parameter to Yes.
For more information on SED files, refer to 2.14.19 Selecting the Dataset for SED Export.

[sc_Goose_dataset_properties, 1, en_US]

Figure A-1 Include in SED File

² Click Station > Export from the menu bar and select IEC 61850 station from the submenu options.
The Export IEC 61850 station dialog is displayed.

² Navigate to the storage location and enter the name for the SED file.

² Select the SED file type from the Save as type list box.
For more information on exporting SED files, refer to 3.1.2 Exporting IEC 61850 Station (SCD, SED, SSD)

A.3
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[sc_Save_station_SED, 1, en_US]

Figure A-2 Save SED File

² Click Save.
The SED file is exported to the desired location.

² Close the source project and open the desired destination project.

² Click Station > Import from the menu bar and select IEC 61850 station from the submenu options.
The Import IEC 61850 station dialog is displayed.

² Navigate to the storage location and select the SED file.

² Click Open.
The SED file is imported with the source-project GOOSE datasets.
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[sc_Goose_dataset_imported, 1, en_US]

Figure A-3 Imported IEDs

The imported GOOSE dataset is indicated by  and IEDs are indicated by .
The destination signals of the IED from the destination project can be subscribed to the imported GOOSE
dataset of the source project.
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[sc_Goose_dataset_sub, 1, en_US]

Figure A-4 GOOSE Datasets

For more information on subscribing GOOSE datasets, refer to 2.14.14 Generating the GOOSE Connection.

ii
NOTE
For an Edition 2 project, if the GOOSE control block name is edited and reimported to the project, the
subscriber control block reference is not updated. You will have to manually edit the control block name
after importing it.
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Copying GOOSE and the Report Configuration within or between
IEDs
To copy GOOSE and the report configuration within or between IEDs, proceed as follows:
² Open the IEC 61850 System Configurator, which has GOOSE already configured.

² In the GOOSE Editor in the GOOSE messages section, select the GOOSE dataset.
For more information on copying multiple GOOSE datasets across IEDs, refer to 2.14.13 Copying all
GOOSE Datasets across IEDs.

² Right-click the dataset and select Copy from the context menu.

[sc_copying_dataset, 1, en_US]

Figure A-5 Copying Dataset - GOOSE Messages

² Right-click the GOOSE application in the GOOSE messages section or the device in the Source catalog
where you want to paste the dataset and select Paste GOOSE Configuration.
The Paste GOOSE Configuration dialog is displayed.

[sc_paste_goose_config, 1, en_US]

Figure A-6 Pasting GOOSE Configuration
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² Select the Target IED and the Logical Device (LD) correspondingly from the list box.

² Click Paste.

² Select an IED/LD/LN from the Destination catalog which already has configured subscribers.

² Right-click the IED/LD/LN and select the Copy from the context menu.

[sc_copying_LN, 1, en_US]

Figure A-7 Copying LN - Destination Catalog

² Right-click the IED/LD/LN from the Destination catalog where you want to paste the GOOSE subscrip-
tions and select Paste.
The GOOSE subscriptions get pasted to the IED/LD/LN.
For more information on copying an IED/LD/LN from the Destination catalog, refer to 2.14.15 Copying
the GOOSE Subscribers across IEDs.

² In the Reports and logs Editor, select a dataset from an IED from the Project tree.

² Right-click the dataset and select Copy from the context menu.
For more information on copying an IED from the Project tree, refer to 2.16.12 Copying all the Reports
and Datasets across IEDs.
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[sc_copying_from_IDE, 1, en_US]

Figure A-8 Copying Dataset - Project Tree

² Right-click any IED from the Project tree where you want to paste the report datasets and select Paste.
The Paste GOOSE Configuration dialog is displayed.

² Select the Target IED and the Logical Device (LD) correspondingly from the list box.
All the reports and the associated datasets get pasted to the IED.

² In the Devices Editor, select an IED.

² Right-click the IED and select Copy from the context menu.

² Right-click an IED from the Devices Editor where you want to paste the GOOSE and reports datasets and
select Paste.
The GOOSE and reports datasets get pasted to the IED.

² In the Substation Editor, right-click the bay and select Copy from the context menu.

² Right-click any desired voltage level in any Substation and select Paste from the context menu.
A copy of the bay is created in the substation.
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[sc_pasting_bay, 1, en_US]

Figure A-9 Pasting Bay - Substation

ii
NOTE
The LNode is not copied.
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Working with Mixed IEC 61850 Editions
Adding a DIGSI Project to an Existing SCD Project

To associate an IEC 61850 System Configurator project with the DIGSI 5 IEC station, proceed as follows:
² In DIGSI 5, open a project tree that contains an IEC station or create a new IEC station.

² Double-click the IEC 61850 stations folder in the project tree.

² Right-click the IEC station to which a device or devices are assigned and select Properties … from the
context menu.

[sc_DIGSI5_Station_Prop, 1, en_US]

Figure A-10 DIGSI 5 Properties

The IEC station 1 [IECStationData] dialog is displayed.
² Click .

The Assign IEC 61850 station description (SCD) dialog is displayed.

² Navigate to the desired location and select the existing SCD project file.

² Click Open.
The selected SCD file is displayed in the IEC 61850 station description file field.

A.5
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[sc_Selected_SCD_File, 1, en_US]

Figure A-11 SCD-File Selection

² Click OK.
The IEC 61850 System Configurator project file is associated with the DIGSI 5 IEC station.
To associate an IEC 61850 System Configurator project with the DIGSI 4 IEC station, proceed as follows:
² In DIGSI 4, right-click the IEC station and select Properties… from the context menu.

The Properties – IEC 61850 station dialog opens.
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[sc_DIGSI4_Prop, 1, en_US]

Figure A-12 DIGSI 4 Properties

²
Click  in the Station description file section in the Information tab.
The IEC 61850 station create or assign data dialog opens.

² Navigate to the desired location and select the desired SCD file.

² Click OK.
The IEC 61850 System Configurator project file is associated with the DIGSI 4 IEC station.
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[sc_DIGSI4_Ed_set, 1, en_US]

Figure A-13 DIGSI 4 Mapping

ii
NOTE
An Edition 1 or Edition 2 project created with the IED tool can be mapped to an existing Edition 1, Edition 2,
and Edition 2.1 SCD file respectively.

Upgrading SCD Project to Edition 2
To change the edition of the station, proceed as follows:
² In the IEC 61850 System Configurator, in the Devices editor, select an IEC station.

² In the Properties section on the right, click the drop-down arrow button for Edition.

² Select the edition from the list box.
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[sc_Edition_Changing, 1, en_US]

Figure A-14 Edition Change

The edition of the station is changed.

ii
NOTE
Only the SCD-file edition is changed in the IEC 61850 System Configurator, the edition of the devices
remains the same in DIGSI 4 and DIGSI 5.

Automatic Upgrade of the SCD Edition
The changes of the IEC 61850 Edition in IED tools (for example DIGSI 4, DIGSI 5) are done automatically by the
IEC 61850 System Configurator.
To check the edition of an SCD file, proceed as follows:
² In DIGSI 5 or in DIGSI 4, upgrade to an Edition 2 station.
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[sc_DIGSI4_Browse, 1, en_US]

Figure A-15 DIGSI 4 Browser – SCD File Selection

² Open IEC 61850 System Configurator from DIGSI 5 or DIGSI 4.

² The IEC 61850 System Configurator will automatically convert the Edition 1 SCD file to an Edition 2
SCD file.

To check the edition version of the SCD file, check the Edition field in the Properties window.

ii
NOTE
Edition compatibility of the station and SCL files:

• Edition 1 SCL files can be imported to an Edition 1 station.

• Edition 1 and Edition 2 SCL files can be imported to an Edition 2 station.

• Edition 1, Edition 2, and Edition 2.1 SCL files can be imported to an Edition 2.1 station.
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