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Safety Guidelines 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to 

prevent damage to property. The notices referring to your personal safety are highlighted in the manual 

by a safety alert symbol, notices referring to property damage only have no safety alert symbol. The 

notices shown below are graded according to the degree of danger. 
 

!  
Danger 
indicates that death or severe personal injury will result if proper precautions are not taken. 

 

!  
Warning 
indicates that death or severe personal injury may result if proper precautions are not taken. 

 

!  
Caution 
with a safety alert symbol indicates that minor personal injury can result if proper precautions are not 
taken. 

 
 Caution 

without a safety alert symbol indicates that property damage can result if proper precautions are not 
taken. 

 
 Attention 

indicates that an unintended result or situation can occur if the corresponding notice is not taken into 
account. 

If more than one degree of danger is present, the warning notice representing the highest degree of 

danger will be used. A notice warning of injury to persons with a safety alert symbol may also include a 

warning relating to property damage. 

Qualified Personnel 

The device/system may only be set up and used in conjunction with this documentation. Commissioning 

and operation of a device/system may only be performed by qualified personnel. Within the context of 

the safety notices in this documentation qualified persons are defined as persons who are authorized to 

commission, ground and label devices, systems and circuits in accordance with established safety 

practices and standards. 

Prescribed Usage 

Note the following: 
 

!  
Warning 
This device and its components may only be used for the applications described in the catalog or the 
technical description, and only in connection with devices or components from other manufacturers 
which have been approved or recommended by Siemens. 
Correct, reliable operation of the product requires proper transport, storage, positioning and assembly 
as well as careful operation and maintenance. 

Trademarks 

All names identified by ® are registered trademarks of the Siemens AG.  

The remaining trademarks in this publication may be trademarks whose use by third parties for their 

own purposes could violate the rights of the owner. 
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Preface 

Purpose of the Manual 
This manual provides a complete overview of programming with SIMATIC PDM. It 
is designed to support you when installing and commissioning the software. It 
explains the procedure for configuring networks and process devices as well as the 
commissioning and run-time functions. 

The manual is intended for persons who are involved in the configuration, 
commissioning and operation of the plant in the field of field control technology.   

Required Basic Knowledge 

In order to understand this manual, general knowledge of field control technology is 
required.  

In addition, you must be familiar with using PCs with Windows operating systems.  

If used with STEP 7 and PCS 7, a corresponding knowledge in the field of 
automation technology and SIMATIC S7 are required. 

Where is this Manual valid? 

This manual is valid for the SIMATIC PDM V6.0 programming software package. 
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Online Help 

The manual is complemented by an online help that is integrated in the software. 
This online help is intended to provide you with detailed support when using the 
software. 

The help system is integrated in the software via a number of interfaces: 

• There are several menu commands that you can select in the Help menu: The 
Contents command opens the index for the Help on SIMATIC PDM.  

• The context-sensitive help offers information on the current context, for 
example, an open dialog box or an active window. You can open the context-
sensitive help by clicking the "Help" button or by pressing F1. 

• The status bar offers another form of context-sensitive help. It displays a short 
explanation for each menu command when the mouse pointer is positioned on 
the menu command. 

• A brief explanation is also displayed for each icon in the toolbar when the 
mouse pointer is positioned on the icon for a short time. 

If you prefer to read the information from the online help in printed format, you can 
print out individual help topics, books, or the entire online help. 

This manual is an extract from the HTML-based Help on SIMATIC PDM. For 
detailed procedures please refer to the SIMATIC PDM help. As the manual and the 
online help share an almost identical structure, it is easy to switch between the 
manual and the online help. 

Getting Started 

The Getting Started "First Steps with SIMATIC PDM" contains the project 
"PDM_1", which makes it possible for you to create your own fully-functional 
project. 

You can find the Getting Started "First Steps with SIMATIC PDM" on the CD 
"SIMATIC PDM V 6.0" in the folder "Manuals" as the file "PDM Getting 
Started.pdf". 
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Further Support 

If you have any technical questions, please get in touch with your Siemens 
representative or agent responsible. 

You will find your contact person at:  

http://www.siemens.com/automation/partner 

You will find a guide to the technical documentation offered for the individual 
SIMATIC Products and Systems here at: 

 http://www.siemens.com/simatic-tech-doku-portal 

The online catalog and order system is found under: 

http://mall.ad.siemens.com/ 

Training Centers 
Siemens offers a number of training courses to familiarize you with the SIMATIC 
S7 automation system. Please contact your regional training center or our central 
training center in D 90327 Nuremberg, Germany for details:  

Telephone:  +49 (911) 895-3200.  

Internet: http://www.sitrain.com 

http://www.siemens.com/automation/partner
http://www.siemens.com/simatic-tech-doku-portal
http://mall.ad.siemens.com/
http://www.sitrain.com
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Technical Support 

 

You can reach the Technical Support for all A&D products 

• Via the Web formula for the Support Request 
http://www.siemens.com/automation/support-request 

• Phone:  + 49 180 5050 222 

• Fax: + 49 180 5050 223 

Additional information about our Technical Support can be found on the Internet 
pages http://www.siemens.com/automation/service 

Service & Support on the Internet 
In addition to our documentation, we offer our Know-how online on the internet at: 

http://www.siemens.com/automation/service&support 

where you will find the following: 

• The newsletter, which constantly provides you with up-to-date information on 
your products. 

• The right documents via our Search function in Service & Support. 

• A forum, where users and experts from all over the world exchange their 
experiences. 

• Your local representative for Automation & Drives. 

• Information on field service, repairs, spare parts and more under "Services". 

 

http://www.siemens.com/automation/support-request
http://www.siemens.com/automation/service
http://www.siemens.com/automation/service&support
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1 Product Introduction and Installation 

1.1 Field of Application 

This Help is for the SIMATIC PDM basic functions including an introduction 
to the configuration of networks and devices. 

 

SIMATIC PDM works within a SIMATIC STEP 7 / PCS 7 environment or at 
least with function modules from it. This Help does not cover these areas! 

 

SIMATIC PDM generates device-specific Help (e.g. on the meaning of 
variables etc.) from the respective Device Descriptions (DDs). This Help does 
not cover specific devices! 

 

SIMATIC PDM undertakes no guarantee of and liability for the correctness 
and completeness of the aforementioned Help that is not part of 
SIMATIC PDM! 
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1.2 Introduction 

SIMATIC PDM is a software package for configuring, parameterizing, 
commissioning and maintaining devices (e.g. transducers) and for configuring 
networks and PCs. 

Among other features, SIMATIC PDM contains a simple process monitoring of the 
process values, interrupts and status signals of the device as well as support for 
putting them in operation and maintaining them by means of a LifeList program, 
which can detect field device configurations and structure projects online. 

SIMATIC PDM is an open tool for device integration. There are already 1,000 
devices from more than 100 device manufacturers integrated in it. The basis for 
device integration is the EDDL (Electronic Device Description Language), which is 
governed by international standard IEC 61804-2. This standard was developed in 
cooperation with the PROFIBUS user organization of the HART Communication 
Foundation and Fieldbus Foundation. 

The EDD (Electronic Device Description) is created by the device manufacturer or 
another service provider. It is supplied along with the device on a data carrier, 
made available on the Internet or integrated into device catalogs for EDD 
applications. 

Whenever necessary, you can import EDDs from different device manufacturers. 
These can be obtained from a diskette or downloaded from the Internet. 

SIMATIC PDM contains functions for Asset Management and Lifecycle 
Management. For integration of the maintenance station, the software supports the 
integrated field devices by means of detailed diagnostics and diagnostics 
classification. 

Options 
The standard version of SIMATIC PDM can use 4 TAGs (a "TAG" is a device) 
simultaneously in a project. If you want to use more than 4 TAGs per project, you 
can also order SIMATIC PDM with 128 TAGs up to an unlimited number of TAGs.  

With the "Integration in STEP 7/PCS 7" option, SIMATIC PDM is based on the 
SIMATIC STEP 7 or SIMATIC PCS 7 software package and is permanently 
integrated as an optional package in the existing installation. This option also 
allows the configuration of PROFIBUS-DP/PA networks and devices with the aid of 
STEP 7 HW-Config.  

The combination of SIMATIC PDM and the Integration in STEP 7/PCS 7 option is 
referred to below as SIMATIC PDM Integrated. 

Sample projects 

SIMATIC PDM come with the following sample projects: 

• DPPA: this project contains a PROFIBUS device (Sitrans P) and an ET 200M 
with HART devices on an analog input module. 

• HART: this sample project contains a HART device (Sitrans TK-H). 

• Multiplexer: this sample project contains a multiplexer and a HART device 
(Sitrans P ES). 

These sample projects can only be used with STEP 7 or PCS 7 and the 
"Integrated" option. 
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1.3 What is New in SIMATIC PDM V6.0? 

Installation 

As of SIMATIC PDM V6.0, there is now a new license model. User rights are no 
longer issued by means of authorizations but by license keys. License keys are 
managed in the Automation License Manager (see User rights through the 
Automation License Manager). The program AuthorsW is no longer used. 

Supported Operating Systems 

As of SIMATIC PDM V6.0, the following operating system are supported: 

• MS Windows 2000 Professional 

• MS Windows XP Professional 

SIMATIC PDM LifeList 

The SIMATIC PDM LifeList program has been revised for SIMATIC PDM V6.0:  

• You now of the option of starting SIMATIC PDM LifeList at a PROFIBUS link 
and, in doing so, getting the LifeList for the subnets belonging to this link. If the 
link object has a link to HW-Config, a connection is established over data 
record routing. This means that the programming device (PG)/PC does not 
necessarily have to be located on the PROFIBUS segment where the IM 157 
module is located. To use this option, select the DP/PA link object and, in the 
context menu for the network view in the SIMATIC Manager or in the SIMATIC 
PDM application, select the "LifeList" menu item. SIMATIC PDM LifeList is 
started and performs a scan of the DP/PA link. The LifeList for the associated 
PA subnet is displayed. 

• To specify which information you want to have displayed, select the View > 
Columns ... menu command. 

• You now have the option of performing subsequent diagnostics. To do so, 
select the Scan > Diagnostics menu command. 

• After you have selected a node, you can now copy the contents of the cell in 
which the cursor is located onto the clipboard (Copy context menu command) 
and, from there, paste it into another program with which you can process the 
contents further. This feature allows you to simply use copy-and-paste to 
transfer the long address for the HART device when configuring a HART 
device behind a HART interface. 

Export / Calibration Log 

In addition to the list of all device parameters, you can now also export the 
following information: 

• HTML display information, and 

• All entries in the change log, or 

• A calibration log (check log) 

This content can be displayed in and printed from a web browser. 
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Update and Supplement of Supported Devices 

The device descriptions of the supported devices were updated to the current 
version. The current library (June 2004) of the HART devices of the HART 
Communication Foundation (HCF) is integrated in this version. 

Improved Product Structure 

• SIMATIC PDM V6.0 is supplied with 2 CDs. The first CD contains the software, 
and the second CD contains the device catalog as well as the HCF library.  

• SIMATIC PDM V6.0 Single Point: contains both CDs for SIMATIC PDM as well 
as the "Single Point" authorization 

• SIMATIC PDM V6.0 Basic: contains the SIMATIC PDM demo version as well 
as the "Basic" authorization 

• SIMATIC PDM V6.0 Service: contains SIMATIC PDM Basic as well as the 
"TAG 128" authorization 

• SIMATIC PDM V6.0 S7: contains SIMATIC PDM Service as well as the 
"Integration in STEP 7" authorization 

• SIMATIC PDM V6.0 PCS 7: contains SIMATIC PDM S7 as well as the 
"Routing" authorization 

• SIMATIC PDM Upgrade from V5.2 to V6.0: contains the SIMATIC PDM demo 
version as well as the "Upgrade" authorization disk. 

Change Log 

As of SIMATIC PDM V6.0, you can keep a change log to track the changes made 
by a given user at a given time in a given project. 

You can use the "SIMATIC PDM change log" tool to view entries in the change log 
and change the settings for archiving. 

The logging of changes is automatically started if there is license for at least 
128 TAGs present. 

SIMATIC PDM Application 

More Security and Convenience When Configuring a Plant 

• SIMATIC PDM indicates inconsistencies between project data and device 
configuration parameters. 

• SIMATIC PDM supports the use of configuration flags in devices. 

• When SIMATIC PDM is exited, it reports any devices that are in simulation 
mode or in manual mode. 

Updating the Diagnostic Status 

By selecting the "Update diagnostic status" menu item in the SIMATIC Manager or 
in SIMATIC PDM, you can update online the diagnostic status of devices that 
report their status. 
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Device Icons 

There are now more device icons available (see Icons for Devices). 

Long Device Names 

As of SIMATIC PDM V6.0, you can give HART Revision 6 devices names up to 32 
characters long. 

Device Import 

As of SIMATIC PDM V6.0, there is a separate device CD that is updated 
independently of the software. The device import function is integrated in PDM 
through the "Manage the SIMATIC PDM device catalog" program. The help 
program "DeviceInstall" is thus no longer supplied and cannot be used for 
PDM V6.0. 
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1.4 Options for SIMATIC PDM 

The following options are available for SIMATIC PDM: 

• Integration in STEP 7 / PCS 7 
This option is only required if you intend to integrate PDM into HW-Config. 

• Routing via STEP 7 stations 

• Communication though standard HART multiplexers 

TAG Options for SIMATIC PDM 

• Up to 128 TAGs 

• Up to 512 TAGs 

• Up to 1024 TAGs 

• Up to 2048 TAGs 

• Unlimited TAGs 

• Power Pack (128 TAGs > 512 TAGs) 

• Power Pack (512 TAGs > 1024 TAGs) 

• Power Pack (1024 TAGs > 2048 TAGs) 

• Power Pack (2048 TAGs > unlimited TAGs) 
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1.5 Installation 

1.5.1 Installing SIMATIC PDM 

SIMATIC PDM contains a Setup program that carries out the installation 
automatically. Input prompts on the screen guide you step-by-step through the 
entire installation process. The standard procedure in Windows 2000/XP for 
installing software is called up.  

The essential phases of the installation are:  

• Copying the data to the path selected by you, 

• The authorization (if desired, it can also be installed later). 

Installation Requirements 

• Microsoft Windows operating system; you will find detailed information in the 
Readme.wri file. 

• Basic hardware  
PC or programming device with 

- Pentium PC; you will find detailed information in the Readme.wri file. 

- RAM: you will find detailed information in the Readme.wri file. 

- Color monitor, keyboard and mouse that are supported by Microsoft 
Windows.  

All the SIMATIC PDM files on the program CD are installed on a hard disk with the  
SETUP program. The files are stored in compressed form on the program CD and 
are decompressed during the transfer. 

SIMATIC PDM cannot be started from the CD! After it has been installed 
successfully it can be started by clicking on the SIMATIC Manager icon. 
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1.5.2 Removing SIMATIC PDM 

Use the usual Windows procedure for removing programs:  

1. Start the dialog box for installing/removing software under Windows by double-
clicking on the "Add/Remove" icon in the "Control Panel".  

2. Select the "SIMATIC PDM" entry in the displayed list of installed software. 
Then click on the command button to "Remove" the software.  

3. If "Remove released file" messages are displayed, click on the "No" command 
button, if you are not sure.  

1.5.3 Automation License Manager 

1.5.3.1 User Rights Through The Automation License Manager 

Automation License Manager 

To use SIMATIC PDM, you require a product-specific license key (user rights). 
Starting with V6.0, this key is installed with the Automation License Manager.  

The Automation License Manager is software product from Siemens AG. It is used 
to manage the license keys (license modules) for all systems. 

The Automation License Manager is located in the following places: 

• On the installation device for a software product requiring a license key  

• On a separate installation device 

• As a download from the Internet page of A&D Customer Support at 
Siemens AG 

The Automation License Manager has its own integrated online help. To obtain 
help after the license manager is installed, press F1 or select the Help > Help on 
License Manager. This online help contains detailed information on the 
functionality and operation of the Automation License Manager. 

Licenses 

Licenses are required to use STEP 7 program packages whose legal use is 
protected by licenses. A license gives the user a legal right to use the product. 
Evidence of this right is provided by the following: 

• The CoL (Certificate of License), and 

• The license key 

Certificate of License (CoL) 

The "Certificate of License" that is included with a product is the legal evidence that 
a right to use this product exists. This product may only be used by the owner of 
the Certificate of License (CoL) or by those persons authorized to do so by the 
owner. 
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License Keys 

The license key is the technical representation (an electronic "license stamp") of a 
license to use software. 

SIEMENS AG issues a license key for all of its software that is protected by a 
license. When the computer has been started, such software can only be used in 
accordance with the applicable license and terms of use after the presence of a 
valid license key has been verified. 
 

 Notes 

• You can use the standard software without a license key to familiarize yourself 
with the user interface and functions. 

• However, a license is required and necessary for full, unrestricted use of the 
STEP 7 software in accordance with the license agreement 

• If you have not installed the license key, you will be prompted to do so at 
regular intervals. 

 

License Keys can be stored and transferred among various types of storage 
devices as follows: 

• On license key diskettes 

• On the local hard disk 

• On network hard disk 

If software products for which no license is available are installed, you can then 
determine which license key is needed and order it as required. 

For further information on obtaining and using license keys, please refer to the 
online help for the Automation License Manager. 

Types of Licenses 
The following different types of application-oriented user licenses are available for 
software products from Siemens AG. The actual behavior of the software is 
determined by which type license key is installed for it. The type of use can be 
found on the accompanying Certificate of License. 
 

License Type Description 

Single License The software can be used on any single computer desired for an unlimited 
amount of time. 

Floating License  The software can be used on a computer network ("remote use") for an 
unlimited amount of time. 

Trial License  The software can be used subject to the following restrictions: 
• A period of validity of up to a maximum of 14 days, 
• A total number of operating days after the day of first use, 
• A use for tests and validation (exemption from liability). 

Upgrade License Certain requirements in the existing system may apply with regard to software 
upgrades: 
• An upgrade license may be used to convert an "old version X" of the 

software to a newer version X+. 
• An upgrade may be necessary due to an increase in the volume of data 

being handled in the given system. 
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1.5.3.2 Installing the Automation License Manager 

The Automation License Manager is installed by means of an MSI setup process. 
The installation software for the Automation License Manager is included on the 
SIMATIC PDM product CD.  

You can install the Automation License Manager at the same time you install 
SIMATIC PDM or at a later time. 
  

 Notes 
For detailed information on how to install the Automation License Manager, please refer to 
the current "Readme.wri" file.  

The online help for the Automation License Manager contains all the information you need 
on the function and handling of License Keys.  

  

Subsequent installation of license keys 

If you start the SIMATIC PDM software and no license keys are available, a 
warning message indicating this condition will be displayed.  
  

 Notes 

• You can use SIMATIC PDM without a license key to familiarize yourself with 
the user interface and functions. 

• However, a license is required and necessary for full, unrestricted use of the 
SIMATIC PDM software in accordance with the license agreement 

• If you have not installed the license key, you will be prompted to do so at 
regular intervals. 

  

You can subsequently install license keys in the following ways: 

• Install license keys from diskettes 

• Install license keys downloaded from the Internet. In this case, the license keys 
must be ordered first. 

• Use floating license keys available in a network 

For detailed information on installing license keys, refer to the online help for the 
Automation License Manager. To access this help, press F1 or select the Help > 
Help on License Manager menu command. 
 

 Notes 

• In Windows 2000/XP, license keys authorization will only be operational if they 
are installed on a local hard disk and have write-access status. 

• Floating licenses can also be used within a network ("remote" use). 
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1.5.3.3 Guidelines for Handling License Keys 

 

!  
Caution 

Please note the information on handling license keys that is available in the online 
help on the Automation License Manager and also in the SIMATIC PDM 
Readme.wri file on the installation CD-ROM. If you do not follow these guidelines, 
the license keys may be irretrievably lost. 

  

To access online help for the Automation License Manager, press F1 for context-
sensitive help or select the Help > Help on License Manager menu command. 

This help section contains all the information you need on the function and 
handling of license keys. 
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2 Starting SIMATIC PDM 

The following illustration shows the various way in which the "SIMATIC PDM" 
application can be started. 

SIMATIC PDM

SIMATIC Manager STEP 7 HW-Konfig LifeList
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2.1 Starting SIMATIC PDM in the Process Device Network 
View 

Start SIMATIC PDM by selecting the desired object or network and opening it with 
a right mouse click with the context-sensitive command Open Object. In many 
cases you can also start PDM by double-clicking on the device icon. If you did not 
specify the device type when you inserted the object, the "SIMATIC PDM Device 
Selection" dialog box is displayed when program is started for the first time. Here 
you will find the devices and profiles that are supported by SIMATIC PDM 
depending on the network. Select a device or a device profile. SIMATIC PDM will 
start once you have made the selection. 

 

 Notes:  

• For further information on particular points pertaining to the distributed 
periphery please refer to the section on Remote I/O Systems. 

• The actual communication path is set in the configuration, not by the network 
from which the program was started. 
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2.2 Starting SIMATIC PDM in the Process Device Plant 
View 

Start SIMATIC PDM by selecting the object and opening it with a right mouse click 
with the context-sensitive command Open Object. In many cases you can also 
start PDM by double-clicking on the device icon. If the program is being started for 
the first time, the "SIMATIC PDM Device Selection" dialog box is displayed.  

This contains the devices and profiles for the MSR point which are supported by 
SIMATIC PDM. Select a device or a device profile. SIMATIC PDM will start once 
you have made the selection. 

You will find at least one type name for the head station depending on the 
manufacturer. Assign the one suggested or select a different one. SIMATIC PDM 
will start once you have made the selection. 

You can now parameterize the selected device completely off-line, i.e. create a 
parameter record in the off-line data storage. You cannot communicate with the 
device, however, as a network has not yet been assigned. 

For further information about assigning a network please refer to the section on 
SIMATIC Manager Views. 

For further information on particular points pertaining to the distributed periphery, 
please refer to the section on Remote I/O Systems. 
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2.3 Starting SIMATIC PDM in HW-Config 

Start SIMATIC PDM double-clicking on the device icon or the device input in the 
detail view. When started for the first time, the program displays the "Insert 
SIMATIC PDM object" dialog box with a preset name. Enter a device-specific 
name, e.g. the system identifier. The name is displayed afterwards on the icon in 
the plant view and in the icon in HW-Config. Once you click on OK the 
SIMATIC PDM device selection dialog box is displayed. Here you will find the 
devices and profiles that are supported by SIMATIC PDM depending on the 
selection in HW-Config. Select a device or a device profile. SIMATIC PDM will start 
once you have made the selection. 

Specify the network topology in the process device network view and insert all 
devices configured in HW-Config. When the devices are inserted the "Insert 
SIMATIC PDM Object" dialog box is opened. Click on the "Select" command button 
and select the project from the dialog box then displayed. All the devices 
configured in HW-Config are displayed and you can select the required device. 
Right-click on the selected project and select the entry Details. The right-hand 
section of the window now displays detailed information on the devices. The 
network column shows whether there is a network connection or not. This creates 
a link to the devices in the plant view. When you carry out this procedure, 
SIMATIC PDM can be started directly from HW-Config, from the plant view and 
from the network view by double-clicking the device icon. 

 

 Notes  

• For special features of the distributed periphery please refer to the section 
Remote I/O SystemsRemote_I/O_Systeme. 

• If you use HW-Config for configuration, you should not change the device 
definitions later. Although this is possible in the process device network view 
(by replacing a device) and also affects HW-Config, the device-specific icon in 
HW-Config does not change and an incorrect PROFIBUS configuration may 
result. You will have to create a new device for another variant in HW-Config if 
necessary and may have to delete the old device. 

 

 

2.4 Starting SIMATIC PDM in LifeList 

To start SIMATIC PDM, select its object, and then right-click to obtain the context 
menu. In this menu, select the command Open object. 

In the header, LifeList shows the relationship to the project and the network used 
for communication. If you open SIMATIC PDM from LifeList, the project data for the 
network are automatically applied. 
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3 Configuring Networks and Devices 

Networks and devices can be configured in the SIMATIC Manager. The following 
networks are supported: 

• PROFIBUS-DP network 

• PROFIBUS-PA network 

• HART modem 

• HART interface network 

• HART multiplexer network 

• SIPART-DR network 

• SIREC network 

• MODBUS network 

Different options with the appropriate authorizations (see Authorization 
Instructions) are necessary for the different communication modes. 

In SIMATIC PDM Integrated PROFIBUS-DP/PA networks and devices can also be 
configured using STEP 7 HW-Config.  
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The following figures show the various network topologies of a STEP 7 project. 
 

PROFIBUS-DP network: 

Engineering Station

Ethernet
SIMATIC S7 Station

PROFIBUS DP
Field Devices
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PROFIBUS-PA network: 

HART
Field

Devices

PROFIBUS
PA

DP/PA
Coupler

Engineering Station

Ethernet
SIMATIC S7 Station

HART
Field

Devices

PROFIBUS
PA

DP/PA
Coupler

DP/PA Link DP/PA Coupler

 

 

HART modem: 

HART
Field

Devices

RS 232

Engineering Station

HART Modem
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HART multiplexer network: 

PROFIBUS DP

HART
Field

Devices

ET 200 M

I/O
Module

Engineering Station

RS 485 Service Bus

SIMATIC S7 Station

HART
Field Devices

HART-/Interface
Multiplexer

HART-/Interface
Multiplexer

HART-/Interface
Multiplexer

Ethernet

ET 200 M

HART
Module

HART Field
Devices

 

 

SIPART DR/SIREC/MODBUS network: 

Engineering Station RS 232C / RS 485
SIPART DR Network

SIPART DR
Devices
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3.1 SIMATIC Manager 

The SIMATIC Manager is the graphical user interface for SIMATIC users which is 
used to manage projects. 

It is the starting user interface for configuring and programming in STEP 7. You 
can:  

• Create projects 

• Configure and parameterize hardware 

• Plan and configure hardware networks 

• Program blocks 

• Debug and commission your programs 

The access to the functionality is object-oriented, intuitive and easy to learn.  

Setting the language  

In order to change the language select the menu  Options > Settings... command. 
The dialog box then displayed the "Language" tab card. You can adapt the 
language and mnemonics to your requirements on this tab card. Select the 
language you want to work in the "Language" field. Only the installed language is 
displayed for selection in the list. 

For detailed information about working with the SIMATIC Manager please refer to 
the corresponding online help. 
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3.2 SIMATIC Manager Views 

Component view 
In addition to the familiar component view for SIMATIC S7 (where you can also 
switch to HW-Config in the integrated version), after SIMATIC PDM has been 
installed the SIMATIC Manager has two other views that can be activated under 
the View menu in the SIMATIC Manager. SIMATIC PDM can be started from all 
three views by double-clicking a device. 

Process device network view 
In the process device network view the devices are shown in groups according 
to the network topology. Devices that can be reached through several networks are 
shown several times accordingly. You can configure networks and devices in this 
view. 

Process device plant view 
The process device plant view gives an overview of all configured devices in all 
configured networks. This view is used to obtain a quick overview of the configured 
devices. New devices or networks cannot be configured in this view.  

You can specify which of the three views is to be displayed when the SIMATIC 
Manager is started by selecting Options > Settings > View > Preset Project View 
in the SIMATIC Manager.  

In the two new views you can select the view as is normal in STEP 7: 

• Large icons 

• Small icons 

• List 

• Details 

In the Details view you can select which information is to be displayed using the 
Options > Settings > Columns menu command. 

New devices that have been added in the process device network view and in HW-
Config are automatically shown in the process device plant view.  

In the plant view you can add devices which you can assign to a network at a later 
date. This is carried out in the network view after Insert New Object or in the HW 
Config after the new device has been opened for the first time by using "Select" in 
the "Insert SIMATIC PDM Object" dialog box. Click Select in the network view after 
Insert new object or in HW-Config after the new device is opened for the first time 
in the Insert SIMATIC PDM object dialog box. In the subsequent Open dialog box 
select the process device plant view and then the device. 

Once a link has been created, changes to the name of an object in a view are also 
automatically transferred to the other views. 

If you work with SIMATIC PDM Integrated, you can configure the system with 
SIMATIC station(s), network(s) and PROFIBUS-DP/PA devices in HW-Config 
(HART modems, HART interface networks, SIPART-DR networks and the 
associated devices cannot be configured in HW-Config, however). 

You can configure "smaller" projects, e.g. for end-end connections between PCs 
and devices in the workshop, in the process device network view. 
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3.3 Icons for Devices 

The following table explains the meaning of the icons for the devices configured in 
SIMATIC PDM. These icons are not completely supported by all devices. The icons 
are shown in the network view and the plant view of the SIMATIC Manager, in 
SIMATIC PDM and in LifeList. 

The icons are assigned when the devices are configured. When a connection is 
established, device-specific diagnostic information is automatically classified and 
represented by the icons. This diagnostic information is automatically stored in the 
project, even if the configuration data is not stored there. 

 

Icon Meaning 

 

  

 
No device type from the device catalog has been assigned to the device, or it is not 
activated. 

 

 

 
A device type from the device catalog could be assigned to the device, but there has not 
yet been any communication with the device. 

 

 

 
Communication could not be established, was interrupted, or no communication with the 
device was possible by using the configured address. 

 

 

 
The device contacted is not the same as the configured device, or the device configuration 
is incorrect (see Secure Communication). 

 

 

 
A fault occurred in the device (e.g. HW temperature too high). 

 

 

 
Immediate maintenance required to prevent a possible device fault from occurring. 

 

 

 
Maintenance initial warning: maintenance should be scheduled. 

 

 

 
Maintenance initial warning: maintenance required to prevent a possible device fault from 
occurring. 

 

 

 
The communication was good. The device is in manual operation. 

 

 

 
The communication was good. The device is in simulated operation or is working with 
substitute values. 

 

 

 
The communication was good. The device is not in operation. 

 

 

 
The device is not functioning due to a configuration error in parameters or hardware 
components. 
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Icon Meaning 

 

 

 
The device is functioning, but one or more parameters are invalid. Instead of the invalid 
parameters substitute values are being used.  

 

 

 
The parameters set for the device do not match the parameters in the project. Please read 
and heed the message texts.. 

 

 

 
At least one process value has overshot or undershot a process interrupt limit. 

 

 

 
At least one process value has overshot or undershot a process warning limit. 

 

 

 
At least one process value has overshot or undershot a process tolerance limit. 

 

 

 
The communication and the device status were good. There are no messages. 

 

 

 
The communication was good. The device does not support a diagnostic check. 

 

 Note 

Whenever you are working in test mode, some of the icons listed above will have a 
blue background. 

 

3.4 SIMATIC PDM (not integrated in STEP 7/PCS 7) 

SIMATIC PDM can also be executed without STEP 7/PCS  7. In this case install 
the SIMATIC Manager which you can select in the SIMATIC PDM Setup. 

Networks and devices are configured in the process-device network view in the 
SIMATIC Manager. 
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3.5 Creating a Project in the Process Device Network View 

Proceed as follows: 

1. Start the SIMATIC Manager. 

2. Select the File > New menu command and then specify the project type and 
enter a name for the project in the "New" dialog box which is displayed. 

3. Select the View > Process Device Network View menu command. A 
Networks object is automatically created in the window in which all networks 
are configured. 

4. Add a PC object by clicking on the Networks object with the right-hand mouse 
button. Select Insert New Object > PC in the pop-up menu which is displayed. 

5. Add an interface to the PC by clicking on the PC object with the right-hand 
mouse button. Select Insert New Object in the pop-up menu that is then 
displayed. Select the corresponding interface type. SIMATIC PDM offers the 
following interface types:  

- DP interface (PROFIBUS DP interface via a CP module)  

- COM interface (serial interface via COM1, COM2). 

6. You can set the Object features by clicking the interface you have inserted 
with the right mouse button. You do not have to do anything for the DP 
interface yet. For the COM interface specify the COM port first in the 
"Connecting Data" tab in the "COM Interface Properties" dialog box. 

7. In order to insert the actual network click on the Networks object with the right 
mouse button and select the appropriate network type in the pop-up menu that 
is displayed. SIMATIC PDM offers the following networks:  

- PROFIBUS-DP network (for DP interface),  

- SIPART-DR network,  

- HART interface network  

- HART modem (for COM interface). 

- HART multiplexer network 

- SIREC network 

8. Couple the previously configured interface with the newly created network by 
clicking it with the right mouse button. For the DP interface specify the 
PROFIBUS-DP network in the "Network" tab of the "DP Interface Properties" 
dialog box. For the COM interface specify the HART interface network, the 
HART modem or the SIPART-DR network in the "Network" tab of the "COM 
Interface Properties" dialog box. 

 

If you want to use the project on different PCs with different hardware 
configurations without having to adapt the existing PC object every time, you can 
insert several PC objects. The PC object marked with a red icon indicates the 
"current" PC that is used for communication. In order to switch over to another PC 
configuration, right-click on the appropriate PC object and select the Options > 
Define Current PC" menu command in the SIMATIC Manager. 
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3.6 Coupling a Device in the Process Device Network View 

You can now insert devices in the network by clicking on the previously configured 
network with the right-hand mouse button. 

PROFIBUS DP network: 

• Inserting a DP device 
PROFIBUS-DP devices can be inserted directly for the PROFIBUS-DP 
network. When you insert the devices, the "Insert SIMATIC PDM Object" dialog 
box is displayed. Enter the desired data there. 

• Inserting a DP remote I/O system (distributed periphery) 
Insert a head station first when inserting a DP remote I/O system (distributed 
periphery). When inserting, enter the desired data in the "Insert SIMATIC PDM 
Object" dialog box.  
Note: For further information on particular points pertaining to the distributed 
periphery please refer to the section on Remote I/O Systems. 

• Inserting a PA device via DP/PA coupler 
PROFIBUS-PA devices can be inserted via a DP/PA coupler for the 
PROFIBUS-DP network. The insert procedure is the same as with DP devices. 
The DP/PA coupler need not be configured, an appropriate bus transmission 
rate (for example, 45.45 kbits/s for the Siemens coupler) merely needs to be 
set for the PROFIBUS-DP network. 

• Inserting a PA device via DP/PA link 
Insert a DP/PA link and then the PROFIBUS-PA device when inserting 
PROFIBUS-PA devices via a DP/PA link. Once you have inserted the DP/PA 
link specify the PROFIBUS address for the DP/PA link in the "Properties … – 
Connecting Data" dialog box. When you insert the devices, the "Insert 
SIMATIC PDM Object" dialog box is displayed. Enter the desired data there. 

• Inserting a PA remote I/O system (distributed periphery) 
Insert a head station in a PROFIBUS-DP network (via DP/PA coupler, see 
above) or to a DP/PA link first when inserting a PA remote I/O system 
(distributed periphery). When inserting, specify a name and the address in the 
"Insert SIMATIC PDM Object" dialog box.  
Note: For further information on particular points pertaining to the distributed 
periphery please refer to the section on Remote I/O Systems. 

• Inserting a HART device via HART module 
When inserting HART devices, first insert a remote I/O, assign a HART module 
to it and then assign the HART device to the module. After inserting specify the 
PROFIBUS address for the remote I/O and the slot for the HART module in the 
respective "Properties … – Connecting Data" dialog boxes. When you insert 
the devices, the "Insert SIMATIC PDM Object" dialog box is displayed. Enter a 
name and the channel for the HART module there. 
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• Inserting redundant devices 
You can create redundant configurations of PROFIBUS devices and 
PROFIBUS remote I/Os. To do this, insert a single device (see above) and 
then select one of the following options:  

- Line redundancy: Insert the previously inserted device again in the same 
PROFIBUS network. To do this, proceed as follows: In the "Insert 
SIMATIC PDM Object" dialog box that is displayed, click the button "Select 
object …" to select the same device. 

- Application redundancy: Insert the previously inserted device again in a 
different PROFIBUS network. To do this, proceed as follows: In the "Insert 
SIMATIC PDM Object" dialog box that is displayed, click the button "Select 
object" … to select the same device. 

HART interface network: 

• Inserting a HART device 
HART devices can be inserted directly for the HART interface network. When 
the first HART device is inserted, a HART modem object will be automatically 
created and all devices configured in the HART interface network will be 
referred to in the HART modem object. Set the Master type 
(primary/secondary, as a rule secondary) in the "Properties … – Connecting 
Data" dialog box for the HART interface network and the HART modem. 
Ensure you specify the Manufacturer, Device type and Device name in the 
"Properties … – Connecting Data" dialog box for the HART device in the HART 
interface network because this is used to form the address information. Ensure 
you specify the Short address in the "Properties … – Connecting Data" dialog 
box for the HART device in the HART modem. 

HART modem: 

• Inserting a HART device 
You can access devices in the HART modem via the HART modem without 
additional configuration (in the HART interface network), for example, for 
commissioning.  
You can insert HART devices directly for the HART modem. Set the Master 
type (primary/secondary, as a rule secondary) in the "Properties … – 
Connecting Data" dialog box for the HART modem. Ensure you specify the 
Short address in the "Properties … – Connecting Data" dialog box for the 
HART device in the HART modem. 

HART Multiplexer Network 

You can insert multiplexer networks in process device network view in the 
SIMATIC Manager. To do so you have to select a multiplexer network included in 
the HART server in the "Insert" dialog box. Then the hierarchy of the selected 
multiplexer is included in the SIMATIC Manager. The structure of the hierarchy 
differs depending on the respective multiplexer. There are one-stage multiplexers 
(for example, multiplexers of Measurement Technology Ltd.) and two-stage 
multiplexers (for example, Pepperl+Fuchs multiplexers). 
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SIPART-DR network: 

• Inserting a SIPART DR compact controller 
You can only insert SIPART DR compact controllers with a serial interface 
(RS 232C/RS 485) in the SIPART-DR network (see the detailed description 
Coupling a SIPART DR Controller). 

Once the (terminal) devices have been inserted in the process device network 
view, they will also be displayed in the process device plant view. 

SIREC network: 

• Inserting a SIREC process recorder 
You can only insert SIREC process recorders in the SIREC network (see the 
detailed description Coupling a SIREC Process Recorder). 
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3.7 Creating a Project in the Process Device Plant View 

Proceed as follows: 

1. Start the SIMATIC Manager. 

2. Select the File > New menu command. In the subsequent "New" dialog box 
specify the "Project" type and enter a name for the project. 

3. Select the View > Process Device Plant View menu command. A "Devices" 
object is automatically created in the window in which all devices are inserted. 

3.8 Coupling a Device in the Process Device Plant View 

You can now insert devices without assignment to a network by clicking on 
Devices with the right mouse button. You can insert: 

• TAG  (a TAG is a "synonym" for a device that you can insert). 

• Remote I/O (distributed periphery). The head station of a remote I/O system is 
the module that will be connected to a network later on and can be connected 
in various modules. These modules cannot be inserted in the plant view (see 
chapter Remote I/O Systems).  

• Remote I/O submodule (distributed periphery).These submodules are 
modules which can be later inserted subordinate to the head station of a 
remote I/O. 

The selected object is inserted directly and only once in the plant view. The "Insert 
SIMATIC PDM Object" dialog box is not displayed. 

3.9 Inserting Several Devices at the Same Time 

In the process device network view you can use the "Insert New Object" menu 
command to insert several devices or modules into a configured network at the 
same time. In the "Insert SIMATIC PDM Object" dialog box you can enter the 
desired number under Number of "Name" Objects (this value  depends on the 
network being used and other factors). These objects are inserted with the 
designations Name 1, Name 2, ...  Name n. Assign each device as required if you 
want to create several devices of the same type. The addresses of the objects are 
incremented starting with the lower value up to the highest permitted address. This 
address assignment may sometimes need to be corrected by the user. 
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3.10 Exchanging Devices 

Devices can be exchanged in the process device network view and process device 
plant view. 

When a device is exchanged in a system, there are two ways of updating the 
project in SIMATIC PDM: 

• Delete the object of the old device and insert an object for the new device. This 
procedure is recommended if the devices are totally different. All settings will 
be lost when the object of the old device is deleted. 

• Try to exchange identical devices whenever possible (e.g. same manufacturer, 
same type but new model) in this way you can assign the new device to the 
object in the "Device" tab card of the "Object Properties" dialog box, using the 
New Assignment function from the subsequent SIMATIC PDM Device 
Selection dialog box. In this case all the read-only variable settings that are in 
both devices will be kept. A device exchange carried out in the process device 
network view will be transferred to the process device plant view and vice 
versa. 

3.11 Deleting Devices 

If you delete device in SIMATIC PDM, in the process device network view or in 
STEP 7/PCS 7 HW-Config, only the use of this device is removed from this specific 
location. However, the device remains available in the process device plant view of 
the SIMATIC Manager. Thus, the device can still be reused. Devices have a history 
that is lost if they are permanently deleted. For example, devices have to be 
prepared in the workshop, installed in the plant and then, at times, removed to be 
serviced in the workshop or installed at another location. To permanently delete a 
device, delete it in the process device plant view of the SIMATIC Manager. 
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3.12 Information on Configuring and Parameterization 

This section contains notes which will provide additional information in particular 
cases. Please See also the information in the README file. This file is installed by 
default under Siemens\PDM\Sim_PDM\README.wri. 

1. For information on specific settings of the bus parameters by means of the 
Set Programming Device/PC Interfaces program, be sure to read the 
README file. 

2. PROFIBUS PA profile devices 
The parameterization and the master configuration have to be carried out 
separately for the cycle in the case of profile devices which can be configured 
in accordance with a profile, but which require an own device-specific GSD file 
(devices master file). For the master configuration import the device-specific 
GSD files in HW-Config and place these devices at the DP/PA master system 
from the HW-Config catalog under the directory "PROFIBUS DP\further field 
devices". For the parameterization insert a further SIMATIC S7 station with a 
DP master system. Place the devices which you want to parameterize with 
SIMATIC PDM at this system. 

3. Error handling of PROFIBUS PA profiles 
For some devices, you can call up the Error Handling dialog box in the 
Options menu. In this you can specify that certain errors which occur during 
downloading to the programming device/PC or to the device be ignored, so that 
downloading is not aborted. Any errors occurring are displayed in an error 
dialog box. 

4. Block configuration of HART devices 
HART devices are configured via general parameters and via parameters 
which are assigned to blocks. For example, some pressure transducers can 
measure the temperature as well. For such a device the number of blocks and 
the number of inputs/outputs are set to two each. SIMATIC PDM supports 
devices having up to 6 blocks. The number of inputs/outputs is limited to up to 
four by the HART definition. Inputs and outputs can be assigned to the blocks 
by means of the Block assignment on-line Dialog Box. This on-line dialog box 
is only supported by devices which allow an assignment of inputs/outputs to 
blocks.  

5. The basic configuration of HART devices (in the "SIMATIC PDM device 
selection" dialog box reached through the menu command HART > Universal > 
Standard) encompasses the functional scope which is defined in the Universal 
Commands and the Common Practice Commands by the HCF. 
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3.13 PROFIBUS 

3.13.1 Coupling a PROFIBUS Device in SIMATIC PDM 

Proceed as follows in order to couple a PROFIBUS device (PROFIBUS-DP device, 
PROFIBUS-PA device or PROFIBUS remote I/O): 

1. Start the SIMATIC Manager by double-clicking on the icon on the desktop or 
by using the Windows Start menu. 

2. Select the menu command View > Process Device Network View to specify 
the process device network view. 

 

 Note 

If you usually intend to work in the process device network view, select the menu 
command Options > Customize, go to the "View" tab, and select "Default project 
view" in the drop-down list box. 

 

3. In order to set the programming device/PC click on the Windows command 
button Start > Settings > Control Panel > Set Programming Device/PC. If 
you have installed a PCMCIA card, click on the desired CP (for example, 
CP5511). Click on "Properties" and carry out the following settings in the 
displayed dialog box: 

- Enter "DP" in the "Profile" field. 

- Select the transfer rate "45.5 kbits/sec" in the "Transfer speed" field. 

- De-activate the "Does not become active as the only master" radio button. 

Note: When installing the PCMCIA card ensure that you always insert the card 
together with the connected cable. 

4. Create a new project by using the File > New menu command. Enter the 
desired project name in the displayed "New" dialog box and confirm your 
entries with "OK". 
 
In order to insert the PROFIBUS device, select the "PROFIBUS DP Network" 
object in the right-hand window and press the right-hand mouse button. In the 
displayed pop-up menu select the entry Insert New Object > PROFIBUS-DP 
device, PROFIBUS-PA device or Remote I/O. Enter the name of the 
measuring point in the displayed dialog box. 
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5. If you are using a PROFIBUS-DP/PA coupler, configure the PROFIBUS-PA 
device directly at the PROFIBUS network or behind the PROFIBUS link. The 
coupler itself is not configured. 
 
As an alternative, you can insert a PROFIBUS link (Y-link or DP/PA-link) into a 
PROFIBUS-DP network. You can then insert PROFIBUS devices behind the 
network, but you cannot insert another PROFIBUS link. 

 

 Note 

The address of the PROFIBUS device that you set in the "Insert SIMATIC PDM 
objects(s)" dialog box can also be entered afterward in the "Object properties" 
dialog box ("Connection properties" tab). 

 

6. Start SIMATIC PDM by double-clicking on the newly inserted PROFIBUS 
device in the right-hand window. Select the corresponding device in the menu 
tree (only required for the first call) and configure the device. 

3.13.2 Block Structure of the PROFIBUS Profile Devices 

PROFIBUS profile devices consist of three different blocks. The following diagram 
shows the connection between them. 

  

 

Physical block: Contains data describing the profile device and the device status (e.g. 
manufacturer, device order number etc.). 

Transducer block: Contains the actual transducer functions. It supplies the measured, 
corrected and adjusted measured value at the output. This block also 
provides additional information, e.g. the sensor temperature, for some 
profile devices. 

Function block: Used to represent the measured value on the actual measured variable, 
e.g. the filling level. Set characteristic curves and attenuation are, for 
example, taken into consideration. The measured value is also returned 
as a percentage value. 
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3.13.3 Distributed Periphery — Remote I/O Systems 

HW-Config  

If you have configured remote I/O systems in HW-Config, you can open (start) 
SIMATIC PDM for the head station and the submodules in the detail view. 

Process device plant view  

The head station of the remote I/O systems and the submodules of the head 
station are shown in the plant view and can be opened. 

Process device network view  

• Create an object for the head station in the network view (if you have carried 
out configuration in HW-Config beforehand, create a link to the corresponding 
object in the plant view by clicking on the "Select" command button in the 
"Insert SIMATIC PDM Object" dialog box).  

• Then add a module object for the head station in the network view for each 
module fitted in the head station (see also Inserting Several Devices at the 
Same Time).  

• Afterwards you can open the remote I/O system in the SIMATIC PDM network 
view. Double-click of the remote I/O or on one of the subordinate objects. 

• If you are working off-line, you will now have to assign a function (according to 
the actual setup or configuration in HW-Config) these "empty" objects 
individually and manually. Open the object by selecting its symbol in the 
parameter group view. Then select the desired setting (*) in the parameter 
table for the parameter defining the function and save the object. 

• If you can work online, select the head station object and select the "Device > 
Complete Upload to the Programming Device/PC" function from the menu 
bar. The parameters for the slot (*) function settings are updated and at the 
same time the functions are assigned to the modules in accordance with the 
slot assignments.  
(*) The names of these parameters and their possible settings are different 
according to the remote I/O system. 

 

 Note:  

In the process device network view and in the process device plant view you can 
open SIMATIC PDM for the head station and the modules by using the Open pop-
up menu command. 
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3.14 HART 

3.14.1 Coupling a HART Device to a HART Modem in SIMATIC PDM 

Proceed as follows in order to couple a HART device to a HART modem: 

1. Start the SIMATIC Manager by double-clicking on the icon on the desktop or 
by using the Windows Start menu. 

2. Select the menu command View > Process Device Network View to specify 
the process device network view. 

 

 Note 

If you usually intend to work in the process device network view, select the menu 
command Options > Customize, go to the "View" tab, and select "Default project 
view" in the drop-down list box. 

 

3. Create a new project by using the File > New menu command. Enter the 
desired project name in the displayed "New" dialog box and confirm your 
entries with "OK". 

4. In order to insert a HART network double-click on the "Networks" object in the 
right-hand window. Select "Networks" in the left-hand window and press the 
right-hand mouse button. In the displayed pop-up menu select the entry Insert 
New Object > HART Modem Network. 

5. In order to check whether the correct network and the correct port are assigned 
to the COM interface, double-click on the "PC" object in the right-hand window. 
Select the "COM interface" object and press the right-hand mouse button. 
Select the Object Properties… entry in the displayed pop-up menu. In the 
displayed "Properties" dialog box set the HART modem network in the 
"Network" tab card. If necessary, enter the desired COM port in the 
"Connection Data" tab card. 
Note: The COM port is almost always "1" for notebooks. Since most PCs have 
two COM interfaces, you always have to specify which interface the HART 
modem is connected to in this tab card. 

6. In order to insert the HART device select the "HART modem network " object in 
the right-hand window and press the right-hand mouse button. In the displayed 
pop-up menu select the entry Insert New Object > HART Device. Enter the 
name of the HART device in the displayed dialog box. 
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7. In order to set the device address select the inserted HART device in the right-
hand window and press the right-hand mouse button. Select the Object 
Properties entry in the displayed pop-up menu. In the displayed dialog box 
select the "Connection Data" tab card and enter the short address. 
Note: The address has to correspond to the connected device. The short 
address at HART devices is always "0" unless the device is in the multi-drop 
function. 

8. Start SIMATIC PDM by double-clicking on the newly inserted HART device in 
the right-hand window. Select the corresponding device in the menu tree (only 
required for the first call) and configure the device. 

 

 Note 
If there are several PCs in your project, you have to define one of them as the "current" one. 
To do this, select the desired "PC" object in the left window, and then select the menu 
command Options > Define Current PC.  

 

3.14.2 Coupling a HART Multiplexer Network 

You can insert multiplexer networks in process device network view in the 
SIMATIC Manager. Prerequisite is that a HART server has been installed on the 
computer. To do so you have to select a multiplexer network included beforehand 
in the HART server in the "Insert" dialog box. Then the hierarchy of the selected 
multiplexer is included in the SIMATIC Manager. The structure of the hierarchy 
differs depending on the respective multiplexer. There are one-stage multiplexers 
(for example, P+F multiplexers) and two-stage multiplexers (for example, MTL 
multiplexers).  

When a device is opened the identification can be read from the device and the 
correct Device Description can be assigned.  

The HART server does not support multimaster operation. Jobs have to be 
coordinated in order to avoid conflicts. The coordination has to be carried out on 
the multiplexer network level.  

Multiplexers from a vast range of companies can be addressed through this HART 
server. Further information is available from the specific manufacturers or the 
HART Communication Foundation. 

You have to use the HART server application in order to build up and manage the 
project. Detailed information on the HART server can be found in the description or 
the online help of this product. 
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One-stage multiplexer (example: Pepperl+Fuchs) 

Proceed as follows in order to couple a Pepperl+Fuchs multiplexer: 

1. Select the File > New menu command in the SIMATIC Manager and enter a 
name for your project in the displayed dialog box. 

2. Change to the process device network view (View > Process Device Network 
View menu command). If you already want to insert a multiplexer network at 
this point via the Insert New Object > HART Multiplexer Network pop-up 
menu command, the HART Server is started automatically, but the data for 
configuring the network are not available yet. 

3. Start the HART server by double-clicking on the icon on the desktop or by 
using the Start >... command button in Windows.  

4. Enter a name for the HART server project in the displayed dialog box.  

5. Select the project, press the right-hand mouse button and select the entry Add 
Network. Select the suitable network type (as a rule RS 485) in the displayed 
dialog box. Enter a name in the "Network Properties" field (this is very 
important since the SIMATIC Manager later uses this name to identify the 
network). Set the properties of the interface under "Properties" and confirm 
your entries with "OK". The network has now been inserted into your project. 

6. You can either read in the data automatically or also set them manually. 

- Automatic reading in: Read in all the data (multiplexer and devices) via 
the File > Learn menu command. The configuration can only be read in 
online. The learning process of the data is displayed in a dialog box. While 
checking the addresses (multiplexer, etc.) the status of all the occupied 
addresses changes from "not responding" to "responding". If this is not the 
case, there is a connection error, for example incorrect polarity. 

- Manual setting: If you want to create the configuration manually, select 
the project, press the right-hand mouse button, select the Add Multiplexer 
entry and enter the required information in the dialog box. Then select the 
multiplexer, press the right-hand mouse button, select the Add Instrument 
entry and enter the required information in the dialog box. Continue by this 
method until all the required devices have been configured. 

The following figure shows a HART Server project after the learning process for a 
Pepperl+Fuchs-multiplexer: 

 

7. Now select the Insert New Object > HART Multiplexer Network pop-up 
menu command in the SIMATIC Manager.  
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8. In the displayed dialog box select the network name assigned by you (refer to 
Point 4). If you activate the option "Automatic Configuration of the Subnets", all 
the devices recognized in the HART Server as well as a HART modem are 
included automatically in the project. If you do not activate "Automatic Device 
Recognition during Reading In", you now have to select the individual devices 
from the device catalog. If the device recognition is activated, an automatic 
assignment is carried out in accordance with the following rules: 

- Highest priority for fully integrated devices 

- HCF devices 

- If no corresponding device is found, a universal DDL is assigned 

9. Edit the individual devices in the SIMATIC Manager. 

Two-stage multiplexer (example: MTL) 

Proceed as follows in order to couple an MTL multiplexer: 

1. Select the File > New menu command in the SIMATIC Manager and enter a 
name for your project in the displayed dialog box. 

2. Change to the process device network view (View > Process Device Network 
View menu command). If you already want to insert a multiplexer network at 
this point via the Insert New Object > HART Multiplexer Network pop-up 
menu command, the HART Server is started automatically, but the data for 
configuring the network are not available yet. 

3. Start the HART server by double-clicking on the icon on the desktop or by 
using the Start >... command button in Windows.  

4. Enter a name for the HART Server project in the displayed dialog box.  

5. Select the project, press the right-hand mouse button and select the entry Add 
Network. Select the suitable network type (as a rule RS 485) in the displayed 
dialog box. Enter a name in the "Network Properties" field (this is very 
important since the SIMATIC Manager later uses this name to identify the 
network). Set the properties of the interface under "Properties" and confirm 
your entries with "OK". The network has now been inserted into your project. 

6. You can either read in the data automatically or also set them manually. 

- Automatic reading in: Read in all the data (multiplexer and devices) via 
the File > Learn menu command. The configuration can only be read in 
online. The learning process of the data is displayed in a dialog box. While 
checking the addresses (multiplexer, etc.) the status of all the occupied 
addresses changes from "not responding" to "responding". If this is not the 
case, there is a connection error, for example incorrect polarity. 

- Manual setting: If you want to create the configuration manually, select 
the project, press the right-hand mouse button, select the Add Multiplexer 
entry and enter the required information in the dialog box. Then select the 
multiplexer, press the right-hand mouse button, select the Add Panel entry 
and enter the required information in the dialog box. Now select a panel, 
press the right-hand mouse button, select the Add Instrument entry and 
enter the required information in the dialog box. Continue by this method 
until all the required devices have been configured. 
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The following figure shows a HART Server project after the learning process for a 
MTL multiplexer: 

 

7. Now select the Insert New Object > HART Multiplexer Network pop-up 
menu command in the SIMATIC Manager.  

8. In the displayed dialog box select the network name assigned by you (refer to 
Point 4). If you activate the option "Automatic Configuration of the Subnets", all 
the devices recognized in the HART Server as well as a HART modem are 
included automatically in the project. If you do not activate "Automatic Device 
Recognition during Reading In", you now have to select the individual devices 
from the device catalog. If the device recognition is activated, an automatic 
assignment is carried out in accordance with the following rules: 

- Highest priority for fully integrated devices 

- HCF devices 

- If no corresponding device is found, a universal DDL is assigned 

9. The hierarchy of the multiplexer network is now displayed in the process 
device network view of the SIMATIC Manager. 
Note: Only those panels are displayed to which devices are connected! 

Learning process 

You can carry out the learning process in a HART Server project on every level. If, 
for example, you select the project, you start the learning process for the complete 
configuration tree. If you select a panel, you start the process for the selected 
partial configuration, meaning for the instruments below the panel level. 

Changing the configuration 

If you change an existing multiplexer network, for example insert new devices or 
exchange devices (do not forget to reconfigure in the HART Server), you can use 
the Edit > Compare menu command in the SIMATIC Manager to carry out a 
comparison in the HART server. The comparison function takes the following into 
consideration: 

• New hierarchy and devices are inserted. 

• Hierarchies and devices that no longer exist are de-activated (grayed-out 
display in the SIMATIC Manager and the "Object activated" option in the 
"Properties" dialog box is not selected).  
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3.15 Coupling HART Devices via HCF-DDs 

Insert a HART device in the process device network view or in HW-Config. If the 
program is being opened for the first time, the "SIMATIC PDM Device Selection" 
dialog box is displayed. In this dialog box click on the "Device Catalog" command 
button once, and in the dialog box that is then displayed select the 
"HCF_DD_Library" directory on the device CD. The current HCF-DD library is 
contained on this CD. Importing this library will add the HART devices that are also 
supported by the handheld communicator to the device catalog. No guarantee 
claims or liability for damages resulting from use will be accepted for these 
devices. If you want to use such a device, please consult the device manufacturer. 
The manufacturer should check whether the device works with SIMATIC PDM and 
then contact us. 

The HCF catalog is sorted according to manufacturer, device type and device 
revision with assigned DD revision. If you are not familiar with these data, in 
particular the device revision, first select Standard HART device (universal 
standard) in the SIMATIC PDM device selection – HART device catalog dialog 
box. This standard can be used to read basic information from the device including 
the manufacturer, device type and device revision. You can then assign the correct 
device from the HCF catalog to the HART device object (see Exchanging Devices). 
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3.16 SIPART 

3.16.1 Coupling a SIPART DR Device to an RS 232C/RS 485 in 
SIMATIC PDM 

Proceed as follows in order to couple a SIPART DR device to an RS 232/RS 485: 

1. Start the SIMATIC Manager by double-clicking on the icon on the desktop or 
by using the Windows Start menu. 

2. Select the menu command View > Process Device Network View to specify 
the process device network view. 

 

 Note 

If you usually intend to work in the process device network view, select the menu 
command Options > Customize, go to the "View" tab, and select "Default project 
view" in the drop-down list box. 

 

3. Create a new project by using the File > New menu command. Enter the 
desired project name in the displayed "New" dialog box and confirm your 
entries with "OK". 

4. In order to insert a SIPART-DR network double-click on the "Networks" object 
in the right-hand window. Select "Networks" in the left-hand window and press 
the right-hand mouse button. In the displayed pop-up menu select the entry 
Insert New Object > SIPART DR-Network. Select "SIPART DR Network", 
press the right-hand mouse button and select the Object Properties... entry in 
the displayed pop-up menu. The settings in the "Connection data" tab card 
must agree with the settings of the device. 

5. In order to check whether the correct network and the correct port are assigned 
to the COM interface, double-click on the "PC" object in the right-hand window. 
Select the "COM interface" object and press the right-hand mouse button. 
Select the Object Properties... entry in the displayed pop-up menu. In the 
displayed "Properties" dialog box set the SIPART DP network in the "Network" 
tab card. If necessary, enter the desired COM port in the "Connection Data" tab 
card. 
Note: The COM port is almost always "1" for notebooks. Since most PCs have 
two COM interfaces, you always have to specify which interface the device is 
connected to in this tab card. 

6. In order to insert the SIPART DR device select the "SIPART DR Network" 
object in the right-hand window and press the right-hand mouse button. In the 
displayed pop-up menu select the entry Insert New Object > SIPART DR 
Device. Enter the name of the measuring point in the displayed dialog box. 

7. In order to set the device address select the inserted SIPART DR device in the 
right-hand window and press the right-hand mouse button. Select the Object 
Properties entry in the displayed pop-up menu. In the displayed dialog box 
select the "Connection Data" tab card and enter the station number. 
Note: The station number has to correspond to the connected device (0 - 31). 
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8. Start SIMATIC PDM by double-clicking on the newly inserted SIPART DR 
device in the right-hand window. Select the corresponding device in the menu 
tree (only required for the first call) and configure the device. 

 

 Note 
If there are several PCs in your project, you have to define one of them as the "current" one. 
To do this, select the desired "PC" object in the left window, and then select the menu 
command Options > Define Current PC.  

 
 

3.16.2 Coupling a SIPART DR Controller 

The compact controllers SIPART DR19, DR19P, DR20, DR21, DR22 and DR2210 
can be optionally equipped with a communication module for PROFIBUS DP 
communication or for serial communication using RS 232C/RS 485. In both cases 
defined settings must be made on the controller. These settings must correspond 
with the settings in SIMATIC PDM! Consult the corresponding device manual about 
use of the controller. 

 

 

 

Function 

Required settings Number of the structure switch S.. with 
SIPART DR.. controller 

 PROFI-    
BUS DP 

RS 232C / 
RS 485 

DR19   
DR19P 

DR20 DR21 DR22 
DR2210 

   

Serial interface 1 1 S92 --- S84 --- 

Data transmission >0 >0 S93 S42 S85 S101 

Transmission rates 0 Any S94 S43 S86 S102 

Vertical parity 0 Any S95 S44 S87 S103 

Longitudinal parity 
position 

0 Any S96 S45 S88 S104 

Longitudinal parity 0 Any S97 S46 S89 S105 

Station number 0 to 125 *, 

**) 
0 to 31 S98 S47   1) S90 S106 

Time monitoring CB OFF, 
≤ 10 s 

OFF S99 S48 S91 S107 

 
*) Station number with DR20 and PROFIBUS DP only 0 to 31 
**) See note for PROFIBUS DP communication 
 

The SIPART DR controllers are configured in the same way as described for other 
devices in the topics SIMATIC PDM Integrated or SIMATIC PDM (without 
HW-Config) with the following additional conditions: 



 Configuring Networks and Devices 

The Process Device Manager 
A5E00325944-01 3-27 

PROFIBUS DP Communication 

The SIPART DR controllers with a PROFIBUS DP module can be inserted as DP 
devices in HW-Config or directly for a PROFIBUS-DP network in the Process 
device network view. The "Select the Nominal Configuration" dialog box which is 
displayed during configuration in HW-Config has no significance for SIMATIC PDM, 
but is important for the cyclic communication (master classes). Confirm this dialog 
box with "OK". 

Ensure you enter the address which must correspond with the station number (see 
table) set on the SIPART DR controller in the corresponding "Properties …" dialog 
box. 

 

 Notes:  

• Please note that the PROFIBUS-DP master also has an address  
(standard 0 … 3). Therefore assign addresses which will not cause a conflict 
with the master address to the controller. 

• Do not select SIPART DRxx in the HW-Config hardware catalog. This is an 
object that cannot be used by SIMATIC PDM. 

 

Serial Communication (RS 232C/RS 485) 

The SIPART DR controllers with an RS 232 C/RS 485 module can be inserted as 
devices directly for a SIPART-DR network in the Process device network view.  

Enter the data corresponding with the settings on the controller for the SIPART-DR 
network in the "Properties … > Connecting data" dialog box (see table).  

Ensure you enter the address/station number for the SIPART DR device which 
must correspond with the station number (see table) set on the SIPART DR 
controller in the "Insert SIMATIC PDM Object" dialog box. 

Please refer to the SIPART DR controller device manuals for special hardware 
conditions (connector pin assignment, operation with bus driver etc.). 
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3.17 SIREC 

3.17.1 Coupling a SIREC Network 

Proceed as follows in order to couple a SIREC network: 

1. Start the SIMATIC Manager by double-clicking on the icon on the desktop or 
by using the Windows Start menu. 

2. Select the menu command View > Process Device Network View to specify 
the process device network view. 

 

 Note 

If you usually intend to work in the process device network view, select the menu 
command Options > Customize, go to the "View" tab, and select "Default project 
view" in the drop-down list box. 

 

3. Create a new project by using the File > New menu command. Enter the 
desired project name in the displayed "New" dialog box and confirm your 
entries with "OK". 

4. In order to insert a SIREC network, double-click on the "Networks" object in the 
right-hand window. Select the "Networks" object in the left-hand window and 
press the right-hand mouse button. In the displayed pop-up menu, select the 
entry Insert New Object > SIREC Network.  

5. In order to insert the SIREC device, select the "SIREC Network" object in the 
right-hand window and press the right-hand mouse button. In the displayed 
pop-up menu, select the entry Insert New Object > SIREC Device. In the 
menu tree, select the appropriate device (only required for the first call). In the 
dialog box displayed, enter the name of the device and confirm your entries 
with "OK". 

6. In order to check whether the correct network and the correct port are assigned 
to the COM interface, double-click on the "PC" object in the right-hand window. 
Select the "COM interface" object and press the right-hand mouse button. In 
the displayed pop-up menu, select the Object Properties entry. In the 
displayed "Properties" dialog box, set the SIREC network in the "Network" tab 
card. If necessary, enter the desired COM port in the "Connection Data" tab 
card. 
Note: The COM port is almost always "1" for notebooks. Since most PCs have 
two COM interfaces, you always have to specify which interface the device is 
connected to in this tab card. 
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7. In order to set the device address, select the inserted SIREC device in the 
right-hand window and press the right-hand mouse button. In the displayed 
pop-up menu, select the Object Properties entry. In the displayed dialog box, 
select the "Connection Data" tab card and enter the settings required for 
communication. 
Note: The station number has to correspond to the connected device. 

8. Start SIMATIC PDM by double-clicking on the newly inserted SIREC device in 
the right-hand window and configure the device. 

 

 Note 
If there are several PCs in your project, you have to define one of them as the "current" one. 
To do this, select the desired "PC" object in the left window, and then select the menu 
command Options > Define Current PC.  
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3.17.2 Coupling a SIREC Process Recorder 

To be able to communicate with you device, you have to configure the interface to 
your process recorder as specified below: 

SIREC L/LA, SIREC P/PA 

No setting at the device are required. 

SIREC PU 

 

Delay time 0.50s  

Response time 0.15s 

SIREC VARIOGRAPH 

 

Address (according to Station number) 

Serial standard RS485  

20mA  (for RS232 communication) 

Procedure ETX-ACK/NAK  

Baud rate (according to SIREC NET) 

Frame 8D-1S, even 

Block length 250  

Delay time 0.00s  

Response time 0.15s  

Format (not relevant)  

Talk Only (not relevant)  

Listen Only (not relevant)  

Mode Manual/remote control 
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3.18 MODBUS 

3.18.1 Coupling a MODBUS Network 

Proceed as follows in order to couple a MODBUS network: 

1. Start the SIMATIC Manager by double-clicking on the icon on the desktop or 
by using the Windows Start menu. 

2. Select the View > Process Device Network View menu command to specify 
the process device network view. 

 

 Note 

If you usually intend to work in the process device network view, select the menu 
command Options > Customize, go to the "View" tab, and select the "Default 
project view" in the drop-down list box. 

 

3. Create a new project by using the File > New menu command. Enter the 
desired project name in the displayed "New" dialog box and confirm your 
entries with "OK". 

4. In order to insert a MODBUS network, double-click on the "Networks" object in 
the right-hand window. Select the "Networks" object in the left-hand window 
and press the right-hand mouse button. In the displayed pop-up menu, select 
the entry Insert New Object > MODBUS Network.  

5. In order to insert the MODBUS device, select the "MODBUS Network" object in 
the right-hand window and press the right-hand mouse button. In the displayed 
pop-up menu, select the entry Insert New Object > MODBUS Network. In the 
menu tree, select the appropriate device (only required for the first call). In the 
dialog box displayed, enter the name of the device and confirm your entries 
with "OK". 

6. In order to check whether the correct network and the correct port are assigned 
to the COM interface, double-click on the "PC" object in the right-hand window. 
Select the "COM interface" object and press the right-hand mouse button. In 
the displayed pop-up menu, select the Object Properties ... entry. In the 
displayed "Properties" dialog box, set the MODBUS network in the "Network" 
tab card. If necessary, enter the desired COM port in the "Connection Data" tab 
card. 
Note: The COM port is almost always "1" for notebooks. Since most PCs have 
two COM interfaces, you always have to specify which interface the device is 
connected to in this tab card. 

7. In order to set the device address, select the inserted MODBUS device in the 
right-hand window and press the right-hand mouse button. In the displayed 
pop-up menu, select the Object Properties entry. In the displayed dialog box, 
select the "Connection Data" tab card and enter the settings required for 
communication. 
Note: The station number has to correspond to the connected device. 
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8. Start SIMATIC PDM by double-clicking on the newly inserted MODBUS device 
in the right-hand window and then configure the device. 

 

 Note 
If there are several PCs in your project, you have to define one of them as the "current" one. 
To do this, select the desired "PC" object in the left window, and then select the menu 
command Options > Define Current PC.  

 

3.18.2 Coupling a MODBUS Device in SIMATIC PDM 

Proceed as follows in order to couple a MODBUS network device to an 
RS 232/RS 485 or a Dolphin interface module: 

1. Start the SIMATIC Manager by double-clicking on the icon on the desktop or 
by using the Windows Start menu. 

2. Select the View > Process Device Network View menu command to specify 
the process device network view. 

 

 Note 

If you usually intend to work in the process device network view, select the menu 
command Options > Customize, go to the "View" tab, and select the "Default 
project view" in the drop-down list box. 

 

3. Create a new project by using the File > New menu command. Enter the 
desired project name in the displayed "New" dialog box and confirm your 
entries with "OK". 

4. In order to insert a MODBUS network, double-click on the "Networks" object in 
the right-hand window. Select the "Networks" object in the left-hand window 
and click the right-hand mouse button. In the displayed pop-up menu, select 
the entry Insert New Object > MODBUS Network. Select "MODBUS 
network", then right-click and in the displayed pop-up menu select the Object 
Properties… entry. The settings in the "Connection Data" tab card must match 
the settings for the device. 

5. In order to check whether the correct network and the correct port are assigned 
to the COM interface, double-click on the "PC" object in the right-hand window. 
Select the "COM interface" object and press the right-hand mouse button. In 
the displayed pop-up menu, select the Object Properties entry. In the 
displayed "Properties" dialog box, set the MODBUS network in the "Network" 
tab card. If necessary, enter the desired COM port in the "Connection Data" tab 
card. 
Note: The COM port is almost always "1" for notebooks. Since most PCs have 
two COM interfaces, you always have to specify which interface the device is 
connected to in this tab card.(Default = 1). 
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6. In order to insert the MODBUS device, select the "MODBUS Network" object in 
the right-hand window and press the right-hand mouse button. In the displayed 
pop-up menu, select the entry Insert New Object > MODBUS Network. In the 
dialog box displayed, enter the name of the measuring point and confirm your 
entries with "OK". 

7. In order to set the device address, select the inserted MODBUS device in the 
right-hand window and press the right-hand mouse button. In the displayed 
pop-up menu, select the Object Properties entry. In the displayed dialog box, 
select the "Connection Data" tab card and enter the station number required for 
communication.. 
Note: The station number has to correspond to the connected device (1 - 247). 

8. Start SIMATIC PDM by double-clicking on the newly inserted MODBUS device 
in the right-hand window. In the menu tree, select the appropriate device (only 
required for the first call), and then configure the device. 

 

 Note 

If there are several PCs in your project, you have to define one of them as the 
"current" one. To do this, select the desired "PC" object in the left window, and 
then select the menu command Options > Define Current PC.  
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4 SIMATIC PDM Integrated 

The coupling of SIMATIC PDM with SIMATIC STEP 7/PCS 7 is described below 
using examples. Confirmation of dialog boxes with "OK" is not described explicitly. 

After installation of SIMATIC PDM, STEP 7 re-creates its database and the 
hardware catalog. 

Always observe the Notes on configuring and parameterization. 

4.1 Creating a STEP 7 Project and Starting HW Config 

Proceed as follows: 

1. Start the SIMATIC Manager. 

2. Select the File > New menu command and then specify the Project type and 
enter a Name for the project in the "New" dialog box that is then displayed. 

3. If necessary, switch to the Component view. Right-click the icon with the name 
of your project and then select the Insert new object menu command, for 
example SIMATIC 400 Station. 

4. Click the icon with the name SIMATIC 400 Station with the right-hand mouse 
button and select the Open object menu command. You then switch to 
HW Config (Hardware Configuration).  

5. Select the Insert > Hardware components menu command to display the 
hardware catalog. Double-click on the SIMATIC 400 icon. 

6. First select a module rack, e.g. CR2 from the list displayed under RACK-400 
and pull it into the top part of the window with the drag-and-drop function of the 
mouse. 

7. Select a power supply, e.g. PS-405 20A, under PS-400. Place this in the first 
slot on the rack (see point 6). 

8. Select a central processing unit, e.g. CPU 414-2 DP under CPU-400 (DP 
means additional PROFIBUS-DP interface!). Place this in the next slot on the 
module rack. Select a network connection in the subsequent dialog box. 
Note: Not every CPU supports the necessary bus transmission rates. The bus 
transmission rates must be selected to suit the coupler used. When using 
Siemens DP/PA couplers, ensure that the CPU supports the necessary bus 
transmission rate of 45.45 kbits/s. 

9. Insert devices as described in "Coupling a Device in HW-Config". 

10. Save the project with Station > Save. 
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4.2 Opening an Existing STEP 7 Project and 
Starting HW-Config 

Proceed as follows to couple a device in an existing project in HW-Config: 

1. Start the SIMATIC Manager. 

2. Load the project with the File > Open menu command. 

3. If necessary, switch to the Component view. Right-click the icon with the 
name SIMATIC 400-Station and select the Open object menu command. You 
then switch to HW-Config (Hardware Configuration).  

4. Insert devices as described in "Coupling a Device in HW-Config". 

5. Save the project with the Station > Save menu command. 

4.3 Coupling a Device in HW-Config 

Devices can be coupled in HW-Config as follows: 

• Inserting a DP device 
PROFIBUS-DP devices can be inserted directly in the PROFIBUS-DP master 
system. 
Select the device you require under "PROFIBUS DP" from the hardware 
catalog and drag-and-drop it into the DP master system. If the DP master 
system is not displayed, select the Insert > DP Master System menu 
command in HW-Config.  

• Inserting a DP remote I/O system (distributed periphery) 
Example: ET 200iS 
Place the head station IM151-2 from the HW-Config catalog under "PROFIBUS 
DP\ET200iS" in the DP master system.  
The slots of the head station are displayed in the detail view (table below the 
graphic). Place the power supply module "PS" from the HW-Config catalog 
under "PROFIBUS DP\ET200iS\IM151-2\PS" in slot 1. You can insert the 
required analog and digital modules in slot 4 or higher. 

• Inserting a PA device via DP/PA coupler 
Select a PROFIBUS-PA device in the HW-Config catalog, e.g. a SITRANS P 
pressure transducer, under "PROFIBUS-
PA\Siemens\Sensors\Pressure\SITRANS-P" or a device profile under 
"PROFIBUS-PA\Others" and place it in the PROFIBUS-DP master system. 
Note: The DP/PA coupler need not be configured, an appropriate bus 
transmission rate (for example, 45.45 kbits/s for the Siemens coupler) merely 
needs to be set for the DP master system. 

• Inserting a PA device via DP/PA link 
Place the IM157 from the HW-Config catalog under "PROFIBUS-DP\DP/PA-
Link" in the DP master system. HW-Config creates a PA master system for the 
DP/PA link. You can place PA devices there as described above. 
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• Inserting a PA remote I/O system (distributed periphery) 
Example Pepperl + Fuchs 
Place the head station RSD-GW-EX1.PA from the HW-Config catalog under 
"PROFIBUS-PA\I/O SYSTEM" in the DP master system (with DP/PA coupler, 
see above) or in the PA master system (with DP/PA link, see above). 
The slots of the head station are displayed in the detail view (table below the 
graphic). Place one of the listed modules from the HW-Config catalog under 
"PROFIBUS-PA\P+F I/O SYSTEM\RSD-GW-EX1.PA" in a free slot.  

• Inserting a HART device via an ET 200M HART module 
Place an IM153-2 from the HW-Config catalog under "PROFIBUS-
DP\ET200M" in the DP master system. The slots of the ET 200 M are 
displayed in the detail view (table below the graphic). Place a HART module 
‘SM331 AI 2_0/4 to 20 mA HART Ex’ from the HW-Config catalog under 
‘PROFIBUS-DP\ET200M\IM153-2\AI-300’ in a free slot. The HART module 
with 2 channels is shown in the detail view. Place the object listed under 
‘..\AI-300\SM331 AI 2_0/4 to 20 mA HART Ex\HART_field_device’ there. 

• Inserting a HART device via an ET 200iS HART MODULE 
Place an IM 151-2 in the DP master system from the HW Config catalog under 
"PROFIBUS DP\ET200iS". The slots of the ET200iS are displayed in the detail 
view (table below the graphic). Place a HART module "2 AI HART" (for HART 
sensors) or "2 AO-HART" (for HART Actors) from the HW Config catalog under 
"PROFIBUS DP\ET200iS\IM151-2" in a free slot. Then open SIMATIC PDM by 
double-clicking on the header module, and configure the ET200iS. Close 
SIMATIC PDM, switch to the process device net view of the SIMATIC 
Manager, and configure the HART device for the ET 200iS modules. 

• To set the address select the dialog box "Object Properties" in HW Config and 
enter the required PROFIBUS address (HW-Config automatically assigns 
addresses in the order that objects are created - these may need to be 
corrected, depending on the device used (refer to the device manual)). Right-
click on the object to reach the "Properties" dialog box. 
Addresses (address/slot/channel) issued by HW-Config for subsequent 
devices/modules (e.g. for modules in head stations) should not be changed if 
possible. 

• Save the project with the Station > Save menu command. 
 

 Notes  

• All PROFIBUS devices, modules and HART devices coupled in HW-Config are 
automatically displayed in the network view and in the PDM application.  

• All PROFIBUS devices, modules and HART devices configured in the network 
view which do not exist in HW-Config are deactivated. Objects which are 
deactivated are displayed with a gray icon and in the properties dialog of the 
object the checkbox "Deactivated" is selected.  

• If you delete an object in the network view and not in HW-Config, the object will 
be reinserted.  

• The devices for cyclic communication are configured in the HW-Config device 
catalog so that the number of values to be communicated has to be selected 
additionally. 
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4.4 Using an IE/PB Link 

Using an IE/PB link with STEP 7 stations 

To establish an Ethernet connection to a DP device at an S7-300 station or to the 
internal DP interface in an S7-400 station, you need an IE-PB link, which provides 
the data record gateway that is needed to configure the devices. An IE/PB link 
must be created for each DP chain in the project. 

In setting up the IE/PB link, the first step is to assign it an IP address. In order to do 
this, the IE/PB link must be connected with the ES computer through Ethernet. To 
assign an address, go to the SIMATIC Manager and select the PLC > Assign 
Ethernet Address... menu command. In the dialog box that is then displayed, 
enter the Ethernet address of the link, or click the "Browse" button to search for 
and select the link. After this, assign the link its corresponding IP parameters. The 
IE/PB link is now ready for use. 

In an STEP 7 project, an S7-300 station is required for the IE/PB link. In HW Config 
for STEP 7/PCS 7, add the IE/PB link to the empty station. This link is located in 
the hardware catalog for the SIMATIC 300 in the "Network Gateway" folder. To 
assign parameters in the project, now enter the values for the Ethernet connection 
and the DP interface that apply to the project. Set the DP interface to "No DP" so 
that it simulates a programming device/PC on the PROFIBUS  DP chain in the 
IE/PB link. 

After you have configured all stations and assigned parameters to them, select the 
Network > Save and Compile menu command to finish creating the routing table. 

To communicate via Ethernet, you now have to select the TCP/IP protocol in the 
programming device/PC settings for the CP1613 or other network card that will be 
used for communication. In addition, you have to create another programming 
device/PC in parallel to the stations in the component view. Configure an Ethernet 
interface in this programming device/PC. Then assign this interface to the interface 
set up with the programming device/PC interface. 

Now when you open the hardware configuration for an S7-300 station, 
communication to the devices will also function via Ethernet. 

Using IE/PB link with systems from other manufacturers 

In order to be able to use systems made by other, third-party manufacturers, you 
will have to configure an S7-300 or S7-400 station as a "dummy" station. For this 
purpose, a simple configuration consisting of a rack, PS, CPU and DP interface will 
be sufficient. The devices will then be distributed on the DP chains for this station 
just as they are connected to the masters from other manufacturers. 

In this case, you have to ensure that the DP settings at the other masters are 
selected so that the token routing can be done through two masters (the "other" 
master and the IE/PB link). 

As is the case for use with an S7 plant, one IE/PB link per DP chain is also 
required here. 

For establishing communication, the same prerequisites and settings apply as for 
use in STEP 7 stations. In other words, a programming device/PC with an Ethernet 
interface is required. 
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5 Working with SIMATIC PDM 

After you have opened a device from the SIMATIC Manager or from HW-Config, 
the parameters with their values from the project that is saved on a hard disk are 
displayed in a table of the user interface of SIMATIC PDM. The Device > 
Download to Programming Device/PC menu command is used to read the 
parameters from the device into this table. 

All configurable objects, including the subordinate objects are displayed in the 
parameter group view. First, only the root object is displayed in the parameter table 
and can be edited (white background). You can set display and other options for 
the parameter table in the "Table". To do this, select the menu command 
Options > Customize. 

If you click on one of the subordinate objects in the parameter group view, the 
parameters in the parameter table are displayed and can be edited. 

If a object is already open by another user, a message will be displayed as to 
which user or PC opened the object. All fields of the parameter table have gray 
backgrounds, and the parameters cannot be modified. 

If you make changes to the parameters of an object and save them, the 
parameters in applications in which the same objects are write-only opened are 
automatically updated. The write permission for the objects remain unchanged until 
you close SIMATIC PDM. 

 

 Caution 
Although the SIMATIC Manager does save each individual change immediately, please be 
aware that all changes in an open SIMATIC PDM object take effect only after you have 
selected the menu command File > Save. 

 

Several dialog boxes may be displayed simultaneously. This means that you can 
open the process values dialog for several objects without having to close the 
dialog boxes, for example. In this way you can compare the process values of two 
objects. In the title line of the dialog box you can see the name of the object. 

The display in the status bar and the title line depends on which object you have 
selected. 

The menu command in the Device menu and in the Display menu open online 
dialog boxes that display the parameters from the device and allow inputs. These 
dialog boxes are marked with "Online" in the title bar. Dynamic device information 
that is updated cyclically is displayed in them. 
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Configuration 

You have the following possibilities of configuring devices: 

• Local configuration 
The Device > Upload to the PC/Programming Device menu command is 
used to upload the current data of the device to your programming device/PC. 
Change the desired parameters and download the data back to the device with 
the Device > Download to the Devices menu command. 

• Online configuration 
The "Online configuration" is not available at every device. It has to be 
supported by the Device Description of the device and you have to activate the 
"Online Dialog Box Available in the Table" option in the "Table" tab card 
(Options > Settings... menu command). After this function has been selected, a 
dialog box with the current parameter value from the device is displayed. In this 
dialog box you can change the parameter and write it individually directly into 
the device. The values from the device and the entries in the online dialog box 
are not imported into the parameter table.  

Curve diagrams 

At some devices curve diagrams are included in the application. x-t or x-y formats 
are displayed. The following operations are possible: 

• The corresponding axis can be stretched or compressed by pressing the left-
hand mouse button. The left-hand or upper scale value remains unchanged. 

• The corresponding axis can be stretched or compressed by pressing the right-
hand mouse button. The right-hand or lower scale value remains unchanged. 

• The corresponding axis range can be moved by pressing the right-hand and 
left-hand mouse button simultaneously. 

Example projects are contained on the SIMATIC PDM CD. 
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5.1 First Steps with SIMATIC PDM 

SIMATIC PDM is easy to use and enables a quick introduction to configuration of a 
device. 

After configuration (see Configuring Networks and Devices...) start 
SIMATIC PDM by double-clicking the device icon (in SIMATIC Manager or in 
HW-Config). 

When SIMATIC PDM is started you will see a welcoming picture and the "User" 
dialog box (which can be disabled) is displayed. The PDM main frame then opens 
It consists of: 

• Title bar 

• Menu bar 

• Toolbar 

• Parameter group overview (on the left in the working window) 

• Parameter table (on the right in the working window) 

• Status bar  

The toolbar provides icons for fast operation of functions that are also contained in 
the main menu. 

There are different ways to select some functions, for example: 

• With menu commands, 

• Open a menu with the keyboard and mouse, 

• Select and execute a menu command with the keyboard and mouse, 

• With the mouse by clicking on icons. 

The parameter group overview shows a directory structure in a tree as in the 
Windows Explorer. Depending on the selected parameter group, the appropriate 
parameters are displayed in the parameter table. 

In the parameter table you can enter or select the values in the value field for input 
parameters (parameters with "Values" field with a white background). Inputs and 
changes are only effective off-line at first; the complete parameter record must be 
clearly transferred to the device in order to become effective there (exception 
parameterization via online dialog boxes; see Parameter table – Functions of the 
right-hand mouse button. 

 

 Note 

Please refer to the manufacturer’s technical manual for information on how to set 
the device parameters. 

 

The status bar shows, among other things, whether there is an online connection 
to the device. 
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The Options > Settings menu command is used to carry out various individual 
settings for using SIMATIC PDM: 

• User (access authorization) 

• Password 

• Table options 

• Font 

• Communication options 

• Log tool 

User settings 

SIMATIC PDM has two different access authorizations for users: 

• Maintenance engineers and 

• Specialists 

The maintenance engineers can only modify the operating data – the specialists all 
the data. 

Setting the password 

After the installation an "empty" password is preset (there is thus no formal 
password). In order to obtain security the specialist should assign a password. 

Table options 

SIMATIC PDM shows an overview of all the device parameters in a table. The 
behavior after an input and the layout in the display and during printing can be set 
here. 

Setting the font 

Here you can set the font used for the display and for printing the table. 

Communication options 

After the installation the cycle time for periodic communication jobs is set to 
1,000 ms (corresponding to 1  s). You can change this value, but should not reduce 
it too far unnecessarily. 

Log tool 

SIMATIC PDM offers an integrated log tool, for example to help in searching for 
errors during communication problems. You can activate it and determine which 
log messages are to be output. If you activate the log tool, a window with the most 
important log messages is displayed while SIMATIC PDM is running. This can be 
printed out and saved. 
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5.2 Maintenance Engineer / Specialist 

Maintenance engineer 

In "Maintenance engineer" mode you can only carry out the modifications 
necessary for operation and maintenance in the parameter table. 

Specialist 

If a password has been defined in the "Settings" dialog box, the current password 
must be entered when selecting the option field "Specialist" in the "User" dialog box 
which is displayed when starting the application. 

The extended modification possibilities are then available for the specialist in the 
parameter table. 

5.3 Main Window 

The "SIMATIC PDM" main window remains on the screen throughout the complete 
working session, and is partially or totally covered by other activated dialog 
windows. 

The main window consists of: 

• Title bar 

• Menu bar 

• Toolbar 

• Parameter group overview (on the left in the working window) 

• Parameter table (on the right in the working window) 

• Status bar  
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5.4 Parameter Group Overview 

The parameter group overview is displayed in the left part of the main window. 

The objects and their parameter groups are displayed here as well as any possible 
existing subordinate objects. The selected group (only one group can be selected 
at any time) is displayed with a blue background. The parameters belonging to the 
selected group are now displayed in the parameter table. The subgroups with their 
parameters are also visible if the Display subentries entries is activated in the 
Options menu. 

If you have changed a value in the parameter table, the color of the corresponding 
directory symbol changes from yellow to blue. In addition, the main directory 
symbol (first line of the parameter group overview) is now also displayed in blue. If 
the modified value is invalid, the color of the corresponding directory symbols 
change to red. 

 

 Note 

To get faster results when refreshing the screen display, we recommend that you 
only select the parameter group (in the parameter group overview) that you 
actually intend to edit.  

 

5.5 Parameter Table 

The right-hand part of the main window is filled by the parameter table. 

This parameter table lists the individual parameter groups in succession (as listed 
in the parameter group overview). A hierarchy as in the parameter group overview 
is not displayed here. 

If you click a parameter group in the parameter group overview, the group is 
displayed in the parameter table. If the "Display subentries" line has been activated 
in the "Options" menu, all subgroups of the selected parameter group are also 
displayed. If the line is inactive, only the parameters of the selected group are 
displayed. 

Each parameter group commences with a heading with the name of the group on a 
colored background. The special characters preceding the heading text indicate the 
level of the heading. The individual parameter lines are positioned underneath the 
heading. 

A field on a white background can be edited, the other fields cannot. 

The number of parameters which can be edited depends on the selected status 
(Maintenance engineer / Specialist) and possibly on parameter values. 
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The parameter table is divided into the following columns: 

• Parameter 

• Value 

• Unit 

• Status  
 

If the table is longer than the screen area, a scrollbar is displayed at the right edge. 

 

 Note 

To get faster results when refreshing the screen display, we recommend that you 
only select the parameter group (in the parameter group overview) that you 
actually intend to edit.  

Functions of the Right-hand Mouse Button 

Clicking the right-hand mouse button within the parameter table opens a pop-up 
menu with the following possible displays and functions: 

 

Entry Explanation / operating information 

Minimum value: Displays the smallest permitted value of the parameter.   *)   **) 

Maximum value Displays the largest permitted value of the parameter.   *)   **) 

Initial value Displays the initial value of the parameter.   *) 

Default value Displays the default value of the parameter.   *)   **) 

Help When you select this entry you will receive context-related Help on 
parameters. 

Online Displays an online dialog box (if selected under Options > Settings > 
Table). The tab card shows the current parameter value from the 
device. You can change the parameters and write them directly into the 
device. The value in the parameter table is not affected by this. It only 
changes after another "Upload to the programming device/PC" 
procedure. 

*)  Clicking on the value with the left mouse button transfers the value to the 
parameter table. 

**) There can be several minimum, maximum and default values. 

 

 Note 

These displays / functions must be supported by the device description. 
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5.6 Log 

SIMATIC PDM provides an integrated log tool. You can activate it and determine 
which log messages are to be output. If you activate the log tool, a window with the 
most important messages is displayed while SIMATIC PDM is running. This can be 
printed out and saved. The log is used to search for errors at communication 
problems with the device. 

The messages are weighted in accordance with their meaning and the following 
categories exist: 

• Errors 

• Warnings 

• Communication log 

• Details 

• All messages 
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6 Loading of Data Between Various Devices 

While on the configuration level of the SIMATIC Manager you can load the data for 
configured devices across a complete plant, across a unit or for individual devices 
into the device or into the PC/programming device without having to open 
SIMATIC PDM for each device. 

You have the following possibilities for loading data: 

• Downloading to the devices/uploading to the programming device/PC of the 
selected device 

• Downloading to the devices/uploading to the programming device/PC of the 
selected device and of the devices in the first level under the selected device  
(only for remote I/O) 

 

 Note 

For remote I/Os, at least 2 connections have to simultaneously supported in order 
to enable communication to connected HART process devices. 

 

• Downloading to the devices/uploading to the programming device/PC of the 
selected device and of all the devices under the selected device 

Loading of data across a complete plant is carried out without interruption. Any 
errors occurring and other messages are saved and displaced afterwards.  

The Upload to the Programming Device/PC function is used to download all the 
device variables of a device object from the device into the off-line database. 

The Download to the Devices function is used to download all the device 
variables of a device object from the off-line database into the device. 

Proceed as follows in order to load data in the network view or the plant view: 

1. Click on the desired device with the right-hand mouse button and select the 
context-sensitive menu command Download to the Devices or Upload to the 
Programming Device/PC. 

2. Select the desired settings in the displayed dialog box "Download to the 
Devices" or "Upload to the Programming Device/PC". 

3. Confirm your settings with "OK". 

During the loading process, a dialog box is displayed which shows the objects 
already processed in a tree structure similar to that of the SIMATIC Manager. Any 
faults occurring at a device do not cause the complete action to be aborted, but 
only apply for the device just processed. 

The dialog box is updated during the loading process. The status "In process" is 
displayed in the title bar while the process is active. The status "Result" is 
displayed after the process has been completed. 
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6.1 Processing Results 

After the data have been downloaded to the configuration level of the SIMATIC 
Manager, you can have the processing results displayed. 

In order to view the messages select the desired device and click on the 
"Properties…" command button or double-click on the corresponding icon. The 
"Properties" dialog box with the messages on the device is displayed. 

Saving and displaying the messages 

The messages created while the data were last being downloaded to the device or 
uploaded to the programming device/PC are saved with the object data of the 
device and are added to the "Properties" dialog box in the tab cards "Download to 
the Device: Status" or "Upload to the Programming Device/PC: Status". This 
means that the messages can be viewed not only immediately after they have 
been loaded but also at a later point.  
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7 Importing/Exporting Configuration and 
Parameter Data 

The configuration and parameterization data of projects with PDM objects can be 
exported as PDM data and be imported at another point (for example, into another 
project or into another PC). 

Complete projects or project sections (partial trees in the tree view of the process 
device network view or plant view) can be exported or imported. 

To open a PDM file, go to the Explorer and double-click the file desired. 

Since the exported data are saved in XML format, they can, for example, also be 
converted easily into other formats by means of XSL files and can be displayed or 
modified by means of external tools. The SIMATIC PDM CD contains an XSL file 
by means of which the exported data can be converted to the CSV format (Comma 
Separated Values) so that they can be displayed in common software projects in 
tabular (spreadsheet) form. 

Exporting data 

Proceed as follows in order to export data: 

1. Select a PDM object in a view of the SIMATIC Manager and press the 
right-hand mouse button. 

2. In the pop-up menu of this object select the entry Export...  

3. In the displayed dialog boxes, specify the type of export as well as the name 
and position at which the PDM file containing the exported data is to be saved. 
Confirm your entries by clicking on "OK".  

4. The selected object and all the objects lying below this object are exported. 
During the exporting process a dialog box is displayed which shows the objects 
already exported in a tree structure similar to that of the SIMATIC Manager. 
Any faults or errors occurring at a device cause the complete action to be 
aborted. 
The dialog box is updated during the exporting process. The status "In 
process" is displayed in the title bar while the process is active. The status 
"Result" is displayed after the process has been completed. 
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Importing data 

When importing data, you can choose between the following two options: 

• Comparative Import: You can use a comparative import to organize data that 
already have been exported and then externally edited so that they can be 
efficiently re-imported at the same location. In addition, you can import data 
located and exported with SIMATIC PDM LifeList into existing projects. 
 
In a comparative import, each device type is checked (based on the assigned 
device DDL) to determine if it is identical. If device type is not identical, a dialog 
box is displayed in which you can indicate whether it should still be imported or 
not. 
Each object is then checked to determine when it was last changed. During this 
process, the following distinctions are made:  

- In the case of an object that was changed in the project but not in the file to 
be imported, a dialog box is displayed in which you can indicate whether it 
should still be imported or not. 

- In the case of an object that is identified as changed in both the file to be 
imported and the project, a dialog box is displayed in which you can 
manually select the objects that you want to import. 

- If an object is shown as having only been changed in the file to be 
imported, then it is imported without any request for user confirmation. 

• In addition, a check is made to determine whether several "identical" objects 
exist on the current configuration level in the file to be imported or in the 
project. During this process, the following distinctions are made: 

- If the file to be imported contains several identical objects, only the first of 
these objects is imported (You will receive a message indicating this 
condition.). 

- If the project contains several identical objects, a comparative import is not 
carried out for this objects (You will receive a message indicating this 
condition.). 

• Additive Import: In this case, all objects in the file to be imported are inserted, 
regardless of whether identical objects already exist in the project. 

 

 Note 

The determination of whether objects are considered to be 'identical' depends on 
the specific object type. For all currently existing SIMATIC PDM object types, 
objects with the same object name or the same TAG are considered identical. For 
submodules (e.g. remote I/O submodules), those submodules with the same slot 
number are considered identical. 
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Proceed as follows in order to import data: 

1. Select a PDM object under which you want to import a partial project in a view 
of the SIMATIC Manager and press the right-hand mouse button. In the pop-up 
menu of this object select the entry Import...  

 

 Note 
If a complete project was exported previously, you can also click on the file with the 
extension .pdm. 

 

2. In the "Import" dialog box, specify whether you want to carry out an additive or 
comparative import, and confirm your choice with "OK". 

3. In the displayed dialog box specify the name and position of the PDM file 
containing the imported data and confirm your entries by clicking on "OK".  

4. During the importing process a dialog box is displayed which shows the objects 
already imported in a tree structure similar to that of the SIMATIC Manager.  
Any faults or errors occurring at a device cause the complete action to be 
aborted. 
The dialog box is updated during the importing process. The status 
"Processing" is displayed in the title bar while the process is active. The status 
"Result" is displayed after the process has been completed. 

 

!  
Caution 
• During the importing process, ensure that the type of the object on which you have 

carried out the export can be configured below the selected PDM object. It is thus, for 
example, not possible to export a HART device and then import it below a PROFIBUS 
network. If you import the data at the incorrect position, a message is displayed stating 
that the object of the type x (= type of the exported object) cannot be configured under 
an object of the type y (= type of the selected object). 

• Objects which are linked to HW-Config objects lose this link during the export. 

• Before exporting, ensure that there are no identical objects in a subtree (such as Name, 
Slot Number). Otherwise, conflicts may occur during a subsequent comparative import. 

• Objects that were originally only present once will possibly be exported several times 
and thus also imported several times. Thus, a HART device that has been configured 
several times (such as in a HART modem network, in an ET200M and in a multiplexer 
network) will appear several times when exporting. When importing, this object will also 
be created several times, even if it is actually only a single device. This means that 
such objects can exist several times in the plant view. 

• If the object type for the root object in the import file matches the object selected in the 
project, the root object will be imported comparatively and not inserted under the 
selected object, since this would then mean that networks or devices could not be 
imported.  
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7.1 "Import - In Process" Dialog Box 

This dialog box is displayed during the importing process. It shows the objects 
already processed in a tree structure similar to that of the SIMATIC Manager. Any 
faults or errors occurring at a device cause the complete action to be aborted. 

The dialog box is updated during the importing process. The status "In process" is 
displayed in the title bar while the process is active. The status "Result" is 
displayed after the process has been completed. 

The device icons used have the following meanings: 

 

  The import was carried out error-free. 

  
The import was carried out error-free and a new object was added. 

  The address of the object changed during the comparative import. 

  The import was not carried out at this device because the object has not been 
changed. 

  Messages and warnings occurred during the import. 

  The import was aborted due to an error. 

  The object is currently being edited elsewhere. 

  The import was not carried out at this device. 

  The device does not support this function. 

  The import is being carried out at this device. 

"Properties…" command button 

Click on this command button in order to have the properties for the selected 
device displayed. 
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7.2 "Export - In Process" Dialog Box 

This dialog box is displayed during the exporting process. It shows the objects 
already processed in a tree structure similar to that of the SIMATIC Manager. Any 
faults or errors occurring at a device cause the complete action to be aborted. 

The dialog box is updated during the exporting process. The status "In process" is 
displayed in the title bar while the process is active. The status "Result" is 
displayed after the process has been completed. 

The device icons used have the following meanings: 

 

  The export was carried out error-free. 

  Messages and warnings occurred during the export. 

  The export was aborted due to an error. 

  The object is currently being edited elsewhere. 

  The export was not carried out at this device. 

  The device does not support this function. 

  The export is being carried out at this device. 

 

"Properties…" command button 

Click on this command button in order to have the properties for the selected 
device displayed. 
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8 Distributed Editing of Projects 

With SIMATIC PDM, you have the option of editing projects in a distributed 
manner. To do this, you can read the device data out from a central project and 
use them to set up devices on location. After this, you can import the device data 
changed on location back into the central project. In order to be able to do this, 
SIMATIC PDM must also be installed on the portable computer being used. 

To edit a project in a distributed manner, proceed as follows: 

1. Export the desired device data from the central project. 

2. Transfer the .pdm file to a portable computer. 

3. Double-click the .pdm file on location. SIMATIC PDM opens and you can now 
transfer the device data to the intended devices. 

4. If necessary, change the data at the device. Then load the changed data back 
to your portable computer and save the .pdm file. 

5. Transfer the .pdm file to computer with the central project 

6. Import the .pdm file (comparative import) into the central project. 

  

 Note 
If any changes were made to the central project in the meantime, a message to this effect 
will be displayed. You can then decide which information should be transferred. 

 

For detailed information on exporting and importing device data, see the section 
Importing/Exporting Configuration and Parameter Data. 
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9 Communication 

9.1 Secure Communication 

In SIMATIC PDM, whenever you establish an online connection to a device, 
relevant points such as the following are checked while the connection is being 
made: 

• Does the device type match? 

• Is it the same type of device? 

• Were changes made to the device that are not yet saved in the project? 

If a connection is interrupted, SIMATIC PDM automatically attempts to establish a 
new connection. Any errors that occur are displayed and logged. 

If a device did not accept the data in an identical manner, the values that were 
written to the device and the actual values read back from the device are 
displayed. You can then decide whether or not to use the changed values in you 
project. 

After the identification test, the device status is determined and the device is 
displayed with the appropriate icon.  
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9.2 Communication Problems 

If communication problems occur, check the following points: 

Problems while a connection is being established 

• Configuration 

- Is the programming device/PC interface configured correctly? You can 
access the configuration of the programming device/PC interface via the 
SIMATIC Manager via the Options > Set Programming Device/PC 
Interface menu command or via the Control Panel of Windows. 

- If configuration is not carried out via HW-Config: Is an interface assigned to 
the PC. Is this interface the correct one? Is this interface assigned to a 
network? Is this network the correct one? 

- In case of routing: Is a programming device/PC included in the project in 
the component view? Is an interface - the correct one - assigned to the 
programming device/PC?  
Check the assignment:  
To do this, first select the interface, then select the Edit > Object 
Properties menu command. In the dialog box that is then displayed, go to 
the "Network" tab and select the desired network. 

- Are the addresses (address, slot, channel) assigned correctly and uniquely 
in the project? 

- Has the correct communication path been selected? Depending on the 
configuration, devices can be accessed via various communication paths - 
for example, HART devices can be reached via ET  200  M, a HART 
module and a HART interface network. 
Check the communication path: 
To do this, select the Device > Communication Path menu command in 
SIMATIC PDM  

- If there are several PCs in your project, specify the current PC: 
To do this, select the Options > SIMATIC PDM > Define Current PC 
menu command in the Simatic Manager. 

- Has an inappropriate device been assigned from the catalog? In the dialog 
box "Properties" select a new device from the list "Supported Devices and 
Profiles", information on which you can find in the README file. If you still 
have problems contact your device dealer. 

• Hardware structure 

- Is the plant complete and has it been cabled correctly? Are all the 
connectors plugged in correctly? Are the modules plugged correctly? 

- Are all the modules and devices of the plant supplied correctly? 

- Are there low-or high-frequency disturbances in the plant? Is the plant 
subject to the influence of electromagnetic fields? 

- Is there short circuit at the bus or a wire break in a wire leading to the 
device? 



 Communication 

The Process Device Manager 
A5E00325944-01 9-3 

• Addressing the devices 

- Are the addresses (address, slot, channel) set correctly at the devices in 
the plant? 

- Do the addresses set at the devices agree with the configured addresses?  
The settings at the devices are carried out via hardware switches, 
configuration or a combination of both. 
In the case of PROFIBUS DP/PA devices the device address can be set 
from SIMATIC PDM - See also assigning addresses. 

• Software in the CPUs, CPs 

- The software downloaded to the CPUs or CPs has the agree with the 
configuration. In HW-Config the configuration is downloaded to the CPU or 
CP of the station by means of the PLC > Download to Module > Select 
Target Module menu command. 

• Maximum number of connections 

- Devices or communication components can only manage a restricted 
number of open connections. It is therefore possible that connections 
cannot be established. To open new connections to devices, close S7 
applications. For information on the maximum number of connections 
permitted, please refer to the respective device manuals. 

- With remote I/Os, at least two connections must be simultaneously 
supported in order to enable communication to connected HART process 
devices.  

Communication Errors 

Communication errors may occur when using standard device descriptions, for 
example HART Universal Standard or a PROFIBUS profile description. 

• The reason for this may be an unsuitable device assignment. If this is the case, 
assign a suitable device in the "Properties" dialog in the "Device" Tab. For 
further information, for example on firmware versions, see the "SIMATIC PDM - 
Integrated Devices" reference file, which you can open by using the Windows 
Start menu (Start > SIMATIC > Documentation > English).  

• Another reason may be that the device does not fulfill or fully implement the 
standard. Please contact the device manufacturer in this case. 
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Disconnection of a connection 

• Address changes 

- Was the address of a device changed at the device without recording this 
change in the configuration? 

• Reset functions 

- Was a reset function triggered in the device? A reset can be triggered 
manually or by the firmware of the device (for example, in case of 
hardware errors, incorrect program execution). The reset can block the 
device in a defined "secure" operating state or trigger a restart of the 
program with basic settings. These basic settings can differ from the 
desired settings, for example incorrect address, transfer speed. 

• Disturbances  

- Do low-or high-frequency disturbances occur in the plant or is the plant 
subject to the influence of electromagnetic fields? Has the power supply of 
the plant, of parts of the plant or of devices been disconnected? Have 
connectors or plugs been withdrawn or plugged in elsewhere? 

 

 Notes 

If other communication problems occur, please contact the device manufacturer. 
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9.3 Communication via SIMATIC S7 Stations (Routing) 

9.3.1 Routing 

Overview 

In most automation plants the programming device can only be operated via the 
bus cable (subnet) connected to the automation system. In larger networked plant 
this therefore means that the programming device has to be connected to various 
bus cables (subnets) before an automation system which lies far away can be 
reached online. 

The routing function allows you to reach automation systems online across subnet 
limits with the programming device/PC, in order, for example, to download user 
programs or a hardware configuration or to carry out debugging functions. 

Routing is also possible via TELEPERM XP. You can route via SIMATIC S7 
stations or via TELEPERM XP stations. 

The "Programming Device Routing" functionality allows you reach automation 
devices across different subnets from a fixed position in the plant without having to 
plug over the bus connectors. To this purpose special "routing tables" for the 
network transitions are generated automatically during the network configuration 
with STEP 7. These routing tables are special system data and have to be 
downloaded to the network transitions, meaning the S7 CPUs or CPs. The path to 
the selected automation device can then be found via the network transitions when 
the programming device goes online. 

The transition from one subnet to one or more other subnets lies in a SIMATIC 
station that has interfaces to the respective subnets.  

Prerequisites 

• STEP 7 above Version 5 and SIMATIC PDM (meaning that you work with 
SIMATIC PDM integrated). 

• The modules with communication functionality (CPUs or CPs) which establish 
the network transitions between the subnets have to be capable of routing. 

• All the automation devices or communications partners which can be reached 
in a plant network have to be configured and downloaded within an S7 project. 

• The desired S7 station is networked and can really be reached via the network 
transitions. 

• The modules have to be downloaded together with the configuration 
information, which contains the current "knowledge" on the complete network 
configuration of the projects. 
Reason: All the modules participating in the network transition must contain the 
information on which subnets can be reached by which routes (routing tables). 

• The programming device/PC to which you want to establish an online 
connection has to be configured in the network configuration and assigned to 
your generation system. 
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9.3.2 Creating a Routing Configuration 

Proceed as follows in order to create a network which enables routing: 

1. Create a new project in the SIMATIC Manager by using the File > New menu 
command and enter a name for the project in the displayed dialog box. 

2. If necessary, change to the component view (View > Component view menu 
command). 

3. Select the project, press the right-hand mouse button and select the entry 
Insert New Object > SIMATIC Station. Objects are now created in the right-
hand part of the window. 

4. Double-click on "Hardware". The module catalog is opened. Select a rack, a 
power supply unit and CPU which enables routing from the module catalog and 
drag-and drop the selected devices into your configuration. Configure the CPU. 

5. Insert an Ethernet or a PROFIBUS interface. 

- Ethernet interface: Select an Ethernet CP (CP443-1, ISO or TCP) and 
drag-and-drop it to the desired slot. Open the "Properties" dialog box by 
double-clicking on the CP. Enter all the required settings (MAC address, 
IP address, etc.) in the "Parameters" tab card. 
Note: If you do not know the MAC or IP address of the interface, you can 
have the network configuration of your plant checked and displayed by 
"pinging" the Internet address.  

- PROFIBUS interface: Select a PROFIBUS CP (CP443-5, extended) and 
drag-and-drop it to the desired slot. Open the "Properties" dialog box by 
double-clicking on the CP. Enter all the required settings (DP address) in 
the "Parameters" tab card. Now click on the "New" command button and 
enter the transfer rate in the "Network Settings" tab card in the displayed 
dialog box. Click on the "DP Master" option in the "Operating mode" tab 
card and confirm your entries with "OK". 

6. Save the project to your CPU by using the PLC > Download to Module menu 
command. 

7. Change to the SIMATIC Manager and from there, if necessary, to the 
component view. 

8. Select the project, press the right-hand mouse button and select the entry 
Add New Object > Programming Device/PC. The programming device or the 
PC is now inserted. 

9. Double-click on the icon and enter the interfaces which are installed in your 
programming device/PC into the "Interfaces" tab card in the displayed dialog 
box. To do so, click on the "New" command button and select the desired 
interfaces. You still have to set the addresses and select the desired network 
for the interfaces. 

- Ethernet interface: Enter the MAC address of the interface installed in your 
programming device/PC. 

- IP interface: Enter the MAC address, the IP address and the subnet mask 
of the interface installed in your programming device/PC. 

Note: If you do not know the addresses of your interfaces, you can find these 
out under Windows NT by using the DOS command box with the command 
"ipconfig /all". If you enter this command and press the Return key, all the 
device data are displayed. 
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10. Connect the interface to the Ethernet line, select the subnet and click on "OK" 
to confirm your entries. Select the interface and the network board in the 
"Assignment" tab card and click on the "Assign" command button.  

Your programming device/PC is now configured so that you can establish 
connections to other subnets and read data from devices in SIMATIC PDM without 
having to replug the bus connector. 

 

 Note 

If the communication path being used in a redundant STEP 7 station fails, this 
failure will be reported. The next time you call a function that requires 
communication to the device, an alternative connection path will be selected if the 
default one is not available. 
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10 Diagnostics 

SIMATIC PDM provides detailed diagnostics and diagnostic classification functions 
for integrated field devices. 

The device icons are assigned during configuration. When a connection is being 
established, device-specific diagnostic information is automatically evaluated and 
classified. The resulting classification is indicated by corresponding icons. These 
icons are displayed in the network view, in the plant view of the of SIMATIC 
Manager, in SIMATIC PDM and in LifeList. 

This diagnostic information is automatically saved in the project, even if the 
parameter data is not saved. 

When an online connection is being established, an identification check is 
performed. After this, the device status is determined, and based on this, the 
device represented by the appropriate icon. 

The diagnostic classification covers the following categories: 

• Communication 

- Communication with the device was good 

- Communication was good, but the device does not support further 
diagnostics 

- Communication faulty 

- Device assignment error 

• Process 

- Device unchecked 

- Device deactivated 

- Process value interrupt 

- Process value warning 

- Process value tolerance 

• Maintenance 

- Maintenance interrupt 

- Maintenance warning 

- Maintenance required 
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• Configuration 

- Configuration error 

- Configurations warning 

- Configuration changed 

• Operating Mode 

- Manual operation 

- Simulation or substitute value 

- Out of operation 

 

 Note 

When checking the status of a device, it is possible that the diagnostic information 
is not determined completely since not all devices support the full extent of this 
function. In this case, please contact the manufacturer of this device to integrate 
the device completely in SIMATIC PDM.  
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10.1 Overview of Device Icons 

The following table provides an overview of the device icons and the associated 
device classification. For an exact description of thee icons, see the section Icons 
for Devices. 

 

        
Category  

 

Priority 

Communication Process Maintenance Configuration Operating 
Mode 

Initial Status 

  
Communication 
error 

  
Unchecked 

 -  -  - 

High  - 

   
Process 
value 
interrupt 

   
Maintenance 
interrupt 
 

   
Configuration 
error 
 

   
Manual 
operation 
 

Medium 

  
Assignment error  
 

   
Process 
value warning 
 

   
Maintenance  
warning 
 

   
Configuration 
warning 
 

   
Simulation or 
substitute 
value 

Low  - 

   
Process 
value 
tolerance 

   
Maintenance 
required 
 

  
Configuration 
changed 
 

 - 

Good 

    
Good 

 

  
Good, no 
diagnostic 
support 

 -  -  -  - 

Deactivated, 

Passivated 

 - 

  
Deactivated 

 -  - 

   
Out of 
operation 
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Diagnostic Classification 

• Error/Interrupt (high) 
The probability that an error will occur within the next 24 hours is very high. 

• Warning/Request (medium) 
The probability that an error will occur within the next 7 days is very high. 

• Required (low) 
The device requires maintenance fairly soon. The probability that an error will 
occur within the next 7 days is low. 
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11 Change Management 

11.1 Change Log 

The change log lets you keep track of the changes made by a given user at a given 
time in a given project for a given reason. 

The fundamental concept behind this function is that, based on the user that is 
logged in (name and ID) and based on the actions that this user carries out at 
given time, the who, what and when pertaining to a change are automatically 
monitored and recorded. This change log functionality is intended to meet the 
requirements of the US Food and Drug Administration (FDA) and similar 
government agencies that issue permits to operate plants. 

 

 Note 

You require an authorization for at least 128 TAGs in order to use the 
"Change Log" function. 

  

There are device-specific change logs and a general, project-neutral 
"SIMATIC PDM" log that is not connected with any project. 

You have the option of entering comments for some of the automatically logged 
actions. All automatically created fields are written in the default language. 

The change log can archived in different time intervals (every year, month, week, 
day, etc.). In addition, you have the option of exporting change logs and using or 
analyzing them in other MS-Office applications. 

"Project Path" Button 

The storage location for the project is shown here. 

Archive 

Click one of the buttons to make settings governing the archiving process. 

"Automatic" and "Manual" Buttons 

Click this button to make settings for automatic or manual archiving.  

Filter 

The filter setting are shown here. To change these settings, click on the "Settings" 
button. 
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"Settings" Button 

Click this button to make filter settings.  

The following information is logged: 

  

 Description 

Object ID Information on the ID of the changed object 

Date/Time Date and time of the change 

Action Information on the type of change 

Comments Comments entered by user 

Details Detailed information the action 

User Name of the user who made the change 

Computer Name of computer used to make the change 

Path Name of the folder in which the change log 
is stored. 

Import Date Date of import 

 

You can change the order of the columns in the table by selecting them and, while 
keeping the mouse button depressed, moving them to another location (drag-and-
drop). The new settings will be saved on your PC. 

11.2 Working With The Change Log 

If you have an authorization for at least 128 TAGs, all changes to the project are 
automatically stored in a log, which you can call up and view in the SIMATIC 
Manager and in SIMATIC PDM.  

The settings selected are retained. 

11.3 "Automatic Archiving" Dialog Box 

In this dialog box you can specify the interval in which you want to carry out long-
term archiving. To so this, select the appropriate checkbox. 

In the "Path for archive data" field you can specify the storage location for the 
archive file. 

Confirm your selections with "OK". 

11.4 Manual Archiving 

In this dialog box you can enter the date and time-of-day that the archiving should 
be completed by. 

In the "Path for archive file" field you can specify the storage location for the 
archive file. 

Click the "Archive" button to archive all entries before the data and time-of-day 
specified. 
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11.5 "Filter" Settings Dialog Box 

In this dialog box you can specify which changes you would like to have displayed. 

Use 

Select this option to display the information for a user. To do this, enter the name of 
the user in the field. 

Action 

Select this option to display the information for a specific action. To do this, select 
the action from the drop-down list. 

Object ID 

Select this option to display the information for a specific object ID. To do this, 
enter the name of the ID in the field. 

No Filter 

Select this option if you do not want to use a filter. 

 

Confirm your entries with "OK". 
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12 SIMATIC PDM LifeList 

12.1 Introduction 

With this program you can scan DP and PA chains and determine what HART 
devices are connected to a HART modem (multi-drop mode). You can specify 
whether the scan process is run once or in cycles and whether subnets should also 
be scanned. You can change the addresses and TAGs for devices directly in the 
SIMATIC PDM LifeList, and you can apply these changes to existing projects. 

SIMATIC PDM LifeList supports XML export of LifeList data. The XML file imported 
into existing projects are used to create or compare device and network data. 

You can save the data generated in the SIMATIC PDM LifeList, and if necessary, 
print them out. 

Starting SIMATIC PDM LifeList 

Regardless of the project, you can open SIMATIC PDM LifeList by means of the 
Windows Start button (Start > Simatic > SIMATIC PDM > LifeList) or in the 
SIMATIC Manager by selecting the desired object, right-clicking, and then selecting 
the context menu SIMATIC PDM > Start LifeList.  

 

12.2 Starting SIMATIC PDM 

To start SIMATIC PDM from LifeList, you have the following options: 

• Double-click an object 

• Select the object desired and then select the menu command Device > Open 
object... 

In either case, a dialog box is displayed in which you can make the settings 
required to import data. The dialog box is updated during the import. As long as the 
import continues, the title bar will display the status "In process". After the import is 
complete, it will display the status "Result". After closing the dialog box, select your 
access authorization ("Maintenance engineer" or "Specialist") in the dialog box that 
then appears. After this, the SIMATIC PDM use interface will open. 
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12.3 User Interface 

The "SIMATIC PDM LifeList" main window contains the following elements: 

• Title bar 
Shows the file name and the project name 

• Menu bar 
Contains the menu commands 

• Toolbar  
Contains the buttons for quick access to commonly used menu commands. 

• Hierarchical node list 
Contains the current scan result (appears as soon as scanning starts) 

• Status bar (with progress indicator) 
Contains information on the scanning process currently underway 

As soon as scanning starts, the node list is constructed as a tree hierarchy. 

The node that has been newly determined is highlighted during the scanning 
process. 

The first column contains the nodes arranged according to their network hierarchy. 
The other columns specific information about the nodes. This information will 
depend on the type of communication concerned: For PROFIBUS PA profile 
devices, the "Information" column contains the block structure. For HART devices, 
the this column contains the long address. 

 

 Notes 
• In order to determine the complete device status you have to activate the "With 

diagnostics" option in the "Options" dialog box (menu command Scan > Options). 

• For devices that are not integrated in SIMATIC PDM, "Device type: ID = ????" is 
displayed. The device cannot be identified and no diagnostic information can be 
determined. All "Device" and context menu functions are disabled. To integrate the 
device in SIMATIC PDM, please contact the manufacturer of this device.  

• When determining the device status of a device, it is possible that the diagnostic 
information is not determined completely. In this case, please contact the manufacturer 
of this device to integrate the device completely in SIMATIC PDM.  

 

After you select node, you can right-click to obtain a context menu pertaining to it. 
After you have selected a node, you can now copy the contents of the cell in which 
the cursor is located onto the clipboard (Copy menu command) and, from there, 
paste them into another program in which you can process this information further. 

12.4 Exporting LifeList Data To An Existing Project 

In SIMATIC PDM LifeList, you can scan the connected devices and export these 
data to an existing project. If these devices have not yet been assigned a name or 
an address, you can use the dialog box that is displayed to specify whether the 
comparative import should be conducted for an existing object or whether a new 
object should be created. 
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12.5 "SIMATIC PDM LifeList" Dialog Box 

In this dialog box you make the basic settings for SIMATIC PDM LifeList. You can 
change this settings later by selection the menu command Scan > Options. 

Communication 

• PROFIBUS / HART Modem 
This setting determines the type of communication for the scan procedure. 

• Address (setting range: 0 ... 126, for PROFIBUS only) 
This setting determines the address range at the highest scan level 
(PROFIBUS DP). Here you can make restrictions, such as to limit the address 
range to scanning a DP/PA link. In this way, you can speed up the scanning 
process. 

• COM port (COM1 ... COM8, for HART modem only) 
This setting determines the COM port to which the HART modem is connected. 

Scanning 

• Scan immediately after Start 
If you select this option, the scanning process will be automatically started after 
having started SIMATIC PDM LifeList. 

• Scan cyclically 
If you select this option, the scanning process will be automatically continued 
after the first run. Each new run will update the results of the previous one; that 
is, newly detected nodes will be inserted and no longer existing ones will be 
removed from the scanning result. 
If this option is not selected, the scanning process will be automatically ended 
after the first run is completed. 

• With Diagnostics 
If you select this option, additional diagnostic information is added to the scan 
result. 

• Scan subnets 
If you select this option, subordinate networks will be included in the scanning 
process. 
(such as PA devices behind the DP/PA link). 
If this option is not selected, only the nodes at the primary level will be 
determined. 

Display dialog during startup 

This option is selected by default. The start dialog appears each time the program 
is started and contains no context information (project context or call parameters). 
If you clear this option, the settings from the last session will be automatically 
applied again. 
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12.6 "Options" Dialog Box 

In this dialog box you make the basic settings for SIMATIC PDM LifeList.  

Communication 

• PROFIBUS / HART Modem 
This setting determines the type of communication for the scan procedure. 

• Address (setting range: 0 ... 126, for PROFIBUS only) 
This setting determines the address range at the highest scan level 
(PROFIBUS DP). Here you can make restrictions, such as to limit the address 
range to scanning a DP/PA link. In this way, you can speed up the scanning 
process. 

• COM port (COM1 ... COM8, for HART modem only) 
This setting determines the COM port to which the HART modem is connected. 

Scanning 

• Scan immediately after Start 
If you select this option, the scanning process will be automatically started after 
having started SIMATIC PDM LifeList. 

• Scan cyclically 
If you select this option, the scanning process will be automatically continued 
after the first run. Each new run will update the results of the previous one; that 
is, newly detected nodes will be inserted and no longer existing ones will be 
removed from the scanning result. 
If this option is not selected, the scanning process will be automatically ended 
after the first run is completed. 

• With Diagnostics 
If you select this option, additional diagnostic information is added to the scan 
result. 

• Scan subnets 
If you select this option, subordinate networks will be included in the scanning 
process. 
(such as PA devices behind the DP/PA link). 
If this option is not selected, only the nodes at the primary level will be 
determined. 

Display dialog during startup 

This option is selected by default. The start dialog appears each time the program 
is started and contains no context information (project context or call parameters). 
If you clear this option, the settings from the last session will be automatically 
applied again. 
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13 Integrating Devices 

13.1 "Managing the SIMATIC PDM Device Catalog" 
Dialog Box 

In this dialog box you can import or reassign devices. To select the individual 
devices or the device groups, click the fields next to the individual devices or the 
device groups (checkmark). New (not yet available) device types are displayed in 
bold type. 

If at least one device, but not all devices, within a group are selected (checkmark), 
this selection field will have a gray background. 

Source 

This section shows the folder in which the desired catalog or file is located. 

"Browse..." Button 

Click this button and navigate to the folder containing the catalog. 
 

 Note 

• If you want to import the whole catalog, navigate to the CD or the folder 
containing the device catalog. 

• If you want to import a single device, navigate to the folder containing the 
device (*.devices). 

• If you want to import a GSD file or a DDL file, navigate to the folder containing 
the file. 

 

"Sort..." Button 

Here you can select the criteria to be used to sort the devices to be imported. 

Import HCF Library 

Select this option to import the HCF library. If you have selected at least one HART 
device, the HCF library is automatically selected and cannot be deselected. 

"Select All" button 

Click this button to select all the devices in the catalog at once. 
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"Deselect All" 

Click this button to deselect all the devices in the catalog at once. 

Information on the device type 

This section shows selected properties of the selected device type. 

 

 Caution 

After you have executed the "Manage Device Catalog" function, you must close 
and reopen the SIMATIC Manager! 

 

13.2 Integrating Devices in SIMATIC PDM with HW Config 

If a DP slave is not displayed in the "Hardware Catalog" window, you will have to 
install the corresponding GSD file supplied by the manufacturer. 

To do this, select the Options > Install New GSD menu command. In the dialog 
box that is displayed, select the drive/folder containing the desired GSD file.  
Result: The DP slave is entered in the "Hardware Catalog" window (only in the 
"Standard" catalog profile!) under "PROFIBUS-DP \ Other field devices" and is now 
available for configuration.  

After you have select the desired device and placed it, select it and then right-click 
to display the context-sensitive menu command Object Properties. In the dialog 
box now displayed, select the check box "Configuration by Means of PDM" so that 
you can edit the device in SIMATIC PDM. 
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