Safety Guidelines

This manual contains notices intended to ensure personal safety, as well as to protect the products and connected equipment against damage. These notices are highlighted by the symbols shown below and graded according to severity by the following texts:

Danger
indicates that death, severe personal injury or substantial property damage will result if proper precautions are not taken.

Warning
indicates that death, severe personal injury or substantial property damage can result if proper precautions are not taken.

Caution
indicates that minor personal injury can result if proper precautions are not taken.

Caution
indicates that property damage can result if proper precautions are not taken.

Notice
draws your attention to particularly important information on the product, handling the product, or to a particular part of the documentation.

Qualified Personnel

Only qualified personnel should be allowed to install and work on this equipment. Qualified persons are defined as persons who are authorized to commission, to ground and to tag circuits, equipment, and systems in accordance with established safety practices and standards.

Correct Usage

Note the following:

Warning
This device and its components may only be used for the applications described in the catalog or the technical description, and only in connection with devices or components from other manufacturers which have been approved or recommended by Siemens.

This product can only function correctly and safely if it is transported, stored, set up, and installed correctly, and operated and maintained as recommended.

Trademarks

SIMATIC®, SIMATIC HMI® and SIMATIC NET® are registered trademarks of SIEMENS AG.

Third parties using for their own purposes any other names in this document which refer to trademarks might infringe upon the rights of the trademark owners.

Copyright © Siemens AG 2002 All rights reserved
The reproduction, transmission or use of this document or its contents is not permitted without express written authority. Offenders will be liable for damages. All rights, including rights created by patent grant or registration of a utility model or design, are reserved.

Disclaimer of Liability
We have checked the contents of this manual for agreement with the hardware and software described. Since deviations cannot be precluded entirely, we cannot guarantee full agreement. However, the data in this manual are reviewed regularly and any necessary corrections included in subsequent editions. Suggestions for improvement are welcomed.
Contents

1 Product Overview ........................................................................................................... 1-1
  1.1 Introduction........................................................................................................ 1-1
  1.2 Form of Delivery and Functionality of @PCS7 ................................................. 1-3
    1.2.1 Package 1: @PCS7 Web Read Access ........................................................... 1-3
    1.2.2 Package 2: @PCS7 Web Write Access (6ES7 658-0DX03-0YC0).................. 1-5
    1.2.3 Package 3: @PCS7 Full Client Access (6ES7 658-0EX03-0YC0)................... 1-6
    1.2.4 Package 4: @PCS7 Server To Server Communication
                   (6ES7 658-0FX03-0YC0) .................................................................................. 1-9
  1.3 Structure and Mode of Operation of the @PCS 7 Server Part ...................... 1-11
  1.4 Structure and Mode of Operation of the @PCS 7 Client Part......................... 1-13
  1.5 Installing @PCS 7 ........................................................................................... 1-14
  1.6 Starting @PCS 7 ............................................................................................. 1-15
  1.7 @PCS 7 Call Interface................................................................................... 1-16
  1.8 Removing @PCS 7 ......................................................................................... 1-16
  1.9 README ......................................................................................................... 1-16
  1.10 @aGlance ....................................................................................................... 1-17
    1.10.1 What Is @aGlance.......................................................................................... 1-17
    1.10.2 What Are @aGlance Client and Server .......................................................... 1-17
    1.10.3 @aGlance Client and Server Applications...................................................... 1-18
    1.10.4 Installing @aGlance........................................................................................ 1-20
    1.10.5 Starting @aGlance Administration.................................................................. 1-20
    1.10.6 @aGlance Administration for @PCS 7........................................................... 1-20

2 @PCS 7 User Interface................................................................................................... 2-1
  2.1 Toolbar Icons..................................................................................................... 2-1
  2.2 Keyboard Operation .......................................................................................... 2-2
    2.2.1 Key Combinations for Moving the Cursor ......................................................... 2-2
    2.2.2 Key Combinations for Accessing Online Help .................................................. 2-3
    2.2.3 Key Combinations for Selecting Text.............................................................. 2-3
    2.2.4 Key Combinations for Menu Commands ........................................................ 2-4
  2.3 File Menu........................................................................................................... 2-5
    2.3.1 Save .................................................................................................................. 2-5
    2.3.2 Exit .................................................................................................................... 2-5
  2.4 Edit Menu .......................................................................................................... 2-7
  2.5 View Menu......................................................................................................... 2-9
    2.5.1 View Toolbar ................................................................................................... 2-9
    2.5.2 View Status Bar................................................................................................. 2-9
  2.6 Section Menu .................................................................................................... 2-9
    2.6.1 Inserting a Section ............................................................................................ 2-9
    2.6.2 Removing a Section .......................................................................................... 2-10
  2.7 User Menu....................................................................................................... 2-10
    2.7.1 Log On User .................................................................................................... 2-10
    2.7.2 Log Off User ................................................................................................... 2-11
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.8 ? @PCS 7 Host ?</td>
<td>2-11</td>
</tr>
<tr>
<td>2.8.1 Contents</td>
<td>2-11</td>
</tr>
<tr>
<td>2.8.2 Context-Sensitive Help F1</td>
<td>2-11</td>
</tr>
<tr>
<td>2.8.3 Introduction</td>
<td>2-12</td>
</tr>
<tr>
<td>2.8.4 Getting Started</td>
<td>2-12</td>
</tr>
<tr>
<td>2.8.5 About</td>
<td>2-12</td>
</tr>
<tr>
<td>2.8.6 Using Help</td>
<td>2-12</td>
</tr>
<tr>
<td>2.9 Miscellaneous Commands</td>
<td>2-13</td>
</tr>
<tr>
<td>2.9.1 Cut</td>
<td>2-13</td>
</tr>
<tr>
<td>2.9.2 Copy</td>
<td>2-13</td>
</tr>
<tr>
<td>2.9.3 Paste</td>
<td>2-14</td>
</tr>
<tr>
<td>2.10 Application Window</td>
<td>2-15</td>
</tr>
<tr>
<td>2.10.1 Log On</td>
<td>2-15</td>
</tr>
<tr>
<td>2.10.2 Log Off</td>
<td>2-15</td>
</tr>
<tr>
<td>2.10.3 Save</td>
<td>2-16</td>
</tr>
<tr>
<td>2.10.4 Inserting an Object</td>
<td>2-17</td>
</tr>
<tr>
<td>2.10.5 About @PCS 7</td>
<td>2-18</td>
</tr>
<tr>
<td>3 Getting Started</td>
<td>3-1</td>
</tr>
<tr>
<td>3.1 Getting Started</td>
<td>3-1</td>
</tr>
<tr>
<td>4 @PCS7 System</td>
<td>4-1</td>
</tr>
<tr>
<td>4.1.1 @PCS 7 System Functionality</td>
<td>4-1</td>
</tr>
<tr>
<td>4.2 Edit Menu</td>
<td>4-2</td>
</tr>
<tr>
<td>4.2.1 Restarting the @PCS 7 System</td>
<td>4-2</td>
</tr>
<tr>
<td>4.2.2 Stopping the @PCS 7 System</td>
<td>4-3</td>
</tr>
<tr>
<td>4.2.3 License of the @PCS 7 Server</td>
<td>4-3</td>
</tr>
<tr>
<td>4.2.4 System Settings</td>
<td>4-4</td>
</tr>
<tr>
<td>4.2.4.1 The Following System Parameters Can Be Set with This Screen</td>
<td>4-4</td>
</tr>
<tr>
<td>4.3 User Interface</td>
<td>4-7</td>
</tr>
<tr>
<td>4.3.1 Language</td>
<td>4-7</td>
</tr>
<tr>
<td>4.3.2 System Trace</td>
<td>4-7</td>
</tr>
<tr>
<td>5 @PCS 7 Configuration</td>
<td>5-1</td>
</tr>
<tr>
<td>5.1 @PCS 7 Configuration Functionality</td>
<td>5-1</td>
</tr>
<tr>
<td>5.2 Configuring the Server</td>
<td>5-2</td>
</tr>
<tr>
<td>5.3 Assigning the Redundant Computer</td>
<td>5-3</td>
</tr>
<tr>
<td>5.4 Specifying the Preferred Server</td>
<td>5-3</td>
</tr>
<tr>
<td>5.4.1 Proceed as follows to specify the preferred server</td>
<td>5-3</td>
</tr>
<tr>
<td>5.5 Specifying Data Access to the Server</td>
<td>5-4</td>
</tr>
<tr>
<td>5.6 Specifying a Message Sink</td>
<td>5-4</td>
</tr>
<tr>
<td>5.7 Edit Menu</td>
<td>5-5</td>
</tr>
<tr>
<td>5.7.1 Inserting a Server</td>
<td>5-5</td>
</tr>
<tr>
<td>5.7.2 Deleting a Server</td>
<td>5-5</td>
</tr>
<tr>
<td>5.7.3 Preferred Server</td>
<td>5-6</td>
</tr>
<tr>
<td>5.8 User Interface</td>
<td>5-7</td>
</tr>
<tr>
<td>5.8.1 Insert Server Dialog Box</td>
<td>5-7</td>
</tr>
<tr>
<td>5.8.2 Redundancy</td>
<td>5-7</td>
</tr>
<tr>
<td>5.8.3 Server Configuration</td>
<td>5-7</td>
</tr>
</tbody>
</table>
1 Product Overview

1.1 Introduction

@PCS 7 - The Interface of PCS 7 to the Plant Operations Level and More

As @aGlance client and/or server, @PCS 7 provides the interface to @aGlance/IT of Intuitive Technologies. @aGlance/IT is client-server technology, independent of operating systems, for the process industry. In addition to interfaces to the plant operations level, this technology also provides high-performance interfaces to office integration (Excel, Word, Lotus 1-2-3,...) and, with Web@aGlance, PCS 7 also has Intranet/Internet capability.

So each client application that has @aGlance capability, such as table calculation, man-machine interface, or manufacturing execution system, can access the data of PCS 7.

@PCS 7 has access to the following PCS 7 applications:
- WinCC archives (message, measured value, and user archives)
- WinCC data management
The Windows NT 32-bit operating system is the basis for @PCS 7. Windows NT is equipped with preemptive multitasking, which to a great degree guarantees rapid reaction to process events and security against loss of data. Windows NT also offers safety-related functions. The @PCS 7 software itself is a 32-bit application that was developed with the most modern, object-oriented software technology.

If you start @PCS 7 by using the Start menu of Windows NT, the @PCS 7 system interface opens. This interface provides access to the @PCS 7 system and the various editors in which the different tasks for communication with the plant operations level can be handled.

**The @PCS 7 System**

With the @PCS 7 system, you can stop your system or restart it. In addition, system messages of the @PCS 7 environment are displayed here.

@PCS 7 System Functionality

**The Editors of @PCS 7**

The editors are displayed only if the appropriate rights and licenses are in place.

@PCS 7 Configuration

You can use the @PCS 7 Configuration to set up and configure the servers required for accessing the data of WinCC.

@PCS 7 Configuration Functionality

@PCS 7 User Administration

You can use the @PCS 7 User Administration to create groups and users and to assign and change their rights and authorizations.

@PCS 7 User Administration Functionality

@PCS 7 Server-Server Configuration

You can use the @PCS 7 Server-Server Configuration to specify the jobs for linking the @PCS 7 server to another @aGlance server (@aGlance Client Functionality, authorization level 3).

@PCS 7 Server-Server Configuration Functionality
1.2 Form of Delivery and Functionality of @PCS7

@PCS7 forms part of the PCS7 Toolset. @PCS7 is available in four different packages:

<table>
<thead>
<tr>
<th>Package</th>
<th>Order No.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Package 1: @PCS7 Web Read Access</td>
<td>None*</td>
</tr>
<tr>
<td>Package 2: @PCS7 Web Write Access</td>
<td>6ES7 658-0DX03-0YC0</td>
</tr>
<tr>
<td>Package 3: @PCS7 Full Client Access</td>
<td>6ES7 658-0EX03-0YC0</td>
</tr>
<tr>
<td>Package 4: @PCS7 Server To Server Communication</td>
<td>6ES7 658-0FX03-0YC0</td>
</tr>
</tbody>
</table>

* You do not require any additional authorization for the basic functionality (Package 1). However, WinCC must be installed with the control system option Basic Process Control and its authorization.

You require a corresponding authorization for the Packages 2 to 4. A higher authorization level of @PCS7 always includes the functionality of the lower authorization levels (Package 4 therefore includes the functionality of Packages 1, 2 and 3). The installation examples below explain the points to be observed during installation and the selection of the installation site of @PCS7.

1.2.1 Package 1: @PCS7 Web Read Access

Properties

- @PCS7 without own authorization (Authorization Level 0)
- Reading access via Internet/Intranet with Web@aGlance
- Web@aGlance is not a part of @PCS7 and has to be ordered separately!

Example Configuration

Installation Instructions

- The @PCS7 Server can be installed on every computer (Client 1, Client 2, Client 3, Engineering Station, Server) in this configuration.
- In addition to the @PCS7 authorization there also has to be a BPC license on the computer on which the @PCS7 Server runs.
- If the @PCS7 is not executed on the "Server" computer, @PCS7 nevertheless has to be installed on this computer (only installed, no further activities and no authorization). If desired, everything can be installed on the "Server" computer.
- An @aGlance Client has to be used in order to be able to access @PCS7 Server. The above authorization of the @PCS7 Server is used to read access the @PCS7 Server with the Web@Glance Client.
- @PCS7 can access several servers or redundant server pairs simultaneously.

Further Required Software

Web@aGlance™ is a product of eMation Software (www.emation.com). From the point of view of the @PCS7 Server it represents a client which can access the @PCS7 Server via the Intranet or Internet.

For further information an @aGlance products: Please refer to http://www.ad.siemens.de/sw-haus.

BPC-License: 6ES7 652-0XX01-2YA0
1.2.2 Package 2: @PCS7 Web Write Access (6ES7 658-0DX03-0YC0)

Properties

- @PCS7 with an own authorization (Authorization Level 1)
- Reading and writing access via Internet/Intranet with Web@aGlance
- Web@aGlance is not a part of @PCS7 and has to be ordered separately!

Possible Configuration

![Diagram showing possible configuration]

Installation Instructions

- The @PCS7 Server can be installed on every computer (Client 1, Client 2, Client 3, Engineering Station, Server) in this configuration.
- In addition to the @PCS7 authorization there also has to be a BPC license on the computer on which the @PCS7 Server runs.
- If the @PCS7 is not executed on the “Server” computer, @PCS7 nevertheless has to be installed on this computer (only installed, no further activities and no authorization). If desired, everything can be installed on the “Server” computer.
- An @aGlance Client has to be used in order to be able to access @PCS7 Server. The above authorization of the @PCS7 Server is used to read and write access the @PCS7 Server with the Web@Glance Client.
Further Required Software

Web@aGlance™ is a product of eMation Software (www.emation.com). From the point of view of the @PCS7 Server it represents a client which can access the @PCS7 Server via the Intranet or Internet.

For further information an @aGlance products: Please refer to http://www.ad.siemens.de/sw-haus.

BPC-License: 6ES7652-0XX01-2YA0

1.2.3 Package 3: @PCS7 Full Client Access (6ES7 658-0EX03-0YC0)

Properties

- @PCS7 with an own authorization (Authorization Level 2)
- Reading and writing accrues for all @aGlance clients

Example Configuration 1
Example Configuration 2 (is also valid for Authorization Levels 1 and 2)

Information on Redundant Mode

Notes:
In contrast to non-redundant WinCC Servers, the @PCS7 Server may not run on both redundant computers (Server 1 and Server 1 redundant) in case of redundant WinCC Server. It has to be installed on every Server, but may not be executed there.
There are various possibilities of structuring @PCS7 redundantly. One solution to install and start the @PCS7 Server on both Client 1 and Client 2. The @aGlance Configurator is then used to enter both computers on which @PCS7 Server runs:

**Redundancy Changeover**

In the above simple solution the @aGlance Client through which @PCS7 is accessed, accesses the @PCS7 which is running on Client 1. If Client 1 cannot be accessed, @aGlance automatically accesses the @PCS7 Server which is running on Client 2.

WinCC internal variables, for example "@RM_MASTER_NAME" can be used so that the @aGlance Client also carries out sign-of-life monitoring automatically and when necessary carries out a changeover by itself.
1.2.4 Package 4: @PCS7 Server To Server Communication
(6ES7 658-0FX03-0YC0)

Properties

• @PCS7 with an own authorization (Authorization Level 3)
• Server-Server communication via the @PCS7 Client functionality
• Communication of your @PCS7 Server with other @aGlance Servers

For this operating mode the @PCS7 Server changes over to Client functionality. You can then configure jobs in @PCS7 which write data to a second @aGlance Server or read them from it.

Example Configuration

![Example Configuration Diagram]

Installation Instructions

• The @PCS7 Server can be installed on every computer (Client 1, Client 2, Client 3, Engineering Station, Server) in this configuration.
• In addition to the @PCS7 authorization there also has to be a BPC license on the computer on which the @PCS7 Server runs.
• If the @PCS7 is not executed on the "Server" computer, @PCS7 nevertheless has to be installed on this computer (only installed, no further activities and no authorization). If desired, everything can be installed on the "Server" computer.
• If IP.21 has an @aGlance Server interface, it can be used to establish a server-server connection via @PCS7. The jobs (reading and writing) are configured and started in @PCS7.
Information on the Function

In this operating mode the @PCS7 Server is an @aGlance Client and accesses an @aGlance Server (IP.21). However, only runtime variables can be addressed. It is not possible to access archives and interrupts in this mode.

Even if @PCS7 implements a server-server coupling, further @aGlance Clients can additionally access @PCS7 in order to read further data from the control system.

Further information can be found in the online help under Configuring Server-Server Communication or in the user documentation.
1.3 Structure and Mode of Operation of the @PCS 7 Server Part

Structure of the @PCS 7 Server Part

@PCS7 Server

- @aGlance - Bridge
  - @aGlance/IT Full-Function RunTime
  - PCS 7-Bridge
    - INSInfo2
    - Ivar2
    - IARCHIV
    - IALARM

Network Transport TCP/IP

Middleware ONC/RPC

Remote Procedure Call (RPC)

Remote Procedure Call (RPC)

Name Server

Port Mapper

COM / DCOM

OS Server 1

- IVar
- INSInfo
- WinCC-Server
  - DM-Variable

OS Server 2

PCS7 Project

IARCHIV

IAlarm

WinCC Archive

WinCC-Server

DM-Variable
Mode of Operation of the @PCS 7 Server Part

When a client application requests information from the @PCS 7 server, Client Runtime is activated. Client Runtime locates the system in which the server is running, connects the server, says which function (method) should be transacted, and provides the client with the results.

As a default, @aGlance uses the V3 Open Network Computing Remote Procedure Call (ONC/RPC) mechanism as platform-independent middleware above TCP/IP. The main functions of this middleware are:

- Automatic format conversion between different numeric representation formats (such as VAX floating point and IEEE floating point)
- Administration of network communication (such as communication errors or several logical communication channels over one physical channel)

The Full-Function RunTime of the server executes all necessary format conversions and calls up the appropriate functions of the @PCS 7 server. The @PCS 7 server selects the appropriate functions in the PCS 7 bridge, organizes the parameters of the client, and starts the functions.

The PCS 7 bridge executes the functions and brings the data and the control back to the Server Runtime. The data are now transferred from the server to Client Runtime. Client Runtime still executes the possible data conversions and transfers the data back to the client application.

In order to expedite frequently repeating data accesses, the PCS 7 bridge stores the tag and attribute addresses in a cache on the first data request. When there is a new data request, the addresses are looked for first in the cache.

The functions in the PCS 7 bridge use the INSInfo and IVar (COM/DCOM) interface from WinCC. You use the INSInfo interface for browsing the WinCC tag names. You use IVar to access the data (values) of the defined objects. You use IArchiv to access the WinCC measured values.
1.4 Structure and Mode of Operation of the @PCS 7 Client Part

Package 4 of @PCS 7 (Server-Server Communication) will include both the server and the client features. With the client functions, @PCS 7 can control data transmission independently, that is, @PCS 7 can activate data transmission both cyclically and in a manner that is dependent on the process. The following figure represents the main components of the client part.

Structure of the @PCS 7 Client Part
Mode of Operation of the @PCS 7 Client Part

Application-specific tag and attribute lists are configured for @PCS 7 in order to enable automatic control of data transmission.

The client part is implemented with the help of the Server-Server bridge /IT.

If the connection between @PCS 7 and the destination application fails, the message frames to be transmitted are stored intermediately. After the connection is set up again, the message frames are sent to the destination application automatically.

1.5 Installing @PCS 7

Installation is carried out by means of the frame setup of the PCS 7 Toolkit.

For additional important information, see the @PCS 7-README file.
1.6 Starting @PCS 7

You can start the @PCS 7 system by means of the Start menu **SIMATIC > @PCS7 > @PCS7 System.**

**Note:**

@PCS 7 can be started automatically with a user name and a password.

**Example:** @PCS 7 link with standard user “Administrator”

1. Create a new link on the windows desktop
2. Enter following information for the target properties in the Link tab (**right mouse click** > **Properties** > **Link**):

   **Target:** C:\Siemens\@PCS 7\Bin\aPCS 7Host.exe /user Administrator /pwd Password

   Recommendation: establish a user without configuration rights in the @PCS 7 user interface. You can do without the password.

   If you want to start @PCS 7 automatically, you can put the link in your Autostart folder.
1.7  @PCS 7 Call Interface

The @PCS 7 call interface describes the Visual Basic access to the @PCS 7 data by means of examples.

In addition the standard interface description of @aGlance is included here.

The call interfaces of @PCS 7 or @aGlance are opened as follows:

• Double-click on the Adobe Acrobat document @PCS 7_API.pdf or AAG_API.pdf in the \@PCS 7\Bin\ directory or

• From the start menu of Windows NT if the PCS 7 system is installed:

• Start > SIMATIC > Documentation > English > @PCS7_API.pdf or AAG_API.pdf

• Or from the start menu of Windows NT without a PCS 7 system:

• Start > SIMATIC > @PCS7 > Call interface @PCS 7 or Call Interface @aGlance

1.8 Removing @PCS 7

The @PCS 7 System can only be removed via Start menu Start > Settings > Control Panel > Add/Remove.

1.9 README

Note

Please note the constantly updated information on installation, on operation, and on the functions of @PCS 7 in the @PCS 7-README file.

The @PCS 7-README file can contain information that was changed after the online Help was completed.

How to open the @PCS 7-README file:

• Double-click on @PCS 7-README on the CD-ROM @PCS 7 or

• Automatically when prompted prompt immediately after the complete installation of @PCS 7 or

• From the start menu of Windows NT if the PCS 7 system is installed:

   Start > SIMATIC > Product Information > German > @PCS7 README

• From the Start menu of Windows NT without a PCS 7 system:

   Start > SIMATIC > @PCS7 README
1.10  @aGlance

1.10.1  What Is @aGlance

@aGlance/IT is a product of eMation and enables the linking of computer systems of the process level (here: PCS 7) to computer systems of the plant operations and corporate management levels.

In this way, real-time process data can be read, analyzed, edited, and replaced independent of the particular server operating system.

In addition, the special Web@aGlance/IT client enables access by means of Intranet and Internet.

@PCS 7 is the @aGlance/IT server and/or client for the SIMATIC PCS 7 process control system.

@aGlance/IT Runtime is a basic requirement for the @PCS 7 function.

For more information, check the Internet under http://www.aglance.com.

1.10.2  What Are @aGlance Client and Server

The @aGlance software consists of the components client and server.

The client requests the data that are provided by the server. For example, a client (such as @aGlance add-in for Excel) can select the process data and import (read) them for later analysis and editing; the server (such as @PCS 7) compresses the requested information and sends the data to the client.

The @aGlance clients and servers can run on different hardware and software platforms over distributed networks.

A client can access the data of several servers simultaneously and a server can serve several clients simultaneously.

An additional client is always needed to enable communication between servers.
1.10.3  @aGlance Client and Server Applications

With @PCS 7, PCS 7 can communicate with the products that are listed in tables 1 and 2. Table 1 shows strictly client applications and Table 2 shows the server applications (often, a server is also a client: for example, a data collector is a client function, and the collected data are provided to other clients).

Table 1: @aGlance/IT Clients - Status 10/2000

You can find the original table in the Internet under: http://www.aglance.com/clients.html

<table>
<thead>
<tr>
<th>Manufacturer</th>
<th>Product</th>
<th>Operating System</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>PC Spreadsheets</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>eMation</td>
<td>Add-in for Microsoft Excel</td>
<td>Windows</td>
</tr>
<tr>
<td><strong>UNIX/VMS Spreadsheets</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Applied Information Systems</td>
<td>XESS</td>
<td>OpenVMS, UNIX</td>
</tr>
<tr>
<td><strong>Application Development Tools</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>eMation</td>
<td>C/C++, VB, OLE, DDE</td>
<td>Windows, UNIX, VMS</td>
</tr>
<tr>
<td>EnvisionIt Software</td>
<td>Visual Flow for SAP</td>
<td>OpenVMS, UNIX</td>
</tr>
<tr>
<td><strong>Process Data Analysis Tools</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Gensym</td>
<td>G2</td>
<td>OpenVMS, UNIX</td>
</tr>
<tr>
<td>Simulation Sciences</td>
<td>AIMstation, AIMview Romeo</td>
<td>OpenVMS, Windows</td>
</tr>
<tr>
<td><strong>Lab Information Management</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Computing Solutions, Inc.</td>
<td>LabSoft</td>
<td>NT</td>
</tr>
<tr>
<td><strong>Process Information and SCADA Systems</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ABB</td>
<td>Advant IMS, Mod300</td>
<td>UNIX, NT</td>
</tr>
<tr>
<td>Aspen Technology</td>
<td>InfoPlus.21, InfoPlus-X, CIM/21</td>
<td>OpenVMS</td>
</tr>
<tr>
<td>Ci Technologies</td>
<td>Citect</td>
<td>NT</td>
</tr>
<tr>
<td>Foxboro</td>
<td>Foxboro Data Historian</td>
<td>Solaris, NT</td>
</tr>
<tr>
<td>Honeywell</td>
<td>PHD Historian</td>
<td>NT</td>
</tr>
<tr>
<td>Intellution</td>
<td>FIX 32 and Dynamics</td>
<td>NT</td>
</tr>
<tr>
<td>OSI Software</td>
<td>PI Data Server</td>
<td>NT, OpenVMS</td>
</tr>
<tr>
<td>Simulation Sciences</td>
<td>AIM Supervisor</td>
<td>OpenVMS</td>
</tr>
</tbody>
</table>
## Product Overview

### @PCS7 V6.0 Interface to the Plant Operations Level

### Web Visualization

<table>
<thead>
<tr>
<th>Manufacturer</th>
<th>Product</th>
<th>Operating System</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Web@aGlance</td>
<td>Any Java-capable web browser</td>
</tr>
</tbody>
</table>

### Manufacturing Systems

<table>
<thead>
<tr>
<th>Manufacturer</th>
<th>Product</th>
<th>Operating System</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base Ten Systems, Inc.</td>
<td>PHARMASYST</td>
<td>NT</td>
</tr>
<tr>
<td></td>
<td>Flowstream</td>
<td>OpenVMS, HPUX, NT</td>
</tr>
</tbody>
</table>

### Table 2: @aGlance/IT Servers - Status 01/2000

You can find the original table in the Internet under:

<table>
<thead>
<tr>
<th>Manufacturer</th>
<th>Product</th>
<th>Operating System</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABB</td>
<td>Advant IMS, Mod300</td>
<td>NT, HPUX</td>
</tr>
<tr>
<td>ABB (Elsag Bailey)</td>
<td>INFI 90 Open, DCI System Six, Conductor, Maestro</td>
<td>NT, Various, SGI IRIX</td>
</tr>
<tr>
<td>Aspen - Setpoint</td>
<td>InfoPlus.21, CIM/21 SETCIM, InfoPLUS-X, Infoplus, SETCON</td>
<td>NT, UNIX, OpenVMS</td>
</tr>
<tr>
<td>Bradley Ward Systems</td>
<td>PMIS, PMIS++</td>
<td>HPUX</td>
</tr>
<tr>
<td>Control Systems International</td>
<td>VXL</td>
<td>OpenVMS</td>
</tr>
<tr>
<td>Crisp Automation</td>
<td>CRISP32</td>
<td>OpenVMS</td>
</tr>
<tr>
<td>Compaq</td>
<td>BASEstar Classic</td>
<td>OpenVMS</td>
</tr>
<tr>
<td>Fisher Rosemount</td>
<td>PROVOX, Delta-V</td>
<td>OpenVMS, NT</td>
</tr>
<tr>
<td>GE Fanuc</td>
<td>CIMPLICITY</td>
<td>NT</td>
</tr>
<tr>
<td>Gensym</td>
<td>G2</td>
<td>OpenVMS</td>
</tr>
<tr>
<td>GSE Systems, formerly TI</td>
<td>D/3, S/3</td>
<td>OpenVMS</td>
</tr>
<tr>
<td>Honeywell IAC</td>
<td>SCAN 3000</td>
<td>HPUX</td>
</tr>
<tr>
<td>Intellution</td>
<td>FIX/32, FIX Dynamics</td>
<td>NT</td>
</tr>
<tr>
<td>OPC Servers</td>
<td>Many – see OPC Foundation</td>
<td>NT, 95/98</td>
</tr>
<tr>
<td>OSI Software</td>
<td>PI</td>
<td>NT, OpenVMS</td>
</tr>
<tr>
<td>Siemens Industrial Automation</td>
<td>SIMATIC PCS 7, PCS</td>
<td>NT, SCO UNIX</td>
</tr>
<tr>
<td>Simulation Sciences, Inc.</td>
<td>AIM/AT, AIM</td>
<td>NT, OpenVMS</td>
</tr>
<tr>
<td>Think&amp;Do</td>
<td>Think&amp;Do- OPC Server</td>
<td>NT, Windows CE</td>
</tr>
<tr>
<td>WonderWare</td>
<td>InTouch, InSQL</td>
<td>NT</td>
</tr>
<tr>
<td>Yokogawa Electric Corporation</td>
<td>CENTUM CS</td>
<td>HPUX</td>
</tr>
</tbody>
</table>

and more...
1.10.4 Installing @aGlance

See @aGlance/IT Systems Manual (not part of the @PCS 7 documentation).

1.10.5 Starting @aGlance Administration

You can start the @aGlance/IT Administration Tool by using the Start menu Programs > @aGlance > Administration.

1.10.6 @aGlance Administration for @PCS 7

How to Prepare @aGlance/IT for Using @PCS 7:

**Note:** If you are working on the local host only, the default entry of "localhost" that already exists is sufficient. Then you do not need to carry out the following steps.

1. Enter as server host the network name of the computer on which @PCS 7 is running.
2. Use Add to enter your server into the server list.

![Screen capture of @aGlance/IT Administration Tool](image-url)
3. Use List Servers to check the server name that you entered.
   If the following message appears, the server name is not correct:

   ![Server Name Error Message]

   Check the server name and test it again with List Servers.
   If the entry is correct, the following window appears:

   ![Server Sessions Window]

   Close it with OK.
   If you have already started the @PCS 7 system, the window could look like the one which follows:
Close it with OK.

4. Use OK to save your entries and close the @aGlance/IT Administration Tool.
2  @PCS 7 User Interface

2.1  Toolbar Icons

- Exit
- Save
- Cut
- Copy
- Paste
- Insert Section
- Remove Section
- Log On User
- Log Off User
- About
- Context-Sensitive Help F1
2.2 Keyboard Operation

2.2.1 Key Combinations for Moving the Cursor

Moving the Cursor in the Menu Bar/ in the Pop-Up Menu

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>For the menu bar</td>
<td>F10</td>
</tr>
<tr>
<td>For the pop-up menu</td>
<td>SHIFT+F10</td>
</tr>
<tr>
<td>For the menu that contains the underlined letter X</td>
<td>ALT+X</td>
</tr>
<tr>
<td>Assigned menu command</td>
<td>Underlined letter in the menu command</td>
</tr>
<tr>
<td>One menu command to the left</td>
<td>LEFT ARROW</td>
</tr>
<tr>
<td>One menu command to the right</td>
<td>RIGHT ARROW</td>
</tr>
<tr>
<td>One menu command up</td>
<td>UP ARROW</td>
</tr>
<tr>
<td>One menu command down</td>
<td>DOWN ARROW</td>
</tr>
<tr>
<td>Activates the selected menu command</td>
<td>ENTER</td>
</tr>
<tr>
<td>Exits the menu or goes back to the text</td>
<td>ESC</td>
</tr>
</tbody>
</table>

Moving the Cursor while Editing Texts

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>One line up or one character to the left in a text that consists of one line only</td>
<td>UP ARROW</td>
</tr>
<tr>
<td>One line down or one character to the right in a text that consists of one line only</td>
<td>DOWN ARROW</td>
</tr>
<tr>
<td>One character to the right</td>
<td>RIGHT ARROW</td>
</tr>
<tr>
<td>One character to the left</td>
<td>LEFT ARROW</td>
</tr>
<tr>
<td>One word to the right</td>
<td>CTRL+RIGHT ARROW</td>
</tr>
<tr>
<td>One word to the left</td>
<td>CTRL+LEFT ARROW</td>
</tr>
<tr>
<td>To the beginning of the line</td>
<td>HOME</td>
</tr>
<tr>
<td>To the end of the line</td>
<td>END</td>
</tr>
<tr>
<td>One screen up</td>
<td>PAGE UP</td>
</tr>
<tr>
<td>One screen down</td>
<td>PAGE DOWN</td>
</tr>
<tr>
<td>To the beginning of the text</td>
<td>CTRL+HOME</td>
</tr>
<tr>
<td>To the end of the text</td>
<td>CTRL+END</td>
</tr>
</tbody>
</table>
Moving the Cursor in Dialog Boxes

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>To the next input field (from left to right and from top to bottom)</td>
<td>TAB</td>
</tr>
<tr>
<td>One input field back</td>
<td>SHIFT+TAB</td>
</tr>
<tr>
<td>To the input field that contains the underlined letter X</td>
<td>ALT+X</td>
</tr>
<tr>
<td>Selects in a selection list</td>
<td>Arrow keys</td>
</tr>
<tr>
<td>Opens a selection list</td>
<td>ALT+DOWN ARROW</td>
</tr>
<tr>
<td>Selects an object or undoes the selection</td>
<td>SPACEBAR</td>
</tr>
<tr>
<td>Confirms entries and closes the dialog box (&quot;OK&quot; button)</td>
<td>ENTER</td>
</tr>
<tr>
<td>Closes the dialog box without saving the selection (&quot;Cancel&quot; button)</td>
<td>ESC</td>
</tr>
</tbody>
</table>

2.2.2 Key Combinations for Accessing Online Help

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opens Help</td>
<td>F1</td>
</tr>
<tr>
<td>(If there is an actual context, such as a selected menu command, the corresponding help topic is called up; otherwise, the Help contents are called up.)</td>
<td></td>
</tr>
<tr>
<td>Activates the question mark icon for context-sensitive help</td>
<td>SHIFT+F1</td>
</tr>
<tr>
<td>Closes the Help window and goes back to the group window</td>
<td>ALT+F4</td>
</tr>
</tbody>
</table>

2.2.3 Key Combinations for Selecting Text

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>One character to the right</td>
<td>SHIFT+RIGHT ARROW</td>
</tr>
<tr>
<td>One character to the left</td>
<td>SHIFT+LEFT ARROW</td>
</tr>
<tr>
<td>To the beginning of the comment line</td>
<td>SHIFT+HOME</td>
</tr>
<tr>
<td>To the end of the comment line</td>
<td>SHIFT+END</td>
</tr>
<tr>
<td>One line up</td>
<td>SHIFT+UP ARROW</td>
</tr>
<tr>
<td>One line down</td>
<td>SHIFT+DOWN ARROW</td>
</tr>
<tr>
<td>One screen up</td>
<td>SHIFT+PAGE UP</td>
</tr>
<tr>
<td>One screen down</td>
<td>SHIFT+PAGE DOWN</td>
</tr>
<tr>
<td>To the beginning of the file</td>
<td>CTRL+SHIFT+HOME</td>
</tr>
<tr>
<td>To the end of the file</td>
<td>CTRL+SHIFT+END</td>
</tr>
</tbody>
</table>
2.2.4 Key Combinations for Menu Commands

You can trigger each menu command by entering the appropriate ALT-key combination.

Press the following keys one after the other:

- ALT key
- The letter that is underlined in the desired menu (for example, ALT, then F for the File menu - if the File menu is entered in the menu list). The menu opens.
- The letter that is underlined in the desired menu (for example, N for the menu command “New”). If a menu command is involved that has additional submenus, the submenus are opened afterwards. Proceed in a similar manner until you have selected the entire menu command by entering the letter in question.

When you have entered the last letter of the key combination, the menu command is executed.

Examples:

<table>
<thead>
<tr>
<th>Menu Commands</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Exit</td>
<td>ALT, F, X (Press and release ALT, then F, and then X)</td>
</tr>
<tr>
<td>File &gt; Save</td>
<td>ALT, F, S</td>
</tr>
</tbody>
</table>

Shortcuts for Menu Commands

<table>
<thead>
<tr>
<th>Function</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exit (“File” menu)</td>
<td>ALT+F4</td>
</tr>
<tr>
<td>Copy (“Edit” menu)</td>
<td>CTRL+C</td>
</tr>
<tr>
<td>Cut (“Edit” menu)</td>
<td>CTRL+X</td>
</tr>
<tr>
<td>Paste (“Edit” menu)</td>
<td>CTRL+V</td>
</tr>
<tr>
<td>Delete (“Edit” menu)</td>
<td>DEL</td>
</tr>
<tr>
<td>Context-Sensitive Help (“Help” menu)</td>
<td>F1</td>
</tr>
</tbody>
</table>

(If there is an actual context, such as a selected menu command, the corresponding help topic is called up; otherwise, the Help contents is called up.)
2.3 File Menu

2.3.1 Save

You can use the Save command in the File menu in the @PCS 7 interface to save the configuration data that you changed.

This menu command appears only if you changed data.

How to Save Your Changed Data:

1. From the File menu, click Save.

or

Click the icon in the standard toolbar.

2. In the Save dialog box, select the data to be saved.

Confirm with OK and the following note appears:

You must restart the @PCS 7 system to activate the altered configuration data.

You can restart the system with Restarting the @PCS 7 System.

2.3.2 Exit

You can use the Exit command in the File menu in the @PCS 7 interface to exit the program, to log off the user, or to log off the user and log on the user under a different name.

If there is no user logged in you can use the Exit command to exit the program after an additional safety prompt (the @PCS 7 system is exited, the user interface is closed).
How to Exit @PCS 7:

1. From the File menu, click Exit.
   or
2. Click the icon in the standard toolbar
   or
3. Click the icon in the Windows toolbar.

You use the Log Off window to make the selection.
If there is no user logged in, acknowledge the following inquiry with Yes.

If there are still unsaved data in the program, a prompt follows asking whether the data should be saved, and which data should be saved.

You can find more information about this dialog box with Save.
2.4 Edit Menu

In the Edit menu, the appropriate commands are displayed for the particular application that is selected (@PCS 7 System, @PCS 7 Configuration, @PCS 7 User Administration, or @PCS 7 Server-Server Configuration).

@PCS 7 System
- Restarting the @PCS 7 System
- Stopping the @PCS 7 System
- License of the @PCS 7 Server
- System Settings

@PCS 7 Configuration
- Inserting a Server
- Deleting a Server
- Preferred Server

@PCS 7 User Administration
- Inserting a Group
- Deleting a Group
- Inserting a User
- Deleting a User
- Rename
- Properties

@PCS 7 Server-Server Configuration
- Edit Server Menu
  - Inserting a New Server
  - Deleting a Server
  - Deleting All Servers
  - Renaming a Server
  - Starting a Server
  - Stopping a Server
  - Server Properties
**Edit Jobs Menu**
Inserting a Job
Deleting a Job
Deleting All Jobs
Renaming a Job
Importing a Job
Showing a Job
Starting a Job
Stopping a Job
Job Properties

**Edit Tags Menu**
Inserting Tag Pairs
Deleting a Tag Pair
Deleting All Tag Pairs
2.5  View Menu

2.5.1  View Toolbar

You can use the Toolbar command in the View menu to show or hide the Toolbar underneath the menu bar for the direct selection of the most important functions of the @PCS 7 user interface.

2.5.2  View Status Bar

You can use the Status Bar command in the View menu to show or hide the status bar with additional information at the lower end of the @PCS 7 user interface.

2.6  Section Menu

2.6.1  Inserting a Section

You can use the Insert command in the Section menu to include additional applications in the @PCS 7 user interface.

How to Insert a Section:

1. In the Section menu, click Insert.
   or
2. Click the icon in the standard toolbar.
   You select the application by means of the Insert Object window.
2.6.2 Removing a Section

You can use the Remove command in the Section menu to remove additional applications from the @PCS 7 user interface.

How to Remove a Section:
1. Select the application to be removed.
2. Use Save to save your changes.
3. In the Section menu, click Remove.
   or
4. Click the icon in the standard toolbar.

Result: The application is removed from the @PCS 7 user interface without further prompting.

2.7 User Menu

2.7.1 Log On User

You can use the Log On command in the User menu in the @PCS 7 interface to log on a user for the @PCS 7 system.

Only one user at a time can be logged in to the @PCS 7 system.

How to Log On a User:
1. In the User menu, click Log On
   or
2. Click the icon in the standard toolbar.

Result: If your login is accepted, the PCS 7 system is started automatically and you get access to the objects enabled in the User Administration.

You use the Log On window to log on.
2.7.2 Log Off User

You can use the Log Off command in the User menu in the @PCS 7 interface to exit the program, to log off the user, or to log off the user and log on the user under a different name.

How to Log Out a User:

1. In the User menu, click Log Off.
   or
2. Click the icon in the standard toolbar.
   You use the Log Off window to make the selection.

2.8 ? @PCS 7 Host ?

2.8.1 Contents

You can use the Contents command to access the online Help of @PCS 7.

How to Call Up the Online Help:

1. In the ? menu, click Contents.
   For additional procedures, see your Windows NT Help.

2.8.2 Context-Sensitive Help F1

You can use What's This? F1 to open the appropriate Help on a menu command, a button icon, or the dialog box elements.

How to Open the What's This Help:

1. In the ? menu, click Context-Sensitive Help F1
   or
2. Use the mouse to select the context and press the F1 key.
   or
3. In the standard toolbar, click the icon and drag the arrow to the desired context.
2.8.3 Introduction

Provides an initial overview of @PCS 7.

2.8.4 Getting Started

Provides guidelines for configuring @PCS 7.

2.8.5 About

You can use the About command to get more information on @PCS 7.

How to Get More Information on @PCS 7:

1. In the ? menu, click About.

or

2. Click the ? icon in the standard toolbar.

Result: The About @PCS 7 window is displayed.

2.8.6 Using Help

Provides a general overview of Windows NT Help.
2.9 Miscellaneous Commands

2.9.1 Cut

You can use the Cut command to delete selected text and copy it to the Clipboard. This command is available only if the text is selected.

The contents of the Clipboard remain stored until it is overwritten by a new entry by means of Cut or Copy.

How to Cut Text:

1. Select the text that you want to cut.
2. In the appropriate pop-up menu, select Cut.
   or
3. Click the icon in the standard toolbar.
4. You can use Paste to insert the cut text at another position.

2.9.2 Copy

You can use the Copy command to copy selected text to the Clipboard. This command is available only if the text is selected.

The contents of the Clipboard remain stored until it is overwritten by a new entry by means of Copy or Cut.

How to Copy Text:

1. Select the text that you want to cut.
2. In the appropriate pop-up menu, select Copy.
   or
3. Click the icon in the standard toolbar.
4. You can use Paste to insert the copied text at another position.
2.9.3 Paste

This command is available if text was stored on the Clipboard with Cut or Copy and the text is supposed to be transferred to a text field.

You can use the Paste command to copy this text to the selected text field.

How to Paste Text:

1. Select a text field.
2. In the appropriate pop-up menu, select Paste.
   
or
3. Click the icon in the standard toolbar.
2.10 Application Window

2.10.1 Log On

Here you must enter the user that was entered in the User Administration with the password that was stored in the same place.

You access your own computer with the computer name "localhost". As an alternative, you can enter the network name of the computer.

The entries must be complete and correct; otherwise, the log on is rejected with an appropriate message.

![@PCS7 Login]

2.10.2 Log Off

Log off offers the following alternatives:

![@PCS7 Logout]
Exit Program and Confirm with OK:
The @PCS 7 system is exited and the user interface is closed.

Log Off and Confirm with OK:
The @PCS 7 system is exited and the user interface stays open.

Log Off and Log On under Another Name and Confirm with OK:
The @PCS 7 system is exited and started with the new user; the user interface stays open.

Use Cancel to close the window without additional action.

2.10.3 Save

If you made changes in the @PCS 7 editors and you want to save these changes, you must select the @PCS 7 Data check box and confirm with OK.

You can only save other data if you included other applications (such as Excel) within the @PCS 7 interface with Insert Section.

Use Cancel to close the window without additional action.
2.10.4 Inserting an Object

You can use the "Insert Object" window to include Active X applications such as Microsoft Excel diagrams and tables, PowerPoint presentations, Word documents, or WinCC cross-reference lists in the @PCS 7 user interface.

Create New:

Select the desired object type and confirm with OK.

The selected application is started within the @PCS 7 user interface with an empty document.

Use Cancel to close the window without additional action.
Create from File:

![Create from File dialog box]

Use Browse to select a file and confirm with OK.

**Note:** Not all file types are supported.

Use **Cancel** to close the window without additional action.

### 2.10.5 About @PCS 7

The About @PCS 7 window displays the release of your @PCS 7 version.
3 Getting Started

3.1 Getting Started

In the following example, @PCS 7 is set up to display the internal tag "Real1" of an active WinCC project in an @aGlance client such as Web@aGlance or the add-in for Microsoft Excel.

A WinCC server with the name "WINCC1," a group "Group 1," and in that group a user "User 1" with the necessary authorizations are created.

A prerequisite is a WinCC project with the internal tag "Real1" that should be included in WinCC Runtime.

1. Start the configuration tool of @aGlance.
   @aGlance Administration for @PCS 7

2. Start the @PCS 7 system.
   Starting @PCS 7

3. Log on as "Administrator" with the password "Passwort".
   Enter "localhost" as the computer name.

   ![PCS7 Login]

   Enter your user name, your password, and the appropriate computer - default setting is the local host.

   User: Administrator
   Password: ********
   Host: localhost

   The @PCS 7 system is started.

4. Open the @PCS 7 User Administration.
   @PCS 7 User Administration Functionality
5. Open the group Administrators.
   Select the user Administrator and change the password by means of the menu.
   Properties
   In this way, only you and the users whom you set up later have access to the @PCS 7 system.
   - Now you can use the @PCS 7 configuration to configure your server for the data from WinCC.
   Configuring a Server
   **Example:** Your configuration could look like the following:

   ![Configuration Example](image-url)
6. Now, in the @PCS 7 User Administration, set up the groups and users with their rights and authorizations.

Configuring a User

**Example:** Your configuration should look like the following:

![Configuration screenshot]

7. Save your newly created configuration data.

Save
8. Log off of the system with "Log Off and Log On under Another Name."

   Log Off User

   The @PCS 7 system is now exited.

9. Log On to the @PCS 7 system again as a user whom you have configured.

   The @PCS 7 system is restarted with your configuration data and you now get
   access to the applications that are enabled for the user in the User
   Administration.

   Now you can access the data of your WinCC projects with @aGlance clients
   such as Web@aGlance or the add-in for Microsoft Excel. These are not
   included in the scope of supply of the @PCS 7 package!

   For read access of Web@aGlance to an @PCS 7 server, you have to enable
   the appropriate levels of authorization in the User Administration for the user
   "WebUser" in the Administrators group.
Example: WebUser gets the authorization levels “Read Tag” and “Navigate”.

Add-In for Excel (not included in the scope of supply of @PCS 7):
Here’s how you use the @aGlance/IT Macro Tool to copy the tag name of “Real1” into cell A2 of the opened Excel table:
Here's how you then use the @aGlance/IT Macro Tool to copy the value of "Real1" into cell A4 of the opened Excel table:

![@aGlance/IT Macro Tool](image)

**Note**

Errors that occur, for example because of missing rights for access to one of the @aGlance servers, are logged on the @PCS 7 system.

**@PCS 7 System Functionality**

10. You can now adapt the rights correspondingly if you have write authorization through the Web Write Access option or full access through the Full Client Access option.

11. If you have authorization through the Server To Server Communication option, you can now configure these.

**Configuring Server-Server Communication**
4  @PCS7 System

4.1.1  @PCS 7 System Functionality

With the @PCS 7 system, you can stop your system or restart it.

In addition, system messages of the @PCS 7 environment since the last restart are displayed here.

In addition you can set the language and edit the system settings here.
4.2 Edit Menu

4.2.1 Restarting the @PCS 7 System

You can use the Restart command in the Edit menu or the command button in the @PCS 7 system to exit the @PCS 7 system and immediately restart it again automatically. The user interface stays open.

How to Restart the @PCS 7 System:

1. Select the Restart command in the Edit menu.
   
   or

2. Click on the command button.

3. Confirm the following dialog box with OK:

   ![Restart Dialog Box]

   With Cancel, the system is not restarted.

4. If necessary, save your data.
   
   (This window is displayed only if you made changes in the previous field.)

   ![Save Dialog Box]

   With OK, the selected data are saved.
   
   Also refer to: Save.
   
   With Cancel, nothing is saved.

5. The @PCS 7 system is now restarted:
4.2.2 Stopping the @PCS 7 System

You can use the Stop @PCS 7 System command in the Edit menu or the button in the @PCS 7 system to exit the @PCS 7 system. The interface stays open.

How to Stop the @PCS 7 System:

1. Select the Stop @PCS 7 System menu item in the Edit menu.

or

2. Click on the Stop button.

3. Confirm the following box with OK:

With Cancel, the system is not stopped.

The @PCS 7 system is shut down now and the user is logged off.

4. In order to restart you have to log on to the system again with Log On User.

4.2.3 License of the @PCS 7 Server

You can use the License command in the Edit menu or the button in the @PCS 7 system to display the license level of your @PCS 7 server.

How to have the license level of your @PCS 7 Server displayed:

1. Select the License command in the Edit menu

or

2. Click on the License command button.
4.2.4 System Settings

You can use the System Settings command in the Edit menu or the button in the @PCS 7 system to display and edit the system settings of your @PCS 7 server.

Hinweis
The new setting becomes effective only after you restart the @PCS 7 system.

How to have the system settings of your @PCS 7 Server displayed:

1. Select the System Settings command in the Edit menu
   or
2. Click on the command button.

You can change the system parameters only if
- The @PCS 7 user has the configuration rights and
- The user has Windows NT administrator privileges.

4.2.4.1 The Following System Parameters Can Be Set with This Screen:

@PCS 7 Server:
- @PCS 7 Server Name: @aGlance name of the @PCS 7 server (such as @PCS 7)
- Maximum Number of Sessions: Maximum number of active sessions, that is, of logged on client applications (Excel, VB program,...)

@PCS 7 Trace:
The @PCS 7 Tracer stores diagnostic messages on the hard disk (in \Siemens\@PCS 7\Tracer) and outputs them in the system user interface, for example.

You can program the maximum number of Trace entries.

You can use the Trace Level during @PCS 7 Start to set how detailed the @PCS 7 diagnostics should be:

Trace Levels:
- 0: only serious errors
- 1: all errors
- 2: errors and warnings
- 3: errors and warnings and information
- 4 to 9: very detailed output (for internal purposes only)
S2S Trace (Server-Server Link)

The S2S jobs can also be logged individually for diagnostic purposes.
In this case, one log file per tracked S2S job is generated in
/Siemens/@PCS7/tmp.

The file name is structured as follows:
<servername>_<jobname>_<jobtype>.log

For example  Reactor4_ReadCounter_RC.log
              Reactor1_WriteCounter_WT.log

The key for the job types is as follows:
RC: cyclic read job  (Read Cyclic)
RP: read job on change (Read OnChange)
RT: event-driven read job (Read Triggered)
WC: cyclic write job  (Write Cyclic)
WP: write job on change (Write OnChange)
WT: event-driven write job (Write Triggered)

S2S Trace Levels:
// =0: log only serious errors
// =1: log start/stop/all errors
// =2: log start/stop/errors/good case
// =3: like 2, but with details on transferred data

S2S Trace Filter:
This string specifies which S2S jobs have to be logged for diagnostic purposes.
for example  "***" : all jobs are logged
            "Reactor1*" : only the jobs of the "Reactor1" server are logged
            "Reactor1_*_R*" : all READ jobs of the "Reactor1" server are logged

If you want to shut off S2S logging altogether, you can simply enter an invalid filter:
for example  "xxx"

Maximum Length of the Log File:
The maximum length of the S2S log files can be programmed in kilobytes.
If this limit is reached, the current .log file is saved to a .lo_ file and a new .log file is created.
Callback Time-Outs:

If the default time-out of 60 s for @aGlance calls would be too short, you can define time-outs for specific calls.

@PCS 7 Add-On:

The add-on logs all the alarm on the configured WinCC server and saves these in a separate message archive.

The user can configure the following message archive parameters via the "Control Panel"

Alarm archive length (in days):

The message archive length is to be set decimally in days (example: 1.5 is 36 hours).

Min. DB entry duration (in days):

The minimum data record validity is to be set decimally in days (example: 0.5 is 12 hours).

This means that no alarm will be deleted from the message archive which is newer than the period specified.

Put alarm delay (in s):

The put alarm delay is to be set in seconds.

By doing this, the alarms will be entered in the alarm archive only after the put alarm delay time has expired. This supports the recording of alarms in the correct time sequence if there is more than one server.

Further information on the meaning of the settings can be found under @PCS 7 Call Interface.
4.3 User Interface

4.3.1 Language

By selecting the language, you can display the @PCS 7 user interface in English or German.

In order to change the language you must end @PCS 7 (Exit) and start it again (Starting @PCS 7).

4.3.2 System Trace

Here the system messages of the @PCS 7 environment are represented in a ring buffer of 1000 data records.

The messages of the System Trace are deleted and restarted during every restart.
5  @PCS 7 Configuration

5.1  @PCS 7 Configuration Functionality

You can use the @PCS 7 Configuration to set up and configure the servers required for accessing the data of WinCC.

Note
PCS 7 Configuration is displayed on the @PCS 7 user interface only if the user who is logged on has received the "Configure @PCS 7" right in the @PCS 7 User Administration.
5.2 Configuring the Server

1. Select the @PCS 7 Configuration by selecting the icon.
   @PCS 7 Configuration Functionality
2. Insert a server.
   Inserting a Server
3. If you have a redundant server pair: assign the redundant computer.
   Assigning the Redundant Computer
4. If you have inserted a redundant computer, you can now specify the preferred server:
   Specifying the Preferred Server
   Note: The first computer automatically becomes the preferred server!
5. Now you can limit or enable the access to data.
   Specifying Data Access to the Server
6. If you would like to display the messages from the @PCS 7 system in the PCS 7 process control system, you must specify a server as message sink.
   Specifying a Message Sink
7. Save your newly created configuration data.
   Save
8. If you want to activate the new configuration, you have to restart the system.
   Restarting the @PCS 7 System
5.3 Assigning the Redundant Computer

How to Assign the Redundant Partner of a Computer:

In the interface of @PCS 7 Configuration, you will find a window with the column headings "Computer" and "Redundant Computer."

With Inserting a Server, you already entered a server with associated computer.

By double-clicking the open field next to the computer, you can enter the redundant computer.

Confirm your entry with RETURN.

You can always use the procedure described above to make changes.

Note:

You should always enter the server as a computer from which the project was copied to the redundant server.

5.4 Specifying the Preferred Server

5.4.1 Proceed as follows to specify the preferred server:

The user interface of the @PCS 7 configuration contains a window with the column headers "Computer" and "Redundant Computer".

You have already entered a server with the corresponding computer and then the redundant computer by using Insert Server.

Specify Preferred User is used to specify one computer of the redundant server pair as the preferred server, meaning that the system first tries to establish the communication via this server. If the preferred server fails, the system changes over to the redundant partner.

If no preferred server is specified, the master of the redundant computer (Computer column) automatically becomes the preferred server.

The activated preferred server is identified by a check mark before the computer name.
5.5 Specifying Data Access to the Server

How to Specify Data Access for a Server:

With inserting a server, you already entered a server.

1. In the interface of @PCS 7 Configuration, you will find a window with the first column heading "Server Name."

2. By using the mouse to select the columns assigned to the server that have the headings "Tags," "Archive," or "Message," you can prevent data access (No) or allow it (Yes).

The default setting allows access to all three components (Yes).

<table>
<thead>
<tr>
<th></th>
<th>Access to the tag management</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tag</td>
<td></td>
</tr>
<tr>
<td>Archive</td>
<td>Access to the archive data</td>
</tr>
<tr>
<td>Message</td>
<td>Access to the messages</td>
</tr>
</tbody>
</table>

5.6 Specifying a Message Sink

If you would like to display the messages from the @PCS 7 system in the PCS 7 process control system, you must specify a server as message sink.

How to Specify the Message Sink:

With inserting a server, you already entered a server.

1. In the interface of @PCS 7 Configuration, you will find the check box Message Sink. Select it with the mouse to activate it.

   ![Message Sink]

2. Next to Message Sink is a drop-down list box. Select the desired server from the list.

   ![Message Sink: WINCC1]
5.7 Edit Menu

5.7.1 Inserting a Server

You can use the Insert Server command in the Edit menu or you can use a pop-up menu (right mouse button on the list with the server names) in @PCS 7 Configuration to create a new server.

How to Create a New Server:

1. In the appropriate pop-up menu, select Insert Server.
2. Fill out the "Insert Server" dialog box and confirm with OK:

   Insert Server Dialog Box

   Sample Entry for a WinCC Server:

   ![Insert Server Dialog Box](image)

   3. If you have a redundant server pair, you must assign the redundant computer.

5.7.2 Deleting a Server

You can use the Delete Server command in the Edit menu or you can use a pop-up menu (right mouse button on the server) in @PCS 7 Configuration to remove a server.

If the Delete Server pop-up menu cannot be selected, the server to be deleted is still entered in the message sink. The message sink must therefore be de-activated first.
How to Delete a Server:

1. Select the server to be deleted.
2. In the appropriate pop-up menu, select **Delete Server**.
3. Confirm the following inquiry with **Yes**.

![Delete dialog box]

The selected server is removed from the list.
If you select **No**, the deleting process is aborted.

5.7.3 Preferred Server

You can specify a computer as the preferred server by using the **Preferred Server** command in the **Edit** menu or the pop-up menu (right-hand mouse button on the computer or redundant computer) in the @PCS 7 configuration.

Proceed as follows to specify the preferred server:

1. Select the computer.
2. Select the **Preferred Server** item in the corresponding pop-up menu.
3. Select the desired computer in the subsequent prompt window.
5.8 User Interface

5.8.1 Insert Server Dialog Box

![Insert Server Dialog Box]

<table>
<thead>
<tr>
<th>Server type</th>
<th>WinCC (at the moment BATCH flexible is not possible!)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server name</td>
<td>You can assign any name, for example: &quot;WinCC1&quot;.</td>
</tr>
<tr>
<td>Project name</td>
<td>For server type WinCC you can assign any name (irrelevant).</td>
</tr>
<tr>
<td>Computer name</td>
<td>The network name of the computer on which your WinCC project is running. For the local computer, you can enter &quot;LOCALHOST&quot; here. &quot;LOCALHOST&quot; is converted immediately to the right computer name.</td>
</tr>
</tbody>
</table>

5.8.2 Redundancy

Here you can enter the redundant partner server to an already configured server.

You can furthermore specified the preferred server here.

5.8.3 Server Configuration

Here you can configure an @PCS7 server for accessing WinCC or BATCH flexible data.
6  @PCS 7 User Administration

6.1  @PCS 7 User Administration Functionality

You can use the @PCS 7 User Administration to create groups and users and to assign and change their rights and authorizations.

Note
PCS 7 User Administration is displayed on the @PCS 7 user interface only if the user who is logged on has received the "Configure @PCS 7" right in the @PCS 7 User Administration.
6.2 Configuring a User

1. Select the @PCS 7 User Administration by selecting the icon.
   User Administration Functionality
2. Insert a group.
   Inserting a Group
3. Assign the desired authorizations to the group.
   Properties
4. Insert a user in the group.
   Inserting a User
5. Assign the desired authorizations to the user.
   Properties
6. Enable the desired access to your server.
   Assigning Authorization Levels
7. Save your newly created configuration data.
   Save
8. If you want to activate the new configuration, you have to restart the system.
   Restart @PCS 7 System
6.3 Assigning Authorization Levels

In the @PCS 7 User Administration, you can display and change the authorization levels for groups and users for each server that is entered in the @PCS 7 configuration.

When you insert a user into a group, these settings are also copied.

Authorization Levels:

<table>
<thead>
<tr>
<th>Authorization Level</th>
<th>WINCC1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigate</td>
<td>No</td>
</tr>
<tr>
<td>Read Tag</td>
<td>No</td>
</tr>
<tr>
<td>Write Variable</td>
<td>No</td>
</tr>
<tr>
<td>Read Archives</td>
<td>No</td>
</tr>
<tr>
<td>Read Alarms</td>
<td>No</td>
</tr>
<tr>
<td>Read User Archives</td>
<td>No</td>
</tr>
<tr>
<td>Write User Archives</td>
<td>No</td>
</tr>
</tbody>
</table>

Authorization Levels:

- **Navigate**: Permits data selection, such as browsing WinCC tags of the @PCS 7 WinCC1 server in Excel or when inserting tag pairs in the @PCS 7 Server-Server configuration.
- **Read Tags**: You can read all tags of your @PCS 7 server.
- **Write Tags**: You can write in all tags of your @PCS 7 server.
- **Read Archives**: You can read all archives of your @PCS 7 server.
- **Read Alarms**: You can read all messages of your @PCS 7 server.
- **Read User Archive**: All the user archives of your PCS 7 server can be read.
- **Write User Archive**: Data can be written to all the user archives of your PCS 7 server.
How to Assign Authorization Levels to a Group or a User:

1. Open the @PCS 7 User Administration.
2. Select a group or a user.
3. Use the mouse to assign authorizations in the column assigned to the desired server.

6.4 Edit Menu

6.4.1 Inserting a Group

From the Edit menu, you can choose Insert Group, or you can use a pop-up menu in the navigation window of the @PCS 7 User Administration (right mouse button in an open field), to create a new group. There are no subgroups.

How to Create a New Group:

1. In the appropriate pop-up menu, select Insert Group.
   In the navigation window, a new group is set up with the name “Group *”.
2. You can use the pop-up menu command Rename to give this group a new name.
3. Use the pop-up menu command Properties to assign the desired authorizations.

Note
A group name can be assigned only once.
6.4.2 Deleting a Group

From the Edit menu, you can choose Delete Group, or you can use a pop-up menu in the navigation window of the @PCS 7 User Administration (right mouse button on the group to be removed), to delete a group.

How to Delete a Group:

1. Select Delete Group in the appropriate pop-up menu.
2. Confirm the following prompt with Yes:
   ![Delete Confirmation Dialog]
   No aborts the process.

6.4.3 Inserting a User

From the Edit menu, you can choose Insert User, or you can use a pop-up menu in the navigation window of the @PCS 7 User Administration (right mouse button on group), to create a new user within a group (menu command:Insert Group).

How to Create a New User:

1. In the appropriate pop-up menu, select Insert User.
   In the navigation window, under the selected group, a new user is set up with the name "user *".
2. You can use the pop-up menu command Rename to give this user a new name.
3. Use the pop-up menu command Properties to assign the desired authorizations.

Note
A user name can be assigned only once.
6.4.4 Deleting a User

From the Edit menu, you can choose Delete User, or you can use a pop-up menu in the navigation window of the @PCS 7 User Administration (right mouse button on the user to be removed), to delete a user.

How to Delete a User:
1. In the appropriate pop-up menu, select Delete User.
2. Confirm the following prompt with Yes:
   
   ![Delete dialog box](image)

   Yes aborts the process.

6.4.5 Rename

From the Edit menu, you can choose Rename, or you can use a pop-up menu in the navigation window of the @PCS 7 User Administration (right mouse button on the user or group to be named), to rename a user or a group.

As an alternative, you can use the left mouse button to select the name.

How to Rename a Group or a User:
1. In the appropriate pop-up menu, select Rename.
2. The text is selected. You can either overwrite it or change it.
   
   The names must be unique.
6.4.6 Properties

From the Edit menu, you can choose Properties, or you can use a pop-up menu for a group or a user in the navigation window of the @PCS 7 User Administration, to assign specific rights to the groups or the users. For the user, you can assign a password here.

How to Assign Rights to a Group:

1. In the appropriate pop-up menu, select Properties.
2. Select the desired right in the Properties dialog box.

How to Assign a Password and Rights to a User:

1. In the appropriate pop-up menu, select Properties.
2. Enter the desired password in the Properties dialog box.
3. Select the desired right in the Properties dialog box.

Note

First assign the rights and authorizations that are valid for the entire group. When you insert a user into a group, these settings are also copied.
6.5 User Interface

6.5.1 Users

Here you create and edit your users with their properties within existing or new groups.

The users Administrator, Guest, S2SUser, and WebUser have specific properties and cannot be deleted.

<table>
<thead>
<tr>
<th>User</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrator</td>
<td>Administrator account, as default setting has all configuration rights and the password &quot;Passwort&quot;.</td>
</tr>
<tr>
<td>Note: After you set up separate users, you should change the password.</td>
<td></td>
</tr>
<tr>
<td>Guest:</td>
<td>Guest account, does not allow access to the editors, no password is preset.</td>
</tr>
<tr>
<td>S2SUser</td>
<td>Internal user for the Server-Server communication, no password. It is only possible to read variables and alarms, as well as to write variables.</td>
</tr>
<tr>
<td>WebUser:</td>
<td>Internal user for access from Web@aGlance, no password is preset.</td>
</tr>
</tbody>
</table>

6.5.2 Own Configuration Rights

The configuration rights of the active user are displayed here.

6.5.3 Authorization Levels

The authorization levels for accessing individual @PCS 7 servers for the groups and users are assigned here.
6.5.4 Properties Dialog Box

Rights to the Group

Password:

Configuring @PCS 7:

Configuring Server-Server Communication

OK Cancel Help

Password and Rights to the User

Password: Here you assign the user the log on password for @PCS 7 (not a mandatory field).

Configuring @PCS 7: Permits access to @PCS 7 Configuration and @PCS 7 User Administration.

Configuring Server-Server: Permits access to @PCS 7 Server-Server Configuration.

With Enter, your entries are accepted and the dialog box is closed.

With Cancel, your entries are discarded and the dialog box is closed.

With Help, the context-sensitive Help is opened.
7  @PCS 7 Server-Server Configuration

7.1  @PCS 7 Server-Server Configuration Functionality

You can use @PCS 7 Server-Server Configuration to specify the jobs for linking a different @aGlance server to your @PCS 7 server (@aGlance Client Functionality).

Note

PCS 7 Server-Server Configuration is displayed in the @PCS 7 user interface only if the appropriate authorization exists and the user who is logged on has the "Configuring Server-Server" right in the @PCS 7 User Administration.
7.2 Configuring Server-Server Communication

**Note**
Server-Server Communication is an option and requires a special authorization. Also refer to: Form of Delivery and Functionality

How to Configure the Communication Data for Linking a Different @aGlance Server to Your @PCS 7 Server:

In the following example, the process value LIC04.PV from the @aGlance demo server Reactor4 is written to the internal tag Real1 of the active WinCC project.

Reactor4 is an @aGlance server with a reactor simulation that delivers process data that change constantly. Start it with **Programs > @aGlance > Reactor4 Demo Server**.

You will also need a WinCC project with the internal tag "Real1" that should be included in WinCC Runtime.

In @PCS 7 Configuration, you must have created a server of the type "WinCC" and you must have permitted access to the tags. Also refer to: Getting Started

1. Set up your user for access to the @PCS 7 Server-Server Configuration.

   Without the configuration rights, you will not get access to the @PCS 7 Server-Server Configuration application.

   Without the authorization level "Navigate" in the server, you will not be able to select any tags from your WinCC project for the tag configuration.

Assigning Authorization Levels
Example: You need all configuration rights for @PCS 7 and the authorization level "Navigate" for the "WINCC1" server.

If you have changed the rights, you have to execute a Restart @PCS 7 System with the @PCS 7 data being saved.

2. In the @PCS 7 User Administration, assign the required rights for accessing the @PCS 7 server to the user "S2SUUser".

For read and write access to the @PCS 7 server, both authorization levels have to be enabled with "Yes".

Assigning Authorization Levels
**Example:** Only write access is required.

Example: The name of the Reactor4 demo server of @aGlance/IT is "Reactor4".

If you have changed the rights, you have to execute a Restart @PCS 7 System with the @PCS 7 data being saved.

3. Choose @PCS 7 Server-Server Configuration by selecting the icon.

4. Insert a new server.

5. Name the server.

Example: The name of the Reactor4 demo server of @aGlance/IT is "Reactor4".
6. If your server supports monitoring, you can set up the server for this function.
   Server Properties
   **Example:** Do not activate monitoring.

7. Create a job to write the value of a tag to a tag of the remote (partner) server.
   **Example:** Insert a new job under "Reactor4" for "Read Jobs" "cyclic".

8. Name the job.
    Renaming a Job
    **Example:** You can leave the name "Job 1" as is.

9. For cyclic jobs, specify the cycle time, or for triggered jobs, specify the trigger tag, or for change jobs, specify the the minimum time between two updates and enable the job for processing.
    Job Properties
    **Example:** Cycle time 2 seconds, enable assigned.

10. Display the job.
    Showing a Job

11. Insert the tag pairs for Server-Server communication into your jobs.
    Inserting Tag Pairs
**Example:** As source of Reactor4 the analog value "LIC04.PV" and as destination of @PCS 7 server "WINCC1" the floating-point tag "Real1", so that the current value of "LIC04.PV" is written cyclically into the WinCC tag "Real1".

12. You can alternatively import the tag pairs from a file created externally.

   **Hint:**
   After you have already created the first tag pair with Insert New Tag Pair, you can export these into an export file with Export Job.
   You can add to this export file by using an external editor (for example, EXCEL) and then import it in 'txt' format.

13. Check to see if the server has been enabled.

   **Server Properties**

14. Start the job.

   **Starting a Job**
   As an alternative, you can start all jobs of one server together instead of starting individual jobs.

   **Starting a Server**

15. Save your configuration data.

   **Save**

   **Note** In order for you to start jobs, the data must not be saved. So that the data are taken into consideration for a restart or complete restart, they must be saved.
Example: Your configuration should look like the following:

![Diagram of Reactor4 with tasks and destinations]

16. As an alternative, you can create, enable, and save several jobs and then activate them with Restart @PCS 7 System.

17. Check in WinCC Runtime to see if the tag "Real1" changes cyclically.

Note

Errors that occur, for example because of missing rights for access to one of the @aGlance servers, are logged on to the @PCS 7 system.

@PCS 7 System Functionality

Check primarily the rights of the user "S2SUser", see Point 2.

For detailed information and error display, for example invalid tags (import function!) please refer to the log files in the \@PCS 7\Bin\ directory.

Example: Reactor4_Job 1_RC.log

In order to obtain more precise information you can set the S2S Trace-Level in the System Settings in the @PCS 7 menu higher.

Please take into consideration that the speed of your computer can be reduced considerably by the increased logging effort when the number of tags is larger!

Therefore reset the S2S Trace-Level to 0 after you have checked the tags!
7.3 Edit Menu Server

7.3.1 Inserting a New Server

You can use the command **Insert Server** in the **Edit** menu or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button in an open field) to create a new server.

**How to Create a New Server:**

1. In the appropriate pop-up menu, select **Insert Server**.
   In the navigation window, a new server is set up with the name "Server **".
2. You must use the Rename Server pop-up menu to give this new server the name of your @aGlance partner server.

7.3.2 Deleting a Server

From the **Edit** menu, you can choose **Delete Server**, or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button on the server to be deleted), to remove a server.

**How to Delete a Server:**

1. In the appropriate pop-up menu, select **Delete Server**.
2. Confirm the following prompt with **Yes**:

   ![Delete Confirmation](image)

   **Yes** aborts the process.
7.3.3 Deleting All Servers

From the Edit menu, you can choose Delete All Servers, or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button under the last server), to remove all servers that are entered in the @PCS 7 Server-Server Configuration.

How to Delete All Servers:

1. In the appropriate pop-up menu, select Delete All Servers.
2. Confirm the following inquiry with Yes:

![Delete Confirmation Screen]

No aborts the process.

7.3.4 Renaming a Server

From the Edit menu, you can choose Rename Server, or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button on the server to be named), to rename a server.

As an alternative, you can use the left mouse button to select the server name.

Attention: The name of your server must match exactly the name of the @aGlance server with which you want to exchange data.

How to Rename a Server:

1. In the appropriate pop-up menu, select Rename Server.
2. The text is selected. You can either overwrite it or change it.
   The server names must be unique.
7.3.5 Starting a Server

From the Edit menu, you can choose Start Server, or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button on the server), to start all enabled jobs of the selected server without restarting the @PCS 7 system.

How to Start a Server:

In the appropriate pop-up menu, select Start Server.
A message is displayed when the start has been successful.

Confirm it with OK.

Note
In the @PCS 7 User Administration, check to see if the user "S2SUser" has the required rights for accessing the @PCS 7 server.
Assigning Authorization Levels
For read and write access to the @PCS 7 server, both authorization levels have to be enabled with "Yes".

7.3.6 Stopping a Server

From the Edit menu, you can choose Stop Server, or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button on the server), to stop all active jobs of the selected server without restarting or stopping the @PCS 7 system.

How to Stop a Server:

In the appropriate pop-up menu, select Stop Server.
A message shows that the stop has been successful.

Confirm it with OK.
7.3.7 Server Properties

You can edit the properties of a server by using the Properties... menu item in the Edit menu or by using a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right-hand mouse button on the server).

How to Edit the Properties of a Server:

1. Select Properties... in the appropriate pop-up menu.
2. Edit the properties in the Server Properties dialog box.

7.4 Edit Menu Jobs

7.4.1 Inserting a Job

You can create a new job for the selected server by using the Insert Job menu item from the Edit menu or by using a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right-hand mouse button on the type of the new job, such as Changed).

You can insert the following jobs:

Read jobs with the external server as source and the @PCS 7 server as destination.

Write jobs with the @PCS 7 server as source and the external server as destination.

These jobs are further divided as follows:

- Changed: data transmission takes place only if there is a change to the tag to be read.
- Triggered: data transmission takes place depending on the status of a trigger tag.
- Cyclic: data transmission takes place in a fixed cycle, such as every second.

How to Create a New Job:

1. In the appropriate pop-up menu, select Insert Job.
   
   In the navigation window, a new job is set up with the name "Job **".

2. You can use the pop-up menu command Rename Job to give this job a different name.

Also refer to:

Configuring Server-Server Communication
Deleting a Job
7.4.2 Deleting a Job

From the Edit menu, you can choose Delete Job, or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button on the job to be deleted), to remove a job.

How to Delete a Job:

3. In the appropriate pop-up menu, select Delete Job.
4. Confirm the following prompt with Yes:

![Delete window](image)

No aborts the process.

7.4.3 Deleting All Jobs

From the Edit menu, you can choose Delete All Jobs, or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button on the type of jobs to be deleted, such as Changed), to remove all jobs of the same type of one server.

How to Delete All Jobs:

1. In the appropriate pop-up menu, select Delete All Jobs.
2. Confirm the following prompt with Yes:

![Delete window](image)

No aborts the process.
### 7.4.4 Renaming a Job

From the Edit menu, you can choose Rename Job, or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button on the job to be named), to rename a job.

As an alternative, you can use the left mouse button to select the job name.

**How to Rename a Job:**

1. In the appropriate pop-up menu, select Rename Job.
2. The text is selected. You can either overwrite it or change it.

   The job names of one type must be unique.

**Note**

You have to stop the job before you can make changes.

### 7.4.5 Showing a Job

From the Edit menu, you can choose Show Job, or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button on the job), to display and edit the tag pairs that belong to a job.

**How to Show a Job:**

1. In the appropriate pop-up menu, select Show Job.
7.4.6 Importing a Job

You can read the tag pairs existing in a file created externally into the selected job by using the **Import Job** menu item in the **Edit** menu or by using the pop-up menu (right-hand mouse button on the job) in the navigation window of the @PCS 7 Server-Server Configuration

**Hint:**
Create the first tag pair by using **Insert New Tag Pair** and create an export file by using **Export Job**. This can be extended by using an external editor (for example, EXCEL) and then importing.

**How to import a job:**

1. Select the **Import Job** menu item in the corresponding pop-up menu.
2. In the subsequent mask select the file to be imported and confirm by clicking on **OK**.

![Import tag pairs](image)

The process is aborted with **Cancel**.

3. The existing tag pairs are deleted and replaced by the imported tag pairs.
   
   Confirm the following prompt with **Yes**:
If you select **No**, the process is aborted.

4. The following message confirms that the import has been successful.

Confirm with **OK**.

**Caution:**

If 0 tab pairs were imported, the incorrect file format was probably selected while editing with an editor (for example, EXCEL).

The file to be imported has to be saved in 'txt' format. The tag pairs have to be separated by a tab.
7.4.7 Exporting a Job

You can write the existing tag pairs of the selected job into a file by using the Export Job menu item in the Edit menu or by using the pop-up menu (right-hand mouse button on the job) in the navigation window of the @PCS 7 Server-Server Configuration.

How to export a job:

1. Select the Export Job item in the corresponding pop-up menu.
2. Select the file path and assign a file name in the subsequent mask.
3. The export file is created in 'txt' format, meaning that the tag pairs are separated by tabs.
   Confirm it with OK.

The process is aborted with Cancel.

4. Acknowledge the subsequent prompt with YES:

5. The export has been carried out successfully.
Confirm it with OK.

6. You can now edit the export file with an external editor (for example, EXCEL) and thus create new tag pairs.

Caution:
Always save the export file on 'txt' format. Otherwise the data cannot be read in again with Import Job.

7.4.8 Starting a Job

From the Edit menu, you can choose Start Job, or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button on the job), to start an enabled job without restarting the @PCS 7 system.

How to Start a Job:

1. Select Start Job in the appropriate pop-up menu.

   A message is displayed when the start has been successful.

   Confirm it with OK.

Note

In the @PCS 7 User Administration, check to see if the user "S2SUser" has the required rights for accessing the @PCS 7 server.

Assigning Authorization Levels

For read and write access to the @PCS 7 server, both authorization levels have to be enabled with "Yes".
7.4.9  Stopping a Job

From the Edit menu, you can choose Stop Job, or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button on the job), to stop a job without restarting or stopping the @PCS 7 system.

How to Stop a Job:

2. In the appropriate pop-up menu, select Stop Job.

A message is displayed when the stop has been successful.

Confirm it with OK.

7.4.10  Job Properties

From the Edit menu, you can choose Job Properties, or you can use a pop-up menu in the navigation window of the @PCS 7 Server-Server Configuration (right mouse button on the job), to edit the properties of a job.

How to Edit the Properties of a Job:

1. In the appropriate pop-up menu, select Job Properties.

2. Edit the properties in the Job Properties dialog box.
7.5   **Edit Menu Tags**

7.5.1   **Inserting a New Tag Pair**

You can create tag pairs for the selected job by using the **Insert Tag Pairs** menu item from the **Edit** menu or by using a pop-up menu in the @PCS 7 Server-Server Configuration (right-hand mouse button on the tag table).

**How to Create a New Job:**

1. Select **Insert Tag Pairs** in the corresponding pop-up menu.
2. You can combine tags into pairs from the source and the destination in the Insert Tag dialog box.

7.5.2   **Deleting a Tag Pair**

You can remove a tag pair by using the **Delete Tag Pair** menu item from the **Edit** menu or by using a pop-up menu in the tag window of the @PCS 7 Server-Server Configuration (right-hand mouse button on the job to be deleted).

**How to Delete a Tag Pair:**

1. Select **Delete Tag Pair** in the appropriate pop-up menu.
2. Confirm the following prompt with **Yes:**

   ![Delete Confirmation Dialog]

   **No** aborts the process.
7.5.3 Deleting All Tag Pairs

You can remove all tag pairs that belong to a job by using the **Delete All Tag Pairs** menu item from the **Edit** menu or by using a pop-up menu in the tag window of the @PCS 7 Server-Server Configuration (right-hand mouse button on the job to be deleted).

**How to Delete All Tag Pairs of a Job:**

1. Select **Delete All Tag Pairs** in the appropriate pop-up menu.

   Confirm the following prompt with **Yes:**

   ![Delete Confirmation Dialog](image)

   **No** aborts the process.

7.6 User Interface

7.6.1 Server Configuration

You can create, display, and edit the servers and their jobs for communication with your @PCS 7 server here.

7.6.2 Tag Configuration

You can create, display, and delete the tag pairs of the selected job here.

- The source is the server which is accessed with read access.
- The destination is the server which is accessed with write access.

**Note**

You have to stop the job before you can make changes.
7.6.3 Server Properties Dialog Box

<table>
<thead>
<tr>
<th>Name:</th>
<th>Displays the name of the selected server.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comments:</td>
<td>Here you can enter any text, such as the server type.</td>
</tr>
</tbody>
</table>
| Enable:       | By clearing the check box, you disable all enabled jobs of this server.  
                By selecting the check box, you create the prerequisite for starting the jobs.  
                See also: Starting a Job |
| Monitor Types:| By selecting Monitor Types, the dialog box for setting the monitoring properties of the server is expanded as follows: |

<table>
<thead>
<tr>
<th>Update on Change:</th>
<th>Here you enter the string that the @aGlance server accepts as ID, for example &quot;changed&quot;, for an @PCS 7 server.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update Cyclically:</td>
<td>Here you enter the string that the @aGlance server accepts as ID, for example &quot;cyclic&quot;, for an @PCS 7 server.</td>
</tr>
</tbody>
</table>
With **OK**, your entries are accepted and the dialog box is closed.

With **Cancel**, your entries are discarded and the dialog box is closed.

You can use Monitoring to remove a significant load from the @PCS 7 client (@PCS 7 Server-Server Communication) during communication. However, the prerequisite is that the @aGlance server supports Monitoring.

**Example:** When you activate cyclical Monitoring, the @PCS 7 client logs in at the @aGlance server. After that, the server independently sends the data cyclically to the client and the client forwards them to the @PCS 7 server.

### 7.6.4 Import/Export Dialog Box

This mask is used to select the file for importing the tag pairs.
This mask is used to create or select the file for exporting the tag pairs.

<table>
<thead>
<tr>
<th>Filter:</th>
<th>Here you enter the filter for selecting files. Wildcards such as * and ? may be used.</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name:</td>
<td>Export: Enter the desired name here. Import/Export: The file selected with the browser is shown here.</td>
</tr>
</tbody>
</table>

If you click on OK your entries are used and the dialog box is closed.

If you click on Cancel, your entries are rejected and the dialog box is closed.
### 7.6.5 Job Properties Dialog Box

With changed and cyclic jobs, the following dialog box appears:

![Job Properties Dialog Box](image)

<table>
<thead>
<tr>
<th>Source:</th>
<th>Displays the name of the source server.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Destination:</td>
<td>Displays the name of the destination server.</td>
</tr>
<tr>
<td>Job:</td>
<td>Displays the name of the job.</td>
</tr>
<tr>
<td>Time (in seconds):</td>
<td>For cyclic jobs: Here you edit the cycle time for the job. For changed jobs: Here you edit the minimum time between two updates.</td>
</tr>
<tr>
<td>Comment:</td>
<td>Here you can enter any text.</td>
</tr>
<tr>
<td>Enable:</td>
<td>Select this box with the mouse to enable the job. <strong>Note</strong> Enable must also be selected in the properties of the server for the job to be activated. See also: Server Properties</td>
</tr>
</tbody>
</table>

With **OK**, your entries are accepted and the dialog box is closed.

With **Cancel**, your entries are discarded and the dialog box is closed.
For triggered jobs, the dialog box shown above is expanded by the Trigger input field:

### Trigger:

- **Enter the trigger tag.**
- *(for example, "WINCC1/TAGS/internal tags/signal1")*
7.6.6 Insert Tag Dialog Box

Use the mouse to select a tag in both the source and the destination.
Use **Apply** to have this tag pair accepted into the tag list.
You can create several tag pairs in succession.
Use **Exit Input** to close this dialog box.
# Index

@PCS7 Interface to the Plant Operations Level

## A

<table>
<thead>
<tr>
<th>About</th>
<th>2-12</th>
</tr>
</thead>
<tbody>
<tr>
<td>About @PCS 7</td>
<td>2-18</td>
</tr>
<tr>
<td>Assigning Authorization Levels</td>
<td>6-3</td>
</tr>
<tr>
<td>Assigning the Redundant Computer</td>
<td>5-3</td>
</tr>
<tr>
<td>Authorization Levels</td>
<td>6-8</td>
</tr>
</tbody>
</table>

## C

| Configuring a User | 6-2 |
| Configuring Server-Server Communication | 7-2 |
| Configuring the Server | 5-2 |
| Context-Sensitive Help F1 | 2-11 |
| Copy | 2-13 |
| Cut | 2-13 |

## D

| Deleting a Group | 6-5 |
| Deleting a Job | 7-12 |
| Deleting a Server | 5-5, 7-8 |
| Deleting a Tag Pair | 7-19 |
| Deleting a User | 6-6 |
| Deleting All Jobs | 7-12 |
| Deleting All Servers | 7-9 |
| Deleting All Tag Pairs | 7-20 |

## E

| Edit Menu | 2-7 |
| Exit | 2-5, 2-6 |
| Exporting a Job | 7-16 |

## G

| Getting Started | 2-12, 3-1 |

## I

| Import/Export Dialog Box | 7-22 |
| Importing a Job | 7-14 |
| Insert Tag Dialog Box | 7-26 |
| Inserting a Group | 6-4 |
| Inserting a New Job | 7-11 |
| Inserting a New Server | 7-8 |
| Inserting a New Tag Pair | 7-19 |
| Inserting a Section | 2-9 |
| Inserting a Server | 5-5 |
| Inserting a User | 6-5 |
| Inserting an Object | 2-17 |
| Installing @aGlance | 1-20 |
| Installing @PCS 7 | 1-14 |

## J

| Job Properties | 7-18 |
| Job Properties Dialog Box | 7-24 |

## K

| Keyboard Operation | 2-2 |

## L

| Language | 4-7 |
| License of the @PCS 7 Server | 4-3 |
| Log Off | 2-15, 2-16 |
| Log Off User | 2-11 |
| Log On | 2-15 |
| Log On User | 2-10 |

## O

| Own Configuration Rights | 6-8 |

## P

| Paste | 2-14 |
| Preferred Server | 5-6 |
| Properties | 6-7 |
| Properties Dialog Box | 6-9 |
Index

R

README...................................................... 1-16
README.TXT.............................................. 1-16
Removing @PCS7....................................... 1-16
Removing a Section..................................... 2-10
Rename....................................................... 6-6
Renaming a Job............................................. 7-13
Renaming a Server........................................ 7-9
Restarting the @PCS7 System...................... 4-2

S

Save...................................................... 2-5, 2-16
Server Configuration............................. 5-7, 7-20
Server Properties......................................... 7-11
Server Properties Dialog Box....................... 7-21
Showing a Job ............................................. 7-13
Specifying a Message Sink............................ 5-4
Specifying Data Access to the Server............ 5-4
Specifying the Preferred Server..................... 5-3
Starting @aGlance Administration............... 1-20
Starting @PCS7.......................................... 1-15
Starting a Job............................................... 7-17
Starting a Server......................................... 7-10
Stopping a Job............................................. 7-18
Stopping a Server ........................................ 7-10
Stopping the @PCS7 System ........................ 4-3
Structure and Mode of Operation of the @PCS 7 Server Part .......... 1-11, 1-13
Structure and Mode of Operation of the @PCS7 Client Part............... 1-13
System Settings ............................................. 4-4
System Trace ................................................. 4-7

T

Tag Configuration........................................ 7-20
Toolbar Icons............................................. 2-1

U

Users.............................................................. 6-8
Using Help.................................................... 2-12

V

View Status Bar.............................................. 2-9
View Toolbar .................................................. 2-9

W

What Are @aGlance Client and Server........ 1-17
What Is @aGlance ....................................... 1-17