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Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

DANGER  
indicates that death or severe personal injury will result if proper precautions are not taken. 

 

WARNING  
indicates that death or severe personal injury may result if proper precautions are not taken. 

 

CAUTION  
with a safety alert symbol, indicates that minor personal injury can result if proper precautions are not taken. 

 

CAUTION  
without a safety alert symbol, indicates that property damage can result if proper precautions are not taken. 

 

NOTICE  
indicates that an unintended result or situation can occur if the corresponding information is not taken into 
account. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The device/system may only be set up and used in conjunction with this documentation. Commissioning and 
operation of a device/system may only be performed by qualified personnel. Within the context of the safety notes 
in this documentation qualified persons are defined as persons who are authorized to commission, ground and 
label devices, systems and circuits in accordance with established safety practices and standards. 

Proper use of Siemens products 
Note the following: 

WARNING  
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be adhered to. The information in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of the Siemens AG. The remaining trademarks in this 
publication may be trademarks whose use by third parties for their own purposes could violate the rights of the 
owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 
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Preface 1
1.1 Scope 

This document is part of the SIMOTION Programming documentation package. 
This document is valid for product version V4.1, Service Pack 4 of SIMOTION SCOUT (the 
engineering system of the SIMOTION product family) in conjunction with: 
● a SIMOTION device with the following versions of the SIMOTION kernel: 

– V4.1 SP4 
– V4.1 SP2 
– V4.1 SP1 
– V4.0 
– V3.2 
– V3.1 
– V3.0 

● The relevant version of the following SIMOTION Technology Packages, depending on the 
kernel 
– Cam 
– Path (kernel V4.1 and higher) 
– Cam_ext (kernel V3.2 and higher) 
– TControl 
– Gear, Position and Basic MC (only for kernel V3.0). 
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1.2 Information in this manual 
The following is a list of chapters included in this manual along with a description of the 
information presented in each chapter. 
● Description (Chapter 1) 

This chapter shortly defines the LAD and FBD programming languages. 
● LAD/FBD Editor (Chapter 2) 

In this chapter you can learn about the various operator control options in the LAD/FBD 
Editor. 

● Software Programming (Chapter 3) 
This chapter shows how to proceed during programming. 

● Functions (Chapter 4) 
This chapter describes how to apply individual LAD/FBD commands and gives an outline 
of their function. 

● Debugging Software / Error Handling (Chapter 5) 
This chapter describes how to test a program and find errors in created programs. 

● Application Examples (Chapter 6) 
You will be given an introduction to the LAD and FBD programming languages using 
some simple examples. 

● Appendix 
– Key combinations 

This appendix contains the keystroke combinations for frequently used commands. 
● Index 

Keyword index for locating information. 
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1.3 SIMOTION Documentation 
An overview of the SIMOTION documentation can be found in a separate list of references.   
This documentation is included as electronic documentation with the supplied SIMOTION 
SCOUT. 
The SIMOTION documentation consists of 9 documentation packages containing 
approximately 80 SIMOTION documents and documents on related systems (e.g. 
SINAMICS).  
The following documentation packages are available for SIMOTION V4.1 SP4: 
● SIMOTION Engineering System 
● SIMOTION System and Function Descriptions 
● SIMOTION Service and Diagnostics 
● SIMOTION Programming 
● SIMOTION Programming - References 
● SIMOTION C 
● SIMOTION P350 
● SIMOTION D4xx 
● SIMOTION Supplementary Documentation 



Preface  
1.4 Hotline and Internet addresses 

 SIMOTION LAD/FBD 
14 Programming and Operating Manual, 05/2009 

1.4 Hotline and Internet addresses 

Siemens Internet address 
The latest information about SIMOTION products, product support, and FAQs can be found 
on the Internet at: 
● General information: 

– http://www.siemens.de/simotion (German) 
– http://www.siemens.com/simotion (international) 

● Downloading documentation 
Further links for downloading files from Service & Support. 
http://support.automation.siemens.com/WW/view/en/10805436 

● Individually compiling documentation on the basis of Siemens contents with the My 
Documentation Manager (MDM), refer to http://www.siemens.com/mdm 
My Documentation Manager provides you with a range of features for creating your own 
documentation. 

● FAQs 
You can find information on FAQs (frequently asked questions) by clicking 
http://support.automation.siemens.com/WW/view/en/10805436/133000. 

Additional support 
We also offer introductory courses to help you familiarize yourself with SIMOTION. 
For more information, please contact your regional Training Center or the main Training 
Center in 90027 Nuremberg, Germany. 
Information about training courses on offer can be found at: 
www.sitrain.com 



 Preface 
 1.4 Hotline and Internet addresses 

SIMOTION LAD/FBD 
Programming and Operating Manual, 05/2009 15 

Technical support  
If you have any technical questions, please contact our hotline: 
 
 Europe / Africa 
Phone +49 180 5050 222 (subject to charge) 
Fax +49 180 5050 223 
€0.14/min from German wire-line network, mobile phone prices may differ. 
Internet http://www.siemens.com/automation/support-request  

 

 
 Americas 
Phone +1 423 262 2522 
Fax +1 423 262 2200 
E-mail mailto:techsupport.sea@siemens.com  

 

 
 Asia / Pacific 
Phone +86 1064 757575 
Fax +86 1064 747474 
E-mail mailto:support.asia.automation@siemens.com 

 
 

 Note 
Country-specific telephone numbers for technical support are provided under the following 
Internet address:  
http://www.automation.siemens.com/partner 

 

Questions about this documentation 
If you have any questions (suggestions, corrections) regarding this documentation, please 
fax or e-mail us at:  
 
Fax +49 9131- 98 2176 
E-mail mailto:docu.motioncontrol@siemens.com    
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Description 2
2.1 Description 

This chapter will give you a brief overview of ladder logic (LAD) and function block diagram 
(FBD).  

2.2 What is LAD? 
LAD stands for ladder logic. LAD is a graphical programming language. The statement 
syntax corresponds to a circuit diagram. LAD enables simple tracking of the signal flow 
between conductor bars via inputs, outputs and operations.  
LAD statements consist of elements and boxes which are graphically connected to networks 
(which are displayed in conformity with the IEC 61131-3 standard). LAD operations follow 
the rules of Boolean logic.  

 
Figure 2-1 Representation of a network in LAD 

The LAD program can also be displayed as an FBD program. 

The LAD programming language 
The LAD programming language features all the elements required for the creation of a 
complete user program. LAD features an extensive command set. This includes the various 
basic operations with a comprehensive range of operands and how to address them. The 
design of the functions and function blocks enables you to structure the LAD program 
clearly. 

The program package 
The LAD programming package is an integral part of the basic SIMOTION software, so that 
after your SIMOTION software has been installed, all editor, compiler and test functions for 
LAD are available for use. 
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2.3 What is FBD? 
FBD stands for function block diagram. FBD is a graphics-based programming language that 
uses the same type of boxes used in boolean algebra to represent logic (networks are 
displayed in conformity with the IEC 61131-3 standard). In addition, complex functions (e.g. 
mathematical functions) can be represented directly in conjunction with the logic boxes.    

 
Figure 2-2 Representation of a network in FBD 

The FBD program can usually also be displayed as an LAD program. 

The FBD programming language 
The FBD programming language features all the elements required for the creation of a 
complete user program. FBD features an extensive command set. This includes the various 
basic operations with a comprehensive range of operands and how to address them. The 
design of the functions and function blocks enables you to structure the FBD program 
clearly. 

The program package 
The FBD programming package is an integral part of the basic SIMOTION software, so that 
after your SIMOTION software has been installed, all editor, compiler and test functions for 
FBD are available for use. 
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2.4 Unit, program organization unit (POU) and program source 
The term "unit" represents a program source.            
The terms "program organization unit (POU)" and "LAD/FBD program" are generic terms and 
may refer to a program, a function (FC), or a function block (FB). 
The term "program source file" is a generic term and may refer to a LAD/FBD unit, an MCC 
unit or an ST source file. 
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LAD/FBD editor 3
3.1 The LAD/FBD editor in the workbench 

The workbench represents the framework for SIMOTION SCOUT. Using the workbench 
tools, you can carry out all the steps required to configure, optimize, and program a machine 
in order to complete a required task.                

 
Figure 3-1 Elements of the workbench in a LAD/FBD program 

The workbench contains the following elements: 
● (1) Project navigator 

The project navigator shows the entire project and its elements as a tree structure. 
● (2) Menu bar 

The menu bar contains menu commands which you can use to control the workbench, 
call up tools, etc. 
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● (3) Toolbars 
Many of the available menu commands can be executed by clicking the appropriate icon 
in one of the toolbars. 

● (4) Declaration tables 
Declaration tables are used for LAD/FBD units and programs. You define variables and 
constants in the declaration tables. 

● (5) Working area 
In this area, you carry out job-specific operations. The working area contains an 
LAD/FBD program, a declaration table, and an editor for graphical displays. 

● (6) Detail view 
More detailed information about the elements selected in the project navigator are 
displayed, e.g. the windows Symbol browsers, Compile/check output. 

3.2 Maximizing working area and detail view 
The windows working area and detail view can be set to maximum zoom.  
The selection is made under the following menu items: 
● View > Maximize working area (e.g., when creating programs) 

or  
● View > Maximized detail view (e.g., monitoring global variables) 

3.3 Enlarging and reducing the editor area for the graphical display 
The size of the graphical area of the LAD/FBD editor (i.e. the size of the elements in this 
area) can be changed using the Zoom list on the Zoom factor toolbar or using the View > 
Zoom in or View > Zoom out menu commands.    
Select a factor from the Zoom list, or enter an integer value of your own choice. This change 
always applies to the active LAD/FBD editor. 
This setting is not saved when a save operation is performed. 

3.4 Bringing the LAD/FBD editor to the foreground 
If several LAD/FBD editors are open in the working area, these are usually overlaid. This 
means that only the top LAD/FBD editor is visible. There are several ways to bring the 
concealed editors to the foreground.  
To bring the editor to the foreground, proceed as follows: 
1. Select the appropriate tab below the working window 

or 
Select the appropriate program name in the Window menu. 
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3.5 Hiding and displaying the declaration table 
If you need more space, you can hide the Interface (exported declaration) declaration area 
and/or the declaration area for a LAD/FBD program completely   
To hide and display the declaration table, proceed as follows: 
1. Double-click the separation line to hide the declaration table. 
2. In order to display the declaration line again, double-click the separation line again. 

3.6 Enlarging/reducing the declaration table 
To change the size of the declaration table, proceed as follows:   
1. Move the mouse cursor onto the separation line until the mouse pointer changes to a 

double line. 
2. Hold down the left mouse button and drag the separation line upwards in order to reduce 

the size of the declaration area. 
- or -  
In order to enlarge the declaration area, move the separation line downwards. 
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3.7 Operation 

3.7.1 Operating the LAD/FBD editor 
The LAD/FBD editor provides the programmer with a variety of different operator input 
options. Alternatives for executing individual operator inputs include the following: 
● The menu bar 
● Context menus 
● Toolbars 
● Key combinations 
● Text and variables can be dragged from the project navigator, declaration tables, symbol 

browser or command library and dropped into the input fields. 

3.7.2 Menu bar 
You can start all of the programming functions from the menu bar.      
The LAD/FBD program item only appears if a LAD/FBD editor is active in the working area. 

3.7.3 Context menu 
To use the context menu for an object, proceed as follows: 
1. Select the appropriate object with the left mouse button (left click). 
2. Briefly click the right mouse button. 
3. Left-click the appropriate menu item. 
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3.7.4 Toolbars 
The dynamic toolbars contain icons for important, frequently used functions, e.g. for inserting 
or saving elements.         
The "dynamic toolbar" changes depending on which workspace is active/selected,  
e.g., MCC chart, ST program or LAD/FBD program.  
The toolbars can be positioned as required within the Workbench. Once moved, they can be 
shown or hidden using View > Toolbars. 
The LAD/FBD editor toolbar contains the full range of LAD/FBD commands. The command 
list is displayed whenever the workspace for a program is active or open. 

 
① Insert LAD/FBD unit 
② Accept and compile 
③ Insert LAD/FBD program 

Figure 3-2 Picture of the toolbar for a LAD/FBD unit 

 

 
① Insert LAD/FBD program ⑧ Insert NO contact 
② Accept and compile ⑨ Insert NC contact 
③ Program status ⑩ Insert coil 
④ Symbol check and type update ⑪ Open branch 
⑤ Switch to FBD ⑫ Close branch 
⑥ Insert network ⑬ Insert comparator 
⑦ Jump label ON/OFF ⑭ Insert an empty box 

Figure 3-3 View of the LAD editor toolbar 
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① Insert LAD/FBD program ⑧ Insert AND box 
② Accept and compile ⑨ Insert OR box 
③ Program status ⑩ Insert assignment 
④ Symbol check and type update ⑪ Binary input 
⑤ Switch to LAD ⑫ Negate binary input 
⑥ Insert network ⑬ Insert comparator 
⑦ Jump label ON/OFF ⑭ Insert an empty box 

Figure 3-4 View of the FBD editor toolbar 

3.7.5 Key combinations 
Use the key combinations for fast operation in the LAD/FBD editor. The shortcuts  
(Page 327) available in the LAD/FBD editor are listed in the Appendix.    

3.7.6 Drag&Drop of variables 
Variables can be moved from the detail view (Symbol browser tab) to the input field using a 
drag-and-drop operation.    
To insert variables using drag&drop, proceed as follows:  
1. Left-click the line number of the variable you wish to move.  

The line with the variables is highlighted. 
2. Keeping the left mouse button depressed, drag the line number into the input field of the 

parameter screen form. 
3. Release the left mouse button. The variable is inserted at the selected position. 

3.7.7 Drag&drop from the declaration tables 
Variable names can be dragged from a declaration table and dropped into an LAD/FBD 
network.    
To insert variable names using drag&drop, proceed as follows:  
1. Left-click the line number with the name of the variable you wish to move. 

The line is shown on a black background. 
2. Continue to press the left mouse button as you drag the variable name to any input field. 
3. Release the left mouse button. 

The variable name is inserted at the selected position. 
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3.7.8 Drag&drop within the declaration table 
You can change the order of the variable declaration in the declaration table.    
To change the order using drag&drop, proceed as follows:  
1. Left-click the line number of the variable you wish to move. 

The line is shown on a black background. 
2. Press the Shift key and continue to press the left mouse button as you drag the line to the 

desired position in the declaration table. 
A red line indicates the point of insertion. 

3. Release the left mouse button. 
The line moves to the corresponding position. 

 

 
 

Note 
To move several adjacent lines together, hold the Shift key down as you select the lines 
you wish to move. 

 

3.7.9 Using Drag&Drop for LAD/FBD elements 
LAD/FBD elements can be inserted into the LAD/FBD network from the project navigator 
(Command library tab) using drag-and-drop.    
To insert LAD/FBD elements using drag&drop, proceed as follows:  
1. Left-click the required LAD/FBD element. 
2. Hold the left mouse button down and drag the LAD/FBD element into the ladder diagram 

line of the LAD/FBD network. 
3. Release the left mouse button. 

The LAD/FBD element is inserted at the selected position. 

3.7.10 Command call drag&drop 
Most commands in the command library can be inserted in LAD/FBD programs.    
For exceptions, see "Unusable command library functions (Page 84)". 
To insert command calls using drag&drop, proceed as follows:  
1. Left-click the required command call. 
2. Continue to hold the left mouse button down as you drag the command call to the 

LAD/FBD program. 
3. Release the left mouse button. 

The command call is inserted at the selected position. 

See also 
Unusable command library functions (Page 84) 
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3.7.11 Drag&Drop of command names 
Command names can be moved using Drag&Drop from the project navigator (tab Command 
library) into the input field of an empty box that has already been generated.    
To insert command names using drag&drop, proceed as follows:  
1. Left-click the required command name. 
2. Holding the left mouse button down, drag the command name into the input field of an 

empty box. 
3. Release the left mouse button. 

The command name is inserted at the selected position. 

3.7.12 Using drag&drop for elements in a network 
To insert elements in a network using drag&drop, proceed as follows:  
1. Left-click the required LAD element. 
2. To move an element, proceed as follows: 

Holding the left mouse button down, drag the element to the required position in the 
ladder diagram line. 

3. To copy an element, proceed as follows: 
Keeping the CTRL key depressed, drag the element with the left mouse button to the 
required position in the ladder diagram line. 

4. Release the left mouse button. 
The LAD element is inserted at the selected position. 

3.7.13 Using drag&drop for functions and function blocks from other sources 
Successfully compiled functions and function blocks from other units can be inserted into a 
ladder diagram line from the project navigator. The connection to the "original source" is 
automatically entered in the Connections tab of the current source file.      
To insert functions and function blocks using drag&drop, proceed as follows:  
1. Left-click the required FC/FB. 
2. Holding the left mouse button down, drag the FC/FB into the input field of an empty box. 
3. Release the left mouse button. 

An FC/FB call box is inserted. 
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3.8 Settings 

3.8.1 Settings in the LAD/FBD editor 
You can define the layout for creating a program in the LAD/FBD programming language. 
The automatic symbol check and type update are set by default in the LAD/FBD editor.        
1. To change the settings, select the Options > Settings > LAD/FBD editor menu command. 

3.8.2 Activating automatic symbol check and type update 
To enable automatic symbol check and type update, follow these steps: 
1. Select the Options > Settings menu item. 
2. Select the tab LAD/FBD editor. 
3. Activate the checkbox Automatic symbol check and type update. 
4. Confirm with OK. 

 

 Note 
The automatic symbol check and type update is activated by default in the LAD/FBD editor. 

 

If the symbol check is activated, the automatic symbol check and type update is performed 
for an LAD/FBD program if the following requirements are met: 
● changes are made in the project (see list below) which impact upon the LAD/FBD 

program 
● the focus is on the LAD/FBD program, i.e. it is opened in the KOP/FUP editor, or the 

LAD/FBD editor from the LAD/FBD program which is already open appears in the 
foreground (Page 22) 

 
In the event of subsequent changes within a project, automatic symbol check and type 
update is performed for an LAD/FBD program if the change affects the LAD/FBD program: 
● A program source is changed, e.g. deleted or renamed. 

The changes are only identified for associated program sources and their LAD/FBD 
programs when the changed program source is compiled. In other words, to enable the 
automatic symbol check and type update to take place, the changed program source 
must be compiled before the focus changes to an LAD/FBD program from an associated 
program source. 
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● The declaration tables in the LAD/FBD unit and/or from LAD/FBD programs within the 
LAD/FBD unit are changed. 
The symbol check/type update takes place for an LAD/FBD program belonging to the 
LAD/FBD unit if the changes affect that LAD/FBD program. 
The following cases are possible: 
– A declaration table is changed within an LAD/FBD program. 

The automatic symbol check and type update only takes place after changing from the 
declaration table to the network. 

– The change within a declaration table takes place within an LAD/FBD program and 
affects another LAD/FBD program within the same program source. 
The automatic symbol check and type update takes place when the focus is on that 
other LAD/FBD program. 

– Changes within a declaration table take place within a program source and affect an 
LAD/FBD program in another program source. 
The automatic symbol check and type update for the LAD/FBD program from another 
program source can only take place once the changed program source has been 
compiled. 

● A technology object (such as an axis) used by the LAD/FBD program is changed. 
The automatic symbol check and type update takes place when the focus is on the 
LAD/FBD program. 

 

 Note 
The term "LAD/FBD program" is a generic term and may refer to a program, a function (FC), 
or a function block (FB). 

 

If you click the mouse on the relevant place in the network (box parameter, input field, 
symbol highlighted in red) following a symbol check/type update, the tool tip indicates the 
following:      
● the expected data type among the box parameters 
● The data type of the variable with labeled input fields 
● the cause of trouble in symbols which are highlighted in red whereby the symbol errors 

may have the following reasons: 
– The specified symbol does not exist 
– The specified symbol is not visible in the current context (incorrect or missing entry of 

the connections in the declaration table) 
– The specified variable does not have the appropriate type 

 

 Note 
The symbol check is automatically updated as soon as the declaration table has been edited 
and left.  
All errors, including errors in the declaration table, are displayed in the detail view. 
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3.8.3 Example of a type update 

Introduction 
During the type update all the data types used are updated:  
● the list of permitted data types in an input field 
● an LAD/FBD program's box type, i.e. in terms of the creation type (program, FB or FC) 

selected for the LAD/FBD program 
● a box's interface in terms of the list of permitted data types per box parameter 
● other data types (structures, enumerations, etc.) 
For example, a structure AAA {a : BOOL} is used in an LAD/FBD program. If this structure is 
changed, e.g. AAA {a : BOOL, b : LREAL}, this change is applied by the LAD/FBD program 
during the type update. 

Initial situation 
The following are present: 
● an ST source ST_1 with a function block FB_1 
● an ST source ST_2 with a function block FB_2 
● an LAD/FBD unit LADFBD_1 with an LAD/FBD program PROGRAM_1 
● FB_1 is called within ST_2, i.e. a connection (Page 135) to ST_1 has to be declared in 

the ST_2 declaration table 
● FB_1 is called within PROGRAM_1, i.e. a connection (Page 135) to ST_1 has to be 

declared in the LADFBD_1 declaration table 
● FB_2 is called within PROGRAM_1, i.e. a connection (Page 135) to ST_2 has to be 

declared in the LADFBD_1 declaration table 
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How the type update works 
This is a special scenario where a program source (in this case LADFBD_1) imports another 
program source (in this case ST_1) both explicitly and by means of inheritance. Inheritance 
takes place via another imported program source (in this case ST_2) which, in turn, imports 
other sources (in this case ST_1).  

 
① LADFBD_1 explicitly imports ST_1 
② LADFBD_1 imports ST_1 by means of inheritance (ST_1 → ST_2 → LADFBD_1) 

Figure 3-5 Special scenario of explicit import and inheritance 

Changes are now made at the interface of the FB_1, for example one or more input/output 
parameters are added (see also interface adjustment in FB/FC (Page 158)) and ST_1 is 
recompiled. 
When PROGRAM_1 is opened in the LAD/FBD editor, the FB_1 call is automatically 
updated, i.e. a type update occurs via which the changed interface is updated.  
Despite the fact that the type update runs error-free, the compiler issues an error message 
during the compilation of LADFBD_1 because the import of ST_1 by inheritance via the 
imported ST_2 presupposes that ST_2 is also recompiled.  
In order to recompile ST_2 without errors, the changed interface of the FB_1 call must be 
updated manually within ST_2. 

 

 Note 
If program sources are imported which import other program sources themselves 
(inheritance), an error message may be output by the compiler during the compilation of the 
program source which is being imported, even if the type update runs error-free. 
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3.8.4 Example of a symbol check 

Introduction 
During the symbol check, the symbols used in the network are checked in context. 
For example, the network includes a box with a BOOL-type input. An LREAL-type variable is 
now assigned to this input. The symbol check determines that this variable cannot be used in 
this context and, therefore, flags up this variable in red. 

Initial situation 
The following are present: 
● an ST source ST_1 with the unit variable VAR_1 
● an LAD/FBD unit LADFBD_1 with an LAD/FBD program PROGRAM_1 
● the unit variable VAR_1 is used within PROGRAM_1, i.e. a connection (Page 136) to 

ST_1 has to be declared in the LADFBD_1 declaration table 

How the symbol check works 
The unit variable VAR_1 is now changed, e.g. the name is changed. 
If ST_1 is recompiled after this change, the unit variable VAR_1 is invalid in LADFBD_1.  
When PROGRAM_1 is opened in the LAD/FBD editor, an automatic symbol check is 
performed, i.e. the changed variable is highlighted in red lettering. 
The changed variable must be updated manually in PROGRAM_1. 

3.8.5 Deactivating automatic symbol check and type update 
The automatic update of the symbol check and type database should only be deactivated if 
computation speed is unduly reduced, e.g. if a large project is being processed on a slow 
computer and the hourglass is displayed after any change in the declaration table or in 
referenced external source files.      
To deactivate automatic symbol check and type update, proceed as follows:  
1. Select the Options > Settings menu item. 
2. Select the tab LAD/FBD editor. 
3. Deactivate the checkbox Automatic symbol check and type update. 
4. Confirm with OK. 

 

 
 

Note 
If the automatic symbol check is deactivated, the display may sometimes be inaccurate, 
e.g. after an external call-up has been inserted, the call-up box interface may be 
incorrectly displayed (i.e. not updated), or not displayed at all. This is because the current 
information only becomes available to the LAD/FBD editor after the Symbol check and 
type update symbol has been clicked, or the corresponding menu selected. 
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3.8.6 Perform symbol check and type update at a specified time 
To perform a symbol check at a specified time, proceed as follows: 
1. Select the LAD/FBD program > Automatic symbol check and type update menu item. 

or 
Click the Check symbols icon. 

3.8.7 Setting the data type list of the declaration table 
In the declaration area, all function blocks of the project not used in the program are stated in 
the list of data types by default.    
To improve clarity, it is possible to set that only those function blocks are displayed for which 
an entry in the Connections tab exists.  
To set the data type display, proceed as follows: 
1. Select the Options > Settings menu item. 
2. Select the tab LAD/FBD editor. 
3. Click the Only known types if type lists exist check box. 
4. Confirm with OK. 

3.8.8 Modifying the operand and comment fields 
Use the following procedure to modify the display options for the operand and comments:     
1. Select the Options > Settings menu command. 
2. Select the LAD/FBD editor tab. 
3. Enter the Number of characters per line for the operand and comment fields. 
4. Enter the Number of lines for the operand and comment fields. 
5. Confirm withOK. 
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3.8.9 Changing fonts 
Use the following procedure to change the font of the LAD/FBD editor:     
1. Select the Options > Settings menu command. 
2. Select the LAD/FBD editor tab. 
3. Click the Fonts and colors button. 

The Fonts and colors dialog box with the Fonts tab appears. 
4. Select the font, font size, type, or display you require. 

 
Figure 3-6 Fonts and colors dialog box 

5. Confirm with OK. 
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3.8.10 Changing colors 
Use the following procedure to change the colors of the LAD/FBD editor:     
1. Select the Options > Settings menu command. 
2. Select the LAD/FBD editor tab. 
3. Click the Fonts and colors button. 

The Fonts and colors dialog box appears. 
4. Click the Colors tab. 
5. Select the required color. 

 
Figure 3-7 Fonts and colors dialog box 

6. Confirm with OK. 
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3.8.11 Activating on-the-fly variable declaration 
When variable declaration is activated, a dialog box appears when an unknown symbol is 
entered in the LAD or FBD diagram. 
To activate on-the-fly variable declaration, proceed as follows:     
1. Select the Options > Settings menu command. 
2. Select the LAD/FBD editor tab. 
3. Activate the on-the-fly variable declaration checkbox. 
4. Confirm with OK. 

3.8.12 Setting the default language 
To set the default language, proceed as follows:    
1. Select the Options > Settings menu item. 
2. Select the tab LAD/FBD editor. 
3. Select the default language, e.g. LAD. 
4. Confirm with OK. 

When a new LAD/FBD program is created, the selected LAD language is set. 

3.8.13 Calling online help in the LAD/FBD editor 
The online help can provide assistance for many of the operating steps. Call up the online 
help using either the:    
● Help menu 

– Help topics 
– Context-sensitive help 
– Getting Started 

● General help with the F1 key 
● Help button, which appears in an open dialog box 
● Context-sensitive help with the Shift+F1 key combination or the arrow with question mark 

icon (also for LAD/FBD elements in a network). 
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LAD/FBD programming 4
4.1 Programming software 

This chapter describes the various operator control options in the LAD/FBD editor and the 
basic procedure for LAD/FBD programming. 

4.2 Managing LAD/FBD source file 
The LAD/FBD units are assigned to the SIMOTION device on which they will subsequently 
be run (e.g. SIMOTION C230). They are stored in the project navigator under the SIMOTION 
device in the PROGRAMS folder or in libraries.        
The individual program organization units (POU) are stored under a LAD/FBD source file. 

 

 Note 
ST source files or MCC source files are also stored. 
There is a description of the programming languages ST (Structured Text) and MCC (Motion 
Control Chart) in the SIMOTION ST and SIMOTION MCC Programming Manuals. 
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4.2.1 Inserting a new LAD/FBD source file 
There are several ways of how to insert a new LAD/FBD source file.     
To insert a LAD/FBD source file, proceed as follows: 
1. In the project navigator, double-click the Insert LAD/FBD source file element in the 

PROGRAMS folder. 
- or - 
Select the Insert > Program > Insert LAD/FBD source file menu item. 
- or - 
In the context menu (PROGRAM folder must be selected), select Insert new object > 
Insert LAD/FBD unit. 

2. Enter the name of the LAD/FBD unit. 
The names of program sources must comply with the rules for identifiers: They consist of 
letters (A to Z, a to z), numbers (0 to 9), or single underscores (_) in any order, whereby 
the first character must be a letter or an underscore. No distinction is made between 
uppercase and lowercase letters. 
The permissible length of the name depends on the SIMOTION Kernel version: 
– SIMOTION Kernel Version V4.1 and higher: maximum 128 characters. 
– SIMOTION Kernel Version V4.0 and lower: maximum 8 characters. 
Names must be unique within the SIMOTION device. Protected or reserved identifiers 
(Page 329) are not allowed. The LAD/FBD programs already available are displayed. 

3. In the Compiler tab, activate checkbox Permit program status to use the online status 
display. 

4. You can also enter an author, version, and a comment. 



 LAD/FBD programming 
 4.2 Managing LAD/FBD source file 

SIMOTION LAD/FBD 
Programming and Operating Manual, 05/2009 41 

5. Select the Open editor automatically checkbox. 

 
Figure 4-1 Insert LAD/FBD source file dialog box 

6. Confirm with OK. 
The Declaration tables dialog box is displayed. 

 
Figure 4-2 Declaration tables for exported and source-internal declarations 
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4.2.2 Opening an existing LAD/FBD source file 
All existing LAD/FBD source files are stored in the PROGRAMS folder in the project 
navigator. 
To open an existing LAD/FBD source file, proceed as follows: 
1. Double-click the name of the source file 

or 
Select the LAD/FBD source file and select the Open menu item in the context menu. 
The LAD/FBD source file (declaration tables) is opened in the workspace. Several 
LAD/FBD source files can be opened at the same time. 

4.2.3 Saving and compiling a LAD/FBD source file 

Prerequisites: 
Ensure that the LAD/FBD source file or one of the associated LAD/FBD programs is the 
active window in the workbench.       
To save a LAD/FBD source file and all its associated LAD/FBD programs in the project and 
start the compiler: 
1. Select the Save and compile symbol in the LAD/FBD editor toolbar. 

- or - 
Select the LAD/FBD source file > Save and compile menu item. 
- or - 
Select the LAD/FBD source file or a LAD/FBD program in the project navigator and select 
Save and compile in the context menu. 

 

 
 

Note 
Save and compile only applies the changes to LAD/FBD source files and associated 
LAD/FBD programs in the project. The data are not saved to disk, together with the 
project, unless you select Project > Save or Project > Save and compile all. 

 

A LAD/FBD source file can also be saved outside the project (exported). 
Error messages and warnings relating to compilation are displayed in the Compile/check 
output tab in the detail view. 
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4.2.4 Closing a LAD/FBD source file 
To close a LAD/FBD source file opened in the working window, proceed as follows: 
1. Click the x button (cross) in the title bar of the dialog box of the LAD/FBD source file 

or 
Select the LAD/FBD source file > Close menu item. 
or 
Select Windows > Close all windows menu item. 
If the changes have not yet been saved in the project, you can save or cancel them, or 
abort the close operation. 

4.2.5 Cut/copy/delete operations in a LAD/FBD source file 
A LAD/FBD source file can be cut or copied together with all its associated LAD/FBD 
programs and inserted in the same or another SIMOTION device.        
It is not possible to insert a LAD/FBD source file that has been deleted. 
To cut, copy or delete, proceed as follows: 
1. In the project navigator, select the required LAD/FBD source file. 
2. In the context menu, select the appropriate item (Cut, Copy, or Delete). 
3. Change the name, if necessary (refer to "See also"). 

See also 
Renaming a LAD/FBD source file (Page 47) 

4.2.6 Inserting a cut or copied LAD/FBD source file 
To insert a cut or copied LAD/FBD source file:    
1. Under the SIMOTION device, select the PROGRAMS folder. 
2. In the context menu, select Insert. 

The LAD/FBD source file is inserted under a new name. 
3. If required, amend the name. 

4.2.7 Know-how protection for LAD/FBD source files 
You can protect LAD/FBD units against being accessed by unauthorized third parties. 
Protected LAD/FBD units and all associated LAD/FBD programs can only be opened or 
viewed with a password.    
The SIMOTION online help provides additional information on know-how protection. 
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4.3 Exporting and importing LAD/FBD source files 
The export and import functions offer you the option of saving a LAD/FBD source file outside 
the project on your hard disk so that you can copy it from there into another project.  

4.3.1 Exporting a LAD/FBD source file in XML format 
 

 Note 
Structures (e.g. several POUs in one unit, advance binary switching) can be used with 
SIMOTION Kernel Version V4.1 and higher. These structures may not be supported by 
previous versions.    

 

You can use an XML export to save an LAD/FBD unit in a directory outside the project, 
independently of any particular version or platform. 
To export a LAD/FBD source file in XML format: 
1. In the project navigator, select the required LAD/FBD source file. 
2. In the context menu, select Experts > Save project and export object or the Project > 

Save and export menu. 
3. Select the directory for the XML export and confirm with OK. 

 

 
 

Note 
LAD/FBD units with know-how protection can also be exported in XML format. The know-
how protection is retained during the import. 

 

4.3.2 Importing LAD/FBD source files as XML data 
To import a LAD/FBD source file in XML format: 
1. In the project navigator, select the PROGRAMS entry or a LAD/FBD source file. 
2. In the context menu, select Import object or Expert > Import object. 
3. Select the XML data to be imported and click OK to confirm. 

The LAD/FBD source file is inserted. 
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4.3.3 Exporting a POU in XML format 
 

 Note 
Structures (e.g. several POUs in one unit, advance binary switching) can be used with 
SIMOTION Kernel Version V4.1 and higher. These structures may not be supported by 
previous versions.    

 

You can use an XML export to save individual program organization units in a directory 
outside the project, independently of any particular version or platform. 
To export a POU in XML format, proceed as follows:  
1. In the project navigator in the LAD/FBD unit, select the POU you want to export. 
2. In the context menu, select Export as XML. 
3. Select the directory for the XML export and confirm with OK. 

4.3.4 Importing a POU from XML format 
To import a POU in XML format, proceed as follows:    
1. In the project navigator, select the PROGRAMS entry or a LAD/FBD unit. 
2. In the context menu, select Import object. 
3. Select the XML data to be imported and click OK to confirm. 

The POU is inserted. 

4.3.5 Exporting a LAD/FBD source file in EXP format 
To export an LAD/FBD unit in EXP format, proceed as follows:     
1. In the project navigator, select the required LAD/FBD unit. 
2. Select the context menu Experts > Export as .EXP. 
3. Enter the path and the name for the EXP export. 
4. Click Save. 

An EXP file is saved under the specified name in the specified path. 
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4.3.6 Importing EXP data into a LAD/FBD source file 
To import EXP data into a LAD/FBD source:     
1. In the project navigator, select the required LAD/FBD program. 
2. Select the context menu Expert > Import from .EXP. 
3. Select the EXP file to be imported. 

 

 
 

Note 
Note the following when importing EXP data: 
• It is possible to import from XOR to FBD 
• Preconnection with simple data types (signal connection) is not generally supported. 
• The original structure is retained when you import data from EXP files. If the structure 

cannot be compiled due to type conflicts, the relevant parameters are highlighted in 
red.  
A type conflict can be resolved by manual revision. 
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4.4 LAD/FBD source files - defining properties 

4.4.1 Defining the properties of a LAD/FBD source file 
The properties of a LAD/FBD source file are specified when it is inserted.  
However, the properties can be viewed and modified by doing the following: 
1. In the project navigator, select the required LAD/FBD source file. 
2. From the context menu, select Properties. 

 
Figure 4-3 Properties of a LAD/FBD source file 

4.4.2 Renaming a LAD/FBD source file 
To rename a LAD/FBD source file:    
1. Open the Properties window of the LAD/FBD source file. 
2. Click . 
3. Confirm the message with OK and enter the new name in the New name input field of the 

Change Name dialog box. 
4. Acknowledge the entries with Apply. 
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4.4.3 Making settings for the compiler 
You can define the compiler settings as follows: 
● globally for the SIMOTION project, applicable to all programming languages, see Global 

compiler settings (Page 48)  
● locally for an individual LAD/FBD source within the SIMOTION project, see Local 

compiler settings (Page 49)  

4.4.3.1 Global compiler settings 
The global setting are valid for all programming languages within the SIMOTION project.   

Procedure 
1. Select the menu Tools > Settings. 
2. Select the Compiler tab. 
3. Define the settings according to the following table. 
4. Confirm with OK. 

 
Figure 4-4 Global compiler settings 

Parameters 
For more information about the parameter description of global compiler settings, see the 
SIMOTION ST Programming and Operating Manual. 
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4.4.3.2 Local compiler settings 
Local settings are configured individually for each LAD/FBD source file; local settings 
overwrite global settings.    

Procedure 
To select the compiler options, proceed as follows: 
1. Open the property view for the LAD/FBD unit (see Defining the properties of an LAD/FBD 

unit (Page 47)). 
2. Select the Compiler tab. 
3. Enter settings. 
4. Confirm with OK. 

 
Figure 4-5 Local compiler settings for LAD/FBD source files in the Properties window 

The current compiler options (the combination of global and local compiler settings which 
currently applies) for the program source are displayed on the Additional settings tab. The 
compiler options used the last time the program source was compiled can be seen on the 
Compilation tab.  
The SIMOTION ST Programming and Operating Manual contains additional information on 
what the compiler options mean. 
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Table 4- 1 Local compiler settings 

Parameters Description 
Ignore global settings See the description under Effectiveness of global or local compiler settings. 
Suppress warnings In addition to error messages, the compiler can output warnings. You can set the scope of 

the warning messages to be output: 
Active: The compiler outputs the warning messages according to the selection in the global 
settings of the warning classes. The checkboxes of the warning classes can no longer be 
selected. 
Inactive: The compiler outputs the warning messages according to the warning classes 
selected. 

Warning classes1 Only for Suppress warnings = inactive. 
Active: The compiler outputs warning messages of the selected class. 
Inactive: The compiler suppresses warning messages of the respective class. 
Grey background: The displayed global setting is adopted (only for Ignore global settings = 
inactive). 
For the meanings of warning classes, see the SIMOTION ST Programming and Operating 
Manual. 
Note: If "Suppress warnings" is active, the checkboxes can no longer be selected and show 
as activated against a gray background. 

Selective linking1 Active: Unused code is removed from the executable program. 
Inactive: Unused code is retained in the executable program. 
Grey background: The displayed global setting is adopted (only for Ignore global settings = 
inactive). 

Use preprocessor1    Active: The preprocessor is used (see SIMOTION ST Programming Manual). 
Inactive: Preprocessor is not used. 
Grey background: The displayed global setting is adopted (only for Ignore global settings = 
inactive). 

Enable program status1 Active: Additional program code is generated to enable monitoring of program variables 
(including local variables) (see Program status (monitor program execution) (Page 269)). 
Inactive: Program status not possible. 
Grey background: The displayed global setting is adopted (only for Ignore global settings = 
inactive). 

Permit language extensions1 Active: Language elements are permitted that do not comply with IEC 61131-3. 
• Direct bit access to variables of a bit data type (see example for ST programming 

language) 
• Accessing the input parameter of a function block when outside the function block (see 

example for ST programming language). 
• Calling a program while in a different program (see example for ST programming 

language) 
Inactive: Only language elements are permitted that comply with IEC 61131-3. 
Grey background: The displayed global setting is adopted (only for Ignore global settings = 
inactive). 
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Parameters Description 
Only create program 
instance data once1 

Active: The local variables of a program are only stored once in the user memory of the 
unit. This setting is required for calling a program while inside a different program. 
Inactive: The local variables of a program are stored according to the task assignment in 
the user memory of the respective task. 
Grey background: The displayed global setting is adopted (only for Ignore global settings = 
inactive). 
See Memory areas of the variable types. 

Enable OPC-XML Active: Symbol information for the unit variables of the ST source file is available in the 
SIMOTION device (required for the _exportUnitDataSet and _importUnitDataSet functions, 
see the SIMOTION Basic Functions Function Manual). 
Inactive: Symbol information is not created. 

1 Global setting is also possible ( Options > Settings > Compiler menu), see Global compiler settings (Page 48). Please 
also refer to the description of the effectiveness of global or local compiler settings. 

See also 
Meaning of warning classes 
Defining the properties of a LAD/FBD source file (Page 47) 
Program status (monitoring program execution) (Page 269) 
Global compiler settings (Page 48) 
Direct bit access to variables of a bit data type 
Effectiveness of global or local compiler settings 
Accessing the input parameter of a function block when outside the function block 
Calling a program while in a different program 
Memory ranges of the variable types 
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4.5 Managing LAD/FBD programs 
LAD/FBD programs are the individual program organization units (program, function, 
function block) in a LAD/FBD source file. They are stored under the LAD/FBD source file in 
the project navigator.  

4.5.1 Inserting a new LAD/FBD program 
To insert a new LAD/FBD program, proceed as follows: :     
1. Open the appropriate SIMOTION device in the project navigator. 
2. Open the PROGRAMS folder and a LAD/FBD source file. 
3. Double-click the entry Insert LAD/FBD program. 
4. Enter the name of the program in the Insert LAD/FBD program dialog box. 

The names must be unique within a source file. Protected or reserved identifiers 
(Page 329) are not allowed. LAD/FBD programs already available in the same source are 
displayed. 

5. Select Program, Function, or Function block as the Creation type. See also Changing the 
LAD/FBD program creation type (Page 58). 

6. Enter the name of the LAD/FBD program. 
The name of an LAD/FBD program can contain a maximum of 25 characters. The name 
of the program organization unit (POU) implemented in the LAD/FBD program object can, 
therefore, also be entered in accordance with this same restriction. Only one program 
organization unit per program object is permissible in the LAD/FBD program. 

7. For the Function creation type only: 
Select Return value data type as the Return type 
(<--> for no return value). 

8. Activate Exportable if you want the LAD/FBD program to be accessible from other 
program sources (LAD/FBD, MCC or ST sources) or from the execution system. 

9. Select the Open editor automatically checkbox. 
10. Confirm with OK. 
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Figure 4-6 Insert LAD/FBD program dialog box 

 
① Name of the LAD/FBD unit 
② Name of the LAD/FBD program 

Figure 4-7 Displaying the source file and program name in the project navigator 
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4.5.2 Opening an existing LAD/FBD program 
All LAD/FBD programs belonging to a LAD/FBD source file are located in the project 
navigator underneath the LAD/FBD source file. 
To open an available program, proceed as follows: 
1. Open the subtree of the appropriate SIMOTION device in the project navigator. 
2. Open the PROGRAMS folder and the desired LAD/FBD source file. 
3. Select the required LAD/FBD program. 
4. Select Open from the context menu. 

The LAD/FBD program opens in the working area. Several LAD/FBD programs can be 
opened at the same time. 

4.5.3 Defining the order of the LAD/FBD programs in the LAD/FBD source file 
LAD/FBD programs in the LAD/FBD unit are compiled and executed in the order in which 
they are displayed in the project navigator. It is thus sometimes necessary to change the 
order of the LAD/FBD programs. A POU (e.g., a function) must be defined before it is used.     
To change the order: 
1. Select a LAD/FBD program in the project navigator. 
2. In the context menu, select Up / Down 

4.5.4 Copying the LAD/FBD program 
To copy a LAD/FBD program: .   
1. In your LAD/FBD source file, select the POU you want to copy. 
2. In the context menu, select Copy. 
3. Select the LAD/FBD source file which is to be inserted in the POU. 
4. In the context menu, select Paste. 

The LAD/FBD program is inserted. 
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4.5.5 Saving and compiling a LAD/FBD program 
An asterisk is appended in the title bar of the project to the name of a program which has 
been modified but not yet saved.     

 

 Note 
The entire source file and its POUs are saved and compiled 

 

To save the LAD/FBD program and start the compilation: 
1. Click the Save and compile icon in the LAD/FBD editor toolbar. 

- or - 
Select the LAD/FBD program > Save and compile menu item. 
- or - 
Select the LAD/FBD program in the project navigator and select Save and compile in the 
context menu. 
- or - 
If you want to save and compile all available LAD/FBD programs, select the Project > 
Save and compile all menu item. 
If any errors occur during compilation, the error locations are displayed in the Detail view.     

2. To fix an error, double-click an error message in the detail view in the Compile / check 
output tab. 
The faulty element is selected and positioned in the window. 

 

 
 

Note 
Backward compatibility 
The present SCOUT program version supports structures (e.g. several POUs in one 
source file, advance binary switching) which may not be supported by previous versions.  
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4.5.6 Closing a LAD/FBD program 
To close a LAD/FBD program opened in the working window, proceed as follows: 
1. Click the x button (cross) in the title bar of the dialog box of the LAD/FBD program. 

or 
Select the LAD/FBD program > Close menu item. 
or 
Select the Windows > Close all menu item. 
If the changes have not yet been saved, you can save or cancel them, or abort the close 
operation. 

4.5.7 Deleting the LAD/FBD program 
To delete a LAD/FBD program:    
1. In the project navigator, select the required LAD/FBD program. 
2. In the context menu, select Delete. 

 

 
 

Note 
It is not possible to insert a LAD/FBD program that has been deleted. 
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4.6 LAD/FBD programs - defining properties 
The properties of a LAD/FBD program are specified when it is inserted.  
However, these properties can be viewed and modified by doing the following: 
1. Open the PROGRAMS folder and the desired LAD/FBD source file under the SIMOTION 

device. 
2. Select the required LAD/FBD program. 
3. From the context menu, select Properties. 

The Object properties dialog box opens. 

4.6.1 Renaming a LAD/FBD program 
To rename a LAD/FBD program:    
1. Open the property view for the LAD/FBD program. 
2. Click . 
3. Confirm the message with OK and enter the new name in the New name input field of the 

Change Name dialog box. 
4. Acknowledge the entries with Apply. 
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4.6.2 Changing the LAD/FBD program creation type 
To change the LAD/FBD program creation type:        
1. Select the new creation type: 

Program 
Programs can be compared with function blocks. Local variables can be stored here 
either statically or temporarily. In contrast to FBs or FCs, programs can be assigned to a 
task or an execution level in SIMOTION SCOUT.  
Programs cannot be called up with parameters. Therefore, unlike FBs and FCs, programs 
do not have any formal parameters. 
Function block (FB) 
A function block (FB) is a program with static data, i.e. all local variables retain their 
values after the function block has been executed. Only variables explicitly declared as 
temporary variables lose their value between two calls. 
Before an FB is used, an instance must be defined: Define a variable (VAR or 
VAR_GLOBAL) and enter the name of the FB as data type. The FB static data is saved in 
this instance. You can define multiple instances of an FB, with each instance being 
independent of the others. 
The static data of an FB instance are retained until the next time the instance is called; 
the static data are reinitialized when the variable type of the FB instance is reinitialized. 
Data transfer to the FB takes place via input or input/output parameters, and the data 
return from the FB takes place via input/output parameters or output parameters. 
Function (FC) 
A function (FC) is a function block without static data, that is, all local variables lose their 
value when the function has been executed. They are reinitialized the next time the 
function is started. 
Data transfer to the function takes place by means of input parameters; output of a 
function value (return value) is possible. 
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4.7 Printing source files and programs 
You can print general information about the LAD/FBD source files and programs. Various 
print options can be set for the printout.      
To print LAD/FBD units and programs, proceed as follows: 
1. Select a LAD/FBD source file or program in the project navigator. 
2. From the context menu, select Print or Print preview. 

The Print dialog box will appear, enabling you to set various print options. 

 
Figure 4-8 Dialog box for setting print options 

3. Click the Print button. 
The source file or LAD/FBD program is printed with the selected options. General 
information, the declaration table and diagram all appear in the printout. 
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4.7.1 Printing a declaration table 
To print a declaration table, proceed as follows:    
1. Activate the Print declaration table check box. 
2. Select Column widths by screen. 

The contents of the declaration table are printed with the set column widths. 
- or - 
Select Default column widths. 

4.7.2 Printing a network area 
To print a network area, proceed as follows:    
1. Activate the Print network area check box. 
2. Select All networks. 

- or - 
Select Selected networks only. 
Prints only the networks selected in the editor (blue selection mark on the left side). 

4.7.3 Printing comments 
You can only select this option if you have already selected the Print network area option. 
To print comments, proceed as follows:    
1. Activate the Print comments check box. 
2. To obtain a shorter, more concise print image, unselect the Print comments option. 
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4.7.4 Defining print variants 
To define the print variant, proceed as follows:   
1. Activate the check box. 
2. Select Scale graphics to page width. 

The print image is scaled so that the widest LAD/FBD network fits on one page width. 
The print image is one page in width and one or more pages in length, depending on the 
size of the program. 
- or - 
Select Scale graphics to page height. 
The print image is scaled so that the entire graphic fits on one page height. The print 
image is one page in length and takes up one or more page widths, depending on the 
width of the networks. 
- or - 
Select Scale graphics to one page. 
The print image is reduced so that all networks fit on one page. 
- or - 
Select Graphic at 100%. 
The image is printed in its original size. The print image can consist of more than one 
page vertically or horizontally. 
- or - 
Select Save screen zoom factor. 
The image is printed according to the zoom factor set in the editor. The print image can 
consist of more than one page vertically or horizontally. 

 

 
 

Note 
If the print image consists of more than one page, an index page is printed to give an 
overview. 
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4.7.5 Placing networks 
With Placing networks you define how the networks are distributed over the pages for 
printing. 
To place networks, proceed as follows:   
1. Activate the Place networks check box. 
2. Select Continuous. 

The networks are printed one after another. Page breaks are not taken into account in 
this case. 
- or - 
Select All on new page. 
All networks are printed beginning on a new page. If a network is longer than one page, it 
is printed on the next page. 
- or - 
Select Optimized. 
This minimizes the horizontal break between networks to save more space. E.g.: If a 
network does not fit on the current page and is not longer than one page, this network will 
be printed on the next page. If the network is longer, then a page break must be inserted.  

4.7.6 Blank pages 
You can select how blank pages are printed out. The layout is displayed on the index page. 
Pages marked with an X are omitted. 
To set the printing of blank pages, proceed as follows:   
1. Activate the Blank pages checkbox. 
2. Select Print all. 

All blank pages are printed. 
- or - 
Select Omit at end. 
Blank pages at the end are not printed. Blank pages in the middle are retained. 
- or - 
Select Omit all. 
Blank pages in the middle and at the end are omitted. 
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4.8 LAD/FBD networks and elements 
The LAD/FBD program is organized in networks which are displayed in the editor area. A 
network contains a logic circuit representing the ladder diagram line.    
The rules for the structure of a network according to IEC standard 61131-3 apply to the 
display of a network. Several LAD/FBD elements and boxes can be inserted, copied or 
deleted in a network.     

 
① Name of program and comment field ⑤ Network 2 
② Call box ⑥ Selected LAD element 
③ LAD element ⑦ Name of network and comment field 
④ Network 1 ⑧ Selected network 

Figure 4-9 Display of the networks in the LAD/FBD editor 

 

See also 
Numbering the networks (Page 65) 
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4.8.1 Inserting networks 
To insert a network:    
1. Select an existing network or click in the working window of the open LAD/FBD program. 
2. From the context menu, select Insert network. 

- or - 
Select the LAD/FBD program > Insert network. 
- or - 
Click the Insert network icon. 
The new network is inserted directly after the network which is currently selected. If no 
network is selected, the new network is inserted at the front. 

See also 
LAD/FBD networks and elements (Page 63) 

4.8.2 Selecting networks 
The relevant networks have to be selected before they can be copied. 
To select networks:    
1. Select the desired network. 

The network is selected (see figure). 
- or - 
If you want to select several adjacent networks, click the first required network and then, 
keeping the Shift key depressed, click the last one required. 
- or - 
If you want to select several networks which are not adjacent to one another, hold the Ctrl 
key down and click each network you need. 
 

Selected networks are indicated by a light blue edge on their left-hand side. You can choose 
the selection color in the LAD/FBD editor tab of the Settings dialog box. 
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Figure 4-10 Selected network 

See also 
Settings in the LAD/FBD editor (Page 29) 

4.8.3 Numbering the networks 
When a network is inserted, it is automatically given the next consecutive number. This 
number is unique and is used to identify the network.   

 

 Note 
You cannot change the numbering. When a network is deleted, the numbering is 
automatically adjusted. 

 

See also 
LAD/FBD networks and elements (Page 63) 
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4.8.4 Enter title/comment 

Titles and comments    
By default, the LAD/FBD program and/or the network contain a title and a comment field. 
The title and comment texts are language-dependent. 

Language-dependent texts    
You can use the Project > Language-dependent texts menu item to import and export ASCII 
files containing translations of LAD/FBD network comments and symbol browser comments 
(I/O variables, global device variables).  
The exported files (Export button) can be re-imported into the project using the import 
function (Import button) once they have been translated.  
After a language change, the user-defined comments in the project are available in the 
respective compiled languages. 

Assigning a title    
The title/name is used for the documentation of the LAD/FBD program or network. It is 
initialized with the name "Title".  
To enter a title, proceed as follows: 
1. Click in the title line. 
2. Enter a different title/name in the window which appears. 

There is no maximum text length. The length of text visible on the screen depends on the 
font, font size and screen resolution. 

Entering/modifying comments      
You can enter a comment in every program or network. 
To enter a comment, proceed as follows: 
1. Click in the comment line. 
2. Enter the text of the comment in the window which appears. 
3. To change an existing comment, double-click the existing comment. 
4. Overwrite the now selected text. 
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Showing/hiding a comment line    
In every program/network, you can hide a comment that has been entered: 
To hide and show comments, proceed as follows: 
1. Click in the working window of the open LAD/FBD program. 
2. From the context menu, select Display > Comments on/off. 

- or - 
Select the LAD/FBD program > Display > Comments on/off menu item. 
This setting is also saved when storing. 

4.8.5 Showing/hiding a jump label 
You can insert a jump label in every network.   
To insert or hide jump labels, proceed as follows: 
1. Select the network in which the jump label is to be inserted. 
2. From the network context menu, select Jump label ON/OFF. 
3. Enter the text of the jump label in the window that appears. 

Only alphanumeric characters and underscores are allowed during input. The text length 
of a label must not exceed 480 characters. 

 

 
 

Note 
The jump label is deleted if it contains an error and cannot be corrected. 

 

4. If you want to hide a jump label, select the required jump label and select Jump label 
ON/OFF in the context menu. 

See also 
Overview of jump operations (Page 223) 
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4.8.6 Copying/cutting/pasting networks 
If a network is copied or cut, and then inserted again, all LAD/FBD elements in the network 
are taken with it.        
To copy a network, proceed as follows: 
1. Select the required network. 
2. In the context menu, select Copyor Cut. 

- or - 
Select the Edit > Copy or Edit > Cut menu item. 
The copied network can be inserted again at any place or even in other LAD/FBD 
programs. 
A new/copied or cut network is always inserted after the selected network. If no network 
is selected, the new network is placed as the first network.  

4.8.7 Undo/redo actions 
 

 Note 
The following actions cannot be undone: 
- Save 
- Save and compile 

 

To undo or redo actions, proceed as follows:    
1. Select the Edit > Undo menu command or the Undo symbol. 

The actions are undone in reverse order. 
2. If you want to redo one or more undone actions, select the Edit > Redo menu item or the 

Redo icon. 

4.8.8 Deleting networks 
To delete a network:    
1. Click in a network in the open LAD/FBD program. 
2. From the context menu, select Delete network. 
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4.9 Displaying LAD/FBD elements 

4.9.1 LAD diagram 

LAD diagram   
The LAD diagram complies with Standard IEC 61131-3 and is organized around the binary 
ladder diagram line. The ladder diagram line begins with a vertical line (conductor bar) and 
ends with a coil, call-up (box) or with a jump to another network. In between, there are 
special LAD elements (NO contacts, NC contacts, connectors), general logical elements 
(SR, RS flipflop), system components call-ups (e.g arithmetic operations), and user functions 
or function blocks.      

Rules for entering LAD statements   
● Start of a LAD network 

The left conductor bar is the network's starting point. Crossed lines are not permitted in a 
LAD diagram. The following elements are not permitted at the beginning of a network: 
(P), (N), (#). 

● LAD network termination 
Every LAD network must terminate with a coil or a box. Multiple outputs are possible. 
The following LAD elements may not be used to terminate a network:  
– (P), 
– (N), 
– POS, 
– NEG, 
– Comparator. 

● Placement of empty boxes 
Empty boxes can be placed anywhere in a network except on the right-hand edge or in a 
parallel branch. Preconnection at binary inputs is supported. 

● Placement of coils 
Coils are automatically placed on the right-hand edge of the network, where they are 
used to terminate a branch. 
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● Parallel branches 
Parallel branches are  
– opened downward and closed upward. 
– opened behind the selected LAD element. 
– closed behind the selected LAD element. 
Another branch can be inserted between two parallel branches.  
To delete a parallel branch, you must delete all LAD elements of this branch.  
When the last LAD element is removed from the branch, the rest of the branch is also 
removed.  
The following elements are not permitted in the parallel branch:  
– (P), 
– (N), 
– (#), 
– Empty box. 
The following elements are permitted in the parallel branch:  
– Contacts, 
– Comparators, 
– Edge detection (POS, NEG). 
Parallel branches which branch directly off the power rail are an exception to these 
placement rules: All elements can be placed in these branches. 

● Constants and enums 
Binary operations can also be assigned constants (e.g. TRUE or FALSE).  
FB/FC parameters can be connected with constants that reflect the parameter data type. 
If a parameter is connected with an enum value that is not unique project-wide, preface 
the enum value with the enum type separated by #. 

4.9.2 Meaning of EN/ENO 

Enable input (EN) and enable output (ENO) of the LAD box 
The LAD box enable input (EN) and enable output (ENO) parameters function according to 
the following principles: . .    
● If EN is not enabled (i.e., the signal is set to "0"), then the box will not execute its function, 

and ENO is not enabled (i.e., the signal is also "0"). 
● If EN is enabled (i.e., the signal is set to "1"), then the appropriate box executes its 

function, and then ENO is also enabled (i.e., the signal is also "1"). 
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4.9.3 FBD diagram 

FBD diagram   
An FBD diagram complies with IEC standard 61131-3. 
The main binary signal line begins with a logic box (top left) and ends with an assignment, 
call (box), or with a jump to another network. In between, there are logic elements (AND, OR 
box), general logic elements (SR, RS flip-flop), system component call-ups (e.g. arithmetic 
operations), and user function or function block call-ups. 

Rules for entering FBD statements   
● Placement of boxes 

Empty boxes (flipflops, counters, timers, arithmetic operations, device-specific 
commands, TO-specific commands, etc.) can be attached to boxes with binary 
connections (&, =1, XOR). 
Preconnections on binary inputs (e.g. S input on flipflop) are allowed. 
Separate connections with separate outputs cannot be programmed in a network. 
Junctions are not supported. 

 
Figure 4-11 FBD with binary preconnection 

● &, >=1, XOR boxes 
Binary inputs can be inserted, deleted, or negated in these boxes. 

● Enable input/enable output 
Connection of the enable input EN and/or the enable output ENO of boxes is possible. 

● Constants and enums 
Binary operations can also be assigned constants (e.g. TRUE or FALSE).  
FB/FC parameters can be connected with constants that reflect the parameter data type. 
If a parameter is connected with an enum value that is not unique project-wide, preface 
the enum value with the enum type separated by #. 
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4.9.4 Converting between LAD and FBD representation 

Converting from LAD to FBD representation 
To switch from LAD to FBD representation, proceed as follows:    
1. Open an existing LAD project. 
2. Select the LAD/FBD program > Switch to FBD menu item. 

- or - 

Click the  button for "Switch to FBD" (Ctrl+3 shortcut) in the LAD editor toolbar. 
The project is now displayed in the FBD programming language. 

 
Figure 4-12 Switching from LAD to FBD 

 

 
 

Note 
A conversion sequence of LAD - FBD - LAD always produces the original network. 
Anything generated in LAD can always be displayed in FBD. 
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Converting from FBD to LAD representation 
To switch from FBD to LAD representation, proceed as follows:    
1. Open an existing FBD project. 
2. Select the LAD/FBD program > Switch to LAD menu command. 

- or - 

Click the  button for "Switch to LAD" (Ctrl+1 shortcut) in the FBD editor toolbar. 
The project is now displayed in the LAD programming language. 

 
Figure 4-13 Switching from FBD to LAD, example with OR box 

 

 
 

Note 
A conversion sequence of FBD- LAD- FBD only produces the original LAD network if the 
FBD structure can be converted to LAD. 
Something generated in FBD cannot always be displayed in LAD. 

 

Example of a non-convertible FBD structure 

 
Figure 4-14 FBD structure with binary XOR box 
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4.10 Editing LAD/FBD elements 

4.10.1 Inserting LAD/FBD elements 
LAD/FBD elements are usually inserted to the right of the selected position in the network.    
FBD elements are usually inserted at a boolean input of a block or at an assignment (left). 
Special case: 
If the right-hand edge of a network or a coil (LAD) or an assignment (FBD) is selected, the 
next element is added in the network on the left-hand side of it. 
To insert LAD/FBD elements: 
1. Select the position in a network behind which you want to insert a LAD/FBD element. 
2. Insert the LAD/FBD element: 

– Via the icons on the toolbar 
– Using the menu item, e.g., LAD/FBD program > Insert element > Empty box 
– With a drag&drop operation from the Command library tab 
– By double-clicking the element in the Command library tab 
– By selecting the element in the Command library tab and confirming with the Enter key 
The selected LAD/FBD element is inserted and the placeholders and ... are inserted for 
variables and parameters. 

 

 
 

Note 
A red ??? symbol indicates mandatory parameters that must be connected. 
A black ... symbol indicates optional parameters that can be connected. 
Move the cursor over the parameter name to display the expected data type. 

 



 LAD/FBD programming 
 4.10 Editing LAD/FBD elements 

SIMOTION LAD/FBD 
Programming and Operating Manual, 05/2009 75 

4.10.2 Syntax check in LAD 
An automatic syntax check during input prevents the incorrect placement of elements.    
● NOT in parallel branch 
● FB/FC call in parallel branch 
● Connector in parallel branch 
● Check 0 -> 1 edge and 1 -> 0 edge in parallel branch 
● XOR in parallel branch 

 
Figure 4-15 Syntax check 

4.10.3 Selecting LAD/FBD elements 
LAD/FBD networks must be selected before they can be deleted, for example. 
To select LAD elements, proceed as follows:    
1. Click the required LAD/FBD element. 

The LAD/FBD element is selected (see following Fig.). 
- or - 
If you want to select several LAD/FBD elements, click the required LAD/FBD elements 
keeping the Shift key depressed. 
Selected LAD/FBD elements are shown with a thick blue outline. You can choose the 
selection color in the LAD/FBD editor tab of the Settings dialog box. 

 
Figure 4-16 Selected LAD/FBD elements 
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4.10.4 Copy/cut/delete operations in LAD/FBD elements 
To copy/cut/delete, proceed as follows:        
1. Select a LAD/FBD element. 
2. In the context menu or in the Edit  menu, select e.g. Copy. 

The copied/cut LAD/FBD element can be inserted into other LAD/FBD programs. 
If you delete an FB/FC box with binary preconnections, this results in several open 
branches (in LAD) or sub-networks (in FBD) which can be further connected. 

4.10.5 LAD/FBD elements - defining parameters (labeling) 
To label the elements, proceed as follows:    
1. Click the parameter. 
2. Label the parameter: 

– Select the corresponding parameter from the pull-down menu (for box-type only). 
- or - 

– Enter the appropriate variable. 
- or - 

– Drag the corresponding variable from the declaration table using a drag-and-drop 
operation. 

3. Confirm the entry with the Return key. 

See also 
Setting call parameters (Page 79) 
Defining global user variables and local variables in the variable declaration dialog box 
(Page 108) 
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4.10.6 Labeling LAD/FBD elements with the symbol input help dialog 
To label the element with the Symbol input help, proceed as follows:    
1. Select the parameter you want to label. 
2. Right-click to open the context menu. 
3. Click the Symbol input help menu. 

- or - 
Select the symbol input help with the key shortcut CTRL+H. 
The Symbol input help dialog box opens. The tree structure shows all variables which 
exist in the project and which can be used. 

4. Select the desired variable and click OK to confirm. 
The label is entered in the selected parameter. 

4.10.7 Setting the LAD/FBD element display 
In order to ensure a manageable view of relatively large call boxes, you can set the display 
mode of LAD/FBD elements.   
To set the LAD/FBD element display, proceed as follows: 
1. Click in the editor area of the LAD/FBD program. 
2. Select the required display mode: 

– In the context menu, select View > No box parameters or the LAD/FBD program > 
View > No box parameters menu item. 
- or - 

– In the context menu, select View > Only assigned box parameters or the LAD/FBD 
program > View > Only assigned box parameters menu item. 
- or - 

– In the context menu, select View > Mandatory and assigned box parameters or the 
LAD/FBD program > View > Mandatory and assigned box parameters menu item. 
- or - 

– In the context menu, select View > All box parameters or the LAD/FBD program > 
View > All box parameters menu item. 
This box parameter setting is also saved when storing. 

 

 
 

Note 
If a call box has non-represented parameters, this is indicated by ... at the bottom of 
the box. 
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4.10.8 Setting the call parameter for an individual parameter 
To set an individual call parameter, proceed as follows:    
1. Double-click the parameter input/output you want to set. 

The Enter call parameter for individual parameter dialog box appears. 

 
Figure 4-17 Dialog box for setting an individual call parameter 

2. Assign a variable or value to the parameter from the Values list. 
3. Confirm your selection twice with the Enter key to close the dialog box again. 
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4.10.9 Setting call parameters 
To set the call parameters, proceed as follows:    
1. Label the type parameters of the box. 
2. Double-click the box. 

- or - 
In the context menu, select Call parameters .... 
The Enter call parameters dialog box appears. 
Only variables which have already been declared and symbols/variables offered by the 
system are displayed. 

 
Figure 4-18 Dialog box for setting call parameters 
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3. Enter: 
– Return value 

Here you assign the function return value to a variable of the calling program. 
– Instance 

Here, you enter the instance of the function block. 
– Value 

Here, you can assign current variables or values to the parameters. 
4. Confirm with OK. 

 

 
 

Note 
The Value list includes all symbols which are visible in the current target (variables, enum 
values, etc.) whose type matches the data type of the parameter. Implicit data type 
conversion is taken into consideration here. You can select a symbol from the list or type 
one in yourself. 
The value of string constants must be entered in inverted commas  
(e.g. 'st_until') 

 

4.10.10 Searching in the project 

Searching for elements in the project 
To search for elements in a project, proceed as follows:    
1. Select the Search in Project menu item in the Edit menu. 
2. The Search in Project dialog box opens. 
3. Enter your search term. 
4. Limit your search, if necessary, using a filter or restrict it to specific objects. 
5. Click on the Search button to start your search. 

The search result is displayed in the Search results table in the workbench. 
6. If you double-click on a search result, the located element is displayed in the editor. 
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4.10.11 Find and replace in a project 

Finding and replacing elements in a project  
In LAD/FBD, you can replace the following: 
● Variable names 
● All elements that appear in the Properties dialog box (e.g. an FC return value, etc.) 
To search for and replace elements in a project, proceed as follows:    
1. Select the Replace in Project menu item in the Edit menu. 
2. The Replace in Project dialog box opens. 
3. Enter your search term. 
4. Enter the expression that should replace the term you are searching for. 
5. Limit your search, if necessary, using a filter or restrict it to specific objects. 
6. Click on the Search button to start your search. 

The search result is displayed in the Search result table in the workbench. 
The elements which can be replaced are identified by a check mark. 

7. If you wish to replace all marked elements, click on the Replace button in the search 
results. 
All elements are replaced with the expression you entered. 

8. If you only wish to replace specific elements, unmark the other elements and then click 
on the Replace button. 
Only the marked elements are replaced. 

 

 
 

Note 
If you wish to replace an element with an invalid element, LAD/FBD outputs an error 
message in the output list, which means the element was located and displayed in the 
list, but not replaced.  
You cannot place a checkmark in the checkbox. 

 

Constraints 
In general, you cannot replace an element with a new element if the new element cannot be 
entered (e.g., in the declaration table, you cannot replace VAR_GLOBAL with VAR because 
you cannot manually enter VAR there). 
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Constraints in the declaration table: 
● VAR, VAR_TEMP and VAR_GLOBAL cannot be freely exchanged for one another 

Constraints in the POUs: 
● The LAD and FBD elements listed in the command library cannot be freely replaced. 
● Comparators can only be exchanged among one another (e.g., "less equal" can be 

replaced with "more equal" or "equal", but not with a "XOR box", etc.). 
● The type of user FBs/FCs can only be replaced with another existing type of user 

FBs/FCs. 
● Mathematic functions can only be replaced with those that can also be entered manually 

(e.g., sin can be replaced with cos, but not with cmp) 
● "..." and "???" are generally not replaced. 
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4.11 Command library 

4.11.1 LAD/FBD functions in the command library 
The command library appears automatically as a tab in the project navigator. The command 
library stays open after the programming window is closed.   

 
Figure 4-19 Command library tab of the project navigator 
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4.11.2 Inserting elements/functions from the command library 
To insert elements/functions in a programming window, proceed as follows:   
1. Left-click the desired function in the command library, drag the function onto the editor 

window while keeping the left mouse button depressed and then release the left mouse 
button. 
- or - 
Double-click the desired function. 
- or - 
Select the desired function and press the Enter key. 

LAD/FBD elements are usually inserted to the right of the selected position in the network. 
FBD elements are usually inserted at a boolean input of a block or at an assignment (left). 

4.11.3 Unusable command library functions 
 
Not all of the ST programming functions are used in the same way in the LAD/FBD 
programming language. For this reason, new functions with different parameters have been 
added ("TaskId" is used instead of "Task") and these are shown in the table below. The new 
commands are also library-capable. :   
The functions in the left column can be used in ST and LAD/FBD. (Extension of the ST 
function name with "id". Example: _alarmsc becomes _alarmscid).  
The ST functions in the right column cannot be used in the LAD/FBD programming 
language.  
These functions are grouped according to call syntax. 

Table 4- 2 List of compatible functions 

ST and LAD/FBD functions ST functions 
Functions for task control 
_getstateoftaskid 
_resettaskid 
_restarttaskid 
_resumetaskid 

_getstateoftask 
_resettask 
_restarttask  
_resumetask 

 

 
Functions for runtime measurement 
_getmaximaltaskidruntime 
_getminimaltaskidruntime 
_getcurrenttaskidruntime 
_getaveragetaskidruntime 

_getmaximaltaskruntime 
_getminimaltaskruntime 
_getcurrenttaskruntime 
_getaveragetaskruntime 
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Functions for message configuration 
_retriggertaskidcontroltime 
_starttaskid 
_suspendtaskid 
_alarmsid 
_alarmsqid 
_alarmscid 

_retriggertaskcontroltime 
_starttask 
_suspendtask 
_alarms 
_alarmsq 
_alarmsc 

4.11.4 Special features of the command library 

Special features 
The following ST commands have no corresponding function that can be used with 
LAD/FBD:   
● BOOL := _checkequaltask([IN]TASK, [IN]TASK) 

Two StructTaskID or two StructAlarmID can be compared to one comparator. 
● StructAlarmID := _getalarmid([IN]ALARM) 

These alarm commands can be found in the _alarm name space (_alarm.myalarm). 
● StructTaskID := _gettaskid([IN]TASK id:=TaskIdThis) 

The task commands can be found in the _task name space (_task.backgroundtask). 

Examples for parameters of type _alarmid and _starttaskid 

 
Figure 4-20 Examples for StructAlarmID 

 
Figure 4-21 Example for StructTaskID 
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4.12 General information about variables and data types 

4.12.1 Overview of variable types 
The following table shows all the variable types available for programming with ST.   
● System variables of the SIMOTION device and the technology objects 
● Global user variables (I/O variables, device-global variables, unit variables) 
● Local user variables (variables within a program, a function or a function block) 

System variables 
 
Variable type Meaning 
System variables of the 
SIMOTION device  
System variables of 
technology objects 

Each SIMOTION device and technology object has specific system variables. These can be 
accessed as follows: 
• Within the SIMOTION device from all programs 
• From HMI devices 
You can monitor system variables in the symbol browser. 
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Global user variables 
 
Variable type Meaning 
I/O variables You can assign symbolic variable names to the I/O addresses of the SIMOTION device or 

the peripherals. This allows you to have the following direct accesses to the I/O: 
• Within the SIMOTION device from all programs 
• From HMI devices 
You create these variables in the symbol browser after you have selected the I/O element 
in the project navigator. 
You can monitor I/O variables in the symbol browser. 

Global device variables User-defined variables which can be accessed by all SIMOTION device programs and HMI 
devices. 
You create these variables in the symbol browser after you have selected the GLOBAL 
DEVICE VARIABLES element in the project navigator. 
Global device variables can be defined as retentive. This means that they will remain stored 
even when the SIMOTION device power supply is disconnected. 
You can monitor global device variables in the symbol browser. 

Unit variables User-defined variables that all programs (programs, function blocks, and functions) can 
access within a unit (source file). 
You declare these variables in the declaration table of the source file: 
• In the interface section: 

After connection (see Define connections (Page 136)), these variables are also 
available in other units (e.g. MCC units, ST source files, and LAD/FBD source files), as 
well as on HMI devices (maximum size of the interface section: 64 Kbytes). 

• In the implementation section: 
You can access these variables only within the source file. 

You can declare unit variables as retentive. This means that they will remain stored even 
when the SIMOTION device power supply is disconnected. 
You can monitor unit variables in the symbol browser. 
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Local user variables 
 
Variable type Meaning 
 User-defined variables that can only be accessed within the program/chart (program, 

function, function block) in which they were defined. 
Variable of a program 
(program variable) 

Variable is declared in a program. The variable can only be accessed within this program. A 
differentiation is made between static and temporary variables: 
• Static variables are initialized according to the memory area in which they are stored. 

Specify this memory area by means of a compiler option. By default, the static variables 
are initialized depending on the task to which the program is assigned (see SIMOTION 
Basic Functions Function Manual). 

You can monitor static variables in the symbol browser. 
• Temporary variables are initialized every time the program in a task is called. 

Temporary variables cannot be monitored in the symbol browser. 
Variable of a function  
(FC variable) 

Variable is declared in a function (FC). The variable can only be accessed within this 
function. 
FC variables are temporary; they are initialized each time the FC is called. They cannot be 
monitored in the symbol browser. 

Variable of a function block 
(FB variable) 

Variable is declared in a function (FB). The variable can only be accessed within this 
function block. A differentiation is made between static and temporary variables: 
• Static variables retain their value when the FB terminates. They are initialized only when 

the instance of the FB is initialized; this depends on the variable type with which the 
instance of the FB was declared. 

You can monitor static variables in the symbol browser. 
• Temporary variables lose their value when the FB terminates. The next time the FB is 

called, they are reinitialized. 

Temporary variables cannot be monitored in the symbol browser. 

 
 
 



 LAD/FBD programming 
 4.12 General information about variables and data types 

SIMOTION LAD/FBD 
Programming and Operating Manual, 05/2009 89 

4.12.2 Scope of the declarations 

Scope of variable and data type declarations according to location of declaration   
 
Location of declaration What can be declared here Scope 
Symbol browser • Global device variables 

• I/O variables 
The declared variables are valid in all units (e.g., ST 
source files, MCC source files, LAD/FBD source files) 
of the SIMOTION device. All programs, function 
blocks, and functions in all units of the device can 
access the variables. 

Interface section of the unit1 • Unit variables 
• Data types 
• Symbolic accesses to the fixed 

process image of the 
BackgroundTask 

The declared variables, data types, etc., are valid in 
the entire unit (e.g., ST source file, MCC source file, 
LAD/FBD source file); all programs, function blocks, 
and functions within the unit can access them. 
In addition, they are also available in other units after 
connection (see Define connections (Page 136)). 

Implementation section of 
the unit1 

• Unit variables 
• Data types 
• Symbolic accesses to the fixed 

process image of the 
BackgroundTask 

The declared variables, data types, etc., are valid in 
the entire unit (e.g., ST source file, MCC source file, 
LAD/FBD source file); all programs, function blocks, 
and functions within the source file can access them. 

POU (program/ 
function block/ 
function)2 

• Local variables 
• Data types 
• Symbolic accesses to the fixed 

process image of the 
BackgroundTask 

The declared variables, data types, etc., can only be 
accessed within the POU in which they were 
declared. 

1 MCC and LAD/FBD programming languages: in the declaration table of the respective source file. 
2 MCC and LAD/FBD programming languages: in the declaration table of the respective chart/program. 

4.12.3 Rules for identifiers 
Names for variables, data types, charts/programs must comply with the following rules for 
identifiers:   
1. They are made up of letters (A to Z, a to z), numbers (0 to 9), and underscores ( _ ). 
2. The first character must be a letter or underscore. 
3. This can be followed by as many letters, digits or underscores as needed in any order. 
4. Exception: You must not use more than one underscore in a row 
5. Both upper and lower case letters are allowed. No distinction is made between upper and 

lower case notation (thus, for example, Anna and AnNa are regarded as identical). 
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4.12.4 Frequently used arrays in declarations 

4.12.4.1 Array length and array element 
An array is a chain of variables of the same type that can be addressed with the same name 
and different indices. ::      
You can define the variable as an array [0...N-1] by entering an array length N.  
You have the following options for entering the array length: 
● You can enter a constant positive integer value. 
● You can enter a value range with ".." separating the min. and max. values. 
● You can enter a constant expression of data type DINT (or of a data type that is implicitly 

convertible to DINT). 
If the array is empty, a single variable is set up rather than an array. 

Example definition of an array in the declaration table 

 
Figure 4-22 Defining the length of a field 

Example of use of field elements in a variable assignment 

 
Figure 4-23 Use of array elements in a variable assignment 
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4.12.4.2 Initial value 
You can specify an initialization value in this column. You can specify this initialization value 
as a constant or an expression. The following are permissible:        
● Constants 
● Arithmetic operations 
● Bit slice and data conversion functions 

Table 4- 3 Preassignment of array elements 

10(1) 10 array elements [0 to 9] are preset to the same value "1". 
1,2,3,4,5 5 array elements [0..4] are preset to different values "1", "2", "3", "4" and "5". 
5(3), 
10(99),3(7),2(1) 

5 array elements [0..4] are preset to the same value "3". 
10 array elements [5..14] are preset to the same value "99". 
3 array elements [15..17] are preset to the same value "7". 
2 array elements [18..19] are preset to the same value "1". 

 
Definition of these initialization values in the declaration table: 

 
Figure 4-24 Definition of the initialization values of an array 

Variables with technology object data types are always initialized with TO#NIL. 
For variables of data type followingAxis, select the associated synchronous object (variable 
of data type followingObjectType). 
 

4.12.4.3 Comments 
A comment can be entered in this column. It may contain any characters or special 
characters.   
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4.13 Data Types 

4.13.1 General 
A data type is used to determine how the value of a variable or constant in a program source 
file is to be used.  
The following data types are available to the user: 
● Elementary data types 
● User-defined data types (UDT) 

– Enumerators 
– Structures (Struct) 

● Technology object data types 
● System data types 
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4.13.2 Elementary data types 
Elementary data types define the structure of data that cannot be broken down into smaller 
units. An elementary data type describes a memory area with a fixed length and stands for 
bit data, integers, floating-point numbers, duration, time, date and character strings.    
All the elementary data types are listed in the table below: 

Table 4- 4 Bit widths and value ranges of the elementary data types 

Type Reserv. word Bit width Range of values 
Bit data type 
Data of this type uses either 1 bit, 8 bits, 16 bits, or 32 bits. The initialization value of a variable of this data type is 0.    

Bit BOOL   1 0, 1 or FALSE, TRUE 
Byte BYTE   8 16#0 to 16#FF 
Word WORD   16 16#0 to 16#FFFF 

 

Double word DWORD   32 16#0 to 16#FFFF_FFFF 
Numeric types 
These data types are available for processing numeric values. The initialization value of a variable of this data type is 0 (all 
integers) or 0.0 (all floating-point numbers).      

Short integer SINT   8 -128 to 127 (-2**7 to 2**7-1) 
Unsigned short integer USINT   8 0 to 255 (0 to 2**8-1) 
Integer INT   16 -32_768 to 32_767 (-2**15 to 2**15-1) 
Unsigned integer UINT   16 0 to 65_535 (0 to 2**16-1) 
Double integer DINT   32 -2_147_483_648 to 2_147_483_647 (-2**31 to 2**31-1) 
Unsigned double 
integer 

UDINT   32 0 to 4_294_96_7295 (0 to 2**32-1) 

Floating-point number  
(per IEEE -754) 

REAL   32 -3.402_823_466E+38 to -1.175_494_351E-38, 
0.0, 
+1.175_494_351E-38 to +3.402_823_466E+38 
Accuracy: 
23-bit mantissa (corresponds to 6 decimal places), 8-bit 
exponent, 1-bit sign. 

 

Long floating-point 
number  
(in accordance with 
IEEE-754) 

LREAL   64 -1.797_693_134_862_315_8E+308 to 
-2.225_073_858_507_201_4E-308,  
0.0, 
+2.225_073_858_507_201_4E-308 to 
+1.797_693_134_862_315_8E+308 
Accuracy: 
52-bit mantissa (corresponds to 15 decimal places), 11-bit 
exponent, 1-bit sign. 
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Type Reserv. word Bit width Range of values 
Time types 
These data types are used to represent various date and time values.     

Duration in increments 
of 1 ms 

TIME   32 T#0d_0h_0m_0s_0ms to T#49d_17h_2m_47s_295ms 
Maximum of two digits for the values day, hour, minute, 
second and a maximum of three digits for milliseconds 
Initialization with T#0d_0h_0m_0s_0ms 

Date in increments of 1 
day  

DATE   32 D#1992-01-01 to D#2200-12-31 
Leap years are taken into account, year has four digits, 
month and day are two digits each 
Initialization with D#0001-01-01 

Time of day in steps of 
1 ms 

TIME_OF_DAY  
(TOD)    

32 TOD#0:0:0.0 to TOD#23:59:59.999 
Maximum of two digits for the values hour, minute, second 
and maximum of three digits for milliseconds 
Initialization with TOD#0:0:0.0 

 

Date and time DATE_AND_TI
ME 
(DT)    

64 DT#1992-01-01-0:0:0.0 to DT#2200-12-31-23:59:59.999 
DATE_AND_TIME consists of the data types DATE and 
TIME 
Initialization with DT#0001-01-01-0:0:0.0 

String type 
Data of this type represents character strings, in which each character is encoded with the specified number of bytes.   
The length of the string can be defined at the declaration. Indicate the length in "[" and "]", e.g. STRING[100]. The default 
setting consists of 80 characters.  
The number of assigned (initialized) characters can be less than the declared length. 
 String with 1 

byte/character 
STRING   8 All characters with ASCII code $00 to $FF are permitted. 

Default ’ ’ (empty string) 

 
 

NOTICE  
During variable export to other systems, the value ranges of the corresponding data types 
in the target system must be taken into account. 

 

 

See also 
Value range limits of elementary data types (Page 95) 
General data types (Page 96) 
Elementary system data types (Page 97) 
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4.13.2.1 Value range limits of elementary data types 
The value range limits of certain elementary data types are available as constants. 

Table 4- 5 Symbolic constants for the value range limits of elementary data types  

Symbolic constant Data type Value Hex notation 
SINT#MIN SINT -128 16#80
SINT#MAX SINT 127 16#7F
INT#MIN INT -32768 16#8000
INT#MAX INT 32767 16#7FFF
DINT#MIN DINT -2147483648 16#8000_0000
DINT#MAX DINT 2147483647 16#7FFF_FFFF
USINT#MIN USINT 0 16#00
USINT#MAX USINT 255 16#FF
UINT#MIN UINT 0 16#0000
UINT#MAX UINT 65535 16#FFFF
UDINT#MIN UDINT 0 16#0000_0000
UDINT#MAX UDINT 4294967295 16#FFFF_FFFF
T#MIN 
TIME#MIN 

TIME T#0ms 16#0000_00001

T#MAX 
TIME#MAX 

TIME T#49d_17h_2m_47s_295ms 16#FFFF_FFFF1

TOD#MIN 
TIME_OF_DAY#MIN 

TOD TOD#00:00:00.000 16#0000_00001

TOD#MAX 
TIME_OF_DAY#MAX 

TOD TOD#23:59:59.999 16#0526_5BFF1

1 Internal display only 
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4.13.2.2 General data types 
General data types are often used for the input and output parameters of system functions 
and system function blocks. The subroutine can be called with variables of each data type 
that is contained in the general data type. 
The following table lists the available general data types: 

Table 4- 6 General data types 

General data type Data types contained 
ANY_BIT BOOL, BYTE, WORD, DWORD 
ANY_INT SINT, INT, DINT, USINT, UINT, UDINT 
ANY_REAL REAL, LREAL 
ANY_NUM ANY_INT, ANY_REAL 
ANY_DATE DATE, TIME_OF_DAY (TOD), DATE_AND_TIME (DT) 
ANY_ELEMENTARY ANY_BIT, ANY_NUM, ANY_DATE, TIME, STRING 
ANY ANY_ELEMENTARY, user-defined data types (UDT), system data types, 

data types of the technology objects 

 
 

 Note 
You cannot use general data types as type identifiers in variable or type declarations. 
The general data type is retained when a user-defined data type (UDT) is derived directly 
from an elementary data type (only possible with the SIMOTION ST programming language).
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4.13.2.3 Elementary system data types 
In the SIMOTION system, the data types specified in the table are treated similarly to the 
elementary data types. They are used with many system functions. 

Table 4- 7 Elementary system data types and their use 

Identifier Bit width Use 
StructAlarmId 32 Data type of the alarmId for the project-wide unique identification of 

the messages. The alarmId is used for the message generation. 
See Function Manual SIMOTION Basic Functions. 
Initialization with STRUCTALARMID#NIL 

StructTaskId 32 Data type of the taskId for the project-wide unique identification of the 
tasks in the execution system. 
See Function Manual SIMOTION Basic Functions. 
Initialization with STRUCTTASKID#NIL 

 

Table 4- 8 Symbolic constants for invalid values of elementary system data types 

Symbolic constant Data type Significance 
STRUCTALARMID#NIL StructAlarmId Invalid AlarmId 
STRUCTTASKID#NIL StructTaskId Invalid TaskId 
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4.13.3 Derived data types 

4.13.3.1 Defining user-defined data types (UDT) 
You can create derived data types in source files and programs:   
● Structures 
● Enumerations 
The scope of the data type declaration depends on the location of the declaration. 

4.13.3.2 Scope of the data type declaration 
You create derived data types in the declaration tables of the source file or the 
program/chart. The scope of the data type declaration depends on the location of the 
declaration.      
● In the Interface (exported declaration) source file section of the declaration table: 

The data type is valid for the entire source file; all programs/charts (programs, function 
blocks, and functions) within the source file can access the data type. 
These variables are also available, if appropriately connected (see Define connections 
(Page 136)), in other source files (or other units). 

● In the Implementation (source-internal declaration) source file section of the declaration 
table: 
The data type is valid in the source file; all programs/charts (programs, function blocks, 
and functions) within the source file can access the data type. 

● In the declaration table of the program: 
The data type can only be accessed within the program/chart in which it is declared. 
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4.13.3.3 Defining structures 
You define structures in the declaration tables of the source file or the program/chart. The 
scope (Page 98) of the structures depends on the location of the declaration. 
To define structures, proceed as follows:     
1. Select the declaration table and, if applicable, the section of the declaration table for the 

desired scope. 
2. Select the Structures tab. 
3. Enter the name of the structure. 
4. In the same line, enter: 

– The name of the first element 
– Data type of element 
– Additional characteristics (array length, start value). 

5. Enter additional elements of the structure in the following lines; leave the Structure name  
field empty. 

6. Begin the definition of the new structure by entering a new name in the Structure name 
field. 

4.13.3.4 Defining enumerations 
You define enumerations in the declaration tables of the source file or the program/chart. 
The scope (Page 98) of the enumerations depends on the location of the declaration. 
To define enumerations, proceed as follows:     
1. Select the declaration table and, if applicable, the section of the declaration table for the 

desired scope. 
2. Select the Enumerations tab. 
3. Enter the name of the enumeration. 
4. In the same line, enter: 

– The name of the first element 
– Optionally, the initialization value of the enumeration data type 

5. Enter additional elements of the enumeration in the following lines; leave the 
Enumeration name field empty. 

6. You begin the definition of the new enumeration by entering a new name in the 
Enumeration name field. 
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Example 
This example shows the definition of an enumeration data type with the name Color and the 
enumeration elements Red, Blue, and Green, as well as the initialization value (initial value) 
Green.   
If there is no initialization entered during the enumeration definition (data type declaration), 
the first value of the enumeration is assigned to the data type. In this example, Red would be 
used for the initialization because it is defined as the first enumeration element. 

 
Figure 4-25 Definition of an enumeration data type 



 LAD/FBD programming 
 4.13 Data Types 

SIMOTION LAD/FBD 
Programming and Operating Manual, 05/2009 101 

4.13.4 Technology object data types 

4.13.4.1 Description of the technology object data types 
You can declare variables with the data type of a technology object (TO). The following table 
shows the data types for the available technology objects in the individual technology 
packages.  
For example, you can declare a variable with the data type posaxis and assign it an 
appropriate instance of a position axis. Such a variable is often referred to as a reference.  

Table 4- 9 Data types of technology objects (TO data type) 

Technology object Data type Contained in the technology 
package 

Drive axis driveAxis CAM1 2, PATH, CAM_EXT 
External encoder externalEncoderType CAM1 2, PATH, CAM_EXT 
Measuring input measuringInputType CAM1 2, PATH, CAM_EXT 
Output cam outputCamType CAM1 2, PATH, CAM_EXT 
Cam track (as of V3.2) _camTrackType CAM, PATH, CAM_EXT 
Position axis posAxis CAM1 3, PATH, CAM_EXT 
Following axis followingAxis CAM1 4, PATH, CAM_EXT 
Following object followingObjectType CAM1 4, PATH, CAM_EXT 
Cam camType CAM, PATH, CAM_EXT 
Path axis (as of V4.1) _pathAxis PATH, CAM_EXT 
Path object (as of V4.1) _pathObjectType PATH, CAM_EXT 
Fixed gear (as of V3.2) _fixedGearType CAM_EXT 
Addition object (as of V3.2) _additionObjectType CAM_EXT 
Formula object (as of V3.2) _formulaObjectType CAM_EXT 
Sensor (as of V3.2) _sensorType CAM_EXT 
Controller object (as of V3.2) _controllerObjectType CAM_EXT 
Temperature channel temperatureControllerType TControl 
General data type, 
to which every TO can be 
assigned 

ANYOBJECT  

1) As of Version V3.1, the BasicMC, Position and Gear technology packages are no longer contained.  
2) For Version V3.0, also contained in the BasicMC, Position and Gear technology packages. 
3) For Version V3.0, also contained in the Position and Gear technology packages. 
4) For Version V3.0, also contained in the Gear technology package. 

You can access the elements of technology objects (configuration data and system 
variables) via structures (see SIMOTION Basic Functions Function Manual). 
Table 4- 10 Symbolic constants for invalid values of technology object data types 

Symbolic constant Data type Meaning 
TO#NIL ANYOBJECT Invalid technology object 

See also 
Inheritance of the properties for axes (Page 102) 
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4.13.4.2 Inheritance of the properties for axes 
Inheritance for axes means that all of the data types, system variables and functions of the 
TO driveAxis are fully included in the TO positionAxis. Similarly, the position axis is fully 
included in the TO followingAxis, the following axis in the TO pathAxis. This has, for 
example, the following effects:  
● If a function or a function block expects an input parameter of the driveAxis data type, you 

can also use a position axis or a following axis or a path axis when calling. 
● If a function or a function block expects an input parameter of the posAxis data type, you 

can also use a following axis or a path axis when calling. 

4.13.5 System data types 
There are a number of system data types available that you can use without a previous 
declaration. And, each imported technology packages provides a library of system data 
types.   
Additional system data types (primarily enumerator and STRUCT data types) can be found 
● In parameters for the general standard functions (see SIMOTION Basic Functions 

Function Manual) 
● In parameters for the general standard function modules (see SIMOTION Basic 

Functions Function Manual) 
● In system variables of the SIMOTION devices (see relevant parameter manuals) 
● In parameters for the system functions of the SIMOTION devices (see relevant parameter 

manuals) 
● In system variables and configuration data of the technology objects (see relevant 

parameter manuals) 
● In parameters for the system functions of the technology objects (see relevant parameter 

manuals) 
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4.14 Variables 
Variables are an important component of programming and provide structure to programs. 
They are placeholders which can be assigned values that can be accessed several times in 
the program.  
Variables have: 
● A specific initialization behavior and scope of validity 
● A data type and operations which are defined for that data type 
User and system variables are differentiated. User variables can be defined by the user. 
System variables are provided by the system. 

4.14.1 Keywords for variable types 
The various keywords for variable types are shown in the following table.   

Description of keywords for variable types 
 
Keyword Description Application 
Global user variables (declared in the interface or implementation section of the unit1) 
VAR_GLOBAL   Unit variable; can be accessed by all POUs within the source file. 

If the variable was declared in the interface section, it can be used in 
another source file once a connection has been defined in its declaration 
table (see Define connections (Page 136)). 

FB, FC, program

VAR_GLOBAL RETAIN    Retentive unit variable; retained during power outage. FB, FC, program
VAR_GLOBAL CONSTANT   Unit constant; cannot be changed from the program. FB, FC, program
Local user variables (declared within a POU2) 
VAR   Local variable (static for FB and program, temporary for FC) FB, FC, program
VAR_TEMP   Temporary local variable FB, program 
VAR_INPUT   Input parameters: Local variable; value is supplied from external source 

and can only be read in the FB or FC. 
FB, FC 

VAR_OUTPUT   Output parameters: Local variable; value is sent to an external 
destination by the FB. It can be read as an instance variable after being 
called by the FB (FB instance name.variable name). 

FB 

VAR_IN_OUT   In/out parameter; the FB or FC accesses this variable directly (by means 
of a reference) and can change it directly. 

FB, FC 

VAR CONSTANT    Local constant; cannot be changed from the program. FB, FC, program
1 MCC and LAD/FBD programming languages: in the declaration table of the respective source file. 
2 MCC and LAD/FBD programming languages: in the declaration table of the respective chart/program. 
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4.14.2 Defining variables 
Variables are defined in the symbol browser or in the declaration table of the source file or 
chart/program. The following table provides an overview of where the relevant variable is 
defined.   

Definition of variables 
 
Variable type Defined in... 
Global device user 
variables 

Symbol browser 

unit variable Declaration table of the source file as VAR_GLOBAL, VAR_GLOBAL 
RETAIN or VAR_GLOBAL CONSTANT 

Local variable Declaration table of the program/chart as: 
• VAR, VAR_TEMP, or VAR CONSTANT 
• Additionally for function blocks as VAR_INPUT, VAR_OUTPUT, 

VAR_IN_OUT 
• Additionally for functions as VAR_INPUT, VAR_IN_OUT 

I/O variable Symbol browser 
Symbolic access to the 
fixed process image of 
the BackgroundTask 

• Declaration table of the source file 
• Declaration table of the program/chart (programs and FB only) 

4.14.2.1 Use of global device variables 
Global device variables are user-defined variables that you can access from all program 
sources (e.g. ST source files, MCC units) of a SIMOTION device.   
Global device variables are created in the symbol browser tab of the detail view; to do this, 
you must be working in offline mode.  
Here is a brief overview of the procedure: 
1. In the project navigator of SIMOTION SCOUT, select the GLOBAL DEVICE VARIABLES 

element in the SIMOTION device subtree. 
2. In the detail view, select the Symbol browser tab and scroll down to the end of the 

variable table (empty row). 
3. In the last (empty) row of the table, enter or select the following: 

– Name of variable 
– Data type of variable (only elementary data types are permitted) 

4. Optionally, you can make the following entries: 
– Selection of Retain checkbox (This declares the variable as retentive, so that its value 

will be retained after a power failure.) 
– Array length (array size) 
– Initial value (if array, for each element) 
– Display format (if array, for each element) 
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You can now access this variable using the symbol browser or any program of the 
SIMOTION device.  
In ST source files, you can use a global device variable, just like any other variable. 

 

 Note 
If you have declared unit variables or local variables of the same name (e.g. var-name), 
specify the global device variable with _device.var-name. 
An alternative to global device variables is the declaration of unit variables in a separate unit, 
which is imported into other units. This has the following advantages: 
1. Variable structures can be used. 
2. The initialization of the variables during the STOP-RUN transition is possible (via 

Program in StartupTask). 
3. For newly created global unit variables, a download in RUN is also possible. 
Please refer to the SIMOTION Basic Functions Function Manual. 

 

 

4.14.2.2 Declaring a unit variable in the source file 
The unit variable is declared in the source file. The valid range (scope) of the variable is 
dependent on the section of the declaration table in which the variable is declared:   
● In the interface section of the declaration table (INTERFACE): 

The unit variable is valid for the entire source file; all programs/charts (programs, function 
blocks, and functions) within the source file can access the unit variable. 
In addition, these variables are available on HMI devices and, once connected (see 
Define connections (Page 136)), in other source files (or other units), as well. 
The total size of all unit variables in the interface section is limited to 64 Kbytes. 

● In the implementation section of the declaration table (IMPLEMENTATION): 
The unit variable is valid in the source file only; all programs/charts (programs, function 
blocks, and functions) within the source file can access the unit variable. 
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Proceed as follows; the source file (declaration table) is open (see Open existing program 
source file (Page 42)): 
1. In the declaration table, select the section for the desired scope. 
2. Then select the Parameters tab. 
3. Enter: 

– Name of the variable 
– Variable type 

See also: Keywords for variable types (Page 103) 
– Data type of the variable 

You can select elementary data types (see Elementary data types (Page 93)); other 
data types must be entered in the appropriate field. 
See also:  
Defining structures (Page 99)  
Defining enumerations (Page 99)   

– Optional array length (to define the array size) 
See also: Array length and array element (Page 90)  

– Optional initial value (initialization value 
See also: Initial value  (Page 91)  

The variable is now declared and can be used immediately. 

 
Figure 4-26 Example: Declaring a unit variable in the source file 

 

 Note 
The declaration table of the source file is read each time parameters are assigned for a 
command. Inconsistent data within the declaration table can therefore cause unexpected 
error messages during parameter assignment. 
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4.14.2.3 Declaring local variables 
A local variable can only be accessed within the program/chart (program, function, function 
block) in which it is declared.   
Proceed as follows; the program/chart with the declaration table is open (see Open existing 
program source file (Page 42)): 
1. In the declaration table, select the Parameter/Variables tab. 
2. Enter: 

– Name of the variable 
– Variable type for variables 

See also: Keywords for variable types (Page 103) 
– You can select elementary data types (see Elementary data types (Page 93)); other 

data types must be entered in the appropriate field. 
See also: 
Defining structures (Page 99)  
Defining enumerations (Page 99)  

– Optional array length (to define the array size) 
See also: Array length and array element (Page 90) 

– Optional initial value (initialization value 
See also: Initial value  (Page 91) 

The variable is now declared and can be used immediately. 

 
Figure 4-27 Example: Declaring a local variable in the chart/program 

  
 

 Note 
The declaration table of the program/chart is read each time parameters are assigned for a 
command. Inconsistent data within the declaration table can therefore cause unexpected 
error messages during parameter assignment. 
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4.14.2.4 Defining global user variables and local variables in the variable declaration dialog box 
As soon as you enter an unknown variable in a LAD/FBD diagram, the Variable Declaration 
dialog box appears. 

 
Figure 4-28 Variable declaration dialog box 

To define variables in the Variable Declaration dialog box, proceed as follows: 
1. Enter the name of the variable in the LAD or FBD diagram. 
2. Press the Return key. 

The Variable Declaration dialog box appears. 
3. Enter: 

– Another variable name, if required 
– Absolute identifier 

The absolute name you entered appears in the I/O symbols tab of the declaration 
table. As soon as you have entered the Absolute name, you can no longer select the 
Variable type, Array length, or Initial value fields in the Variable Declaration dialog 
box. 

– Data type of the variables  
Select the data type from the pull-down menu. If the data type of an I/O symbol is not 
ANY_BIT or ANY_INT, you may enter an absolute name. 
If you select a global variable (e.g. VAR_GLOBAL) as the type, the Exportable check 
box is activated. 

 
Figure 4-29 Example: Variable declaration (absolute name) 
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Figure 4-30 Example: Variable declaration 

Confirm with OK. 
The variable is defined and entered in the declaration table of the source file or the program, 
depending on the selected variable type and Exportable. 

 

 Note 
In order for the Variable declaration dialog box to appear, the on-the-fly variable declaration 
check box must be selected in the Settings dialog box. 
If you leave the Variable declaration dialog box by clicking Cancel, your input remains as it 
is, and the variable is not created. 
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4.14.3 Time of the variable initialization 
The timing of the variable initialization is determined by: 
● Memory area to which the variable is assigned 
● Operator actions (e.g. source file download to the target system) 
● Execution behavior of the task (sequential, cyclic) to which the program was assigned. 
All variable types and the timing of their variable initialization are shown in the following 
tables. You will find basic information about tasks in the SIMOTION Basic Functions 
Function Manual.  
The behavior for variable initialization during download can be set: To do this, as a default 
setting select the Options > Settings menu and the Download tab or define the setting during 
the current download. 

 

 Note 
You can upload values of unit variables or global device variables from the SIMOTION 
device into SIMOTION SCOUT and save them in XML format. 
1. Save the required data segments of the unit variables or global device variables as a data 

set with the function _saveUnitDataSet. 
2. Use the Save variables function in SIMOTION SCOUT. 
You can use the Restore variables function to download these data sets and variables back 
to the SIMOTION device. 
For more information, refer to the SIMOTION SCOUT Configuration Manual. 
This makes it possible, for example, to obtain this data, even if it is initialized by a project 
download or if it becomes unusable (e.g. due to a version change of SIMOTION SCOUT). 

 

 

4.14.3.1 Initialization of retentive global variables 
Retentive variables retain their last value after a loss of power. All other data is reinitialized 
when the device is switched on again. 
Retentive global variables are initialized: 
● When the backup or buffer for retentive data fails. 
● When the firmware is updated. 
● When a memory reset (MRES) is performed. 
● With the restart function (Del. SRAM) in SIMOTION P350. 
● By applying the _resetUnitData function (as of kernel V3.2), possible selectively for 

different data segments of the retentive data. 
● When a download is performed according to the following description. 
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Table 4- 11 Initializing retentive global variables during download 

Variable type Time of the variable initialization  
Retentive global 
device variables 

The behavior when downloading depends on the Initialization of all retentive global device 
variables and program data setting1: 
• Yes2: All retentive global device variables are initialized. 
• No3: 

– As of version V3.2 of the SIMOTION Kernel: 

Separate version ID for retentive global device variables. If the version ID is changed, the 
retentive global device variables are initialized. 

– Up to Version V3.1 of the SIMOTION kernel: 

Joint version ID for all global device variables (retentive and non-retentive). If the version 
ID is changed, all global device variables are initialized. 

See: Version ID of global variables and their initialization during download (Page 117). 
Retentive unit 
variables 

The behavior when downloading depends on the Initialization of all retentive global device 
variables and program data setting1: 
• Yes2: All retentive unit variables (all units) are initialized. 
• No3: 

– As of version V3.2 of the SIMOTION Kernel: 

Separate version ID for each individual data block ( = declaration block)4 of the retentive 
unit variables in the interface or implementation section. If the version identification is 
changed, only the associated data block will be initialized5. 

– Up to Version V3.1 of the SIMOTION kernel: 

Common version ID for all unit variables (retentive and non-retentive, in the interface and 
implementation section) of a unit. If the version ID is changed, all unit variables of this unit 
are initialized. 

See: Version ID of global variables and their initialization during download (Page 117). 
1 Default setting in the Options > Settings menu, Download tab, 
or the current setting for the download. 
2 The corresponding checkbox is active. 
3 The corresponding checkbox is inactive. 
4 Several data blocks for retentive unit variables in the interface or implementation section can be declared only in the 
SIMOTION ST programming language. For the SIMOTION MCC and SIMOTION LAD/FBD programming languages, only 
one data block for retentive unit variables will be created in the interface or implementation section. 
5 Also for the download in RUN, provided the associated prerequisites have been satisfied and the following attribute has 
been specified in the associated declaration block within a pragma (only for the SIMOTION ST programming language): 
{ BlockInit_OnChange := TRUE; }. 
For the download in RUN, see the SIMOTION Basic Functions Function Manual. 
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4.14.3.2 Initialization of non-retentive global variables 
Non-retentive global variables lose their value during power outages. They are initialized: 
● For the Initialization of retentive global variables (Page 110), e.g. during a firmware 

update or general reset (MRES). 
● During power up. 
● By applying the _resetUnitData function (as of kernel V3.2), possible selectively for 

different data segments of the non-retentive data. 
● During the download in accordance with the description on the following table. 
● Only as of Version V4.1 of the SIMOTION Kernel and for non-retentive unit variables: 

For transition to the RUN mode when the associated declaration block within a pragma 
specifies the following attribute (only for SIMOTION ST programming language): { 
BlockInit_OnDeviceRun := ALWAYS; } 
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Table 4- 12 Initializing non-retentive global variables during download 

Variable type Time of the variable initialization  
Non-retentive global 
device variables 

The behavior when downloading depends on the Initialization of all non-retentive global device 
variables and program data setting1: 
• Yes2: All non-retentive global device variables are initialized. 
• No3: 

– As of version V3.2 of the SIMOTION Kernel: 

Separate version ID for non-retentive global device variables. If the version ID is changed, 
the non-retentive global device variables are initialized. 

– Up to Version V3.1 of the SIMOTION kernel: 

Joint version ID for all global device variables (retentive and non-retentive). If the version 
ID is changed, all global device variables are initialized. 

See: Version ID of global variables and their initialization during download (Page 117). 
Non-retentive unit 
variables 

The behavior when downloading depends on the Initialization of all non-retentive global device 
variables and program data setting1: 
• Yes2: All non-retentive unit variables (all units) are initialized. 
• No3: 

– As of version V3.2 of the SIMOTION Kernel: 

Separate version ID for each individual data block ( = declaration block)4 of the non-
retentive unit variables in the interface or implementation section. If the version 
identification is changed, only the associated data block will be initialized5. 

– Up to Version V3.1 of the SIMOTION kernel: 

Common version ID for all unit variables (retentive and non-retentive, in the interface and 
implementation section) of a unit. If the version ID is changed, all unit variables of this unit 
are initialized. 

See: Version ID of global variables and their initialization during download (Page 117). 
1 Default setting in the Options > Settings menu, Download tab, 
or the current setting for the download. 
2 The corresponding checkbox is active. 
3 The corresponding checkbox is inactive. 
4 Several data blocks for non-retentive unit variables in the interface or implementation section can be declared only in the 
SIMOTION ST programming language. For the SIMOTION MCC and SIMOTION LAD/FBD programming languages, only 
one data block for non-retentive unit variables will be created in the interface or implementation section. 
5 Also for the download in RUN, provided the associated prerequisites have been satisfied and the following attribute has 
been specified in the associated declaration block within a pragma (only for the SIMOTION ST programming language): 
{ BlockInit_OnChange := TRUE; }. 
For the download in RUN, see the SIMOTION Basic Functions Function Manual. 
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4.14.3.3 Initialization of local variables 
Local variables are initialized: 
● For the initialization of retentive unit variables (Page 110).  
● For the initialization of non-retentive unit variables (Page 112). 
● Also, according to the following description: 

Table 4- 13 Initialization of local variables 

Variable type Time of the variable initialization  
Local program 
variables 

Local variables of programs are initialized differently: 
• Static variables (VAR) are initialized according to the memory area in which they are stored. 

See: Initialization of static program variables (Page 115). 
• Temporary variables (VAR_TEMP) are initialized every time the program of the task is called. 

Local variables of 
function blocks (FB) 

Local variables of function blocks are initialized differently: 
• Static variables (VAR, VAR_IN, VAR_OUT) are only initialized when the FB instance is 

initialized. 

See: Initialization of instances of function blocks (FBs) (Page 116). 
• Temporary variables (VAR_TEMP) are initialized every time the FB instance is called. 

Local variables of 
functions (FC) 

Local variables of functions are temporary and are initialized every time the function is called. 

 
 

 Note 
You can obtain information about the memory requirements of a POU in the local data stack 
using the Program Structure (Page 165) function. 
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4.14.3.4 Initialization of static program variables 
The following versions affect the following static variables: 
● Local variables of a unit program declared with VAR 
● Function block instances declared with VAR within a unit program, including the 

associated static variables (VAR, VAR_INPUT, VAR_OUTPUT). 
The initialization behavior is determined by the memory area in which the static variables are 
stored. This is determined by the "Create program instance data only once" (Page 48) 
compiler option. 
● For the deactivated "Create program instance data only once" compiler option (default): 

The static variables are stored in the user memory of each task, which is assigned to the 
program. 
The initialization of the variables thus depends on the execution behavior of the task to 
which the program is assigned (see SIMOTION Basic Functions Function Manual):  
– Sequential tasks (MotionTasks, UserInterruptTasks, SystemInterruptTasks, 

StartupTask, ShutdownTask): The static variables are initialized every time the task is 
started. 

– Cyclic tasks (BackgroundTask, SynchronousTasks, TimerInterruptTasks): The static 
variables are initialized only during transition to RUN mode. 

● For the activated "Create program instance data only once" compiler option: 
This setting is necessary, for example, if a program is to be called within a program. 
The static variables of all programs from the program source (unit) involved are only 
stored once in the user memory of the unit. 
– They are thus initialized together with the non-retentive unit variables, see Initialization 

of non-retentive global variables (Page 112). 
– Only as of Version V4.1 of the SIMOTION Kernel: 

In addition, they can be initialized during transition to RUN mode. To do this, the 
following attribute must be specified in the associated declaration block within a 
pragma (only SIMOTION ST programming language): 
{ BlockInit_OnDeviceRun := ALWAYS; }. 
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4.14.3.5 Initialization of instances of function blocks (FBs) 
The initialization of a function block instance is determined by the location of its declaration: 
● Global declaration (within VAR_GLOBAL/END_VAR in the interface of implementation 

section): 
Initialization as for a non-retentive unit variable, see Initialization of non-retentive global 
variables (Page 112). 

● Local declaration in a program (within VAR / END_VAR): 
Initialization as for static variables of programs, see Initialization of static variables of 
programs (Page 115). 

● Local declaration in a function block (within VAR / END_VAR): 
Initialization as for an instance of this function block. 

● Declaration as in/out parameter in a function block or a function (within 
VAR_IN_OUT / END_VAR): 
For the initialization of the POU, only the reference (pointer) will be initialized with the 
instance of the function block remaining unchanged. 

 

 
 

Note 
You can obtain information about the memory requirements of a POU in the local data 
stack using the Program Structure (Page 165) function. 

 

 
4.14.3.6 Initialization of system variables of technology objects 

The system variables of a technology object are usually not retentive. Depending on the 
technology object, a few system variables are stored in the retentive memory area (e.g. 
absolute encoder calibration). 
The initialization behavior (except in the case of download) is the same as for retentive and 
non-retentive global variables. See Initialization of retentive global variables (Page 110) and 
Initialization of non-retentive global variables (Page 112). 
The behavior during the download is shown below for: 
● Non-retentive system variables 
● Retentive system variables 
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Table 4- 14 Initializing technology object system variables during download 

Variable type Time of the variable initialization  
Non-retentive system 
variables 

Behavior during download, depending on the Initialization of all non-retentive data for technology 
objects setting1: 
• Yes2: All technology objects are initialized. 

– All technology objects are restructured and all non-retentive system variables are 
initialized. 

– All technological alarms are cleared. 
• No3: Only technology objects changed in SIMOTION SCOUT are initialized. 

– The technology objects in question are restructured and all non-retentive system variables 
are initialized. 

– All alarms that are pending on the relevant technology objects are cleared. 
– If an alarm that can only be acknowledged with Power On is pending on a technology 

object that will not be initialized, the download is aborted. 

Retentive system 
variables 

Only if a technology object was changed in SIMOTION SCOUT, will its retentive system variables 
be initialized. 
The retentive system variables of all other technology objects are retained (e.g. absolute encoder 
calibration). 

1 Default setting in the Options > Settings menu, Download tab, 
or the current setting for the download. 
2 The corresponding checkbox is active. 
3 The corresponding checkbox is inactive. 

4.14.3.7 Version ID of global variables and their initialization during download 

Table 4- 15 Version ID of global variables and their initialization during download 

Data segment As of Version V3.2 of the SIMOTION kernel Up to Version V3.1 of the 
SIMOTION kernel 

Global device variables 
Retentive global 
device variables 

 

Non-retentive 
global device 
variables 

• Separate version ID for each data segment of the global 
device variables. 

• The version identification of the data segment changes 
for: 
– Add or remove a variable within the data segment 
– Change of the identifier or the data type of a variable 

within the data segment 
• This version ID does not change on: 

– Changes in the other data segment 
– Changes to initialization values1 

• During downloading2, the rule is: Initialization of a data 
segment only if its version ID has changed. 

• Use of the functions for data backup and initialization 
possible. 

• Common version ID for all data 
segments of the global device 
variables. 

• This version ID changes when 
the variable declaration is 
changed in a data segment. 

• During downloading2, the rule 
is: Initialization of all data 
segments if the version ID 
changes. 

• Use of the functions for data 
backup not possible. 
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Data segment As of Version V3.2 of the SIMOTION kernel Up to Version V3.1 of the 
SIMOTION kernel 

Unit variables of a unit 
Retentive unit 
variables in the 
interface section 
Retentive unit 
variables in the 
implementation 
section 
Non-retentive unit 
variables in the 
interface section 

 

Non-retentive unit 
variables in the 
implementation 
section 

• Several data blocks ( = declaration blocks)3 in each data 
segment possible. 

• Own version ID for each data block. 
• The version identification of the data block changes for: 

– Add or remove a variable in the associated 
declaration block 

– Change of the identifier or the data type of a variable 
in the associated declaration block 

– Change of a data type definition (from a separate or 
imported4 unit) used in the associated declaration 
block 

– Add or remove declaration blocks within the same 
data segment before the associated declaration block

• This version ID does not change on: 
– Add or remove declaration blocks in other data 

segments 
– Add or remove declaration blocks within the same 

data segment after the associated declaration block 
– Changes in other data blocks 
– Changes to initialization values1 
– Changes to data type definitions that are not used in 

the associated data block 
– Changes to functions 

• During downloading2, the rule is: Initialization of a data 
block only if its version ID has changed.5 

• Functions for data backup and initialization take into 
account the version ID of the data blocks. 

• One data block in each data 
segment (also for several 
declaration blocks)3 

• Common version ID for all 
global declarations in a unit. 

• This version ID changes in 
response to the following 
changes: 
– Variable declaration in a 

data segment 
– Declaration of global data 

types in the unit 
– Declaration in the interface 

section of an imported4 unit. 
• During downloading2, the rule 

is: Initialization of all data 
segments if the version ID 
changes. 

• Use of the functions for data 
backup only possible for: Non-
retentive unit variables in the 
interface section 

1 Changed initialization values are not effective until the data block or data segment in question is initialized. 
2 If Initialization of all retentive global device variables and program data = No and Initialization of all non-retentive global 
device variables and program data = No.  
In the case of other settings: See the sections "Initialization of retentive global variables (Page 110)" and "Initialization of 
non-retentive global variables (Page 112)". 
3 Several declaration blocks per data segment are possible only in the SIMOTION ST programming language. For the 
SIMOTION MCC and SIMOTION LAD/FBD programming languages, only one declaration block per data segment will be 
created. 
4 The import of units depends on the programming language, refer to the associated section (Page 136). 
5 Also for the download in RUN, provided the associated prerequisites have been satisfied and the following attribute has 
been specified in the associated declaration block within a pragma (only for the SIMOTION ST programming language): { 
BlockInit_OnChange := TRUE; }. 
For the download in RUN, see the SIMOTION Basic Functions Function Manual. 
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4.15 Access to inputs and outputs (process image, I/O variables) 

4.15.1 Overview of access to inputs and outputs 
You can access the SIMOTION device inputs and outputs as well as the central and 
distributed I/O:    
● Via direct access with I/O variables  

You define an I/O variable (name and I/O address). The entire address range can be 
used. 
It is preferable to use direct access with sequential programming (in MotionTasks); 
access to current input and output values at a particular point in time is especially 
important in this case. (  

● Via the process image of cyclic tasks using I/O variables   
A memory area in the RAM of the SIMOTION device, on which the address space of the 
SIMOTION device is mapped. The mirror image is refreshed with the assigned task and 
is consistent throughout the entire cycle. It is used preferentially when programming the 
assigned task (cyclic programming). 
Define an I/O variable (name and I/O address) and assign a task to it. The entire address 
area of the SIMOTION device can be used. 
Direct access to this I/O variable is still possible: Specify direct access with _direct.var-
name.    

● Using the fixed process image of the BackgroundTask 
A memory area in the RAM of the SIMOTION device on which a subset of the I/O 
address space is mapped. The mirror image is refreshed with the BackgroundTask and is 
consistent throughout the entire cycle. It is used preferentially when programming the 
BackgroundTask (cyclic programming). 
The address range 0 .. 63 can be used, except for the process image of the cyclic tasks.  

 

 
 

Note 
An access via the process image is more efficient than direct access. 
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4.15.2 Important features of direct access and process image access 

Table 4- 16 Important features of direct access and process image access 

 Direct access Access to process image of 
cyclic tasks 

Access to fixed process image 
of the BackgroundTask 

Permissible address 
range 

Entire address range of the SIMOTION device  
Exception: I/O variables comprising more than one byte must not 
contain addresses 63 and 64 contiguously (example: PIW63 or 
PQD62 are not permitted). 
The addresses used must be present in the I/O and appropriately 
configured. 

0 .. 63, 
except for the addresses used 
in the process image of cyclic 
tasks 
Addresses that are not present 
in the I/O or have not been 
configured can also be used. 

Assigned task None. Cyclic task for selection: 
• SynchronousTasks, 
• TimerInterruptTasks, 
• BackgroundTask. 

BackgroundTask. 

Updating • Onboard I/O of SIMOTION 
devices C230-2, C240, and 
P350: 

Update occurs in a cycle 
clock of 125 µs. 

• I/O via PROFIBUS DP, 
PROFINET, P-Bus, and 
DRIVE-CLiQ as well as 
Onboard I/O of the D4xx 
SIMOTION devices: 

Update occurs in the 
position control cycle clock. 

Inputs are read at the start of 
the cycle clock. 
Outputs are written at the end 
of the cycle clock. 

Update occurs with the 
assigned task: 
• Inputs are read before the 

assigned task is started and 
transferred to the process 
input image. 

• Process output image is 
written to the outputs after 
the assigned task has been 
completed. 

An update is made with the 
BackgroundTask: 
• Inputs are read before the 

BackgroundTask is started 
and is transferred to the 
process input image. 

• Process output image is 
written to the outputs when 
the BackgroundTask is 
complete. 

– During the entire cycle of the 
assigned task. 
Exception: Direct access to 
output occurs. 

Consistency 

Consistency is only ensured for elementary data types. 
When using arrays, the user is responsible for ensuring data 
consistency. 

During the entire cycle of the 
BackgroundTask. 
Exception: Direct access to 
output occurs. 

Use Preferred in MotionTasks Preferred in the assigned task Preferred in the 
BackgroundTask 

Declaration as 
variable 

Necessary, for the entire device in the symbol browser  Possible, but not necessary: 
• For the entire device in the 

symbol browser, 
• As unit variable, 
• As local variable in a 

program. 
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 Direct access Access to process image of 
cyclic tasks 

Access to fixed process image 
of the BackgroundTask 

Write protection for 
outputs 

Possible; Read only status can 
be selected. 

Not supported. Not supported. 

Declaration of arrays Possible. Not supported. 
Error during access from user 
program, alternative reactions 
available: 
• CPU stop1 
• Substitute value 
• Last value 

Error during generation of 
process image, alternative 
reactions available: 
• CPU stop1 
• Substitute value 
• Last value 

Error during generation of 
process image, reaction: CPU 
stop1. 
Exception: If direct access has 
been set up at the same 
address, the behavior set there 
applies. 

Responses in the 
event of an error 

See Description of Functions SIMOTION Basic Functions 
Use the absolute 
address  

Not supported.  Supported 

Access 
• In RUN mode Without any restrictions. Without any restrictions. Without any restrictions. 

• During 
StartupTask 

Possible with restrictions: 
• Inputs can be read. 
• Outputs are not written until 

StartupTask is complete. 

Possible with restrictions: 
• Inputs are read at the start 

of the StartupTask. 
• Outputs are not written until 

StartupTask is complete. 

Possible with restrictions: 
• Inputs are read at the start 

of the StartupTask. 
• Outputs are not written until 

StartupTask is complete. 

• During 
ShutdownTask 

Without any restrictions. Possible with restrictions: 
• Inputs retain status of last 

update 
• Outputs are no longer 

written. 

Possible with restrictions: 
• Inputs retain status of last 

update 
• Outputs are no longer 

written. 
1 Call of PeripheralFaultTask.  
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4.15.3 Direct access and process image of cyclic tasks 

Properties 
Direct access to inputs and outputs and access to the process image of the cyclic task 
always take place via I/O variables. The entire address range of the SIMOTION device (see 
table below) can be used.  
A comparison of the most important properties, also in comparison to the fixed process 
image of the BackgroundTask (Page 128) is contained in "Important properties of direct 
access and process image (Page 120)". 

Direct access    
The direct access is used to directly access the corresponding I/O address. Direct access is 
used primarily for sequential programming (in MotionTasks). The access to the current value 
of the inputs and outputs at a specific time is particularly important.   
For direct access, you define an I/O variable (Page 125) without assigning it a task. 

 

 Note 
An access via the process image is more efficient than direct access. 

 

Process image of the cyclic task    
The process image of the cyclic tasks is a memory area in the RAM of the SIMOTION 
device, on which the whole I/O address space of the SIMOTION device is mirrored. The 
mirror image of each I/O address is assigned to a cyclic task and is updated using this task. 
The task remains consistent throughout the whole cycle. This process image is used 
preferentially when programming the assigned task (cyclic programming). The consistency 
during the complete cycle of the task is particularly important.   
For the process image of the cyclical task you define an I/O variable (Page 125) and assign 
it a task. 
Direct access to this I/O variable is still possible: Specify direct access with _direct.var-name.   
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Address range of the SIMOTION devices 
The address range of the SIMOTION devices depending on the version of the 
SIMOTION kernel is contained in the following table. The complete address range can be 
used for direct access and process image of the cyclical tasks. 

Table 4- 17 Address range of the SIMOTION devices depending on the version of the 
SIMOTION kernel 

Address range for SIMOTION Kernel version SIMOTION device 
V3.0 V3.1, V3.2 As of V4.0 

C230-2 0 .. 1023 0 .. 2047 4 0 .. 2047 4 
C240 – – 0 .. 4096 4 

C240 PN 1 – – 0 .. 4096 5 
D410 2 – – 0 .. 16383 4 5 
D425 3 – 0 .. 4095 4 0 .. 16383 4 5 
D435 0 .. 1023 0 .. 4095 4 0 .. 16383 4 5 

D445 3 – 0 .. 4095 4 0 .. 16383 4 5 
D445-1 1 – – 0 .. 16383 4 5 

P350 0 .. 1023 0 .. 2047 4 0 .. 4095 4 
1 Available with V4.1 SP2 HF4 and higher 
2 Available with V4.1 and higher 
3 Available with V3.2 and higher 
4 For distributed I/O (over PROFIBUS DP), the transmission volume is restricted to 1024 bytes per 
PROFIBUS DP line. 
5 For distributed I/O (over PROFINET), the transmission volume is restricted to 4096 bytes per 
PROFINET segment. 

 
 

 Note 
Observe the rules for I/O addresses for direct access and the process image of the cyclical 
tasks (Page 124). 
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4.15.3.1 Rules for I/O addresses for direct access and the process image of the cyclical tasks 
 

NOTICE  
You must observe the following rules for the I/O variable addresses for direct access and 
the process image of the cyclic task (Page 122). Compliance with the rules is checked 
during the consistency check of the SIMOTION project (e.g. during the download). 
1. Addresses used for I/O variables must be present in the I/O and configured 

appropriately in the HW Config. 
2. I/O variables comprising more than one byte must not contain addresses 63 and 64 

contiguously. 
 The following I/O addresses are not permitted:  
– Inputs: PIW63, PID61, PID62, PID63 
– Outputs: PQW63, PQD61, PQD62, PQD63 

3. All addresses of an I/O variable comprising more than one byte must be within an 
address area configured in HW-config. 

4. An I/O address (input or output) can only be used by a single I/O variable of data type 
BYTE, WORD or DWORD or an array of these data types. Access to individual bits with 
I/O variables of data type BOOL is possible. 

5. If several processes (e.g. I/O variable, technology object, PROFIdrive telegram) access 
an I/O address, the following applies: 
– Only a single process can have write access to an I/O address of an output (BYTE, 

WORD or DWORD data type). 
Read access to an output with an I/O variable that is used by another process for 
write access, is possible. 

– All processes must use the same data type (BYTE, WORD, DWORD or ARRAY of 
these data types) to access this I/O address. Access to individual bits is possible 
irrespective of this. 
Please be aware of the following, for example, if you wish to use an I/O variable to 
read the PROFIdrive telegram transferred to or from the drive: The length of the I/O 
variables must match the length of the telegram. 

– Write access to different bits of an address is possible from several processes; 
however, write access with the data types BYTE, WORD or DWORD is then not 
possible. 

 

 Note 
These rules do not apply to accesses to the fixed process image of the BackgroundTask 
(Page 128). These accesses are not taken into account during the consistency check of the 
project (e.g. during download). 
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4.15.3.2 Creating I/O variables for direct access or process image of cyclic tasks 
You create I/O variables for direct access and a process image of the cyclic tasks in the 
symbol browser in the detail view; you must be in offline mode to do this.     
Here is a brief overview of the procedure: 
1. In the project navigator of SIMOTION SCOUT, select the I/O element in the subtree of the 

SIMOTION device. 
2. In the detail view, select the "Symbol browser" tab and scroll down to the end of the 

variable table (empty row). 
3. In the last (empty) row of the table, enter or select the following: 

– Name of variable. 
– I/O address according to the "syntax for entering I/O addresses (Page 127)". 
– Optional for outputs: 

Activate the "Read only" checkbox if you only want to have read access to the output. 
You can then read an output that is already being written by another process (e.g. 
output of an output cam, PROFIdrive telegram). 
A read-only output variable cannot be assigned to the process image of a cyclic task. 

– Data type of the variables in accordance with "Possible data types of the I/O variables 
(Page 128)". 

4. Optionally, you can also enter or select the following (not for data type BOOL): 
– Array length (array size). 
– Process image or direct access: 

Can only be assigned if the "Read only" checkbox is cleared. 
For process image, select the cyclic task to which you want to assign the I/O variable. 
To select a task, it must have been activated in the execution system. 
For direct access, select the blank entry. 

– Strategy for the behavior in an error situation (see SIMOTION Basic Functions 
Function Manual). 

– Substitute value (if array, for each element). 
– Display format (if array, for each element), when you monitor the variable in the 

symbol browser. 
You can now access this variable using the symbol browser or any program of the 
SIMOTION device. 
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NOTICE  
Note the following for the process image for cyclic tasks: 
• A variable can only be assigned to one task. 
• Each byte of an input or output can only be assigned to one I/O variable. 
In the case of data type BOOL, please note: 
• The process image for cyclic tasks and a strategy for errors cannot be defined. The 

behavior defined via an I/O variable for the entire byte is applicable (default: direct 
access or CPU stop). 

• The individual bits of an I/O variable can also be accessed using the bit access 
functions. 

Take care when making changes within the I/O variables (e.g. inserting and deleting I/O 
variables, changing names and addresses): 
• In some cases the internal addressing of other I/O variables may change, making all I/O 

variables inconsistent. 
• If this happens, all program sources that contain accesses to I/O variables must be 

recompiled. 
 

 
 

 Note 
I/O variables can only be created in offline mode. You create the I/O variables in SIMOTION 
SCOUT and then use them in your program sources (e.g. ST sources, MCC sources, 
LAD/FBD sources). 
Outputs can be read and written to, but inputs can only be read. 
Before you can monitor and modify new or updated I/O variables, you must download the 
project to the target system. 

 

You can use I/O variables like any other variable, see "Access I/O variables (Page 134)". 
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4.15.3.3 Syntax for entering I/O addresses 
For the input of the I/O address for the definition of an I/O variable for direct access or 
process image of cyclical tasks (Page 122), use the following syntax. This specifies not only 
the address, but also the data type of the access and the mode of access (input/output). 

Table 4- 18 Syntax for the input of the I/O addresses for direct access or process image of the cyclic tasks 

Syntax for Permissible address range Data type 
Input Output Direct access Process image e.g. direct access  

D435 V4.1 
BOOL PIn.x PQn.x n: 

x: 
0 .. MaxAddr 
0 .. 7 

 -1 n: 
x: 

0 .. 16383 
0 .. 7 

BYTE PIBn PQBn n: 0 .. MaxAddr n: 0 .. MaxAddr n: 0 .. 16383 
WORD PIWn PQWn n: 0 .. 62 

64 .. MaxAddr - 1 
n: 0 .. 62 

64 .. MaxAddr - 1 
n: 0 .. 62 

64 .. 16382 
DWORD PIDn PQDn n: 0 .. 60 

64 .. MaxAddr - 3 
n: 0 .. 60 

64 .. MaxAddr - 3 
n: 0 .. 60 

64 .. 16380 
n = logical address 
x = bit number 
MaxAddr = Maximum I/O address of the SIMOTION device depending on the version of the SIMOTION kernel, see 

address range of the SIMOTION devices in "direct access and process image of the cyclical tasks 
(Page 122)". 

1 For data type BOOL, it is not possible to define the process image for cyclic tasks. The behavior defined via an I/O 
variable for the entire byte is applicable (default: direct access). 

Examples: 
Input at logic address 1022, WORD data type: PIW1022. 
Output at logical address 63, bit 3, BOOL data type: PQ63.3. 

 

 Note 
Observe the rules for I/O addresses for direct access and the process image of the cyclical 
tasks (Page 124). 

 



LAD/FBD programming  
4.15 Access to inputs and outputs (process image, I/O variables) 

 SIMOTION LAD/FBD 
128 Programming and Operating Manual, 05/2009 

4.15.3.4 Possible data types of I/O variables 
The following data types can be assigned to the I/O variables for direct access and process 
image of the cyclical tasks (Page 122). The width of the data type must correspond to the 
data type width of the I/O address. 
If you assign a numeric data type to the I/O variables, you can access these variables as 
integer. 

Table 4- 19 Possible data types of the I/O variables for direct access and the process image of the 
cyclical tasks 

Data type of I/O address Possible data types for I/O variables 
BOOL (PIn.x, PQn.x) BOOL 
BYTE (PIBn, PQBn) BYTE, SINT, USINT 
WORD (PIWn, PQWn) WORD, INT, UINT 
DWORD (PIDn, PQDn) DWORD, DINT, UDINT 

For details of the data type of the I/O address, see also "Syntax for entering I/O addresses 
(Page 127)". 

4.15.4 Access to fixed process image of the BackgroundTask 
The process image of the BackgroundTask is a memory area in the RAM of the SIMOTION 
device, on which a subset of the I/O address space of the SIMOTION device is mirrored. 
Preferably, it should be used for programming the BackgroundTask (cyclic programming) as 
it is consistent throughout the entire cycle.     
The size of the fixed process image of the BackgroundTask for all SIMOTION devices is 64 
bytes (address range 0 ... 63). 
A comparison of the most important properties in comparison to the direct access and 
process image of the cyclical tasks (Page 122) is contained in "Important properties of direct 
access and process image (Page 120)". 

 

NOTICE  
I/O addresses that are accessed with the process image of the cyclic tasks must not be 
used. These addresses cannot be read or written to with the fixed process image of the 
BackgroundTask. 

 

 Note 
The rules for I/O addresses for direct access and the process image of the cyclical tasks 
(Page 124) do not apply. The accesses to the fixed process image of the BackgroundTask 
are not taken into account during the consistency check of the project (e.g. during 
download). 
Addresses not present in the I/O or not configured in HW Config are treated like normal 
memory addresses. 
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You can access the fixed process image of the BackgroundTask by means of: 
● Using an absolute PI access (Page 130): The absolute PI access identifier contains the 

address of the input/output and the data type. 
● Using a symbolic PI access (Page 131): You declare a variable that references the 

relevant absolute PI access. 
– A unit variable 
– A static local variable in a program. 

● Using an I/O variable (Page 133): In the symbol browser, you define a valid I/O variable 
for the entire device that references the corresponding absolute PI access.  

 

NOTICE  
Please note that if the inputs and outputs work with the little-endian byte order (e.g. the 
integrated digital inputs of SIMOTION devices C230-2, C240, or C240 PN) and the 
following conditions are fulfilled: 
1. The inputs and outputs are configured to an address 0 .. 62. 
2. An I/O variable for direct access (data type WORD, INT or UINT) has been created for 

these inputs and outputs. 
3. You also access these inputs and outputs via the fixed process image of the 

BackgroundTask. 
then the following is valid: 
• Access with the data type WORD supplies the same result via the I/O variable and the 

fixed process image of the BackgroundTask. 
• The access to the individual bytes with the _getInOutByte function (see SIMOTION 

Basic Functions Function Manual) supplies these in the Little Endian order. 
• Access to the individual bytes or bits with the fixed process image of the 

BackgroundTask supplies these in the Big Endian order. 
For information on the order of the bytes Little Endian and Big Endian: Please refer to the 
SIMOTION Basic Functions Function Manual. 
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4.15.4.1 Absolute access to the fixed process image of the BackgroundTask (absolute PI access) 
You make absolute access to the fixed process image of the BackgroundTask (Page 128) by 
directly using the identifier for the address (with implicit data type). The syntax of the 
identifier (Page 130) is described in the following section. 
You can use the identifier for the absolute PI access in the same manner as a normal 
variable. 

 

 Note 
Outputs can be read and written to, but inputs can only be read. 

 

 

4.15.4.2 Syntax for the identifier for an absolute process image access 
For the absolute access to the fixed process image of the BackgroundTask (Page 130), use 
the following syntax. This specifies not only the address, but also the data type of the access 
and the mode of access (input/output). 
You also use these identifiers: 
● For the declaration of a symbolic access to the fixed process image of the 

BackgroundTask (Page 131). 
● For the creation of an I/O variables for accessing the fixed process image of the 

BackgroundTask (Page 133). 

Table 4- 20 Syntax for the identifier for an absolute process image access 

Syntax for Data type 
Input Output 

Permissible address range 

BOOL %In.x 
 or 
%IXn.x1 

%Qn.x 
or 
%QXn.x1 

n: 
x : 

0 .. 63 2 
0 .. 7 

BYTE %IBn %QBn n: 0 .. 63 2 
WORD %IWn %QWn n: 0 .. 63 2 
DWORD %IDn %QDn n: 0 .. 63 2 
n = logical address 
x = bit number 
1 The syntax %IXn.x or %QXn.x is not permitted when defining I/O variables. 
2 Except for the addresses used in the process image of the cyclic tasks. 
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Examples 
Input at logic address 62, WORD data type: %IW62. 
Output at logical address 63, bit 3, BOOL data type: %Q63.3. 

 

NOTICE  
Addresses that are accessed with the process image of the cyclic tasks must not be used. 
These addresses cannot be read or written to with the fixed process image of the 
BackgroundTask. 

 

 Note 
The rules for I/O addresses for direct access and the process image of the cyclical tasks 
(Page 124) do not apply. The accesses to the fixed process image of the BackgroundTask 
are not taken into account during the consistency check of the project (e.g. during 
download). 
Addresses not present in the I/O or not configured in HW Config are treated like normal 
memory addresses. 

 

4.15.4.3 Defining symbolic access to the fixed process image of the BackgroundTask 
You create symbolic access to the fixed process image of the Background Task in the 
declaration table of the source file or the MCC chart or LAD/FBD program (only in the case 
of programs). The scope of the symbolic process image access is dependent on the location 
of the declaration: 
● In the interface section of the declaration table of the source file (INTERFACE): 

Symbolic process image access behaves like a unit variable; it is valid for the entire 
source file; all MCC charts or LAD/FBD programs (programs, function blocks, and 
functions) within the source file can access the process image. 
In addition, these variables are available on HMI devices and, once connected, in other 
source files (or other units), as well. 
The total size of all unit variables in the interface section is limited to 64 Kbytes. 

● In the implementation section of the declaration table of the source file 
(IMPLEMENTATION): 
Symbolic process image access behaves like a unit variable; it is only valid in the source 
file; all MCC charts or LAD/FBD programs (programs, function blocks, and functions) 
within the source file can access it. 

● In the declaration table for the MCC chart or LAD/FBD program (only in the case of 
programs): 
Symbolic process image access behaves like a local variable; it can only be accessed 
within the MCC chart or LAD/FBD program in which it is declared.  
No symbolic process image access can be declared in functions or function blocks. 
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Proceed as follows; the source file or the MCC chart or LAD/FBD program (programs only) 
with the declaration table is opened: 
1. Select the declaration table and, if applicable, the section of the declaration table for the 

desired scope. 
2. Select the I/O Symbols tab. 
3. Enter: 

– Name of symbol (variable name) 
– For Absolute ID, the identifier of the absolute process image access (Page 130). 
– Data type of symbol (Page 132) (this must agree with the length of the process image 

access). 

4.15.4.4 Possible data types for symbolic PI access 
In the following cases, a data type that differs from that of the absolute PI access can be 
assigned to the fixed process image of the BackgroundTask (Page 128). The data type width 
must correspond to the data type width of the absolute PI access. 
● For the declaration of a symbolic PI access (Page 131). 
● For the creation of an I/O variable (Page 133). 
If you assign a numeric data type to the symbolic PI access or to the I/O variables, you can 
access these variables as integer. 

Table 4- 21 Possible data types for symbolic PI access 

Data type of the 
absolute PI access 

Possible data types of the  
symbolic PI access 

BOOL (%In.x, %IXn.x, %Qn.x. %QXn.x) BOOL 
BYTE (%IBn, %QBn) BYTE, SINT, USINT 
WORD (%IWn, %QWn) WORD, INT, UINT 
DWORD (%IDn, %PQDn) DWORD, DINT, UDINT 

For the data type of the absolute PI access, see also "Syntax for the identifier for an absolute 
PI access (Page 130)". 
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4.15.4.5 Example: Defining symbolic access to the fixed process image of the BackgroundTask 

 
Figure 4-31 Example: Defining symbolic access to the fixed process image of the BackgroundTask 

 

4.15.4.6 Creating an I/O variable for access to the fixed process image of the BackgroundTask 
You create I/O variables for access to the fixed process image for the background task in the 
symbol browser in the detail view; you must be in offline mode to do this.     
Here is a brief overview of the procedure: 
1. In the project navigator of SIMOTION SCOUT, select the "I/O" element in the subtree of 

the SIMOTION device. 
2. In the detail view, select the Symbol browser tab and scroll down to the end of the 

variable table (empty row). 
3. In the last (empty) row of the table, enter or select the following: 

– Name of variable. 
– Under I/O address, the absolute PI access according to the "syntax for the identifier 

for an absolute PI access (Page 130)" 
 (exception: The syntax %IXn.x or %QXn.x is not permitted for data type BOOL). 

– Data type of the I/O variables according to the "possible data types of the symbolic PI 
access (Page 132)". 

4. Select optionally the display format used to monitor the variable in the symbol browser. 
You can now access this variable using the symbol browser or any program of the 
SIMOTION device.  

 

 Note 
I/O variables can only be created in offline mode. You create the I/O variables in SIMOTION 
SCOUT and use them in your program sources. 
Note that you can read and write outputs but you can only read inputs. 
Before you can monitor and modify new or updated I/O variables, you must download the 
project to the target system. 

 

 
You can use I/O variables like any other variable, see "Access I/O variables (Page 134)". 
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4.15.5 Accessing I/O variables 
You have created an I/O variable for: 
● Direct access or process image of the cyclic tasks (Page 122). 
● Access to the fixed process image of the BackgroundTask (Page 128). 
You can use this I/O variable just like any other variable. 

 

NOTICE  
Consistency is only ensured for elementary data types. 
When using arrays, the user is responsible for ensuring data consistency. 

 

 
 

 Note 
If you have declared unit variables or local variables of the same name (e.g. var-name), 
specify the I/O variable using _device.var-name (predefined namespace, see the 
"Predefined namespaces" table in "Namespaces"). 
It is possible to directly access an I/O variable that you created as a process image of a 
cyclic task. Specify direct access with _direct.var-name or _device._direct.var-name. 

 

 
If you want to deviate from the default behavior when errors occur during variable access, 
you can use the _getSafeValue and _setSafeValue functions (see SIMOTION Basic 
Functions Function Manual).  
For errors associated with access to I/O variables, see SIMOTION Basic Functions Function 
Manual. 
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4.16 Connections to other program source files or libraries 
In the declaration table of a source file, you can define connections to:       
● LAD/FBD units under the same SIMOTION device 
● MCC source files under the same SIMOTION device 
● ST source files under the same SIMOTION device 
● Libraries 
This will then allow you to access the following in this source file: 
● In the case of connected program sources, the following items which are defined there 

– Functions 
– Function blocks 
– Programs (optional) 
– Unit variables 
– User-defined data types (structures, enumerations) 
– Symbolic accesses to the fixed process image of the BackgroundTask 

● In the case of connected libraries, the following items which are defined there 
– Functions 
– Function blocks 
– Programs (optional) 
– User-defined data types (structures, enumerations) 

Program source files and libraries must be compiled beforehand. 
For information about the library concept, see also the SIMOTION ST Programming Manual. 

 

 Note 
Libraries can be created in all programming languages (MCC, ST, or LAD/FBD). 
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4.16.1 Defining connections 

4.16.1.1 Procedure for defining connections to other units (program source files) 
Connections to other units (program sources) are defined in the declaration table of the 
source file. The mode of action of a connection is dependent on the section of the 
declaration table in which it is defined. 
● In the interface section of the declaration table: 

The imported functions, variables, etc., will continue to be exported to other units and to 
HMI devices. This can lead to name conflicts. 
This setting is necessary, for example, if unit variables are declared in the interface 
section of the source file with a data type that is defined in the imported program source 
file. 

● In the implementation section of the declaration table: 
The imported functions, variables, etc. will no longer be exported. 
This setting is usually sufficient. 

Proceed as follows; the source file (declaration table) is open (see Open existing program 
source files (Page 42)): 
1. In the declaration table, select the section for the desired mode of action. 
2. Select the Connections tab. 
3. For the connection type, select: Program/Unit 
4. In the same line, select the name of the unit to be connected: 

Units (program sources) must be compiled beforehand. 
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4.16.1.2 Procedure for defining connections to libraries 
Connections to libraries are defined in the declaration table of the source file. 
Proceed as follows; the source file (declaration table) is open (see Open existing program 
source files (Page 42)): 
1. In the interface section of the declaration table, select the Connections tab. 
2. For the connection type, select: Library. 
3. In the same line, select the name of the library to be connected. 

Libraries must be compiled beforehand. 
4. Optionally, you can define a name space for libraries (see Using name space 

(Page 137)): 
To do this, enter a name under Name space. 

 

 
 

Note 
When programming the subroutine call command (see Inserting and parameterizing 
subroutine calls (Page 142)) with a library function or a library function block, the 
connection to the library is automatically entered into the declaration table of the program 
source file; the name of the library is assigned as the name space. You can also change 
the designation of the name space at a later point in time. 

 

4.16.2 Using the name space 
You can optionally assign a name space to every connected library. You define the 
designation of the name space when connecting the library (see How to define connections 
to libraries (Page 137)).   
It is important to specify the name space if the current LAD/FBD program/MCC chart or 
program source file contains variables, data types, functions, or function blocks with the 
same name as the connected library. The name space will then allow you to specifically 
access the variables, data types, functions, or function blocks in the library. This can also 
resolve naming conflicts between connected libraries. 
If you wish to use variables, data types, functions, or function blocks from the connected 
library in a command in the LAD/FBD program/MCC chart, then insert the designation of the 
name space in front of the variable name, etc., from the library, separated by a period (for 
example, namespace.var_name, namespace.fc_name). 
Name spaces are predefined for device-specific and project-specific variables, direct 
accesses to I/O variables, and variables of TaskId and AlarmId in the following table: If 
necessary, write their designation before the variable name, separated by a period, e.g. 
_device.var_name or _task.task_name. 
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Table 4- 22 Predefined name spaces 

Name space Description 
_alarm  For AlarmId: The _alarm.name variable contains the AlarmId of the message with 

the name identifier – see SIMOTION ST Programming Manual. 
_device  For device-specific variables (global device user variables, I/O variables, system 

variables, and system variables of the SIMOTION device) 
_direct  By means of direct access to I/O variables. 

Local name space for _device. Nesting as in _device._direct.name is permitted. 
_project  For names of SIMOTION devices in the project; only used with technology objects 

on other devices. 
With unique project-wide names of technology objects, used also for these names 
and their system variables 

_task  For TaskID: The _task.name variable contains the TaskId of the task with the name 
identifier – see SIMOTION ST Programming and Operating Manual. 

_to  For technology objects as well as their system variables and configuration data – 
see SIMOTION ST Programming and Operating Manual. 
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4.17 Subroutine 
Universal, reusable sections of a program can be created in the form of subroutines.   
When a subroutine is called, the program branches from the current task into the subroutine. 
The commands in the subroutine are executed. The program then jumps back to the 
previously active task. 
Subroutines can be called repeatedly, as required, by one or more LAD/FBD programs of the 
SIMOTION device. 

Subroutine as a function (FC), function block (FB), or program  
The creation type of a subroutine can be a function (FC), a function block (FB) or, as an 
option, a program ("program in program"). 
● Function 

A function (FC) is a subroutine without static data, that is, all local variables lose their 
value when the function has been executed. They are re-initialized when the function is 
next started. 
Data are transferred to the function using input or in/out parameters; the output of a 
function value (return value) is also possible. 

● Function block 
A function block (FB) is a subroutine with static data, that is, local variables retain their 
value after the function block has been executed. Only variables that have been explicitly 
declared as temporary lose their value. 
An instance has to be defined before using an FB: Define a variable (VAR or 
VAR_GLOBAL) and enter the name of the FB as data type. The FB static data is saved in 
this instance. You can define several FB instances; each instance is independent from 
the others. 
The static data of an FB instance remain stored until the instance is next called; they are 
reinitialized when the variable type of the FB instance is initialized again (see Initialization 
of instances of function blocks (FB) (Page 116)). 
Data are transferred to the FB using input parameters or in/out parameters; the data are 
returned from the FB using in/out or output parameters. 
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● Program ("program in program") 
You also have the option of calling a program within a different program or a function 
block. This requires the following compiler options to be activated (see Global compiler 
settings (Page 48) and Local compiler settings (Page 49)): 
– "Permit language extensions" for the program source of the calling program or 

function block and 
– "Only create program instance data once" for the program source of the called 

program. The static data of the called program is stored in the user memory of the 
program source (unit) of said called program. 

Most of the programming work involved in assigning the programs to the tasks can be 
performed by calling up programs within another program. In the execution system, only 
one associated calling program needs to be assigned to the tasks concerned. 
A program is called without parameters or return values. 
Further information on calling a program within a program can be found in the ST 
Programming and Operating Manual. 

 

NOTICE  
The activated "Only create program instance data once" compiler option causes: 
• The static variables of the programs (program instance data) to be stored in the user 

memory of the program source (unit) (see the SIMOTION ST Programming and 
Operating Manual). This also causes the initialization behavior to change (see the 
SIMOTION ST Programming and Operating Manual). 

• All called programs with the same name to use the same program instance data. 
 

Exchange of information between the subroutine and calling program   

Function (FC) and function block (FB) as a subroutine 
Information is exchanged between the subroutine and the calling program using transfer 
parameters or global variables (e.g. unit variables). 
Transfer parameters can be input, input/output or output parameters. They are defined in the 
declaration table for the subroutine: 
● Input parameters: As variable type VAR_INPUT 
● In/out parameter: As variable type VAR_IN_OUT 
● Output parameter (for FB only): As variable type VAR_OUTPUT 
For functions, a function value can be returned; you specify the data type of the return value 
when you insert (create) the function (see Insert function (FC) or function block (FB) 
(Page 141)). 
You assign current values to the input and/or in/out parameters when you call the subroutine 
(FC or FB instance). You may only assign user-defined variables to the in/out parameters of 
an FB because the called FB accesses the assigned variables directly and can therefore 
change them. 
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The output parameters of an FB can be read-accessed as often as required in the calling 
program. 
A function does not formally contain any output parameters, since the result of the function 
can in this case be assigned to the return value of the function. 
See also the examples of functions (Page 145) and function blocks (Page 150). 

Program as subroutine ("program in program") 
A program is called without parameters or return values. This means that information can 
only be exchanged between the calling program and the called program (subroutine) using 
global variables (e.g. unit variables). 

See also 
Inserting a subroutine call into the LAD/FBD program and assigning parameters (Page 142) 

4.17.1 Inserting a function (FC) or function block (FB) 
The creation dialog is similar to that of an LAD/FBD program:    
1. LAD/FBD unit must already exist (see Managing LAD/FBD programs (Page 52)). 
2. In the project navigator, open the relevant LAD/FBD unit. 
3. Double-click the entry Insert LAD/FBD program. 

The input screen form opens. 
– Enter the name of the LAD/FBD program (see Rules for identifiers (Page 89)). 
– For the creation type, select Function or Function block. 
– With creation type Function only: 

Select the data type of the return value as the return type (<--> for no return value). 
– Check the Exportable option if the function or function block is to be used in other 

program source files (LAD/FBD, MCC or ST source files). 
When the checkbox is cleared, the LAD/FBD program can only be used in the 
associated LAD/FBD unit. 

– You can also enter an author, version, and a comment. 
– Confirm with OK. 

4. Program the instructions in the function or function block. 
Assign an expression to the return value of a function (= function name) or to the output 
parameters of a function block. 

5. Accept and compile the LAD/FBD unit. The subroutine you have created will then be 
displayed in the list. 
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4.17.2 Inserting a subroutine call into the LAD/FBD program and assigning parameters 
In order to execute a call of a subroutine (function, function block, or program), the relevant 
subroutine must have been inserted into the network of an LAD/FBD program from the 
project navigator using drag-and-drop. When the subroutine inserted into the network is 
reached during a program run, the subroutine is called and the program branches from the 
current task into the subroutine. 
You can use drag-and-drop to insert the following FCs, FBs, and programs into an LAD/FBD 
program and call them as a subroutine: 
● Functions, function blocks, or programs of the same LAD/FBD unit or a different program 

source (e.g. MCC unit, ST source file). 
● Library functions or library function blocks from a program library. 
The subroutine call is parameterized, i.e. specifications are made as to which variables are 
to be transferred when the subroutine is called and returned once it has been executed, in 
the Enter Call Parameter parameter screen form. 

 
Figure 4-32 Parameterization of a function's subroutine call 
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NOTICE  
Pay attention to the order of the LAD/FBD programs in an LAD/FBD unit. A subroutine 
(function, function block, or program) must be defined before it is used. This is the case 
when the subroutine appears above the LAD/FBD program in which it is used in the project 
navigator. If necessary, reorder the LAD/FBD programs. 
See also: Subroutine call of the function (FC) (Page 147)  

 

 Note 
The term "LAD/FBD program" is a generic term and may refer to a program, a function (FC), 
or a function block (FB). 

 

4.17.2.1 Overview of parameters for 
You can set the following parameters when parameterizing the subroutine call: 

Overview of Subroutine call parameters 
 
Field/Button Explanation/instructions 
Subroutine type/ 
Subroutine 

The type and name of the subroutine are displayed here: 
Function(default value) 
A function is a calculation subroutine that supplies a defined result as a return 
value based on the parameter entered. Functions have no memory beyond the 
call. 
Function block 
A function block is a subroutine that can have several return values. A function 
block corresponds to a data type. Instances are defined. They have a memory, 
that is, they retain instance data of a function block extending over several calls. 
Return values of the call can also be scanned in the instance. 
Program ("program in program") 
You also have the option of calling a program within a different program or a 
function block. 
This requires the following compiler options to be activated (see Global compiler 
settings (Page 48) and Local compiler settings (Page 49)): 
• "Permit language extensions" for the program source of the calling program 

or function block and 
• "Only create program instance data once" for the program source of the 

called program. The static data of the called program is stored in the user 
memory of the program source (unit) of said called program. The same 
program instance data is used every time the program is called. 

A program is called without parameters or return values. 
Return value In the case of a function-type subroutine: 

Here, you enter the variable in which the return value is to be stored. The type of 
variable must match the return value type. 
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Field/Button Explanation/instructions 
Type In the case of a function-type subroutine: 

The data type of the return value is displayed. 
Instance In the case of a function block-type subroutine: 

Here, enter the name of the function block instance. The instance contains the 
memory of the function block in the form of instance data. 
You define the instance as a variable whose data type is the name of the 
function block in one of the following ways: 
• In the declaration table of the LAD/FBD unit as VAR_GLOBAL 
• In the declaration table of the LAD/FBD program as VAR 

List of transfer parameters 
Name The name of the transfer parameter is displayed here. 
On / Off The variable type of the transfer parameter is displayed here. 

VAR_INPUT 
Input parameter (for functions and function blocks) 
VAR_IN_OUT 
In/out parameter (for functions and function blocks) 
VAR_OUTPUT 
Output parameter (for function blocks only) 

Data type The data type of the transfer parameter is displayed here. 
Value Here, you can assign current variables or values to the transfer parameters: 

• Input parameter (variable type VAR_IN): 

Here, you enter a variable name or an expression. The assignment of 
system variables or I/O variables is permissible; type transformations are 
possible. 

• In/out parameter (variable type VAR_IN): 

Enter a variable name; the variable must be directly writable and readable. 
System variables of SIMOTION devices and technology objects are not 
permitted nor are I/O variables. The data type of the in/out parameter must 
correspond to that of the assigned variables; application of type 
transformation functions is not possible. 

• Output parameter (variable type VAR_OUTPUT – for FB only): 

The assignment of an output parameter to a variable in this parameter 
screen form is optional; you can also access an output parameter after 
executing the function block. 

When assigned in this parameter screen form: Enter a variable name. The 
data type of the output parameter must correspond to that of the assigned 
variables; the application of type transformation functions is not possible. 
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4.17.3 Example: Function (FC) 
You want to create a subroutine with a circumference calculation for a circle. The calculation 
is performed in a function (FC). This is named Circumference.   
The circle circumference calculation can thus be called as a subroutine by any task. 
Formula for circumference calculation: Circumference = PI * 2 * radius 
You define the Radius and PI variables in the declaration table of the function. 

4.17.3.1 Creating and programming the function (FC) 
1. In the project navigator, open the LAD/FBD unit in which you want to create the function. 
2. Double-click the entry Insert LAD/FBD program. 

– Enter the name Circumference. 
– For creation type, select Function. 
– For return type (data type of return value), select REAL. 
– Confirm with OK. 

3. In the declaration table, define the Radius input parameters, the Diameter parameter, and 
the PI constant. 

 
Figure 4-33 Declaring variables (e.g. input parameters) in the LAD/FBD program 

4. Click the Insert network button on the LAD editor toolbar. 
A network is inserted into the Circumference function. 

5. Drag the LAD/FBD element MUL from the command library and drop it into the network of 
the Circumference function twice. 
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6. Program the circumference calculation for the return value by assigning the variables 
accordingly to the input/output parameters of the two MUL LAD/FBD elements. 

 
Figure 4-34 Programming the Circumference subroutine (e.g. assignment to a return value) 

7. Accept and compile the LAD/FBD unit. 
You have now finished programming the Circumference function. 

 

 Note 
The term "LAD/FBD program" is a generic term and may refer to a program, a function (FC), 
or a function block (FB). 
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4.17.3.2 Subroutine call of function (FC) 
The function (FC) is called from a program in the example. 
1. Create an LAD/FBD program as a program in the same LAD/FBD unit (see Inserting a 

new LAD/FBD program (Page 52)): 
– Enter the name Program_circumference. 
– For creation type, select Program. 
– Confirm with OK. 

2. Declare the following in the LAD/FBD unit or the LAD/FBD program: 
– The mycircum variable.  

The return value of the "Circumference" function is assigned to this variable. 
– The myradius variable.  

This variable contains the radius and is assigned to the input parameter Radius of the 
Circumference function. 

Note that the validity range of the variables is dependent on the declaration location (see 
Define variables (Page 104)). 

 
① You can continue to use the myumfang (mycircum) variable in the program. 
Figure 4-35 Declaring a variable in the LAD/FBD program 

1. Click the Insert network button on the LAD editor toolbar. 
A network is inserted into the Program_circumference program. 

2. Drag the Circumference function from the project navigator and drop it into the network of 
the Program_circumference program. 

3. Select the inserted function, Circumference, followed by the Parameterize call command 
from the context menu. 
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4. Assign parameters to the subroutine call in the Enter Call Parameter parameter screen 
form. 

 
Figure 4-36 Opened parameter screen form for assigning parameters to the subroutine call 
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5. Pay attention to the order of the LAD/FBD programs in the LAD/FBD unit. The LAD/FBD 
program with the function (FC) must appear in the project navigator above the LAD/FBD 
program containing the subroutine call.  
In other words, the Circumference function must be positioned in the project navigator 
above the Program_circumference program.  
If necessary, reorder the LAD/FBD programs by selecting the relevant LAD/FBD program 
in the project navigator, then selecting the Down or Up command in the context menu. 

 
① Circumference function 
② Program_circumference program, which contains the subroutine call of the Circumference 

function 

Order of LAD/FBD programs 
 

6. Accept and compile the LAD/FBD unit. 
You have now finished programming the subroutine call. 

 

 Note 
The term "LAD/FBD program" is a generic term and may refer to a program, a function (FC), 
or a function block (FB). 
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4.17.4 Example: Function block (FB) 
You want to calculate a following error. The calculation is performed in a function block (FB) 
named FollError. The following error calculation can thus be called as a subroutine by any 
task. 
Formula for following error calculation: Difference = Specified position – Actual position 
Define the required input and output parameters Set position, Actual position, and Difference 
(with the other variables, if necessary) in the LAD/FBD program (function block) or LAD/FBD 
unit. 

4.17.4.1 Creating and programming the function block (FB) 
1. In the project navigator, open the LAD/FBD unit in which you want to create the function 

block. 
2. Double-click the entry Insert LAD/FBD program. 

– Enter the name FollError. 
– For creation type, select Function block. 
– Confirm with OK. 

3. In the declaration table, define the variables (e.g. input and output parameters). 

 
Figure 4-37 Declaring variables (e.g. input and output parameters) in the LAD/FBD program 

4. Click the Insert network button on the LAD editor toolbar. 
A network is inserted into the FollError function block. 

5. Drag the LAD/FBD element SUB from the command library and drop it into the network of 
the FollError function block. 
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6. Program the following error calculation by assigning the variables accordingly to the 
input/output parameters of the SUB LAD/FBD element. 

 
Figure 4-38 Programming the following error calculation 

7. Accept and compile the LAD/FBD unit. 
You have now finished programming the FollError function block. 

 

 Note 
The term "LAD/FBD program" is a generic term and may refer to a program, a function (FC), 
or a function block (FB). 

 

 

4.17.4.2 Subroutine call of function block (FB) 
In this example, the function block (FB) is called from a program. 
1. Create an LAD/FBD program as a program (see Inserting a new LAD/FBD program 

(Page 52)). 
2. Create a function block instance. 

– In the LAD/FBD unit or LAD/FBD program, declare the instances of the function block 
along with the variables. 

Note that the validity range of the instance and variables is dependent on the declaration 
location (see Define variables (Page 104)).  

3. Call the function block: 
– Program the subroutine call. 

4. After executing an instance of the function block, you can access the output parameters 
at any location in the calling program. 
– Program the MOVE command. 

5. Accept and compile the program. 
You have now finished programming the subroutine call. 
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4.17.4.3 Creating a function block instance 
Before you can use a function block, you must define an instance. Each instance of an FB is 
independent of the others; once an instance has ended, its static variables remain stored. 
Instances of an FB are defined in the declaration tables of the LAD/FBD unit or of the 
LAD/FBD program. The scope of the instance declaration is dependent on the location of the 
declaration: 
● In the interface section of the declaration table of the LAD/FBD unit: 

The instance behaves like a unit variable; it is valid for the entire LAD/FBD unit; all 
LAD/FBD programs (programs, function blocks, and functions) within the LAD/FBD unit 
can access the instance. 
In addition, the instance is available on HMI devices and, once connected (see How to 
define connections to other units (program source files) (Page 136)), in other LAD/FBD 
units (or other units), as well. 
The total size of all unit variables in the interface section is limited to 64 Kbytes. 

● In the implementation section of the declaration table of the LAD/FBD unit: 
The instance behaves like a unit variable which is only valid in the LAD/FBD unit; all 
LAD/FBD programs (programs, function blocks, and functions) within the LAD/FBD unit 
can access the instance. 

● In the declaration table of the LAD/FBD program (for programs and function blocks only): 
The instance behaves like a local variable; it can only be accessed within the LAD/FBD 
program in which it is declared. 

Proceed as follows; the LAD/FBD unit or the LAD/FBD program with the declaration table is 
open (see Open existing LAD/FBD unit (Page 42) or Open existing LAD/FBD program 
(Page 54)): 
1. Select the declaration table and, if applicable, the section of the declaration table for the 

desired scope. 
2. Select the Parameter tab. 
3. Enter or select the following: 

– Name of instance (variable name – see Rules for identifiers (Page 89)) 
– Variable type VAR or VAR_GLOBAL, depending on the declaration location (in 

LAD/FBD program or LAD/FBD unit, respectively) 
– Designation of the function block as data type. 
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4. Declare the other variables. 

 
① The output parameter Difference is assigned to the variable Result_2 during subsequent 

program runtime. You can use the Result_2 variable for other purposes in the program. 
② The output parameter Difference is assigned to the variable Result in the subroutine call. You 

can use the Result variable for other purposes in the program. 
③ Creating an instance 
④ Select the required FB as the data type.  

The created function blocks are offered as data types in the drop-down list box depending on 
the LAD/FBD editor settings (Page 34): 
• Only function blocks with the same program source or from connected program sources or 

libraries 
• All function blocks defined in the project 

Figure 4-39 Defining an instance of the function block and variables in the LAD/FBD program or the 
LAD/FBD unit 
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4.17.4.4 Programming the subroutine call of the function block 
1. Drag the FollError function block from the project navigator and drop it into the network of 

the program_FollError LAD/FBD program. 
2. Select the inserted function block, FollError, followed by the Display > All Box Parameters 

command from the context menu. 
All the input/output parameters of the inserted function block FollError are shown. 

3. Select the inserted function block, FollError, followed by the Parameterize call command 
from the context menu. 

4. Assign parameters to the subroutine call in the Enter Call Parameter parameter screen 
form: 
– In the Value column, select the Result variable for the Difference output parameter. 
– Enter the instance myfollerror, defined in the declaration table, in the Instance field. 

The input and in/out parameters of the FB are displayed. 

 
Figure 4-40 Opened parameter screen form for assigning parameters to the subroutine call 

5. Confirm with OK. 
6. Assign the current values to the transfer parameters: 

– Input parameters: Variable or expression 
– In/out parameter: Directly readable/writable variable 
– Output parameter (optional): Variable 
You can use drag-and-drop to assign unit variables and system variables from the detail 
view to the input, output, or in/out parameters of the instance of the FollError function 
block inserted into the LAD/FBD network. 
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Figure 4-41 Assigning system variables from the detail view to the transfer parameters using drag-

and-drop 

7. Pay attention to the order of the LAD/FBD programs in the LAD/FBD unit. The LAD/FBD 
program with the function block must appear in the project navigator above the LAD/FBD 
program containing the program with the subroutine call.  
In other words, the FollError function block must be positioned in the project navigator 
above the Program_FollError program. 
If necessary, reorder the LAD/FBD programs by selecting the relevant LAD/FBD program 
in the project navigator, then selecting the Down or Up command in the context menu. 
See also: Subroutine call of the function (FC) (Page 147)  

 

 Note 
The term "LAD/FBD program" is a generic term and may refer to a program, a function (FC), 
or a function block (FB). 
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4.17.4.5 Accessing the output parameters of the function block retrospectively 
After an instance of the function block has been executed, the static variables of the function 
block (including the output parameters) are retained. You can access the output parameters 
at any point in the calling program. 
If you have defined the FB instance as VAR_GLOBAL, you can also access the output 
parameter in other LAD/FBD programs. 
1. Insert the MOVE command into the LAD/FBD program. 
2. Program the command (see figure). 

 
① Name of the FB instance ② Output parameter 

Figure 4-42 Programming a variable assignment 
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4.17.5 Limitations with advance signal switching 
An output from an LAD/FBD element can only be connected in advance of an LAP/FBD 
element input if both the input and output are of data type BOOL. As a result, only Boolean 
advance signal switching is possible in a network.         
An output parameter from an FB or a return value from an FC cannot be switched to an input 
parameter of a different FB/FC, i.e. Boolean advance signal switching is not possible here 
either. 
Non-Boolean advance signal switching and output/input parameter switching with the FB/FC 
can be implemented with the aid of an additional network and a temporary variable. If the 
output from an LAD/FBD element cannot be assigned directly to the input of the other 
LAD/FBD element, then the former LAD/FBD element is added to this additional network. 
The same temporary variable is assigned to both output and input, and so the output and 
input are switched via the temporary variable. 
Alternatively, this can also be implemented with just one network and a temporary variable, 
with the result that both LAD/FBD elements are in the same network. 

Example of output/input parameter switching with FB/FC 
In the ST programming language, with TO commands from the commands library the 
"commandid" input parameter can be assigned directly with the _getcommandid function.  
This output/input parameter switch with FB/FC can be implemented in the LAD/FBD 
programming language with an additional network for the _getcommandid function and a 
temporary variable.  
The _getcommandid function is added to the upper network, and the temporary variable 
"var_commandid" is assigned to its output "OUT". The TO command _pos  is added to the 
lower network, and the temporary variable "var_commandid" is likewise assigned to its input 
"commandid". The switching of the output "OUT" of _getcommandid and of the input 
"commandid" of _pos  is thus effected using the temporary variable. 

 
Figure 4-43 Output/input parameter switching with FB/FC 



LAD/FBD programming  
4.17 Subroutine 

 SIMOTION LAD/FBD 
158 Programming and Operating Manual, 05/2009 

4.17.6 Interface adjustment with FB/FC 
If the properties of an FB/FC that has been added to the network are modified, then in the 
following cases there will be an interface adjustment:        
1. One or more new input/output parameters are added 
2. One or more unused input/output parameters are deleted 
3. One or more used input/output parameters are deleted 
In cases 1 and 2 the network is updated immediately when it is opened in the LAD/FBD 
editor, or immediately after it is opened. 
In case 3 the FB/FC call is shown in red in the network, and a manual update must be 
carried out. An existing Boolean advance switching of a deleted input parameter is not 
deleted; instead it is merely separated off and, for instance, shown in the LAD display as an 
as an open ladder diagram in the network. 

Manual update of a specific FB/FC call 
To manually update a particular FB/FC call, follow these steps: 
1. Click on the desired FB/FC call. 
2. Select the Update call command in the context menu. 

The FB/FC call is shown with the input/output parameters which are currently present, i.e. 
without the deleted input/output parameters. 

Manually updating all FB/FC calls 
To manually update all the FB/FC calls for the program organization unit (POU) currently 
displayed in the work area, follow these steps: 
1. Click on an empty position in the network. 
2. Select the Update all calls for all networks command in the context menu. 

The FB/FC calls are shown with the input/output parameters which are currently present, 
i.e. without the deleted input/output parameters. 

 
For the following cases there is no interface adjustment available, and so updating must be 
performed entering data manually or with Find/Replace (see restrictions under Find/Replace 
in a Project (Page 81)): 
● Changing the name of the instance variable (only for FBs) 
● Changing the name, the data type of the box type of the FB/FC call 
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① Instance variable (instance name) 

Only used with FBs. 
In the declaration table an FB instance is declared by specifying the instance variable with the name of the FB as 
the data type. This instance variable (instance name) is used for calling up the FB. 

② Data type 
The relevant FB is assigned to the instance variable as its data type.  
In order for an FB call to work correctly, the data type and box type must be identical, otherwise the FB call will be 
displayed in red in the network. 

③ Box type, consisting of: 
• the type name, e.g. MOVE, ADD etc. or the names of user programs/FBs/FCs 
• the type, i.e. the selected creation type (program, FB or FC) of the LAD/FBD program 

④ Instance variable (instance name) 
Only for FBs. 

⑤ Name of the FB/FC (type of a (user-defined) FB/FC) 
FB: The name of the FB is used as the data type in the FB instance declaration in the declaration table. 
FC: The name of the FC is used as the box type. 

Figure 4-44 Overview of FB/FC terms used 
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Display in the Detail view 
Only in case 3 are the deleted input/output parameters and the deleted variables assigned to 
them displayed in the Detail view in the Compile/check output  window immediately after a 
manual update. Deleted input parameters with Boolean advance switching are not displayed 
because the advance switching is merely separated off and therefore continues to exist in 
the network. 



 LAD/FBD programming 
 4.18 Reference data 

SIMOTION LAD/FBD 
Programming and Operating Manual, 05/2009 161 

4.18 Reference data 
The reference data provide you with an overview of:   
● on utilized identifiers with information about their declaration and use  

(Cross-reference list (Page 161)). 
● on function calls and their nesting  

(Program structure (Page 165)) 
● on the memory requirement for various data areas of the program sources 

(Code attributes (Page 166)) 

4.18.1 Cross reference list 
The cross-reference list shows all identifiers in program sources (e.g. ST source files, MCC 
source files):   
● Declared as variables, data types, or program organization units (program, function, 

function block) 
● Used as previously defined types in declarations 
● Used as variables in the statement section of a program organization unit. 
You can generate the cross-reference list selectively for: 
● An individual program source (e.g. ST source file, MCC source file, LAD/FBD source) 
● All program sources of a SIMOTION device 
● All program sources and libraries of the project 
● Libraries (all libraries, single library) 

4.18.1.1 Creating a cross-reference list 
To create the cross-reference list:   
1. In the project navigator, select the element for which you want to create a cross-reference 

list. 
2. Select the menu Edit > Reference data > Create. 
The cross-reference list is displayed in its own tab in the detail view. 
 

 

 Note 
The generated cross-reference list is saved automatically and can be displayed selectively 
after selecting the appropriate element in the project navigator. To display the cross-
reference list, select the Edit > Reference data > Display > Cross-Reference List menu 
command. 
When a cross-reference list is recreated, it is updated selectively (corresponding to the 
selected element in the project navigator). Other existing cross-reference data are retained 
and displayed, if applicable. 
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4.18.1.2 Content of the cross-reference list 
The cross-reference list contains all the identifiers assigned to the element selected in the 
project navigator. The applications for the identifiers are also listed in a table:        
Details of how to work with the cross-reference list are described in the section "Working with 
the cross-reference list (Page 164)". 

Table 4- 23 Meanings of columns and selected entries in the cross-reference list 

Column Entry in column Meaning 
Name Identifier name 
Type Identifier type 
 Name • Data type of variable (e.g. REAL, INT) 

• POU type (e.g. PROGRAM, FUNCTION) 

 DERIVED Derived data type 
 DERIVED ANY_OBJECT TO data type 
 ARRAY … ARRAY data type 
 ENUM … Enumerator data type 
 STRUCT … STRUCT data type 
Declaration Location of declaration 
 Name (unit) Declaration in the program source name 
 Name (LIB) Declaration in the library name 
 Name (TO) System variable of the technology object name 
 Name (TP) Declaration in the default library specified: 

• Technology package name  
• std_fct = IEC library 
• device = device-specific library 

 Name (DV) Declaration on the SIMOTION device name (e.g. I/O variable or global device 
variable) 

 _project Declaration in the project (e.g. technology object) 
 _device Internal variable on the SIMOTION device (e.g. TaskStartInfo) 
 _task Task in the execution system 
Usage Use of identifier  
 CALL Call as subroutine 
 ENUM name As element when declaring the enumerator data type name 
 I/O Declaration as I/O variable 
 R Read access 
 R (TYPE) As data type in a declaration 
 R/W Read and write access 
 STRUCT name As component when declaring the structure name 
 TYPE Declaration as data type or POU 
 Variable type (e.g. VAR, 

VAR_GLOBAL) 
Declaration as variable of the variable type specified 

 W Write access 
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Column Entry in column Meaning 
Path specification Path specification for the SIMOTION device or program source 
 Name SIMOTION device name 
 Name1/Name2 • Program source name2 on SIMOTION device name1 

• Program source name2 in library name1 

 Name/taskbind.hid Execution system of the SIMOTION device name 
Range Range within the SIMOTION device or program source 
 IMPLEMENTATION Implementation section of the program source 
 INTERFACE Interface section of the program source 
 POU type name (e.g. 

FUNCTION name, 
PROGRAM name) 

Program organization unit (POU) name within the program source (also MCC 
chart, LAD/FBD program) 

 I/O address I/O variable 
 TASK name Assignment for the task name 
 _device Global device variable 
Language Programming language of the program source 
Line/Block Line number of the program source (e.g. ST source file) 

With MCC units or MCC charts, the following is also shown: 
• Number: serial numbers for the command (block numbers) or 
• DT: declaration table 

 
 

 Note 
Activated single-step monitoring in MCC programming 
Each task is assigned two variables TSI#dwuser_1 and TSI#dwuser_2, which can be written 
and read.  
When single step monitoring is activated, the compiler uses these variables to control single 
step monitoring if at least one MCC chart is assigned to the relevant task. The user then 
cannot use these variables, because their contents are overwritten by single step monitoring 
and may cause undesirable side effects. 
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4.18.1.3 Working with a cross-reference list 
In the cross-reference list you are able to: 
● Sort the column contents alphabetically: 

– To do this, click the header of the appropriate column. 
● Search for an identifier or entry: 

– Click the "Search" button and enter the search term. 
● Filter (Page 164) the identifiers and entries displayed. 
● Copy contents to the clipboard in order, for example, to paste them into a spread-sheet 

program 
– Select the appropriate lines and columns. 
– Press the CTRL+C shortcut. 

● Print the contents ("Project" > "Print" menu). 
● Open the referenced program source and position the cursor on the relevant line of the 

ST source file (or MCC command or LAD/FBD element): 
– Double-click on the corresponding line in the cross-reference list. 

or 
– Place the cursor in the corresponding line of the cross-reference list and click the "Go 

to application" button. 
Further details about working with cross-reference lists can be found in the online help. 

4.18.1.4 Filtering the cross-reference list 
You can filter the entries in the cross-reference list so that only relevant entries are 
displayed:   
1. Click the "Filter settings" button. 

The "Filter Setting for Cross References" window will appear. 
2. Activate the "Filter active" checkbox. 
3. If you also want to display system variables and system functions: 

– Deactivate the "Display user-defined variables only" checkbox. 
4. Set the desired filter criterion for the relevant columns: 

– Select the relevant entry from the drop-down list box or enter the criterion. 
– If you want to search for a character string within an entry: Deactivate the "Whole 

words only" checkbox. 
5. Confirm with "OK." 
The contents of the cross-reference list will reflect the filter settings selected. 
 

 

 Note 
A filter is automatically activated after the cross-reference list has been created. 

 



 LAD/FBD programming 
 4.18 Reference data 

SIMOTION LAD/FBD 
Programming and Operating Manual, 05/2009 165 

4.18.2 Program structure 
The program structure contains all the function calls and their nesting within a selected 
element. 
When the cross-reference list has been successfully created, you can display the program 
structure selectively for:   
● An individual program source (e.g. ST source file, MCC source file, LAD/FBD source) 
● All program sources of a SIMOTION device 
● All program sources and libraries of the project 
● Libraries (all libraries, single library, individual program source within a library) 
Follow these steps: 
1. In the project navigator, select the element for which you want to display the program 

structure. 
2. Select the menu Edit > Reference data > Display > Program structure. 

The cross-reference tab is replaced by the program structure tab in the detail view. 

4.18.2.1 Content of the program structure 
A tree structure appears, showing: 
● as base respectively 

– the program organization units (programs, functions, function blocks) declared in the 
program source, or 

– the execution system tasks used 
● below these, the subroutines referenced in this program organization unit or task. 
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For structure of the entries, see table: 

Table 4- 24 Elements of the display for the program structure 

Element Description 
Base 
(declared POU or 
task used)) 

List separated by a comma 
• Identifier of the program organization unit (POU) or task 
• Identifier of the program source in which the POU or task was declared, 

with add-on [UNIT] 
• Minimum and maximum stack requirement (memory requirement of the 

POU or task on the local data stack), in bytes [Min, Max] 
• Minimum and maximum overall stack requirement (memory requirement of 

the POU or task on the local data stack including all called POUs), in bytes 
[Min, Max] 

Referenced POU List separated by a comma: 
• Identifier of called POU 
• Optionally: Identifier of the program source / technology package in which 

the POU was declared: 

Add-on (UNIT): User-defined program source 

Add-on (LIB): Library 

Add-on (TP): System function from technology package 
• Only for function blocks: Identifier of instance 
• Only for function blocks: Identifier of program source in which the instance 

was declared: 

Add-on (UNIT): User-defined program source 

Add-on (LIB): Library 
• Line of (compiled) source in which the POU is called; several lines are 

separated by "|". 

4.18.3 Code attributes 
You can find information on or the memory requirement of various data areas of the program 
sources under code attribute. 
When the cross-reference list has been successfully created, you can display the code 
attributes selectively for:   
● An individual program source (e.g. ST source file, MCC source file, LAD/FBD source) 
● All program sources of a SIMOTION device 
● All program sources and libraries of the project 
● Libraries (all libraries, single library, individual program source within a library) 
Follow these steps: 
1. In the project navigator, select the element for which you want to display the code 

attributes. 
2. Select the Edit > Reference data > Display > Code attributes menu. 

The Cross-references tab is now replaced by the Code attributes tab in the detail view. 
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4.18.3.1 Code attribute contents 
The following are displayed in a table for all selected program source files: 
● Identifier of program source file, 
● Memory requirement, in bytes, for the following data areas of the program source file: 

– Dynamic data: All unit variables (retentive and non-retentive, in the interface and 
implementation sections), 

– Retain data: Retentive unit variables in the interface and implementation section, 
– Interface data: Unit variables (retentive and non-retentive) in the interface section, 

● Number of referenced sources. 
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Functions 5
 

This chapter provides a detailed description of the commands with the parameters. The 
commands described are applicable to both the LAD editor and the FBD editor. Examples 
are provided to illustrate individual commands in the LAD and FBD editors. Where there are 
differences such as bit logic, you should refer to the relevant LAD bit logic instructions 
(Page 169) editor. 

 

 Note 
Functions not described in this section can be found in the Function Descriptions of the ST 
programming language. 

 

5.1 LAD bit logic instructions 
Bit logic operations work with the numbers 1 and 0. These numbers form the basis of the 
binary system and are called binary digits or bits. In connection with AND, OR, XOR and 
outputs, a 1 stands for logic YES and a 0 for logic NO.  
The bit logic operations interpret the signal states 1 and 0 and link them according to 
boolean logic. 
The following bit logic operations are available:   
● ---| |--- NO contact 
● ---| / |--- NC contact 
● XOR Linking EXCLUSIVE OR 
● ---( ) Relay coil, output 
● ---( # )--- Connector 
● ---|NOT|--- Invert signal state 
The following operations react to a signal state of 1: 
● ---( S ) Set output 
● ---( R ) Reset output 
● SR Prioritize set flip-flop 
● RS Prioritize reset flipflop 
Some operations react to a rising or falling edge change, so that you can perform one of the 
following operations: 
● --( N )-- Scan edge 1 -> 0 
● --( P )-- Scan edge 0 -> 1 
● NEG edge detection (falling) 
● POS edge detection (rising) 
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5.1.1 ---| |--- NO contact 

Symbol   
<Operand> 
 ---| |--- 
 
Parameters Data type Description 
<Operand> BOOL Scanned bit 

Description 
---| |--- (NO contact) is closed if the value of the scanned bit, saved at the specified 
<Operand>, is equal to 1.  
Otherwise, if the signal state at the specified <address> is "0", the contact is open.  
With series connections, the ---| |--- contact is linked by AND. With parallel connections, the 
contact is linked by OR. 

Example 

 
Current can flow if: 
The state at the inputs %I 0.0 AND %I 0.1 = 1 OR the state at input %I 0.2 = 1. 
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5.1.2 ---| / |--- NC contact 

Symbol   
<Operand> 
 —| / |— 
 
Parameters Data type Description 
<Operand> BOOL Scanned bit 

Description  
---| / |--- (NC contact) is closed if the value of the scanned bit, saved at the specified 
<Operand>, is equal to 0.  
Otherwise, if the signal state at the specified <address> is "1", the contact is open.  
With series connections, the ---| / |--- contact is linked bit for bit by AND. With parallel 
connections, the contact is linked by OR. 

Example 

 
Current can flow if: 
The state at the inputs %I 0.0 AND %I 0.1 = 1 OR the state at input %I 0.2 = 0. 
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5.1.3 XOR Linking EXCLUSIVE OR 

Symbol    
For the function XOR, a network of NC contacts and NO contacts must be created: 

 
 
 
Parameters Data type Description 
<Operand> BOOL Scanned bit 
<Operand> BOOL Scanned bit 

Description 
The value of an XOR (Link EXCLUSIVE OR) link is 1 if the signal states of both specified bits 
are different. 

Example 

 
 
Output %Q 4.0 is 1 if (%I 0.0 = 0 AND %I 0.1 = 1) OR (%I 0.0 = 1 AND %I 0.1 = 0). 
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5.1.4 ---|NOT|--- Invert signal state 

Symbol    
---|NOT|--- 

Description  
---|NOT|--- (Invert signal state) inverts the signal bit. 

Example 

 
Output %Q 4.0 is 0 if: 
The state at input %I 0.0 = 1 OR the state at %I 0.1 AND  
%I 0.2 = 1. 
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5.1.5 ---( ) Relay coil, output 

Symbol    
<Operand> 
---( ) 
 
Parameters Data type Description 
<Operand> BOOL Assigned bit 

Description 
--- (  ) (Relay coil, output) works like a coil in a circuit diagram. If current flows to the coil, the 
bit at the <Operand>is set to 1. If no current flows to the coil, the bit at the <Operand> is set 
to 0. An output coil can only be positioned at the right-hand end of a ladder diagram line in a 
ladder logic. A negated output can be created with the operation ---|NOT|---. 

Example 

 
Output %Q 4.0 is 1 if: 
(The state at input %I 0.0 AND %I 0.1 = 1) OR the state at input %I 0.2 = 0. 
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5.1.6 ---( # )--- Connector (LAD) 

Symbol    
<Operand> 
 ---( # )--- 
 
Parameters Data type Description 
<Operand> BOOL Assigned bit 

Description  
---( # )--- (Connector) is an interposed element with assignment function which saves the 
current signal state of the signal flow at a specified <Operand>. This assignment element 
saves the bit logic of the last opened branch in front of the assignment element. If connected 
in series with other elements, the ---( # )---operation is inserted as a contact. The ---( # )--- 
element can never be connected to the conductor bar, nor positioned directly behind a 
branch, nor used as the end of a branch. A negated element ---( # )--- can be created with 
the element ---|NOT|--- (Invert signal state). 

Example 
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5.1.7 ---( R ) Reset output (LAD) 

Symbol    
<Operand> 
---( R ) 
 
Parameters Data type Description 
<Operand> BOOL Assigned bit 

Description  
---( R ) (Reset output) is executed only if the signal state of the previous operations is 1 
(signal flow at the coil). If current flows to the coil (signal state is 1), the specified <Operand> 
of the element is then set to 0.  
A signal state of 0 (no signal flow at the coil) has no effect, so that the signal state of the 
operand of the specified element is not changed.  

Example 

 
Output %Q 4.0 is only reset if: 
(The state at input %I 0.0 AND at input %I 0.1= 1) OR the state at input %I 0.2 = 0. 
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5.1.8 ---( S ) Set output (LAD) 

Symbol    
<Operand> 
---( S ) 
 
Parameters Data type Description 
<Operand> BOOL Set bit 

Description  
---( S) (Set output) is executed only if the signal state of the previous operations is 1 (signal 
flow at the coil). If the signal state is 1, the specified <Operand> of the element is set to 1.  
A signal state = 0 has no effect, so that the current signal state of the specified element's 
operand is not changed. 

Example 

 
Output %Q 4.0 is only set to 1 if: 
(The state at input %I 0.0 AND %I 0.1 = 1) OR the state at input %I 0.2 = 0. 
If the signal state is 0, the signal state of output %Q 4.0 remains the same. 
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5.1.9 RS Prioritize reset flipflop 

Symbol    

 
 
 
Parameters Data type Description 
<Operand> RS Instance variable of FB type RS 
S BOOL Enable set 
R1 BOOL Enable reset 
Q1 BOOL Signal state of <address> 

Description 
RS (Prioritize reset flipflop) is reset if the state at input R1 is 1, and 0 at input S. Otherwise, if 
input R1 has state 0 and input S has state 1, the flipflop is set.  
The operations S (set) and R1 (reset) are executed only if the pending signal = 1. If the 
pending signal = 0, these operations are not affected and the specified operand is not 
changed. If the pending signal at both inputs is 1, the RS is reset. 

Example 

 
If the state at input %I 0.0 = 1 and at input %I 0.1 = 0, the state flag VAR1 is set and %Q 4.0 
is 1. Otherwise, if the signal state at input %I 0.0 = 0 and the state at input %I 0.1 = 1, the 
state flag VAR1 is reset and %Q 4.0 is 0. If both signal states are 0, nothing is changed. If 
both signals are 1, the reset operation has priority. VAR1 is reset and %Q 4.0 is 0. 
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5.1.10 SR Prioritize set flipflop 

Symbol    

 
 
 
Parameters Data type Description 
<Operand> SR Instance variable from FB type SR 
S1 BOOL Enable set 
R BOOL Enable reset 
Q1 BOOL Signal state of <address> 

Description 
SR (Prioritize set flipflop) is set if input S1 has state 1 and input R has state 0. Otherwise, if 
input S1 has state 0 and input R has state 1, the flipflop is reset. 
The operations S1 (set) and R (reset) are executed only if the pending signal = 1. If the 
pending signal = 0, these operations are not affected and the specified operand is not 
changed. If the pending signal at both inputs is 1, then SR is set. 

Example 

 
If the state at input %I 0.0 is 1 and at input %I 0.1 = 0, the state flag VAR1 is set and %Q 4.0 
is 1. Otherwise, if the state at input %I 0.0 = 0 and the state at input %I 0.1 = 1, the state flag 
VAR1 is reset and %Q 4.0 is 0. If both signal states are 0, nothing is changed. If both signals 
are 1, the set operation has priority. VAR1 is set and %Q 4.0 is 1. 
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5.1.11 --( N )-- Scan edge 1 -> 0 (LAD) 

Symbol    
<Operand> 
---( N )--- 
 
Parameters Data type Description 
<Operand> BOOL N connector bit, saves the previous signal state 

Description 
---( N )--- (Scan edge 1 -> 0) recognizes a signal state change in the operand from 1 to 0 and 
displays this after the operation with signal state = 1. The current signal state is compared to 
the signal state of the operand, the N connector. If the signal state of the operand is 1 and 
the signal state before the operation is 0, then the signal after the operation is 1 (pulse), in all 
other cases 0. The signal before the operation is saved in the operand. 

Example 

 
The N-connector saves the signal state of the result of the entire bit logic. 
If the signal state changes from 1 to 0 the jump to the CAS1 jump label is performed.  
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5.1.12 --( P )-- Scan edge 0 -> 1 (LAD) 

Symbol    
<Operand> 
---( P )--- 
 
Parameters Data type Description 
<Operand> BOOL P connector bit, saves the previous signal state 

Description  
---( P )--- (Scan edge 0 -> 1) recognizes a signal state change in the operand from 0 to 1 and 
displays this after the operation with signal state = 1. The current signal state is compared to 
the signal state of the operand, the P connector. If the signal state of the operand is 0 and 
the signal state before the operation is 1, then the signal after the operation is 1 (pulse), in all 
other cases 0. The signal before the operation is saved in the operand. 

Example 

 
The P-connector saves the signal state of the result of the entire bit logic. If the signal state 
changes from 0 to 1 the jump to the CAS1 jump label is performed.  
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5.1.13 NEG edge detection (falling) 

Symbol    

 
 
 
Parameters Data type Description 
<Operand1> BOOL Scanned signal 
<Operand2> BOOL Connector bit, saves the previous signal state from 

<Operand1> 
Q BOOL Signal change detection 

Description 
NEG (edge detection) compares the signal state of <Operand1> with the signal state of the 
previous scan, which is saved in <Operand2>. If the current state of the signal is 0 and the 
previous state was 1 (detection of a falling edge), output Q is 1 after this function, in all other 
cases 0.  

Example 

 
 
Output %Q 4.0 is 1 if: 
(The state at %I 0.0 AND at %I 0.1 AND at %I 0.2 = 1) AND VAR1 has a falling edge AND 
the state at %I 0.4 = 1. 



 Functions 
 5.1 LAD bit logic instructions 

SIMOTION LAD/FBD 
Programming and Operating Manual, 05/2009 183 

5.1.14 POS edge detection (rising) 

Symbol    

 
 
 
Parameters Data type Description 
<Operand1> BOOL Scanned signal 
<Operand2> BOOL Connector bit, saves the previous signal state from 

<Operand1> 
Q BOOL Signal change detection 

Description 
POS (edge detection) compares the signal state of <Operand1> with the signal state of the 
previous scan, which is saved in <Operand2>. If the current state of the signal is 1 and the 
previous state was 0 (detection of a rising edge), output Q is 1 after this operation, in all 
other cases 0.  

Example 

 
Output %Q 4.0 is 1 if: 
(The state at %I 0.0 AND at %I 0.1 AND at %I 0.2 = 1) AND VAR1 has a rising edge AND 
the state at %I 0.4 = 1. 
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5.1.15 Open branch 
Parallel branches are opened downward.    
Parallel branches are always opened behind the selected LAD element.  

Procedure 
To open a parallel branch downward, follow these steps: 
1. Use the cursor to select the position where the branch is to be opened. 

 
2. Click the  button (shortcut F8) on the LAD editor toolbar. 

The branch is opened behind the selected element. 

 

5.1.16 Close branch 
Parallel branches are closed upward.    
Parallel branches are always closed behind the selected LAD element.  

Procedure 
To close a parallel branch upward, follow these steps: 
1. Use the cursor to select the position where the branch is to be closed. 

 
2. Click the  button (shortcut F9) on the LAD editor toolbar. 

The branch is closed behind the selected element. 
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5.2 FBD bit logic instructions 

FBD bit logic instructions  
Bit logic operations work with the numbers 1 and 0. These numbers form the basis of the 
binary system and are called binary digits or bits. In connection with AND, OR, XOR and 
outputs, a 1 stands for logic YES and a 0 for logic NO. 
The bit logic operations interpret the signal states 1 and 0 and link them according to 
boolean logic. 
The following bit logic operations are available in the FBD editor:   
● & AND box 
● >=1 OR box 
● XOR Exclusive OR box 
● [=] Assignment 
● [#] Connector 
The following operations react to a signal state of 1: 
● [R] Reset assignment 
● [S] Set assignment 
● RS Prioritize reset flipflop 
● SR Prioritize set flip-flop 
Some operations react to a rising or falling edge change, so that you can perform one of the 
following operations: 
● [N] Scan edge 1 -> 0 
● [P] Scan edge 0 -> 1 
● NEG edge detection (falling) 
● POS edge detection (rising) 
The other operations directly affect the signal states: 
● --| Inserting a binary input 
● --o| Negating a binary input 



Functions  
5.2 FBD bit logic instructions 

 SIMOTION LAD/FBD 
186 Programming and Operating Manual, 05/2009 

5.2.1 & AND box 

Symbol   

 
 
 
Parameters Data type Description 
<Operand> BOOL Scanned bit 

Description 
With the AND operation, you can scan the signal states of two or more specified operands at 
the inputs of an AND box. If the signal status of all operands is 1, the condition is fulfilled and 
the result of the operation is 1. If the signal status of one operand is 0, the condition is not 
fulfilled and the operation returns a result of 0. 

Example 

 
Output %Q 4.0 is set when the signal state at input %I 1.0 AND %I 1.1 is 1. 
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5.2.2 >=1 OR box 

Symbol   

 
 
 
Parameters Data type Description 
<Operand> BOOL Scanned bit 

Description 
With the OR operation, you can scan the signal states of two or more specified operands at 
the inputs of an OR box. If the signal status of one of the operands is 1, the condition is 
fulfilled and the result of the operation is 1. If the signal status of all operands is 0, the 
condition is not fulfilled and the operation returns a result of 0. 

Example 

 
Output %Q 4.0 is set when the signal state at input %I 1.0 OR %I 1.1 is 1. 
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5.2.3 XOR EXCLUSIVE OR box 

Symbol    

 
 
 
Parameters Data type Description 
<Operand> BOOL Scanned bit 

Description 
In an EXCLUSIVE OR box, the signal state is 1 if the signal state of one of the two specified 
operands is 1. 

Example 

 
At output %Q 4.0, the signal state is 1 if the signal state is 1 either EXCLUSIVELY at input 
%I 0.0 OR at input %I 0.1. 
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5.2.4 --| Inserting a binary input 

Symbol    
<Operand> 
 ---| 
 
Parameters Data type Description 
<Operand> BOOL Scanned bit 

Description 
The Insert binary input operation inserts a binary input in an AND, OR, or XOR box behind 
the selection mark. 

Example 

 
Output % Q 4.0 is 1 when the state %I 1.0 AND %I 1.1 AND %I 1.2 = 1. 
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5.2.5 --o| Negating a binary input 

Symbol    
<Operand> 
 –o| 
 
Parameters Data type Description 
<Operand> BOOL Scanned bit 

Description 
The Negate binary input operation negates the signal state. 
All binary inputs of any elements can be negated. 

Example 

 
Output %Q 4.0 is 1 if: 
● The signal state at %I 1.0 AND %I 1.1 is NOT 1 
● AND the signal state at %I 1.2 AND %I 1.3 is NOT 1 
● OR the signal state at %I 1.4 = 1. 
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5.2.6 [=] Assignment 

Symbol   

 
 
 
Parameters Data type Description 
<Operand> BOOL Assigned bit 

Description 
The Assignment operation supplies the value. The box at the end of the logic operation 
carries a signal of 1 or 0 according to the following criteria: 
● The output carries a signal of 1 when the conditions of the logic operation are fulfilled 

before the output box. 
● The output carries a signal of 0 when the conditions of the logic operation are not fulfilled 

before the output box. 
The FBD logic operation assigns the signal state to the output that is addressed by the 
operation. If the conditions of the FBD logic operation are fulfilled, the signal state at the 
output box is 1. Otherwise, the signal state is 0. 

Example 

 
Output %Q 4.0 is 1 if: 
● At inputs %I 0.0 AND %I 0.1, the signal state is 1, 
● OR %I 0.2 = 0. 
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5.2.7 [#] Connector (FBD) 

Symbol   

 
 
 
Parameters Data type Description 
<Operand1> BOOL Assigned bit 

Description  
The Connector operation is an intermediate assignment element that stores the signal state. 
Specifically, this assignment element saves the bit logic of the last opened branch in front of 
the assignment element. 

Example 

 
Connectors store the following logic operation results: 
VAR4 saves the negated signal state of 
%I1.0 
%I1.1 
VAR1 saves the negated signal state of 
%I1.2 
%I1.3 
VAR2 saves the negated signal state of %I 1.4. 
VAR3 saves the negated signal state of the entire bit logic operation. 
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5.2.8 [R] Reset assignment (FBD) 

Symbol    

 
 
 
Parameters Data type Description 
<Operand> BOOL Assigned bit 

Description  
The Reset assignment operation then is only performed when the signal state = 1. If the 
signal state = 1, the specified operand is reset to 0 by the operation. If the signal state = 0, 
the operation does not affect the specified operand. The operand remains unchanged. 

Example 

 
The signal state at output %Q 4.0 is only reset to 0 if: 
● The signal state is 1 at inputs %I 0.0 AND %I 0.1 
● OR the signal state at input %I 0.2 = 0 
If the signal state of the branch = 0, the signal state at output %Q 4.0 is not changed. 
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5.2.9 [S] Set assignment (FBD) 

Symbol    

 
 
 
Parameters Data type Description 
<Operand> BOOL Set bit 

Description  
The Set assignment operation is only performed when the signal state = 1. If the signal state 
= 1, the specified operand is reset to 1 by the operation. If the signal state = 0, the operation 
does not affect the specified operand. The operand remains unchanged. 

Example 

 
The signal state at output %Q 4.0 is only reset to 1 if: 
● The signal state is 1 at inputs %I 0.0 AND %I 0.1 
● OR the signal state at input %I 0.2 = 0 
If the signal state of the branch = 0, the signal state of %Q 4.0 is not changed. 
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5.2.10 RS Prioritize reset flipflop 

Symbol    

 
 
 
Parameters Data type Description 
<Operand> RS Instance variable of FB type RS 
S BOOL Enable set 
R1 BOOL Enable reset 
Q1 BOOL Signal state of <address> 

Description 
The Prioritize reset flipflop operation only performs operations such as Set assignment (S) or 
Reset assignment (R) only if the signal state = 1. A signal state of 0 does not affect these 
operations: The operand specified in the operation is not changed. 
Prioritize reset flipflop is reset when the signal state at input R = 1 and the signal state at 
input S = 0. The flipflop is set when input R = 0 and input S = 1. If the signal state at both 
inputs is 1, the flipflop is reset. 

Example 

 
If %I 0.0 = 1 and %I 0.1 = 0, the VAR1 variable is set and output %Q 4.0 is 1. If %I 0.0 = 0 
and %I 0.1 = 1, the VAR1 variable is reset and output %Q 4.0 is 0. 
If both signal states are 0, a change occurs. If both signal states are 1, the reset operation 
has priority due to the sequence. VAR1 is reset and %Q 4.0 is 0. 
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5.2.11 SR Prioritize set flipflop 

Symbol    

 
 
 
Parameters Data type Description 
<Operand> SR Instance variable from FB type SR 
S1 BOOL Enable set 
R BOOL Enable reset 
Q1 BOOL Signal state of <address> 

Description 
The Prioritize set flipflop operation performs operations such as Set (S) or Reset (R) only if 
the signal state = 1. A signal state of 0 has no effect on these operations; the operand 
specified in the operation is not changed. 
Prioritize set flipflop is set when the signal state at input S = 1 and the signal state at input R 
= 0. The flipflop is reset when input S = 0 and input R = 1. If the signal state at both inputs is 
1, the flipflop is set. 

Example 

 
 
If %I 0.0 = 1 and %I 0.1 = 0, the VAR1 variable is set and %Q 4.0 is 1. If %I 0.0 = 0 and %I 
0.1 = 1, the VAR1 is reset and %Q 4.0 is 0. If both signal states are 0, nothing is changed. If 
both signals are 1, the set operation has priority. VAR1 is set and %Q 4.0 is 1. 
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5.2.12 [N] Scan edge 1 -> 0 (FBD) 

Symbol    

 
 
 
Parameters Data type Description 
<Operand> BOOL N connector bit, saves the previous signal state 

Description 
The Scan edge 1 -> 0 recognizes a signal state change in the specified operands from 1 to 0 
(falling edge) and displays this after the operation with signal state = 1. The current signal 
state is compared to the signal state of the operand, the edge variable. If the signal state of 
the operand is 1 and the signal state before the operation is 0, then the signal after the 
operation is 1 (pulse), in all other cases 0. The signal state before the operation is saved in 
the operand. 

Example 

 
The VAR4 variable saves the signal state. 
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5.2.13 [P] Scan edge 0 -> 1 (FBD) 

Symbol    

 
 
 
Parameters Data type Description 
<Operand> BOOL P connector bit, saves the previous signal state 

Description  
The Scan edge 0 -> 1 recognizes a signal state change in the specified operands from 0 to1 
(rising edge) and displays this after the operation with signal state = 1. The current signal 
state is compared to the signal state of the operand, the edge variable. If the signal state of 
the operand is 0 and the signal state before the operation is 1, then the signal state after the 
operation is 1, in all other cases 0. The signal state before the operation is saved in the 
operand. 

Example 

 
The VAR1 variable saves the signal state. 
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5.2.14 NEG edge detection (falling) 

Symbol    

 
 
 
Parameters Data type Description 
<Operand1> BOOL Scanned signal 
M_BIT BOOL The M-BIT operand indicates the variable in which the 

previous signal state of NEG is saved. 
Q BOOL Signal change detection 

Description 
The Edge detection (falling) operation compares the signal state of <Operand1> with the 
signal state of the previous scan, which is saved in M_BIT. If a change has occurred from 1 
to 0, then output Q = 1, in all other cases 0. 

Example 

 
Output %Q 4.0 is 1 if: 
● Input %I 0.3 has a falling edge 
● AND the signal state at input %I 0.4 = 1. 
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5.2.15 POS edge detection (rising) 

Symbol    

 
 
 
Parameters Data type Description 
<Operand1> BOOL Scanned signal 
M_BIT BOOL The M-BIT operand indicates the variable in which the 

previous signal state of POS is saved. 
Q BOOL Signal change detection 

Description 
The Edge detection (rising) operation compares the signal state of <Operand1> with the 
signal state of the previous scan, which is saved in M_BIT. If a change has occurred from 0 
to 1, then output Q = 1, in all other cases 0. 

Example 

 
Output %Q 4.0 is 1 if: 
● Input %I 0.3 has a rising edge 
● AND the signal state at input %I 0.4 = 1. 



 Functions 
 5.3 Relational operators 

SIMOTION LAD/FBD 
Programming and Operating Manual, 05/2009 201 

5.3 Relational operators 

5.3.1 Overview of comparison operations 

Description   
The inputs IN1 and IN2 are compared using the following comparison methods: 
= IN1 is equal to IN2 
<> IN1 is not equal to IN2 
> IN1 is greater than IN2 
< IN1 is less than IN2 
>= IN1 is greater than or equal to IN2 
<= IN1 is less than or equal to IN2 
The following comparison operation is available: 
● CMP comparator 

5.3.2 CMP Compare numbers 

Icons    
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Table 5- 1 Parameters for CMP <, CMP > CMP >=, CMP <= 

Parameter Data type Description 
Box output BOOL Result of the comparison,  

processing is only continued if the signal state at 
the box input = 1. 

IN1 ANY_NUM1 
ANY_BIT 
DATE 
TIME_OF_DAY (TOD) 
DATE_AND_TIME (DT) 
TIME 
STRING2 

First comparison value 

IN2 ANY_NUM1 
ANY_BIT 
DATE 
TIME_OF_DAY (TOD) 
DATE_AND_TIME (DT) 
TIME 
STRING2 

Second comparison value 

The first and second comparison values must be of the same data type, e.g. ANY_NUM and 
ANY_NUM, DATE and DATE, STRING and STRING. 
1 It must be possible to convert both comparison values into the most powerful data type by means of 
implicit conversion. 
2 Variables of the STRING data type can be compared irrespective of the declared length of the 
string. 
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Table 5- 2 Parameter for CMP =, CMP <> 

Parameter Data type Description 
Box output BOOL Result of the comparison,  

processing is only continued if the signal state at 
the box input = 1. 

IN1 ANY_NUM1 
ANY_BIT 
DATE 
TIME_OF_DAY (TOD) 
DATE_AND_TIME (DT) 
TIME 
STRING2 
Enumeration3 
Array3 
Structure3 
STRUCTTASKID 
STRUCTALARMID 
ANYOBJECT 

First comparison value 

IN2 ANY_NUM1 
ANY_BIT 
DATE 
TIME_OF_DAY (TOD) 
DATE_AND_TIME (DT) 
TIME 
STRING2 
Enumeration3 
Array3 
Structure3 
STRUCTTASKID 
STRUCTALARMID 
ANYOBJECT 

Second comparison value 

The first and second comparison values must be of the same data type, e.g. ANY_NUM and 
ANY_NUM, DATE and DATE, STRING and STRING.  
1 It must be possible to convert both comparison values into the most powerful data type by means of 
implicit conversion. 
2 Variables of the STRING data type can be compared irrespective of the declared length of the 
string. 
3 The data type specifications (see the SIMOTION ST Programming and Operating Manual) must be 
identical for both comparison values. 
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Description 
CMP (Compare numbers) can be used like a normal contact. The box can be used at the 
positions where a normal contact can also be positioned. IN1 and IN2 are compared with the 
comparison method selected by you. 
If the comparison is true, then the value of the operation is 1. The value of the whole ladder 
diagram line is linked by AND if the comparison element is connected in series or by OR if 
the box is connected in parallel. 

Example 

 
Representation in the LAD editor 

 
Representation in the FBD editor 
%Q 4.0 is set when: 
● VAR1 >= VAR2 
● AND the signal state at input %I 0.0 is (1). 

AND the signal state at input %I 0.1 is (1). 
AND the signal state at input %I 0.2 is (1). 
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5.4 Conversion instructions 

5.4.1 TRUNC Generate integer 

Symbol   

 
 
Parameters Data type Description 
EN BOOL Enable input 
ENO BOOL Enable output 
IN ANY_REAL Number which is to be converted 
OUT ANY_INT Integral part of the value from IN 

Description 
TRUNC (generate integer) reads the contents of the IN parameter as a floating-point number 
and converts this value to an integer (32-bit). The result is the integral part of the floating-
point number which is output by the OUT parameter.  

Example 

 
Representation in the LAD editor 

 
Representation in the FBD editor 
If %I 0.0 = 1, the contents of VAR1 are read as a floating-point number and converted to an 
integer (32-bit). The result is the integral part of the floating-point number which is saved in 
VAR2.  
Output %Q 4.0 is 1 if an overflow occurs or the statement is not processed (%I 0.0 = 0). 
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5.4.2 Generating numeric data types and bit data types 

Symbol     
e.g. BOOL_TO_TYPE 

 
 

Description 
You can carry out the explicit data type conversion with the standard functions listed in the 
tables below. 
● Input parameters 

Each function for the conversion of a data type has exactly one input parameter. 
● Function value 

The function value is always the return value of the function. The table shows the rules 
with which a data type can be converted. 

● Naming 
Because the data types of the input parameter and the function value come from the 
respective function name, they are not listed specially in the table "Functions for 
conversion of numerical data types and bit data types": E.g. with function 
BOOL_TO_BYTE, the data type of the input parameter is BOOL, the data type of the 
function value BYTE. 

Table 5- 3 Functions for conversion of numerical data types and bit data types 

Function name Conversion rule Implicit 
okay 

BOOL_TO_BYTE  Accept as least significant bit and fill the rest with 0. yes 
BYTE_TO_BOOL  Accept the least significant bit. no 
BYTE_TO_SINT Accept bit string as SINT value. no 
BYTE_TO_USINT Accept bit string as USINT value. no 
BYTE_TO_WORD Accept least significant bit and fill the rest with 0.  yes 
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Table 5- 4 Functions for conversion of numerical data types and bit data types 

Function name Conversion rule Implicit 
okay 

DINT_TO_DWORD Accept value as bit string. no 
DINT_TO_INT Cut off two most significant bytes. no 
DINT_TO_LREAL Accept value. yes 
DINT_TO_REAL Accept value (accuracy may be lost). no 
DINT_TO_UDINT Accept value as bit string.  no 
DINT_TO_UINT Cut off two most significant bytes. no 
DINT_TO_WORD Cut off two most significant bytes. no 

 

Table 5- 5 Functions for conversion of numerical data types and bit data types 

Function name Conversion rule Implicit 
okay 

DWORD_TO_DINT  Accept bit string as DINT value. no 
DWORD_TO_INT Accept the two least significant bytes as INT value. no 
DWORD_TO_REAL Accept bit string as REAL value (validity check of the 

REAL number is not carried out!). 
no 

DWORD_TO_UDINT Accept bit string as UDINT value.  no 
DWORD_TO_UINT Accept the two least significant bytes as UINT value. no 
DWORD_TO_WORD Accept the two least significant bytes of the bit string. no 

 

Table 5- 6 Functions for conversion of numerical data types and bit data types 

Function name Conversion rule Implicit 
okay 

INT_TO_DINT Accept value. yes 
INT_TO_LREAL Accept value. no 
INT_TO_REAL Accept value. yes 
INT_TO_SINT Cut off the most significant byte.  no 
INT_TO_UDINT Accept value as bit string; the two most significant bytes 

are filled with the most significant bit of the input 
parameter. 

no 

INT_TO_UINT  Accept value as bit string.  no 
INT_TO_WORD Accept value as bit string.  no 
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Table 5- 7 Functions for conversion of numerical data types and bit data types 

Function name Conversion rule Implicit 
okay 

LREAL_TO_DINT Round off to integer part.  no 
LREAL_TO_INT Round off to integer part.  no 
LREAL_TO_REAL Accept value (accuracy may be lost). no 
LREAL_TO_UDINT  Round off to integer part.  no 
LREAL_TO_UINT Round off to integer part. no 

 

Table 5- 8 Functions for conversion of numerical data types and bit data types 

Function name Conversion rule Implicit 
okay 

REAL_TO_DINT Round off to integer part. no 
REAL_TO_DWORD Accept bit string. no 
REAL_TO_INT Round off to integer part. no 
REAL_TO_LREAL Accept value. yes 
REAL_TO_UDINT  Round off to integer part. no 
REAL_TO_UINT Round off to integer part. no 

 

Table 5- 9 Functions for conversion of numerical data types and bit data types 

Function name Conversion rule Implicit 
okay 

SINT_TO_BYTE Accept bit string. no 
SINT_TO_INT Accept value. yes 
SINT_TO_USINT Accept bit string. no 

 

Table 5- 10 Functions for conversion of numerical data types and bit data types 

Function name Conversion rule Implicit 
okay 

UDINT_TO_DINT Accept bit string. no 
UDINT_TO_INT Cut off numerical sequence (2 most significant bytes).  no 
UDINT_TO_DWORD Accept bit string. no 
UDINT_TO_LREAL Accept value.  yes 
UDINT_TO_REAL Accept value (accuracy may be lost).  no 
UDINT_TO_UINT Cut off numerical sequence (2 most significant bytes). no 
UDINT_TO_WORD  Cut off numerical sequence (2 most significant bytes).  no 
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Table 5- 11 Functions for conversion of numerical data types and bit data types 

Function name Conversion rule Implicit 
okay 

UINT_TO_DINT Accept value. yes 
UINT_TO_DWORD Accept bit string, fill rest with zeros. no 
UINT_TO_INT Accept bit string. no 
UINT_TO_LREAL Accept value (accuracy may be lost).  no 
UINT_TO_REAL  Accept value. yes 
UINT_TO_UDINT Accept value. yes 
UINT_TO_USINT Cut off numerical sequence (most significant byte).  no 
UINT_TO_WORD Accept bit string. no 

 

Table 5- 12 Functions for conversion of numerical data types and bit data types 

Function name Conversion rule Implicit 
okay 

USINT_TO_BYTE Accept bit string. no 
USINT_TO_INT Accept value.  yes 
USINT_TO_DINT  Accept value. no 
USINT_TO_SINT Accept bit string. no 
USINT_TO_UINT Accept value. yes 

 

Table 5- 13 Functions for conversion of numerical data types and bit data types 

Function name Conversion rule Implicit 
okay 

WORD_TO_BYTE Cut off most significant byte.  no 
WORD_TO_DINT Accept bit string, fill rest with zeros. no 
WORD_TO_DWORD  Accept the two least significant bytes and fill the rest with 

0. 
yes 

WORD_TO_INT Accept bit string and interpret this as an integer. no 
WORD_TO_UDINT Accept bit string, fill rest with zeros.  no 
WORD_TO_UINT Accept bit string. no 
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5.4.3 Generating date and time 

Symbol    

 
 

Description 
The table below shows the standard functions for date and time data types: 

Table 5- 14 Standard functions for date and time 

Function  
name 

Data type of 
input parameter 

Data type of function 
value 
 

Description 

CONCAT   1: DATE  
2: TIME_OF_DAY 

DATE_AND_TIME Compress DATE and 
TIME_OF_DAY to 
DATE_AND_TIME. 

DT_TO_TOD   DATE_AND_TIME TIME_OF_DAY Accept time of day. 
DT_TO_DATE   DATE_AND_TIME DATE Accept date. 

 
 

 Note 
Data type TIME can be converted to numerical data types as follows: 

 

● To data type UDINT:  
Divide it by a standardization factor of data type TIME. 
Multiply the reconversion by the same standardization factor. 
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5.5 Edge detection 
System function block R_TRIG can be used to detect a rising edge; F_TRIG can detect a 
falling edge. You can use this function, for example, to set up a sequence of your own 
function blocks.   

5.5.1 Detection of rising edge R_TRIG 

Symbol   

 
 

Description 
If a rising edge (R_TRIG, Rising Trigger), i.e. a status change from 0 to 1, is present at the 
input, 1 is applied at the output for the duration of one cycle. 

 
TA Cycle time 

Figure 5-1 Mode of operation of R_TRIG (rising edge) function block 

Table 5- 15 Call parameters for R_TRIG 

Identifier Parameters Data type Description 
CLK Input BOOL Input for edge detection 
Q Output BOOL Status of edge 
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5.5.2 Detection of falling edge F_TRIG 

Symbol   

 
 

Description 
When a falling edge (F_TRIG, falling trigger), i.e. a status change from 1 to 0, occurs at the 
input, the output is set to 1 for the duration of one cycle time. 

 
TA Cycle time 

Figure 5-2 Mode of operation of F_TRIG (falling edge) function block 

Table 5- 16 Call parameters for F_TRIG 

Identifier Parameters Data type Description 
CLK Input BOOL Input for edge detection 
Q Output BOOL Status of edge 
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5.6 Counter operations 

5.6.1 Overview of counter operations 
Every call-up of the function block and the function should be recorded in a counter.   

5.6.2 CTU up counter 

Symbol    

 
 

Description 
The CTU counter allows you to perform upward counting operations: 
● If the input is R = TRUE when the FB is called up, then the CV output is reset to 0. 
● If the CU input changes from FALSE to TRUE (0 to 1) when the FB is called (positive 

edge), then the CV output is incremented by 1. 
● Output Q specifies whether CV is greater than or equal to comparison value PV. 
The CV and PV parameters are both INT data types, which means that the maximum 
counter reading possible is 32767 ( = 16#7FFF). 

Table 5- 17 Parameters for CTU 

Identifier Parameters Data type Description 
CU Input BOOL Count up if value changes from FALSE to 

TRUE  
(positive edge) 

R Input BOOL Reset the counter to 0 
PV Input INT Comparison value 
Q Output BOOL Status of counter (CV >= PV) 
CV Output INT Counter value 
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5.6.3 CTU_DINT up counter 

Symbol    

 
 

Description 
The method of operation is the same as for the CTU incrementer except for the following: 
The CV and PV parameters are both DINT data types, which means that the maximum 
counter reading possible is 2147483647 ( = 16#7FFF_FFFF). 

Table 5- 18 Parameters for CTU_DINT 

Identifier Parameters Data type Description 
CU Input BOOL Count up if value changes from FALSE to 

TRUE  
(positive edge) 

R Input BOOL Reset the counter to 0 
PV Input DINT Comparison value 
Q Output BOOL Status of counter (CV >= PV) 
CV Output DINT Counter value 
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5.6.4 CTU_UDINT up counter 

Symbol    

 
 

Description 
The method of operation is the same as for the CTU incrementer except for the following: 
The CV and PV parameters are both UDINT data types, which means that the maximum 
counter reading possible is 4294967295 ( =16# FFFF_FFFF). 

Table 5- 19 Parameters for CTU_UDINT 

Identifier Parameters Data type Description 
CU Input BOOL Count up if value changes from FALSE to 

TRUE (positive edge) 
R Input BOOL Reset the counter to 0 
PV Input UDINT Comparison value 
Q Output BOOL Status of counter (CV >= PV) 
CV Output UDINT Counter value 
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5.6.5 CTD down counter 

Symbol    

 
 

Description 
The CTD counter allows you to perform downward counting operations. 
● If the LD input = TRUE when the FB is called, then the CV output is reset to start value 

PV. 
● If the CD input changes from FALSE to TRUE (0 to 1) when the FB is called (positive 

edge), then the CV output is decremented by 1. 
● Output Q specifies whether CV is less than or equal to 0. 

 
The CV and PV parameters are both INT data types, which means that the minimum counter 
reading possible is -32,768 ( = 16#8000). 

Table 5- 20 Parameters for CTD 

Identifier Parameters Data type Description 
CD Input BOOL Count down if value changes from FALSE to 

TRUE  
(positive edge) 

LD Input BOOL Reset the counter to start value 
PV Input INT Start value of counter 
Q Output BOOL Status of counter (CV <= 0) 
CV Output INT Counter value 
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5.6.6 CTD_DINT down counter 

Symbol    

 
 

Description 
The method of operation is the same as for the CTD up counter except for the following: 
The CV and PV parameters are both DINT data types, which means that the minimum 
counter reading possible is -2147483648 ( = 16#8000_0000). 

Table 5- 21 Parameters for CTD_DINT 

Identifier Parameters Data type Description 
CD Input BOOL Count down if value changes from FALSE to 

TRUE  
(positive edge) 

LD Input BOOL Reset the counter to start value 
PV Input DINT Start value of counter 
Q Output BOOL Status of counter (CV <= 0) 
CV Output DINT Counter value 
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5.6.7 CTD_UDINT down counter 

Symbol    

 

Description 
The method of operation is the same as for the CTD up counter except for the following: 
The CV and PV parameters are both UDINT data types, which means that the minimum 
counter value possible is 0. 

Table 5- 22 Parameters for CTD_DINT 

Identifier Parameters Data type Description 
CD Input BOOL Count down if value changes from FALSE to 

TRUE  
(positive edge) 

LD Input BOOL Reset the counter to start value 
PV Input UDINT Start value of counter 
Q Output BOOL Status of counter (CV <= 0) 
CV Output UDINT Counter value 
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5.6.8 CTUD up/down counter 

Symbol    

 

Description 
The CTUD counter allows you to perform both upward and downward counting operations.  
● Reset the CV count variable: 

– If the input is R = TRUE when the FB is called up, then the CV output is reset to 0. 
– If the LD input = TRUE when the FB is called, then the CV output is reset to start value 

PV. 
● Count: 

– If the CU input changes from FALSE to TRUE (0 to 1) when the FB is called (positive 
edge), then the CV output is incremented by 1. 

– If the CD input changes from FALSE to TRUE (0 to 1) when the FB is called up 
(positive edge), then the CV output is decremented by 1. 

● Counter status QU or QD: 
– Output Q specifies whether CV is greater than or equal to comparison value PV. 
– Output QD specifies whether CV is less than or equal to 0. 
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Table 5- 23 Parameters for CTUD 

Identifier Parameters Data type Description 
CU Input BOOL Count up if value changes from FALSE to 

TRUE  
(positive edge) 

CD Input BOOL Count down if value changes from FALSE to 
TRUE  
(positive edge) 

R Input BOOL Reset the counter to 0 (up counter) 
LD Input BOOL Reset the counter to PV start value (down 

counter) 
PV Input INT Comparison value (for up counter) 

Start value (for down counter) 
QU Output BOOL Status as up counter (CV >= PV) 
QD Output BOOL Status as down counter (CV <= 0) 
CV Output INT Counter value 
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5.6.9 CTUD_DINT up/down counter 

Symbol    

 

Description 
The method of operation is the same as for the CTUD up counter except for the following: 
The CV and PV parameters are both DINT data types. 

Table 5- 24 Parameters for CTD_DINT 

Identifier Parameters Data type Description 
CU Input BOOL Count up if value changes from FALSE to 

TRUE  
(positive edge) 

CD Input BOOL Count down if value changes from FALSE to 
TRUE  
(positive edge) 

R Input BOOL Reset the counter to 0 (up counter) 
LD Input BOOL Reset the counter to PV start value (down 

counter) 
PV Input DINT Comparison value (for incrementer) Start 

value (for decrementer) 
QU Output BOOL Status as up counter (CV >= PV) 
QD Output BOOL Status as down counter (CV <= 0) 
CV Output DINT Counter value 
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5.6.10 CTUD_UDINT up/down counter 

Symbol    

 

Description 
The method of operation is the same as for the CTUD up counter except for the following: 
The CV and PV parameters are both UDINT data types. 

Table 5- 25 Parameters for CTD_DINT 

Identifier Parameters Data type Description 
CU Input BOOL Count up if value changes from FALSE to 

TRUE  
(positive edge) 

CD Input BOOL Count down if value changes from FALSE to 
TRUE  
(positive edge) 

R Input BOOL Reset the counter to 0 (up counter) 
LD Input BOOL Reset the counter to PV start value (down 

counter) 
PV Input UDINT Comparison value (for incrementer) Start 

value (for decrementer) 
QU Output BOOL Status as up counter (CV >= PV) 
QD Output BOOL Status as down counter (CV <= 0) 
CV Output UDINT Counter value 
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5.7 Jump instructions 

5.7.1 Overview of jump operations 

Description 
Jump operations can be used in all logic blocks, e.g. programs, function blocks (FBs), and 
functions (FCs).   

Jump label as operand 
The operand of a jump operation is a jump label. The jump label specifies the point to where 
the program is to jump.  
Enter the jump label via the JMP coil. The jump label consists of up to 480 characters. The 
first character must be a letter, the other characters can be either letters or numbers (e.g. 
SEG3). 

Jump label as target 
The target jump label can be at the start of a network.  

See also 
Showing/hiding a jump label (Page 67) 
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5.7.2 ---( JMP ) Jump in block if 1 (conditional) 

Symbol  
<jump label> 
---( JMP ) 

Description  
---( JMP ) (Jump in block if 1) functions as a conditional jump if the pending signal of the 
previous logic operation is 1.  
There must also be a target (LABEL) for every ---( JMP ). 
The operations between the jump operation and the jump label are not executed!  

 

 Note 
An unconditional jump is created by hanging the --( JMP ) element directly on the power rail.
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5.7.3 ---( JMPN ) Jump in block if 0 (conditional) 

Symbol  
<jump label> 
---( JMPN ) 

Description  
---( JMPN ) (Jump in block if 0) functions as a conditional jump if the pending signal of the 
previous logic operation is 0.  
There must also be a target (LABEL) for every ---( JMPN ). 
The operations between the jump operation and the jump label are not executed! 
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5.7.4 LABEL Jump label 

Symbol    

 

Description 
LABEL marks the target of a jump operation. It can have a maximum of 80 characters. The 
first character must be a letter, the other characters can be letters or numbers, e.g. CAS1. 
There must be a target (LABEL) for every ---( JMP ) or ---( JMPN ). 

 

 Note 
Only alphanumeric characters are allowed during input. The jump label is deleted if it 
contains an error and cannot be corrected. 

 



 Functions 
 5.8 Non-binary logic 

SIMOTION LAD/FBD 
Programming and Operating Manual, 05/2009 227 

5.8 Non-binary logic 

Symbol   
e.g. AND 

 
e.g. NOT 

 

Description 
Logic operations (AND, OR, XOR, NOT) are also provided as boxes with EN/ENO for non-
binary values in the LAD/FBD editor. 
The logical operations are listed in the table below. 
There is only one operand for NOT. 

 

 Note 
In the Command library tab of the project navigator, the elements AND, XOR, and  OR, NOT
are represented in the Logic entry. 

 

 

Table 5- 26 Non-binary logic 

Operator 
Parameters 

AND XOR OR NOT 

IN1 ANY_BIT ANY_BIT ANY_BIT ANY_BIT 
IN2 ANY_BIT ANY_BIT ANY_BIT  
EN BOOL BOOL BOOL BOOL 
ENO BOOL BOOL BOOL BOOL 
OUT ANY_BIT ANY_BIT ANY_BIT ANY_BIT 
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5.9 Arithmetic operators 

Symbol   
e.g. addition 

 

Description 
An arithmetic expression is composed of arithmetic operators. These expressions allow 
numerical data types to be processed. 
The divide operators DIV and MOD require that the second operand is not equal to zero. 

 

 Note 
In the Command library tab of the project navigator, the elements ADD, SUB, MUL, and  DIV
are represented as +, -, *, and  /. 
The execution of a network, for example, is simply aborted in the event of an overflow, and 
the relevant/assigned event-triggered task (ExecutionFaultTask) is started. 

 

The table below contains a list of the arithmetic operators: 

Table 5- 27 Arithmetic operators 

Instruction Operator 1. Operand (IN1) 2. Operand (IN2) Result (OUT) 
ANY_NUM ANY_NUM ANY_NUM1 
BYTE BYTE BYTE 
WORD WORD WORD 
DWORD DWORD DWORD 
TIME TIME TIME2 
TOD TIME TOD2 

Addition ADD 

DT TIME DT3 
ANY_NUM ANY_NUM ANY_NUM1 
BYTE BYTE BYTE 
WORD WORD WORD 
DWORD DWORD DWORD 

Multiplication MUL 

TIME ANY_INT TIME 
ANY_NUM ANY_NUM ANY_NUM1 
BYTE BYTE BYTE 
WORD WORD WORD 
DWORD DWORD DWORD 

Subtraction SUB 

TIME  TIME TIME 
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Instruction Operator 1. Operand (IN1) 2. Operand (IN2) Result (OUT) 
TOD TIME4 TOD 
TOD TOD TIME5 
DT TIME DT 
DT DT TIME5 
ANY_NUM ANY_NUM6 ANY_NUM1 
BYTE BYTE6 BYTE 
WORD WORD6 WORD 
DWORD DWORD6 DWORD 
TIME ANY_INT6 TIME 

Division DIV 

TIME TIME6 UDINT 
ANY_INT ANY_INT6 ANY_INT1 
BYTE BYTE6 BYTE 
WORD WORD6 WORD 

Modulo division. MOD 

DWORD DWORD6 DWORD 
1 The data types of the operands and of the result must be identical. 
2 Addition, possibly with overflow. 
3 Addition with date correction. 
4 Restriction of TIME to TOD before calculation. 
5 These operations are based on the modulo of the maximum value of the TIME data type. 
6 The second operand must not be equal to zero. 
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5.10 Numeric standard functions 
Every numeric standard function has an input parameter. The result is always the function 
value. 

5.10.1 General numeric standard functions 

Symbol    
e.g. absolute value 

 

Description 
General numeric standard functions are used for: 
● Calculation of the absolute value of a variable 
● Calculation of the square root of a variable 
The table below shows the general numeric standard functions: 

Table 5- 28 General numeric standard functions 

Function name Input parameter 
data type (IN) 

Function value 
data type (OUT) 

Description 

ABS ANY_NUM ANY_NUM1 Absolute value 
SQRT ANY_REAL ANY_REAL1 Square root 
1 Identical to the data type of the input parameter IN 
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5.10.2 Logarithmic standard functions 

Symbol    
e.g. exponential value 

 

 Description 
Logarithmic standard functions are functions for calculating an exponential value or a 
logarithm of a value.  
The table below shows the logarithmic standard functions: 

Table 5- 29 Logarithmic standard functions 

Function name Input parameter 
data type (IN) 

Data type of 
function value 
(OUT) 
 

Description 

EXP ANY_REAL ANY_REAL1 ex (natural exponential function) 
EXPD ANY_REAL ANY_REAL1 10x (decimal exponential function) 
EXPT ANY_REAL (IN1) 

ANY_NUM (IN2) 
ANY_REAL2 Exponentiation  

LN ANY_REAL ANY_REAL1 Natural logarithm 
LOG ANY_REAL ANY_REAL1 Common logarithm 
1 Identical to the data type of the input parameter IN 
2 Identical to the data type of the input parameter IN1 
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5.10.3 Trigonometric standard functions 

Symbol    
e.g. COS 

 

Description 
The trigonometric standard functions listed in the table expect and calculate variables of 
angles in radian measure. 

Table 5- 30 Trigonometric standard functions 

Function name Input parameter 
data type 

Data type of 
function value 
 

Description 

ACOS ANY_REAL ANY_REAL  Arc cosine (main value) 
ASIN ANY_REAL ANY_REAL  Arc sine (main value) 
ATAN ANY_REAL ANY_REAL  Arc tangent (main value) 
COS ANY_REAL ANY_REAL  Cosine (radian measure input) 
SIN ANY_REAL ANY_REAL  Sine (radian measure input) 
TAN ANY_REAL ANY_REAL  Tangent (radian measure input) 
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5.11 Move 

5.11.1 MOVE Transfer value 

Symbol   

 
 
Parameters Data type Description 
EN BOOL Enable input 
ENO BOOL Enable output 
IN ANY Source value 
OUT ANY Destination address 

Description 
MOVE (Assign a value) is activated by the enable input EN. The value specified by the IN 
input is copied to the value specified in the OUT output. ENO has the same signal state as 
EN.  
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5.12 Shifting operations 

5.12.1 Overview of shifting operations 

Description   
The contents of input IN can be moved bit-by-bit to the left or right using shifting operations. 
A shift of n bits to the left multiplies the contents of input IN by 2 to the power of n; a shift of n 
bits to the right divides the contents of input IN by 2 to the power of n. If, for example, you 
move the binary equivalent of the decimal value 3 by 3 bits to the left, this gives the binary 
equivalent of the decimal value 24. Shift the binary equivalent of the decimal value 16 by 2 
bits to the right, this gives the binary equivalent of the decimal value 4. 
The number that you specify at input N indicates the number of bits by which to shift. The 
places which become free as a result of the shifting operation are filled up with zeroes. 
The following shifting operations are available: 
● shift bit to the left 
● shift bit to the right 

5.12.2 SHL Shift bit to the left 

Symbol    

 
 
Parameters Data type Description 
EN BOOL Enable input 
ENO BOOL Enable output 
IN ANY_BIT Value to be shifted 
N USINT Number of bit positions to be shifted 
OUT ANY_BIT Result of shifting operation 

Description  
SHL (e.g. shift left by 32 bits) is activated if the enable input (EN) has the signal state 1. The 
operation SHL shifts the bits 0 to 31 of the input IN bit-by-bit to the left. Input N specifies the 
number of bit positions to be shifted. If N is greater than 32, the command writes a 0 in the 
OUT output. The same number (N) of zeros is shifted from the right in order to occupy the 
positions which have become free. The result of the shifting operation can be queried at 
output OUT.  
ENO has the same signal state as EN. 
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5.12.3 SHR Shift bit to the right 

Symbol    

 
 
Parameters Data type Description 
EN BOOL Enable input 
ENO BOOL Enable output 
IN ANY_BIT Value to be shifted 
N USINT Number of bit positions to be shifted 
OUT ANY_BIT Result of shifting operation 

Description  
SHR (e.g. shift right by 32 bits) is activated if the enable input (EN) has the signal state 1. 
The operation SHR shifts the bits 0 to 31 of the input IN bit-by-bit to the right. Input N 
specifies the number of bit positions to be shifted. If N is greater than 32, the command 
writes a 0 in the OUT output. The same number (N) of zeros is shifted from the left in order 
to occupy the positions which have become free. The result of the shifting operation can be 
queried at output OUT.  
ENO has the same signal state as EN. 
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5.13 Rotating operations 

5.13.1 Overview of rotating operations 

Description   
The entire contents of input IN can be rotated bit-by-bit to the left or right using rotating 
operations. The positions which become free are filled up with the signal states of the bits 
which have been moved out of the IN input. 
At the input N you can specify the number of bits for the rotation. 

5.13.2 ROL Rotate bit to the left 

Symbol    

 
 
Parameters Data type Description 
EN BOOL Enable input 
ENO BOOL Enable output 
IN ANY_BIT Value to be rotated 
N USINT Number of bit positions to be rotated 
OUT ANY_BIT Result of rotation operation 

Description 
ROL (e.g. rotate left by 32 bits) is activated if the enable input (EN) has the signal state 1. 
The operation ROL rotates the entire contents of the IN input bit-by-bit to the left. Input N 
specifies the number of bit positions by which to rotate. If N is greater than 32, the double 
word IN is rotated by ((N-1) modulo 32)+1 positions. The bit positions coming from the right 
are occupied with the signal state of the bits which have been rotated to the left (left 
rotation). The result of the rotation operation can be queried at output OUT. 
ENO has the same signal state as EN. 
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Example 

 
Figure 5-3 Representation in the FBD editor 

 
Figure 5-4 Representation in the LAD editor 

The ROL box is executed if %I 0.0 = 1. VAR1 is loaded and rotated to the left by the number 
of bits specified in VAR2. The result is written to VAR3. %Q 4.0 is set. 
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5.13.3 ROR Rotate bit to the right 

Symbol    

 
 
Parameter Data type Description 
EN BOOL Enable input 
ENO BOOL Enable output 
IN ANY_BIT Value to rotate 
N USINT Number of bit positions to rotate 
OUT ANY_BIT Result of rotation operation 

Description 
ROR (e.g. rotate right by 32 bits) is activated if the enable input (EN) has the signal state 1. 
The operation ROR rotates the entire contents of the IN input bit-by-bit to the right. Input N 
specifies the number of bit positions by which to rotate. If N is greater than 32, the double 
word IN is rotated by ((N-1) modulo 32)+1 positions. The bit positions coming from the left 
are occupied by the signal state of the bits which have been rotated to the right (right 
rotation). The result of the rotation operation can be queried at output OUT. 
ENO has the same signal state as EN. 

Example 

 
Figure 5-5 Representation in the LAD editor  

 
Figure 5-6 Representation in the FBD editor 

The ROR box is executed if %I 0.0 = 1. VAR1 is loaded and rotated to the right by the 
number of bits specified in VAR2. The result is written to VAR3. %Q 4.0 is set. 
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5.14 Program control instructions 

5.14.1 Calling up an empty box 

Symbol    

 
 
Parameters Data type Description 
EN BOOL Enable input 
ENO BOOL Enable output 
<Type> FB / FC FC/FB type 
<Instance variable> FB FB instance variable 

Description 
The symbol for an empty box depends on the function block/function (according to how 
many parameters there are). EN, ENO and the name of the FB/FC must be available. 
You do not have to specify EN/ENO in the variable declaration. The input and output are 
automatically allocated by the system. 
The EN input can be used to inhibit a block call and redirect the block of the EN input to the 
ENO output. 
It is not possible to control the ENO output in the block itself. 

 

 Note 
You can use an empty box to insert a call (Page 74). As soon as you enter the type, the box 
transforms and displays the parameters of the specified FB/FC call. 

 

See also 
Inserting LAD/FBD elements (Page 74) 
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5.14.2 RET Jump back 

Symbol   
---( RET ) 

Description 
RET (jump back) is used for the conditional exit from blocks. A preceding logic operation is 
necessary for this output. 

Example 

 
Figure 5-7 Representation in the LAD editor 

 
Figure 5-8 Representation in the FBD editor 

The operation is executed if %I 0.0 = 1. 
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5.15 Timer instructions 

5.15.1 TP pulse 

Symbol    

 

Description 
With a signal state change from 0 to 1 at the IN input, time ET is started. Output Q remains 
at 1 until elapsed time ET is equal to programmed time value PT. As long as time ET is 
running, the IN input has no effect. 

 
Figure 5-9 Mode of operation of TP pulse timer 

Table 5- 31 Call parameters for TP 

Identifier Parameters Data type Description 
IN Input Input Start input 
PT Input TIME Duration of pulse 
Q Output BOOL Status of time 
ET Output TIME Elapsed time 
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5.15.2 TON ON delay 

Symbol    

 

Description 
With the signal state change from 0 to 1 at the IN input, time ET is started. The output signal 
Q only changes from 0 to 1 if the time ET = PT has elapsed and the input signal IN still has 
the value 1, i.e. the output Q is switched on with a delay. Input signals of shorter durations 
than programmed time PT do not appear at the output. 

 
Figure 5-10 Mode of operation of TON on delay timer 

Table 5- 32 Call parameters for TON 

Identifier Parameters Data type Description 
IN Input BOOL Start input 
PT Input TIME Duration for which the rising edge at input IN 

is delayed. 
Q Output BOOL Status of time 
ET Output TIME Elapsed time 
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5.15.3 TOF OFF delay 

Symbol    

 

Description 
With a signal state change from 0 to 1 at start input IN, state 1 appears at output Q. If the 
state at the start input IN changes from 1 to 0, then time ET is started. If a change occurs at 
input IN from 0 to 1 before time ET has elapsed, then the timer operation is reset. A start is 
initiated again when the state at input IN changes from 1 to 0. Only after the duration ET = 
PT has elapsed does output Q adopt a signal state of 0. This means that the output is 
switched off with a delay. 

 
Figure 5-11 Mode of operation of TOF off delay timer 

Table 5- 33 Call parameters for TOF 

Identifier Parameters Data type Description 
IN Input BOOL Start input 
PT Input TIME Duration for which the falling edge at input IN 

is delayed. 
Q Output BOOL Status of time 
ET Output TIME Elapsed time 
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5.16 Selection functions 

5.16.1 SEL Binary selection 

Symbol   

 
 
Parameters Input parameter  

data type 
Description 

EN BOOL Enable input 
ENO BOOL Enable output 
G BOOL Input parameter 
IN0 ANY Input parameter 
IN1 ANY Input parameter 

Description 
The function value is one of the input parameters IN0 or IN1, depending on the value of the 
input parameter G. 
The input parameters IN0 and IN1 must be the same data type or must be capable of implicit 
conversion into the same data type. 
The return value is data type ANY. 
Selected input parameter 
IN0 if G = 0 (FALSE) 
IN1 if G = 1 (TRUE) 
The data type corresponds to the common data type of the input parameters IN0 and IN1. 
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5.16.2 MAX Maximum function 

Symbol    

 
 
Parameter Input parameter  

data type 
Description 

EN BOOL Enable input 
ENO BOOL Enable output 
IN0 ANY_ELEMENTARY Input parameter 
IN1 ANY_ELEMENTARY Input parameter 

Description 
The function value is the maximum value of both input parameters IN0 and IN1. 
The input parameters IN0 and IN1 must be the same data type or must be capable of implicit 
conversion into the most powerful data type. 
The return value is of data type ANY_ELEMENTARY. 
Maximum of the input parameters. 
The data type corresponds to the most powerful data type of the input parameters IN0 and 
IN1. 
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5.16.3 MIN Minimum function 

Symbol   

 
 
Parameter Input parameter  

data type 
Description 

EN BOOL Enable input 
ENO BOOL Enable output 
IN0 ANY_ELEMENTARY Input parameter 
IN1 ANY_ELEMENTARY Input parameter 

Description 
The function value is the minimum value of both input parameters IN0 and IN1. 
All IN0 and IN1 input parameters must be the same data type or capable of implicit 
conversion into the most powerful data type. 
The return value is of data type ANY_ELEMENTARY. 
Minimum of the input parameters. 
The data type corresponds to the most powerful data type of the input parameters IN0 and 
IN1. 
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5.16.4 LIMIT Limiting function 

Symbol    

 
 
Parameters Input parameter  

data type 
Description 

EN BOOL Enable input 
ENO BOOL Enable output 
MN ANY_ELEMENTARY Input parameter  

Lower limiting value 
IN ANY_ELEMENTARY Input parameter 

Value to be limited 
MX ANY_ELEMENTARY Input parameter 

Upper limiting value 

Description 
The input parameter IN is limited to values lying between the lower limit value MN and the 
upper limit value MX. 
All input parameters must be the same data type or capable of conversion into the most 
powerful data type by implicit conversion. 
The return value is of data type ANY_ELEMENTARY. 
MIN (MAX (IN, MN), MX) 
The data type corresponds to the most powerful data type of the input parameters. 
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5.16.5 MUX Multiplex function 

Symbol    

 
 
Parameters Input parameter  

data type 
Description 

EN BOOL Enable input 
ENO BOOL Enable output 
C ANY_INT Input parameter 
IN0 ANY Input parameter 
IN1 ANY Input parameter 

Description 
The function value is one of the two input parameters IN0 or IN1, depending on the value of 
the input parameter K. 
The input parameters IN0 and IN1 must be the same data type or must be capable of implicit 
conversion into the same data type. 
The return value is data type ANY. 
The data type corresponds to the common data type of the input parameters IN0 and IN1. 
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Commissioning (software) 6
6.1 Commissioning 

This chapter describes how to assign created programs to the task system of a control unit 
and how to download them to the target system. 

6.2 Assigning programs to a task 
Programs must be assigned to a task before they can be downloaded to the target system 
(the SIMOTION device).   
Various tasks are made available by SIMOTION, each with different priorities or system 
responses (e.g. during initialization).  
Further information can be found in the SIMOTION SCOUT Basic Functions Function 
Manual, and in SIMOTION online help. 
Assigning programs to a task:    
1. In the project navigator, double-click under the corresponding SIMOTION device the 

EXECUTION SYSTEM element. 
The configuration window for the execution system opens. 

2. Select the required task (e.g. MotionTask_1) from the left pane. 
3. Select the Program assignment tab. 
4. Select the program to be assigned from the Programs list. 
5. Click the button >>. 
6. Select the Task configuration tab to specify additional settings for the task if required. 
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Figure 6-1 Configure execution system 

 
Figure 6-2 Assigning a program to a motion task 
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6.3 Execution levels and tasks in SIMOTION 

Table 6- 1      

Execution level Description 
Time-controlled Cyclic tasks: 

automatically restarted once assigned programs have been executed.   
• SynchronousTasks Tasks are started periodically, synchronous with specified system cycle 

clock. 
• ServoSynchronousTask: Synchronous with position-control cycle 

clock 
• IPOsynchronousTask: Synchronous with interpolator cycle clock 

IPO 
• IPOsynchronousTask_2: Synchronous with interpolator cycle clock 

IPO_2 
• PWMsynchronousTask: Synchronous with PWM cycle clock 

(for TControl technology package) 
• InputSynchronousTask_1: Synchronous with Input1 cycle clock 

(for TControl technology package) 
• InputSynchronousTask_2: Synchronous with Input2 cycle clock 

(for TControl technology package) 
• PostControlTask_1: Synchronous with Control1 cycle clock 

(for TControl technology package) 
• PostControlTask_2: Synchronous with Control2 cycle clock 

(for TControl technology package) 

• TimerInterruptTasks Tasks are started periodically in a fixed time frame. This time frame 
must be a multiple of interpolator cycle clock IPO. 

Interrupts Sequential tasks: 
executed once after start and then terminated.   

• SystemInterruptTasks Started when a system event occurs: 
• ExecutionFaultTask: Error processing a program 
• PeripheralFaultTask: Error on I/O 
• TechnologicalFaultTask: Error on the technology object 
• TimeFaultBackgroundTask: BackgroundTask timeout 
• TimeFaultTask: TimerInterruptTask timeout 

• UserInterruptTasks They are started when a user-defined event occurs. 
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Execution level Description 
Round robin MotionTasks and BackgroundTasks share the free time remaining after 

execution of the higher-priority system and user tasks. The proportion 
of the two levels can be assigned. 

• MotionTasks Sequential tasks: 
executed once after start and then terminated. Start takes place: 
• Explicitly via a task control command in a program assigned to 

another task. 
• Automatically when RUN mode is attained if the corresponding 

attribute was set during task configuration. 
The priority of a MotionTask can be temporarily increased using the 
Wait for... functions (see Wait for axis , Wait for signal , Wait for 
condition). 

• BackgroundTask Cyclic task: 
automatically restarted once assigned programs have been executed. 
The task cycle time depends on the runtime. 

StartupTask Task is executed once when there is a transition from STOP or STOP 
U mode to RUN mode. 
SystemInterruptTasks are started by their triggering system event. 

ShutdownTask Task is executed once when there is a transition from RUN mode to 
STOP or STOP U mode. 
STOP or STOP U mode is reached by: 
• Activating the operating mode switch 
• Calling the relevant system function, for example, MCC Change 

operating mode command 
• Occurrence of a fault with the appropriate error response 
SystemInterruptTasks and PeripheralFaultTasks are started by their 
triggering system event. 

For information on behavior of sequential and cyclic tasks: 
• During initialization of local program variables:  

See Initialization of local variables (Page 114). 
• In the event of processing errors in the program: 

 Please refer to the SIMOTION Basic Functions Function Manual. 
For information about access options for the process image and I/O variables:  
Please refer to Important features of direct access and process image (Page 120). 
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6.4 Task start sequence 
When the StartupTask is completed, RUN mode is reached.     
The following tasks are then started: 
● SynchronousTasks 
● TimerInterruptTasks 
● BackgroundTask 
● MotionTasks with startup attribute. 

 

 Note 
The sequence in which these tasks are first started after RUN mode has been reached does 
not conform to the task priorities. 

 

 

 
Figure 6-3 Task configuration of a motion task 
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6.5 Downloading programs to the target system 
The program has to be downloaded into the target system, together with the technology 
objects etc., before being executed.  
To download the program to the target system, proceed as follows:    
1. Select Project > Save and compile all 

The project is locally saved on the hard disk and compiled, with due regard for all 
dependencies. 

2. Select the Project > Check consistency menu command to check the project for 
consistency. 
This is not necessary if the option Check consistency before loading is activated in menu 
option Options > Settings in the Download tab (the default for this option is to be 
activated). This means that the consistency check is performed automatically during 
Download. 

3. Select the Project > Connect to target system menu command or click . 
The Online mode is activated. 

4. Select the Target system > Connect to target system menu command or click . 
The project data (including the sample program) and the data of the hardware 
configuration are downloaded to the RAM of the target system. 

For more information about downloading a program to the target system, see the SIMOTION 
Basic Functions Function Manual. 
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Debugging Software / Error Handling 7
7.1 Modes for program testing 

7.1.1 Modes of the SIMOTION devices 
Various SIMOTION device modes are available for program testing. 
How to select the mode of a SIMOTION device: 
1. Highlight the SIMOTION device in the project navigator. 
2. Select the "Test mode" context menu. 
3. Select the required mode (see following table). 

If you have selected "Debug mode": 
– Accept the safety information. 
– Parameterize the sign-of-life monitoring. 
Observe the following section: Important information about the life-sign monitoring 
(Page 257). 

4. Confirm with "OK". 
The SIMOTION device switches to the selected mode. 
When the SIMOTION device switches to "Debug mode": 
– A connection to the target system will be established automatically (online mode) if 

SIMOTION SCOUT is currently in offline mode. 
– The activated debug mode is indicated in the status bar. 
– The breakpoints toolbar (Page 278) is displayed. 
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Table 7- 1 Modes of a SIMOTION device 

Setting Meaning 
Process mode Program execution on the SIMOTION device is optimized for maximum system performance. 

The following diagnostic functions are available, although they may have only restricted 
functionality because of the optimization for maximum system performance: 
• Monitor variables in the symbol browser or a watch table. 
• Program status (only restricted): 

– Restricted monitoring of variables (e.g. variables in loops, return values for system 
functions). 

– As of version V4.0 of the SIMOTION kernel: 

No more than one program source (e.g. ST source, MCC source, LAD/FBD source) can 
be monitored per task. 

– Up to version V3.2 of the SIMOTION kernel: 

No more than one program source (e.g. ST source, MCC source, LAD/FBD source) can 
be monitored. 

• Trace tool (only restricted) with measuring functions for drives and function generator, see 
online help: 
– No more than one trace on each SIMOTION device. 

Test mode The diagnostic functions of the process mode are available to the full extent: 
• Monitor variables in the symbol browser or a watch table. 
• Program status: 

– Monitoring of all variables possible. 
– As of version V4.0 of the SIMOTION kernel: 

Several program sources (e.g. ST sources, MCC sources, LAD/FBD sources) can be 
monitored per task. 

– Up to version V3.2 of the SIMOTION kernel: 

No more than one program source (e.g. ST source, MCC source, LAD/FBD source) can 
be monitored per task. 

• Trace tool with measuring functions for drives and function generator, see online help: 
– No more than four traces on each SIMOTION device. 

 
Note 
Runtime and memory utilization increase as the use of diagnostic functions increases. 

Debug mode This mode is available in SIMOTION kernel as of V3.2. 
In addition to the diagnostic functions of the test mode, you can use the following functions: 
• Breakpoints 

Within a program source file, you can set breakpoints (Page 272). When an activated 
breakpoint is reached, selected tasks will be stopped. 

• Controlling MotionTasks 

In the "Task Manager" tab of the device diagnostics, you can use task control commands for 
MotionTasks, see the SIMOTION Basic Functions Function Manual. 

No more than one SIMOTION device of the project can be switched to debug mode. 
SIMOTION SCOUT is in online mode, i.e. connected with the target system. 
Observe the following section: Important information about the life-sign monitoring (Page 257). 
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7.1.2 Important information about the life-sign monitoring. 
 

WARNING  
You must observe the appropriate safety regulations. 
Use the debug mode or a control panel only with the life-sign monitoring function activated 
with a suitably short monitoring time! Otherwise, if problems occur in the communication 
link between the PC and the SIMOTION device, the axis may start moving in an 
uncontrollable manner. 
The function is released exclusively for commissioning, diagnostic and service purposes. 
The function should generally only be used by authorized technicians. The safety 
shutdowns of the higher-level control have no effect. 
Therefore, there must be an EMERGENCY STOP circuit in the hardware. The appropriate 
measures must be taken by the user. 

 

Accept safety notes 
After selecting the debug mode or a control panel, you must accept the safety notes. You 
can set the parameters for the life-sign monitoring. 
Proceed as follows: 
1. Click the Settings button. 

The "Debug settings" window opens. 
2. Read there, as described in the following section, the safety notes and parameterize the 

life-sign monitoring. 
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Parameterizing the life-sign monitoring 
In the Life-sign monitoring parameterization window, proceed as described below: 
1. Read the warning! 
2. Click the Safety notes button to open the window with the detailed safety notes. 
3. Do not make any changes to the defaults for life-sign monitoring. 

Changes should only be made in special circumstances and in observance of all danger 
warnings. 

4. Click Accept to confirm you have read the safety notes and have correctly parameterized 
the life-sign monitoring. 

 

NOTICE  
Pressing the spacebar or switching to a different Windows application causes: 
• In debug mode for activated breakpoints: 

– The SIMOTION device switches to STOP mode. 
– The outputs are deactivated (ODIS). 

• For controlling an axis or a drive using the control panel (control priority for the PC): 
– The axis or the drive is brought to a standstill. 
– The enables are reset. 

 

WARNING  
This function is not guaranteed in all operating modes. Therefore, there must be an 
EMERGENCY STOP circuit in the hardware. The appropriate measures must be taken by 
the user. 
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7.1.3 Life-sign monitoring parameters 

Table 7- 2 Life-sign monitoring parameter description 

Field Description 
Life-sign monitoring The SIMOTION device and SIMOTION SCOUT regularly exchange life-sign 

signals to ensure a correctly functioning connection. If the exchange of the 
life-sign is interrupted longer than the set monitoring time, the following 
response occurs: 
• In debug mode for activated breakpoints: 

– The SIMOTION device switches to STOP mode. 
– The outputs are deactivated (ODIS). 

• For controlling an axis or a drive using the control panel (control priority 
for the PC): 
– The axis is brought to a standstill. 
– The enables are reset. 

The following parameterizations are possible: 
• Active check box: 

If the check box is selected, life-sign monitoring is active. 

The deactivation of the life-sign monitoring is not always possible. 
• Monitoring time: 

Enter the timeout. 
 
Prudence 
Do not make any changes to the defaults for life-sign monitoring, if possible.
Changes should only be made in special circumstances and in observance 
of all danger warnings. 

Safety information Please observe the warning! 
Click the button to obtain further safety information. 
See: Important information about the life-sign monitoring (Page 257) 
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7.2 Symbol Browser 

7.2.1 Characteristics 
In the symbol browser, you can view and, if necessary, change the name, data type, and 
variable values. In particular, you can: see the following variables:   
● Unit variables and static variables of a program or function block 
● System variables of a SIMOTION device or a technology object 
● I/O variables or global device variables. 
For these variables, you can: 
● View a snapshot of the variable values 
● Monitor variable values as they change 
● Change (modify) variable values 
However, the symbol browser can only display/modify the variable values if the project has 
been loaded in the target system and a connection to the target system has been 
established. 

7.2.2 Using the symbol browser 

Enabling symbol browser 
To enable the symbol browser, proceed as follows:    
1. Make sure that a connection to the target system has been established and that the 

sample program has been downloaded to the target system (see Download programs to 
the target system (Page 254)). You can run the program, but you don't have to. If the 
program is not run, you only see the initial values of the variables. 

2. If you have not already done so, select a LAD/FBD unit in the project navigator. 
3. Click the Symbol browser tab. 

All of the unit variables used in the program are displayed. 
In the Status value column, the current variable values are displayed and periodically 
updated. 
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Variables in the user memory of the unit or in the retentive memory 
In the symbol browser, you can monitor the variables contained in the user memory of the 
unit or in the retentive memory: 
● Retentive and non-retentive unit variables of the interface section of a program source 

(unit) 
● Retentive and non-retentive unit variables of the implementation section of a program 

source (unit) 
● Static variables of the function blocks whose instances are declared as unit variables. 
● In addition, if the program source (unit) has been compiled with the "Create program 

instance data only once" compiler option (Page 48): 
– Static variables of the programs. 
– Static variables of the function blocks whose instances are declared as static variables 

of programs. 
Follow these steps: 
1. Select the program source file in the project navigator. 
2. In the detail view, click the Symbol browser tab. 
In the symbol browser, you can see all the variables of the program source contained in the 
user memory of the unit or in the retentive memory. 
● All unit variables of the program source. 
● Only if the program source has been compiled with the "Create program instance data 

only once" compiler option: The programs of the program source file and below their 
static variables (including instances of function blocks). 
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Variables in the user memory of the task 
You can use the symbol browser to monitor the variables contained in the user memory of 
the associated task: 
If the program source (unit) was compiled without the compiler option (Page 48) "Create 
program instance data only once" (default), the user memory of the task to which the 
program was assigned contains the following variables: 
● Static variables of the programs. 
● Static variables of the function blocks whose instances are declared as static variables of 

programs. 
Follow these steps: 
1. In the project navigator of SIMOTION SCOUT, select the EXECUTION SYSTEM element 

in the subtree of the SIMOTION device. 
2. In the detail view, click the Symbol browser tab. 
The symbol browser shows all tasks used in the execution system together with the 
assigned programs. The associated variables contained in the user memory of the task are 
listed below. 

 

 Note 
You can monitor temporary variables (together with unit variables and static variables) with 
Program status (see Program status (Page 269)). 

 

System variables and global device variables 
You can also monitor the following variables in the symbol browser: 
● System variables of SIMOTION devices 
● System variables of technology objects 
● I/O variables 
● Global device variables 
Follow these steps: 
1. Select the appropriate element in the SIMOTION SCOUT project navigator. 
2. In the detail view, click the Symbol browser tab. 
The corresponding variables are displayed in the symbol browser. 
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Status and controlling variables 
In the Status value column, the current variable values are displayed and periodically 
updated. 
You can change the value of one or several variables. Proceed as follows for the variables to 
be changed:    
1. Enter a value in the Control value column. 
2. Activate the check box in this column 
3. Click the Immediate control button. 
The values you entered are written to the selected variables. 

 

NOTICE  
Note when you change the values of several variables: 
The values are written sequentially to the variables. It can take several milliseconds until 
the next value is written. The variables are changed from top to bottom in the symbol 
browser. There is therefore no guarantee of consistency. 

 

Fixing the display 
You can fix the display of the symbol browser for the active object:   
1. To do so, click the Maintain display  symbol in the right upper corner of the symbol 

browser. The displayed symbol changes to . 
The variables of this object are still displayed and updated in the symbol browser even if 
another object is selected in the project navigator. 

2. To remove the display, click the  symbol again. The displayed symbol changes back 
to . 

Display invalid floating-point numbers 
Invalid floating-point numbers are displayed as follows in the symbol browser (independently 
of the SIMOTION device): 

Table 7- 3 Display invalid floating-point numbers 

Display Meaning 
1.#QNAN 
-1.#QNAN 

Invalid bit pattern in accordance with IEEE 754 (NaN Not a Number) There is no 
distinction between signaling NaN (NaNs) and quiet NaN (NaNq). 

1.#INF 
-1.#INF 

Bit pattern for + infinity in accordance with IEEE 754 
Bit pattern for – infinity in accordance with IEEE 754 

-1.#IND Bit pattern for indeterminate 



Debugging Software / Error Handling  
7.3 Watch tables 

 SIMOTION LAD/FBD 
264 Programming and Operating Manual, 05/2009 

7.3 Watch tables 

7.3.1 Monitoring variables in watch table 

Watch table options   
With the symbol browser you can view the variables belonging to one object in your project; 
with the program status you can view the variables belonging to a selected monitoring area 
in the program. With watch tables, by contrast, you can monitor selected variables from 
different sources as a group (e.g. program sources, technology objects, SINAMICS drives - 
even on different devices). 
You can see the data type of the variables in offline mode. You can view and also modify the 
value of the variables in online mode.      

Creating a watch table   
Procedure for creating a watch table and assigning variables:  
1. In the project navigator, open the Monitor folder. 
2. Double-click the Insert watch table entry to create a watch table and enter a name for it. A 

watch table with this name appears in the Monitor folder. 
3. In the project navigator, click the object from which you want to move variables to the 

watch table. 
4. In the symbol browser, select the corresponding variable line by clicking its number in the 

left column. 
5. From the context menu, select Add to watch table and the appropriate watch table, e.g. 

Watch table_1. 
6. If you click the watch table, you will see in the detail view of the Watch table tab that the 

selected variable is now in the watch table. 
7. Repeat steps 3 to 6 to monitor the variables of various objects. 
If you are connected to the target system, you can monitor the variable contents. 
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Status and controlling variables   
In the Status value column, the current variable values are displayed and periodically 
updated. 
You can change the value of one or several variables. Proceed as follows for the variables to 
be changed:  
1. Enter a value in the Control value column. 
2. Activate the checkbox in this column 
3. Click the Immediate control button. 
The values you entered are written to the selected variables. 

 

NOTICE  
Note when you change the values of several variables: 
The values are written sequentially to the variables. It can take several milliseconds until 
the next value is written. The variables are changed from top to bottom in the watch table. 
There is therefore no guarantee of consistency. 

 

Fix the display of the watch table   
You can fix the display of the active watch table: 
● To do so, click the Retain display  icon in the right upper corner of the Watch table tab in 

the detail view. The displayed symbol changes to  . 
This watch table is still displayed even if another one is selected in the project navigator. 

● To remove the display, click the  icon again. The displayed symbol changes back 
to  . 
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7.4 Trace 

Trace options 
Trace allows you to record and save signal characteristics of inputs/outputs or the variable 
values. This allows you to document the optimization, for example, of axes. 
You can set the recording time, display up to four channels with eight values each in the test 
or debug mode, select trigger conditions, parameterize timing adjustments, select between 
different curve displays and scalings, etc. 
The SIMOTION online help provides additional information on the trace tool. 
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7.5 Program run 

7.5.1 Program run: Display code location and call path 
You can display the position in the code (e.g. line of an ST source file) that a MotionTask is 
currently executing along with its call path.    
Follow these steps: 
1. Click the "Show program run" button on the Program run toolbar. 

The "Program run call stack (Page 268)" window opens. 
2. Select the desired MotionTask. 
3. Click the "Update" button. 
The window shows: 
● The position in the code being executed (e.g. line of the ST source file) stating the 

program source and the POU. 
● Recursively positions in the code of other POUs that call the code position being 

executed. 
The following names are displayed for the SIMOTION RT program source files: 

Table 7- 4 SIMOTION RT program source files 

Name Meaning 
taskbind.hid Execution system 
stdfunc.pck IEC library 
device.pck Device-specific library 
tp-name.pck Library of the tp-name technology package, 

e.g. cam.pck for the library of the CAM technology package 
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7.5.2 Parameter call stack program run 
You can display the following for all configured tasks: 
● the current code position in the program code (e.g. line of an ST source file) 
● the call path of this code position 

Table 7- 5 Parameter description call stack program run 

Field Description 
Selected CPU The selected SIMOTION device is displayed. 
Refresh Clicking the button reads the current code positions from the 

SIMOTION device and shows them in the open window.  
Calling task Select the task for which you want to determine the code position 

being executed. 
All configured tasks of the execution system. 

Current code position The position being executed in the program code (e.g. line of an ST 
source file) is displayed (with the name of the program source file, 
line number, name of the POU). 

is called by The code positions that call the code position being executed within 
the selected task are shown recursively (with the name of the 
program source file, line number, name of the POU, and name of the 
function block instance, if applicable). 

For names of the SIMOTION RT program sources, refer to the table in "Program run 
(Page 267)". 

7.5.3 Program run toolbar 
You can display the position in the code (e.g. line of an ST source file) that a MotionTask is 
currently executing along with its call path with this toolbar.   

Table 7- 6 Program run toolbar 

Symbol Meaning 

 
Display program run 
Click this button to open the Program run call stack window. In this window, you can 
display the currently active code position with its call path. 
See: Program run: Display code position and call path (Page 267) 
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7.6 Program status (monitoring program execution) 

Monitoring the program execution    
Monitoring the program execution does not affect the actual execution of the program, but 
does increase the communication load. This has an impact on the execution of MotionTasks 
and the BackgroundTask. 
Program status can be switched on and off during all modes of a SIMOTION device. 

 

 Note 
In the process mode, the program status can be called only once for a LAD/FBD program, 
FB or FC. 
In the test mode, the program status can be called for a maximum of four LAD/FBD 
programs, FB or FC.  
If you do not observe the restriction, error message 25023 "No resources in the runtime" will 
appear. 

 

7.6.1 Starting and stopping the program execution monitoring 

Starting and stopping program status   
You can call up information on network status in two different ways using the program status: 
● You can select specific networks to display their status. Multiple selection (shift key) and 

the selection of all networks (Ctrl+a) is possible. The boxes will be displayed in the same 
color as the corresponding output. 
The left-hand border of a selected network is highlighted in blue. 

● If you do not select a network, the status is displayed for those networks that are visible 
on the screen. If you scroll down, the status of those visible networks is now displayed. 

To start/stop Program status, proceed as follows: 
1. Make sure that the LAD/FBD unit generates the additional debug code during 

compilation: 
Select the LAD/FBD unit in the project navigator and select the Edit > Object properties 
menu command. 
Select the Compiler tab, activate the Permit program status checkbox and confirm with 
OK. 

2. Open the LAD/FBD unit and recompile it with LAD/FBD unit > Save and compile. 
3. Download and start the program in the usual way. Make sure that the target system is in 

STOP mode. 
4. Click the Program status button to start the test mode. 
5. To stop the program execution monitoring, click the Program status icon. 
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If the program execution monitoring is activated, the ladder diagram lines/signal paths of the 
selected networks or the networks displayed on the screen are colored according to the 
current values: 

 
① Green: 1, True 
② Gray background: Non-binary value 
③ Red: 0, False 

Figure 7-1 Online display in the LAD/FBD editor 
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 Note 
When a constant is used in a network, the current value of the constant is also displayed 
during program execution. 
A constant which is not included is colored turquoise. 
Monitoring of the program execution is started by means of the Program status icon. 
In order to be able to monitor several programs simultaneously with the program status, the 
following conditions must be fulfilled: 
• Mark the required LAD/FBD unit in the project navigator, select the Properties command 

in the context menu and mark the Permit program statuscheckbox in the Compiler tab. 
• Mark the required SIMOTION device in the project navigator, select the Test mode 

command in the context menu and enable the Test mode option. 
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7.7 Breakpoints (WS) 

7.7.1 General procedure for setting breakpoints 
You can set breakpoints within a POU of a program source (e.g. ST source, MCC chart, 
LAD/FBD source). On reaching an activated breakpoint, the task in which the POU with the 
breakpoint is called is stopped. If the breakpoint that initiated the stopping of the tasks is 
located in a program or function block, the values of the static variables for this POU are 
displayed in the "Variables status" tab of the detail display. Temporary variables (also in/out 
parameters for function blocks) are not displayed. You can monitor static variables of other 
POUs or unit variables in the symbol browser.   

Requirement: 
● The program source with the POU (e.g. ST source file, MCC chart, LAD/FBD program) is 

open. 

Proceed as follows 
Follow these steps: 
1. Select "Debug mode" for the associated SIMOTION device, see Set debug mode 

(Page 273). 
2. Specify the debug task group, see Specifying the debug task group (Page 274). 
3. Set breakpoints, see Setting breakpoints (Page 276). 
4. Define the call path, see Defining a call path for a single breakpoint (Page 279). 
5. Activate the breakpoints, see Activating breakpoints (Page 283). 
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7.7.2 Setting the debug mode 
 

WARNING  
You must observe the appropriate safety regulations. 
Use the debug mode only with activated life-sign monitoring (Page 257) with a suitably 
short monitoring time! Otherwise, if problems occur in the communication link between the 
PC and the SIMOTION device, the axis may start moving in an uncontrollable manner. 
The function is released exclusively for commissioning, diagnostic and service purposes. 
The function should generally only be used by authorized technicians. The safety 
shutdowns of the higher-level control have no effect! 
Therefore, there must be an EMERGENCY STOP circuit in the hardware. The appropriate 
measures must be taken by the user. 

 

To set the debug mode, proceed as follows: 
1. Highlight the SIMOTION device in the project navigator. 
2. Select Test mode from the context menu. 
3. Select Debugmode (Page 255). 
4. Accept the safety information 
5. Parameterize the sign-of-life monitoring. 

See also section: Important information about the life-sign monitoring (Page 257). 
6. Confirm with OK. 

If no connection has been established with the target system (offline mode), the online 
mode will be established automatically. 
The activated debug mode is indicated in the status bar. 
The breakpoints toolbar (Page 278) is displayed. 

 

 Note 
You cannot change the program sources in debug mode! 

 

NOTICE  
Pressing the spacebar or switching to a different Windows application causes in debug 
mode for activated breakpoints: 
• The SIMOTION device switches to STOP mode. 
• The outputs are deactivated (ODIS). 

 

WARNING  
This function is not guaranteed in all operating modes. Therefore, there must be an 
EMERGENCY STOP circuit in the hardware. The appropriate measures must be taken by 
the user. 
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7.7.3 Define the debug task group 
On reaching an activated breakpoint, all tasks that are assigned to the debug task group are 
stopped.  

Requirement 
● The relevant SIMOTION device is in debug mode. 

Proceed as follows 
How to assign a task to the debug task group: 
1. Highlight the relevant SIMOTION device in the project navigator. 
2. Select Debug task group from the context menu. 

The Debug Task group window opens. 
3. Select the tasks to be stopped on reaching the breakpoint: 

– If you only want to stop individual tasks (in RUN mode): Activate the Debug task group 
selection option. 
Assign all tasks to be stopped on reaching a breakpoint to the Tasks to be stopped 
list. 

– If you only want to stop individual tasks (in HALT mode): Activate the All tasks 
selection option. 
In this case, also select whether the outputs and technology objects are to be released 
again after resumption of program execution. 

 

NOTICE  
Note the different behavior when an activated breakpoint is reached, see the following 
table. 
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Table 7- 7 Behavior at the breakpoint depending on the tasks to be stopped in the debug task group. 

Tasks to be stopped Properties 
Single selected tasks 
(debug task group) 

All tasks 

Behavior on reaching the breakpoint 
 Operating mode RUN STOP 
 Stopped tasks Only tasks in the debug task group All tasks 
 Outputs Active Deactivated (ODIS activated) 
 Technology Closed-loop control active No closed-loop control (ODIS activated) 
 Runtime measurement of the 

tasks 
Active for all tasks Deactivated for all tasks 

 Time monitoring of the tasks Deactivated for tasks in the debug task 
group 

Deactivated for all tasks 

 Real-time clock Continues to run Continues to run 
Behavior on resumption of program execution 
 Operating mode RUN RUN 
 Started tasks All tasks in the debug task group All tasks 
 Outputs Active 
 Technology Closed-loop control active 

The behavior of the outputs and the 
technology objects depends on the 
'Continue' activates the outputs (ODIS 
deactivated) checkbox. 
• Active: ODIS will be deactivated. All 

outputs and technology objects are 
released. 

• Inactive: ODIS remains activated. All 
outputs and technology objects are 
only released after another download 
of the project. 

 
 

 Note 
You can only make changes to the debug task group if no breakpoints are active. 

 

Proceed as follows: 
1. Set breakpoints (see Setting breakpoints (Page 276)). 
2. Define the call path (see Defining a call path for a single breakpoint (Page 279)). 
3. Activate the breakpoints (see Activating breakpoints (Page 283)). 
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7.7.4 Setting breakpoints 

Requirements:    
1. The program source with the POU (e.g. ST source file, MCC chart, LAD/FBD program) is 

open. 
2. The relevant SIMOTION device is in debug mode, 

see Setting debug mode (Page 273). 
3. The debug task group is defined, see Defining the debug task group (Page 274). 

Proceed as follows 
How to set a breakpoint: 
1. Select the code location where no breakpoint has been set: 

– SIMOTION ST: Place the cursor on a line in the ST source file that contains a 
statement. 

– SIMOTION MCC: Select an MCC command in the MCC chart (except module or 
comment block). 

– SIMOTION LAD/FBD: Set the cursor in a network of the LAD/FBD program. 
2. Alternative: 

– Select the Debug > Set/remove breakpoint menu command (shortcut F9). 

– Click the  button in the Breakpoints toolbar. 
To remove a breakpoint, proceed as follows: 
1. Select the code position with the breakpoint. 
2. Alternative: 

– Select the Debug > Set/remove breakpoint menu command (shortcut F9). 

– Click the  button in the Breakpoints toolbar. 
To remove all breakpoints (in all program sources) of the SIMOTION device, proceed as 
follows: 
● Alternative: 

– Select the Debug > Remove all breakpoints menu command (shortcut CTRL+F5). 

– Click the  button in the Breakpoints toolbar. 
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 Note 
You cannot set breakpoints: 
• For SIMOTION ST: In lines that contain only comment. 
• For SIMOTION MCC: On the module or comment block commands. 
• For SIMOTION LAD/FBD: Within a network. 
• At code locations in which other debug points (e.g. trigger points) have been set. 
You can list the debug points in all program sources of the SIMOTION device in the debug 
table: 
• Click the  button for "debug table" in the Breakpoints toolbar. 
In the debug table, you can also remove all breakpoints (in all program sources) of the 
SIMOTION device: 
• Click the button for "Clear all breakpoints". 
Set breakpoints remain saved also after leaving the "debug mode", they are displayed only 
in debug mode. 

 

You can use the program status (Page 269) diagnosis functions and breakpoints together in 
a program source file or POU. However, the following restrictions apply depending on the 
program languages: 
● SIMOTION ST: For Version V3.2 of the SIMOTION Kernel, the (marked) ST source file 

lines to be tested with program status must not contain a breakpoint. 
● SIMOTION MCC and LAD/FBD: The commands of the MCC chart (or networks of the 

LAD/FBD program) to be tested with program status must not contain a breakpoint. 

Proceed as follows 
1. Define the call path, see Defining a call path for a single breakpoint (Page 279). 
2. Activate the breakpoints, see Activating breakpoints (Page 283). 



Debugging Software / Error Handling  
7.7 Breakpoints (WS) 

 SIMOTION LAD/FBD 
278 Programming and Operating Manual, 05/2009 

7.7.5 Breakpoints toolbar 
This toolbar contains important operator actions for setting and activating breakpoints:   

Table 7- 8 Breakpoints toolbar 

Symbol Meaning 

 
Set/remove breakpoint 
Click this icon to set at breakpoint for the selected code position or to remove an 
existing breakpoint. 
See: Setting breakpoints (Page 276). 

 
Activate/deactivate breakpoint 
Click this icon to activate or deactivate the breakpoint at the selected code position. 
See: Activating breakpoints (Page 283). 

 
Edit the call path 
Click this icon to define the call path for the breakpoints: 
• If a code position with breakpoint is selected: The call path for this breakpoint. 
• If a code position without breakpoint is selected: The call path for all breakpoints 

of the POU. 
See: Defining the call path for a single breakpoint (Page 279), Defining the call path 
for all breakpoints (Page 281). 

 
Activate all breakpoints 
Click this icon to activate all breakpoints in the current program source or POU (e.g. 
ST source file, MCC chart, LAD/FBD program). 
See: Activating breakpoints (Page 283). 

 
Deactivate all breakpoints 
Click this icon to deactivate all breakpoints in the current program source or POU 
(e.g. ST source file, MCC chart, LAD/FBD program). 
See: Activating breakpoints (Page 283). 

 
Remove all breakpoints 
Click this icon to remove all breakpoints in the current program source or POU (e.g. 
ST source file, MCC chart, LAD/FBD program). 
See: Setting breakpoints (Page 276). 

 
Debug table 
Click this icon to display the debug table. 
See: Debug table parameters. 

 
Display call stack 
Click this icon after reaching an activated breakpoint to: 
• View the call path at the current breakpoint. 
• View the code positions at which the other tasks of the debug task group have 

been stopped together with their call path. 
See: Displaying the call stack (Page 285). 

 
Resume 
Click this icon to continue the program execution after reaching an activated 
breakpoint. 
See: Activating breakpoints (Page 283), Displaying the call stack (Page 285). 
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7.7.6 Defining the call path for a single breakpoint 

Requirements:  
1. The program source with the POU (e.g. ST source file, MCC chart, LAD/FBD program) is 

open. 
2. The relevant SIMOTION device is in debug mode, 

see Setting debug mode (Page 273). 
3. The debug task group is defined, see Defining the debug task group (Page 274). 
4. Breakpoint is set, see Setting breakpoints (Page 276). 

Proceed as follows 
To define the call path for a single breakpoint, proceed as follows: 
1. Select the code location where a breakpoint has already been set: 

– SIMOTION ST: Set the cursor in an appropriate line of the ST source. 
– SIMOTION MCC: Select an appropriate command in the MCC chart. 
– SIMOTION LAD/FBD: Set the cursor in an appropriate network of the LAD/FBD 

program. 

2. Click the  button for "edit call path" in the Breakpoints toolbar. 
In the Call path / task selection breakpoint window, the marked code position is displayed 
(with the name of the program source file, line number, name of the POU). 

3. Select the task in which the user program (i.e. all tasks in the debug task group) will be 
stopped when the selected breakpoint is reached. 
The following are available: 
– All calling locations starting at this call level 

The user program will always be started when the activated breakpoint in any task of 
the debug task group is reached. 

– The individual tasks from which the selected breakpoint can be reached. 
The user program will be stopped only when the breakpoint in the selected task is 
reached. The task must be in the debug task group. 
The specification of a call path is possible. 
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4. Only for functions and function blocks: Select the call path, i.e. the code position to be 
called (in the calling POU). 
The following are available: 
– All calling locations starting at this call level 

No call path is specified. The user program is always stopped at the activated 
breakpoint if the POU in the selected tasks is called. 

– Only when a single task is selected: The code positions to be called within the 
selected task (with the name of the program source, line number, name of the POU). 
The call path is specified. The user program will be stopped at the activated 
breakpoint only when the POU is called from the selected code position. 
If the POU of the selected calling code position is also called from other code 
positions, further lines are displayed successively in which you proceed similarly. 

5. If the breakpoint is only to be activated after the code position has been reached several 
times, select the number of times. 

 

 Note 
You can also define the call path to the individual breakpoints in the debug table: 
1. Click the  button for "debug table" in the Breakpoints toolbar. 

The "Debug table" window opens. 
2. Click the appropriate button in the "Call path" column. 
3. Proceed in the same way as described above: 

– Specify the task. 
– Define the call path (only for functions and function blocks). 
– Specify the number of passes after which the breakpoint is to be activated. 

 

Proceed as follows: 
● Activate the breakpoints, see Activating breakpoints (Page 283). 

 

 Note 
You can use the "Display call stack (Page 285)" function to view the call path at a current 
breakpoint and the code positions at which the other tasks of the debug task group were 
stopped.  

 

See also 
Defining the call path for all breakpoints (Page 281) 
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7.7.7 Defining the call path for all breakpoints 
With this procedure, you can: 
● Select a default setting for all future breakpoints in a POU (e.g. MCC chart, LAD/FBD 

program or POU in an ST source file).  
● Accept and compare the call path for all previously set breakpoints in this POU. 

Requirements 
● The program source with the POU (e.g. ST source file, MCC chart, LAD/FBD program) is 

open. 
● The relevant SIMOTION device is in debug mode, 

see Setting debug mode (Page 273). 
● The debug task group is defined, see Defining the debug task group (Page 274). 

Proceed as follows 
To define the call path for all future breakpoints of a POU, proceed as follows: 
1. Select the code location where no breakpoint has been set: 

– SIMOTION ST: Set the cursor in an appropriate line of the ST source. 
– SIMOTION MCC: Select an appropriate command in the MCC chart. 
– SIMOTION LAD/FBD: Set the cursor in an appropriate network of the LAD/FBD 

program. 

2. Click the  button for "edit call path" in the Breakpoints toolbar. 
In the "Call path / task selection all breakpoints for each POU" window, the marked code 
position is displayed (with the name of the program source file, line number, name of the 
POU). 

3. Select the task in which the user program (i.e. all tasks in the debug task group) will be 
stopped when a breakpoint in this POU is reached. 
The following are available: 
– All calling locations starting at this call level 

The user program will always be started when an activated breakpoint of the POU in 
any task of the debug task group is reached. 

– The individual tasks from which the selected breakpoint can be reached. 
The user program will be stopped only when a breakpoint in the selected task is 
reached. The task must be in the debug task group. 
The specification of a call path is possible. 
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4. Only for functions and function blocks: Select the call path, i.e. the code position to be 
called (in the calling POU). 
The following are available: 
– All calling locations starting at this call level 

No call path is specified. The user program is always stopped at an activated 
breakpoint when the POU in the selected tasks is called. 

– Only when a single task is selected: The code positions to be called within the 
selected task (with the name of the program source, line number, name of the POU). 
The call path is specified. The user program will be stopped at an activated breakpoint 
only when the POU is called from the selected code position. 
If the selected calling code position is in turn called by other code positions, further 
lines are displayed successively in which you proceed similarly. 

5. If a breakpoint is only to be activated after the code position has been reached several 
times, select the number of times. 

6. If you want to accept and compare this call path for all previously set breakpoints in this 
POU: 
– Click Accept. 

Proceed as follows: 
● Activate the breakpoints, see Activating breakpoints (Page 283). 

 

 Note 
You can use the "Display call stack (Page 285)" function to view the call path at a current 
breakpoint and the code positions at which the other tasks of the debug task group were 
stopped.  

 

See also 
Defining the call path for a single breakpoint (Page 279) 
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7.7.8 Activating breakpoints 
Breakpoints must be activated if they are to have an effect on program execution.   

Requirements 
1. The program source with the POU (e.g. ST source file, MCC chart, LAD/FBD program) is 

open. 
2. The relevant SIMOTION device is in debug mode, 

see Setting debug mode (Page 273). 
3. The debug task group is defined, see Defining the debug task group (Page 274). 
4. Breakpoints are set, see Setting breakpoints (Page 276). 
5. Call paths are defined, see Defining a call path for a single breakpoint (Page 279). 

Activating breakpoints 
How to activate a single breakpoint: 
1. Select the code location where a breakpoint has already been set: 

– SIMOTION ST: Set the cursor in an appropriate line of the ST source. 
– SIMOTION MCC: Select an appropriate command in the MCC chart. 
– SIMOTION LAD/FBD: Set the cursor in an appropriate network of the LAD/FBD 

program. 
2. Alternative: 

– Select the Debug > Activate/deactivate breakpoint menu command (shortcut F12). 

– Click the  button in the Breakpoints toolbar. 
To activate all breakpoints (in all program sources) of the SIMOTION device, proceed as 
follows: 
● Alternative: 

– Select the Debug > Activate all breakpoints menu command. 

– Click the  button in the Breakpoints toolbar. 
 

 Note 
Breakpoints of all program sources of the SIMOTION device can also be activated and 
deactivated in the debug table: 
1. Click the  button for "debug table" in the Breakpoints toolbar. 

The "Debug table" window opens. 
2. Perform the action below, depending on which breakpoints you want to activate or 

deactivate: 
– Single breakpoints: Check or clear the corresponding checkboxes. 
– All breakpoints (in all program sources): Click the corresponding button. 
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Behavior at the activated breakpoint 
On reaching an activated breakpoint (possibly using the selected call path (Page 279)), all 
tasks assigned to the debug task group will be stopped. The behavior depends on the tasks 
in the debug task group and is described in "Defining a debug task group (Page 274)". The 
breakpoint is highlighted. 
If the breakpoint that initiated the stopping of the tasks is located in a program or function 
block, the values of the static variables for this POU are displayed in the "Variables status" 
tab of the detail display. Temporary variables (also in/out parameters for function blocks) are 
not displayed. You can monitor static variables of other POUs or unit variables in the symbol 
browser (Page 260). 
You can use the "Display call stack (Page 285)" function to: 
● View the call path at the current breakpoint. 
● View the code positions with the call path at which the other tasks of the debug task 

group have been stopped. 

Resuming program execution 
How to resume program execution: 
● Alternative: 

– Select the Debug > Continue menu command (shortcut CTRL+F8). 

– Click the  button on the Breakpoint toolbar to "Continue". 

Deactivate breakpoints   
To deactivate a single breakpoint, proceed as follows: 
1. Select the code position with the activated breakpoint. 
2. Alternative: 

– Select the Debug > Activate/deactivate breakpoint menu command (shortcut F12). 

– Click the  button in the Breakpoints toolbar. 
To deactivate all breakpoints (in all program sources) of the SIMOTION device, proceed as 
follows: 
● Alternative: 

– Select the Debug > Deactivate all breakpoints menu command. 

– Click the  button in the Breakpoints toolbar. 
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7.7.9 Display call stack 
You can use the "Display call stack" function to: 
● View the call path at the current breakpoint. 
● View the code positions with the call path at which the other tasks of the debug task 

group have been stopped. 

Requirement 
The user program is stopped at an activated breakpoint, i.e. the tasks of the debug task 
group (Page 274) have been stopped. 

Proceed as follows 
To call the "Display call stack" function, proceed as follows: 
● Click the  button for "display call stack" in the Breakpoints toolbar. 

The "Breakpoint call stack" dialog opens. The current call path (including the calling task 
and the number of the set passes) is displayed. 
The call path cannot be changed. 

To use the "Display call stack" function, proceed as follows: 
1. Keep the "Breakpoint call stack" dialog open. 
2. To display the code position at which the other task was stopped, proceed as follows: 

– Select the appropriate task. All tasks of the debug task group can be selected. 
The code position, including the call path, is displayed. If the code position is contained in 
a user program, the program source with the POU (e.g. ST source file, MCC chart, 
LAD/FBD program) will be opened and the code position marked. 

3. How to resume program execution: 

– Click the  button for "resume" (Ctrl+F8 shortcut) in the Breakpoint toolbar. 
When the next activated breakpoint is reached, the tasks of the debug task group will be 
stopped again. The current call path, including the calling task, is displayed. 

4. Click "OK" to close the "Breakpoint call stack" dialog. 
For names of the SIMOTION RT program sources, refer to the table in "Program run 
(Page 267)". 
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Application Examples 8
8.1 Examples 

You will be given an introduction to the LAD and FBD programming languages using two 
simple examples. 

8.2 Creating sample programs 

Requirements for program creation 
The project is the highest level in the data management hierarchy. SIMOTION SCOUT 
saves all data which belongs, for example, to a production machine, in the project directory.   
This means that the project therefore brackets together all SIMOTION devices, drives, etc., 
belonging to one machine. 
 
Within the project, the hardware used must be made known to the system, including: 
● SIMOTION device 
● Centralized I/O (with I/O addresses) 
● Distributed I/O (with I/O addresses) 
A SIMOTION device must be configured before you can insert and edit LAD/FBD sources. 

Sample programs 
We will create two short programs (position blinker program, axis program) that demonstrate 
all the work steps from the creation through to the start and testing of a program.  
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8.3 Blinker program 

Prerequisites 
A project must have been created and the hardware used in the project must be known to 
the system. 

Task specification 
Output of a cyclically changing bit pattern after exceeding a limit value.   
This task is divided into the following parts: 
● Insert LAD/FBD source file 
● Insert LAD/FBD program 

Network one 
A program variable is incremented and compared to a reference value 
Network two 
When the reference value is exceeded, the program variable is reset and a bit pattern is 
output 

● Compiling 
● Insert program in a task 
● Download program onto target device 
You can observe the result of your program at the outputs of your target system. 
This example deals only with the LAD programming aspect. 
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8.3.1 Insert LAD/FBD source file 
To insert a new LAD/FBDsource file using the shortcut menu:    
1. Select the PROGRAMS folder of the relevant SIMOTION device in the project navigator. 
2. Double-click the entry Insert LAD/FBD unit. 

 
Figure 8-1 Project folder 

The Insert LAD/FBD unit dialog box appears. 
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Figure 8-2 Insert LAD/FBD unit dialog box 

3. Enter the name of the LAD/FBD unit. 
The names of program sources must comply with the rules for identifiers: They consist of 
letters (A to Z, a to z), numbers (0 to 9), or single underscores (_) in any order, whereby 
the first character must be a letter or an underscore. No distinction is made between 
uppercase and lowercase letters. 
The permissible length of the name depends on the SIMOTION Kernel version: 
– SIMOTION Kernel Version V4.1 and higher: maximum 128 characters. 
– SIMOTION Kernel Version V4.0 and lower: maximum 8 characters. 
Names must be unique within the SIMOTION device. Protected or reserved identifiers 
(Page 329) are not allowed. The LAD/FBD programs already available are displayed. 

4. In the Compiler tab, activate checkbox Permit program status, to use the online status 
display later. 

5. You can also enter an author, version, and a comment. 
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6. Select the Open editor automatically checkbox. 
7. Confirm with OK. 

The declaration tables for exported and source-internal variables appear in the working 
area. 
No variables are defined here in the sample program. 

 
Figure 8-3 Declaration tables for exported and source-internal declarations 
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8.3.2 Insert LAD/FBD program 
To insert an LAD/FBD program, proceed as follows:    
1. In the PROGRAMS folder within the project navigator, open the LAD/FBD unit you just 

inserted. 
2. Double-click the entry Insert LAD/FBD program in the LAD/FBD unit. 

 
Figure 8-4 Opening a project folder 

The Insert LAD/FBD program dialog box appears. 
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Figure 8-5 Insert LAD/FBD program dialog box 

Enter the name of the program in the Insert LAD/FBD program dialog box. 
The names must be unique within a source file. Protected or reserved identifiers 
(Page 329) are not allowed.  
The following appear: 
– all POUs from its own program source 
– the exportable POUs (e.g. LAD/FBD programs, MCC charts) from other program 

sources 
3. For Creation type, select program. 
4. Where necessary, activate Exportable if you want the LAD/FBD program to be accessible 

from other program sources (LAD/FBD, MCC or ST source files) or from the execution 
system. 

5. Select the Open editor automatically checkbox. 
6. Confirm with OK. 

A blank LAD/FBD program is opened. 
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Figure 8-6 Open LAD/FBD program 
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8.3.3 Entering variables in the declaration table 
To enter variables, proceed as follows:    
1. Select the Parameters/variables tab. 
2. Enter name, variable type, data type and/or start value in the declaration table (as shown 

in the figure below). 

 
Figure 8-7 Variables in the declaration table 

3. Select the I/O Symbols tab. 
4. Enter the name and absolute identifier (in accordance with the figure below). 

The data type is entered automatically. 

 
Figure 8-8 I/O symbols in the declaration table 
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8.3.4 Entering a program title 
To enter a program title, proceed as follows:   
1. Click in the title line. 
2. Enter the program name in the window. 

 
Figure 8-9 Program title 

8.3.5 Inserting network 
To insert a network:     
1. Select LAD/FBD program > Insert network menu item. 

 
Figure 8-10 Menu selection 

2. Click in the title line. 
3. Enter the network name in the window. 

 
Figure 8-11 Network with entered name 

4. Click the power rail to the left of the coil. 
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8.3.6 Inserting an empty box 
To insert an empty box, proceed as follows:    
1. From the menu, select the LAD/FBD program > Insert element > Empty box menu item. 

 
Figure 8-12 Insert an empty box 

An empty box is inserted. 
Mandatory parameters in a network are identified by ???, optional parameters by ... . 
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8.3.7 Selecting box type 

 
Figure 8-13 Empty box 

To select a box type, proceed as follows:    
1. Press the Enter key in the selected empty box. 

A drop-down menu appears. 
2. Select the appropriate box type from the drop-down menu and confirm your selection by 

pressing the Enter key. 

 
Figure 8-14 Selection of box type 
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8.3.8 Parameterizing the ADD call-up 
To parameterize the ADD call-up, proceed as follows:    
1. Click in the other mandatory input fields ???. 

 
Figure 8-15 ADD box 

2. Enter the appropriate values. 
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8.3.9 Inserting comparator 
To insert a comparator, proceed as follows:    
1. Select the ADD box. 

 
Figure 8-16 Selected ADD box 

2. Select LAD/FBD program > Insert element >Comparator > > =. 

 
Figure 8-17 Select comparator 
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Figure 8-18 Inserted comparator 

8.3.10 Labeling the comparator 
To label the comparator, proceed as follows:    
1. Click each comparator input field individually. 
2. Enter the appropriate values for the comparator. 

 
Figure 8-19 Labeled comparator 
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8.3.11 Initializing a coil 
To initialize a coil, proceed as follows:    
1. Click in the input field ??? of the coil. 
2. Enter the appropriate variable. 

 
Figure 8-20 Initialized coil 

8.3.12 Inserting next network 
To insert another network, proceed as follows:    
1. To insert the second network, repeat the steps used to insert the first network. 

 
Figure 8-21 Project with two networks 
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8.3.13 Details view 
To show the detail view, proceed as follows:    
1. Select the View > Detail view menu command. 

Information, e.g. compiler messages, will be displayed during the compilation of a 
program. 

 
Figure 8-22 Detail view menu selection 

8.3.14 Compiling 
To compile the created program, proceed as follows:     
1. Select the program in the project navigator. 
2. Open the LAD/FBD program menu and select Accept and compile. 

The source file and its POUs are saved and compiled. 
During the compilation process, messages on the successful compilation status are 
displayed in the detail view. Should any error occur during compilation, they will be 
displayed in plain text there. 

 
Figure 8-23 Save and compile menu selection 
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Figure 8-24 Compiled project with compiler information in the detail view 
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8.3.15 Assigning a sample program to an execution level 
To assign a program to an execution level, proceed as follows:    
1. Double-click the EXECUTION SYSTEM folder in the project navigator. 
2. Click BackgroundTask. 
3. Click the Program assignment tab. 
4. Select the program Q_blink.p_blink. 
5. Click the button >>. 

 
Figure 8-25 Assigning a program to the BackgroundTask 

6. Click Close and acknowledge the message saying the execution system has changed by 
clicking Yes. 
The changes are accepted into the project. 
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8.3.16 Starting sample program 
To start a program, proceed as follows:      
1. Select Project > Save and compile all 

The project is locally saved on the hard disk and compiled. 
2. Select the Project > Connect to target system menu command or click . 

The Online mode is activated. 
3. Select the Target system > Connect to target system menu command or click . 

The project data (including the sample program) and the data of the hardware 
configuration are downloaded to the RAM of the target system. 

4. Mark both networks and click the Program status button (shortcut CTRL+F7) in the LAD 
editor toolbar (Page 25) to confirm. 
Monitoring the program execution (Page 269) is switched on. 

5. Mark the SIMOTION device in the project navigator and select Target device > Operating 
mode in the context menu. 
The Operating mode window with the software switch for modes opens. 

6. Click the RUN button in the software switch. 
The SIMOTION device is in RUN mode. The sample program is run and the current 
paths/signal paths are color-coded in accordance with the current signal values 
(Page 269). 
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Figure 8-26 Sample program is started 
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8.4 Position axis program 

Prerequisites 
A project, a CPU and a virtual position axis must be created.  

Task specification 
An axis is to be traversed at a velocity of 100 mm/s from the current position 1000 mm in the 
negative direction.   
This task is divided into the following parts: 
● Insert LAD/FBD unit 
● Insert LAD/FBD program 

– Insert network 
– Set axis enable signals 
– Traverse axis to position 
– Remove axis enable 

● Compile program 
● Insert program in a task 
● Download program onto target device 
PLCopen blocks are used for the programming. The PLCopen blocks are designed for use in 
cyclic programs/tasks and enable motion control programming in a PLC environment. They 
are used primarily in the LAD/FBD programming language.  
PLCopen blocks are available as standard functions (directly from the command library). 
You can find further information about PLCopen blocks in the SIMOTION PLCopen Blocks 
Function Manual. 
There is a TO-specific command available for the aforementioned subtasks Set axis enable 
and Traverse axis to position/Remove axis enable. Each command is represented by a box 
in LAD/FBD. The parameters for individual commands (position = 1000, speed = 100 etc.) 
are entered  
via the Variable declaration dialog box. 
- or - 
via the Enter call parameters dialog box 
- or - 
by entering the values in the input fields on each connector. 
The task is implemented using LAD programming. 
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8.4.1 Insert LAD/FBD source file 
To insert an LAD/FBD unit (for details of how to insert the unit and program, see also the 
blinker program (Page 288) example), proceed as follows:    
1. Open the PROGRAMS folder of the relevant SIMOTION device in the project navigator. 
2. Double-click the entry Insert LAD/FBD unit. 

The Insert LAD/FBD unit dialog box appears. 
3. Enter the name of the LAD/FBD unit. 

The names of program sources must comply with the rules for identifiers: They consist of 
letters (A to Z, a to z), numbers (0 to 9), or single underscores (_) in any order, whereby 
the first character must be a letter or an underscore. No distinction is made between 
uppercase and lowercase letters. 
The permissible length of the name depends on the SIMOTION Kernel version: 
– SIMOTION Kernel Version V4.1 and higher: maximum 128 characters. 
– SIMOTION Kernel Version V4.0 and lower: maximum 8 characters. 
Names must be unique within the SIMOTION device. Protected or reserved identifiers 
(Page 329) are not allowed.  
Existing program sources (e.g. ST source files, MCC units) are displayed. 

4. In the Compiler tab, activate checkbox Permit program status, to use the online status 
display later. 

5. You can also enter an author, version, and a comment. 
6. Select the Open editor automatically checkbox. 
7. Confirm with OK. 

The declaration tables for global and unit-local variables appear in the working area. 

See also 
Blinker program (Page 288) 



Application Examples  
8.4 Position axis program 

 SIMOTION LAD/FBD 
310 Programming and Operating Manual, 05/2009 

8.4.2 Insert LAD/FBD program 
To insert an LAD/FBD program, proceed as follows:    
1. In the PROGRAMS folder within the project navigator, open the LAD/FBD unit you just 

inserted. 
2. Double-click the entry Insert LAD/FBD program in the LAD/FBD unit. 

The Insert LAD/FBD program dialog box appears. 
3. Enter the name of the program in the Insert LAD/FBD program window. 

The names must be unique within the SIMOTION device. Protected or reserved 
identifiers (Page 329) are not allowed. 
The following appear: 
– all POUs from its own program source 
– the exportable POUs (e.g. LAD/FBD program, MCC charts) from other program 

sources 
4. For Creation type, select program. 
5. Select the Open editor automatically checkbox. 
6. Confirm with OK. 

A blank LAD/FBD program is opened. 
7. Click the working area and select LAD/FBD program > Insert network from the menu to 

insert a new network. 

 
Figure 8-27 Inserted network 

 

 
 

Note 
Mandatory parameters in a network are identified by ???, optional parameters by ... . 
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8. Mark the inserted box and select Delete in the context menu. 
The box is removed from the network. 

 
Figure 8-28 Inserted network without a box 
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8.4.3 Inserting a TO-specific command 
To insert a TO-specific command, proceed as follows:      
1. To enhance the display in the working area, open the shortcut menu of the network and 

select Display > Mandatory and assigned box parameters. 
2. Select the Command Library tab in the project navigator. 

The command groups appear. 
3. Click the relevant plus sign to open the PLCopen > SingleAxis command group. 
4. Drag&drop the _mc_power command into the network (see Network with RET 

assignment). 
This command serves to enable the command. 

 
Figure 8-29 TO-specific command (_mc_power) from the command library 
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Figure 8-30 Network with inserted _mc_power box 

5. Mark the network and select LAD/FBD program > Insert network from the menu to insert 
a second network. 

6. Mark the inserted box from the second network and select Delete in the context menu. 
The box is removed from the network. 

7. Drag&drop the _mc_moverelative command from the command library to the marked 
position in the second network. 
The axis is positioned at the specified speed with this command. 
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Figure 8-31 TO-specific command (_mc_moverelative) from the command library 

 
Figure 8-32 Network with inserted _mc_moverelative box 
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8.4.4 Connecting the enable inputs 
The enable input for the _mc_power command and the execute enable input for the 
_mc_moverelative command still have to be connected to NO contacts. 
How to insert the NO contacts:      
1. Click the working area and select Display > Alle Box Parameters in the context menu. 

All the inputs and outputs of the boxes are shown. 
2. Select the Command Library tab in the project navigator. 

The command groups appear. 
3. Click the plus symbol to open the command group LAD elements. 
4. Drag&drop the NO contact LAD element to the enable input of the _mc_power function 

block. 

 
Figure 8-33 Drag&drop the NO contact LAD element to the connector of the enable input 
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Figure 8-34 Network with a NO contact LAD element inserted 
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5. Drag&drop two NO contact LAD elements to the execute enable input of the 
_mc_moverelative function block. 

 
Figure 8-35 Networks with NO contacts inserted 
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8.4.5 Entering variables in the declaration table 
To enter variables, proceed as follows:    
1. Select the Parameters/variables tab. 
2. Enter name, variable type, data type and/or start value in the declaration table (as shown 

in the figure below). 
In order to use PLCopen blocks, you must create one block instance for each being used 
(_mc_power and _mc_moverelative). The data type of the instance corresponds to the 
block name. The variables i_mc_power and i_mc_moverelative are instance variables for 
the two function blocks _mc_power and _mc_moverelative. 
You can find further information about the declaration and use of instance variables in 
Example: Function block (FB) (Page 150). 

 
Figure 8-36 Variables in the declaration table 
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8.4.6 Parameterization of the NO contacts 
How to parameterize each of the NO contacts:      
1. Click in the input field ??? for the NO contact. 
2. Enter the appropriate variable. 
3. Press Enter. 

 
Figure 8-37 Parameterization of the NO contacts 
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8.4.7 Setting call parameters for the _mc_power command 
 

 Note 
The Enter call parameters dialog box displayed below is available for each Simotion 
command. 

 

To set the call parameters, proceed as follows:    
1. Double-click the box. 
2. Select the instance, the homing axis, the axis enables to be set, stop mode and enable 

mode for the axis. 
If you print the project, your parameters appear in the printout according to your settings, 
e.g. only allocated box parameters. 

3. Confirm with OK. 

 
Figure 8-38 Set call parameters for the PLCopen block _mc_power 
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Figure 8-39 Labeled _mc_power box 
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8.4.8 Setting call parameters for the _mc_moverelative command 
To set the call parameters, proceed as follows:    
1. Double-click the _mc_moverelative box. 
2. Select the instance and the homing axis. Enter values for the difference in distance 

traveled and for the maximum speed of the axis. 
If you print the project, your parameters appear in the printout according to your settings, 
e.g. only allocated box parameters. 

3. Confirm with OK. 

 
Figure 8-40 Set call parameters for the PLCopen block _mc_moverelative 
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Figure 8-41 Network with entered variables 
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8.4.9 Details view 
To show the detail view, proceed as follows:    
1. Select the View > Detail view menu item. 

Information, e.g. compiler messages, will be displayed during the compilation of a 
program. 

8.4.10 Compiling 
To compile the program, proceed as follows:     
1. Select the program in project navigation. 
2. Open the LAD/FBD program menu and select Accept and compile. 
During the compilation process, messages on the successful compilation status are 
displayed in the detail view. Should any error occur during compilation, they will be displayed 
in plain text there. 

8.4.11 Assigning a sample program to an execution level 
Before you can run the sample program, you must assign it to an execution level or a task. 
When you have done this, you can establish the connection to the target system, download 
the program to the target system, and then start it. 
To assign the program to an execution level (see also the blinker program (Page 305) 
example), proceed as follows:    
1. Double-click the EXECUTION SYSTEM folder in the project navigator. 
2. Mark the BackgroundTask. 
3. Click the Program assignment tab. 
4. Select the program. 
5. Click the button >>. 
6. Click Close. 

See also 
Assigning a sample program to an execution level (Page 305) 
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8.4.12 Starting sample program 
To start a program, proceed as follows:      
1. Select Project > Save and compile all 

The project is locally saved on the hard disk and compiled. 
2. Select the Project > Connect to target system menu command or click . 

The Online mode is activated. 
3. Select the Target system > Connect to target system menu command or click . 

The project data (including the sample program) and the data of the hardware 
configuration are downloaded to the RAM of the target system. 

4. Mark both networks and click the  button for program status (shortcut CTRL+F7) in the 
LAD editor toolbar (Page 25) to confirm. 
Monitoring the program execution (Page 269) is switched on. 

5. Mark the SIMOTION device in the project navigator and select Target device > Operating 
mode in the context menu. 
The Operating mode window with the software switch for modes opens. 

6. Click the RUN button in the software switch. 
The SIMOTION device is in RUN mode. The sample program is run and the current 
paths/signal paths are color-coded in accordance with the current signal values 
(Page 269). 
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Figure 8-42 Sample program is started 
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Appendix A
A.1 Key combinations 

The following key combinations are available:  
 
With LAD/FBD editor open 
Cursor keys With a selected operator: Navigation between the individual operators 
Ctrl+CursorUp Select previous network 
Ctrl+CursorDn Select next network 
Page up Select the network at the start of the visible editor area 
Page down Select the network at the end of the visible editor area 
Del Deletes an operator 
Tab / Shift+Tab Jumps forward to next button / input field / jumps back to previous button / input field 
Return Opens the edit field of the current operand or confirms the entry made in the edit field 
Esc Aborts the entry while edit field is open 

 

 
Window menu 
Ctrl+Shift+F5 Rearranges all windows opened in this application in horizontal tiled format. 
Ctrl+Shift+F3 Rearranges all windows opened in this application in vertical tiled format. 
Alt+F4 Closes all windows and ends the application. 

 

 
View menu 
Ctrl+F11 Maximizes the working area 
Ctrl+F12 Maximizes the detail view 
Ctrl+Num+ Enlarges the contents of the working area. 
Ctrl+Num- Reduces the contents of the working area. 
F5 Updates the view 
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Edit menu 
Ctrl+Z Undoes the last action (except: Save) 
Ctrl+Y Redoes the last action which was undone. 
Ctrl+X Cuts a command 
Ctrl+C Copies a command 
Ctrl+V Inserts a command 
Del Deletes selected commands in the LAD editor 
Alt+Enter Displays the properties of the active/selected object for editing. 
Enter  Opens the selected object. 
Ctrl+B  Saves and compiles the active/selected object. 
Ctrl+A Selects all objects in the current window 
Alt+F8 Insert comparator 
Alt+F9 Insert an empty box 
Ctrl+R Inserts a new network 
Ctrl+L Jump label ON/OFF 
Ctrl+Shift+K Show/hide comment line 
Ctrl+Z Undo 
Ctrl+Y Repeat 
Ctrl+1 Switches to LAD 
Ctrl+3 Switches to FBD 
Ctrl+T Symbol check and type update 
Ctrl+Shift+B Display options for boxes 
Shift+F6 Switches between declaration table and editor area 

 

 
LAD elements 
F2 Insert NO contact 
F3 Insert NC contact 
F7 Insert coil 
F8 Open branch 
F9 Close branch 

 

 
FBD elements 
F2 Insert AND box 
F3 Insert OR box 
F4 Insert XOR box 
F7 Assignment 
F8 Insert binary input 
F9 Negate binary input 

 

 
Symbol input help 
Ctrl+H Opens the symbol input help dialog window 
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A.2 Protected and reserved identifiers 
Reserved identifiers may only be used as predefined. You may not declare a variable or data 
type with the name of a reserved identifier.    
There is no distinction between upper and lower case notation. 
The ST programming language includes protected and reserved identifiers (see the 
SIMOTION ST Programming and Operating Manual). The same list also applies to the 
LAD/FBD programming languages. The LAD/FBD programming language also includes the 
protected and reserved identifiers listed in the table. 
You can find a list of all the identifiers whose meanings are predefined in SIMOTION in the 
SIMOTION Basic Functions Function Manual.  

Table A- 1 Protected identifiers applicable only to the LAD/FBD programming language 

A 
ANDN  
C 
CAL 
CALC 

CALCN 

J 
JMP 
JMPC 

JMPCN 

L 
LD LDN 
O 
ORN  
R 
RET 
RETC 

RETCN 

S 
ST STN 
X 
XORN  
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_additionObjectType, 101 
_camTrackType, 101 
_controllerObjectType, 101 
_device, 134 
_direct, 119, 122, 134 
_fixedGearType, 101 
_formulaObjectType, 101 
_getcommandid 

Advance signal switching, 157 
_getSafeValue 

Application, 134 
_sensorType, 101 
_setSafeValue 

Application, 134 

A 
Activate 

Automatic symbol check, 30 
Symbol browser, 260 
Type update, 30 

Activating 
On-the-fly variable declaration, 37 

Advance signal switching 
_getcommandid, 157 
Boolean, 157 
Non-Boolean, 157 

Advance switching, 157 
AND box, 186 
ANY, 96 
ANY_BIT, 96 
ANY_DATE, 96 
ANY_ELEMENTARY, 96 
ANY_INT, 96 
ANY_NUM, 96 
ANY_REAL, 96 
ANYOBJECT, 101 
Arithmetic operators, 228 
Array element 

Initial value, 91 
Initialization value, 91 

Array length 
Variables, 90 

Assignment, 191 

Resetting, 193 
Setting, 194 

Automatic symbol check 
Activating, 30 
Deactivating, 33 
LAD/FBD editor, 29 

Automatic syntax check 
LAD/FBD elements, 75 

B 
Backward compatibility, 55 
Binary input 

Inserting, 189 
Negate, 190 

Bit data types, 93, 206 
BOOL, 93 
Boolean advance signal switching, 157 
Box type 

Interface adjustment, 158 
Selecting, 298 

Breakpoint, 272 
Activating, 283 
Call path, 279, 281 
Call stack, 285 
Deactivating, 284 
remove, 276 
Set, 276 
Toolbar, 278 

BYTE, 93 

C 
Call parameters 

Making individual settings for LAD/FBD 
elements, 78 
Making settings for LAD/FBD elements, 79, 320, 
322 

Call path 
Breakpoint, 279, 281 
Call stack, 285 
Program run, 267 

camType, 101 
Change 

Colors, 36 
Fonts, 35 
LAD/FBD program creation type, 58 
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Operand and comment fields, 34 
Variable values in the symbol browser, 263 

Changing 
LAD/FBD network comments, 66 
LAD/FBD program comments, 66 

Close 
LAD/FBD program, 56 
LAD/FBD source file, 43 

Close parallel branch, 184 
Code attributes, 166 
Colors 

Changing, 36 
Command call 

Drag&Drop, 27 
Command library, 83 

Inserting functions, 84 
Inserting LAD/FBD elements, 84 
Special features, 85 
Unusable functions, 84 

Command name 
Drag&Drop, 28 

Comment 
Print, 60 

Commissioning 
Execution levels and tasks, 251 

Commissioning (software) 
Assigning programs to a task, 249 
Downloading the project to the target system, 254 
Task start sequence, 253 

Comparator, 201 
Comparison operations 

Comparator, 201 
Overview, 201 

Compile 
Defining the order of the POU, 54 
Detail view, 42, 55 
LAD/FBD program, 55, 303, 324 
LAD/FBD unit, 42 

Compiler 
Global settings, 48 
Local settings, 49 

CONCAT, 210 
Conductor bar 

LAD/FBD elements, 69 
Connections 

Defining, 135 
to LAD/FBD programs, 135 
To libraries, 135 
to MCC charts, 135 
to ST source files, 135 

Connector, 175, 192 
CONSTANT, 103 
Constants 

Time specifications, 94 
Context menu 

LAD/FBD editor, 24 
Conversion functions 

Bit data types, 206 
Date and time, 210 
Numeric data types, 206 
TRUNC, 205 

Converting 
LAD to FBD representation, 72 

Converting FBD to LAD representation, 73 
Copy 

LAD/FBD elements, 76 
LAD/FBD network, 68 
LAD/FBD program, 54 
LAD/FBD unit, 43 

Counter instructions 
CTD down counter, 216 
CTD_DINT down counter, 217 
CTD_UDINT down counter, 218 
CTU up counter, 213 
CTU_DINT up counter, 214 
CTU_UDINT up counter, 215 
CTUD up/down counter, 219 
CTUD_DINT up/down counter, 221 
CTUD_UDINT up/down counter, 222 
Overview, 213 

Creation type, 58 
Cross-reference list, 161 

Displayed data, 162 
Filtering, 164 
Generating, 161 
Single step monitoring (MCC), 162 
Sorting, 164 
TSI#dwuser_1, 162 
TSI#dwuser_2, 162 

Cut 
LAD/FBD elements, 76 
LAD/FBD network, 68 
LAD/FBD unit, 43 

Cyclic program execution 
Effect on I/O access, 119 
Effect on variable initialization, 110 

Cyclic program processing 
Effect on I/O access, 122, 128 

D 
Data type list 

Setting in declaration tables, 34 
Data types 

Bit data type, 93 
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elementary, 93 
Inheritance, 102 
Interface adjustment, 158 
Numeric, 93 
STRING, 94 
Technology object, 101 
Time, 94 

DATE, 94 
Date and time, 210 
DATE_AND_TIME, 94 
Deactivate 

Automatic symbol check, 33 
Type update, 33 

Debug mode, 256, 273 
Declaration 

Scope, 89 
declaration table 

Comment, 91 
Defining enumerations, 99 
Defining structures, 99 
Implementation section, 98 
Initial value, 91 
Initialization value, 91 
Interface section, 98 
Scope of derived data types, 98 

Declaration table 
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