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 What's new in CFC? 1 
 

CFC V8.0.4 
Version V8.0.4 includes the following enhancements or changes as compared to the 
previous version V8.0.3: 

● Technological editor 

The technological editor now supports: 

– Equipment modules and types of equipment modules with lower-level control 
modules. 

● Data exchange with COMOS Integrated Engineering or Advanced ES 

Equipment modules and types of equipment modules are supported for data exchange.  

● Global and specific commands and states 

The following commands and states are now supported  

– At the type of a control module (not at an instance) or at a "Control module (basic 
requirement)". These commands and states are specific to these objects. 

– Globally, i.e. created with the SIMATIC Manager in the master data library. These 
global commands and states are generally based on equipment phases and can be 
used in all equipment phases of a plant. 

CFC V8.0.3 
Version V8.0.3 includes the following enhancements or changes as compared to the 
previous version V8.0.2: 

● "S7-410" AS  

The "S7-410" automation system is supported. 

CFC V8.0.2  
Version 8.0.2 contains the following extensions or changes as compared to the previous 
version, V8.0.1: 

● Control module types and control modules 

The synchronization of control module types and control modules is supported. 
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CFC V8.0.1  
Compared with the previous version V8.0, version V8.0.1 includes the following 
enhancements or changes: 

● Technological editor 

The technological editor now supports: 

– the standard AND, OR, XOR and NOT functions 

– Control modules and control module types with hierarchical charts 

CFC V8.0  
Version V8.0 contains the following enhancements or changes compared to the previous 
version V7.1.2: 

● Fine-grained operating rights 

You can use the new "Op_Level" attribute to configure levels of operator control 
permissions for a block type. 

● Block encryption 

CFC supports the encryption of blocks. Functions (FCs) and function blocks (FBs) can be 
encrypted. During compiling/loading, an encryption is recognized as a change and the 
respective block or function is replaced. 

● License consumption for process objects   

More than one license or no license at all can now be booked for the use of process 
objects depending on the functionality of the block type. 

● New concept for process tag types and process tags 

In addition to process tag types and process tags, there are now control module types 
and control module instances. These support instance-specific changes in case of 
process tag synchronization and several versions of process tag types. Data exchange 
with PCS 7 Advanced ES is also possible. 

See also 
PCS 7 license information (Page 23) 

Count and booking of the PO licenses (Page 24) 

Configuring in the network (Page 35) 

Forcing block I/Os (Page 268) 

Setting up AS-wide interconnections (Page 120) 

Basic information on control module types (Page 168) 
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 Introduction 2 
 

What is CFC?         
CFC (Continuous Function Chart) is an editor with a graphical user interface, an extension 
based on the STEP 7 software package. It is used to create the entire software structure of 
the CPU and uses pre-configured blocks. The editor lets you insert blocks into function 
charts, assign block parameters and interconnect blocks. 

Interconnecting means that values can be transferred from one output to one or more inputs 
during communication between the blocks or other objects. 

Operating principle 
You work with graphic tools in the CFC editor: You drag-and-drop pre-configured blocks from 
the pool of blocks to your chart. The chart is a kind of "drawing board". You interconnect the 
block inputs and outputs via a mouse click. There is no need to consider details such as 
algorithms or the assignment of machine resources, in other words, you can fully 
concentrate on the technological aspects of your configuration. 

The runtime properties of blocks are assigned default settings you can adapt individually. 
Since individual blocks or groups of blocks can be copied or moved from chart to chart, you 
can save a considerable amount of time. Interconnections between the blocks are retained. 

After having created all functions, generate the executable machine code by means of 
mouse click, download the code to the target system and debug it using the CFC debugger 
functions provided for this purpose. 

Target systems 
CFC can be used to configure various target systems. Operations performed by the user 
when working with CFC are identical to a great extent. 

It is possible that parts of this help do not apply to the target systems that differ from 
SIMATIC. This affects the description of the STEP7 and PCS 7-specific blocks in particular. 
In this case, please read the Help for the superposed applications. 

 

 Note 

MW0 cannot be used for operation with an S7-300 module, because it would be overwritten 
each time a block with startup characteristics is called, for example, FC 70 (RESTART). 
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Pool of blocks 
You can import blocks required in CFC from block libraries, the master data library or other 
projects, or you can create your own blocks. 

 

 Note 

CFC is "upwards compatible". Modification of programs using tools other than those of the 
CFC editor will lead to inconsistencies. 

 

Compatibility with earlier projects 
With the current CFC version you can read and display data created using an earlier CFC 
version. You can edit these data. At the first write access, these data are converted 
(following a system prompt) in order to ensure compatibility. However, the version is not 
"downward compatible". You cannot use the V5.x CFC editor to edit data created or 
converted under version 6.0 or later. 

Additional information 
You will find brief instructions relating to the configuration steps required to create a project 
and download it to the AS in the section: Getting started (Page 13) 
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 Getting started 3 
 

Overview    
This section explains the procedures for configuring your S7 target system: 

1. Creating the project structure  

In the SIMATIC Manager , you need to create a chart folder for the CFC below the 
hierarchy level of the program folder. 

Create the specific CFC charts in the chart folder, either in the SIMATIC Manager or 
directly in the CFC editor.  

In PCS 7, you use the "New Project" wizard for these steps. 

2. Creating blocks (optional) 

CFC works with ready-made blocks. These can be blocks from libraries, other programs, 
or block types created by you. You can create block types in CFC by compiling the 
charts. 

3. Inserting and importing blocks 

Block types required for the project must be implemented and, in some cases, imported 
to the project according to the target system used.  

You insert blocks into the chart from the catalog using drag-and-drop or copy a block 
from another position to the S7 program block folder. Inserting a block in a chart creates 
a block instance with a name that is unique throughout the chart. You can create any 
number of block instances from each block type. When a block is inserted in a chart, the 
block type is imported to the CFC data management. 

4. Assigning parameters and interconnecting the blocks  

You can assign parameters to block I/Os and interconnect them. Targets of the 
interconnection are other blocks, nested charts or shared addresses. You can specify 
textual interconnections at block/chart inputs whose interconnection target is not yet in 
the chart folder. This interconnection remains open until the referenced target of the 
interconnection is available and the interconnection is made via a menu command. 

5. Adapting the runtime properties  

The runtime properties of a block determine how the block is included in the processing 
of the entire structure on the PLC. The properties are decisive for the response of the 
target system in terms of reaction times, dead times or the stability of time-dependent 
structures, for example, control loops. 

When it is inserted, each block is assigned default runtime properties. A block is inserted 
in a task at the position you specify. You can change the position at which the block is 
installed and other attributes later if necessary. 
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6. Compiling the CFC charts  

When a program is compiled, all charts of the active CPU are converted to machine code. 
Different compilers are used, depending on the target system; the call is identical, 
however. If you compile as a block type, only the individual chart is compiled.  

7. Downloading the CFC program 

You can download the CFC program to the CPU after compilation.  

8. Testing the CFC program 

You can test the compiled and downloaded program. The scope and type of test 
functions differs depending on the target system. In the test mode, you are connected to 
the automation system online. 
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 Essentials of CFC 4 
4.1 CFC in the STEP 7 environment 

STEP 7 components  
The following STEP 7 components are important when working with CFC: 

● SIMATIC Manager  
Used as the central database and to coordinate the tools and objects of SIMATIC 
Manager for all target systems. It manages tools and data and is used, for example, for 
creating and modifying project structures (CPU, CFC charts) and for starting the CFC 
editor. 

● STEP 7 tools 
These tools are used to create the input data for CFC and I/O data which you can 
reference in the CFC: 

– LAD, STL, SCL 
Programming languages used to create block types for S7. After you have created 
block types in these languages, you can import them into CFC and configure them. 

– Symbol table 
The process signals and other shared addresses such as bit memories and data 
blocks are assigned symbolic names and are entered in the symbol table of STEP 7. 
The CFC can use these names. 

● SFC (PCS 7) 
Engineering tool used to create technological sequential control systems. With sequential 
control systems, you can control functions in basic automation using operating and state 
changes (these functions are normally configured with CFC). 

Interaction between CFC and SIMATIC Manager 
The following should be observed when working with the SIMATIC Manager : 

● You can only delete charts, chart folders and projects using the SIMATIC Manager if no 
chart in the particular chart folder or project is currently being edited in CFC. 

● Projects that contain CFC charts may not be saved on diskettes, neither using the "New 
project" nor the "Save project as" functions. 

● You should only generate chart reference data in the CFC. If you generate reference data 
in the SIMATIC Manager , you will no longer be able to download changes to this 
program online. 
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Flow of configuration data 
The figure below shows the flow of configuration data in S7, starting at the creation of block 
types and going through to the point where the machine code is downloaded to the 
automation system. 
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Data flow for configuring an S7-CPU 

1. (Optional) Create the block types with STEP 7 tools (for example, with SCL) and save 
them to the S7 user program. 
(Optional) Global data blocks are created with the LAD/STL editor and stored in the S7 
user program. 

2. In the CFC editor, create charts in which blocks (taken from the S7 user program or block 
libraries) are inserted, configured and interconnected. 

3. The CFC charts are compiled. A CFC program is generated. 
Note: In CFC, you can create block types by compiling charts with chart I/Os as block 
type.  
Restriction: These charts cannot contain nested charts. Block types created in CFC can 
also be saved to a library. 

4. The CFC program is downloaded to the CPU. 
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4.2 Blocks in CFC 

Functions as blocks            
In CFC, you work with preconfigured blocks that execute a specific function. You insert these 
function blocks in the chart, interconnect and configure them. 

 

 Note 

The initial value at the output of the CFC blocks is "1", regardless of the values at the inputs. 
This means the following logic is supplied with "1" as long as the block is not processed. 

 

The block type 
A type definition exists for each function block and specifies the following: 

● Algorithm 

● Type name 

● Data interface (input and output parameters) 

The type name is an abbreviation or acronym of the function, for example: 

● CTUD (COUNT UP and DOWN) 
For edge-triggered up/down counters 

● COUNT_P 
up/down counter which is triggered at the positive edge of a binary signal, depending on 
the setting 

● ADD_R 
A simple function that adds input values and transfers the result to the output 

The type definition also determines the data types of the I/O parameters. In the following, 
these I/O parameters are referred to as block I/Os, since this is how they appear in the 
graphical display of the block. 

The data type of an input or output specifies the values it can accept.  

Examples: 

BOOL: Boolean type, can only adopt the values 0 or 1. 

STRING: Character string type, can contain a character string as its value. 

You can find information about other data types in: Data types for S7 (Page 138) 

The block instance 
When you insert a block in your CFC chart, you generate an instance of this block type. In 
this context, “instance” refers to an instance of the selected block type.  

You can create any number of block instances from a particular block type. You can assign 
names to these block instances, interconnect and assign parameters to them without 
changing the functionality specific to the type. 
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One useful aspect of this type instance concept is, for example, that subsequent local 
changes to the block type can be automatically distributed to all block instances. 

Multiple instance blocks 
Functions may consist of various sub-functions. These sub-functions are implemented as 
blocks and merged in order to create a complex block. This can be a control (internal) block, 
for example, that contains a message block and an operator control block. 

Multiple instance blocks can be created in CFC by interconnecting different blocks 
(functions) and assigning suitable parameters to those blocks. This chart is subsequently 
compiled as block type. 

Blocks with variable number of inputs 
CFC contains blocks whose number of inputs is variable and can be changed in the CFC 
chart. Such blocks are known as generic blocks. The AND block, for example, is a block with 
a variable number of inputs. 

Block families 
Blocks are assembled in groups (block families) according to their functional properties. 
Each block is assigned a family identifier when it is created. The following blocks, for 
example, form a family: 

● Conversion blocks for adapting various data types  
CONVERT (e.g., BO_BY, BY_DW, W_DW) 

● Multiplexer blocks =  
MULTIPLX (e.g., MUX8_R, MUXn_DI,) 

● Blocks with mathematical (floating point) functions  
MATH_FP (e.g., SQRT, ADD_R) 

The block family names are also used, for example, as a sort criterion in the CFC catalog. 

Organization blocks  
The interface between the CPU operating system and the user program is formed by tasks 
known under S7 as organization blocks (OBs). Those OBs/tasks are used to execute 
specific program sections at certain times and in certain situations. For example, there are 
OBs for: 

● CPU startup (cold restart, hot restart) 

● Process alarms 

● Cyclic interrupts with different time bases 

Organization blocks or tasks do not represent blocks in the context of CFC; since they can 
neither be inserted nor edited in CFC. In CFC, the OBs are displayed in a run sequence after 
calling the runtime editor. 
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Additional differences 
Blocks also differ in their type. When a block is created, it must be declared as a function 
block (FB), function (FC) or basic operation (BOP). 

● The FB has a memory function. Existing data can be accessed across several processing 
cycles. Data access is enabled by creating a data block (DB) for each block instance. In a 
complex block, however, the FB contains additional subsidiary FBs, but only one 
common DB. 

● The FC does not have a memory function. The values generated by the block are 
processed directly. No data block is required here. Outputs of an FC are not assigned 
default values. 

● The BOP does not have a memory function, the same as the FC. Its basic operations 
form part of the CFC program and are entered as SCL statements during compilation and 
used for basic functions such as AND and OR. 

 
  Note 

In case of a warm restart of the CPU, the BOP inputs receive the last value of the pool 
DB. 

 

Special situation: Overlapping blocks 
Overlapping blocks are inserted or moved to a chart where they have insufficient space. In 
this case, they overlap other objects completely or partly.  

They are displayed in light gray and without visible block I/Os until they are repositioned to a 
free sheet location. Their interconnections and entries in the sheet bar are also hidden, but 
nevertheless exist. 
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4.3 Automatic naming 

Introduction    
Automatic naming in this context refers to objects generated, copied or moved via SIMATIC 
Manager and/or the CFC/runtime editor.  

Creating 
Each object in a project is automatically assigned a name at the time of its creation. This 
name consists of the object type name and an appended counter. The counter is displayed 
in brackets. Uniqueness of names within the namespace is taken into consideration here. 
This applies to the following objects: 

 
Objects Namespace 
Hierarchy folder (THO) Project 
OS area ID and picture name for OS Project 
Charts (top charts and nested charts) Program 

Examples: 

 
Folder name: S7 program(1) 
Chart name: CFC(1) 
OS picture name: Picture(1) 

Copying 
The following applies when copying objects within or to other folders: 

If the name is identical, the "Overwrite object" dialog box appears, with the options "Yes", 
"No" or "Rename": 

● If you select "Yes", the object is overwritten and the name is retained. This only makes 
sense when copying data to another folder, since this would otherwise generate a zero 
operation. 

● If you select "No", the object is copied and an additional counter is appended without 
delimiter. 
When the (original) object is copied once again, the appended counter is incremented.  
When you copy the copied version, an additional counter is appended. 

Examples: 

 
Chart: CFC(1) First copy → CFC(1)(1) 
Chart: CFC(1) Repeated copy → CFC(1)(2) 
Chart: CFC(1)(2) Copy → CFC(1)(2)(1) 

● If you select "Rename", another dialog box appears. Here you can enter a new name or 
accept the default name automatically assigned in the edit box. 
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Moving 
The conventions for copying objects also apply when you move objects. 

The response of objects described below differs to that of those described above: 

Moving block instances 

When you insert it in the chart, the block is automatically assigned a number as its name. 
This naming is sequential. Each new block inserted as a copy or via drag-and-drop from the 
catalog is assigned the next available higher number. 

The following applies when you change the default name of this copied/moved block: 
Identical names are appended a number (without brackets). If the name being modified 
already ends in a number, this number is simply incremented. 

Examples: 

 
Block: 2 Copy → 3 
Block: REG Copy → REG1 
Block: REG1 Copy → REG2 

Moving runtime groups 

The response of copied runtime groups is identical to that of block instances when they are 
inserted in the run sequence. A sequential number is appended to the name without 
brackets. 
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 What you should know about CFC 5 
5.1 PCS 7 license information 

Process objects (only relevant for CFC in PCS 7)  
Process objects are all SFCs and all block instances that contain blocks which support 
reporting, operating and monitoring. These are the objects that are transferred to the OS and 
require licenses. Driver block are not used as PO. 

In the SIMATIC Manager , you can start a function that identifies all of the POs configured 
and booked in the Automation License Manager (ALM). The result is displayed in the "PCS 7 
license information" dialog box. This allows you to check whether the existing "SIMATIC 
PCS 7 AS RT PO" license, or the license you intend to order, is adequate for your project 
and the number of POs you can still add to your project. 

Different process objects can use a varying number of licenses. How many licenses are 
needed depends on the functionality of the block type. You can view this information in the 
object properties of the block type in the module folder.  

These objects are only entered in the count if they can be downloaded to an AS. Block 
instances in S7 programs without hardware assignment (at the project level or in libraries) 
are not considered. 

Display PCS 7 license information 

Procedure: 

1. Selects the multiproject or the project. 

2. Select the PCS 7 license information shortcut menu command. 

3. In the left window of the dialog box, select the "Process objects (AS RT PO)" license. 

 

The "PCS 7 license information" dialog box opens. The right window shows the total of all 
process objects in the multiproject and the number of process objects in each individual 
project and station. 

If you select an individual project, only the number of process objects in this project and the 
stations is shown. 

Information concerning scenarios during the counting of POs can be found under: Count and 
booking of the PO licenses (Page 24)  
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5.2 Count and booking of the PO licenses 

Basic sequence 
The loader determines the process objects (PO) and the serial number of the CPU and 
Memory Card during the download. Aided by this number, a program is assigned to the 
CPU. A PO info is created in the ES data management for each CPU that is downloaded and 
records identifiers and the number of used PO licenses. 

During the downloading process it is determined if and how many PO licenses for the current 
CPU have already been used. The number of POs that were identified during the last 
download is read from the PO info stored in the ES data management. The difference 
between the currently determined number of POs is compared with the number of licenses 
available in Automation License Manager (ALM). If the required POs are still covered by the 
license the difference is booked in the ALM and the download is executed.  

If the current program contains fewer POs than the one previously downloaded, the number 
of available PO licenses is increased again through the download. If not enough licenses are 
available, the license violation generates a corresponding message that must be confirmed 
Now you may either terminate the download or continue just the same. The number of the 
required but unavailable licenses are recorded as a shortage. If you have purchased 
additional licenses, these missing licenses are included and registered in the ALM at the 
next download. 

Licensing the POs for the "S7-410" AS 

The following additional properties apply to the licensing of POs for the "S7-410" AS: 

● The number of POs is licensed by the hardware for the "S7-410" AS. It is not possible to 
download a greater number of POs than is licensed by the hardware into the AS. 

● For the "S7-410" AS, the number of process objects (PO) that are recorded in the 
Automation License Manager under the license "AS RT PO" is compared with the number 
of POs that are loaded in the "S7-410" AS. 

If the number of the recorded licenses for POs in the Automation License Manager is 
lower than the number of POs that are loaded in the "S7-410" AS, this insufficient 
licensing is indicated by:  

– An entry in the diagnostics buffer of the CPU 

– Cyclical triggering of a corresponding message in SIMATIC WinCC. 

The message is always triggered immediately during the loading operation for which 
insufficient licensing is detected and when the difference changes due to the loading 
operation. After this, the message appears approximately every 6 hours.  

When the process objects are sufficiently licensed once again, for example due to the 
purchase of additional licenses, this message no longer appears. No "OUTGOING" 
message is generated. 
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Scenarios during the PO count 
The following scenarios are considered: 

● First full download of a program 

The loader determines that this program has never been downloaded. A PO info is 
created in the ES data management and assigned the CPU identification data along with 
the current number of POs. The current number of POs is booked in the ALM. This 
results in reducing the counter reading of licenses. 

● Downloading changes to a program on the same CPU 

After comparing the data of the PO info the loader determines that this program has 
already been downloaded to the same CPU. The current number of POs is determined 
and the difference made up between value of the last download procedure. The 
difference is booked in the ALM. This results in reducing or increasing the counter 
reading of licenses. The stored number of POs in the PO info is replaced with the current 
number. 

● Moving a program to a different CPU 

After comparing the data of the PO info the loader determines that this program has 
already been downloaded to a different CPU. A message is output which indicates that 
the number of POs stored during the last download can no longer be booked back if this 
download procedure continues. Here you can terminate the download process and book 
back the used PO licenses. Use the Charts > Booking Back Process Objects for selected 
chart folder. Requirement: The existing CPU must be connected.  

The PO info is updated with the data from the CPU that is currently connected when you 
continue the download. The current number of POs is determined and entered likewise in 
the PO info. This number is booked in the ALM. This results in reducing the counter 
reading of licenses. 

● Retiring a CPU 

If you no longer wish to use a CPU then you can retrieve its used POs. Use the Charts > 
Booking Back Process Objects for selected chart folder.  

A comparison with the PO info is made to verify whether the same CPU that was used 
during the last download is connected.  

If this is not the case then a corresponding message appears informing that the PO 
licenses that were used during the last download can not be booked back by deleting the 
program in the connected CPU. The process must be terminated here in order to repeat it 
after the "correct" CPU is connected.  

A security check is made to verify the pending deletion of the program after the correct 
CPU is connected. The program is deleted after confirmation is made. The number of 
stored PO licenses is booked back in the ALM. Afterwards, the PO info is initialized; in 
other words, during the next download procedure, the program appears as if it were 
newly created.  
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The PO info remains unchanged if you were unable to book back the POs because, for 
example, the license was no longer available. You can book back the POs at a later time 
after the license is available again. 

This function is terminated after a corresponding message appears if no CPU is 
connected or the one that is connected is not accessible. 

● Multiple use of a program in several CPUs 

If the same program is downloaded to several CPUs then the number on the PO counter 
for each downloaded CPU is reduced by the current number of POs.  

After comparing the data of the PO info the loader determines that this program has 
already been downloaded to a different CPU. A message is output which indicates that 
the number of POs stored during the last download can no longer be booked back if this 
download procedure continues. Here you can terminate the download process. Otherwise 
the PO info is updated with the data from the CPU that is currently connected. The 
current number of POs is determined and entered likewise in the PO info. This number is 
booked in the ALM. This results in reducing the counter reading of licenses. 

Notes on PO use 
● Download to S7-PLCSIM and test CPU: 

No PO count is carried out here. 

● Deleting projects: 

The CFC is not notified when you delete a project. Therefore you cannot book back any 
POs either. 

● Deleting chart folders or superimposed objects: 

If you delete the chart folder, the S7 program, the CPU or the SIMATIC station, then this 
order to delete is passed on to the CFC. In this case a warning message appears that 
allows you to terminate the deletion process. 

● Defective CPU: 

A new CPU that replaces a defective CPU is recognized as the previous download 
destination if the data stored in the PO info corresponds with the serial number of the 
CPU or the memory card. It is assumed that the "correct" CPU is connected for older 
CPU versions that do not allow a serial number query. 

● CPU replacement in a high availability system: 

In a high availability system, if the memory cards used do not permit a query of the serial 
number and both CPUs are to be replaced, you should follow the procedure below.  

To avoid an incorrect booking of the PO of this high availability system, the CPUs may 
only be replaced one after the other. After the replacement of one CPU, the associated 
AS must be loaded again. Only then may the second CPU be replaced and loaded.  

Additional information pertaining to process objects (PO) is available in the section: PCS 7 
license information (Page 23)  



 What you should know about CFC 
 5.3 Drive for page file 

CFC for SIMATIC S7 (V8.0 SP4) 
Function Manual, 07/2013, A5E03710059-06 27 

5.3 Drive for page file 

Swap file on USB drive 
A page file containing the most available storage space is automatically set up on the drive 
by the CFC. If the drive is a USB drive, you must take the following into account: 

In order to prevent the storage medium performance from decreasing the performance of the 
computer during the swap activity, proceed as follows: 

1. Open the System Properties dialog box by selecting System > Hardware > Device 
Manager > USB Drive > Properties > Policies in the Windows Control Panel. 

2. Under “Write caching and safe removal”, select the “Optimize for performance” check box 
for the drive. 

3. Before removing the drive, click "Safely Remove Hardware" in the info area of the 
taskbar. 
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5.4 Reaction of S7 CPUs to error 

 
An S7 CPU will always continue to run in the event of number overflow/underflow or division 
by 0. 

Reaction to such states can be determined via the block algorithm, by means of evaluation 
of the status bit in the status word. 

You can find additional information in the LAD/STL/FBD online help, for example, help on 
STL, statement list, floating-point functions, master recipe operations. 

The response of library blocks is described in the corresponding "Troubleshooting" help 
topic. 
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5.5 Migration to the new CFC version 

5.5.1 Migration to other CFC versions 

Additional processing  
You can still process data created with CFC V3.x to CFC V7.x as follows in CFC V8.x:  

● You can read and display the CFC data from previous versions with CFC V8.x. 

● If you edit those data, the contents of each chart folder are converted after you have 
confirmed the first write access. This ensures compatibility. 

General notes on compatibility 
● A backwards conversion of V8.x data to previous versions is not possible.  

● You cannot use previous CFC versions to edit data created with a newer CFC version. 

5.5.2 Converting CFC library blocks to BOPs 

Introduction 
As of version V5.0, you can convert blocks previously stored in the CFC library to basic 
operations (BOPs).  
The new BOPs are shown in the list “Blocks as BOPs” below. 

You can achieve the following goals by using the basic operations:  

● You improve CPU runtime. 

● You require fewer DB numbers. 

Projects created with CFC versions < V5.0 (old projects) are not modified automatically when 
you convert them to V7.x, since this would effect changes in the S7 program on the CPU. 

 

 Note 

The "CFC Library" no longer contains the blocks now available as basic operations.  
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Migration 
If you want to migrate old projects without modifying your existing program, proceed as 
follows: 

1. Create a new S7 project program, including a chart folder and a CFC chart. 

2. Copy the symbol table to the new S7 program. 

3. Delete all blocks that are now shown as BOPs in the symbol table (you can find 
information about this in the “Blocks as BOPs” list below). 

4. Double-click the chart icon.  
The CFC chart opens. 

5. Use the menu command Options > Customize > Compile/Download… to open the 
“Settings for Compilation/Download” dialog box. 

6. Update the number ranges according to the previous ranges and click “OK”. 
The dialog box closes. 

7. Use the menu command Options > Customize > Copy/Move… to open the “Settings for 
Copying/Moving” dialog box. 

8. In “Connections to Addresses”, select the option “Include” and click “OK”. 
The dialog box closes. 

9. Close and delete the newly created CFC chart. 

10.Select all charts – not the chart folder! – of the old project and  
copy them to the new chart folder. 

11.If your project contains user-specific blocks whose DBs are in the area reserved for other 
applications, copy them to the block folder manually. 

12.Assign the old S7 program name to the new S7 program. 

13.Cut the new S7 program and  
 paste it to the old program of the CPU. 
The new S7 program replaces the old S7 program. 

14.Select the chart folder and then  
 select the menu command Edit > Compile to recompile the program. 

Result 
The project has been converted to the new BOPs. 

Exceptions 
If you follow these steps the project will remain unchanged. Exceptions: 

● Interconnections to runtime groups will be lost and must be redefined. 

● The DB number assignment changes. When necessary, the AS-OS connection data must 
be transferred again ("Compile OS"). 
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Blocks as BOPs 
The CFC contains the blocks below as BOPs: 

 
ABS_DI EPS_DI MIN2_DI MUX4_I ROR_W 
ABS_I EPS_I MIN2_I MUX8_BO RS_FF 
DI_DW I_DW MOD_DI MUX8_DI SHL_DW 
DI_I I_W MOD_I MUX8_I SHL_W 
DIV_DI JK_FF MUX2_BO NEG_DI SHR_DW 
DIV_I LIM_DI MUX2_DI NEG_I SHR_W 
DW_DI LIM_I MUX2_I ROL_DW SR_FF 
DW_R MAX2_DI MUX4_BO ROL_W W_BY 
DW_W MAX2_I MUX4_DI ROR_DW W_I 

5.5.3 Migration of old projects to the enhanced runtime model 

Introduction 
Projects created with older CFC versions (< V6.0) can be easily migrated to the enhanced 
runtime model, which is available with CFC version V6.0 and higher, in the course of a 
migration.  

 

 Note 

Migration is initiated after the user’s first write access and prompt confirmation. 
 

Procedure 
1. Runtime editor: Create a runtime group in a cyclic task for each chart in your project. 

2. Assign the runtime group the name of the corresponding chart. 

3. In the run sequence, move the blocks of each chart to the corresponding runtime group. 

4. CFC Editor: Set the local installation pointer for each chart (block installation pointer). Do 
so by selecting a block at which you want to append all further blocks and select the 
shortcut menu command Predecessor for Insertion Position. 

5. Runtime editor: Set the global installation pointer for the program (chart installation 
pointer). Do so by selecting a runtime group at which you want to append the runtime 
group of the next chart to be inserted. 
Background: The "old" installation pointer previously used to refer to the “predecessor for 
insertion position" was transferred to the chart installation pointer during migration. It may, 
therefore, point to a task or runtime group that is not intended for the insertion of 
additional runtime groups (charts). 
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5.5.4 Migration of control blocks to the external view 

 
Any SFC control block (SFC_CTRL) which exists in the project is deleted and replaced by 
the external view of the corresponding SFC chart when you migrate ES data from V5.x > 
V6.x or V7.x. The parameters and block interconnections of SFC_CTRL are activated in the 
external view.  

Runtime response is not altered. The control block will be deleted from the run sequence 
and the SFC chart takes over its function.  
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 Multiuser engineering 6 
6.1 Multiuser engineering 

Introduction 
Multiuser engineering of projects or multiprojects is basically possible. This setup allows you 
to configure, test and commission target systems from different remote locations or from a 
PC network (multiuser engineering). 

Basic options 
● PCs are networked 

The project resides on the server or on a released drive of the PC and several users are 
able to simultaneously configure specific parts of the project . 

Detailed information pertaining to multi-user engineering and to consequences is 
available at: "Configuring in the network (Page 35)"  

● PCs not connected to a network 
The project is split into several segments for distributed editing and is subsequently 
merged to form a master project, for example, via a diskette or a ZIP drive. 

● Projects in a multiproject 
The projects of a multiproject are stored on a central computer and can be split for 
distributed editing. The projects required for editing specific stations are transferred to the 
workstation of the respective author. Several projects can therefore be present on one 
workstation at the same time. 

After the project has been edited and returned to the multiproject, the system must 
synchronize all interproject data by means of the menu command File > Multiproject > 
Align Projects and perform all interproject functions required, for example, compile OS. 
Always execute this function when you prepare the multiproject for commissioning. 

● Branching and merging project data 
As of CFC V6.0 you can branch the charts of an S7 program to form multiple working 
projects. The new concept of the V6.0 runtime model supports the branching and 
merging of individual project charts as well as the structuring of the run sequence by 
chart. You can find additional information in: 

– Concept and use of installation pointers (Page 155)  

– Textual interconnections in branched and merged project data (Page 132)  
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Procedure for branching and merging project data 
1. Copy a plant-relevant part of the project (single chart, several charts) to another project. 

Result: Textual interconnections to sources not included in the scope of the copy have 
been generated in this copy. 

2. Edit the copied section separately (add, delete, change blocks and charts). 

3. Copy the edited plant-relevant part to the source project. 
Result: The system first deletes the charts with the same names from the original project. 
There are now textual interconnections in all charts that expect data from the deleted 
charts. The system then pastes the copies of the chart(s) into the project. 

4. Close all “open” interconnections via menu command Options > Make Textual 
Interconnections. 
Result: The interconnections are made again in charts that were edited in another project 
and copied back to the source project, as well as in the charts for which textual 
interconnections were generated due to the deletion. 
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6.2 Configuring in the network 

Configuring in the network 
The system supports simultaneous multi-user access on your Engineering Stations to 
defined elements of projects which are stored on a central server or on the network drive of a 
station. Multi-user access is always possible outside the CFC. Feasible scenarios in multi-
user mode:  

Editing various charts from different chart folders 
Different charts from different chart folders can be edited separately by several authors on 
different engineering workstations. Mutual interference should not be a problem. 

Editing various charts from the same chart folder 
Different charts from the same chart folder can be edited separately by several authors on 
different Engineering Stations There is less chance of mutual interference compared to 
working on the same chart. Conflicts cannot be entirely excluded because all charts access 
shared resources, such as the symbol table, run sequence etc. 

Working on the same chart 
Mutual interference may occur when several engineers work on the same chart. This work 
procedure is therefore not recommended. 

Reaction to a variety of actions 
If access conflicts develop, the system always executes the action assigned the highest 
priority class. The action with the lower priority is aborted in this case. Priority of the actions: 

 
Action Priority 
Short read actions 3 
Short write actions 2 
Prolonged read action 1 
Prolonged write action 1 

 

The first action started is executed if users initiate several actions which are assigned the 
same priority class. 
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● Short read actions (without resource usage) are: 

– Open chart 

– Open run sequence 

– Open dialog box 

When other short read actions are performed at the same time in addition, no adverse 
effect should be expected. 

Short or long write actions executed in parallel may lead to access conflicts, that is, the 
short read action is canceled. 

● Short write actions (without resource usage) are: 

– Instancing, parameter assignment, interconnection etc. 

– Closing dialog boxes with OK 

When a short or long write action is performed at the same time in addition, access 
conflict may occur for the action latest started.  

● Long read actions (with resource usage) are: 

– AS-OS data transfer (compile OS) 

– Displaying chart reference data 

When an access conflict does not occur immediately when a long read action is triggered, 
perhaps because a write action is already being performed, this action is performed 
without access conflict. Exception: see the notes relating to system behavior. 

● Long write actions (with resource usage) are: 

– Optimization of the run sequence 

– Compiling and downloading (AS and OS) 

– Type import and update / cleanup of block types 

– Updating shared declarations 

– Generating module drivers 

– Readback 

– Creating block icons 

– Creating diagnostic screens 

– Updating the PH in a multiproject 

– Import / Export functions of the IEA and of the process object view 

– Import / Export functions of the ES objects of Version Cross Manager 

When an access conflict does not occur immediately when a long write action is 
triggered, perhaps because a write action is already being performed, this action is 
performed without access conflict. Exception: see the notes relating to system behavior. 
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Notes on procedures 
● It is advisable to update the data at specific cyclic intervals (F5 function) if several authors 

are working on the same project. These updates ensure that all users work on an 
identical and consistent project database. 

● It is not advisable to have several authors running long read or write actions in parallel. 
The authors should preferably coordinate their action schedules. It is hardly feasible to 
tolerate a situation in which one author is editing an SFC type, while a second author is 
setting out to compile the program, for example. The authors are responsible for 
coordinating simultaneous actions and for assessing the feasibility of such actions. Only 
one author is allowed to carry out prolonged actions at any chart folder. It is therefore 
advisable only to start engineering which involves prolonged actions if the database is 
consistent. 

● Only one worker has access the data of an OS at any one time. The WinCC Explorer 
prevents access to the OS by more than one worker. 

Notes relating to system behavior 
● Any action which could not be completed because other applications outside the CFC are 

already accessing the resources will be canceled. This access may be initiated by STEP 
7 applications such as the SCL / Block or Symbol Editor. The content of messages may 
differ depending on the triggering application. However, their significance is always the 
same: The action must be restarted after the other active application was completed or 
canceled. 

Example: You initiated a compiling session which is by now active over a longer period of 
time and the compiler wants to access the symbol table. If this symbol table is already in 
use by a different author, the compiler cancels the operation and generates a message 
informing you that you have to close the other application before you restart the action. 

● If one user is editing data in offline mode while other users have activated the test mode, 
a message is output to these other users the next time they activate test mode to request 
recompilation and download of the chart to the CPU. The author is now responsible for 
deciding whether or not to activate the test mode. This may make more or less sense 
depending on the offline changes; authors should come to agreement in this regard. 

● After receiving a message that the data is being used by another application, when a 
value is logged in or out for monitoring in test mode, it is not stored in the session 
memory. The login or logout must be repeated the next time test mode starts. 

● When values monitored in test mode are no longer updated due to offline changes 
(because a block has been deleted, for example), the "#" character appears with a red 
background at the corresponding I/Os instead of the value. 

● Any compilation initiated by an author while another author is editing parameters in test 
mode will be rejected with a message stating that the data is currently in use by a 
different application. 
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 Starting and operating the CFC editor 7 
7.1 Starting and closing the CFC editor 

Starting CFC from the SIMATIC Manager 
Proceed as follows to start the CFC editor:  

Double-click the icon of the CFC chart you want to open. 
The CFC editor starts and opens the chart. 

Starting CFC from the Windows Desktop 
Double-click the icon for the CFC editor (if available) 

or 

Select the program entry from the Start menu: SIMATIC > STEP 7 > CFC. 
 

 Note 

A separate file save function is not available, since the CFC editor saves all file changes 
immediately. Note that you cannot undo or cancel changes in the CFC editor by closing the 
editor without saving. 

You should always back up all data by copying the entire program to a backup project, You 
can then revert to old versions at any time. This also allows you to archive your complete 
configuration. 

 

Closing CFC 
Proceed as follows to close the CFC editor:  

In CFC, select the menu command Chart > Exit. 
The CFC Editor closes. 
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7.2 Operator controls and structure of the CFC editor 

7.2.1 Working window 

 
The editor lets you open any number of windows within the limits of Windows. Each chart 
window displays a CFC chart.  

You can open multiple windows for the same chart, for example, to create well-arranged 
interconnections across sheet boundaries. You can open a clear view of the same chart in 
two windows by selecting Window > New Window > Window > Arrange > Horizontally or 
Vertically. The menu command Arrange > Cascade is unsuitable for this particular 
application. 

The window in the foreground is always the active working window. This means that the 
menu commands and toolbar buttons have an effect on this window. Exception: Functions 
for opening and closing windows, for example.  

The title bar in online mode is displayed in a different color (default setting: cyan). You can 
customize the default settings for the background and text in the SIMATIC Manager with the 
menu command Options > Customize > "View" tab. 

CFC allows you to simultaneously display the chart window and the following windows: 

● "Dynamic display" 

● "Trend display" 

● "Chart Inputs/Outputs" (interface editor) 

● "Run sequence" (runtime editor) 

7.2.2 Catalog of blocks, charts, templates and libraries 

Opening and closing the catalog 
You can insert blocks and charts selected from the catalog into your CFC chart.                  

There are several ways of opening and closing the catalog: 

● Click the button in the toolbar 

 
or 

● Select the menu command View > Catalog. 

or 

● Use the <Ctrl+K >key shortcut. 
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There are several ways of opening the catalog: 

● Select the menu command Insert > Block/Chart (from Catalog) 

or 

● In the shortcut menu, select the command Catalog 

or 

● Use the <F2> key. 

Positioning the catalog 
You can drag-and-drop the catalog at its edge to any screen position. It is then shown as a 
separate window with a title bar.  

If you move the catalog close enough to the right or left edge of the CFC window or double-
click its title bar, it is docked accordingly and shares the workspace. When it is docked, you 
can also double-click the catalog's edge to open the catalog as a separate window and move 
it to any position. 

Go to the catalog window 
Within the catalog, you can navigate to the following catalogs: 

 

 
Block catalog 

 
Chart catalog 

 
Template catalog 

 
Library catalog 

 
If the project contains unplaced blocks, the catalog of unplaced blocks is also shown. This 
catalog is not available as by default. 

Object search 
Information on the search is available in the paragraph below "Options available in the lower 
part of the window".  

Catalog of block types 
You can select a block from the "All blocks" folder of a block family folder or from the S7 
program folder and drag it to your chart. You can also select a block / new text / new chart 
and insert it in a free space in the chart using the <Return> key.  

Blocks from the S7 program  are automatically imported to CFC when you insert them in 
the chart and also appear in a family of CFC blocks. The block icon indicates whether or not 
the block is already known to CFC, in other words, has been imported.  
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Blocks that were not imported look like this:  

Blocks in the S7 program are still unknown in CFC, even if a block of this type has already 
been imported. When you insert a block from the S7 program into the chart, the block is 
always checked first to determine if it has already been imported.  

You can find imported blocks in one of the block families . A block that is not assigned to 
a family (indicated in the header) is found in the "Other blocks" folder. These blocks appear 
as .  

In the  "All blocks" folder, you can find all blocks of all block families (including "Other 
blocks"), sorted in alphabetical order. All imported blocks are therefore displayed twice, but 
in a different sorting order. 

 

 Note 

Inserting blocks from the block families or from "All blocks" is the fastest way of inserting 
blocks in your chart, because no previous check is performed. You should therefore always 
use the imported blocks of the corresponding family. 

 

You can also insert an empty text box into your chart using the  "New Text" icon located 
above the block families, for example, when you want to enter a comment or notes on the 
configuration either via drag-and-drop or by selecting and applying with <Return>). 

With the  "New chart" icon displayed above the block families, you can insert a nested 
chart using drag-and-drop or selecting it using the <Return > key.  

To open help on a block and the "New Text" or "New Chart" function, select the object and 
press the <F1> key to display the help topic. 
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Chart catalog 
The chart layout in the catalog window can differ, depending on the settings made on the 
"Catalog" tab of the "Customize Layout" dialog box. You reach the area for these settings 
with the menu command Options > Customize > Layout. 

● When the "Select active chart" check box is selected, the chart symbol  of the active 
chart is displayed as an open folder . The corresponding hierarchy branch is also 
opened if the active chart is nested. If the chart is not shown in the visible area of the 
catalog window after it is activated, the window is scrolled until the selected chart 
appears. When you close the hierarchy branch or move the visible area of the window, 
the selected chart is longer visible unless you activate it again, for example, by toggling 
the chart once. 

● When the "Show with plant hierarchy" check box is selected in this dialog box, the charts 
are displayed with their plant hierarchy, in other words, with the hierarchy folders, 
provided the charts exist in a plant hierarchy. 

 
  Note 

The catalog shows no entry if the "Show with plant hierarchy" check box is selected, 
although there is no plant hierarchy. 

 

● If a plant hierarchy does not exist and the "Show catalog with plant hierarchy" check box 
is not selected, the charts are displayed in alphabetical order (as a tree). 

● The + character in the box indicates charts that contain nested charts. Click this box to 
expand this tree level and displays the hierarchy of the chart. 

Note:  

The base chart is the chart displayed in the SIMATIC Manager . The nested charts 
contains within it are not displayed in the SIMATIC Manager . 

You can select and drag-and-drop a CFC chart to your chart. The layout of the inserted chart 
is similar to that of a block. When this involves a chart with chart I/Os, the I/Os are also 
displayed. The representation of the chart also differs from that of a block by its chart icon: 

 
When you insert the chart, it is copied to the chart folder along with any nested charts. 

You can also hold down the shift key and drag-and-drop top charts to the chart. In this case, 
they are not copied but moved. The chart is now no longer at the previous location in the 
catalog. It is displayed in the hierarchy of the current chart.  

You can also open charts directly in the catalog window. Select the required chart and then 
select the shortcut menu command Open Chart.  
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Template catalog 
The base data library, lower-level PH folders and control module types are displayed 
hierarchically in the catalog. 

You can move the control module types with drag-and-drop into the editor for technological 
connections. 

Library catalog 

Available block libraries are displayed in the catalog window by the icon . They represent 
a collection of additional block libraries, shown as block folders . The block types they 
contain are displayed as . 

Click the plus box to open the libraries, select a block and drag-and-drop it into the chart. 
The block is automatically copied to the active S7 program and imported into CFC. It then 
also appears in the block catalog in a family of CFC blocks and in "All blocks". 

The blocks are shown twice in the catalog but with different sorting: 

● According to family (for example, FMT_PID in  CONTROL) 

and 

● In alphabetical order in the "All blocks" folder  

The blocks are displayed with: 

● Block name (for example, CTRL_PID) 

● Block number (for example, FB 61) 

● Block comment (for example, PID Control) 

● Icon comment (if available) 

If you require help on a block, you can select it and then display the associated help topic 
with the <F1> key. 

Unplaced blocks catalog 
 

 Note 

This catalog is only available if unplaced blocks actually exist. 
 

Here you can select unplaced blocks and reinsert them in your CFC chart.  

Unplaced blocks are arranged in the CFC charts in which they were originally placed. You 
can select a block and drag-and-drop it to the chart. 
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Options available in the lower part of the window 
● Find 

In the catalog of blocks or libraries, you can enter a text and start the search by clicking 
the following button: 

 
The search starts at the object selected in the active catalog window. The search is 
performed through all folders until the specified object is found or until the search cycle 
reaches the selected object again.  

In the catalog of charts, you can perform a search for a chart, for example, for a nested 
chart. If the search result is positive, the function expands the tree level and highlights the 
selected chart.  

You will find detailed information on this topic in the section "Searching for objects in the 
catalog (Page 322)". 

● Closing a folder 

If you want to close all folders, click the following button:  

 
  

7.2.3 Menu bar 

 
The menu bar is located at the extreme upper edge of the application window. Its functions 
affect the active working window. You can only select menu commands that have a feasible 
function in the current situation. For example, you can only select the menu command Edit > 
Delete when at least one object which can be deleted is selected, for example, a block, 
nested chart, connection line, or I/O.  
Disabled menu commands are grayed out. 

The bar displays only menu commands relevant for the selected target system. 

7.2.4 Toolbar 

 
The toolbar is located below the menu bar. It contains a series of icons that start frequently 
required menu bar functions, including a drop-down list for the selection of sheets/overview. 
You can see what function the button is associated with by positioning the cursor over the 
icon, but not clicking. A small box appears on the screen, displaying the designation (tooltip) 
of the function. More detailed information on the function is displayed in the status bar.  
A click the button triggers the function. Disabled buttons are grayed out. 
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7.2.5 Status Bar 

 
The status bar is located at the bottom edge of the CFC window. It displays important 
information and the editor status. Its content changes according to operator input and editor 
status. 

The left side of the status bar displays context-sensitive information, for example, 
descriptions of menu commands, prompts or error messages. 

The right section of the status bar contains three fields: 

● The right (larger) field shows the current mode (edit mode or test mode) and additional 
information: 

– In edit mode: 
Task, chart name and the predecessor for the insertion of blocks into the run 
sequence 
If the text "(Start)" is appended to the name of the runtime group, the insertion position 
lies at the beginning of the group, in other words, above the existing blocks, for 
example, OB 35 Group1 (Start). 

– In test mode: 
Test: Status of the CPU, breakpoint status, cause of stop 
The CPU status is also indicated by the background color:  
Light green = RUN 
Red = STOP 

● The middle, smaller field shows the following chart information: 

– In the overview:  
Identifier of the chart partition (A – Z) and "Overview" 

– In the sheet view:  
Identifier of the chart partition (A – Z) and current sheet number (Sheet 1 -6), 
supplemented by the overflow page number 

● If the SIMATIC Logon Service is installed and a user is logged on, the left field displays 
the user name. 

You can hide or show the status bar via the "View" menu. 

7.2.6 Shortcut menu 

 
A right-click opens a shortcut menu that contains frequently used menu bar functions. You 
can only select functions useful for the current application. All others are grayed out. You can 
access various shortcut menus, depending on the position of the cursor or selected object.  
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Examples of locations where different menus are called: 

● Free area 

● Block/nested chart 

● Text field (when not in editing mode) 

● I/O 

● The chart partition tab 

● Sheet bar entry (small field) 

● Dialog boxes 

● Windows of the run sequence, chart inputs/outputs and catalog 
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7.3 Keyboard and mouse operation 

7.3.1 Shortcut keys for menu commands 

Introduction 
You can select any menu command via a corresponding shortcut using the <Alt> key. 

Shortcut keys 
Press the following keys in the order shown: 

● <Alt> 

● The underscored letter in the name of the required menu (for example, <Alt>+<C> for the 
"Chart" menu - if the "Chart" menu is included in the menu bar). The menu opens. 

● The underscored letter in the name of the required menu command (for example, <N> for 
the menu command "New"). 
A submenu of this menu command will also be opened. Repeat the actions described 
above until you have selected the menu command required. 

The menu command is executed after you have entered the last letter of the shortcut key. 

 

Examples 
 
Function Shortcut key 
Chart > New <Alt>, <C>, <N> 
Edit > Go To, Sheet <Alt>, <E>, <G>, <S> 
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7.3.2 Shortcut keys in the CFC chart 

Overview 
You can navigate in the CFC chart using the following keys:  

● Chart window 

 
Shortcut key Function 
<Tab> A single block is selected: Moves the cursor to the next block  

(sequence defined internally, the user cannot intervene). 
Multiple blocks are selected: The selection is canceled and the cursor 
moves to the next block in the internal sequence. 
In the overview, the cursor moves to the next page. In the sheet view, the 
cursor moves only within the sheet; first to normally positioned and then to 
overlapping blocks. 

<Shift+Tab> Same as <Tab>, but reversed sequence. 
<Arrow up> An input/output is selected: 

Moves the cursor to the next higher input/output (if it exists; otherwise, the 
block will be selected). 

<Arrow down> A block is selected: 
Selects the first input (or first output, if only outputs exist). 
Input/output selected: 
Moves the cursor to the next lower input/output (if it exists). 

<Right arrow> An input is selected: 
Moves the cursor to the opposing output (if it exists; otherwise,  
to the last output). 

<Left arrow> An output is selected: 
Moves the cursor to the opposing input (if it exists, otherwise  
to the last output). 

<Ctrl+Arrow up> In the sheet view: Move to the next page up (e.g., 2 -> 1). 
<Ctrl+Arrow down> In the sheet view: Move to the next page down (e.g., 2 -> 3). 
<Ctrl+Right arrow> In the sheet view: Move to the next page on the right (e.g., 2 -> 5). 
<Ctrl+Left arrow> In the sheet view: Move to the next page on the left (e.g., 5 -> 2). 
<Ctrl+Page Up> Move to the previous chart partition, if one exists (e.g., B -> A). 
<Ctrl+Page Down> Move to the next chart partition, if one exists (e.g., B -> C). 
<Ctrl+K> Opens and closes the catalog. 
<Ctrl+F6/Ctrl+Tab> Switches between open windows. 
<Alt+Page Up> Shifts the visible part of the chart to the left. 
<Alt+Page Down> Shifts the visible part of the chart to the right. 
<F6> Toggles keyboard from the active chart to the catalog. 
<Shift+F10> Opens a shortcut menu for the selected object.  

Opens the shortcut menu for the empty space if multiple objects or no object 
is selected. 

<Esc> Cancels all existing selections in the chart  
(also multiple selections and the flashing function) 
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● Interconnections 

 
Shortcut key Function 
<Ctrl+X> Input: Copies the interconnection to the clipboard and deletes it at this input when 

you paste it to another selected input with <Ctrl+V>. 
<Ctrl+C> Input: Copies the interconnection to the clipboard 
<Ctrl+C> Output: Copies the output to the clipboard as a potential interconnection source 
<Ctrl+C> Sheet bar entry: Copies the interconnection to the clipboard 
<Ctrl+V> Input: If you have previously used <Ctrl+C> on an input/sheet bar entry or <Ctrl+X> 

on an input, the interconnection will be pasted from the clipboard to the selected 
input. 

<Ctrl+V> Input: If you have previously used <Ctrl+C> on an output, the input will be 
interconnected with this output. 

  

● Catalog window: 

 
Shortcut key Function 
<Ctrl+Page Up> Switches catalog views, from right to left. 
<Ctrl+Page Down> Switches catalog views, from left to right. 
<Return> 
 

• In the "Blocks" window: Inserts the selected type into the active  
chart (new text, new chart or block instance) 

• In the "Charts" window: Opens the selected chart. 
• In the "Libraries" window: Imports the selected block and  

places the block instance in the active chart 
• In the "Unplaced Blocks" window: Places the selected  

block in the active chart 
• In the search box: Triggers the search. 

<F6> Toggles keyboard from the catalog to the active chart. 
<Tab> Switches between operating elements, from top to bottom or left to right  

(catalog views, search box, buttons) 
<Shift+Tab> Same as <Tab>, but in reversed direction. 
<Arrow up> 
<Arrow down> 

Moves from the selected to the next object  
in up or down direction 

<Arrow right> 
 
<Arrow left> 

Expands the hierarchy of the selected object and selects the first object  
at this level  
or moves one level up in the expanded hierarchy 

<Page Up> 
<Page Down> 

Selects the object at the upper or  
lower edge of the window.  
When actuated again, it shifts the visible area accordingly  
(if the full content was not visible) 
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● Runtime editor window: 

 
Shortcut key Function 
<Tab> Moves between the hierarchy window (left pane) and the detail window (right 

pane). 
<Arrow up> 
<Arrow down> 

Moves from the selected to the next object  
in up or down direction 

<Arrow right> 
 
<Arrow left> 

Expands the hierarchy of the selected object and selects the first object at this level  
or moves one level up in the expanded hierarchy 

<Page Up> 
<Page Down> 

Selects the object at the upper or 
lower edge of the window.  
When actuated again, it shifts the visible area accordingly (if the full content was 
not visible) 

  

7.3.3 Cursor movement in the text editor 

Keys for moving the text cursor 
You move the text cursor within the text using the following keys: 

 
Shortcut key Function 
<Arrow up> One line up or one character to the left in a text consisting of only one line 
<Arrow down> One line down or one character to the right in a text consisting of only one 

line 
<Right arrow> One character to the right 
<Left arrow> One character to the left 
<Ctrl+Right arrow> One word to the right 
<Ctrl+Left arrow> One word to the left 
<Pos1> To the beginning of the line 
<End> To the end of the line 
<Page Up> To the previous page 
<Page Down> To the next page 
<Ctrl+Home> To the beginning of the text 
<Ctrl+End> To the end of the text 

Additional information 
You can find additional information in the section: International/German keyboard (Page 56) 
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7.3.4 Cursor movement in the menu bar/shortcut menu 

Keys for moving the mouse pointer 
You move the cursor in the menu bars or the shortcut menu using the following keys: 

 
Shortcut key Function 
<F10> Move to the menu bar 
<Shift+F10> Open the shortcut menu 
<Alt+X> Select the menu containing the  

underscored character X 
Underscored character in the 
menu command 

Select a menu command 

<Left arrow> Moves one menu command to the left 
<Right arrow> Moves one menu command to the right 
<Arrow up> Moves one menu command up 
<Arrow down> Moves one menu command down 
<Return> Execute the selected menu command 
<Esc> Exit the menu or return to text 

Additional information 
You can find additional information in the section: International/German keyboard (Page 56) 

7.3.5 Cursor movement in dialog boxes 

Keys for moving the mouse pointer 
You move the cursor in dialog boxes using the following keys: 

 
Shortcut key Function 
<Tab> Move to the next edit box (left to right and top to bottom) 
<Shift+Tab> Move one edit box back 
<Alt+X> Move to edit box that contains the underscored character X 
Arrow keys Move the cursor in a selection list 
<Alt+Arrow down> Open a selection list 
<Spacebar> Select an object or cancel this selection 
<Return> Confirms your entries and exits the dialog box (corresponds to the "OK" 

button). 
<Esc> Exits the dialog box without saving changes (corresponds to the "Cancel" 

button). 
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Additional information 
You can find additional information in the section: International/German keyboard (Page 56) 

7.3.6 Selecting text via shortcut keys 

Key commands 
You select text using the following keys: 

 
Shortcut key Function  
<Shift+Right arrow> One character to the right 
<Shift+Left arrow> One character to the left 
<Ctrl+Shift+Right arrow> One word to the right 
<Ctrl+Shift+Left arrow> One word to the left 
<Shift+Home> Text to beginning of line 
<Shift+End> Text to end of line 
<Shift+Arrow up> One line up 
<Shift+Arrow down> One line down 
<Shift+Page Up> To the previous page 
<Shift+Page Down> To the next page 
<Ctrl+Shift+Home> To the beginning of a file 
<Ctrl+Shift+End> To the end of a file 

Additional information 
For more information, refer to the section: International/German keyboard (Page 56) 

7.3.7 Accessing help via shortcut keys 

 
You call Help using the following keys: 

 
Shortcut key Function 
<F1> Opens help. 

If there is a current context, for example, a selected menu command, the 
relevant help topic will be opened. Otherwise the table of contents will be 
displayed. 

<Alt+F4> Closes the Help window and return you  
to the CFC editor 
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7.3.8 Shortcut keys for programming 

Introduction 
The next section lists the shortcut keys experienced users can deploy instead of the menu 
commands in order to accelerate access to specific functions. 

Moving between chart sheets in the sheet view 
Press <Ctrl> and <Left arrow>, <Arrow up>, <Right arrow>, <Arrow down> to browse the 
sheets if you are in the sheet view. The sheet is selected according to the arrow direction. If 
there is no sheet in this direction of the arrow the shortcut key has no effect. 

Moving between the chart view and sheet view 
Proceed as follows to toggle the views: 

● In the sheet view:  
To change to the overview, double-click a free point on the sheet, in other words, not on a 
block, block I/O, interconnection, or the sheet bar. 

● In the overview:  
To change to the sheet view, double-click a free point on the sheet, in other words, not on 
a block, block I/O, interconnection or the sheet bar. Displays the position at the middle of 
the sheet you have selected by double-clicking. 

Interconnecting multiple block inputs to one block output 
Proceed as follows to create the interconnection: 

● Select the block output. 

● Press the <Shift> key and select the block input.  
The interconnection is established and the block output remains selected. 

● Press the <Shift> key and select the next block input. 

● Select the last block input to be interconnected without pressing the <Shift> key. 

Selecting a group of blocks 
Proceed as follows to select a group of blocks: 

● Hold down the <Ctrl> key and click any block required. Repeat this action until you have 
selected all blocks required. You can cancel a selection by clicking a selected block 
again, while holding down the <Ctrl> key. 

● To select multiple blocks arranged in the same area, position the cursor at a point outside 
of the blocks, hold down the left mouse button, draw a lasso around the blocks and then 
release the mouse button. When you release the button, all the blocks within the lasso 
are selected. 
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Editing the object properties of a group of blocks 
To edit the object properties, proceed as follows: 

● Select the blocks you want to edit either by using the <Ctrl> key and clicking or by using 
the lasso function. 

● Select the menu command Edit > Object Properties....  
The SIMATIC Manager's "Open" dialog box appears. 

● Make your required entries in the dialog box. 

● Click "OK".  
You exit this dialog box and the dialog box for editing the next block opens. 

● You can click "Cancel" to exit the dialog box without saving changes. This closes the 
dialog box. The set object properties are not applied. 

7.3.9 Mouse operation 

Overview 
The mouse offers the following functions:   

 
 Single click Double-click <Ctrl> + 

click 
Click +  
drag-and-drop 

Block header  
(also applies to the 
header 
nested chart) 

Select object;  
all other objects  
deselected 

Open “Properties – Block” or 
“Properties – Chart” dialog box 

Selection 
block/ 
nested chart 

Move 
block/ nested 
chart 

Block body Select block;  
all other objects  
deselected 

- Selection 
block 

Move 
block 

Runtime properties 
box in the block header 

Select block; 
all other objects  
deselected 

Open “Run Sequence” window Selection 
block 

Move 
block 

Input, output Select 
input/output 

Open “Properties – Input/Output” 
dialog box (or, with STRUCT, 
“Select Structure Element” dialog 
box) 

Selection 
block/ 
nested chart 

Moving 
interconnections 
(rewiring) 

Nested 
chart body 

Select object;  
all other objects  
deselected 

Open nested chart Selection 
nested chart 

Move nested 
chart 

Connector  Signal tracking -  Track 
signal 

Draw 
lasso 

Connection line Signal tracking Switch to sheet view or overview Track 
signal 

Draw 
lasso 
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 Single click Double-click <Ctrl> + 
click 

Click +  
drag-and-drop 

Sheet bar entry  
(small field) 

Field selected Jump from a sheet bar with signal 
tracking;  
with addresses, open “Modify 
Interconnection to Address” dialog 
box 

Track 
signal  

Draw 
lasso 

Sheet bar entry  
(large field) 

Signal tracking As for small field Track 
signal 

Draw 
lasso 

Free area on the sheet Cancel 
selection  

Switch to sheet view or overview - Draw 
lasso 

Free area of the  
sheet bar 

 -  - -  - 

  
 

 Note 

Note that you can also right-click for the corresponding shortcut menu commands, for 
example, “Jump from Sheet Bar” or “Go to I/O Module”, for the elements described above. 
You can find additional information about this in the section: Shortcut menu (Page 46) 

 

  

7.3.10 International/German keyboard 

Table 7- 1  

International keyboard German keyboard 
<Pos1> <Pos1> 
<End> <End> 
<PAGE UP> <Page up> 
<PAGE DOWN> <Page down> 
<Ctrl> <Ctrl> 
<Enter>/<Return> <Enter> 
<Del> <Del> 
<Insert> <Ins> 
<BACKSPACE> <Back> 
<Up> 
<Down> 
<Left> 
<Right> 

<Up arrow> 
<Down arrow> 
<Left arrow> 
<Right arrow> 
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 Layout of configuration data 8 
8.1 Charts 

 
The chart represents the basic working unit of the CFC editor. Each chart has a name that is 
unique within a CPU. Each chart consists of up to 26 chart partitions (Page 58) each with 6 
sheets (Page 59). 

You can create charts either in the SIMATIC Manager or directly in the CFC editor. 

You can insert additional charts into a chart. This can result in a nested chart with a nesting 
depth of up to eight charts. You can insert existing charts from the chart catalog or new 
charts from the block catalog using drag-and-drop or with the menu command Insert > New 
Chart. 
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8.2 Chart partitions 

 
You can change the size of a CFC chart. You can increase the size of the chart by adding a 
maximum of 26 chart partitions (A to Z). You can decide whether to insert the new chart 
partition at the start or at the end of the current chart partition. Each chart partition consists 
of 6 sheets (Page 59).  

At the bottom edge of the window you can select the chart partition you want to edit via the 
tab in the scroll bar. The status bar displays the letter of the currently active chart partition, 
including the sheet number, for example, "A/Sheet 2". 
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8.3 Sheets 
Each  chart  (Page 57) (partition) consists of 6 sheets. In the CFC editor they are arranged in 
2 columns, each containing 3 sheets. A sheet consists of a central work area and sheet bars 
with the sheet and chart references. In the work area, you can position and interconnect 
blocks.       

Each sheet contains an internal grid pattern. Blocks can be moved in the sheet by distances 
determined by the grid pattern. This grid pattern determines the smallest possible distance 
between two connection lines. 

The toolbar contains a drop-down list  from where you can select the sheet you want 
to edit. The status bar displays the current sheet number as follows: it includes the identifier 
(letters) of the chart partition, separated by a slash, for example, “A/Sheet 2”. 

You can find additional information in the section: Display of interconnections in sheet bars 
(Page 68)  
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8.4 Overflow pages 

 
If so many interconnections between sheets are generated that there is insufficient space in 
the sheet bar for all the entries, an overflow page is created automatically. The overflow 
page represents an extension of the sheet bars and contains no additional objects. 



 Layout of configuration data 
 8.5 Nested charts 

CFC for SIMATIC S7 (V8.0 SP4) 
Function Manual, 07/2013, A5E03710059-06 61 

8.5 Nested charts 

 
A CFC chart can be inserted into another CFC chart (chart-in-chart technique). This allows 
the creation of hierarchy structures. Each nested chart can be opened and modified 
individually, the same as any other chart. The objects are placed on the work areas of the 
sheets. 

A chart can be encapsulated for further use, in other words, it is assigned chart I/Os. You 
can individually determine which block I/Os are made available to the chart I/Os. 

Nested charts are displayed in the chart as graphic objects, similar to blocks. The chart 
symbol is displayed in the chart header. Also included are the chart name and comments (if 
any comments exist). 

 
You can also generate nested charts without chart I/Os. In this case, only the header and the 
empty body are displayed. 
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8.6 Blocks 

Display in a chart 
Blocks are displayed in the chart as graphic objects. The objects are placed on the work 
areas of the sheets. Each block occupies a specific area. Blocks positioned so that they 
partly or fully overlap other objects or the sheet bar are displayed in their normal size, but 
without block I/Os and in light gray.      

Blocks can also be positioned across the horizontal line dividing two sheets. In this case, 
immediately below the dividing line, an additional block header is inserted that represents a 
copy of the first header. This allows blocks to be positioned that would not otherwise fit on 
one sheet. 

The blocks are displayed in the chart with block I/Os that are identified at the block type by 
the S7_visible: = true attribute. In the object properties dialog of the block you can specify 
whether to show or hide the block I/Os.  
Restriction: Due to space requirements, the chart can display no more than 160 inputs and 
160 outputs of a block. 

If the limit of 160 is exceeded, all other I/Os are hidden automatically. You can hide 
individual I/Os in the object properties of the block or the I/O.  

If you hide an interconnected I/O, the CFC responds as follows: 

● For interconnections within a sheet, the interconnection of the connection partner is laid 
to the sheet bar. The text “INVISIBLE” is entered after the I/O name. 

● For interconnections that go across sheets, the sheet bar entry is labeled with the text 
“INVISIBLE” following the I/O name. 

● For textual interconnections and interconnections with shared addresses, to runtime 
groups and to the interface (chart I/Os), no sheet bar entry is generated. These 
interconnections can only be recognized in the object properties of the block 
(“Interconnection” column of the “I/O” tab). 

● A colored triangle appears in the top right corner of the block header. 

Block layout 
The blocks are displayed in the chart graphically as “large blocks” and “small blocks”.  

The graphic layout of a large block features the following: 

● Header: 

– Block name, block type and comment 

– Field for runtime properties with highlighting of blocks that do not execute.  
You will find detailed information on this topic in the section: Display of the runtime 
properties box (Page 312) 

– If an interconnected, hidden I/O exists, a colored triangle is displayed in the top right 
corner. 
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● Body: 

– “Inputs” and “outputs”.  
The I/Os are displayed as selectable fields that contain only the I/O name (narrow 
layout) or the I/O name and the data type (wide layout). 

– Free area 

● The I/Os: 

– Outside the body, each interconnectable input or output has an I/O pin. Exception: 
Inputs that cannot be interconnected because they have been assigned the 
"S7_link := false" attribute can be identified by the missing I/O pin.  
Not interconnectable in this context refers to an input you can neither interconnect to 
the I/O of a block or nested chart, nor to shared addresses. It is possible, however, to 
interconnect this I/O to its internal chart I/O, provided the CFC chart contains chart 
I/Os. 

You can set the width of large blocks using the menu command Options > Customize > 
Block/Sheet Bar Width. The settings apply to the chart folder that contains the active chart.  
The settings are saved to the registry (CurrentUser) as a default that you can then use to 
create new chart folders. Each user can therefore define an individual logon setting. 

The graphic layout of a small block is similar to that of a block header of the large block, the 
difference being that it includes the I/O.  

The small block is displayed without boxes or I/O names for the I/Os and without a free area 
in the body. The I/Os are only represented by the I/O pin. The block width cannot be 
changed. 
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8.7 Texts 

 
Use the text box to enter a chart comment. You can position a text box in the chart just like 
blocks.  

Drag-and-drop the text box  "New Text" from the block catalog to the chart or insert it 
using the menu command Insert > New Text at a free location in the chart. You then open 
the selected text box by clicking on it. The text cursor is active and you can begin editing 
immediately. A line break is added automatically at the right edge of the box. If you enter 
more text than can be displayed in the box, the size of the box is not increased 
automatically; instead the text moves out of the visible area. You can make the entire text 
visible by increasing the size of the box manually. 

To change the size of a box, click the box handles and drag with the mouse until the required 
size is reached. If you change the width of the box, the length of the text lines is 
automatically adapted.  

When you open a text box, the text cursor is positioned where you clicked. 
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8.8 Interconnections 

 
An interconnection is the connection between the following elements: 

● A block/chart output to one or more inputs of another or the same block/chart or to the 
input of a chart I/O. 
The data types of the input and output must be compatible. 
Interconnected blocks or charts can be located in the same sheet, different sheets of the 
same chart or in different charts on the same CPU. 

● A block output to a runtime group 

● A block I/O to a chart I/O within one chart 

● A block output to objects outside the CFC data management, for example, to shared 
addresses. 

Another interconnection option is the textual interconnection. This represents a path 
reference to an interconnection partner that does not exist in the current chart folder.  
You will find more information about this in section: Working with textual interconnections 
(Page 128) 

 

 Note 

Each interconnectable input or output of a block is displayed with an I/O pin in the chart. 
Inputs that cannot be interconnected because they have been assigned the "S7_link := false" 
attribute can be identified by the missing I/O pin.  
Not interconnectable in this context refers to an input you can neither interconnect to the I/O 
of a block or nested chart, nor to shared addresses. Textual interconnections are also 
impossible.  
It is possible, however, to interconnect this I/O to its internal chart I/O, provided the CFC 
chart contains chart I/Os. 
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8.9 Layout of interconnections 

Block/chart interconnections 
Layout of block/chart interconnections: 

When the blocks and/or charts to be interconnected are located in the same sheet, a 
connection line will be drawn. Reference entries will be generated automatically in the sheet 
bar if the objects are not located in the same sheet. Those references contain the identifier of 
the corresponding target I/O. 

Branches will be generated for a block/chart output that is interconnected to more than one 
input. A branch is indicated by a dot. 

On some target systems the interconnected binary inputs may have been inverted. This 
inversion is indicated by a dot. 

 

 Note 
• Interconnections to a hidden I/O are laid to the sheet bar. 
• A block with a hidden interconnection is indicated by a colored triangle in the top right 

corner of the block header. 
 

Interconnections to shared addresses, runtime groups, chart I/Os, and textual interconnections 
Sheet bar entries will be generated for interconnections to shared addresses, runtime groups 
or chart I/Os and for textual interconnections.  

 

 Note 

If the interconnection begins at an I/O that has been subsequently hidden, there is no sheet 
bar entry. The interconnection can then only be made in the object properties of the 
block/chart, “Interconnection” column of the “I/O” tab. 

 

Connectors 
If no additional line can be drawn due to lack of sheet space, CFC will insert a connector at 
the block/chart I/O and enter a number in the sheet bar. The corresponding connectors will 
be assigned the same reference number. Multiple output interconnections that cannot be 
displayed will be assigned the same reference number. The differences in the layout of the 
connectors indicates the position of the I/O point: 

 
 Rectangle with point, white inner area I/O point in the sheet 

 Rectangle filled with the  
color of the connection line 

I/O point in the overflow page 

 Rectangle with point, filled with  
the color of the connection line 

I/O point in the sheet and in the overflow page 
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If so many interconnections between sheets are generated that there is insufficient space in 
the sheet bar for all the entries, an overflow page is created automatically. The overflow 
page represents an extension of the sheet bars and contains no additional objects. 

If an output contains multiple interconnections, some of the interconnections may only be 
displayed as a line. In such an event, a connector is attached to the line.  

Using this connector technique, you can always display the full CFC structure, regardless of 
its complexity. 

Interconnection colors: 
The CFC editor displays interconnections, block/chart I/O points to inputs and outputs as 
well as the sheet bar entries in color. The default color varies according to the data type or 
group of data types. This feature enhances the chart layout and makes it easier to configure 
connections. 

You can customize the colors of the various objects using the menu command Options > 
Customize > Colors.... 
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8.10 Display of interconnections in sheet bars 

Layout 
There is a sheet bar at the right and left margin of each sheet. The entries they contain are 
displayed in the sheet view. 

The large sheet bar field has a variable width. You can set a width from 2 to 50 characters by 
selecting the Options > Customize > Block/Sheet Bar Width menu command in the dialog 
box. The settings apply to the entire chart folder. 

A sheet bar entry is always generated when there is an interconnection to an object that is 
not located within the active sheet. The entry consists of two fields, each with two lines. The 
type of connection determines the field content. 

Large field 
The large field contains the reference to the linked object: 

● Interconnection between blocks: 
Line 1: Chart name*), block name *) 
Line 2: I/O name and, if available, comment of the I/O (may be abbreviated) 

The chart partition and sheet number are given in parentheses after the chart name for 
sheet-wide interconnections. 

The technological path or, when the PH is not available, the component path is given for 
an interconnection to an I/O located in another CPU. 

● Interconnection to shared addresses: 
Line 1: Symbol and/or absolute address value based on symbol table **) 
Line 2: Comment from symbol table **) 

● Interconnection to a runtime group: 
Line 1: Name and, if available, comment for the runtime group 
Line 2: "ENABLE", task name 

● Interconnection to unplaced block 
Line 1: Block name and text: (NO POSITION) 
Line 2: I/O name and, if available, comment of the I/O 

● Interconnection of I/Os (block/chart) to chart I/Os 
Line 1: I/O name and, if available, comment 
Line 2: I/O type and data type 

● Interconnection to hidden I/O 
Line 1: Chart name*), block name *) 
Line 2: I/O name and text: (INVISIBLE) and, if available, comment of the I/O (may be 
abbreviated) 
 

 
*) If the chart is used in a plant hierarchy (PCS 7), the chart and block names are preceded by the 

hierarchy path name. The start of the path name is truncated if there is not enough space. 
**) The symbol table is not available in all CPUs. 
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 Note 

Depending on the set sheet bar width, it may happen that the full text cannot be displayed, 
i.e., it will be truncated according to the default number of characters. However, the tooltip 
box will show you the full text when you position the cursor on the field. 

 

Small field 
The small field of the sheet bar entry is used as follows: 

● The field contains the number of the connector reference when the connection line cannot 
be drawn to the sheet bar due to the lack of sheet space. 

● A colored triangle indicates the connection type. 

 
ID Interconnected to ... 
(empty) Block I/O / chart I/O (external) 
White triangle Chart I/O (internal) 
Blue triangle Shared addresses 
Red triangle Runtime group 
Yellow triangle Textual interconnection 
Green triangle Connection to another CPU 

You cannot change the width of the small field. 

Entries in the overflow page 
An overflow page will be generated if the sheet bar cannot accept additional reference 
entries for interconnections to other sheets. 

Information on the interconnected I/O (origin) is also displayed next to the entries in the 
sheet bar of the overflow page (small and large field). 



Layout of configuration data  
8.11 Tooltips 

 CFC for SIMATIC S7 (V8.0 SP4) 
70 Function Manual, 07/2013, A5E03710059-06 

8.11 Tooltips 

 
You can display a tooltip about certain parts of the CFC chart by positioning the cursor over 
the relevant items: 

 
Position of the cursor Information 
Block header, block body Block type, block comment 
Chart header, chart body Type (always "Chart"), chart comment 
Runtime properties box in the block header Full task name, name of runtime group, if available 
Block I/O / chart I/O I/O name 

I/O type 
Data type 
Value (only for I/O which is not interconnected) 
I/O comment 

Sheet bar Full sheet bar entry  
(may be truncated if PH path is too long) 

The following applies to the test mode: 

● The information is actively retrieved from the CPU by placing the cursor on an I/O or the 
connection line even if the I/O has not been registered for monitoring. The cursor here 
functions like a "test prod" of a measuring device. This requires, however, for the I/O to 
be updated online (no unconnected FC input, for example). Updating occurs in a one 
second cycle, regardless of the monitoring cycle that is set. 

● The value is substituted with the online value and the background color of the tooltip 
changes from light yellow to yellow, as it does with monitored I/Os. 

● The output value is displayed for an interconnection.  
Exception: With interconnections to shared addresses, the input value is displayed. 
Inversions are taken into account in this case. 
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8.12 Views 

8.12.1 Views in CFC 

Views 
The CFC editor provides two different views for inserting and editing blocks/nested charts:       

● The overview is useful for copying/moving objects and inserting large blocks. 

● Because some details (I/O names, for example) cannot be displayed in this view, certain 
functions are only available in the sheet view. 

You will find more information on this subject in the following sections: 

– Overview (Page 71) 

– Sheet view (Page 72) 

Toggling between views 
You have the following options for toggling between views: 

● Select the menu command View > Overview or View > Sheet View.  
The CFC will switch to the selected view 

or 

● Select the button for overview or sheet view in the toolbar. 

 

 
Overview 

 
Sheet view 

or 

● Double-click a free location in the chart 

or 

● Select the sheet number in the list box  to open the required sheet view or the 
asterisk (*) to change to the overview. 

8.12.2 Overview 

The "Overview" chart view 
The overview (chart view) is useful for copying and moving blocks to or from nested charts 
and for inserting large blocks.       
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It is also possible to make interconnections of block I/Os, even beyond sheet margins. The 
information about I/Os (for example, name, I/O type and data type) that cannot be displayed 
in the chart view can be shown as a tooltip.  

Changing to the "Chart view" 
You have several options for changing to the "Chart view": 

● Select the menu command View > Chart View. 

or 

● In the toolbar, select the icon: 

 
or 

● Double-click a free point in the chart in the sheet view 

or 

● Select the asterisk (*) in the combo box . 

8.12.3 Sheet view 

Sheet view 
Depending on the resolution of your screen and the display size you have set, the sheet view 
displays the full sheet or only parts of it. Use the scroll bars to scroll the display.      

Changing to the "Sheet view" 
You have several options for changing to the "Sheet view": 

● Select the menu command View > Sheet View. 

or 

● In the toolbar, select the icon: 

 
or 

● Select the required sheet number in the combo box of the toolbar 

or 

● Double-click a free area of the chart in the overview 

or 

● Select the sheet number in the combo box . 
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 Creating runtime structures 9 
9.1 Working with charts 

9.1.1 How to create and delete charts 

Requirement  
In the SIMATIC Manager , you have created a project with an S7 program including a chart 
folder. 

Creating a chart 
You usually create a chart with the SIMATIC Manager . Proceed as follows: 

1. Open a chart folder in the project. 

2. Select the menu command Insert > S7 Software > CFC.  
The chart is inserted and assigned a default name by the system that you can change to 
suit your purposes.  
You will find more information about this in the Automatic naming (Page 21) 

You can also create a chart directly in the CFC editor. Proceed as follows: 

1. In the CFC editor, select the menu command Chart > New…. 

2. In the dialog box, select the project and the chart folder. 

3. Under "Object name:", enter the name of the new chart.  
The maximum length of the chart name is 22 characters (illegal characters: \ / . " %). 

4. Click "OK". 
The dialog box closes. 

Result 
The chart has been created. 

Creating a runtime group automatically 
When you create a new chart, a new runtime group is automatically generated and inserted 
into the run sequence according to the chart installation pointer. The name of the runtime 
group corresponds to the chart name. 

There is a certain amount of interdependence between the automatically generated runtime 
group and the chart until the runtime group is modified. Modifications are, for example, 
renaming and/or subsequent insertion of other blocks into this runtime group. 



Creating runtime structures  
9.1 Working with charts 

 CFC for SIMATIC S7 (V8.0 SP4) 
74 Function Manual, 07/2013, A5E03710059-06 

This interdependence ensures that the name of the runtime group is identical to the chart 
name and that it is automatically renamed when the chart is renamed. Furthermore, the 
runtime group is also deleted when the chart is deleted if it is empty as a result. 

When this interdependence disappears due to modifications to the runtime group, the 
automatically generated runtime group responds in the same way as any other manually 
inserted runtime group. 

Nested chart 
You generate a nested chart when you insert a new chart into an existing chart. You can find 
additional information in the section: Creating nested charts (Page 84) 

Deleting a chart 
You can delete a chart similar to other objects in the SIMATIC Manager :  

● Select the chart and press <Del>. 

9.1.2 How to open charts 

Procedure  
You usually open a chart in the SIMATIC Manager: 

1. First, select a project. Secondly, select the S7 program folder and open the chart folder. 

2. Double-click the required chart. 

The chart opens and the CFC editor started. 

Additional options for opening a chart 
The "Chart" menu displays the last four charts edited and closed in the form of menu 
commands. Select one of these menu commands to open the corresponding chart or to 
display it if it has been opened already. 

You can open a chart that is not displayed in the "Chart" menu as follows: 

1. Select the Chart > Open... menu command or click the button 

 
2. In the dialog box, select the project and the S7 program folder. 

3. Open the chart folder. 

4. Double-click on the required chart  
or 
 select the required chart and click on the "OK" button. 
The chart opens. 
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You can select a chart in the chart catalog and open it with the shortcut menu command 
Open or by pressing <Return>. The chart opens. 

In addition to opening nested charts in the chart catalog, you can also open them as follows: 

● Select the nested chart, then select the Open menu command, in either the "Edit" menu 
or the shortcut menu. 

● A double-click on a free area in the body (not on the header or an I/O!) also opens the 
chart. By repeating this, you can work down to the lowest chart level in the tree. 

From a nested chart you can open the parent chart of the current nested chart: 

● Select the menu command Open Parent Chart from the "Chart" menu or shortcut menu. 
The parent chart opens at the position of the nested chart. The nested chart is 
highlighted. 

9.1.3 Navigating in the chart 

Introduction 
Several functions help you browse the chart. The following options are available:     

● Menu command Edit > Go To > .... 

● Double-clicking 

● Buttons and list boxes on the toolbar 

Toolbar Icons 
You can change to the respective view using the icons.  

● Overview 

 
● Sheet view 

 
The last setting determines the size of the new view. 

Double-click 
Double-clicking on a free area changes the view. You change from the overview to the sheet 
view and vice versa.  

When you change to the sheet view, the position of the cursor determines the center of 
alignment for the view. 
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Drop-down list for sheet and overview 

The toolbar of the chart also allows you to change to the sheet required and to the overview 
via the drop-down list . 

Chart partition tabs 
The chart partitions are displayed on a maximum of 26 tabs located next to the scroll bar at 
the lower edge of the window. You can use these tabs to change to another existing chart 
partition by clicking. 

Go To 
The menu command Edit > Go To > opens a submenu which provides the following 
navigation options: 

● Insertion Position 
This function starts the runtime editor and displays the block selected from the chart in 
the run sequence. 
This menu command will be disabled if more than one/no block has been selected. 

● Next Insertion Position 
Use this function to find further insertion positions for the selected block in the run 
sequence. 
This menu command is only enabled after you have started the runtime editor and when 
a block/SFC chart has been selected in the run sequence. 

● Chart 
Use this function to open the chart that contains the selected block. This block will be 
highlighted in the open chart. 
This menu command is only enabled after you have started the runtime editor and when 
a block/SFC chart has been selected in the run sequence. 

● Track Signal 
You can use this function to track the signal of a selected chart I/O of a nested chart to 
the I/O which is internally interconnected to the I/O of this chart. Signal tracking means 
that the nested chart will be opened and the displayed interconnection and sheet bar 
entry will flash.  
This menu command is only enabled if you have selected a chart I/O that is internally 
interconnected with a block/chart I/O. 

● I/O Module 
After you have selected the field of a shared address from the sheet bar, use this function 
to call "HW Config". An error message will be output to you if the entry does not refer to a 
module or if the address could not be found. 

● Block Type 
Use this command to jump from the selected block instance to the corresponding block 
type. If the source file of the block is included in the project, the relevant programming 
tool (LAD/STL/FBD or SCL) is opened. You can use this programming tool to edit the 
block type. Otherwise, LAD/STL/FBD is opened, enabling you to read the block (for 
example, the system attributes of the I/Os). 
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● Jump Back 
With this function, you return to the sheet you exited by clicking the sheet bar. 
This menu command is only enabled if the window displaying the original chart is still 
open. 

● Next Overflow Page 
This function lets you jump from the current overflow page or from the original sheet to 
the next overflow page.  
This menu command is only enabled if an overflow page exists. 

● Previous Overflow Page  
With this function, you can jump from the current to the previous overflow page or from 
the first overflow page to the original sheet.  
This menu command is only enabled when an overflow page is displayed. 

● Original Sheet 
Use this function to return from an overflow page of a sheet to the original sheet (sheet 
with blocks/nested charts). 
This menu command is only enabled if you are currently in an overflow sheet. 

● Chart Partition... 
This function displays a dialog box with a list of all chart partitions. By selecting the 
required chart partition letter (A – Z) and clicking "OK" you can change to the required 
chart partition. 

● Sheet... 
This function opens a dialog box that contains buttons that allow you to select one of the 
6 sheets. Click the appropriate button to jump to the required sheet. 

Jump from Sheet Bar 
If an I/O is interconnected with another I/O via the sheet bar or is located on another sheet or 
chart, you can jump to the interconnection partner. 

● Single interconnection 
Select the interconnection (I/O / sheet bar entry / connection line) and select the shortcut 
menu command Jump from Sheet Bar. You can also double-click the sheet bar entry.  
The corresponding sheet that contains the interconnection partner opens. The target 
chart is opened if the interconnection partner is located in another chart. The 
interconnection flashes (connection line and sheet bar entry). 

● Multiple interconnection 
If this is an I/O that contains multiple output interconnections, a dialog box appears 
showing a list of the interconnected I/Os before the sheet bar jump is executed. There 
you can double-click the I/O required or you can confirm a selection with "OK" in order to 
jump to the sheet/chart of the interconnection partner. 
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Signal tracking 
Proceed as follows to track signals: 

Signal tracking from within a nested chart 

1. Within the nested chart, position the cursor on the sheet bar entry. 

2. Select the shortcut menu command Jump from Sheet Bar. 
The higher-level chart is opened and the interconnection flashes. 

Signal tracking into a nested chart 

You can find information on this in the above section “Go To” under “Track Signal”. 

Signal tracking at the overview level 

Click an interconnection.  
All the connection lines associated with a chart partition flash on the following pages: 

● Overview page 

● All six sheets 

● All overflow pages 

9.1.4 Copying/moving charts 

Introduction 
Copying entire charts allows you to duplicate or move tested structures or substructures, 
even to other CPUs.  

Copying/moving 
Including resources in the copy 

When you copy/move charts, the resources will also be copied, provided they do not already 
exist in the destination. The following elements are resources: 

● Block types, FBs and FCs, including symbols 

● System attributes 

● Called blocks of multiple instance blocks 

Textual interconnections 

When you copy/move a chart to another chart folder, interconnections that exceed the chart 
boundaries are implemented as textual interconnections. These open textual 
interconnections can be closed again. They then form real block interconnections, provided 
you copy/move the chart and the interconnection partner to this chart folder, or once you 
have copied/moved the corresponding chart back to its original folder.  

This includes textual interconnections of the chart you want to copy/move. 
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Peculiarities of nested charts: When you move or copy nested charts, the internal 
interconnections to the chart I/Os are not converted to textual interconnections, that is, they 
will be lost. 

You can find additional information in the section: Working with textual interconnections 
(Page 128) 

Shared addresses 

When copying charts, remember that interconnections to shared addresses are also copied, 
depending on the default setting. You can change this setting in the "Settings for 
Copying/Moving" dialog box. You can open this dialog box with the menu command Options 
> Customize > Copy/Move.... 

Runtime groups 

When copying/moving charts, interconnections to runtime groups are not copied. No textual 
interconnections are generated. 

System attributes 

When charts are copied or moved, the system attributes of the copied/moved blocks are 
compared to existing blocks in the destination. You may abort the copying/moving operation 
based on the results of the comparison. The causes of this are described in the following 
section: What you should know about copying blocks (Page 107) ("Checking the System 
Attributes"). 

Copying/moving charts to a different CPU/library/project 
When you copy charts to other CPUs, remember the following points: 

● If a block type in the destination CPU is incompatible with the block type you are copying 
(number, order, name, and data types of the block I/Os), the chart will not be copied.  
You are shown a log with a list of relevant block types. 

In this case, before you copy the chart again:  

– You must copy the relevant block type either to the block folder of the source program 
or to the block folder of the destination program. 

– Select the block type in the “Chart Folder” box using the menu command Options > 
Block Types... and click the “New Version” button.  
A central block type change is made. 

● The copied blocks will maintain the runtime properties of the blocks from the source CPU. 
Therefore, the blocks are installed in the run sequence as they were installed in the 
source CPU.  
If no task with the same name exists on the destination CPU, a log displaying the missing 
tasks is output and the copy operation will be rejected. 
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  Note 

We do not advise the copying of complete chart folders, since the resources (e.g., FBs, 
FCs, shared DBs, symbols) are not included and program inconsistency might develop. 

If you do not want to copy the complete program, you can select and copy all the charts 
in the chart folder. In this case, the resources are also copied. 

Copying the entire program, the CPU or a station does not lead to any inconsistency. 

If a chart is empty, the chart runtime group is not copied or moved. 
 

Charts on different target systems 
You can copy and move CFC charts between different target systems. Once again, the block 
types used on both target systems must be identical, since the block types are not included. 
If the block types are not identical, copying of the charts would be rejected. 
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9.2 Editing charts 

9.2.1 Adapting chart properties 

Use and call 
In the "General" tab of the "Properties CFC" dialog box, you can set general properties such 
as the chart name, author and comment for the active chart. In the "Version" tab, you can 
change the version number, for example, after changing the chart. 

In CFC, you can display this dialog box using the menu command Chart > Properties....  

Note: The dialog box opens automatically with the "Version" tab, if versioning has been 
activated in the project properties and the chart is closed after a change. 

Content of the "General" tab 
The "General" tab contains the following input and output fields: 

● Name 

You can display and edit the name of the active CFC chart here. The name must be 
unique in the CPU. This is checked by the system.  

The maximum permitted name length is 22 characters. The following characters are 
prohibited: / \ . " %. 

 
  Note 

When assigning names, please consider that the variable name cannot be longer than 
128 characters for the OS compilation. This name is made up of the name of the folder in 
the hierarchy path, the chart name, the block name, the delimiter (period), and the I/O 
name. 

 

● Project path 

● Technological path 

● Storage location of project 

You cannot change the path displayed in this dialog box. You can only do this from the 
SIMATIC Manager. The technological path is only available if a plant hierarchy has been 
configured in the project and a hierarchy folder has been assigned to the CFC chart. 

● Author 

The author of the chart. 

● Created on 

Date of creation 
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● Last modification on 

Date of most recent modification If a chart has been modified, the date of most recent 
modification applies to all other charts in the same chart folder because there may be 
interconnections from one chart to another. Only one global "last modified" date is, 
therefore, applied to the chart folders.  

● Comment 

Here, you can enter a comment that is included on your printed CFC chart. 

● "Write-protected" option 

Use this option to enable or disable write protection for a chart. You cannot edit the write-
protected CFC chart in the CFC editor. Because of the write protection, you can no longer 
alter any SFC instances in the chart using the SFC editor. 

Content of the "Version" tab 
In this tab, you can change the version number of the chart. 

Version: 

Major and minor versions can be set separately with the arrow keys. Version change is 
deactivated for write-protected charts.  

You can set the versions from 0.0001 to 255.4095. A new chart always starts with version 
number 0.0001. You cannot set a number that is smaller than the last saved version. 

If versioning is activated in the properties of the project, the dialog box automatically opens 
with the "Version" tab when the chart is closed after a change. 

Data version: 

Displays the software version used to create or last modify the program. The data version 
depends on the product version. The data version is determined by the database and 
displays the current status of the data structure. 

9.2.2 How to insert and delete chart partitions 

Introduction 
You can always expand the CFC chart by additional chart partitions, if its size is insufficient. 
The tab level with the bottom scroll bar can be used to select the chart partition required. 

Insert  
When you insert a chart partition, you can decide whether the new chart partition is inserted 
before the current chart partition or whether it should be appended as the last chart partition. 
You have two options: 
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Before the current chart partition: 

● Select the menu command Insert > Chart Partition > Before Active Partition 
or 
open the shortcut menu of the chart partition tab and select the Insert Before Active 
Partition menu command. 

As the last chart partition: 

● Select the menu command Insert > Chart Partition > After Last Partition 
or 
 open the shortcut menu for the chart partition tab and select the menu command Insert 
Chart Partition After Last. 

A chart can contain up to 26 chart partitions. They are identified in alphabetical order (A-Z). 
The alphabetical identifier of the existing chart partitions changes if additional chart partitions 
are inserted before it.  

If, for example, the "CFC1" chart consists of a single chart partition, it is assigned the ID 
letter "A". If you insert an additional chart partition before this chart partition, the new 
"primary” chart partition is assigned the "A" identifier, while the identifier of the previous 
partition changes to “B”. 

Depending on the view (sheet or overview), the ID of the current chart partition is displayed 
with the sheet number or "Overview" in the status bar.  
Example:  

 
B/Sheet 3 B/Overview 

Delete 
You can only delete the current chart partition.  

● Select the menu command Edit > Delete Chart Partition or, in the shortcut menu for the 
chart partition tab, select the menu command Delete Chart Partition. 
The current chart partition is deleted if it empty. If the chart partition contains any objects, 
you are prompted to confirm deletion. 



Creating runtime structures  
9.3 Creating nested charts 

 CFC for SIMATIC S7 (V8.0 SP4) 
84 Function Manual, 07/2013, A5E03710059-06 

9.3 Creating nested charts 

9.3.1 Creating nested charts 

Introduction     
You can insert a CFC chart into another CFC chart. This allows you to develop a program 
whose modular segments can be standardized for reuse, with a structure according to your 
system requirements. 

You can open and modify the (nested) charts inserted in the parent chart in edit mode and 
you can operate and monitor them in test mode on the CPU.  

The chart containing the nested charts is the top chart. Only the top chart can be seen in the 
SIMATIC Manager . The maximum nesting depth of nested charts is 8 (top chart + 7 levels of 
nested charts). 

Chart-in-chart 
You can drag-and-drop a new nested chart from the CFC catalog of blocks (symbol:  New 
chart) to the current chart for further editing. Execute the menu command Insert > New Chart 
in order to find a free location in the chart (in the sheet view only in the current sheet) and 
insert the new chart at this position. The search for this free area is performed horizontally, 
line by line, from left to right, and from top to bottom (in the overview of all sheets). 

In order to handle charts in the same way as CFC blocks, the chart catalog displays the 
charts in a tree view. From this location you can drag-and-drop a chart to the currently open 
chart. When you insert the chart, it is copied to the chart, along with all nested charts, if it 
contains any. 

 

 Note 

Remember that the chart you have inserted into the current CFC chart via drag-and-drop 
from the chart catalog is a copy. This nested chart no longer has any relationship to the 
original chart. Modifications that you make in one of the charts only affect that chart. 

 

Moving a chart 
You can also hold down the shift key and drag-and-drop top charts to the chart. In this case, 
they are not copied but moved. In the catalog, the chart no longer appears at its previous 
location. It is shown in the hierarchy of the active chart instead. 

Interconnecting 
You can interconnect nested charts with other nested charts in the chart, if they have chart 
I/Os, with blocks or shared addresses, or establish textual interconnections. 
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Navigating in a chart 
Opening nested charts: 

1. Select the nested chart. 

2. Open the shortcut menu and select the command Open 
or  
select the command Edit> Open 
or 
double click on an open space in the body (not on the header or an I/O!). 
The chart opens. 

By repeating this, you can work down to the lowest chart level in the tree.  

Moving up through the hierarchy as far as the top chart: 

1. Activate the nested chart. 

2. Open the shortcut menu and select the command Open Parent Chart 
or  
select the command Chart > Open Parent Chart 
or  
double click on an entry in the sheet bar (not on shared addresses). 
The parent chart opens. 

Opening a chart in the chart catalog: 

1. Select a chart in the catalog. 

2. Select the shortcut menu command Open 
or  
press on the <Return> button. 

The active chart is identified in the catalog by its black border. 

Copying a nested chart to another CPU 
You can copy a nested chart and paste it into the chart of another CPU. The installation 
position of the "Predecessor for Insertion Position" of the target chart applies to the blocks it 
contains. Runtime groups are not copied. 

You can find additional information about nested charts in the following sections: 

Copying/deleting nested charts (Page 86) 

How to replace nested charts (Page 86) 

How to create a chart with chart I/Os (Page 87) 
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9.3.2 Copying/deleting nested charts 

Copying/moving within a chart or to other charts 
You can copy or move nested charts in the same way as blocks. 

Copying to the chart folder 
You can first copy a nested chart into the chart folder if you want to delete it from its parent 
chart, but not from the chart folder (you may have modified it and want to use it later at a 
different point). Proceed as follows: 

1. Open the nested chart to be copied by selecting Edit > Open 
or  
by selecting the Open command from the shortcut menu of the nested chart. 

2. Once the chart is open (active), select the menu command Chart > Copy to Chart Folder. 

The chart will be copied to the chart folder as a top chart. If a top chart already exists under 
the same name in this chart folder, a new name will be automatically assigned to it (with a 
message), provided you have not modified it before you copied it.  

Deleting nested chart 
You can delete the nested chart from its parent chart as follows: 

● Select the chart and press <Del>. 

or 

● select the shortcut menu command Delete 

or  

● select the menu command Edit > Delete. 

9.3.3 How to replace nested charts 

Introduction 
You can replace a nested chart with another. In this case, the interconnections of the “old” 
chart are maintained, if possible.  

Application 
The “Replace” function can be very useful in situations where you have configured the 
nested charts as encapsulated functions for different applications.  
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Such an application might be: 

You have encapsulated a (partial) function in a nested chart and interconnected it in this 
chart. For example, this partial function can be a control for a ventilation unit of which several 
variants are available for different fields of application. These variants can be replaced within 
the global structure, without you having to modify the interconnections. 

Procedure 
The chart that is to replace a specific nested chart is located either in a library, the current 
chart folder (as a top chart) or in another chart of the chart folder. 

1. Open the chart that contains the nested chart you want to replace. 

2. Open the chart or library catalog; expand the hierarchy tree, if required. 

3. Drag-and-drop the required chart from the catalog onto the nested chart you want to 
replace. 

4. Release the mouse button when the cursor is positioned exactly over the chart you want 
to replace. 

You are prompted to confirm the action. 

5. Click "OK". 

The nested chart will be replaced, provided the cursor was positioned within the chart you 
want to replace.  
Click “Cancel” to abort this operation. 

9.3.4 How to create a chart with chart I/Os 

Introduction 
You can add I/Os to a chart in order, for example, to: 

● Insert the chart in a different chart and interconnect it with other charts or blocks 

● Compile the chart as a block type 

Procedure 
Two methods are available: 

● Creating chart I/Os without assignment 

● Creating chart I/Os with interconnection 

Creating chart I/Os without assignment 

In the first step, you create chart I/Os without reference to any parameters (for example, 
because the chart does not yet contain blocks and/or additional nested charts).  
You then assign the chart I/O names, attributes and default values. 
In the second step, you insert and interconnect the blocks/charts in the chart and assign the 
corresponding object I/Os from the chart to the chart I/Os. 



Creating runtime structures  
9.3 Creating nested charts 

 CFC for SIMATIC S7 (V8.0 SP4) 
88 Function Manual, 07/2013, A5E03710059-06 

Creating chart I/Os (1st step): 

1. Click the button on the toolbar 

 
or  
select the View > Chart Inputs/Outputs menu command.  
The dialog box for editing chart I/Os opens and "docked" to the upper section of the chart 
window. 

2. In the hierarchy window on the left, select the required I/O type (IN, OUT or INOUT). 

3. In the detailed window on the right, edit the empty declaration line for the particular I/O 
type (name, data type, initial value, comment). Select the data type via a list box. 

Assign I/Os via drag-and-drop (2nd step): 

1. Drag-and-drop the I/O of the block/chart to one of the chart I/Os that is of a compatible 
data type. 

As an alternative with existing chart I/Os 

You can assign the I/Os of blocks placed in the chart and/or nested charts to the existing 
chart I/Os without opening the chart I/O window.  

1. Select the I/O, then select the menu command Interconnection to Chart I/O... in the 
shortcut menu or in the “Insert” menu.  
A dialog box opens that displays a list of all available I/Os of the relevant I/O type 
(available I/Os of IN and IN_OUT are displayed for IN under S7). 

2. Select the required chart I/O and exit the dialog box by clicking “OK”. 

 
  Note 

You can only assign unconnected I/Os with a compatible data type. 
 

You can also create interconnections the other way round. You drag a chart I/O to the 
required I/O of the block/chart with a compatible data type. Please note the following: 

– With outputs: The chart I/O must not yet be assigned to a block/chart I/O. However, a 
chart output that is not yet assigned can be assigned to the output of a block or chart 
that is already interconnected. 

– With inputs: You can assign the chart I/O to several block/chart inputs. 

If an I/O is already interconnected, it is not possible to change the data type. 

Creating chart I/Os with interconnection  

The first step is to create the chart itself, i.e., you insert and interconnect blocks/charts.  
In the second step, you open the chart I/O window and define the chart I/Os by connecting 
them to the I/Os of blocks/charts placed in the chart. A new line will always be created and 
all the properties of the connected I/O are adopted, for example, the name, attribute and 
initial value. Restrictions for the attributes S7_param and S7_link: If the values cannot be 
adopted, only the interconnection is created.  
If naming conflicts occur, for example, because the same names are used in different blocks, 
the name is made unique in the chart I/O by incrementing it. 
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Create chart I/Os by connecting with <Ctrl> + drag-and-drop 

1. Click the button on the toolbar 

 
or  
select the View > Chart Inputs/Outputs menu command.  
The dialog box for editing chart I/Os opens and "docked" to the upper section of the chart 
window. 

2. In the hierarchy window on the left, click the required I/O type (IN, OUT or INOUT). The 
details window on the right displays the lines with I/Os. If new chart I/Os are yet to be 
created, these lines will be empty. 

3. In the working window of the chart, select the required I/O on the block/chart, press and 
hold down the <Ctrl> key and drag the I/O to the “Name” box in the right window of the 
chart I/Os.  
The I/O is then adopted with its properties.  
Exception: interconnected I/Os are not reassigned. 

4. Follow the same procedure for all other I/Os of the blocks/charts in the chart you want to 
interconnect with the chart inputs/outputs. 

While holding down the <Ctrl> key, drag-and-drop an I/O that already exists in the chart I/Os 
to another empty line in the Chart I/Os window. A number is automatically appended to the 
name. The I/O name is then unique. 

When you hold down the <Ctrl> key and drag-and-drop an internally interconnected I/O to a 
new line, a copy will be generated. The I/O will not be interconnected to the internal I/O. 

Representation in the sheet bar 
The CFC sheet bar displays the I/Os names and comments, I/O type and data type applied 
to the chart I/Os. The "interface I/O" type of interconnection is indicated by a small white 
triangle above the interconnection line. 

 

 Note 

If an I/O interconnected to the chart interface has been hidden, there is no sheet bar entry. 
These interconnections can only be recognized in the object properties of the block 
("Interconnection" column of the "I/Os" tab). 

 

Changing Chart I/O Names 
The chart I/O name does not need to include the name of the associated block I/O. You can 
rename it. If you want to rename it, select the name in the "Name" box and enter a new 
name. As an alternative, you can double-click on the start of the line of the chart I/Os in the 
right pane and enter the new name in the properties dialog. 
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System attributes 
You can also assign system attributes to specific chart I/Os, as with block I/Os. The following 
rules apply: 

When you interconnect an I/O of a block/chart already placed in the chart to a chart I/O: 

● The chart I/O inherits the block/chart attribute, if an attribute has not yet been assigned. 

● The chart I/O retains an attribute that has already been entered.  
Restrictions: For example, if text attributes are retained, with S7_link and S7_param an 
attempt is made to assign those values.  
Exception: The function will always adopt the value of S7_visible. 

A chart with chart I/Os is not assigned system attributes, except the I/Os. These attributes 
can be assigned when you compile the chart as block type. 

Assigning I/Os to inserted charts 
You can also extend a chart with chart I/Os later by adding further chart I/Os. Adding I/Os 
may cause positioning conflicts if the target is a nested chart, i.e., a chart already inserted in 
another. In this case, as with overlapping blocks, the nested chart is displayed as an 
overlapping chart, in light gray and without I/Os.  
Once the chart is positioned at a free location, the I/Os and interconnections are visible 
again. 

You can find additional information in the following sections: 

Compile chart as block type (Page 241) 

Interconnection rules for chart I/Os (Page 134) 

System attributes of block connections 
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9.4 Handling block types 

9.4.1 Import of block types 

Import to CFC  
Blocks are made known to CFC by their import. You can only use such blocks in CFC. 

There are two ways of importing blocks:  

● Import in the background: By installing them in the chart from the catalog 

● Explicit import: By installing them with the menu command Options > Block Types… 

Explicit importing is always useful when you require a lot of different blocks, for example, if 
you want to import a large number of blocks from the user program (block folder) to the chart 
folder. You would also use this dialog box if you have modified blocks (type modification) in 
the block folder that exist with the same name in the chart folder and need to be updated 
there. After this type of import, inserting from the catalog is much faster since import in the 
background is no longer necessary.  

Tip: Imported blocks appear in the block catalog in the relevant block families and under "All 
blocks". You should then only insert blocks in the chart from this block catalog. 

You can select the blocks you require in the "Offline block folder" box of the "Block types" 
dialog box and then import the blocks to the chart folder by dragging them with the mouse or 
clicking " -> ". If a block already exists in the chart folder, a warning is displayed. If an older 
version already exists, follow the steps outlined in the following section: New block type 
version (Page 92). 

Importing using the SIMATIC Manager 
Proceed as follows to perform an import with the SIMATIC Manager : 

1. Open the relevant library in the SIMATIC Manager . 

2. Copy the block from the library block folder and paste it into the program block folder. Any 
existing block is overwritten. 

3. Switch to CFC and select the menu command Options > Block Types.... 

Handling blocks with identical numbers 
Block numbers must be unique in an S7 program. Using different block types (symbolic 
name and/or function) with identical object names is not permitted, for example, both "FB61", 
and will be rejected by the system. In this case, the block number must be changed. 
Note: The object name consists of the block type "FB" or "FC" and the number. 
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During import, the system detects a block that already exists under this object name. An 
error message then appears in the "Block types" log. If the two blocks have different 
symbolic names, for example, the existing block name is "CTRL_PID" and that of the block 
you are importing is "CTRL_xx", the entry is made automatically in the symbol table. If two 
blocks have an identical symbolic name, you have to make the entry in the symbol table 
yourself. 

Make sure that the block number is in the range supported by your CPU. You can find 
additional information on this: 

● In the reference manual Automation System S7-400; Module Data 

● With the menu command CPU > Module Information > "Performance Data" tab 

The "No. of FBs" listed here is also the range for the block number. Example: No. of FBs = 
512. The highest possible block number is thus FB 511. 

9.4.2 New block type version 

Introduction      
If you want to use the modified blocks for previously used block types following a block type 
change, you must import the new block types to the chart folder. The block instances used in 
CFC are then adapted to the modified block types.  
There are two ways of importing: 

● Import in the background, achieved by inserting a modified block type from the S7 
program or the block library into the chart 

● Import using the the menu command Options > Block Types in the "Block Types" dialog 
box. Select the block to be imported from the list of source files ("Offline block folder", 
“Project”) and drag-and-drop it to the "Chart folder" list or click "→". 

Using a new version 
If a block type with this name but of a different version exists in the chart folder, the "Import 
New Version" dialog box appears displaying a corresponding message and version 
information on both blocks.  

If you answer the "Do you really want to use the new version of the block types?" prompt 
with "Yes", all corresponding block instances will be adapted. If you answer with "No", 
nothing is imported and no adaptation is made.  
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The following separate situations can be distinguished: 

 

 

Changes requiring neither a download of the entire program nor repeated OS compilation 
because the changes are relevant only within the ES. Example: A block I/O was assigned 
the “hidden” attribute. In this case, you only need to download changes when the CPU is 
in RUN. 

 

Changes relevant to the OS and therefore requiring OS compilation. 
Example: After you have edited a message text. 

 

Changes in which the structure was modified. 
Example: By adding I/Os and/or messages. 
This can have the following consequences: 
• Interconnections and parameter assignments can be lost. 
• The only option is to download the entire program, in other words, the CPU must be 

switched to STOP mode. 
• If the block is intended for operator control and monitoring, in other words, it will be 

executed on the OS, you also need to compile the OS. 
• If you want to retain parameter settings from the AS, the chart must be read back 

before the next download. 

Identical version 
When you import block types of the same version as those in the chart folder, a dialog box 
displays the following: 

● The message "The new versions of the block types from the offline block folder match the 
block types of the same name in the CFC chart. Importing is not necessary." 

● A list of identical block types 

You can find additional information about block type changes in section: Effects of type 
changes on block instances (Page 102) 

9.4.3 Inserting block types 

Block types in the catalog  
You can drag-and-drop a selected block type from the libraries/block catalog to the chart. As 
an alternative, you can insert a block selected in the catalog at a free location in the chart 
partition in the overview or in the current sheet in the sheet view by pressing <Return>.    

Additional informagtion on searching for a block is contained in section: Searching for 
objects in the catalog (Page 322) 
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Inserting block types 
● Inserting from the libraries catalog 

Block types inserted from the libraries catalog will be implicitly imported into CFC. 

Block I/Os with modified system attributes 

If you attempt to insert a block in the chart from a library and when copying it to the block 
folder it is recognized that the system attributes differ from those of the existing block, the 
"Insert function block" dialog box opens.  

Click "Adjust attributes" to open the "Adjustment of system attributes" dialog box, where 
you can view all I/Os with different attributes. 

Click the attribute value "source" or "target (old)" to decide whether the I/O of the 
imported block [target (new)] will be assigned the attribute value of the "source" or the 
"old" target. 

Click “OK” to overwrite previously used attributes with the current values. Both dialog 
boxes are closed. 

● Inserting from the block catalog 

Blocks from the S7 program  are automatically imported to CFC when you insert them 
in the chart and also appear in a family of CFC blocks. The block icon appears in different 
forms, depending on whether the block is already known to CFC, in other words, whether 
or not it has been imported.  

Blocks that were not imported are indicated by the following icon: 
 

Blocks in the S7 program are still unknown in CFC, even if a block of this type has 
already been imported. This means that when you want to insert a block from the S7 
program into the chart, a check is always made to determine whether the block has 
already been imported.  

You can find blocks that are already imported in the "All Blocks" directory  and in one 
of the block families . A block that is not assigned to a family (indicated in the header) 
can be found in the "Other blocks" directory. These blocks are indicated by the following 
icon: 

 
Tip:Inserting blocks from the block families is the fastest method of positioning blocks in 
the chart, since these are already known in CFC and no longer need to be verified.  

You should always select this method if a block type has already been imported.  
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Note on startup blocks 
Note the following information on startup blocks, for example, controller blocks CONT_C, 
CONT_S or PULSEGEN, relevant to specific CPUs: 

● With S7-3xx and S7-4xx CPUs, the block must not only be called in the cyclic interrupt 
OB, for example, OB 35, but also in OB 100 (startup OB) so that their startup code can 
be processed. The block is installed automatically. 

● With the S7-3xx CPU, note that the RESTART block (FC 70) must be the first block called 
in OB 100. Each time this block is called, memory word MW 0 will be modified to allow 
blocks called in OB 100 to recognize the startup. MW 0 must not be used elsewhere in 
the CPU. 

Blocks with identical numbers 
Object names (block type + block number) must be unique in an S7 program. You will find 
more detailed information on this topic in "Handling blocks with identical numbers" in the 
section: Import of block types (Page 91) 

9.4.4 How to update block/SFC types in the multiproject 

Introduction  
In the multiproject, you can compare all block and SFC types used in the individual projects 
with those of the master data library and update them accordingly. At the same time, you can 
also update the templates in the chart folder of the master data library. 

Assuming that the latest versions are always kept in the master data library, you can use the 
update function to make sure that all or only certain types have the same current version in 
all or selected projects of the multiproject. If the project contains associated instances of the 
types concerned, they are also updated when type synchronization is performed centrally. 

Procedure 
Proceed as follows to update block/SFC types in the multiproject: 

1. Select the block folder or chart folder of the master data library in the SIMATC Manager 
or the blocks or SFCs you want to update in them. 

2. Select the menu command Options > Charts > Update Block Types.... 
Page 1(3) "Select the S7 program to be checked" of the dialog box opens. This lists all 
the S7 programs in the multiproject and they are already displayed as selected. 

3. Check the selection and, if required, exclude the S7 programs in which you do not want to 
update any blocks/SFC types. 
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4. Click "Next". 
A check mark in the "Status" column indicates which programs have already been 
checked.  
When the check is completed, dialog page 2(3) opens. On the "Select the block types or 
SFC types to be updated." page, you can see the types selected in the library that have a 
different version in the individual S7 programs. 

To help you decide whether to select blocks, the "Consequence" column shows you the 
effects of the new import. The following consequences are displayed: 

– All associated instances are modified (no additional consequences!). 

– The OS has to be recompiled  
All associated instances will be modified. You can then launch the wizard to compile 
the OS with the menu command Options > Wizard: "Compile Multiple OSs" > Start... 
or by selecting an OS and using the shortcut menu command Compile. 

– Loading the entire program in STOP operating mode 
After compiling, you can no longer download changes in the RUN operating mode. All 
associated instances are modified. 

Note: When updating SFC types on this page 2(3) the button "Display Differences" is 
shown. When the "Version Cross Manager (VXM)" add-on package is installed, you can 
use this button to open VXM and display the detailed information about the differences. 

5. Check the selection and, if required, exclude those objects you do not want to update due 
to the consequences. 

6. Click "Finish".  
A check mark in the "Status" column indicates which objects have already been updated.  
When the update is completed, you move on to the next dialog box page 3(3), "Log". 
Here, you can see all the information on what took place during the update and the 
results.  
Examples: 

– Start of type synchronization 

– The log path 

– The library 

– The selected objects 

– The selected S7 programs 

– The updated objects 

– End of type synchronization 

7. If you want to print the log, click "Print", otherwise click "Close". The dialog box closes. 

If you stop the update with "Cancel", all the updates made up to this point are retained. 
These are also included in the log. 

You can find additional information in the section: How to update block/SFC types in single 
projects (Page 97) 
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9.4.5 How to update block/SFC types in single projects 

Introduction  
You can update block/SFC types of a library that is not the master data library of a 
multiproject in individual projects of your choice. If the project contains associated instances 
of the types concerned, they are also updated when type synchronization is performed 
centrally.  

Procedure 
Proceed as follows to update types in a single project: 

1. Open the required library in the SIMATIC Manager , for example, PCS 7 Library. 

2. Select the block/SFC types you want to update in a project in the block/chart folder of the 
library. 

3. Select the Options > Charts > Update Block Types.... menu command. 
The "Open Project" dialog box opens. 

4. Select the project in which you want to update the types and click "OK". 
Page 1(3) of the dialog box "Update Block Types" opens. 

5. Follow the steps described in the section: How to update block/SFC types in the 
multiproject (Page 95) (starting at point 3). 

9.4.6 How to delete block types 

Deleting block types from the chart folder 
Call menu command Options > Block Types... to open a dialog box where you can delete 
block types that are no longer required from the chart folder and, if necessary, also from the 
block folder. Select the blocks and click "Clean up" to delete the blocks from the list.  

Clean Up 
Click "Clean up" in the "Block types" dialog box to open two dialog boxes in succession in 
order to delete blocks from the chart/block folders.  

1. “Clean up blocks in CFC” dialog box 
Lists all block types contained in the chart folder which are not used in the charts, in other 
words, no instance blocks exist. 

2. “Clean up blocks in block folder” dialog box 
Lists all block types that exist offline in the block folder that are not used in the CFC (the 
block types do not exist in the chart folder).  
This could also involve block types that are called from other blocks und are normally only 
found in the block folder.  
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Example: The CTRL_PID (FB 61) block, which calls the OP_A_LIM (FB 46) block, was 
deleted in the chart folder, but the OP_A_LIM block is still in the block folder. 

Select the corresponding blocks in each dialog box and delete them from the respective 
target (chart/block folders) with "OK". 
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9.5 Editing blocks 

9.5.1 Editing blocks 

Overview 
The following sections contain information about editing blocks:      

● Inserting blocks (Page 99) 

● Specifying object properties (Page 104) 

● How to copy blocks (Page 109) 

● How to move blocks (Page 110) 

● Deleting blocks (Page 111) 

● How to align blocks (Page 112) 

● How to set I/O parameters (Page 113) 

● What you should know about global block type changes (Page 102) 

  

9.5.2 Inserting blocks 

9.5.2.1 Inserting blocks 

 
To insert a block means that you select a block type and insert it in the chart. You can insert 
the block easily in different ways: 

● Drag-and-drop it from the block or library catalog; 

● If the block is selected, use the <Return> key. 

When a block is inserted, it is assigned a name that is unique within the chart.  

The inserted block is an instance of the block type. You can generate as many block 
instances as required from each block type. 

 

 Note 

The block type comment is not transferred for the block instance. 
 

Each inserted block is assigned default runtime properties, which the user can modify. 
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You can find additional information about inserting blocks in: 

Catalog of blocks, charts, templates and libraries (Page 40) 

Searching for objects in the catalog (Page 322) 

Settings for inserting blocks (Page 100) 

Positioning large blocks (Page 100) 

Inserting unplaced blocks (Page 101) 

9.5.2.2 Settings for inserting blocks 

Default runtime properties 
When inserting a block, you must also specify its runtime properties, for example, the block 
insertion position in the run sequence. 

As default:  
The block is inserted following the block that is displayed in the status bar. 

The status bar displays one of the following: 

● When you first create a chart, the default of the specific PLC 

● The last block to be inserted 

● The block specified by the run sequence 

The current insert point is displayed to the right in the status bar. It displays the following: 

● Task name (OB x) 

● Chart name 

● Name of the block which will serve as the predecessor in the run sequence the next time 
a block is inserted in the CFC chart 

Additional information 
You can find additional information about this in the section: Runtime properties (Page 153) 

9.5.2.3 Positioning large blocks 

Introduction 
You can also insert large blocks, in other words, blocks containing a high number of visible 
block I/Os. To do this, position the block across the horizontal dividing line of two or three 
successive sheets. In this case, a copy of the first block header is inserted immediately 
below the dividing line. 
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Notes 
● If a positioning conflict occurs, the block is shown at this position as an overlapping block, 

light gray and without I/Os. A positioning conflict occurs when a block is inserted at the 
sheet boundary, with the result that only the header can be displayed in the first sheet 
and not all I/Os (to avoid a double header). You can change this layout by moving the 
block slightly in the vertical direction.  
The same applies to "small blocks", in other words, blocks that do not have a body with 
designated I/Os such as "AND" and "NOR". 

● If the block is too large for those three sheets, the I/Os that cannot be displayed will be 
hidden automatically. The maximum number of visible I/Os amounts to 160 inputs and 
160 outputs. You can access all I/Os using the menu command Edit > Object 
Properties.... 

Tip:In order to improve your overview, it is useful to show only the I/Os you are going to use 
for interconnections or monitoring in test mode. 

9.5.2.4 Inserting unplaced blocks 

Unplaced blocks in the catalog 
You can take unplaced blocks from the "unplaced blocks" catalog and position them in the 
chart again. To do this, click the button 

 
 

 Note 

This catalog is only available if unplaced blocks actually exist. 
 

The block name and the complete path (chart name) are specified. This allows you to see 
the block source. Use the shortcut menu command Open Original Chart to open the chart 
from which the block originated. 

You can also insert unplaced blocks from a different chart in the active chart. Previous 
interconnections to blocks or to the sheet bar are not regenerated when the block is 
positioned in the chart again. 
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9.5.3 Global block type change 

9.5.3.1 What you should know about global block type changes 

What is a global block type change? 
When you modify the interface description and/or system attributes of a block type and 
import it to the CFC data management, an existing block type of the same name can be 
replaced and, therefore, updated, by this new version. All block instances of this type will be 
updated to the new block type.  

The ability to modify the global block type relates to FBs and FCs. BOP types cannot be 
changed since they are an integral component of CFC. 

Before the changes are applied, a warning is displayed, pointing out the effects and showing 
data of the old and new block type, such as the name and date of last interface modification. 
At this point, you can cancel the update by clicking “No” or accept the changes by clicking 
“Yes”. 

Global modifications of the type may produce unwanted effects on the block instances. For 
example, interconnections and parameter settings may be lost. In this case, you must modify 
the block instances manually. 

Modifications that result from a global type change are logged and automatically displayed 
following the update. You can also display this log using the menu command Options > 
Logs: Block Types.... If a modification of block instances is required, this log helps you save 
time while also reducing the risk of errors. 

Situations preventing block type change 
If the category of the block type has been changed (for example, FB <--> FC), the block type 
is not changed and a corresponding message is written to the log. 

Additional information 
You can find additional information on this in the following sections:  

Effects of type changes on block instances (Page 102) 

Tolerant type import after data type extension (Page 104) 

9.5.3.2 Effects of type changes on block instances 

Introduction 
In CFC, when you modify the interface description (block I/Os) or the system attributes of a 
block type, all instance blocks are automatically adapted. You should take into account any 
relevant effects of an interface modification. 

Block comments are changed globally in the block instances (overwritten) following a block 
type change, regardless of any previous instance-specific modification.  
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Modification of block I/Os  
Modifications to block I/Os affect the instances as follows: 

● I/O was added: 
The instances will be updated accordingly. The default system attributes will be set. If no 
more space is available at this position after you have increased the block size, the block 
will be displayed as an overlapping block. 
For PCS 7, you can find information below in the section "Effects on WinCC". 

● I/O was deleted: 
The I/O is removed in the instances. If this is an interconnected I/O, the interconnection 
or an SFC access will also be deleted. The deleted interconnection or SFC access is 
entered in the log of the changes.  
For PCS 7, you can find information below in the section “Effects on WinCC”. 

● I/O data type was modified: 
Result of deleting an I/O and of the creation of a new I/O.  
For PCS 7, you can find information below in the section “Effects on WinCC”. 

● An I/O was renamed: 
The reference to the old name cannot be generated automatically by the system. Thus, 
this is the result of deleting an I/O and of the creation of a new I/O.  
For PCS 7, you can find information below in the section “Effects on WinCC”. 

● The order of the I/Os was changed: 
The order of the I/Os is taken into account. The interconnection, parameter assignments 
and attributes will be retained. 

Effects on values, comments and system attributes of the block I/Os 
General guideline on the effects of changing attributes: What cannot be changed for a 
specific instance is updated automatically when the type is changed. 

Values, comments and system attributes S7_string_0, S7_string_1, S7_unit, S7_shortcut can 
only be changed globally at the I/Os of block instances if no instance-specific changes were 
effected previously. This means that only the default type-specific values, comments and 
system attributes will be changed.  

If the system attribute "S7_archive" of a block type is changed, this attribute change is not 
made to existing instance blocks following the type import. 

Effects on WinCC (PCS 7) 
When you modify block type data, DBs with new DB numbers can be created by 
compressing and compiling. In order to maintain the possibility of online access, the data 
must be transferred again to WinCC (OS compilation).  

If this change affects block I/Os intended for operator control and monitoring (attribute 
S7_m_c=true), the following rules apply: 

● An I/O added will be made known and used in WinCC following the OS compilation. 

● After an I/O is deleted, the WinCC tag no longer exists. Any existing interconnections 
must also be deleted in WinCC. 
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● When the name of an I/O is changed, the name of the WinCC tag also changes. 
Interconnections of picture elements, block icons and faceplates must be adapted. 

As a general rule: All changes affecting WinCC are followed by a new OS compilation. 
 

 Note 

Changes to block I/Os have an effect on compilations and downloads. Following an interface 
modification, only compilation of the entire program is possible. If there is already an older 
version of the modified block type loaded, the entire program must also be downloaded. 

 

9.5.3.3 Tolerant type import after data type extension 

Data types 
If the data type for a block type is extended, for example, from INT to DINT, all I/O data will 
be retained during a global type change if the old data type can be mapped on the new one 
without conversion. This applies to the following data types: 

 
BYTE → WORD 
BYTE → DWORD 
WORD → DWORD 
INT → DINT 
STRING1n → STRINGn+m   (e.g. STRING16 → STRING32) 

 

 

 Note 

Remember that interconnections to these I/Os will still be lost due to the global type change. 
 

9.5.4 Specifying object properties 

9.5.4.1 Specifying object properties 

 
The editing of object properties is described in the following sections: 

How to enter block names (Page 105) 

How to enter comments (Page 105) 

How to assign block icons to specific instances (Page 106) 

How to specify the number of I/Os (Page 106) 
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9.5.4.2 How to enter block names 

Introduction 
A name is assigned to the block when you insert it. You can modify this name. The block 
name must be unique within the chart. The CFC verifies this uniqueness. The name has a 
maximum length of 16 characters and is displayed in the block header. Illegal characters: / \ . 
" %. 

 

 Note 

CFC in PCS 7:  

Remember when assigning names that the variable name must not be longer than 128 
characters for transfer to the OS. This name consists of the following components: 
• The name of the folder in the hierarchy path 
• The chart name 
• The block name 
• The separator (period mark) 
• The I/O name (variable name) 

 

Editing block names 
To edit block names, proceed as follows: 

1. Select one or several blocks  
 and then select the Edit > Object Properties... menu command. 

2. Select the "General" tab. 

3. Enter the required name in the "Name" input box. 

4. Confirm your entries by clicking “OK”. 

The dialog box is closed and, if multiple blocks were selected, the dialog box of the next 
block appears. 

9.5.4.3 How to enter comments 

Introduction 
The comment, a user-specific text, appears in the block header. The block header can 
display up to 14 characters of comment. Small blocks do not display the comment. 
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Procedure 
To enter block comments, proceed as follows: 

1. Select one or several blocks  
 and then select the Edit > Object Properties... menu command. 

2. Select the "General" tab. 

3. Enter the required text in the "Comment" input box. 

4. Confirm your entries with "OK". 

The dialog box is closed and, if multiple blocks were selected, the dialog box of the next 
block appears. 

9.5.4.4 How to assign block icons to specific instances 

Block icons 
Blocks intended for operator control and monitoring can be displayed under WinCC by a 
block icon (for example, used for calling a faceplate). 

Different block icons available for a block type can be assigned to specific instances (for 
example, to indicate different type versions: MOTOR block as motor, fan or pump).  

In the “Special object properties” group, specify the block icon displayed under WinCC in the 
“Block icon” input box, using a maximum of 16 characters. 

This input box is only enabled if you have selected the "OCM possible" check box. 

9.5.4.5 How to specify the number of I/Os 

Introduction 
You can add or delete inputs at blocks that have a variable number of inputs of the same 
data type (for example, NAND or OR). 

Procedure 
To change the number of inputs: 

1. Select the corresponding block and then select  
the Edit > Number of I/Os... menu command. 
The dialog box of the same name opens. 

2. Enter the number of inputs (2 to 120) in the input box and click "OK". 

 
  Note 

If the available space is insufficient for the new block length, the block will be displayed 
as an overlapping block that you can move within the chart.  

You can only reduce the number of I/Os down to the lowest interconnected I/O. 
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9.5.5 Copying blocks 

9.5.5.1 What you should know about copying blocks 

Introduction 
You can copy blocks and nested charts both within charts or to other charts. It is also 
possible to copy several or all the objects of a chart at the same time. This allows you to 
duplicate tested substructures quickly and without errors. 

Copying blocks/nested charts 
When copying blocks/nested charts, you must consider the following effects on 
interconnections: 

● Interconnections between objects copied in groups will be retained. 

● Interconnections between copied objects and external elements will be deleted. 

● Interconnections to shared addresses are either copied also or removed, depending on 
the setting in the "Settings for Copying/Moving" dialog box. You can display this dialog 
box using the menu command Options > Customize > Copy/Move.... 

● Names are retained if possible. A corresponding error number will be appended to the 
names if there is a conflict. 

Runtime properties of copied blocks 
When you copy blocks, the response is basically the same as if you were adding blocks from 
the catalog: 

● All copied blocks will be inserted at the position specified by the currently set 
"Predecessor for Insertion Position". Multiple instances of blocks in a cyclic task are 
transferred and inserted at the end of the OBs. 

● Blocks the CFC will also automatically insert in different tasks (for example, blocks with 
startup relevance) will be inserted according to their task list. 

● The runtime groups will not be copied. Blocks of those groups are installed in their 
previous order according to the block installation pointer of the destination. 

Checking the block types and the system attributes 
When blocks are copied, the block types and the system attributes are compared with the 
existing block types and system attributes in the destination.  
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The check is performed according to the following rules: 

Block type 

● Check the system attributes of the block type. 

● Check the availability of all I/O types. 

● Check the identity of the following names/types: 

– I/O type name (for example, MODE) 

– I/O type (for example, IN_OUT) 

– Data type (for example, DWORD) 

– If data type STRING: Check string length. 

– If data type STRUCT: Check data type. 

● Check the system attributes of the I/Os. 

● Check if the block types (SFC type, other type) are the same in the source and the 
destination. 

System attributes of the block type 

● Check if the system attributes s7_alarm and s7_m_c, which are always available, match. 

System attributes of the block I/Os 

● Check if the system attributes s7_a_type, s7_m_c, s7_link, and s7_param, which are 
always available, match. 

● Check if the optional system attributes s7_server, s7_ts and s7_qc are available and if 
they match. 

– If they are in the source, they must be available in the destination. 

– If they are not in the source, they cannot be available in the destination. 

– If they are in the source and the destination, they must have the same values. 

● Check if the optional system attributes s7_shortcut, s7_unit, s7_string0, and s7_string1 
are available. 

– If they are in the source, they must be available in the destination. 

● The optional system attribute s7_enum is always included when copying within a project. 
If the block is inserted in a different project that does not contain the enumeration in the 
shared declarations, the system attribute is inserted as a numeric value. 

Additional information 
You can find additional information in the following sections: 

How to copy blocks (Page 109) 

How to move blocks (Page 110) 
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9.5.5.2 How to copy blocks 

Requirements  
● There must be enough space in the target chart to paste the copied blocks. 

● The relevant charts must be open. 

● The charts must be located on the same CPU. 

● If you want to copy blocks to other sheets, select the overview or open another chart 
window that displays the destination sheet. 

– You will find further information on the overview in section: Views in CFC (Page 71) 

Copying blocks to other sheets or charts 
You have two copy options: 

Drag-and-drop 

1. Select the blocks you want to copy. 

2. Hold down the <Ctrl> key and the mouse button to drag-and-drop one of the selected 
blocks to the new position in the same or a different chart. 

Copying/pasting 

1. Select the blocks you want to copy. 

2. Click the button for Edit > Copy 

 
The selected blocks will be highlighted. 

3. Activate the chart to which you want to copy the blocks and  
click the Edit > Paste button. 

 
The blocks are inserted in the other chart at the same position, offset by one grid section 
to the right and down. If this position is already occupied by other objects, the blocks are 
displayed as overlapping blocks. Otherwise, they are displayed as usual.  

4. In this case, you can move the blocks to an appropriate position. The AS can also 
execute overlapping blocks. 

Copying blocks to other CPUs 
You can copy blocks from your CPU to external locations. This operation affects functionality 
in the same way as operations for copying charts to a different CPU.  
You will find more information on the installation position in the run sequence in the section: 
What you should know about copying blocks (Page 107) 
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9.5.6 Moving blocks 

9.5.6.1 How to move blocks 

Introduction 
You can move blocks to other chart positions and charts. It is also possible to move block 
groups or all blocks at once.  

Moving blocks has no effect whatsoever on the functionality. This means that the 
interconnections and runtime properties remain the same. Block names are retained if 
possible. A corresponding error number will be appended to the names if there is a conflict. 

Moving blocks within a chart 
You move one or more blocks within a chart as follows: 

1. Select the block(s). 

2. Drag-and-drop the selected block(s) to the new position in the chart. 

In the overview, you can also move blocks to other sheets. 
 

 Note 

“Cut” and “Paste” operations are not possible within the same chart partition. If you move a 
block to another chart partition, the object is inserted in the same sheet and at the same 
position it had in its original chart partition. 

If this position is already occupied by other objects, the blocks are displayed as overlapping 
blocks. otherwise they are displayed as usual. In this case, you can move the blocks to an 
appropriate position. The AS can also execute overlapping blocks. 

 

Moving blocks to other charts 
Requirements 

The chart to which you want to move blocks must be open. 
The charts must be located on the same CPU.  
 

You have two options for moving blocks to other charts: 

Drag-and-drop 

1. Select the blocks you want to move. 

2. Drag-and-drop the block(s) to the new position in the other chart. 
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Cut and paste 

1. Select the blocks to be moved and  
 click the Edit > Cut button. 

 
The selected blocks are highlighted in light gray. 

2. Activate the chart to which you want to move the blocks and  
click the Edit > Paste button. 

 
The blocks are inserted in the other chart at the same position, offset by one grid section 
to the right and down. “At the same position” in this context means that the block is also 
inserted in the sheet with the same sheet number.  
If this position is already occupied by other objects, the blocks are displayed as 
overlapping blocks, otherwise they are displayed as usual. In this case, you can move the 
blocks to an appropriate position. The AS can also execute overlapping blocks. 

 
  Note 

You cancel the cut function when you initiate a function other than Paste after you have 
selected the menu command Edit > Cut. The blocks you cut will remain at their original 
position. 

 

Effects of moving 
Moving blocks has no effect whatsoever on the functionality. This means that the 
interconnections and runtime properties remain the same. Block names are retained if 
possible. A corresponding error number will be appended to the names if there is a conflict. 

9.5.7 Deleting blocks 

9.5.7.1 Deleting blocks 

Deleting blocks 
You can delete one or multiple blocks via the <Del> key or the menu command Edit > 
Delete. 

Deleting blocks from the chart has the following effects: 
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Effects on interconnections 
When you delete blocks, all interconnections between blocks to be deleted and objects you 
have not deleted will be lost.  

If a block output is interconnected to a block that is not to be deleted, a warning is displayed. 
You can then decide whether to continue and delete the block. Instead of the truncated 
interconnections, the block inputs of the block that is not deleted are assigned default 
parameter values. 

Effects on runtime properties 
The following rules apply to the default insertion position in runtime groups: 

● When you select to delete the "Predecessor for Insertion Position" block, the preceding 
object inherits this attribute. 

● After you have deleted all blocks in a runtime group, the installation pointer moves to the 
start of this runtime group. 

Additional information 
You can find additional information on this in the following sections: 

How to delete block types (Page 97) 

Runtime properties (Page 153) 

9.5.8 Aligning blocks 

9.5.8.1 How to align blocks 

Introduction 
The system can align blocks you have inserted in a chart and blocks already assigned 
interconnections.  

Procedure 
1. Select the blocks you want to align. 

2. Select one of the menu commands Edit > Align > Left/Right/Top/Bottom. 
All blocks selected will be aligned to the left/right/top/bottom. 

Result 
The blocks are aligned at the visible edge of the block graphic, not at the frame of the 
selected blocks. The block to the extreme left or right or nearest to the top or bottom 
determines the alignment position for the blocks. 
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If alignment causes a conflict, for example, overlapping blocks, an error message is 
generated and the old layout will be restored. The blocks will not be aligned in this case, not 
even those that do not cause a conflict.  

 

 Note 

This align command is disabled when blocks selected for alignment include an overlapping 
block (displayed in light gray). 

 

9.5.9 Editing I/Os 

9.5.9.1 How to set I/O parameters 

Definition 
In this context, setting parameters refers to the assignment of parameter values and, if 
required, attributes to a block or chart I/O. These might, for example, be texts for unit and 
identifier. Depending on the data type of the I/O, the system verifies the syntax of each 
parameter value and that the numerical range is not exceeded.                  

Assigning global I/O parameters (block/nested chart) 
How to edit the properties of all the I/Os of an object: 

1. Double-click the object 

or  

select the object, followed by the menu command Edit > Object Properties.... 

The "Properties - Block" or "Properties - Chart" dialog box opens. 

2. Open the "I/Os" tab. 

This tab contains a list of all the inputs and outputs. 

You can find additional information on this in the section ""Properties - Block/Chart" dialog 
box, "I/Os" tab (Page 315)". 

3. You can sort the I/Os in the table before you set the parameters. This sorting order is 
temporary and restored to the original order when you close the dialog box. 

Click a column title to sort all I/Os again. Each click toggles the alphabetical order: 
ascending/descending. The sorting order of columns with selection boxes is determined 
by: not active / active. The "#" column indicates changes to the sorting order. 

4. Make your entries in the fields that are not grayed out. 
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Configuring single I/Os 
You change the properties of an individual I/O as follows:  

Double-click the required I/O 

or  

Select the required I/O, followed by the menu command Edit > Object Properties....  

The "Properties - Input/Output" dialog box opens. 

The dialog elements such as input boxes and check boxes are displayed differently in the 
dialog. The display depends on the data type and the other properties of the I/O. Some of 
the elements may be read-only (for example "Block:") and some boxes may have the 
following properties: 

● Not visible at all 

● Visible but disabled (grayed out and cannot be edited) 

● Active (can be edited) 

Input of units 
In the corresponding properties dialogs, you can either enter the unit input directly or select it 
via a drop-down list. The drop-down list contains all units that were installed as the basic set 
with CFC. The user can add to or modify these units according to the PCS 7 application.  

You can find additional information on this in the section "Configuring Shared Declarations 
(Page 143)". 

Advantages 

Using the drop-down list for selection has the following advantages: 

● The units benefit from consistent notation in the various applications (for example, 
process tag list, CFC Editor and SFC Editor). 

● There is no need for the painstaking keyboard input of special characters such as "°C". 
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9.5.9.2 How to invert inputs 

 
Interconnected binary inputs (of block and chart I/Os) can be inverted, In this way "0" 
becomes "1" and "1" becomes "0". 

Inverting interconnected binary inputs 
1. Select the input. 

2. Click the button on the toolbar 

 
or  
select the Edit > Invert Input.... menu command. 

or alternatively 

1. Double-click the input.  
The "Properties - Input/Output" dialog box opens. 

2. Select the “Inverted” check box. 

The input will be inverted and identified by a dot. 

Canceling the inversion of an input 
Execute the "Invert Input" function once again to cancel the inversion.  

You can also cancel the inversion by performing the following actions: 

● Delete the interconnection of the inverted input 

● Move the interconnection to a different input 

● Interconnect the input again 

Points to note 
Please note the following: 

● If you copy a signal from an inverted input to another input, the new input will not be 
inverted automatically. The inversion must be done explicitly. 

● If you move an interconnection from an inverted input to non-inverted input, the new input 
is not automatically inverted. The inversion is canceled at the input that is no longer 
interconnected. 

● Inputs assigned to a chart I/O cannot be inverted.  
Remedy: Insert a NOT block. 
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9.5.9.3 Value identifiers at block/chart I/Os 

Creating value identifiers 
Using the value identifiers, you can define symbolic names (texts) for the parameter values 
of the block or chart I/Os. The system attributes below are available for the definition when 
creating block types or chart I/Os: 

● "S7_enum" 

● "S7_string_0" to "S7_string_25" 

The system attributes below can be used for different values: 

● "S7_string_0" and "S7_string_1" exclusively for binary values (data type: BOOL) 

● "S7_string_2" to "S7_string_25" for integer values (data type: BYTE, INT, DINT, WORD, 
DWORD) 

● "S7_enum" for binary values and integer values (data type: BOOL, BYTE, INT, DINT, 
WORD, DWORD) 

 
  Note 

When using the system attribute "S7_enum", system attributes of the type "S7_string_0" 
through "S7_string_25" that may exist at the same I/O are not effective. 

The system attribute "S7_enum" requires the object name of an enumeration as a value. 
The enumerations are included in the project as "shared declarations". Every 
enumeration can include several values. For more information, refer to the section: 
Configuring enumerations (Page 144) 

The text for "S7_enum" and "S7_string_0/1" can have a maximum of 16 characters and 
for "S7_string_2...25" it can have a maximum of 8 characters. Only 8 characters are 
displayed. If you have more than 8 characters of text, you can define the characters to be 
displayed. You do this by using the "=" character in the text.  
• If the equal sign (=) is included in the text, the first 8 characters to the right of the 

equal sign are displayed.  
Example: Motor=ON; Motor=OFF4567890; ON or OFF45678 is displayed. 

• If the text does not include the equal sign, the first (left) 8 characters are displayed. 
 

Displaying and modifying value identifiers in the chart 
In the chart, you can specify whether to display the value identifier or the absolute value. 
Select the menu command Options > Customize > Layout.... In the “Customize Display” 
dialog box, you can set or reset the “Parameter: Value Identifier” option. 

In the object properties dialog, you can select value identifiers defined for an I/O. The “Value” 
box will then contain an additional button for opening the drop-down list. From now on, the 
selected value identifier will be displayed at the I/O. 
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9.6 SFC in the CFC 

9.6.1 Inserting SFC types in CFC charts 

 
Analogous to block types, SFC types can be inserted into CFC charts from the block catalog. 
This creates SFC instances, which you can configure and interconnect. They are displayed 
as blocks, the same as CFC instances. 

SFC types are listed in the catalog by family and in the "All blocks" folder. If the "Family" 
attribute is not assigned to the SFC type, it will be displayed under "Other blocks".  

9.6.2 SFC external views in CFC charts 

 
The SFC external view as of V6.0 replaces the control block SFC_CTRL. 

In order to enable control of the SFC chart by means of CFC interconnections, it is assigned 
an interface derived from the interface of the SFC runtime system. It is displayed in the CFC 
as a block by a chart symbol, analogous to a nested chart. The block name is identical to 
that of the SFC chart and cannot be modified here. 

The external view is displayed in a separate window of the CFC. In this window you cannot 
insert any additional objects, for example, blocks. Interconnections can be executed as usual 
in CFC, for example, textual interconnections, interconnections to shared addresses and 
block/chart I/Os.  

When printing the external view locally, it is printed like a CFC chart without the interface. 
 

 Note 

You can print interface I/Os in the form of a table in the SFC editor (print: external view). 
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9.7 Creating and working with interconnections 

9.7.1 How to create block interconnections 

General information about block interconnections  
A block interconnection is the connection between the output of a block and one or more 
inputs of another or the same block. The data types of the input and output must be 
compatible. 

Interconnected blocks can be located in the same sheet, in different sheets of the same 
chart or in different charts. The interconnection partner can also be located in another chart 
folder of the project or in another project of the same multiproject. Refer also to the section: 
Setting up AS-wide interconnections (Page 120)  

You can interconnect I/Os in the chart overview or sheet view. 

A special form of a block interconnection is the textual interconnection, in other words, the 
interconnection partner can be located in a different chart folder. 

A sheet bar entry is always generated when there is an interconnection to an object that is 
not located within the active sheet. If entries cannot be made in the sheet due to lack of 
space in the sheet bar, overflow pages will be created automatically. 

A sheet bar entry is also generated the moment an interconnection within the sheet leads to 
a hidden I/O. The entry is labeled with the text "INVISIBLE" after the I/O name. This 
additional text in the sheet bar is available even when an I/O for interconnections across 
sheets is hidden. 

Textual interconnections and interconnections to shared addresses or to runtime groups 
have no sheet bar entries when the I/O is hidden. These interconnections can only be 
recognized in the object properties of the block ("Interconnection" column of the "I/Os" tab). 
The same applies when both interconnection partners have been switched to invisible. 

 

 Note 

Please note the following: 
• If the output of an FB is interconnected to an INOUT I/O of an FC, the FC writes to the 

instance data block of the FB. 
When the FB reads this output in its algorithm (and not only writes), this may lead to 
problems or malfunctions of the output due to the FC. 

• Note that the block outputs have specific default values and may affect other blocks when 
the CPU starts up if they have already been executed. 

 

The correct startup response of the blocks is the responsibility of the project engineer. 
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Procedure 
Create block interconnections as follows: 

Single or multiple interconnections 

1. Select the output you want to interconnect. 

2. Click the input you want to interconnect to the selected output.  
You can repeat this procedure to create multiple interconnections for this output.  
You can select the I/Os in any order. You can also click the input first and then the output. 
Multiple interconnections also function in this way. 

Sequential interconnections 

1. Select the output you want to interconnect. 

2. Press and hold down the <Shift> key and then click the target inputs you want to 
interconnect to the selected output, working in successive order. 
With sequential interconnections, you must keep to the order output → input. 

Interconnecting via drag-and-drop  

1. Click the output you want to interconnect and hold down the left mouse button. 

2. Drag the cursor to the target input.  
You can select the I/Os in any order here. You can also drag an input to an output to 
interconnect them. 

The interconnection is usually displayed as a line, in exceptional cases as a connector. This 
happens when a line cannot be drawn due to lack of space or if no additional entries can be 
made in the sheet bar.  

Tips 
● You can easily create interconnections across sheet or chart boundaries by opening the 

sheet view of several windows simultaneously. 

● You can also create interconnections across sheet boundaries in the overview. 

Additional information 
You can find information about the layout of interconnections in the section  

Layout of interconnections (Page 66)  

You can find information about interconnections with S7 in the following sections: 

How to interconnect to shared addresses (Page 122)  

Working with textual interconnections (Page 128)  

How to create and delete interconnections with runtime groups (Page 133)  

Creating interconnections to chart I/Os (Page 133)  

Interconnection rules for chart I/Os (Page 134)  

Interconnection rules for data types A, DT, S, and ST (Page 140)  

Interconnecting with SFC Charts (Page 127)  
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9.7.2 Setting up AS-wide interconnections 

General information on AS-wide interconnections  
With the CFC, you can set up interconnections to partners located on other automation 
systems. Interconnection partners are always block I/Os. Requirements for AS-wide 
interconnections: 

● The PLCs involved are located in a common project or multiproject. 

● The network configuration has been performed with NetPro. 

Setting up AS-wide interconnections  
You make the interconnection as you would for a chart-wide interconnection. To do this, 
open both charts and arrange them in the CFC in such a way that you can connect the 
source to the destination; in other words, click on the I/O to be connected in one of the charts 
and then click on the I/O partner in the other chart. 

For connections, an interconnection line is drawn to the sheet bar. The AS-wide 
interconnection is marked as a green triangle in the small field of the sheet bar. The 
project/station/CPU type or hierarchical path and chart name/block/connection is entered in 
the large box. 

Notes on AS-wide interconnections 
● You can also perform a jump from the sheet bar to track signals with an AS-wide 

interconnection. The interconnection is then displayed flashing in the other chart. 

● Only the S7 target system is supported. 

● AS-wide interconnections to addresses and runtime groups are not possible. 

● S7-300 CPUs are not supported. 

● F programs are not supported and F blocks cannot be interconnected AS-wide. 

● The fastest possible cycle for an AS-wide interconnection is 200 ms. In the case of an 
AS-wide interconnection, the cyclic interrupt OB30 - OB38 must be parameterized in such 
a way that its cycle times and priorities relate to each other. The faster the cycle time, the 
higher the priority must be. 

● The maximum transmission volume between 2 partner CPUs in an OB is 4800 bytes. 

● STRING, ANY and POINTER data types are not supported. 

● An AS can communicate with a maximum of 15 partner AS. 

● I/Os of nested charts cannot be interconnected AS-wide. 

● AS-wide interconnections between an H station and an S7-400 station are not possible. 

Maximum number of AS-wide interconnections 
A maximum of 200 AS-wide interconnections are permitted per OB.  
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 Note 

It may no longer be possible in the current version to compile a program with AS-wide 
interconnections that could be run with the previous version. This is the case if the default of 
30% maximum CPU load for AS-wide interconnections in this program has been exceeded. 
If you increase this default to the correct value, then you will be able to compile the program 
once again. 

You can view and change the default in the dialog box "Settings for Compilation/Download" . 
 

Effects of moving a project 
If you move a project out of a multiproject that is the source or destination of an AS-wide 
interconnection, the interconnection partner is recorded in the ES database. The 
interconnection to the sheet bar is retained; the sheet bar entry is deleted and replaced by a 
question mark. 

When the project is reintegrated, the previously existing AS-wide interconnection is 
automatically reestablished upon update (F5) if the interconnection partner is available 
unchanged as before.  

 

 Note 

Moving projects from the current (multi) project can lead to single-sided AS-wide 
interconnections if the AS-wide interconnection is deleted from a project but remains intact in 
the other when disconnected. If the last AS-wide interconnection is deleted from a project 
when disconnected, the inherent partner connection is deleted as well. As soon as the 
moved project is reconnected, a single-sided interconnection is created (identified by 
question marks in the sheet bar of the CFC chart). This single-sided interconnection then 
generates a warning in the code generator and is not loaded into the AS. 

You will find information on eliminating one-sided AS-wide interconnections in: 
Synchronizing AS-wide interconnections (Page 311) 

 

General information on the procedure  
Once AS-wide interconnections have been created, the affected S7 programs need to be 
compiled and loaded. The S7 connection in NetPro must not be deleted manually. The 
NetPro IDs cannot be changed.  

To view the NetPro IDs, follow these steps: 

 
• Select the chart reference data. In the CFC click the button: 

 

• In the "View" menu, select the menu command "AS-wide interconnection"  

You can now read the NetPro IDs from the table. 
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The user does not need to undertake any special measures to perform the data transfer via 
the AS-wide interconnection. The blocks required for the data transfer are made available 
and loaded by the ES when loading is performed. These blocks are not instanced in the 
chart and cannot be seen in the catalog. The data transfer is called directly from the 
corresponding OBs of the AS (OB1, OB3x). The handling instructions are located in special 
DBs created by the code generator and transferred from the loader to the CPU. 

The "IK STATE" block is located in the "ELEM_400" folder in the CFC library. This can be 
integrated into the program in order to respond to communication errors in the process. You 
can find a description of the "IK STATE" block in the Help for CFC elementary building 
blocks > AS-wide blocks > IK STATE 

If the last AS-wide interconnection is deleted, the S7 connection in NetPro is also deleted. 
Following this, compiling and loading is required. 

9.7.3 How to interconnect to shared addresses 

Introduction      
Shared addresses are interconnection partners outside the CFC charts, for example, shared 
data blocks, I/O signals, bit memories, timers, and counters. You can specify the addresses 
in symbolic or absolute form. You must, however, keep to certain conventions. 

Interconnections to shared addresses are inserted and identified in the sheet bar by a small 
blue triangle. 

 

 Note 

If the interconnection begins at an I/O that has been subsequently switched to hidden, the 
sheet bar entry is also deleted. You can then only recognize the interconnection in the object 
properties of the block/chart in the "Interconnection" column of the "I/Os" tab. 

 

Procedure 
1. Select the input/output and  

select the Interconnection to Address... 
 command from the shortcut menu,  
or click the button in the toolbar 

 
The address selection list appears at the I/O, consisting of: 

– The input box (upper row) for editing the shared address 

– Table of all symbols in the current symbol table for the selected data type 
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  Note 

The address selection list will possibly be displayed in minimized format at the block 
I/O when you open it, in other words, only the input box is visible. Use the cursor to 
optimize the selection list size in order to display the entries in the symbol table also. 

 

2. Specify the address as follows: 

– Enter the symbolic name or absolute address in the input box 

or 

– Select the symbol required. 

3. Select a symbol or double-click the line of the selected symbol. 

4. Press <Return> in the edit box  
or 
click an area outside of the box. 

The address selection list is closed. 

Press <Esc> to exit without saving your selection. 

Result 
A sheet bar entry will be generated that refers to the target of the interconnection. 

Note on input of the address 
● Based on syntax rules (see Help on the symbol table, section "Permissible addresses 

and data types in the symbol table"), the CFC can detect whether you have input an 
absolute or a symbolic address. 

● Absolute addresses (depends on the address type) can only be interconnected to block 
I/Os of the type BOOL, BYTE, WORD, or DWORD. Alternative data types (BYTE -> 
CHAR; WORD -> INT, S5TIME; DWORD -> DINT, REAL, TOD, TIME) can only be 
interconnected to symbolic addresses. For this purpose, the data type required is also 
specified in the symbol table (“Data type” column). 
See also "Absolute addressing without entry in the symbol table". 

● The entry of an absolute address is not case-sensitive and may or may not include empty 
strings, for example, e1.1, E1.1, e 1.1. The permitted range of values depends on the 
type of CPU. Syntactical write errors in absolute addresses may cause the CFC to 
misinterpret the entry as a symbol! 

 
  Note 

Always comply with CPU-specific limits. Otherwise you cannot download the compiled 
program to the CPU and a download error message appears. 

 

● Symbolic addresses are enclosed by upper quotation marks in the sheet bar of the chart. 
You can thus check how the CFC has interpreted your entry, in other words, as a 
symbolic or an absolute address. 
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● The following addresses cannot be accessed via the CFC:  
OB, SDB, SFB, SFC, UDT and VAT 

● Absolute access to DB elements is possible. The following samples show the permitted 
syntax: 

 
Address Access to 
DB10.DW20 Data block 10, word 20 
DB20.DX2.1 Data block 20, bit 2.1  

The notation DB20.DBX2.1 is also tolerated as input, but "B" is not accepted 
and not shown in the sheet bar. 

● Mixed addressing of DB elements is also allowed. 
Example: DB10.DW11, DB10.Valve, Mixer.DW8, Mixer.Valve 

● ANY I/Os, for example, SD_1 for SFB 12/BSEND, can also be interconnected with a 
complete data block (shared address, absolute, for example -> DB1 or symbolic). The 
complete length of the DB is transferred. Entire data blocks can thus be transferred.  
The individual elements of the data blocks (even STRUCT) can be accessed through the 
interconnection to the DB element. This allows for the easy assembly and evaluation of 
the data to be transferred. 

● If you want to use a symbolic address although the symbol has the syntax of an absolute 
address, you must enclose the symbol in double quotes.  
Example: "Q1.1", "DB10".Valve. 

Accessing the symbol table 
Call the menu command Options > Symbol Table to open the symbol editor for editing 
entries in the symbol table.  

Chart update 
Select the menu command View > Update or press <F5> to open the dialog for updating 
symbols, addresses and block types in the CFC charts of the active chart folder, based on 
the symbol table. 

Please note the STEP 7 conventions when you make entries in the symbol table.  

Important points on interconnecting 
When interconnecting shared addresses, note the following relationships and options: 

● You can interconnect block I/Os with an address in absolute or symbolic form. If the 
symbol is already defined in the symbol table and has a comment, you will see the 
symbol comment in the sheet bar. 
You can also enter the symbol in the symbol table at a later point in time. CFC recognizes 
the symbol when the chart is updated. 
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● If a shared symbolic address is not yet available in the symbol table, an error warning is 
output during compilation and the following actions will be triggered: 

– Input: the code will be generated and the default value of the block type will be set for 
the interconnection. 

– Output: The interconnection is ignored in the generated code. 

● When interconnecting to a symbol, you can also rename the symbol in the symbol table. 
CFC recognizes the modifications during a chart update. 

● If you want to change the context of the symbol, delete it from the symbol table and 
create a new one. 

● Do not interconnect the EN input of startup blocks, for example, CONT_S, that are 
located in the process image, for example, I5.1, otherwise the startup function will not be 
enabled. 

● If a STRUCT I/O of an instance block is interconnected with a shared data block and the 
structure name of the shared data block is subsequently changed, this change will not be 
detected during compilation. The change is updated in the ES data management only 
after closing and reopening the CFC chart. 

This also applies if the names of elementary data types are changed. 

● If the name of symbolic and absolute address are identical, the absolute address is used 
during interconnection. 

Modifying the interconnection to the address 
Double-click the large field of the sheet bar (for this interconnection) to open the address 
selection list showing the default in the input box. You can modify (overwrite) this entry, 
delete it via the <Del> key or select another symbol from the list. 

Absolute addressing without entry in the symbol table 
Absolute addressing is also possible if a symbol does not exist in the symbol table for the 
absolute address or DB number.  

Note the following rules: 

● The address must not occupy the range that is reserved for CFC chart compilation. 

● The address must not be located in a value range that does not exist for the current CPU. 

● The address must match the data type of the linked element. 

You can find additional information on interconnections to shared addresses in: 

Possible interconnections between symbols and data types (Page 127) 

Examples of symbolic addressing (Page 126) 

Examples of absolute addressing (Page 126) 
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9.7.4 Examples of symbolic addressing 

Symbolic addresses 
The following examples illustrate the options when specifying symbolic addresses: 

 
Address Remark 
Limit switch For example access to an input bit.  

The absolute address is defined in the symbol table. 
Recipe. Setpoint Access to a data block (recipe).  

The structure or the type of the data block determines the data block element 
(setpoint). 

"I5.1" Access to the symbol with the name I5.1. To avoid the absolute address with the 
same name being addressed instead of the symbol, the symbol is enclosed in 
quotation marks. 

9.7.5 Examples of absolute addressing 

Absolute addresses 
The following examples illustrate absolute addressing: 

 
Address Remark 
I5.1 Access to input 5.1 
i5.1 Access to input 5.1 
M6.7 Access to memory bit 6.7 
MW10 Access to memory word 10 
DB10.DW20 Access to data block 10, data word 20 
DB20.DX2.1 Access to data block 20, bit 2.1 (syntax also: DB20.DBX2.1) 
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9.7.6 Possible interconnections between symbols and data types 

Valid data types 
The table shows which symbols with the specified data length can be interconnected to the 
block I/Os of which data types. You must then also enter the corresponding data type of the 
block I/O in the symbol table. 

 
Data length Address Symbol Block I/O data type 
8 bits IB, QB, MB, PIB, PQB BYTE, CHAR 
16 bits IW, QW, MW, PIW, PQW WORD, INT, S5TIME 
32 bits ID, QD, MD, PID, PQD DWORD, DINT, REAL, TOD, TIME 

9.7.7 Interconnecting with SFC Charts 

SFC access 
A special form of interconnection is direct SFC access from actions or transitions to I/Os of 
the block or nested chart in the CFC chart. This type of SFC access can be "rewired" in the 
CFC chart, in other words, it can be moved from one I/O to a different I/O of a compatible 
data type. If the I/O is interconnected, you can decide whether only the SFC access or also 
the interconnection will be moved. 

● Move only the SFC access  
Drag the selected I/O to the new I/O while holding down <Alt>. The SFC access symbol 
is moved to the new I/O. Existing interconnections will not be included. 

● Move interconnection and SFC access 
Drag the selected I/O to the required new I/O. You will be prompted to include the SFC 
accesses. If you click “Yes”, the interconnection and the SFC access are moved. If you 
click “No”, only the interconnection is moved. 

● Delete the SFC access 
You cannot delete an SFC access in the CFC. 

Access markers 
In the CFC chart, a marker at the I/O identifies SFC accesses. Write and read access are 
indicated differently. 

Markers have the following meanings: 

● A marker above the I/O = "read access" 

● A marker below the I/O = "write access" 

The color of the marker is identical to the interconnection color indicating a specific data 
type. 
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SFC references 
You can display SFC references as follows: Double-click the block I/O to open the 
“Properties - Input/Output” dialog box. When I/Os with SFC access are used, this dialog box 
contains the “SFC Access…” button. Click this button to open an additional dialog box that 
contains a list of SFC references. 

The reference contains the names of the SFC chart, SFC object (step name/transition name) 
and the object type (step/transition) and type of access (write/read). 

Double-click the chart name of a listed object to open the relevant SFC chart where the 
referenced object is highlighted. 

9.7.8 Working with textual interconnections 

What is a textual interconnection?  
A textual interconnection can only exist at one block/chart input and always refers to a block 
or chart output in the CFC. The textual interconnection remains "open" until it is converted 
into a "real" interconnection by closing it.  

A textual interconnection you can close equates to the addressing of an input using a 
character string that identifies an interconnection source (output) through the pathname.  

How is a textual interconnection created? 
A textual interconnection is created as follows: 

● Automatically as a path reference (chart\block.I/O) including the PH path (if it exists), by 
copying or moving it to a different chart folder. 
After copying, the textual interconnection is generated at the input of the copy; after 
moving, it is generated at the moved object as well as at the previous object, if the 
corresponding output is no longer located in the same chart folder. The interconnection is 
deleted at the output if the input is no longer available in the same chart folder. 

● Via user action at the input: Select the input or open the shortcut menu and select the 
menu command Insert > Textual Interconnection. 
– As a path reference (chart\block.I/O) with PH path (if it exists).  

The interconnection is closed as soon as the interconnection partner is available in the 
chart folder. If the interconnection partner is not available in the chart folder until a 
later point, the interconnection can be closed via menu command Options > Make 
Textual Interconnection. A real block interconnection is created. 

– As an interconnection request (any character string that does not contain a defined 
path reference, for example, a comment). 
This interconnection request cannot be closed (warning in the log); the user must 
close it manually in the project. 

● If the data type of interconnected I/Os no longer matches due to global modification of the 
type. 
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Note that a textual interconnection is created under the following conditions: 

● When the source of an interconnection is deleted. 
The real interconnection is deleted in this case. 

● When the interconnection source of internal interconnections to chart I/Os is deleted or 
moved (nested chart or block). 
The chart I/O assignment is lost in this case. 

● When the global modification of the type involves renaming with interface modification. 
Note: The interconnection is retained if you only change names without modifying the 
interface. 

Representation in the sheet bar 
With an open textual interconnection, the interconnection partner does not exist in the chart 
folder or the reference does not correspond with an existing block I/O.  
The large box of the sheet bar displays the one line of text you have entered.  
The small box displays a yellow triangular identifier. 

 
 

 Note 

Please note the following: 
• If the I/O with the textual interconnection has been hidden, there is no sheet bar entry. 

These interconnections can only be recognized in the object properties of the block 
("Interconnection" column of the "I/Os" tab). 

• The block with a hidden interconnection is indicated by a colored triangle in the top right 
corner of the block header. 

 

By closing the textual interconnection, you convert it to a real interconnection; that is, to a 
normal block interconnection. The small box no longer displays the identifier (yellow 
triangle). 

 

Representation in the sheet bar for AS-wide interconnections 
You can see the path to the AS-wide interconnection in the large field of the sheet bar. A 
yellow triangle is shown in the small field to indicate that the textual interconnection is open. 

 
This is converted into a real interconnection by closing the textual interconnection. The 
yellow triangle in the small field is replaced by a green triangle. 
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With AS-wide interconnections, care must be given to the syntax of the path in the large 
field. It is important to distinguish whether or not the chart is integrated in the plant hierarchy. 

● The syntax without plant hierarchy 

– Project\\Station\CPU\Program\\Chart\Block.IO 

● The syntax with plant hierarchy: 

– Project\\Hierarchy Path\\Chart\Block.IO 

Modifying a textual interconnection  
You can modify an existing textual interconnection as follows: 

● Rewire it to another input of the same data type. 
You will find more information on this topic in the section: How to modify (rewire) 
interconnections (Page 137). 

● Edit the text in the sheet bar 
Double-click the entry in the sheet bar (small or large box) to open the dialog box in which 
you can enter your new text. The previous text is selected and can be overwritten. 

● Replace the textual interconnection: 

– Via an interconnection to a shared address 
Select the input or text from the sheet bar then select the shortcut menu command 
Interconnection to Address....  
For more information, refer to the section: How to interconnect to shared addresses 
(Page 122) 

– Via an interconnection to a chart I/O 
Select the input or text from the sheet bar and then select the shortcut menu 
command Interconnection to Chart I/O.... This dialog box shows a list that contains all 
configured chart I/Os of the active chart and the I/O type (IN, OUT, IN_OUT). 

Closing open textual interconnections 
Once all interconnection partners are available in the chart folder, you can convert the 
textual interconnections into real interconnections.  

Use the menu command Options > Make Textual Interconnections to close all textual 
interconnections of the current chart folder.  
You cannot close single textual interconnections.  

The log generated lists all closed textual interconnections and any that are still open. Call 
this log with the menu command Logs > "Textual Interconnections" tab . 

The following applies to compiling: 

If one or several textual interconnections are not closed, a corresponding log entry is 
generated. You can view this entry with the menu command Logs > "Compile" tab.  
The data is compiled and a substitute value is generated for the corresponding input (default 
value of the block type). An interconnection at the output is ignored. 
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Deleting and finding textual interconnections 
Use the menu command Options > Delete Textual Interconnections... to open a dialog box 
that contains a list of all textual interconnections.  

This dialog box offers you the following options:  

● You can obtain an overview of all existing textual interconnections in the current chart 
folder. Click "Cancel" to exit the dialog box without deleting the interconnections. 

● You can click "Go To" to open the chart in which the interconnection was implemented. 
The interconnection is displayed flashing. 

● You can select textual interconnections and click "Delete" to delete them from the chart 
folder. The interconnections are deleted immediately without any prompt for confirmation. 

General information 
Please observe the following information: 

● A textual interconnection consists of a maximum string length of 512 visible characters. 

● A textual interconnection cannot co-exist with a closed interconnection or another textual 
interconnection. 

● When you close a textual interconnection, all actions and error messages are listed and 
displayed in the log file. You can open the log file with the menu command "Options > 
Logs > "Make Textual Interconnections" tab. 

● Open textual interconnections are tolerated when you compile the program. A warning is 
generated and the following actions are performed: 

– Input: The code is generated and the default value of the block type is applied to the 
open interconnection. 

– Output: The interconnection is ignored in the generated code. 

● If an I/O with a textual interconnection is switched to invisible, the sheet bar entry is 
deleted. You can then only recognize the interconnection in the object properties of the 
block/chart in the "Interconnection" column of the "I/Os" tab. 

● If an I/O is negated with a textual interconnection, this negation is not displayed in the 
technological editor. 

Additional information 
You can find additional information on textual interconnections in the section:  

Textual interconnections in branched and merged project data (Page 132) 
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9.7.9 Textual interconnections in branched and merged project data 

Introduction 
When branching projects into separate configurable segments and merging them again at a 
later point, note the following peculiarities and aspects that apply to the textual 
interconnections. 

Sequence and procedure 
When you split a project (which we refer to here as a "master project"), you copy parts of a 
chart folder to one or several other chart folders, for example, to temporary projects ("branch 
projects") for different project engineers. This action usually concerns the interproject 
transfer of one or several (but not all) charts. Interconnections across chart boundaries are 
converted into textual interconnections at the input side and deleted at the output side. 

When you return the edited charts to the master project (copy or move), the application 
recognizes charts with identical names in the master project. In this case, you are prompted 
to overwrite the existing object. If you click "No", the chart is inserted as a copy ("None", if 
multiple charts are involved). If you click "Yes", the existing chart is overwritten ("All", if 
multiple charts are involved). The corresponding chart is deleted from the master project 
prior to the transfer of the chart from the branch project. In this case, contrary to a normal 
deleting action (<Del>), textual interconnections will be generated.  
Select the menu command Options > Make Textual Interconnections to reconvert them into 
real interconnections.  

Rather than copying charts to other projects, you can also move them using "Cut" and 
"Paste". Copying, nonetheless, has the advantage that the edited charts have the safety 
level of a fully functional (master) project until they are returned. 

 

 Note 

Please note the following: 
• You must not rename any of the interconnection partners in a "broken" interconnection, 

since it will be impossible in this case to close the textual interconnection. 
• Modifications of charts in the master project are canceled if charts with identical names 

are returned from the branch projects to the master project. 
• An interconnection might be generated unintentionally in the master project, for example, 

when you modify interconnections that exceed chart limits in the branch project and 
subsequently return only a single chart to the master project. 
Example: Chart CFC_A contains an interconnection to a block in the CFC_B chart. Both 
charts are copied to a branch project for additional editing. In this case, the 
interconnection between both charts will be deleted. Only CFC_A is returned to the 
master project. A textual interconnection that you can actually close will be generated in 
the CFC_B chart of the master project. Result: The interconnection that was deleted in 
the branch project exists again in the master project. 

• Textual interconnections generated prior to a copy/move action are applied to the target 
project. This can be a defined path reference (that can be closed) or any character string 
(interconnection request that is actually configured in the target project). 
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9.7.10 How to create and delete interconnections with runtime groups 

General 
You can enable and disable runtime groups dynamically. This means that the output value of 
a block decides whether or not a particular runtime group will be executed. In order to 
achieve this, connect the binary block output to the enable attribute of the runtime group. In 
this case, the setting of the “Active” option in the object properties of the runtime group is not 
taken into account.      

A small red triangle in the sheet bar indicates interconnections to runtime groups. 
 

 Note 

Please note the following: 
• If the interconnection begins at an I/O that has been subsequently hidden, there is no 

sheet bar entry. You can then only recognize the interconnection in the object properties 
of the block/chart in the "Interconnection" column of the "I/Os" tab. 

• The block with a hidden interconnection is indicated by a colored triangle in the top right 
corner of the block header. 

 

Creating an interconnection 
1. Select the binary output you want to interconnect, followed by the menu command 

Insert > Interconnection to Runtime Group.... 

The dialog box "Insert Interconnection to Runtime Group" appears. This contains a list of 
all CPU tasks and runtime groups. 

2. Select the task containing the required runtime group from the list. 

The list of runtime groups is sorted accordingly. 

3. Select the runtime group and click "OK". 

The dialog box closes. The interconnection is entered in the sheet bar. 

Delete interconnection 
Click the small or large box in the sheet bar and press <Del>. 

The interconnection to the runtime group is deleted. The interconnection is deleted 
automatically when you delete the runtime group.  

9.7.11 Creating interconnections to chart I/Os 

Interconnecting chart I/Os 
You can create interconnections to chart I/Os from blocks or from nested charts with chart 
I/Os.    
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You have the following options: 

● Interconnect I/Os to existing chart I/Os 

● Create the chart I/Os at the same time as the interconnection 

A small white triangle in the sheet bar indicates interconnections to chart I/Os. 

You can find additional information about chart I/Os in: 

● How to create a chart with chart I/Os (Page 87) 

● Interconnection rules for chart I/Os (Page 134) 

  

9.7.12 Interconnection rules for chart I/Os 

Interconnection rules 
The following rules apply when interconnecting chart I/Os:  

● Block I/Os interconnected internally cannot be interconnected with a chart I/O. 

● A block input of the type IN can be interconnected with chart I/Os of the type IN or 
IN_OUT. 

● You can interconnect a block I/O of the data type ANY with chart I/Os of any elementary 
data type (exception: not with pointers). 

● The compatibility of data types of the I/Os you are interconnecting may differ on the 
various target systems. If there is a data type incompatibility, an error message is 
displayed when you make the interconnection. 

● You cannot configure chart output parameters.  
Remedy: Set parameters for the output in the block. This value is then entered in the 
corresponding chart output. 

● Structured data types of FC outputs cannot be interconnected with chart I/Os. 
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9.7.13 Signal tracking 

Tracing interconnections 
Even if numerous interconnections are displayed in a sheet, you can nevertheless track the 
path of a specific interconnection as follows: 

● Click the displayed line or the large field in the sheet bar. 
All lines and sheet bar entries, including those in overflow pages, connected to the 
selected line will flash on-screen. Signal tracking is also possible along branched lines 
and beyond break connectors. 

● From the chart I/O of a nested chart, you can track the signal to the I/O that is 
interconnected internally with this chart I/O.  
In the shortcut menu, select the command Track Signal. This opens the nested chart; the 
interconnection and the sheet bar entry flash. 

You can track an interconnection that leads into a nested chart over the sheet bar to the 
interface by opening the shortcut menu for the I/O or the sheet bar entry and selecting the 
menu command Jump from Sheet Bar. The higher-level chart is then opened and the 
relevant I/O of the nested chart is selected if it is not interconnected. If the chart I/O is 
interconnected, the interconnection flashes. 

● To disable the flashing, simply click a different position in the chart. 

Signal tracking is also possible with Jump from Sheet Bar.  

You can find additional information about this in the section: Jump from Sheet Bar 
(Page 136) 
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9.7.14 Jump from Sheet Bar 

 
With “Jump from Sheet Bar”, you can move quickly to the interconnected block on the other 
sheet of the current chart or another chart from a sheet bar entry of a sheet or an overflow 
page: 

● If you jump from the sheet bar entry or from an I/O with a single interconnection, the jump 
is made directly.  
The sheet or chart in which the interconnected block or nested chart is located appears. 
With block interconnections and interconnected chart I/Os, signal tracking is activated 
(line flashes). If the I/O of a nested chart is not interconnected, the relevant chart I/O is 
selected. 

If the destination of the jump is an overlapping block, the block alone is fetched to the 
center of the screen and selected. Since I/Os and connecting lines cannot be displayed, 
signal tracking is not possible in this situation. 

● If you jump from the sheet bar from an output with a multiple interconnection, a dialog box 
opens with a list of the interconnections of this output. The jump is executed when you 
double-click the output required or select it and confirm with “OK”. 

● You can use the Edit > Go To > Jump Back menu command to return to the point at 
which you started the jump even if you have closed the selected chart or have deleted the 
block. 

You can find additional information in the section: Signal tracking (Page 135) 

9.7.15 How to copy interconnections 

Procedure 
In order to copy an interconnection, proceed as follows: 

1. Select the interconnected input. 

2. Press and hold down the <Ctrl> key and the left mouse button and drag the cursor to the 
target input (of the same type). When you reach this input, release the mouse button first 
and then the <Ctrl> key. An additional interconnection is thus created. 

Copying is a highly convenient function, particularly in situations when the interconnection 
originates in a block from a different chart, since you do not need to initially locate the 
source. 

 

 Note 

An SFC access cannot be copied in CFC. 
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9.7.16 How to modify (rewire) interconnections 

Procedure 
You can modify existing interconnections in the sheet view. To do this, move the 
interconnection from one I/O to another I/O with a compatible data type. Proceed as follows: 

Input 

1. Position the cursor on the input whose interconnection you want to move to another input 
and hold down the mouse button. 

2. Drag the cursor to the target input (of the same type) and release the button. The 
interconnection line is redrawn. 

Output 
The procedure is basically the same as for the inputs. However, the following rules apply: 

● If there is more than one interconnection, all interconnections will be moved to this output. 

● If the interconnection from an output to an address is dragged to an output that is already 
interconnected to the same address, a warning is displayed. You can then decide 
whether or not to delete the interconnection of the original block. 

 
  Note 

Please note the following: 
• If you want to modify an interconnection that is accessed by an SFC chart (see the 

block I/O identifier), a message prompts you to move the SFC access also. If you click 
“Yes”, the interconnection and SFC access are moved, if you click “No”, only the 
interconnection is moved. 

• If you only want to move the SFC access to a different I/O of a compatible data type, 
drag the I/O with the SFC access to the required I/O, holding down the ALT key. 

 

9.7.17 How to delete interconnections 

Procedure 
Proceed as follows to delete an interconnection: 

Multiple interconnection  

Deleting all interconnections of an output: 

1. Select the output or the connection line and select the menu command Edit > Delete or 
press <Del>. 

2. If you click “Yes” in response to the prompt for confirmation, the interconnections are 
deleted.  
If you respond by clicking “No”, no interconnection is deleted. 

Deleting one of several interconnections of an output: 
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1. Select the input and press <Del> 
 or 
 position the cursor on the sheet bar entry of the output and press the right mouse button.  
The small field before the sheet bar entry is selected. 

2. In the shortcut menu, select the command Delete Interconnection(s).  
The interconnection to the input will be deleted. 

You can also click the small field in the sheet bar directly and delete the relevant 
interconnection via <Del> or the menu command Edit > Delete.  

Single interconnection 

You can delete the interconnection for the output, input, sheet bar entry, or connecting line 
as follows: 

Select the corresponding object and  
 select the menu command Edit > Delete 
or 
 press <Del>. 

Textual interconnection 

Single textual interconnection: 

You delete a single textual interconnection from the chart in the same way as a single 
interconnection (see above). 

All textual interconnections: 

1. Select the menu command Options > Delete Textual Interconnections. 
A dialog box opens which contains a table listing all textual interconnections of all charts 
in your current chart folder. 

2. In the "Chart" column, select all the textual interconnections you want to delete. 

3. Click "Delete". 

 
  Note 

An SFC access cannot be copied in CFC. 
 

9.7.18 Data types and structures 

9.7.18.1 Data types for S7 
The following topics list all the S7 data types that can occur at a block/chart I/O that is 
capable of being assigned parameters or being interconnected.   

The description shows the following elements:  

● Abbreviation of the data type 

● Keyword and data type 

● Value range 
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● Sample entries 

● Display with the maximum length in the chart (examples) 

The maximum string length for displaying parameters in the chart is limited to 18 characters. 
This ensures that sufficient space is maintained for blocks and interconnections. Input 
options are not affected by this limitation. 

Data types 

● ANY, A (Page 303) 

● ARRAY (Page 303) (not permitted in CFC) 

● BOOL, BO (Page 304) 

● BYTE, BY (Page 304) 

● CHAR, C (Page 305) 

● COUNTER, CR (Page 305) 

● DATE, D (Page 305) 

● BLOCK_DB, DB (Page 303) 

● DINT, DI (Page 306) 

● DATE AND TIME, DT (Page 305) 

● DWORD, DW (Page 306) 

● BLOCK_FB, FB (Page 304) 

● BLOCK_FC, FC (Page 304) 

● INT, I (Page 306) 

● POINTER, P (Page 306) 

● REAL, R (Page 307) 

● STRING, S (Page 308) 

● STRING[N], SN (Page 308) 

● STRUCT, ST (Page 309) 

● TIME OF DAY, T (Page 309) 

● S5TIME, T5 (Page 308) 

● TIME, TI (Page 309) 

● TIMER, TR (Page 309) 

● WORD, W (Page 310) 
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9.7.18.2 Interconnection rules for data types A, DT, S, and ST 

Interconnection rules 
The following interconnection rules apply to block I/Os of the structured data types ANY, 
STRING, DATE_AND_TIME, and STRUCT:        

 
 Data type 
Interconnection type  

ANY 
STRING, 
DATE_AND_TIME, 
STRUCT 

Mandatory interconnection 
for: 

FC - OUT, 
 with all other I/Os, NIL is transferred, 
which must not be evaluated by the calling 
block (only relevant for STL blocks written 
by the user; with PCS 7 blocks, this is 
guaranteed). 

FC - OUT, 
FC - IN_OUT, 
FB - IN_OUT,  
FC - IN (with STRUCT) 

Target/source of the 
interconnection 
(address): 

Any: 
CFC block I/O, 
Address range, 
DB element, 
Entire DBs 

DB element, 
CFC block I/O 
(except for FC - OUT) 

Target/source of the 
interconnection 
(data type): 

Any: except for same  
 data type (ANY) 

only to same  
 data type 

Interconnection to chart I/O 
Structured I/Os of FBs and structured inputs of FCs can be freely interconnected to chart 
I/Os. Since structured data types of FCs do not have their own resources (storage space in 
the instance DB), FC outputs cannot be interconnected with chart I/Os. 

 

 Note 

Blocks of STEP 7 or PCS 7 libraries do not contain FCs with structured outputs. 
 

9.7.18.3 Structures 

Layout 
Structures are used to group data in a tree view and apply those data to a block I/O. 
Structures in the block view are assigned, similar to elementary data types, an I/O name and 
the type "ST". 
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A structure consists of several elements and a nesting depth of up to 8 levels. The following 
elements are permitted: 

● Elementary data type (BO, WORD, etc. ) 

● Structure 

A structure element contains the following information: 

● Type (of the elementary data type, otherwise "ST") 

● Name 

● Value (only with the elementary data type) 

Interconnecting structures 
You can only interconnect a block I/O with a structure to other structures, not to elementary 
data types. The structures you interconnect must be compatible, in other words, the order, 
data type, and the element name of the elementary data types it contains must be identical. 
The names of the structures can be different. 

You can only interconnect the complete block I/O structure, not separate elements of the 
structure. 

Interconnections to shared addresses 
You cannot interconnect a block I/O with a structure to a shared address that refers to an 
entire data block (DBx). Interconnections to structures within the first level of the DB are 
possible (DBx.name_st). Interconnections of elementary data type I/Os are permitted with 
elementary data types within the first level of the DB (DBx.element). 

 

 Note 

If a STRUCT I/O of an instance block is interconnected with a shared data block and the 
structure name of the shared data block is subsequently changed, this change will not be 
detected during compilation. This also applies if the name of the elementary data type is 
changed. The change is updated in the ES data management only after closing and 
reopening the CFC chart. 

 

Editing structure elements 
You can display the object properties of the structure or of an elementary data type in the 
structure and edit them (assign parameters).  
Double-click the block I/O to display the "Select Structure Element" dialog box. In the 
structure that appears, select the element you want to edit and open the properties dialog by 
clicking the "Properties" button or by double-clicking the element.  

You can open the dialog box in both the edit and test mode. 
 

 Note 

You cannot interconnect FC outputs with a structure to chart I/Os. 
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Inserting structure in dynamic display 
You can insert the entire structure or individual structure elements in the dynamic display. To 
do this, proceed as follows: 

1. Open the dynamic display with the menu command View > Dynamic Display. 

2. Select the block I/O in the CFC chart and select the "Insert in Dynamic Display" command 
in the shortcut menu. 

The "Select Structure Element" dialog box opens. 

3. Select the top level if you want to insert all structure elements or select an individual 
element of you only want to insert a single element. 

4. Click "Apply". 

The dialog box closes and the selection is inserted in the dynamic display. 
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9.8 Shared Declarations 

9.8.1 Configuring Shared Declarations 

Introduction 
In the project, you can store shared declarations that can be used by different applications. 
These shared declarations are, for example, enumerations, units and equipment properties. 
This ensures that attributes with the same names are used throughout a project. 

Configuring 
When a new project is created, the shared declarations and the “Enumerations”, “Units” and 
“Equipment properties” folders they contain are created automatically. Shared declarations 
are also created in the master data library when a new multiproject is created.  

In the component view or plant view of the SIMATIC Manager, you create the "Shared 
declarations" folder directly below the project node. With the shortcut menu command Insert 
New Object > Shared Declarations, you insert the folder with the underlying folders 
"Enumerations", "Units" and “Equipment properties” into the project.  

You can delete, copy, move, and create the folders contained in the “Shared declarations” 
folder individually. This folder must not contain more than one folder of the same type. 

When you select the “Shared declarations” folder, the following menu commands are 
available via the shortcut menu command “Insert New Object”: 

● Enumerations 

● Enumeration 

● Units 

● Unit 

● Equipment properties 

● Equipment property 

You can also insert the "Enumeration", "Unit" or "Equipment property" objects if no 
“Enumerations”, “Units” or “Equipment properties” folder exists. It is then created 
automatically at the same time. 

If you insert one of these folders, an existing folder of this type is overwritten if you confirm 
the displayed prompt. It is also overwritten if you renamed the existing folder earlier.  

After insertion, the “Enumerations” folder already contains the enumeration, with the name 
“Operating State” but without values. The enumeration is used in PCS 7 for hiding 
messages.  

The "Units" folder already contains a list of units installed with CFC. You can extend or 
modify these as required.  



Creating runtime structures  
9.8 Shared Declarations 

 CFC for SIMATIC S7 (V8.0 SP4) 
144 Function Manual, 07/2013, A5E03710059-06 

No equipment properties exist yet in the "Equipment properties" folder. In the 
multiproject/master data library, this is the folder where you insert a type. In the plant 
hierarchy, it is where you insert an instance of the equipment property. 

Additional information 
You can find additional information on this in the following sections: 

Configuring enumerations (Page 144) 

Configuring units (Page 145) 

Configuring equipment properties (Page 146) 

Updating shared declarations in the multiproject (Page 147) 

9.8.2 Configuring enumerations 

Introduction 
You use enumerations for block I/Os or chart I/Os that have the system attribute "S7_enum". 
Regardless of the current value of the system attribute (value matches the object name of an 
enumeration), you can use any object name from the enumerations that exist within the 
project. These enumerations are available in a drop-down list in the object properties of the 
I/O. 

Enumerations are permitted for I/Os for the following data types with Boolean and integer 
values: BOOL, BYTE, INT, DINT, WORD, DWORD. 

 

 Note 

If a system attribute "S7_string_0" ... "S7_string_25" and the system attribute "S7_enum" is 
assigned to the I/O, only the enumeration will be used as the value identifier (system 
attribute "S7_enum"). 

 

Creating an enumeration 
When a new project is created, the shared declarations and the “Enumerations” folder they 
contain are created automatically with an enumeration. The enumeration with the name 
“Operating State” is intended to automatically hide messages but does not contain any 
values. 

Create a new enumeration by selecting the “Shared declarations” folder and the shortcut 
menu command Insert New Object > Enumeration. Alternatively, you can use the menu 
command Insert > Shared Declarations > Enumeration. 

You can change the object name and the display name in the object properties of the 
enumeration.  

You can specify the object name of the enumeration so that it matches the value of the 
system attribute "S7_enum" of the block I/O for which this enumeration will be used. 
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 Note 

In the object properties of a block I/O or in the process object view, the "Enumeration" box is 
active when the system attribute "S7_enum" is assigned to the I/O. It does not matter 
whether the value of the system attribute matches the existing name of the enumerations in 
the project. You can assign the required enumeration to the I/O at any time using a drop-
down list. 

 

The display name of the enumeration can be translated into different languages and is 
transferred to WinCC when you compile the OS. 

When you create the enumeration, "0.1" is entered automatically as the version. You can 
change the version in the object properties of the enumeration. 

You can assign any number of values to the enumeration. For enumerations that will be 
used for I/Os with the data type BOOL, only two values are practical. 

Inserting values 
You create a new value using the shortcut menu command Insert New Object > Value or the 
menu command Insert > Shared Declarations > Value. 

The first value to be entered contains the numeric value 0; this number is incremented with 
each additional value added. 

The display name of the value is displayed in the object properties of the block I/Os under 
"Value". You can select each existing value of an enumeration there from a drop-down list. 

If you want to identify the enumeration in SIMATIC BATCH for a control strategy, select the 
“Control strategy” option in the "Properties Enumeration” dialog box, “General” tab. When 
you select the option, the symbol of the enumeration and the value changes its appearance. 

Checking plausibility 
You can check any enumerations in the multiproject/project to ensure that the enumeration 
values are unique, in other words, that they have not been assigned more than once. 

You can find additional information in the section: Checking the plausibility of shared 
declarations (Page 149) 

9.8.3 Configuring units 

Inserting a unit 
Create a new unit by selecting the "Units" folder and the shortcut menu command Insert New 
Object > Unit. Alternatively, you can use the menu command Insert > Shared Declarations > 
Unit. 
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If you want to undo a change to the units or remove added units, insert the "Units" folder 
again. The content of the existing folder is then overwritten with the basic set from CFC. 

The object name is the text that is displayed as the unit. In the object properties, you can 
change the following: 

● Name 

● Version 

● Author 

● Comment 

9.8.4 Configuring equipment properties 

Creating an equipment property 
When a new project is created, the shared declarations are created automatically along with 
the associated equipment properties folder. You use the equipment properties (unit 
parameters) in BATCH projects. 

Create a new equipment property by selecting the "Equipment properties" folder and the 
shortcut menu command Insert New Object > Equipment Property. Alternatively, you can 
use the menu command Insert > Shared Declarations > Equipment Property.  

Take the following into account when creating equipment properties: 

● The equipment property that is created in the shared declarations is an equipment 
property type. 

● The equipment property that is created in the plant hierarchy is an instance of the 
equipment property. 

You can generate as many equipment property instances as required from each equipment 
property type. 

Configuring the equipment property type 
You configure the equipment property type in the shared declarations. 

1. In the "Equipment properties" folder, select the equipment property, followed by the 
shortcut menu command "Object Properties". 

2. Assign the equipment property a logical name as well as a display name. 

3. Select the required data type from the drop-down list. 

Depending on which data type is selected, the "Enumeration" and "Unit" input boxes will 
either be enabled or disabled.  

If the "LOCATION" data type is selected, three additional check boxes will be displayed: 
Source, Dest and Via.  
Note: If all three check boxes are disabled, this equipment property is ignored by 
SIMATIC BATCH. 
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4. Make any other settings you may require in the light of how you intend to proceed in 
SIMATIC BATCH. 

5. Click "OK" to complete configuration. 

Configuring an equipment property instance 
You configure equipment property instances in the plant hierarchy. 

1. Select the "Unit" hierarchy folder followed by the shortcut menu command Insert New 
Object > Equipment Property. 

2. Select the "Equipment properties" folder, followed by the shortcut menu command Insert 
New Object > Equipment Property. 

3. Select the equipment property, followed by the shortcut menu command "Object 
Properties". 

4. In the "Name:" field, select the equipment property type from the drop-down list. 
The instance will now be automatically assigned the same name as the type from Shared 
declarations. 

5. You can edit the author and comment in accordance with your requirements. 

6. If the equipment property contains an enumeration, you can use the "Value" drop-down 
list for the instance to assign a configured value to this enumeration. 

7. Click "OK" to complete configuration. 

9.8.5 Updating shared declarations in the multiproject 

Updating shared declarations 
You have two options for performing the update: 

● Merge the shared declarations of all projects in the multiproject 

The enumerations, units and equipment properties are updated across all the available 
projects. This means that at the end of this process, all the shared declaration objects are 
present in each of the projects concerned. 

● Export shared declarations of a project to another project 

The shared declarations of a template project are exported to selected destination 
projects of the multiproject. 
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Procedure  
1. Select the multiproject, followed by the shortcut menu command Shared Declarations > 

Update in Multiproject.... Alternatively, you can select the menu command Options > 
Shared Declarations > Update in Multiproject.... 

A dialog box opens where you can select the type of update. 

2. Select either a) "Merge the shared declarations of all projects in the multiproject" or b) 
"Export shared declarations of a project to another project". 

a) Merge the shared declarations of all projects in the multiproject 

– Click "OK" to start the update. 

b) Export shared declarations of a project to another project 

– Select the project (or library) in the list that you wish to use as a template for exporting 
the shared declarations to another project. 

– Click "OK". 

Another dialog box opens. It lists all the projects that are available for selection as the 
destination project.  

– If you do not want the shared declarations of the template project to be transferred to 
a specific project, you must remember to deselect the project concerned. 

– Click "OK" to start the export. 

 
  Note 

Please note the following: 
• A master data library may only be used as the source of an update. 
• Changing names for units, enumerations or equipment properties in the template 

causes these to be created new in the target project when the comparison is made.  
The previously used shared declarations are retained at the points of use. 

• Units, enumerations or equipment properties deleted in the template are ignored 
during the comparison in the target project and are therefore retained there. 

 

Result 
Once the update is complete, the result is displayed in the form of a message. In the event of 
an error, a full log will be generated.  

You can view the full log by selecting the shortcut menu command Shared Declarations > 
Display Full Log.... 
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9.8.6 Checking the plausibility of shared declarations 

Plausibility check 
You can check any enumerations in the projects and libraries of a multiproject to ensure that 
the enumeration values are unique, in other words, that they have not been assigned more 
than once.  

You perform this plausibility check for each individual project or a library. When an update in 
the multiproject is performed, consistency is checked across the entire multiproject as a 
matter of course.  

If you select a multiproject, all the projects and libraries within this multiproject will be 
checked one after the other.  

To initiate the check, proceed as follows: 

1. Select a multiproject, a project or the shared declarations. 

2. Select the Shared Declarations > Validate command from the shortcut menu. 

Results of the check 
● If you have run the check on a multiproject, a message will be displayed to indicate that 

the process is complete. This message will ask you to open the local project logs so that 
you can see if any errors have occurred. 

● If you have run the check on a single project, the log will be displayed automatically once 
the checking process is complete. If any errors have occurred, you will find them 
recorded in the log, e.g., "Enumeration type 'xyz': 'value 1 assigned several times". 
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9.9 Configurations for OS and MIS/MES 

9.9.1 Operating and monitoring 

Introduction 
Messages are generated on the CPU during process runtime and need to be passed on to 
the WinCC operator control and monitoring system.  

Via the message configuration in CFC you can define event-relevant messages, edit their 
texts and assign attributes directly in the block. 

In your AS configuration you have already specified data required for OS <-> AS 
communication, in other words, for operator control and monitoring. You transfer those data 
to the OS during OS compilation. 

Message blocks 
After you have inserted a message block into the CFC chart, a message will be generated 
automatically. Default block message structures are assigned default attributes and 
message texts. In this way, the CPU sends default event messages without additional 
configuration on the part of the user. The signals that form messages can also be assigned 
associated values, which allow the input of dynamic values in message texts. 

You can edit those attributes, such as message class, message type, and message texts for 
each block instance via the message configuration functions (Special properties: 
"Messages"). If the "Messages" button is disabled, the block does not have message 
capability. 

Operator control blocks 
You can set and edit WinCC attributes for blocks with inputs that allow operator control. To 
do this, call the dialog box by clicking "Operator Control and Monitoring..." in the object 
properties of the block. 
You can modify this property at the block instances intended for operator control and 
monitoring by selecting or deselecting the "OCM possible" option in the "Object properties" 
section of the block. 

In a WinCC picture template, you can create multiple block icons for each block type. In this 
way you can indicate specific variants of a type, for example, the MOTOR block as motor, 
fan or pump. In the "Block icon" input box of the "Object properties" dialog you can define the 
block instance symbol to be displayed in WinCC. The input box is active if the "Create block 
icon" check box is selected. 
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AS <-> OS communication 
After you have configured the messages, the OS data required for AS <-> OS 
communication will be downloaded to one or several target operator stations where they are 
used by graphic objects or faceplates.  
The "AS-OS Engineering" software package must be installed to enable this transfer. Start 
the compilation in the SIMATIC Manager using the menu command Options > "Compile 
Multiple OSs" wizard > Start... or, for a single OS, using the menu command Edit > Compile. 

 

 Note 

Note than when you assign names to charts/blocks, the string length of the variable name 
must not exceed 128 characters for OS compilation. This name consists of the following 
components: 
• The name of the folder in the hierarchy path 
• The chart name 
• The block name 
• The separator (period mark) 
• The I/O name 

 

9.9.2 Configuring archive tags 

Introduction 
In CFC, you can select the block I/Os intended for operator control and monitoring (system 
attribute S7_m_c := 'true') for archiving in WinCC. 

The I/Os identified as being relevant for archiving are created as archive tags during 
compilation of the OS in the OS project. If it does not already exist, a process value archive 
is also created automatically.  
Requirement: In the "Compile (Multiple) OSs" wizard, the option "Archive tags" is selected 
and in the object properties of the OS, the setting "Create/update archive tags" is selected.  

If an I/O relevant for archiving is deleted later or is changed to "No Archiving", the 
corresponding archive tag is deleted the next time you compile the OS. 

If there are no more archive-relevant I/Os available, the process value archive is deleted, if it 
also contains no more archive tags. 

Configuration 
You identify tags for archiving in the object properties of the I/O (for a single I/O) or on the 
"I/Os" tab in the object properties of the block (for multiple I/Os). 

In the drop-down list of the input box, you choose whether and how the I/O will be archived: 

● "No Archiving" (S7_archive := 'false') 
 The I/O will not be archived (any longer). 
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● "Archiving" (S7_archive := 'shortterm') 
 The I/O will be archived on the OS or on an archive server. 

● "Long-term archiving" (S7_archive := 'longterm')  
 The values archived on the OS or on the archive server will be stored for long-term 
archiving on CD, DVD, MOD, tape, etc. 

The system attribute S7_archive is permitted for all OCM-capable I/Os of the data types 
BOOL, BYTE, WORD, DWORD, INT, DINT, and REAL. 

 

 Note 

If a new block type is used in a project, the existing block instances remain unchanged in 
terms of the system attribute "S7_archive". New instances of the block type will inherit this 
attribute. 

 

9.9.3 Configurations for MIS/MES 

Introduction 
The enterprise levels MIS and MES require specific information from the automation level. 
To ensure that only information relevant for MIS/MES is transferred, the projects can be 
created with a suitable filter.  

The system attribute "S7_mes := "true"" is used as the filter. It is set for blocks and block I/Os 
intended for operator control and monitoring (S7_m_c := "true"). The system attribute is 
specified by the block type and can be modified in the block instances. 

Configuration 
You have the following configuration options: 

● In the "Blocks" dialog box, "General" tab, you can activate or deactivate the entire block 
for the MIS/MES system by selecting or deselecting the "MES-relevant" check box. The 
option can only be changed when "OCM possible" is set. 

● You modify the system attribute for I/Os that can be operator controlled and monitored as 
follows: 

– For several I/Os: In the "Properties - Block" dialog box, in the "I/Os" tab 

– For a single I/O: In the "Properties - Input/Output" dialog box 
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9.10 Defining runtime properties 

9.10.1 Runtime properties 

Runtime properties of blocks  
The runtime properties of a block determine how the block is executed in the run sequence 
within the entire structure of the CPU. These properties determine the behavior of the target 
system with respect to response times, dead times, or the stability of time-dependent 
structures, such as control loops. 

When it is inserted, each block is assigned default runtime properties. It is thus inserted into 
the run sequence of a task. In S7, a task consists of an OB (organization block). You will find 
information on the installation pointers in the section: Concept and use of installation pointers 
(Page 155). If required, blocks can also be installed in the runtime groups of tasks. 

 

 Note 

When you create a new chart, a runtime group is created automatically in which all the 
blocks of this chart are integrated.  

 

Runtime groups 
Runtime groups are used for structuring tasks. The blocks are installed sequentially in the 
runtime groups and can be assigned "reduction ratio" and "phase offset" attributes in the 
“Object Properties” dialog box.  

For more information on attributes, refer to the section: Task attributes (Page 165) 

Runtime groups can be enabled and disabled individually (for example, by a block output of 
the "BOOL" data type). The blocks of a disabled runtime group will not be executed. 

Additional information 
You can find additional information about runtime properties in: 

Displaying runtime properties (Page 154) 

Modifying the run sequence and the installation pointer (Page 158) 

Concept and use of installation pointers (Page 155) 
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9.10.2 Displaying runtime properties 

Introduction         
There are various ways in which you can display information on runtime properties:  

● Of a single block 

● Of the entire CPU 

Runtime properties of individual blocks 
The runtime properties of each block are displayed on a colored background in the block 
header, in the runtime display field: 

● Upper line (left): 

Identifier for the Display of block execution (Page 166)  
Task name (for example, OB 35) 

● Upper line (right): 

Name of the task or sampling time of the block (depends on the display setting). 
The sampling time is the task cycle time multiplied by the reduction ratio of the runtime 
group. 

 

 
● Lower row (to the left of the slash): 

position of the block or runtime group in the task 

● Lower row (to the right of the slash): 

if the block is installed in a runtime group, position of the block in the runtime group; 
otherwise "-" 

Tip: When you position the cursor on the box of the runtime properties, the tooltip box will 
display the task name and, if the block is installed in a runtime group, the name of the 
runtime group. The task name is also displayed if the sampling time is entered in the runtime 
properties field. 
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Entire CPU 
You can obtain a complete view of the run sequence as follows:  

1. Double-click the runtime properties box in the block header. 

The runtime editor is started and the task in which the block is installed (first insert 
position) opens in the run sequence window. The relevant block is highlighted. 

2. Select the menu command Edit > Run Sequence... 

or  

Click the icon: 

 
The runtime editor opens with the window of the run sequence. If a block was selected, 
the task in which the block is installed (first insertion position) is opened in the run 
sequence. The relevant block is highlighted. 

In this window, you can also edit the run sequence. 

3. Select the menu command Options > Chart Reference Data... 

or  

Click the icon: 

 
An application is started with its own window and menu commands/toolbar buttons.  

The "Run Sequence" view shows the complete run sequence of the current CPU with 
comments and run attributes.  

You have the following options for enabling the "Run Sequence" view:  

– With the menu command View > Run Sequence 

– By clicking the icon: 

 
The tasks containing the objects are open. You can print out a list of the run sequence.  

In this window, you cannot edit the run sequence. 

9.10.3 Concept and use of installation pointers 

Concept of the runtime model  
The runtime model as of V6.0 allows chart-oriented structuring of the run sequence. All 
blocks are inserted in successive order in the run sequence. The installation pointer 
determines the insertion position for the next runtime object to be inserted in the run 
sequence. We differentiate between chart installation pointers and block installation pointers.  
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The following exist in an S7 program:  

● A global chart installation pointer for the program 

● A separate local block installation pointer for each chart. 

In conjunction with the runtime group created automatically for each chart, the concept of the 
installation pointer ensures better chart orientation. This feature, for example, allows block-
oriented handling of charts blocks when branching and merging a project for multi-user 
engineering. This allows you to word chart-oriented and to specify the runtime sequence of 
the blocks regardless of the runtime sequence of other charts.  

Provided the user does not specify otherwise in the installation pointers, charts are inserted 
as follows:  

● New charts are inserted after existing charts. 

● Blocks are inserted in the chart directly one after the other. 

Other advantages:  

● The insertion position cannot be adjusted unintentionally by project engineers during 
chart-oriented multiuser engineering. 

● There is no need to modify the complete OB when a chart is modified. Rather, only the 
corresponding runtime group of the modified chart is compiled and loaded. 

● The load performance of the CPU can be influenced according to the specific chart. 

● Individual charts can be enabled/disabled during CPU runtime (also in test mode), without 
the need to initialize this action by means of an external control (for example, SFC). 

Chart installation pointer  
Each program contains its own global "chart installation pointer". This pointer determines the 
following:  

● The task into which the runtime group of the chart created next is inserted. 

● The position after a runtime group or block at the task level at which the runtime group of 
the chart created next is inserted. If the task does not yet contain a runtime group, this 
position is "empty". The pointer refers to the actual task. 

This pointer is customized only in the runtime editor (not in the CFC Editor). OB 35 is the 
default chart installation pointer.  

You customize the chart installation pointer as follows: 

1. Select a task, a block/SFC chart or a runtime group in the run sequence. 

2. Select the menu command Edit > Predecessor for Insertion Position. 

Display of the chart installation pointer 
The predecessor for the insertion position is highlighted visually in the run sequence by 
means of a light-green background. 
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Block installation pointer 
Each CFC chart (including nested charts) contains its own local "block installation pointer". 
This pointer determines the following: 

● The task into which the next new block is to be inserted. 

● The position after a block at which the next new block is placed in the runtime sequence. 

The block position always has a unique link to the task number. 

The block installation pointer is "undefined" in an empty chart. Instead, the chart installation 
pointer will be displayed in the status bar. After insertion of the first block, this information is 
fetched from the current chart installation pointer. 

The block installation pointer is customized only in the CFC Editor (not in the runtime editor). 
The default start position (after a new chart was created) is the beginning of the 
automatically generated chart runtime group. 

You customize the block installation pointer as follows: 

1. Select a block from the chart. 

2. Select the menu command Edit > Predecessor for Insertion Position. 

If you insert an additional block in the chart, the installation pointer is moved to this block. It 
becomes the new "Predecessor for Insertion Position". 

 

 Note 
Behavior of the block installation pointer during copying and pasting 

With standard functions, e.g. AND, OR, etc., the block installation pointer behaves as it does 
during copying to the CFC chart when it is inserted, for example from the template catalog. 

When blocks are copied to the CFC chart, they are always copied to the end of the runtime 
group. The block installation pointer is not included in this process and remains unchanged. 

 

Display of the block installation pointer: 
The predecessor for the insertion position differs from other blocks in the chart because it is 
highlighted in color. The box for the runtime properties in the block header is displayed in a 
black font on a light-green background. 

Note on nested charts: 
Blocks copied/inserted in nested charts are always located at the end of the runtime group. 
The position of the block installation pointer is ignored. 

Additional information 
You can find information about migration in the section: Migration of old projects to the 
enhanced runtime model (Page 31) 
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9.10.4 Modifying the run sequence and the installation pointer 

Starting the runtime editor                 
Call the menu command Edit > Run Sequence... and click on the following icon in the toolbar 
to open an additional window:  

 
This window is split into a hierarchy window (left) and a detail window (right). The structure of 
this window is similar to that of Windows Explorer and is handled in the same way.  

Moving objects 
To move an object (chart, runtime group or block), select it in the window (right or left pane) 
and then drag it to the object after which you want to install it.  

When you drag an object to a runtime group: 

● The object is installed at the first position within the runtime group if the tree is expanded 
[-]. 

● The object is installed after the runtime group if the tree is closed [+]. 

● If the runtime group is empty, you will be asked whether or not to install the block within 
the runtime group. If you click "Yes", it is installed inside, if you click "No", it is installed 
after the runtime group. 

Any object you drag to a block/chart within the runtime group is inserted after this 
block/chart. 

When you drag an object to a task, it is inserted before the existing installed objects. 
 

 Note 

When you move blocks, verify that – according to runtime model V6.0 and higher – all chart 
blocks exist only in their corresponding runtime group. If you move them to another group, 
the chart-oriented structure would no longer exist, making segmented editing of charts 
harder or impossible for multiuser engineering. 

 

Removing a block 
You can only delete blocks from a task if they are installed more than once in the run 
sequence. At least one insert instance must be retained. Removal is denied if only one block 
was inserted. Otherwise, the block is deleted and the run sequence of the next blocks is 
adapted accordingly. 
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Inserting blocks 
You can install several instances of the blocks and runtime groups in different tasks using 
the copy / paste function. Use either the corresponding menu commands, or the toolbar 
buttons, or drag-and-drop while holding down the <Ctrl> key (for additional information, refer 
to the "Moving objects" section). 

You can also install blocks (if you have the windows displayed simultaneously) by dragging 
these directly from a CFC chart to the required position in the run sequence.  

 

 Note 

Please note the following: 
• Installation of a block in different tasks implies that you should not install several 

instances of the block in a cyclic task. However, the system does not prevent this 
installation. 

• The objects with system identifier "@" which were inserted automatically in the run 
sequence during generation of the module drivers may only be edited using the Options > 
Charts > Generate Module Drivers... function in the SIMATIC Manager; these objects 
may neither be moved nor deleted manually. 

 

Customizing installation pointers 
You can edit the installation pointers as follows: 

● Chart installation pointer (default: OB 35)  
To edit the chart installation pointer, go to the runtime editor and select the corresponding 
task (OB), or a block at the task level (not within a runtime group), or a runtime group 
within the task.  
Select the Edit > Predecessor for Insert Position menu command in the runtime editor. 

The predecessor for the insertion position is highlighted using a font with light-green 
background. 

● Block installation pointer  
You cannot set up the block installation pointer in the runtime editor. To edit the block 
installation pointer, open the CFC editor and select the block for the default insertion 
position for all successive blocks.  
Select the Edit > Predecessor for Insert Position menu command in the chart. 

The insertion pointer is incremented with each new block you insert. The last block 
inserted will become the predecessor for the installation position. The insertion pointer is 
not modified when you copy blocks. 

If you delete the block you have defined as predecessor for the insertion position, the 
block insertion pointer is decremented, which means it is set to the position of the 
previously inserted block. This also applies if the block is moved to a different chart. The 
block insertion pointer of the destination chart is not modified. The moved block retains 
the insertion position it had in the previous chart. 

For additional information on the run sequence, refer to the section: How to find the insertion 
position (Page 162) 
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9.10.5 Optimizing the run sequence 

Purpose of optimization 
This function is used to optimize the program run sequence according to the data flow in 
order to reduce dead times to a minimum during program runtime in the CPU. Tasks and 
runtime groups are optimized separately. 

Start 
To start the optimization process, in the runtime editor, select the menu command  

● Options > Optimize Run Sequence to optimize the entire run sequence. 

Alternatively, if you only want to optimize the selected task or runtime group, open the 
shortcut menu with the menu command 

● Optimize Groups/Tasks. 

Selecting single elements 
When optimizing the run sequence, you can optimize specific elements or exclude them from 
optimization. Select the setting for the selected task via its object properties. The "Properties 
- Task" dialog box appears. 

● You can optimize the full task, including all enabled runtime groups. 
Option "Task and runtime groups" (default setting) 

● You can optimize only the enabled runtime groups of a task. 
Option "Runtime groups only" 

● You can exclude the full task - including its runtime groups - from optimization. 
Option "None" 
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  Note 

Please note the following: 
• The selections made in the "Properties – Task" dialog box will not affect optimization 

in cases where this process is started via the shortcut menu command Optimize 
Groups/Tasks for an individual runtime group or task. 

• You can enable specific runtime groups for optimization via the object properties 
dialog of the corresponding runtime group (option "Optimize run sequence").  
This means that you can exclude specific runtime groups from optimization by 
deselecting this option. 

• All F objects are excluded from the optimization. 
• Tasks or runtime groups excluded from the optimization are identified by an additional 

element in the symbol. 

• : If "None" or "Runtime groups only" is selected for optimization of the run 
sequence in the object properties of the task. 

• : If the "Optimize run sequence" check box is not selected in the object properties 
of the runtime group or optimization is not activated for the task. 

• The contents of runtime groups generated by the driver generator ("Generate module 
driver") (@......) will not be optimized, since the correct order has already been set for 
these groups. 

If the optimization is carried out after the generation of the module driver, there is no 
guarantee that the runtime groups of the driver blocks are still in the order set by the 
driver generator. Therefore, the module driver is started again during the next compilation 
procedure. 

 

What happens during an optimization run? 
All tasks are optimized separately. The runtime groups of a task are treated separately. The 
reduction ratio and phase offset of a runtime group are not taken into consideration.  

The data flow volume is determined by the number of interconnections. This includes all 
block-to-block interconnections, as well as interconnections to SFC charts and between 
module outputs and the ENABLE signal of a runtime group. Global and textual 
interconnections will be ignored. Interconnections to the chart interface are taken into 
account up to the actual interconnection source. If no such connection exists, the 
interconnection will be ignored, in other words, if the interconnection terminates at an 
interface. Interconnections to blocks in other tasks, or accesses from SFC charts to block 
I/Os are also ignored. 

Interconnections to or from a runtime group are treated as if they were interconnections of 
the runtime group itself. The runtime groups forms a virtual block at task level. 
Interconnections between internal blocks of a runtime group are only used for optimization 
processes within the runtime group. On the one hand, this ensures a correct arrangement of 
the actual runtime groups, and on the other hand an optimal position of the runtime group 
within the task. 
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Subsequent optimization runs are carried out without effecting unnecessary changes in order 
to reduce the volume of compiled and downloaded configuration data. 

 

 Note 

When the block is connected via the INOUT parameter, the data flow may be reversed from 
the input to the output. This cannot be taken into account during optimization of the run 
sequence. 
Remedy: In this case, you have to optimize the run sequence manually and remove the 
corresponding runtime group from the optimization. 

 

9.10.6 How to find the insertion position 

Procedure 
In the runtime editor you can search for the insertion positions of an object as follows: 

1. Select the menu command Edit > Find.... 
A dialog box opens. 

2. Use the radio buttons to select the search object (task, group, SFC, or block). 
You can enter the full name or only its initial letter(s). 

Result 
The search result is displayed in a window. If no object matching the search key was found, 
a message is displayed. 

9.10.7 How to create, edit and delete runtime groups 

What are runtime groups?  
Runtime groups are optional but are created automatically when you create a new chart. 
Runtime groups are used for structuring or splitting tasks. The blocks are installed in 
sequential order in the runtime groups.  

Three types of runtime groups are used in the run sequence: 

● The standard runtime groups resulting when a chart is created or created manually. 

● Runtime groups created by the driver generator (@OBxx_@..). 

● Runtime groups created by the system in OB 100 (@@OB100@@..). 
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You can use the runtime groups to: 

● Delete or reconnect selected blocks for execution on the AS. 

Runtime groups are activated or deactivated using a block output of the data type 
“BOOL” or, with runtime groups that are not interconnected, using the “Active” option in 
the object properties of the runtime group. 

● Execute selected blocks with a specific reduction ratio, in other words, every n-th number 
of cycles, and/or with a phase offset. This improves the load balance on the CPU. 

● You can arrange tasks containing a large number of installed blocks in smaller units. In 
the improved runtime model V6.0 and higher this is achieved by automatic and chart-
granular insertion of chart blocks in the runtime groups (one chart per runtime group). 
Advantage: Instead of creating one "large" FC when you compile each task, "smaller" 
FCs are created, depending on the number of runtime groups. 
If the program is modified later, only the runtime groups/FCs that actually contain 
modified blocks are given the "modified" ID. That is, the time required for compiling 
changes and downloading changes online will be reduced considerably. 

● All blocks with startup relevance are installed in runtime groups in OB 100. Each runtime 
group contains only small number of blocks (maximum 10). This avoids aborts during 
SCL compilation due to the 64K limit. 

When the blocks are installed, there is a search for existing runtime groups. If none are 
found or if the maximum number of blocks for this runtime group has been reached, a 
new one is created. The names of the runtime groups are created generically, for 
example "@@OB100@@(2)". 

You can assign runtime attributes to objects you have inserted in the runtime groups. For 
more information, refer to the section: Task attributes (Page 165) 

How are runtime groups created? 
Runtime groups can be created in two ways: 

● Automatically 

CFC:After you have created a new CFC chart, a runtime group is automatically generated 
and inserted according to the chart installation pointer. The properties of automatically 
generated and manually created runtime groups differ: 

The automatically generated runtime group and the chart form a dependent relationship 
that is maintained until the name of the runtime group is modified.  

This dependent relationship ensures identical names both of the runtime group and of the 
chart. The name of the runtime group is automatically updated when the chart name is 
modified.  

When this dependent relationship no longer exists (due to modification of the runtime 
group name), the automatically generated runtime group responds as any other manually 
inserted runtime group. 
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OB100:If blocks with runtime relevance are used, they are installed not only in the cyclic 
OB but also in OB100 in a runtime group created by CFC. A maximum of 10 blocks are 
installed in a runtime group. When more blocks need to be installed, additional runtime 
groups are created. 

Driver generator:When creating module drivers, runtime groups are created with the 
identifier "@..." and these can then only be processed by the driver generator.  

● Manually 

You can create runtime groups manually at any time using the menu command Create 
New or Copy. The name of a runtime group you copy and paste into the run sequence is 
appended a consecutive number without brackets. 

Creating a new runtime group  
In order to create a runtime group, proceed as follows: 

1. Select the menu command Edit > Run Sequence... or click the button 

 
The runtime editor opens and displays the run sequence window. 

2. In the left window, select the task in which you want to install the runtime group or an 
object as the default insertion position for the runtime group. 

3. Select the menu command Insert > Runtime Group.... 
The "Insert Runtime Group" dialog box opens. 

4. Enter the name and comment in the corresponding boxes. 
You can enter the name in either upper or lower case letters. 

5. Enter the values for the runtime attributes. If this function is not supported by the target 
system, the attributes “reduction ratio” and “phase offset” are deactivated and displayed 
in gray. 

6. If necessary, modify the preset options: 

– Optimize run sequence (you will find information on this topic in the section: 
Optimizing the run sequence (Page 160)) 

– Active (the runtime group is active for editing in test mode) 
Exception: "Active" is always set in F systems. 

7. Close the dialog by clicking “OK”. 
The runtime group is inserted at the required point. 

Editing a runtime group 
1. Select the runtime group in the left or right window and then  

 select the menu command Edit > Object Properties.... 

2. In the "Properties - Runtime Group" dialog box, modify the existing values (name, 
comment, phase offset, reduction ratio). 

Do not edit runtime groups with the "@..." identifier. Those objects are created when the 
module drivers are generated and should only be manipulated by the driver generator. When 
they are no longer required, they will be deleted again by the driver generator. 
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You can edit the runtime groups created in OB100 (@@OB100@@...) by the system. 

Activating and deactivating a runtime group 
You can activate or deactivate runtime groups for editing by selecting/deselecting the 
“Active” check box in the run sequence. This function only affects runtime groups that are not 
interconnected. 

Deleting a runtime group 
You can only delete runtime groups that do not contain objects.  

1. Select the runtime group and then  
 select the menu command Edit > Delete or press <Del>. 

2. With the menu command Edit > Delete Empty Runtime Groups, you can delete all empty 
runtime groups of the current S7 program after confirming a prompt. 

 
  Note 

If the deleted runtime group was selected as the "Predecessor for Insertion Position", the 
default insertion position is moved to the next element of the task before the deleted 
group or, if no additional element exists, to the start of the task. 

 

9.10.8 Task attributes 

Attributes    
A runtime group is assigned the following attributes: 

● Enable attribute (Page 320) 

● Scan rate (Page 327) 

● Phase offset (Page 322) 

The runtime group passes these attributes on to all the objects it contains. 
The attributes are assigned when the runtime group is created. The reduction ratio and 
phase offset can also be modified later in the object properties. The enable attribute can be 
controlled via an interconnection. 

 

 NOTICE 

Whenever possible, only use the reduction ratio and phase offset in tasks that run in 
defined cycles, in other words in cyclic interrupts. Handle all other tasks very carefully, 
particularly the hardware interrupt OBs and any special OBs. Here, you should not change 
the default reduction ratio=1 and phase offset=0. 
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9.10.9 Display of block execution 

Introduction  
In CFC, blocks that are not executed are identified visually. This is done in the runtime 
properties field in the block header.  

Edit mode 
In edit mode (offline), the blocks are identified as follows: 

● Block is executed (no identification) 

 
The following blocks are identified in this way: 

– Blocks whose EN input is not interconnected and is set statically to 1. 

– Blocks which are located in runtime groups that are not interconnected and are 
activated statically. 

– Blocks for which there are no SFC write accesses to their block EN and their runtime 
group EN. 

● Block is not executed (red box with a yellow exclamation point) 

 
The following blocks are identified in this way: 

– Blocks whose EN input is not interconnected and is set statically to 0. 

– Blocks which are located in runtime groups that are not interconnected and are 
deactivated statically 

– In test mode: If the interconnection to the EN block or EN runtime groups writes a "0". 

● Block execution uncertain (yellow field with a black question mark) 

 
The following blocks are identified in this way: 

– Blocks that are not covered by the above lists, for example because their EN is 
interconnected or SFC access is in place (or if their runtime group is interconnected or 
SFC writing operations exist there), and whose execution status is therefore not static. 
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Test mode 
In test mode (online), the CFC obtains the enable values of the blocks and runtime groups 
and uses them to control the display. Here, there are two statuses: 

● Block is executed 

 
(no identification) if the EN of the block and the EN of the group are set to "1". 

● Block is not executed 

 
(red box with a yellow exclamation point) if the EN of the block or the EN of the group is 
set to "0". 
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9.11 Handling of control module types 

9.11.1 Basic information on control module types 

Introduction 
You can configure control module types and control modules in the same way as process 
tag types and process tags. Control modules and their types offer the following advantages: 

● Synchronization is available when there are differences between the type and instance. 
Instance-specific extensions are managed as such and are not lost when the type and 
instance are synchronized. Changes can therefore be bumplessly loaded in the 
automation system. 

You can find additional information on synchronization in the section "Relevant attributes 
for synchronization of control module types and their instances (Page 180)". 

● A control module type can include optional blocks. If different instances of a control 
module type are created, the optional blocks can be inserted into different instances in 
different versions. 

● The use of control module types and control modules enables extended data exchange 
with Advanced ES and COMOS Integrated Engineering. 

Components of a control module type 

A control module type consists of: 

● the technological interface. 

This can optionally contain the following objects: 

– Sub-control modules; possibly more than one 

– The following objects can be used multiple times as control variables: 

Parameters 

Signals 

– Messages; possibly more than one 

– Commands; possibly more than one 

– States; possibly more than one 

● The assigned CFC chart with its possible components, for example, blocks, subcharts. 

You can find additional information on this in the section "Overview of data objects of the 
equipment module and control module (Page 187)". 

Creating a control module type 
You can create control module types from the plant view of a project library in SIMATIC 
Manager or directly in the CFC editor. They can also be converted from a process tag type. 
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The figure below provides you with an overview of the creation of a control module type as a 
new module type or by migration from a process tag type and the creation of associated 
instances. 

 
You can find information on creating a new control module type in the section "How to create 
a control module type (Page 170)". 

Information on creating control module types using migration can be found in the "Process 
tag type migrator help". 

Editing of control module types 
Control module types and their associated instances are edited in their own window within 
the CFC Editor - the technological editor. 

You can find additional information on this in the section "Editing of control module types 
(Page 171)". 

Optional blocks and interconnections on a control module type 
Blocks can be defined as optional within a control module type, which means that an 
individual selection of optional blocks and interconnections can be made for each instance 
when you create an associated control module.  
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Example: Control module type in the technological editor and with optional blocks 

 

Additional characteristics of control module types 
● You can drag several interconnections to one input with control module types, which is 

not possible with a CFC. The prerequisite for this is that the "Optional" attribute is 
activated in the control module type to be configured as interconnection target. 

● In the CFC Editor, elements that belong to the definition of the control module type, such 
as blocks and connections, are highlighted in color. You may customize the colors used 
for this purpose. 

9.11.2 How to create a control module type 

Requirement 
You have created a multiproject with a master data library using the SIMATIC Manager. 
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Procedure 
To create a control module type in the SIMATIC Manager, follow these steps:  

1. Open the library in the project. 

2. Use the menu command View > Plant view to change to the plant view 

3. Right-click a folder to select the menu command Insert new object > Control module type. 

The control module type is inserted and assigned a default name by the system that you 
can change to suit your purposes.  

Result 
The control module type has been created. You can specify the structure of the control 
module type in a new window and assign the corresponding objects or attributes in the CFC 
chart. 

You can find additional information on this in the section "Editing of control module types 
(Page 171)". 

9.11.3 Editing of control module types 

Requirement 
You have created at least one control module type. You can find information on creating a 
control module type in the section "How to create a control module type (Page 170)". 

Editing of control module types within the CFC Editor  
If a control module type is initially created or opened, a new editing window opens in the 
CFC Editor. This technological editor provides the following operating options:  

The left section of the technological editor shows the objects of the control module type 
arranged hierarchically.  

Here you can edit the following objects: 

● Control module 

● As control variables: 

– Signals 

– Parameters 

● Message 

● Command 

● Status 
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You can create, copy and delete these objects via a shortcut menu. To create such an 
object, open the shortcut menu with a right-click on the higher-level control module and then 
select a new object. You can also insert a block from the CFC Editor to the hierarchy of the 
control module with drag-and-drop. 

The attributes and assignments are located in the right section of the technological editor. 
The attributes that are displayed depend on which object is selected in the left window. 
Depending on the attribute, you can fill the text boxes either with a free text per drag-and-
drop from the CFC Editor or from a drop-down menu. Boxes that are grayed out cannot be 
edited. 

You can find more information on attributes in the section "Attributes and attribute values of a 
control module (Page 175)". 

Data types for control variables "Parameter" and "Process value" 
A control variable is either of the "parameter" or "process value" variable type, depending on 
its assigned block I/O.  

Only the REAL, BOOL, INT and DINT data types are valid for the "Process value" variable 
type because these define an I/O channel request.  

However, the data type at the assigned driver block may also be BYTE or WORD. In such a 
case, the data type is mapped as follows: 

● BYTE at the driver block is equivalent to BOOL at the control variable 

● WORD at the driver block is equivalent to REAL at the control variable 

Exchange of standard functions in COMOS 
You can use the simple standard functions in COMOS, for example, to configure an interlock 
logic for control modules. Following data exchange with COMOS, these standard functions 
are mapped to control modules. The AND, OR, XOR and NOT standard functions are 
predefined in PCS 7. They are available on the "Templates" tab of the template catalog, 
provided a control module has been created. 

You may define other standard functions. This is done by creating a control module that has 
an interface which exactly corresponds to the definition in COMOS. The names of the control 
modules and control variables and their data type must match precisely. The check box for 
the "Standard function" attribute must be selected. The PCS 7-specific implementation of the 
standard function is defined in the corresponding CFC.  

Along with the standard data types, standard functions may be assigned generic data types 
ANY_BIT, ANY_NUM, ANY_REAL or ANY_INT. These are displayed in the technological 
editor by the "Data type" attribute of control variables. The following rules apply if a control 
variable with a generic data type is assigned to a block I/O in the CFC: 

● ANY_BIT is assigned BOOL, BYTE, WORD, or DWORD. 

● ANY_NUM is assigned REAL, INT or DINT. 

● ANY_REAL is assigned REAL. 

● ANY_INT is assigned INT or DINT. 

Only block I/Os that fulfill the rules described above can be assigned. The user has to 
perform the assignment manually. 
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Display in the CFC Editor 
● Control modules are color-coded in the CFC Editor. The following objects are marked:  

– Blocks and interconnections that belong to the control module type 

– Blocks and interconnections that are optional 

– Connections assigned to the control module type 

You may customize the colors used for this purpose. To do so, select "Options > 
Settings > Colors...". In the next "Color settings" dialog, select the "Control module 
type blocks and I/Os" object under "Objects". 

● Blocks that are part of the standard functions are also color-coded in the CFC Editor. 

You may customize the colors used for this purpose. To do so, select "Options > Settings 
> Colors...". In the "Color settings" dialog which follows, select the object "Standard 
function" under "Objects". 

9.11.4 Configuring a command or status at the type of the control module 

Introduction 
Commands and states can only be defined at the type of control module, not at an instance.  

Commands and states are identified by a name and there can be more than one. They can 
be selected and copied individually or collectively in the technological editor.  

You can find additional information about commands and states in the section "Overview of 
data objects of the equipment module and control module (Page 187)". 

Requirement 
A control module type is created in the master data library. 

Procedure 
1. In the master data library, open the control module type in the CFC editor. 

2. Select the icon for the control module type in the technological editor. 

 
3. Select the "Insert new object" command from the shortcut menu. 

All available objects are shown in the shortcut menu.  
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4. Select the "Command" or "Status" menu command. 

The selected object is inserted and displayed as an icon.  

– Command 

 
– Status 

 
A lower-level "Parameter" object named "OUT" is created automatically for a new 
status. This parameter has the BOOL data type and serves as the formal output 
parameter.  

5. Select the icon for the "Command" or "Status" in the technological editor. 

The associated attributes are displayed.  

Configure the attributes, for example, the name, comment and author.  

6. Select the icon for the "Command" or "Status" in the technological editor. 

In the shortcut menu, select the menu command "Properties".  

The "Properties" dialog box opens.  

For "Command", the dialog has a similar structure to the dialog for step configuration; for 
"Status", the dialog has a similar structure to the dialog for the configuration of transition 
conditions. 

7. Configure the desired conditions for the command or status. 

You can also use the "Browse" button to open a selection dialog. All the parameters that 
can be used, i.e. only the block I/Os that have an identifier "S7_contact = true", are 
displayed in this dialog box.  

Read the section titled "Special considerations for the implementation of specific 
commands/statuses (Page 230)" for more information. 

8. Select the desired parameter. Click the "Apply" button to apply the selected parameter in 
the line previously selected of the "Properties" dialog box. 

In the "Properties" dialog box, the next row of conditions is selected automatically and the 
selection dialog box remains open. If needed, repeat this step to configure additional 
conditions.  

Click "Close" to close the selection dialog. 

9. Click "Close" to close the "Properties" dialog box. 

If required, a prompt for applying the configuration is displayed. Confirm this prompt. 

Result 
Commands and/or states are defined at the control module type.  

Lower-level parameters may also have been inserted for these objects optionally.  

A parameter named "OUT" is created automatically at the status. 
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9.11.5 Attributes and attribute values of a control module 

Attributes and attribute values 
In the left section of the technological editor, the objects in a control module or equipment 
module are represented hierarchically in a tree structure, for example a "Parameter" or 
"Message".  

The right section lists the attributes for the object that is currently selected in the tree.  

  

Note regarding the "Data exchange" column in all subsequent tables  

This column indicates whether an attribute is included in the data exchange with COMOS 
Integrated Engineering or Advanced ES. 

Attributes for higher-level control module 
 
Attribute Description of attribute values Data exchange 
Assigned chart Cannot be edited No 
Name Can be edited, is forwarded to associated objects 

Gets the name of the assigned chart as default value 
Yes 

Comment Can be edited, is forwarded to associated objects No 
Author Can be edited, is not forwarded to associated objects No 
Function 
identifier 

Can be edited, is forwarded to associated objects No 

Location identifier Can be edited, is forwarded to the DOCPRO footer 
"Code field according to location" of the assigned chart 

No 

Sampling time Can be edited, all blocks of the assigned chart are 
installed in the OB with the most suitable sampling time. 
The next higher value will be entered in case of an 
invalid entry. 
The runtime editor is adapted accordingly. 

Yes 

Standard function Can be edited, is used to identify a control module as a 
standard function. 

No 

Standard function 
name 

Displays the name of the standard function. 
• Cannot be edited at the type of the control module.  

When the "Standard function" attribute is enabled, 
the value of the "Name" attribute is applied 
automatically. 

• Can be edited at the instance. 

No 

Control module 
type 

Cannot be edited, is not forwarded No 
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Attributes for a lower-level control module 
 
Attribute Description of attribute values Data exchange 
Assigned block Cannot be edited No 
Name Can be edited, is forwarded to associated objects 

Gets the default value "Control module" 
Yes 

Comment Can be edited, is forwarded to associated objects No 
Operation symbol Can be edited, is forwarded to the block icon (for WinCC) 

of a block according to the assignment 
No 

Optional Select the check box for optional activation of this control 
module. 

Yes 

Author Can be edited, is not forwarded to associated objects No 
Control module 
type 

Cannot be edited, the name of the control module type is 
displayed here. 

No 

  

Attribute for the "Process value"/"Parameter" objects 
 
Attribute Description of attribute values Data exchange 
Assigned I/O Cannot be edited No 
Interconnection to Can be edited, the interconnection is displayed here No 
Name Can be edited, is not forwarded Yes 
Comment Can be edited, is not forwarded Yes 
Process value Can be edited, right-click the text box to open the symbol 

table of the CFC using the menu command "New signal 
interconnection". The value is forwarded to the 
"Interconnection" property of the assigned I/O. 

No 

Value Can be edited, is forwarded to the "Value" property of the 
assigned I/O 

Yes 

Negation Select the check box to negate the control variable. The box 
can only be selected if there is an interconnection. 

No 

Enumeration Can be edited, is forwarded to the "Enumeration" property of 
the assigned I/O. The attribute s7_Enum must be configured. 

No 

Unit Can be edited, is forwarded to the "Unit" property of the 
assigned I/O. The attribute s7_unit must be configured. 

No 

Operation identifier Can be edited, is forwarded to the "Identifier" property of the 
assigned I/O. The attribute s7_shortcut must be configured 

No 

IO type Selection via drop-down menu, must match IO type of the 
assigned I/O 

No 

Data type Selection via drop-down menu, must match data type of the 
assigned I/O 

Yes 

Variable type "Process value" or "Parameter", selection via drop-down 
menu. Forwarded to the assigned I/O. 

Yes 

Control module 
type 

Cannot be edited No 
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Attributes of the "Message" object  
 
Attribute Description of attribute values Data exchange 
Assigned message Cannot be edited No 
Name Can be edited, is not forwarded to associated objects 

Gets the default value "Message". 
Yes 

Message class Cannot be edited, this value is inherited from the 
"Message class" property of the assigned single message. 

No 

Priority Can be edited, only numbers possible. The value "0" is 
entered in case of an invalid entry. Forwarded to the 
property "Priority" of the assigned single message. 

Yes 

Message identifier must be specified manually 
If an invalid message identifier (e.g. SIG1) is entered, the 
attributes message class, event and origin are 
automatically applied if the assigned block has a message 
response. 

No 

Event Cannot be edited, is inherited from the "Event" property of 
the assigned single message 

No 

Information Forwarded to the "Infotext" property of the assigned single 
message. 

No 

Origin Forwarded to the property "Origin" of the assigned single 
message. 

No 

  
 

 Note 

It may not be possible to edit some attributes, because of dependencies to other attributes. 
 

Attributes of the "Command" object 
 
Attribute Description Data exchange 
Name Can be edited, is not forwarded 

Gets the default value "Command". 
Yes 

Comment Can be edited, is not forwarded Yes 
Author Can be edited, is not forwarded to associated objects Yes 
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Attributes of the "Status" object 
 
Attribute Description Data exchange 
Name Can be edited, is not forwarded 

Gets the default value "Status". 
Yes 

Comment Can be edited, is not forwarded Yes 
Author Can be edited, is not forwarded to associated objects Yes 

  

Assignments 
You can only fill the text boxes of the "Assignment" column by dragging and dropping 
parameters or blocks from the CFC Editor or by right-clicking on the text box and selecting a 
shortcut menu. 

See also 
Attributes of the objects of an equipment module (Page 225) 

9.11.6 Comparing and synchronizing the type and instances of a control module 

Introduction 
The type and instance of a control module are identical when the instance is created.  

Synchronization of the type and the instances may be required when changes are made to 
the type or its associated instances.  

Comparison and synchronization 

During synchronization, all instances of a type in the project are compared to the 
corresponding type in the master data library. This shows the differences between the types 
of the control module and their instances (process engineering level) and between the 
associated objects, such as CFCs (program level).  

Attributes and relations that are relevant for synchronization become part of the comparison 
result. Attributes and relations that are usually modified at the instance, on the other hand, 
are excluded from the comparison and are not displayed in the comparison result. 

The display of the comparison result is based on the instances of the control modules below 
the plant hierarchy nodes. In addition to the objects mentioned above, you therefore also see 
the higher-level objects of the control modules in the comparison dialog box. These serve 
merely as a navigation or orientation aid. 
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Included objects 

The following lower-level objects are included in the synchronization of the type and 
instances of control modules on the plant level: 

● Sub-control modules 

● Control variables: 

– Parameters 

– Signals 

● Messages 

Commands and states, however, are generally not involved, because they are not permitted 
at the instances by definition. 

Procedure 
1. Select the project in the plant view. 

2. Open the shortcut menu and select the menu command "Technological types > 
Synchronize...". 

A dialog box opens.  

3. Select the desired types of control modules or equipment modules as well that you want 
to compare and synchronize in the left column of the table. 

4. Click the "Synchronize..." button to start the comparison. 

Only relevant attributes and relations are included in the comparison. You can find 
additional information on this in the section "Relevant attributes for synchronization of 
control module types and their instances (Page 180)".  

5. The comparison result is displayed. 

The following objects are highlighted in the comparison result:  

– Objects added at the instance, for example sub-functions, messages, functions and 
function blocks, are marked as additional objects. 

– Deleted objects. 

– Objects with modified attributes. 

6. In the comparison result, select the instances to be synchronized to the corresponding 
type. 

Select or clear the check boxes next to objects at the left in the dialog.  

7. Start the synchronization with the "Synchronize templates" icon. 

The selected instances are synchronized. 

Instance-specific extensions are retained if they do not apply to objects of the type.  

Result 
A comparison of the types of control modules and their instances has been performed and 
selected instances have been synchronized.  
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9.11.7 Relevant attributes for synchronization of control module types and their 
instances 

Introduction 
An identity check of the type and its instances is performed to synchronize control modules 
and their types. This check is limited to attributes and relations that may not be modified at 
the instance according to the type instance concept.    

Precisely these attributes and relations are compared for the synchronization between type 
and instances to ensure compatibility and conformity.  

Comparison and display of result  

Attributes and relations that are relevant for synchronization become part of the comparison 
result. Attributes and relations that are usually modified at the instance, on the other hand, 
are excluded from the comparison and are not displayed in the comparison result. 

The data transfer dialog is available in PCS 7 to display the comparison result and for 
synchronization. The actual synchronization process is started in this dialog. 

The display of the comparison result is based on the instances of the control modules below 
the plant hierarchy nodes. In addition to the objects mentioned above, you will therefore also 
see the higher-level objects of the control modules in the comparison dialog. These serve 
merely as a navigation or orientation aid. 

Overview of attributes and relations relevant for synchronization 
The table below lists all objects that are relevant for synchronization with the attributes and 
relations that are to be synchronized: 

 
Object Relevant attributes  Relevant relations 
Control module -  • Assigned block (block instance or 

sub-CFC) 
• Assigned name 
• Assigned comment 
• Assigned function identifier 
• Assigned block symbol 

Control variable • Negation (only with interconnected inputs) 
• Name 
• Variable type (Parameter/signal) 
• Data type 
• Comment 
• Operation identifier 
• Unit 
• Enumeration 

• Interconnection 
• Assigned I/O (block variable) 

Message • Name 
• Message identifier 

Assigned message 
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Object Relevant attributes  Relevant relations 
Block instance • Name 

• S7_mes 
• Block type (function/function block) 

Block type (instance of function/function 
block) 

Block variable • inverted (only with interconnected inputs) 
• Name 
• Comment 
• I/O type 
• Data type 
• Value 
• S7_edit 
• S7_visible 
• S7_mes 
• S7_archive 
• S7_enum 
• S7_string0 
• S7_string1 
• S7_shortcut 
• S7_unit 

Interconnection source 

Sub-CFC • Name 
• Version 

 -  

Interface of the CFC chart  -   -  
Interface parameters 
of the CFC chart 

• Name 
• Comment 
• I/O type 
• Data type 
• Value 
• S7_edit 
• S7_visible 
• S7_mes 
• S7_archive 
• S7_enum 
• S7_string0 
• S7_string1 
• S7_unit 

 

Block message • Message identifier 
• Message type 

 

Sub-message Message identifier (sub-message number)  
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See also 
Basic information on control module types (Page 168) 
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9.12 Configuring and Using Equipment Modules 

9.12.1 Basics of equipment modules and their types 

Introduction 
Terms 

The English terms "Equipment Module (EM)" and "Equipment Phase (EPH)" are used in the 
international language environment according to the ISA-88 standard. In German-speaking 
countries, the terms "Technische Einrichtung" ("Equipment module") and "Technische 
Funktion" ("Equipment phase") are used. You can find additional information about 
classification in the "ISA-88" standard in the section "Classification of the equipment module 
in the ISA-88 standard (Page 197)".  

Concept of the equipment module 

The so-called "equipment phase" is a component of an equipment module. Control 
strategies, setpoints, other parameters and the actual procedural control with the sequencers 
is defined in the "equipment phase". The actions and transition conditions of the sequencer 
can be described using commands and status. 

A control module is used to assign the equipment module to the sensors and actuators on 
the control-loop level. Commands and states can be defined specifically at the control 
modules or globally in the master data library for the step and transition programming.  

 
The configured mapping on the technological level in the system description between the 
equipment module and the control modules is automatically implemented in PCS 7 for the 
automation level in the corresponding CFC interconnections between the given blocks.  

Although control modules can also be used for continuous processes, they are preferably 
used together with the equipment modules for batch processes. 
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The control module in the equipment module 

● A control module can be assigned to an equipment module.  

The following configuration options are available:  

– The control module to be assigned is integrated as a component of the equipment 
module type and is therefore available as a lower-level object. 

If this control module is available as a type in the master data library, a so-called 
"Control Module Assignment" is configured for this lower-level object "Control 
module". The so-called "role" is also defined in the "Control Module Assignment".  

If this control module is not available as a type in the master data library, it can be 
integrated as a lower-level object in the equipment module, even without an 
associated "Control Module Assignment". This type of control module makes sense for 
example for interlocks or calculations.  

 
  Note 

A control module that is assigned a "role" via the "Control Module Assignment" cannot be 
designated as "optional"! 

 

– The control module is not a component of the equipment module type. 

The "Control Module (Basic Requirement)" and "Control Module Assignment" objects 
are then configured for this control module. 

The the minimum requirements for the control module to be assigned, e.g. the 
required commands or feedback about the status, are described in abstract in the 
"Control Module (Basic Requirement)".  

The so-called "role" is also defined in the "Control Module Assignment".  

● A control module can be designated as as optional at the type of an equipment module. 

This means that this control module may also be omitted at an instance of the equipment 
module in accordance with the real plant. 

 
  Note 

When an optional control module that is defined as a process tag (e.g. calculations, 
interlocks, etc.) is omitted, the user must ensure that certain control strategies are 
prohibited at the instance! 

 

● A control module can be addressed in the sequencers of the equipment module using 
commands and states. 

● A control module that is a component of the equipment module type can be defined as a 
"basic requirement". The "Basic requirement" attribute is set at the control module for this. 
Thereafter, the control module is no longer a component of the equipment module type. 
With this procedure, the properties of the control module can be implemented in a basic 
requirement. In addition to the basic requirement, a "Control Module Assignment" is 
configured as described in the section above on configuration options. 
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Basics of the equipment module 
Brief overview  

The following description gives a brief overview of the data objects for equipment modules 
and control modules and the global command or status.  

You can find additional information on this in the section "Overview of data objects of the 
equipment module and control module (Page 187)."  

Elements of the equipment module 

● Equipment phase (EPH) with its sequencers and parameter descriptions always has to be 
available in the equipment module, but only once. 

 The following objects can be optionally contained: 

● Control module as an integral part of the type, several are possible 

● Control Module Assignment; several are possible 

● "Control Module (Basic Requirement)" (or Control Module Requirements), in which the 
minimum requirements for the control module are defined. 

Cannot be marked as optional, several are possible 

● The following objects can be used multiple times as control variables: 

– Parameters 

– Signals 

● Messages; possibly more than one 

Elements of the control module  

The control module can optionally contain the following objects: 

● Sub-control modules; possibly more than one 

● Commands; possibly more than one 

● States; possibly more than one 

● The following objects can be used multiple times as control variables: 

– Parameters 

– Signals 

● Messages; possibly more than one 

Commands and status 

The "Command" and "Status" objects can be defined as follows: 

● At the type of a control module (not at an instance) or at a "Control Module (Basic 
Requirement)". 

These commands and states are specific to these objects.  

● Globally, i.e. with the SIMATIC Manager in the master data library. 

These global commands and states are generally based on equipment phases and can 
be used in all equipment phases of a plant. 
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You can find additional information on this in the section "Overview of data objects of the 
equipment module and control module (Page 187)" in the tables for the data objects of the 
control module and the globally defined data objects. 

Type and instance of an equipment module 
The type-instance concept is used for repeated usage. The advantage of the type-instance 
concept is the ability to make changes to the type at a central location and then to transfer 
the changes by synchronizing the instances.  

● Synchronization is available when there are differences between the type and instance. 
Instance-specific extensions are managed as such and are not lost when the type and 
instance are synchronized. Changes can therefore be bumplessly loaded in the 
automation system. 

● The type and instance of equipment modules and control modules are included in the 
data exchange with COMOS Integrated Engineering. 

Type and instance: 

● A type of equipment module can be created in the plant view of the SIMATIC Manager in 
the master data library. 

The type is created and managed in a master data library. It can be created, copied and 
deleted with the SIMATIC Manager. 

● The instances are the repeated uses of a type in the plant description of the plant 
hierarchy. 

Instances of a type are created simply by copying the type from the master data library 
into the project under a node in the plant hierarchy.  

When the control modules are assigned to the instances, the connections to the control-
loop level and the specific control modules are created as well.  

The following figure shows the ways to create a type and instances. 
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Naming the type and instance  

The name of this type is unique within the master data library, exactly like the control module 
types.  

The types of equipment modules share a namespace in the master data library with the 
following objects:  

● Type of a control module 

● Global commands and status 

Therefore, an equipment module type cannot have the same name as a control module type. 

The instances of the equipment module type are hierarchically addressed through the plant 
hierarchy. Higher-level units are therefore unique. 

Comparison and synchronization of type and instance 

You can information on this in the section "Comparing and synchronizing the type and 
instances of an equipment module (Page 220)". 

Data exchange with COMOS 
The import functions of the automation interface (AI) can be used to transfer the types of 
equipment modules (basic functions) defined on the engineering level with COMOS 
Integrated Engineering to the PCS 7 process control system. The associated sequencers, 
transition conditions and actions are imported along with the types. 

This enables the data generated on the engineering level in COMOS in the form of 
equipment modules and their equipment phases to be imported into PCS 7 and thereby 
entered in the automation layer. There, the data appear as sequencers (SFC) and 
automation programs (CFC). 

You can find additional information on this in the section "Overview of data exchange with 
COMOS (Page 199)". 

9.12.2 Overview of data objects of the equipment module and control module 

Introduction 
The following tables describe:  

1. Data objects of the equipment module 

Icon in the technological editor: 
 

2. Data objects of the equipment phase 

Icon in the technological editor: 
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3. Data objects of the control module 

Icon in the technological editor: 
 

4. Globally defined "Command" and "Status" objects 

Icons:  
 
 

Data objects of the equipment module 
An equipment module consists of the following elements, of which there can be one or 
several.  

 

 Note 

No "Command" and "Status" objects can be defined in an equipment module. They can be 
defined either specifically for a control module type or basic requirement, or as "global" 
objects. You can find additional information on this in the tables below.  

 

  

 
Object/icon Description 
Equipment phase 
(EPH) 

 

The equipment phase defines the sequential control system with the sequencers and their 
parameter descriptions (e.g. setpoints, control strategies, parameters, messages). 
The equipment phase must be contained in the equipment module once and only once. 
Each equipment module must be assigned one and only one equipment phase. 
The elements are described in the table below, "Data objects of the equipment phase". 

Control Module 
  

 

A control module can be configured as component of an equipment module type.  
Several control modules can be present. 
Optional control modules:  
• Control modules can only be defined as "optional" at the type in the master data library. 
• Control modules can only be defined as "optional" on the first sub-level under an 

equipment module type. 
• The nesting depth for control modules under the equipment module is limited to a 

maximum of 3 levels. 

This means that an equipment module can only have a maximum of two sub-levels of 
lower-level control modules, for example, the levels "Equipment module > Control 
modules > Lower-level control modules". 

Note: 
A control module that is a component of the equipment module type can be defined as a 
"basic requirement". The "Basic requirement" attribute is set at the control module for this. 
The control module is then no longer a component of the equipment module type and the 
blocks of the control module are deleted from the model.  
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Object/icon Description 
Control Module Assignment 
  

 

If a control module is to be controlled in the sequencers, the equipment module must be 
assigned to the control module. 
The assignment configures the following:  
1. The "role". 

The so-called "role" of the control module is set in the equipment module type, but no 
specific control module. 

The "role" indicates how the assigned control module is used in the context of this type, 
e.g. that an assigned "valve" control module has the "role" of an "outlet".  

The "role" is used to address the target control module in the actions and transition 
conditions of the sequencers. 

2. The link to a control module or basic requirement. 
– When the control module is integrated in the type of the equipment module, this 

control module is assigned. 
– If the control module is not integrated in the type, a corresponding basic requirement 

is assigned. 

The specific requirements for the control module to be assigned are specified 
themselves under "Control Module (Basic Requirement)" described below. 

The assignment can be provided with a comment. 
There can be more than one assignment.  
If a "Control Module Assignment" is configured, you must also create a corresponding basic 
requirement or a control module that is integrated in the type. 

Control Module (Basic 
Requirement) 
(also "control module 
requirements") 

 

The minimum requirements for the control module to be assigned are abstractly described in 
the "Control Module (Basic Requirement)".  
The requirements include,in particular, the necessary commands as well as feedback about 
the status. 
• There can be more than one basic requirement. 
• The basic requirements are needed at the equipment module type to enable the use of 

commands and states, for example, in the procedural logic. 
• The "Command" and "Status" objects can be defined at the basic requirement. 

For additional information, refer to the section "Special considerations for the 
implementation of specific commands/statuses (Page 230)".  

• A basic requirement cannot be defined as optional. 
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Object/icon Description 
Parameters 
  

 
 

• There can be several parameters. 
• The "Parameter" object can be used: 

– As a sub-object of an equipment module or control module. 
– As a formal parameter of commands and states. 

These formal parameters define in the equipment phase placeholders for specific 
parameters or constants at the points of use in the actions and transitions of the 
sequencer.  

• The "Value" and "Signal" attributes and the "Interconnection" relation can only be 
entered as alternatives. 

• The "Signal" attribute is only allowed for input parameters and is disabled for output 
parameters. 

• The "Negation" attribute is only allowed for input parameters of the "BOOL" data type 
and is disabled for output parameters. 

For input parameters, the "Negation" attribute relates to the parameter interconnection or 
the signal. 

Signals 
  

 

• There can be several signals. 
• The attributes of signals are represented in the same way as parameters in the 

technological editor. The input boxes of the "Value", "Enumeration", "Operation 
identifier", "Unit" and "Interconnection" values or relations are disabled, however. 

• The "Negation" attribute is only allowed for input parameters of the "BOOL" data type 
and is disabled for output parameters. It applies to the "Signal" attribute for signals. 

Messages 
  

 

An equipment module can generate messages by default. 
• There can be several messages. 
• Messages can be configured directly under the equipment module. They then apply only 

to the block instance of the SFC type in the associated CFC. To assign the 
corresponding message, the message inputs of this block instance of the SFC type must 
be set as visible. 
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Data objects of the equipment phase 

An equipment phase consists of the following elements, of which there can be one or 
several:  

 
Object/icon Description 
Parameters 

 
Used for the parameter 
description 
  

• The parameter descriptions of the technical phases correspond to the so-called 
characteristics, which are set at the SFC type. 

• In the context of integration on the engineering level (COMOS Integrated Engineering), 
there is a limitation to the parameters and attributes required for the process engineering 
in the data exchange models. 

• Parameters can be used as sub-objects of an equipment phase in order to define as 
individual variables the equipment phase interface externally and internally to the 
sequencers. 

You can find additional information on this at the end of this table.  
• Control strategies 

  

Various process engineering procedures can be defined using control strategies. 
The control of sequencers is basically a function of the control strategies. Control strategies 
are important for higher-level recipe control level (batch systems). 
Attributes: 
• Name 
• Number 
• Comment 
• Assigned setpoint 

The assignment of a setpoint to a control strategy is performed in the COMOS data 
exchange model using a relation (assigned control strategy). 

• Setpoints 

  

Setpoints can be specified in process engineering by manual operation or by a higher control 
level (batch system). 
Setpoints are assigned to individual control strategies. The actual (process) value is always 
offered as a control variable in addition to the setpoint. 
Attributes: 
• Name 
• Data type 
• Comment 
• Low limit 
• High limit 
• Unit (of measure) 
High, low limit and unit (of measure) are typically determined or adapted at the instance of the 
equipment module.  
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Object/icon Description 

• Actual values 

(process values) 

The integration of process values in the equipment module is used to control sequencers, 
e.g., using an actual value for step-enabling the sequencers.  
Attributes: 
• Name 
• Data type 
• Comment 
• Unit (of measure) 
The unit is typically set at the instance of the equipment module. 

• Control values 

  

Control values are required to connect external control modules, which are not directly 
accessible through the control module contacts. 
Attributes: 
• Name 
• Data type 
• Comment 
• Unit (of measure) 
The unit is typically set at the instance of the equipment module. 

• Parameters 

  

A parameter is used to influence the behavior of an equipment phase in an instance, for 
example, with options. These parameters can also be used to set limits for specific instances. 
Attributes: 
• Name 
• Data type 
• Comment 
• Unit (of measure) 

• Bit memory 

  

Bit memory is needed to temporarily store values. It is only used locally in the sequential 
control system. 
Attributes: 
• Name 
• Data type 
• Comment 

• Timers 

  

Timers are used, for example, for time monitoring or calculation of run time. 
Attributes: 
• Name 
• Comment 

• Note texts 

  

Note texts are used, for example, for the user interface. 
Attributes: 
• Name 
• Text 

• Position texts 

  

Position texts are used to display the current procedural status on the operator station.  
Attributes: 
• Name 
• Text 
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Object/icon Description 
Sequencer 
(or phase sequencer) 

The process engineering task - the equipment phase - is defined in a sequencing logic. This is 
described using sequencers. The behavior must be defined for each control strategy for each 
state of the equipment phase. 
The sequencers have exactly one start step and one end step. 
Sequencers can include the following elements, which are familiar from the SFC type: 
• Steps 
• Transitions 
• Alternative branches 
• Simultaneous branches 
• Loops 
• Jumps 
Both alternative and simultaneous branches are symmetrically merged again. 
The actions that are defined for a step on the process engineering level in COMOS are 
described with commands in the form of a list. The commands used for this are centrally 
provided on the control module, e.g. motor, valve. Commands can be defined as well at the 
equipment module. 
The transition conditions are set on the process engineering level in COMOS as expressions 
with a Boolean result using the status and logical standard functions.  
One or more states provided by the control modules, e.g. motor, valve, as well as the status 
defined at the equipment module can be used for this.  

  

Parameters as individual variables for step and transition configuration 

In a sequencer, various individual variables, e.g. actual values, limit values may be required 
for step and transition configuration.  

To create these individual variables, the required block I/O of the block instance of the 
corresponding SFC type is selected and dragged to the equipment phase in the 
technological editor. A "Parameter" object is automatically created. The names of these 
individual variables are pre-defined and cannot be changed.  

These individual variables are interconnected and assigned parameters at the instance of 
the equipment module. 
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Data objects of the control module 
One or more control modules can be assigned to an equipment module.  

In connection with the equipment module, it is particularly important that control modules be 
accessible via commands and states of the equipment module sequencers. 

The control module consists of the following elements, which may or not be present: 

 
Object/icon Description 
Commands  
  

 

• A command can only be defined as an object of a control module at the type of the control 
module (not at an instance), and is therefore type-specific. 

For additional information, refer to the section "Special considerations for the implementation 
of specific commands/statuses (Page 230)".  

• A command can be provided with one or more formal parameters. 
• A control module command is determined by its name. 
• Each command has the attributes "Comment" and "Author". 
• There can be several commands. 
Example of a command: 
A command named "Open" is defined for opening a valve. 
Commands can also be provided with parameters, e.g., if certain information (values, variables) 
are first known at the instance.  
An example of a command with parameters is the specification of motor speed: 
• "Set_Motor_Speed(Speed)" 

Statuses 
  

 

• A status can only be defined as an object of a control module at the type of the control module 
(not at an instance), and is therefore type-specific. 

For additional information, refer to the section "Special considerations for the implementation 
of specific commands/statuses (Page 230)".  

• A status can be provided with one or more formal parameters. 
• The status of a control module command is determined by its name. 
• Each status has the attributes "Comment" and "Author". 
• There can be several states. 
Example of a status: 
A status named "Closed" is created for the closed state of a valve. 



 Creating runtime structures 
 9.12 Configuring and Using Equipment Modules 

CFC for SIMATIC S7 (V8.0 SP4) 
Function Manual, 07/2013, A5E03710059-06 195 

Object/icon Description 
Parameters 
  

 
 

• There can be several parameters. 
• The "Parameter" object can be used: 

– As a sub-object of an equipment module or control module. 
– As a formal parameter of commands and states. These formal parameters define in the 

equipment phase placeholders for specific parameters or constants at the points of use in 
the actions and transitions of the sequencer. 

• The "Value" and "Signal" attributes and the "Interconnection" relation can only be entered as 
alternatives. 

• The "Signal" attribute is only allowed for input parameters and is disabled for output 
parameters. 

• The "Negation" attribute is only allowed for input parameters of the "BOOL" data type and is 
disabled for output parameters. For input parameters, the "Negation" attribute relates to the 
parameter interconnection or the signal. 

Signals 
  

 

• There can be several signals. 
• A signal defines an I/O channel request. 
• The attributes of signals are represented in the same way as parameters in the technological 

editor. The input boxes of the "Value", "Enumeration", "Operation identifier", "Unit" and 
"Interconnection" values or relations are disabled, however. 

• The "Negation" attribute is only allowed for input parameters of the "BOOL" data type and is 
disabled for output parameters. It applies to the "Signal" attribute for signals. 

Lower-level control 
modules  
  

 

• A control module can be subordinate to other control modules. 
• There can be several lower-level control modules. 
• The nesting depth for control modules is limited to a maximum of 2 levels. 

This means that a control module can only have one sub-level of lower-level control modules.  
• Lower-level control modules can only be defined as "optional" on the first sub-level under a 

control module/equipment module type. You can find additional information on this in the 
above table of the data objects of an equipment module. 

Messages 
  

 

• An equipment module can generate messages by default. 
• There can be several messages. 

  

Globally defined "Command" and "Status" data objects 
The "Command" and "Status" objects can be defined as follows: 

● At the type of a control module (not at an instance) or at a "Control Module (Basic 
Requirement)". These commands and states are specific to these objects. 

You can find a description of this in the tables above. 

● "Globally", i.e. with the SIMATIC Manager in the master data library. 

These commands and states are generally based on equipment phases and can be used 
in all equipment phases of a plant. 
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These global commands and states are described in the table below. 

You can find additional information about configuration and about characteristics in 
conditions in the section "Configuring a global command or status (Page 231)". 

 
Object/icon Description 
Commands  
  

 

• "Global" commands are generally based on equipment phases and can be used in all 
equipment phases of a plant. 

This means that the implementation only uses operating states, sequencer information, 
characteristics, etc. of a sequence control system.  

• A command is determined by its name. 
• Global commands share a namespace in the master data library with the following objects: 

– Types of equipment module and control module 
– SFC and CFC 
– Global status 

• Each command has the attributes "Comment" and "Author". 
• A command can be provided with one or more formal parameters. 
• There can be more than one command. 

They can be selected and copied individually or collectively in the SIMATIC Manager. 
Statuses 
  

 

• "Global" states are generally based on equipment phases and can be used in all equipment 
phases of a plant. 

This means that the implementation only uses operating states, sequencer information, 
characteristics, etc. of a sequence control system. 

• The status is determined by specifying its name. 

Global status shares a namespace in the master data library with the following objects:  
– Types of equipment module and control module 
– SFC and CFC 
– Global commands 

• Each status has the attributes "Comment" and "Author". 
• A status can be provided with one or more formal parameters. 
• There can be several states. 

They can be selected and copied individually or collectively in the SIMATIC Manager. 

  

See also 
Basics of equipment modules and their types (Page 183) 

Basic information on control module types (Page 168) 



 Creating runtime structures 
 9.12 Configuring and Using Equipment Modules 

CFC for SIMATIC S7 (V8.0 SP4) 
Function Manual, 07/2013, A5E03710059-06 197 

9.12.3 Classification of the equipment module in the ISA-88 standard 

Overview 
An equipment module is classified in the physical plant model of the ISA-88 standard (IEC 
61512-1) below a unit.  

● When using SIMATIC BATCH, a node must be labeled in the plant hierarchy as an 
equipment module according to ISA-88. This is why the possibility provided by the 
existing standard to classify an equipment module directly under a process cell is not 
supported in the context of PCS 7. 

● Control modules can be either below an equipment module or on the level directly below 
the unit. 

The following figure shows the placement of the equipment module in the so-called physical 
model of the ISA-88 standard. Examples of three possible configurations for a PCS 7 project 
are presented.  
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Terms of the ISA-88 standard 
Process cell  

A plant or process cell contains all of the equipment required to make a batch. Process cells 
are often divided into lines. A line consists of all units and other devices that can be used by 
a specific batch. Lines can be left unchanged from batch to batch, or be defined differently 
for each batch. 

In a PCS 7 multiproject, only one "Plant" hierarchy folder can be created. Examples for this 
include polymerization plants, dying works, multi-purpose plants. 

Unit 

A unit is an independent group of equipment modules that are usually arranged around 
essential process equipment, for example, a mixing tank or a reactor.  

A unit has the following characteristics:  

● A unit can perform one or more key process activities, for example, reactions, 
crystallization and preparation of solutions. 

● Units operate relatively independent of one another. 

● A unit frequently contains a complete material batch at some point in the process flow of 
the batch. 

● A unit cannot process more than one batch at a given time. 

Equipment module 

An equipment module can consist of control modules and lower-level equipment modules. 
An equipment module is usually located in a process device, for example, a filter.  

Characteristics of an equipment module: 

● Can belong to a unit or incorporate an independent group of equipment in a process cell. 

● Can perform a finite number of specific, minor processing functions, for example, dosing 
or weighing. 

● Can optionally contain the raw materials for a batch. 

Control module 

A control module is usually a collection of sensors, actuators and other control modules and 
associated process equipment that can be operated as an individual device from the 
perspective of the control engineering.  

A control module can also be composed of other control modules. For example, a dosing 
control module can be defined as a combination of several automatic switching valve control 
modules. 

See also 
Basics of equipment modules and their types (Page 183) 
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9.12.4 The equipment module in data communication with COMOS 

9.12.4.1 Overview of data exchange with COMOS 

Introduction 
The data generated on the engineering level in COMOS in the form of equipment modules, 
their equipment phases and control modules can be imported into the automation layer of 
PCS 7. This forms the basis for creating sequential controls (SFC) and automation programs 
(CFC).  

Overview of data exchange between PCS 7 and COMOS 
The following figure shows the principle of data exchange between PCS 7 and COMOS 
using the automation interface (AI). 

The following options are available for data exchange: 

● Direct data exchange when COMOS and PCS 7 are installed on the same computer. 

This direct data exchange is described below.  

● Indirect data exchange via an XML file when COMOS and PCS 7 are installed on 
different computers. 

You can find additional information on this in the section "Data communication with 
equipment modules using XML format (Page 202)". 

Not only the types and instances of equipment modules are read from COMOS Integrated 
Engineering and PCS 7 and compared with the data exchange via the import service of the 
automation interface (AI). The plant hierarchy, types and instances of control modules, 
hardware configuration, etc. are compared as well. Changes can be deleted or applied to the 
target thereby. 

All elements available for data exchange with PCS 7 are displayed in the COMOS 
Automation Tree.  
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 Note 
Data exchange of types 

Bidirectional data exchange is possible with control module types.  

Equipment module types, on the other hand can only be transferred by COMOS Integrated 
Engineering to PCS 7 in the current version!  
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How data exchange between PCS 7 and COMOS works 
1. Technical functions, which have been identified for the plant to be configured based on 

the customer requirements and the appropriate types of equipment modules with their 
equipment phases, are specified, depending on the planned process sequences. 

The possible control strategies, setpoints and parameter descriptions (e.g. process 
values, parameters, timers, bit memory, control values, operator and note texts, position 
texts and messages) are defined for each type. The procedural control of the equipment 
phase is described in the form of sequencers. An essential part of the type description for 
equipment modules is the assignment of the control modules (actuators and sensors), 
which are needed for the sequential control system. 

2. The type descriptions of equipment modules are (preferably) created with COMOS 
Integrated Engineering. Thereafter, these descriptions are transferred to the master data 
library ("Project Library") of PCS 7 to complement the implementation of the SFC and 
CFC editor there. 

Types and instances of equipment modules/control modules, the plant hierarchy, 
hardware configuration, etc. from COMOS Integrated Engineering and PCS 7 are read 
and compared during data exchange. Changes can be deleted or applied to the target 
thereby.  

The types of equipment modules and control modules are provided in the master data 
library as templates for instantiation. When you import the instances, the types of 
equipment modules and control modules in the master data library are used as 
templates.  

 
  Note 

Certain restrictions in PCS 7 have to be taken into consideration for a successful import 
from COMOS Integrated Engineering to PCS 7. You can find additional information 
below.  

 

3. After the types of equipment modules are defined and implemented, the instances can be 
configured. The instances of the equipment modules are created and the connections are 
made to the specific control modules, representing the devices on the control module 
level of the unit. 

The instances of equipment modules with the assigned control modules are used as 
generation instructions on the process engineering level of COMOS Integrated 
Engineering in order to create, configure and interconnect the specific automation charts 
(CFC) in the corresponding PCS 7 project.  

Relevant restrictions in PCS 7 for importing from COMOS Integrated Engineering  

● Commands and status in equipment phases:  

– Commands can only be used in equipment phases in steps. 

– Status can only be used in transitions. 

● Instructions and conditions: 

– Step: A maximum of 50 instructions per step are possible. 

– Transition / Start condition: A maximum of 16 conditions are possible per transition / 
start condition, in groups of 2 x 5 and 2 x 3 conditions. 
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You can find additional information in the paragraph "Instructions and conditions of the 
steps and transitions" of the "The equipment phase in data communication with COMOS 
(Page 204)" section.  

  

See also 
Basics of equipment modules and their types (Page 183) 

9.12.4.2 Data communication with equipment modules using XML format 

Introduction 
Data can be transferred bi-directionally and compared with data exchange between PCS 7 
and COMOS.  

The following options are available for transfer and synchronization:  

● Direct data exchange when COMOS and PCS 7 are installed on the same computer. 

The types and instances of equipment modules are read from COMOS Integrated 
Engineering and PCS 7 and compared via the import service of the automation interface 
(AI). 

● Indirect data exchange via an XML file when COMOS and PCS 7 are installed on 
different computers. 

With indirect data exchange, data is first saved to an XML file using the export function in 
the SIMATIC Manager or COMOS Integrated Engineering. 

Then, the XML file generated by COMOS Integrated Engineering or PCS 7 is imported in 
turn into the SIMATIC Manager or COMOS Integrated Engineering. Synchronization is 
also performed with the import. Changes can be deleted or applied to the target thereby. 

Indirect data exchange in the context of PCS 7 is described in this section.  

Requirement 
Data exchange via an XML file requires an installation of the "SIMATIC XML Transfer" 
software on the computer with the PCS 7 system. The software is available on the Product 
DVD of COMOS.  

Data transfer in the context of PCS 7 
Bi-directional data exchange 

Control module types can be specified and implemented in PCS 7 or they may already be 
available in a library. If these existing implemented control module types are to be used in 
COMOS, they must be transferred from PCS 7 to COMOS Integrated Engineering. 

In the case of changes on the engineering level or when types of control modules or 
equipment modules have been specified technologically in COMOS Integrated Engineering, 
these two kinds of types can be transferred to PCS 7. 
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 Note 
Data exchange of types 

Bidirectional data exchange is possible with control module types.  

Equipment module types, on the other hand can only be transferred by COMOS Integrated 
Engineering to PCS 7 in the current version!  

 

A type of equipment module is fully transferred with all control modules and optional control 
modules.  

Export and Import function in the SIMATIC Manager 

Two menu commands, "Export XML" and "Import XML", are available for the export and 
import function in the SIMATIC Manager in the shortcut menu of the PCS 7 project.  

These menu commands are only available if the "SIMATIC XML Transfer" software is 
installed and can only be used for indirect data exchange with COMOS Integrated 
Engineering.  

Import in PCS 7 

● The "Import XML" import function mentioned above is used for indirect data exchange via 
an XML file. The user must provide and select the appropriate XML file for this. 

The import can be started using the "Import XML" command from the shortcut menu of 
the PCS 7 project. As an alternative, you can start the process by using the "Edit" menu 
command in the main menu of the SIMATIC Manager.  

● Once the import of an equipment module type into the PCS 7 project is successfully 
completed, in the import dialog the user can use the shortcut menu to directly open the 
equipment module in the master data library, where it is now available as a technological 
shell. 

● The associated CFC only contains the instance of the SFC type as an equipment phase 
after the initial import. 

The user now has the possibility to implement the equipment module using the resources 
of the CFC and SFC editors. 

Export from PCS 7 

● The "Export XML" export function mentioned above is used for indirect data exchange via 
an XML file. 

The export can be started by using the "Edit > Export XML" command from the shortcut 
menu of the PCS 7 project. As an alternative, you can start the process by using the 
"Edit" menu command in the main menu of the SIMATIC Manager. 

The user can select the path for the XML file.  

● After that, the XML file is transferred and imported to the computer with COMOS 
Integrated Engineering. 
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See also 
Overview of data exchange with COMOS (Page 199) 

9.12.4.3 The equipment phase in data communication with COMOS 

Introduction 
The equipment phase is exchanged as part of the equipment module during data exchange 
with COMOS Integrated Engineering via the import service of the automation interface (AI). 
The data from COMOS Integrated Engineering and PCS 7 can also be read and compared. 
Changes can be deleted or applied to the target thereby.  

The equipment phase defines the sequential control system with the sequencers and their 
parameter descriptions (e.g. setpoints, control strategies, parameters, messages). 

The sequencers can contain the same elements as an SFC type:  

● Steps 

● Transitions 

● Alternative branches 

● Simultaneous branches 

● Loops 

● Jumps 

The following describes how the equipment phases, sequencers and their elements 
participate in the data exchange.  

Overview 
Below is a description of how the components of the equipment phase participate in the data 
exchange:  

● Sequencer 

● Steps and transitions 

● Instructions and conditions of the steps and transitions 

● Characteristics of the SFC type of the equipment phase 

The sequencer in the data transfer dialog box 

In the data transfer dialog of the automation interface (AI), the equipment phase and its 
elements are presented in a tree.  
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The elements of the sequencer are represented as elements of the equipment phase.  

● Sequencer 

 
The sequencer always starts with a START step and ends with an END step. A start 
condition must always be be configured at the start of the sequencer.  

– Start condition 

 
● A sequencer contains alternating step and transition elements. 

– Step 

 
– Transition 

 
● In addition to a simple step and a transition, sequencers can also contain alternative and 

simultaneous branches. 

–  Alternative branch 

 
An alternative branch contains at least 2 transition sequences.  

 
A transition sequence always begins and ends with a transition element. A transition 
sequence itself is a transition element.  

– Simultaneous branch 

 
An simultaneous branch contains at least 2 transition sequences.  

 
A step sequence always begins and ends with a step element.  

The step and transition elements are displayed according to the graphical and topological 
structure of the comparison tree in the automation interface. 

● Sequencers can also contain loops and jumps. The loops and jumps are performed in 
accordance with a transition condition. 

– Loop 

 
A loop can be generally determined only by a step sequence. The transition condition 
is checked after the last step at the end of a sequence of steps and transitions. If 
necessary, the sequencer resumes at the first step of the sequence.  

– Jump 

 
A jump can cause the sequencer to resume at a given step depending on whether a 
transition condition is met. 
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Properties of the sequencer during data exchange and import 

● A previously unavailable equipment phase is fully transferred with the initial import 
operation. 

● A sequencer in an equipment phase can only be selected or deselected as a whole in the 
comparison tree of the automation interface. 

This means that only a complete sequencer can be included in an import or left out of it. 
This avoids inconsistencies.  

 

 Note 
Existing steps and transitions during import into PCS 7  

If a sequencer is marked and thereby included in the import, all the contents of the existing 
steps and transitions in the sequencer are overwritten in PCS 7. During import, 
corresponding messages are generated when objects are created, modified or deleted.  

If changes were made to steps and transitions in the sequencers at the PCS 7 end after the 
import, these manual changes have to be checked, and possibly backed up before the 
import!  

 

  

Order of sequencers of an equipment phase  

During the first import process from COMOS Integrated Engineering, the sequencers of an 
equipment phase as sorted alphabetically.  

This order does not make sense from the process engineering point of view. Therefore, the 
user can set the sequencers manually to the desired order in the SFC editor.  

If the order was sorted manually and one or more new sequencers were added for the 
subsequent import, these are placed in front of the existing order of the sequencers. The 
new sequencers are thus shown at the far left in the graphical layout in the SFC editor.  

 

 Note 

If the order of several sequences in an equipment phase was changed manually, the new 
order arising after new sequencers have been imported has to be checked by the user and if 
necessary modified.  
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Steps and transitions in the data transfer dialog 

1. Synchronization of the equipment phase first involves comparing the step and transition 
sequences with their steps, branches, transitions, etc.. Newly inserted, nameless 
topological elements, for example, simultaneous and alternative branches, loops, step 
and transition sequences can be correctly identified in this way. 

2. Transitions and steps by definition have a name that cannot consist of numbers only. 

When steps and transitions are created in PCS 7, a name is not automatically generated 
or a number assigned for identification of these objects. Therefore, if there is no name at 
the PCS 7 end, a name is artificially created within the context of data exchange with 
COMOS Integrated Engineering. The name is formed by number. A "S" is prefixed for 
steps and a "T" for transitions. 

The user should assign suitable names for steps and transitions in the SFC editor of 
PCS 7 for the data exchange with COMOS Integrated Engineering. 

3. Step and transition elements can only occur in accordance with the topographical rules of 
a sequencer; otherwise, the sequencer would be in an inconsistent state. 

If implausible sequences of steps and transitions are detected, an entry to this effect is 
made in the log file.  

4. Steps and transition elements are compared in the comparison tree in the same way as 
all other objects. Therefore, only the objects involved are changed, added or deleted. 

Step and transition programs:  

The types of the equipment modules can be transferred with or without the step and 
transition program descriptions by COMOS Integrated Engineering.  

– Transfer without step and transition programs: 

The step and transition programs are not changed in PCS 7, even if the entire 
sequencer is selected for import as described above.  

– Transfer with step and transition programs: 

In the data transfer dialog, the step and transition programs are displayed with 
differences in the form of superfluous objects at the COMOS end. The objects of the 
step and transition programs can now be selected or removed for import.  

If an object is selected, it is also imported to PCS 7 and overwrites the existing 
contents.  

If an object is removed, no import is not carried out and the existing contents in PCS 7 
are retained.  

5. Step and transition elements cannot be selected or removed individually, but only 
indirectly via the selected or removed sequencer. 

Only the complete sequencer can be selected and thereby be included in the import. 
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  Note 
Meaning of the "Delete at target" option 

If the sequencer is selected and thereby included in the import, steps and transitions are 
inserted or deleted at the target during import. This applies irrespective or whether the 
option "Delete at target" is activated or deactivated. Steps and transitions are also deleted 
in the target when the option "Delete at target" is deactivated. The decisive factor is 
whether or not the sequencer is included in the import process! 
Existing steps and transitions during import into PCS 7 

If a sequencer is marked and thereby included in the import, the existing steps and 
transitions in the sequencer are overwritten in PCS 7. You can find additional information 
above in the section "Properties of the sequencer during data exchange and import". 

Step and transition programs: If the types of the equipment modules were transferred 
with the step and transition program descriptions from COMOS Integrated Engineering, 
the user can specify whether these step and transition program descriptions are to be 
imported into PCS 7. You can find additional information is under point 4. 

 

  

Instructions and conditions of the steps and transitions 

● The instructions of the steps and conditions of the transitions do not have own objects in 
the technological editor and are therefore not displayed for comparison in the data 
transfer dialog. 

 

 Note 
Limits for instructions and conditions 

The following limits in PCS 7 have to observed at steps and transitions for the transfer from 
COMOS:  
• Step: A maximum of 50 instructions per step are possible. 
• Transition / Start condition: A maximum of 16 conditions are possible per transition / start 

condition, in groups of 2 x 5 and 2 x 3 conditions. 

If these limits are exceeded during the transfer from COMOS Integrated Engineering, the 
corresponding sequencer is not imported / generated in PCS 7 and a corresponding entry is 
made in the log file of the Automation Interface (AI).  
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Characteristics of the SFC type of the equipment phase 

During the first import process from COMOS Integrated Engineering, characteristics of the 
SFC type, such as strategies, are also transferred to the equipment phase and arranged in 
alphabetical order in PCS 7.  

This order of the characteristics, particularly the control strategies, does not make sense 
from a process engineering point of view. Therefore, the user can manually arrange the 
characteristics in the desired order in the SFC editor.  

 

 Note 

If the order of the characteristics of the SFC type of an equipment phase was changed 
manually, the new order arising after new sequencers have been imported has to be 
checked by the user and modified if necessary.  

 

 

9.12.5 Creating, configuring and managing equipment modules 

9.12.5.1 Overview of equipment module management 

Overview 
● Creating 

The equipment module type can be created with the functions of the SIMATIC Manager 
in the master data library.  

You can find additional information on this in the section "Creating an equipment module 
(type) (Page 210)". 

● Management 

An equipment module type can be copied and deleted in the SIMATIC Manager.  

● Creating an instance 

An instance can be created by copying the equipment module type from the master data 
library into a node of the plant hierarchy.  

You can find additional information on this in the section "Creating an instance of the 
equipment module type (Page 218)".  

● Type/instance synchronization 

Synchronization of the type and the instances may be required when changes are made 
to the type or its associated instances. You can find additional information on this in the 
section "Comparing and synchronizing the type and instances of an equipment module 
(Page 220)".  
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9.12.5.2 Creating an equipment module (type) 

Introduction 
For use of an equipment module, a corresponding type must first be created. An equipment 
module type can be generated with the following options in PCS 7:  

● Import from COMOS via the automation interface (AI) 

Importing from COMOS Integrated Engineering can be performed directly or indirectly 
through the XML format. 

You can find additional information on this in the section "Overview of data exchange with 
COMOS (Page 199)".  

● Direct creation in the master data library in the SIMATIC Manager 

This procedure is described below.  

Alternatively, a CFC can be opened in the CFC editor and converted to an equipment 
module by configuring the attributes in the technological editor.  

Requirement 
A multiproject open containing a master data library is open in the SIMATIC Manager. 

Procedure 
1. Use the menu command "View > Plant View" to open the plant view. 

2. In the plant view, navigate in the master data library to the directory where you want to 
create the equipment module, for example "Process tag types". Other directories can be 
used, for example, ones you have created in the master data library. 

3. Select the "Insert New Object > Equipment Module (Type)" command from the shortcut 
menu. 

The newly created equipment module type appears in the right window with the 
corresponding icon. 

 
Alternatively, you can create an equipment module type in a hierarchy folder of the plant 
view.  

4. Open this type in the CFC editor to configure the properties of the equipment module 
type. 

Open the technological editor. The new type has the default attributes "Name", "Author" 
and "Comment".  

Enter the desired data for the attributes.  

5. If you want to configure lower-level elements under this type, select the icon for the type 
of the equipment module in the technological editor. 
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6. Select the "Insert New Object" command from the shortcut menu. 

All available elements are shown in the shortcut menu.  

– "Control Module"; for a lower-level control module 

You can find information about configuration in the section "Integrating and assigning 
a control module in the type (Page 216)". 

– "Control Module (Basic Requirement)"; for a requirement at a control module 

You can find information about configuration in the section "Configuring and assigning 
a control module as a basic requirement (Page 213)". 

– "Control Module Assignment" 

You can find information about configuration in the section "Integrating and assigning 
a control module in the type (Page 216)". 

– "Parameter" 

– "Signal" 

–  "Message" 

– "Equipment Phase" 

You can find information about configuration in the section "Creating and assigning an 
equipment phase of an equipment module (Page 211)".  

7. Select the appropriate menu command to insert the desired object, for example 
"Parameter". 

8. Repeat this step as often as necessary to add more lower-level elements. 

Result 
The type of equipment module is created.  

Lower-level elements such as parameters and control modules are inserted.  
 

 Note 

The objects, for example, the values of attributes or assignments still have to be configured 
in the technological editor. 

 

9.12.5.3 Creating and assigning an equipment phase of an equipment module 

Introduction 
An equipment module also requires an equipment phase.  

The equipment phase is assigned to an SFC type in which the sequential control system and 
the parameter interface are defined.  

Each equipment module must be assigned one and only one equipment phase.  
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Requirements 
● A multiproject open containing a master data library is open in the SIMATIC Manager. 

● An equipment module type is created as described in the section "Creating an equipment 
module (type) (Page 210)". 

Procedure 
1. If the SFC type to be assigned as an equipment phase already exists, continue with Step 

4 

2. To create an SFC type, switch to the component view and navigate to the "Charts" 
directory" in the master data library. 

3. Select "Insert New Object > SFC Type" from the shortcut menu. The newly created SFC 
type appears in the right window with the corresponding icon. 

4. In the master data library, open the equipment module type in the CFC editor. 

Select the icon for the equipment module type in the technological editor. 
 

5. Select the "Insert New Object" command from the shortcut menu. 

All available objects are shown in the shortcut menu.  

Select the "Equipment phase" menu command.  

The equipment phase is inserted and displayed as an icon.  
 

Since each equipment module can be assigned one and only one equipment phase, the 
corresponding menu command is disabled in the shortcut menu of the equipment module 
afterwards.  

6. Select the icon for the equipment module type in the technological editor. The right 
window shows the associated attributes. 

Configure the assignment of the desired SFC type.  

Drag the desired SFC type and drop it in the chart window of the CFC editor. The newly 
inserted SFC type is displayed in the "Assigned block" attribute.  

7. If you want to configure lower-level elements for this equipment phase, select the icon for 
the equipment phase in the technological editor. 

Select the "Insert New Object" command from the shortcut menu. All available objects are 
shown in the shortcut menu. Only "Parameter" can be selected in the current version.  

8. Select the "Parameters" menu command in the shortcut menu. 

The "Parameters of the equipment phase" dialog opens. All the parameters that can be 
used are shown in this dialog.  

Select the required parameter and click "Insert". The parameter is inserted and displayed 
as an icon. Configure the attributes of this parameter. 
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9. Parameters can also be used as individual variables for configuring steps and transitions, 
e.g., for actual value, limit values. 

If you would like to create a parameter as an individual variable, select the desired block 
I/O of the block instance of the corresponding SFC type and drag it to the equipment 
phase in the technological editor. 

The "Parameter" object is created automatically. The names of these individual variables 
are pre-defined and cannot be changed. You can find additional information on this in the 
section "Overview of data objects of the equipment module and control module 
(Page 187)" in the table of the data objects of an equipment phase.  

Alternative procedure for Steps 5 to 6: 

If the equipment module type is open in the editor, you can drag the desired SFC type from 
the master data library and drop it into the "Charts" folder in the chart window of the editor. 
The SFC type is then added as an instance and displayed as a block icon. 

At the same time, the "Equipment phase" object is created and the instanced SFC type is 
automatically entered in the attributes as an assignment. 

Result 
An SFC type is assigned to the equipment module type as an equipment phase.  

Parameters are created as subobjects of this equipment phase if required.  
 

 Note 

If you have created a new SFC type in Steps 2 and 3, you still need to configure the content, 
for example, the sequencer and characteristics in the SFC editor. 

 

  

9.12.5.4 Configuring and assigning a control module as a basic requirement 

Introduction 
The assignment of a control module to an equipment module is configured in the 
technological editor of the equipment module.  

The configuration depends on whether the control module to be assigned is integrated in the 
equipment module type as a component.  



Creating runtime structures  
9.12 Configuring and Using Equipment Modules 

 CFC for SIMATIC S7 (V8.0 SP4) 
214 Function Manual, 07/2013, A5E03710059-06 

The following configurations are possible: 

● "Configuration 1": 

The control module to be assigned is integrated as a component of the equipment 
module type.  

The following objects are configured for this:  

– A control module as an object in the equipment module, represented by the following 
icon: 

 
– A "control module assignment" object, represented by the following icon: 

 
You can find additional information on this in the section "Integrating and assigning a 
control module in the type (Page 216)". 

● "Configuration 2": 

The control module to be assigned is not a component of the equipment module type. 

The following objects are configured for this:  

– A corresponding "control module (basic requirement)" object, represented by the 
following icon: 

 
The minimum requirements for the control module to be assigned are abstractly 
described in the basic requirements. 

– A "control module assignment" object, represented by the following icon: 

 
The corresponding control module or a basic requirement and "role" are assigned and 
configured in the "control module assignment".  

The following section describes the procedures for "Configuration 2", in which the control 
module to be assigned is not a component of the type.  

Requirement 
An equipment module type is created in the master data library.  

Procedure 
1. Open the desired equipment module type in the CFC editor. 

2. Select the icon for the equipment module type in the technological editor. 

 
3. Select "Insert new object > Control module (basic requirement)" from the shortcut menu. 

The control module requirement is inserted and displayed as an icon. 
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4. Select the icon for the control module requirement in the configuration editor. 

The associated attributes are displayed.  

5. Configure the attributes, for example, the name and function identifier. 

6. Select the icon for the equipment module type in the technological editor. 

7. Select "Insert new object > Control module assignment" from the shortcut menu. 

The control module assignment is inserted and displayed as an icon with the following 
additional information. 

 

 
Name of the associated control module or basic requirement "(" <Role> ")" 

8. Select the icon for the newly created control module assignment in the configuration 
editor. The associated attributes such as "Control module assignment" and "Role" are 
displayed. 

A basic requirement is configured for the "Control module assignment" attribute and no 
specific control module because this associated control module is not integrated as a 
component of the type.  

For configuring the "Assigned control module" attribute, drag the basic requirement 
created above to the "Control module assignment" object in the technological editor.  

The newly created assignment is displayed in the "Control module assignment" attribute. 

9. Configure the "role" for the attribute with the same name. 

The "role" indicates how the associated control module or basic requirement is to be used 
in the context of this type.  

Enter a comment, if needed.  

10.If you want to configure lower-level elements under this control module requirement, for 
example the "Status", select the icon for the "Control module (basic requirement)" in the 
configuration editor. 

 
11.Select the "Insert new object" command from the shortcut menu. 

All available elements are shown in the shortcut menu.  

– "Control module" 

– "Parameters" 

– "Process value" 

– "Message" 

– "Command" 

– "Status" 

Select the appropriate menu command to insert the desired object, for example 
"Command". 

Repeat this step as often as necessary to add more lower-level elements. 

12.Configure the attributes of the lower-level elements. 
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Result 
The basic requirement and the control module assignment are configured at the equipment 
module type. 

In this case, the control module is not a component of the equipment module type; it is 
abstractly described in the basic requirement.  

9.12.5.5 Integrating and assigning a control module in the type 

Introduction 
The assignment of a control module to an equipment module is configured in the 
technological editor of the equipment module.  

The configuration depends on whether the control module to be assigned is integrated in the 
equipment module type as a component.  

The following configurations are possible: 

● "Configuration 1": 

The control module to be assigned is integrated as a component of the equipment 
module type.  

The following objects are configured for this:  

– A control module as an integrated object in the equipment module, represented by the 
following icon: 

 
– A "Control Module Assignment" object, represented by the following icon: 

 
The corresponding control module and "role" are assigned and configured in the 
Control Module Assignment.  

● "Configuration 2": 

The control module to be assigned is not a component of the equipment module type. 

The following objects are configured for this:  

– A "Control Module Assignment" object, represented by the following icon: 

 
– A corresponding "Control Module (Basic Requirement)" object, represented by the 

following icon: 

 
You can find additional information on this in the section "Configuring and assigning a 
control module as a basic requirement (Page 213)". 

The following section describes the procedures for "Configuration 1", in which the control 
module to be assigned is a component of the type. 
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Requirements 
The following are available in the master data library:  

● An equipment module type. 

● A control module type 

Procedure 
1. In the master data library, navigate to the desired equipment module type and open it in 

the CFC editor. 

2. To configure the associated control module, navigate to the desired control module type 
in the template catalog of the master data library. 

3. Drag the desired control module type and drop it onto the equipment module type in the 
technological editor. 

4. The control module is inserted and displayed as an icon. 

 
5. Select the icon for the equipment module type in the technological editor. 

 
6. Select "Insert New Object > Control Module Assignment" from the shortcut menu. 

The Control Module Assignment is inserted and displayed as an icon with the following 
additional information. 

 

 
Name of the assigned control module "(" <Role> ")" 

7. Select the icon for the newly created "Control Module Assignment". 

The associated attributes such as "Control Module Assignment" and "Role" are displayed. 

8. For configuring the "Control Module Assignment" attribute, drag the control module 
created above to the "Control Module Assignment" object in the technological editor. 

The newly created assignment is displayed in the "Control Module Assignment" attribute.  

9. Configure the "role" for the attribute with the same name. 

The "role" indicates how the associated control module or basic requirement is to be used 
in the context of this type. 

Enter a comment, if needed.  

Result 
A control module is integrated into the equipment module type and the Control Module 
Assignment is configured. 

This control module is now a component of the equipment module type. 
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9.12.5.6 Creating an instance of the equipment module type 

Overview 
The equipment module type is stored in the master data library. 

A type can be copied within the master data library or copied to create an instance in the 
project.  

Properties when copying an equipment module type in the master data library  

● When a type is copied within the master data library, a new type is created and all the 
components of the original type, including the basic requirements, are copied along with 
it. 

● A control module assignment defined at the type is copied as well, regardless of whether 
the assigned control module therein is a component of type or a basic requirement. 

Properties when creating an instance (copying from the master data library into the project)  

● An instance can be created by copying the equipment module type from the master data 
library into a node of the plant hierarchy. 

This node can be classified as an equipment module according to the ISA-88 standard.  

If SIMATIC BATCH is used, however, this node must be labeled as an equipment 
module! 

 
  Note 

Number of instances in a process cell node 

Any number of instances of an equipment module type can be created under a process 
cell node in the plant hierarchy. If this node is classified as an equipment module 
according to ISA-88, however, multiple instances do not make sense. However, this is not 
checked by the SIMATIC Manager and is thus the user's responsibility! 

 

● Optional control modules are not copied. 

These can be selected and connected at the instance. 

Lower-level control modules can only be defined as "optional" on the first sub-level under 
the equipment module.  

● A control module assignment defined at the type is copied as well, regardless of whether 
the assigned control module therein is a component of type or a basic requirement. 

● A control module integrated as a component in the type is also copied when the instance 
is created. 

● A "Control module (basic requirement)" is not included in the copying because the basic 
requirement only abstractly describes the minimum requirements for the control module 
to be assigned. 

The corresponding control modules must be assigned at the instance for these basic 
requirements. 
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● Commands and status can be defined at the types of equipment modules and control 
modules. These are not included in the copying. 

● The corresponding type is known at the instance in order to support the type-instance 
synchronization. 

Comparison between type and instance 

Synchronization of the type and the instances may be required when changes are made to 
the type or the associated instances.  

You can find additional information on this in the section "Comparing and synchronizing the 
type and instances of an equipment module (Page 220)". 

9.12.5.7 Assigning the control module instance to an equipment module 

Introduction 
A control module can be configured at the equipment module type as a component of the 
type or as a "Control module (basic requirement)".  

1. If a control module is integrated as a component of the type, it is included in the copying 
when the instance is created. 

2. If the control module is configured at the type as a "Control module (basic requirement)", 
a specific control module from the project must be assigned at the instance. 

The following section describes the procedures for this option "2".  

Requirements 
● The master data library contains the desired type of the equipment module. 

● A control module as a "Control module (basic requirement)" and the corresponding 
"Control module assignment" are configured at this type. 

● An instance is created from this type. 

Procedure 
1. In the CFC editor, open the desired instance that meets the requirements listed above. 

2. Open the control module to be assigned in the CFC editor. 

3. To get a better overview, arrange the two open windows so that both are visible. 

4. Select the icon of control module in the window of the control module in the technological 
editor. 
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5. Drag this icon from the window of the instance and drop it onto the icon of the desired 
control module assignment in the technological editor. 

 
6. The newly configured assignment appears in the attribute list of the "Control module 

assignment" attribute. 

At the same time, the interconnections between the instance and the associated control 
module are automatically created.  

Use the shortcut menu of this attribute to delete the assignment or to jump to the control 
module.  

 
  Note 

If you delete the entry in the "Control module assignment" attribute, all the associated 
interconnections are deleted as well.  

 

Result 
A specific control module is assigned at the instance of an equipment module.  

The interconnections between the instance and the associated control module are created.  

9.12.5.8 Comparing and synchronizing the type and instances of an equipment module 

Introduction 
The type and instance of an equipment module are the same when the instance is created.  

Synchronization of the type and the instances may be required when changes are made to 
the type or its associated instances.  

Thus, for example, the sequencers of the equipment module defined in an SFC type is 
identical when the instance is created. If changes are made to the SFC type in the master 
data library, however, synchronization has to be performed as usual by updating the SFC 
type in the project. 

Comparison and synchronization 

During synchronization, all instances of a type in the project are compared to the 
corresponding type in the master data library. This shows the differences between the types 
of equipment modules and their instances (process engineering level) and between the 
associated objects, such as CFCs (program level).  

The synchronization of parameter descriptions and sequencers between the master data 
library and project is accomplished by updating the SFC type in the project. You can find 
additional information on this in the section "How to update block/SFC types in the 
multiproject (Page 95)". 
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Included objects 

The following lower-level objects are included in the synchronization of the type and 
instances of equipment modules on the plant level: 

● Control modules 

● Control variables: 

– Parameters 

– Signal 

● Messages 

● Assignments of control modules 

● Equipment phase 

Basic requirements for control modules, commands and states, however, are generally not 
involved, because they are not permitted at the instances by definition. 

 

 Note 
Synchronization within the master data library 

If a control module type is used in the library as a lower-level control module at the type of an 
equipment module, this lower-level control module is also synchronized with its control 
module type. 

 

   

Procedure 
1. Select the project in the plant view. 

2. Open the shortcut menu and select the menu command "Technological types > 
Synchronize...". 

A dialog box opens.  

3. Select the desired types of equipment modules or control modules as well that you want 
to compare and synchronize in the left column of the table. 

4. Click the "Synchronize..." button to start the comparison. 

Only relevant attributes and relations are included in the comparison. You can find 
additional information on this in the section "Relevant object attributes for the type-
instance synchronization (Page 222)".  

Functions and function blocks that have been added to an instance are not included in 
the comparison and are suppressed in the presentation of the comparison result. 
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5. The comparison result is displayed. 

The following objects are highlighted in the comparison result:  

– Objects added at the instance, for example sub-functions, messages, functions and 
function blocks, are marked as additional objects. 

– Deleted objects. 

– Objects with modified attributes. 

Differences in the topology of the sequencers and parameter descriptions are not shown 
directly in the comparison result. Rather, the change time stamps of the two compared 
objects are displayed:  

– The change time stamp of the SFC type in the master data library that is associated 
with the equipment phase. 

– The change time stamp of the corresponding SFC type in the project. 

For a control module that is integrated in the type of the equipment module, the 
corresponding "control module assignment" is also shown in the comparison result. If the 
"control module assignment" is missing or has been changed, you are prompted by an 
entry in the log file to check the control modules in the context of this equipment module. 

6. In the comparison result, select the instances to be synchronized to the corresponding 
type. 

Select or clear the check boxes next to objects at the left in the dialog.  

7. Start the synchronization with the "Synchronize templates" icon. 

The selected instances are synchronized. 

Instance-specific extensions are retained if they do not apply to objects of the type.  

Result 
A comparison of the types of equipment modules or control modules and their instances has 
been performed and selected instances have been synchronized.  

See also 
Basics of equipment modules and their types (Page 183) 

Creating an instance of the equipment module type (Page 218) 

9.12.5.9 Relevant object attributes for the type-instance synchronization 

Introduction 
A comparison or synchronization between the type and the corresponding instances may be 
required when changes are made to the type or the associated instances of an equipment 
module / control module. 
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The comparison only includes attributes and relations that cannot be changed at the 
instance. The comparison result is determined and displayed only for these attributes and 
relations.  

Overview 
The following table is an overview of the objects, attributes and relations that are relevant for 
comparison.  

 
Object / type Relevant attributes  Relevant relations 
Equipment module  • Assigned block (block instance 

or sub-CFC) 
• Assigned name 
• Assigned comment 
• Assigned block icon 

Equipment phase Change time stamp  
(of the assigned SFC type) 

Assigned block (block instance or 
SFC type) 

Control module  • Assigned block (block instance 
or sub-CFC) 

• Assigned name 
• Assigned comment 
• Assigned function identifier 
• Assigned block icon 

Control module assignment 
(link object in the equipment 
module) 

 Control module assignment  
(not relevant for basic 
requirements) 

Control variable • Negation (only with 
interconnected inputs) 

• Name 
• Variable type 

(parameter/signal) 
• Data type 
• Comment 

• Interconnection 
• Assigned I/O (block variable) 

Message • Name 
• Message identifier 

Assigned message 

Block instance • Name 
• S7_mes 
• S7_read_back 
• Block type (function / 

function block) 

Block type (instance of function / 
function block) 
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Object / type Relevant attributes  Relevant relations 
Block variable • Inverted (only with 

interconnected inputs) 
• Name 
• Comment 
• I/O type 
• Data type 
• Value 

(see the notes below). 
• S7_edit 
• S7_visible 
• S7_mes 
• S7_archive 
• S7_enum 
• S7_string0 
• S7_string1 
• S7_shortcut 
• S7_unit 

Interconnection source 

Sub-CFC • Name 
• Version 

 

CFC interface  -   -  
CFC interface parameters • Name 

• Comment 
• I/O type 
• Data type 
• Value 

(see the notes below). 
• S7_edit 
• S7_visible 
• S7_mes 
• S7_archive 
• S7_enum 
• S7_string0 
• S7_string1 
• S7_shortcut 
• S7_unit 

 

Block message • Message identifier 
• Message type 

 

Sub-message Message identifier 
(sub-message-number) 
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Special notes 
"Value" attribute 

The "Value" attribute is ignored for the following objects under certain conditions: 

● Block variables 

● CFC interface parameters 

The attribute is ignored if one of the following conditions exist: 

● When there is an assignment to a control variable of the equipment module. 

● When the "S7_m_c" attribute is set. 

Under these conditions, the "Value" attribute is typically adapted to the instance.  

Interconnections at the block instance 

Interconnections at the block instance are also ignored if the "S7_contact" attribute is set at 
the block type. These interconnections are automatically made to the processing blocks, 
e.g., motor block, when the control module is assigned to the equipment module. 

The "Value" attribute at this point is always ignored as well, because the parameters that are 
explicitly or implicitly (in the SFC type instance) defined as block contact are interconnected 
by definition. 

See also 
Comparing and synchronizing the type and instances of an equipment module (Page 220) 

9.12.5.10 Attributes of the objects of an equipment module 

Introduction 
In the left section of the technological editor, the objects in a control module or equipment 
module are represented hierarchically in a tree structure, for example a "Parameter" or 
"Message".  

The right section lists the attributes for the object that is currently selected in the tree.  

Overview 
The following tables show the attributes of the objects of an equipment module. 

1. Equipment module 

2. Equipment phase 

3. Control module 

4. Control module assignment 

5. Control module (basic requirement) 
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6. Parameters 

7. Process value 

8. Message 

Note regarding the "Data exchange" column in all subsequent tables  

This column indicates whether an attribute is included in the data exchange with COMOS 
Integrated Engineering or Advanced ES. 

   

1. Attributes of the "Equipment module" object 

 
Attribute Description of attribute value Data exchange 
Name Can be edited, is not forwarded 

Gets default value "CFC(x)". 
Yes 

Comment Can be edited, is not forwarded Yes 
Author Can be edited, is not forwarded to associated objects Yes 
Sampling time Can be edited, all blocks of the assigned chart are 

installed in the OB with the most suitable sampling 
time. The next higher value will be entered in case of 
an invalid entry. 
The runtime editor is adapted accordingly. 

Yes 

Assigned chart Cannot be edited No 

  
 

 Note 
"Command" and "Status" attributes 

No "Command" and "Status" objects can be defined in an equipment module. They can be 
defined either specifically for a control module type or basic requirement, or as "global" 
objects. You can find the description of the attributes of the "Command" and "Status" objects 
in the section "Attributes and attribute values of a control module (Page 175)".  

 

  

2. Attributes of the "Equipment phase" object 

 
Attribute Description of attribute value Data exchange 
Name Can be edited, is not forwarded 

Gets the default value "Equipment phase". 
Yes 

Comment Can be edited, is not forwarded Yes 
Author Can be edited, is not forwarded to associated objects Yes 
Assigned block Cannot be edited No 
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3. Attributes of the "Control module" object 

 
Attribute Description of attribute value Data exchange 
Assigned chart Cannot be edited No 
Name Can be edited, is forwarded to associated objects 

Gets the name of the assigned chart as default value. 
Can also be assigned to the CFC or a block.  

Yes 

Comment Can be edited, is forwarded to associated objects No 
Author Can be edited, is not forwarded to associated objects No 
Optional Editable 

Occurs only at the type. 
The attribute is not available for lower-level control 
modules, that is, for control modules that are directly below 
a type of a control module/equipment module.  

Yes 

Function 
identifier 

Can be edited, is forwarded to associated objects. 
Is not of use for lower-level control modules.  

No 

Location identifier Can be edited, is forwarded to the DOCPRO footer "Code 
field according to location" of the assigned chart. 
Only useful in the plant description of the project; it is 
therefore only offered in this context.  
Is not of use for lower-level control modules. 

No 

Standard function Can be edited, is used to identify a control module as a 
standard function. 

No 

Standard function 
name 

Displays the name of the standard function. 
• Cannot be edited at the type of the control module. 

When the "Standard function" attribute is enabled, the 
value of the "Name" attribute is applied automatically.  

• Can be edited at the instance. 

No 

Basic requirement Editable 
Occurs only at the type. 
A standard function cannot be basic requirement.  

Yes 

Control module 
type 

Cannot be edited, is not forwarded No 

  

There is no "Sampling time" attribute for control modules in equipment modules, because the 
control module is assigned in the runtime group of the equipment module.  
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4. Attributes of the "Control module assignment" object 

 
Attribute Description of attribute value Data exchange 
Role Editable 

Gets the default value "Role". 
Yes 

Comment Can be edited, is not forwarded Yes 
Assigned control module Can be edited, is not forwarded to associated objects Yes 

  

5. Attributes of the "Control module (basic requirement)" object 

 
Attribute Description of attribute value Data exchange 
Name Can be edited, is not forwarded 

Gets default value "Control module(x)". 
Yes 

Comment Can be edited, is not forwarded Yes 
Author Can be edited, is not forwarded to associated objects Yes 
Optional Can be edited, is not forwarded to associated objects. Yes 
Function 
identifier 

Can be edited, is forwarded to associated objects Yes 

Standard function Can be edited, is used to identify a control module as a 
standard function. 

No 

Standard function name Can be edited, displays the name of the standard 
function 

No 

Basic requirement Editable Yes 
Assigned block Cannot be edited No 

  

6. Attributes of the "Parameter" object 

 
Attribute Description of attribute value Data exchange 
Assigned I/O Cannot be edited No 
Interconnection to Can be edited, the interconnection is displayed here No 
Name Can be edited, is not forwarded 

Gets the default value "Parameter". 
Yes 

Comment Can be edited, is not forwarded Yes 
Process value Can be edited, right-click the text box to open the symbol 

table of the CFC using the menu command "New signal 
interconnection". The value is forwarded to the 
"Interconnection" property of the assigned I/O. 

No 

Value Can be edited, is forwarded to the "Value" property of the 
assigned I/O 

Yes 

Negation Select the check box to negate the control variable. The 
box can only be selected if there is an interconnection. 

No 
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Attribute Description of attribute value Data exchange 
Enumeration Can be edited, is forwarded to the "Enumeration" property 

of the assigned I/O. The attribute s7_Enum must be 
configured. 

No 

Unit Can be edited, is forwarded to the "Unit" property of the 
assigned I/O. The attribute s7_unit must be configured. 

No 

Operation identifier Can be edited, is forwarded to the "Identifier" property of 
the assigned I/O. The attribute s7_shortcut must be 
configured 

No 

IO type Selection via drop-down menu, must match IO type of the 
assigned I/O 

No 

Data type Selection via drop-down menu, must match data type of 
the assigned I/O 

Yes 

Variable type "Parameter" (selection via drop-down menu). Forwarded to 
the assigned I/O. 

Yes 

  

7. Attributes of the "Process value" object 

 
Attribute Description of attribute value Data exchange 
Assigned I/O Cannot be edited No 
Name Can be edited, is not forwarded 

Gets the default value "Process value". 
Yes 

Comment Can be edited, is not forwarded Yes 
Process value Can be edited, right-click the text box to open the 

symbol table of the CFC using the menu command 
"New signal interconnection". The value is forwarded 
to the "Interconnection" property of the assigned I/O. 

No 

Negation Select the check box to negate the control variable. 
The box can only be selected if there is an 
interconnection. 

No 

IO type Selection via drop-down menu, must match IO type of 
the assigned I/O 

No 

Data type Selection via drop-down menu, must match data type 
of the assigned I/O 

Yes 

Variable type "Process value" (selection via drop-down menu). 
Forwarded to the assigned I/O. 

Yes 
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8. Attributes of the "Message" object 

 
Attribute Description of attribute value Data exchange 
Assigned message Cannot be edited No 
Name Can be edited, is not forwarded to associated objects 

Gets the default value "Message". 
Yes 

Message class Cannot be edited, this value is inherited from the 
"Message class" property of the assigned single 
message. 

No 

Priority Can be edited, only numbers possible. The value "0" is 
entered in case of an invalid entry. Forwarded to the 
property "Priority" of the assigned single message. 

Yes 

Message identifier Must be specified manually 
If a valid message identifier (e.g. SIG1) is entered, the 
message class, event and origin attributes are 
automatically applied as long as the assigned block has a 
message response. 

No 

Event Cannot be edited, is inherited from the "Event" property of 
the assigned single message 

No 

Information Forwarded to the "Infotext" property of the assigned single 
message. 

No 

Origin Forwarded to the property "Origin" of the assigned single 
message. 

No 

  

9.12.5.11 Special considerations for the implementation of specific commands/statuses 

Overview 
Introduction 

A command/status can be defined as follows: 

● At the type of a control module (not at an instance) or at a "Control Module (Basic 
Requirement)". 

These commands and statuses are specific to these objects. 

● "Globally", i.e. with the SIMATIC Manager in the master data library. 

Condition for "specific" commands/statuses 

The description below for the implementation of "specific" commands and statuses applies 
under the following conditions:  

● Command/status is a lower-level element of the type of a control module 

● Command/status is a lower-level element of a "Control Module (Basic Requirement)", 
whereby this basic requirement was defined in the master data library by setting the 
attribute "Basic Requirement" in a control module. 
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Configuration for implementation  

If one of these conditions applies, the following implementation is necessary. 

● In the basic requirement or control module type which has lower-level 
commands/statuses, a block type is configured in the "Assigned Block" attribute. 

A block type can be selected in the "Assigned block" attribute in the basic requirement or 
control module type.  

● This means that only block I/Os of this assigned block type which have the ID 
"S7_contact = true" can be used in the lower-level commands/statuses. 

See also 
Configuring a command or status at the type of the control module (Page 173) 

Overview of data objects of the equipment module and control module (Page 187) 

9.12.6 Configuring a global command or status 

Introduction 
The "Command" and "Status" objects can be defined as follows:  

● At the type of a control module (not at an instance) or at a "Control Module (Basic 
Requirement)". 

These commands and states are specific to these objects.  

● Globally, i.e. with the SIMATIC Manager in the master data library. 

These global commands and states are generally based on equipment phases and can 
be used in all equipment phases of a plant. This means that the implementation only uses 
operating states, sequencer information, etc. of a sequence control system. 

The following section describes how a global command or status is created. The optional 
creation of formal parameters for these objects is also described.  

General information 

Commands and states are identified by a name and there can be more than one. These 
objects can be selected, copied and deleted individually or collectively in the SIMATIC 
Manager. 
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 Note 
Use of characteristics in the conditions of a global command/status 

No tags that can be used directly in the conditions exist for the following characteristics:  
• Control strategy 
• Note text 
• Position text 

When the standard parameters "QCS", "QCSP", "OPTINO" and "POSINO" are used in a 
condition of a global command/status, these above-mentioned characteristics can only be 
addressed via the number, for example of the control strategy. 

For this purpose, the following configuration in the global command/status is required:  
• To use one of the above-mentioned characteristics in a condition, a corresponding formal 

parameter must be created as lower-level object of the global command/status for this 
characteristic. This formal parameter must have the relevant data type. 
Example: A position text has the name "Positiontext_A" and the data type "POSITION 
TEXT".  

• In the assignment of the condition, the name of this formal parameter, e.g. 
"Positiontext_A", is entered and supplemented by the string "_NUMBER". The field 
automatically gets a yellow background. 
In this example, the condition would be called: "POSINO" = "Positiontext_A_NUMBER".  

When data is taken from COMOS Integrated Engineering or the runtime program is 
generated in PCS 7, the corresponding number of the characteristic, e.g. of the position text, 
is automatically inserted into the condition in the sequencer of the equipment phase.  

In this example, the condition would be called: "POSINO" = "1". 
 

  

Requirement 
A multiproject open containing a master data library is open in the SIMATIC Manager. 

Procedure 
1. Use the menu command "View > Plant View" to open the plant view. 

2. In the plant view, navigate in the master data library to the directory where you want to 
create the global command or status, for example "Process tag types". Other directories 
can be used, for example, ones you have created in the master data library. 
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3. Select the command "Insert New Object" and then "Command" or "Status" in the shortcut 
menu. 

The newly created command or status appears in the right window with the 
corresponding icon. 

– Status 

 
A lower-level "Parameter" object named "OUT" is created automatically for a new 
status. This parameter has the BOOL data type and serves as the formal output 
parameter. 

– Command 

 
4. Open the command or status in the CFC editor to configure its properties. 

Select the icon for the "Command" or "Status" in the technological editor. 

The command or status has the default attributes "Name", "Author" and "Comment".  

Configure the desired attributes.  

5. Optionally, you can create lower-level formal parameters for this command or status. 

To do this, select the icon for which you want to create a parameter in the technological 
editor. 

6. Select "Insert New Object > Parameter" from the shortcut menu. 

The selected object is inserted and displayed as an icon.  
 

7. If you want to configure the attributes of the parameter, select the "Parameter" icon in the 
technological editor. 

The associated attributes are displayed.  

Configure the desired attributes. 

8. To configure the properties of the new command or status, select the corresponding icon 
in the technological editor. 

In the shortcut menu, select the menu command "Properties".  

The "Properties" dialog box opens.  

For "Command", the dialog has a similar structure to the dialog for step configuration; for 
"Status", the dialog has a similar structure to the dialog for the configuration of transition 
conditions. 

9. Configure the desired conditions for the command or status. 

You can also use the "Browse" button to open a selection dialog. All the parameters that 
can be used, i.e. only the block I/Os that have an identifier "S7_contact = true", are 
displayed in this dialog box.  
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10.Select the desired parameter. Click the "Apply" button to apply the selected parameter in 
the line previously selected of the "Properties" dialog box. 

In the "Properties" dialog box, the next row of conditions is selected automatically and the 
selection dialog box remains open. If needed, repeat this step to configure additional 
conditions.  

Click "Close" to close the selection dialog.  

11.Click "Close" to close the "Properties" dialog box. 

If required, a prompt for applying the configuration is displayed. Confirm this prompt.  

Result 
The global commands and/or states have been created in the master data library.  

Formal parameters for these objects have been optionally inserted.  

A parameter named "OUT" is created automatically at the status.  

See also 
Overview of data objects of the equipment module and control module (Page 187) 
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 Compiling 10 
10.1 Essentials for CFC chart compilation 

General 
If you want to control the assignment of resources on the target system via the "Settings for 
compilation" dialog box, it is important to understand the relationships explained below.  

You can find additional information in the section: Settings for compilation/download 
(Page 236) 

The structure you configure in CFC is mapped to the S7 objects FC and DB. 

FCs are required to call the blocks processed in the CFC chart according to the configured 
run sequence, as follows: 

● One FC for each OB used 

● One FC for each runtime group 

DBs are used as follows: 

● An instance DB is created for each instance of an FB. 

● Internal DBs are created in CFC for storing intermediate results, for example, from FCs. 
One of these DBs is required for each data type. An additional DB will be created when 
the maximum length of 4 KB is reached. 

SCL compiler 
Note the following when compiling with the SCL compiler: 

● In CFC you can generate SCL source files that exceed the capacity of the SCL compiler. 
This may occur if too many blocks are installed in a task or runtime group. The FC 
containing the block calls will thus become too large and the SCL compiler returns the 
error message “Internal symbol list is full”. 

Remedy:Distribute the blocks across several runtime groups. Smaller FCs are thus 
generated during compilation, since the blocks of one runtime group are called in their 
own FC. 

● The time required by the SFC compiler may be extended considerably due to large CFC 
structures. In some cases, there may be no progress visible for several minutes. 
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10.2 Settings for compilation/download 

Making the settings     
You can customize settings for the current CPU prior to compilation. 

Select the menu command Options > Customize > Compile/Download…. 

A dialog box opens in which you can: 

● Set warning limits in order to detect possible risks in due time before you start your 
download. Warning limits are available for: 

– Local Data 

– Instance DB of the S7 communication(Number) 

– Load memory/work memory. This is only checked when the download is carried out. 

– Blocks per runtime group or OB 

● Specify which resources should remain unused when compiling the charts of the current 
chart folder (areas reserved for other applications). This may be useful, for example, if 
you want to solve an automation task partly with charts and partly by programming, for 
example, STL, LAD or SCL programs, and when you are using functions (FCs) or data 
blocks (DBs) from other sources in your user program. 

● View the statistics of resources (DBs, FCs) available on your CPU for compiling the 
charts and how many of those are currently being used. The following information is 
provided: 

– The maximum available DB and FC numbers on the CPU 

– The DB and FC numbers available for CFC (maximum CPU minus the reserved 
areas) 

– The number of DB and FC numbers in use by CFC 

If no CPU has been assigned to the active chart, the "Maximum" and "Available" columns 
have the entry "- -". 

● Check the relevant box to generate an image of the downloaded program for comparison 
purposes: 

With this option you can generate an image of the current program following a successful 
download operation. The image is created as an XML document and assigned to the 
program.  

Then, when you want to download again, you can click "Show Changes" in the "S7 
Download" dialog box to run a comparison between the XML file and the data you want to 
download before it is actually downloaded. You can only carry out this comparison if you 
have the Version Cross Manager (VXM) add-on package installed and if an image was 
generated when the program was previously downloaded. 

Please note that XML file generation slows down a full download.  
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Compressing 
Click "Compress" to call a function you can use to close gaps in the DB and FC number 
pool. Such gaps develop, for example, when you delete objects. Compressing eliminates 
gaps in the pool DB. DB numbers may then be free again. 

 

 Note 

If you have changed and compressed the number ranges, you must compile the entire 
program and download it to the CPU in stop mode. 
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10.3 Compile charts as program 

Compiling                   
If objects have been modified in or added to a chart folder, the SIMATIC Manager displays 
the closed chart folder with an additional icon at the lower left corner. 

 
This means that the program still needs to be compiled. 

A consistency check is performed automatically during compiling. You can also start this 
consistency check without compiling, for example, before you overwrite an old and still 
functioning CFC program by compiling. To do this, select the menu command Chart > Check 
Consistency > Charts as Program.../Chart as Block Type.... 

To compile, select the menu command Chart > Compile > Charts as Program... or click the 
icon in the toolbar: 

 
A dialog box opens. You can select other options here.  

Logs are generated during the consistency check and compiling. You can view the entries in 
CFC with the menu command Options > Logs.... 

The consistency check differs, depending on the specific target system. The following 
checks are performed, for example, to see: 

● Whether the in/out parameters or block outputs of the type "ANY", "STRING", 
"DATE_AND_TIME" or "POINTER" were interconnected 

● Whether blocks are installed according to their task list 

● Whether FC and DB numbers are in the range that is illegal for CFC (areas reserved for 
other applications) 

Scope of compiling 
You can select one of two compiling options: 

● Scope: Entire program 
When you set this option, all AS resources will be compiled, in other words the full 
content of the chart folder, regardless of any changes. 

● Scope: Changes only 
When you set this option, you only compile the changes made in AS resources since the 
last compilation. This only includes changes in content, for example, interconnections, 
block attributes or number of inputs, but not the movement of objects within the chart. 
Select "Compile changes" wherever possible, since it significantly reduces compilation 
time. 
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  Note 

When you compile changes, only the scope of your changes will be checked. You need 
to perform a consistency check to verify the entire program. 

 

Optional functions for execution prior to compilation 
Before you compile your data, you can set specific optional functions to be executed prior to 
compilation: 

● "Generate SCL source" option 

The check box is disabled as the default setting. If this box is checked, an SCL source file 
is generated and stored in the source files folder. This source file is not needed for 
compiling the program. 

Generating the source is only relevant to you if you want to view certain program sections 
in SCL code, for example, to make things clearer or for use in troubleshooting.  

The enabled check box is only valid for one compile; at the next compile it is disabled 
again. 

● "Generate module drivers" option 

The check box is enabled by default, in other words prior to each compile the driver 
generator will also be started. In special cases, when the hardware is still incomplete, for 
example, you can disable the check box so that the function "Generate Module Drivers" is 
not executed. 

This deactivation only applies for this compile, for the next compile the check box is 
reactivated. 

● "Module drivers settings" button 

The driver generator creates and interconnects module drivers for the existing signal-
processing blocks, if the hardware configuration has changed since the last compilation 
run. If you do not want to use the driver blocks from the current PCS 7 Library, you can 
use the "Module driver settings" button to open a dialog box where you can select the 
required driver library. 

 
  Note 

Changes to sample times in HW Config take effect the next time the ES is compiled. 
 

After compiling 
When the compilation is completed or canceled, the S7 Logs dialog box opens. All 
compilation events, warnings and errors are included in this log. Based on this log you can 
verify compilation and print the log file by clicking "Print". Click "Close" to close this dialog 
box. 
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You can open and print the log subsequently with the menu command Options > Logs.... 
 

 Note 

Please note the following: 
• The warning events written to the log did not abort compilation, but may cause errors 

during subsequent downloads, in other words, prevent or cancel the download. 
Warnings relating to textual interconnections that are not closed or interconnections to 
addresses not (yet) available in the symbol table do not affect the download. In both 
situations, a substitute value will be generated according to the default parameter value 
of the block type. 

• A warning is written to the log if your project contains blocks that are called recursively. 
Recursive blocks are displayed in the "Block Call Hierarchy" view in the chart reference 
data. You can call this view using the menu command Options > Chart Reference Data. 

• Since PCS 7 blocks do not contain recursive calls, these must be user blocks. Make sure 
that any abort conditions defined in your program are always met so that no endless 
loops can occur or remove the recursion. 

• If the license is not adequate you can only compile the entire program. Compiling of 
changes is canceled in this case. 

• Compiling the entire program does not necessarily mean that a complete download is 
necessary. If the program was already loaded on the CPU prior to compiling, it is possible 
to perform a download of changes. 

 

Additional information 
You can find additional information in the following sections: 

Essentials for CFC chart compilation (Page 235) 

Settings for compilation/download (Page 236) 

Compile and download objects (Page 256) 
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10.4 Compile chart as block type 

Start 
You can create block types from existing CFC charts that will be used more than once and 
that have the required chart I/Os. You can assign system attributes to these block types. 

To perform the compilation, select the menu command Chart > Compile > Chart as Block 
Type.... A dialog box opens displaying the “General” and “Attributes” tabs. 

Compiling 
You have the following compilation setting options: 

● In the "General" tab, specify the block type properties before starting compilation (FB 
number, symbolic name, name (header), family, author, version) and specify the target 
system on which the block will be used. This information (S7-300/S7-400) is relevant for 
the startup blocks, since the SCL compiler needs to generate a different code for each 
target system.  
Note on the FB number: This number must not exceed the range supported by your 
destination CPU.  
Example: In the case of 414-2DP CPUs, the maximum number range is set to 512 
(address range: number of FBs). The number you assign to the block must, therefore, not 
be higher than 511. 

The use of specific code sequences ensures that all chart blocks to be compiled are 
called according to their entry in the S7_tasklist attribute.  
 

 
  Note 

An S7 -300 supports only OB100, an entry of any other OB in the task list is not 
permitted. Otherwise an error message results. 

 

● You can start a code optimization that affects the local data requirements or the online 
download of changes. 

– Local data requirements: 
With this type of optimization, a change in the chart does not increase the local data 
requirements, since all temporary variables are stored in the instance DB (VAR area). 
This does, however, lead to a change in the structure of the instance DB and to a 
change in its interface time stamp. In this case, no online download of changes is 
possible. 

– Downloading changes in RUN: 
With this type of optimization, if there is a change in the chart, the temporary variables 
will be stored in the VAR_TEMP area if possible. Possible in this context means that 
all intermediate results in the data flow are stored at this location. Only the 
intermediate results that do not exist in the data flow, for example, in feedback loops, 
continue to be stored in the VAR area (instance DB). The advantage of this 
optimization method is that not all modifications will affect the interface time stamp of 
the instance DB, in other words, in most cases an online download of changes will still 
be possible. However, the local data requirements are increased. 
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● As an option, you can also enable know-how protection. The algorithm of the block can 
be viewed, but only modified if the suitable SCL source files exist. 

● You can set the system attributes for this block type in the "Attributes" tab. 

Consistency check 
Consistency is checked against the following criteria during compilation: 

● Whether the chart contains nested charts 

● Whether the block is installed manually only once in an OB, in other words, only once 
outside the OB specified by the "S7_tasklist" system attribute 

● Whether all blocks are installed consecutively in the same OB, so that no blocks of other 
charts are placed in between 

● Whether the blocks are inserted into runtime groups 

● Whether all chart I/Os are connected to internal block I/Os 

● Whether the chart I/Os have an EN input, since these are generated automatically 

● Whether an existing ENO I/O is assigned the BOOL data type 

● Whether block inputs that cannot be interconnected are assigned the attribute 
S7_link:="false" at the chart I/O 

● Whether illegal blocks exist 

● Whether illegal data types exist at the I/Os 

Additional information 
You can find additional information in: 

System attributes of blocks 

System attributes of block connections 

Assigning system attributes 

Creating block types in CFC (Page 293) 
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10.5 Special considerations during compilation for an "S7-410" AS 

Overview 
During compilation of the program for an "S7-410" AS, the following special considerations 
apply:  

● Monitoring block for license information 

During compilation, a "@PA-CPU" CFC is automatically created which includes an 
instance of the "PA_CPU" block. This CFC is also installed in the OB1.  

The "PA_CPU" block is required in the "S7-410" AS and is used for license monitoring. It 
is available as FB16 in the directory "ELEM_400" in the CFC library.  
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 Downloading 11 
11.1 How to download a user program to the target system 

Overview  
After you have completed compilation, you can download the user program and test and run 
it on the target system.    

If a program has been compiled but not yet downloaded, this is indicated in SIMATIC 
Manager by an additional icon at the lower left corner of the closed chart folder.  

 
The program is downloaded to the CPU assigned to the active chart.  

General information 
Please observe the following information: 

● Always download programs created in CFC to the target system from CFC, since only the 
download function of CFC ensures consistency of offline and online target system data.  
Exception: 

The CFC download function is also offered in the SIMATIC Manager in the following 
cases: 

– For a selected chart folder, with the menu command CPU > Download. 

– For a selected (multi)project or a station, with the menu command CPU > Compile 
Object and Download.  
For more information, refer to the section: Compile and download objects (Page 256) 

What is not allowed is marking the block folder or individual blocks and calling the menu 
command CPU > Download or copying the blocks from the "Offline block folder" and then 
inserting them into the "Online block folder". 

● Downloading to the CPU, just like working in test mode, is a protected function in S7 that 
must be logged if the SIMATIC Logon Service is installed. The actions during 
downloading and the time stamps are listed in the ES log if the current chart folder for the 
ES log was enabled with the menu command Chart Folder > Object Properties... > "ES 
Log" tab. 

You can find additional information about this in the section: Change log and ES log 
(Page 275) 

● If warnings are entered in the log during compilation of the program, this may mean that 
downloading will be prevented or aborted. In this case, check whether warnings in the 
compilation log are relevant to downloading before you download. 
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Procedure 
To download the user program to the target system, proceed as follows: 

1. Select the CFC menu command CPU > Download... 
or  
click the following button in the toolbar: 

 
A dialog box opens where you can select the type of download. 

If changes to data relevant for the download have been made in the user program prior to 
downloading, a message appears, which informs you that the program first needs to be 
compiled. You are then asked whether you want to perform that compilation, followed by 
the download.  

2. Select the type of download: 

– Entire program: All applicable program objects will be downloaded. 

– Changes only: Changes that have been made since the last download are 
downloaded. 

– Download to test CPU (entire program): All applicable program objects will be 
downloaded. 

3. Click "OK". 
The download begins. 

Click "Apply" to save your changes without initiating the download. 

If you only want to save your settings without downloading, click "Apply" and then "Cancel". 

Download: Entire program  
The "entire program" can be downloaded in the STOP or RUN-P modes. In RUN-P mode, 
the CPU is set to STOP – following a prompt – and all its blocks are deleted. After the 
download has been completed, you are prompted "Do you want to restart the CPU?". Click 
"Yes" to trigger a CPU restart. 

Before a full download is performed, a dialog box opens and you have the option of reading 
back the parameters. Readback is only possible if no interface changes have been made to 
block types, in other words, provided that a download of changes remains possible. 

The following applies when performing a full download: 

● Compiling the entire program does not necessarily mean that a complete download is 
necessary. If the program was already loaded on the CPU prior to compiling, it is possible 
to perform a download of changes. 

● If a full download has been canceled, it is no longer possible to download changes until a 
full download has been completed.  
Reason: The blocks were deleted on the CPU prior to the download. 
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Download: Changes 
You can download changes when the CPU is in RUN-P mode. The correct download order 
and segmentation required for the download of data will be maintained. Please note that 
there is no absolute guarantee that the CPU will not change to STOP as a result of 
temporary inconsistencies, since not all conditions can be checked. 

If the "Include user data blocks" check box is selected (default setting), the following 
conditions apply to data blocks located outside of the CFC area when downloading changes: 

● The blocks are included in the download if the time stamp is different or data blocks have 
been added. 

● The blocks are deleted on the CPU if they do not exist in the S7 program. 

If user data blocks are to be ignored when downloading changes, deselect the check box.  

This can have the following consequences: 

● If a user data block exists in the S7 program but does not exist on the CPU, downloading 
will be aborted with an error message. 

● If the user data block exists on the CPU but no longer exists in the S7 program, a warning 
is displayed. A warning also appears if the user data block in the S7 program differs from 
that on the CPU. Correct execution of the program is then the user's responsibility. 

Notes on downloading changes 
Please observe the following information: 

● It is always possible to download changes if the following conditions are met: 

– When a full download has been successfully completed at least once 

– The download is performed with the program structure previously used.  
For information, refer to the section: What you should know about downloading 
changes (Page 251). 

● An "asynchronous compression of the CPU" is implicitly performed following the 
download of changes. This may help to prevent warnings and error messages during a 
later download of changes due to lack of memory.  
Compressing the CPU memory has other effects on downloading compared with 
compressing the DB/FC number areas. In the latter case, no download of changes is 
possible. 

● Compiling the entire program does not necessarily mean that a complete download is 
necessary. It is possible to download changes if the program was loaded on the CPU 
prior to compilation. 

● You can compile a program as often as you wish (changes only or entire program) 
without losing the ability to download changes. 

● You can repeat a download of changes you have canceled in order to download objects 
not included the first time. 
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● You cannot download changes after you have tested a modified program on another 
system or via PLCSIM before downloading it to the runtime system. 

Remedy:With the option "Scope: Download to test CPU (entire program)", it is still 
possible to download changes to the original CPU. See also: 

Downloading a modified program to a test CPU (Page 250) 

● Answers to the questions: 

– "What situations will prevent online downloads of changes?" 

and  

– "How do I maintain my program's ability to perform online downloads of changes?" 
can be found under: What you should know about downloading changes (Page 251) 

 
  Note 

Certain scenarios may mean that a download of changes can no longer be performed. 
The only option is to download the entire program with the CPU in STOP. Before this 
is carried out, a warning appears to guard against unintentional loss of the capability 
to download changes. 

 

System support 
Reference lists will be created for blocks compiled under STEP 7 => V5.0 + SP3 or SCL => 
V5.0 + SP3. Based on those reference lists, the system performs a check in order to detect 
causes of CPU STOP and to prevent downloads if any errors (messages) have occurred. 

You can find additional information about this in the section: System support for avoiding 
causes of CPU STOP (Page 253) 

Displaying modifications before download 
The "Show Changes" function is only available if the Version Cross Manager(VXM) add-on 
package is installed and if an image of the downloaded program was generated. 

Generating an image of the downloaded program 

Assuming you have selected "Generate image of downloaded program for comparison" in 
the "Settings for Compilation/Download" dialog box, the image will be generated as an XML 
document and assigned to the program following a successful download operation. 

Comparing programs 

If you generated an image of the downloaded program, you can click "Show Changes" in the 
"S7 Download" dialog box to run a comparison between the XML file and the program you 
now want to download before it is actually downloaded. 

VXM opens for the comparison. The comparison will enable you to see which data have 
changed in relation to the program that was downloaded previously. You can then decide 
whether or not to download the latest version. 
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Notes on H CPUs 
● If the H CPU is being operated in solo mode, for example, due to CPU failure, and a CPU 

failover has taken place, a dialog will appear following an online access request. There 
you can select which CPU should be linked. This dialog box does not appear in 
redundancy mode. 

● All changes will be lost if you download program changes to a CPU operating in solo 
mode and then execute "Switchover with modified configuration" with the menu command 
CPU > Operating Mode.... In this case you need to download the entire program. 

Remedy: Download in redundant operation. In this case, you must make sure that the 
operating mode remains unchanged until the download is complete. 

Note on F systems 
You must enter the F password in order to download changes from programs with a modified 
F component. Otherwise, the F system will reject the download. 
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11.2 Downloading a modified program to a test CPU 

Downloading to a test CPU 
With the option "Download to test CPU" in the S7 download dialog, you can download a 
changed program for testing to a different CPU or to PLCSIM. The ability to download 
changes is not lost. 

When you download as a test, the entire program is downloaded to the test CPU or to 
PLCSIM without losing the download identifiers and without the comparison stamp being 
written to the ES data management. 

To avoid accidental overwriting of the program by a test download, the loader checks 
whether the changed program is capable of a changes-only download. If this is the case, the 
original CPU must be involved and not the test CPU. A note text to this effect is then 
displayed and the download cannot be performed. The “OK” button is disabled. 

Additional information 
You can find additional information in the section: What you should know about downloading 
changes (Page 251) 
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11.3 What you should know about downloading changes 

How do I maintain my program’s ability to perform online downloading of changes?     
In cases where plants change during operation but must not be set to STOP mode under 
any circumstances, the possibility of downloading changes to them must be ensured.  

 

 Note 

If you want to ensure that your program retains its ability to download changes, you should 
generate a backup copy after each completed download. 

 

This measure may not be required for the testing or commissioning phase. The decision is 
yours and depends whether or not a complete download in STOP can be tolerated under 
specific circumstances. 

The figure below shows how the online ability to download changes can be lost 
unintentionally. 

 
Legend: 
Blue triangle = delta download 

Step 1: 
The program was downloaded to the CPU and a backup copy was generated. At the time of 
download the time stamp generated during compilation is stored in the offline and online 
program (17.04.02 12:04:38).  
Therefore, two time stamps exist in the offline program: 
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● One which is updated each time a compilation is performed 

● One which is used for comparison and is only overwritten once the download has been 
successfully completed 

Step 2: 
The offline program is assigned the current time stamp "18.04.02 10:14:22" after it has been 
modified and subsequent compiling. The offline comparison stamp generated during the last 
download points to "17.04.02 12:04:38"; the online program also contains this time stamp. A 
download of changes is carried out. The offline program is assigned the new comparison 
stamp "18.04.02 10:14:22" that will also be transferred to the online program. 

Step 3: 
You are modifying a program that is now inconsistent, for example, after data was lost due to 
a power loss. 

Step 4: 
The system will refer to the last known good version (step 1) and execute the changes made 
in steps 2 and 3 once again. The program is assigned the current time stamp 
"20.04.02 09:05:35" after it has been compiled, the offline comparison stamp of the last 
download points to "17.04.02 12:04:38" (step 1). The time stamp of the online program 
points to "18.04.02 10:14:22" (step 2). A download of changes is no longer possible, since 
those two time stamps are not identical. 

This scenario shows clearly that a backup copy generated in step 2 would have sufficed to 
generate identical time stamps in step 4 and thus would have enabled a download of 
changes. 

What situations will prevent online downloads of changes? 
It is no longer possible to download changes if the following conditions are present: 

● A used block type has been replaced by a new version that contains structural changes, 
for example, due to the addition of I/Os and/or messages. 

● DB and FC number areas have been compressed during compilation using the menu 
command Options > Settings > Compile/Download… > Option: "Compress" DBs and FCs 
will be assigned a new numbering sequence in this case. 

● A modified program was downloaded to another CPU prior to the download of changes, 
for example, for testing purposes. In this case, the time stamp no longer matches the time 
stamp of the original CPU. 

Exception: If you use the “Download to test CPU” option in the “S7 Download” dialog box, 
the download identifier and comparison stamp are retained. You can thus still transfer the 
program to the original CPU by downloading changes. 

● You have restored a program from archive. This is not the original program used for the 
last download (time stamp comparison). 
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11.4 System support for avoiding causes of CPU STOP 

Introduction 
During compilation and download, the system performs checks and evaluations in order to 
avoid the causes of CPU STOP during online program downloads. 

The block reference lists are also used for these checks. These reference lists exist only for 
blocks compiled with STEP 7 >= V5.0 + SP3 or SCL V5.0 + SP3. This affects blocks of the 
PCS 7 V5.1 libraries. A full verification is not possible if the program uses blocks without 
reference lists (blocks of the libraries PCS 7 V4.x and V5.0 and the STEP 7 standard library). 
In this case, a warning will be displayed. 

System support during compilation 
The system supports compilation as follows: 

● The consistency check includes the entire block call hierarchy and its time stamps. The 
system can detect that two blocks will call the same block (recursive call), but those 
called blocks have different versions. 

● The maximum local data requirements are calculated and compared with the resources of 
the configured CPU. A warning is generated if the absolute value (100%) or the warning 
limit set using the menu command Options > Customize > Compile/Download… is 
exceeded; the code is generated all the same. This allows you to adapt the local data 
stack without having to recompile the data. 

● The program structure is scanned in terms of the nesting depth of its blocks and the result 
is compared with the maximum possible nesting depth of the configured CPU. 
Compilation is canceled if the maximum is exceeded. An error message which contains 
the complete call hierarchy of the relevant OB is written to the log file.  
The maximum nesting depth of an OB is <= 24. 
It is calculated as follows (nesting depth = ND): 
 NDmax = NDmax of the OB + NDmax of OB121 + NDmax of OB122 

● The OBs are checked to make sure that they call the correct blocks generated by the ES 
(task FCs). An error message is written to the log file if the incorrect FC is called. 

● The number of instance DBs of S7 Communication are counted and compared with the 
configured maximum number of communication jobs after compilation was completed. 
The number of communication jobs matches the number of instance DBs of S7 
Communication. This check determines whether the set warning limit or absolute limit 
(100%) is exceeded. 

A warning message is written to the log file if one of these limits is exceeded. 

All error messages prevent subsequent downloads. 
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System support during downloads 
The system supports downloads as follows: 

● A check is made to determine whether the connected CPU supports the system functions 
(SFBs, SFCs) required by the program. The download is canceled if support is lacking. 

● The maximum local data requirements calculated during compilation are compared with 
resources of the online CPU receiving the download. The system status list is read for 
corresponding information. A warning message is output in the log if the warning limit is 
exceeded, however, the download is not canceled. The download is canceled and an 
error message is output in the log if the absolute limit is exceeded. 

● Memory requirements for the blocks to download are calculated and the result is 
compared with memory resources of the CPU. A check is made to determine whether the 
set warning limit and/or the absolute limit (100%) are exceeded. A corresponding 
message is output to a dialog box one of these limits is exceeded. The following options 
are available in this dialog box: 

– Compressing CPU memory 

– Discarding compression and continuing the download (responsibility of the user) 

– Cancellation of the download 

Memory resources are determined after data compression in CPU RUN mode was 
completed. The download is carried out if memory requirements are now less than the set 
warning limit. If the result of compression is not satisfactory a corresponding message is 
once again output to the dialog box. You can now decide whether to continue or cancel 
the download. 

If you ignore the warning and continue the download, the download will be canceled on 
reaching the absolute limit. However, the CPU does not go into STOP. The error 
message written to the log file. 

 
  Note 

Note that the calculation of memory requirements cannot ascertain whether existing 
blocks in the work memory are deleted or overwritten or if so, how many. That is, the 
actual work memory space required may be less than the data volume of blocks to be 
reloaded.  

Blocks already downloaded are retained in the CPU if the download is canceled. Only the 
blocks not downloaded yet are included in the calculation of memory requirements after a 
new download was initiated. This download procedure can be repeated as required until 
the entire program was successfully transferred to CPU memory.  

 

● The number of instance DBs for S7 Communication calculated during compilation is 
compared with the number configured for the online CPU. A warning message is output 
in the log if the warning limit is exceeded, however, the download is not canceled. The 
download is canceled and an error message is output in the log if the absolute limit is 
exceeded. 
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Additional system support functions 
● Type import 

The reference lists of the blocks to import are also used during a type import of multiple 
instance blocks in order to identify the blocks called. This functionality allows you to copy 
FCs to the target program during import.  

If time stamp evaluation identifies a block which is called by blocks of a different version, 
the call hierarchy of this block is displayed in a dialog box. Blocks updated during import 
are identified in this dialog box.  

If a called block is updated implicitly by the import function, another block that calls the 
same block may no longer be executable. 

Example: The diagram below shows FB 61 which also contains the call of FB 46. Both 
FBs are updated during import. However, FB 46 is also called by FB 202 which is not 
updated and therefore unable to access modified parameters.  

 
From this point onwards, the user must intervene: 
Read the chart reference data by selecting the Options > Chart Reference Data... menu 
command. 
Search for the called block by selecting the Edit > Find menu command in the "Block Call 
Hierarchy" view until all calling blocks have been found. You can also import these blocks 
after having completed the search. 

● Copy/Move 

By evaluating the block reference lists, the called blocks will be included if you copy or 
move multiple instance blocks to another program, similar to the type import.  

● Generate module drivers 

As PCS 7 process control systems may enter the stop state if errors are detected, it must 
be possible to react to various causes of errors such as rack/module failures or I/O 
access errors. To this end, the driver generator inserts the blocks OB_BEGIN and 
OB_END (the MSG_CSF block was used up to V5.2).  

The error OBs which detect these causes of error and prevent CPU STOP are generated 
in the CFC and downloaded to the AS. 
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11.5 Compile and download objects 

       
The SIMATIC Manager function "Compile and Download Objects" allows you to generate 
consistent modified data of different objects in a single pass, for example, networks, 
hardware, blocks, charts, OS servers, OS clients, BATCH servers, and BATCH clients. All 
steps previously distributed across multiple applications are now grouped and processed in 
the correct sequence. 

Please note that for safety's sake, downloading the entire program using this function is only 
possible when you have set the respective CPU to the "STOP" operating mode before 
starting processing. 

You can find additional information on this function in the STEP 7 Basic Help. 
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11.6 Comparing the time stamp of the CPU program 

Time stamp      
On the basis of the time stamp, you can establish which areas of the user program have 
been changed and whether it needs to be recompiled or downloaded again. The system will 
assign time stamps in respect of the following: 

● The last download-relevant change 

● The last compilation process 

● The time when the downloaded program was compiled 

Procedure 
Select the CPU > Compare menu command inthe CFC. 

Alternatively, you can also select the SIMATIC Manager menu command: 

Select the station or the CPU or the S7 program or the chart folder, followed by the shortcut 
menu command CPU > Compare. 

A dialog box showing the current time stamp of the downloaded program appears. 

Evaluation 
● The "Last download-relevant change" time stamp indicates the time when changes were 

made to the offline program that also necessitate changes to the online program, for 
example, interconnection changes or block changes. The time stamp is also changed if 
block I/Os are programmed in test mode. 

Changes are not classed as download-relevant if they are not taken into account during 
compilation into machine code. Examples include changes to the position of blocks in the 
chart or the insertion or deletion of text boxes. 

● The "Last compilation" time stamp is the time the program was last compiled following a 
change. 

● The "Compilation of downloaded program" time stamp is the time stamp that was 
generated during the last compilation process and entered at the time of the download. If 
a connection with the CPU has not been established, it will not be possible to read this 
time stamp and "---" will be displayed. 

The user program that you downloaded to the CPU is only identical with the user program in 
terms of CFC data management and machine code if the "Last compilation" time stamp and 
"Compilation of downloaded program" time stamp match exactly and are more recent than 
the "Last download-relevant change" time stamp.  

Tip: You can identify user programs requiring compilation and/or download due to changes 
by means of the chart folder symbol. In the SIMATIC Manager, the relevant icon is displayed 
at the closed chart folder. 
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Compilation required: 

 
Download required: 

 

Note on H CPUs 
● If the H CPU is being operated in solo mode, for example, due to CPU failure, and a CPU 

failover has taken place, a dialog box will appear following an online access request 
There you can select which CPU should be linked. This dialog box does not appear in 
redundancy mode. 

● All changes will be lost if you download program changes to a CPU operating in solo 
mode and then execute "Switchover with modified configuration" with the menu command 
CPU > Operating Mode.... In this case you need to download the entire program. 

Remedy: Download in redundant mode. However, you must ensure in this case that the 
operating mode remains unchanged until the download is completed. 
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11.7 Special considerations during download for an "S7-410" AS 

Overview 
When downloading the program into an "S7-410" AS, the following special considerations 
apply:  

● The number of POs is licensed by the hardware. 

The maximum number of POs is licensed by the hardware for the "S7-410" AS. It is not 
possible to download a greater number of POs than is licensed by the hardware into the 
AS.  

If this happens, the download operation is canceled.  

● The "PCS 7 project" project type is required. 

During downloading to the "S7-410" AS, a check is made as to whether the project has 
the "PCS 7 project" project type.  

Download is only possible when the project has this project type.  

● Download only possible with CFC. 

The "S7-410" AS can only be downloaded with CFC V8.0 SP3 (or higher). Downloading 
from other STEP 7 editors is not possible.  

● Monitoring block for license information 

During downloading to the "S7-410" AS, the "@PA-CPU" CFC is automatically 
downloaded with the "PA_CPU" block. The "PA_CPU" block is required in the "S7-410" 
AS and is used for license monitoring.  
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 Testing user programs 12 
12.1 How to work in test mode 

Requirement          
Prior to testing and commissioning, the user program created in the CFC editor must first be 
compiled free of errors and downloaded to the CPU. 

Test settings 
You can set the watch cycle under Test Settings. The watch cycle is the cycle time used for 
updating the I/Os registered for testing.  
Default: 2 s. 

The watch cycle is CPU-specific; in other words, the setting applies to all charts of the 
current chart folder. If the current chart is moved to the chart folder of a different CPU, the 
value set for this CPU applies to the chart.  

Setting the watch cycle 
1. Select the Debug > Test Settings... menu command. 

A dialog box opens. 

2. Adjust the watch cycle. 

In edit or test mode, you can change the watch cycle setting: 

● In the active chart window 

● In the dynamic display window in which a line of the entries is selected 

 
  Note 

If the cycle time is modified outside the CFC (for example, in SFC), the change is only 
activated by closing and re-opening the CFC chart. 
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Editing modes 
The CFC editor provides two editing modes:  

● Create mode 
In this offline mode you can configure the entire software structure for a CPU. 

● Test mode 
Lets you monitor and edit values in online mode. 

 
  Note 

You can also prepare certain debug functions offline in edit mode, for example, you can 
add block I/Os to the watch list and edit these.  

 

Test mode 
The test mode refers to the CPU to which the currently active chart belongs. 

The CFC editor supports commissioning by providing test functions that allow you to watch 
and influence the execution of the blocks on the CPU and to change setpoints as required. 
Testing can be performed in two modes: 

● Process mode 

● Laboratory mode 

In edit mode, you can select the test mode using the menu commands of the "Debug" menu. 
It is not possible to switch between process mode and laboratory mode once you are in test 
mode. 

In process mode, communication for the online dynamic display of blocks is restricted and 
thus causes only slight extra load on the CP and bus.  
All blocks are initiated with the "watch off" attribute when you activate test mode. 

Laboratory mode allows for convenient and efficient debugging and commissioning. In 
contrast to process mode, the laboratory mode does not restrict communication for online 
dynamic update of charts.  
All blocks are initialized with the "watch on" attribute when you activate test mode. 

Change log and ES log 
Working in test mode, just like downloading to the CPU, is a protected function in S7 that 
must be logged if the SIMATIC Logon Service is installed.  

If access protection and the change log are enabled in the SIMATIC Manager , a dialog box 
opens when you start and end the test mode and when you change values on the CPU. You 
enter the reason for your action in this dialog and this is then entered in the change log. 

The trackable actions are listed in the ES log if the current chart folder for the ES log was 
enabled with the menu command Chart Folder > Object Properties... > "ES Log" tab. 

You can find additional information about this in the section: Change log and ES log 
(Page 275) 
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Activating/deactivating test mode 
Activate test mode as follows: 

Select the CFC menu command Debug > Test Mode...or click the following button in the 
toolbar: 

 
You can now enable the test menu functions; most of the edit mode functions will be 
disabled. 

 

 Note 

If the user program is modified after the code has been compiled a corresponding message 
is output if you want to change to test mode. 

 

When you close the test mode, the test functions will be disabled and the editor functions will 
be re-enabled. 

Exit test mode by selecting the Debug > Test Mode menu command or by clicking the 
following button again in the toolbar: 

 

Configuring I/O 
You can modify the values of all inputs which are not interconnected if test mode is active. 
For exceptions, refer to the section: Essentials for monitoring block I/Os (Page 264). 
Before the modified value is adopted on the CPU, its validity is checked. 

 

 Note 

Note that the parameters modified in test mode are always written to the CFC database. 
 

Notes on H CPUs 
● If the CFC is used in fault-tolerant systems (H-CPUs), the CFC in test mode always with 

the master CPU. 

● If the master changes during redundancy mode then the connection to the CPU is 
terminated. You must exit the test mode and switch the device back on in order to re-
establish the connection. 

● If the H-CPU is operating in stand-alone mode, for example, after a CPU changeover as a 
result of CPU failure, any online access (here: Activate Test Mode) opens a selection 
dialog. There you can select which CPU should be linked. This dialog box does not 
appear in redundancy mode. 
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12.2 Monitoring and assigning parameters to block/chart I/Os 

12.2.1 Essentials for monitoring block I/Os 

Monitoring block I/Os 
If "Watch" is enabled for I/Os that have been registered for debugging, the CPU will provide 
these I/Os with current values in debug mode.    

When you start test mode, the "Watch On" function is also enabled for CFC charts in 
"laboratory mode" with the following icon:  

 
This means, in test mode you can monitor dynamic data of block/chart I/Os registered for 
testing, i.e., those values will be fetched cyclically from the CPU and displayed. and you can 
modify the options for this dynamic data display and the parameters of the I/Os with OCM 
capability. 

In "process mode", the "Watch Off" function is enabled with the following icon:  

 
That means, in a first step you must select the blocks/charts for dynamic data in the chart 
you want to watch. Then, select "Watch On". 

If, on the other hand, there is an overload, you can remove specific blocks/charts from the 
watch list. To do this, select the block/chart followed by the menu command "Watch Off". 

 

 Note 

If monitoring is disabled and you select an I/O in order to register it for testing, monitoring will 
be enabled for this and for all previously registered I/Os of this block.  

 

Monitoring of an I/O is enabled with the following icon: 

 
When you enable test mode for an active dynamic display window, all I/Os listed will be 
connected to the CPU. Enable the "watch" function with a check mark in the "Watch" column 
for the specific I/Os. 
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 Note 

Please note the following: 
• You cannot watch block I/Os if they are not stored in DBs. This also applies, for example, 

to open inputs of FCs and BOPs and to outputs of the data type STRING, 
DATE_AND_TIME, ANY. 

• In test mode and if EN=0 is set, the function blocks (FBs) do not indicate the value of the 
connected source at interconnected inputs. Those interconnected inputs will only display 
the value with which the block was last executed. Note that the value of interconnected 
inputs can change when EN=0 is set to EN=1. This statement also applies to forced 
values. FCs and BOPs, on the other hand, always show the value of the interconnection 
source. 

• If I/Os are registered for testing but are not operable, for example, if they are 
interconnected, the values are shown with a yellow-gray background. 

• You can display the value of a block I/O as a tooltip even if the I/O has not been 
registered for testing. See also: Displaying tooltips using the cursor (Page 321) 

• In test mode, only the status of the first element of a structure is shown in color. The 
status of the other elements is not visible. 

 

Additional information 
You will find more information on this subject in the following sections: 

● How to add and remove I/Os in the watch list (Page 265) 

● How to enable/disable monitoring of dynamic I/O data (Page 266) 

● Configuring I/O (Page 267) 

● The dynamic display window (Page 271) 

● The trend display window (Page 273) 

  

12.2.2 How to add and remove I/Os in the watch list 

Add to watch list        
In edit or test mode (process or laboratory mode), you can add individual block or chart I/Os 
for debugging. Select the I/O followed by the menu command Debug > Add I/O or click the 
following button on the toolbar: 
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When you change to test mode, monitoring is also enabled, i.e., the I/O and its current value 
are displayed on a yellow background. With I/Os that are not OCM-capable, the value is 
shown on a yellow-gray background. If the watch function was previously disabled for this 
block/chart, it will be enabled for all other I/Os that were previously added to the watch list. 

Remove from watch list 
You can remove I/Os from the watch list by selecting the I/O followed by the menu command  
Debug > Remove I/O or by clicking the following button on the toolbar: 

 
This is only possible in test mode and if "watched" is selected.  

As an alternative: 
In edit mode, you can also add and remove I/Os for a specific block/chart. Call the "Object 
Properties" dialog for a selected block and select or deselect the individual I/Os in the 
"Watched" column of the "I/Os" tab. 

 

 Note 

Do not watch too many I/Os at the same time, for this would induce a high communication 
load on the bus and on the CPU. Time monitoring may respond if this load exceeds a certain 
capacity, for example, >500 I/Os in a 1-second watch cycle. The I/O values will be 
temporarily marked as "corrupted". 

 

12.2.3 How to enable/disable monitoring of dynamic I/O data 

Enabling and disabling 
You can enable monitoring of block/chart I/Os in the watch list as follows: 

● Automatically, by enabling the debug mode in "laboratory mode" for all blocks 

● with the menu command Debug > Watch On or by clicking the following button in the 
toolbar: 

 
In laboratory mode, this function applies to all blocks and in process mode only to blocks 
previously selected in the chart. 

● You can stop the monitoring function using the menu command Debug > Watch Off or by 
clicking the following button in the toolbar. 

 
The values of the I/Os are no longer updated In laboratory mode, this applies to all blocks 
and in process mode only to blocks selected in the chart. 
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All I/O values activated in the watch list will be updated in accordance with the watch cycle 
set using the menu command Debug > Test Settings.... 

The values are displayed beside the I/Os according to their data type. They are displayed on 
screen on a colored background.  

 
Blue on white Display of the values in the edit mode (offline) 
Black on yellow, asterisks Display of the values during the transition to  

 dynamic display 
Black on yellow, value Display of the values fetched from the CPU during test mode  
Black on gray-yellow, value Display of values at I/Os without OCM capability read from the CPU 

in test mode 
#### on a red background Display of the values when the dynamically updated values  

requested from the CPU cannot be supplied (disturbance, overload) 

12.2.4 Configuring I/O 

 
You can modify the values of all inputs which are not interconnected if test mode is active. 
For exceptions, refer to the section: Essentials for monitoring block I/Os (Page 264). 
Before the modified value is adopted on the CPU, its validity is checked. 

 

 Note 

Note that the parameters modified in test mode are always written to the CFC database. 
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12.3 Forcing block I/Os 

Brief description  
It may be helpful during commissioning to simulate a variety of values for an interconnection, 
in other words to permanently overwrite the value of an interconnection with a force value. 
While the configuration of an input in test mode is basically possible, it will not lead to the 
desired results because the value will be immediately overwritten by the output of the 
interconnection. For simulation, the interconnections between the blocks must be temporarily 
removed and specified values must be assigned to the corresponding inputs (IN or IN_OUT) 
of these interconnections. Replacing an interconnection with this type of configuration is 
hereafter referred to as "forcing". Forcing involves replacing the value at the block input 
normally supplied by the interconnection with the "forced value". Such forcing can be 
activated and deactivated at the input of the block instance at any time. 

For reasons of performance, not all block inputs are designed for forcing at the outset. This 
prevents too much SCL code being generated by the code generator. The inputs that can be 
forced are set in the configuration of the CFC or in the process object view. If the attributes 
"Add forcing" and "Forcing active" are changed at the input after the program is compiled, 
the program needs to be compiled and loaded again. 

A maximum of 8192 standard and 8192 F I/Os can be forced. 
 

 Note 

If the maximum number of force parameters are registered and downloaded, a download of 
changes must be carried out after the parameters have been deregistered in order to re-
approve the parameters in the CPU as well. Only after the download of changes can new or 
different force parameters be registered. 

 

Settings for forcing 
Forcing is controlled by 4 attributes: 

● "Support forcing" 

● "Add forcing" 

● "Forcing active" 

● "Force value" 

The use of these attributes is enabled with the corresponding check boxes in the SIMATIC 
Manager and CFC. 

In the SIMATIC Manager in the object properties of the chart folder in the "Advanced" tab:  

● "Support forcing" check box This enables the force function and the corresponding 
options in the CFC and the process object view. 



 Testing user programs 
 12.3 Forcing block I/Os 

CFC for SIMATIC S7 (V8.0 SP4) 
Function Manual, 07/2013, A5E03710059-06 269 

In the CFC in the object properties of the block input: 

● "Add forcing" check box This enables or disables "Forcing" at this input. Each change 
requires the program to be compiled and loaded again. This option cannot be changed in 
test mode. 

● "Forcing active" check box When this check box is activated, the value of the 
interconnection is permanently replaced by the force value. The value of interconnection 
becomes active again when forcing is disabled. A change in test mode does not require 
recompiling. 

● "Force value" text box Enter a value here to be applied to the block input if the options 
"Add forcing" and "Forcing active" are enabled. A change in test mode does not require 
recompiling. At an INOUT, the force value is also written to the output of the 
interconnected block. 

Alternative procedure 
If the "Support forcing" option is activated for the chart folder, you can proceed as follows: 

1. You can make settings for multiple block inputs in the CFC. The corresponding columns 
for the force function are available in the "I/Os" tab of the object properties of the block. 

2. In the process object view, you can make the setting for the desired inputs for all blocks in 
the project. The corresponding columns for the force function are available in the 
"Parameters" and "Signals" tabs. 

Display  
The interconnection of the forced input is identified in the CFC chart by means of a colored 
rectangle at the block input.  

● A green rectangle means: "Add forcing" is activated 

● A red rectangle means: "Add forcing" and "Forcing active" are activated. 

 
  Note 

Colored rectangles are only visible for interconnection, as forcing is only possible for 
interconnected parameters. 

 

In test mode, the force value is distinguished from the other dynamic values by a different 
background color. The default setting is "light blue" and can be changed in the "Color 
Settings". Only the first element of a structure is shown in color. Other elements are not 
visible. 

The background color of the force value is identical to the dynamic display of the chart. 
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 Note 

All force settings are lost after a cold restart of the CPU is performed while forcing is 
activated. The settings are retained in the offline program. To restore consistency between 
the offline and online programs, disable "Support forcing" at the chart folder, compile and 
download the data, re-enable "Support forcing" at the chart folder and once again recompile 
and download the data. 

 

Although connections with textual interconnections can be registered for forcing, this does 
not have any effect in test mode. 

Message to WinCC with forcing enabled (only when using an S7-400 CPU) 
In the case of forcing, a new system chart @FRC_CFC is automatically installed with a 
runtime group of the same name in OB1 during compilation. The message block FRC_CFC 
is added to this chart, as well as being added to the OB100. This block triggers an active 
message to WinCC if "Forcing active" is set at a parameter. The block triggers a 
corresponding outgoing message after "Forcing active" was disabled again. The "Active" 
control option of the @FRC_CFC runtime group defines that the block is only executed after 
the "Forcing active" function has changed. 

If forcing is disabled, the block, the system chart, and the runtime group are removed again 
from the program the next time you compile and download. 

Data types 
The following data types can be forced: 

BOOL, BYTE, INT, DINT, REAL, STRUCT, WORD, DWORD, DATE_AND_TIME 

With the STRUCT data type, only the first level of the structure can be forced. Chart 
inputs/outputs cannot be forced. 

 

 Note 

If an EN input or the input of an FC or BOP is registered for forcing, the parameters can be 
set for this input in test mode making it capable of operator control and monitoring. 
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12.4 The dynamic display window 

Dynamic display window 
In debug mode, the values of block and chart I/Os can be displayed dynamically in a 
separate window. This is possible for the basic data types (BO, W, R, etc.) and for elements 
of structures.  

The dynamic display window can be opened and arranged in the CFC editor window along 
with any chart windows and/or the trend display. The window size is adjustable. The content 
(static content only, not the values) of the window is saved when you close it or when the 
CFC editor is exited and restored when you open it the next time. 

You can create and manage any number of dynamic displays for each CPU. Each display 
has its own name that you enter when you create it and that you can modify at any time. In 
the dynamic display window, only one dynamic display can be active at any one time. You 
make your selection in the list box in the header. This bar also contains the buttons for 
creating, deleting and renaming dynamic displays. 

In this window, the values of I/Os from different charts of a CPU can be displayed, monitored 
and changed. The relevant chart does not need to be open. The connection to the CPU must 
be established. 

Use the menu command View > Dynamic Display to open and close the dynamic display 
window. 

Inserting I/Os 
You can add I/Os to the dynamic display in edit or test mode. This function is handled in the 
same way as the one for adding or removing block I/Os in the watch list. 

How to add I/Os of an open chart to the dynamic display window: 

1. Open the required dynamic display in the dynamic display window (relevant only if more 
than one dynamic display was created). 

2. Select the I/O required followed by the menu  
command Test > I/Os > Insert in Dynamic Display. 

3. Drag-and-drop this I/O to the dynamic display window. 

For block I/Os with a structure: Before the I/O is entered in the dynamic display, a dialog box 
appears in which you can select the structure element for the value to be displayed. 

If you want to add all I/Os of a block or nested chart to the dynamic display, you can select 
the block or chart and drag-and-drop it to the dynamic display window.  

I/Os of the data type STRUCT and hidden I/Os will be excluded. 
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Deleting I/Os 
To delete I/Os, select the relevant lines in the dynamic display and delete them using the 
shortcut menu command Delete or by selecting the menu command Edit > Delete. 

 

 Note 

If you delete blocks whose I/Os are contained in a dynamic display or move them out of the 
S7 program, the relevant entries will also be removed from the dynamic display. 

 

Monitoring values 
You can watch block/chart I/O values without opening the relevant charts.  

The value is displayed dynamically on a yellow background according to the set watch cycle 
if: 

● Test mode is enabled. 

● The I/O or element of a structure is registered for monitoring via selection in the "Watch" 
column. 

● Your station is connected to the CPU. 

Corrupted values are indicated with "####", an I/O value that cannot be monitored is 
displayed as "- - - -". 

A forced value is not shown with another background color as yellow (as specified in the 
"Color Settings"). The default setting is "light blue". 

Printing 
You can also print the contents of the dynamic display. Use the menu command Chart > 
Print ... or click the printer symbol in the function bar to print the values that were current 
when you started printing.  

Open chart 
If you select a row in the dynamic display, you can jump to the chart that contains the block 
whose I/O is monitored. Call menu command Edit > Go To > Chart to open the relevant chart 
and to highlight the I/O. 
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12.5 The trend display window 

Trend display 
With the trend display in CFC, you can follow the changes in one or more signals of a CPU 
continuously over time. The trend display can be used by all target systems that support 
normal online operation. A maximum of 12 values can be recorded at one time. 

 

 Note 

If you delete blocks whose I/Os are contained in a trend display or move them out of the S7 
program, the relevant entries will be removed from the trend display. 

 

You can create and manage any number of trend displays for each CPU. Each display has 
its own name that you enter when you create it and that you can modify at any time. In the 
trend display window, only one trend display can be active at any one time. You select trend 
display in the drop-down list in the "Trend Display:" box in the header. This bar also contains 
the buttons for creating, deleting, renaming, and exporting trend displays. 

Use the menu command View > Trend Display to open and close the trend display window. 

● When you open the trend display for the first time, an empty window is displayed with the 
name "Untitled". You can rename this trend display. 

● If there is more than one trend display, the display at the first position in the drop-down 
list is displayed when you open the trend display following a restart of the CFC. 

Operator inputs and settings 
You must assign each I/O for which you wish to record values to one of the 8 trend display 
channels. You can only assign I/Os with numeric data types (BYTE, INT, DINT, WORD, 
DWORD, and REAL) and the Boolean data type (BOOL).  

For each selected channel with numeric data type, you can set the high limit and low limit for 
the display parameter (y axis). Assignments that are no longer required can be deleted for 
the specific channel. 

You can jump from an occupied channel to the chart containing the I/O used. The chart is 
opened and the relevant I/O is selected or, if the I/O is interconnected, it flashes.  

Enter the number of measuring points to be displayed (x axis) for each channel in the edit 
box. The number can be between 10 and 500 and is effective after you click "Apply". The 
number specified here cannot exceed the buffer length (for additional information, see 
"Recording"). 

During the recording, the recording time (start and end) is not displayed but is replaced by 
the text "Recording...". 

Click "Change..." to open the "Recording Parameters" dialog box and specify the following: 

● The number of values to be recorded (buffer length) 

● The acquisition cycle (in seconds) 
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● Recording mode ("Continuous", "Continuous with abort conditions", "One-time") 

● Abort conditions 

The "Start" button is active only in test mode. After starting, the start button changes into a 
“Hold” button and is relabeled accordingly. You can then use it to stop recording at any time. 

Recording window 
After starting, the last recorded trend is deleted and the values acquired now are displayed. 
If the display area is smaller than the total number (buffer size), the window scrolls 
automatically when the right edge of the window is reached so that the latest value is always 
displayed. 

If you record continuously, the display is shifted left when the maximum buffer size is 
reached. 

The display of the entire time axis below the recording window depends on the number of 
values (buffer size) entered for "Recording" and the acquisition cycle.  

The visible time axis and, therefore, the scale, are decided by the sampling values entered 
for "Display" and the acquisition cycle. 

If the buffer length is greater than the number of sampling values for "Display", a slider is 
displayed below the time axis. You can use it to move the visible section in the window. 

Printing 
It is not possible to print the trend display directly. You can, however, export the current trend 
display in a format that can be read in Excel, for example, and then edit the display in this 
program and print it as a table. To export the display, click "Export...". You should check the 
settings for export using the menu command Options > Customize > Export Trend Data. 
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 Change log and ES log 13 
 

The change log 
The change log is opened when an action is performed that needs to be logged if  

● The SIMATIC Logon Service is installed 

● Access protection and the change log are enabled in the SIMATIC Manager . 

The following protected actions are logged: 

● Download to PLC (entire program) 

● Download to PLC (changes only) 

● Activating and deactivating test mode 

● Changing values in test mode 

The change log keeps a record of the user, the changes the user makes, the reasons for the 
change, the time of the change, and the CPU involved.  

If you have not enabled the change log in the SIMATIC Manager , you cannot edit the 
reasons for the change.  

Open the change log in the SIMATIC Manager (with a SIMATIC station selected) with the 
menu command Options > Change Log > Display.... 

The ES log 
In addition to the information of the change log, the actions performed when downloading 
and current time stamps can be logged in CFC/SFC if 

● the ES log is enabled for the current chart folder. 

Activating the ES Log 
To enable the ES log for the current chart folder, proceed as follows: 

1. Select the menu command Object Properties…. 

2. In the dialog box "Properties Chart Folder", "ES Log" tab, select the "ES log active" check 
box.  
The ES log is then activated. 

If protected functions do not need to be logged, for example, within the context of initial 
configuration, you can deactivate the ES log. To do this, reset the "ES log active" check box 
(by removing the check mark).  
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 Note 

Please note the following: 
• If you are not using an S7 target system, check in the target system online help to find out 

whether the ES log is supported by the target system. 
• Note that an activated ES log can only be deactivated on the computer on which 

SIMATIC Logon Service is installed. Reason: Deactivation, as well as activation must 
both be logged. 

• If you copy the program or chart folder with an active ES log to a computer on which the 
SIMATIC logon service is not installed, you will receive an error message while 
downloading or switching to test mode, and the action will not be executed.  
Deactivating the ES log in this case is not possible because the "ES Log" tab is not 
offered in the object properties dialog box for the chart folder. Activation and deactivation 
can only be set in this dialog box. 

• If access protection and the ES log has been activated, the "Compile and Download 
Objects" function of the SIMATIC Manager is interrupted prior to the download to each 
individual CPU by the ES log opening. 

 

Logging in the ES 
Open the log in CFC with the menu command Options > Logs... > Tab: ES Log. 

Each action is recorded in the log in a main line, followed by any additional relevant details of 
the action (for example, a download log). The actions are logged consecutively in 
chronological order.  
When the action "Download entire program" is performed, the ES log is cleared but 
simultaneously saved as a file with a date ID. The archiving action and the file name used 
(including the path) are recorded in the log. 

During download, the comparison stamp of the target system is also written to the log: 

● Last download-relevant change 

● Last compilation 

● Compilation of the loaded program 

When the action "Test mode on" is performed, all subsequent actions resulting in a change 
in values in the CPU are logged. Specifically, these are: 

● In CFC: 

– Configuration of the connections 

– Activation/deactivation of runtime groups 

● In SFC (PCS 7): 

– Configuration of constants in steps 

– Configuration of constants in transitions 

– Configuration of constants in sequencer properties 

The logging includes the value and how it changed (address, old value, new value). 
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 Reading back charts 14 
14.1 How to save parameters (read back) 

Read Back     
You can save (read back) the parameters of all CFC charts contained in the chart folder of 
the active chart whose AS data were, for example, changed via OS operations. This applies 
to, for example, limit values or control parameters.  

 

 Note 

You will automatically be presented with a read-back option before a full download of the 
program is performed. This is aimed at preventing values previously modified by you in 
debug mode or on the OS from being lost unintentionally if all blocks are deleted. You are 
free to accept or reject the read-back option, which is made available in a dialog box. 

Read-back is only possible if no interface changes have been made to block types, i.e., 
provided that a download of changes remains possible. 

 

Procedure 
1. Select the Chart > Read Back... menu command. 

2. Select the source in the "Read Back" dialog box: 

– Select "Program on the CPU" 
to read back the program with the current parameters from the CPU (online block 
folder) into the chart folder. 

– Select "Offline program" 
if you do not have direct access to the CPU and have copied the online block folder 
into the offline block folder of an S7 program in the plant. A browser will then open 
before the read back allowing you to select the respective S7 program with the plant 
data. The values are then read from this source and written to the ES data store. 

You can select the following in the dialog box in both cases: 

● If you want to read back all parameters of the block inputs 

● If you only want to read back the parameters assigned the system attribute for operator 
control and monitoring 
(S7_m_c := "true") or with special identifier for the readback  
(S7_read_back := "true") 

The default setting for the scope is "OCM-capable parameters". 
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General rules 
The following applies regardless of the selected scope: 

● Only in/out and input parameters can be read back. Output parameters cannot be read 
back. 

● The following data types are not included in the readback: 
ANY, ARRAY, POINTER, UDT 

● Inputs, which write to the SFC, are not read back. 

● If a parameter is never to be read back, you must set the attribute S7_read_back = never. 

If a parameter is always to be read back, you must set the attribute S7_read_back = 
always. 

● Entire blocks can be excluded from the readback, for example, BATCH blocks. In this 
case, the block type contains the attribute S7_read_back := 'false'. The attribute can be 
changed at the block instances with the menu command Block Properties > "Read-back 
enabled" Option . 

● Unconfigured inputs (S7_param = "false") are not read back if they have a simple data 
type. S7_param = "false" does not prevent readback for complex data types. 

● Note for H CPU 
When the H CPU is in solo mode, due the failure of a CPU for example, and the CPU has 
switched over, a dialog box opens for online access (in this case: Readback). There you 
can select which CPU should be linked. This dialog box does not appear in redundancy 
mode. 

● Note about downloading HW Config data 
After the download of HW Config data, note that the data is taken from the loading 
memory. Changes performed by operator control and monitoring or in test mode are only 
available in the main memory. The changes in the main memory are lost when the data is 
taken from the loading memory because it is overwritten by the initial values of the 
loading memory. If you have performed a readback before downloading the HW Config 
data to obtain the operator values, you can transfer it to the CPU with a complete 
download in the STOP state. 

Rules for the scope  
The following applies for specifying the scope as "OCM-capable parameters" und 
"Designated parameters": 

● Values from FC inputs are ignored. 

The following applies when specifying the scope as "All parameters": 

● FC inputs interconnected to the chart I/Os are read back. This also applies to chart I/Os 
that are multiply interconnected to block inputs (FB and FC). 
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After the readback 
● A complete compilation is not required after the readback. The program can also continue 

to be downloaded when the CPU is in the RUN state (download of changes). 

● A log is generated and displayed when the readback is completed. You can later open 
the log with the menu command Options > Log > "Read Back" tab. The following is 
displayed in the log, for example: 

– Which I/Os were read back and changed 

– Where problems occurred 



Reading back charts  
14.1 How to save parameters (read back) 

 CFC for SIMATIC S7 (V8.0 SP4) 
280 Function Manual, 07/2013, A5E03710059-06 



 

CFC for SIMATIC S7 (V8.0 SP4) 
Function Manual, 07/2013, A5E03710059-06 281 

 Signal processing 15 
15.1 How to generate module drivers 

Generating module drivers automatically 
PCS 7 provides a signal processing function that automatically generates required module 
drivers, interconnects them and sets their parameters accordingly after you have configured 
the hardware using HW Config and the technological functions in CFC. These module 
drivers are required for diagnosing and reporting errors during signal processing.     

The function is called when you compile the program if the "Generate module drivers" check 
box is enabled (default). If module drivers have already been generated for the project, the 
system checks whether they need to be updated during processing. An update is necessary 
if the hardware configuration has changed in the meantime.  

Generating module drivers manually 
You can also call the function from the SIMATIC Manager . Proceed as follows: 

1. Select the chart folder. 

2. Select the menu command Options > Charts > Generate Module Drivers.... 

In the following we shall refer to the "Generate Module Drivers" function as "driver 
generator". 

The driver and message concept described here is only applicable to CPUs of the S7-400 
family. 

 

 Note 

If the address spaces for digital I/O modules were packed in HW Config ("Pack addresses" 
function), the driver generator can no longer supply the associated blocks with unique 
addresses. To ensure that each module has a defined slot assignment, the addresses must 
not be packed. 

 

Driver and message concept 
An extended driver concept was introduced with CFC version V5.2 + SP1. The driver 
generator can be executed either according to the extended or previous concept. The 
concept actually used for existing projects depends on the signal-processing blocks (CH 
blocks) used. Imported block types are searched and the version of the CH blocks is 
checked. The previous concept will be applied to CH blocks of a version < 2.0.  

You can find additional information about this in the section: Signal processing with driver 
concept up to V5.2 (Page 323). 
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The extended driver concept 
The extended driver concept supports additional modules for ET 200M, ET 200S, ET 200X, 
PA devices, DP/PA couplers, DP/PA links, Y links, DPV0/DPV1 slaves, diagnostic repeaters, 
HART field devices (diagnostics), and redundant I/Os released for PCS 7. This enables the 
precise identification of channel errors in messages. It is also possible to apply configured 
data from SIMATIC PDM.  

The new nested interconnection model (Page 287), module drivers for driver blocks in 
combination with the OB_BEGIN and OB_END blocks for CPU and connection diagnostics 
(instead of MSG_CSF with V5.2) provides the means for runtime optimization. 

This also leaves an opening for future expansions. When implementing user-specific and 
third-party module types, the meta-knowledge for the driver generator can be expanded by 
additional XML files (object and action lists). How to create those files is described in the 
Programming Guide for Creating Driver Blocks for PCS 7 manual. 

 

 Note 

Please note the following: 
• The driver block library must be installed on your PC via Setup. Only this type of 

installation ensures that sufficient meta-knowledge is available for the driver generator. 
You are not permitted to copy the library from one computer to another. 

• You can also use driver blocks from other libraries (for example, user blocks from a 
custom library). In the "Generate Module Drivers" dialog box you can specify an 
additional library. The driver generator then looks in this additional library first for every 
block to be imported. It will only look in the control file (XML file) when it cannot find the 
block in the specified library. 

• If the S7 program contains a block for processing signals (CH_xx, CH_U_xx, PA_xx ), but 
none from one of the PCS 7 libraries, you must specify the version of the driver library 
from where the driver blocks should be imported in the "Generate Module Drivers" dialog 
box. 

• The signal processing blocks (CH_xx, CH_U_xx, PA_xx) must be interconnected with a 
corresponding signal name from the symbol table. This is the only way to ensure that the 
driver generator considers this block during generation of the system charts and 
parameter assignment of the blocks for signal processing. Otherwise, the functionality of 
other signal processing blocks with the same parameter assignment may be affected. 

 

Additional information 
You can find additional information in the following sections: 

● Brief description of blocks used (Page 284) 

● How the "Generate Module Drivers" function works (Page 288) 

● Session model for "Generate Module Drivers" (Page 290) 

● Devices supported by the driver generator (Page 283) 
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15.2 Devices supported by the driver generator 

Table 15- 1  

Catalog folder Supported devices 
SIMATIC 400 All racks and SM modules in the HW Config catalog (profile PCS 7_V52 or 

PCS 7_V60 or PCS 7_V61 or PCS 7_V70 or PCS 7_V71) 
SIMATIC PC station All racks and SM modules in the HW Config catalog (profile PCS 7_V52 or 

PCS 7_V60 or PCS 7_V61 or PCS 7_V70 or PCS 7_V71) 
PROFIBUS DP ET 200iS, ET 200M and ET 200X slaves (as of V6.0 including ET 200S) 

• All racks and SM modules listed in the HW Config catalog (profile 
PCS 7_V52 or PCS 7_V60 or PCS 7_V61 or PCS 7_V70 or PCS 
7_V71) 

• SM modules inserted on the slaves 
• CP and FM modules, with certain restrictions,  

see the list "PCS 7 - Released Modules". 
• With ET 200S, also PM and motor starter, with certain restrictions,  

as of V6.1 also downstream from Y link, 
see the list "PCS 7 - Released Modules". 

Non-redundant standard slaves: For DPV0 slaves, a diagnostic block 
OB_DIAG1 is placed. 
As of V6.0 also for DPV1 slaves. 
As of V6.0, diagnostic blocks are placed for the diagnostic repeaters. 

PROFIBUS PA For all PA slaves acc. to DPV0 (slave family 12 and PA profile 3.0 required) 
configured downstream from a PA link, appropriate PA diagnostic blocks 
are placed (access via the signal-processing blocks PA_xx or CH_U_xx). 
As of V6.0, also PA slaves acc. to DPV0 and DPV1 configured directly on a 
DP master system over a DP/PA coupler. 
PA slaves acc. to DPV1 downstream from a PA link (DPV1) are also not 
processed. 
PA devices with a maximum of 16 allocated slots are supported. 

 

 

 Note 

In addition, device manufacturers may deliver their own diagnostic blocks with corresponding 
XML files, which are then processed by the driver generator. 
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15.3 Brief description of blocks used 

Block Types 
The following block types are used, which separate the hardware and software configuration: 

● The user inserts channel-specific blocks (CH/PA blocks) into the CFC chart and 
interconnects those entries to corresponding signal names from the symbol table. These 
blocks and system functions are always included in the same process, since the blocks 
are a part of system functions. 

The driver block library provides the following types of channel blocks for signal 
processing: 

– Standard channel blocks: 
CH_AI, CH_AO, CH_DI, CH_DO. 
These blocks are only used to process signals of the S7-300/400 SM modules. Use 
these standard blocks if you want to optimize memory utilization and runtime and do 
not need to process any PA devices. 

– Universal channel blocks: 
CH_U_AI, CH_U_AO, CH_U_DI, CH_U_DO. 
These blocks are used for processing the signals of S7-300 / 400 SM modules or PA 
field devices. The advantage of these blocks is that you can create CFC charts 
irrespective of the hardware I/O to be used later. A disadvantage is an increase of the 
load on memory and cycle times. 

– PA channel blocks: 
PA_AI, PA_AO, PA_DI, PA_DO, PA_TOT, 
These blocks are designed especially for use with PA field devices. They are used 
primarily where the special features of these devices are required. In contrast to CH 
blocks, the PA channel blocks process not only the actual signal but also all variables, 
according to the desired device configuration selected in the hardware configuration. 

– Special channel blocks 
CH_CNT, CH_CNT1, CH_MS. 
These blocks are required for special applications such as controlling and reading the 
counter or frequency values of FM 350-1/-2 modules and 8-DI NAMUR modules of the 
ET 200iSP, as well as for signal processing of ET 200S motor starter modules. 

– Standard channel blocks in the Advanced Process Library: 

Pcs7AnIn, Pcs7AnOu, Pcs7Diln, Pcs7DiOu, Pcs7DilT 

These blocks are used only for processing the signals of S7-300/400 SM modules. 
Use these standard blocks if you want to optimize memory and runtime utilization and 
do not need to process any PA devices. 
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– FF/PA channel blocks in the Advanced Process Library: 

FbAnIn, FbAnOu, FbDiIn, FbDiOu 

These blocks are specifically intended for use with PA field devices and the 
PROFIBUS 3.0 class A and B with FF field devices. You should use these blocks if 
you want to make use of the special features of these devices. In contrast to standard 
channel blocks, PA channel blocks not only process the signal itself but also all 
variables, according to the desired device configuration selected in the hardware 
configuration. 

For additional information about the functions and functionality of CH and PA blocks, refer 
to the context-sensitive help (<F1>) for each block. 

● In the extended driver design, MSG_CSF was replaced by the OB_BEGIN block for 
standard CPUs and H CPUs. This function monitors the status of the (redundant) CPU 
and the DP master systems. It fetches OB startup information (see figure: Interconnection 
model, module drivers (Page 287)), determines the geographical address based on the 
logical address and passes this information to the output (CPU_DIAG structure). All driver 
blocks are interconnected, using this structure. OB_END is installed at the end of the 
sequencer of all OBs and resets startup information.  
OB_BEGIN also performs connection diagnostics, for example. Process control 
enclosures, which were monitored with MSG_CSF, are no longer monitored. This function 
must be implemented in a separate block as required. 

● Using OB 70 and OB 86, the SUBNET blocks analyze the status of the DP master 
systems and return this information (linked to the CPU monitoring) as higher-ranking 
errors to the RACK blocks. 

● The RACK block monitors the status of a rack, DP/PA or Y link DP V1 and reports the 
error events.  
In order to prevent all MOD blocks from reporting a module failure if a rack fails, a RACK 
block in each rack takes over the reporting function. The MOD blocks recognize in OB 86 
that the event has been processed and do not report. 

● Using diagnostic blocks: 

– MOD blocks are used to monitor SM modules, motor starter modules and HART/PA 
field devices. They provide the channel-specific value status for the signal-processing 
blocks (1 = good, 0 = bad). ALARM_8P is used to report these events. Errors 
originating from a higher level, for example, DP master system diagnostics, are 
entered in the RACK block. 

– DP/PA slaves are monitored with the PADP_L0x (V0) or PADP_L10 (V1) blocks, PA 
slaves with the DPAY_V0 or DPAY_V1 blocks. 

● The PO_UPDAT block ensures that the startup values that were written to the process 
image by the CH_AO and CH_DO blocks are sent to the output modules when the CPU 
is restarted (OB 100). This means that these values are effective immediately when the 
CPU changes to RUN. 

For additional information on the functions, functionality and message capability of the 
blocks, refer to the context-sensitive help (<F1>) for the block. 
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Additional information 
You will find additional information in the following sections: 

How the "Generate Module Drivers" function works (Page 288) 

Session model for "Generate Module Drivers" (Page 290) 

Devices supported by the driver generator (Page 283) 
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15.4 Interconnection model, module drivers 
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15.5 How the "Generate Module Drivers" function works 

How it works 
This function automatically generates system charts and inserts the diagnostic blocks (MOD 
or PADP/DPAY blocks), the RACK and SUBNET blocks, OB_BEGIN and OB_END, and the 
block for outputting the process image PO_UPDATE. System charts are assigned the name 
"@.....".    

Blocks inserted by the driver generator are assigned the name of the module assigned. 
Process control messages of the WinCC message system are assigned the name of their 
origin. In this case, this is the block name and thus the name of the monitored module.  

Tip: You can assign a specific text to process control messages by setting a corresponding 
module name in HW Config. This text then becomes part of the process control message. 

The blocks are imported from the library when you initially generate module drivers and the 
CFC data management does not yet contain any driver blocks (including OB_BEGIN and 
OB_END). The block search starts at the path defined in the "Settings – Generate Block 
Drivers" dialog box. If a block is not found in this path, the searches extendss to the default 
paths defined during setup of the PCS 7 libraries. 

 

 Note 

Please note the following: 
• Objects identified by the "@" character should not be modified by the user, but should 

only be manipulated using the “Generate Module Drivers” function. Accordingly, the 
MOD/PADP/DPAY, RACK and SUBNET blocks should not be inserted manually. 

• Driver blocks created by the user must be inserted from the block catalog. Copied "@" 
blocks will be deleted after the next call of the "Generate Module Drivers" function, since 
the driver generator does not assign their ID. 

 

The MOD/PADP/DPAY blocks are installed in the acyclic error OBs as well as in OB 1. This 
ensures that they are also executed following an online download of changes (since OB 100 
is no longer executed in this case). The runtime group is assigned a reduction ratio of 16. 
The blocks will be called only every 16th time OB 1 is executed, in order to avoid 
unnecessary load on the CPU. 

Following driver generator startup, the runtime groups in OB 1 will be assigned the reduction 
ratio 16. User-specific changes will be overwritten in order to prevent inconsistency during 
the program cycle. 

The system verifies the existence of the PO_UPDAT block in CFC. If it does not exist, it is 
imported from the library and inserted in the system chart. It is installed in the run sequence 
at the last position in OB 100. If the block already exists, the system verifies that it is installed 
in OB 100 after the driver blocks and that it is deleted from all other OBs. 

The system verifies the existence of OB_BEGIN/OB_END blocks in CFC. If not found, the 
system will import the blocks from the library and insert them into the chart and run 
sequence. 
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Process image partitions 
The CH/PA blocks receive and output their signals via the process image (PI). 

The PO_UPDAT block ensures that startup values written to the process image by the 
CH_AO and CH_DO blocks are transferred to the output modules during a CPU restart and 
that they take effect immediately.  

The OB 1 PI is updated at the cycle control point (no constant scan cycle time). You can 
achieve a constant scan time by using process image partitions (PIP). PIP update times are 
configured in HW Config by assigning a PIP to an OB. The PIP update covers the inputs at 
the start of OB execution and the outputs at the end of OB execution. Process image 
partitions are module-related, i.e., the fastest signal determines the update of all module 
signals. 

Implementing blocks of new versions 
The installation of a new PCS 7 library containing modified block types does not initially 
affect used blocks. Online downloads of changes might not be possible any more. 

If you want to update blocks, proceed as follows:  

● Delete all @ system charts from the chart folder. 

● Select the menu command Options > Block Types…. 

● Select the relevant blocks in the “Chart folder” window. 

● Click "Clean Up". 
The blocks are deleted. 

● Call the “Generate Module Drivers” function in the component view of SIMATIC Manager.  
New system charts will be created. The driver blocks of the new library will be installed, 
since they are now no longer available in the CFC. The library must be entered in the 
“Customize” dialog box. 

Additional information 
You can find additional information in the following sections: 

How to generate module drivers (Page 281) 

Session model for "Generate Module Drivers" (Page 290) 

Interconnection model, module drivers (Page 287) 

Devices supported by the driver generator (Page 283) 
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15.6 Session model for "Generate Module Drivers" 

 
Configuring the session model for "Generate Module Drivers": 

● Configure the hardware and assigns symbolic names to the I/O signals. HW Config will 
write the signal names directly to the symbol table: 

– Select module. 

– Select the menu command Edit > Symbols… in HW Config. 

 
  Note 

If a message appears telling you that an attempt was made to enter an illegal symbolic 
address, it may be that the size of the process image configured in HW Config is too 
small. The default size for some CPUs is 512, for example. You will find the settings 
for the process image in the CPU properties on the "Cycle/Clock Memory" tab. If you 
insert analog inputs and outputs, their addresses always begin at 512 and are thus no 
longer located in the process image. If you now assign symbolic names, "PIW" or 
"PQW" will be entered as the address in the symbol table. As a result, the 
inputs/outputs can no longer be linked with the CH_AI/CH_AO blocks. 

Remedy 1: 
Change the initial addresses of the individual analog modules in the object properties 
of the module on the "Addresses" tab so that the address range does not exceed the 
size of the process image. 

Remedy 2: 
If sufficient work memory exists, open the object properties of the CPU, "Cycle/Clock 
Memory" tab, and change the size of the I/O process image. 

 

● Configure the technological functions in CFC and uses the CH_ blocks (or PA_ blocks) 
that are interconnected to the signal names taken from the symbol table: 

– Select the menu command Insert > Interconnection to Address.... 

● In the SIMATIC Manager , call the driver generator with the menu command Options > 
Charts > Generate Module Drivers... to generate, interconnect and configure all module 
drivers. The following steps are performed automatically: 

– In the first step the function identifies all channel blocks (_AI, _AO, _DI, _DO) used in 
the CFC charts, and in the next step all I/Os, for example, Value, O_SP, I_OUT_D, 
that are interconnected to the symbols of the I/O channels configured in HW Config. 
PA_AO/PA_DO blocks may require the interconnection of several symbols. Only a 
"leading" symbol needs to be interconnected in this case, the others are automatically 
identified and interconnected via the driver generator. By using the symbolic 
addresses of the symbol table, the corresponding module and channel are identified in 
hardware configuration data. Based on the module type, the corresponding diagnostic 
block type (MOD or PADP) is identified and in the system chart a block instance will 
be created for each I/O module. 
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– The parameters required for the diagnostic blocks are obtained from HW Config data 
and entered in the block instances, as well as in the SUBNET block for optimizing 
runtime in error OBs. 

– The channel-specific output at the MOD/PADP block is interconnected to the 
corresponding input at the CH block. If the "value status" module is supported, the 
address of the value status is obtained and interconnected to the CH/PA block. 

Changes made in configuration data (hardware or software) must be processed by the driver 
generator. Existing driver blocks will not be deleted and recreated, but are rather assigned 
new parameters. Blocks that are no longer required will be deleted, except for user blocks, 
and additional blocks are created as required, using blocks imported from the CFC data 
management instead of the library blocks. 
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 Creating block types in CFC 16 
 

General 
You can either purchase the block types you use in CFC in the form of block libraries or 
create them yourself. You can also expand the existing pool of blocks.    

In CFC, block types can only be created by compiling CFC charts. If you want to create your 
own blocks with STL/SCL, you will find information in the "PCS 7 Blocks" programming 
guide. 

A CFC chart can be compiled for further use (with chart I/Os) as block type. 

You create a CFC chart, interconnect the blocks and create the chart I/Os for selected block 
I/Os. 

Once the chart has been compiled, the block type is stored inside the block folder. By 
inserting it in the chart (from the S7 folder of the CFC block catalog) or by importing it using 
the menu command Options > Block types..., you can include the block type in the chart 
folder. In the block catalog, the block type is displayed under the family name specified for 
compilation. 

The block type is managed via the object name FB xxx. 

Make sure that the FB number is in the range supported by the CPUs on which you want the 
block to run. You can find information on these ranges in reference manual Automation 
System S7-400, Module Data. Example: No. of FBs = 512. The highest possible block 
number is thus FB 511. 

You can assign a symbolic name to the block. This name will be entered automatically in the 
symbol table. The header name and symbolic name of PCS 7 blocks are identical. 

Restrictions and characteristics 
Before the CFC chart can be compiled as block type, it must satisfy the following conditions: 

● The chart cannot contain nested charts, but may contain other block types created with 
CFC. 

● Blocks can only be installed once manually in the run sequence, in other words, once 
outside the task assigned the "S7_tasklist" system attribute. 

● All blocks have to be installed manually in the same task. All blocks of the chart to be 
compiled have to follow one another consecutively without gaps. There should be no 
blocks of other charts between them. 

● The blocks cannot be installed in runtime groups. 

● It is not possible to access the blocks in the chart externally, for example, using 
faceplates in WinCC. The blocks are initialized during runtime. 

● The results (values) of the blocks in the chart are only applied to the outputs of the 
generated block type during runtime and after all blocks have been processed. Values 
are applied to the outputs even if ENO = FALSE is set. 
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● There cannot be any cross-connections with elements in the chart that is being compiled. 
Cross-connections of this kind are interconnections from another chart that bypass chart 
I/Os. 

● The chart I/Os should not have an EN input since this is generated automatically. 

● Signal inputs of the blocks have to be applied to the chart I/Os. Before signal inputs are 
assigned, the relevant chart I/Os have to be unhidden. The chart I/O inherits the block I/O 
attributes. Once the signal inputs have been assigned, the chart I/O can be hidden again. 

● The interconnection of an ENO I/O defined at the chart I/Os is converted accordingly. If 
no ENO is defined, the ENO I/O of the block type provides the result of logical AND 
operations at the I/Os of all blocks called in the block type. 

● The "S7_tasklist" system attribute represents the complete set of all task list attributes of 
the internal blocks. 

● If a chart I/O is not connected to the I/O of a block contained in the chart, a warning is 
displayed during compilation.  
If one block I/O with the attribute S7_m_c is connected to a chart I/O, WinCC operations 
affect the same variable, regardless of whether the block I/O or the chart I/O was 
manipulated.  
In cases where several block I/Os are interconnected with a chart I/O, they will be 
provided with values during runtime. WinCC operations will be immediately overwritten, 
thereby rendering them ineffective. During compilation, this is recognized and a warning 
is displayed. 
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 Documenting Programs 17 
17.1 Printing charts, dynamic display, I/Os 

17.1.1 How to print charts 

Printing a chart 
To print a chart, select the menu command Chart > Print. 
The active chart is printed on your default printer. 

Options 
Print options are available for different printouts. They also apply when printing from the 
SIMATIC Manager using the menu command File > Print > Object Content. 

Print what 
You can set the following print ranges: 

● Current sheet  
Prints the current sheet. 

● Current chart partition 
Prints only the overview or sheets or both the overview and sheets of the current chart 
partition, depending on your selection. 

● All chart partitions 
Prints only the overview, the sheets or both the overview and the sheets of all chart 
partitions of the current chart, depending on your setting. 

 

If the current chart contains chart I/Os, you can select the following print scope: 

● Chart with chart I/Os 

● Chart without chart I/Os 

● Chart I/Os only 

If you select print chart I/Os, these will be printed in a table on a separate page. This table 
contains all relevant information, such as data type, initial value or "Invisible". Chart I/O 
information (columns) will always be printed, regardless of which columns are visible in the 
chart I/O window. If there are too many I/Os to fit on one page, additional pages are printed. 

The "Overview" and "Sheets" options let you decide whether to print only the overview of the 
chart, only the sheets or both (depending on the setting for the chart I/Os). These options are 
disabled when the option "Chart I/Os only" is selected. 
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Only sheets with contents will be printed. Since at least one chart page will be printed for a 
chart with or without chart I/Os, an empty sheet will also be printed if the chart consists only 
of empty sheets.  

When you print from the SIMATIC Manager , the lower-level charts, in other words the 
nested charts of the top chart, are also printed (default). If you do not want to print the lower-
level charts, deselect the "Include nested charts (from the SIMATIC Manager)" check box.  

 

 Note 

The option only applies to the SIMATIC Manager. When printing from CFC, only the open 
chart will be printed, regardless of this setting. This can also be a nested chart. 

 

Click "Options" in this dialog box to display additional print options. Regardless of the current 
chart layout, this dialog box lets you customize the print layout for addresses, I/Os and block 
header information. You change the current layout in the chart with the menu command 
Options > Customize > Layout. 

Page setup 
With the menu command Chart > Page Setup..., you can customize the layout. You specify 
the paper format for the printer and the page margins.  

Print preview 
The menu command Chart > Print Preview displays a WYSIWYG view of the chart (sheet or 
overview). Click "Close" or hit <Esc> to return to the standard display. 

17.1.2 Creating footers 

Introduction 
The DOCPRO add-on package can be used for printing a CFC chart, along with footer data. 
In the footer data, a distinction is made between global data and chart-specific local data. 

You can enter global data for the project using DOCPRO or SIMATIC Manager ; local chart-
specific data must be input via the CFC editor. Note that chart-specific data will overwrite the 
global data in the particular chart. 

You can also input chart-specific data even if you have not installed the DOCPRO add-on 
package. Although these data are saved, they will not be available until you have installed 
DOCPRO. 
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Keywords in footers 
In the global footers, you can enter keywords that will be replaced by current texts in the 
printout. Below, you can see the available keywords and their meaning: 

 
Keyword Designation Meaning DOCPRO 

key 
$$CN$$ Chart name Chart name (also nested chart),  

as entered in the chart properties 
 
$54 

$$CC$$ Chart comment Comment text  
as entered in the properties. 

 
$60 

$$A$$ Author Name 
as entered in the chart properties 

 
$55 

$$DC$$ Created on Date 
as entered in the chart properties 

 
$56 

$$DM$$ Last modification on Date 
as entered in the chart properties 

 
$57 

--------- --------- --------- --------- 
$$CH$$ Project path Path, as entered in the chart properties 
$$PP$$ Storage location  

of project 
Physical storage location, as entered in the chart properties 

In new projects generated under DOCPRO V5.1, you can define the keywords using 
DOCPRO keywords. This means you do not need to enter the keywords in the footers of the 
CFC. The footers are, nevertheless, still supported. You still have to enter the texts directly 
for older projects. 

 

 Note 

If keywords entered in CFC also specify other print objects (for example, STL blocks or the 
table of contents of DOCPRO), the printed copy will display the actual keywords, rather than 
their substitutes, for these objects. This problem no longer exists if you use DOCPRO keys. 

 

When using DOCPRO keys, you must change the standard layout in DOCPRO. Open the 
"Modify layout" dialog box to replace the default footers with chart-specific footers. You can 
find information on this in the DOCPRO Online Help or in the manual DOCPRO: Creating 
Documentation in Conformance with Standards. 

You must continue to use the keys for "project path" and "Location of the project" (in the 
lower part of the table) because there are no DOCPRO keys for them.  

Footer data for a specific chart 
You enter footer data for a specific chart as follows: 

1. Select the menu command Chart > Footers…. 

A dialog box that contains several tabs ("Part 1" to "Part 4" and "Free Fields") opens. 

2. Input corresponding entries in the active fields, for example, the type of document, date 
when created, document number, data relating to modifications, free texts. 
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Sheet numbers in the footer 
The footer includes a fixed field for continuous page numbering of the print job. For jobs 
consisting of up to 99 pages, both the consecutive number and the total number of pages is 
shown, for example, 2/14. 

If the job covers more than 99 pages, the total number of pages is not shown but the page 
number is appended a "+" character. This indicates that there are more pages to come, for 
example, 1+…7+. The number of the last page is appended a "-" character, for example, 
127-. 

17.1.3 How to print the dynamic display 

Procedure 
You can print the contents of the (active) dynamic display with the normal print function using 
the menu command Chart > Print....  

The values currently displayed when printing is triggered will be printed. 

The column widths are set to optimum values for printing. The printout is in landscape format 
(default), but can be temporarily changed in the printer setup. 

17.1.4 How to print block/chart I/Os 

 
You can print the table of I/Os from the "Properties – Block" and " Properties – Chart" dialog 
boxes. The "Print..." button is available on the "General" and "I/O" tabs. This button always 
prints the table of the I/Os. 

Procedure 
1. Select the “General” or “I/Os” tab. 

2. Click "Print…". 

The column widths are set to optimum values for printing. The printout is in landscape format 
(default), but can be temporarily changed in the printer setup. 
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17.2 Printing chart reference data 

 
Along with the printed charts, the chart reference data provide you with complete 
documentation of your configuration structure. 

Refer to the online help for chart reference data for additional information under: What you 
should know about chart reference data 
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17.3 How to display logs 

Introduction 
The log files do not belong to the complete documentation of the configuration structure. 
They can, however, provide important information during configuration and commissioning if 
errors occur or if specific executed operations are to be checked.    

Procedure 
1. Select the menu command Options > Logs….  

A dialog box with several tabs opens. The tabs are only available when the 
corresponding functions have been previously executed. 

2. Click "Print". 
The messages are printed. 

You can select the layout with the "Page Setup" button.  

The different dialog box tabs are described below. 

The "Compile" tab 
This tab lists the messages that occurred during compilation, including those returned by the 
compiler, for example, if only the S7 program exists in the project and there is not yet a 
station: "W: The program is not assigned to a defined CPU. The system will not verify that 
the CPU is ready to receive the program." 

CFC V5.2 and higher evaluates the block reference lists during compilation. If the program 
uses blocks that contain no reference data (blocks compiled in versions earlier than STEP 7 
V5.0 + SP3 or SCL V5.0 + SP3), the check cannot be completed and an error message is 
output, 
for example, "Local data requirements cannot be determined". 

 

 Note 

CFC version < V5.2 does not output this warning message, in other words, the user had to 
check local data/memory requirements. If projects containing old blocks without reference 
lists are edited with a CFC version >= V5.2, the user has to carry out this check, as was 
previously the case. This prevents excessive local data or memory requirements from 
stopping the CPU when changes are being downloaded.  

 

Blocks without reference lists are indicated in the CFC chart reference data. To display the 
chart reference data, select the menu command Options > Chart Reference Data 

 
Select the block call hierarchy in the chart reference data window with the menu command 
View > Block Call Hierarchy 
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Blocks that do not have a reference list are indicated in this hierarchy as follows:  
 No call information 

Remedy:Use the latest block library (CFC Library V5.1/PCS 7 Library V5.1 or higher) or 
compile blocks you have created yourself using a compiler >= V5.0 + SP3. 

The "Check Consistency" tab 
This tab lists the messages returned by the consistency check. Example: "The immediate 
successor to the control block SFC_CTRL in the run sequence of OB 31 is not the assigned 
SFC chart". 

The "Download" tab 
This tab lists the messages that occurred during a download, for example, if no errors 
occurred during the download: "0 error(s) and 0 warning(s) found". 

For warnings due to missing block reference lists, see the description of the "Compile" tab 
above. 

The "Block Types" tab 
This tab displays the block type log that shows the results of a block type verification (when 
importing). The log might contain, for example "E: <FB46 OP_A_LIM> cannot be deleted. 
There are still blocks of this type in the charts". 

The "Make Textual Interconnections" tab 
This tab displays the textual interconnections closed by this action and error messages for 
textual interconnections that could not be closed for one reason or another.  

The "Module Driver" tab  
This tab lists all messages generated when the module drivers were created (SIMATIC 
Manager > Options > Charts > Generate Module Drivers...). 

Example: "A: No signal-processing blocks found. Module drivers were not generated." 

"ES Log" tab 
All actions relevant for validation are logged in this tab when the SIMATIC Logon Service is 
installed. 

Each action is logged consecutively in chronological order. The most recent action appears 
in the first line.  

When the action "Download entire program" is performed, the change log is cleared but 
simultaneously saved as a file with a date ID. The archiving action and the file name used, 
including the path, are recorded in the log. 



Documenting Programs  
17.3 How to display logs 

 CFC for SIMATIC S7 (V8.0 SP4) 
302 Function Manual, 07/2013, A5E03710059-06 

For the action "Start test mode", all subsequent actions resulting in a change (of value) in the 
CPU are logged. In the CFC this specifically includes new parameters for the I/Os and the 
activation or deactivation of runtime groups. 

The "Read Back" tab 
This tab logs all error and warning events, as well as actions taken during read back. This 
can be, for example, modified I/O values that were read back. These are parameter values 
to be transferred to the chart folder after they were modified in the CPU. 

The "Step Processing" tab 
After verifying the SFC runtime behavior with the menu command Options > Check Step 
Processing, this tab lists the steps that use the same address in the terminating action of one 
step and in the initializing action or processing action of the next step. The log shows how 
many SFC charts were checked and how many accesses were found. It also shows the SFC 
charts with unchanged runtime behavior. 

The "Convert Format" tab 
After converting charts of older versions to V5.1 or higher, the charts that no longer have the 
same properties are listed here. These include, for example, SFC charts that had the 
attributes "reduction ratio" and "phase offset" in the old version. The information includes the 
insertion location (task) and the values for the reduction ratio and phase offset for every 
chart affected.  
Example: "SFC1: Task OB 35 reduction ratio 4 phase offset 2" 

The "Details" button 
Details are available for specific log messages.  

Select the required entry and click "Details". This button is disabled if the message does not 
contain any information.  
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 Appendix 18 
18.1 Data types for S7 

18.1.1 ANY, A 

Table 18- 1  

Abb. Keyword,  
Type 

Range of values 
from ... to 

Sample  
entries 

Display in the  
chart 

A ANY; pointer to  
 data element 

only as interconnection to  
block input or shared  
address 

You will find information in the section:  
Interconnection rules for data types A, DT, 
S, and ST (Page 140) 

 

 

 Note 

ANY I/Os, for example, SD_1 for SFB 12/BSEND, can also be interconnected with a 
complete data block (shared address, absolute, for example -> DB1, or symbolic). The 
complete length of the DB is transferred. 

 

18.1.2 ARRAY 
An array consists of a grouped data type with up to 6 dimensions.   

CFC does not support this data type. 

This means that user-specific blocks that contain this data type will be rejected with an error 
message during an import to the CFC database. 

18.1.3 BLOCK_DB, DB 

Table 18- 2  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

DB BLOCK_DB, number  
 of a data block (DB) 

0... 65535  
(number depends on target 
system) 

123 123 
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18.1.4 BLOCK_FB, FB 

Table 18- 3  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

FB BLOCK_FB, number  
of a function  
block (FB) 

0... 65535 (number 
depends on target system) 

123 123 

18.1.5 BLOCK_FC, FC 

Table 18- 4  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

FC BLOCK_FC, number 
of  
 a function (FC) 

0... 65535 (number  
depends on target 
system) 

123 123 

18.1.6 BOOL, BO 

Table 18- 5  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

BO BOOL; logical 
number 

0-1 0;  
1;  
False;  
True;  
F;  
T 

0;  
1; 
0; 
1; 
0; 
1 

18.1.7 BYTE, BY 

Table 18- 6  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

BY BYTE; Sequence of 
8 bits 

0... 255, (0... FF) 1C;  
16#2a;  
10#123;  
2#10110011 

16#1C;  
16#2A;  
16#7B 
16#B3 
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18.1.8 CHAR, C 

Table 18- 7  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

C CHAR; individual 
character 

Depending on the configured 
Windows character set, "Single 
byte" or "Multibyte" 

"A";  
"a";  
"0";  
"%" 
A;  
a;  
0;  
% 

"A";  
"a";  
"0";  
"%" 
"A";  
"a";  
"0";  
"%" 

18.1.9 COUNTER, CR 

Table 18- 8  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

CR COUNTER; 
number  
 of an S7 counter 

0... 65535  
(number depends on target 
system) 

123 123 

18.1.10 DATE, D 

Table 18- 9  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

D DATE; Date 1990-1-1... 
2168-12-31 

1996-04-29 
2000-01-03 

96-04-29 
00-01-03 

18.1.11 DATE AND TIME, DT 

Table 18- 10  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

DT DATE_AND_TIM
E  
or DT; date and 
time 

1990-1-1... 
2168-12-31-23:59:59.999 

1996-03-16-
23:56:19.123 

96-03-16:23:56:19 
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18.1.12 DINT, DI 

Table 18- 11  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

DI DINT; double 
integer 

-2147483648...  
2147483647 

12345;  
-17385267;  
16#3BC9;  
10#123456789; 
2#1011010101010101 

12345;  
-17385267; 
15305;  
123456789 
46421 

18.1.13 DWORD, DW 

Table 18- 12  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

DW DWORD; 
sequence of  
32 bits 

0... 4294967295,  
(0 ... FFFFFFFF) 

23AC43BF;  
16#1a2b3c4d; 
10#1234567890; 
2#10010010010010010010 

16#23AC43BF; 
16#1A2B3C4D 
16#499602D2 
16#92492 

18.1.14 INT, I 

Table 18- 13  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

I INT; integer -32768... 32767 4099;  
-30123;  
16#1AC5;  
10#12345;  
2#0010110010101110 

4099;  
-30123;  
6853; 
12345; 
11438 

18.1.15 POINTER, P 

Table 18- 14  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

P POINTER; pointer 
to  
memory area 

As interconnection only - - - - 
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 Note 

When supplying the data type POINTER, certain restrictions and rules must be kept to. 
Please read the online help of SCL on the POINTER data type. As a general rule, POINTER 
can be interconnected with any other data type except for POINTER and ANY. If the 
interconnection is not permitted, you receive a message when you compile the program. 

 

18.1.16 REAL, R 

Description 
 
Abb. Keyword,  

Type 
Value range (normalized) 
from ... to 

Sample  
entries 

Display in the  
chart 

R REAL; floating-
point number 

-3.402823e+38... -1,175495e-38... 
 0.0... 1.175495e-38... 
3.402823e+38 

22.78; 
-
1234522.456789
;  
-3.456e-3; 
2.573e19 

2.278e1;  
-1.23452e+6; 
-3.456e-3;  
2.573e19 

 

Note 
STEP 7 maps the data type REAL according to the IEEE standard (to 32-bit short real). Due 
to the self-restriction, only normalized coding of the numbers is used (see above). 

This standard reserves the following additional special bit patterns. 

● Not normalized coding with values below the smallest number of the normalized range (-
1.175495e-38 < x < 0.0 and 0.0 < x < 1.175495e-38) 

● Infinite positive values (+ infinite) 

● Infinite negative values (- infinite) 

● Illegal bit patterns for numbers, so-called NaN (Not a Number) 

When using the data type REAL in CFC, the display/evaluation of online values, for example, 
dynamic update of values in test mode or when reading back from the CPU, is always based 
on a calculation with special bit patterns. CFC thus handles those values as follows: 

 
Value Dynamic display  

 
Activation during  
readback 

Normalized numbers Floating-point number Yes 
Not normalized numbers +0.0 or -0.0 No 
+ infinite #+Inf No 
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Value Dynamic display  
 

Activation during  
readback 

- infinite #-INF No 
"Not a Number" #NaN No 

18.1.17 S5TIME, T5 

Table 18- 15  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

T5 S5TIME; 
duration  
in S5 format 

0h_0m_0s... 2h_46m_30s; 
0... 9990ms in 10ms-, 
100ms... 99900ms in 
100ms-  
1s... 999s in 1s- and  
10s... 9990s in 10s-
Schritten 

1h_30m_0s;  
1234567ms; 
2h; 32m_5s 

1h_30m_0s;  
20m_34s_567ms 
2h; 32m_5s 

18.1.18 STRING, S 

Table 18- 16  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

W STRING;  
character string 

Depending of the configured 
Windows character set, "Single 
byte" or "Multibyte" (at least 
127 characters) 

"Batch_127"; 
This is a longer text. 

"Batch_127"; 
"This is a lon»" 

18.1.19 STRING[N], SN 

Table 18- 17  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

SN STRING[N];  
character string 

Depending of the configured 
Windows character set, "Single 
byte" or "Multibyte" (at least 
127 characters) 

"Batch_127"; 
This is a longer text. 

"Batch_127"; 
"This is a lon»" 



 Appendix 
  

CFC for SIMATIC S7 (V8.0 SP4) 
Function Manual, 07/2013, A5E03710059-06 309 

18.1.20 STRUCT, ST 

Table 18- 18  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

ST STRUCT;  - - - - Name and value of  
the first elementary  
data type 

18.1.21 TIME, TI 

Table 18- 19  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

TI TIME; duration -
24d_20h_31m_23s_647ms
...  
24d_20h_31m_23s_647ms 
(-2147483647... 
2147483647ms) 

12d_12h_12m_34s_789
ms; 
123456789ms;  
2h;  
-32m_5s 

12d_12h_12m_34s
; 
3h_25m_45s_678
ms 
2h;  
-32m_5s 

18.1.22 TIMER, TR 

Table 18- 20  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

TR TIMER; number  
of an S7 timer 

0... 65535 (number depends on  
target system) 

123 123 

18.1.23 TIME OF DAY, T 

Table 18- 21  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

T TIME_OF_DAY or  
TOD; time of day 

0:0:0.0... 
23:59:59.999 

12:45:18.012 12:45:18.012 
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18.1.24 WORD, W 

Table 18- 22  

Abb. Keyword,  
Type 

Value range 
from ... to 

Sample  
entries 

Display in the  
chart 

W WORD; 
sequence of  
16 bits 

0... 65535, (0... FFFF) 16#bAc1;  
10#12345 
2#1000011101011010 

16#BAC1; 
16#3039 
16#875A 
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18.2 References 

18.2.1 Synchronizing AS-wide interconnections 

Synchronizing AS-wide interconnections 
This menu command can be used to determine all one-sided AS-wide interconnections.  

● If the interconnection partner is available, the one-sided AS-wide interconnections 
between these two partners are deleted. 

● If one of the interconnection partners is not available, the command has no effect on the 
interconnections between the two partners and the one-sided AS-wide interconnections 
are retained. 

After the command has been executed, a log is displayed showing the deleted and 
remaining one-sided AS-wide interconnections. 

 

 Note 

If you have already manually deleted the AS-wide interconnections in the unavailable 
partner, you nevertheless have to use the command to synchronize the internal time stamp. 

 

18.2.2 Example of reduction ratio and phase offset 
The following graphic shows an example for the phase offset and reduction ratio in the clock 
cycle.      
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18.2.3 Display of the runtime properties box 

 
The runtime properties box is displayed in the block header with a dark green background 
(default). Exception: The block that is intended as the "Predecessor for Insertion Position" is 
displayed with a light green background. 

 

 
You can find additional information in: 

Displaying runtime properties (Page 154) 

Display of block execution (Page 166) 

18.2.4 "Properties - Block/Chart" dialog box, "General" tab 

"Properties - Block/Chart" dialog box, "General" tab 
On this tab, you can see the general properties of the: 

● Block 

or  

● Nested chart 

Block and chart options on the "General" tab 
Type 

At the block:  
Here you can view the type name of the block. If you only see the FB or FC number, you 
should import the relevant entry with the name of the block into the active symbol table from 
the symbol table of the source file, or edit the block name for the function block (FB) or 
function (FC) in the active symbol table. 

Nested chart:  
The entry always displays the "Chart" type. 
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Name 

In this box, you can view and edit the name of the block instance or chart. The maximum 
string length for blocks is 16 characters, for nested charts 22 characters. The name string 
must not contain these characters: \ / . " %. 

 

 Note 

Please note the following: 
• Remember when assigning names that the variable name must not be longer than 128 

characters for transfer to the OS ("Compile OS"). The name consists of the following 
elements: 
– The name of the folder in the hierarchy path 
– The chart name 
– The block name 
– The separator (period mark) 
– The I/O name (variable name) 

• When transferring to the OS, in addition to the illegal characters listed above, the 
following characters are not permitted in the name and are automatically replaced by the 
$ character: space  ? * ' : 

 

Tip: Never use any of the characters listed above when selecting names. 

Comment 

In this box, you can view and edit the block or chart comment. You can enter a maximum of 
80 characters. Only the first 14 characters (large block and nested chart) or 7 characters 
(small block) are displayed in the header.  

The comment will only be adopted by WinCC, if it was edited at this instance prior to OS 
compilation.  

Group (only for blocks with messages) 

In this field you can assign the block to a group that is intended for hiding messages. The 
name of the group can have a maximum of 24 characters. 

Options on the "General" tab for blocks 
The following options only exist for the block properties. 

Inputs 

Here, you can see the number of block inputs of the selected block. If the block has a 
variable number of inputs and the same data type, for example, NAND, OR, etc., you can 
change the number of block inputs with the menu command Edit > Number of I/Os. 

Internal identifier (S7 only) 

When you implement block types as functions or function blocks, you will see the block type 
(for example, FC or FB) and number. The block folder of the SIMATIC Manager displays this 
internal block identifier as "Object name". 

Instance DB (S7 only) 

The program displays the DB number of blocks mapped to a data block. 
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Name (header) 

Displays the name of the block as specified in the internal block header at the time the block 
was created. 

Family 

Displays the family name of the block as specified in the internal block header at the time the 
block was created. This is used, for example, as a sorting criterion in block catalogs. 

Author 

Displays the name as specified in the internal block header at the time the block was created 
(for example, with basic operations "CFC-BOP" or technological blocks "TECH"). 

To be inserted in OB/tasks 

There are blocks that must be installed in certain tasks, for example, to ensure that the 
startup behavior, process-control message capability and other properties will take effect. 
The list displays the tasks where CFC has automatically installed the block. You can edit the 
run sequence later with the menu command Edit > Run Sequence.... 

OCM possible 

Here you can define the response of a block that can output messages or can be controlled 
and monitored from an OS. 

The option "OCM possible" does not influence message transfer to the OS. 

● Select or deselect the "OCM possible" check box in order to decide whether this block is 
entered in the watch list on the OS for operator control and monitoring. When you 
deselect the check box, all elements of this group are switched to inactive. They are then 
no longer relevant for execution but they retain their setting. 

● Click "Operator Control and Monitoring" to open the dialog box where you can set special 
properties. There is usually no need to call this dialog box when using WinCC and the 
PCS 7 library blocks, since the properties are here set by default. 

● When you select/deselect the "Create block icon" check box, you decide whether or not a 
block icon is created for this block. 

● In the "Block icon" edit box, you can specify the icon WinCC displays for this block. You 
can thus set different views for the same block type, if they exist. The edit box is switched 
inactive if you deselect the "Create block icon" check box; however, the entry is retained. 
You can enter a maximum of 16 characters. 

● When you select/deselect the "MES-relevant" check box, you decide whether or not the 
information of this block is transferred to the enterprise levels MIS/MES when requested. 

This input box is only enabled if you have selected the "OCM possible" check box.  
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Special properties 

● Click "Messages..." to open a dialog box where you can edit the block's message texts. 

● If the “Read-back enabled” check box is selected, the block is included in the read back 
(default). The block has the system attribute S7_read_back = 'true'. 

Depending on the scope set in the Read Back dialog box, all block I/Os are read back or 
only those with the “Operator control and monitoring” system attribute (S7_m_c := ‘true’) 
and/or those with a special designation (S7_read_back := ‘true’).  

You can also exclude the entire block from the read back if you deselect the check box 
(S7_read_back := 'false').  

● Use the "Technolog. assignments..." button to open a dialog box in which all assigned 
objects are listed. Select an object and confirm with the "Go to" button to jump directly to 
this object. This button only exists if there are assignments. 

"OK" button 

This button applies all the changes you have made in the dialog box. The dialog box is 
closed. 

"Apply values" button 

This button is active only when you are in test mode and have changed one or more values 
in the "Value" column of the "I/Os" tab. 

The button applies only the modified values in the "Value" column on the CPU. The dialog 
box remains open so that you can change a value more than once and follow the result in 
the block in the chart. 

"Print" button 

This button enables you to print the table of input/outputs. The tab switches from "General" 
to “I/Os” when you click the button. 

The table is printed in landscape format. The columns are set to optimum width and then set 
back to their previously set width. 

"Cancel" button 

This button discards all unsaved changes and closes the dialog box. Modified values that 
you have already accepted with the "Apply values" button are retained. 

18.2.5 "Properties - Block/Chart" dialog box, "I/Os" tab 

"Properties - Block/Chart" dialog box, "I/Os" tab 
The table on this tab displays the I/Os of the selected object.  

All existing elements are listed in table columns, regardless of the object type (block 
instance, nested chart, external view of the SFC chart, instance of an SFC type). However, 
not all columns are globally relevant to every object type and you may not be able to change 
them. You can never edit grayed out fields. 
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Meanings of table columns 
# 

This column is always visible. I/Os are assigned numbers in this column. After you open the 
object properties dialog, you will see the consecutive numbering in ascending order. Sorting 
the I/Os changes the order. The original (ascending) order is restored after you exit the 
dialog box. 

Name 

Here, you see the name of the I/O. This column is always visible. 

I/O 

Here, you can see the type of I/O (IN = Input, OUT = Output, IN_OUT = In/Out). 

Type 

Here, you see the data type of the I/O.  
You will find detailed information on this topic in the section: Data types for S7 (Page 138) 

Value 

Here, you can view and edit I/O parameter values. Different ranges of values and inputs are 
permitted, depending on the data type. You cannot modify grayed out values: 

● At interconnected I/Os and an empty field (contains no value) 

● Of I/Os that are not configurable (system attribute: S7_pram := 'false') 

● Of a textual interconnection  
The value (of the block type) is used here as a substitute value for the interconnection 
partner. 

Instead of an absolute numeric value, a value identifier can also be displayed here if value 
identifiers were configured for this I/O and the "Value identifier" option is enabled in the 
settings for the display. In this case, you can select the text to be displayed in a list box, for 
example, the display text of an enumeration. The button for the drop-down list is displayed 
when you click in the list box. 

Interconnection 

This shows the connected partner when I/Os are interconnected. When an output has 
several interconnections, all inputs connected to this output are shown. 

Background:  
A maximum of 160 I/Os per interface side (left side IN and IN_OUT, right side OUT) can be 
displayed in the CFC. When there are more than 160 I/Os per interface side they are 
switched to invisible. This occurs from the last I/O onward. This may include interconnected 
I/Os. Although these interconnections are no longer visible, they can be recognized only in 
the "Interconnection" column.  

Note: If the I/O of one interconnection partner is invisible, the interconnection of the visible 
I/O is led to the sheet bar and the target of the interconnection is identified by "(INVISIBLE)".  
If both partners in the interconnection are switched to invisible, the interconnection can no 
longer be recognized in the chart. This also applies to textual and symbolic interconnections 
and for interconnections to runtime groups.  

If an I/O cannot be interconnected (S7_link := 'false'), the text <cannot be interconnected> is 
entered. 
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Add forcing 
Displays the selected I/O at which the add forcing function is enabled. This option is only 
available if forcing has been globally enabled in the SIMATIC Manager . 

Forcing active 
Displays the selected I/O at which the forcing active function is set. This option is only 
available if "Add forcing" is active. 

Force value 
Displays the force value. You can only edit this value if "Add forcing" is active. This value 
depends on the data type of the I/O. 

SFC access 
Shows the I/O which are selected for read / write access by an SFC. This identifier is of 
particular significance to hidden I/O, because this SFC access is not shown in the block 
representation of the chart. 

Technological assignments 
Here the connections are selected that are connections of a control module. You copy and 
insert the connections with a shortcut menu. 

Comment 
Here you can view and edit the I/O comment (maximum of 80 characters).  

The comment of an interconnected input can be an input comment (I/O comment) or an 
interconnection partner comment (interconnection comment). The display depends on the 
settings made in "Customize Display". Open the dialog box using the menu command 
Options > Customize > Layout.... If the interconnection comments are to be displayed in the 
CFC chart, select the "Interconnection comment" check box in the "Parameter" group of the 
dialog box. 

You cannot modify the interconnection comment in the input object properties. 

Invisible 
Here, you can decide whether interconnected or not interconnected I/Os are to be displayed 
or hidden.Check mark = hiddenNo check mark = visible. 

If the I/O of one interconnection partner is invisible, the interconnection of the visible I/O is 
led to the sheet bar and the target of the interconnection is identified by "INVISIBLE". 
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If both interconnection partners or the I/O with a symbolic or textual interconnection is 
switched to invisible, this interconnection can no longer be recognized in the chart, but only 
in the "Interconnection" column. The same applies to interconnections to runtime groups. 

 

 Note 

If the block contains invisible interconnected I/Os, a colored triangle appears in the top right 
corner of the block header. This also applies to SFC access. 

 

Watched 

Here you can set the I/Os so that they are logged in for test mode. This allows you to view 
and edit the actual values of the CPU. 

Archive 
Here, you can mark I/Os of the data type BOOL, BYTE, WORD, DWORD, INT, DINT, and 
REAL for the following types of archiving: 

● No archiving 

● Archiving 

● Long-term archiving 

Requirement: The I/Os are intended for operator control and monitoring. 

The boxes in this column can only be edited when the I/O is intended for operator control 
and monitoring (system attribute S7_m_c := 'true'). This applies regardless of whether the 
current block is switched to operator control and monitoring.  
With the integrated drop-down list, you can specify that the I/O is not relevant for archiving 
("No Archiving"), or is marked for "Archiving", or for "Long-term archiving".  

You can find additional information about this in the section: Configuring archive tags 
(Page 151) 

Identifier 

Here you can view the identifier of I/Os that are not of the type BOOL and you can enter 
identifiers with a maximum string length of 16 characters, for example, "Setpoint" or "CP". 
The OS uses these texts for displays and logs. 

Unit 

Here, you can select the most common units from a drop-down list for I/Os that are not of the 
BOOL data type. The button for the drop-down list is displayed when you click in the list box. 

 

 Note 

The set of units is installed with CFC and can be modified or supplemented in the SIMATIC 
Manager . You can find additional information about this in the section: Configuring Shared 
Declarations (Page 143). 

 



 Appendix 
  

CFC for SIMATIC S7 (V8.0 SP4) 
Function Manual, 07/2013, A5E03710059-06 319 

Text 0 

Here, you can enter a text with a maximum length of 16 characters for the value "0" for I/Os 
of the BOOL data type, for example, "Close" and "Closed". 
In the "Value" column you can select this text or "Text 1". 

 

 Note 

If the I/O is also assigned the system attribute "S7_enum", this box is deactivated. In this 
case, only the enumeration is used as value identifier. 

 

Text 1 

Here, you can view and enter a text with a maximum length of 16 characters for the value "1" 
for I/Os of the BOOL data type, for example, "Open" and "Opened". 
In the "Value" column you can select this text or "Text 0". 

 

 Note 

If the I/O is also assigned the system attribute "S7_enum", this box is deactivated. In this 
case, only the enumeration is used as value identifier. 

 

Enumeration 

If this involves an I/O that is assigned the "S7_enum" system attribute, you can select the 
enumeration in the drop-down list created in the current project in "Shared Declarations" for 
I/Os of the data type BOOL, BYTE, INT, DINT, WORD, DWORD.  

The display names that you can select from the "Value" box in the drop-down list are 
assigned as values to each enumeration if the "Value identifier" option is activated in the 
"Customize Display".  

You can select the empty field in the "Enumeration" drop-down list to delete an enumeration. 
The numerical value is then displayed in the "Value" box instead of the display name.  

Note: When the enumeration is deleted, the "S7_enum" system attribute is retained at the 
block I/O, in other words an empty string is entered instead of the enumeration previously 
shown.  

You will find more information on enumerations in the section: Configuring Shared 
Declarations (Page 143) 

Parameters 

You can here identify the I/Os you want to display on the "Parameters" tab of the process 
object view. You can change this setting in the SIMATIC Manager using the menu command 
Options > Process Objects > Select I/Os.... 

Signal 

Here you can identify the I/Os you want to display on the "Signal" tab of the process object 
view. You can change this setting in the SIMATIC Manager using the menu command 
Options > Process Objects > Select I/Os.... 

Options are: "Parameter" or "Signal", or none at all. 
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MES-relevant 

When the "MES-relevant" check box is selected, this acts as a filter so that if an MES system 
is connected, only the control system information of interest for MES is transferred. With this 
option, you can mark individual I/Os with OCM capability as being relevant or irrelevant for 
MIS/MES. You can identify these I/Os as relevant regardless of the setting of the "MES-
relevant" check box on the "General" tab. 

Sort I/Os 

You can sort the I/Os in this table. This sorting order is temporary and restored to the original 
order when you close the dialog box. 

Click a column title to sort all I/Os. Each click toggles the alphabetical order: 
ascending/descending. The sorting order of columns with selection boxes is determined by: 
not set/set. The "#" column indicates changes to the sorting order.  

Buttons 
"OK" button 

This button applies all the changes you have made in the dialog box and closes the dialog 
box. 

"Apply values" button 

This button is active only when you are in test mode and have changed one or more values 
in the "Value" column of the "I/Os" tab. 

The button applies only the modified values in the "Value" column on the CPU. The dialog 
box remains open so that you can change a value more than once and follow the result in 
the block in the chart. 

"Print" button 

This button enables you to print the table of input/outputs. The tables are printed in 
landscape format. The columns are set to optimum width and then set back to their 
previously set width. 

"Cancel" button 

This button discards all unsaved changes and closes the dialog box. Modified values that 
you have already accepted with the "Apply values" button are retained. 

18.2.6 Enable attribute 

Function 
The enable attribute enables or disables a runtime group (on = 1, off = 0) and represents a 
master control. As long as “0” is set the runtime group will not be executed, regardless of any 
other conditions. 
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Enabling/disabling runtime groups dynamically 
The default setting of the enable attribute is 1. It can also be set dynamically, i.e., the output 
value of a CFC block can enable or disable the runtime group. You can interconnect the 
binary output of a block to the runtime group. 

Enabling/disabling runtime groups in the runtime editor 
You can enable/disable runtime groups via the runtime editor window.  

To enable a runtime group, select the “Active” check box in the object properties of the 
corresponding runtime group. To disable a runtime group, deselect the “Active” check box in 
the object properties of the corresponding runtime group. You can also do this via the 
shortcut menu commands Switch on Runtime Group and Switch off Runtime Group. This 
avoids you having to open the object properties dialog box. 

 

 Note 

If a runtime group is interconnected to a binary output of a block, this output value always 
controls the runtime group. In this case, the “Active” option is ignored. 

 

18.2.7 Displaying tooltips using the cursor 

 
In test mode you can display online values as tooltips by placing the cursor on an I/O or an 
interconnection line. Here, the cursor functions like the "test prod" of a measuring device.  

Requirement: It must be possible to update the I/O online (not an unconnected FC input, for 
example). 

The following applies in respect of tooltip display: 

● The information is actively retrieved from the CPU by placing the cursor on an I/O or the 
interconnection even if the I/O has not been registered for monitoring. Updating is 
performed once a second, regardless of the selected watch cycle. 

● The value is substituted with the online value and the background color of the tooltip 
changes from light yellow to yellow, as it does with watched I/Os. With I/Os that cannot 
be operator controlled and monitored, for example, when they are interconnected, the 
background is yellow-gray. 

● The output value is displayed for an interconnection. Exception: With interconnections 
with shared addresses, the input value is displayed. Inversions are taken into account in 
this case. 
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18.2.8 Searching for objects in the catalog 

Searching in the catalog 
You can specify a text in the input box of the catalog and search for it by clicking this button: 

 
If the text you entered is not found as an object name, CFC searches for a block with a 
corresponding comment. The folder, for example, of the block family, or the library in which 
the block is located is opened and the block is selected. 

The block is searched for starting from the selected object (library, folder or block) in the 
active catalog window. All the libraries and folders are searched until the required object is 
found or until the search returns to the selected object.  

With the "Find initial letter" check box you can decide whether the search starts at the initial 
letters (restricted search) or whether any part of a name or comment should be searched for 
(free search; default). 

During the search, a dialog box with a progress display is shown. Here, you can stop the 
search if it takes too long, for example, when you first search through libraries. 

The search stops when an object with the specified letters is found. 

By clicking on the button mentioned above, you can search for other objects with these 
letters. The search is completed when it returns to its starting point. 

18.2.9 Phase offset 

Function 
Phase offset allows a uniform distribution of load within the CPU. It must be considered in 
conjunction with "n", the reduction ratio. The group is processed as often as specified by "n", 
offset in each case by "m" units of the task cycle. "m" is an integer, where 0 <= m <= (n-1).  

Default: 0, in other words, no phase offset. 

Additional information 
You can find additional information in the following sections: 

Scan rate (Page 327) 

Example of reduction ratio and phase offset (Page 311) 
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18.2.10 Signal processing with driver concept up to V5.2 

 
The driver and message concept described here applies if you want to use or continue to 
use CH blocks with version < 2.0. 

Driver and message concept 
For this functionality, block types are used to isolate hardware data from software 
configuration data: 

● The user interconnects channel-specific blocks (CH blocks) of the CFC chart and assigns 
corresponding signal names from the symbol table. 
The CH block is used for signal preprocessing and can be configured and interconnected 
independent of the hardware. It is thus an object of the system functions and is always 
processed along with those functions.  
Four different types are available for signal preprocessing: 

– Signal preprocessing of analog input values (CH_AI) 

– Signal preprocessing of analog output values (CH_AO) 

– Signal preprocessing of digital input values (CH_DI) 

– Signal preprocessing of digital output values (CH_DO) 

For additional information on the functions and operating principle of CH blocks, refer to 
the context-sensitive help (<F1>) for the block. 

● The system automatically generates the multi-channel blocks (MOD blocks) for the 
module-specific functions, that is, it imports the blocks from a block library and inserts, 
programs and interconnects these. 
The MOD block is also known as diagnostics block. It handles all special situations such 
as startup and error events, for example, by providing process control messages and the 
signal value status (1 = good, 0 = bad). 

● In addition to the diagnostic blocks and in order to ensure that not all MOD blocks report a 
rack failure if a rack fails, a RACK block is automatically added for each rack.  
The RACK block is responsible for signaling in this case. The MOD blocks recognize in 
OB 86 that the event has been processed and do not report. 

● The SUBNET block controls the runtime groups for each configured DP chain and is used 
to reduce acyclic OB execution times. When an event occurs, only the blocks that are 
actually affected will be called. The SUBNET block is also installed automatically. 

● The PO_UPDAT block ensures that the start values written to the process image by the 
CH_AO and CH_DO blocks are transferred to the output modules during a CPU restart. 
This means that these values are effective immediately when the CPU changes to RUN. 

● The MSG_CSF message block is implemented in PCS 7 process control systems in order 
to prevent errors, for example, rack failure, module failure, from triggering a CPU 
transition to STOP, In other words, it is implemented by installing the MSG_CSF block in 
special OBs generated by the system. 

For additional information on the functions, functionality and message capability of RACK 
and SUBNET blocks, refer to the context-sensitive help (<F1>) for the relevant block. 
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How the "Generate Module Drivers" function works 
A system chart is generated automatically and the MOD, RACK, SUBNET blocks and the 
process control message block MSG_CSF and the PO_UPDATE block for outputting the 
process image are inserted. The system chart is assigned the name "@1" and can contain 
up to 52 blocks, with 2 blocks per chart partition. If additional blocks are generated, another 
system chart will be created and assigned the name "@2".  

The blocks are imported from the libraries when you initially generate the module drivers and 
if the CFC database does not yet contain the corresponding driver blocks or MSG_CSF. The 
block search starts at the path defined in the "Settings – Generate Block Drivers" dialog box. 
If a block is not found, it searches through the default paths specified during setup of the 
PCS 7 libraries. 

 

 Note 

This method prevents new versions of block types being used in the program if blocks with 
the same name already exist in the CFC data management. It also prevents global block 
type changes for these blocks. 

 

The MOD blocks for each rack will be installed in runtime groups, including the RACK block. 
Those blocks and the runtime groups are identified in the run sequence by the "@" prefix.  

 

 Note 

Please note the following: 
• Objects identified by the "@" character should not be modified by the user, but should 

only be manipulated using the “Generate Module Drivers” function. The same applies to 
manual insertion of MOD, RACK and SUBNET blocks. 

• Driver blocks created by the user must be inserted from the block catalog. When "@" 
blocks are copied, they will be deleted the next time the "Generate Module Drivers" 
function is executed. 

 

The MOD blocks are installed in the acyclic error OBs as well as in OB 1. This ensures that 
they are also executed following an online block download, since OB 100 is no longer 
executed in this case. The runtime group is assigned a reduction ratio of 16. The blocks will 
be called only every 16th time OB 1 is executed, in order to avoid unnecessary load on the 
CPU. 

The system verifies the existence of the PO_UPDAT block in CFC. If it does not exist, it is 
imported from the library and inserted in the system chart. It is installed in the run sequence 
at the last position in OB 100. If the block already exists, the system verifies that it is installed 
in OB 100 after the driver blocks and that it is deleted from all other OBs. 

The system checks whether an MSG_CSF exists in CFC. If this is not the case, it will be 
imported from the "PCS 7 Technology\Blocks" library, inserted in the system chart and in the 
run sequence of the cyclic interrupt OB 32 and in the following startup/special OBs: OB 72, 
OB 81, OB 83, OB 84, OB 85, OB 86, OB 87, OB 100, OB 121, and OB 122. 
No warning is issued when there is more than one MSG_CSF. 
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Process image partitions 
The CH blocks receive and output their signals via the process image (PI). 

The PO_UPDAT block ensures that startup values written to the process image by the 
CH_AO and CH_DO blocks are transferred to the output modules during a CPU restart and 
that they take effect immediately.  

The OB 1 PI is updated at the cycle control point (no constant scan cycle time). You can 
achieve a constant scan time by using process image partitions (PIP). PIP update times are 
configured in HW Config by assigning a PIP to an OB. The PIP update covers the inputs at 
the start of OB execution and the outputs at the end of OB execution. Process image 
partitions are module-related, In other words, the fastest signal determines the update of all 
module signals. 

Implementing blocks of new versions 
The installation of a new PCS 7 library containing modified block types initially has no effect 
on blocks used already.  

Proceed as follows to update the blocks:  

1. Delete all @ system charts from the chart folder. 

2. Select the menu command Options > Block Types…. 

3. Select the relevant blocks and click "OK". 
The blocks are deleted in the "Chart folder" window. 

4. Call the "Generate Module Drivers" function in the component view of SIMATIC 
Managers .  
New system charts will be created. The driver blocks of the new library will be installed, 
since they are now no longer available in the CFC. Enter the library in the “Customize” 
dialog box. If MSG_CSF is not found in this library, it is searched for in the default path 
that was entered during setup. 

Model session, version 1 
● Configure the hardware and assigns symbolic names to the I/O signals. The signal 

names are entered directly in the symbol table by HW Config: 
Select the module 
Select the menu command Edit > Symbols... in HW Config. 

● Configure the technological functions in CFC using CH blocks that must be 
interconnected under the signal names taken from the symbol table. 
Select the menu command Insert > Interconnection to Address.... 



Appendix  
  

 CFC for SIMATIC S7 (V8.0 SP4) 
326 Function Manual, 07/2013, A5E03710059-06 

● In theSIMATIC Manager , call the driver generator with the menu command Options > 
Charts > Generate Module Drivers... to generate, interconnect and configure all module 
drivers. The following steps are performed automatically: 

– The system identifies all channel blocks (CH_AI, CH_AO, CH_DI, CH_DO, CH_CNT, 
CH_CNT1, CH_MS) of the CFC charts in the first step, and all symbols (name and 
address) interconnected to the "Value" I/Os in the next. Using the symbolic addresses 
of the symbol table, the system identifies the corresponding module and channel in 
hardware configuration data. Based on the module type, it determines the 
corresponding MOD block type and generates a block instance for each I/O module in 
the system chart. 

– Parameters required for MOD blocks are fetched from hardware configuration data 
and entered at the block instances and at the SUBNET block that is used for 
optimizing runtime in the error OBs. 

– The channel-specific output at the MOD block is interconnected to the corresponding 
input at the CH block. If the "value status" module is supported, the address of the 
value status is obtained and interconnected to the CH block. 

Changes made in configuration data (hardware or software) must be computed via the 
"Generate Module Drivers" function. Existing driver blocks will not be deleted and recreated, 
but are rather assigned new parameters. Blocks that are no longer required will be deleted 
(except for user blocks) and additional blocks will be created as required. using blocks 
imported from the CFC data management instead of the library blocks. 

Model session, version 2 
● Configure the technological functions in CFC using CH blocks that must be 

interconnected under the signal names taken from the symbol table. 
Select the menu command Insert > Interconnection to Address.... 
Entering the signal name in the dialog box 

● Configure the hardware and assigns symbolic names to the I/O signals. The signal 
names are entered directly in the symbol table by HW Config: 
Select the module 
Select the menu command Edit > Symbols... in HW Config. 

Tip on configuring the hardware: 
If you have configured the software first and already interconnected the block I/Os to the 
symbolic names of the I/O signals with the menu command Interconnection to Address... and 
then want to configure the hardware, you can copy the symbolic names from the "Cross-
References of Addresses" list and paste them into HW Config data. 
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18.2.11 Scan rate 

Function 
The reduction ratio specifies whether the runtime group is processed each time the OB is 
executed or only every nth time the OB is executed. "n" is an integer (n = 2t, where 0 <= t <= 
15). The run cycles are a multiple of the time base. 

Default:1, in other words, the runtime group is executed in every run cycle. 

Example: 
Basic cycle of a cyclic interrupt: 1 sec 
Possible clock cycles with reduction ratio: 2, 4, 8, 16, etc.  

Additional information 
You can find additional information in the following sections: 

Phase offset (Page 322) 

Example of reduction ratio and phase offset (Page 311) 
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Predecessor for Insertion Position, 312 
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