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Legal information 
Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

DANGER  
indicates that death or severe personal injury will result if proper precautions are not taken. 

WARNING  
indicates that death or severe personal injury may result if proper precautions are not taken. 

CAUTION  
with a safety alert symbol, indicates that minor personal injury can result if proper precautions are not taken. 

CAUTION  
without a safety alert symbol, indicates that property damage can result if proper precautions are not taken. 

NOTICE  
indicates that an unintended result or situation can occur if the relevant information is not taken into account. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems. 

Proper use of Siemens products 
Note the following: 

WARNING  
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 

 

 Siemens AG 
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GERMANY 
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Start of application 2
2.1 Start techniques 

Calling the "Comos.exe" file 
You can start the COMOS installation by running the "Comos.exe" file in the "Bin" directory. 
You can also use parameters if you run the program from the command line or via a 
shortcut. See also section Parameters (Page 7). If start parameters are used, no direct start 
is performed. See also section Quicklaunch (Page 10). 

Calling the "Comos.XIF.exe" file 
The "Comos.XIF.exe" executable file is located in the "Bin" directory of COMOS. 

● If COMOS was already started, a project is opened and an object is selected in the active 
COMOS application by running the "Comos.XIF.exe" file with appropriate parameters. 

● If COMOS was not yet started, the main application of COMOS is also started by calling 
the "Comos.XIF.exe" file. 

You can create an XIF desktop link using drag&drop. You drag an object from the Navigator 
onto the desktop for this purpose. An XIF link is automatically created which additionally 
opens the properties of the object. See also section Start via an XIF link (Page 10). 

2.2 Parameters 
● The start parameters are optional. 

● You can pass any number of start parameters, but each start parameter only once. 

● Use the following notation for each start parameter: 

/<Start parameter name>:<parameter value> 
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Parameters 
The following table describes the parameters:  

 
Parameters Name Description 
/DT: Data type Data type of the database. Also 

replaces the parameters /DB and /DN. 
You obtain this data type from 
Workset.Init(...), for example.  
Example: 
/DT: [SQL -
SERVER]PT_SQL_SERVER_1 

/PR: Project Project name 
Example: /PR:"H001" 

/WO: Working overlay ID Pass the ID of the working layer. 
1. Set ID: 
2. Open project 
3. "Extra > Working layers/Histories 

> Management", tab "Working 
layers": Open the properties of the 
working layer 

4. Apply the value from the "ID" field 
/US: User Possible values: 

 User name (login) from 
Workset.CurrentUser.Name 

Example: /US: Frank 
 1: Setup user 
 2: Second account 

/MD: Module  V: View mode 
 E or ET: Electrical Engineering 
 PID: Piping&Instrumentation Design
 FEED: Front-end 

Engineering&Design 
 CA: Construction Assistant 
See also section Module-specific start 
(Page 11). 
 PA: The modules belonging to the 

package are started. 

Additional information about this 
topic is available in the "COMOS 
LS" manual, keyword "Packages". 

/CG: Config Name of the configuration file. The 
configuration file must be located in the 
folder of the respective COMOS 
version in the following subfolders: 
"Current\config"  
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Parameters Name Description 
/MN: Menu Name of the menu file. The menu file 

must be located in the folder of the 
respective COMOS version in the 
following subfolder: "Current\config" 

/AT: Application type 
(AS: Assistant Mode) 

Compact display of the COMOS 
interface. When the mouse is not on 
the application, the interface is 
represented by icons that are fixed in 
the foreground. This facilitates 
simultaneous work with other 
applications. 
Example: /AT:AS 

/ID: Identify Internal unique identifier of an object: 
COMOS-Object.SystemUID 
Example: /ID: A17XK7X4K0 

/ST: System type The system type 
You can find more information on this 
topic in the "COMOS.dll" class 
documentation, keyword 
"SystemType". 
Object examples: /ST: 8 
Base object example: /ST: 13 

/DG: Debug Debug mode 
Example: /DG:D 

/? Help Help 

Space 
You can enter a space in the database path or the name, particularly if you use Access. In 
this case it is mandatory that you put the parameters for the path and name in quotation 
marks. 

2.3 Application start via an HTML page 

Start via an HTML page 
XIF lets you start COMOS from an HTML page via VBScript. Call via: 
set WshShell = CreateObject("WScript.Shell") WshShell.Run ("xif.exe 
/DT: [SQL - SERVER]PT_SQL_SERVER_1 " &amp; comosCallParams) 

comosCallParams are /PR, /ID etc. 

Contact your customer representative or support for further assistance. 
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2.4 Start via an XIF link 

Creating an XIF link 
If you drag an object from COMOS onto the desktop, an XIF link is automatically created 
there. If you want to directly open the respective project later, you only need to double-click 
the XIF link. Information regarding the database and users are namely also stored in the XIF 
link. 

In the XIF link, you can enter the same parameters that you use when calling the 
"Comos.exe" file from the command line. See also section Parameters (Page 7). 

 

 Note 
Correcting link properties for drag&drop links 

If you are logged on with the universal access "@Setup" or the alternative user access 
"Name_2" in COMOS when creating the drag&drop link, incorrect user information (US) will 
be input in the link: 

/US: @Setup or /US: Test_2 

Correct is: /US: 1 or /US: 2 

If you correct this information in the link properties, the link will also work. 
 

 

2.5 Quicklaunch 

Recreating the last work environment 
You set the COMOS Quick Launch here: 

"View > Quick launch" menu 

If the direct start (Quick launch) has been activated, then at the next start, COMOS 
automatically tries to restore the working environment that existed when you last quit 
COMOS. 

 

 Note 

With the direct start you open the database that was closed last and not the last open one. 
You will not notice a difference if you only work with one COMOS instance. 

If you work with several COMOS instances simultaneously, the most recently closed 
COMOS instance determines the database that opens with Quick launch. 
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Quick launch tries to open the project that was last used in COMOS. Even the Navigator tree 
is opened up to the most recently selected object, unless it is an inherited object. You can 
find more information on this topic in the "Inheriting, Copying, Deleting" manual, keyword 
"Inheritance". 

Quick launch uses the standard access or alternative access of a user only. The universal 
access is not supported by Quick launch. 

Quick launch works only when no other specification is available. Quick launch will not have 
an effect if you use start properties or start parameters. 

2.6 Module-specific start 

Module-specific start mode 
In the command line for the COMOS start, you can set a module-specific start mode, e.g. 
/MD: CA for starting the Construction Assistant. See also section Parameters (Page 7). 

Command line 
If you have entered the module in the command line, the menu file with the same name is 
also searched as the default setting. You can overwrite the default setting in the command 
line: 

/CG: <Config file name> 

/MN: <Menu file name> 

2.7 Server login with file 

Password for server login 
The password for the server login (not the COMOS login) for the SQL server and Oracle is 
saved in a file. Advantages: 

● You do not have to enter the password every time you log in. 

● It is sufficient if an administrator knows the password. The administrator creates this file 
once and then distributes it to all clients. 

● This technology will also let you use any user name and you are not restricted to the user 
name "COMOS". 

You can find more information on this topic in the commissioning documentation "DB 
Administration", keyword "Password". 
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2.8 Remote administration 
You have the option to access COMOS by means of a remote access. 

This requires an access with TerminalClient software to a Windows 2000 or Windows 2003 
server in administration mode. Contact the support team to find out which licenses are 
required and how to technically implement this option. 

2.9 Detecting internal networks 

Background 
Company internal PCs log on with a different license then PCs with an external access to the 
company network. 

IP numbers 
You can specify IP numbers in collaboration with you customer representative or Customer 
Support; these are regarded as in-house numbers. This gets you around the problem that 
the domain of a client is not known in certain cases. 

2.10 COMOS Web 

2.10.1 Background 
COMOS Web is a server-based Internet interface to COMOS. The target group for COMOS 
Web are users within and outside a company that do not frequently work with COMOS or 
that are primarily active in a limited task field. 

COMOS Web users log in to a COMOS database with the COMOS Web Server via an 
Internet Explorer from Microsoft.  



 Start of application 
 2.10 COMOS Web 

Starting COMOS 
Operating Manual, 08/2011, A5E03638054-01 13 

2.10.2 Starting COMOS Web 

Requirement 
COMOS Web has been installed. 

Procedure 
To start COMOS Web, proceed as follows: 

1. Start the Microsoft Internet Explorer. 

2. Enter the following URL in the "Address" field: 

"http://<server name>/" 

Result 
The window for the COMOS Web login opens. 

You can find more information on this topic in the "COMOS Web" manual, keyword "Starting 
COMOS Web". 
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Registration in the database 3
3.1 Open database 

Procedure 
1. Click the "File > Open database..." menu. 

2. In the "Open database" window, select the required database type in the first line. 

  Note 
Microsoft Jet database type 

Access requires the presetting "Microsoft Jet". 

3. In the "Database" line, click the "..." button. 

4. Select the required database in the "Open database" window. 

  Note 
Select instance 

If you have selected "Oracle" or "SQL-Server" in the second step, select an instance 
instead of a database. You can find more information on this topic in the "DB 
Administration" manual, keyword "Creating instances for an Oracle client". 

The "User name" field first takes the user that you used to log in to the company network.  

5. If you want to work on a shared COMOS database from different locations, click the 
"Extended" button. 

– In the "Time zone" field, you can find information on your GMT (Greenwich Mean 
Time) setting. COMOS takes the time information from the respective operating 
system to synchronize PCs that access a shared database from different time zones. 

– You can enter your location in the "Location" field. For example, this information is 
used for electronic signatures. 

6. Select one of the following options: 

– If you want to log in as a user that has already been registered, click the "Open" 
button. 

– If you want to log in as another user, right-click the "User name" field and select the 
respective user. Then click the "Open" button. 
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3.2 Setup login in the example database 

Universal access / user account "@Setup" 
A @SETUP user is created in the user administration of the COMOS database and in newly 
created Access databases. For security reasons you do not have the option to enter any 
name to log in. The user name of the operating system will be entered in the "User name" 
input field of the "Open database" dialog field. 

Procedure 
To enter the "@SETUP" user account in the "User name" input field, proceed as follows: 

1. Click the "File > Open database..." menu. 

2. Right-click the "User name" input field. 

Various user accounts are offered in the context menu. 

3. Click "Universal access" in the context menu. 

Result 
The "@SETUP" entry is in the "User name" input field. You can now log in with this user 
account. 

3.3 Alternative access 

Procedure 
Proceed as follows to enter the alternative access in the "User name" field: 

1. Open the database. 

2. Right-click the "User name" field. 

Various user accounts are offered in the context menu. 

3. Click "Alternative access of user" in the context menu. 

Result 
A user name will be created that consists of the standard user name with the extension "_2". 
You have the option to assign other user rights than the standard user to this user. 
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3.4 Initial login to a new database 
You can find more information on this topic in the "COMOS Administration" manual, keyword 
"Initial login". 

3.5 Login verifications 

3.5.1 Definitions 

Database model 
All object properties available in COMOS are stored in the COMOS database. If a new object 
property is introduced with a COMOS version, you need to expand the database to include 
this new property. 

Database indices 
Database indexes are needed to speed up the access. The result of this check will be output 
in one dialog window together with the result of the database model check. 

Database version 
The COMOS DB is assigned specific version numbers whenever relevant enhancements are 
made. 

Document version 
Documents are also subject to constant improvement similar to the database model. The 
document version regulates the range of options available for the user. If the document 
version was incremented, you can use new options. 
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3.5.2 Adjusting database models and database indices 

Joint adjustment 
You adjust database models and database indices at the same time. Only one window 
opens. Clicking the "Adjust" button will have an effect on both. 

Conversion matrix 
 
Client Description 
Old clients  Old database (model and/or indices not adjusted): Normal state 

 Converted database (model and/or indices adjusted): An old client can open the 
database and use the old functions, while new clients cannot. 

New clients  Old database (model and/or indices not adjusted): A new client cannot open the old 
database. 

 Converted database (model and/or indices adjusted): Normal state 

User 
If a user opens an older COMOS database with a current COMOS version, the following 
notification is displayed: 

"The tables in the database do not match the COMOS requirements! Contact your COMOS 
administrator!" 

COMOS remains open after the message and you can select another database. 

Administrator 
If an administrator opens an older COMOS database with a current COMOS version, the 
"Checking tables" dialog field opens. The administrator has the following options: 

 
Option Description 
"No" button The database remains unchanged and is not opened. COMOS remains open and the 

administrator has the option to select another matching database. 
"Yes" button The database model will be adjusted. Both the older and the new, current COMOS 

clients can continue to work as usual. There will be no loss of data. Older COMOS 
clients cannot use the options that were provided through the update of the database 
model. 
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3.5.3 Incrementing the database version 

Conversion matrix 
 
Client Description 
Old clients  Old database (database version not adjusted): Normal state 

 Converted database (database version adjusted): An old client cannot open the 
converted database. 

New clients  Old database (database version not adjusted): A new client can open the old 
database. 

 Converted database (database version adjusted): Normal state 

Execution 
The database version in COMOS is managed with the help of the Support dialog. You can 
find additional information on this topic in the "COMOS Administration" manual, keyword 
"Adjusting the database version". 

 

 Note 

You cannot reset an incremented database version. 
 

3.5.4 Incrementing the document version 
Old clients cannot work with documents that have a higher document version. 

Conversion matrix 
 
Client Description 
Old clients  Old database (document version not adjusted): Normal state 

 Converted database (document version adjusted): An old client will gets a warning 
when logging in. If the new document version has not yet been transferred, an old 
client can open and edit the documents. After the transfer of the new document 
version, the old clients only have read access to the document. 

New clients  Old database (document version not adjusted): A new client can open the old 
database. A new client can open and edit old documents. 

 Converted database (document version adjusted): Normal state 

When old documents are stored for the first time with a new client, the new 
document version is transferred to the old documents. 
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Execution 
The document version in COMOS is managed with the help of the Support dialog. You can 
find more information on this topic in the "COMOS Administration" manual, keyword 
"Adjusting the document version".  

 

 Note 

You cannot reset an incremented document version. 
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COMOS menu bar and COMOS toolbar 4
Principle 

An XML file controls the content you see in the COMOS menu bar and COMOS toolbar. 

The content depends on the module you have started and whether the standard XML file of 
the module is used or a customer-specific file created by your administrator. See also 
section Managing the menu bar and toolbar (Page 45). 

User menus and administrator menu  
Depending on your user rights, menus, submenus, menu commands and tools may be 
locked or not displayed for you. 

Menus and menu commands with the default setting 
For information on which menus, submenus and menu commands are contained in the 
COMOS menu bar by default, see also section Menu overview: User (Page 23) and section 
Menu overview: Administrator (Page 41).  
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Menu overview: User 5
5.1 "File" menu 

Commands in the "File" menu 
 
Objective Symbol Call Description 
Open or create a database   "File > Open database..." Enter the login information in the following 

dialog field. The database you have used last 
will be displayed. You can find additional 
information on this topic in the manual "COMOS 
Platform Getting Started", keyword "Opening 
the database and project". 
Alternatively: Create a database (Access). You 
can find more information on this topic in the 
"COMOS Administration" manual, keyword 
"Creating a new Access database". 

Open or create a project  "File > Open project" A database can include one or more projects. 
Which projects you see also depends on the 
assigned rights. You can find additional 
information on this topic in the "COMOS 
Platform Getting Started" manual, keyword 
"Project management". 
Alternatively: Create a project. You can find 
more information on this topic in the "Basic 
Operation" manual, keyword "Creating projects".

Close project  "File > Close project" If more than one project is open at a time, this 
command is active. The command saves and 
closes the active project, but not the database. 

Close working layer  "File > Close working layer" Effect of "Close working layer" in COMOS: 
If working layers are open, you close the current 
working layer with this command. The next 
available project working layer then opens 
automatically. This may continue until the 
project itself is opened. 

Save current project  "File > Save project" Effect of "Save project" in COMOS: 
All open objects and actions are saved.  
Note: This also means that a save is made in 
changed properties (and the "Apply" button is 
set to inactive.) 
You cannot cancel after saving. Navigator 
operations cannot be undone. 
 As many as possible are saved. The "Save" 

button in the dialog fields, however, only 
saves if the entries are consistent. 
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Objective Symbol Call Description 

Example: duplicate name in the properties: 
– Save in COMOS: 

Name is automatically corrected; object 
is saved. 

– Save in properties: 

Save is rejected; an error message is 
output due to duplicate names. 

 The cache is cleared under certain 
circumstances. 

The existence of objects in the object cache 
is not an illegal action and should only be 
reduced by saving if the number has 
become extremely large due to the use of 
certain bulk processing functions, such as 
import actions, etc. 

Language of the interface  "File > Languages" Select the language for the interface in the 
following dialog window. 
You can find additional information on this topic 
in the "COMOS Platform Getting Started" 
manual, keyword "Switching language". 

Exit (program)  "File > Exit" Use this command to exit COMOS. All changes 
since the last save operation are saved in the 
project and in the database. 
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5.2 "View" menu 

Commands in the "View" menu 
 
Objective Symbol Call Description 
Back  "View > Back" This is a navigation help which reverses the last 

action you executed in COMOS. 
Forward  "View > Forward" If you want to execute a reversed action again, 

you have to click on the "Forward" menu. 
Quick launch - "View > Quick launch" Recreating the most recent work environment. 

See also section Quicklaunch (Page 10). 
Screen 2 - "View > Screen 2" Use this menu to open a second screen which 

displays the COMOS desktop. By default, 
COMOS is configured in such a way that 
documents are opened on this screen. 

Icon with placing 
information 

- "View > Icon with placing 
information" 

If the command is activated, a checkmark is 
displayed in the Navigator at the icons in the 
upper right-hand corner when the object is 
placed on a report and also provides placing 
information (DocObj). You can choose from 
three different options here: 
 "Hide": No placing information is displayed. 
 "For all placed objects": The checkmark is 

displayed for all objects with placing 
information. 

 "For placed elements only": The checkmark 
is only displayed for objects with placing 
information that are part of the element 
collection of another object (on the 
"Elements" tab). 

Properties tree  "View > Properties tree" The menu opens a window in the detail area of 
the Navigator which displays the properties of 
an object in list format. 

Symbol and document 
preview 

 "View > Symbol and document 
preview" 

The menu opens a window in the detail area of 
the Navigator which displays symbols of objects 
or documents. 

Window list  "View > Window list" The menu opens a window in the detail area of 
the Navigator which lists all opened windows in 
the working area. 

Favorites  "View > Favorites" The menu opens a window in the detail area of 
the Navigator which lists the favorites you have 
created in COMOS. 

Static New menu  "View > Static New menu" The menu opens a new window in which new 
objects can be created more quickly. This 
applies in particular when the same new objects 
need to be created in bulk. 
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5.3 "Documents" menu 
Using the "Documents" menu, you can select all actions of "All Document tools" as individual 
actions. 

Commands in the "Documents" menu 
 
Objective Symbol Call Description 
Print (documents)  "Documents > Print" This is the individual action "Print" of "All 

Document tools".  
Evaluate documents  "Documents > Evaluate" Runs the "Evaluate" function for any number of 

reports at once (bulk). You can find more 
information on this topic in the "Reports - Basic 
Operation" manual, keyword "Evaluate".  

Revision  "Documents > "Revision" This is the individual action "Revision" of "All 
Document tools". 

Export as DWG/DXF files  "Documents > DWG/DXF 
Export" 

This is the individual action "Save as DWG/DXF 
file" of "All Document tools". 

Word export  "Documents > Word export" This is the individual action "Word Export" of "All 
Document tools". 

Excel export  "Documents > Excel export" This is the individual action "Excel export" of "All 
Document tools". 

PDF export  "Documents > PDF export" This is the individual action "PDF export" of "All 
Document tools". 

Copy TIFF / PDF file of the 
released revision 

 "Documents > Copy TIFF/PDF 
of the released revision 

Bulk copying of the TIFF/PDF file of the most 
recently released revision into the specified 
directory. This is the individual action "Copy 
TIFF/PDF of the released revision" of "All 
Document tools". 

Print current revision file  "Documents > Print current 
revision file" 

This is the individual action "Print current 
revision file" of "All Document tools". 

Print with revision printer  "Documents > Print with 
revision printer" 

This is the individual action "Print with revision 
printer" of "All Document tools". 

All document tools  "Documents > All document 
tools" 

Collection of documents tools, which otherwise 
can be called in the various submenus of the 
"Documents" menu. You can find more 
information on this topic in the "Queries" 
manual, keyword "Standard query documents". 
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5.4 "Extra" menu 

5.4.1 "Extra > Bulk processing" menu 

Commands in the "Extra > Bulk processing" menu 
 
Objective Symbol Call Description 
Bulk processing for 
engineering objects 

 "Extras > Bulk processing > 
Bulk processing for engineerin
g objects" 

You can find additional information on this topic 
in the "Queries" manual or the "COMOS 
Platform Getting Started" manual, keyword 
"Bulk processing for engineering objects". 

Bulk processing for base 
objects 

 "Extra > Bulk processing 
> Bulk processing for base 
objects" 

You can find more information on this topic in 
the "Queries" manual, keyword 
"Bulk processing of base objects". 

Bulk processing for 
attributes 

 "Extras > Bulk processing > 
Bulk processing for attributes" 

You can find more information on this topic in 
the "Queries" manual, keyword 
"Bulk processing of attributes". 

Bulk processing for 
documents 

 "Extras > Bulk processing 
> Bulk processing for 
documents" 

You can find more information on this topic in 
the "Queries" manual, keyword 
"Bulk processing for documents". 

Bulk processing for 
connectors 

 "Extras > Bulk processing 
> Bulk processing for 
connectors" 

You can find more information on this topic in 
the "Queries" manual, keyword 
"Bulk processing for connectors". 

5.4.2 "Extra > Query" menu 

Commands in the "Extra > Queries" menu 
 
Objective Symbol Call Description 
Query - "Extra > Query" This submenu provides access to all base 

objects that are in the base data under 
"@System > @O > @Query" and are created 
by using the "New query..." context menu. 
You create a basic structure by using the 
database adjustment. You can find more 
information on this topic in the "COMOS 
Administration" manual, keyword "Database 
adjustment". 
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5.4.3 "Extra > Standard import" menu 

Commands in the "Extra > Standard import" menu 
 
Objective Symbol Call Description 
Standard import - "Extra > Standard import" This submenu provides access to all base 

objects that are in the base data under 
"@System > @O > @StdImport" and are 
created by using the "New standard import..." 
context menu.  
You can find more information on this topic in 
the "COMOS Administration" manual, keyword 
"Database adjustment". 

 

 

5.4.4 "Extra > Translation" menu 

Command in the "Extra > Translation" menu 
 
Objective Symbol Call Description 
Single translation  "Extra > Translation > Single 

translation" 
Object translation You can find more information 
on this topic in the "COMOS Administration" 
manual, keyword "Single translation". 

Bulk translation  "Extra > Translation > Bulk 
translation" 

This function simultaneously translates the 
description for several engineering objects. You 
can find more information on this topic in the 
"COMOS Administration" manual, keyword 
"Bulk translation". 

Translation database 
 

"Extra > Translation 
> Translation database" 

Opens the "Translation database" plugin. You 
can find more information on this topic in the 
"COMOS Administration" manual, keyword 
"Translation database". 
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5.4.5 "Extra > Check" menu 

Commands in the "Extra > Check" menu 
 
Objective Symbol Call Description 
Object test  "Extra > Check > Object test" You can find more information on this topic in 

the "Basic Operation" manual, keyword "Object 
test". 

Edit instances  "Extra > Check > Edit 
instances" 

You can find additional information on this topic 
in the "COMOS Administration" manual, 
keyword "Edit instances". 

Edit product data  "Extra > Check > Edit product 
data" 

Find more information on this topic in the “EI&C 
Operation" manual, keyword "Edit product data".

5.4.6 "Extra > Detail" menu 

Commands in the "Extra > Detail" menu 
 
Objective Symbol Call Description 
Modification of 
name/label 

 "Extra > Detail > Modification of 
Name/Label" 

You can find more information on this topic in 
the "EI&C Operation" manual, keyword 
"Modification of Name/Label". 

Device selection (product 
data) 

 "Extra >Detail >Device selection 
(Product data)" 

You can find more information on this topic in 
the “EI&C Operation" manual, keyword "Product 
data". 

Characteristics for 
connections 

 "Extra > Detail 
> Characteristics for connections

You can find more information on this topic in 
the “EI&C operation" manual, keyword 
"Characteristics for connections". 
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5.4.7 "Extras > Working layers/history" menu 

Commands in the "Extra > Working layers/history" menu 
 
Objective Symbol Call Description 
Management  "Extra > Working 

layers/history 
> Management" 

You can find more information on this topic in the 
"Basic Operation" manual, keyword "History 
management". 

Object status  "Extra > Working 
layers/history > Object 
status" 

You can find more information on this topic in the 
"Basic Operation" manual, keyword "Object 
status". 

Release Manager  "Extra > Working layers 
/history > Release 
Manager" 

You can find more information on this topic in the 
"COMOS Administration" and "Revisions" 
manuals, keyword "Release Manager". 

5.4.8 "Extra > Viper 3D Editor" menu 
You can open the Viper 3D visualization tool from this menu. 

Commands in the "Extra > Viper 3D Editor" menu 
 
Objective Symbol Call Description 
3D Piping  "Extra > Viper 3D Editor > 3D 

Piping" 
Electrical Engineering  "Extra > Viper 3D Editor 

> Electrical engineering" 
Symbol editor  "Extra > Viper 3D Editor 

> Symbol editor" 

You can find additional information on this topic 
in the "Viper" quickstart that is available from 
the support team. 

 

 

5.4.9 "Extra > Object matcher" menu 

"Extra > Object matcher" menu 
 
Objective Symbol Call Description 
Object Matcher  "Extra > Object matcher"  The role the object matcher is to compare and 

copy. It compares two trees sections in different 
projects. You can find more information on this 
topic in the "Inheriting, Copying, Deleting" 
manual, keyword "Object matcher". 
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5.4.10 "Extra > Cross-Project Copy" menu 

"Extra > Cross-Project Copy" menu 
 
Objective Symbol Call Description 
Copying across projects  "Extra > Cross-Project Copy" You can find more information on this topic in 

the "Inheriting, Copying, Deleting" manual, 
keyword "Cross-project copy". 

5.4.11 "Extra > Report designer" menu 

"Extra > Report designer" menu 
 
Objective Symbol Call Description 
Report designer  "Extra > Report designer" Module for creating report templates. You can 

find more information on this topic in the 
"Reports - Basic Operation" manual, keyword 
"Report designer". 

5.4.12 "Extra > Reimport" menu 

"Extra > Reimport" menu 
 
Objective Symbol Call Description 
Reimport  "Extra" > Reimport" You can find more information on this topic in 

the "Interfaces" manual, keyword "Reimport". 
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5.4.13 "Extra > Engineering tasks" menu 

"Extra > Reimport" menu 
 
Objective Symbol Call Description 
Engineering tasks  "Extra > Engineering tasks" Opens an interface for creating and executing 

engineering tasks. 
You will find additional information on this topic 
in the "Working with SIMATIC Automation 
Designer" manual, keyword "Detailed 
engineering with tasks". 

5.4.14 "Extra > Restrict working areas" menu 

"Extra > Restrict working areas" menu 
 
Objective Symbol Call Description 
Restrict working areas  "Extra > Restrict working 

areas" 
You can find more information on this topic in 
the "Rights" manual, keyword "Restrict working 
areas". 

5.4.15 "Extra > Object debugger" menu 

"Extra > Object debugger" menu 
 
Objective Symbol Call Description 
Object debugger  "Extra > Object debugger" For directly affecting objects per script. You can 

find more information on this topic in the 
"COMOS Administration" and "Rights" manuals, 
keyword "Object debugger". 
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5.4.16 "Extra > Monitoring" menu 

Commands in the "Extra > Monitoring" menu 
 
Objective Symbol Call Description 
System Monitor  "Extra > Monitoring > System 

Monitor [Ctrl+S]" 
You can find more information on this topic in 
the "COMOS Administration" manual, keyword 
"System Monitor". 

Performance Monitor  "Extra > Monitoring > 
Performance Monitor" 

You can find more information on this topic in 
the "COMOS Administration" manual, keyword 
"Performance Monitor". 

Performance Monitor 
(ListView) 

 "Extra > Monitoring > 
Performance monitor for query 
analysis" 

For analyzing queries. In this alternative display 
of the performance monitor, the interface is 
constructed without queries which distort the 
results in the analysis of queries. 

CVS Monitor  "Extra > Monitoring > CVS 
Monitor" 

To display all clients that are currently available 
via CVS. You can find more information on this 
topic in the "Infrastructure planning" manual, 
keyword "Network segments / cache 
synchronization (CVS)". 

Database performance  "Extra > Monitoring > Database 
performance" 

You can find more information on this topic in 
the "COMOS Administration" manual, keyword 
"Database performance". 
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5.5 "Plugins" menu 

5.5.1 No multiple starts 
You cannot start from a plugin with multiple instances. 

5.5.2 "Plugins > Basic" menu 

Commands in the "Plugins > Basic" menu 
 
Objective Symbol Call Description 
Define attribute colors.  "Plugins > Basic > Define 

attribute color" 
Opens the "Define attribute color" plugin. You 
can find more information on this topic in the 
"Basic Operation" manual, keyword "Define 
attribute color". 

Document interface  "Plugins > Basic > Document 
interface" 

Opens the "Document interface" plugin. You 
can find more information on this topic in the 
"Interfaces" manual, keyword "Document 
interface". 

Native object XML import 
export 

 "Plugins > Basic > Native 
Object XML Import Export" 

Opens the "Native Object XML Import Export" 
plugin. You can find additional information on 
this topic in the "Interfaces" manual, keyword 
"Native Object XML Import Export". 

Cross-class copy  "Plugins > Basic > Cross-class 
copy" 

Opens the "Cross-class copy" plugin. You can 
find more information on this topic in the 
"Inheriting, Copying, Deleting" manual, keyword 
"Cross-class copy". 

Full-text search  "Plugins > Basic > Full-text 
search" 

Opens the "Full-text search" plugin. You can 
find more information on this topic in the 
"Document Management" manual, keyword 
"Full-text search". 

Unit conversion  "Plugins > Basic > Unit 
conversion" 

Opens the "Unit conversion" plugin. You can 
find more information about this topic in the 
"COMOS Administration" manual, keyword "Unit 
conversion". 

Error analysis for 3D objects  "Plugins > Basic > 3D object 
error analyzer" 

Opens the "3D object error analyzer" plugin. 
You can find more information on this topic in 
the "PipeSpec Designer" manual, keyword "3D 
object error analyzer". 

DWG/DXF mapping editor  "Plugins > Basic > DWG/DXF 
mapping editor" 

Opens the "DWG/DXF mapping editor" plugin. 
You can find additional information on this topic 
in the "Interfaces" manual, keyword "Mapping 
editor". 

Assign line types - "Plugins > Basic > Assign line 
types". 

Opens the "Assign line types" plugin. You can 
find more information on this topic in the "P&ID" 
manual, keyword "Assign line types". 
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Objective Symbol Call Description 
Pipe Spec Mapping  "Plugins > Basic > Pipe Spec 

Mapping" 
Opens the "Pipe Spec Mapping" plugin. You 
can find additional information on this topic in 
the "P&ID" manual, keyword "Pipe spec 
mapping via the Navigator". 

Job Management  "Plugins > Basic > Job 
Management". 

Opens the "Job Management" plugin. You can 
find more information on this topic in the "Basic 
Operation" manual, keyword "Job Manager". 

Data Aggregation  "Plugins > Basic > Data 
Aggregation". 

The plugin allows you to create data lists in 
COMOS that can be grouped, similar to Excel 
lists. The level of detail for the lists can be 
controlled by grouping. 

PDMS Interface  "Plugins > Basic > PDMS 
Interface" 

Opens the "PDMS Interface" plugin. You can 
find additional information on this topic in the 
"COMOS 3D Integration Operation" manual, 
keyword "COMOS PDMS Integration". 

5.5.3 "Plugins > Maintenance" menu 

Commands in the "Plugins > Maintenance" menu 
 
Objective Symbol Call Description 
Maintenance  "Plugins > Maintenance 

> Maintenance" 
For selecting: 
 Maintenance order 
 Manual maintenance preview 
 Resource management 
 Direct 
 Maintenance demon 
You can find more information on this topic in 
the "MRO (Maintenance Repair and Overhaul)" 
manual under the keywords "Maintenance 
order", "Manual maintenance preview", 
"Resource management" and "Maintenance 
demon" and in the "Portable & Direct" manual , 
keyword "Direct". 

Events  "Plugins > Maintenance 
> Events" 

For selecting: 
 Event manager 
 Easy event 
You can find more information on this topic in 
the "MRO (Maintenance Repair and Overhaul)" 
manual, keywords "Event manager" and "Easy 
event". 
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Objective Symbol Call Description 
Shutdown  "Plugins > Maintenance 

> Shutdown" 
For selecting: 
 Shutdown management 
 Quick edit 
 Logistics 
You can find more information on this topic in 
the "Shutdown" manual, keywords "Shutdown 
management" and "Quick edit plugin". 

Resources  "Plugins > Maintenance 
> Resources" 

For selecting: 
 Resource management 
 Shift management 
 Resource monitor 
You can find more information on this topic in 
the "MRO (Maintenance Repair and Overhaul)" 
manual, keywords "Resource management", 
"Shift management" and "Resource monitor". 

Warehouse management  "Plugins > Maintenance 
> Warehouse management" 

For selecting: 
 Warehouse management 
 Goods receipt 
 Goods issuing 
You can find more information on this topic in 
the "MRO (Maintenance Repair and Overhaul)" 
manual, keywords "Warehouse management", 
"Goods receipt", "Goods issuing".  

Object search  "Plugins > Maintenance 
> Object search" 

The "Object search" plugin is used to search for 
objects throughout the entire data structure. You 
can find more information on this topic in the 
"MRO (Maintenance Repair and Overhaul)" 
manual, keyword "Object search".  

5.5.4 "Plugins > Mechatronics" menu 

Commands in the "Plugins > Mechatronics" menu 
 
Objective Symbol Call Description 
Plant and machine 
configuration 

 "Plugins > Mechatronics > Plant 
and machine configuration" 

Opens the "Plant and machine configuration" 
plugin. You can find more information on this 
topic in the "Express" manual, which you can 
obtain from Support, keyword "Plant and 
machine configuration". 

Path-time diagram  "Plugins > Mechatronics > Path-
time diagram" 

Opens the "Path-time diagram" plugin. You can 
find more information on this topic in the "ME 
Designer" manual, which you can obtain from 
Support, keyword "Path-time diagram". 
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5.5.5 "Plugins > PT" menu 

Commands in the "Plugins > PT" menu 
 
Objective Symbol Call Description 
Signal name matching  "Plugins > PT > Signal name 

matching" 
You can find more information on this topic in 
the "Instrumentation and Control" manual, 
keyword "Signal name matching". 

Signal/device assignment 
manager 

 "Plugins > Signal/device 
assignment manager" 

Find more information on this topic in the "EI&C 
Operation" manual, keyword "Signal/device 
assignment manager". 

Updating macro blocks  "Plugins > Update macro 
blocks" 

You can find more information on this topic in 
the "Logical" manual, keyword "Update macro 
blocks". 

Generic Excel import  "Plugins > Generic Excel 
import" 

Additional information about this topic is 
available in the "Automation Interfaces" manual, 
keyword "Generic Excel import". 

IEC/JIC conversion  "Plugins > PT > IEC-JIC 
conversion" 

You can find more information on this topic in 
the "EI&C Administration" manual, keyword 
"IEC to JIC". 

SPI Interface  "Plugins > SPI Interface" You can find more information on this topic in 
the "Automation Interfaces" manual, keyword 
"SPI". 

Automation - "Plugins > Automation" The following commands are available in this 
menu: 
"... > Create templates" 
"... > Import / Export PCS 7" 
You can find more information on this topic in 
the "Automation Interfaces" manual, keywords 
"Create templates" and "Data transfer PCS 7". 

5.5.6 "Plugins > PQM" menu 

Commands in the "Plugins > PQM" menu 
 
Objective Symbol Call Description 
Include documents  "Plugins > PQM > Include 

documents" 
Opens the "Include documents" plugin. 

File transfer 
 

"Plugins > PQM > File transfer" Opens the "File transfer" plugin. You can find 
additional information on this topic in the PQM" 
manual, keyword "File transfer". 

Start Excel  "Plugins > PQM > Start Excel" Starts Excel. 

Start Outlook  "Plugins > PQM > Start Outlook" Starts Outlook. 
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Objective Symbol Call Description 
Start Powerpoint  "Plugins > PQM > Start 

PowerPoint" 
Starts Powerpoint. 

Start Visio  "Plugins > PQM > Start Visio" Starts Visio. 

Start Word  "Plugins > PQM > Start Word" Starts Word. 

Viewer settings  "Plugins > PQM > Viewer 
settings" 

Opens the "Viewer settings" plugin, in which you 
can assign individual file types to specific 
viewers for display in COMOS. If a file type is 
not assigned to a viewer in COMOS, the default 
viewer of the operating system is used. You can 
find additional information on this topic in the 
"PQM" manual, keyword "Viewer settings". 

DVM Transmittal  "Plugins > PQM > DVM 
Transmittal" 

You can find additional information on this topic 
in the "PQM" manual, keyword "DVM 
Transmittal". 

5.5.7 "Plugins > ET" menu 

Commands in the "Plugins > Mechatronics" menu 
 
Objective Symbol Call Description 
EPlan5 data exchange  "Plugins > Mechatronics 

> EPlan5 data exchange" 
Opens the "EPlan data exchange" plugin. You 
can find more information on this topic in the 
"Electrical Engineering" manual, keyword 
"EPLAN data exchange". 

Ruplan import  "Plugins > Mechatronics 
> Ruplan import" 

Opens the "Ruplan import" plugin. You can find 
more information on this topic in the "Electrical 
Engineering" manual, keyword "Ruplan import". 

VNS import  "Plugins > Mechatronics > VNS 
import" 

Opens the "VNS import" plugin. Available for 
compatibility. You can find more information on 
this topic in the "Automation Interfaces" manual, 
keyword "VNS". 
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5.5.8 "Plugins > SAP" menu 

Commands in the "Plugins > SAP" menu 
 
Objective Symbol Call Description 
SAP Login  "Plugins > SAP > SAP 

Login" 
Opens the "SAP Login" plugin. You can find more 
information on this topic in the "SAP Interface" 
manual, keyword "Login".  

SAP interface configuration  "Plugins > SAP > SAP 
interface configuration" 

Opens the "SAP interface configuration" plugin. You 
can find more information on this topic in the "SAP 
Interface" manual, keyword "Interface configuration".

5.6 "Help" menu 

Commands in the "Help" menu 
 
Objective Symbol Call Description 
COMOS Platform - "Help > COMOS Platform" Opens a menu to select the PDF help files for 

COMOS Platform. 
COMOS Process - "Help > COMOS Process" Opens a menu to select the PDF help files for 

COMOS Process. 
COMOS Automation - "Help > COMOS Automation" Opens a menu to select the PDF help files for 

COMOS Automation. 
COMOS Operations - "Help > COMOS Operations" Opens a menu to select the PDF help files for 

COMOS Operations. 
Full-text search - "Help > Full-text search" For opening the full-text search. 
COMOS <version number> 
readme 

 "Help > COMOS <version 
number> readme" 

Opens a PDF help file with important 
information about the installed version. 

Show help at start - "Help > Show help at start" Option activated: Next time you start COMOS, 
the PDF help file "COMOS <version number> 
readme" will open automatically.  

COMOS info - "Help > COMOS info" Information on the installed COMOS version 
Database info - "Help > Database info" Information regarding the database in use. 
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Menu overview: Administrator 6
6.1 Using the administrator functions 

Requirement 
You have administrator rights in the open database. 

6.2 "Administrator > Script error handling" menu 

"Administrator > Script error handling" menu 
 
Objective Symbol Call Description 
Script error handling - "Administrator 

> Script error handling" 
You can find more information on this topic in 
the "Properties" manual, keyword "Script error 
handling". 

6.3 "Administrator > Base data" menu 

Commands in the "Administrator > Base data" menu 
 
Objective Symbol Call Description 
Standard tables  "Administrator > Base data 

> Standard tables" 
You can find additional information on this topic 
in the "COMOS Administration" manual, 
keyword "Standard tables". 

Unit systems  "Administrator > Base data 
> Unit systems" 

You find more information on this topic in the 
"COMOS Administration" manual, keyword "Unit 
systems". 

Document types  "Administrator > Base data 
> Document types" 

You can find more information on this topic in 
the "Document Management" manual, keyword 
"Document types". 

Import ECAD 
components 

 "Administrator > Base data 
> Import ECAD components" 

You can find more information on this topic in 
the "EI&C Operation" manual, keyword "Import 
ECAD components". 

Pipe spec management  "Administrator > Base data 
> Pipe specs" 

You can find more information on this topic in 
the "PipeSpec Designer" manual, keyword 
"Pipe specs". 
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Objective Symbol Call Description 
Bulk processing of report 
templates 

 "Administrator > Base data 
> Bulk processing of report 
templates" 

The menu opens a utility program for bulk 
processing of evaluating reports. The program 
searches and replaces text expressions. You 
can find additional information on this topic in 
the "Reports - Basic Operation" manual, 
keyword "MultiCrp.exe". 

Advanced properties  "Administrator > System > 
Extended properties" 

You can find additional information on this topic 
in the "COMOS Administration" manual, 
keyword "Extended properties". 

6.4 "Administrator > System" menu 

Commands in the "Administrator > System" menu 
 
Objective Symbol Call Description 
Support  "Administrator > System > 

Data maintenance (support)" 
The "Data maintenance (support)" dialog 
window includes a number of utility programs 
and organizational help.  
You can find more information on this topic in 
the "COMOS Administration" manual, keyword 
"Support". 

User management  "Administrator > System > 
User management" 

You can find additional information on this topic 
in the "Rights" manual, keyword "User 
management". 

Permissions  "Administrator > System > 
Permissions" 

Opens the "Permissions" plugin. You can find 
additional information on this topic in the 
"Rights" manual, keyword "Permissions". 

Database adjustment  "Administrator > System > 
Database adjustment" 

You can find more information on this topic in 
the "COMOS Administration" manual, keyword 
"Database adjustment". 

Project directory matching  "Administrator > System 
> Synchronize document 
folder" 

Synchronize document folder 
You can find more information on this topic in 
the "COMOS Administration" manual, keyword 
"Synchronize document folder". 

Numbering ranges - "Administrator > System > 
Numbering ranges" 

You can find more information on this topic in 
the "COMOS Administration" manual, keyword 
"Numbering ranges". 
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6.5 Menu "Administrator > Update Classification" 

Commands in the "Administrator > Update classification" menu 
 
Objective Symbol Call Description 
Current project  "Administrator > Update 

Classification > Current project" 
Updates the classifications from the base object 
data for the current project. You can find more 
information on this topic in the "Queries" 
manual, keyword "Performing a classification 
update". 

All projects  "Administrator > Update 
Classification > All projects" 

Updates the classifications from the base object 
data for all projects. You can find more 
information on this topic in the "Queries" 
manual, keyword "Performing a classification 
update". 
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Managing the menu bar and toolbar 7
7.1 Introduction 

Principle 
The COMOS menu bar and COMOS toolbar can be controlled with an XML file. The file 
controls: 

● The content the user can see in the COMOS menu bar 

● The toolbars used to form the COMOS toolbar and the content that is offered in them 

You have the option to create a custom file - "Main.xml". You adapt the definition of COMOS 
menu bar and COMOS toolbar to suit your requirements in this file. 

If no "Main.xml" is available, COMOS uses a standard XML file, which is managed internally 
by the system.  

If "Main.xml" is corrupt, the standard XML file is also used. If "DBMon.exe" or 
"DebugView.exe" are running, a corresponding message appears there. 

Advantage of customized XML files 
● The COMOS menu bar and COMOS toolbar can be extended by customer-specific 

content (menus, submenus, menu commands, tools). 

● The content offered by the default setting can be reduced to the content relevant to the 
given user. 
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7.2 Clone of "Main.xml" 

Principle 
You have the option to create a clone of "Main.xml": XML files that have the same XML 
structure but a different file name 

In order for a clone to be used, it must be passed as a COMOS start parameter. Passing 
start parameters is not required for the following modules:  

● Construction Assistant 

● EI&C 

● FEED 

● P&ID 

● View 

The clones are used automatically when you start the module, provided they adhere to a 
fixed naming convention.  

See also section Creating a custom XML file (Page 47). 

Evaluation sequence 
During startup, COMOS checks whether an XML file has been passed as a start parameter. 
Then COMOS checks which XML files are available and uses the first file found in the 
following order: 

1. File passed as a start parameter 

2. If COMOS has been started with the Construction Assistant, EI&C, FEED, PID or View 
modules: The module-specific clone (must adhere to the fixed naming convention) 

3. "Main.xml" 

4. If COMOS has been started with one of the modules mentioned in step 2: The internal 
system XML file for this module 

5. The internal system standard XML file 

7.3 Storage directory 
Storage directory for "Main.xml" and its clones: 

"<COMOS installation directory>\config\menu" 
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7.4 Creating a custom XML file 

Procedure 
1. Go to the directory "<COMOS installation directory>\config\menu". 

The "ExampleMain.xml" file is located there. 

2. If the file is not present, install the latest update. 

The file is copied to the directory. 

3. Open file in an XML editor or text editor that supports Unicode. 

4. Edit the XML file to meet your needs. 

  Note 
Note case-sensitive entry (upper and lower case letters) 

Your entries are case-sensitive, as described in this document. 

5. Save your changes. 

6. Rename the file. You have two options 

– Assigning standardized name: 

The file is automatically evaluated during the start of the following module: 
 

Module Name of the XML file 
Construction Assistant "CA.xml" 
EI&C "ET.xml" 
FEED "FEED.xml" 
P&ID "PID.xml" 
View "V.xml" 
Remaining modules "Main.xml" 

– Assigning name freely: The file is only evaluated when it was passed as a COMOS 
start parameter: /MN:<File name> 
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Adapting the XML file 
You have the following options: 

● Remove the nodes of menus, submenus, menu commands, or toolbars and tools that are 
not needed from the <Menu> node. 

● Register the custom menus, menu commands, etc., in the <Lib> node and use them in 
the <Menu> node. 

● Change the definition of a menu command or tool from the toolbar, which is used by the 
standard XML file. 

Examples: Change the visibility of a command or change its label, assign a command to 
a different function right as the present one 

Proceed as follows: 

– In the <Lib> node, open the <Tool> node with which the menu command or tool is 
registered. 

– Copy the node. 

With the following steps, you edit the copy. 

– Change the value of the id attribute. Use a unique identifier. 

– Adapt the attributes and subnodes. 

– In the <Menu> node, open the <Toolbar> node. 

– Search for the menu command or tool whose idref attribute uses the original id. 

– Replace the value for idref with the id you have assigned. 

See also 
Clone of "Main.xml" (Page 46) 
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7.5 Example 

Objective 
Edit a "Main.xml" to add a submenu for opening base objects to the "Extra" menu in the 
COMOS menu bar. 

Requirement 
● A "Main.xml" is available. 

● The file contains the following nodes: 

– <ComosMainMenu> <Lib> <Toolbars> <Toolbar id="MainMenu" type="MainMenu" /> 

– <ComosMainMenu> <Menu> <Toolbars> <Toolbar idref="MainMenu"> 

And the subnode <Tool idref="ID_mnuExtra"> below that.  

Procedure  
1. Open "Main.xml". 

2. Open the following node: <ComosMainMenu> <Lib> <Tools>. 

3. Add the following subnodes: 

<Tool id="ID_MyOwnAdminQueries" type="PopupMenu"> 

 <Caption>  

 <Text xml:lang="de-de" value="Meine Administrator-Abfragen" /> 

 <Text xml:lang="en-en" value="My administrator queries" /> 

 </Caption> 

 <Binding type="CDevices" root="@System|@O|@Query" /> 

 <Rights dependencyProperty="Visible" adminOnly="true" /></Tool> 

4. Open the following node: 

<ComosMainMenu> <Menu> <Toolbars> <Toolbar idref="MainMenu"> 

5. Add the following subnode: 

<Tool idref="ID_MyOwnAdminQueries" /> 

6. Save the file. 



Managing the menu bar and toolbar  
7.6 XML structure 

 Starting COMOS 
50 Operating Manual, 08/2011, A5E03638054-01 

7.6 XML structure 

7.6.1 Structure 

Overview 
The XML file for configuring the COMOS menu bar and COMOS toolbar has the following 
structure: 

 
Node layer 1 Node layer 2 Description 
<ComosMainMenu>  The parent node 
 <General> For the declaration of the used XML 

structure 
Attribute: Version 
Current: Version="1" 

 <Lib> Library for registering the basically 
available menu bars, toolbars and their 
contents 
See also section Attributes and subnodes 
of <Lib> (Page 50). 

 <Menu> Defines the content users can see in 
COMOS. 
See also section Attributes and subnodes 
of <Menu> (Page 57). 

7.6.2 Reference to node <Lib> 

7.6.2.1 Attributes and subnodes of <Lib> 

Purpose of <Lib> 
Library for registering the basically available menu bars, toolbars and their contents 

Attributes of <Lib> 
None 
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Subnodes of <Lib> and their attributes 
 
Node Attributes Description 
<Tools> - Here, you can register items in the COMOS interface that can 

be used by the menu bar and toolbars (menus, submenus, 
commands, tools).  
There is a <Tool> subnode for every item. See also section 
Attributes and subnodes of <Tool> (Page 51). 

<Toolbars> - Here, you can register the toolbars or menu bar that can be 
used in the COMOS interface. 
There is a <Toolbar> subnode for each toolbar and for the 
menu bar. See also section Attributes and subnodes of 
<Toolbar> (Page 57). 

7.6.2.2 Attributes and subnodes of <Tool> 

Purpose of <Tool> 
Each node represents an item in a toolbar or menu bar, which is basically available in the 
interface. The attributes define the properties and behavior of the item. 

Attributes of <Tool>  
 
Attribute Description 
id Must be unique. Any character string.  
type Determines the type of menu bar and toolbar item.  

Possible values: 
 PopupMenu 

A menu or submenu 

In order to create a menu with three drop-down submenus, you need 
four <Tool> nodes of the type PopupMenu. 

 Button 

A command in a menu or a button for a tool in a toolbar 
 StateButton: 

An option 
 ComboBox 

A list generated automatically by COMOS for selecting a case. 
Name: ID_ProjCasesCB 

Other lists cannot be registered. 
 Seperator 

Hyphen for optical division of menus  
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Subnodes of <Tool> and their attributes 
 

 Note 
Mandatory node 

The <Tool> node requires the following subnodes: 
 <Caption> and <Text> 
 If <Tool> for type has the value "Button" or "StateButton": <Class> or <Binding> 
 For tool buttons: <Picture> 

 

 

 
Node Attributes Description 
<Caption> - Defines the label of an item. 

The label appears in the tooltip for buttons. 
The label is read depending on the interface language 
configured in COMOS. If there is no label for the current 
interface language, the English text is read. 
Subnodes: 
 If the translations are determined by the ITX 

functionality, a <Caption> subnode is required. 
 If the translations are entered manually, a <Caption> 

subnode is required for each language. 
<Text> xml:lang or 

itx 
Subnodes of <Caption> 
There must be a separate <Text> node for each language, 
in which the label is displayed. 
All languages for which ITX support is available are 
permitted. 
xml:lang:  
 Use the following syntax: 
 xml:lang="<standard language code>" 

value="<label>" 
 Example: 

<Caption><Text xml:lang="en-en" 

value="Load"/><Text xml:lang="de-de" 

value="Laden"/></Caption> 
itx: 
 The label is determined with the ITX functionality. 
 Support from the Support required. 
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Node Attributes Description 
<Picture> key Assigns the picture specified by key to the higher-level 

<Tool> node. 
Permitted picture formats: 
 "*.ico" 
 "*jpg" 
 "*.png" 
Permitted dimensions: 16 x 16 pixels 
If the <Tool> higher-level node is an option 
(type="StateButton"), the picture is only visible when the 
option is deactivated. If the option is activated, the user 
sees a check mark. 
Value for key for a custom picture:  
 Path to the picture file 
 File name if the file is located in the following directory: 

"<COMOS installation directory>\Current\config\icons" 
<Class> type, 

progid, 
assembly, 
method 

Defines the action triggered when the user selects this item.
Values for type: 
 NET 

A .NET WPF interface opens or a .NET method is 
started. 

Sets the assembly and progid attributes. To invoke a 
method, also set the method attribute. 

 COM 

A COM plugin or COM method is started. To invoke a 
method, also set the method attribute. Values for 
progid:  

 If type="NET": The full name of the class that defines 
the .NET WPF interface 

The .NET class must have a constructor without 
parameters. 

 If type="COM": The ProgID of the plugin 
assembly: 
 Not defined if type="COM" 
 Value: The full name of the assembly, i.e. without the 

extension "*.dll" 

Custom assemblies must be located in the following 
directory: "<COMOS installation directory>\bin\Custom". 

Value for method: Name of the method that is called 
Examples: 
 NET WPF interface: 

<Class type="NET" assembly="Comos.UIF" progid= 

"Comos.UIF.UIControls.UIFormsList"/> 
 .NET method: 
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Node Attributes Description 

<Class type="NET" assembly="TestNET" 

progid="TestNET.XY" method="ABC"/> 
 COM plugin: <Class type="COM" 

progid="CPlugInWord.Word"/> 
You can find additional information about this topic in the 
"Programming" manual, keyword ".NET components for 
COMOS". 

<Rights> dependency-
Property, 
functionRights or 
adminOnly 

Locks the item or hides it, depending on the user rights. 
Values for dependencyProperty: 
 Visible 

The item is only visible when the condition set by the 
functionRights or adminOnly attribute is fulfilled. 

 Enabled 

The item can only be selected when the condition set by 
the functionRights or adminOnly attribute is fulfilled. 

functionRights: 
 Bit field for the function rights that the user must have 
 You can find the current list of the function rights and 

their constants in the "COMOS_dll" class 
documentation. 

Values for adminOnly: true or false 
Examples: 
 <Rights dependencyProperty="Enabled" 

adminOnly="true" /> 
<Binding> type, 

root 
Links the item to a base object.  
Typical application case: Opening an object query from a 
menu. Queries behave the same way in the base data and 
engineering data so that these objects can be integrated 
using a base object call. 
Values for type: 
 CDevice 

When the user selects the item, the base object 
specified by root opens. 

 CDevices 

When the user selects the item, a submenu appears 
with the base objects located below the base object 
specified by root. Base objects with base object 
references are not displayed.  

Value for root: The SystemFullName of the base object 
Example:  
<Binding type="CDevice" root="@System|@O|@Print" 
/> 

<Window> type, 
area, 
subarea, 

Only when a NET WPF interface is opened: Determines the 
behavior of the interface 
Values for type: 
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Node Attributes Description 
width, 
height, 
scaleMode, 
resizeMode, 
state 

 Tab 
– The interface is inserted in the area or subarea as a 

tab. 
– Default 

 Floating 

The interface appears as a non-modal window. The 
window and main application can be used 
interchangeably. 

 Modal 

The interface appears as a modal window. You can only 
use the main application again once you close the 
window. 

area: 
 Set only if type="Tab" 
 Value: Document 

– The tab is opened in the working area. 
– Default 

 Value: Document2 

If COMOS is used on two screens (menu bar, command 
"View > Screen 2": The tab is opened in the working 
area of the second screen. 

 Value: Navigator 

The tab is opened in the Navigator. 
subarea: 
 Set only for type="Tab" 
 Value: Detail 

The tab is opened in the detail area. 
width and heigt:  
 Set only if type="Modal" or ="Floating" 
 Width and height in the unit defined by scaleMode 
 Not for type="Tab" 
scaleMode: 
 Set only if type="Modal" or ="Floating" 
 Values: pixel or twips 
resizeMode: 
 Set only if type="Modal" or ="Floating" 
 Values: NoResize or Resize (default) 
autoClose: 
 Set only if type="Modal" or ="Floating" 
 Value: true 

Default 
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Node Attributes Description 

The window closes automatically with a project change 
or database change. 

 Value: false 
state: 
 Defines whether the tab or a card is fixed or its contents 

are replaced the next time you open an object of the 
same type. 

 Values: 
– Reuse: "Reuse tab/window" button is green (not 

fixed). The user can switch to yellow (fixed). 
– Unique: The "Leave tab/window open" button is 

yellow. The user can switch to green (reuse). 
– ReuseOnly: The button is green. It is not possible to 

switch to yellow. 
– UniqueOnly: The button is yellow. It is not possible 

to switch to green. 
Example: 
<Window type="Floating" width="9045" 
height="6810" scaleMode="twip" 
resizeMode="NoResize" /> 

Combining the <Tools> node 
When a custom XML file is available, COMOS does the following: 

● COMOS combines the custom file and the standard file to form the contents of the 
<Lib><Tools> node. 

● If two <Tool> nodes from the custom file and standard file have the same value for id, the 
definition from the standard file is given priority. 
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7.6.2.3 Attributes and subnodes of <Toolbar> 

Purpose of <Toolbar> 
Each node represents a toolbar or menu bar, which is basically available in the interface. Its 
attributes define the properties and behavior of the toolbar or menu bar. 

Attributes of <Toolbar> 
 
Attribute Description 
id Must be unique. Any character string.  
type Determines the type of bar.  

Possible values: 
 MainMenu 

COMOS menu bar 
 Toolbar 

A toolbar of the COMOS toolbar 

Subnode 
<Toolbar> can have the <Rights> subnode. The node has the same attributes as the node of 
the same name under <Tool>. 

See also 
Attributes and subnodes of <Tool> (Page 51) 

7.6.3 Reference to node <Menu> 

7.6.3.1 Attributes and subnodes of <Menu> 

Purpose of <Menu> 
Defines the content displayed in the COMOS interface. 

Attributes of <Menu> 
None 
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Subnode of <Menu> and it attributes 
 
Node Attributes Description 
<Toolbars> - Here you define the menu bars and toolbars the user can see 

in COMOS. 
Subnodes: There is a <Toolbar> subnode for each bar. 
See also section Attributes and subnodes of <Toolbar> 
(Page 58). 

7.6.3.2 Attributes and subnodes of <Toolbar> 

Purpose of <Toolbar> 
Each node represents a toolbar or menu bar, which the user can see in COMOS. 

Attributes of <Toolbar> 
 
Attribute Description 
idref Reference to a toolbar or menu bar registered in the <Lib><Toolbars> 

node 
The value of idref must be identical to the value assigned to the 
corresponding <Toolbar> node in the library with the id  attribute.  
Example: 
<Lib> 
   <Toolbars> 
      <Toolbar id="Query_Main" type="Toolbar" /> 
   </Toolbars> 
</Lib> 
<Menu> 
   <Toolbars> 
      <Toolbar idref="Query_Main" /> 
   </Toolbars> 
</Menu> 



 Managing the menu bar and toolbar 
 7.6 XML structure 

Starting COMOS 
Operating Manual, 08/2011, A5E03638054-01 59 

Subnodes of <Toolbar> and their attributes 
Under <Toolbar>, you define the toolbar and menu bar items the user sees in COMOS 
(menus, submenus, menu commands and tools). There is a Tool node for every item.  

Attributes of <Tool>: 

 
Attribute Description 
idref Reference to a toolbar or menu bar item registered in the <Lib><Tools> 

node 
The value of idref must be identical to the value assigned to the 
corresponding <Tool> node in the library with the id  attribute.  
Example: 
<Lib> 
   <Tools> 
      <Tool id="id_MenuView" type="PopupMenu" /> 
   </Tools> 
</Lib> 
<Menu> 
   <Toolbars> 
      <Toolbar idref="MainMenu" > 
         <Tool idref="id_MenuView> ... <Tool/> 
      </Toolbar> 
   </Toolbars> 
</Menu> 

Subnodes of <Tool> 
Only when the node referenced via idref is a PopupMenu type. In this case, there is a <Tool> 
subnode under <Tool> for each submenu. 
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