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This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

DANGER  
indicates that death or severe personal injury will result if proper precautions are not taken. 

 

WARNING  
indicates that death or severe personal injury may result if proper precautions are not taken. 

 

CAUTION  
with a safety alert symbol, indicates that minor personal injury can result if proper precautions are not taken. 

 

CAUTION  
without a safety alert symbol, indicates that property damage can result if proper precautions are not taken. 

 

NOTICE  
indicates that an unintended result or situation can occur if the corresponding information is not taken into 
account. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation for the specific task, in particular its warning notices and 
safety instructions. Qualified personnel are those who, based on their training and experience, are capable of 
identifying risks and avoiding potential hazards when working with these products/systems. 

Proper use of Siemens products 
Note the following: 

WARNING  
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be adhered to. The information in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of the Siemens AG. The remaining trademarks in this 
publication may be trademarks whose use by third parties for their own purposes could violate the rights of the 
owner. 

Disclaimer of Liability 
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described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
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editions. 
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Preface 

Scope and standards 
This document is part of the Engineering System Handling documentation package. 

Scope of validity 
This manual applies to SIMOTION SCOUT in association with the SIMOTION Cam Tool 
option package for product version V4.2. 

Sections in this manual 
The following is a list of chapters included in this manual along with a description of the 
information presented in each chapter. 
● Overview 

This chapter contains an overview of the SIMOTION SCOUT Engineering System. 
● Installing software 

This chapter contains the system requirements for SIMOTION SCOUT, describes the 
procedure for installing and uninstalling it, and provides important information on the 
communications link to the SIMOTION device. 

● Functions 
This chapter describes the basic steps for operating SIMOTION SCOUT. The SIMOTION 
SCOUT workbench and HW Config are explained.  
An important tool is provided in the form of the SIMOTION SCOUT online help, for 
example. This chapter contains basic information about this topic. Additional functions 
such as the licensing of the runtime components and the replacement of the SIMOTION 
device are also described. 

● Product combinations 
This chapter describes topics such as compatibility and storage media as well as STEP 
7, NetPro, Drive ES, HMI, and other interfaces. 

● Diagnostics 
It also contains information about which diagnostic functions are available and how these 
are operated. 

● FAQs 
This chapter contains handling recommendations for service with SCOUT V4.1. It 
explains how projects are created and edited.  
The process of inserting and commissioning drives is described. It contains general 
information and special applications. 

● Index 
Index 
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SIMOTION Documentation 
An overview of the SIMOTION documentation can be found in a separate list of references.  
This documentation is included as electronic documentation in the scope of delivery of 
SIMOTION SCOUT. It comprises 10 documentation packages.  
The following documentation packages are available for SIMOTION V4.2: 
● SIMOTION Engineering System 
● SIMOTION System and Function Descriptions 
● SIMOTION Service and Diagnostics 
● SIMOTION IT 
● SIMOTION Programming 
● SIMOTION Programming - References 
● SIMOTION C 
● SIMOTION P 
● SIMOTION D 
● SIMOTION Supplementary Documentation 

Hotline and Internet addresses 

Additional information 
Click the following link to find information on the the following topics: 
● Ordering documentation/overview of documentation 
● Additional links to download documents 
● Using documentation online (find and search in manuals/information) 
http://www.siemens.com/motioncontrol/docu 
Please send any questions about the technical documentation (e.g. suggestions for 
improvement, corrections) to the following e-mail address: 
docu.motioncontrol@siemens.com 

My Documentation Manager 
Click the following link for information on how to compile documentation individually on the 
basis of Siemens content and how to adapt this for the purpose of your own machine 
documentation: 
http://www.siemens.com/mdm 

Training 
Click the following link for information on SITRAIN - Siemens training courses for automation 
products, systems and solutions: 
http://www.siemens.com/sitrain 
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FAQs 
You can find Frequently Asked Questions on the Service&Support pages under Product 
Support: 
http://support.automation.siemens.com 

Technical support 
Country-specific telephone numbers for technical support are provided on the Internet under 
Contact: 
http://www.siemens.com/automation/service&support  
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Description 1
1.1 Description 

The SIMOTION SCOUT Configuration Manual is a general description of the software. Not 
all available software functions are described in this document. All detailed, subject-specific 
information can be found in the context-sensitive online help and the corresponding 
documentation. 
Important notes and information on the SIMOTION Motion Control system are contained in 
the following catalog: 
● SIMOTION, SINAMICS S120 and Motors for Production Machines, PM 21 Catalog 

1.2 SIMOTION SCOUT Engineering System general 

Introduction 
While the Motion Control system SIMOTION provides a wide variety of preprogrammed 
functions, it is also parameterizable and programmable for individual requirements. High-
performance tools, which provide optimum support and ease of use for the necessary 
engineering steps, are required for this. 
The SIMOTION SCOUT Engineering System is the environment for the uniform automation 
of production machines with SIMOTION and integrates into the SIMATIC environment in 
accordance with TIA (Totally Integrated Automation). 
SCOUT provides a uniform, function-oriented view for your automation task and at the same 
time is very easy to use. 
The possible SIMOTION applications range from simple, parameterizable, speed-controlled 
single axes through to complex, mechatronically-coupled and programmable multi-axis 
machines. Therefore, SIMOTION SCOUT provides views adapted to the task and can be 
expanded with additional tools (e.g. tool for the graphic creation of cams). 
SIMOTION SCOUT is the engineering system for SIMOTION. It is integrated into STEP 7 
and provides all the required tools for the following functionalities:  
● Configuration 
● Parameterization 
● Programming 
● Testing 
● Diagnostics. 
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The following tasks are graphically supported with operator guidance: 
● Creation of the hardware and network configuration 
● Creation, configuration and parameter assignment of technology objects  

such as axes, output cams and cams. 

 
Figure 1-1 SIMOTION system overview  

The automation topology is defined in the first engineering steps. The hardware and network 
configuration is created by parameterizing the required components and networks. 
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1.3 Procedure for creating the project 

Steps to create a project 
Machine automation is implemented step by step as the project is created: 
● First create a new project. 
● Create the device (SIMOTION D, SIMOTION C, SIMOTION P). 
● Then, you create the system configuration that describes the structure of the automation 

topology: 
– Which hardware components (drives, SIMOTION hardware platform, I/O) are you 

going to use? 
– How are they interconnected? 

● The basic parameterization of the hardware components and networks is then performed. 
SIMOTION SCOUT does this using two field-proven STEP 7 programs: HW Config and 
NetPro. 

● In the next step, the technology objects are configured, supported by wizards. 
● Select the programming language (MCC, ST, LAD/FBD or DCC). 
● The download to the SIMOTION device is performed and 
● test the machine application. 

1.4 Workbench 

What is the SIMOTION SCOUT workbench?  
The workbench is the SIMOTION user interface and is, therefore, the common framework for 
all other tools in the Engineering System. The workbench is also the navigation center for the 
individual engineering steps. It is used to create and manage SIMOTION projects and 
provides a uniform and integrated view of all data and programs.  

Workbench features 
The workbench is: 
● An integrated and intuitively operated engineering system 
● Enables central data and program management, even for distributed systems 
● A function-oriented, technological project structure with filterable views 
● Enables quick access to individual engineering tools, such as configuration, 

programming, and commissioning. 
You will find further information on the workbench at: Getting to know the workbench 
(Page 27) 
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1.5 Technology packages and technology objects 

Technology packages in SIMOTION SCOUT 
Technology packages combine software functions which are required for automation in 
mechanical engineering in various sectors.  
The following standard technology packages are available for SIMOTION: 
● TP CAM 

contains the basic Motion Control technologies, such as drive axis, position axis, 
following axis, synchronous object, cam, output cam, cam track, and measuring input 

● TP PATH 
also contains the path interpolation technology 

● TP CAM_EXT 
contains additional objects for preparing technological data on the system level, e.g. 
addition object, formula object 

● TControl 
contains the temperature controller technology. 

● DCBlib 
contains interconnectable DCC blocks (DCC stands for Drive Control Chart) for drive-
related controller functions. 

● More sector-specific technology packages are also available as separate products. 
Access to the technology package functions is carried out via additional language 
commands and system variables. Programming of motional sequences is therefore simple 
and integrated. 
The Motion Control Basic, Position and Gear technology packages were available for earlier 
versions.  
As from SIMOTION SCOUT Version V3.2, they are contained in the Cam technology 
package. 
Once the basic project structure has been created by the system configuration, the next step 
is to define the technology objects (axes, output cams, cams, etc.) required for the 
automation task. This defines the volume of project data that must be assigned parameters 
for the purpose of commissioning. 

Technology objects in SIMOTION SCOUT 
The technology objects (TOs) are inserted directly into the folders provided in the project 
navigator. These are completed with the associated parameterization tool or commissioning 
tool.  
The next step is to program the SIMOTION devices. The SIMOTION SCOUT engineering 
system provides user-friendly and efficient programming languages to describe the individual 
functions of the machine process. 
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Additional references 
Please refer to the following documents on these subjects 
● SIMOTION Basic Functions Funtion Manual 
● SIMOTION Motion Control, Basic Functions, Description of Functions for modular 

machines 
● Function Manual: SIMOTION Motion Control, TO Axis, Electric/Hydraulic, TO External 

Encoder 
● Function Manual: SIMOTION Motion Control, Synchronous Operation TO, TO Cam 
● Function Manual: SIMOTION Motion Control Output Cams and Measuring Inputs 
● Function Manual: SIMOTION Motion Control, Path Interpolation TO 
● SIMOTION Communication System Manual 
● Function Manual: SIMOTION Motion Control, Supplementary Technology Objects 
● Configuration Manual: SIMOTION CamTool 
and the online help. 

See also 
Selecting technology packages (Page 57) 
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1.6 Programming languages 

1.6.1 Programming languages in SIMOTION SCOUT 
Access to the technology packages and functions is carried out in the same way as access 
to the SIMOTION Kernel via language commands from the user program.  
The programming languages in SCOUT provide all of the language commands required to 
implement the functions simply and quickly. The SIMOTION runtime system also supports 
cyclic, sequential, time-controlled, and event-driven programming. 
The programming languages are: 
● Motion Control Chart (MCC)  

If you want to program graphically, you can use MCC for sequential flowchart-oriented 
programming.  

● Ladder Logic/Function Block Diagram (LAD/FBD) 
The familiar programming methods using LAD/FBD are also available in the SCOUT 
Engineering System for user-friendly logic programming, supplemented with 
motion control functions via PLCopen function blocks.  

● Structured Text (ST) 
If you prefer a high-level language for your automation task, ST is available as an efficient 
and IEC 61131-3-compliant text-based language.  

● Drive Control Chart (DCC) 
Many applications require a combinatorial logic that combines several states (e.g. access 
control, plant states) to form a control signal (e.g. ON command) for controlling the drive 
system. 
In addition to the logical operations, arithmetic operations and storing elements are 
increasingly required in drive systems. 
This functionality is available as Drive Control Chart (DCC) on drive objects of the 
SINAMICS drive system and the SIMOTION control system. 
The Drive Control Chart Editor (DCC editor), based on CFC, can be used to graphically 
configure SIMOTION controllers and SINAMICS drives.  
For further information, see the chapter titled DCC Programming System (Page 171) 

A variety of programming languages can be combined in a single project. 
The user program is executed in various tasks. A task is a job which is executed in a certain 
chronological sequence. The advantage of the task system is that processes hung in the 
appropriate task levels can run in parallel.  
The SIMOTION motion control system uses high-performance CPUs on which a realtime 
operating system suitable for fast control processes is implemented. Each task is allocated a 
slice of the computing time. The organization of the task sequences is performed by the 
operating system. A differentiation is made between user and system tasks that are 
independent of one another. 
Various debug functions are possible in the programming languages. Please refer to the 
appropriate programming manuals for more detailed information. 
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1.6.2 Graphics-based flowchart programming with MCC 

Motion Control Chart 
The idea behind MCC is to formulate the process sequences in the machine using simple 
and logical expressions. The result is one or more flowcharts showing the chronological 
sequence of the individual actions. As production machines are primarily concerned with 
controlling the motion of a large number of individual axes, MCC particularly supports the 
simple description of these motion sequences with powerful Motion Control commands. 
To control the machine, commands are available for awaiting the fulfillment of conditions and 
for formulating computations, as well as for executing various control structures, such as 
polling (IF), case determination (CASE), and loops (FOR, WHILE, UNTIL). Several MCC 
programs may be created to describe different process situations. For example, you can 
create one MCC program to bring the machine to a defined initial state when it is switched 
on, a second MCC program for the normal production sequence, and a third MCC program 
to specify what the machine is to do in the event of a fault. 
All commands are available in toolbars, sorted according to command groups. Clicking a 
command in the toolbar automatically incorporates it at the position marked in the flow chart. 
Double-clicking a command in the flow chart opens a specific dialog box for assigning 
parameters to this command. 
Performance features: 
● Easy-to-use due to graphics-based representation in flowcharts. 
● Hierarchical command library for Motion Control, PLC, and technology functions. 
● Control structures (IF, WHILE, CASE, etc.) 
● Conditions can be created in different languages. The chart can then be displayed in an 

arbitrary language. Plain text can be created in an MCC with the ST zoom. 
● Structuring based on command modules, i.e. combination of command sequences to 

create a command module. Clicking the command module invokes the corresponding 
command sequence. 

● Easy-to-use debug functions for online testing and diagnostics: E.g. single-step or 
program status mode for easier troubleshooting (debugging). 

Additional references 
Please refer to the following document on this subject 
● SIMOTION MCC Motion Control Chart Programming and Operating Manual 
and the online help. 
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1.6.3 Graphics-based programming language with LAD/FBD 

Ladder Logic / Function Block Diagram 
LAD/FBD stand for ladder logic and function block diagram. LAD/FBD are graphics-based 
programming languages. The statement syntax corresponds to a circuit diagram. LAD/FBD 
enable simple tracking of the signal flow between power rails via inputs, outputs, and 
operations. LAD/FBD statements consist of elements and boxes, which are graphically 
connected to networks. LAD/FBD operations follow the rules of Boolean logic. 
The programming language provides all the elements required for the creation of a complete 
user program. LAD/FBD features an extensive command set. This includes the various basic 
operations with a comprehensive range of operands and how to address them. The design 
of the functions and function blocks enables you to clearly structure the LAD/FBD program. 
The LAD/FBD programming package is an integral part of the basic SIMOTION software. 
Easy-to-use debug functions for online testing and diagnostics are available: E.g. monitoring 
of the variable values, program status and stopping points. 

Additional references 
Please refer to the following document on this subject 
● SIMOTION LAD/FBD Programming and Operating Manual 
and the online help. 
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1.6.4 High-level language programming in ST 

Structured Text  
ST is a high-level, PASCAL-based programming language. This language is based on the 
IEC 61131-3 standard, which standardizes programming languages for programmable 
controllers (PLC). 
The basic command scope is sufficient for the implementation of everything related to data 
management, arithmetic functions, control structures, and I/O access. The addition of 
technology packages for Motion Control expands the scope of commands by further 
comprehensive, extremely flexible Motion Control commands (e.g.: _pos(..) for axis 
positioning). 
In addition, applications can be subdivided into any number of sections. Such a section 
might be a program allocated to a runtime level, an instantiatable function block with its own 
memory, or a function without its own memory. In this case, the function blocks and functions 
are not allocated to a runtime level, but are instead called in programs. 
● Motion control, PLC and technology functions in a single language 
● Well structured programs with comment capability 
● High-performance editor functions, such as 

– Syntax coloring 
– Automatic indenting 
– Automatic completion 
– Bookmarks 
– Fold (show and hide blocks) 
– Display pairs of brackets 
– Select text, e.g. by column 
– Using the command library 

● Easy-to-use debug functions for online testing and diagnostics: e.g. display of up-to-date 
variable content of the code sequence selected in the editor (program status) and 
stopping points. 

Additional references 
Please refer to the following document on this subject 
● SIMOTION ST Structured Text Programming and Operating Manual 
and the online help. 
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1.7 CamEdit cam editor 
CamEdit can be used to describe curves by means of either interpolation points or 
segments. A combination is not possible. If the curve is to be created from segments using 
polynomials, SIMOTION SCOUT provides the VDI wizard to assist in creation of the curve. 
Cam geometries are created in offline mode. 
Information on the graphical creation of cams can be found in the CamTool (Page 170) 
section. 
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Installing software 2
2.1 SCOUT and SCOUT Standalone system requirements 

Minimum requirements of the system  
The readme file on the SIMOTION SCOUT DVD contains information on SIMOTION SCOUT 
and SCOUT Standalone system requirements; alternatively, you can access this information 
after installation via Start -> All Programs -> Siemens -> Information -> English. 

 

 Note 
Simultaneous operation of SIMOTION SCOUT, Starter and SIMATIC S7-Technology on one 
PC is not intended and is not possible. 
SIMATIC S7-Technology is integrated in SIMOTION SCOUT V4.0 and higher. 

 

2.2 To install the software 

2.2.1 Installing SIMOTION SCOUT 
SIMOTION SCOUT and SCOUT Standalone are both available as software packages 
including full license and upgrade license. The installation process is identical for both 
versions. 

Requirements: 
● SIMATIC STEP 7 is installed. 
● You are logged on to the operating system with administrator rights. 

 

 
 

Note 
Read the readme file and the important information on the SIMOTION SCOUT Add-Ons 
DVD contained in the SCOUT software package. 

 

To install SIMOTION SCOUT 
1. Insert the DVD 1 with SIMOTION SCOUT into the CD-ROM drive. 
2. Start Windows Explorer and select the CD-ROM drive. 
3. Open the root directory on the DVD. 
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4. Double-click Setup.exe. 
5. Now follow the instructions in the installation program. 

The installation program prompts you to insert or connect the supplied data medium 
which contains the authorization. You can install the authorization as part of this setup. Or 
install the authorization with the Automation License Manager after installing 
SIMOTION SCOUT.  
Information on this can be found in the section titled "To install the authorization". 

6. If a restart of the PC is required during the installation, carry this out. 
After the restart of the operating system, log on at least as main user. 

7. After the installation:  
Restart the PC and log on at least as main user. 

All users who are logged on as main user are now able to start and operate 
SIMOTION SCOUT. 

2.2.2 Installing SIMOTION SCOUT Standalone 

Requirements 
● No SIMATIC STEP7 must be installed or 
● No previous version of SIMOTION SCOUT Standalone must be installed. 
● You are logged on to the operating system with administrator rights. 

 

 
 

Note 
Read the readme file and important information on the Add-On CD supplied with SCOUT.

 

To install SIMOTION SCOUT Standalone  
1. Insert DVD 1 with SIMOTION SCOUT Standalone into the CD-ROM drive. 
2. Start Windows Explorer and select the CD-ROM drive. 
3. Open the root directory on the DVD. 
4. Double-click Setup.exe. 
5. Now follow the instructions in the installation program. 

The installation program prompts you to insert or connect the supplied data medium 
which contains the authorization. You can install the authorization as part of this setup. Or 
install the authorization with the Automation License Manager after installing 
SIMOTION SCOUT.  
Information on this can be found in the section titled "To install the authorization". 

6. A restart of the PC is required during the installation, carry this out. You are requested to 
insert CD"/". 
After the restart of the operating system, log on at least as main user. 

7. After the installation:  
Restart the PC and log on at least as main user. 
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All users who are logged on as main user are now able to start and operate 
SIMOTION SCOUT. 

2.2.3 SINAMICS Support Package (SSP) 
You can use a SINAMICS Support Package (SSP) to upgrade the version of the drive units 
on a STARTER integrated into SIMOTION SCOUT.  
This permits the use of new functions which only become available with new drive unit FW 
versions.  
SSPs are available when installing SCOUT or can be installed at a later time.  
In this regard, the following SSPs are relevant for SIMOTION SCOUT:  
● "SINAMICS" SSP for upgrading single drive units (e.g. CU3xx) 
● "SIMOTION SINAMICS Integrated" SSP for upgrading the SINAMICS drives integrated 

into SIMOTION D. 
The readme files for the relevant SSP contain detailed information regarding installation. 

2.3 To install the authorization 

Installing the authorization for SIMOTION SCOUT 
A data medium containing the authorization is supplied along with the product CD so that 
you can use SIMOTION SCOUT. This contains the license key for the SIMOTION SCOUT 
Engineering System.  

The authorization for SIMOTION SCOUT and SIMOTION SCOUT Standalone can be installed as 
follows: 

1. Connect or insert the data medium containing the authorization and the license key. 
2. Start the Automation License Manager: 

– Via the start menu 
Start > SIMATIC > License Management > Automation License Manager or 

– Double-click the Automation License Manager icon 
3. In the navigation area (left-hand window), select the drive where the data medium 

containing the authorization is located. The license key is displayed in the right-hand 
window. 

4. Mark the license key and drag this with drag-and-drop to the target drive. 
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5. Exit the Automation License Manager. 
6. Remove the data medium containing the authorization. 

 

 
 

Note 
Information on operating the Automation License Manager and transferring the 
license key can be found in the online help for the Automation License Manager. 

 

The authorization for SIMOTION SCOUT and SIMOTION SCOUT Standalone can be upgraded as 
follows: 

As of Version 4.0, the authorization for SIMOTION SCOUT has been upgraded from 
authorization (single license) to the licensing procedure involving a floating license. The 
Automation License Manager program is used to manage the licenses. 
1. Connect or insert the data medium containing the authorization and the upgrade license 

key.  
2. Start the Automation License Manager: 

– Via the start menu 
Start > SIMATIC > License Management > Automation License Manager or 

– Double-click on the Automation License Manager 
 icon. A new window will open. 

3. In the navigation area (left-hand window), select the drive where the authorization for the 
old version of SIMOTION SCOUT is located. Generally the authorization will be installed 
on a hard disk drive on the PC. 

4. Transfer the authorization to the data medium containing the upgrade license key. 
To do this, select the license in the right-hand window and select 
License key > Transfer... via the menu. 

5. In the Transfer license key dialog, select the connected data medium. Start the transfer 
by clicking OK. 
The authorization and upgrade license key will then be located on the data medium. 

6. Select License key > Upgrade... in the menu. 
The previous authorization will be deleted and a new floating license will be available 
once the upgrade is complete. 

 

 
 

Note 
Do not interrupt the upgrade while it is in progress. Interrupting this process can lead to 
the license key being lost. 

 

7. Now transfer the new floating license onto the hard disk drive. To do this, follow the same 
procedure as before: Via License key > Transfer... in the menu 

8. After the transfer has completed successfully, remove the automation data medium. 
9. Exit the Automation License Manager. SIMOTION SCOUT can now be operated without 

restrictions. 
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2.4 Saving and moving the license key 

Saving and moving the license key 
You can transfer the license key to a removable disk. This is useful when you want to save 
the license key when reinstalling a PC or when you want to use it on another PC. A copy of 
the license key is not created during this operation, it is moved. 

 

 Note 
More detailed information on the license keys can be found in the online help for the 
Automation License Manager. 

 

2.5 To uninstall the software 

Requirements:  
You are logged on to the operating system with administrator rights. 

 

 Note 
Note that the SIMATIC STEP7 must be uninstalled separately. 

 

To uninstall SIMOTION SCOUT from the hard disk 
1. Open the system control via Start > Settings > System control. 
2. Double-click Software. 
3. Select SIMOTION SCOUT x.x and click Change/Remove or Add/Remove. Follow the 

instructions. 
4. Once the above software has been uninstalled, restart the computer. 

Uninstalling SIMOTION SCOUT Standalone  
Uninstall SIMOTION SCOUT Standalone as described in the "How to uninstall 
SIMOTION SCOUT from the hard disk" section. 
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2.6 Language setting of the SIMOTION SCOUT 

Language setting of the SIMOTION SCOUT 
SIMOTION SCOUT uses the language default setting in the SIMATIC Manager. You can 
make changes to this setting in the SIMATIC Manager via the 
Options > Settings... > Language menu. 
German, English, French and Italian languages are currently available in SIMOTION 
SCOUT. If a different language is set in the SIMATIC Manager, SIMOTION SCOUT uses the 
English setting. 

 

 Note 
Only those languages installed in STEP 7 are available. 
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Functions 3
3.1 Getting to know the workbench 

Additional references 
Please refer to the following documents on this subject 
● SIMOTION Basic Functions Function Manual 
● Function Manual: SIMOTION Motion Control, TO Axis, Electric/Hydraulic, TO External 

Encoder 
● Function Manual: SIMOTION Motion Control, Synchronous Operation TO, TO Cam 
● Function Manual: SIMOTION Motion Control, Supplementary Technology Objects 
● Function Manual: SIMOTION Motion Control Output Cams and Measuring Inputs 
● Function Manual: SIMOTION Motion Control, Path Interpolation TO 
● Function Manual: SIMOTION Motion Control, Basic Functions for Modular Machines 
and the SIMOTION SCOUT online help. 

 

 Note 
We recommend that you run through Getting Started with SIMOTION SCOUT in the online 
help. This is a series of guided steps which teaches you how to work with SIMOTION 
SCOUT. For example, how to create, compile, and save a project, insert a SIMOTION 
device, insert and assign parameters for a technology object, and create a program.  
When you have worked through all these steps, you will be able to create more complex 
projects. 

 

 Note 
It is not recommended that you open one SIMOTION SCOUT project twice. This application 
case can result in malfunctions and is not supported by SIMOTION SCOUT. If you want to 
open two different projects, you must open SIMOTION SCOUT twice. 
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The SIMOTION workbench 
The SCOUT workbench is the common framework for all other tools of the engineering 
system. The workbench is also the navigation center for the individual engineering steps. It is 
used to create and manage SIMOTION projects and provides a uniform and integrated view 
of all data and programs.  
The SCOUT workbench offers a basic display split into three views: 
● Project navigator (left Workbench area) 

The project navigator shows the technical tree structure of the project. 
● Working area (right-hand area of the workbench) 

All editing tools of the engineering system, e.g. parameterization dialog boxes, program 
editors etc. are available in the working area as snap-ins. 
A snap-in is a program that is automatically integrated in the working area of the 
SIMOTION SCOUT workbench. Snap-ins provide functions for the editing of 
SIMOTION SCOUT projects. Snap-ins are displayed in the working area of the 
workbench as working windows. Several snap-ins can be opened in order to be able to 
work in these. The opened snap-ins are displayed as tabs in the working area. The active 
snap-in is visible in the foreground. Examples are:  
– Program editors: 
– Wizards for the configuration of technology objects 
– Device diagnostics 
– Drive navigator 

● Detail view (lower area of the workbench) 
The detail view displays data and messages that vary according to the situation. 
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Figure 3-1 Workbench view 

Workbench elements 
The elements of the Workbench are:  
● Menu bar: 

You call the functions of SIMOTION SCOUT via the menus in the menu bar.  
● Toolbars: 

Frequently used menu commands are also available in toolbars, which can be activated 
or deactivated as required. These provide quick access to the functions. The toolbars can 
be undocked from the top and relocated to a different position (right, left, lower border or 
as a window).  

● Project navigator: 
The project navigator provides an overview of the entire project. All defined elements, 
such as devices, drives, axes, etc., are displayed here in a tree structure.  
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● Working area: 
The task-specific windows are displayed in the working area. In these windows, you can 
perform the configuration with wizards for the axis configuration and drive configuration. 
You also create programs in the working area. Further information about the active 
window in the working area is provided in the detail view.  

● Detail view 
More detailed information about the element selected (marked) in the project navigator or 
the active window in the working area is displayed in the detail view. For example, 
variables of a program, system variables of a technology object or logs during the 
compilation of program sources.  

3.2 Menu structure 

3.2.1 Main menus 
The SIMOTION SCOUT menus are divided into different main menus.  
● Main menus that are primarily used to control the workbench or a project are always 

displayed. These main menus are also called static menus. 
● In addition, the Edit and Insert  main menus are continually displayed if a project has 

been loaded. 
● The main menu in the third position, between Project and Edit, is a dynamic menu.  

Each snap-in supplies its own specific main menu to be displayed in this position. Always 
the main menu that has been selected in the project navigator and therefore active in the 
working area is displayed.  
In addition, each snap-in can incorporate its own menu items in the static main menus, 
primarily in the Edit and Insert main menus. 

Table 3- 1 Structure of the menu bar 

Menu Comment 
Project Static menu, always visible 
(Dynamic menu) See Dynamic menus table 
Edit Static menu, visible only when project has been loaded 
Insert Static menu, visible only when project has been loaded 
Target system Static menu, always visible 
View Static menu, always visible 
Options Static menu, always visible 
Window Static menu, always visible 
Help Static menu, always visible 
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Table 3- 2 Dynamic menus 

Dynamic menu Comment 
Axis 
Output cam 
Measuring input 
Synchronous operation 
Cam 
External encoder 
Sensor 
Controller object 
Drive 
Fixed gear 
Formula object 
Addition object 
Drive control panel 
Trace 
ST source file 

Visible only when a project has been loaded and the associated 
snap-in is active in the working area. 
Dynamic menus appear in the third position on the menu bar, 
between Edit and Insert. 

MCC unit 
MCC chart 
LAD/FBD source 
LAD/FBD program 

Visible only when a project has been loaded and the associated 
snap-in is active in the working area. 
Dynamic menus appear in the second position on the menu bar, 
between Project and Edit. 

3.2.2 Keyboard action and shortcuts 
 

 Note 
There are various keyboard assignments and shortcuts for the menu items to facilitate your 
work in SIMOTION SCOUT. 

 

The following table provides an overview of the keyboard assignments and shortcuts that 
you can use for SIMOTION SCOUT.  

Table 3- 3 Keyboard action 

Keyboard action / shortcuts Meaning 
Workbench: Change window... 
ALT+0 Project navigator 
ALT+1 Working area 
ALT+2 Detail view 
CTRL+F6 Next window in the working area 
CTRL+F11 Minimize/maximize working area in relation to the whole 

desktop 
CTRL+F12 Minimize/maximize detail view in relation to the whole desktop 
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Project navigator 
Left mouse button Selects the tree object at the cursor position; 

detail view displays the associated details 
Double-click with left mouse button Selects the tree object at the cursor position; 

detail view displays the associated details; 
corresponding snap-in is opened 

Right mouse button Selects the tree object at the cursor position; 
detail view displays the associated details; 
context menu is opened 

UP/DOWN arrow keys Selects the tree object at the cursor position 
"Return" Snap-in for the selected tree object opens 
"Context menu key" Context menu for the selected tree object opens 

3.2.3 Menu items 
You can use the shortcuts listed in the table to call the menu items available in 
SIMOTION SCOUT.  

Table 3- 4 Menu items in SIMOTION SCOUT 

Shortcuts Menu item Reaction 
Project... 
CTRL+N New Creates a new project 
CTRL+O Open Opens a project 
Ctrl+S Save Saves a project 
CTRL+ALT+K Check consistency Checks project consistency 
CTRL+ALT+B Save and compile 

changes 
Saves the project and compiles the changes 
made in the project since the last compilation 

CTRL+P Print Prints the selected window 
ALT+F4 Exit Exits the SIMOTION SCOUT program 

 

 
Shortcuts Menu item Reaction 
Edit... 
Ctrl+Z Undo Undoes the last action 
Ctrl+Y Redo Redoes the last action 
Ctrl+X Cut Cuts the selection 
Ctrl+C Copy Copies the selection 
Ctrl+V Paste Inserts the clipboard contents 
Del Delete contents Deletes the selection 
F2 Rename Renames the selected tree object 
ALT+Enter Object properties Displays the properties of an object in the 

project tree 
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Shortcuts Menu item Reaction 
Edit... 
CTRL+ALT+O Open object Opens a new object of the selected tree object 
Ctrl+A Select all Selects the entire contents in the ST and MCC 

snap-ins 
 

 
CTRL+F Find Opens the Find window 
F3 Find next Continues the search from the current position 
CTRL+SHIFT+F Searching in the project Opens the Find window 
CTRL+SHIFT+G Replace in the project Opens the Find and Replace window 

 

 
CTRL+H Replace Opens the Replace window 
CTRL+J Display next position  

 

 
Shortcuts Menu item Reaction 
Target system... 
CTRL+L Download / target device Downloads to individual target device 
CTRL+D 
Only possible in online 
mode 

Device diagnostics Opens device diagnostics 

CTRL+I 
Only possible in online 
mode 

Control operating mode Opens the dialog box for control of the 
operating mode 

 

 
Shortcuts Menu item Reaction 
View... 
CTRL+F11 Maximize working area Maximizes and minimizes the view of the 

working area 
CTRL+F12 Maximize detail view Maximizes and minimizes the view of the detail 

view 
CTRL+Num+ 
(Plus key on the numeric 
keypad) 

Zoom in Magnifies the diagram in MCC 

CTRL+Num- 
(Minus key on the 
numeric keypad) 

Zoom out Reduces the diagram in MCC 

F5 Refresh Refreshes the view 
 

 
Shortcuts Menu item Reaction 
Options... 
CTRL+ALT+E Settings Opens the Properties window 
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Shortcuts Menu item Reaction 
Window... 
CTRL+SHIFT+F5 Arrange cascading 
CTRL+SHIFT+F3 Arrange vertically 

Arranges the opened windows in the working 
area 

 

 
Shortcuts Menu item Reaction 
Snap-in menu... 
CTRL+F4 Close Closes the selected window 
CTRL+B Accept and compile Compiles the active object 
CTRL+E Expert list Opens the expert list for the current technology 

object 
 

 
Shortcuts Menu item Reaction 
ST source file 
Ctrl+space  Automatic completion 
Ctrl+F2  Set and delete bookmarks 
Ctrl+F4 ST source file > Close Close ST source file 
Ctrl+F7 ST source file > 

Program status on/off 
Switches the program status function on or off 

Ctrl+Shift+F2  Delete all bookmarks in the ST source file 
Ctrl+Shift+F3  Arrange windows, tile horizontally 
Ctrl+Shift+F5  Arrange windows, tile vertically 
Ctrl+Shift+F8  Format selected area 
Ctrl+Shift+F9  Move cursor to the start of the current or 

higher-level block 
Ctrl+Shift+F10  Move cursor to the end of the current block 
Ctrl+Shift+F11  Move cursor to the start of the higher-level 

block, 1st level 
Ctrl+Shift+F12  Move cursor to the start of the higher-level 

block, 2nd level 
Ctrl+Alt+B  Display bracket pairs in the current ST source 

file 
Ctrl+Alt+C  Folding: Hide all blocks of the current ST 

source file 
Ctrl+Alt+D  Folding: Display all blocks of the current ST 

source file 
Ctrl+Alt+F  Folding: Display or hide folding information in 

the current ST source file 
Ctrl+Alt+I  Display indentation level in the current ST 

source file 
Ctrl+Alt+L  Display or hide line numbers in the current ST 

source file 
Ctrl+Alt+R  Folding: Display all subordinate blocks 
Ctrl+Alt+T  Folding: Show/hide block. 
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Shortcuts Menu item Reaction 
ST source file 
Ctrl+Alt+V  Folding: Hide all subordinate blocks 
Ctrl+Alt+W  Display or hide spaces and tabs in the current 

ST source file 
Ctrl+ADD (numeric 
keypad) 

 Increase font size in the current ST source file 

Ctrl+MINUS 
(numeric keypad) 

 Decrease font size in the current ST source file

Ctrl+DIV (numeric 
keypad) 

 Increase font size in the current ST source file 
to 100% 

Alt+Shift+arrow key  Select text by column 
Alt+Shift+L  Change selected text to upper case 
Alt+Shift+U  Change selected text to lower case 

 

 
Shortcuts Menu item Reaction 
MCC 
CTRL+F4 Close Closes the MCC unit 
ALT+Enter Properties Opens the MCC Unit Properties window 
CTRL+R Insert MCC chart Insert a new MCC chart 
CTRL+F7 Program status Switches monitoring on/off 
CTRL+F8 Monitor  
CTRL+F9 Single-step  
CTRL+F10 Next step  
Return – Opens the MCC configuration dialog 
Arrow keys – Changes within the tab 

 

 
Shortcuts Menu item Reaction 
LAD/FBD (source or program) 
CTRL+F4 Close Closes the MCC unit 
ALT+Enter Properties Opens the MCC Unit Properties window 
CTRL+R LAD/FBD source: Insert 

LAD/FBD program 
LAD/FBD program:  
Insert network 

Inserts a new LAD/FBD program 

CTRL+L Jump label On/Off Switches jump labels on and off 
CTRL+SHIFT+K Display/comment On/Off Switches comments on and off 
CTRL+SHIFT+B All box parameters Displays all box parameters 
CTRL+T Symbol check and type 

update 
Performs symbol check and type update 

CTRL+F7 Program status Switches monitoring on/off 
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Shortcuts Menu item Reaction 
LAD/FBD (source or program) 
F2 for LAD 
 
F2 for FBD 

Insert element / Insert 
make 
contact element / AND 
box 

Inserts a make contact 
 
Inserts an AND box 

F3 for LAD 
 
F3 for FBD 

Insert element / Insert 
break 
contact element / OR 
box 

Inserts a break contact 
 
Inserts an OR box 

F7 for LAD 
 
F7 for FBD 

Add element/Add coil 
Add element/Assignment

Adds a coil 
 
Adds an assignment 

F8 for LAD 
 
 
F8 for FBD 

Insert element / Insert 
Open branch 
element / Insert binary 
input 

Inserts an Open branch 
 
 
Inserts a binary input 

F9 for LAD 
 
 
F9 for FBD 

Insert element / Insert 
Close branch 
element / Invert binary 
input 

Inserts a Close branch 
 
 
Inverts the binary input 

ALT+F9 Insert element / empty 
box 

 

Ctrl + 3 
Ctrl + 1 

Switch to FBD 
Switch to LAD 

Switches the display 

 

 
Shortcuts Menu item Reaction 
Help... 
F1 Help topics Opens the entire help available for SIMOTION 

SCOUT 
SHIFT+F1 Context-sensitive help Opens the context-sensitive help function for 

the selected object, parameter, etc. 
 

 
Shortcuts Menu item Reaction 
Hardware configuration... 
CTRL+U 
(In HW Config) 

Address overview Opens the Address Overview window 

F4 Optimize layout  
 
 

 Note 
List of all shortcuts 
The online help feature includes a complete list of all the shortcuts available in SIMOTION 
SCOUT. 
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3.2.4 Using context menus 
The tree elements of the project navigator have context menus. These provide quick access 
to all major functions enabled for this tree element.  
To call up a function for the tree element via context menus, proceed as follows: 
1. Right-click the relevant tree element in the project navigator. 
2. Left-click the appropriate menu item. 

 
Figure 3-2 Example of a context menu 
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3.3 Project navigator 

3.3.1 Using the project navigator 

The project navigator in the SIMOTION SCOUT workbench 
As standard, the project navigator has two tabs, the Project and Command library tabs. 
The Project tab displays the entire project structure and is used for managing elements 
within the projects. 
The commands and functions required for the programming are displayed in the Command 
library tab. You can search in the command library or set filters. You can use commands and 
functions in the ST, LAD/FBD and MCC programming languages, e.g. for the creation of 
conditions. In the MCC programming language, the functions are used, e.g. via the ST zoom 
or the system function call command.  

3.3.2 Creating elements 

Elements in SIMOTION SCOUT 
There are two different ways to insert elements in the project navigator tree:  

Inserting hardware 
Integrate hardware using: 
● SIMOTION device element: Insert SIMOTION device 
Alternatively, you can also call up the Insert > SIMOTION device menu. 
● Drive element: Insert single drive unit 

 

 
 

Note 
You can insert a standalone drive (e.g. SINAMICS S120) with the Insert single drive unit 
element in the project navigator. It is commissioned using wizards in the working area of 
the workbench that contains the Starter functionality.  
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Elements within a SIMOTION device 
Create the following elements within a SIMOTION device directly in the project navigator: 
● Technology objects, e.g.: 

Axes, external encoders, cams, measuring inputs, output cams, synchronous operation, 
temperature channels, path objects 

● Programs: 
– Insert ST program 
– Insert MCC unit 
– Insert DCC charts 
– Insert LAD/FBD unit 

Other elements are created automatically, e.g. 
● When creating a project: 

– LIBRARIES: Insert library/DCC library 
– MONITOR: Insert watch table 

● When inserting a SIMOTION device: 
– AXES, EXTERNAL ENCODERS, PATH OBJECTS, CAMS, TECHNOLOGY, 

PROGRAMS folders 
– EXECUTION SYSTEM, I/O, GLOBAL DEVICE VARIABLES elements 

● When creating an axis: 
– MEASURING INPUTS, OUTPUT CAM, CAM TRACK folders 
– Access to the configuration views 

● Additionally when creating a following axis: 
– Synchronous operation element 

Inserting a single drive unit 
To insert a single drive unit element:  
In the project navigator, double-click Insert single drive unit.  
This enables you to insert a standalone drive (e.g. SINAMICS S120). The STARTER 
functionality in SCOUT is responsible for commissioning the drive concerned. 

Inserting elements within a SIMOTION device 
To insert technology objects, source files, or watch tables: 
1. Open the SIMOTION device under which the element is to be created. 
2. Select the relevant folder (e.g. AXES, PROGRAMS). 
3. Select the desired function, e.g.: 

– Insert > Technology object > ... menu or 
– Insert > Program > ... menu or 
– Insert > Watch table menu 
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Displaying the station level of a SIMOTION device 
The function provides a better transparency in large SIMOTION SCOUT projects. A project 
with several SIMOTION devices and a large number of drives can be displayed in a 
structure. The assignment in station levels, as is well known from SIMATIC STEP7, is used. 

 

 Note 
Optionally, the associated SIMATIC station of the SIMOTION device in the project navigator 
can be displayed. In this way, all drive units that are assigned to a SIMATIC station are also 
displayed in this structure. 

 

Proceed as follows to activate or deactivate this function:  
1. In the SIMOTION SCOUT, click the Options > Settings function. 
2. Click the Workbench tab. 
3. Activate/deactivate the Display station level function. 

The project must be reopened for this to take effect. 
When the function is activated, all drive units associated with a STEP7 station are also 
displayed under this station. 
When the function is deactivated, all drive units are displayed under the project. 

4. Click OK to confirm the change. 

Opening HW Config of a SIMOTION device 
To call up the hardware configuration of a previously inserted SIMOTION device:  
● Select the required SIMOTION device in the project navigator and select Insert > 

SIMOTION device in the menu or 
● In the project navigator, double-click the SIMOTION device whose hardware 

configuration you wish to open or 
● Select the desired SIMOTION device in the project navigator, open the shortcut menu 

and click Open HW configuration. 
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3.3.3 Changing properties of the elements 
You can change the properties of various elements as follows:  

 

CAUTION  
Changing a name can have far-reaching consequences. References to the axis, particularly 
in programs, are lost. This can cause runtime errors in the program. Make sure that you 
also change all name references. 

 

1. In the project navigator, select the element to be edited, e.g. a specific axis or a specific 
program. 

2. Select the menu: Edit > Object properties. 
 

 
 

Note 
You define the hardware properties in the hardware configuration. 

 

To rename an element: 
1. Select the element you wish to rename in the project navigator. 
2. Open the shortcut menu and select Rename. 
3. Confirm the warning message. 
4. Enter a new name and confirm the input by pressing the Enter key. 
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3.3.4 Wizards for configuration support 
Wizards are provided to assist you in configuring axes and external encoders. The wizards 
guide you step-by-step through the configuration. Parameter interdependencies are taken 
into account. 

 
Figure 3-3 Axis configuration wizard - window for drive assignment 
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3.4 Using the working area 
The workbench displays all of the snap-in working windows in the working area. Each snap-
in provides its own working window. You can open multiple instances of these windows. You 
can, for example, open several programs at the same time for editing. For further 
information, refer to the online help.  

Using windows in the working area 
You can change the size of the windows in the working area:  
Click on the edge of the window, hold down the left mouse button, and drag the window to 
the required size.  
You can maximize or minimize each window using the shortcut CTRL+F11. 
Each window opened in the working area can be accessed via a tab at the bottom edge of 
the working area. To bring a window into the foreground:  
● Click on the relevant tab or 
● Select the appropriate entry in the Window menu. 
To close the window: 
● Configuration dialog boxes: Click Close. 
● Editors for MCC, ST and LAD/FBD: 

Click the X button in the top right-hand corner. 
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3.5 Detail view 

3.5.1 Using the detail view 
When you select an element in the project navigator, the associated detail view will appear in 
the lower area of the workbench.  
Various tabs are available depending on the element selected. The tabs available are 
determined by the project mode (offline/online) and the active snap-ins. 

 
Figure 3-4 Example of detail view 

You can maximize or minimize each tab using the shortcut CTRL+F12. 
Each tab is opened only once, i.e.: 
● The active tab shows the details of the selected element. 
● The contents of the tab change when you select a different element. 

3.5.2 Using the symbol browser 

The symbol browser in the detail view. 
The symbol browser is a tab in the detail view. It displays status values of the variables for 
the element selected in the project navigator.  
To activate the symbol browser: 
1. Select an element in the project navigator. 
2. In the detail view, select the Symbol browser tab. 

Continuous display of the symbol browser 
To activate/deactivate the continuous display of the symbol browser:  
Click the symbol at the top right of the the symbol browser (pin). 
The active element is displayed continuously until this function is deactivated. To deactivate 
this function, click the pin again. 
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3.5.3 Address list 
The address list is where you create I/O variables, which you then assign to a particular item 
of hardware. You can monitor, control, and, if necessary, adapt these in the address list. You 
can enter the I/O variable assignment manually or use an assignment wizard to make the 
relevant selections. 

Opening the address list 
1. Browse to the folder for your device in the project navigator and double-click Address list 

to open the address list. 
2. The address list opens in the detail area. 

 

 
 

Note 
For further information and guidance on the address list, refer to the online help. 

 

3.5.4 Watch table 

Watch table options  
With the symbol browser you can view the variables belonging to one object in your project; 
with the program status you can view the variables belonging to a selected monitoring area 
in the program. With watch tables, in contrast, you can monitor selected variables from 
different sources as a group (e.g. program sources, technology objects, SINAMICS drives - 
even on different devices). You can sort the variables in the watch table in any way you wish, 
add comments regarding them, and combine them into groups. You can hide individual 
variables in order to make the watch table more manageable and also control variables via 
the watch table directly. 

Creating a watch table  
Procedure for creating a watch table and assigning variables:  
1. In the project navigator, open the Monitor folder. 
2. Double-click the Insert watch table entry to create a watch table and enter a name for it. A 

watch table with this name appears in the Monitor folder. 
3. In the project navigator, click the object from which you want to move variables to the 

watch table. 
4. In the symbol browser, address list, or expert list, select the corresponding variable line 

by clicking its number in the left column. 
5. From the context menu, select Add to watch table and the appropriate watch table, e.g. 

Watch table_1. 
6. If you click the watch table, you will see from the Watch table tab of the detail view that 

the selected variable is now in the watch table. 
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7. Alternatively, you can also copy and paste variables to the watch table. 
8. Repeat steps 3 to 6 to monitor the variables of various objects. 
You can also create a watch table directly by selecting a variable followed by Add to watch 
table > New watch table in the context menu. The new watch table, containing the selected 
variable, is created automatically. 
If you are connected to the target system, you can monitor the variable contents. 
For further information, please refer to the online help for SIMOTION SCOUT. 

3.5.5 Working with lists 
In order to make lists, e.g. watch table, address list, symbol browser, or expert list, more 
manageable and clearer, and to enable them to display larger quantities of data in a 
structured manner, you have various options for structuring the lists and adapting them to 
the relevant conditions. You can hide unimportant or redundant information and focus on 
important information. You can also transfer and group contents quickly and easily. For 
further information, see Working with lists in the online help. 

3.6 Adding add-ons to the workbench 

Add-ons in SIMOTION SCOUT 
SIMOTION provides you with the option of enhancing the functionality or accommodating 
customer-specific requirements. You can integrate add-ons. The CamTool add-on is 
currently available. 

 

 Note 
More detailed information about the CamTool add-on is contained in the CamTool 
configuration manual or the associated online help. 

 

Add-ons are added to the workbench and are displayed as fully integrated: 
● Menus and toolbars appear at the appropriate position in the workbench. After installation 

of add-ons, the menus are visible and the toolbars are active. 
● The working windows appear in the working area of the workbench and have tabs. 
● The detail view of the workbench shows details about the currently active add-on. If the 

associated details are distributed over several tabs, you can select the relevant tab and 
place it in the foreground. 
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3.7 Online help 

3.7.1 Structure of the online help 
SIMOTION SCOUT has a comprehensive context-sensitive help.  
Examples of using the online help can be found under: 
SIMOTION SCOUT > Help > Using help 

 
Figure 3-5 Help for online help 

3.7.2 Types of online help 
The following types of online help are available: 
● Entire help 
To open the entire help: 
In the SIMOTION SCOUT menu bar, select Help > Help topics or press the F1 key. The 
entire help is displayed. 
● Getting Started with SIMOTION SCOUT 
To open Getting Started: 
In the menu bar, select Help > Getting Started.  
All new functions for the current version are listed here in an overview. On the left-hand side, 
on the Content tab, select Getting Started with SIMOTION SCOUT. 
● Help button 
To open the help: 
Click the Help  button in the respective dialog box or window.  
The context-sensitive help for the dialog box is opened. 
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● Context-sensitive help 
To open the context-sensitive help: 
1. Press the SHIFT+F1 keys, click the button in the function bar or select 

Help > Context-sensitive help in the menu bar.  
The cursor changes to a question mark. 

2. Use the mouse pointer to click on, e.g. dialogs, parameters, input fields, menu items, 
command libraries, expert lists, symbol browsers or objects in the project navigator.  
The context-sensitive help for the selected entry is displayed. 
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3.7.3 Searching in the online help 
You can carry out a full-text search throughout the entire help in the Search tab.  
With a full-text search, you have to consider certain points to ensure that the search is 
successful. A simple search according to subject consists of the word or expression that you 
want to find. 
To refine your search, you can use wildcard expressions, nested expressions, Boolean 
operators, similar word hits, the previous result list or subject titles. 
To carry out a full-text search: 
1. In the menu bar, select Help > Help topics or press key F1. The entire help is displayed. 
2. Click the Search tab and enter the search term. You can add Boolean operators by 

clicking the arrow next to the input field. 
 

 
 

Note 
If you enter the term System, this term is sought throughout the entire Help. Only the 
Help pages that contain the word System are found. Compound words, e.g. Systemclock 
are not found. Therefore it is usually more appropriate to search with wildcards if you are 
not searching for a definite term, e.g. *system* returns all the results that contain system.

 

3. Click List subjects to start the search. The search returns a maximum of the first 500 hits. 
If you want to sort the subject list, click Title, Position or Order. With many search results, 
it is better to sort them by position so hits are grouped together by subject matter. 

4. Double-click the desired subject to display the Help page. The found terms are 
highlighted on the page. 

 

 
 

Note 
If the terms are not highlighted or you want to switch the highlighting off, click the Options
button and select Activate/deactivate search term highlighting in the menu displayed. 

 

You can also search just within the last result list, include similar word hits or only search the 
subject titles in the table of contents.  
In the case of multiple matches, a clearer overview can be obtained by sorting them with 
Position , as the search results will then be arranged according to the associated topic. 

Additional references 
You can find more information about this subject in the online help. 
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3.7.4 Getting Started in SCOUT 

Calling Getting Started with SIMOTION SCOUT  
Getting Started is displayed by default when SCOUT is opened.  
You can also select Help > Getting Started in order to open this feature.  

 
Online help 
Getting Started provides a brief overview of how you can work with SIMOTION SCOUT. A 
typical example is used to show you the different steps required to create a project and 
introduces the configuration, programming, and diagnostic tools.  
In addition, the section titled "New with SIMOTION V4.2" provides an overview of which new 
functionalities are available in the latest version of SIMOTION.  

 

 Note 
We recommend that you run through Getting Started with SIMOTION SCOUT in the online 
help. You will then be able to start work on more complex projects as well. 

 

Deactivating the Getting Started with SIMOTION SCOUT online help 
To deactivate the default setting that automatically opens the online help when you launch 
SIMOTION SCOUT: 
1. In the menu bar, select Options > Settings... 
2. Click the Workbench tab. 
3. Uncheck the Display "Getting started" at start checkbox. 
4. Click OK. 
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3.7.5 Error remedy 
If error messages appear in the detail view in the SCOUT workbench, you can call up 
detailed information in the online help. This is possible for technology objects alarms and 
alarms for drive units and I/O devices. To do this, click the Help for event button. 
Otherwise, additional information about the error text can be found using the complete text 
search.  

3.8 Basic steps 

3.8.1 Overview 
In order that the machine or plant can perform the desired tasks, you must carry out the 
following steps with SIMOTION SCOUT: 
● Create a project: 

The project is the generic term under which you store all of the relevant files. 
● Configure hardware: 

Provide the SIMOTION system with information about the hardware. 
● Configure technology objects (TO): 

Provide the SIMOTION system with information about the technologies used. 
SIMOTION SCOUT provides wizards for comprehensive assistance. 

● Create and test open-loop and closed-loop control programs. 
● Commission and optimize drives and axes. 
● Test the system and utilize the diagnostic options. 
SIMOTION SCOUT provides the workbench to enable you to perform these steps easily and 
efficiently. 
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3.8.2 Basic settings of SCOUT 
In SCOUT, you have the possibility of predefining various basic settings via the Options > 
Settings menu. Detailed information on the individual tabs and settings is provided in the 
SIMOTION SCOUT online help. 
1. Open SIMOTION SCOUT. 
2. Click the Options > Settings... menu. 

The Settings window is opened. 
3. Select the desired tab. 
4. Enter the settings. 
5. Click OK. 

 

 
 

Note 
Select Scripts > Additional scripts > Scripts for SIMOTION Scout Engineering in 
Utilities&Applications to access scripts for making useful standard settings. 

 

3.8.3 SIMOTION SCOUT project 
The project is the highest level in the data management hierarchy. SIMOTION SCOUT 
saves all data which belongs, for example, to a production machine, in the project directory. 
The project is therefore the sum of all data, programs, settings, etc. 
The project encompasses all of the SIMOTION devices, drives, etc., that belong to a 
machine. The axes, external encoders, path objects, cams, technology, and programs are 
assigned hierarchically to the respective devices. This hierarchical structure is displayed in 
the project navigator. 
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3.8.4 Creating a new SCOUT project 

To create a new project:  
1. Open SIMOTION SCOUT from the Start menu on the Windows desktop:  

Start > SIMATIC > STEP 7 > SIMOTION SCOUT. 
Or double-click the SIMOTION SCOUT icon on your PC desktop. 
SIMOTION SCOUT starts the workbench and the online help. 
Getting Started with SIMOTION SCOUT is displayed. 

2. In the workbench menu bar, select Project > New. 
The New Project window opens. 

 

 
 

Note 
SIMOTION SCOUT creates a directory with the selected name. All files relevant to the 
project are stored in this directory. 
Directory names and file names are shortened to 8 characters. If you assign longer 
names, these are displayed in SCOUT. However, these names are only managed with 8 
characters in the Explorer. 
Special characters may not be used. 

 

 
Figure 3-6 Creating a new project 
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3. Enter the following data in the dialog box: 
– Name:  

Select a name for the project. 
– Storage location (path): 

The default storage location (path), where the new project is to be stored, is displayed 
here. 

4. Click OK to confirm. 
The new project appears in the project navigator with an icon and its full name. The 
associated tree is expanded. 

 
Figure 3-7 Workbench with new project 
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The following entries are located beneath the project name in the project navigator: 
● Insert SIMOTION device element. Double-click on this symbol to select the required 

SIMOTION device, create and configure a new subnet and insert the new device in the 
HW Config program. 

 
Figure 3-8 Insert SIMOTION device 

● Insert single drive unit element. Double-click on this symbol to insert and commission a 
standalone drive (e.g. MM4 Basic). Although this drive cannot be linked to or configured 
in the master system of the project using a PROFIBUS DP connection, it appears in the 
project navigator within the project. 

● Folder labeled LIBRARIES 
● Folder labeled MONITORING 

 

 
 

Note 
For further information, refer to the online help at: 
"Getting Started with SIMOTION SCOUT". 
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3.8.5 Opening an existing project 

To open a project saved on the hard disk of the PC:  
You can open projects that SIMOTION SCOUT has stored locally (e.g. on the hard disk). 
1. Select the Project > Open menu. 
2. In the User projects tab, select the desired project. 

If the project you want is not stored according to the default path: Click Browse... and 
follow the instructions on the screen. 

3. Click OK to confirm. 
If you want to open a project that was created in an older version, a message appears 
asking whether the project should be converted to the newer version. This function is 
available since SIMOTION SCOUT Version V3.1. 

 

 Note 
The Save as... function saves all previously made changes in either a new or in an existing 
project. 
This means when you change an existing project and save with a different name, you must 
do this before you make any changes in the existing project. 

 

 

 
Figure 3-9 Opening a project stored on the hard disk 
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 Note 
The workbench displays one project at a time. 
If you wish to display two projects at the same time, e.g. in order to copy/paste parts of a 
project, start SIMOTION SCOUT a second time.  

 

3.8.6 Selecting technology packages 
The SIMOTION technology packages (e.g. TP CAM, TP PATH, DCBlib) are available in 
various versions for installation purposes.  
You can only use the functions of the technology objects selected if the technology objects 
are available in the target system. You can select the technology packages and their product 
versions (as well as the service packs and hotfix versions) for each SIMOTION device.  
Select Target device > Select Technology Packages ... in SIMOTION SCOUT if you want to 
adopt a more targeted approach when choosing the technology packages you want to use. 

 
Figure 3-10 Select Technology Packages 

 

 Note 
Device diagnostics can provide information on which technology package product version 
has been loaded to a CPU. 
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Loading technology packages to the target device 
Technology packages are only loaded to the target device if no technology package has 
been loaded so far. If a technology package version changes, the technology package must 
be explicitly reloaded to the target device. Proceed as follows: 
1. Select Download project to target system in SIMOTION SCOUT. 
2. Select the Replace product versions of the technology packages option and confirm with 

OK. 
For further information, please refer to the online help for SIMOTION SCOUT. 

See also 
Technology packages and technology objects (Page 14) 

3.8.7 Using program editors 

Editors in SIMOTION SCOUT  
Three editors are available for creating programs:  
● Graphics-based editor for creating MCC charts. 

You program by arranging symbolic program commands similar to a flow diagram and 
assigning parameters to these commands. 

● Text-based editor for creating ST source files. 
ST is a text-based programming language in compliance with IEC 61131-3, expanded to 
include motion commands (system functions for the technology objects). An ST source 
file can encompass several programs. 

● Graphics-based editor for creating ladder and function block diagrams. (LAD/FBD) 
LAD/FBD is a graphics-based programming language in compliance with IEC 61131-3. 
The ladder logic statement syntax corresponds to a circuit diagram. LAD statements 
consist of elements and boxes, which are graphically connected to networks. The LAD 
operations work according to the rules of Boolean logic. 
FBD uses the logic boxes familiar from Boolean algebra to map logic. You can represent 
complex functions (e.g. mathematical functions) directly in connection with the logical 
boxes. 
FBD provides all the elements required for the creation of a complete user program. FBD 
features a powerful command set. This includes the various basic operations with a 
comprehensive range of operands and how to address them. The design of the functions 
and function blocks enables you to structure the FBD program clearly. 

Optional editors 
● CamTool for the easy creation of cams using a graphical editor 
● DCC graphical editor based on CFC. SIMOTION controllers and SINAMICS drives can be 

configured graphically. 
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Additional references 
Please refer to the following documents on this subject 
● SIMOTION MCC Motion Control Chart Programming and Operating Manual 
● SIMOTION ST Structured Text Programming and Operating Manual 
● SIMOTION LAD/FBD Programming and Operating Manual 
● Programming and Operating Manual SINAMICS/SIMOTION Editor description DCC 
and the SIMOTION SCOUT online help. 
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Figure 3-11 Program editors 
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3.8.8 Saving and compiling 
The project must be saved and compiled first before the download. SIMOTION SCOUT 
distinguishes three commands in the main project menu that act differently when saving and 
compiling: 
● Save; the project is saved to the hard disk 
● Save and compile all 
● Save and recompile all 

Save 
The project is saved to the hard disk. The changes are accepted into the project. No further 
processes (such as compilation or consistency checking) are triggered for the project. 

Save and compile all 
On this command, the whole project is searched for changes. If a source is found which has 
been changed or has no compilation results, this and any linked sources (e.g. when an FB is 
called) undergo compilation and are saved. Therefore only the changes are compiled. Use 
this command when performing your day-to-day tasks within a SCOUT version. 

Save and recompile all 
All sources of the entire project are recompiled with this command. 
The Save and recompile all command is suitable if you are entirely sure that all the old data 
from older SCOUT versions has been removed and should be replaced with new compilation 
results. The command incorporates the following steps: 
● Project-wide deletion of all compilation results 
● Recompilation of all objects 
Use this command if you specifically want to switch a project from an older SCOUT version 
to a newer one. This involves accepting all the error correction and optimization elements in 
the new SCOUT, although the compilation results in SCOUT and SIMOTION RT become 
inconsistent as a result. The project navigator and object comparison feature then display 
the objects as "inconsistent" in ONLINE mode. You can only debug the project if you have 
loaded the entire project to the target system. 
For further information, please refer to the online help for SIMOTION SCOUT. 
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3.8.9 Performing a consistency check 

Checking the project for consistency and compiling the project 
Before you download the project to the target system, the program sources must be 
compiled without error and the consistency ensured. In this process, I/O addresses or TO 
configurations are checked, for example.  
1. Select the Project > Save and compile all menu. 
2. SIMOTION SCOUT compiles all the changed sources. 
3. Select the Project > Check consistency menu. 
SIMOTION SCOUT checks, for example, whether all technology objects have been 
configured and that the source files have been compiled without errors. Prior to a download, 
a consistency check can be performed automatically if the corresponding option is selected 
under Options > Download > Check consistency before loading. 
For further information, please refer to the online help for SIMOTION SCOUT. 
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3.9 Inserting and configuring a SIMOTION device 
You have created a project in SIMOTION SCOUT. The project navigator on the left of the 
SCOUT workbench  (Page 27)is open. To insert a device, double-click the Insert SIMOTION 
device entry under the name of your project in the project navigator. The following dialog 
then opens: 

 
Figure 3-12 Insert SIMOTION device 

Select the device platform you are working with under Device. The characteristics of the 
relevant platform then appear under Device characteristic. Select a version under 
SIMOTION version. If the Open HW Config option is selected, the hardware configuration 
(Page 65) opens after the device has been inserted. Click OK to confirm. 
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When you have created a SIMOTION device in the project via the Insert SIMOTION device 
element, the hardware configuration (HW Config) opens automatically.  
In HW Config, you tell the SIMOTION system which hardware is present; for example:  
● Type of SIMOTION device 
● Type of the I/O modules 
● Type of the drives 
In addition, you also specify which parameters the SIMOTION system should use, e.g.: 
● Configuration of the SIMOTION device 
● Configuration of PROFIBUS/PROFINET 
● Assignment of the hardware to PROFIBUS/PROFINET 

The following sections explain how to use the HW Config tool: 
● How to insert objects from the hardware catalog. 
● How to edit objects. 
● How to replace or delete objects. 

3.9.1 Starting HW Config 
HW Config can be started, e.g. to add a drive to the PROFIBUS.  
To start HW Config: 
● Double-click on the appropriate SIMOTION device in the project navigator or 
● Select the appropriate device in the project navigator and confirm your selection in the 

Open HW configuration shortcut menu or 
● Select the appropriate device in the project navigator, then select the Insert > SIMOTION 

device menu. 
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3.9.2 The HW Config program 
The HW Config program is displayed as follows: 
● A hardware catalog window 
● A working window that is split into two: 

– In the upper half, you can see the rack or station frame with the CPU already inserted 
automatically in slot 2 (example for C240).  
Insert the objects from the hardware catalog and edit them here. 

– In the lower half, you can see detailed information about the selected objects. 

 
Figure 3-13 HW Config with opened hardware catalog and the CPU previously inserted in the 

module 

3.9.3 HW Config: Opening the hardware catalog 
You can open the hardware catalog in the following ways:  
● Select the Insert > Insert object menu. 
● Select the View > Catalog menu. 
For additional information, see 
Chapter Inserting drives (Page 74) 
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3.9.4 SIMOTION devices in the hardware catalog 
You can find the SIMOTION devices in the corresponding directories of the hardware catalog 
in HW Config. 
With SIMOTION D, the SINAMICS version is selected in addition to the SIMOTION version. 
The SIMOTION version determines whether one or more SINAMICS versions are available. 

Add interfaces 
After inserting the SIMOTION device, the Properties - PROFIBUS DP Master Interface 
(R0/S2.1) window appears. Create the PROFIBUS DP subnets and configure the SIMOTION 
device interfaces in this window. 

 

 Note 
With SIMOTION D, the PCI integrated PROFIBUS subnet is created and configured 
automatically. The user may neither configure nor select it! 

 

 
Figure 3-14 Hardware configuration of a D4x5 

Detailed information on the configuration of the SIMOTION device is contained in the 
corresponding documentation for the SIMOTION devices. 
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3.9.5 Changing the SIMOTION device 

Requirements 
You will only need to perform this operation if you intend to upgrade a kernel or change a 
platform within the same station type. 

Swapping modules between SIMOTION families 
Module replacement is only possible within the same device family:  
● Within SIMOTION C 
● Within SIMOTION D410 
● Within SIMOTION D4x5 and D4x5-2 
● Within SIMOTION P 
Exchanges involving SIMOTION families SIMOTION C, SIMOTION P, SIMOTION D410, and 
SIMOTION D4x5/D4x5-2 require an XML export. 
For further information about replacing the device, see the section titled Replacing the 
SIMOTION device (Page 85) 

3.9.6 Connecting to the target system 

3.9.6.1 Installing the interface card 

Installing the interface card in the PG/PC 
An interface card must be installed in the PG/PC so that the SIMOTION device can 
communicate with the PG/PC. This applies only to PROFIBUS. 
To use Ethernet, an Ethernet connection must be present on the PC.  
Communication between a SIMOTION device and a PG/PC requires a conditioner card (for 
PROFIBUS) or an Ethernet interface. PGs already have both, but PCs may need a 
conditioner card to be installed. 
The PG/PC is used for configuration, parameter assignment, programming, and testing.  
● Install the interface card in the PG/PC according to the installation guide provided. 
● Install the appropriate drivers on the PG/PC. 
● Connect the interface card to the interface of the SIMOTION device indicated below using 

a suitable cable. 
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Table 3- 5 Interface assignment for SIMOTION devices 

SIMOTION device Interface As delivered 
C230-2/C240 X8 DP1 

X9 DP2/MPI 
 
X7 (Ethernet) 

PROFIBUS address 2, baud rate 1.5 Mbit/s 
PROFIBUS address 2, baud rate 1.5 Mbit/s 
 
IP address: 169.254.11.22 
Subnet: 255.255.0.0 

SIMOTION C240 PN X8 DP1 
X9 DP2/MPI 
 
X7 (Ethernet) 
 
X11 (1 PROFINET interface with 
3 ports) 

PROFIBUS address 2, baud rate 1.5 Mbit/s 
PROFIBUS address 2, baud rate 1.5 Mbit/s 
 
IP address: 169.254.11.22 
Subnet: 255.255.0.0 
Supplied without IP address and subnet. 

SIMOTION P350 X101 DP1 
X102 DP2/MPI 
 
Ethernet 

PROFIBUS address 2, baud rate 1.5 Mbit/s 
PROFIBUS address 2, baud rate 1.5 Mbit/s 
 
IP address: 169.254.11.22 

SIMOTION P350-3 DP X101 DP1 
X102 DP2/MPI 
 
Ethernet SS1  
 
Ethernet SS2 

PROFIBUS address 2, baud rate 1.5 Mbit/s 
PROFIBUS address 2, baud rate 1.5 Mbit/s 
 
IP address: 169.254.11.22 
Subnet: 255.255.0.0 
IP address: 192.168.214.1 
Subnet: 255.255.255.0 

SIMOTION P350-3 PN X21 MCI-PN (1 PROFINET 
interface with 4 ports) 
 
Ethernet SS1  
 
Ethernet SS2 

Supplied without IP address and subnet. 
 
 
IP address: 169.254.11.22 
Subnet: 255.255.0.0 
IP address: 192.168.214.1 
Subnet: 255.255.255.0 

SIMOTION P320-3 X3 PROFINET onboard 
interface with 3 ports 
 
X2 onboard Ethernet 1 

Supplied without IP address and subnet. 
 
 
 
Access to/from Windows: 
IP address: 169.254.11.21 
Subnet: 255.255.0.0 
Access to/from SIMOTION P Runtime: 
IP address: 169.254.11.22 
Subnet: 255.255.0.0 

SIMOTION D4x5 X126 DP1, 
X136 DP2/MPI 
 
X120 IE1/OP 
(Ethernet) 
 
X130 IE2/NET  
(Ethernet) 
With optionally inserted CBE30: 
X1400 (1 PROFINET interface 
with 4 ports) 

PROFIBUS address 2, baud rate 1.5 Mbit/s 
PROFIBUS address 2, baud rate 1.5 Mbit/s 
 
IP address: 192.168.214.1 
Subnet: 255.255.255.0 
 
IP address: 169.254.11.22 
Subnet: 255.255.0.0 
Supplied without IP address and subnet. 
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SIMOTION device Interface As delivered 
SIMOTION D4x5-2 X126 DP 

X136 DP/MPI 
 
X127 P1 PN/IE 
(Ethernet) 
 
X130 P1 PN/IE-NET 
(Ethernet) 
 
X150 P1-P3 PN 
(1 PROFINET interface with 3 
ports) 

PROFIBUS address 2, baud rate 1.5 Mbit/s 
PROFIBUS address 2, baud rate 1.5 Mbit/s 
 
IP address: 169.254.11.22 
Subnet mask: 255.255.0.0 
 
Delivered without IP address and subnet 
 
 
Delivered without IP address and subnet 

SIMOTION D410 DP X21 DP PROFIBUS address 2, baud rate 1.5 Mbit/s 
SIMOTlON D410 PN X200 and X201 

(1 PROFINET – interface with 
2 ports) 

Supplied without IP address and subnet. 
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3.9.6.2 Configuring the interface card 

Configuring the interface card 
Proceed as follows:  
1. Start SIMOTION SCOUT. 
2. Select the menu Tools > Set PG/PC interface. 

The Set PG/PC Interface window opens. 

 
Figure 3-15 Set PG/PC interface (example) 

3. Select the access point of the application. 
4. Click Select. 

The Install/Uninstall Interfaces window appears. 

 
Figure 3-16 Installing / deinstalling interfaces 

5. Select the module to be installed. 
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6. Click Install. 
7. Click Close to exit the dialog. 
8. Confirm the settings by clicking OK. 

Installing / deinstalling other interfaces 
Proceed as follows to install or uninstall additional interfaces: 
1. In the Set PG/PC Interface window, select S7ONLINE as the access point of the 

application. 
2. Click Select under Add/remove interfaces. 
3. In the left-hand field, select the interface that you want to install and click Install. 

Or select the interface that you want to uninstall in the right-hand field and click Uninstall. 
4. Click Close. 
5. Select the interface to be used in the Used interface parameterization field. 

The list of the used interface parameterization will be taken from SIMATIC STEP 7. 
With the PC Adapter (Auto) setting, the interface to which the PG/PC is connected is 
examined. This function automatically determines the current parameterization of the 
respective interface.  
Detailed information on the individual interfaces of the SIMOTION devices can be found 
in the relevant commissioning manuals. 

6. Click Properties to parameterize the interface. 
7. Click OK to confirm. 

3.9.6.3 Defining the interface 

Specifying the access point  
A unique access point is defined when you insert a SIMOTION device. If you make changes 
to the project which mean the access point is no longer unique, you can change the setting. 

 

 Note 
SIMOTION devices have two PROFIBUS connections. Defining the associated PROFIBUS 
connection speeds up online operation with the device. 

 

Proceed as follows in offline mode: 
1. Open the project. 
2. Select the SIMOTION device, e.g. C240, in the project navigator. 
3. Right-click and select Target device > Online access... in the context menu. 

The Properties - Program (Online) window opens. 
If you have defined the interface uniquely, you cannot make any settings in this window. 

4. Select Module Addresses on the tab. The IP/PROFIBUS address of the 
SIMOTION device is displayed here. 

5. Click OK to close the dialog. 
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3.9.6.4 Communication via PROFIBUS DP 
PROFIBUS is a powerful, open, and robust bus system, which guarantees trouble-free 
communication. The system is fully standardized, which enables trouble-free connection of 
standardized components from a variety of manufacturers. Configuration, commissioning, 
and troubleshooting can be carried out from any side. This results in user-defined 
communication relationships that are very versatile, simple to implement, and easy to 
change.  
The high-speed, cyclic exchange of data with field devices (distributed I/O) is carried out via 
the PROFIBUS DP protocol. Expansion of the protocol to include isochronous mode also 
integrates the drive components into communication via PROFIBUS DP. The individual 
components can be connected via the integrated interfaces, connections, interface modules 
or communications processors. 
Important information on communication with PROFIBUS is contained in the following 
catalog:  
SIMOTION, SINAMICS S120 and Motors for Production Machines, PM 21 Catalog 
The following PROFIBUS DP subnet applications are possible: 
● PROFIBUS DP isochronous 

Compatible extension to the standard PROFIBUS DP: 
– Equidistance (constant synchronous bus cycle clock) enables synchronized time 

slices for master/slave applications. 
– Data exchange broadcast enables slave-to-slave communication. 
Digital drives (e.g. SIMODRIVE 611U, MICROMASTER 4xx, SINAMICS) can be 
connected via PROFIBUS DP. 
In order to be able to operate the SIMOTION device with two isochronous 
PROFIBUS DP subnets, isochronous mode and the same bus cycle must be set. The 
cycle clock of the subnet of the second PROFIBUS interface is synchronized to the cycle 
clock of the subnet of the first PROFIBUS interface. 
If the bus cycle does not agree, the second PROFIBUS interface of the SIMOTION 
device will be operated as a PROFIBUS DP subnet. 

● PROFIBUS DP (MPI) 
Standard PROFIBUS DP with DP-V0 and optional DP-V1 or DP-V2 functionality. 
– For the connection of distributed I/Os 
– For connection to a higher-level automation system 
– For the connection of HMI devices 
– For connection to the SCOUT engineering system 
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3.9.6.5 Ethernet communication 
SIMOTION devices can also be connected to a PG/PC via Industrial Ethernet. Industrial 
Ethernet is a communication network with a transmission rate of 1 Gbit/s.  
For additional information, refer to the manual titled SIMATIC NET, Industrial Twisted Pair 
and Fiber Optic Networks. See the list of references for the order number.  
Examples for the use of Industrial Ethernet: 
● For the connection of HMI devices 
● For connection to the SCOUT engineering system 
● For communication via UDP (User Datagram Protocol) 
● TCP/IP 
● IT DIAG 

3.9.6.6 Communication via PROFINET 
SIMOTION devices can be connected to a PROFINET subnet via interface modules or the 
onboard PROFINET interface. With PROFINET IO IRT/RT, IT services can be performed in 
parallel to realtime communication via an Ethernet cable. PROFINET IO supports parallel 
operation of:  
● IRT (isochronous realtime Ethernet) 
● RT (realtime Ethernet) 
● TCP/IP, UDP, http . . . (standard Ethernet services) 
● For mixed operation of IRT and RT it has to be observed that the IRT-compatible devices 

must form an IRT domain, i.e. there must not be any non-IRT devices on the data 
transmission link between the IRT devices. 

Additional references 
Please refer to the following documents on this subject 
● SIMOTION D4x5 and SIMOTION D4x5-2 Commissioning and Hardware Installation 

Manual 
● SIMOTION D410 Commissioning Manual 
● SIMOTION P, SIMOTION P350-3, SIMOTION P320-3, and Panels Commissioning and 

Hardware Installation Manual 
● SIMOTION C Operating Instructions 
● SIMOTION Communication System Manual 
and the online help. 
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3.10 Inserting drives 

3.10.1 Drives with SIMOTION 

Note the following:  
Drives must be differentiated between: 
● Drives that are connected to PROFIBUS/PROFINET 
● Drives that are connected directly to the SIMOTION device 
The following applies to drives connected to PROFIBUS/PROFINET: 
● Only drives that meet the requirements of PROFIdrive profile V3.0 can be connected: 

– SINAMICS 
– MICROMASTER (PROFIBUS only) 
– COMBIMASTER 411 (PROFIBUS only) 
– MASTERDRIVES (MC, VC) (PROFIBUS only) 
– SIMODRIVE 611U (PROFIBUS only) 
– SIMODRIVE POSMO (CA, CD, SI) (PROFIBUS only) 
– ADI4 (analog drive interface for 4 axes) 
– IM 174 (Interface Module for 4 axes) 

● These drives are taken into the hardware configuration. 
● The drives of the SINAMICS and MICROMASTER drive families can be configured, 

assigned parameters, and commissioned with SIMOTION SCOUT. 
All analog drives can be connected via one of the four analog interfaces on the 
SIMOTION C230-2/C240 or via the ADI4 and IM174 PROFIBUS module. 
● These drives are inserted into the project via the hardware configuration.  

 
● The SIMOTION device requires only the actual values from the encoder at the input and 

issues the setpoints at the analog output. 
● The drives must be configured, assigned parameters, and commissioned directly on the 

corresponding device. 
With SIMOTION D, drives on SINAMICS Integrated are not inserted via HW Config. For 
more detailed information, see the D4x5 Commissioning and Hardware Installation Manual. 
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3.10.2 Inserting a SINAMICS drive on PROFIBUS DP 

Initial situation 
● The SIMOTION device is created in SIMOTION SCOUT 
● A PROFIBUS subnet has been configured, for example, as PROFIBUS DP isochronous 

(by selecting Edit > Isochronous operation) 
● The subnet interface is the master on this subnet of the SIMOTION device 

Proceed as follows: 
1. Open the PROFIBUS DP folder in the hardware catalog. 
2. Open the SINAMICS subfolder. 
3. Use drag-and-drop to drag an entry to the isochronous PROFIBUS subnet of the 

SIMOTION device. 
4. Double-click the SINAMICS drive Properties to open them and set a cycle clock. 

 
Figure 3-17 Inserting a SINAMICS drive 
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3.10.3 Inserting a SINAMICS drive on PROFINET IO 

Initial situation 
● The SIMOTION device is created in SIMOTION SCOUT 
● A PROFINET IO has been configured 

Proceed as follows: 
1. Open the HW Config of the SIMOTION device. 
2. Open the PROFINET IO/Drives/SINAMICS folder in the hardware catalog. 
3. Select the SINAMICS S120 CBE20 drive. 
4. Use drag-and-drop to drag the drive to the PROFINET IO subnet of the 

SIMOTION device. 

 
Figure 3-18 Inserting a SINAMICS drive with PROFINET 
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3.10.4 Commissioning the drives 

Drives that can be commissioned with SIMOTION SCOUT 
You can use SIMOTION SCOUT to assign parameters to the following drives: 
● SINAMICS 
● MICROMASTER 
● COMBIMASTER 411 
For all other drives or for third-party drives, the appropriate commissioning program for the 
specific drive must be used (e.g. the SIMOCOM U program for SIMODRIVE 611U). If 
required, you must commission these drives directly on the drive. 

Table 3- 6 Commissioning of various drives 

Drive Connection Commissioning 
SINAMICS S110, S120, 
S150, 
G110 CPM100, G120, G130, 
G150, GM150 

PROFIBUS DP or analog 
interface 

With SIMOTION SCOUT or  
STARTER 

SINAMICS S120 PROFINET With SIMOTION SCOUT or  
STARTER 

MICROMASTER 410 analog interface With SIMOTION SCOUT or  
DRIVE ES Basic or  
STARTER 

MICROMASTER 
420/430/440 

PROFIBUS DP or 
analog interface 

With SIMOTION SCOUT or  
DRIVE ES Basic or  
STARTER 

COMBIMASTER 411 PROFIBUS DP or 
analog interface 

With SIMOTION SCOUT or  
DRIVE ES Basic or  
STARTER 

SIMODRIVE 611U PROFIBUS DP or analog 
interface 

With SIMOCOM U or  
DRIVE ES Basic 

MASTERDRIVES MC, VC PROFIBUS DP or analog 
interface 

With SIMOVIS or  
DRIVE ES Basic 

SIMODRIVE POSMO  
CA; CD, SI 

PROFIBUS DP With SIMOCOM U or  
DRIVE ES Basic 

Third-party drives Analog interface or  
PROFIBUS DP 
according to PROFIdrive 
profile V3.02 

With commissioning tool supplied by the 
manufacturer 

 
 

 Note 
If the Drive-ES Basic commissioning program is installed, it can be called by SIMOTION 
SCOUT in the project navigator via Commissioning. 
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3.10.5 SINAMICS on SIMOTION 

3.10.5.1 SINAMICS S120 on SIMOTION 

STARTER functionality in SIMOTION SCOUT 
It is possible to parameterize drives directly with SIMOTION SCOUT. The following example 
describes how to insert a SINAMICS drive in SIMOTION SCOUT. 

Requirements: 
● SIMOTION SCOUT has been installed on the PC/PG 
● A SIMOTION SCOUT has been created 

 

 
 

Note 
You can create the SINAMICS drive with PROFIBUS or PROFINET. 

 

You must execute the following steps: 
● Insert SIMOTION device 
● Configure SINAMICS 

Commissioning in SIMOTION SCOUT 
1. Open the SIMOTION project in SIMOTION SCOUT. 
2. Double-click Insert SIMOTION device. 
3. Select a SIMOTION device. 
4. Select the variant. 
5. Deactivate the Open HW Config box. 
6. Click OK to confirm. 
7. Select the PROFIBUS interface or Ethernet. 

If you have selected Ethernet, select the interface parameterization of the PG/PC. 
8. Click OK to confirm. 
9. With SIMOTION C and P only: Insert a SINAMICS device (see Inserting a drive 

(Page 74)). 
10. Select Station > Save and compile in HW Config, then exit HW Config. 
11. Open the structure tree of the SIMOTION device in the project navigator. 
12. Open the structure tree of the drive (SINAMICS or SINAMICS_Integrated) in the project 

navigator. 
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13. Double-click Configure drive unit. 
The Configuration - Option module window opens. 

14. Run through the drive wizard. 
The STARTER functionality now starts in SIMOTION SCOUT.  
How to configure the SINAMICS_Integrated drive (with SIMOTION D) is described in detail in 
the following documents: 
● SIMOTION D4x5 Commissioning Manual 
● SIMOTION D4x5 Product Manual 
● SIMOTION D410, Commissioning Manual 

 

 
 

Note 
You can insert a standalone drive (e.g. SINAMICS S120) with the "Insert single drive unit" 
element in the project navigator. It is commissioned using wizards in the working area of 
the workbench that contains the STARTER functionality. 

 

3.10.6 Controlling drives 
You can use SIMOTION SCOUT to control the configured drive. Use the control panel for 
this purpose. This is displayed as a detail view tab. Drives can only be controlled in online 
mode.  

 

DANGER  
Before the motor turns for the first time, pay special attention to the following potential 
hazards:  
Make sure that the motor is connected correctly! 
Secure the surrounding area:  
Secure the motors! Do not release the magnetic motor brake of vertical axes without a 
safeguard! 
Set the limit values! Bring the axes to neutral position! Choose low velocities and speeds! 
Observe general accident prevention guidelines! 
The function is released exclusively for commissioning and service purposes. The safety 
shutdowns from the higher-level control have no effect. 
The function should only be used by authorized technicians. 
The "Emergency stop with space bar" function is not guaranteed in all operating modes. 
Therefore, there must be an EMERGENCY STOP circuit in the hardware. The appropriate 
measures must be taken by the user. 
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Follow the steps outlined below: 
1. Open the element (folder) for the drive unit in the project navigator. 
2. Open the drive element below the folder. 
3. Double-click the Control panel element. 

The control panel is displayed in the detail view. 
4. Select the drive that you want to control. 
5. Select the relevant checkbox: 

– Control: 
You switch the drive and control its speed. 

– Enables and actual value: 
You monitor setpoints and actual values as well as enables and alarms. 

– Links to status info:  
You can switch to the drive diagnostics. 

 
Figure 3-19 Controlling drives with SIMOTION SCOUT 

Switching the drive and controlling its speed 
Follow the steps outlined below:  
1. Activate the Control checkbox. 
2. Click Assume control priority. 
3. Move the slider to the left. 
4. Activate the Enables (bit 1 to bit 6) checkbox. 
5. Switch on the drive: Click the I button. 
6. Use the slider to control the speed. 
To switch off the drive: 
● Click the O button. 
● Press the space bar. 

 

CAUTION  
 

Make sure that all windows in the working area are closed. Otherwise, delays may occur 
between the entry of the control command on the PC and its execution by the drive! 
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Monitoring enables and actual values 
● The speed setpoint and actual speed value are displayed constantly.  
● Select two additional parameters for display. These parameters are displayed below the 

selection box. 
● The enables and alarms are displayed. 

3.11 Inserting an axis 
Axes are integrated as technology objects (TO) in SIMOTION. The axes are created with the 
appropriate settings under the inserted SIMOTION device and then interconnected with the 
drives. 

Procedure 
1. Double-click the Axes > Insert axis entry in the project navigator. 

The Insert axis window opens. 
2. Enter a name and click OK to confirm the other standard settings. The axis configuration 

wizard will be displayed. 
3. You can insert a virtual axis or a real axis. When first working with SIMOTION SCOUT, it 

is recommended that you first insert a virtual axis and carry out the first steps with this 
axis. Getting Started in the online help contains specific operating instructions based on 
SIMOTION D. 

4. Run through the drive wizard until the end, then select Finish to confirm. The configured 
axis is displayed in the project navigator. To test correct functioning of this axis, the 
project is saved and compiled, and the axis is then tested with the axis control panel. 

For further information, please refer to the online help for SIMOTION SCOUT. 

Testing with the axis control panel 
The axis control panel is used to control and monitor individual axes without requiring a user 
program. You can use it to traverse axes along with the drive.  
To do this, switch to online mode, download the project, and make sure the mode switch is 
set to STOP_U. Then open the Axis folder in the project navigator and select the Axis control 
panel entry under the axis created. 
For further information, please refer to the online help for SIMOTION SCOUT. 
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3.12 Searching in the project 
In the open project, you can search all the project data for variables or any text. 
If you select a variable search, you can also search within the ST sources. All global and 
local variables at the declaration and use points are recognized.  
Open the dialog using Edit > Search in project... on the menu bar or by using the shortcut 
Ctrl + Shift + F. 
The results are displayed in the search results tab of the detail view. 

 
Figure 3-20 Searching in the project 

Searching in CPU/Libraries only 
If the "Search only in CPU/Library" checkbox is ticked, a selection list of all the CPUs and 
user-defined libraries in the project appears. You can select one to search in this 
CPU/Library only. 
For more information regarding this topic, see the online help. 

Local searching in MCC 
You can perform quick searches for specific free text items in the current MCC chart editor or 
the current declaration tables. To start searching locally, open the search function (with the 
CTRL+F shortcut key) while the current focus is on the MCC editor or the editor window for 
global and global unit declarations and connections. 
The SIMOTION MCC Motion Control Chart Programming and Operating Manual contains 
further information on local searches. 
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3.13 Replacing in the project 
The Replace in project function is based on the Search in project function.  
To open it, select Edit > Replace in the project... on the menu bar. 
When you carry out a replacement, both the results found and the replacement term are 
displayed in the "Search result" tab of the "detail view". The text can be edited again here. 
Use the Replace button to replace all search results selected using the check box. 

Boundary conditions: 
● Only text can be entered. 
● Replaced texts cannot be undone. 
More information on this topic is available in: 
● Online help. 

Local replacement in MCC 
You can perform quick searches for specific free text items in the current MCC chart editor or 
the current declaration tables and replace these with text of your choice. To start the local 
replacement process, select the CTRL+H shortcut key while the current focus is on the MCC 
editor or the editor window for global and global unit declarations and connections. 
The SIMOTION MCC Motion Control Chart Programming and Operating Manual contains 
further information on local replacement. 

3.14 Configuring multilingual messages 

To configure multilingual messages: 
1. Select Project > Language-dependent texts in the menu. The Select Language window 

opens. 
2. Set the language in which you want to configure the messages as the current language. 
3. Click OK. The window closes. 
4. Select Project -> Messages -> Configure in the menu and check the set language under 

Configuration language in the displayed window. 
The message texts and remarks are displayed in the language in which they were 
originally configured. These texts must then be compiled in the new configuration 
language. 

5. In the Message configuration window, double-click the messages for which you want to 
enter texts in the new configuration language or click the Edit button. The Edit Message 
window is displayed. 

6. Enter the new message text and remarks in the changed language. 
The symbol name must not be changed in foreign language messages, as this symbol 
name is used for programming. Only the message text and remarks are language-
dependent. 
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7. Click OK to confirm. The modified message text is entered in the Message configuration 
table. 

8. Repeat steps 6 to 8 if you want to enter more message texts in the new configuration 
language. 

For further information, please refer to the online help for SIMOTION SCOUT. 

3.15 Printing projects 
You can print various parts of a project or view them in the print preview in order to, for 
example, document settings, data, etc. The part to be printed depends on the element 
selected in the project navigator or the window active in the working area. 
● An element is selected in the project navigator or a window is active in the working area. 

The data of the associated technology object, MCC chart, etc. is printed. 
● The detail view is active. The data of the active tab of the detail view is printed. 
● The project is selected in the project navigator. All data of the project (e.g. programs, 

execution system, technology objects) is printed. 
 

 
 

Note 
If you select Print or Print preview in the Project menu, the print dialog or the print 
preview is displayed immediately. If you select the context menu for Print or Print preview 
of the selected element in the project navigator, a window is displayed in which you can 
activate the components to be printed. If, for example, you only want to print certain parts 
of a technology object, select Print in the context menu. 

 

For further information, please refer to the online help for SIMOTION SCOUT. 

3.16 Know-how Protection 
The know-how protection installed on SIMOTION SCOUT protects the programs (ST source 
files, MCC charts, LAD/FBD programs, and DCC charts) and libraries in your project. This 
protection prevents unauthorized viewing of the programs.  
Log-in details and a password have to be set by selecting Project > Know-how protection. 
This activates the know-how protection for the program. The programs contained in the 
project are still visible to the user in this session, but the program names are grayed-out. 
For further information on know-how protection, please refer to the online help for 
SIMOTION SCOUT. 
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3.17 Upgrading and changing platforms for SIMOTION devices 

3.17.1 General information 
The procedure in the Engineering System depends on what is involved:  
● Upgrading the firmware version of a device within a platform 
● Platform change: The platform is changed within the same SIMOTION version. For 

example, a SIMOTION C240 is replaced by a SIMOTION P350. 
 

The section titled Upgrading devices and updating projects with the device update tool 
(Page 131) contains further information. 

3.17.2 Changing a SIMOTION device followed by a TP upgrade 

3.17.2.1 Upgrading SIMOTION devices (upgrades within the same platform) 
An upgrade is necessary when you want to replace the type or version of the SIMOTION 
device in your existing project. Perform this replacement in HW Config.  

To replace a SIMOTION device: 
1. Double-click the SIMOTION device to be replaced in the project navigator in SIMOTION 

SCOUT. HW Config is opened. 
2. Open the appropriate folder structure in the hardware catalog: 
3. Select the module of the new version in the hardware catalog and drag this above the old 

module with the mouse (to the header of the rack shown in the case of SIMOTION D, to 
slot 2 in the case of SIMOTION C or P). 

 

 
 

Note 
Ensure that the module/device (SIMOTION D) to be replaced does not get deleted. When 
you change to the new module/device using Drag&Drop, the old module will be updated. 

 

4. Confirm the displayed dialog box with Yes if you want to replace the SIMOTION device. 
5. Alternatively, select the SIMOTION device and call the context menu by right-clicking in 

the header area of the device. Then select the Replace object ... command followed by 
the version required. 
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6. Accept the changes made to the hardware configuration with Station > Save and compile. 
7. Close the HW Config. 

 

 
 

Note 
The data for the SIMOTION device is immediately accepted in the SIMOTION SCOUT 
project and the entire project is saved. In this way, the project also accepts all changes in 
the project (e.g. axis configuration). 
If you are using technology packages in your project, these are updated automatically. 

 

The device replacement process differs from the platform replacement process in that it is 
really easy to accept project data during device replacement. Device replacement uses HW 
Config, whereas platform replacement (e.g. replacing SIMOTION C with D) requires an XML 
export/import. 
Examples of device replacement: 
- Replacement involving different power classes (e.g. D445-2 DP/PN <-> D455-2 DP/PN)  
- Replacement involving generations (D4x5 -> D4x5-2) 
- Replacement involving versions (D410 DP <-> D410 PN; C240 <-> C240 PN) 
- Replacement involving the main version (C240 V4.1 <-> C240 V4.2) 

Upgrade of libraries 
When the version of a SIMOTION device and the technology packages changes, the 
libraries created in SIMOTION SCOUT must also be adapted.  
1. Select a library in the project navigator. 
2. Right-click and select Properties... in the context menu. 

The Object Properties window opens. 
3. Click in the TPs/TOs tab. 
4. Select the appropriate device and the technology packages. 
5. Click OK to confirm the changes. 
6. Select the same library. 
7. Right-click and select Save and compile in the context menu. The upgrade is completed. 
8. Repeat the operations for all created libraries. 
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3.17.3 Changing the SIMOTION platform 
Platform changes involving, for example, the following SIMOTION devices: 
● SIMOTION C 
● SIMOTION P as of V2.1 
● SIMOTION D 
Proceed as follows: 
1. Export the SIMOTION CPU data to be replaced via the 

Expert > Save project and export object context menu. 
2. Create a new SIMOTION device involving a different platform. This will be automatically 

inserted in the project navigator. 
3. Insert a new SIMOTION device or several master systems and configure them. 

The HW Config is opened. The new station and the created master systems are already 
inserted. 

4. Also open the old station in the HW Config. Switch to the old station. 
5. Copy the DP slaves. 
6. Switch to the new station. 
7. Insert the DP slaves in the new station. 
8. Check the configuration of the elements of the new station. 
9. Close the HW Config. 
10. Delete the old device in the project navigator. 
11. Carry out an object import on the new device with the previously exported data. 

 
Figure 3-21 Example of importing an object with a station change 

Connecting drives/slaves after platform changes 
It may no longer be possible to assign drives/slaves after a platform change. This can be 
remedied as follows: 
● Repeat the process with the original project (prior to platform replacement). 
● Alternatively, select the CTRL+ALT+F11 shortcut key in HW Config. The objects become 

unassigned and connections can then be set up in the usual manner once more. 
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3.17.4 Upgrading technology packages 

Overview 
The SIMOTION TP technology packages (e.g. TP CAM, TP PATH, DCBlib) are available in 
various versions. 
You can only use the functions of the technology objects selected if the technology objects 
are available in the target system. You can select the technology packages and their version 
for each SIMOTION device. Each version of SIMOTION SCOUT has a kernel (FW version) 
for the SIMOTION CPU and an associated technology package with the same version. 

TPs during upgrades 
Device replacement (in HW Config), platform replacement (XML export/import), or even 
upgrades may cause versions of SIMOTION technology packages (TPs), which are 
assigned to individual technology objects (TOs), to change. 
● The TP version may change if the main version changes 

The TP version depends on the relevant main version in all cases; it may, however, 
remain unchanged through a number of main versions. 

● If service packs and hotfixes are installed, there may even be a selection of TP product 
versions available for the same TP version 

The TP version is automatically updated during device replacement (in HW Config). With a 
platform replacement (XML export/import), however, the required technology package along 
with the TP version and, if necessary, the product version have to be selected manually after 
the import. 
It is also possible to define a specific TP product version (by selecting V4.1.5.3, for 
example).  
If the product version  
● "Vx.x.x.x" is displayed, the version cannot be determined (as with TP DCBlib, for 

example). 
● "Select" is displayed, this means the TP product version has yet to be selected; if the TP 

is loaded to the CPU without any prior selection having been made, the latest available 
technology package is loaded automatically. 

Selecting the TP product version 
Selecting Target device > Select Technology Packages ... in SIMOTION SCOUT enables 
you to adopt a more targeted approach when choosing the technology packages you want to 
use. 

 

 Note 
Device diagnostics can provide information on which technology package product version 
has been loaded to a CPU. 
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Loading technology packages to the target device 
Technology packages are only loaded to the target device if no technology package has 
been loaded so far or if Load to File System is executed.  
If a technology package version changes, the technology package must be explicitly 
reloaded to the target device.  
Proceed as follows: 
1. Select Download project to target system in SIMOTION SCOUT. 
2. Select the Replace product versions of the technology packages option and confirm with 

OK. 
For further information, please refer to the online help for SIMOTION SCOUT. 

 
Figure 3-22 Select Technology Packages 
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3.18 Saving and restoring variables from the device 

Saving and restoring data with SCOUT 
Using the SIMOTION SCOUT functions Save variables and Restore variables it is possible 
to save and then restore data (which has been changed during operation and is only saved 
in the SIMOTION device or on the memory card) to the hard disk. This can be used if a 
SIMOTION platform is changed or a version updated, for example. 
The following types of data can be backed up: 
● Data variables that are in the SRAM/NVRAM of the controller: 

– Retentive global device variables 
– Retentive global unit variables 
– TO retain data (as of V4.1) 

● Data sets which have been backed up from the user program via _saveUnitDataSet or 
_exportUnitDataSet and are located on the memory card, including 
– Global unit variables of interface and implementation sections from program sources 

(ST, MCC or LAD/FBD sources): 
Remanent variables (VAR_GLOBAL_RETAIN) 
Non-remanent variables (VAR_GLOBAL) 

The _exportUnitDataSet  function backs up unit variables in a version-independent format 
(XML). 
By contrast, data is backed up in a version-dependent format (binary) via the 
_saveUnitDataSet function and can, therefore, only be read back in on a device/unit of the 
same version (e.g. V3.2) via the _loadUnitDataSet function. 
Data sets saved via _saveUnitDataSet are automatically converted into XML format using 
the Save variables function. The data sets are available in binary format for the new version 
once the Restore variables function has been executed. 
Data backed up using Save variables are saved as version-independent XML files in a user-
defined folder on the PC's hard disk. 
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In addition to the data backup functions provided by SIMOTION SCOUT, backup functions 
are also available in the runtime system. 

 

 Note 
When performing an update with a kernel version that is ≥ V4.1, the above 
SIMOTION SCOUT functions are only required for backing up and restoring unit data sets 
that have been created using _saveUnitDataSet. 
Reason: 
 Retain data remain valid after an update. 
 Unit data backed up using _exportUnitDataSet also remain valid after an update. 
 Retain data can also be backed up to a memory card without the use of 

SIMOTION SCOUT: 
– The _savePersistentMemoryData function saves all retain data from the 

SRAM/NVRAM; these can be remanent global unit variables in the interface or 
implementation sections of a source (VAR_GLOBAL_RETAIN) or remanent global 
device variables (RETAIN) and  
TO retain data 
(For further information, see Parameter Manual: Device System Functions/Variables) 

– The Back up diagnostic data function (triggered via a service switch/diagnostic button 
or IT DIAG) saves all retain data (as above, see _savePersistentMemoryData). 
Subsequently executing the Restore non-volatile data function reactivates this backed 
up data. 
(For further information, see the SIMOTION D Commissioning Manuals.) 

 

A directory structure is created in the selected path using the Save variables function. This 
directory is assigned the name of the selected SIMOTION device or the selected unit, 
depending on whether the variables should be saved or restored for the entire device or just 
one unit. 
The remanent global device variables are backed up in the file unitdata.xml. The number of 
subdirectories corresponds to the number of sources in the SIMOTION project. The names 
of the subdirectories correspond to the names of the sources. Every subdirectory contains a 
file named unitdata.xml, where the remanent unit variables are backed up. If required, 
another file is saved containing the non-remanent global variables for the source. This 
DS*.xml file is assigned the data set number as its name, which is transferred by specifying 
the parameter ID for the _saveUnitDataSet or _exportUnitDataSet function. 

Additional references 
Detailed information on this topic can be found in: 
● SIMOTION Basic Functions Function Manual, Data Backup from User Program 
● SIMOTION SCOUT Online Help 
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Example of a folder structure when backing up on the device: 
The folder structure is as follows: 
 
<Folder device>, e.g. D435 
 unitdataset.xml 
 DS000001.xml 
 <Folder device>, e.g. ST_UNIT1 
 Unitdataset.xml 
 DS000002.xml 

3.19 Exporting and importing projects 

3.19.1 Exporting and importing a project in XML format 
A log of the export or import is displayed in the XML export/import status display tab in the 
detail view. The XML export log also contains a link to the exported file. Double-click on this 
link to view the exported project data in the Internet browser.  

 

 Note 
Projects are exported and imported version-neutral. However, if a project has version-
specific properties, related errors may occur following import into another SCOUT version, 
e.g. when compiling of ST programs. 

 

Additional references 
Please refer to the online help on this subject 
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3.20 Archiving and backing up projects on memory cards 

Procedure 
In SIMOTION SCOUT, you can back up your project to the memory card as a *.zip file.  
Proceed as follows to archive the SIMOTION project on the memory card: 
1. Open SIMOTION SCOUT and select the Project > Archive menu. 
2. In the Archive dialog, select the SIMOTION project and save it to your drive (PG/PC). 
3. Open the project. 
4. Go online with SIMOTION. 
5. In the project navigator, select the SIMOTION device followed by the Target system > 

Load > Archive project on card menu command. 
6. In the dialog that is displayed, select the project and click Open. This saves the project to 

the CompactFlash Card as Project.zip in the directory USER\SIMOTION\HMI\PRJLOG. 
 

 
 

Note 
If you want to load the current project from the card, select the Target system > Load 
project from card menu command. 
This assumes that you have backed up the project with Archive project on card each time 
a change was made. 

 

Additional references 
Detailed information on loading data to the target device can be found in the SIMOTION 
SCOUT Basic Functions Function Manual. 
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3.21 Online multiuser mode 
Thanks to the new project comparison, device upload and download with supplementary 
data functions, several users can exchange project data that has been modified via the 
target device, online. This allows them to synchronize the status of their own 
SIMOTION project with that of another one, thereby updating it.  
In online multiuser mode, it is possible for two people to work online on the same 
SIMOTION device. The following functions can be performed: 
● Reading and controlling of system variables and configuration data 
● Execution of measuring functions and axis control panel 
● Uploading of configuration data 
● Uploading of programs or technology objects and other settings (e.g. execution system) 
● Editing and downloading of programs (following prior alignment, if applicable) 
The following graphic shows a schematic representation of online multiuser mode: 

 
Figure 3-23 Schematic representation of online multiuser mode 

Editors A and B are working on one SIMOTION project at the same time. Changes made by 
both editors are loaded to the target device. The project must be synchronized beforehand, 
otherwise parts of it could be found to be inconsistent and subsequently overwritten when 
the Load project to target device command is executed. 
This means, for example, that Editor A must synchronize his project with Editor B's project 
before loading it to the target device. This can be done via the synchronization mechanism in 
the project comparison facility. 
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Figure 3-24 Synchronizing project data via the project comparison function 

3.22 Licensing runtime 

3.22.1 Licensing of the runtime components 

3.22.1.1 Overview for the licensing 
Functions can be licensed using the following software options:  
● Motion control technology functions 

The licensing is performed axis-specifically for: 
– POS - position; use of the technology functions for position axis 
– GEAR; use of the technology functions for following axis 
– CAM; use of the technology functions for cam axis 

The GEAR technology function contains the POS technology function, while the CAM 
technology function contains the POS and GEAR technology functions. 
The MultiAxes package permits a simple licensing of the Motion Control technology 
functions. It contains the license for the unlimited use of the CAM technology function on a 
SIMOTION device, e.g. a C240, a D4x5, or a P350. 
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● TControl technology function 
The use of the TControl technology package functions is licensed on a channel-specific 
basis in packages of 8 temperature channels. 

● IT functions, IT DIAG, and SIMOTION IT 
The use of these functions is licensed for each SIMOTION device. 

 

 
 

Note 
Another option is to order SIMOTION memory cards (MMC and CompactFlash) and 
SIMOTION P3x0-3 with pre-installed runtime licenses. 

 

Additional references 
Further important information for the licensing of the runtime software and the ordering data 
can be found in:  
● Catalog: SIMOTION, SINAMICS S120 and Motors for Production Machines 
● PM 21 catalog, section titled SIMOTION runtime software 
● Configurator for SIMOTION Runtime Licenses in the A&D Mall 

(http://mall.automation.siemens.com) 

3.22.1.2 Licenses and license key 
Depending on the type and number of runtime components used in the project, licenses 
must be acquired as part of the licensing procedure for SIMOTION. The licenses required for 
a SIMOTION device are assigned to a license key. This license key is stored on the memory 
medium of the SIMOTION device during the licensing procedure.  
There are two ways of ordering the licenses: 
● Preinstalled licenses 

The license key is already stored on the card. 
● Ordered licenses (Certificate of License) 

These licenses must be assigned to the storage medium using the Web-License-
Manager. The determined license key is transferred to the hardware using SCOUT. 

You require the following information to obtain the license key: 
● The serial number of the SIMOTION device memory medium 

You can obtain the serial number from the memory medium or have it displayed online in 
the SIMOTION SCOUT (licensing wizard). 

● The serial number of the CoL (Certificate of License) 
You have this number on paper. 

Table 3- 7 The serial number on the SIMOTION hardware assigned to the SIMOTION device 

SIMOTION device Hardware serial number of module 
SIMOTION C2xx SIMOTION Micro Memory card 
SIMOTION P SIMOTION IsoPROFIBUS-Board or 

SIMOTION MCI-PN board 
SIMOTION D SIMOTION CompactFlash card 
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License keys can be generated separately from the licensing. 
 

 Note 
When the SIMOTION memory card is deleted or formatted, the licensing data is also 
deleted. Archive the licensing data in order to be able to transfer it again to the memory 
medium in such a case. If the data is not backed up, you have to perform the licensing again. 
You can display the entered license key in the Web License Manager. 
You will find additional information in the section:  
License key is protected from deletion (as of kernel V4.1) (Page 100) 

 

See also 
FAQ - Dealing with licenses (http://support.automation.siemens.com/WW/view/en/36947932) 

3.22.1.3 Determining licensing requirements 
 

 Note 
Determine your license requirement only after you have completed the configuration! A 
license that has been assigned a license key cannot be withdrawn. 

 

Once you have completed your project configuration with SIMOTION SCOUT and before 
you download it to the target device, you can determine the licenses required for the project. 
You have three options for determining license requirements. Before you begin, the project 
must have been saved and compiled. If you have not yet acquired any licenses, 
underlicensing is displayed.  
Options for determining license requirements are as follows: 
● Offline mode with open project 

The required licenses are displayed. 
● Online mode with open project 

A comparison of the required and actual licenses is displayed. 
● Online mode without project 

The actual licenses of the selected SIMOTION device are displayed. 

Proceed as follows: 
1. Select the SIMOTION device in the project navigator. 
2. Select Licenses in the context menu. 

The required licenses for the project or a comparison of required and actual licenses are 
displayed. 

3. You can close the window with X or continue with Perform licensing.... 

http://support.automation.siemens.com/WW/view/en/36947932�
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The license check, i.e. the inspection of the license keys, is carried out in the target system. 
Possible responses in the case of underlicensing are described in the Underlicensing 
section. 

 

 Note 
Memory cards can be purchased with integrated runtime licenses, which do not require 
separate licensing. 

 

3.22.1.4 Displaying existing licenses of the SIMOTION device 

Displaying via accessible nodes 
You can use the list of Accessible nodes  to determine the specific licenses that have 
already been assigned to the SIMOTION device. You can access the data of the SIMOTION 
device directly.  

 

 Note 
This step is not necessary if the required and actual licenses are displayed within a project. 

 

Requirements: 
● SIMOTION SCOUT is running 
● SIMOTION SCOUT is in online mode 
● No projects are open 

Proceed as follows: 
1. Select the Project > Accessible nodes menu.  

The list of accessible nodes is displayed in the working area. 
2. Select the relevant SIMOTION device. 
3. Select Licenses in the shortcut menu. 

The Licenses dialog box appears, showing the actual licenses for the selected 
SIMOTION device. 

4. You can close the window with X or continue with Perform licensing.... 
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3.22.1.5 Performing the licensing 

To perform the licensing: 
If there are no pre-installed licenses, you can acquire the licenses you need and then 
generate the license key required.  

Requirements: 
● Configuration has been completed 
● The project has been saved and compiled 
● The required licenses have been determined 
● The license key has been determined or the serial numbers of the memory medium and 

the CoL are available 
● SIMOTION SCOUT is in online mode 

Proceed as follows: 
1. Select the relevant SIMOTION device in SIMOTION SCOUT. 
2. Open the context menu and click Licensing. 
3. In the Licenses dialog box, click Perform licensing...  

If the Use wizard checkbox is activated, a wizard guides you through the licensing 
procedure. 
If the checkbox is not activated, the window for the expert licensing is opened. You can 
enter the license key there without running through the wizard. 
If you have not yet generated the license key, the wizard gives you the option to switch to 
the Web tool to generate one. Then switch back to the wizard. 

4. If you have an online connection, continue with item 5.  
Otherwise, you can establish an online connection with Online in the Step 2 of 3 window. 

5. Enter the license key in the Step 3 of 3 window. 
6. Click Finish. 

The wizard is closed. Licensing is complete. 
 

 
 

Note 
The license key is written to the retentive memory when the project data is transferred to 
the target system. 
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3.22.2 Changing the license key 
The license key is influenced by changes to the project, such as expanding it to include an 
additional axis. This is why underlicensing is displayed when the project is downloaded and 
the SF LED flashes at 0.5 Hz.  
After you have determined the actual requirement and purchased the necessary licenses, 
generate the license key again. Now replace the license key already entered with the newly 
generated one. 

 

 Note 
Transition from Version 3.0 to a higher version 
In a project as of Version V3.1, the license key is stored in a different location than in a 
Version 3.0 project. You must re-enter the license key in order for Version V3.0 licenses to 
be recognized in a project as of V3.1. 

 

3.22.3 License key is protected from being deleted (as from Kernel V4.1) 
The license key is stored in the "KEYS" directory on the SIMOTION Memory Card. 
When the controller starts up for the first time, the license key will be saved in the boot sector 
of the card and from this time is protected from being lost. 
Operator actions cannot delete the license key in the boot sector. Also not by formatting the 
card or with the "Write boot sector..." function. 
If the license key is no longer present on the card, it will be written again during the startup 
from the boot sector into the "KEYS" directory. This means that the system will repair any 
deletion on the "Key" file. 
The license key can be changed at any time, for example, by relicensing. At the next startup, 
the license key will be saved again in the boot sector. 

3.22.4 Licensing during hardware replacement 
For the replacement of licensed SIMOTION components (MMC, CF, IsoPROFIBUS board or 
PN board), the associated license key must be assigned to the new SIMOTION component. 
In this case, contact the Customer Support for assistance.  
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3.22.5 Underlicensing 
If SIMOTION SCOUT detects the presence of underlicensing during license verification, an 
entry is made in the diagnostics buffer. The verification is repeated every hour, and an entry 
is made in the diagnostics buffer each time underlicensing is detected.  
The following information can be read from the diagnostics buffer entry: 
● Number of required licenses 
● Number of actual licenses 
● Operating mode 
As an additional warning signal, the SF LED flashes at 0.5 Hz as long as underlicensing is 
present on the system. Underlicensing will only be displayed if no acknowledgeable 
technological event is pending, as the same SF LED is used to indicate this as well. 

3.23 Writing the boot sector 
There are various reasons why it might prove necessary to write a boot loader, such as 
when new firmware is used on older hardware. Use the Options > Write boot sector menu in 
SIMOTION SCOUT to enable the boot sector on a memory card to be rewritten. 

Additional references 
For additional information on this topic, refer to: 
● D4x5 and D4x5-2 Commissioning and Hardware Installation Manual 
● The D410 Commissioning Manual 
● SIMOTION SCOUT Online Help 
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Target system 4
4.1 Controlling the target system 

4.1.1 Overview 
In online mode, you can control the SIMOTION device with SIMOTION SCOUT, e.g.:  
● Change and compile program sources 
● Download 
● Control operating mode 
● Set the internal clock of the SIMOTION device 
● Change Configuration Data in RUN Mode 
● Control variables in RUN 
● Copy current data to RAM 
● Copy RAM to ROM 
● Delete the RAM of the SIMOTION device (overall reset) 
● Archive project data 

4.1.2 Controlling the operating mode with SIMOTION SCOUT 
 

DANGER  
Danger to personnel and machine can result from an uncontrolled change of the operating 
mode. 
Please note the safety regulations before you control a SIMOTION device via the mode 
selector in SIMOTION SCOUT. 

 

1. Select the SIMOTION device in the project navigator. 
2. Select the Target system > Control operating mode menu. 

A software switch is displayed. This represents the mode selector on the 
SIMOTION device or the virtual hardware mode selector (SIMOTION P). The current 
operating mode is displayed with symbolized switch setting and LEDs. 

3. Select the desired operating mode. 
Click the corresponding button. 
The switching options are dependent on the position of the mode selector on the 
SIMOTION device. 
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The operating mode can be monitored and switched with the device diagnostics.  

Table 4- 1 Operating modes of a SIMOTION device 

Operating mode Description 
STOP   Technology objects inactive (enables deleted, no axis motion) 

 User program is not executed 
 Loading a user program is possible 
 All system services are active (communication, etc.) 
 All analog and digital outputs set to 0 
 The I/O modules (signal modules) are in the safe state (SIMOTION D) 

STOP U   Technology objects are active 
 Technology objects can execute jobs for testing and commissioning 

functions. 
 Otherwise identical to STOP operating mode 
 STOP U means stop user program 
 User program is not executed 

RUN   Technology objects are active 
 Execution of the user programs assigned to the execution system 
 Loading a user program is possible 
 Process image of the inputs and outputs is read or written 

MRES  Overall reset 
 Switch setting for the overall reset of the SIMOTION C2xx, SIMOTION P350-

3, and SIMOTION D 
 

Table 4- 2 Switching possibilities of the software switch depending on the position of the mode 
switch on the SIMOTION device (with regard to SIMOTION D, see the SIMOTION D4x5 
Manual, SIMOTION D410 Manual, D4x5-2 Manual) 

Mode selector position of the SIMOTION device Switching options of software switch in 
SIMOTION SCOUT 

STOP STOP 
STOP U 
MRES 

STOP U STOP U  
STOP 

RUN RUN  
STOP U  
STOP 

MRES MRES  
STOP 
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Table 4- 3 LEDs of the mode selector 

LED Description Color Meaning 
5 VDC Power OK Green Power supply 5 V 

 Steady:  
Power supply functioning correctly. 

 Flashing:  
Power supply defective 

RUN RUN Green RUN mode 
 Steady:  

SIMOTION device is in RUN mode. 
 Flashing:  

RUN mode is selected (by SIMOTION SCOUT or 
switch) and the SIMOTION device is on its way there. 

 Flashing simultaneously with STOP U 
SIMOTION device is in SERVICE mode. 

 Off: 
SIMOTION device is not in RUN mode. 

STOP U STOP User 
program 

Orange STOP U mode 
 Steady:  

SIMOTION device is in STOP U mode. 
 Flashing:  

STOP U mode is selected (by SIMOTION SCOUT or 
switch) and the SIMOTION device is on its way there. 

 Flashing simultaneously with RUN 
SIMOTION device is in SERVICE mode. 

 Off:  
SIMOTION device is not in STOP U mode. 

STOP STOP Orange STOP mode 
 Steady:  

SIMOTION device is in STOP mode. 
 Flashing:  

STOP mode is selected (by SIMOTION SCOUT or 
switch) and the SIMOTION device is on its way there. 

 Flickering (fast flashing):  
Write access to the memory card 

 Off:  
SIMOTION device is not in STOP mode. 

 
 

 Note 
The LED displays on SIMOTION devices are described in the associated Manuals. 

 



Target system  
4.1 Controlling the target system 

 SIMOTION SCOUT 
106 Configuration Manual, 11/2010 

SIMOTION C and SIMOTION D 

 
Figure 4-1 Mode selector  

 

 Note 
For the SIMOTION D, it is recommended that the operating mode be switched with the 
SIMOTION SCOUT. 

 

On the SIMOTION C, the operating mode can also be set via a rotary switch on the device. 

SIMOTION P 
 

 Note 
With SIMOTION P, the mode selector is displayed via the SIMOTION P Startup application. 
You can call this via Start > Programs > SIMOTION P Startup. 
For more information, see the SIMOTION P Manual. 

 

 
Figure 4-2 SIMOTION P state application 
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Additional references 
Please refer to the following documents on this subject 
● Operating Instructions SIMOTION C2xx 
● SIMOTION P350-3 and Panels Commissioning and Hardware Installation Manual 
● SIMOTION P320-3 and Panels Commissioning and Hardware Installation Manual 
● SIMOTION D4x5 Commissioning and Hardware Installation Manual 
● SIMOTION D4x5-2 Commissioning and Hardware Installation Manual 
● SIMOTION D410 Commissioning Manual 
and the SIMOTION SCOUT online help. 

4.1.3 Overall reset 
Proceed as follows:  
1. Start the software mode selector. 
2. ClickMRES. 
3. Acknowledge the warning. 
On the SIMOTION device, MRES automatically switches to the STOP mode once execution 
is completed. 
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4.1.4 Setting the time of day 
Proceed as follows:  
1. Select the SIMOTION device in the project navigator. 
2. Select the Target system > Set time of day menu. 

The current date and the time of day of the PG/PC and the SIMOTION device are 
displayed. 

3. Change the date and time of day of the SIMOTION device, if necessary: 
If you want to accept the values from the PG/PC: 
– Activate the Accept from PG/PC checkbox. 
If you want to enter values: 
– Deactivate the Accept from PG/PC checkbox. 
– Enter the values in the corresponding fields (Module). 

 
Figure 4-3 Setting the time of day 

4.1.5 Loading data to the target system 
You have to download the project data that you have created with SIMOTION SCOUT to the 
target system. The target system can consist of several CPUs (SIMOTION controllers). 
The project data contains the programs (ST, MCC, LAD/FBD, and DCC) that you have 
created and compiled, the hardware configuration, and the technology objects that you have 
created and to which you have assigned parameters. 

Additional references 
The exact download procedure is described in: 
● SIMOTION Basic Functions Function Manual 
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4.1.6 Archive project data to memory card 
The Target system > Archive project on card... function archives the complete SCOUT 
project on the MMC/CompactFlash card or hard disk of the P350. 
The Target system > Load project from card... function loads the archived SCOUT project 
from the card or the hard disk. 
A zip file is archived. This function is only possible in online mode. In addition to the zip file, 
an info file is saved. This can be read with the Target system > Load project from card... 
function. The following contents are written to the info file:  
● The project name 
● The size of the zipped project file 
● The storage date 
For additional information, see 
● Handling Recommendations for Service with SCOUT V4.1 section 

4.1.7 Loading to the file system 
Use Edit/Target system > Load to File System to save data from a device to the memory 
card/CompactFlash Card or locally to a hard disk.  
For further information, please refer to the online help for SIMOTION SCOUT. 
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Diagnostics 5
5.1 Using diagnostic functions 

5.1.1 Overview of the possible diagnostic functions 
A wide range of diagnostic functions can be used for the operation of SIMOTION devices in 
the online mode. These diagnostic options are summarized in the diagnostics overview:  
● The diagnostics overview is a tab in the detail view and is available by default in online 

mode. You can call up detail displays from here. 
● An Alarms tab is also available in the detail view. This provides a tabular overview of 

– Technological alarms (from technology objects) 
– Alarm_S messages (from user programs) 

The alarms can be acknowledged either individually or all together. 
● The Address list tab in the detail area offers extended functions in terms of I/O 

diagnostics and hardware availability. 
● Comprehensive diagnostic information ( e.g. diagnostics buffer, system utilization, and 

task status, etc.) is accessible via Device Diagnostics as a window in the working area. 
● You can record signal charts with the trace tool. The values of system variables can be 

recorded during runtime for diagnostic purposes. 
● Program testing and debugging, e.g. variable control, program status, breakpoints 
Additional diagnostic functions are available with SIMOTION V4.1 SP2 and higher. On the 
basis of simple operations (e.g. by setting the switch position) and without the need for the 
SIMOTION SCOUT engineering system, you can: 
● Back up diagnostic data including non-volatile data (retain data) to CompactFlash Card 

(for SIMOTION D), MMC (for SIMOTION C) or hard disk (for SIMOTION P) 
● Back up websites, including the most up-to-date content for diagnostic purposes, to the 

CompactFlash Card, MMC, or hard disk 
● Restore backed up non-volatile data (retain data) 
Further information can be found in the FAQs on the Utilities & Applications CD under: 
FAQs > Engineering > Backing up diagnostic data and non-volatile data 
SIMOTION IT DIAG also offers comprehensive diagnostic options that can be easily 
accessed via an Internet browser. 
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References 
For more information, please refer to 
● SIMOTION ST Structured Text Programming and Operating Manual 
● SIMOTION MCC Motion Control Chart Programming and Operating Manual 
● SIMOTION LAD/FBD Programming and Operating Manual 
● Diagnostics Manual: SIMOTION IT Ethernet-based HMI and Diagnostic Function 
● SIMOTION SCOUT Online Help 
● Overview of Service and Diagnostics Options, Product Information 

5.1.2 Using the diagnostics overview 
The diagnostics overview is available as a tab in the detail view when the project is in online 
mode.  
● In the detail view, select the Diagnostics overview tab. 

 
Figure 5-1 Diagnostics overview in the detail view (online mode) 

The following are displayed for each accessible SIMOTION device: 
● Operating mode 
● Memory used (absolute and percentage display) 

RAM disk, RAM, memory card, retentive data 
● CPU utilization (percentage display) 
The drive devices specified in the hardware configuration are also displayed. To obtain a 
detailed display of the individual devices, open the device diagnostics. 
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5.1.3 Device diagnostics 
In online mode, the device diagnostics function enables you to obtain a comprehensive 
display of diagnostics results of the individual SIMOTION devices.  
Proceed as follows: 
1. Select the desired SIMOTION device in the project navigator. 
2. Select the Target system > Device diagnostics... menu. 
or 
1. Double-click the SIMOTION device in the Diagnostics overview tab in the detail view. 

 

 
 

Note 
You may open the device diagnostics for several SIMOTION devices simultaneously. 
This allows you to compare different devices. 
You can also access these device diagnostics via the Accessible nodes function. 

 

The Device Diagnostics window appears in the working area of the workbench. This window 
provides you with the following information: 
● General information 
● Diagnostics buffer 
● Slaves 
● Task runtimes 
● System utilization 
● User log file 
● Syslog file 
● Version overview 
You have the following options: 
● Print: 

Select the Project > Print menu. 
● Save it as a text file: 

Click Save. 
● Refresh:  

Click Refresh or press the <F5> function key. 
You can also monitor and change the operating mode: 
● Click Control operating mode. 
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5.1.4 Device diagnostics: General 
This provides general information on the SIMOTION device:  
● Select the General tab in the Device Diagnostics window. 
The following information will be displayed: 
● Name and system ID of the SIMOTION device 
● Operating mode of the SIMOTION device 
● MAC addresses 
● IP addresses 
● Subnet mask 
● Standard gateway 
● Order numbers and names of the components used,  

e.g. SIMOTION device, Motion Control technology package. 

 
Figure 5-2 Display of general information in the device diagnostics 
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5.1.5 Device diagnostics: Diagnostics buffer 
The diagnostics buffer is part of the system status list. It is possible to jump to the error 
position from the diagnostics buffer (as of V3.2). It logs important events (e.g. changes in 
module state) in the order in which they occur. These include the following:  
● Faults in a module 
● Faults in the process wiring 
● System errors in the CPU 
● CPU operating mode transitions 
● Drive alarms 
● Errors caused by the technology objects of SIMOTION 
● Errors in the user program that caused an operating state transition (a double-click on the 

error message causes the cursor to jump to the error location in the program) 
● User-defined entries with the _writeAndSendMessage function 
● PMC error messages (SIMOTION D) 
● Compatibility errors, e.g. the drive software with SIMOTION (SIMOTION D) 
The SINAMICS Integrated diagnostics buffer is also displayed for SIMOTION D as of 
SIMOTION Version V4.1 SP2. 

To work with the diagnostics buffer: 
1. In the Device Diagnostics window, select the diagnostics buffer tab. 

The saved events are displayed in tabular form. 
2. Select the event for which you want to obtain more information. 

Detailed information for the selected event is displayed in the lower pane of the window. 

 
Figure 5-3 Example of the diagnostics buffer display in the device diagnostics 
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5.1.6 Device diagnostics: Slaves 
The devices displayed in the Slaves tab of the device diagnostics are not identical to the 
display in the Accessible Nodes window.  

 

 Note 
When you open the Slaves tab, you must refresh the display.  
Click the Update button or press F5 on the keyboard. 

 

After refreshing the view, the following devices are displayed in the Slaves tab: 
● Devices configured in HW Config 
● All devices that are configured in the Slaves function 

 
Figure 5-4 Example of the Slaves tab display in the device diagnostics 
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5.1.7 Device diagnostics: Task Manager 
You can display the task runtimes and the status of the tasks set up in the project if you are 
connected online with the unit. The resolution of the displayed task runtimes is performed in 
the servo cycle clock.  

 

 Note 
The task runtimes are calculated to the µs and indicate the effective level runtime of the 
respective task (including the interrupt times). These thus correspond to the values of the 
effectiveTaskruntime device variables. 
The following applies to SIMOTION Runtime versions < V4.1: 
The display is calculated in the servo cycle clock and has only the resolution of the servo 
cycle clock. As the task runtime can be less than the servo cycle clock, e.g., for the 
ServoSynchronousTask or IPOSynchronousTask, the value 0 ms is displayed in this case. 

 

 
Figure 5-5 Example of the task runtimes display in the device diagnostics 

The display is refreshed according to the refresh rate selected. The status and the following 
values are then displayed: 
● Current runtime (current):  

Value of last polling 
● Minimum runtime (min.):  

Minimum value since last transition from STOP to RUN 
● Maximum runtime (max.):  

Maximum value since last transition from STOP to RUN 
● Mean runtime (mean value):  

Value averaged from the last 10 cycles 
The runtimes measured include the interruptions by higher-priority tasks. 
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Meaning of the various status displays: 
● RUNNING (TASK_STATE_RUNNING) 

Task running, e.g.: 
– Via the _startTask function 
– As an active cyclic task 

● RUNNING_SCHEDULED (TASK_STATE_RUNNING_SCHEDULED) (as of V4.1) 
Task interrupted by system. 
If the task status RUNNING_SCHEDULED remains pending for a long time, it identifies a 
long-runner in the user task, e.g., a programmed continuous loop. 

● STOP_PENDING (TASK_STATE_STOP_PENDING) 
Task has received signal to stop; it is in a state between RUNNING and STOPPED. 
Actions may be performed until the task has stopped. 

● STOPPED (TASK_STATE_STOPPED) 
Task stopped (e.g. via the _resetTask function), completed or not yet started. 

● SUSPENDED (TASK_STATE_SUSPENDED) 
Task suspended by function _suspendTask. 
Use _resumeTask(name) to cancel this command. The task then resumes from the point 
at which it was interrupted. 

● WAITING (TASK_STATE_WAITING) 
Task is waiting due to function _waitTime or WAITFORCONDITION. 

● WAITING_FOR_NEXT_CYCLE (TASK_STATE_WAIT_NEXT_CYCLE) 
TimerInterruptTask waiting for start trigger. 

● WAITING_FOR_NEXT_INTERRUPT (TASK_STATE_WAIT_NEXT_INTERRUPT) 
SystemInterruptTask or UserInterruptTask is waiting for the triggering event to occur. 
When an interrupt occurs, the SystemInterruptTasks are started and executed once. Up 
to 8 incoming interrupts can be stored in the buffer. If another interrupt occurs, the buffer 
overflows and the CPU goes into STOP mode. 

● LOCKED (TASK_STATE_LOCKED) 
Task locked by function _disableScheduler. 
This status prevents the activation of all user tasks (except the IPOSynchronousTask and 
IPOSynchronousTask_2) until command _enableScheduler is called. It does not, 
however, affect system tasks. The time watchdog for cyclic tasks is not suspended.  

 

 
 

Note 
The also prevents the activation of the SystemInterruptTasks and UserInterruptTasks. 
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Controlling MotionTasks 
It is possible to control MotionTasks via SIMOTION SCOUT without a user program that has 
been created by the user. Consequently, you can test programs and influence MotionTask 
sequences in a very specific way. 
Selected MotionTasks can be stopped, and locked or restarted for the sequence. 
This means that programs in MotionTasks can also be downloaded in RUN mode. If you 
have made changes to sources and want to reload them in RUN mode, an active 
MotionTask can prevent this. To avoid this problem, you can terminate specific MotionTasks 
with SIMOTION SCOUT and then carry out the download in RUN mode. 

Additional references 
Further information on downloading in RUN mode can be found in: 
● SIMOTION Basic Functions Function Manual 
● SIMOTION SCOUT Task Trace Function Manual 

5.1.8 Device diagnostics: Checking the system utilization 
To display the system utilization:  
● Select the System utilization tab in the device diagnostics. 

 
Figure 5-6 Example of the system utilization display in the device diagnostics 

Additional references 
Further information on this topic can be found in: 
● SIMOTION Basic Functions Function Manual, Chapter "Overview of Memory in Target 

Device" 
● SIMOTION SCOUT Online Help 
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5.1.9 Device diagnostics: User log file 
With the Userlog file, you can store your own text strings in the RT system. This is 
necessary, for example, when changes, which are to be documented, are made in the 
SIMOTION system on a plant which has already been commissioned.  
Changes can be written in the SIMOTION SCOUT. These are loaded to the ROM of the 
target device. When required, the text strings can be read out again. The text editor for the 
Userlog file is integrated as a tab in the device diagnostics snap-in. This function is only 
available in online mode.  

 
Figure 5-7 Example of the Userlog file display in the device diagnostics 

How to work in the Userlog file 
● Select the Userlog tab in the device diagnostics. 

The editor is in editing mode, i.e., you can immediately type or delete. 
The system adds no further system contents, such as date/time.  
You enter all of the necessary information. 

● To save, click Save as... The Userlog file is stored as .txt. 
All text entries can be changed or deleted at any time.  
Access protection is not available. 

● The Userlog file can also be read without a project. 
The online mode is required for this. 

● The Userlog file remains after user data are deleted. 
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5.1.10 Device diagnostics: Syslog file 
In addition to the user-defined Userlog file, the SIMOTION device also has a Syslog file. The 
ROM actions entered therein facilitate a subsequent diagnosis. This function is only available 
in online mode. The information of the Syslog file can also be read without a project.  
The Syslog file logs the following actions: 
● RAM2ROM 
● Overall reset 
● Formatting of the card from SIMOTION SCOUT 

 
Figure 5-8 Example of the Syslog file display in the device diagnostics 
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5.1.11 Device diagnostics: Version overview 
The version overview tab displays the SIMOTION version and the data of the SIMOTION 
device stored in the CompactFlash card.  
The following data are displayed: 
● SIMOTION version 
● BIOS version 
● Components 

Versions of the SINAMICS components 
● Internal version / stamp 

Internal components 
This information is relevant for any questions to the hotline. 

 
Figure 5-9 Example of the version overview display in the device diagnostics 
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5.1.12 Device diagnostics: Alarms 
In the device diagnostics Alarms tab, pending alarms and configured messages are 
displayed in the same way as in the Alarms tab in the detail view.  
Detailed information can be found in the SIMOTION online help, in the Alarms output 
window. 

 
Figure 5-10 Device diagnostics - Alarms 

5.1.13 Diagnostic functions in the address list 
As of SIMOTION V4.2, the address list offers extended functions for I/O diagnostics. In 
online mode, the information is displayed in the Availability column. You can access more 
detailed information via a tool tip if you move the cursor over the relevant cell. 

To open the address list: 
1. Browse to the folder for your device in the project navigator. 
2. Double-click the ADDRESS LIST entry. 

The address list opens in the detail area. 

The summary contains the following diagnostic information: 
● I/O stations which have failed completely 
● Modules have been removed (e.g. for ET200S). 
● Deactivated I/O stations 
● I/O variables working with replacement values 
● I/O stations whose set topology differs from the actual topology 
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● I/O stations configured to be isochronous are not isochronous 
– Distributed synchronous operation 
– Drive units 
– Isochronous I/O 

● Partner device has stopped (e.g. I-device, I-slave) 
● For PROFINET devices: Provider state/consumer state is showing an error 

– Controller 
– I/O device 
– Module 
– Submodule 

See also the description of the _quality() system function in the section titled Detailed status 
of I/O variables (as of kernel V4.2) in the SIMOTION ST Structured Text Programming and 
Operating Manual. 
For further information on diagnostics involving the address list, please refer to the online 
help. 

5.1.14 Interconnection overview 
The interconnection overview allows you to display all motion input and output 
interconnections of technology objects within the project. This overview is displayed in the 
SIMOTION SCOUT working area in the form of an interconnection tree.  
The tree display enables the synchronous operation interconnections to be displayed in 
cascades. In the interconnection table below, you can see all the TOs interconnected on the 
input and output sides for the technology object selected in the interconnection tree. 

 
Figure 5-11 Example of an interconnection overview 
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Additional references 
Further information on this topic can be found in: 
● Function Manual: SIMOTION Basic Functions 
● SIMOTION SCOUT Online Help 

5.1.15 Service Overview 
In online mode, the service overview shows a tabular complete overview of all configured 
axes in the project. The current state (including values from system variables) is displayed 
along with fault conditions. 
The service overview is called up via the Target system > Service overview menu. 

 
Figure 5-12 Service Overview 
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5.1.16 Task Trace 

Application area 
The SIMOTION Task Trace supports you when troubleshooting in the SIMOTION 
multitasking environment. The SIMOTION Task Trace records the sequence of individual 
tasks, identifies user events that you can generate via a program command, and displays 
these graphically.  

Structure of the Task Trace 
The SIMOTION Task Trace includes two main components: 
● The SIMOTION Task Tracer, which writes the task change and events to a buffer on the 

target device, and  
● The SIMOTION Task Profiler, an application for displaying the recorded data  

Additional references 
Further information on this topic can be found in: 
● Function Manual: Task Trace 
● Diagnostics Manual: SIMOTION IT Ethernet-based HMI and Diagnostic Function 
● SIMOTION SCOUT Online Help 

5.1.17 Accessible nodes 
A list of the devices switched on and connected to the PG/PC is displayed via the Accessible 
nodes function in the SIMOTION SCOUT working area. The display is related to the PG/PC 
interface which is configured as the application access point in "Set PG/PC interface".  
A SIMOTION project must not be open in order to use this function. 
Proceed as follows: 
1. Select the Project > Accessible nodes menu. 
2. Select the corresponding node. 
3. Right-click and select the following functions in the context menu. 
● Operating mode ... 
● Device diagnostics ... 
● Copy from RAM to ROM ... 
● Licenses 
● Log files 
● Archived project 
● SINAMICS Upload 
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Additional references 
For additional information on this topic, refer to: 
● SIMOTION SCOUT Online Help 

5.1.18 Program testing and debugging 
Comprehensive program testing and debugging functions are available in SIMOTION 
 SCOUT. You can execute the following functions: 
● Control variable 
● Program status 
● Breakpoints 

Additional references 
Please refer to the following documents on this subject: 
● SIMOTION ST Structured Text Programming and Operating Manual 
● SIMOTION MCC Motion Control Chart Programming and Operating Manual 
● SIMOTION LAD/FBD Programming and Operating Manual 
● SINAMICS/SIMOTION DCC Editor Description, Programming and Operating Manual 
and the SIMOTION SCOUT online help. 
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5.1.19 Project comparison 
You can use the SIMOTION SCOUT/Project comparison starter function to compare objects 
within the same project and/or objects from different projects (online or offline) with one 
another.  
Objects are devices, programs, technology objects (TOs) or drive objects (DOs), and 
libraries. 
The project comparison is available with SIMOTION SCOUT and Starter. Comparing 
projects is useful if you need to carry out service work on the system. 

1. Start the project comparison by clicking the Start object comparison button. 
2. The Select Comparison Partners dialog is displayed. Select the projects to be compared. 

 
Figure 5-13 Select comparison partner dialog 
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Figure 5-14 Synchronizing project data via the project comparison function 

 

 
 

Note 
A detail comparison is only possible if supplementary data (e.g. program sources) has 
also been downloaded to the target device (Options > Settings > CPU download). 

 

References 
For detailed information, refer to: 
● Function Manual: SIMOTION Project Comparison 
● SIMOTION SCOUT Online Help 
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5.1.20 Project overview 
In Utilities&Applications, select Scripts > Report scripts to access scripts for generating 
reports on all 
● TOs 
● Programs, function blocks, functions 
● Units 
● Tasks and assigned programs 
in the current SIMOTION project. 
A script lists the relevant specific objects of the SIMOTION project in an HTML document, 
arranged in a tabular format. Once generated, the HTML document opens and is displayed 
automatically in the Internet Explorer. The information involved can also be saved from there 
in HTML or CSV format or as an Excel file. 

5.1.21 Services and diagnostics without an Engineering System 
SIMOTION devices have an integrated web server. The web server supports the display of 
diagnostic and system data in standard Internet browsers, even in the absence of an 
Engineering System, and the carrying out of project/firmware updates.  
For more detailed information, see the SIMOTION IT Ethernet-based  
HMI and Diagnostic Function Diagnostics Manual. 
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Upgrading and project updates 6
6.1 Upgrading devices and project updates using the device update tool 

Overview 
SIMOTION offers a convenient solution for machine manufacturers and machine operators 
to update SIMOTION devices or SIMOTION projects. 
Updating does not simply refer to an update to a higher version of firmware; rather, in 
general terms it refers to switching to a defined configuration, e.g. a project update. It is also 
possible to return (restore) to a previous configuration. Update or restore procedures can 
easily be performed on SIMOTION devices locally or remotely. The data can be imported to 
a SIMOTION device via a convenient and handy storage medium or a communication 
connection. 

 

 Note 
As far as the P350 is concerned, there are currently only plans to upgrade the project data, 
technology packages, and user data. Firmware cannot be upgraded given the dependency 
on other Windows components. 

 

Update data and update media 
The update data is created by SIMOTION SCOUT based on one or more 
SIMOTION projects. All information required for the update is contained in the update data. 
This includes: 
● SIMOTION project 
● Technology packages 
● User data 
● Firmware 
After the update data has been created, it can be handled flexibly depending on the 
SIMOTION device in question (SIMOTION C, D, or P). The storage or update medium can 
take the form of: 
● CF/MMC card 
● USB memory stick or 
● SIMOTION IT DIAG file 
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Update wizard and Device Update tool 
Call up the update wizard via SIMOTION SCOUT. This will give you a step-by-step guide to 
creating the requested update data, which are then either saved in an update archive or 
imported directly to an update medium. 
1. Select the Project > Start device update tool menu, either directly in SIMOTION SCOUT 

or in an open SIMOTION project. 

 
Figure 6-1 SIMOTION SCOUT - Starting the SIMOTION Device Update tool 

2. The update wizard opens with the start screen . Now you can select the data for updating 
from the SIMOTION project to the SIMOTION device on a step-by-step basis, and specify 
whether you want to update subsets or the entire project. 
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Figure 6-2 Wizard start page: Device Update tool 

Additional references 
A detailed overview of the update process can be found in: 
● Operating Manual: Upgrading SIMOTION Devices 
● SIMOTION SCOUT Online Help 
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Services with SCOUT 7
7.1 Selecting the right project with SCOUT 

The observation of the following recommendations for the configuring simplifies maintenance 
work. 

Working with the right project 
In order to ensure that you are always working with the right project, save the revised and 
archived project as a zip file on the CF card.  
For details on how to do this, refer to the section titled Archiving and backing up projects on 
memory cards (Page 93). 
You should only use this zip file in future.  
The project data can be archived on a memory card in SCOUT. 

 
Figure 7-1 Archive SIMOTION project to card 

The accessible nodes function can be used to determine on which CPU a Project.zip is 
stored. 

Differences between the SCOUT project and the project data loaded to the device 
Once you are online, any inconsistencies between the engineering project and the data in 
the target system are highlighted in the project navigator with "red" symbols.  
The object comparison feature enables you to show these differences in detail and perform 
an alignment process. 
For additional information, refer to the section titled Project comparison (Page 128). 
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Load the project from the memory card. 
The project data archived on the memory card can be transferred to "PROJEKT.ZIP" on the 
hard disk of the PG/PC in the Accessible Nodes view via context menu (right mouse button).  
Alternatively, the SCOUT function is also available in the context menu 
Load project from card... on the device. Next, the archive project transferred to the hard disk 
must be dearchived. 

Use routing 
The following must be considered in order to be able to use routing (e.g., for access to 
SINAMICS_Integrated with SIMOTION D4x5):  
● If the project should be generated on another computer, a  

PG/PC assignment is necessary. The PG/PC has the unique "computer name" of the 
creation system and this must be adapted to the current system. 

● This change can be made directly using the Assign PG/PC toolbar button. 

The Log Files as Further Help 
The Syslog file and the Userlog file are also available to help verify the project (as 
of Runtime V4.0). These files are stored on the memory card can can be read out, for 

example, without a project on the PG/PC using the SCOUT function 
Accessible Nodes.  
The log files on the memory card are directly accessible from the dialog box (via context 
menu). 

 
Figure 7-2 Log files via the context menu 

● user\simotion\hmi\syslog\syslog.000 
System logbook: The system makes an entry here when a RAM TO ROM, an overall 
reset or a reformatting of the memory card is carried out. 

● user\simotion\hmi\prjlog\userlog.txt 
Machine logbook: It is possible here to document the tasks carried out and the SCOUT 
version used for the next service worker. Call for editing from the SCOUT dialog box 
Device diagnostics. 
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Below are other data, which are stored on the memory card and can be accessed from this 
dialog box: 
● USER/SIMOTION/HMI/PRJLOG/info.txt  

is created with the archived ES project and contains the name, variable, save date. 
● USER/SIMOTION/HMI/PRJLOG/project.zip 

archived ES project. Max. 1 archived project can be archived on the memory card using 
SCOUT. 

The above-named files visible in the dialog box also remain on the memory card after 
Delete user data. 
For a detailed description, please refer to: 
● SCOUT Online Help -> Device diagnosis: Syslog / Userlog 
● Device Diagnosis section: User log file 
● Device Diagnosis section: Syslog file 

7.2 Project was created in Version V3.2 SP1/V4.0/V4.1 
If the project was created in Version V3.2 SP1/V4.0/V4.1, remember the following points:  
● If SCOUT V4.2 is used to open a project created with an earlier version of SCOUT, a 

request is automatically made to convert the project to the current internal data format of 
SCOUT. 
In such cases, only the data management of the SCOUT project is converted to V4.2; the 
SIMOTION device version is not converted. 

● After the project conversion, the system asks whether the project should be opened write-
protected. 
If the project needs to be changed, the write protection can also be revoked later. 
– Select Project > Revoke write protection from the menu bar.  
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7.3 Project V3.2 SP1/V4.0/V4.1 was edited with SCOUT V4.2 
If the project of version V3.2 SP1/V4.0/V4.1 was edited with SCOUT V4.2, remember the 
following points: 
● The project can be saved back in the original project version when closing the projects, 

exiting SCOUT or by selecting the SCOUT function Save in old project format.... This 
makes it possible to edit the project later using the corresponding SCOUT version again. 

 

 
 

Note 
In case of a back-conversion to the V3.2 SP1/V4.0/V4.1 project format, the V4.2 internal 
compilation results of the changed sources are deleted. 
This means that after the project has been opened again and the online connection 
made, the changed sources are inconsistent (shown in red). 
Only after the compilation and download are completed are the sources consistent again 
(shown in green). 
This is due to the editing with different SCOUT versions, which contain different compiler 
versions. 

 

● If the project was opened write-protected for diagnostic purposes or if no changes were 
made in non-write protected mode, then it need not be saved. 

Recommendation 
After editing an earlier project version using SCOUT V4.2, the engineering project should 
remain in Version V4.2. This eliminates the need to back-saving in the old project format so 
that the project remains consistent at all times.  
The engineering project is then no longer available in the old project version. 
After the project changes are completed, they should be documented in the Userlog file. 
The Userlog file is edited in the device diagnostics dialog box. 

 
Figure 7-3 Example of the User log file display 
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7.4 Introduction of versioning with standard library and software 
components 

It is possible to introduce versioning for any standard library and any software component 
during configuration, i.e., each component then has its own version identifier.  
● For every unit and every library the version, author and a brief description in the 

comments field (offline version identifier) in the Properties dialog box in 
SIMOTION SCOUT. 

● Each library and each software component can disclose its version identifier during 
runtime (online version identifier identical to offline version identifier). 
– Version identifier as constant(s) or 
– Version identifier as function return value, e.g. FCGetVersion. 

● The version identifiers can be displayed separately on the available HMI systems, i.e., 
self-identification of all involved system components. 

● A simple variant for applying versioning is in a date identifier as a constant in the format 
yyyy-mm-dd. This can be assigned to a variable, which is then, for example, passed on to 
HMI systems for the version display. 
 
Example, date identifier: 

VAR_GLOBAL CONSTANT  
 APP_VERSION : UDINT := 20060612; // 12.06.2006 
END_VAR  
 
VAR_GLOBAL  
 G_uAppVersion : UDINT := APP_VERSION; 
END_VAR  
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Advanced Diagnostics on SCOUT crash 8
 

In the rare event of a SCOUT crash, important diagnostics data can be stored. This data is 
important for the reproducibility of the error in order to determine the cause. Contact the 
hotline straightaway and forward the diagnostics data.  
The following dialog "Siemens Automation Diagnostics" would open: 

 
Figure 8-1 Siemens Automation Diagnostics 

Please note the following: 
1. Click on the Create report button to generate the diagnostics data. 

Another dialog opens. 
 

 
 

Note 
If you close the dialog by pressing Cancel, the diagnostics data is not saved! 

 

 
Figure 8-2 Generate Diagnostics Data 

2. Click Detailsbutton. Another "Siemens Automation Diagnostics" dialog is displayed. 
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Figure 8-3 Siemens Automation Diagnostics - Details 

In this window, there is more detailed information in the Details and Common data tabs. 
● Add File(s) button 

Here, you can add more user-specific files to the diagnostics directory. 
● View Report button 

The problem details are displayed in plain text. 
● Close button 

The dialog closes. The diagnostics data is saved in the following default directory: 
– U7umc/data/AdvancedDiagnostic/<files> 

● Save As button 
You can select a user-defined directory to save the diagnostics data to. 

● Discard button 
Corresponds to 'Cancel', the diagnostics data is not saved. 
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Network configuration and HMI connection 9
9.1 Rules for arranging modules in HW Config 

Slot rules 
Modules must be inserted in the rack without gaps.  
Exception:  
Slot 3 remains empty in the configuration table. This slot is reserved. 

 

 Note 
The actual arrangement has no gaps, as otherwise the bus on the backplane would be 
interrupted. 

 

 

Table 9- 1 Slot rule for SIMOTION rack 0 (SIMOTION C only) 

Slot 1:  Power supply only, PS 307 xA 
Slot 2: CPU only  
Slot 3: Empty or interface module 
Slots 4 to 11: I/O modules or empty 

SIMOTION SCOUT provides the following support when you configure a station:  
● A message will appear if, for example, a module cannot be inserted into the desired slot. 
● Address areas are also checked to prevent dual allocation of addresses. 
● The status bar or messages displayed provide feedback, which you should pay attention 

to. Important information can also be found in the help. 
● Temporary rules, that is, rules that apply only to a specific version, are not considered 

(such as restriction of the useable slots due to a functional restriction for individual 
modules). 

Consult the documentation or the current product information for the modules. 
 

 Note 
Modules that are installed but not configured are repeatedly addressed via the PROFIBUS. 
This requires additional computing time.  
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9.2 Routing 
Routing describes the relaying of information from one network x to another network y.  
With SCOUT and STEP 7, it is possible to access SIMOTION, drives, and S7 stations online 
via a PG/PC beyond the subnet boundaries, in order to, for example, load user programs or 
a hardware configuration or to perform test and diagnostic functions. You can connect this 
PG/PC to any position in the network and establish an online connection to all stations that 
can be reached via gateways. 
For more details on this topic, see the following documents: 
● SIMOTION Communication System Manual 
● SIMOTION D4x5/D4x5-2 Commissioning and Hardware Installation Manual 
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9.3 HMI (Human Machine Interface) connection 
SIMOTION allows the end user to communicate with operating devices (Human Machine 
Interface systems) such as operator panels.  
The following configuration is possible, for example, with the SIMOTION C240:  
● HMI device is connected to the non-isochronous PROFIBUS of SIMOTION device 1. 
● Four other SIMOTION devices are connected to the PROFIBUS DP (isochronous) of 

SIMOTION device1. 
SIMOTION automatically also establishes connections between the HMI device and 
SIMOTION devices 2 to 5 (routing). Therefore, the HMI device can also display variables, 
messages, and alarms for these devices. 

 

 Note 
The number of routed connections depends on the device. Between 4 and 10 routed 
connections are possible.  
A maximum of two routers are possible. 
For more information, please contact your local Siemens representative. 

 

 

 
Figure 9-1 Example for the connection of an HMI device to a group of SIMOTION devices 

 

 Note 
Routing via a controller, e.g. C2xx, P350 or D4x5, is only possible if the controller has been 
configured as active I-slave. However, please note that with an active I-slave, the 
PROFIBUS connection on the HMI can no longer be operated isochronously. 
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9.4 Higher-level automation systems 
A SIMOTION device can be connected to a higher-level automation system. Communication 
takes place via the MPI interface of the SIMATIC STEP 7 device or the non-isochronous 
PROFIBUS interface of the SIMOTION device. 

 
Figure 9-2 Higher-level automation system with SIMOTION device  

Additional references 
For additional information, refer to: 
● SIMOTION Communication System Manual 
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Scripts for SIMOTION 10
 

The scripting functionality enables you to automate the configuration of devices, SIMOTION 
technology objects (TOs), and SINAMICS drive objects (DOs) with the help of the easy-to-
learn script language VBScript. Standard scripts can be adapted to special situations 
occurring during runtime with interactive queries. This facilitates and speeds up 
commissioning. Other application possibilities include the documentation of the settings that 
have been made and the repetition of complex settings without error.  
To access these scripts and the related documentation, select Scripts in 
Utilities&Applications. 
The selection of documents and scripts you will find there should help you quickly get to 
grips with scripting in SIMOTION. As well as demonstration-only scripts for studying the 
code, there are also scripts and script libraries you can actually use yourself. 
For further information, please also see Scripts for sequence automation in the online help. 
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Creating an example program for axis positioning in 
SIMOTION SCOUT 11
Program overview 

In this section, a program for positioning the connected axis is created in the MCC (Motion 
Control Chart) editor. 
The Getting Started section of the SIMOTION SCOUT online help contains a detailed 
description of an example configuration. 

Requirements 
● You need to have created a SIMOTION device 
● You need to have created an Axis 1 technology object (e.g. as a virtual axis). 

Inserting the programs 
Set four programs with MCC. 
● motion_1 
● backgr 
● perfault 
● tecfault 

Creating a program with MCC 
1. Open the Programs folder under the created SIMOTION device in the project navigator. 
2. Double-click Insert MCC unit. 
3. Enter the name motion_1 for the MCC unit. 
4. Click the Compiler tab. 
5. Activate the required settings. 
6. Click OK. An MCC unit is created in the project navigator. 
7. Double-click the MCC unit motion_1 in the project navigator. 
8. Double-click Insert MCC chart. 
9. Enter the name motion_1 for the MCC. 
10. Click OK. The MCC is opened. 
11. Click the Single-axis commands > Switch axis enable icon. 

The command is inserted. 
12. Click the Single-axis commands > Position axis icon. 

The command is inserted. 
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13. Click the Single-axis commands > Remove axis enable icon. The command is inserted. 

 
Figure 11-1 Menu bar of the single-axis commands 

 
Figure 11-2 Opened command: Position axis 

14. Double-click the Switch axis enable command. 
15. Click OK. 
16. Double-click the Position axis command. 
17. Enter the value 2000 at Position. 
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18. Select Relative in the Type field. 

 
Figure 11-3 Arrangement of the single-axis commands in MCC motion_1 

19. Click OK. 
20. Double-click the Remove axis enable command. 
21. Click OK. 
22. Compile using the menu command MCC chart > Apply and compile. 

Creating the backgr program 
1. Double-click Insert MCC unit. 
2. Enter the name backgr for the MCC unit. 
3. Click the Compiler tab. 
4. Activate the required settings. 
5. Click OK. An MCC unit is created in the project navigator. 
6. Double-click the MCC unit backgr in the project navigator. 
7. Double-click Insert MCC chart. 
8. Enter the name backgr for the MCC. 
9. Click OK. The MCC is opened. 
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10. Enter the following variable data in the MCC unit backgr. 
– In the Name field: Run 
– As the variable type, select: VAR_GLOBAL 
– As the data type, select: BOOL 
– In the Initial value field: False 

 
Figure 11-4 Entering a global variable 

11. Switch to the MCC Chart backgr tab. 
12. In the Program structures command bar, click on the  

IF program branch icon. 

 
Figure 11-5 IF program branch under basic commands 

13. Double-click the IF program branch command. 
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14. Select Formula and enter the condition Run=true. 

 
Figure 11-6 Configuration of the IF program branch 

15. Confirm the input with OK. 
16. In the Task commands command bar, select the command Start task. 

This inserts the command. 
17. In the Important commands command bar, select the command Variable assignment. 

This inserts the command. 
18. Double-click the Start task command. 
19. Click OK to confirm. 
20. Double-click the Variable assignment command. 
21. Enter the statement Run:=false. 

 
Figure 11-7 Configuration of the variable assignment 
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22. Click OK to confirm. 

 
Figure 11-8 Completed program of the BackgroundTask 

23. Select MCC Chart > Accept and compile from the menu bar. 
The detail display in the Compile/Check output tab indicates how compilation is 
progressing and when it is complete. 

Creating the perfault program 
1. Double-click Insert MCC unit. 
2. Enter the name perfault for the MCC unit. 
3. Click the Compiler tab. 
4. Activate the required settings. 
5. Click OK. An MCC unit is created in the project navigator. 
6. Double-click the MCC unit perfault in the project navigator. 
7. Double-click Insert MCC chart. 
8. Enter the name perfault for the MCC. 
9. Click OK. The MCC is opened. 
10. Select from the menu bar MCC chart > Apply and compile. 

Creating the tecfault program 
The procedure for creating the tecfault program is exactly the same as for the perfault 
program. 
In the MCC unit and MCC chart, enter tecfault as the name. 
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Assigning programs to the execution system 
1. In the project navigator, double-click Execution system under the SIMOTION device. The 

execution system is opened in the working area. 

 
Figure 11-9 Execution system of the SIMOTION device 

2. Click the MotionTasks button. 
3. Assign the motion_1 program to MotionTask_1. 
4. Assign the backgr program to the BackgroundTask. 
5. Assign the perfault program to the PeripheralFaultTask. 



Creating an example program for axis positioning in SIMOTION SCOUT  
  

 SIMOTION SCOUT 
156 Configuration Manual, 11/2010 

6. Assign the tecfault program to the TechnologicalFaultTask. 

 
Figure 11-10 Assignment of the tasks in the task system 

7. Click the Save project and compile all button. 

Loading the programs to the SIMOTION device and switching to RUN 
The toggle switch of the SIMOTION device is still set to STOP.  
1. Establish an online connection. To do this, click the Connect to selected target devices 

button. 
2. Click the  Download project to target system button. 

This can take several minutes. 
3. Switch the SIMOTION device to RUN via the keyswitch after the project has been 

downloaded to the target system. Two LEDs, the green 5 VDC and the RUN LED, light 
up. 
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Monitoring and controlling in SIMOTION SCOUT 
1. Click the Connect to selected target devices button. 
2. Select the backgr program. 
3. Activate the Monitor function in the MCC toolbar. 
4. Select the Symbol browser tab. 
5. As control value, enter the variable Run "TRUE". 
6. Activate the setting in Status value. 
7. Click Start status. The value FALSE is displayed. 
8. Activate the setting in Control value. 
9. Click Control immediately. The active command is highlighted in yellow in the program. 

 
Figure 11-11 Monitoring and controlling the variable in the BackgroundTask 

The motor now rotates at 6000 rpm and approaches the position 2000 mm. You can 
check this by selecting Axis_1 under Axes, opening positioningstate in the symbol 
browser, and noting the actualposition. 
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10. Select the variable to be monitored. 
11. Click Start status. 

 
Figure 11-12 Checking the positioning motion in the symbol browser of Axis_1 

When the axis has finished positioning, a value of 2000 mm appears here. If the positioning 
is restarted, the actual position value increases by 2000 mm for each motion. 
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Product combinations 12
12.1 Compatibility 

12.1.1 General compatibility 
Different hardware and software combinations as well as different Kernel and SIMOTION 
SCOUT version combinations are possible when using SIMOTION.  
These possible combinations can be found in the compatibility list on the SIMOTION SCOUT 
add-on CD (under 1_Important) as well as on the Internet at:  
http://support.automation.siemens.com/WW/view/de/18857317  

12.1.2 Software compatibility 

Technology packages with Kernel 
The SIMOTION Kernel and the technology packages must always have the same version.  
Example: Only a TP Cam Version V3.2 technology package will run on a SIMOTION Kernel 
Version V3.2.  

Table 12- 1 SIMOTION SCOUT with SIMOTION Kernel 

Kernel version SCOUT version 
V2.1.x V3.0.x V3.1.x V3.2.x V4.0 V4.1 

SCOUT V3.2.x x x x x - - 
SCOUT V4.0 - x x x x - 
SCOUT V4.1 - x x x x x 
x = supported; - = not supported 

Project on memory card with SIMOTION Kernel 
A project contains SIMOTION devices with a particular configured version. This exact 
SIMOTION Kernel version must be available on the relevant SIMOTION device. 
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SIMOTION SCOUT with project version 
A project with a version earlier than the installed version of SIMOTION SCOUT will be 
converted to the current version when it is opened. Only the data content of the 
SIMOTION project will be converted to the current version, but not the SIMOTION device 
version. 
Example: If you have installed SIMOTION SCOUT V4.1 and wish to open a project created 
in SIMOTION SCOUT Version V4.0, the project is converted to V4.1 . 

Table 12- 2 SIMOTION SCOUT with project version 

Project created with SCOUT version SCOUT version 
V2.1.x V3.0.x V3.1.x V3.2.x V4.0 V4.1 

SCOUT V3.2.x* x x x x x x 
SCOUT V4.0* x x x x x x 
SCOUT V4.1* x x x x x x 
x = supported; - = not supported 

* As of SIMOTION SCOUT Version V3.1 SP1, a project can be saved in the project format of 
an older version (up to Version V3.0), and therefore opened and worked on with an older 
version of SIMOTION SCOUT. 
To successfully convert a project to an older format, no devices or functions must be used 
which are not implemented in the desired version./ 
Detailed statements on combining products can be found in the compatibility lists 
(see section General compatibility (Page 159)). 

12.2 Memory media of the SIMOTION devices 

Storing on memory media 
The online project consisting of the technology package and the user data is saved to a non-
volatile storage medium. The storage medium used will vary depending on the SIMOTION 
platform.  
● SIMOTION C: Micro memory card 
● SIMOTION P: Virtual memory card 

Handling and functionality correspond to the micro memory card of the SIMOTION C. 
● SIMOTION P: CompactFlash card 
● SIMOTION D: CompactFlash card 

 

 
 

Note 
The memory card must not be inserted or removed during operation. Removing the card 
in RUN mode triggers an overall reset, which results in the loss of stored data. 
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Additional references 
More information on this topic is available in 
● SIMOTION C Operating Instructions 
● SIMOTION P350, SIMOTION P350-3, SIMOTION P320-3, and Panels Commissioning 

and Hardware Installation Manual 
● SIMOTION D4x5 and SIMOTION D4x5-2 Commissioning and Hardware Installation 

Manual 
● SIMOTION D410 Commissioning Manual 
● SIMOTION SCOUT Online Help 

Retentive data 
Retentive data (non-volatile data) is saved to a non-volatile memory in the SIMOTION 
device. Depending on the SIMOTION device involved, this non-volatile memory buffers the 
data  
● Permanently (e.g. NVRAM with D410, D4x5-2) or 
● Using a buffered SRAM (e.g. D4x5). 
With an SRAM, buffering uses a SuperCap and (this is optional) a battery. 
You can back up the non-volatile data to a memory card (e.g. CompactFlash or MMC)  
● To avoid loss of data with an SRAM if the buffer fails 
● To protect data in the event of a spare part failing 
Use the _savePersistentMemoryData system function to back up the non-volatile data to the 
memory card. 
In the event of a buffer failure or module replacement, the data is automatically restored at 
the time of ramping up. 

Additional references 
More information on this topic is available in 
● Function Manual: Basic Functions 
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12.3 STEP7 

12.3.1 SIMATIC Manager 

Open SIMOTION project 
You can also open a project in the SIMATIC Manager and edit it with the tools provided. 
However, you do not have any direct access there to specific SIMOTION components, such 
as technology object and programs. 
You can open the SIMOTION SCOUT from the CPU. 

 

 Note 
You can use File > Manage... to show and hide the projects you have created in 
SIMOTION SCOUT in the SIMATIC Manager. 

 

12.3.2 SIMATIC logon (V4.1.1) 

Overview 
As of SIMOTION SCOUT V4.1, you have the option of assigning a project password to 
provide access protection for projects. This functionality requires the previous installation of 
the SIMATIC Logon STEP7 option. 
This function makes it possible to restrict project creation to authorized personnel only and to 
track changes in versions created with SIMATIC Logon. It also therefore provides support for 
the validation process of a machine or system [as per FDA 21 CFR Part 11].  

Installation / Prerequisites 
The STEP7 V5.4 SP1 options SIMATIC Logon and Version Trail must be installed and 
licensed in addition to SIMOTION SCOUT V4.1. 

Features 
When SIMATIC Logon is installed, password protection can be activated for any project. A 
SCOUT project saved with SIMATIC Logon can only be opened and edited with password 
protection. 
● If a project is opened in SCOUT that has an access protection set with SIMATIC Logon, 

the access dialog appears in which the project password must be entered. This means 
the correct password must be entered to open the project. 
If an incorrect password is entered, an error message will be issued and the project 
remains closed. 

● Passwords are assigned in a separate administrator screen using a process configured 
according to the guidelines under FDA 21 CFR Part 11. 
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● Every file open and every change is automatically recorded in a revision log. 
● SCOUT projects created with SIMATIC Logon can be archived, managed and their 

changes tracked in a clearly organized fashion using the SIMATIC Version Trail option. 

Activate SIMATIC logon 
When SIMATIC Logon is installed, password protection can be activated for any project. 
To do this, select Options > Access Protection > Activate in SIMATIC Manager. 

 
Figure 12-1 Activate SIMATIC Manager access protection 

When access protection is activated, the SIMATIC Logon Service window opens. The 
administrator logs in here to assign a project password for this project. 

 
Figure 12-2 Activate access protection 

Then the users are entered in the user administration for this project using drag&drop. 
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Figure 12-3 SIMATIC Logon AdminTool 

Open protected project 
When a protected project is opened, the following dialog box appears if SIMATIC Logon is 
installed. Enter your user name and password here.  

 
Figure 12-4 SIMATIC Logon service 

If SIMATIC Logon is not installed, the project can also be set to open only with the project 
password using STEP7 V5.4. 

 
Figure 12-5 Enter the project password. 

For more details on this topic, see the following document: 
● SIMATIC Logon; SIMATIC Electronic Signature, Manual 
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12.3.3 SIMATIC Version Trail (V4.1.1) 

Overview 
SIMATIC Version Trail is a software option for SIMOTION engineering which, together with 
the SIMATIC Logon central user administration, can assign a version history to libraries and 
projects.  

Installation / Prerequisites 
SIMATIC Version Trail is an option in STEP7 V5.4 SP1 and must be installed and licensed in 
addition to SIMOTION SCOUT V4.1. SIMATIC Version Trail can only be used and licensed 
in a package together with SIMATIC Logon. 

Function 
When archiving, SIMATIC Version Trail creates a version history with the following 
information in association with SIMATIC Logon: 
● Version 
● Version name 
● Date and time 
● Users 
● Comments 
This version history can be displayed and printed. Individual versions can be retrieved from 
the version history, and used further. SIMATIC Logon organizes the access protection. 
View of a SIMATIC Version Trail window, showing the project name, comments and 
versioning data. The versions created with SIMATIC Logon can be documented and 
managed in a clearly organized fashion after changes. 
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Figure 12-6 SIMATIC Version Trail - version data 

 

 Note 
Please note that SIMATIC Version Trail cannot be used separately, but only in combination 
with SIMATIC Logon. 

 

12.4 NetPro 

NetPro in STEP7  
NetPro is integrated in the STEP 7 basic package. NetPro is a tool that supports network 
configuration in STEP 7. 

Application for SIMOTION 
So that network nodes can communicate, configure networks and/or subnets in NetPro. In 
NetPro, you create a graphic view of the networks and subnets and specify their properties 
or parameters. You can also define the node properties. 
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You can open NetPro in SIMOTION SCOUT using the  button, whereby the NetPro 
application opens as a separate window. Application cases for the SIMOTION project are, 
for example, the connection of the engineering system via network nodes and the creation of 
routing connections. 

Additional references 
Detailed information can be found in: 
● Online help, SIMOTION SCOUT Getting Started 
● SIMOTION SCOUT Communication System Manual 

12.5 HMI 

Overview 
The Human Machine Interface (HMI) connects the world of automation with the individual 
demands of the operator. As part of TIA, SIMATIC HMI supports uniform engineering under 
Windows, accesses common data and communicates uniformly.  
For efficient machine operation and monitoring in various performance classes, you can use 
the following panels recommended for SIMOTION as well as PC-based panel systems with 
membrane keyboards or touch screen operation: 
● Panels 

For efficient machine operation and monitoring in various performance classes, either 
text-based or graphics-capable with membrane keyboards or touch screen operation. 

● Multi-panels 
These can be used for operator control and monitoring in the same way as the panels, 
with operation by means of touch screens or membrane keyboards. Multi-panels (MP) 
also permit the installation of additional applications and therefore provide typical PC 
flexibility. 

● Panel PCs 
Are designed for demanding environmental conditions and provide the same degree of 
robustness and suitability for industry. 

SIMATIC ProTool/Pro, a modern visualization software under Windows, and the WinCC 
flexible engineering software are available for the display of the user interface. 

Additional references 
Detailed information can be found in: 
● Catalog: SIMOTION, SINAMICS S120 and Motors for Production Machines 
● PM 21 Catalog. 
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SIMATIC ProTool/ ProTool/Pro 
ProTool is the system-wide and uniform configuration software under Windows for all 
SIMATIC HMI operator panels.  
SIMATIC ProTool covers the applications of the machine-related area with PC-based control 
and monitoring solutions for single-user systems based on ProTool/Pro through to the 
SIMATIC HMI operator panels. For the configuration of the ProTool/Pro runtime for PCs as 
well as SIMATIC HMI operator panels, the ProTool family has the uniform and scalable 
configuration tools ProTool/Lite, ProTool and ProTool/Pro CS.  
ProTool/Pro is the visualization software under Windows for the PC-based HMI in the 
machine-related area. It allows quick response times and safe process control. 

SIMATIC WinCC flexible 
SIMATIC WinCC flexible is the innovative HMI software offered by Windows XP/Vista and 
Windows 7 for all applications in the machine-related area. The engineering software 
enables the uniform configuration of all Windows-based SIMATIC HMI operator panels.  
WinCC flexible Runtime provides basic HMI functionality on PCs, including messaging and 
logging systems and can be expanded when required via options. The runtime functions 
available on the SIMATIC HMI operator panels are dependent on the device class. 
Existing ProTool projects can be accepted or converted. The WinCC flexible engineering 
software can be integrated in the central programming software of the SIMATIC world, 
SIMATIC STEP 7, and used for the configuration of all operator panels. The engineering 
software of SIMATIC HMI also accesses variable lists and message lists of the controller and 
uses their communication parameters.  

OPC / OPC XML-DA  
Open communications standard for automation components. The goal of the standard is to 
ensure a problem-free and standardized data exchange between controllers, operator 
control and monitoring systems, field devices and office applications from different 
manufacturers. 
The OPC abbreviation previously means "OLE for Process Control", because the 
implementation is based on Microsoft's COM/DCOM technology.  
Nowadays, one uses the term "Openness, Productivity and Collaboration". Today, a number 
of standards defined by the OPC Foundation have evolved. The OPC Foundation is a 
grouping of many manufacturers from the automation technology area. 
SIMOTION supports the OPC DA (Data Access) and OPC AE (Alarm & Event) standards 
with the SIMATIC NET Softnet package. This is based on the Windows COM technology.  
SIMOTION also supports OPC XML-DA (Data Access based on XML). The OPC server is 
located in the SIMOTION device and is accessed from a partner station no longer using 
COM mechanisms but with Web services and their XML-coded function calls. This makes 
the partner stations independent of hardware and operating systems.  
The client application on the partner station works with the symbolic SIMOTION variable 
names. There is no dependency on the SIMOTION SCOUT database, which means that no 
consistency problems arise, even when there is a switch in versions. 
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12.6 Drive ES 

Drive ES engineering system  
Drive ES is the engineering system used to integrate Siemens drive technology into the 
SIMATIC automation world easily, efficiently and cost-effectively in terms of communication, 
configuration and data management. The STEP 7 Manager user interface provides the basis 
for this procedure. 
Drive ES Basic is the basic software for the parameterization of all drives, online and offline. 
With the Drive ES Basic software, the automation and the drives are edited on the user 
interface of the SIMATIC Manager. Drive ES Basic is the starting point for common data 
archiving from complete projects and for extending the use of the routing and SIMATIC 
teleservice to drives. Drive ES Basic provides the engineering tools for the new motion 
control functions - data exchange broadcast, equidistance and isochronous operation with 
PROFIBUS DP. 
The following commissioning tools are contained in Drive ES: 
● STARTER Standalone for SINAMICS is not required and cannot be used in conjunction 

with SIMOTION SCOUT because STARTER is integrated in SIMOTION SCOUT. 
● SIMOCOM U for SIMODRIVE 
● Drive Monitor for MASTERDRIVES 

 

 
 

Note 
Drive ES Basic is within the scope of delivery for SCOUT and SCOUT Standalone. 
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12.7 Commissioning drives (STARTER) 
STARTER supports simple and rapid commissioning, optimization, and diagnostics for all 
new-generation Siemens drives with only one tool.  
The STARTER drive/commissioning tool supports the following drives: 
● SINAMICS 
● MICROMASTER 420/430/440 
● MICROMASTER 411 / COMBIMASTER 411 
● COMBIMASTER 
● ET200pro FC 
● ET200S FC ICU24 
The following variants are available: 
● STARTER Standalone: 

STARTER as commissioning tool for applications without SIMOTION, but with integration 
of the new drives in SIMATIC S7. STARTER Standalone is not required in connection 
with SIMOTION SCOUT and cannot be used. 

● STARTER integrated in SIMOTION SCOUT:  
For SIMOTION applications, SIMOTION SCOUT contains the entire functionality of 
STARTER. 

Performance characteristics: 
● Wizards support new users by providing solution-oriented dialog guidance, whereby the 

uniform graphics-based display facilitates understanding. 
● However, experts are also able to access the individual parameters quickly. 

12.8 CamTool 

Graphic creation of cams  
Simple text-based editors are already integrated in the basic SIMOTION SCOUT package 
for the creation of cams. The CamTool V3.0 SP1 option package expands 
SIMOTION SCOUT to include a powerful tool for the fully graphical creation and optimization 
of cams. CamTool fully integrates into the SIMOTION SCOUT user interface. In SIMOTION 
CamTool, you can create, edit and optimize cams with the aid of a graphical user interface. 

Additional references 
Please refer to the following document on this subject 
● Configuration Manual: SIMOTION CamTool 
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12.9 DCC programming system 

Drive Control Chart 
DCC enables SIMOTION and SINAMICS users to also implement and graphically configure 
drive-related tasks employing continuous closed-loop and open-loop control.  
A set of Drive Control Blocks (DCB) is available in a library for this purpose. These function 
blocks can be graphically interconnected and configured in what are known as "charts" via a 
configuration tool (DCC editor). 
A large number of Drive Control Blocks (DCB) are available for both DCC-SIMOTION and 
DCC-SINAMICS with identical functionality. 
● Module library with administration, calculation, control, logic and complex modules. 
● Graphical switching editor with various editing, macro, help, search, comparison and print 

functions. 
● Sequence environment for SIMOTION with selectable, mixable scanning times and 

consistent data transfer between scanning periods. 
● Sequence environment for SINAMICS with embedding of technology option in SINAMICS 

using the BICO technique, with the applications set using configured parameters 
● Diagnostics environment with signal display, diagnostics and trace functions. 
● Scalability with different performance features and project data volumes for DCC-

SIMOTION and DCC-SINAMICS. 

Additional references 
More information on this topic is available in 
● Programming and Operating Manual SINAMICS/SIMOTION Editor description DCC 
● SINAMICS/SIMOTION DCC Module Description Function Manual 
● SIMOTION SCOUT Online Help 
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Technical data 13
13.1 Quantity framework 

Technical data 
 

 

 Note 
Please also refer to the function overview contained in Section 8 of the PM 21 catalog 
as well as the Industry Mall (http://www.siemens.de/automation/mall 
(http://www.siemens.com/automation/mall)).  

 

For quantity structures of SIMOTION devices, see: 
● SIMOTION C Operating Instructions 
● SIMOTION D4x5 Manual 
● SIMOTION D4x5-2 Manual 
● SIMOTION D410 Manual 
● SIMOTION P320-3 and Panels Manual 
● SIMOTION P350-3 and Panels Manual 

http://www.siemens.com/automation/mall�
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13.2 Memory requirement 

Memory requirement 

Table 13- 1 Memory requirement for each instance of a technology object 

Technology object Memory requirement / KB 
Drive axis 180 
Position axis 200 
Following axis with following object 350 
External encoder 150 
Output cam 100 
Measuring input 100 
Cam 
In addition for each interpolation point pair 

100 
1 

TController: Heating controller 85 
TController: Cooling controller 70 
TController: Heating/cooling controller 100 
Position axis path interpolation  250 
Path object (for 4 axes, 1 cam) 200 
Cam track 450 
Addition object 50 
Formula object 150 
Fixed gear 100 
Controller 100 
Sensor 100 

 

Table 13- 2 Memory requirement of technology packages 

Technology package Memory requirement / KB 
TP TControl 1.700 
TP CAM 7.700 
TP PATH 8.500 
TP CAM_EXT 9.500 
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