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 Preface

Purpose of the Manual

PCS 7 Getting Started provides you with an initial overview of the process control
system PCS 7 and helps you to create a simple project yourself. You can configure
the project on an existing SIMATIC Station.

Getting Started – Part 1 is intended for newcomers to PCS 7 active in the following
areas:

• Configuration

• Commissioning and service

Required Experience

You should already have experience in the following areas:

• Microsoft operating system Windows 2000

• Functions and configuration of SIMATIC S7 (S7-400, STEP 7)

• Functions and configuration of SIMATIC NET (network components,
transmission media)

Scope of the Manual

Getting Started applies to the "PCS 7 Engineering Toolset V 6.0".
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Guide to the Manual

Getting Started explains the individual steps required to create the "color_gs"
project. You will find the most important background information required to
understand the steps in Getting and detailed instructions on how to work through
the steps.

You also receive the finished "color_gs" project as a sample project in the form of a
file. This is installed along with the system documentation of PCS 7. You can open
this project on an existing engineering system (ES) to view the configuration data
and compare the data with your own configuration data. You can activate the
project on an operator station (OS) to control and monitor the process.

Note

To test the sample project in the process mode, you may need to adapt the
hardware configuration of the project to the hardware that is actually installed; in
other words, you must replace the hardware components of the sample project
with the actual existing hardware components.

For more detailed information on opening the sample project, refer to "Starting and
Adapting the Sample".

Notes on Getting Started

In Getting Started, all the instructions are explained based on the full menu
commands. You can also activate the majority of functions with the context-
sensitive menu or by double-clicking.

In PCS 7, you can use standard Windows functions in many situations:

• Multiple selection with the "CTRL" and "Shift" keys

• Sorting columns in tables by clicking on the column header

• Using Drag & Drop instead of Copy and Paste

If you open the HTML version of Getting Started, you can open video sequences.
These video sequences show the exact steps that you can follow on screen before
performing them yourself. Video sequences are indicated by the following icon:

 Video

Click on the word "Video" to start a video sequence. You can freeze, stop and
restart video sequences. You have buttons available similar to those of the
Windows Media Player.

One tutorial in Getting Started leads on to the next and you will create a complete
PCS 7 project yourself step by step. This makes it essential to work through the
tutorials in the correct order.
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Further Information

You will find more detailed information and wider-ranging topics in the configuration
manuals "Process Control System PCS 7, Engineering System" and "Process
Control System PCS 7, Operator Station" and these will be useful to you as a
source of reference.

These manuals are located

• on the CD "SIMATIC Process Control System PCS 7 V 6.0, Electronic
Manuals[0]".

• in the PCS 7 Software in the SIMATIC Manager[0]. You can open the
documents with the menu command "Start > SIMATIC > Documentation >
[required language] ".

Here, you will also find other manuals on specific topics, for example on SFC, CFC.

Further Support

If you have any technical questions, please get in touch with your Siemens
representative or agent responsible.

http://www.siemens.com/automation/partner

Training Centers
Siemens offers a number of training courses to familiarize you with BATCH flexible
and the Process Control System PCS 7. Please contact your regional training
center or our central training center in D 90327 Nuremberg, Germany for details:

Telephone:  +49 (911) 895-3200.

Internet: http://www.sitrain.com

http://www.siemens.com/automation/partner
http://www.sitrain.com
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A&D Technical Support
Worldwide, available 24 hours a day:

 

Beijing

 Nuernberg

Johnson City

Worldwide (Nuernberg)

Technical Support

24 hours a day, 365 days a year

Phone: +49 (0) 180 5050-222

Fax: +49 (0) 180 5050-223

E-Mail: adsupport@
siemens.com

GMT: +1:00

Europe / Africa (Nuernberg)

Authorization

Local time: Mon.-Fri. 8:00 to 17:00

Phone: +49 (0) 180 5050-222

Fax: +49 (0) 180 5050-223

E-Mail: adautorisierung@
siemens.com

GMT: +1:00

United States (Johnson City)

Technical Support and
Authorization

Local time: Mon.-Fri. 8:00 to 17:00

Phone: +1 (0) 423 262 2522

Fax: +1 (0) 423 262 2289

E-Mail: simatic.hotline@

sea.siemens.com

GMT: -5:00

Asia / Australia (Beijing)

Technical Support and
Authorization

Local time: Mon.-Fri. 8:30 to 17:30

Phone: +86 10 64 75 75 75

Fax: +86 10 64 74 74 74

E-Mail: adsupport.asia@

siemens.com

GMT: +8:00

The languages of the SIMATIC Hotlines and the authorization hotline are generally German and English.
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Service & Support on the Internet
In addition to our documentation, we offer our Know-how online on the internet at:

http://www.siemens.com/automation/service&support

where you will find the following:

• The newsletter, which constantly provides you with up-to-date information on
your products.

• The right documents via our Search function in Service & Support.

• A forum, where users and experts from all over the world exchange their
experiences.

• Your local representative for Automation & Drives via our representatives
database.

• Information on field service, repairs, spare parts and more under "Services".

http://www.siemens.com/automation/service&support
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1 Requirements for Getting Started

1.1 Requirements for Working through Getting Started

To be able to work through Getting Started the following requirements must be met
for the components below:

• Hardware

• Software

1.1.1 Hardware Required for Getting Started

The list below shows the hardware components you require to work through
Getting Started and that we have used in the Getting Started example. In some
cases, you require a specific version of a hardware component since it is not
possible to work through Getting Started with an older or different version.

 Hardware Component  Version Used in Getting Started  Other Version
Possible

PG or PC with a standard
network adapter

3Com EtherLink III IS Yes

Rack UR2 Yes

Power supply PS 407 10A Yes

CPU CPU 417-4, firmware V 3.1 or
higher

no

CP 443-1 6GK7 443-1 EX11-0XE0,
firmware 2.0 or higher with a
fixed MAC address

no

Memory card

Crossover cable no

Caution

The CPU and the CP are absolutely necessary to be able to create the
configuration as described in Getting Started.



Requirements for Getting Started

Process Control System PCS 7, Getting Started - Part 1
1-2 A5E00164244-01

If you use a different hardware component, you must remember to enter the actual
component you are using at certain points during the configuration, for example in
HW Config. If it is at all possible, we recommend that you use exactly the same
components as we used in Getting Started.

If you do not have any hardware components available, you can also use the
software PLC Sim that is also on the PCS 7 Toolset CD. You require a special
license to use this software. If you use this software, you can use exactly the same
hardware components as described in getting started.

1.1.2 Software Required for Getting Started

The following software must be installed:

• Windows 2000 Professional

• Internet Explorer 6.0

• Message queuing service

• SQL Server

• Software package from PCS 7: "PCS 7 Engineering"

These packages are all available on the "PCS 7 Toolset V 6.0" CD. If you have
questions relating to the installation of the PCS 7 Toolset, please read the readme
file on the installation CD or contact customer support.
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2 Overview of PCS 7

2.1 Brief Overview of PCS 7

PCS 7 is a process control system that supports you during configuration with
numerous automatic functions so that you can create a project quickly and
conveniently. You will get to know some of these automatic functions when you
work through this Getting Started. When you have become an advanced user, you
will also find that PCS 7 provides a variety of options with which you can create
individual and project-specific solutions tailored to your specific requirements.
These individual solutions are, of course, not part of this Getting Started – for more
information in this direction, you can refer to the configuration manuals once you
are familiar with the basic functionality.

What is a PCS 7 Project?

Among other things, a PCS 7 project includes the following objects:

• Hardware configuration

• Blocks

• CFC and SFC charts

These objects always exist regardless of the number of operator stations, modules,
and networking.

2.2 What Belongs to PCS 7?

The project is created with the Engineering System, generally abbreviated to ES.
The ES consists of various applications. All applications provide you with a graphic
user interface for simple control and clear display of your configuration data. When
you work through Getting Started, you will get to know the following applications:

• SIMATIC Manager – the central application providing you with access to all
other applications that you use to create a PCS 7 project. The SIMATIC
Manager is the starting point for creating your entire project.

• HW Config – configuration of the entire hardware of a system, for example
CPUs, power supply, communications processors.

• CFC and SFC Editor – for creating CFC charts and sequential controls

• PCS 7 OS with various editors – for creating the OS configuration
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2.3 Introduction to the SIMATIC Manager

What is the SIMATIC Manager?

The SIMATIC Manager is the central application and in some ways the "core" of
PCS 7. This is your starting point from which you can open all other applications in
which you make the settings for your PCS 7 project. The SIMATIC Manager and all
other applications are linked to each other. When you open the SIMATIC Manager,
you can for example also see all the blocks you inserted in a CFC chart with the
CFC editor.   Another great advantage of this linking becomes clear when you
configure the operator station. You can access all data you created in the SIMATIC
Manager and the other applications, for example you can visualize a process tag
from a CFC chart quickly and simply during configuration of the OS.

Due to its central function within PCS 7, it is worth taking time to become familiar
with the structure and functions of the SIMATIC Manager.

2.4 What is the Basic Structure of the SIMATIC Manager?

The SIMATIC Manager has a window made up of two panes – comparable with the
Windows Explorer:

• The left pane contains a tree structure whose contents depend on the selected
view.

• The right-hand window, the detailed window contains details of the object you
select in the tree structure.
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2.5 What Does View Mean in the SIMATIC Manager?

The SIMATIC Manager provides you with three different views. One important
feature of these views is that the objects they contain exist only once in reality but
can be displayed and manipulated in the various views. Each view has basically
the same structure: In the left-hand pane you see the tree structure and in the
right-hand pane the detailed window. Each view has its own particular advantages
depending on the task in hand.

• Component view – this represents the physical memory location of the
individual objects, for example of the charts and blocks. In the Component
view, you can see immediately which blocks and charts belong to which PLC.

• Plant view – this shows the hierarchical structure of your plant. You can divide
the plant into sections or units and can see which charts and which process
pictures belong to which plant section.

• Process object view – this shows details of the individual objects of the plant
view. This is particularly suitable when you want to assign similar parameter
values to a large number of objects, add comments to them or interconnect
them.

In the step-by-step instructions in Getting Started, you always know the view in
which you should be working.

All the work that you do in the SIMATIC Manager is saved automatically by PCS 7.

2.5.1 How to Open the SIMATIC Manager

Open the SIMATIC Manager

There are two ways in which you can start the SIMATIC Manager:

 Option  Procedure

 1 Double-click on the STEP 7 icon on your desktop.

 2 Start the SIMATIC Manager from the Windows taskbar with the
following menu command:

Start > SIMATIC > SIMATIC Manager.

When you start the SIMATIC Manager, the project you last opened is opened
automatically again.
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3 First Steps in the Project

3.1 Introducing the Project

3.1.1 The 'color_gs' Project

After this initial theoretical introduction  to PCS 7, we will now turn to more practical
matters and create the "color_gs" project. You will, of course, be supported by
detailed step-by-step instructions. To better understand the step-by-step
instructions, a certain amount of theory is of course necessary – and we will
provide you with the most important background information on all topics.

We will only configure a small part of the entire plant for fully automatic paint
production since configuring the entire plant would be beyond the scope of this
Getting Started project. You should, nevertheless, know how this small part is
integrated in the entire plant so that you have a more complete picture. With this in
mind, the individual phases of the entire process are explained briefly below.

Phase I – Raw Materials

The liquid raw materials required for the product are stored in two tanks and are
pumped from these tanks to the reactors. The solid raw materials are stored in
three silos. Three feed screws leading from the silos transport the solid raw
materials to a weighing hopper where they are weighed. Once the correct mixture
has been obtained, a further feed screw and a blower transport the raw materials
to one of the two mixing containers.

Phase II – Creating the Product

The required quantities of liquid material are fed to either reactor 1 or reactor 2 via
valves. The solid materials from the mixing containers are transported to the
reactors by feed screws and mixed by an agitator. The product is produced in the
reactors by agitating, heating and cooling the raw materials along with the
additives. The temperature in the reactors is controlled by valves and actuators.
When necessary, water can be let in to the reactors flow-controlled from a filtering
unit.
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Phase III – Holding Phase

The finished product is then pumped to a holding tank. Here, it is stirred slowly and
kept at a constant temperature.

Phase IV – Filling

Following the holding phase, the product is briefly stored in a filling tank from which
it can then be filled into tankers or small drums.

Phase V – Cleaning

The reactors, piping, valves, actuators, holding tank, and filling tank can then be
cleaned by a cleaning system (CIP). The resulting effluent is then collected in a
separate effluent tank for disposal.

3.1.2 The Task for Getting Started

Your Configuration Task…

You will configure part of "Phase I – Raw Materials":

The storage of the liquid raw materials in two tanks and control of the pumps to
pump these raw materials to the two reactors.

Piping and Instrumentation Flow Diagram

The piping and instrumentation flow diagram illustrates the precise sequence of the
configuration tasks and shows you all the relevant measuring points (tags):

Reactor 1 Reactor 2

Li

Nk

Nk

Fc

Nk

111

111

111

112

114

Raw material 
    tank 1
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Explanation of the Piping and Instrumentation Flow Diagram

• LI111 (Level Indicate) – measurement of the current level of the raw material
tank

• NK111 and NK112 (customer-specific identifier for valves) – stop valves that
must always be open when dosing raw materials.

• NP111 (customer-specific identifier for motors) – pump that transports the raw
material to the reactors

• NK113 or NK114 (customer-specific identifier for valves) – valves of which only
one can ever be open at any one time used to transport the raw material to
either Reactor 1 or Reactor 2

• FC111 (Flow Control) – actuator with which the amount of raw material is
controlled

The states of valves NK111 to NK114 will be displayed on the operator station and
can be monitored. It will also be possible to influence the dosing with FC111.

3.1.3 Structure of the Plant for the 'color_gs' Project

The "color_gs" project is implemented in a small unit of plant with one
programmable controller and a combined engineering system and operator station.
The operator station is designed as a single workstation system. The following
figure illustrates the structure of the plant.

Engineering Station (ES)/
Operator Station (OS)

Direct link via 
crossover cable

Programmable controller
SIMATIC S7 400

with CP 443-1

Single workstation system
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In Getting Started, you will create a control system containing the following
components:

• Programmable controller, abbreviated to PLC
The individual components are described in Requirements for Implementing
Getting Started.

• Program that handles the control of the "color_gs" plant. You will create this
program in the engineering system, abbreviated to ES and download it to the
CPU. The CPU processes the loaded program and returns process values to
you. You download the program via the CP 443-1.

• Operator station, abbreviated to OS, on which the plant operator can control
and monitor the plant in the process mode. You will create the process picture
that the operator sees on the OS yourself. The connection between the PLC
and the OS is via the CP.

Note

Please remember that the plant setup and the hardware settings resulting from it
are designed specially for the requirements of this Getting Started. When you
configure a real project, you will certainly use more programmable controllers and
run the engineering system and the operator station(s) on different computers. As
a result, the hardware settings will be far more complex and will certainly no
longer match the descriptions in Getting Started.

3.1.4 Overview of the Steps in Configuration

To configure this plant section, you will need to perform the following steps:

• Make hardware settings

• Start the SIMATIC Manager and set up a PCS 7 project

• Create CFC charts

• Create SFC charts

• Download and test the project

• Configure and compile the PCS 7 OS

• Create process pictures

• Change to the process mode with the simulated process values
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3.2 Hardware Settings

3.2.1 Hardware Settings outside the SIMATIC Manager

Before you even start to configure the "color_gs" project, you should check the
hardware settings, set the PG/PC interface, and test the connection between your
ES computer and the PLC. This makes sure that you will be able to download the
configuration data without problems and that you can change your project to the
process mode once you have completed the configuration data.

Note

These settings are generally made immediately after installing PCS 7 using the
Commissioning Wizard. Since you probably did not install PCS 7 yourself, you
should check the settings again and make any necessary adaptations.

3.2.1.1 How to Check the Hardware Settings

Requirement

Make sure of the following:

• That all required hardware components are inserted in the rack and turned on

• That there is a crossover cable between the 3Com network adapter of your ES
computer and the CP 443-1

Follow the steps outlined below...

1. Open the Configuration Console using the Windows command Start >
Simatic > SIMATIC NET > Settings > Configuration Console.
The configuration console opens and all the hardware components belonging
to your PC are displayed under the "Modules" entry in the tree structure.

Caution

If the configuration console is not opened directly but rather the Commissioning
Wizard is started, click on the "Cancel" button.
This closes the Commissioning Wizard and the Configuration Console is opened.
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2. In the tree structure, select the entry
"SIMATIC NET Configuration/Modules/[name of the network adapter,
for example: "3Com EtherLink III IS..."]/General".
The general information on this module is then displayed in the detailed
window.

Note

If you are using a different network adapter in your PC, the name of your network
adapter will of course be displayed here. In this case, you must select this network
adapter.

3. In the detailed window you will see a drop-down list box "Mode of the module"
where you select the entry "Configured mode".
This activates this network adapter.

4. Click the "Apply" button.
This enters your settings.
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5. If you have other network adapters, for example the CP 5611 MPI adapter or
another 3Com adapter in your PC, you must deactivate it since it will not be
required for getting started.
Follow the steps below:

- Select the required entry in the tree structure, for example
"SIMATIC NET Configuration/ Modules/[Name of the adapter, for example
"CP5611"]/ General".
The general information on this module is then displayed in the detailed
window.

- In the detailed window you will see a drop-down list box "Mode of the
module" where you select the entry "Not yet specified".

- Click the "Apply" button.
This enters your settings.

6. Repeat Step 5 for all other network adapters in your PC that you do not require
for communication between the ES/OS computer and the CPU.

7. Close the Configuration Console.
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3.2.1.2 How to Set the PG/PC Interface

1. Select the following menu command via the Windows taskbar Start >
Simatic > STEP 7 > NCM S7 Industrial Ethernet > Diagnostics.
NCM S7 diagnostics is opened.

2. Select the menu command Diagnostics > Open Online Connection…
The "NCM S7 Diagnostics: Online Path" dialog box is opened.

3. Click on the "Set PG/PC Interface" button.
The "PG/PC Interface" dialog box opens.

4. Select the entry "ISO Ind. Ethernet -> 3Com EtherLink III ISA..."

5. Click the "OK" button to enter your settings.

6. In the "Destination Station" area, select the entry "Industrial Ethernet" in the
"Destination station attachment" drop-down list box.

7. Enter the MAC address printed on your CP in the "Node address" box.
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8. In the "Rack/slot" drop-down list box, select the entry "0/5".
The CP is in the rack in Slot 5 if you have inserted a power supply and CPU in
the rack.
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9. Click the "OK" button to enter your settings.
If your connection is functioning correctly, the data of the CP will be displayed.

10. Close NCM S7 diagnostics.
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3.3 Creating the Project

3.3.1 Using the 'New Project' Wizard

When you start the SIMATIC Manager, the default setting automatically starts the
PCS 7 wizard "New Project". You can activate or deactivate this option in the "New
Project" wizard.

The "New Project" wizard supports you step-by-step when you create a new
project and supports you with default settings. Depending on the default settings
you leave and any settings you make extra, the wizard automatically creates
various objects.

For the "color_gs" project, the following objects are important:

• Hardware objects: SIMATIC stations, for example a SIMATIC 400 for the PLC,
SIMATIC PC station for the OS

• Hierarchy folders representing the hierarchy levels of the plant structure. The
number of hierarchy folders created corresponds to the setting you made in the
wizard.

• one CFC chart

• one SFC chart

• one picture per plant hierarchy folder

• one master data library

3.3.2 Background Information on the PCS 7 Wizard

What happens in the background when you create a new project?

The next two sections provide you with a little theoretical background on the PCS 7
"New Project" wizard. These sections also introduce you to two new terms whose
significance you should understand:

• Multiproject

• Master data library

How does a multiproject function?

When you create a new project with the PCS 7 wizard, a multiproject is
automatically created. This requires a little explanation. A multiproject consists of
several single projects. Taken in the context of a concrete project, a multiproject
could be implemented as follows: The multiproject represents the entire plant and
all of the single projects within this multiproject could, for example, represent the
individual phases of the process for making paint. Since you are only configuring a
small section of the entire plant, your multiproject naturally only contains one single
project.
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Multiprojects have one major advantage: You can distribute the single projects to
different configuration engineers who can then edit them. Once the configuration of
the single projects is complete, these can be merged back to form the full project.

In Getting Started, although you will be working within a multiproject, you will not
be using the wide range of functions provided by multiproject engineering.

For more detailed information on this topic, refer to the Configuration Manual
Process Control System PCS 7, Engineering System.

What is a master data library?

When you create a new project with the PCS 7 wizard, a master data library is
automatically created. You store all the blocks required for the entire project in this
library. Before you create, for example a CFC chart, you deposit all the standard
blocks you want to insert in this CFC chart in your master data library. A master
data library has the following advantage: When you archive a project, the master
data library is automatically archived along with the project. You can also make
changes to the blocks and then continue to use these adapted blocks repeatedly.

In the context of a multiproject, the master data library is, of course, particularly
important because it allows you to provide all the configuration engineers involved
with a defined set of block versions so that you can be sure that only this version is
used in the project.

3.3.2.1 How to Create the 'color_gs' Project

When you create the "color_gs" project, you are supported by the wizard. Follow
the steps outlined below:

1. Open the SIMATIC Manager

2. If the wizard does not start automatically, select the menu command File >
'New Project' Wizard....
The PCS 7 "New Project" wizard opens.
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3. In step 1(4) "Introduction", activate the option "Multiproject with project and
master data library" – this option is activated as the default setting.

4. Click the "Next" button.

5. In Step 2(4) "Which PLC will you use in your project?", select the CPU type
you are using in your project, for example a CPU 417-4.
Below the list, you will see detailed information on the selected CPU.
When you make your selection here, you should compare the type number and
order number printed on the front panel of your CPU with the type number and
order number displayed in the list.
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6. Click the "Continue" button.

7. In step  3(4) "Which objects will be used in the project ?", make the following
settings:

- In the list box "Number of levels", select the entry "4".

- Under OS objects, activate the "PCS 7 OS" check box.
The "Single-user system" option is automatically activated.

8. Click the "Next" button.

9. In step  4(4), enter the name "color_gs" in the "Directory name" box and
confirm the storage location.
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10. Click on the "Preview >>" button to display a preview of your current stage of
configuration. This preview corresponds to the appearance of the project in the
SIMATIC Manager.

11. Click on the "Finish" button.
The "Message Number Assignment Selection" dialog box is opened twice
when the project is being created.
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12. Accept the default settings:

- "Unique message number assignment for the CPU" activated

- "Always prompt for settings" activated

13. Click the "OK" button.
The project is now created with these settings.

Note

• If the project does not open automatically, follow the same steps as in "First
Steps in the Project – Creating the Project – How to Open and Close the
"color_gs" Project.

• To activate the various views, follow the steps as described in "First Steps in
the Project – Creating the Project – How to Work in the Various Views".
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The project then appears as follows in the plant view of the SIMATIC Manager:
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3.3.2.2 How to Open and Close the 'color_gs' Project

Closing a project

1. If you have other projects open in the SIMATIC Manager, close these projects
to keep the display simpler.
Select the menu command Window > [Name of the Project] and select the
project you want to close.
The project is then shown in the foreground in the SIMATIC Manager.

2. Select the menu command File > Close.
The project closes.

Opening the project

1. Open the SIMATIC Manager.

2. If your "color_gs" project does not open automatically, select the menu
command File > Open.
The "Open Project" dialog box opens and the "User Projects" tab is active.

3. Change to the "Multiprojects" tab and select the "color_gs_MP" entry.

4. Click the "OK" button.
The project along with its master data library opens.

3.3.2.3 How to Work in the Various Views

Once you have opened your project in the SIMATIC Manager, you can activate
various views:

• Select the menu command View > [Name of the required view] in the
SIMATIC Manager:

- Component view

- Plant view

- Process object view

• If you have already opened several projects, select the menu command
Window > [Name of the project (name of the view)]".
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3.4 Configuring the Hardware

3.4.1 Configuring the Hardware

The individual components of the control system such as the CPU, the operator
station, the engineering system must be able to communicate with each other. To
make this possible, you must insert and configure hardware components. When
you run the wizard, some hardware components such as the rack, the CPU and
the connection are automatically inserted. You must also insert the CPs you
require and set the required connections.

Which hardware components do you need to configure for the "color_gs" project?

• Configuring the programmable controller and configuring the connection – the
CPU communicates with the ES over this connection.

• Downloading the configuration to the CPU

• Configuring the OS and configuring the connection – the OS communicates
with the PLC via this connection.
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3.4.1.1 How to Configure the Hardware - PLC

Ready to Start?

• The "color_gs" project is open in the SIMATIC Manager

• The component view is activated

Follow the steps outlined below...

1. Go to the tree structure and select the folder "color_gs_MP/ color_gs_Prj/
SIMATIC 400(1)".

2. Select the "Hardware" object in the detailed window and then select the menu
command Edit > Open Object.
HW Config is opened and the hardware structure of your system is displayed.

Note

If the hardware catalog is not displayed, select the menu command View >
Catalog.
The hardware catalog opens and the "PCS7_V60" profile is active.
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3. Select the following CP from the catalog:
"SIMATIC 400/ CP-400/Industrial Ethernet/ CP 443-1/ 6GK7 443-1EX11-0XE0/
V2.0".
And drag it to slot 5 of the rack.
The "Properties - Ethernet Interface" dialog box opens.

4. Activate the "Set MAC address/use ISO protocol" option.

5. In the "MAC address" box, enter the MAC address printed on the front of the
CP.

6. Deactivate the "IP protocol is used" option.
This activates all the associated input boxes.

7. Click on the "New" button.
The "Properties - new subnet Industrial Ethernet" dialog box opens.
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8. Apply all your selections and click the "OK" button.
The "Ethernet(1)" entry is entered in the "Subnet" list box and is already
selected.

9. Click the "OK" button to enter your settings.
The dialog is closed.

10. Select the menu command Station > Save and Compile.
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3.4.1.2 How to Download the Hardware Configuration

Once you have created the hardware configuration for the CPU, you must also
inform the CPU of this configuration. You do this by downloading the hardware
configuration.

Requirement

Set your CPU to RUN-P with the mode selector. This allows the CPU to be stopped
automatically and restarted again in HW Config.

Ready to Start?

• HW Config is open for the "color_gs" project

Follow the steps outlined below...

1. Select the menu command PLC > Download to Module.
The "Select Target Module" dialog box opens and the CPU 417-4 is displayed
and automatically selected in the list. This is the CPU you have installed in
your project.

2. Click the "OK" button.
The "Select Node Address" dialog box opens.
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3. Click the "Display" button.
In the list of "Accessible Nodes", you can see the CP with the MAC address
you entered when configuring the hardware.

4. Select the "CP 443-1" in the list of "Accessible Nodes" and click the "OK"
button.
The progress bar is displayed. Finally the "Stop Target Modules" message
window opens.

5. Click on the "OK" button to stop the CPU.
The message window closes and the download is continued. On completion of
the download, the "Download to Module" message window opens.
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6. Click on the "Yes" button to restart the CPU.
The following LEDs are then lit green and the download has been completed
successfully.

- On the CPU: "RUN"

- On the CP: "LINK" and "RUN"



First Steps in the Project

Process Control System PCS 7, Getting Started - Part 1
3-26 A5E00164244-01

3.4.1.3 How to Configure the Hardware - OS

Ready to Start?

• The "color_gs" project is open in the SIMATIC Manager

• The component view is activated

Follow the steps outlined below...

1. Go to the tree structure and select the folder
"color_gs_MP/ color_gs_Prj/ SIMATIC PC-Station(1)".

2. Select the "Configuration" object in the detailed window and then select the
menu command Edit > Open Object.
HW Config opens and the components of the OS are displayed. HW Config is
opened with the settings you made during configuration of the PLC:

- The hardware catalog is open.

- The "PCS7_V60" profile is active.

3. Select the following CP from the catalog:
"SIMATIC PC-Station/CP-Industrial Ethernet/IE General"
and drag it to Slot 2.
The "Properties - Ethernet Interface" dialog box opens.
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4. Open the "Ethernet" entry in the "Subnet" list box.
This is the connection that you already configured for the CP.

5. Click the "OK" button to enter your settings.
The dialog box closes and you return to HW Config.
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6. Select the menu command Station > Save and Compile.

7. Close HW Config.
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3.5 Working in the PH

3.5.1 Settings in the Plant Hierarchy

Once again, it is time for a little theory:

The plant hierarchy that normally abbreviates to PH, mirrors the hierarchical
structure of your plant: Plant, unit, function etc. The PH allows you to make a lot of
different settings and the most important of these are described below.

• Number of hierarchy levels:
Your plant structure influences the number of hierarchy levels. As a rule of
thumb, the more complex the plant structure the higher the number of
hierarchy levels you require to reflect your plant structure. Hierarchy folders
with the default names are created when you work with the wizard.

• Selecting the hierarchy level(s) that contribute to the name of the plant
designation (also known as higher level designation):
The higher level designation abbreviated to HID is used at many points in the
PCS 7 project for example messages occurring during the process mode and
tags contain this HID. This makes it easy to recognize the plant section to
which a message or tag belongs. As a rule of thumb, the more hierarchy levels
used to specify the HID and the longer each individual part is, the longer and
less easily recognizable the entire HID becomes.

• Basing the picture hierarchy on the PH:
The process pictures are arranged in a certain hierarchy: This allows you to
change from an overview picture to a lower level picture showing only part of
the overview picture but with far greater detail. You can base the hierarchy of
process pictures on the plant hierarchy so that it corresponds to the plant
hierarchy.
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3.5.1.1 How to Make the Settings for the PH

Ready to Start?

• The "color_gs_MP" project is open in the SIMATIC Manager

• The plant view is activated

Follow the steps outlined below...

1. Select the "color_gs_MP/color_gs_Prj" hierarchy level in the tree structure.

2. Select the menu command Options > Plant hierarchy > Customize.
The "Customize Plant Hierarchy" dialog box opens where you can set all the
options for the Plant Hierarchy.

3. Enter the value "4" in the "Number of hierarchy levels" box.
This means that a maximum of 4 hierarchy levels are permitted.

4. Enter the value "10" in the "Max. number of characters" box.
This limits the plant designation to 10 characters per hierarchy level.

5. Activate the "Include in designation" check box for the levels  1 and 2.

6. Activate the "OS area" option button for level 2.

7. Select the "Base picture hierarchy on the plant hierarchy" check box.
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When you have made the settings, the dialog box appears as shown below:

8. Click the "OK" button to enter your settings.
The message "You have changed the include in designation property. Do you
also want the changes to apply to existing hierarchy folders?" is displayed.
Click on the "Yes" button in the dialog.
This enters all your settings.
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3.5.2 Structuring in the Plant View

You already specified four hierarchy levels in the "New Project" wizard. As a result,
you will find the following hierarchy folders in the tree structure of your project:

• Plant – level 1

• Unit – level 2

• Function – level 3

• Device – level 4

The names of the hierarchy folders are default names assigned automatically by
PCS 7 when you create the project.

In your "color_gs_MP" project, you must, of course, adapt these to the individual
requirements of the "color_gs" project, in other words, change the default names
and insert new hierarchy folders. This provides you with a clear structure and
makes it easier to navigate through your project. You can also handle all the
objects and individual units.

For the various plant sections, we decided on the following names for the hierarchy
folders:

 Default Name  Hierarchy Folder  Technological assignment

Plant Plant1 Complete plant

Unit RMT1 Raw material Tank 1

Function FC111 Flow control (dosing)

Function LI111 Level indicator raw material tank 1

Function NP111 Pump control

Function NK111 Valve

Function NK112 Valve

Function NK113 Valve

Function NK114 Valve

Device ADDIT Auxiliary chart for selecting setpoints
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3.5.2.1 How to Adapt the Default Names

Ready to Start?

• The "color_gs" project is open in the SIMATIC Manager

• The plant view is activated

Renaming the "Plant" Folder

1. Select the hierarchy folder "color_gs_MP/color_gs_Prj/Plant(1)".

2. Select the menu command Edit > Object Properties.
The "Properties – Hierarchy Folder" dialog box opens and the "General" tab is
active.

3. Enter the name "Plant1" in the "Name" box.

4. Click the "OK" button to enter your settings.
The dialog box is closed and the name of the hierarchy folder is changed to
"Plant1".
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Object Properties and Renaming the "Unit" Folder

1. Select the "Unit(1)" hierarchy folder.

2. Select the menu command Edit > Object Properties.
The "Properties – Hierarchy Folder" dialog box opens and the "General" tab is
active.

3. Enter the name "RMT1" in the "Name" input box.

4. Change to the "Control and Monitoring Attributes" tab.

5. Make sure that the check box "No modification when renaming the hierarchy
folder" is deactivated.
This makes sure that the text for the OS area identifier is modified according to
the name of the hierarchy folder.

6. Click the "OK" button to enter your settings.
The dialog box is closed and the name of the hierarchy folder is changed to
"RMT1".
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Renaming the Other Folders

1. Select the "color_gs_MP/ color_gs_Prj/Plant1/RMT1/ Function(1)" hierarchy
folder and make the following settings:

- Change the name "Function(1)" to "FC111".

- Deactivate the check box "No modification when renaming the hierarchy
folder"

Note

Follow the same procedure as for renaming the "Plant" folder.

2. Select the " color_gs_MP/ color_gs_Prj/Plant1/RMT1/ Function(1)/ Device(1)"
folder and make the following settings:

- Change the name "Device(1)" to "ADDIT"

- Deactivate the check box "No modification when renaming the hierarchy
folder"

Note

Follow the same procedure as for renaming the "Plant" folder.

3.5.2.2 How to Insert Further Hierarchy Folders

Ready to Start?

• The "color_gs" project is open in the SIMATIC Manager

• The plant view is activated

Follow the steps outlined below...

1. Select the "RMT1" folder.

2. Select the menu command Insert > Technological Objects > Hierarchy
Folder.
A new hierarchy folder "Function [consecutive number]" is created

3. Change the name to "LI111" and make sure that the check box "No
modification when renaming the hierarchy folder" is deactivated in the "Control
and Monitoring Attributes" tab of the "Properties – hierarchy folder" dialog box.

4. Press Enter.
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5. Repeat steps 1 to 4 to create the following hierarchy folders:

- NP111 – motor control

- NK111 – valve control

- NK112 – valve control

- NK113 – valve control

- NK114 – valve control

Your plant hierarchy should now appear as follows:

3.5.3 Exchange of Information between PLC and OS

The individual parts of the plant are assigned to specific programmable controllers
or specific operator stations. Each hierarchy folder includes this information. This
is, of course, only important when you have more than one programmable
controller or operator station in your system. In the "color_gs" project, you have
only one programmable controller and one operator station. As a result, all the
hierarchy folders are automatically assigned. You can check the assignment as
follows:

1. Select the hierarchy folder "Plant1" and select the menu command Edit >
Object Properties.
The "Object Properties" dialog box opens.

2. Change to the "PLC and OS Assignment" tab.
Here, you will see the following assignment:

- In the "Assigned PLC (chart folder)", you will see the programmable
controller that processes the data.

- In the "Assigned OS" list box, you will see the operator station on which the
data is displayed.

3. Close the dialog box.
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3.6 The Current Status of Your Project...

Up to now, you have made the following settings for your project:

• You have created the "color_gs" project in the SIMATIC Manager

• You have configured the hardware components in HW Config

• You have downloaded the hardware configuration to the CPU starting from
HW Config

• You have made the settings in the plant hierarchy

• You have created the plant structure of the "color_gs" project in the plant
hierarchy
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4 Creating CFC Charts

4.1 Overview of CFC Charts and the CFC Editor

The Theory – What are CFC Charts, What is the CFC Editor?

The entire operation of a plant is described by continuous processes. This is
achieved by creating CFC charts in the CFC Editor of PCS 7. To create CFC
charts, you insert blocks located in the "PCS 7 Library V6.0" in the CFC charts.
These include single blocks such as blocks for controlling a process or for
monitoring measured values. The inputs and outputs of these blocks are then
interconnected directly in the CFC Editor and are given parameter values. While
doing this, you are supported by the user-friendly graphic user interface of the CFC
Editor.

In the standard library, PCS 7 also provides process tag types that are based on
full CFC charts for various process tags such as motors and valves.

You will also find the CFC charts in the plant hierarchy. To keep the structure of the
project clear, the CFC charts are always in the hierarchy folders in which they are
of technological significance.

Identifying CFC Charts

CFC charts can be identified by the following symbol in front of their names:  
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4.2 Working with Libraries

4.2.1 CFC Charts and the Master Data Library

Brief Theoretical Introduction to the Master Data Library…

When you create the CFC charts, you will work with the master data libraries. You
have already got to know the master data library in the theoretical section dealing
with the multiproject and when creating your project. All the blocks and process tag
types required in the CFC charts in your project are never taken directly from the
standard library of PCS 7. You first store the required blocks and process tag types
in the master data library and insert them in the CFC charts from there.

What are the Advantages of the Master Data Library?

At first, working with the master data library appears to be somewhat "long
winded": You first store the blocks in this library and then take them from the
master data library again to insert them in the CFC charts. Why take the trouble?
Using the master data library makes sure that the same version of a block is
always used in a project and that there can be no mix ups. This is particularly
important when there is more than one configuring engineer working in a project
which is almost always the case in larger projects working within the framework of
a multiproject. The use of the master data library also provides you with another
convenient PCS 7 function: Namely the hiding of libraries. This allows you to hide
all the libraries except for the master data library to avoid inconsistencies and
errors within the project. Inconsistencies and errors in a configuration can cause
considerable unnecessary extra work. One other advantage of using master data
libraries is that they are archived automatically when you archive the multiproject.
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4.2.2 Storage of Objects in the Master Data Library

Changes to Blocks

At this point, we will make another brief excursion. This work does not of course
belong to the scope of Getting Started but will provide you with a good insight into
the options made available to you by PCS 7:

In the master data library, you can change the properties of the block, for example
adapt the messages to your particular project. Each block instance created when
you insert a block in a CFC chart automatically has the modified properties. This
means that you only need to make the changes once to the block in the master
data library, you no longer have to make individual modifications to the block
instances over and over again. Changes to a block that is specific to a CFC chart
can then be made directly in the block instance in the CFC chart itself. This
includes, for example, parameters for inputs and outputs such as setpoints and
limit values.

Master Data Library and Process Tag Types

You can, of course, also store the process tag types provided by PCS 7 in your
master data library. In the background, all the blocks included in this process tag
type, are automatically entered in the block folder of your master data library.

Basic Procedure

• Open a library

• Put all the blocks in your master data library – the master data library was
created automatically by the  PCS 7 wizard when you created the project

• Enter the process tag types in your master data library
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4.2.3 Working with the Master Data Library

Blocks in the Master Data Library

Creating a master data library for a large project does, of course, involve a lot of
precise planning before the CFC charts are created. In Getting Started, we will of
course provide you with all the blocks you require for the "color_gs" project. The
blocks are shown in the following list. We have added a certain amount of
additional information:

• Object name – this is an alphanumeric short identifier for the block that is
displayed in PCS 7

• Symbolic name – this is a short self-explanatory name for the block

• Meaning – here, you will find a brief explanation of how the block can be used

• Type of block – here you will see the category to which the block belongs

• Relevant CFC chart – here you will find all the CFC charts in which the block is
used

 Object
name

 Symb.
name

 Meaning  Type of
block

 Relevant
CFC chart

FB40 INT_P Forms the time integral of an input
value

Technological
block

CFC_LI111
CFC_FC111

FB46 OP_A_LIM Controls and analog value Operator control
block

CFC_FC111

FB48 OP_D Controls a digital value Operator control
block

CFC_FC111

FB61 CTRL_PID Continuous PID controller Technological
block

CFC_FC111

FB63 DOSE Doses components Technological
block

CFC_FC111

FB65 MEAS_MON Monitors an analog measured value Technological
block

CFC_LI111

FC63 MUL_R Multiplies input values and outputs
the product at the output

Function CFC_FC111

FC275 CH_AI Signal processing of an analog
input value

Driver block CFC_LI111
CFC_FC111

FC276 CH_AO Signal processing of an analog
output value

Driver block CFC_FC111

Process Tag Types in the Master Data Library

You enter the process tag types in your master data library in exactly the same
way as the blocks. You require the following process tag types for the "color_gs"
project:

 Object name  Meaning  Relevant CFC chart

MOTOR CFC chart for a motor CFC_NP111

VALVE CFC chart for a valve CFC_NK111
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4.2.3.1 How to Open Libraries

Ready to Start?

SIMATIC Manager is open

Opening Libraries

1. Select the menu command File > Open.
The "Open Project" dialog box opens.

2. Select the "Libraries" tab.

3. Select the libraries "PCS 7 Library V60" and "color_gs_Lib" in the selection list.

4. Click the "OK" button.
Both libraries are opened in the component view.
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4.2.3.2 How to Insert Blocks in Your Library

Ready to Start?

• SIMATIC Manager is open

• "PCS 7 Library V60" is open and the component view is activated.

• Master data library "color_gs_Lib" is open and the component view activated

Inserting Blocks in the Master Data Library

1. Select the menu command Window > PCS 7 Library V60 (component view).
This brings you to the PCS 7 standard library.

2. Select the following entry in the tree structure
"PCS 7 Library V60/ Blocks + Templates/ Blocks".
All the blocks provided by PCS 7 as default are displayed in the detailed
window.

3. Select the menu command View > Details.
The object names, in other words the brief identifiers of the blocks and the
symbolic names are now displayed providing you with more detailed
information.

4. In the detailed window, select the required blocks according to the following
list:

- FB40 – INT_P

- FB46 – OP_A_LIM

- FB48 – OP_D

- FB61 – CTRL_PID

- FB63 – DOSE

- FB65 – MEAS_MON

- FC63 – MUL_R

- FC275 – CH_AI

- FC276 – CH_AO
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5. Select the menu command Edit > Copy.

6. Select the menu command Window > color_gs_Lib (component view).
This brings you to the master data library.

7. Select the following entry in the tree structure
"In <color_gs_MP>/ color_gs_Lib/ S7-Program(1)/ Blocks".

8. Select the menu command Edit > Paste.
All selected blocks are inserted.
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4.2.3.3 How to Insert Process Tag Types in a Library

Ready to Start?

• SIMATIC Manager is open

• "PCS 7 Library V60" is open and the component view is activated.

• Master data library "color_gs" is open and the component view activated

Inserting a Process Tag Type in the Master Data Library

1. Select the menu command Window > PCS 7 Library V60 (component view).
You change to the component view of the PCS 7 standard library.

2. Select the following entry in the tree structure "PCS 7 Library V60/ Blocks +
Templates/Templates".
All the charts provided by PCS 7 as default are displayed as templates in the
detailed window.

3. Select the following charts in the detailed window:

- "MOTOR"

- "VALVE"

4. Select the menu command Edit > Copy.

5. Select the menu command Window > color_gs_Lib (component view).
This brings you to the master data library.

6. Select the following entry in the tree structure
"In <color_gs_MP>/ color_gs_Lib/ S7-Program(1)/ Charts".

7. Select the menu command Edit > Paste.
All selected process tag types are inserted.

Note

Once you have inserted a process tag type in the master data library, all the
individual blocks contained in this process tag type are entered automatically in
the "Blocks" folder.

If you select the entry "In <color_gs_MP>/ color_gs_Lib/ S7-Program(1)/ Blocks",
all the blocks are displayed in the detailed window: The blocks you have inserted
yourself along with the blocks that were inserted automatically as a result of
copying the process tag types.
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8. Now close the "PCS 7 Library V60" and "color_gs_lib" libraries.
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4.2.4 Showing and Hiding Libraries

You have the option of hiding all the libraries that you do not require. This makes
working with the catalog in the CFC Editor clearer and less liable to errors. Since
you have already inserted all the required blocks and process tag types in your
master data library, you will only need to work with the master data library to create
the "color_gs" project.

You can, of course, display libraries again when you require them.

4.2.4.1 How to Hide and Show Libraries

Caution

Make sure that you actually have all the required blocks and charts in your master
data library.

Ready to Start?

• SIMATIC Manager is open

Hiding Libraries

1. Select the menu command File > Manage.
The "Manage" dialog box opens.

2. Select the "Libraries" tab.

3. Select all the libraries in the list except the following libraries:

- Master data library "color_gs_Lib"

- PCS 7 Library V60

- SFC Library
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4. Click the "Hide" button.
All the libraries you selected are removed from the list.

5. Click the "Close" button.
You have now made all the libraries you do not want to use invisible. As a
result, they will not longer be displayed in the catalog of the CFC Editor.

Showing Libraries Again

1. Select the menu command File > Manage.
The "Manage" dialog box opens.

2. Click the "Display" button.
The "Browse" dialog is opened.

3. Select the folder ".../SIEMENS/ STEP7/ S7LIBS in the tree structure.

4. Select the required library.
This is displayed in the adjacent "Libraries" tab.

5. Click the "OK" button.
The dialog box closes and the required library is displayed and selected in the
list of libraries in the "Manage" dialog.

6. If you want to display further libraries, repeat steps  2 through 5.

7. Click the "Close" button.
The dialog box is closed.
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4.3 CFC Charts in the PH

4.3.1 Working with CFC Charts

Once you have made the preparations for creating the CFC charts by filling your
master data library, you can now start with the actual creation of the CFC charts.

What are the Basic Steps in Creating CFC Charts?

In principle, there are three basic steps:

• Creating empty CFC charts in the plant hierarchy

• Inserting individual blocks in an empty CFC chart

• Interconnecting the inputs and outputs of blocks and assigning parameter
values to them

CFC Charts in the PH

The "New Project" wizard has already created a CFC chart in your plant hierarchy.
This is stored in the "ADDIT" folder. This chart does not yet contain any blocks –
you will insert these in the CFC Editor.

For the "color_gs" project you require other charts that you insert in the plant
hierarchy and then edit in the CFC Editor.

It important that you assign self-explanatory short names to all the charts of the
"color_gs" project to keep the project clear to understand.

4.3.2 Which Charts do You Require in the 'color_gs' Project?

The following charts are required for the "color_gs" project:

• CFC_SETP – Assigning setpoints

• CFC_FC111 – controlling the dosing amount and speed

• CFC_LI111 – controlling and simulating the level

• CFC_NP111 – motor control

• CFC_NK111 to CFC_NK114 – valve control

Each chart has a technological significance. To fully understand each part of the
plant that you configure in Getting Started, you should also understand the
technological significance of the individual charts and we therefore provide you
with a brief explanation of each chart.
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A Few Details on Creating CFC Charts

You will create the charts CFC_SETP, CFC_FC111 and CFC_LI111 yourself.
PCS 7 provides you with the charts CFC_NP111 and CFC_NK11x in the form of a
process tag type. This will illustrate the great advantage of using process tag types
that you have simply inserted in your master data library up to now.

Note

In the "color_gs" project, the names of the charts are assigned according to the
naming of the corresponding hierarchy folder and therefore at the same time
according to the naming of the corresponding process tag. As a result, unique
identification is always possible.

4.3.3 Technological Significance of the 'CFC_SETP' Chart

The operator must be able to control the dosing from the OS. The following
settings are necessary:

• The PARA_DOS_RM1_QTY block specifies the dosing speed.

• The PARA_DOS_RM1_VOL block specifies the dosing volume.

• The target reactor is specified with the PARA_DOS_RM1_SEL block.

4.3.4 Technological Significance of the 'CFC_FC111' Chart

This chart is used to control the dosing amount and speed:

• The "CH_AI" block provides the currently dosed volume at the "V" output and
transfers this measured value to the "PV_IN" (process value) input of the
"DOSE block".

• The "INT_P" block is used for simulation of the dosed volume.

• The speed of the dosing is controlled by a flow control with the "CTRL_PID"
block.

• The "CTRL_PID" block receives the setpoints via the step control in
conjunction with the "PARA_DOS_RM1_VOL" block.

• The manipulated variable for the valve is output at the "LMN" output and is fed
directly to the "CTRL_PID" block at input "LMNR_IN" in the absence of
feedback from the process.

• The "CH_AO" block outputs the manipulated variable to the valve.
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4.3.5 Technological Significance of the 'CFC_LI111' Chart

This chart is used to control and simulate the level:

• The "CH_AI" block reads in the fill level of the raw material tank and outputs
the current value at output "V".

• In the default setting, this output is interconnected with the "U" input of the
"MEAS_MON" block.

• The "INT_P" block is used to simulate the fill level.

4.3.6 Technological Significance of the 'CFC_NP111' Chart

The "CFC_NP111" chart is used for pump control:

• The "CH_DI" block supplies the current state of the pump (on or off) at output
"Q".

• This value is connected to the "FB_ON" input (feedback ON) of the MOTOR
block where it is evaluated.

• The operator or a higher level controller controls the "MOTOR" block.

• The "CH_DO" block takes the control command from the "QSTART" output of
the "MOTOR" block and outputs this to the pump in the process.

4.3.7 Technological Significance of the 'CFC_NK11x' Chart

This chart is used to control the valves:

• The "CH_DI" block returns feedback on the status of the valve – open or
closed – to the "VALVE" block.

• The "VALVE" block switches the valve according to the setting made by an
external controller or by an operator: The control command is passed on from
the "QCONTROL" output via the "CH_DO" output driver to the valve.

• The "VALVE" block can forward fault messages to the operator station.

4.3.7.1 How to Rename CFC Charts in the PH

Ready to Start?

• The "color_gs" project is open in the SIMATIC Manager

• Plant view activated
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Follow the steps outlined below...

The ADDIT folder already contains a CFC chart created automatically by the
wizard. This chart needs to be renamed.

1. Select the following folder in the tree structure
"color_gs_MP/color_gs_Prj/Plant1/RMT1/FC111/ADDIT".

2. Select the "CFC(1)" object in the detailed window.

3. Select the menu command Edit > Object Properties.
The "Properties CFC Chart" dialog box opens.

4. Enter the name "CFC_SETP" in the "Name" input box.
In real projects, the name of the chart already relates to an identification
system as required by the customer for the process tags.

5. Click the "OK" button to enter your settings.
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4.3.7.2 How to Insert New CFC Charts in the PH

You will need to insert the following charts yourself as new empty CFC charts:

• "CFC_FC111"

• "CFC_LI111"

Ready to Start?

• The "color_gs" project is open in the SIMATIC Manager

• Plant view activated

Follow the steps outlined below...

1. Select the following folder in the tree structure
"color_gs_MP/color_gs_Prj/Plant1/RMT1/FC111".

2. Select the menu command Insert > Technological Objects > 2 CFC.
The "CFC(1)" CFC chart is inserted. When you insert new charts, PCS 7
assigns the default name "CFC" followed by a consecutive number and
activates the input mode for a new name.

3. Enter the name "CFC_FC111".

4. Select the following folder in the tree structure
"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1/ LI111".

5. Select the menu command Insert > Technological Objects > 2 CFC.
The "CFC(1)" CFC chart is inserted.

6. Enter the name "CFC_LI111".
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4.3.7.3 How to Insert the 'MOTOR' Process Tag Type

You have already inserted the "MOTOR" process tag type in your master data
library. You now only need to insert this process tag type in your "color_gs" project
in the plant hierarchy.

Ready to Start?

• The "color_gs" multiproject is open in the SIMATIC Manager

• Plant view activated

Follow the steps outlined below...

1. Select the following entry in the tree structure
"color_gs_MP/ color_gs_Lib/Templates/MOTORS".
The detailed window displays the process tag types you inserted in your
master data library.

2. Select the "MOTOR" chart and then the menu command Edit > Copy.

3. Select the following folder in the tree structure
"color_gs_MP/ color_gs_Prj/Plant1/RMT1/NP111" and select the menu
command Edit > Paste.
The "MOTOR" chart is inserted in the hierarchy folder and is selected.

4. Select the menu command Edit > Object Properties.
The "Properties CFC Chart" dialog box opens.

5. Change the default name "MOTOR" to "CFC_NP111" in the "Name" box.

6. Click the "OK" button to enter your settings.
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4.4 The Current Status of Your Project...

As preparation for the actual creation of CFC charts, you have now performed the
following tasks:

• Inserted all the required blocks and process tag types in the master data library

• Hidden libraries that you do not require for the "color_gs" project so that only
the "color_gs_Lib" master data library is visible.

• Renamed and inserted new CFC charts in the plant hierarchy

• Inserted the "MOTOR" process tag type in the plant hierarchy

4.5 Working with the CFC Editor

4.5.1 Introduction to the CFC Editor

The actual editing of the CFC charts such as inserting blocks and assigning
parameter values to them is done in the CFC Editor.  As soon as you open a CFC
chart, the CFC Editor opens. The editor is always opened in the view in which it
was closed the last time you worked with it.

With its normal settings, the CFC Editor is divided up as follows:

• On the left-hand side of the editor you see the chart displayed. If you have
opened an empty CFC chart, here you will simply see an empty space. This is
where you insert blocks as required to describe continuous processes. The
final job is to assign parameter values and interconnect the blocks.

• On the right-hand side of the editor you will see the catalog with blocks,
libraries, and charts.

All the work that you do with the CFC Editor is saved automatically by PCS 7.

For more detailed information on the CFC Editor refer to the online help
Help on CFC and the manual SIMATIC CFC for S7, Continuous Function Chart.
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4.5.2 The Chart in the CFC Editor

Each CFC chart can contain up to 26 chart partitions. When a chart is created the
first time, it consists of only one chart partition. Only one chart partition is
necessary for the "color_gs" project. Each chart partition itself consists of six
sheets.

You can select between two different views using the buttons in the toolbar:

•      A single sheet

•      Overview with six sheets

The status bar indicates which sheet of which chart partition is currently displayed.

Changing from the Overview to a Single Sheet

You can change from the overview to the single sheet view by double-clicking on
the required sheet.

The arrangement of the individual sheets at the overview level is in the order
shown below:

�

�

�

�

�

�

You will find more detailed information in the online help Help on CFC and in the
manual SIMATIC, CFC for S7, Continuous Function Chart.
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4.5.3 The Catalog in the CFC Editor

If it is not already open, open the catalog using the menu command "View >
Catalog".

In the catalog you will see four tabs:

• Blocks – here you will find blocks sorted according to block families. In the
"color_gs" project you will not work in this tab.

• Charts – here you will find all the charts you created in the plant hierarchy, for
example CFC_FC111, CFC_LI111. The chart that is currently open in the CFC
Editor and displayed is indicated by a small open folder.

• Libraries – normally, you would find all the libraries provided by PCS 7 along
with your master data library.
In the "color_gs" project, you have already made the libraries you do not
require invisible using the "Hide" function. This means that you will only see the
"color_gs_Lib" library.

• Unplaced blocks – here you will find blocks that are not displayed in a CFC
chart. Within the "color_gs" project, this tab is not displayed since there are no
"unplaced blocks" in your project.

You will find more detailed information in the online help Help on CFC and in the
manual SIMATIC, CFC for S7, Continuous Function Chart.

4.5.4 Overview of the Configuration Steps for CFC Charts

When you create CFC charts, follow the steps below in exactly the order shown:

• Open chart

• Insert blocks in the required run sequence

Caution

The order in which you insert blocks in the CFC chart is exactly the same order in
which the blocks will be executed in the process mode. In this Getting Started, we,
of course, tell you the correct order. In a real configuration, you must find out the
exact run sequence based on the process and keep to this when inserting blocks
in the CFC chart.
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• Set block parameters

- Rename blocks

- Set input/output values

• Interconnect blocks

Note

If you require further information about the blocks, for example, which inputs of the
block have which function, select the corresponding block in the library and then
press the F1 key. This opens the online help for this block.

The step "Insert Blocks" is, of course, omitted for process tag types. With these,
you only need to assign parameter values and interconnect them.

4.5.4.1 How to Open the 'CFC_SETP' CFC Chart

To be able to place blocks in your CFC charts, you must now open the CFC chart.

Ready to Start?

• The "color_gs" multiproject is open in the SIMATIC Manager

• Plant view activated

Follow the steps outlined below...

1. Select the following folder in the tree structure
"color_gs_MP/color_gs_Prj/Plant1/RMT1/FC111/ADDIT".

2. Select the "CFC_SETP" object in the detailed window and then select the
menu command Edit > Open Object.
The CFC editor is opened.

You can now edit the open chart.
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4.5.5 Assigning Parameter Values to the Blocks in CFC Charts

Each block has a number of different I/Os, which are displayed in a table in the
Properties dialog. To find the I/Os quickly in this dialog box, you can click in the
column head of the table and sort the column in an ascending or a descending
order.

The I/Os of a block can be both visible or invisible: You can only see invisible
parameters in the properties of the block but not in the representation in the CFC
chart. You can specify which I/Os in the CFC chart will be visible and which will be
invisible. You specify this in the properties of the block in the "Not Displayed"
column by unchecking the check box of the relevant I/O to make the I/O visible in
the CFC chart. This function helps to make a CFC chart easier to read. In the
"color_gs" project, we will use the default settings.

Follow the steps outlined here...

4.5.5.1 How to Insert the Blocks in 'CFC_SETP'

Ready to Start?

• CFC chart "CFC_SETP" is open in the CFC Editor –
stored in folder "color_gs_MP/ color_gs_prj/ Plant1/ RMT1/ FC111/ ADDIT"

• The catalog is open

Follow the steps outlined below...

1. Change to the "Libraries" tab in the catalog.
Here you will see the "color_gs_Lib" library.

2. Open the following folder in the tree structure "color_gs_Lib/S7
Program(1)\Blocks".

3. Drag the "OP_A_LIM – FB46" block from the catalog to your CFC chart.
This block is used to set the dosing volume.

4. Insert further blocks into the CFC chart.
Use the same procedure as described for the "OP_A_LIM – FB46" block.

- OP_A_LIM – FB46: Setting the dosing speed

- OP_D – FB48: Specifying the reactor to which the raw material will be
pumped



Creating CFC Charts

Process Control System PCS 7, Getting Started - Part 1
A5E00164244-01 4-23

5. Arrange the blocks in the CFC chart as shown below:

OP_D

OP_A_LIM

OP_A_LIM

Note

If a block is shown in blue or light gray after you have inserted it and if no block
I/Os are displayed, this is covering an underlying block or extends beyond the
edge of the sheet. In this case, you must move the block with the mouse so that it
does not cover any other block and is within the limits of the sheet.
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4.5.5.2 How to Assign Parameter Values for the Blocks in 'CFC_SETP'

Ready to Start?

• CFC chart "CFC_SETP" is open in the CFC Editor – stored in folder
"color_gs_MP/ color_gs_prj/ Plant1/ RMT1/ FC111/ ADDIT"

• All blocks are inserted

Follow the steps outlined below...

1. Select the "OP_A_LIM" block and select the menu command Edit > Object
Properties.
The "Properties – Block" dialog box opens and the "General" tab is active.

2. Enter the name "PARA_DOS_RM1_QTY" in the "Name" box.
The "Operator C and M possible" check box is activated as default.

3. Select the "Inputs/Outputs" tab.
Here, you can assign parameter values for all the I/Os of a block. The "Name"
column lists the names of all inputs and outputs.
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4. Position the mouse pointer in the "Value" column of the "U" field and overwrite
the default value with the value "50".

5. Click the "OK" button to enter your settings.
The name "PARA_DOS_RM1_QTY" is displayed in the header of the block in
the CFC chart.
When you create the process pictures, you will interconnect the I/Os of the
blocks from the CFC charts with objects in the process pictures. The name of
tags is formed from the plant hierarchy, the CFC chart name, and the block
name. You will find the name "PARA_DOS_RM1_QTY" as part of the tag
name.
The values of the I/Os are entered.
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6. Now change the names and parameter settings for the other blocks as shown
in the following table. Follow the procedure as explained in Steps 1 to 5.
Some of the I/Os are not visible in the CFC chart.

 Block  Name in Project  I/O  Meaning  Value

OP_A_LIM PARA_DOS_RM1_VOL U* Setpoint for dosing 1000 liters 1000

U_HL Limit value of the entry for the
U parameter

10000

OP_D PARA_DOS_RM1_SEL IO* The material is fed to reactor 1 OFF

  * invisible in CFC.

4.5.5.3 How to Insert the Blocks in 'CFC_FC111'

Ready to Start?

• CFC chart "CFC_FC111" is open in the CFC Editor – stored in folder
"color_gs_MP/ color_gs_prj/ Plant1/ RMT1/ FC111"

• The catalog is open, the Libraries tab is visible

Follow the steps outlined below...

1. Insert the following blocks by dragging with the mouse:

- CH_AI – FC275: Signal processing of an analog input value

- INT_P – FB40: Simulation of the dosing volume

- DOSE – FB63: Dosing the raw material

- MUL_R – FC63: Multiplication of the input values and output of the product
at the output

- CTRL_PID – FB61: Fill level monitoring and visualization of the level in the
process mode

- CH_AO – FC276: Signal processing of an analog output value
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2. Arrange the blocks in the CFC chart as shown below:

CTRL_PID

MUL_R

CH_AI

INT_P DOSE

CH_AO

4.5.5.4 How to Assign Parameter Values for the Blocks in 'CFC_FC111'

Ready to Start?

• CFC chart "CFC_FC111" is open in the CFC Editor – stored in folder
"color_gs_MP/ color_gs_prj/ Plant1/ RMT1/ FC111"

• All blocks are inserted

Follow the steps outlined below...

1. Open the "Object Properties" dialog box, "Inputs/Outputs" tab for each block.

2. Enter the parameters for all blocks according to the following list:

Note

Make sure that you use a period as the decimal separator.

In some fields, PCS 7 displays default values in a drop-down list box that you can
select. This drop-down list box is activated automatically when you position the
mouse pointer in the input field.
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 Block  Name in Project  I/O  Meaning  Value

CH_AI INPUT_U SIM_ON* Simulation activated  1

MODE Measuring range 4 to 20 mA  16#0203

VHRANGE Upper measuring range  100 **

SUBS_ON Enabling of a substitute value  1

INT_P INT_P V_HL Upper limit quantity summation
10000 Liters

 10000

DOSE DOSE SP_HLM* Upper limit of the setpoint for the
dosing volume

 10000

MO_PVHR* Upper limit of the process value for
the dosing volume

 10000

SPEXON_L Interconnection for the
internal/external switchover active

 1

SPEXT_ON Default for the internal/external
switching

 1

MUL_R MUL_R IN2 Parameters for optional adaptation
of the flow rate value

 1 **

CTRL_PID CTRL_PID LIOP_MAN_SEL Interconnection automatic/manual
active

 1

LIOP_INT_SEL Interconnection for the
internal/external switchover active

 1

SPEXON_L Switch controller to external setpoint  1

GAIN Set the gain of the controller to 0.5  0.5

CH_AO OUTPUT_LMN omitted — —

  * invisible in CFC.

  ** default value

3. When you have entered the parameters for all the I/Os, click on the "OK"
button to enter your settings.
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4.5.5.5 How to Insert the Blocks in 'CFC_LI111'

You now have to complete the "CFC_LI111" chart. The procedure is exactly the
same as for the "CFC_FC111" chart.

Ready to Start?

• CFC chart "CFC_LI111" is open in the CFC Editor –
stored in folder "color_gs_MP/ color_gs_prj/ Plant1/ RMT1/ LI111"

• The catalog is open

Follow the steps outlined below...

Drag the blocks with the mouse pointer and arrange them as shown in the figure: 

• CH_AI – FC275: This function reads the process value of an input module and
makes the value read in available in CFC for further processing

• INT_P – FB40: This block is used to simulate the level of the raw material
tank 1

• MEAS_MON – FB65: Fill level monitoring and visualization of the level in the
process mode

MEAS_MON

INT_P

CH_AI
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4.5.5.6 How to Assign Parameter Values for the Blocks in 'CFC_LI111'

Ready to Start?

• CFC chart "CFC_LI111" is open in the CFC Editor – stored in folder
"color_gs_MP/ color_gs_prj/ Plant1/ RMT1/ LI111"

• All blocks are inserted

Follow the steps outlined below...

1. Open the "Object Properties" dialog box, "Inputs/Outputs" tab for each block.

2. Enter the parameters for all blocks according to the following list:

 Block  Name in
Project

 I/O  Meaning  Value

CH_AI INPUT_U MODE Measuring range 4 to 20 mA  16#0203

VHRANGE Upper measuring range  100 **

SIM_ON Simulation value active  1

SIM_V Raw material tank level 78%  78

SUBS_ON Enabling of a substitute value  1

SUBS_V Substitute value for SIM_V  78

INT_P INT_P U Simulation of the raw material tank level  -0.4

MEAS_MON LIA U_WH Warning high = 90 m3  90

U_WL Warning low = 7 m3  7

U_AH Alarm high = 98 m3  98

U_AL Alarm low = 5 m3  5

MO_PVHR* Upper limit of the process value in the
container = 100 m3

 100

  * invisible in CFC.

  ** default value

3. When you have entered the parameters for all the I/Os, click on the "OK"
button to enter your settings.
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4.5.5.7 How to Assign Parameter Values for Blocks in 'CFC_NP111'

You have already inserted the CFC_NP111 chart as a process tag type. In this
chart, you only need to adapt the default parameter values to your "color_gs"
project.

Note

You do not need to adapt the names of the individual blocks when using process
tag types.

1. Open the "Object Properties" dialog box, "Inputs/Outputs" tab for each block.

2. Enter the parameters for all blocks according to the following list:

 Block  Name in
Project

 I/O  Meaning  Value

CH_DI FB_RUN SIM_ON Switch simulation active  1

SUBS_ON Enabling of a substitute value  1

MOTOR MOTOR MONITOR Deactivate monitoring Monitoring =Off

AUT_ON_OP* Activate the automatic mode Mode = AUTO

   * invisible in CFC.

3. Click the "OK" button to enter your settings.

4.5.6 Interconnecting the Blocks in the CFC Charts

Now make the required interconnections in the charts between outputs and inputs.
You can create the interconnections of blocks conveniently by clicking on the
graphic user interface of the CFC editor with the mouse. Click first the output of a
block and then the input you want to connect to it. After clicking on the input, the
interconnection is displayed as a line. The CFC Editor draws the lines
automatically taking the most suitable path. The position of the lines has no effect
whatsoever on the function of the interconnection.

Caution

Always connect the output of a block to the input of another block – and not vice-
versa.

Note

If you make an incorrect interconnection:

Click on the line of the incorrectly interconnection and select the menu command
Edit > Delete.
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Special Feature of the Charts "CFC_SETP", "CFC_NP111" and "CFC_NK11x"

The CFC_SETP charts do not require any interconnection because this chart is
used only for setting the setpoints and for storing operator commands.

In the CFC_NP111 and CFC_NK11x charts, you do not need to make
interconnections since you used the process tag types for these charts and all the
interconnections are already made.

4.5.6.1 How to Interconnect Blocks in 'CFC_FC111'

Ready to Start?

• The "CFC_FC111" chart is open in the CFC Editor

• All blocks are inserted

Now make the interconnections…

1. Click on output "V" of the "INPUT_U" block.

2. Now click on the input "U" of the "INT_P" block.
The CFC Editor automatically creates a line indicating the interconnection.

3. Following the same procedure, make the remaining interconnections according
to the list below:

 Block  Output  Block  Input:

erl.: INPUT_U V INT_P U

INT_P V DOSE PV_IN

MUL_R OUT CTRL_PID PV_IN

CTRL_PID LMN OUTPUT_LMN U

CTRL_PID LMN MUL_R IN1

CTRL_PID LMN CTRL_PID LMNR_IN
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The chart then appears as shown below:
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4.5.6.2 How to Interconnect Blocks in 'CFC_LI111'

Ready to Start?

• The "CFC_LI111" chart is open in the CFC Editor

• All blocks are inserted

Now make the interconnections…

Make the interconnections according to the following list:

 Block  Output  Block  Input:

INPUT_U V INT_P VTRACK

INT_P V LIA U

The chart appears as shown below:

Close the CFC editor.
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4.6 CFC Charts in the Process Object View

4.6.1 Using the Process Object View for Controlling Valves

You may be asking yourself why we have done nothing up to now with the charts
CFC_NK111 to CFC_NK114. You have simply inserted the "VALVE" process tag
type in your master data library and created the four hierarchy folders in the plant
hierarchy.

To handle almost identical charts, we will now introduce you to an extremely
convenient function in PCS 7: The process object view. This means that you do not
need to open each individual chart in the CFC Editor and assign parameter values
but can simply change values quickly in a table.

The following preparations are necessary:

• Specify I/Os in the process tag type for the process object view – since some
I/Os are not displayed in the process object view to improve clarity, you must
first define the I/Os you want to be visible. You define this once in the process
tag type in the master data library.

• Insert the process tag type in the individual hierarchy folders and rename them
– you will copy the process tag type from the master data library to all
hierarchy folders in which you require valve control.

• Adapt the values of the parameters in the process object view – you will now
get to know the great advantage of the process object view: You can edit
values quickly and conveniently in a table.

4.6.1.1 How to Define I/Os for the Process Object View

Ready to Start?

• The "color_gs" project is open in the SIMATIC Manager

• Plant view activated

Follow the steps outlined below...

1. Select the following folder in the tree structure
"color_gs_Lib/Templates/Valves".

2. Select the "VALVE" CFC chart in the detailed window.

3. Select the menu command Options > Process Objects > Select I/Os.
The "Select I/Os" dialog box opens.

4. Click on the column header of the "Parameter" column.
All the I/Os are then displayed in the upper lines that are activated in the
"Parameter" column.

5. Deactivate the check boxes of these I/Os.
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6. Activate the check boxes in the "Parameter" column for the following I/Os:

 Block  I/O

VALVE START_SS

VALVE MONITOR

VALVE AUT_ON_OP

Note

Click in the column header of the "Input/Output" column to sort the I/Os in
ascending or descending order and make them easier to find.

7. Click the "Apply" button to enter your settings.

8. Click the "OK" button.
The "Select I/Os" dialog box is closed.
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4.6.1.2 How to Insert the 'VALVE' Process Tag Type

Ready to Start?

• The "color_gs" multiproject is open in the SIMATIC Manager

• Plant view activated

Follow the steps outlined below...

Follow exactly the same procedure as for the "MOTOR" process tag type:

1. Select the "VALVE" process tag type in the folder "color_gs_MP/
color_gs_Lib/Templates/VALVES".

2. Insert the "VALVE" process tag type in the following folders using the function
"Edit > Copy" and "Edit > Paste":

- color_gs_MP/color_gs_Prj/Plant1/RMT1/NK111

- color_gs_MP/color_gs_Prj/Plant1/RMT1/NK112

- color_gs_MP/color_gs_Prj/Plant1/RMT1/NK113

- color_gs_MP/color_gs_Prj/Plant1/RMT1/NK114

3. In the message dialog "The object 'valve' already exists. Do you want to
overwrite it?", click on the "No" button.

4. In the message box "The object 'Valve' exists already. Do you want to
overwrite it?", click on the "No" button.

5. Rename the inserted process tag types according to the following table:

 Hierarchy Folder  Rename to:

../RMT1/NK111 CFC_NK111

../RMT1/NK112 CFC_NK112

../RMT1/NK113 CFC_NK113

../RMT1/NK114 CFC_NK114

You will find a detailed description in "Creating CFC Charts – CFC Charts in the
PH – How to Insert the "MOTOR" Process Tag Type.
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4.6.1.3 How to Adapt the Parameters for 'CFC_NK11x'

Ready to Start?

• The "color_gs" multiproject is open in the SIMATIC Manager

• The process object view is activated

Follow the steps outlined below...

1. Select the following folder in the tree structure
"color_gs_MP/ color_gs_Prj/ Plant1/RMT1".

2. Select the "Parameter" tab.
The data is updated.

3. Select the "Block" entry from the "Filter by column" drop-down list box.
This activates the "Display" box.

4. Enter the name of the block in the "Display" box: "VALVE".
The table is updated and shows you the "Valve" block for all four CFC charts.
For each chart you can see three I/Os that have been made visible especially
for the process object view.

Note

If the name of the CFC chart is not fully displayed in the column, position the
cursor between the "Chart" column and "Comment" column and double-click. This
adapts the column width automatically to the width of the entries.

5. In the "Block Comment" column for the "CFC_NK111" chart, enter the name
"Stop_valve1" and press the Enter key.
The block comment is then updated for all I/Os of this chart.

6. Do the same for the block comment in the other CFC charts:

 CFC Chart  Block comment

CFC_NK112 stop_valve2

CFC_NK113 stop_valve3

CFC_NK114 stop_valve4
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7. Change to the "Value" column and make the entries according to the table
shown below:

Note

Depending on the size of your monitor, you may not be able to see the "Chart"
column any more and this makes the assignment of the individual I/Os to a chart
unclear.

In the process object view, you have the following option:

1. Position the cursor on the small box to the left beside the horizontal scroll bar
and click.
This makes a vertical marker visible in the table.

2. Hold down the mouse button and drag this vertical marker between the
"Hierarchy" and "I/O" columns.

3. Release the mouse button.
This splits the table window and you can navigate on the right-hand side with
the horizontal scroll bar in the table while the chart names are displayed on
the left-hand side.

- Position the mouse pointer in the relevant field
This converts the field to a drop-down list box.

- Select the required entry from this drop-down list box.
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 CFC Chart  I/O  Meaning  Value

CFC_NK111 START_SS Select the valve default state (open/closed)  0

MONITOR Disable monitoring of feedback from the process
for the example.

Monitoring=off

AUT_ON_OP Switch the valve to the automatic mode Mode=Auto

CFC_NK112 START_SS see above  0

MONITOR see above Monitoring=off

AUT_ON_OP see above Mode=Auto

CFC_NK113 START_SS see above  1

MONITOR see above Monitoring=off

AUT_ON_OP see above Mode=Auto

CFC_NK114 START_SS see above  1

MONITOR see above Monitoring=off

AUT_ON_OP see above Mode=Auto

4.6.1.4 How to Specify the Type of Block Icon

At this stage, you must make preparations for creating the process pictures. Since
there are certain automatic functions, you can already make settings here.

Ready to Start?
• The "color_gs" multiproject is open in the SIMATIC Manager

• The process object view is activated
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Follow the steps outlined below...

1. Select the following folder in the tree structure
"color_gs_MP/ color_gs_Prj/ Plant1/RMT1".

2. Select the "Picture Objects" tab.
The data is updated. The first time, this updating can take several minutes.

3. Select the "Block" entry from the "Filter by column" drop-down list box.
This activates the "Display" box.

4. Enter the name of the block in the "Display" box: "VALVE".
The table is updated and shows you the "Valve" block for all four CFC charts.

5. Enter the value "2" in the "Block Icon" column for the following charts:

- "CFC_NK113"

- "CFC_NK114"

6. Press the enter key
This specifies that a block icon aligned horizontally will be used in the process
picture.

7. Close the process object view.
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4.7 The Current Status of Your Project...

During CFC configuration, you have performed the following tasks:

• You have inserted blocks in the CFC Editor, assigned parameter values to the
blocks and interconnected them.

• You have used the process object view to assign parameter values to the
same process tag types.
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5 Creating SFC Charts

5.1 Overview of SFC Charts

What is SFC?
SFC (Sequential Function Chart) is a sequential control system partitioned to
ensure step-by-step execution with control passing from one state to the next state
dependent on conditions. With a sequential control system, basic automation
functions, for example CFC charts are controlled based on state changes and can
be selectively processed. You create SFC charts in the SFC Editor.

When you created the "color_gs" project with the wizard, PCS 7 automatically
created an SFC chart. This chart is, of course, still empty and you must edit the
chart with the SFC Editor for the "color_gs" project.

5.2 Working with the SFC Editor

5.2.1 Introduction to the SFC Editor

As soon as you open an SFC chart, the SFC Editor opens. The editor is always
opened in the view in which it was closed the last time you worked with it.

The SFC Editor – just like the CFC Editor – provides you with a graphic user
interface that allows the convenient creation of sequential control systems.

A sequential control system consists primarily of two basic elements: Steps and
transitions.

• The transition is a condition that controls the execution of a step. Transitions
are represented by small rectangles in the SFC chart.

• The step is the control instance for processing the assigned actions on the
programmable controller. It is executed until the following transition is satisfied.
Steps are represented by large rectangles in the SFC chart.

When you open a new SFC chart in the SFC Editor, you will first see two steps and
one transition:

• Step "START"

• Transition 1

• Step "END"

A sequential control system will run with the values you assigned to the blocks in a
CFC chart.
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5.2.2 The Main Functions of the SFC Editor

Here, we will introduce you to the main functions of the SFC Editor that you will
require for configuring the SFC charts for your "color_gs" project.

You will use the element bar of the SFC Editor to build up your sequential control
system. The buttons have the following significance:

•      "Activate Selection" button – when this button is active, you can select
individual objects of the SFC chart, for example the steps and transitions. A
selected step or a selected transition is displayed in blue.

•      "Insert Step + Transition" button – when this button is active, the mouse
pointer changes to a small cross and a circle with a bar across. Once you
move the cross to a position in the chart at which you can insert a step or a
transition, the circle becomes the icon for "Step with Transition". At the same
time, a green line indicates where the "Step with Transition" will be inserted.

•      "Insert Alternative Sequence" button – when this button is active, you
can insert an alternative sequence. This means that depending on the defined
transition either one or the other sequence is processed.

None of the other buttons are used in the "color_gs" project.

For more detailed information on the SFC Editor refer to the online help Help on
SFC and the manual SIMATIC SFC for S7, Sequential Function Chart.

5.2.3 Properties of Steps and Transitions

To be able to edit the names and values of the steps and transitions, you will work
in the "Properties" dialog box. You do not need to open the dialog box extra for
each step and each transition but can move directly to the next transition or next
step and to transitions and steps of an alternative sequence in this dialog box.

To allow this, the following buttons are available:

•      "Arrow Down" button – with this button you change to the next
transition/step

•      "Arrow Up" button – with this button you change to the previous
transition/step

•      "Arrow Right" button and    "Arrow Left" button – with these buttons
you change to the adjacent transition/step

The dialog box has four different tabs. These tabs will be introduced briefly below.
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Tabs in the "Properties" Dialog Box for a Step:

• General – here, you make the general settings such as changing the name of
the step.

• Initialization – the action you define here is processed once only when the step
is activated.

• Processing – the action you define here is processed cyclically until the next
transition is satisfied.

• Termination – the action you define here is processed once only when the step
is terminated.

Tabs in the "Properties" Dialog Box for a Transition:

• General – here, you make the general settings, such as changing the name of
the transition.  

• Condition – in this tab, you specify the condition that decides when control will
be passed to the next step in the sequential control system.

5.2.4 Overview of the Configuration Steps for SFC Charts

To create SFC charts, you perform the steps listed below:

• Move the SFC Chart

• Rename the SFC Chart

• Open the SFC Chart

• Specify the Technological Structure of the Sequential Control System

• Name the Steps

• Name the Transitions

• Assign Parameter Values for the Steps

• Assign Parameter Values for the Transitions
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5.2.4.1 How to Move an SFC Chart

The SFC chart "SFC(1)" created by the "New Project" PCS 7 wizard when you
created the "color_gs" project is stored in the "ADDIT" hierarchy folder. Since the
charts are stored according to their significance in the plant hierarchy, you will
need to move the SFC chart created automatically by the wizard to the relevant
hierarchy folder.

Ready to Start?

• The "color_gs" multiproject is open in the SIMATIC Manager

• Plant view activated

Follow the steps outlined below...

1. Select the following folder in the tree structure
"color_gs_MP/color_gs_Prj/Plant1/RMT1/FC111/ADDIT".

2. Select the "SFC(1)" object in the detailed window.

3. Select the menu command Edit > Cut.

4. Select the following folder in the tree structure
"color_gs_MP/color_gs_Prj/Plant1/RMT1".

5. Select the menu command Edit > Paste.
The SFC chart is inserted in the selected folder.

5.2.4.2 How to Rename the SFC Chart

To keep the naming system consistent and clear within your project, you will need
to change the default names.

Ready to Start?

• The "color_gs" multiproject is open in the SIMATIC Manager

• Plant view activated

Follow the steps outlined below...

1. Select the following folder in the tree structure
"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1".

2. Select the "SFC(1)" object in the detailed window.

3. Select the menu command Edit > Object Properties.
The "Properties SFC Chart" dialog box opens.

4. Overwrite the default name "SFC(1)" with "SFC_RMT1" in the "Name" box.

5. Click the "OK" button to enter your settings.
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5.2.4.3 How to Open the 'SFC_RMT1' SFC Chart

Ready to Start?

• The "color_gs" multiproject is open in the SIMATIC Manager

• Plant view activated

Follow the steps outlined below...

1. Select the following folder in the tree structure
"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1".

2. Select the "SFC_RMT1" object in the detailed window and then select the
menu command Edit > Open Object.
The SFC editor is opened. The "Start" and "End" steps and transition 1 already
exist.

5.2.5 Technological Structure of the Sequential Control System

The following section provides you with an overview of the technological sequence
of the individual steps and transitions in the sequential control system for the
"color_gs" project.

 Name of the Step  Function

START Defaults:

• Changing the dosing controller to manual mode

• Switching the dosing controller to external

• Setting the units to automatic mode

• Stopping dosing

DOSE_REA1

DOSE_REA2

Query:

• Will Reactor 1 or Reactor 2 be used for dosing?

INIT_LINE1

INIT_LINE2

Controllers:

• Open valves of the relevant branch

• Turn on the pump

• Switch the dosing controller to an external setpoint

INIT_1_OK

INIT_2_OK

Query:

• Is the pump turned on?

• Is the controller set to "External Setpoint"?
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 Name of the Step  Function

INIT_DOSE Controllers:

• Set the setpoint for the dosing speed

• Set the dosing controller to automatic mode

• Set the setpoint for dosing volume

• Start dosing

INIT_OK Query:

• Dosing started ?

• Dosing volume (setpoint actual value) < 500 liters?

SLOW_DOWN Controller:

• Reduction of the dosing rate shortly before reaching the
required dosing volume

END_DOSE Query:

• Dosing ended ?

CLOSE_LINE Controllers:

• Close all valves

• Turn off the pump

• Switch the dosing controller to manual

• Set dosing speed to 0

• Stop dosing

CLOSE_OK Query:

• Is the pump turned off?

END Reset

• Switch the dosing controller to internal

• Close valves

• Turn off motor

The plant operator can start, control, and monitor this chart on the operator station.
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5.2.5.1 How to Create the Sequential Control System in the SFC Chart

When you insert steps and transitions, the SFC Editor assigns continuous
numbers. You then replace these numbers with self-explanatory, plant-specific
names.

Ready to Start?

• The "SFC_RMT1" SFC chart is open in the SFC Editor

• The steps "START" and "END" and transition 1 are visible

Follow the steps outlined below...

1. If the element bar with the buttons for inserting steps and transitions is not
displayed, Select the menu command View > Element Bar.
This opens the element bar.

2. Click the "Insert Step + Transition" button.

The mouse pointer changes to a small cross and a circle with a bar.

3. Position the mouse pointer below Transition 1 until a green line is displayed
and insert the object by clicking.
Step "3" and transition "2" are inserted in the chart.

4. Click the "Insert Alternative Sequence" button.

5. Position the mouse pointer below the "START" step until a green line is
displayed and insert the object by clicking.
An alternative sequence is inserted directly below the "START" step: The
transitions "3" and "4" are inserted parallel to each other and step "4" below
them.

6. Click the "Insert Step + Transition" button.

7. Position the mouse pointer at the following positions and insert a step +
transition:

- Below transition 3 – step 5 and transition 5 are inserted

- Below transition 4 – step 6 and transition 6 are inserted

- Below transition 2 – step 7 and transition 7 are inserted
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Your SFC chart should now appear as follows:
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5.2.5.2 How to Rename Steps

Ready to Start?

• The "SFC_RMT1" SFC chart is open in the SFC Editor

• All steps and transitions are inserted

Follow the steps outlined below...

1. Click the "Select" button.

2. Select step "5".

3. Select the menu command Edit > Object Properties.
The "Properties" dialog box opens and the "General" tab is active.
The default entry "5" in the "Name" box is already selected.

4. Change the name "5" in the "Name" box to "INIT_LINE1".

5. Click the "Apply" button.
The new name is stored.

6. Click the "arrow down" button.
You change to step "4".

7. Change the default name "4" in the "Name" box to "INIT_DOSE" and click the
"Apply" button.
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8. Change to the other steps with the arrow buttons and change the names
according to the table below. Each time you enter a name, complete the
change by clicking the "Apply" button.

 Default Name  New Name

 5 INIT_LINE1 – done

 4 INIT_DOSE – done

 3 SLOW_DOWN

 7 CLOSE_LINE

 6 INIT_LINE2

9. Click the "Close" button.
This saves your settings and the "Object Properties" dialog box is closed. The
changed names of the steps are displayed in the SFC chart.
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5.2.5.3 How to Rename Transitions

In just the same way as you renamed the steps, you must also replace the default
names of all transitions with self-explanatory, plant-specific names. The procedure
is exactly the same as for changing the names of the steps.

Ready to Start?

• The "SFC_RMT1" SFC chart is open in the SFC Editor

Follow the steps outlined below...

1. Double-click on transition "3".
The "Object Properties" dialog box opens and the "General" tab is active.

2. Replace the default name in the "Name" box with a plant-specific name.
The plant-specific names are listed in the following table.

3. Each time you enter a name, complete the change by clicking the "Apply"
button.

4. Use the arrow buttons to move from one transition to the next.

 Default Name  New Name

 3 DOSE_REA1

 5 INIT_1_OK

 1 INIT_OK

 2 END_DOSE

 7 CLOSE_OK

 4 DOSE_REA2

 6 INIT_2_OK

5. Click the "Close" button.
This saves your settings and the "Object Properties" dialog box is closed. The
changed names of the transitions are displayed in the SFC chart.
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Your SFC chart should now appear as follows:
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5.3 Setting the Parameters

5.3.1 How to Assign Parameter Values to the Steps of the SFC Chart

Starting in SFC, you assign values to the block inputs of the CFC charts. With the
first step "START", you make the settings for the sequence of the dosing process.

Each step for which you have defined and action is displayed in dark gray. This
means that you can see at a glance whether or not a step has had parameters
values assigned to it.

Ready to Start?

• The "SFC_RMT1" SFC chart is open in the SFC Editor

• You have adapted the names of the steps and transitions

Follow the steps outlined below...

1. Double-click on the "START" step.
The "Properties" dialog box opens and the "General" tab is active.

2. Select the "Initialization" tab.
This tab displays an empty list with statement rows and the mouse pointer is
positioned in the left column of the first row.

3. Click the "Browse" button.
The "Browse" dialog box opens and the "CFC Charts" tab is active.
In this dialog box, you can see the CFC charts of the "color_gs" project with the
PH assignment, the chart name, and the comment in the first three columns. In
the next three columns, you can see all the blocks belonging to the chart
selected in the first columns. As soon as you select a block, the last column
displays all the relevant I/Os.



Creating SFC Charts

Process Control System PCS 7, Getting Started - Part 1
5-14 A5E00164244-01

4. Select the "CFC_FC111" CFC chart.
In the adjacent columns, you now see all the blocks of the "CFC_FC111" CFC
chart.

5. Select the "CTRL_PID" block.
In the right-hand columns, you will see all the relevant I/Os of this block.
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6. Double-click on the "AUT_L" input.
The "Browse" dialog box goes to the background and the selected block I/O
along with its full path is entered as the first address in row 1.
The mouse pointer is automatically positioned in the right column of row 1.

Note

If you cannot read the names of the block I/Os, position the mouse pointer over
the relevant field – the full name is then displayed in a tooltip.

7. Enter the value "0" in this field.

8. Click the "Apply" button.
The value "0" is automatically replaced by "FALSE". The first assignment in the
"Start" step is now complete.

The dialog box now appears as shown below:

9. Click on the button with the continuous number "2". This button is arranged
directly in front of the statement row.
This positions the mouse pointer in the left column of the second row.

10. Repeat steps  3 through 9 to define the remaining addresses for the "START"
step. You will find the information you require in the following table.
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Note

The addresses in the table are specified in the following format:

[chartname\block\I/O].

The plant hierarchy is omitted to make the table clearer. As soon as you insert a
further plant or unit in the "color_gs" project, you must, of course, include the
assignment of the chart to the plant hierarchy.

 Cont.
No.

 Address 1  Address 2  Meaning

 1 already done:

CFC_FC111\ CTRL_PID\ AUT_L

FALSE Controller manual mode

 2 CFC_FC111\CTRL_PID.SP_EXT CFC_SETP\PARA_
DOS_RM1_QTY.V

Setpoint for flow control

 3 CFC_FC111\CTRL_PID.LMN_SEL FALSE No setpoint correction

 4 CFC_FC111\DOSE.L_START FALSE Dosing stopped

 5 CFC_FC111\INT_P.TRACK TRUE Track integrator

 6 CFC_LI111\INT_P.TRACK TRUE Track integrator

 7 CFC_NK111\VALVE.AUT_ON_OP Auto Valve in automatic mode

 8 CFC_NK112\VALVE.AUT_ON_OP Auto Valve in automatic mode

 9 CFC_NK113\VALVE.AUT_ON_OP Auto Valve in automatic mode

 10 CFC_NK114\VALVE.AUT_ON_OP Auto Valve in automatic mode

 11 CFC_NP111\MOTOR.AUT_ON_OP Auto Motor in automatic mode

 12 CFC_LI111\INT_P.HOLD FALSE Hold output value

11. Click the "Apply" button.

12. Click on the arrow button to change to the other steps and enter the addresses
according to the tables.

Note

When entering the addresses (operands), check whether you have selected the
required step based on the title bar of the "Properties" dialog box.

If you have accidentally closed the "Properties" dialog box, double-click on the
step you are currently editing to open the dialog box.

- INIT_LINE1

- INIT_LINE2

- INIT_DOSE

- SLOW_DOWN

- CLOSE_LINE

- END
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5.3.1.1 Parameters for the 'INIT_LINE1' Step

The following table shows the parameters for the "INIT_LINE1" step:

 Cont. No.  Address 1  Address 2  Meaning

 1 CFC_NK111\VALVE.AUTO_OC TRUE Open valve

 2 CFC_NK112\ VALVE.AUTO_OC TRUE Open valve

 3 CFC_NK113\ VALVE.AUTO_OC TRUE Open valve

 4 CFC_NP111\MOTOR.AUTO_ON TRUE Turn on motor

5.3.1.2 Parameters for the 'INIT_LINE2' Step

The following table shows the parameters for the "INIT_LINE2" step:

 Cont. No.  Address 1  Address 2  Meaning

 1 CFC_NK111\VALVE.AUTO_OC TRUE Open valve

 2 CFC_NK112\VALVE.AUTO_OC TRUE Open valve

 3 CFC_NK114\VALVE.AUTO_OC TRUE Open valve

 4 CFC_NP111\MOTOR.AUTO_ON TRUE Turn on motor

5.3.1.3 Parameters for the 'INIT_DOSE' Step

The following table shows the parameters for the "INIT_DOSE" step:

 Cont. No.  Address 1  Address 2  Meaning

 1 CFC_FC111\CTRL_PID.SP_EXT CFC_SETP\PARA
_DOS_RM1_QTY.V

Active setpoint for flow
control

 2 CFC_FC111\CTRL_PID.AUT_L TRUE Controller automatic mode

 3 CFC_FC111\DOSE.SP_EXT CFC_SETP\PARA
_DOS_RM1_VOL.V

Active setpoint for dosing
volume

 4 CFC_FC111\DOSE.L_START TRUE Start dosing

 5 CFC_FC111\INT_P.TRACK FALSE Integrator after setpoint
correction

 6 CFC_FC111\INPUT_U.SIM_V 50.0 Simulation: Flow 50
liters/min simulated!

 7 CFC_FC111\INPUT_U.SUBS_V 50.0 Substitute value for the
simulation value SIM_V

 8 CFC_LI111\INT_P.TRACK FALSE No correction for integrator

Setting the Run Time

1. Change to the "General" tab.

2. Enter the value "8s" in the "Minimum" in the box of the "Run times" area.

3. Click on the "Apply" button
PCS 7 automatically changes the value to "T#8s".
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5.3.1.4 Parameters for the 'SLOW_DOWN' Step

The following table shows the parameters for the "SLOW_DOWN" step:

 Cont. No.  Address 1  Address 2  Meaning

 1 CFC_FC111\CTRL_PID.SP_EXT 10.0 Reduction of the flow
setpoint

 2 CFC_FC111\INPUT_U.SIM_V 10.0 Simulation: Flow
10 liters/min simulated!

 3 CFC_FC111\INPUT_U.SUBS_V 10.0 Substitute value for the
simulation value SIM_V

5.3.1.5 Parameters for the 'CLOSE_LINE' Step

The following table shows the parameters for the "CLOSE_LINE" step:

 Cont. No.  Address 1  Address 2  Meaning

 1 CFC_NK111\VALVE.AUTO_OC FALSE Close valve
 2 CFC_NK112\VALVE.AUTO_OC FALSE Close valve
 3 CFC_NK113\VALVE.AUTO_OC FALSE Close valve
 4 CFC_NK114\VALVE.AUTO_OC FALSE Close valve
 5 CFC_NP111\MOTOR.AUTO_ON FALSE Turn off motor
 6 CFC_FC111\CTRL_PID.LMN_SEL TRUE Correct manipulated variable

to 0
(close valve)

 7 CFC_FC111\CTRL_PID.SP_EXT 0.0 Active setpoint for flow
control

 8 CFC_FC111\CTRL_PID.AUT_L FALSE Controller manual mode
 9 CFC_FC111\DOSE.L_START FALSE Dosing stopped
 10 CFC_FC111\ INPUT_U.SIM_V 0.0 Simulation: Flow

0 liters/ min simulated
 11 CFC_FC111\INPUT_U.SUBS_V 0.0 Substitute value for the

simulation value SIM_V
 12 CFC_LI111\INT_P.HOLD TRUE Track integrator

5.3.1.6 Parameters for the 'END' Step

The following table shows the parameters for the "END" step:

 Cont. No.  Address 1  Address 2  Meaning

 1 CFC_FC111\CTRL_PID.AUT_L FALSE Reset input
 2 CFC_FC111\CTRL_PID.LMN_SEL FALSE No correction of manipulated

variable
 3 CFC_NK111\VALVE.AUTO_OC FALSE Close valve
 4 CFC_NK112\VALVE.AUTO_OC FALSE Close valve
 5 CFC_NK113\VALVE.AUTO_OC FALSE Close valve
 6 CFC_NK114\VALVE.AUTO_OC FALSE Close valve
 7 CFC_NP111\MOTOR.AUTO_ON FALSE Turn off motor
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5.3.2 How to Assign Parameter Values to the Transitions of the
SFC Chart

A transition contains the conditions according to which a sequential control system
passes control from one step to the next. In principle, you assign parameter values
for the transitions in the same way as for the steps.

Ready to Start?

• The "SFC_RMT1" SFC chart is open in the SFC Editor

• You have adapted the default names of the steps and transitions

Follow the steps outlined below...

1. Double-click on the "DOSE_REA1" transition.
The "Properties" dialog box opens and the "General" tab is active.

2. Select the "Condition" tab.
This tab displays an empty list with statement rows and the mouse pointer is
positioned in the left column of the first row. The layout of the dialog box is the
same as you saw when the assigning parameter values for the steps.

3. Set all the parameter values for the "DOSE_REA1" transition. You will find the
information you require in the following table. Below you can see an overview
of the steps as a reminder:

- For address 1, open the "Browse" dialog box by clicking the "Browse"
button and selecting the relevant I/O

- Enter address 2

- Apply your settings

- Select a new line

- etc.

4. Select a new transition and enter the addresses.

Notes

When entering the addresses (operands), check whether you have selected the
required transition based on the title bar of the "Properties" dialog box.

Just as with the parameters for the steps, the addresses in the table are specified
in the following format:

[chartname\block\I/O].

The plant hierarchy is omitted.
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Parameters for the "DOSE_REA1" Transition

 Cont. No.  Address 1  Operator  Address 2  Meaning

 1 CFC_SETP\PARA_DOS_RM1_SEL.Q0 = FALSE Dosing in reactor 1?
 2 CFC_SETP\PARA_DOS_RM1_VOL.V > 0.0 Dosing volume higher than 0 ?

Parameters for the "INIT_1_OK" Transition

 Cont. No.  Address 1b  Operator  Address 2  Meaning

 1 CFC_NP111\MOTOR.QRUN = TRUE Motor on?
 2 CFC_FC111\CTRL_PID.QSPEXTON = TRUE Controller set to external

setpoint?

Parameters for the "INIT_OK" Transition

 Cont. No.  Address 1  Operator  Address 2  Meaning

 1 CFC_FC111\DOSE.QSTRTDOS = TRUE Dosing started ?
 2 CFC_FC111\DOSE.ER < 500.0 Dosing volume:

setpoint – actual value <
500 liters?

Parameters for the "END_DOSE" Transition

 Cont. No.  Address 1  Operator  Address 2  Meaning

 1 CFC_FC111\DOSE.QEND_DOS = TRUE Dosing ended ?

Parameters for the "CLOSE_OK" Transition

 Cont. No.  Address 1  Operator  Address 2  Meaning

 1 CFC_NP111\MOTOR.QRUN = FALSE Motor off?

Parameters for the "INIT_2_OK" Transition

 Cont. No.  Address 1  Operator  Address 2  Meaning

 1 CFC_NP111\MOTOR.QRUN = TRUE Motor on?
 2 CFC_FC111\CTRL_PID.QSPEXTON = TRUE Controller set to external

setpoint?

Parameters for the "DOSE_REA2" Transition

 Cont. No.  Address 1  Operator  Address 2  Meaning

 1 CFC_SETP\PARA_DOS_RM1_SEL.Q0 = TRUE Dosing in reactor 2?
 2 CFC_SETP\PARA_DOS_RM1_VOL.V > 0.0 Dosing volume higher than 0 ?
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5.4 The Current Status of Your Project...

What have you learnt during configuration in SFC?

• You have worked with standard functions such as renaming and opening.

• You have created a sequential control system with graphic support.

• You have renamed and assigned parameter values to the steps and transitions
of the sequential control system.
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6 Compiling, Downloading, and Testing the
Charts

6.1 Overview of Compiling, Downloading, and Testing

This tutorial explains how you compile the program you have created with CFC and
SFC, download it to the CPU and run it in the test mode. This gives you the
opportunity of checking the correct functionality of the charts. You already got to
know the "Download" function when you downloaded the hardware configuration.

You now have two steps to perform with the charts:

• First you will compile and download the blocks and charts – for this task use
the "Compile and Download Objects" function.

• You will then test the program – you can test both in the SFC Editor and in the
CFC Editor.

6.1.1 How to Compile and Download CFC and SFC Charts

You have already created the CFC and SFC charts for your "color_gs" project.
These charts must be compiled into a language so that they can execute on a
CPU. Obviously they must also be downloaded to the CPU so that the CPU can
run the program. The compilation and download are started in a common dialog
box and run one after the other.

Ready to Start?

• Green "RUN" LED on the CP is lit

• CPU is in STOP

• The "color_gs" project is open in the SIMATIC Manager

• The component view is activated
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Follow the steps outlined below...

1. Select the following folder in the tree structure
"color_gs_MP/ color_gs_Prj/ SIMATIC 400".

2. Select the menu command PLC > Compile and Download Objects.
The "Compile and Download Objects" dialog box opens.

3. Click on "+" to expand the tree structure.
The "color_gs" project is displayed with a structure basically the same as in the
component view of the SIMATIC Manager.
You will see the individual objects and relevant information on the status or
operating state:

 Object  Status  Operating state

CPU 417-4 – STOP
Sources – –
Blocks – –
Charts modified –
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4. For the "Charts" object, check the "Compile" and "Download" check boxes.

5. Select the "Charts" entry and click on the "Edit..." button under "Settings for
Compilation/Download".
The "Compile program / download to target system" dialog box opens and the
"Compile Charts as Program" tab is active. The "Entire program" check box is
automatically activated since you are starting the compilation and download for
the first time.

Note

If you find errors in your program when you test it, you will have to make changes
to your CFC or SFC charts to eliminate the problem. When you restart compilation
and downloading afterwards, make sure that you activate the "Changes only"
check box. This will save you a considerable amount of time when compiling and
downloading. Selecting this option also means that you can down load the
changes without needing to stop the CPU.

6. Make sure that the following check boxes are activated:

- Update sampling time – With this option, prior to compiling, the system
checks to find out the OB in which the relevant block is installed and
makes the appropriate entry at the "SAMPLE_T" input. "SAMPLE_T"
corresponds to the sampling time of the block in seconds.

- Delete empty run-time groups – This option deletes or empty run-time
groups that might exist in the S7 program.



Compiling, Downloading, and Testing the Charts

Process Control System PCS 7, Getting Started - Part 1
6-4 A5E00164244-01

7. Click the "OK" button to enter your settings.
The dialog closes and the message box " Remember that if you download later
(...), the blocks in the CPU will be deleted " opens.

8. Click the "OK" button.

9. Check the settings in the following check boxes:

 Check box  Setting

Compile only deactivated

Do not load if compilation error is detected activated

10. Click on the "Start" button to start the compilation and download.
The message box "Please make sure the settings for downloading changes
are correctly selected for all the objects to be downloaded ... Do you want to
continue?" opens.

11. Click the "yes" button.

Note

The progress display indicates exactly what PCS 7 is currently doing, for
example: 

• "Compiling and downloading object"

• "Compiling charts as program"

When this is completed, the log file opens to show you whether or not the
compilation and download was error-free.

The status in the "Charts" row is now "downloaded".

12. Click the "Cancel" button.
The dialog box is closed.

13. Start the CPU.
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6.2 Testing the Program

You can test both in the SFC Editor and in the CFC Editor. In the test mode, you
can watch how the values change during the course of the process. Using the test
mode, you can make sure that your configured sequential control system runs free
of errors.

Test Mode in SFC

The test is made in the SFC Editor that you already got to know when you created
the SFC chart: The "Properties" dialog box that you have already seen also plays a
central role in the test mode.

If you double-click on a step or a transition in the SFC chart, the "Properties" dialog
box opens – this is familiar territory. Just as during creation of the SFC charts, you
can use the arrow buttons to change from one step or transition to the next. In the
test mode, the dialog boxes also provide additional information:

• In the properties dialog of a step, you see the actual values on the left beside
address  1 and the setpoints to the right beside address 2.

• In the properties dialog of a transition the current values are displayed to the
left of address 1 and to the right of address 2.

Caution

You can modify all values in the white fields. Remember, however, that these
values are written directly into your configuration data and therefore change the
parameters of your SFC chart.

While working through Getting Started, you will not change any values here and
will simply use the "Properties" dialog boxes to monitor the values.

Test Mode in CFC

You start the test mode in CFC in the CFC Editor. You will be able to display
process values at the individual block I/Os and to monitor the changes.
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6.2.1 How to Test the Program in the SFC Editor

After you have compiled and downloaded the program, you can run the program in
the test mode to check whether the sequential control system works properly and
whether the program runs correctly.

Ready to Start?

• The "color_gs" project is open in the SIMATIC Manager

• The "SFC_RMT1" SFC chart is open in the SFC Editor

Working in the Test Mode

1. Select the menu command Debug > Test Mode.
The Test mode is activated.

- In the title bar of the SFC Editor, the name "SFC_RMT1 –
color_gs_Prj\Plant1\RMT1 ONLINE" is shown on a colored background.

- In the lower part of the SFC editor, you will see the status of the program,
the mode, and the step control mode. As default, the mode is set to
"MANUAL". The current step control mode is displayed in the drop-down
list box and as default is set to "T".

- In the lower part of the SFC Editor, there are also buttons for controlling
the SFC chart, for example start, hold, resume.

2. Select the menu command Debug > Step Control Mode > T or C.
In this step control mode, an additional button "C" is displayed beside the
transition while the SFC chart is running:

 If the chart…  … the sequential control system will do the following:

is free of errors The sequential control system will be executed according to the
configured parameters. You do not need the button.

contains errors The sequential control system stops when the transition is not
satisfied. You can click the "C" button to pass control to the next
step regardless of whether the transition is satisfied.

3. Click on the "Start" button to start the program.
The SFC chart is started.

- Each step that is currently being executed is light green with a small arrow
pointing down next to the step.

- Steps that have already been processed are displayed in dark green and
have a small check mark beside them.

- Transitions that are active but not yet satisfied are shown on a brown
background.
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If you created your configuration correctly, the entire SFC chart will execute to the
end and all steps will turn dark green and have a check mark beside them.
Otherwise, you can click the "C" button to pass control to the next step manually
although the transition is not satisfied.

4. Select the menu command Debug > Test Mode.
This stops the Test mode.

6.2.2 How to Test the Program in the CFC Editor

You can test CFC charts in the CFC Editor in just the same way as SFC charts.

Ready to Start?

• The "color_gs" project is open in the SIMATIC Manager

• The "SFC_RMT1" SFC chart is open in the SFC Editor and the Test mode is
active

• The "CFC_FC111" CFC chart is open in the CFC Editor

Follow the steps outlined below...

1. Select the menu command Debug > Test Mode.
The Test mode is activated.

2. Press the "CTRL" key and select the following blocks:

- CTRL_PID

- INPUT_U

- DOSE

3. Select the menu command Debug > Watch On.
All the block I/Os activated for the test mode in the properties of the block are
then shown on a yellow background.

4. Change to the "SFC_RMT1" SFC chart.

5. Click on the "Start" button in the toolbar.
This starts the program.

6. Change to the "CFC_FC111" CFC chart.
You can then watch the values change: for example, the current value of the
dosed volume is displayed at the "PV_OUT" output of the "DOSE" block.

Note

Arrange the windows one beside the other to be able to watch the CFC and the
SFC chart at the same time in the Test mode.

7. Select the menu command Debug > Test Mode.
This stops the Test mode.
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6.3 Current Status of the Project...

In the meantime, you have completed almost the entire configuration work in the
SIMATIC Manager and in the CFC and SFC Editors. After compiling and
downloading this configuration, you have been able to watch the project execute in
the SFC and CFC Editors.

This allowed you to make sure that your configuration is free of errors up to now. If
you find that your project has errors when it runs in the test mode, it is much easier
to correct at this stage than after the entire project has been completed.
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7 Configuring the Operator Station

7.1 The Operator Station in the Process Mode

The plant operator can control and monitor the process on the operator station in
the process mode. The operator station displays process pictures. The PLC
controls the process and the OS reads the process values from the PLC and
represents the values graphically in the process pictures. Warnings and alarms are
also displayed in the process pictures as soon as certain specified limits are
reached or exceeded. This allows the operator to identify the point at which a
problem occurs in the plant.

You will create one process picture for your "color_gs" project that will allow you to
visualize the level of the raw material container, the status of the valves etc.

7.2 Configuring the Operator Station

The Operator Station in the Project

When you create a project with the "Create New Project" wizard, PCS 7
automatically creates an operator station. You have already configured this
operator station in HW Config. You have not, however, created a network
connection for this OS as you did for communication between the programmable
controller and the engineering system so that you could download the data of the
ES to the PLC. This is not necessary for the "color_gs" project because the
engineering system and the operator station are on the same computer and the
operator station uses the same connection to the PLC as the ES.

The Process Pictures in the Project

The wizard also creates the pictures automatically in the plant hierarchy and you
then configure them in the PCS 7 OS. Larger projects do, of course, have several
process pictures for the various plant sections. For the "color_gs" project, you only
need to configure a single picture. You will nevertheless become familiar with all
the basic functions involved in configuration of the PCS 7 OS. Pictures are
identified by the following icon:
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7.3 Working in the SIMATIC Manager

7.3.1 Preparations in the SIMATIC Manager

Before you can start to configure in the PCS 7 OS, there are a few preliminary jobs
to be done in the SIMATIC Manager:

• Adapting picture names and activating the function for creating block icons

• Deleting unnecessary pictures

• Creating block icons

• Compiling the OS

Editing the Picture Properties

Since the "Create New Project" wizard has already created pictures, these
pictures, just like the CFC chart, have default names. You must first adapt these
default names to suit your project by assigning self-explanatory short names to
them.

You must also activate the function for creating block icons.

Deleting Unnecessary Pictures

When you create a project with the wizard, pictures are automatically inserted in
every hierarchy folder of the plant hierarchy. Since you only require one picture in
your "color_gs" project, you must remove the unnecessary pictures from the PH.

Creating Block Icons

PCS 7 provides you with an excellent function: "Create block icons": Block icons
are inserted in process pictures and provide the operator with the most important
information on a process tag at a glance. For example, in the block icon for a
controller, the operator sees the process value (PV), the setpoint (SP) and the
manipulated value (OUT). The block icon for a controller is displayed in a process
picture as shown below:
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Compiling the OS

You run the "Compile OS" function once you have completed configuration of all
data in the SIMATIC Manager and before you start to configure the OS data of the
PCS 7 OS. All the data from the SIMATIC Manager, such as variables, messages,
texts and the hardware and connection configuration must be "made known" to the
OS.

Starting the OS

To continue configuration of the PCS 7 OS, you must start the OS so that you can
continue working in the WinCC Explorer.

7.3.1.1 How to Edit Picture Properties

When you edit the picture properties, you make two settings:

• Change the name of the picture

• Activate the option for creating block icons

Ready to Start?

• The "color_gs" multiproject is open in the SIMATIC Manager

• The plant view is activated

Change the name of the picture

1. Select the following folder in the tree structure
"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1".

2. Select the picture "Picture(3)" in the detailed window.

3. Select the menu command Edit > Object Properties.
The "Properties – WinCC Picture(3)" dialog box opens and the "General" tab is
active.
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4. Change the default name "Picture(3)" to "RMT1" in the "Name" box.

5. Click the "Apply" button to enter your settings.

Activate the option for creating block icons

1. Change to the "Block Icons" tab.

2. Select the "Base block icons on the plant hierarchy" check box.

3. Click the "OK" button to enter your settings.
The dialog box is closed and the new name of the picture is displayed in the
plant hierarchy.
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7.3.1.2 How to Delete Unnecessary Pictures

The PCS 7 "Create New Project" wizard creates a picture in every hierarchy folder.
In the "color_gs" project, you require only one picture since all the required data
can be represented clearly in one picture.

Ready to Start?

• The "color_gs" multiproject is open in the SIMATIC Manager

• The plant view is activated

Follow the steps outlined below...

1. Select the "Plant1" folder in the tree structure.

2. Select the picture "Picture(2)" in the detailed window.

3. Press the "Del" key.
The "Delete" dialog box opens.

4. Click the "yes" button.
The picture is deleted.

5. Repeat steps  1 through 4 for the following folders in the plant hierarchy:

 Name of the Folder  Name of the Picture

FC111 Picture(4)

ADDIT Picture(5)
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7.3.1.3 How to Create Block Icons

Ready to Start?

• The "color_gs" multiproject is open in the SIMATIC Manager

• The plant view is activated

• The option for creating block icons is activated

For more detailed information on these settings, refer to "Configuring the Operator
Station – Working in the SIMATIC Manager – How to Edit Picture Properties" in
section "Activate the option for creating block icons".

Follow the steps outlined below...

1. Select the following folder in the tree structure
"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1".

2. Select the menu command Options > Plant Hierarchy > Create/Update
Block Icons…
The "Create/Update Block Icons" dialog box opens. The picture for which the
block icons will be created "Plant1\RMT1\RMT1" is displayed in the list.
The value "1" is entered in the "Lower hierarchy levels included" drop-down list
box.
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3. Click the "OK" button.
This starts creation of the block icons.
A message window opens informing you that you will need to compile the
operator stations involved. "Do you want to see the log of the function?"

4. Click the "No" button.
The message window is closed and creation of the block icons is completed.

At present, you will not see any visible results of this function. When, however, you
open the process picture for the "color_gs" project, you will see the block icons that
were created.

7.3.1.4 How to Compile the OS

Before you start to configure the data on the PCS 7 OS, you must first compile the
OS. With this function, all the data from the SIMATIC Manager, such as variables,
messages, texts and the hardware and connection configuration is "made known"
to the OS. Do not confuse compiling with downloading: When you compile, the
data remains on the computer in the engineering system – it is simply made known
to the PCS 7 OS so that you can access this data during configuration.

Ready to Start?

• The "color_gs" multiproject is open in the SIMATIC Manager

• The component view is activated
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Follow the steps outlined below...

1. Go to the tree structure and select the entry
"color_gs_MP/ color_gs_Prj/ SIMATIC PC Station(1)".

2. Select the menu command Options > OS > Compile…
The first step of the "Compile OS" wizard is opened. Below, you will find a brief
overview of the steps.

3. In step 1, click the "Next" button.
The step "Which operator stations do you want to compile and with which S7
programs?" opens.
Under "Operator stations and S7 programs", you will see all operator stations
and S7 programs that belong to your project. The objects "OS(1)" and "S7
Program(1)" belong to your project and are activated already as default. In the
area "Network connection for OS(1)", you will find the entry "S7 Program(1)"
and the subnet "Ethernet(1)": This is the connection via which the
programmable controller and operator station communicate and that you
already created for your CP in HW Config.

4. If a different connection is displayed here, click on the "Connection..." button,
select the Ethernet connection you created for your CP in HW Config in the
"Select Network Connection" dialog and then click "OK".
The dialog box closes and you return to the wizard. In the wizard, the
connection you have selected is displayed under "Network connection for
OS(1)".
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5. Click the "Next" button.
The "Select the data you want to compile and the scope of the compilation"
step opens. The following check boxes are activated as default when you
compile for the first time:

 Area  Check Box

"Data" • "Tags and Messages"

• "Picture Tree"

"Scope" • "Entire OS"

• "With memory reset"

6. Under "Data", activate the "SFC Visualization" check box.

7. Click the "Next" button.
The last step of the wizard "Check the selected options" opens and shows you
a summary of the settings you have made.
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8. Click the "Compile" button.
Compilation is started and a progress bar is displayed.
After compilation, a message window is displayed: "The compilation was
completed without errors and warnings".

9. Click the "OK" button.
This completes your compilation.
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7.3.1.5 How to Start the PCS 7 OS

You have now completed all the preparations for configuring the PCS 7 OS in the
SIMATIC Manager and you can now start to configure the PCS 7 OS. You start by
opening the PCS 7 OS.

Ready to Start?

• The "color_gs" project is open in the SIMATIC Manager

• The component view is activated

Follow the steps outlined below:

1. Select the following object in the tree structure
"color_gs_MP/ color_gs_Prj/ SIMATIC PC-Station/ WinCC Application/ OS(1)".

2. Select the menu command Edit > Open Object.
The PCS 7 OS – WinCC Explorer is opened.
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7.4 Working on the PCS 7 OS

7.4.1 Structure of the PCS 7 OS - WinCC Explorer

The WinCC Explorer provides you with a series of editors that you can use to
configure a PCS 7 OS. But don't worry! – to configure the PCS 7 OS, we only need
to use some of these editors.

How is the WinCC Explorer Structured?

In principle, the structure of the WinCC Explorer is very similar to the Windows
Explorer:

• In the left pane, there is a navigation window: Here you find all the editors that
you can use to configure the PCS 7 OS.

• In the right pane, there is a detailed window in which detailed information on
the entry selected in the navigation window is displayed.

In the "color_gs" project, we will work solely with the Graphics Designer. This is the
tool you use to create process pictures. You do not require any other editors to
configure the PCS 7 OS.

7.4.2 The Function of Process Pictures

Overview

Process pictures represent the plant equipment for the operator. Here, the operator
can enter commands and display plant statuses.

The process picture you will create for the "color_gs" project already exists in the
SIMATIC Manager in the plant hierarchy.

In the "Graphics Designer" editor, you will edit this process picture; in other
words, you will insert the required static and dynamic objects and interconnect
them.
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7.5 General Aspects of Working with the Graphics Designer

7.5.1 Introduction to the Graphics Designer

User Interface

The Graphics Designer is an editor for the PCS 7 OS. The user interface of the
Graphics Designer is structured as follows:

• On the left-hand side, you will see a Color Palette with which you can assign
colors to the objects.

• In the middle, you have the file window or drawing board on which you insert
the objects for the process picture.

• On the right-hand side, you will see the Object Palette. This is the library with
the various standard objects provided by the Graphics Designer. You will also
see a Style Palette on the right-hand side with which you can format the
objects.

Libraries

The libraries of the Graphics Designer contain a wide selection of ready-to-use
graphic elements such as piping and valves. You can modify these elements or
add to them and store them in your own project libraries so that they are available
to you at any time.

Objects

The Graphics Designer distinguishes between two different types of objects:

• Static objects – these objects are purely drawing objects as you would find in a
drawing program, for example lines, circles, polygons, static text etc.

• Dynamic objects – these objects are made dynamic due to a connection to a
block I/O or variable; in other words, these objects always show the current
values of a tag in the plant in the process mode. In the "color_gs" project, you
will get to know various dynamic objects.
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7.5.1.1 How to Open a Process Picture

The process picture is edited in PCS 7 OS. The editor used is the "Graphics
Designer".

Ready to Start?

The "color_gs" project is open in the WinCC Explorer

Follow the steps outlined below...

1. In the navigation window, select the "Graphics Designer" entry.
The detailed window displays all the pictures belonging to the project. All the
default pictures and template pictures provided by PCS 7 are, of course, also
displayed. These can be identified by the preceding "@" character.

2. Select the picture "RMT1.pdl" in the detailed window.

3. Double-click the picture "RMT1".
The process picture is opened in the Graphics Designer.
Here, you can see that there are already objects in this process picture,
although you yourself have not yet inserted any objects. These are the block
icons that you created in the process picture with the "Create block icons"
function in the SIMATIC Manager. You can also see that the block icon for the
valve has been inserted aligned both horizontally and vertically. These two
versions are influenced by the setting of the process object view in the "Picture
Objects" tab that you made when assigning parameter values to the CFC
charts.
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7.5.1.2 How to Open the Various Toolbars

As default, the most important toolbars and palettes are open and you do not need
to change the settings. If you accidentally close toolbars or palettes, you should
know how to make them visible again.

Ready to Start?

The picture is opened in the Graphics Designer.

Follow the steps outlined below...

1. Select the menu command View > Toolbars.
The "Toolbars" dialog box opens. Here, you see all the toolbars provided by
the Graphics Designer.

2. Make the same settings as shown in the screenshot of the dialog box:

3. Click the "OK" button to enter your settings.
The toolbars and object palettes you have selected will be displayed.

The "Objects" check box is important – you use this to open the object palette from
which you take all the static and dynamic objects you require to create the process
picture. The object palette contains to tabs: "Standard" and "Controls". In Getting
Started, will only use the "Standard" tab.
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7.5.2 The Objects in the Graphics Designer

However, before you get started with the actual configuration and work in the
Graphics Designer, it is time for a little theory relating to the various objects that
you will use to create the "RMT1.pdl" process picture. These objects include the
following:

• Static objects

• Text fields

• I/O fields

You also need a certain amount of background information on interconnecting tags
– this is the way you create the relationship between the process picture and the
tag.

7.5.3 What Are Static Objects?

To visualize a plant, you require a lot of static objects, for example, to represent a
pipe or a tank. These objects do not change during the process mode; in other
words, they are not influenced by the status or by a value of a tag.

7.5.4 What Are Text Fields?

In a text field, you can enter any information that you want the operator to see in
the process picture. You can, for example, insert a text field to allow you to label
objects and to simplify the assignment of the picture objects to the process for the
operator. You can enter any text in these text fields and can position the text fields
anywhere in the document.

For the "color_gs" project, you will insert text fields for all the tags and label them.

7.5.5 What Are I/O Fields?

Input/output fields are used to input or output values. There are different versions
of I/O fields:

• Pure output field

• Pure input field

• Combined input and output field

I/O fields can process different data formats, such as binary, decimal, string,
hexadecimal.

Just as for all other objects, you can also select different formats and make
different settings for I/O fields.

In the "color_gs" project, you will use an I/O field to control dosing either in
reactor 1 or 2.
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7.5.6 How Does Tag Interconnection Work?

The interconnection with tags is a central function when you create process
pictures: Objects are entered in the process picture that represent the process
values of a measuring point (tag) in the process mode. By interconnecting with a
variable, you create the connection between the object and the actual measuring
point. This allows the OS to receive or read out data from the PLC and to display
and update this data in the process picture.

7.6 Creating the Process Picture

7.6.1 How to Insert Pipes and a Tank for the Process Picture

Ready to Start?

• The "RMT1" picture is opened in the Graphics Designer.

• Block icons exist
Initially, you will not make any modifications to the block icons. You must first
create a picture of the plant with static objects before you can move the icons
to the positions where they require information.

Follow the steps outlined below...

1. Select the menu command View > Library.
This opens the libraries of PCS 7 OS.

2. Select the object "Global Library/PlantElements/Tanks/Tank4" and drag it to
the drawing board.

Note

Click on the "glasses" button in the toolbar to obtain a preview of the graphic
objects.
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3. Then drag the following objects to the drawing board:

 Name of the Object  Number  Path in the Library

Pipe horizontal  2 x Global Library/PlantElements/Pipes - Smart
Objects/3D Pipe Horizontal

Pipe vertical  5 x Global Library/PlantElements/Pipes - Smart
Objects/3D Pipe Vertical

Angle  1 x Global Library/PlantElements/Pipes - Smart
Objects/3D Pipe Elbow 1

Angle  1 x Global Library/PlantElements/Pipes - Smart
Objects/3D Pipe Elbow 2

Angle  1 x Global Library/PlantElements/Pipes - Smart
Objects/3D Pipe Elbow 3

Angle  1 x Global Library/PlantElements/Pipes - Smart
Objects/3D Pipe Elbow 4

Control valve  1 x Global Library/Symbols/Valves/30

Tanks representing
the reactors

 2 x Global Library/Siemens HMI Symbol
Library/Tanks/Tank1

4. Close the library.
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5. Select an object and adapt its size and position to match the following picture:

- You can move the object by positioning the mouse pointer on the object,
holding down the mouse button and dragging the object to the required
location.

- You can increase or decrease the size of the object by positioning the
mouse pointer on the corner handles of the object, holding down the
mouse button, and dragging to make the object larger or smaller.
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7.6.2 Labeling the Various Pieces of Equipment

Labeling the equipment requires three steps:

 Step  What?

Step 1 Inserting and formatting a text field

Step 2 Making further settings

Step 3 Duplicating the text field

7.6.2.1 Step 1 - How to Insert a Text Field

Ready to Start?

• The "RMT1.pdl" picture is opened in the Graphics Designer.

• The static objects have been inserted

Follow the steps outlined below...

1. Select the entry "Standard Objects/Static Text" in the Object Palette.

2. Move the mouse pointer to the drawing board.
The mouse pointer changes to a small text input symbol.

3. Open a text box under the left reactor.
A rectangle is inserted and the text in the rectangle is already selected.

4. Change this text to "Reactor 1".

5. Press the Enter key to enter the text.

6. Now format the text field using the Style Palette:

- Click on the "Line Weight/Invisible" entry.
The frame of the text field is then invisible.

- Click on the "Fill Pattern/Transparent" entry.
The color of the text field is then transparent.
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7.6.2.2 Step 2 - How to Set the Text Field

Ready to Start?

• The "RMT1.pdl" picture is opened in the Graphics Designer.

• You have inserted a text field

Follow the steps outlined below...

1. Select the menu command View > Properties.
The "Object Properties" dialog box opens and the "Properties" tab is active.

2. Select the entry "Static Text" in the tree structure in which the properties input
field is located.
In the detailed window, you will see the name of the text field and the level.

3. Change to the detailed window and double-click on the "Static Text 1" field in
the "Static" column.
You can now edit the field.

4. Enter the name "Reactor 1" and press the Enter key.
This enters the name which is then displayed in the top box. When you work
on the drawing board, this name will be displayed as a tooltip whenever you
move the mouse pointer over the object.

5. Select the "Static Text/Font" entry in the tree structure.

6. Change to the detailed window and double-click on the "No" field of the "Bold"
attribute.
The value changes from "No" to "Yes" and the text changes to bold print.

7. Close the "Object Properties" dialog box.
All the changes you have made are displayed.
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7.6.2.3 Step 3 - How to Duplicate the Text Field

Ready to Start?

• The "RMT1.pdl" picture is opened in the Graphics Designer.

• You have inserted a text field

• You have made the settings for text fields

Follow the steps outlined below...

To avoid having to repeat all the settings you made for the first text field, you can
duplicate an existing text field and simply overwrite the existing text.

1. If the text field is no longer selected, select it and select the menu command
Edit > Duplicate.
The text field is duplicated.

2. Double-click on the text field and change the text to "Reactor 2".
All other formatting is automatically included because you duplicated the field.

3. Select the menu command View > Properties.

4. Change the object name to "reactor2" in the detailed window.

5. Position the text field below the object.

6. Repeat steps 1 through 6 to create the text fields for the following tags and
adapt the object names to reflect the name of the tag:

- LI111

- NK111

- NK112

- NK113

- NK114

- NP111

- FC111

7. Select the menu command File > Save.
This saves the process picture.
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7.6.3 Current Status of the Process Picture...

Now that you have inserted the tank, the pipes, and the labeling, your process
picture should look like the one below:
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7.6.3.1 How to Connect the Raw Material Tank with the Process Value

The tank you inserted in your picture represents the raw material tank. You now
connect this tank with the relevant block to be able to display the current fill level of
the raw material tank in the process mode.

Ready to Start?

• The "RMT1.pdl" picture is opened in the Graphics Designer.

• The static objects have been inserted

Follow the steps outlined below...

1. Select the "Tank4" object.

2. Select the menu command View > Properties.
The "Object Properties" dialog box opens and the "Properties" tab is active.

3. Select the "Tank4" entry in the tree structure.
In the detailed window, you will see the name of the text field and the level.

4. Change to the detailed window and double-click on the "Tank4" field in the
"Static" column.
You can now edit the field.

5. Enter the name "Raw material tank1" and press the Enter key.
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6. Select the entry "Tank4/ Tag Assignment" in the tree structure.

7. Change to the detailed window and position mouse pointer on the "lightbulb"
symbol of the "Fill Level" attribute and open the context-sensitive menu.

8. Select the menu command Tag...
The tag selection dialog opens.

9. Activate the "ES Variables" check box as the "Data source".
The ES variables are displayed in the tree structure.

10. Select the following entry in the tree structure
"ES Variables/ Plant1/ RMT1/ LI111/CFC_LI111/ LIA".
All the variables are then displayed in the detailed window.

11. Select the "U" variable in the detailed window:
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12. Click the "OK" button.
As a result, the variable and its entire path are entered in the "Dynamic"
column.

13. Position the mouse pointer on the "lightbulb" symbol of the "Maximum Value",
open the context-sensitive menu and select the Delete menu command.
The default variable is deleted and the default value "100" becomes active.

14. Do the same for "Minimum Value" attribute.

15. Close the "Object Properties" dialog box.

16. Select the menu command File > Save.
This saves the process picture.

7.6.3.2 How to Adapt the Block Icons

There are already block icons in your process picture that were inserted in the
SIMATIC Manager using the "Create/Update Block Icons" function. If you take a
look at the block icons, you will see that PCS 7 has automatically generated block
icons in the horizontal and vertical directions due to the settings for the block in the
CFC chart.

These block icons must now be positioned and certain specific settings made for
the "color_gs" project.
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Ready to Start?

• The "RMT1.pdl" picture is opened in the Graphics Designer.

• The block icons exist

Positioning Block Icons in the Plant Representation

1. Select the block icon "..._NK111/VALVE" and drag it with the mouse to the
required position so that the valve shown in the block icon is exactly between
the pipes.

2. Select the menu command View > Properties.
The "Object Properties" dialog box opens.

3. Select the entry "Styles" in the tree structure in which the properties of the
block icon are located.
Various attributes are then displayed in the detailed window.

4. Change to the detailed window and double-click on the "Yes" field of the
"View_Tag" attribute.
The value changes to "No".

5. Close the Object Properties.
The settings you have made here will only become visible when you change
the project to the process mode.
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6. Repeat steps 1 through 5 for all block icons according to the list below:

- "..._NK111/VALVE"

- "..._NP111/MOTOR"

- "..._NK112/VALVE"

- "..._NK113/VALVE"

- "..._NK114/VALVE"

Your process picture should now appear as shown below:
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7.6.4 Inserting Input/Output Fields for Operator Control

You will provide two methods of operator control in your process picture:

• Reactor selection

• External/internal setpoint

Start with the configuration for selecting the reactor – this involves three steps.
Afterwards, you follow practically the same procedure to configure setpoints:

 Step  What?

Step 1 Insert I/O field

Step 2 Format I/O field

Step 3 Enter explanatory text

Step 4 Configure setpoint assignment

7.6.4.1 Step 1 - How to Insert the I/O Field

Ready to Start?

• The "RMT1.pdl" picture is opened in the Graphics Designer.

• The object palette is visible

• The style palette is visible

Follow the steps outlined below...

1. Select the "Smart Objects/I/O Field" in the object palette.

2. Move the mouse pointer to the drawing board.
The mouse pointer changes to a small I/O field symbol.

3. Open a rectangle between the reactors holding down the mouser button. The
size of the rectangle is the size that your I/O field will have.
The "I/O-Field Configuration" dialog opens.

4. Click on the "Tag selection dialog" button beside the "Tag" box".
This opens the "Tags – Project" dialog box.

5. Activate the "ES Variables" check box as the "Data source".
The ES variables are displayed in the tree structure.

6. Select the following entry in the tree structure:
"ES Variables/Plant1/RMT1/FC111/ADDIT/CFC_SETP/
PARA_DOS_RM1_SEL".
All the variables are then displayed in the detailed window.
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7. Select the "I0" variable in the detailed window.

8. Click the "OK" button to enter your settings.
This enters the tag in the "Tag" input field.

9. Make sure that the "Both" check box is activated.

10. Click the "OK" button to enter your settings.
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7.6.4.2 Step 2 - How to Format the I/O Field

Ready to Start?

• The "RMT1.pdl" picture is opened in the Graphics Designer.

• You have inserted the I/O field

Follow the steps outlined below...

In just the same way as you formatted the text fields, you can also format the I/O
fields:

1. Select the I/O field 1.

2. Now format the text field using the Style Palette:

- Click on the "Line Weight/Invisible" entry.
The frame of the text field is then invisible.

- Click on the "Fill Pattern/Transparent" entry.
The color of the text field is then transparent.

3. Select the menu command View > Properties.
The "Object Properties" dialog box opens and the "Properties" tab is active.

4. Select the entry "I/O Field" in the tree structure in which the properties input
field is located.
In the detailed window, you will see the name of the text field and the level.

5. Change to the detailed window and double-click on the "I/OField1" field in the
"Static" column.
You can now edit the field.

6. Enter the name "SEL_REAC" and press the Enter key.
This enters the name which is then displayed in the top box.

7. Select the entry "I/O Field/Font" in the tree structure and change the value of
the "Bold" attribute to "Yes" in the detailed window.

8. Select the entry "I/O Field/Output/Input" in the tree structure and change the
value of the "Data Format" attribute to "Binary" in the detailed window.

9. Close the "Object Properties" dialog box.
All the changes you have made are displayed.
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7.6.4.3 Step 3 - How to Add Explanatory Text

Ready to Start?

• The "RMT1.pdl" picture is opened in the Graphics Designer.

• You have inserted and formatted the I/O field

Follow the steps outlined below...

The operator must, of course, know what can be set with this I/O field. For this
purpose, you can use a text field – you have already used text fields when labeling
the equipment.

1. Insert a text field – use the "Standard Objects/Static Text" object.

2. Enter the following text: "Select reactor: 0 = Reactor 1, 1 = Reactor 2".
Press "Shift + Enter key" to create a line feed.

3. Now format the text field using the Style Palette:

- Frame invisible – setting "Line Weight/Invisible"

- Fill transparent – setting "Fill Pattern/Transparent"

4. Drag a frame round the I/O field and the explanatory text – use the "Standard
Objects/Rectangle" object.

5. Now format the text field using the Style Palette:

- Thickness of the frame – setting "Line Weight/3 Pixel"

- Fill transparent – setting "Fill Pattern/Transparent"

6. Position the object as shown in the picture below:

7. Drag a frame around all the objects.

8. Select the menu command Edit > Group > Group.
All the objects now belong to a group and can be moved easily.

9. Position the object between the reactors.
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7.6.4.4 Step 4 - How to Insert Setpoint Assignment

Follow exactly the same procedure as for the selection between reactor 1 and
reactor 2. Below, you will find an overview of the individual steps:

1. Insert an I/O field and link it to the tag
"Plant1/RMT1/FC111/CFC_FC111/DOSE/SPEXT_ON".

2. Specify the properties for the I/O field in the style palette:

- Frame invisible – style palette setting "Line Weight/Invisible"

- Fill transparent – style palette setting "Fill Pattern/Transparent"

3. Specify the properties for the I/O field in the "Properties" dialog box:

- "I/O Field" property – "Object Name" attribute: "SEL_SP"

- "Font" property – "Bold" attribute: "Yes"

- "Output/Input" property – "Data Format" attribute: "Binary"

4. Insert explanatory text field: "Input setpoint, 0 = internal (operator), 1 = external
(CFC chart)"

5. Format the text field using the Style Palette:

- Frame invisible – setting "Line Weight/Invisible"

- Fill transparent – setting "Fill Pattern/Transparent"

6. Insert a frame – object palette, object "Standard Objects/ Rectangle"

7. Format the frame using the style palette:

- Thickness of the frame – setting "Line Weight/3 Pixel"

- Fill transparent – setting "Fill Pattern/Transparent"

8. Group the objects with the menu command Edit > Group > Group.

9. Position the object at the lower left.
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7.6.4.5 Finishing Touches

1. Position the block icon "..._FC111/CTRL_PID" to the right beside the control
valve "FC111".

2. Insert an arrow between the actuator and the block icon to indicate the
relationship between the measuring point and the block icon.

3. Position the block icon "/CFC_LI111/LIA" to the right beside the raw material
tank.

4. Insert an arrow between the raw material tank and the block icon to indicate
the relationship between the measuring point and the block icon.

5. Position the block icon ".../CFC_FC111/DOSE" to the left beside reactor 1.

6. Position the setpoint selection above the block icon ".../CFC_FC111/DOSE".

7. Position the block icon "...RMT1/SFC_RMT1" in the top left corner.
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Your process picture should now appear as shown below:

8. Select the menu command File > Save.
Your process picture is then saved with all changes and additions.
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7.7 The Current Status of Your Project...

The meantime, your project is completed so that you can activate the process
mode. Which functions have you got to know during the OS configuration?

• Setting the picture properties in the SIMATIC Manager

• Creating block icons

• Compiling the operator station

• Creating a process picture in the Graphics Designer with a variety of objects,
for example static and dynamic objects
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8 Working in the Process Mode

8.1 Introduction to the User Interface

8.1.1 The Operator Station in the Process Mode

In the process mode, the "color_gs" project provides various options for controlling
and monitoring the process.

With the block icons, you have the following options:

• Monitoring the status of the valves: valve open or closed

• Monitoring the status of the pump: pump active or inactive

• Changing from a block icon to the relevant faceplate

With I/O fields, you have the following options:

• Selecting the reactor

• Selecting whether the setpoint is read from the CFC chart or whether the
operator sets the setpoint externally

• Assigning the setpoint for the dosing volume in the faceplate

You can, of course, also monitor the CFC and SFC charts at the same time. You
have already got to know this function when testing the charts.

8.1.2 User Interface in the Process Mode

To allow you to monitor and operate the process yourself, we will briefly introduce
the user interface of PCS 7 in the process mode.

The user interface in the process mode is divided into four areas:

• Message line – the latest message with the highest priority is displayed here

• Overview area – with various buttons, you can select the various areas of a
plant and display them. In your "color_gs" project, you have only one button,
namely "RMT1" because your plant consists of only one plant section. Beside
each button, there are four further small buttons with which alarms and
warnings from hierarchically lower levels can be displayed. If you click in this
area, you automatically change to the process picture in which the alarm or
warning originated. With the arrow button on the extreme right, you can open a
tree structure in which you can select a lower area in the hierarchy.
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• Process picture – depending on the area you selected in the overview area,
you will find the relevant process picture here. In your "color_gs" project, the
plant picture you created in the Graphics Designer is displayed.

• Keyset – using the keyset, you can invoke various functions that you can select
in the process mode. In the "color_gs" project, you will, of course, only get to
know the buttons that are important for this project.

Message line

Process picture

Overview area

Keyset

Follow the steps outlined here...



Working in the Process Mode

Process Control System PCS 7, Getting Started - Part 1
A5E00164244-01 8-3

8.2 How to Control and Monitor in the Process Mode

8.2.1 How to Activate the Process Mode

Ready to Start?

• WinCC Explorer is open

• The "color_gs" project is open

Activating the Process Mode

1. Select the menu command File > Activate.
The progress bar opens and the standard startup picture opens.

2. Click on the "RMT1" button in the overview area.
This displays the process picture that you created in the Graphics Designer.
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8.2.2 How to Start the Process

You must, of course, start the dosing before you can control and monitor all the
functions you have configured.

Dosing is started using the SFC chart. You do not return to the SIMATIC Manager
now, but will start the SFC chart directly in the process mode.

1. Click on the "Change Keyset" button:     
The second button selection is displayed.

2. Click on the "SFC Visualization" button:     
The "Open SFC" dialog box opens. Since you only have one OS and one SFC
chart in your project, only this one OS is displayed in the tree structure and
only the SFC chart in the detailed window.

3. Select the chart "RMT1/FC111/SFC_RMT1" in the detailed window and click
the "OK" button.
A greatly reduced overview of the SFC chart is opened.
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4. Click on this overview.
The detailed display of the SFC chart appears. This detailed display is
compatible with the display with which you worked when testing the SFC chart
in the SFC Editor.

5. Position this detailed display so that you can see your entire process picture.

6. Click on the "Start" button.
The "SFC Control" dialog box opens.

7. Click the "OK" button.
The sequential control system starts: You can monitor the process both in your
process picture and in the detailed display of the SFC chart. The
representation in the SFC chart is no different from the representation you
know from the test mode.
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8.2.3 How to Stop the Process

If you do not want the process to run through completely, you can stop it manually:

1. Click on the "Stop" button in the detailed display of the SFC chart.
The "SFC Control" dialog box opens.

2. Click the "OK" button.
The process is then stopped.

3. Afterwards, click on the "Reset" button and the "OK" button in the "SFC
Control" dialog box.
All values are then reset to the initial values.

8.2.4 How to Control the Process from the Process Picture

There are several ways of influencing the process in the process mode using the
process picture:

• Selecting the reactor

• Opening faceplates

• Changing the setpoint

8.2.5 How to Select the Reactor

1. Position the mouse pointer on the I/O field in the "Select reactor" area.
The mouse pointer changes to a text selection symbol.

2. Click on the I/O field.
The I/O field is displayed on a gray background.

3. Enter the required number to select the reactor.

 If you …  … enter the following number:

want to dose in reactor 1  1

want to dose in reactor 2  0

4. Press the enter key
The new value is entered after a brief delay and displayed in this area.

5. Restart the process and watch the result.
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8.2.6 How to Open Faceplates

1. Start the process

2. Click on the  "..._FC111/CTRL_PID" block icon.
The relevant faceplate is opened and the "Standard" tab is active.

3. Select other tabs using the drop-down list box. For your "color_gs" project, the
following views are of interest:

- Standard – here, you can see, for example, the setpoint and actual value
of the controller as concrete values and in graphic form.

- Parameters – here, you can, for example, modify certain values. Using the
input fields "Bar HL" and "Bar LL", you can modify the graphic display for
the "Standard" tab.

- Limits – here, you can see, for example, the alarm limits that you defined in
the CFC chart for this block.

4. Close the faceplate.

8.2.7 How to Change the Setpoint

To change the setpoint assignment requires two steps:

• First you define whether or not the process uses the external or internal
setpoint.

• Finally, you enter the concrete setpoint.

Step 1 – Specifying the Setpoint Assignment

1. Position the mouse pointer on the I/O field in the "Input setpoint" area. You
created this area yourself in the process image.
The mouse pointer changes to a text selection symbol.

2. Click on the I/O field and enter the required number of the type of setpoint
assignment.

 If the setpoint …  … enter the following number:

will be read from the CFC chart  1

will be entered manually  0

3. Press the enter key
The new value is entered after a brief delay and displayed in this area.
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Step 2 – Entering the Setpoint

1. Click on the ".../CFC_FC111/DOSE" block icon.
The faceplate is opened and the "Standard" tab is active.

2. Open the "Setpoint" drop-down list box.
The "SP" dialog box opens.

3. Activate the "Internal" check box.

4. Click the "Run" button.
The "Setpoint" input field is activated.

5. Click on the "Setpoint" input field.
The "Setpoint" dialog box opens.

6. Click in the input field and enter the required value.
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7. Click the "OK" button.
The value is entered in the input field.

8. Close the faceplate.
The changed value is displayed in the block icon.

9. Restart the process and watch the result.

8.2.8 How to Work with Messages

Messages are displayed both in the message line and in a separate message list.

Message Line

While the process is active, warnings and alarms with messages are displayed in
the message line of your screen. The message line contains the latest message
with the highest priority.

Click the button to the right of the message line to acknowledge the messages.

Message list

You can also view all the messages and alarms in a list.

1. Click the "Change Keyset" button.

2. Click the "Message System" button

The message list is displayed.

3. Acknowledge the messages:

 If you …  … then

want to acknowledge a single message click on the line number of the required
message and then click on the
"Acknowledge single messages" button.

acknowledge all messages click the "Acknowledge all visible
messages" button.
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4. Click on the buttons in the button area to change to the various message and
alarm lists.

5. Click on the "Previous Graphic" button in the button area:

This returns you to the "RMT1" process picture.

8.2.9 How to Exit the Process Mode

1. Click on the "Change Keyset" button in the button area.

2. Click on the "Exit Runtime" button:

The "Exit Runtime" dialog box opens.

3. Click the "Deactivate" button.
This stops the process mode.
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9 The Additional Task

9.1 Introducing the Additional Task

In the "color_gs" project, two identical raw material tanks are required. The
additional task is to configure the second raw material tank "RMT2". But don't
worry: You do not need to work through all steps again but will use the automatic
functions of PCS 7. You will find that the PCS 7 copy function saves many steps
that are handled automatically for you in the background.

When you create the second raw material tank, you will work largely on your own.
You have already got to know many of the dialogs you require during configuration
of the first raw material tank. In this section, we will not provide you with details
step-by-step instructions but will simply without the order in which you configure so
that you have guidelines to the general principles of the procedure.

9.1.1 How to Copy the Existing 'RMT1' Plant Section

Ready to Start?

• The "color_gs" project is open in the SIMATIC Manager

• The plant view is activated

• You have configured RMT1 completely and it is free of errors

Follow the steps outlined below...

1. Using the "Copy/Paste" Windows function, copy the entire "RMT1" hierarchy
folder to the "Plant1" hierarchy folder.

2. The SIMATIC Manager makes a copy of the "RMT1" hierarchy folder in the
"Plant1" hierarchy folder and calls it "RMT1(1)". The names of the various
objects, for example CFC and SFC charts also have a continuous number
added to their existing names.
When you copy/move hierarchy folders with CFC charts and process pictures,
the references of the dynamic objects from the OS pictures to a CFC blocks
are automatically updated in the destination hierarchy folder.
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Caution

If you copy or move charts and pictures singly; in other words, copy or move not
within the hierarchy folder, the references of the dynamic objects are lost and they
must be linked to the blocks again in the pictures.

3. Change the names of the hierarchy folder and the objects in the individual
hierarchy folders according to the table below:

 Hierarchy folder  New name  Object contained – old name  New name

RMT1(1) RMT2 Process picture "RMT1(1)" RMT2

SFC_RMT1(1) SFC_RMT2

FC111 FC112 CFC_FC111(1) CFC_FC112

ADDIT ADDIT2 CFC_SETP(1) CFC_SETP2

LI111 LI112 CFC_LI111(1) CFC_LI112

NK111 NK115 CFC_NK111(1) CFC_NK115

NK112 NK116 CFC_NK112(1) CFC_NK116

NK113 NK117 CFC_NK113(1) CFC_NK117

NK114 NK118 CFC_NK114(1) CFC_NK118

NP111 NP112 CFC_NP111(1) CFC_NP112

Your plant hierarchy should now appear as follows:
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9.2 Preparing for the Process Mode

To be able to monitor and control the plant section "RMT2" that you have inserted
in the SIMATIC Manager, you must, of course, inform the programmable controller
and the OS of the new information. In this situation, PCS 7 provides you with the
option of compiling and downloading only changed information. This reduces the
time required to compile and download. In your "color_gs" project, this is not yet a
problem since you only have a small project. When configuring large systems, this
function is, of course, extremely important.

• Downloading charts – Since the copy operations effectively created new
charts, these charts must also be downloaded to the programmable controller.

• Creating block icons and compiling the OS – This function is necessary
because you have renamed the hierarchy folders and charts. Since the name
of the hierarchy folder is included in the tag name, this new name must be
made known to the OS so that the tag names can be updated.



The Additional Task

Process Control System PCS 7, Getting Started - Part 1
9-4 A5E00164244-01

9.2.1 How to Download the New Charts

Ready to Start?

• The "color_gs" project is open in the SIMATIC Manager

• The plant view is activated

Follow the steps outlined below...

1. Select the "color_gs_Prj" object in the tree structure.

2. Select the menu command PLC > Compile and Download Objects.
The status of the "Charts" object is "modified".

3. Select the "Charts" object.
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4. Click the "Edit" button.
The "Compile/Download Program to PLC" program opens.

5. Make the following settings:

- Activate the "Changes" check box – You only need to download the
additional charts from the "RMT2" plant section, you have already
downloaded all the other charts belonging to "RMT1".

Caution

The CPU remains in RUN only if you select this option.

- "Update sampling time" check box

- "Delete empty run-time groups" check box

6. Click the "OK" button and click "OK" in the "Download" message window.

7. Click on the "Start" button.
The "Download" message dialog opens.

8. Click the "yes" button.
The starts the download and the CPU remains in "RUN".
On completion of the download, the log file is displayed in an additional
window.
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9. Close the log file.

10. Click on the "Cancel" button in the "Compile and Download" dialog box.

11. Test the sequential control system. Use the same procedure as when you
tested the "RMT1" plant section.
If you are no longer sure how to do this, you will find detailed information in the
following sections:

- "Compiling, Downloading, and Testing Charts – How to Test the Program
in the SFC Editor"

- "Compiling, Downloading, and Testing Charts – How to Test the Program
in the CFC Editor"

9.2.2 How to Compile the OS after Changes

Ready to Start?

The "color_gs" project is open in the SIMATIC Manager

Follow the steps outlined below...

1. Select the "RMT2" folder in the plant view.

2. Select the menu command Options > Plant Hierarchy > Create/Update
Block Icons.

Caution

Make sure that you do not select a higher-level hierarchy folder. Otherwise, you
might overwrite the block icons in the RMT1 picture as well as the settings you
made there.

For more detailed information, referred to "Configuring the Operator Station –
Working in the SIMATIC Manager – How to Compile the OS".

3. Select the following entry in the tree structure in the component view
"color_gs_MP/ color_gs_Prj/ SIMATIC PC Station(1)".

4. Select the menu command Options > OS > Compile…

Caution

In step 4, activate the "Changes" option. This avoids all the information being
downloaded. This reduces the time required to compile.
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If you no longer know the exact procedure in the various steps of the wizard, you
will find detailed information in
"Configuring the Operator Station – Working in the SIMATIC Manager – How to
Compile the OS".

5. Open the PCS 7 OS and open the "RMT2" process picture in the Graphics
Designer.

6. Make the following changes:

- Adapt static texts to match the names in the plant hierarchy, for example
the text "NK111" must be changed to "NK115"

- Position the block icons

- Set the "View Tag" attribute to "no" for the block icons

You will find detailed information on these procedures in "Configuring the Operator
Station – Creating the Process Picture".

9.2.3 How to Start the Process Mode

Ready to Start?

• You have compiled the OS

• PCS 7 OS "color_gs" is open

• You have completed the changes in the "RMT2" process picture

Follow the steps outlined below...

1. Select the menu command File > Activate in the WinCC Explorer.
You then change to the process mode.
You will now see an additional button in the overview with the label "RMT2". By
clicking on the "RMT1" and "RMT2" buttons, you can monitor one plant section
of the other.
The button of the plant section currently displayed is highlighted in color.

2. Click on the "RMT2" button in the overview area.

3. Change the keyset and click on the "SFC Visualization" button.
The "Open SFC" dialog box opens.
In the detailed window, you will now see to SFC charts: the SFC chart of
"RMT1" and the SFC chart of "RMT2".

4. Select the "../RMT2" SFC chart and start the sequential control system.

Note

For more detailed information, refer to "Working in the Process Mode – Operator
Control and Monitoring in the Process Mode".
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5. Working in the process mode:

- Change between the plant sections

- Change the setpoint assignment

- Select the reactor

- …

You will find more detailed information in "Working in the Process Mode".
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10 Starting and Adapting the Sample Project

10.1 The Supplied Sample Project 'color_gs'

With Getting Started, you also receive the PCS 7 project "color_gs" that has
already been fully configured. You can open this project and start it on your
computer. Since we assumed a specific hardware configuration when creating the
project, you will need to adapt the hardware configuration if you use different
hardware components.

The following sections provide you with an overview of opening the sample project
and the work involved in adapting it.

• Opening the sample project

• Adapting the hardware of the sample project

• Compiling and downloading the sample project

10.1.1 How to Open the Sample Project

Ready to Start?

The SIMATIC Manager is open

Note

You receive the sample project as a zip file that you can extract using a PCS 7
function. If you want to store the project in a specific folder, create the folder first in
the Windows Explorer and call it, for example, "sampleproj_gs".
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Follow the steps outlined below...

1. Open the SIMATIC Manager and select the menu command File > Retrieve...
The "Retrieving – Select an archive" dialog box opens.

2. Open the folder "SIEMENS/ STEP7/ Examples_MP"

3. Select the file "color_gs.zip" and click on the "Open" button.
The "Select destination directory" dialog box opens and the "S7proj" folder is
selected – this is the default storage location for all PCS 7 projects.

 If you …  … then

want to accept the default folder, click the "OK" button.

 have already created a separate folder
for the sample project

navigate to this folder and then click the
"OK" button.

Retrieval is then started. On completion of the retrieval, the "Retrieving" message
window opens.

4. Click the "OK" button.
A further message window is then opened: "The multiproject 'color_gs' has
been removed from the archive. Do you want to open it now?".

5. Click the "yes" button.
The sample project opens.
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10.1.2 How to Adapt the Hardware for the Sample Project

Ready to Start?

• The sample project is open in the SIMATIC Manager

• The component view is activated

Follow the steps outlined below...

1. Check the hardware settings – this step is basically the same as when you
prepared for your own project.

For more detailed information, refer to "First Steps in the Project – Hardware
Settings – How to Check the Hardware Settings".

2. Set the PG/PC interface – you also know this step from the preparations for
your own project.

For more detailed information, refer to "First Steps in the Project – Hardware
Settings – How to Set the PG/PC Interface".

3. Select the "SIMATIC 400(1)" folder in the tree structure.

4. Select the "Hardware" object in the detailed window and then select the menu
command Edit > Open Object.
HW Config opens.

5. Select your components from the hardware catalog and drag them to the slot in
which our component is inserted.
This overwrites our component with your component.

6. Save and compile the hardware configuration and then download it to the CPU.

For more detailed information, refer to "First Steps in the Project – Configuring the
Hardware – How to Download the Hardware Configuration".

7. Close HW Config.
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10.1.3 How to Compile and Download the Sample Project

Ready to Start?

• The sample project is open in the SIMATIC Manager

• The component view is activated

Follow the steps outlined below...

1. Select the "color_gs_MP/ color_gs_Prj/ SIMATIC 400" folder in the tree
structure and select the menu command PLC > Compile and Download
Objects.
The "Compile and Download Objects" dialog box opens.

Caution

Make sure that you activate the "Entire program" check box in the "Compile
Program/Download" dialog box.

For more detailed information refer to "Compiling, Downloading, and Testing the
Charts – How to Compile and Download the CFC and SFC Charts".

2. Change to the plant view, select the "color_gs_MP/ color_gs_Prj/ Plant1/
RMT1" folder in the tree structure and then select the menu command
Options > Plant Hierarchy > Create/Update Block Icons…

For more detailed information, refer to "Configuring the Operator Station – Working
in the SIMATIC Manager – How to Create the Block Icons".

3. Change back to the component view, select the "color_gs_MP/ color_gs_Prj/
SIMATIC PC-Station(1)" entry in the tree structure and then select the menu
command Options > OS > Compile…

Caution

Activate the "Entire OS" check box and the "With memory reset" check box.
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For more detailed information, refer to "Configuring the Operator Station – Working
in the SIMATIC Manager – How to Compile the OS".

4. Open PCS 7 OS and adapt the computer names:

- Select the OS(1)/Computer entry in the navigation window.

- Select the computer in the detailed window and then select the menu
command View > Properties.

- Enter the name of the computer on which you open the project in the
"Computer name" input field. This name corresponds to the name used for
the computer in the network. You can find this name as follows: "Start >
Settings > Control Panel > System > "Network Identification" > "Computer
name"".

5. Activate the process mode.

For more detailed information, refer to "Working in the Process Mode – Operator
Control and Monitoring in the Process Mode".
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