SIMATIC

STEP 7 V5.5 Programming Software for SIMATIC S7 / M7 / C7

Notes on Installation and Usage

These notes should be considered more up-to-date than the information in other documents.

Read the notes carefully, because they contain information on installing and using STEP 7 V5.5.

Important amendments to this version are in italics and identified with the note "New as of this version".

Note when printing the file that the left and right margins are set to a width of 25 millimeters for A4 portrait format.

Contents

Notes on Installation
1 Contents of the Consignment
2 Hardware Requirements
3 Software Requirements
  3.1 Operating Environment
  3.2 Memory Requirements
  3.3 Compatibility with Other Software Products
    3.3.1 Rational ClearCase
    3.3.2 Network Settings when using Other Software Products
  3.4 Online Documentation
4 Installation
  4.1 Installing STEP 7 V5.5
  4.2 Upgrading an older STEP 7 version
  4.3 License Key of STEP 7 V5.5
  4.4 Removing STEP 7 V5.5
  4.5 Additional Notes on Installation
    4.5.1 Using a Wheel Mouse
    4.5.2 Notes on using Communication Cards in PCs/ PGs
Notes on Usage (Release Notes)
5 New Features and Changes in the New Version
6 Notes on Configuring and Operating the Software
  6.1 How STEP 7 Fulfills the IEC Standard
  6.2 General Notes
  6.3 Using Network Drives
  6.4 Multi-user Operation
  6.5 Multiprojects
  6.6 Swapping Different Versions of STEP 7
  6.7 Libraries and Sample Projects
  6.8 SIMATIC Manager
  6.9 Using Symbolic Names
  6.10 Hardware Configuration (Central)
  6.11 Hardware Configuration (PROFIBUS DP)
  6.12 Hardware Configuration (PROFINET IO)
  6.13 Redundant I/O: Channel-granular Redundancy
6.14 Hardware Diagnostics
6.15 MPI / PROFIBUS Network Settings
6.16 SIMATIC M7
6.17 Ladder Logic, Function Block Diagram, and Statement List, Reference Data
6.18 Translating Texts
6.19 Managing Multilingual Texts
6.20 Converting S5 Programs to S7 Programs
6.21 Converting TI Programs to S7 Programs
6.22 Fault-tolerant Systems
6.23 Note on Using Foreign-Language Character Sets
6.24 Note on the use of SIMATIC Logon
6.25 Command Interface
6.26 TCI – Tool Calling Interface
6.27 Special Characteristics of the MS Windows 7 Operating System

7 Notes on Documentation
Notes on Installation

The installation notes contain important information that you will require in order to install STEP 7 V5.5. Read these notes before installing the software.
1 Contents of the Consignment

The DVD included in the content of consignment contains a complete version of STEP 7 V5.5 as well as a variety of optional components.

The STEP 7 version is available in 5 languages and can be run using the operating systems listed in section 3.1.

STEP 7 V5.5 is currently included on the DVD "STEP 7 V5.5" in the contents of consignment with a floating, upgrade, rental or trial license:

**STEP 7 V5.5 (Floating License)**
Order number: 6ES7810-4CC10-0YA5
The following items are included in this package:
- 1 STEP 7 DVD
- 1 License key USB Memory Stick
- 1 Certificate of license
- 1 Product information

**STEP 7 V5.5 (Floating License) (V3/V4/V5.x > V5.5)**
Order number: 6ES7810-4CC10-0YE5
The following items are included in this package:
- 1 STEP 7 DVD
- 1 License key USB Memory Stick
- 1 Certificate of license
- Product information

**STEP 7 V5.5 Rental License (50h)**
Order number: 6ES7810-4CC10-0YA6
The following items are included in this package:
- 1 STEP 7 DVD
- License key USB Memory Stick
- 1 Certificate of license
- 1 Product information

**STEP 7 V5.5 Trial License (14 days)**
Order number: 6ES7810-4CC10-0YA7
The following items are included in this package:
- 1 STEP 7 DVD

**Contents of the STEP 7 DVD**
Setup.exe
Readme.rtf (5 languages)
Readme_OSS.rtf (5 languages)
Folder CD_1 (Installation)
- STEP 7 V5.5
- Automation License Manager
- S7PCT V2.1

Folder CD_2
- Product information: "What's New"
- Product information: "New Modules"
- Product information: "Central Installation"
- Manual: "Getting Started: Working with STEP 7"
- Manual: "Programming with STEP 7"
- Manual: "Configuring Hardware and Communication Connections with STEP 7"
- Manual: "System Modification in RUN Mode via CiR"
- Manuals: "NCM S7"
- Manual: "From S5 to S7"
- Manual: "Ladder Logic (LAD) for S7-300/400"
- Manual: "Statement List (STL) for S7-300/400"
- Manual: "Function Block Diagram (FBD) for S7-300/400"
- Manual: "Standard and System Functions for S7-300/400"
- Manual: "Standard and System Functions for TI STEP 7 Converter"
- Manual: "PID Control"
- Manual: "PID Temperature Control"
- Compatibility list
- SIMATIC iMap STEP 7 Add-on
- Description of the Command Interface
- New as of this version: source code of the OSS software (folder "Open Source Software")

The manuals are available in an installable form in the folder CD_2 and are optionally available on your computer after STEP 7 has been installed. If you do not install the manuals, you can also view at any time on the data carrier.

- Folder "Optional Components"
  - Folder "Communication Blocks"
    Documentation of blocks FETCH/WRITE-FBs 210 and 220.

New as of this version:
- **Folder "S7 Web2PLC"**
  Application for creation and setup of user-defined Web pages for the Web server of the CPU.
- **Folder "S7 Block Privacy"**
Application for encoding of blocks.

Notes:
A block protected with Block Privacy can only be loaded to the following CPUs:
- S7-300 and ET 200 CPUs as of firmware V3.2
- S7-400 CPUs as of firmware V6
- A block protected with "Block Privacy" will not be considered in the reference data lists! Keep this in mind when creating protected blocks. All global variables used in creating protected blocks cannot be entered in the reference data list. This means you should not use global variables in the protected blocks.
2 Hardware Requirements

In order to work with the STEP 7 V5.5, you need a programming device or a PC with the following minimum requirements for processor speed/performance, expanded memory configuration and graphics capability:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Minimum Requirements for:</th>
<th>Graphics</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Processor</td>
<td>Expanded memory configuration</td>
</tr>
<tr>
<td>MS Windows XP Professional</td>
<td>600MHz</td>
<td>512 MB *)</td>
</tr>
<tr>
<td>MS Windows Server 2003</td>
<td>2.4 GHz</td>
<td>1 GB</td>
</tr>
<tr>
<td>MS Windows 7 Professional</td>
<td>1 GHz</td>
<td>1GB **)</td>
</tr>
<tr>
<td>MS Windows 7 Ultimate</td>
<td>1 GHz</td>
<td>1GB **)</td>
</tr>
<tr>
<td>MS Windows 7 Enterprise</td>
<td>1 GHz</td>
<td>1GB **)</td>
</tr>
</tbody>
</table>

*) At least 1 GB expanded memory configuration is recommended

**) At least 2 GB expanded memory configuration is recommended

Use a programming device or PC with the latest performance capabilities if you are editing extensive STEP 7 projects or working with hardware configurations containing several hundred modules (CPUs, slaves, I/O devices, etc.).

In addition, you will need an external prommer for SIMATIC memory cards / MMC if you are using a PC and want to save your user programs to EPROMs and a SIMATIC NET interface if you want to use online functions with your personal computer for the automation system.

New as of this version: As of STEP 7 V5.5 you can use the USB prommer without installing additional software. The necessary functionality has been integrated in STEP 7.

Additional information on MS Windows 7:

The “Aero Glass Style” can only be used with a high-performance graphic adapter. It requires:

- DirectX9 capability
- 128 MB separate graphic memory
- The performance of the graphics system architecture can have a substantial impact on the performance of STEP 7.
3 Software Requirements

3.1 Operating Environment

Operating systems
STEP 7 V5.5 is a 32-bit application that can be used with the following operating systems:

- MS Windows XP Professional SP2 or SP3
- MS Windows Server 2003 SP2 / R2 SP2 Standard Edition as workstation computer
- New as of this version: MS Windows 7 32 Bit Ultimate, Professional Enterprise (standard installation). The Windows XP mode under Windows 7 has not been approved yet.

STEP 7 has not been tested for the following operating systems; use at your own risk:

- MS Windows XP Professional with SP1
- MS Windows Server 2003, SP1, SP1 R2
- MS Windows Vista Ultimate, Business and Enterprise
- MS Windows Server 2008 std. Edition SP1 and SP2

STEP 7 V5.5 cannot be installed or operated under:

- MS Windows 3.1
- MS Windows for Workgroups 3.11
- MS Windows 95
- MS Windows 98
- MS Windows Millennium
- MS Windows NT 4.0
- MS Windows 2000
- MS Windows XP Home
- MS Windows XP Professional (without SP)
- MS Windows Vista Home Basic, Premium
- MS Windows Vista 64 Bit versions
- MS Windows 7 64 Bit versions

Important additional information:

- Special considerations when installing the software on MS Windows Server 2008: You need administrator rights to configure the PG/PC interface or install hardware support packages. The user rights from the user group "Siemens TIA Engineer" are not sufficient.
- Special consideration when installing the software on MS Windows 7: Observe the notes in the paragraph "Special Characteristics of the MS Windows 7 Operating System" regarding the user group "Siemens TIA Engineer".
Internet Explorer
All operating systems must be using MS Internet Explorer 6.0 (or higher).

Display of PDF files
New as of this version: To read the supplied PDF files, you need a PDF reader that is compatible with PDF 1.7 (ISO32000-1:2008 PDF).

Security settings
In project directories, all users who have write access are to receive write permission in case of non-exclusive use by one user only. These rights have to be set up by an administrator.

Note: The standard rights available in the operating system depend on the operating system in use. Tools used for the creation of partitions will implement their own security guidelines.

Hibernation mode
Shifting to hibernation mode is generally permitted in STEP 7. However, hibernation must not be triggered if online connections are open or projects are being accessed by STEP 7 applications via a network.

In such cases, online connections could be terminated unintentionally and open projects on networks may experience data loss.

For these reasons, the energy options for the operating system in the Windows Control Panel should be set so that hibernation is not automatically triggered (by timer). Hibernation should not be triggered manually by the user in the cases mentioned above.

3.2 Memory Requirements

Memory requirements for STEP 7
Depending on your installation requirements and the number of languages installed, STEP 7 V5.5 requires between ca. 650 MB and 900 MB of memory on your hard disk. The exact value also depends on your operating system and on the file system used on your programming device/personal computer.

MS Windows swap file
The supported Windows operating systems also require additional free space on the hard disk (typically C:) for their swap files, depending on the memory configuration. You should keep at least double the value of the RAM free. (Example: If you have 512 Mbytes of RAM, you will require another 1024 Mbytes of free space on the hard disk for the swap file after STEP 7 has been installed.) Depending on the size of the project, it may be necessary to have a larger swap file, for example, when copying an entire project (twice the size of the project on the hard drive in addition). If the free memory area for the swap file is too small, errors may occur (the program could possibly crash). Additional Windows applications which run parallel to STEP 7 (such as Microsoft Word) also require additional hard disk space for the swap file.

In order to ensure that the required memory for the swap file is really available, the minimum size for the swap file should be set to the above value. This can be set in Windows (for example, Windows XP Professional) in the taskbar in Start > Settings > Control Panel (in System > Advanced > System Performance > Settings > Advanced).

You must make certain that you have enough free memory on the drive where the project data are located. If there is not enough memory on the drive, the project data may be destroyed during an operation (for example, when compiling an STL source file into
blocks). We also recommend that you do not store the project data on the same drive as the Windows swap file.

3.3 **Compatibility with Other Software Products**

3.3.1 **Rational ClearCase**

STEP 7 projects must not be stored on ClearCase drives; that is, drives that are linked to a ClearCase View (MVFS).

3.3.2 **Network Settings when using Other Software Products**

If you are using other software products (for example, mail providers) on a programming device or PC with STEP 7, observe the additional notes on network settings in the section "Using Network Drives".

3.4 **Online Documentation**

The online help in STEP 7 V5.5 is split into two sections.

You can find notes on the current context in the same way as with the standard Windows help.

The general section of the online help is based on the HTML format.
4 Installation

4.1 Installing STEP 7 V5.5

When installing STEP 7 V5.5, you can overwrite existing installations of STEP 7 V5.1, V5.2, V5.3 or V5.4 while observing the authorized operating systems (refer to Chapter 3.1). You do not have to uninstall these STEP 7 versions and optional packages prior to the installation.

Before starting the Setup program, close all applications (such as Microsoft Word, etc.) and the "Control Panel" window, because you will need to restart Windows following the installation of STEP 7 V5.5 so that all system variables can be entered completely.

Insert the STEP 7 DVD in the drive. The setup program will guide you through the installation. The setup program starts automatically after the STEP 7 DVD is inserted in the drive. If you have disabled this function on your computer, start the setup program by double-clicking the SETUP.EXE program in the root directory.

In the component selection box, select the Adobe Reader, STEP 7, the Automation License Manager and any other components that you wish to install.

If you would like to change the installation path suggested in the setup during the STEP 7 installation, please note that you cannot install it directly to a root directory (e.g. D:) on your computer. There has to be at least one higher-level folder such as "STEP7", for example, D:\STEP7.

These components will then be installed.

The following notes are intended to help you make the correct user entries required during the Setup program:

- The drive on which you install your STEP 7 V5.5 system can be selected freely. On some PCs/programming devices, you will not be able to select the drive via the selection list. In this case, simply enter the drive with its path in the appropriate input box (for example, "e:\Siemens/Step7"). Note that all STEP 7 optional packages must also be installed on this drive, so there must be sufficient space available (see "Memory Requirements"). Avoid installing STEP 7 on a SUBST drive.

- Before you use STEP 7 V5.5, Windows must be restarted. Only then do all of the Microsoft Windows entries become active. If you do not restart Windows, STEP 7 V5.5 cannot run properly and data may be lost. If the installation procedure is aborted, you will also need to restart Windows.

- Refer to the tables in the S7KOMP_B.PDF file (in the directory "Step7" following installation) for information on which versions of the optional packages can run with STEP 7 V5.5 under the respective operating systems.

- STEP 7 must not be installed in a directory whose path includes characters that are not listed in the ASCII character set (refer to the section “Note on Using Foreign-Language Character Sets”).

- The security settings of your system are modified during installation so that you can use STEP 7: Port 4410 for TCP is entered as an exception in the Windows Firewall. If you are using additional firewall software, you may have to ensure that the exceptions made in the Windows Firewall are also taken into consideration in your additional firewall software.

Contact your Siemens representative for more up-to-date information or check our website: http://support.automation.siemens.com/WW.
Note
STEP 7 registers itself in the system files of the MS Windows operating system. You cannot delete, move or rename STEP 7 files or folders using Microsoft Windows utilities such as the Explorer or modify STEP 7 data in the Microsoft Windows registry. The program may no longer run properly after such modifications.

4.2 Upgrading an older STEP 7 version

Prerequisite for installation of the upgrade package is a valid license of STEP 7 V3.x, V4.x, V5.0, V5.1, V5.2, V5.3 or V5.4.

Note
Note that an upgrade may require changing to a different operating system, because as of STEP 7 V5.3 and STEP 7 V5.4 SP4 older operating systems (for example Windows 2000) are no longer supported (see 3.1). Additional information on the upgrade is available in the product information.

Prior to changing the operating system, you will have to backup the existing authorization / license key with the program AuthorsW / Automation License Manager on disk / USB Memory Stick.

When installing any components without removing S7DOS V7.1.x first, there may be a few instances when you will receive the following error message from the operating system: "s7oehsx.exe - Error in application." The installation will still be executed correctly.

4.3 License Key of STEP 7 V5.5

The license key is provided on a USB Memory Stick instead of a floppy in new deliveries of STEP 7 as of STEP 7 V5.4 SP3.

Therefore, when transferring the license key to the hard disk of your computer, select the source medium where the license key is located accordingly, a floppy or USB Memory Stick.

Before you can start working with STEP 7, you must transfer the license key to the computer. There are two ways of doing this:

- While you are installing STEP 7, the Setup program displays a message if there is no suitable license key installed on your computer. You can then decide whether you want the license key to be installed by the “Setup” program or whether you want to install the license key manually at a later time using the “Automation License Manager” program.
- If the license key cannot be installed during setup, continue the Setup program without installing the license key. Then boot the computer and install the license key using the taskbar in (for example, Windows XP Professional) Programs\Siemens Automation\Automation License Manager.

To operate STEP 7 as of V5.3, you must make sure the Automation License Manager is installed.

After the upgrade from V3.x, V4.x, V5.0, V5.1, V5.2, V5.3 or V5.4 to V5.5 you will have to use a V5.5 license key.
Note

As of STEP 7 V5.2, you can install the license key to all local drives.

The Automation License Manager prevents the license keys from being installed on invalid drives or media such as RAM drives, diskettes or compressed drives (i.e. DBLSPACE). If the drive in a device is reported as being a "removable medium" and not, as usual, as a "hard drive", it will be treated as a CD/DVD, which means that no license key may be installed on it.

In the case of compressed drives, you can install the authorization on the associated host drive.

Read the notes on the Automation License Manager in the almreadme.rtf file on the STEP 7 installation DVD under "Automation License Manager\disk1".

Hidden files are stored in the folder "<Drive, on which the license key is installed>:\AX NF ZZ". These files and the folder must not be deleted, moved, or copied. They contain data required for the licensing of your software.

If you do not adhere to these guidelines, the license key may be irretrievably lost.

Note about using license keys correctly

- The USB Memory Stick must not be read-only. This means you run the risk of passing a virus from the hard disk to the USB Memory Stick. You should therefore run a virus check on your PC or programming device every time you install or remove a license key.

- If you use a defragmentation program, which enables you to move fixed blocks of memory, only use this option once you have moved the license key from the hard disk back to the license diskette/ the USB Memory Stick.

- When you install a license key, a cluster appears on the target drive marked with a special character. Some testing programs may show this cluster as "defective." Do not attempt to "repair" the cluster.

- Do not forget to transfer the license key to the USB Memory Stick before formatting, compressing, or restoring your hard disk or before installing a new operating system.

- If a backup copy of your hard disk contains copies of license keys, there is a danger that these copies may overwrite the valid installed license keys when you restore your backup data to the hard disk, thereby destroying the valid license keys. To prevent a valid license key from being overwritten by a backup copy, you must remove all license keys before you make a backup copy or exclude the license keys from the backup.

Using the trial license

If no valid license key has been installed for STEP 7 V5.5, you can use and install a trial license key supplied with STEP 7 as standard. You can operate STEP 7 with this license key for 14 days. When you start STEP 7 without valid license key for the first time, you will be automatically prompted to activate the trial license key.

4.4 Removing STEP 7 V5.5
Note
Software products must be uninstalled according to Microsoft Windows conventions.

Use the Microsoft Windows application "Add/Remove Programs" (for example, under MS Windows XP in the taskbar in ..> Settings > Control Panel > Add/Remove Programs) to remove your software package (for example, "STEP 7").

As an alternative, you can use the setup program to uninstall a program.

If you uninstall an older version of STEP 7 in order to install STEP 7 V5.5, you must first uninstall any existing optional packages for STEP 7 as well.

4.5 Additional Notes on Installation

4.5.1 Using a Wheel Mouse

When using a wheel mouse, be sure that the driver supplied by the manufacturer is installed. If this is not the case, STEP 7 will not always support the wheel feature of the mouse.

4.5.2 Notes on using Communication Cards in PCs/ PGs

**CP 5611/ CP 5611 onboard (SIMATIC NET PROFIBUS interface via PCI Bus)**

In order to use the CP 5611 card you require a PC or a programming device with PCI bus. You can then address SIMATIC stations via MPI or PROFIBUS (9.6 Kbps to 12 Mbps).

If you install STEP 7 after the CP has been inserted in the computer, the Plug and Play mechanism enters the CP 5611 in the Device Manager of the Control Panel\System in "Other Devices". Therefore, the CP is sometimes not recognized when installing STEP 7.

In such cases, remove the CP 5611 in the Device Manager after installing STEP 7 and reboot your computer.

Observe the notes in the online help under "Setting the PG/PC Interface."

**CP 5512 (SIMATIC NET PROFIBUS interface via PC card)**

A PC or a programming device with PC card slot is required to use the CP 5512. You can then address SIMATIC stations via MPI or PROFIBUS (9.6 Kbps to 12 Mbps).

**CP 5711 (SIMATIC NET PROFIBUS interface via USB 2.0)**

A PC or a programming device with USB port is required to use the CP 5711. You can then use this port to address the SIMATIC stations via MPI or PROFIBUS (9.6 Kbps to 12 Mbps).

Note
The use of communication processors CP 5611 A2 and CP 5621 in multi-core/multi-processor systems on PROFIBUS networks has been approved with a baud rate of up to 1.5 Mbps. You may experience problems if you operate with higher baud rates.
Hardnet modules

If you use the Industrial Ethernet network card CP 1613 or the PROFIBUS cards CP 5613/14, you require the optional package SIMATIC NET PC additionally in a version compatible with STEP 7 V5.5 (see Compatibility list S7KOMP_A.PDF in the installation directory "STEP 7").

You require the SIMATIC-NET software as of V6.2 (CD 11/2003) to operate CP 5613_A2 and CP 5614_A2.

General PC/programming device settings

Commissioning plug-and-play compliant modules

To commission the Plug-and-Play compliant modules (e.g. CP 5512, CP 5611 and CP 5711) in MS Windows/XP/Server 2003/MS Windows 7, please proceed as follows:

1. Install STEP 7. At the end of the setup exit the dialog "PG/PC interface" without entering anything.

2. Close MS Windows, shut down the PC and install the card. The CP 5512/CP 5711 can also be inserted during operation.

3. The communication module is installed automatically after the restart (or after CP 5512 has been inserted).

4. Under WinXP/Server2003, the Hardware Wizard is displayed. In the first dialog shown, select the option "No, not this time". Confirm all following dialogs (do not click on CANCEL).

5. Then check the settings or select the desired interface configuration in "Set PG/PC Interface" (.....> STEP 7>Set PG/PC Interface).

Observe the information in the online help under "Set programming device/personal computer interface".

When STEP 7 is installed on programming devices, the communication drivers are installed automatically and the default settings are accepted.

Setting of interrupt and address

MS Windows/XP/Server 2003/MS Windows 7:

The settings of address area and interrupt cannot be changed in MS Windows XP, Server 2003 as well as MS Windows 7. The assigned values can be viewed by doing the following: Open, for example, in MS Windows XP Start > Settings > Control Panel > Administrative Tools > Computer Management and then "System". In the Device Manager, you can view the values of individual modules. In System Information > Hardware Resources, you can view the reserved resources.

In BIOS of the PC, a certain interrupt and address area may be reserved for PCI components. Please consult your PC or BIOS manufacturer.
Notes on Usage (Release Notes)

These notes should be considered more up-to-date than the information in manuals and online helps.
5 New Features and Changes in the New Version

What's new in comparison to version 5.4?
For more information, read the RTF file "What's New" on your STEP 7 DVD or refer to the corresponding section "What's New?" in the online help. You can call this topic from the contents page of the Help on STEP 7 (menu command Help > Contents).
6 Notes on Configuring and Operating the Software

6.1 How STEP 7 Fulfills the IEC Standard

The exact definition of compliance with the standard to IEC 61131-3 for the programmable logic controller (PLC) can be found in the NORM_TLB.RTF file in the subdirectory that you have selected during setup.

6.2 General Notes

Special characters may not be used in file names, folder names, or project names. Comments in modules, icons etc. may not be closed with the special character "\".

The contents of the windows are not automatically updated (for example, the window contents in the SIMATIC Manager are not always up-to-date after an interruption of the Online connection). If in doubt, use the F5 key to refresh the contents of the active window.

Screen savers

When using a screen saver, you should note that the additional processing required takes up CPU time and this can lead to a system overload. Some screen savers are known to prevent the release of main memory components. This leads to a continuous reduction in the available main memory.

Using virus scanners

The following virus scanners have been tested with STEP 7 V5.5 for compatibility:

- Symantec Endpoint Protection V11.0
- Trend Micro OfficeScan V10
- McAfee VirusScan Enterprise V8.57i

The virus scanners listed above can generally be used in the standard setting.

User data should not be stored in STEP 7 project directories (for example, Microsoft Word documents), because when you delete a STEP 7 project from the SIMATIC Manager these user data are also permanently deleted. You cannot use the "Undo" function to retrieve deleted data from the Windows Recycle Bin.

Moving (with drag-and-drop) selected STEP 7 objects (such as blocks) to MS Windows objects (such as the Recycle Bin) is not possible even if the "unavailable" cursor does not appear.

SUBST drives should not be used for storing STEP 7 or your project.

PC and TS adapters

If the connection is interrupted or lost when using PC or TS adapters for communication connections, check the power management preferences on your computer.

Downloading configuration data

When you configure the complete SIMATIC hardware, the configuration data are stored automatically in the offline database. The data are stored in the "System Data" folder under
the user program (described as "Blocks"). If this user program is downloaded to a CPU with its configuration data, the data in the CPU become effective immediately, meaning they may change the existing set values (for example, a new MPI address). For safety reasons, it is recommended that the complete user program with the configuration data should only be downloaded when absolutely necessary (such as loading onto memory cards).

Downloading a configuration also containing configuration data for a CP should be done via the MPI interface of the CPU. Downloading the configuration data to the CPU via the CP can result in the connection being canceled.

Handling system data

It is not a good idea to copy these data to another module. This folder contains the configuration data of the hardware configuration and the network/communication configuration. The network/communication configuration data are data that are not just relevant to one station/module. In the same way, when loading a SIMATIC configuration from the PLC to a programming device/PC using the "Configuring Hardware" application, you only load the hardware configuration data to the system data folder.

'Remote Desktop' and 'Quick User Change'

STEP 7 does not support the "Remote Desktop" or the "Quick User Change" Windows XP Professional, and MS Windows Server 2003 and MS Windows 7. However, if you wish to use these operating system properties with STEP 7, please note the following: STEP 7 applications can only be started in one session. If a STEP 7 application is started in a session via "Remote Desktop" or "Quick User Change", no more STEP 7 applications can be started in other sessions. Only one user can work with STEP 7 applications on a computer.

When using optional software packages please note that these can only be called up and operated by one user - otherwise they could influence each other.

6.3 Using Network Drives

Storing projects on a network

If the network connection is interrupted while you are working with projects/multiprojects on network servers and you then receive a message that a project/server is not available, exit all affected projects/multiprojects without saving and then restore the connection to the server before you continue working with the projects.

To access network drives, it is also necessary that the PCs are connected with their names and not their IP addresses. If the name resolution cannot be performed automatically by broadcasts and no service is used for resolving names, it can be performed by a reference to the PCs in the file <WINDOWS>\system32\drivers\etc\HOSTS. If no HOSTS file is available, it can be generated by copying LMHOSTS.SAM. The file contains an example of the syntax.

In order to access the network drives, ensure that the editor has the necessary read/write permissions for the network as well as the folders it contains. In a multi-user environment, the logged on user must also have share rights for the network as well as the folders it contains.

6.4 Multi-user Operation

Release of shares

If shares of a NTFS partition are released in MS Windows XP/Server 2003 as well as MS Windows 7, then users who are to have access to this share should be entered in two
places. Select the menu command "Sharing and Security", and enter the users in both the "Sharing" tab as well as the "Security" tab.

Please also observe the notes in the following section on "Multiprojects".

6.5 Multiprojects

Opening of multiprojects on several computers simultaneously is not supported!

In a STEP 7 multiproject, an editor working at Computer 1 ("client") can access information in a STEP 7 project on Computer 2 ("server"), such as in the case of interproject functions. When working in this environment, please observe the information in the following notes:

**There are two fundamentally different ways of working with multiprojects**

- **The projects in a multiproject are centrally stored on one server**

  In this case, the projects in a multiproject are all stored on a central server. Editors working on the individual projects can access the projects stored on this server directly from their workstations.

  If many projects are opened simultaneously on this central server (more than 20 projects in a multiproject) and if interproject functions are also triggered, you may only use "**MS Windows Server 2003**" as the operating system on the server (no other MS operating systems may be used due to operating system limitations).

- **The projects in a multiproject are distributed over many computers**

  Each editor has "his project" on his own programming device/PC and only edits this one project. An editor responsible for managing interproject functions has the multiproject on his PC. The distributed storage of the project (one project per programming device /PC) means that the limitations of MS Windows operation systems will not be reached.

  Both methods of managing a multiproject can be used in sequence or in alternation during any phase of the project. For example, during its initial stages, a project can be distributed over many workstations and worked on locally. During the end stage, (such when being placed in service), the project can then be stored on a central server and accessed there.

  To avoid problems caused by operating system limitations and access conflicts, those editors working on individual projects should open them separately and not from within the multiproject.

---

**Caution**

If interproject functions are being used in a multiproject, then it must absolutely be ensured through coordination with the project manager that no one is working on the projects concerned while these interproject functions are running.

Examples of such interproject functions are those in the SIMATIC Manager such as File > Multiproject > Adjust Projects... or, if the multiproject itself is selected: File > Save As, File > Reorganize and File > Archive.

If you receive a message that a project / a server is not available, exit all projects / multiprojects without saving and then restore the connection to the server.

---

Also observe the requirements and recommendations for working with multiprojects as described in the online help.
6.6 Swapping Different Versions of STEP 7

Projects in version 2

- You can basically continue to use the project data from STEP 7 V2.1 in STEP 7 V5.5, if these project data have been imported into a project in the current version.

Projects from version 3 and higher

- Projects that were set up and edited with STEP 7 V3.1, V3.2 or higher can be used unchanged as (current) projects with STEP 7 V5.5.
- For multiple-user operation, existing V3.0 projects must be converted to projects for the current version using the menu command "Save as, with reorganization".

New modules in earlier STEP 7 versions

- If you assign parameters to modules with STEP 7 V5.5 and these parameters were not yet contained in an earlier version of STEP 7, then these modules and their subordinate components will not be displayed in STEP 7 versions earlier than V5.1 SP3. If you have assigned parameters to modules that were added on through an optional package, they also will not be displayed if the project was created in a STEP 7 version earlier than V5.1 SP3.
- As of STEP 7 V5.1 SP3, a generic object is used to represent these "unknown" modules.

Caution

If objects with messages are in progress with STEP 7 version <= V5.1, such as blocks with block-related messages, symbol tables with symbol-related messages, blocks with S7-PDIAG monitoring or programs with user-defined messages, this project may not be opened by another PG/PC with STEP 7 version V5.2 or later. This means that the project has to be closed on the computer with the older STEP 7 version - even for read access.

Assigning unique message numbers for the CPU or for the project

- Please note that in projects in which messages numbers are assigned for the CPU (new procedure), that only those programs, blocks or symbols without message configuration (such as user-defined messages, block messages, scan messages, S7-PDIAG configurations) can be edited in earlier versions of STEP 7 (such as V5.1). It is not possible to convert CPU-based message assignment to project-based message assignment.

Please refer to the notes in the "Message Configuration" section.

6.7 Libraries and Sample Projects

- A number of libraries and sample projects are supplied with STEP 7 V5.5. These sample projects can be deleted in the SIMATIC Manager. To reinstall them, you will need to run the STEP 7 V5.5 Setup program again. Sample projects and libraries are only installed if you run the entire STEP 7 Setup again.
Note
Sample projects and libraries shipped with STEP 7 V5.5 are always copied when you install STEP 7. If you have edited the standard sample projects, they will be overwritten with the original examples if you reinstall STEP 7.

You should therefore make a copy of the standard examples before you make changes to them and then make changes to the copy.

- New as of this version: The symbolic name of the blocks FB210 and FB220 has been changed. The existing functionality will remain the same.

  FB210: S5FW_TCP ➔ FW_TCP
  FB220: S5FW_IOT ➔ FW_IOT

6.8 SIMATIC Manager

- In certain circumstances, the wait cursor will not appear or will disappear too early during long operations.

Accessible Nodes

- The "Accessible Nodes" and "Memory Card" views are not always automatically updated. You can update both of these windows by pressing the F5 key.

Programs for Archiving and Retrieving Files

The selection of tools for archiving or retrieval has been changed as of STEP 7 V5.4 SP4 in the SIMATIC Manager under Options > Settings > Archive: ARJ32 V3.x, JAR, LHARC and WinZip Automatic are no longer offered. ARJ 2.50a provided on the disk has not been approved for MS Windows 7 and MS Windows 2003 Server, but can be used under MS Windows XP.

Note

Please note that loading of split projects in ARJ format is no longer supported as of V5.4 SP4. In older STEP 7 versions, the included ARJ2.50a can be installed on Windows XP to unzip older archives. You can then convert the project with PKZip 124 into the standard zip format, which means you can archive and retrieve files.

Compiling and downloading objects

- Startup after a successful download is possible after executing "Compile and Download" via the SIMATIC Manager (PLC > Diagnostics > Settings > Operating Mode).

- All SDBs are loaded from the offline container at download just as with the SIMATIC Manager. The user is responsible for making sure that the SDBs for Netpro, GD or other optional packages are up-to-date.

- In general, the automatic download of hardware configurations is not possible for PC stations.
Change log

- A change log for a project can only be written if SIMATIC Logon is installed on the PC/PG. Please read the information in the section "Note on the use of SIMATIC Logon."

- You should only edit projects with a change log on a PC / PG on which SIMATIC Logon is installed.

- Activities involving the memory card are not contained in the change log. You can find additional notes on the change log in the online help.

Updating the menu structure

Certain option packages will be integrated in the menu structure of the SIMATIC Manager. If this integration is incomplete, you can use the “Update menu” function under Help > Info. The menu structure will be updated once you execute this function and restart STEP 7.

Show access control symbols

You can show symbols in "Open Browser" that display the status of the access control. Contrary to the "Search" function, the included projects will be analyzed in this respect with implicit search of the project folder using double-click or the expand function. You can speed up the implicit opening of large project folders by disabling the item "Show access control symbols" under "Options > Customize > General".

6.9 Using Symbolic Names

- If symbols with messages are copied into another symbol table, it could happen that the message "Symbol table occupied by another process" appears. In this case, save and close the symbol table. After reopening the table you can continue to work as usual.

6.10 Hardware Configuration (Central)

CPUs with MPI/DP interface:

- Make sure that you do not select a transmission rate that is not supported by your programming device/PC when configuring these interfaces. If you do reconfigure this setting, you will no longer be able to establish an online connection to the CPU via this interface.

Possible remedies:

1. Use a second interface with the same transmission rate as your programming device/PC.

2. Create a new station in an STEP 7 project. Configure the CPU in your new station with your default settings in the "Configuring Hardware" application. After saving and compiling, copy the system data in the SIMATIC Manager to an S7 memory card. Insert the memory card in the CPU and carry out a memory reset.

- If you have uploaded data from a reset CPU, you must reconfigure the MPI/DP interface.

- If the MPI Address of a module (CPU/CP/FM) in a 300 Station is changed, we recommend that you load the entire station. Otherwise, it is possible that the module cannot be reconnected.
S5 adapter modules

- When you use a number of S5 adapter modules in an S7-400 station, no check is made to determine whether the S5 addresses overlap in the P/Q/IM3/IM4 area across the modules. You have to ensure that no S5 address that is already occupied is used in the input dialog box for the S5 adapter module/IM463-2.

- No S5-analog input/output modules can be used or addressed in the user program in the S5 adapter module. S5-analog input/output modules can only be used in SIMATIC-S7 systems in the IM463-2 or via DP interface.

Other issues

- Deleting parameter data (SDB>1000): Some FMs and CPs not only store their parameter data in system data blocks (SDB) > 1000 on the CPU but retain this data themselves. If the SDBs are then deleted from the CPU, the FMs or CP will continue to have parameters consisting of the previously valid data. For more information, refer to the description of your FM or CP.

- For reasons having to do with ensuring data consistency, in multi-user operation (several users working on a project at the same time) only one other station can be used at the same time.

- If your configuration contains module from earlier optional packages, it may happen that not all data in this modules is acquired (“captured”) when using the "Export station" function. In this case, check whether the module data are complete after the import process is complete.

- If you use the CPU function "Hot Restart", make sure that the module address area does not exceed the process I/O image range.

Hardware Configuration (PROFIBUS DP)

Cross-reference

- Note when configuring direct data exchange (DP cross reference) that both the station at which the slave is configured as sender and the receiver must be downloaded.

- Copying from stations, among which there are communication relationships (for example, data cross-reference), in other projects must be carried out jointly. Otherwise these communication relationships will be lost during copying. Therefore, select the other stations and then begin copying.

- On downloading a configuration, the program does not check whether the product revision of the DP slave supports the function "sender in direct communication link." You should therefore observe the scope of performance of the DP slave (compare versions, if this is available in the configuration).
Constant scan time
- When you configure both "constant scan time" and sync/freeze groups for PROFIBUS DP, note the following:
  - Group 8 cannot be used (reserved for constant scan time clock). If you have already configured the group assignment as group 8, you cannot set constant scan time.
  - The function for setting constant scan time cannot be used for the DP slave DP/AS-i_Link ET 200B analog, ET 200-SC up to product version 5, ET 200X, IM 153-1 up to version 3 and IMSC up to version 5.
  - When the constant scan operating mode is selected, a programming device on the PROFIBUS may not be able to enter the ring. If this occurs decrease the HSA as much as possible or select an interface without automatic bus parameter recognition and try it again.
  - PROFIBUS Slaves, which do not support SYNC- or FREEZE-commands, cannot be used for the function "Constant scan time".
  - In the case of ET 200M 6ES7153-2BA00-0XB0 and 6ES7153-2BB00-0XB0, there is no provision for using active backplane bus modules for operations using constant scan time. The configurable minimum times only apply to operation without active backplane bus modules. Note: Should active backplane bus modules nevertheless be used, a time period of 1 ms should be added to the Tdp by the user.
  - The PROFINET devices ET200S HS V1.0, 2.0 and 2.1 cannot be operated with the CPU 400 as of V6.0 or with CPU 300 as of V3.2 in isochronous mode.

Sync/Freeze:
- There should be no FMs or CPs inserted in the ET 200M peripheral I/Os assigned by STEP 7 Sync/Freeze-Groups.

Switching languages
- After you have changed the language, you must restart HW-Config once more before copying stations with DP configurations.
- If the set language differs from the one used during configuration, it may happen that not all DP slaves modules are imported with the menu command Station > Import.
  Solution: Import the configuration in the original language and reset it afterwards.

I-slave: BM147 and IM151/CPU:
- When configuring the BM147/CPU (ET 200X) and IM151/CPU (ET 200S9 with intelligent preprocessing, use a SIMATIC 300 station.
- The module BM147/CPU must also be networked in the configuration with a new PROFIBUS network if it is being used as a stand-alone (separate operation) device.
- A download or upload of the IM 151/CPU is only possible if the access point "S7 online" in the PG/PC matches the one supported by the module or configured interface. For the IM 152/CPU without a switchable MPI/DP interface, the setting should be PROFIBUS interface (see SIMATIC Manager, Set PG/CP interface).

DP slaves
- The SFCs 5 and 49 which are used for converting geographic to logical addresses and vice versa for slaves which are interconnected via the GSD file supply correct values only in the following configurations:
  - The DP slave is connected to a 300 CPU with firmware V2.0 or higher or a master in the operation mode DPV1.
In case of fault the SSL 0x91 supplies an incorrect parameter "adr 2" (Slot, Interface No.) in a record for these slaves.

**Diagnostic repeater**

- In DPV0 operating mode (DP alarm mode), diagnostic events will cause OB 82 to be called. In DPV1 operating mode, OB 82 is only triggered by a diagnostic interrupt. If the diagnostic interrupt is not offered as a DPV1 interrupt in the slave parameters, then this is not supported by the given slave.

- For this reason, the diagnostic repeater should be used in DPV0 operating mode.

- Topology display (PLC > PROFIBUS > Show Network Topology):
  Under certain conditions (number of nodes connected to the network, baud rate, etc.), a "time out" may occur for an online connection and not all the data may be read from the diagnostic repeater and displayed. In this case, we recommend that the interface settings for CPxxxx (PROFIBUS) be reset to 10s in the properties dialog.

**Preparing for line diagnostics**

- With interface "CPxxxx(Auto)" it not possible to measure the nodes at the PROFIBUS DP. The interface must be set to "CPxxxx(PROFIBUS)".

- The onboard MPI interfaces for PG740 and PC-Adapter (PC/MPI cable 6ES7901-2BF00-0AA0) does not support the function "Prepare Line Diagnostics". If the function is started in STEP 7 anyway, the measurement will be stopped at end of a monitoring time. In this case, the reporting status " determination stopped " will be displayed in STEP 7 with the additional text " Time monitoring addressed".

- The following interface cards support the function for measuring the nodes on PROFIBUS-DP: CP 5512, CP 5611, CP 5711.

- When the dialog "Prepare Line Diagnostics" is active, online connections cannot be established to the network transitions. During a network transition to the CPU of a module, the module status cannot be called in the "Prepare Line Diagnostics" dialog.

---

**Note**
If there is a PROFIBUS line behind an IE/PB link 6GK1-411-5AB00 (as a PN IO device), such a network transition is given, however this is not the case behind a network transition 6GK1-411-5AA or 6GK1-411-5AB00 (as pure network transition) or for a PROFIBUS line without a link transition.

---

**IM-157**

Note that the assignment of parameters on the CPU may be aborted when using the IM 157 as an interface module for PA slaves if the set transmission rate on the PROFIBUS is too low or if you have configured IM 157 modules that do not exist on the PROFIBUS. In this case, increase the set monitoring time in the "Startup" tab for the CPU by changing the parameter "Transfer of parameters to modules." You must also delete the system data in the CPU and then download the new parameter assignment to the CPU.

**Updating the firmware with redundant interface modules (IM 157 and IM 153-2) are used**

If you want to use the IM 157-0AA82-0XA0 or the IM 153-2BAXX-0XB0 redundantly and update the firmware of the IMs, you will have to do this in two steps.
Caution
If the PG is not directly connected to the PROFIBUS, you will not be able to
determine whether both modules can be addressed via the STEP 7 Routing
mechanisms.

System changes in runtime using CiR

Caution
Loading the current configuration form the automation system to the PG (Menu
command PLC > Download to PG) will cause your station to lose the CiR
capability.

We therefore strongly recommend that you not perform this download procedure.

Loading stations with CiR objects in RUN mode

• "Loading in RUN mode" may possibly be rejected if there are other Multi systems
located next to the Master system in the CiR objects in the station or the station was
last loaded with STEP 7 V5.3 or older in "STOP" mode. To remedy this, the
configuration has to be loaded once in STOP mode onto the CPU.

• If your station contains a CP 443-5 or 443-1 and was downloaded with STEP 7 V5.3
SP1, V5.3 SP2 or V5.3 SP3, it may be necessary to download the configuration once in
STOP mode to the CPU, to enable a correct CiR behavior for the future.

• If CiR modifications are made to a DP-Slave ET 200iSP with inserted 8 DI NAMUR
modules, it is necessary to save and compile the modified configuration before a
download in RUN.

• The limitations that existed for STEP 7 versions up to and including V5.4 SP5 during
hardware configuration in RUN (CiR) for PROFIBUS when upgrading the STEP 7
version do no longer exist in V5.5.

For systems with CPU 41x in which either the integrated PROFINET interface or a
PROFINET CP was used for operation of an IO system or for Ethernet communication or
configuration, you can make the upgrade to V5.5. The CiR capability will be retained.

Revision 3, GSD files

Functions in GSD Revision 3 are supported with STEP 7 V 5.1. Backwards compatibility
with STEP 7 versions < V 5.1 is not ensured for DP slaves with these functions. If such DP
slaves were configured with STEP 7 V 5.1, the project can only be processed in STEP 7
versions < V 5.1 if the following conditions are observed:

• The slave can be used only in the operation mode DPV0.

• In the case of function-modular devices only modules may be placed which are allowed
at the corresponding slots. This limitation is not monitored for STEP 7 versions < V 5.1.

• Modules which occupy more than one slot in the DP slave are split into individual
modules. The module whose name begins with "?????" and the following module called
"-->........" form a unit and may not be changed.

Symbols

• Modules whose input or outputs data consist of different data types are currently
offered with byte-oriented symbols. If the number of data amounts to 3 or more bytes,
these data can only be accessed as a whole (by using the SFC 14 and SFC 15)
although a symbol is specified for every byte.
## Reporting system errors

- Distributed I/O components which are connected via CP 3xx are not supported by "Report system error".
- The synchronization loss is detected by "Report System Error" and reported for the affected device. There is no alarm for the PNIO Controller.
- Module mode Web server CPU: After restart of a Web server CPU, the module mode will be displayed with delay.
- The synchronization loss is detected by "Report System Error" and reported for the affected device. There is no alarm for the PNIO Controller.
- Module mode Web server CPU: After restart of a Web server CPU, the module mode will be displayed with delay.
- In case of a resource shortage on CPU 3xx the module status displayed by the SFM or the Web browser when calling the SFC51 may not be up-to-date. Recommendation: You free up resources by not calling the SFC51 as frequently, for example.
- For enabling and disabling of devices via SFC 12, the modes 3 (enable) and 4 (disable) are available. The requirement is a CPU 300 with firmware status as of V2.8 or a CPU 400 with firmware status as of V5.3. The status for devices with the initial status "disabled" may be reported as incorrect until these devices will be enabled for the first time using the new mode 3.
- New as of this version: If the used CPU supports 'ALARM_D', you can reload SFM blocks even without subsequent restart. You will have to make sure that all SFM blocks are loaded so that they are consistent in themselves. For the function to become effective, you will have to restart the CPU after the very first download following a compilation with the new version, if old messages are still pending.
- **Note:** Between loading of the HW Config data and the SFM blocks, "Report System Error" will be based on incorrect prerequisites. This means you may receive incorrect reports from SFM.

## Miscellaneous

- PA slaves cannot be operated with the CP 342-5 MLFB 6GK7342-5DA00-XXXX, 6GK7342-5DA01-XXXX, 6GK7342-5DA02-XXXX and CP 342-5 FO MLFB 6GK7342-5DF00-0XE0
- If configuration modifications are made to a DP slave ET200iSP with inserted 8 DI NAMUR modules, you have to check the configuration of the 8 DI NAMUR modules following the modification, because their configuration may have also changed.

### 6.12 Hardware Configuration (PROFINET IO)

#### IM466 and CP 443-1

If IM466s and CP 443-1 Advanced are configured in a rack, all the IM466s have to be inserted between the CPU and the CP 443-1 Advanced.

#### Updating the GSD file of a PROFINET IO device

If the function **Change Release Number** function is aborted during the update of GSD files, there will be an inconsistency between the current and desired release number. This inconsistency occurs, for example if you have used an old GSD file to configure a module which is not contained in the new GSD file. In this case you should delete the device and then reconfigure it.

#### PN/PN coupler

The device names of the PN/PN coupler can only be saved to the MMC if both interfaces of the coupler are configured in the same project. The transmission of both device names to the MMC is not supported if the coupler is configured using GSD.
Configurations with CPU4xx V5.x or V6.x and more than 16 devices

For certain configurations with the CPU4xx V5.x or V6.x as PN-IO controller, individual devices may not operate.

These configurations are identified as follows:

- When the send clock of the controller is set to a value less than 1ms.
- When devices not configured using GSDML are used:
  - ET 200S
  - IM 151-3 PN with MLFB "6ES7 151-3AA10-0AB0" (from HSP0089)
  - IM 151-3 PN with MLFB "6ES7 151-3AA20-0AB0" (from HSP0098)
  - IM 151-3 PN HF with MLFB "6ES7 151-3BA20-0AB0" (from HSP0099)
  - ET 200pro
  - IM 154-4 PN HF with MLFB "6ES7 154-4AB00-0AB0" (from HSP0092)
  - More than 16 devices are configured.

Remedy:

- Set the send clock on the controller to at least 1ms or
- Configure one or more of the devices described above using GSDML or
- Increase the update time for at least one of the devices used.

Shared Device

In a shared device configuration within a project or in separate projects, you may not exceed the maximum IO configuration of the IO device regardless of the module and submodule assignment to the individual IO controllers.

Identification data with Shared Device

In a shared device, the identification data will only be available within the context of the controller that has been fully assigned the PDEV (interface and ports).

CP 1616

If a CP 1616 was configured as a PROFINET IO device with the RT class IRT (high performance) and modules from the "Isochron" catalog folder of the corresponding PROFINET IO device were used for this purpose, without the option "Operate IO device/application in isochrone mode" being enabled in the "Application" property dialog of the PN-IO module, then an error will be reported in case of a consistency check. In this case you will either have to enable the option "Operate IO device/application in isochrone mode" or update the GSDML file of the PROFINET IO device.

More details as well as an updated GSDML file are available on the web pages of Siemens Product Support.

6.13 Redundant I/O: Channel-granular Redundancy

For channel-granular redundancy, the signal modules listed below are currently approved:

<table>
<thead>
<tr>
<th>Module</th>
<th>Order number</th>
</tr>
</thead>
<tbody>
<tr>
<td>DI16xDC 24 V</td>
<td>6ES7321-7BH01-0AB0</td>
</tr>
<tr>
<td>As of product revision 2, this module can also be deactivated on a granular channel group basis. In the event of an error on one channel, the entire group (2 channels) is deactivated.</td>
<td></td>
</tr>
<tr>
<td>DO 16xDC 24 V/0.5 A</td>
<td>6ES7322-8BH01-0AB0</td>
</tr>
<tr>
<td>Module</td>
<td>Order number</td>
</tr>
<tr>
<td>------------------------</td>
<td>--------------------</td>
</tr>
<tr>
<td>This module can also be operated in channel-granular redundancy.</td>
<td></td>
</tr>
<tr>
<td>DO 16xDC 24 V/0.5 A</td>
<td>6ES7322-8BH10-0AB0</td>
</tr>
<tr>
<td>This module can also be operated in channel-granular redundancy.</td>
<td></td>
</tr>
<tr>
<td>DO 10xDC 24 V/2 A</td>
<td>6ES7326-2BF01-0AB0</td>
</tr>
<tr>
<td>As of product revision 3, this module can also be operated in channel-granular redundancy.</td>
<td>6ES7331-7NF00-0AB0</td>
</tr>
<tr>
<td>Al 8x16 Bit</td>
<td></td>
</tr>
<tr>
<td>As of product revision 10, this module can also be operated in channel-granular redundancy.</td>
<td>6ES7331-7TF01-0AB0</td>
</tr>
<tr>
<td>Al 8x0/4...20mA HART</td>
<td>6ES7331-7PE10-0AB0</td>
</tr>
<tr>
<td>AO8x12 Bit</td>
<td>6ES7332-5HF00-0AB0</td>
</tr>
<tr>
<td>As of product revision 5, this module can also be operated in channel-granular redundancy.</td>
<td></td>
</tr>
<tr>
<td>AO8x12 Bit</td>
<td>6ES7332-8TF01-0AB0</td>
</tr>
<tr>
<td>AO 8x0/4...20mA HART</td>
<td></td>
</tr>
</tbody>
</table>

**Changed characteristics for the parameters CH_INF_H and CH_INF_L des FB 453 "RED_STATUS"**

When all of the channels of a module show errors, as of v4.0 of the "Channel-granular redundancy" library the bits assigned to the channel are set to 0 in the CH_INF_H and CH_INF_L output parameters.

All parameters were set to 0 in the previous version.

You can find information about redundant I/O in the manual "Automation System S7-400H; Fault-tolerant Systems". Read the description for the procedure involved in case of failure and for exchanging the I/O or function module.

**Depassivation after a plant change in runtime**

Perform a complete passivation after changing the plant in runtime (CiR).

**Channel information bit of the FB 450 "RED_IN"**

The "Channel information available" bit in the status/force word "FB_RED_IN.STATUS_CONTROL_W" of the instance-DB of FB 450 "RED_IN" is only relevant for fail-safe modules.

**FC 450 "RED_INIT"**

FC 450 "RED_INIT" deletes all blocks configured in HW Config for the number range in the work DBs.

**Wire break detection with a HART AI module**

If the wire break detection is deactivated for a HART AI module in HW Config and a wire break is caused in a single channel, FB 453 "RED_STATUS" reports an underflow in the MODUL_STATUS_WORD.

**Reaction of FB 450 "RED_IN"**

If FB 450 "RED_IN" detects an error in a module, the affected channel is passivated. If another error occurs in the corresponding channel of the second (redundant) module before the first error is remedied, it is not shown at the CH_INF_L or CH_INF_H output parameter. The CH_L or CH_H parameter correctly shows that an error has occurred.
6.14 Hardware Diagnostics

- The hardware can only be completely diagnosed if the CPU supports special diagnostic functions. If a CPU does not have all necessary diagnostic functions, some of the diagnostics symbols are displayed with reduced contrast. If you require a complete diagnostic display, check, in this case, the version of the module using the menu command "Module Information" and ask the SIMATIC Customer Support if a firmware update for your CPU is advisable or is at all possible.

- If a station with a CR2 rack (operation in a segmented rack) is to be diagnosed, always select the CPU you want to display in the online project in the SIMATIC Manager. Depending on the CPU capabilities, the other CPU may also be displayed. If the diagnostics symbols for all modules in the station are shown grayed out, you should connect the programming device directly to the interface of the CPU you want to diagnose.

- If the error message "Download of the configuration to the programming device has been aborted" is generated, the temporary directory for system diagnosis may not be created. Solution: take care that the standard STEP 7 project directory (Siemens\Step7\S7proj) is not write protected and that enough memory is available.

   If the error message "The directory... could not be deleted." is generated, another application is blocking the deletion of the temporary project from a previous session. The hardware diagnostics will be blocked. Remedy: Close the application which is blocking the deletion of the temporary directory, and restart the hardware diagnostics.

- An H Station can only be fully diagnosed if there is an online connection to both CPUs.

6.15 MPI / PROFIBUS Network Settings

Network settings

- For MPI and PROFIBUS networks, a "highest MPI address" or "highest PROFIBUS address" (HSA) must be configured. We recommend that you use the default values recommended by STEP 7 for new projects.

  - If you want to connect to a network using a programming device/PC, you should ensure that the address of the programming device/PC does not lie above the HSA. The default value for the highest MPI address was 15 for STEP 7 V2.1 projects.

  - The other network settings must also be the same on all stations in a subnet.

  - After making changes to network settings, the configuration should be downloaded to all SIMATIC stations in this network so that the settings are the same for all stations.

- At 19.2 Kbps, no more than 8 nodes should be operated at the MPI interface of a CPU.

- If the MPI/DP interface for a CPU318 is operated as a MPI interface at 19.2 Kbps, the HSA may not be set to 126.

- To assign a PROFIBUS address to an ET 200C station, only the programming device/PC should be the master on the PROFIBUS DP. The address assignment is only possible with the CP 5512, CP 5611 and CP 5611 on-board, not with PC or TS adapters.
Caution

If you make a setting using the wrong bus parameters when you connect the programming device/PC to the bus, the bus may be subject to major disturbances to the point where other bus nodes (such as DP slaves) may fail. You must also observe the notes on PROFIBUS-DP address assignment in the section "Hardware Configuration (PROFIBUS DP)".

- Older PC and TS adapters (PC/MPI cable for MPI connection via the COM port of the PC/PG) can only be used for MPI and not for PROFIBUS (DP, universal). PC and TS adapters from V5.0 can be used with MPI and PROFIBUS up to 1.5 Mbps. The TS Adapter II can be used with MPI and PROFIBUS up to 12 Mbps.

- If your programming device/PC can only reach a module through a gateway, STEP 7 will always select the shortest path to the module. However, if communication is not possible through this gateway (line interrupted, etc.), the connection will not be established. If there is an alternative way of reaching the module through other gateways, STEP 7 will automatically attempt to establish the connection through these other gateways. The sequence in which these attempts are made can be set in the properties dialog for the STEP 7 program.

To do this, proceed as follows:

1. Open the online view of the project.
2. Navigate to the STEP 7 program associated with the CPU.
3. In the properties dialog for the STEP 7 program, open the "Addresses: Module" tab (menu command "Object Properties").
   Here you can set an alternative gateway if one is available.

Address Assignment

- The addresses of active PROFIBUS nodes must have a gap of at least one address with certain modules. In this case, STEP 7 V5.5 automatically assigns addresses which take this rule into account. For example, you have configured two CPU 315-2 DP devices without DP Master systems. These CPUs will automatically receive the PROFIBUS addresses 2 and 4. You can change these addresses, but you must then ensure you allow for the PROFIBUS address gap. This also applies to projects which you have already created with STEP 7 V2.0/2.1.

You must also take the address gap into account when assigning addresses to other active bus nodes (for example, a programming device/PC to which you assign an address using the "Setting the PG/PC Interface" application).

Caution

If you do not take into account the address gap between active bus nodes, this may cause bus nodes to malfunction or to fail completely (for example, DP slave stations).

You should note that if the address is equal to the "Maximum no. of nodes," the address 0 should not be used.

- The station address for a programming device/PC must not be set to the station address for a station on the PROFIBUS bus, such as for a DP slave
6.16 SIMATIC M7

As of MS Windows 7 as well as MS Windows 2003 Server, M7 components no longer have to be configured. You can continue to use any existing station with M7 components, however.

6.17 Ladder Logic, Function Block Diagram, and Statement List, Reference Data

Blocks and sources

- For offline blocks that were processed with version 5, you can now make changes to the interface in the incremental editor.

To do this, proceed as follows:

1. Make sure that all blocks have been compiled with version 5, generate a source file containing all the blocks, and compile this file.
2. Change the interface of the block concerned.
3. Now open all the calling blocks one after another (the corresponding calls are displayed in red).
4. Select the menu command Edit > Update Block Call.
5. Generate the relevant instance data blocks again.

- In the ASCII Editor the parameters have to be transferred in a defined order when a block is called. Changes to a block interface open online may lead to a CPU STOP.

- Function blocks generated with STEP 7 version older than V5.1 and having an OUT parameter with assembled data types, cannot be monitored as from STEP 7 V5.0 SP3 with the block status. An error is reported when you attempt to open the block.
  Remedy: Save the block with STEP 7 V5.5 and download it to the PLC.

- Function blocks generated with STEP 7 version as from V5.0 SP3 and having an OUT parameter with assembled data types cannot be edited by versions older than STEP 7 V5.0 through "Accessible Nodes."
  Remedy: Open the block in the offline project, save it and load it again.

If the changes described above are not made the block will continue to perform as before but cannot be edited.
When the changes have been made the ENO output of the block is correctly set.

Language elements
Note

- The use of high-level language constructions in Statement List, such as the following, can lead to the contents of the DB register and the address register AR1 being changed:
  - Fully-qualified data block access (for example, DB20.DBW10) as an actual parameter for a function (FC), FB and multiple instance CALL
  - Structure components of a formal parameter as operand within FCs or FBs
  - Structure components of a formal parameter as actual parameters for FC or FB can change the contents of DB register and address register AR1.

- In a function block, function, or multiple-instance CALL, RLO or accumulators 1 and 2 may not be used as additional (implicit) parameters.
- The DI register and the address register AR2 are used by the system for the function block and multiple-instance CALL and must not therefore be changed within function blocks.
- Some of the loadable standard blocks use the address register AR1.
- Within a function block, the command "L P#parameter_name" loads the address offset of the specified parameter, relative to the address register AR2. To determine the absolute offset in the instance data block of multiple-instance function blocks, you must add the area-internal pointer (address only) of the AR2 register to this value.

If you use the above programming methods and the above-mentioned registers and accumulators at the same time, you must ensure that the contents of the specified registers and accumulators is restored, otherwise this may lead to errors.

Refer to the topic "Avoiding Errors when Calling Blocks" in the Help on STEP 7 for details.

- In the instructions AW, OW, XOW, AD, OD, XOD, binary constants (such as OW 2#101010101010101) are not supported. Hexadecimal constants (such as OW W#16#AAAA) are possible.

Block parameters

- Blocks with Boolean input and in_out parameters should only be called by blocks with the property "Block Version 2." Otherwise the first Boolean input or in_out parameter may, in some cases, not be passed correctly.
- If you use Boolean output parameters of a call box as the input parameters of a second call box, the call boxes must be located in different networks or the output parameters of the first call box may have no effect as the input parameters of the other call box.
- If a parameter of the type UDTx is supplied with a data block which also has the type UDTx (entry in the symbol table: DBx UDTx), your parameter entry is rejected as a type conflict. You can still, however, transfer a DB component with the type of this UDTx.
- In the temporary variable range, only the temporary local data declared by the user can be used for programming. This should also be noted when using blocks from optional software packages in Statement List, Function Block Diagram, and Ladder Logic programs.

Reference data

- The time required to display the view selected for reference data depends greatly on the number of entries to be displayed. For very long programs you can restrict the number of reference data using the menu command Options > Reference Data >
Filter in the SIMATIC Manager. In the filter for the cross references you should only select the address and value ranges relevant for your requirements.

When the reference data are generated, the following addresses are not included:

1. Address in the form of a formal parameter, for example: SP / CU <parameter name>
2. Addresses from register-indirect statements
3. Addresses from memory-indirect statements
4. Local data
5. Data blocks opened with OPN Dlx are displayed in the program structure as OPN DBx

- After rewiring block calls the reference data may no longer be valid. Therefore, you must always generate the reference data after rewiring.
- In the program editor, (LAD, FBD, STL), a window displays the use locations for the addresses in the current network in the entire program (menu command View > Details; "Cross-reference” tab). This section of the cross-reference list (reference data) contains neither cross-references for partially qualified access to data blocks nor any pointer accesses.
- The "Unused symbols" view for the reference data lists the symbols that are not used in the S7 program. If you have assigned attributes, such as messages for display devices, to symbols, be sure to look in the symbol table before deleting unused symbols (column "M" for "message properties") to verify that these symbols are, in fact, not needed for a display device. This also applies to the "O" attributes (Operator Control and Monitoring with WinCC) and "C" attributes (Communication Properties).

**Note**

The scope of the reference data you want to display has been extended to include far more information as of STEP 7 V5.0. If you have programs whose reference data were generated in an older STEP 7 version, generate the reference data again in the SIMATIC Manager using the menu command Options > Reference Data > Generate.

A filter determines which data are selected and how they are represented for the various views of the reference data. If you want to check the default filter settings and make any changes you require before the reference data are displayed, select the menu command Options > Reference Data > Filter in the SIMATIC Manager.

### 6.18 Translating Texts

**Copying objects**

If objects are copied from project to project with configured display texts (for example, message blocks, symbol tables with assigned messages), you should make sure that the required display languages are available in the target project (check using the menu command Options > Language for Display Devices). Not all the display languages which exist in the source project will be created automatically in the target; instead, only the texts whose languages have been created in the target object are copied.
6.19 Managing Multilingual Texts

Importing display texts (menu command Options > Manage texts in several languages > Import):

When importing display texts (S7UserTexts, S7SystemTextLibrary and S7UserTextLibrary) it is possible that an access error is reported in the log file <import.txt>, because the operating system may still be causing internal process to access this object. In this case repeat the importing process under observation of the specifications below. The access error should then no longer occur.

Ensure that no editors or applications are opened with the above-mentioned objects (editors from the main menu Options > Text Libraries > User Library or System Library for user texts or system text libraries).

Before importing always close the log file <export.txt>. If <export.txt> is opened, an access error can occur while display texts are being imported.

For the function "Managing multilingual texts" you can use a Microsoft Office Excel version as of EXCEL 97 SR2 up to and including version 2007.

6.20 Converting S5 Programs to S7 Programs

- When converting S5 programs to S7 programs, the special instructions for the CPUs in the SIMATIC S5-135U and SIMATIC S5-155U series are not taken into account.
- The blocks in the library "FBLIB1" (visible in the SIMATIC Manager using File > Open > Libraries under "Standard Library V3.x") are only intended for converting existing S5 programs to S7 programs. They must not be used in new S7 programs.
- When using the standard function blocks FC100 through FC111, the I/O addresses should be noted (see also the online help on these blocks). The update of the process image is dependent on the S7 CPU. If you assign a part I/O address (between 1 and 8) to the address, these addresses are not taken into account in the cyclic process-image update.
- It is recommended that you select landscape format for printing out converted S5 programs. With A4 portrait format, the characters at the end of a line may be printed in the next line.
- You cannot convert S5 data to STEP 7 if the data are on write-protected media; for example, on read-only diskettes.

Remedy:
- First copy the S5 data to a directory which is not write-protected.
- Then start the Converter and convert the copies.

6.21 Converting TI Programs to S7 Programs

The following points apply to the operating system used to date, under MS Windows 7 the TI converter is no longer installed.
- A tool for converting TI programs to S7 programs is supplied. A manual in electronic form (English only) is supplied with this tool.
- The TI converters can be started as usual from the Windows taskbar ("Start/SIMATIC/STEP 7").
• The library "TI-S7 Converting Blocks" (visible in the SIMATIC Manager via File > Open > Library Standard Library V3.x") contains the standard routines for use in converted TI programs.

• If the function FC80 is called several times one after the other, the output variable "Q" may not be supplied by DB variables or local data.

• When using the functions FC94 and FC95, the parameters IN and OUT cannot both point to data blocks at the same time.

• When using the function FC104, the parameters TBL1 and TBL2 cannot point to data blocks.

• The function FC102 can only be used with REAL data types (B#16#08). It will not work with INT or DINT data types.

• The following TI systems are supported:
  - TI 405
  - TI 505

6.22 Fault-tolerant Systems

If you want to configure several redundant S7 connections to a fault-tolerant system, please take into account that is can take longer to establish all the connections than is permitted under the configured maximum communication delay. If this is the case, please increase the value "Maximum communications delay [ms]" in the fault-tolerant parameter properties of the CPU.

6.23 Note on Using Foreign-Language Character Sets

In projects and libraries you can use foreign-language character sets that do not correspond to the language set in STEP 7. The prerequisite for this being that the desired character set is correspondingly installed in the operating system. For this, please observe Chapter "Using Foreign-Language Character Sets" in the Help for STEP 7 (refer to Chapter “Setting Up and Editing the Project ”).

In addition to the Help, the following information must also be observed:

• The following foreign-language character sets have been tested for applicability under the MUI variations of the approved Windows operating systems:
  - Japanese
  - Chinese (simplified)
  - Korean
  - Russian
  - Greek

Other languages are generally possible, however an unlimited applicability cannot be guaranteed.

• The operating system option "Extend support of advanced text services to all programs" must not be enabled (for example, under Windows XP Control Panel/Regional Options and Language Settings/Details/Advanced).

• The option "Upper Case/Lower Case" is offered in "Search/Replace" dialog , even if the foreign language being used does not recognize differences (e.g. visual languages of Japanese and Chinese).
With input fields that only allow numerical inputs, only one-byte figures are permitted (relevant with visual languages like Japanese and Chinese).

When uploading a station, note that text that has been saved on a CPU can only be correctly displayed on Windows that has been installed in the same language.

Please note that CPU passwords may only contain ASCII characters.

In order to avoid display errors (e.g. with umlauts) on the interface, it is recommended to use STEP 7 with English as its interface language.

STEP 7 may not be installed in a directory the path of which includes characters that are not listed in the ASCII character set.

The PID control, S5/S7 converter and TI converter do not support foreign-language character sets.

Furthermore, foreign-language characters are not permitted in variable names in the LAD/FBD/STL editor.

When using optional packages, particularly language editors, you should ensure that these also support foreign-language input. Otherwise, the characters could become distorted when displayed or printed. If in doubt, items in the optional package should not be opened via the Recent File List, but via the open browser.

Please note that sources and blocks in the statement part use characters from the English character set exclusively (ASCII characters 0x2a - 0x7f). Especially blank spaces that are not entered in the specified character set are not interpreted as blank spaces and can lead to errors in the program.

Please note that when inserting external sources (function in SIMATIC Manager), the file name and directory name may only contain characters from the ASCII character set 0x2a - 0x7f.

Please note that for symbolic addressing, the symbolic names have to be written in quotation marks ("symbolic name >").

Note on the use of SIMATIC Logon

Use the SIMATIC Logon Product, use at least V1.4 SP1. For operation of SIMATIC Logon under MS Windows 7 you need at least version V1.4 SP3. Also pay attention to the information provided in this product.

Additional notes:

Furthermore, a project password is available for opening projects. This is primarily for administrators, to transfer protected projects between the Windows domains, for example. Please note that when opening a project, a logged on user via Extras > SIMATIC Logon Services is entered in the project as an administrator, via a password.

STEP 7 supports the default settings of "Configure SIMATIC Logon". Changing these settings may result in unexpected problems with access-protected projects.

Note when using SIMATIC Logon that a user remains logged on even after closing the last project. The user is fully logged off with "SIMATIC Manager > Options > SIMATIC Logon Service --> Log off".

Change log

Users need the necessary rights in the file system to display the change log.

Possible cause and remedy see "Security settings" in section 3.1 Operating Environment / File system.

Default User in SIMATIC Logon
Make sure that a "default user" set up in SIMATIC Logon has access to all protected projects. The role "default user" includes all users of the PC in use.

6.25 Command Interface

- When using command interfaces under Microsoft .net, we recommend you access object collections within loops for intermediate variables.
- If you set the "VerbLogFile" property at the SIMATIC object, messages for the symbol import will be recorded in the log file and not in the file (as was previously the case).
- When using the command interface, you will have to note the following when installing older CPs (e.g. 342-5, 443-5):
  - For such CPs use a number with the format "XY0" (e.g. "100") instead of the firmware version "VX.Y" (e.g. "V1.0").
  - For CPs with firmware versions of the type "product version X-X" (e.g. "1-5") use the format "X00" (e.g. "200").

6.26 TCI – Tool Calling Interface

As of STEP 7 V5.4 SP4, the TCI standard V1.1 is supported. Use a TCP/IP direct connection to communicate with PROFINET IO devices. You can access DP slaves with the data record routing.

6.27 Special Characteristics of the MS Windows 7 Operating System

Note that MS Windows 7 offers an extended protection concept.

This means that access to protected areas of the file system, such as the directories "Programs" and "Windows", are virtualized. Your data will be forwarded by the operating system in such a case to user-specific areas.

Note that the software under MS Windows 7 is no longer available at "Start menu> SIMATIC", but under "Start menu > Programs > Siemens Automation > SIMATIC". This change is caused by the current architecture of MS Windows 7. Any information listed in the documentation and online help has to be interpreted accordingly.

Setting the access rights in the operating system

Important changes have been made to the MS Windows 7 safety concept in STEP 7 V5.5. This concept is used in case of a new installation (STEP 7 has never been installed on this computer). In this case, most settings, such as the STEP 7 language and mnemonic method are user-defined. This means users can make settings using a PC and their login information. An exception is the setting of the configuration language for the PG/PC interface.

A user group "Siemens TIA Engineer" will be created under MS Windows 7. The installer will automatically be added to this user group. Users from this user group have additional rights, such as configuration of the PG/PC interface and installation of the hardware support packages as well as for global setting of the STEP 7 language and mnemonic for all users of the "Siemens TIA Engineer" group. This language setting does also apply for the configuration of the PG/PC interface.

For manual IP configuration of the PGs (for PROFINET without DHCP), the user must also be added to the preinstalled user group "Network configuration operators".

The administrator has to assign these user rights.
Access rights in project directories
See "Security settings" in section 3.1 Operating environment / File system.

Project files on network drives
If several users work on the same project saved on a network drive at the same time, MS Windows 7 clients may not recognize changes made to blocks by other users. Possible remedies include a restart of STEP 7 on the MS Windows 7 client or deactivation of the opportunistic locking of the respective PG/PC. The latter influences the performance of the client. Given this background, we do not recommend that several users work on the same project simultaneously.

User account control
Der Betrieb von STEP 7 V5.5 under MS Windows 7 ist enabled (3 Stufen möglich) als auch disabled (nie benachrichtigen) user account control (UAC) möglich.

Following the conversion of the user account control (e.g. by UAC conversion of a program installed by the system administrator), some of the settings made by the user may no longer be present. The position and size of the application windows may, for example, be reset to older (default) values. Some of the projects processed by the user may no longer be visible. You will have to enter them once again in the project management of STEP 7 (SIMATIC Manager > Open Project > Find).

Set up domain global user group "Siemens TIA Engineer"
For operation in a domain, you can create a domain global user group that will be mapped to the local user groups "Siemens TIA Engineer" and "Network configuration operators".

The following prerequisites will have to be met:

- The domain administrator has created a domain global user group.
- The domain administrator has added users to the domain global user group whose login will be used for access to STEP 7.

Editing projects
You need at least "Siemens TIA-Engineer" rights to reconfigure the PG/PC interface.

These rights are also required for the following example:

A project can include an implicit configuration of the PG/PC interface (PG/PC).

If the PG/PC interface in such a project was implicitly reconfigured by a user with "Siemens TIA-Engineer" rights, then operators with user rights will not be able to undo this configuration. This means you will not be able to work online again until an operator with Siemens TIA-Engineer" rights has reconfigured the PG/PC interface. Otherwise operators will see the following alarm: "Insufficient user rights for operation of STEP 7".

---

Note
Do not use the hibernate / standby function under MS Windows 7.
7 Notes on Documentation

Comprehensive documentation on STEP 7 is available to you in the online help for STEP 7. The "basic information" on STEP 7 is contained in the HTML-based "Help on STEP 7".

The basic information and the reference information are both available to you as electronic manuals.

This means that you have the choice between calling information exclusively from the online help or by printing out individual chapters in order to read this information later on.

Manuals

The manuals for STEP 7 can be accessed for example, under Windows XP, at Start > SIMATIC > Documentation. They can be displayed and printed with a PDF reader, which is supplied with the STEP 7 software.

Due to the editorial deadline necessary in the creation of the product manuals, there may be an occasional slight difference between their content and that of the online help.

Up-to-date information:

When reading references to the Start menu, keep in mind the form of the Start menu differs under the various operating systems.