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法律资讯

警告提示系统

为了您的人身安全以及避免财产损失，必须注意本手册中的提示。人身安全的提示用一个警告三角表示，仅与财产

损失有关的提示不带警告三角。警告提示根据危险等级由高到低如下表示。

危险

表示如果不采取相应的小心措施，将会导致死亡或者严重的人身伤害。

警告

表示如果不采取相应的小心措施，可能导致死亡或者严重的人身伤害。

小心

表示如果不采取相应的小心措施，可能导致轻微的人身伤害。

注意

表示如果不采取相应的小心措施，可能导致财产损失。

当出现多个危险等级的情况下，每次总是使用最高等级的警告提示。如果在某个警告提示中带有警告可能导致人身

伤害的警告三角，则可能在该警告提示中另外还附带有可能导致财产损失的警告。

合格的专业人员

本文件所属的产品/系统只允许由符合各项工作要求的合格人员进行操作。其操作必须遵照各自附带的文件说明，特

别是其中的安全及警告提示。 由于具备相关培训及经验，合格人员可以察觉本产品/系统的风险，并避免可能的危

险。

按规定使用 Siemens 产品

请注意下列说明：

警告

Siemens 产品只允许用于目录和相关技术文件中规定的使用情况。如果要使用其他公司的产品和组件，必须得到 
Siemens 推荐和允许。正确的运输、储存、组装、装配、安装、调试、操作和维护是产品安全、正常运行的前提。

必须保证允许的环境条件。必须注意相关文件中的提示。

商标

所有带有标记符号 ® 的都是西门子股份有限公司的注册商标。本印刷品中的其他符号可能是一些其他商标。若第三

方出于自身目的使用这些商标，将侵害其所有者的权利。

责任免除

我们已对印刷品中所述内容与硬件和软件的一致性作过检查。然而不排除存在偏差的可能性，因此我们不保证印刷

品中所述内容与硬件和软件完全一致。印刷品中的数据都按规定经过检测，必要的修正值包含在下一版本中。

Siemens AG
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德国
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前言 1
PCS 7 入门指南 - 新手上路文档相关信息     

入门指南 - 新手上路文档使用简单易懂的实例项目说明 SIMATIC PCS 7 软件组件的基本

原理以及它们在工程和过程模式环境中是如何互相作用的。

本入门指南文档仅作简介使用，因此不含详细信息或背景信息。 如果本入门指南的信息引

起了您对 SIMATIC PCS 7 的兴趣，我们建议您关注一下针对初学者的《过程控制系统 
PCS 7，入门指南第一部分》。

约定

说明

在本文档中，软件界面元素的名称使用的语言与本文档的语言一致。 如果为该操作系统安

装了多语言软件包，某些名称在切换语言后将会以操作系统的基本语言显示，因此，与文

档中所用的名称不同。

在 PCS 7 中，许多情况下都可以使用 Windows 标准功能：

● 使用“CTRL”和“Shift”键来选择多项

● 通过单击列标题排序表中各列

● 使用拖放功能取代复制和粘贴

入门指南中的每个教程之间都是环环相扣的，所以您可以逐步创建自己的完整 PCS 7 项目。 
为此，需要按指定顺序完成所有教程。

本入门指南文档的用途

本文档旨在引导您快速有效地掌握 SIMATIC PCS 7 的基本知识。您将了解许多基本组态

步骤，以及 SIMATIC PCS 7 是如何在过程中工作的。

入门指南（V8.1 版本，含 APL）
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PCS 7 入门指南- 新手上路文档的要求

在任何装有以下软件的 PC 或编程设备上可以执行“fast_MP”示例项目：

● 操作系统、Internet Explorer、消息队列服务和 SQL 服务器（更多相关信息，请参见手

册《过程控制系统 PCS 7；PCS 7 PC 组态》(Process Control System PCS 7; PCS 7 
PC configuration) 和《过程控制系统 PCS 7；发布的模块》(Process Control System 
PCS 7; Released Modules)）

● 安装 SIMATIC PCS 7 工程师站 (Process Control System; SIMATIC PCS 7 DVD)

● 许可证密钥

● 用于模拟 SIMATIC S7-400 自动化系统的 S7 PLCSIM

访问 PCS 7 文档的方式

可在以下位置找到 PCS 7 文档：

● Process Control System; SIMATIC PCS 7 DVD 上

● 安装后的计算机上

● Internet 上

完整版本的文档可在“SIMATIC PCS 7 技术文档”网站找到：www.siemens.de/pcs7-
dokumentation (www.siemens.com/pcs7-documentation)

说明

PCS 7 自述文件（Internet 版本）

Internet 上的 PCS 7 自述文件中提供的信息优先于所有 PCS 7 文档。 
请仔细阅读该 PCS 7 自述文件；其中包含有关 PCS 7 的重要信息和修正。

前言
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Process Control System; SIMATIC PCS 7 DVD 上的 PCS 7 文档

● PCS 7 自述文件（DVD 版本）

Process Control System; SIMATIC PCS 7 DVD 中的 PCS 7 自述文件包含有关 PCS 7 
的重要信息，其优先级高于随产品所提供的 PCS 7 文档。 安装 PCS 7 后，可在 
Windows“开始”(Start) 菜单的以下路径下找到《过程控制系统 PCS 7；PCS 7 自述文

件》(Process Control System PCS 7; PCS 7 Readme) 文档：

“Siemens Automation > SIMATIC > 产品说明 > <语言>”(Siemens Automation > 
SIMATIC > Product Notes > <language>)

● 可在以下位置找到最重要的 PCS 7 系统文档：

– SIMATIC PCS 7 DVD 中的“_Manuals”文件夹

– 工程师站上 SIMATIC Manager 应用程序的在线帮助（CHM 文件）

– 工程师站上 Windows“开始”(Start) 菜单的以下路径下的 PDF 文件：

“Siemens Automation > SIMATIC > 文档 > <语言>”(Siemens Automation > SIMATIC 
> Documentation > <language>)

说明

包括以下 PCS 7 系统文档：

● 目录一览《过程控制系统 PCS 7；PCS 7 文档》(Process Control System PCS 7; 
PCS 7 Documentation)

● 组态手册《过程控制系统 PCS 7；工程组态系统》(Process Control System PCS 7; 
Engineering System)

● 功能手册《过程控制系统 PCS 7；PCS 7 - PC 组态》(Process Control System PCS 
7; PCS 7 - PC Configuration)

● 组态手册《过程控制系统 PCS 7；操作站》(Process Control System PCS 7; Operator 
Station)

● 功能手册《过程控制系统 PCS 7；OS 过程控制》(Process Control System PCS 7; 
OS Process Control)

● 产品文档随相关产品一起安装。

前言
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Internet 上的 PCS 7 文档（最新版本）

最新版本的 PCS 7 文档可在“SIMATIC PCS 7 技术文档”网站的以下位置找到：

● 在“SIMATIC PCS 7 的软件手册 ...”部分中

– 特定 PCS 7 版本的最新系统文档和产品文档的链接。

– 最新的系统文档“PCS 7 文档门户安装程序”的下载链接。

说明

PCS 7 文档门户安装程序

安装程序包含完整的 PCS 7 系统文档（PDF 文件和在线帮助）。

● 无需 PCS 7 即可运行此安装程序。

● 在工程师站上运行此安装程序时（完全安装和覆盖安装 - 选择原始安装文件夹时），
将更新以下文档：

– “SIMATIC Manager”应用程序的在线帮助：（CHM 文件）

– Windows 开始菜单中的 PCS 7 系统文档：
Siemens Automation > SIMATIC > 文档 > 语言 > PDF 文件

● PCS 7 新闻快讯将通知您新版本的系统文档何时可用。

– 我的文档管理器 (http://support.automation.siemens.com/CN/view/zh/38715968)中
手册汇集形式的完整 PCS 7 文档的下载链接。

手册汇集包括硬件和软件手册。

● 在“SIMATIC PCS 7 ... 的硬件手册”部分中

– 批准用于某个 PCS 7 版本的组件的最新手册的链接。

– 批准用于 PCS 7 的 SIMATIC PCS 7 工业软件的最新手册的链接。

目录、小册子、客户杂志和演示软件

此信息在以下 Internet 地址提供： 信息和下载中心 (http://www.automation.siemens.com/
mcms/infocenter)

PCS 7 入门指南- 新手上路文档的元素

本文档以在线帮助的形式提供，还可打印输出为硬拷贝 PDF。 对于在 PC 上进行组态的情

况建议使用打印的 PDF 版本。 

安装 SIMATIC PCS 7 后，即可在“开始”(Start) 菜单的 SIEMENS SIMATIC 文档下找到在

线帮助和可打印的手册。 

祝您成功！

SIEMENS 公司

前言
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创建 PCS 7 项目 2
2.1 如何创建 PCS 7 项目

简介         

利用 PCS 7 的“新建项目”(New Project) 向导，只需单击几下鼠标即可创建新的 PCS 7 多
项目。

要求

● 已安装 PCS 7 V8.0 或更高版本以及相关的授权密钥。

● 已安装 S7-PLCSIM V5.4 或更高版本。

步骤

步骤 操作

1 在“开始”(Start) 菜单中的 SIEMENS SIMATIC 产品下选择菜单命令 
SIMATIC Manager，或者双击桌面上的以下图标：

SIMATIC Manager 将启动。

2 如果项目在 SIMATIC Manager 中仍处于打开状态，则选择菜单命令“文件”(File) 
>“关闭”(Close)，直到关闭所有项目。

3 选择“文件 > 新建项目向导...”(File > New Project Wizard)。
程序将启动 PCS 7 的“新建项目向导”。

4 在步骤 1(4) 中：

单击“下一步”(Next)。

5 在步骤 2(4) 中：

● 选择 CPU“AS 414-3IE”。

● 选择产品包 6ES7654**D10-3BC* E-STAND:5。
● 从“通讯模块数”(Number of communication modules) 下拉列表中选择“0”。

● 单击“下一步”(Next)。

入门指南（V8.1 版本，含 APL）
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步骤 操作

6 在步骤 3(4) 中：

● 从“工厂层级”(Plant hierarchy) 组的“层级数”(Number of levels) 字段选择

“3”。

● 选中

“AS 对象”(AS objects) 组中的“CFC 图表”(CFC chart) 和“SFC 图表”(SFC 
chart) 复选框。

● 在“OS 对象”(OS objects) 组中，选中“PCS 7 OS”复选框，然后选择“单站

系统”(Single station system) 单选按钮。

● 单击“下一步”(Next)。

7 在步骤 4(4) 中：

● 在“目录名称”(Directory name) 输入框中，输入“fast”。

● 如果需要，为项目选择其它存储位置。

● 单击“生成”(Make)。

8 若是采用标准方式安装 PCS 7 且未作任何更改，将显示“选择消息号分配”
(Message Number Assignment Selection) 对话框。

注：

在 SIMATIC Manager 中，可以调整为新项目分配消息号的默认设置（标准设置

是“总是请求设置”）。

1. 选择“选项 > 自定义 ...”(Options > Customize ...)。
2. 在“消息号”(Message numbers) 选项卡中，按如下所述更改未来项目/库的

默认设置：

– 选择“分配面向 CPU 的唯一消息编号”(Assign CPU-oriented unique 
message numbers) 单选按钮。

– 如果指定的设置与默认设置不同，则 PCS 7 向导不再提示选择消息号分

配。

3. 单击“确定”(OK)。

9 完成后向导将自动关闭，同时将在 SIMATIC Manager 中显示工厂视图和组件视

图。

关闭工厂视图，选择“视图 > 过程对象视图”(View > Process Object view)。

10 选择“窗口 > 排列 > 垂直平铺”(Window > Arrange > Tile vertically)。
“过程对象视图”(Process Object view) 和“组件视图”(Component view) 窗口

将垂直平铺。

创建 PCS 7 项目

2.1 如何创建 PCS 7 项目

入门指南（V8.1 版本，含 APL）
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说明

通过在 SIMATIC Manager 中选择菜单命令“选项 > 自定义 ...”(Options > Customize ...)，
可以从“设置”(Settings) 对话框的“视图”(View) 选项卡的“默认项目视图”(Default project 
view) 条目中选择打开项目时要显示的视图。

结果

在 SIMATIC Manager 中成功创建了包括 SIMATIC 400 站、SIMATIC PC 站和主数据

库“fast_Lib”的多项目“fast_MP”。 新的多项目将显示在 SIMATIC Manager 的过程对象

视图和组件视图中。

创建 PCS 7 项目

2.1 如何创建 PCS 7 项目
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创建 PCS 7 项目

2.1 如何创建 PCS 7 项目
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组态硬件和网络 3
3.1 如何组态硬件

简介         

PCS 7 向导已创建了一个 SIMATIC 400 站、一个 SIMATIC PC 站和一个主数据库。 
在 HW Config 中执行以下组态步骤：

● 创建通信接口。

● 将硬件模块从硬件目录添加到自动化系统中。

要求

● 已创建 PCS 7 多项目“fast_MP”。

步骤

步骤 操作

1 在组件视图中选择 SIMATIC 400 站，然后选择菜单命令“编辑 > 打开对象”
(Edit > Open Object)。
将打开 HW Config。

2 打开 CPU 414-3 模块上 X5 连接器 (PN-IO) 的快捷菜单，然后选择菜单命令“对

象属性”(Object properties)。
将打开“属性 - PN-IO (R0/S3.5)”(Properties - PN-IO (R0/S3.5)) 对话框。

入门指南（V8.1 版本，含 APL）
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步骤 操作

3 ● 打开“常规”(General) 选项卡。

● 单击“接口”(Interface) 区域的“属性”(Properties) 按钮。

将打开“属性 - 以太网接口 PN-IO (R0/S3.5)”(Properties - Ethernet interface 
PN-IO (R0/S3.5)) 对话框。

● 将“IP 地址”(IP address) 输入字段中的条目更改为计算机地址范围内的一个空

闲地址。

注： 可通过命令行程序“ipconfig”获取有关计算机地址范围的信息。

● 单击“子网”(Subnet) 区域的“新建”(New) 按钮。

将打开“属性 - 新子网工业以太网”(Properties - New Subnet Industrial 
Ethernet) 对话框。

● 在“名称”(Name:) 输入字段中输入名称，如“Plant bus”。

● 在“属性 - 新子网以太网”(Properties - New Subnet Industrial Ethernet) 对话

框中单击“确定”(OK)。 对话框关闭。

● 在“属性 - 以太网接口 PN-IO (R0/S3.5)”对话框中，“子网”(Subnet) 区域

的列表随即会显示“Plant bus”条目。

● 单击“确定”(OK)。 对话框关闭。

● 在“属性 – PN-IO (R0/S3.5)”对话框中单击“确定”(OK)。 对话框关闭。

4 ● 如果没有显示硬件目录，则请选择菜单命令“视图 > 目录”(View > Catalog)。
● 在“配置文件”(Profile) 下拉列表中选择当前的 PCS 7 版本。

● 在硬件目录中，打开“PROFIBUS DP”文件夹。

● 打开 "ET 200M" 文件夹并选择 "IM 153‑2" 模块。 将该模块拖放到“DP 主站

系统”(DP master system) 总线。

将打开“属性 - PROFIBUS 接口 IM 153-2”(Properties - PROFIBUS Interface 
IM 153-2) 对话框。

● 单击“确定”(OK)。
将应用默认设置。

组态硬件和网络
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步骤 操作

5 ● 在硬件目录中，单击 "IM 153-2"  文件夹左侧的加号。

● 打开 "AI-300" 文件夹并将模块

"SM 331 AI8x12Bit" (6ES7 331-7KF02-0AB0) 
拖到 IM 153-2 组态表底部的插槽 4。
关闭 "AI-300" 文件夹。

提示：

在硬件目录中选中模块时，部件编号会显示在屏幕下方的信息框内。

● 打开 "AO-300" 文件夹并将模块

"SM 332 AO4x12Bit" (6ES7 332-5HD01-0AB0) 
拖到 IM 153-2 组态表底部的插槽 5。
关闭 "AO-300" 文件夹。

● 打开 "DI-300" 文件夹并将模块

"SM 321 DI16xDC24V" (6ES7 321-1BH02-0AA0) 
拖到 IM 153-2 组态表底部的插槽 6。
关闭 "DI-300" 文件夹。

● 打开 "DO-300" 文件夹并将模块

"SM 322 DO16xDC24V/0,5A" (6ES7 322-1BH01-0AA0) 
拖到 IM 153-2 组态表底部的插槽 7。
关闭 "DO-300" 文件夹。

6 通过菜单命令“站 > 保存”(Station > Save) 保存至此所作的更改。

组态硬件和网络
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结果

在 HW Config 中，ET 200M 分布式 I/O 站的冗余可用接口模块 IM 153‑2  中增加了几个模

拟/数字输入/输出模块。

组态硬件和网络

3.1 如何组态硬件
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3.2 在 HW Config 中编辑符号

3.2.1 如何编辑模拟输入模块的符号

简介         

要为“AI8x12Bit”模拟输入模块的地址指定名称，应在“编辑符号”(Edit symbols) 对话框中

为每个地址指定符号名称和注释。

要求

● 已在 HW Config 中组态模拟输入模块。

● HW Config 已打开。

步骤

步骤 操作

1 在组态表中，打开插槽 4 中模拟量输入模块的快捷菜单，并选择菜单命令“编

辑符号...”(Edit symbols...)。

2 在“符号”(Symbol) 列中为第一个地址 (EW 512) 输入“PIDCTRL1-PV_IN”，并

使用制表键将光标移到“数据类型”(Data type) 列，然后再移到“注释”
(Comment) 列。 在“注释”(Comment) 列中再次输入“符号”(Symbol) 列中的符

号名称。

提示： 复制“符号”(Symbol) 列中输入的名称，并将其粘贴到“注释”(Comment) 
列中。

3 以同样的方式，为其余地址输入符号名称和注释：

● 第二个地址 (EW 514)： “PIDCTRL2-PV_IN”
● 第三个地址 (EW 516)： “PIDCTRL1-LMNR_IN”
● 第四个地址 (EW 520)： “PIDCTRL2-LMNR_IN”

4 单击“确定”(OK)。
将应用设置并关闭对话框。

组态硬件和网络
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结果

3.2.2 如何编辑模拟输出模块的符号

简介    

要为“AO4x12Bit”模拟输出模块的地址指定名称，应在“编辑符号”(Edit symbols) 对话框

中为每个地址指定符号名称和注释。

其方法与模拟输入模块的方法相同。

输入下图所示的符号名称和注释。

要求

● 已在 HW Config 中组态模拟输出模块。

● HW Config 已打开。

组态硬件和网络
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结果

3.2.3 如何编辑数字输入模块的符号

简介        

要为“DI16x24V”数字输入模块的地址指定名称，应在“编辑符号”(Edit symbols) 对话框

中为每个地址指定符号名称和注释。

其方法与模拟输入模块的方法相同。

输入下图所示的符号名称和注释。

要求

● 已在 HW Config 中组态数字输入模块。

● HW Config 已打开。

组态硬件和网络
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结果

3.2.4 如何编辑数字输出模块的符号

简介        

要为“DO8xDC24V/0.5A”数字量输出模块的地址指定名称，应在“编辑符号”(Edit Symbols) 
对话框中为每个地址指定符号名称和注释。

其方法与模拟输入模块的方法相同。

输入下图所示的符号名称和注释。

要求

● HW Config 中已组态数字输出模块。

● HW Config 已打开。

组态硬件和网络
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结果
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3.3 设置 PC 接口

3.3.1 如何设置 SIMATIC PC 站的以太网接口

简介         

为了使用 S7-PLCSIM，必须设置 SIMATIC PC 站的以太网接口，以便可以编译 OS 变量

并可在用于 PLCSIM 的 AS 和 OS 之间建立连接。

要求

● 已使用 PCS 7 向导创建了 PCS 7 的“fast_MP”项目。

● 已在组件视图中打开 SIMATIC Manager。

步骤

步骤 操作

1 在组件视图中，在“fast_Prj”文件夹中选择 SIMATIC PC 站，然后选择菜单命

令“编辑”(Edit) >“打开对象”(Open Object)。
将打开 HW Config。

2 ● 如果没有显示硬件目录，则选择菜单命令“视图 > 目录”(View > Catalog)。
● 在“配置文件”(Profile) 下拉列表中选择当前的 PCS 7 版本。

● 打开硬件目录中的以下文件夹： “SIMATIC PC 站 > 工业以太网 CP > IE 常
规”(SIMATIC PC Station > CP Industrial Ethernet > IE General)。

● 将最新版本的“SW V...”模块拖放到插槽“1”中。 将打开“属性 - 以太网接

口 IE 常规 (R0/S1)”(Properties – Ethernet Interface IE General (R0/S1)) 对
话框。

● 选中“IP 协议正在使用”(IP protocol is being used) 复选框。

● 将“IP 地址”(IP address) 输入字段中的条目更改为计算机的 IP 地址。

● 清除“设置 MAC 地址/使用 ISO 协议”(Set MAC address/use ISO protocol) 
复选框。

● 从“子网”(Subnet) 列表中选择“工厂总线”(Plant bus) 条目。

● 单击“确定”(OK)。对话框关闭。

3 选择“站”(Station) >“保存并编译”(Save and Compile) 命令。

4 选择“站”(Station) >“退出”(Exit) 命令。

组态硬件和网络
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结果
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3.4 在 Netpro 中保存并编译数据

3.4.1 如何保存并编译 NetPro 组态

简介       

NetPro 将接受用户在 HW Config 为 OS 以太网接口组态的设置。 现在请保存、编译和检

查网络组态。

要求

● HW Config 中已完成组态。

步骤

步骤 操作

1 在组件视图中，选择 SIMATIC Manager 左侧窗口中的“fast_Prj”项目。 

2 在 SIMATIC Manager 的右侧窗口中，双击“工厂总线”(Plant bus) 对象。

将打开“NetPro”对话框。

3 在 NetPro 中选择菜单命令“网络”(Network) >“保存并编译...”
(Save and Compile)。
将打开“保存并编译”(Save and Compile) 对话框。 

4 激活“编译并检查全部内容”(Compile and check everything) 单选按钮并

单击“确定”(OK)。

5 关闭“一致性测试的输出”(Output for Consistency Testing) 对话框。

组态硬件和网络
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结果

组态硬件和网络
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3.5 启动 S7 PLCSIM

3.5.1 如何启动 S7-PLCSIM

简介         

S7-PLCSIM 启动后，即可将 HW Config 中组态的以太网接口从 NetPro 下载到 PLC。

要求

● HW Config 中已完成组态。

● NetPro 的网络组态已保存、编译和检查。

步骤

步骤 操作

1 切换到 SIMATIC Manager 窗口。

2 选择菜单“选项”(Options) >“仿真模块”(Simulate Modules)。
将打开“S7 PLCSIM1”对话框。

3 从工具栏的下拉列表中选择“PLCSIM(TCP/IP)”条目。

4 确保 CPU 处于“STOP”状态。

5 使用任务栏，返回到 NetPro。

组态硬件和网络
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3.6 下载目标系统

3.6.1 如何将以太网接口从 NetPro 下载到 PLC

简介             

以下部分介绍如何将 HW Config 中组态的以太网接口从 NetPro 下载到 PLC。

要求

● HW Config 中已完成组态。

● NetPro 处于打开状态。

● S7-PLCSIM 已经启动，而且 CPU 处于“STOP”状态

步骤

步骤 操作

1 在 NetPro 的网络视图中，单击“CPU 414-3 PN/DP”接口上的 AS“SIMATIC 
400(1)”符号。 

2 打开上下文菜单并选择菜单命令“下载到当前项目 > 所选站”(Download 
to current project > Selected stations)。

3 在出现的警告对话框中单击“是”(Yes) 按钮。

4 选择菜单命令“网络”(Network) >“退出”(Exit)。 

NetPro 关闭。

组态硬件和网络
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结果

组态硬件和网络
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组态过程标签和顺序控制 4
4.1 如何将 CFC 图表从 Zip 文件复制到主数据库

简介             

使用 PCS 7 AP Library Vxx 中的以下模块进行组态：

● MotorLean

● PIDConL_ConPerMon

● ValveLean

要求

● 已在组件视图中打开 SIMATIC Manager。

● 已使用 PCS 7 向导将 PCS 7 项目 "fast_MP"  创建为一个多项目并已打开该项目。

● 已打开“fast_Lib”下的“S7 Program(1)/Charts”文件夹

● 已安装最新的 PCS 7 AP Library Vxx 。

步骤

步骤 操作

1 ● 选择菜单命令“文件”(File) >“打开”(Open)。
● 选择“库”(Libraries) 选项卡。

● 在列表中选择条目 "PCS 7 AP Library <Vxx>".。
● 单击“确定”(OK)。

2 在 SIMATIC Manager 编辑器中，选择菜单命令

“窗口”(Window) >“排列”(Arrange) >“垂直平铺”(Tile vertically)。

入门指南（V8.1 版本，含 APL）
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步骤 操作

3 ● 浏览到 "fast_MP" 多项目的“S7 Program(1)/Charts”文件夹中的 "fast_Lib" 
主数据库。

● 在“PCS 7 AP Library V... （组件视图）...”窗口，打开“PCS 7 AP Library 
<Vxx> > Blocks + Templates > Templates”文件夹。

● 按住 <Ctrl>，同时选择右侧窗口中的 MotorLean、PIDConL_ConPerMon 
和 ValveLean 过程标签类型（CFC 图表）。

● 将所选的过程标签类型（CFC 图表）拖放到 "fast_MP" 多项目的 "fast_Lib" 
主数据库中的“S7 Program(1)/Charts”文件夹。

已成功将过程标签类型（CFC 图表）保存到多项目的主数据库中。

4 关闭“PCS 7 AP Library V... （组件视图）...”窗口。

结果

组态过程标签和顺序控制

4.1 如何将 CFC 图表从 Zip 文件复制到主数据库

入门指南（V8.1 版本，含 APL）
30 入门指南, 07/2014, A5E32713212-AA



4.2 如何创建项目特定的 CFC 图表

您已将一个图表或模板从库或项目复制到主数据库。 可按原样使用该对象，也可修改该对

象，然后在项目中使用。

在示例中，您已将模板从 PCS 7 AP Library Vxx 复制到 "fast_MP" 项目的主数据库。 已针

对具体项目修改过这些图表。

说明

CFC 编辑器有一项缩放功能。 可使用该功能来调整块的显示尺寸。

组态过程标签和顺序控制
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步骤

步骤 操作

1 ● 在组件视图的 SIMATIC Manager  中，打开 "fast_Lib"  主数据库中的“S7 
Program(1)/Charts”文件夹。

● 选择 "MotorLean" CFC 图表 在快捷菜单中，选择菜单命令“重命名”
(Rename)。 输入对象名称 "MOTOR1" 。

● 选择 "ValveLean" CFC 图表 在快捷菜单中，选择菜单命令“重命名”
(Rename)。 输入对象名称 "VALVE1" 。

● 选择 "PIDConL_ConPerMon" CFC 图表 在快捷菜单中，选择菜单命令“重

命名”(Rename)。 输入对象名称 "PIDCTRL1" 。
重命名完成后，过程标签类型将变成过程标签。

2 ● 双击 "MOTOR1" CFC 图表。

CFC 编辑器将打开。

● 将 "Motor" 块的“Start”参数连接到 "FbkRun" 块的 "SimPV_In" 参数。操作

过程如下：

– 左键单击 "Start" 参数并按住鼠标按钮。

– 将光标移动到 "SimPV_In" 参数，直到出现箭头。

– 释放鼠标按钮。

● 双击 "FbkRun" 块的 "Sim_On" 参数。

将打开“选择结构元素”(Select Structure Element) 对话框。

● 双击 "Value ..." 行。

将打开“属性 - 输入/输出”(Properties - Input/Output)对话框。

● 将“值”(Value) 输入框中的条目更改为“1”。

● 单击“确定”(OK)。
将关闭“属性 - 输入/输出”(Properties - Input/Output)对话框。

● 单击“关闭”(Close)。
“选择结构元素”(Select Structure Element) 对话框将关闭。

● 在 CFC 编辑器中，选择菜单命令“图表”(Chart) >“关闭”(Close)。

组态过程标签和顺序控制
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步骤 操作

3 ● 在组件视图的 SIMATIC Manager  中，打开 "fast_Lib"  主数据库中的“S7 
Program(1)/Charts”文件夹。

● 双击 "VALVE1" CFC 图表。

CFC 编辑器将打开。

● 将  "Valve" 块的 "Ctrl" 参数连接到 "FbkOpen" 块的 "SimPV_In" 参数。

● 双击 "FbkOpen" 块的 "Sim_On" 参数。

将打开“选择结构元素”(Select Structure Element) 对话框。

● 双击 "Value ..." 行。

将打开“属性 - 输入/输出”(Properties - Input/Output)对话框。

● 将“值”(Value) 输入框中的条目更改为“1”。

● 单击“确定”(OK)。
将关闭“属性 - 输入/输出”(Properties - Input/Output)对话框。

● 单击“关闭”(Close)。
“选择结构元素”(Select Structure Element) 对话框将关闭。

● 将 "Valve" 块的 "Ctrl"参数连接到 "FbkClose" 块的 "SimPV_In"  参数。

● 选择 "FbkClose" 块的 "SimPV_In" 参数。 选择快捷菜单中的“取反”(Invert) 
命令。

注：

将通过块输入上的实心圆代表取反的输入信号。

● 双击 "FbkClose" 块的 "Sim_On" 参数。

将打开“选择结构元素”(Select Structure Element) 对话框。

● 双击 "Value ..." 行。

将打开“属性 - 输入/输出”(Properties - Input/Output)对话框。

● 将“值”(Value) 输入框中的条目更改为“1”。

● 单击“确定”(OK)。
将关闭“属性 - 输入/输出”(Properties - Input/Output)对话框。

● 单击“关闭”(Close)。
“选择结构元素”(Select Structure Element) 对话框将关闭。

● 在 CFC 编辑器中，选择菜单命令“图表”(Chart) >“关闭”(Close)。

结果

已针对具体项目修改过 "MOTOR1" 和 "VALVE1" CFC 图表。 "PIDCTRL1" CFC 图表是 
PCS 7 AP Library Vxx 的 "PIDConL_ConPerMon" 模板。

说明

MOTOR1 和 VALVE1 示例

下图中以红色标识对 APL 目标的更改。
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图 4-1 MOTOR1

图 4-2 VALVE1
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4.3 如何将 CFC 图表复制到项目中

简介             

现在可将已修改和重命名的 CFC 图表从 "fast_Prj" 项目的 "fast_Lib" 主数据库复制到工厂

的“Function(1)”文件夹中。 完成复制后，可以继续在 SIMATIC Manager 的“过程对象视

图”(Process Object View) 中进行组态。 

要求

● 项目特定的 CFC 图表 "MOTOR1", "VALVE1" 和 "PIDCTRL1" 位于过程对象视图中主

数据库的“Charts”文件夹中。

● 已在组件视图中打开 SIMATIC Manager。

步骤

步骤 操作

1 在 SIMATIC Manager 中选择菜单命令“视图”(View) >“工厂视图”(Plant View)。

2 在工厂视图中，打开左侧窗口的树形结构。

3 选择 "fast_Lib" 文件夹中的“Process tag types”文件夹。

4 在 SIMATIC Manager 编辑器中，选择菜单命令“窗口”(Window) >“排列”
(Arrange) >“垂直平铺”(Tile vertically)。

5 在组件视图中，选择文件夹 "fast_Lib" > S7 Program(1) > Charts。

6 按住 <CTRL>，同时选择“MOTOR1”、“VALVE1”和“PIDCTRL1”这 3 个图

表。

7 打开快捷菜单并选择菜单命令“Cut”(剪切)。

8 选择工厂视图中的“Process tag types”文件夹。

9 打开快捷菜单并选择菜单命令“粘帖”(Paste)。

这 3 个图表随即出现在工厂视图中的“Process tag types”文件夹中。

10 在 SIMATIC Manager 中，选择菜单命令“视图 > 过程对象视图”(View > Process 
Object View)。

11 在过程对象视图中，打开左侧窗口的树形结构。 

12 单击 "fast_Lib" 文件夹中的“Process tag types”文件夹。

组态过程标签和顺序控制
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步骤 操作

13 在右侧窗口中打开“常规”(General) 选项卡。

在表中会显示以下 CFC：

● "MOTOR1"
● "VALVE1"
● "PIDCTRL1"

14 选择全部的 3 个图表。 
要执行此操作，请单击第一列的行号。 
将所选的 CFC 图表拖放到“fast_Prj\Plant(1)\Unit(1)\Function(1)”文件夹。

注：

同时按住 <Ctrl> 键可选择多个图表。

15 单击文件夹“fast_Prj\Plant(1)\Unit(1)\Function(1)”。

复制的 CFC 随即在右侧窗口的表中显示。 

结果

下图显示在“Process tag types”文件夹中复制的图表。

组态过程标签和顺序控制
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4.4 如何组态 SFC 图表

简介      

PCS 7 向导已在 "fast_Prj" 项目的“Function(1)”文件夹中创建了 SFC 图表 "SFC(1)" 。 以
下部分介绍如何重命名 SFC 图表并针对仿真对其进行修改。

其中还介绍了如何从结构互连变量。

要求

● 已完成“新建项目”(New Project) PCS 7 向导中的会话。

● SIMATIC Manager 已打开且 "fast_MP" 项目和所有打开的层级文件夹显示在过程对象

视图中。

步骤

步骤 操作

1 在“fast_Prj\Plant(1)\Unit(1)\Function(1)”文件夹中，打开 "SFC(1)"对象的快捷

菜单。 选择菜单命令“重命名”(Rename)。

2 输入新名称 "CONTROL1" 并按 Enter 键。

3 双击 "CONTROL1" 对象。

将打开 SFC 编辑器。

4 ● 在 SFC 编辑器中，选择菜单命令“插入”(Insert) >“步+转移”(Step
+Transition)。

● 在 SFC 图表中将光标移到“START”步骤的下方，直到显示绿线，然后按下

鼠标左键。

● 选择“插入”(Insert) >“选择”(Select)。

组态过程标签和顺序控制
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步骤 操作

5 ● 选择“START”步骤下方的第一个转移 (2)，然后从快捷菜单中选择“对象属

性”(Object Properties) 命令。

● 选择“条件”(Condition) 标签。

● 单击“浏览”(Browse)。
● 单击 "PIDCTRL1" CFC 图表前的加号。

● 选择 "PID" 块。

● 选择“名称”(Name) 列中的 "PV_Out" 连接。

如果列宽不够，请更改对话框和各列的宽度。

● 打开快捷菜单，并选择“打开结构”(Open Structure)。
● 在“名称”(Name) 列中，选择 "Value" 连接。单击“应用”(Apply)。
● 在“属性 - 2 --...”(Properties - 2 --...) 对话框的第 1 行中，在“=”旁输入数

值“50”，并将该字符从“=”更改为“>”。

● 单击“应用”(Apply)，然后单击“关闭”(Close)。

6 ● 在 SFC 图表中，打开转移 (2) 下步骤 (3) 的快捷菜单，然后选择“对象属

性”(Object Properties)。
● 在“运行时间”(Runtimes) 组的“最小值：”(Minimum:) 条目中输入“10s”（不

加空格）。

● 选择“处理”(Processing) 选项卡。

● 单击“浏览”(Browse)。
● 单击 "MOTOR1" CFC 图表前的加号。

● 选择 "Motor" 块。

● 在“名称”(Name) 列中，选择 "StartAut" 连接。

● 打开快捷菜单，并选择“打开结构”(Open Structure)。
● 在“名称”(Name) 列中，选择 "Value" 连接。单击“应用”(Apply)。
● 在“属性 - 3--...”(Properties - 3--...) 对话框的第 1 行中，在 ":=" 旁输入数值 

"1"，并单击“应用”(Apply)。
● 选择第二行

● 单击“浏览”(Browse)。
● 选择 "Motor" 块。

● 在“名称”(Name) 列中，选择 "StopAut" 连接。

● 打开快捷菜单，并选择“打开结构”(Open Structure)。
● 在“名称”(Name) 列中，选择 "Value" 连接。单击“应用”(Apply)。
● 在“属性 - 3--...”(Properties - 3--...) 对话框的第 2 行中，在 ":=" 旁输入数值 

"0"，并单击“应用”(Apply) 和“关闭”(Close)。
控制系统的过程值达到或超出 50 时，电机即启动。
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步骤 操作

7 ● 打开 SFC 步骤 3 的快捷菜单，然后选择“复制”(Copy)。
● 在 SFC 图表的空白区域中打开快捷菜单，然后选择“粘贴”(Paste)。
● 在 SFC 图表中将光标移到“End（结束）”步骤的上方，直到出现绿线，然

后按下鼠标左键。

8 ● 在 SFC 图表中，打开步 (4)  的快捷菜单，然后选择菜单命令“对象属性”
(Object Properties)。

● 选择“处理”(Processing) 选项卡。

● 在第一行（"StartAut" 参数）中，将 "TRUE"  值更改为 "FALSE"。
● 在第二行（"StopAut" 参数）中，将 "FALSE" 值更改为 "TRUE"。
● 单击“应用”(Apply)，然后单击“关闭”(Close)。
● 电机关闭。 在 10 秒后继续处理。

结束 ● 选择 SFC >“退出”(Exit)。

组态过程标签和顺序控制
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结果
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4.5 如何组织项目文件夹

简介                             

PCS 7 向导已创建和命名“fast_Prj”项目的 Unit(1)。 下面，您将重命名这些层级文件夹：

● “Plant(1)”文件夹将变为 "PLANT"

● “Unit(1)”文件夹将变为 "UNIT_A"

如此将使工厂结构更清晰。 

可以删除由 PCS 7 向导创建但并不需要的对象

要求

● 已完成 PCS 7 向导“新建项目”(New Project) 中的会话。

● SIMATIC Manager 已打开且 "fast_MP" 项目和所有打开的层级文件夹显示在工厂视图

中。

说明

可在 SIMATIC Manager 中组态不同视图，方法是选择“视图 >”(View >)，然后选择具体

视图，如“工厂视图”(Plant view)。

步骤

步骤 操作

1 打开工厂视图左侧窗格中“Process cell(1)”文件夹的快捷菜单，然后选择“重命

名”(Rename)。

2 输入名称 "PLANT" 并按 Enter 键。

3 打开工厂视图左侧窗格中“Unit(1)”文件夹的快捷菜单，然后选择“重命名”
(Rename)。

4 输入名称 "UNIT_A" 并按 Enter 键。

5 单击 "UNIT_A" 文件夹下的“Function(1)”文件夹。

6 打开右侧窗格中 "CFC(1)" 对象的快捷菜单，然后选择“删除”(Delete)。
将打开“删除”(Delete) 对话框。

7 单击“是”(Yes)。

组态过程标签和顺序控制
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结果
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自动生成过程画面的准备工作 5
5.1 如何做自动生成工厂显示的准备工作。

简介      

要进行自动生成过程画面的准备工作，请按以下所述步骤操作。

要求

● 已完成 PCS 7 向导“新建项目”(New Project) 中的会话。

● SIMATIC Manager 已打开且 "fast_MP" 项目和所有打开的层级文件夹显示在工厂视图

中。

步骤

步骤 操作

1 选择工厂视图左侧窗口的 "UNIT_A" 文件夹。

2 在右侧窗口中打开“Picture(3)”对象的快捷菜单，并选择菜单命令“对象属性...”
(Object Properties...)。

3 选择“块图标”(Block icon) 标签。

4 选中“从工厂层级获得块图标”(Derive block icons from the plant hierarchy) 复
选框并单击“确定”(OK)。

5 打开 "UNIT_A" 文件夹的快捷菜单，然后选择“工厂层级 > 自定义”
(Plant Hierarchy > Customize)。

将打开“工厂层级 - 设置”(Plant Hierarchy - Settings) 对话框。

6 在“层级设置”(Level Settings) 组的“OS 区域”(OS area) 列中，选择第二层级单

选按钮。

7 选中“从工厂层级获得画面层级”(Derive picture hierarchy from the plant 
hierarchy) 复选框。

8 单击“确定”(OK)。
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“自定义工厂层级”对话框

自动生成过程画面的准备工作

5.1 如何做自动生成工厂显示的准备工作。
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通过复制操作创建单元 6
6.1 如何通过复制“Unit_A”单元来创建一个单元

简介      

以下部分介绍如何将 "UNIT_A" 复制到工厂视图中的 "PLANT" 文件夹中。 在复制过程中，

将生成 UNIT_A 的副本，其中包括其所有已组态对象。 您需要重命名复制的对象；

要求

● SIMATIC Manager 已打开且 "fast_MP" 项目和所有打开的层级文件夹显示在工厂视图

中。

步骤

步骤 操作

1 打开工厂视图左侧窗格中 "UNIT_A" 文件夹的快捷菜单，然后选择“复制”
(Copy)。

2 打开 "PLANT" 文件夹的快捷菜单，然后选择“粘贴”(Paste)。

3 ● 打开所复制的 "UNIT_A(1)" 文件夹的快捷菜单，然后选择“重命名”
(Rename)。

● 输入名称 "UNIT_B" 并按 Enter 键。

4 在左侧窗口中，单击 "UNIT_B" 文件夹下的 "Funktion(1)" 文件夹。

5 ● 在右侧窗口中，打开 "MOTOR1(1)" 文件夹的快捷菜单，然后选择“重命名”
(Rename)。

● 输入名称 "MOTOR2" 并按 Enter 键。

● 在右侧窗口中，打开 "PIDCTRL1(1)" 文件夹的快捷菜单，然后选择“重命

名”(Rename)。
● 输入名称 "PIDCTRL2" 并按 Enter 键。

● 在右侧窗口中，打开 "VALVE1(1)" 文件夹的快捷菜单，然后选择“重命名”
(Rename)。

● 输入名称 "VALVE2"并按 Enter 键。

● 在右侧窗口中，打开 "CONTROL1(1)" 文件夹的快捷菜单，然后选择“重命

名”(Rename)。
● 输入名称 "CONTROL2" 并按 Enter 键。

入门指南（V8.1 版本，含 APL）
入门指南, 07/2014, A5E32713212-AA 45



结果

通过复制操作创建单元

6.1 如何通过复制“Unit_A”单元来创建一个单元
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组态和互连过程标签 7
7.1 如何组态和互连过程标签

简介               

要为过程标签分配参数和互连过程标签，必须先在过程对象视图中插入信号，然后修改参

数值。

要求

● SIMATIC Manager 已打开且 "fast_MP" 项目和所有打开的层级文件夹显示在过程对象

视图中。

步骤

步骤 操作

1 在过程对象视图的左侧窗口中，单击 "PLANT" 文件夹。

2 在右侧窗口中单击“信号”(Signals) 选项卡。

3 在右侧窗口中，将光标置于紧靠底部水平滚动条左侧

的竖条上（如图所示），将显示窗口拆分成两部分。 
当光标变为拆分符号时，将该竖条移到显示窗口中

间。

4 ● 单击“图表”(Chart) 列的标题，使其按升序排序。

● 使用左下方的滚动条来查看左侧窗口的“图表”(Chart)、“块”(Block) 和“I/O 
注释”(I/O comment) 列。

使用列标题边缘上的拆分光标隐藏各列或缩小各列的大小。

● 然后，使用右下方的滚动条来查看“信号”(Signal) 列。
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步骤 操作

5 ● 找到表中包含以下条目的行：

“图表”(Chart) 列；"MOTOR1"  条目和“块”(Block) 列；"FbkRun" 条目

● 在相应的“信号”(Signal) 列中使用快捷菜单打开。 选择“插入信号”
(Insert Signal) 菜单命令。

● 在“插入信号”(Insert Signal) 对话框中，打开右侧窗口中“Inputs”文件夹的

快捷菜单，选择菜单命令“打开”(Open)。
将打开“插入信号”(Insert Signal) 对话框。

● 打开“SIMATIC 400 ...\Outputs”文件夹。

● 在右侧窗口中选择 "MOTOR1-OUT" 信号并单击“应用”(Apply)。
随即会插入信号。

6 下表显示必须分配给块 I/O 的信号。 按上述步骤继续操作。

注意，在“插入信号”(Insert Signal) 对话框的左侧窗口中，必须为每个信号切

换“Inputs”和“Outputs”文件夹。

7 关闭“插入信号"(Insert Signal) 对话框。

组态和互连过程标签

7.1 如何组态和互连过程标签
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步骤 操作

8 ● 在过程对象视图的左侧窗口中，单击“参数”(Parameters) 选项卡。

● 按上述步骤 3 所述，将右侧窗口拆分为两部分。 左侧窗口显示“图表”(Chart) 
列，右侧窗口显示“I/O”、“类别”(Category) 和“值”(Value) 列。

● 单击“图表”(Chart) 列的标题，使其按降序排序。

● 在右侧窗口中对应图表名 "VALVE1" 和 I/O "MonTiDynamic"  的“值”(Value) 
列中输入值 6。

● 在右侧窗口中对应图表名 "VALVE2" 和 I/O "MonTiDynamic"  的“值”(Value) 
列中输入值 6。

组态和互连过程标签
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编译和下载 8
8.1 如何编译和下载对象

简介       

您现在已经完成了编译和下载对象的所有准备工作。 在“编译和下载对象”(Compile and 
Download Objects) 对话框中，对编译和下载图表与 OS 所需的所有设置进行组态。

要求

● SIMATIC Manager 已打开，并且 "fast_MP" 项目已显示在组件视图中。

● S7-PLCSIM 已启动。

步骤

步骤 操作

1 ● 在左侧窗格中，打开 "fast_MP" 根文件夹的快捷菜单，然后选择

“PLC > 编译和下载对象”(PLC > Compile and Download Objects)。
● 通过单击加号展开“编译和下载对象”(Compile and download objects) 对话

框中的文件夹结构。

● 在“Charts”文件夹中，选中“编译"(Compile)  和“下载"(Download) 列中的

复选框。

● 单击“Charts”文件夹，然后在“编译/下载的设置”(Settings for Compilation/
Download) 组中单击“编辑”(Edit)。
将打开“编译程序/下载到目标系统”(Compile program / download to target 
system) 对话框。

2 ● 在“范围”(Scope) 组中选中“整个程序”(Entire program) 复选框。

● 单击“确定”(OK)。
将打开“下载到 PLC”(Download to PLC) 对话框。

● 单击“确定”(OK)。
程序将关闭这两个对话框。
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步骤 操作

3 ● 选中“编译和下载对象”(Compile and Download Objects) 对话框“编译”
(Compile) 列中“OS(1)”文件夹的复选框。

● 单击“OS(1)”文件夹，然后单击“编译/下载的设置”(Settings for Compilation/
Download) 组中的“编辑”(Edit)。

● 在“向导： 编译 OS”(Wizard: Compile OS) 对话框中单击“下一步”(Next)。
● 再次单击“下一步"(Next)。
● 在显示的对话框中，激活以下复选框：

在“数据”(Data) 组中：

-“变量和消息”(Tags and messages) 复选框

-“SFC 可视化”(SFC Visualization) 复选框

-“画面树”(Picture Tree) 复选框。 
在“范围”(Scope) 组中：

-“整个 OS”(Entire OS) 选项框。

● 单击“完成”(Finish)。
将关闭该对话框。

4 ● 单击“编译和下载对象”(Compile and Download Objects) 对话框中的“开

始”(Start)。
将打开“编译和下载对象”(Compile and download objects) 对话框。

● 单击“确定”(OK)。
● 又一个“编译和下载对象”(Compile and Download Objects) 对话框打开。

● 单击“是”(Yes)。
将启动操作。

操作完成时将显示日志文件。

● 关闭日志文件。

● 在“编译和下载对象”(Compile and Download Objects) 对话框中单击“取

消”(Cancel)。

编译和下载

8.1 如何编译和下载对象
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结果

经过编辑的“编译和下载对象”(Compile and Download Objects) 对话框如下图所示。

编译和下载完成时将显示以下日志文件。 此处可忽略报警。

编译和下载

8.1 如何编译和下载对象
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8.2 如何在 S7-PLCSIM 中将 CPU 设置为 RUN/P

简介       

完成对象的编译和下载后，必须将仿真 CPU 从“STOP”状态切换到“RUN-P”状态。

要求

● 已编译和下载对象。

● S7-PLCSIM 程序已启动。

步骤

步骤 操作

1 在任务栏中单击“S7/PLCSIM ...”窗口，将其打开。 

2 在“CPU”窗口中激活“RUN-P”复选框。

结果： 

3 在“S7 PLCSIM1”窗口中，单击“最小化”(Minimize) 按钮。

编译和下载

8.2 如何在 S7-PLCSIM 中将 CPU 设置为 RUN/P
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调整过程画面 9
9.1 如何调整过程画面

简介               

要操作和监视过程，请在 SIMATIC Manager 中打开 OS 并激活 OS 项目。 

可在 WinCC Explorer  的 Graphics Designer 中，根据需要随意更改或扩展过程画面。

以下自动生成的过程画面包含过程对象：

● 单元 "UNIT_A" 的 Picture(3)

● 单元 "UNIT_B"  的 Picture(3)(1)

自动生成的过程画面中不显示对象名称。 为此，请将“@TemplateAPLV8.PDL”模板画面

的“显示/隐藏变量”(Show/Hide Tag) 按钮插入“Picture(3)”过程画面。 使用此按钮显示/隐
藏过程名称。 

步骤

步骤 操作

1 在组件视图的左侧窗口中，打开 SIMATIC PC 站的树形视图。

2 右键单击“OS(1)”文件夹，然后从快捷菜单中选择“打开对象”(Open object)。

WinCC Explorer 将打开。

3 如果 WinCC Explorer 用户界面语言与 SIMATIC Manager 用户界面语言不匹

配，请在 WinCC Exlorer 中选择菜单命令“视图 > 语言”(View > Language) 然
后更改语言。

4 在树形视图中选择“"Graphics Designer"”文件夹。

5 双击列表中“名称”(Name) 列的“Picture(3).Pdl”对象。

将在 Graphics Designer 中打开该过程画面。

6 选择“文件 > 打开”(File > Open) 菜单命令。 
将打开“打开”(Open) 对话框窗口

7 双击列表中“名称”(Name) 列的 "@TemplateAPLV8.PDL" 对象。 
"@TemplateAPLV8.PDL" 模板画面将打开。
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步骤 操作

8 选择“显示/隐藏变量”对象。

9 在快捷菜单中，选择菜单命令“复制”(Copy)。

10 单击未完成的“Picture(3).Pdl”画面。

11 选择菜单命令“编辑 > 粘贴”(Edit > Paste)。

12 选择菜单命令“文件”(File) >“保存”(Save)。

13 选择菜单命令“文件 > 退出”(File > Exit)。
Grafics Designer 将关闭。

结果

“显示/隐藏变量”对象插入到“Picture(3).Pdl”过程画面中。

调整过程画面

9.1 如何调整过程画面
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操作和监视过程 10
10.1 如何操作和监视过程

简介

要操作和监视过程，请在 SIMATIC Manager 中打开 OS 并激活 OS 项目。 

说明

可以在 WinCC Explorer  的 Graphics Designer 中修改和扩展自动生成的画面 - "UNIT_A" 
单元的 Picture(3) 和 "UNIT_B"  单元的 Picture(3)(1)。

要求

● 在 S7-PLCSIM  中，CPU 仿真已设置为 "RUN-P" 状态。

● SIMATIC Manager 已打开，并且 "fast_MP"  项目已显示在组件视图中。

步骤

步骤 操作

1 在 SIMATIC Manager  的左侧窗口中，打开 SIMATIC PC 站的树形视图。

2 右键单击“OS(1)”文件夹，然后从快捷菜单中选择“打开对象”(Open object)。

WinCC Explorer 将打开。
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步骤 操作

3 检查以下设置：

● 双击“变量管理”(Tag Management)。 将打开“WinCC Configuration 
Studio”。

● 在“变量管理”(Tag Management) 窗口中，转到“SIMATIC S7 PROTOCOL 
SUITE > TCP/IP”。

● 打开快捷菜单，并选择“系统参数”(System parameters) 命令。 将打开“系

统参数 - TCP/IP”(System parameters - TCP/IP) 对话框。

● 选择“单元”(Unit) 选项卡。

● 在“选择逻辑设备名称”(Select logical device name) 区域中，“逻辑设备名

称”(Logical device name) 的输入内容现在应该是“PLCSIM.TCPIP.1”。 不
然，请从下拉列表中选择此条目。

● 单击“确定”(OK)。 将关闭“系统参数 - TCP/IP”(System parameters - TCP/
IP) 对话框。

● 关闭“WinCC Configuration Studio”。

如果执行了更改，则此时需要重新启动 WinCC Explorer。

4 ● 右键单击“OS(1)”文件夹以打开快捷菜单，然后选择“对象属性”(Object 
Properties) 菜单命令。

● 选择“选项”(Options) 选项卡。

● 选中“允许在 ES 上激活”(Allow activation on ES) 复选框。

5 选择 WinCC Explorer  中的菜单命令“文件”(File) >“激活”(Activate)。

将启动 WinCC Runtime。

6 ● 如果 WinCC Runtime 用户界面语言与 SIMATIC Manager 用户界面

语言不匹配，则单击用户界面左下角的“键组更改”(Key set change) 
按钮更改到键组 2。

 
● 单击键组 2 中的“更改语言”(Change language) 按钮。将打开“更

改语言”(Change language) 对话框。

● 选择所需的 WinCC Runtime 用户界面语言。

 

操作和监视过程

10.1 如何操作和监视过程
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步骤 操作

7 ● 在“SIMATIC PCS 7 控制系统”(SIMATIC PCS 7 Control System) 用户界面左

上方的总览区（参见“包含所有操作员控件的工作区”下方的图）中，单击 
"UNIT_A" 区域选择键。

● 单击“显示/隐藏变量”(Show/Hide Tag) 按钮。

将显示图片对象的名称。

以下自动生成的画面包含以下对象的块图标： 

CONTROL1 顺序控制系统

MOTOR1 电机

VALVE1 阀

PIDCTRL1 控制器

显示/隐藏变量 单击该对象可显示/隐藏画面对象的名称。

注：

在“包含所有控件元素的工作区”下方的图中，

电机和控制器的面板处于打开状态。

8 ● 单击用户界面工作区中的“MOTOR1/Motor”块图标。

将在用户界面工作区显示电机的面板。

● 单击“命令”(Command) 旁的“...”按钮。

将展开“MOTOR1/ Motor”面板。

● 单击“启动”(Start)。单击“确定”(OK)。
将启动电机。 面板中的“状态”(Status) 即显示“启动”(Start)。

9 对阀的块图标重复步骤 6 的基本过程并测试“打开”(Open) 命令。

测试电机的“停止”(Stop) 命令和阀的“关闭”(Close) 命令。

10 对电机和阀的“自动”模式重复步骤 6 的基本过程。

退出处于“自动”模式的电机的面板。

11 ● 在用户界面工作区中单击 "PIDCTRL1/PID"  块图标。

● 单击操作模式显示位置旁的“...”按钮。

将展开 "PIDCTRL1/PID" 面板。

● 单击“自动”(Automatic) 按钮。单击“确定”(OK)。
控制器切换到“自动”模式。

● 单击“设定值”(Setpoint) 显示框。

将展开 "PIDCTRL1/PID" 面板。

● 使用滑块将设定值设置为 25。单击“确定”(OK)。
● 等到过程值大于 10。
● 在面板的工具栏中，单击消息“确认错误”(Acknowledge error) 按钮。 控制

器随即消除了错误并处于“自动”操作模式。

操作和监视过程

10.1 如何操作和监视过程
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步骤 操作

12 ● 通过单击用户界面左下角的“按钮切换”(Keyset change) 切换到按

钮区域 2。

13 ● 单击键组 2 中的“SFC 可视化”(SFC Visualization)。
将打开“打开 SFC”(Open SFC) 对话框。

14 ● 在右侧窗口中选择“SFC 名称”(SFC Name) 列中的 "CONTROL1" 条目，然后

单击“确定”(OK)。
将在工作区显示 SFC 总览。

● 单击“启动”(Start) 按钮并通过单击“确定”(OK) 确认随后出现的对话框。

如果控制器的过程值没有超过 50，则顺序控制系统会在出现第一个转移条件

时停止并且不再继续执行。

– 单击 "PIDCTRL1/PID"  控制器的面板（见下面的“执行顺序控制系统”

画面）。

– 单击控制器面板上“设定值”(Setpoint) 旁边的输入框。 面板随即展开。 
输入 "80"  作为设定值 单击“确定”(OK)。

15 ● 观察顺序控制系统的执行情况。

– 若组态正确。顺序控制系统将完成执行。

– MOTOR1 在流程图的步骤 3 启动，在步骤 4 又停止。

16 ● 单击“按钮切换”(Keyset change) 以切换到按钮区域 1。

17 ● 单击“消息系统”(Message System) 按钮。

新收到的消息将显示在工作区中。

18 ● 单击“操作列表”(Operation List)。
操作消息将显示在工作区中。 该列表显示已在面板中执行的所有操

作。

操作和监视过程

10.1 如何操作和监视过程
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结果

打开了 PIDCTRL1 的面板的工作区： 

执行顺序控制系统（步骤 9 到 11）：

操作和监视过程

10.1 如何操作和监视过程
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操作列表（步骤 10）：

退出 WinCC Runtime

要退出 WinCC Runtime，请单击以下符号：

操作和监视过程

10.1 如何操作和监视过程
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操作和监视过程

10.1 如何操作和监视过程

入门指南（V8.1 版本，含 APL）
入门指南, 07/2014, A5E32713212-AA 63



操作和监视过程

10.1 如何操作和监视过程
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