<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>1</td>
</tr>
<tr>
<td>Terms</td>
<td>2</td>
</tr>
<tr>
<td>Software requirements</td>
<td>3</td>
</tr>
<tr>
<td>Synchronizing project data with Teamcenter</td>
<td>4</td>
</tr>
<tr>
<td>2D-based 3D design</td>
<td>5</td>
</tr>
<tr>
<td>Integrated document management</td>
<td>6</td>
</tr>
<tr>
<td>Integrated change management</td>
<td>7</td>
</tr>
<tr>
<td>Administration</td>
<td>8</td>
</tr>
<tr>
<td>User interface reference</td>
<td>9</td>
</tr>
</tbody>
</table>
Legal information

Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are graded according to the degree of danger.

**DANGER**
indicates that death or severe personal injury will result if proper precautions are not taken.

**WARNING**
indicates that death or severe personal injury may result if proper precautions are not taken.

**CAUTION**
indicates that minor personal injury can result if proper precautions are not taken.

**NOTICE**
indicates that property damage can result if proper precautions are not taken.

If more than one degree of danger is present, the warning notice representing the highest degree of danger will be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property damage.

Qualified Personnel

The product/system described in this documentation may be operated only by personnel qualified for the specific task in accordance with the relevant documentation, in particular its warning notices and safety instructions. Qualified personnel are those who, based on their training and experience, are capable of identifying risks and avoiding potential hazards when working with these products/systems.

Proper use of Siemens products

Note the following:

**WARNING**
Siemens products may only be used for the applications described in the catalog and in the relevant technical documentation. If products and components from other manufacturers are used, these must be recommended or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and maintenance are required to ensure that the products operate safely and without any problems. The permissible ambient conditions must be complied with. The information in the relevant documentation must be observed.

Trademarks

All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability

We have reviewed the contents of this publication to ensure consistency with the hardware and software described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the information in this publication is reviewed regularly and any necessary corrections are included in subsequent editions.
# Table of contents

1 Introduction........................................................................................................................................... 7  
2 Terms................................................................................................................................................... 9  
3 Software requirements........................................................................................................................ 11  
4 Synchronizing project data with Teamcenter...................................................................................... 13  
   4.1 Transferring data from Teamcenter to COMOS.............................................................................. 13  
      4.1.1 Basic principles......................................................................................................................... 13  
      4.1.2 Mapping a unit from Teamcenter ............................................................................................ 13  
      4.1.3 Checking and making settings............................................................................................... 14  
      4.1.4 Synchronizing a unit from Teamcenter.................................................................................. 14  
   4.2 Transferring data from COMOS to Teamcenter............................................................................... 15  
      4.2.1 Basic principles......................................................................................................................... 15  
      4.2.2 Checking and making settings............................................................................................... 15  
      4.2.3 Synchronizing a unit to Teamcenter..................................................................................... 16  
   4.3 Synchronizing attribute values........................................................................................................ 16  
      4.3.1 Static and dynamic data............................................................................................................ 17  
      4.3.2 Forms for static data................................................................................................................ 18  
      4.3.3 Forms for dynamic data........................................................................................................... 18  
   4.4 Changes in COMOS......................................................................................................................... 19  
      4.4.1 Creating a mapping object....................................................................................................... 19  
      4.4.2 Specifying the instance mapping............................................................................................ 20  
   4.5 Configuring the interface to Teamcenter.......................................................................................... 21  
      4.5.1 Overview.................................................................................................................................. 21  
      4.5.2 Workflow.................................................................................................................................. 23  
      4.5.3 Naming conventions................................................................................................................ 25  
      4.5.4 Configuring Teamcenter.......................................................................................................... 25  
      4.5.5 Setting Teamcenter options.................................................................................................... 26  
      4.5.6 Making changes in the "Default.xml" file................................................................................ 27  
      4.5.7 Configuring a project in Teamcenter..................................................................................... 27  
      4.5.8 Specifying resources and types for the assignment............................................................... 28  
      4.5.9 Creating an "Application Interface".................................................................................... 29  
      4.5.10 Creating a "Collaboration Context" for an existing unit.................................................... 30  
      4.5.11 Creating a "Collaboration Context" for synchronizing a plant from COMOS................... 31  
   4.6 Configuring COMOS......................................................................................................................... 31  
      4.6.1 Saving access data for Teamcenter in the project properties............................................... 31  
      4.6.2 Installing the buffer component for the COMOS client......................................................... 32  
      4.6.3 Synchronizing resources.......................................................................................................... 33  
      4.6.4 Calling the properties of synchronized resources.................................................................... 34  
      4.6.5 Assigning units of measurement............................................................................................ 34  
      4.6.6 Assigning resources and types............................................................................................... 35  
      4.6.7 Assigning attributes................................................................................................................ 36  
      4.6.8 Synchronizing resource information....................................................................................... 37
## Table of contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>5</strong> 2D-based 3D design</td>
<td>39</td>
</tr>
<tr>
<td>5.1 Requirements for the connection between COMOS and NX</td>
<td>39</td>
</tr>
<tr>
<td>5.2 Exporting pipe specs to Teamcenter</td>
<td>39</td>
</tr>
<tr>
<td>5.3 Transferring P&amp;IDs to Teamcenter/NX</td>
<td>40</td>
</tr>
<tr>
<td>5.4 Connecting COMOS and NX</td>
<td>41</td>
</tr>
<tr>
<td>5.5 Disconnecting the connection between COMOS and NX</td>
<td>41</td>
</tr>
<tr>
<td>5.6 Assigning objects</td>
<td>42</td>
</tr>
<tr>
<td>5.7 Canceling the assignment</td>
<td>42</td>
</tr>
<tr>
<td>5.8 Navigating to the 3D object in NX</td>
<td>43</td>
</tr>
<tr>
<td>5.9 Navigating to the COMOS object on the P&amp;ID</td>
<td>43</td>
</tr>
<tr>
<td><strong>6</strong> Integrated document management</td>
<td>45</td>
</tr>
<tr>
<td>6.1 Assigning a COMOS document to a Teamcenter document</td>
<td>45</td>
</tr>
<tr>
<td>6.2 Creating COMOS documents with user-defined settings in Teamcenter</td>
<td>46</td>
</tr>
<tr>
<td>6.3 Creating COMOS documents with standard settings in Teamcenter</td>
<td>47</td>
</tr>
<tr>
<td>6.4 Assigning a workflow template to a TC document subsequently</td>
<td>48</td>
</tr>
<tr>
<td>6.5 Creating revision and transferring documents to Teamcenter</td>
<td>49</td>
</tr>
<tr>
<td>6.6 Transferring documents of a revision subsequently</td>
<td>50</td>
</tr>
<tr>
<td>6.7 Synchronizing metadata</td>
<td>51</td>
</tr>
<tr>
<td><strong>7</strong> Integrated change management</td>
<td>53</td>
</tr>
<tr>
<td>7.1 Change management for units</td>
<td>53</td>
</tr>
<tr>
<td>7.2 Change management for documents</td>
<td>54</td>
</tr>
<tr>
<td>7.3 Submitting Teamcenter tasks to COMOS</td>
<td>56</td>
</tr>
<tr>
<td>7.4 Querying change objects from Teamcenter</td>
<td>56</td>
</tr>
<tr>
<td><strong>8</strong> Administration</td>
<td>59</td>
</tr>
<tr>
<td>8.1 Synchronizing project data with Teamcenter</td>
<td>59</td>
</tr>
<tr>
<td>8.1.1 Adding an attribute</td>
<td>59</td>
</tr>
<tr>
<td>8.1.2 Editing an attribute</td>
<td>59</td>
</tr>
<tr>
<td>8.1.3 Deleting an attribute</td>
<td>60</td>
</tr>
<tr>
<td>8.2 2D-based 3D design</td>
<td>60</td>
</tr>
<tr>
<td>8.2.1 Preparing transfer of P&amp;IDs</td>
<td>60</td>
</tr>
<tr>
<td>8.2.2 XML file &quot;pipepartfamilies&quot;</td>
<td>61</td>
</tr>
<tr>
<td>8.2.3 Editing the XML file &quot;pipepartfamilies&quot;</td>
<td>61</td>
</tr>
<tr>
<td>8.2.4 Configuration of the &quot;Pipe part attribute mapping&quot; window</td>
<td>62</td>
</tr>
<tr>
<td>8.3 Preparing integrated document management</td>
<td>62</td>
</tr>
<tr>
<td>8.3.1 Preparing transfer of documents</td>
<td>62</td>
</tr>
<tr>
<td>8.3.2 Checking the settings of the revision printer</td>
<td>63</td>
</tr>
<tr>
<td>8.3.3 Importing document types</td>
<td>63</td>
</tr>
<tr>
<td>8.3.4 Importing workflow templates</td>
<td>64</td>
</tr>
<tr>
<td>8.3.5 Manually creating workflow templates</td>
<td>65</td>
</tr>
<tr>
<td>Section</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>8.3.6</td>
<td>Importing dataset types</td>
</tr>
<tr>
<td>8.3.7</td>
<td>Importing relation types for datasets</td>
</tr>
<tr>
<td>8.3.8</td>
<td>Importing item types</td>
</tr>
<tr>
<td>8.3.9</td>
<td>Configure the &quot;Teamcenter Interface&quot; object</td>
</tr>
<tr>
<td>8.3.10</td>
<td>Setting the direction of the synchronization of metadata</td>
</tr>
<tr>
<td>8.4</td>
<td>Preparing integrated change management</td>
</tr>
<tr>
<td>8.4.1</td>
<td>Importing workflow templates</td>
</tr>
<tr>
<td>8.4.2</td>
<td>Manually creating workflow templates</td>
</tr>
<tr>
<td>8.4.3</td>
<td>Importing types of change objects</td>
</tr>
<tr>
<td>8.4.4</td>
<td>Configuring change objects</td>
</tr>
<tr>
<td>8.4.5</td>
<td>Configuring &quot;Change management backlog&quot; in the project properties</td>
</tr>
<tr>
<td>8.4.6</td>
<td>Importing relation types for change objects</td>
</tr>
<tr>
<td>8.4.7</td>
<td>Preparing units for change management</td>
</tr>
<tr>
<td>8.4.8</td>
<td>Prepare transfer of Teamcenter tasks to COMOS</td>
</tr>
<tr>
<td>9</td>
<td>User interface reference</td>
</tr>
<tr>
<td>9.1</td>
<td>Status area in windows</td>
</tr>
<tr>
<td>9.2</td>
<td>&quot;Teamcenter login&quot; window</td>
</tr>
<tr>
<td>9.3</td>
<td>&quot;Synchronize plant from Tc&quot; window</td>
</tr>
<tr>
<td>9.4</td>
<td>&quot;Synchronize plant to Tc&quot; window</td>
</tr>
<tr>
<td>9.5</td>
<td>&quot;Element properties&quot; window</td>
</tr>
<tr>
<td>9.6</td>
<td>&quot;Select Tc resource&quot; window</td>
</tr>
<tr>
<td>9.7</td>
<td>&quot;Element properties&quot; window in the base objects</td>
</tr>
<tr>
<td>9.8</td>
<td>&quot;Synchronize resource info&quot; window</td>
</tr>
<tr>
<td>9.9</td>
<td>&quot;Teamcenter units of measurement&quot; tab</td>
</tr>
<tr>
<td>9.10</td>
<td>&quot;CTI resource mapping&quot; tab</td>
</tr>
<tr>
<td>9.11</td>
<td>&quot;CTI attribute mapping&quot; tab</td>
</tr>
<tr>
<td>9.12</td>
<td>&quot;CTI instance mapping&quot; tab</td>
</tr>
<tr>
<td>9.13</td>
<td>&quot;XMLViewer&quot; window</td>
</tr>
<tr>
<td>9.13.1</td>
<td>Views</td>
</tr>
<tr>
<td>9.13.2</td>
<td>Calling a view</td>
</tr>
<tr>
<td>9.13.3</td>
<td>Version comparison</td>
</tr>
</tbody>
</table>
Introduction

Data exchange with Teamcenter

COMOS has an interface to the Siemens PLM software Teamcenter. The interface supports data communication in both directions. You can start the exchange from COMOS.

The interface with Teamcenter provides you with the following options:

- You can create plants in Teamcenter and synchronize them with COMOS. See also chapter Synchronizing a unit from Teamcenter (Page 14).
- You can synchronize your existing COMOS unit with Teamcenter. See also chapter Synchronizing a unit to Teamcenter (Page 16).
- You can edit a synchronized plant either in COMOS or in Teamcenter and then synchronized it again.
- You can submit COMOS documents, revisions and associated documents to Teamcenter. See also chapter Integrated document management (Page 45).
- Create change requests, problem reports or other objects for change management in COMOS and export them to Teamcenter.
- See also chapter Integrated change management (Page 53).

Data exchange with NX

The interface allows you to transfer pipe parts from COMOS to NX via Teamcenter. Transferring takes place by means of XML files in which the information about pipe specs and pipe parts is collected.

P&IDs are transferred as PDFs. Information about PipeRun and XMplant is also transferred as an XML file.

See also chapter 2D-based 3D design (Page 39).
Terms

Mapping object

A mapping object is an engineering object created on the basis of a base object. A Teamcenter resource or a Teamcenter type must be assigned to the base object for this. Mapping objects can be synchronized between Teamcenter and COMOS.

PDI

Process Data Interface

PLM

PLM (Product Lifecycle Management) is uniform management of product data throughout the entire product lifecycle.

Synchronization

Synchronization is the equivalent of repeated importing or exporting of data. Synchronization includes all cases in which only a portion of the data is to be updated.

Teamcenter

Siemens PLM software Teamcenter

Assignment

The resources and types familiar in Teamcenter are initially independent of COMOS base objects. To link the relevant objects, they must be assigned to one another.

The resource assignment also determines which base object is used to create an object from Teamcenter in COMOS.

In the opposite direction, instance mapping defines the translation of COMOS engineering objects into resources or types that can be understood by Teamcenter.

Attributes and units of measurement are translated in both directions using corresponding assignments.
Software requirements

To use the functions of PDI, you need to use Teamcenter version 10.1.1 and NX version 9.0.

The COMOS interface has been designed to interface with Teamcenter Version 10.1.1.

When you use TCCS on the COMOS client, a Java Runtime Environment of version 1.6_22 or higher must be installed.
Synchronizing project data with Teamcenter

4.1 Transferring data from Teamcenter to COMOS

4.1.1 Basic principles

Preparation of data communication by the user

- If you want to start the transfer for the first time, you must prepare the data communication in COMOS. See chapter Configuring COMOS (Page 31).
- If you have already performed a synchronization from Teamcenter or to Teamcenter, use the prepared settings.
- In the event of problems during data communication, check that the default settings have been made and contact your administrator if necessary.

4.1.2 Mapping a unit from Teamcenter

Objective

Plant data is to be transferred from the Siemens PLM solution Teamcenter to COMOS for the first time.

Procedure

1. Create a new plant below the project node in the "Units" tab in the Navigator.
2. To determine the plant type used in Teamcenter, open the "@20 > B60 > M06 > Y30 > A20 Teamcenter types" node in the "Base objects" tab in the Navigator. The types used in Teamcenter are listed.
3. Open the properties of the object matching the type of your plant in Teamcenter.
4. To navigate to the corresponding base object, click the "Navigate, properties" button in the "Attributes > CTI resource mapping" tab and select "Navigate > Object". This object is to be created on the engineering side.
5. Use drag&drop to move this object from the "Base objects" tab onto the plant in the "Units" tab.
4.1.3 Checking and making settings

Requirement

The created plant is classified. A Teamcenter integrator object is added.

Procedure

1. To check the classification, select the created plant in the "Units" tab in the Navigator and navigate to the base object.
2. Open the base object properties.
3. Open the "Classification" tab.
4. Check whether the "A490 Teamcenter object" entry is set in the "Functional classification" list.
   If it is not, inform your administrator.
5. Check whether the "Teamcenter integrator" object is present in the "Units" tab of the Navigator in the mapping of the unit:
   – If this object is listed, the interface is ready for connection to Teamcenter.
   – If it is not listed, add a Teamcenter integrator object:
     Open the "@20 > B60 > M06 > A10 > A10 Teamcenter integrator" node in the "Base objects" tab in the Navigator.
     Use drag&drop to move the Teamcenter integrator object onto the plant in the Units tab.

4.1.4 Synchronizing a unit from Teamcenter

Requirements

- Your administrator has made the necessary default settings. See also chapter Specifying resources and types for the assignment (Page 28).
- The plant from Teamcenter has been mapped in COMOS. See also chapter Mapping a unit from Teamcenter (Page 13).
- You have checked or entered the settings. See also chapter Checking and making settings (Page 14).
Procedure

1. In the "Units" tab in the Navigator, select the mapping of the plant from Teamcenter.
2. Select the "Teamcenter > Synchronize plant from Tc..." command from the context menu.
   - If there is not an existing connection to Teamcenter, the "Teamcenter login" window opens. Enter your access details and click "OK" to confirm. See also chapter "Teamcenter login" window (Page 79).
   - As soon as the connection to Teamcenter is established, the "Synchronize plant from Teamcenter" window opens.
3. Make the required settings in the "Synchronize plant from Teamcenter" window. See also chapter "Synchronize plant from Tc" window (Page 80).
4. To perform synchronization, click "OK".

Result

The plant in COMOS is updated with the data from Teamcenter.

4.2 Transferring data from COMOS to Teamcenter

4.2.1 Basic principles

Preparation of data transfer by the user

If you want to start the transfer for the first time, prepare the data communication in COMOS.
If you have already performed a synchronization from Teamcenter or to Teamcenter, use the prepared settings.

4.2.2 Checking and making settings

Objective

Data of a plant in COMOS is to be synchronized to Teamcenter. Synchronization to Teamcenter requires certain settings.

Procedure

1. Select the plant node you want to synchronize to Teamcenter (along with its content) in the "Units" tab in the Navigator.
2. Check whether the "Y00T00128 @Y CTI instance mapping" tab is located below the selected plant.
   - If the tab is not there, contact your administrator.
3. Navigate to the base object.
4. Open the base object properties.
5. To check the classification, open the "Classification" tab.
6. Ensure that the "A490 Teamcenter object" entry has been set in the "Functional classification" list.
   If it has not, inform your administrator.
7. To add the Teamcenter integrator object, open the "@20 > B60 > M06 > A10 > A10 Teamcenter integrator" node in the "Base objects" tab in the Navigator.
8. Use drag&drop to move the Teamcenter integrator object onto the plant in the "Units" tab.

Result

The plant in COMOS is prepared for synchronization to Teamcenter.

4.2.3 Synchronizing a unit to Teamcenter

Procedure

1. Select the desired plant in the "Units" tab in the Navigator.
2. Select the "Teamcenter > Synchronize plant to Tc" command from the context menu.
   – If there is not an existing connection to Teamcenter, the "Teamcenter login" window opens. Enter your access details and click "OK" to confirm. See also chapter "Teamcenter login" window (Page 79).
   – As soon as the connection to Teamcenter is established, the "Synchronize plant to Tc" window opens.
3. Make the required settings in the "Synchronize plant to Teamcenter" window. See also chapter "Synchronize plant to Tc" window (Page 81).
4. To perform synchronization, click "OK".

Result

The plant in Teamcenter is updated with the data from COMOS.

4.3 Synchronizing attribute values

Overview

You can synchronize attribute values of Teamcenter forms to the engineering and base data with COMOS attributes. Conversely, you can synchronize attribute values from COMOS engineering to Teamcenter forms.
Sequence

1. You define the Teamcenter forms together with the other resources in Teamcenter and synchronize these to the base data in COMOS.

2. You assign the attributes in COMOS. See also chapter Assigning attributes (Page 36). To do this, use the "@20 > B60 > M06 > Y30 > A40 > Y00T00127 CTI attribute mapping" tab.

Note
Units of measurement not supported

The Teamcenter form attributes do not support units of measurement.

4.3.1 Static and dynamic data

Data types

We distinguish between two types of data:

- Static data
- Dynamic data

Static data

You define this data in Teamcenter and synchronize it to COMOS. Do not change the data in COMOS. See also chapter Forms for static data (Page 18).

Examples of static data

Technical data of manufacturer device definitions:

- Maximum power
- Model number
- Connectors
- Dimensions
- Weight

Dynamic data

Dynamic data is predefined in Teamcenter and is part of and a result of the engineering process. This data is synchronized to both COMOS and Teamcenter. See also chapter Forms for dynamic data (Page 18).
Examples of dynamic data
Process data which is necessary for a particular use of a manufacturer device:
- Process temperature
- Pressure
- Volume flow
- Medium

4.3.2 Forms for static data

Resources
Forms for static data are attached to the respective resource in Teamcenter. The same object is also used for later synchronization of engineering data. In COMOS, objects are created during synchronization of resources under the following node and attached as elements under the COMOS base object which corresponds to the Teamcenter resource:
"@20 > B60 > M06 > Y30 > A40 > A10 Static Teamcenter forms"

Attribute assignment to the base object assigned to the resource in COMOS takes place from the element. See also chapter Assigning attributes (Page 36).

4.3.3 Forms for dynamic data

"Structure Context" type object
You copy forms for dynamic data in Teamcenter under the object of the type "Structure Context". See also chapter Assigning resources and types (Page 35). When a plant is synchronized, the forms defined in this way are used as templates to create additional forms with the same name and type in Teamcenter. In COMOS, these templates are created in the base data under the following node:
"@20 > B60 > M06 > Y30 > A40 > A20 Dynamic Teamcenter forms"

Define the templates as COMOS base object elements to which a Teamcenter resource is assigned. At the engineering end, you create these elements if dynamic data is to be exchanged for the engineering object.

Recommendation
Use the exchange of dynamic data selectively. For managing the dynamic data, Teamcenter uses runtime objects which could slow down your system.
**Synchronizing attribute values**

At the engineering end, the "Attribute mapping" tab reflects the status of the attribute values of a dynamic form which is synchronized with Teamcenter. To transfer all values that come from Teamcenter to the assigned COMOS attributes, click "Update values".

With the "Update values" button, you transfer all values that come from Teamcenter to the assigned COMOS specifications.

Using the static link, you can copy the values from COMOS to the tab for the next synchronization to Teamcenter. To do this, use a normal attribute query. All inconsistencies between the data from COMOS and the data from Teamcenter are marked in orange. You can find additional information on this topic in the "Operation" manual, keyword "Refreshing static links".

### 4.4 Changes in COMOS

#### 4.4.1 Creating a mapping object

**Objective**

In this example, a new mapping object is created in COMOS and transferred to Teamcenter. A resource or type mapped in COMOS that has been synchronized and assigned from Teamcenter is used as the source.

**Procedure**

1. To select a resource, open one of the following nodes in the "Base objects" tab in the Navigator:
   - "@20 > B60 > M06 > Y30 > A10 > A20 Teamcenter classified resources"
   - "@20 > B60 > M06 > Y30 > A10 > A30 Teamcenter unclassified resources"
   - "@20 > B60 > M06 > Y30 > A20 Teamcenter types"

2. Select a resource saved below this node from Teamcenter. Example: "@20 > B60 > M06 > Y30 > A20 Teamcenter types" node, the "MEStation" object below it.

3. Open the properties of this object.

4. To navigate to the mapped base object, click the "Navigate, properties" button in the "Attributes > CTI resource mapping" tab and select "Navigate > Object" from the menu. This object is to be created on the engineering side. Example: The base object "CMEStation" has been selected and marked.

5. Use drag&drop to move this object onto an existing mapping object in the "Units" tab. The new mapping object is displayed below the existing mapping object. So that you can transfer the necessary attributes of the new mapping during a subsequent synchronization to Teamcenter, specify the Teamcenter "Item ID", "Revision ID", and "Name".

6. Open the properties of the newly created mapping object.
7. Select the "Attributes > CTI instance mapping" tab.

8. Click the "Instance properties ..." button.

9. To complete the mandatory fields "Item ID", "Revision ID", and "Name" in the "Element properties" window, click the "Assign" button. See also chapter "Element properties window" (Page 81).

   A unique "Item ID" is requested from the Teamcenter server. Alternatively, you can also edit these fields.

10. Click "OK" to save your settings.

Result

A Teamcenter item ID and a revision ID have been assigned to the mapped object.

Note

Synchronization of the created objects

There is a risk of data loss if you synchronize a plant from Teamcenter without transferring your changes to the Teamcenter server first.

The objects you have created are not transferred to the Teamcenter server until the moment you synchronize the unit to Teamcenter.

To link the created objects to their matches in Teamcenter, synchronize the plant from Teamcenter afterwards.

Note

"Item" type objects

If you select the "Item" type, a new unclassified resource is produced when the plant is synchronized to Teamcenter. Before you can synchronize the plant from Teamcenter, your administrator must first synchronize the resources and map the new unclassified resource to the same object in COMOS to which the "Item" type is mapped.

If you wish to add new resources, do this in Teamcenter.

4.4.2 Specifying the instance mapping

Objective

You are changing the instance mapping for a newly created mapping object. If you used the COMOS-internal inheritance mechanism during resource assignment, you have a means of specifying the instance mapping.

For example, you can assign multiple robots from Teamcenter to a single base object in COMOS. The first resource assigned is specified as the default value for the instance mapping. If the resource is a classification (a robot, for example), once you have created a mapping object, select a concrete classified resource (a Cartesian robot, for example). Then synchronize the superior unit to Teamcenter.
Procedure

1. Open the properties of the mapping object in the "Units" tab.
2. Select the "Attributes > CTI instance mapping" tab.
3. To call the "Select Tc resource" window, click the "Select Tc resource ..." button. All resources assigned to the base object of the mapping object are listed in the "Select Tc resource" window. The COMOS-internal inheritance hierarchy is displayed as the tree structure. See also chapter "Select Tc resource" window (Page 82).
4. You have the following options:
   – To specify the assignment for a resource, select the required resource in the "Select Tc resource" window.
   – To cancel the assignment for a resource, click the "Remove pointer" button.
5. Click "OK" to confirm your selection.

Result

During the next synchronization to Teamcenter, the newly created mapping object is transferred in accordance with the modified instance mapping.

4.5 Configuring the interface to Teamcenter

4.5.1 Overview

Settings for Teamcenter

Specify the basic settings for data communication with COMOS for multiple projects.

Individual project in Teamcenter

Make the settings for each project.

Installing the cache component for the COMOS client

Install an additional component for the COMOS client for multiple projects.
Settings in COMOS

Specify the settings for multiple projects and settings for individual projects. In the case of additions to a plant in Teamcenter, you will be involved several times within the framework of a project.

Note

Need for reconciliation in a project

The tasks assigned to a user include synchronizing units to Teamcenter or to COMOS. If resources, units of measurement, or attributes have been added to the current project in Teamcenter, you should be informed as the administrator. You carry out the necessary mapping in COMOS.
4.5.2 Workflow

Overview
4.5 Configuring the interface to Teamcenter

Synchronizing project data with Teamcenter

Legend:
- Teamcenter Admin
- Teamcenter User
- COMOS Admin
- COMOS User

Diagram:
- Tc Configuration
  - Transmission method
  - Settings
- Resources:
  - Create Collaboration Context
  - Create Structure Context
  - Create Application Interface
- Unit:
  - Create Collaboration Context
  - Create Application Interface
- Synchronize resources
- Create corresponding base objects, e.g., CItem
- Assign resources
- Assign types
- Assign attributes
- Assign units
- Synchronize resource information
- Latest version of the unit?
  - if in COMOS
    - Synchronize unit from COMOS to Tc
  - if in Tc
    - Synchronize unit from Tc to COMOS
- Make changes in Tc
- Changes planned?
  - in Tc
  - in COMOS
- Make changes in COMOS, e.g., creating a Tc object in COMOS
- New resources?
  - Yes
    - Project completed
  - No
    - Synchronize unit from Tc to COMOS

Operating Manual, 05/2016 V 10.2, A5E37098396-AA
4.5.3 Naming conventions

Naming conventions in COMOS

Teamcenter resources and types are mapped below defined nodes in COMOS using the original names from Teamcenter. The corresponding base objects must be assigned to the Teamcenter types in COMOS.

If there are no matching base objects in COMOS, create these base objects. You can find additional information in the "Operation" manual, keyword "Creating multiple objects via the static new menu".

Recommendation

Prefix the original name with "C" when assigning new base objects to Teamcenter types. This denotes the origin of the Teamcenter types.

Example:

<table>
<thead>
<tr>
<th>COMOS node for assigning the Teamcenter type</th>
<th>New COMOS base object based on the Teamcenter type</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;@20 &gt; B60 &gt; M06 &gt; Y30 &gt; A20 &gt; Item&quot;</td>
<td>&quot;CItem&quot;</td>
</tr>
</tbody>
</table>

Naming conventions in Teamcenter

In Teamcenter, you create objects defining the configuration of data communication.

Recommendation

When you assign names, select names that indicate the following characteristics:
- Project name
- Resources or units
- Collaboration Context", "Structure Context" or "Application Interface"
- Consecutive numbering if necessary

Examples:
- "AnyTownResourcesAI01"
- "AnyTown_Plant_03_CC"

4.5.4 Configuring Teamcenter

Defining the "Application Interface" with transfer types

To define the type of data transfer between Teamcenter and COMOS, you install one of the supplied templates using the Teamcenter Environment Manager program.
Procedure

1. Start Teamcenter Environment Manager in the Teamcenter installation directory.
   Relative path: ".\install\tem.bat".

2. Activate the "Configuration Manager" option in the "Maintenance" step and click the "Next" button.

3. Activate the "Perform maintenance on an existing configuration" option in the "Configuration Maintenance" step and click the "Next" button.

4. Click the "Next" button in the "Configuration Selection" step.

5. If the template is already installed, update it. To do so, enable the "Update Database (Full Model - System downtime required)" option.
   If the template is not yet installed, activate the "Add/Remove Features" option in the "Feature Maintenance" step and click the "Next" button.

6. To import the template with the saved settings, click the "Browse" button in the "Select Features" step and load the supplied file.
   Relative path on the CD for Teamcenter 10.1: "\.Software\AddOns\Teamcenter\Teamcenter101ServerConfiguration"

7. Activate the "Extensions > COMOS Interface" option in the tree structure displayed in the "Select Features" step.

8. Activate the "Extensions > Manufacturing Process Management > Customization for eM-Server Integration" option and click the "Next" button.
   The additional components which are required to synchronize certain types from the COMOS database to Teamcenter are installed.

9. In the "Teamcenter Administrative User" step, enter the administrator password in the "Password" field and click the "Next" button.

10. Click the "Next" button in the "Database Template Summary" step.

11. To confirm your settings and install the required components, click the "Next" button in the "Confirm Selections" step.
    This starts a copy operation. When the copy operation finishes, the definition of the "Application Interface" with the transfer types is complete.

4.5.5 Setting Teamcenter options

Objective

Change the "Al_request_no_dependancy" setting in the options menu of Teamcenter.

Procedure

1. Select the "Edit > Options" menu command in Teamcenter.

2. Click the "Search" button in the lower area.

3. Enter "*request*" in the "Search On Keywords" field in the "Search Options" window:
4. To run the search, click on the button with the magnifying glass symbol. The search results are displayed in the "Preference List" list.

5. Select the "Al_request_no_dependancy" entry in this list.

6. Enter "true" in the "Current Values" field.

7. To save the changes, click the "Modify" button.

4.5.6 Making changes in the "Default.xml" file

Procedure

Edit the "Default.xml" file in the ".\soap\policies" subdirectory of the Teamcenter "tcdata" folder and make the following addition:

```xml
<ObjectType name="MEPlantContext">
    <Property name="configuration_context"/>
    <Property name="revision_rule"/>
</ObjectType>
```

4.5.7 Configuring a project in Teamcenter

Creating the "Collaboration Context" and "Structure Context" for resources

To prepare Teamcenter for interaction with COMOS, you start by creating "Collaboration Context" and "Structure Context" type objects.

- A "Collaboration Context" type object is used in order to derive an "Application Interface" type object from it.
- "Structure Context" type object: Used to reference resources and types to be synchronized to COMOS.

Procedure

1. Open the "My Teamcenter" application in Teamcenter.

2. To create a folder for saving the "Collaboration Context", select the "Home" folder and select the "File > New > Folder..." command in the menu.
   The "New Folder" window opens.

3. In the "New Folder" window, enter a name for the new folder in the "Name" field and, if required, a description in the "Description" field.

4. Click "OK" to confirm your entries.

5. Select the created folder and then select the "File > New > Collaboration Context" command in the menu.

6. Make sure that the "CCObject" type is selected on the left side of the window.
7. Choose a name with the following characteristics:
   - Multiple projects
   - Either resources/types or units
   - "Collaboration Context", "Structure Context" or "Application Interface"
8. Click "OK" to save your entries and close the window.
9. To create a "Structure Context" type object, select the "Collaboration Context" type object and click the "File > New > Structure Context" command.
10. Make sure that the "MEResourceContext" type is selected on the left side of the window.
11. Assign a name for the "Structure Context" type object and click "OK".

4.5.8 Specifying resources and types for the assignment

Objective

Specify the resources and types that are used in the plant and are to be synchronized to COMOS. The specified resources and types are referenced in a "Structure Context" type object for the synchronization to COMOS.

Requirements

A "Structure Context" type object is created.

Procedure

1. To specify the resources and types required for synchronization to COMOS, select a plant and select the "Send to > Manufacturing Process Planner" command in the context menu. The "Manufacturing Process Planner" application opens.
2. Copy all "ItemRevision" type objects to the "Structure Context" type object in the "My Teamcenter" application.
3. To empty the "Manufacturing Process Planner" application, close and reopen this window.
4. To create a new working area, select the "File > New > New Workarea" command in the "Manufacturing Process Planner" application.
5. If there are types listed in the "New Workarea" window that are not contained in the supplied database, create the missing types.

The database supplied with the product includes the following types:

- "MECell"
- "MECompResource"
- "MEDepartment"
- "MELine"
- "MEPlant"
- "MEPrLine"
- "MEProcResource"
- "MEProductLocation"
- "MEPrPlant"
- "MEPrStation"
- "MEPrZone"
- "MESite"
- "MESStation"
- "MEStation"
- "MEWorkarea"
- "MEZone"

6. Copy all types to the same "Structure Context" type object as described in Step 2.

Result

All resources and types for synchronization have been selected. Selection of the resources and types is the requirement for the synchronization of resources.

Once the resources have been synchronized, the user can synchronize a plant from Teamcenter to COMOS.

### 4.5.9 Creating an "Application Interface"

**Objective**

In order to exchange data, you need an "Application Interface" type object.

This object is used to specify the following:

- Definition of a transfer format for the import
- Definition of a transfer format for the export
- Definition of the content of the data transfer by connecting the "Application Interface" type object with a "CollaborationContext" type object
- History of previous data transfers
Requirement

- A "Collaboration Context" type object is created for resources. Alternatively, a "Collaboration Context" type object is created for a plant. This plant exists in Teamcenter or an empty plant is created in Teamcenter for the synchronization.
- The "Application Interface" type object and transfer types are defined.

Procedure

1. To create a new "Application Interface" type object, select the "Collaboration Context" type object and select the "Tools > Export > Objects..." command.
2. Select "AppInterface" on the left. Click the button at the top right.
3. Select "COMOS_Al" on the left and enter a name. Make sure that the following settings are used:
   - "Import Transfer Mode Name:" "COMOS_Import"
   - "Export Transfer Mode Name:" "COMOS_Export"
4. To make the display clearer, move the new "Application Interface" type object from the "Newstuff" folder to the folder containing the "Collaboration Context" type object.

4.5.10 Creating a "Collaboration Context" for an existing unit

Requirement

A plant exists in Teamcenter.

Procedure

1. Select the plant, transfer it to the "Manufacturing Process Planer", and click "File > Save as new Collaboration Context".
2. Select the "MECollaborationContext" type.
3. Enter the name of the new "CollaborationContext".
4. Check that the entry "MEPlantContext" is selected for "Structure Context Type".
5. Click the "Save" to save.
6. To make the display clearer, move the created "Collaboration Context" type object from the "Newstuff" folder in "My Teamcenter" to the folder in which the "Collaboration Context" type object is usually saved.
7. Select the created "Collaboration Context" type object and create an "Application Interface" type object with the "COMOS_Al" subtype.
4.5.11 Creating a "Collaboration Context" for synchronizing a plant from COMOS

A unit has already been created in COMOS and there is no match for it in Teamcenter. To synchronize an existing plant from COMOS to Teamcenter, create a "Collaboration Context" type object in Teamcenter.

Requirement

- A "Collaboration Context" object has been created for resources in Teamcenter.
- Resources and types for the assignment have been specified in Teamcenter.
- An "Application Interface" has been added in Teamcenter.
- Resources are synchronized in COMOS.
- Resources and types are assigned in COMOS.

Procedure

1. Create an empty plant in Teamcenter of the type assigned to the base object in COMOS.
2. Transfer the plant to the "Manufacturing Process Planer". Select the plant and select the "File > Save as new Collaboration Context" command.
3. To make the display clearer, move the new "Collaboration Context" type object from the "Newstuff" folder to a suitable location.
4. Create an "Application Interface" for the "Collaboration Context".
5. Switch to COMOS.
6. Start the synchronization of the unit from COMOS to Teamcenter.

4.6 Configuring COMOS

4.6.1 Saving access data for Teamcenter in the project properties

To avoid having to enter all the access data for every data exchange with Teamcenter, you save the data in the project properties of COMOS.

Procedure

1. Select the "Teamcenter interface" category in the project properties.
2. Enter your access data.
3. Select a directory in the "Shared folder" field in order to allow data exchange between COMOS and NX. Configure NX accordingly so that the same directory is used.
Result

During data exchange you are only prompted to enter your password.

You can overwrite the access data at the "Teamcenter Interface" object on the base data tree or in the engineering view and enter other data.

4.6.2 Installing the buffer component for the COMOS client

Requirement

- The COMOS client and the Teamcenter installation are in use on different computers.
  In this case, install a Teamcenter component on the computer running the COMOS client.
  The Teamcenter TCCS is part of the Teamcenter data storage concept and caches files locally on the respective client. Data transfers between Teamcenter client and Teamcenter server take place over this cache. The installation file is located on the data carrier supplied with the product.

**Note**

**Installing the cache component**

If you are using the COMOS client and the Teamcenter installation on the same computer, you do not need the cache component. In this context, it does not matter whether you are using the Teamcenter server or the Teamcenter client.

- The software requirements for the Java Runtime Environment are met. See also chapter Software requirements (Page 11).

Procedure

1. Start the COMOS Setup browser on the data carrier supplied with the product.
2. Click the entry "Additional programs > Teamcenter TCCS". Confirm the prompt to run the file (if there is one) and follow the installation instructions.
3. Confirm the defaults.
4. Enter the following in the "FCC Parent Settings" window:
   To enter a link to the Teamcenter server, enter either the computer name or the IP address in the "Host" field.
5. Check whether the entry in the "Port" field matches the Teamcenter server setting. Change the setting if necessary.
   Default setting: 4544
6. Click the "Next" button.
7. Complete the installation.
8. Set the "FMS_HOME" environment variable to the directory in which you installed the cache component.
   Note that the environment variable for the relevant Windows user account must be set.
4.6.3 Synchronizing resources

The plant in Teamcenter comprises various types of objects called resources and types. To synchronize this plant to COMOS, the resources and types used must be declared in COMOS. When resources are synchronized, representations of the resources and types from Teamcenter are created in COMOS. This is achieved using data transfer using a transfer file. This file is also used to transfer resource information.

Following synchronization, you assign objects to the resources and types in COMOS. If you synchronize the resource information subsequently, the resource information from the transfer file is sent to all assigned COMOS objects.

Procedure

1. In the "Base objects" tab in the Navigator, select the "@20 > B60 > M06 > Y30 > A10 Teamcenter resources" node.

2. Select the "Teamcenter > Synchronize resources..." command from the context menu.
   - If an active connection to the Teamcenter does not exist, the "Teamcenter Login" window is called up. Enter the access information in this window and press "OK" to confirm your entry. See also chapter "Teamcenter login window" (Page 79).
   - When the connection to Teamcenter has been established, the "Synchronize resources" window opens.

3. Carry out the following settings in the "Synchronize Tc resources" window:
   - The first time the window opens, select the project corresponding to the resources in Teamcenter from the "Project selection" list.
   - If called again, the previously selected project is set by default. To select a new project, show the list using the "Project selection" button.
   - To retain existing data, activate the "Incremental update" option.
   - To create transferred data in a separate working layer, activate the "Create working layer" option.

4. To perform synchronization, click "OK".

Result

New resources are stored at various locations in COMOS depending on their type:

- Classified resources appear in the "@20 > B60 > M06 > Y30 > A10 > A20 Teamcenter classified resources" node
- Unclassified resources appear in the "@20 > B60 > M06 > Y30 > A10 > A30 Teamcenter unclassified resources" node
- Types appear in the "@20 > B60 > M06 > Y30 > A20 > A10 resource types" node
- Units of measurement appear in the "@20 > B60 > M06 > Y30 > A30 Teamcenter units of measurement" node
• Static formulas appear in the "@20 > B60 > M06 > Y30 > A40 > A10 Static Teamcenter Formulas node
• Dynamic formulas appear in the "@20 > B60 > M06 > Y30 > A40 > A20 Dynamic Teamcenter Formulas" node

Existing resources are updated in COMOS in the locations described.
See also chapter Calling the properties of synchronized resources (Page 34).

4.6.4 Calling the properties of synchronized resources

Procedure

1. Select the desired resource.
2. Open the properties.
3. Select the "Attributes > CTI resource mapping" tab.
4. Click the "Resource properties..." button.

Result

The "Element properties" window containing the relevant information from Teamcenter is displayed. See also chapter "Element properties" window (Page 81).

4.6.5 Assigning units of measurement

Objective

To use the units of measurement used in Teamcenter in COMOS, you carry out an assignment in COMOS.

Requirement

• Resources from Teamcenter are synchronized. See also chapter Synchronizing resources (Page 33).
• Attributes for assigning a COMOS unit of measurement are created automatically for the units of measurement used in the Teamcenter resources during the synchronization of resources.

Procedure

1. In the "Base objects" tab in the Navigator, select the "@20 > B60 > M06 > Y30 > A30 Teamcenter units of measurement" node.
2. Open the properties of the object.
3. Select the "Attributes > Teamcenter units of measurement" tab. A table containing columns called "Name", "Description", and "COMOS unit" is displayed.
   - If no rows are displayed, cancel the process. Either no units of measurement are used in Teamcenter or no assignment attributes have yet been created in COMOS. Assignment attributes are created automatically when synchronizing resources to COMOS.
   - If rows are displayed, the "Name" and "Description" fields have already been completed. Complete empty cells in the "COMOS unit" column.

4. To complete empty cells in the "COMOS unit" column, select an empty cell.
5. Select the "Properties > Attribute" command in the context menu.
6. Click the "..." button next to the "Unit" field.
7. In the "Groups" area of the "Unit selection" window, click the unit group matching the unit of measurement from Teamcenter, for example "Length".
8. Click the unit used in COMOS, for example "Meter".
9. Save the entries.
10. Repeat Steps 4 through 9 for all empty cells in the table.

Result

The units of measurement used in COMOS have been assigned to the units of measurement used in Teamcenter. These units of measurement are displayed in the "COMOS unit" column in the "Attributes > Teamcenter units of measurement" tab.

4.6.6 Assigning resources and types

Objective

For synchronization of a plant from Teamcenter, mappings are created in COMOS of the Teamcenter objects. When the mappings are created, the base objects used in each case are determined using the Teamcenter object type. Base objects are assigned to each of the types and resources.

Procedure

1. In order to map an object from Teamcenter in COMOS, create a base object or use an existing base object and add the "Y00T00128 @Y CTI instance mapping" tab. This tab is located in the "Base objects" tab in the Navigator under the "@40 > A20 > Y00 > A10 > A60>Y00T00128>A01" node.
2. In the "Base objects" tab in the Navigator, select the "@20 > B60 > M06 > Y30 > A10 Teamcenter resources" node.
3. Open the properties of a synchronized resource.
4. There must be an entry in the "Mapped base object" field in the "Attributes > CTI resource mapping" tab. See also chapter "CTI resource mapping" tab (Page 84). A suitable source object must contain the "Y00T00128 @Y CTI instance mapping" tab. Select one of the following options:

- If the required base object contains the necessary "Y00T00128 @Y CTI instance mapping" tab, drag the base object from the Navigator into the "Mapped base object" field.

- If the desired base object does not contain the required "Y00T00128 @Y CTI instance mapping" tab, add this tab and use drag&drop to move the added base object to the "Mapped base object" field.

   The tab is located under the "@40 > A20 > Y00 > A10 > A60>Y00T00128>A01" node.

**Note**

**Resources and base object**

Multiple Teamcenter resources can be assigned to a single COMOS base object. The Teamcenter objects are mapped by the same type of COMOS objects for the synchronization of a plant from Teamcenter.

An instance mapping must be specified for an individual resource for synchronization to Teamcenter. The first resource to which a base object is assigned is specified as the default value for the instance mapping of the base object.

To change the instance mapping, click the "Navigate, properties" button and navigate to the base object used during resource mapping. Open the properties of the base object and select the "Attributes > CTI instance mapping" tab. Click the "Select Tc resource" button. In the "Select Tc resource" window, select the required Teamcenter resource from the tree structure displayed.

5. Repeat steps 1 through 3 for other resources and types located in the "@20 > B60 > M06 > Y30 > A20 Teamcenter types" node.

**Note**

**Unassigned resources**

The assignment of the "Item" type is a different solution for synchronizing a plant with unassigned resources.

### 4.6.7 Assigning attributes

**Objective**

The relationship between the attributes saved for the Teamcenter objects and the corresponding attributes in COMOS is defined by the administrator. For classified resources, the attribute assignments can be inherited within the COMOS hierarchy.

To make this possible, you assign corresponding base objects to the resources from a classification. The base objects inherit the tabs and attributes from a common source.
Procedure

1. In the "Base objects" tab of the Navigator, select the "@20 > B60 > M06 > Y30 > A10 Teamcenter resources" node.
2. Open the properties of a synchronized resource.
3. Open the "Attributes > CTI attribute mapping" tab. Note the table in this tab. See also chapter "CTI attribute mapping" tab (Page 84).
4. Select the "Attributes > CTI resource mapping" tab. Use the "Navigate, properties" button to find the assigned object in the tree structure of COMOS. Search the tab for attributes matching the synchronized attributes from Teamcenter. See also chapter "CTI resource mapping" tab (Page 84).
5. Select the "Attributes > CTI attribute mapping" tab. Drag&drop the attributes from the COMOS tree structure into the row of the corresponding attribute synchronized from Teamcenter.
6. Repeat the above steps for other resources and types located in the "Base objects" tab in the Navigator under the "@20 > B60 > M06 > Y30 > A20 Teamcenter types" node.

4.6.8 Synchronizing resource information

Transfer file

One of the purposes of the transfer file is to transfer resource information. This transfer file is transferred at the same time as resources are synchronized.

Resource information contains:

- Labels used to reference Teamcenter objects
- Properties of objects as they are saved in Teamcenter These properties include, for example, the name, type, and description.
- Values of attributes synchronized to COMOS

After resources have been synchronized, objects are assigned to resources and types in COMOS. The additional information from the transfer file is then transferred to the assigned COMOS objects by synchronizing the resource information.

When the resources, attributes, and units have been assigned, additional information is read from the transfer file and transferred to the corresponding COMOS objects based on the assignments. This additional information includes attribute values, for example. These are values saved for the relevant attributes in Teamcenter.

You do not need to be connected to Teamcenter to synchronize the resource information. The data was transferred when the resources were synchronized and is available in the transfer file. See also chapter Synchronizing resources (Page 33).
Procedure

1. In the "Base objects" tab in the Navigator, select the "@20 > B60 > M06 > Y30 > A10 Teamcenter resources" node.

2. Select the "Teamcenter > Synchronize resource info..." command in the context menu.

3. If required, activate the "Create working layer" option in the "Synchronize resource info" window. See also chapter "Synchronize resource info" window (Page 83).

4. Click "OK" to synchronize the resource information.
5.1 Requirements for the connection between COMOS and NX.

Requirements for the connection

- You have access to COMOS and NX from your workplace.
- COMOS and NX communicate through a directory that is specified in the project properties, category "Teamcenter interface", field "Shared folder". You have to have access to this directory.
- If you are working with Windows 7, start COMOS with administrator rights.

5.2 Exporting pipe specs to Teamcenter

Requirement

- You have write rights for the base project.
- The pipe specs have already been created and configured.
- The XML file "pipepartfamilies" exists. See chapter XML file "pipepartfamilies" (Page 61).
- The NX template is assigned, meaning that the pipe parts have already been created and configured.

Note

Assigning pipe parts

No assignment of pipe parts is supplied with the database. See also chapter Assigning objects (Page 42).

Procedure

1. Open the base project.
2. Navigate to the desired pipe spec.
3. Select the "Teamcenter > Export pipe spec to Teamcenter" command from the context menu.
4. If you are not yet logged in, log in to Teamcenter in the "Teamcenter login" window. Various windows help you in the export process. Click the "Cancel" button to stop the process. Initially, a window with the pipe part catalog and the pipe specs is displayed. You can compare the last version of the data with the current version.
5. Check the information and click "Next".
6. Click "Next" in the "XMLViewer" window. See also chapter "XMLViewer" window (Page 86).

7. To export the pipe specs, click the "Transfer" button.

Result

After the transfer to Teamcenter has been completed, a corresponding notice is displayed. Two XML files are generated that are transferred to Teamcenter. The XML files contain information about the pipe specs and the pipe part catalog. Teamcenter stores the files under "Home > PDI" with the name of the pipe spec. "Home" is the node of the same name of the user with which you logged in.

5.3 Transferring P&IDs to Teamcenter/NX

Requirement

The settings for the base object of the document have been made.

- See chapter “Preparing transfer of P&IDs (Page 60)”.
- See chapter “Preparing transfer of documents (Page 62)”.

Procedure

1. Open the properties of the desired document.
2. Select the tab "Revisions".
3. Click the "Creates a new revision" button.
4. Click the "Yes" button in the "Create revision" window.
5. Expand the "Created by" button and select the "Released by" entry.
6. Transfer the P&ID to Teamcenter. See also chapter Integrated document management (Page 45).

Note

To read the content of the P&ID in NX, you must transfer the following files below the P&ID to Teamcenter:
- PDF file
- XML file "Piperun"
- XML file "XMpLant"

Result

The document is created in Teamcenter.
The following files are saved in the “Additional documents” folder under the revision of the P&ID:

- PDF file
- XML file "Piperun"
- XML file "XMpLant"

5.4 Connecting COMOS and NX

Requirement

- Requirements for the connection are met. See also chapter "Requirements for the connection between COMOS and NX." (Page 39).
- NX is opened.

Procedure

1. Open COMOS.
2. Select a P&ID in the Navigator.
3. Open the context menu.
4. Select the "Teamcenter > Start cross selection" command.
5. Switch to NX.
6. Select the menu entry "Tools > Schematics > Connect" in the main menu "Tools".

Result

When the connection has been established successfully, you have the following options on the P&ID:

- Connecting objects
- Navigating to the object in NX
- Disconnecting the connection between the objects

5.5 Disconnecting the connection between COMOS and NX

Requirement

COMOS and NX are connected. See chapter "Connecting COMOS and NX (Page 41)".
5.7 Canceling the assignment

Requirement
COMOS and NX are connected. See chapter "Connecting COMOS and NX (Page 41)".

Procedure
1. In COMOS, select the desired object on the P&ID.
2. Select the "Teamcenter > Unassign" command from the context menu.
Alternative procedure

1. Select the desired object in NX.
2. Select the menu entry "Tools > Schematics > Unassign" in the main menu "Tools".

Result

The assignment is canceled; you can no longer navigate between the respective object in NX and COMOS.

5.8 Navigating to the 3D object in NX

Requirement

- COMOS and NX are connected. See chapter "Connecting COMOS and NX (Page 41)".
- The object is assigned. See chapter Assigning objects (Page 42).
- The P&ID is open.

Procedure

1. Select the desired object on the P&ID.
2. Select the entry "Teamcenter > Navigate to NX" in the context menu.
3. Switch to NX.

Result

The corresponding object is centered in NX and highlighted.

5.9 Navigating to the COMOS object on the P&ID

Requirement

- COMOS and NX are connected. See chapter Connecting COMOS and NX (Page 41).
- The object is assigned. See chapter Assigning objects (Page 42).

Procedure

1. Select the object in NX.
2. Select the menu entry "Tools > Schematics > Navigate to PID Symbol" in the main menu "Tools".
3. Switch to COMOS.
5.9 Navigating to the COMOS object on the P&ID

Result

The corresponding object is displayed highlighted on the P&ID in COMOS.
The integrated document management enables you to do the following:

- Transfer documents created in COMOS to Teamcenter or assign them to existing Teamcenter documents
- Transfer revisions of COMOS documents to Teamcenter or assign them to existing revisions
- Add any number of documents to a revision and transfer them to Teamcenter
- Update metadata in both directions

### 6.1 Assigning a COMOS document to a Teamcenter document

#### Requirement

- A document to which you want to assign a COMOS document exists in Teamcenter.
- The "Teamcenter Interface" object is specified as an element at the base object of the document. See also chapter Preparing transfer of documents (Page 62).
- Optional: The "Teamcenter Interface" object is configured. See also chapter Configure the "Teamcenter Interface" object (Page 67).

#### Procedure

1. In the engineering view, select a document that is to be assigned to a document in Teamcenter.
2. Use the context menu to create the "Teamcenter Interface" object.
3. Log into Teamcenter using the context menu of the document.
4. Open the properties of the "Teamcenter Interface" object.
5. Select the "Attributes > PDI document settings" tab.
6. To select a document from the Teamcenter in the "Teamcenter Document" field, click "Select from TC".
7. In the "TC document mapping" window, enter a document name and a document type. Alternatively, specify only one document type to display all documents of this type.
8. Click "Search". The search results are displayed.
10. Click "OK". The window closes. The document ID is displayed in the "Teamcenter document" field.
6.2 Creating COMOS documents with user-defined settings in Teamcenter

To create COMOS documents with user-defined settings in Teamcenter, proceed as follows.

**Requirement**

The publication of documents is prepared. See also chapter Preparing transfer of documents (Page 62).

**Procedure**

1. In the engineering view, select a document that is to be created in Teamcenter.
2. Use the context menu to create the "Teamcenter Interface" object.
3. Log into Teamcenter using the context menu of the document.
4. Open the properties of the "Teamcenter Interface" object.
5. Select the "PDI document settings" tab.
6. Click the "Select from TC" button next to the "Document owner" field.
   The "Select document owner" window opens in which you specify under which owner the document is to be created in Teamcenter.
7. To display all Teamcenter objects under the Home directory, activate the "Home folder" option.
   Optional: To also display the items, activate the option "Show items".
   To start the search, click "Search".
8. To search for objects based on specific criteria, select the "Search" option.
   – To only display objects with a specific name component, enter a string, a substring or an asterisk (*) as placeholder in the "Owner name" field.
   – To only display objects of a specific type, select an entry from the "Item type" list.
   – To display objects that are assigned to you or the current group, select an entry from the "Scope" list.
9. Select the desired owner.
10. Click "OK".
    The window closes.
11. Select the document type to be created in Teamcenter from the "Document type" list.
12. Click the "Create TC document" button.
    The document is created under the owner.
    The document ID is entered in the "Teamcenter document" field.
13. If the document is to be created in Teamcenter under a workflow, select a template from the "Workflow template" list.

14. Click the "Create TC workflow" button next to the "Teamcenter Workflow" field.

---

**Note**

**Requirement for creation of a TC workflow**

Your user has permission to create workflows in Teamcenter.

---

15. Confirm your entries.

**Result**

In Teamcenter:

- The document is created under the specified owner.
- If you have not selected a workflow template, a workflow object is created. The TC document receives a reference to the workflow object.

In COMOS:

- The name of the Teamcenter document is entered in the "Teamcenter document" field in the "PDI document settings" tab.
- The metadata of the Teamcenter document is entered on the "PDI Teamcenter metadata" tab.
- If you have selected a workflow template, the name of the created workflow object is displayed in the "Teamcenter workflow" field in the "PDI document settings" tab.

**See also**

Configure the "Teamcenter Interface" object. (Page 67)

---

**6.3 Creating COMOS documents with standard settings in Teamcenter**

To create COMOS documents with the settings that are saved in the "Teamcenter Interface" base object in Teamcenter, proceed as follows.

**Requirement**

A document type and an owner is specified in the "Teamcenter Interface" base object. A workflow template can be specified as an option. See also chapter Configure the "Teamcenter Interface" object. (Page 67).

**Procedure**

1. In the engineering view, select a document that is to be created in Teamcenter.
2. Use the context menu to create the "Teamcenter Interface" object under the object.
3. Select the command "Teamcenter > Login" in the context menu of the document.

4. Select the command "Teamcenter > Create TC document" in the context menu of the document.

Result

In Teamcenter:
- The document is created under the specified owner.
- If you have not selected a workflow template, a workflow object is created. The TC document receives a reference to the workflow object.

In COMOS:
- The name of the Teamcenter document is entered in the "Teamcenter document" field in the "PDI document settings" tab. The metadata of the Teamcenter document is entered on the "PDI Teamcenter metadata" tab.
- If you have selected a workflow template, the name of the created workflow object is displayed in the "Teamcenter workflow" field in the "PDI document settings" tab.

6.4 Assigning a workflow template to a TC document subsequently

If you have already created a COMOS document in Teamcenter or have connected it to a Teamcenter document, you can subsequently assign a workflow template to the Teamcenter document.

Requirement

You have imported workflow templates. See also chapter Importing workflow templates (Page 64).

Procedure

1. Open the properties of the "Teamcenter Interface" object under the COMOS document.
2. Select the "PDI document settings" tab.
3. Select a workflow template.
4. Click the "Create TC workflow" button.
5. Click "OK".

Result

- A workflow object is created in Teamcenter. The TC document receives a reference to the workflow object.
- The name of the created workflow object is displayed in the "Teamcenter Workflow" field in the "PDI document settings" tab.
6.5 Creating revision and transferring documents to Teamcenter

You can create a revision for a COMOS document in Teamcenter and assign a released COMOS revision to it. When creating the revision, you have the option to transfer documents of the COMOS revision to Teamcenter.

Requirement

- A Teamcenter document is assigned to the COMOS document.
- At least one released COMOS revision exists for the document.
- To use dataset types and relations other than the default ones, you have to import these objects from Teamcenter.
  - See also chapter Importing dataset types (Page 65).
  - See also chapter Importing relation types for datasets (Page 66).
- The publication of documents is prepared. See also chapter Preparing transfer of documents (Page 62).
- A "Teamcenter Interface" object is located under the document.

Procedure

1. Select a COMOS document.
2. Select the "Teamcenter > Login" command in the context menu.
3. Select the "Teamcenter > Create TC revision" command in the context menu.
   The "Create TC revision" window opens.
4. Select an entry from the "COMOS revision" list to connect an existing COMOS revision with a Teamcenter revision.
5. Optional: To assign a workflow template to the revision, select an entry from the "Workflow template" list.
6. Optional: Activate the option "Submit documents to TC".
   - Active: All documents of the COMOS revision are transferred to Teamcenter under the newly created revision with default settings.
   - Deactivated: Documents are not transferred. You can subsequently select manually which documents are to be transferred and change the settings for the document transfer.
7. Click "OK".
   - A revision is created under the "Teamcenter Interface" object.
   - The COMOS revision is connected to the Teamcenter revision.
   - The metadata of the revision from Teamcenter are read in and entered on the "PDI Teamcenter Metadata" tab at the "Teamcenter Revision" object.
   - If you have activated the option "Transfer the documents to TC immediately", all documents of the COMOS revision are transferred to Teamcenter under the newly created revision.

8. If you later select the "Teamcenter > Create TC revision" command again, you can decide whether a new revision is to be created in Teamcenter.
   "Create new TC revision" option:
   - Activated: A new revision is created in Teamcenter. The COMOS revision is linked to it.
   - Deactivated: The COMOS revision is linked to the Teamcenter revision created last.

6.6 Transferring documents of a revision subsequently

If you have created a revision in Teamcenter without transferring documents or if you want to add additional documents to the revision, you can transfer these documents subsequently.

Requirement

You have created a revision in Teamcenter for a COMOS document. See also chapter Creating revision and transferring documents to Teamcenter (Page 49).

Procedure

1. In COMOS, navigate to the document that you have revised.
2. Open the revision under the "Teamcenter Interface" object.
3. Select the "Attributes > PDI revision settings" tab in the properties of the "Teamcenter Revision" object.
   The name of the assigned Teamcenter revision is displayed in the "Teamcenter Revision" field.
   All the released COMOS revisions of the document are displayed in the "COMOS revision" list.
4. Optional: Select a different COMOS revision that is to be connected to a Teamcenter revision.
5. Click the "Refresh" button.
   The table with the documents of the revision is updated and shows all documents of the selected COMOS revision.
   Each document of the revision is displayed in a line.
6. Select the type which the document is to have in Teamcenter in the "Dataset type" column of the table.
7. Select the relation which the document is to have to its revision in Teamcenter in the "Relation" column.

8. Select whether the document is to be transferred to Teamcenter in the "Transmittal" column.
   "Documents were transferred" field: Shows whether a document was transferred to Teamcenter during a previous revision.
   "Info text" field: Shows whether an error occurred during the transfer.

9. Click the “Transfer documents to TC” button.

10. Optional: Select a workflow template for the revision.

11. Click the "Create TC workflow" button.
    A workflow is created under the revision in Teamcenter.

**Result**

- The selected documents of the COMOS revision are submitted to the Teamcenter under the existing revision.
- The metadata of the revision from Teamcenter are read in and entered on the "PDI Teamcenter Metadata" tab at the "Teamcenter Revision" object.

**See also**

[Preparing transfer of documents](Page 62)

### 6.7 Synchronizing metadata

You can use the metadata of a revision to synchronize in the direction from COMOS to Teamcenter, Teamcenter to COMOS or bidirectionally. The administrator can specify which attributes are to be synchronized and the direction for the synchronization. See also chapter Setting the direction of the synchronization of metadata (Page 68).

You have the following options:

- Using the context menu in the Navigator
- At the "Teamcenter Interface" object

#### Synchronizing using the context menu

1. Open the context menu of a document under which the "Teamcenter Interface" object is located.

2. Select one of the following commands:
   - "Teamcenter > Synchronize metadata from TC"
     Transfers the metadata from Teamcenter to COMOS and enters it in the "PDI Teamcenter metadata" tab.
   - "Teamcenter > Synchronize metadata to TC"
     Transfers the metadata from COMOS to Teamcenter.
Synchronizing at the "Teamcenter Interface" object

1. Open the properties of the "Teamcenter Interface" object under a document.
2. Select the "PDI Teamcenter metadata" tab.
3. Click one of the following buttons:
   - "Synchronize from TC"
     Transfers the metadata from Teamcenter to COMOS and enters it in the "PDI Teamcenter metadata" tab.
   - "Synchronize to TC"
     Transfers the metadata from COMOS to Teamcenter.
Integrated change management

The integrated change management allows you to create change requests, problem reports or other objects for change management in COMOS and to export them to Teamcenter. You can create a workflow for objects for the change management in Teamcenter. In Teamcenter, you decide on the future handling of the objects.

7.1 Change management for units

Change management takes place based on the objects for change management. You create these objects in the engineering view for a mapped unit or the mapping objects below the unit.

Requirement

- The required types and workflows have been imported and edited. See also chapter Importing relation types for change objects (Page 73).
- The unit is mapped and synchronized. See also chapter Transferring data from Teamcenter to COMOS (Page 13).
- The unit has been prepared for change management. See also chapter Preparing units for change management (Page 73).
- You have edited the project properties. See also chapter Configuring "Change management backlog" in the project properties (Page 72).

Procedure

1. In the engineering view, select one or more COMOS objects of a mapped unit for which you want to create objects for change management.
2. Select the entry "Teamcenter > Prepare change object" in the context menu of the selected objects. The "Prepare change object" window opens. A change object is created under the node which you have specified in the project options in the "Prepared change objects" field.
3. Enter a short description of the change object in the "Synopsis" field.
4. Select the type which the change object is to have in the "Change type" list.
5. Optional: Select an entry in the "Workflow template" list to link the change object to a workflow.
6. The "List of reference/impacted items" includes the object for which you have started change management.
   - Optional: To add additional objects, drag&drop COMOS objects mapped in Teamcenter to the "List of reference/impacted items" field.
   - To delete objects from the list, click on "Remove from list".
   References are created in Teamcenter for all objects in the "List of reference/impacted items" field.

7. Select a relation type from the list to the right of the objects in the "List of reference/impacted items" field.
   If you do not select an entry, the relation type defined in the base object tree at the type of the change object is used.

8. Enter a detailed description of the change object in the "Description" field.
   The description has an unlimited number of characters and, depending on the change object, should specify an existing problem or a change request.

9. Select an object to transfer the Teamcenter ID of an object in the "List of reference/impacted items" field to the description.

10. Click "Append ID to description".
    The ID is placed at the end of the text in the "Description" field.

11. Confirm your entries.

Result

- In Teamcenter:
  The change object and a change revision of the object are created.
  PseudoFolders are created under the revision in which the appended COMOS objects are sorted according to the relation type used.
  If you have selected a workflow template, a workflow is created and started.

- In COMOS:
  The change object is moved under the node which you have specified in the project options in the "Submitted change objects" field. An object is created for all included relation types below the change object.

7.2 Change management for documents

Requirement

- The document is assigned to a Teamcenter document.
- The required types and workflows have been imported and edited. See also chapter Preparing integrated change management (Page 70).
- You have edited the project properties. See also chapter Configuring "Change management backlog" in the project properties (Page 72).
Procedure

1. In the engineering view, select a document for which you want to create objects for change management.

2. Select the entry "Teamcenter > Prepare change object" in the context menu of the selected objects.
   The "Prepare change object" window opens.
   A change object is created under the node which you have specified in the project options in the "Prepared change objects" field.

3. Enter the name of the change object in the "Overview" field.

4. Select the type which the change object is to have in the "Type" list.

5. Optional: Select an entry in the "Workflow template" list to link the change object to a workflow.

6. The "List of reference/impacted items" includes the object for which you have started change management.
   – Optional: To add additional objects, drag&drop COMOS objects mapped in Teamcenter to the "List of reference/impacted items" field.
   – To delete objects from the list, click on "Remove from list".
   References are created in Teamcenter for all objects in the "List of reference/impacted items" field.

7. Select a relation type from the list to the right of the objects in the "List of reference/impacted items" field.
   If you do not select an entry, the relation type defined in the base object tree at the type of the change object is used.

8. Enter a detailed description of the change object in the "Description" field.
   The description has an unlimited number of characters and, depending on the change object, should specify an existing problem or a change request.

9. Select an object to transfer the Teamcenter ID of an object in the "List of reference/impacted items" field to the description.

10. Click "Append ID to description".
    The ID is placed at the end of the text in the "Description" field.

11. Confirm your entries.

Result

- In Teamcenter:
  The change object and a change revision of the object are created.
  PseudoFolders are created under the revision in which the appended COMOS objects are sorted according to the relation type used.
  If you have selected a workflow template, a workflow is created and started.

- In COMOS:
  The change object is moved under the node which you have specified in the project options in the "Submitted change objects" field. An object is created for all included relation types below the change object.
7.3 Submitting Teamcenter tasks to COMOS

**Requirement**
You have prepared a workflow step in Teamcenter for which tasks are to be created in COMOS. See also chapter Prepare transfer of Teamcenter tasks to COMOS (Page 74).

**Procedure**
1. Execute the task in Teamcenter for which you have prepared a transfer to COMOS.
2. Mark the workflow step as completed.

**Result**
- The task is automatically transferred to COMOS. It is created in COMOS in the "Locations" tab according to the settings for the task management.
- The properties of the task include the values that were specified in the Action Handler.

7.4 Querying change objects from Teamcenter

**Requirement**
You have created change objects and transferred them to Teamcenter.
- See also chapter Change management for units (Page 53).
- See also chapter Change management for documents (Page 54).

**Procedure**
1. In the engineering view, select the node you have specified in the project properties in the "Submitted change objects" field in the "Teamcenter interface" category.
2. In the context menu, select the command "Query change objects from TC".
3. Enter your login information for Teamcenter if requested. The "Query change objects from TC" window opens.
4. Optional: Enter the short description of the change object in the "Synopsis" field. The "*" character can be used as a wildcard.
5. Select a type for which you are searching from the "Change object type" list.
6. In the "Scope" list, select if you want to search for change objects of the current user or of the user group.
7. Click "Search". The search results are listed.
8. To close the window, click "OK" or "Cancel".
7.4 Querying change objects from Teamcenter
7.4 Querying change objects from Teamcenter
8.1 Synchronizing project data with Teamcenter

8.1.1 Adding an attribute

Requirement
You have called up the "Pipe part attribute mapping" window. See chapter "Editing the XML file "pipepartfamilies"" (Page 51).

Procedure
1. Right-click under a table.
2. Select the "Add row" command.
3. Enter the desired information in the "Pipe part attribute mapping" window.
4. Click "OK".

8.1.2 Editing an attribute

Requirement
You have called up the "Pipe part attribute mapping" window. See chapter "Editing the XML file "pipepartfamilies"" (Page 51).

Procedure
1. Right-click the desired attribute.
2. Select the "Edit row" command from the context menu.
3. Carry out the required changes in the "Pipe part attribute mapping" window.
4. Click "OK".
8.1.3 Deleting an attribute

**Requirement**
You have called up the "Pipe part attribute mapping" window. See chapter "Editing the XML file "pipepartfamilies" (Page 61)".

**Procedure**
1. Right-click the desired attribute.
2. Select the "Remove row" command from the context menu.

8.2 2D-based 3D design

8.2.1 Preparing transfer of P&IDs

**Objective**
To enable the user to publish a P&ID in Teamcenter, you specify the base object of the document and assign the necessary revision type to the user.

**Procedure**
1. Navigate to the base object of the document.
2. Open the properties.
3. Select the "Elements" tab.
4. Navigate to the following object: "@20 > B60 > M06 > A10 > A30 Teamcenter Interface"
5. Configure the object if it has not been configured yet. See also chapter Configure the "Teamcenter Interface" object, (Page 67).
7. Set the following at the generated element: "Virtual" = "1"
8. Select the "System" tab.
9. Select the "Teamcenter revision" entry in the "Revision type" list.
10. Save the setting.
11. Make the document available to the user.

You can find additional information on this topic in the "Operation" manual, keyword "General" tab for documents". 
Result
All the derived documents in the engineering view use the revision type "Teamcenter Revision". A "Teamcenter Interface" object which allows data exchange with Teamcenter can be created below the documents.

8.2.2 XML file "pipepartfamilies"

General
The XML file "pipepartfamilies" is located in the installation directory of COMOS in the "config \pdi" folder.

A pipe part family from NX has to be mapped for each pipe part in COMOS. The pipe part family categorizes pipe parts. The mapping is saved in the XML family. The mapping can be edited in the file "pipepartfamilies.xml" either in COMOS or via an XML editor.

Recommendation
Edit the content of the XML file only in COMOS. See chapter "Editing the XML file "pipepartfamilies" (Page 61)".

8.2.3 Editing the XML file "pipepartfamilies"

Procedure
1. Open the base project in COMOS.
2. Navigate to a pipe spec.
3. Select a pipe part lying under it.
4. Select the "Teamcenter > Map attribute configuration" command from the context menu.
5. Carry out the required changes in the "Pipe part attribute mapping" window:
   - See chapter "Adding an attribute (Page 59)".
   - See chapter "Editing an attribute (Page 59)".
   - See chapter "Deleting an attribute (Page 60)".
6. Click "OK".
8.2.4 Configuration of the "Pipe part attribute mapping" window

Overview

<table>
<thead>
<tr>
<th>Control group</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;ID Mask&quot;</td>
<td>This displays the information on how the ID of the pipe part is generated.</td>
</tr>
<tr>
<td>&quot;Nx template&quot;</td>
<td>This list contains all the pipe part families that are supported by PDI. You can change the pipe part family for the selected pipe part.</td>
</tr>
<tr>
<td>&quot;Text Based Attributes&quot;</td>
<td>This table contains all the family attributes with values as text.</td>
</tr>
<tr>
<td>&quot;General Attributes&quot;</td>
<td>This table contains family attributes that have no connection to the geometry of the pipe part.</td>
</tr>
<tr>
<td>&quot;Geometry Attributes&quot;</td>
<td>This table contains all the attributes of the selected pipe part with a connection to geometry. In the &quot;Check&quot; column, you set whether a value is interpreted as valid or not by PDI. At invalid values, the respective checkbox is cleared and the pipe part is not exported.</td>
</tr>
</tbody>
</table>

8.3 Preparing integrated document management

8.3.1 Preparing transfer of documents

Objective

To enable the user to transfer documents in Teamcenter, configure the base object of the document.

Procedure

1. Navigate to the base object of the document.
2. Open the properties.
3. Select the "Elements" tab.
4. Navigate to the following object: "@20 > B60 > M06 > A10 > A30 Teamcenter Interface"
5. Configure the object if it has not been configured yet. See also chapter Configure the "Teamcenter Interface" object, (Page 67).
7. Set the following at the generated element: "Virtual" = "1"
8. Save the setting.
9. Make the document available to the user.

You can find additional information on this topic in the "Operation" manual, keyword "General" tab for documents".

Result

You can use the context menu to create a "Teamcenter Interface" object which allows data exchange with Teamcenter below the derived documents.

8.3.2 Checking the settings of the revision printer

In order to publish documents, the corresponding settings must have been made. Check the relevant settings before publishing a document for the first time or if errors occur.

Procedure

1. Open the project properties.
2. Select the "General settings > Revision options" category.
3. Check in the "Settings" control group whether the "PDFFactory (as of v. 1.5x)" entry has been selected in the "Revision archive" list.

8.3.3 Importing document types

Requirement

- The publication of documents is prepared. See also chapter Preparing transfer of documents (Page 62).
- The "Teamcenter Interface" object is configured. See also chapter Configure the "Teamcenter Interface" object (Page 67).

Procedure

1. Navigate to the following object: "@20 > B60 > M06 > Y30 > A20 Teamcenter Types"
2. Select the "Teamcenter > Login" command in the context menu.
3. Log in to Teamcenter.
4. Select the "Teamcenter > Import document types from TC" command in the context menu.
5. The "Select for import" list displays all the document types from Teamcenter that are located under the preset root types.
6. In order to display the document types under a different base type, enter the name of a different type in the "Root type name" field. Click the "Retrieve types below root" button.
7. Select one or more document types.
8. Confirm your entries.

Result

- The document types are created under the following object: "@20 > B60 > M06 > Y30 > A20 > A30 Document types"
- The document types are offered for selection in the properties of the "Teamcenter Interface" object.

8.3.4 Importing workflow templates

To assign a workflow to a document in COMOS, import the workflow templates for document management from Teamcenter.

Requirement

- The transfer of documents is prepared. See also chapter Preparing transfer of documents (Page 62).
- The "Teamcenter Interface" object is configured. See also chapter Configure the "Teamcenter Interface" object. (Page 67).

Procedure

1. Navigate to the following object: "@20 > B60 > M06 > Y30 > A50 Workflow templates preselection"
2. Select the "Teamcenter > Login" command in the context menu.
3. Log in to Teamcenter.
4. Select the "Teamcenter > Import workflow templates for document management" command in the context menu.
5. The "Select for import" list displays all the templates for workflows from Teamcenter.
6. Select one or more templates.
7. Confirm your entries.

Result

The selected templates are created under the following object:
"@20> B40 > M06 > Y30 Workflow templates definition"
8.3.5 Manually creating workflow templates

If you do not have access to Teamcenter, you can create the workflow templates manually in COMOS.

**Procedure**

1. Navigate to the following object: 
   
   "@20 > B40 > M06 > Y30 Workflow template definition"

2. Select "New > Base object" from the context menu.

3. Open the properties of the new base object.

4. Enter the name of an existing workflow template from Teamcenter as name.

5. Close the properties.

6. Navigate to the following object: 
   
   "@20 > B60 > M06 > Y30 > A50 > A20 Document management"

7. Select "New > Base object" from the context menu.

8. Open the properties of the new base object.

9. Drag&drop the newly created base object under the node "Y30 Workflow template definition" to the "Base object" field.

**Result**

The template is offered for selection during management of documents and revisions.

8.3.6 Importing dataset types

You need dataset types to specify documents that you want to transfer to Teamcenter with the help of revisions.

Import the dataset types for document management when the types are missing in COMOS.

**Procedure**

1. Navigate to the following object: 
   
   "@20 > B60 > M06 > Y30 > A20 Teamcenter types"

2. In the context menu, select the "Teamcenter > Import dataset types from TC" command. The window for the import opens.

3. Optional: In the "Root type name" field, enter the name of another root node from the Teamcenter type hierarchy with child objects that are to be displayed in the "Select for import" list.

4. Click the "Retrieve types below root" button. The entries in the "Select for import" list are updated.

5. From the list, select one or more types to be imported.

6. Confirm your entries.
8.3 Preparing integrated document management

Result

The imported objects are created in COMOS under the following nodes:
Dataset types: "@20 > B60 > M06 > Y30 > A20 > A40 Dataset types"

The objects are offered for selection at the "Teamcenter Revision" object on the "PDI revision settings" tab.

8.3.7 Importing relation types for datasets

You need relation types during transfer of additional documents of a revision to specify the documents.

See also chapter Creating COMOS documents with user-defined settings in Teamcenter (Page 46).

By default, a selection of relation types is available under the node "@20 > B60 > M06 > Y30 > A20 > A50 > A20 Document management". To import additional types, follow these steps:

Procedure

1. Navigate to the following object: "@20 > B60 > M06 > Y30 > A20 Teamcenter types"
2. In the context menu, select the entry "Teamcenter > Import document relation types from TC".

   The window for the import opens.
3. Optional: In the "Primary object type" field, enter the name of another node with child objects that are to be displayed in the "Select for import" list.
4. Click the "Retrieve relation types" button.

   The entries in the "Select for import" list are updated.
5. From the list, select one or more types to be imported.
6. Confirm your entries.

Result

The imported types are created in COMOS under the following node:
"@20 > B60 > M06 > Y30 > A20 > A50 > A20 Document Management"

8.3.8 Importing item types

Import additional item types in COMOS to simplify the search for an owner when creating a Teamcenter document. You use the item types for the search to only display objects of a specific type.

See also chapter Creating COMOS documents with user-defined settings in Teamcenter (Page 46).
By default, the following item types are available in the database:

- "Folder"
- "Item"

**Procedure**

1. Navigate to the following object: 
   "@20 > B60 > M06 > Y30 > A20 Teamcenter types"
2. In the context menu, select the "Teamcenter > Import item types from TC" command. The "Import item types from TC" window opens.
3. Optional: In the "Root type name" field, enter the name of another node from the Teamcenter type hierarchy with objects that are to be displayed in the "Select for import" list.
4. Click the "Retrieve types below root" button. The entries in the "Select for import" list are updated.
5. From the list, select one or more types to be imported.
6. Confirm your entries.

**Result**

The imported objects are created in COMOS under the following nodes:

"@20 > B60 > M06 > Y30 > A20 > A60 item types"

**8.3.9 Configure the "Teamcenter Interface" object.**

This object must be created in the engineering view to make the following possible:

- Creating documents in the Teamcenter
- Assigning COMOS documents and Teamcenter documents to each other
- Revisioning documents and submitting documents under a revision to Teamcenter.

**Requirement**

- The publication of documents is prepared. See also chapter [Preparing transfer of documents](#Page 62).
- Optional: You have imported objects from Teamcenter. See also chapters [Importing document types](#Page 63) and [Importing dataset types](#Page 65).

**Procedure**

1. Navigate to the following object: 
   "@20 > B60 > M06 > A10 > A30 Teamcenter Interface"
2. Open the "Teamcenter access" tab in the properties of the object.
3. To avoid having to enter the access data for Teamcenter at each document in the engineering view, enter the data here.

4. Specify the settings for the creation of COMOS documents:
   - To specify the default settings for the creation of COMOS documents in Teamcenter, configure the "PDI document settings" tab.
     Configuration: See also chapter Creating COMOS documents with user-defined settings in Teamcenter (Page 46).
     When you make default settings, users can create documents directly in the engineering view with the context menu without any additional settings. See also chapter Creating COMOS documents with standard settings in Teamcenter (Page 47).
   - In order to carry out the configuration for each document individually, configure the object in the engineering view. See also chapter Assigning a COMOS document to a Teamcenter document (Page 45).

8.3.10 Setting the direction of the synchronization of metadata

If you use the objects "Teamcenter Interface" and "Teamcenter Revision", the metadata of the document or the revision are entered in the "PDI Teamcenter metadata" tab. Users can synchronize the metadata with Teamcenter at a later time.

If you have created new attributes in the "PDI Teamcenter metadata" tab, you must use a predefined query to specify the Teamcenter attribute with which you want to synchronize and the direction for the synchronization.

Using the query, you can change the direction of the synchronization of existing attributes.

Procedure

1. Open the following query:"@20 > A70 > Y20 > M06 > A40 TC Metadata"

2. To change the metadata for documents, navigate to the following object:
   
   "@20 > B60 > M06 > A10 > A30 Teamcenter Interface"

   To change the metadata for revisions, navigate to the following object:
   
   "@20 > B60 > M06 > A10 > A40 Teamcenter Revision"

3. Expand the node in the Navigator.

4. Drag&Drop the "PDI Teamcenter metadata" tab into the "Start object" field of the query.
5. The query lists all the attributes of the tab.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Soa key</th>
<th>Direction</th>
</tr>
</thead>
<tbody>
<tr>
<td>BU001</td>
<td>Synchronize from Tc</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BU002</td>
<td>Synchronize to Tc</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Creation_date</td>
<td>Created on</td>
<td>creation_date</td>
<td>tc</td>
</tr>
<tr>
<td>Item_id</td>
<td>ID</td>
<td>item_id</td>
<td>tc</td>
</tr>
<tr>
<td>Last_mod_date</td>
<td>Last modified date</td>
<td>last_mod_date</td>
<td>tc</td>
</tr>
<tr>
<td>Last_mod_user</td>
<td>Last modified user</td>
<td>last_mod_user</td>
<td>tc</td>
</tr>
<tr>
<td>Object_desc</td>
<td>Description</td>
<td>object_desc</td>
<td>&lt;&gt;</td>
</tr>
<tr>
<td>Object_name</td>
<td>Name</td>
<td>object_name</td>
<td>tc</td>
</tr>
<tr>
<td>Object_type</td>
<td>Type</td>
<td>object_type</td>
<td>tc</td>
</tr>
<tr>
<td>Owning_user</td>
<td>Created by</td>
<td>owning_user</td>
<td>tc</td>
</tr>
</tbody>
</table>

Attributes
– "Name": Name of the COMOS attribute
– "Description": Description of the COMOS attribute
– "Soa key": ID of an attribute from the Teamcenter with which the COMOS attribute is synchronized
– "Direction": Direction of the synchronization

6. To change the direction of the synchronized, edit the "Direction" column
Possible values:
– "tc": Synchronization only from Teamcenter to COMOS
– "ct": Synchronization only from COMOS to Teamcenter
– "<>": Synchronization bidirectional

7. If you have created a new COMOS attribute, enter the Soa key of a Teamcenter attribute in the "Soa key" column and specify a direction.

Result

- If a user clicks on "Synchronize from TC" in the "PDI Teamcenter metadata" tab, the COMOS attributes with value "tc" or "<>" the "Direction" column are updated.
- If a user clicks on "Synchronize to TC" in the "PDI Teamcenter metadata" tab, the Teamcenter attributes with value "ct" or "<>" the "Direction" column are updated.

See also chapter Synchronizing metadata (Page 51).
8.4 Preparing integrated change management

8.4.1 Importing workflow templates

Requirement
You have created workflow templates for the change management in Teamcenter.

Procedure
1. Open the base project.
2. Navigate to the following object: "@20 > B60 > M06 > Y30 > A50 Workflow templates preselection"
3. Select the "Teamcenter > Import workflow templates for change management" command in the context menu.
4. Log in to Teamcenter.
   The "Select for import" list displays all the workflow templates from Teamcenter.
5. Select one or more workflow templates to be imported.
6. Confirm your entries.

Result
The selected templates are created under the following object:
"@20> B40 > M06 > Y30 Workflow templates definition"

8.4.2 Manually creating workflow templates

If you do not have access to Teamcenter, you can create the workflow templates manually in COMOS.

Procedure
1. Navigate to the following object: "@20 > B40 > M06 > Y30 Workflow template definition"
2. Select "New > Base object" from the context menu.
3. Open the properties of the new base object.
4. Enter the name of an existing workflow template from Teamcenter as name.
5. Close the properties.
6. Navigate to the following object: @20 > B60 > M06 > Y30 > A50 > A10 Change management"
7. Select "New > Base object" from the context menu.
8. Open the properties of the new base object.

9. Drag&drop the newly created base object under the node "Y30 Workflow template definition" to the "Base object" field.

Result

The template is offered for selection in the properties of Teamcenter Interface objects in the "PDI document settings" tab.

8.4.3 Importing types of change objects

By default, the following types of change objects exist in COMOS:

- Change report
- Change request
- Problem report

To use other types, import the types from Teamcenter.

Procedure

1. Open the base project.
2. Navigate to the following object: "@20 > B60 > M06 > Y30 > A20 Teamcenter types"
3. Select the "Teamcenter > Login" command in the context menu.
4. Select the "Teamcenter > Import change object types from TC" command in the context menu.
5. Optional: In the "Root type name" field, enter the name of another node from the Teamcenter type hierarchy with child objects that are to be displayed in the "Select for import" list.
   Click the "Retrieve types below root" button.
   The entries in the "Select for import" list are updated.
6. From the list, select one or more types to be imported.
7. Confirm your entries.

Result

The imported types are created under the following object: "@20 > B60 > M06 > Y30 > A20 > A20 Change management types".

8.4.4 Configuring change objects

To preconfigure change objects, edit the types of change objects.
Procedure

1. Navigate to the object: "@20 > B60 > M06 > Y30 > A20 > A20 Change management types".
2. Open the properties of an imported type.
3. Select the "Attributes > PDI change object settings" tab.
   The "Workflow template" list displays the imported workflows which lie under the object that is specified in the "Parent node for workflow templates" field.
4. Optional: Select a template in the "Workflow template" list that is to be used as default for this type.
5. Optional: If you created workflow templates under a different node, select the corresponding parent node in the "Workflow templates parent node" field. With different parent nodes, you can narrow down the options according to type.
   The entries in the "Workflow template" list are updated in the base object tree and in the engineering view. Workflows that have already been selected are retained.
6. Optional: If you want to use a user-defined relation for documents, select a different object in the "Default relation for documents" field.
   Requirement: You have imported the relation into COMOS. See also chapter Importing relation types for change objects (Page 73).
7. Optional: If you want to use a user-defined relation for items, select a different object in the "Default relation for items" field.
   Requirement: You have imported the relation into COMOS.
8. Confirm your entries.

Result

The change objects are preconfigured according to their settings in the engineering view.

8.4.5 Configuring "Change management backlog" in the project properties

Procedure

1. Open the "Teamcenter Interface" category in the project properties.
2. In the "Task inventory for change management" control group, select the engineering objects under which you want to save the objects for change management:
   - "Prepared change objects" field Object under which change objects are created after before they are transferred.
   - "Submitted change objects" field Object under which change objects are moved after they have been submitted.
3. Confirm your entries.
4. Navigate to the base objects of the engineering objects that you have defined in the "Task inventory for change management" control group.
5. Select the "Classification" tab.
6. Select the classification "A490 Teamcenter object" as "Functional classification".

### 8.4.6 Importing relation types for change objects

You need relation types when preparing change objects to specify the impacted elements and reference elements.

See also the following chapters:
- Change management for units (Page 53)
- Change management for documents (Page 54)

By default, the following types are available in the database under the following node "@20 > B60 > M06 > Y30 > A20 > A50 > A10 Change management":
- Problem elements
- Reference elements

To import additional types, follow these steps:

**Procedure**

1. Navigate to the following object: "@20 > B60 > M06 > Y30 > A20 Teamcenter types"
2. In the context menu, select the entry "Teamcenter > Import relation types for change objects from TC".
   The window for the import opens.
3. Optional: In the "Primary object type" field, enter the name of another node from the Teamcenter hierarchy with child objects that are to be displayed in the "Select for import" list.
   Click the "Retrieve relation types" button.
   The entries in the "Select for import" list are updated.
4. From the list, select one or more types to be imported.
5. Confirm your entries.

**Result**

The imported types are created in COMOS under the following node:
"@20 > B60 > M06 > Y30 > A10 > A50 > A10 Change Management"
8.4 Preparing integrated change management

Procedure

1. Open the base object properties of a unit.
2. Select the "Elements" tab.
3. Drag&drop the object "@20 > B60 > M06 > A10 > A10 Teamcenter Integrator" to the tab.
4. Confirm your entries.

8.4.8 Prepare transfer of Teamcenter tasks to COMOS

Terminology: Action Handler and Workflow Handler are synonyms.

Requirement

- The Windows server is configured and SSL is set up.
  You can find additional information on this topic in the "Mobile Solutions" manual, keyword "Installation and configuration".
- The database is prepared for task management.
  You can find additional information on this topic in the "Administration" manual, keyword "Overview of task management".

Procedure

1. Open the "Workflow Designer" in Teamcenter.
2. Select a workflow step for which tasks are to be created in COMOS.
3. Define the following Action Handler in a workflow step:
"Com2-create-COMOS-Task"
Additional information regarding the procedure can be found in the Teamcenter documentation.

4. Configure the Action Handler.
Enter a fixed value or a tag for the arguments of the Action Handler:

**Note**
**Showing quotation marks in combined texts**
If you wish to fill a COMOS attribute or a description with a combined text using the -taskDesc argument, you can use multiple key words in an argument value.
If the combined text should contain quotation marks, precede them with a backslash: \\
Otherwise, quotation marks will be removed.

<table>
<thead>
<tr>
<th>Argument</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;-service&quot;</td>
<td>Enter the COMOS server and port of the Windows server. Example: <a href="https://vmhost:44444">https://vmhost:44444</a></td>
</tr>
<tr>
<td>&quot;-db&quot;</td>
<td>Enter the index of a &quot;&lt;Key&gt;&quot; node from the file &quot;Comos.Web.config.xml&quot;. You use the index to select the database in which COMOS tasks are created. You can find additional information on this topic in the &quot;Mobile Solutions&quot; manual, keyword &quot;Configure &quot;Comos.Web.config.xml&quot;.&quot;. Example: For a &lt;Key&gt;db1&lt;/Key&gt; node Enter the following: db1</td>
</tr>
<tr>
<td>&quot;-taskDesc&quot;</td>
<td>Enter the description of the task. Example: Teamcenter task</td>
</tr>
<tr>
<td>&quot;-projectUID&quot;</td>
<td>Enter the UID of the project in which you create tasks. This is usually a &quot;USERS&quot; project. Syntax: U:2:&lt;UID of the project&gt;:.</td>
</tr>
</tbody>
</table>

COMOS attributes refer to attributes of the following base object, "Data" tab:
"@20 > B43 > A10 > A10 > A10 Basic task"
Example: -Y00T00032.Y00A00788
Enter a value which is to be transferred to the created COMOS tasks.

**Note**
**Login to Windows Server**
The Windows authentication is used during login to the Windows Server.

**Note**
**Accepted certificates**
All certificates are accepted during login to the Windows Server.
Usable keywords for arguments in Action Handler

Teamcenter has a predefined set of keywords for the Action Handler. The following keywords are predefined, for example.

The common keywords are used in the sense described in the Teamcenter documentation. You can find more information on this topic in the Teamcenter documentation.

Common keywords:

- $USER
- $GROUP
- $ROLE
- $PROCESS_OWNER
- $PROCESS_GROUP
- $TARGET_OWNER[[Class]|Type]]
- $TARGET_GROUP[[Class]|Type]]
- $TARGET_OWNERS[[Class]|Type1[,Type2,...]]
- $TARGET_GROUPS[[Class]|Type1[,Type2,...]]
- $TARGET_OWNERS
- $ROLE_IN_GROUP
Handler-specific keywords:

- \$TARGET[Type].property_name
  Extract an attribute value from target objects of the workflow. You can define a type in square brackets from which a value is to be extracted.
  Example: \$TARGET[ChangeRequestRevision].object_desc
  Extracts the description of the last ChangeRequestRevision that was added to the workflow as an objective.
  If not attribute is set, "object_name" is removed.
  For example, \$TARGET is equivalent to \$TARGET.object_name.
  You can call a unique identifier by using the following: \$TARGET.uid.

- \$TASK.property_name
  Extract an attribute value from the current task of the workflow.
  If not attribute is set, "object_name" is removed.
  For example, \$TASK is equivalent to \$TASK.object_name.
  You can call a unique identifier by using the following: \$TASK.uid.

- \$PROCESS.property_name
  Extract an attribute value from the current workflow step.
  If not attribute is set, "object_name" is removed.
  For example, \$PROCESS is equivalent to \$PROCESS.object_name.

Note

A process is often named after the object for which it was created.

Depending on how you create a process, \$PROCESS.object_name and \$TARGET.object_name can differ.

You can call a unique identifier by using the following: \$PROCESS.uid.
8.4 Preparing integrated change management
9.1 Status area in windows

To keep track of time-consuming processes, the corresponding windows have a status area.

"Status" control group

The element at the top is a progress bar which displays the current status of the process. These windows have a status area for displaying system messages. When you start the particular process, system messages are output.

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Errors&quot;</td>
<td>The process has not been executed successfully. Further processing is not possible. Check the content of the error message and repeat the process with the correct settings.</td>
</tr>
<tr>
<td>&quot;Warnings&quot;</td>
<td>This message shows information about problems that do not prevent further operation but may lead to an unwanted result. When a warning is displayed, use the description to check the result of the process. If you wish to continue despite the warnings, click &quot;Cancel&quot;. To restart the process, click &quot;OK&quot;.</td>
</tr>
<tr>
<td>&quot;Messages&quot;</td>
<td>This message shows information that has no impact on further processing. It might contain additional information about the progress of the process, for example. To close the window, click &quot;Cancel&quot;.</td>
</tr>
</tbody>
</table>

To hide certain types of system message, click on the appropriate buttons ("Errors", "Warnings", or "Messages").

The entries in the status window are context-sensitive. To navigate to the cause of the system message, double-click on the entry in the status window. If the message is uniquely assigned to a specific COMOS object, the object is selected in the Navigator.

9.2 "Teamcenter login" window

To establish a connection to Teamcenter, log in.

If a connection to Teamcenter has to be established in order to perform steps, the "Teamcenter login" window will open automatically.

Alternatively, you can call the "Teamcenter login" window in the "Units" tab in the Navigator. To do this, select the "Teamcenter > Login..." command in the context menu for the mapping of the plant in COMOS.

As administrator, you can also open the context menu in the "Base objects" tab in the Navigator from the "@20 > B60 > M06 > Y30 > A10 Teamcenter resources" node.
**Login** control group

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Server&quot;</td>
<td>Specify the server in the following format: &quot;http://&lt;Server&gt;:&lt;Port&gt;/&lt;Database name&gt;&quot;.</td>
</tr>
<tr>
<td>&quot;User ID&quot;</td>
<td>The user name agreed upon together with the administrator.</td>
</tr>
<tr>
<td>&quot;Password&quot;</td>
<td>Password for authentication</td>
</tr>
<tr>
<td>&quot;Group&quot;</td>
<td>This field is optional and shows the group membership in the Teamcenter organization structure as it is stored in Teamcenter.</td>
</tr>
<tr>
<td>&quot;Role&quot;</td>
<td>This field is optional and shows the role in the selected group, if it deviates from the default role. The data is shown as they are stored in Teamcenter.</td>
</tr>
</tbody>
</table>

"Status" control group

See also chapter **Status area in windows** (Page 79).

**Buttons**

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;OK&quot;</td>
<td>Click on this button to start the login process.</td>
</tr>
<tr>
<td>&quot;Cancel&quot;</td>
<td>Use this button to cancel the login process.</td>
</tr>
</tbody>
</table>

9.3 "Synchronize plant from Tc" window

"Project" control group

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Server URI&quot; field</td>
<td>Shows the connection to the current Teamcenter server.</td>
</tr>
<tr>
<td>&quot;Project selection&quot; list</td>
<td>Select the desired project. The previously selected project is preset. To select a different project, show the list by clicking the &quot;Project selection&quot; button.</td>
</tr>
<tr>
<td>&quot;Current project&quot; field</td>
<td>Shows the current project.</td>
</tr>
<tr>
<td>&quot;Incremental update&quot; option</td>
<td>If you want to retain existing data, activate this option. This option is only available for the first execution.</td>
</tr>
<tr>
<td>&quot;Create working layer&quot; option</td>
<td>If you want to create transferred data in a separate working layer, activate this option.</td>
</tr>
</tbody>
</table>

"Status" control group

See also chapter **Status area in windows** (Page 79).
### Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;OK&quot;</td>
<td>Starts the synchronization process from Teamcenter</td>
</tr>
<tr>
<td>&quot;Cancel&quot;</td>
<td>Cancels the synchronization.</td>
</tr>
</tbody>
</table>

### 9.4 "Synchronize plant to Tc" window

#### "Project" control group

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Server URI&quot; field</td>
<td>Shows the connection to the current Teamcenter server.</td>
</tr>
</tbody>
</table>
| "Project selection" list | Select the desired project. The previously selected project is preset.  
To select a different project, show the list by clicking the "Project selection" button. |
| "Current project" field | Shows the current project.                                                  |

#### "Status" control group

See also chapter Status area in windows (Page 79).

### Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;OK&quot;</td>
<td>Starts the synchronization process to Teamcenter</td>
</tr>
<tr>
<td>&quot;Cancel&quot;</td>
<td>Cancels the synchronization.</td>
</tr>
</tbody>
</table>

### 9.5 "Element properties" window

#### "COMOS instance" control group

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Name&quot;</td>
<td>Shows the name assigned in COMOS.</td>
</tr>
</tbody>
</table>
"Teamcenter instance" control group

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Item ID&quot; field</td>
<td>If you click the &quot;Assign&quot; button, the field is automatically filled with a valid value. A 6-digit consecutive number is assigned by default. Alternatively, you can enter a text for identifying the object in Teamcenter.</td>
</tr>
<tr>
<td>&quot;Revision ID&quot; field</td>
<td>If you click the &quot;Assign&quot; button, the field is automatically filled with a valid value. By default, the letter &quot;A&quot; is assigned for the first revision. Alternatively, you can enter text for identifying the first revision in Teamcenter.</td>
</tr>
<tr>
<td>&quot;Assign&quot; button</td>
<td>Automatically fills the &quot;Item ID&quot; and &quot;Revision ID&quot; fields with valid values assigned by the Teamcenter server.</td>
</tr>
<tr>
<td>&quot;Name&quot; field</td>
<td>Free text for designating the object in Teamcenter.</td>
</tr>
<tr>
<td>&quot;Type&quot; field</td>
<td>Shows the resource or type to which the base object is assigned.</td>
</tr>
<tr>
<td>&quot;Description&quot; field</td>
<td>Shows the description.</td>
</tr>
</tbody>
</table>

"Teamcenter position" control group

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Name&quot;</td>
<td>Name of the position of the object in the Teamcenter plant.</td>
</tr>
<tr>
<td>&quot;Quantity&quot;</td>
<td>Frequency of the object at the position in the Teamcenter plant.</td>
</tr>
</tbody>
</table>

"Status" control group

See also chapter Status area in windows (Page 79).

9.6 "Select Tc resource" window

Working area

Select a resource to be the instance mapping for the reference object via the working area. Only resources whose resource assignment points to the reference object are displayed.

"Remove pointer" button

To remove the existing instance mapping, click on the "Remove pointer" button and then click "OK".
9.7 "Element properties" window in the base objects

"COMOS instance" control group

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Name&quot;</td>
<td>The name of the element is displayed in this field.</td>
</tr>
</tbody>
</table>

"Teamcenter instance" control group

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Item ID&quot;</td>
<td>If the resource information has been synchronized, the data from Teamcenter is entered automatically in these fields.</td>
</tr>
<tr>
<td>&quot;Revision ID&quot;</td>
<td></td>
</tr>
<tr>
<td>&quot;Name&quot;</td>
<td></td>
</tr>
<tr>
<td>&quot;Type&quot;</td>
<td></td>
</tr>
<tr>
<td>&quot;Description&quot;</td>
<td></td>
</tr>
</tbody>
</table>

9.8 "Synchronize resource info" window

"Project" control group

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Server URI&quot; field</td>
<td>Shows the connection to the current Teamcenter server.</td>
</tr>
<tr>
<td>&quot;Project name&quot; field</td>
<td>Shows the current project name.</td>
</tr>
<tr>
<td>&quot;Create working lay‐er&quot; option</td>
<td>If you want to create transferred data in a separate working layer, activate this option.</td>
</tr>
</tbody>
</table>

"Status" control group

See also chapter Status area in windows (Page 79).
### 9.9 "Teamcenter units of measurement" tab

#### Table

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Name&quot;</td>
<td>Non-editable field&lt;br&gt;The text in this field indicates the unit of measurement used in Teamcenter. To clarify the origin, the units of measurement from Teamcenter are prefixed with &quot;CTI_&quot;.</td>
</tr>
<tr>
<td>&quot;Description&quot;</td>
<td>Non-editable field&lt;br&gt;This field contains the description text saved in COMOS.</td>
</tr>
<tr>
<td>&quot;COMOS unit&quot;</td>
<td>Editable field provided for the unit of measurement used in COMOS.  &lt;br&gt;● If there is an entry in this field, you have already assigned a COMOS unit of measurement to the text used in Teamcenter.  &lt;br&gt;● If this field is empty, assign a COMOS unit of measurement to the text used in Teamcenter.</td>
</tr>
</tbody>
</table>

### 9.10 "CTI resource mapping" tab

#### Tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Mapped base object&quot; field</td>
<td>Drag&amp;drop the required object into this field to make the assignment. A suitable base object must contain the &quot;Y00T00128 CTI instance mapping&quot; tab.</td>
</tr>
<tr>
<td>&quot;Resource properties&quot; button</td>
<td>Click this button to view entries for the resource from Teamcenter. The &quot;Element properties&quot; window opens. See also chapter &quot;Element properties&quot; window (Page 81).</td>
</tr>
</tbody>
</table>

### 9.11 "CTI attribute mapping" tab

#### Button

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Update values ...&quot;</td>
<td>When you click this button, the &quot;Update values&quot; window is called up. By clicking &quot;OK&quot;, you start the transfer from this window of the values synchronized from Teamcenter to the corresponding COMOS attributes based on the attribute mapping.</td>
</tr>
</tbody>
</table>
### Table

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Tc description&quot;</td>
<td>Non-editable field&lt;br&gt;This field contains a short descriptive text that is synchronized to COMOS from Teamcenter with the attribute.</td>
</tr>
<tr>
<td>&quot;Tc value&quot;</td>
<td>Non-editable field&lt;br&gt;The &quot;Tc value&quot; column displays the value of the attribute as it was synchronized from Teamcenter.</td>
</tr>
<tr>
<td>&quot;Tc unit&quot;</td>
<td>Non-editable field&lt;br&gt;The &quot;Tc unit&quot; column displays information about the unit of measurement as stored in Teamcenter.</td>
</tr>
<tr>
<td>&quot;Attribute mapping&quot;</td>
<td>Here, you can assign an attribute. If you want to assign an attribute, use drag&amp;drop to move it from the assigned resource or its inheritance source into the &quot;Attribute mapping&quot; field.</td>
</tr>
<tr>
<td>&quot;Attribute unit&quot;</td>
<td>Non-editable field&lt;br&gt;This field displays the unit of measurement in COMOS.</td>
</tr>
</tbody>
</table>

### 9.12 "CTI instance mapping" tab

#### Control elements

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Assigned Tc resource&quot;</td>
<td>Shows the assigned Teamcenter resource.</td>
</tr>
<tr>
<td>&quot;Instance properties ...&quot; button</td>
<td>The user needs this button when creating an engineering object based on the reference object.</td>
</tr>
<tr>
<td>&quot;Select Tc resource&quot; button</td>
<td>To select a Teamcenter resource, click this button. Only those resources to which the reference object is assigned are listed for selection. The default value is the first resource to which the reference object was assigned.</td>
</tr>
</tbody>
</table>
9.13 "XMLViewer" window

9.13.1 Views

Introduction

Before transferring a pipe to Teamcenter, you can view the generated files in the "XMLViewer" window. You cannot make changes in this window. The XMLViewer is used for the final data check before transfer. Recommendation: If abnormalities occur, cancel the transfer and make the appropriate improvements in COMOS. The following functions are available in the "XMLViewer" window:

- View of pipe spec specification in XML format
- View of the pipe part catalog in XML format
  The views of pipe parts/pipe specs appear automatically one after the other. You cannot go back to a previous view. You can call a version comparison in each case.
- Version comparison of generated files
- Confirmation of file transfer

Overview

The window "XMLViewer" has the same layout in every view.

The path to the generated and displayed file is shown at the top of the window. The symbol bar contains the buttons which you use to switch between the views. The file data is shown as content. Display of the content depends on which view you have selected. See also chapter Calling a view (Page 87).

Views

You can call the following views:

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;XML table&quot;</td>
<td>Tabular display of the data prepared for export</td>
</tr>
<tr>
<td>&quot;Normal XML format&quot;</td>
<td>Display of the generated file in XML format</td>
</tr>
<tr>
<td>&quot;Version comparison&quot;</td>
<td>This display shows the differences between two versions of a pipe spec. The current version is always compared to the previous version. See also chapter Version comparison (Page 87).</td>
</tr>
</tbody>
</table>
### 9.13.2 Calling a view

**Procedure**

Select one of the following options:

- To call the "XML table" view, click the button.
- To call the "Normal XML format" view, click the button.
- To call the "Version comparison" view, click the button.

### 9.13.3 Version comparison

**Displaying the changes**

The "Version comparison" view is divided into three content areas:

<table>
<thead>
<tr>
<th>Content area</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Before&quot;</td>
<td>Shows the specific contents of the previously generated XML file. This older version is the basis for the comparison. If all areas are empty, the contents are identical.</td>
</tr>
<tr>
<td>&quot;Current&quot;</td>
<td>Displays the content of the currently generated XML file.</td>
</tr>
<tr>
<td>&quot;Differences&quot;</td>
<td>Shows the discrepancies between the two versions. The result is displayed in a table.</td>
</tr>
</tbody>
</table>

**Table in the "Differences" content area**

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Current element names&quot;</td>
<td>List of all XML root elements which deviate.</td>
</tr>
<tr>
<td>&quot;Comparison element names&quot;</td>
<td>List of XML elements which contain differences between two versions.</td>
</tr>
<tr>
<td>&quot;Comparison result&quot;</td>
<td>Shows a description of differences.</td>
</tr>
<tr>
<td>&quot;Current element content&quot;</td>
<td>Shows the content of the XML element in the previous version.</td>
</tr>
<tr>
<td>&quot;Comparison element content&quot;</td>
<td>Shows the content of the XML element to be compared in the current version.</td>
</tr>
</tbody>
</table>
User interface reference

9.13 "XMLViewer" window