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WinCC/CAS Installation Notes 1
1 Resources

1.1 WinCC/CAS - Installation Instructions

Contents
This documentation contains important instructions on the following topics:

● Scope of delivery

● Installation

● Configuration of WinCC CAS

1.2 Scope of Delivery

Introduction     
You obtain the following components in the WinCC/Central Archive Server V7.0 SP1 product 
package:

CD WinCC CAS V7.0 SP1
● WinCC CAS V7.0 SP1

● Microsoft Office Web Components V10.0

DVD WinCC V7.0 SP1
● SIMATIC NCM PC Manager

● Microsoft SQL Server 2005

● WinCC V7.0 SP1

MDM - WinCC/Central Archive Server
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1.3 System requirements

Hardware requirements        
You require at least three computers for configuring a CAS scenario: A WinCC Server, a 
WinCC CAS and a CAS Engineering Station (ES). 

WinCC CAS - Central Archive Server
The hardware requirements for a WinCC CAS correspond with those for a WinCC Server. You 
will find the respective information in the WinCC Information System in chapter "Installation 
Notes > Installation Requirements > Hardware Requirements for Installation".

CAS Engineering Station (CAS ES)
The CAS ES is the configuration computer for the WinCC CAS. 

Note

The WinCC Server is not to be used as CAS ES because it can cause faults in the archived 
data.

You will find the hardware requirements for WinCC Server in the WinCC Information System 
in the chapter "Installation Notes > Installation Requirements > Hardware Requirements for 
Installation".

Note

The name of the server computer must not contain an underscore. An underscore in the 
computer name can lead to problems when the WinCC CAS WebViewer accesses data. You 
will find the name of the server computer in the Windows Control Panel under "System" on 
the "Computer Name" tab. Change the name of the server computer before installing WinCC 
CAS.

Software Requirements for WinCC CAS - Central Archive Server
The following requirements must be met when installing the Central Archive Server:

Operating system
● Windows Server 2003 SP2

Installed software
● Microsoft Internet Explorer V6.0 SP1, V6.0 SP2 or V7.0

● Microsoft SQL Server 2005

● WinCC V7.0 SP1 Typical or WinCC V7.0 SP1 Complete

WinCC/CAS Installation Notes
1.3 System requirements
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Special requirements to be met by WinCC projects
For a WinCC project with WinCC CAS, the same restrictions apply as for a WinCC project 
used in PCS 7.

Note

WinCC CAS cannot be installed along with WinCC Historian.

Do not use any other programs on the computer on which you are operating CAS.

Software requirements for the CAS Engineering Station (CAS ES)
The following requirements must be met when installing the Engineering Station:

Operating system
● Windows Server 2003 SP2

● Windows XP SP3

● Windows Vista SP1

Installed software
● Microsoft Internet Explorer V6.0 SP1, V6.0 SP2 or V7.0

● Microsoft SQL Server 2005

● SIMATIC NCM PC Manager
WinCC projects that use WinCC CAS are administered using the SIMATIC NCM PC 
Manager.

● WinCC V7.0 SP1 Complete

1.4 Licensing

Introduction
The WinCC CAS requires licenses to operate and for all archive tags that are used in the 
WinCC project.

The licenses for the archive tags that have been installed up to now will be transferred to 
WinCC CAS and cumulated there. The CAS monitors the number of archive tags used and, if 
the license is exceeded, outputs an error message on the server. A maximum of 120,000 
archive tags can be registered with a WinCC CAS.

To transfer the licenses, use the Automation License Manager.

WinCC/CAS Installation Notes
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Scope of delivery
With the WinCC CAS, you will receive the license storage medium with the following licenses:

● WinCC/DataMonitor

● WinCC/Server

● WinCC RT (128)

● WinCC/StoragePlus

● WinCC Archive

Quantity structure
The method of counting the archive tags for licensing depends on the configuration:

● Archive tags with long-term relevance are swapped out to the CAS and count as one tag.

● Archive tags that are not swapped out to the CAS count as one tag if they are used on a 
single server.

● Archive tags that are not swapped out to the CAS count as two tags if they are used on a 
redundant server pair.

Note

Disable the "long-term relevance" option for tags that are not to be archived. All tags where 
this option is set will be counted for licensing. You deactivate the option in the "Tag 
Logging" editor.

Diagnostics options
Problems that occur with licensing of the archive tags are logged in the following files:

● On the WinCC server: License_CAS_TLG.log:
Which licenses are required on the server and transferred to the CAS are logged in this file.

● On the WinCC CAS: License_CAS.log:
Log file for any requests to the CAS by the servers. Contains the messages indicating, for 
example, that the number of licensed archive tags is inadequate or that other problems 
have occurred.

Requirements
● You have the required licenses for operating the WinCC project.

● You have the required archive licenses for the WinCC project.

Basic procedure
The various computers need different licenses.

The individual steps for transferring licenses are found under "Procedures" or "Alternative 
procedures".
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WinCC CAS
Use the license keys from the license data medium.

Transfer the license keys to the computer where WinCC CAS will be operated.

Configuration computer (ES)
You need a WinCC/RCxxx license on the configuration computer. The license is based on the 
total number of tags and archive tags in the WinCC project.

You will find additional information in WinCC Information System in the "Licensing" chapter.

SIMATIC NCM PC Manager does not require a license.

Procedure
1. In the Start menu, click "SIMATIC > License Management > Automation License Manager".

2. Insert the license data medium and select the data medium in the Automation License 
Manager.
The license keys on the data medium are displayed.

3. Select the license keys.

4. In the context menu of these licenses, click on the entry "Transfer...".
The "Transfer License Key" dialog opens.
As an alternative, you can transfer the License Keys via Drag&Drop.

5. Select the destination drive and click "OK".

Alternative procedure
1. In the Start menu, click "SIMATIC > License Management > Automation License Manager".

2. Connect the WinCC CAS server with the WinCC servers.

3. Move the License Keys from the WinCC servers to the WinCC CAS server.

Result
The desired licenses are transferred to the destination drive.

Additional information
You will find additional information in the documentation of the Automation License Manager.

WinCC/CAS Installation Notes
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1.5 Installation

1.5.1 Installation

Introduction
Additional software components must be installed before you can install WinCC CAS.

The requirements and the installation sequence for the Central Archive Server and the 
configuration server are different.

NOTICE

Make sure that you keep to the installation sequence. Otherwise you will encounter problems 
during installation.

WinCC CAS

Requirements 
The following programs are installed:

● Microsoft SQL Server 2005

● WinCC V7.0 SP1 

The following applies to the WinCC project:

● The WinCC Project is managed using SIMATIC NCM PC Manager

Installation sequence
1. Internet Information Services (IIS)

2. Windows 2003 Server function

3. Microsoft Office Web Components V10.0

4. WinCC CAS

CAS Configuration Computer (engineering station ES)

Installation sequence
1. Internet Information Service (IIS)

2. Windows 2003 Server function

3. Microsoft Office Web Components V10.0
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4. SIMATIC NCM PC Manager

5. WinCC V7.0 SP1 Complete and Microsoft SQL Server 2005

 

See also
How to Install Internet Information Service (IIS) (Page 13)

1.5.2 How to Install Internet Information Service (IIS)

Introduction
WinCC CAS uses the Internet Information Service (IIS) from Microsoft. These components are 
an integral part of the operating system. IIS must be configured for the server function.

Requirements
● Windows installation CD

● You need local administrator rights to install WinCC.

Procedure
1. From the Windows Start menu choose "Settings > Control Panel > Software".

2. In the left navigation bar click the "Add/Remove Windows Components" button.
The wizard for Windows components opens.

3. Select the "Application Server" component and click "Details".
The "Application Server" dialog opens.

4. Select "Internet Information Service (IIS)".

– Click "Details".

– Select the "Shared Files", "Internet Information Service Manager" and "www Service" 
options.

– Click "Details".

– Select the "Active Server Pages" and "www Service" options.

– Close the windows by clicking "OK".

5. When prompted, insert the Windows Installation CD and click "OK".
Internet Information Services will be installed.

6. Close the menu by clicking "Finish".

See also
How to Configure the Server Function of Windows 2003 (Page 14)
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1.5.3 How to Configure the Server Function of Windows 2003

Introduction
To use WinCC CAS, configure the server function (ASP) of Windows Server 2003.

Requirements
● Local administrator rights

Procedure
1. From the Windows Start menu choose "Settings > Control Panel > Software".

2. In the left navigation bar click the "Add/Remove Windows Components" button.
The wizard for Windows components opens.

3. Select the "Application Server" component and click "Details".
The "Application Server" dialog opens.

4. Select the "ASP.NET" component and click "OK" to close the windows.

5. When prompted, insert the Windows Installation CD and click "OK".
Internet Information Services will be installed.

6. Close the menu by clicking "Finish".

1.5.4 How to Install Office Web Components V10.0

Introduction
You can use the WinCC CAS CD to install the Microsoft component "Office Web Components 
V10.0".

Note

Install the language version corresponding to your operating system language.

WinCC/CAS Installation Notes
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Procedure
1. In Windows Explorer, select the directory on the WinCC CAS CD "storageplus\install

\Components\4.Microsoft Office Web Components\10\".

2. Double-click the corresponding language version of the program:

– For German: owc_10_de

– For English: owc_10_en

– For French: owc_10_fr

Installation is started.

3. Follow the instructions on the screen.
"Office Web Components" is installed.

4. Restart the computer.

1.5.5 How to install SIMATIC NCM PC Manager on the configuration computer

Introduction
To administer the WinCC project, you need an additional computer that will be used as the 
configuration computer.

Requirements
● Read the installation notes for WinCC V7.0 SP1.

Procedure
1. Insert your WinCC DVD in the drive. Installation is started automatically.

If the installation does not start automatically, double-click on the "setup.exe" file on the 
DVD.

2. Follow the instructions on the screen until the "Installation type" dialog is opened.

3. Select "User-defined installation", then click "Next."
The "Program" dialog box is opened.

4. Select the following options:

– "WinCC V7.0 SP1 Complete"

– "SIMATIC NET PC V5.4 + SP4"

– If required: "SIMATIC NET PC Software Documentation 2008"

5. Click "Next".
The software will be installed.
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Result
SIMATIC NCM PC Manager for administration of WinCC projects is installed on the 
configuration computer.

You will find the SIMATIC NCM PC Manager in the Start menu under "SIMATIC > SIMATIC 
NCM PC Manager".

1.5.6 Installing WinCC CAS

Introduction
WinCC CAS is installed using a setup program.

Requirements
● Internet Information Service (IIS) is installed.

● Windows 2003 Server function (ASP) is configured.

● Microsoft Office Web Components V10.0 is installed.

● WinCC V7.0 SP1 is installed.

Note

If you have installed WinCC using OPC-XML and install a WinCC CAS server on the 
computer, the standard Web site is deactivated because the StoragePlus Web site is set 
up on port 80. 

To access the standard Web site, you will need to change the port for the standard Web 
site and reload it.

Procedure
1. Insert the WinCC CAS CD. Installation is started automatically.

If the installation does not start automatically, double-click on the "setup.exe" file on the CD.

2. Follow the instructions on the screen until the "Select the programs to be installed" dialog 
is opened.

3. Activate the "CAS StoragePlus V1.3 SP1" option. The Automation License Manager has 
already been installed with WinCC.

4. Click "Next".

5. Enter the database name and the installation directory for the database. You can select 
any suitable database name.
We recommend that you accept the proposed name.

WinCC/CAS Installation Notes
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6. In the "Shared Archive Name" box, enter the drive you are using and path where the CAS 
data will be transferred.
Please ensure that this drive has adequate free space.

Note

If your computer has multiple drives, then create the installation directory and the archive 
directory on different drives.

7. Follow the instructions on the screen.
WinCC CAS is installed.

Result
WinCC CAS has been installed. You create the configuration in the NCM PC Manager on the 
configuration computer.

After installing WinCC CAS you will find the new folder "StoragePlus" in the "SIMATIC" program 
group in the Start menu of the operating system. You can start the individual components of 
WinCC CAS from this folder:

● WinCC/CAS Administration Console

● WinCC/CAS View Editor

● WinCC/CAS Web Viewer

● WinCC Central Archive Server - Information System

You will find the SIMATIC NCM PC Manager for administering the WinCC projects under 
"SIMATIC > SIMATIC NCM PC Manager".

1.6 How to Uninstall WinCC CAS

Introduction
You can completely uninstall WinCC CAS from your computer.

Requirement
● Administrator rights for uninstalling components are available.

Procedure
1. In the Start menu of the operating system, select the menu command "Settings > Control 

Panel > Software".

2. Select "SIMATIC StoragePlus V1.3 SP1" and click the "Remove" button.
The WinCC CAS Setup program is started.

3. Confirm the dialog box.

4. Follow the instructions on the screen.
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Alternative Procedure
1. In the Start menu of the operating system, select the menu command "Settings > Control 

Panel > Software".

2. Select "SIMATIC StoragePlus" and click the "Change" button.
The WinCC CAS Setup program is started.

3. To uninstall the software, select the "Remove SIMATIC StoragePlus V1.3 SP1" option.

4. To repair the installation, select the "Repair SIMATIC StoragePlus V1.3 SP1" option.

5. Click the "Finish" button.

6. Follow the instructions on the screen.

The following elements are not included in the uninstall step: 

● ViewEditor configurations that have been created

● WinCC CAS database files

1.7 Importing a WinCC Project and Configuring WinCC CAS

1.7.1 Importing a WinCC Project and Configuring WinCC CAS

Introduction
A WinCC Project in which WinCC CAS is used is administered using the SIMATIC NCM PC 
Manager.

You can install SIMATIC NCM PC Manager from the WinCC installation DVD. You do not need 
any additional licenses.

Note

SIMATIC NCM PC Manager does not support the entire spectrum of SIMATIC STEP 7 
applications. It is only used for installing and configuring your WinCC projects. You will find 
additional information on the SIMATIC Manager in the WinCC Information System under 
"Working with WinCC > Integrating WinCC in SIMATIC Manager".

The following chapters show you how to create a new project and import a WinCC project into 
SIMATIC NCM PC Manager.

We will create a project for a redundant system with the following configuration: 

● WinCC Server

● Redundant server pair

● Two identical clients with their own projects

● Redundant CAS server pair

WinCC/CAS Installation Notes
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You can set up the project for any system configuration based on the principle described. 
Please keep in mind the approved configuration limits for WinCC. You will find information on 
this topic in the WinCC Information System under "Performance data" and under 
"Configurations > Distributed Systems > Configurations and Quantity Structure".

WinCC Projects with WinCC CAS
For a WinCC project with WinCC CAS, the same restrictions apply as for a WinCC project 
used in PCS 7.

WinCC CAS has not been released for operating and monitoring WinCC projects. It would 
however make sense to create an entry screen for WinCC CAS with the following elements:

● Login dialog for accessing WinCC CAS

● Display of WinCC CAS system messages via WinCC Alarm Control

Editing WinCC projects in WinCC Explorer
To create or edit a WinCC project, start WinCC Explorer in the SIMATIC NCM PC Manager 
with the "Open Object" command of the shortcut menu. 

Note

Clients without their own project are not released in a WinCC CAS project.

Port the existing project to the NCM PC Manager
To use WinCC CAS in an existing project, you will need to import and administer the project 
in SIMATIC NCM PC Manager. The following steps are necessary:

1. Create a new project and import the WinCC project

2. Configure the server

3. Create a standby server and configure it

4. Create CAS and configure it

5. Create standby CAS and configure it

6. Import client projects and configure them

7. Generate server data

8. Assign OS server

9. Load target systems
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See also
Step 1: Create a new project in SIMATIC NCM PC Manager and import a WinCC project 
(Page 20)

Step 2: Create and configure server and standby server (Page 21)

Step 3: Create and configure CAS server and CAS standby server (Page 24)

Step 4: Create client application and references (Page 28)

Step 5: Generate server data, assign OS server and load target system (Page 30)

1.7.2 Step 1: Create a new project in SIMATIC NCM PC Manager and import a WinCC 
project

Introduction
On the SIMATIC NCM PC Manager configure the various computers, their configuration and 
the WinCC projects running on them in an NCM project.          
The data of this project will be generated locally, linked and then transferred to the relevant 
destination computer. 

Regardless of whether you create a new WinCC project or import an existing WinCC project, 
you will first need to create a new project for the SIMATIC NCM PC Manager.

Procedure
1. Start SIMATIC NCM PC Manager in Windows Start menu with "Start > SIMATIC > SIMATIC 

NCM PC Manager".

2. Create a new project. Keep to the PCS 7 naming conventions for the project.

3. If necessary, change the storage location of the project.

You have created a SIMATIC NCM PC Manager project. This project still does not have any 
computer or any WinCC project.

● To create a new WinCC project, open WinCC Explorer using the "Edit Object" command 
of the shortcut menu.

● To use an existing WinCC project, import it according to the steps described below.

Requirements for importing a WinCC project
● You have access to a WinCC project that you want to import to the SIMATIC NCM PC 

Manager. 

● The WinCC project is closed.
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Procedure
1. Open the dialog using the menu command "Tools > Import OS" and select the location of 

the project you want to import using "...". Select the file with the "mcp" extension and click 
"Import OS".

2. A status message is displayed when the import is completed.          
If the messages you see under "Details" only refer to long picture names, confirm the 
messages by clicking "OK" and exit the dialog by clicking "Close".

During import, a PC station with a WinCC application is created in SIMATIC Manager for the 
WinCC project to be imported. The imported WinCC project is created as a lower-level OS 
object with the name defined at the time of import. 

The following actions are executed in the imported WinCC project: 

● Existing packages are deleted.

● The computer name is set.

● Activated redundancy is deactivated.

Result
You have imported a WinCC project and can now configure the other HMI applications that 
are needed.

See also
Importing a WinCC Project and Configuring WinCC CAS (Page 18)

Step 2: Create and configure server and standby server (Page 21)

Step 3: Create and configure CAS server and CAS standby server (Page 24)

Step 4: Create client application and references (Page 28)

Step 5: Generate server data, assign OS server and load target system (Page 30)

1.7.3 Step 2: Create and configure server and standby server

Introduction     
After creating the SIMATIC NCM PC Manager project and importing or creating a WinCC 
project you need applications on which your WinCC project will run.

You have the option of configuring a redundant server pair with master server and standby 
server or one single server.
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HMI Applications
In a SIMATIC PC Station you can create the following HMI applications:

Application Use

WinCC Appl. WinCC Server
WinCC Appl. (Stby.) Redundant partner for the WinCC server in a redundant system
WinCC CAS Appl. WinCC CAS server
WinCC CAS Appl. 
(Stby.)

Redundant partner for the WinCC CAS server in a redundant system

WinCC Appl. Ref. This application type does not support any CAS functionality.
WinCC Appl. Client WinCC client with its own project.

Note
WinCC clients without their own project are not released in a WinCC CAS 
project.

WinCC Appl. Client 
Ref.

WinCC client that matches another client and that is referenced on it.

SPOSA Appl. Application for the Connectivity Station of WinCC/Connectivity Pack

Procedure for a redundant server pair
If you have created a new WinCC project, then start at point 1.

If you have imported an existing WinCC project, then the master server has already been 
created by the SIMATIC NCM PC Manager. Start at point 2.

1. Add a new object to your list in the shortcut menu "Add New Object > SIMATIC PC Station".

– Double-click "Configuration" to define the application type.
A new window opens. 

– Double-click in the right field "SIMATIC PC Station > HMI > WinCC Appl." and close the 
window.
A dialog box opens. 

– Confirm the question.

2. Change the name of the PC station and the project according to your naming convention.

3. Add a new object to your list in the shortcut menu "Add New Object > SIMATIC PC Station".

– Double-click "Configuration" to define the application type.
A new window opens. 

– Double-click in the right field "SIMATIC PC Station > HMI > WinCC Appl. (Stby.)" and 
close the window.
A dialog box opens. 

– Confirm the question.

– Change the name of the PC station and the project according to your naming convention.

4. Open the object properties in the shortcut menu of the project on the master server.

5. In the "Target OS and Standby OS" tab enter the name, the drive and the directory path 
where you want to store the project data in the "Path to target OS computer" field.
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6. In the "Symbolic computer name" field, enter the name of the package as it will be used in 
the project.

Note

This name must be the original package name. Otherwise you will need to change all the 
elements of the package accordingly.

7. In the "Standby computer" field, select the computer you have inserted in step 3.

8. Open the object properties in the shortcut menu of the project on the standby server.

9. In the "Target OS and Master OS" tab enter the name, the drive and the directory path 
where you want to store the project data in the "Path to target OS computer" field.

Result
You have created a redundant server pair for your WinCC project.

Procedure for a single server
If you have created a new WinCC project, then start at point 1.

If you import an existing WinCC project, then the server has already been created by the 
SIMATIC NCM PC Manager. Start at point 2.

1. Add a new object to your list in the shortcut menu "Add New Object > SIMATIC PC Station".

– Double-click "Configuration" to define the application type.
A new window opens. 

– Double-click in the right field "SIMATIC PC Station > HMI > WinCC Appl." and close the 
window.
A dialog box opens. 

– Confirm the question.

2. Change the name of the PC station and the project according to your naming convention.

3. Open the object properties in the shortcut menu of the project on the master server.

4. In the "Target OS and Standby OS" tab enter the name, the drive and the directory path 
where you want to store the project data in the "Path to target OS computer" field.

5. In the "Symbolic computer name" field, enter the name of the package as it will be used in 
the project.

Note

This name must be the original package name. Otherwise you will need to change all the 
elements of the package accordingly.

Result
You have created a single server for your WinCC project.
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See also
Importing a WinCC Project and Configuring WinCC CAS (Page 18)

Step 1: Create a new project in SIMATIC NCM PC Manager and import a WinCC project 
(Page 20)

Step 3: Create and configure CAS server and CAS standby server (Page 24)

Step 4: Create client application and references (Page 28)

Step 5: Generate server data, assign OS server and load target system (Page 30)

1.7.4 Step 3: Create and configure CAS server and CAS standby server

Introduction    
The Central Archive Server (CAS) is the HMI application, that backs up, collates and archives 
your long-term-relevant data. You can configure the CAS as a redundant server pair or as a 
single server.

Archiving concept
Configure the archiving in the Tag Logging Editor and Alarm Logging Editor as described in 
WinCC Information System. Do not configure any backup at this point. You will configure a 
backup in CAS.

Note

Disable the "long-term relevance" option for tags that will not to be archived. All tags where 
this option is set will be counted for licensing.

The data is transferred in segments according to the configured times and sizes of the server 
or the master server of a redundant server pair to both the CAS servers and is processed there 
separately. After the data has been transferred, the short-term archive of the server is 
overwritten during the next run.

CAS compresses the data to form larger archives and saves it in the short-term archive of 
CAS. Completed segments are swapped out to external data media according to the backup 
configuration. The short-term archive of CAS is overwritten during the next run after the data 
has been swapped.

CAS is configured in SIMATIC NCM PC Manager. You will find the "CAS Options" tab of the 
object properties in the shortcut menu of the project on the master server. The configuration 
in alarm logging and tag logging of the WinCC project is not taken into account on the CAS. 
It is used only when the StoragePlus.config file is corrupted in the <Projectpath>\Config 
directory.

NOTICE

For the message system, CAS requires the same configuration as the connected servers.
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Message blocks and message classes in all projects must be identical.

Note

For each NCM PC Manager project you can configure one redundant CAS server pair or one 
individual CAS server.

WinCC CAS cannot be installed along with WinCC Historian.

"CAS Options" tab
You configure the transfer of the archived data on the "CAS Options" tab of the object properties 
in the shortcut menu of the project on the master server. The fields have the following 
significance:

Field Description

Archive type In this area you select whether you want to archive all archives or only the 
archives of a specific type. "All" is preset. If you change this selection, then only 
the data of the selected type will be archived. The archiving settings of the WinCC 
server will then be ignored.

Archive size Here, you define the period and size of the archive segment.
Note
Please make sure that the archive size you set here is significantly larger than 
the size of the archive segment that you have defined in the Alarm Logging and 
Tag Logging Editors of the WinCC project.

Time of first 
segment change

Set the time of the unconditional segment change. At this time, the segment is 
changed, irrespective of its size. 

Backup 
configuration

Area for configuring the backup.

Only long-term data If this option is activated, then only the data with the "long-term-relevant" 
parameter will be archived. This option is activated as default. If you disable this 
option, all messages and tags will be archived. The archiving settings of the 
WinCC server will then be ignored.
Take the licensing into account.

Activate backup Activates the backup. If the backup is not activated, the data is kept only in the 
short-term archive of CAS and is overwritten after one run.

Signing activated Setting for a backup signature. This function monitors whether the file was 
changed after a save operation.

Backup to both 
paths

Specifies whether redundant backup is used.

Target path Destination path in which the backup file is stored. There will be no backup unless 
a path is specified.

Alternative target 
path

The secondary storage location is used in the following cases, for example:
● If the storage space on a backup medium is occupied.
● If the original destination path is not available, for example due to a network 

failure.
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You will find additional information about the various archiving strategies in the WinCC 
Information System under "Working with WinCC > Archiving Process values > Archiving 
methods".

You have the option of configuring a redundant CAS server pair (master server and standby 
server) or a single CAS server.

Procedure for a redundant CAS server pair
1. Add a new object to your list in the shortcut menu "Add New Object > SIMATIC PC Station".

– Double-click "Configuration" to define the application type.
A new window opens. 

– Double-click in the right field "SIMATIC PC Station > HMI > WinCC CAS Appl." and 
close the window.
A dialog box opens. 

– Confirm the prompt.

– Change the name of the PC station and the project according to your naming convention.

2. Repeat step 1 to create a CAS standby server. For it select "WinCC CAS Appl. (Stby.)".

3. Open the object properties in the shortcut menu of the project on the CAS master server.

4. In the "Target OS" tab enter the name, the drive and the directory path where you want to 
store the project data in the "Path to target OS computer" field.

5. In the "Symbolic computer name" field, enter the name of the package.

6. In the "Standby OS" field, select the computer you have inserted in step 2.

7. Open the "CAS Options" tab.
Configure the archiving of your data here. The significance of the fields was described 
above.

8. Open the object properties in the shortcut menu of the project on the CAS standby server.

9. In the "Target OS and Master OS" tab enter the name, the drive and the directory path 
where you want to store the project data in the "Path to target OS computer" field.

Result
You have created a redundant archive server pair for your WinCC project.
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Procedure for a single CAS server
1. Add a new object to your list in the shortcut menu "Add New Object > SIMATIC PC Station".

– Double-click "Configuration" to define the application type.
A new window opens. 

– Double-click in the right field "SIMATIC PC Station > HMI > WinCC CAS Appl." and 
close the window.
A dialog box opens. 

– Confirm the prompt.

– Change the name of the PC station and the project according to your naming convention.

2. Open the object properties in the shortcut menu of the project on the CAS server.

3. In the "Target OS" tab enter the name, the drive and the directory path where you want to 
store the project data in the "Path to target OS computer" field.

4. In the "Symbolic computer name" field, enter the name of the package.

5. Open the "CAS Options" tab.
Configure the archiving of your data here. The significance of the fields was described 
above.

Result
You have created a single archive server for your WinCC project.

Tips for operating CAS
No operator action is needed for CAS during normal operations. However, remember the 
following during operation and when there are problems:

Do not use any other programs on the computer on which you are operating CAS.

Regularly check the availability of adequate disk space on the archive drive of CAS.

NOTICE

If a redundant server pair is completely deactivated in a project with WinCC CAS, then you 
must keep to the following sequence while activating it:
● First activate the server you deactivated last.

Otherwise, it is is possible that one server transfers data but it has not been updated fully by 
the redundancy synchronization.

Note

After a redundancy failure on the redundant server, only the comments about the following 
messages are synchronized:
● Messages in incomplete archive segments.
● Messages that lie in the synchronization period.
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Note

When a redundant CAS is used, servers and clients are always connected to the current 
master. The configuration of a preferred server does not have any effect on the behavior of 
the servers and clients on CAS.

See also
Importing a WinCC Project and Configuring WinCC CAS (Page 18)

Step 1: Create a new project in SIMATIC NCM PC Manager and import a WinCC project 
(Page 20)

Step 2: Create and configure server and standby server (Page 21)

Step 4: Create client application and references (Page 28)

Step 5: Generate server data, assign OS server and load target system (Page 30)

1.7.5 Step 4: Create client application and references

Introduction
Because clients without own their project are not released in a WinCC CAS environment, you 
will also need to import a separate project for the WinCC client. You can configure other 
identical clients as reference.

Procedure
If you have created a new WinCC project, start at point 1 and continue with point 4.

If you have imported an existing WinCC project, the object will be created by the SIMATIC 
NCM PC Manager. Start at point 2.

1. Add a new object to your list in the shortcut menu "Add New Object > SIMATIC PC Station".

– To create a new WinCC client project, open the WinCC Explorer using the "Edit Object" 
command in the shortcut menu.

– Go to step 4 to continue with the configuration of your WinCC client in the NCM PC 
Manager.

2. Open the dialog using the menu command "Tools > Import OS" and select the location of 
the project you want to import using "...".
Select the file with the "mcp" extension and click "Import OS".
A status message is displayed as soon as the import is completed. 

3. If the messages you see under "Details" only refer to long picture names, confirm the 
messages by clicking "OK" and exit the dialog by clicking "Close".
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4. Double-click "Configuration" to define the application type.
A new window opens.

– Double-click in the right field "SIMATIC PC Station > HMI > WinCC Appl. Client" and 
close the window.
A dialog box opens. 

– Confirm the question.

5. Change the name of the PC station and the project according to your naming convention.

6. Open the object properties in the shortcut menu of the project on the client computer.

7. In the "Target OS" tab enter the name, the drive and the directory path where you want to 
store the project data in the "Path to target OS computer" field.

Result
You have created a client for your WinCC project.

Client reference
If you are using multiple identical clients in your WinCC project, you can manage them together 
by configuring the client references on the first of these clients. All changes to your client will 
automatically be transferred to the other client references.

Requirements
You have created a client in the SIMATIC NCM PC Manager.

Procedure
1. Add a new object to your list in the shortcut menu "Add New Object > SIMATIC PC Station".

– Double-click "Configuration" to define the application type.
A new window opens. 

– Double-click in the right field "SIMATIC PC Station > HMI > WinCC App. Client Ref." 
and close the window.
A dialog box opens. 

– Confirm the question.

– Change the name of the PC station and the project according to your naming convention.

2. Open the object properties in the shortcut menu of the project on the client reference 
computer.

3. In the "Target OS" tab enter the name, the drive and the directory path where you want to 
store the project data in the "Path to target OS computer" field.

4. In the "OS Basis" field, select the client to which you want to create a reference.

Result
You have created a client reference for your WinCC project.
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See also
Importing a WinCC Project and Configuring WinCC CAS (Page 18)

Step 1: Create a new project in SIMATIC NCM PC Manager and import a WinCC project 
(Page 20)

Step 2: Create and configure server and standby server (Page 21)

Step 3: Create and configure CAS server and CAS standby server (Page 24)

Step 5: Generate server data, assign OS server and load target system (Page 30)

1.7.6 Step 5: Generate server data, assign OS server and load target system

Introduction
You have so far performed the following steps:

● You have imported or created a WinCC project and the corresponding client projects.

● You have configured all the required computers.

In the last step the server data is generated, the applications are made known to each other 
and the data is transferred to those computers where the system will run.

Generate server data
Select the "Generate server data" command in the shortcut menu of the project on the master 
server.

This action is performed only on master servers or independent servers.

Assign OS server
To allow various HMI applications to exchange data they need information about their 
communication partners. The function "Assign OS Server" does just this.

The different application types need the following information:

The server(s) need the CAS package. Standby servers get the information from their master 
servers.

The clients need the packages of all master servers or all individual servers whose projects 
they operate or display as well the CAS package for transparent access. Client references get 
the information from their referenced client.

CAS does not need any packages. It gets its configuration from the SIMATIC NCM PC Manager 
when the target system is loaded.

Procedure
Repeat the individual steps until all applications of the relevant type have been processed.
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Server
1. Select the "Assign OS Server" command in the shortcut menu of the project on the master 

server.

2. Select the package of the CAS server and confirm the selection using "OK".

Client
1. Select the "Assign OS Server" command in the shortcut menu of the project on the client 

computer.

2. Select the packages of the CAS and all servers whose projects the client operates or 
displays and confirm the selection by clicking "OK".

Load target systems
In the pop-up menu of the project select the "Load Target System" command for all configured 
HMI applications.

Result
You have configured your WinCC project in SIMATIC NCM PC Manager and loaded it on the 
computers that are operated using it.

See also
Importing a WinCC Project and Configuring WinCC CAS (Page 18)

Step 1: Create a new project in SIMATIC NCM PC Manager and import a WinCC project 
(Page 20)

Step 2: Create and configure server and standby server (Page 21)

Step 3: Create and configure CAS server and CAS standby server (Page 24)

Step 4: Create client application and references (Page 28)

1.8 WinCC CAS in Operation

Introduction
There are several special features while using WinCC CAS and these are described in this 
chapter.

Please read this information carefully.
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Start WinCC CAS

Requirement
● You have configured WinCC CAS in the SIMATIC NCM PC Manager and loaded it on the 

destination computer.

Procedure
● Start WinCC on the computer on which WinCC CAS is to run, open the Start menu and 

select "SIMATIC > WinCC > WinCC Explorer".

● Open the WinCC CAS project in WinCC Explorer. Start the project using the menu 
command "File > Activate".

Operating WinCC CAS in a redundant system
No operator input is required for WinCC CAS during normal operation. Please remember the 
following for operation and if problems occur.

Preferred server
When a redundant CAS is used, servers and clients are always connected to the current 
master. The configuration of a preferred server does not have any effect on the behavior of 
the servers and clients on CAS.

Redundancy failure
After a redundancy failure on the redundant server, only the comments about the following 
messages are synchronized:

● Messages in incomplete archive segments.

● Messages that lie in the synchronization period.

NOTICE

If a redundant server pair is completely deactivated in a project with WinCC CAS, then you 
must keep to the following sequence while activating it:
● First activate the server you deactivated last.

Otherwise, it is is possible that one server transfers data but it has not been updated fully by 
the redundancy synchronization.
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Archive data modified during runtime
Data in the short-time archives can be modified using WinCC Controls:

● Process values in Online Table Control

● Comments for messages in Alarm Control

These changes are accepted in WinCC CAS when the data is modified almost immediately 
after being created.

If the archive segment involved in the short-term archive has already been swapped then this 
change is not made subsequently on WinCC CAS. When you delete the archive segment on 
the WinCC server, then the modified data is also lost.

If the archive segment has not yet been swapped, then the changes are accepted permanently 
in WinCC CAS.

You cannot change data that has already been swapped to WinCC CAS.
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WinCC/CAS Release Notes 2
2 Resources

2.1 Release notes

Contents
These release notes contain important instructions.

The statements in these release notes are more binding than the instructions in the manuals 
and in the online help.

Please read these release notes carefully as they contain useful information.

2.2 Instructions for WinCC/CAS

Configuration   
The central archive server is a station on the terminal bus and has no connection to the plant 
bus.

Notes on installation
When you install the WinCC CAS, use the same language for the installation and the same 
user name as when you installed WinCC.

Symbolic computer name: Use lower case
Use the upper case only for symbolic computer names in a project where you are using WinCC 
CAS.

Additional recommendations for hardware and software
● To increase performance, we recommend that you create the archives on a different hard 

disk and not on the disk with the operating system.

● To increase data integrity and availability on the WinCC CAS, we recommend that you use 
a suitable RAID system.
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Archivable data types
You can archive the following data types on a WinCC CAS:

● Messages in the message archive

● Process values in the process value archive

● OS reports in the report archive for OS reports (output as .emf file)

Settings for configuring the WinCC CAS
Using the shortcut menu of the project, check that the option "Transfer to central archive server" 
is enabled on the servers on the "Target OS and Standby OS" tab in the object properties.

Note on archiving strategy
When you select the time to start transfer of individual segments (for example when transferring 
on a daily basis), you should try to find a time that does not coincide with increased 
requirements caused by trend access by the OS.

Behavior of the standard Web site
If you have installed WinCC using OPC-XML and install a WinCC CAS server on this computer, 
the standard Web site is deactivated because the StoragePlus Web site is set up on port 80. 

To reaccess the standard Web site, you will need to modify the port for the standard Web site 
and reload it.

WinCC/CAS View Editor: Displaying curves in a diagram
If a diagram is configured with a CAS View Editor which displays more than 7 curves, only the 
first 7 curves are displayed in the legend. Thus, do not configure more than 7 curves per control.

Tag-logging data from earlier versions
Backup databases with tag logging data from earlier versions can be connected on servers 
which have no connection to a CAS.

Multilingual messages: Release only WinCC installation languages
Messages can be configured only in the WinCC installation languages for projects where 
WinCC CAS is used.

Additional runtime languages cannot be used for archived messages.

Displaying swapped messages
Messages that have already been swapped out to the CAS, are only displayed when a time 
selection is set in the alarm control.
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Displaying reports with the Web Viewer
No continuous logs (subsequent message logs) are supported.

Web viewer: Copying alarm texts from the Web Viewer into the view editor
Alarm texts which contain "-" cannot be copied from the Web Viewer into the view editor. 

Web viewer: Displaying tag names with Asian characters
In order to display tag names with Asian characters correctly, you have to make the following 
settings:

● In the Windows Control Panel select the desired country under "Regional and Language 
Options > Standards and formats".

● Enter the desired language in the Internet Explorer under "Tools > Internet Options > 
General > Languages".
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WinCC/CAS Administration Console 3
3 Resources

3.1 WinCC/CAS Administration Console

Contents
You use the WinCC/CAS Administration Console to configure the system.

The sections below provide you with the following information:

● How to work with the Log Viewer

● How to work with archives

● How to assign access permissions

● How to manage views

3.2 StoragePlus Administration Console

Introduction
You use the Administration Console to configure the server, for example for managing user 
permissions. 

You require administrator privileges to use the Administration Console. The Administration 
Console consists of the following components:

● Log Viewer

● System Configuration

● User Management 

● View Management 

Layout
The Administration Console is structured according to Windows standards. The Administration 
Console has the following command bars: 

● Toolbar 

● Menu Bar

● Status Bar 
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Menu Bar
In the menu bar of the Administration Console, you will find most of the commands you can 
call up in the Administration Console. Commands that you cannot use in a specific situation 
are grayed out.

Toolbar
The toolbar gives you fast access to important commands that you will use often.

See also
System Configuration (Page 43)

User Management (Page 52)

View Management (Page 53)

Log Viewer (Page 40)

3.3 Log Viewer

3.3.1 Log Viewer

Common
You use the Log Viewer to see the events generated by WinCC CAS.

The information is located in two log files:

1. Application Log: The Application Log contains events recorded by WinCC CAS.
Example: Generating backups, attaching and detaching archives.

2. Activity Log: The Activity Log contains events recorded there is operator input to WinCC 
CAS.
Example: Publishing or changing the configuration.
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Information about the event
In the detailed window, you can see additional information about the selected  event. Double-
click on the selected event to open the "Information Properties" dialog.
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Output box Description

Date Day on which the event occurred.
Time Time stamp of when the event occurred.
Type Type of event 
Source Component that triggered the event
Event Action that triggered the event
User Name of the user that triggered the event, for example, with an operator 

command. This entry is available only in the Activity log.
Computer Name of the computer on which event was triggered. This entry is available 

only in the Activity log.
Additional Information Optional text with additional information.

Note

When a new event occurs, the display is not automatically updated. To update the view, select 
the "Application Log" entry. Click "Update" in the context menu.

3.3.2 "Action" Menu

Introduction
The "Action" menu contains the essential commands of the Log Viewer. The content of the 
menu depends on the current selection. You   can also use the context menu or the toolbar to 
call the menu commands.

"Action" Menu

Menu command Action

Delete All Events Deletes the entries from the Application Log or Activity Log. This action cannot 
be undone.

Update Updates the view.
Export List... Exports the entries from the Application Log or Activity Log. The events are 

exported to a TXT or CSV file. 
Help Opens Help for the Administration Console.
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3.4 System Configuration

3.4.1 System Configuration

Overview
Use the system configuration to configure WinCC CAS.

The System Configuration has three areas:

● Common

● Archive

● Advanced

See also
Common (Page 43)

Archive (Page 46)

"Advanced" dialog for data migration (Page 50)

3.4.2 Common

Settings in "Common"
The archive data is displayed in the "Common" detailed window.
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The meaning of the input and output boxes is explained below:

Box Description

Server Name Name of server computer.
Database Name The name of the database is specified during the installation of WinCC CAS. 

The database name cannot be changed.
Archive Share Name Path for storing the archives
Archive Type This area shows whether all archives or only archives of a certain type have 

been selected.
Archive size The time period and size of the archive are specified here.
Time of the segment 
change

Displays the time of the unconditional segment change. At this time, the 
segment is changed, irrespective of its size. 

Backup configuration This area shows the configuration of backups.
Long term data only When this option is selected, only long-term data is archived.
Backup activated Activates backup archiving.
Signing activated Setting for a backup signature. This function monitors whether the file was 

changed after a save operation.
Backup to both paths This setting decides whether or not saves are redundant.
Destination path Destination path in which the backup file is stored.
Alternative destination 
path

The secondary storage location is used in the following cases, for example:
● If the storage space on a backup medium is occupied.
● If the original destination path is not available, for example due to a network 

failure.
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3.4.3 Archive

3.4.3.1 Archive

Actions in "Archive"
You use "Archive" to configure the access to backup files. Use "Attach" to reconnect previously 
created backup files to the WinCC CAS database. 
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See also
How to Attach and Detach Backups (Page 47)

Catalog (Page 48)

Archive List (Page 49)

Configuration Data (Page 50)

3.4.3.2 How to Attach and Detach Backups

Introduction
Closed archives that were transferred to backup are not available online. You need to reattach 
the backup first before WinCC CAS can access the data. 

Attaching
1. Select the backup file (*.mdf) in the drop-down list box and click "Open".

2. If the connection was established successfully, click "OK".
The backup file is connected to WinCC CAS.
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Detaching
1. Select an archive in the fold-down list box in the "Detach" dialog box.

Click "Detach selected entries".

3.4.3.3 Catalog

Introduction
The "Catalog" function shows a list of archives, beginning with the newest archive.
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Status of archives
The following archive statuses are available:

● Backed-up&Detached - The archive has been transferred to a backup file. You can connect 
to the StoragePlus Server again.

3.4.3.4 Archive List

Introduction
The archive list shows a list of archived data.

"Archived Data" dialog
The dialog shows you a list of all archived data. Which data is archived depends on your 
configuration. The following information is displayed in the dialog: 

● Server

● Data Type

● Time From - Time To

If you select a different server or a different data type, you limit the list to this selection.
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3.4.3.5 Configuration Data

Saving configuration data
The configuration data of WinCC CAS, such as the catalog content, is saved to a backup file. 

Start the backup using the "Save" button. In the "Backup Configuration" dialog, enter the 
destination path where the backup file will be saved. 

Downloading configuration data
Any unexpected server failure (such as power failure or unplugging the power cord) may 
corrupt the configuration data. Use the "Restore" button to restore the configuration data from 
the backup file.

3.4.4 "Advanced" dialog for data migration

Introduction
In the "Advanced" dialog you can migrate the archive database from version V1.1 to the current 
version. Migration is required to be able to work with the installed version of the central archive 
server. 

Note

If the data is in the current version, this is indicated in the dialog and the data does not have 
to be migrated.

Requirement
The data is in version V1.1. 
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Procedure
1. Click the "Start" button in the "Migration V1.1 > V1.3" area of the "Advanced" dialog.

1. Click "Yes" in the "Database Migration Procedure" dialog that is displayed.
The "Migration Status" dialog box is displayed. When the update is completed, the "OK" is 
enabled.

2. Click "OK".
The archive database is adapted to StoragePlus V1.3.
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3.5 User Management

3.5.1 User Management

Introduction
You use the User Management to manage users and groups. You can set up and manage 
access rights for users in User Management.

General rules
You can assign each user to one or more groups. You cannot change the four predefined 
groups:

● Administrator - Full access to WinCC CAS System

● Power User - Read and create views

● User - Read views

● Guest - No access to views

You can associate the four groups with roles. 

● Administrators (Role: Administrator) 

● Power Users (Role: Power User) 

● Users (Role: User) 

● Guests (Role: Guest) 

User rights are assigned based on maximum access rights. 
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Example: A user is a member of the "Administrator" group and the "User" group. The 
"Administrator" group has more permissions than the "User" group. In this case, the user 
always has administrator rights.

At least one user must be assigned administrator rights in the system. This user must be 
assigned to the "Administrator" group.

3.5.2 "Action" Menu

Introduction
The "Action" menu contains the essential commands of User Management. The content of the 
menu depends on the current selection. You   can also use the context menu or the toolbar to 
call the menu commands.

"Action" Menu

Menu command Action

New user... Creates a new user. 
The "Add New Users" dialog box opens. 
From the "Domain" field, select the relevant user domain. Click "List all users" to 
open a list of all users of this domain. 
If you enter the user name manually, make sure that you spell the entry correctly. 
Click "Next". 
Specify the group to which the user belongs.

New group... Creates a new group. 
The "Initial Settings" dialog box opens. 
Enter the name and the description. Specify the role of the group. Click "Next". 
In the next dialog box, you can select the users to be included in this group.

Properties Changes the properties of users or groups.
Delete Removes a user or a group. You cannot delete a group that contains users. You 

must first remove the users from the group before it can be deleted.

3.6 View Management

3.6.1 View Management

Introduction
View Management manages the view objects. View objects represent views of the WinCC 
CAS data. View objects are created with the WinCC CAS View Editor. 
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Layout

The tree view shows the published view objects. The following view objects exist:

● Configuration 

● Group

● Views

Additional information
The detailed window provides you with additional information on the selected view object. 

Double-click the selected view object. The "Properties" dialog with information on the view 
object opens.
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"General Settings" tab

Box Description

Name Name of object view.
Description Optional text with additional information.
Show If this option is enabled, the view object is displayed in the WebViewer.

If this option is disabled, the view object is not visible in the 
WebViewer.

Object status You will find additional information in the section "Editing View 
Objects". 

Force release editing You will find additional information in the section "Editing View 
Objects". 

Note

When a new view object is created, the display is not automatically updated. To update the 
view, select the "View Management" menu item.

WinCC/CAS Administration Console
3.6 View Management

MDM - WinCC/Central Archive Server
System Manual, 11/2008,  55



"Security" tab
You will find additional information on the "Security" tab in the section "Working with Access 
Rights".

See also
Working with Access Rights (Page 56)

Editing View Objects (Page 58)

3.6.2 "Action" Menu

Introduction
The most important commands of View Management can be found in the "Action" menu. The 
functionality of the menu depends on your selection. The menu commands can also be called 
from the context menu and toolbar.

"Action" Menu

Menu command Action

New group Creates a new group.
Delete Deletes a view object.
Update Updates the view.
Properties Opens the "Properties" dialog with information on the view object.
Help Opens Help for the Administration Console.
Shift view Shifts a view within the same project.

3.6.3 Working with Access Rights

Introduction
View objects created in the View Editor are assigned default access properties. You can 
change the access rights subsequently in View Management. You can change the access 
rights in the "View Properties" dialog on the "Security" tab.
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"Security" tab

The boxes in the dialog have the following meaning: 

Box Description

Users or Groups Specifies users or groups permitted to access the view objects.
Access Right: Specifies the following access right for users or groups:

● Get
– View object may be read in View Editor but may not be changed.

● Change
– View object may be read and changed in View Editor.

● Full access
● No access

– View object is not visible in View Editor or Web Viewer.
Inherit access rights 
from parent

If this option is enabled, the view object inherits the access rights of the parent 
object. The previous access rights are overwritten.
If this option is disabled, the view object may be assigned its own access rights. 
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3.6.4 Editing View Objects

Notes
Please note the following when editing view objects:

● The view objects are saved centrally on the WinCC CAS. The current object status of the 
view object is displayed in the properties dialog of the "General Settings" tab.

● If the View object is not edited, then the following text is displayed in the object status: "You 
can modify this object".
If the view object is being edited, the display indicates which user is editing the view object.
The view object is blocked for other users during the user's editing session.

● Once the user has finished the editing session, the object status is reset. The view object 
can then be changed by other users.

● If the view object is being edited, the administrator may modify the object status in View 
Management. Using the "Force release editing" button, the view object is enabled again 
and any changes made are reset. This may be necessary, for example, if there was a power 
failure while editing the view object. The view object remains blocked for other users.
The administrator can re-enable the view object for editing using the Administration 
Console. 

NOTICE

Use the "Force release editing" button only when absolutely necessary.
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WinCC/CAS View Editor 4
4 Resources

4.1 WinCC CAS View Editor

Contents
You use the WinCC CAS View Editor to create views. Views represent views of WinCC CAS 
data.

The sections of this documentation contain information regarding: 

● Available views

● How to configure views

● Properties of view components

● How to configure WinCC components

4.2 WinCC CAS View Editor

Introduction
You use the WinCC CAS View Editor to create views. Views represent views of WinCC CAS 
data.

The following views exist:

● Configuration 

● Group

● Views
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View
With views, you specify the data to be displayed and its form. The tree views are stored under 
the "Configuration" entry. The "Configuration" element is also termed the view configuration. 

Saved and published view configurations can be displayed in the WinCC CAS Web Viewer, 
and can be selected for viewing.

Note

The term "alarm", which is used at a number of points, corresponds to the WinCC term 
"message".

See also
Working with Views (Page 66)

4.3 Layout

4.3.1 Status Bar

Information
The status bar provides you with the following information:

● Which object is selected 

● Which mode the user is working in (offline or online) 

● The exact position in the editing box where the cursor is located 

WinCC/CAS View Editor
4.3 Layout

MDM - WinCC/Central Archive Server
60 System Manual, 11/2008,  



Properties
You can display and hide the status bar.

4.3.2 Toolbar

Introduction
The toolbar provides buttons for the most important menu commands of the WinCC CAS View 
Editor. If you do not require it, you can hide  the toolbar.

Functions
Functions of the standard toolbar buttons:

Icon Function Description

New configuration Creates a new configuration. If a configuration is already open, 
you must close it first.

Open configuration Opens an existing configuration.

Save configuration as .. Saves the active configuration.

New group Creates a new group in the active configuration.

New view Creates a new view in the active group.

Copy Copies the selected object (text or drawing object) to the 
clipboard. This function is only available if an object is selected.

Paste Inserts the content of the clipboard at the cursor position. This 
function is only available if the clipboard contains data.

Delete Deletes the selected object. This function is only available if an 
object is selected.

New text label Inserts a text label in the active view.

New link Inserts a link in the active view.

New alarm table Inserts a new alarm table in the active view.

New alarm hitlist Inserts a new alarm hitlist in the active view.

New WinCC report table Adds a new WinCC report table to the active view.

New diagram Inserts a new diagram in the active view.

Note

Users with the appropriate access permissions,  for example, full control, can change views.
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4.3.3 Menu Bar

4.3.3.1 Menu Bar

Introduction
The menu bar is always visible. The commands in the respective menus are enabled or 
disabled according to the context. To select a command, open the corresponding menu. Click 
on the command and set parameters in the open dialog, as needed.

Menu Bar
The menu bar contains the following menu commands:

● File

● Edit

● Paste

● Configuration

● View

● Help

See also
"File" menu (Page 62)

"Edit" menu (Page 63)

"Paste" menu (Page 63)

"Configuration" menu (Page 64)

"View" menu (Page 65)

"Help" menu (Page 65)

4.3.3.2 "File" menu

Commands
The "File" menu contains the following commands:

Command Shortcut Function

New - Creates a new configuration, group or view. A new 
configuration cannot be created when a configuration is 
already open. 

Open configuration <Ctrl+O> Opens an existing configuration.
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Command Shortcut Function

Close - Closes the active configuration.
Add - Adds an existing view to the active configuration.
Save <Ctrl+S> Saves the active configuration.
Save As - Saves the active configuration under a new name. 
Rename <F2> Renames a selected view, group, or configuration. 
Exit - Closes the WinCC CAS View Editor

4.3.3.3 "Edit" menu

Commands
The "Edit" menu contains the following commands:

Command Shortcut Function

Copy <Ctrl+C> Copies the selected view or the component to the clipboard.
Paste <Ctrl+V> Inserts a copied object.
Delete <Del> Deletes a selected element
Undo <Ctrl+Z> Undoes the previous action. This command is not available for 

all actions.
Arrange - Arranges the components in a view. 
Translate texts ... - Opens the "Translate" dialog box. In this dialog, the texts are 

directly translated as follows: 
1. From the "To:" drop-down list box select the target language. 
2. Click in the corresponding column.
3. Press the <F2> key. Enter the translated text.

4.3.3.4 "Paste" menu
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Commands
The "Paste" menu contains the following commands:

Command Function

Text field Inserts a text field in the active view.
Link Inserts a text link in the active view.
Table Inserts an alarm table, alarm hit list, table of tag values or a WinCC report 

table into the current view.
Diagram Inserts a new diagram into the current view

4.3.3.5 "Configuration" menu

Introduction
This menu contains the commands for managing configurations. 

Commands
The "Configuration" menu contains the following commands:

Command Function

Get Opens the following dialog: 
In this dialog you select the configuration you 

want to read. The configuration cannot be edited. If you attempt to make a change,  
the following message appears.

To edit the configuration, click "Yes". 
Get for Editing Opens the View Configuration for changing the views. You can only change the 

configuration offline. By the "Publish" function the information on the server is 
updated. 
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Command Function

Publish Saves the configuration to the WinCC CAS database. The views are published for 
the Web. You can access the views using the WebViewer.

Release Editing Exits the change mode for this view without saving changes. The changes in this 
view are discarded.          
 Note that you can save changes beforehand in a new view under a different name. 

4.3.3.6 "View" menu

Commands
The "View" menu contains the following commands:

Command Function

Toolbar Displays and hides the toolbar.
Status Bar Displays and hides the status bar.
Configuration Displays and hides the tree view.

4.3.3.7 "Help" menu

Commands
The "Help" menu contains the following commands:

Command Function

Function Starts the online help for the WinCC CAS Editor.
About... Shows more detailed information about the  current application.
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4.4 Configuring View Objects

4.4.1 Working with Views

Introduction
The views are hierarchically arranged in the tree view. The following views exist:

● Configuration

– Top level

● Group

– Groups views. Can only be positioned under a configuration. 

● Views

– View of the data stored in WinCC CAS. Can be positioned under a group or configuration.

You can edit each view in the following ways: 

● Using the menu bar 

● Using the context menu 

● Using the toolbar 

The menu commands are enabled or disabled depending on the situation. 
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Commands
The following commands are available:

Command Shortcut Function

New - Creates a new configuration, group or view. A new 
configuration cannot be created when a configuration is 
already open.

Open Configuration... <Ctrl+O> Opens an existing configuration.
Save View ... - Saves the active view. 
Copy <Ctrl+C> Copies the selected view or the component to the clipboard.
Paste <Ctrl+V> Inserts a copied object.
Delete <Del> Deletes a selected element.
Inherit rights from parent - Hands down the access authorization rights of the parent 

object to the view. You will find additional information on 
access rights in the "Assigning access rights" section.

User Rights... - Opens a dialog where you specify which user or group has 
access to the view. You will find additional information on 
access rights in the "Assigning access rights" section.

Language... - Specifies the language for the view. Keep in mind that the 
texts must be translated into the respective language. You 
will find additional information on language in the "Edit" 
section. You translate the texts from the "Edit" menu by 
choosing "Translate texts ...". Then you can select the new 
view language.

Rename <F2> Renames selected views, groups, or configurations. You will 
find the "Rename" command on the "File" menu.

Moving Views
You can move the views using Drag&Drop. The cursor indicates whether Drag&Drop is 
possible at the target location.

See also
How to Assign Access Rights (Page 68)

"Edit" menu (Page 63)
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4.4.2 How to Assign Access Rights

General information
View objects created in the View Editor are assigned default access properties. An access 
right specifies a user or group and an assigned access level.

Access right Effects in the View Editor Effects in the Web Viewer

No access View components are not 
visible and the object cannot 
be edited.

View is not visible

Get View components are read 
only, and objects cannot be 
edited.

View is visible.

Modify View components and 
object can be edited.

View is visible. The time period involved can 
be changed in each table.

Full access View components and 
object can be edited.

View is visible. The time period involved can 
be changed in each table.

Procedure
1. In the tree view, select the view object for which you want to configure access rights.

2. From the context menu choose "User Rights".
The "User Rights" dialog opens.
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3. To delete users/groups:

– In the "Available Users/Groups" group select the user or group.

– Click the "Add..." button.

– Click the "Accept" button.
This saves the changes.

– Click "OK" to close the dialog box.

4. To delete users/groups:

– In the "Assigned Users/Groups" group select the user or group. Click the "Delete" button. 
Click the "Accept" button.
This saves the changes.

– Click "OK" to close the dialog box.

5. To assign access rights:

– Open the context menu to the "Assigned Users/Groups" entry. Select the access right.

– Click the "Add..." button.

– Click the "Accept" button.
This saves the changes.

– Click the "OK" button.
The dialog box is closed.

4.5 View Components

4.5.1 View Components

View Components
The data is displayed using view components. Each view can have one or more view 
components. You can zoom in and out and move each view component.

You can use the standard Add, Delete and Copy commands for the view components. You 
can select the menu commands Copy and Insert from the main menu, the context menu, or 
the toolbar. 

You can undo each editing action. To do so, choose "Edit > Undo" from the menu or use the 
shortcut <CTRL+Z>.

The View Editor supports the following view components for data visualization:

● Text label 

● Link 

● Alarm table 

● Alarm hitlist
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● Report table 

● Graph

4.5.2 Text label

General information
You can use the text label to describe events or view components  in more detail. You can 
also use the text label without any text as a wide colored separator between two tables. The 
text label is then a field with a defined background color and size.

Properties
Open the context menu by right-clicking the text label.

You can use the following settings to specify the appearance of the text label:

Menu command Function

Font Opens the "Font" dialog box. In this dialog box you define the settings for 
the displayed text.

Foreground Color Specifies the color for the foreground  of the object. The "foreground color" 
is equivalent to the text color. Select a color from the color palette.

Background Color Specifies the background color of the object. Select a color from the color 
palette.

Text Defines the text. Enter a text in the "Text" dialog box.         
 Alternatively, you can open the "Text" dialog box by double-clicking on the 
text label. 
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4.5.3 Link

General information
You can use the link object to link views together. 

Properties
Open the context menu by right-clicking on the link object.

You can use the following settings to specify the properties of the link object:

Menu command Function

Font Opens the "Font" dialog box. Use this dialog to specify the settings for the 
text to be displayed.

Foreground Color Specifies the color for the foreground  of the object. The "foreground color" 
is equivalent to the text color. Select a color from the color palette.

Background Color Specifies the background color of the object. Select a color from the color 
palette.
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Menu command Function

Text Defines the text. Enter a text in the "Text" dialog box.         
 Alternatively, you can open the "Text" dialog box by double-clicking on the 
text field. 

Link Defines which view the link object will be linked to. When you click on the 
"Link" property the "View Editor" dialog box opens.         
 In the "View Editor" dialog box click "OK". The mouse pointer changes to 
the hand pointer. Click on the view to be linked in the tree structure. 
Alternatively, you can open the "View Editor" dialog box by double-clicking 
on the link object. 

4.5.4 Alarm table

General information
The alarm table is used to output WinCC messages. 

Properties
Open the context menu by right-clicking on the status bar.

You can use the following settings to define the alarm table properties:
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Menu command Function

Font Opens the "Font" dialog box. In this dialog box you define the settings for the 
displayed text.

Header -> Font Opens the "Font" dialog box. Use this dialog to specify the settings for the table 
header.

Header -> 
Foreground Color

Specifies the color for the foreground of the header. The "foreground color" is 
equivalent to the text color. Select a color from the color palette.

Header -> 
Background Color

Specifies the background color of an object. Select a color from the color palette.

Filter Specifies which data will be displayed. You can also open the "Filter" dialog box 
by double-clicking on the alarm table. 

"Column 
Selection" tab 

Specifies which columns in the alarm table will be generated. Activate the columns 
you require by clicking on the option.
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Menu command Function

"Query" tab Specifies which messages will be displayed.

1. Select a filter criterion from the list.
2. From the "Server" group select the server holding the archive data. The entry 

"*" signifies that the tags are used by all available servers.
3. In the "Filter" group, select a value from the drop-down list box. You can also 

enter the value directly in the selection box.
In the filter function you can use the wildcards "*","?","-".
– "*"  replaces any number of characters at the start or end of the name.
– "?"  stands for any character.
– "-"  can be used to enter a number range, e.g. 2-100

You can combine these wildcards with other letters or numbers. The 
selection list shows the available search items.
Click the "Add" button to add the selected tag. 
Click the "Update" or "Delete" button to define or delete a tag. 

Note
A filter must always be selected. If no special filter is required, for "Server" and 
"Filter" use the wildcard "*". 

"Time" tab On the "Time" tab you define the time span.

The "Period" defines the time span to be analyzed, e.g. one week.
The time unit indicated in the "Shift" field is the time difference relative to the 
current system time.
Example: You want to analyze the messages which occurred during the week two 
weeks ago. In the "Shift" field enter a "2". A point two weeks back from the current 
system time is calculated.
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4.5.5 Alarm hitlist

General information
The alarm hitlist is used to output WinCC alarm statistics in a table.

Properties
Open the context menu by right-clicking on the status bar.

Use the following settings to set the alarm hitlist properties:

Menu command Function

Font Opens the "Font" dialog box. In this dialog box you define the settings for 
the displayed text.

Header -> Font Opens the "Font" dialog box. Use this dialog to specify the settings for the 
table header.

Header -> Foreground 
Color

Specifies the color for the foreground of the header. The "foreground color" 
is equivalent to the text color. Select a color from the color palette.

Header -> Background 
Color

Specifies the background color of the header. Select a color from the color 
palette.

Filter Specifies which data will be displayed. You can also open the "Filter" dialog 
box by double-clicking on the alarm hitlist. 
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Menu command Function

"Column Selection" tab Specifies which columns in the alarm hitlist will be generated. Activate the 
columns you require by clicking on the option.
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Menu command Function

"Query" tab Specifies which messages will be displayed.

1. Select a filter criterion from the list.
2. From the "Server" group select the WinCC CAS server holding the 

archive data. The entry "*" signifies that the tags are used by all 
available servers.

3. In the "Filter" group, select a value from the drop-down list box. You can 
also enter the value directly in the selection box. 
In the filter function you can use the wildcards "*","?","-". 
– "*"  replaces any number of characters at the start or end of the 

name.
– "?"  stands for any character.
– "-"  can be used to enter a number range, e.g. 2-100

You can combine these wildcards with other letters or numbers. The 
selection list shows the available search items.
Click the "Add" button to add the selected tag. 
Click the "Update" or "Delete" button to define or delete a tag. 

Note
A filter must always be selected. If no special filter is required, for "Server" 
and "Filter" use the wildcard "*". 

"Time" tab On the "Time" tab you define the time span.

The "Period" defines a the time span to be analyzed, e.g. a week.
The time unit indicated in the "Shift" field is the time difference relative to 
the current system time.
Example: You want to analyze the messages which occurred during the 
week two weeks ago. In the "Shift" field enter a "2". A point two weeks back 
from the current system time is calculated.
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4.5.6 WinCC Report Table

General information
The report table is used to view WinCC reports.

Properties
Open the context menu by right-clicking on the status bar.

You use the following settings to set the report table properties:

Menu command Function

Font Opens the "Font" dialog box. Here you define the settings for the text to be 
displayed.

Foreground Color Specifies the color for the foreground  of the table row. The "foreground 
color" is equivalent to the text color. Select a color from the color palette.

Background Color Specifies the background color for the table row. Select a color from the 
color palette.

Header -> Font Opens the "Font" dialog box. Here you define the settings for the header.
Header -> Foreground 
Color 

Specifies the color for the foreground of the header. The "foreground color" 
is equivalent to the text color. Select a color from the color palette. 

Header -> Background 
Color 

Specifies the background color of the object. Select a color from the color 
palette. 

Filter Opens the "Filter" dialog box. Here you specify which data will be displayed. 
You can also open the dialog box by double-clicking on the report table.

WinCC/CAS View Editor
4.5 View Components

MDM - WinCC/Central Archive Server
78 System Manual, 11/2008,  



Menu command Function

"Column Selection" tab Specifies which columns in the report table will  be generated.
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Menu command Function

"Query" tab Specifies which WinCC reports will be displayed.

1. Select an element from the "Criterion" list.
2. From the "Server" group select the WinCC CAS server holding the 

archive data. The entry "*" signifies that the tags are used by all 
available servers.

3. In the "Filter" group, select a value from the selection list. You can also 
enter the value in the selection list. 
In the filter function you can use the wildcards "*","?","-". 
– "*"  replaces any number of characters at the start or end of the 

name.
– "?"  stands for any character.
– "-"  can be used to enter a number range, e.g. 2-100.

You can combine these wildcards with other letters or numbers. The 
selection list shows the available search items.
Click the "Add" button to add the selected tag. 
Click the "Update" or "Delete" button to update or delete a tag. 

Note
A filter must always be selected. If no special filter is required, for "Server" 
and "Filter" use the wildcard "*". 

"Time" tab On the "Time" tab you define the time span.

The "Period" defines a the time span to be analyzed, e.g. a week. 
The time unit indicated in the "Shift" field is the time difference relative to 
the current system time. 
Example: You want to analyze the WinCC reports which occurred during 
the week two weeks ago. In the "Shift" field enter a "2". A point two weeks 
back from the current system time is calculated. 
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4.5.7 Diagram

General information
The diagram function is used to visualize tags in a trend. A table of values is available for each 
trend. The table of values is displayed in WinCC CAS WebViewer only. Statistical values for 
the tags can also be calculated and displayed.

Properties
Open the context menu by right-clicking on the status bar.

You can use the following settings to specify the diagram properties:

Menu command Function

Foreground Color Specifies the color for the foreground  of the table row. The "foreground 
color" is equivalent to the text color. Select a color from the color palette.

Background Color Specifies the background color for the table row. Select a color from the 
color palette.

Tags Opens the "Filter" dialog box. In this dialog you specify which data will be 
displayed. You can also open the "Filter" dialog box by double-clicking on 
the diagram.
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Menu command Function

"Tags" tab Specifies which tags will be displayed as trends.

1. Select the server. Make sure nothing is entered in the "Tag" drop-down 
list box. Any existing tags will otherwise have a filter effect.
If the selected WinCC CAS server has a redundant partner, the 
"Redundant Server" option is active. The redundant partner is shown 
in the drop-down list box. The data is provided by either the WinCC CAS 
Server or by the redundant partner server. If the data supply from the 
WinCC CAS Server fails, the data is obtained from the redundant 
partner server.
If the selected server has no redundant partner, you can specify a server 
as the redundant partner server. Activate the "Redundant Server" 
option and select a server. This modification applies to all tags.

2. In the "Filter" group, select a value from the drop-down list box. You can 
also enter the value in the drop-down list box.
In the filter function you can use the wildcards "*","?","-".
- "*" replaces any number of characters at the start or end of the name.
- "?" stands for any character.
- "-" can be used to enter a number range, e.g. 2-100.
You can combine these wildcards with other letters or numbers. The 
drop-down list box provides you with a list of possible search terms.
Click the "Add" button to add the selected tag. Click the "Update" or 
"Delete" button to update or delete a tag. 
Note
If you use a view that was created under PCS7 V6.1 SP1, you need to 
select and update each tag. Then publish the view again.

3. Assign the corresponding x axis and y axis to the tag. Up to three axes 
are available. Each axis must be configured on the "Axes" tab. Click the 
"Add" button to add the selected tag. Click the "Update" or "Delete" 
button to define or delete a tag.

4. In the statistics options, select whether or not the values of each tag will 
be displayed.

"Axes" tab Specifies the time interval and the scale of the axes.

The time span defines the time interval involved, for example one week. 
The time unit indicated in the "Shift period" field is the time difference 
relative to the current system time. 
Example: You want to analyze the WinCC process values which occurred 
during the week two weeks ago. In the "Shift period" field enter a "2". A 
point two weeks back from the current system time is calculated. 
In the "Value Axis" group you define the start and end values. Under "Title" 
you define the axis name. To be able to view the trend curve in the WinCC 
CAS WebViewer, activate the "Active" option. 
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4.6 Examples

4.6.1 Example: How to create a view

Introduction
This section describes how to create a view with an alarm table.

Requirement
● The WinCC CAS View Editor has been started.

Procedure
1. Click the  button on the toolbar or choose "File > New > Configuration" from the menu. 

2. Enter a name for the configuration, for example "Test". This name is displayed in the WinCC 
CAS Web Viewer.

3. From the menu choose "File > New > View" and enter "Alarm" as the view name.

4. From the menu choose "Paste > Table > Alarm".

5. Position the cursor at the point in the view where you want to insert the alarm table. The 
cursor changes to a crosshair. 

6. Keeping the mouse button pressed, drag the alarm table to the desired size. The insertion 
of the alarm table is completed as soon as you release the mouse button.

7. Select the view in the tree view. From the context menu choose "User Rights". The "User 
Rights" dialog opens.

8. In the "Available Users/Groups" group select the user or group. Click the "Add..." button. 

9. In the "Assigned Users/Groups" group right-click on the user or group. Select the "Modify" 
access right.

See also
Example: How to access the WinCC archive data (Page 83)

4.6.2 Example: How to access the WinCC archive data

Introduction
This section shows how to access archive data of WinCC. In the "Alarm Table" view a filter is 
configured.
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Requirements
● The WinCC CAS View Editor has been started.

● You have created a view with an alarm table.

● The computer used as the WinCC CAS Server is available within the network (LAN).

Procedure
1. Double-click on the alarm table.

The "Filter" dialog opens.

2. On the "Column Selection" tab, define the columns to be displayed in the table.

3. On the "Query" tab, select the "Class" criterion.

4. Select the WinCC CAS server holding the archive data.

5. In the "Filter" group, select a message class from the drop-down list box. You can also enter 
the value in the selection list.
If you use the wildcard '*' under "Filter", all message classes will be displayed. 

6. Enter the time period you want to analyze on the tab.

7. From the menu choose "File > Save". Select the folder to which you want to save the view 
configuration.

8. From the menu choose "View Configuration > Publish". The view configuration is saved in 
the WinCC CAS database. 

9. Start the WinCC CAS Web Viewer from the Start menu by choosing SIMATIC > StoragePlus 
> Web Viewer. The start page opens.

10.On the start page select the "Test" configuration. Click on the "Alarm" view. The detailed 
view displays the alarm table and the selected time period.
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WinCC/CAS Web Viewer 5
5 Resources

5.1 WinCC CAS Web Viewer

Contents
The WinCC CAS Web Viewer is a tool for the interactive display of archived data.

Various display options are available in the Web Viewer:

● Display views from saved configurations

● Display alarms in tabular form

● Display alarm hitlist

● Display tag data in a table

● Display tag data in a diagram

● Displaying WinCC Reports

5.2 WinCC CAS Web Viewer

Introduction
The Web Viewer is used to display and analyze saved data.

Different display options and functions are available in the Web Viewer.

● Display views from saved configurations

● Display alarms in tabular form

● Display alarm hitlist 

● Display tag data in a table

● Display tag data in a diagram

● Displaying WinCC Reports
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Additional display options may be set, such as time period to be displayed, number of lines 
per page, and for messages selection of fields and language of message texts. 

Additional functions are available for displaying search results. 

● Filter criteria can be defined when searching for messages.  

● Statistical values, such as mean value and standard deviation, can be calculated with 
aggregate functions. 

● The search result can be printed out or exported. 

Note

The display types are only visible if permitted by the set permissions.
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5.3 Common

5.3.1 Common

Introduction 
This section describes the requirements and the steps necessary to start the Web Viewer for 
the first time.

See also
Requirements for the Web Viewer (Page 87)

How to Start WinCC CAS Web Viewer (Page 88)

Attaching and Detaching Archives (Page 89)

Column Names of Alarm Archives (Page 89)

5.3.2 Requirements for the Web Viewer

Introduction
This chapter describes the hardware and software requirements for Web Viewer.

Web Viewer server 
The server for the Web Viewer is the computer where your WinCC CAS installation runs. 

Web Viewer client 
The required software is Internet Explorer V7.0 or V6.0 SP1 or V6.0 SP2. 
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Security settings in Internet Explorer
Before the client computer can receive data from the server, the following settings must be 
made on the "Security" tab in Internet Explorer in the "Tools > Internet Options" menu:

● Select the "Trusted sites" zone and click the "Sites" button. The list must contain the entry 
"http://localhost" or you must add it. Close the window by clicking "OK".

● Click "Custom level". The "Security settings" window opens. If necessary, correct the 
following settings:

– "Initialize and script ActiveX controls not marked as safe" -> Enable

– "Download signed ActiveX controls" -> Enable

– "Download unsigned ActiveX controls" -> Enable

– "Automatic logon with current user name and password"

– "Access data sources across domains" -> Enable

● Click "OK" to close all windows

Configuring Windows firewall
You will have to configure the Windows firewall on the computer if you want to use the Web 
Viewer.

1. Click "Start" > "Control Panel" > "Windows Firewall".

2. Select the network connection that you use to access the Internet on the "Advanced" tab.

3. Click on "Settings" and check the "Web Server (HTTP)" or "Secure Web Server (HTTPS)" 
service.

4. Click "OK" to close the dialog box. Click "OK" to save the settings and close the "Windows 
Firewall" dialog box.

See also
Requirements for the Web Viewer (Page 87)

5.3.3 How to Start WinCC CAS Web Viewer

Introduction
The Web Viewer permits you to view data from linked archives and views that have been 
published on the server. The views are created and published by the Web Editor.

The Web Viewer is not a stand-alone application. The display is shown in Internet Explorer.

Requirement
Automatic authentication has been activated. 
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To do this, open the Internet Explorer and select "Tools > Internet Options". On the "Security" 
tab, select the "Trusted sites" zone and click the "Custom level" button In the "User 
Authentication" section, select "Automatic logon with current user name and password". Close 
the windows by clicking "OK". Close Internet Explorer.

Starting StoragePlus Web Viewer
1. From the Windows Start menu choose "SIMATIC > StoragePlus".

2. Select "StoragePlus WebViewer".

5.3.4 Attaching and Detaching Archives

General information      
Archives and backups are attached and detached in the Administration Console of WinCC/
CAS. 

Note

You require administrator privileges to attach and detach archives and backups in the 
Administration Console.

Attaching swapped-out archives in WinCC/Connectivity Pack and WinCC/DataMonitor
You can attach archives that have been swapped out from CAS with WinCC Archive Connector 
from Connectivity Pack or DataMonitor .

The DataMonitor client or WinCC OLE DB provider can then access the archives.

5.3.5 Column Names of Alarm Archives

Introduction
When displaying alarms in Web Viewer, you can select which columns of the alarm archive 
will be displayed. 
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Overview of column names 
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Position Name Comment

1 WinCCServer Name of WinCC server
2 Number Alarm number
3 Date/Time Time stamp of alarm (date/time without milliseconds) 
4 Milliseconds Time stamp of message (milliseconds)
5 State Come or gone
6 Acknowledged Indicates whether the message has been 

acknowledged
7 Class Message class
8 Type Message type
9 Duration Time lag between "come" and "gone"
10 Info Text For configuring stored text
11 Comment Comment
12 Computer Name Computer Name
13 Priority Priority of the message
14 User Name User Name
15 Application Application that has sent the message
16 Instance Instance that has sent the message
17 Loop in Alarm Call the picture that will send the message
18 - 27 User text 1 - 10 User texts for the process values
28 - 37 Process value 1 - 10 Process values at the timestamp of the message
38 - 47 Process text 1 - 10 Texts for the process values
50 AS number Number of AS
51 CPU number Number of CPU
52 Alarm Tag Tag that has triggered the message
53 Parameters Parameters

The column names "User text .." correspond to the following PCS7 names:

Position PCS7 - Name

User text 1 Source
User text 2 Area
User text 3 Event
User text 4 Batch name
User text 5 Operations
User text 6 Free 1
User text 7 Free 2
User text 8 Free 3
User text 9 Free 4
User text 10 Free 5
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5.4 Displaying Data

5.4.1 Displaying Data

Introduction
The following pages describe the various methods for displaying data from connected archives.

Note

The display types are only visible if permitted by the set permissions.

See also
Displaying Saved WinCC CAS Views (Page 92)

Displaying Archived Messages in a Table (Page 94)

Displaying Archived Messages in a Hitlist (Page 100)

Displaying Archive Tag Values in a Table (Page 105)

Displaying Archive Tag Values in a Diagram (Page 109)

Displaying WinCC Reports (Page 115)

5.4.2 Displaying Saved WinCC CAS Views

Introduction
You use the Web Viewer to display archived data.

As well as configuring the display during runtime in Web Viewer, you can also configure and 
save views in advance. In this way, filter settings you use frequently, as well as combinations 
of tables, charts, and reports are readily available.

Creating, saving and publishing views is described in the View Editor documentation. 

In this section, the display of a saved view will be described based on an example.

Requirements
● The required view has been published on the WinCC CAS Server.

● The Internet Explorer is installed on the Web Viewer Client.
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Display views
1. Start the Web Viewer in the start menu with SIMATIC > StoragePlus > StoragePlus Web 

Viewer.

2. Choose "Select saved configurations".
The "View Selection" dialog opens.
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The saved configurations are displayed with their groups and views. Select the desired 
view.
The selected view will be displayed in a new window.
The components that you configured in the View Editor are displayed in the view. 
In the view window, you can change the display time period for the components and print 
out or export the data. For more detailed information, refer to the sections on component 
displays.

Note

If you want to display the tag values in a diagram in a view that was created under PCS7 
V6.1 SP1, then you must select and update each tag in the View Editor in the context menu 
of the component under "Properties >  Tags". Then publish the view again.

See also
Column Names of Alarm Archives (Page 89)

5.4.3 Displaying Archived Messages in a Table

Introduction
You use the WinCC CAS Web Viewer to display archived data.

This section describes how to display messages in a table based on an example. 
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Requirements
● The archive database is connected to the SQL Server. The connection status can be 

checked in the Administration Console under System Configuration > Archive.

● The Internet Explorer is installed on the Web Viewer Client.
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Displaying archived messages
1. Start the Web Viewer in the start menu with SIMATIC > StoragePlus > StoragePlus Web 

Viewer.

2. Select "Display alarm as table".
The "Project Selection" dialog opens.
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The name of the selected archive is displayed.

3. Follow the "Continue to display options" link.
The display options open.
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4. Set the desired time period and select the columns you want to display in the search result. 
Specify the time period:

– As absolute values with date and time for beginning and end.

– As values relative to the current time.

You can use the "Filter" dialog box to limit the expected search result with filter conditions 
in SQL syntax. This reduces the amount of data to be transferred. To do so, enter in the 
standard search filter conditions for individual columns, or in the expanded search a filter 
condition for all columns.
The header of the "Filter" dialog box indicates whether the search result is filtered. This 
display appears only after the initial search with the specified filter conditions. Filter 
conditions can be changed or reset.
You can further limit the search in the "Select WinCC servers from the list" dialog if the 
database contains reports from more than one WinCC Server.

5. Change the settings for lines per page and language of the alarm texts, if necessary.
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6. Continue using the "Display alarm" link.
The search result will be displayed in the table.

Each alarm displayed also indicates the associated server. This permits the display of 
alarms from several servers.
You can look through the pages and print out or export the displayed contents. You can 
export all values for a selected time period or only the visible area. The selected data is 
exported as *.xml or *.csv files.

Note

This data export is intended for import into Excel and is not suitable for larger data volumes. 
Exporting larger data volumes can bring about longer runtimes and warning messages 
from IE; no data will of course be lost and the export will also not be aborted; however, 
the user will have to confirm the actions so that the export can be continued.

7. To change the data display, in the "Change period" field select a correspondingly shorter 
or longer time. After setting the time or date, click "Refresh" to view the new search result.

8. To change or reset the filter conditions, return to the display options.

Note

For queries to message archives with advanced filter conditions, the data for each archive is 
sorted and displayed individually. This applies to all columns except the "DateTime" column. 
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See also
Column Names of Alarm Archives (Page 89)

5.4.4 Displaying Archived Messages in a Hitlist

Introduction
You use the Web Viewer to display archived data.

This section describes how to display alarms in a hitlist based on an example.

Requirements
● The desired archive database is connected to the SQL Server. The connection status can 

be checked in the Administration Console under System Configuration > Archive.

● The Internet Explorer is installed on the Web Viewer Client.
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Displaying Archived Alarms in a Hitlist
1. Start the Web Viewer in the start menu with SIMATIC > StoragePlus > StoragePlus Web 

Viewer.

2. Select "Display alarm hitlist".
The "Project Selection" dialog opens.
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The name of the selected archive is displayed.

3. Follow the "Continue to display options" link.
The display options open.
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4. Set the desired time period and select the columns you want to display in the search result. 
Specify the time period:

– As absolute values with date and time for beginning and end.

– As values relative to the current time.

5. You can use the "Filter" dialog box to limit the expected search result with filter conditions 
in SQL syntax. This reduces the amount of data to be transferred. To do so, enter in the 
standard search filter conditions for individual columns, or in the expanded search a filter 
condition for all columns.
The header of the "Filter" dialog box indicates whether the search result is filtered. This 
display appears only after the initial search with the specified filter conditions. Filter 
conditions can be changed or reset.

6. If the database contains alarms from more than one WinCC Server, select one or more 
servers via the "Select WinCC servers from the list" dialog box.

7. If necessary, change the setting for the alarm text language.
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8. Continue using the "Display list" link.
The search result for the selected server(s) is displayed in a table.

The table contains configured data and statistics, such as frequency of alarms, cumulative 
duration between "message came" and "message gone". You will find information about 
the table at the bottom of the page.
You can look through the pages and print out or export the displayed contents. You can 
export all values for a selected time period or only the visible area. The selected data is 
exported as *.xml or *.csv files.

Note

When printing the alarm hitlist, the MS Document   Image Writer cannot be supported. A 
printout is therefore only possible using the default printer set in Windows.

Note

This data export is intended for import into Excel and is not suitable for larger data volumes. 
Exporting larger data volumes can bring about longer runtimes and warning messages 
from IE; no data will of course be lost and the export will also not be aborted; however, 
the user will have to confirm the actions so that the export can be continued.

9. To change the data display, in the "Change period" field select a correspondingly shorter 
or longer time. After setting the time or date, click "Refresh" to view the new search result.
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5.4.5 Displaying Archive Tag Values in a Table

Introduction
You use the Web Viewer to display archived data.

This section describes how to display tag values in a table based on an example.

Requirements
● The desired archive database is connected to the SQL Server. The connection status can 

be checked in the Administration Console under System Configuration > Archive.

● The Internet Explorer is installed on the Web Viewer Client.
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Displaying tag values in a table
1. Start the Web Viewer in the start menu with SIMATIC > StoragePlus > Web Viewer.

2. Select "Display tag data in table".
The "Project Selection" dialog opens.

The name of the selected archive is displayed.
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3. Follow the "Continue to display options" link.
The display options open.
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4. Set the desired interval and select the tags whose values you want to display in the table. 
Specify the time period:

– As absolute values with date and time for beginning and end.

– As values relative to the current time.

If the "Display tag values" checkbox is activated, the result table displays the tag values. 
Disable this option if you only want to display values of the selected aggregate functions.

5. If necessary, change the "Rows per page" setting for the number of rows displayed per 
page.

6. Select one or more aggregate functions to be applied to the tag values in the selected time 
period. The values of these functions are applied for the selected time period. They are 
displayed in addition to the tag values if the option "Display tag values" has been activated.
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7. Continue using the "Display data" link.
The search result will be displayed in the table.

In the "Chosen tags" field, you can select the archive tags whose values will be displayed 
in the table.
The time stamp in the format "Date/Local Time/Time Zone" and the quality code are 
displayed for each tag value. In the example, all aggregate functions are also displayed. 
You can look through the pages and print out or export the displayed contents. You can 
export all values for a selected time period or only the visible area. The selected data is 
exported as *.xml or *.csv files. A separate export file is created for each tag. 

Note

This data export is intended for import into Excel and is not suitable for larger data volumes. 
Exporting larger data volumes can bring about longer runtimes and warning messages 
from IE; no data will of course be lost and the export will also not be aborted; however, 
the user will have to confirm the actions so that the export can be continued.

8. To change the data display, in the "Change period" field select a correspondingly shorter 
or longer time. After setting the time or date, click "Refresh" to view the new search result.

5.4.6 Displaying Archive Tag Values in a Diagram

Introduction
You use the Web Viewer to display archived data.

This section describes how to display tag values in a diagram based on an example.

WinCC/CAS Web Viewer
5.4 Displaying Data

MDM - WinCC/Central Archive Server
System Manual, 11/2008,  109



Requirements
● The desired archive database is connected to the SQL Server. The connection status can 

be checked in the Administration Console under System Configuration > Archive.

● The Internet Explorer is installed on the Web Viewer Client.
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Displaying tag values in a diagram
1. Start the Web Viewer in the start menu with SIMATIC > StoragePlus > StoragePlus Web 

Viewer.

2. Select "Display tag data in table".
The "Project Selection" dialog opens.
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The name of the selected archive is displayed. 

3. Follow the "Continue to display options" link.
The display options open.
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4. You can display tags for three different time periods. Specify the time period:

– As absolute values with date and time for beginning and end.

– As values relative to the current time.

The "Add Tags" command opens a window in which you first select the server from which 
the tags will be displayed. Then select the desired tags and close the window with "OK". In 
the "Chosen Tags" window, assign one color to each tag and specify the time interval and 
value axis of the display. You can also activate the display of statistical functions in the 
"Aggregate" area. If the server has a redundant partner, it is entered in the corresponding 
field.
In the "Value Axis" dialog box, you can set automatic or manual scaling for up to three axes. 
With automatic scaling, the area between the lowest and the highest tag value is mapped 
on the display area. With manual scaling, you can control the minimum and maximum value 
of the display by making the appropriate selections.
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5. Continue using the "Display data" link.
The search result is displayed in the diagram.

You can look through the pages and print out or export the displayed contents. You can 
export all values for a selected time period or only the visible area. The selected data is 
exported as *.xml or *.csv files.
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Note

This data export is intended for import into Excel and is not suitable for larger data volumes. 
Exporting larger data volumes can bring about longer runtimes and warning messages 
from IE; no data will of course be lost and the export will also not be aborted; however, 
the user will have to confirm the actions so that the export can be continued.

6. Use the "Zoom" button to activate and deactivate the zoom function. Activate the zoom 
function and use the mouse pointer to click on any point in a displayed trend and zoom in 
on this segment. Repeated clicking enlarges the section.
Use the "1 : 1" button to restore the original view.
Use the "Scale" button to activate and deactivate the automatic scaling of the y-axis when 
zooming.

7. To change the data display, in the "Change period" field select a correspondingly shorter 
or longer time. After setting the time or date, click "Refresh" to view the new search result.

Note

When zooming with automatic scaling active, the labeling of the y-axis is adjusted to the 
values of the trend that was previously selected and enlarged. Trends of other tags are 
ignored and are not displayed in the zoomed area. If automatic scaling is disabled, all trends 
are included and only the displayed time segment is modified when zooming. 

5.4.7 Displaying WinCC Reports

Introduction
You use the Web Viewer to display archived data.

In this section, the display of a WinCC Report will be described based on an example.

Requirements
● The archive database where the report was saved is connected to the SQL server. The 

connection status can be checked in the Administration Console under System 
Configuration > Archive.

● The Internet Explorer is installed on the Web Viewer Client.
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Displaying WinCC Reports
1. Start the Web Viewer in the start menu with SIMATIC > StoragePlus > Web Viewer.

2. Select "Display WinCC reports".
The "Project Selection" dialog opens.

The name of the selected archive is displayed.
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3. Follow the "Continue to display options" link.
The display options open.

4. Set the desired time period and select the columns you want to display in the search result. 
Specify the time period:

– As absolute values with date and time for beginning and end.

– As values relative to the current time.
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5. If necessary, change the "Rows per page" setting for the number of rows displayed per 
page.
You can further limit the search in the "Select WinCC servers from the list" dialog if the 
database contains reports from more than one WinCC Server.

6. Continue using the "Display report list" link.
The search result will be displayed in the table.

7. To change the data display, in the "Change period" field select a correspondingly shorter 
or longer time. After setting the time or date, click "Refresh" to view the new search result.

See also
Column Names of Alarm Archives (Page 89)
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