S7 communication over Industrial Ethernet
S7-200, S7-300 and S7-400
FAQ • April 2013
Question

This entry is from the Siemens Industry Online Support. The general terms of use (http://www.siemens.com/terms_of_use) apply.

Clicking the link below directly displays the download page of this document.

Caution

The functions and solutions described in this article confine themselves to the realization of the automation task predominantly. Please take into account furthermore that corresponding protective measures have to be taken up in the context of Industrial Security when connecting your equipment to other parts of the plant, the enterprise network or the Internet. Further information can be found under the Content-ID 50203404.

Question

How do you configure a S7 connection to exchange data between S7-200 and S7-300 or S7-400 on Industrial Ethernet?

Answer

The instructions and notes listed in this document provide a detailed answer to this question.
Table of content

1 Introduction .................................................................................................................................4
2 S7 communication between S7-200 and S7-300/400..............................................................5
   2.1 Configuration of a client connection in the S7-200...........................................................5
   Configure a client connection to the S7-300 .................................................................8
   Configure a client connection to the S7-400 .............................................................11
   2.2 Configure the S7-300/400 as server for the S7 communication ..............................18
   2.3 Configuration of a server connection in the S7-200 ...............................................19
   Configure a server connection to the S7-300 ...........................................................21
   Configure a server connection to the S7-400 ...........................................................22
   2.4 Configure the S7-300/400 as client for the S7 communication .............................25
   Configuration of the S7 connection ............................................................................25
   Calling the function blocks in the S7 program .........................................................28
3 History .......................................................................................................................................29
1 Introduction

The S7-200 with CP243-1 supports the S7 communication as server and client, i.e. it's possible to

- configure a client connection in the S7-200. So the S7-200 builds up active the S7 connection to the remote server.
- configure a server connection in the S7-200. So the S7-200 takes passive part in building up the S7 connection. The remote client builds up active the S7 connection to the S7-200. The S7-200 provides the data as server.

For the S7-200 you have to configure the S7 connection in STEP 7-MicroWIN with the Ethernet Wizard and for the S7-300 and S7-400 you have to configure the S7 connection in STEP 7.

In this example in the S7-200, S7-300 and S7-400 respectively is used a PLC and a communication processor. You can alternative use a PLC with integrated Industrial Ethernet interface in the S7-300 and S7-400.
2 S7 communication between S7-200 and S7-300/400

2.1 Configuration of a client connection in the S7-200

In this example the S7-200 is configured as client for the S7 communication, i.e. the S7-200 builds up active the S7 connection to the S7-300 and S7-400. The S7-300 and S7-400 are passive involved in establishment of the S7 connection:

The configuration is as follows:

- PLC 315-2DP (6ES7 315-2AG10-0AB0) and CP343-1 (6GK7 343-1EX30-0XE0)
- PLC 416-2DP (6ES7 416-2XK02-0AB0) and CP443-1 (6GK7 443-1GX11-0XE0)
- PLC 222 (6ES7212-1AB22-0XB0) and CP243-1 (6GK7 243-1EX00-0XE0)

In this example in the S7-200, S7-300 and S7-400 the following memory area are defined as send buffer and receive buffer.

**Figure 2-1 overview about the configuration**

**Figure 2-2 send and receive buffer in the S7-200, S7-300 and S7-400**
Start STEP 7-MicroWIN in the Windows START Menu → SIMATIC or double-click the icon of the same name on the desktop.

Open the Ethernet Wizard with the menu command „Tools → Ethernet Wizard…“. Figure 2-3 opening the Ethernet Wizard

In the first step of the Ethernet Wizard you will find a description of it. Click the button „Next“ to start with the configuration. Figure 2-4 description of the Ethernet Wizard

If you have connected the SIMATIC Field PG to the CP243-1 over Industrial Ethernet it will be possible to find out the module position automatically. Therefore click the button “Read Modules”. You can also enter the module position manually. Following click the button „Next“. 
Enter a unique IP address for the CP243-1 and enter the corresponding subnet mask. Click on the button „Next“ to apply the settings.

In the following dialog you set the number of S7 connections which are configured for the CP243-1. Over one S7 connection you can read data from the communication partner and you can write data to the communication partner. Click the button “Next” to continue with the configuration of the S7 connection.
Configure a client connection to the S7-300

In the example the first S7 connection is configured as client connection.

For the remote parameter you enter the IP address of the server. The S7-300 with CP343-1 is the server for the first client connection. The IP address of the CP343-1 is 140.80.0.50 (see Figure 2-1 overview about the configuration).

The S7 connection between S7-200 and S7-300 is well-defined with the TSAPs. The client connection is one-sided configured in the S7-200. You enter 03.02 for the remote TSAP. This TSAP means:

- 03: one-sided configured connection
- 02: slot of the PLC in the S7-300 (is always 2)

Following click the button „Data Transfer“.
You have to choose the following function to write data in the S7-300:

- Write data to the remote server connection

Enter the number of data which should be written to the server. Here 8 byte data (Variables Byte 0-7) are written to the S7-300. In the S7-300 these data are saved in DB20 (byte 0-7).

Click the button „Next Transfer“ to read data from the S7-300.
You have to choose the following function to read data from the S7-300:
This data transfer should
- Read data from the remote server connection

Enter the number of data which should be read from the server. Here 8 byte data (byte 10-17) are read from the DB20 in the S7-300. In the S7-200 these data are saved in Variables Byte 10-17.

Click the button „OK“ to apply the settings for the data transfer.
Configure a client connection to the S7-400

The second S7 connection is also configured as client connection.

For the remote parameter you enter the ip address of the server.
The S7-400 with CP443-1 is the server for the second client connection. The ip address of the CP443-1 is **140.80.0.150** (see Figure 2-1 overview about the configuration).
The S7 connection between S7-200 and S7-400 is well-defined with the TSAPs. The client connection is one-sided configured in the S7-200. You enter **03.03** for the remote TSAP. This TSAP means:

- **03**: one-sided configured connection
- **03**: slot of the PLC in the S7-400

**NOTE**
You find out the slot of the PLC from the hardware configuration of the S7-400 station.

Following click the button „Data Transfer“. 
Figure 2-11 configure client connection to the S7-400

You have to choose the following function to write data in the S7-400:
This data transfer should
- Write data to the remote server connection

Enter the number of data which should be written to the server. Here 8 byte data (Variables Byte 0-7) are written to the S7-400. In the S7-400 these data are saved in DB30 (byte 0-7).
Click the button „Next Transfer“ to read data from the S7-400.
You have to choose the following function to read data from the S7-400:

- **Read data from the remote server connection**

Enter the number of data which should be read from the server. Here 8 byte data (byte 10-17) are read from the DB30 in the S7-400. In the S7-200 these data are saved in Variables Byte 20-27.

Click the button „OK“ to apply the settings for the data transfer.
Since the configuration of the CP243-1 module may no longer be changed, you select the setting with CRC protection. You can specify the Keep Alive Interval with the default time. Click the button „Next“.

Figure 2-14 CRC protection and KeepAlive intervall
Select a free address area for storing the configuration.

Figure 2-15 storing the configuration of the CP243-1

Click on the button „Finish“ to close the Ethernet Wizard.

Figure 2-16 finish the configuration of the CP243-1

So the function blocks ETHx_CTRL and ETHx_XFR are created. You have to call these function blocks in the main program ("MAIN (OB1)") of STEP 7-MicroWIN.

The function block ETHx_CTRL is necessary for the communication setup.
2 S7 communication between S7-200 and S7-300/400

Figure 2-17 call ETH0_CTRL

The function block ETHx_XFR is necessary to read and write the data. It’s called twice to read data from the S7-300 and write data to the S7-300 over the first client connection.

Figure 2-18 call ETH0_XFR to exchange data with S7-300

Additional the function block „ETHx_XFR“ is called twice to read data from the S7-400 and write data to the S7-400 over the second client connection.
2 S7 communication between S7-200 and S7-300/400

Figure 2-19 call ETH0_XFR to exchange data with S7-400

Network 4

Right click the input parameter "Chan_ID" and "Data" of the function block ETHx_XFR. So it's possible to select the symbolic name directly.

Save the configuration and download it in the PLC S7-200.

**NOTE**

The function block ETH0_XFR should not be called more than one time simultaneously over the same S7 connection, but rather one after another. In the user program you need a locking mechanism, so that the second ETH0_XFR is called not before the first ETH0_XFR is finished with DONE.
2.2 Configure the S7-300/400 as server for the S7 communication

In the S7-300 and S7-400 which is the server for the S7 connection you only need a data block (DB) with adequate length. The S7-200 reads the data from this DB and writes the data to this DB, which is defined as send and receive buffer respectively.

In the S7-300 the DB20 is defined as send and receive buffer.
In the S7-400 the DB30 is defined as send and receive buffer.
It’s not necessary to configure a S7 connection for the S7-300 and S7-400 respectively in NetPro.
Furthermore it’s not necessary to call any communication blocks in the S7 program of the S7-300 and S7-400.

Check the data transfer of S7 communication

In STEP 7-MicroWIN open the program of the S7-200 and change to the status table. Here you can check and observe the receive buffer (VB10-17 and VB20-17) of the S7-200 to find out if data are exchanged. Furthermore it’s possible to control the variables in the send buffer (VB0-7).

You insert a variable table in the STEP 7 project of the S7-300 and S7-400 respectively. With the variable table it’s possible to observe the receive buffer of the S7-300 and S7-400 and to control the variables in the send buffer of the S7-300 and S7-400.
2.3 Configuration of a server connection in the S7-200

In this example the S7-200 is configured as server for the S7 communication, i.e. the S7-300 and S7-400 build up active the S7 connection to the S7-200. The S7-200 is passive involved in establishment of the S7 connection:

The configuration is as follows:

- PLC 315-2DP (6ES7 315-2AG10-0AB0) and CP343-1 (6GK7 343-1EX30-0XE0)
- PLC 416-2DP (6ES7 416-2XK02-0AB0) and CP443-1 (6GK7 443-1EX11-0XE0)
- PLC 222 (6ES7212-1AB22-0XB0) and CP243-1 (6GK7 243-1EX00-0XE0)

In this example in the S7-200, S7-300 and S7-400 the following memory area are defined as send buffer and receive buffer.

Figure 2-21 send and receive buffer in the S7-200, S7-300 and S7-400

Start STEP 7-MicroWIN in the Windows START Menu → SIMATIC or double-click the icon of the same name on the desktop.

Open the Ethernet Wizard with the menu command „Tools → Ethernet Wizard…“ (see Figure 2-3 opening the Ethernet Wizard).

In the first step of the Ethernet Wizard you will find a description of it. Click the button „Next“ to start with the configuration.
If you have connected the SIMATIC Field PG to the CP243-1 over Industrial Ethernet it will be possible to find out the module position automatically. Therefore click the button "Read Modules". You can also enter the module position manually. Following click the button „Next“.

Figure 2-23 find out the module position

Enter a unique IP address for the CP243-1 and enter the corresponding subnet mask. Click on the button „Next“ to apply the settings.
2 S7 communication between S7-200 and S7-300/400

In the following dialog you set the number of S7 connections which are configured for the CP243-1. Over one S7 connection you can read data from the communication partner and you can write data to the communication partner. Click the button "Next" to continue with the configuration of the S7 connection.

Configure a server connection to the S7-300

In the example the third S7 connection is configured as server connection. The S7-300 with CP343-1 is the client for this server connection.
The S7 connection has to be configured for the server (S7-200) and client (S7-300), i.e. the S7 connection is configured both-sided.

The S7 connection between S7-200 and S7-300 is well-defined with the TSAPs. You enter **10.04** for the remote TSAP. This TSAP means:

- **10**: both-sided configured connection
- **04**: slot of the CP in the S7-300

**NOTE**

If you use a PLC S7-300 with integrated Industrial Ethernet interface you will enter the slot of the PLC.

Following you activate the function "Accept all connection requests." and click the button “Next Connection” to configure a further S7 connection.

Figure 2-26 configure a server connection to S7-300

Configure a server connection to the S7-400

In the example the fourth S7 connection is configured as server connection. The S7-400 with CP443-1 is the client for this server connection.

The S7 connection has to be configured for the server (S7-200) and client (S7-400), i.e. the S7 connection is configured both-sided.

The S7 connection between S7-200 and S7-400 is well-defined with the TSAPs. You enter **10.03** for the remote TSAP. This TSAP means:

- **10**: both-sided configured connection
- **03**: slot of the PLC in the S7-400

Following you activate the function “Accept all connection requests." and click the button “OK” to change to the next dialog.
Figure 2-27 configure a server connection to the S7-400

Since the configuration of the CP243-1 module may no longer be changed, you select the setting with CRC protection. You can specify the Keep Alive Interval with the default time. Click on the button “Next”.

Figure 2-28 CRC protection and KeepAlive Interval

Select a free address area for storing the configuration.
Click on the button „Finish“ to close the Ethernet Wizard.

So the function blocks ETHx_CTRL and ETHx_XFR are created. You have to call these function blocks in the main program ("MAIN (OB1)") of STEP 7-MicroWIN.

The function block ETHx_CTRL is necessary for the communication setup.
2 S7 communication between S7-200 and S7-300/400

Figure 2-31 call ETH0_CTRL

<table>
<thead>
<tr>
<th>PROGRAM COMMENTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network 1</td>
</tr>
<tr>
<td>Network Title</td>
</tr>
<tr>
<td>ETH0_CTRL</td>
</tr>
<tr>
<td>SM0.0</td>
</tr>
<tr>
<td>CP_Fie~ M10.0</td>
</tr>
<tr>
<td>Ch_Fie~ Mv12</td>
</tr>
<tr>
<td>Error</td>
</tr>
</tbody>
</table>

NOTE The function block ETHx_XFR only has to be call for the data transfer over a client connection.

Save the configuration and download it in the PLC S7-200.

2.4 Configure the S7-300/400 as client for the S7 communication

Configuration of the S7 connection

This example shows the configuration of a S7 connection for the S7-300. Use the same procedure for the S7-400.

Open the STEP 7 project with the configuration of the S7-300. Following open the program NetPro with the menu command „Options→Configure Network“ or click on the corresponding symbol in the toolbar

Figure 2-32 open NetPro
In NetPro you select the CPU in the S7-300 station and add a new connection with the menu command „Insert → New Connection.“

Select for the connection partner „unspecified“ and for the connection type „S7 connection“. Click on the button „Apply“. The property view of the S7 connection will open.
In the property view of the S7 connection you activate the function „Establish an active connection“, because the S7 connection is build up by the S7-300. Enter the IP address of the CP243-1 for the Partner. Click on the button “Address Details”.

Figure 2-35 property view of the S7 connection

In the dialog „Address Details“ you enter the TSAP for the Partner, i.e. that’s the local TSAP of the S7-200 (in this example =12.0).

Figure 2-36 Address Details

Select the S7-300 station in NetPro. Save and compile the configuration and download it in the S7-300 station.
Calling the function blocks in the S7 program

It's necessary to call function blocks FB14 “GET” and FB15 “PUT” in the S7 program of the S7-300. These function blocks you find in Standard Library → Communication Blocks → Blocks.

Figure 2-37 calling FB14 “GET” und FB15 “PUT”

Right click the input parameter „ID“ of the function blocks FB14 „GET“ and FB15 „PUT“ respectively, to insert the local ID of the connection automatically. You can also find out the local ID of the connection in the property view of the S7 connection (see Figure 2-35 property view of the S7 connection).

On the input parameter ADDR_1 of the function blocks FB14 „GET“ and FB15 „PUT“ you enter the area in the S7-200 which should be read and write respectively.

The data are written in the area of Variables Bytes in the S7-200 and the data are read from the area of Variables Bytes in the S7-200. The area of Variables Bytes is addressed as DB1 by the S7-300.

NOTE
If you use a S7-400 you will need the function blocks SFB14 „GET“ and SFB15 „PUT“. These you find in the Standard Library → System Function Blocks → Blocks.

Sample program FB14 „GET“ and FB15 „PUT“ for the S7-300

You find a sample program with the function blocks FB14 “GET” and FB15 “PUT” for the S7-300 in the following article: 18610307.
Sample program SFB14 „GET“ and SFB15 „PUT“ for the S7-400

You find a sample program with the function blocks SFB14 “GET” and SFB15 “PUT” for the S7-400 in the following article: 1819293.

3 History

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>V 1.0</td>
<td>22.04.2008</td>
<td>first issue</td>
</tr>
<tr>
<td>V 1.1</td>
<td>15.08.2008</td>
<td>complete revision</td>
</tr>
<tr>
<td>V 1.2</td>
<td>19.04.2013</td>
<td>Add a note in chapter 2.1</td>
</tr>
</tbody>
</table>