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Question 
How do you do an operating system update (OS update) on operator panels with 
WinCC flexible? 

 

 

 

Answer 
Follow the instructions and notes listed in this document for a detailed answer to 
the above question. 

 

 

 

http://www.siemens.com/nutzungsbedingungen�
http://support.automation.siemens.com/WW/view/de/%3cBeitrags-Nr%3e�


Contents

 

WinCC flexible 2008 
Version V2.0, Entry ID: 19701610 3 
 

Contents 
1 Operating System Update with WinCC flexible.................................... 4 
1.1 Operating System Update (OS Update)............................................... 5 
1.2 Resetting the Operating System to the Factory Settings (Booting) ..... 7 
1.3 Resetting the Operating System to the Factory Settings via Ethernet 

Connection ........................................................................................... 9 
2 Additional Information......................................................................... 11 
2.1 Cable Connection between PC and Operator Panel ......................... 11 
2.1.1 Operating System Update.................................................................. 11 
2.1.2 Resetting the Operating System to the Factory Settings (Booting) ... 11 
2.2 Set the Image Path / File in ProSave................................................. 13 
2.3 Determining the MAC Address........................................................... 14 
3 Problem Analysis................................................................................ 15 
3.1 Disconnected Connection when Using the RS232/PPI Multi-Master 

Cable .................................................................................................. 15 
3.2 Check Box Not Available in ProSave................................................. 15 
3.3 Check Box Cannot be Deselected in ProSave .................................. 15 
3.4 Error Message During the Transfer of the Configuration ................... 15 
3.5 MP 377 "Reset to factory settings" (booting) ..................................... 16 
3.6 A Connection to the Operator Panel Cannot be Established............. 16 
3.6.1 Check transmission type and address on the operator panel............ 16 
3.6.2 Check Cable Connection and Connector........................................... 17 
3.6.3 Check the PG/PC Interface on the Configuration Computer ............. 18 

 

 

 

 



1 Operating System Update with WinCC flexible 

 
 

 

4 
WinCC flexible 2008 

Version V2.0, Entry ID: 19701610 
 

1 Operating System Update with WinCC 
flexible 
Below is a summary of how to do an operating system update (OS update) with 
WinCC flexible.  

 The operating system of the operator panel depends on the version of WinCC 
flexible used.  
You should do always do an operating system update whenever the operating 
system of the operator panel does not match the software version used.  
Information about this is described in section 1.1.  

 If no operable operator panel image exists on the operator panel,  
you can only update the operating system by means of a reset to factory 
settings.  
Information about this is described in sections 1.2 and 1.3.   

 If you have questions on establishing the connection or problems with the 
operating system update, please refer to chapters 2 and 3.   

 

Notes Updating the operating system deletes all the data on the operator panel. 

Therefore, first make a backup of the data below:  
(using ProSave or Automation License Manager, for example) 

 User management. 

 Recipes. 

 Licenses 
(if you reset the operating system to the factory settings. 
Information about this is available in Entry ID: 27005215.) 

 

 

 

http://support.automation.siemens.com/WW/view/de/27005215�
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1.1 Operating System Update (OS Update) 

If you use WinCC flexible 2008 SP1 or higher to transfer a project to an operator 
panel on which an incorrect version of the operating system is installed, WinCC 
flexible recognizes this immediately. 

You get a message via which you can do the operating system update 
automatically. 

 

Please proceed as follows to perform an operating system update "manually".  

Table 1-1 

No. Procedure 

1.  Back up data:  
 
Updating the operating system deletes all the data on the operator panel. 
Therefore, first make a backup of the data below, with ProSave, for example:  

 User management.  

 Recipes.  

2.  Set the PG/PC interface: 
 

 In the SIMATIC Manager, you select the menu command  
"Tools > Set PG/PC Interface...".  

 There you set the interface parameters used,  
CP5512 (PROFIBUS), for example. 

3.  Make transfer settings on the operator panel: 
 
Make the corresponding transfer settings on the operator panel and then switch the 
operator panel to Transfer mode. 

4.  Establish cable connection:  
 
Connect the operator panel to the PG/PC with an appropriate connection cable 
(according to the transfer setting selected). 

5.  Configure WinCC flexible:  
 
Open the WinCC flexible configuration. 

6.  Set transfer mode:  
 

 In the WinCC flexible menu bar, select the menu  
"Project > Transfer > Transfer settings...".  
Make the following settings in the dialog displayed.  

 Then click the "Apply button".  
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No. Procedure 

7.  Update the operating system:   
 

 In the WinCC flexible menu bar, select the menu  
"Project > Transfer > Update operating system...".  
(Project > Transfer > OS update...). 

 The "SIMATIC ProSave [OS Update]" dialog opens.  
– The path with the image of the operating system is already preinstalled.  

(You can also choose a different path for the image of the operating 
system).  

– ProSave automatically adopts the transfer settings you made in Point 5.  

 Click the "Device status" button.  
A connection is established between "ProSave" and the "operator panel".  

 After the connection has been established successfully, the current image 
version of the operator panel is displayed.  
Click on the "Update OS" button. The operating system update is started. 

 
Note:  
Make sure that the correct image path is set.  
(See also section 2.2)  

8.  Transfer the project:  
 
After updating the operating system, the operator panel switches to "Transfer 
Mode".  
Now you can transfer the configuration.  
 
Note: 
For Touch operator panels, you should calibrate the screen beforehand under  
"Control Panel > OP > Touch". 
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1.2 Resetting the Operating System to the Factory Settings 
(Booting) 

Proceed as follows to reset an operator panel to the factory settings. 

 

Notes If you reset the operating system to the factory settings, you cannot use all the 
communication connections and cables.  

Information on which cable you can use for which operator panel is available in 
section 2.1.2. 

 

If "Ethernet" is preset as transfer type for booting, then refer to section 1.3. 

 

Table 1-2 

No. Procedure 

1.  Back up licenses and authorizations:  
 
Before resetting your operator panel to the factory settings, make sure that there are 
no licenses or authorizations on the operator panel. 
Information about this is available in Entry ID: 27005215 

2.  Set the PG/PC interface:  
 
For the "Reset to factory settings" function, the only setting you have to make in the 
PG/PC interface is for the transfer type "Ethernet"  
(see section 1.3). 

3.  Make transfer settings on the operator panel: 
 
No transfer settings need to be made on the operator panel. 

4.  Operator panel power supply:   
 
Switch off the power supply for the operator panel. 

5.  Establish cable connection:  
 
Connect the operator panel to the PG/PC with an appropriate connection cable  

6.  Configure WinCC flexible:  
 
Open the WinCC flexible configuration.  

7.  Set transfer mode:  
 

 In the WinCC flexible menu bar, select the menu  
"Project > Transfer > Transfer settings...".  

 Make the relevant settings in the dialog window displayed.  

http://support.automation.siemens.com/WW/view/de/27005215�
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No. Procedure 

8.  Reset to the factory settings:  
 

 In the WinCC flexible menu bar, select the menu  
"Project > Transfer > Update operating system...". 
(Project > Transfer > OS update...).  
The "SIMATIC ProSave [OS Update]" dialog opens.  
– The path with the image of the operating system is already preinstalled.  

(You can also choose a different path for the image of the operating 
system). 

– ProSave automatically adopts the transfer settings you made in "Point 7". 

 Check the "Reset to factory settings" option or "Boot" (in earlier versions of 
ProSave).  

 Click on the "Update OS" button.  
– If you have specified "Ethernet" as the connection parameter, then you 

also enter the "MAC address" of the operator panel here.  

 Click "Update OS" button and depending on the operator panel used... 
– A dialog window opens with a safety note. Read the note.  

Acknowledge the message with "Yes" and you will be requested to reboot 
the operator panel. 

– The connection to the operator panel starts to be established. 
Read the note. If necessary, you can abort the action with the "Cancel" 
button.  

 Switch the operator panel’s power supply on again.  
The operator panel is reset to the factory settings.  

 
Note:  
If the "Reset to factory settings" check box is not displayed, refer to section 3.2.   

9.  Depending on the operator panel used, after transfer of the data, "ProSave" 
requests you to reboot the operator panel (switch off and on).    
The operator panel then performs additional installation steps. 

10.  Transfer the project:  
 
After completion of the installation, the "Control Panel" is displayed on the operator 
panel.  
For a subsequent project transfer, you first make the required transfer settings on 
the operator panel.  
For Touch operator panels, you should calibrate the screen beforehand under 
"Control Panel > OP > Touch". 
 
Now you can transfer the configuration.  
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1.3 Resetting the Operating System to the Factory Settings 
via Ethernet Connection 

Below we take the example of an MP 377 Touch to show how to reset an operator 
panel to the factory settings via Ethernet. 

 

Notes MP 377 operator panels with the Image version installed for WinCC flexible 2008 
and higher (Image version as from V01.00.02.00_01.83) have the parameter 
"Prepare for Reset". 

More information on this is available in  
Entry ID: 35677293. 

 

 

Table 1-3 

No. Procedure 

1.  Back up licenses and authorizations:  
 
Before resetting your operator panel to the factory settings, make sure that there are 
no licenses or authorizations on the operator panel. 
Information about this is available in Entry ID: 27005215  

2.  Set the PG/PC interface:  
 

 In the SIMATIC Manager, you select the menu command  
"Tools > Set PG/PC Interface...".  

 Set the interface parameters used to  
"TCP/IP -> Your network card".  

3.  Make transfer settings on the operator panel: 
 
No transfer settings need to be made on the operator panel.  

4.  MAC address of the operator panel:  
 
To continue you need the MAC address of the operator panel. 
Please refer to section 2.3 to determine the MAC address. 

5.   Operator panel power supply:  
 
Switch off the power supply for the operator panel.  

6.  Establish cable connection: 
 
Connect the operator panel and the PG/PC using an Ethernet cable  
(cross-over or patch cable). 

7.  Configure WinCC flexible:  
 
Open the WinCC flexible configuration.  

8.  Set transfer mode:  
 
In the WinCC flexible menu bar, select the menu  
"Project > Transfer > Transfer settings..." and select "Ethernet" as the transfer type. 
Specify a unique IP address and then click the "Apply" button.    

http://support.automation.siemens.com/WW/view/de/35677293�
http://support.automation.siemens.com/WW/view/de/27005215�
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9.  Reset to the factory settings:  
 

 In the WinCC flexible menu bar, select the menu  
"Project > Transfer > Update operating system..."  
(Project > Transfer > OS update...). 

  The "SIMATIC ProSave [OS Update]" dialog opens.  
– The path with the image of the operating system is already preinstalled.  

(You can also choose a different path for the image of the operating 
system). 

– ProSave automatically adopts the transfer settings you made in "Point 9". 

 Check the "Reset to factory settings" option or "Boot" (in earlier versions of 
ProSave).   
An input field is displayed for the MAC address. 

 Enter the operator panel's "MAC address".  
Refer to section 2.3 for how to determine the MAC address.  

 Click on the "Update OS" button.  
You will then receive a security warning.  
Read the note. Acknowledge the message with "Yes" and you will be requested 
to reboot the operator panel.  

 Switch the operator panel on again.  
 
Note:  

 If the "Reset to factory settings" check box is not displayed, refer to section 3.2.  

 Make sure that the correct image path is set. This applies, in particular, if 
multiple Engineering Systems  
like ProTool, WinCC flexible or WinCC (TIA Portal), for example, are installed 
jointly on your computer. (See also section 2.2).  

10.  Transfer the project:  
 
After completion of the installation, the "Control Panel" is displayed on the operator 
panel.  
For a subsequent project transfer, you first make the required transfer settings on 
the operator panel.  
For Touch operator panels, you should calibrate the screen beforehand under 
"Control Panel > OP > Touch". 
 
Now you can transfer the configuration. 
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2 Additional Information 

2.1 Cable Connection between PC and Operator Panel 

2.1.1 Operating System Update 

When performing an operating system update, you can use all the communication 
connections supported by your operator panel. 

2.1.2 Resetting the Operating System to the Factory Settings (Booting) 

If you reset the operating system to the factory settings, you cannot use all the 
communication connections and cables. 

Information about this is given in the table below. 
The settings were made in ProSave version V9.0.0.0. 

Table 2-1 

Operator panel RS 232 

Zero modem 
cable 

RS232/PPI 

Multi-master 
cable 

USB/PPI 

Multi-master 
cable 

PN PtP 

Cross 

PN 

Ethernet 

 6ES7 901-
1BF00-0XA0 

6ES7 901-
3CB30-0XA0 

6ES7 901-
3DB30-0XA0 

6XV1 870-

3RH20 *1
) 

Standard 
Ethernet CAT5

C7-635  
OP / TP 

X -- -- -- -- 

C7-636  
Key / Touch 

X -- -- -- -- 

OP 73 micro 
 

-- X X -- -- 

OP 73  
 

-- X X -- -- 

OP 77A 
 

-- X X -- -- 

OP 77B 
 

X -- -- -- -- 

TP 170 micro 
 

-- X -- -- -- 

TP 170A 
 

X -- -- -- -- 

OP 170B 
 

X -- -- -- -- 

TP 170B 
 

X -- -- -- -- 

TP 177 micro 
 

-- X X -- -- 

TP 177A 
 

-- X X -- -- 

TP 177B  
PN/DP 

-- X X
*2

) -- -- 

TP 177B  
mono DP 

-- X X
*2

) -- -- 

TP 177B 4” 
color PN/DP 

-- -- -- X X 

OP 177B 
PN/DP 

-- X X
*2

) -- -- 
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Operator panel RS 232 

Zero modem 
cable 

RS232/PPI 

Multi-master 
cable 

USB/PPI 

Multi-master 
cable 

PN PtP 

Cross 

PN 

Ethernet 

OP 177B  
mono DP 

-- X X
*2

) -- -- 

OP 270 
 

X -- -- -- -- 

OP 277 
 

-- X X
*2

) -- -- 

TP 270  
 

X -- -- -- -- 

TP 277  
 

-- X X
*2

) -- -- 

MP177 
 

-- X X
*2

) -- -- 

MP 270 
 

X -- -- -- -- 

MP 277 
 

-- X X
*2

) -- -- 

MP 370 
 

X -- -- -- -- 

MP 377 
 

-- -- -- X X 

Mobile Panel 
170 

X -- -- -- -- 

Mobile Panel 
177 DP 

-- X X
*2

) -- -- 

Mobile Panel 
177 PN 

-- X X
*2

) -- -- 

Mobile Panel 
277 

-- X X
*2

) -- -- 

Mobile Panel 
277 IWLAN 

-- -- -- X X 

Mobile Panel 
277F IWLAN 

-- -- -- X X 

KTP400 
Basic mono PN 

-- -- -- X X 

KTP600 
Basic DP 

-- X X -- -- 

KTP600 
Basic PN 

-- -- -- X X 

KTP600 
Basic mono PN 

-- -- -- X X 

KTP1000 
Basic DP 

-- X X -- -- 

KTP1000 
Basic PN 

-- -- -- X X 

TP1500 
Basic PN 

-- -- -- X X 

 

*1) For the RS232/PPI multi-master cable you set DIP switches 1 to 3 according to 
the baud rate selected in ProSave.  
DIP switches 4 to 8 must all be set to ZERO. 

*2
) With this cable connection you cannot deselect the "Reset to factory settings" 

option. 
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2.2 Set the Image Path / File in ProSave 

In the following cases, you must change the image path or the image file 
accordingly. 

1. After you have set the ProTool image path for the operator panel displayed, 
you must set the image path for  
WinCC flexible if you now wish to use the same operator panel in WinCC 
flexible. 

2. If you need an earlier version of Image than the one currently displayed. 

 

Notes  The image path setting is device-related. The setting is retained for the selected 
panel type after ProSave is closed.  

 Beforehand, make sure that the correct Image path is set. This applies, in particular, 
if, for example, WinCC flexible and ProTool  
are installed jointly on your computer.  

 

 

In order to set the image path in ProSave, click the button to the right of the image 
path and browse through the folder tree to specify the folder path in which the 
image files are located.  

In the folders you find the image files required for the respective operator panel. 

Figure 2-1 

 
 

 

Sample image path in WinCC flexible 

C:\Program Files\Siemens\SIMATIC WinCC flexible\WinCC flexible 
Images\Operator Panel\xxxxx.img 
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Notes The Image version of the operator panels depends on the version of  
WinCC flexible used.  

Information about how these are interrelated is available at this link: 
http://support.automation.siemens.com/WW/view/de/28263711 

 

 

2.3 Determining the MAC Address 

You can determine the operator panel's MAC address as follows. 

 The MAC address is printed on the back of the operator panel  
(for example, MAC-ADD.: 00-0E-8C-F8-6A-18). 

 When you switch on the operator panel, the MAC address is displayed during 
startup.  

 Via the "Control Panel" of the operator panel. 
In the Control Panel you open the "OP" dialog and select the "Device" tab.  
In this tab you find the device-specific data, like the MAC address. 

 

http://support.automation.siemens.com/WW/view/de/28263711�
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3 Problem Analysis  

3.1 Disconnected Connection when Using the RS232/PPI 
Multi-Master Cable 

If the connection is disconnected when updating the operating system, set a lower 
bit rate.  

If you are using high bit rates, then you must implement the RS232/PPI multi-
master cable with "E-Stand 03" (development status 03) or higher. 

3.2 Check Box Not Available in ProSave  

If the "Reset to factory settings" check box is not displayed, then recheck the 
connection settings made (Link). It is possible that the operator panel does not 
support the transfer type required for this option. 

Refer here to Table 2-1 under point 2.1.2. 

3.3 Check Box Cannot be Deselected in ProSave  

If you use the "USB/PPI Multi-Master Cable" transfer type, then, depending on the 
system, on some operator panels it might not be possible to deselect the "Reset to 
factory settings" option. 
In this case, you cannot make an operating system update (OS Update) using the 
cable, but can only do a reboot ("Reset to factory settings"). 

Refer here to Table 2-1 under point 2.1.2. 

3.4 Error Message During the Transfer of the 
Configuration  

You have changed the operating system of your operator panel and during transfer 
of the configuration you receive the message that the operating system version of 
the operator panel does not match the software version used. 

In this case, prior to updating the operating system, check that the image path has 
been set correctly and that you have selected the correct image file. See section 
2.2 for this. 

Example of an error message in WinCC flexible 

Figure 3-1 

 

or in older versions of WinCC flexible 

Figure 3-2 
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3.5 MP 377 "Reset to factory settings" (booting)  

If the MP 377 operator panel cannot be reset to the factory settings, then check the 
Image version of the MP 377. 

MP 377 operator panels with the Image version installed for WinCC flexible 2008 
and higher (Image version as from V01.00.02.00_01.83) have the new parameter 
"Prepare for Reset".  

In this case refer to Entry ID: 35677293. 

3.6 A Connection to the Operator Panel Cannot be 
Established 

Some points are given below, which you should check if no connection is 
established between the operator panel and the configuration computer. 

3.6.1 Check transmission type and address on the operator panel 

Compare the transfer settings on the operator panel with those on the configuration 
computer. 

Example 

Specification of configuration computer... 

 Transfer via PROFIBUS 

 Panel address 10   

Make sure that "Panel is the only master on the bus" is checked for the transfer 
settings on the operator panel. 

Figure 3-3 

 
 

More information on the topic of "Transfer Settings" is available in Entry ID: 
23802404  

 

http://support.automation.siemens.com/WW/view/de/35677293�
http://support.automation.siemens.com/WW/view/de/23802404�
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3.6.2 Check Cable Connection and Connector  

MPI/PROFIBUS cable 

Please check the points below. 

 Cable connection between the operator panel and the configuration computer. 

 Check the cable for damage. 

 Bus connector especially the connection of the terminating resistors. 

– Terminating resistors ON/OFF.  

The following guideline value applies: 

 Bus terminating resistor OFF:   

– Bus connector with "two" cables connected. 

 Bus terminating resistor ON:  

– Bus connector with "one" cable connected. 

More information on the topic of "Bus terminating resistor" is available in Entry ID: 
187276. 

 

RS232/PPI multi-master cable 

When using an "RS232/PPI multi-master cable", please note the switch settings.  

More information on this topic is available in Entry ID: 16532946  

 

Ethernet Cable 

Use a "crossed" Ethernet cable for the connection between a PG/PC and an 
operator panel.  

If you use a "patch" cable, you need a switch in addition. 

 

Notes Operator panels with two "Ethernet interfaces" have an integrated switch. 

 

 

http://support.automation.siemens.com/WW/view/de/187276�
http://support.automation.siemens.com/WW/view/de/16532946�
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3.6.3 Check the PG/PC Interface on the Configuration Computer 

Check the PG/PC interface on your configuration computer. 

 In Windows XP 

– "Start > SIMATIC > SIMATIC NET > Set PG-PC interface". 

 In STEP 7 

– "Menu bar: Tools > Set PG/PC interface..." 

When setting the interface parameters in 
MPI or PROFIBUS, make sure that the node address is set to "0".  
We also recommend that you select the "PG/PC is the only master on the bus" 
option.  

Figure 3-4 
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