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Safety Guidelines 
This manual contains notices you have to observe in order to ensure your personal safety, as well as to 
prevent damage to property. The notices referring to your personal safety are highlighted in the manual 
by a safety alert symbol, notices referring to property damage only have no safety alert symbol. The 
notices shown below are graded according to the degree of danger. 

 

!  
Danger 
indicates that death or severe personal injury will result if proper precautions are not taken. 

 

!  
Warning 
indicates that death or severe personal injury may result if proper precautions are not taken. 

 

!  
Caution 
with a safety alert symbol indicates that minor personal injury can result if proper precautions are not 
taken. 

 
 Caution 

without a safety alert symbol indicates that property damage can result if proper precautions are not 
taken. 

 
 Notice 

indicates that an unintended result or situation can occur if the corresponding notice is not taken into 
account. 

If more than one degree of danger is present, the warning notice representing the highest degree of 
danger will be used. A notice warning of injury to persons with a safety alert symbol may also include a 
warning relating to property damage. 

Qualified Personnel 
The device/system may only be set up and used in conjunction with this documentation. Commissioning 
and operation of a device/system may only be performed by qualified personnel. Within the context of 
the safety notices in this documentation qualified persons are defined as persons who are authorized to 
commission, ground and label devices, systems and circuits in accordance with established safety 
practices and standards. 

Prescribed Usage 
Note the following: 

 

!  
Warning 
This device and its components may only be used for the applications described in the catalog or the 
technical description, and only in connection with devices or components from other manufacturers 
which have been approved or recommended by Siemens. 
Correct, reliable operation of the product requires proper transport, storage, positioning and assembly 
as well as careful operation and maintenance. 

Trademarks 
All names identified by ® are registered trademarks of the Siemens AG.  
The remaining trademarks in this publication may be trademarks whose use by third parties for their 
own purposes could violate the rights of the owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and 
software described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. 
However, the information in this publication is reviewed regularly and any necessary corrections are 
included in subsequent editions. 
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Preface 

Purpose of this Documentation 
This documentation contains information to support you in the following: 

• Performing steps to ensure the availability of a PCS 7 system 

• Verifying requirements for effective diagnostics for your PCS 7 system 

• Understanding the alarm concept of a PCS 7 system 

• Responding appropriately to faults and preparing Detailed information about 
the state of the PCS 7 system for service experts 

• Selecting the correct diagnostic tool, enabling you to perform diagnostics on 
your PCS 7 system with the help provided 

Disclaimer of Liability 
 

!  
Warning 
Siemens assumes no liability for inappropriate use of the instructions provided in 
this documentation or any consequences that might result for the customer. 

 

!  
Warning 
• Only trained service employees should be authorized to work on the process 

control system. 

• Always observe the plant-specific rules and government regulations when 
making changes to your system. 

• Observe the plant-specific boundary conditions and adjust the work 
accordingly.  

• Always bear in mind that changes in a system can impact other sections of the 
system. 
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Target Audience of this Documentation 
This documentation is intended for use by the following trained service personnel 
(Service Level 1): 

• PCS 7 users  

• SIMATIC S7 specialists  

Required Knowledge  
This documentation contains information about working with PCS 7 intended for 
trained service personnel. The following knowledge is required to understand the 
documentation: 

• Basic knowledge of Microsoft Windows operating systems 

• Knowledge of the functions and configurations of SIMATIC PCS 7 
(Engineering System, PCS 7 Operator Station). 

• Knowledge of the functions and configurations of SIMATIC S7  
(S7-400, STEP 7) 

• Knowledge of the functions and configurations of SIMATIC NET  
(network components and transmission media) 

Important Information about this Documentation 
This documentation is a guide for service support. It therefore does not claim to be 
complete. Due to our lack of knowledge of the particular circumstances in your 
plant, we cannot guarantee the following with this documentation: 

• That you will be able to use this documentation to remedy problems yourself. 

• That, if service is required (similar to what is presented), the procedure 
described will not necessarily enable you to find the cause of the fault or to 
correct the fault. 

• That Detailed information about individual hardware or software components is 
complete. 

• That Detailed information about individual hardware or software errors is 
complete. 

• This documentation cannot provide the same expert knowledge as that 
provided by a service technician or a member of the hotline staff. 

• That procedures carried out will not disturb the system. 

• That the procedures described can be performed via remote access. 
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Scope of this Documentation 
The documentation applies to the software package Process Control System; 
PCS 7 Toolset as of V7.0. 

 
 Note 

The PCS 7 Manual Collection DVD contains all PCS 7 software and hardware 
manuals. You can quickly find important information in this collection by using the 
navigation interface and the full-text search feature. 

 

Differences Between This and the Previous Version 
Below you will find an overview of the most important differences between this 
documentation and that of the previous version: 

• Maintenance station for universal diagnostics/maintenance in PCS 7 
You can find information about this in the section "Full Diagnostics with the 
Maintenance Station" 

• Diagnostics for PROFIBUS PA 
You can find information on this in the section "Diagnostics for PROFIBUS PA". 

• Diagnostic tools for the following operating systems: 

- Microsoft Windows XP Professional 

- Windows Server 2003 

• Other diagnostic tools: 

- PC DiagMonitor  

- Simatic Shell  

- Microsoft Baseline Security Analyzer (MBSA)  

- BANY PROFIBUS  

Conventions 
The names of the elements in the software interface in this documentation are 
presented in the language of the documentation. If you have installed a multi-
language package for the operating system and subsequently switch languages, 
however, some terms may appear in the basic language of the operating system 
and therefore deviate from the terms used in the documentation. 

PCS 7 Glossary 
You can find a PCS 7 glossary defining the most important technical terms used in 
the documentation on the DVD SIMATIC PCS 7; Manual Collection or within the 
PCS 7 software through the help menu of the SIMATIC Manager (menu command 
Help > Topics > "Glossary" button). 
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Further Support 
If you have any technical questions, please get in touch with your Siemens 
representative or responsible agent. 

You will find your contact person at:  

http://www.siemens.com/automation/partner 

You will find a guide to the technical documentation offered for the individual 
SIMATIC Products and Systems at: 

http://www.siemens.com/simatic-tech-doku-portal 

The online catalog and order system is found under: 

http://mall.automation.siemens.com/ 

Training Centers 
Siemens offers a number of training courses to familiarize you with the 
Process Control System SIMATIC PSC 7. Please contact your regional training 
center or our central training center in D 90327 Nuremberg, Germany for details:  
Telephone:   +49 (911) 895-3200.  
Internet:  http://www.sitrain.com 

http://www.siemens.com/automation/partner
http://www.siemens.com/simatic-tech-doku-portal
http://mall.automation.siemens.com/
http://www.sitrain.com/
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Technical Support 
You can reach the Technical Support for all A&D products 

• Via the Web formula for the Support Request 
http://www.siemens.com/automation/support-request 

• Phone:  + 49 180 5050 222 

• Fax: + 49 180 5050 223 

Additional information about our Technical Support can be found on the Internet 
pages http://www.siemens.com/automation/service 

Service & Support on the Internet 
In addition to our documentation, we offer our Know-how online on the internet at: 
http://www.siemens.com/automation/service&support 

where you will find the following: 

• The newsletter, which constantly provides you with up-to-date information on 
your products. 

• The right documents via our Search function in Service & Support. 

• A forum, where users and experts from all over the world exchange their 
experiences. 

• Your local representative for Automation & Drives. 

• Information on field service, repairs, spare parts and more under "Services". 

 

http://www.siemens.com/automation/support-request
http://www.siemens.com/automation/service
http://www.siemens.com/automation/service&support
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1 Safeguarding Availability 

1.1 Introduction 

Overview 
This section presents measures for ensuring availability of a PCS 7 system. 

You can information about fault-tolerant systems in the manual 
Process Control System PCS 7; Fault-tolerant Process Control Systems. 

The information in this section enables you to perform the following tasks: 

• Maintain the specified condition of a system. 
Examples: adhere to maintenance intervals, replace batteries 

• Optimize the system and prevent faults 
Examples: update firmware, eliminate possible known sources of errors 

• Minimize downtime caused by faults 
Examples: provide backups 

Note to Reader 
Topics in this section are divided into topic areas. The following information is 
provided for each topic area: 

 
What? What is described? 

When? When can you perform this action? 

How? You can find Information on the topic in the section entitled "...". 
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Contents 
 

Topic Area Information 

Data backup • What?: Information on backing up and restoring data in a PCS 7 system. Backups 
are necessary if you want to restore the state of a component or configuration 
(because a hard disk is damaged, for example). 

• When?: You should perform a data backup if changes have been made in a 
PCS 7 system. 

• How?: You can find information on creating data backups in the section "Options 
for Data Backup". 

Hardware update A SIMATIC station may switch to STOP mode if you change the hardware. 
• What? Information on how to perform a firmware update and the subsequent 

configuration steps required. 
• When?: If you want to convert components to a current firmware version (because 

new functions are to be used or errors must be corrected, for example). 
• How?: You can find information about firmware updates in the section "Hardware 

Updates". 
Software update A SIMATIC station may switch to STOP mode if you change the software.  

• What? Information on converting projects from older versions to a current version. 
There are two types of software updates: 
- Updates that utilize the new functions of a new version of PCS 7  
- Updates that do not utilize the new functions of a new version of PCS 7 

• When?:  
- If you want to utilize new functions of a new version of PCS 7.  
- If you want your PCS 7 projects to always run with the latest software version.
- If software corrections necessitate conversion. 

• How?: You can find information about software updates in the section "Software 
Updates". 
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1.2 Data backup 

1.2.1 Options for Data Backup 

Introduction 
You can back up project data in a variety of ways and for a variety of purposes, for 
example, project archiving, image file. 

After system failure, you can use a backup to quickly restore the system to its 
original state. 

Recommendations for Increasing Data Security 
• Always back up the data in the following cases:  

- After configuration changes 

- Before and after system component upgrades  

- Before and after configuration software upgrades  

• Keep at least the three most recent versions of your PCS 7 project. 

• Use different storage media for backing up the data. 
Examples: 

- A second hard disk  

- ZIP disk 

- MOD 

- CD/DVD 

This way, data can also be read from another storage medium in the event a 
device becomes defective. 

• You can also back up data on hard disks of PCs in a network. Simultaneous 
hard disk failures on more than one PC are very unlikely.  
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Options for Data Backup 
The sections below describe the options for backing up data: 

Backing up ES project data 

• Backing Up Parameter Settings of the SIMATIC Station  

• Archiving a PCS 7 Project  

• Retrieving a PCS 7 Project  

• Archiving and Retrieving a Multiproject  

• Archiving Custom Libraries  

• Exporting Operator and Display Texts  

• Backing Up Custom Functions and Actions  

Backing up OS project data 

• Backing up OS Configuration Data  

Backing up Batch data 

• Backing Up Configuration Data  

• Generating a Backup  

• Restoring Data From a Backup  

• Archiving Batches  

Backing up the Route Control Data 

• Backing Up Configuration Data  

• Backing up the Project Data of SIMATIC Route Control  

• Restoring Data From a Backup  

Creating an image 

• Backing Up Data by Generating an Image File  

 
 Note 

Make sure that backups are stored in a protected location (in separate rooms, 
fireproof cabinets, etc.). 

Make sure the backups are readable (particularly when reusable storage media 
such as floppy disks are used). 
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1.2.2 Backing Up ES Project Data 

1.2.2.1 How to Back Up Parameter Settings of the SIMATIC Station 

Introduction 
You can change parameters (such as controller settings) online in the 
SIMATIC station using the PCS 7 OS and the engineering station.  

Some situations make it necessary to back up the current data blocks, FBs or 
parameter settings from the SIMATIC station. This is the case, for example, when 
the configuration data have been restored from a data backup.  

You can make use of the following backup options: 

• Read the data blocks and FBs from the SIMATIC station 

• Read charts containing the current parameters from the SIMATIC station 

 
 Notice 

These actions overwrite all settings in the configuration with the current values of 
the system. Make sure that the settings for start values, for example, are correctly 
maintained. 

 

!  
Danger 
If you read in the data from the SIMATIC Station, you must ensure that hazardous 
conditions cannot occur following a hot restart of the system or after configuration 
data are downloaded. 

 

Reading Out Data Blocks and FBs from the SIMATIC Station 
1. Open the project in SIMATIC Manager. 

2. Select the menu command View > Online. 

3. In the tree view, select the data blocks and FBs you want to read from the 
SIMATIC Station. 

4. Select the menu command Edit > Copy. 

5. Select the menu command View > Offline. 

6. Select the menu command Edit > Paste. 
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Reading Out Charts with Current Parameters from the SIMATIC Station 
1. Double-click any CFC chart in SIMATIC Manager to start the CFC Editor. 

2. Select the menu command Chart > Read Back. 

3. In the "Read Back Chart" dialog box, make the following settings: 

- Sources: Program of the CPU 

- Scope: Operator control and monitoring parameters 

Recommendation: back up the project at this point. You can find information on this 
in the section "How to Archive a Project".  

This data backup includes all current parameter settings of the SIMATIC station. 
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1.2.2.2 How to Archive a Project 

Introduction 
You can use various tools to archive project data.  

The PKZIP for Windows program is used in the following for archiving: 
You will find the setup for PKZIP for Windows on the PCS 7 Toolset DVD. 
PKZIP for Windows is automatically installed during the system setup of PCS 7.  

You can open PKZIP for Windows from the SIMATIC Manager. 

Requirement 
• A utility for archiving the project data is installed (usually PKZIP for Windows). 

Making Settings in SIMATIC Manager 
1. In SIMATIC Manager, select the menu command Options > Settings. 

The "Settings" dialog box opens. 

2. Select the "Archiving" tab. 

3. Select your "preferred archiving program" from the drop-down list box 
(PKZIP for Windows is the default). 

4. Select the following "options": 

- Check options 

- Check target directory on retrieval 

5. Click "OK" to accept your entries. 

Making Settings in the PKZIP Software 
If you use PKZIP for Windows, which is supplied on the PCS 7 Toolset DVD, the 
following settings need to be made:  

1. In the Start menu, select the menu command Start > Programs > PKZIP > 
PKZIP for Windows. 
PKZIP for Windows opens. 

2. Select the menu command Tools > Options. 
The "Options" dialog box opens. 

3. Select the "Compress" tab. 
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4. Make the following settings: 

- In the "File Options" group: 
Select the "Include subfolders (recurse)" check box. 
In the "Save folder name" list, select "Relative path". 
In the "Update mode" list, select "Add & Update files". 

- In the "File Attributes" group: 
Select all check boxes.  

- In the "Folders" tab: 
You can specify a default folder for your data backup here. 

5. Click "OK" to accept your entries. 

Archiving a Project 
1. In SIMATIC Manager, select the menu command File > Archive. 

The "Archiving" dialog box opens. 

2. Select the "User Projects" tab. 

3. Click "Browse" and select the project you want to archive from the list.  

4. Click "OK" to save your entries. 
The "Archiving - Select Archive" dialog box opens. 

5. Make the following settings for the archiving: 

- In the "Save in" list: 
Select the drive and folder. 

- In the "File name" field: 
Enter the name of the file in which the data are to be saved. 

6. Click "Save" to accept your entries. 
The "Archive – Options" dialog box opens. 

7. If you want to archive the project to diskettes, select the disk size. 
You can find more information about this dialog box by pressing "Help". 

8. Click "OK". 
The archive operation starts. 

When the "Archiving" dialog box closes, archiving is finished. 

Recommendation 

After compressing your project in the archive directory (S7 project), you should 
rename the project in such a way that you can determine the archiving date from 
the name.  
Example: "yearmonthdayprojectname"; 021230name 

 
 Note 

If you copy the project directly to the CD, all files and directories will be write-
protected. Before using the project again, you need to remove the "Write-
protected" file attribute for all files and folders in the project. 
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Backing up Configuration Data 
Also back up the following configuration data: 

• GSD files (Siemens/STEP 7/S7Data/GSD) to another partition or to another 
drive 

• C scripts of the standard functions 
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1.2.2.3 How to Retrieve a Project 

Requirements 
• The utility used for archiving the project is installed (usually PKZIP for 

Windows). 

• The settings required for the tool used for archiving the project are made (you 
can find additional information on this in the section "How to Archive a Project". 

 
 Note 

You will find the setup for PKZIP for Windows on the PCS 7 Toolset DVD. 
PKZIP for Windows is automatically installed during the system setup of PCS 7. 

 

Procedure 
1. In SIMATIC Manager, select the menu command File > Retrieve. 

The "Retrieving - Select Archive" dialog box opens. 

2. Make the following settings for the archive file: 

- In the "Search in" list:  
Enter the drive and folder where the project was archived. 

- In the "File name" field: 
Enter the name of the file under which the project was archived. 

3. Click "Open" to save your entries. 
The "Select Destination Directory" dialog box opens. 

4. Select the destination directory/project directory in the selection list. 

5. Click "OK" to accept your entries. 

The retrieval is finished when the "Retrieving" dialog box closes. 
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1.2.2.4 How to Archive and Retrieve a Multiproject 

Introduction 
You can store a multiproject in compressed form in an archive file in the same way 
as individual projects or libraries. This can be done on a hard disk or on 
transportable storage media (such as a ZIP disk). 

If individual projects of a multiproject are stored on more than one PC in a network, 
you must use the following program to archive the multiproject: 

• PKZIP for Windows (available on the PCS 7 Toolset DVD) 

Recommendation:  
Archive the multiproject on an engineering server. 

Requirements for Archiving a Multiproject 
• A utility for archiving the project data is installed (usually PKZIP for Windows). 

PKZIP for Windows is automatically installed during the system setup of 
PCS 7. 

• Archiving a multiproject is a cross project function. Therefore, no other process 
can access any of the projects in the multiproject during archiving.  

 Archiving a Multiproject 
1. Select the multiproject in SIMATIC Manager.  

2. Select the menu command File > Archive. 
The "Archiving" dialog box opens. 

3. Select the "User Projects" tab. 

4. Confirm the selected multiproject by clicking "OK" to save your entries.  

5. Make the following settings for the archiving: 

- In the "Save in" list: 
Select the drive and folder. 

- In the "File name" field: 
Enter the name of the file in which the data are to be saved. 

6. Click "Save" to accept your entries. 
The "Archive – Options" dialog box opens. 

7. If you want to archive the project to diskettes, select the disk size. 
You can find more information about this dialog box by pressing "Help". 

8. Click "OK". 
The archive operation starts. 

When the "Archiving" dialog box closes, archiving is finished. 
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Retrieving a Multiproject  
1. In SIMATIC Manager, select the menu command File > Retrieve. 

2. In the next dialog box, select the archived multiproject. 

3. Click "Open" to save your entries.  
The "Select Destination Directory" dialog box opens.  

4. Select the directory where the archive should be extracted. Click "OK". 
The multiproject is retrieved.  
After retrieval, the "Retrieve" dialog box opens. 

5. Click "OK". 
The following is shown in the "Retrieve" dialog box: 

- Name of the retrieved project 

- Prompt for opening the project 

6. Click "Yes" to open project or "No" to stop working. 

Result 
A subdirectory is automatically created in the destination directory you selected. 
The subdirectory contains the following: 

• By default: The name of the multiproject  

• Custom: A unique directory name derived from the name of the multiproject 

The following are placed in the subdirectory: 

• Multiproject 

• Projects contained in the multiproject 

• Libraries, including the master data library 

Once a multiproject is retrieved, all project directories of the multiproject are 
located on the same level below this directory. 
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1.2.2.5 How to Archive Custom Libraries 

Introduction 
If you have created a custom project library in PCS 7, we recommend that you 
archive it. Perform the steps below for each library to be backed up. 

Procedure 
1. In SIMATIC Manager, select the menu command File > Archive.  

The "Archiving" dialog box opens. 

2. Select the "Libraries" tab. 

3. Click "Browse" and select the library you want to archive from the list.  

4. Click "OK" to save your entries. 
The " Archiving - Select Archive" dialog box opens. 

5. Make the following settings for the archiving: 

- In the "Save in" drop-down list box: 
Drive and folder 

- In the "File name" field: 
Enter the name of the file in which the data are to be saved. 

6. Click "Save" to accept your entries. 
The archive operation starts. 
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1.2.2.6 How to Export Operator and Display Texts 

Introduction 
To visualize the process on the operator station you use faceplates, which show 
the plant operator the measured values, operating limits, units, and operator texts 
of the blocks, for example.  

If you have changed operator or display texts in your blocks, we recommend that 
you back up the operator and display texts. 

Exporting Operator and Display Texts 
The SIMATIC Manager allows you to export information from parameters, signals 
and messages to a file *.csv format). 

You can edit this file in standard Office applications (such as MS Excel, MS 
Access). 

The same mechanisms that are used for converting to project-specific languages 
are used for the export. 

Requirement 
PCS 7 allows you to store all operator and display texts in every desired language. 
The only requirement is that the language is installed in your project: 

• The languages available in SIMATIC Manager can be displayed via the menu 
command Options > Language for Display Devices.  

• The number of languages offered is specified when Windows is installed 
(system characteristics). 

Procedure 
1. Open the project in SIMATIC Manager.  

2. In the Component view, select the master data library (or, if not available, the 
project folder). 

3. Select the menu command Options > Manage Multilingual Texts > Export. 
The "Export User Text" dialog box opens. 

4. Make the following settings: 

- Under the "Text Tables" section, specify the storage location and the 
format of the export file (possible formats: *.xls and *.csv). 

- In the "Language" group, set the source and target languages in 
accordance with your display language.  

5. Click "OK". 

6. If you have to manage several project-specific languages, repeat steps 3 to 5 
for each language. Please note that you then have to set different export file 
names or target directories. 
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1.2.2.7 How to Back Up Custom Functions and Actions 

Introduction 
PCS 7 enables you to create dynamic sequences in your OS project by creating 
custom functions and actions. These functions and actions are written in ANSI-C 
language. 

You must back up any project functions, standard functions, local actions, and 
global actions that you have created or modified.  

Project and Standard Functions 
Project functions and standard functions have file names with the extension *.fct. 
By default, PCS 7 places these functions in the following folders: 

• Project functions are placed in the "\library" folder of the OS project.  

• Standard functions are placed in the "\aplib" folder in the installation directory 
of PCS 7. 

Local and Global Actions 
Local and global actions have file names with the extension *.pas. By default, 
PCS 7 places these actions in the following folders: 

• Local actions are placed in the "\<Name of PC>\Pas" folder of the project 
directory.  

• Global actions are placed in the "\Pas" folder of the OS project. 

Additional information 
• Online help for WinCC Information System 
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1.2.3 Backing Up OS Project Data 

1.2.3.1 Backing Up Configuration Data 

Introduction 
When you archive a multiproject, the configuration data of the PCS 7 operator 
station is saved automatically. A separate backup is unnecessary. 

Backing Up OS Configuration Data 
The configuration data for PCS 7 Operator Station are saved by default in the 
following folder: ...\Siemens\WinCC\WinCCProjects. 

To back up data, compress the project paths in this folder and save them on a 
suitable medium (such as a CD). 

Backing Up OS PC Data 
The OS configuration data are located on the PCS 7 engineering station. You 
therefore back up OS server PCs or OS client PCs with an image. You can find 
information on this in the section "Backing Up Data by Generating an Image File". 
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1.2.4 Backing Up Batch Data 

1.2.4.1 Backing Up Configuration Data 

Options for Data Backup 
SIMATIC BATCH offers several options for backing up and restoring project data.  

 
Data Menu command for backup 

operation 
Menu command for restore 
operation 

• Materials 

• Libraries 

• Basic recipes 

• Formula categories 

• Formulas 

• Orders 

• Permissions and 
roles 

• User settings (1) 

• Project settings 

Options > Backup  

You can find information on 
this in the section  
"How to Generate a 
Backup". (2) 

 

Options > Restore  

You can find information 
on this in the section  
"How to Restore Data 
From a Backup". (3) 

• Completed batches Select batch(es), select 
Archive on the context 
menu 

You can find information on 
this in the section "How to 
Archive Batches". 

- 

(1) "User settings" can only be backed up in a database copy. 

(2) You save the data to a database copy or an SBB file (compressed XML file). 

(3) You restore the data from a database copy or an SBB file (compressed XML 
file). 

Additional information 
• Manual Process Control System PCS 7; SIMATIC BATCH 
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1.2.4.2 How to Generate a Backup 

Elements of the Backup 
You can back up all configured data with the Backup command. The backup 
includes the following elements: 

• Materials 

• Libraries 

• Basic recipes 

• Formula 

• Permissions and roles 

• Project settings 

Rule 
 

 Notice 
The follow applies when a backup is running: 

Operator input cannot be executed on the BATCH client where a backup is being 
generated. 

 

Procedure 
1. Select the multiproject/project in SIMATIC Manager. 

2. Select the menu command Options > SIMATIC BATCH. 
The "Batch Process Cell" dialog box opens. 

3. In BatchCC, select the menu command Options > Backup. 

4. If there are unarchived batches in the project, you need to confirm the 
message dialog for unarchived batches. In this case, click "OK". 
The "Backup" dialog box opens. 

5. Enter the name of the backup file in the "File name" input box. 

6. Click "Save".  
The backup file is created. 
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1.2.4.3 How to Restore Data from a Backup 

Introduction 
You reconstruct the data from a backup file and update the Batch process cell in 
the SIMATIC BATCH Control Center (BatchCC). 

Requirement 
There is no Batch process cell in the BatchCC. 

Read Backup 
1. Select the multiproject/project in SIMATIC Manager. 

2. Select the menu command Options > SIMATIC BATCH. 
The "Batch Process Cell" dialog box opens. 

3. In BatchCC, select the menu command Options > Restore. 
The "Restore" dialog box opens. 

4. Select the backup file. 

5. Click "Open". 
The backup file is read. 

Updating the Batch Process Cell 
1. Select the batch process cell in the tree view of BatchCC. 

2. Select the menu command Edit > Update Process Cell. 
The "Select a process cell" dialog box opens.  

3. Click "OK".  
The "Update process cell" dialog box is displayed.  

4. Compare the columns "Current process cell" and "New process cell" row by 
row. Rearrange them if necessary.  
You can find additional information about this in the manual Process Control 
System PCS 7; SIMATIC BATCH. 

5. Click "OK". 
The "Updating process cell" dialog box opens and automatically closes with the 
update is completed. 

Result 
The data from a backup file are entered in a Batch database in the BatchCC and 
the process cell is made available again. 
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1.2.4.4 How to Archive Batches 

Long-term Archive 
You archive batches in long-term archives in BatchCC. Long-term archives are 
used for long-term storage of batch data in accordance with the FDA.  

Rules 
• You can only archive completed batches. 

• The archiving method and archiving path are set. 

• Data from long-term archives cannot be used to restore defective batch data or 
batch structures. 

Archiving Individual Batches 
You archive a single completed batch as follows: 

1. Select the batch to be archived in the tree view. 

2. Open the context menu (by right-clicking) and select the menu command 
Archive. 

Archiving Multiple Batches 
You archive multiple completed batches as follows: 

1. Right-click to open the "Details" shortcut menu and select batch overview list. 

2. Select the batches to be archived.  

3. Open the context menu (by right-clicking) and select the menu command 
Archive. 
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1.2.5 Backing Up SIMATIC Route Control Data 

1.2.5.1 Backing Up Configuration Data 

Options for Data Backup 
SIMATIC Route Control offers the following options for backing up and restoring 
project data.  

• You can backup the project data from SIMATIC Route Control together with a 
PCS 7 project.  
You can find additional information about this in the section "How to Archive a 
Project". 

• You can generate an image of the partition on which the project database is 
located. 

• You can export/import the partial routes from SIMATIC Route Control. 
You can find additional information about this in the section  
"How to Back Up SIMATIC Route Control Project Data" 

Additional information 
• Manual Process Control System PCS 7; SIMATIC Route Control 
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1.2.5.2 How to Back Up SIMATIC Route Control Project Data 

Introduction  
This section describes a separate backup of partial routes from SIMATIC Route 
Control to a file. 

 
 Note 

You can backup the partial routes with offline project data from SIMATIC Route 
Control. The interface blocks are part of the PCS 7 project and are archived along 
with the PCS 7 project. 

 

Preparing the Database Backups 
Before performing a backup, you must always carry out the following steps in 
Route Control engineering: 

• Check the database consistency via the menu command Options > Check 
Consistency. 

• Compress the database via the menu command Options > Compress 
Database. 

Creating a Backup 
1. Select the multiproject/project in SIMATIC Manager. 

2. Select the menu command Options > SIMATIC Route Control > 
Engineering. 
The "Route Control-Engineering - ..." dialog box opens. 

3. Select the menu command Options > CSV Export/Import > CSV 
Export/Import Assistant .... 
The dialog box "Wizard: CSV file data exchange (Export/Import)" opens. 

4. Check the path in the "Directory" input box. 

5. Activate the "RC project engineering >> CSV file(s) (Export)" check box in the 
"Direction" group. 

6. Click "Next". 

7. Select all check boxes. 

8. Click "Next". 

9. Click "Finish". 
The files are exported. 

Additional information 
• Manual Process Control System PCS 7; SIMATIC Route Control 
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1.2.5.3 How to Restore Data from a Backup 

Introduction 
You reconstruct the partial routes from SIMATIC Route Control from a backup file. 

Importing a Backup 
1. Select the multiproject/project in SIMATIC Manager. 

2. Select the menu command Options > SIMATIC Route Control > 
Engineering. 
The "Route Control-Engineering - ..." dialog box opens. 

3. Select the menu command Options > CSV Export/Import > CSV 
Export/Import Assistant .... 
The dialog box "Wizard: CSV file data exchange (Export/Import)" opens. 

4. The dialog box "Wizard: CSV file data exchange (Export/Import)" opens. 

5. Check the path set in the "Directory" input box. 

6. Activate the "CSV file(s) (Import) >> RC project engineering" check box in the 
"Direction" group. 

7. Click "Next". 

8. Select all check boxes. 

9. Click "Next". 

10. Click "Finish". 
The configuration data is read. 

Additional information 
• Manual Process Control System PCS 7; SIMATIC Route Control 
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1.2.6 Creating an Image 

1.2.6.1 Backing Up Data by Generating an Image File 

Introduction  
We recommend that you generate an image of the installation in order to back up 
partitions and hard disk data (following a reinstallation, for example). 

Image File 
An image file maps all of the data on the backed-up medium (hard disk, logical 
drives). It is used to back up data on partitions or hard disks. Many of the software 
packages that can be used to generate image files also offer data compression.  

Boot partitions are included in the backup. This enables you to save all the PC 
settings including the Windows system settings. 

All the data of a PC can be restored using an image file, usually in a short amount 
of time (e.g., 2  GB in approx. 15 minutes). In the event of a fault, you can restore 
the complete PC installation.  

Rules 
• You must use the same hardware to restore data. 

• Note the following hard disk settings for the image file  
(you can find additional information on this in the section "Managing the 
Operating System"): 

- Partition size 

- Formatting of partition or hard disk (e.g., NTFS, FAT32) 

• Authorizations and license keys cannot be included in the backup. 

• The image software must be suitable for the operating system in question. 

Basic Procedure 
1. Move the authorizations and license keys to another medium (diskette, 

partition, etc.) before generating the image. 

2. Follow the image software manufacturer's instructions to create an image. 

Additional information 
• Documentation relating to the image software used 
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1.2.7 Comparing Project Versions 

1.2.7.1 Comparing Project Versions with VXM 

Version Cross Manager (VXM) 
The Version Cross Manager is a standalone application which can purchase as an 
add-on. The Version Cross Manager enables you to find the differences between 
two user programs quickly and surely. This allows you to detect whether changes 
have been made to the user program, and what those changes are. 

Overview 
 

Comparison of Detailed 
information 

Called with Additional information 

Changes to different 
project versions in the 
user program 

CFC charts 
SFC charts 

Start > SIMATIC > STEP 7 > 
VXM - Compare Versions 
 

Configuration manual 
Process Control System 
PCS 7; Engineering System
Online help 
Version Cross Manager 

User programs based 
on XML files  
(for synchronizing 
process-control project 
data with planning data, 
for example) 

CFC charts 
SFC charts 

Version Cross Manager 
• Generate XML file using 

File > Export. 
• Compare XML files 

using File > Compare 
With XML File.... 

Online help  
Version Cross Manager 
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1.3 Hardware Update 

1.3.1 Hardware Updates 

Introduction 
In this section, a hardware update refers to loading new firmware in SIMATIC 
modules. Loading new firmware in a SIMATIC module is referred to as a "firmware 
update" in the following. 

A firmware update includes the following: 

• Function upgrades  

• Operating system enhancements 

Released Modules 
You can learn about the firmware versions of modules released for a PCS 7 
version in the documentation "PCS 7 Released Modules" for the respective 
version.  

Reasons for a Firmware Update 
A firmware update for a SIMATIC module may be needed if you wish to use new 
functions or correct errors. 

Checking the Current Revision or Firmware Version for a Module 
You may need to check the revision or firmware version of a module in the 
following situations: 

• When you replace a module (because it is defective, for example)  

• When you wish to use new functions after changing the configuration 

Compare the document PCS 7 - Released Modules for older PCS 7 versions to 
find out which PCS 7 version first included the feature. 
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Recognizing the Revision or Firmware Version  
Update-capable modules: 

• You will see the following codes for update-capable modules: 

- The revision is indicated by a cross (in the following example: revision 6). 

- The original version of a firmware is show in text (in the following example: 
V3.0.2).  

Example: 

CPU 416-2

416-2XK02-0AB0

7

V3.0.2

X
98

  

• In the firmware update package you receive a label, which you can paste over 
the currently shown firmware version. When the firmware update is completed, 
you should change the specified firmware version of the module to reflect the 
information for the new firmware version. This will ensure uniform plant 
documentation. 

Non-update-capable modules: 

• When only the manufacturer can make changes to a module, only the revision 
is indicated on the housing of the module (indicated by a cross; in the following 
example: revision 10).  

Example: 

PS 407 10A

407-0KA01-0AA0

 X 11
 12 13

 

Recommendation for Performing Firmware Updates 
Perform these firmware updates at regular intervals when an opportunity presents 
itself (such as during a scheduled plant shutdown). 
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Reference Sources for the Latest Firmware Version 
The update file with the latest firmware versions can be obtained from your 
Siemens representative or the Internet: 

Internet address: www.ad.siemens.com/support 

If you cannot access the Internet address, contact Technical Support. 

 
 Note 

The update file may be in an executable, self-extracting file (EXE file). When 
performing consecutive updates for various module types or module versions, you 
must extract the files in separate folders that differ in the following ways: 

• Type of module 

• Revision 

• Firmware version 

 

Overview 
The sections below describe topics related to hardware updates:  

• Adjustments After a Hardware Change  

• Updating a SIMATIC S7 CPU  

• Updating an Interface Module IM xxx  

• Updating a CP xxx  

• Working with GSD Files  
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1.3.2 How to Make Adjustments after a Hardware Change 

Basic Procedure 
A change to the hardware always requires a change to the software. You configure 
the modified hardware in HW Config, after which you then compile and download 
the changes to the CPU. You can then physically replace, remove or add the 
modified hardware. 

Procedure 
1. In HW Config, open the project (AS). 

2. Drag the object (for example, CPU: Type, Firmware Version x.x) from the 
hardware catalog to the corresponding slot in the configuration table of the AS.  
The following message appears: "Do you want to replace component ...with 
component ...?" 

3. After verification, click "Yes" to confirm. 

4. Select the menu command Station > Save/Compile. 
The compile operation can also be performed during the concluding steps. 



Safeguarding Availability 

 Process Control System PCS 7 V7.0 - Service Support and Diagnostics 
1-30 A5E00783462-01 

1.3.3 Updating the CPU 

1.3.3.1 Updating a SIMATIC S7 CPU 

Preparation 
Compare the type and revision of the deployed CPU modules to the documentation 
Process Control System PCS 7; Released PCS 7 Modules. 

If replacement of the CPU is required, contact your Siemens representative. 

Firmware Update for H-CPUs 
 

 Note 
A uniform hardware version and the same revision must always be ensured for the 
H-CPUs of a fault-tolerant PCS 7 system. 

It is necessary to place both H-CPUs in STOP mode for a firmware update. 

 

Update-capability of CPUs 
You perform the firmware update using an S7 memory card. This is referred to 
simply as a memory card in the following. 

 
Component Updating CPU S7-400 Updating CPU S7-400H

PC with external EPROM burner or programming 
device for programming the memory card 

X X 

2 MB S7 Memory card - Order No. 6ES7 952- 
1KL00-0AA0 

X - 

4 MB S7 Memory card - Order No. 6ES7 952- 
1KM00- 0AA0 

X X 

STEP 7 X X 
Files for the firmware update (available on the 
Internet).  

X X 
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1.3.3.2 How to Perform a Firmware Update of the CPU 

Notes about the Firmware Update 
The procedures for firmware updates is described below using the CPU 416-2 
(6ES7 416-2XK02-0AB0) as an example. 

Preparation 
Compare the type and revision of the deployed CPU modules to the documentation 
Process Control System PCS 7; Released PCS 7 Modules. 

If replacement of the CPU is required, contact your Siemens representative. 

Requirements 
The following requirements must be met for the update: 

• STEP 7 V5.3 or later is installed on the programming device or PC. 

• The update file for the firmware update is available on the programming 
device/PC. 

Loading the Memory Card for Updating the CPU Firmware 
1. Clear the memory card by selecting the menu command File > S7 Memory 

card > Delete. 

2. In SIMATIC Manager, select the menu command PLC > Update Operating 
System > Set Destination Directory. 

3. Set the destination directory. 

4. Select the file CPU_HD.UPD. 

5. Click "Open".  
This starts programming the memory card (downloading the firmware). 
Upon completion, the "Operating System Update" message dialog box 
indicates that the download of the firmware on the memory card has been 
executed. 

6. Click "OK". 
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Performing the CPU Firmware Update 
 

 Notice 
With the next steps, all data on your CPU are deleted and cannot be recovered!  

Do not cancel a download operation once it is started. If the download operation 
aborts, you can repeat it. If defects occur as a result of the abort, send the CPU in 
for repair. 

 

1. Switch off the power supply (PS) of the rack where the CPU is inserted.  

2. Insert the prepared memory card into the CPU. 

3. Switch on the power supply of the rack. 
The firmware is transferred from the memory card to the internal CPU FLASH 
EPROM.  
During the transfer, all display LEDs on the CPU are illuminated (INTF, EXTF, 
FRCE, CRST, RUN, STOP). 
After approximately 2 minutes, a slowly flashing STOP LED (=> request for 
general reset on the system side) signals completion of the CPU firmware 
update.  

 
 Notice 

Following the CPU update, an H-CPU starts a self test, which can last several 
minutes depending on the memory configuration. 

 

4. Switch off the power supply of the rack.  

5. Remove the memory card that was used for the CPU update and insert the 
memory card intended for CPU operation into the CPU, if one is provided. 

6. Switch on the power supply of the rack. 
The CPU automatically performs a memory reset and is then ready for 
operation. 
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1.3.4 Updating an Interface Module 

1.3.4.1 Updating an Interface Module (IM) 

Introduction 
The interface modules (IM) are the interfaces to the PROFIBUS DP in PCS 7. 

Preparation 
• Compare the type and version of the deployed interface modules to the 

documentation PCS 7 - Released Modules. 

• If replacement of the interface module is required, contact your Siemens 
representative. 

• A firmware update is possible for some interface modules. You will find the 
procedure to be followed below, in the section "How to Perform a Firmware 
Update of an IM".  

Update-capability of Interface Modules or Interface Modules after Couplers 
You can update the firmware of the following components (interface modules or 
interface modules after couplers) update:  

 
Components Order Number As of firmware version 

IM 153-2 6ES7 153–2Bx00–0XB0 and higher  
IM 152-1 6ES7 152-1AA00-0AB0 V2.02 
Y Coupler 6ES7 197–1LB00–0XA0  
Y Link 6ES7 197–1LA01–0XA0  
DP/PA Link 6ES7 157–0AA82–0XA0 V4.x 

 

Firmware Update for SIMATIC Stations with Redundant Interface Modules 
 

 Note 
For SIMATIC 400H stations with redundant interface module, you can update the 
firmware of the interface modules in runtime. 
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1.3.4.2 How to Perform a Firmware Update for an Interface Module (IM) 

Introduction 
This section describes the firmware update for interface modules (IM) via Industrial 
Ethernet.  

Requirements 
The following is required to perform the update via Industrial Ethernet: 

• STEP 7 V5.3 or later is installed on the programming device or PC. 

• The update file for the firmware update is available on the programming 
device/PC. 

• The CP 443-1 is routing-capable (in HW Config check: Properties of the 
CP > description entry "Routing" is present). 

• The files containing the current (new) version of the firmware is available in the 
file system of your programming device or PC. 

• The IM is integrated in the PCS 7 project. 

Procedure 
1. Open SIMATIC Manager. 

2. In the Component view, select the SIMATIC station in which the IM is located. 

3. Double-click the "Hardware" object in the detail window. 
HW Config opens. 

4. Select the IM whose firmware you want to update.  

5. Select the menu command PLC > Update Firmware. 
The "Update Firmware" dialog box opens. 

6. Make the following settings: 

 
Setting Action 

Location of  
firmware file 

1. In the "Firmware File" group, specify the folder where you 
placed the file for the firmware update. If you want to search, 
you can use "Browse" to open Explorer. 

Activation of "new" 
firmware 

2. Use the "Activate firmware after download" check box to 
specify when the "new" firmware is to be activated as follows: 
- Select the "Activate firmware after download" check box if 

you want the IM to automatically reset after successfully 
downloading the new firmware. The new firmware is active 
following the restart. 

- Clear the "Activate firmware after download" check box if 
you do not want the IM to reset after downloading the new 
firmware. The "new" firmware becomes active only after 
the power supply has been switched off. 

 

7. Click "Execute". The firmware is updated. 
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Firmware Update in the Redundant System 
After the firmware update of the active IM, the "RESET" automatically triggers the 
switchover of the two IMs.  

You can now update the second IM in the redundant system. Each IM must be 
updated separately.  

Updating the Identifier 
 

 Note 
After the firmware update of the IM has been successfully completed, update the 
identifier of the firmware version. You can find information about this in the section 
"Updating the Hardware ". 
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1.3.5 Updating a CP xxx 

1.3.5.1 Updating a Communication Processor (CP) 

Introduction 
In PCS 7, communication modules (CPs) are used to connect a SIMATIC station to 
bus systems. By updating the firmware, you can enhance the CP properties without 
replacing the hardware. 

Update Capability of CPs 
The specific properties of a module are retained when there is a firmware update. 
The CP type is not changed by a firmware update. 

 
CP type Update capability  Order number 

CP 341 Can be updated in all versions  
CP 443-1 Can be updated in all versions  
CP 443-5 Extended Can be updated in all versions  

 

Overview 
The sections below describe procedures for updating firmware:  

• CP 341 Firmware Update  

• CP 443-1 Firmware Update 

• CP 443-5 Extended Firmware Update  
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1.3.5.2 How to Perform a Firmware Update of the CP 341 

Introduction 
This section describes how to update the firmware for CP341.  

Preparations 
• Compare the type and version of the modules you are using with the 

information in the document PCS 7 - Released Modules. 

• If you need to replace the CP, contact your Siemens representative. 

Requirements for the Firmware Update 
• STEP 7 V5.3 or later is installed on the programming device or PC. 

• The update file for the firmware update is available on the programming 
device/PC. 

• The software package "Configuration package for point to point 
communication" V5.0 or later is installed (supplied with the CP). 

• The valid parameter assignment is stored in HW Config and has been 
downloaded to the CPU. 

Procedure 
1. Open SIMATIC Manager. 

2. In the Component view, select the SIMATIC station in which the CP 341 is 
located. 

3. Double-click the "Hardware" object in the detail window. 
HW Config opens. 

4. Double-click on the CP whose firmware you wish to update. 
The "Properties" dialog box for the CP opens. 

5. Open the "General" tab. 

6. Click "Parameters ...". 
The dialog box for the parameter assignment interface opens. 

7. Select the menu command Options > Firmware Update ... 

- If the CP is available, the firmware version of the current module firmware 
is indicated (Vx.y.z). 

- If there is no firmware on the CP, a message to that effect is displayed. 
This can occur, for example, if the firmware update was aborted. The old 
firmware is deleted in this case. You must download a firmware. 
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8. In the "Firmware File" group, specify the folder where you placed the file for the 
firmware update. If you want to search, you can use "Browse" to open 
Explorer. 
The version of the selected firmware is displayed under "Selected FW 
Version". 

9. Switch the CPU to STOP. 

10. Click "Download Firmware" to start the download procedure for the CP.  

11. Click "Download Firmware" to confirm the download procedure.  
If you click "Cancel", the download is aborted. The module will not be 
operational if this happens.  
Restart the firmware download to make the module operational again.  

 
 
 

Note 
Before deleting the older firmware, the CP checks if the order number of the 
firmware to be downloaded is permitted. 

 

Result 
The new firmware is saved in the operating system memory of the CP. The 
progress of the installation is indicated by a progress bar and a percentage under 
"Done". Once the firmware update is complete, the module is ready for immediate 
operation. 
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1.3.5.3 How to Perform a Firmware Update of the CP 443-1 

Preparation 
• Compare the type and version of the modules you are using with the 

information in the document PCS 7 - Released Modules. 

• If you need to replace the CP, contact your Siemens representative. 

Requirements for the Firmware Update 
• STEP 7 V5.3 or later is installed on the programming device or PC. 

• The update file for the firmware update is available on the programming 
device/PC. 

• Ethernet card (CP 1613, 3COM network adapter, for example) 

Determining the MAC Address of the CP 443-1 
When updating firmware, you must know the current MAC address of the 
CP 443-1. 

1. Open SIMATIC Manager. 

2. In the Component view, select the CP 443-1 for which the firmware is to be 
updated from below the SIMATIC station. 

3. Select the menu command CPU > Diagnostics/Settings > Module 
Information. 

4. Click "Special Diagnostics".  
 The NCM S7 diagnostics tool opens.  

 
 Note 

If the NCM S7 diagnostics do not start, the connection between the programming 
device/PC and the CP 443-1 is faulty. Correct the fault. 

 

5. Note the MAC address setting of the CP 443-1 under "Industrial Ethernet". 
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Performing the Firmware Update 
 

 Notice 
• A warning message appears before the download operation begins if an 

incorrect CP type has been inadvertently addressed. The firmware can 
nevertheless be downloaded to an incorrect CP type if the message is 
acknowledged.  

• With the next steps, all data on your CP are deleted and cannot be recovered! 

• Do not cancel a download operation once it is started. The CP may no longer 
be usable if you do this and you will have to send it in for repair. 

 

1. Select the menu command Start > SIMATIC > STEP 7 > NCM S7 Industrial 
Ethernet > Firmware Loader. 
The Firmware Loader dialog box opens. 

2. Click "Next".  

3. In the dialog box "Step 1set the path for the update file:  

- Click "Browse". 

- Use "Select file" to select the desired file ("<drive>:\TEMP\Cp4435ba.fwl", 
for example). 

- Click "Open". 

4. Click "Next". 

5. In the dialog box "Step 2", set the MAC address. 

6. Click "Next". 

7. Check the following settings: 

- "Application access point"  

- "Interface parameter assignment used" 

8. Make sure that the correct settings have been activated in the configuration 
console. 

 
 Note 

The access point must be set to "S7ONLINE CP xxxx(ISO)". 

 

9. Activate the firmware update by clicking "Download".  
The update operation takes approximately 1 minute. 
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Procedure when a download error occurs 
If the download operation was terminated by an error, no LED is lit on the CP. 

1. Switch the power supply of the rack off and on again. 

2. Repeat the load operation.  

If the CP responds to the download start, but the download operation does not 
finish properly, it could be that: 

• The same address has been assigned more than once on the plant bus.  

• The load on the plant bus is too high.  

 
 Note 

If a CP does not respond to a load procedure via the configured MAC address, 
load the CP again via the imprinted address. 
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1.3.5.4 How to Perform a Firmware Update of the CP 443-5 Extended 

Preparation 
• Compare the type and version of the modules you are using with the 

information in the document PCS 7 - Released Modules. 

• If you need to replace the CP, contact your Siemens representative. 

Requirements for the Firmware Update 
• STEP 7 V5.3 or later is installed on the programming device or PC. 

• The update file for the firmware update is available on the programming 
device/PC. 

• MPI cable 

 
 Note 

Ensure the following for the firmware update of the CP 443-5 Extended: 

• If you wish to connect devices that work with the PROFIBUS DPV1 standard to 
your PCS 7 plant following the update, you must replace the hardware (new 
type of CP type: 6GK7 443-5DX03-0XE0 with firmware version V5.1) 

• This hardware requires special device drivers.  
You can find information about the device drivers in the manual Process 
Control System SIMATIC PCS 7; Programming Instructions - Creating Blocks 
for PCS 7. 

 

Preparing for the Firmware Update 
1. Make sure that the update files required for the firmware update are available 

on the programming device or PC.  
Files for the firmware update are available on the Internet. You can find 
information on this in the section "Hardware Updates". 

2. Switch off the power supply (PS) of the rack where the CP is inserted. 

3. Use an MPI cable to establish a direct connection between the MPI interface of 
your programming device or PC and the PROFIBUS interface of the CP. 

4. Switch on the power supply of the rack and the programming device or PC.  
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5. Select the menu command Start > Settings > Control Panel > Set PG/PC 
Interface.  
You use this to establish the access path to the CP 443-5 Extended.  
Example: Make the following settings for the CP 5611 (FOC):· 

- Select "FWL_LOAD" as the "Application access point" to the CP 443-5 
Extended. 

- Select the MPI interface with the supplement "(FWL)" as the interface.  

6. Click "OK". 

7. Make sure there are no active applications on your programming device.  

8. Restart the interface. 

Performing the Firmware Update 
 

 Notice 
• With the next steps, all data on your CP are deleted and cannot be recovered! 

• Do not cancel a download operation once it is started. The CP may no longer 
be usable if you do this and you will have to send it in for repair. 

 

1. Select the menu command Start > SIMATIC > STEP 7 > NCM S7 > Firmware 
Loader. 
The Firmware Loader dialog box opens. 

2. Click "Next".  

3. In the dialog box "Step 1 set the path for the update file:  

- Click "Browse". 

- Use "Select file" to select the desired file ("<drive>:\TEMP\Cp4435ex.fwl", 
for example). 

- Click "Open". 

4. Confirm the next three dialog boxes that appear with "Next" unit you reach 
"Step 4: Perform Download".  
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5. Follow the instructions given in the dialog box "Step 4: Perform Download". 
In the table below you will find the download operation states that are 
displayed. 

 
Where Display State 

On the PG/PC in the 
Firmware Loader dialog box 

The bar in the dialog box 
changes.  

Download procedure is 
running. 

On the PG/PC in the 
Firmware Loader dialog box 

The message "Download 
completed successfully" is 
displayed. 

Download procedure is 
complete. 

CP 443-5 Extended The CP RUN LED flashes. Download procedure is 
running. 

CP 443-5 Extended The CP STOP LED is lit. Download procedure is 
complete. 

 

6. Switch off the power supply of the rack. 

7. Click "Cancel" to close the dialog box. 

8. Reestablish the original PROFIBUS connection. 

9. Switch on the power supply of the rack. 
The CP conducts a self-test and is then ready for operation. 

Procedure when a download error occurs 
If the download operation was terminated by an error, no LED is lit on the CP. 

1. Switch the power supply of the rack off and on again. 

2. Repeat the load operation. 
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1.3.6 Working with GSD Files 

Introduction 
STEP 7 Version 5 carefully checks GSD files. Syntax errors or non-interpretable 
errors can occur with GSD files from an older project, however.  

Improved help texts are provided for syntax errors and GSD problems starting with 
STEP 7 Version 5.1 SP2.  

If the following measures are not successful, contact the device manufacturer and 
request a new GSD file. You can find solutions for some errors in this table: 

Troubleshooting 
 

When Error 
Occurs 

Error message Source of Error  Remedy 

During insert 
operation 

In the 
'SIMATIC 400(1)’ 
station, the 
transmission rate 
of '187 5 Kbps' is 
not supported by 
the 'MBK-P' 
station. 

The entry 
'187.5_supp = 1' is 
not present. 

1. Contact the device manufacturer. 

Install a new 
GSD  

The path\file 
name of the GSD 
file contains a 
syntax error. 
File cannot be 
interpreted. 

Vendor_Name: The 
number of 
characters between 
the quotation marks 
must not exceed 32; 
special characters 
are not allowed. 

1. Create a backup copy of the file and open it 
with a text editor (such as WordPad) 

2. Check Vendor_Name. 

3. Make corrections to the name, save the file 
and link it again. 

Determine 
the names of 
the GSD files 
and the path: 
via the object 
properties of 
the DP slave 

In the 
'SIMATIC 400(1)' 
station, the 
transmission rate 
of '187.5 Kbits/s' 
is not supported 
by the "MBK-P' 
station. 

The decimal 
separator in the 
transmission rate 
must be a period 
and not a comma. 

1. Create a copy of the file. 

2. Open the original file with a text editor (such 
as WordPad). In transmission rate, change 
'187,5_supp = 1' to '187.5_supp = 1'). 

3. Start HW Config by selecting the menu 
command Options Update Catalog. 

Note: If the entry '187,5_supp = 1' is not present, 
the transmission rate is not supported. Contact 
the device manufacturer. 
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1.4 Software Update 

1.4.1 Software Updates 

Information 
• You can find information on updates for the PCS 7 software in the manuals 

Process Control System PCS 7; Software Update. 

• You can find information about updating redundant operator stations in runtime 
in the manual Process Control System PCS 7; Fault-tolerant Process Control 
Systems, under the section " Guidelines for Updating a Redundant OS in 
Runtime". 
You can find a brief overview of this topic in this documentation in the section 
"Updating the PCS 7 OS in Runtime". 

• Information on installing hot fixes are included in the respective software 
package with the hot fix. 

Note about Software Updates 
 

 Note 
Note that you must use the appropriate hardware in order to take advantage of 
features in new software versions. 

You can find information on the minimum requirements for PC stations in PCS 7 in 
the manual Process Control System PCS 7; PC Configuration and Authorization. 
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1.5 Updating the PCS 7 OS During Running Operation 

1.5.1 Updating the PCS 7 OS in Runtime 

Introduction 
If you configure a PCS 7 OS with redundance, you can update the PCS 7 OS in 
runtime, which allows you to adapt your existing Process Control System PCS 7 
from an "older" version to a "newer" PCS 7 version). 

Updating the PCS 7 OS involves the following tasks: 

• Preparatory measures 

• Installation of the "new" software 

• Commissioning measures required to adapt you existing PCS 7 process 
control system  

Updating the PCS 7 OS in runtime offers the following benefits:  

• Operation of the PCS 7 system is not disrupted. 

• The AS does not enter STOP mode. 

• The automation process can still be operator controlled and monitored. 

Guide to Updating the PCS 7 OS in Runtime  
You can find a guide to updating a redundant OS in runtime in the documentation 
below. 

 
Scenario Information can be found 

in ... 
Section ... 

Updating the PCS 7 
OS in runtime 
(updating the 
software, for 
example)  
Requirement: 
redundant OS 

Configuration manual 
Process Control System 
PCS 7; Fault-tolerant 
Systems 

Guide to Updating the PCS 7 OS in 
Runtime: 
• Phase 1: Updating the standby 

server 
• Phase 2: Updating OS clients 

connected to the standby server 
• Phase 3: Downloading 

connections, gateways and 
changes to the AS 

• Phase 4: Updating OS clients 
connected to the master server 

• Phase 5: Updating the master 
server 
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2 Checking Diagnostics Requirements 

2.1 Requirements for Diagnostics 

Requirements 
Several requirements must be fulfilled to ensure that the status of a PCS 7 system 
can be diagnosed effectively. The most important requirements are:  

• Diagnostics are enabled for the components. 

• Diagnostic options were activated during configuration 

Information on Configuring the Diagnostic Options 
The primary configurations can be found in the following documentation: 

• Configuration manual Process Control System PCS 7; Engineering System 

• Configuration manual Process Control System PCS 7; Operator Station 

You can search for information in the index of these manuals by entering 
"Diagnostics ..." as a key word. 

Checking PC Components 
• You can check PC components using software resources of PCS 7 (for 

example, maintenance station or PC DiagMonitor) and the operating system.  

• The following configuration actions assist you in diagnosing PC components: 

 
Configured Element Reference 

Lifebeat monitoring Configuration manual  
Process Control System PCS 7; Operator Station 

Diagnostic screens for PC 
diagnostics 

Configuration manual  
Process Control System PCS 7; Operator Station 

WinCC "System Info" channel Online help for WinCC Information System, 
"Communication > System Info" 

Diagnostics for systems with 
redundant OS PCs 

Configuration manual  
Process Control System PCS 7; Operator Station 

 



Checking Diagnostics Requirements 

 Process Control System PCS 7 V7.0 - Service Support and Diagnostics 
2-2 A5E00783462-01 

Checking Module Properties 
1. Open the project in SIMATIC Manager.  

2. In the Component view, select the SIMATIC station. 

3. Double-click the "Hardware" object in the detail window. 
HW Config opens. 

4. Double-click the module you wish to check.  
The properties dialog box for the selected module opens. 

5. Browse the individual tabs for appropriate options.  
Select the diagnostic properties depending on the module type. 
Available diagnostic options can be found in the following tabs: 

- "Diagnostics" 

- "Inputs" 

- "Outputs" 

- "Options" 

SIMATIC Modules with Diagnostic Properties 
Diagnostic-capable modules are available for the following components in PCS 7: 

• S7-400 

• S7 300 modules 

• ET 200M 

• ET 200S 

• ET 200iSP 

• DP slaves 

• DP/AS-i link 

• Diagnostic repeaters 

• Network components (SCALANCE; OSM, ESM) 

Additional information 
• Configuration manual Process Control System PCS 7; Operator Station 

• Online help PC DiagMon 
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3 Message Concept of PCS 7 

3.1 Servicing a System - Message Concept 

Introduction 
The message system and diagnostic options of PCS 7 help you to assess the 
system status. You can find information about the PCS 7 message concept in the 
following sections: 

• PCS 7 Message System 

• Origin of a Message  

• Determining the Source of a Message 

• Evaluating and Understanding Messages  

Basic Terms 
Some basic terms used in the PCS 7 message concept are defined in the 
following:  

 
Term Definition 

Events Events cause a change in the data status to occur in the automation system. For example, 
an event can be the following: A bit is modified in an automation system by a change to a 
process value or by attaining a specified limit value. The configuration determines which 
events trigger a message. 

Messages Messages are triggered by events or by a message frame. PCS 7 has the following 
message types:  
• Operating messages 
• Process messages 
• Event messages 
• Process control messages and system messages 

Error and 
Fault 

In PCS 7, the PCS 7 Operator Station operator control and monitoring system is also used 
to display errors and faults in the process. 
• Error: State of components (objects) that does not cause a fault to occur in the process 

(for example, defective display lights) 
• Fault: A state of components (objects) that inhibits the process (for example, a 

defective motor). 

 



Message Concept of PCS 7 

 Process Control System PCS 7 V7.0 - Service Support and Diagnostics 
3-2 A5E00783462-01 

Additional Information  
You can find Detailed information about the message system as follows: 

• In the WinCC Information System: 
Select the menu command Start > SIMATIC > WinCC > WinCC Information 
System, and look under "System Overview > How WinCC Works >  

- Message system of a PCS 7 OS 

- Archive system of a PCS 7 OS 

- Reports system of a PCS 7 OS 

• in the configuration manual Process Control System PCS 7; Operator Station, 
in the section "Settings for the Alarm System" 

• In the Online help for SIMATIC BATCH, you will find the following information 
under "Batch Data Management": 

- Batch reports  

- Archiving batches  

• In the SIMATIC Route Control online help, you will find the following 
information under "Operator Control and Monitoring": 

- Route log 
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3.2 PCS 7 Message System 

Message Systems of PCS 7 
PCS 7 acquires data on the status of your process and process control system 
using blocks assigned with appropriate parameters. You can influence the 
response to an event with a suitable program.  

The most important message systems of PCS 7 are: 

• WinCC operator control and monitoring system  

• SIMATIC BATCH batch data management 

Both message system are available on the PCS 7 OS in process mode (runtime). 

Configuration of Messages in the Message Lists of PCS 7 OS 
Every process message displayed on a PCS 7 OS always includes the following 
information: 

• Date 

• Time of day 

• Origin 

• Event 

• Message class  

You can achieve the following when configuring messages: 

• Specify the status used to report an event 

• Use the "Alarm Logging" editor on the PCS 7 OS to modify the selection of 
message information to be displayed in WinCC 

Message Accuracy for Signal Transitions 
 

 Note 
Be aware of the accuracy of the message system. 

If events are recorded within one scan cycle, they can appear in the wrong order in 
the message list. 

Remedy: You can find information about this in the function manual Process 
Control System PCS 7; High-precision Time Stamping. 
 

Additional information 
You can find Detailed information on configuring messages in the following 
manuals: 

• Configuration manual Process Control System PCS 7; Engineering System 

• Configuration manual Process Control System PCS 7; Operator Station 
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3.3 Origin of a Message 

Message Path 
Messages can originate in different locations in PCS 7 depending on the 
configuration. Each message is given a time stamp. The event which causes a time 
stamp to be assigned to a message depends on the place where the message has 
originated. Irrespective of where they originate, all messages are handled in the 
same way regarding how they are displayed and archived on the PCS 7 OS. 

  

Additional information 
You can find information on configuring messages in the following documentation: 

• Configuration manual Process Control System PCS 7; Engineering System 

• Configuration manual Process Control System PCS 7; Operator Station 

You can find information about configuring messages with time stamping with 
increased precision the function manual Process Control System PCS 7; 
High-precision Time Stamping. 
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3.4 How to Determine the Source of a Message 

Procedure 

1. Enable the message list by clicking "Activate/Deactivate Autoscroll" .  

2. In the message list, select the message for which you need additional 
information. 

3. Click "Open Infotext" . 

4. Note the message number and use "Alarm Logging" to determine the source of 
the message.  
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3.5 Understanding Messages 

3.5.1 Introduction 

Overview 
You can find important information for understanding the PCS 7 message concept 
in the following sections: 

• Message Types in Message Lists and Archives  

• Target Groups of Messages  

• Message Lists in Process Mode  

• Overflow of Message Buffer  

• Message Priorities  

• Influencing Messages  

3.5.2 Message Types in Message Lists and Archives 

Message Types in Message Lists and Archives  
There are three classes of message:  

 
Term Definition 

Operating messages Operating messages are generated when an operator controls 
process variables, for example, changes the operating mode of a 
controller.  
• SIMATIC PCS 7 generates operating messages automatically if 

you use faceplates prepared from the libraries.  
• If you have configured faceplates according to the 

programming instructions Process Control System PCS 7; 
Creating Blocks for PCS, operating messages that comply with 
PCS 7 can also be used for custom blocks. 

Process messages Process messages signal process events that take place in the 
automated process, such as limit value violations and event 
messages. 
• Process messages are predefined for the blocks and therefore 

do not need to be configured. Message texts and message 
priority can be modified as needed in the object properties for 
the CFC blocks. These modifications can also be made 
centrally in the process object view or by means of 
import/export operations. 

• Event messages are a subgroup of process messages. They 
signal process values that can be used to evaluate a process-
related component, such as an operating hours counter. 
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Term Definition 

Process control 
messages 

Process control messages are generated when SIMATIC PCS 7 
detects and signals errors in components within its own system. 
Such errors range from failure of a component to a wire break 
message for a connected I/O signal. 
Process control messages are generated by the driver blocks in 
PCS 7 and do not need to be configured. 

 

System messages 
System messages are messages that are triggered by self-diagnostics of a device. 
System messages are usually included in the process control messages or process 
messages (operating messages). 
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3.5.3 Target Groups of Messages 

Target Groups 
 

Message Type Target group: 
Process 
management 

Target group: 
Operation 
management and 
recording 

Target group: 
System and 
maintenance 
specialists 

Operating messages X X X 
Process messages X X X 
Event messages X X X 
Process control 
messages 

 X X 

System messages   X 
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3.5.4 Message Lists in Process Mode 

Message Lists 
PCS 7 places incoming messages in message lists. You can locate a message in 
the various message lists according to the source of the event and the message 
status. 

The following messages lists are available by default. You can modify these 
standard message lists or create additional message lists. 

Default Message Lists 
 
List Contents 

Entered state 
list 

The entered state list contains unacknowledged messages. 

Acknowledged 
list 

The old list contains the acknowledged messages and the messages 
pending in the process. 

Exited state list The exited state list contains messages with "exited" status (special 
message property). 

Operating list The operating input list contains all operating messages. 
Example: The setpoint of a controller is set to 5 bars, the motor has been 
enabled. 

Process control 
list 

The process control list contains the process control messages. 
Example: Rack failure 

Journal list The journal list contains all messages (entered, acknowledged, and 
exited messages) 
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The following figure illustrates the path a message takes through the message lists. 
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3.5.5 Overflow of Message Buffer 

Overflow of Message Buffer 
Each component of the overall PCS 7 system can process only a limited number of 
messages. If more messages are generated in a component (for example, an AS) 
within a particular time frame than the component can process, some of these 
messages will be lost. If this occurs, the AS sets an overflow indicator, and the 
following event will be signaled in the PCS 7 OS:"NRMS7 message lost". 

 

 
 Note 

If events that trigger messages change status in very quick succession, this can 
trigger a message surge. The overview of the plant status can no longer be  
sufficiently ensured. 

 

Additional information 
You can prevent a message surge by activating the "Messaging Triggered by 
Acknowledgment" function. You can find information about the configuration in the 
configuration manual Process Control System PCS 7; Engineering System. 
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3.5.6 Message Priorities 

Changing Message Priorities 
In PCS 7, a priority can be assigned to each message. 0 is the lowest priority and 
16 the highest priority. When a signaling block is newly generated, its messages 
initially have the lowest priority (0).  

You can change the message priority in a variety of ways: 

• In the object properties for the block 

• In the process object view 

• Via an import operation 

Rules 
• Message priorities can only be specified if you defined the message number 

range as "Unique for Entire CPU". 

• In PCS 7 OS, the unacknowledged message with the highest priority is always 
displayed in the message row above the overview. If multiple messages have 
the same priority, the most recent message is displayed here.  

• You can filter the list according to priority. 

Additional information 
You can find information about configuring message priorities in the configuration 
manual Process Control System PCS 7; Operator Station. 
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3.5.7 Influencing Messages 

Options 
You have the following options for influencing messages in PCS 7: 

• Message suppression 

- You can suppress individual block messages with the CFC configuration. 

- In process mode, you can suppress individual messages directly in the 
faceplate using the "Suppress message" check box. 

• Locking and releasing messages for blocks and OS areas 
Locking (and releasing) messages for blocks and OS areas is used when the 
plant operator wants to lock all messages of an interrupt-capable block or OS 
area. 

• Hiding and displaying messages 
You hide messages to reduce the number of messages displayed in process 
mode. The messages are entered in the message archive list. The following 
variations are used to hide and display messages in PCS 7: 

- Manual hiding and displaying of messages in process mode  

- Automatic hiding and displaying of messages in process mode 

Additional information 
• Configuration manual Process Control System PCS 7; Operator Station 

• Configuration manual Process Control System PCS 7; Engineering System 

• Manual Process Control System PCS 7; PCS 7 OS Process Management 
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4 Failure - What Next? 

4.1 Activities in the Event of a Fault 

Basic Procedure in the Event of a Fault 
1. Evaluate the messages with regard to the following aspects: 

- Time 

- Sequence 

- Source 

2. Determine the location and area of the fault. 

 
 Note 

If the components you are using do not have diagnostics capability, only secondary 
faults are signaled. 

 

- Use diagnostic tools to analyze the fault. You can achieve the following 
with the diagnostic tools:  

You can find the cause of a fault. 

or 

You can verify the presumed cause of a fault.  

- You can find the following information in the section "Diagnostics for PCS 
7" for support:  
The diagnostic tools available for PCS 7  
Applications for the various diagnostic tools according to subsystem 

 
 Note 

Make use of skilled experts if you cannot find a solution to your problem based on 
available information. You can find information on this in the "Preface" of this 
documentation. 
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3. Determine the actions to be taken. 
In a running plant, check if a stop is necessary. 

 

Notice 
• The following actions should be carried out only under observance of 

applicable governmental and plant-specific regulations and only by qualified 
personnel: 

- Changes to the configuration 

- Replacement of and changes to components 

• Bear in mind that uncharacteristic situations can occur in the plant after 
activation. Make sure the activation of components and secondary systems is 
carefully directed. 

 

Examples of Causes 
 

Fault Possible Causes Initial Diagnostics 

CPU fault • Fault due to internal error 
• Fault due to external error 

CPU diagnostics 

CP fault • Fault due to internal error 
• Fault due to external error 

Module diagnostics > Special 
diagnostics > NCM S7 
diagnostics CP... > 
Information from: 
• "Module" folder 
• "Operating mode" folder 
• "Diagnostic buffer" folder 

I/O module 
fault 

• Fault due to SIMATIC station 
component  

• Fault due to external influences 
(such as a short circuit on the 
module terminals) 

Module diagnostics > Status 
information and, if available, 
diagnostic information  

PC 
component 
fault 

If the PC is running: 
• Fault due to events 
• Faulty connections 

If the PC is defective: 
• Repair/replace 
• Restore data 
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4.2 Preparing for Expert Support 

4.2.1 Information on Cause of Fault 

Introduction 
 

Topic Area Information 

Supporting 
service experts 

• What? Actions for making essential information available to experts for fault 
analysis. 

• When?: If expert support is needed in the event of a fault, you facilitate the work 
of the experts by providing them essential information on the plant or the faulty 
components. 

• How?: You can find information on this in this section. 

 

Overview 
You support the work of service experts by providing them with information: 

• Service experts need information about your plant and the faulty system in 
order to provide quick support.  
You can find information on this below, in the section "Plant Documentation". 

• Service experts need information from the diagnostic buffer of the CPU in order 
to analyze the cause of a CPU fault. 
You can find information on this below, in the section  
"How to Read the CPU Diagnostic Buffer". 

• A memory dump facilitates the analysis of the cause of the CPU fault. 
You can find information on this below, in the section  
"CPU Fault - Preparing Diagnostics". 

• Backing up the diagnostics files facilitates the analysis of the cause of an OS 
fault.  
You can find information on this below, in the section  
"How to Back Up the Diagnostic Data of the PCS 7 OS". 

• You can create the conditions required for remote diagnostics via 
"remote access". 
You can find information on this below, in the section  
"Remote Diagnostics of a PCS 7 System". 
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4.2.2 Plant Documentation 

Maintaining System Information 
Information on the components of your system is among the most important 
information needed for successful repair. 

You need this information in the following situations: 

• When you are planning maintenance 

• When you contact the hotline for assistance 

Continual maintenance of this information shortens downtimes in case of a fault. 
Therefore, always keep up-to-date lists (in a database or in a table, for example) 
containing the following data: 

• Plant 

• Unit 

• Location in plant 

• Component 

• Versions  

- Hardware 

- Firmware 

- Software 
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4.2.3 How to Read the CPU Diagnostic Buffer 

Formats for Saving Diagnostic Data 
You can make it easier for service engineers to perform initial diagnostics on a 
faulty CPU by saving and having ready the content of the diagnostic buffer in the 
following formats: 

• HEX format 

• TXT format 

Procedure 
1. Select the faulty CPU in the SIMATIC Manager. 

2. Select the menu command CPU > Diagnostics/Settings > Module 
Information. 
The "Module Information - Online" dialog opens. 

3. Select the "Stacks" tab and read the following system memory: 

- Block stack (B stack) 

- If the CPU is in "STOP": Interrupt stack (I stack)  

4. Provide these data to the service engineers. 
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4.2.4 CPU Fault - Preparing Diagnostics 

Introduction 
The following information is important for analyzing a CPU fault: 

• Information on the relevant CPU 

• Information or actions in the event of a fault 

Rules 
 

!  
Warning 
• Only trained service employees should be authorized to work on the process control 

system. 
• Always observe the plant-specific rules and government regulations when making 

changes to a system. 
• Observe the plant-specific boundary conditions and adjust the work accordingly.  
• Always bear in mind that changes in a system can impact other sections of the system.

 

Information on the Relevant CPU  
The following information is needed when a CPU fault occurs: 

• Order number  

• Firmware version 

• Hardware version  

If you can access the CPU from the engineering station, you can query this 
information via the module information. You can find information on this in the 
section "Module Information". 

 
 Note 

A constantly updated list of all module information facilitates troubleshooting in the 
event of a fault and reduces the time needed for correcting the fault. 

 

Information in the Event of a Fault 
The following information is needed if a fault occurs: 

• Operations and actions/event history leading to the fault 

• Status indicated by LED displays on the front of the CPU (such as RUN) 
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Only the RUN LED is Lit 
The SIMATIC station is functioning without errors. 

RUN LED and Additional Red LED is Lit 
Faults have occurred in the SIMATIC station. Use the diagnostic tools for analysis. 
You can find additional information in the section "Diagnostics for the CPU". 

STOP LED is Lit  
• If the STOP LED is lit, read the diagnostic buffer. You can find information 

about this procedure in the section "How to Read the CPU Diagnostic Buffer". 
Save the diagnostic buffer both as a HEX file and as a TXT file! 

• These data can be analyzed by trained service engineers. They contain 
information about the cause, for example: 

- I/O error 

- Synchronization error with an H-CPU 

• If the possibility exists that a hardware error in the I/O caused the CPU to 
switch to STOP mode, save the diagnostic buffer of the relevant module and 
the associated bus interface module (for example, CP 443-5). 

• Generate a memory dump.  

All LEDs Are Off or Are Flashing 
You recognize the "CPU defective" status by the following LED displays on the 
front of the CPU: 

• All LEDs are flashing. 

• All LEDs are off, even though the power supply is switched on. 

For additional support, contact your Siemens representative or Technical Support. 
Have the "information in the event of a fault" indicated above ready. 
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4.2.5 How to Back Up the Diagnostic Data of the PCS 7 OS 

Basic Procedure 
We recommend that you back up the diagnostic files for analysis of the cause of 
the OS fault by experts.  

1. Back up all diagnostic folders of WinCC 
(default: drive:\Siemens\WinCC\Diagnose). 

2. Provide this data to the service engineers. 

You can back up the data using the PKZIP software supplied on the  
PCS 7 Toolset DVD.  

Setting Up the PKZIP Software 
If you use the PKZIP software supplied on the PCS 7 Toolset DVD, the following 
settings need to be made. 

1. In Windows Explorer, select the path "Program Files > Pkware > Pkzipw4". 

2. Double-click the PKZIP compression program. 
PKZIP for Windows opens. 

3. Select the menu command Tools > Options. 
The "Options" dialog box opens. 

4. Select the "Compress" tab. 

5. Make the following settings: 

- In the "File Options" group: 
Select the "Include subfolders (recurse)" check box. 
In the "Save folder name" list, select "Relative path". 
In the "Update mode" list, select "Add & Update files". 

- In the "File Attributes" group: 
Select all check boxes. 

- In the "Folders" tab: 
Specify a default folder for your data backup. 

6. Click "OK" to confirm your settings. 
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Backing Up Diagnostic Data 

1. Close WinCC. 

2. In Windows Explorer, select the path "Program Files > Pkware > Pkzipw4". 

3. Double-click the PKZIP compression program. 
PKZIP for Windows opens. 

4. Select the menu command File > New. 
The "Save File As" dialog box opens. 

5. Set the parameters as follows: 

- In the "Save in" group: 
Enter the folder for the backup file. 

- In the "File name" group: 
Enter the name for the backup file (use unique names for backups such as 
"Plant_Date_BackupNo.". 

6. Click "Save" to confirm your settings. 
The dialog box "Add Files - (drive: folder for the backup file)" opens. 

7. Set the parameters as follows: 

- In the "Drives:" group: 
Enter the drive containing the diagnostic files. 

- In the "Directory:" group: 
Specify the folder where the diagnostic files are located (default: 
...\Siemens\WinCC\Diagnose). 

- Click "Add Directory". 
Information regarding the drive and folder of the diagnostic files is entered 
in the "Files & Directories To Zip." group. 

8. Click "OK" to confirm your settings. 
You can watch the progress of the backup in the "Add Status" dialog box. The 
backup is finished when "Done" appears in the message box. 

9. Click "Done". 
All archived files are shown in the PKZIP dialog box. 

10. Close PKZIP with the menu command File > Exit. 

 
 Note 

Once the diagnostic files are backed up (not in diagnostic folder), you can delete 
the content of the diagnostic folder. In this way, you avoid keeping old information 
in the new diagnostic files.  

If the same error occurs the next time you start WinCC, make an additional backup 
to help the experts. Only a few messages will need to be analyzed in this backup. 
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4.2.6 Remote Diagnostics of a PCS 7 System 

Remote Diagnostics Options 
We recommend the following options for the remote diagnostics of PCS 7 systems: 

• Remote desktop connection 

• Net meeting 

Remote Diagnostics and Remote Administration Option for a PCS 7 Plant 
To perform remote diagnostics for PCS 7 plants and enable administrative access 
to PC stations with Windows XP Professional and Windows Server 2003, we 
recommend you use "Netmeeting". 
You can find additional information on this in the operating system's online help. 

 

Transmission Methods 
Data can be transmitted with the following: 

• Telephone line (modem) 

• TCP/IP connection (network connection within the system) 

Security Requirements 
If you wish to perform remote diagnostics for a PCS 7 plant, you must protect this 
plant against unauthorized access.  

Several measures are needed to realize a security concept. A plant is optimally 
protected only by the total sum of all security measures.  

You can find additional information about this in the documentation 
Process Control System PCS 7; Security Concept PCS 7.  
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4.2.7 Interactive Operator Control and Monitoring with the 
PCS 7 OS Web Option 

Interactive Operator Control and Monitoring of a PCS 7 System Using 
PCS 7 OS Web Option 

Use the PCS 7 OS web option for the interactive operator control and monitoring of 
a PCS 7 system.  
You can find additional information about this in the manual Process Control 
System PCS 7; PCS 7 OS Web Option. 

The figure below shows how the PCS 7 OS web option (OS web server, web client) 
can be used in a PCS 7 system. 

  



Failure - What Next? 

 Process Control System PCS 7 V7.0 - Service Support and Diagnostics 
4-12 A5E00783462-01 

Transmission Methods 
Data can be transmitted with the following: 

• Telephone line (modem) 

• TCP/IP connection (network connection within the system) 

• Internet 

Security Requirements 
If you use the PCS 7 OS Web Option in a PCS 7 plant, you must protect this plant 
against unauthorized access.  

Several measures are needed to realize a security concept. A plant is optimally 
protected only by the total sum of all security measures.  

You can find additional information about this in the documentation 
Process Control System PCS 7; Security Concept PCS 7.  
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5 Diagnostics in PCS 7 

5.1 Diagnostic Capabilities in PCS 7 Subsystems 

Disclaimer of Liability 
 

!  
Warning 
Siemens assumes no responsibility for inappropriate use of the instructions 
provided in this documentation or any consequences that might result for the 
customer. 

 

!  
Warning 
• All work on the process control system must be performed by trained service 

personnel. 

• Always observe the plant-specific rules and government regulations when 
making changes to your system. 

• Observe the plant-specific boundary conditions and adjust the work 
accordingly.  

• Always bear in mind that changes in a system can impact other sections of the 
system. 

 

Introduction 
The message system and diagnostic tools of PCS 7 help you to assess the status 
of your system. You can find information about the diagnostic tools In the following 
sections. 

This description illustrates the capabilities of the diagnostic tools so that you can 
apply them to your individual requirements.  

• You will also find information on the fields of application for diagnostic tools.  

• You will learn you how to call up a diagnostic tool. 

• Since malfunctions can have a variety of causes and because procedures for 
using the diagnostic tools are already available in the online help, a detailed 
description is not provided here.  
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Assessing the Status of your Process Control System 
 

Topic Questions Answered 

Diagnostics in PCS 7 What diagnostics can be performed and where? 
Diagnostic tools • Which diagnostic procedures can be performed with a 

diagnostic tool? 
• How is the diagnostic tool activated? 
• Where can I find a description of the diagnostic tool or 

diagnostic capability? 

 

Diagnostics  
Diagnostics refers to all activities intended to: 

• Ascertain the status of a system 

• Find errors and faults as early as possible and identify their cause 

Diagnostic Message 

Diagnostic capabilities are used to analyze the system status and to determine the 
causes of faults. 

Overview of Diagnostic Tools 

You can find information on using diagnostic tools, grouped according to areas of 
application, in the following sections: 

• Full Diagnostics Using the Maintenance Station  

• Diagnostics for PC user settings 

• Diagnostics for PC Components  

• Diagnostics for Network Connections 

• Diagnostics during Configuration 

• Diagnostics for the CPU  

• Diagnostics for Modules  

• Diagnostics for PROFIBUS DP 

• Diagnostics for PROFIBUS PA  

• Diagnostics for the OS  

• Diagnostics for the BATCH Station  

• Diagnostics for the Route Control Station  

• Diagnostics for Time of Day  

For many components, you will find displays on the front panel indicating the status 
of the component and any errors. Analyzing these displays enables you to obtain 
information without intervening in the system. The additional product manuals you 
will need for this analysis can be found in the section "Diagnostics for Hardware 
Displays". 
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5.2 Full Diagnostics with the Maintenance Station 
(Asset Management) 

Introduction 
With PCS 7 V6.1 and higher, a PCS 7 system can be fully diagnosed with the help 
of the maintenance station. The maintenance station is an operator station that is 
specially configured and assigned parameters for use in diagnostic and 
maintenance functions.  

We particularly recommend the use of a maintenance station in medium and large 
PCS 7 systems. 

Maintenance Station 
With the maintenance station, PCS 7 enables you to call up information on the 
states of all PCS 7 components on diagnostics screens which are hierarchically 
structured. As part of this process, the data of a component are analyzed using the 
available online functions of the associated tools. You can access ES data from the 
diagnostics screens (can be controlled via access protection mechanisms). 

Screens for process-control diagnostics can be generated automatically for the 
entire PCS 7 system and made available on the maintenance station. The topmost 
level forms an overview screen for the entire system. 
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Diagnostic Options 
You will find information on the states of individual PCS 7 components with 
diagnostic capability on the maintenance station's special diagnostics screens. 

 
Area Diagnostics for ... 

Automation systems  • CPU  
• SIMATIC PCS 7 BOX 
• Distributed I/O, such as ET 200M, ET 200S,  

ET 200iSP, I/O modules 
• Field devices (HART, PROFIBUS PA, etc.) 
• Redundancy 

- Master/standby configuration 
- Status of redundant partners 

PC stations  • Operator stations  
• BATCH stations 
• Route Control stations 
• Archive servers 
• SIMATIC PCS 7 BOX 
• Industrial PCs 
• Standard PCs (also web client via IP address) 
• Redundancy of PCS 7 PC stations 

- Master/standby configuration 
- Status of redundant partners 

Ethernet components • Switches, e.g.: 
- SCALANCE X 
- OSM 
- ESM 

• Network objects (via profile file) 
- Bridges 
- Routers 

• Network components, which enable diagnostics using the 
"NIB II" profile (for example, printers and other SNMP-
capable devices) 

PROFIBUS components  • PROFIBUS DP 
- Interface modules (IM) 
- Coupler 
- Link modules 
- Diagnostic repeater 

• PROFIBUS PA 
- Interfaces 
- Coupler 
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Additional information 
• You can find a description of how to configure a maintenance station in the 

configuration manual Process Control System PCS 7; Operator Station. 

• You can find a description of how to use the maintenance station to process 
mode in the configuration manual Process Control System PCS 7; PCS 7 OS 
Process Management. 

• You can find information about configuring a plant with PCS 7 OS Web 
diagnostic server and PCS 7 Web diagnostic client in the manual 
Process Control System PCS 7; PCS 7 OS Web Option 

5.3 Diagnostics for PC User Settings 

Overview 
 

Diagnostics for Diagnostics tool Called with 

Defining users and 
setting access authorization to files 
and folders 
(Windows users and user groups) 

Windows User 
Management 

Start > Settings > Control Panel > 
Administrative Tools > Computer 
Management > System Tools > Local 
Users and Groups 

WinCC Users User Administrator Open WinCC Explorer by selecting the 
menu command Editors > User 
Administrator > Open 

PCS 7 users (user roles and rights 
in PCS 7 applications) 

 Start > SIMATIC > SIMATIC Logon > 
Configure SIMATIC Logon 

Shares Shares for Drives, Folders 
and Files 

Start > Settings > Control Panel > 
Administrative Tools > Computer 
Management > System Tools > 
Shared Folders > Shares 
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5.4 Diagnostics for PC Components 

Overview 
 

Diagnostics for Diagnostics tool Called with 

Status of PC stations, redundancy Maintenance Station The maintenance station is an operator 
station that is specially configured for use 
in diagnostics. 
The maintenance station has to be 
configured. 
Additional information in the manual 
Process Control System PCS 7; PCS 7 
OS Process Management 

PC configuration System Information From 
Windows  

Menu command Start > Run... > Enter 
"msinfo32" in the input window. 

Functions of drivers, logs, and 
services 

Managing the Operating 
System Event Display 

Start > Settings > Control Panel > 
Administrative Tools > Computer 
Management > System > Event Viewer 
Note: Blue symbols only = "everything 
OK" 

Function of standard network 
modules 

Set PC Station  Start > SIMATIC > SIMATIC NET > 
Settings > Set PC Station 
In the tree view, select PC Station > 
"Network Module" modules > 
Softnet IE. 
Click "Test". 

Online verification of operating 
capability of redundant OS 
components 

Redundancy State Control Picture must be configured and 
downloaded to the OS. 
Additional information in the 
configuration manual Process Control 
System PCS 7; Operator Station 

Networks and network 
connections 

 You can find information on this in the 
section "Diagnostics for Network 
Connections".  

Installed versions of the PCS 7 
software  

SIMATIC Manager  Start > SIMATIC >  
SIMATIC Manager 
Help > About >  
Click "Display". 

Security settings and patches MBSA Menu command Start > Run... > Enter 
"Mbscali.exe" in the input window. 

Printers and print jobs Printers and Print Jobs  Start > Settings > Printers and Faxes 
Click on the printer that should perform 
the printing for information about the print 
job. 

PCS 7 Bundle PCs PC DiagMonitor  PC DiagnMonitor is started automatically 
on bundle PCs when the PC boots. 
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5.5 Diagnostics for Network Connections 

Overview 
 

Diagnostics for Diagnostics tool Called with 

Connections with diagnostic 
capability 

Maintenance Station The maintenance station is an operator 
station that is specially configured for 
use in diagnostics. 
The maintenance station has to be 
configured. 
Additional information in the manual 
Process Control System PCS 7; PCS 7 
OS Process Management 

Network configuration NetPro  Network > Check Consistency 
Established connections to 
SIMATIC stations 

NetPro Select the CPU: PLC > Activate 
Connection Status 

Status of network adapters on 
Industrial Ethernet  

"Network Connections" 
Windows Dialog Box"  

Start > Settings > Network 
Connections 

Connection to other stations; IP 
address, MAC address 

Command Line Commands Start > Programs > Command 
Prompt  
Open DOS window - enter 'ping IP 
address' 

Determining MAC addresses and 
TCP/IP addresses 

Command Line Commands Start > Programs > Command 
Prompt  
Open DOS window:  
enter ipconfig –all 

Connection established to domain 
servers: 
DHCP, WINS, DNS 

Command Line Commands Start > Programs > Command 
Prompt  
Open DOS window:  
enter ipconfig –all 

PC station Set PC Station  Start > SIMATIC > SIMATIC NET > Set 
PC Station 

Status of network components, 
status of a WinCC application  

Station Configuration Editor Configuration with HW Config and 
loading of PC station required  
Call: in start bar via  
 

  
PC Ethernet modules NCM S7 Industrial Ethernet Start > SIMATIC > STEP 7 > NCM S7 

Industrial Ethernet > Diagnostics 
Status of configured channels and 
their connections to the SIMATIC 
station 

WinCC - Channel 
Diagnostics  

Start > Simatic > WinCC > Tools > 
Channel Diagnostics > 
"Channels/Connections" tab 

Connections to the OS: faulty or 
established 

Lifebeat Monitoring  Call picture (@CONFIG.PDL) in 
process mode. 
Picture must be configured and 
downloaded to the OS. 

Status of process interface  Status of Connections  In the WinCC Explorer: Options > 
Status of Connections 
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Diagnostics for Diagnostics tool Called with 

Client-server connections Status of Multi-user 
Operation  

In the WinCC Explorer: Options > 
Status of Multi-user Operation 

Determine stations  
Find IP address and MAC address 
Message frames 
Collisions 

BANY (Add-on Product)  If you have installed BANYnet, call the 
program with the menu command Start 
menu > Programs > BANYnet. 

PROFIBUS DP connections  You can find additional information in 
the section "Diagnostics for PROFIBUS 
DP".  

PROFIBUS PA connections  You can find additional information in 
the section "Diagnostics for PROFIBUS 
PA".  

Status of devices with SNMP 
capability (e.g., network switches) 

PC DiagMonitor  Start > SIMATIC > PC DiagMonitor > 
Management Station 
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5.6 Diagnostics during Configuration 

Overview 
 

Diagnostics for Diagnostics tool Note 

Consistency of hardware 
configuration  

HW Config  Menu command Station > Check 
Consistency 

Consistency of PC station 
configuration 

Station Configuration Editor Click the following icon in the task bar:  
 

  
Analyze "Status" column table entry 

Block consistency in a SIMATIC 
station 

SIMATIC Manager  Select SIMATIC Station > S7 Program > 
Blocks 
Menu command Edit > Check Block 
Consistency 

Chart consistency in a SIMATIC 
station 

SIMATIC Manager  Select SIMATIC Station > S7 Program > 
Charts 
Menu command Edit > Check 
Consistency 

Connection error Module Information  Select the SIMATIC station in SIMATIC 
Manager or  
the CPU in HW Config. 

Open signal interconnections in 
PCS 7 Operator Station  

PCS 7 operator station 
(WinCC) 

Convert pictures  

Connection functions for a PC 
station 

Set PC Station  Start > SIMATIC > SIMATIC NET > 
Settings > Set PC Station 
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5.7 Diagnostics for the CPU 

Overview 
 

Diagnostics for Diagnostics tool Called with 

CPU module information, 
redundancy, connections 

Maintenance Station The maintenance station is an operator 
station that is specially configured for use 
in diagnostics. 
The maintenance station has to be 
configured. 
Additional information in the manual 
Process Control System PCS 7; PCS 7 
OS Process Management 

CPU HW Config  Select the CPU: Menu command 
Station > Online 

CPU Module Information  Select the SIMATIC station in SIMATIC 
Manager or the CPU in HW Config. 

Module displays Evaluating the Module 
Display  

Notes on manuals: Diagnostics for 
Hardware Displays  

CPU fault - preparing diagnostics Only to support experts CPU Fault - Preparing Diagnostics  
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5.8 Diagnostics for Modules 

Overview 
 

Diagnostics for Diagnostics tool Called with 

Diagnostics for all diagnostics-
capable modules 

Maintenance Station The maintenance station is an operator 
station that is specially configured for 
use in diagnostics. 
The maintenance station has to be 
configured. 
Additional information in the manual 
Process Control System PCS 7;  
PCS 7 OS Process Management 

Modules and CPs with diagnostics 
capability 

HW Config Station > Open Online 

I/O modules and CPs with 
diagnostics capability 

Module Information Select the SIMATIC station in SIMATIC 
Manager or the CPU in HW Config.  

Module displays Evaluating the Module 
Display 

Notes on manuals: Diagnostics for 
Hardware Displays 
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5.9 Diagnostics for PROFIBUS DP 

Overview 
 

Diagnostics for Diagnostics tool Called with 

Devices and connections with 
diagnostic capability 

Maintenance Station The maintenance station is an operator 
station that is specially configured for use 
in diagnostics. 
The maintenance station has to be 
configured. 
Additional information in the manual 
Process Control System PCS 7; PCS 7 
OS Process Management 

Status of stations  NCM S7 PROFIBUS  Start > SIMATIC > STEP 7 > NCM S7 
PROFIBUS > Diagnostics 

Internal PROFIBUS DP interface 
of the CPU 

Module Information Diagnostics via HW Config > Module 
Information 

PROFIBUS DP error  PROFIBUS DP 
Diagnostics With 
Diagnostic Repeater  

Diagnostics via HW Config > Module 
Information 

Status of PROFIBUS nodes NetPro Start > SIMATIC > STEP 7 > NetPro 
Select the menu command View > With 
DP Slaves to display the DP slaves in 
the network view 

Station failure 
Fault indication with Detailed 
information about cause of error 
Name and comments from HW 
Config 
Order number, addresses, slot 
types 

SYSTEM Diagnostics for 
Process Control (Add-on 
Product)  

Picture must be configured and 
downloaded to the OS. 
Additional information in the 
configuration manual Process Control 
System PCS 7; Operator Station 

PROFIBUS error Amprolyzer (Add-on 
Product)  

If you have installed Amprolyzer, call the 
program with the menu command Start 
menu > Programs > Amprolyzer. 
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5.10 Diagnostics for PROFIBUS PA 

Overview 
 

Diagnostics for Diagnostics tool Called with 

Devices and connections with 
diagnostic capability 

Maintenance Station The maintenance station is an operator 
station that is specially configured for use 
in diagnostics. 
The maintenance station has to be 
configured. 
Additional information in the manual 
Process Control System PCS 7; PCS 7 
OS Process Management 

Devices and connections on the 
PROFIBUS PA with diagnostic 
capability 

SIMATIC PDM SIMATIC Manager: View > Process 
Device Network View 

Status of devices on the 
PROFIBUS PA with diagnostic 
capability 

NCM S7 PROFIBUS Start > SIMATIC > STEP 7 > NCM S7 
PROFIBUS > Diagnostics 

Station failure 
Fault indication with Detailed 
information about cause of error 
Name and comments from HW 
Config 
Order number, addresses, slot 
types 

SYSTEM Diagnostics for 
Process Control (Add-on 
Product) 

Picture must be configured and 
downloaded to the OS. 
Additional information in the 
configuration manual Process Control 
System PCS 7; Operator Station 

PROFIBUS error Amprolyzer (Add-on 
Product) 

If you have installed Amprolyzer, call the 
program with the menu command Start 
menu > Programs > Amprolyzer. 
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5.11 Diagnostics for the OS 

Overview 
 

Diagnostics for Diagnostics tool Called with 

Operating capability of all OS 
components and communication 
connections 

Maintenance Station The maintenance station is an operator 
station that is specially configured for use 
in diagnostics. 
The maintenance station has to be 
configured. 
Additional information in the manual 
Process Control System PCS 7;  
PCS 7 OS Process Management 

WinCC projects and the assigned 
SIMATIC stations 

Lifebeat Monitoring  Call picture (@CONFIG.PDL) in process 
mode. 
Picture must be configured and 
downloaded to the OS. 

Connections between OS 
components 

Simatic Shell  Windows Explorer (workstation):  
Select PC station > "Simatic Shell" folder 
> in the context menu Properties 

Connection between WinCC and 
AS 

Status of Connections  In WinCC: Options > Status of 
Connections 

Connection between OS server 
and OS client 

Status of Multi-user 
Operation  

In WinCC: Options > Status of Multi-
user Operation 

Status of channels and 
connections to the AS 

WinCC Channel 
Diagnostics  

Start > SIMATIC > WinCC > Tools > 
Channel Diagnostics 

Operating capability of redundant 
OS components 

Redundancy State Control Picture must be configured and 
downloaded to the OS. 
For more information, refer to the 
configuration manual Process Control 
System PCS 7 Operator Station 

General system information of an 
OS server 

WinCC "System Info" 
Channel  

Picture must be configured and 
downloaded to the OS. 
For more information, refer to the 
configuration manual Process Control 
System PCS 7 Operator Station 

OS fault - preparing diagnostics Only to support experts You can find information on this in the 
section "OS Fault - Preparing 
Diagnostics". 

Status OS Web Server  Internet Explorer: http://<server 
address>.status.html 
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5.12 Diagnostics for the BATCH Stations 

Overview 
 

Diagnostics for Diagnostics tool Called with 

Operating capability of all BATCH 
components and communication 
connections 

Maintenance Station The maintenance station is an operator 
station that is specially configured for use 
in diagnostics. 
The maintenance station has to be 
configured. 
Additional information in the manual 
Process Control System PCS 7; PCS 7 
OS Process Management 

Status of the BATCH server Status Symbols in the 
BATCH Server Task Bar  

Task Bar 

Status master Status Symbols in the 
BATCH Server Task Bar  

Task Bar 

Status of the standby server 
(partner server) 

Status Symbols in the 
BATCH Server Task Bar 

Task Bar 
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5.13 Diagnostics for the Route Control Stations 

Overview 
 

Diagnostics for Diagnostics tool Called with 

Operating capability of all SIMATIC 
Route Control components and 
communication connections 

Maintenance Station The maintenance station is an operator 
station that is specially configured for 
use in diagnostics. 
The maintenance station has to be 
configured. 
Additional information in the manual 
Process Control System PCS 7; PCS 7 
OS Process Management 

Status of redundant servers Status Symbols in the 
Route Control Server Task 
Bar  

Task Bar 

Established connections to 
SIMATIC stations 

NetPro NetPro: Online view > Select the CPU: 
PLC > Activate Connection Status 

 

5.14 Diagnostics for Time of Day 

Overview 
 

Diagnostics for Diagnostics tool Called with 

AS-CPU time SIMATIC Manager  Select the CPU: PLC > Set Time of Day
AS-CPU time Module Information Station > Open Online 

Select the CPU: PLC > Set Time of Day
PC time Managing the Operating 

System 
Start > Settings > Control Panel > 
Date/Time. Do not change these 
settings. 

Activated time services Windows System Utilities Start > Settings > Control Panel > 
Administrative Tools > Services 
Select the "Windows time transmitter": 
Action > Properties 
"General" tab > Startup type: ... 

Synchronization status on the 
terminal bus 

Set PG/PC Interface Start > SIMATIC > SIMATIC Net > Set 
PG/PC Interface 
Select interface > Click "Diagnostics" > In 
the "Time" group 

Configuration of time displayed in 
operator control and monitoring 
systems 

WinCC Editor "Time 
Synchronization" 

Open WinCC Explorer with the menu 
command Editors > Time 
Synchronization > Open 
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5.15 Diagnostics for Hardware Displays 

Overview 
Many components have displays indicating the component status and errors. 
Analyzing these displays enables you to obtain information without intervening in 
the system. 

 
Component  You can find information about diagnostic options in the following 

manuals and sections: 

Power supply module Reference manual SIMATIC;  
Automation System S7-400; Module Data 
• Backup battery (optional) 
• Error messages by means of LED displays  
• Operator control and display elements 

Central module for S7-
400 
CPU 

Reference manual SIMATIC;  
Automation System S7-400; CPU Data 
• Monitoring functions of the CPU 
• Status and error displays 
• Operating mode switch 

CP 441 Manual SIMATIC; 
CP 441 Point-to-Point Communication - Installation and Parameter Assignment 
• Diagnostics for CP 441 

CP 443-1 Device manual S7 CPs/Part B4;  
Description CP 443-1 
• Displays and operating mode switch 

CP 443-5 Extended Device manual S7 CPs/Part B4;  
Description CP 443-5 Extended 
• Displays and operating mode switch 

S7-300 I/O modules Reference manual SIMATIC; 
Automation System S7-300; Module Data 
• Diagnostic data for the signal modules 

S7-300 fail-safe signal 
modules 

Manual SIMATIC; 
Automation System S7-300; Fail-safe Signal Modules 
• Diagnostics of F-SM errors 
• Properties, front view, connection and block diagram 

S7-300  
ex I/O modules 

Manual SIMATIC; 
Programmable Controllers S7-300, ET 200M; 
Ex I/O Modules 
• Digital input module: Properties 
• Diagnostics for analog modules 
• Module view and block diagram 

ET 200M Manual SIMATIC; 
Distributed I/O Device ET 200M; Commissioning and Diagnostics 
• Diagnostics by means of LED display IM 153-1, IM 153-2 
• Diagnostics with STEP 7 



Diagnostics in PCS 7 

 Process Control System PCS 7 V7.0 - Service Support and Diagnostics 
5-18 A5E00783462-01 

Component  You can find information about diagnostic options in the following 
manuals and sections: 

ET 200iSP Manual SIMATIC; 
Distributed I/O Device ET 200iSP; Commissioning and Diagnostics  
• Status and error LEDs on IM 151-2 
• Insertion and removal of modules 
• Line break of the NAMUR encoder on the digital input module 
• Diagnostics with STEP 7 

ET 200S Manual SIMATIC; 
Distributed I/O Device ET 200S; Commissioning and Diagnostics  
• Diagnostics by means of LED displays 
• Diagnostic messages for electronic modules 

DP/PA couplers Manual SIMATIC;  
Bus Interfaces DP/PA Link and Y Link 
Diagnostics by means of LED displays 
• LED displays of the IM 157 
• LED displays of the DP/PA coupler 
• LED displays of the Y coupler 

AFD (used with 
PROFIBUS PA) 

Manual SIMATIC; 
SIMATIC NET; PROFIBUS PA 
• Diagnostics by means of LED displays 
• Diagnostic messages for electronic modules 

AFS (used with 
PROFIBUS PA) 

Manual SIMATIC; 
SIMATIC NET; PROFIBUS PA 
• Diagnostics by means of LED displays 
• Diagnostic messages for electronic modules 

Y Link Information under DP/PA Coupler 
Diagnostic repeater Manual SIMATIC;  

Diagnostic Repeater for PROFIBUS DP 
• LED diagnostics 

Switch for Ethernet Operating instructions SIMATIC NET; 
Industrial Ethernet switches SCALANCE X-400 
• LED  
Commissioning manual SIMATIC NET; Industrial Ethernet SCALANCE X-100 
and SCALANCE X-200 Product Line 
• SCALANCE X<…> displays (SCALANCE X208 displays, for example) 
Manual SIMATIC NET; Industrial Ethernet OSM/ESM 
• Display and control elements 
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5.16 Diagnostic Tools 

5.16.1 Diagnostics Tools of PCS 7 

Disclaimer of Liability 
 

!  
Warning 
Siemens assumes no responsibility for inappropriate use of the instructions 
provided in this documentation or any consequences that might result for the 
customer. 

 

!  
Warning 
• All work must be performed by trained service personnel. 

• Always observe the plant-specific rules and government regulations when 
making changes to your system. 

• Observe the plant-specific boundary conditions and adjust the work 
accordingly.  

• Always bear in mind that changes in a system can impact other sections of the 
system. 
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5.16.2 Diagnostics for the PCs 

5.16.2.1 System Information From Windows 

Calling 
Menu command Start > Run... > Enter "msinfo32" in the input window. 

Overview 
 

Topic Detailed information Called with Additional information 

PC configuration Operating system 
Operating system version 
PC NAME 
Processor 
BIOS data 
Users currently logged on 
Time zone 
Size of the work memory 
Information on the swap file 

System Overview Online help of the 
operating system 

Graphics 
settings  

Type of graphics card 
Set resolution and frequency 

System Overview > 
Components > Display 

Online help of the 
operating system 

Printers  Display of existing printers System Overview > 
Components > Printer 

Online help of the 
operating system 

Drives Recognized internal and external 
drives or storage media 
Partitioning of hard disks 

System Overview > 
Components > Storage 
> Drives 

Online help of the 
operating system 
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5.16.2.2 Managing the Operating System 

Calling 
Call this tool by selecting the menu command Start > Settings > Control Panel > 
Administrative Tools > Computer Management  

Overview 
 

Topic Detailed information Called with Additional information 

Event display Icons indicate status (specialist 
knowledge required for analysis) 

System Tools > Event 
Viewer 

Select folder,  
press "F1" key - blue 
icon only = "everything 
OK" 

Removable 
memory 

Recognized external drives or 
storage media 

Data Memory > 
Removable Media 

 

Hard disks Drive names, formats, size, 
segmentation, partitions, status 

Data Memory > Storage 
Media Management 

 

Network 
adapters and PC 
cards 

Network adapter type access 
levels, users, servers, network 
addresses (IP/MAC address) 

System Tools > System 
Information > 
Components > Network 
> Adapter 

 

Network-wide 
analysis of 
connected PCs 

Active users in network, 
active PCs 

System Tools > Shared 
Folders > Shares 

 

Management of 
users and user 
groups 

• Creation and modification of 
local user accounts  

• Creation and modification of 
user profiles  

• Creation, addition and 
deletion of local groups 

System Tools > Local 
Users and Groups 

Online help of the 
operating system 
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5.16.2.3 Shares for Drives, Folders and Files 

Calling 
Call this tool by selecting the menu command Start > Settings > Control Panel > 
Administrative Tools > Computer Management > System 

Overview 
 

Topic Detailed information Called with Additional information

Drives and 
folders 

Granting or changing of 
shares for drives and 
folders  

In the tree view 
Select Shared Folders > Share 

Select folder,  
press "F1" key 

Drives and 
folders 

Granting or changing of 
shares for drives and 
folders 

• Open Windows Explorer  
• In the tree view, select the 

drive/folder 
• Menu command: File > 

Properties > "Release" tab 

Online help of the 
operating system  

Files Granting or changing of 
shares for files 

• Select the file in Windows 
Explorer 

• Menu command: File > 
Properties 

• Select the "Security" tab 
and make the required 
settings in the "Permissions" 
group. 

Online help of the 
operating system  
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5.16.2.4 Local Users and Groups in the System 

Overview 
 

Topic Detailed information Called with Additional information

Managing users 
and groups in 
the operating 
system 

• Creation and modification of 
local user accounts  

• Creation and modification of 
user profiles  

• Creation, addition and 
deletion of local groups 

Start > Settings > 
Control Panel > 
Administrative Tools > 
Computer Management 
> System Tools > Local 
Users and Groups 

Online help of the 
operating system  

Application 
permissions 

• Standard users, language 
and password changes 

• Selection of the computer 
from which the user data are 
to be obtained 

• Selection of the device via 
which component logon is to 
be checked  

• Setting a delay time for 
logging off from SIMATIC 
Logon 

Start > SIMATIC > 
SIMATIC Logon > 
Configure SIMATIC 
Logon 

Online help for SIMATIC 
Logon 
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5.16.2.5 Command Line Commands 

Calling 
Menu command Start > Run... > Enter "cmd" in the input window.  

You can find additional information about the Windows commands used here using 
the search function in the Microsoft "Help and Support Center": Start > Help and 
Support 

Overview 
 

Topic Detailed information Called with Additional information

Connections 
Network adapter 
function 

Verification of own network 
adapter 

Enter "ping localhost" or  
"ping 127.0.0.0". 

Help and Support 
Center 

Connections/ 
Network adapter 
function 

Verification of a connection to 
another Ethernet node 

Enter "ping - {PC name}" or 
"ping -  {IP address}" 

Help and Support 
Center 

Connections/ 
Network adapter 
function 

Identification of own network 
adapter 

Enter "ipconfig" Help and Support 
Center 

Connections/ 
Network adapter 
function 

Identification of network 
adapter of servers and 
network services 

Enter "ipconfig -all" Help and Support 
Center 

Connections/ 
Network adapter 
function 

Active connections, 
computer I/Os, 
Ethernet statistics 

Enter "netstat". Help and Support 
Center 
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5.16.2.6 Set PC Station 

Calling 
Call this tool by selecting the menu command Start > SIMATIC > SIMATIC NET > 
Settings > Set PC Station 

Overview 
 

Topic Detailed information Called with Additional information 

Configuration Detected modules SIMATIC NET Configuration 
> Modules folder 

Online help Microsoft 
Management Console; "Set 
PC Station" topic 

Diagnostic 
options 

Available options vary 
for each module 

SIMATIC NET Configuration 
> Modules > folder, select 
module. 
You can find additional 
information in the online help 

Online help Microsoft 
Management Console; "Set 
PC Station" topic 

 

5.16.2.7 Set PG/PC Interface 

Calling 
Call this tool by selecting the menu command Start > SIMATIC > SIMATIC NET > 
Set PG/PC Interface or the menu command Options > Set PG/PC Interface in 
SIMATIC Manager. 

Overview 
 

Topic Detailed information Called with Additional information

Time 
synchronization 

Status of synchronization of 
PC on terminal bus 
(requirement: CP 1613) 

Select interface > Click 
"Diagnostics" > In the "Time" 
group 

Online help Microsoft 
Management Console; 
"Set PC Station" topic 
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5.16.2.8 Station Configuration Editor 

Calling 

Call on the Windows task bar with the button: . 

Requirement 
The components in the configuration list must be entered in the same order as in 
the component image you created with HW Config. If the configuration deviates, it 
cannot be downloaded to the PC station. You can find additional information about 
this in the manual Process Control System PCS 7; PC Configuration and 
Authorization, in the section "Preparing the PC Stations". 

 
 Notice 

Making changes to the configuration list when the PC station is running causes the 
entire PC communication to be closed and restarted.  

In this case, you will receive a corresponding warning message. 

 

Overview 
 

Topic Detailed information Called with Additional information

Hardware 
configuration and 
configuration of 
the PC station 

The status display in the 
configuration list indicates the 
following:  
• Whether or not the 

created component 
matches the current 
hardware configuration  

• Whether or not the 
configuration matches a 
downloaded configuration 

"Components" tab Online help  
Topic: "Status Symbols 
for Components" 

Check module Verification of accessibility of 
modules following 
configuration.  

After completing the 
configuration, you can click 
"Ring" to check whether 
modules can be accessed. 

Provided the module 
supports this function, a 
display on the module 
will indicate whether the 
module can be 
accessed. 

PC station  Diagnostics for a PC station "Diagnostics" tab > Export  
Save file 

Requires expert 
knowledge. 
Consult an expert if you 
encounter problems 
with the content of a log 
file 
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5.16.2.9 Printers and Print Jobs 

Overview 
 

Topic Detailed information Called with Additional information 

Printers and 
devices 

Device failure  
Display of available printers 

Start > Settings > 
Printers and Faxes 
• Problem devices  
• Printers 

Online help via F1 

Pending print 
jobs 

Display of print jobs 
Deletion of print jobs 

Start > Settings > 
Printers and Faxes 
Double-click the name of 
the printer.  

Online help via F1 

 

5.16.2.10 PC DiagMonitor 

Overview 
 

Topic Detailed information Called with Additional information 

Status of the PC 
station 

CPU temperature, 
Fan speed, 
Hard disks, 
Operating hours, 
BIOS data 

Start > SIMATIC >  
PC DiagMonitor >  
PC DiagMonitor 

Online help 
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5.16.3 Diagnostics in the Network 

5.16.3.1 NetPro 

Calling 
Call in the SIMATIC Manager or HW Config with the menu command Options > 
Configure Network. 

Overview 
 

Topic  Detailed information Called with Additional information 

Consistency of 
configuration 

Nodes that are not networked 
(exception: MPI nodes that are 
not networked) inconsistent 
connections in subnets with only 
one node 

Network > Check 
Consistency 

Online help STEP 7: 
"Checking the 
Consistency of the 
Network" topic 

Connection 
status 

Established connections to 
SIMATIC stations 

Select the CPU: PLC > 
Activate Connection 
Status 

 

Connection 
status 

Established connections to PC 
stations 

Select PC stations: PLC 
> Activate Connection 
Status 

 

Faults on 
PROFIBUS 

Only when diagnostic repeaters 
are used 

CPU > PROFIBUS > 
Display Network 
Topology 

 

Status of DP 
slaves 

Display DP slaves in the network 
view 

View > With DP Slaves  
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5.16.3.2 NCM S7 Industrial Ethernet 

Calling 
Menu command Start > SIMATIC > STEP 7 > NCM S7 Industrial Ethernet > 
Diagnostics 

Overview 
 

Topic Detailed information Called with Additional information 

CP status Dynamic information about the 
operating mode of the 
communication functions of 
CPs connected online 

Diagnostics > Online 
> Open Connection 

Online help STEP 7; Topic: 
"Diagnostics for the 
Hardware" 
Manual SIMATIC NET; 
NCM S7 for Industrial 
Ethernet 

General CP 
diagnostics and 
statistics functions 

Operating mode 
Scan event messages 
recorded in the Ethernet CP 

Diagnostics > Online 
> Open Connection 

 

Diagnostics 
functions 
depending on CP 
type and operating 
mode 

ISO transport connections 
ISO-on-TCP connections 
TCP connections 
UDP connections 
E-mail connections 

Diagnostics > Online 
> Open Connection 

 

 

 

5.16.3.3 "Network Connections" Windows Dialog Box 

Overview 
 

Topic Detailed information Called with Additional information 

Status of network 
adapters on 
Industrial Ethernet 

Dynamic display of the status 
of physical and virtual network 
adapters 

Start > Settings > 
Network Connections 

Online help of the 
operating system 
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5.16.3.4 NCM S7 PROFIBUS 

Calling 
Menu command Start > SIMATIC > STEP 7 > NCM S7 PROFIBUS > Diagnostics 

Overview 
 

Topic Detailed information Called with Additional information 

General CP 
diagnostics and 
statistics functions 

Operating mode 
Connected stations 
Station-related statistics 
functions 
Station overview 

"General" tab • Online help for NCM 
Diagnostics, "General 
Diagnostic Functions" 

• Manual SIMATIC NET; 
NCM S7 for 
PROFIBUS 

Mode-specific 
diagnostics 

Dynamic information about the 
operating mode of the 
communication functions of 
CPs connected online 

  

FMS connections DP master diagnostics 
Communication status of 
slaves and call of data for DP 
slave diagnostics 
DP slave diagnostics (non-
passive slaves) 

  

PROFIBUS 
connections 

DP master 
DP slave 
FDL connection 
FMS connection 

  

PROFIBUS 
connections 

Faults and inconsistencies in 
FMS connections of the CP 

  

 

5.16.3.5 MBSA 

Introduction  
The Microsoft Baseline Security Analyzer (MBSA) is a tool for administrators that 
enables them to check a Windows network for security vulnerability. 

Overview 
 

Topic  Detailed information Called with Additional information
Security 
vulnerability 

Configuration, passwords, 
utilities, creation of security 
reports, required updates 

Mbscali.exe MBSA description from 
Microsoft® 
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5.16.4 Diagnostics for the Operator Station 

5.16.4.1 Lifebeat Monitoring 

Overview 
 

Topic Detailed information Called with Additional information 

Monitoring of 
components of 
WinCC projects and 
their associated 
SIMATIC stations 

Configured components are 
displayed graphically in a 
plant picture. Faulty 
components have a red line 
running through them in the 
graphic. 

Configure lifebeat 
monitoring and call 
the picture in 
process mode 

Online help for WinCC 
Information System, "Lifebeat 
Monitoring" 
Information on the 
configuration in the 
configuration manual Process 
Control System PCS 7; 
Operator Station  
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5.16.4.2 Simatic Shell 

Calling 
1. Select the PC station (workstation) in the tree view of Windows Explorer. 

2. Select the "Simatic Shell" folder. 

3. Select the menu command Settings from the context menu. 

Overview 
 

Topic Detailed information Called with Additional information 

Network 
adapters 

• Network adapters of the 
local computer 

• "IP" column, 
current TCP/IP addresses 
and MAC addresses of 
the local network adapters 

"Network adapters" list Online help of SIMATIC 
Shell 

Multicast service 
life (TTL) 

Maximum number of route 
jumps between subnets ("TTL" 
IP parameter) 

"Multicast service life 
(TTL)" input line 

Online help of SIMATIC 
Shell 

Multicast proxy IP address of a computer in 
another subnet, which is to be 
used as a substitute for 
distributing Multicast packets 

"Multicast proxy" input 
line 

Online help of SIMATIC 
Shell 

Compatibility Compatibility mode for 
communication between 
different versions of WinCC 

"Compatibility" check box Online help of SIMATIC 
Shell 

Computer status 
change 

When the status of a computer 
changes, a message is sent to 
all stations, for example: 
• When a computer has 

archived a project 
• When a computer shuts 

down 
• When a computer boots 

up, thus becoming part of 
a network/station group 

 Online help for WinCC 
Information System 
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5.16.4.3 WinCC "System Info" Channel 

Introduction 
The WinCC "System Info" channel is used to evaluate system information from 
server PCs.  

This channel does not require hardware because it directly accesses the system 
information on the server PC on which it is installed.  

 
 Note 

Only system information from a single server can be represented or evaluated on a 
client. 

 

Overview 
 

Topic Detailed information Called with Additional information

Time information Display of time of day, date and 
day of the week in process 
pictures 

Display in configured 
picture 

Online help WinCC 
Information System, 
Topic: "Communication 
> System Information" 

CPU 
load 

CPU load in a trend display Display in configured 
picture 

 

Drive capacities -  
storage space 

• Display and monitoring of 
available drive capacities of 
different servers on a multi-
client system 

• Monitoring of available drive 
capacity and message 
triggering 

Display in configured 
picture 

 

Timers and  
counters 

Use of timers  
and counters (for example, to 
count operating hours) 

Display in configured 
picture 

 

Event triggering Triggering of events through 
evaluation of system information in 
scripts 

Display in configured 
picture 

 

 

Configuration 
Online help for WinCC Information System, "Communication > System Info > 
Channel Configuration > How to Configure the Channel System Info". 
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5.16.4.4 User Administrator 

Calling 
Call this tool by selecting the menu command Start > SIMATIC > WinCC 

Overview 
 

Topic Detailed information Called with Additional information 

For the OS 
Creating users  
Setting access 
permissions 

Assignment and verification of 
access permissions for users 
of the PCS 7 Operator Station: 
• For process mode  
• For configuration system 

editors  

In the tree view of WinCC 
Explorer, select: 
Editors > User 
Administrator > Open 

Online help for  
WinCC Information 
System, "User 
Administrator Functionality" 
topic and "Preventing 
Unauthorized Operation" 
topic 

 

5.16.4.5 WinCC - Channel Diagnostics 

Calling 
Select the menu command Start > SIMATIC > WinCC > Tools > Channel 
Diagnostics  

Overview 
 

Topic Detailed information Called with Additional information

Connections Overview of the status of the configured 
channels and their connections to the 
SIMATIC station, directly or by network 
connection through Internet Explorer 

"Channels/Co
nnections" tab 

Online help for WinCC 
Information System, 
"How to Test the 
Channel and the 
Connection" 

Trace mode Trace mode can be activated in process 
mode (this affects runtimes) 

Only to 
support 
experts 

Online help for WinCC 
Information System, 
"How to Configure the 
Trace Function of a 
Channel" 

 

Additional information 
Online help for WinCC Information System, "Channel Diagnostics Using Channel 
Diagnosis" 
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5.16.4.6 Status of Multi-user Operation 

Calling 
Diagnostics on the connection between OS server and an OS client 

Only when WinCC is in process mode: in the menu of the WinCC Explorer. 

Overview 
 

Topic Detailed information Called with Additional information 

Connection 
status 

Status - logical connections 
and  
current status of  
server-client interface 

Options > Status of 
Multi-user Operation 

Online help WinCC 
Information System, Topic: 
"Options Status of Multi-user 
Operation" 

Connection 
status on the 
server 

Current status of connections 
in Multi-user operation 

"Process Data Server" 
tab 

 

Connection 
status on the 
client 

Current status of the client on 
which the scan is started 

"Process Data Clients" 
tab 

 

 

5.16.4.7 Status of Connections 

Calling 
Diagnostics of the connection between WinCC and an automation system 

Only when WinCC is in process mode: in the menu of the WinCC Explorer. 

Overview 
 

Topic  Detailed information Called with Additional information 

Connection 
status 

Status - logical connections 
and  
current status of process 
interface 

Options > Status of 
Connections 

Online help WinCC 
Information System, Topic: 
"Checking the Status of the 
Connection" 
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5.16.4.8 Redundancy State Control 

Overview 
For diagnostics in systems with redundant PCs, it is important to always have an 
overview of the redundancy status. The redundancy status represents the status of 
the individual master and standby computers. You use the redundancy status 
display for this. 

 
Topic Detailed information Called with Additional information 

Redundant OS 
components 
Status 

Master; STANDBY 
Standalone 
Connection 
• Not initialized  
• Initialized  
• No connection 
• Fault 

Create a picture in the 
WinCC project of the OS 
server. Insert a control. 
Graphics Designer: 
Object palette > "Default" 
tab > in the "Smart 
Objects" tree > drag the 
control into the picture > 
in the "Insert Control" 
dialog box > 
Select "PCS 7 
Redundancy State 
Control". 

You can find information about 
the configuration in the 
configuration manual Process 
Control System PCS 7; 
Operator Station 
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5.16.5 Diagnostics for the BATCH Station 

5.16.5.1 Status Symbols in the BATCH Server Task Bar 

Overview 
With SIMATIC BATCH, status symbols in the BATCH server task bar indicate the 
redundancy status. 

 
Topic Detailed information Called with Additional information 

Status server Status displays in the task 
bar of the BATCH server 

Double-click a status 
symbol to display a field 
containing information 
about the server status. 

You can find information on 
the status symbols in the 
online help. 

Status of 
redundant 
servers 

Status display of the server 
in process mode: 
• In the master server 

task bar you will see 
the following symbols, 
highlighted in red: 

    
• In the standby server 

task bar you will see 
the following symbols: 

   

Double-click a status 
symbol to display a field 
containing information 
about the server status. 

You can find information on 
redundant BATCH servers in 
the manual Process Control 
System PCS 7; SIMATIC 
BATCH 

Status of data 
replication on the 
standby server 
(partner server) 

In the standby server task 
bar you will see the 
following symbols: 
• Data replication 

running: 

   
• Data replication 

completed: 

   

Double-click a status 
symbol to display a field 
containing information 
about the server status. 

You can find information on 
redundant BATCH servers in 
the manual Process Control 
System PCS 7; 
SIMATIC BATCH 
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5.16.6 Diagnostics for the Route Control Station 

5.16.6.1 Status Symbols in the Route Control Server Task Bar 

Overview 
With SIMATIC Route Control, status symbols in the Route Control server task bar 
indicate the redundancy status. 

 
Topic Detailed information Called with Additional information 

Status of 
redundant 
servers 

Status display of the server 
in process mode: 
• In the master server 

task bar you will see 
the following symbol: 

    
• In the standby server 

task bar you will see 
the following symbol: 

    

Double-click a status 
symbol to display a field 
containing information 
about the server status. 

You can find information on 
redundant Route Control 
servers in the manual Process 
Control System PCS 7; Route 
Control 
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5.16.7 Diagnostics for the SIMATIC Station 

5.16.7.1 SIMATIC Manager 

Calling 
Call SIMATIC Manager by selecting the menu command Start > Simatic > 
SIMATIC Manager 

Overview 
 

Topic Detailed information Called with Additional information 

Diagnosing 
hardware 

Quick view: Symbols indicate 
operating status and module 
information.  

PLC > Diagnostics/Setting 
> Hardware Diagnostics 
Continue to Modules Status 
> Update: F5 key 

Online help STEP 7, 
Topic: "Hardware 
Diagnostics and 
Troubleshooting" 
You can find information 
about this in the section 
"Module Status" 
Additional information: 
Double-click on the icon  

Module 
information 

Use this menu command to 
read information on the 
selected module. 

Select CPU or CP: PLC > 
Module Status 

Online help STEP 7, 
Topic: "Hardware 
Diagnostics and 
Troubleshooting" 
You can find information 
about this in the section 
"Module Status" 

Operating mode Displays the operating mode 
of the current module (RUN, 
STOP). 
This requires an online 
connection to the CPU. 

Select CPU or CP: PLC > 
Operating Mode 

 

Time of day Checks/sets time of day  Select the CPU: PLC > 
Diagnostics/Settings > Set 
Time of Day 

Online help for STEP 7, 
"CPU Clocks with Time 
Zone Setting and 
Summer/Winter Time" 
and "Using the Clock 
Functions"  

Faults on 
PROFIBUS 

• Faulty bus segment 
• Distance of an error 

location from the 
diagnostics repeater 

Select the master system: 
PLC > Diagnose, 
Monitor/Modify PROFIBUS 
Node 

Online help for STEP 7, 
"Topology display using 
diagnostics repeaters" 

All installed 
authorizations 
(Versions of 
installed 
components) 

• Products (name, 
version, release) 

• Components (name, 
version, release) 

• Firmware updates 
• DLLs (STEP 7 DLLs, 

Windows DLLs) 

Help > About > "Display" 
button 

Online help for STEP 7, 
"Installed SIMATIC 
Software" 
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Topic Detailed information Called with Additional information 

PA devices and 
HART devices 

Requirement: SIMATIC PDM 
is installed.  
• Symbols provide 

information about the 
status of these devices 

View > Process Device 
Plant view 
Select device. 
Select context menu 
command Open Object. 

Online help for 
SIMATIC PDM > 
Configuring networks and 
process devices 
Icons: ...> device icons in 
the process device - Plant 
view 
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5.16.7.2 HW Config 

Calling 
Select the menu command Start > SIMATIC > SIMATIC Manager.  

In the tree view, click on "SIMATIC Station" and double-click "Hardware" in the 
selection list. 

Overview 
 

Topic Detailed information Called with Additional information 

Components 
accessible online 

Icon indicates  
the operating mode  
of modules (= system 
diagnostics).  

Station > Open Online The <F5> key refreshes the 
display. Double-click the icon to 
obtain additional information. 

Time of day Check/Set Station > Open Online 
Select the CPU: PLC > 
Set Time of Day 

Online help for STEP 7, "CPU-xxx 
Clocks Time Zone Setting and 
Summer/Winter Time" and "Using 
the Clock Function" 

Module 
Information 

Use this menu 
command to read 
information  
about the selected 
module. 

Select module: PLC > 
Module Status 

You can find information about this 
in the section "Module Status" 

 

Additional information is available in the Online help for STEP 7. 
• Diagnostic icons in the online view  

• Information functions in the quick view  

• Basic procedure for determining the cause of a STOP (CPU) 

• Hardware diagnostics and troubleshooting  

• Operating mode and operating mode transitions  
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5.16.7.3 Module Information 

Calling up quick information 
1. Call up the quick information in SIMATIC Manager by selecting the menu 

command Component View > View > Online. 

2. Select the SIMATIC station with the menu command CPU > 
Diagnostics/Settings > Hardware Diagnostics. 

Additional diagnostics: select a module and click "Module Information" 

Calling up module diagnostics 
1. Open HW Config. 

2. Select the menu command Station > Open Online. 

3. Select the module. 

4. Select the menu command PLC > Module Information. 

Diagnostics for the CPU 
Extensive diagnostic checks are performed on a CPU. 

Additional information:  
Online help for STEP 7, "Diagnostics, Hardware Diagnostics and Troubleshooting" 

 
Topic Detailed information Called with Additional information 

Module data Data for identifying the selected 
module Examples: 
• Type 
• Order number 
• Firmware 
• Version 
• Status 
• Slot in the rack 

"General" tab Comparison of configured 
and inserted modules 

Events in the 
diagnostic buffer 
and Detailed 
information 
about the 
selected event 

Analysis of the cause of STOP 
of a CPU, overview of previous 
events on the selected module. 
Diagnostic data for the selected 
module 

"Diagnostic Buffer" tab  Check of events in the 
diagnostic buffer and 
Detailed information 
about the selected event 

DP slave 
diagnostics  

Diagnostic data for the selected 
DP slave (in accordance with 
EN 50170)  

"DP Slave Diagnostics" 
tab 

To determine the cause 
of a DP slave error 

Target system  Current time, operating hours 
and  
information about clock 
synchronization 
(synchronization intervals)  

"Time System" tab  



 Diagnostics in PCS 7 

Process Control System PCS 7 V7.0 - Service Support and Diagnostics 
A5E00783462-01 5-43 

Topic Detailed information Called with Additional information 

Performance 
data  

Operand areas and the 
available blocks of the selected 
(CPU/FM) module  

"Performance Data" tab  
For checking the user 
program to determine 
whether the CPU meets 
the appropriate 
requirements to execute a 
user program, for 
example, with regard to 
process image size  

 

Performance 
data 

Display of all module types 
available  
in the functional scope of the 
selected module. List of OB, 
SFB and SFC that can be used 
in the module.  

Used to check the 
standard blocks contained 
and called in the user 
program. 

 

 

Diagnostics for DP Slaves 
 

Topic Detailed information Called with Additional information 

Module data Data for identifying the selected 
module Examples: 
• Type 
• Order number 
• Firmware 
• Version 
• Status 
• Slot in the rack 

"General" tab Comparison of configured 
and inserted modules 

DP slave 
diagnostics  

Diagnostic data for the selected 
DP slave (in accordance with EN 
50170)  

"DP Slave Diagnostics" 
tab 

To determine the cause 
of a DP slave error 
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5.16.7.4 PROFIBUS Diagnostics with Diagnostic Repeater 

Requirements 
• The diagnostic repeater must be installed. 

• The cable diagnostics must be prepared. 

Calling 
Select Diagnostic Repeater in HW Config. 
Select the menu command PLC > Diagnostics/Setting > Module Information 

Additional information:  
Online help for STEP 7, "Hardware Diagnostics and Troubleshooting" 

Overview 
 

Topic  Detailed information Called with Additional information 

Quick overview  
Error on bus 
segment 

Icons indicate the status of 
the PROFIBUS master 
systems 

"Module Information" dialog 
box 
- Status 
- Icons in front of the tab 

names (DP1, DP2, DP3, 
PG) 

Online help STEP 7, Topic: 
"Hardware Diagnostics and 
Troubleshooting" 
Comparison of configured 
and inserted modules 

DP slave 
diagnostics  

Diagnostic data for the 
selected DP slave (in 
accordance with EN 50170)

"DP Slave Diagnostics" tab To determine the cause of 
DP slave errors 

Location of 
error 

Graphical representation of 
the error location 
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5.16.7.5 SIMATIC PDM 

Introduction 
SIMATIC PDM is a software package used for configuring, assigning parameters 
to, commissioning, and maintaining devices (transducers, for example) and for 
setting network configurations and configuring PCs. 

With SIMATIC PDM, you monitor devices with diagnostic capability which are 
located in a subnet on the PROFIBUS DP, downstream of a DP/PA link, for 
example. 

Overview 
 

Topic Detailed information Called with Additional information 

Connections to 
SIMATIC PDM 

Connection configuration In the SIMATIC Manager: 
Options > Set PG/PC Interface

Online help 
SIMATIC PDM; 
"Configuring Networks 
and Process Devices" 
topic 

PDM device  
identification 

Life List - determine 
accessible devices 
(HART and PROFIBUS 
PA profile V2/V3)  

Start > SIMATIC > STEP 7 > 
SIMATIC PDM - Life List 

Manual SIMATIC;  
The Process Device 
Manager  
Online help for 
SIMATIC PDM, Life List 
• Take note of the 

"Scan subnets" 
option. 

Quick 
information; 
display 
configuration 

Symbols provide an 
overview of the 
configuration and device 
status 
(more: see Device 
Status) 

In the SIMATIC Manager: View 
> Process Device Plant view 

Online help for 
SIMATIC PDM, 
"Configuring Networks 
and Process Devices" 
Icons: ...> Device icons in 
the process device - Plant 
view 

Device 
information 

• Type  
• DLL (type file) 
• Manufacturer  
• Versions 

Open project in the Process 
Devices - Plant view> 
Select device > Edit > Object 
Properties  
"Device" tab 

Online help for 
SIMATIC PDM 

Device status • Communication 
• Maintenance status 
• Process errors 
• Configuration errors 
• Overall status 
• Device-specific 

messages 

Open project in the Process 
Devices - Plant view> 
Select device > Edit > Object 
Properties  
"Device Status" tab 

Online help for 
SIMATIC PDM, if 
manufacturer files are 
available in it 
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5.16.8 Additional Diagnostics Options 

5.16.8.1 Additional Diagnostic Options for PCS 7 

Disclaimer of Liability 
 

!  
Warning 
Siemens does not accept responsibility for inappropriate use of the procedures 
presented in this documentation or any consequences that might result thereof for 
the customer. 

 

!  
Warning 
• All work on the process control system must be performed by trained service 

personnel. 

• Always observe the plant-specific rules and government regulations when 
making changes to your system. 

• Observe the plant-specific boundary conditions and adjust the work 
accordingly.  

• Always bear in mind that changes in a system can impact other sections of the 
system. 

 

Overview 
The listed components and tools in the following are not part of PCS 7. You can 
use them to perform advanced inspections and diagnostics. Below you will find 
some of the diagnostics applications suitable for PCS 7: 

• Amprolyzer (Add-on Product) 

• BANY (Add-on Product) 

• BT 200 Bus Test Device  

• SYSTEM Diagnostics for Process Control (Add-on Product) 
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5.16.8.2 Amprolyzer (Add-on Product) 

Introduction 
Amprolyzer is a program that allows you to perform simple, thorough diagnostics 
for PROFIBUS. 

Calling 
If you have installed Amprolyzer, call the program with the menu command Start 
menu > Programs > Amprolyzer. 

Overview 
 

Topic Detailed information Called with Additional information 

System 
configuration 

Comparison of specified and 
actual configuration, lifebeat 
monitoring 

Addition of a new bus using 
the "Add Bus" button. 
Display of all bus information 
using the "Show Bus State" 
button. 

Manual in PDF format 

Message frame 
traffic 

Interpretation, statistics, 
detection/triggering of frame 
errors and repeats 

1. Without filters/triggers: 
As above 
2. With filters/triggers: 
"Record Complex" button 
Message frame traffic is 
recorded here, in addition to 
a display of all bus 
information. 

Manual in PDF format 

Bus recording Parallel recording of  
multiple busses at the same 
time, special triggers, filters 

As above Manual in PDF format 

Interface to 
data evaluation 

Open interface using MS Excel Recorded data are 
automatically exported and 
displayed in MS Excel. 
A recording can be sent as 
an Excel file, so that the 
recipient does not have to 
have this tool. 

Manual in PDF format 
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5.16.8.3 BANY (Add-on Product) 

Overview 
BANY is utility based on Microsoft Windows used for documentation, diagnostics, 
recording and analysis of your PCS 7 Ethernet and PROFIBUS networks. 

The program packages below can be supplied separately or as a bundle: 

• BANYnet  
Diagnostic tool for Ethernet networks 

• BANY PROFIBUS 
Diagnostic tool for PROFIBUS networks 

Requirements 
• The PC to be used for analyzing the PROFIBUS using BANY PROFIBUS must 

be equipped with a PROFIBUS network adapter (CP 5512). 

• If you wish to analyze the terminal bus and plant bus at the same time, the PC 
must be equipped with two Ethernet network adapters. 

Calling 
You call the analysis programs via the following menu commands: 

• If you have installed BANYnet: Start menu > Program Files > BANYnet. 

• If you have installed BANY PROFIBUS: Start menu > Program Files > BANY 
PROFIBUS. 

BANYnet 
The options for diagnosing Ethernet networks using BANYnet are shown in the 
table below: 

 
Topic Detailed information Called with Additional information

System 
configuration 

Comparison of specified and 
actual configuration, graphical 
overview, lifebeat monitoring 

In the Start window, 
select "Plant Manager" 

Online help 

Status of 
OSM/ESM 

Display, parameter assignment, 
bus load measurement, SNMP 
server 

In the Start window, 
select "System 
Diagnostics" 

Online help 

Message frame 
traffic 

Interpretation (including PCS 7), 
statistics, batch analysis 

In the Start window, 
select "Bus Analysis" 

Online help 

Bus recording Parallel recording, special 
trigger, filter 

Called from the menu in 
the "Bus Analysis" dialog 
box 

Online help 
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BANY PROFIBUS 
The options for diagnosing PROFIBUS networks using BANY PROFIBUS are 
shown in the table below: 

 
Topic Detailed information Called with Additional information

System 
configuration 

Comparison of specified and 
actual configuration, graphical 
overview, master/slave 
monitoring, lifebeat monitoring 
Display, parameter assignment 

In the Start window, 
select "Plant Manager" 

Online help 

Bus analysis, 
transmission rates 
of 9.6 Kbps to 12 
Mbps 

Bus load measurement, 
interpretation (incl. PCS 7), 
statistics, batch analysis, bus 
bottlenecks, available reserves, 
redundancy analysis 

In the Start window, 
select "Bus Analysis" 

Online help 

Bus recording Parallel recording, special 
trigger, filter 
The recording can be started 
and finished automatically with 
the help of triggers. 

Refer to menu in the "Bus 
Analysis" dialog 

Online help 

 

5.16.8.4 BT 200 Bus Test Device 

Overview 
 

 Note 
The bus test device is not a software program - for this reason, the Call column is 
omitted. 

 

 
Topic  Details Information and Help 

Bus line diagnostics Tests for : 
• Line breaks 
• Monitor breaks 
• Line exchange A  B 
• Short circuits 
• Number of terminating resistors inserted 
• Reflection points (for example, for line breaks) 

Device description 

Test of PROFIBUS 
interfaces 

• RS 485 drivers 
• Internal voltage supply at 5V 
• RTS signal 

Device description 

Test of accessibility ... of stations Device description 
Protocol functions  Device description 
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5.16.8.5 SYSTEM Diagnostics for Process Control (Add-on Product) 

Introduction 
Display of PROFIBUS diagnostic information on the operator station 

Online help: SYSTEM DIAGNOSTICS - Help 

Overview 
 

Topic Detailed information Called with Additional information 

PROFIBUS DP – General Station failure 
Display from HW Config 

Picture in the OS  See "Configuration" below

PROFIBUS DP Fault Fault indication with 
Detailed information 
about cause of error 

Picture in the OS  See "Configuration" below

From HW Config 
Information 

"Name and comments" Picture in the OS  See "Configuration" below

Configuration information Order no; Addresses; 
Slot types 

Picture in the OS  See "Configuration" below

 

Configuration 
The configuration is described in the online help SYSTEM DIAGNOSTICS - Help >, 
section "PROFIBUS DP/PA DIAGNOSTICS". 
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6 Failure, Exchange and Return 

6.1 Failure, Exchange and Return - Guide to 
Documentation 

Guide to Documentation 
You can find information on component response and the procedure to be followed 
in the event of failure, exchange and return in the following documentation: 

 
Scenario Information can be found 

in ... 
Section ... 

I/O 
Failure and function 
fault of modules 

Manual Automation System 
S7-400 CPU Data 

• Monitoring functions of the CPU 

Failure and function 
fault of SIMATIC 
ET 200M 

Manual SIMATIC 
Distributed I/O Device ET 
200M 

• Commissioning and Diagnostics 

Failure and function 
fault of SIMATIC 
ET 200iSP 

Manual SIMATIC 
Distributed I/O Device ET 
200iSP 

• Commissioning and Diagnostics 

Failure and function 
fault of SIMATIC 
ET 200S 

Manual SIMATIC 
Distributed I/O Device ET 
200iSP 

• Commissioning and diagnostics 

Failure and function 
fault of Ex I/O 
modules 

Reference manual 
Automation Systems 
S7-300, ET 200M 
Ex I/O Modules 

• SIMATIC S7 Ex digital modules 
• Diagnostics for analog modules  

Failure and function 
fault of redundant 
input/output 
modules 

Configuration manual 
Process Control System 
PCS 7; Fault-tolerant 
Systems 

• Failure of Redundant I/O Modules 
• How to Set the CPU in Respect of 

the Response of the I/O Modules in 
the Event of Channel Errors 

Failure and function 
fault of distributed 
I/O components 

Manual Automation 
Systems S7-400H; Fault-
tolerant Systems : 

• Failure and Replacement of a 
PROFIBUS DP Master 

• Failure and Replacement of a 
Redundant PROFIBUS DP 
Interface Module 

• Failure and Replacement of a 
Redundant PROFIBUS DP Slave 

• Failure and Replacement of 
Redundant PROFIBUS DP Lines 

Failure of devices 
configured using 
PDM 

Manual SIMATIC; The 
Process Device Manager 
 

• Device Replacement 
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Scenario Information can be found 
in ... 

Section ... 

Automation systems 
Failure of a CPU in 
a redundant AS 

Configuration manual 
Process Control System 
PCS 7; Fault-tolerant 
Systems 

• Failure of the Master CPU 

Failure of 
synchronization 
between the CPUs 
of a redundant AS 

Configuration manual 
Process Control System 
PCS 7; Fault-tolerant 
Systems 

• Failure of a Fiber-Optic Cable 

Communication 
Failure and function 
fault of SCALANCE 
X-400 

Operating Instructions  
SIMATIC NET; Industrial 
Ethernet switches 
SCALANCE X-400 

• Installation and Commissioning 
- Installation and Removal 
- Displaying LEDs 
- Replacing the C-PLUG 

Failure and function 
fault of SCALANCE 
X-200 

Commissioning manual 
SIMATIC NET; Industrial 
Ethernet SCALANCE X-100 
and SCALANCE X-200 
Product Line 

• Installation and Maintenance 
• Configuration/Diagnostics via 

Remote Mechanisms 
• SCALANCE X2<...> Displays 

Failure and function 
fault on the OSM 

User manual SIMATIC NET; 
Industrial Ethernet 
OSM/ESM Network 
Management  

• Notes on Troubleshooting 

Disrupted network 
connections 

Configuration manual 
Process Control System 
PCS 7; Fault-tolerant 
Systems 
 

• Failure, Failover and Restarting of 
Redundant OS Servers 
- Disrupted network connection 

to the OS partner server 
- Disrupted Network Connection 

Between the OS Client and the 
OS Server 

- Disrupted Network Connection 
Between the OS and AS 

Fault on 
PROFIBUS DP 

Manual SIMATIC; 
Diagnostic Repeater for 
PROFIBUS DP 

• Mounting 
• Commissioning 
• Diagnostics 

Operator control and monitoring stations 
Failure of a 
redundant OS 
server 

Configuration manual 
Process Control System 
PCS 7; Fault-tolerant 
Systems  

• Failure of a redundant OS server 

Switchover 
response of OS 
clients in the event 
of an OS server 
failure 

Configuration manual 
Process Control System 
PCS 7; Fault-tolerant 
Systems 

• Switchover response of OS clients 
in the event of an OS server failure 

Failure of BATCH 
servers 

Manual Process Control 
System PCS 7; SIMATIC 
BATCH 

• Failure of BATCH servers 
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Scenario Information can be found 
in ... 

Section ... 

Switchover 
response of 
BATCH clients in 
the event of a 
BATCH server 
failure 

Manual Process Control 
System PCS 7; SIMATIC 
BATCH 

• Switchover response of BATCH 
clients in the event of a BATCH 
server failure 

Failure response of 
Route Control 
servers 

Manual Process Control 
System PCS 7; SIMATIC 
Route Control 

• Failure response of Route Control 
servers 

Switchover 
response of Route 
Control clients in 
the event of a 
Route Control 
server failure 

Manual Process Control 
System PCS 7; SIMATIC 
Route Control 

• Switchover response of Route 
Control clients in the event of a 
Route Control server failure 
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