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Siemens Industry Online Support 
This article is taken from the Siemens Industry Online Support. The following link 
takes you directly to the download page of this document: 
http://support.automation.siemens.com/WW/view/en/48418663 
 
 
Caution 
The functions and solutions described in this article confine themselves to the 
realization of the automation task predominantly. Please take into account 
furthermore that corresponding protective measures have to be taken up in the 
context of Industrial Security when connecting your equipment to other parts of the 
plant, the enterprise network or the Internet. Further information can be found 
under the Item-ID 50203404. 
http://support.automation.siemens.com/WW/view/en/50203404 
 
 
 
 

http://support.automation.siemens.com/WW/view/en/48418663
http://support.automation.siemens.com/WW/view/en/50203404


 

Distillation column 
V1.1, Entry ID: 48418663 3 
 

C
op

yr
ig

ht
 

 S
ie

m
en

s 
A

G
 2

01
3 

A
ll 

rig
ht

s 
re

se
rv

ed
  

s  
 
 
 
 
 
 
 

SIMATIC PCS 7 
 
Distillation column 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

   

Automation Task 
 1 

   

Automation Solution 
 2 

   

Basics 
 3 

   

Structure and Principle 
 4 

   
Configuration and 
Settings 

 5 
   
Starting the Unit 
Template 

 6 
   
Operation of the 
Application 

 7 
   

Links & Literature 
 8 

   

History 
 9 

   

Appendix 
 10 

   

 
  



Warranty and Liability 
 

4 
Distillation column 

V1.1, Entry ID: 48418663 
 

C
op

yr
ig

ht
 

 S
ie

m
en

s 
A

G
 2

01
3 

A
ll 

rig
ht

s 
re

se
rv

ed
 

Warranty and Liability 
 

Note The application examples are not binding and do not claim to be complete 
regarding configuration, equipment and any eventuality. The application 
examples do not represent customer-specific solutions. They are only intended 
to provide support for typical applications. You are responsible for ensuring that 
the described products are used correctly. These application examples do not 
relieve you of the responsibility to use sound practices in application, installation, 
operation and maintenance. When using these Application Examples, you 
recognize that we cannot be made liable for any damage/claims beyond the 
liability clause described. We reserve the right to make changes to these 
Application Examples at any time without prior notice. If there are any deviations 
between the recommendations provided in this application example and other 
Siemens publications – e.g. Catalogs – the contents of the other documents 
have priority. 

 
We accept no liability for information contained in this document. 
Any claims against us - based on whatever legal reason - resulting from the use of 
the examples, information, programs, engineering and performance data etc., 
described in this application example shall be excluded. Such an exclusion shall 
not apply in the case of mandatory liability, e.g. under the German Product Liability 
Act (“Produkthaftungsgesetz”), in case of intent, gross negligence, or injury of life, 
body or health, guarantee for the quality of a product, fraudulent concealment of a 
deficiency or breach of a condition which goes to the root of the contract 
(“wesentliche Vertragspflichten”). However, claims arising from a breach of a 
condition which goes to the root of the contract shall be limited to the foreseeable 
damage which is intrinsic to the contract, unless caused by intent or gross 
negligence or based on mandatory liability for injury of life, body or health. The 
above provisions do not imply a change in the burden of proof to your detriment. 
 
It is not permissible to transfer or copy these Application Examples or excerpts 
thereof without express authorization from Siemens Industry Sector. 
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1 Automation Task 
1.1 Introduction 

Looking at a chemical plant and its engineering processes it becomes apparent 
that certain process steps, procedures and devices repeat in identical or similar 
form. The concept of unit templates offers you pre-engineered, standardized partial 
automation solutions (templates) for plant engineering processes. 
A unit template is configured independent of the automation hardware and contains 
a preconfigured user program including the process visualization. 
Integrating the unit template into an existing PCS 7 project requires interconnecting 
the user program with the automation hardware and configuring the controllers. 
The objective for the application of unit templates is: 

 Reducing the required know-how for application development 
 Reducing the configuration workload 
 Illustrating typical control strategies 
 Unified program structures 

1.2 Description  

The “Distillation column” unit template is a template which contains all typical 
components of a distillation column, its control, the required logic and the 
visualization. 
 

Figure 1-1 Distillation column as an integral part of the bio-ethanol process 
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The structure of the enclosed example project enables directly adopting predefined 
elements into an existing PCS 7 project.  
For the user program, the Advanced Process Library (APL) is employed with a 
multi-variable controller concept. The multi-variable controller enables a distillation 
column control which keeps the demanded product quality constant and also 
enables optimization. 
As a unit, a distillation column consists of a number of individual process 
engineering components, such as the column, the actuators and the sensors. The 
controller is the link between all components of a distillation column, hence an 
important part of an automation process. 
During the configuration a number of conditions must be considered (e.g. 
interlocking, controller structures) which require a high level of detailed knowledge 
about the process plant and a high level of detailed knowledge and experience with 
PCS 7. 
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2 Automation Solution 
2.1 Overview of the overall solution 

Description 
The quality of a substrate separation is measured by the purity of the separation 
products, i.e. the concentration of light ends and heavy ends in the head and 
bottom extraction. Measuring these concentrations by means of online analyzers is 
extensive, so it is not performed in most of the plants. On the individual trays of the 
column there are thermo-dynamic correlations in the phase equilibrium (between 
vapor and liquid) and hence there is also a correlation between the concentrations 
and the temperatures. The easily measurable temperatures are used as 
substitutional controlled variables. The advantage is that the correlation between 
the temperatures and the control operations can be linearized more easily than the 
correlation between the concentrations. 
The “Distillation column” unit template is realized as PCS 7 multiproject and 
consists of an AS project (user program) as well as an OS project (visualization 
with process pictures). In the AS project all control functions have already been 
realized in form of CFC (Continuous Function Chart). Furthermore, the AS project 
contains a simulation which simulates a distillation column (packed or packed bed 
columns) for distilling isopropanol (light end) and butanol (heavy end). 
The AS (Automation System) project was created using the APL (Advanced 
Process Library), which also contains a model predictive multi-variable controller. 
The multi-variable controller is the core component of the control strategy; it takes 
on the control of head and bottom temperature in the distillation column. Further 
controls are subordinate to the multi-variable controller. 
The process pictures contain an overview of the most important characteristics 
(KPI: Key Performance Indicators) of the distillation column, as well as all detailed 
information on the individual components of the distillation column.  

Restriction 
The following exceptional cases are not covered by the “Distillation column” unit 
template: 

 Multi-substance distillation, i.e. columns with additional lateral extractions 
 Columns with gaseous head products, which require a different structure for 

the pressure control 
 Vacuum columns with a special pressure control structure 
 Stripper, i.e. columns without reinforcement part 
 Columns with no representative temperature as controlled variable 

Required knowledge 
Basic knowledge of the following subject areas is required: 
 Configuration with SIMATIC PCS 7 and the APL 
 Knowledge of control engineering 
 Basic knowledge of process engineering 
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2.2 Core functionality 

The individual components of a distillation column are described below. The 
introduction is provided via the process picture of the visualization user interface. 

2.2.1 Visualization  

Figure 2-1  

 
The visualization of the “Distillation column” unit template consists of an overview 
picture and a process picture. 

Overview picture 
The overview picture shows the most important process values and the control 
performance of each control loop. For each displayed value you can receive further 
information via the respective faceplate and make changes. Evaluating the curve 
display of a control performance enables detecting gradual deterioration over a 
longer period of time (e.g. signs of wear). 

Process display 
The process display shows a schematic representation of the distillation column 
and the faceplates for controlling the individual components. Additionally, the 
process display contains an overview of relevant characteristics (Key Performance 
Indicator) and operating time displays. The process display gives the operator an 
overview of the entire plant and enables the operator to make necessary control 
operations. 
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2.2.2 Description of individual functions 

Figure 2-2 

1

2

3

4

5

6

 
 
The process display of the distillation column consists of the following main 
components: 
1. Distillation column 
2. Feed 
3. Vaporizer (“Vapor”) 
4. Condenser with reflux (“Reflux”) 
5. Extraction of the head product (“Light end”) 
6. Extraction of the bottom product (“Heavy end”) 

1. Distillation column 
The distillation column is controlled by means of a multi-variable controller. The 
head and bottom temperature (controlled variables) is detected and controlled via 
the vapor volume or the condensate reflux (manipulated variables). Both controlled 
variables are used as setpoint specifications for the underlying PID controllers. 

2. Feed 
The substance mixture is fed to the distillation column via the feed.  
A PID controller controls the flow rate of the feed (controlled variable) via a valve 
(manipulated variable) until the setpoint specification has been reached. The 
process value of the PID controller is integrated into the higher-level multi-variable 
controller as a measurable disturbance variable. 
In a column with predefined feed (preceding unit) the measured value of the feed 
(flow rate) is used for disturbance variable compensation. In this case there is no 
PID controller for controlling the flow rate. 
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3. Vaporizer (“Vapor”) 
The vaporizer removes the liquid substance mixture from the bottom of the column 
and heats it until the components vaporize. The gaseous substance mixture is then 
fed back to the distillation column. 
The hot vapor flow rate (controlled variable) for heating the vaporizer is controlled 
via a valve (manipulated variable) using a PID controller which contains the 
setpoint specified by the multi-variable controller. 

4. Condenser with reflux (“Reflux”) 
The condenser extracts the gaseous substance mixture at the head of the column 
and cools it down until both substances (light end and heavy end) start 
condensing. The liquid substance mixture is then fed back into the distillation 
column. The condenser also contains a tank where the liquid substance mixture is 
intermediately stored to enable regulating the reflux volume. 
The pressure in the head of the distillation column (controlled variable) is controlled 
via the cooling water flow rate (manipulated variable) using a PID controller. The 
operator specifies the setpoint. 
The reflux flow rate (controlled variable) is controlled via valve (manipulated 
variable) using a PID controller. The setpoint is specified by the multi-variable 
controller of the distillation column. 

5. Extraction of the head product (“Light end”) 
The volume of drained head product depends on the filling level of the condenser 
and cannot be specified. For a stable operating point in the entire distillation 
column the volume of the head product to be extracted results from the following 
components: 
 The concentration of the light end in the fed substance mixture  
 The feed volume of the distillation column 

The filling level in the condensate container (controlled variable) is controlled via a 
valve (manipulated variable) using a PID controller. The operator specifies the 
setpoint. 

6. Extraction of the bottom product (“Heavy end”) 
The volume of the bottom product to be extracted depends on the filling level of the 
bottom and cannot be specified. For a stable operating point of the entire 
distillation column the volume of the bottom product to be extracted results from the 
following components: 
 The concentration of the heavy end in the fed substance mixture 
 The feed volume of the distillation column 

The filling level in the bottom of the column (controlled variable) and hence 
indirectly the flow rate of the heavy end are controlled via a valve (manipulated 
variable) using a PID controller. The operator specifies the setpoint. 
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Further functions 
Temperature and pressure display 
The distillation column contains 6 temperature displays and 2 pressure displays: 
 Temperature at the head of the distillation column 
 Pressure at the head of the distillation column 
 Temperature for regulating the head temperature 
 Temperature above the feed 
 Temperature below the feed 
 Temperature for regulating bottom temperature 
 Temperature at the bottom of the distillation column 
 Pressure at the bottom of the distillation column 

Specified concentration 
For the feed the concentration of the light end can be specified in relation to the 
heavy end. This concentration ratio is an undetected disturbance variable for the 
process. 
Operating point 
An SFC (step chain) brings the distillation column to the operating point after the 
controller has been started. 

Characteristic values (KPI = Key Performance Indicator) 
The following characteristic values are measured or calculated: 
 Production volume of the head product 
 Production volume of the bottom product 
 Pressure loss = Pressure at column bottom– Pressure at column head 
 Relative power consumption = Vapor volume / Production volume of head 

product 
 Reflux ratio: Reflux / Extraction of head product  

Operating time display 
The following operating displays are contained in the process picture: 
 Distillation column 
 Reflux motor  
 Head product motor 
 Bottom product motor 

2.2.3 Control concept 

For controlling the distillation process an MPC multi-variable controller is used 
which controls the head and bottom temperature (see also chapter Temperature ). 
These control variables are detected by the temperature process tags for head and 
bottom temperature. The controlled variables of the multi-variable controller are 
used as setpoint specifications for the underlying PID controllers. 
Both level controls of the distillation column are fitted with standard PID controllers 
and work automatically.  
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2.2.4 Piping and instrumentation diagram 

The figure below shows the individual components of a distillation column in the 
P&I (piping and instrumentation) diagram. 
Figure 2-3 
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2.3 Used hardware and software components 

The application is runnable as of SIMATIC PCS 7 V7.1 SP1. The following 
components are used for generating the application. 

Hardware components 
Table 2-1 

Component Note 
SIMATIC PCS 7 ES/OS 
547C BCE WXP 

Used for the PCS 7 V7.1 SP1 sample project 

SIMATIC PCS 7 ES/OS 
IPC547D W7 

Used for the PCS 7 V8.0 SP1 sample project 

 

Note If the hardware differs, please observe the minimum installation requirements of 
the software components. The minimum requirements are available in the 
readme file of PCS 7.  

 

Standard software components 
Table 2-2 

Component Note 
SIMATIC PCS 7 V7.1 SP1 Component of SIMATIC PCS 7 ES/OS 547C 

BCE WXP 
SIMATIC PCS 7 V8.0 SP1 Component of SIMATIC PCS 7 ES/OS 

IPC547D W7 
S7-PLCSIM  License is not part of SIMATIC PCS 7 ES/OS 

547C BCE WXP 
PCS 7 Advanced Process 
Library V7.1 SP3 

Component of SIMATIC PCS 7 V7.1 SP1 

PCS 7 Advanced Process 
Library V8.0 SP1 

Component of SIMATIC PCS 7 V8.0 SP1 

 

Example files and projects  
The following table contains all files and projects of this application document.  
Table 2-3 

Component Note 
48418663_DistillColumn _PCS7V711.zip PCS 7 V7.1 SP1 sample project 
48418663_DistillColumn _PCS7V7801.zip PCS 7 V8.0 SP1 sample project 
48418663_DistillColumn_en.pdf This document 

 

Note All procedures, descriptions and screenshots relevant for PCS 7 are based on 
the PCS 7 V7.1 SP1 and are applicable to the PCS 7 V8.0 SP1 without 
restrictions. The innovated faceplates of the APL V8.0 do not affect the way of 
operation of the equipment modules and are not described separately. 
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2.4 Performance data  

The following performance data are relevant for selecting the controller and for 
operating the process visualization on the OS.  

Application software 
The performance data was determined in ProTime by entering all used blocks. 
Additionally, the cycle times of the flow charts were taken into account.  
The following table shows the relevant basic performance data without basic CPU 
load and for selecting a CPU 416-3 PN/DP (6ES7416-3ER05-0AB0).  
Table 2-4 

Criterion Program Program + basic 
CPU load 

Reaction time (t/ms) CPU 
dependent 

83 

Buffer size (Mem/KB) 203 577 
Programmable block communication (PBK) 64 89 
Data block (DB) 113 113 
Process objects (AS RT PO) 39 39 

Visualization 
The 55 process objects (OS RT PO) required for visualization were determined in 
ProTime.  
 

Note The number of process objects is an average value valid for using the standard 
library of PCS 7. When using a different library (e.g. your own libraries) the 
required process objects and variables must be determined by yourself.  

 
 

Note The listed basic performance data do not contain any CPU reserves and were 
calculated on the PCS 7 V7.1 SP1 project. 

 



3 Basics 
3.1 Process engineering 

 

Distillation column 
V1.1, Entry ID: 48418663 17 
 

C
op

yr
ig

ht
 

 S
ie

m
en

s 
A

G
 2

01
3 

A
ll 

rig
ht

s 
re

se
rv

ed
 

3 Basics 
3.1 Process engineering 

3.1.1 Distillation column (rectification column) 

For distillation a multi-component mixture is divided into at least two streams using 
the different boiling temperatures of the components. The substance mixture 
(liquid) is fed into the column via a feed and vaporized at the bottom of the column.  
The gas mixture rises up inside the column where the substance mixture slightly 
cools down and starts condensing. At the bottom of the column (bottom) the 
component with a higher boiling temperature (heavy end) accumulates and can be 
removed. At the head of the column the component with a lower temperature (light 
end) accumulates and can be removed there. The balance between the heavy end 
and light end fractions shifts across the entire column.  
During rectification the gas mixture is fed back into the column via a reflux using a 
cooler. Opposing the ascending vapor, the reflux drips down over a number of 
trays where it is vaporized again. Rectification hence represents an expansion of 
the distillation process, or respectively a series connection of several distillation 
steps. 
 
Figure 3-1 
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3.1.2 Temperature profile 

The quality of a substrate separation is measured by the purity of the separation 
products, i.e. the concentration of light ends and heavy ends in the head and 
bottom extraction. Measuring these concentrations by means of online analyzers is 
extensive, so it is not performed in most of the plants. On the individual trays of the 
column there are thermo-dynamic correlations in the phase equilibrium (between 
vapor and liquid) and hence there is also a correlation between the concentrations 
and the temperatures.  
The easily measurable temperatures are used as substitutional controlled 
variables. The advantage is that the correlation between these temperatures and 
the control operations can be linearized more easily than the correlation between 
the concentrations.  
In the process design for the column an “s”-type, a vertical temperature profile is 
established within the column, which leads to the desired concentration profile, 
hence to the desired purity of the products. Two temperature process tags 
representative for the control are placed in the reinforcement and output part of the 
column. The following points should be taken into account: 
 The process tags should be located in those parts of the “s”-type profile with a 

significant temperature difference from tray to tray, so the process tags show a 
sensitive reaction to changes within the column (e.g. due to changes of the 
feed volume or the composition of the feed). 

 The dead times for temperature control increase with the distance of the 
process tag to head and bottom.  

The following figure shows the “s”-type temperature curve of a distillation column 
for two different temperature distributions. 
 
Figure 3-2 
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3.2 Automation technology 

3.2.1 The unit concept 

The term “unit” stands for a unit in process plants (plant component, device, 
machines) including sensors, actuators and respective automation software, which 
in this composition of the components is often required. The unit as a “type” is used 
as a template for creating many, differently configured instances. 
In process technology the so-called “package units” exist. Examples for “package 
units” are refrigeration plants, vacuum systems and packaging machines. Here the 
manufacturer of the mechanical process engineering device provides an 
automation software specifically designed for this device, which is located on a 
special hardware. The “package unit” is integrated as a whole into a process 
control system. The configuration of the control system does not require detailed 
knowledge of the automation of the “package unit”. 
As opposed to the “package units” the automation solutions for process plants are 
unified in the unit concept, prefabricated and generated in form of templates which 
do not or only partially require a special hardware. The templates only need to be 
adjusted to the existing hardware and the special requirements. This clearly 
reduces the engineering expenses for several similar automation tasks. 

Unit template 
In a unit template, process tags are combined into an automation function. All 
blocks relevant for a process tag are interconnected in a CFC chart. For naming 
the process tag a uniform name convention was used.  
Additionally, a unit template contains a CFC chart with economic and process 
engineering characteristics (Key Perdormance Indicators), a CFC chart for 
monitoring the operating time and CFC charts for simulation.  
The unit template is summarized in a hierarchy folder and can be integrated into 
existing projects. 

3.2.2 PLS engineering with templates 

A process tag type (template) in a process control system is a unified template for 
creating signal flow charts which occur several times during plant automation. The 
signal flow charts (CFC: Continuous Function Chart) for many process tags of a 
similar type are created by forming instances of a process tag type and must then 
be configured and connected with the concrete measured and manipulated values. 
Configuration and interconnection of the process tag types can be automated using 
an import/export file.  
A Unit Template in SIMATIC PCS 7 comprises all functions required for automating 
a unit:  
 CFC charts (instances of process tag types) 
 SFC charts  
 OS pictures  

All functions are summarized in a hierarchy folder of the technology view of the 
SIMATIC Manager. 
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3.2.3 KPI characteristics 

KPI characteristics (Key Performance Indicator) are economic or process 
engineering parameters which describe the course of production, the degree of 
performance for certain requirements or the quality of a plant. 

3.2.4 PID controller 

The PID controller is an industrial standard controller used for a linear, continuous 
control (e.g. filling level control). A typical application is regulating a controlled 
variable (e.g. filling level of a vessel) by means of a manipulated variable (e.g. 
feed). The filling level (controlled variable) is here regulated to a predetermined 
setpoint value (manipulated variable) via the feed, while various volumes can also 
drain off through several outlets. 
The series connection of PID controllers (cascading) enables improving the control 
results if apart from the main control variable a further intermediate variable can be 
measured. A master controller manipulates the main controlled variable, by 
defining setpoints for the subordinate slave controller which directly accesses the 
manipulated variable.  

3.2.5 MPC controller 

The MPC controller is a model predictive multi-variable controller (Model Predictive 
Control) for controlling complex, linear systems.  
If there are several manipulated and controlled variables in a unit, which interfere 
with each other, a multi-variable controller clearly yields better control results. The 
aim of the control is to direct each controlled variable to the individual setpoint, 
independent of the other controlled variables. This is even more difficult since 
interfering with a manipulated variable does not only effect one controlled variable 
but also has an impact on other controlled variables. 
A model predictive multi-variable controller additionally uses a complete 
mathematical description of the controlled system. This description enables the 
controller to calculate the process behavior over a defined period of time 
(“prediction horizon”) without controller operation. An optimization algorithm is 
applied to find the most efficient manipulated variable strategy and the planned 
optimal trajectory is calculated. There are several options for formulating the 
optimization problem. Future control deviation, CV constraints and future MV 
moves are included in the performance index as well as economic targets. 



3 Basics 
3.2 Automation technology 

 

Distillation column 
V1.1, Entry ID: 48418663 21 
 

C
op

yr
ig

ht
 

 S
ie

m
en

s 
A

G
 2

01
3 

A
ll 

rig
ht

s 
re

se
rv

ed
 

3.2.6 Linearization 

Many components in industrial plants do not have linear characteristic curves. 
When 50% of the valves are controlled the characteristic curve of many valves 
does not yield a flow rate of 50% of the maximum value. The larger the deviation of 
the flow rate from the linear characteristic curve, the worse the control result of a 
linear controller. Since the design of a non-linear controller is more difficult than 
that of a linear controller, the characteristic curves are normally linearized. 

Linearization in the operating point  
For linearization in the operating point (OP) not the entire characteristic curve is 
viewed but only the part of the curve which lies in the vicinity of the defined 
operating point and which is required during normal operation. A tangent is placed 
in the operating point of the characteristic curve and the deviation of the tangent 
from the characteristic curve is viewed.  
Figure 3-3 

Valve lift

Flow

OP

Deviation

lower limit upper limit

Linear characteristic line

Valve
characteristic line

Tangent
in OP

 
Using the tangent in the operating point the deviations between the actual non-
linear characteristic curve and the assumed tangent are reduced to the extend that 
in most cases the control parameters need not be adjusted. 
If a controller is designed for the operating range between lower and upper limit 
(operating range), the controller is then also only valid for this range. If several 
operating points of a characteristic curve are required, a controller can be designed 
for each operating point and, depending on the process value, the control 
parameters can be adjusted to the respective operating point. 

Linearization with smoothing function 
The linearization with a smoothing function is normally used if the operating range 
covers the largest part of the characteristic curve. For this linearization a 
polynomial is created which multiplied with the characteristic valve curve yields a 
linear function. The following graph shows how the smoothing function is 
determined mathematically or graphically. 
Figure 3-4 

Valve lift

Flow

Deviation

Linear characteristic line

Valve
characteristic line

Balancing function
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4 Structure and Principle 
4.1 Overview 

4.1.1 Name convention of the CFC charts 

A standard name convention was used for naming the process tags, with the 
function named after the European standard EN 62424. The following figure shows 
the composition of a process tag name. 
 
Figure 4-1 

FIC_Reflux

Function
F = flow rate (first letter)
I = indicate (subsequent letter)
C = control (subsequent)

Name

 
 
The following table specifies all letters used in the application and their meaning: 
 
Table 4-1 

First letter 

Letter Meaning 

F Flow  
L Level 
P Pressure 
T Temperature 

Subsequent letter 
I Indication 
C Control 
V Valve (Regulator function) 
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4.1.2 Plant view 

Unit template “Distillation column” is realized in the plant view in two hierarchy 
folders.  
The first hierarchy folder of the OS project contains the overview picture 
“DistillationGroup.pdl” of the distillation column and a further hierarchy folder. The 
subordinate hierarchy folder contains the process picture. In the AS project the first 
hierarchy folder is empty and the subordinate hierarchy folder contains a sequential 
control (SFC chart) for starting the column as well as all of the required CFC 
charts. 
 
Figure 4-2 
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4.2 Structure of process tag charts 

4.2.1 Charts “FIC_xxx”, “TIC_xxx”, “LIC_xxx”, “PIC_xxx” 

The following process tags are structured according to the same principle: 
 FIC_Feed 
 FIC_Reflux 
 FIC_Vapor 
 LIC_Bottom 
 LIC_RefluxDrum 
 PIC_ColuHead 

The following figure shows the CFC chart “FIC_Feed”: 
 

Figure 4-3 

Subchart “A” Subchart “B”

Sheet 1

Sheet 2

Sheet 3

Sheet 1

Sheet 2

 
 

Subchart A 
In sheet 1 the PID controller “PIDConL” block (left block) is interconnected with the 
“ConPerMon” block (right block) used for permanent monitoring of the control 
performance.  
 
Sheet 2 contains a block which is not contained in the APL or the standard library. 
This block provides an interface with SFC “StartDistColumn”, which simplifies the 
SFC connection. The logic blocks control the operating mode of the PID controller.  
Sheet 3 contains the interlock block. 
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Subchart B 
Sheet 1 contains the following blocks:  
 PV (“Pcs7AnIn”): driver block for signal processing of an analog input value 
 Sim (“SimAn”): simulation block 
 Sqrt (“SwSqrt”): linearization block 

At the “PV_In” input of the driver block the real process value must be 
interconnected. For more information, please refer to Table 5-3. 
Sheet 2 contains the following blocks.  
 Pcs7AnOu: driver block for signal processing of an analog output value 
 Or04 block for the field device status and the process value validity 

At the “PV_In” input of the driver block the real process value must be 
interconnected. For more information, please refer to Table 5-3. 

4.2.2 “TI_xxx” charts 

In subchart “A” the following CFC charts contain a “MonAnL” block for monitoring 
an analog process tag, and in subchart “B” the “Pcs7AnIn” block with a simulation 
block: 
 TI_Head 
 TI_HeadControl 
 TI_AboveFeed 
 TI_BelowFeed 
 TI_BottomControl 
 TI_Bottom 

4.2.3 “FV_x” charts 

The following CFC charts are structured according to the same principle: 
 FV_Bottom 
 FV_Distil 
 FV_Reflux 

Subchart A 
Sheet 1 contains a motor block for controlling a pump motor and an operating 
hours counter. 
Sheet 2 contains interlock and logic blocks for external modules of the pump (e.g. 
motor protection switch). 

Subchart B 
Sheet 1 contains a simulation block for external modules, a driver block for the 
“Feedback” input of the pump as well as the respective logic block. 
Sheets 2 and 3 contain driver and logic blocks for external modules. 
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4.2.4 “TIC_DistBottom” chart 

Sheet 1 contains the multi-variable controller and four logic blocks, which generate 
the logic for the status (quality code and service) of the controlled variable driver 
blocks. 
Sheet 4 contains a block for each controlled variable for monitoring the control 
quality and a block for displaying the temperature deviation of the controlled 
variable from the setpoint. 
Sheet 5 contains a logic block which, if necessary, suppresses the calculation of 
the control performance for the filling level control at the bottom. 
 

4.3 “StartDistColumn” SFC chart 

This SFC chart is necessary since all controls for the non-linear processes are 
linearized in the operating point and so they are not suitable for starting the plant. 
The following actions are configured in the SFC chart:  
 Resetting the simulation 
 Initialization of the controllers 
 Initialization of the SFC connection 
 Operating mode of the pumps to automatic mode 
 Initialization of the “ConPerMon” block for monitoring the control performance 
 Suppression of messages (MsgLock = 1) during the startup of the plant (only 

available in the PCS 7 V8.0 SP1 project)  
 
After reaching the operating point of the distillation column, the “ConPerMon” 
blocks of the subsequent process tags are initialized after approx. 5 minutes with 
the SFC chart: 
 FIC_Feed 
 LIC_RefluxDrum  
 LIC_Bottom  
 PIC_ColuHead 

 

Note The “ConPerMon” blocks of process tags “FIC_Reflux” and “FIC_Vapor” are not 
initialized due to the cascaded control.  
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4.4 Setup of the simulation 

The simulation of the process runs in a time OB whose cycle time is 5 times slower 
than the cycle time of the template. Furthermore, the simulation model of the 
sample distillation column is adjusted so the time sequence is shortened in 
comparison to a real plant to receive a faster reaction to a manipulated value 
change (“fast motion”). 
The simulation contained in the template consists of the following parts: 
 Simulation in process tags “FIC_xxx”, “TI_xxx” and “PI_ColuBottom” 
 Calculating the temperature values (CFC chart “SimControlTemp”) 
 Integrations restriction (CFC chart “SimAntiWindUp”) 
 Simulation of the process (CFC chart “SimProcModel”) 
 Simulation of the transmission functions (CFC chart “SimController”) 

Simulation in process tags “FIC_xxx”, “TI_xxx” and “PI_ColuBottom” 
Process tags “FIC_xxx”, “TI_xxx” and “PI_ColuBottom” contain maximal two 
simulation blocks. The “Sim” block receives the simulated process value and also 
offers the possibility of scaling the process value. Scaling is not part of this 
template. 
The “Sqrt” block calculates the square root from the process value and can be 
used as balancing function for squared process values. In this template the block is 
deactivated. 
 

Calculating the temperature values (CFC chart “SimControlTemp”) 
In CFC chart “SimControlTemp” the standardized temperatures of 
“TI_HeadControl” and “TI_BottomControl”, used in the simulation model are 
converted into degrees Celsius, so the values can be displayed in the process 
tags. 

Integrations restriction (CFC chart “SimAntiWindUp”) 
CFC chart “SimAntiWindUp” serves as integration restriction for integral 
transmission functions of the process model. This CFC chart is employed in CFC 
chart “SimProcModel” (chart in chart technology). 

Simulation of the transmission function (CFC chart “SimController”) 
CFC chart "SimController" simulates the transmission functions which prompt the 
PID controller to compensate. The transmission function consists of the following 
components: 
 "Mul04" block to reinforce the transmission function 
 "Lag" block to smooth the input variable after a delay time 

Both blocks yield a PT1 transmission function. For simulating the pressure in the 
column head "PIC_ColuHead" an additional "NoiseGen" block was interconnected. 
This block creates a signal noise.  
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Simulation of the process (CFC “SimProcModel”) 
The process model is a 6x4 multi-variable system which simulates all mutually 
interfering input-output combinations in individual partial transmission functions. 
The simulation is designed for the operating point of the process. 
The figure below shows the process model with the respective names. 
 

Figure 4-4 

u1 u2 u3 u4 u5 u6
y1 G1,1 G1,2 G1,3 G1,4 G1,5 G1,6

y2 G2,1 G2,2 G2,3 G2,4 G2,5 G2,6

y3 G3,1 G3,2 G3,3 G3,4 G3,5 G3,6

y4 G4,1 G4,2 G4,3 G4,4 G4,5 G4,6

Reflux Vapor Distill. Flow Bottom Flow Flow Inlet Concentr. Inlet
L V D B F zF

xD y1u1 y1u2 y1u3 y1u4 y1u5 y1u6
xB y2u1 y2u2 y2u3 y2u4 y2u5 y2u6
mD y3u1 y3u2 y3u3 --- --- ---
mB y4u1 y4u2 --- y4u4 y4u5 ---

Concentr.Distillation 
Concentr.Bottom 
Level Distillation
Level Bottom

General Model

Process Model (with name in the CFC chart)

Inputs

O
ut

pu
ts

 

The process model is in CFC chart “SimProcModel” divided into two subcharts.  

Subchart A 
Subchart “A” contains partial transmission functions of an input signal which 
influence defined output signals (Figure 4-4). All partial transmission functions are 
structured according to the same principle where unnecessary function 
components do not exist.  
The following figure shows sheet 1, which contains the influences of the input 
signal “Reflux” (L) on all output signals. 
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Figure 4-5 

1

2 3

4

5
6

3

 
A partial transmission function may contain up to six components which are 
illustrated in a partial transmission function with PT behavior “y1u1” (components 1, 
2, 3) and a partial transmission function with IT behavior “y4u1” (components 1, 3, 
4, 5, 6). 
The following components can be contained in a partial transmission function: 
1. Deviation from the operating point 

At this block the operating point of the input is specified and the difference to it 
is calculated. Some input values are standardized beforehand in order to 
facilitate the calculation with various physical variables. 

2. Dead time 
Specifies the dead time of the partial transmission function. 

3. PT transmission function (chart in chart) 
Three delay elements and one reinforcement element are connected in 
succession. Additionally a noise can be added to the output signal. 

4. Sign 
Determines the sign of the integrator. 

5. Delimiting the integration (“SimAntiWindUp” as chart in chart) 
The input signal for the integrator is previously checked for exceeding or falling 
short of the limits and, if necessary, the integration of the output value is 
stopped (output signal). 

6. Integrator 
The integrators are used for filling level simulations. 

Subchart B 
In subchart “B” the output signals are calculated from all intermediate values of the 
individual inputs. First all influences of the inputs are added up to one output. The 
output can be limited depending on the defined ranges. Subsequently, the 
standardization of the outputs (only for filling levels) is cancelled. 
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5 Configuration and Settings 
5.1 Using the sample solution 

Preparation 
The following instructions contain the integration of the unit template into a PCS 7 
project in which the following steps are completed: 
 Adjusting HW Config 
 Configuring the communication between AS and OS (NetPro) 
 Settings at the hierarchy folders 

Table 5-1 

No.  

1.  Copying the “48418663_DistillColumn _PCS7V711.zip” file to the configuration computer and 
subsequently opening the SIMATIC Manager. 

2.  Click “File > Retrieve” and select the “48418663_DistillColumn _PCS7V711.zip” file. Then confirm 
by clicking “Open”. 

3.  Select the folder in which the project is saved and acknowledge with “OK”. 
The project is extracted. 

4.  In the “Retrieve” dialog you click the “OK” button and then click “Yes” in the dialog to open the 
project. 

5.  Go to the Plant View 
6.  Parallel you open the project in which the template is to be integrated. 
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Integration of the unit template  
The following instruction describes how you can integrate the unit template into 
your project. The interconnection of each individual signal and the settings of each 
individual parameter are not described here. It is illustrated how you can integrate 
the simulation into your project and how you can effectively interconnect the copied 
unit template to your process. 
The opened unit template and the opened target project in the Plant view are 
required. 

Table 5-2 

No. Action 

1.  In the plant view of the unit template in the OS project you select the hierarchy folder “ChColumn 
> DistillationGroup” and click on “Edit> Copy”. 

2.  Go to the target project. 
In the OS project you select the hierarchy folder to which the distillation column is added and then 
click “Edit > Paste” in the menu bar.  
The hierarchy structure with the overview picture and the process picture is copied. 

 
3.  In the target project you select the OS project and in the menu bar you click on “Options > Plant 

View > Update in the Multiproject”. 
The dialog for exporting the Plant Hierarchy appears. 

4.  Acknowledge the dialog with “OK” and also confirm the following dialog with “OK”. The plant 
hierarchy is adjusted in all AS projects of the target project. 

5.  Go to the unit template and click the hierarchy folder “ChColumn > DistillationGroup > Distillation” 
in the AS project of the tree view. 

6.  In the menu bar you click “Edit > Select all” and then click on “Edit > Copy”. 
7.  Go to the target project. 

In the tree view of the AS project you select the hierarchy folder “DistillationGroup > Distillation” 
and in the menu bar you click “Edit > Paste”.  

 
Note: 
All charts of the unit template and the simulation are copied. 

8.  Compile the AS project and then the OS project. 
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Adjust the parameters of the unit template  
The following instruction shows how to configure the entire unit template. For the 
operability of the simulation no settings need to be made. 
The opened target project is a prerequisite. 

Table 5-3 

No. Action 

1.  Go to the process object view and click on the “Parameter” tab. 
2.  In the dropdown menu you select the “Filter by column” entry and enter the chart name (e.g. 

FIC_Feed) into the “Display” input field.  
Note: 
The button with the double arrow pointing down, next to the deactivated input field “Filter general” 
opens a second filter. With this filter you can, for example, filter for all connections in the “I/O 
name” column containing “PV” which have an impact on the process value. 

 
3.  Click into the “Value” column of the block connection you wish to change and enter the new value. 

Acknowledge the input with the input button. 

 

Interconnect the unit template 

The opened target project is a prerequisite. 
Table 5-4 

No. Action 

1.  Open the "Signals" tab in the process object view. 
2.  Right-click the "Signal" column of the signal you wish to interconnect and select the "Insert signal" 

command.  
Note: 
This column already contains the most important signals. 

3.  In the dialog you open the folder structure and subsequently click on “Inputs” or “Outputs”. 
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No. Action 

4.  In the Details view you select the signal you wish to interconnect and click on the “Apply” button. 

 
Note: 
If you wish to interconnect several signals, then click on a further signal in the process object view 
and repeat this step. 

5.  Click on the “Close” button to close the dialog. 

 

Integrating the central color palette of the unit template into the OS 
The process picture of the unit template uses colors from the central project 
palette. In the target project the colors of the palette must also exist, otherwise the 
colors of the color palette are represented as black. 
The colors for cooling water (blue, position 10), vapor (red, position 11), medium 
(violet, position 12), text frame (gray, position 15) and frame font: (gray, position 
16) are defined in the project palette. 
 
The opened target project is a prerequisite. 

Table 5-5 

No. Action 

1.  Go to the component view and open the tree view of the OS project. 
2.  Open the OS project. 
3.  Click the OS name with the right mouse button and select “Properties” from the context menu. 
4.  In the “Properties” you select the “User Interface and Design” tab and then click the “Edit” button in 

the “Central Color Palette” area. 

 
5.  In the Color selection dialog you click on the “Import palette” icon. 
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No. Action 

6.  In the file selection dialog you select “DistillColumn.xml” from the 
<Projektpfad>\ChColumn\ChColu_2\wincproj\OS\GraCS \DistillColumn.xml> path and 
acknowledge with “Open”. 
Note: 
The unit template uses colors 10 to 16 of the project palette in the process picture. If you are 
already using these positions, cancel the import of the color palette and change the colors of the 
pipes in the process picture. 

7.  In the message you click “Yes”, in order to overwrite the existing color palette and then close the 
Color selection and the Project properties dialog with “OK”. 

 

5.2 Configuration of the PID controllers 

For the configuration of the PID controllers the program “PID Tuner” is available. 
This program determines the optimal PID parameters for the connected controlled 
system. The following instruction describes the general procedure at the example 
of the PID controller in the CFC chart “FIC_Feed”. 
  

Note A practical example for the operation is shown in the document “PID Control with 
Gain Scheduling and PID Tuning” 

 

Prerequisites 

 The controller is connected to the process or the simulation. 
 The control program is compiled and downloaded. 

ATTENTION An intervention in the plant process occurs through optimization. You 
have to be aware of the consequences this might have. 

To receive an optimal result, perform the controller optimization between 
the minimal and maximal manipulated values of the respective parameters 
(for FIC_Feed: 15-25). 

Continuously monitor the process at the curve plotter during optimization. 

 

 

http://support.automation.siemens.com/WW/view/en/38755162
http://support.automation.siemens.com/WW/view/en/38755162
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Settings at the block 
The “PID Tuner” program is always executed on the Engineering Station (ES). 
Since the operator control and monitoring station (OS) and the ES normally do not 
run on the same computer, a coordination of the users is offered by the PCS 7 
system. The enable is given in the operator picture of the controller (View > 
Parameter). This enable gives the Engineering system (PID Tuner) the right to 
actively interfere with the process. During optimization the respective operating 
options on the OS are blocked.  
 
To be able to use the “PID-Tuner” program, value “1” must be pending at the 
“OptimEn” input of the “PIDConL” block. If you wish to set this input in ES, execute 
the steps 1 to 5. If an enable on the OS was granted, start with step 1 of Table 5-7. 

Table 5-6 

No. Action 

1.  Open the PCS 7 project in the Plant View. 
2.  Open the hierarchy folder “ChColumn > DistillationGroup > Distillation” and double-click on the 

“FIC_Feed” chart.  
The CFC editor is opened. 

3.  In the menu bar of the CFC Editors click “Debug > Test Mode” and acknowledge the “Register 
CPU for testing” dialog with “Yes”. 

4.  Double-click block “C” in sheet 1 of the CFC chart and click on the “Connections” tab. 
5.  Change the value of the “OptimEn” connection to value “1” and acknowledge with “OK”. Then 

close the block. 
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Performing controller optimization 
The following instruction describes a controller optimization for a controlled system 
with PT behavior. 
 

Table 5-7 

No. Action 

1.  In the menu bar of the CFC editors you click on “Edit > Optimize PID controller…”.  
The PID tuner opens. 

2.  In the curve plotter you click “Stop” to stop the recording and then click the “Settings” button. 

 
3.  For the 3 curves (setpoint, actual value, manipulated value) you specify suitable limits for the 

Y axis. 
4.  Adjust the “Recording cycle” and the “Length of the time axis” to the expected process behavior 

and acknowledge the input with “OK”. 
Note: 
The online help offers detailed information on controller optimization. In the bottom part of the PID 
tuner you click the “Help” button to open the online help. 

5.  In the bottom part of the PID tuner you click the “Start Controller Optimization”. 
6.  In step 1 you click the radio button “without integral action in the process” and then click on “Next”. 
7.  In the “Operating mode” group you select the checkbox “Automatic”. As a start point you enter the 

typical operating point of the controlled variable. Please note the warning in the bottom part of the 
dialog and then click on “Next”. 

8.  As “Step trigger, new setpoint:” you specify a setpoint value clearly above the typical operating 
point. Please note the warning in the bottom part of the dialog and then click on “Next”. 
The controller optimization is now started. 

9.  After completing the optimization in the “Process trigger” group you select the checkbox “Reset”. 
Please note the warning in the bottom part of the dialog and then click on “Next”. 

10.  In the “Controller design for” group you select the “Optimal control response” box and click “Next”. 
An additional window with the result of the identification is opened. 
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No. Action 

11.  In the “Controller parameter” group you select the checkbox of the PI controller and click on 
“Next”. 

12.  In step 8 you click “Simulate a control loop with the optimized parameters” and on “Next”. 
13.  Click the “New” button to accept the determined values. 

Please note the warning in the bottom part of the dialog and then click on “Finish” to complete the 
optimization. 

 

5.3 Configuration of the MPC controller 

Preparations 
The basis for the controller design are step responses recorded in manual 
controller mode and displayed in trend curves. These trend curves show all excited 
manipulated variables and all controlled variables. The excitement of the controlled 
variables starts in the operating point and contains a step to the upper limit value 
and to the lower limit value (linearization in the operating point) of the typical 
manipulated range for the plant operation. Each change of the manipulated 
variable is only performed after the system has reached a steady state. The same 
procedure can be used for measurable disturbance variables. These can be taken 
into account in the controller design.  
Additionally trend curves for verifying the controller design can also be evaluated. 
The required tend curves can be created in the CFC trend display and be exported. 
Further information is available in the Help of the MPC configurator in “The 
individual design steps in detail > Recording the measurement series”. 

Note A detailed description is available in the application example “Model Predictive 
Control including integral transfer functions”. 

 
 

ATTENTION Coordinating the MPC controller requires intervention into the process! 

Before the process intervention, please check the effects this intervention 
might have and inform the respective staff. 

 
 

http://support.automation.siemens.com/WW/view/en/42200753
http://support.automation.siemens.com/WW/view/en/42200753
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System identification 
 

Table 5-8 

No. Action 

1.  Open the PCS 7 project in the Plant View. 
2.  Open the hierarchy folder “ChColumn > DistillationGroup > Distillation” and double-click on the 

“TIC_DistBottom” chart.  
The CFC editor is opened. 

3.  Select the “ModelPredictCont” block and click on “Edit > Configure MPC” in the menu bar. 
The MCP configurator opens. 

4.  Click the “Load data” button and select the file with the exported trend curves. Confirm your 
selection with “OK”. 
The selected trend curves are loaded to the “Raw data” group. 
Note: 
Click on the “Help” button to receive detailed information on the functioning of the MPC 
configurator. 

5.  In the drop-down list on the right next to the trend display you select the represented signal and 
activate the “Process with dead times” checkbox. 

 
Then click on the “Identify” button. The “MPC process model” dialog box opens. 
Note: 
In the “Parameters” group a period of time can be defined. 

6.  Repeat steps 4 and 5 for the trend curve of the disturbance variable. 
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No. Action 

7.  In the “Parameters” group you enter the sample time (the OB cycle time, in which the controller is 
called up) and the DB number for the process model. 

 
Then click on the “Design controller” button. The “MPC – verification and simulation” dialog box 
opens. 
Note: 
In the top left corner of the “MPC – process model” dialog the quality of the trend curve is 
displayed. The quality for a controller design should be larger than 50%. 

8.  In the “Verification of the process model” group you click on the “Load data” button and select the 
file with the verification data in the opened file selection dialog. 
The verification is started and the quality of the process model is displayed. 

 
9.  Click the “Simulate control loop” button to check the value range. 

Subsequently, the result between button and trend display is evaluated and can also be viewed by 
clicking the trend display. 

10.  Click on the “Export SCL code” button and select the folder for saving the SCL source in the 
subsequent file selection dialog. 
Enter a name for the file and click “Save”. 

11.  Confirm the message with “OK” and close all dialogs of the MPC configurator and the CFC chart. 
12.  Save the Session memory of the MPC configurator by right-clicking on the background of the 

operator user interface. 
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Process model introduced to the block 
 

Table 5-9 

No. Action 

1.  Go to the components view of the project. 
2.  Right-click on “ChColumn_AS_Prj > AS01 > CPU 417-4 > AS01 > Sources” and select “Insert 

New Object > External Source…”. 
3.  Select the previously created SCL source and click “Open”. 

The SCL source is imported. 
4.  Double-click the SCL source and click on “File > Compile” in the menu bar of the opened SCL 

editor. Then close the SCL editor. 
Note: 
In the first line of the source code you see the DB number of the created block. 
Attention: 
If a data block with DB number exists, you receive a message whether you wish to overwrite the 
data block. Only overwrite data blocks whose function you know exactly. If in doubt cancel the 
compilation process and change the DB number of the first line into a not yet assigned DB 
number. 
The MPC function block must be called in the suitable watchdog interrupt OB. The cycle time of 
the OB and the specified time “OB-Timing” in the header of the SCL source must be identical. 

5.  Right-click on “ChColumn_AS_Prj > AS01 > CPU 417-4 > AS01 >Charts” and double-click on the 
“TIC_DistBottom” chart which contains the MPC controller. 

6.  Double-click on the “DB_No” input and change the value in the connection properties to the 
number of the previously created data block. 

 

 

Note The process model is updated at the next compilation and download of the 
controller. 

If the control program has already been downloaded, the DB number can also be 
changed online. The DB must be loaded to the controller and the “Restart” input 
be set to “Reset” online. After restarting the controller jumps of the manipulated 
variable may occur. 
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6 Starting the Unit Template 
6.1 Preparation 

The following instruction describes the commissioning of the unit template in which 
the controller is simulated with the “S7-PLCSIM” program. If a real controller is 
used you must adjust the hardware settings in HW Config beforehand.  

Table 6-1 

No. Action 

1.  Copy the “48418663_DistillColumn _PCS7V711.zip” file to any folder on the configuration 
computer and subsequently opening the SIMATIC Manager. 

2.  Click “File > Retrieve” and select the “48418663_DistillColumn _PCS7V711.zip” file. Then confirm 
by clicking “Open”. 

3.  Select the folder in which the project is saved and acknowledge with “OK”. 
The project is retrieved. 

4.  Acknowledge the “Retrieve” dialog with “OK” and then click “Yes” in the dialog to open the project. 
5.  Right-click on “ChColumn_OS_Prj > PCS7VM > WinCC Appl. > OS” and click on the menu 

command “Open object”. 
6.  Acknowledge the “The configured server is not available” dialog with “OK”. 
7.  In WinCC Explorer you open the properties of your computer and click “Use Local Computer 

Name”. 
Acknowledge the “Change computer name” message with “OK”. 

 
8.  In the WinCC Explorer you click on “File > Exit” and in the following dialog you select “Close 

project and exit WinCC Explorer”.  
Acknowledge with "OK". 

9.  Open the WinCC Explorer again as described in step 5. 
10.  In the WinCC Explorer you right-click on “OS > Tag Management > SIMATIC S7 PRO… > 

Industrial Ethernet” and select the menu command “System Parameter”. 
Note for PCS 7 V8:  
Please double-click  on the "Tag Management".  
Please right-click in the “WinCC Configuration Studio” on “SIMATIC S7 Protocol Suite > Industrial 
Ethernet” and select the menu command “System Parameter”. 

11.  In the “Unit” tab you check the set “Logical device name”. When using the “S7-PLCSIM” the 
device name PLCSIM(ISO) is selected. Changing the device name requires a restart of the 
program. Open the WinCC Explorer again as described in step 5. 
Note for PCS 7 V8:  
If a connection between the OS and AS can't be established (gray block icons), please select the 
"Logical device name" "CP_H1_1" and restart the OS. 
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6.2 Commissioning 

The following instruction shows how the unit template is set to initialization mode. 
The project contains a SFC chart where all the important settings are configured so 
the plant reaches the operating point.  
 
Commissioning requires that the SIMATIC Manager has already been opened and 
the unit template is selected in the components view. 

Start simulation (S7-PLCSIM) 
To start the simulation, proceed according to the instruction: 

Table 6-2 

No. Action 

1.  Select “Options > Simulate Modules” from the menu. 
The dialog window of “S7-PLCSIM” opens. 

2.  In the “Open project” dialog you select the “Open project from a file” option. 
3.  Select the “ChColumn.plc” file from the path <project path>\ChColumn\ChCo_Prj\ ChColumn.plc> 
4.  Select “Execute > Key position switch > RUN-P” from the menu. 
5.  Go to the components view of the SIMATIC Manager and select “ChColumn_AS_Prj > AS01”. 
6.  In the menu bar you click on “PLC > Download” and acknowledge the “Download” with “Yes”. 

Acknowledge the “Stop Target Module” dialog with “OK” and subsequently the “Download” dialog 
with “Yes”. 

 

Note During the startup behavior of the distillation column simulation the focus was not 
on a correct startup of the column with regards to process engineering since this 
is very plant-specific. The startup control in the unit template is therefore not 
suitable for starting up a real plant. 

The startup of the column simulation takes approx. 6 minutes until the plant has 
reached the operating point. 
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Activating OS (WinCC Runtime) 
To activate the OS, proceed according to the following instruction: 

Table 6-3 

No. Action 

1.  Make a right mouse click on the OS and select the “Open Object” menu.  

 
2.  To activate the OS (WinCC Runtime), select “File > Activate” in the WinCC Explorer menu. 

3.  In the “System Login” dialog you enter the user “Unit” as a “Login” and the password “Template” 
and acknowledge with “OK”. 

4.  In the picture section you click on the entry “DistillationGroup” and then click on the “Process-
Picture” button. 
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Initialization of the control performance monitoring 
The initialization of the control performance monitoring (“ConPerMon” blocks) of 
the multi-variable controller is possible approx. 15 minutes after starting the CPU. 
For initialization of the control performance monitoring you proceed according to 
the following instruction: 

Table 6-4 

No. Action 

1.   In the picture section of the OS you click the entry “DistillationGroup”.  
The overview picture is displayed. 

2.   In the overview picture you click on block icon “ModPreCon_CPM1”. The respective block is 
opened. 

 
Note: 
In the faceplate the operator receives the information “CPI invalid”.  

3.   Go to the setpoint menu and wait until the evaluation has been completed. 

 
Note: 
The initialization process can only be started after a completed evaluation.  

4.   Go to the parameter menu and press the “Initialize” button.  

 
 

5.   Repeat steps 2 to 4 for block icon “ModPreCon_CPM2”.  
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7 Operation of the Application 
7.1 Overview  

Via the process picture all components of the distillation column can be operated 
and monitored. The following two scenarios are restricted to the two parameters 
which are mainly relevant for operating a distillation column and the operation of 
the multi-variable controller for compensating disturbing influences. 
 Scenario A: changing the feed volume 
 Scenario B: changing the feed concentration 

In both scenarios one respective parameter is changed which works as disturbance 
variable for the controller. 

7.2 Scenario A: changing the feed volume 

Description 
In a stable state the distillation column the feed volume and the feed concentration 
determine the extracted volume of the head or bottom product. In this scenario the 
concentration of the light end in the fed substance mixture is constant and the feed 
volume is increased from 20 L/min to 23 L/min (+15%). The feed volume is 
detected as disturbance variable by the controller (DV1 input) and the effect of the 
disturbance variable is known in the process model. 

Table 7-1 

No. Action 

1.  Click on the block icon of the “ModelPredictCont” block and click on the trend icon in the menu bar 
of the faceplate.  

2.  Click on the block icon of “FIC_Feed” also in order to open its faceplate. Align the windows for a 
clear overview. 

 
3.  Click on the input field “Setpoint” in the “FIC_Feed” block and enter value“23” in the input field of 

the expansion. Acknowledge the input with the Enter key and click on the “OK” button. 
The setpoint value for the feed is adopted and the multi-variable controller starts controlling the 
detected disturbance variable. 

4.  Wait approx. 4 minutes and click on the “Start/Stop” icon to evaluate the control result. 
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Evaluation 
The figure below shows the trend curve of the multi-variable controller. 
 
Figure 7-1 

approx. -0.05°C

approx. +0.06°C

Head control temperature

Bottom control temperature

 
 
The low deviation of approx. 0.06°C shows a good control result, which is 
explained by the detected disturbance value and the known influence of the 
disturbance value to the controller. The controller can immediately react to the 
changed disturbance variable with the required operations and needs not wait for 
changes of the controlled variable. 
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7.3 Scenario B: changing the feed concentration 

Description 
In a stable state of the distillation column the feed volume and the feed 
concentration determine the extracted volume of the head or bottom product. In 
this scenario the feed volume is constant and the concentration of the light end in 
the fed substance mixture is reduced from 0.5 to 0.4 (-20%). 
The concentration of the light end in the fed substance mixture is an unknown 
disturbance variable for the controller which is not detected in the model. 

Table 7-2 

No
. 

Action 

1.  Click on the block icon of “ModelPredictCont” and click on the trend icon in the menu bar of the 
faceplate. 

2.  Click on the block icon of “FeedComposition” also in order to open its faceplate. Align the windows 
for a clear overview. 

1

2

 
3.  Click on the input field “Setpoint” in the faceplate of “FeedComposition” and enter value “0.4” in the 

input field of the expansion. Then acknowledge the input with the “Enter” key and click on the “OK” 
button. 
The setpoint for the concentration of the light end in the fed substance mixture is adopted and the 
multi-variable controller starts compensating the disturbance variable. 

4.  Wait approx. 4 minutes and click on the “Start/Stop” icon to evaluate the control result. 

 



7 Operation of the Application 
7.3 Scenario B: changing the feed concentration 

 

48 
Distillation column 

V1.1, Entry ID: 48418663 
 

C
op

yr
ig

ht
 

 S
ie

m
en

s 
A

G
 2

01
3 

A
ll 

rig
ht

s 
re

se
rv

ed
 

Evaluation 
The figure below shows the trend curve of the multi-variable controller. 
 
Figure 7-2 

approx. +0.5°C approx. +0.6°C

Head control temperature

Bottom control temperature

 
The low deviation of 0.6°C shows a good control result since the size and effect of 
the disturbance variable is not known to the controller and the controller can only 
react to changes of the controlled variables. 
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8 Links & Literature 
Literature 

The following list is by no means complete and only provides a selection of 
appropriate sources. 
 
Table 8-1  

 Topic Title 

/1/ STEP7 Automating with STEP7 in STL and SCL 
Hans Berger 
Wiley-VCH 
ISBN 3895782955 

 

Internet links 
The following list is by no means complete and only provides a selection of 
appropriate sources. 
 
Table 8-2  

 Topic Title 
\1\ Reference to this entry http://support.automation.siemens.com/WW/view/en/4841

8663 

\2\ Siemens Industry Online 
Support 

http://support.automation.siemens.com 

\3\ SIMATIC PCS 7 Overview – 
Landing Page 

http://support.automation.siemens.com/WW/view/en/6348
1413 

\4\ PCS 7 V8.0 SP 1 Manual 
Collection 

http://support.automation.siemens.com/WW/view/en/7117
8283 

\5\ Application for model-based 
predicative control 

http://support.automation.siemens.com/WW/view/en/4220
0753 

\6\ Controller optimization with 
PID tuner 

http://support.automation.siemens.com/WW/view/en/8031
495 

\7\ SIMATIC Process Control 
System PCS 7 Compendium 
Part A – Configuration 
Guidelines 

http://support.automation.siemens.com/WW/view/en/6318
7279 

\8\ SIMATIC Process control 
system PCS 7 Compendium 
Part C – Technical functions 
with SFC types 

http://support.automation.siemens.com/WW/view/en/6318
7297 

\9\ ProTime PCS 7 – the 
configuration tool for 
SIMATIC PCS 7 

https://www.automation.siemens.com/mcms/process-
control-systems/en/distributed-control-system-simatic-pcs-
7/supply-tool/Pages/protime.aspx 

\10\ SIMATIC Process Control 
System PCS 7 Advanced 
Process Library (V8.0 SP1) 

http://support.automation.siemens.com/WW/view/en/6815
4793 

 

http://support.automation.siemens.com/WW/view/en/48418663
http://support.automation.siemens.com/WW/view/en/48418663
http://support.automation.siemens.com/
http://support.automation.siemens.com/WW/view/en/63481413
http://support.automation.siemens.com/WW/view/en/63481413
http://support.automation.siemens.com/WW/view/en/71178283
http://support.automation.siemens.com/WW/view/en/71178283
http://support.automation.siemens.com/WW/view/en/42200753
http://support.automation.siemens.com/WW/view/en/42200753
http://support.automation.siemens.com/WW/view/en/8031495
http://support.automation.siemens.com/WW/view/en/8031495
http://support.automation.siemens.com/WW/view/en/63187279
http://support.automation.siemens.com/WW/view/en/63187279
http://support.automation.siemens.com/WW/view/en/63187297
http://support.automation.siemens.com/WW/view/en/63187297
https://www.automation.siemens.com/mcms/process-control-systems/en/distributed-control-system-simatic-pcs-7/supply-tool/Pages/protime.aspx
https://www.automation.siemens.com/mcms/process-control-systems/en/distributed-control-system-simatic-pcs-7/supply-tool/Pages/protime.aspx
https://www.automation.siemens.com/mcms/process-control-systems/en/distributed-control-system-simatic-pcs-7/supply-tool/Pages/protime.aspx
http://support.automation.siemens.com/WW/view/en/68154793
http://support.automation.siemens.com/WW/view/en/68154793
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9 History 
 
Table 9-1  

Version Date Changes  

V1.0 11.02.2011 First issue 

V1.1 04.06.2013 Valid for PCS V7.1 SP1 and PCS 7 V8.0 SP1, new links 
added, minor changes in the description   
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Appendix 
Block description “SwSqrt” 

Function description 
The square root function does not correct the non-linear signal band of a squared 
signal. The block has one operating mode without (mode 1) and one with low value 
suppression (mode 2). Simulation and substitution values are performed without 
change. 
The square root function is activated by changing the MODE input to 1 or 2. For 2 
the signals are suppressed under the LSUPLEVL (=LRANGE). 

Operating modes 
During the simulation (SimMode = 1) the status of the input signal is ignored. 
 

No. MODUS Scale IN QUALITY OUT 

1.  <1 
>2 

all all all OUT = IN 

2.  all all all 16#48 
16#60 

OUT = IN 

3.  1 
or 
2 

Scale.Low 
< Scale.High 

all all OUT = IN 

4.  1 Scale.Low 
< Scale.High 

IN <= Scale.Low 
Oder 
IN < 0 

<> 16#48 
<> 16#60 

OUT = SQRT*1
 

5.  1 Scale.Low 
< Scale.High 

IN > 0 <> 16#48 
<> 16#60 

OUT = SQRT*2 

6.  2 Scale.Low 
< Scale.High 

IN < 0 
or 
SUP* 

<> 16#48 
<> 16#60 

OUT =0 

7.  2 Scale.Low 
< Scale.High 

IN > LoSupLv <> 16#48 
<> 16#60 

OUT = SQRT*2 

 

100
....* LowScaleHighScaleLoSupLvlLowScaleHighScaleINSUP

HighScaleINSQRT .11*1  

LowScaleLowScaleHighScaleINSQRT ...*2  
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Inputs 
 

Input Data type Default value Description 

Mode BOOL 0 MODE selection 
IN 
->Value 
->ST 

STRUCT 
->INT 
->Byte 

 
0 
16#0 

Input value 

Scale 
->High 
->Low 

STRUCT 
->REAL 
->REAL 

 
100.0 
0.0 

Measuring range of “IN“ 

LoSupLvl REAL 0.0 Degree of suppression for low 
values 

SimMode Bool 0 1=Ignore Sim/Subs, 0=Pass 
IN value through, Value if 
IN.ST=48 or 60 

 

Outputs 
 

Output Data type Default value Description 
OUT 
->Value 
->ST 

STRUCT 
->INT 
->Byte 

 
0 
16#0 

Output value 

 

Block description “SimAn” 

Function description 
The block represents the interface between an analog channel driver block of the 
Advanced Process Library (APL) and the operator station (OS). In the run 
sequence, the block is installed before the driver block. A maximum of 8 analog 
values are simulated with a block. 

Inputs 
 

Input 
(X = 1…8) 

Data type Default 
value 

Description 
(X = 1…8) 

SimXActOp->Value 
->ST 

STRUCT 
->BOOL 
->Byte 

 
0 
16#0 

Simulation ON / OFF 
for simulation value X 

SimXValueOp 
->Value 
->ST 

STRUCT 
->REAL 
->Byte 

 
0.0 
16#0 

Simulation value X 

ScaleX 
->High 
->Low 

STRUCT 
->REAL 
->REAL 

 
100.0 
0.0 

Measuring range of 
simulation value X 

OpEnSiOff BOOL 1 1=operator can switch off the 
simulation. 
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Input 
(X = 1…8) 

Data type Default 
value 

Description 
(X = 1…8) 

OpEnSiOn BOOL 1 1=operator can switch on the 
simulation. 

OpEnSiValue BOOL 1 1=operator can enter the 
simulation value. 

BatchEn BOOL 0 1=Batch enable 
BatchID DWORD 16#0 Batch ID number 
BatchName STRING[32]  Batch name 
StepNo DWORD 16#0 Batch step number 
Occupied BOOL 0 1=occupied by a batch. 
SelFp1 ANY  Calling a batch as additional 

faceplate in the standard view 
SelFp2 ANY  Calling a batch as additional 

faceplate in the standard view 
Feature STRUCT  Connection for further 

functions 

 

Outputs 
 

Output 
(X = 1…8) 

Data type Default 
value 

Description 
(X = 1…8) 

SimXActOut->Value 
->ST 

STRUCT 
->BOOL 
->Byte 

 
0 
16#0 

Simulation ON / OFF 
for simulation value X 

SimXValueOut 
->Value 
->ST 

STRUCT 
->REAL 
->Byte 

 
0.0 
16#0 

Simulation value X 
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Block description “SimDi” 

Function description 
The block represents the interface between an analog channel driver block of the 
Advanced Process Library (APL) and the operator station (OS). In the run 
sequence, the block is installed before the driver block. A maximum of 8 digital 
values can be simulated with one block. 

Inputs 
 

Input 
(X = 1…8) 

Data type Default 
value 

Description 
(X = 1…8) 

SimXActOp->Value 
->ST 

STRUCT 
->BOOL 
->Byte 

 
0 
16#0 

Simulation ON / OFF 
for simulation value X 

SimXValueOp 
->Value 
->ST 

STRUCT 
->BOOL 
->Byte 

 
0.0 
16#0 

Simulation value X 

OpEnSiOff BOOL 1 1=operator can switch off the 
simulation. 

OpEnSiOn BOOL 1 1=operator can switch on the 
simulation. 

OpEnSiValue BOOL 1 1=operator can enter the 
simulation value. 

BatchEn BOOL 0 1=Batch enable 
BatchID DWORD 16#0 Batch ID number 
BatchName STRING[32]  Batch name 
StepNo DWORD 16#0 Batch step number 
Occupied BOOL 0 1=occupied by a batch. 
SelFp1 ANY  Calling a batch as additional 

faceplate in the standard view 
SelFp2 ANY  Calling a batch as additional 

faceplate in the standard view 
Feature STRUCT  Connection for further 

functions 

Outputs 
 

Output 
(X = 1…8) 

Data type Default 
value 

Description 
(X = 1…8) 

SimXActOut->Value 
->ST 

STRUCT 
->BOOL 
->Byte 

 
0 
16#0 

Simulation ON / OFF 
for simulation value X 

SimXValueOut 
->Value 
->ST 

STRUCT 
->REAL 
->Byte 

 
0.0 
16#0 

Simulation value X 
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