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Safety Guidelines 

This manual contains notices intended to ensure personal safety, as well as to protect the products and 
connected equipment against damage. These notices are highlighted by the symbols shown below and 
graded according to severity by the following texts: 

 

!  
Danger 
indicates that death, severe personal injury or substantial property damage will result if proper 
precautions are not taken. 

 

!  
Warning 
indicates that death, severe personal injury or substantial property damage can result if proper 
precautions are not taken. 

 

!  
Caution 
indicates that minor personal injury can result if proper precautions are not taken. 

 
 Caution 

indicates that property damage can result if proper precautions are not taken. 
 

 Notice 
draws your attention to particularly important information on the product, handling the product, or to a 
particular part of the documentation. 

Qualified Personnel 

Only qualified personnel should be allowed to install and work on this equipment. Qualified persons 
are defined as persons who are authorized to commission, to ground and to tag circuits, equipment, and 
systems in accordance with established safety practices and standards. 

Correct Usage 

Note the following: 
 

!  
Warning 
This device and its components may only be used for the applications described in the catalog or the 
technical description, and only in connection with devices or components from other manufacturers 
which have been approved or recommended by Siemens. 
 
This product can only function correctly and safely if it is transported, stored, set up, and installed 
correctly, and operated and maintained as recommended. 

Trademarks 

SIMATIC®, SIMATIC HMI® and SIMATIC NET® are registered trademarks of SIEMENS AG.  

Third parties using for their own purposes any other names in this document which refer to trademarks 
might infringe upon the rights of the trademark owners. 
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Preface 

Purpose of the manual 
This manual provides support for the configuration and commissioning of plants 
using SIMATIC iMap.  
It is directed towards project engineers working in the field of configuration, 
commissioning and servicing automation systems with component based 
automation..  
We recommend you read the documentation, "Getting Started with SIMATIC iMap". 
It will help to introduce you to working with SIMATIC iMap. 

Required knowledge 
To understand the manual, you require general experience in the field of 
automation engineering.  
In addition, you are required to have a good working knowledge of computers or 
other equipment similar to PCs (e.g. programming devices) under the operating 
systems Windows 2000 or Windows XP. Since SIMATIC iMap is based on the 
basic STEP 7 software when SIMATIC devices are used, you should have 
knowledge about operating this basis software as described in the manual, 
"Programming with STEP 7 V5.2". 

Validity of the Manual 
This manual is valid for the software package SIMATIC iMap V2.0. 
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What is new in SIMATIC iMap V2.0? 
• Structures as a data type for connectors � Chap. 1.3 

• Optimized display of the Industrial Ethernet in the network view � Chap. 3.4.3 

• Display of additional information in the project view � Chap. 3.4.4 

• Specialized display of message in several tabs of the information window � 
Chap. 3.4.10 

• Improved data storage with the project library � Chap. 4.3.1 
• Cyclic data transmission between PROFInet communication participants � 

Chap. 4.4.3.4 

• Project-wide setting of interconnection properties � Chap. 4.4.3.4 

• Checking the load on devices � Chap. 4.5.6 

• Creating cross-project interconnections � Chap. 4.6.3  

• Improved editing options for PROFInet components in the libraries. � Chap. 
4.7.1  

• Replacing instances � Chap. 4.7.2 

• Querying runtime information using online device analysis � Chap. 5.10 

• Unique OPC path over several projects � Chap. 5.11.1  

• Singleton components � Chap. 6.2 

• PROFInet components with HMI sections � Chap. 6.3  

Your guide through the manual 
The following manual is divided into the following topic areas: 

• Chapter 1 provides an overview of the overall concept and the product range of 
component based automation. 

• Chapter 2 describes the installation of the software 

• Chapters 3 to 6 describe working with SIMATIC iMap  

• The appendix contains a summary of the control elements for your reference. 

• The glossary contains explanations of important terms. 

• The index helps you to quickly find textual information on important keywords. 
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Its place in the information environment 
This manual is part of the SIMATIC iMap documentation package. The 
documentation is supplied with the software and includes the electronic manuals in 
PDF format: 

• Getting started with SIMATIC iMap  
Brief introduction to working with component based automation and 
SIMATIC iMap. 

• Configuring Plants with SIMATIC iMap � this manual 
Contains detailed information and instructions about configuration and 
commissioning of plants using SIMATIC iMap. 

• Creating PROFInet Components 
Contains detailed information and instructions about creating PROFInet 
components with STEP 7 and the use of SIMATIC devices in component based 
automation. 

• Commissioning the System, Tutorial 
Contains detailed information and step-by-step instructions using examples, 
from the creation of PROFInet components to commissioning of the complete 
plant. 

In addition, the entire documentation is available as an HTML basic help in 
SIMATIC iMap. 

References 
The following section provides references to information for carrying out the 
following tasks: 

• Creating PROFInet components with STEP 7 

• Configuring plants with SIMATIC iMap 

• Commissioning plants with SIMATIC iMap 

The following table provides a "thread" through all manuals about component 
based automation and SIMATIC iMap. The chapters are listed in the order required 
for performing the task.  
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References for Creating PROFInet Components with STEP 7 
Target group: Plant and machine engineers 

 
Chapter Manual 

Required Optional
Title 

 1 Getting Started - Introduction  
 2 Step 1: Defining PROFInet components 

Getting Started with 
SIMATIC iMap 

 3 Step 2: Creating PROFInet components with 
STEP 7  

1.1  Basic procedure 

1.3  Creating the project with STEP 7 
1.4.1  Properties of PROFInet interfaces 
 1.4.2 Using the PROFInet interface editor 
1.4.3  Creating PROFInet interface 
 1.4.4 Changing PROFInet interfaces 
1.6.1  Creating PROFInet components in 

SIMATIC Manager 
 1.7 Importing PROFInet components to a library 
 1.8 Modifying PROFInet components 

Creating 
PROFInet 
Components 

 2 SIMATIC devices as PROFInet components 
Commissioning 
Systems, Tutorial 

 2 Part 1: Creating PROFInet components 
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References for Configuring Plants Using SIMATIC iMap 
Target group: Plant designers 

 
Manual Chapter Title 

 Required Optional  
 1 Getting Started - Introduction  Getting Started 

with 
SIMATIC iMap 

 4 Steps 3 to 6: Configuring a plant with SIMATIC iMap

 1 Component based Automation - Overview 
2  Installing SIMATIC iMap 
3.1  Starting SIMATIC iMap 
 3.3 Operating philosophy 
4.1  Basic procedure for configuring the plant 
4.2.1  Creating a new project 
4.2.2  Opening and closing projects 
4.3.2  Creating a new library 
4.3.3  Opening and closing libraries 
4.3.4  Importing PROFInet components 
4.4.1  Inserting PROFInet components into a 

SIMATIC iMap project 
4.4.2  Coupling devices in the net view  
4.5.3  Assigning addresses  
4.4.3  Interconnecting technological functions 
 4.5.1 Looking up and modifying properties 
4.5.6  Checking the utilization 
 4.6.1 Creating subordinate charts  
 4.7 Working with modified PROFInet components  
 4.7.2 Replacing instances 
4.2.4  Generating the project 
 4.2.5 Documenting and printing a project 
4.2.3  Saving and archiving projects 
 4.3.6 Archiving and retrieving libraries 

Configuring 
plants with 
SIMATIC iMap 

 5.11.1 Creating OPC symbol files 

 3.3.2 Step 3: Configuring Machine 1 with SIMATIC iMap 
 3.4.2 Step 3: Configuring Machine 2 with SIMATIC iMap 

Commissioning 
Systems, 
Tutorial 

 3.5.2 Step 3: Configuring Machine 3 with SIMATIC iMap 
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References for Commissioning Plants Using SIMATIC iMap 
Target group: Plant operators 

 
Chapter Manual 

Required Option
al 

Title 

 1 Getting Started - Introduction  
 5 Step 7: Generating and Download 
 6 Step 8: Diagnostics 

Getting Started with 
SIMATIC iMap 

 7 Step 9: Visualizing Process Data 
2  Installing SIMATIC iMap 
3.1  Starting SIMATIC iMap 
 3 Working with SIMATIC iMap 
 4 Configuring plants 
5.1  Basic procedure for commissioning 
 5.2 Overview of the online functions 
5.3  Downloading Programs and Interconnections 
5.4  Diagnostic information in the online view t 
5.5  Diagnosing PROFInet components 
5.6  Checking the accessiblity of the devices 
5.7  Comparing online and offline data 
5.8  Displaying and setting online values in the plant 

view 
5.9  Online testing with the variable table 
 5.10 Online device analysis 
5.12.1  Special features of plants with SIMATIC devices 
5.12.2  Using SIMATIC devices in online mode 

Anlagen 
projektieren mit 
SIMATIC iMap 

 5.12.3 Editing instances with STEP 7 
Commissioning 
Systems, Tutorial 

 3 Part 2: Commissioning the system 
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Conventions 
Menu commands are written in bold letters, for example: Project> Save. 
Placeholders are set in angle brackets, for example <File name>. 

Further support 
Please contact your local SIEMENS partner if you have any further queries on the 
products described in this manual.  

http://www.siemens.com/automation/partner 

http://www.ad.siemens.de/cba/ 

 

Training Centers  
We offer a range of courses to help you get started with xxxx and the S7 
automation system. Please contact your regional training center or the central 
training center in D 90327 Nuremberg.  
Phone:  +49 (911) 895-3200.  
Internet: http://www.sitrain.com 

http://www.siemens.com/automation/partner
http://www.ad.siemens.de/cba/index_76.htm
http://www.sitrain.com
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A&D Technical Support 
 

Open round the clock, worldwide:  
 

Beijing 

 Nuremberg

Johnson City 

  

Worldwide (Nuremberg) 
Technical Support  
 

Local time: 0:00 to 24:00 / 365 days 

Phone: +49 (180) 5050-222 

Fax: +49 (180) 5050-223 

EMail: adsupport@ 
 siemens.com 

GMT: +1:00 

  

Europe / Africa (Nuremberg) 
Authorization 
 
Local time: 8:00 to 17:00 

Phone: +49 (180) 5050-222 

Fax: +49 (180) 5050-223 

EMail: adsupport@ 
 siemens.com 

GMT: +1:00 

United States (Johnson City) 
Technical Support and 
Authorization 
Local time: 8:00 to 17:00 

Phone: +1  (423)  262 2522. 

+1-52520779 740 3699, Fax: 

EMail: simatic.hotline@ 

 sea.siemens.com 

GMT: -5:00 

Asia / Australia (Beijing) 
Technical Support and 
Authorization 
Local time: 8:00 to 17:00 

Phone: +86 10 64 75 75 75 

Fax: +86 10 64 74 74 74 

E-Mail: adsupport.asia@ 

 siemens.com 

GMT: +8:00 

German and English spoken at the Technical Support and Authorization hotlines. 
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Service & Support on the Internet 
In addition to our documentation services, we also offer you our knowledge base 
on the Internet. 
http://www.siemens.com/automation/service&support 

Here, you will find: 

• our Newsletter, a source that offers updated information on your products 

• your appropriate documentation via our Service & Support search engine 

• a forum for the exchange of information between users and specialists 
worldwide 

• your local Automation & Drives partner via our partner database. 

• information on repairs, replacement parts and on-site service. You will find 
more information under "Services�. 

http://www.siemens.com/automation/service&support
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Component based Automation - 
Overview 1
1.1 New automation concept with Component based Automation 

What is Component based Automation? 
As part of Totally Integrated Automation (TIA), Component based Automation is an 
automation concept for implementing modular, distributed applications based on 
the open PROFInet standard. It allows a distributed automation package to be 
created using off-the-shelf components and partial solutions. This concept meets 
the demand for increased modularization in the field of plant and machine 
construction by extensively distributing the intelligent processing required.  

The following diagrams show how automation packages are transformed by 
Component based Automation. 

Figure 1-1 The old automation concept with a modular plant structure 
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Figure 1-2 New: A modular concept with distributed intelligence 

Component based Automation allows complete technological modules to be used 
as standardized automation components - known as PROFInet components - in 
large-scale plants.  

Component based Automation is implemented by using the PROFInet standard for 
programmable controllers and through the use of suitable engineering tools, such 
as SIMATIC iMap.  

 What is PROFInet ? 
PROFInet is the Ethernet-based automation standard issued by the PROFIBUS 
Nutzerorganisation e.V. (PNO).  The PROFInet standard defines a cross-vendor 
communication, automation and engineering model. 

PROFINet has the following objectives: 

• Open, distributed automation 

• Standardized communication via field bus and Ethernet 

• Use of open IT standards. 

PROFInet specifies the functions for implementing an integrated automation 
package, from installation of the network right through to web-based diagnostics. 
The modular structure means the PROFInet can be very easily upgraded with 
additional functions in the future.  
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Use of PROFInet with Industrial Ethernet and PROFIBUS 
The following diagram illustrates the types of network that are supported for 
Component based Automation with PROFInet: Industrial Ethernet and PROFIBUS. 

 
Figure 1-3 Supported network types: Industrial Ethernet and PROFIBUS 

The PROFInet communication takes place via Industrial Ethernet. The following 
transmission modes are supported: 

• Acyclical transmission of engineering data and non time-critical data  

• Cyclical transmission of time-critical process data.  

Existing PROFIBUS systems can easily be incorporated into PROFInet 
communication using the proxy concept, whereby the proxy represents the 
PROFIBUS devices on the Ethernet.  
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What is SIMATIC iMap? 
PROFInet provides a standardized, vendor-independent engineering interface. It 
allows devices and components from different vendors to be easily integrated into 
a plant.  

SIMATIC iMap is such a cross-vendor engineering tool for configuring PROFInet 
applications. It brings together distributed automation applications in a graphical 
format so that they can be displayed for the entire plant. All the PROFInet 
components needed are provided in a standardized format in the form of library 
elements. The communication links between devices are not programmed. Instead 
they are configured in graphical format as interconnection lines. 

SIMATIC iMap can download the contents of PROFInet components and the 
associated interconnections to the devices in the plant. During commissioning and 
while the plant is in operation, you can use SIMATIC iMap to look up process data 
and diagnostic data concerning the devices as well as modify parameters and 
project data for testing purposes. 

Vendor-specific programming and configuration tools may be integrated into 
SIMATIC iMap. 

Product range 
The product range for Component based Automation based on the PROFInet 
standard comprises: 

• PROFInet devices that conform to the PROFInet specification, e.g. the 
SIMATIC devices CPU 317-2 PN/DP and IE/PB Link. 

• SIMATIC iMap, the engineering tool for Component based Automation for 
configuring plants and linking to vendor-specific programming, configuration and 
diagnostic tools. 

In addition, many existing automation and field devices from different vendors can 
also be used as PROFInet components. 

As part of the PNO's work, a specification was drawn up for the communication 
mechanisms and the engineering model. This allows further devices to be made 
PROFInet-compliant and the associated configuration and programming tools to be 
linked into SIMATIC iMap.  
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1.2 PROFInet components 

What are PROFInet components? 
The mechanical, electrical and electronic parts of a programmable controller that 
perform a specific technological function within the automation system or 
production process, combined with the associated control program, form an 
independent technological submodule. If this technological submodule meets the 
communication requirements of the PROFInet standard, then it can be used to 
create a PROFInet component.  

The concept is based on the Microsoft component model, which is the commonly-
used data and communication model for the Windows PC world. It defines the 
protocol for exchanging data between software components from different vendors. 

In Component based Automation, all the functionality of a technological module is 
encapsulated in a single component. A PROFInet component is the mapping of a 
technological module - i.e. an automation unit with defined functionality - in the 
PROFInet specification. PROFInet components are modular and thus can be easily 
assembled and reused, greatly simplifying the process of configuring an 
automation system.  

 
Figure 1-4 Creating a PROFInet component from a technological submodule 
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A PROFInet component incorporates all the hardware configuration data, the 
module parameters and the associated user program. The PROFInet component is 
made up of: 
• an (optional) technological (software) function and  
• the associated device. 
The technological function of the component comprises the interface to other 
PROFInet components in the form of interconnectable inputs and outputs.  
The device  is the representation of the physical programmable controller or field 
device, including any peripheral devices, sensors and actuators, the mechanical 
system and the device's firmware. 

How are PROFInet components created? 
The programmable controller or field device of the PROFInet component is 
configured and programmed using the configuration and programming tool 
supplied by the device manufacturer. A PROFInet component is then created from 
the configuration of the programmable controller and its user program, e.g. using a 
menu command. The device's functionality is also encapsulated with the 
application-specific programs. From the outside, only the component interfaces 
that are needed for interaction across a machine or plant or for diagnostics, 
visualization and vertical integration are accessible.  

The component interface of the PROFInet component is written in XML (Extended 
Markup Language) and is stored in a PCD (PROFInet Component Description) file. 
XML allows you to display information in a platform and vendor-independent 
format. A specification of the PCD file structure is given in the PROFInet 
engineering model.  

The PROFInet component can incorporate information on the hardware 
configuration and on the user program, if necessary, in a device specific form. 

Properties of PROFInet components 
• Modularization and reusability  

The concept of the PROFInet component allows extensive modularization of 
automation systems. PROFInet components can be reused as often as 
necessary in different automation systems.  

• Constant communication by support for the PROFInet specification 
Each PROFInet component provides a standardized interface for 
communicating with other components on the Ethernet or PROFIBUS, 
regardless of its internal functionality. The PROFInet specification describes the 
open communication interface for PROFInet-compliant devices.  

• Cross-vendor engineering  
The technological functions of individual devices are programmed in the vendor-
specific engineering tools. However, cross-vendor engineering tools such as 
SIMATIC iMap are used for the plant-wide interconnection of technological 
functions, since they allow products from different vendors to be incorporated 
into PROFInet communication. Thus, all field device and programmable 
controller vendors have to do is extend their programming and configuration 
tools to allow them to be linked to the device-neutral engineering tool (e.g. 
SIMATIC iMap).  
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Programmable and Fixed functionality 
In an intelligent device, the application-specific functionality is defined by the user 
program that is downloaded to the device. More simple devices, such as drives or 
field devices, do not have their own user programs. The functionality of such 
devices is integrated into the firmware. We therefore differentiate between 
PROFInet components 

• with programmable functionality 

The component has its own user program that can be downloaded from 
SIMATIC iMap to the device. 

• with fixed functionality 

The component does not have its own user program. 

Representation of PROFInet components 

 
Figure 1-5 Representation of a PROFInet component in SIMATIC iMap 
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SIMATIC iMap represents PROFInet components in different ways:  

• As part of a library (window 1), the PROFInet components are represented by a 
separate icon. 

• In a SIMATIC iMap project, the instances of each PROFInet component are 
represented in different views: the technological functions in the plant view 
(window 2) and the devices in the net view (window 3).  

• The assignment of PROFInet components to the associated instances is 
represented in the project view (see diagram below). 

 

 
Figure 1-6 Project view in SIMATIC iMap 



Component based Automation - Overview 

Component based Automation, Configuring Plants with SIMATIC iMap 
A5E00248797-01 1-9 

1.3 Technological function 

Definition of a technological function 
The technological function of a PROFInet component comprises the application-
specific functionality of a programmable controller or field device and the 
component interface for communication with other PROFInet components.  

The term "technological function� frequently occurs in automation technology, and 
always in conjunction with the implementation of specific functions for an 
automation process, e.g. positioning, counting or controlling motors. In most cases, 
it means individual functions within the programmable controller. In terms of 
Component based Automation, a technological function means the entire 
functionality of a device or group of devices, whereas the associated hardware is 
represented by a device in the SIMATIC iMap net view. 

Component Interface 
The component interface defines the connectors - i.e. the inputs and outputs - of 
the PROFInet component. The connectors represent the external communication 
interface that is accessed via Ethernet or PROFIBUS. Every connector is 
characterized by the following features, as defined in the user program for the 
PROFInet component: 

• Direction  

Every connector is either an input or an output.  

• Interconnectability in SIMATIC iMap  

Inputs and outputs that are visible in SIMATIC iMap may be interconnected.  

Non-interconnectable connectors are not represented graphically in 
SIMATIC iMap. They can be accessed via other communication mechanisms, 
e.g. OPC (OLE for Process Control), and are generally used for operator control 
and process monitoring. 

• Name  

Any connector names can be selected, provided that it conforms to the naming 
conventions and is no more than 24 characters long. 

• Data type  

A data type, e.g. BOOL, I1 or U2, is defined for each connector. Complex data 
types, such as arrays, are also supported. 

• Value  

While the plant is in operation, the current value of a connector can be 
displayed online in SIMATIC iMap. Online values of non-interconnected inputs 
may also be modified. 
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PROFInet data types 
The following PROFInet data types, which conform to Microsoft OLE 2.0, are 
supported for the connectors of technological functions.  

Table 1-1 Data types 

Data type Range of values 

BOOL TRUE / FALSE 

I1 -128 to +127 

UI1 0 to 255 

R4 3.4E +/- 38 

I2 -32,768 to +32,767 

UI2 0 to 65,535 

I4 - 2.147.483.648 to +2.147.483.647 

UI4 0 to 4.294.967.295 

DATE 01.01.1900 00:00:00 to 31.12.9999 23:59:59*) 

BSTR Character string 

ARRAY One-dimensional, from simple data types**) 

STRUCT Made up from simple data types**) 

*) There may be restrictions in the range of values, depending on the type of device. For 
example, for SIMATIC devices this would be: 01.01.1990 00:00:00 to 31.12.2089 23:59:59. 

** Simple data types are all the listed data types, apart from ARRAY and STRUCT. The 
maximum length depends on the amount of memory in the device.  

Interconnections 
In SIMATIC iMap, an interconnection is the connection between an output and an 
input. An output can be interconnected to one or more inputs. Once the 
interconnections have been downloaded to the programmable controllers, the 
corresponding communication links are automatically established between senders 
and receivers.  
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Representation of technological functions 
The technological functions of a plant are represented by blocks with 
interconnectable inputs (1) and outputs (2). Interconnections are represented by 
connecting lines (3). 

Figure 1-7 Interconnected technological functions 
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1.4 Devices of PROFInet components 

PROFInet and PROFIBUS Devices 
The device is the part of the PROFInet component that contains the hardware-
specific data for that component.  

In Component based Automation, a device is a representation of the physical 
device for which the PROFInet component was created. Such devices include 
programmable controllers, intelligent field devices and peripheral, hydraulic and 
pneumatic devices.  

The main feature of a device is that it is integrated into the PROFInet 
communication via an Ethernet or PROFIBUS. We differentiate between the 
following types of device downstream of the bus connectors: 

• PROFInet devices 

A PROFInet device always has an Ethernet connector. A PROFInet device may 
also have a PROFIBUS connector, and thus act as a master with proxy 
functionality.  

• PROFIBUS devices 

A PROFIBUS device has just one PROFIBUS connector and is always a slave. 
It cannot participate directly in PROFInet communication, and must always be 
integrated via a PROFIBUS master with proxy functionality. 

The following picture illustrates both types of device. 

Figure 1-8 PROFInet and PROFIBUS Devices 
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The PROFInet device with proxy functionality is a proxy of the PROFIBUS devices 
on the Ethernet. The proxy functionality allows a PROFIBUS device to 
communicate with all participants in the PROFInet communication, as well as with 
its own master.  

PROFIBUS devices may also be coupled to the local PROFIBUS of a PROFInet 
device (see below, "Representation of the devices"), thus allowing existing 
PROFIBUS configurations to be integrated into PROFInet components. The local 
PROFIBUS of a device is not visible in SIMATIC iMap. 

Representation of the devices 
PROFInet and PROFIBUS devices are represented in the SIMATIC iMap net view. 

 
Designation Representation in 

SIMATIC iMap  
Example: Hardware configuration 

for a PROFInet component 

PROFInet device 
with proxy 
functionality 

PROFInet device 
with proxy 
functionality and 
local PROFIBUS 

PROFInet device 
without proxy 
functionality  

PROFInet device 
(with local 
PROFIBUS) without 
proxy functionality 



Component based Automation - Overview 

 Component based Automation, Configuring Plants with SIMATIC iMap 
1-14 A5E00248797-01 

Designation Representation in 
SIMATIC iMap  

Example: Hardware configuration 
for a PROFInet component 

PROFIBUS device  
(DP slave on the 
PROFIBUS) 

 

The diagram below illustrates the devices in the SIMATIC iMap net view. 

Figure 1-9 Example: Representation of the devices in the SIMATIC iMap net view 

Table 1-2 Key 

Icon Meaning 

1 PROFInet device with proxy functionality 

2 PROFInet device without proxy functionality 

3 PROFIBUS devices 
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1.5 New engineering concept with SIMATIC iMap 

Device-independent engineering concept 
SIMATIC iMap is a device-independent engineering tool for configuring, 
commissioning and operating plants using PROFInet components.  

In addition to the technological plant view, SIMATIC iMap also provides a link to 
vendor-specific or proprietary programming and configuration tools for the 
programmable controllers and intelligent field bus devices. 

 
Figure 1-10 SIMATIC iMap engineering concept 
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The basic engineering procedure 
The following steps must be carried out in order to structure and operate an 
automation system using SIMATIC iMap: 
1. Planning the plant  

The plant planner defines the following aspects: 
� Which functions are needed 
� Which programmable controllers and field devices are to be used 
� Which functions can be combined to create reusable technological 

submodules 
� NEW for Component based Automation:  

Component interfaces and interaction between PROFInet components, plus 
variables for diagnostics and visualization. 

2. Creating PROFInet components  
The plant and machinery constructor creates the PROFInet component using 
the vendor-specific configuration and programming tool by: 
� Configuring and programming the hardware 
� Creating the description of the component interface 
� Creating the user program 
� Testing the technological submodule 
� Creating the PROFInet component (XML file and associated data) 
� Optional: Importing the PROFInet component into a SIMATIC iMap library. 

3. Configuring the plant in SIMATIC iMap  
The plant configuration engineer creates the project in SIMATIC iMap by:  
� Opening an existing library or creating a new library 
� If necessary: Importing the new PROFInet component into the library 
� Inserting the PROFInet Components into the Project 
� Networking the devices in the net view 
� Assigning the device addresses (IP address and/or PROFIBUS address) to 

the devices (this step is device-specific) 
� Interconnecting the technological functions in the plant view 
� Modifying the properties of the devices and functions 
� Checking the configuration 
� Documenting and archiving the project 

4. Commissioning and testing the plant  
The plant operator is responsible for the following tasks: 
� Commissioning individual devices 
� Downloading project data to the devices in the plant 
� If necessary: Reworking devices and technological functions in the vendor-

specific engineering tool 
� Testing the plant 
� Creating the symbol data for OPC access 

5. Operating the plant 
� Monitoring and modifying process data online (vertical integration)  
� Diagnosing faults in the plant 
� Operator control and process monitoring  
� Carrying out maintenance and modifications 
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Support from SIMATIC iMap  
SIMATIC iMap provides the following support for plant engineering: 

• Storage of in-house and off-the-shelf PROFInet components in libraries  

Libraries are used to administer PROFInet components that you create yourself 
or purchase. The content of these libraries can be configured as required. 

• Interconnection of technological functions in the plant view  

In the plant view, you can position and interconnect technological functions 
graphically, and easily check and modify their properties.  

• Networking of devices in the net view  

In the net view, you can link devices graphically to a PROFIBUS or Ethernet 
subnet, and assign the corresponding addresses.  

• Online monitoring and control of variables  

You can access the process data online at any time by using a variable table, 
incorporating HMI devices such as ProTool/Pro into your plant or using OPC-
based client programs.  

• Diagnosing PROFInet devices and technological functions  

The separate diagnostic window constantly displays the current status of 
PROFInet devices and technological functions. An online-offline comparison 
allows you to determine whether programs and/or interconnections need to be 
downloaded. 

• Representation of the project in a hierarchical tree structure  

All parts of the plant needed for easy navigation and other administration 
functions within the project are clearly displayed. 

• Automatic creation of the plant documentation  

Full documentation of the configured plant, including all devices, technological 
functions and their connectors, plus a graphical representation of the 
networking and interconnections can be created automatically in 
SIMATIC iMap. 

• Checking the configuration  

You can check the configuration in SIMATIC iMap with reference to the device-
specific performance parameters even before you generate the project. 

• Looking up the device's online data.  

The online device analysis allows you to look up the online data for individual 
devices for testing and diagnostic purposes. 

Vendor-specific configuration and programming tools 
SIMATIC iMap provides the following functions for linking to vendor-specific 
configuration and programming tools: 

• Software for creating PROFInet components for SIMATIC devices in STEP 7. 

• Access to vendor-specific tools for configuring and diagnosing devices.  
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Transparent data access 
PROFInet communication supports access to process data from different levels of 
the plant. Using PROFInet, you can now use standard communication and IT 
mechanisms, such as OPC, XML, COM/DCOM, in your automation system, which 
means that office-bound company managers can directly access the data from 
PROFInet devices at the control and production levels.  

 

Figure 1-11 Access to process data 
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1.6 User documentation for SIMATIC iMap and Component based 
Automation 

User documentation 
The SIMATIC iMap and PROFInet documentation is broken down into various 
activities and target groups. The contents contain different levels of information. 

Manual Type of 
description 

Content Target group

Introduction • Component based Automation  

• SIMATIC iMap  

• PROFInet components 

Beginners 

Plant 
planners 

• Installing SIMATIC iMap 

• Using SIMATIC iMap 

• Configuring Plants 

Plant 
configuration 
engineers 

• Commissioning plants 

Configuring 
Plants  
with 
SIMATIC iMap 
� manual Extensive 

description and 
instructions  

• Online Operation and Diagnostics 

Plant 
operators 

Commissioning 
Systems  
� Tutorial 

Detailed step-by-
step instructions 
with reference to 
an example 

• Creating PROFInet components with STEP 7  

• Configuring Plants with SIMATIC iMap  

• Commissioning Plants with SIMATIC Devices 

All 

Getting Started 
with SIMATIC 
iMap 

Brief introduction  • Creating PROFInet components with STEP 7  

• Configuring Plants with SIMATIC iMap  

• Online Monitoring and Diagnostics with 
SIMATIC iMap 

Beginners  

Creating 
PROFInet 
components  

Extensive 
description and 
instructions  

• Creating PROFInet components with STEP 7  

• Using SIMATIC Devices as PROFInet components 

Plant 
constructors  

Machinery 
constructors 

 

Options for accessing the user documentation 
To call up the SIMATIC iMap documentation: 

• Use the Start > Programs > Component based Automation > 
Documentation > SIMATIC iMap > ... command to open the PDF document in 
Windows.  

• In SIMATIC iMap, you can open the complete documentation as online help 
using the Help > Help Topics menu command.  

Additional information 
The associated product documentation contains information on related topics, e.g. 
descriptions of individual devices. 



Component based Automation - Overview 

 Component based Automation, Configuring Plants with SIMATIC iMap 
1-20 A5E00248797-01 

 

 



 

Component based Automation, Configuring Plants with SIMATIC iMap 
A5E00248797-01 2-1 

Installing SIMATIC iMap  2
2.1 Requirements 

Hardware Requirements 
The computer on which SIMATIC iMap is installed must have at least the following 
configuration: 

• Pentium processor, 700 MHz or faster (1 GHz recommended) 

• 256 MB or more RAM (512 MB recommended) 

General software requirements 
Operating system: 

• Microsoft Windows 2000 Professional, SP 4 or later, or 

• Microsoft Windows XP as of SP1 

• Microsoft Internet Explorer, V6.0 SP1 or later (on the SIMATIC iMap CD) 

Recommendation:  

We recommend that you also install the Microsoft Windows security patches.  

Authorizations: 

• You will need administrator rights to install SIMATIC iMap. 

• You will need at least primary user rights to run SIMATIC iMap. 
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Software requirements for SIMATIC devices 
If you are using PROFInet components of SIMATIC devices, you will also need the 
following software packages: 

• STEP 7 V5.2, SP1 or later, including NCM for Industrial Ethernet and 
PROFIBUS, or  

� STEP 7 Professional V5.2 SP1 

� STEP 7 V5.3  

• SIMATIC NET IE SOFTNET-PG, V6.1 or later � for using the OPC server 
and/or the WinAC PN. 

• Software required for the SIMATIC devices used: 
 

Device/Function Software required 

WinAC PN  WinAC PN V1.1 and V4.1 

SIMATIC NET IE SOFTNET-S7 V6.1 or later 

HMI Process Visualization ProTool/Pro Configuration V6.0 + SP2 or later 

Access to process variables via OPC SIMATIC NET PN OPC Server, V6.1 or later 

Access to process variables via OPC  SIMATIC NET IE SOFTNET-S7 V6.1 or later 

SIMATIC NET PN OPC Server, V6.1 or later 

 

Other important information... 
on SIMATIC iMap can be found in the readme file. 
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2.2 Installation 

Requirement 
• The conditions described in the "Requirements" section must be fulfilled. 

• The floppy disk provided must contain the SIMATIC iMap copy protection. 

To install SIMATIC iMap 
1. Insert the floppy disk with the SIMATIC iMap copy protection in the floppy drive. 

2. Insert the SIMATIC iMap CD into the CD-ROM drive. 
If the setup program starts automatically, you can continue from step 5. 
Otherwise continue from step 3. 

3. Select the CD-ROM drive in Windows Explorer.  

4. Double click on the setup.exe file to start the setup program.  

5. Run the necessary setup programs in the order specified by clicking on the 
relevant buttons.  

During the installation you will be prompted to install the authorization. 
Following instructions in the "Authorization" section. 

 

 Note 
When you have installed some software packages, you are prompted to restart the 
computer. Restart the computer if you are prompted to do so by the setup 
program. 

 

Please follow the notes on installing and using SIMATIC iMap in the readme file, 
which is also on the CD-ROM. 
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2.3 Authorization 

A product-specific authorization (right of use) is needed in order to use the 
SIMATIC iMap engineering software. SIMATIC iMap can only be used if the 
necessary authorization is detected on the hard drive of the PG/PC.  

Authorization diskette 
For the authorization, you will need the authorization diskette that is supplied with 
the software. This contains the actual authorization. The "AuthorsW" program that 
you will need to display, install and uninstall the authorization can be found on the 
CD-ROM that also contains SIMATIC iMap V2.0.  

 

 Note 
For the SIMATIC iMap engineering software you will receive a red authorization 
diskette with the associated authorization. 

 

 Caution 
Follow the instructions under iMap > Authors > Disk1 > Readme.wri on the CD-
ROM. If you do not follow these instructions, you risk losing the authorization 
permanently. 

 

You can also use SIMATIC iMap without the authorization to get to know the user 
interface and range of functions. However, you can only really use the program 
with the authorization installed. If you have not installed the authorization, you will 
be prompted at regular intervals to install it.  

If you lose your authorization ...  

An authorization can be lost if a hard disk fault occurs, for example, and you are 
unable to uninstall the authorization from the defective hard drive.  

If you use the authorization, you can access the emergency authorization, which is 
also on the authorization diskette. This emergency authorization allows you to 
continue to use the software for a limited period. In this case, the time remaining 
until the authorization expires is shown on start-up. You should obtain a 
replacement for the lost authorization during this period. To do this, contact your 
local SIEMENS dealer.  

 

 Note 
The time limit for the emergency authorization starts to run when you install the 
authorization, even if SIMATIC iMap is not started. The time limit will not stop even 
if you write the authorization back to the floppy disk. 
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Installing AuthorsW 
The "AuthorsW" program that you will need to display, install and uninstall 
authorizations can be found on the CD-ROM that also contains SIMATIC iMap 
V2.0. Install this program on your hard disk via an option in the setup program. You 
can then use it from there for the authorization operations.  

 

 Note 
The AuthorsW program can be found at  

Start > SIMATIC > AuthorsW > AuthorsW. 

Running the authorization at initial installation 
You should run the authorization when a message prompts you to do so during the 
initial installation of SIMATIC iMap. The procedure is as follows:  

1. Insert the authorization diskette when you are prompted to do so.  

2. Then confirm the prompt.  

3. The authorization is transferred to a physical drive.  

Running the authorization at a later date 
If you start SIMATIC iMap and there is no authorization installed, a message to this 
effect appears. To retrospectively install the authorization, start the AuthorsW 
program. The Help for this program contains detailed information on the procedure. 

  

 Note 
The authorization will not work under Windows 2000/XP unless you are approved 
for write access on a local hard drive. 
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Working with SIMATIC iMap  3
3.1 Starting SIMATIC iMap 

Requirement 
SIMATIC iMap must be installed on your PC/PG. 

Starting SIMATIC iMap 
There are two ways to start SIMATIC iMap: 

• Click on the Start / Programs / Component based Automation / SIMATIC 
iMap command or  

• Double-click on the iMap icon on your desktop: 



Working with SIMATIC iMap 

 Component based Automation, Configuring Plants with SIMATIC iMap 
3-2 A5E00248797-01 

Result: The SIMATIC iMap user interface is opened: 

 

 
Figure 3-1 Start SIMATIC iMap: User interface 
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3.2 Help functions in SIMATIC iMap 

Online help 
SIMATIC iMap's built-in help system provides targeted information for the points in 
the program at which you need help. You can thus quickly and efficiently access 
the information you need. The ways in which you can obtain help for each 
procedure are described below. 

Via the "?" menu 
• Help: Displays information about the selected object or on the active dialog box 

or window.  

• Help Topics: Opens the online help for "Component based Automation and 
SIMATIC iMap". You can then use the Content, Index and Find tabs to navigate 
within the online help. 

• Getting Started: Describes the first steps that you have to carry out to create a 
working application.  

• About: Opens an information box listing the most important properties of the 
installed software version.  

In dialog boxes 
In all dialog boxes containing a "Help" button, you can click on this button to obtain 
a description of the dialog box. 

In messages 
In all message boxes containing a "Help" button, you can click on this button to 
obtain a detailed description of the message. 

Via the F1 function key 
Use the F1 function key to move directly from your current working context to the 
point in the online help that describes this aspect. For example, if there is a dialog 
box on screen, pressing F1 will call up a description of this dialog. 

In the status bar 
The status bar displays a short help text that describes the selected command from 
the main or context menu (opened by clicking the right mouse button).  

Via the Tooltip texts 
If you move the cursor slowly over a button in the toolbar, a brief description 
appears for a short time.  
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SIMATIC iMap documentation 
You can call up documentation about SIMATIC iMap: 

• In Windows, open the individual documents as PDF files  using the Start > 
Programs > Component based Automation > Documentation > SIMATIC 
iMap > ... command.  

• In SIMATIC iMap, you can open the complete documentation as online help 
using the Help > Help Topics menu command.  
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3.3 Operating philosophy 

3.3.1 Objects and object hierarchy 

Ease of use  
SIMATIC iMap's graphical user interface is designed to be as straightforward and 
intuitive to use as possible. It therefore contains objects with which you are familiar 
from your daily work: devices, functions and charts. 

Object-oriented operation 
In the SIMATIC iMap user interface, objects are represented by graphical symbols. 
You can open and edit the objects by selecting the symbols. In most cases, when 
you work with SIMATIC iMap you will use the normal Windows conventions.  

Object hierarchy 
In SIMATIC iMap, projects may have a hierarchical structure. By default, the 
project tree contains two tabs, the "plant tree� and the "net tree�. The technological 
functions are listed under "Plant tree�, while the devices can be found under "Net 
tree �. 
New charts, which may contain further charts or objects, may be inserted into the 
project tree under "Plant tree". PROFIBUS masters can be represented 
hierarchically with the associated PROFIBUS slaves under "Net tree ". Example: 

 
Figure 3-2 Project tree, example of an object hierarchy 
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Object properties 
Objects have properties, e.g. addresses and connectors. Once you have selected 
an object, you can then open a dialog box using the Properties pop-up menu, for 
example, in order to make certain object-specific settings.  

Actions on objects 
You can carry out certain actions on each object, e.g. Copy, Cut, Paste. When you 
select an object, the actions that you can carry out on that object are displayed in 
the context menu. 

Associated objects 
The associated objects in a SIMATIC iMap project are: a PROFInet component 
and its instances (devices and optionally technological functions). The following 
diagram show how they fit into the project. 

Figure 3-3 PROFInet components and their instances 
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3.3.2 Editing objects 

Basic actions 
Certain basic actions on objects are the same for all objects. These basic 
sequences of actions are summarized below. In the following chapters of this 
manual, we have assumed that you already know how to use them when we 
describe individual procedures. If you attempt to carry out an illegal action, you will 
be stopped and the cursor will change into a Stop sign. 

The usual sequence of actions for handling objects is as follows:  

• Create the object  

• Select the object  

• Perform actions with the object  

Creating objects  
With SIMATIC iMap you can create new libraries, projects and charts. The actual 
PROFInet components are created using a device-specific programming and 
configuration tool, e.g. STEP 7. 

Use the following menu commands to create objects: 

• Library > New 

• Project > New 

• Insert > New Chart 

Creating an object hierarchy 
The project forms an object hierarchy. The "Plant tree" and "Net tree " views are 
automatically created in the project tree. When a chart is opened, objects already 
contained in that chart appear in the project tree.  

You can then structure the project further by inserting more charts into a project or 
even into another chart. You can also insert new charts into the project tree and 
plant view.  

At the bottom of the object hierarchy are the technological functions and devices. 
These are automatically created when the PROFInet components are inserted into 
a project.  

Opening objects 
In SIMATIC iMap you can open libraries, projects and charts. These objects are 
opened using the following menu commands: 

• Library > Open 

• Project > Open  

• Edit > Open Selected Chart or by double clicking on the chart. 

Once you have opened an object, you can then create or modify its content. You 
cannot, however, open projects that are currently in use.  
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Setting object properties 
Object properties are the data of an object that define its behaviour. The 
Properties context menu opens the dialog box in which you can read or set the 
properties of the highlighted object. 

 

 Note 
If you change the settings of objects, e.g. interconnections, offline in SIMATIC 
iMap, they do not take immediate effect on the plant. These changes will not 
become active until you download the data to the target system.  

Cutting, pasting and copying 
Most objects can be cut, pasted and copied as is usual under Windows. The 
associated menu commands can be found in the Edit menu and the context 
menus that you access by clicking the right mouse button. 

You can also Drag&Drop objects to copy them. If you attempt to drop the object at 
a destination that is not permitted, the cursor changes into a Stop sign. 

 

 Note 
New PROFInet components are inserted into the project from a library.  

PROFInet components that have already been inserted may be copied or inserted 
in the net or plant view, or may be dragged from the project tree and dropped in 
the net or plant view. 

Selecting objects - Multiple selection 
Several objects may be selected at the same time in the net and plant views 
(multiple selection). To do this, hold down the left mouse button and catch the 
objects using the lasso. 

With multiple selection, only objects of the same type may be selected, e.g. only 
technological functions and charts or only connectors may be selected in the plant 
view. Objects are selected in the following order: If the lasso contains complete 
technological functions and charts, these objects are selected complete with all the 
associated interconnections. If this is not the case, any complete connectors that 
they contain are selected. If there are no connectors, then any interconnections 
that they contain are selected.  

 Note 
Hint: You can also make multiple selections with the left mouse button by holding 
down the �Shift� or �Ctrl� key at the same time. 

Copying subordinate charts 
When you copy a subordinate chart, the entire hierarchy beneath that object is 
copied as well. This means that, once a subsystem has been developed, it can 
then be reused in many other systems. 
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 Note 
Please note that, in this case, PROFInet components without technological 
functions such as the IE/PB Link are not copied as well. If you wish to copy a 
PROFIBUS master together with its PROFIBUS slaves, we recommend that you 
make the multiple selection in the net view.  

Renaming objects 
In SIMATIC iMap you can change the names of technological functions, devices 
and charts. The names of PROFInet components in the libraries cannot be 
changed, however. 

Technological functions and devices are given the name of the PROFInet 
component by default. If the same PROFInet component is used several times, 
then the name is supplemented by a consecutive number, regardless of which 
level of the hierarchy the component is located, e.g. Machining_1.  

When a new chart is inserted, it is called "New Chart" by default. A second chart is 
called "New chart_1", and so on. 

To rename, highlight the desired object and select Edit > Properties.... Change 
the name in the dialog box and click on the "OK" button. When you close the 
Properties dialog, the object is renamed and appears with the new name.  

Moving objects 
In SIMATIC iMap you can move the following objects using Drag&Drop: 

• PROFInet components from one library to another. 

• Devices in the net view from one Ethernet or PROFIBUS network to another. 

• Technological functions in the plant view. 

• Charts within the project tree. 

Deleting objects 
You can delete both folders and objects. When you delete a chart, you also delete 
all the objects contained in that chart.  

The project tree and the SIMATIC iMap net , plant and project views are different 
representations of the same project. If an object is removed from one of the 
windows, it automatically disappears from the other windows.  

 

 

Caution 
The deletion operation cannot be reversed. If you might need an object again, then 
you should archive the entire project first. 

When you delete an object, you also delete the corresponding interconnections 
with a technological function! It may therefore be necessary to reconnect the inputs 
and outputs to other technological functions. 
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Finding objects: 
With the Edit > Find... menu command, you can find all the objects whose names 
contain a certain character string.  
The components, instances, devices and functions thus found are listed in the 
information window. Double-click on an entry in the information window to select 
and display the corresponding object in the plant view, net view, project view or 
project library. 

Highlighting associated objects 
Once you have highlighted an object, you can double-click on that object or use the 
Edit > Select in all Windows menu command to highlight all the associated 
objects (PROFInet component, device and technological function, if applicable) in 
the other windows as well. 

Example: If you double-click on a technological function in the plant view, the 
following objects are highlighted: 

• in the library: the PROFInet component whose instance contains the selected 
function,  

• in the project view: the instance of the PROFInet component, 

• in the plant tree of the project tree: the same technological function and  

• in the net tree of the project tree and in the net view: the associated device. 
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3.4 Windows and views 

3.4.1 SIMATIC iMap user interface 

Structure  
The SIMATIC iMap user interface is made up of various windows that can be 
opened and closed as required by clicking on the icons in the toolbar. 

Figure 3-4 SIMATIC iMap user interface 
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Table 3-1 SIMATIC iMap user interface 

No. Window Icon 

 1 Project tree 
 

 2 Diagnostic window 
 

 3 Information window 
 

 4 Library window 
 

 5 Preview window (can only be opened in conjunction with the library 
window)  

6 Plant view, net view or project view (always open)  

7 Menu bar (see description in the appendix)  

8 Toolbar (see description in the appendix)  

 

Using SIMATIC iMap 
Depending on which window is active, various actions can be carried out. Features 
used in Windows applications are available here: 

• Menu commands (menu bar, context menus or icons in the toolbar), 

• Drag&Drop, 

• Keyboard input 

Calling help 
To call up help about a window in the user interface, click in the window and press 
function key F1. 
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3.4.2 Plant view 

Description 
In the plant view, the instances of the inserted PROFInet components are visible 
as technological functions. The interconnections, i.e. the logical data connections 
between two or more technological functions, are represented by a line. These 
lines cannot be manipulated. Lines which cannot be displayed, for example, due to 
a lack of space are replaced by "continuation" connectors.  

Figure 3-5 Plant view 

Actions 
The main actions available in the plant view are as follows: 

• Inserting instances of PROFInet components from the libraries 

• Displaying and modifying properties of instances.  

• Creating and deleting interconnections 

• Displaying and modifying properties of connectors 

• Downloading interconnections and programs to the devices of the plant  

• Inserting and deleting new charts  

• Printing charts.  

• Set and display online values 

• Comparing online and offline data 

• Diagnosing technological functions and interconnections 
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Reference to other windows and views 
If a PROFInet component is inserted into the plant view, then the instance in the 
project view, the technological function in the plant tree and the device in the net 
tree of the project tree are displayed automatically.  

From a highlighted object in the plant view you can use the Go To context menu to 
jump directly to the associated object in one of the other windows. 

3.4.3 Net view 

Description 
In the net view  the instances of inserted PROFInet components are displayed as 
objects with one or more network connectors. They are designated as "Devices" in 
the net view. The devices each have IP and/or PROFIBUS addresses. 

The Ethernet is created as a green line and the PROFIBUS network as a violet 
horizontal line when a PROFInet component of a PROFIBUS master with proxy 
functionality is inserted from a library. Possible insertion positions are highlighted in 
color. 

Figure 3-6 Net view 
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Actions  

The main actions available in the net view are as follows: 

• Inserting PROFInet components from the libraries.  

• Moving, copying, cutting or deleting devices. 

• Displaying and modifying properties of instances.  

• Inserting, cutting, moving and deleting Ethernet nodes. 

• Coupling uncoupled PROFIBUS devices to a PROFIBUS network. 

• Assigning addresses. 

• Downloading programs and interconnections to all or just the selected devices. 

• Printing the net view. 

• Online monitoring and diagnostics of devices. 

• Comparing online and offline data. 

To insert an Ethernet node: 
The Insert > New Ethernet node menu command is used to create a new 
Ethernet node in the net view. Several PROFInet devices without proxy 
functionality may be coupled to it (see diagram below). 

 
Figure 3-7 Ethernet node in the net view 

Reference to other windows and views 
If a PROFInet component is inserted into the net view, then the instance in the 
project view, the technological function in the plant tree and the device in the net 
tree of the project tree are displayed automatically if necessary. 

From a highlighted object in the net view you can use the Go To context menu to 
jump directly to the associated object in one of the other windows. 
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Uncoupled PROFIBUS devices 
Uncoupled PROFIBUS devices are saved in the net view above a separating line  

• if no PROFInet component with proxy functionality has been inserted yet or  

• if the PROFInet device with proxy functionality, to which they were coupled, was 
deleted from the project window or the net or plant view or  

• when inserting the component into the plant view or project view, if the "Couple 
PROFIBUS devices automatically" check box is unchecked on the "Net view" 
tab in the Customize dialog box (Options > Customize menu command). 

Uncoupled PROFIBUS devices can be coupled to a PROFIBUS network using 
Drag&Drop. 

Figure 3-8 Net view, uncouple PROFIBUS devices 
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3.4.4 Project view 

Description 
The project view represents the association between the PROFInet components in 
the library and the inserted instances � functions and devices. The information is 
shown in table format (see diagram below). 

 
Figure 3-9 Project view 

The instances present in the project plus the integrated HMI devices (if present) 
and their generation status are displayed for every PROFInet component.  

Table 3-2 Information in the project view 

Column Content 

Component Name, version and creation date of the PROFInet 
component 

Generation status of the 
instance 

Graphical representation 

Device Icon and name of the device  

Technological function Icon and name of the technological function 

Generation status of the 
HMI module 

Graphical representation 

HMI module Integrated HMI module  
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Symbols for the generation status 

Table 3-3 Generation status - graphical representation 

Icon Meaning 

 The generation was successful. 

 Generation is required 

 

Hint: The generation status is displayed as a Tooltip.  

Actions 
You can carry out the following actions in the project view: 

• Cutting, copying or deleting instances 

• Replacing instances 

• Looking up and modifying properties 

• Showing/hiding instances 

Showing/hiding instances  
You can show and hide information about instances as follows: 

• Using the menu commands:  

� View > Project view > Show instances or 

� View > Project view > Hide instances 

• By clicking on the "+"- or "-" symbol in the Component column. 
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3.4.5 Project tree 

Description 
In the project tree, the objects in the project are shown hierarchically. The project 
tree has two parts:  

• The plant tree � corresponds to the plant view 

• The net tree � corresponds to the net view  

 
Figure 3-10 Project tree 

The technological functions are displayed in the plant tree and the devices in the 
net tree when PROFInet components are inserted into the project. Subordinate 
charts are also displayed hierarchically in the plant tree. PROFInet components 
which do not contain a technological function, e.g. the IE/PB link, are only 
displayed in the net tree. 

The plant tree contains the designation of each function, while the net tree contains 
the designation of the device, e.g. BM 147. 

Changing the project view 
You can use the View > Project tree >...  menu command to:  

• display additional information about the objects and 

• show/hide hierarchical levels. 
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Actions  
The main actions available in the project tree are as follows: 

• Navigating between different charts. 

• Moving, copying, inserting and deleting objects. 

• Looking up and modifying properties. 

• Downloading programs and interconnections to the devices of the plant. 

• Comparing online and offline data. 

• Creating and opening subordinate charts in the plant tree. 

Reference to other windows and views 
When you insert a PROFInet component into the SIMATIC iMap project, the 
technological function in the plant tree is automatically displayed in the project tree 
and the device is displayed in the net tree. 

Double-clicking on an object in the project tree highlights all the associated objects 
in the other windows.  
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3.4.6 Library window 

Description 
Several libraries can be opened concurrently in the library window. Libraries are 
used to manage and structure PROFInet components. 

The PROFInet component from a library can be displayed with large or small icons 
or as a list with or without detailed information via the  View context menu.  

 
Figure 3-11 Library window 

The project library is assigned to the most recently opened project. It is 
automatically opened, saved and closed together with the project. 

Actions 
You can carry out the following actions in the library window: 

• Creating, opening and closing libraries. 

• Importing PROFInet components from the file system into a library. 

• Inserting PROFInet components from a library into the plant or net view. 

• Cutting or copying PROFInet components and pasting them into other libraries. 

• Displaying the properties of a PROFInet component. 

 

 Note 
Libraries are stored as folders in the file system, where they can be moved, copied, 
inserted or deleted. Libraries which are deleted in Explorer can no longer be 
opened via SIMATIC iMap. 
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Reference to other windows  

If a PROFInet component is selected in the library window, information on this 
component is displayed on four information tabs in the preview window. 

 
Figure 3-12 Library and preview windows 
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3.4.7 Preview window 

Description 
The preview window  displays information on each PROFInet component selected 
in a library on four information tabs. 

The library window must be open in order to open the preview window. 

Info tab 
This tab displays information on the PROFInet component selected in a library.  

Double-click on the "Documentation" link to open the documentation for the 
PROFInet component. The link is only displayed if the component contains a 
documentation link. 

 
Figure 3-13 Preview window, Info tab 
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Function tab 

This tab displays the technological function of the PROFInet component selected in 
a library.  

 
Figure 3-14 Preview window, Function tab 

Device tab 
This tab displays the device for the PROFInet component selected in a library. 

 
Figure 3-15 Preview window, Device tab 
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HMI tab 
This tab displays the HMI units of the PROFInet component selected in a library (if 
present). 

Actions 
You can carry out the following actions in the preview window: 

• On the Info tab: Open the documentation stored for a PROFInet component (if 
present). 

• On the Function tab: Display the technological function. 

• On the Device tab: Display the device. 

• On the HMI tab: Display the HMI units. 

Reference to other windows and views 
The preview window can only be opened if the library window is open. The preview 
window is closed when the library window is closed. 
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3.4.8 Diagnostic window 

Description 
Diagnostic information on process variables and on faults in technological 
functions, devices and interconnections is displayed on three tabs in the diagnostic 
window. The three tabs in the diagnostic window are: 

• Functions 

• Device 

• Variable table - described in a separate section. 

To display the diagnostic information on the "Functions" and "Devices" tabs, select 
the Online > Monitor menu command. 

Functions tab 
All the malfunctions are displayed in the left-hand window. In the right-hand 
window, you will find detailed information about each selected object and, if 
relevant, buttons for downloading or calling up help or device-specific diagnostics. 

Figure 3-16 Diagnostic window, Functions tab 
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Devices tab 

Information on all faulty devices is displayed in the left-hand window. In the right-
hand window, you will find detailed information (and possible causes and 
remedies) about each selected object and buttons for calling up help or device-
specific diagnostics. 

Figure 3-17 Diagnostic window, Devices tab 

Actions 
You can carry out the following actions in the diagnostic window: 

• Finding and analyzing errors. 

• Reading troubleshooting information, e.g. that a download is required. 

• In the right-hand window, you can click on any buttons that are present: 
Button Action 

Diagnostics Calls up the device-specific diagnostics 

Download Downloading interconnections  

Help Calls up help  

 

Reference to other windows and views 
A fault that appears in the diagnostic window is identified by a symbol on the 
affected device in the net view, on the technological function in the plant view and 
on the instance in the project view. 

Double click on a faulty function in the diagnostic window to display the affected 
technological function in the plant view. 

Double-click on a faulty device in the diagnostic window to the affected device in 
the net view. 
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Example of faults in technological functions 
The following diagram illustrates technological functions for which the 
interconnections will have to be downloaded. The right-hand window shows which 
interconnections have to be downloaded for the selected function. If you click on 
the "Download" button, the interconnections are downloaded to the target system. 

Figure 3-18 Diagnostic window: Example of faults in technological functions  
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3.4.9 Diagnostic window, "Variable table" tab 

Description 
The variable table is used in SIMATIC iMap for online monitoring and control of 
variables during the plant testing and commissioning phase. It has its own online 
mode that can be switched on and off independently of the online monitoring in the 
plant and net views. 

The variable table contains the data for the connectors of the SIMATIC iMap 
project to be monitored. You can enter the connectors directly or use drag-and-
drop to insert them from the plant view into the variable table. 

Individual columns in the variable table can be shown / hidden using the View > 
Variable table >... menu command or with the Columns >... context menu. 

The following diagram shows a variable table in the online view. 

 
Figure 3-19 Diagnostic window, "Variable table" tab 

Actions 
You can carry out the following actions in the variable table: 

• Adding, copying, deleting and sorting entries 

• Changing the display format 

• Showing/hiding columns  

• Monitoring and controlling all or just selected variables online 

• Editing control values and transferring them to the devices of the plant for 
testing purposes. 

• Importing and exporting data 

Reference to other windows 
The Go To > Function connector context menu command highlights the 
associated connector in the plant view. 
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3.4.10 Information window 

Description 
The information window displays information about current actions in 
SIMATIC iMap. The appropriate tab is opened automatically when new information 
arises about an action.  

Figure 3-20 Information window 

Content of the information window 
The following messages are automatically displayed on the tabs in the information 
window: 

Tab Content 

General Status and progress of the action, plus any errors that occur 
while running commands, such as Open and Save, Download 
or Online Connection. 

Results when searching for objects. 

Generate Generation status and progress 

Online / offline 
comparison 

Result of the online / offline comparison of programs and 
interconnections 

Utilization Result of the utilization check for devices and functions 

 

The "Reference object" column lists the names of the objects to which the 
messages relate.  

 

 Note 
The old content of the information window is not automatically deleted when new 
messages are displayed. 
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Editing the content 
You can edit the content of the information window as follows: 

• Use the Edit > Information window > Copy All  menu command to copy all 
the messages in text format to the clipboard so that they can be further edited, 
e.g. by pasting them into a text editor. 

• Use the Edit > Information window > Delete All  menu command to delete all 
the messages. 

Reference to other windows 
Double-click on a reference object to highlight the associated object in the relevant 
view. 

3.4.11 Information window, "General" tab 

Displays information about actions such as opening or creating projects and 
libraries in SIMATIC iMap. This information window tab opens automatically when 
new information arises about such actions. 

3.4.12 Information window, "Generate" tab 

Displays the progress and any errors during generation of the project. This 
information window opens automatically when a project is generated. 

3.4.13 Information window, "Online-offline comparison" tab 

Displays the results of the online/offline comparison of programs and/or 
interconnections. This information window tab opens automatically when an 
online/offline comparison is carried out. 

3.4.14 Information window, "Utilization" tab 

Displays the results of the utilization check of the configured devices and functions. 
This information window tab opens automatically when new information arises 
about such actions. 
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3.4.15 Menu bar 

Description 
The menu bar contains the menu commands for SIMATIC iMap. A brief description 
of the selected menu command is displayed on the SIMATIC iMap status bar. A 
summary of all the menu commands can be found in the appendix. 

3.5 Setting up and starting tools 

You can configure SIMATIC iMap so that you can start any software tool with a 
menu command, e.g. in order to further edit data from the current project.  

To set up a new tool: 
1. Select the Options > Customiye menu command and open the "Tools" tab  

2. Click on the "New Entry" button. 

3. In the "Name" box, enter the name under which the program is to be called in 
SIMATIC iMap. 

4. In the "Command" box, enter the path of the program or click on the "Browse" 
button to select the program from the file system. You can select the following: 

� the actual program (e.g. winword.exe) or  

� a file (e.g. <document>.doc) to be opened with this program. 

5. Click on "OK" or "Accept" to confirm your input. 

Result: The program is added to the list of tools that can be called directly in 
SIMATIC iMap. 

 
Figure 3-21 Setting up tools 
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 Note 
You can use the buttons in the Customize dialog to move or delete entries in the 
tools list.  

To start a tool you have set up: 
You can only call tools  that are entered under "Tools" in the settings. 

To start a tool, select the Options > Tools > ... menu command. 

Result: The called program is started. 
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Configuring plants 4
4.1 Basic procedure for configuring the plant 

Requirements 
The following requirements must be fulfilled before you can configure a plant using 
SIMATIC iMap: 

• SIMATIC iMap must be installed on your PC/PG. 

• The device-specific configuration and programming tool, e.g. STEP 7, is 
installed on your PC/programming device (optional). Depending on the type of 
device, this software is needed in order to carry out certain actions, e.g. 
Generate. 

• The necessary PROFInet components must have been created. 

Basic procedure 
1. Start SIMATIC iMap 
2. Create or open a project. 
3. The options are as follows, depending on whether the PROFInet components 

have already been imported into a target library: 
� If yes, then open the library with the PROFInet components. 
� If no, then open a library or create a new library and import the PROFInet 

components. 
4. Insert PROFInet components into the SIMATIC iMap project. 
5. Couple devices in the net view. 
6. Assign IP and/or PROFIBUS addresses to the devices. 
7. Interconnect technological functions in the plant view. 
8. Modify properties (optional). 
9. Check the configuration (utilization) of the devices and functions (optional). 
10. Re-edit PROFInet components (optional) 
11. Replace instances (optional). 
12. Generate a SIMATIC iMap project.  
13. Document a SIMATIC iMap project (optional). 
14. Print a SIMATIC iMap project (optional). 
15. Archive a SIMATIC iMap project and library (optional). 
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4.2 Working with projects 

4.2.1 Creating a new project 

Creating a new project 
A new SIMATIC iMap project is always opened when you open SIMATIC iMap. 
You can edit and save this project or open an existing project for editing. 

How to create a new SIMATIC iMap project 
The options for creating a new SIMATIC iMap project are as follows: 

• Restart SIMATIC iMap or 

• Select the Project > New menu command. 

A new SIMATIC iMap project opens in both cases. The associated project library is 
opened in the library window. 

The SIMATIC iMap project is stored in a folder. 

 

 Notice 
The content of a SIMATIC iMap project folder must only be edited with 
SIMATIC iMap.  

If you change the project data using Windows Explorer, for example, it may no 
longer be possible to open the project in SIMATIC iMap. 

 

The actual project folder may be renamed, moved, copied or deleted in Windows 
Explorer, however. 

 

 Note 
In SIMATIC iMap, you can only edit one project at a time. If you wish to edit 
several projects at the same time, then you must start several instances of 
SIMATIC iMap. 
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4.2.2 Opening and closing projects 

Requirement 
A new, empty SIMATIC iMap project is always opened when you open SIMATIC 
iMap. You can open a different project at any time, provided that this project was 
saved in SIMATIC iMap. 

In SIMATIC iMap, only one project may be open at any given time. When you open 
a new project, the current project is closed and you are prompted to save any 
changes you have made. 

 

 Note 
A SIMATIC iMap project cannot be open in two SIMATIC iMap applications 
concurrently. 

To open a project in SIMATIC iMap 

Figure 4-1 Open the SIMATIC iMap project 
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1. Select the Project > Open... menu command.  

A dialog box for browsing the file system for existing projects opens. Look for a 
project file with the extension .cbp. 

2. Select the project folder from the "Search in" box. The box beneath display only 
directories and files of the desired file type - SIMATIC iMap project. 

3. Select the file name with the extension .cbp.  

The file name is displayed in the "File name" box. 

4. If the selected project is password-protected, enter your password in the 
"Password" box. 

5. Click on the "Open" button. 

Result: The project is opened in SIMATIC iMap.  

Hint: The "File name" drop-down list contains the most recently opened 
SIMATIC iMap projects. 

To close a project in SIMATIC iMap  
To close a project in SIMATIC iMap, you can either: 

• Exit SIMATIC iMap, 

• Create a new project or 

• Open another project. 

Each of these options closes the current project. If you have made any changes to 
the current project or to the project library, you are first prompted to save these 
changes. A dialog box with the following selection options opens:  

• "Yes" to save the changes to the current project before closing  

• "No" to close the current project without saving 

• "Cancel" to cancel the operation and return to the current project. 

 

 Note 
Changes that have to be saved with the project include the following: 

• Changes to the project library 

• Changes to the variable table 

• Changes to the OPC prefix 
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Projects from the previous version 
The way in which data is stored in the latest version of SIMATIC iMap (V2.0) has 
changed, and is no longer compatible with the previous version (V1.2). 

If you want to edit a project that was created in SIMATIC iMap V1.2, you will have 
to convert the data storage system to the current version. The associated SIMATIC 
iMap library must be open to be able to convert the PROFInet components used.  

1. Start SIMATIC iMap 

2. Use the Library > Open... menu command to open the library that was used for 
the project from the earlier version. 

3. Open the project using the Project > Open menu command. 

Result: The project is converted to the new version of the data storage system, and 
the PROFInet components used are imported into a project library.  

 

 Notice 
After conversion, you will no longer be able to open the project using 
SIMATIC iMap V1.2. 

Recommendation: 

If you wish to continue opening the project in SIMATIC iMap V1.2, create a copy of 
the project before you open it in the current version. 
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4.2.3 Saving and archiving projects 

Data storage for a SIMATIC iMap project 
A SIMATIC iMap project is created in the form of a directory tree, and can be 
stored as an archive file. 

If you save it, all the files belonging to the SIMATIC iMap project are stored in a 
separate folder. You are prompted to enter the path when you save the project for 
the first time. You can enter any name for the project file. It is automatically given 
the extension .cbp. The project file is stored together with other project data in a 
folder of the same name. 

If you archive it, all the project data is stored in an archive file. You can enter any 
file name, and the archive file is automatically given the extension .arp. 

 

 Note 
Use the Options > Customize menu command to define, on the "Directories", a 
storage location that will be suggested by default when you open, save or archive 
projects. 

Password protection 
You can assign a password to your SIMATIC iMap project in order to protect it 
against unauthorized access. This password is defined via Project > Properties 
on the "General" tab, and must be entered whenever you open the project. The 
project cannot be opened without the password. 

When you archive a project, it retains its password protection. 

To save a SIMATIC iMap project:  
The options for saving a project in SIMATIC iMap are as follows:  

• Select the Project > Save  menu command to save the current project under 
the same name. The old project is overwritten. 

• Select the Project > Save As... menu command to save the current project 
under a different name. The old project remains unchanged. You can enter any 
path and name for the new project. 

If you save a project with a new name, it retains its password protection. The 
project library is saved together with the project. 

To archive a SIMATIC iMap project:  
 

 Note 
You cannot archive SIMATIC iMap projects unless they are closed. To archive the 
current project, you must first close it by creating a new project or opening another 
project. 
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To archive a project, proceed as follows:  

1. Make sure that the project to be archived is closed and that no other programs 
are accessing the project folder. 

2. Select the Project > Archive... menu command.  

A dialog box for browsing the file system for existing projects opens. Look for a 
project file with the extension .cbp. 

3. Select the project folder from the "Search in" box. The box beneath displays 
only directories and files of the desired file type - SIMATIC iMap project. 

4. Select the file name with the extension .cbp.  

The file name is displayed in the "File name" box. 

5. Click on the "Open" button.  

A dialog box for selecting the storage location opens.  

6. In the "Archive iMap project library as..." dialog box, select the folder in which 
the archive file is to be stored.  

7. Accept the name suggested in the "File name� box or enter a different name for 
the archive file, and click on "Save�. 

Result: The archive file is created and the result is signalled on screen. The project 
library is archived together with the project. 

To retrieve a SIMATIC iMap project:  
 

 Note 
You can only retrieve projects that were archived with SIMATIC iMap.  

 

To retrieve a project, proceed as follows:  

1. Select the Project > Retrieve... menu command.  

A dialog box for browsing the file system for existing archive files opens.  

2. Select an archive file (.ARP file). There are two options: 

� Search for the required archive file in the "Search in" box or 

� Select the most recently archived projects from the "File name" drop-down 
list.  

3. Click on the "Open" button.  

A dialog box for selecting the target folder opens.  

4. Select the folder to which you wish to save the retrieved project and click on 
"OK".  



Configuring plants 

 Component based Automation, Configuring Plants with SIMATIC iMap 
4-8 A5E00248797-01 

Result: The project folder is created in the specified target folder and the result is 
signalled on screen. 

 

 Note 
When you archive a project, it retains its password protection. 

4.2.4 Generating the project 

Generating in SIMATIC iMap 
You must generate a project before you can download data from that project to the 
devices of the plant. When you generate the project in SIMATIC iMap, the current 
project data for all instances of PROFInet components contained in the SIMATIC 
iMap project is prepared for specific devices, so that it can be downloaded to those 
devices in the plant.  

To generate, SIMATIC iMap requires the vendor-specific configuration and 
programming tool for the configured devices, e.g. STEP 7 for SIMATIC 
programmable controllers. A separate generation process is required for each 
integrated vendor-specific configuration and programming tool. The current version 
of SIMATIC iMap supports the following generation processes: 

Menu command Device type 

Project > Generate > Control unit > Control units of the SIMATIC programmable 
controllers 

Project > Generate > HMI units > HMI units of the SIMATIC programmable 
controllers 

 

Unless expressly stated, the following descriptions relate to generation of the 
control units of the SIMATIC programmable controllers. A description of the HMI 
units can be found under "Special PROFInet component types, PROFInet 
components with HMI units". 

The shadow project 
The shadow project is a folder that contains the vendor-specific data for the control 
units in the project. HMI units and singleton components are not contained in the 
shadow project (see the section entitled �Special PROFInet component types�). 

The shadow project is created from the component projects in the project library 
when the SIMATIC iMap project is generated for the first time. All changes to 
PROFInet components in the SIMATIC iMap project, e.g. IP addresses or 
PROFIBUS addresses, are transferred to the shadow project whenever the project 
is generated again.  

The shadow project is needed for program downloads. 
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 Note 
The Project > Save menu command does not update the shadow project. 

 

 Caution 
The shadow project must not be modified directly via the vendor-specific 
configuration and programming tool (e.g. STEP 7). 

Changes to the shadow project may lead to inconsistent data in the SIMATIC iMap 
project, preventing any further downloads. 

Possible remedies 

•  Regenerate SIMATIC iMap project 

• Create new PROFInet components from the modified shadow project and 
replace the old instances.  

 

The Edit > Check Consistency menu command compares the current shadow 
project with the corresponding component project(s). The result of the consistency 
check is displayed on the "General" tab in the information window. 

Which actions are transferred when the project is generated? 
The following actions in SIMATIC iMap are transferred when the project is 
generated: 

• Cutting, copying or deleting devices or technological functions and their 
interconnections 

• Replacing instances 

• Inserting new instances of PROFInet components into the project 

• Changing the properties of instances, e.g. names or addresses 

• Changes to the device networking, e.g. coupling and uncoupling PROFIBUS 
devices  

 

 Note 
If you have made any of the above changes to the project, they cannot be 
downloaded to the devices of the plant until you have generated the control units in 
the project.  
You can tell from the generation status whether the generation is required. The 
generation status of the instance of a PROFInet component is displayed in the 
project view and in the Properties dialog box for the instance. The generation 
status "generated" means that downloading to the devices of the plant is possible. 
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Which actions are not transferred when the project is generated? 
• Changes to the device-specific data of the shadow project that you make using 

one of the Edit > Special... menu commands. These changes must be 
downloaded to the devices in the plant using the vendor-specific configuration 
and programming tool.  

• Changes to the graphical representation, e,g, the position within the plant view. 

Requirement 
Before you generate a project, you must ensure that the necessary vendor-specific 
configuration and programming tool, e.g. STEP 7, is installed on the computer. 

To generate the changes to the control units of the project:  
Call the Project > Generate > Control unit > Changes only menu command to 
generate just the changes to the project. The generation progress messages and 
any error messages are displayed on the "Generate" tab in the information window. 

When you run this menu command for the first time, the shadow project is created 
from the component projects in the library(ies). Whenever this menu command is 
called again, the shadow project is updated with any changes you have made. 

If the generation was successful, all the components of the project receive the 
generation status �generated�. The program can then be downloaded. The 
generation status can be seen in the project view (green icon) or from the 
properties of the instances.  

To regenerate the control units of the project: 
If the SIMATIC iMap project cannot be generated because the shadow project 
contains incorrect or inconsistent data, for example, then the shadow project must 
be recreated. When you regenerate, the shadow project is recreated from the 
component projects for the PROFInet components in the library(ies).  

Select the Project > Generate > Control unit > All menu command. If the project 
has already been generated, a message appears to indicate the effect that the 
command has had. Click on "Yes" to acknowledge this message if you wish to 
regenerate.  

The generation progress messages and any error messages are displayed on the 
"Generate" tab in the information window. 

Result: The shadow project is created once more from the component projects for 
the PROFInet components in the project library. The regenerated shadow project 
does not contain changes you have made using the vendor-specific configuration 
and programming tool. A copy is made of the old shadow project. You can use this 
to copy any changes in the new shadow project. 

 

 Note 
Only 3 backup copies of the shadow project are kept in the project directory. 

If there are 3 backup copies already, then the oldest is deleted during the 
generation process. 
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Cancelling generation 
Generation can take a long time for large projects, You can cancel and 
subsequently resume the generation of changes at any time by clicking on the 
"Cancel" button in the message box. Any data you have already generated is 
retained when you cancel. 

If you then call the Project > Generate > Control unit > Changes only menu 
command again, only the new, modified and still ungenerated parts of the project 
are generated. 

Generating the HMI units 
The HMI units of the instances are generated using the Project > Generate > HMI 
units menu command.  

Further information can be found under "Special PROFInet component types, 
PROFInet components with HMI units". 

4.2.5 Documenting and printing a project 

Content of the project documentation 
You can create documentation containing the following information for a 
SIMATIC iMap project: 
• General project data such as name, path and creation date  
• All the technological functions and subordinate charts of the plant chart and 

their interconnections  
• All the PROFInet and PROFIBUS devices of the network chart 
• The PROFInet components used as library elements and their instances 

(devices and functions) in the project 
• Optional � descriptions of the interconnectable and non-interconnectable 

connectors of the component interfaces 
• Optional � graphical representations of all charts (network chart, plant chart and 

optionally subordinate charts) 

To create the project documentation 
1. Select the Project > Documentation menu command.  
2. In the "Create Project Documentation" dialog box, activate the options for the 

information to be transferred to the documentation. 
3. If necessary, click on the "Modify" button and change the path under which the 

project documentation is stored. 
4. Confirm by clicking on the "OK" button. 
Result: The most current version of the project is documented. The project 
documentation is stored as a collection of HTML files together with the associated 
graphics files (icons, etc.) in the folder.  
The project documentation is structured as an online document, rather than as a 
template for printing. Use the menu command Project > print to print the project 
data. 
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 Note 
The project documentation is recreated whenever you call the Project > 
Documentation menu command.  

You can display stored project documentation versions by opening the HTML file 
directly in an HTML browser. 

To set up the page for printing: 
Select the Project > Page Setup  menu command to make the following settings 
for printing the current window: 

• Paper size and source 

• Paper orientation (portrait or landscape) 

• Width of the page margins 

To set up the header and footer 
You can set up the header and footer as follows in order to print the plant or net 
view: 

1. Select the Project > Headers and Footers menu command.  

A dialog box for setting the header and footer opens. 

2. Enter the content of your header and footer. You can edit the �Left�, �Middle� 
and �Right� boxes. The field buttons can be used to automatically insert field 
functions, such as the project name or page. 

3. Specify the font and point size, if necessary.  

4. You can specify the type of separating lines to be inserted between adjacent 
pages and for the lines in the header and footer. 

5. Click on �OK� to accept the settings. 

To print the project: 
• Select the Project > Print > Active Window menu command to print the plant 

view, net view or project view for the current project. The active window is 
printed with the current zoom factor. 

• Use the menu command Project > Print > All Charts menu command to print 
all the charts in the project, i.e. the net view and the plant view, and all 
subordinate charts. They are printed with the zoom factor 100%. 

Large projects are printed on several pages. 

Hint: Use the menu command View > Plant view > Show Page Margins to show 
and hide the page margins in the plant view, thus providing a preview of the printed 
area. 
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4.3 Working with libraries 

4.3.1 Library types in SIMATIC iMap 

Project libraries and global libraries 
There are two types of library in SIMATIC iMap: 

• Project library, which is contained in a SIMATIC iMap project and is opened, 
closed, archived and retrieved automatically with the project. The project library 
contains all the PROFInet components whose instances are contained in the 
project. The information needed to generate the project is thus available.  

• (Global) library that can be opened, closed archived and retrieved using menu 
commands. The global library contains PROFInet components that can be used 
in several projects. 

In the following descriptions, the global library is simply called the "library". 

When a PROFInet component is inserted from a global library into the project, it is 
automatically inserted into the project library as well. PROFInet components that 
have already been inserted into the project are identified in the project library by a 
tick (see diagram below). 

Figure 4-2 Example: Project library and global library 
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Comparison between a project library and a global library 
 

Property/Action in the project library in global libraries 

Create automatically with the project  independently of the project, using the 
Library > New... menu command 

Name Project library any 

Open / Close automatically with the project  separately from the project, using the 
Open library... or Close library menu 
command 

Import PROFInet 
Components 

• automatically when the PROFInet 
component is inserted into the 
project from a global library or 

• using the Library > Import 
components menu command 

using the Library > Import 
components menu command 

Number of open 
libraries 

just one  any 

Copy PROFInet 
component 

any any 

Delete PROFInet 
component 

only possible if there is no instance of 
the PROFInet component in the project 

any 

Archive / Retrieve automatically with the project using the Library > Archive... or 
Library > Retrieve... menu command 

4.3.2 Creating a new library 

Data storage system for SIMATIC iMap libraries 
You can open, create or close any number of libraries in the SIMATIC iMap library 
window, regardless of which project you are editing. 

New libraries are created as folders in SIMATIC iMap. When you create a new 
library, a library file with the extension .cbl is generated. You can specify any 
name. The file is stored in a folder of the same name. You can enter any path.  

You can also archive an existing library. In this case, the entire content of the 
library is stored in an archive file with the extension .arl. You can enter any path 
and name for the archive file.  

To create a new library: 
1. In SIMATIC iMap, select the Library > New... menu command.  

A dialog box for browsing the file system opens. 

2. Select the folder in which the library is to be created from the "Search in" box. 

3. Enter the name of the library in the �File name� box. The name is automatically 
assigned the extension .cbl. 

4. Click on the "Save" button. 

Result: The library is created and opened. 
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4.3.3 Opening and closing libraries 

Requirement 
The library must have been created in SIMATIC iMap. 

To open an existing library: 
1. In SIMATIC iMap, select the Library > Open... menu command.  

A dialog box for browsing the file system for existing libraries opens. 

2. Select the library folder from the "Search in" box. The box beneath display only 
directories and files of the desired file type - SIMATIC iMap library. 

3. Select the file name with the extension .cbl.  

The file name is displayed in the "File name" box. 

4. Click on the "Open" button. 

Result: The library is opened in the SIMATIC iMap library window. 

Hint: The "File name" drop-down list contains the most recently opened 
SIMATIC iMap libraries. 

To close a library  
1. Click on the library that you wish to close. 

2. You can then either: 

� Click on the cross (X) in the top right-hand corner of the library or 

� Select the Library > Close menu command or  

� Select the Close library  command from the context menu. 

Libraries from earlier versions 
When you open a library that was created with an earlier version of SIMATIC iMap, 
it is automatically converted to the data storage system of the current version.  

 

 Notice 
After conversion, the library can no longer be opened with the earlier version of 
SIMATIC iMap. 

Recommendation: 

If you would like to continue opening the library with the earlier version of 
SIMATIC iMap, then create a copy of the library before you open it in the current 
version. 
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4.3.4 Importing PROFInet components 

PROFInet components in libraries 
A PROFInet component must be located in a library before it can be inserted into a 
SIMATIC iMap project. Instances of the PROFInet component can then be inserted 
from this library into the project. 

When you create a PROFInet component, you can define whether it should be 
stored in the file system or imported into an existing global library. If a PROFInet 
component was created in the file system, then it can subsequently be imported 
into a library in SIMATIC iMap. 

Unique identification of PROFInet components 
PROFInet components are uniquely identified by the identification (ID) and the 
version number. Both the ID and the version number are displayed in the 
"Properties" dialog for the PROFInet component. 

 

 Note 
PROFInet components cannot be overwritten by importing into a library. If the 
library already contains a PROFInet component with the same version number and 
identification (ID), then the selected component will not be imported.  

Requirement 
The PROFInet component must have been created using the vendor-specific 
configuration and programming tool, e.g. STEP 7, and must have been stored in 
the file system. 

To import a PROFInet component into a library:  
1. Click on the library into which you wish to import the PROFInet component. 

2. Select the Library> Import components menu command.  

A dialog box for browsing the file system for existing PROFInet components 
opens, and the system searches for the associated .XML files. 

3. Select an XML file.  

Hint: Click on the down arrow in the "File name" box to display a list of the most 
recently opened XML files. 

4. Click on "Open" to import the selected PROFInet component. 

Result: The selected PROFInet component is imported and the component's icon 
appears in the library. 
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4.3.5 Administering PROFInet components in libraries 

Editing PROFInet components in the library  
You can edit PROFInet components contained in one or more libraries in the 
following ways: 

• Move from one library to another 

• Cut 

• Copy 

• Paste cut or copied PROFInet components 

To move a PROFInet component: 
You can move a PROFInet component from one library to another: 

• Using Drag&Drop 

• By cutting and pasting 

To delete a PROFInet component:  
You can delete a PROFInet component from a library: 

• Using the "Delete" key 

• Using the Edit > Delete menu command. 

PROFInet components can only be deleted from the project library if they are not 
being used in the project. 

Copying, cutting and pasting PROFInet components  
You can use the following menu commands: 

• Edit > Copy � Copies the selected PROFInet component to the clipboard. 

• Edit > Cut � Cuts the selected PROFInet component and places it on the 
clipboard.  

• Edit > Paste � Inserts the clipboard contents. 

The commands are also available in the context menu, depending on which 
window is active. 
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4.3.6 Archiving and retrieving libraries 

The following description relates solely to global libraries. The project library is 
always automatically archived and retrieved together with the project. 

Data storage system for global SIMATIC iMap libraries 
A global SIMATIC iMap library is created in the form of a directory tree, and can be 
stored as an archive file. 

When you archive a global library, all the data for the PROFInet components 
contained in that library is stored in an archive file. You can enter any file name, 
and the file is automatically given the extension .arl. 

 

 Note 
Use the Options > Customize menu command to define, on the "Directories" tab, 
a storage location for global libraries that will be suggested by default when you 
create, open or archive global libraries.  

To archive a global library:  
1. Select the Library > Archive... menu command.  

A dialog box for browsing the file system for existing libraries opens. Look for a 
file with the extension .cbl. 

2. Select the library folder from the "Search in" box. The box beneath display only 
directories and files of the desired file type - SIMATIC iMap library. 

3. Select the file name with the extension .cbl.  

The file name is displayed in the "File name" box. 

4. Click on the "Open" button.  

A dialog box for selecting the storage location opens.  

5. In the "Archive iMap library as..." dialog box, select the folder in which the 
archive file is to be stored. 

6. Accept the name suggested in the "File name� box or enter a different name for 
the archive file, and click on "Save�. 

Result: The archive file is created and the result is signalled on screen. 
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To retrieve a library:  
 

 Note 
You can only retrieve libraries that were archived with SIMATIC iMap.  

 

To retrieve a library, proceed as follows:  

1. Select the Library > Retrieve... menu command.  

A dialog box for browsing the file system for existing archive files opens.  

2. Select an archive (.ARL file). There are two options: 

� Search for the required archive file in the "Search in" box or 

� Select a file from the list of most recently archived libraries from the "File 
name" box. (Click on the down arrow in the "File name" box to display a list 
of the most recently archived libraries.) 

3. Click on "Open" to select the archive file.  

A dialog box for selecting the target folder opens.  

4. Select the folder to which you wish to save the retrieved library and click on 
"OK".  

Result: The library folder is created in the specified target folder and the result is 
signalled on screen. 
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4.4 Working with instances of PROFInet components 

4.4.1 Inserting PROFInet components into a SIMATIC iMap project 

Options for inserting into the SIMATIC iMap project 
You can insert a PROFInet component into your SIMATIC iMap project from a 
library. You can insert a PROFInet component: 

• into the plant view,  

• into the net view, 

• into the project view, 

• into the project tree (plant tree and net tree). 

In all cases, both parts of the PROFInet component are inserted - the technological 
function and the associated device. PROFInet components with no technological 
function can also be inserted into the specified windows, although they cannot be 
viewed in all of those windows.  

Instances of a PROFInet component 
When you insert a PROFInet component from a library into the SIMATIC iMap 
project, it creates an instance of the PROFInet component in the project, i.e. one 
usage of this component type. One or more instances of a PROFInet component 
may be inserted into a project. Each instance is assigned additional properties, for 
example, a name and address.  

The association between all the instances and the original PROFInet component is 
indicated by their identical identification (ID) and version number.  

Requirement 
The PROFInet components that you want to insert into your project must be 
contained in a library in SIMATIC iMap. 

To insert a PROFInet component into the project: 
1. Select the PROFInet component from the library. 

2. Insert it into the window You have several options, e.g.:  

� Drag-and-drop  

� Copy and Paste menu commands (into the net view, plant view, project 
view or project tree).  

When you call the menu command, you must position the instance in exactly 
the right place, as with drag-and-drop. 
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Result: The technological function of the component - if it contains one - appears in 
the plant view and in the plant tree of the project tree. The associated device 
appears in the net view and in the net tree of the project tree.  

 
Figure 4-3 Inserting a PROFInet component into a SIMATIC iMap project  
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The association between PROFInet components and their instances is represented 
in the project view (see diagram below). 

Figure 4-4 PROFInet components and their instances in the project view 
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4.4.2 Coupling devices in the net view 

Arrangement of the devices in the net view 
The devices in the net view are always arranged according to the following rules: 

• All PROFInet devices with Ethernet connections are automatically connected to 
the Ethernet bus. 

• PROFIBUS devices are automatically coupled or are coupled using drag-and-
drop to the PROFIBUS of the DP master. 

Changing the networking 
You can make the following changes to the networking:  

• Coupling a free-standing PROFIBUS device to a PROFInet device with proxy 
functionality. 

• Moving and copying the PROFIBUS devices to the same or another 
PROFIBUS. In this case, remember that the PROFIBUS addresses on a 
PROFIBUS must not be assigned more than once. 

• Moving and copying the PROFInet devices as required on the vertical or 
horizontal Ethernet bus. PROFInet devices with proxy functionality can only be 
coupled to the vertical Ethernet bus. PROFInet devices without proxy 
functionality may be coupled and moved both on the vertical Ethernet and on 
the horizontal Ethernet nodes. 

Accurate positioning of devices  
You can position devices accurately by pasting them from the library into the net 
view or into the net tree: 

• directly with drag-and-drop, 

• using the Copy and Paste menu commands. 

When you call the menu command, you must position the device in exactly the 
right place, as with drag-and-drop. The possible insertion positions are indicated in 
color. 

Positioning devices automatically  
If you do not position the devices accurately in the net view or net tree using drag-
and-drop, but rather insert them into the plant view or project view, for example, 
then they are positioned automatically. 

• PROFInet devices are automatically coupled to the Ethernet bus. 

• PROFIBUS devices are positioned according to how the "Couple PROFIBUS 
devices automatically" option is set. 
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"Couple PROFIBUS devices automatically" option 
You can use the Options > Customize... menu command the "Net view" tab to 
activate the "Couple PROFIBUS devices automatically" option. This setting takes 
effect if you do not position instances accurately in the net view or net tree using 
drag-and-drop, but rather insert them into the plant view or project view, for 
example. 

• Option activated:  
Newly inserted PROFIBUS devices (DP slaves) are automatically coupled to 
the PROFIBUS of the most recently inserted PROFInet device with proxy 
functionality. 

Figure 4-5 Coupled PROFIBUS devices 

• Option deactivated:  
Newly inserted PROFIBUS devices (DP slaves) remain uncoupled and must be 
subsequently positioned. 
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Figure 4-6 Uncoupled PROFIBUS devices 
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4.4.3 Interconnecting technological functions 

4.4.3.1 Interconnecting technological functions 

Rules for interconnection 
• An interconnection may only be set up between an output and an input. An 

output may be interconnected with several inputs, but an input can only be 
interconnected with one output.  

• The two connectors of an interconnection must be of the same data type, e.g. 
both of type I2 or type R4.  
Connectors with composite data types must be of the same type, i.e. arrays and 
structures must have the same structure.  

Requirement 
The technological functions to be interconnected must have been inserted into the 
project. 

To interconnect technological functions: 
1. Open the plant view. 
2. Click on a connector. The connector changes color, and the shape of the cursor 

also changes. 
3. There are two options: 

� Hold down the mouse button and drag to the second connector or  
� Click on the second connector of the interconnection.  

With this procedure, those connectors that are suitable for the data type of the 
technological functions are always highlighted in color.  

Figure 4-7 Interconnecting technological functions 

The interconnection appears between the two connectors as a line or in the form of 
continuation connectors (see below "Displaying the interconnection lines"). 
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Hint: Multiple interconnections 
Used to connect several inputs to one output:  

• Hold down the CTRL key and select the required inputs. 

• Release the CTRL key and select the output to be interconnected. 

Result: All the selected inputs are interconnected to this output. 

Interconnections 
An interconnection is represented by a line that connects the input of a 
technological function to the output of a second technological function. 

When you delete a technological function, all the associated interconnections are 
deleted.  

When you move a technological function, the course of the associated 
interconnections is also changed. 

If the course of a line cannot be calculated due to lack of space, for example, then 
only the two ends of the interconnection are displayed. These are known as 
continuation connectors. 

The color of the line changes when you select an interconnection. You can delete a 
selected interconnection or look up and modify its properties. 
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Displaying the interconnection lines 

Use the View > Plant view > Display Interconnection Lines menu command to 
show or hide the interconnection lines.  

You can switch off the interconnection lines temporarily by removing the tick from 
the menu command in order to work more efficiently in the plant view. In this case, 
only the end points of the interconnections are displayed in the form of 
interconnection endpoints. Interconnection endpoints with the same number 
represent an interconnection. In this display mode, your computer does not have to 
constantly recalculate the lines, which allows you to move and interconnect 
technological functions faster. 

Figure 4-8 Display Interconnection Lines 
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Figure 4-9 Displaying the interconnection endpoints 

Hint: Recalculate Interconnection Lines 
The View > Plant view > Recalculate Interconnection Lines menu command or 
function key F5 is used to refresh the representation of the interconnection lines.  
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4.4.3.2 Interconnecting with constant values 

Constant values at component inputs 
Some technological functions require a constant value to be applied at an input, in 
order to test the function, for example. This value can be set using SIMATIC iMap. 

Rules 
In SIMATIC iMap, only inputs can be interconnected with constant values. This is 
not possible with outputs. 

Requirement 
The input to be interconnected must not already be interconnected. If this is the 
case, the existing interconnection must first be deleted. 

To interconnect an input with a constant value: 
1. Select the input so that the mouse pointer with the interconnection icon 

appears. 

2. Select Interconnect Constants from the context menu.  

3. Enter the desired value in the "Interconnection with Constant Value" dialog box 
and click on the "OK" or "Accept" button. 

The input is identified by a constant icon, and the value of the constant is displayed 
at the input. 

Example 
The selected input is interconnected with the value 30. 

 
Figure 4-10 Interconnection with a constant value 
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To modify the interconnection with a constant value: 

1. Select the constant icon for the input. 

2. Open the interconnection properties.  

3. Enter the required value in the Constant Value" box in the "Interconnection with 
Constant Value" dialog box. 

4. Click on the "OK" or "Apply" button. 

The changed value is displayed at the input. 

Constant values for composite data types 
With composite data types such as arrays or structures you can enter constant 
values for each individual element.  

With arrays, you can also enter the same constant value for all the elements in the 
array. To do this, enter the required value in the "Constant value" box and click on 
the "for all array elements" button. 

Example: Constant values for a connector of the type STRUCT 
The following diagram shows how to enter a constant value for a structure element 
of the type UI1 (byte): 

 
Figure 4-11 Interconnecting with constant values for a connector of the data type STRUCT 



Configuring plants 

 Component based Automation, Configuring Plants with SIMATIC iMap 
4-32 A5E00248797-01 

To delete an interconnection with a constant value: 
1. Select the constant icon for the input. 
2. Select the Delete Interconnection command from the context menu.  
The constant icon disappears, and the input can be interconnected once more. 

4.4.3.3 Configuring substitute values  

Substitute values 
If a fault occurs on a device such that the values that are sent via its 
interconnections are no longer valid, then the recipient switches to substitute 
values.  

Figure 4-12 Example - Substitute values 

In SIMATIC iMap, there is a default substitute value for every interconnection. This 
may be the last known value or a user-defined value.  
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Note 
Substitute values can only be configured for interconnections between PROFInet 
devices.  
If a PROFIBUS device is involved, then only substitute value 0 may be used.  
Exception:�1.1.2000� is always used as the substitute value for connectors of the 
type DATE. 

To change the default substitute value of an interconnection:  
1. Select the interconnection from the plant view. 

2. Select Properties from the context menu. 

3. In the "Properties" dialog box, activate the required option in the "Substitute 
value" box. If you wish to activate a specified value as the substitute value, then 
enter the required value. 

4. Click on the "OK" or "Accept" button to confirm the changes. 

5. Select the function with the affected input (on the recipient side) and select 
Download Selected Device > Interconnections only from the context 
menu to download the newly configured interconnection to the associated 
device. 

 
Figure 4-13 Example - Changing substitute values 
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Result: The change takes effect immediately. If there is already a fault on the 
device, you can monitor the modified substitute value online. 

Substitute values for composite data types 
With composite data types such as arrays or structures you can enter a user-
defined substitute value for each individual element.  

With arrays, you can also enter the same user-defined substitute value for all the 
elements in the array. To do this, enter the required value in the "User-defined 
value" box and click on the "for all array elements" button. 

4.4.3.4 Transfer properties of the interconnections 

In SIMATIC iMap, the following PROFInet communication properties can be 
defined as properties of the interconnections: 

• Transfer mode 

• Transfer frequency and scanning frequency 

Interconnections to local and remote communication partners 
• Interconnections to local communication partners are:  

� Interconnections between two PROFIBUS devices on the same PROFIBUS 

� Interconnections between a PROFIBUS device and the associated 
PROFInet device with proxy functionality 

� Interconnections inside the device  

• Interconnections to remote communication partners are interconnections that 
run via Industrial Ethernet.  

Transfer mode 
PROFInet communication via Industrial Ethernet supports the following transfer 
modes: 

• Cyclical transfer, e.g. for time-critical process data.  

The data is transferred cyclically, regardless of whether the values have 
changed. 

• Acyclical transfer, e.g. for engineering data and non time-critical data.  

The data is polled cyclically, i.e. checked for changes. The data is only 
transferred if it has changed, however. 

The data is polled on the sender side of the interconnection (output from a 
technological function). 

The supported transfer modes are device properties. They can be taken from the 
properties of the PROFInet component concerned. 
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Quality of service (QoS) 
A quality of service is defined for both transfer modes: 

• Transfer frequency (cyclical):  

For cyclical transfer, the transfer frequency is the time after which a data item is 
transferred again, e.g. every 100 ms.  

• Scanning frequency (acyclical):  

For acyclical transfer, the scanning frequency is the frequency with which the 
data is polled, e.g. every 200 ms. The scanning frequency is thus the maximum 
time that elapses before a change in value is transferred. 

Scanning frequency and transfer frequency values 
Three frequency levels are defined for both transfer modes  

• Fast � high frequency 

• Medium � medium frequency 

• Slow � low frequency 

A transfer value of between 1 ms and 1000 ms may be set centrally for each 
frequency level. 

Settings within the project 
You can set the following in the properties of the SIMATIC iMap project (Project > 
Properties, "Interconnections" tab) menu command: 

• Default transfer properties for new interconnections � these will apply to all 
subsequent new interconnections  

• Time values for the frequency levels � apply to all instances of the 
SIMATIC iMap project.  
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Example 
The following diagram shows the transfer properties set within the project: 

 
Figure 4-14 Transfer properties within the project 

The following have been set: 

• Default setting for new interconnections:  

Transfer mode: acyclical  
Scanning frequency: medium, i.e. every 200 ms. 

All subsequently created interconnections will have these properties. 

• Transfer values for the individual frequency levels and transfer modes 

� Transfer frequencies (cyclical): 
fast� every 10 ms 
medium� every 50 ms 
slow� every 100 ms 

� Scanning frequency (acyclical): 
fast� every 50 ms 
medium� every 200 ms 
slow� every 1000 ms 

A transfer frequency of 100 ms is thus set for all interconnections with cyclical 
transfer and the frequency level "slow", for example. This means that every 100 ms 
the data is transferred via these interconnections cyclically. 
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4.4.3.5 Setting the transfer properties of interconnections 

Central settings and individual adaptations 
Every interconnection is assigned a transfer mode and a transfer value in 
SIMATIC iMap. The following is defined centrally in the project settings: 

• The default setting for new interconnections.  

• The precise transfer values for the frequency levels "fast", "medium" and "slow" 
in milliseconds for all interconnections.  

You can change the transfer mode and the frequency level "fast", "medium" or 
"slow" in the properties of the individual interconnections. 

 

 Note 
The transfer properties (transfer mode, transfer frequency and scanning frequency) 
are only of relevance for interconnections to remote communication partners via 
Industrial Ethernet. 

During a download, interconnections are checked, however, regardless of whether 
they are remote interconnections or not. The transfer properties must therefore still 
be specified at the configuration stage for internal device interconnections and 
interconnections within a proxy system.  

 

 Note 
Interconnections with cyclical transfer only work between communication partners 
that are on the same subnet.  

To define the transfer properties for the interconnections of the entire project: 
1. Select the Project > Properties menu command. 

2. Open the "Interconnections" tab. 

3. In the "Default setting for the new interconnections� box, select:  

� the transfer mode "acyclical" or "cyclical" and  

� the frequency level "fast", "medium" or "slow".  

These settings will apply to all subsequently created interconnections. 

4. In the "Transfer frequency (cyclical)" box, select the transfer values for the three 
frequency levels. There are two options: 

� Select the required value from the drop-down list or 

� drag the pointer onto the required value. 

5. In the "Scanning frequency (acyclical)" box, select the transfer values for the 
three frequency levels (as in step 4). 

6. Click on the "OK" or "Accept" button to confirm your input. 
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The settings in step 4 and 5 apply to all the interconnections in the project with the 
corresponding transfer mode and frequency level. These values are retained in 
SIMATIC iMap until they are changed again.  

You can change the transfer properties of individual interconnections via the 
interconnection properties. 

Hint: The transfer properties of a highlighted interconnection are also displayed as 
a Tooltip. 

To change the transfer properties of an interconnection 
1. Select the interconnection in the plant view and select the Edit > Properties 

menu command.  

2. In the "Properties� dialog box select: 

� the transfer mode "acyclical" or "cyclical" and/or 

� the frequency level "fast", "medium" or "slow". The precise transfer value in 
milliseconds for this transfer mode and frequency level can be taken from 
the project settings. 

3. Click on "OK" or "Accept� to confirm. 

Example: Transfer properties for the entire project 

 
Figure 4-15 Transfer properties for the entire project 
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Example: Transfer properties of an interconnection 

 
Figure 4-16 Transfer properties of an interconnection 



Configuring plants 

 Component based Automation, Configuring Plants with SIMATIC iMap 
4-40 A5E00248797-01 

4.5 Properties 

4.5.1 Looking up and modifying properties 

Properties � Overview 
In SIMATIC iMap you can view and, if necessary, modify the properties of the 
following objects: 

• Project  

• Instance 

• Chart  

• Interconnection  

• Connector 

• Library  

• PROFInet component  

A description of the properties can be found in the context-sensitive help for the 
"Properties" dialog boxes. 

To modify the properties of objects: 
Proceed as follows: 

1. Open the desired window. 

2. Select the object and then select one of the following menu commands: 

� Edit > Properties from the menu bar or 

� Properties from the context menu.  

The "Properties" dialog box opens. 

3. Modify the desired properties and click on "Accept" to confirm your changes. 

4. Close the dialog box:  

� Click on OK if you want your changes to take effect 

� Click on "Cancel" if you want to cancel all your changes.  
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4.5.2 Addresses of PROFInet devices 

PROFInet devices may have the following addresses, depending on the bus ports 
used: 

Bus port Address 

Ethernet IP address 

PROFIBUS PROFIBUS address 

IP address and subnet mask 
The IP address and the subnet mask each consist of 4 decimal numbers with a 
range of values from 0 to 255. The decimal numbers are each separated by a dot.  

Example: IP address  192.168.0.20 

  Subnet mask 255.255.255.0 

The IP address is made up of  

• The address of the (sub-)net  

• The address of the node (generally called the host or network node)  

The subnet mask separates these two addresses. It determines which part of the 
IP address the network addresses and which part of the IP address is addressed 
by the node.  

In binary format, the 4 decimal numbers of the subnet mask must contain a 
continuous sequence of 1s from the left and a continuous sequence of 0s from the 
right. The bits set for the subnet mask determine the network part of the IP 
address.  

As a rule:  

• The network address is obtained by an AND combination of IP address and 
subnet mask.  

• The node address is obtained by an AND-NOT combination of IP address and 
subnet mask.  

Association between the IP address and default subnet mask  

There is a convention concerning the assignment of IP address areas and the 
"default subnet masks". The first decimal number (from the left) of the IP address 
determines the structure of the default subnet mask with regard to the number of 
"1" values (binary) as follows:  

 
IP address  IP address (bin.)  Addres

s class  
Default subnet 

mask  

1.0.0.0 to 126.255.255.255 0xxxxxxx.xxxxxxxx....  A  255.0.0.0  

128.0.0.0 to 191.255. 255.255 10xxxxxx.xxxxxxxx...  B  255.255.0.0  

192.0.0.0 to 223.255.255.255 110xxxxx.xxxxxxxx...  C  255.255.255.0  

 

 Note 
Only class A, B or C IP addresses are permitted. 
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Example: IP address and subnet mask  
 

Addresses Example 

IP address 141.30.0.5 

Subnet mask 255.255.0.0 

Subnet 141.30 

Host 0.5 

 

Decimal and binary representation of the subnet mask in the above example:  

255.255.0.0 = 11111111.11111111.00000000.00000000 

Meaning: The first 2 bytes of the IP address determine the subnet, i.e. 141.30. The 
last two bytes address the node, i.e. 5.  

Router 
You will need a network transition (router) if you want the device to be able to 
communicate with other devices outside its own subnet. In this case, you will have 
to enter the router address for every node on the subnet. The structure of your 
plant will determine whether you use a network transition or not. The address is 
specified by the network administrator or plant operator.  

The IP address of a node on the subnet and the address of the network transition 
(router) must only differ at the points at which the subnet mask is set to "0". 

PROFIBUS address 
The PROFIBUS address is entered as a decimal number from 1 to 125. The 
current range of values depends on the module concerned. 
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4.5.3 Assigning addresses 

Addresses of PROFInet and PROFIBUS devices 
The IP and/or PROFIBUS addresses are assigned to the devices via the 
�Properties� dialogs. IP addresses and subnet masks must be assigned in order to 
be able to establish online connections with the devices of the plant.  

 

 Note 
The IP address and subnet mask that you assign to a PROFInet device in 
SIMATIC iMap must be exactly the same as the IP address and subnet mask of 
the device within the plant, otherwise the device cannot be accessed online from 
SIMATIC iMap. 

If you use a network transition: The IP address of the device and the IP address 
of the network transition must belong to the same subnet. 

Requirement 
The IP addresses and associated subnet masks have to be assigned to the 
devices of the plant using vendor-specific configuration tools. They are generally 
defined by the network administrator.  

To assign addresses: 
1. Select the required device from the net view or the associated function from the 

plant view. 
2. Open the object properties 

� using the Properties context menu or 
� using the Edit > Properties menu command. 

3. Enter the addresses required for the device type on the Addresses" tab. 
� IP address and subnet mask: 

Enter the IP address and subnet mask to be assigned to the device at the 
node (e.g. via the vendor-specific configuration and programming tool). 

� PROFIBUS address:  
Enter the PROFIBUS address to be assigned to the device, e.g. using the 
DIL switches. The default is the PROFIBUS address defined when the 
PROFInet component was created. If this is already in use, then the lowest 
free address on the PROFIBUS becomes the default. 

4. If you use a router (network transition), you must activate the "Network 
transition, Use router" option and enter the IP address of the router in the 
"Address" box. 

5. Confirm your input by clicking on the 
� �OK� button to accept the input and close the dialog box 
� �Accept� button to accept the input and leave the dialog box open. 

Result: The assigned addresses are displayed on the device in the net view. 
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4.5.4 Password protection for SIMATIC iMap projects 

Effect of the password 
You can assign a password to your SIMATIC iMap project to protect it against 
unauthorized access. The password is defined in the project properties and must 
be entered when you open the project.  

If you attempt to open a project and do not enter the correct password, the project 
will not be opened.  

Defining a password 
To define a password for the project:  

1. Open the project properties using the Project > Properties  menu command 
and follow the procedure detailed below: 

� To enter a new password for the first time, enter the password in the "New 
password" box and then repeat it in the "Confirm password" box. 

� To change an existing password, enter the old password in the "Old 
password" box. Then enter the new password in the "New password" box 
and then repeat it in the "Confirm password" box. 

2. Click on "OK" or "Accept" to confirm your input. 

Cancelling password protection 
To cancel the password protection for a project: 

1. Open the project properties using the Project > Properties menu command. 

2. Enter the old password in the "Old password� box and leave the "New 
password� and "Confirm password" boxes blank. 

3. Click on "OK" or "Accept" to confirm your input. 
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4.5.5 Generation status 

Status of the shadow project 
The shadow project is generated in SIMATIC iMap from the component projects of 
the PROFInet components present within the project.  

The generation status of the instance of a PROFInet component is displayed on 
the "Instance" tab in the Properties. Highlight the technological function or device 
and select the Properties... context menu to open this dialog.  

 
Generation status Meaning Action 

Not generated The shadow project has not 
yet been generated or does 
not yet contain the 
PROFInet component 

Generating the Project 

Changes only 

All 

Generated The shadow project has 
been generated, it contains 
the PROFInet component 
and the properties of the 
PROFInet component are 
consistent with the STEP7 
shadow project 

No action required 

Inconsistent/modified The properties of the 
PROFInet component have 
been modified and are no 
longer consistent with the 
shadow project 

Generating the Project 

Generation not possible The properties of the 
PROFInet component 
contain illegal values (e.g. 
an address is assigned 
twice) which make 
generation impossible. 

Eliminate the error(s) and 
then generate the project 
again 

Graphical representation of the generation status 
The generation status of an instance is represented graphically in the project view 
(see "Windows and views, project view"). 
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4.5.6 Checking the utilization 

Application 
From runtime version V2.0.0.0 onwards, PROFInet devices have performance 
parameters that describe the PROFInet communication properties of the devices 
(see also the section entitled "Performance parameters of PROFInet devices").  

The performance parameters can be used to check the device utilization even 
during the configuration phase in SIMATIC iMap. This allows you to see at an early 
stage whether the devices can meet the needs of the SIMATIC iMap project 
without causing faults in the plant due to overloading at runtime.  

If the performance parameters are exceeded or undershot during the configuration 
phase, they can thus be traced and rectified before the project is generated. 

What is checked?  
The following is checked: 

• Whether the configuration has exceeded any of the device's performance 
parameters, e.g. the maximum number of interconnections or the maximum 
transfer values for the interconnections.  

• Whether the device supports the configured transfer properties of the 
interconnection (e.g. cyclical transfer). 

• For PROFIBUS devices only: Whether the PROFIBUS device and the 
associated PROFInet device with proxy functionality are compatible with 
respect to the PROFInet runtime version. 

The performance parameters can be found on the �Device� tab in the PROFInet 
component properties. Highlight the PROFInet component in the library window 
and select Properties from the context menu.  

Rules 
Only PROFInet devices can be checked. 

With a PROFInet device with proxy functionality, the utilization check relates to the 
entire proxy system, consisting of the actual device and any PROFIBUS devices 
coupled to it. 
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To check the utilization of PROFInet devices: 
1. In the net view, highlight the PROFInet devices to be checked. 

2. Select the following command from the context menu:  

� Verify utilization > Default, to call up a summary of the results. Only those 
performance parameters that have been exceeded or undershot are listed. 

� Verify utilization > Detailed, to call up a detailed description of the results. 
This lists all the performance parameters with their current values and limit 
values (Act./Max. or Act./Min.).  

Result: The check is carried out and the results are displayed on the 
"Utilization" tab of the information window. 

3. In the event of overloading: Correct the configuration of the devices or 
interconnections, if necessary, or change the networking of the devices. 

Hint: Finding objects 
If the utilization check discovers that limit values are exceeded or undershot, the 
affected object appears in the "Reference object" column in the information 
window, highlighted with a warning symbol. Double-click on the reference object to 
select the relevant object. You can then check its properties and correct them if 
necessary. 

Hint: Check the online utilization 
Use the Online > Online device analysis menu command to call up the online 
data for a certain PROFInet device, including a comparison of the downloaded 
configuration data against the performance parameters (see "Online device 
analysis"). 
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4.5.7 Performance parameters of the PROFInet devices 

For PROFInet devices from PROFInet runtime version 2.0 onwards, certain 
performance parameters are defined that are important for PROFInet 
communication. 
The performance parameters can be found on the �Device� tab in the PROFInet 
component properties. Highlight the PROFInet component in the library window 
and select Properties from the context menu.  

PROFInet performance parameters 
 

Parameter Description 
General parameters 
PROFInet runtime version see below 
Communication on the PROFIBUS (proxy system)*) 
Maximum number of slaves 
that can be operated 

Maximum number of PROFIBUS devices that can be 
coupled to the PROFInet device with proxy functionality.  
This includes DP slaves on the local PROFIBUS. 

Maximum number of 
connectors (including slaves) 

Maximum number of connectors for the technological 
function(s). For PROFInet devices with proxy functionality, 
this incorporates the functions of the coupled PROFIBUS 
devices. 

Maximum data length for 
arrays and structures 

Maximum data length for arrays and structures in bytes*) 
(see "Connector data types"). 

Maximum number of internal 
device and PROFIBUS 
interconnections 

Maximum number of interconnections: 
• between PROFIBUS devices on the same PROFIBUS 
• between the PROFIBUS device and the associated 

PROFInet device with proxy functionality 
• on the same device (internal)  

Communication on the Industrial Ethernet*) (to remote communication partners) 
Maximum number of remote 
interconnection partners 

Maximum number of communication partners via Industrial 
Ethernet. 

Remote interconnections with acyclical transfer 
• Minimum interval for 

scanning frequency 
Minimum time interval for the scanning frequency with 
frequency level "fast" in milliseconds 

• Maximum number of 
incoming interconnections 

Maximum number of interconnected inputs. 

• Maximum number of 
outgoing interconnections 

Maximum number of interconnected outputs.**) 

Remote interconnections with cyclical transfer 
• Minimum interval for 

transfer frequency 
Minimum time interval for the transfer frequency with 
frequency level "fast" in milliseconds 

• Maximum number of 
incoming interconnections 

Maximum number of interconnected inputs. 

• Maximum number of 
outgoing interconnections 

Maximum number of interconnected outputs.**)  

*) For PROFInet devices with proxy functionality: including the coupled PROFIBUS devices 
(see following rule).  
**) Outputs interconnected multiple times with remote partners are counted multiple times 
accordingly. 
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PROFInet runtime version 
The PROFInet runtime version identifies the release of the PROFInet functionality 
in the firmware on the PROFInet device.  

The PROFInet runtime version of a PROFInet device with proxy functionality is 
particularly important for the coupled PROFIBUS devices. The coupled PROFIBUS 
devices will not be able to use certain functions unless they are supported by the 
proxy device, such as connectors of data type STRUCT.  

Rule 
With a PROFInet device with proxy functionality, the performance parameters 
relate to the entire proxy system, consisting of the actual device and any 
PROFIBUS devices coupled to it. 

4.5.8 Utilization parameters for PROFInet devices 

For the detailed utilization check � using the Verify utilization > Detailed menu 
command � all the parameters are listed in the information window with their 
current values and limits. For the standard utilization check � using the Verify 
utilization > Standard menu command � only those parameters for which the 
limits are exceeded or undershot are listed in the information window. 

Exceeded and undershot utilization parameters are identified by a warning symbol 
in the information window. The quantitative deviations can be seen from the 
Actual/Max and Actual/Min values. 

Validity of the utilization parameters 
The parameters listed below apply to: 

• a PROFInet device without proxy functionality or  

• the entire proxy system of a PROFInet device with proxy functionality.  

Descriptions of the utilization parameters 
The utilization parameters can be subdivided into the following parameter groups: 

• Device parameters 

• General non interconnection-specific parameters 

• Parameters for acyclical remote interconnections of master and slaves 

• Parameters for cyclical remote interconnections of master and slaves 

The "Remedy" column contains possible remedies in the event that utilization 
parameter limits are exceeded or undershot. 

<Actual> represents a current actual value, while <Min> and <Max> are limit 
values. 
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Device parameters 
These parameters apply to the entire proxy system of the PROFInet device with 
proxy functionality. 

 
Parameter Meaning  Remedy 

Number of coupled 
PROFIBUS devices 

Number of PROFIBUS devices that are coupled to 
the PROFInet device with proxy functionality.  

This includes DP slaves on the local PROFIBUS. 

Sum of all master and 
slave connectors  

Total number of connectors for the technological 
function(s). For PROFInet devices with proxy 
functionality, this incorporates the functions of the 
coupled PROFIBUS devices. 

Reduce the number of 
coupled PROFIBUS 
devices. 

Maximum data length for 
arrays and structures for 
master and slaves 
[bytes] 

Total data length for arrays and structures in bytes 
(see "Connector data types"). For PROFInet 
devices with proxy functionality, this incorporates 
the functions of the coupled PROFIBUS devices. 

Possible cause:  
The data length of at least one connector of a 
coupled PROFIBUS device is too long for this 
master 

Couple the PROFIBUS 
device to another 
PROFInet device with 
proxy functionality. 

Sum of the data lengths 
of all master and slave 
inputs [byte] 

Total data length of all inputs of the technological 
function(s) in bytes (see "Connector data types"). 
For PROFInet devices with proxy functionality, this 
incorporates the functions of the coupled 
PROFIBUS devices. 

Sum of the data lengths 
of all master and slave 
outputs 

Total data length of all outputs of the technological 
function(s) in bytes (see "Connector data types"). 
For PROFInet devices with proxy functionality, this 
incorporates the functions of the coupled 
PROFIBUS devices. 

Memory required for 
type descriptions of all 
master and slave 
connectors 

This parameter comprises the memory required for 
the description of the data types of all connectors. 
This memory is required in addition to the working 
data (sum of the data lengths of all inputs and 
outputs). 

Reduce the number of 
coupled PROFIBUS 
devices. 
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General non interconnection-specific parameters 
These parameters are independent of the transfer mode. 

Parameter Meaning  Remedy 

Number of internal 
device and PROFIBUS 
interconnections for 
master and slaves  

Number of interconnections: 

• between PROFIBUS devices on the 
same PROFIBUS 

• between PROFIBUS devices and the 
associated PROFInet device with proxy 
functionality 

• on the same device (internal) 

Sum of the data lengths 
of all internal device and 
PROFIBUS 
interconnections of 
master and slaves 

Total data length in bytes for all connectors 
with the following interconnections: 

• between PROFIBUS devices on the 
same PROFIBUS 

• between PROFIBUS devices and the 
associated PROFInet device with proxy 
functionality 

• on the same device (internal) 

If necessary, reduce the 
number of internal device 
interconnections and 
PROFIBUS interconnections. 

Number of 
interconnections with 
constants of master and 
slaves 

Number of interconnections with constants. 
For PROFInet devices with proxy 
functionality, this incorporates the functions 
of the coupled PROFIBUS devices. 

Sum of the data lengths 
of all interconnections 
with constants of master 
and slaves  

Total data lengths of all interconnections 
with constants. For PROFInet devices with 
proxy functionality, this incorporates the 
functions of the coupled PROFIBUS 
devices. 

Reduce the number of 
interconnections with constants.

Number of remote 
interconnection partners 
of master and slaves 

Number of remote communication partners 
(via Industrial Ethernet). 

Reduce the number of remote 
communication partners of the 
device 

Utilization due to the 
number of device 
relationships between 
master and slaves and 
with remote 
interconnection partners 

This parameter shows the utilization (as a 
percentage) in relation to the number of 
directed communication relationships 
between the device and its communication 
partners, in both the local and the remote 
proxy system.  

All interconnections in a direction � e.g. 
from outputs of device A to inputs of device 
B � are regarded as directed 
communication relationships between 
devices A and B. All interconnections in the 
other direction � from outputs of device B to 
inputs of device A � are regarded as 
another directed communication relationship 
between devices A and B.  

Reduce the number of directed 
communication relationships of 
the device.  

It is not sufficient simply to 
remove some of the 
interconnections that form a 
directed communication 
relationship. All the 
interconnections in the same 
direction between two devices 
must be removed in order to 
remove a directed 
communication relationship 
between these devices. 
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Parameters for acyclical remote interconnections of master and slaves 
Parameters for interconnections with acyclical transfer to remote communication 
partners. For PROFInet devices with proxy functionality, this incorporates the 
interconnections of the coupled PROFIBUS devices. 

 
Parameter Meaning  Remedy 

Minimum interval for 
scanning frequency  

Minimum time interval for the scanning 
frequency with frequency level "fast" in 
milliseconds 

Increase the minimum interval for 
the scanning frequency for 
frequency level "fast" in the 
project settings. 

Incoming 
interconnections: 

Interconnection at the inputs of technological function(s) 

Number  Number of incoming interconnections. For 
PROFInet devices with proxy functionality, 
this incorporates the interconnections of 
the coupled PROFIBUS devices. 

Sum of the data lengths  Sum of the data lengths of all connectors 
with incoming interconnections in bytes. 
For PROFInet devices with proxy 
functionality, this incorporates the 
interconnections of the coupled 
PROFIBUS devices. 

• Reduce the number of 
incoming interconnections 
with acyclical transfer to 
remote communication 
partners or  

• use interconnections with 
cyclical transfer, if necessary. 

Distribution by 
frequency:  

This parameter is represented as follows: 

• OK � if the distribution of 
interconnections by frequency level is 
OK. 

• With a warning symbol � if the 
distribution of interconnections by 
frequency level is not suitable.  

The following parameters show whether 
the performance parameters are 
exceeded or undershot by the 
configuration of the interconnection for 
each frequency level. 

If a warning symbol appears on 
the line: 

• Determine the frequency level 
at which at least one device 
parameter limit value is 
exceeded or undershot by the 
associated configured value 
and 

• distribute the incoming remote 
interconnections for the 
affected frequency level to 
other frequency levels or  

• use interconnections with 
cyclical transfer, if necessary. 

Device parameter:  
fast (<Min> ms);  
Interconnections: 
<Max>; 
Total data length: <Max> 
byte 

Device performance parameters (limit 
values) for the frequency level "fast": 

• The minimum time interval for the 
scanning frequency with frequency 
level "fast" in milliseconds 

• The maximum number of incoming 
interconnections with frequency level 
"fast" 

• The total data length of all inputs with 
interconnections of frequency level 
"fast" in bytes. 

These lines never contain a 
warning; they are used for 
breakdown purposes only. The 
potential overload is highlighted in 
the "Distribution by frequency..." 
line. 
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Parameter Meaning  Remedy 
Configured:  
fast (<Actual> ms);  
Interconnections: 
<Actual>;  
Data length: <Actual> 
byte 

Current configured values for incoming 
interconnections with frequency level 
"fast":  

• The configured time interval for the 
scanning frequency with frequency 
level "fast" in milliseconds 

• The current number of incoming 
interconnections with frequency level 
"fast" 

• The current total data length of all 
inputs with interconnections of 
frequency level "fast" in bytes. 

Device parameter:  
medium (<Min>ms);  
Interconnections: 
<Max>; 
Data length: <Max> byte 

Device performance parameters (limit 
values) for the frequency level "medium": 

• The minimum time interval for the 
scanning frequency with frequency 
level "medium" in milliseconds 

• The maximum number of incoming 
interconnections with frequency level 
"medium" 

• The total data length of all inputs with 
interconnections of frequency level 
"medium" in bytes. 

Configured:  
medium (<Actual> ms); 
Interconnections: 
<Actual>;  
Data length: <Actual> 
byte 

Current configured values for incoming 
interconnections with frequency level 
"medium":  

• The configured time interval for the 
scanning frequency with frequency 
level "medium" in milliseconds 

• The current number of incoming 
interconnections with frequency level 
"medium" 

• The current total data length of all 
inputs with interconnections of 
frequency level "medium" in bytes. 

Device parameter:  
slow (<Min>ms);  
Interconnections: 
<Max>; 
Data length: <Max> byte 

Device performance parameters (limit 
values) for the frequency level "slow": 

• The minimum time interval for the 
scanning frequency with frequency 
level "slow" in milliseconds 

• The maximum number of incoming 
interconnections with frequency level 
"slow" 

• The total data length of all inputs with 
interconnections of frequency level 
"slow" in bytes. 
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Parameter Meaning  Remedy 
Configured:  
slow (<Actual> ms);  
Interconnections: 
<Actual>;  
Data length: <Actual> 
byte 

Current configured values for incoming 
interconnections with frequency level 
"slow":  

• The configured time interval for the 
scanning frequency with frequency 
level "slow" in milliseconds 

• The current number of incoming 
interconnections with frequency level 
"medium" 

• The current total data length of all 
inputs with interconnections of 
frequency level "slow" in bytes. 

 

Outgoing 
interconnections: 

Interconnection at the outputs of technological function(s) 

Number  Number of outgoing interconnections. For 
PROFInet devices with proxy functionality, 
this incorporates the interconnections of 
the coupled PROFIBUS devices. 

Sum of the data lengths  Sum of the data lengths of all connectors 
with outgoing interconnections. For 
PROFInet devices with proxy functionality, 
this incorporates the interconnections of 
the coupled PROFIBUS devices. 

• Reduce the number of 
outgoing interconnections with 
acyclical transfer to remote 
communication partners or  

• use interconnections with 
cyclical transfer, if necessary. 

Distribution by 
frequency: 

This parameter is represented as follows: 

• OK � if the distribution of 
interconnections by frequency level is 
OK. 

• With a warning symbol � if the 
distribution of interconnections by 
frequency level is not suitable.  

The following parameters show whether 
the performance parameters are 
exceeded or undershot by the 
configuration of the interconnection for 
each frequency level. 

If a warning symbol appears on 
the line: 

• Determine the frequency level 
at which at least one device 
parameter limit value is 
exceeded or undershot by the 
associated configured value 
and 

• distribute the outgoing remote 
interconnections for the 
affected frequency level to 
other frequency levels or  

• use interconnections with 
cyclical transfer, if necessary. 

Device parameter:  
fast (<Min>ms);  
Interconnections: 
<Max>; 
Data length: <Max> byte 

Device performance parameters (limit 
values) for the frequency level "fast": 

• The minimum time interval for the 
scanning frequency with frequency 
level "fast" in milliseconds 

• The maximum number of outgoing 
interconnections with frequency level 
"fast" 

• The total data length of all outputs with 
interconnections of frequency level 
"fast" in bytes. 

These lines never contain a 
warning; they are used for 
breakdown purposes only. The 
potential overload is highlighted in 
the "Distribution by frequency..." 
line. 
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Parameter Meaning  Remedy 
Configured:  
fast (<Actual> ms);  
Interconnections: 
<Actual>;  
Data length: <Actual> 
byte 

Current configured values for outgoing 
interconnections with frequency level 
"fast":  

• The configured time interval for the 
scanning frequency with frequency 
level "fast" in milliseconds 

• The current number of outgoing 
interconnections with frequency level 
"fast" 

• The current total data length of all 
outputs with interconnections of 
frequency level "fast" in bytes. 

Device parameter:  
medium (<Min>ms);  
Interconnections: 
<Max>; 
Data length: <Max> byte 

Device performance parameters (limit 
values) for the frequency level "medium": 

• The minimum time interval for the 
scanning frequency with frequency 
level "medium" in milliseconds 

• The maximum number of outgoing 
interconnections with frequency level 
"medium" 

• The total data length of all outputs with 
interconnections of frequency level 
"medium" in bytes. 

Configured:  
medium (<Actual> ms); 
Interconnections: 
<Actual>;  
Data length: <Actual> 
byte 

Current configured values for outgoing 
interconnections with frequency level 
"medium":  

• The configured time interval for the 
scanning frequency with frequency 
level "medium" in milliseconds 

• The current number of outgoing 
interconnections with frequency level 
"medium" 

• The current total data length of all 
outputs with interconnections of 
frequency level "medium" in bytes. 

Device parameter:  
slow (<Min>ms);  
Interconnections: 
<Max>; 
Data length: <Max> byte 

Device performance parameters (limit 
values) for the frequency level "slow": 

• The minimum time interval for the 
scanning frequency with frequency 
level "slow" in milliseconds 

• The maximum number of outgoing 
interconnections with frequency level 
"slow" 

• The total data length of all outputs with 
interconnections of frequency level 
"slow" in bytes. 
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Parameter Meaning  Remedy 
Configured:  
slow (<Actual> ms);  
Interconnections: 
<Actual>;  
Data length: <Actual> 
byte 

Current configured values for outgoing 
interconnections with frequency level 
"slow":  

• The configured time interval for the 
scanning frequency with frequency 
level "slow" in milliseconds 

• The current number of outgoing 
interconnections with frequency level 
"medium" 

• The current total data length of all 
outputs with interconnections of 
frequency level "slow" in bytes. 
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Parameters for cyclical remote interconnections of master and slaves 
Parameters for interconnections with cyclical transfer to remote communication 
partners. For PROFInet devices with proxy functionality, this incorporates the 
interconnections of the coupled PROFIBUS devices. 

 
Parameter Meaning  Remedy 

Minimum interval for 
transfer frequency  

Minimum time interval for the transfer 
frequency with frequency level "fast" in 
milliseconds 

Increase the minimum interval for 
the transfer frequency for 
frequency level "fast" in the 
project settings. 

Incoming 
interconnections: 

Interconnection at the inputs of technological function(s) 

Number  Number of incoming interconnections. For 
PROFInet devices with proxy functionality, 
this incorporates the interconnections of 
the coupled PROFIBUS devices. 

Sum of the data lengths  Sum of the data lengths of all connectors 
with incoming interconnections. For 
PROFInet devices with proxy functionality, 
this incorporates the interconnections of 
the coupled PROFIBUS devices. 

• Reduce the number of 
incoming interconnections 
with cyclical transfer to remote 
communication partners or  

• use interconnections with 
acyclical transfer, if 
necessary. 

Distribution by 
frequency: 

The following parameters comprise the 
current configuration data for incoming 
interconnections with cyclical transfer, 
distributed by frequency level. 

Configured:  
fast (<Actual> ms);  
Interconnections: 
<Actual>;  
Data length: <Actual> 
byte 

Configured:  
medium (<Actual> ms); 
Interconnections: 
<Actual>;  
Data length: <Actual> 
byte 

Configured:  
slow (<Actual> ms);  
Interconnections: 
<Actual> ; 
Data length: <Actual> 
byte 

Current configured values for the incoming 
interconnections with frequency levels 
"fast", "medium" and "slow":  

• The configured interval for the transfer 
frequency in milliseconds 

• The current number of outgoing 
interconnections with the relevant 
frequency level 

• The current total data length of all 
outputs with interconnections of the 
relevant frequency level in bytes. 

No limit values are displayed, so 
no remedy is required. 

Utilization for 
interconnections of all 
frequency levels: 
<Actual>% 

This parameter shows the device 
utilization by incoming interconnections 
with cyclical transfer of all frequency levels 
(as a percentage). 

• Reduce the number of 
incoming interconnections 
with cyclical transfer to remote 
communication partners or  

• redistribute the incoming 
interconnections to other 
frequency levels or 

• use interconnections with 
acyclical transfer, if 
necessary. 
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Parameter Meaning  Remedy 
Outgoing 
interconnections: 

Interconnection at the outputs of technological function(s) 

Number Number of outgoing interconnections. For 
PROFInet devices with proxy functionality, 
this incorporates the interconnections of 
the coupled PROFIBUS devices. 

Sum of the data lengths  Sum of the data lengths of all connectors 
with outgoing interconnections in bytes. 
For PROFInet devices with proxy 
functionality, this incorporates the 
interconnections of the coupled 
PROFIBUS devices. 

• Reduce the number of 
outgoing interconnections with 
cyclical transfer to remote 
communication partners or  

• use interconnections with 
acyclical transfer, if 
necessary. 

Distribution by 
frequency: 

The following parameters comprise the 
current configuration data for outgoing 
interconnections with cyclical transfer, 
distributed by frequency level. 

Configured:  
fast (<Actual> ms);  
Interconnections: 
<Actual>;  
Data length: <Actual> 
byte 

Configured:  
medium (<Actual> ms); 
Interconnections: 
<Actual>;  
Data length: <Actual> 
byte 

Configured:  
slow (<Actual> ms);  
Interconnections: 
<Actual>;  
Data length: <Actual> 
byte 

Current configured values for the outgoing 
interconnections with frequency levels 
"fast", "medium" and "slow":  

• The configured interval for the transfer 
frequency in milliseconds 

• The current number of outgoing 
interconnections with the relevant 
frequency level 

• The current total data length of all 
outputs with interconnections of the 
relevant frequency level in bytes. 

No limit values are displayed, so 
no remedy is required. 

Utilization for 
interconnections of all 
frequency levels: 
<Actual>% 

This parameter shows the device 
utilization by incoming interconnections 
with cyclical transfer of all frequency levels 
(as a percentage). 

• Reduce the number of 
incoming interconnections 
with cyclical transfer to remote 
communication partners or  

• redistribute the incoming 
interconnections to other 
frequency levels or 

• use interconnections with 
acyclical transfer, if 
necessary. 
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Error messages for interconnections with cyclical transfer 
 

Error message Remedy 

The device does not 
support remote 
interconnections with 
cyclical transfer. 

• Replace the device with one with runtime version 2.0 or 
later that supports cyclical transfer or 

• use interconnections with acyclical transfer 

The capacity limit for 
remote 
interconnections with 
cyclical transfer 
between <Device 1> 
and <Device 2> with a 
transfer frequency of 
<nn> ms was 
exceeded. 

Reduce the volume of data transferred between the 
specified interconnection partners at the specified frequency 
level, i.e.: 

• Reduce the number of interconnections to remote 
partners 

• Redistribute the affected remote interconnections to 
other frequency levels or 

• use interconnections with acyclical transfer 

The connector 
<name> cannot be 
interconnected 
remotely with cyclical 
transfer due to its data 
length. 

Use interconnections with acyclical transfer, if necessary. 
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4.5.9 Checking the consistency 

What is the consistency check? 
The consistency check is a comparison between the device-specific data of the 
shadow project and the data of the original component project. This allows you to 
identify changes to the shadow project that were made with the vendor-specific 
configuration and programming tool.  

The result of the consistency check is displayed on the "General" tab in the 
information window. 

What is checked? 
For SIMATIC programmable controllers, the consistency is checked using STEP 7. 
This compares the program blocks for the station in the shadow project with those 
of the original component project in the SIMATIC iMap library. The check 
determines whether program blocks have been added, removed or changed in the 
shadow project.  

Requirement 
The vendor-specific configuration and programming tool (e.g. STEP 7) must be 
installed on the PG/PC. 

To run a consistency check: 
1. Highlight the instances to be checked in the plant view or net view. 

2. Select the Edit > Check Consistency menu command. 

The consistency check is carried out and the results are displayed on the "General" 
tab of the information window. 
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4.6 Structuring projects 

4.6.1 Creating subordinate charts 

Subordinate charts 
Subordinate charts are used to create a hierarchical structure for your plant, just 
like a directory tree in the file system.  

In the plant tree of the project view, a subordinate chart is represented as a folder 
that can contain technological functions and further subordinate charts. There are 
no subordinate charts in the net tree of the project view. 

In the plant view, a subordinate chart looks like a technological function with a 
chart interface for creating interconnections. The chart interface contains the inputs 
and outputs of the technological functions contained in the subordinate chart, 
which can extend beyond the limits of individual charts.  

To create a subordinate chart 
1. Open the project plant view. 

2. Select the Insert > New chart menu command.  

The new chart is inserted and is displayed in both the plant view and the project 
window. 

3. Give the subordinate chart a name 

� Via the editable name box in the plant view or 

� Via the "Properties" dialog 

4. Open the subordinate chart by double-clicking or using the Open chart context 
menu command. 

5. Insert your PROFInet components from the library and interconnect. 

6. For each connector to be contained in the chart interface, select the connector 
and activate the In chart interface option from the context menu If the 
connector is already contained in the chart interface, this is indicated by a tick in 
the context menu. 

If you then return to the chart one level up, the subordinate chart is represented in 
the same way as a technological function with the defined chart interface.  



Configuring plants 

 Component based Automation, Configuring Plants with SIMATIC iMap 
4-62 A5E00248797-01 

To move technological functions to a new chart: 
If you want to create a new subordinate chart from several technological functions: 

1. Select the technological functions. 

2. You have several options: Select: 

� the Paste > New Chart  menu command or  

� the "Insert new chart" icon from the toolbar or  

� the Move to new chart command from the context menu. 

Result: A new subordinate chart is created and the selected technological functions 
are moved to this chart. Any existing interconnections between charts are 
automatically inserted into the chart interface. 

Working with subordinate charts 
You can work with subordinate charts just as though they were technological 
functions, i.e. they can be interconnected, moved, deleted, cut and copied. 

The content and connectors of a subordinate chart can be modified as required. 

It is not possible to download a selected subordinate chart to all devices. To carry 
out a specific download, you must select individual objects. If you download to all 
devices in the plant, those devices whose functions are contained in the 
subordinate chart are included in the download. 

Hint: Navigation aid 
Select a connector of a subordinate chart and select Go To > Function connector 
from the context menu to access the associated connector of the technological 
function. 
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4.6.2 Data storage system in SIMATIC iMap 

Overview 
The SIMATIC iMap data storage system essentially comprises the following types 
of folder: 

• PROFInet components 

• SIMATIC iMap projects 

• SIMATIC iMap libraries 

The storage structure of these folders is described below.  

SIMATIC iMap also uses other file types, such as: 

• Archive files  

• Project documentation 

• Variable tables 

• OPC symbol files 

• Online device analyses 

• Re-edited component projects 

There are default storage locations in SIMATIC iMap for all of the file types and 
folder types used. 
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Project structure for PROFInet components 
Different types of project occur over the life cycle of a PROFInet component. The 
content and structure of these project is determined by the vendor-specific 
configuration and programming tool used for the component. We distinguish 
between the following types of project: 

• The basic project is the project from which the PROFInet component was 
created using the vendor-specific configuration and programming tool, e.g. a 
STEP 7 project. 

• The component project is a copy of the basic project that is assigned to the 
finished PROFInet component. It is stored in the file system or in a library 
together with the PROFInet component. The component project is the basis for 
upgrading the PROFInet components.  

 
Figure 4-17 Project structure for PROFInet components 

Storage structure for PROFInet components 
A PROFInet component consists of a folder containing: 

• The XML file containing the description of the PROFInet component and, in 
particular, the technological function. The system searches for this XML file 
when importing to a library.  

• The icon files  

• The component project (copy of the relevant part from the basic project).  

• The documentation link file (optional).  

The folder name is formed from the name, the identification (class ID) and the 
version number of the PROFInet component. This file structure is retained for all 
instances of the PROFInet component.  
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Storage structure for SIMATIC iMap libraries 
A SIMATIC iMap library is created as a folder. The important part is the library file 
of the same name, but with the extension .cbl, that must be specified when the 
library is opened. A library also contains the PROFInet components folder. 

Storage structure for SIMATIC iMap projects 
The SIMATIC iMap project  is the working project that contains the configured 
instances of the PROFInet components and their interconnections for a specific 
plant.  

A SIMATIC iMap project is created as a folder. The important part is the project file 
of the same name, but with the extension .cbp, that must be specified when the 
project is opened. A project folder also contains: 

• information about the inserted instances of the PROFInet components 

• the project library  

� visible as a separate folder if the project is open 

� not visible (compressed) if the project is closed. 

• one or more shadow projects that are created when the SIMATIC iMap project 
is generated. 

• a variable table, if one was created. 

 

 
Figure 4-18 Folder structure of iMap libraries and projects 
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The shadow project contains the vendor-specific data for the control units of the 
SIMATIC iMap project. It is created from the component projects in the project 
library when the SIMATIC iMap project is generated for the first time. The shadow 
project is needed for program downloads.  

The shadow project is either device-specific or vendor-specific. For example, the 
HMI units of a SIMATIC iMap project form a separate shadow project. 

 

 Note 
The way in which data is stored in the latest version of SIMATIC iMap (V2.0) has 
changed, and is no longer compatible with the previous version (V1.2). 

If you want to edit a project that was created in SIMATIC iMap V1.2, you will have 
to convert the data storage system to the current version. The associated SIMATIC 
iMap library must be open to be able to convert the PROFInet components used. 

Accessing iMap libraries and projects 
SIMATIC iMap libraries and projects behave just like normal documents. You can 
open, modify, save and archive them in SIMATIC iMap.  

 

 Notice 
The content of a SIMATIC iMap project folder must only be edited with 
SIMATIC iMap.  

If you change the project data using Windows Explorer, for example, it may no 
longer be possible to open the project in SIMATIC iMap. 

 

The actual project folder may be renamed, moved, copied or deleted in Windows 
Explorer, however. 

You cannot access several SIMATIC iMap projects at the same time.  

Deleting iMap libraries and projects 
You can delete SIMATIC iMap libraries and projects by deleting the folder 
concerned from the file system using Windows Explorer. 

Default storage locations 
The "Directories" tab on the Options > Customize menu command displays the 
default directories used as storage locations for the file types used in 
SIMATIC iMap. These directories are suggested first when you create, save and 
select the corresponding file types. 

Click on the "Modify" button to change the paths.  

These settings apply to all SIMATIC iMap projects. 



Configuring plants 

Component based Automation, Configuring Plants with SIMATIC iMap 
A5E00248797-01 4-67 

4.6.3 Connecting multiple projects 

Interconnecting connectors across projects 
In SIMATIC iMap, you can connect several projects by interconnecting the 
connectors across projects. This creates interconnections between technological 
functions that are located in different projects.  

 
Figure 4-19 Interconnection across projects 

The origin of the interconnection is an output in the source project, while the 
destination is an input in the target project. The interconnection between the two 
projects is always configured at the input (receiver) in the target project. 

Rules for interconnections across projects 
Only connectors from the relevant chart interface of the main chart (plant chart) of 
a project may be interconnected across projects.  

Outgoing interconnections across projects are ignored when the device utilization 
is verified. Only incoming interconnections across projects in the target project are 
included. 
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Requirements 
• In the source project, the device must have an IP address assigned to the 

instance to be interconnected across projects. If the source connector is on a 
PROFIBUS device, then the associated PROFInet device with proxy 
functionality must have an IP address. 

• The connectors to be interconnected across projects must be contained in the 
chart interface of the main chart (plant chart) of the project concerned.  

For every connector to be interconnected, select the connector and activate the 
�In chart interface� option from the context menu. If the connector is located in a 
subordinate chart, repeat this procedure until the connector is contained in the 
chart interface of the plant chart. 

To create interconnections across projects using drag-and-drop: 
1. Start SIMATIC iMap twice.  

2. Open the target project and the source project in separate SIMATIC iMap 
applications. Arrange the windows on the desktop of your PC/PG so that both 
are visible. 

3. In both projects, open the chart interface of the plant chart in the plant view by 
clicking on the "Open chart one level up" icon. 

4. In the source project, highlight the output to be interconnected, hold down the 
left mouse button and drag an interconnection to the input in the target project.  

Result: The input is identified as interconnected across projects. 

To create interconnections across projects using menu commands: 
1. In SIMATIC iMap, open the target project containing the input to be 

interconnected across projects. 

2. Open the chart interface of the plant chart in the plant view by clicking on the 
"Open chart one level up" icon. 

3. In the chart interface, highlight the input to be interconnected across projects 
and select the Interconnect externally command from the context menu.  

4. In the "Properties � External interconnection" dialog box, enter the following 
data from the source project in the "From" box (see example below): 

� the IP address, 

� the name of the PROFInet device, 

� the name of the technological function, 

� the name of the output to be interconnected from. 

5. Define the transfer parameters of the interconnection in the "Transfer 
parameters" box. You can either accept the defaults or modify the parameters. 

6. In the "Substitute value" box, enter a substitute value for the interconnection. 

7. Click on the "OK" or "Apply" button.  

Result: The interconnection data is assigned to the input and the connector is 
identified as interconnected across projects. 
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8. Highlight the device or the technological function whose input you have 
interconnected across projects. 

9. Download the interconnection to the device using the Download Selected 
Device > Interconnections only command.  

Result: The interconnection is downloaded and the communication link is 
established to the partner device in the source project. You can then monitor 
online in SIMATIC iMap the modified online values at the connectors 
interconnected across projects in the source project and in the target project. 

Example: Interconnection across projects 
The following diagram shows the data of the connector in the source project that 
you must enter using the Edit > Interconnect externally menu command when 
you create the interconnection across projects. 

 

 
Figure 4-20 Configuring an interconnection across projects 
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4.7 Working with modified PROFInet components 

4.7.1 Upgrading PROFInet components 

You can re-edit PROFInet components directly via a SIMATIC iMap library. This 
creates a copy of the component project in the directory defined under Options > 
Customize. You can edit the copy using the vendor-specific configuration and 
programming tool and then use it as the basic project for creating the re-edited 
PROFInet component. 

The copy of the component project is uniquely identified by the ID and version of 
the original PROFInet component. 

To re-edit a PROFInet component in SIMATIC iMap 
1. Highlight the PROFInet component to be modified in the library. 

2. Select the Re-edit command from the context menu. 

3. In the "Re-edit PROFInet component" dialog, select the directory in which you 
want to create a copy of the component project. Click on the "Browse" button to 
search the file system for the directory. 

4. Click on the "OK" button.  

If you do not yet have a copy of the component project, a copy is created and is 
opened for editing in the vendor-specific configuration and programming tool.  

If the selected directory already contains a copy of the component project, you 
are asked whether you want to overwrite this copy. Result: 

� Click on "Yes" to create a copy of the current component project in the 
specified directory and open it for editing in the vendor-specific configuration 
and programming tool. The existing copy is overwritten. 

� Click on "No" to open the existing copy of the component project for editing 
in the vendor-specific configuration and programming tool. 

5. Make the necessary changes to the copy of the component project. 

6. Create a new version of the PROFInet component and import the newly created 
PROFInet component into a SIMATIC iMap library. You can then use the 
component in SIMATIC iMap projects. 

7. If necessary, replace any instances of the earlier version of the PROFInet 
component with instances of the modified component (see "Replacing 
instances"). 

 

 Note 
The uniquely defined storage location for the modified component project makes it 
easier to make changes to PROFInet component. The next time you edit the 
PROFInet component, you will be reminded that an earlier copy already exists (if 
appropriate). 
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4.7.2 Replacing instances 

In SIMATIC iMap, you can easily replace the instance of a PROFInet component 
with the instance of another PROFInet component. In this way, you can quickly 
incorporate changes to PROFInet components into existing SIMATIC iMap 
projects. 

Rules for replacing instances 
The instances selected for replacement must originate from the same source 
component. 

The devices of the source component and target component must have bus ports 
of the same type. For example, a PROFInet device with Ethernet connector 
cannot be replaced with a PROFIBUS device (DP slave). 

What happens when you replace instances? 
The configured properties of the old instance, such as the name and addresses are 
transferred to the new instances.  

When you replace instances, interconnections are accepted if the technological 
function of the target component contains connectors of the same type (input or 
output), name and data type. Any configured substitute values and transfer 
properties of the interconnections are also accepted. 

 

 Notice 
If the source component and the target component have different technological 
functions, the instances will still be replaced.  

When you replace the instances, interconnections can be lost if the technological 
function of the target component does not contain all the connectors of the 
technological function of the source component. 

Requirement 
The target component must be located in the project library. If necessary, you 
should import the target component into the project library.  
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To replace the instance of a PROFInet component: 
1. Select either: 

� the original component from the project view or 

� the instance or instances to be replaced. You can do this both in the project 
tree and in the plant view, net view or project view. 

2. Select Replace from the context menu. The "Replace instances" dialog box 
opens.  

3. Define the target component. You can either accept the suggested target 
component and its version or select one from the drop-down list. 

4. If necessary, change the instances selected for replacement. Highlight the 
required instances in the "Available instances" or "Instances selected for 
replacement" box and click on the ">" or "<" button to move to the other box. 

5. Click on the "Replace" button.  

Result: The selected instances of the original component are replaced by 
instances of the selected target component.  

The interconnections are transferred to the new instances in conformity with the 
connectors. 

6. Check the replaced instances: 

� to ensure that all the necessary interconnections are present and 

� to ensure that the substitute values and transfer properties of the 
interconnections are configured correctly. 

7. Check the configuration of the replaced instances using the Edit > Verify 
utilization menu command (optional). 

8. Generate the project using the Project > Generate > Changes only menu 
command. 

9. Use the Download Selected Device > All menu command to download all the 
programming and configuration data to the target system.  

Hint: Replace with drag-and-drop 
To replace an individual instance: Select the target component from the library, 
hold down the "Alt" button and drag it onto the instance to be replaced within the 
project. Answer "Yes" when you are asked whether you really want to replace the 
instance. Then carry out steps 6 to 9 as described above. 
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4.7.3 Moving interconnections 

Definition 
In SIMATIC iMap, the end point of an interconnection can be moved onto a 
connector of another technological function.  

Rules for moving interconnections 
The target connector to which the end point of an interconnection is to be moved 
must fulfil a number of conditions. These conditions depend on the number of end 
points to be moved. 
• Some or all of the end points of the interconnections of a technological function 

can only be moved onto connectors of the same type (input or output), same 
name and same data type of another technological function.  

• There are two ways to move the interconnection at an individual end point: 
� at a connector of the same type (input or output) and same data type (in 

which case the I/O names do not have to be the same) or 
� at a different technological function. In this case, the technological function 

selected as the target must contain a connector of the same type (input or 
output), same name and same data type. 

• If the end point is an input, it can only be moved to an unconnected input. An 
output can be moved onto an already interconnected output. 

• Interconnections cannot be moved across the boundaries of a chart; the source 
and target must be in the same chart. 

• The configured substitute values are accepted for the interconnections.  
• Interconnections with configured substitute values cannot be moved from a 

PROFInet device to a PROFIBUS device if the configured substitute values are 
not equal to the default values. 

To move several interconnections: 
1. Select: 

� the entire technological function if you wish to move all the interconnections 
or 

� just the connectors whose interconnections are to be moved. 
2. Select the Move Interconnections command from the context menu. The 

technological functions to which the selected interconnections can be moved 
are highlighted in color when the mouse pointer moves over them. 

3. Click on the technological function to which the interconnections are to be 
moved.  

4. You are prompted to confirm that you want to move the interconnections. Click 
on "Yes" to confirm.  
Result: the interconnections are moved to suitable connectors in the new 
technological function. 

Interconnections for which no suitable targets are found are not moved. They 
remain at the original technological function. 
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To move an individual interconnection: 
1. Select the connector whose interconnection is to be moved. 

2. Select the Move Interconnections command from the context menu. The 
possible target connectors or technological functions to which the 
interconnection can be moved are highlighted in color when the mouse pointer 
moves over them. 

3. Click on the target connector to which the interconnection is to be moved.  

Result: the end point of the interconnection is moved to the target connector. 

4.8 Editing in the vendor-specific programming and configuration tool  

SIMATIC iMap allows you to call applications from the vendor-specific 
programming and configuration tool directly at an instance within the project. You 
can then look up or edit the device-specific data, for example. The device-specific 
diagnostic information that can be looked up in this way is particularly important. 

Accessing the vendor-specific programming and configuration tool 
You can call the vendor-specific programming and configuration tool from 
SIMATIC iMap in the following ways: 

• Modify a technological function in the plant view 

• Modify a device in the net view 

Depending on which object you have selected, you can open different applications 
in the vendor-specific engineering tool in order to edit parts of the PROFInet 
component. 

Requirement 
The SIMATIC iMap project has been generated. 

To edit objects in the vendor-specific programming and configuration tool: 
1. Select the object to be edited: 

� The technological function in the plant view or project window 

� The device in the net view or project window. 

2. Select Edit > Special using one of the available commands. These commands 
are device-specific. The menu is grayed out if there is nothing to edit or if 
nothing has been generated yet. 

3. Save the changes and download them to the target system. 
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 Caution 
When you are editing with the vendor-specific configuration and programming tool, 
you must make sure that no inconsistencies or other errors occur in the edited 
component project or shadow project  

In the event of an error, you may find that you have to generate the SIMATIC iMap 
project again. 

 

 Caution 
If you regenerate the iMap project using the Project > Generate > Control unit > 
All menu command, any changes you have made using the vendor-specific 
configuration and programming tool will be lost. A copy of the old shadow project is 
created, however. 

Changes you make using the vendor-specific configuration and programming tool 
cannot be undone in SIMATIC iMap. 
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Commissioning and online mode 5
5.1 Basic procedure for commissioning  

Requirements 
The following requirements must be fulfilled before you can commission a plant: 

• The device-specific configuration and programming tools, e.g. STEP 7, are 
installed on your PC/PG. Depending on the type of device, this software is 
needed in order to carry out certain actions, e.g. to download programs. 

• The project has been generated without errors in SIMATIC iMap. 

• All the device configuration data has been prepared (generated) for 
downloading. 

• The devices are connected via Ethernet or PROFIBUS. 

• The devices are switched on. 

• The PC/PG running SIMATIC iMap is connected to the devices in the plant via 
Ethernet. 

Basic procedure 
1. Start SIMATIC iMap 

2. Open the project. 

3. Download programs and interconnections to the devices. 

You can then use the following test and diagnostic functions (optional): 

• Perform online monitoring and diagnostics for the plant  

• Test and control with the variable table  

• Display and set online values  

• Run online device analysis 

• Checking the accessiblity of the devices 

• Compare online and offline data for programs and interconnections 

• Run device-specific diagnostics  
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5.2 Overview of the online functions 

Requirement 
SIMATIC iMap must be connected to the plant via Ethernet in order to monitor the 
devices online. Both PROFInet and PROFIBUS devices (via a PROFInet device 
with proxy functionality) can be accessed via the online connection. 

SIMATIC iMap in the online and offline views 
By default, SIMATIC iMap is in the offline view (no connections established to the 
devices). 

Online mode may be switched on and off for individual SIMATIC iMap views. 

• Variable table - by clicking on the "Monitor variables online" icon or using the 
Online > Variable table > Monitor variables menu command. 

• All the other views (e.g. the plant view, net view or the "Functions" and 
"Devices" tabs in the diagnostic window) by clicking on the "Online connection" 
icon or using the Online > Monitor menu command. 
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Figure 5-1 SIMATIC iMap in the online view 

 

 Note 
A plant may only be monitored online with just one SIMATIC iMap application. 

Switching on the online view for a plant in several SIMATIC iMap applications 
increases the processor load in the target devices of the plant. 
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Online functions 
SIMATIC iMap offers the following functions for starting and for controlling and 
monitoring the plant during operation:  

Online monitoring activated 

• Diagnosis for devices, functions and interconnections 

• Downloading interconnections to the devices of a plant  

• Displaying and setting online values 

• Displaying the module status (depending on the device type)  

• Displaying the operating status (depending on the device type)  

• Downloading interconnections 

Online monitoring deactivated 

• Comparison between the online and offline interconnection and program data  

• Downloading the programs and interconnections to the devices of a plant.  

• Checking the accessiblity of the devices 

Separately from the online view: 

• Device-specific diagnostics via the vendor-specific configuration and 
programming tool. 

• Online device analysis 

Possible actions in the online view 
If Online connection is switched on, certain actions that modify the project, such 
as copying, pasting, deleting and interconnecting, are disabled. Generating, 
documenting and archiving/retrieving are also unavailable in the online view. 

Actions such as viewing (not changing) properties, printing the current window and 
calling the Edit > Special...  menu command are also not possible in the online 
view. 
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5.3 Downloading Programs and Interconnections 

Download options  
The term "downloading" means loading data from SIMATIC iMap onto a 
programmable controller or field device. You can download the following data to 
the devices of the plant from SIMATIC iMap: 

• Program  

Downloading of the user program including all the device-specific data, such as 
the hardware configuration and network configuration. The vendor-specific 
configuration and programming tool, for example STEP 7, is required for the 
program download. 

• Interconnections  

Downloading of the interconnection information into the corresponding devices 
of the plant. Interconnections may be downloaded from SIMATIC iMap without 
the vendor-specific configuration tool.  

• All  

Loads the program and interconnections onto the devices of the plant. The 
vendor-specific configuration and programming tool is also required. 

The following downloads are possible, depending on which objects are selected: 

 
Selection Possible download Menu command 

Not 
selected 

for the complete project 

• All  

• Program only 

• Interconnections only 

Main menu 

Online > Download all instances 
> All 
> Program only 
> Interconnections only 

One or 
more 
instances  

for the select instances  

• All  

• Program only 

• Interconnections only 

Main menu 

Online > Download all instances  
> All  
> Program only 
> Interconnections only 

Context menu 

Download selected instances  
> All 
> Program only 
> Interconnections only 

 

 Note 
Make sure that the program and interconnections are downloaded to device from 
only one instance of SIMATIC iMap at any given time. 

The user program may be overwritten in the target system concerned if you use 
the wrong IP addresses. 
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 Note 
Instances of singleton components are not included in the program download. The 
program download can only be carried out via the vendor-specific configuration 
tool.  

Target for the download  
 

Download... Selected device to 
SIMATIC iMap  

Target device for the downloads in the 
plant 

Program PROFInet device Corresponding PROFInet device 

 PROFIBUS device Corresponding PROFIBUS device 

Interconnections PROFInet device Corresponding PROFInet device 

 PROFIBUS device Associated PROFInet device with proxy 
functionality 

 

 Note 
Additional steps may be needed to permanently store the downloaded data to the 
device, depending on the device type. 

When is a download required? 
• Program download  

You can determine whether a program download is necessary by carrying out 
an online-offline comparison.  

A program download is needed in the following situations: 

� When a device is commissioned  

� After coupling or decoupling PROFIBUS devices  

In this case, a program download to the associated PROFInet device with 
proxy functionality and to all intelligent PROFIBUS devices associated with 
the proxy system is required. 

� After replacing instances 

Attention: When you replace a PROFIBUS device, a program download is 
required both to the associated PROFInet device with proxy functionality and 
to the target device of the replaced instance. 

• Interconnections can be downloaded to the target devices later if required, e.g. 
in order to test the PROFInet communication between the components.  
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The instances for which interconnections have to be downloaded are identified 
by a vertical arrow and are listed on the "Functions" tab in the diagnostic 
window (see diagram). 

Figure 5-2 Download required 
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Requirements for the download 
For program and interconnection download: 

• Your PC/programming device must be connected to the plant via the Ethernet.  

• The devices must be accessible. 

Plus for program download only: 

• All instances of the PROFInet components for which the program download is 
required must have the generation status "generated" in their properties. You 
may have to generate the SIMATIC iMap project. 

• Online monitoring must be switched off in SIMATIC iMap.  

 

 Note 
Recommendation: Before downloading, check the device utilization (with the Edit 
> Verify utilization menu command) to ensure that the plant runs error-free. 

To download to all the instances: 
Select one of the following commands from the main menu in the project net or 
plant view: 

• Online > Download all Instances > Program only to download the programs 
to all the devices of the plant 

• Online > Download all Instances > Interconnections only to download the 
interconnections to all the devices of the plant 

• Online > Download all Instances > All to download both programs and 
interconnections to all the devices of the plant. 

Result: The desired data is downloaded to all the devices of the plant. Information 
on the progress and completion of the action and any error messages are 
displayed in the information window.  

To download to selected instances: 
1. Select the instances of the PROFInet component(s) for which a download is to 

be carried out. The options are as follows: 

� One or more technological functions in the plant view or project tree. 

� One or more devices in the net view or project tree. 

� One or more instances in the project view. 

2. Select one of the following commands from the context menu:  

� Online > Download selected instances > Program only to download only 
the program to the devices 

� Online > Download selected instances > Interconnections only to 
download only the interconnections to the devices 

� Online > Download selected instances > All to download both the 
program and the interconnections to the devices. 
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Result: The desired data is downloaded to those devices of the plant which are 
assigned to the selected objects. Information on the progress and completion of 
the action and any error messages are displayed on the "General" tab in the 
information window. 

Downloading to PROFIBUS devices 
The interconnections of PROFIBUS devices are downloaded to the associated 
PROFInet device with proxy functionality, where they are stored.  

When the program is downloaded, part of the configuration data for the coupled 
PROFIBUS devices is stored on the associated PROFInet device with proxy 
functionality. When you download programs to select instances, you must therefore 
first download the program to the PROFInet device with proxy functionality, and 
then download the program to the coupled PROFIBUS devices.  

 
Figure 5-3 Downloading to PROFIBUS devices 

 

 Notice 
When you download the program to a PROFInet device, both the interconnections 
of the actual PROFInet device and the interconnections of any coupled PROFIBUS 
devices are deleted. 

You will then have to download the interconnections to all devices of the DP 
master system. 
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Downloading interconnections 
 

 Caution 
The interconnections are downloaded to the target system regardless of the 
operating status or level of protection on the target system. Existing 
interconnections will be deleted. To guarantee the security of your plant, make 
sure that all the settings, such as function names and IP addresses, have been 
entered correctly. This also applies to the "Download" button in the diagnostic 
window. 

Select the Online > Online-offline comparison >... menu command to determine 
the differences between the SIMATIC iMap project (offline) and the plant (online). 

Examples 

Table 5-1 Examples: Download required 

Example Display 

Function, 
interconnection 
download required 

 
Device, 
interconnection 
download required 

 
List of functions with 
faults  
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Example Display 
List of devices with 
faults 

5.4 Diagnostic information in the online view 

Introduction 
When the online view is switched on in SIMATIC iMap, it provides information in 
graphical format about  

• the availability and status of the PROFInet stations,  

• the status of the interconnections and online values, and 

• The operating status of the devices (depending on the device type) 

Online-offline comparison 
SIMATIC iMap allows you to compare the online and offline interconnection and 
program data. The result of an online-offline comparison is displayed: 

• in text format in the information window and diagnostic window, and  

• as graphical information in the plant and net views, and in the diagnostic 
window. Graphical information means: 

� Icons, e.g. "Interconnection download required", or 

� Object colors, e.g. grayed-out devices are not accessible. 
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Status of the PROFInet communication nodes 
From the viewpoint of PROFInet communication the nodes have certain states 
which are indicated in SIMATIC iMap by icons and diagnostic messages, e.g.: 

• whether the devices are accessible online (configuration error), 

• whether there is a diagnostic messages for the devices, 

• whether an interconnection download is required, 

• whether diagnostic information is available at all, 

• whether interconnections are functioning correctly, 

• whether a PROFIBUS device is connected to the associated PROFInet device 
with proxy functionality. 

In the plant view, there is also an indication of whether online values are valid or 
not. 

In the net view, the operating statuses of the devices are also displayed. 

Table 5-2 Diagnostic icons 

Icon Error message Meaning 

 Configuration check The connection to the device cannot (yet) be 
established, the device is not (yet) accessible or the 
function is not available on the target device. 

 Device diagnostics or 
fault 

• On devices in the net view: Device-specific 
diagnostics available. You can click on the 
"Diagnostics" button in the right-hand part of the 
diagnostic window to look up diagnostic 
information. 

• On a subordinate chart in the plant view: There is a 
fault in one or more functions within the chart. 

 Not connected The PROFIBUS device is not connected to the 
PROFInet device with proxy functionality, is not 
switched on the state is STOP. 

 No information 
available 

The device can be accessed, but its state cannot be 
determined. (This can happen to a DP slave, for 
example, if the DP master state is STOP). 

 Download required Interconnection download required. 

 Interconnection failed At least one interconnection to the device has failed. 

No icon   The device or function is OK (blue) 
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Normal representation and inverse video 

The symbols in both the plant view and the net view are displayed normally or 
inverted.  

• The normal representation (black symbol on a yellow background applies to the 
instance displayed, e.g. device in the net view or technological function in the 
plant view). 

• The inverted representation (yellow symbol on a gray background): Diagnostic 
symbols for the technological functions (e.g. "Interconnection failed") are 
displayed inverted on the devices in the net view, while diagnostic symbols for 
the devices are displayed inverted on the technological functions . 

In the project view, the diagnostic symbols are displayed normally on the device or 
on the technological function. 

Device operating statuses 
The current operating state of a device is displayed as a symbol in the 
SIMATIC iMap online net view.  

 
Icon Operating state 

 RUN 

 STOP 

 STARTUP 

 DEFECTIVE 

 

For PROFIBUS devices it is also indicated whether the device is connected to the 
PROFIBUS master: 

 
Icon State 

 Connected to the PROFInet device with proxy 
functionality 

 Not connected 

Status of the interconnections 
The status is indicated by the color of the interconnection line:  

 
Color of the interconnection 

line 
Meaning 

Black  the interconnection is OK 

Green  The interconnection has been selected 

Red  The interconnection has failed (the failure generally 
occurs at the output from the technological function of 
the sending device) 

Gray  There is no information about the interconnection (e.g. if 
the device is unavailable or a download is required) 
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Diagnostic messages in the Diagnostic window 
If the SIMATIC iMap online view is switched on, current messages are displayed 
on the "Functions" and "Devices" tabs in the diagnostic window. 

• The "Functions" tab displays diagnostic messages on the faulty technological 
functions and interconnections, such as a list of the functions for which the 
interconnections will have to be downloaded. 

• The "Devices" tab displays diagnostic messages on the devices, such as a list 
of faulty or unavailable devices.  

The left-hand window contains the faulty devices or functions, sorted by type of 
fault. The inaccessible devices are displayed hierarchically by DP master system 
so that all the DP slaves assigned to a DP master can be recognized readily.  

The right-hand window contains detailed information about the highlighted faulty 
instance and provides download, device-specific diagnostics and help buttons 
according to the type of fault.  

 

 Note 
When a PROFInet device with proxy functionality (DP master) fails or is not 
accessible, then no detailed diagnostic messages are displayed for the coupled 
PROFIBUS devices.  

Examples 
Example Display 

Diagnostic window, 
"Functions" tab 

Diagnostic window, 
"Devices" tab 
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5.5 Diagnosing PROFInet components 

Basic diagnostic procedure 
To diagnose PROFInet components in SIMATIC iMap, you can either follow the 
basic sequence described below or carry out specific individual actions. 

1. Switch on the online view using the "Online connection" icon, for example. 

2. Open the "Devices" tab in the diagnostic window.  

Result: The left-hand window displays diagnostic information about the devices 
dynamically in the form of a tree structure.  

If no diagnostic information is available, then there are no faults in the devices 
of the plant. Then continue from step 4.  

3. If there is diagnostic information available on the "Devices" tab, process this 
information by selecting the device and following the detailed information and 
troubleshooting options in the right-hand window. Eliminate any faults. Click on 
any available buttons to call up device-specific diagnostics, for example.  

Order: First process the devices in the "Configuration check" category. If the 
configuration check for a device cannot be carried out successfully, it will not be 
possible to run PROFInet diagnostics for that device. You can then process the 
remaining devices in any order. 

4. Check the entries on the "Functions" tab. If there are no faulty functions listed, 
then there are no faults in the plant. 

5. If there is diagnostic information available on the "Functions" tab, process this 
information by selecting the function and following the detailed information and 
troubleshooting options in the right-hand window. Eliminate any faults. Click on 
any available buttons in order to download the interconnections, for example.  

Order: First process the functions in the "Configuration check" category. If the 
configuration check for a function cannot be carried out successfully, it will not 
be possible to run PROFInet diagnostics for that function. You can then process 
the remaining functions in any order. 

The following tables contain a summary of the common diagnostic scenarios for 
devices and functions, and the troubleshooting options. 
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Diagnostic scenarios for devices 
The individual diagnostic scenarios for devices are described in the following table. 

 
Diagnostic 
scenario 

Possible Causes Possible Remedies 

 
Configuration check 

• Communication fault, for example, 
cable break, cable not connected 

• The device is switched off  

• The device has not been started or 
has not been initialized completely 

• The device is not a PROFInet 
device  

• Error in the hardware configuration 
(different configuration) 

• The program has not been loaded 
yet 

• Wrong device or function 
downloaded 

• Check the communication links  

• Eliminate the fault 

• Switch on or start device 

• Check the IP addresses and subnet 
masks 

• Check the PROFIBUS addresses 

• Check the hardware configuration 

• Download program to the device 

 
Device diagnostics 

• Error in the program  

• The device has STOPped 

• Call device-specific diagnostics by 
clicking  

on the "Diagnostics" button, if 
necessary  

• Eliminate the error 

• Download program to the device 

 
Not connected 

• PROFIBUS cable not connected or 
defective 

• PROFIBUS device not switched on 
or STOP status 

• Check the PROFIBUS cable 

• Switch on the PROFIBUS device 

• Switch the PROFIBUS device to 
RUN 

 
No information 
available 

• The associated PROFInet device 
with proxy functionality is faulty or 
status is STOP. 

• The program has not been 
downloaded to the PROFIBUS 
device 

• Switch on PROFInet device or switch 
to RUN 

• Rectify fault on PROFInet device, if 
necessary 

• Download program to the 
PROFIBUS device 

 

 Notice 
When you switch on the online view, all configured devices are first assigned to the 
"configuration check" category, and remain present until the first check is 
completed. If this test does not identify any differences between the configured 
device and the data in the plant, then the device is removed from the category. The 
time required for this operation will differ according to the plant size and PC. 
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Diagnostic scenarios for technological functions 
The individual diagnostic scenarios for technological functions are described in the 
following table. 

 
Diagnostic 
scenario 

Possible Causes Possible Remedies 

 
Configuration check 

• The device is switched off 

• The device has not been started 
or has not been initialized 
completely  

• The program has not been 
loaded yet  

• Target system contains no or a 
different technological function 

• Check the communication links  

• Rectify the fault, if necessary 

• Switch on or start device  

• Download program to the device  

 
on the subordinate 
chart in the plant 
view 

• The chart contains at least one 
faulty function 

• Open the chart and check the 
individual functions. 

 
Download required 

• The interconnection data is 
different in SIMATIC iMap and in 
the device. 

• Download interconnections into the 
device 

Click on the "Download" button 

 
Interconnection 
failed 

• Communication partner of the 
device has a fault or is not 
available. 

• Incompatible transfer properties 
for interconnections (transfer 
mode or transfer frequency) 

• Check the communication connections 

• Check the properties of the 
interconnection and correct, if 
necessary  

• Run an online-offline comparison of 
the interconnections and 

• Eliminate the fault 
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5.6 Checking the accessiblity of the devices 

Requirement 
Your PG/PC must be connected to the plant via Ethernet in order to check the 
accessibility of the devices. 

Accessible device 
A device of the plant must be accessible via PROFInet communication 
mechanisms in order to download the interconnections or monitor variables.  

SIMATIC iMap provides a number of ways of checking whether a PROFInet device 
is accessible online. 

• If Online connection is switched on: 

� In the net view and plant view, the accessiblity of the devices is represented 
graphically: Accessible devices are shown in blue, while inaccessible 
devices are gray and are shown with a diagnostic symbol. 

� On the "Devices" tab in the diagnostic window, the inaccessible devices are 
listed. 

• If Online connection is switched off, the accessiblity of individual devices can be 
looked up using menu commands. 

Check accessibility 
To look up the online accessiblity of a device: 

1. Switch off the "Online connection" option, using the Online > Monitor menu 
command, for example.  

2. Select the device from the net view or the technological function from the plant 
view that you wish to check. You can also select multiple objects. 

3. Select:  

� Check Accessibility from the context menu or 

� the Online > Check Accessibility menu command. 

Result: The online accessiblity of the devices is checked, and the result are 
displayed on the "General" tab in the information window. 
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Possible messages 

 
Message Possible Causes Remedy 

No node is accessible at 
IP address <IP_address>. 

• The physical connection to the device has 
failed or is not available. 

• The device is not switched on 

• For PROFIBUS devices: The associated 
PROFInet device with proxy functionality is 
not accessible or its status is STOP. 

If the device is a PROFInet device with proxy 
functionality, then any PROFIBUS devices 
coupled to it will also be inaccessible. 

• Check connection or 
cable 

• Switch on the device 

• Check the PROFInet 
device with proxy 
functionality (DP 
master) 

The PROFInet access to 
the device <IP_address> 
is not accessible 

The device is physically connected, but it is not 
ready for use (e.g. status is STOP)  

Switch the device to RUN 

The logical device <device 
name> (proxy at <IP 
address>) is accessible, 
but the physical device is 
not. 

For PROFIBUS devices only:  

• The PROFInet configuration data for the 
device can be found on the associated 
PROFInet device with proxy functionality, 
but the connection between the DP master 
and DP slave has failed, or 

• the PROFInet configuration data has not 
been downloaded. 

• Check the PROFIBUS 
connection between 
the DP master and DP 
slave.  

• Download the program 

The device <Device 
name> is accessible 

  

 

Logical device 
The logical device is part of the runtime software that is responsible for the 
PROFInet communication of a device. It is addressed during online monitoring by 
SIMATIC iMap. The PROFInet configuration data for a component downloaded to 
the device is assigned to this logical device.  

 

 Note 
The logical device of a PROFIBUS device can be found on the associated 
PROFInet device with proxy functionality.  

If the logical device of a PROFIBUS device is signalled as accessible, although the 
device is represented as inaccessible in the online view, this can mean the 
following: 

The PROFInet configuration for the PROFIBUS device is OK, but the physical 
device of the DP slaves is inaccessible because the connection to the DP master 
(associated PROFInet device with proxy functionality) has failed, for example. 
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Examples: Accessiblity  
 

Figure 5-4 Representation in the net view 

 

Figure 5-5 Message in the information window 
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5.7 Comparing online and offline data 

Comparison options  
If SIMATIC iMap is linked to a device of the plant via Ethernet, it is possible to run 
an online-offline comparison for one or more instances. This compares the online 
data in the plant with the offline data in the SIMATIC iMap project. You can 
compare the following data in SIMATIC iMap: 

• Interconnections only � connectors and interconnections of the technological 
functions 

• Program only � all the blocks in the user program, including all device-specific 
data such as the hardware and network configurations.  

Online-offline comparison of interconnections 
In an online-offline comparison of the interconnections, the online and offline data 
for the technological functions and their interconnections are compared. The 
following are tested: 

• Added or removed interconnections  

• Different transfer properties, e.g. transfer mode and transfer frequency. 

• Inputs and outputs added or removed from the technological function 

• Different connector data types  

 

 Note 
Before interconnections are downloaded, the online-offline comparison of the 
interconnections is not carried out automatically since this would lead to longer 
run times. For safety reasons, we therefore urgently recommend that you run a 
comparison before downloading in order to avoid possible errors at runtime. 

Requirements 
• Your PC/programming device must be connected to the plant via the Ethernet.  

• The SIMATIC iMap project must have been generated before you can run the 
Online-offline comparison for programs. 

• Online monitoring must be switched off in SIMATIC iMap.  

To compare programs: 
1. Select  

� the required devices from the net view or 

� the required technological functions from the plant view. 

2. Select Online-offline comparison > Program only from the context menu. 

The result of the comparison is displayed on the "Online-offline comparison" tab in 
the information window. 
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Example: Comparing programs 
Comparison of the program and configuration information before online monitoring. 
Devices in which differences were found are identified by a STOP symbol. 

 

Figure 5-6 Online-offline comparison of programs 

To compare interconnections: 
1. Select  

� the required devices from the net view or 

� the required technological functions from the plant view. 

2. Select Online-offline comparison > Interconnections only from the context 
menu . 

The result of the comparison is displayed on the "Online-offline comparison" tab in 
the information window. 

Additional error messages may be displayed on the "Functions" tab in the 
diagnostic window for failed interconnections. 
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Example: Comparing interconnections 
In the following diagram, the comparison shows that an interconnection download 
is required since the interconnection partners are different. 

Figure 5-7 Online-offline comparison of interconnections 
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5.8 Displaying and setting online values in the plant view 

Online values of PROFInet variables 
The online values of PROFInet variables are current values at the connectors of 
technological functions.  

In the Online view of SIMATIC iMap you can: 

• monitor selected online values at the connectors of technological functions,  

• set online values of individual inputs once in order to test a PROFInet 
component in the commissioning phase, for example, 

• monitor and set online values in the variable table (see section entitled "Online 
testing with the variable table). 

The procedure for displaying and setting online values in the plant view is 
described below. 

Requirements 
SIMATIC iMap must be connected to the plant online ("Online connection" button 
pressed).  

To display online values: 
1. Select the required connectors of the technological function(s) from the plant 

view. 

2. Select the Online > Display Online Values menu command or Display Online 
Values from the context menu. 

Result: The online values of the connectors are displayed in the plant view. 

The online values are updated dynamically.  

 

 

Caution 
Network load on the Industrial Ethernet and in the devices of the plant. 

Additional communication functions for monitoring connectors are performed on 
the Industrial Ethernet.  

You should note, however, that the network load can be affected both by the 
number of connectors to be monitored and by the frequency with which the values 
change. 

Remedy: Individually select the connectors whose values you wish to monitor 
online. 
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 Note 
The display of online values of the type array and struct is limited. No more than 16 
elements can be displayed via Tooltips. Larger arrays and structures must be 
displayed via the variable table. 

Validity of online values 
The validity of displayed online values is indicated by different colors. 

 
Color of the online value Significance: the value ... 

Black is valid 

Red is invalid (e.g. due to a fault or immediately after setting, if 
the online value has not yet been confirmed in the target 
system) 

Red with question mark has not yet been confirmed or the device is not (yet) 
accessible 

Red with exclamation mark cannot be monitored because there are no free resources 
on the device 

Gray is uncertain (the validity cannot be determined) 

Gray italic is a substitute value 

 

Example: Displaying online values 
 

 
Figure 5-8 Displaying online values 
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To set an online value:  
1. Select the desired input of a technological function in the plant view.  

2. Select the Online > Display Online Value menu command.  

Result: The online value of the connector is displayed. 

3. Click on the value or select the Online > Set Online Values menu command.  

Result: Depending on the data type of the connector either  

� A selection box with the permitted values, e.g. True and False for the data 
type BOOL, or 

� An edit box for all other data types is displayed. 

4. Select the required value or enter it in the edit box and press Enter to confirm. 
Result: The entered value must be confirmed by the device in the plant. It can then 
change to black, red or gray (see above "Validity of the Online Values").  
If the device cannot be accessed online or if a fault has occurred, the set value is 
not confirmed. In this case, the last known value is displayed as red or as a red 
question mark. 
The value remains constant as long as this input is not interconnected or modified 
by the user program of the technological function. If the input is interconnected via 
SIMATIC iMap, the online value can be modified via the interconnection. 
 

 Note 
Online values of the data type Array and Struct cannot be set. You should use the 
variable table for these values. 

 
Hint: You can also interconnect inputs to constant values for testing purposes.  

Example: Setting an online value 
Setting an input of the type DATE. 

 

 
Figure 5-9 Setting online values 
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5.9 Online testing with the variable table 

5.9.1 Creating a variable table 

Structure of the variable table 
The variable table contains the variables of the connectors to be tested online.  

Table 5-3 Structure of the variable table 

Column Meaning 

No. Line number 

 Automatically displays whether the entry is deactivated, 
connected online or inaccessible. 

Device Here you can enter the device name or select it from a list. 

Function Here you can enter the function name or select it from a list. 

Connector Here you can enter the connector name or select it from a list. 

Type The data type of the connector is displayed here. 

Format Here you can select the display format for the online value. 
<Automatic> means the default format, e.g. decimal for I1, I2, 
UI1, R4 or True/False for BOOL. 

Online value Displays the online value when the variable is connected online.

Control value Here you can enter control values for inputs. You can transfer 
these values to the plant at any time to set the relevant online 
values. 

Comment A comment is entered here. 

 

Select the Columns command from the context menu to show or hide individual 
columns. 

To insert entries: 
1. Open the "Variable table" tab in the diagnostic window. 

2. Select the required connectors or technological functions from the plant view 
and drag them into the variable table.  

Result: An entry is completed in the variable table for every inserted connector. For 
arrays and structures, you can expand and shrink the lines that make them up. 

Other options:  

• Enter data directly into the "Function" and "Connector" boxes or 

• Select the function and connector from the drop-down list. 

The other fields are filled in automatically. 
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Rule 
The variable table can contain up to 50 entries. 

Invalid entries (e.g. unknown name for functions or connectors) are displayed in 
red. Variables with invalid fields cannot be monitored. 

Example: Variable table 
The following variable table contains the connectors for the "Coordinator" function. 

 

Moving, copying, cutting and deleting entries 
Move 

You can move selected entries within the variable table using drag-and-drop 

Copy, cut and delete 

Select the appropriate commands from the context menu to copy, cut or delete 
selected entries. 

To sort the entries:  
You can sort the entries by clicking on the required column header. 
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To save the variable table:  
The variable table is always saved together with the SIMATIC iMap project. If you 
wish to save a variable table within the file system, to test another project, for 
example, then you will have to export it. 

To export the variable table:  
1. Select the Options > Export Variable table menu command. 

2. In the "Export Variable table" dialog, select a directory from the "Search in" box. 

3. In the "File name" box, enter a file name or select a name from the list. 

4. Click on the "Save" button. 

Result: The current variable table is stored in the file system. The file name always 
has the extension .CBV 

To import a variable table:  
By importing, you can copy a variable table from the file system into the currently 
opened SIMATIC iMap project. 

 

 Note 
The existing entries are overwritten when you import the variable table. We 
recommend that you use the Options > Export Variable table menu command to 
back up the current variable table, if necessary, before importing.  

 

Proceed as follows: 

1. Select the Options > Import Variable table menu command. 

2. Select the required variable table from the "Import variable table" dialog. Look 
for a file name with the extension .CBV. 

3. Click on the "Open" button. 

Result: The entries in the imported variable table are copied to the variable table 
for the project. 

Default storage location for variable tables 
Use the Options > Customize menu command on the "Directories" tab to define a 
directory for storing variable tables. This directory will be suggested when you 
import and export variable tables. 
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5.9.2 Perform online monitoring and diagnostics of variables 

Overview 
You can use the variable table to test the plant by: 
• monitoring selected variables online and  
• assigning control values to selected variables during the testing phase. 
Only variables whose entries are activated in the variable table can be monitored. 
You can exclude selected variables from the monitoring by deactivating the 
associated entries in the variable table. 
With the variable table, you can monitor variables online, regardless of whether 
Online connection is switched on in the plant view or net view. You can monitor 
just selected variables or all active variables in the variable table. 
You can enter control values for selected input variables. You can then assign 
these control values to the variables for testing purposes, and thus replace their 
current online values. 

Deactivating and reactivating entries 
Newly inserted entries are active. You must explicitly deactivate entries to exclude 
them from the monitoring. To deactivate entries: 
1. Open the "Variable table" tab in the diagnostic window. 
2. Select the entries. Press the CTRL or Shift key at the same time to select 

several entries. 
3. Select the Deactivate command from the context menu.  
Result: The selected entries are identified with a cross symbol. The associated 
variables can no longer be monitored.  
To be able to monitor these variables again, you must first reactivate the entries. 
To do this, select the Reactivate command from the context menu. 
In the following example, entries no. 1 and 2 are deactivated. 

Figure 5-10 Example: Deactivating entries in the variable table 



Commissioning and online mode 

Component based Automation, Configuring Plants with SIMATIC iMap 
A5E00248797-01 5-31 

Requirement 
Your PG/PC must be connected to the plant via Ethernet in order to monitor 
variables and set online values. 

To start monitoring with the variable table: 
1. Open the "Variable table" tab in the diagnostic window. 

2. Select: 

� the Online > Variable table > Monitor all variables menu command or 
click on the "Monitor variables online" icon to monitor all the active variables, 
or 

� select the required entries and then select the command Monitor from the 
context menu to monitor just selected variables. 

Result: All or the selected entries are identified with a "Monitor" symbol (glasses) in 
the second column and the current online values of the variables are displayed in 
the "Online value" column. The online values are displayed in the defined format. 
"<Automatic>" means the default display format, e.g. decimal for I1, I2, I4, UI1, UI2, 
UI4, R4 or True/False for BOOL. 

No online values are displayed for deactivated entries. 

Variables of inaccessible devices are identified by a separate symbol (glasses with 
a cross).  

The validity of the displayed online values is represented by different colors, as 
with the online values in the plant view (see "Diagnostic information in the online 
view"). 

Example - Online variable table 
The diagram shows: 

• Variables no. 1 and 2 cannot be monitored because the associated device is 
inaccessible. 

• Variables no. 5 and 7 are deactivated. 

• All other variables are monitored. 
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To end monitoring:  
• Select the Online > Variable table > Monitor all variables menu command 

again or click on the "Monitor variables online" icon again in order to stop 
monitoring all variables.  

• Select the required entries from the variable table and then select the Stop 
Monitoring command from the context menu to end monitoring of the selected 
variables. 

To transfer control values: 
For input variables, you can enter control values to be set as online values for 
testing purposes. Online values cannot be set at outputs. 

Proceed as follows: 

1. Open the "Variable table" tab in the diagnostic window. 

2. Enter the control values in the boxes in the "Control value" column. Make sure 
that the values can be interpreted in the display format, for example, if 
hexadecimal is set for a variable in the "Format" box, then you must also enter 
the control value in hexadecimal format. 

3. Select the variables whose online values you wish to set. 

4. Select the Monitor command from the context menu to start monitoring these 
variables. 

5. Select the Transfer control value command from the context menu or click on 
the "Transfer control value" icon. 

Result: The control values are transferred to the plant and appear in the boxes in 
the "Online value" column.  

No online values are set for deactivated entries and variables of inaccessible 
devices. 

 

 Note 
If there are more variables selected than there are for transferring the control 
values, then the process will stop with an error message, and no control values will 
be transferred. 

To copy the online value of a variable: 
Select the Copy online value command from the context menu to copy the online 
value of a variable.  

Result: The online value is copied to the clipboard. 

Tips 
You can enter control values regardless of whether the monitoring of variables is 
switched on or off in the variable table. No input is possible for deactivated and 
invalid entries. 

Control values that have already been transferred are displayed in gray.  
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5.10 Online device analysis 

Content of the online device analysis 
If SIMATIC iMap is connected to the devices of the plant via Industrial Ethernet, 
you can look up specific online information about the devices for testing and 
diagnostic purposes. The online device analysis returns the following information: 

• Performance parameters for the device (see "Performance parameters of 
PROFInet devices") 

• Configuration data for the device and the associated technological function (if 
present) 

• For PROFInet devices with proxy functionality only: the configuration data for 
the coupled PROFIBUS devices (devices and technological functions). 

• Diagnostic information, e.g. error statistics and timeouts 

The online device analysis can only be run for one PROFInet device. The online 
data for the PROFIBUS devices is recorded together with the data for the 
associated PROFInet device with proxy functionality. 

Storing the online device analysis 
The information from the online device analysis is stored in HTML format in a 
separate folder. Using the Options > Customize menu command you can define a 
default path on the "Directories" tab. 

Requirement 
SIMATIC iMap must be connected to the target device via Industrial Ethernet.  

To look up the online data for a device: 
1. Highlight a device in the net view. 
2. Select the Online > Online device analysis... menu command. 
3. The IP address of the device is displayed in the "IP address" box in the "Online 

device analysis" dialog. If this is not the case, enter the IP address of the device 
to be analyzed.  

4. If necessary, click on the "Modify" button and change the path.  
5. Confirm by clicking on the "OK" button.  
Result: The current version of the online device data is stored in the folder in the 
form of several HTML files. 
 

 Note 
The information is updated for the specified IP address whenever you call the 
Online > Online device analysis...  menu command.  

You can display stored versions of the online device analysis by opening the HTML 
files directly in an HTML browser. 
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5.11 Accessing information variables 

5.11.1 Creating OPC symbol files 

OPC symbol file 
In SIMATIC iMap, you can create an OPC symbol file for the current project that 
can be analyzed using client programs on the SIMATIC NET PN OPC server. The 
OPC symbol file is created for the entire SIMATIC iMap project and is stored in any 
folder of your choice.  

Requirement 
The SIMATIC iMap project must have been generated. If the project contains 
objects that do not have the generation status "generated", you will not be able to 
create an OPC symbol file. 

To create the OPC symbol file for the project 
1. Select the  

Options > Create OPC symbol file menu command. The "Create OPC symbol 
file" dialog opens. 

2. Optional: Enter any character string in the "Prefix" box. You will need the prefix 
to provide OPC information variables with unique identification across multiple 
projects. Any changes to the prefix are stored in the project. 

3. The current path of the OPC symbol file appears in the "Save As" box. Accept 
the settings or click on the "Modify" button to change the path. You can select 
another directory, if necessary, or enter a different file name.  

Result: The OPC symbol file with the extension .sti is saved to the selected folder. 

 

 Note 
Use the Options > Customize menu command to define a directory for storing 
OPC symbol files. This directory will be suggested whenever you look up the 
storage location. 

Select the Project > Properties menu command, "Special" tab to define the OPC 
prefix.  

The created OPC symbol files can be integrated into the SIMATIC NET PN OPC 
server configuration. 
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Caution 
Network load on the Industrial Ethernet and in the devices of the plant. 

 
Additional communication functions for monitoring connectors� including via OPC 
� are performed on the Industrial Ethernet.  
You should note, however, that the network load can be affected both by the 
number of connectors to be monitored and by the frequency with which the values 
change. 

5.11.2 OPC information variables in SIMATIC iMap 

Syntax 
At the OPC interface, process variables are identified by a unique name - the OPC 
item ID. The OPC item ID is made up of the following: 
<Protocol ID>:[<Connector name>]<Variable name> 
The individual components have the following significance for PROFInet: 
• The protocol ID specifies the protocol used to access the process variable. The 

protocol ID "PN" is used for the PROFInet protocol. 
• The connector name specifies the connector or the device via which the 

variable can be reached. 
• The variable name is the symbolic name of the variable.  

Accessing variables via symbols 
In the browser (e.g. the SIMATIC NET symbol file wizard), the process variable 
symbols are displayed in the following hierarchical order: 
[<Project_prefix>] [<Chart>] <Function> <Variable> 
Where: 
 

Element Explanation 

<Project_prefix> Project-wide user-defined identification 

<Chart> Subordinate chart 

Subordinate charts are optional and may have multiple levels. 

<Function> Name of the technological function 

<Variable> Name of the input or output 

Variable types for PROFInet 
In PROFInet, we distinguish between the following three types of variable: 
• Process variables 
• System variables  
• Device-specific information variables 
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Process variables 
Process variables are assigned to the inputs and outputs of technological 
functions. The OPC item ID of a process variable has the following structure: 

PN:[aaa.bbb.ccc.ddd|<devicename>|<funcname>]<variable> 

 
Designation Explanation 

aaa.bbb.ccc.ddd • For PROFInet devices - the IP address of the device 

• For PROFIBUS devices - the IP address of the master (proxy) 

< devicename > Name of the configured device in iMap 

< funcname > Name of the technological function in iMap 

<variable> Name of the input or output of the technological function 

Access rights to process variables 
Process variables for inputs can both be written and read. 

Process variables for output can only be read. 

Example - Process variables 
Representation of process variables in the SIMATIC NET symbol file wizard 

 
Figure 5-11 Example - Process variables 
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System variables 
These information variables are located in the browser's "&System" folder. They 
apply to the entire plant. 

 
Variable icon  OPC item ID Meaning 

&localhost PN:[SYSTEM]&localhost() 
 

Designation of the host 
computer 

&version PN:[SYSTEM]&version() Version of the PROFInet 
core server 

 

Example - System variables 
Representation of system variables in the SIMATIC NET symbol file wizard 

Figure 5-12 Example - System variables 

Device-specific information variables 
These information variables are located in the "&DevicePlan" folder and are 
assigned to the individual devices.   

Variable icon OPC item ID Meaning 

&statepath PN:[aaa.bbb.ccc.ddd|<devicename>]&statepath()  Status of the connection as 
a string  

&statepathval PN:[aaa.bbb.ccc.ddd|<devicename>]&statepathval() Status of the connection as 
a value 
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&statepath() 
Returns the state of a communication link to a partner device as a string. 

Returned values: 

• DOWN - Connection not established 

• UP - Connection established 

• RECOVERY - Establishing connection 

• ESTABLISH (reserved for future upgrades) 

Data types: 

 
OLE data type Visual Basic type 

VT_BSTR STRING 

 

&statepathval() 
Returns the state of a communication link to a partner device. 

Returned values: 

1 - Connection not established 

2 - Connection established 

3 - Establishing connection 

4 (reserved for future upgrades) 

Data types: 

 
OLE data type Visual Basic type 

VT_UI1 BYTE 
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Example - Device-specific information variables 
Representation of device-specific variables in the SIMATIC NET symbol file wizard 

Figure 5-13 Example - Device-specific information variables 
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5.12 Plants with SIMATIC Devices 

5.12.1 Special features of plants with SIMATIC devices 

SIMATIC devices in SIMATIC iMap projects 
Please note the following points when you use SIMATIC devices as PROFInet 
devices in a project: 

• When you commission the plant, certain software requirements must be fulfilled, 
and certain settings must be made in STEP 7. 

• STEP 7 contains a number of options especially designed for editing PROFInet 
components of SIMATIC devices. 

• The SIMATIC iMap online view contains device-specific online and diagnostic 
functions.  

• You must configure the OPC server in order to monitor variables via OPC. 

Requirements for commissioning the plant 
• STEP 7 is needed on your PG/PC in order to: 

� Generate the project 

� Download device-specific data (programs) to the devices 

� Edit the PROFInet components in the SIMATIC iMap project using STEP 7 

� Compare the online and offline data of the programs 

• The associated optional packages for configuring and programming specific to 
the devices used must be installed. 

• SIMATIC NET Softnet IE PG is needed in order to run online functions with 
SIMATIC iMap via Ethernet � e.g. download, monitor or online-offline 
comparison.  

• The devices of the plant must have been assembled, wired, networked, and 
started up correctly. All the necessary addresses, such as the IP address, 
subnet mask, router address and PROFIBUS address, must have been 
assigned using the device-specific resources, e.g. using STEP 7 via MPI. You 
will find the necessary information in the associated product documentation. 

• To access target systems from SIMATIC iMap, configure a PG/PC and then 
assign your created system to the configured PG/PC. In this way, you can 
transfer default settings to the installed interfaces of your created system during 
the configuration process. (In this situation, interfaces are module parameter 
settings on the PG/PC). The steps are as follows: 

� Set the PG/PC interface 

� Assigning the PG/PC 
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Data storage - the STEP 7 shadow project 
When you generate a SIMATIC iMap project with PROFInet components of 
SIMATIC devices for the first time, a common STEP 7 project is formed from all the 
component projects (control units) in the shadow project. The STEP 7 shadow 
project is located in the SIMATIC iMap project directory under Step7\Shadow. It 
contains a station for each component with programmable functionality in the 
SIMATIC iMap project. PROFIBUS devices with fixed functionality are assigned to 
the station of the DP master system concerned. 

Figure 5-14 Data storage with STEP 7 projects 

All changes to PROFInet components, e.g. IP addresses or PROFIBUS addresses, 
are transferred to the STEP 7 shadow project whenever the SIMATIC iMap project 
is regenerated. 
The shadow project is automatically opened for editing in SIMATIC iMap whenever 
the Edit > Special > SIMATIC Manager menu command is called for a 
technological function or device.  

 

 Caution 
The shadow project may not be modified directly under STEP 7. 

Changes to the shadow project may lead to inconsistent data in the SIMATIC iMap 
project, preventing any further program downloads. 

Possible remedies 

• Regenerating a project 

• Edit > Re-edit component menu command from the modified shadow project 
to create a new PROFInet component 
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 Caution 
Changes that you make to the shadow project in STEP 7 are ignored when you 
generate with SIMATIC iMap, and may therefore be overwritten.  

Regenerating a project 
The Project > Generate > Control unit > Changes only menu command only 
generates the changes. If this is not possible because the S7 program or the 
hardware or network configuration contains incorrect or inconsistent data, for 
example, then the STEP 7 shadow project must be fully regenerated.  

When you select the Project > Generate > Control unit > All menu command a 
new STEP7 project is created, and all the stations of the associated component 
projects from the library are added to the library once more.  

 

 Caution 
Any changes you have made to the shadow project using STEP 7 will be 
overwritten by the newly generated shadow project. A copy is made of the old 
shadow project. You can use this to copy any changes in the new shadow project.

 

The new shadow project is always called "Shadow". An extension is appended to 
the name of the copy of the old shadow project. 

Hint: Check the consistency 
Use the Edit > Check Consistency menu command to run a consistency check 
and identify any differences between the blocks of the station in the shadow project 
and the blocks of the corresponding component project.  
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5.12.2 Using SIMATIC devices in online mode 

Special features of SIMATIC devices  
The following online functions are provided for SIMATIC devices: 

• Online/offline comparison of STEP 7 data 

• Device-specific diagnostics with STEP 7 

Online-offline comparison of the Programs 
The Online-offline comparison of the program data for SIMATIC device compares 
the blocks of the associated STEP 7 shadow project with the online blocks. The 
result of the comparison is displayed is displayed on the "Info" tab in the diagnostic 
window.  

Device-specific diagnostics 
You can call the device-specific diagnostics as follows:  

• If there is a diagnostic message for a device, you can click on the "Diagnostics" 
button in the right-hand part of the diagnostic window to call up device-specific 
diagnostics. 

• You can use the Edit > Special > menu command to call up the available 
device-specific diagnostic functions, e.g. "Module state" or "Diagnose 
hardware", in STEP 7. 

Program download 
 

 Notice 
Program downloads can only be carried out when the devices are in the STOP 
operating state. 

 

The devices must be in the STOP operating state while the program is 
downloaded. If this is not the case, the devices attempt to switch to STOP when 
one of the following menu commands is called: 

• Download all Instances > All / > Program only 

• Download selected instances > All / > Program only 

Before the program is downloaded, you are asked whether the device should be 
switched to STOP. You may also have to press the operating mode switch, and 
possibly enter a password, depending on the type of device, and the currently set 
level of protection. 

 Once the program has been downloaded to a device, you are asked whether you 
wish to switch the device to RUN. If you click on "Yes" to confirm, this occurs 
automatically. If you click on the "No" button, the device remains set to STOP, and 
can subsequently be switched to RUN.  
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Hint: Permanently storing the downloaded data 

With some devices in SIMATIC iMap, once you have downloaded the program you 
must call the Special > Copy RAM to ROM  menu command in order to transfer 
the data to the ROM area of a device. This means that the data is retained even 
after the power is switched off. 

PROFIBUS device inputs 
When a PROFInet device acting as a PROFIBUS master is switched to the STOP 
operating state, the inputs of the technological functions of the associated 
PROFIBUS devices are set to zero (safe state).  

5.12.3 Editing instances with STEP 7 

Introduction 
If you have created a PROFInet component using STEP 7, you can call certain 
STEP 7 applications from SIMATIC iMap, e.g. SIMATIC Manager or HW Config, in 
order to modify the S7 program or parameter settings for a module. In this case, 
you will edit the STEP 7 shadow project that belongs to the instance of the 
PROFInet component.  

 

 Caution 
When you edit the STEP 7 shadow project, you must make sure that no 
inconsistencies occur in it since this can lead to inconsistencies in the 
SIMATIC iMap project and to communication faults in the plant. 

 

In SIMATIC iMap you can edit PROFInet components using STEP 7 in the 
following ways: 

• Modify a technological function in the SIMATIC iMap project. 

• Modify a PROFInet device in the SIMATIC iMap project. 

The available editing functions are device-specific, i.e. different menu commands 
can be called for each type of device. The following descriptions contain the 
generally accessible editing functions.  
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Special editing functions for SIMATIC devices 

Table 5-4 Editing technological functions in the plant view 

Edit > Special > menu 
command 

Meaning 

SIMATIC Manager Opens the shadow project in SIMATIC Manager. 

Monitor variable Opens variable table VAT1 for the station in the shadow 
project. You can enter the variables of the technological 
function (from the interface DB) to be monitored in the 
variable table, for example. If a variable table called VAT1 
already existed when you created the PROFInet component, 
it is opened at the first call, otherwise the VAT1 table in the 
shadow project is originally empty.  

Program Opens the program folder for the associated module in 
SIMATIC Manager. You can open the blocks, sources and 
symbol table for editing. 

Compare blocks Runs an online-offline comparison of the program blocks, i.e. 
compares the blocks in the target system (online) with the 
blocks in the SIMATIC iMap shadow project (offline). 

 

Table 5-5 Editing devices in the net view 

Edit > Special > menu 
command 

Meaning 

SIMATIC Manager Opens the shadow project in SIMATIC Manager. 

Configuration Opens the station's hardware configuration (offline, on the 
PC/PG). 

Network configuration Opens the network configuration (Netpro) for the station 

Module state Displays the current state of the module. The "Module State" 
tab opens in the online view. 

Diagnose hardware Opens the hardware setup for the station that can be 
accessed online in diagnostic mode. 

Clear / Reset Clears / Resets the device. 

Operating state  Displays the current operating state of the module. You can 
then modify the module's operating state in the "Operating 
state" dialog. 

Assigning the PG/PC Opens the "Assign PG/PC" dialog box. 

Copy RAM to ROM Copies the content of the RAM memory of the current 
module to the ROM area (only for modules that support this 
functionality). 

Download user program to 
memory card 

Downloads the generated user program to the CPU's 
memory card (only for modules that support a memory card). 

Set Time of Day Allows you to set the time on the module. 
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Requirements 
The following software must be installed on your computer in order to edit 
PROFInet components using STEP 7: 

• STEP 7 basic package with the necessary optional packages 

• SIMATIC iMap STEP 7 Add-on 

The project must have been saved and generated in SIMATIC iMap (Project > 
Generate > menu command). 

To edit a technological function or device 
1. Select the technological function or device in the SIMATIC iMap project. 

2. Select Edit > Special >from the context menu using one of the available 
commands. 

3. Save any changes and close STEP 7. 

4. Select the device from the net view. 

5. Select the menu command Download selected instances > Program only 
menu command to download the program to the target system. 

 

 Note 
If you modify the interface DB and download it to the device from STEP 7, you 
must make sure that all associated PROFInet blocks with the attribute CBA_... are 
downloaded as well, otherwise run-time errors may occur in the program. 

 

 Caution 
The shadow project is overwritten when you regenerate the SIMATIC iMap project 
using the Project > Generate > Control unit > All menu command. A copy of the 
previous shadow project is saved in the same directory. You can use this copy to 
update any changes that you made in the shadow project using special editing 
functions. 

Tips 
Re-edit PROFInet component 

To ensure that you do not lose changes you have made to the shadow project, we 
recommend that you create a copy of the component project using the Edit > Re-
edit component menu command, and then accept the changes in this copy and 
create a new version of the PROFInet component. 

Program download from STEP 7 

Alternatively, you can run the program download after a special editing function 
from STEP 7. This is a good idea, particularly if you have only modified blocks, for 
which you do not have to switch the device to STOP. 
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5.12.4 Set the PG/PC interface 

Application 
You must establish a connection from STEP 7 to the Ethernet in order to download 
programs or use certain online functions on the SIMATIC devices in the plant. In 
STEP 7, you must set up the PG-PC interface as follows: 

• To TCP/IP if all remote devices in the plant can be accessed via Ethernet or 

• To "PC internal" (local computer) if a WinLC PN is installed there. 

In this way you can access all the SIMATIC devices, whether they are on the 
Ethernet or PROFIBUS or are on a local PC/PG, e.g. a WinLC PN.  

Setting the PG/PC interface to TCP/IP 
Proceed as follows: 

1. Select Start > SIMATIC > STEP 7 > Set PG-PC interface. 

2. On the "Access path" tab in the "Set PG-PC interface� dialog, select  
S7ONLINE (STEP 7) from the "Application access point" box. 

3. In the "Interface parameter settings used" box, select "TCP/IP..." with the 
associated network adapter.  

4. Click on "OK" to confirm your settings. 

 
Figure 5-15 Set the PG/PC Interface to TCP/IP 
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Setting the PG/PC interface to local computer 
If a WinLC PN representing part of the SIMATIC iMap project is installed on the 
local computer, this WinLC PN takes over communication with the PROFInet 
communication partners. The procedure is as follows: 

1. Select Start > SIMATIC > STEP 7 > Set PG-PC interface. 

2. On the "Access path" tab in the "Set PG-PC interface� dialog, select  
S7ONLINE (STEP 7) from the "Application access point" box. 

3. Select "PC internal (local) from the "Interface parameters settings used" box.  

4. Click on "OK" to confirm your settings. 

 
Figure 5-16 Setting the PG/PC interface to local computer 
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5.12.5 Assigning the PG/PC 

Note 
The PG/PC assignment in SIMATIC iMap is automatically performed during the 
initial generation and anytime the project is newly generated. In special cases it 
may not be possible to automatically assign the PG/PC, for example: 

• When several network cards are installed in the PG/PC or  

• When the PG/PC interface S7ONLINE (STEP 7) is not set to TCP/IP 

In such situations an error is reported during generation and you must perform the 
PG/PC assignment as described in the following. 

The PG/PC assignment is not necessary when you are using a local WinLC PN 
which contains a network card in its configuration. 

How to assign the PG/PC interface to the SIMATIC iMap project 
 

Task Procedure 

1. Open the SIMATIC iMap project. Select any device from the SIMATIC iMap net view, then 
select Special > Assign PG/PC from the context menu. This is necessary to be able to 
perform the program download to the intelligent PROFIBUS devices. 

2. In the "Interfaces" tab of the "PG/PC Interface" dialog, press the "New" button and select 
"Industrial Ethernet" from the list. 

 
Click on the "OK" button to confirm your entry. 
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Task Procedure 
3. In the "Properties - Ethernet Interface" dialog, enter the IP address and the subnet mask of the 

local computer and select the Ethernet subnet. 

 

 
4. Click on the "OK" button to confirm your entry. Result: The newly configured interface is 

displayed in the "Interfaces" tab. 
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Task Procedure 
5. In the "Assignment" tab, mark the Ethernet interface you have just configured in the 

"Configured interfaces:" selection field below "Not assigned". In the "Interface parameter 
settings on the PG/PC:" select  

TCP/IP -> <network card used> 
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Task Procedure 
6. Confirm by clicking on the "Assign" button. 

Result: The assigned interface is displayed in the "Assigned" field. 

Activate the option "S7ONLINE access". 

The assignment becomes effective by clicking on "OK". 
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5.12.6 Set up OPC server 

OPC symbol file 
Create the OPC symbol file for the plant in SIMATIC iMap using the Options > 
Create OPC symbol file  menu command. The following OPC symbol files are 
created and are stored in a directory of your choice: 

• _TAGFILE_.SSD  

• _TAGFILE_.WSD  

Setting up the OPC server  
To set up the OPC server: 

1. Run the following command: Start > SIMATIC > SIMATIC NET > Settings > 
Set PC station. The configuration console opens. This is used to make your 
new OPC symbol file known to a SIMATIC NET OPC server. 

2. In the "Structure" window, open the "Applications > OPC settings" folder.  

3. Open the OPC protocol selection dialog box and select the following protocols:. 

� PROFInet � always 

� S7 � for non-connectable connectors of programmable PROFIBUS devices 
(intelligent DP slaves) only. The non-connectable connectors are highlighted 
in the interface DB with the attribute CBA_transfer_type = s7extended.  

4. Click on the "Accept" button. 

5. Open the "Symbols" folder. Select the "Use symbol file" option and enter the 
path of the _TAGFILE_.SSD symbol file under "File name" (see above).  

Click on the "Browse" button to search for the file. 

6. Click on the "Extended symbols" button and select the module for the TCP/IP 
protocol on your PG/PC from the "PROFInet" box. 

7. Click on the "Accept" button. 

The OPC server is now set up on your PG/PC, and you can visualize process data 
with reference to the OPC symbol data using an OPC client such as the OPC 
Scout. 
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Special PROFInet components 6
6.1 Special PROFInet components - Overview 

PROFInet component types 
The current version of SIMATIC iMap supports the following PROFInet component 
types: 

• Standard PROFInet components � as described above 

• Singleton components  

In SIMATIC iMap, the device-specific configuration and programming data for 
these PROFInet component is held and edited in the STEP 7 basic project, 
rather than in the common shadow project. This component type allows you to 
incorporate hardware configurations with SIMATIC devices that were previously 
not supported into PROFInet communication. 

• PROFInet components with HMI units � this component type is used to 
incorporate special HMI devices into the PROFInet communication. You will 
also need WinCC Flexible V1.0  in order to create these PROFInet components 
and edit them in SIMATIC iMap. 

The special features of working with these special component types are described 
below. 
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6.2 Singleton components 

6.2.1 Properties of singleton components 

What are singleton components? 
Singleton components are PROFInet components for which the device-specific 
data is stored and handled separately. The device-specific configuration 
information and program data is located in the STEP 7 basic project for the 
PROFInet component, rather than in the common shadow project. 

Advantages in use 
The use of singleton components has the following advantages: 

• Special hardware configurations with SIMATIC device that were not supported 
in PROFInet components in the past can now be incorporated into PROFInet 
communication as singleton components. 

• The device-specific configuration and program data is stored separately, so 
singleton components in SIMATIC iMap are excluded from certain time-
consuming functions such as generation or program downloads, and thus do 
not affect the processing time of the overall project. 

• Singleton components may have default names and addresses. Thus, these 
properties do not have to be configured for instances of singleton components 
in SIMATIC iMap. 

Rule 
Singleton components can only be created for PROFInet devices without proxy 
functionality. Thus, singleton components have only one bus connector on the 
Industrial Ethernet. 

Special hardware configurations 
The singleton concept allows previously unsupported hardware configurations with 
SIMATIC devices to be incorporated into PROFInet communication, such as: 

• S7-400 automation systems 

• Fail-safe systems � Distributed Safety � S7-300F 

• Micromaster-type drives 

• Integration of process diagnostics 

• Functional modules (FM) 

• Integration of PROFInet I/O 
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6.2.2 Using singleton components in the SIMATIC iMap project 

Use in the SIMATIC iMap project  
You can insert singleton components into a SIMATIC iMap project one or more 
times depending on the project settings: 

To set the project properties: 

Select the Project > Properties menu command and, in the "Use of singletons" 
box on the "Special" tab, select the 

• Once option if you only want one instance per project, or 

• Multiple option if several instances per project are to be permitted. 

Editing in SIMATIC iMap 
In SIMATIC iMap, you can carry out all the same actions on singleton components 
as on standard components, with the following exceptions: 

• Changing the properties of the instance when more than one instance is 
permitted in the SIMATIC iMap project. If only one instance is permitted in the 
project, you cannot change the name and address(es) of the instance. 

• Generating and downloading the program  

Instances of singleton components are excluded from the generation of the 
SIMATIC iMap project (Project > Generate > menu command) and from the 
program download (Online > Download... > All/Program Only menu 
command).  

• Editing in the vendor-specific programming and configuration tool (see below). 

 

 Note 
If an action is not supported for singleton components, the corresponding menu 
commands are not available (grayed out). Otherwise a message will appear in the 
information window or in a separate message window. 

Modifying properties 
The following properties of the instance cannot be modified for singleton 
components that may only have one instance in a SIMATIC iMap project: 

• Name of the technological function 

• Name of the device  

• IP address and subnet mask 

For the instance, the properties are taken from the basic project of the singleton 
component. To modify these properties, you will have to recreate the singleton 
component and insert it into the SIMATIC iMap project, e.g. by replacing the old 
instance. 
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Editing in the vendor-specific tool 
Use the Edit > Special > menu command to directly call up the vendor-specific 
configuration and programming tool, e.g.SIMATIC Manager, from SIMATIC iMap. 
Some functions, such as "Diagnose hardware", are not available using the Edit > 
Special > command. These have to be called up from inside the tool. 

Notes on editing with STEP 7 
The following actions must be carried out directly in the STEP 7 basic project for 
the singleton component: 

• Open the STEP 7 basic project � using the File > Open menu command in 
SIMATIC Manager. 

• Modify the hardware configuration � in HW Config 

• Modify the S7 program � in the relevant block editor. 

• Compile configuration information � in HW Config using the Station > Save 
and Compile menu command. 

• Download the program � in SIMATIC Manager using the  Target system > 
Download station to PG menu command. 

• Look up device-specific diagnostic information � in SIMATIC Manager using the 
Target system > Diagnostics/Settings > menu command. 

 

 Note 
Notes on the program download 

When you create the singleton component from the basic project in STEP 7, the 
system data blocks (SDB) for PROFInet communication are created as well. 

Once you have created the singleton components, you must download the blocks 
from the program folder to the device. In SIMATIC Manager, this is done using the 
Target system > Download station to PG menu command. 
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6.3 PROFInet components with HMI units 

This section provides an overview of the use of PROFInet components with HMI 
units in SIMATIC iMap. A detailed description can be found in the user 
documentation for WinCC Flexible V1.0.  

Requirement 
WinCC Flexible is needed in order to create, configure, generate and download 
PROFInet components with HMI units. 

To create:  
PROFInet components with HMI units are created using the WinCC Flexible 
Component Merger function. 

Use in SIMATIC iMap 
PROFInet components with HMI units are used just like standard components in 
SIMATIC iMap. They first have to be imported into a SIMATIC iMap library, and 
can then be inserted into projects.  
The HMI units of a PROFInet component are handled in a special way in 
SIMATIC iMap: 
• Generate � using the Project > Generate > HMI units menu command. 
• Edit � using the Edit > Special menu command. 

Representation of HMI units  
The properties of the PROFInet component in the library will show whether a 
PROFInet component has HMI units. The HMI parts are listed on the tab of the 
"Properties" dialog and on the "HMI" tab in the preview window. 

 

The HMI units of the instances are represented in the project tree and in the project 
view (see example in the diagram below). 

Figure 6-1 Representation of the HMI units in the project view and project tree 
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To generate the HMI units of the project: 
To be able to download the configuration data for the HMI units to the target 
system, this data must first be generated.  

• Changes to the HMI units are generated using the Generate > HMI units > 
Changes only menu command.  

• The HMI units of all instances are generated using the Generate > HMI units > 
All menu command. 

The generated data is stored in a separate shadow project. 

It is then possible to download the configured HMI units. 

 

 Note 
The link to WinCC Flexible is needed in order to generate and download the 
configuration data for the HMI units in SIMATIC iMap. 

6.4 Off-the-shelf PROFInet components 

6.4.1 IE/PB Link, network transition Industrial Ethernet - PROFIBUS DP 

Off-the-shelf PROFInet components 
SIMATIC iMap is supplied with off-the-shelf PROFInet components for the IE/PB 
Link for different transmission speeds. 

The off-the-shelf PROFInet components are located in the \iMap\components 
directory. You will have to import them into a SIMATIC iMap library (Library > 
Import Component menu command) before they can be used in SIMATIC iMap. 

Application 
The IE/PB Link is a network transition that interconnects the two types of network: 
Industrial Ethernet (factory level) and PROFIBUS (cell level). 

Function in the PROFInet environment 
IE/PB Link is a PROFInet device, and is represented accordingly in the SIMATIC 
iMap net view. 

The IE/PB Link acts as a DP master on the PROFIBUS interface. The IE/PB Link 
provides the connection to coupled PROFIBUS devices for the PROFInet devices 
connected to the Ethernet. For the coupled PROFIBUS devices, the IE/PB-Link is a 
DP master with proxy functionality. 
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Representation in SIMATIC iMap 
The PROFInet component of the IE/PB Link has fixed functionality, but has no 
technological function. It is supplied ready for use in the SIMATIC iMap system 
library. It is not necessary to create a component in STEP 7 for the IE/PB Link. 

• Net view in SIMATIC iMap  

In the net view, the IE/PB Link is represented as a component that links the 
Ethernet and PROFIBUS. The IE/PB Link can be selected and configured from 
this view. 

• Plant view in SIMATIC iMap  

The IE/PB Link is not shown in the plant view. 

Bus ports 
The PROFInet component of the IE/PB Link has two bus ports: 

• A connector to PROFIBUS as the DP master and  

• A connector to the Industrial Ethernet 

 
Figure 6-2 Bus ports of the IE/PB Link 

Special features  
• Range of functions as a DP master  

The IE/PB Link supports operation with DP standard slaves (DP V0). Acyclical 
services (reading and writing records) are not supported. 

• Substitute values for DP slaves under PROFInet  

When it acts as a DP master under PROFInet, the IE/PB Link is configured to 
apply substitute values. 

If the IE/PB Link detects that a connected (interconnected in PROFInet) DP 
slave has failed, it sets the inputs interconnected with this DP slave to the 
substitute value "0". 

Lifestate monitoring allows this PROFInet component to detect if the input 
values supplied are substitute values. 
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Example 

Table 6-1 PROFInet component of the IE/PB Link, representation in SIMATIC iMap 

Technological function PROFInet device 

None 
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Appendix 7
7.1 Menu commands 

Overview 
Menu commands can be used to create and edit selected objects (e.g.charts, 
functions and libraries). They are accessed via the menu bar, in the context menu 
or as an icon on the toolbar.  

The menus on the menu bar of the SIMATIC iMap user interface are explained 
briefly below. This description may differ slightly from the actual application, but 
any differences will be updated in the next version. 

Project menu 
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Menu command Description 

New Creates a new project. Before it is opened, the currently open 
project is closed. 

Open... Opens an existing project. Before a new project is opened, 
the currently open project is automatically closed. 

Save Saves the current project. 

Save As... Saves the current project under a new name. 

Archive... Archives a project. 

Retrieve... Retrieves an archived project. 

Import... Imports from a project description into a new project. 

Generate > Control unit > 
Changes only 

Saves the current project and generates the changes to the 
control units, i.e. the modified data is synchronized with the 
shadow project.  

This is required in order to use the online functionality 
(download and diagnostics). 

Generate > Control unit > All Saves the current project and generates the control units from 
scratch, i.e. the shadow project is recreated from the 
PROFInet components in the library. 

Generate > HMI units > Changes 
only 

Saves the current project and generates the changes to the 
HMI units.  

Generate > HMI units > 
All 

Saves the current project and generates HMI units from 
scratch. 

Page setup... Defines the page margins and other layout options. 

Headers and footers... Displays the settings for the header and footer of a printout. 

Print > Active window Prints the current plant or net view. 

Print > All charts Prints the net view and all charts in the plant view. 

Documentation Creates the documentation for the current project. 

Properties... Opens a dialog box containing the individual parts of the 
project. You can enter a password in order to protect the 
project against unauthorized access. 

Recent projects  Lists the recently opened projects.  

Exit Exits SIMATIC iMap. If the edited project has not yet been 
saved, you are prompted to save it. 
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Edit menu 
 

 
 

Menu command Description 

Cut Removes the highlighted objects and saves them to the 
clipboard. 

Copy Copies the highlighted objects to the clipboard. 

Paste Inserts the clipboard contents 

Delete Removes the highlighted objects. 

Select all Highlights all the objects in the current window.  

Undo selection Deselects the selected objects.  

Highlight in all windows Transfers the current selection to all other windows. 

Open selected chart Opens the selected chart. 

Open superordinate chart Opens the chart one level up. 

Go to > Used to navigate in the various windows. 

Find... Searches for components, instances, devices and functions 
containing the search text. 

Replace... Replaces selected instances with the instances of a target 
component. 
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Menu command Description 
Plant view > In chart interface Transfers the selected connectors to the chart interface. 

Plant view > Interconnect 
constants 

Sets a constant value at the input. 

Plant view > Move 
interconnections 

Moves the interconnections of the technological function. 

Plant view > Interconnect 
externally 

Interconnects the input with an external output. 

Plant view > Interconnections Selects all the interconnections in the open chart. 

Variable table > Deactivate Deactivates monitoring of the selected variables. 

Variable table > Reactivate Reactivates monitoring of the selected variables. 

Variable table > Complete 
structure 

Lists all the structure elements up to the selected connector. 

Information window > Copy all Copies all the messages in text format to the clipboard. 

Information window > Delete all Deletes all the messages in the information window. 

Special > Calls up functions or dialogs associated with the vendor-
specific programming / configuration tool, e.g. SIMATIC 
Manager, module status. 

Properties... Displays the properties of the selected object. 

Check consistency > All 
instances/Selected instances 

Compares the shadow project and component project for all 
or just the selected instances. 

Verify utilization > Standard Checks the configuration with respect to the performance 
requirements of the selected devices  

Verify utilization > Detailed Compares the configuration performance requirements with 
the performance parameters of the selected devices. 

Re-edit component... Defines where the copy of the component project is to be 
stored. Opens SIMATIC Manager in order to re-edit the 
PROFInet component. 
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View menu 
 

 
 

Menu commands Description 

Toolbars Shows or hides the toolbar.  

Status bar Shows or hides the status bar. 

Project tree Shows/hides the window with the plant and net tree. 

Diagnostic window Shows or hides the diagnostic window. 

Information window Shows or hides the information window.  

Library window Shows or hides the library window. 

Preview window Shows or hides the component preview window.  

Plant view >Page margins Shows or hides the page margins for printing in the plant or 
net view. 

Plant view > Dot screen Shows or hides the dot screen in the plant view. 

Plant view > Recalculate 
interconnection lines 

Refreshes the interconnection lines. 

Plant view > Display 
interconnection lines 

Shows or hides the interconnection lines. 

Project tree > Plant tree > Displays additional information, such as the associated 
devices, component type or HMI modules. 

Project tree > Net tree > Displays additional information, such as the associated 
functions, component type, HMI modules or bus system. 

Project tree > Show levels Displays all the levels beneath the selected object. 

Project tree > Hide levels Hides all the levels beneath the selected object. 

Project view > Show instances Shows all the instances of the component. 

Project view > Hide instances Hides all the instances of the components. 

Variable table > Shows / hides the columns in the variable table. 

Zoom > Allows you to change the size of the view of the projects in the 
plant view, project view or net view. 
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Insert menu 
 

 
 

Menu commands Description 

New chart Inserts a new chart into the project and moves selected 
objects into this chart, if necessary. 

New Ethernet node Inserts a new Ethernet node. 

Online menu 
 

 
 

Menu commands Description 

Monitor Activates / deactivates the online connection between 
SIMATIC iMap and the devices of the plant. Activating the 
online connection does not result in a download. �Monitor� 
must be activated for the diagnostics. 

Download all Instances > 
All 

Downloads the interconnections and programs to all the 
devices of the plant.  

Download all Instances > 
Program only 

Downloads the programs to all the devices of the plant. 

Download all Instances > 
Interconnections only 

Downloads the interconnections to all the devices of the plant. 

Download selected instances > 
All 

Downloads the programs and interconnections to the selected 
devices. 

Download selected instances > 
Program only 

Downloads only the programs to the selected devices. 

Download selected instances > 
Interconnections only 

Downloads only the interconnections to the selected devices. 



Appendix 

Component based Automation, Configuring Plants with SIMATIC iMap 
A5E00248797-01 7-7 

Menu commands Description 
Online / Offline comparison > 
All 

Runs an online-offline comparison for the programs and 
interconnections of the selected devices. 

The result appears in the information window. 

Online / Offline comparison > 
Program only 

Runs an online-offline comparison for the programs of the 
selected objects.  

The result appears in the information window. 

Online / Offline comparison > 
Interconnections only 

Runs an online-offline comparison for the interconnections of 
the selected objects.  

The result appears in the information window. 

Check accessibility Checks the online accessiblity of the associated devices. 

The result appears in the information window. 

Online device analysis Returns online device information for an IP address as an 
HTML file. 

Variable table > Monitor all 
variables 

Activates online monitoring with the variable table.  

The result appears in the diagnostic window. 

Variable table > Monitor selected 
variables 

Activates online monitoring of the selected variables.  

The result appears in the diagnostic window. 

Variable table > Stop monitoring 
selected variables 

Deactivates online monitoring of the selected variables. 

Variable table > 
Transfer selected control values 

Transfers the control values of the selected variables to the 
plant. 

Variable table > 
Copy online value 

Copies the online value of the select variables to the 
clipboard.  

The value can be entered as a control value, for example, via 
the Paste context menu. 

Plant view > 
Display online values 

Shows / hides the current values of the selected connectors. 

Plant view > Set online values Changes the current value of the selected connector. 
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Library menu 
 

 
  

Menu commands Description 

New... Opens a dialog box for Creating a new library, e.g. for a new 
project or new operations.  

Open... Opens a dialog box for selecting an existing library. 

Close Closes the current library. 

Archive... Opens a dialog box for archiving the current library and 
specifying the path. 

Retrieve... Opens a dialog box for selecting a library from an archive. 

Import components... Imports an existing PROFInet component from a directory to a 
library. 

View > Changes the view of the PROFInet components in the 
selected library. 

Auto arrange Automatically arranges the representation in the library 
window. 

Properties... Opens the Properties dialog box for the selected library. 

Recent libraries Lists the most recently opened libraries.  

 

Options menu 
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Menu commands Description 

Customize ... Modifies the general settings in SIMATIC iMap. 

Language > Changes the language of the SIMATIC iMap user interface. 

Create OPC symbol file... Creates an OPC symbol file for the entire project.  

Import variable table... Imports a saved variable table into the diagnostic window. 

Export variable table... Saves a variable table as a cbv file. 

Tools... Opens the programs defined under �Customize�. 

? menu 
 

 
 

Menu commands Description 

Help F1 Opens the online help for the current window 

Help topics Opens the online help for "Component based Automation and 
SIMATIC iMap". 

Getting Started  Opens the Introduction to SIMATIC iMap. 

About Provides information on the current software version and 
copyright. 
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7.2 Toolbar 

Icons on the toolbar 
The icons on the toolbar are specially designed for working with SIMATIC iMap. 
They correspond to the following menu commands: 

Table 7-1 Icons on the SIMATIC iMap toolbar 

Icon  Description Menu command 

 
New project Project > New 

 
Open Project Project > Open... 

 
Saving a Project Project > Save 

 
Generating the Project Project > Generate >Control unit > 

Changes only 

 
Print Project > Print > All Charts 

 
Cut Edit > Cut 

 
Copy Edit > Copy 

 
Paste Edit > Paste 

 
Open Chart One Level 
Up 

Edit > Open Chart One Level Up 

 
Insert chart Insert > New chart  

 
Interconnection lines 
on/off 

View > Plant view > Display 
Interconnection Lines 

 
Online connection Online > Monitor 

 
Monitor variables online Online > Variable table > Monitor all 

variables 

 
Transfer control value Online > Variable table > Transfer control 

value 

 
Open Help Help > Help Topics 

 
Project Window  View > Project window. 

 
Diagnostic window  View > Diagnostic window 

 
Information window  View > Information window 

 
Library window  View > Library window 

 
Preview window  View > Preview window 

 
Zoom in  View > Zoom > Zoom in 

 
Zoom out  View > Zoom > Zoom out 

 
Entire content  View > Zoom > Entire content 

 
Normal  View > Zoom > 100% 
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7.3 Actions 

Which actions do you want to carry out? 
The following table lists, in alphabetical order, the actions that you can carry out 
with SIMATIC iMap and describes where and how these actions can be used.  

As a rule, the objects to be processed must be selected first. 

Table 7-2 Actions in SIMATIC iMap 

Which object? Which action? In which window? How? 

Addresses Assign Plant view, Net view, 
Project view, Project tree 

Edit > Properties > Address 
tab 

Utilization Verify Net view Edit > Verify utilization 

Library Create Library Library > New  

 Archive  Library > Archive 

 Retrieve  Library > Retrieve 

 Close Library Library > Close 

 Open Library Library > Open 

Library window Display SIMATIC iMap View > Library window. 

Diagnostic window Display SIMATIC iMap View > Diagnostic window 

Download Run SIMATIC iMap Online > Download... 

Documentation for 
PROFInet components 

Open Preview window Info tab > Documentation 

Documentation for 
SIMATIC iMap 

Open Desktop Start / Programs / 
Component based Automation 
/ Documentation 

Inputs / Outputs Interconnect  Plant view Click on the input that you 
wish to interconnect, and then 
on the corresponding output. 

Properties Display / modify Plant view, Net view, 
Project view, Project tree 

Edit > Properties... 

Project > Properties 

Error Diagnose Diagnostic window Online > Monitor 

Device Rename All views Edit > Properties > Address 
tab 

Information window Display  View > Information window 

Instance Replace Plant view, Net view, 
Project view, Project tree 

Edit > Replace 

IP address Assign Plant view, Net view, 
Project view, Project tree  

Edit > Properties > Address 
tab 

Consistency  Verify Plant view, Net view Edit > Check Consistency 

Chart Print Net view Project > Print 

 Zoom Net view View > Zoom 

Subordinate chart Create Plant view Insert > New chart 

Online device analysis Run SIMATIC iMap Online > Online device 
analysis 



Appendix 

 Component based Automation, Configuring Plants with SIMATIC iMap 
7-12 A5E00248797-01 

Which object? Which action? In which window? How? 
Online value Display Plant view Online > Monitor 

Online > Plant view > Display 
Online Values 

 Set Plant view / Variable table Select connector 

Online > Plant view > Set 
Online Values 

 Copy Variable table Online > Variable table > 
Copy online value 

 Insert Variable table Edit > Paste 

PROFIBUS address Assign Plant view, Net view, 
Project view, Project tree 

Edit > Properties > Address 
tab 

PROFInet component Import into a 
library 

Library Library > Import components 

 Paste Into 
Project 

Library Drag&Drop  

Edit > Paste 

 Create SIMATIC Manager Edit > Create PROFInet 
component 

 Rename Library Not possible. 

 Re-edit Library, Project view Edit > Re-edit component... 

 Move From library to library Drag&Drop  

Edit > Copy / Edit > Paste 

Project Archive SIMATIC iMap  Project > Archive 

 Retrieve  Project > Retrieve 

 Document  Project > Document 

 Print  Project > Print 

(Keyboard: Ctrl + P) 

 Generate  Project > Generate 

 Open  Project > Open 

(Keyboard: Ctrl + O) 

 Save  Project > Save /  
Project > Save As  

(Keyboard: Ctrl + S) 

 Delete Windows Explorer Entf/Del key 

Project tree Display SIMATIC iMap View > Project tree 

Technological function Rename All views Edit > Properties > Address 
tab 

 Variable table Display SIMATIC iMap View > Diagnostic window > 
Variable table tab 

 Monitor SIMATIC iMap Online > Variable table > 
Monitor variables 

 Import / Export SIMATIC iMap Options > Import / Export 
variable table 

Interconnections Create Plant view Click on the input that you 
wish to interconnect, and then 
on the corresponding output. 



Appendix 

Component based Automation, Configuring Plants with SIMATIC iMap 
A5E00248797-01 7-13 

Which object? Which action? In which window? How? 
 Delete Plant view Highlight the line and press 

the Del key. 

 Move Plant view Select connector  

Edit > Plant view > Move 
Interconnections  

Left-click on the new 
connector 

Preview window Display SIMATIC iMap If library is open: View > 
Preview window 

Tools Insert SIMATIC iMap Options > Customize > Tools 
tab 

 Use SIMATIC iMap Options > Tools... 

7.4 Naming conventions 

7.4.1 Naming conventions in SIMATIC iMap 

The following rules must be followed when you assign names:  

File names and paths 
• A file name must not contain any of the following characters: 

\ / :�?� * < > | 
• A path name must not contain any of the following characters: 

/ :�?� * < > | 

Object names 
The following rules apply to the names of SIMATIC iMap projects, libraries, 

technological functions, devices and charts. 
• The name may not be left blank. 
• Illegal characters  
The name must not contain characters with the following ISO 8859-1 codes: 0 to 

31, 33, 34, 38, 42 to 44, 46, 47, 58 to 63, 91 to 94, 96, 124, 127 to 159, 180.  
The characters that are not permitted are thus: 
� all non-printing characters (with ISO 8859-1 codes 0 to 31, 127 to 159) 
� AND !� � & * + � . , / : ; < = > ? [ \ ] ^ ` | ´  
•  Spaces are not permitted at the start and end of the name. 
• Name length: Object names must not in exceed 32 characters in length in 

SIMATIC iMap.  
• The names of functions, devices and subordinate charts must be unique within 

a SIMATIC iMap project. 
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7.4.2 Naming conventions for PROFInet components 

The following rules must be followed when you assign names:  

File names and paths 
• A file name must not contain any of the following characters: 

\ / :�?� * < > | 

• A path name must not contain any of the following characters: 
/ :�?� * < > | 

Names of PROFInet components 
• The name may not be left blank. 

• Illegal characters  

The name must not contain characters with the following ISO 8859-1 codes: 0 
to 31, 33, 34, 38, 42 to 44, 46, 47, 58 to 63, 91 to 94, 96, 124, 127 to 159, 180.  

The characters that are not permitted are thus: 

� all non-printing characters (with ISO 8859-1 codes 0 to 31, 127 to 159) 

� AND !� � & * + � . , / : ; < = > ? [ \ ] ^ ` | ´  

•  Spaces are not permitted at the start and end of the name. 

• The first character must not be an underscore. 

• The name of a PROFInet component created in STEP 7 must not be more than 
24 characters long. 

Names of connectors  
• The names of connectors may only contain the following characters (ISO 

10646-1):  

Letters A to Z and a to z, digits 0 to 9, and the underscore character "_". 

• The first characters of a connector name must be a letter (not underscore or a 
number). 

• The name of a connector must not exceed 24 characters in length. 
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7.5 Data Types of Connectors 

Data types, data lengths and ranges of values for connectors 
A PROFInet data type conforming to Microsoft OLE 2.0 is assigned to every S7 
data type . The following table shows the assignment, data lengths and ranges of 
values.  

Table 7-3 Data types, data lengths and ranges of values for connectors 

PROFInet 
data type 

S7 data type Data length in bytes Range of values 

BOOL BOOL  2  TRUE / FALSE 

I1 CHAR 1  -128 to +127 

UI1 BYTE 1  0 to 255 

R4 REAL 4  3.4E +/- 38 

I2 INT 2  -32,768 to +32,767 

UI2 WORD 2  0 to 65,535 

I4 DINT 4  - 2.147.483.648 to 
+2.147.483.647 

UI4 DWORD 4  0 to 4.294.967.295 

DATE DT 
(DATE_AND_TIME) 

8  01.01.1900 00:00:00 to 
31.12.9999 23:59:59*) 

BSTR STRING 4 + 2 * number of 
characters 

 Character string 

ARRAY ARRAY Number * data type 
length 

One-dimensional, from 
simple data types**) 

STRUCT STRUCT Sum of the data type 
lengths 

Made up from simple data 
types**) 

*) There may be restrictions in the range of values, depending on the type of device. For 
example, for SIMATIC devices this would be: 01.01.1990 00:00:00 to 31.12.2089 23:59:59.  

**) Simple data types are all the listed data types, apart from ARRAY and STRUCT. The 
maximum length depends on the amount of memory in the device.  

Data types supported in PROFInet runtime version V2.0.0.0 or later 
The following data types are supported by PROFInet devices from runtime version 
V2.0.0.0 onwards: 

• Data type STRUCT with all simple data types, including STRING  

• Data type ARRAY with the data types BOOL, REAL, DATE_AND_TIME, 
STRING 

Earlier runtime versions do not support these data types. 
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7.6 File types 

Overview of the file types in SIMATIC iMap 
The following table shows the file name extensions for the file types used in 
SIMATIC iMap. 

File type Extensi
on 

Created with the menu command...* In ... 

Project CBP Project > Save or  

Project > Save As 

the project folder of the 
same name 

Library CBL Library > New or  

Library > Create New Library 

the library folder of the 
same name 

Project library CPL is automatically created and opened with 
the project 

the \projlib subfolder of the 
project folder 

Archived project ARP Project > Archive any folder in the file system 

Archived library ARL Library > Archive any folder in the file system  

PROFInet 
component 

XML Edit > Create PROFInet component in 
the device-specific configuration and 
programming tool, e.g. STEP 7 

the component folder  

- in the file system or 

- in a library 

Variable table CBV Options > Export Variable table any folder in the file system 

Project 
documentation 

HTML Project > Document any folder in the file system 

Online device 
analysis 
information 

HTML Online > Online device analysis any folder in the file system 

OPC symbol file STI Options > Create OPC symbol file any folder in the file system 

Project 
description 

CBI Project > Import any folder in the file system 

• Menu command in SIMATIC iMap, unless otherwise specified.  

•  

 Note 
In SIMATIC iMap you can use the menu command Options > Customize, 
"Directories" tab, to define a directory for every file type that will always be 
suggested when you create, save and select this file type. 
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7.7 The "lifestate" connector in SIMATIC devices 

The technological functions of the PROFInet components that were created in 
STEP 7 receive an additional output of the type UI1,called "Lifestate". This output 
allows the PROFInet components to be monitored by the user program of a 
PROFInet communication partner. The "Lifestate" output may be interconnected as 
required for diagnostic purposes.  

Lifestate values 
The lifestate output can return the following values which describe the current state 
of the device:  

 
Value Designation of the 

state 
General significance 

0x00 NonExistent The device is not powered and is thus unable to 
communicate. This operating state cannot be 
transferred via the interconnection since no 
communication is possible. It is only listed for the sake 
of completeness.  

This value is also the default substitute value. 

0x01 Initializing The device is initializing, e.g. after a power off or reset. 

0x02 Ready The device is ready for use, but the component is not 
active. The device outputs are in the safe state.  

This state corresponds to the STOP operating state of 
a CPU, for example. 

0x03 Operating The device is operating normally. 

This state corresponds to the RUN operating state of a 
CPU, for example. 

0x04 Defect There is an error in the device that cannot be rectified 
without further intervention. Typical examples include 
hardware or firmware errors. The device can only be 
restarted by switching the power off and on again.  

Only limited communication is possible with the device, 
depending on the type of error. 

The value is 1 byte long. 
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Abbreviations 8
Abbreviations 

 
Abbreviation Explanation 

CbA Component based Automation 

COM Component Object Model  

DCOM Distributed Component Object Model 

GUID Global Unique IDentifier  

HMI Human Machine Interface  

MES Manufacturing Engineering System 

MAC Medium Access Control 

PN PROFINet  

PNO PROFIBUS NutzerOrganisation e.V. (PROFIBUS User 
Organization) 

SRT Soft Real-Time 

TIA Totally Integrated Automation 

UNC Uniform Naming Convention 

URL Uniform Resource Locator 

XML EXtended Markup Language 
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Glossary 9
 

Term Description 

Basic project Project folder in the vendor-specific configuration tool from which a 
PROFInet component is created. 

Example: STEP 7 basic project 

Chart In SIMATIC iMap: Folder that contains the technological function and 
their interconnections. The chart is used to structure the plant. We 
distinguish between the -> Main chart and -> subordinate charts 

Chart, subordinate In SIMATIC iMap: A subordinate chart may be located on any lower 
hierarchically level in the plant view. It may contain technological 
functions and further subordinate charts. 

Component based Automation Concept for implementing modular, distributed automation 
applications based on open standards for data processing and data 
communications.  

Component based Automation is an extension of Totally Integrated 
Automation (TIA). 

Component project A folder containing the vendor-specific project data for the PROFInet 
component, e.g. in the form of a STEP 7 project. 

Continuation connector Graphical representation of the end point of an interconnection. 
Interconnections are represented by lines or continuation connectors 
in SIMATIC iMap. 

Device In Component based Automation, this is part of the PROFInet 
component that contains the hardware-specific data for the PROFInet 
component. In SIMATIC iMap, a device is the software representation 
of the physical device for which the PROFInet component was 
created. In the SIMATIC iMap net view it is represented as an object 
with one or more bus ports. We distinguish between -> PROFInet 
devices and -> PROFIBUS devices according to the communication 
functions to be performed. 

Functionality, fixed A PROFInet component with fixed functionality does not contain its 
own user program. 

Functionality, programmable A PROFInet component with programmable functionality contains its 
own user program. 

Global library A library that can be opened, closed archived and retrieved in 
SIMATIC iMap using menu commands. The global library contains 
PROFInet components that can be used in several projects. 

Instance The instance of a PROFInet component is one use of that component 
type in the SIMATIC iMap project.  

Interconnection General: A logical data link between two objects.  

In SIMATIC iMap: Interconnection between two technological 
functions. An output is always connected to an input of the same data 
type. Interconnections are represented by lines or continuation 
connectors in SIMATIC iMap. 
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Term Description 

Interconnections to local 
communication partners 

Interconnections to local communication partners are:  

• Interconnections between two PROFIBUS devices on the same 
PROFIBUS 

• Interconnections between a PROFIBUS device and the 
associated PROFInet device with proxy functionality. 

Interconnections to remote 
communication partners 

Interconnections to remote communication partners are 
interconnections that run via Industrial Ethernet.  

Interface DB In Component based Automation, this is a data block in STEP 7 that 
describes the inputs and outputs of the technological function.  

Library In Component based Automation, this is a folder containing reusable 
PROFInet components. We distinguish between two types: > Project 
library and > Global library. 

Main chart In SIMATIC iMap: The main chart is the highest level of the 
hierarchical representation of the plant view. It contains all the 
technological functions and subordinate charts and their 
interconnections.  

Net view Representation of the devices and the networks (Ethernet, 
PROFIBUS) in SIMATIC iMap. 

Plant view Representation of the technological functions of the automation 
system and its interconnections in SIMATIC iMap. The plant view 
displays one chart. 

PROFIBUS device 
 

In Component based Automation, a PROFIBUS device has just one 
PROFIBUS connector as a slave. It does not participate directly in 
PROFInet communication and is integrated via a PROFInet device 
with proxy functionality. 

PROFInet Standard published by the Profibus User Organization (PNO) to 
define a cross-vendor communication and engineering model. 

PROFInet device 
 

A device on the Ethernet is a PROFInet device. A PROFInet device 
may also have a PROFIBUS connector as a master (PROFInet 
device with proxy functionality) for PROFIBUS devices. 

PROFInet device with proxy 
functionality 

The PROFInet device with proxy functionality is a proxy of the 
PROFIBUS devices on the Industrial Ethernet. The proxy functionality 
allows a PROFIBUS device to communicate with all PROFInet 
communication partners, as well as with its own DP master.  

If the device has a local (internal) PROFIBUS, then it is the DP 
master for the local DP slaves.  

PROFInet component Software representation of a technological module with defined 
functionality. An automation system is made up of several PROFInet 
components.  

A PROFInet component essentially consists of a technological 
function and the associated device. 

Project tree In Component based Automation: Hierarchic representation of the 
SIMATIC iMap project. There are two parts to this representation: 

The plant tree contains the technological functions. This part may be 
structured hierarchically using subordinate charts. The plant part 
always contains the main chart and may contain any number of 
nested subordinate charts. 

The net tree contains the devices. The slaves coupled to a 
PROFIBUS master are represented hierarchically. 



Glossary 

Component based Automation, Configuring Plants with SIMATIC iMap 
A5E00248797-01 9-3 

Term Description 

Project library Library which is contained in a SIMATIC iMap project and is opened, 
closed, archived and retrieved automatically with the project. The 
project library contains all the PROFInet components whose 
instances are contained in the project.  

Project view Representation of the assignment between PROFInet components 
and their instances in the SIMATIC iMap project. 

Proxy functionality see PROFInet device with proxy functionality 

Proxy system A proxy system consists of a PROFInet device with proxy 
functionality and all the PROFIBUS devices coupled to it. 

Scanning frequency For acyclical transfer, the scanning frequency is the frequency with 
which the data is polled, e.g. every 200 ms. The scanning frequency 
is thus the maximum time that elapses before a change in value is 
transferred. 

Shadow project Folder in which the vendor-specific data of the project is stored during 
generation in SIMATIC iMap. 

SIMATIC iMap The Siemens engineering tool for Component based Automation. It is 
used to configure, commission and monitor modular, distributed 
automation systems based on the PROFInet standard. 

SIMATIC iMap - STEP 7 Add-on Software for the SIMATIC iMap link to STEP 7. 

Singleton component In SIMATIC iMap, PROFInet components whose device-specific 
configuration and programming data is held and edited in the 
(STEP 7) basic project, rather than in the common shadow project. 
This component type allows you to incorporate hardware 
configurations with SIMATIC devices that were previously not 
supported into PROFInet communication. 

Technological function General: This is a task or sub-task within a technological process, 
e.g. measurement, control of motors, positioning. A technological 
function can be implemented both as hardware - e.g. a functional 
module - and as software � e.g. a control block.  

In Component based Automation, the technological function of a 
PROFInet component comprises the application-specific functionality 
of a programmable controller or field device and the component 
interface for communication with other PROFInet components.  

It is represented as a block with inputs and outputs in the 
SIMATIC iMap plant view. 

Transfer frequency For cyclical transfer, the transfer frequency is the time after which a 
data item is transferred again, e.g. every 100 ms. 
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