# SIMATIC Ident

**RFID systems**

SIMATIC RF680M Mobile Reader

## Operating Instructions

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>1</td>
</tr>
<tr>
<td>Safety Information</td>
<td>2</td>
</tr>
<tr>
<td>Description</td>
<td>3</td>
</tr>
<tr>
<td>Power supply</td>
<td>4</td>
</tr>
<tr>
<td>Commissioning</td>
<td>5</td>
</tr>
<tr>
<td>Operation</td>
<td>6</td>
</tr>
<tr>
<td>Software overview</td>
<td>7</td>
</tr>
<tr>
<td>The software &quot;RF-MANAGER&quot;</td>
<td>8</td>
</tr>
<tr>
<td>&quot;RF680M&quot; software</td>
<td>9</td>
</tr>
<tr>
<td>Advanced functions</td>
<td>10</td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>11</td>
</tr>
<tr>
<td>Technical data</td>
<td>12</td>
</tr>
<tr>
<td>Ordering data</td>
<td>13</td>
</tr>
<tr>
<td>Appendix</td>
<td>A</td>
</tr>
</tbody>
</table>

06/2011

J31069-D0241-U001-A2-7618
Legal information

Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are graded according to the degree of danger.

**DANGER**

indicates that death or severe personal injury will result if proper precautions are not taken.

**WARNING**

indicates that death or severe personal injury may result if proper precautions are not taken.

**CAUTION**

with a safety alert symbol, indicates that minor personal injury can result if proper precautions are not taken.

**CAUTION**

without a safety alert symbol, indicates that property damage can result if proper precautions are not taken.

**NOTICE**

indicates that an unintended result or situation can occur if the relevant information is not taken into account.

If more than one degree of danger is present, the warning notice representing the highest degree of danger will be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property damage.

Qualified Personnel

The product/system described in this documentation may be operated only by personnel qualified for the specific task in accordance with the relevant documentation, in particular its warning notices and safety instructions. Qualified personnel are those who, based on their training and experience, are capable of identifying risks and avoiding potential hazards when working with these products/systems.

Proper use of Siemens products

Note the following:

**WARNING**

Siemens products may only be used for the applications described in the catalog and in the relevant technical documentation. If products and components from other manufacturers are used, these must be recommended or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and maintenance are required to ensure that the products operate safely and without any problems. The permissible ambient conditions must be complied with. The information in the relevant documentation must be observed.

Trademarks

All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability

We have reviewed the contents of this publication to ensure consistency with the hardware and software described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the information in this publication is reviewed regularly and any necessary corrections are included in subsequent editions.
# Table of contents

1 Introduction ............................................................................................................................... 7

2 Safety Information ................................................................................................................... 9

2.1 General safety instructions ................................................................................................. 9

3 Description .............................................................................................................................. 11

3.1 Field of application and features ..................................................................................... 11

3.2 Design .................................................................................................................................. 13

3.3 Antenna and antenna field ................................................................................................. 14

4 Power supply .......................................................................................................................... 17

4.1 Inserting the battery ........................................................................................................... 17

4.2 Charging the device .......................................................................................................... 18

4.3 The backup battery ........................................................................................................... 18

5 Commissioning ...................................................................................................................... 19

5.1 Scope of supply ................................................................................................................. 19

5.2 Switching the device On and Off..................................................................................... 20

5.3 Recommendations for first commissioning ..................................................................... 20

5.3.1 Creating a back-up copy ............................................................................................... 20

5.3.2 Changing the password for the operating system ...................................................... 21

5.3.3 Performing a back-up ................................................................................................. 21

5.4 Basic settings in the operating system ............................................................................ 22

5.4.1 Operating modes .......................................................................................................... 22

5.4.2 Adjusting the acoustic signal volume ....................................................................... 23

5.4.3 Set the backlighting of the screen ............................................................................ 23

6 Operation .................................................................................................................................. 25

6.1 The keypad .......................................................................................................................... 25

6.1.1 Key functions .............................................................................................................. 25

6.1.2 The shift keys .............................................................................................................. 26

6.2 The Touch display ............................................................................................................. 26

7 Software overview .................................................................................................................. 27

7.1 Software applications ........................................................................................................ 27

7.2 Overview of possible applications .................................................................................... 27

8 The software "RF-MANAGER" .............................................................................................. 29

8.1 Prerequisites for working with the software "RF-MANAGER" ........................................ 29

8.1.1 Necessary components ............................................................................................... 29

8.1.2 Starting the software "RF-MANAGER" .................................................................... 29

8.1.3 Preconditions for parameterization of the WLAN connection .................................. 30
## Table of contents

8.1.4 Settings in the Engineering System ................................................................. 30
8.1.5 Parameterizing the WLAN card in the SIMATIC RF680M mobile reader .......................... 31
8.1.6 Enter the IP address in the mobile reader ......................................................... 32
8.1.7 Creating a back-up ......................................................................................... 32

8.2 Application mode "Remote" ............................................................................. 33
8.2.1 Acquire data and transfer it to RF-MANAGER .............................................. 33

8.3 Application mode "Mobile" ............................................................................... 34
8.3.1 Acquire data and transfer it to RF-MANAGER .............................................. 34
8.3.2 The data editor ............................................................................................. 35
8.3.2.1 Progress and timeout display ................................................................. 39
8.3.2.2 Read tag .................................................................................................. 40
8.3.2.3 Writing to the tag .................................................................................. 41

8.3.4 The functions in the "File" menu .................................................................. 44
8.3.4.1 Overview of file functions ....................................................................... 44
8.3.4.2 Open ...................................................................................................... 44
8.3.4.3 Save Tag / Save Tag As .......................................................................... 45
8.3.4.4 Exit ........................................................................................................ 45
8.3.4.5 The functions in the "Tag" menu .............................................................. 46
8.3.4.5.1 Overview of tag functions .............................................................. 46
8.3.4.5.2 Write ID ......................................................................................... 47
8.3.4.5.3 Locking data areas .......................................................................... 48
8.3.4.5.4 Kill tag ............................................................................................ 50
8.3.4.6 The functions in the "Extras" menu ......................................................... 51
8.3.4.6.1 Overview of the Extras functions .................................................. 51
8.3.4.6.2 Password for the RF-MANAGER application .................................. 52
8.3.4.6.3 Reader status .................................................................................. 53
8.3.4.6.4 Setting the language ....................................................................... 53
8.3.4.6.5 Settings ............................................................................................ 54
8.3.4.7 The functions in the "Help" menu ............................................................. 57
8.3.4.7.1 Overview of "Help" menu ............................................................... 57

9 "RF680M" software .................................................................................................. 59
9.1 Overview of functions ..................................................................................... 59
9.2 Start "RF680M" software ............................................................................... 59
9.3 The data editor ............................................................................................... 60

9.4 The functions in the "File" menu .................................................................. 62
9.4.1 Overview of file functions ........................................................................... 62
9.4.2 Open ........................................................................................................ 63
9.4.3 Save Tag / Save Tag As ............................................................................. 63
9.4.4 Save List As ............................................................................................... 63
9.4.5 Append List ................................................................................................ 64
9.4.6 Exit ........................................................................................................... 64

9.5 The functions in the "Tag" menu .................................................................. 64
9.5.1 Overview of tag functions ........................................................................... 64
9.5.2 Scanning RFID tags and their tag ID ......................................................... 65
9.5.3 Progress and timeout display .................................................................... 66
9.5.4 Read tag ................................................................................................... 67
9.5.5 Writing to the tag ...................................................................................... 69
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>9.5.6</td>
<td>Copying tag data</td>
<td>70</td>
</tr>
<tr>
<td>9.5.7</td>
<td>Write ID</td>
<td>71</td>
</tr>
<tr>
<td>9.5.8</td>
<td>Locking data areas</td>
<td>71</td>
</tr>
<tr>
<td>9.5.9</td>
<td>Kill tag</td>
<td>74</td>
</tr>
<tr>
<td>9.5.10</td>
<td>Tag Type Selection</td>
<td>75</td>
</tr>
<tr>
<td>9.6</td>
<td>The functions in the “Extras” menu</td>
<td>77</td>
</tr>
<tr>
<td>9.6.1</td>
<td>Overview of the Extras functions</td>
<td>77</td>
</tr>
<tr>
<td>9.6.2</td>
<td>Password for the SIMATIC RF680M application</td>
<td>78</td>
</tr>
<tr>
<td>9.6.3</td>
<td>Reader status</td>
<td>79</td>
</tr>
<tr>
<td>9.6.4</td>
<td>Reader settings</td>
<td>79</td>
</tr>
<tr>
<td>9.6.5</td>
<td>Settings</td>
<td>80</td>
</tr>
<tr>
<td>9.6.6</td>
<td>Setting the language</td>
<td>83</td>
</tr>
<tr>
<td>9.6.7</td>
<td>The functions in the “Help” menu</td>
<td>84</td>
</tr>
<tr>
<td>9.6.8</td>
<td>Overview of “Help” menu</td>
<td>84</td>
</tr>
<tr>
<td>9.7</td>
<td>Application example</td>
<td>84</td>
</tr>
<tr>
<td>10</td>
<td>Advanced functions</td>
<td>87</td>
</tr>
<tr>
<td>10.1</td>
<td>File storage on the RF680M</td>
<td>87</td>
</tr>
<tr>
<td>10.2</td>
<td>Data transfer between the PC and mobile reader</td>
<td>88</td>
</tr>
<tr>
<td>10.2.1</td>
<td>Prerequisites</td>
<td>88</td>
</tr>
<tr>
<td>10.2.2</td>
<td>Working with the Active Sync program</td>
<td>88</td>
</tr>
<tr>
<td>10.2.3</td>
<td>Organization of the .XML files in the Flash Disk directory</td>
<td>90</td>
</tr>
<tr>
<td>10.3</td>
<td>The automatic power-saving function</td>
<td>93</td>
</tr>
<tr>
<td>10.4</td>
<td>System reset</td>
<td>93</td>
</tr>
<tr>
<td>11</td>
<td>Troubleshooting</td>
<td>95</td>
</tr>
<tr>
<td>12</td>
<td>Technical data</td>
<td>97</td>
</tr>
<tr>
<td>13</td>
<td>Ordering data</td>
<td>99</td>
</tr>
<tr>
<td>A</td>
<td>Appendix</td>
<td>101</td>
</tr>
<tr>
<td>A.1</td>
<td>Certificates and approvals</td>
<td>101</td>
</tr>
<tr>
<td>A.2</td>
<td>Ordering components for advanced functions</td>
<td>101</td>
</tr>
<tr>
<td>A.3</td>
<td>Developing user applications</td>
<td>101</td>
</tr>
<tr>
<td>A.4</td>
<td>Service &amp; support</td>
<td>101</td>
</tr>
<tr>
<td></td>
<td>Glossary</td>
<td>105</td>
</tr>
<tr>
<td></td>
<td>Index</td>
<td>107</td>
</tr>
</tbody>
</table>
Introduction

Purpose of this document

These operating instructions contain information required for starting up and using the RF680M device.

The documentation is aimed at commissioning engineers and machine operators who start up the application themselves, and it describes the functions of the software "RF-MANAGER" and "RF680M".

Scope of validity of this document

This documentation is valid for the SIMATIC RF680M Mobile Reader and describes the delivery status from 12/2010.

Further information

The present instructions are a supplement to the operating instructions of the basic device PSION WORKABOUT PRO.

The documents "Quick Reference Guide" and "Regulatory & Warranty Guide" for "WORKABOUT PRO C/M-E Hand-Held Computer" are included with the device. Please note the information they contain.

You can find further information in the PSION User Manual and in the documentation for the docking station.

Conventions

The following terms/abbreviations are used synonymously in this document:

- tag, transponder, mobile data memory (MDS), data carrier
- Mobile reader, reader, handheld terminal, handheld; write/read device (SLG)

History

Previous editions of these operating instructions:

<table>
<thead>
<tr>
<th>Edition</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>12/2010</td>
<td>First edition</td>
</tr>
<tr>
<td>06/2011</td>
<td>Revision of the Operating Instructions</td>
</tr>
</tbody>
</table>
Safety Information

2.1 General safety instructions

SIMATIC RFID products comply with the salient safety specifications to VDE/DIN, IEC, EN, UL and CSA. If you have questions about the validity of the installation in the planned environment, please contact your service representative.

<table>
<thead>
<tr>
<th>CAUTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alterations to the devices are not permitted.</td>
</tr>
<tr>
<td>Failure to observe this requirement shall constitute a revocation of the radio equipment approval, CE approval and manufacturer's warranty.</td>
</tr>
</tbody>
</table>

Repairs

Repairs may only be carried out by authorized qualified personnel.

<table>
<thead>
<tr>
<th>WARNING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unauthorized opening of and improper repairs to the device may result in substantial damage to equipment or risk of personal injury to the user.</td>
</tr>
</tbody>
</table>
Safety Information

2.1 General safety instructions
SIMATIC RF680M expands the RF600 identification system with a powerful mobile reader for applications in the areas of logistics, production and service. In addition, it is an indispensable aid for startup and testing.

3.1 Field of application and features

Device variants for different frequency ranges

The SIMATIC RF680M device is available in two variants:

- For the European frequency bands
- For the US frequency bands

Implementation environment, field of application and features

- Field of application
  The SIMATIC RF680M mobile readers can be used in a harsh environment. The device is extremely rugged and protected against spray water. The backlit display is easy to read even under unfavorable lighting conditions.

- RFID system
  The SIMATIC RF680M mobile reader is intended especially for the SIMATIC RF600 RFID system. The device can be used to process all RF600 tags and compatible transponders.

- RF-MANAGER
  The SIMATIC RF680M mobile reader can exchange data with the RF-MANAGER over a WLAN connection. This means that RFID data that has been read locally is also available for evaluation in enterprise systems.

- Tag standards
  It is not possible to edit data memories of other RFID systems. The following tag standards are supported:
  - ISO 18000-6c (EPC Class1 GEN2)

- The software "RF-MANAGER" and "RF680M"
  The RF-MANAGER and RF680M software is stored in non-volatile memory on an integrated flash disk and permits user-friendly, distributed reading and writing of all RF600 tags.
3.1 Field of application and features

- **API software interface**
  
  The SIMATIC RF680M mobile reader is supplied with an API software interface that can be used by customized user programs.

- **Additional functional units for the SIMATIC RF680M Mobile Reader**

  All other functional units of SIMATIC RF680M, such as barcode scanners and WLAN can be accessed via the interfaces supplied by the PSION device manufacturer. The descriptions and development tools can be obtained from the PSION websites.

  You can perform the following functions with the SIMATIC RF680M mobile reader:

- **Reading the tag ID**
- **Reading the data from the tag (data memory)**
- **Writing the data to the tag**
- **Reading and displaying the ID number of the tag (Tag/Scan)**
- **Transferring the data that has been read to RF-MANAGER**
- **Writing the tag ID to a transponder**
- **Displaying reader status**
- **Representing and editing the data in hexadecimal, ASCII and binary format**
- **Activatable/deactivatable password protection for all write functions and for terminating the program**
- **Menu prompting in English and German (switchable)**
- **Saving of the read-in RF600 data to files in the mobile reader. The reader has approximately 900 MB available for this purpose.**
- **Easy creation of your own RFID applications with the Software Application Interface (API)**

  The RFID read/write unit of RF600 is integrated into the PSION basic unit.

**Security: Password protection**

You can assign different passwords for the SIMATIC RF680M mobile reader:

- **Password for the operating system.** For more information, see Changing the password for the operating system (Page 21)

- **Password for the SIMATIC RF680M application.** For more information, see Password for the SIMATIC RF680M application (Page 78)

- **Passwords for locking tag data areas.** For more information, see Locking data areas (Page 71)
Accessories

The charging and docking station (including wide-range power supply unit, 100 to 240 V AC, 50 to 60 Hz) for recharging the battery and connecting to PCs via USB port must be ordered separately. This station has a charging bay for an additional replacement battery. See Ordering data (Page 99).

3.2 Design

<table>
<thead>
<tr>
<th>Design of the SIMATIC RF680M</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>①</td>
<td>Integrated read/write head</td>
</tr>
<tr>
<td>2</td>
<td>②</td>
<td>Holder for input pen</td>
</tr>
<tr>
<td>3</td>
<td>③</td>
<td>Charge indicator</td>
</tr>
<tr>
<td>4</td>
<td>④</td>
<td>USB connector</td>
</tr>
<tr>
<td>5</td>
<td>⑤</td>
<td>Power supply</td>
</tr>
<tr>
<td>6</td>
<td>⑥</td>
<td>Charging station</td>
</tr>
<tr>
<td>7</td>
<td>⑦</td>
<td>On/off button</td>
</tr>
<tr>
<td>8</td>
<td>⑧</td>
<td>ASCII keypad</td>
</tr>
<tr>
<td>9</td>
<td>⑨</td>
<td>Numeric keys</td>
</tr>
<tr>
<td>10</td>
<td>⑩</td>
<td>Microphone</td>
</tr>
<tr>
<td>11</td>
<td>⑪</td>
<td>Display</td>
</tr>
<tr>
<td>12</td>
<td>⑫</td>
<td>Loudspeaker</td>
</tr>
</tbody>
</table>
3.3 Antenna and antenna field

Read head with integral antenna

The antenna is housed in the read head ① under a cover.

Figure 3-1  Read head with antenna

Direction of propagation of the high-frequency field

The write/read area for transponders is located on the end face as well as on the top and bottom of the front section of the enclosure.

The antenna of the RF680M is linearly polarized. For successful reading and writing, the dipoles of the transponders and the antennas of the RF680M must be in parallel. Note the technical data of the individual transponders.
The following figure shows the positioning of transponders in front of the antenna. The maximum working range is achieved above and below the read head.

Figure 3-2  Positioning of transponders
3.3 Antenna and antenna field
## Power supply

### 4

#### 4.1 Inserting the battery

The mobile reader’s battery is located on the rear of the unit.

<table>
<thead>
<tr>
<th>Steps for inserting the battery</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Turn the screws on the rear of the device in the direction of the arrow and lift the cover at the side where the screws are.</td>
</tr>
<tr>
<td><img src="image1.png" alt="Image showing screws and cover being lifted" /></td>
</tr>
<tr>
<td>2. Hold the battery at an angle when inserting so that the side of the battery with the direction arrow is inserted into the battery compartment first (see the depiction of the arrow).</td>
</tr>
<tr>
<td><img src="image2.png" alt="Image showing battery being inserted" /></td>
</tr>
</tbody>
</table>
4.2 Charging the device

Complete charging of an empty battery takes approximately 5 hours.

Starting the charging operation

The charging operation is started as soon as you insert the mobile reader into the charging station.

⚠️ WARNING
Explosion hazard when using a different charging station. Use only the original charging station from PSION. Use of another charging station can result in explosions and serious personal injury.

Detecting the level of charge

You can check the level of charge via the charge indicator (LED) on the reader when the SIMATIC RF680M is placed in the charging station:

<table>
<thead>
<tr>
<th>LED color</th>
<th>LED status</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Flashing</td>
<td>Charging in progress. Battery charge is less than 80%</td>
</tr>
<tr>
<td></td>
<td>Flashes slowly</td>
<td>Charging in progress. Battery charge exceeds 80%</td>
</tr>
<tr>
<td></td>
<td>Rapid flashing</td>
<td>Battery temperature is higher than 45 °C. Charging not in progress.</td>
</tr>
<tr>
<td></td>
<td>Permanently lit</td>
<td>Battery is fully charged.</td>
</tr>
<tr>
<td>red</td>
<td>Permanently lit</td>
<td>Charging not in progress. Battery fault!</td>
</tr>
</tbody>
</table>

4.3 The backup battery

The backup battery in the SIMATIC RF680M is used for retaining the application data when the main batteries are discharged. It is a rechargeable battery that is charged together with the main battery.

Please note that a new backup battery (in the case of an empty or removed main battery) can only retain the data in the tag for a few minutes. It cannot be replaced because it is permanently connected to the device.
Commissioning

5

5.1 Scope of supply

The scope of supply of the SIMATIC RF680M comprises the following components.

- **SIMATIC RF680M**
  - with integrated RFID read/write unit for RF600

- **Documentation**
  - in the directory "Flash Disk\SIMATIC RF680M\Documents\deutsch" or "Documents\english":
    - The SIMATIC RF680M Operating Instructions
    - The "Mobile Readers" function manual
    - The PSION WORKABOUT PRO 3 Operating Instructions

- **Drivers and software**
  - in the directory "Flash Disk\SIMATIC RF680M\Support"
    - The RFID software interface API
    - The USB driver (for procedure, see the chapter on data transmission between the PC and mobile reader for instructions on installing the driver Prerequisites (Page 88))

![Figure 5-1 Directory "Flash Disk\SIMATIC RF680M"

---

**Note**

Information on accessing the directory "Flash Disk"

See Chapter Data transfer between the PC and mobile reader (Page 88)
5.2 Switching the device On and Off

Requirements for startup

- The mobile reader SIMATIC RF680M is mounted
- The device battery is charged and inserted in the device (see chapters Charging the device (Page 18) and Inserting the battery (Page 17)).

**Note**
Before switching the device on for the first time, you must insert the reader into the charging unit and charge it for approximately five hours.

Switching the device on/off

To switch the reader on or off, press and hold the ON/OFF button for at least one second.

![ON/OFF button](image)

Figure 5-2 ON/OFF button

After switching on, the first power-up lasts a few seconds.

Automatic shutdown of the device

The device shuts down automatically if no key is pressed for three minutes. After switching on again, the reader continues to operate with the same interface it was using before it was manually or automatically switched off. See chapter The automatic power-saving function (Page 93).

5.3 Recommendations for first commissioning

We recommend the following steps for first commissioning:

1. Creating a back-up copy
2. Changing the password for the operating system
3. Implementing other operating system settings (e.g. WLAN)
4. Performing a back-up

The steps are explained in more detail in the following chapters.

5.3.1 Creating a back-up copy

Create a backup copy so that you can restore the delivery status of the device when necessary.
5.3 Recommendations for first commissioning

Requirement

The reader is connected to the PC.

Procedure

Copy all the data from the directory "Flash Disk" to your PC. See also Chapter Data transfer between the PC and mobile reader (Page 88)

| NOTICE |
| Do not delete files with the extension ".PFL" |
| Files with the extension ".PFL" in the "Flash Disk" directory are used to restore the status that existed at the time of the last back-up and must therefore not be modified or deleted. If the files with the ending ".PFL" are damaged or lost, the original status of the device can only be restored at the factory. |
| To restore a backup, replace all the data on the device with your backup copy and then run a system reset. |

5.3.2 Changing the password for the operating system

Assign a password to protect the system from unauthorized access.

Prerequisite

The operating mode must be set to "Supervisor". See Chapter Operating modes (Page 22)

Procedure for changing the password

To change the password of the operating system, select "Start > Security". Enter the previous password. The password on delivery is "123456".

You can assign a new password using the button "Set Password".

5.3.3 Performing a back-up

Set the operating mode to "Supervisor". See Chapter Operating modes (Page 22)

Select "Start > Settings > Control Panel > Total Recall".

1. Select the "Create Profile" button.
2. Select "Auto Restore" and then confirm with the "-->" button.
3. Select "Default Backup" and confirm this with the "Create Profile" button.

Reaction: The backup is started.

4. Click "Finished" to return to the application.
All changes, e.g. a new password for the operating system, are now stored in the back-up secure against power failure.

See also
System reset (Page 93)

5.4 Basic settings in the operating system

5.4.1 Operating modes

Operating modes
The SIMATIC RF680M device has two operating modes:
1. "Supervisor Mode"
   Configuration and settings for the SIMATIC RF680M Mobile Reader.
2. "User Mode"
   Default mode. The user can only use the installed service and test applications. The start menu functionality is restricted.

Changing the operating mode
You can change the operating mode in the "Security Level" settings. "Start > Security" is used for changeover:

![Operating mode](Figure 5-3 Operating mode)

Changeover to "Supervisor Mode" is password-protected. On delivery, this password is set to "123456" and should be changed the first time it is used for security reasons.

See also
System reset (Page 93)
5.4.2 Adjusting the acoustic signal volume

The tag functions trigger an acoustic signal indicating whether the operations were successful or were terminated with an error. You can switch these acoustic acknowledgements/signals on and off and you can regulate their volume.

Adjusting the volume of the acoustic signals

Press the blue labeled <FN> button in each case to regulate the volume of the acoustic signals in steps using the "Plus" button (louder) or the "Minus" button (quieter).

Specific setting of the acoustic signals

In "Supervisor" mode, select "Start > Settings > Control Panel > Volume & Sounds". On the "Volume" tab, you can regulate the volume between "Soft" and "Loud" using the bar. You can also permit or deactivate acoustic signals for different messages by activating the relevant checkboxes.

5.4.3 Set the backlighting of the screen

To alter the brightness of the display, select "Start > Settings > Control Panel > Display > Backlight in "Supervisor" mode."
Commissioning

5.4 Basic settings in the operating system
6.1 The keypad

6.1.1 Key functions

Table 6-1 Key functions

<table>
<thead>
<tr>
<th>Overview of the keypad</th>
<th>Item</th>
<th>Key label</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>①</td>
<td>&lt;F2&gt;</td>
<td>If you first press the blue &lt;FN&gt; key, the function of other keys is changed. Similar to the &lt;ALT&gt; key in the Windows operating system.</td>
</tr>
<tr>
<td>2</td>
<td>②</td>
<td>&lt;SCAN&gt;</td>
<td>Scanning of tags</td>
</tr>
<tr>
<td>3</td>
<td>③</td>
<td>Blue &lt;FN&gt;</td>
<td>Shift key: Changes the function of other keys to that shown by the blue labeling</td>
</tr>
<tr>
<td>4</td>
<td>④</td>
<td>&lt;TAB&gt;</td>
<td>Moves the cursor to the right or down at specific intervals.</td>
</tr>
<tr>
<td>5</td>
<td>⑤</td>
<td>&lt;ENTER&gt;</td>
<td>On/Off key, Enter key</td>
</tr>
<tr>
<td>6</td>
<td>⑥</td>
<td>&lt;SPACE&gt;</td>
<td>Inserting spaces. In a Windows dialog window, checkboxes can be activated or deactivated with the &lt;SPACE&gt; key.</td>
</tr>
<tr>
<td>7</td>
<td>⑦</td>
<td>&lt;SHIFT&gt;</td>
<td>Display of uppercase letters (A-Z) and symbols also specified on the numeric keys (e.g. &amp;,*,...).</td>
</tr>
<tr>
<td>8</td>
<td>⑧</td>
<td>&lt;BKSP&gt;</td>
<td>Moves the cursor to the left to delete the last entered character. If the blue &lt;FN&gt; key is pressed first, the character after the cursor is removed.</td>
</tr>
<tr>
<td>9</td>
<td>⑨</td>
<td>&lt;ESC&gt;</td>
<td>Closes the currently open menu, dialog window or started application and returns you to the previous interface.</td>
</tr>
</tbody>
</table>
6.2 The Touch display

<table>
<thead>
<tr>
<th>Overview of the keypad</th>
<th>Item</th>
<th>Key label</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>⑪ Orange &lt;FN&gt;</td>
<td>Shift key:</td>
<td>Changes the function of other keys to that shown by the orange labeling</td>
<td></td>
</tr>
<tr>
<td>⑫ Arrow keys</td>
<td>Enable navigation to the left, right, up and down in the display.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>⑬ &lt;F1&gt;</td>
<td>If you first press the blue &lt;FN&gt; key, the function of other keys is changed. Corresponds to the &lt;CTRL&gt; key in the Windows operating system.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

6.1.2 The shift keys

An activated shift key causes a change in the function of the subsequently pressed keys.

The following keys of the SIMATIC RF680M are shift keys:
- <SHIFT>
- Orange <FN> (changes the key assignment in accordance with the orange-colored labeling on the keypad)
- Blue <FN> (changes the key assignment in accordance with the blue-colored labeling on the keypad)

Activating the shift keys:

When you press a shift key once briefly, it is activated and the name of the selected switch key appears in lowercase in the task bar, e.g. "Org key", "Blue key".

Any subsequently pressed key then changes its function, the display in the task bar disappears and the shift key is deactivated again.

If you press a shift key briefly twice in succession, it will become inactive again.

6.2 The Touch display

The screen of the SIMATIC RF680M is designed as a touch-sensitive display. You can easily enter commands by touching it with the pen.
Software overview

7.1 Software applications

Two software applications are available to you in SIMATIC RF680M:

- **The software "RF680M" of the standalone product SIMATIC RF680M**
  The application program "RF680M" is primarily intended for use in the service and test fields for reading and writing tags in RFID applications.

- **The software "RF-MANAGER"**
  With the application software "RF-MANAGER", the SIMATIC RF680M device becomes an integral component of that of SIMATIC RF-MANAGER.
  Data acquisition for the "RF-MANAGER" software is configured in the engineering system of SIMATIC RF-MANAGER.
  The software serves to acquire data and transfer it to SIMATIC RF-MANAGER.

7.2 Overview of possible applications

You can use the SIMATIC RF680M device in different ways:
As a standalone product or in combination with SIMATIC RF-MANAGER.

<table>
<thead>
<tr>
<th>Interfacing to SIMATIC RF-MANAGER with the software &quot;RF-MANAGER&quot;</th>
<th>Standalone product with the software &quot;RF680M&quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application mode &quot;Remote&quot;</td>
<td>Application mode &quot;Mobile&quot;</td>
</tr>
<tr>
<td>• RF680M behaves like a stationary reader</td>
<td>• The acquired data is acknowledged before</td>
</tr>
<tr>
<td>• The acquired data are only displayed and transferred to RF-</td>
<td>being transferred to RF-MANAGER. Data that</td>
</tr>
<tr>
<td>MANAGER</td>
<td>has been incorrectly scanned can be deleted.</td>
</tr>
<tr>
<td>• The acquired data cannot be modified</td>
<td>• All the tag data from the RFID chip can</td>
</tr>
<tr>
<td></td>
<td>also be displayed or edited depending</td>
</tr>
<tr>
<td></td>
<td>on the configuration in the engineering</td>
</tr>
<tr>
<td></td>
<td>system.</td>
</tr>
</tbody>
</table>
7.2 Overview of possible applications
The software "RF-MANAGER"

8.1 Prerequisites for working with the software "RF-MANAGER"

8.1.1 Necessary components

WLAN module

Communication with the runtime system of RF-MANAGER is performed over a radio link. The SIMATIC RF WLAN module is required for this purpose.

Barcode scanner

When reading of bar codes is configured in the engineering system of RF-MANAGER, you will need the accessory SIMATIC RF barcode scanner for the SIMATIC RF680M device.

Both components can be ordered and installed separately as accessories. [See Ordering data (Page 99)].

8.1.2 Starting the software "RF-MANAGER"

To start the RF-MANAGER application, double-click the "RF-MANAGER" icon on the desktop.

A connection to RF-MANAGER will only be established when the "RF-MANAGER" software has been started and the WLAN connection is active.

After it has been correctly installed, the SIMATIC RF680M Mobile Reader automatically receives its configuration from RF-MANAGER.
8.1.3 Preconditions for parameterization of the WLAN connection

- The mobile reader must be ready for operation (the battery is charged).
- The mobile reader must contain a WLAN card.
- A WLAN connection must exist between the reader and the network of the PC, e.g. via an access point.
- Information regarding the WLAN settings must be available.
- The operating mode of the mobile reader must be set to "Supervisor".

8.1.4 Settings in the Engineering System

1. **Enter IP address of the reader**
   
Enter the assigned IP address in the device settings of the mobile reader ("RFID devices > RFID device_X").

2. **Enter the network address of the PC**
   
Enter the network address of the PC in the network settings ("Device settings > RFID / network settings").
Note
An automatic reader search is not possible in the Engineering System
The automatic reader search via "Project > Reader configuration > Communication settings" does not function in the case of mobile readers.

8.1.5 Parameterizing the WLAN card in the SIMATIC RF680M mobile reader

Two examples are given below for the procedure that you can follow for configuring the WLAN card of SIMATIC RF680M.

Consult your network administrator to ensure that the WLAN connection is set up correctly. You will find detailed information on configuring the WLAN in the operating instructions for the PSION WORKABOUT PRO.

Example 1

With this procedure, the active radio networks are displayed automatically.
1. Set the operating mode to "Supervisor" in SIMATIC RF680M.
2. In SIMATIC RF680M, select "Start > Programs > Summit > SCU"
3. Under "Active Config", select "Third party".
4. To activate these changes, change to the device to the "Powerdown" mode by pressing the blue <FN> key and the on/off button at the same time for approximately 7 seconds. The device then restarts.
5. Select the required active wireless network in the dialog that now opens.
6. Click the "Connect" button and enter the respective encryption code under "Authentication" and "Network key".
7. Click on the "OK" button.

Example 2

1. Select "Start > Programs > Summit > SCU" in the mobile reader.
2. Click on the "Profiles" tab.
3. Select the "New" button to create a new profile setting
4. Enter a name for the profile setting.
5. At least make the following settings:
   - **SSID** (name of the radio network), e.g. "RF680M"
   - **Auth Type** (security level): e.g. "Shared"
6. Select the encryption required under "Encryption": e.g. "WPA2 PSK".
7. Then click the button "WEP keys/PSKs". Enter the encryption code and confirm with "OK".

8. Click the "Commit" button to confirm the settings.

9. In the "Main" tab, under "Active config", select the profile that should be active.

10. To activate these changes, change to the device to the "Powerdown" mode by pressing the blue <FN> key and the on/off button at the same time for approximately 7 seconds. The device then restarts.

---

**Note**

**Other encryption possibilities**

You can also use other encryption methods, depending on the access point. "WEP" encryption is no longer regarded as secure; you should not use this.

---

### 8.1.6 Enter the IP address in the mobile reader

If a DHCP server is not present in the network, you must enter the IP address of SIMATIC RF680M in the SIMATIC RF680M mobile reader:

1. Double-click the WLAN icon in the taskbar for this purpose.

2. In the "IP Information" tab, click the "Configure" button and select "Specify an IP address". Enter the IP address.

As an alternative, you can also enter the IP address as follows:

1. "Start > Settings > Control Panel > Network and Dial-up Connections" and select the relevant connection.

2. In the "IP Information" tab, click the "Configure" button and select "Specify an IP address". Enter the IP address.

---

### 8.1.7 Creating a back-up

Create a back-up to save the settings even in the case of power failure. The steps you have to perform to do this are described in detail in the section Performing a back-up.

---

**See also**

Performing a back-up (Page 21)
8.2 Application mode "Remote"

In application mode "Remote" that is configured via the Engineering System in RF-MANAGER, the SIMATIC RF680M mobile reader has the properties of a stationary reader. This means that the acquired data are only displayed on the reader and transferred to RF-MANAGER.

You are not able to acknowledge or reject the acquired data in SIMATIC RF680M.

8.2.1 Acquire data and transfer it to RF-MANAGER

Data acquisition

Depending on the configuration in the Engineering System, you can activate a barcode or RFID read using the hardware keys or the "Scan" button of SIMATIC RF680M.

If you have configured the reading of barcodes, the acquired barcode will be preceded by "BAR".

If you have configured the reading of RFID tag data, the acquired tag ID will be preceded by "RFID".

Transfer data to RF-MANAGER

All acquired data is transferred immediately to RF-MANAGER.
8.3 Application mode "Mobile"

In application mode "Mobile" that is configured via the Engineering System in RF-MANAGER, you can check the read data for validity in the SIMATIC RF680M mobile reader and reject any faulty reads. Only that data which you have acknowledged will be transferred to RF-MANAGER.

Functional expansion by means of configuration in the Engineering System

When the function "Edit Tag" is activated in RF-MANAGER, you can display and edit all the data for the read RFID tag.

8.3.1 Acquire data and transfer it to RF-MANAGER

Data acquisition

Depending on the configuration in the Engineering System, you can activate a barcode or RFID read using the hardware keys, the RF-MANAGER or the "Scan" button of SIMATIC RF680M.

If you have configured the reading of barcodes, the acquired barcode will be preceded by "BAR".

If you have configured the reading of RFID tag data, the acquired tag ID will be preceded by "RFID".

Transfer data to RF-MANAGER

If you want to transfer data to RF-MANAGER, select the "OK" button.

The data then disappears from the user interface of the SIMATIC RF680M.
Read Data

You can edit the data scanned from an RFID tag via the "Data" button.
The following chapters contain detailed information about this.

Delete data

You can reject any data that has been incorrectly acquired via the "Delete" button.

8.3.2 The data editor

Prerequisites for working in the data editor

In order to process tag data, a tag must have been scanned by the SIMATIC RF680M device and its tag ID must be indicated in the display. See Chapter Acquire data and transfer it to RF-MANAGER (Page 34).

The transponder data can be edited in the editor window in hex, ASCII or decimal format. You can toggle between the two in the "Tools > Settings" menu. (See Settings (Page 54)).
### Interface structure of the data editor

<table>
<thead>
<tr>
<th>User interface</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="" /></td>
<td>①</td>
<td>Menu bar</td>
</tr>
<tr>
<td></td>
<td>②</td>
<td>Indication of the tag ID</td>
</tr>
<tr>
<td></td>
<td>③</td>
<td>Drop-down list box with the transponder-specific memory areas (e.g. EPC, TID, USER) that are displayed in the data field.</td>
</tr>
<tr>
<td></td>
<td>④</td>
<td>Length of the data area (the field can be edited when &quot;Total&quot; is not checked)</td>
</tr>
<tr>
<td></td>
<td>⑤</td>
<td>Data field</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The data can be displayed in either hexadecimal, decimal or ASCII format.</td>
</tr>
<tr>
<td></td>
<td>⑥</td>
<td>Buttons for processing the tag data:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Scan tag (ID)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Read tag data</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Write to the tag</td>
</tr>
<tr>
<td></td>
<td>⑦</td>
<td>Indication of the tag type</td>
</tr>
<tr>
<td></td>
<td>⑧</td>
<td>The editor window contains the tag data. The size of the represented data depends on the tag type.</td>
</tr>
<tr>
<td></td>
<td>⑨</td>
<td>(Start) address (the field can be edited when &quot;Total&quot; is not checked)</td>
</tr>
<tr>
<td></td>
<td>⑩</td>
<td>&quot;Complete&quot; check mark: Indication of the completely selected memory area; all memory areas of the tag are always read or written at once, independent of the memory area currently set.</td>
</tr>
<tr>
<td></td>
<td>⑪</td>
<td>Length of the user area:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The software &quot;RF-MANAGER&quot; contains an additional field for the length of the user area. In this field, you must enter the tag-specific length of the user area.</td>
</tr>
</tbody>
</table>

One memory area of the most recently scanned tag is always shown in the editor. In the drop-down list box [③], you can select and display the different memory areas of the tag. If you check "Complete" [⑩], the current memory area will be displayed complete in the editor, otherwise you can enter values under "Address" [⑨] and "Length" [⑩] to display the relevant data area only.
The "current area"

<table>
<thead>
<tr>
<th>Current area</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Image]</td>
<td>When &quot;Total&quot; is not checked, the area is displayed that is specified in the fields &quot;Address&quot; and &quot;Length&quot;. You can reach the individual addresses using the input pen. If you change the values, they will have a green background. The green background remains until the data are transferred/written to the transponder. The color green therefore indicates that the actual tag data differs from the values visible in the editor. All other data areas of the tag are shown against a white background.</td>
</tr>
</tbody>
</table>

**Memory area ISO 18000-6C (EPC Class1 Gen2)**

- **USER:**
  User data area. Freely available its size or presence is specific to the manufacturer.

- **EPC:**
  Memory area in which the tag ID is stored. The area is read-only.

[Image]
The software "RF-MANAGER"

8.3 Application mode "Mobile"

- **TID:**
  Memory area for tag ID (tag identifier)
  The area is read-only.

- **Reserved:**
  Memory area for access password and kill password
  The area may be read only (manufacturer-specific).

For further information on the detailed structure of the different areas, see "EPCglobal-Specification for RFID Interface" (EPCTM Radio-Frequency Identity Protocols Class-1 Generation-2 UHF RFID Protocol for Communications at 860 MHz - 960 MHz, Version 1.0.9)

**See also**

Acquire data and transfer it to RF-MANAGER (Page 33)
8.3.2.1 Progress and timeout display

The tag functions carry out communication with the transponder. They indicate the progress of the currently executing function and any timeout, if applicable:

Progress display in the case of the tag function

During data transfer, the progress of the executing function is displayed in the form of a bar display:

![Progress display](image)

The tag function is not interrupted if you briefly move the tag out of the read field.

Timeout display in the case of the tag function

If the tag remains unedited for longer than 20 seconds, the function is interrupted and a message window appears:

![Timeout display](image)

You can now stop the command completely with "Yes" or continue it with "No". If you continue, the interrupted command is continued at the point of interruption.
8.3.2.2 Read tag

Note
Distance limits between the tag and the reader

Please observe the maximum distance limits between the reader and the tag when reading a tag. These depend on the:

- Tag type
- Ambient conditions / fixing method of the tag.

Under favorable conditions, the limit distances are 250 cm.
For additional information, see Technical data (Page 97).

Read tag data

If you click the "Read" button in the data editor (or press <Ctrl+R>), you can read the data from the tag. The read-in data appears in the editor.

![Image of data editor]

"Read" button

Reading the data area of a tag

In the data editor, you can use the drop-down list box to select the required memory area of the tag whose data you want to read, and reduce it, if required, by removing the check mark from "Complete" and entering the address and length in the respective fields.

Read complete tag

If all memory areas of the tag are to be completely read or written together, set the check mark for "Complete".

With this function you can display the complete size of the selected memory area.

If the check mark is set for "Complete", "Read all" and "Write all" are displayed on the buttons.
**Note**

**ID check**

It is checked for all tags before any read or write procedure whether the tag ID displayed in the editor corresponds to the ID of the tag that is located in the field of the SIMATIC RF680M. If this is not the case, time-out will be displayed after 20 seconds.

---

**See also**

Settings (Page 80)

---

### 8.3.2.3 Writing to the tag

**Write tag data**

If you click the "Write" button in the data editor (or press <Ctrl+W>), you can write the data that is currently displayed in the editor to the tag.

**Writing the data area of a tag**

In the data editor, you can select the required memory area of the tag in which you want to write data, and reduce it, if required, by removing the check mark from "Complete" and entering the address and length in the respective fields.
Writing the complete tag

If all memory areas of the tag are to be completely read or written together, set the check mark for "Complete".

With this function you can display the complete size of the selected memory area.

If the check mark is set for "Complete", "Read all" and "Write all" are displayed on the buttons.

![Write all](image)

Figure 8-6 "Write All" button

---

**Note**

**ID check**

It is checked for all tags before any read or write procedure whether the tag ID displayed in the editor corresponds to the ID of the tag that is located in the field of the SIMATIC RF680M. If this is not the case, time-out will be displayed after 20 seconds.

---

**See also**

Settings (Page 80)

---

**8.3.3 Overview of functions**

When the RF-MANAGER application starts up, the screen for scanning tags appears on the display. You can then scan tags or call a function from the menu. You can find out from the following table which functions are available in the respective application mode.

---

**Note**

If you want to use the function "Edit Tag" in application mode "Mobile", you must activate this in RF-MANAGER.
## Application mode "Mobile"

<table>
<thead>
<tr>
<th>Function</th>
<th>Remote</th>
<th>Mobile</th>
<th>Edit Tag</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td></td>
<td></td>
<td>X</td>
<td>Load file from the integral PSION &quot;Flash Disk&quot; directory to the work memory.</td>
</tr>
<tr>
<td>Open</td>
<td>-</td>
<td>-</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save Tag</td>
<td>-</td>
<td>-</td>
<td>X</td>
<td>Save read-in tag data to the &quot;Flash Disk&quot; directory.</td>
</tr>
<tr>
<td>Save Tag As</td>
<td>-</td>
<td>-</td>
<td>X</td>
<td>Save read-in tag data to the &quot;Flash Disk&quot; directory.</td>
</tr>
<tr>
<td>Exit</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Exit application.</td>
</tr>
<tr>
<td>Tag</td>
<td></td>
<td></td>
<td>X</td>
<td>Read tag ID</td>
</tr>
<tr>
<td>Scan</td>
<td>-</td>
<td>-</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Write ID</td>
<td>-</td>
<td>-</td>
<td>X</td>
<td>Write the tag ID to a tag</td>
</tr>
<tr>
<td>Read Data</td>
<td>-</td>
<td>-</td>
<td>X</td>
<td>Read tag ID, write tag</td>
</tr>
<tr>
<td>- Read &lt;CTRL+R&gt;</td>
<td>-</td>
<td>-</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Write &lt;CTRL+W&gt;</td>
<td></td>
<td>-</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Functions</td>
<td>-</td>
<td>-</td>
<td>X</td>
<td>Lock data areas on the tag</td>
</tr>
<tr>
<td>Tools</td>
<td></td>
<td></td>
<td>X</td>
<td>Change password for the application</td>
</tr>
<tr>
<td>Password</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Reader status</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Information about the reader</td>
</tr>
<tr>
<td>Language</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Set the menu language</td>
</tr>
<tr>
<td>Settings</td>
<td>-</td>
<td>-</td>
<td>X</td>
<td>Define tag area for reading/writing</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Specify format (editor, data, address, length)</td>
</tr>
<tr>
<td>Help</td>
<td></td>
<td></td>
<td>X</td>
<td>Manufacturer data</td>
</tr>
<tr>
<td>Info</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>
8.3.4 The functions in the "File" menu

8.3.4.1 Overview of file functions

The following file functions are available that you can select in the menu via "File":

- Open (with "Edit Tag" function)
- Save Tag (with "Edit Tag" function)
- Save Tag As (with "Edit Tag" function)
- Exit

![Figure 8-7 The file functions](image)

8.3.4.2 Open

The function is available in the application mode "Mobile" when "Edit Tag" has been activated in RF-MANAGER.

You can load a file via "File > Open" if the file was saved beforehand with the command "File > Save" or if it was transferred from the PC to the "Flash Disk" directory of the SIMATIC RF680M (also see Data transfer between the PC and mobile reader (Page 88)).

All the files of the "Flash Disk" folder are displayed. You can select the desired file via the touchscreen or by entering the filename under "Name" and <OK>. 
8.3.4.3 **Save Tag / Save Tag As**

The functions are available in the application mode "Mobile" when "Edit Tag" has been activated in RF-MANAGER.

Via "File > Save", you can save data currently displayed in the editor of the reader to a file on the SIMATIC RF680M. If you select "Save", the current file will be replaced; if you select "Save Tag As", you can select a new directory or a new file name.

The filename can be up to 100 (alphanumeric) characters in length. XML format is used automatically for saving. Also refer to the Chapter "File storage on the RF680M (Page 87)" as well as "Organization of the .XML files in the Flash Disk directory (Page 90)".

8.3.4.4 **Exit**

You can exit the RF-MANAGER program using "File > Exit" or the <ESC> key. You then reach the WinCE operating system level of the PSION Workabout Pro. You require the password relevant to the application for this, if you have previously assigned one.

---

**Note**

A connection to RF-MANAGER is established as long as the "RF-MANAGER" software is running on the SIMATIC RF680M. On exiting, this connection is closed down.
8.3.5 The functions in the "Tag" menu

8.3.5.1 Overview of tag functions

The following tag functions are available that you can select in the menu via "Tag":

- **Scan (with "Edit Tag" function activated)**
  You can switch to data acquisition by selecting this function (see Acquire data and transfer it to RF-MANAGER (Page 34)).

- **Read Data (with "Edit Tag" function activated)**
  You can switch to the data editor by selecting this function (see The data editor (Page 35)).

- **Write ID (with the "Edit Tag" function activated)**

- **Lock Tag (with the "Edit Tag" function activated)**

- **Kill Tag (with the "Edit Tag" function activated)**

![RF-Manager tag functions](image)

Figure 8-8 RF-Manager tag functions
8.3.5.2 Write ID

You can change the ID of a tag using the function "Write ID".

Select "Tag > Write ID" for this purpose. The following window is displayed.

!["Write ID" window]

Enter ID

Enter the desired ID.

It must be possible to divide number of ID characters by four.

Transferring the ID to the transponder

Click the "OK" button to transfer the ID to the tag.

"Access Password" field

When the tag to be written is protected with an access password, you must enter the password in the "Access Password" field.

Note

Only keep one tag in the scanning range of the SIMATIC RF680M

Ensure that only one tag is in the scanning range of the SIMATIC RF680M when the tag ID is being written. Otherwise, the tag will not be written.
8.3.5.3 Locking data areas

You can lock a tag by means of the "Lock Tag" function.
Select "Tag > Lock Tag..." for this purpose. The following window is displayed.

![Lock Tag Window](image)

In the "Mask" line, you can select the following transponder-specific memory areas:
- "Kill": Kill Password
- "Acc": Access Password For memory areas EPC, TID and user memory
- "EPC": EPC memory
- "TID": TID memory
- "Usr": User memory

"Lock"

The entries under "Mask" determine which function is executed in the action area.

<table>
<thead>
<tr>
<th>Line</th>
<th>Kill PWD</th>
<th>Access PWD</th>
<th>EPC memory</th>
<th>TID memory</th>
<th>User memory</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mask</td>
<td>0/1</td>
<td>0/1</td>
<td>0/1</td>
<td>0/1</td>
<td>0/1</td>
</tr>
<tr>
<td>Action</td>
<td>r/w</td>
<td>p</td>
<td>r/w</td>
<td>w</td>
<td>p</td>
</tr>
</tbody>
</table>

The entry in the "Action" line specifies how the associated memory area will be locked.
The software "RF-MANAGER"

8.3 Application mode "Mobile"

- The identifier "r/w" defines password protection for reading/writing
- The identifier "w" defines password protection for writing (reading is permitted)
- The identifier "p" specifies permanent locking

All the possible combinations of "r/w", "w" and "p" are listed in the table below complete with their significance for the different memory areas.

The tag has the status "Open" when it has been identified (access without password) and "Secured" when its access password has been evaluated.

<table>
<thead>
<tr>
<th>w</th>
<th>p</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>The associated memory area can be written in both the &quot;Open&quot; and &quot;Secured&quot; states.</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>The associated memory area can be permanently written in both the &quot;Open&quot; and &quot;Secured&quot; states and can no longer be locked.</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>The associated memory area can only be written in the &quot;Secured&quot; state, but not in the &quot;Open&quot; state.</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>The associated memory area cannot be written, regardless of the state of the tag.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>r/w</th>
<th>p</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>The associated password area can be read and written in both the &quot;Open&quot; and &quot;Secured&quot; states.</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>The associated password area can be permanently read and written in both the &quot;Open&quot; and &quot;Secured&quot; states and can no longer be locked.</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>The associated password area can be read and written in the &quot;Secured&quot; state, but not in the &quot;Open&quot; state.</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>The associated memory area cannot be read or written, regardless of the state of the tag. This state can be used to protect the passwords on the tag from being read out and overwritten.</td>
</tr>
</tbody>
</table>

**Example**

```
Mask  1  1  1  1  1  0  0  0  0
Action 1  0  1  0  1  0  0  0  0
```

In the above example, the mask bits only enable the actions for the memory areas "Kill password", "Access password" and "EPC memory"; no change is made to the access mechanisms in the TID memory and user memory areas.

The bits assigned to the mask in this example mean:
The software "RF-MANAGER"

8.3 Application mode "Mobile"

- **"Kill password":**
  The kill password can be read and written by the "Secured" state, but not by the "Open" state.
  You must know the access password of the tag to read or write the kill password.

- **"Access password":**
  The access password can be read and written from the "Secured" state, but not from the "Open" state.
  You must know the access password of the tag to read or write the access password.

- **"EPC memory":**
  This memory area can be written from the "Secured" state, but not from the "Open" state.
  You must know the access password of the tag to write a new ID to the tag.

For detailed information, please refer to "EPCglobal-Specification for RFID Interface" (EPCTM Radio-Frequency Identity Protocols Class-1 Generation-2 UHF RFID Protocol for Communications at 860 MHz - 960 MHz, Version 1.0.9).

**Displaying and executing the "Lock Tag..." function**

The current status of the action bit of a tag cannot be scanned. If the specified function cannot be executed, an error message will not be output directly from the tag. In this case, the command will only be terminated after 20 seconds with the time-out. In this case, check the passwords that you have entered and the bits in the mask and action lines carefully before you activate the command again. If the status of the available tag is not known to you, it is highly probable that this command will always result in a time-out.

**8.3.5.4 Kill tag**

You can erase a tag by means of the "Kill Tag..." function.

The prerequisites for this are:

- The tag must have a valid kill password (non-zero)
- The password is entered in the interface in the "Kill Password" field.

Select "Tag > Kill Tag..." for this purpose.
The following window is displayed.

![Kill tag window](image)

Figure 8-11 Kill tag

### 8.3.6 The functions in the "Extras" menu

#### 8.3.6.1 Overview of the Extras functions

The Tools menu contains the following functions that you can select via "Tools":

- Password (application password)
- Reader status
- Language
- Settings (with "Edit Tag" function activated)

![Tools functions](image)

Figure 8-12 The Tools functions
8.3.6.2 Password for the RF-MANAGER application.

As an option, you can assign a password for the RF-MANAGER application.

Select "Tools > Password" from the menu.

1. Enter a password with up to 8 characters under "New Password".
2. Then enter the password again under "Confirm password".
3. Select the "OK" button.

The password is now set. All write functions to a tag are now protected by this password.

If you want to perform a write function now, you must enter the appropriate password. You only have to enter the password once in the case of several consecutive write commands. It will remain valid for 5 minutes after the last write function is executed.

This password is also required to exit the application.

Default password

No password is assigned in the delivery condition.

Note

Forgot password?

If you have forgotten your password, the original status of the device can be restored. See System reset (Page 93)
8.3.6.3 Reader status

Version statuses and settings of the RF600 read/write device can be read out with the "Reader Status" function.

- API version
- Model (US or EU)
- Firmware version of the RFID module.

![Reader Status](Figure 8-14 Reader status)

8.3.6.4 Setting the language

You can set the following menu languages for operating the application:

- English
- German
8.3 Application mode "Mobile"

Procedure for selecting the language

Select the desired language in the "Language selection" window of the "Tools > Language" menu and confirm with "OK".

![Language selection window](image)

Figure 8-15  Language selection window

8.3.6.5  Settings

You can make the following settings using this function

- Specifying the write and read area of a tag
- Setting data formats

Select "Tools > Settings" to parameterize these settings. The "Settings" window opens:

![Settings window](image)

Figure 8-16  Settings window
Settings under "Format"

You can set different formats (for the editor, data, address and length) under "Format" that are explained below.

- **Effect of the "Editor" settings:**
  Byte, binary
  Depending on the format that you select, the interface in the data editor is as depicted below:

<table>
<thead>
<tr>
<th>Presentation in the data editor for the settings</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>&quot;Byte&quot;</strong></td>
</tr>
<tr>
<td><img src="image1" alt="Presentation in bytes" /></td>
</tr>
</tbody>
</table>

- **Effect of the "Data" settings:**
  Hexadecimal, decimal or ASCII number format
  "Hex" or "Dec" presentation format can be recognized in the "Address" and "Length" lines in the data editor.
Effect of the settings under "Address" and "Length"

When the check mark is missing, you can enter decimal data here. If you subsequently set the check mark, the data will be converted into hexadecimal format. Depending on the format setting, the values will be changed in the editor. You can see from the data editor whether "Hex" or "Dec" is activated; for Hex format, "0x" is shown for "Address" and "Length".

<table>
<thead>
<tr>
<th>Hex check mark not activated</th>
<th>Hex check mark activated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address 0</td>
<td>Length 0x0000</td>
</tr>
<tr>
<td>Address 0x0000</td>
<td>Length 0x0000</td>
</tr>
</tbody>
</table>

Settings under "Auto-Save Filename"

Under "Auto-Save Filename" you can define whether the same file with the same name is always updated when scanning tags, or whether new files are saved in each case.
• "READ.XML"
  If the setting "READ.XML" is selected, the same file READ.XML is always updated each
time tag data is read.

• "Tag_xxx.XML"
  If the setting "Tag_xxx.XML" is selected, a new file with the name TAGxxx.XML is created
each time tag data is read. "xxx" is replaced by the ID of the read tag.

  If a tag with the same ID is read again, the corresponding file is overwritten.
  "READ.XML" is set as the default value.

8.3.7 The functions in the "Help" menu

8.3.7.1 Overview of "Help" menu

The "Help" menu contains the following function that you can select via "Help":
"About":

![Figure 8-18 "Help" menu](image)

Using "Help > About" you can obtain information on the following points:

- Information about the device: EU or US version
- Software version
- Manufacturer of the application Siemens AG
The software "RF-MANAGER"

8.3 Application mode "Mobile"
"RF680M" software

9.1 Overview of functions

When the SIMATIC RF680M application starts up, the screen for scanning tags appears on the display. You can then scan tags or call a function from the menu.

<table>
<thead>
<tr>
<th>Function</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open</td>
<td></td>
<td>Load file from the integral PSION &quot;Flash Disk&quot; directory to the work memory.</td>
</tr>
<tr>
<td>Save Tag</td>
<td></td>
<td>Save read-in tag data to the &quot;Flash Disk&quot; directory.</td>
</tr>
<tr>
<td>Save Tag As</td>
<td></td>
<td>Save read-in tag data to the &quot;Flash Disk&quot; directory.</td>
</tr>
<tr>
<td>Save List As</td>
<td></td>
<td>Save list of scanned tag IDs.</td>
</tr>
<tr>
<td>Append List</td>
<td></td>
<td>Append list of scanned tag IDs from a directory.</td>
</tr>
<tr>
<td>Exit</td>
<td></td>
<td>Exit application</td>
</tr>
<tr>
<td>Tag</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scan</td>
<td>&lt;CTRL+S&gt;</td>
<td>Read tag ID</td>
</tr>
<tr>
<td>Write ID</td>
<td></td>
<td>Write the tag ID to a tag</td>
</tr>
<tr>
<td>Read Data</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Read</td>
<td>&lt;CTRL+R&gt;</td>
<td>Read tag data, write tag, copy tag data</td>
</tr>
<tr>
<td>- Write</td>
<td>&lt;CTRL+W&gt;</td>
<td></td>
</tr>
<tr>
<td>- Copy</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lock Tag</td>
<td></td>
<td>Lock data areas on the tag</td>
</tr>
<tr>
<td>Kill Tag</td>
<td></td>
<td>Kill tag</td>
</tr>
<tr>
<td>Tools</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Password</td>
<td></td>
<td>Change password for the application</td>
</tr>
<tr>
<td>Tag Type</td>
<td></td>
<td>Set tag type</td>
</tr>
<tr>
<td>Reader status</td>
<td></td>
<td>Information about the reader</td>
</tr>
<tr>
<td>Reader settings</td>
<td></td>
<td>Setting of the antenna performance and the tag protocol</td>
</tr>
<tr>
<td>Language</td>
<td></td>
<td>Set the menu language</td>
</tr>
<tr>
<td>Settings</td>
<td></td>
<td>Set tag scanning mode (individually or bulk)</td>
</tr>
<tr>
<td>Help</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Info</td>
<td></td>
<td>Manufacturer data</td>
</tr>
</tbody>
</table>

9.2 Start "RF680M" software

To start the RF680M application, click the "RF680M" icon on the desktop.
9.3 The data editor

Prerequisites for working in the data editor

In order to process tag data, a tag must have been scanned by the SIMATIC RF680M device and its tag ID must be indicated in the display. See Chapter Scanning RFID tags and their tag ID (Page 65).

The transponder data can be edited in the editor window in hex, ASCII or decimal format. You can toggle between the two in the "Tools > Settings" menu. (See Settings (Page 80)).

Interface structure of the data editor

<table>
<thead>
<tr>
<th>User interface</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>① Menu bar</td>
<td></td>
<td></td>
</tr>
<tr>
<td>② Indication of the tag ID</td>
<td></td>
<td></td>
</tr>
<tr>
<td>③ Drop-down list box with the transponder-specific memory areas (e.g. EPC, TID, USER) that are displayed in the data field.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>④ Length of the data area (the field can be edited if &quot;Complete&quot; is not checked)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>⑤ Data field</td>
<td>The data can be displayed in either Hex, decimal or ASCII format.</td>
<td></td>
</tr>
<tr>
<td>⑥ Buttons for processing the tag data:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Scan tag (ID)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Read tag data</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Write to the tag</td>
<td></td>
<td></td>
</tr>
<tr>
<td>• Copy data to another tag</td>
<td></td>
<td></td>
</tr>
<tr>
<td>⑦ Indication of the tag type</td>
<td></td>
<td></td>
</tr>
<tr>
<td>⑧ The editor window contains the tag data. The size of the represented data depends on the tag type.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>⑨ (Start) address (the field can be edited when &quot;Total&quot; is not checked)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>⑩ &quot;Complete&quot; check mark: Indication of the completely selected memory area; all memory areas of the tag are always read or written at once, independent of the memory area currently set.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

One memory area of the most recently scanned tag is always shown in the editor. In the drop-down list box [③], you can select and display the different memory areas of the tag. If you check "Complete" [⑩], the current memory area will be displayed complete in the editor, otherwise you can enter values under "Address" [⑨] and "Length" [⑩] to display the relevant data area only.
The "current area"

<table>
<thead>
<tr>
<th>Current area</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td>If &quot;Complete&quot; is not checked, the area is displayed that is specified in the fields &quot;Address&quot; and &quot;Length&quot;. You can reach the individual addresses using the input pen. If you change the values, they will have a green background. The green background remains until the data are transferred/written to the transponder. The color green therefore indicates that the actual tag data differs from the values visible in the editor. All other data areas of the tag are shown against a white background.</td>
</tr>
</tbody>
</table>

Memory area ISO 18000-6C (EPC Class1 Gen2)

- **USER**: User data area. Freely available, its size or presence is specific to the manufacturer.

- **EPC**: Memory area in which, for example, the tag ID is stored. The area is read-only.
9.4 The functions in the "File" menu

- **TID:**
  Memory area for tag ID (tag identifier)
  The area is read-only.

- **Reserved:**
  Memory area for access password and kill password
  The area may be read only (manufacturer-specific).

For further information on the detailed structure of the different areas, see "EPCglobal-Specification for RFID Interface" (EPCTM Radio-Frequency Identity Protocols Class-1 Generation-2 UHF RFID Protocol for Communications at 860 MHz - 960 MHz, Version 1.0.9)

9.4.1 Overview of file functions

The following file functions are available that you can select in the menu via "File":

- Open
- Save Tag
- Save Tag As
9.4 The functions in the “File” menu

- Append List
- Exit

![Figure 9-1 The file functions](image)

9.4.2 Open

You can load a file via "File > Open" if the file was saved beforehand with the command "File > Save" or if it was transferred from the PC to the "Flash Disk" directory of the SIMATIC RF680M (also see Data transfer between the PC and mobile reader (Page 88)).

All the files of the "Flash Disk" folder are displayed. You can select the desired file via the touch screen or by entering the filename under "Name" and <OK>.

9.4.3 Save Tag / Save Tag As

Via "File > Save", you can save data currently displayed in the editor of the reader to a file on the SIMATIC RF680M. If you select "Save", the current file will be replaced; if you select "Save Tag As", you can select a new directory or a new file name.

The filename can be up to 100 (alphanumeric) characters in length. XML format is used automatically for saving. Also refer to the Chapter "File storage on the RF680M (Page 87)" as well as "Organization of the .XML files in the Flash Disk directory (Page 90)".

9.4.4 Save List As

When you have scanned one or more tags, you can save the tag IDs that are currently displayed in the form of a list. Select "File > Save List As" for this purpose. Select a directory and name the file. It will be saved in XML format.

See Chapter Organization of the .XML files in the Flash Disk directory (Page 90)
9.4.5 Append List

When you have already saved a list of scanned tags and you want to expand them, select "File > Append list" in the menu. The old data are not overwritten in this case, but simply added to.

The size of the list is limited to the available storage space.

9.4.6 Exit

You can exit the SIMATIC RF680M program using "File > Exit" or the <ESC> key. You then reach the WinCE operating system level of the PSION Workabout Pro. You require the password relevant to the application for this, if you have previously assigned one.

9.5 The functions in the "Tag" menu

9.5.1 Overview of tag functions

The following tag functions are available that you can select in the menu via "Tag":

- Scan
- Read Data
- Write ID
- Lock Tag
- Kill Tag
- Tag type

![The tag functions](image)

Figure 9-2 The tag functions
9.5.2 Scanning RFID tags and their tag ID

To scan one or more tags and their IDs, click the "Scan" button.

You can also activate the "Scan" function by other means:

- Via the keystroke combination <Ctrl + S>
- Via "Tag > Scan" in the menu, then click the "Scan" button
- Via the white <Scan> buttons mounted on the side of the device. See Chapter Key functions (Page 25) Key(s) ③.

The tag IDs (in Hex) appear in the display:

Only newly scanned tags or their IDs are added, i.e. IDs are not entered twice in the ID list. Depending on the setting mode, you can acquire one or more tags at the same time. For detailed information on scanning mode, see Chapter Settings (Page 80).

The time-out display appears when a tag has not been scanned for 20 seconds.

Archiving scanned tags

To save the list of scanned tags, select "File > Save List As" in the menu.
Further processing of scanned tags

To process the data scanned from a tag, click the "Data" button or select "Tag > Data" from the menu. You can read the tag data, write new data to the tag or copy the tag data.

**Note**

**Tags without tag ID**

If a tag does not have a tag ID, it cannot be scanned and indicated.

9.5.3 Progress and timeout display

The tag functions carry out communication with the transponder. They indicate the progress of the currently executing function and any timeout, if applicable:

Progress display in the case of the tag function

During data transfer, the progress of the executing function is displayed in the form of a bar display:

![Figure 9-5 Progress display](image)

The tag function is not interrupted if you briefly move the tag out of the read field.
Timeout display in the case of the tag function

If the tag remains unedited for longer than 20 seconds, the function is interrupted and a message window appears:

Figure 9-6  Timeout display

You can now stop the command completely with "Yes" or continue it with "No". If you continue, the interrupted command is continued at the point of interruption.

9.5.4 Read tag

Note

Distance limits between the tag and the reader

Please observe the maximum distance limits between the reader and the tag when reading a tag. These depend on the:

- Tag type
- Ambient conditions / fixing method of the tag.

Under favorable conditions, the limit distances are 250 cm. For additional information, see Technical data (Page 97).
Read tag data

If you click the "Read" button in the data editor (or press <Ctrl+R>), you can read the data from the tag. The read-in data appears in the editor.

![Image of the data editor showing read tag data]

"Read" button

Reading the data area of a tag

In the data editor, you can use the drop-down list box to select the required memory area of the tag whose data you want to read, and reduce it, if required, by removing the check mark from "Complete" and entering the address and length in the respective fields.

Read complete tag

If all memory areas of the tag are to be completely read or written together, set the check mark for "Complete".

With this function you can display the complete size of the selected memory area.

If the check mark is set for "Complete", "Read all" and "Write all" are displayed on the buttons.

![Image of the data editor showing complete tag reading]

"Read All" button

Note

ID check

It is checked for all tags before any read or write procedure whether the tag ID displayed in the editor corresponds to the ID of the tag that is located in the field of the SIMATIC RF680M. If this is not the case, time-out will be displayed after 20 seconds.
See also

Settings (Page 80)

9.5.5 Writing to the tag

Write tag data
If you click the "Write" button in the data editor (or press <Ctrl+W>), you can write the data that is currently displayed in the editor to the tag.

Writing the data area of a tag
In the data editor, you can select the required memory area of the tag in which you want to write data, and reduce it, if required, by removing the check mark from "Complete" and entering the address and length in the respective fields.

Writing the complete tag
If all memory areas of the tag are to be completely read or written together, set the check mark for "Complete".

With this function you can display the complete size of the selected memory area.
If the check mark is set for "Complete", "Read all" and "Write all" are displayed on the buttons.
9.5 The functions in the "Tag" menu

**Note**

**ID check**

It is checked for all tags before any read or write procedure whether the tag ID displayed in the editor corresponds to the ID of the tag that is located in the field of the SIMATIC RF680M. If this is not the case, time-out will be displayed after 20 seconds.

**See also**

Settings (Page 80)

**9.5.6 Copying tag data**

You can use this function to transfer data, for example, from one tag to another.

**Procedure for copying data**

To copy data from one tag to another, proceed as follows:

1. Scan the tag ID of the tag from which you want to copy data, as described in the Chapter Scanning RFID tags and their tag ID (Page 65).
2. From the list of tag IDs, select the ID of the transponder whose data you want to copy.
3. Click the "Data" button. The data editor is displayed.
4. Click the "Read" button to display the data of the currently scanned tag in the editor.
5. Click on the "Copy" button:

   ![Copy button image]

6. The window for scanning tags is displayed.
7. Scan the tag to which you want to copy the data.
8. From the list of tag IDs, select the tag (or the ID) onto which you want to copy the data.
9. Click the "Copy" button. The data will be transferred to the tag.
9.5.7 Write ID

You can change the ID of a tag using the function "Write ID".
Select "Tag > Write ID" for this purpose. The following window is displayed.

![Write ID window](image)

**Enter ID**

Enter the desired ID.

It must be possible to divide number of ID characters by four.

**Transferring the ID to the transponder**

Click the "OK" button to transfer the ID to the tag.

**"Access Password" field**

When the tag to be written is protected with an access password, you must enter the password in the "Access Password" field.

---

**Note**

*Only keep one tag in the scanning range of the SIMATIC RF680M*

Ensure that only one tag is in the scanning range of the SIMATIC RF680M when the tag ID is being written. Otherwise, the tag will not be written.

---

9.5.8 Locking data areas

You can lock a tag by means of the "Lock Tag" function.
Select "Tag > Lock Tag..." for this purpose. The following window is displayed.

Figure 9-10  Lock Tag

In the "Mask" line, you can select the following transponder-specific memory areas:
- "Kill": Kill Password
- "Acc": Access Password For memory areas EPC, TID and user memory
- "EPC": EPC memory
- "TID": TID memory
- "Usr": User memory

"Lock"

The entries under "Mask" determine which function is executed in the action area.

<table>
<thead>
<tr>
<th>Line</th>
<th>Kill PWD</th>
<th>Access PWD</th>
<th>EPC memory</th>
<th>TID memory</th>
<th>User memory</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mask</td>
<td>0/1</td>
<td>0/1</td>
<td>0/1</td>
<td>0/1</td>
<td>0/1</td>
</tr>
<tr>
<td>Action</td>
<td>r/w</td>
<td>p</td>
<td>r/w</td>
<td>w</td>
<td>w</td>
</tr>
</tbody>
</table>

The entry in the "Action" line specifies how the associated memory area will be locked.
- The identifier "r/w" defines password protection for reading/writing
- The identifier "w" defines password protection for writing (reading is permitted)
- The identifier "p" specifies permanent locking

All the possible combinations of "r/w", "w" and "p" are listed in the table below complete with their significance for the different memory areas.
The tag has the status "Open" when it has been identified (access without password) and "Secured" when its access password has been evaluated.

<table>
<thead>
<tr>
<th>w</th>
<th>p</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>The associated memory area can be written in both the &quot;Open&quot; and &quot;Secured&quot; states.</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>The associated memory area can be permanently written in both the &quot;Open&quot; and &quot;Secured&quot; states and can no longer be locked.</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>The associated memory area can only be written in the &quot;Secured&quot; state, but not in the &quot;Open&quot; state.</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>The associated memory area cannot be written, regardless of the state of the tag.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>r/w</th>
<th>p</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>The associated password area can be read and written in both the &quot;Open&quot; and &quot;Secured&quot; states.</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>The associated password area can be permanently read and written in both the &quot;Open&quot; and &quot;Secured&quot; states and can no longer be locked.</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>The associated password area can be read and written in the &quot;Secured&quot; state, but not in the &quot;Open&quot; state.</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>The associated memory area cannot be read or written, regardless of the state of the tag. This state can be used to protect the passwords on the tag from being read out and overwritten.</td>
</tr>
</tbody>
</table>

**Example**

<table>
<thead>
<tr>
<th>Mask</th>
<th>Action</th>
<th>Kill PWD</th>
<th>Access PWD</th>
<th>EPC memory</th>
<th>TiD memory</th>
<th>User memory</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 1</td>
<td>1 0</td>
<td>1 1</td>
<td>1 1</td>
<td>1 1</td>
<td>0 0</td>
<td>0 0</td>
</tr>
</tbody>
</table>

In the above example, the mask bits only enable the actions for the memory areas "Kill password", "Access password" and "EPC memory"; no change is made to the access mechanisms in the TiD memory and user memory areas.

The bits assigned to the mask in this example mean:

- **"Kill password"**: The kill password can be read and written by the "Secured" state, but not by the "Open" state. You must know the access password of the tag to read or write the kill password.

- **"Access password"**: The access password can be read and written from the "Secured" state, but not from the "Open" state. You must know the access password of the tag to read or write the access password.

- **"EPC memory"**: This memory area can be written from the "Secured" state, but not from the "Open" state. You must know the access password of the tag to write a new ID to the tag.
For detailed information, please refer to "EPCglobal-Specification for RFID Interface" (EPC™ Radio-Frequency Identity Protocols Class-1 Generation-2 UHF RFID Protocol for Communications at 860 MHz - 960 MHz, Version 1.0.9)

**Displaying and executing the "Lock Tag..." function**

The current status of the action bit of a tag cannot be scanned. If the specified function cannot be executed, an error message will not be output directly from the tag. In this case, the command will only be terminated after 20 seconds with the time-out. In this case, check the passwords that you have entered and the bits in the mask and action lines carefully before you activate the command again. If the status of the available tag is not known to you, it is highly probable that this command will always result in a time-out.

**9.5.9 Kill tag**

You can erase a tag by means of the "Kill Tag..." function.

The prerequisites for this are:

- The tag must have a valid kill password (non-zero)
- The password is entered in the interface in the "Kill Password" field.

Select "Tag > Kill Tag..." for this purpose.

The following window is displayed.

![Kill Tag Window](image-url)
9.5.10 Tag Type Selection

If you want to select the tag type, proceed as follows:

Select "Tools > Tag Type".

The following window is displayed.

![Tag Type Selection Window](image)

Figure 9-12 Window for tag type selection

Different types of tag are supported:

<table>
<thead>
<tr>
<th>Tag type 1)</th>
<th>Corresponding exemplary RF600 tags</th>
</tr>
</thead>
<tbody>
<tr>
<td>EPC.Gen2.(ISO18000-6C)</td>
<td>RF630L&lt;br&gt;RF620T</td>
</tr>
<tr>
<td>EPC.Gen2.240Bit</td>
<td>RF680T&lt;br&gt;RF630L_03&lt;br&gt;RF640T_GEN2</td>
</tr>
</tbody>
</table>

1) Siemens tags can be selected directly.

For non-Siemens tags, the corresponding tag type is available for selection.

For Gen 2 tags, you must also configure the size of the "user memory". Please refer to the technical tag information of the relevant manufacturer for this purpose.

You can directly select SIMATIC RF600 tags, see the window "Tag type selection"
Select the corresponding tag. The following window appears:

![Tag Type Selection](image)

Figure 9-13  Enter user memory
9.6 The functions in the "Extras" menu

9.6.1 Overview of the Extras functions

The Tools menu contains the following functions that you can select via "Tools":

- Password (application password)
- Reader status
- Reader settings
- Settings
- Language

![Image of the Tools functions menu]

Figure 9-14 The "Tools" functions
9.6.2 Password for the SIMATIC RF680M application

As an option, you can assign a password for the SIMATIC RF680M application.

Select "Tools > Password" from the menu.

1. Enter a password with up to 8 characters under "New Password".
2. Then enter the password again under "Confirm password".
3. Select the "OK" button.

The password is now set. All write functions to a tag are now protected by this password.

If you want to perform a write function now, you must enter the appropriate password. You only have to enter the password once in the case of several consecutive write commands. It will remain valid for 5 minutes after the last write function is executed.

This password is also required to exit the application.

Default password

No password is assigned in the delivery condition.

Note

Forgot password?

If you have forgotten your password, the original status of the device can be restored. See System reset (Page 93)
9.6.3 Reader status

Version statuses and settings of the RF600 read/write device can be read out with the "Reader Status" function.

- API version
- Model (US or EU)
- Firmware version of the RFID module.

![Reader Status](image)

Figure 9-16 Reader status

9.6.4 Reader settings

With the "Reader settings ..." function you can make the following settings:

- Change the reader's antenna performance
- Set the modulation pattern of the radio profile
- "Initial Q" value setting. This value defines the number of tags expected to be in the measuring field at the same time. A suitable selection permits a faster detection of tags in the field by the reader.

The following relation applies:

\[ 2^{\text{Initial Q}} = \text{number of expected tags}. \]

- Select the transmit channel for the European radio profile (ETSI).

Select "Tools > Reader Settings ..." to parameterize these settings.
The "Reader Settings" window opens:

![Reader Settings Window](image)

**9.6.5 Settings**

You can make the following settings using this function:

- Setting scan mode
- Specifying the write and read area of a tag
- Setting data formats.

Select "Tools > Settings" to parameterize these settings. The "Settings" window opens:

![Settings Window](image)
9.6 The functions in the "Extras" menu

Settings in "Scan mode"

Here, you can choose between single tag and bulk scanning.

- With "Single Tag", the tags are only scanned until a tag ID is detected.
- With "Bulk", the device will constantly try to scan additional tag IDs (until time-out or manual interruption of the command).

This setting is appropriate, for example, if you are searching for a specific tag in a field that contains several tags.

Settings under "Format"

You can set different formats (for the editor, data, address and length) under "Format" that are explained below.

- **Effect of the "Editor" settings:**
  Byte, binary
  Depending on the format that you select, the interface in the data editor is as depicted below:

<table>
<thead>
<tr>
<th>Presentation in the data editor for the settings</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>&quot;Byte&quot;</strong></td>
</tr>
<tr>
<td><img src="image1.png" alt="Presentation in bytes" /></td>
</tr>
<tr>
<td><strong>&quot;Binary&quot;</strong></td>
</tr>
<tr>
<td><img src="image2.png" alt="Presentation with &quot;0&quot; and &quot;1&quot;" /></td>
</tr>
</tbody>
</table>

- **Effect of the "Data" settings:**
  Hexadecimal, decimal or ASCII number format
  "Hex" or "Dec" presentation format can be recognized in the "Address" and "Length" lines in the data editor.
9.6 The functions in the "Extras" menu

- Effect of the settings under "Address" and "Length"
  If there is no check mark, you can also enter decimal data here. If you subsequently set
  the check mark, the data will be converted into hexadecimal format. Depending on the
  format setting, the values will be changed in the editor.
  You can see from the data editor whether "Hex" or "Dec" is activated; for Hex format, "0x"
  is shown for "Address" and "Length":

<table>
<thead>
<tr>
<th>Hex check mark not activated</th>
<th>Hex check mark activated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display in the editor</td>
<td></td>
</tr>
<tr>
<td>Address 0000 45 46 47</td>
<td>Address 0x 0000 45 46 47</td>
</tr>
<tr>
<td>Length 0000 40</td>
<td>Length 0x 0000 40</td>
</tr>
</tbody>
</table>

Settings under "Auto-Save Filename"

Under "Auto-Save Filename" you can define whether the same file with the same name is
always updated when scanning tags, or whether new files are saved in each case.

Figure 9-19 Auto-Save Filename
9.6 The functions in the "Extras" menu

- "READ.XML"
  If the setting "READ.XML" is selected, the same file README.XML is always updated each time tag data is read.

- "Tag_xxx.XML"
  If the setting "Tag_xxx.XML" is selected, a new file with the name TAGxxx.XML is created each time tag data is read. "xxx" is replaced by the ID of the read tag.
  If a tag with the same ID is read again, the corresponding file is overwritten.
  "READ.XML" is set as the default value.

See also

The data editor (Page 60)

9.6.6 Setting the language

You can set the following menu languages for operating the application:
- English
- German

Procedure for selecting the language

Select the desired language in the "Language selection" window of the "Tools > Language" menu and confirm with "OK".

Figure 9-20 Language selection window
9.7 The functions in the "Help" menu

9.7.1 Overview of "Help" menu

The "Help" menu contains the following function that you can select via "Help": "About":

![About RF680M](image)

Using "Help > About" you can obtain information on the following points:

- Information about the device: EU or US version
- Software version
- Manufacturer of the application Siemens AG

9.8 Application example

Typical application cases for SIMATIC RF680M are shown below.

Starting the software

To start the SIMATIC RF680M application, click the "RF680M" icon on the desktop.

Setting the language of the SIMATIC RF680M application

Select the desired language in the "Language selection" window of the "Tools > Language" menu and confirm with "OK".
Prerequisites for working with transponders: Set tag type

Select the appropriate transponder type using "Tools > Tag Type".

Confirm with <OK>.

Scan tag

To scan the tag and its ID, press the white <Scan> key on the side of the device or click the "Scan" button on the display. The following window is displayed.

To read, write or copy the tag data, click the "Data" button.
Save tag ID list

To save the list of all scanned tags, select "File > Save List As" in the menu. Select a directory and name the file. It will be saved in XML format.

Read tag

To read the data of the scanned tag, select the "Read" button in the data editor (or <Ctrl+R>). The read-in data appears in the editor.

Write to the tag

When writing data to the scanned tag, the data that is currently displayed in the editor is written to the tag. Click the "Write" button in the data editor for this purpose (or <Ctrl+W>).

Copying tag data

See Chapter "Copying tag data (Page 70)".
Advanced functions

When you are using the SIMATIC RF680M as a stand-alone product or in "Mobile" operating mode (configured as editable through the "Edit Tag" function in RF-MANAGER), you can use the extended functions of the SIMATIC RF680M that are described below.

10.1 File storage on the RF680M

Storing the read tag data using the data editor

The data read from the tag are automatically stored on the mobile reader to a file with the name "READ.xml" in the "Flash Disk" directory.

Every subsequent read command overwrites this file.

Length of the written tag data

When writing to the tag, the write data are written from the Editor to the tag and also to the "Flash Disk" folder of the mobile reader under the name "WRITE.xml". Every subsequent write command overwrites this file.

Display Files

The function "File > Open" shows all files with the extension ".xml". You can select one of these. This file is then loaded into the Editor. The file is not saved with the name READ.xml or WRITE.xml.

Save files

The function "File > Save / Save Tag As" saves the data from the Editor to a file with the extension ".xml" in the "Flash Disk" directory of the reader. You can enter any name with 1 to 8 alphanumeric characters.

---

Note

When you read the data from the tag, modify them in the Editor and then save them, the modified data are saved to the .xml file.
10.2 Data transfer between the PC and mobile reader

10.2.1 Prerequisites
If you want to access the supplied files and documentation, please note the following prerequisites:

- USB driver for PSION Workabout Pro
- You will find the USB driver
  - of PSION (http://www.psiontekblogix.com).
  - On the CD "RFID Systems Software & Documentation" (Order No. 6GT2080 2AA10, as of 07/2007 Edition)
- The "Active Sync" program from Microsoft
  You can download the current version of Microsoft Active Sync from the Internet at Microsoft homepage (http://www.microsoft.com).
- A USB cable for connecting the PC to the SIMATIC RF680M (included in the scope of supply of the docking station)

10.2.2 Working with the Active Sync program
The ActiveSync program provides a connection via the USB to RF680M. You can now copy data and programs very easily in the manner familiar from Explorer. You only have to select the point "Mobile Device" in Explorer. It is also possible to access ActiveSync directly from the SIMATIC RF680M device.

Requirements for opening the RF680M workstation

- The USB driver for the PSION Workabout Pro is installed.
- The Active Sync program from Microsoft is installed.
- The SIMATIC RF680M is connected to the PC in the docking station and via the USB cable.
Opening the RF680M workstation via Explorer and Mobile Device:

Select "Mobile Device" in Explorer:

![Figure 10-1 Opening the RF680M workstation via Explorer](image1)

Then select the "Flash Disk" folder.

Opening the RF680M workstation via ActiveSync and "Explore"

Select the button "Explore" (button for German installation: "Durchsuchen") to access ActiveSync on the device.

![Figure 10-2 Access to the SIMATIC RF680M device via Active Sync "Explore"](image2)
Advanced functions

10.2 Data transfer between the PC and mobile reader

Opening the RF680M workstation / "Flash Disk" directory

Then select the "Flash Disk" directory and open it:

```
<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Type</th>
<th>Modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flash Disk</td>
<td>23 bytes</td>
<td>Shortcut</td>
<td>09.10.2007 12:01:06</td>
</tr>
<tr>
<td>Microsoft .NET CF 2.0...</td>
<td>7,23KB</td>
<td>Text Document</td>
<td>09.10.2007 12:01:06</td>
</tr>
<tr>
<td>Application Data</td>
<td></td>
<td>File Folder</td>
<td></td>
</tr>
<tr>
<td>SIMATIC RF680M</td>
<td></td>
<td>File Folder</td>
<td></td>
</tr>
<tr>
<td>680_300_000_101_6_H066p.pdf</td>
<td>2,33MB</td>
<td>PDF-File</td>
<td>02.11.2010 12:56:26</td>
</tr>
<tr>
<td>READ.XML</td>
<td>1,0KB</td>
<td>XML Document</td>
<td>02.11.2010 12:52:28</td>
</tr>
<tr>
<td>WRITE.xml</td>
<td>1,0KB</td>
<td>XML Document</td>
<td>27.10.2010 14:24:42</td>
</tr>
</tbody>
</table>
```

Figure 10-3  Select the Flash Disk folder

The following window is displayed.

```
<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Type</th>
<th>Modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documents and Settings</td>
<td></td>
<td>File Folder</td>
<td></td>
</tr>
<tr>
<td>SIMATIC RF680M</td>
<td></td>
<td>File Folder</td>
<td></td>
</tr>
<tr>
<td>680_300_000_101_6_H066p.pdf</td>
<td>2,33MB</td>
<td>PDF-File</td>
<td>02.11.2010 12:56:26</td>
</tr>
<tr>
<td>READ.XML</td>
<td>1,0KB</td>
<td>XML Document</td>
<td>02.11.2010 12:52:28</td>
</tr>
<tr>
<td>WRITE.xml</td>
<td>1,0KB</td>
<td>XML Document</td>
<td>27.10.2010 14:24:42</td>
</tr>
</tbody>
</table>
```

Figure 10-4  Flash disk folder

There you will find the file "READ.XML" and the files you have stored with the extension ".XML". You can now drag and drop or copy these files from the drive of the RF680M to the PC drive.

The contents of the file can now be displayed and modified using the relevant editor on the PC.

You can use any editor to display the XML structure: Notepad, Write, Microsoft Word or Microsoft Internet Explorer.

10.2.3 Organization of the .XML files in the Flash Disk directory

The XML structure for the stored "Tag data" as well as the tag ID list is shown below.
### XML Structure of the Read or Written Tag Data

```xml
<xml version="1.0" encoding="utf-8" ?>
  <tag xmlns:tag="urn:com:siemens:simaticrfm610m:1" tagId="30112234+3366778099AAC0" tagTypeName="User">
    <bank name="USER!" userDefined="true">
      <items>
        <item>
          <tagAddress>0</tagAddress>
          <value1>0</value1>
          <value2>0</value2>
          <value3>0</value3>
          <value4>0</value4>
          <changeMask>0</changeMask>
        </item>
        <item>
          <tagAddress>4</tagAddress>
          <value1>0</value1>
          <value2>0</value2>
          <value3>0</value3>
          <value4>0</value4>
          <changeMask>0</changeMask>
        </item>
        <item>
          <tagAddress>8</tagAddress>
          <value1>0</value1>
          <value2>0</value2>
          <value3>0</value3>
          <value4>0</value4>
          <changeMask>0</changeMask>
        </item>
        <item>
          <tagAddress>12</tagAddress>
          <value1>0</value1>
          <value2>0</value2>
          <value3>0</value3>
          <value4>0</value4>
          <changeMask>0</changeMask>
        </item>
      </items>
    </bank>
    + <bank name="ERP!">
    + <bank name="TID!">
    + <bank name="Reserved">
    </bank>
  </tag>
</xml>
```

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Selected tag type</td>
</tr>
<tr>
<td>2</td>
<td>Tag ID</td>
</tr>
<tr>
<td>3</td>
<td>Data area of the tag</td>
</tr>
<tr>
<td>4</td>
<td>Start address of a 4-byte block (decimal format)</td>
</tr>
<tr>
<td>5</td>
<td>Value of the 4 bytes of a data area (decimal format).</td>
</tr>
<tr>
<td></td>
<td>- Value 1 = Start address + 1</td>
</tr>
<tr>
<td></td>
<td>- Value 2 = Start address + 2</td>
</tr>
<tr>
<td></td>
<td>- Value 3 = Start address + 3</td>
</tr>
<tr>
<td>6</td>
<td>These values are hidden in this example with &quot;Internet Explorer&quot;; by clicking on the &quot;+&quot; character, the view that is used for the &quot;User&quot; data area can be displayed.</td>
</tr>
</tbody>
</table>
Advanced functions

10.2 Data transfer between the PC and mobile reader

XML structure of the tag ID list

```xml
<?xml version="1.0" encoding="utf-8" ?>
<scanList xmlns:scanList="urn:com:siemens:simatic:hmi:rf610m:1" readerName="SIMATIC RF610M EU">
  <tagIdLists>
    <tagIdList deviceType="RF610M" tagTypeName="Gen2">
      <tagIds>
        <string>30112233445566778899AAG0</string>
        <string>30112233445566778899AA0B</string>
      </tagIds>
    </tagIdList>
    <tagIdList deviceType="RF610M" tagTypeName="Gen2">
      <tagIds>
        <string>30112233445566778899AC0D</string>
        <string>30112233445566778899AC0E</string>
      </tagIds>
    </tagIdList>
  </tagIdLists>
</scanList>
```

1. Structure that has arisen from the initial "Save List". Two tags are read.
2. Device
3. Tag type
4. Tag ID
5. Structure that has arisen from the second save of "Append List". Three tags are read.

Presenting the XML file in Excel

You can also open the XML file with Excel to obtain a tabular display:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>readerName</td>
<td>deviceType</td>
<td>tagTypeName</td>
<td>string</td>
</tr>
<tr>
<td>2</td>
<td>SIMATIC RF610M EU</td>
<td>RF610M</td>
<td>Gen2</td>
<td>30112233445566778899AAG0</td>
</tr>
<tr>
<td>3</td>
<td>SIMATIC RF610M EU</td>
<td>RF610M</td>
<td>Gen2</td>
<td>30112233445566778899AA0B</td>
</tr>
<tr>
<td>4</td>
<td>SIMATIC RF610M EU</td>
<td>RF610M</td>
<td>Gen2</td>
<td>30112233445566778899AC0D</td>
</tr>
<tr>
<td>5</td>
<td>SIMATIC RF610M EU</td>
<td>RF610M</td>
<td>Gen2</td>
<td>30112233445566778899AC0E</td>
</tr>
<tr>
<td>6</td>
<td>SIMATIC RF610M EU</td>
<td>RF610M</td>
<td>Gen2</td>
<td>30112233445566778899AC0D</td>
</tr>
</tbody>
</table>

Figure 10-5  XML file in Excel
10.3 The automatic power-saving function

The SIMATIC RF680M has an automatic shutdown function. This is activated if no key on the reader is pressed for approximately three minutes.

In addition, the "SIMATIC RF680M" software has a further power-saving function. If no tag is detected for 20 seconds after starting a tag command, or if the tag currently being edited exits the field for longer than 20 seconds, the current tag command is interrupted. The following message appears (see also Progress and timeout display (Page 66):

![Timeout display](image)

You can now stop the command completely with "Cancel" or continue it with "Retry". If you continue, the interrupted command is continued at the point of interruption.

10.4 System reset

After inserting the batteries and switching on for the first time, the reader carries out a system reset. This reset is the same as a hardware reset.

A system reset can also be performed manually.

The saved back-up status of the device can be restored.

Requirements for the system reset:

- The "Flash Disk" directory contains the backup file with the extension *.pfl
- The devices must be in the "Supervisor" operating mode. See Operating modes (Page 22).
Performing a system reset and importing a back-up file

You can activate a system reset via "Start > Shutdown > Cold Reset". The most recently saved back-up file will then be copied back in. Please note that during a "Cold Reset", the device restarts twice.

To restore a backup, replace all the data in the "FlashDisk" directory with your backup copy and then run a system reset.

Note

Data retention and data loss during system reset

When you perform a system reset, only the saved data in the flash memory are retained ("Flash Disk" directory). All other data in RAM (e.g. in the "Application Data" folder) is lost.

Note

Restoring the delivery status of the device

If you want to restore the delivery status of the device, delete the self-stored files in the "Flash Disk" directory, especially the self-created back-up files with the ending *.pfl.

Ensure that the "Flash Disk" directory still contains the files that were supplied on delivery (especially the files with the ending *.pfl). Otherwise, you will have to copy in the files that were backed up on initial commissioning again.
## Troubleshooting

<table>
<thead>
<tr>
<th>Problem</th>
<th>Possible cause</th>
<th>Problem recovery</th>
</tr>
</thead>
<tbody>
<tr>
<td>The display goes blank when reading/writing.</td>
<td>The battery or the batteries of the reader are empty.</td>
<td>Insert the device into the charging and docking station or insert new batteries.</td>
</tr>
<tr>
<td>The display is blank after switching on.</td>
<td>The battery or the batteries are empty.</td>
<td>Insert the device into the charging and docking station or insert new batteries.</td>
</tr>
<tr>
<td>Error messages appear that are not defined anywhere.</td>
<td></td>
<td>Remove the batteries from the basic unit and re-insert them after 60 s. The device now has the delivery status. If the error persists, the device may have a defect.</td>
</tr>
<tr>
<td>The tag ID of a tag is not scanned and does not appear in the list on the display.</td>
<td>The tag has no tag ID.</td>
<td>Use the tags that already have an ID.</td>
</tr>
<tr>
<td>The supervisor password is not known.</td>
<td></td>
<td>Restore the factory state. See Chapter System reset (Page 93).</td>
</tr>
<tr>
<td>The password for the write commands of the SIMATIC RF680M application has been forgotten.</td>
<td></td>
<td>Copy in the most recent back-up.</td>
</tr>
<tr>
<td>The tag at the read head is not read.</td>
<td>The EPC tag has not been initialized.</td>
<td>The tag must be initialized.</td>
</tr>
<tr>
<td></td>
<td>The tag is defective.</td>
<td>Use a different/new tag.</td>
</tr>
<tr>
<td></td>
<td>The tag is too far away from the read head.</td>
<td>Reduce the distance between the read head and the tag. Please observe the limit distances between the reader and tags. Refer to the limit distances in Chapter Technical data (Page 97).</td>
</tr>
<tr>
<td></td>
<td>The frequency ranges of tag and reader do not match. (US; EU)</td>
<td>Use a transponder that suits the RF680M read head.</td>
</tr>
<tr>
<td></td>
<td>The orientation of the tag antenna does not comply with the alignment of the reader antenna.</td>
<td>Ensure correct alignment of the transponder antenna and reader antenna. See Antenna and antenna field (Page 14).</td>
</tr>
<tr>
<td>The “Function …” command (e.g. Write) was not performed on the tag that is situated in the field.</td>
<td>The “Secured” state or a password have been set on the tag</td>
<td>You can only perform the “Function …” command when you know the exact status of the tag. It is not possible to read out the status of the tag.</td>
</tr>
</tbody>
</table>
### Technical data

<table>
<thead>
<tr>
<th>Specification</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>Intel XScale PXA270- 624 MHz, ARM</td>
</tr>
<tr>
<td>RAM</td>
<td>256 MB</td>
</tr>
<tr>
<td>ROM</td>
<td>1 GB Flash ROM</td>
</tr>
<tr>
<td>User program</td>
<td>RF680M.exe</td>
</tr>
<tr>
<td>Screen</td>
<td>Color Touch Display, 480 x 640 pixels, portrait</td>
</tr>
<tr>
<td>Keypad</td>
<td>Alphanumerical</td>
</tr>
<tr>
<td>Sound</td>
<td>Piezo signal transmitter</td>
</tr>
<tr>
<td>Power supply</td>
<td>Lithium-ion battery (3.7 V; 3300 mAh) for rapid charging; automatic switch-off</td>
</tr>
<tr>
<td>Interfaces</td>
<td>LIF interface (low insertion force interface) for battery charging and communication with PC (USB)</td>
</tr>
<tr>
<td>Operating system</td>
<td>Microsoft Windows Embedded CE 5.0</td>
</tr>
<tr>
<td>File management</td>
<td>MS-DOS-compatible</td>
</tr>
<tr>
<td>Technical specifications</td>
<td>Complete unit (incl. rechargeable batteries)</td>
</tr>
<tr>
<td>Dimensions</td>
<td>265 x 100 x 42 mm</td>
</tr>
<tr>
<td>Weight</td>
<td>Approx. 600 g</td>
</tr>
<tr>
<td>Temperature</td>
<td>Operation -20 °C to +50 °C</td>
</tr>
<tr>
<td></td>
<td>Storage -40 °C to +60°C (without battery)</td>
</tr>
<tr>
<td>Relative humidity</td>
<td>5% to 95%, no condensation</td>
</tr>
<tr>
<td>Degree of protection</td>
<td>IP65, IEC 60529 (splashproof)</td>
</tr>
<tr>
<td>EMC</td>
<td>EN55022; EN301489; EN55024</td>
</tr>
<tr>
<td>Safety</td>
<td>CSA/UL60950-1; IEC60950-1, EN60950-1</td>
</tr>
<tr>
<td>RF</td>
<td>EN 300 220; FCC Part 15</td>
</tr>
<tr>
<td>Transmission frequency</td>
<td>EU: 865.6...867.6 MHz</td>
</tr>
<tr>
<td></td>
<td>USA: 902 to 928 MHz</td>
</tr>
<tr>
<td>Transmit power</td>
<td>Max. 500 mW</td>
</tr>
<tr>
<td>Compatibility</td>
<td>With all SIMATIC RF600 data carriers (tags)</td>
</tr>
<tr>
<td>Read/write distance to transponder</td>
<td>Max. 250 cm</td>
</tr>
</tbody>
</table>
### Ordering data

<table>
<thead>
<tr>
<th>Component</th>
<th>Order No.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mobile reader SIMATIC RF680M with integrated RFID read/write unit for RF600</td>
<td>ETSI: 6GT2813-0BC00 FCC: 6GT2813-0BC10</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Accessories</th>
<th>Order No.</th>
</tr>
</thead>
<tbody>
<tr>
<td>SIMATIC RF reader charging/docking station.</td>
<td>6GT2898-0BA00</td>
</tr>
<tr>
<td>SIMATIC RF WLAN module for mounting on RF680M</td>
<td>6GT2898-0DA00</td>
</tr>
<tr>
<td>SIMATIC RF barcode scanner for mounting on RF680M</td>
<td>6GT2898-0DB00</td>
</tr>
<tr>
<td>Replacement battery 3300 mAh</td>
<td>6GT2898-0CA00</td>
</tr>
<tr>
<td>CD &quot;RFID Systems Software &amp; Documentation&quot;</td>
<td>6GT2080-2AA10</td>
</tr>
</tbody>
</table>
Appendix

A.1 Certificates and approvals

<table>
<thead>
<tr>
<th>Certificates and approvals</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Certificates</td>
<td>CE approval to R&amp;TTE</td>
</tr>
<tr>
<td>Approvals</td>
<td>FCC Federal Communications Commission GM3UHFCA3A5</td>
</tr>
</tbody>
</table>

A.2 Ordering components for advanced functions

The advanced functions of the SIMATIC RF680M reader require additional components from PSION Teklogix that are not supplied by Siemens.

If you require these components for your application, please contact PSION direct or its representative in your country. Addresses and ordering lists of PSION can be found on the Internet at PSION homepage (http://www.psionteklogix.com).

You can also find the PSION agent in your country at this Internet address.

In Germany, PSION components are supplied by WAROK (Tel. -49 7721/202630).

A.3 Developing user applications

User applications require the SDK development package from PSION (PSION Teklogix Mobile Devices SDK for MS Visual Studio, Microsoft and Visual Studio 2005).

You will find further details in the function manual for SIMATIC RF680M that is also saved in the "Flash Disk" directory of the RF680M.

A.4 Service & support

Contact partner

If you have any further questions on the use of our products, please contact one of our representatives at your local Siemens office.
Appendix
A.4 Service & support

The addresses are found on the following pages:

- In Internet (http://www.siemens.com/automation/partner)
- In Catalog CA 01
- In Catalog ID 10 specifically for industrial communication / industrial identification systems

Technical Support

You can access technical support for all IA/DT projects via the following:

- Phone: + 49 (0) 911 895 7222
- Fax: + 49 (0) 911 895 7223
- E-mail (mailto:support.automation@siemens.com)
- Internet: Online support request form: (http://www.siemens.com/automation/support-request)

Service & support for industrial automation and drive technologies

You can find various services on the Support homepage (http://www.siemens.com/automation/service&support) of IA/DT on the Internet.

There you will find the following information, for example:

- Our newsletter containing up-to-date information on your products.
- Relevant documentation for your application, which you can access via the search function in "Product Support".
- A forum for global information exchange by users and specialists.
- Your local contact for IA/DT on site.
- Information about on-site service, repairs, and spare parts. Much more can be found under "Our service offer".

RFID homepage

For general information about our identification systems, visit RFID homepage (http://www.siemens.com/ident).

Technical documentation on the Internet

A guide to the technical documentation for the various products and systems is available on the Internet:

SIMATIC Guide manuals (http://www.siemens.com/simatic-tech-doku-portal)

Online catalog and ordering system

The online catalog and the online ordering system can also be found on the Industry Mall Homepage (http://www.siemens.de/industrial-controls/mall).
Training center

We offer appropriate courses to get you started. Please contact your local training center or the central training center in D-90327 Nuremberg.

Phone: +49 (0) 180 523 56 11
(€ 0.14 /min. from the German landline network, deviating mobile communications prices are possible)

For information about courses, see the SITRAIN homepage (http://www.sitrain.com).
Glossary

API
Application Programming Interface (programming interface)

Byte
A group of eight bits form a byte.

CE mark
Communauté Européenne (product mark of the European Union)

EPC
Electronic product code

MDS
Mobile data memory (see transponder)

RAM
Random Access Memory

Read/write devices (SLG)
See readers

Readers
Readers ensure fast, secure data transfer between mobile data storage units and higher-level systems. The data, energy included, are transmitted across an electromagnetic alternating field. This principle enables contact-free data transmission, ensures high industrial compatibility and works reliably in the presence of contamination or through non-metallic materials.

RFID
Radio Frequency Identification
**RFID systems**

SIMATIC RF identification systems control and optimize material flow and production sequences. They identify reliably, quickly and economically, use non-contact data communication technology, and store data directly on the product. They are also resistant to contamination.

**Tag**

See transponder

**TID**

Transponder identification number

**Transponder**

An invented word from transmitter and responder. Transponders are used on the product, the product carrier, the object, or its transport or packaging unit, and contain production and manufacturing data, i.e. all application-specific data. They follow the product through assembly lines, transfer and production lines and are used to control material flow.

Because of their wireless design, transponders can be used, if necessary, at individual work locations or manufacturing stations, where their data can be read and updated.
Index

A
Accessories, 13, 99
ActiveSync, 89
Application example, 84
Automatic shutdown, 20
Automatic switching off, 20

B
Backlighting, 23
Backup battery, 18
Battery
   Charging, 18
   Inserting, 17
   Level of charge, 18

C
Charging
   Battery, 18
Contact partner, 101
Conventions, 7
Copying
   Tag data, 70
Courses, 103
Creating a back-up copy, 20
Current area, 37, 61

D
Data editor
   Interface structure, 36, 60
Data transfer
   Reader - PC, 88
Delivery status
   Restore, 93
Design
   SIMATIC RF680M, 13
Directories, 87
Display
   Progress, 39, 66
   Timeout, 39, 67

E
Exit, 45, 64

F
Features
   SIMATIC RF680M, 11
File
   Downloading, 63
   Exit, 45, 64
   Loading, 44
   Save, 45, 63
File functions
   Overview, 44, 62
File storage, 87
Function, 57, 84
Functions
   Overview, 12
   SIMATIC RF680M, 12
Functions with RF680M
   Overview, 59
Functions with RF-MANAGER
   Overview, 42
Further information, 7

H
High-frequency field
   Direction of propagation, 14

I
ID check, 42, 70

K
Key combinations, 59
Key functions, 25

L
Language selection, 54, 83
LED
Index

Charge indicator, 13
Level of charge, 18
List, 63
List tag ID, 63

Reader status, 53, 79
Recommendations for first commissioning, 20
Remote, 33
  Mode, 33

S
Save, 45, 63
Scan
  Of tags, 65
Scan mode, 80
Scope of supply, 19
Set menu language, 54, 83
Settings
  Format, 54, 80
  Read and write area, 54, 80
  Tag scanning mode, 80
Shift keys, 26
Shortcuts, 59
Software
  Overview, 27
Start "RF680M" software,
Starting the software "RF-MANAGER",
Switching on the device, 20
System reset, 93

T
Tag
  Copying data, 70
Tag functions
  Overview, 46, 64
Tag ID
  Read, 65
  Write, 47, 71
Tag standards, 11
Tag type
  Set, 75
Tags
  Scan, 65
Technical documentation
  On the Internet, 102
Technical specifications, 97
Technical Support, 102
Tools functions
  Overview, 51, 77
Training, 103
Troubleshooting, 95

P
Password
  For locking data areas, 49, 72
  For the operating system, 21
  For the RF-MANAGER application, 52
  For the SIMATIC RF680M application, 78
Password protection, 12
Passwords
  Overview, 12
Performing a back-up, 21
Power supply, 17
power-saving function, 93
Problem handling, 95
Progress display, 39, 66
PSION workstation, 89

R
Read
  Tag data, 40, 67
  Tag ID, 65
Read head, 14
Read tag, 40, 68

M
Mobile
  Operating mode, 34

O
ON/OFF button, 20
Open
  via Mobile Device, 89
  via PSION workstation, 89
Operating mode, 22
  Mobile, 34
  Remote, 33
Order numbers, 99
Ordering data, 99
Accessories, 99
Overview
  Functions with RF680M, 59
  Functions with RF-MANAGER, 42

J31069-D0241-U001-A2-7618
Operating Instructions, 06/2011
Index

U
USB driver, 88
User applications, 101
User mode, 22

V
Volume
Acoustic signals, 23
Volume of acoustic signals, 23

W
Write
Tag data, 41, 69
Tag ID, 47, 71
Writing tags, 41, 69

X
XML file
in Excel, 92
XML structure
List tag ID, 92
Tag data, 91