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DANGER  
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Prescribed Usage 
Note the following: 

WARNING  
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Trademarks 
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Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 

 

 Siemens AG 
Automation and Drives 
Postfach 48 48 
90327 NÜRNBERG 
GERMANY 

 Ordernumber: A5E00857337-02  
Ⓟ 09/2007 

Copyright © Siemens AG 2007. 
Technical data subject to change



 

Getting Started - First steps in PCS 7 
Getting Started, 09/2007, A5E00857337-02 3 

Table of contents 
1 Preface ...................................................................................................................................................... 5 
2 Creating the PCS 7 Project........................................................................................................................ 7 

2.1 How to Create the PCS 7 Project ..................................................................................................7 
3 Configuring the hardware and networks .................................................................................................. 11 

3.1 How to Configure the Hardware...................................................................................................11 
3.2 Editing the symbols in HW Config ...............................................................................................14 
3.2.1 How to edit the symbols of the analog input module ...................................................................14 
3.2.2 How to Edit the Symbols of the Analog Output Module...............................................................16 
3.2.3 How to Edit the Symbols for the Digital Input Module .................................................................17 
3.2.4 How to Edit the Symbols for the Digital Output Module...............................................................18 
3.3 Configuring the MPI interface for the SIMATIC PC Station .........................................................19 
3.3.1 How to Set Up the MPI Interface for the SIMATIC PC Station ....................................................19 
3.4 Saving and compiling data in Netpro ...........................................................................................21 
3.4.1 How to Save and Compile the Configurations in NetPro.............................................................21 
3.5 Starting S7 PLCSIM.....................................................................................................................23 
3.5.1 How to Start S7-PLCSIM .............................................................................................................23 
3.6 Download to the PLC ...................................................................................................................25 
3.6.1 How to download the MPI interface from NetPro to the PLC ......................................................25 

4 Configuring the process tags and the sequence control .......................................................................... 27 
4.1 How to Copy the CFC Charts from the Zip File to the  

Master Data Library .....................................................................................................................27 
4.2 How to Copy the CFC Charts into the Project .............................................................................29 
4.3 How to Configure the SFC Chart .................................................................................................31 
4.4 How to Organize the Project Folder.............................................................................................34 

5 Preparing the plant display for automatic generation ............................................................................... 37 
5.1 How to Prepare the Plant Display for Automatic Generation.......................................................37 

6 Creating a Unit_B by Copying unit_A....................................................................................................... 39 
6.1 How to Create Unit_B by Copying Unit_A....................................................................................39 

7 Programming and interconnecting the process tags ................................................................................ 41 
7.1 How to program and interconnect the process tags ....................................................................41 



Table of contents  
  

 Getting Started - First steps in PCS 7 
4 Getting Started, 09/2007, A5E00857337-02 

8 Compiling and downloading..................................................................................................................... 45 
8.1 How to Compile and Download Objects ..................................................................................... 45 
8.2 How to Set the CPU to RUN/P in S7-PLCSIM............................................................................ 50 

9 Operating and monitoring the process ..................................................................................................... 51 
9.1 How to Operate and Monitor the Process................................................................................... 51 

 Index........................................................................................................................................................ 57 



 

Getting Started - First steps in PCS 7 
Getting Started, 09/2007, A5E00857337-02 5 

Preface 1
Information About the Getting Started PCS - First Steps Documentation 

The Getting Started PCS 7 - First Steps Documentation uses a straightforward sample 
project to illustrate the basic principles of the SIMATIC PCS7 software components and how 
they interact in an engineering and in a Process Mode context. 
This Getting Started serves as an introduction and does not contain detailed or background 
information. If this Getting Started information has increased your interest in  
SIMATIC PCS 7, we recommend you consider the Getting Started PCS 7 - Part 1 for 
Beginners.  

Conventions 
In this documentation the designations of elements of the user interface are specified in the 
language of this documentation. If you have installed a multi-language package for the 
operating system, some of the designations will be displayed in the base language of the 
operating system after a language switch and will, therefore, differ from the designations 
used in the documentation. 

Purpose of this Getting Started Documentation 
This document aims to guide you quickly and successfully through the basics of 
SIMATIC PCS 7. You get to know many elementary configuration steps and develop an 
understanding for how SIMATIC PCS 7 functions in the process. 

Requirements for the Getting Started PCS 7 - First Steps Documentation 
The "fast_MP" sample project can be carried out on any PC or programming device on which 
the following software is installed: 
● operating system, Internet Explorer, Message Queuing Service and SQL Server  

(se: the Process Control System PCS 7; PC Configuration and Authorization Manual) 
● Software package SIMATIC PCS 7 V7.0 and later and the license key diskette 
● S7-PLCSIM for simulating a SIMATIC S7-400 automation system 
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Elements of the Getting Started PCS 7 - First Steps Documentation 
The document is available in online help format or can be printed out as a hardcopy PDF. 
We recommend using the printed PDF for configuration on the PC.  
You will find the online help and the printed manual under Start > SIMATIC > 
Documentation > English following installation of SIMATIC PCS 7  
 
To speed up configuration, we have included a library in the form of the "Sim_lib.zip" file 
which contains the ready-made CFC charts. 
After SIMATIC PCS 7 has been installed, the "Sim_lib.zip" file is saved in the following path: 
<Installation path>\SIEMENS\STEP7 \Examples_MP. Chapter 3 contains details on how to 
use this file.  
We wish you every success! 
Your SIEMENS AG 
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Creating the PCS 7 Project 2
2.1 How to Create the PCS 7 Project 

Introduction 
The PCS 7 "New Project" Wizard enables you to create a new PCS 7 multiproject with just a 
few mouse clicks. 

Requirements 
● PCS 7 V7.0 and higher is installed complete with the associated license keys. 
● S7-PLCSIM is installed with V5.4 and higher. 

Procedure 
 

Step Action 
1 Select the Start > SIMATIC > SIMATIC Manager command, or 

double-click the corresponding symbol on your desktop. 
SIMATIC Manager starts. 

2 Select File > Close to close all active projects in SIMATIC Manager. 
3 Select the File > "New Project..." Wizard. 

The program starts the "New Project" wizard of PCS 7. 
4 Click on "Next" in step 1(4). 
5 In step 2(4): 

• Select CPU "AS 417-4". 
• Select the bundle 6ES7654-1LE57-0XX0. 
• Select "0" from the "Number of Communications Modules" drop-down list. 
• Click "Continue". 

6 In step 3(4): 
• Select "3" from the "Levels" field in the "Plant Hierarchy" group. 
• Activate the 

"CFC chart" and "SFC chart" check boxes in the "AS Objects" group. 
• In the "OS Objects" group, check the "PCS 7 OS" check box and select the "Single 

Station System" option button. 
• Click "Continue". 
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Step Action 
7 In step 4(4): 

• Enter "fast" in the "Folder Name" text field. 
• Change the storage location for the project if necessary. 
• Click "Finish". 

8 If you have not changed the default setting "Always Prompt for Settings" for new projects 
in the "Message Numbers" tab in the "Options" menu, the "Message Number Assignment 
Selection" dialog box will be displayed. 
• Activate the "CPU-wide unique message number assignment" option. 
• Click "OK". 
In this dialog box you can also specify default settings for future projects/libraries. If you 
specify a default setting that differs from the standard default setting, the message number 
assignment selection in the PCS 7 Wizard is no longer prompted.  

9 On completion, the wizard closes automatically and the Plant View and Component View 
are displayed in the SIMATIC Manager. 
Close the Plant View and select the menu command View > Process Object View. 

10 Select the menu command Window > Arrange > Horizontally. 
Both the "Process Object View" and "Component View" windows are arranged horizontally.

 
 

 Note 
Select the Options > Settings command in SIMATIC Manager to open the "Settings" dialog 
box. Go to the "Default Project View" area on the "View" tab to select the default view to 
display when you open a project. 
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Result 
The "fast_MP" multiproject with a SIMATIC 400 station, a SIMATIC PC station and a master 
data library, "fast_Lib," has been created in the SIMATIC Manager. The newly created 
multiproject is displayed in the Process Object view and in the Component view in the 
SIMATIC Manager. 
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Configuring the hardware and networks 3
3.1 How to Configure the Hardware 

Introduction 
The PCS Wizard has created a SIMATIC 400 station, a SIMATIC PC station and master 
data library. Now add other hardware modules from the hardware catalog to the project. 
You perform these configuration steps in HW Config. 

Requirement 
● The PCS 7 multiproject "fast_MP" has been created. 

Procedure 
 

Step Action 
1 Select the SIMATIC 400 station in the component view, and then select the Edit > Open 

object command. 
HW Config opens. 

2 • Open the shortcut menu of the CP 443-1 in slot 5, and then select the Delete 
command. 
The "Delete" dialog box opens. 

• Click "Yes". 
The CP 443-1 is deleted. 

3 • If the hardware catalog is not visible select the View > Catalog command. 
• Open the "PROFIBUS DP" folder in the hardware catalog. 
• Open the "ET 200M" folder and select the "IM 153-2" module. Drag-and-drop the 

module tot the "DP master system" line. 
The "Properties - PROFIBUS interface IM 153-2" opens. 

• Click "OK". 
The program accepts the default settings. 
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Step Action 
4 • Click on the plus sign to the left of the "IM 153-2" folder in the hardware catalog. 

• Open the "AI-300" folder. Drag-and-drop the "SM 331 AI8x12Bit" module (6ES7 331-
7KF01-0AB0) to 
slot 4 at the bottom of the IM 153-2 configuration table. 
Close the "AI-300" folder. 

Tip: 
When the module is selected in the hardware catalog, the Order Number (MLFB) is 
displayed below in the information box. 
• Open the "AO-300" folder. Drag-and-drop the SM 332 AO2x12Bit" module (6ES7 332-

5HB01-0AB0) to slot 5 at the bottom of the IM 153-2 configuration table. 
Close the "AO-300" folder. 

• Open the "DI-300" folder. Drag-and-drop the DI16xDC24V" module (6ES7 321-1BH01-
0AA0) to slot 6 at the bottom of the IM 153-2 configuration table. 
Close the "DI-300" folder. 

• Open the "DO-300" folder. Drag-and-drop the "SM 322 DO8xDC24V/2A" module 
(6ES7 322-1BF01-0AA0) to slot 7 at the bottom of the IM 153-2 configuration table. 
Close the "DO-300" folder. 
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Result 
In HW Config, the redundantly applicable interface module IM 153-2 for the ET 200M 
distributed I/O station is extended by the analog/digital input/output modules 
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3.2 Editing the symbols in HW Config 

3.2.1 How to edit the symbols of the analog input module 

Introduction 
In order to assign names to the addresses of the "AI8x12Bit" analog input module, assign 
symbolic names and comments for each address in the "Edit Symbols" dialog box. 

Requirements 
● The analog input module has been configured in HW Config. 
● HW Config is open. 

Procedure 
 

Step Action 
1 • Open the shortcut menu for the analog input module in slot 4 in the configuration table 

and select the menu command Edit Symbols.... 
• To save previous changes, click "OK" in the dialog box. 

2 In the"Symbol" column enter "PIDCTRL1-PV_IN" for the first address (IW 512) and move 
the cursor onto the "Data type" column using the tabulator key and then on to the 
"Comment" column. Enter the symbolic name from the "Symbol" column again in the 
"Comment" column. 
Tip: Copy the name entered in the "Symbol" column and paste it to the "Comment" 
column. 

3 Enter the symbolic names and comments for the remaining addresses in the same way: 
• Second address (IW 514): "PIDCTRL2-PV_IN" 
• Third address (IW 516): "PIDCTRL1-LMNR_IN" 
• Fourth address (IW 520): "PIDCTRL2-LMNR_IN" 

4 Click "OK". 
The program saves your settings and closes the dialog box. 
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Result 
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3.2.2 How to Edit the Symbols of the Analog Output Module 

Introduction 
In order to assign names to the addresses of the analog output module "AO2x12Bit", assign 
symbolic names and comments for each address in the "Edit Symbols" dialog box. 
The procedure is the same as for the analog input module. 
Please enter the symbolic names and comments as shown in the figure below. 

Requirements 
● The analog output module has been configured in HW Config. 
● HW Config is open. 

Result 
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3.2.3 How to Edit the Symbols for the Digital Input Module 

Introduction 
In order to assign names to the addresses of the "DI16x24V" digital input module, assign 
symbolic names and comments for each address in the "Edit Symbols" dialog box. 
The procedure is the same as for the analog input module. 
Please enter the symbolic names and comments as shown in the figure below. 

Requirements 
● The digital input module has been configured in HW Config. 
● HW Config is open. 

Result 
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3.2.4 How to Edit the Symbols for the Digital Output Module 

Introduction 
In order to assign names to the addresses of the "DO8x24 VDC/2A" digital output module, 
assign symbolic names and comments for each address in the "Edit Symbols" dialog box. 
The procedure is the same as for the analog input module. 
Please enter the symbolic names and comments as shown in the figure below. 

Requirements 
● The digital output module has been configured in HW Config. 
● HW Config is open. 

Result 
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3.3 Configuring the MPI interface for the SIMATIC PC Station 

3.3.1 How to Set Up the MPI Interface for the SIMATIC PC Station 

Introduction 
In order to use S7-PLCSIM, you will need to set up an MPI interface for the  
SIMATIC PC station so that the OS variables can be compiled and a connection can be 
established between the AS and OS for PLCSIM. 

Requirement 
● The PCS 7 "fast_MP" project has been created using the PCS 7 Wizard. 

Procedure 
 

Step Action 
1 Select the SIMATIC PC station contained in the "fast_Prj" folder in the Component view of 

the SIMATIC Manager. 
2 In the right window of the SIMATIC Manager double click the "Configuration" object. 
3 • Open the "SIMATIC PC-Station" folder in the hardware catalog. 

• Open the "CP-PROFIBUS" folder contained in it and thereafter the "CP 5611" folder. 
• Drag-and-drop the "SW V6.0 SP5..." object from this folder to Index 1 in the 

configuration table. 
The "Properties - PROFIBUS interface CP 5611 (R0/S1)" opens. 

• Click "OK". 
The program accepts the default settings and closes the dialog box. 

4 Open the shortcut menu of the CP 5611 you inserted and select the Object Properties 
command. 
The "Properties - CP 5611" dialog box opens. 

5 • Open the "General" tab. Go to the "Interface" group and select the "MPI" entry from the 
"Type:" drop-down -list box. 
Confirm your selection by clicking "Yes" in the warning dialog box. 

• Click "Properties" in the "Interface" group and select the MPI(1)" entry from the 
"Subnet" area. 
The program automatically sets MPI address 3 because address 2 is already in use by 
the CPU. 

• Click on "OK" in the "Properties - MPI Interface CP 5611 (R0/S1)" dialog box. 
The program closes the dialog box. 

• Click "OK" in the "Properties - CP 5611" dialog box. 
The program closes the dialog box. 

6 Select the Station > Save and Compile command. 
7 Select the Station > Exit command. 
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Result 
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3.4 Saving and compiling data in Netpro 

3.4.1 How to Save and Compile the Configurations in NetPro 

Introduction 
The settings for the MPI interface of the OS that you have configured in HW Config are 
imported into NetPro. The network configuration must now be saved, compiled and tested. 

Requirement 
● Configuration has been completed in HW Config. 

Procedure 
 

Step Action 
1 Select the "fast_Prj" project in the Component view in the left window of the 

SIMATIC Manager.  
2 In the right window of the SIMATIC Manager double click the "MPI(1)" object. 

The "NetPro" dialog box opens. 
3 Select the Network > Save and compile command in NetPro. 

The program opens the "Save and compile" dialog box.  
4 Activate the "Compile and check all" check box and then  

click "OK". 
5 Close the "Output for Consistency Testing" dialog box. 
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Result 
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3.5 Starting S7 PLCSIM 

3.5.1 How to Start S7-PLCSIM 

Introduction 
Once S7-PLCSIM has been started, you can download the MPI interface configured in 
HW Config from NetPro to the PLC. 

Requirements 
● Configuration has been completed in HW Config. 
● The network configuration from NetPro has been saved, compiled and checked. 

Procedure 
 

Step Action 
1 Using the task bar change to the SIMATIC Manager window. 
2 Select the Options> Simulate Modules command. 

The "S7 PLCSIM" dialog box opens. 
3 Select option "Select CPU Access Nodes". Click "OK". 
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Step Action 
4 The next dialog box ("Select CPU Access Nodes") opens. 

5 Select the MPI access nodes in your project. Click "OK". 
Result: 

6 Make sure the CPU is in "STOP" state.  
7 Using the task bar, go back to NetPro. 
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3.6 Download to the PLC 

3.6.1 How to download the MPI interface from NetPro to the PLC 

Introduction 
The following section describes how to download the MPI interface configured in HW Config 
from NetPro to the PLC. 

Requirements 
● Configuration has been completed in HW Config. 
● NetPro has been opened in the original window. 
● S7-PLCSIM has been started and the CPU is in the "STOP" state 

Procedure 
 

Step Action 
1 In the network view in NetPro, click on the AS "SIMATIC 400(1)" symbol on the MPI/DP" 

interface.  
2 Open the context menu and select menu command Download in current project > 

Selected stations. 
3 Click the "Yes" button in the warning dialog box that appears. 
4 Select the menu command Network > Exit.  

NetPro closes. 
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Result 
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Configuring the process tags and the sequence 
control 4
4.1 How to Copy the CFC Charts from the Zip File to the  

Master Data Library 

Introduction 
The standard templates for MOTOR, VALVE and PIDCTRL from PCS 7 Library have to be 
adapted for process simulation. 
The CFC charts are prepared and archived as Zip file. To reduce the CFC execution time, 
open SIMATIC Manager and unpack the CFC charts from the zip files to the "Charts" folder 
of the master data library in the S7 program. 

Requirements 
● The PCS 7 "fast_MP" project has been created using the PCS 7 Wizard. 
● The SIMATIC Manager is open and the "fast_MP" project is displayed in Components 

view with all open hierarchy folders. 
● The "Sim_lib.zip" ZIP file has been copied from the "..\SIEMENS\STEP7\Examples_MP" 

folder to the "..\SIEMENS\STEP7\S7tmp" folder. 

Procedure 
 

Step Action 
1 • Select the File > Retrieve command to open the library from the zip file. 

• In the "Retrieve - Select Archive" dialog box, select the "Sim_lib.zip" archive file and 
click the "Open" button. 
Dialog box "Select Target Directory" opens. 

• Click the plus symbol of the folder to which you have saved your project (S7Proj). 
Select the "fast" project folder 
Click "OK". 
The "Retrieve - Folder exists" dialog box opens. 

• Click "Rename". 
The "Retrieve" dialog box opens. 

• Click "OK". 
The "Retrieve" dialog box opens once again with a different text. 

• Click the "Yes" button. 
Component view "fast_Lib (Component View)" opens. 
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Step Action 
2 Select the  

Window > Arrange > Tile vertically command in SIMATIC Manager. 
3 • In the "fast_Lib (Component View)" window, select the "Charts" folder under "S7 

Program(1) in the "fast_Lib" master data library. 
• Keeping <Ctrl> pressed, select the MOTOR1, PIDCTRL1 and VALVE1 CFC charts in 

the right window. 
• Drag and drop the selected CFC charts to the "fast_MP" multiproject in order to copy 

them to the "S7 Program(1)/Charts" folder" in the "fast_Lib" master data library. 
The CFC charts are now stored in the master data library within your multiproject. 

4 Close the "fast_Lib (Component View)" window. 

Result 
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4.2 How to Copy the CFC Charts into the Project 

Introduction 
Now copy the adapted and renamed CFC charts from the "fast_Lib" master data library in 
the "fast_Prj" project to the plant's "Function (1)" folder. When you have completed copying 
you can continue with configuration in SIMATIC Manager in the Process Object view.  

Requirement 
● In the master data library, the MOTOR1, VALVE1 and PIDCTRL1 templates are located 

in the "Templates" folder in the Process Object view. 

Procedure 
 

Step Action 
1 In the SIMATIC Manager, select the menu command 

View > Process Object view and open all hierarchy folders. 
2 Click the "Templates" folder in the "fast_Lib" folder in the left window. 

The three CFC charts MOTOR1, VALVE1 and PIDCTRL1 will be displayed in the table in 
the right-hand window.  

3 Press and hold down the <Ctrl> key and select all three charts by clicking on each of the 
line numbers in the first column.  

4 Drag and drop the selected CFC charts in order to copy them to the 
"fast_Prj\Plant(1)\Unit(1)\Function(1)" folder.  
The copied CFC charts will be displayed in the table in the right-hand window.  
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Result 
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4.3 How to Configure the SFC Chart 

Introduction 
The PCS 7 Wizard has created an SFC chart "SFC(1)" in the "Function(1)" folder in the 
"fast_Prj" project. The following section describes how to rename the SFC chart and adapt it 
for simulation. 

Requirements 
● The PCS 7 Wizard "New Project" has been executed. 
● The SIMATIC Manager is open and the "fast_MP" project is displayed in the Process 

Object view with all the opened hierarchy folders. 

Procedure 
 

Step Action 
1 Open the shortcut menu of the "SFC(1)" object in the "Function(1)" folder and select the 

menu command Rename. 
2 Enter the new name "Control" and press the Enter key. 
3 Double click the "Control" object.. 

The SFC editor opens. 
4 • Select the Insert > Step+Transition command in the SFC. 

• Move the cursor in the SFC chart below the "START" step until the green line appears 
and then press the left mouse button. 

• Select Insert > Select. 
5 • Select the first transition (2) beneath the "START" step, open the shortcut menu and 

select the menu command Object Properties. 
• Select the "Condition" tab. 
• Click the "Browse" button. 
• Click on the plus sign in front of the "PIDCTRL1" CFC. 
• Select the "PID" block. 
• Now select the "PV_IN" I/O in the "Name" column and then click the "Apply" and 

"Close" buttons. 
• In line 1 of the "Properties - 2 --..." dialog box, enter the number "50" next to the "=" and 

change the sign from "=" to ">". 
• Click the "Apply" and "Close" buttons. 
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Step Action 
6 • Open the shortcut menu of step (3) in the SFC chart below the transition (2) and select 

the menu command Object Properties. 
• Enter the value "10s" at "Minimal:" in the "Runtimes" group (without white spaces). 
• Select the "Processing" tab and click the "Browse" button. 
• Click on the plus sign in front of the "MOTOR1" CFC. 
• Select the "MOTOR" block. 
• Now select the "AUTO_ON" I/O in the "Name" column and then click the "Apply" and 

"Close" buttons. 
• In line 1 of the "Properties - 3--..." dialog box, enter the number "1" next to the "=" and 

click on "Apply" and "Close". 
The motor is now switched on when the process value of the control system reaches the 
value of 50 or exceeds it. 

7 • Open the shortcut menu for step 3 of the SFC and select the menu command Copy. 
• Open the shortcut menu in the blank area of the SFC chart and select the menu 

command Insert. 
• Move the cursor in the SFC chart above the "End" step until the green line appears and 

then press the left mouse button. 
8 • Open the shortcut menu of step (4) inserted and select the menu command Object 

Properties. 
• Select the "Processing" tab. 
• In line 1 of the "Properties - 4--..." dialog box, enter the number "0" next to the "=" and 

click on "Apply" and "Close". 
The motor is switched off again. 
• Select SFC > Exit. 
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Result 
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4.4 How to Organize the Project Folder 

Introduction 
The "Unit(1)" contained in the "fast_Prj" project has been created and named by the  
PCS 7 Wizard. In the following section you will rename Unit(1) as Unit_A and move it to the 
"Process cell(1)" folder. The plant structure gains in clarity by being renamed. Objects 
created by the PCS 7 Wizard that are not required can be deleted 

Requirements 
● The "New Project" PCS 7 Wizard has been executed. 
● The SIMATIC Manager is open and the "fast_MP" project is displayed with all the opened 

hierarchy folders in the Plant view. 
 

 

 Note 
Configure the views in SIMATIC Manager, for example, by selecting the View >Plant View 
command. 

 

Procedure 
 

Step Action 
1 Open the shortcut menu of the "Process cell(1)" folder in the left window of the Plant view 

and select the menu command Rename. 
2 Enter the name "Plant" and press Enter. 
3 Open the shortcut menu of the "Unit(1)" folder in the left window of the Plant view and 

select the menu command Rename. 
4 Enter the name "Unit_A" and press Enter. 
5 Click the "Function(1)" folder below the "Unit_A" folder. 
6 Open the shortcut menu of the "CFC(1)" object in the right pane and select the Delete 

command. 
The "Delete" dialog box opens. 

7 Click "Yes". 
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Result 
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Preparing the plant display for automatic generation 5
5.1 How to Prepare the Plant Display for Automatic Generation. 

Introduction 
You can prepare for automatic plant display generation by taking the steps described below. 

Requirements 
● The "New Project" PCS 7 Wizard has been executed. 
● The SIMATIC Manager is open and the "fast_MP" project is displayed with all the opened 

hierarchy folders in the Plant view. 

Procedure 
 

Step Action 
1 Select the "Unit_A" folder in the Plant view in the left window. 
2 Open the shortcut menu of the "Display(3)" object in the right window and select the menu 

command Object Properties. 
3 Select the "Block icons" tab. 
4 Select the "Derive block icons from the plant hierarchy" check box and click "OK". 
5 Open the shortcut menu of the "Unit_A" folder and select the menu command 

Plant Hierarchy > Settings 
6 Select the check box in the "OS area" column for the second level in the "Customize Plant 

Hierarchy" dialog box in the "Level Settings" group. 
7 Activate the "Derive picture hierarchy from the plant hierarchy" check box. 
8 Click "OK". 
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Result 
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Creating a Unit_B by Copying unit_A 6
6.1 How to Create Unit_B by Copying Unit_A 

Introduction 
The following is a description of how to copy "Unit_A" into the "Plant" folder in the Plant view. 
In the copying process a duplicate of Unit_A is created with all the contained and configured 
objects. You then rename the copy of "Unit_A" as "Unit_B".  

Requirement 
● The SIMATIC Manager is open and the "fast_MP" project is displayed with all the opened 

hierarchy folders in the Plant view. 

Procedure 
 

Step Action 
1 Open the shortcut menu of the "Unit_A" folder in the left pane of the plant view. Select the 

Copy command. 
2 Open the shortcut menu of the "Plant" folder and select the menu command Paste. 
3 Open the shortcut menu of the copied "Unit_A (1)" file and select the menu command 

Rename.  
4 Enter the name "Unit_B" and press Enter. 
5 In the left window below the "Unit_B" folder, select the "Function(1)" folder. 
6 • In the right window, open the shortcut menu of the "MOTOR1(1)" folder and select the 

menu command Rename. 
• Enter the name "MOTOR2" and press Enter. 
• In the right window open the shortcut menu of the "PIDCTRL1(1)" folder and select the 

menu command Rename. 
• Enter the name "PIDCTRL2" and press Enter. 
• In the right window open the shortcut menu of the "VALVE1(1)" file and select the 

menu command Rename. 
• Enter the name "VALVE2" and press Enter. 
• In the right window, open the shortcut menu of the "Controller(1)" folder and select the 

menu command Rename. 
• Enter the name "Controller2" and press Enter. 
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Result 
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Programming and interconnecting the process tags 7
7.1 How to program and interconnect the process tags 

Introduction 
To configure and interconnect the process tags, first insert the signals in the Process Object 
view and then modify the parameter values. 

Requirement 
● The SIMATIC Manager is open and the "fast_MP" project is displayed in the Process 

Object view with all the opened hierarchy folders. 

Procedure 
 

Step Action 
1 Click the "Plant" folder in the Process Object view in the left window. 
2 Click the "Signals" tab in the right window. 
3 • In the right window split the display window into two sections by positioning the cursor 

over the bar on the left next to the bottom horizontal scroll bar. When the cursor 
assumes the split symbol, move the bar to the middle of the display window. 

• Use the bottom left scroll bar to view the "Chart", "Block" and "I/O comment" columns in 
the left pane. 
Use the split cursor on the edges of the column headers to hide or reduce the size of 
columns. 

• Next, use the bottom right scroll bar to view the "Signal" column. 
• Click the "Chart" header to sort the column in ascending order. 

4 • Open the shortcut menu of the "Motor1" chart and the "FB_ON" block in the "Signal" 
column. Select the Insert signal command. 

• In the "Insert Signal" dialog box open the shortcut menu of the "Inputs" folder in the 
right window and select the menu command Open. 

In the hardware configuration the signal names are selected as composites of the name of 
the process tag "Chart" column, and the name of the channel drivers, "Block" column. 
• Select the "MOTOR1-FB_RUN" signal accordingly in the "Insert Signal" dialog box in 

the right window and then click "Apply". 
In the Process Object view the inserted signal is applied automatically in the "Signal" 
column and the next cell is selected. 

5 • In the "Insert signal" dialog box in the left window click the "Outputs" folder. 
• Select the "MOTOR1-OUT" signal in the right window and click "Apply". 
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Step Action 
6 Insert all other signals as described in step 5. Note that, depending on the signal, you have 

to change between the "Inputs" and "Outputs" folders in the "Insert Signal" dialog box in 
the left window 

7 Close the "Insert signals" dialog box. 
8 • Click the "Parameters" tab in the Process Object view in the right window. 

• Split the right window into two sections as described in step 3. The "Chart" column is 
displayed in the left window and the columns "Process tag I/O", "Category" and "Value" 
are displayed in the right window. 

• Click column header "Chart" to sort the column in descending order. 
• Enter the value 6 in the "Value" column in the right window for the "VALVE1" chart 

name and "Monitoring time" process tag/IO interface. 
• Enter the value 6 in the "Value" column in the right window for the "VALVE2" chart 

name and "Monitoring time" process tag/IO interface. 
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Result 
The result shown in the following figure is displayed after step 7. 
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The result shown in the following figure is displayed after step 8. 

 
 



 

Getting Started - First steps in PCS 7 
Getting Started, 09/2007, A5E00857337-02 45 

Compiling and downloading 8
8.1 How to Compile and Download Objects 

Introduction 
You have now carried out all the preparations for compiling and downloading the objects. 
Configure all the necessary settings for compiling and downloading the charts and the OS in 
the "Compile and Download Objects" dialog box. 

Requirements 
● The SIMATIC Manager is open and the "fast_MP" project is displayed in the Component 

view. 
● S7-PLCSIM has been started. 

Procedure 
 

Step Action 
1 • Open the shortcut menu of the "fast_MP" root folder on the left pane. Select the 

PLC > Compile and download objects command. 
• Open all folders in the "Compile and Download Objects" dialog box by clicking on the 

plus sign. 
• Select the check boxes in the "Compile" and "Download" columns in the "Charts" 

folder. 
• Click the "Charts" folder, and then click "Edit" in the "Settings for 

Compilation/Download" group. 
The "Compile program/download to PLC" dialog box opens. 

2 • Check the "Complete Program" option in the "Scope" option group. 
• Click OK". 

The "Download to PLC" dialog box opens. 
• Click "OK". 

The program closes both dialog boxes. 
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Step Action 
3 • Select the check box for the "OS(1)" folder in the "Compile" column in the "Compile and 

Download Objects" dialog box. 
• Click the "OS(1)" folder and then on "Edit" in the "Settings for Compiling/Downloading" 

group. 
• Click "Next" in the "Settings: Compile OS" dialog box. 
• Click "Next" again. 
• Select the "Variables and Messages", "SFC Visualization" and "Picture Tree" check 

boxes in the following dialog box of the "Data" group. In the "Scope" group, activate the 
"Entire OS" and "With memory reset" check boxes. 

• Click "Apply". 
The program closes the dialog box. 

4 • Click "Start" in the "Compile and download objects" dialog box. 
The "Compile and download objects" dialog box opens. 

• Click "OK". 
• A further "Compile and Download Objects" dialog box opens. 
• Click "Yes". 

The program starts the operation. 
The program opens the log file when this operation is completed. 

• Close the log file. 
• Click "Close" in the "Compile and Download Objects" dialog box. 



 Compiling and downloading 
 8.1 How to Compile and Download Objects 

Getting Started - First steps in PCS 7 
Getting Started, 09/2007, A5E00857337-02 47 

Result 
The edited "Compile and Download Objects" dialog box is shown in the figure below. 
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The following file is displayed after the compiling and downloading process has been 
completed: 
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Update blocks 
You may have to update certain blocks if compilation of the CFC charts fails in higher 
version of PCS 7. 
Procedure: 

 
Step Action 
1 Select File > Open in SIMATIC Manager. 

The "Open Project" dialog box opens 
2 Select the line of the current PCS 7 library on the "Libraries" tab and click "OK". 

The library opens in the component view. 
3 Select all blocks in the folder "PCS 7 Library\ Blocks+Templates\Blocks" with the key 

combination <Ctrl>+a. 
4 Select the Options> Charts > Update block types command. 

The "Open project" dialog box opens. 
5 Select the line "fast_Prj" and click "OK". 
6 Click "Continue". 
7 Follow the instructions of the wizard. 
8 Repeat the "Compile and download objects" operation. 

(step 4 in the upper table) 
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8.2 How to Set the CPU to RUN/P in S7-PLCSIM 

Introduction 
After the objects have been compiled and downloaded, the simulation of the CPU has to be 
switched over from the "STOP" state to the "RUN-P" state. 

Requirements 
● The objects have been compiled and downloaded. 
● The program S7-PLCSIM has already been started. 

Procedure 
 

Step Action 
1 Click the "S7/PLCSIM / SimView1" window in the task bar to open the window.  
2 Select the "RUN-P" check box in the "CPU" window. 

3 Click "Minimize" in the "S7-PLCSIM - SimView1" window. 
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Operating and monitoring the process 9
9.1 How to Operate and Monitor the Process 

Introduction 
If you activate the OS from the SIMATIC Manager and activate the OS project, you can 
operate and monitor the process.  

 

 Note 
You can modify and extend the automatically generated displays (pictures) - Display (3) from 
Unit_A and Display (3)(1) from Unit_B in the WinCC Explorer Graphics Designer. 

 

Requirements 
● The simulation of the CPU in the "RUN-P" state is set in S7-PLCSIM. 
● The SIMATIC Manager is open and the "fast_MP" project is displayed in the Component 

view. 
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Procedure 
 

Step Action 
1 Open the Tree view of the SIMATIC PC-Station in the left window of the SIMATIC 

Manager. 
2 Right-click the "OS(1)" folder and select the Open object command from the shortcut 

menu. 
3 Select File > Activate in WinCC Explorer. 
4 • Click the "Unit_A" area selection key in the overview area at the top left of the 

"SIMATIC PCS 7 Control system" user interface. 
The automatically generated display is displayed with the "Control", "Controller", "Motor" 
and "Valve" objects and symbols. 

5 • Click the "MOTOR1/MOTOR" symbol in the working area of the user interface. 
The faceplate of the motor is displayed in the working area of the user interface. 
• Click "Reset" in the faceplate and then "Execute" in the dialog box that is displayed. 
Tip: Use the "Enter" key to avoid having to click on "Execute". 
• Click "Start" and then "Execute" in the dialog box that is displayed. 
The motor will start. The "Status" on the left of the faceplate will now show "On".  

6 Repeat the procedure from Step 5 onwards for the controller and valve faceplates. Then 
test the operator inputs.  

7 • To stop the motor, click "STOP" in the "MOTOR1" faceplate followed by "Execute" in 
the dialog box that appears. 

• To set the "MOTOR1" faceplate to "Automatic" mode, click "Auto" followed by 
"Execute" in the dialog box that appears. 

8 • Click the "PIDCTRL1/PID" symbol to display this faceplate in the working area. 
• Set the operating mode to "Auto". 
• Click the text field next to "SP". Then use it to enter a setpoint value of 40. 

9 • Use the "Keyset Change" button in the bottom left of the user interface to switch to 
keyset 2. 

• Click "SFC Visualization" in keyset area 2. 
• In the right-hand window of the "Open SFC" dialog box, select "Control" in the "SFC 

Name" column. Then click "OK". 
The SFC overview window will now be displayed in the working area. 
• Click into the SFC overview window. 
The detailed window opens. 
• Click "Start" in the detailed window and then click "OK" to acknowledge the dialog field 

that appears. 
Unless the controller actual value is higher than 50, the sequential control will stop at the 
first transition and will no longer run. 
• By this point, the "PIDCTRL1/PID" control block window will have appeared and you 

should click it. 
• Click the text field next to "SP". Then use it to enter a setpoint value of 90. 
Watch what happens in the SFC detailed window. The sequential control runs right 
through to the end. MOTOR1 starts in step 3 of the sequence control chart and stops 
again in step 4. 
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Step Action 
10 • Click "Keyset Change" to switch to keyset 1. 

• Click "Message System". 
Any new messages will be displayed in the working area.  
• Click "Control List". 
The control list will be displayed in the working area. All the operator actions you 
performed in the faceplates are shown here. 
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Result 
Working area with all control elements (step 8):  
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Sequential control execution (step 9): 
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Control list (step 10): 
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