TIA Translation Tool V2.x

Automatically translating TIA Portal project texts

Warranty and liability

Note

The Application Examples are not binding and do not claim to be complete regarding the circuits shown, equipping and any eventuality. The Application Examples do not represent customer-specific solutions. They are only intended to provide support for typical applications. You are responsible for ensuring that the described products are used correctly. These Application Examples do not relieve you of the responsibility to use safe practices in application, installation, operation and maintenance. When using these Application Examples, you recognize that we cannot be made liable for any damage/claims beyond the liability clause described. We reserve the right to make changes to these Application Examples at any time without prior notice. If there are any deviations between the recommendations provided in these Application Examples and other Siemens publications – e.g. Catalogs – the contents of the other documents have priority.

We do not accept any liability for the information contained in this document. Any claims against us – based on whatever legal reason – resulting from the use of the examples, information, programs, engineering and performance data etc., described in this Application Example shall be excluded. Such an exclusion shall not apply in the case of mandatory liability, e.g. under the German Product Liability Act ("Produkthaftungsgesetz"), in case of intent, gross negligence, or injury of life, body or health, guarantee for the quality of a product, fraudulent concealment of a deficiency or breach of a condition which goes to the root of the contract ("wesentliche Vertragspflichten"). The damages for a breach of a substantial contractual obligation are, however, limited to the foreseeable damage, typical for the type of contract, except in the event of intent or gross negligence or injury to life, body or health. The above provisions do not imply a change of the burden of proof to your detriment.

Any form of duplication or distribution of these Application Examples or excerpts hereof is prohibited without the expressed consent of the Siemens AG.

Security information

Siemens provides products and solutions with industrial security functions that support the secure operation of plants, systems, machines and networks. In order to protect plants, systems, machines and networks against cyber threats, it is necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial security concept. Siemens’ products and solutions only form one element of such a concept.

Customer is responsible to prevent unauthorized access to its plants, systems, machines and networks. Systems, machines and components should only be connected to the enterprise network or the internet if and to the extent necessary and with appropriate security measures (e.g. use of firewalls and network segmentation) in place.

Additionally, Siemens’ guidance on appropriate security measures should be taken into account. For more information about industrial security, please visit http://www.siemens.com/industrialsecurity.

Siemens’ products and solutions undergo continuous development to make them more secure. Siemens strongly recommends to apply product updates as soon as available and to always use the latest product versions. Use of product versions that are no longer supported, and failure to apply latest updates may increase customer’s exposure to cyber threats.

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed under http://www.siemens.com/industrialsecurity.
# Table of contents

Warranty and liability .................................................................................................................. 2

1 Task ........................................................................................................................................... 4

2 Solution ...................................................................................................................................... 5

   2.1 Hardware and Software Components ................................................................................. 6
   2.2 Sample files and projects ................................................................................................. 6

3 Mode of Operation ................................................................................................................... 7

4 Installation and Commissioning .............................................................................................. 8

5 Operating the TIA Translation Tool ......................................................................................... 9

   5.1 Overview .......................................................................................................................... 9
   5.2 Exporting TIA Portal project texts .................................................................................... 11
   5.3 Creating a new TIA Translation Tool project .................................................................. 12
   5.4 Importing project texts into the Translation Tool .............................................................. 13
   5.5 Upgrading TIA Translation Tool V1 projects .................................................................. 13
   5.6 Creating new languages ................................................................................................... 13
   5.7 Translating project texts ................................................................................................... 14
   5.8 Analyzing project texts ..................................................................................................... 16
   5.9 Exporting project texts from the TIA Translation Tool ................................................... 17
   5.10 Import of translated project texts into the TIA Portal ..................................................... 18

6 Dictionaries ............................................................................................................................... 19

   6.1 Global dictionary .............................................................................................................. 19
   6.2 Creating and loading dictionaries .................................................................................... 19
   6.3 Editing dictionaries ......................................................................................................... 20
   6.4 Expanding dictionaries .................................................................................................... 21
   6.5 Importing and exporting dictionaries .............................................................................. 22

7 Appendix ................................................................................................................................... 23

   7.1 Service and Support ......................................................................................................... 23
   7.2 Links and Literature .......................................................................................................... 24
   7.3 Change documentation ..................................................................................................... 24
1 Task

Introduction

You have created a TIA Portal project in a project language and would now like to translate it into several target languages. There are several ways to translate project texts into other languages. On the one hand, you can manually adjust the individual project texts in TIA Portal, or let the project texts be translated by an external service provider. On the other hand, this application example will show you how to quickly, independently and efficiently translate project texts via the TIA Translation Tool V2.x.

Figure 1-1
2 Solution

With the TIA Translation Tool V2, you can translate your project texts automatically with the help of dictionaries. Due to growing dictionaries, you will by and by achieve a high level of translation.

Advantages

TIA Translation Tool V2 offers you the following advantages:

- A simplified user interface compared to TIA Translation Tool V1
- An effective translation through comprehensive dictionaries
- Time and cost savings through automatic translation

Topics not covered by this application

This application example does not contain a description of:

- TIA Portal (configuration)

Basic knowledge of this topic is assumed.

Prerequisites

- Installation of the TIA Translation Tool V2
- Exported TIA Portal project texts

Note

This application example requires a project text file that is exported from your project in TIA Portal.
2.1 Hardware and Software Components

Validity

This application example is valid for the following software versions:
- TIA Portal V14 or higher
- TIA Translation Tool V2

Components used

The application example has been created with the following components:

Software components

<table>
<thead>
<tr>
<th>Component</th>
<th>Qty.</th>
<th>Article number</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>TIA Translation Tool V2</td>
<td>1</td>
<td>--</td>
<td>You can download the file from the entry page with the ID: 109475387</td>
</tr>
<tr>
<td>TIA Portal V14 or higher</td>
<td>1</td>
<td>6AV210.-....3-0</td>
<td>--</td>
</tr>
<tr>
<td></td>
<td></td>
<td>6AV210.-....4-0</td>
<td></td>
</tr>
</tbody>
</table>

2.2 Sample files and projects

The following list contains all files and projects that are used in this application example.

<table>
<thead>
<tr>
<th>Component</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>109475709_TIA_TranslationTool_V2_DOC_en.pdf</td>
<td>This document.</td>
</tr>
</tbody>
</table>
3 Mode of Operation

General overview

The following figure shows the basic functionality of the translation via the TIA Translation Tool.

Figure 3-1 Overview

The TIA Translation Tool translates your project texts with the help of the stored dictionaries. The more often you use the TIA Translation Tool, the more comprehensive the existing dictionaries will be. As you manually translate each term just once and then save it in a dictionary, you will have to add less and less manual translations in the future.

The application example shows how to use the TIA Translation Tool and the required steps to translate project texts from the TIA Portal.

General procedure

1. Export of project texts from the TIA Portal
2. Import of project texts into a TIA Translation Tool project
3. Translation in the TIA Translation Tool
4. Export of project texts from the TIA Translation Tool
5. Import of translated project texts into the TIA Portal

This procedure is described in detail in chapter 5.
4 Installation and Commissioning

Installing the software

To install the TIA Translation Tool, proceed as follows:

1. Download the “TIATranslationTool_V2.x_setup.exe” file from the entry page of this application example:

   **Note**
   Information on the compatibility of the TIA Translation Tools can be found in the Compatibility Tool under the Entry ID: 64847781
   http://www.siemens.com/kompatool

2. Unzip the zip file
3. Click on the file “TIATranslationTool_V2.0_setup.exe“ to start the installation
4. Follow the instructions of installation wizard and click on the “Install” button in the last step

   **Note**
   During the installation, no shortcut is created on the desktop. For a desktop shortcut, open the installation path. Create a shortcut of the “TIA.Translation.Tool.exe” file on your desktop.

   The default installation path is: “C:\Program Files (x86)\Siemens AG\TIA Translation Tool”.
5 Operating the TIA Translation Tool

5.1 Overview

Overview and description of the user interface

Figure 5-1: Overview of the icon buttons

1. Buttons for showing and hiding the columns
2. Buttons for filtering entries
3. “Undo” and “Redo” buttons
4. “Updates screen” button
5. “Copy to dictionary” button
6. “Analyze” button
7. “Import” and “Export” buttons (for the project text files)
8. Task cards for language settings and properties (dictionaries)

Note

If you start the tool without an opened project, the above icons are not displayed. Create or open a project to gain access to the screen shown above.

You can change interface language using the selection list in the title bar (9).
Figure 5-2

1. Buttons for opening projects and dictionaries
2. Buttons for saving projects and dictionaries
3. Checkbox “Term locked”
4. Checkbox “Use reference”
5.2 Exporting TIA Portal project texts

To be able to translate TIA Portal project texts with the TIA Translation Tool, you first need to export them from your TIA Portal project.

1. Open your TIA Portal project.
2. In the TIA Portal, navigate to “Languages & resources > Project texts” in the project navigation to display the project texts.

![Figure 5-3](image)

3. In order to export the project texts, click “Tools > Export project texts”.
4. The following dialog opens.

![Figure 5-4](image)
5 Operating the TIA Translation Tool

Select the desired source language and target language (1).
In this application example, only the source language English (United States) will be exported. The target language will later be set in the TIA Translation Tool.
Select the text categories you want to export (2). Select a storage location and a file name (3).
Click on the “Export” button.

Note
If already configured languages are to be imported into the Translation Tool, this is always done in pairs of “source language” and a “target language”. In this case, you need the number of export files into which you want to export target languages.

When creating a language in the TIA Portal, some project text fields will already be filled in, e.g. the project text fields will be filled in with a wildcard. These wildcards are counted as already translated in the Translation Tool.

5.3 Creating a new TIA Translation Tool project

1. To start the TIA Translation Tool, double-click the file “TIA.Translation.Tool.exe”.
The file can be found in the installation path. The default installation path is: “C:\Program Files (x86)\Siemens AG\TIA Translation Tool”
TIA Translation Tool V2 will be opened.
2. Create a new project. To do so, click on “File > New > Project” in the menu.
3. Enter a name for the file in the saving dialog and click “Save”. TIA Translation Tool projects are saved with the “.tp” file extension.
5 Operating the TIA Translation Tool

5.4 Importing project texts into the Translation Tool

1. Click on the “Import project” button.  
   Figure 5-5

2. Select the exported project file in the dialog window.
3. Click on the “Open” button.

Note In the TIA Translation Tool, the export format version is displayed in the title line of the project.

5.5 Upgrading TIA Translation Tool V1 projects

If you want to import TIA Translation Tool V1 with project texts from TIA Portal V13 into TIA Portal V14, proceed as follows:
1. Creating a new dictionary in the TIA Translation Tool V1 project, e.g. “V14Import”.
2. Save all project texts in this dictionary.
3. Create a new TIA Translation Tool V2 projects.
4. Add the “V14Import” dictionary.
5. Import the TIA Portal V14 project texts into the TIA Translation Tool V2
6. Translate all with the “V14Import” dictionary.

Note Due to the different export formats, you cannot convert the project texts from “V13” to “V14”.

5.6 Creating new languages

Importing languages from the TIA Portal project

If large parts of the project texts have already been translated into the target language in TIA Portal, then you also import the target languages into the TIA Translation Tool, in addition to the source language. The import requires one “.xlsx” export file per target language from the TIA Portal.
Creating languages in the tool

You can create new target languages in the TIA Translation Tool via the “Languages” task card. If you import the translated project texts into the TIA Portal, these target languages are automatically created in the TIA Portal. No additional settings in TIA Portal are required.

5.7 Translating project texts

Preparation

Set the source language and the target language(s) via the “Languages” task card.

Note

You can also continue to use your previous dictionaries from the TIA Translation Tool in version 2.

Dictionaries used

In the “Settings” task card (1), via the “+” button (2), you can add the dictionaries you would like to use for the translation.

Figure 5-6

Via the arrow icons (3), you can change the order of the dictionaries. The dictionary at the top will be used with the highest priority during the automatic translation, the dictionary at the bottom with the lowest priority.

Manually translating

To translate project texts manually, click on the corresponding field and enter the term (1). With the button marked below (2), you can accept those project texts that are identical in both languages.

Translation by external service providers

If you want untranslated project texts to be translated by external service providers, follow the instructions in chapter 6.5.
Automatically translating

To translate project texts with your stored dictionaries, click on the “Translate entries” icon button.

Figure 5-7

The project texts are automatically translated with the previously added dictionaries. Afterwards, you may analyze the project texts. In the dialog window, you can see how many entries have been translated automatically and how many have not yet been translated.
5.8 Analyzing project texts

1. Click on the marked icon button (1).

   Figure 5-8

2. The Tool now analyses the project texts and then outputs the information in the following window:

   Figure 5-9

You see the number of project texts at a glance and how many of them are or are not translated. Via the status bar (marked in red), you can view and edit the respective project text in the following categories:

Table 5-5

<table>
<thead>
<tr>
<th>Column</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>“Not translated”</td>
<td>Here, all project texts are shown that have not been translated on the basis of the existing dictionaries.</td>
</tr>
<tr>
<td>“Reference duplicates”</td>
<td>With this filter, you can find texts that are different in the source language but translated with identical terms in the target language.</td>
</tr>
<tr>
<td>“Translation duplicates”</td>
<td>With this filter, you can find texts that are identical in the source language but translated with different terms in the target language.</td>
</tr>
</tbody>
</table>
5 Operating the TIA Translation Tool

<table>
<thead>
<tr>
<th>Column</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>“Unverified translations”</td>
<td>In the dictionaries, you can check the translations. If the tool translates from unchecked entries, the according project texts are listed here.</td>
</tr>
<tr>
<td>“Multiple translations”</td>
<td>If there is more than one translation in the dictionary for a reference term (source language), you can choose here, which translation you would like to use for the text.</td>
</tr>
<tr>
<td>“Length differences”</td>
<td>Here, translation pairs are shown whose letter length deviates from each other by more than 10 %. If the length difference is too great, display errors may occur in the HMI visualization.</td>
</tr>
</tbody>
</table>

There are the following options to translate "untranslated" terms:

1. Manual translation right in this window.
   For this, click on the target language in the line of the term and enter the translated term. For untranslatable terms, e.g. units, use the arrow button between source and target language to copy the term to the target language.

2. Translation in the dictionary.
   You can translate the words directly in a dictionary and then click on the "Translate entries" button.

It is crucial to save the new translations in a dictionary. This ensures that each new term has to be translated just once, since it is from then on translated automatically.

5.9 Exporting project texts from the TIA Translation Tool

As soon as you have translated the texts, you need to export the project texts from the TIA Translation Tool and then load them back into the TIA Portal.

1. For this purpose, click on the marked “Export project” button.

Figure 5-10

In the “Export project” dialog window, select a target directory (1), the reference language of the TIA Portal project (2) and the languages you would like to export (3).
2. Click on the “OK” button (4).

5.10 Import of translated project texts into the TIA Portal

1. Open your TIA Portal project.
2. Click on “Tools > Import project texts”.

Figure 5-12

Select your project texts translated in chapter 5.9

3. If the source language has not yet been imported, activate the option box “Import source language” and click on the “Import” button.

Figure 5-13

The translation process is now complete.
6 Dictionaries

Via the dictionaries, the TIA Translation Tool can translate your project texts into the desired target language. The more comprehensive and better structured the dictionaries are, the more efficient you can translate your project texts with the TIA Translation Tool.

Structure of the dictionaries

Dictionaries can contain translations in several languages at the same time. If a dictionary contains words and terms in English, German and Spanish, this means that from every language included in the dictionary, the program can translate into any other language included in the dictionary.

6.1 Global dictionary

The Global dictionary can be used across projects and is therefore at your disposal for every translation in the TIA Translation Tool. Use this dictionary for general and project-overlapping terms that occur in many of your projects.

6.2 Creating and loading dictionaries

1. Click on “File > New > Dictionary” to create a new dictionary.
2. Afterwards, enter a name for the file in the saving dialog and click “Save”. Dictionaries are saved with the “.ttdictionary” file extension.
3. Click on “File > Open > Dictionary > File” to load an existing dictionary. Alternatively, you can load the global dictionary.
6.3 Editing dictionaries

To edit dictionaries, proceed as follows:

Click on the “Dictionaries” task card on the left side.

The following integrated window opens up in the Translation Tool:

Figure 6-1

The following integrated window opens up in the Translation Tool:

Figure 6-2

1. Button for closing the window
2. Reference language
3. Target language with various possible translations
4. Language selection for the dictionary
To edit the dictionary entries manually, proceed as follows:

1. Click on the term to be edited in the “Reference language” column.
2. In the “Target language” column, you can see all previously saved translations for this entry.
3. Click on the translation to edit it. By clicking on the empty line, you add another translation for this term.
4. Activate the checkbox. The translation then receives the status “Verified”.

### 6.4 Expanding dictionaries

To increase the automatic level of translation of the Tool, you need to keep the dictionaries updated and continually expand them. In order to do so, you need to save the entries that could not be translated by the Tool earlier in a dictionary.

#### Adding translations to a dictionary

You have translated new terms and would now like to add them to a dictionary.

1. Click on the “Copy to dictionary” button
2. The “Copy to dictionary” dialog box opens.
3. Select a dictionary from the dropdown list (2).

**Note**

You can only select those dictionaries which you have previously stored in the “Settings” task card.

3. Via the tabs, you can choose the following categories (3).
   - All
   - Translated
   - Untranslated
   - Different Translation
   - Multiple translation

4. To copy the respective terms to the dictionary, click on the “OK” button.

### 6.5 Importing and exporting dictionaries

If you wish untranslated project texts to be translated by an external service provider, proceed as follows:

1. Save all untranslated project texts in a dictionary.
2. Export the dictionary in the Excel file format.
3. The external service provider will translate the project texts in this Excel file.
4. Import the fully translated Excel file.
5. Importing the dictionary into the TIA Translation Tool
6. Translate the project texts in the TIA Translation Tool by clicking onto the “Translate entries” button.
Appendix

7.1 Service and Support

Industry Online Support

Do you have any questions or need assistance?
Siemens Industry Online Support offers round the clock access to our entire service and support know-how and portfolio.
The Industry Online Support is the central address for information about our products, solutions and services.
Product information, manuals, downloads, FAQs, application examples and videos – all information is accessible with just a few mouse clicks at:
https://support.industry.siemens.com

Technical Support

The Technical Support of Siemens Industry provides you fast and competent support regarding all technical queries with numerous tailor-made offers – ranging from basic support to individual support contracts. You send queries to Technical Support via Web form:
www.siemens.com/industry/supportrequest

Service offer

Our range of services includes, inter alia, the following:
- Product trainings
- Plant data services
- Spare parts services
- Repair services
- On-site and maintenance services
- Retrofitting and modernization services
- Service programs and contracts
You can find detailed information on our range of services in the service catalog:
https://support.industry.siemens.com/cs/sc

Industry Online Support app

You will receive optimum support wherever you are with the "Siemens Industry Online Support" app. The app is available for Apple iOS, Android and Windows Phone:
https://support.industry.siemens.com/cs/ww/en/sc/2067
7.2 Links and Literature

Table 7-1

<table>
<thead>
<tr>
<th>No.</th>
<th>Topic</th>
</tr>
</thead>
</table>
| 1   | Siemens Industry Online Support  
https://support.industry.siemens.com |
| 2   | Link to this entry page of this application example  
| 3   |       |

7.3 Change documentation

Table 7-2

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Modifications</th>
</tr>
</thead>
<tbody>
<tr>
<td>V1.0</td>
<td>03/2017</td>
<td>First version</td>
</tr>
</tbody>
</table>