# COMOS

**Operations**
**MRO (Maintenance Repair and Overhaul)**

**Operating Manual**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trademarks</td>
<td>1</td>
</tr>
<tr>
<td>Introduction</td>
<td>2</td>
</tr>
<tr>
<td>Maintenance objects</td>
<td>3</td>
</tr>
<tr>
<td>&quot;General maintenance&quot; plugins</td>
<td>4</td>
</tr>
<tr>
<td>&quot;Events&quot; plugin</td>
<td>5</td>
</tr>
<tr>
<td>&quot;Resources&quot; plugin</td>
<td>6</td>
</tr>
<tr>
<td>&quot;Warehouse management&quot; plugin</td>
<td>7</td>
</tr>
<tr>
<td>Object search</td>
<td>8</td>
</tr>
<tr>
<td>Lifecycle structure</td>
<td>9</td>
</tr>
<tr>
<td>Locking objects</td>
<td>10</td>
</tr>
<tr>
<td>User interface reference</td>
<td>11</td>
</tr>
</tbody>
</table>

08/2011
A5E03633096-01
Legal information

Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are graded according to the degree of danger.

**DANGER**
indicates that death or severe personal injury will result if proper precautions are not taken.

**WARNING**
indicates that death or severe personal injury may result if proper precautions are not taken.

**CAUTION**
with a safety alert symbol, indicates that minor personal injury can result if proper precautions are not taken.

**CAUTION**
without a safety alert symbol, indicates that property damage can result if proper precautions are not taken.

**NOTICE**
indicates that an unintended result or situation can occur if the relevant information is not taken into account.

If more than one degree of danger is present, the warning notice representing the highest degree of danger will be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property damage.

Qualified Personnel

The product/system described in this documentation may be operated only by personnel qualified for the specific task in accordance with the relevant documentation, in particular its warning notices and safety instructions. Qualified personnel are those who, based on their training and experience, are capable of identifying risks and avoiding potential hazards when working with these products/systems.

Proper use of Siemens products

Note the following:

**WARNING**
Siemens products may only be used for the applications described in the catalog and in the relevant technical documentation. If products and components from other manufacturers are used, these must be recommended or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and maintenance are required to ensure that the products operate safely and without any problems. The permissible ambient conditions must be complied with. The information in the relevant documentation must be observed.

Trademarks

All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability

We have reviewed the contents of this publication to ensure consistency with the hardware and software described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the information in this publication is reviewed regularly and any necessary corrections are included in subsequent editions.
# Table of contents

1 Trademarks ............................................................................................................................................... 9

2 Introduction.................................................................................................................................................. 11
   2.1 Overview............................................................................................................................................... 11
   2.2 Prerequisites ......................................................................................................................................... 11
   2.3 Making the basic settings .................................................................................................................... 12
   2.4 User interface ....................................................................................................................................... 12

3 Maintenance objects .................................................................................................................................. 13
   3.1 Unit structure ....................................................................................................................................... 13
   3.2 Company ............................................................................................................................................... 13
      3.2.1 Company database ...................................................................................................................... 13
      3.2.2 Creating a new company ............................................................................................................. 13
      3.2.3 Profiles ......................................................................................................................................... 14
      3.2.4 Creating a profile ........................................................................................................................ 14
      3.3 Creating a company reference ......................................................................................................... 15
      3.4 Structures ......................................................................................................................................... 16
      3.4.1 Creating a unit object ................................................................................................................... 16
      3.4.2 Creating a plant part object ......................................................................................................... 16
      3.4.3 Creating a stock object ............................................................................................................... 17
      3.4.4 Creating a storage/stock area object ............................................................................................ 17
      3.4.5 Creating a stockyard .................................................................................................................... 17
      3.4.6 Creating a bulk goods object ....................................................................................................... 18
      3.4.7 Functional location ..................................................................................................................... 18
      3.4.8 Creating a functional location .................................................................................................... 18
      3.4.9 Equipment .................................................................................................................................... 19
      3.4.9.1 Equipment .............................................................................................................................. 19
      3.4.9.2 Creating equipment ............................................................................................................... 19
      3.4.9.3 ID number for equipment ...................................................................................................... 19
      3.4.9.4 Assigning an ID number for equipment .................................................................................. 20
      3.4.9.5 Moving equipment to a different functional location .............................................................. 20
      3.4.10 Recycle ........................................................................................................................................ 20
      3.4.11 Moving an object to the recycle bin .......................................................................................... 21
      3.5 Plant system ....................................................................................................................................... 21
      3.5.1 Overview ....................................................................................................................................... 21
      3.5.2 Creating a plant system ............................................................................................................... 22
      3.5.3 Referencing a plant system ......................................................................................................... 22
      3.5.4 Administrative work packages .................................................................................................. 22
      3.6 Maintenance ...................................................................................................................................... 23
      3.6.1 Maintenance plan ......................................................................................................................... 23
      3.6.1.1 What is a maintenance plan? .................................................................................................. 23
      3.6.1.2 Creating a maintenance plan .................................................................................................. 24

MRO (Maintenance Repair and Overhaul)
Operating Manual, 08/2011, A5E03633096-01
| 3.6.1.3 | Calculating work package dates | 24 |
| 3.6.1.4 | Calculating a maintenance date using a formula | 24 |
| 3.6.1.5 | Change maintenance date | 26 |
| 3.6.1.6 | Archiving maintenance plans | 27 |
| 3.6.2 | Work packages | 27 |
| 3.6.2.1 | Creating a work package | 28 |
| 3.6.2.2 | Reactivating work packages | 29 |
| 3.6.2.3 | Deleting a canceled work package | 30 |
| 3.6.2.4 | Archiving work packages | 30 |
| 3.6.3 | Report | 31 |
| 3.6.3.1 | Report | 31 |
| 3.6.3.2 | Report "Configuration" tab | 32 |
| 3.6.4 | Creating a task package | 32 |
| 3.6.5 | Base package | 32 |
| 3.6.5.1 | What is a base package? | 32 |
| 3.6.5.2 | Creating a base package | 32 |
| 3.6.5.3 | Creating a work package like the base package including package selection | 33 |
| 3.6.6 | Activities | 34 |
| 3.6.7 | Creating an activity | 34 |
| 3.6.8 | Qualification | 35 |
| 3.6.8.1 | What is a qualification? | 35 |
| 3.6.8.2 | Creating a qualification | 35 |
| 3.6.8.3 | New qualification objects | 36 |
| 3.6.8.4 | Using new qualification objects | 36 |
| 3.6.8.5 | Requirement object of the qualification | 36 |
| 3.6.9 | Calculating the costs of an activity | 36 |
| 3.6.10 | Creating a spare part | 37 |
| 3.6.11 | Inserting a spare part from a store | 37 |
| 3.6.12 | Creating a device | 38 |
| 3.6.13 | Making the resource check | 38 |
| 3.6.14 | Tour | 39 |
| 3.6.14.1 | Tour | 39 |
| 3.6.14.2 | Tour configuration | 39 |
| 3.6.14.3 | Creating a tour maintenance plan | 40 |
| 3.6.14.4 | Linking a maintenance plan to a tour maintenance plan | 40 |
| 3.6.14.5 | Dynamic linking of work packages to tours | 41 |
| 3.6.14.6 | Putting together a tour with Object search | 42 |
| 3.6.14.7 | Deleting the assignment of the individual maintenance plans to the tour maintenance plan | 43 |
| 3.6.14.8 | Deleting the assignment of an inspection to the tour maintenance plan | 44 |
| 3.7 | Inspections | 44 |
| 3.7.1 | What are inspections? | 44 |
| 3.7.2 | Creating associated inspections | 44 |
| 3.7.3 | Automatic creation of work packages/inspections | 45 |
| 3.7.4 | Linking an inspection to a tour automatically | 47 |
| 3.8 | Calibration | 47 |
| 3.8.1 | What is calibration? | 47 |
| 3.8.2 | Creating a basic structure for calibration | 47 |
| 3.8.3 | Creating a measurement series | 48 |
| 3.8.4 | Defining the desired values of the measurement series | 48 |
| 3.8.5 | Creating a calibration reference | 49 |
| 3.8.6 | Completing a work package definition | 49 |
3.8.7 Calculating the deviation of the measured values .......................................................... 49
3.9 Legal care objects ............................................................................................................ 50

4 "General maintenance" plugins ......................................................................................... 51
  4.1 Maintenance order .......................................................................................................... 51
  4.1.1 "Maintenance order" plugin ...................................................................................... 51
  4.1.2 Creating an order collector ......................................................................................... 51
  4.1.3 Opening the "Maintenance order" plugin .................................................................. 51
  4.1.4 Creating an order via the "Maintenance order" plugin .............................................. 52
  4.1.5 Creating order data .................................................................................................... 52
  4.1.6 Creating a work package via the "Maintenance order" plugin ................................... 53
  4.2 Manual maintenance preview ....................................................................................... 53
  4.2.1 "Manual maintenance preview" plugin ..................................................................... 53
  4.2.2 "Membership options" window of the "Manual maintenance preview" plugin .......... 54
  4.3 Maintenance Demon ..................................................................................................... 54
  4.3.1 "Maintenance demon" plugin .................................................................................. 54
  4.3.2 Preparing data for the "Maintenance demon" plugin ................................................. 55
  4.3.3 Opening the "Maintenance demon" plugin ............................................................... 55
  4.3.4 Scanning maintenance plans .................................................................................... 56
  4.3.5 Creating multiple work packages for each maintenance plan .................................. 56

5 "Events" plugin .................................................................................................................. 59
  5.1 "Event manager" plugin ............................................................................................... 59
  5.2 Preparing data for the "Event manager" plugin ............................................................... 60
  5.3 Events ............................................................................................................................ 60
  5.4 Creating an event .......................................................................................................... 60
  5.5 Opening the "Event manager" plugin ............................................................................ 61
  5.6 "Easy event" plugin ....................................................................................................... 61
  5.7 Opening the "Easy event" plugin .................................................................................... 61
  5.8 Creating an event via the "Easy event" plugin ................................................................ 61

6 "Resources" plugin ............................................................................................................. 63
  6.1 Resource management .................................................................................................. 63
  6.1.1 Preparing data for the "Resource management" plugin ............................................. 63
  6.1.2 Opening the "Resource management" plugin ............................................................. 63
  6.1.3 Color display of absences ........................................................................................ 63
  6.1.4 Displaying absences ................................................................................................. 64
  6.1.5 Creating an absence .................................................................................................. 64
  6.1.6 Editing an absence .................................................................................................... 65
  6.1.7 Importing absences ................................................................................................... 65
  6.1.8 Assigning an activity to a person ............................................................................... 66
  6.1.9 Editing an assigned activity ...................................................................................... 67
  6.1.10 Editing the assignment of an activity to a person ................................................... 68
  6.1.11 Centering the view of an activity in the calendar ..................................................... 69
  6.1.12 Displaying an overview of a person's absences and activities ................................ 69
  6.1.13 Creating dependencies between activities ............................................................... 69
  6.1.14 Editing dependencies between activities ................................................................. 70
# Table of contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.1.15</td>
<td>Deleting a dependency between activities</td>
<td>71</td>
</tr>
<tr>
<td>6.1.16</td>
<td>Tours in the &quot;Resource management&quot; plugin</td>
<td>71</td>
</tr>
<tr>
<td>6.2</td>
<td>Shift management</td>
<td>72</td>
</tr>
<tr>
<td>6.2.1</td>
<td>Settings in the properties of the shift planning object</td>
<td>72</td>
</tr>
<tr>
<td>6.2.2</td>
<td>Creating an object structure for the &quot;Shift management&quot; plugin</td>
<td>72</td>
</tr>
<tr>
<td>6.2.3</td>
<td>&quot;Shift management&quot; plugin</td>
<td>73</td>
</tr>
<tr>
<td>6.2.4</td>
<td>Opening the &quot;Shift management&quot; plugin</td>
<td>73</td>
</tr>
<tr>
<td>6.2.5</td>
<td>Assigning a shift group to a date</td>
<td>73</td>
</tr>
<tr>
<td>6.2.6</td>
<td>Adopting the shift group assignment of a period</td>
<td>74</td>
</tr>
<tr>
<td>6.2.7</td>
<td>Deleting a shift group assignment</td>
<td>75</td>
</tr>
<tr>
<td>6.2.8</td>
<td>Defining roles and qualifications for a shift</td>
<td>76</td>
</tr>
<tr>
<td>6.2.9</td>
<td>Displaying information about the shift</td>
<td>76</td>
</tr>
<tr>
<td>6.2.10</td>
<td>Creating a shift report</td>
<td>77</td>
</tr>
<tr>
<td>6.2.11</td>
<td>Starting a shift</td>
<td>77</td>
</tr>
<tr>
<td>6.2.12</td>
<td>Changing a shift automatically</td>
<td>78</td>
</tr>
<tr>
<td>6.2.13</td>
<td>Assigning a person to a shift</td>
<td>79</td>
</tr>
<tr>
<td>6.2.14</td>
<td>Deleting the assignment of a person to a shift</td>
<td>80</td>
</tr>
<tr>
<td>6.2.15</td>
<td>Editing a person's details</td>
<td>80</td>
</tr>
<tr>
<td>6.2.16</td>
<td>Statistical evaluation of the shift</td>
<td>81</td>
</tr>
<tr>
<td>6.3</td>
<td>&quot;Resource monitor&quot; plugin</td>
<td>82</td>
</tr>
<tr>
<td>7</td>
<td>&quot;Warehouse management&quot; plugin</td>
<td>83</td>
</tr>
<tr>
<td>7.1</td>
<td>&quot;Warehouse management&quot; plugin</td>
<td>83</td>
</tr>
<tr>
<td>7.1.1</td>
<td>&quot;Warehouse management&quot; plugin</td>
<td>83</td>
</tr>
<tr>
<td>7.1.2</td>
<td>&quot;Warehouse management&quot; plugin</td>
<td>83</td>
</tr>
<tr>
<td>7.1.3</td>
<td>Putting equipment to stock</td>
<td>83</td>
</tr>
<tr>
<td>7.1.4</td>
<td>Releasing equipment from stock</td>
<td>84</td>
</tr>
<tr>
<td>7.1.5</td>
<td>Assigning equipment to a functional location</td>
<td>84</td>
</tr>
<tr>
<td>7.1.6</td>
<td>Finding suitable equipment for a functional location</td>
<td>85</td>
</tr>
<tr>
<td>7.1.7</td>
<td>Editing bulk material using the &quot;Warehouse management&quot; plugin</td>
<td>86</td>
</tr>
<tr>
<td>7.2</td>
<td>&quot;Goods receipt&quot; plugin</td>
<td>86</td>
</tr>
<tr>
<td>7.2.1</td>
<td>Opening the &quot;Goods receipt&quot; plugin</td>
<td>86</td>
</tr>
<tr>
<td>7.2.2</td>
<td>Creating a goods receipt folder</td>
<td>86</td>
</tr>
<tr>
<td>7.2.3</td>
<td>Creating a goods receipt object</td>
<td>87</td>
</tr>
<tr>
<td>7.2.4</td>
<td>Editing goods receipt</td>
<td>87</td>
</tr>
<tr>
<td>7.2.5</td>
<td>Assigning a goods receipt object to a goods issue object</td>
<td>88</td>
</tr>
<tr>
<td>7.3</td>
<td>&quot;Goods issue&quot; plugin</td>
<td>88</td>
</tr>
<tr>
<td>7.3.1</td>
<td>Opening the &quot;Goods issue&quot; plugin</td>
<td>88</td>
</tr>
<tr>
<td>7.3.2</td>
<td>Creating a goods issue folder</td>
<td>89</td>
</tr>
<tr>
<td>7.3.3</td>
<td>Creating a goods issue object</td>
<td>89</td>
</tr>
<tr>
<td>8</td>
<td>Object search</td>
<td>91</td>
</tr>
<tr>
<td>8.1</td>
<td>&quot;Object search&quot; plugin</td>
<td>91</td>
</tr>
<tr>
<td>8.2</td>
<td>Opening the &quot;Object search&quot; plugin</td>
<td>91</td>
</tr>
<tr>
<td>8.3</td>
<td>Searching for an object via the &quot;Object search&quot; plugin</td>
<td>91</td>
</tr>
<tr>
<td>8.4</td>
<td>Exporting the search result from the &quot;Object search&quot; plugin</td>
<td>92</td>
</tr>
</tbody>
</table>
# Lifecycle structure

9.1 Concept......................................................................................................................... 93
9.2 Evaluation of lifecycle link objects................................................................................. 94
9.3 Using the lifecycle structure......................................................................................... 94
9.4 Changing the lifecycle link object of a lifecycle object............................................... 95
9.5 Adding multiple lifecycle link objects to a lifecycle object........................................ 96
9.6 Deleting the lifecycle link object of a lifecycle object................................................ 97

## User interface reference

11.1 "Options > Maintenance" tab of the project ................................................................. 101
11.2 "Personal data" tab .................................................................................................... 103
11.3 Maintenance objects.................................................................................................. 104
11.3.1 Company............................................................................................................... 104
11.3.1.1 "General" tab...................................................................................................... 104
11.3.1.2 "System internals" tab....................................................................................... 104
11.3.1.3 "Commercial data" tab....................................................................................... 105
11.3.1.4 "Company data" tab........................................................................................ 105
11.3.1.5 "Portal" tab......................................................................................................... 106
11.3.1.6 "iAge profile" tab.............................................................................................. 106
11.3.1.7 "Regular working time" tab.............................................................................. 106
11.3.2 "Company" tab of the company reference............................................................. 106
11.3.3 "Building data" tab................................................................................................ 107
11.3.4 Equipment............................................................................................................. 108
11.3.4.1 "Equipment data" tab...................................................................................... 108
11.3.4.2 "Functional location" tab.................................................................................. 108
11.3.4.3 "Header data" tab............................................................................................ 109
11.3.5 "Plant system" tab................................................................................................ 110
11.3.6 Maintenance plan.................................................................................................. 110
11.3.6.1 "Configuration" tab........................................................................................ 110
11.3.6.2 "History" tab.................................................................................................... 110
11.3.6.3 "Legal care" tab............................................................................................... 111
11.3.6.4 "Sub maintenance" tab.................................................................................... 111
11.3.6.5 "Formula/details" tab..................................................................................... 111
11.3.6.6 "Maintenance plan" tab................................................................................... 112
11.3.6.7 "Responsibilities" tab...................................................................................... 114
11.3.7 "Calculate work package dates" window.............................................................. 115
11.3.8 "Time planning" window....................................................................................... 116
11.3.9 Work package........................................................................................................ 117
11.3.10 Task package object............................................................................................ 120
11.3.10.1 "Dis- /mounting info" tab.............................................................................. 120
11.3.10.2 "Qualifications" tab....................................................................................... 120
11.3.10.3 "Resource planning" tab................................................................................ 121
11.3.11 Activity............................................................................................................... 122
11.3.11.1 "Barcode" tab................................................................................................ 122
11.3.11.2 "Activity" tab............................................................................................... 122
<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>11.3.11.3</td>
<td>&quot;Qualification types&quot; tab</td>
<td>123</td>
</tr>
<tr>
<td>11.3.12</td>
<td>&quot;Qualification&quot; tab</td>
<td>124</td>
</tr>
<tr>
<td>11.3.13</td>
<td>&quot;Spare part&quot; tab</td>
<td>124</td>
</tr>
<tr>
<td>11.3.14</td>
<td>&quot;Bulk material&quot; window</td>
<td>125</td>
</tr>
<tr>
<td>11.3.15</td>
<td>&quot;Device reference&quot; tab</td>
<td>126</td>
</tr>
<tr>
<td>11.3.16</td>
<td>&quot;Tour configuration&quot; tab</td>
<td>127</td>
</tr>
<tr>
<td>11.4</td>
<td>Plugins</td>
<td>128</td>
</tr>
<tr>
<td>11.4.1</td>
<td>Tab of the &quot;Object search&quot; plugin</td>
<td>128</td>
</tr>
<tr>
<td>11.4.2</td>
<td>&quot;Options&quot; window of the &quot;Object search&quot; plugin</td>
<td>130</td>
</tr>
<tr>
<td>11.4.3</td>
<td>&quot;Export&quot; window</td>
<td>131</td>
</tr>
<tr>
<td>11.4.4</td>
<td>&quot;Order data&quot; tab</td>
<td>131</td>
</tr>
<tr>
<td>11.4.5</td>
<td>Tab of the &quot;Maintenance order&quot; plugin</td>
<td>132</td>
</tr>
<tr>
<td>11.4.6</td>
<td>Tab of the &quot;Manual maintenance preview&quot; plugin</td>
<td>133</td>
</tr>
<tr>
<td>11.4.7</td>
<td>&quot;Membership options&quot; window of the &quot;Manual maintenance preview&quot; plugin</td>
<td>135</td>
</tr>
<tr>
<td>11.4.8</td>
<td>&quot;COMOS Direct Workpackage&quot; tab</td>
<td>135</td>
</tr>
<tr>
<td>11.4.9</td>
<td>Tab of the &quot;Maintenance demon&quot; plugin</td>
<td>137</td>
</tr>
<tr>
<td>11.4.10</td>
<td>&quot;Additional data&quot; tab</td>
<td>139</td>
</tr>
<tr>
<td>11.4.11</td>
<td>&quot;Event&quot; tab</td>
<td>139</td>
</tr>
<tr>
<td>11.4.12</td>
<td>&quot;Work request - details&quot; tab</td>
<td>140</td>
</tr>
<tr>
<td>11.4.13</td>
<td>Menu bar of the &quot;Event manager&quot; plugin</td>
<td>140</td>
</tr>
<tr>
<td>11.4.14</td>
<td>&quot;Easy event&quot; plugin</td>
<td>142</td>
</tr>
<tr>
<td>11.4.15</td>
<td>&quot;Scheduling&quot; tab</td>
<td>143</td>
</tr>
<tr>
<td>11.4.16</td>
<td>&quot;Report&quot; tab</td>
<td>143</td>
</tr>
<tr>
<td>11.4.17</td>
<td>&quot;Workflow&quot; tab</td>
<td>144</td>
</tr>
<tr>
<td>11.4.18</td>
<td>Menu bar of the &quot;Resource management&quot; plugin</td>
<td>146</td>
</tr>
<tr>
<td>11.4.19</td>
<td>&quot;Shift planning&quot; tab</td>
<td>146</td>
</tr>
<tr>
<td>11.4.20</td>
<td>Menu bar of the &quot;Shift management&quot; plugin</td>
<td>147</td>
</tr>
<tr>
<td>11.4.21</td>
<td>&quot;Configuration of trigger&quot; tab</td>
<td>148</td>
</tr>
<tr>
<td>11.4.22</td>
<td>&quot;Statistics and evaluation&quot; tab</td>
<td>148</td>
</tr>
<tr>
<td>11.4.23</td>
<td>&quot;Goods receipt&quot; tab</td>
<td>149</td>
</tr>
<tr>
<td>11.4.24</td>
<td>&quot;Resource monitor&quot; plugin</td>
<td>150</td>
</tr>
</tbody>
</table>
Registered trademark: COMOS®
2.1 Overview

Maintenance is a comprehensive, integrated system for the planning and organization of maintenance and inspection tasks.

Application range of Maintenance

Your work with Maintenance begins after you have planned the unit with the relevant COMOS modules. COMOS has an integrative structure that allows you to perform all the necessary tasks on the same database. The entire technical information on all aspects of the industrial unit can be collected together and edited in a central information system. If the unit is reconfigured or maintenance work is necessary, the data can be updated and remains available for the entire life cycle of the unit.

It is also possible to include maintenance aspects even in the planning phase.

Generally, even a unit that was not planned with COMOS can also be maintained with Maintenance.

Unit structure

This manual describes how structures can be built up in Maintenance. This involves a suggestion for a possible unit structure that can be considered as ideal from a maintenance perspective.

2.2 Prerequisites

With the Maintenance module, you can plan and process various types of maintenance. You need to be familiar with the basics of the COMOS software and need to know how to work with typical resources. All examples and explanations are based on the COMOSDB supplied with the installation CD and the sample project "COMOS_MA Maintenance".

Before you start to work with Maintenance, you will need to have the appropriate licenses for the various modules. To be able to use the planning sequence on which the following description is based, you should already have unit structures and corresponding objects in COMOS that will now be extended by maintenance information.

You can find additional information on this topic in the manual "COMOS Platform Getting Started".
2.3 Making the basic settings

Before you can work with Maintenance, you will need to make a couple of settings. Generally, this is the responsibility of the administrator.

Procedure

1. Open the "COMOS_MA Maintenance" project.
2. Open the project properties.
3. Select the "Options > Maintenance" tab.
   - Activate the "Is maintenance project" option.
   - Activate the "Use EventManager" option.
   - Activate the "Structural mode" option.
   - Enter the name of the company project in the "Company DB" field, for example, "USERS" or "COMOS_MA_CSM".
4. Save your settings.

See also

"Options > Maintenance" tab of the project (Page 101)

2.4 User interface

The user interface in Maintenance is the normal COMOS user interface; a modified user interface is only used for the plugins "Direct" and the portal view (user-defined menu configuration). The settings for the various user interfaces are made by the responsible administrator.

Planning and processing of maintenance is partially done in the familiar COMOS Navigator and partially using plugins.

You enter maintenance information for scheduled recurring work packages in the maintenance plan. You have the option of creating the maintenance plan below various objects, such as equipment, a functional location, or a unit. The maintenance plan is visible not only in the Navigator, it can also be displayed in other interactive reports such as the P&ID, isometry, or 3D model.
3.1 Unit structure

All objects supplied as standard are listed and described below, but not the objects that were customized for a specific company.

3.2 Company

3.2.1 Company database

You manage company and personal information in the Maintenance module in a separate planning project. You define which planning project COMOS will use as the company database in the project settings of the maintenance planning project. You can also use the COMOS USERS project for this purpose if you wish. The USERS project exists as a default in COMOS.

3.2.2 Creating a new company

Procedure

1. Open the company database.
2. Select the "Units" tab in the Navigator.
3. Select the project node of the company DB.
4. Select the "New > Comp company" command from the context menu.

Result

A new company is created in the Navigator underneath the project node.

You should always enter basic company data such as the name, address, and company logo.
3.2 Company

3.2.3 Profiles

You can use profiles in the following projects:
- "Object search"
- "Manual maintenance preview"
- "Event manager"
- "Resource monitor"

XML profiles

To use XML profiles, open the properties of the project and go to the "Options > Maintenance" tab, then in the project settings set the value of the "UseNewProfiles" parameter underneath the "SearchPlugIn" node to "1".

Old profile technology

The old profile technology is no longer supported in the current COMOSDB.

3.2.4 Creating a profile

You can create profiles in the following plugins:
- "Object search"
- "Manual maintenance preview"
- "Event manager"
- "Resource monitor"

You can also copy profiles of other people and insert them in the profile collector.

Procedure

1. Open the according plugin.
2. Make the required settings.
3. Enter the name under which the profile will be saved in the "*****" field in the menu bar of the plugin.
4. Click the "Save" button to the left of the field.

Result

A profile collector object is created under the current user in the company database, and the profiles below it. Depending on the plugin in which you save the profile, the type of profile is set for the "ProfileTab.Type" attribute on the tab.

If you create a profile using the "Eventmanager" plugin, settings including those for the start object, the column width of the results table, the history, and export are saved.
General profiles

You can also save profiles in a company object or department, which will then be available to all subordinate users. If you want to do this, copy an existing profile collector and insert it underneath the required object. The profiles can be used but cannot be edited. Only profiles created under the particular user can be edited by the user.

3.3 Creating a company reference

Introduction

The company reference is the first node of each project that is created directly underneath the project node. It is used to create a connection to a company in the company DB and it is the starting point for additional unit structures.

Procedure

1. Right-click on the project node.
2. Select the "New > CompRef Company reference" command from the context menu.
   The "CompRef Company Reference" node is created below the project node in the Navigator.
3. Open the properties of the object.
4. Select the "Attributes > Company" tab.
5. Click the "Select company from company project..." button.
   The "Select company" window opens.
6. Select the required company reference.
7. Click "OK" to confirm your selection and close the "Select company" window.
   The data relating to the selected company reference is entered in the corresponding fields.
8. Click "OK" to save the company reference data and close the properties.

Result

The company reference has been created.
3.4 Structures

3.4.1 Creating a unit object

Introduction
You place unit objects underneath the company reference. Unit objects serve to collect unit parts, functional locations and manufacturer devices.

Procedure
1. Right-click on the company reference underneath which you want to create the unit object.
2. Select the "New > P Unit" command from the context menu.

Result
The unit has been created.

3.4.2 Creating a plant part object

Introduction
You can structure an existing unit into as many unit parts as you like. Underneath a unit part, you can also create any number of other unit parts. You can have as many nesting levels as you desire.

Procedure
1. Right-click on the unit object underneath which you want to create the unit object.
2. Select the "New > U Unit part" command from the context menu.

Result
The unit part object is created underneath the unit object.
3.4.3 Creating a stock object

Procedure
1. Right-click on the company reference underneath which you want to create the stock object.
2. Select the "New > L storage" command from the context menu.

Result
The stock object is created underneath the company reference.

3.4.4 Creating a storage/stock area object

The storage area object is used to structure the storage on the "Units" tab in the Navigator.

Procedure
1. Right-click on the storage/stock object underneath which you want to create the storage/stock area object.
2. Select the "New > LU Storage/stock area" command from the context menu.

Result
The storage area is created underneath the stock object.

3.4.5 Creating a stockyard

The storage place object is the node below which the actually stocked devices are inserted.

Procedure
1. Right-click on the stock object underneath which you want to create the storage place object.
2. Select the "New > LP Storage location" command from the context menu and select an object type.

Result
The storage location is created underneath the stock object.
3.4.6 Creating a bulk goods object

You create bulk goods objects underneath bulk goods store places.

Procedure

1. Right-click on the bulk goods storage place object below which you want to create a bulk goods object.
2. Select the "New > BG Bulk material" command from the context menu.

Result

The bulk goods object is created underneath the storage place object.

3.4.7 Functional location

You create each piece of equipment or manufacturer device underneath a functional location. This can be understood as a procedural placeholder for equipment. You can either insert it underneath a unit part or directly underneath the unit.

Different functional locations are available for the various equipment types.

Example

You can only create equipment of type "pump" underneath a functional location for pumps.

3.4.8 Creating a functional location

Procedure

1. Right-click on the unit object or the unit part object underneath which you want to create the functional location.
2. Select the "New > @F Functional locations" command from the context menu and select the object for which you want to create a functional location.

Result

The functional location is created underneath the unit object or unit part object.
3.4.9 Equipment

3.4.9.1 Equipment

Equipment is used as a generic term for all physically existing manufacturer devices used in a plant. From a maintenance perspective, equipment should be installed underneath a functional location.

Equipment can consist of several subequipment parts. If this is the case, the equipment automatically brings its components with it when it is created. These components are inserted as subnodes underneath the main equipment. Each of these components also exists as an individual device in the manufacturer's catalog and can be maintained and supplied with maintenance information separately.

3.4.9.2 Creating equipment

Procedure

1. Right-click on the functional location underneath which you want to create the equipment.
2. Select the "New" command from the context menu and select the equipment you want to create.

Result

The equipment is created underneath the functional location.

Example

If you created a "pump" functional location previously, you can only create pumps as equipment.

"Attributes > Equipment data" tab

The settings in the "ID" area are made in the base object tree by the responsible administrator.

3.4.9.3 ID number for equipment

Equipment has a cross-project unique ID number that is also marked on the physical manufacturer device in the plant. In this way, you can search for equipment using the "Object search" plugin, for example.

You can also assign the ID number via the "Ident" tab, if this exists at the object.
3.4.9.4 Assigning an ID number for equipment

Requirement

The settings for assigning the ID number for equipment have been made by the administrator in the base data so that the equipment is automatically numbered and identified uniquely.

Procedure

1. Open the properties of the relevant item of equipment.
2. Select the "Attributes > Equipment data" tab.
3. To specify how many digits the ID number has, select an entry from the list in the "ID" control group.
4. Click the "Assign new ID" button to assign a new ID number to the object.
5. Save the information you entered.

3.4.9.5 Moving equipment to a different functional location

To document the move process, use the warehouse management plugin.

The functional location is fixed during the planning phase. Therefore, you must not move it during maintenance activities.

3.4.10 Recycle

"Recycle" object

This functionality is available only when the "Recycle" object exists on the "Units" tab of the relevant planning project in the Navigator. If you want to use this functionality, contact the responsible administrator. You can find additional information on this topic in the "Maintenance Administration" manual, keyword "Recycle bin".

Rights for deleting

If the authorizations for deleting are restricted at the user level, you can no longer select the "Delete" command from the context menu by right-clicking. Even if this is the case, you can still remove objects from the unit structure that are no longer required by moving these objects below the "Recycle" object with this function.

Only a user with the right to delete can delete the object completely underneath this node. An object in the recycle bin can, however, be moved back to its original place by any user with the "Maintenance > Restore object" command.
Description of the menu item

With special maintenance objects, the labeling of the menu item can vary.

Automatic deactivation of maintenance plans

If objects are located in recycling can, they are regarded as inactive. This means, for example, that maintenance plans moved to recycling are ignored when duplicating shutdown objects.

If you move an active maintenance plan to the recycle bin, the "Maintenance active" option on the subordinate level "Maintenance plan" tab is automatically deactivated in the properties of the object. If you restore the object, you will be asked whether or not you want to activate the maintenance plan.

3.4.11 Moving an object to the recycle bin

If you do not have the required rights to delete objects, you can move objects you no longer require to recycling.

The responsible administrator can configure the function so that you can only move objects of selected object classes to the recycle bin. You can find more information on this topic in the "COMOS Administration" manual, keyword "Recycle bin".

Procedure

1. Select the "Units" tab in the Navigator.
2. Right-click on the object you want to delete.
3. Select the "Maintenance > Delete object" command.

The object is moved to recycling.

3.5 Plant system

3.5.1 Overview

A plant system helps you to define which items of equipment are logically connected to one another and, consequently, depend on one another during operation. If you make a repair, all equipment that is part of a plant system must be taken into consideration. All of them must be taken out of operation, for example.

A plant system covers several functional locations. Each functional location or item of equipment is only assigned to one single plant system.

You use the "Main plant system" object to create the required plant system structure. The "Plant system" object represents the lowest level of the structure and is the grouping object.
3.5 Plant system

3.5.2 Creating a plant system

Base object

You will find the base object for the plant system here:
"@CBO > @PS > PST > MS Main plant system"

Procedure

1. Create an organizational structure.
2. Create an "MS Main plant system" object underneath this structure.
3. Create a "PS Plant system" object underneath this object.
4. Create a "Maintenance plan plant system" object underneath this object.
5. Create an "Administrative work package" object underneath this object.

3.5.3 Referencing a plant system

Object search

You can add functional locations to an existing plant system via the "Extra > Add TAGs to plant system" command in the toolbar of the "Object search" plugin.

Manually

If the "System element" tab exists at the functional location, you can move the required plant system object from the Navigator to the "Link to PlantSystem" field via drag&drop.

Context menu

If you are able to add the object to a plant system, the "Add to plant system" command will be available in the context menu.

3.5.4 Administrative work packages

Overview

You can create administrative work packages in plant systems. The associated work packages of the equipment or functional locations are linked to the administrative work package via an existing link to the plant system. The link is entered in the "Plant system" field on the "Object links" tab, provided that the "Link to plant system workpackage automatically" option is activated on the "Object links" tab relating to the work package in the base data.
Milestone activities

Administrative work packages are used to change the status of a plant system. They contain five milestone activities:

- "Prepare shutdown"
- "System shutdown completed"
- "Associated work completed"

The "Related work completed" milestone activity is reported as finished once the activities for the associated items of equipment are finished. The "Related system status" value on the "Plant system activity" tab is modified accordingly.

- "Prepare system reboot"
- "System start completed"

Linking work packages

To link existing work packages to the administrative work package, select the "Maintenance > Link to plant system work package" command from the context menu of the existing work package.

3.6 Maintenance

3.6.1 Maintenance plan

3.6.1.1 What is a maintenance plan?

Starting from the unit level, it is possible to define maintenance plans and create work packages and dates underneath them.

A maintenance plan has two functions:

- Management of the maintenance base data, for example calculating the maintenance date.
- Group object for the work packages actually executed on an object.

You cannot create any work packages without a maintenance plan.

Selecting a maintenance plan

Different maintenance plans are offered for selection depending on the object type you want to maintain.
3.6 Maintenance

3.6.1.2 Creating a maintenance plan

Procedure

1. Select the "Units" tab in the Navigator.
2. Right-click on the object for which you want to create a maintenance plan.
3. Select the "New" command from the context menu and select the type of maintenance plan you require.

Result

A maintenance plan object is created below the selected object. You can now create a work package underneath this.

3.6.1.3 Calculating work package dates

Procedure

1. Open the properties of the maintenance plan you want to edit.
2. Select the "Attributes > Maintenance plan" tab.
3. Click the "Edit calculation" button.
   The "Calculate work package dates" window opens.
4. Make the required settings.
5. Click "Apply".
   The date calculated for the next work package is entered in the "Date" field.
6. Save the settings you made.

Calculation using formulas and static date calculation

You cannot calculate using formulas if static date calculation is enabled. If both methods are used, the calculation by formula is ignored.

3.6.1.4 Calculating a maintenance date using a formula

Calculation using formulas and static date calculation

You cannot calculate using formulas if static date calculation is enabled. If both methods are used, the calculation by formula is ignored.
**Procedure**

1. Open the properties of the maintenance plan for which you want to enter a date calculation formula.
2. Select the "Attributes > Maintenance plan" tab.
3. Click the "Edit calculation" button.
   The "Calculate work package dates" window opens.
4. Click the "..." button of an already completed interval row.
   A formula editor opens. This is capable of processing all basic math calculations, bracket rules and powers.
5. Enter the required information.
   The syntax of the formula has already been checked by the interpreter for correctness during the input. Variables that are used correctly are displayed in blue, correct operators and brackets in black. If the syntax of the formula is incorrect, an error message is displayed and the element or elements involved are displayed in red.
   The result of the calculation is interpreted as days and added to the last maintenance date. To allow you to make calculations, you can declare any number of variables and assign values to them in the "Variable list" table at the bottom.
   With the "Insert system variable" button, you can used predefined system variables.
6. Enter a name for the variable in the "Variable" field.
7. Enter a value for the variable in the "Value" field.
   You can now use this variable name in the formula like a normal constant. This allows the maintenance date to be recalculated automatically based on the actual statuses of the equipment (for example, operating hours). You only need to update the value of the variable.
8. Click "OK" to save your entries and close the formula editor.
   The edited formula is entered in the "Formula" column in the "Calculate work package dates" window.
9. Click "Apply".
   The "Next date" field now contains the next date of all intervals and formulas of the list. If, for example, the "Next date" according to the interval is earlier than the next date according to the formula, the date based on the interval is entered, and vice versa. This makes a combined calculation possible so that, for example, a maintenance date depends on both an interval and on the operating hours.
10. Save the settings you made.

"Formula/Details" tab

You can attach the "Formula/Details" tab to the maintenance plan. If this tab exists at the maintenance plan, enter the variable names and values here or write them by means of a script.
3.6.1.5 Change maintenance date

Requirement

The internal attributes "DynamicBaseDate" and "StaticBaseDate" must be created in the "Attributes > Maintenance plan" tab of the maintenance plan.

Procedure

1. To change the date in a maintenance plan, right-click on the maintenance plan.
2. In the context menu, select the "Maintenance > Reschedule" command.
   The "Time planning" window opens. See also chapter "Time planning" window (Page 116).
3. Select one of the following options:
   – "Suspend execution"
     If you select this option, the date that you enter in the "New work package date" field is inserted into the "Next date" field. This new date must be later than the date that was entered in the "Next date" field. All planned work packages assigned to the maintenance plan with a planned date prior to the new date are canceled. If the "Canceled" option is not present in the "Attributes > Maintenance Plan" tab, all scheduled work packages are deleted.
   – "Postpone execution"
     If you select this option, the date of the associated work package is moved to the date specified in the "New work package date" field. The new date must be after the date in the "Next date" field. The dates of all scheduled work packages are adjusted based on the new date and the specified intervals. All scheduled work packages whose next date is after the new date plus a forewarn time are canceled. If the "Canceled" option is not present in the "Attributes > Maintenance Plan" tab, all scheduled work packages are deleted.
4. Save your entry.

Result

The new date is entered in the "Next date" field in the "Attributes > Maintenance plan" tab of the maintenance plan.

Example

"Last date": 2011.01.01
Interval: 1 month
Valid dates in the "Next date" field: 2011.02.01, 2011.03.01, 2011.04.01, ...
Entry in the "New work package date" field: 2011.03.15
COMOS generates an error message and suggests a valid date for the next date. You can accept this suggestion and continue, or cancel the procedure and enter a new date or change the interval.

See also

"Maintenance plan" tab (Page 112)

3.6.1.6 Archiving maintenance plans

Requirement

If all the associated work packages are canceled, you can archive the maintenance plan.

Procedure

1. Right-click on the maintenance plan.
2. Select the "Maintenance > Archive" command from the context menu.

Result

All scheduled work packages assigned to the maintenance plan are canceled. The "Maintenance active" option is deactivated in the "Attributes > Maintenance plan" tab of the maintenance plan.

See also

Canceling work packages (Page 29)

3.6.2 Work packages

There are three different types of work packages:

- Inspections - preventive and status-oriented maintenance: Inspections are checks such as visual checks and measurements. No repairs are made during an inspection. Inspections are generally put together to create a tour.

- Maintenance - preventive and status-oriented maintenance: Maintenance represents planned servicing activities to be undertaken, such as lubrication or calibration, for example.

- Repairs - reactive maintenance: Repairs are maintenance activities during which a defective device is returned to its original, fully functional status.
3.6.2.1 Creating a work package

Requirement

You have created a maintenance plan object.

Procedure

1. Right-click on the maintenance plan for which you want to create a work package.
2. Select the "New > WT Maintenance/work package" command from the context menu and select the type of work package you require.
   Depending on the setting for the base object, a window opens or the work package is created as real maintenance.
3. If a window opens, select one of the two options.

Result

A work package is created below the selected maintenance plan object.
When you create a work package, a device check is carried out. After opening the "Attributes > Work package" tab in the properties of the work package, the activated "Device OK" option indicates that the necessary devices have not exceeded their maintenance interval at the time of the work package. See also chapter Making the resource check (Page 38).

Options

If you select the "Plan work package" option, the date entered in the "Next date" field of the maintenance plan is entered automatically in the "Sched. date" field on the "Work package" tab. The "planned" status is set automatically.

If you select the "Real maintenance" option, the current system date is entered in the "Date" field on the "Work package" tab. The "in progress" status is set automatically if there are activities underneath the work package. If there are no pending activities, the status is automatically set to "tasks done". If activities are created underneath the work package, the status changes to "in progress".

Menu selection

If you have created a work package underneath the selected maintenance plan object, you can select the "Maintenance > New work package > Like last work package" command from the context menu. This creates a new work package from the base object of the most up-to-date work package. The task packages, activities, spare parts or devices, material reservations, and qualifications inserted underneath the last work package you created are also included underneath the new work package. A work package can also bring along standard activities and the associated resources or spare parts.

If you have created a spare part via a material reservation, only the material reservation is created when the "Maintenance > New work package > Like last work package" command is executed. To create the spare part, book the material reservation.
3.6.2.2 Canceling work packages

Procedure

1. Right-click on the work package you want to cancel.
2. Select the "Maintenance > Cancel work package" command from the context menu.

Result

The work package is grayed out in the Navigator. The "Canceled" status is inserted before the date in the name of the work package. The "Canceled" option is activated in the "Attributes > Work package" tab. See also chapter "Work package" tab (Page 118). You cannot edit the work package.

The "Last date" field in the "Attributes > Maintenance plan" tab of the higher-level maintenance plan is recalculated if the cancellation of the work package had an effect on it.

Lifecycle structure

If you use the lifecycle structure, all lifecycle link objects that reference the canceled work package are deleted.

Cancellation not possible

If a work package is part of a tour and inspections have already been assigned to the work package, you cannot cancel the work package.

If the work package is assigned to a shutdown, and the shutdown has already reached a state that allows no changes, you cannot cancel the work package. You can find more detailed information on this topic in the "Shutdown" manual.

If the work package is assigned to an order, and the order has already reached a state that allows no changes, you cannot cancel the work package. See also chapter Maintenance order (Page 51).

Effects on plugins

Canceled work packages are not evaluated in the following plugins:

- "Maintenance order"
- "Shutdown management"
- "Resource management"
- "Object search"

If the work package is assigned to a tour, the assignment to the tour is canceled.

If the work package is assigned to a shutdown, the assignment to the shutdown is canceled.

If the work package is assigned to an order, the assignment to the order is canceled.
3.6 Maintenance

Maintenance objects

See also
Reactivating a canceled work package (Page 30)

3.6.2.3 Reactivating a canceled work package

Procedure
1. Right-click on the canceled work package that you want to reactivate.
2. Select the "Maintenance > Reactivate work package" command from the context menu.

Result
The work package is no longer grayed out. The "Canceled" status is removed from the name. The "Canceled" option is deactivated in the "Attributes > Work package" tab. The next date of the associated maintenance plan is recalculated. A new object is created for each deleted lifecycle link object.

See also
Canceling work packages (Page 29)

3.6.2.4 Archiving work packages

Requirement
There is an activated option with the name "ArchiveFinishedWorkpackage" in the "Options > Maintenance" tab in the properties of the project. Contact the responsible administrator.

Procedure
1. Right-click the work package.
2. Select the "Maintenance > Archive work package" command from the context menu.

Result
The "Archive" folder is created under the associated maintenance plan. The archived work package is moved into the "Archive" folder. If you use the lifecycle structure, the lifecycle link object, not the lifecycle object, is moved to the "Archive" folder. Archived work packages are included in searches for work packages.
3.6.3 Report

3.6.3.1 Report

You can create a report underneath a work package. The following report serves as an example.

<table>
<thead>
<tr>
<th>Task</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1201</td>
<td>Dismount</td>
</tr>
<tr>
<td>1202</td>
<td>Mount</td>
</tr>
<tr>
<td>1202</td>
<td>Uninstall</td>
</tr>
<tr>
<td>1203</td>
<td>Clean device</td>
</tr>
<tr>
<td>1204</td>
<td>Setup scaffolding</td>
</tr>
</tbody>
</table>

Task finished: [ ]

Actual time: 0

Total time: 10
3.6.3.2 Report "Configuration" tab

Overview
The report "Configuration" tab at the subordinate level is used to set the information that will be displayed on the report.

3.6.4 Creating a task package
A task package puts several tasks together to form a package.

Procedure
1. Right-click on the work package underneath which you want to create the task package.
2. Select the "New > Task package" command and select the required option.

Result
The node for the task package is created underneath the work package.
You can now create the required activities underneath the task package.

3.6.5 Base package

3.6.5.1 What is a base package?
A base package is a template for a work package that can be defined per maintenance plan. You can group activities to form task packages within a base package and these can then be selected as required. If work packages of the same scope need to be performed repeatedly for a device, it is advisable to work with base packages.

3.6.5.2 Creating a base package

Procedure
1. Select the maintenance plan for which you want to define a base package.
2. Open the context menu and select the "Maintenance > New work package" command.
3. Select one of the two options.
   A work package is created below the selected maintenance plan object.
4. Create the required activities and task packages with the appropriate activities underneath the work package.
5. Right-click on the work package to be used as a template for the base package.

6. Select the "Maintenance > Create base package" command from the context menu, along with the required option.

Result

The base package has been created.

Converting or cloning

You can either convert or clone work packages. To do this, select the "Maintenance > Create base package" command from the context menu. If you select the "convert" command, a base package is generated immediately from the work package. You can only execute this command if the work package is not yet being used, for example, it has not yet been linked to a tour or shutdown.

If you select the "clone" command, the work package remains unchanged and a copy of the work package is converted to a base package. These base packages consist of activities and the qualifications of the cloned work package. The planning times relating to the activities are adopted too.

Base packages in the lifecycle structure

If you use the lifecycle structure, converted base packages are moved below the maintenance plan object in the unit structure under which you originally created the work package.

See also

Concept (Page 93)

3.6.5.3 Creating a work package like the base package including package selection

Introduction

If a base package with task packages already exists underneath a maintenance plan, when you create a new work package you select which task packages are to be created.

Procedure

1. Right-click on the maintenance plan underneath which you want to create the work package like the base package including task packages.

2. Select the "Maintenance > New work package > Like base package (incl. package selection)" command from the context menu.
3. Select the required task packages.
4. Select one of the following options:
   - To apply your selection, click "OK".
   - To cancel the action, click "Cancel".

Result

The node of the configured work package is created underneath the maintenance plan object.

3.6.6 Activities

When you create a work package, activities to be performed within the work package are also created by default.

Adding activities

These default elements are defined by the administrator.

You can add further activities. In this case, a distinction is made between additional activities and additional activity charged according to time/effort (additional work).

Editing an activity

- You can change the description of the activity. However, you should only change the description of planned activities in exceptional cases, since activities can also have predefined planning times that relate to the task.
- If there are activities underneath a real maintenance that have not yet been performed, the maintenance status is "in progress". If all activities are reported as completed, the maintenance status on the "Work package" tab changes to "Completed tasks".
- Activities can be reported as being partly completed (completion %) or fully completed ("task done"). If you do not need an activity, report it as completed on the "Activity" tab using the "Not needed to be done" option.

3.6.7 Creating an activity

Procedure

1. Right-click on the work package for which you want to create an activity.
2. Select the "New > @ STEP Activities" command from the context menu and select the type of activity you require.
Result

The activity is created underneath the selected work package.

3.6.8 Qualification

3.6.8.1 What is a qualification?

You create qualifications underneath an activity. A qualification specifies the type of qualification the person requires who will perform the activity or who performed it.

You also specify the hourly rate to be calculated for performing the activity. Hourly rates can also be specified by an administrator at the qualification's base object.

In addition, you specify a number of hours that will be required for the activity.

"Direct" plugin

When the activity reports back via the "Direct" plugin, a reference to the person who actually performed the activity is inserted underneath the qualification.

See also

"Qualification" tab (Page 124)

3.6.8.2 Creating a qualification

Procedure

1. Right-click on the activity for which you want to create a qualification.

2. Select the "New > Q Qualification" command from the context menu and select the type of qualification you require.

Result

A qualification is created underneath the selected activity.

You need to create a qualification before you can assign the activity to a person or define the required hourly rate.
3.6.8.3 New qualification objects

Separation of live and base data
You can enter fixed data at the qualification's base object on the "Attributes > Qualification" tab. You create a requirement object for the qualification in the planning project. The data from the base project is not displayed on the "Qualification" tab of this requirement object. You can enter data that applies to this requirement only here.
These settings can be evaluated in the "Resource monitor" plugin.

3.6.8.4 Using new qualification objects

Project properties
To use the new qualification objects and the structure that belongs to them, activate the "Use new qualification objects" option on the "Options > Maintenance" tab in the properties of the planning project.
If you select an entry from the "Qualification compare mode" list, this affects the comparison of the qualifications in the "Resource management" plugin. In the "Shift management" plugin, however, the qualification is always compared to the base object, since only the base object of the qualification can be set in the "Shift management" plugin.

3.6.8.5 Requirement object of the qualification

Base object
You will find the base object for qualification requirements under "@CBO > @CompObj > PERS > QR > 01 Internal qualification requirement".

Creating a requirement object
Create the requirement object for the qualification below the desired activity and set a reference to the quality object from the base object.

3.6.9 Calculating the costs of an activity

Procedure
1. Open the properties of the qualification assigned to the activity.
2. Select the "Attributes > Qualification" tab.
3. Select an hourly rate filter and an hourly rate in the "Qualification" control group.
4. Enter the required number of hours in the "Expenditure of time planned" field in the "Planned working time" control group.
5. Click the "Transfer times and costs into steps" button. The "Planned costs" and "Sell price planned" fields are filled in automatically.
6. Save the settings you made.
7. If necessary, repeat steps 1 to 6 for all the qualifications you have created for the activity.
8. Switch to the activity underneath which the qualification is found.
9. Open the properties of the activity.
10. Select the "Attributes > Activity" tab.

Result

The calculation of the costs for the qualification has been transferred to the "Activity" tab. If you have created several qualifications and performed calculations for them, the costs for all the qualifications are added together and the total cost displayed.

3.6.10 Creating a spare part

If you require spare parts for an activity, enter them underneath the activity. You can repeat this procedure as often as you need to. When you create some activities, the necessary spare parts are also created as default.

Procedure

1. Right-click on the activity for which you want to create a spare part.
2. Select the "New > ET Spare part" command from the context menu and select the spare part you require.

Result

The node for the spare part is created below the activity.

3.6.11 Inserting a spare part from a store

Procedure

1. Select the activity for which you want to insert a spare part from a store.
2. Select the "Maintenance > Insert material from store" command from the context menu. The "Select material" window opens.
3. Select the spare part you want to insert from a store.
4. Click "OK" to confirm your selection.

The "Bulk material" window opens. See also chapter "Bulk material" window (Page 125).
5. Make the required settings.
6. Click "OK" to confirm your selection.

Result

The spare part is created underneath the activity.

3.6.12 Creating a device

Procedure

1. Select the activity for which you want to create a device.
2. Select the "New > BM Device" command from the context menu and select the required device.

Result

The device is created underneath the activity.

3.6.13 Making the resource check

The device check makes sure that none of the devices used has exceeded its maintenance date. This check is made automatically when a maintenance plan is cloned. You can also start the resource check manually.

Procedure

1. Right-click on the work package for which you want to check the resources.
2. Select the "Maintenance > Device check" command from the context menu.

Result

A resource check is run. If none of the devices has exceeded its maintenance date, the "Device OK" option is activated on the "Attributes > Work package" tab of the work package. See also chapter "Work package" tab (Page 118).
3.6.14 Tour

3.6.14.1 Tour

This functionality puts together individual work packages to be performed in a plant and creates a tour.

A tour consists of an administrative part and the individual work packages. The administrative part is known as the tour itself and the work packages are known as inspections.

Creating a tour

You create a tour underneath the object that encompasses all the inspections covered by the tour; underneath a unit or a unit part, for example.

Requirement

Before you create a tour, you must first create the maintenance plans for the tour and the inspections belonging to the tour. See also chapter Creating a tour maintenance plan (Page 40) and chapter Creating associated inspections (Page 44).

3.6.14.2 Tour configuration

Options for creating a tour

You have three different options when it comes to creating a tour. The responsible administrator decides which of these options will be used as a default. See also chapter "Tour configuration" tab (Page 127). The "Options for creating inspections" list in the "Tour configuration" tab contains the following options:

- "Create tour without inspections (norm)"
  
  If this option is activated, no inspections are created when you create a tour. The user can select the inspections later. This is done by selecting "Create associated work packages" in the context menu of the inspection.

- "Display the dialog for creating inspections at the creation of a tour"
  
  If this option is activated, a new tour work package is created underneath the tour maintenance plan and the "Create objects" window opens.

- "Create all inspections automatically at the creation of a tour"
  
  If this option is activated, inspections are created automatically for all maintenance plans assigned to a tour maintenance plan and are then assigned to the tour work package.
3.6.14.3 Creating a tour maintenance plan

Before you create a tour, you must create a tour maintenance plan.

Procedure

1. Right-click on the object for which a tour is to be created; a unit, for example.
2. Select the "New > MTO Maintenance plan tour" command from the context menu.

Result

A tour maintenance plan is created underneath the selected object. A tour maintenance plan has the same tabs as a maintenance plan.

See also

"Configuration" tab (Page 110)
"History" tab (Page 110)
"Legal care" tab (Page 111)
"Sub maintenance" tab (Page 111)
"Formula/details" tab (Page 111)
"Maintenance plan" tab (Page 112)
"Responsibilities" tab (Page 114)

3.6.14.4 Linking a maintenance plan to a tour maintenance plan

Procedure

1. Open the properties of the maintenance plan you want to link to a tour maintenance plan.
2. Select the "Attributes > Sub maintenance" tab.
3. Drag & drop the tour maintenance plan from the Navigator to the "Tour/master" field of the "Sub maintenance" tab.

4. Save your settings.

   The maintenance plan has been linked to the tour maintenance plan and a tour with the associated activities can be created underneath the tour maintenance plan.

   Depending on the setting on the "Tour configuration" tab, either all, none, or only the inspection packages you have selected in the dialog are created.

5. Repeat steps 2 to 6 for each maintenance plan you want to link to the tour maintenance plan.

3.6.14.5 Dynamic linking of work packages to tours

Requirement

The "Link to tour automatically" option is activated in the "Attributes > Object links" tab of the tour work package. The "Create tour without inspections. (norm)" entry is selected at the base object of the tour work package in the "Options for creating inspections" list of the "Attributes > Tour configuration" tab.

The desired maintenance plans are linked to the tour. The tour is not yet completed.

Evaluation

The work package is linked to the tour whose planned date is within the period set in the "Date from" and "Date to" fields of the "Attributes > Object link" tab and whose date is furthest in the future. A reference to the tour is set in the "Tour" field.

If no tour is found, no tour is linked.

See also

"Object links" tab (Page 117)

Linking a maintenance plan to a tour maintenance plan (Page 40)
3.6.14.6 Putting together a tour with Object search

Requirement

You use the object search function to find the inspections you want to group into a tour. You must have created the corresponding inspections and tour for this purpose.

Procedure

1. Open the "Object search" plugin.
2. Drag&drop the object underneath which you want to search for inspections to the "Start object(s)" field.
3. From the "Class" list, select the "Work package" entry.
4. Click the "Start search" button.
   The result of the search is listed.
   If you do not want to link a particular work package to the tour, right-click on the relevant search result and select the "Remove from result" command.
5. Open the "Extra" list in the menu bar of the plugin.
6. Select the "Add result collection to tour" command.
   The "Add to tour object" window opens.
7. Drag & drop the relevant tour work package to the "Add to tour object" field.

8. Click "OK" to add the selected tour work package to the tour.

   If one of the search results was already assigned to a tour, the "General maintenance" window opens. If you want to overwrite the existing assignment, click "Yes". If you do not want the previously assigned work packages to be reassigned, click "No".

   The "General maintenance" window opens.

9. Save your settings.

Result

The selected inspections are assigned to the tour.

Once the search for work packages is complete, the "Add result collection to tour" command becomes active. Following this, you can assign all objects found during the object search to the tour.

The equipment is sorted for the reports. This sorting is tantamount to routing for the tours. Sorting is specified in the "Location sort field" field on the "Device-specific assembly data" tab of the equipment.

3.6.14.7 Deleting the assignment of the individual maintenance plans to the tour maintenance plan

Procedure

1. Open the properties of the sub maintenance plan underneath the equipment whose assignment you want to delete.

2. Select the "Attributes > Sub maintenance" tab.
3. Click the "Remove pointer" button.
4. Save your settings.

### 3.6.14.8 Deleting the assignment of an inspection to the tour maintenance plan

#### Procedure
1. Open the properties of the inspection whose assignment you want to delete.
2. Select the "Attributes > Object links" tab.
3. Click the "Remove pointer" button to the right of the "Tour" field.
4. Save your settings.

### 3.7 Inspections

#### 3.7.1 What are inspections?

**General**

Which inspections are created automatically with the tour and which inspections you need to create manually are specified by your administrator in the base data for the base object of the tour work package on the "Attributes > Tour configuration" tab. See also chapter "Tour configuration" (Page 39). You set the way in which the inspections are created on the "Attributes > Configuration" tab of the linked inspection maintenance plan. See also chapter "Configuration" tab (Page 110).

#### 3.7.2 Creating associated inspections

**Introduction**

If the "Create tour without inspections (norm)" option is selected at the base object of the tour work package, you can create the inspections associated with the tour at a later time.
Procedure

1. Right-click on the tour for which you want to create an inspection.
2. Select the "Maintenance > Create associated work packages" command from the context menu.
   The "Select devices" window opens.
   COMOS checks whether inspections have been created. If an inspection has already been created, the option for this inspection is already enabled in the "Select devices" window.
3. Activate the options of additional inspections that you want to create.
4. Click "OK" to confirm your selection.
   A window opens.
5. Click "OK".
   If you have created all links correctly, the "All work packages created successfully" window opens. If not all the work packages were created, an error message opens that indicates how many work packages were created.

Result

When you confirm your selection, the selected inspections are created.

3.7.3 Automatic creation of work packages/inspections

"Options for creating inspections" list

You specify the template used to create the inspections along with the tour via the inspection maintenance plan, on the "Attributes > Configuration" tab. See also chapter Configuration tab (Page 110).

The "Options for creating inspections" list contains the following options:

- "Like base package"
  The inspections and work packages created underneath the relevant maintenance plan are created based on the template of the base package. If no base package exists, no inspection or work package is created.

- "Like last work package"
  The inspections and work packages are created based on the template of the last work package that was created. If no previous work package exists, no inspection or work package is created.

- "With selected base object"
  The inspections and work packages are created based on the template of the selected base objects. If there is no reference in the "Base object of work package" field, no inspection or work package is created.
3.7 Inspections

- "Symbol"
  This option is not relevant here; it is part of the "Inspection" plugin.

- "Like local base package"
  The inspections and work packages are created based on the template of the first basic package which is found below the maintenance plan. If no base package exists, no inspection or work package is created.

- "Like external base package"
  The inspections and work packages are created based on the template of the basic package which is linked in the "External base package" field in the "Attributes > Configuration" tab. If no external base package is linked, no inspection or work package is created.

- "Like strategy base package"
  The inspections and work packages are created based on the template of the basic package which is located directly below the maintenance plan of the linked strategy reference. You can link the strategy reference in the "Strategy reference" field of the "Attributes > Configuration" tab of the maintenance plan.

- "Like strategy external base package"
  The inspections and work packages are created based on the template of the basic package which is linked in the "External base package" field at the maintenance plan of the strategy reference.

If you do not select an entry, the work package displayed first under the "New" context menu command is created.

Base package order

If you have selected the "Like base package" entry at the base object of the maintenance plan from the "Create new work package" list of the "Attributes > Configuration" tab, you specify in the "Base package order" table the order in which COMOS should search for a template for creating inspections and work packages. If no entry in the table is suitable, no work package is created.

The order defined in the table is also evaluated in the context menu of the Navigator and displayed under "Maintenance > New work package > Select base package".

Defaults

In order for work packages to be created automatically, the "Create work package automatically" option must be activated on the "Configuration" tab of the maintenance plan. If the next maintenance date of the maintenance plan changes, a new planned work package with this date will be created.

If a planned work package already exists, the user is informed that no new planned work package could be created.

To create the inspection via the tour, the "Create work package automatically" option does not need to be activated.
3.7.4 Linking an inspection to a tour automatically

Procedure

1. Open the base project.
2. Select the "Base objects" tab in the Navigator.
3. Open the properties of the relevant inspection object.
4. Select the "Attributes > Object links" tab.
5. Activate the "Link to tour automatically" option.
   See also chapter "Object links" tab (Page 117).
6. Save your settings.

If the "Link to tour automatically" option is activated, all linked inspections created in the planning project with this base object are linked to the tour. Based on the link to the maintenance plans, the inspection searches for the most recent tour work package that has not yet been reported as finished.

3.8 Calibration

3.8.1 What is calibration?

Inspection and calibration belong to the comparative maintenance.

During calibration, the reading of a measuring device is compared with the standard test reading (comparison measuring device). If the reading of the measuring device is outside the permitted tolerance, it must be calibrated.

During an inspection, the reading of an approved measuring device is compared with defined desired values.

3.8.2 Creating a basic structure for calibration

Procedure

1. Create, for example, a functional location of the type "general sensor/measuring".
2. Create a piece of equipment of the type "general sensor/measuring" underneath the functional location.
3. Create a maintenance plan of the type "calibration" underneath the equipment.
4. Create a work package of the type "calibration" underneath the maintenance plan.
   This work package will later be converted to a base package.
5. Create an activity of the type "calibration" underneath the work package.

3.8.3 Creating a measurement series

Procedure

1. Create the basic structures for a calibration.
   See also chapter Creating a basic structure for calibration (Page 47).
2. Right-click on the activity of the type "calibration" for which you want to create a measurement series.
3. Select the "New > Measurement series calibration" command from the context menu and select the required object.

Result

The measurement series object is created underneath the activity.

See also

Defining the desired values of the measurement series (Page 48)

3.8.4 Defining the desired values of the measurement series

Procedure

1. Open the properties of the measurement series object for which you want to define a measurement series.
2. Select the "Attributes > Measurement data" tab.
3. Enter the required number of measurement points in the "Number of measurement points:" field.
4. Click the "+" button.
   A separate row is created for each measurement point in the "Values" table.
5. Enter the required setpoint of the measurement point in the "Setpoint" column.
6. Enter the maximum accepted deviation of the measured value from the setpoint in the "Acceptance" column.
7. Save your entry.
3.8.5 Creating a calibration reference

The measuring device or the measurement itself is known as a calibration reference.

Procedure

1. Right-click on the activity of the type "calibration" underneath which you want to create the calibration reference.
2. Select the "New > BM Device > CR Calibration reference" command from the context menu.

Result

The calibration reference is created underneath the node of the activity.

3.8.6 Completing a work package definition

Procedure

1. Convert the defined work package to a base package.
2. Create a new work package with the "Maintenance > New work package > Like base package" command from the context menu.

3.8.7 Calculating the deviation of the measured values

Procedure

1. Open the properties of the required measurement series object.
2. Select the "Attributes > Measurement data" tab.
3. Enter the display values in the "Display" column.
4. Enter the values measured at the measuring points in the "Reading value" column.

   The comparison of the measured value with the displayed value starts automatically. The deviation is calculated from the SI units of the values in percentage. The status changes to "Measuring in progress".

   Once the calculation is completed, the status of the measurement changes to "Measuring finished" and the activity is reported as being completed.
5. Save your settings.
3.9 Legal care objects

Result

The calculation to establish whether the acceptance criteria are fulfilled starts automatically. If the acceptance criteria are met, the “Acceptance fulfilled” option on the “Measurement data” tab is activated automatically.

3.9 Legal care objects

Requirement

You have defined legal care objects in the planning project.

You will find base objects for legal care objects underneath the “CBO > @LC” node. Use this object as a template and configure it in the planning project as required.

Legal texts

You can attach the legal text to the legal care object as a text file, a PDF, or a web link.

You can find additional information on this topic in the "Document Management" manual, keyword "Drag&drop import".

Overview

To record that an activity is performed in accordance with certain laws, the activity must be linked to a legal care object.

In order to be able to respond to changes in the legal situation, you define the law links using a base package. If the legal situation changes, you can define a new base package according to the new requirements and update the links to the legal care objects. Archive the old base package and create a reference to the newly defined base package.

Procedure

1. Create a base package which contains the activities prescribed by the legal object.
2. Open the properties of the base package or activity which you want to link to the legal object.
3. Select the "Attributes > Legal care" tab.
4. Drag&drop the desired legal care object from the Navigator into the "Link" list.

Result

The legal object is linked to the base package or activity.

You evaluate legal care objects by means of reports, queries, or the lifecycle structure, for example.
"General maintenance" plugins

4.1 Maintenance order

4.1.1 "Maintenance order" plugin

This plugin is used to assign work packages to commercial orders.

4.1.2 Creating an order collector

Requirement

Before you create commercial orders, you create an order collector to collect the orders below an object.

Procedure

1. Right-click on the company object for which you want to create an order collector.
2. Select the "New > BO Commercial" command from the context menu.

Result

The node for the order collector is created underneath the company object.

You can create commercial orders using either the context menu of the right mouse button or the "Maintenance order" plugin.

4.1.3 Opening the "Maintenance order" plugin

Procedure

1. Click on "Plugins" in the menu bar.
2. Select the "Maintenance > General maintenance > Maintenance order" command.

Result

The "Maintenance order" plugin opens.
4.1.4 Creating an order via the "Maintenance order" plugin

Procedure

1. Open the "Maintenance order" plugin.
2. Drag&drop the required company object to the "Company" field if the required object is not already displayed here.
3. Click the "Open order" button in the menu bar of the plugin.
   The "New order" window opens.
4. Enter the required information.
   - The "Order kind", "Order no.", and "Date of receipt" fields are mandatory and you must fill them in. As default, the current system date is entered in the "Date of receipt" field.
   - The entries in the "Order kind" list are created in the base project by the responsible administrator. All objects found underneath the "CBO > @MntcObj > BO > ORDER Commercial order" base object appear in the list for selection.
5. Save your settings.

Result

The "New order" window closes. A new row is added to the table of the plugin. The order object is created underneath the order collector on the "Units" tab in the Navigator.

4.1.5 Creating order data

Procedure

1. Open the "Maintenance order" plugin.
2. Drag&drop the required company object to the "Company" field if the required object is not already displayed here.
3. Drag&drop the required order object to the "Order" field.
4. Click the "Edit order" button in the menu bar of the plugin.
   The "Order data" window opens.
5. Enter the required information.
6. Save your settings.
4.1.6 Creating a work package via the "Maintenance order" plugin

Procedure

1. To open the "Maintenance order" plugin, select the menu command "Plugins > Maintenance > General maintenance > Maintenance order".
2. Drag&drop the required company object to the "Company" field if the required object is not already displayed here.
3. Drag&drop the required order object to the "Order" field.
4. Drag&drop the maintenance plans for which you want to create work packages to the table of the plugin.
   The maintenance plans are listed.
   To add maintenance plans for specific equipment, select, for example, the "Identity" entry from the "Add with" list and enter the name of the equipment in the field to the right of the list (for example, "PU1"). Press the Enter key. If there is more than one maintenance plan underneath the equipment, the "Add maintenance plans" window opens. Select the maintenance plan for which you want to create work packages. Confirm your selection. The maintenance plan is added to the table of the plugin.
5. Double-click in the "work package" cell of the relevant maintenance plan.
   To create all work packages, click the "Auto-create work packages" button in the menu bar of the plugin.
6. Select the work package you want to create from the list.
7. Enter the date with which the work packages will be created in the "Package date" field.
8. Click "Apply".

Result

All work packages are created underneath the relevant maintenance plan in the plant structure. The work packages are displayed in the table in the "Work package" column.

4.2 Manual maintenance preview

4.2.1 "Manual maintenance preview" plugin

General

This tool allows a preview of the pending work packages, for example in certain areas or periods. This plugin is basically a preconfigured search.

See also chapter Tab of the "Object search" plugin (Page 128).
"General maintenance" plugins

4.3 Maintenance Demon

Colors for the status

The colors of the manual maintenance preview show the status of the maintenance plan. The status is also output as text.

"Membership" column

The "Membership" column shows which maintenance plans belong together. You define membership via membership queries, which are found in the base objects underneath the "@CBO > @Q > MBS Membership queries" node.

Use the "Navigate > To membership parent" command in the context menu to navigate to the associated maintenance plan.

Events

Events are created automatically, depending on the result of the evaluation, and stored on the "Units" tab underneath the "EVC Event collector" object.

See also chapter Tab of the "Manual maintenance preview" plugin (Page 133).

4.2.2 "Membership options" window of the "Manual maintenance preview" plugin

Overview

Using the membership search, you can expand the search for maintenance plans beyond the basic filter settings. When a maintenance plan is found, the search continues for other maintenance plans that are related to the one already found (for example, all maintenance plans of devices installed in a pipe). With the "Membership - Options" application area, you can call up available, predefined queries.

4.3 Maintenance Demon

4.3.1 "Maintenance demon" plugin

General

The main task of the "Maintenance demon" plugin is to search the database for maintenance plans that are due and, where necessary, to inform the person responsible by e-mail. The planned work packages for due maintenance plans can also be created automatically.

The automatic sending of emails or the creation of work packages can be implemented with the help of the enterprise server. Contact the responsible administrator.

You can find additional information on this topic in the "Enterprise Server" manual.
4.3.2 Preparing data for the "Maintenance demon" plugin

Settings

Before you work with the "Maintenance demon" plugin, you make several settings in the properties of the maintenance plan.

Activate the "Automatic preview" option on the "Attributes > Maintenance plan" tab so that, when a forewarn time is reached for the maintenance date, a notification is sent to all persons entered on the "Attributes > Responsibilities" tab whose "Notify" option is activated.

To create work packages automatically, activate the "Create work package via Maintenance Demon" option on the "Attributes > Configuration" tab.

"Create work package automatically" option

To avoid incorrect entries, do not activate the "Create work package automatically" option at the same time as the "Create work package via Maintenance Demon" option.

Linking of options

If you activate the "Create work package via Maintenance Demon" option on the "Attributes > Maintenance plan" tab, the "Automatic preview" option is also activated automatically.

The "Create work package via Maintenance Demon" option is linked to the option of the same name on the "Attributes > Configuration" tab.

4.3.3 Opening the "Maintenance demon" plugin

Requirement

You have administrator rights in COMOS.

Procedure

1. Click on "Plugins" in the menu bar.
2. Select the "Maintenance > General maintenance > Maintenance demon" command.

The menu command is not visible without administrator rights.

Result

The "Maintenance demon" plugin opens.

See also

Tab of the "Maintenance demon" plugin (Page 137)
4.3.4 Scanning maintenance plans

Procedure

1. Prepare the data of the maintenance plans you want to scan.
   
   See also chapter Preparing data for the "Maintenance demon" plugin (Page 55).

2. Open the "Maintenance demon" plugin.

3. Drag&drop the required start object to the "Start object(s)" field.

4. Click the "Scan maintenance plans" button.

Result

The result of the scan is listed in a table.

Context menu

From the context menu, you can navigate to the relevant maintenance plan on the "Units" tab in the Navigator or send a notification to the responsible persons.

See also

"Sub maintenance" tab (Page 111)

4.3.5 Creating multiple work packages for each maintenance plan

Requirements

The maximum number of work packages to be created is entered at the "MAINTENANCEDEMON > MaxNbrOfPlannedPackages" parameter in the user-specific project options. The value "10" is entered here as the default.

If you create work packages via the Enterprise Server, you have the option of defining the maximum number of work packages to be created in the configuration file. Contact the responsible administrator.

A forewarn time is specified in the "Attributes > Maintenance plan" tab in the properties of the maintenance plan. If you do specify a forewarn time, only one work package is created for each maintenance plan.
Conditions

To create several work packages for a maintenance plan using the "Maintenance Demon" plugin, one of the following conditions must be met:

- The system date plus the forewarn time must be greater than or equal to the next date of the maintenance plan.
- The system date plus forewarn time must be greater than or equal to the date calculated based on the scheduled date of the last planned work package.

Example:

Settings made:
- Weekly inspection
- Forewarn time: 30 days
- Scheduled date: "Today"

Work packages (+7 days each) are created until the date of the next planned work package exceeds the forewarn time of 30 days.

See also

"Configuration" tab (Page 110)
"Maintenance plan" tab (Page 112)
"General maintenance" plugins

4.3 Maintenance Demon
"Events" plugin

5.1 "Event manager" plugin

The "Event manager" plugin is the tool with which you manage and edit events. You can run this plugin in two different modes:

- Collector mode
- Structural mode

Collector mode

In collector mode, the "EVC event collector" node is created underneath the project node and contains links to all active events.

Structural mode

In structural mode, a parallel structure is created on the "Units" tab in the Navigator underneath the unit structure. The actual event objects are created in this parallel structure and displayed as links in the plant structure.

Optimizing performance

The structural mode or the lifecycle structure can be used for performance optimization when managing large numbers of events.

Selecting the mode

You should decide on one mode or the other and then stick to this mode.

Starting the "Event manager" plugin automatically

You can also start the "Event manager" automatically when a project is opened. The plugin is then displayed in a window. This setting is not recommended. If you want to start the Event manager automatically when you open the project instead of using the plugin, contact the responsible administrator.
5.2 Preparing data for the "Event manager" plugin

Before you use the "Event manager" plugin, you make several default settings in the properties of the planning project.

Procedure

1. Open the properties of the planning project.
2. Select the "Options > Maintenance" tab.
   
   See also chapter "Options > Maintenance" tab of the project (Page 101).
   
   – Activate the "Use Event manager" option.
   
   The Event manager is opened automatically when you start COMOS.
3. If you want to use structural mode, activate the "Structural mode" option.
4. Save your settings.

5.3 Events

The sum of all events defines the overall plant status. An event can, for example, be a fault message, a notification/indication or a maintenance request. Events should always be created underneath the object with which they occur.

5.4 Creating an event

Procedure

1. Right-click on the object for which you want to create an event.
2. Select the "New > EV Events/Incidents" command from the context menu and select the required option.

Result

If you selected structure mode, the event object is created in the parallel structure. A link is created underneath the node of the selected object.

If you selected collector mode, an event collector object is created underneath the project node. The event object is created underneath the selected object. A link is stored underneath the event collector.

Identifying new events

Newly created events are indicated in red in the index column of the "Event manager" plugin.
5.5 Opening the "Event manager" plugin

Procedure

1. Click on "Plugins" in the menu bar.
2. Select the "Maintenance > Events > Event manager" command.

Result

The "Event manager" plugin opens.

5.6 "Easy event" plugin

Using the "Easy event" plugin, you can create events that will either be displayed in the "Event manager" plugin immediately or at a later time.

5.7 Opening the "Easy event" plugin

Procedure

1. Click on "Plugins" in the menu bar.
2. Select the "Maintenance > Events > Easy event" command.

Result

The "Easy event" plugin opens.

5.8 Creating an event via the "Easy event" plugin

Procedure

1. Open the "Easy event" plugin.
2. Drag&drop the object for which you want to create an event to the "Object" field.
3. Enter the required information.
   - If you have selected an event type from the "Type" list, the properties of the event object are displayed and you can edit them.
4. Save the information you entered.
Result

The event object is created underneath the selected start object on the "Units" tab in the Navigator.
"Resources" plugin

6.1 Resource management

6.1.1 Preparing data for the "Resource management" plugin

On the "Attributes > Qualification" tab of the qualifications of individual activities, the "Planned working time" field must normally be filled in. If you click the "Transfer times and costs into steps" button, the data is passed to the activities. See also chapter "Qualification" tab (Page 124). The expected time and the planned working units are now entered on the "Activity" and "Resource planning" tabs. See also chapter "Activity" tab (Page 122) and chapter "Resource planning" tab (Page 121). The start and end dates are calculated in the plugin.

6.1.2 Opening the "Resource management" plugin

You use the "Resource management" plugin to plan the scheduling of absences, activities, and their work packages and to assign people to activities.

Procedure

1. Click on "Plugins" in the menu bar.
2. Select the "Maintenance > Resources > Resource management" command.

Result

The "Resource management" plugin opens.

6.1.3 Color display of absences

Color display

What type of absence is displayed with what color is set by the responsible administrator and can be seen in the legend. Hatched surfaces indicate that the corresponding person is not employed at this time.

You manage this information in the "Date of joining" and "Date of quitting" fields on the "Attributes > Personal data" tab in the properties of the person object.
6.1.4 Displaying absences

Procedure

1. Open the company database.
2. In the menu bar, select the "Plugins > Maintenance > Resources > Resource management" command.
3. Select the "Absences" filter.
4. Drag&drop the object to the "Start object" field underneath which the person was created (company, department, person).
   The evaluation starts automatically. The result of the evaluation is listed in a table.
   If a result is displayed with "***" in the first column, the subordinate nodes will be loaded and displayed by clicking on "***". The same applies to "*" in the first table column. Here, the subobjects are already preloaded. If a result is displayed with "--" in the first column, the entries that follow are subnodes of this result.
5. Expand the individual results as far as necessary to be able to see the persons relevant to you.

Result

The absences of the individual persons are displayed in the calendar to the right of the results list.

6.1.5 Creating an absence

You can only create absences for a period for which no absence has yet been created. Overlapping absences are not permitted.

Procedure

1. Open the company database.
2. In the menu bar, select the "Plugins > Maintenance > Resources > Resource management" command.
3. Select the "Absences" filter.
4. Drag&drop the person for whom you want to create an absence to the "Start object" field.
5. The evaluation starts automatically.
   The result of the evaluation is listed in a table.
6. Right-click on the person for whom you want to create an absence.
7. Select the "New absence" command from the context menu.
   The "Add/Edit absence" window opens.
8. Enter the required information.
9. Save your entry.

Result

The newly created absence is displayed in the calendar to the right of the person's name.

6.1.6 Editing an absence

Procedure

1. Open the company database.
2. In the menu bar, select the "Plugins > Maintenance > Resources > Resource management" command.
3. Select the "Absences" filter.
4. Drag&drop the person for whom you want to edit the absence to the "Start object" field.
   The evaluation starts automatically. The result of the evaluation is listed in a table. The already created absence is displayed in the calendar to the right of the person's name.
5. Select one of the following options:
   - If you want to shorten or lengthen the absence of a person, click on the bar in the calendar. The color of the bar changes because the bar can now be edited. You can change the length of the bar, in other words, the start and end date of the absence, at the two ends of the bar. If you want to move the entire bar, click in the middle of the bar and move it to the required position. The length of the absence is retained.
   - If you also want to edit the reason for the absence or add a comment, double-click on the bar. The properties window of the absence opens. Enter the required information. You can also edit the start and end dates here. Click "OK" to apply your changes.
6. Save the information you entered.

6.1.7 Importing absences

You can import both "TXT" and "CSV" files.

Procedure

1. Open the company database.
2. In the menu bar, select the "Plugins > Maintenance > Resources > Resource management" command.
3. Select the "Absences" filter.
4. Drag&drop the person for whom you want to create an absence to the "Start object" field.
   The evaluation starts automatically. The result of the evaluation is listed in a table. The already created absence is displayed in the calendar to the right of the person’s name.
   Overlapping absences are not permitted.

5. Right-click on the name of the person for whom you want to import absences.

6. Select the "Import absences ..." command from the context menu.
   The "Open" window opens.

7. Select the file you want to import.

8. Click "Open".

9. Save your settings.

Result

The absences are indicated by a bar in the calendar. The objects of annual planning are created underneath the person on the "Units" tab in the Navigator.

6.1.8 Assigning an activity to a person

Procedure

1. Open the "Resource management" plugin.

2. Select the "Work packages" filter.

3. Drag&drop the object underneath which the activities you want to assign are located to the "Start object" field.
   The evaluation starts automatically. The result of the evaluation is listed in a table. The work units of the activity and the assigned qualifications are displayed in the calendar to the right of the activity.

4. Right-click on the activity you want to assign to a person.

5. Select the "Edit assignment..." command from the context menu.
   The "Edit qualifications/persons" window opens.

6. Make the required filter settings.
7. Select one of the following options:
   - Right-click on the activity. Select the "Additional resources" command from the context menu, along with the required person. The activity is assigned to the person and displayed in the calendar as a colored bar.
     
     Which persons are displayed and which persons you can select depends on the filter settings. After the name of the person, you can see in brackets whether the person is qualified for this activity and whether they are available during the corresponding period.
     
   - Click on the first column in the table and drag&drop the activity to the required person. The activity is assigned to the person and displayed in the calendar as a colored bar.
     
     If the person is not qualified to perform the activity, the "Qualification check" window opens. Select the required option.

8. Close the "Edit qualifications/persons" window.

9. Save the settings you made.

Result

The activity is assigned to the person.

If an activity has 0 hours as the working unit, the relevant bar in the calendar is normally displayed over two days to make it clearer to see. Right-click on the activity and select the "Refresh" command. The view is refreshed and the bar is displayed as a line.

6.1.9 Editing an assigned activity

Requirement

The "Start date (move) locked" option on the "Resource planning" tab of the activity must be deactivated. See also chapter "Resource planning" tab (Page 121).

Procedure

1. Open the "Resource management" plugin.

2. Select the "Work packages" filter.

3. Drag&drop the object underneath which the activity you want to edit is located to the "Start object" field.

   The evaluation starts automatically. The result of the evaluation is listed in a table. The work units of the activity and the assigned qualifications are displayed in the calendar to the right of the activity.
6.1 Resource management

4. Select one of the following options:
   - If you want to shorten or lengthen the duration of the activity, click on the bar in the calendar. The color of the bar changes because the bar can now be edited. You can change the length of the bar, in other words, the start and end date of the activity, at the two ends of the bar. If you want to move the entire bar, click in the middle of the bar and move it to the required position. The length of the activity is retained. The start date changes on the "Resource planning" tab.
   - If you want to change the duration of the activity or the units per time, click on the bar in the calendar. A window opens. Make the required changes.

5. Save the settings you made.
   The scheduled maintenance date is recalculated.

6.1.10 Editing the assignment of an activity to a person

Procedure

1. Open the "Resource management" plugin.
2. Select the "Work packages" filter.
3. Drag&drop the object below which the activities whose assignment you want to edit are located to the "Start object" field.
   The evaluation starts automatically. The result of the evaluation is listed in a table. The work units of the activity and the assigned qualifications are displayed in the calendar to the right of the activity.
4. Right-click on the activity whose assignment you want to edit.
5. Select the "Edit assignment..." command from the context menu.
   The "Edit qualifications / persons" application area opens.
6. Make the required filter settings.
7. Right-click on the bar of the activity in the calendar.
8. Select one of the following options:
   - Select the "Edit" command from the context menu if you want to add a comment to the activity. The "Edit activity" window opens. Enter the required comment in the text field. Click "OK" to save the comment.
   - Select the "Delete" command from the context menu if you want to delete the assignment of the activity. The assignment of the activity to the person is deleted and the activity is displayed in the list again. You can now assign the activity to a different person.
   If several persons have been assigned to a qualification, you can spread the workload by double-clicking on the bar in the calendar.
10. Save your settings.
6.1.11 Centering the view of an activity in the calendar

Procedure
1. Right-click on the activity whose view you want to center.
2. Select the "Center" command from the context menu.

Result
The activity bar is displayed in the center of the calendar.

6.1.12 Displaying an overview of a person's absences and activities

Procedure
1. Open the "Resource management" plugin.
2. Select the "Assignment" filter.
3. Drag&drop the object underneath which the relevant person was created to the "Start object" field.

Result
The evaluation starts automatically. The found persons are listed in a table. The absences and the activities assigned to the person are displayed in the calendar to the right of the results table.

6.1.13 Creating dependencies between activities

To document that an activity is a predecessor or a successor activity of another activity, you can create dependencies between the activities in the "Resource management" plugin.

Requirement
The "Dependencies locked" option on the "Resource planning" tab of the activities must not be activated.

Procedure
1. Open the "Resource management" plugin.
2. Select the "Work packages" filter.
3. Drag&drop the object underneath which the activities for which you want to create a dependency are located to the "Start object" field.

   The evaluation starts automatically. The result of the evaluation is listed in a table. The activities are displayed as a colored bar in the calendar to the right of the results list.

4. Click on the bar of the activity which you want to document as a predecessor activity and hold down the mouse button.

   The mouse pointer changes its appearance from an arrow to a cross with arrows.

5. Move the mouse pointer over the bar of the activity you want to document as a successor activity.

6. Release the mouse button.

   A dependency is created between the two activities and is represented by an arrow. The tip of the arrow points to the successor activity.

7. Save your settings.

**MS Project**

These dependencies are evaluated during export to an MS Project. Activities are ordered according to their dependencies.

You can also export the progress of the activities.

### 6.1.14 Editing dependencies between activities

**Requirement**

The "Resource management" plugin is open. You have already created dependencies.

The "Dependencies locked" option on the "Resource planning" tab of the activities must not be activated.

**Procedure**

1. Select the "Work packages" filter in the menu bar of the plugin.

2. Drag&drop the object below which the activities whose dependency you want to edit are located to the "Start object" field.

   The evaluation starts automatically. The result of the evaluation is listed in a table. The activities are displayed as a colored bar in the calendar to the right of the results list. The dependency between activities is displayed as an arrow. The tip of the arrow points to the successor activity.

3. Right-click on the arrow which connects the two activities whose dependency you want to edit.

   The arrow is highlighted in color.
4. Select the "Edit dependency..." command from the context menu. The "COMOS - Resource manager - <Name of activity>" window opens.

5. In the "Type:" list, select the type of dependency.

6. In the "Displacement" field, enter how many hours need to be left between the two activities.

7. Click "OK" to save your changes and close the "COMOS - Resource manager - <Name of activity>" window.

8. Save your changes in the "Resource management" plugin.

Result

The dependency between the activities is changed in accordance with your settings.

6.1.15 Deleting a dependency between activities

Requirement

The "Resource management" plugin is open. You have already created dependencies.

Procedure

1. Select the "Work packages" filter.
2. Drag&drop the object underneath which the activities whose dependency you want to delete are located to the "Start object" field.

   The evaluation starts automatically. The result of the evaluation is listed in a table. The activities are displayed as a colored bar in the calendar to the right of the results list. The dependency between activities is displayed as an arrow. The tip of the arrow points to the successor activity.

3. Right-click on the bar of the activity whose dependency you want to delete.
4. Select the "Delete relation" command from the context menu.

   The dependency between the activities is deleted.
5. Save your settings.

6.1.16 Tours in the "Resource management" plugin

Tour work package as start object

If you set a tour's work package as a start object, activities of the type "Placeholder (tour)" are not listed on the plugin's display; the activities of the linked work packages and of the tour work package are displayed instead.
Work package as start object

If you set a work package with planned activities, which is linked to a tour work package, as a start object and the start/end date changes, the assigned tour and its placeholder activities are recalculated.

Nested tour

If you nest tours in such a way that tour work packages are located below one another at different levels in the Navigator and you set a superior tour work package as a start object, only activities of the type "Placeholder" are displayed in the plugin. You cannot edit these activities.

If the result collection also contains work packages which you then edit, the placeholder activities are updated after the save operation has been performed. Refresh the view in the plugin in order to display the updated activities.

6.2 Shift management

6.2.1 Settings in the properties of the shift planning object

You make settings that affect the "Shift management" plugin in the properties of the shift planning object. The base object of the shift planning object is located in "@CBO Maintenance > @RM Resource management objects> S Shift planning > M Shift planning".

6.2.2 Creating an object structure for the "Shift management" plugin

Procedure

1. Create an object of the type "M Shift planning" underneath the company reference.
2. Create the following objects underneath the shift planning object:
   - "A work description"
   - "GP planning folder"
   - "SH shift folder"
   - "ST shift template folder"
3. Create elements of the type "shift template" for every shift underneath the shift template folder.
6.2.3 "Shift management" plugin

With the "Shift management" plugin, you can plan and organize production shifts. The "Shift management" plugin is divided into three operating modes. You choose between the individual views using the menu bar:

- "Basic planning" view
  In basic planning, a basic plan is created for shift work. The display is organized according to months, calendar weeks and days. No persons are assigned to shifts, but rather entire shift groups.

- "Detail planning" view
  The actual planning takes place in the detail planning. The deviations from the basic planning are covered here.

- "Historical data" view
  In the historical data, you can access PDF reports created at the end of the shift.

6.2.4 Opening the "Shift management" plugin

Procedure

1. Click on "Plugins" in the menu bar.
2. Select the "Maintenance > Resources > Shift management" command.

Result

The "Shift management" plugin opens.

6.2.5 Assigning a shift group to a date

Shifts can only be planned for the current date or for the future.

Procedure

1. Open the "Shift management" plugin.
2. Drag&drop the required shift planning object to the "Start object" list.
3. Select the "Basic planning" view in the menu bar of the plugin.
   The shift groups that have been assigned to the shift planning object are listed in a table. A calendar with the created shifts, for example, early shift and night shift, is displayed underneath the table.
4. In the calendar, select the current date or a day in the future for which you want to plan the shift.
5. Right-click in the field of the corresponding date and the required shift.

6. Select the "Assignment" command from the context menu and select the required shift group.

Result

The shift group is assigned to the date and the required shift and is entered in the calendar.
In the same way, you can also change the assignment of a shift group to a date.

6.2.6 Adopting the shift group assignment of a period

Procedure

1. Open the "Shift management" plugin.

2. Drag&drop the required shift planning object to the "Start object" list.

3. Select the "Basic planning" view in the menu bar of the plugin.

   The shift groups that have been assigned to the shift planning object are listed in a table.
   A calendar with the created shifts, for example, early shift and night shift, is displayed underneath the table.

4. Right-click in the left column on the field of the shift whose shift group assignment you want to adopt.

5. Select the "Wizard..." command from the context menu.

   The "Wizard" window opens.

6. Select one of the following options:

   - Enter the date as of which you want to adopt the shift group assignment in the left-hand field of the "Reference" section. The format of the date must be YYYY.MM.DD.

   - Click the "..." button beside the left-hand field of the "Reference" section. The "Select date" application area opens. Click on the date as of when you want to adopt the shift group assignment. Click "OK".

     The date is entered in the left-hand field of the "Reference" section.

7. Select one of the following options:

   - Enter the date up to which you want to adopt the shift group assignment in the right-hand field of the "Reference" section. The format of the date must be YYYY.MM.DD.

   - Click the "..." button beside the right-hand field of the "Reference" section. The "Select date" application area opens. Click on the date up to when you want to adopt the shift group assignment. Click "OK".

     The date is entered in the right-hand field of the "Reference" section.
8. Select one of the following options:
   - Enter the start date of the period for which you want to adopt the shift group assignment in the left-hand field of the "Target" section. The format of the date must be YYYY.MM.DD.
   - Click the "...." button beside the left-hand field of the "Target" section. The "Select date" application area opens. Click on the date you want as the start date of the period for which you want to adopt the shift group assignment. Click "OK". The date is entered in the left-hand field of the "Target" section.

9. Select one of the following options:
   - Enter the end date of the period for which you want to adopt the shift group assignment in the right-hand field of the "Target" section. The format of the date must be YYYY.MM.DD.
   - Click the "...." button beside the right-hand field of the "Target" section. The "Select date" application area opens. Click on the date you want as the end date of the period for which you want to adopt the shift group assignment. Click "OK". The date is entered in the right-hand field of the "Target" section.

10. Click "OK".

Result

The shift group assignment is adopted for the selected period.

6.2.7 Deleting a shift group assignment

You can delete the shift group assignment for dates in the future. All assignments from the past and the current day remain.

1. Open the "Shift management" plugin.

2. Drag&drop the required shift planning object to the "Start object" list.

3. Select the "Basic planning" view in the menu bar of the plugin.

   The shift groups that have been assigned to the shift planning object are listed in a table. A calendar with the plannable shifts, for example early and night shift, is displayed underneath the table.

4. Right-click in the left column on the field of the shift whose shift group assignment you want to delete.

5. Select "Delete row" from the context menu.

   The "Confirm delete" window opens.

6. If you want to delete shift group assignment, click the "Yes" button.

Result

The assignment of the shift groups is deleted for future dates.
6.2.8 Defining roles and qualifications for a shift

This function is available only for shifts that have already started.

**Procedure**

1. Open the "Shift management" plugin.
2. Drag&drop the required shift planning object to the "Start object" list.
3. Select the "Basic planning" view in the menu bar of the plugin.
   The shift groups that have been assigned to the shift planning object are listed in a table. A calendar with the created shifts, for example, early shift and night shift, is displayed underneath the table.
4. In the calendar, select the current date or a day in the future for which you want to plan the shift.
5. Right-click in the field of the corresponding date and the required shift.
6. Select the "Show shift" command from the context menu.
   The "Report/COMOS object" window opens.
7. Select the "Specification profile" tab.
8. Click the "Edit" button in the "Specification of demanded roles" section.
   The "Profile definition" window opens.
9. Click the "Add definition" button.
   A new row is created.
10. Enter the required information.
11. Save the information you entered.
   You return to the "Report/COMOS object" window.
12. Repeat steps 8 to 10 for every role or qualification you want to define.
13. In the "Minimum number" field, enter the minimum number of persons that need to be present in this shift.
14. Save the information you entered.

6.2.9 Displaying information about the shift

This function is available only for shifts that have already started.

This function is also available in the "Detail planning" view.

**Procedure**

1. Open the "Shift management" plugin.
2. Drag&drop the required shift planning object to the "Start object" list.
3. Select the "Basic planning" view in the menu bar of the plugin.

   The shift groups that have been assigned to the shift planning object are listed in a table. A calendar with the created shifts, for example, early shift and night shift, is displayed underneath the table.

4. Right-click in the field of the corresponding date and shift whose information you want to display.

5. Select the "Show shift" command from the context menu.

   The "Report/COMOS object" window opens.

6. Select the "Shift" tab.

### 6.2.10 Creating a shift report

**Procedure**

1. Open the "Shift management" plugin.

2. Drag&drop the required shift planning object to the "Start object" list.

3. Select the "Basic planning" view in the menu bar of the plugin.

   The shift groups that have been assigned to the shift planning object are listed in a table. A calendar with the created shifts, for example, early shift and night shift, is displayed underneath the table.

4. Right-click in the field of the corresponding date and shift whose information you want to display.

5. Select the "Reports > Shift report" command from the context menu.

**Result**

The "Shift report" window opens.

The shift report is created underneath the shift object on the "Units" tab in the Navigator.

### 6.2.11 Starting a shift

**Requirement**

You can only start shifts whose date is in the past or present. Future shifts cannot normally be started. If you also want to start future shifts, contact the responsible administrator.

**Procedure**

1. Open the "Shift management" plugin.

2. Drag&drop the required shift planning object to the "Start object" list.
3. Select the "Detail planning" view in the menu bar of the plugin.

A table opens. The description of each row is displayed in the left column with a light blue background. The first three rows with a light blue background display the calendar. The fourth row with a light blue background displays the shifts for which basic planning exists.

The abbreviation of the individual shifts is displayed in italics as long as the shift has not yet been started. Finished shifts are displayed with a green background. The shift that has currently started has a yellow background.

4. Right-click in the "Shift" row on the shift you want to start.

5. Select the "Start shift" command from the context menu.

Result

The shift is started. The abbreviation of the shift is no longer in italics and has a yellow background. The entire column of the shift is displayed in yellow.

6.2.12 Changing a shift automatically

You can finish a shift and start the next shift automatically by using the automatic shift changeover function.

Requirement

If you want to use the automatic shift changeover function, activate the "Disable manual start/stop" option on the "Workflow" tab in the properties of the shift planning object.

You can only start shifts whose date is in the past or present. Future shifts cannot normally be started. If you also want to start future shifts, contact the responsible administrator.

Procedure

1. Open the "Shift management" plugin.
2. Drag&drop the required shift planning object to the "Start object" list.
3. Select the "Detail planning" view in the menu bar of the plugin.

A table opens. The description of each row is displayed in the left column with a light blue background. The first three rows with a light blue background display the calendar. The fourth row with a light blue background displays the shifts for which basic planning exists.

The abbreviation of the individual shifts is displayed in italics as long as the shift has not yet been started. Finished shifts are displayed with a green background. The shift that has currently started has a yellow background.

4. Click the "Shift change" button in the menu bar of the plugin.

5. If you want to perform an automatic shift changeover, click the "Yes" button.
Result

The currently started shift is finished and the next shift is opened.

6.2.13 Assigning a person to a shift

Requirement

You can only assign a person to a shift that has not yet finished.

Procedure

1. Open the "Shift management" plugin.
2. Drag&drop the required shift planning object to the "Start object" list.
3. Select the "Detail planning" view in the menu bar of the plugin.
   
   A table opens. The description of each row is displayed in the left column with a light blue background. The first three rows with a light blue background display the calendar. The fourth row with a light blue background displays the shifts for which basic planning exists.
   
   The abbreviation of the individual shifts is displayed in italics as long as the shift has not yet been started. Finished shifts are displayed with a green background. The shift that has currently started has a yellow background. As of subversion 1, the entire column of the current shift is displayed with a yellow background.

4. Click the "Show resources" button in the menu bar of the plugin.
   
   The resources are displayed in the left column with a light blue background.
   
   The row of absent persons is displayed in red.
5. Select the required resource row and the relevant shift column.
6. Right-click on the cell that forms the intersection set of the row and column.
7. Select the "Add person" command from the context menu.

Result

The person is assigned to the shift. The corresponding row is displayed in blue.

"Show status" filter

If you activate the "Show status" filter, start and end times of the shift will be displayed in the first rows of the table. The "Resources" row also displays how many persons were assigned to this shift. If the entry in the "Resource" row is displayed in red, the minimum number of persons for this shift has not yet been reached.
6.2.14 Deleting the assignment of a person to a shift

Requirement
You can edit shifts that have not yet finished.

Procedure
1. Open the "Shift management" plugin.
2. Drag&drop the required shift planning object to the "Start object" list.
3. Select the "Detail planning" view in the menu bar of the plugin.
   A table opens. The description of each row is displayed in the left column with a light blue background. The first three rows with a light blue background display the calendar. The fourth row with a light blue background displays the shifts for which basic planning exists. The abbreviation of the individual shifts is displayed in italics as long as the shift has not yet been started. Finished shifts are displayed with a green background. The shift that has currently started has a yellow background. As of subversion 1, the entire column of the current shift is displayed with a yellow background.
4. Click "Show resources" in the menu bar of the plugin.
   The resources are displayed in the left column with a light blue background.
   The row of absent persons is displayed in red.
5. Select the required resource row and the relevant shift column.
6. Right-click on the cell that forms the intersection set of the row and column.
7. Select the "Delete person" command from the context menu.

Result
A window opens. You can create an absence for the selected person. The assignment of the person to the shift is deleted. The corresponding row is no longer displayed in blue.
You can switch off the window display by activating the "Disable warning on person delete" option in the properties of the shift planning object.

6.2.15 Editing a person's details

Requirement
You can only edit the details of a person for one day. The person must be assigned to a shift for this day.
**Procedure**

1. Open the "Shift management" plugin.
2. Drag&drop the required shift planning object to the "Start object" list.
3. Select the "Detail planning" view in the menu bar of the plugin.
   
   A table opens. The description of each row is displayed in the left column with a light blue background. The first three rows with a light blue background display the calendar. The fourth row with a light blue background displays the shifts for which basic planning exists.

   The abbreviation of the individual shifts is displayed in italics as long as the shift has not yet been started. Finished shifts are displayed with a green background. The shift that has currently started has a yellow background.

4. Click the "Show resources" button in the menu bar of the plugin.
   
   The resources are displayed in the left column with a light blue background.

   The row of absent persons is displayed in red.

5. Select the required resource row and the relevant shift column.

6. Right-click on the cell that forms the intersection set of the row and column.

7. Click the "Details..." button.
   
   The "Details on person" window opens.

8. Enter the required information.
   
   Here, you can, for example, enter the actual times the person was present or assign a specific role to the person for this shift.

9. Save your settings.

**Result**

The details are saved. If, for example, you changed the actual time the person was present, the corresponding row is displayed in turquoise. The abbreviation of the shift is no longer displayed in italics. The changes are displayed on the shift report.

**6.2.16 Statistical evaluation of the shift**

**Introduction**

You can display statistical evaluations relating to one or more shifts.

You will find the base object of the evaluation objects under the following node: "@CBO > @RM > STATS > SEV Evaluation objects". The evaluation objects are elements of the shift object.
New shift status

If you create a shift object using the "Shift management" plugin and the status of the shift changes, COMOS checks the configuration of the evaluation objects in the properties on the "Attributes > Configuration of trigger" tab. If the settings in the two attributes "Shift state trigger" and "Time criteria trigger" are correct, the evaluation object is created underneath the shift. See also chapter "Configuration of trigger" tab (Page 148).

Evaluation

COMOS evaluates all attributes on the "Attributes > Statistics and evaluations" tab of the evaluation object whose name starts with either "EVAL" or "LIMIT". This always involves comparing the "EVAL" attributes with the corresponding "LIMIT" attributes, row by row. The calculated status is then set automatically in every row of the "Status" list. See also chapter "Statistics and evaluation" tab (Page 148).

Once all rows have been calculated, the overall status of the shift is entered in the "Status" list on the "Configuration of trigger" tab.

Status display

The overall status of the evaluation, which is entered on the "Configuration of trigger" tab, is displayed in the Navigator. The name of the shift which has been evaluated is displayed in the Navigator in the corresponding color.

6.3 "Resource monitor" plugin

The Resource monitor compares required and available resources.
"Warehouse management" plugin

7.1 "Warehouse management" plugin

7.1.1 "Warehouse management" plugin

The "Warehouse management" plugin is used to put equipment in stock or release it from stock, to manage the stocks of bulk material, and to assign equipment to functional locations.

7.1.2 "Warehouse management" plugin

Procedure

1. Click on "Plugins" in the menu bar.
2. Select the "Maintenance > Resources > Warehouse management" command.

Result

The "Warehouse management" plugin opens.

7.1.3 Putting equipment to stock

Procedure

1. Open the "Warehouse management" plugin.
2. Drag&drop the storage place object to the "Storage location" field underneath which you want to put the equipment to stock.
   The company object underneath which the storage place was created is entered in the "Start object" field. A table opens on the "To stock" tab of the plugin.
3. Select the "To stock" tab.
4. Drag&drop the required equipment to the table.
5. Click the "Apply" button.
Result

The equipment is moved underneath the selected storage place. On the subordinate level "Functional location" tab of the equipment, the stock movement is documented in the History table.

7.1.4 Releasing equipment from stock

Procedure

1. Open the "Warehouse management" plugin.
2. Drag&drop the storage place object to the "Storage location" field underneath which the relevant equipment is stored.
3. Select the "Release" tab.
4. Drag&drop the functional location to the "Destination" column underneath which the equipment is to be moved.
   If you have assigned a specific functional location to the equipment, you can switch any check of the currently selected location on and off using the "Check functional locations" button.
5. Save your settings.

Result

The equipment is moved out of stock to the selected functional location. On the subordinate level "Functional location" tab of the equipment, the stock movement is documented in the History table.

7.1.5 Assigning equipment to a functional location

Requirement

If a functional location has been assigned to a piece of equipment, you can then search for suitable equipment for the functional location using the context menu on the "Units" tab in the Navigator.

Procedure

1. Open the "Warehouse management" plugin.
2. Drag&drop the storage place object to the "Storage location" field underneath which the relevant equipment is stored.
3. Select one of the two tabs of the plugin.
4. Drag&drop the equipment to which you want to assign a functional location to the "Equipment" column of the plugin table.

5. Right-click on the required equipment in the "Equipment" column.

6. Select the "Functional location > Edit assignments" command from the context menu. The "Allowed functional locations" window opens.

7. Drag&drop the required functional locations to the table. You can delete the assignment again by using the context menu.


Result

The selected functional locations are assigned to the equipment.

7.1.6 Finding suitable equipment for a functional location

Procedure

1. In the Navigator, right-click on the functional location for which you want to find suitable equipment.

2. Select the "Find suitable equipment..." command from the context menu. The "Suitable equipment for..." window opens.

3. Drag&drop the required stock or a unit part to the "Start object" field.

Result

If the equipment is suitable for the functional location, the functional location is listed in the table of the "Suitable equipment for..." window.

Moving equipment

To move equipment underneath the functional location, right-click on the table entry in the "Suitable equipment for..." window. Select the "Mount equipment" command. The equipment is moved to underneath the selected functional location.
7.1.7 Editing bulk material using the "Warehouse management" plugin

Procedure

1. Open the "Warehouse management" plugin.
2. Drag&drop the bulk material storage place object to the "Storage location" field underneath which the required bulk goods object is located.
   The "Bulk goods" tab opens. All bulk goods objects created underneath the storage place/location are listed.
3. Right-click on the bulk goods object object you want to edit.
4. Select one of the following options:
   - Select "Bulk goods > Edit stock" to change the number of articles in stock.
   - Select "Bulk goods > Edit material master" to open the properties of the object.

7.2 "Goods receipt" plugin

You use the "Goods receipt" plugin to assign goods receipts, equipment, or work packages.

7.2.1 Opening the "Goods receipt" plugin

Procedure

1. Click on "Plugins" in the menu bar.
2. Select the "Maintenance > Warehouse management > Goods receipt" command.

Result

The "Goods receipt" tab opens.

7.2.2 Creating a goods receipt folder

Procedure

1. Right-click on the stock / storage object underneath which you want to create the goods receipt folder.
2. Select the "New > WE Goods receipt folder" command from the context menu.
7.2.3 Creating a goods receipt object

Procedure

1. Right-click on the goods receipt folder underneath which you want to create a goods receipt object.
2. Select the "New > WIN Goods receipt" command from the context menu.
   The "Goods receipt" window opens.
3. Select the "Base data" tab.
4. Enter the required information.
5. Click "Add lines" in the menu bar of the window.
   The "Add lines" window opens.
6. Enter the required information.
7. Click "OK" to apply the information you entered and close the "Add lines" window.
   The lines are added to the table in the "Goods receipt" window.
   - Drag&drop the equipment that you want to assign to the goods receipt object to the "Equipment" cell.
   - Drag&drop the work package that you want to assign to the goods receipt object to the "Work package" cell.
8. Save the information you entered.

7.2.4 Editing goods receipt

Procedure

1. Open the "Goods receipt" plugin.
2. Drag&drop the required goods receipt object to the "Receipt" field.
   The assigned equipment is listed.
3. Make the required changes.
4. Save your changes.
7.2.5 Assigning a goods receipt object to a goods issue object

Procedure

1. Open the "Goods receipt" plugin.
2. Drag&drop the goods receipt object whose equipment or work package you want to assign to the goods issue object to the "Receipt" field.
   The data of the goods receipt object is loaded automatically and listed in the table.
3. Drag&drop the goods issue object to the "GI-no." column of the equipment or work package to which you want to assign the goods issue object.
4. Save your settings.

Result

The goods issue object has been assigned to the selected pieces of equipment or work packages.
To check the assignment, open the "Goods issue" plugin and drag&drop the relevant goods issue object to the "Receipt" field. The assigned objects are listed.

7.3 "Goods issue" plugin

The "Goods issue" plugin is used to display the pieces of equipment or work packages that have been assigned to a goods issue object.

7.3.1 Opening the "Goods issue" plugin

Procedure

1. Click on "Plugins" in the menu bar.
2. Select "Maintenance > Warehouse Management > Goods Receipt - Out".

Result

The "Goods issue" tab opens.
7.3.2 Creating a goods issue folder

**Procedure**

1. Select the "Units" tab in the Navigator.
2. Right-click on the stock / storage object underneath which you want to create the goods issue folder.

**Result**

The goods issue folder is created underneath the selected stock / storage object.

7.3.3 Creating a goods issue object

**Procedure**

1. Select the "Units" tab in the Navigator.
2. Right-click on the goods issue folder underneath which you want to create a goods issue object.
   A menu opens.
3. Select "New > WOUT Goods issue".
   The "Goods issue" application area opens.
4. Select the "Base data" tab.
5. Enter the required information.
   The table is used only to display the objects that have been assigned to a goods issue object using the "Goods receipt" plugin.
6. Save the information you entered.
Object search

8.1 "Object search" plugin
The "Object search" plugin is used to search for objects throughout the entire data structure.

8.2 Opening the "Object search" plugin

Procedure
1. Click on "Plugins" in the menu bar.
2. Select the "Maintenance > Object search" command.

Result
The "Object search" plugin opens.

8.3 Searching for an object via the "Object search" plugin

Procedure
1. Open the "Object search" plugin.
2. Drag&drop the required start object for the search to the "Start object(s)" field.
   If you want to use more than object as the start object, click the "Root nodes" button.
3. Select one of the following options:
   – If you are searching based on object classification, activate the "Use COMOS classification" button.
     When the corresponding parameter is activated in the user-specific project options, search based on object classification is displayed by default.
     You can find additional information on this topic in the "Maintenance Administration" manual, keyword "StandardSearchClassification".
   – If you are searching based on labels, activate the "Search by label" button.
4. Make the required filter settings.
5. If you want to search for attributes, drag&drop the relevant attributes to the "Attributes" section.
8.4 Exporting the search result from the "Object search" plugin

6. If applicable, make the required filter settings in the "Attributes" section.
7. Click the "Start search" button.

Result

The result of the search is listed in a table below the "Attributes" section.

Context menu

If you select the search result, you can navigate via the context menu (right mouse button), display the properties of the object or delete the entry from the results list.

Saving a search

You can save the search as a user-defined profile.

8.4 Exporting the search result from the "Object search" plugin

When you click the "Export result" button, the "Export" window opens. This is where you select whether the data is to be exported to an empty Excel file or an Excel template. You also have the option of exporting the data to an XML file.

Excel template

When exporting to an Excel template, you select an appropriate Excel template of type XLT or XLTX before starting the export.

The sample template contains cells with the titles of the columns to be exported in square brackets, for example, [Description:]. You can place these cells anywhere in the document. The data is inserted at these locations or in the cells underneath them when you export the data. They should not therefore be directly underneath each other, otherwise the columns could overwrite each other depending on their length.

If you export to a document template, the column titles themselves are not exported. They can be placed in the template as required. After export, you can save the file as an Excel file. The document template remains unchanged.

If you export the data to an empty Excel sheet, a new Excel file is opened in which the entire table (including the column headers and row numbers) is inserted.
9.1 Concept

Overview

To be able to seamlessly connect all requirements from the maintenance area with all the engineering concepts currently available in COMOS, a parallel structure, which is decoupled from the engineering unit structure, is built up. This is known as the lifecycle structure. It is an additional way of viewing the COMOS objects.

Basic idea

All objects from the engineering area are regarded as requirement objects. This also applies to manufacturer devices. Manufacturer devices are lifecycle objects and represent real manufacturer devices in the unit. They contain all information which is relevant to the lifecycle, such as serial numbers, testing certificates, maintenance histories, Ex certificates, or equipment numbers.

All requirement objects from the engineering area point to the lifecycle object or LC object via a new lifecycle link object. The lifecycle link object in the unit structure can be viewed as a requirement object. The LC object in the parallel structure meets these defined requirements, making it the implementation for the requirement object.

Functional scope

- Decoupling the engineering requirements from live maintenance data
- Maintenance data is not copied along with engineering structures
- Maintenance data is retained when units parts are deleted
- Equipment movements do not affect engineering structures
- Separation of data according to specialist disciplines
- Slimline structures

Base objects

The following base objects are available by default:

- "@CBO >@RL > LCS > LCL > EV Lifecycle link"
- "@CBO > @RL > LCS > LCL > WPL Work package - Lifecycle link"

You also have the option of creating your own lifecycle link base objects, using the existing base objects as an example.
9.2 Evaluation of lifecycle link objects

Deleting

Deleting the lifecycle object also deletes the associated lifecycle link object.

Copying

Lifecycle link objects cannot be copied. If you copy the owner of an LC link object, the LC link object is not copied along with it. If you copy the LC object, you must create the reference subsequently.

9.2 Evaluation of lifecycle link objects

Display in the Navigator

Only the relevant data of the lifecycle object is displayed in the unit structure.
The display ends at the lifecycle link object. The objects located underneath the lifecycle object are not displayed in the Navigator underneath the lifecycle link object.

Search

The lifecycle link object inherits the following data from the lifecycle object and checks it in so that a search result is available quickly:

- Label
- Description
- Classification

If a lifecycle link object has been found via the search manager, this manager supplies the linked lifecycle object by following the implementation pointer.

Changes to the label, description, and classification of the lifecycle object result in changes to all associated lifecycle link objects.

Plugins

If you are working with lifecycle link objects within a plugin, the plugin supplies the linked lifecycle object by following the implementation pointer.

9.3 Using the lifecycle structure

Requirement

The "Use Lifecycle structure" option has been activated on the "Options > Maintenance" tab in the project properties. The full name of the base object has been entered in the "Lifecycle base object fullname" field. Use a tilde for this, not the pipe character.
You can also define a separate lifecycle link base object on the "Lifecycle" tab for each object to be moved to the lifecycle structure.

**Procedure**

1. Hook the "Lifecycle" tab to the base object of the object which you want to move to the lifecycle structure.
2. Use the "GetDisplayValue" function of the "Lifecycle path" attribute to define the system full name of the object in the parallel structure underneath which the lifecycle object is being moved.
   
   Use the "GetDisplayValue" script to enable you to create the structure dynamically and thus to adapt it to your individual search criteria.
   
   If the parallel structure does not exist yet, it is created automatically before an object is moved to the structure.

**Example for events**

If you want to sort events according to the year, month, and status, use the "GetDisplayValue" function of the "Lifecycle path" attribute to define the required variables and link them to a valid system full name:

\[
\text{GetDisplayValue} = \text{year} \& | \text{month} \& | \text{status}
\]

If the status changes, the display value of the "Lifecycle path" attribute changes too.

**Relocating**

To trigger a relocation to the parallel structure when creating an object, activate the "Use lifecycle structure" option on the "Lifecycle" tab at the base object of the lifecycle object.

To respond to changes to the attributes of an object and trigger a relocation within the parallel structure, insert the following script at the "OnChange" function of the attribute concerned, for example:

```vba
Set oc = createObject("chemserv.relocationclass")
Call oc.checkdeviceExt(GetSpecOwner,"","Relocation.LCLinkCDevice")
```

Calling this function causes the lifecycle object to be relocated to the position in the parallel structure defined in the "Lifecycle path" field.

**9.4 Changing the lifecycle link object of a lifecycle object**

**Requirement**

A lifecycle object has been created.

Exactly one lifecycle link object has been assigned to the lifecycle object.
9.5 Adding multiple lifecycle link objects to a lifecycle object

**Procedure**

1. Select the desired lifecycle object in the Navigator.
2. Select the "Maintenance > Edit lifecycle links > Change link owner" command from the context menu.
   
   If you use unit pointers instead of the lifecycle structure, select the "Maintenance > Edit unit pointer > Change unit pointer" command from the context menu.

   The "Select owner" window opens.

3. Drag&drop the object under which you want to store the new lifecycle link object from the Navigator to the "Select owner" field in the "Select owner" window.

4. Close the window with "OK".

**Result**

The previous lifecycle link object is deleted.

A new lifecycle link object is created below the selected object in the Navigator.

**Unit pointer**

If you use unit pointers instead of the lifecycle structure, the commands in the context menu change accordingly.

Since there is only one unit pointer, you do not have the option of adding or removing multiple links.

---

**9.5 Adding multiple lifecycle link objects to a lifecycle object**

**Requirement**

- A lifecycle object has been created.
- The script function "Relocation.MultiReferencing = 1".

**Procedure**

1. Select the desired lifecycle object in the Navigator.
2. Select the "Maintenance > Edit lifecycle links > Add link owner" command from the context menu.
   
   The "Select owner" window opens.

3. Drag&drop the object under which you want to store the new lifecycle link object from the Navigator to the "Select owner" field in the "Select owner" window.

4. Close the window with "OK".
9.6 Deleting the lifecycle link object of a lifecycle object

**Result**

A new lifecycle link object is created below the selected object.

**9.6 Deleting the lifecycle link object of a lifecycle object**

**Requirement**

- A lifecycle object has been created.
- At least one lifecycle link object has been assigned to the lifecycle object.

**Procedure**

1. Select the desired lifecycle object in the Navigator.
2. If a lifecycle link object is assigned to the lifecycle object, select the "Maintenance > Edit lifecycle link > Remove link" command in the context menu.
3. If several lifecycle link objects are assigned to the lifecycle object, select the "Maintenance > Edit lifecycle link > Remove all links" command in the context menu.

**Result**

All lifecycle link objects of the lifecycle object are deleted.

**Unit pointer**

If you use unit pointers instead of the lifecycle structure, select the "Maintenance > Edit unit pointer > Remove unit pointer" command from the context menu.
Lifecycle structure

9.6 Deleting the lifecycle link object of a lifecycle object
Locking objects

Requirement

The "Lock maintenance objects" option has been activated on the "Options > Maintenance" tab in the project properties. You have reopened the database after activating the option.

Effect

If you activate the "Lock maintenance objects" option in the project properties, various objects are grayed out in the Navigator under certain conditions and can no longer be edited.

Locking functions in the "Resource management" plugin

You can control which functions are locked in the "Resource management" plugin using the "Attributes > Resource planning" tab and the following options:

● "Start date (move) locked"  
● "Load (units/time) locked"  
● "Assignments (persons) locked"  
● "Dependencies locked"

If you activate an option, you can no longer use the corresponding function in the "Resource management" plugin.

"Finished" work package

Change the status of the work package to "Finished".  

● You are no longer able to edit the work package  
● You can add the work package to a shutdown for documentation purposes.  
● You cannot assign the work package to a new tour.  
● You cannot create any objects underneath the work package

Order locked

If you lock an order using the "Maintenance order" plugin or the "Attributes > Order data" tab, you cannot add any work packages or maintenance plans.

Order canceled

If you cancel an order using the "Maintenance order" plugin or the "Attributes > Order data" tab, you cannot add any work packages or maintenance plans. You can assign available work packages to a new order.
Locking objects

Order finished

If an order is finished, you cannot add or delete any work packages.

Tour completed or exported to mobile device

If a tour has been completed or exported to a mobile device, you can no longer add or remove any work packages. You can no longer edit activities of the tour, nor can you add or delete objects underneath the tour.

Maintenance plan archived

You can only archive a maintenance plan if no work package is active. If a maintenance plan is present in the strategy archive folder, you can no longer add or delete any objects. Existing links to tours or main and sub maintenances lose their function.

Shutdown completed

If you set the phase of a shutdown to "5 – Finished" in the "Shutdown management" plugin, you can no longer add or delete any objects.

You can continue to clone the shutdown.

Shift completed

Events which are assigned to a completed shift should not be deleted, as to do so could impair the traceability of the shift report. However, if you still want to delete an event, you are informed that a link exists.

Enable event lock

You can configure whether and in what status an event is to be locked.

Additional information

- You can find additional information on action codes in the "Maintenance Administration" manual, keyword "Action codes".
- You can find additional information on the "RemaTab" in the "Maintenance Administration" manual, keyword "RemaTab" tab.

See also

"Dis-/mounting info" tab (Page 120)
11.1 "Options > Maintenance" tab of the project

Overview

The "Options > Maintenance" tab in the project properties shows information on the default settings for working with Maintenance.

![Options tab screenshot](image)

- **Is maintenance project**: Checked
- **Is shutdown project**: Checked
- **Use EventManager**: Checked
- **Structure Mode**: Checked
- **Company DB**: USERS
- **Lock maintenance objects**: Unchecked
- **Do not reset planned date on workpackage**: Unchecked
- **Use Maintenance navigator text**: Unchecked
- **Use lifecycle structure**: Checked
- **Lifecycle CDVDJF Fullname**: 
- **Operating resource - Compare mode**: 
- **Operating resource - Compare attribute**: 
- **Use new qualification objects**: Unchecked
- **Qualification - Compare mode**: 
- **Qualification - Compare attribute**: 

The settings shown here define how the maintenance tasks are handled within the project.
"Options" control group

<table>
<thead>
<tr>
<th>User interface element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Settings&quot; button</td>
<td>You use this button to open the &quot;Options&quot; application area for the relevant project.</td>
</tr>
<tr>
<td>&quot;Is maintenance project&quot; option</td>
<td>The activated option identifies the project as a maintenance project. If this option is activated, you can use the multiple selection function in the Navigator and edit the selected objects simultaneously via the &quot;Maintenance&quot; command in the context menu.</td>
</tr>
<tr>
<td>&quot;Is shutdown project&quot; option</td>
<td>The activated option identifies the project as a shutdown project.</td>
</tr>
<tr>
<td>&quot;Use EventManager&quot; option</td>
<td>If this option is activated, the EventManager is used.</td>
</tr>
<tr>
<td>&quot;Structural mode&quot; option</td>
<td>If this option is activated, the structural mode is used.</td>
</tr>
<tr>
<td>&quot;Company DB&quot; field</td>
<td>This field displays the name of the company database to be used.</td>
</tr>
<tr>
<td>&quot;Use object hierarchy (old)&quot; option</td>
<td>If this option is activated, the object hierarchy is used.</td>
</tr>
<tr>
<td>&quot;Use new classification&quot; option</td>
<td>If this option is activated, the new classification is used.</td>
</tr>
</tbody>
</table>

"Expansions" control group

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Lock maintenance objects&quot; option</td>
<td>If this option is activated, objects which are locked for editing are grayed out in the Navigator.</td>
</tr>
<tr>
<td>&quot;Do not reset planned date&quot; option</td>
<td>If this option is activated, the planned execution date is retained in the system if a work package contains a feedback date.</td>
</tr>
<tr>
<td>&quot;Use maintenance navigator text&quot; option</td>
<td>If this option is activated, the default texts are used in the Navigator. In order to use the Navigator texts, the &quot;Function NavigatorText (object)&quot; script function must be activated at the base objects of the required objects.</td>
</tr>
<tr>
<td>&quot;Use Lifecycle structure&quot; option</td>
<td>If this option is activated, the lifecycle structure is used.</td>
</tr>
<tr>
<td>&quot;Lifecycle base object full name&quot; field</td>
<td>This field displays the full name of the lifecycle base object.</td>
</tr>
<tr>
<td>&quot;Device compare mode&quot; list</td>
<td>You select the desired compare mode from this list.</td>
</tr>
<tr>
<td>&quot;Device compare attribute&quot; field</td>
<td>If you selected the compare mode &quot;Display value of attribute&quot;, you need to enter the nested name of the attribute here.</td>
</tr>
</tbody>
</table>
### 11.2 "Personal data" tab

#### "Company data - person" control group

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Personnel no.:&quot; field</td>
<td>This field displays the personnel number.</td>
</tr>
<tr>
<td>&quot;Card ID&quot; field</td>
<td>This field displays the ID number with which the user logs in in the &quot;Direct&quot; plugin.</td>
</tr>
<tr>
<td>&quot;Email address&quot; field</td>
<td>This field displays the user's email address. It is used to send messages, for example, through the &quot;Maintenance demon&quot; plugin.</td>
</tr>
<tr>
<td>&quot;Login&quot; field</td>
<td>This field displays the user's login details, which are used to assign the COMOS user to the person object. This allows profiles to be saved underneath the relevant person object and the name to be displayed in the &quot;Resource monitor&quot; plugin.</td>
</tr>
<tr>
<td>&quot;Is system user&quot; option</td>
<td>If this option is activated, the user can work with COMOS.</td>
</tr>
<tr>
<td>&quot;Password&quot; field</td>
<td>This field displays the password requested when mobile devices are used.</td>
</tr>
<tr>
<td>&quot;Is portable user&quot; option</td>
<td>If this option is activated, this user can be used on portable devices.</td>
</tr>
<tr>
<td>&quot;SAP contact person&quot; field</td>
<td>This field displays the name of the SAP contact person.</td>
</tr>
<tr>
<td>&quot;Debtors No.: SAP&quot; field</td>
<td>This field displays the debtor number of SAP.</td>
</tr>
<tr>
<td>&quot;Office&quot; field</td>
<td>This field displays the office.</td>
</tr>
<tr>
<td>&quot;Position&quot; list</td>
<td>You select the position from this list.</td>
</tr>
<tr>
<td>&quot;Date of joining&quot; field</td>
<td>This field is evaluated in the &quot;Resource management&quot; plugin.</td>
</tr>
</tbody>
</table>

---

**See also**
- [Concept](Page 93)
- [Locking objects](Page 99)
### 11.3 Maintenance objects

#### 11.3.1 Company

**"General" tab**

The "General" tab shows the base object of the company object.

Only change the base object selection following consultation with the administrator.

**"System internals" tab**

The "System internals" tab displays system settings that are required for searching. You cannot make any changes on this tab in the planning project.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Object type&quot; list</td>
<td>You select the object type from this list.</td>
</tr>
<tr>
<td>&quot;Creator login&quot; field</td>
<td>This field shows the login of the person who created this object.</td>
</tr>
<tr>
<td>&quot;Creator name&quot; field</td>
<td>This field displays the name of the person who created the object.</td>
</tr>
<tr>
<td>&quot;at&quot; field</td>
<td>This field displays the date on which the object was created (format: YYYY.MM.DD).</td>
</tr>
<tr>
<td>&quot;at&quot; field</td>
<td>This field shows the time at which the object was created.</td>
</tr>
<tr>
<td>&quot;Origin before deleting&quot; field</td>
<td>This field displays where the object was created prior to being deleted.</td>
</tr>
<tr>
<td>&quot;Deleted by&quot; field</td>
<td>This field shows the name of the user who deleted the object.</td>
</tr>
<tr>
<td>&quot;at&quot; field</td>
<td>This field displays the date on which the object was deleted.</td>
</tr>
<tr>
<td>&quot;Name before deleting&quot; field</td>
<td>This field displays the name of the object before it was deleted.</td>
</tr>
<tr>
<td>&quot;Label before deleting&quot; field</td>
<td>This field displays the object label prior to it being deleted.</td>
</tr>
</tbody>
</table>
11.3.1.3 "Commercial data" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Company&quot; field</td>
<td>This field displays the name of the company.</td>
</tr>
<tr>
<td>&quot;Regular customer&quot; option</td>
<td>If this option is activated, the company is identified as a regular customer.</td>
</tr>
<tr>
<td>&quot;Legal form&quot; list</td>
<td>In this list, you select the legal form of the company.</td>
</tr>
<tr>
<td>&quot;Corporate center&quot; field</td>
<td>This field displays the corporate center of the company.</td>
</tr>
<tr>
<td>&quot;Branch office&quot; field</td>
<td>This field displays the branch office of the company.</td>
</tr>
<tr>
<td>&quot;Staff&quot; field</td>
<td>This field displays the names of the staff of the company.</td>
</tr>
<tr>
<td>&quot;Management&quot; field</td>
<td>This field shows remarks relating to the management.</td>
</tr>
<tr>
<td>&quot;Market activity&quot; field</td>
<td>This field shows remarks relating to the marketing activities of the company.</td>
</tr>
<tr>
<td>&quot;Customer news&quot; field</td>
<td>This field shows remarks regarding customer news.</td>
</tr>
<tr>
<td>&quot;Competitor&quot; field</td>
<td>This field displays remarks relating to competitors.</td>
</tr>
<tr>
<td>&quot;Profit in MIO&quot; field</td>
<td>This field displays the profit of the company in millions.</td>
</tr>
<tr>
<td>&quot;Turnover in MIO&quot; field</td>
<td>This field displays the turnover of the company in millions.</td>
</tr>
<tr>
<td>&quot;Cash Flow in MIO&quot; field</td>
<td>This field displays the cash flow of the company in millions.</td>
</tr>
<tr>
<td>&quot;Share capital&quot; field</td>
<td>This field displays the share capital of the company in millions.</td>
</tr>
<tr>
<td>&quot;EUR&quot; list</td>
<td>You select the currency from this list. Euro is set as default.</td>
</tr>
<tr>
<td>&quot;Year&quot; field</td>
<td>This field displays the year to which the information applies.</td>
</tr>
</tbody>
</table>

11.3.1.4 "Company data" tab

The "Company data" tab displays the company data. The selected data is then available in the COMOS_MA project.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Name&quot; field</td>
<td>This field displays the name of the company.</td>
</tr>
<tr>
<td>&quot;Street&quot; field</td>
<td>This field displays the name of the street.</td>
</tr>
<tr>
<td>&quot;ZIP&quot; field</td>
<td>This field displays the ZIP (postal) code.</td>
</tr>
<tr>
<td>&quot;Location&quot; field</td>
<td>This field displays the name of the location.</td>
</tr>
<tr>
<td>&quot;PO box&quot; field</td>
<td>This field displays the PO box.</td>
</tr>
<tr>
<td>&quot;Phone1&quot; field</td>
<td>This field displays the phone number of the company.</td>
</tr>
<tr>
<td>&quot;Short description&quot; field</td>
<td>This field displays a brief description of the company.</td>
</tr>
<tr>
<td>&quot;Branch&quot; list</td>
<td>You select the branch to which the company belongs from this list.</td>
</tr>
<tr>
<td>&quot;Product&quot; field</td>
<td>This field displays a description of the companies product.</td>
</tr>
<tr>
<td>&quot;Homepage&quot; field</td>
<td>This field displays the address of the companies homepage.</td>
</tr>
<tr>
<td>&quot;Debtors No.: SAP&quot; field</td>
<td>This field displays the companies own debtor number when there is an SAP interface.</td>
</tr>
<tr>
<td>&quot;Company logo&quot; field</td>
<td>This field displays the path to the company logo. The logo selected here can then, for example, be displayed on reports.</td>
</tr>
</tbody>
</table>
11.3.1.5 "Portal" tab
The "Portal" tab displays the portal settings of the company. For more information, contact the responsible administrator.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Configuration&quot; column</td>
<td>This column displays the consecutive row numbers.</td>
</tr>
<tr>
<td>&quot;Parameter&quot; list</td>
<td>You select the required portal parameter from this list.</td>
</tr>
<tr>
<td>&quot;Value&quot; field</td>
<td>This field displays the value of the portal parameter. This might, for example, be a Boolean value or a system full name.</td>
</tr>
</tbody>
</table>

11.3.1.6 "iAge profile" tab
The "iAge profile" tab displays information on the iAge settings that apply to the entire company.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Type&quot; field</td>
<td>This field displays the profile type.</td>
</tr>
<tr>
<td>&quot;Default profile&quot; option</td>
<td>If this option is activated, it indicates that a corresponding setting has been made in the plugin. The option should not be activated here.</td>
</tr>
<tr>
<td>XML profiles</td>
<td>This field displays the iAge profile in XML format.</td>
</tr>
</tbody>
</table>

11.3.1.7 "Regular working time" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;General availability&quot; field</td>
<td>As default, this box displays 1. This means that they are working full time. The entry 0.5 would mean half availability.</td>
</tr>
<tr>
<td>&quot;Time&quot; column</td>
<td>This column displays the consecutive row numbers.</td>
</tr>
<tr>
<td>&quot;Day&quot; list</td>
<td>You select the desired weekday from this list.</td>
</tr>
<tr>
<td>&quot;Start&quot; column</td>
<td>This column displays the time at which work normally starts.</td>
</tr>
<tr>
<td>&quot;End&quot; column</td>
<td>This column displays the time at which work normally ends.</td>
</tr>
</tbody>
</table>

11.3.2 "Company" tab of the company reference
The "Company" tab displays information on the linked company in the company DB.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Company&quot; field</td>
<td>This field displays the name of the company.</td>
</tr>
<tr>
<td>&quot;Street&quot; field</td>
<td>This field displays the name of the street.</td>
</tr>
<tr>
<td>&quot;ZIP&quot; field</td>
<td>This field displays the ZIP (postal) code.</td>
</tr>
<tr>
<td>&quot;Location&quot; field</td>
<td>This field displays the name of the location.</td>
</tr>
</tbody>
</table>
### 11.3 Maintenance objects

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Phone&quot; field</td>
<td>This field displays the phone number of the company.</td>
</tr>
<tr>
<td>&quot;Navigate to object&quot; button</td>
<td>Via this button, you navigate to the company object in the company database.</td>
</tr>
<tr>
<td>&quot;Select company from company project&quot; button</td>
<td>Via this button, you create the link to the company object in the company database (for example: USERS or COMOS_MA_CSM). The data from the company database is adopted.</td>
</tr>
<tr>
<td>&quot;System UID&quot; field</td>
<td>This field displays the system UID of the company reference.</td>
</tr>
</tbody>
</table>

#### 11.3.3 "Building data" tab

The "Building data" tab displays the data of the unit.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Short description&quot; field</td>
<td>This field displays a brief description of the unit.</td>
</tr>
<tr>
<td>&quot;Detail description&quot; field</td>
<td>This field displays details regarding the unit description.</td>
</tr>
<tr>
<td>&quot;Category&quot; list</td>
<td>You select the building/unit category from this list.</td>
</tr>
<tr>
<td>&quot;Accompanying building&quot; field</td>
<td>This field displays which buildings belong to the unit.</td>
</tr>
<tr>
<td>&quot;Year of erection&quot; field</td>
<td>This field displays the year in which the unit was erected.</td>
</tr>
<tr>
<td>&quot;Used&quot; option</td>
<td>The activated option means that the unit is in use.</td>
</tr>
<tr>
<td>&quot;Remarks to usage&quot; field</td>
<td>This field displays remarks relating to the use of the building.</td>
</tr>
<tr>
<td>&quot;Remarks&quot; field</td>
<td>This field displays general remarks regarding the unit.</td>
</tr>
<tr>
<td>&quot;EX-Zone plan&quot; field</td>
<td>This field displays the ex-zone plan field.</td>
</tr>
<tr>
<td>&quot;EX-Temperature class&quot; field</td>
<td>This field displays the explosion risk temperature class.</td>
</tr>
<tr>
<td>&quot;EX-Group&quot; field</td>
<td>This field displays the explosion risk group.</td>
</tr>
<tr>
<td>&quot;EX-Zone&quot; field</td>
<td>This field displays the explosion risk (hazardous) zone.</td>
</tr>
<tr>
<td>&quot;EX-Protection&quot; field</td>
<td>This field displays the explosion risk protection.</td>
</tr>
<tr>
<td>&quot;EX-Class&quot; field</td>
<td>This field displays the explosion risk class.</td>
</tr>
<tr>
<td>&quot;Ignition group&quot; field</td>
<td>This field displays the explosion risk ignition group.</td>
</tr>
<tr>
<td>&quot;Cost center&quot; field</td>
<td>This field displays the cost center.</td>
</tr>
</tbody>
</table>
11.3.4 Equipment

11.3.4.1 "Equipment data" tab

The "Equipment data" tab at the subordinate level displays information relating to a manufacturer device.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;ID&quot; fields</td>
<td>The left-hand field displays the ID of the equipment. The right-hand field displays a consecutive number.</td>
</tr>
<tr>
<td>&quot;without leading zero&quot; list</td>
<td>In this list, you select how the ID should be displayed.</td>
</tr>
<tr>
<td>&quot;Assign new ID&quot; button</td>
<td>With this button, you can assign a new ID to the equipment.</td>
</tr>
<tr>
<td>&quot;Unique ID&quot; option</td>
<td>If this option is activated, the uniqueness of the assigned ID is checked.</td>
</tr>
<tr>
<td>&quot;Use quick ID&quot; option</td>
<td>If this option is activated, a quick ID is assigned.</td>
</tr>
<tr>
<td>&quot;Unique across all projects&quot; option</td>
<td>If this option is activated, the uniqueness of the ID is also checked across all projects.</td>
</tr>
<tr>
<td>&quot;Description&quot; field</td>
<td>This field displays a description of the equipment.</td>
</tr>
<tr>
<td>&quot;Client ID&quot; field</td>
<td>This field displays the client number.</td>
</tr>
<tr>
<td>&quot;Year of erection&quot; field</td>
<td>This field displays the year the equipment was errected.</td>
</tr>
<tr>
<td>&quot;Manufacturer No.&quot; field</td>
<td>This field displays the manufacturer number of the equipment.</td>
</tr>
<tr>
<td>&quot;Permit ID&quot; field</td>
<td>This field displays the permit ID number.</td>
</tr>
<tr>
<td>&quot;Inventory ID&quot; field</td>
<td>This field displays the inventory ID of the equipment.</td>
</tr>
<tr>
<td>&quot;Check device ID&quot; field</td>
<td>This field displays the check device ID.</td>
</tr>
<tr>
<td>&quot;Client info&quot; field</td>
<td>This field displays client information.</td>
</tr>
<tr>
<td>&quot;Status&quot; list</td>
<td>You select the status of the equipment from this list.</td>
</tr>
<tr>
<td>&quot;Sub EQ of&quot; field</td>
<td>This field displays a reference to the superordinate equipment.</td>
</tr>
<tr>
<td>&quot;Remarks&quot; field</td>
<td>This field displays a remark concerning the equipment.</td>
</tr>
<tr>
<td>&quot;Location&quot; field</td>
<td>This field displays locations.</td>
</tr>
</tbody>
</table>

11.3.4.2 "Functional location" tab

The "Functional location" tab displays information on the functional locations to which the equipment has been assigned.

<table>
<thead>
<tr>
<th>Date</th>
<th>Time</th>
<th>Name</th>
<th>Description</th>
<th>Label of</th>
<th>User</th>
<th>Action</th>
<th>Description of action</th>
</tr>
</thead>
<tbody>
<tr>
<td>11.10.2010</td>
<td>16:08</td>
<td>002</td>
<td>General apparatus 002</td>
<td>ADSOC01</td>
<td>MOUNT</td>
<td>Mounted</td>
<td></td>
</tr>
<tr>
<td>12.10.2010</td>
<td>15:58</td>
<td>002</td>
<td>General apparatus 002</td>
<td>ADSOC01</td>
<td>DISMOUNT</td>
<td>Dismounted</td>
<td></td>
</tr>
<tr>
<td>12.10.2010</td>
<td>15:59</td>
<td>001</td>
<td>Apparatus 1</td>
<td>ADSOC01</td>
<td>INSTORE</td>
<td>Storied</td>
<td></td>
</tr>
<tr>
<td>12.10.2010</td>
<td>15:59</td>
<td>001</td>
<td>General apparatus 001</td>
<td>ADSOC01</td>
<td>OUTSTORE</td>
<td>OutSourced</td>
<td></td>
</tr>
<tr>
<td>12.10.2010</td>
<td>15:59</td>
<td>001</td>
<td>General apparatus 001</td>
<td>ADSOC01</td>
<td>MOUNT</td>
<td>Mounted</td>
<td></td>
</tr>
<tr>
<td>12.10.2010</td>
<td>15:59</td>
<td>001</td>
<td>General apparatus 001</td>
<td>ADSOC01</td>
<td>DISMOUNT</td>
<td>Dismounted</td>
<td></td>
</tr>
<tr>
<td>12.10.2010</td>
<td>15:59</td>
<td>001</td>
<td>Apparatus 1</td>
<td>ADSOC01</td>
<td>INSTORE</td>
<td>Storied</td>
<td></td>
</tr>
<tr>
<td>12.10.2010</td>
<td>16:00</td>
<td>002</td>
<td>Apparatus 1</td>
<td>ADSOC01</td>
<td>OUTSTORE</td>
<td>OutSourced</td>
<td></td>
</tr>
<tr>
<td>12.10.2010</td>
<td>16:00</td>
<td>002</td>
<td>General apparatus 002</td>
<td>ADSOC01</td>
<td>MOUNT</td>
<td>Mounted</td>
<td></td>
</tr>
</tbody>
</table>
## 11.3 Maintenance objects

### 11.3.4 "Header data" tab

The "Header data" tab displays information on the manufacturer of the equipment.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Type&quot; list</td>
<td>You select the type of the equipment from this list.</td>
</tr>
<tr>
<td>&quot;Manufacturer&quot; field</td>
<td>This field displays the manufacturer.</td>
</tr>
<tr>
<td>&quot;Supplier&quot; field</td>
<td>This field displays the supplier.</td>
</tr>
<tr>
<td>&quot;select...&quot; button</td>
<td>With this button, you can add information which is stored in the company database.</td>
</tr>
<tr>
<td>&quot;Description&quot; field</td>
<td>This field displays a description.</td>
</tr>
<tr>
<td>&quot;Order code&quot; field</td>
<td>This field displays the order code of the equipment.</td>
</tr>
<tr>
<td>&quot;Order No.&quot; field</td>
<td>This field displays the order number.</td>
</tr>
<tr>
<td>&quot;Description&quot; field</td>
<td>This field displays a description.</td>
</tr>
</tbody>
</table>
11.3.5 "Plant system" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Current data set&quot; list</td>
<td>The current data set is valid if all attributes have been entered with high priority.</td>
</tr>
<tr>
<td>&quot;Current system status&quot; list</td>
<td>This list determines the current status of the plant system.</td>
</tr>
<tr>
<td>Object query</td>
<td>The object query displays all objects which refer to a particular plant system.</td>
</tr>
</tbody>
</table>

11.3.6 Maintenance plan

11.3.6.1 "Configuration" tab

You use the "Configuration" tab to configure how work packages are created.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Create new work package&quot; list</td>
<td>In this list, you select the template to be used for creating work packages underneath the maintenance plan.</td>
</tr>
<tr>
<td>&quot;Base object of work package&quot; field</td>
<td>You drag&amp;drop the base object of the work package to this field.</td>
</tr>
<tr>
<td>&quot;Create work package automatically&quot; option</td>
<td>If this option is activated, a new work package is created automatically when the next date of the maintenance plan changes.</td>
</tr>
<tr>
<td>&quot;Create work package via Maintenance Demon&quot; option</td>
<td>If this option is activated, when the defined forewarn time is reached, a work package is created automatically using the maintenance demon. The automatic sequences can be defined via the enterprise server.</td>
</tr>
</tbody>
</table>

11.3.6.2 "History" tab

The "History" tab displays when emails were sent by the enterprise server or by manual calls in the "Maintenance demon" plugin.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;History&quot; column</td>
<td>This column displays a consecutive number.</td>
</tr>
<tr>
<td>&quot;Date sent&quot; column</td>
<td>This column shows the date on which the email was sent.</td>
</tr>
<tr>
<td>&quot;Time sent&quot; column</td>
<td>This column displays the time at which the email was sent.</td>
</tr>
<tr>
<td>&quot;Sent to&quot; column</td>
<td>This column displays the recipient of the email.</td>
</tr>
<tr>
<td>&quot;State&quot; column</td>
<td>This column displays the status of the email.</td>
</tr>
<tr>
<td>&quot;Outlook ID&quot; column</td>
<td>This column shows the ID generated by Outlook for the email.</td>
</tr>
</tbody>
</table>
11.3.6.3 "Legal care" tab

The "Legal care" tab shows links to legal texts.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Legal object&quot; list</td>
<td>You drag&amp;drop a legal care object to this field.</td>
</tr>
<tr>
<td>&quot;Reset list&quot; button</td>
<td>With this button, you delete the &quot;Legal object&quot; list.</td>
</tr>
<tr>
<td>&quot;Law link&quot; field</td>
<td>This field is not relevant here. It simply serves as an auxiliary object.</td>
</tr>
</tbody>
</table>

11.3.6.4 "Sub maintenance" tab

The "Sub maintenance" tab displays the link to the tour or master maintenance plan.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Maintenance tour/Master&quot; field</td>
<td>You drag&amp;drop the tour or master maintenance plan to which this maintenance plan is to be assigned as an inspection or sub maintenance plan to this field.</td>
</tr>
</tbody>
</table>

If two maintenance plans are due at the same time and only one of them is to be run, you can link the two plans together on the "Sub maintenance" tab. Drag&drop the master maintenance plan to the "Tour/master" field of the sub maintenance plan.

If you insert a work package below the master maintenance plan, the next maintenance date of the sub maintenance plan changes according to the setting on the "Maintenance plan" tab.

11.3.6.5 "Formula/details" tab

The "Formula/Details" tab displays the variables of the formulas for date calculations that you have defined using the "Edit calculation" button on the "Maintenance plan" tab.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Variables&quot; column</td>
<td>This column displays a consecutive number.</td>
</tr>
<tr>
<td>&quot;Name&quot; column</td>
<td>This column displays the name of the variable, for example, operating hours.</td>
</tr>
<tr>
<td>&quot;Value&quot; column</td>
<td>This column displays the value of the variable.</td>
</tr>
<tr>
<td>&quot;Edit calculation&quot; button</td>
<td>This button opens the &quot;Calculate work package dates&quot; window. See also chapter &quot;Calculate work package dates&quot; window (Page 115).</td>
</tr>
</tbody>
</table>
11.3.6.6 "Maintenance plan" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Next date&quot; field</td>
<td>This field displays the next maintenance date.</td>
</tr>
<tr>
<td>&quot;Forewarn time&quot; field</td>
<td>This field displays the forewarn time in days.</td>
</tr>
<tr>
<td>&quot;Tolerance&quot; field</td>
<td>This field displays the tolerance in days.</td>
</tr>
<tr>
<td></td>
<td>• Static date calculation: This field displays the number of days that you</td>
</tr>
<tr>
<td></td>
<td>can report a work package as ready prior to the next date. The next date</td>
</tr>
<tr>
<td></td>
<td>of the maintenance plan is recalculated.</td>
</tr>
<tr>
<td></td>
<td>• Dynamic date calculation: The entry in this field determines the number</td>
</tr>
<tr>
<td></td>
<td>of days that the maintenance plan can exceed the next date. The status</td>
</tr>
<tr>
<td></td>
<td>of the maintenance plan is &quot;Within tolerance&quot;. If the &quot;Advanced tolerance&quot;</td>
</tr>
<tr>
<td></td>
<td>field is available, use this field.</td>
</tr>
<tr>
<td>&quot;Advanced tolerance&quot; field</td>
<td>This field is not displayed by default in the tab. It must have the</td>
</tr>
<tr>
<td></td>
<td>name &quot;ToleranceAdvEdit&quot;. The description displayed in the</td>
</tr>
<tr>
<td></td>
<td>interface may vary. Contact the responsible administrator.</td>
</tr>
<tr>
<td></td>
<td>If this field is available and you are using dynamic or static date</td>
</tr>
<tr>
<td></td>
<td>calculation, enter the number of days that the maintenance plan can</td>
</tr>
<tr>
<td></td>
<td>exceed the next date. The status of the maintenance plan is</td>
</tr>
<tr>
<td></td>
<td>&quot;Within tolerance&quot;. You now have the possibility for static date</td>
</tr>
<tr>
<td></td>
<td>calculation and also for specifying a tolerance for a missed deadline.</td>
</tr>
</tbody>
</table>
### Control element | Description
--- | ---
"Maintenance active" option | When this option is enabled, it indicates that maintenance is active.
"Status" field | This field displays the current status of the maintenance plan. You either initiate the status calculation for the maintenance plan by opening this tab or the calculation is performed automatically via the "Maintenance demon" plugin. The current status can be evaluated via the status display in the Navigator, for example.
"Automatic preview" option | If this option is activated, you can create work packages underneath this maintenance plan using the "Maintenance demon" plugin.
"Create work packages via Maintenance Demon" option | This option is linked to the option of the same name on the "Configuration" tab.
"Scheduling Status" field | This field displays the currently selected scheduling status.
"Use date calculation" option | If this option is activated, the automatic date calculation function is used.
"Static date calculation" option | If this option is activated, the date calculation procedure changes from dynamic to static. This setting is required, for example, when the work package is not performed at the specified time, but, for example, 3 days later. If dynamic date calculation is selected, the next maintenance date is also postponed for 3 days. With static date calculation, on the other hand, the next maintenance date is calculated from the actual planned date.
"Last date" field | This field displays the date of the last processed work package.
"^Today^" button | This button enters the date of the current day in the "Last date" field.
"Edit calculation..." field | This button opens the "Calculate work package dates" window. See also chapter "Calculate work package dates" window (Page 115).
"Remarks" field | This field displays remarks relating to scheduling.
"Maintenance plan is relevant for devices" option | The activated option ensures that this device can no longer be used in plans in case of overdue maintenance plans. The device cannot be used until maintenance has been performed.

**Calculation using formulas and static date calculation**

You cannot use the "Calculate by formula" option at the same time as static date calculation. If both methods are used, the calculation by formula is ignored.
11.3.6.7 "Responsibilities" tab

The "Responsibilities" tab displays information concerning the responsible companies, departments, and people.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Responsibility - maintenance&quot; field</td>
<td>This field shows the person who is responsible for maintenance.</td>
</tr>
<tr>
<td>&quot;Responsibility - QA&quot; field</td>
<td>This field shows the person who is responsible for quality assurance.</td>
</tr>
<tr>
<td>&quot;Responsibility - operation&quot; field</td>
<td>This field shows the person who is responsible for operation.</td>
</tr>
<tr>
<td>&quot;Inherit from structure&quot; option</td>
<td>If this option is activated, the responsibilities are inherited from the structure.</td>
</tr>
<tr>
<td>&quot;Notify&quot; option</td>
<td>If this option is activated, the responsible persons can be notified of pending work packages via email from the maintenance demon.</td>
</tr>
</tbody>
</table>

"Responsibilities" tab and use of the USERS project

If you use the USERS project as the company DB, you must use the new "Responsibilities" tab. To do this, drag&drop the responsibilities from the USERS project shown in the planning project to the corresponding fields.
11.3.7 "Calculate work package dates" window

Overview

The "Calculate work package dates" window displays information on the scheduling (date calculation) of work packages.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Add line&quot; button</td>
<td>Via this button you append a new row at the end of the table.</td>
</tr>
<tr>
<td></td>
<td>This function is also available in the context menu.</td>
</tr>
<tr>
<td>&quot;Remove line&quot; button</td>
<td>This button deletes the row in which the focus is currently set.</td>
</tr>
<tr>
<td></td>
<td>This function is also available in the context menu.</td>
</tr>
<tr>
<td>&quot;Last date&quot; field</td>
<td>This field displays the date of the last work package.</td>
</tr>
<tr>
<td>&quot;Next date&quot; field</td>
<td>This field displays the date of the next work package.</td>
</tr>
<tr>
<td>&quot;State&quot; column</td>
<td>This column displays the status of the maintenance plan date.</td>
</tr>
<tr>
<td>&quot;Interval&quot; column</td>
<td>This column displays the interval after which the next work package</td>
</tr>
<tr>
<td></td>
<td>should take place.</td>
</tr>
<tr>
<td>&quot;Time type&quot; column</td>
<td>You select the time type for the interval from this list.</td>
</tr>
<tr>
<td></td>
<td>Double-click on the field to open the list.</td>
</tr>
<tr>
<td>&quot;Date&quot; column</td>
<td>This column displays the calculated date of the next work package.</td>
</tr>
<tr>
<td>&quot;Formula&quot; column</td>
<td>This column displays the formula which you have created in the</td>
</tr>
<tr>
<td></td>
<td>&quot;Formula entry&quot; window.</td>
</tr>
<tr>
<td>&quot;...&quot; button</td>
<td>With this button, you open the &quot;Formula entry&quot; window.</td>
</tr>
</tbody>
</table>

See also

Calculating a maintenance date using a formula (Page 24)
## 11.3.8 "Time planning" window

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Add line&quot; button</td>
<td>You can use this button to add a new row at the end of the table.</td>
</tr>
<tr>
<td>&quot;Remove line&quot; button</td>
<td>You can use this button to delete the selected row in the table.</td>
</tr>
<tr>
<td>&quot;Last date&quot; field</td>
<td>This field displays the last date of the maintenance plan. Date format: YYYY.MM.DD</td>
</tr>
<tr>
<td>&quot;Next date&quot; field</td>
<td>This field displays the next date of the maintenance plan. Date format: YYYY.MM.DD</td>
</tr>
<tr>
<td>&quot;New work package date&quot; field</td>
<td>This field display the new date on which the work package will be performed.</td>
</tr>
<tr>
<td>&quot;Suspend execution&quot; option</td>
<td>If you select this option, the date that you enter in the &quot;New work package date&quot; field is inserted into the &quot;Next date&quot; field. This new date must be later than the date that was entered in the &quot;Next date&quot; field. All planned work packages assigned to the maintenance plan with a planned date prior to the new date are canceled. If the &quot;Canceled&quot; option is not present in the &quot;Attributes &gt; Maintenance Plan&quot; tab, all scheduled work packages are deleted.</td>
</tr>
<tr>
<td>&quot;Postpone execution&quot; option</td>
<td>If you select this option, the date of the associated work package is moved to the date specified in the &quot;New work package date&quot; field. The new date must be after the date in the &quot;Next date&quot; field. The dates of all scheduled work packages are adjusted based on the new date and the specified intervals. All scheduled work packages whose next date is after the new date plus a forewarn time are canceled. If the &quot;Canceled&quot; option is not present in the &quot;Attributes &gt; Maintenance Plan&quot; tab, all scheduled work packages are deleted.</td>
</tr>
<tr>
<td>Table</td>
<td>You can use this table to change the interval on which the date calculation is based. This displays the interval stored in the &quot;Attributes &gt; Maintenance plan&quot; tab of the maintenance plan. If, for example: the interval cannot be changed due to the selected strategy, this table is locked against editing.</td>
</tr>
</tbody>
</table>
### 11.3.9 Work package

#### 11.3.9.1 "Object links" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Goods receipt&quot; field</td>
<td>This field displays the linked goods receipt object.</td>
</tr>
<tr>
<td>&quot;Goods issue&quot; field</td>
<td>This field displays the linked outgoing goods object.</td>
</tr>
<tr>
<td>&quot;Order&quot; field</td>
<td>This field displays the linked order object.</td>
</tr>
<tr>
<td>&quot;Date of receipt&quot; field</td>
<td>This field displays the date the goods were received.</td>
</tr>
<tr>
<td>&quot;Goods issue display&quot; field</td>
<td>This field displays goods that are sent out.</td>
</tr>
<tr>
<td>&quot;Date of supply&quot; field</td>
<td>This field displays the delivery date.</td>
</tr>
<tr>
<td>&quot;Offer&quot; field</td>
<td>This field displays the linked offer object.</td>
</tr>
<tr>
<td>&quot;Date from&quot; field</td>
<td>This field specifies the date as of which a tour is defined as valid and can be linked to the work package. The link between the maintenance plan and the tour maintenance plan is evaluated.</td>
</tr>
<tr>
<td>&quot;Date to&quot; field</td>
<td>This field specifies the date up to which a tour is defined as valid and can be linked to the work package. The link between the maintenance plan and the tour maintenance plan is evaluated.</td>
</tr>
<tr>
<td>&quot;Date delta&quot; field</td>
<td>This field specifies the number of days that are subtracted from or added to the scheduled date of the tour. All maintenance plans linked to the work package plan within this period are included in a search for tours. If you enter a value in this field, the entries in the &quot;Date from&quot; and &quot;Date to&quot; fields are calculated automatically.</td>
</tr>
<tr>
<td>&quot;Plant system&quot; field</td>
<td>This field displays the linked plant system.</td>
</tr>
<tr>
<td>&quot;Link to plant system automatically&quot; option</td>
<td>If this option is activated for the base object, the work package is linked automatically to the plant system work package during creation.</td>
</tr>
<tr>
<td>&quot;Linked base package&quot; field</td>
<td>This field displays the linked base package.</td>
</tr>
<tr>
<td>&quot;Shutdown/Turnaround master&quot; field</td>
<td>This field displays the shutdown master.</td>
</tr>
<tr>
<td>&quot;Shutdown&quot; field</td>
<td>This field displays the linked shutdown object.</td>
</tr>
</tbody>
</table>
11.3.9.2 "Work package" tab

Overview

Control element | Description
--- | ---
"Date" field | This field displays the date of the next work package.
"To" field | This field displays the completion date.
"^Exec now^" button | This button enters the scheduled data in the "Date" field and the maintenance status is changed from "planned" to "in progress".
"Sched. date" field | This field displays the scheduled date of the work package.
"Update Rema date" button | You use this button to update the scheduled start and end dates in the "Resource planning" tab, without having to open the "Resource management" plugin.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Date&quot; field</td>
<td>This field displays the date of the next work package.</td>
</tr>
<tr>
<td>&quot;To&quot; field</td>
<td>This field displays the completion date.</td>
</tr>
<tr>
<td>&quot;^Exec now^&quot; button</td>
<td>This button enters the scheduled data in the &quot;Date&quot; field and the maintenance status is changed from &quot;planned&quot; to &quot;in progress&quot;.</td>
</tr>
<tr>
<td>&quot;Sched. date&quot; field</td>
<td>This field displays the scheduled date of the work package.</td>
</tr>
<tr>
<td>&quot;Update Rema date&quot; button</td>
<td>You use this button to update the scheduled start and end dates in the &quot;Resource planning&quot; tab, without having to open the &quot;Resource management&quot; plugin.</td>
</tr>
<tr>
<td>Control element</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>&quot;Description&quot; field</td>
<td>This field displays the description of the work package.</td>
</tr>
<tr>
<td>&quot;Detail planning possible&quot; option</td>
<td>If this option is activated in the base objects, you will be asked when you create the work package whether it should be planned or performed immediately.</td>
</tr>
<tr>
<td>&quot;Planned as default&quot; option</td>
<td>If this option is activated in the base objects, you will be asked when you create the work package whether it should be planned or performed immediately if the work package is created immediately as &quot;planned&quot;.</td>
</tr>
<tr>
<td>&quot;Device OK&quot; option</td>
<td>If this option is activated, it indicates that no device has violated its maintenance cycle, so all devices are fully operational. See also chapter Making the resource check (Page 88).</td>
</tr>
<tr>
<td>&quot;Optimized&quot; option</td>
<td>This option is activated automatically if the activities of this work package have been optimized using the shutdown management.</td>
</tr>
<tr>
<td>&quot;Canceled&quot; option</td>
<td>This option is activated automatically when the work package is canceled. See also chapter Canceling work packages (Page 29).</td>
</tr>
<tr>
<td>&quot;Description&quot; field</td>
<td>This field displays the description of the work package.</td>
</tr>
<tr>
<td>&quot;Status&quot; list</td>
<td>This list displays the current status of the work package.</td>
</tr>
<tr>
<td>&quot;Degree of completion (linear)&quot; field</td>
<td>This field displays the linear completion degree. Each activity gets the same weighting. Example: 2 of 3 activities are completed, degree of completion linear: 2/3 = 0.66 ; 66.67%</td>
</tr>
<tr>
<td>&quot;%&quot; list</td>
<td>This list displays the unit of the completion degree. The entry &quot;%&quot; is selected as default.</td>
</tr>
<tr>
<td>&quot;Degree of completion (hours)&quot; field</td>
<td>This field displays the completion degree weighted according to hours. Each activity is weighted according to its planned duration. If no qualification is created for an activity, the activity is counted as taking one hour. Example: Activity1: 5 hours (completed); Activity2 : - hours (completed); Activity3 : 3 hours (not completed). Degree of completion weighted: 6/9 = 0.66 ; 66.67%</td>
</tr>
<tr>
<td>&quot;Time&quot; row</td>
<td>This row displays the hours required to perform the work package.</td>
</tr>
<tr>
<td>&quot;Costs&quot; row</td>
<td>This row displays the costs in Euro that result from performing the work package.</td>
</tr>
<tr>
<td>&quot;Price&quot; row</td>
<td>This row displays the price in Euro that is reckoned for performing the work package.</td>
</tr>
<tr>
<td>&quot;Material&quot; row</td>
<td>This row displays the amount in Euro calculated for materials.</td>
</tr>
<tr>
<td>&quot;Total&quot; row</td>
<td>This field displays the total costs in Euro resulting from the work package.</td>
</tr>
<tr>
<td>&quot;Plan Plan&quot; column</td>
<td>This column displays the planned costs for performing the activities.</td>
</tr>
<tr>
<td>&quot;Plan Additional&quot; column</td>
<td>This column displays the costs expected to result from additional activities.</td>
</tr>
<tr>
<td>&quot;Actual Plan&quot; column</td>
<td>This column displays the actual costs resulting from the planned activities.</td>
</tr>
</tbody>
</table>

User interface reference
11.3 Maintenance objects

MRO (Maintenance Repair and Overhaul)
Operating Manual, 08/2011, A5E03633096-01
### 11.3 Maintenance objects

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Actual Additional&quot; column</td>
<td>This column displays the actual costs resulting from additional activities.</td>
</tr>
<tr>
<td>&quot;Calculate from tasks&quot; button</td>
<td>This button enters the times and costs of the individual activities belonging to the work package in total in the appropriate fields.</td>
</tr>
<tr>
<td>&quot;Order No.&quot; field</td>
<td>This field displays the order number.</td>
</tr>
<tr>
<td>&quot;Remarks&quot; field</td>
<td>This field displays remarks relating to the work package.</td>
</tr>
<tr>
<td>&quot;Internal Remarks&quot; field</td>
<td>This field displays internal remarks.</td>
</tr>
<tr>
<td>&quot;History&quot; table</td>
<td>This table displays the history of the work package.</td>
</tr>
</tbody>
</table>

#### 11.3.10 Task package object

**11.3.10.1 "Dis-/mounting info" tab**

The "Dis-/mounting info" tab contains information regarding the nozzle list.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Refresh&quot; button</td>
<td>This button refreshes the nozzle list for the superordinate level work package.</td>
</tr>
<tr>
<td>&quot;Edit&quot; button</td>
<td>This button opens the &quot;Nozzles/work packages&quot; window, in which the task package can be adapted. The nozzle list should be edited using the &quot;Quick edit&quot; plugin.</td>
</tr>
<tr>
<td>Table</td>
<td>This table displays information regarding the nozzle.</td>
</tr>
<tr>
<td>&quot;Remarks&quot; field</td>
<td>This field displays remarks relating to the nozzle.</td>
</tr>
</tbody>
</table>

**11.3.10.2 "Qualifications" tab**

The "Qualifications" tab displays information regarding the qualifications that have been assigned to the activities.

Qualifications entered here can be generated for every activity using the "Create all qualifications" function.

**Activity**

You should note that the corresponding type must be entered for the activity on the "Qualifications" tab.
11.3.10.3 "Resource planning" tab

The "Resource planning" tab contains information that is evaluated in the "Resource management" plugin.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Planned start date&quot; field</td>
<td>This field displays the planned start date.</td>
</tr>
<tr>
<td>&quot;Canceled&quot; option</td>
<td>If this option is activated, the work package is not displayed in the &quot;Resource management&quot; plugin.</td>
</tr>
<tr>
<td>&quot;Planned end date&quot; field</td>
<td>This field displays the planned end date.</td>
</tr>
<tr>
<td>&quot;Display text&quot; field</td>
<td>Here, an authorized administrator can use GetDisplayValue to define which description is to be displayed in the &quot;Resource management&quot; plugin and in the MS Project export.</td>
</tr>
<tr>
<td>&quot;Planned working units&quot; field</td>
<td>This field displays the planned working units in hours.</td>
</tr>
<tr>
<td>&quot;Start date (move) locked&quot; option</td>
<td>If this option is activated, the start date cannot be changed in the &quot;Resource management&quot; plugin. The bar displayed cannot be moved using drag&amp;drop.</td>
</tr>
<tr>
<td>&quot;Units/Time&quot; field</td>
<td>This field displays the working units per time unit in percentage.</td>
</tr>
<tr>
<td>&quot;Load (units/time) locked&quot; option</td>
<td>If this option is activated, the load cannot be changed in the &quot;Resource management&quot; plugin. The bar displayed cannot be extended or shortened.</td>
</tr>
<tr>
<td>&quot;Progress&quot; field</td>
<td>This field displays the progress in percentage.</td>
</tr>
<tr>
<td>&quot;Assignments (person) locked&quot; option</td>
<td>If this option is activated, no assignment can be made for this object in the &quot;Edit qualification/persons&quot; window.</td>
</tr>
<tr>
<td>&quot;Factor units&quot; field</td>
<td>This field displays the factor units. As default, 1 is entered here.</td>
</tr>
<tr>
<td>&quot;Dependencies locked&quot; option</td>
<td>If this option is activated, you cannot add or change any dependencies using drag&amp;drop or via the context menu.</td>
</tr>
<tr>
<td>&quot;Planning mode&quot; list</td>
<td>You select the planning mode from this list. If the status &quot;Schedule stop at this level (sequential)&quot; or &quot;Planstop at this level (parallel)&quot; is selected, it is only possible to plan as far as the level of the work package in the &quot;Resource management&quot; plugin.</td>
</tr>
<tr>
<td>&quot;Turnaround phase&quot; list</td>
<td>You select the assignment of the object to a shutdown phase from this list.</td>
</tr>
<tr>
<td>Table</td>
<td>This table displays information regarding the predecessors in the resource planning.</td>
</tr>
</tbody>
</table>

Additional information

- You can find more information on the milestone phases in the "Shutdown" manual, keyword "Milestones".
11.3.11 Activity

11.3.11.1 "Barcode" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field</td>
<td>This field displays the barcode.</td>
</tr>
<tr>
<td>&quot;Standard by DisplayValue&quot; list</td>
<td>This list displays how the barcode is generated.</td>
</tr>
<tr>
<td>&quot;New Barcode&quot; button</td>
<td>With this button, you generate a new barcode.</td>
</tr>
<tr>
<td>&quot;Use barcode&quot; option</td>
<td>If this option is activated, the barcode is used.</td>
</tr>
</tbody>
</table>

To be able to call and report back individual activities via the "Direct" plugin, each activity must be assigned a unique barcode. You use the unique system UID or generate a numerical value for this purpose.

11.3.11.2 "Activity" tab

The "Activity" tab shows details of the activity.
User interface reference

11.3 Maintenance objects

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Finished&quot; option</td>
<td>If this option is activated, it indicates that the activity has been reported as completed.</td>
</tr>
<tr>
<td>&quot;Progress&quot; field</td>
<td>This field displays the progress of the activity.</td>
</tr>
<tr>
<td>&quot;%&quot; list</td>
<td>This list displays the unit of the progress.</td>
</tr>
<tr>
<td>&quot;Not needed to be done&quot; option</td>
<td>If this option is activated, it indicates that the activity did not need to be done.</td>
</tr>
<tr>
<td>&quot;Additional activity&quot; option</td>
<td>If this option is activated, it indicates that the activity involved is an additional activity.</td>
</tr>
<tr>
<td>&quot;Description&quot; field</td>
<td>This field displays a description of the activity.</td>
</tr>
<tr>
<td>&quot;Picture&quot; field</td>
<td>This field displays the path to a picture file.</td>
</tr>
<tr>
<td>Button</td>
<td>Via this button, you delete the path to the picture file.</td>
</tr>
<tr>
<td>&quot;Time Plan&quot; field</td>
<td>This field displays the planned working hours for the activity.</td>
</tr>
<tr>
<td>&quot;Time Actual&quot; field</td>
<td>This field displays the actual working hours for the activity.</td>
</tr>
<tr>
<td>&quot;Costs Plan&quot; field</td>
<td>This field displays the planned costs for the activity.</td>
</tr>
<tr>
<td>&quot;Costs Actual&quot; field</td>
<td>This field displays the actual costs for the activity.</td>
</tr>
<tr>
<td>&quot;Price Plan&quot; field</td>
<td>This field displays the planned price for the activity.</td>
</tr>
<tr>
<td>&quot;Price Actual&quot; field</td>
<td>This field displays the actual price for the activity.</td>
</tr>
<tr>
<td>&quot;Refresh time and costs&quot; button</td>
<td>With this button, you refresh the entries in the &quot;Time&quot; and &quot;Costs&quot; fields.</td>
</tr>
<tr>
<td>&quot;Remarks&quot; field</td>
<td>This field displays remarks.</td>
</tr>
<tr>
<td>&quot;Internal Remarks&quot; field</td>
<td>This field displays internal remarks.</td>
</tr>
<tr>
<td>&quot;History&quot; table</td>
<td>This table displays the history of the activity.</td>
</tr>
</tbody>
</table>

11.3.11.3 "Qualification types" tab

The "Qualification types" tab displays information relating to the qualifications. Here, you select which qualification type entered for the work package is relevant for this activity. The type references the qualifications entered for the work package. Its predecessor list on the "Resource planning" tab lists the activities for which dependencies have been created and which precede the selected activity.

See also

"Resource planning" tab (Page 121)
11.3 Maintenance objects

11.3.12 "Qualification" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Qualification&quot; field</td>
<td>This field displays the name of the qualification that is entered automatically based on the selection in the &quot;Filter hour rate&quot; and &quot;Hour rate&quot; lists. This entry is then displayed in the Navigator as the name.</td>
</tr>
<tr>
<td>&quot;Qualification is standard&quot; option</td>
<td>This option is relevant only when a Primavera interface exists. If this option is activated, this qualification is used for calculating the resources.</td>
</tr>
<tr>
<td>&quot;Filter hour rate&quot; list</td>
<td>You select a grouping option for the hourly rate from this list.</td>
</tr>
<tr>
<td>&quot;Hour rate&quot; list</td>
<td>This list displays the hourly rate of the qualification. The list is filled only if an entry was selected from the &quot;Filter hour rate&quot; list.</td>
</tr>
<tr>
<td>&quot;Time exposure planned&quot; field</td>
<td>This group field displays the planned time required by the qualification to perform the task.</td>
</tr>
<tr>
<td>&quot;h&quot; list</td>
<td>You select the time unit for the time required from this list. Hours is selected as default.</td>
</tr>
<tr>
<td>&quot;Planned costs&quot; field</td>
<td>This field displays the planned costs.</td>
</tr>
<tr>
<td>&quot;EUR&quot; list</td>
<td>This field displays the unit of currency. Euro is selected here as default.</td>
</tr>
<tr>
<td>&quot;Sell price planned&quot; field</td>
<td>This field displays the planned selling price.</td>
</tr>
<tr>
<td>&quot;Transfer times and costs into steps&quot; button</td>
<td>This button transfers the planned costs and the planned selling price to the superordinate level activity if a selection was made in the &quot;Qualification&quot; section and the &quot;Time exposure planned&quot; field has an entry.</td>
</tr>
<tr>
<td>&quot;Role&quot; field</td>
<td>This field is not relevant.</td>
</tr>
<tr>
<td>&quot;Availability&quot; field</td>
<td>This field is not relevant here.</td>
</tr>
</tbody>
</table>

Additional information

- You can find additional information on the "Availability" field in the "Maintenance Administration" manual, keyword "Nodes underneath the person object".

11.3.13 "Spare part" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Material ID&quot; field</td>
<td>This field displays the material ID of the spare part.</td>
</tr>
<tr>
<td>&quot;Quantity&quot; field</td>
<td>This field displays how many spare parts of this type are required.</td>
</tr>
<tr>
<td>&quot;Description&quot; field</td>
<td>This field displays the description of the spare part.</td>
</tr>
<tr>
<td>&quot;Single price&quot; field</td>
<td>This field displays the price per spare part.</td>
</tr>
<tr>
<td>&quot;EUR&quot; list</td>
<td>You select the currency of the single price from this list. Euro is set as default.</td>
</tr>
</tbody>
</table>
11.3 Maintenance objects

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Sparepart is additional&quot; option</td>
<td>If this option is activated, the spare part is booked separately.</td>
</tr>
<tr>
<td>&quot;Material ID SAP&quot; field</td>
<td>This field is relevant only when an SAP interface exists and displays the SAP material ID.</td>
</tr>
<tr>
<td></td>
<td>If there is an SAP interface, the spare part can be booked out of SAP.</td>
</tr>
<tr>
<td>&quot;Short text for material&quot; field</td>
<td>This field is relevant only when an SAP interface exists and displays the short text for the material.</td>
</tr>
<tr>
<td></td>
<td>If there is an SAP interface, the spare part can be booked out of SAP.</td>
</tr>
<tr>
<td>&quot;Tender relevant&quot; option</td>
<td>If this option is activated, the spare part is included in the tender documents.</td>
</tr>
<tr>
<td>&quot;Stock good&quot; field</td>
<td>This field displays the bulk goods object from which the spare part was taken assuming it was defined as bulk goods.</td>
</tr>
</tbody>
</table>

11.3.14 "Bulk material" window

Overview

The "Bulk material" window contains information on the material that has been defined as bulk goods and that will be inserted from stock.
### 11.3 Maintenance objects

#### "Material no." field
This field displays the material number of the bulk goods object. This field cannot be edited.

#### "Amount" field
This field displays the amount of the bulk commodity currently in stock.
This field displays the information entered in the properties of the bulk goods object on the "Bulk goods" tab.

#### "Unit" field
This field displays how many of this commodity make up a unit.
Note: This field displays the information entered in the properties of the bulk goods object on the "Bulk goods" tab.

#### "PU" field
This field displays how many of this commodity make up a package unit.
This field displays the information entered in the properties of the bulk goods object on the "Bulk goods" tab.

#### "Minimum" field
This field displays the minimum stock level.
This field displays the information entered in the properties of the bulk goods object on the "Bulk goods" tab.

#### "Maximum" field
This field displays the maximum stock level.
This field displays the information entered in the properties of the bulk goods object on the "Bulk goods" tab.

#### "Optimal quantity" field
This field displays the ideal stock level.
This field displays the information entered in the properties of the bulk goods object on the "Bulk goods" tab.

#### "Amount" field
This field displays the amount of this commodity currently available.

#### "+" button
With this button, you reduce the number of the commodity that will be taken from stock.

#### "-" button
Via this button, you increase the number of the commodity that will be taken from stock.

#### "Use package unit" option
If this option is activated, the predefined package unit is used.

#### "Difference" field
This field displays how many units of this commodity were taken from stock.

#### "Remarks" field
This field displays remarks relating to the bulk goods.

#### "Assigned to activity:" field
This field displays the activity to which the commodity is assigned.

### 11.3.15 "Device reference" tab
The "Reference" tab displays information regarding the referenced equipment.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Type of resource&quot; list</td>
<td>In this list, you select the type of resource.</td>
</tr>
<tr>
<td>&quot;Use resource UID&quot; field</td>
<td>This field displays the used UID of the reference.</td>
</tr>
<tr>
<td>&quot;Used resource&quot; field</td>
<td>You drag&amp;drop the equipment object to be used as the device to this field.</td>
</tr>
<tr>
<td>&quot;Is valid&quot; option</td>
<td>If this option is activated, this indicates that the device will still be valid at the time of the next maintenance date.</td>
</tr>
</tbody>
</table>
11.3 Maintenance objects

### Control element Description

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Description&quot; field</td>
<td>This field displays a description of the resource.</td>
</tr>
<tr>
<td>&quot;Mandatory&quot; option</td>
<td>If this option is activated, maintenance can only be performed if the device is available and its maintenance date has not been exceeded.</td>
</tr>
<tr>
<td>&quot;Duration of activity&quot; field</td>
<td>This field displays the duration of activities in hours.</td>
</tr>
</tbody>
</table>

#### 11.3.16 "Tour configuration" tab

The "Tour configuration" tab displays options for creating inspections.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Options for creating inspections&quot; list</td>
<td>This list displays the option selected by the administrator for the base object.</td>
</tr>
</tbody>
</table>
11.4 Plugins

11.4.1 Tab of the "Object search" plugin

Overview

![Object search plugin tab](image)

Table of attributes:

<table>
<thead>
<tr>
<th>Label</th>
<th>Description</th>
<th>Maintenance plan Status</th>
<th>Maintenance plan Next date</th>
</tr>
</thead>
<tbody>
<tr>
<td>R</td>
<td>Planning folder</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MTO1</td>
<td>Maintenance plan tour</td>
<td>OK</td>
<td>2011.01.20</td>
</tr>
<tr>
<td>01</td>
<td>Unit</td>
<td></td>
<td></td>
</tr>
<tr>
<td>C11</td>
<td>Import</td>
<td></td>
<td></td>
</tr>
<tr>
<td>C02</td>
<td>Export</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CO1</td>
<td>Export</td>
<td></td>
<td></td>
</tr>
<tr>
<td>R</td>
<td>Planning folder</td>
<td></td>
<td></td>
</tr>
<tr>
<td>R</td>
<td>Planning folder</td>
<td></td>
<td></td>
</tr>
<tr>
<td>R</td>
<td>Planning folder</td>
<td></td>
<td></td>
</tr>
<tr>
<td>R</td>
<td>Planning folder</td>
<td></td>
<td></td>
</tr>
<tr>
<td>R</td>
<td>Planning folder</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MTO1</td>
<td>Maintenance plan tour</td>
<td>Inactive/not calculated</td>
<td></td>
</tr>
<tr>
<td>2015.12.06</td>
<td>Allgemeine Pumpenwar...</td>
<td>(...),</td>
<td></td>
</tr>
<tr>
<td>MPPL</td>
<td>General maintenance</td>
<td>Inactive/not calculated</td>
<td></td>
</tr>
</tbody>
</table>
Menu bar

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Start search&quot; button</td>
<td>With this button, you start the search.</td>
</tr>
<tr>
<td>&quot;Extra&quot; button</td>
<td>With this button, you open a list containing options for editing the search result. Which options are displayed here can be configured and expanded by the responsible administrator.</td>
</tr>
<tr>
<td>&quot;Edit attributes&quot; button</td>
<td>With this button, you enable the &quot;Attributes&quot; section. Attributes can be added with drag&amp;drop from the Navigator. Expression fields can be added. The attribute can be deleted with the &quot;X&quot; button. Calendar values can be entered not only as text but also via calendar selection &quot;....&quot;. The individual attributes are displayed as columns in the results area on completion of the search.</td>
</tr>
<tr>
<td>&quot;Insert expression field&quot; button</td>
<td>With this button, you insert expression fields in the &quot;Attributes&quot; section. In the &quot;&lt;&lt;Enter Expression&gt;&gt;&quot; field, you can enter any COMOS Script code that will be evaluated for each row. This makes it possible to access the object model of COMOS.</td>
</tr>
<tr>
<td>&quot;Reset&quot; button</td>
<td>With this button, you reset all filter settings.</td>
</tr>
<tr>
<td>&quot;Options&quot; button</td>
<td>With this button, you open the &quot;Options&quot; window. Here, you can make the search settings.</td>
</tr>
<tr>
<td>&quot;Query mode&quot; button</td>
<td>With this button, you enable and disable the query mode. In query mode, the search result (rows and columns) is defined using a query. Drag&amp;drop a query object to the &quot;Query&quot; field. You can use all standard query modes in the object search.</td>
</tr>
<tr>
<td>&quot;Search by COMOS classification&quot;</td>
<td>Use this button to display a search based on classification. The authorized administrator determines in the user-specific project options if the search based on classification should be selected by default.</td>
</tr>
<tr>
<td>button</td>
<td></td>
</tr>
<tr>
<td>&quot;Search by label&quot; button</td>
<td>With this button, you select whether the filter option &quot;Label&quot; or &quot;Name&quot; is available.</td>
</tr>
<tr>
<td>&quot;Multiple root nodes&quot; button</td>
<td>With this button, you enable or disable the dragging of multiple objects to the &quot;Start object&quot; field.</td>
</tr>
<tr>
<td>&quot;Export result&quot; button</td>
<td>This button opens the &quot;Export&quot; window. See also chapter Exporting the search result from the &quot;Object search&quot; plugin (Page 92).</td>
</tr>
<tr>
<td>&quot;View result in Excel&quot; button</td>
<td>Via this button, you can display the result in an Excel table instead of in a result list. The Excel table is then integrated in the COMOS user interface.</td>
</tr>
<tr>
<td>&quot;Result to Excel&quot; button</td>
<td>Via this button, you open a list containing options for editing the Excel table.</td>
</tr>
<tr>
<td>&quot;Load profile&quot; button</td>
<td>Via this button, you open a stored search profile. See also chapter Profiles (Page 14).</td>
</tr>
<tr>
<td>&quot;Save profile&quot; button</td>
<td>With this button, you store a search profile.</td>
</tr>
<tr>
<td>***** list</td>
<td>You select a profile from this list.</td>
</tr>
<tr>
<td>&quot;Multiline&quot; button</td>
<td>This button expands cells accordingly if their content extends beyond one line.</td>
</tr>
</tbody>
</table>
Application area

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Start object&quot; field</td>
<td>This field displays the start object for the search.</td>
</tr>
<tr>
<td>&quot;Class&quot; list</td>
<td>Using this list, you restrict the search result to a specific object class. You have the following options for selecting an object class:</td>
</tr>
<tr>
<td></td>
<td>- Drag &amp; drop an object to the field.</td>
</tr>
<tr>
<td></td>
<td>- Select an object class from the list.</td>
</tr>
<tr>
<td></td>
<td>- Use the &quot;-&gt;&quot; button to open a window where you select an object class or subclass.</td>
</tr>
<tr>
<td>&quot;Label&quot; field</td>
<td>Via this field, you restrict the search result to specific object labels or names.</td>
</tr>
<tr>
<td>&quot;Description&quot; field</td>
<td>Use this field to restrict the search result to objects with a particular description.</td>
</tr>
</tbody>
</table>

11.4.2 "Options" window of the "Object search" plugin

Overview

In the "Options" window, you make the settings for searches and the display of the search result.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Compare attributes afterwards&quot; option</td>
<td>If this option is activated, the search result is compared with the filter criteria afterwards. This allows attributes that have not been checked in to be evaluated. Search results that are excluded by the subsequent filters are marked &quot;(False)&quot;.</td>
</tr>
<tr>
<td>&quot;Delete non-matching lines&quot; option</td>
<td>If this option is activated, search results excluded from the result collection by subsequent filtering are not displayed.</td>
</tr>
<tr>
<td>&quot;Mark parental attributes&quot; option</td>
<td>If this option is activated, the attributes of the superior object in the tree structure are highlighted in color when you search for attributes of different objects.</td>
</tr>
<tr>
<td>&quot;Search by label instead of name&quot; option</td>
<td>If this option is activated, the filter field &quot;Label&quot; is available. If the option is not activated, the &quot;Name&quot; filter field is displayed.</td>
</tr>
<tr>
<td>&quot;Case-sensitive&quot; option</td>
<td>If this option is activated, searches for object names and object descriptions are case-sensitive. This filter is ignored for attributes. Database settings overlay this setting. If non-case-sensitive searches are configured in the database, this setting cannot change anything.</td>
</tr>
<tr>
<td>&quot;Excel template (*.xl, *.xltx)&quot; field</td>
<td>This field displays the selected Excel template. This setting is saved in the user profile. If you do not specify a template here, the result is shown on a blank Excel sheet.</td>
</tr>
<tr>
<td>&quot;...&quot; button</td>
<td>Via this button, you select the required Excel template.</td>
</tr>
</tbody>
</table>
11.4 Plugins

"Use embedded Excel as default view" option

If this option is activated, the search result is not displayed in the form of a list but as an Excel table. The next time you load your user profile, the "View result in Excel" button is activated automatically. You can also enable and disable this option with the "Result to Excel" button.

"Show units" option

If this option is activated, the associated units are also displayed.

11.4.3 "Export" window

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Export to new Excel sheet&quot; option</td>
<td>If this option is activated, the result is exported to a blank Excel sheet.</td>
</tr>
<tr>
<td>&quot;Excel template (*.xlt, *.xltx)&quot; option</td>
<td>If this option is activated, the result is exported to an Excel template.</td>
</tr>
<tr>
<td>Field</td>
<td>This field displays the selected Excel template.</td>
</tr>
<tr>
<td>&quot;…&quot; button</td>
<td>Via this button, you select the required Excel template.</td>
</tr>
<tr>
<td>&quot;Life view during export (slow)&quot; option</td>
<td>If this option is activated, you can view how the Excel sheet is being filled in as it happens.</td>
</tr>
<tr>
<td>&quot;Export to XML (*.xml)&quot; option</td>
<td>If this option is activated, the result is saved to an &quot;XML&quot; file.</td>
</tr>
<tr>
<td>Field</td>
<td>This field shows the selected &quot;XML&quot; file.</td>
</tr>
<tr>
<td>&quot;…&quot; button</td>
<td>You use this button to select the required &quot;XML&quot; file.</td>
</tr>
</tbody>
</table>

11.4.4 "Order data" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Date of receipt&quot; field</td>
<td>This field displays the date the order was received. The date format is YYYY.MM.DD.</td>
</tr>
<tr>
<td>&quot;Report ID&quot; field</td>
<td>This field displays the report number.</td>
</tr>
<tr>
<td>&quot;Order cancelled&quot; option</td>
<td>If this option is activated, this means that the order has been canceled.</td>
</tr>
<tr>
<td>&quot;Order-No.&quot; field</td>
<td>This field displays the order number.</td>
</tr>
<tr>
<td>&quot;Order finished&quot; option</td>
<td>If this option is activated, this means that the order has been completed.</td>
</tr>
<tr>
<td>&quot;Order No. Client:&quot; field</td>
<td>This field displays the order number.</td>
</tr>
<tr>
<td>&quot;Lock order&quot; option</td>
<td>Activating this option locks the order.</td>
</tr>
<tr>
<td>&quot;Description&quot; field</td>
<td>This field displays the description of the order.</td>
</tr>
<tr>
<td>&quot;Order costs&quot; field</td>
<td>This field displays the order costs.</td>
</tr>
<tr>
<td>&quot;Order price&quot; field</td>
<td>This field displays the order price.</td>
</tr>
</tbody>
</table>
"Alternative order" field | This field displays the alternative order.
---|---
"Alternative order 2" field | This field displays the second alternative order.
"Order folder name" field | This field displays the order folder.
"Links" table | This table displays linked equipment and maintenance plans.
"Long text" field | This field displays a long text.

### 11.4.5 Tab of the "Maintenance order" plugin

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Open order&quot; button</td>
<td>With this button, you open the &quot;New order&quot; window.</td>
</tr>
<tr>
<td>&quot;Edit order data&quot; button</td>
<td>With this button, you open the &quot;Order data&quot; window.</td>
</tr>
<tr>
<td>&quot;Edit responsibilities&quot; button</td>
<td>With this button, you open the &quot;Responsibilities&quot; tab. To be able to use this function, the tab must exist for the order object.</td>
</tr>
<tr>
<td>&quot;Cancel order&quot; button</td>
<td>Via this button, you cancel the order.</td>
</tr>
<tr>
<td>&quot;Archive order&quot; button</td>
<td>Via this button, you archive the order.</td>
</tr>
<tr>
<td>&quot;Clone order&quot; button</td>
<td>With this button, you clone the order loaded in the plugin.</td>
</tr>
<tr>
<td>&quot;Create work package automatically&quot; button</td>
<td>With this button, you create the associated work packages automatically.</td>
</tr>
<tr>
<td>&quot;Company&quot; field</td>
<td>This field displays the company selected in the unit structure when the plugin is opened.</td>
</tr>
<tr>
<td>&quot;Order&quot; field</td>
<td>This field displays the order object.</td>
</tr>
<tr>
<td>&quot;Add with&quot; list</td>
<td>In this list, you select how a new maintenance plan will be added to the order.</td>
</tr>
<tr>
<td>Field</td>
<td>In this field, the required identity or manufacturer number can be entered. Pressing the Enter key adds the required maintenance plan or a selection screen opens.</td>
</tr>
<tr>
<td>&quot;Package date&quot; field</td>
<td>This field displays the date of the work package to be created. Date format is YYYY.MM.DD.</td>
</tr>
<tr>
<td>Table</td>
<td>This table displays the result of the evaluation. The colored background of the &quot;Work package&quot; column depends on the status of the work package. The colors are set by the responsible administrator.</td>
</tr>
</tbody>
</table>
11.4.6 Tab of the "Manual maintenance preview" plugin

Overview

Menu bar

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Start search&quot; button</td>
<td>Via this button, you start the evaluation.</td>
</tr>
<tr>
<td>&quot;Extra&quot; button</td>
<td>With this button, you open a list containing options for editing the search result.</td>
</tr>
<tr>
<td>&quot;Edit attributes&quot; button</td>
<td>With this button, you enable the &quot;Attributes&quot; section. Attributes can be added with drag&amp;drop from the Navigator. Expression fields can be added. You delete the attribute with the &quot;X&quot; button. Calendar values can be entered not only as text but also via calendar selection &quot;....&quot;. The individual attributes are displayed as columns in the results area on completion of the search.</td>
</tr>
<tr>
<td>&quot;Insert expression field&quot; button</td>
<td>With this button, you insert expression fields in the &quot;Attributes&quot; section. In the &quot;&lt;&lt;Enter Expression&gt;&gt;&quot; field, you enter any COMOS script code that will be evaluated for each row. This makes it possible to access the object model of COMOS.</td>
</tr>
<tr>
<td>&quot;Reset&quot; button</td>
<td>With this button, you reset all filter settings.</td>
</tr>
<tr>
<td>&quot;Options&quot; button</td>
<td>With this button, you open the &quot;Options&quot; window. Here, you can make the search settings.</td>
</tr>
<tr>
<td>&quot;Search by label&quot; button</td>
<td>With this button, you select whether the filter option &quot;Label&quot; or &quot;Name&quot; is available.</td>
</tr>
<tr>
<td>&quot;Start node&quot; button</td>
<td>With this button, you enable or disable the dragging of multiple objects to the &quot;Start object&quot; field.</td>
</tr>
<tr>
<td>&quot;Export result&quot; button</td>
<td>This button opens the &quot;Export&quot; window.</td>
</tr>
<tr>
<td>&quot;View result in Excel&quot; button</td>
<td>Via this button, you can display the result in an Excel table instead of in a result list. The Excel table is then integrated in the COMOS user interface.</td>
</tr>
</tbody>
</table>
11.4 Plugins

Control element  | Description
--- | ---
"Result to Excel" button | Via this button, you open a list containing options for editing the Excel table.
"Load profile" button | Via this button, you open a stored search profile.
"Save profile" button | With this button, you store a search profile.
"***" list | You select a profile from this list.
"Multiline" button | This button expands cells accordingly if their content extends beyond one line.

### Application area

Control element  | Description
--- | ---
"Start object" field | This field displays the start object for the search.
"Class" list | Using this list, you restrict the search result to a specific object class.
"Label" field | Via this field, you restrict the search result to specific object labels.
"Name" field | Via this field, you restrict the search result to specific object names.
  The asterisk "***" is permitted as a wildcard. Example: If you enter "SV", all devices with a name starting with "SV" will be searched for.
"Description" field | Via this field, you restrict the search result to specific object descriptions.

### "Attributes" section

Control element  | Description
--- | ---
">=" list | You select the required comparison operator via this list.
"***" field | This field displays the next maintenance date.
"..." button | Click this button to open the "Select date" window.
"<=" list | You select the required comparison operator via this list.
Status "***" | This field displays the status of the maintenance.
11.4.7 "Membership options" window of the "Manual maintenance preview" plugin

![Membership options window]

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Selection&quot; column</td>
<td>This column displays whether or not the query will be used.</td>
</tr>
<tr>
<td>&quot;Label&quot; column</td>
<td>This column displays the label of the query.</td>
</tr>
<tr>
<td>&quot;Description&quot; column</td>
<td>This column displays the description of the query.</td>
</tr>
<tr>
<td>&quot;Search depth&quot; column</td>
<td>This column displays the search depth.</td>
</tr>
<tr>
<td></td>
<td>- 1= query is run through once and the result listed.</td>
</tr>
<tr>
<td></td>
<td>- 2= query is run through twice; the search results of the first search are also searched.</td>
</tr>
<tr>
<td></td>
<td>- 3= query is run through three times; the search results of the first and second searches are also searched.</td>
</tr>
<tr>
<td>&quot;Apply filter on result objects&quot; option</td>
<td>If this option is activated, the selected filters are taken into account for the search.</td>
</tr>
</tbody>
</table>

11.4.8 "COMOS Direct Workpackage" tab

**Menu bar**

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Button</td>
<td>Via this button, you set the focus on the node above the currently selected node.</td>
</tr>
<tr>
<td>Button</td>
<td>Via this button, you set the focus on the node underneath the currently selected node.</td>
</tr>
<tr>
<td>&quot;Navigate to COMOS object&quot; button</td>
<td>With this button, you navigate to the COMOS object in the Navigator on the &quot;Units&quot; tab of the currently selected node.</td>
</tr>
</tbody>
</table>
“Maintenance” control group

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Date&quot; field</td>
<td>This field displays the date on which the work package was performed.</td>
</tr>
<tr>
<td>&quot;planned&quot; field</td>
<td>This field display the planned date on which the work package will be performed.</td>
</tr>
<tr>
<td>&quot;Customer&quot; field</td>
<td>This field displays information regarding the customer.</td>
</tr>
<tr>
<td>&quot;Equipment&quot; field</td>
<td>This field displays the name and the description of the equipment.</td>
</tr>
<tr>
<td>&quot;Functional location&quot; field</td>
<td>This field displays the name and the description of the functional location.</td>
</tr>
<tr>
<td>&quot;Order&quot; field</td>
<td>This field displays information regarding the order.</td>
</tr>
<tr>
<td>&quot;Purchase no.&quot; field</td>
<td>This field displays the order number.</td>
</tr>
<tr>
<td>&quot;Date&quot; field</td>
<td>This field displays the date of the order.</td>
</tr>
</tbody>
</table>
"Detail" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Finished&quot; option</td>
<td>If this option is activated, the selected activity is marked as finished.</td>
</tr>
<tr>
<td>&quot;Not needed to be done&quot; option</td>
<td>If this option is activated, it indicates that the selected activity did not need to be done.</td>
</tr>
</tbody>
</table>

Other attributes can be shown on the "Detail" tab by the administrator.

"Remarks" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Activity&quot; field</td>
<td>This field displays the name of the selected activity.</td>
</tr>
<tr>
<td>&quot;Progress&quot; field</td>
<td>This field displays the progress of the activity.</td>
</tr>
<tr>
<td>&quot;Remarks&quot; field</td>
<td>This field displays remarks regarding the activity.</td>
</tr>
<tr>
<td>&quot;Internal Remarks&quot; field</td>
<td>This field displays internal remarks regarding the activity.</td>
</tr>
<tr>
<td>&quot;Description&quot; field</td>
<td>This field displays a description of the activity.</td>
</tr>
</tbody>
</table>

"Material" tab

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Material&quot; column</td>
<td>This column displays the description of the spare part.</td>
</tr>
<tr>
<td>&quot;Amount&quot; column</td>
<td>This column displays how many spare parts of this type are associated with the activity.</td>
</tr>
<tr>
<td>&quot;Price&quot; column</td>
<td>This column displays the price per spare part.</td>
</tr>
<tr>
<td>&quot;SAP – Nbr&quot; column</td>
<td>This column displays the SAP number.</td>
</tr>
</tbody>
</table>

Qualification – Hours table

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Qualification&quot; column</td>
<td>This column displays the qualification assigned to the activity.</td>
</tr>
<tr>
<td>&quot;Hours&quot; column</td>
<td>This column displays the hours assigned to the qualification.</td>
</tr>
</tbody>
</table>

11.4.9 Tab of the "Maintenance demon" plugin

The "Maintenance demon" plugin tab consists of a menu bar and a results table.

You can send emails or create work packages automatically with the help of the enterprise server. Contact the responsible administrator.
## 11.4 Plugins

### Control element | Description
--- | ---
"Scan maintenance plans" button | Via this button, you start the scan process for maintenance plans.

"Next scan" button | If you want to search a large amount of data, the results are split up into different sets; you use this button to jump to the next set of results.

"Send notifications" button | Via this button, you send a message to the persons responsible for a selected maintenance plan or for all maintenance plans. If a message has been sent, this is documented in the properties of the maintenance plan on the subordinate level tab "History".

"Create work package" button | With this button, you create the work packages for a selected maintenance plan or for all maintenance plans.

"Calculate maintenance plan status" button | With this button, you calculate the current status of the selected maintenance plan or all maintenance plans.

"Force resend during scan-time" button | With this button, you select whether or not messages that have already been sent are displayed as able to be sent when the scan starts.

"Start object(s)" field | This field displays the root node that is to be searched for root nodes.

"Name" column | This column displays the name of the maintenance plan.

"Due" column | This column displays the next maintenance date of the maintenance plan.

"Action" column | This column displays the due date of the maintenance minus the forewarn time. If you have not defined a forewarn time, the due date and the action date are identical.

"Create package" column | This column displays whether the "Create packages automatically" option on the "Maintenance plan" tab of the maintenance plan properties has been activated ("True") or not ("False").

"Recipient" column | This column displays the email address of the recipient.

"State/Create" column | This column displays whether or not work packages can be created.

"State/Send" column | This column displays whether or not notifications can be sent.

### Color legend

| Color | Description |
--- | ---|
green | Action can be taken |
blue | No action necessary |
red | Incorrect entry, bad setting |
11.4.10 "Additional data" tab

The "Additional data" tab displays the additional data of the event.

The control elements displayed here are only an example and can be adapted by the responsible administrator so that you can acquire the required information from the tab.

11.4.11 "Event" tab

The "Event" tab at the subordinate level displays information regarding the event.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Date&quot; field</td>
<td>This field displays the date on which the event was created.</td>
</tr>
<tr>
<td>&quot;Time&quot; field</td>
<td>This field displays the time at which the event was created.</td>
</tr>
<tr>
<td>&quot;User&quot; field</td>
<td>This field displays the user who created the event.</td>
</tr>
<tr>
<td>&quot;Recipient&quot; field</td>
<td>This field displays to whom the event is visible.</td>
</tr>
<tr>
<td>&quot;Status&quot; list</td>
<td>You select the status of the event from this list.</td>
</tr>
<tr>
<td></td>
<td>As default, newly created events have the status &quot;N/A&quot; if they do not adopt the status from the base object.</td>
</tr>
<tr>
<td>&quot;Mandatory workflow&quot; option</td>
<td>If this option is activated for the base object in the base project, the workflow defined for the event must be adhered to.</td>
</tr>
<tr>
<td>&quot;Status from base object&quot; option</td>
<td>If this option is activated for the base object in the base project, the event adopts the predefined status from the base object.</td>
</tr>
<tr>
<td>&quot;Can be cancelled&quot; option</td>
<td>If this option is activated for the base object in the base project, the event can be canceled.</td>
</tr>
<tr>
<td>&quot;Notify automatically&quot; option</td>
<td>If this option is activated, an email is sent automatically to the responsible person when the event is created. The event searches upwards through the plant structure until an object with the predefined responsible person is found.</td>
</tr>
<tr>
<td>&quot;Request confirmation&quot; option</td>
<td>If this option is activated, a confirmation is requested.</td>
</tr>
<tr>
<td>&quot;Canceled&quot; option</td>
<td>The activated option means that the event has been deleted from the &quot;Event manager&quot; plugin.</td>
</tr>
<tr>
<td>&quot;Shift&quot; field</td>
<td>This field displays the linked shift.</td>
</tr>
<tr>
<td>&quot;Shift book&quot; field</td>
<td>This field displays the name and the description of the event as it will appear in the shift book.</td>
</tr>
</tbody>
</table>
11.4.12 "Work request - details" tab

You make settings relating to the delegation of actions on the "Job requirement" tab of the event object.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Object type&quot; list</td>
<td>This list shows the system object type of the maintenance plan being searched for or being used for delegation.</td>
</tr>
<tr>
<td>&quot;Package type&quot; field</td>
<td>This field displays the base object of the work package that will be created. If no work package is defined here, the work package is created according to the maintenance plan configuration.</td>
</tr>
<tr>
<td>&quot;Created activity&quot; field</td>
<td>This field contains a reference to the work package that was generated when delegating the action from the event.</td>
</tr>
<tr>
<td>&quot;According to maintenance plan&quot; field</td>
<td>This field displays the shutdown maintenance plan underneath which the work package is created by the &quot;Delegation&quot; action. The entry in this field is made when the &quot;Prepare for Delegation&quot; action executes.</td>
</tr>
<tr>
<td>&quot;Shutdown&quot; field</td>
<td>This field displays the shutdown object to which the event was assigned. The entry in this field is made automatically if the event was assigned to a shutdown object.</td>
</tr>
</tbody>
</table>

11.4.13 Menu bar of the "Event manager" plugin

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Scan&quot; button</td>
<td>Via this button, you can rescan the database for new events. After rescanning, new events are no longer displayed as new events by highlighting them color.</td>
</tr>
<tr>
<td>&quot;Properties&quot; button</td>
<td>With this button, you open the properties of the event in a window.</td>
</tr>
<tr>
<td>&quot;Change status&quot; button</td>
<td>With this button, you open a list of all available statuses for the currently selected event. If you change the status of an event, an event history object is created automatically underneath the event object. A separate row is created for each history object in the history table of the plugin.</td>
</tr>
<tr>
<td>Control element</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>&quot;New remark...&quot; button</td>
<td>Via this button, you open a comments window. The text you enter here is displayed in the event history.</td>
</tr>
<tr>
<td>&quot;Cancel event&quot; button</td>
<td>With this button, you cancel the selected event if the function has been activated in the properties of the base object in the base project. Canceled events are no longer displayed in the plugin.</td>
</tr>
<tr>
<td>&quot;Display history&quot; button</td>
<td>Via this button, you open the history of the selected event. The history displays the previous status changes and remarks on the event in the form of a table. Via the context menu, you can edit remarks, create new remarks and delete entries from the history. Before you can delete an entry from the history, the &quot;Can be cancelled&quot; option must be activated on the &quot;Event history&quot; tab of the event history object. The setting is conducted in the base project.</td>
</tr>
<tr>
<td>&quot;Autofilter&quot; button</td>
<td>Via this button, you customize individual columns in the table. You can filter every column. If you select the value &quot;(all)&quot;, you reset the filter settings. With the value &quot;(user-defined)&quot;, you define your own filter. If you click this button again, the filter is deactivated.</td>
</tr>
<tr>
<td>&quot;Edit columns...&quot; button</td>
<td>This button opens the &quot;Edit columns...&quot; window. Here, you define which columns will be displayed in the table.</td>
</tr>
<tr>
<td>&quot;Export&quot; button</td>
<td>Via this function, you export the table displayed in the &quot;Event manager&quot; plugin to a new MS Excel worksheet. You can also write the data to an Excel template or an XML file.</td>
</tr>
<tr>
<td>&quot;Multiline&quot; button</td>
<td>This button expands cells accordingly if their content extends beyond one line.</td>
</tr>
<tr>
<td>Button</td>
<td>With this button, you open the &quot;Profiles&quot; window. See also chapter Profiles (Page 14).</td>
</tr>
<tr>
<td>Button</td>
<td>With this button, you save the profile settings.</td>
</tr>
<tr>
<td>List</td>
<td>This field displays the name of the profile.</td>
</tr>
<tr>
<td>&quot;Start object&quot; field</td>
<td>Drag&amp;drop the folder of the parallel structure you want to search through for events to this field. If you have selected collector mode, the search starts automatically with the &quot;(all)&quot; setting. In collector mode, the start node is the start node underneath which the events are stored. In collector mode, the events are filtered according to the start node.</td>
</tr>
</tbody>
</table>

**Additional information**

- You can find additional information on exporting a table of shutdown management in the "Shutdown" manual, keyword "Exporting the shutdown management table".
11.4.14  "Easy event" plugin

Overview

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Use current time as start time&quot; on/off button</td>
<td>Clicking the button means that the current date and current time are entered in the Date field automatically. If the event is only valid at a later point in time and therefore displayed later in the &quot;Event manager&quot; plugin, deactivate this button. You can then set the date manually.</td>
</tr>
<tr>
<td>&quot;Show object search&quot; on/off button</td>
<td>If this button is activated, the fields relevant for the object search are displayed.</td>
</tr>
<tr>
<td>&quot;Search at once&quot; on/off button</td>
<td>If this button is activated, the search is started immediately if a start object has been selected or if something has been entered in the filter for the object search (equipment or functional location).</td>
</tr>
<tr>
<td>&quot;Reset&quot; on/off button</td>
<td>With this button, you can reset all settings of the base data.</td>
</tr>
<tr>
<td>&quot;Object&quot; field</td>
<td>This field displays the object for which an event will be created.</td>
</tr>
<tr>
<td>&quot;Recipient&quot; field</td>
<td>This field displays a person or superior hierarchy level for which the event will be displayed in the &quot;Event manager&quot; plugin.</td>
</tr>
<tr>
<td>Person button</td>
<td>Via this button, you open the &quot;Select company/department/person&quot; window.</td>
</tr>
<tr>
<td>&quot;Kind&quot; list</td>
<td>In this list, you select the kind of event.</td>
</tr>
<tr>
<td>&quot;Status&quot; list</td>
<td>You select the status of the event from this list.</td>
</tr>
<tr>
<td>Object search field</td>
<td>This field displays the start object for the object search.</td>
</tr>
<tr>
<td>Field</td>
<td>This field displays a filter for the object search.</td>
</tr>
<tr>
<td>Table</td>
<td>This table displays the result of the object search.</td>
</tr>
</tbody>
</table>
11.4.15 "Scheduling" tab

The "Scheduling" tab displays the start and end date of the shutdown.

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Start date&quot; field</td>
<td>This field displays the start date of the shutdown.</td>
</tr>
<tr>
<td>&quot;Set current date&quot; button</td>
<td>Via this button, you enter the current date in the field.</td>
</tr>
<tr>
<td>&quot;Select date&quot; button</td>
<td>Via this button, you select a date from the calendar.</td>
</tr>
<tr>
<td>&quot;End date&quot; field</td>
<td>This field displays the end date of the shutdown.</td>
</tr>
</tbody>
</table>

11.4.16 "Report" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Show event history with user and timestamp&quot; option</td>
<td>If this option is activated, the user who created the event and the time of the event are both displayed on the shift report along with the event history.</td>
</tr>
<tr>
<td>&quot;Extended event grouping&quot; option</td>
<td>If this option is activated, events are grouped on the shift report according to type and unit part. If you want to use this function, attach the &quot;Grouping&quot; tab to the relevant object.</td>
</tr>
<tr>
<td>&quot;Display absences&quot; option</td>
<td>If this option is activated, attendances and absences are displayed on the shift report.</td>
</tr>
<tr>
<td>&quot;Compact attendances/absences&quot; option</td>
<td>If this option is activated, all absences are listed in sequence in one row on the shift report. If you deactivate this option, each absence is displayed in a separate row.</td>
</tr>
<tr>
<td>&quot;Show absence reasons within days&quot; option</td>
<td>If this option is activated, the reason for the absence is displayed on the shift report.</td>
</tr>
<tr>
<td>&quot;Show absences within days&quot; option</td>
<td>If this option is activated, actual attendances are displayed on the shift report, along with their corresponding times.</td>
</tr>
<tr>
<td>&quot;Shift leader&quot; description field</td>
<td>This field displays the text that appears in the signature field of the shift report. Here, enter the role of the person who is to sign the shift report.</td>
</tr>
<tr>
<td>&quot;Production leader&quot; description field</td>
<td>This parameter displays the text that appears in the signature field of the shift report. Here, enter the role of the person who is to sign the shift report.</td>
</tr>
</tbody>
</table>
**11.4 Plugins**

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Shift data&quot; list</td>
<td>With this list, you can add data that will be displayed for the shift object. Enter the name of the tab whose data you want to display in the &quot;Tab&quot; column. Enter the name of the subreport with which the data will be displayed in the &quot;Report&quot; column.</td>
</tr>
<tr>
<td>&quot;Events&quot; list</td>
<td>From this list, you choose which attributes of an event object will be displayed on the shift report. In the &quot;Filter&quot; column, enter the nested name of the attribute to be displayed. In the &quot;Specification&quot; column, enter the name of the attribute to be displayed. Enter the value &quot;1&quot; in the &quot;Initial&quot; column so that the attributes of the events are only displayed on the report of the shift during which the events were created. This means, for example, that you can display the header data of the event only on the first shift report after the event was created.</td>
</tr>
</tbody>
</table>

**11.4.17 "Workflow" tab**

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Last worked shift&quot; field</td>
<td>This field displays the shift that was most recently completed. The entry is made automatically.</td>
</tr>
<tr>
<td>&quot;Enable automatic start/stop&quot; option</td>
<td>If this option is activated, the shifts are started and stopped automatically if you use the shift service for the enterprise server. You can find additional information on this topic in the &quot;Enterprise Server&quot; manual.</td>
</tr>
<tr>
<td>&quot;Enable event lock&quot; option</td>
<td>If this option is activated, associated events are locked automatically at the end of a shift if you use the shift service for the enterprise server.</td>
</tr>
<tr>
<td>&quot;Enable report handling&quot; option</td>
<td>If this option is activated, reports are created automatically at the start and end of the shift if you use the shift service for the enterprise server. You can define further behavior via the &quot;Shift reports&quot; list.</td>
</tr>
<tr>
<td>&quot;Disable warning on person delete&quot; option</td>
<td>If this option is activated, no window opens when a person is deleted from a current shift.</td>
</tr>
<tr>
<td>&quot;Disable manual start/stop&quot; option</td>
<td>If this option is activated, you cannot start and stop shifts manually; automatic shift changeover is used instead.</td>
</tr>
<tr>
<td>&quot;Automatic coarse plan creation lead-time&quot; option</td>
<td>This field displays how many months before the end of the year the basic planning for the next year is created. Enter the number of months in this field.</td>
</tr>
</tbody>
</table>
### Control element

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Automatic coarse plan creation cycle&quot; option</td>
<td>This field displays the period in days of the old year that will be adopted for the basic planning of the new year. Enter the number of days in this field.</td>
</tr>
<tr>
<td>&quot;Lag time&quot; field</td>
<td>This field displays a time in minutes that describes the lag time with which the shift is ended. This parameter also configures the time from which you can end a shift manually.</td>
</tr>
<tr>
<td>&quot;Lead time&quot; field</td>
<td>This field displays a time in minutes that describes the lead time with which the shift is started. This parameter also configures the time from which you can start a shift manually.</td>
</tr>
</tbody>
</table>
| "Shift reports" list | This list defines how the shift reports are configured and how a shift report is converted to a PDF file. In the "Mode" column, specify whether the shift report will be created at the start of the shift (value "2") or at the end of the shift (value "3"). Enter the name of the report located underneath the shift in the "Report" column. In the "Save - template" column, enter the name of the template that is to be used as the model for the shift report. You can use the following variables for the template:  
  - @WEEK - calendar week, e.g. "52"  
  - @DAY - day, e.g. "27"  
  - @YEAR - year, e.g. "2007"  
  - @MONTHNAME - month name, e.g. "May"  
  - @MONTHKZ - month name, e.g. "Sept."  
  - @MONTH - month, e.g. "03"  
  - @SHIFTTEMPLATE - name of the shift template  
  - @SHIFTTEAM - name of the shift team  
  - @SHIFTUID - system UID of the shift  
  - @SHIFT - name of the shift  
  - @REPORT - name of the report |
| "Automatic locking exceptions" list | If the "Enable event lock" option is activated, you can define attributes of event or shift objects in this list that will not be locked by the automatic shift service. If the shift changeover is performed by manually starting/stoping a shift, only the attributes of the shift are locked. Attributes of the events are not locked. In the "Code" column, enter whether an event object ("EVENT") or a shift object ("SHIFT") is involved. Enter the nested name of the required attribute in the "Path" column. You can use "*" and "?" for this purpose. |
11.4.18 Menu bar of the "Resource management" plugin

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Work packages&quot; button</td>
<td>You enable and disable the filter for work packages with this button.</td>
</tr>
<tr>
<td>&quot;Assignment&quot; button</td>
<td>You enable and disable the filter for assignments with this button.</td>
</tr>
<tr>
<td>&quot;Absences&quot; button</td>
<td>You enable and disable the filter for absences with this button.</td>
</tr>
<tr>
<td>&quot;Resource monitor&quot; button</td>
<td>With this button, you open the &quot;Resource monitor&quot; plugin.</td>
</tr>
<tr>
<td>&quot;Zoom in&quot; button</td>
<td>With this button, you reduce the display area in the calendar so that the individual entries are displayed larger.</td>
</tr>
<tr>
<td>&quot;Zoom out&quot; button</td>
<td>With this button, you increase the display area in the calendar so that the individual entries are displayed smaller.</td>
</tr>
<tr>
<td>&quot;Options&quot; button</td>
<td>With this button, you open the &quot;Options&quot; window.</td>
</tr>
<tr>
<td>&quot;Time range&quot; button</td>
<td>With this button, you open the &quot;Display range&quot; window. Here, you make the settings for the calendar display.</td>
</tr>
<tr>
<td>&quot;Dependency type for new dependencies&quot; button</td>
<td>With this button, you set what dependency type will apply when new dependencies are created.</td>
</tr>
<tr>
<td>&quot;Export&quot; button</td>
<td>With this button, you open the &quot;Export&quot; window. Here, you can export the data to MS Project.</td>
</tr>
<tr>
<td>&quot;Import&quot; button</td>
<td>With this button, you open the &quot;Import&quot; window. Here, you can reimport the data that was exported to MS Project and edited there back into COMOS.</td>
</tr>
<tr>
<td>&quot;Start object&quot; list</td>
<td>You select the start object from this list. If there is not yet a start object in the list, drag&amp;drop the required start object to the field.</td>
</tr>
</tbody>
</table>

11.4.19 "Shift planning" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Prod. node&quot; field</td>
<td>This field displays the production node of your unit, which is the start node when searching for events. This node is searched for events, for example, for the shift report.</td>
</tr>
<tr>
<td>&quot;Company DB node&quot; field</td>
<td>This field displays the start node starting at which the shift teams and shift members are evaluated.</td>
</tr>
<tr>
<td>&quot;Shift base object&quot; field</td>
<td>This field displays the link to a base object with which new shifts are created. With this field, different shift objects that can store different data, for example, can be defined for different companies in a project or in a database.</td>
</tr>
</tbody>
</table>
Control element | Description
--- | ---
"Calculation mode" list | Via this list, you select the calculation mode for the current shift. The value "According to date/time" means that the current shift is set when the date changes or when a predefined time is reached. The value "New state" means that the current shift is set when there is a change of state for a shift.
"Current shift" field | This field displays the currently started shift. The entry is made automatically.
"Cache" field | This field is reserved for internal system purposes.
"Cache validity" field | This field is reserved for internal system purposes.

11.4.20 Menu bar of the "Shift management" plugin

Control element | Description
--- | ---
"Basic planning" button | This button opens the "Basic planning" view.
"Detail planning" button | This button opens the "Detail planning" view.
"Historical data" button | Via this button, you search for shift reports.
"Resource monitor" button | This button opens the "Resource monitor" plugin.
"Scroll left" button | Via this button, you scroll to the display area of earlier data.
"Scroll right" button | With this button, you scroll to the display area of later data.
"Shift change" button | Via this button, you end the current shift and start the next one.
"Show status" button | You hide or show the status of the shift with this button.
"Show resources" button | You hide or show the resources with this button.
"Show qualification" button | You hide or show the qualifications with this button.
"Show roles" button | You hide or show the roles with this button.
"Time range" button | This button opens the "Detail planning: display range" window. Here, you make the settings for scrolling behavior.
"Start object(s)" list | You drag&drop the required shift planning object to this field. If the shift planning object is already selected on the "Units" tab in the Navigator when the plugin is opened, this is automatically entered as the start object.
11.4 Plugins

11.4.21 "Configuration of trigger" tab

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Shift state trigger&quot; list</td>
<td>If the superior shift reaches the state specified here, the evaluation object is created.</td>
</tr>
<tr>
<td>&quot;Time criteria trigger&quot; list</td>
<td>Define the validity of the evaluation object here. Possible time criteria are:</td>
</tr>
<tr>
<td></td>
<td>• &quot;Daily&quot;</td>
</tr>
<tr>
<td></td>
<td>• &quot;First day of month&quot;</td>
</tr>
<tr>
<td></td>
<td>• &quot;Last day of month&quot;</td>
</tr>
<tr>
<td></td>
<td>• &quot;Defined date (MM.DD)&quot;</td>
</tr>
<tr>
<td></td>
<td>• &quot;Defined weekday&quot;</td>
</tr>
<tr>
<td>&quot;Weekday&quot; list</td>
<td>If you have selected &quot;Defined weekday&quot; from the &quot;Time criteria trigger&quot; list, select the required weekday here.</td>
</tr>
<tr>
<td>&quot;MM.DD&quot; field</td>
<td>If you have selected &quot;Defined weekday&quot; from the &quot;Time criteria trigger&quot; list, select the required date here.</td>
</tr>
<tr>
<td>&quot;Data query&quot; field</td>
<td>This field displays the stored query. The query is used to define raw data.</td>
</tr>
<tr>
<td>&quot;Use system user&quot; option</td>
<td>If this option is activated, the @Setup system user is used for the evaluation, not the current user.</td>
</tr>
<tr>
<td>&quot;Date&quot; field</td>
<td>The date of the evaluation is saved here.</td>
</tr>
<tr>
<td>&quot;Time&quot; field</td>
<td>The time of the evaluation is saved here.</td>
</tr>
<tr>
<td>&quot;User&quot; field</td>
<td>The name of the user who triggered the evaluation is saved here.</td>
</tr>
<tr>
<td>&quot;Status&quot; list</td>
<td>The overall status of the evaluation object is displayed here.</td>
</tr>
<tr>
<td></td>
<td>• &quot;Green (OK)&quot; : All status attributes have the status Green.</td>
</tr>
<tr>
<td></td>
<td>• &quot;Amber (warning)&quot; : At least one status attribute has the status Amber. No status attributes have the status Red.</td>
</tr>
<tr>
<td></td>
<td>• &quot;Red (critical)&quot; : At least one status attribute has the status Red.</td>
</tr>
</tbody>
</table>

11.4.22 "Statistics and evaluation" tab

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value 1-5</td>
<td>This column displays statistical values, which you can determine via a script, for example.</td>
</tr>
<tr>
<td>&quot;Limit green&quot;</td>
<td>This column defines the lower and the upper limit of the &quot;green&quot; status.</td>
</tr>
</tbody>
</table>
### 11.4 Plugins

#### Column Description

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Limit amber&quot;</td>
<td>This column defines the lower and the upper limit of the &quot;yellow&quot; status.</td>
</tr>
<tr>
<td>&quot;Function&quot;</td>
<td>Defines the evaluation method used. The following methods are available:</td>
</tr>
<tr>
<td></td>
<td>- &quot;AVG Arithmetic average&quot;</td>
</tr>
<tr>
<td></td>
<td>- &quot;CNT Count&quot;</td>
</tr>
<tr>
<td></td>
<td>- &quot;GEOM geometric mean&quot;</td>
</tr>
<tr>
<td></td>
<td>- &quot;MAX maximum&quot;</td>
</tr>
<tr>
<td></td>
<td>- &quot;MED median&quot;</td>
</tr>
<tr>
<td></td>
<td>- &quot;MIN minimum&quot;</td>
</tr>
<tr>
<td></td>
<td>- &quot;SUM sum&quot;</td>
</tr>
<tr>
<td></td>
<td>- &quot;USR user defined (GetDisplayValue)&quot;</td>
</tr>
<tr>
<td>&quot;Status&quot;</td>
<td>Evaluates the status of the evaluation object. The following statuses are possible:</td>
</tr>
<tr>
<td></td>
<td>- &quot;Green (OK)&quot;</td>
</tr>
<tr>
<td></td>
<td>- &quot;Amber (warning)&quot;</td>
</tr>
<tr>
<td></td>
<td>- &quot;Red (critical)&quot;</td>
</tr>
</tbody>
</table>

This tab is read out row by row and the values are checked in.

### 11.4.23 "Goods receipt" tab

#### Overview

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Add lines&quot; button</td>
<td>Via this button, you open the &quot;Add lines&quot; application area.</td>
</tr>
<tr>
<td>&quot;Receipt&quot; field</td>
<td>This field displays the link to the goods receipt object.</td>
</tr>
<tr>
<td>&quot;Date&quot; field</td>
<td>As default, this field displays the system date.</td>
</tr>
<tr>
<td>&quot;Number&quot; field</td>
<td>This field displays the ID number of the goods receipt object.</td>
</tr>
</tbody>
</table>
11.4.24 "Resource monitor" plugin

Overview

The Resource monitor compares required and available resources.

Menu bar

<table>
<thead>
<tr>
<th>Control element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Evaluate&quot; button</td>
<td>Via this button, you start the evaluation.</td>
</tr>
<tr>
<td>&quot;Options&quot; button</td>
<td>This button opens the &quot;Options&quot; window.</td>
</tr>
<tr>
<td>&quot;Autofilter&quot; button</td>
<td>Via this button, you enable and disable the auto filter function.</td>
</tr>
<tr>
<td>&quot;Export&quot; button</td>
<td>This button opens the &quot;Export&quot; window.</td>
</tr>
<tr>
<td>&quot;Result to Excel&quot; button</td>
<td>Via this button, you display the result in an Excel table instead of in a result list. The Excel table is then integrated in the COMOS user interface.</td>
</tr>
<tr>
<td>&quot;Result to Excel&quot; button</td>
<td>Via this button, you open a list containing options for editing the Excel table.</td>
</tr>
</tbody>
</table>

Button via this button, you open a stored search profile. See also chapter Profiles (Page 14).

Button With this button, you store a search profile.
You choose between conventional work packages and all work packages, including virtual work packages, in the "Required resources" control group. You select the personnel of the relevant company in the "Available resources" control group. The company reference or the corresponding company in the company database is stored in the start node.

### Control element Description

<table>
<thead>
<tr>
<th><strong>Control element</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;**** list&quot;</td>
<td>You select a profile from this list.</td>
</tr>
<tr>
<td>&quot;Data sources&quot; list</td>
<td>If you have opened the &quot;Resource management&quot; plugin, you establish a connection between the &quot;Resource management&quot; plugin and the &quot;Resource monitor&quot; plugin here. To do this, select the &quot;Resource management&quot; entry. All changes in the &quot;Resource management&quot; plugin are immediately applied in the &quot;Resource monitor&quot; plugin without the changes having to be saved.</td>
</tr>
</tbody>
</table>

You choose between conventional work packages and all work packages, including virtual work packages, in the "Required resources" control group. You select the personnel of the relevant company in the "Available resources" control group. The company reference or the corresponding company in the company database is stored in the start node.

### Control element Description

<table>
<thead>
<tr>
<th><strong>Control element</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;Start object&quot; field</td>
<td>This field displays the relevant start object.</td>
</tr>
<tr>
<td>&quot;Mode&quot; list</td>
<td>In this list, you select the objects to be displayed. To display no objects, select &quot;Deactivated&quot; mode.</td>
</tr>
<tr>
<td>&quot;Grouping&quot; list</td>
<td>In this list, you select a level whose objects will be displayed.</td>
</tr>
<tr>
<td>&quot;Display&quot; list</td>
<td>In this list, you select an object type as an additional criterion.</td>
</tr>
<tr>
<td>&quot;Start&quot; field</td>
<td>This field displays the start date of the evaluation.</td>
</tr>
<tr>
<td>&quot;End&quot; box</td>
<td>This field displays the end date of the evaluation.</td>
</tr>
<tr>
<td>&quot;Time range&quot; list</td>
<td>In this list, you select how the time range is to be structured.</td>
</tr>
<tr>
<td>&quot;Display&quot; list</td>
<td>You select a display type from this list. This is where you distinguish between a duration in hours and manpower.</td>
</tr>
<tr>
<td>&quot;Format&quot; list</td>
<td>You select a format from this list. Default display type or optimized for export.</td>
</tr>
</tbody>
</table>

### Display of the time ranges

The displayed time ranges contain a complete range, in other words from 01/01/2009 – 12/31/2009 for a year, even if the start and end date specify a shorter period.