Continuous Function Chart
Getting Started

Preface
Creating a closed loop with a simulated process
Testing the program
Performing changes at or in the chart
Chart I/Os and nested chart
Creating and testing a block
Summary
Legal information

Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are graded according to the degree of danger.

<table>
<thead>
<tr>
<th>Degree of Danger</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>DANGER</strong></td>
<td>indicates that death or severe personal injury will result if proper precautions are not taken.</td>
</tr>
<tr>
<td><strong>WARNING</strong></td>
<td>indicates that death or severe personal injury may result if proper precautions are not taken.</td>
</tr>
<tr>
<td><strong>CAUTION</strong></td>
<td>indicates that minor personal injury can result if proper precautions are not taken.</td>
</tr>
<tr>
<td><strong>NOTICE</strong></td>
<td>indicates that property damage can result if proper precautions are not taken.</td>
</tr>
</tbody>
</table>

If more than one degree of danger is present, the warning notice representing the highest degree of danger will be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property damage.

Qualified Personnel

The product/system described in this documentation may be operated only by personnel qualified for the specific task in accordance with the relevant documentation, in particular its warning notices and safety instructions. Qualified personnel are those who, based on their training and experience, are capable of identifying risks and avoiding potential hazards when working with these products/systems.

Proper use of Siemens products

Note the following:

<table>
<thead>
<tr>
<th>Degree of Danger</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WARNING</strong></td>
<td>Siemens products may only be used for the applications described in the catalog and in the relevant technical documentation. If products and components from other manufacturers are used, these must be recommended or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and maintenance are required to ensure that the products operate safely and without any problems. The permissible ambient conditions must be complied with. The information in the relevant documentation must be observed.</td>
</tr>
</tbody>
</table>

Trademarks

All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability

We have reviewed the contents of this publication to ensure consistency with the hardware and software described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the information in this publication is reviewed regularly and any necessary corrections are included in subsequent editions.
# Table of contents

1. Preface .......................................................................................................................... 5
2. Creating a closed loop with a simulated process .............................................................. 7
   2.1 How to create a project .............................................................................................. 7
   2.2 How to create a chart .............................................................................................. 8
   2.3 How to compile and download a chart ..................................................................... 12
3. Testing the program ........................................................................................................... 13
   3.1 How to test the program ......................................................................................... 13
   3.2 The current status of your project .......................................................................... 15
4. Performing changes at or in the chart ............................................................................. 17
   4.1 How to change the runtime properties .................................................................... 17
   4.2 The current status of your project .......................................................................... 21
5. Chart I/Os and nested chart ............................................................................................. 23
   5.1 How to create a chart with chart I/Os ..................................................................... 23
   5.2 How to insert a chart in another chart .................................................................... 27
   5.3 The current status of your project .......................................................................... 28
6. Creating and testing a block ........................................................................................... 29
   6.1 How to create a block type ..................................................................................... 29
   6.2 How to test a block ................................................................................................. 30
7. Summary .......................................................................................................................... 31
Preface

Introduction

The "Getting Started" documentation provides quick instructions for first-time users to acquaint them with the CFC program package. An tutorial is divided into several tasks and guides you step-by-step from the simplest configuration work to the creation of a chart with chart I/Os and the generation of the block in the CFC.

Note

You can find a completed example in the SIMATIC Manager with the menu command File > Open... in the "Example Projects" tab under the file name ZDt04_01_CFC (German).
(English: ZEn..., French: ZFr..., Spanish: ZEs..., Italian: ZIt...)

This example assumes that the CFC is used in the STEP 7 environment. The STEP 7 basis package, SCL and CFC must be installed. The target system is S7-300 or S7-400.

You create the "CFCBSP_2" example project described in the following with the SIMATIC Manager.
Creating a closed loop with a simulated process

2

2.1 How to create a project

Introduction

The following describes the tasks for creating a project with the menu commands of the SIMATIC Manager. You configure the hardware with HW Config. This can also be performed at a later point in time but before downloading to the CPU. We limit ourselves to the S7 program in this example.

Procedure

1. Click the icon in the toolbar

or select the File > New... menu command.

2. Enter the project name "CFCBSP_2" in the "New Project" dialog box and click "OK".

3. Select the project folder and select the menu command Insert > Program > S7 Program.
   The S7 program is created in the "Component view" with the source folder, block folder and symbol table.

4. Select the S7 program folder and select the menu command Insert > S7 Software > Chart Folder.
   The chart folder is created.

5. Select the chart folder and select the menu command Insert > S7 Software > CFC.
   A "CFC(1)" chart is created.
   Enter "Controlling" as the chart name.

6. Double-click on the CFC chart.
   The chart opens.

Result

All the requirements for working with the CFC editor are fulfilled.
2.2 How to create a chart

Introduction

You create a closed loop with process simulation in which the process is to be simulated by a floating mean value. Use the following blocks for this:

- **SAMP_AVE**
  This block forms the mean value from a number of input values.

- **CONT_C**
  This block is a PID controller which controls this floating mean value.

A mean value is formed here from the most recent 30 values of the "Controller1" output LMN and sent to the "Controller1" input PV_IN by the "Process1" output OUT.

LMN sends the manipulated variable to the "Process1" input IN.

Inserting blocks

Create the block as follows:

1. Click the following icon

   ![Catalog icon](image)

   The catalog opens.
   The default setting is that the catalog is already open.

2. Click the icon for the libraries tab in the catalog:

   ![Libraries icon](image)

   Open the **CFC Library**. This is a collection of block libraries.
Creating a closed loop with a simulated process

2.2 How to create a chart

3. For S7-300 CPUs:
   Open the **ELEM_300** folder.
For S7-400 CPUs:
   Open the **ELEM_400** folder.

4. Drag the **CONT_C** block from the list and drop it to the top right of Sheet 1 in the chart.

5. Drag the **SAMP_AVE** block from the list and drop it to the left of the **CONT_C** block in the chart.

6. Click the icon in the toolbar
   or double-click on a free area close to the two blocks.
   This opens the sheet view.
   In the sheet view, you see the blocks as graphic objects with a head and multiple I/Os on the body. The I/Os (inputs left, outputs right) are shown as fields with the I/O name and with the data type in the "wide" view.
   With the menu command **Options > Settings > Block/Sheet Bar Width**, you can set the block width to "Narrow" or "Wide" in the dialog box. The "Narrow" default setting shows the blocks more narrow and without specifying the data type.

**Interconnecting blocks**

Interconnect the blocks as follows:

1. Click on the **OUT** output on the **SAMP_AVE** block and then click on the **PV_IN** input on the **CONT_C** block.
2. Click on the **LMN** output on the **CONT_C** block and then click on the **IN** input on the **SAMP_AVE** block.
   Alternatively, you can drag a block output to the input to be interconnected using drag-and-drop.

The two blocks are now interconnected.

**Making blocks more legible**

The blocks are displayed in the chart with all I/Os (inputs and outputs), as specified by the block type. We will not need all I/Os in our example. We therefore show the unrequited I/Os in the chart as invisible, as described below. This improves the legibility of your chart. You can also change the block name in this dialog box.

1. Double-click on the block header of the **CONT_C** block.
   The "Properties" dialog box for this block opens.
   The name ("1") is already selected.
   Enter "Controller1" as the new name.
2. Select the "Connections" tab.
3. Use the horizontal scroll bar to move the window to the left until the "Invisible" column appears on the right.

4. Click on the first selection field, hold down the mouse button and drag the mouse pointer vertically to the end of the column. The column is selected.

Open the shortcut menu in the selected area and select the menu command Set. All unconnected I/Os are made invisible. Some I/Os, however, will later be needed in test mode for entering values. You can make them visible again by doing the following:

5. Click on each marking cross in the "Invisible" column for:
   - MAN_ON
   - SP_INT
   - MAN
   - GAIN
   - TN
   - TV
   - DEADB_W

### Configuring I/Os and selecting them for testing

1. In the "Watch" column of the "I/Os" tab, set all visible I/Os including the interconnected LMN output.

2. Enter "20" as the setpoint for the controller in the "Value" column for SP_INT. Click "OK". The object properties close.

You can directly configure a single I/O as follows:

1. Double-click on the MAN_ON block input of the controller.

2. Under "Value:", change "1" to "0". This switches "Manual" mode off, which interrupts the control loop.

3. Click "OK". The dialog box closes.

Do the following also with the SAMP_AVE block using the properties dialog of the individual I/O or using the properties dialog of the block:

1. Double-click on the SAMP_AVE block header. Enter "Process1" as the block name.

2. Set the N input in the "Watch" column of the "I/Os" tab. You can skip this step if the input is already set.
3. Enter the value "30" for \( N \) in the "Value" column. This is the number of the input values to be watched for which a mean value is to be formed.

4. Click "OK". The dialog box closes.

Result

The blocks are now interconnected and configured for our process simulation.
2.3 How to compile and download a chart

Procedure

Note
You can only perform a download if an AS 3xx or AS 4xx type CPU is configured and connected to your PC. The key switch setting for the CPU is "RUN-P".

Proceed as follows to compile and download the chart as a program:

1. Click the icon in the toolbar of the CFC
   
   or select the menu command Chart > Compile > Charts as Program....

2. Set "Scope: Entire Program" in the dialog box.
   Click "OK".
   Compiling is triggered and the progress is shown in a dialog box.

3. Click "Close" in the final message with the S7 protocols. You can ignore any warnings it contains.

4. Click the icon
   
   or select the menu command CPU > Download....
   The program is downloaded to the CPU.

5. Select the type of download in the dialog box. "Entire program" is set by default here.

6. Click "Yes" in the safety prompt.
   The CPU is set to STOP before the download and any blocks in the CPU are deleted.
   The download procedure is displayed in another dialog box.

7. When the download is successfully completed, click "Yes" in the final message.
   The CPU restarts.

Result

The CPU goes to RUN mode. The program is downloaded and can now be tested.
3 Testing the program

3.1 How to test the program

Introduction

In test mode, you can monitor the values of the block I/Os and change the values of the block inputs. The values listed for testing are marked in yellow.

By changing a few parameters, you can easily observe the control response, for example, how the manipulated variable approaches the setpoint and adjusts itself.

Switching to test mode

Before switching to test mode, use the menu command Test > Laboratory Mode to set test mode from "Process mode" to "Laboratory mode". This automatically sets all block I/Os to "Watch".

Note: No I/O is listed by default for monitoring in "Process mode". In this test mode, you select the relevant blocks and register them for monitoring by clicking the following icon:

Activating test mode

Click the icon

or select the Test > Test Mode menu command.

Changing values online

Enter another setpoint for the test in this example:

1. On the "Controller1" controller, double-click the SP_INT I/O and enter a value < 100 as the internal setpoint in the dialog box.

2. Click "Apply".
   The value is applied; the dialog box remains open for more changes.

3. Change other values and observe the control response.

4. Click "OK".
   The dialog box closes.
Examples:

You can, for example, influence the speed of the transient conditions at the block inputs:

**GAIN** (proportional coefficient that determines the controller gain)

**TN** (integration time that determines the time response of the integrator)

**TV** (derivative-action time constant that determines the time response of the differentiator)

Changing "GAIN" to a smaller value and "TN" to a longer time changes the dynamic response of the controller "Controller1" and slows down the control response in this example.

With the **MAN_ON** block I/O, you can interrupt the control loop and switch to "Manual mode" (=1). The manipulated variable (the value at the **LMN** output) is then specified by the value at the **MAN** I/O.
3.2 The current status of your project

Completed configuration tasks

In the meantime, you have performed almost the entire configuration in the SIMATIC Manager and CFC editor. You have created a project with the SIMATIC Manager, created a CFC chart and inserted blocks from a library. You have interconnected and configured blocks. You have generated an executable program and loaded it in the CPU. You can monitor and change the dynamic response of the closed loop in test mode.

You can therefore ensure that your configuration can be run without error.
Testing the program

3.2 The current status of your project
Performing changes at or in the chart

4.1 How to change the runtime properties

Introduction

The blocks of a chart have specific runtime properties. These runtime properties determine when and the order in which blocks are executed in the CPU. The blocks are integrated in OBs for this purpose. In this example, the blocks are in OB 35 by default (100 ms cyclic interrupt) and, because they also have startup characteristics, inserted in OB 100 (warm restart).

The CFC places the blocks one after the other behind a specific block so you do not have to pay attention to the run sequence for each block. This block is the "predecessor for insert position" for blocks added later. You can see which block is the "predecessor for insert position" by the light green color of the runtime properties field in the block header and in the status bar to the lower right of the window.

A runtime group is automatically created when a CFC chart is generated and given the same name as the chart.

You can assign attributes to the runtime group. You specify the reduction ratio of the OB cycle and the phase offset to be used to execute the blocks.

Changing the runtime property

You want to assign the blocks other runtime characteristics. Proceed as follows:

1. Click the icon

You change from test mode to edit mode.

Now open the Runtime editor with the run sequence:

2. Click the following icon in the toolbar or select the menu command Edit > Run Sequence....

A new window opens showing all the OBs. In OB 100 and OB 35, all objects are already inserted; you can recognize them by the + box in front of the OB icon.

3. Select OB 35 and the "Closed loop" runtime group in it.

The blocks are shown in the right detail window.

4. Open the shortcut menu of the runtime group and select the menu command Object Properties....

A dialog box opens.
Performing changes at or in the chart

4.1 How to change the runtime properties

5. Make the settings as shown below and then click "OK".

<table>
<thead>
<tr>
<th>Name</th>
<th>Closed loop</th>
<th>(default setting remains)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment</td>
<td>U8_PV0</td>
<td></td>
</tr>
<tr>
<td>Reduction ratio</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>Phase offset</td>
<td>0</td>
<td>(default setting remains)</td>
</tr>
<tr>
<td>Optimize run sequence</td>
<td>✔</td>
<td>(default setting remains)</td>
</tr>
<tr>
<td>Run</td>
<td>✔</td>
<td>(default setting remains)</td>
</tr>
</tbody>
</table>

6. Then, click "OK"

The entries are applied.

Based on the reduction ratio, the blocks are now executed every 8 runs. A basic cycle of 100 ms for OB 35 means there is an execution every 800 ms.

The phase offset provides a better load distribution in the CPU when the blocks are allocated to several different runtime groups. Since this is not relevant in this example, the default setting "0" is retained and there is no phase offset.

You can use the "Optimize run sequence" option to determine whether or not the runtime group should be included in an optimization run, which needs to be explicitly started. Use the "Active" check box to switch the runtime group on or off for processing in the CPU.
( Exception: When the runtime group is interconnected with a Boolean block output, the value of the output determines whether or not the runtime group should be processed).

Copying blocks within the chart

For practical training, copy the content from sheet 1 to sheet 2 and continue working with it there. The interconnections are retained when interconnected blocks are copied.

1. Switch from the run sequence to chart editing as follows:
   - Click on any position in the chart window
   - (CFCBSP_2\S7 Program(1)\...\Controlling)
   - or
   - click the icon

Then click the icon

You switch to the overview.

2. Draw a lasso around the interconnected blocks in sheet 1.
   The blocks are now highlighted in blue.
Performing changes at or in the chart

4.1 How to change the runtime properties

3. Keep the mouse point on the selection, hold down the <Ctrl> key at the same time and then drag the blocks to sheet 2 (below sheet 1).

   The blocks are copied to sheet 2 and the number in the block name is incremented, e.g. "Controller1" becomes "Controller2" in the copy.

4. Select the "Controller2" block in sheet 2, copy it, and then insert it back into the same sheet. The copied block is now called "Controller3".

Changing an interconnection

1. Click on the connection line or on the LMN output of "Controller2" and then press <Del>. The connection to the IN input of "Process2" is deleted.

2. Click on LMN of "Controller2" and then on SP_INT of "Controller3".

   (You will later learn how to make this "rewiring" without having to delete and reconnect).

3. Click on LMN of "Controller3" and then on IN of "Process2".

4. Click on OUT of "Process2" and then on PV_IN of "Controller3".

The interconnection for the shown block position now appears as follows:
Performing changes at or in the chart

4.1 How to change the runtime properties

Compiling, downloading and testing changes

Now compile the chart and download it to the CPU.

1. Click the following icon in the toolbar:

2. Set "Scope: Changes only" and then click "OK". Compiling is triggered. Confirm the final message by clicking "Close".

3. Click the following icon

4. Set "Download: Changes only" and then click "OK". The CPU does not have to be in STOP mode during the download.

Note

If this were a real project, you should read the information regarding the topic of "System support for avoiding causes of CPU STOP" in the online help. You can find this information with the menu command Help > Topics, entering "avoiding causes" in the "Index" tab and then clicking "Show".

Once the download is completed, you can switch back to test mode and test your modified program.
4.2 The current status of your project

Summary

In this section you have learned that the blocks of the CFC chart have certain runtime properties in the CPU and how you can change them. You have learned that substructures (runtime groups) are used in the run sequence and the attributes you can assign to them.

You have copied blocks within the chart and seen the interconnections between these blocks are retained. You have changed interconnections and regenerated an executable program. You have learned about the difference between a complete download and downloading changes only.
Performing changes at or in the chart

4.2 The current status of your project
5.1 How to create a chart with chart I/Os

Introduction

In the following, you will create chart I/Os for a CFC chart and insert this chart into another CFC chart.

You can use chart I/Os to a chart, for example, to encapsulate CFC charts for reuse. When the chart I/Os are created, you can specify which block I/Os are relevant for an interconnection to other charts or blocks and which should be made to the chart I/Os.

Procedure

1. Click the following icon in the toolbar:

   ![Icon](image1)

   Enter "Sim_reg" as the object name in the dialog box and click "OK". A new chart is created and displayed.

2. Click the following icon in the toolbar:

   ![Icon](image2)

   The "Sim_reg" and the "Controlling" charts are displayed next to each other.

3. Click the following icon:

   ![Icon](image3)

   The overview mode is set for both charts.

4. Copy the blocks from sheet 1 of the "Controlling" chart to sheet 1 of the "Sim_reg" chart, as you learned to do in the section "How to change the runtime properties" under "Copying blocks within the chart".

5. Close the "Controlling" chart and switch to the sheet view (sheet 1) of the "Sim_reg" chart.

6. Select the tab with the icon

   ![Icon](image4)

   and click on the block family **MULTIPLEX**. The block catalog opens.
7. Drag the SEL_R block to sheet 1 and enter the name "Switch1" in the properties dialog.
   To include the "Switch1" block in this example, you need to "rewire" an existing
   interconnection. Rewiring means changing an existing interconnection without deleting it.

8. Select the PV_IN I/O at the "Controller1" block and drag the I/O to "Switch1" IN1.
   The OUT output of "Process1" is now connected to IN1 of "Switch1".
   Alternatively, you can delete the existing connection and make a new connection.
   Now, the output of "Switch1" needs to be connected to the input for the process value of
   "Controller1".

9. Connect "Switch1" OUT with "Controller1" PV_IN.
   Now, depending on the value of input K, "Switch1" switches the value of the input IN0 (K=1)
   or IN1 (K=0) to the output OUT.
   In a real project, for example, you can switch between a process simulation "Process1" (IN1)
   and a real process (value from process connected to IN0) in this way.

Creating chart I/Os for a chart

Now create the chart I/Os for the chart. These are then connected to selected block I/Os.

1. Click on the following icon in the toolbar or select the menu command View > Chart I/Os.
   The window for editing chart I/Os is opened and “docked” to the upper part of the chart
   window.

2. Click on the block icon of the IN inputs in the left window.
   The block inputs are displayed in the right window (currently empty).

3. In the work area of the chart, select the block I/O MAN_ON at "Controller1" and drag the
   I/O to the "Name" box in the right window of the chart I/Os.
   The I/O is then adopted with its properties.

4. Proceed in exactly the same manner for all other unconnected inputs as shown in the
   table below.

5. Change the name of the K I/O of the "Switch1" block in the chart I/Os as follows:
   Double-click on the "Name" box and enter SIM here.
   Enter PV (process value) for IN0.

6. Click on the block icon of the OUT outputs in the left window of the chart I/Os.
   Select the LMN output at "Controller1", press and hold down the <Ctrl> key and drag the
   I/O to the "Name" box in the right window of the chart I/Os.
The chart I/Os are allocated as follows:

<table>
<thead>
<tr>
<th>Block</th>
<th>Block input</th>
<th>Data type</th>
<th>Block output</th>
<th>Data type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controller1</td>
<td>MAN.ON</td>
<td>BOOL</td>
<td>LMN</td>
<td>REAL</td>
</tr>
<tr>
<td></td>
<td>SP.INT</td>
<td>REAL</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>MAN</td>
<td>REAL</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>GAIN</td>
<td>REAL</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>TN</td>
<td>TIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>TV</td>
<td>TIME</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>DEADB_W</td>
<td>REAL</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Switch1</td>
<td>SIM (previously: K)</td>
<td>BOOL</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>PV (previously: IN0)</td>
<td>REAL</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Further procedure**

1. Close the window of the chart I/Os as follows:
   Click the following icon:

2. Design the chart as follows to make it as legible as possible:
   Position the blocks in the chart in such a way that the interconnection lines intersect as little as possible. You can see one such arrangement in the following figure:
**Chart I/Os and nested chart**

5.1 How to create a chart with chart I/Os

---

**Result**

The CFC sheet bar displays the I/Os names and comments, I/O type and data type applied to the chart I/Os.

All chart I/Os have now been created for the chart.
5.2 How to insert a chart in another chart

Procedure

The "Sim_reg" chart with chart I/Os created in the preceding configuration task should now be inserted into another chart. Generate the new chart as follows:

1. Click the following icon in the toolbar:
   ![chart icon]
   Enter "Basic_Chart" as the object name in the dialog box and click "OK". The new chart is displayed.

2. Click the tab with the icon
   ![chart icon]
   The "Charts" catalog opens. The "Basic_Chart", "Controlling" and "Sim_reg" charts are shown in a tree view.

   **Note:** If only the notice "! (no hierarchy folder exists)" appears in the catalog, the "Show with plant hierarchy" check box is activated in the Options > Settings > Layout.... dialog box. You need to deactivate this check box since you have created this project without a plant hierarchy. To do this, click on the check box. This removes the check mark.

3. Select the "Sim_reg" chart and drag it into the work area of "Basic_Chart". The original chart is copied.

4. Switch the sheet view.

   The chart with chart I/Os looks like a block and can be identified as a chart by its icon:
   ![chart icon]

Control

To ensure that this is a copy of the chart you have previously created, proceed as follows:

1. Select the copy and then
   select the **Open** command from the shortcut menu.
   You can see by the path information in the title bar that this is a "Hierarchical chart": "...\Basic_Chart\Sim_reg".

2. A + box is shown in front of the "Basic_Chart" in the chart catalog.
   Click on the box
   or
do double-click on the chart icon.
   The advanced tree display and the hierarchy of the chart become visible. The "Sim_reg" chart is shown as the active chart in this branch with the icon of the open folder.

3. Open the shortcut menu in the chart window and
   select the menu command **Open Parent Chart** or
   select the menu command **Window** and the path of the "Basic_Chart" here.
   You return to the basic chart.
5.3 The current status of your project

Summary

In this section, you have learned how to edit a chart so that it contains chart I/Os. These I/Os allow you to interconnect the chart like a block to other block I/Os and thereby use it multiple times. You have learned how to insert a chart like a block using the chart-in-chart technique. You have seen that, in contrast to the block, the inserted chart can be opened and therefore specifically modified.

Using the chart-in-chart technique, you can create hierarchical charts and use them to generate a structure based on technological aspects with improved legibility.
Creating and testing a block

6.1 How to create a block type

Introduction

Usually, the compiling is performed for the complete chart folder in which the opened chart is located. The resulting program can then be loaded in a CPU. You can also compile a single chart and generate a block type from it, to use it in your block library or in the S7 program.

Procedure

Compile the original "Sim_reg" chart as a block type as follows:

1. Select the menu command Window > Close All.
   All the charts are closed.

2. In the component view, select the "Sim_reg" chart in the "Charts" directory and open it with the "Open" command from the shortcut menu.
   Be sure to open the original "Sim_reg" chart, which is located on the same level as the "Basic_Chart" and "Controlling" charts.

3. Select the menu command Chart > Compile > Chart as Block Type in the CFC editor.
   A dialog box opens for more input.

4. Enter the following values in the "Block Type Properties" group and click "OK":

   | FB number:   | 110    |
   | Symbolic name: | REG_1  |
   | Name (header): | REG_1  |
   | Family:       | CONTROL|
   | Author:       | TEST   |
   | Version (header): | 0.1    |

Compiling is triggered and the progress is shown in a dialog box. Once the compiling is successfully completed, the FB 110 block is in the block folder and the icon name "REG_1" is entered in the symbol table.
6.2 How to test a block

Procedure

The last task is to create a new chart and insert the REG_1 block in it:

1. Create a new "Test" chart.
2. Press the <F5> key or select the menu command View > Update. The CFC reads the changes in the symbol table and block folder.
3. Open the S7 program in the catalog of the blocks. You see the new REG_1 block type there.
4. Drag REG_1 into the "Test" chart and switch to the sheet view. You see the block I/Os that you have created as chart I/Os. The system has inserted the EN and ENO I/Os so that the block can be enabled and disabled. These I/Os are invisible with the default setting. If you want to show these I/Os, you will need to activate their visibility in the object properties of the "I/Os" tab.
5. Compile the charts as program and download the program to the CPU. Click the following icon:

![Download icon]

You will see a message that the program has been changed and must first be compiled.
6. Respond to the question "Do you want to compile now and then download?" by clicking "Yes". A dialog box opens with the tabs "Compile charts as program" and "Download S7".
7. Select "Scope: Changes only" in the two tabs and then click "OK". The process is started.
8. Change to the test mode

![Test mode icon]

to monitor and change the I/Os of the block. You can use the SIM input to switch between internal simulation (= 0) and external process value (of the PV input) (= 1).
Summary

You have become familiar with a few possibilities offered by CFC in this brief tutorial. The exercise has shown you how easy it is to use this configuration tool to create an automation task as a program and execute it in the CPU.

Once you have worked through this example, you are ready to solve more complex problems using the CFC.

Refer to the online help for CFC for additional information.