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法律资讯 
警告提示系统 

为了您的人身安全以及避免财产损失，必须注意本手册中的提示。人身安全的提示用一个警告三角表示，仅与财产

损失有关的提示不带警告三角。警告提示根据危险等级由高到低如下表示。 

危险  
表示如果不采取相应的小心措施，将会导致死亡或者严重的人身伤害。 

警告  
表示如果不采取相应的小心措施，可能导致死亡或者严重的人身伤害。 

小心  
带有警告三角，表示如果不采取相应的小心措施，可能导致轻微的人身伤害。 

小心  
不带警告三角，表示如果不采取相应的小心措施，可能导致财产损失。 

注意  
表示如果不注意相应的提示，可能会出现不希望的结果或状态。 

当出现多个危险等级的情况下，每次总是使用最高等级的警告提示。如果在某个警告提示中带有警告可能导致人身

伤害的警告三角，则可能在该警告提示中另外还附带有可能导致财产损失的警告。 

合格的专业人员 
本文件所属的产品/系统只允许由符合各项工作要求的合格人员进行操作。其操作必须遵照各自附带的文件说明，特

别是其中的安全及警告提示。 由于具备相关培训及经验，合格人员可以察觉本产品/系统的风险，并避免可能的危

险。 

Siemens 产品 
请注意下列说明： 

警告  
Siemens 产品只允许用于目录和相关技术文件中规定的使用情况。如果要使用其他公司的产品和组件，必须得到 
Siemens 推荐和允许。正确的运输、储存、组装、装配、安装、调试、操作和维护是产品安全、正常运行的前

提。必须保证允许的环境条件。必须注意相关文件中的提示。 

商标 
所有带有标记符号 ® 的都是西门子股份有限公司的注册商标。标签中的其他符号可能是一些其他商标，这是出于保

护所有者权利的 目地由第三方使用而特别标示的。 

责任免除 
我们已对印刷品中所述内容与硬件和软件的一致性作过检查。然而不排除存在偏差的可能性，因此我们不保证印刷

品中所述内容与硬件和软件完全一致。印刷品中的数据都按规定经过检测，必要的修正值包含在下一版本中。 
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前言 1
文档用途       

本文档介绍了有关 SIMATIC PCS 7 维护站的软件组件、应用领域、组态选项和调试方面

的信息。 

并解答了下列关键问题： 

● 什么是维护站？ 

● 哪些软件组件属于维护站？ 

● 安装过程中，有哪些硬件和软件要求以及需要哪些许可证？ 

● 维护站适用于哪些应用领域？ 

● 如何使用维护站进行诊断？ 

本文档的德语版和英语版免费提供，可从 Internet 网站 http://www.siemens.de/pcs7-
dokumentation (http://www.siemens.com/pcs7-documentation) 的 
MyDocumenationManager 中获取。 

必备的基本知识 

本文档面向参与组态、调试以及操作基于 SIMATIC PCS 7 的自动化系统的所有人员。 

本文档的读者通常应具备一定的基本知识，并应知道如何使用 PC/PG 以及 Windows 操
作系统。 应熟练掌握 SIMATIC PCS 7 的各种功能及组态。 

本手册假设用户熟悉指定手册中的以下知识： 

● 《过程控制系统 PCS 7；工程组态系统》 

● 《过程控制系统 PCS 7；操作站》 

● 《过程控制系统 PCS 7；OS 过程控制》 

本文档的适用范围 

本文档适用于过程控制系统；SIMATIC PCS 7 软件包 V8.0 或更高版本。 

http://www.siemens.com/pcs7-documentation�
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SIMATIC PCS 7；手册汇集 

在 Internet 站点 http://www.siemens.de/pcs7-dokumentation 
(http://www.siemens.com/pcs7-documentation) 的 MyDocumenationManager 中，以多

种语言和手册汇集的形式免费提供完整的 PCS 7 文档。 

自述文件 

可从该自述文件搜集最新的高优先级信息：  

该自述文件位于过程控制系统；SIMATIC PCS 7 V8.0 或更高版本的 DVD 光盘上。 

● 在安装 PCS 7 后，也可通过 Windows“开始”(Start) 菜单中的子菜单“SIMATIC”和“产
品信息”(Product Information) 打开该自述文件。 

约束 

在本文档中，软件的界面术语已按文档语言本地化。 但是，如果安装了多语言操作系统

软件包，则在转换语言后，某些术语可能会以操作系统的基本语言显示，因而会与本文档

中所用的术语不同。 

PCS 7 词汇表 

PCS 7 词汇表定义了文档中所使用的重要技术术语，可通过 PCS 7 软件中的 SIMATIC 
Manager 帮助菜单访问，即菜单命令“帮助”(Help) >“主题”(Topics) >“词汇表”(Glossary) 
按钮。 

http://www.siemens.com/pcs7-documentation�
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附加文档 2
附加文档   

下表列出了提供更多信息的文档。 在线帮助 (CHM) 中也包含电子手册 (PDF) 的所有内

容。 

 

文档 用途 

在线帮助： 
PCS 7， 
组态 - 工程组态系统的帮助 
 

手册 
《过程控制系统 PCS 7； 
工程组态系统》 

本文档可协助您在工程师站上使用 SIMATIC PCS 7 
过程控制系统进行组态。 

在线帮助： 
PCS 7，组态 - 操作站的帮助 
 

手册： 
《过程控制系统 PCS 7  
操作站》 

本文档可协助您在操作站上使用 SIMATIC PCS 7 过
程控制系统进行组态。 

手册： 
《SIMATIC Logon， 
SIMATIC 电子签名》 

本文档将帮助您使用 SIMATIC Logon 设置集中访问

授权管理。 

在线帮助和手册： 
《过程控制系统 PCS 7 
PCS 7 基本库》  

该文档描述了驱动程序和诊断块的功能、块 I/O 和输

入/输出字段。 

在线帮助和手册： 
《过程控制系统 PCS 7 
PCS 7 高级过程库》 

该文档描述了各个面板的功能、块 I/O 和输入/输出

域。 

在线帮助： 
WinCC 信息系统 

本文档将帮助您组态操作站以及在过程控制中运行操

作站。 
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文档 用途 

手册： 
《PCS 7 过程控制系统 PCS 7 
SIMATIC PDM》 

本文档可在安装调试软件、组态网络和现场设备、调

试和使用运行功能期间提供支持。 

手册： 
《用于工业以太网 
的 SIMATIC NET S7 CP》（BL1 
部分） 

本文档介绍了 IE/PB Link PN IO 的组态、安装和调

试。 

文档 
Process Control System 
PCS 7; Licenses and 
configuration limits 

本文档介绍了过程控制系统不同组件和达到相应工厂

规模所需的最新许可证等级。 

手册 

《过程控制系统 PCS 7 
使用新功能的软件更新》 

手册 

《过程控制系统 PCS 7 
不使用新功能的软件更新》 

文档的“维护站”部分提供了有关迁移维护站的信

息。 
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访问选项 

可通过以下方式访问文档： 

● 在 PCS 7 计算机上 

– 通过相关应用程序的帮助菜单访问在线帮助 

– 通过 Windows“开始”(Start) 菜单的子菜单“SIMATIC > 文
档”(SIMATIC > Documentation) 访问手册 

– 通过子菜单“SIMATIC > WinCC”访问 WinCC 信息系统的在线帮助 

● 在 Internet 上 

– 通过以下链接访问 PCS 7 过程控制系统的在线帮助、手册和文档： 

http://www.siemens.de/pcs7-dokumentation (http://www.siemens.com/pcs7-
documentation)  

– 在以下链接可找到更多在线帮助和手册： 

http://www.siemens.com/automation/service 
(http://www.siemens.com/automation/service)  

http://www.siemens.com/pcs7-documentation�
http://www.siemens.com/pcs7-documentation�
http://www.siemens.com/automation/service�
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使用维护站 3
3.1 应用、版本和组态 

应用   

维护站侧重于“工厂资产管理”，可用于对工厂进行预防性和预测性诊断与维护。  

在进行过程控制的同时，维护站还为系统组件（资产）提供统一的维护信息和功能。 

工厂操作员通过操作员系统 (OS) 接收所有与过程相关的信息，从而可以对过程进行选择

性地干预。在此过程中，维护工程师将通过维护站检查自动化系统硬件并处理相关的诊断

消息和维护要求。 

这基于维护站始终是一个可提供这些维护功能的 OS。  

在 SIMATIC Manager 的工厂层级中确定具有维护功能的 OS 和操作的维护站的版本。 

有关工程组态、组态和过程控制的基本信息，请参见以下文档： 

● 《过程控制系统 PCS 7；工程组态系统》 

● 《过程控制系统 PCS 7；操作站》 

● WinCC 在线帮助 

版本      

用户可使用以下版本的维护站： 

● 基本维护站（集成在 PCS 7 项目中） 

– 在文档中称为基本 MS。   

● 标准维护站（集成在 PCS 7 项目中） 

– 在文档中称为标准 MS。   

● SIMATIC PDM 维护站（独立项目） 

– 在文档中称为 SIMATIC MS PDM。   
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不同版本之间的差异 

下表列出了差异。 

 

 基本 MS 标准 MS SIMATIC MS PDM 

显示的信息  总览画面 

 区域总览画面 

– AS 对象 

– 网络对象 

– PC 站 

 各组件的状态信息 

 总览画面 

 区域总览画面 

– AS 对象 

– 网络对象 

– PC 站 

– 用户对象 

 各组件的状态信息 

 各组件的详细信息 

 层级画面的结构 

 全局功能 

 组件特定的功能 

 总览画面 

 区域总览画面 

– 现场设备 

– 网络对象（可选） 

– PC 站（可选） 

 各组件的状态信息 

 各组件的详细信息 

 层级画面的结构 

 全局功能 

 组件特定的功能 

生成诊断 
结构 

通过 SIMATIC PCS 7 硬件项目自动生成 通过 SIMATIC PDM 独立项

目 
自动生成（网络视图） 

设置诊断 
结构 

 区域总览画面 

– AS 对象 

– 网络对象 

– PC 站 

 带有诊断状态的组件的

符号表示 

 无层级画面的结构 

 不调用面板 

 区域总览画面 

– 用户对象 

– AS 对象 

– 网络对象 

– PC 站 

 带有诊断状态的组件的符号

表示 

 具有较低级别现场组件的 
AS 组件的层级画面结构 

 用户组件的层级画面结构 

 调用面板 

 区域总览画面 

– 现场设备 

– 网络对象（可选） 

– PC 站（可选） 

 带有诊断状态的组件的符

号表示 

 连接有现场组件的现场总

线组件的层级画面结构 

 调用面板 
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 基本 MS 标准 MS SIMATIC MS PDM 

消息 
分配 

按区域 按组件 

诊断 
更新 

 系统周期性更新 

 事件驱动更新 

 系统周期性更新 

 事件驱动更新 

 手动更新 

 周期性轮询 

 手动更新 

 周期性轮询 

详细 
信息 (1) 

不可用  电子铭牌（标识数据） 

 与组件相关的消息 

 符合 SNMP 配置文件的详

细信息 

 符合 EDD 信息 (3) 的组件

状态 

 符合 EDD 信息的详细信息

 用户须知 

 冗余状态 

 CPU 利用率/ 
循环利用率 

 调用设备特定的条件监视功

能（例如，诊断监视器） 

 电子铭牌（标识数据） 

 与组件相关的消息 

 与 SNMP 配置文件一致的

详细信息（可选） 

 符合 EDD 信息的组件状态

 符合 EDD 信息的详细信息

 用户须知 

 调用设备特定的条件监视

功能，例如诊断监视器

（可选） 

具有诊断功能

的组件 
有关此主题的更多信息，请参见“具有诊断功能的组件 (页 17)”部分。 

全局功能 不可用  完全导出所有组件的电子铭牌（包括维护状态） 

 与组件状态相关的过滤功能 

 与电子铭牌内容相关的过滤功能 

 导出个别组件的数据 

 手动更改组件的维护状态 

 使用 PCS 7 操作站的标准功能，例如，过程控制中的报告

生成 
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 基本 MS 标准 MS SIMATIC MS PDM 

在线调用 HW Config 不可用 组件 
特定的功能 
(2) 

不可用 

调用 

 组件特定的 Web 门户 

 在工程组态中组态的 Web 门户 

 处理基于 EDD 组件的 SIMATIC PDM 

 用于 IPC 对象的诊断监视器 

许可证 不需要 取决于数量和功能 

(1) 取决于所使用的组件 

(2) 取决于所用的组件类型以及是否在多工作站系统中使用 MS 客户端。 

(3) 电子设备描述 

在本文档的其它章节，将介绍所有的区别。  

组态   

基本 MS 版本的维护站和标准 MS 版本的维护站可组态为 MS 单工作站系统或 MS 多工

作站系统。 

更多相关信息，请参见“MS 单工作站系统 (页 23)”和“MS 多工作站系统 (页 25)”部分。 

SIMATIC PDM MS 可组态为 MS 单工作站系统。 

有关此主题的更多信息，请参见“SIMATIC MS PDM (页 27)”部分。 

在 PCS 7 Web 客户端上进行操作和监视   

可使用 PCS 7 Web 客户端操作和监视 MS 单工作站系统和 MS 多工作站系统。 手册的

相应部分对现有限制进行了说明。 
 

 说明 
该功能对 SIMATIC MS PDM 不可用。 
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3.2 具有诊断功能的组件 

可以监视哪些组件？  

在过程控制过程中，将在诊断区域的某些区域内显示具有诊断功能的组件。   

下表列出了可监视的组件示例以及这些组件的显示区域。 

 

诊断对象 区域 基本 
MS 

标准 
MS 

SIMATIC 
MS PDM 

 例如，西门子工业 PC 

– 操作站 

– BATCH 站 

– Route Control 站 

– 中央归档服务器 

– SIMATIC PCS 7 BOX 

 第三方的用于 SIMATIC PCS 7/PC 
的高级服务器 

PC 站 

 交换机，例如： 

– SCALANCE X 

– OSM 

– ESM 

 其它支持 SNMP 服务的组件 

– 例如，打印机、桥接器、路由器 

网络对象 

X 可选  
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诊断对象 区域 基本 
MS 

标准 
MS 

SIMATIC 
MS PDM 

 CPU 和连接 

 SIMATIC PCS 7 BOX 

 分布式 I/O（如 ET 200M、ET 
200S、 
ET 200iSP、ET 200PRO、输入和输

出模块） 

 PROFIBUS 设备 

 PROFINET 设备 

 现场设备（HART、PROFIBUS 
PA、……） 

 故障安全模块 

 接口模块 (IM, Interface Module) 

 具有诊断功能的非透明耦合器 

 链路模块 

 诊断中继器 

AS 对象 X - 

 可由 SIMATIC PDM 检测到的 EDD 
对象 

 分布式 I/O（如 ET 200M、ET 
200S、 
ET 200iSP、ET 200PRO、输入和输

出模块） 

 现场设备（HART、PROFIBUS 
PA、……） 

 接口模块 (IM, Interface Module) 

 具有诊断功能的非透明耦合器 

 链路模块 

现场设备 - X 

 可由应用程序为其生成诊断的用户对

象 
用户对象 - X -  

更多信息 

有关可以由维护站监视的所有 PCS 7 组件，请参见列表 PCS 7 过程控制系统；已发布模

块。 



 使用维护站 
 3.2 具有诊断功能的组件 

维护站 
功能手册, 12/2011, A5E03397308-01 19 

将监视 PC 站区域中的哪些组件？ 

 

监视的组件 补充条件和显示的信息 

安装有为 IPC 组态的“诊断

监视器”诊断程序，并且可通

过 SNMP 访问的 Siemens 
工业 PC (IPC)（ES、服务

器、客户端或其它计算机）

 故障监视 

 带有限值的风扇速度 

 带有 CCPerfmon 限值的硬盘利用率 

 冗余电源 

 温度、CPU、板件等信息 

 使用 RAID1 的硬盘故障 

 连接故障 

 禁用 OS - 仅适用于 OS 服务器项目 

 终端适配器故障 

 看门狗 

 修订版报警 

通过 SNMP 访问的第三方 
PC 

通过 SNMP 访问的用于 
SIMATIC PCS 7 的高级服

务器 

 符合 SNMP 配置文件 MIB-II 的标识数据 

 故障监视 

无 SNMP 的第三方 PC  通过 WMI 监视故障的标识数据 

将监视网络对象区域中的哪些组件？ 

 

监视的组件 补充条件和显示的信息 

SCALANCE X200、X300、
X400、X500、W700； 

OSM/ESM 

 用于监视电源错误的组故障（红色、馈入） 

 端口错误 

 环型冗余错误 

必须在组件中启用监视功能。 

第三方交换机  借助 SNMP 配置文件 MIB-II 监视故障 

打印机  借助 SNMP 配置文件 MIB-II 监视故障 
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在 AS 对象区域中监视哪些组件？ 

 

监视的组件 补充条件和显示的信息  

SIMATIC S7-4xx 系列 CPU  有关 CPU 利用率的诊断信息 

 OB3x、OB8x 和 OB1 的使用情况 

 过载情况下 OB3x 的降低率 

 显示引用 PNO 规范的电子铭牌 
如果无法从组件读取数据，则显示项目中的数据（如果

存在）。 

 详细的错误消息 

 详细的维护状态 

这些信息取决于 CPU 固件的版本。 

SIMATIC PCS 7 中央模块

和标准 I/O 
 显示引用 PNO 规范的电子铭牌 

如果无法从组件读取数据，则显示项目中的数据（如果

存在）。 

 详细的错误消息 

 详细的维护状态 

PROFIBUS DP/PA 现场设

备（通过 EDD 集成） 
 详细的设备特定/基于 EDD 的诊断信息 

 显示引用 PNO 规范的电子铭牌 
如果无法从组件读取数据，则显示项目中的数据（如果

存在）。 

 详细的错误消息 

 详细的维护状态 

PROFIBUS DP/PA 标准从

站（通过 GSD 集成的现场

设备） 

 故障监视 

 显示引用 PNO 规范的电子铭牌 
如果无法从组件读取数据，则显示项目中的数据（如果

存在）。 

 维护状态“良好”和“维护报警” 

HART 现场设备（通过 
EDD 集成到 SIMATIC PCS 
7 标准 I/O 中） 

 详细的设备特定/基于 EDD 的诊断信息 

 显示电子铭牌（基于 HART 通信基金会 (HCF) 的规

范） 

 详细的错误消息 

 详细的维护状态 
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监视的组件 补充条件和显示的信息  

SIMATIC TIA 对象  故障监视 

 显示引用 PNO 规范的电子铭牌 
如果无法从组件读取数据，则显示项目中的数据（如果

存在）。 

 维护状态“良好”和“故障” 

SIMATIC PCS 7 附加件对

象（通过 EDD 集成的现场

设备） 

 详细的设备特定/基于 EDD 的诊断信息 

 显示引用 PNO 规范的电子铭牌 
如果无法从组件读取数据，则显示项目中的数据（如果

存在）。 

 详细的错误消息 

 详细的维护状态 

将监视现场对象区域中的哪些组件？ 

 

监视的组件 补充条件和显示的信息 

现场设备  PROFIBUS DP/PA 现场设备（通过 EDD 集成） 

 PROFIBUS DP/PA 远程 I/O（通过 EDD 集成） 

 以太网现场设备（通过 EDD 集成） 

 HART 现场设备（通过 EDD 集成） 

 无线 HART 现场设备（通过 EDD 集成） 

 Modbus 现场设备（通过 EDD 集成） 

将监视用户对象区域中的哪些组件？ 

 

监视的组件 补充条件和显示的信息 

用户对象  无法通信访问的组件 

 间接诊断的对象 

 状态监视功能的结果 

 过程设备网络视图中未在 HW Config 中组态的组件，

例如，无线 HART 现场设备 
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信息的显示区域 

有关具有诊断功能的各个 PCS 7 组件状态的信息，可在维护站的诊断画面上找到。 

诊断画面仅显示组件或项目中的数据。 

有关诊断画面的信息，请参见“操作员监控 (页 101)”部分。 
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3.3 MS 单工作站系统 

OS 单工作站系统中的 MS 单工作站系统 

维护站在工程师站上运行。 

工厂组态     

MS 单工作站系统具有以下功能： 

● 操作站 (OS) 

● 工程师站 (ES) 

● 维护站 (MS) 

● SIMATIC PDM 

在一个工作站上，操作员可以完全监控一个 PCS 7 项目（工厂/单元）。 在过程控制的总

览区域中，将显示 MS 的 OS 区域和“诊断”区域。  

“诊断”区域通过诊断画面显示诊断状态，提供所需操作员监控功能。 

工厂总线上的 MS 单工作站系统可与其它单工作站或多工作站系统并行使用。  

工厂组态 

下图显示了一个工厂组态示例。 
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规则 

组态期间禁用维护站。 

软件和许可 

如果必须监视智能现场设备，则在工程师站上安装 SIMATIC 过程设备管理器 (SIMATIC 
PDM)。 

有关软件的更多信息，请参见手册《过程控制系统 PCS 7；PC 组态与授权》。 

有关过程控制系统各种组件的当前许可证等级和所能达到的相应工厂规模的信息，请参见

文档Process Control System PCS 7; Licenses and configuration limits。 可以通过 
http://www.siemens.de/pcs7-dokumentation (http://www.siemens.com/pcs7-
documentation) 在 Internet 上获取该文档。 

http://www.siemens.com/pcs7-documentation�
http://www.siemens.com/pcs7-documentation�
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3.4 MS 多工作站系统 

OS 多工作站系统中的 MS 多工作站系统 

在分布式系统中，维护站集成在一个客户端/服务器体系架构中。 

工厂组态      

MS 服务器  

● 在独立 PC 站上或具有 OS 服务器的 PC 站上进行组态 

● 可以冗余组态 

● 处理 OS/MS 和/或 MS 客户端上显示的过程控制消息 

● 如果连接到工厂总线，则可以通过工厂总线处的 OPC 服务器监视网络组件 

可以通过以下方式组态 MS 客户端： 

● 在工程师站上组态为 MS 客户端 

工程师站中的 MS 客户端具有完整功能。 

在组态期间，将禁用工程师站上运行的 MS 客户端。 

● 在单独的 PC 站上组态为 MS 客户端 

单独 PC 站上的 MS 客户端通过诊断画面显示诊断区域中的诊断状态，并提供所需的

操作员监控功能。 

此 MS 客户端具有工程师站上的 MS 客户端的功能，但在以下几个方面有所不同： 

无法执行“如何打开 HW Config 的在线视图”与“如何打开 SIMATIC PDM 的参数分配

接口”功能。 

● 在 OS 客户端上组态为 OS/MS 客户端 

OS/MS 客户端是一种 MS 客户端，在该 MS 客户端上，将同时显示 OS 服务器区域与

诊断区域。 

该 OS/MS 客户端具有单独 PC 站上 OS 客户端和 MS 客户端的功能。 
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工厂组态 

下图显示了一个工厂组态示例。 

 

必需的服务器数据  

● 在 MS 或 OS/MS 客户端上 

更多相关信息，请参见“服务器数据和客户端的下载 (页 96)”部分。 

● 在 MS 客户端上 

生成诊断结构后，多项目/项目中的所有 OS 服务器的服务器数据将自动下载到 MS 服
务器。 

软件和许可 

如果必须监视智能现场设备，则在工程师站上安装 SIMATIC 过程设备管理器 (SIMATIC 
PDM)。 

有关软件的更多信息，请参见手册《过程控制系统 PCS 7；PC 组态与授权》。 

有关过程控制系统各种组件的当前许可证等级和所能达到的相应工厂规模的信息，请参见

文档Process Control System PCS 7; Licenses and configuration limits。 可以通过 
http://www.siemens.de/pcs7-dokumentation (http://www.siemens.com/pcs7-
documentation) 在 Internet 上获取该文档。 

http://www.siemens.com/pcs7-documentation�
http://www.siemens.com/pcs7-documentation�
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3.5 SIMATIC MS PDM 

工厂组态 

SIMATIC MS PDM 是预组态为 IPC Microbox 427C 的单工作站系统。 它专为单机使用设

计，独立于所使用的自动化解决方案。 并且基于 PCS 7 维护站。 可在此 PC 站上执行所

有操作和监视功能。     

SIMATIC MS PDM 可以处理由 SIMATIC PDM 确定的诊断信息。  

SIMATIC MS PDM 使用诊断画面显示诊断区域中的诊断状态，并提供所需的操作员监控

功能。 

自动化系统通过一个集成 AS RTX (WinLC RTX) 映射到软件中。  

诊断消息在集成 AS RTX 中产生，在 SIMATIC MS PDM 上显示。 
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工厂组态 

下图显示了一个工厂组态示例。 
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规则 

在组态期间，禁用 SIMATIC MS PDM。 

软件和许可 

● 随附的恢复软件 

● PDM 的最新设备 DVD 光盘 

可以选择扩展 SIMATIC MS PDM 的级别和功能。 

下列许可证可用于扩展： 

● 各个级别的 PDM TAG 

● PCS 7 维护站的资产变量 

● 操作站 (OS) 的 PO 变量 

● 自动化系统 (AS) 的 PO 变量 

● PCS 7 维护站运行系统基本软件包（与 OPC 服务器结合使用） 

有关各个产品的信息，请参见 Internet 上“技术支

持”http://www.siemens.com/automation/service 
(http://www.siemens.com/automation/service) 下随产品提供的文档。 

有关过程控制系统各种组件的当前可用许可等级和所能达到的相应工厂规模的信息，请参

见文档Process Control System PCS 7; Licenses and configuration limits。可以通过 
http://www.siemens.de/pcs7-dokumentation (http://www.siemens.com/pcs7-
documentation) 在 Internet 上获取该文档。 

http://www.siemens.com/automation/service�
http://www.siemens.com/pcs7-documentation�
http://www.siemens.com/pcs7-documentation�
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组态维护站 4
4.1 MS 单工作站系统概览 

下表列出了包含信息和组态说明的主题。 表中的顺序与建议的组态顺序一致。   

 

内容 基本 
MS 

标准 
MS 

多重项目/项目中的常规设置 (页 35)  

组态作为 MS 单工作站系统的 PC 站 (页 37)  

组态 PC 站和网络对象的监视 (页 52)  

创建诊断结构 (页 62)  

X 

高级诊断设置 (页 68)  

组态用户诊断 (页 77)  

- 

SIMATIC PDM 的设置 (页 85)  

完全导出 - 导出所有组件的数据 (页 87)  

单个导出 - 导出各个组件数据 (页 90)  

创建/更新诊断画面 (页 92)  

编译和下载维护站 (页 94)  

项目中的更改 (页 97)  

X 

通过报警控制中心集成 (页 187)  - 

X 
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4.2 MS 多工作站系统概览 

4.2.1 MS 服务器概览 

下表列出了包含信息和组态说明的主题。 表中的顺序与建议的组态顺序一致。   

 

内容 基本 
MS 

标准 
MS 

多重项目/项目中的常规设置 (页 35)  

如何组态作为工程师站的 PC 站 (页 39)  

如何组态作为 MS 服务器的 PC 站 (页 41)  

组态 PC 站和网络对象的监视 (页 52)  

创建诊断结构 (页 62)  

X 

高级诊断设置 (页 68)  

组态用户诊断 (页 77)  

- 

SIMATIC PDM 的设置 (页 85)  

完全导出 - 导出所有组件的数据 (页 87)  

单个导出 - 导出各个组件数据 (页 90)  

创建/更新诊断画面 (页 92)  

编译和下载维护站 (页 94)  

项目中的更改 (页 97)  

X 

通过报警控制中心集成 (页 187)  - 

X 
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4.2.2 冗余 MS 服务器概览 

下表列出了包含信息和组态说明的主题。 表中的顺序与建议的组态顺序一致。    

 

内容 基本 
MS 

标准 
MS 

多重项目/项目中的常规设置 (页 35)  

如何组态作为工程师站的 PC 站 (页 39)  

如何组态作为 MS 服务器的 PC 站 (页 41)  

如何组态作为冗余伙伴的 PC 站 (页 43)  

组态 PC 站和网络对象的监视 (页 52)  

创建诊断结构 (页 62)  

X 

高级诊断设置 (页 68)  

组态用户诊断 (页 77)  

- 

SIMATIC PDM 的设置 (页 85)  

完全导出 - 导出所有组件的数据 (页 87)  

单个导出 - 导出各个组件数据 (页 90)  

创建/更新诊断画面 (页 92)  

编译和下载维护站 (页 94)  

项目中的更改 (页 97)  

X 

通过报警控制中心集成 (页 187)  - 

X 

4.2.3 MS 客户端或 OS/MS 客户端概览 

下表列出了包含信息和组态说明的主题。 表中列示的顺序与建议的组态顺序一致。    

 

内容 基本 
MS 

标准 
MS 

如何组态作为 MS 或 OS/MS 客户端的 PC 站 (页 45)  

服务器数据和客户端的下载 (页 96)  

项目中的更改 (页 97)  

X X 
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4.3 SIMATIC MS PDM 概览 
下表列出了包含信息和组态说明的主题。 表中的顺序与建议的组态顺序一致。   

 

内容 组态 
SIMATIC MS PDM

多重项目/项目中的常规设置 (页 35)  

组态作为 SIMATIC MS PDM 的 PC 站 (页 47)  

X 

组态 IE/PB Link PN IO (页 49)  

组态 PC 站和网络对象的监视 (页 52)  

可选 

创建诊断结构 (页 62)  X 

SIMATIC PDM 的设置 (页 85)  

完全导出 - 导出所有组件的数据 (页 87)  

单个导出 - 导出各个组件数据 (页 90)  

创建/更新诊断画面 (页 92)  

编译和下载维护站 (页 94)  

项目中的更改 (页 97)  

X 

通过报警控制中心集成 (页 187)  可选 



 组态维护站 
 4.4 多重项目/项目中的常规设置 

维护站 
功能手册, 12/2011, A5E03397308-01 35 

4.4 多重项目/项目中的常规设置 

MS 单工作站/多工作站系统概览    

要通过维护站对组件进行监视，应检查下表中指定的设置，并根据需要进行调整。 

 

设置 位置 注释 

区域语言与 

显示设备的语言 

SIMATIC Manager  设置在过程控制中操作 
WinCC 项目时所使用的

语言。 

AS 站名称 (1) SIMATIC Manager 

组件标识 (1) HW Config 

 <=14 个字符 

 无空格 

S7 程序 (1)  多项目/项目中所有 S7 
程序消息编号的范围必须

都相同 

 S7 程序的名称不可分配

两次 

驱动程序块 (1) 驱动程序块的版本最低必须

为 V6.1。 

必要时可使用相应的库。 

OS 编译模式 面向区域 

工厂层级设置 (1) 

SIMATIC Manager 

在多项目/项目的所有项目

中，工厂层级的设置必须相

同。 

WinCC 项目类型的单工作

站项目 (2) 
在项目属性中必须选择单工

作站项目类型。  

组显示层级 (1) 

WinCC 项目管理器 

使用用户诊断时，必须自动

创建组显示层级。 

(1) 仅适用于基本 MS 和标准 MS 

(2) 仅适用于 SIMATIC MS PDM 
 

 说明 
一个多重项目/项目中只有一个 MS 服务器。 
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更多信息 

有关此主题的更多信息，请参见《过程控制系统 PCS 7 工程组态系统》手册和《过程控

制系统 PCS 7；操作站》手册。 



 组态维护站 
 4.5 组态作为 MS 单工作站系统的 PC 站 

维护站 
功能手册, 12/2011, A5E03397308-01 37 

4.5 组态作为 MS 单工作站系统的 PC 站 

简介 

如果您已经在多重项目/项目中使用现有 ES/OS 单工作站系统，则不需要执行以下步骤。 

要求    

已经创建多项目/项目。 

步骤 

1. 在 SIMATIC Manager 的组件视图中，选择要在其中插入 MS 单工作站系统的项目。 

2. 选择菜单命令“插入 > 站 > SIMATIC PC 站”(Insert > Station > SIMATIC PC 
station)。 

在所选项目中插入一个新的 SIMATIC PC 站。 

3. 选择该 SIMATIC PC 站，然后选择“编辑 > 对象属性”(Edit > Object Properties)。 

4. 在“名称”(Name) 输入字段中，输入 PC 站名称。 

5. 在“计算机名称”(Computer name) 输入框中，输入 Windows 计算机名称。 

6. 单击“确定”(OK)。 

7. 在 SIMATIC Manager 的组件视图中选择 SIMATIC PC 站。 

8. 在详细视图中，通过双击“组态”(Configuration) 对象打开 HW Config。 

将打开 SIMATIC PC 站的硬件配置。 

9. 如果没有显示硬件目录，则请选择菜单命令“视图 > 目录”(View > Catalog)。 

将打开硬件目录。 

10. 在硬件目录中的“SIMATIC PC 站 > HMI”(SIMATIC PC Station > HMI) 下，选择 
WinCC 应用程序并将其拖入组态表中。 

11. 如果要监视 PC 站和/或网络对象，则在硬件目录的“SIMATIC PC 站 > 用户应用程序 
> OPC 服务器”(SIMATIC PC Station > User application > OPC server) 下，选择 
OPC 服务器并将其拖到组态表中。 

12. 如果要使用 SIMATIC PDM，则在硬件目录的“SIMATIC PC 站 > PDM”(SIMATIC PC 
Station > PDM) 下，选择 PDM 应用程序并将其拖到组态表中。 
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13. 插入任何附加组件，例如网卡。 

对于以太网连接，推荐使用 IE 常规接口。 

14. 选择菜单命令“保存并编译站”(Save and Compile Station)，然后关闭 HW Config。 

15. 在 SIMATIC Manager 的组件视图中，选择“WinCC 应用程序”(WinCC Appl.) 层级文

件夹中的 SIMATIC PC 站下的“[OS(*)]”对象。 

* 是系统分配的编号。 

16. 选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)。 

将打开“属性 – OS：[OS 名称]”(Properties – OS: [Name of the OS]) 对话框。 

17. 在“名称”(Name) 输入字段中，输入 MS 单工作站系统的 WinCC 项目的名称。 

18. 选择“目标 OS 和备用 OS”(Target OS and Standby OS) 选项卡。 

– 在“目标 OS 计算机的路径”(Path to target OS computer) 输入框中输入目标 OS 
计算机的路径。 

– 在“符号计算机名称”(Symbolic computer name) 输入框中输入符号计算机名称。 

– 在“备用 OS”(Standby OS) 区域中，从下拉列表框中选择“>无>”(>none>)。 

19. 单击“确定”(OK)。 



 组态维护站 
 4.6 组态作为 MS 多工作站系统的 PC 站 

维护站 
功能手册, 12/2011, A5E03397308-01 39 

4.6 组态作为 MS 多工作站系统的 PC 站 

4.6.1 如何组态作为工程师站的 PC 站 

简介 

如果您已经在多重项目/项目中组态工程师站 (ES) 且正在使用 SIMATIC PDM，则只需执

行从步骤 12 开始的步骤。 

要求   

已经创建多重项目/项目。 

步骤 

1. 在 SIMATIC Manager 的组件视图中，选择要在其中插入 ES 的多重项目/项目。 

2. 选择菜单命令“插入 > 站 > SIMATIC PC 站”(Insert > Station > SIMATIC PC 
station)。 

在所选多重项目/项目中插入一个新的 SIMATIC PC 站。 

3. 选择该 SIMATIC PC 站，然后选择“编辑 > 对象属性”(Edit > Object Properties)。 

4. 在“名称”(Name) 输入字段中，输入 PC 站名称。 

5. 将“计算机名称”(Computer name) 输入框留空。 

6. 单击“确定”(OK)。 

7. 在 SIMATIC Manager 的组件视图中选择 SIMATIC PC 站。 

8. 在详细视图中，通过双击“组态”(Configuration) 对象打开 HW Config。 

将打开 SIMATIC PC 站的硬件配置。 

9. 如果没有显示硬件目录，则请选择菜单命令“视图 > 目录”(View > Catalog)。 

将打开硬件目录。 

10. 在硬件目录中的“SIMATIC PC 站 > HMI”(SIMATIC PC Station > HMI) 下，选择 
WinCC 应用程序并将其拖入组态表中。 

11. 插入任何附加组件，例如网卡。 

对于以太网连接，推荐使用 IE 常规接口。 
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12. 如果要使用 SIMATIC PDM，则在硬件目录的“SIMATIC PC 站 > PDM”(SIMATIC PC 
Station > PDM) 下，选择 PDM 应用程序并将其拖到组态表中。 

13. 选择菜单命令“保存并编译站”(Save and Compile Station)，然后关闭 HW Config。 

14. 下载组件组态器。 
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4.6.2 如何组态作为 MS 服务器的 PC 站 

简介 

如果您已经在多重项目/项目中将现有 OS 服务器用作 MS 服务器，则无需执行以下步

骤。 

要求    

已经创建多重项目/项目。 

步骤 

1. 在 SIMATIC Manager 的组件视图中，选择要在其中插入 MS 服务器的多重项目/项
目。 

2. 选择菜单命令“插入 > 站 > SIMATIC PC 站”(Insert > Station > SIMATIC PC 
station)。 

在所选多重项目/项目中插入一个新的 SIMATIC PC 站。 

3. 选择该 SIMATIC PC 站，然后选择“编辑 > 对象属性”(Edit > Object Properties)。 

4. 在“名称”(Name) 输入字段中，输入 PC 站名称。 

5. 在“计算机名称”(Computer Name) 输入框中，输入计算机的 Windows 名称。 

6. 单击“确定”(OK)。 

7. 在 SIMATIC Manager 的组件视图中选择 SIMATIC PC 站。 

8. 在详细视图中，通过双击“组态”(Configuration) 对象打开 HW Config。 

将打开 SIMATIC PC 站的硬件配置。 

9. 如果没有显示硬件目录，则请选择菜单命令“视图 > 目录”(View > Catalog)。 

将打开硬件目录。 

10. 在硬件目录中的“SIMATIC PC 站 > HMI”(SIMATIC PC Station > HMI) 下，选择 
WinCC 应用程序并将其拖入组态表中。 

11. 如果要监视 PC 站和/或网络对象，则在硬件目录的“SIMATIC PC 站 > 用户应用程序 
> OPC 服务器”(SIMATIC PC Station > User application > OPC server) 下，选择 
OPC 服务器并将其拖到组态表中。 

12. 插入任何附加组件，例如网卡。 
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13. 选择菜单命令“保存并编译站”(Save and Compile Station)，然后关闭 HW Config。 

14. 在 SIMATIC Manager 的组件视图中，选择 MS 服务器的“WinCC 应用程序”(WinCC 
Appl.) 层级文件夹中的 SIMATIC PC 站下的“[OS(*)]”对象。 

* 是系统分配的编号。 

15. 选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)。 

将打开“属性 – OS [OS 名称]”(Properties – OS [name of OS]) 对话框。 

16. 在“名称”(Name) 输入字段中，输入 MS 服务器的 WinCC 项目的名称。 

17. 选择“目标 OS 和备用 OS”(Target OS and Standby OS) 选项卡。 

– 在“目标 OS 计算机的路径”(Path to target OS computer) 输入框中输入目标 OS 
计算机的路径。 

– 在“符号计算机名称”(Symbolic computer name) 输入框中输入符号计算机名称。 

– 在“备用 OS”(Standby OS) 区域中，从下拉列表框中选择以下选项： 

如果没有冗余组态 MS 服务器，则选择“>无>”(>None>)。 

如果冗余组态 MS 服务器，则选择冗余伙伴。 仅当伙伴已组态后，才可选择伙伴。 

18. 单击“确定”(OK)。 



 组态维护站 
 4.6 组态作为 MS 多工作站系统的 PC 站 

维护站 
功能手册, 12/2011, A5E03397308-01 43 

4.6.3 如何组态作为冗余伙伴的 PC 站 

简介 

如果您已经在多重项目/项目中使用 OS 服务器的冗余伙伴，则不需要执行以下步骤。 

要求    

已经创建多重项目/项目。 

步骤 

1. 在 SIMATIC Manager 的组件视图中，选择要在其中插入冗余伙伴的多重项目/项目。 

2. 选择菜单命令“插入 > 站 > SIMATIC PC 站”(Insert > Station > SIMATIC PC 
station)。 

在所选多重项目/项目中插入一个新的 SIMATIC PC 站。 

3. 选择该 SIMATIC PC 站，然后选择“编辑 > 对象属性”(Edit > Object Properties)。 

4. 在“名称”(Name) 输入字段中，输入 PC 站名称。 

5. 在“计算机名称”(Computer Name) 输入框中，输入计算机的 Windows 名称。 

6. 单击“确定”(OK)。 

7. 在 SIMATIC Manager 的组件视图中选择 SIMATIC PC 站。 

8. 在详细视图中，通过双击“组态”(Configuration) 对象打开 HW Config。 

将打开 SIMATIC PC 站的硬件配置。 

9. 如果没有显示硬件目录，则请选择菜单命令“视图 > 目录”(View > Catalog)。 

将打开硬件目录。 

10. 在硬件目录中的“SIMATIC PC 站 > HMI”(SIMATIC PC Station > HMI) 下，选择 
WinCC 应用程序 (stby) 并将其拖入组态表中： 

11. 插入任何附加组件，例如网卡。 

12. 选择菜单命令“保存并编译站”(Save and Compile Station)，然后关闭 HW Config。 

13. 在 SIMATIC Manager 的组件视图中，选择“WinCC 应用程序”(WinCC Appl.) 层级文

件夹（备用）中 SIMATIC PC 站下的“[OS(*)_StBy]”对象。 

* 是系统分配的编号。 
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14. 选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)。 

将打开“属性 – 备用 OS：[OS 名称]”(Properties – Standby OS: [Name of the OS]) 对
话框。 

15. 选择“目标 OS 和主 OS”(Target OS and Master OS) 选项卡，并输入目标 OS 计算

机的路径。 

16. 单击“确定”(OK)。 
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4.6.4 如何组态作为 MS 或 OS/MS 客户端的 PC 站 

简介    

如果您已经在多重项目/项目中将现有 OS 客户端用作 OS/MS 客户端，则不需要执行以下

步骤。 

可以在工程师站或单独的 PC 上运行 MS 客户端或 OS/MS 客户端。 
 

 说明 
如果在工程师站上运行 MS 客户端，并且已经在项目或多重项目（例如 OS 仿真）中为工

程师站创建了 PC 站，则无法在工程师站的“计算机名称”(Computer name) 输入框中输入

任何名称。 
 

要求 

已经创建多重项目/项目。 

步骤 

1. 在 SIMATIC Manager 的组件视图中，选择要在其中插入 MS 客户端的多重项目/项
目。 

2. 选择菜单命令“插入 > 站 > SIMATIC PC 站”(Insert > Station > SIMATIC PC 
station)。 

在所选多重项目/项目中插入一个新的 SIMATIC PC 站。 

3. 选择该 SIMATIC PC 站，然后选择“编辑 > 对象属性”(Edit > Object Properties)。 

4. 在“名称”(Name) 输入字段中，输入 PC 站名称。 

5. 在“计算机名称”(Computer name) 输入字段中，输入名称。 

– 如果要在单独 PC 站上运行 MS 客户端，则输入目标计算机的 Windows 计算机名

称。 

– 如果要在工程师站上运行 MS 客户端作为 MS 客户端，则输入工程师站的 Windows 
计算机名称。 

6. 单击“确定”(OK)。 

7. 在 SIMATIC Manager 的组件视图中选择 SIMATIC PC 站。 
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8. 在详细视图中，通过双击“组态”(Configuration) 对象打开 HW Config。 

将打开 SIMATIC PC 站的硬件配置。 

9. 如果没有显示硬件目录，则请选择菜单命令“视图 > 目录”(View > Catalog)。 

将打开硬件目录。 

10. 在硬件目录中的“SIMATIC PC 站 > HMI”(SIMATIC PC Station > HMI) 下，选择 
WinCC 应用程序客户端并将其拖到组态表中。 

11. 插入其它组件。 

12. 选择菜单命令“保存并编译站”(Save and Compile Station)，然后关闭 HW Config。 

13. 在 SIMATIC Manager 的组件视图中，选择 MS 客户端的 SIMATIC PC 站下的

“[OSC]”对象。 

14. 选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)。 

将打开“属性 – 客户机 OS：[OS 名称]”(Properties – Client OS: [Name of the OS]) 对
话框。 

15. 在“名称”(Name) 输入字段中，输入 MS 客户端的 WinCC 项目的名称。 

16. 单击“确定”(OK)。 
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4.7 组态作为 SIMATIC MS PDM 的 PC 站 

要求     

已创建项目。 

步骤 

1. 在 SIMATIC Manager 的组件视图中，选择要在其中插入 SIMATIC MS PDM 的项目。 

2. 选择菜单命令“插入 > 站 > SIMATIC PC 站”(Insert > Station > SIMATIC PC 
station)。 

在所选多重项目/项目中插入一个新的 SIMATIC PC 站。 

3. 选择该 SIMATIC PC 站，然后选择“编辑 > 对象属性”(Edit > Object Properties)。 

4. 在“名称”(Name) 输入字段中，输入 PC 站名称。 

5. 在“计算机名称”(Computer Name) 输入框中，输入计算机的 Windows 名称。 

6. 单击“确定”(OK)。 

7. 在 SIMATIC Manager 的组件视图中选择 SIMATIC PC 站。 

8. 在详细视图中，通过双击“组态”(Configuration) 对象打开 HW Config。 

将打开 SIMATIC PC 站的硬件配置。 

9. 如果没有显示硬件目录，则请选择菜单命令“视图 > 目录”(View > Catalog)。 

将打开硬件目录。 

10. 在硬件目录中的“SIMATIC PC 站 > 控制器 > WinLC RTX”(SIMATIC PC 
Station > Controller > WinLC RTX) 下，选择所需的“WinLC-RTX”应用程序并将其拖到

组态表中。 

  说明 
请注意，只能添加一个 WinLC RTX。 

11. 在硬件目录中的“SIMATIC PC 站 > HMI”(SIMATIC PC Station > HMI) 下，选择 
WinCC 应用程序并将其拖入组态表中。 

12. 如果要监视 PC 站和/或网络对象，则在硬件目录的“SIMATIC PC 站 > 用户应用程序 
> OPC 服务器”(SIMATIC PC Station > User application > OPC server) 下，选择 
OPC 服务器并将其拖到组态表中。 
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13. 在硬件目录中的“SIMATIC PC 站 > PDM”(SIMATIC PC Station > PDM) 下，选择 
PDM 应用程序并将其拖到组态表中。 

14. 插入任何附加组件，例如网卡。 

对于以太网连接，推荐使用 IE 常规接口。 

15. 选择菜单命令“保存并编译站”(Save and Compile Station)，然后关闭 HW Config。 

16. 在 SIMATIC Manager 的组件视图中，选择“WinCC 应用程序”(WinCC Appl.) 层级文

件夹中的 SIMATIC PC 站下的“[OS(*)]”对象。 

* 是系统分配的编号。 

17. 选择菜单命令“编辑 > 对象属性”(Edit > Object Properties)。 

将打开“属性 – OS：[OS 名称]”(Properties – OS: [Name of the OS]) 对话框。 

18. 在“名称”(Name) 输入字段中，输入 SIMATIC MS PDM 的 WinCC 项目的名称。 

19. 选择“目标 OS 和备用 OS”(Target OS and Standby OS) 选项卡。 

– 在“目标 OS 计算机的路径”(Path to target OS computer) 输入框中输入目标 OS 
计算机的路径。 

– 在“符号计算机名称”(Symbolic computer name) 输入框中输入符号计算机名称。 

– 在“备用 OS”(Standby OS) 区域中，从下拉列表框中选择“>无>”(>none>)。 

20. 单击“确定”(OK)。 
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4.8 组态 IE/PB Link PN IO 

简介 

IE/PB Link PN IO 链路模块用作网关，以确保 SIMATIC MS PDM 有权访问与下级 
PROFIBUS 连接的所有 PROFIBUS DP 从站。 

IE/PB Link PN IO 链路模块连接两种网络类型，即工业以太网和 PROFIBUS。 

要求 

已创建项目。 

步骤 1 - 创建 SIMATIC 300 站 

1. 在 SIMATIC Manager 的组件视图中选择要在其中插入 SIMATIC 300 站的项目。 

2. 选择菜单命令“插入 > 站 > SIMATIC 300 站”(Insert > Station > SIMATIC 300 
station)。 

在所选项目中插入一个新的 SIMATIC 300 站。 

3. 选择该 SIMATIC PC 站，然后选择“编辑 > 对象属性”(Edit > Object Properties)。 

4. 在“名称”(Name) 输入字段中，输入 SIMATIC 300 站的名称。 

5. 单击“确定”(OK)。 

步骤 2 - 在 SIMATIC 300 站中组态 IE/PB Link PN IO 链路模块 

1. 在 SIMATIC Manager 的组件视图中选择 SIMATIC 300 站。 

2. 在详细视图中，通过双击“硬件”(Hardware) 对象打开 HW Config。 

将打开 SIMATIC 300 站的硬件配置。 

3. 如果没有显示硬件目录，则请选择菜单命令“视图 > 目录”(View > Catalog)。 

4. 在硬件目录下的“SIMATIC 300”中选择设备类型“网关 – IE/PB Link PN IO”(Gateway – 
IE/PB Link PN IO)。 

  说明 
请注意，IE/PB Link PN IO 链路模块是特殊的组态组件。 
除了该组件之外，其它组件（例如方形导轨或模块）均不能放置在 S7-300 站中。 

5. 创建一个以太网。 
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6. 使用以下数据为以太网分配参数： 

– IP 地址 

– S7 子网 ID 

7. 创建一个 PROFIBUS 网络。 

8. 使用以下数据为 PROFIBUS 网络分配参数： 

– 地址 

– “无 DP”模式 

9. 针对 IE/PB Link PN IO 链路模块选中“激活数据记录网关”(Activate data record 
gateway) 复选框。 

10. 将参数传送到 IE/PB Link PN IO 链路模块。 

11. 记下以下信息： 

– 以太网的 S7 子网 ID 和 IP 地址 

– PROFIBUS 网络的 DP 主站地址 

12. 对所有其它 IE/PB Link PN IO 链路模块重复上述步骤。 

  说明 
对于所有其它 IE/PB Link PN IO 链路模块，以太网均使用相同的 S7 子网 ID。 
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步骤 3 - 在过程设备网络视图中组态 IE/PB Link PN IO 链路模块 

1. 在过程设备网络视图中组态一个以太网。 

2. 使用 S7 子网 ID 为以太网分配参数。 

3. 在此以太网中组态 IE/PB Link PN IO 链路模块。 

4. 使用以下数据为 IE/PB Link PN IO 链路模块分配参数： 

– S7 子网 ID 

– 相应的 IP 地址 

– 相应的 DP 主站地址 

5. 对所有其它 IE/PB Link PN IO 链路模块重复上述步骤。 

更多信息 

有关此主题的更多信息，请参见手册《SIMATIC NET；用于工业以太网的 S7-CP》和

《PCS 7 过程控制系统；SIMATIC PDM》。 
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4.9 组态 PC 站和网络对象的监视 

4.9.1 要求 

简介       
 

 说明 
对于下列维护站版本，可以监视 PC 站和网络对象： 

 基本 MS 

 标准 MS 

 SIMATIC MS PDM（可选） 
 

下表列出的程序或服务必须可用且必须组态以监视 PC 站和网络对象。 

 

应用/服务 MS 单工作站系统 MS 多工作站系统 SIMATIC MS PDM 

OPC 服务器 

NDIS 适配器 

 MS 服务器 

 MS 服务器的冗

余伙伴 

SNMP 服务 

诊断监视器 

MS 单工作站系统 

在每个要监视的 IPC 
上 

SIMATIC MS PDM 
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程序和服务 

● OPC 服务器 

– OPC（用于过程控制的 OLE）是自动化工程组态中进行数据交换的接口。 

– 其在 HW Config 中设置。 

有关这方面的信息，请参见以下部分。 

● NDIS 适配器 

– 用于在通过通信处理器 (CP 1623 / CP 1613) 访问工厂总线时监视工厂总线上的组

件。 

– 必须组态 NDIS 适配器。 

有关这方面的详细信息，可参考手册《过程控制系统 PCS 7；PC 组态与授权》

(Process Control System PCS 7; PC Configuration and Authorization)。 
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● SNMP 服务 

– SNMP 是指用于管理网络的简单网络管理协议。 

– 必须组态 SNMP 服务。 

有关这方面的详细信息，可参考手册《过程控制系统 PCS 7；PC 组态与授权》

(Process Control System PCS 7; PC Configuration and Authorization)。 

要包括到诊断中具有 SNMP 功能的组件必须具有网络连接。 

● 诊断监视器 

– “诊断监视器”是为 SIEMENS 工业 PC 提供所需诊断数据的诊断工具。 

– 可在过程控制面板的上部调用“诊断监视器”。 

– 必须安装并组态“诊断监视器”。 

有关这方面的详细信息，可参考手册《过程控制系统 PCS 7；PC 组态与授权》

(Process Control System PCS 7; PC Configuration and Authorization)。 

– 其它设置 

启动 Web 服务器 

启动“管理浏览器”。 

选择“选项 > Web 服务器”(Options > Web server)。 

对于采用用户帐户管理的系统，必须以高级权限启动“管理浏览器”。 

在 Windows 防火墙中授权诊断监视器 Web 服务器 

开启防火墙。 

为“MiniWebService.exe”程序创建一条新的例外/规则。 

通过 Windows“开始”(Start) 菜单的子菜单

“SIMATIC > DiagnosticManagement > WebServer > Bin”访问此文件。 
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4.9.2 设备规约和区域 

简介 

如果在 OPC 服务器中组态 SNMP 兼容的组件，则必须将设备规约和团体分配给此 
SNMP 兼容的组件。 

概述 

下表显示了团体到设备规约的分配。    

 

组件 设备配置文件 区域 

SCALANCE 系列 X200 Profil_SCALANCE_X200_Vxy.txt 

SCALANCE 系列 X300 

SCALANCE 系列 X400 

Profil_SCALANCE_X300X400_Vxy.t
xt 

SCALANCE 系列 W700 Profil_SCALANCE_W700_Vxy.txt 

ESM/OSM Profil_OSM_Vxy.txt 

公共 

Siemens IPC（工业 PC） Profil_IPC_Vxy.txt SOL 

其它设备， 
例如第三方 PC、用于 
SIMATIC PCS 7 的高级服务器、

网络适配器、交换机 

MIB-II_V10.txt 确定在设备中组态的团体。 

所有通过导入集成的但不显示的设

备 
无 SNMP  
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4.9.3 如何将带有 SNMP 功能的组件分配给 OPC 服务器 

命名规则 

命名带有 SNMP 功能的组件时，需要考虑以下几点： 

● 模块名称中请勿包含空格或特殊字符。 

● 对于 IPC，指定的模块名称应该与 SIMATIC Manager 中该 IPC 的计算机名称相同。 

● 对于所有其它模块，指定的模块名称不能与项目中 PC 站的当前计算机名称相同。 

● 如果在组态中使用了两个独立的以太网网络，请确保模块名称和 IP 地址在网络中唯

一。 

要求   

● 已完成 PC 对象和网络对象的 HW 组态。 

● 已插入 OPC 服务器。 

有关此主题的更多信息，请参见以下部分： 

– 组态作为 MS 单工作站系统的 PC 站 (页 37) 

– 如何组态作为 MS 服务器的 PC 站 (页 41) 

– 组态作为 SIMATIC MS PDM 的 PC 站 (页 47) 

步骤 

1. 在 HW Config 中选择 OPC 服务器，然后选择菜单命令“编辑 > 对象属性...”(Edit > 
Object Properties...)。 

将打开“属性 - OPC 服务器”(Properties – OPC server) 对话框。 

2. 打开“SNMP”选项卡。 

3. 在“循环时间”(Cycle time) 输入框中输入至少 1000 ms。 

4. 单击“编辑工厂组态”(Edit plant configuration)。 

将打开“编辑工厂组态”(Edit plant configuration) 对话框。 
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5. 单击“导入”(Import)。 

将导入项目中组态有 IP 地址的所有对象。 

  说明 
导入 CP 1623 / CP 1613 时，会导入 HW Config 的 IP 地址。 必要时，请使用 NDIS 
IP 地址替换该 TCP/IP 地址。 

6. 双击该节点。 

将打开“编辑节点”(Edit node) 对话框。 

7. 为已导入的设备输入下列数据。 

– 名称 (Name)： 

请输入一个名称。 

– IP 地址 (IP address)： 

必要时，请更改该 IP 地址。 

– 设备配置文件和区域 (Device profile and community)： 

有关此主题的更多信息，请参见“设备规约和区域 (页 55)”部分。 
 

  说明 
注意：这些区域名称的输入区分大小写。  
“编辑节点”(Edit Node) 和“添加节点”(Add Node) 对话框中的区域名称必须与相应

设备上存储的区域名称相匹配。 

– 超时 (Timeout)： 

请输入 9000  ms 或更大值，这取决于要监视的组件数目。 

– SNMP 优化 (SNMP optimization) 

选中该复选框。 

– 注释 (Comment): 

请在该字段中输入一段注释。 此注释显示在过程控制系统的面板中。 

8. 单击“确定”(OK)。 

将关闭“编辑节点”(Edit nodes) 对话框，并返回到“编辑工厂组态”(Edit plant 
configuration) 对话框。 
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9. 如果要插入 IPC 或其它带有 SNMP 功能的组件，请单击“添加”(Add) 按钮。 

将打开“添加节点”(Add node) 对话框。 

10. 输入所有需要的数据。 

执行第 7 步中所述的操作。 

11. 单击“确定”(OK)。 

将关闭“添加节点”(Add node) 对话框，并返回到“编辑工厂组态”(Edit plant 
configuration) 对话框。 

12. 根据需要插入其它节点。 

13. 单击“导出用于 WinCC 的变量”(Export tags for WinCC)。 
系统将为带有 SNMP 功能的组件生成全部变量和消息。 

14. 单击“确定”(OK)。 

将完成组态。 

15. 编译和下载硬件配置。 

更多相关信息，请参见手册《过程控制系统 PCS 7；工程组态系统》。 

16. 创建/更新诊断画面。 

有关此主题的更多信息，请参见“创建/更新诊断画面 (页 92)”部分。 

创建/更新诊断画面之后，需要执行以下步骤： 

– 在 MS 单工作站系统中，编译 MS。 

– 在 MS 多工作站系统中，编译并下载 MS 服务器。 
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4.9.4 如何将 OPC 服务器插入冗余伙伴 

要求   

已在 MS 服务器中组态 OPC 服务器。 

有关此主题的详细信息，请参见“如何将带有 SNMP 功能的组件分配给 OPC 服务器 
(页 56)”部分。 

步骤 

1. 在 SIMATIC Manager 中，打开组件视图。 

2. 选择 MS 服务器的 SIMATIC PC 站。 

3. 在详细视图中，通过双击“组态”(Configuration) 对象打开 HW Config。 

将打开 SIMATIC PC 站的硬件配置。 

4. 选择 OPC 服务器。 

5. 从菜单中选择编辑 > 复制 (Edit > Copy)。 

6. 选择作为冗余伙伴的 SIMATIC PC 站。 

7. 在详细视图中，通过双击“组态”(Configuration) 对象打开 HW Config。 

将打开 SIMATIC PC 站的硬件配置。 

8. 选择 OPC 服务器的位置。 

9. 选择“编辑”(Edit) >“粘贴”(Paste) 命令。 

10. 选择“站”(Station) >“保存并编译”(Save and Compile) 命令。 
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4.9.5 如何将 OPC 组态传送到 WinCC 项目 

简介 

具有 SNMP 功能的所有组件的数据变量、报警变量和报警文本通过变量导出在 WinCC 
项目中生成。 

要求 

在 WinCC 项目中创建了“诊断”区域。    

步骤 

1. 在 HW Config 中选择 OPC 服务器，然后选择编辑 > 对象属性... (Edit > Object 
Properties...)。 

将打开“属性 - OPC 服务器”(Properties – OPC server) 对话框。 

2. 打开“SNMP”选项卡。 

3. 在“变量导出”(Tag export) 组中，选中以下复选框 

– 在初始变量导出时选中“导出完整工厂组态”(Export complete plant configuration) 

– 在所有后续变量导出时选中“仅导出更改”(Export changes only) 

4. 单击“导出用于 WinCC 的变量”(Export Tags for WinCC)。 

5. 单击“确定”(OK)。 

对话框关闭。 
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4.9.6 在过程控制期间显示带有 SNMP 功能的组件 

显示 

在过程控制期间，带有 SNMP 功能的组件在总览画面中映射为 PC 对象或网络对象：   

● PC 对象 

已在 SIMATIC Manager 中保存为 PC 站并在 OPC 服务器的 SNMP 组态中为其分配

了规约 IPC_v** 或 MIB II_V10 的 PC 站显示在此处。 

● 网络对象 

在 OPC 服务器的 SNMP 组态中已组态，但尚未在 SIMATIC Manager 中保存为 PC 
站的所有其它组件显示在此处。 

网络对象“通信处理器” 

如果要将通信处理器 CP 1623 / CP 1613 映射为网络对象，请使用“属性”(Properties) 按
钮激活 TCP/IP 协议，此按钮位于 HW Config 界面区域“常规”(General) 选项卡中 PC 站
的对象属性中。   
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4.10 创建诊断结构 

4.10.1 有关诊断结构和工厂层级的信息 

工厂层级中的诊断结构     

诊断结构是工厂层级中的文件夹结构，由系统自动创建。 层级数限制为 8 个。 

诊断层级文件夹是顶部层级文件夹；其映射 OS 的区域构成层次（过程控制总览中的区域

选择按钮）。 根据工厂层级中设置的 OS 区域层次，最多创建三个名为“诊
断”(Diagnostics) 的文件夹。 

名称为“AS 对象”(AS objects)、“现场设备”(field devices)、“网络对象”(network objects) 
和“PC 站”(PC stations) 的层级文件夹在映射 OS 区域的诊断层级文件夹下的相同层级中

创建。 维护站的版本和现有对象决定创建的层级文件夹。 

无法更改自动生成的层级文件夹的名称。 

工厂层级中的设置 

在“工厂层级 - 设置”(Plant hierarchy - Settings) 对话框中对维护站进行以下设置： 

● 层级数 (1) 

● OS 的区域构成层次 (1) 

● 创建诊断结构 

● 维护站的版本 

● 获取 PH 中的名称的设置 

● 维护站的选择 

(1) 注： 适用于所有多项目/项目 

有关工厂层级的设置的组态的信息，请参见以下部分。 

更多信息 

有关此主题的更多信息，请参见“诊断结构和版本之间的关系 (页 66)”部分。 
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4.10.2 如何在工厂层级中进行设置 

MS 单工作站系统和 MS 多工作站系统的要求      

● 已经创建多项目/项目。 

● 已完成硬件组态。 

● 已完成网络组态。 

● 所有组件的基本参数分配可在离线状态完成。 

SIMATIC MS PDM 的要求 

● 该项目没有创建为多重项目。 

● 已完成硬件配置 

● 已完成工厂组态。 

● 已完成 PC 站和网络组件（可选）的组态。 

● 已完成 LID 和 TAG 相关组件的命名。 

● 已组态过程设备网络视图中的所有组件。 

● 已组态所用的 IE/PB Links PN IO。 

步骤 

1. 在 SIMATIC Manager 中打开工厂视图。 

2. 在树形视图中，选择该对象： 

– 如果使用多项目，请选择对象“[项目的名称] MP”。 

– 如果使用单项目，请选择对象“[项目的名称]”。 

3. 选择菜单命令选项 > 工厂层级 > 设置... (Options > Plant Hierarchy > Settings...)。 

4. 如果已选择多重项目，将打开“工厂层级 - 设置”(Plant Hierarchy - Settings) 对话框。 

选择要将其设置用作工厂层级模板的项目。 

– 单击“确定”(OK)。 
将打开“工厂层级 - 设置”(Plant Hierarchy - Settings) 对话框。 

– 转到第 6 步。 
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5. 如果选择了一个单项目或多项目中的某个项目，将打开“工厂层级 - 设置”(Plant 
Hierarchy - Settings) 对话框。 

6. 定义相应级别的设置。 

请记住，多重项目/项目中的工厂层级设置将统一。 

7. 激活“从工厂层级获得画面层级”(Derive picture hierarchy from the plant hierarchy) 
复选框。 

8. 启用“从工厂层级获得诊断画面”(Derive diagnostics screens from the plant 
hierarchy) 复选框。 

9. 指定版本。 

启用相应的选项按钮： 

–  “标准维护站（具有所有功能）”(Maintenance Station Standard (full functionality)) 
选项按钮 

– “基本维护站（无详细信息）”(Maintenance Station Basic (no detailed 
information)) 选项按钮 

– “PDM 维护站（单个应用程序）”(Maintenance Station PDM (stand-alone 
application)) 选项按钮 

10. 创建/更新诊断画面时，指定是否应从硬件组件的名称或注释获得已创建的层级文件夹

的名称。 启用相应的选项按钮： 

– “根据硬件组件的名称产生 PH 名称”(Derive PH names from the names of the 
hardware components) 选项按钮 

– “根据硬件组件的名称产生 PH 名称”(Derive PH names from the names of the 
hardware components) 选项按钮 

由于注释文本没有字符个数限制，因此可以使用任意类型的名称。 

11. 单击“确定”(OK)。 
将打开“定义维护站”(Define maintenance station) 对话框并显示多重项目/项目中的所

有可用 OS。 

12. 选择要定义为维护站的 OS。 

13. 单击“确定”(OK)。 
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结果 

在多重项目中，“诊断”(Diagnostics) 层级文件夹会插入到该多重项目的所有项目中。  

● 在具有 MS 服务器的项目中会自动创建标准诊断结构，其中包括层级文件夹“AS 对
象”(AS Objects)、“网络对象”(Network Objects) 和“PC 站”(PC Stations)。 用户诊断的

结构必须手动创建。 

● 在多重项目的其它项目中，只会在诊断结构中自动创建“AS 对象”(AS objects) 层级

文件夹。 

如果激活 OS 区域的第二层或第三层，将在工厂层级中创建一个具有两个或三个“诊
断”(Diagnostics) 文件夹的结构。 
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4.10.3 诊断结构和版本之间的关系 

简介 

根据维护站版本的不同会以不同的方式创建诊断结构。 

诊断结构 MS 基本版本    

下表给出了诊断结构的示例。 

 

级别 

1 2 3 4 5 6 7 8 

诊断 AS 对象 

 网络对象 

 PC 站 

- 

诊断结构 MS 标准版本 

下表给出了诊断结构的示例。 

 

级别 

1 2 3 4 5 6 7 8 

AS 对象 AS 详细视

图 
- 

模块 HART 现
场设备 

- 

AS 对象 

DP 主站系统 DP 节点 

PA 现场设

备 
- 

网络对象 

PC 站 

- 

诊断 

用户对象 取决于工厂层级中的组态 
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诊断结构 SIMATIC MS PDM 版本 

下表给出了诊断结构的示例。 

 

级别 

1 2 3 4 5 6 7 8 

现场设备 取决于 SIMATIC PDM 中的组态  

网络对象 

诊断 

PC 站 

- 
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4.11 高级诊断设置 

4.11.1 创建维护链接 

简介    

在过程控制中，可以在面板的总览画面和标题区域中调用可自由组态的 Web 页面的链

接；这些 Web 页面用于支持诊断措施。 

系统会自动创建三个链接对象。  
 

 说明 
如果组态 MS 标准版本的维护站，则可使用此功能。 

 

自动生成的链接对象 

● Maintenance-Link1 

● Maintenance-Link2 

● Maintenance-Link3 

规则 

● 维护链接对于整个多项目/项目始终有效。 

● 链接对象的数量不可超过 3 个。 

● 可以重命名、删除和重新生成自动生成的链接对象。 

● 目标对象的名称不可超过 24 个字符。 

● Web 地址最多包含 256 个字符。 

● 在链接对象的对象属性中组态 Web 页面的名称和 Web 地址。 

  说明 
用户负责确保 Web 界面的可访问性。 

要求 

维护站已创建。 
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步骤 

下文说明了如何组态、更改和删除链接对象。 

要打开“高级诊断设置”(Advanced diagnostics settings) 对话框，请执行以下步骤。 

1. 在 SIMATIC Manager 中打开工厂视图。 

2. 在树形视图中，选择该对象： 

– 如果使用多项目，请选择对象“[项目的名称] MP”。 

– 如果使用单项目，请选择对象“[项目的名称]”。 

3. 选择菜单命令选项 > 工厂层级 > 高级诊断设置... (Options > Plant Hierarchy > 
Advanced Diagnostics Settings...)。 

将打开“高级诊断设置”(Advanced Diagnostics Settings) 对话框。 

添加维护链接 

1. 在“高级诊断设置”(Advanced diagnostics settings) 对话框中，单击“维护链

接”(Maintenance links) 区域中的“添加...”(Add...)。 

将打开“添加维护链接”(Add maintenance link) 对话框。 

2. 在“名称：”(Name:) 输入字段中，输入链接对象的名称。 

3. 在“URL：”(URL:) 中输入 Web 地址。 . 

4. 单击“确定”(OK)。 

将关闭“添加维护链接”(Add maintenance link) 对话框。 

5. 单击“确定”(OK)。 

将关闭“高级诊断设置”(Advanced diagnostics settings) 对话框。 

更改维护链接属性 

1. 在“高级诊断设置”(Advanced diagnostics settings) 对话框中，单击“维护链

接”(Maintenance links) 区域中的“属性...”(Properties...) 按钮。 

将打开“维护链接属性”(Maintenance link properties) 对话框。 

2. 进行相应的更改。 

3. 单击“确定”(OK)。 

将关闭“维护链接属性”(Maintenance link properties) 对话框。 

4. 单击“确定”(OK)。 

将关闭“高级诊断设置”(Advanced diagnostics settings) 对话框。 
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删除维护链接 

1. 在“高级诊断设置”(Advanced diagnostics settings) 对话框中，单击“维护链

接”(Maintenance links) 区域中的“属性...”(Properties...) 按钮。 

2. 单击“确定”(OK)。 

将关闭“高级诊断设置”(Advanced diagnostics settings) 对话框。 
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4.11.2 创建维护目标 

简介    

可组态各种维护目标以存储单个导出文件；提供这些目标以在面板的“维护”视图中进行

选择。 

系统将自动创建一个默认目标。 
 

 说明 
如果组态 MS 标准版本的维护站，则可使用此功能。 

 

自动创建的目标对象 

系统自动创建具有以下名称和路径的默认目标：  

● 名称： 默认目标 

● 路径： 项目目录 ...\wincproj\<os 名称> 

目标目录 

目标目录可以组态为绝对目录，也可以组态为相对目录。 

 

目标目录 目标目录示例 存储位置 

绝对目录 D:\folder 在导出开始时作为主站的 MS 服务器

的组态路径下 

相对目录 \\计算机名称\共享驱动器\文件

夹 
在指定计算机的组态路径下 

 

 

 说明 
对于具有 MS 服务器和备用 MS 服务器的工厂组态，建议将目标目录组态为相对目录。 
这可确保导出文件始终存储在同样的“位置”，而不管启动导出操作时哪台 MS 服务器为主

站。 
 



组态维护站  
4.11 高级诊断设置 

 维护站 
72 功能手册, 12/2011, A5E03397308-01 

规则 

● 维护目标对于整个多项目/项目始终有效。 

● 目标对象的名称不可超过 24 个字符。 

● UNC 路径的最大长度为 256 个字符。 

要求 

维护站已创建。 

步骤 

下文说明了如何组态、更改和删除目标对象。 

要打开“高级诊断设置”(Advanced diagnostics settings) 对话框，请执行以下步骤。 

1. 在 SIMATIC Manager 中打开工厂视图。 

2. 在树形视图中，选择该对象： 

– 如果使用多项目，请选择对象“[项目的名称] MP”。 

– 如果使用单项目，请选择对象“[项目的名称]”。 

3. 选择菜单命令选项 > 工厂层级 > 高级诊断设置... (Options > Plant Hierarchy > 
Advanced Diagnostics Settings...)。 

将打开“高级诊断设置”(Advanced Diagnostics Settings) 对话框。 

组态维护目标 

1. 在“高级诊断设置”(Advanced diagnostics settings) 对话框中，单击“维护目

标”(Maintenance targets) 区域中的“添加...”(Add...)。 

将打开“添加维护目标”(Add maintenance target) 对话框。 

2. 在“名称：”(Name:) 输入字段中，输入目标对象的名称。 

3. 单击“浏览”(Browse)。 

4. 选择所需的目标目录。 

在输入字段“路径：”(Path:) 中将显示该目标目录。 
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5. 单击“确定”(OK)。 

将关闭“添加维护目标”(Add maintenance targets) 对话框。 

6. 单击“确定”(OK)。 

将关闭“高级诊断设置”(Advanced diagnostics settings) 对话框。 

更改维护目标的属性 

1. 在“高级诊断设置”(Advanced diagnostics settings) 对话框中，单击“维护目

标”(Maintenance targets) 区域中的“属性...”(Properties...)。 

将打开“维护目标属性”(Maintenance target properties) 对话框。 

2. 进行相应的更改。 

3. 单击“确定”(OK)。 

将关闭“维护目标属性”(Maintenance target properties) 对话框。 

4. 单击“确定”(OK)。 

将关闭“高级诊断设置”(Advanced diagnostics settings) 对话框。 

删除维护目标 

1. 在“高级诊断设置”(Advanced diagnostics settings) 对话框中，单击“维护目

标”(Maintenance targets) 区域中的“属性...”(Properties...)。 

2. 单击“确定”(OK)。 

将关闭“高级诊断设置”(Advanced diagnostics settings) 对话框。 
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4.11.3 创建维护操作 

简介   

在过程控制期间，维护工程师可以为“请求的操作”(Requested action) 区域的下拉列表

中的所需维护措施分配一项操作，该区域在“维护”(Maintenance) 视图的面板中。  

该操作存储在操作对象中。  

系统将自动创建操作对象。 可以更改或删除这些操作对象。  

可以组态其它操作对象。 

如果要在过程控制期间更改语言，则必须以相应语言组态文本。 组态文本之前，必须将

要组态的文本的语言定义为默认语言。 在 SIMATIC Manager 中，通过“选项 > 显示设备

的语言”(Options > Language for Display Devices) 菜单命令设置语言。 
 

 说明 
如果组态 MS 标准版本的维护站，则可使用此功能。 

 

自动创建的操作对象 

● 拆卸 

● 更换设备 

● 校准 

● 调零设置 

● 清洗 

● 服务 

● 其它 

规则 

● 维护操作对于整个多项目/项目始终有效。 

● 操作对象的名称长度不能超过 24 个字符。 
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要求 

● 维护站已创建。 

● 默认语言已设置。 

步骤 

下文说明了如何组态、更改和删除操作对象。 

要打开“高级诊断设置”(Advanced diagnostics settings) 对话框，请执行以下步骤。 

1. 在 SIMATIC Manager 中打开工厂视图。 

2. 在树形视图中，选择该对象： 

– 如果使用多项目，请选择对象“[项目的名称] MP”。 

– 如果使用单项目，请选择对象“[项目的名称]”。 

3. 选择菜单命令选项 > 工厂层级 > 高级诊断设置... (Options > Plant Hierarchy > 
Advanced Diagnostics Settings...)。 

将打开“高级诊断设置”(Advanced Diagnostics Settings) 对话框。 

添加维护操作 

1. 在“高级诊断设置”(Advanced diagnostics settings) 对话框中，单击“维护操

作”(Maintenance actions) 区域中的“添加...”(Add...)。 

将打开“添加维护操作”(Add maintenance action) 对话框。 

2. 在“名称：”(Name:) 输入字段中，输入目标对象的名称。 

该名称将应用到“操作员的名称：”(Name for operator:) 输入字段中。 

如果要编辑一个其它语言的项目，则在此处输入该语言的名称。 

3. 单击“确定”(OK)。 

将关闭“添加维护操作”(Add maintenance actions) 对话框。 

4. 单击“确定”(OK)。 

将关闭“高级诊断设置”(Advanced diagnostics settings) 对话框。 
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更改维护操作的属性 

1. 在“高级诊断设置”(Advanced diagnostics settings) 对话框中，单击“维护操

作”(Maintenance actions) 区域中的“属性...”(Properties...)。 

将打开“维护操作属性”(Maintenance action properties) 对话框。 

2. 进行相应的更改。 

3. 单击“确定”(OK)。 

将关闭“维护操作属性”(Maintenance action properties) 对话框。 

4. 单击“确定”(OK)。 

将关闭“高级诊断设置”(Advanced diagnostics settings) 对话框。 

删除维护操作 

1. 在“高级诊断设置”(Advanced diagnostics settings) 对话框中，单击“维护操

作”(Maintenance action) 区域中的“删除”(Delete)。 

2. 单击“确定”(OK)。 

将关闭“高级诊断设置”(Advanced diagnostics settings) 对话框。 
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4.12 组态用户诊断 

4.12.1 概述 

简介 

可以通过用户诊断监视那些不具有自我诊断功能的被动或间接组件（例如，泵、电机、控

制环路）。 为此，需在诊断结构中创建“用户”区域。   

可以在“用户”区域执行以下任务： 

● 创建单独的诊断结构 

● 创建项目特定的诊断规则 

● 组态条件监视功能 
 

 说明 
您只能在 MS 标准版本中使用用户诊断。 

 

用户诊断结构 

在工厂层级中，可以在“诊断”(Diagnostics) 层级文件夹中创建一个层级文件夹，并在此

层级文件夹中创建附加的层级子文件夹，以基于工艺特点构建用户诊断结构。 

在用户诊断结构中，可以为每个层级文件夹插入一个自己创建的诊断画面和 CFC 图表。  

可以在诊断画面中添加按钮，以便在用户创建的诊断画面与自动创建的诊断画面之间进行

切换。 

诊断功能是使用不同的块（例如集成在 CFC 图表中的 AssetM）执行的。 
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使用 AssetM 块的诊断功能 

“AssetM”块具有替代对象的功能，用于监视不具有自诊断功能的组件。 

可以使用“AssetM”块监视三个模拟值。 

可以监视每个模拟值是否超过限值。  

基于此限值定义维护状态，包括要求维护或报警定义（按照 NAMUR 的 NE 107 实施交通

灯功能）。 

此处还可以使用下列功能： 

● 7 个用于报告相应维护状态的输入 

● 16 个显示诊断详细信息的输入 

● 1 个用于维护状态的输入 

● 1 个用于信号状态的输入 

级联过程值的信号状态 

通过使用“MuxST”多路复用器块，可将评估的不同过程值的信号状态与“AssetM”块互

连。 在过程模式下，面板中会显示优先级最高的信号状态。 

信号状态必须与 PA 规约 3.x 一致。 

级联维护状态 

通过使用“MuxMST”多路复用器块，可将不同“AssetM”块的维护状态与更高级别的

“AssetM”块互连。在过程模式下，面板中会显示优先级最高的维护状态。 
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4.12.2 如何创建用户诊断结构 

简介 

在具有 AS 的项目和具有维护站的项目中创建用户诊断结构。 如果 AS 和维护站在多项目

的不同项目中，则在具有 AS 的项目中为用户诊断区域组态 CFC 图表，在具有维护站的

项目中为用户诊断区域组态 OS 画面。 两种项目中都必须创建用户诊断区域。 

要求  

已经创建了诊断结构。 

步骤 

1. 在 SIMATIC Manager 中打开工厂视图。 

2. 在工厂层级中，选择一个要为其创建用户诊断结构的项目。 

3. 在树形视图中，选择“AS 对象”(AS objects) 层级文件夹直接位于其下的诊断层级文件

夹。 

4. 选择菜单命令“插入 > 工艺对象 > 层级文件夹”(Insert > Technological Objects > 
Hierarchy Folder)。 

  说明 
“诊断”(Diagnostics) 层级文件夹下只能有一个为用户诊断结构创建的层级文件夹。

5. 在详细视图中标记层级文件夹，然后选择菜单命令编辑 > 重命名 (Edit > Rename)。 

6. 输入长度尽可能短的唯一名称并按 Enter 键确认。 

将应用该名称。 
可以在该层级文件夹下创建其它层级子文件夹。 

  说明 
请注意，变量名最多允许 128 个字符。 
更多相关信息，请参见《过程控制系统 PCS 7；操作员站》手册。 

7. 如果尚未在 MS 服务器的项目中创建用户诊断结构，则必须更新工厂层级。 

有关此主题的更多信息，请参见“如何更新用户诊断结构 (页 82)”部分。 
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4.12.3 如何创建 CFC 图表并插入 AssetM 块 

简介 

“AssetM”块用于监视工厂的用户特定部分。 可以将该块集成到一个 CFC 图表中。 可以

将多个块集成到一个 CFC 图表中。 

要求   

已经创建了用户诊断结构。   

步骤 

1. 在树形视图中，选择要在其中创建 CFC 图表的层级文件夹。 

2. 选择菜单命令“插入 > 工艺对象 > CFC”(Insert > Technological Objects > CFC)。 

将创建一个新的 CFC 图表。 

3. 在详细视图中选择 CFC 图表。 

4. 选择菜单命令编辑 > 重命名 (Edit > Rename)。 

输入长度尽可能短的唯一名称并按 Enter 键确认。 将应用该名称。 

  说明 
请注意，变量名最多允许 128 个字符。 
更多相关信息，请参见手册《过程控制系统 PCS 7；操作员站》。 

5. 在详细视图中选择该 CFC，然后选择菜单命令编辑 > 打开对象 (Edit > Open 
Object)。 

6. 从 PCS 7 高级过程库中选择“AssetM”块，然后将其拖放到 CFC 中。 

7. 使用“AssetM”块，互连将要通过 PCS 7 维护站显示的信号。 

有关“AssetM”块的更多信息，可参见该块的在线帮助。 

8. 如果要创建更多的 CFC，请执行步骤 1-7。 

更多信息 

更多相关信息，请参见手册《过程控制系统 PCS 7；工程组态系统》。 
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4.12.4 为 AssetM 块分配参数 

概述    

将 AssetM 块放入 CFC 中后，互连要使用的参数。 

在过程设备工厂视图中，必须为每个 AssetM 块创建 PDM 对象，以便在过程控制期间的 
PDM 面板上，能够显示被监视组件的信息。 该 PDM 对象将保存铭牌（标识数据）和诊

断文本。 该 PDM 对象被分配给“AssetM”设备。 

之后将为该 PDM 对象生成一个 PLT ID。 必须在 CFC 中的 AssetM 块上输入该 PLT 
ID。  

PLT ID 是 PDM 对象（参数数据 EDD）和维护站中的面板之间的连接参数。PLT-ID 链接

到 PDM 对象。 

更多信息 

更多相关信息，请参见手册《过程控制系统 PCS 7；高级过程库》。 
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4.12.5 如何更新用户诊断结构 

简介 

只有在 MS 服务器项目外的某个位置创建了用户诊断结构时，才需要执行以下步骤。   

必须更新多项目中的工厂层级。 

步骤 

1. 在“工厂层级”中，选择一个已创建了用户诊断结构的项目。 

2. 在快捷菜单中，选择菜单命令“工厂层级 > 在多项目中更新”（Plant Hierarchy > 
Update in Multiproject）。 

将打开“工厂层级 - 在多项目中更新”(Plant Hierarchy - Update in Multiproject) 对话

框。 

3. 单击“确定”(OK)。 

将打开“工厂层级 - 在多项目中更新（目标项目）”(Plant Hierarchy - Update in 
Multiproject (target projects)) 对话框。 

4. 启用 MS 服务器当前项目的复选框。 

5. 单击“确定”(OK)。 

6. 对已创建用户诊断结构的多项目中的所有项目执行第 1 步至第 6 步。 

结果 

在 MS 服务器项目的工厂层级中，添加其它项目的用户诊断层级。 
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4.12.6 如何创建用户诊断画面 

简介   

在项目的用户特定诊断结构的层级文件夹中，创建用户诊断面画。 在 MS 单工作站系统

中，是指 MS 项目。在 MS 多工作站系统中则指 MS 服务器项目。 

您可以为每个层级文件夹创建一个用户诊断画面。 

要求 

● 已经创建了用户诊断结构。 

● 已经创建了用户诊断结构的 CFC。 

● 对多项目执行了多项目更新。 

步骤 

1. 在 SIMATIC Manager 中打开工厂视图。 

2. 在树形视图中，选择要创建用户诊断画面的层级文件夹。 

3. 选择菜单命令“插入”(Insert) >“工艺对象”(Technological Objects) >“画面”(Picture)。 

4. 输入长度尽可能短的唯一名称并按 Enter 键确认。 

将应用该名称。 

5. 单击“确定”(OK)。 

6. 在详细视图中选择画面，然后选择菜单命令编辑 > 对象属性... (Edit > Object 
properties...)。 

7. 选择“块图标”(Block icon) 选项卡。 

8. 选中“从工厂层级获得图标”(Derive icons from the plant hierarchy) 复选框。 

9. 对于要在其中插入用户诊断画面的所有层级文件夹，重复第 2 步至第 9 步。 
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4.12.7 如何为用户诊断创建组显示层级 

简介   

如果已经将用户特定的诊断结构添加到诊断结构中，您将需要参考此部分的信息。 

要求 

WinCC 项目已打开： 

● 在 MS 单工作站系统中，是指 MS 的 WinCC 项目。 

● 在 MS 多工作站系统中则是 MS 服务器的 WinCC 项目。 

步骤 

1. 在 WinCC 项目管理器的树形视图中，选择“项目编辑器”(Project Editor)。 

2. 打开快捷菜单并选择菜单命令“打开”(Open)。 

将打开“OS 项目编辑器”(OS Project Editor) 对话框。 

3. 选择“消息表示”(Message Representation) 选项卡。 

4. 在“组显示层级”(Group display hierarchy) 组中，启用“创建/更新组显

示”(Create/Update Group Displays) 复选框。 

5. 单击“确定”(OK)。 

保存层级、编译 OS 或下载 OS 时，画面中将自动插入用于层级计算的组显示。  



 组态维护站 
 4.13 SIMATIC PDM 的设置 

维护站 
功能手册, 12/2011, A5E03397308-01 85 

4.13 SIMATIC PDM 的设置 

简介     

要在面板中显示现场设备的扩展诊断功能，需要有得到许可的附件软件包，即“SIMATIC 
过程设备管理器 (SIMATIC PDM, SIMATIC Process Device Manager)”。 

在 SIMATIC PDM 中分配诊断项目 

要使用 SIMATIC PDM 的诊断功能，请在 SIMATIC PDM 中指定当前的诊断项目。  

要求 

● PCS 7 多项目/项目的组态已完成。 

● ES 上安装了 PDM。 

● 现场设备组态已完成。 

● 已在作为工程师站的 PC 站中插入 PDM 应用程序。 

步骤 

1. 在 SIMATIC Manager 的组件视图中选择 PCS 7 多项目/项目。 

2. 选择菜单命令选项 > SIMATIC PDM > 设置... (Options > SIMATIC PDM > 
Settings...)。 

3. 选择“维护”(Maintenance) 选项卡。 

4. 检查设置的路径。 

如果组态的路径不是所需路径，请使用“分配当前项目”(Assign current project) 按钮

选择路径。 

5. 单击“确定”(OK)。 
 

 说明 
请注意，需要在工程师站的 SIMATIC PDM ASSET Service Manager 中手动启动一次 
SIMATIC PDM ASSET 服务，这样才能接收到 PDM 发来的数据。 
SIMATIC PDM ASSET Service Manager 位于操作系统工具栏的信息区。 
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更多信息 

相关信息，请参见以下文档： 

● SIMATIC PDM 在线帮助 

● 手册《SIMATIC PDM；过程设备管理器》(SIMATIC PDM; The Process Device 
Manager) 
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4.14 完全导出 - 导出所有组件的数据 

4.14.1 完全导出的概述 

概述 
 

 说明 
如果使用 MS 标准或 SIMATIC MS PDM 版本的维护站，则可在过程控制中使用此功能。

 

将导出所有具有诊断功能的组件（如现场设备、PC、AS 组件、网络组件）的标识数据。    

使用完全导出功能时，所有具有诊断功能的组件中的数据将导出到导出文件

“@XML_Export.sml”中。 

该完全导出文件将自动保存在默认目标目录中。 

还可以在已组态的目标目录中存储完全导出文件（例如，使用外部系统中的数据）。  

有关默认目标目录和完全导出文件的信息包括在以下部分中。 

在过程控制期间，可以过滤出上一次完全导出的数据，并导出该数据。 

更多信息 

有关在过程控制中显示和导出数据的更多信息，请参见“总视图画面中的功能 (页 110)”
部分。 
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4.14.2 完全导出文件的标准目标目录 

MS 单工作站系统中的标准目标目录 

完全导出文件存储在 MS 的项目目录中。   

MS 多工作站系统中的标准目标目录 

完全导出文件保存到 MS 服务器的项目文件夹中。  

对于冗余系统，完全导出文件保存在启动导出操作时作为主站的 MS 服务器中。 

4.14.3 完全导出文件的用户特定目标目录 

用户特定目标目录 

用户特定目标目录可以组态为绝对路径或相对路径。 

 

路径 存储路径实例 存储路径 

绝对路径 D:\folder 在组态的路径中 

 在 MS 上的 MS 单工作

站系统中 

 在 MS 服务器上具有冗

余 MS 服务器的 MS 多
工作站系统中，该 MS 
服务器在启动导出操作

时用作主站。 

相对路径 \\计算机名\驱动器\文件夹 
(\\computer 
name\drive\folder) 

在指定计算机的组态路径下

有关组态用户特定目标目录的更多信息，请参见以下部分。 

冗余系统情况下的用户特定目标目录   

对于具有冗余 MS 服务器的 MS 多工作站系统中的工厂组态，建议将目标目录组态成相对

路径。 这可确保导出文件始终存储在同样的“位置”，而不管启动导出操作时是 MS 服务器

作为主站还是冗余伙伴作为主站。 
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4.14.4 如何为完全导出文件组态目标目录 

简介 

通过“@ExportPath”变量的起始值，设置完全导出文件的目标目录。    

要求 

WinCC 项目已打开： 

● 在 MS 单工作站系统中，是指 MS 的 WinCC 项目。 

● 在 MS 多工作站系统中则是 MS 服务器的 WinCC 项目。 

步骤 

1. 在 WinCC 项目管理器中，从树形视图中选择“变量管理”(Tag Management) 编辑器。 

2. 选择“内部变量”(Internal tags) 对象。 

3. 打开快捷菜单，并选择菜单命令“新建变量...”(New tag...)。 

将打开“变量属性”(Tag properties) 对话框中的“常规”(General) 选项卡。 

4. 在“名称：”(Name:) 输入字段中，输入“@ExportPath”。 

5. 转到“数据类型：”(Data type:) 下拉列表框并选择条目“16 位字符集文本变量”(Text 
tag 16-bit character set)。 

6. 选择“限制值/记录”(Limits / Logging) 选项卡。 

7. 选中“起始值”(Start value) 复选框。 

8. 输入完全导出文件的目标目录路径作为起始值。 

有关此主题的更多信息，请参见“完全导出的概述 (页 87)”部分。 

9. 单击“确定”(OK)。 

结果 

完全导出的用户特定目标目录已创建。 
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4.15 单个导出 - 导出各个组件数据 

4.15.1 单个导出概述 

概述   
 

 说明 
如果使用 MS 标准或 SIMATIC MS PDM 版本的维护站，则可使用此功能。 

 

在过程控制期间的““维护”视图 (页 146)”视图中，可以将具有诊断功能的组件（例如

现场设备、PC、AS 组件、网络组件）中的数据（例如标识数据、报警列表）导出到文件

中。  

系统会自动将该文件存储在默认目标目录中。 

系统将自动生成文件名。 

可在以下部分中找到有关默认目标目录和文件名的详细信息。 

可以选择其它目标目录，以便在外部系统中进一步使用。例如，用于 WinCC 附加件“报警

控制中心”。 这些目标目录将在目标对象中进行组态。 在这些组态的目标目录中，最多可

以同时选择 2 个作为过程控制中的目标目录。 

有关组态目标目录的更多信息，请参见“创建维护目标 (页 71)”部分。 
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4.15.2 单个导出文件的默认目标目录和名称 

默认目标目录   

单个导出文件保存在 <项目目录>\AssetExport\Out 中： 

● 在 MS 单工作站系统中，存储在 MS 的项目目录中 

● 在 MS 多工作站系统中 

– 对于 MS 服务器，存储在 MS 服务器的项目目录中 

– 对于冗余 MS 服务器，存储在启动导出时作为主站的服务器的项目目录中 

导出文件名称的结构   

导出文件的名称结构如下所示： 

“<变量名>.<资产 ID>_YYYY-MM-DD_HH_MM_SS.XML” 

 

文件名的结构 描述 

<变量_名> 组态的组件标识 

<资产_ID> 组件的 ID 编号： 

YYYY-MM-
DD_HH_MM_SS 

导出组件数据时的日期和时间 

xml 文件类型  
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4.16 创建/更新诊断画面 

简介 

使用此功能在诊断区域中创建或更新诊断画面及其块图标。 

“@@maintenancetypicals.pdl”文件包含用于显示诊断信息的所有块图标模板。   

如果执行“创建/更新诊断画面”(Create/update diagnostic screens)，PCS 7 将自动使用

此文件中的块图标。 默认情况下，在 PCS 7 安装过程中会安装该文件。 

可以根据具体需要定制块图标。  
 

 说明 
如果要自定义 @@maintenancetypicals.pdl 文件中包含的标准块图标，则不要更改此文

件。 可通过更新覆盖此文件中的所有更改。 
总是创建一个新文件。 文件的名称以固定名称成分“@maintenancetypicals”开头。 可自

行指定文件名的其余部分。 插入所需的块图标，并对其进行自定义。 
该过程与调整标准块图标的步骤完全相同。 
更多相关信息，请参见 WinCC 信息系统在线帮助中的“示例：创建对象模板”部分。 

 

创建/更新画面时，所有 PCS 7 块图标将从左上角开始自动排列。 

显示机架结构（例如，ET 200 中央机架）的画面是个例外。 在这种情况下，对象的块图

标按照其插槽顺序排列。 

在更新/创建诊断画面满足要求后，可移动块图标。 

被移动了的块图标在画面更新后保持其位置不变。 

新的块图标添加到画面的左上角。 请注意，添加新的块图标可能会导致图标重叠。 

要删除的块图标将从画面中移除。 其在画面中的位置保持未被占用状态。 

要求    

组态必须具有以下状态： 

● 已完成与诊断结构相关的设置。 

更多相关信息，请参见“如何在工厂层级中进行设置 (页 63)”部分。 

● 在 SIMATIC Manager 中将“显示设备的语言”(Language for display devices) 设置为默

认语言。 在过程控制期间显示的文本将以该语言生成。 
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步骤 

1. 打开 SIMATIC Manager 并激活工厂视图。 

2. 在树形视图中选择所需的层级文件夹。 

– 如果要为多项目/项目创建诊断画面，请选择多项目/项目。 

– 如果要为某些层级文件夹创建诊断画面，请在维护站中选择所需的层级文件夹。 

3. 选择选项 > 工厂层级 > 创建/更新诊断画面 (Options > Plant Hierarchy > 
Create/Update Diagnostics Screens) 菜单命令。 

4. 如果已编译了 AS 图表，则不会打开其它对话框，而是直接创建/更新诊断画面。 

转到第 6 步。 

5. 如果尚未编译 AS 图表，将为尚未执行此功能的每个 CPU 相继打开“创建模块驱动程

序”(Create module drivers) 对话框。  
在所有这些对话框中单击“确定”(OK)，以启动创建必需的模块驱动程序。 

  说明 
如果在此对话框中单击“取消”(Cancel)，将不会为相应的 CPU 创建模块驱动程序，

也不会更新诊断画面！ 

6. 在完成生成过程后，将打开“创建/更新诊断画面”(Create/update diagnostic screens) 
对话框。 

单击“是”(Yes)。 

将在“写字板”(WordPad) 编辑器中显示该功能的日志。 如果出现错误消息，请纠正

错误，然后再次运行该功能。 

7. 关闭“写字板”(WordPad) 编辑器。 

结果 

将创建或更新诊断画面。 

显示诊断画面的日志   

在 SIMATIC Manager 中选择选项 > 工厂层级 > 诊断画面日志 (Options > Plant 
Hierarchy > Diagnostics Screen Log)。 

诊断画面日志中将记录与诊断画面创建相关的信息。 
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4.17 编译和下载维护站 

编译和下载 MS 单工作站系统或多工作站系统 

● 编译   

在生成或更新诊断画面后，必须对其进行编译并将其下载到维护站。 

在编译维护站之前，必须在组态更改后至少创建一次或更新诊断画面。 

“面向区域”必须设置为 OS 编译模式。 

在 MS 单工作站系统中，编译 MS。 

在 MS 多工作站系统中，编译 MS 服务器。 

● 下载   

在编译之后执行下载。 

如果使用 MS 多工作站系统，则加载 MS 服务器。 

如果使用冗余 MS 多工作站系统，则下载 MS 服务器和冗余伙伴。 

不得下载 MS 单工作站系统。 

编译和下载 SIMATIC MS PDM 

要求 

● 过程设备网络视图中的组态已完成。 

● 所有现场设备的参数视图已打开过一次。 

● “创建/更新诊断画面”(Create/update diagnostics screens) 功能已执行。 

● 已在 SIMATIC Manager 中打开项目。 
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步骤  

编译和下载图表 

1. 在 SIMATIC Manager 的组件视图中选择“图表”(Charts) 层级文件夹。 

2. 从菜单中选择“编辑 > 编译”(Edit > Compile)。 

3. 选中以下复选框： 

– 整个程序 (Entire program) 

– 生成模块驱动程序 (Generate module drivers) 

加载 WinLC RTX 

1. 在 SIMATIC Manager 的组件视图中选择 PC 站。 

2. 选择菜单命令“PLC > 下载”(PLC > Download)。 

编译 OS 

1. 在 SIMATIC Manager 的组件视图中选择 OS 层级文件夹。 

2. 从菜单中选择“编辑 > 编译”(Edit > Compile)。 

3. 选中以下复选框： 

– 整个 OS (Entire OS) 

– 使用存储器复位 (With memory reset) 

加载 OS 

无需为 SIMATIC MS PDM 加载 OS。 
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4.18 服务器数据和客户端的下载 

服务器数据 

在下载 MS 或 OS/MS 客户端之前，必须为其分配相关的 OS 服务器。 这会将服务器数据

加载到 MS 或 MS/OS 客户端项目中 

 

服务器数据（服务器包） 客户端 

MS 服务

器 
OS 服务器 
其自动化系统正受到监视 

OS 服务器 
其 OS 区域已显示

工程师站上的 MS 
客户端 

单独 PC 站上的 MS 
客户端 

X X - 

OS/MS 客户端 X X X 

下载 

下载 MS 或 OS/MS 客户端的方式与下载 OS 客户端的方式完全相同。 无需下载工程师站

中的 MS 客户端。 

更多信息 

更多相关信息，请参见手册《过程控制系统 PCS 7；操作站》中的“下载服务器数据”以及

“如何编译和下载多个操作站”部分。 
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4.19 项目中的更改 

版本变更 

可在 SIMATIC Manager 的工厂层级设置中更改版本。 有关此主题的更多信息，请参见“
如何在工厂层级中进行设置 (页 63)”部分。 

如果要更改维护站的版本，必须注意以下事项：   

● 标准 MS 更改为基本 MS 

– 会删除 AS 对象下的诊断结构以及用户诊断结构，包括相关的画面。 

● 标准 MS 更改为 SIMATIC MS PDM 

– 会删除 AS 对象下的诊断结构，包括相关的画面。 

– 会创建现场设备的诊断结构。 

● 基本 MS 更改为 SIMATIC MS PDM 

– 会删除 AS 对象的诊断结构，包括相关的画面。 

– 会创建现场设备的诊断结构。 

● SIMATIC MS PDM 更改为基本 MS 

– 会删除现场设备的诊断结构以及用户诊断结构，包括相关的画面。 

● SIMATIC MS PDM 更改为标准 MS 

– 会删除现场设备的诊断结构，包括相关的画面。 

更改之后，可能需要执行以下任务： 

● 创建/更新诊断画面 (页 92) 

● 编译和下载维护站 (页 94) 

● 服务器数据和客户端的下载 (页 96) 

HW Config 中的更改   

工程组态系统硬件配置的更改会影响诊断画面中的显示。 

更改之后，请执行以下任务： 

● 创建/更新诊断画面 (页 92) 

● 编译和下载维护站 (页 94) 
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添加 OS 服务器 

如果在多项目/项目中创建诊断结构后添加 OS 服务器，请执行以下任务： 

● 将 OS 服务器数据分配到 MS 服务器 

有关此主题的详细信息，请参见《过程控制系统 PCS 7；操作站》手册中的“如何加

载服务器数据”部分。 

● 加载 MS 服务器 

有关此主题的更多信息，请参见“编译和下载维护站 (页 94)”部分。  

随后将 OS 服务器定义为 MS 服务器 

如果以后在运行中的工厂中将 OS 服务器定义为 MS 服务器，则不仅需要为 MS 服务器执

行所述的组态任务，还需要为担当 OS/MS 客户端角色的 OS 客户端执行下载。 

有关下载的更多信息，请参见“服务器数据和客户端的下载 (页 96)”部分。 

软件中的更改   

● 更改“报警”组件的标准消息服务器 

在包含 OS 客户端的多工作站系统的工厂组态中，如果为“报警”组件分配的标准消息服

务器有变化，则必须编译并下载该 MS 服务器。 

有关此主题的更多信息，请参见手册《过程控制系统 PCS 7；操作站》中的“如何分配

标准服务器”部分。 

● 更改画面分辨率 

如果在 OS 项目编辑器的“布局”(Layout) 选项卡的“可用布局：”(Available layouts:) 组
中更改了 画面分辨率，则下次调用“创建/更新诊断画面”(Create/Update Diagnostics 
Screen) 时，将重命名可用的总览画面，并将建立对应于新画面分辨率的总览画面。 
“创建/更新诊断画面”(Create/Update Diagnostics Screen) 功能的日志中将包含相应的

消息。 同时为之前的总览画面重新命名。 

如果手动更改了总览画面，可以复制之前的总览画面，并在当前总览画面中手动进行

更改。 
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4.20 删除诊断区域 

简介 

在删除诊断结构过程中，将删除以下内容： 

● 诊断层级文件夹及其所有子文件夹 

● 目标对象 

● 操作对象 

● 链接对象 

要求   

● 已创建诊断结构和/或用户诊断结构。 

  说明 
如果已经手动更改了诊断画面，请确保在删除之前创建了备份副本，这是因为在删除

并重新创建诊断结构之后会丢失之前的所有更改。 

步骤 

1. 在 SIMATIC Manager 中打开工厂视图。 

2. 在树形视图中，选择该对象： 

– 如果使用多项目，请选择对象“[项目的名称] MP”。 

– 如果使用单项目，请选择对象“[项目的名称]”。 

3. 选择菜单命令选项 > 工厂层级 > 设置... (Options > Plant Hierarchy > Settings...)。 

将打开“工厂层级 - 设置”(Plant Hierarchy - Settings) 对话框。 

4. 如果选择了多项目，则按如下所述操作： 

– 单击“确定”(OK)。  
将打开“工厂层级 - 设置”(Plant Hierarchy - Settings) 对话框。 

– 转到第 6 步。 

5. 如果选择了一个单项目或多项目中的某个项目，将打开“工厂层级 - 设置”(Plant 
Hierarchy - Settings) 对话框。 

6. 禁用“从工厂层级获得诊断画面”(Derive diagnostic screens from the plant hierarchy) 
复选框。 
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7. 单击“确定”(OK)。 

  说明 
将删除整个诊断结构以及所有诊断画面，包括用户诊断结构在内。 
在此过程中不会删除诊断结构层级文件夹中包含的驱动程序图表，它们仍然会保留在 
S7 程序的图表文件夹中。 

8. 编译 OS。 

9. 在 OS 多工作站系统中，下载 OS 服务器。 
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操作员监控 5
5.1 启动过程控制 

标准 MS 和基本 MS    

启动维护站的过程控制与启动操作站的过程控制相同。 

当使用 MS 多工作站系统和 SIMATIC PDM 时，必须开启工程师站，并启动 PDM Server 
Manager 以提供 PDM 设备数据。 

SIMATIC MS PDM 

激活过程控制之前，请检查 WinCC 项目管理器中 WinCC 项目类型的设置。 必须将单工

作站项目设置为项目类型。 

在 WinCC 项目管理器中使用“激活”(Activate) 图标激活过程控制。 

OS 仿真 

只能在标准 MS 和基本 MS 中使用 OS 仿真功能。 

在标准 MS 和基本 MS 中，只能在一定程度上实现 PCS7 维护站的 OS 仿真（例如，无

标识或诊断数据）。 
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5.2 用户界面的布局 

过程控制中的用户界面   

用户界面的结构与操作员系统界面的结构相同。 该界面分为 3 个区域：  

● 总视图区域 (页 104) 

将始终显示总视图区域。 整个工厂的总视图中包括各个工厂区域的组显示和消息行。 

总视图区域中的显示画面和操作员控件与 OS 中的显示画面和操作员控件相同。 

如果存在偏差，将在文档中指出。 

● 工作区 (页 107) 

在工作区中，会为诊断区域显示个别组件的总览画面、区域总览画面和诊断画面。 

● 按钮区 (页 106) 

按钮区域始终会显示。 按钮区域中包含多个按钮组，维护工程师（“诊断”区域的操作

员）可以在这些按钮组之间进行切换。  

按钮组中的按键的操作方式与 OS 中的按键相同。  

如果存在偏差，将在文档中指出。 
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下图显示了用户界面的示例： 

 

更多信息 

更多相关信息，请参见《PCS 7 过程控制系统，OS 过程控制》手册。 



操作员监控  
5.2 用户界面的布局 

 维护站 
104 功能手册, 12/2011, A5E03397308-01 

5.2.1 总视图区域 

在总览区域中显示 

下图显示了一个总视图区域的示例：    

 

本部分只介绍专用于维护站的图标。 

“最高优先级消息”图标列表 

至少有一条优先级为 16 的消息处于激活状态（到达状态或经过确认的到达状态）时，才

会显示该图标。 此优先级由系统针对 AS 的紧急操作所定义。 单击该图标可显示“最高优

先级消息”列表。 

 

图标 功能 授权 

 调用“最高优先级消息”列

表 
针对诊断区域启用 

有关组态消息优先级的更多信息，请参见手册《过程控制系统 PCS 7；操作站》。 

用于诊断区域的区域按键 

下图显示了一个用于诊断区域的区域按键示例： 

 

该区域按键可用于打开诊断区域的总览画面。 

在画面层级中的导航与 OS 区域的画面层级导航类似。 
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诊断区域的组显示 

除区域按键以外，在整个诊断区域的组显示的第三个按钮上还将显示最新消息状态。 

可通过组显示调用低级区域总览画面。 

下表显示了可能的状态： 

 

显示 消息类型/状态 优先级 消息状态 

 消息已锁定 (1) 1 - 

 AS 过程控制故障 2  “S”显示 

 闪烁 
进入消息 

 静止 
消息已确认 

 AS 过程控制错误 3 “F”显示 

 闪烁 
进入消息 

 静止 
消息已确认 

 要求维护 4 “M”显示 

 闪烁 
进入消息 

 静止 
消息已确认 

 不存在任何未决消息 5 - 

优先级列中的数字指示显示的优先级。 最小的数字具有最高的优先级。  

请注意，未确认消息的优先级高于已确认消息的优先级。 

(1) 至少一条消息被锁定。 只能针对 AS 对象、用户对象和现场设备等区域的组件锁定消

息。 
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5.2.2 按钮区 

按钮区的表示 

下图显示了按钮区中的一个按钮组示例。    

 

本部分只介绍专用于维护站的图标。 

锁定/解锁消息     

如果在区域 AS 对象、现场设备和用户对象的总览画面下打开一个画面，则可锁定或解锁

在此画面中显示的组件的所有消息。  

有关锁定/解锁消息的更多信息，请参见“如何锁定和解锁消息 (页 135)”部分。 
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5.2.3 工作区 

在工作区中将按层级显示诊断画面。    

通常通过层级获得从总览到详细信息的画面。 

总览画面为最高层级。 通过区域的维护组显示获得相应的区域总览画面。 

组件在区域总览画面中显示为块图标。  

工作区还会输出由操作员调用的面板、控制窗口、消息列表或对话框。 

您还可以通过按钮组中的层级按钮来更改画面。 
 

 说明 
由于 SIMATIC MS PDM V1 基于 SIMATIC PCS 7 V7.1.3，SIMATIC MS PDM V1 的显

示和功能可能有所不同。 
《过程控制系统 PCS 7；OS 过程控制》手册中介绍了 SIMATIC PCS 7 V7.1.3 的显示和

功能。 
本文档的相应部分详细说明了功能限制。 

 

更多信息 

更多信息，请参见以下内容： 

● 总览画面 (页 108) 

● 区域总览画面 (页 117) 

● 块图标 (页 119) 

● 面板 (页 129) 
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5.3 总视图画面 

简介 

维护工程师可在总览画面中获得整个工厂的工厂状态总览。  

将在每个至少具有一个画面的区域中显示维护组显示。 各区域以不同颜色显示，如下所

示：  

● PC 站（黄色背景） 

● 网络对象（绿色背景） 

● AS 对象或现场设备（青色背景） 

● 用户对象（浅蓝色背景） 

下图显示了诊断区域总览画面的示例：   
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调用总览画面 

按照如下方式调用总览画面： 

● 区域按钮 

● 总视图中的组显示 

● 画面树浏览器 

● 按钮组中的导航按钮 

总览画面中的维护组显示 

维护组显示为维护工程师提供了各区域工厂状态的总览。 

可以从维护组显示切换到区域画面。 

下表显示了可能的状态： 

 

显示 消息类别/状态 消息状态 
 消息已锁定 (1) - 
 AS 过程控制故障/ 

维护报警 
“S”显示 

 闪烁 
进入消息 

 静止 
消息已确认 

 AS 过程控制错误/ 
所要求的维护 

“F”显示 

 闪烁 
进入消息 

 静止 
消息已确认 

 预防性维护/ 
所需维护 

“M”显示 

 闪烁 
进入消息 

 静止 
消息已确认 

 不存在任何未决消息 - 

(1) 至少一条消息被锁定。 只能针对 AS 对象、用户对象和现场设备等区域的组件锁定消

息。 
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5.4 总视图画面中的功能 

5.4.1 概述 

总览画面中的功能  

在总览画面中，可以执行以下功能： 

● 通过维护链接调用 Web 页面 

● 完全导出 

● 过滤功能 

● 对带有 SNMP 功能组件的消息更正 

有关这方面的信息，请参见以下部分。 
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5.4.2 通过维护链接调用 Web 页面 

简介 

最多可调用 3 个 Web 页面来为诊断措施提供支持。 在组态调用时将显示图标。   
 

 说明 
该功能对 SIMATIC MS PDM 不可用。 

 

用户界面中的图标 

 

图标 功能 授权 

 

 

 

显示 Web 页面 诊断区域的“高级过程控制” 

步骤 

1. 单击此图标。 

结果 

调用了 Web 页面。 

更多信息 

有关组态的信息，请参见“创建维护链接 (页 68)”部分。 
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5.4.3 完全导出 

简介    

完全导出用于导出具有诊断功能的所有对象（例如，现场设备、PC 和网络组件）的数

据。  

该文件构成了过滤式完全导出的基础。 

用户界面中的图标 

 

图标 功能 授权 

 
触发完全导出 诊断区域的“过程控制” 

步骤 

1. 单击此图标。 

结果 

执行了完全导出。  

此信息保存在“@XML_Export.sml”文件中。 

更多信息 

有关组态的信息，请参见“完全导出 - 导出所有组件的数据 (页 87)”部分。 
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5.4.4 过滤完全导出的数据 

简介    

系统允许您显示已过滤的上次完全导出数据并导出此数据。 

如果工厂不是通过 PCS 7 Web 客户端运行，则可以使用过滤功能。   

执行完全导出，以显示当前数据。 

过滤数据时，可以使用各种过滤条件。 

用户界面中的图标 

 

图标 功能 授权 

 
过滤设备状态 

 调用过滤视图 

 过滤数据 

诊断区域的“过程控制” 

步骤 

1. 单击此图标。 
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结果 

调用过滤器视图。 

下图显示了过滤视图的示例： 

 

更多信息 

有关过滤的更多信息，请参见“如何过滤和导出完全导出的数据”部分。 
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5.4.5 如何过滤和导出完全导出的数据 

要求    

● 总览画面已打开。 

● 完全导出已启动。 

步骤 

1. 选中“维护状态”(Maintenance status)、“维护作业”(Maintenance job) 和“服务状

态”(Service status) 组中的过滤条件复选框。 

– 可以使用“全选”(Select All) 按钮选中所有复选框。 

– 单击“取消全选”(Deselect all) 可清除所有复选框。 

2. 从每个下拉列表中，选择“类型信息”(Type information) 组中的文本。 

3. 在输入框中输入所需文本。 

字符“*”和“?”可用作通配符。 

4. 连接文本字段。 

5. 单击“显示数据”(Display data) 按钮。 

将显示“结果”(Result) 视图。 

6. 如果要保存导出的数据，请单击“保存”(Save)。 

导出文件的名称默认设置为“FilteredExport_<日期>”。 必要时可更改该默认文件名。 
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5.4.6 对带有 SNMP 功能组件的消息更正 

简介     

“消息更正”功能用于删除维护站组态数据（服务器数据）中 SNMP 兼容组件的消息，

这些组件与项目的关系已删除，例如，从系统中移除了 PC 硬件后。 

如果未通过 PCS 7 Web 客户端操作工厂，则可以使用“消息更正”功能。  

用户界面中的图标 

 

图标 功能 授权 

 
执行消息更正 诊断区域的“区域授权”和“高级过程控

制” 

步骤 

1. 单击此图标。 

结果 

相关消息被删除。 

并触发一个操作员消息。 
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5.5 区域总视图画面 

可能出现的区域总览画面   

诊断区域的总览画面中可以包含以下区域总览画面： 

● PC 站 

– 项目中，已创建为 PC 站的 PC 对象和 IPC 对象。 

– 无从属结构 

● 网络对象 

– 在 OPC/SNMP 服务器组态中创建的所有网络对象 

– 无从属结构 

● AS 对象或现场设备 

– 自动化层级中所有已组态对象的层级结构表示 

● 用户对象 

– 用户对象的用户创建的层级结构表示 

在工作区中将显示所选区域的总览画面。 各组件在区域总览画面中显示为块图标。 

调用区域总览画面 

按照如下方式调用区域画面： 

● 维护组显示 

● 按钮组中的层级按钮 

区域总览画面中的功能 

通过区域总览画面中的块图标调用区域中各组件的诊断画面。 
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5.6 组件的表示 

简介   

在过程控制期间，在诊断画面中将以块图标的形式显示待监视的组件。 

有关组件的更多信息，请单击鼠标调用相应的面板。 

块图标     

系统支持且可在诊断画面中显示的块图标包含在文件“@@maintenancetypicals.pdl”中。  

该模板文件位于项目目录的“... \wincproj\<os-name>\GraCS”下。 

有关块图标的说明，可参见“块图标 (页 119)”部分。 

面板   

在过程模式下，面板显示具有诊断功能组件的所有相关信息。 这包括由组件自身获得的

信息或从项目数据获得的信息。 无任何信息时，相应字段将为空。 

面板由画面窗口标题、标题和不同视图组成。 您可以更改视图。 

面板中视图的数量取决于组件的类型。 面板中始终有“标识”(Ident)、“消息”(Messages) 和
“维护”(Maintenance) 三个视图可供选择。 智能组件（如 EDD（电子设备描述）描述的组

件和 SIMATIC PDM 中集成的组件）具有附加视图，具体取决于组件。 
 

 说明 
如果在 MS 标准版本和 SIMATIC MS PDM 中使用维护站，则显示面板。 

 

有关此主题的更多信息，请参见“面板 (页 129)”部分。 
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5.7 块图标 

块图标显示  

下图显示了一个紧凑型设备的块图标示例： 

 

块图标中的元素和功能 

块图标中将显示以下元素： 

● 块图标的标签 

下图显示了标签的示例： 
 

标签的本地 ID (LID) 与标识数据相匹配。 

有关 LID 的信息，请参见“标识数据的来源 (页 173)”部分。 

● 位图 

下图显示了一个 ET200： 

 

如果 HW Config 包含位图，则在“DeviceIcon”属性中会自动输入显示设备图标的位

图。 

● 自定义组件的维护组显示 

下图显示了 AS 过程控制故障时的维护组显示。 
 

通过维护组显示打开关联的面板。 

根据组件的维护状态显示以下状态。 

有关显示的信息，请参见“维护状态和维护组显示 (页 121)”部分。 
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● 自定义组件的维护状态 

下图显示了维护状态为“维护报警”的诊断图标。 

 

可以使用诊断图标打开关联的面板。 

有关显示的信息，请参见“维护状态和维护组显示 (页 121)”部分。 

对于冗余组件，将显示已形成的维护状态。 

有关详细信息，请参见“冗余组件的维护状态 (页 124)”。 

● 激活说明 

下图显示了激活说明时的显示。 
 

有关详细信息，请参见““说明”视图 (页 149)”。 

● 较低级别层级的维护组显示 

下图展示了 AS 过程控制故障时维护组显示的显示。 
 

根据较低层级组件的维护组显示在维护组显示中显示各种状态。 

有关详细信息，请参见“维护状态和维护组显示 (页 121)”。 

可以通过维护组显示跳转到较低层级。 
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5.8 维护状态和维护组显示 

简介     

诊断图标表示组件的维护状态。 

维护组显示表示组件和较低级别组件的消息状态。 
 

 说明 
如果面板中的维护状态为“未检查/未知”，则所有其它动态显示均不相关。 

 

维护状态和维护组显示的关系 

下表提供了概要说明： 

 

维护状态 维护组显示 
显示 备注 优先 

级 
显示 消息类别/ 

状态 
消息状态 

 未知/未经测试 1  
 

不存在任何未决

消息  
- 

 维护报警 2  
 

AS 过程控制故

障 
“S”显示 

 闪烁 
进入消息 

 静止 
消息已确认 

 维护 
请求 

3  
 

AS 过程控制错

误 
“F”显示 

 闪烁 
进入消息 

 静止 
消息已确认 

 请求维护 4  
 

预防性维护 “M”显示 

 闪烁 
进入消息 

 静止 
消息已确认 
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维护状态 维护组显示 

显示 备注 优先 
级 

显示 消息类别/ 
状态 

消息状态 

 本地操作员控制 5  
 

 至少有一个过程值正

在仿真 
6  

 

AS 状态  组显示中无显示 

 消息不需要确认，不

具有“离开”状态 

 消息只能在历史列表

中输入 

 停止运行 7  
 

AS 过程控制故

障  
“S”显示 

 闪烁 
进入消息 

 静止 
消息已确认 

 设备已禁用 8  
 

 组态 
更改已识别 

9  
 

AS 状态  组显示中无显示 

 消息不需要确认，不

具有“离开”状态 

 消息只能在历史列表

中输入 

 良好 10  
 

不存在任何未决

消息 
- 

适用于所有显示  
 

消息已锁定 “X”显示 

至少有一条消息被锁定；

仅适用于区域 AS、用户

设备和现场设备中的对象

优先级列中的数字指示显示的优先级。 最小的数字具有最高的优先级。 

请注意，未确认消息的优先级高于已确认消息的优先级。 
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维护状态和维护作业的关系 

下表提供了概要说明： 

 

含义 维护 
作业 

状态维护 
作业 

已请求所需维护， 
维护工程师尚未创建维护作业 

 
 

已请求所要求的维护， 
维护工程师尚未创建维护作业 

 
 

已请求维护报警， 
维护工程师尚未创建维护作业 

 
 

已请求所需维护， 
维护作业的状态已设置为“进行中” 

  

已请求所要求的维护， 
维护作业的状态已设置为“进行中” 

  

已请求维护报警 

维护作业的状态已设置为“进行中” 
  

维护作业已取消 

维护工程师已取消维护作业 

维护 
状态，请参见上表 

 

维护作业已完成 维护 
状态，请参见上表 
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5.9 冗余组件的维护状态 

简介 

在面板标题和块图标中，两个组件的维护状态显示在一个诊断图标中。 

此诊断图标的维护状态由两个组件的维护状态构成。 
 

 说明 
维护状态“组态更改”的显示与冗余组件不相关。 

 

形成带有冗余组件的维护状态  

下表列出了由于此规则而形成的维护状态。   

 

维护状态  
冗余组件 组件 A 组件 B 

 良好 良好 良好 

 良好 未知/未经测试 良好 

 良好 组件钝化 良好 

 要求维护 停止运行 良好 

 良好 至少有一个过程值正在仿

真 
良好 

 良好 本地操作 良好 

 请求维护 请求维护 良好 

 要求维护 要求维护 良好 

 要求维护 维护报警 良好 

 良好 良好 组件钝化 

 组件钝化 未知/未经测试 组件钝化 

 组件钝化 组件钝化 组件钝化 

 停止运行 停止运行 组件钝化 
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维护状态  

冗余组件 组件 A 组件 B 

 至少有一个过程值正在仿真 至少有一个过程值正在仿

真 
组件钝化 

 本地操作 本地操作 组件钝化 

 请求维护 请求维护 组件钝化 

 要求维护 要求维护 组件钝化 

 维护报警 维护报警 组件钝化 

 要求维护 良好 停止运行 

 停止运行 未知/未经测试 停止运行 

 停止运行 组件钝化 停止运行 

 停止运行 停止运行 停止运行 

 至少有一个过程值正在仿真 至少有一个过程值正在仿

真 
停止运行 

 本地操作 本地操作 停止运行 

 请求维护 请求维护 停止运行 

 要求维护 要求维护 停止运行 

 维护报警 维护报警 停止运行 

 良好 良好 至少有一个过程值正在仿

真 

 至少有一个过程值正在仿真 未知/未经测试 至少有一个过程值正在仿

真 

 至少有一个过程值正在仿真 组件钝化 至少有一个过程值正在仿

真 

 至少有一个过程值正在仿真 停止运行 至少有一个过程值正在仿

真 

 至少有一个过程值正在仿真 至少有一个过程值正在仿

真 
至少有一个过程值正在仿

真 



操作员监控  
5.9 冗余组件的维护状态 

 维护站 
126 功能手册, 12/2011, A5E03397308-01 

维护状态  

冗余组件 组件 A 组件 B 

 本地操作 本地操作 至少有一个过程值正在仿

真 

 请求维护 请求维护 至少有一个过程值正在仿

真 

 要求维护 要求维护 至少有一个过程值正在仿

真 

 维护报警 维护报警 至少有一个过程值正在仿

真 

 本地操作 良好 本地操作 

 本地操作 未知/未经测试 本地操作 

 本地操作 组件钝化 本地操作 

 本地操作 停止运行 本地操作 

 本地操作 至少有一个过程值正在仿

真 
本地操作 

 本地操作 本地操作 本地操作 

 请求维护 请求维护 本地操作 

 要求维护 要求维护 本地操作 

 维护报警 维护报警 本地操作 

 请求维护 良好 请求维护 

 请求维护 未知/未经测试 请求维护 

 请求维护 组件钝化 请求维护 

 请求维护 停止运行 请求维护 

 请求维护 至少有一个过程值正在仿

真 
请求维护 

 请求维护 本地操作 请求维护 

 请求维护 请求维护 请求维护 

 要求维护 要求维护 请求维护 
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维护状态  

冗余组件 组件 A 组件 B 

 维护报警 维护报警 请求维护 

 要求维护 良好 要求维护 

 要求维护 未知/未经测试 要求维护 

 要求维护 组件钝化 要求维护 

 要求维护 停止运行 要求维护 

 要求维护 至少有一个过程值正在仿

真 
要求维护 

 要求维护 本地操作 要求维护 

 要求维护 请求维护 要求维护 

 要求维护 要求维护 要求维护 

 维护报警 维护报警 要求维护 

 要求维护 良好 维护报警 

 维护报警 未知/未经测试 维护报警 

 维护报警 组件钝化 维护报警 

 维护报警 停止运行 维护报警 

 维护报警 至少有一个过程值正在仿

真 
维护报警 

 维护报警 本地操作 维护报警 

 维护报警 请求维护 维护报警 

 维护报警 要求维护 维护报警 

 维护报警 维护报警 维护报警 

 良好 良好 未知/未经测试 

 未知/未经测试 未知/未经测试 未知/未经测试 



操作员监控  
5.9 冗余组件的维护状态 

 维护站 
128 功能手册, 12/2011, A5E03397308-01 

维护状态  

冗余组件 组件 A 组件 B 

 组件钝化 组件钝化 未知/未经测试 

 停止运行 停止运行 未知/未经测试 

 至少有一个过程值正在仿真 至少有一个过程值正在仿

真 
未知/未经测试 

 本地操作 本地操作 未知/未经测试 

 请求维护 请求维护 未知/未经测试 

 要求维护 要求维护 未知/未经测试 

 维护报警 维护报警 未知/未经测试 
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5.10 面板 

5.10.1 面板显示 

简介   

在过程运行期间，维护工程师可以通过诊断画面中的块图标打开相应的面板；通过该面

板，维护工程师可以了解更多详细信息，同时方便操作员对块进行控制。  

面板中的冗余组件显示方式如下： 

● 在冗余组件的视图中显示每个组件带有各自维护状态的诊断图标。 在显示当前主站的

诊断图标之间显示橙色方块。 

● 形成的维护状态显示在一个诊断图标的标题中。 

有关形成维护状态的更多信息，请参见“冗余组件的维护状态 (页 124)”部分。 

显示面板视图“标识” 

下图显示了面板的示例： 

 

有关这方面的信息，请参见以下部分。 
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5.10.2 画面窗口标题和标题 

5.10.2.1 显示和操作员控制 

简介     

控制栏的结构始终相同。 控制栏中显示的符号，取决于组件类型和组态。 

下图为一个控制栏符号的显示示例：  

 

显示 

下表提供了概要说明： 

 

图标 名称 该区域中显示的组件 功能 
 画面窗口标题  PC 站 

 网络对象 

 AS 对象 

 现场设备 

 用户对象 

显示本地 ID 

有关本地 ID 的更多信息，请参见“标
识数据的来源 (页 173)”部分。 

 块注释  AS 对象 

 现场设备 

 用户对象 

显示块注释 

本地 ID 显示在工具提示中。 

 固定面板 在用户界面上固定面板 

这样即可切换到另一画面或区域而无

需关闭该面板。 
 返回 

 PC 站 

 网络对象 

 AS 对象 

 现场设备 

 用户对象 

调用过程画面 

画面更改后，可以看到在其中调用和

固定面板的过程画面。 
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图标 名称 该区域中显示的组件 功能 
 维护 

组显示（自定义组件）

如果与组件相关的消息处于未决状

态，则显示该图标 

有关维护组显示的更多信息，请参见

“维护状态和维护组显示 (页 121)”部
分。 

 维护状态/ 
维护作业（自定义组

件）  

显示当前维护状态/ 
维护作业 

更多相关信息，请参见“维护状态和

维护组显示 (页 121)”和“冗余组件的维

护状态 (页 124)”部分。 

 维护作业状态 

 PC 站 

 网络对象 

 AS 对象 

 现场设备 

 用户对象 

如果已创建或执行维护作业，则会显

示该图标 

有关维护作业状态的更多信息，请参

见“维护状态和维护组显示 (页 121)”
部分。 

 波动抑制  AS 对象， 

适用于 
输入/输出 
模块和现场设备 

激活波动抑制之后，显示该图标 

 锁定消息 

 解锁消息 

 AS 对象 

 现场设备 

 用户对象 

禁用或启用块的所有消息 

有关此主题的更多信息，请参见“如

何锁定和解锁消息 (页 135)”部分。 

 确认消息  PC 站 

 网络对象 

 AS 对象 

 现场设备 

 用户对象 

确认块的消息 

 取消钝化  AS 对象， 

适用于冗余输入/输
出 
模块 

如果模块或通道已钝化，则显示该图

标 

有关此主题的更多信息，请参见“如

何取消钝化模块或通道 (页 137)”部
分。 
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图标 名称 该区域中显示的组件 功能 
 链接对象 1 
 链接对象 2 
 链接对象 3 

 PC 站 

 网络对象 

 AS 对象 

 现场设备 

 用户对象 

调用 Web 页面 

如果已组态对 Web 页面的调用，则

显示该图标 

有关组态的信息，请参见“创建维护

链接 (页 68)”部分。 

 调用硬件项目  AS 对象 

 现场设备 

调用 HW Config 

有关此主题的更多信息，请参见“如

何打开 HW Config 的在线视图 
(页 138)”部分。 

 调用 SIMATIC PDM  现场设备 

 用户对象 

调用 PDM 

有关此主题的更多信息，请参见“如

何打开 SIMATIC PDM 的组态界面 
(页 139)”部分。 

调用组态数据  网络对象 调用 SCALANCE Web 服务器 

有关此主题的更多信息，请参见“如

何调用 Web 界面 (页 140)”部分。 

 

诊断监视器  PC 站， 

适用于 SIEMENS 
IPC 

调用“诊断监视器”诊断工具 

有关此主题的更多信息，请参见“如

何调用“诊断监视器”诊断工具 
(页 141)”部分。 

 激活说明  PC 站 

 网络对象 

 AS 对象 

 现场设备 

 用户对象 

当激活消息时显示 

有关此主题的更多信息，请参见“

“说明”视图 (页 149)”部分。  
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图标 名称 该区域中显示的组件 功能 

 
“标识”视图 

 
“消息”视图  

 PC 站 

 网络对象 

 AS 对象 

 现场设备 

 用户对象 

 
“性能”视图  AS 对象， 

适用于 CPU 

 
“说明”视图  PC 站 

 网络对象 

 AS 对象 

 现场设备 

 用户对象 

 
“诊断”视图   现场设备 

 PC 站， 

适用于 SIEMENS 
IPC 

 AS 对象， 

适用于开关和驱动

器 

 
“维护”视图  PC 站 

 网络对象 

 AS 对象 

 现场设备 

 用户对象 

 
“连接显示”视图  PC 站 

适用于 MS 客户

端、OS/MS 客户端

和 OS 客户端 

调用相应视图 

 如果左键单击，该视图会出现在同

一窗口中 

 如果右键单击，则在新窗口中打开

该视图。 
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图标 名称 该区域中显示的组件 功能 

 
“监视”视图  用户对象 

 
“参数”视图  AS 对象， 

适用于 CPU 

 
“OB3x”视图 

 
“OB8xOB1”视图 

 AS 对象， 

适用于 CPU 

调用相应视图 

 如果左键单击，该视图会出现在同

一窗口中 

 如果右键单击，则在新窗口中打开

该视图。 

 
调用附加视图  PC 站 

 网络对象 

 AS 对象 

 现场设备 

 用户对象 

仅当可调用附加视图时才能进行操作 
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5.10.2.2 如何锁定和解锁消息 

简介   

针对 AS 对象、现场设备和用户对象区域中的组件，可锁定或解锁消息。 

可以在按钮组或面板中锁定或解锁消息。 

锁定的消息标识为 X： 

● 在总览区的组显示中 
有关此主题的更多信息，请参见“总视图区域 (页 104)”部分。 

● 在总览画面、区域总览画面、块图标和面板的维护组显示中 

有关此主题的更多信息，请参见“维护状态和维护组显示 (页 121)”部分。 

用户界面中的图标 

 

图标 功能 说明 授权 

 锁定消息  面板 

组件的消息被锁定 

 按钮组 

所有显示组件的消息被锁定 

 解锁消息  面板 

组件的消息被解锁 

 按钮组 

所有显示组件的消息被解锁 

过程控制 (1) 

(1) 操作员授权级别可以进行调整。 

操作员授权级别保存在 WinCC 变量管理的内部变量 @LockMessageAuthLevel 中。 该
变量由 OS 项目编辑器创建。 

操作员授权级别取决于保存为变量属性中初始值的数字。 系统将初始值预分配为 5。 

用户管理器中提供了与所需授权对应的数字。 
 

 说明 
请注意，操作员授权级别的任何更改都必须实施到 MS 多工作站系统每一个操作站的项目

中。 
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步骤 

1. 单击所需图标。 

结果 

消息被锁定或解锁。 

更多信息 

更多相关信息，请参见手册《过程控制系统 PCS 7；操作站》。 
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5.10.2.3 如何取消钝化模块或通道 

简介 

在面板中显示钝化符号，以确保维护工程师可检测到冗余模块或其故障通道的差异。  

只要激活差异时间，则将在模块面板中的消息系统中显示“请求维护”状态以及消息。 

此外，如果检测到长期差异，则会钝化相应的模块/通道。 这将导致冗余丢失。 该模块或

通道在块图标中标识为“故障”。 在面板的消息系统中将显示“要求维护”状态、取消钝化符

号和消息。     

如果已消除了引起差异的原因，则可通过面板中的图标执行取消钝化操作。 

用户界面中的图标 

 

图标 功能 说明 授权 
 取消钝化 模块或通道已钝化。 诊断区域的“高级过

程控制” 

步骤 

1. 单击“取消钝化”(Depassivation) 图标。 

2. 单击“执行”(Execute) 按钮。 

结果 

执行了取消钝化操作。 将隐藏该图标。 
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5.10.2.4 如何打开 HW Config 的在线视图 

简介   

“调用硬件项目”(Call hardware project) 图标用于调用硬件配置 (HW Config) 的在线视

图。 
 

 说明 
该功能对 SIMATIC MS PDM 不可用。 

 

用户界面中的图标 

 

图标 功能 说明 授权 
 调用硬件项目 打开硬件配置 (HW Config) 

的在线视图 
诊断区域的“高级过程控制”

显示“调用硬件项目”图标 

此图标显示在现场设备 (EDD) 和 AS 对象的面板的所有视图中。 

如果在 ES 上运行 MS 客户端，则可调用硬件项目。 

要求 

组件是硬件配置的一部分。 

步骤 

1. 单击“调用硬件项目”(Call hardware project) 图标。 

  说明 
在硬件配置 (HW Config) 的在线视图完全打开之前不要继续操作，否则 HW Config 的
在线视图可能被置于后台，并且如果组合键被锁定，则可能无法再次访问此在线视

图。 这种情况下，请再次按下该按钮。 

结果 

打开了硬件配置 (HW Config) 的在线视图。 



 操作员监控 
 5.10 面板 

维护站 
功能手册, 12/2011, A5E03397308-01 139 

5.10.2.5 如何打开 SIMATIC PDM 的组态界面 

简介   

“调用 SIMATIC PDM”(Call SIMATIC PDM) 图标用于为面板中显示的组件调用 SIMATIC 
PDM 的参数分配界面。 

用户界面中的图标 

 

图标 功能 说明 授权 
 调用 SIMATIC 

PDM 
从该组件调用 SIMATIC 
PDM 的组态界面 

诊断区域的“高级过程控制” 

显示“调用 SIMATIC PDM”图标 

此图标显示在现场设备 (EDD) 的面板的所有视图中。 

如果在 ES 上运行 MS 客户端，则可调用参数分配界面。 

要求 

可使用 SIMATIC PDM 对该组件编程。 

步骤 

1. 单击“调用 SIMATIC PDM”(Call SIMATIC PDM) 图标。 

结果 

将打开 SIMATIC PDM。 
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5.10.2.6 如何调用 Web 界面 

简介   

“调用组态数据”(Call configuration data) 图标用于打开组件的 Web 界面。 
 

 说明 
该功能对 SIMATIC MS PDM 不可用。 

 

要求 

● 网络对象必须可通过网络进行访问。 

● 使用“受信任的站点”(Trusted sites) 安全设置。 

有关此主题的详细信息，请参见手册《SIMATIC NET；工业以太网 OSM/ESM 网络管

理》。 

● 网络组件设备的配置文件与 OSM 或 SCALANCE 设备的配置文件相对应。 

用户界面中的图标 

 

图标 功能 说明 授权 
 调用组态数据 调用组件的 Web 界面 诊断区域的“高级过程控制” 

显示“调用组态数据”图标 

此图标显示在网络组件的所有面板视图中。 

无法访问网络组件时，也会显示此图标。 

步骤 

1. 单击“调用组态数据”(Call configuration data) 图标。 

结果 

将打开组件的 Web 界面。 
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5.10.2.7 如何调用“诊断监视器”诊断工具 

简介   

使用“诊断监视器”(Diagnostics Monitor) 图标调用“诊断监视器”诊断工具。 

仅当未通过 PCS 7 Web 客户端操作工厂时，才能使用该诊断工具。 

要求 

● 已安装软件。 

● “诊断监视器”已组态。 

● 已组态端口号。 

● 已在 Windows 防火墙中启用并启动 Web 服务器。 

用户界面中的图标 

 

图标 功能 说明 授权 
 调用“诊断监视

器” 
调用“诊断监视器”诊断

工具 
诊断区域的“高级过程控制” 

显示“调用组态数据”图标 

该图标显示在 IPC 面板中。 

步骤 

1. 单击“诊断监视器”(Diagnostics Monitor) 图标。 

结果 

调用诊断工具。 
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5.10.3 视图 

5.10.3.1 “标识”视图 

适用性 

此视图适用于所有组件。 

概述    

在此视图中，根据组件的不同，信息框中将显示从设备在线读取的组态数据或标识数据。 

所有面板的视图结构均相同；只是标识数据的来源有所不同。 

下图显示了该视图的示例： 
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显示 

● 维护状态 

有关维护状态的更多信息，请参见“维护状态和维护组显示 (页 121)”和“冗余组件的维

护状态 (页 124)”部分。 

● 标识数据 

有关标识数据来源的信息，请参见“标识数据的来源 (页 173)”部分。 

  说明 
并非每个资产都提供所有标识数据。 
如果“标识”(Ident) 视图中的某些标识字段为空，则即使“上一次更新”(Last update) 
字段中的时间戳已更新，组件也不会提供这些数据。 原因可能如下： 

 组件中未保存数据 

 组件不识别数据 
不过，如果“上一次更新”(Last update) 字段中未显示时间戳，则要么标识数据尚未

更新，要么这些组件没有可用的在线数据。 

● 注释 (Comment) 

注释从 HW Config 中读取。 

● 上次更新 (Last update) 

显示上次更新标识数据的时间戳。 

操作元件 

 

图标 说明 授权 

 单击该图标更新组件的标识

数据。 
诊断区域的“过程控制” 
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5.10.3.2 “消息”视图 

适用性 

此视图适用于所有组件。 

概述    

此视图包含组件的所有未决消息。 

显示下列消息： 

● 诊断/错误消息 

● 在工具栏中选择长期归档列表后的操作消息 

下图显示了该视图的示例： 

 

显示 

消息 

● 当前未决消息，与确认状态无关 

● 已离开的未确认消息 

● 除“tagname”过滤器外，仅显示与“诊断”相关的消息。 
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操作员元件 

按照与操作员站上的操作相同的方式进行操作。 

更多相关信息，请参见《PCS 7 过程控制系统，OS 过程控制》手册。 

如果选中短期归档列表，则还会显示用于在“年表”视图和“操作员消息”视图之间切换

的如下图标。 

 

图标 说明 授权 

 
通过单击该图标，可调用短期归档列表并显示

用于在“年表”视图和“操作员消息”视图之

间切换的如下图标。 

 可通过单击该图标更改视图。 

无访问保护 
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5.10.3.3 “维护”视图 

适用性 

此视图适用于所有组件。 

概述 

此视图允许维护工程师要求对特定组件执行维护作业并对维护作业进行管理。 所要求的

维护措施的维护状态会显示在诊断画面的维护组显示中。 维护状态、维护作业和维护作

业的状态也将显示在面板的标题中。     

在此视图中，可执行单个导出，包含各组件的标识数据、维护状态和维护信息。 

下图显示了该视图的示例： 
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显示 

● 维护发布的汇总状态 

显示画面由较低级别/互连的组件及其自身组件的维护发布状态构成。 
 

显示 含义 
 已为涉及的所有组件启用发布 
 至少没有为一个涉及的组件启用发布 

● 工艺区域中较低级别组件和互连组件的维护发布 
 

显示 含义 
 未互连 
 未启用互连和发布 
 已互连且已启用发布 

● 说明 

将显示为维护作业输入的说明文本。 
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操作员元件 

 

图标/ 
名称 

说明 操作员权限 

“维护作业”区域 通过单击选项按钮请求维护作业。 

“请求的操作”区域 从下拉列表框中选择操作。 

例如，可以是“拆卸”操作。 

有关操作组态的信息，请参见“创建维

护操作 (页 74)”部分。 

“请求时间”区域 在输入框中指定维护作业请求的时间。 
请按以下格式输入时间： 
YYYY.MM.DD - hh:mm。 

“服务状态”区域 通过选择操作按钮，可为维护作业指定

处理状态。 

“目标”区域  复选框 

通过选中此复选框，可将单个导出

文件存储在所选目标中。 

 下拉列表框 

从下拉列表框中选择单个导出文件

的存储路径。 最多可同时选择两个

目标。 

有关目标组态的信息，请参见“创建维

护目标 (页 71)”部分。 

 可通过单击该图标打印单个导出文件。

如果未通过 PCS 7 Web 客户端操作工

厂，则可以使用打印功能。   

诊断区域的“过程控

制” 

有关单个导出的信息，请参见“单个导出 - 导出各个组件数据 (页 90)”部分。 
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5.10.3.4 “说明”视图 

适用性   

此视图适用于所有组件。 
 

 说明 
该功能对 SIMATIC MS PDM 不可用。 

 

概述   

在此视图中，可为其他维护工程师留下临时消息。  

下图显示了“说明”视图的示例。 
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操作元件 

 

图标 说明 授权 

空闲区域 说明的文本框 
 通过选中该复选框来启用或禁用说明。 

 启用 

选中复选框时启用说明。 

下次打开面板或者过程画面更改时，可在块

图标和面板的状态栏中看到有新消息。 

 禁用 

将隐藏面板的状态栏和块图标中的显示。 

不自动删除该消息。 

诊断区域的“过程控制” 

 

 

 说明 
请记住，MS（对于单工作站系统是 MS，对于多工作站系统是 MS 服务器）的完整编译

和 MS 服务器的后续下载将删除说明视图的内容。 
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5.10.3.5 “诊断”视图 PC 对象区域 

适用性 

此视图适用于 PC 对象区域中的 IPC 组件。 
 

 说明 
该功能对 SIMATIC MS PDM 不可用。 

 

概述    

此视图中最多可以显示 16 个二进制状态。 

● 下图显示了具有 V1.3 规约的 IPC 组件的视图示例： 

 

● 下图显示了具有 V1.4 规约的 IPC 组件的视图示例： 
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显示 

● 状态 

下表显示了状态的图标标识： 
 

图标标识 含义 

无图标 状态已禁用 
 未决故障 
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5.10.3.6 “诊断”视图 AS 对象区域 

适用性    

以下视图适用于 AS 对象区域中的组件。 
 

 说明 
该功能对 SIMATIC MS PDM 不可用。 

 

开关和驱动器总览 

有关开关和驱动器设备的信息显示在这些视图中。  

● 下图显示了开关视图的示例： 

 

● 下图显示了驱动器视图的示例： 

 

● 下图显示了符合 NAMUR 标准的驱动器的视图示例： 
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显示 

● 状态 

下表显示了状态的图标标识： 
 

图标标识 含义 

无图标 状态已禁用 
 未决故障 
 未决警告 



 操作员监控 
 5.10 面板 

维护站 
功能手册, 12/2011, A5E03397308-01 155 

5.10.3.7 “诊断”视图用户对象区域 

适用性    

以下视图适用于用户对象区域中的组件。 

概述  

在此视图中，显示有关用户对象的信息。  

下图显示了该视图的示例： 

 

显示 

● 状态 

下表显示了状态的图标标识： 
 

图标标识 含义 

无图标 状态已禁用 
 未决故障 

● 显示文本 

文本由用户在 EDD 中 AssetM 块的 PDM 对象中组态。 
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5.10.3.8 “诊断”视图现场设备区域 

适用性 

此视图适用于现场设备区域中的所有组件。 

概述    

在此视图中，显示来自 HART 或 PROFIBUS 现场设备的数据。 

将为 SIMATIC PDM 读取这些数据。 

下图显示了该视图的示例： 
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显示 

● 通过 PDM 通信 

显示上次建立通信时，SIMATIC PDM 与设备之间的通信连接状态 
 

图标 含义 

无图标 无未决状态 
 “良好”状态 

● 设备状态 

显示相关设备的可能状态（符合 PA 规约的标准诊断） 
 

图标 含义 

无图标 无未决状态 
 “良好”状态 
 “不良”状态 

● 详细诊断： 

信息和文本将直接从组件中读取，并由组件制造商提供的 EDD 解释。 

● 循环更新 
 

图标 含义 

 显示更新间隔。 

默认情况下预分配的值为“1 天”。  

如果要更改更新间隔，则需要调整包含测量点的 OS 
服务器的 WinCC 项目中内部变量

“@PDMDiagCycleTime”的值。 

● 上次检查 

上次更新组件数据的时间戳 

  说明 
文本和语言与具体的制造商和设备有关。 显示的语言对应于为 SIMATIC PDM 设置的

语言或制造商的默认语言。 此区域中显示的信息指示相关现场设备的消息。 
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操作员元件 

 

图标 说明 授权 
 通过选中该复选框来启用或禁用循

环更新。 

在此显示中禁用更新。 
 单击该图标更新显示的信息。 

诊断区域的“过程控制” 
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5.10.3.9 “性能”视图 AS 对象区域 

适用性   

此视图适用于 AS 对象区域中具有 SCF78 组件的下列固件版本的 CPU：   

● 标准 CPU >= 固件版本 V5.0 

● H CPU >= 固件版本 V4.5 

概述 

此视图以图形方式显示了 CPU 利用率的总体情况。 棒图中的所有值以百分率的形式给

出。 参考值是组态的 CPU 的最大周期监视时间。 

由于各自上一周期的实际值显示会导致屏幕刷新周期内的减速比显示出现大幅波动，因此

总体情况的所有显示均为平均值。 

下图显示了该视图的示例： 
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显示 

● 总运行时间 

棒图中的值以百分比形式、相对于设置的最大循环监视时间指定。 

其数量级显示在棒图下面。 

– 平均值 

实际值的平均值（以百分比表示）（TOTALPER 块参数） 

– 实际值 

OB3x/OB8x + OB1 所有净运行时间的平均值（以百分比表示）（TOTALCUR 块参

数） 

– 最大值 

由上一个周期的所有 OB3x/OB8x + OB1 净运行时间的净运行时间生成（以百分比

表示）（TOTALMAX 块参数） 

– 最小值 

由上一个周期的所有 OB3x/OB8x + OB1 净运行时间的净运行时间生成（以百分比

表示）（TOTALMIN 块参数） 

● OB3x 的水平棒图 

这些值指的是各自的 OB 循环时间。 

OB 3x 时间的图形显示通过指示缓冲的和丢失的启动事件的指示器  

进行扩展。 

– 净值 

– 总值 

● OB8x 和 OB1 的水平棒图 

这些值指的是已组态的最大循环监视时间。 

– 净值 

● 扫描速率： 

显示用户程序所有循环 OB 的扫描速率 
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操作元件 

 

图标 说明 授权 

 可通过单击该图标复位这些值。 诊断区域的“过程控制” 

避免 CPU 停止工作 

集成到 CPU 中的功能可确保用户程序即使在 CPU 过载的情况下仍可以继续运行，同时

防止 CPU 切换到“STOP”模式。 在“CPU 功能块”(CPU function block) 的“参
数”(Parameters) 视图中对“紧急模式”进行了参数化。 

 

小心 
 

当 CPU 接近满载时，用户程序将变得缓慢。 如果这开始影响到过程模式，则需要对用

户程序进行重新组态。 
 

有关此主题的更多信息，请参见““参数”视图 AS 对象区域 (页 164)”部分。 
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5.10.3.10 “OBx...”视图 AS 对象区域 

适用性    

此视图适用于 AS 对象区域中具有 SCF78 组件的下列固件版本的 CPU： 

● 标准 CPU >= 固件版本 V5.0 

● H CPU >= 固件版本 V4.5。 

概述 

此视图显示了具有诊断功能的 CPU 中 OB 的利用率。 

下图显示了“OB3x”视图的一个示例。 

 

下图显示了“OB8x/OB1”视图的示例。 
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显示 

● OB3x 组织块的利用率显示在“OB3x”视图中： 

– 若干周期内 OB 3x 的绝对总值、净值以及平均值与各情况下组态的 OB 的最大循环

监视时间有关。 

– 自上次 OB 重置后达到的最小值和最大值 

● OB8x 组织块的利用率等级显示在“OB8x/OB1”视图中： 

– 若干周期内 OB8x 和 OB1 的绝对净值和平均值与每种情况下已组态的 OB 的最大

循环监视时间有关。 

– 自上次 OB 重置后达到的最小值和最大值。 

操作元件 

 

图标 说明 操作员权限 

 可通过单击该图标复位这些计数器值。 诊断区域的“过程控制” 
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5.10.3.11 “参数”视图 AS 对象区域 

适用性 

● 适用于 AS 对象区域中的 CPU 组件 

– 标准 CPU >= 固件版本 V5.0 

– H CPU >= 固件版本 V4.5 

概述    

在此视图中，可以为过载行为分配参数。 

CPU 的默认循环监视时间为 6 s。  

如果未能在此时间内处理所有 OB，将导致循环过载。  

要避免 CPU 切换到“Stop”模式，可以参数化“紧急模式”。 

● 下图显示了具有 SFC78 的 CPU 的“参数”视图的示例。 
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● 下图显示了没有 SFC78 的 CPU 的“参数”视图的示例。 

 

紧急模式 

“紧急模式”可自动减小组态的循环任务的速度。 随后，用户程序的运行速度会变得更

慢。 

“紧急模式”不应连续使用。 指示为维护报警。 
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显示/操作 

 

标识符 说明 操作员权限 

过载时 OB3x 减速处理 (OB3x 
reduction with overload) 

过载时更慢地处理 OB。 

通过选中该复选框启用或禁用减速。 

在此显示中，减速已启用。 

抑制 STOP 要求的最大数 (Max. 
number suppr. STOP demanded) 

X 

第 X+2 次超过循环监视时间后，CPU 将切换

至“STOP”模式 

（X 为 1 和 9999 之间的数字） 

系统将数字 50 预设为该块的 X 值。 

报警限制容量 (Alarm limit 
capacity) 

如果总利用率（该值等于所有净运行时间的平

均值之和 [以百分比形式表示的 OB3x、OB8x 
+ OB1]）超过了报警限制容量，则会输出消息

“所有 OB 的净时间消耗超出了最大限值”(Net 
time consumption of all OBs exceeds max. 
limit)，同时维护状态被设置为“要求维

护”(Maintenance demanded)。 

取消减速处理时的百分比 (Cancel 
reduction for) 

当在“达到 x% 时取消减速处理”(Cancel 
reduction for x%) 或“MAX_VAL (CPU_RT)”参
数中组态的控制器最大总利用率相应减小，并

且不再存在长期超出循环时间的现象时，紧急

模式会自动终止。 

滞后报警限制 (Hysteresis alarm 
limit) 

滞后可避免消息“所有 OB 需要的净时间超出

了最大限制”(Net time required by all OBs 
exceeds max. limit)“反复出现”。 

计算 CPU 负载（显示）

(Calculating the CPU load 
(Display)) 

计算指定循环数的用于显示的 CPU 负载。 

计算 CPU 负载（内部）

(Calculating the CPU load 
(internally)) 

计算指定循环数的（内部）CPU 负载。 

诊断区域的“高级过

程控制” 
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标识符 说明 操作员权限 

显示消息时的最小请求错误数 
(Message as of request errors) 

如果超过该值，将输出“OB3x 请求错

误”(OB3x request error) 消息。 

CPU 负载增加至 (CPU load 
increase to) 

只要运行最慢的 OB 重新以正常的运行速度连

续运行 5 个周期后，取消减速处理。 
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5.10.3.12 “客户端组件的连接显示”视图 

适用性    

此视图适用于 OS 客户端、MS 客户端和 OS/MS 客户端类型的 PC 对象区域中的所有组

件。 

如果未通过 PCS 7 Web 客户端操作工厂，则可以使用此视图。   
 

 说明 
该功能对 SIMATIC MS PDM 不可用。 

 

概述 

此视图显示了所加载服务器数据所属的服务器的所有客户端连接。 

服务器为 OS 服务器和 MS 服务器。 

下图显示了该视图的示例： 
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显示 

● 所有服务器的符号计算机名称 

● 所有服务器的计算机名称 

● 冗余伙伴的计算机名称 

● 首选服务器 

● 当前连接 

 

显示 含义 
 已组态的首选服务器 

 当前连接的服务器，连接可用 
 连接可用 
 连接不可用 
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5.10.3.13 “监视”视图用户对象区域 

适用性 

此视图适用于用户对象区域中所有组件。 

概述    

PCS 7 在用户诊断结构中提供了相应工具，可设置针对特定对象（未自动集成到维护站

的诊断画面中的对象）的监视功能。 例如，这些对象包括： 

● 由规则或计算定义的值 

● 不支持诊断的对象（例如，PCS 7 不识别的现场设备） 

● 技术区域 

● 组件的组 

在诊断画面中可显示下列监视功能： 

● 运行时间计 

● 服务间隔 

● 校准间隔 

下图显示了该视图的示例： 
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显示 

● 过程值的标签，例如 PV1 

文本由用户在 EDD 中 AssetM 块的 PDM 对象中组态。 

如果 EDD 中没有标签，则标签会隐藏。 

● 信号状态 

优先级列中的数字指示显示的优先级。最小的数字具有最高的优先级。 
 

显示 优先级 备注 

 1 不良，与设备相关 

 2 不良，与过程相关 

 3 本地功能检查，仿真 

 4 不确定，与设备相关 

 5 不确定，与过程相关 

 6 要求维护 

无 7 良好 

无 - 输入未连接 

● 实际值 

值从 AssetM 块中读取。 

● 保留值 

实际值与下一个限制值之间的差异在 AssetM 块中形成。 

● 测量单位 

测量单位在 AssetM 块中组态。 

● 报警限制 

报警限制在 AssetM 块中组态。 
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操作员元件 

 

图标 说明 授权 
 通过选中该复选框启用或禁用报警限制。 

在此显示中，报警限制已禁用。 

 通过单击此图标可在块中输出脉冲。 可进一步处理此

脉冲，例如复位后面的工艺块（计数器）中的计数器

值。 

诊断区域的“过程控

制” 
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5.11 标识数据的来源 

从哪里获取 IPC 面板的标识数据？    

对于 IPC 面板，将从数据管理器读取变量的标识数据。 可以通过 OPC 服务器属性中的

“导出 WinCC 变量”(Export tags for WinCC) 功能，创建这些变量。 

 

来源 标识数据 

规约 V1.3 规约 V1.4 规约 MIB-II 

TAG/HID SNMP 变量“.sysName” PC 站的对象属性 
“计算机名称” 

LID HW Config/OPC 服务器“名称” PC 站的对象属性 
“名称” 

地址 (Address) HW Config/OPC 服务器的“IP 地址”/ 
SNMP 变量“&ipAddress()” 

IP 地址，终端总线 CCAgent 

描述 (Description) 不可用 SNMP 变量“.&description()” 不可用 

消息 (Message) 不可用 消息 (Message) 不可用 

设备类型 (Device 
type) 

SNMP 变量“.ProductName” IWbemService 
(Win32_ComputerSystem_Model) 

制造商 
(Manufacturer) 

SNMP 变量“.Manufacturer” IWbemService 
(Win32_ComputerSystem_Manufacture
r) 

订货号 (Order 
number)  

不可用 SNMP 变量“.OrderNumber” IWbemService 
(Win32_ComputerSystemproduct_ 
IdentifyingNumber) 

序列号 (Serial 
number) 

SNMP 变量“.SerialNumber” IWbemService 
(Win32_BaseBoard_SerialNumber) 

安装日期 
(Installation date) 

不可用 SNMP 变量“.SwDate” IWbemService 
(Win32_OperatingSystem_ 
InstallDate) 

硬件修订版 (HW 
revision) 

SNMP 变量“.HwVersion” IWbemService 
(Win32_BaseBoard_Version) 
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来源 标识数据 

规约 V1.3 规约 V1.4 规约 MIB-II 

软件修订版 
(Software 
revision) 

SNMP 变量“.SwVersion” IWbemService 
(Win32_BIOS_SMBIOSVersion) 

上次更新 (Last 
update) 

更新标识数据时的时间戳 

注释 (Comment) PC 站的对象属性“注释” 

从哪里获取 PC 面板的标识数据？ 

对于 PC 面板，将从数据管理器读取变量的标识数据。  

 

标识数据 来源 

TAG/HID PC 站对象的对象属性“计算机名称” 

LID PC 站的对象属性“名称” 

地址 (Address) IP 地址，终端总线 CCAgent 

描述 (Description) 不可用 

消息 (Message) 不可用 

设备类型 (Device 
type) 

IWbemService (Win32_ComputerSystem_Model) 

制造商 
(Manufacturer) 

IWbemService (Win32_ComputerSystem_Manufacturer) 

订货号 (Order 
number)  

IWbemService 
(Win32_ComputerSystemproduct_IdentifyingNumber) 

序列号 (Serial 
number) 

IWbemService (Win32_BaseBoard_SerialNumber) 

安装日期 
(Installation date) 

IWbemService (Win32_OperatingSystem_InstallDate) 

硬件修订版 (HW 
revision) 

IWbemService (Win32_BaseBoard_Version) 

软件修订版 
(Software revision) 

IWbemService (Win32_BIOS_SMBIOSVersion) 
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标识数据 来源 

上次更新 (Last 
update) 

更新标识数据时的时间戳 

注释 (Comment) PC 站的对象属性“注释” 

从哪里获取 OSM 面板的标识数据？ 

对于 OSM 面板，将从数据管理器读取变量的标识数据。 可以通过 OPC 服务器属性中的

“导出 WinCC 变量”(Export tags for WinCC) 功能，创建这些变量。 

 

来源 标识数据 

Profil_OSM_V10.txt 规约 MIB-II 

TAG/HID WBM“automationFunctionTag” 不可用 

LID HW Config/OPC 服务器“名称” 

地址 (Address) HW Config/OPC 服务器的“IP 地址”/ 
SNMP 变量“.&ipAddress()” 

描述 (Description) 

消息 (Message) 

不可用 

设备类型 (Device type) WBM“设备类型”/ 
SNMP 变量“.sysDesr” 

制造商 (Manufacturer) WBM“automationManufacturerId” 

订货号 (Order number) SNMP 变量“.snInfoOrderNr” 

序列号 (Serial number) SNMP 变量“.snInfoSerialNr” 

安装日期 (Installation 
date) 

不可用 

硬件修订版 (HW 
revision) 

SNMP 变量“.snHWVersion” 

软件修订版 (Software 
revision) 

SNMP 变量“.snSWVersion” 

不可用 



操作员监控  
5.11 标识数据的来源 

 维护站 
176 功能手册, 12/2011, A5E03397308-01 

来源 标识数据 

Profil_OSM_V10.txt 规约 MIB-II 

上次更新 (Last update) 更新标识数据时的时间戳 

注释 (Comment) HW Config/OPC 服务器“注释” 

WBM = 基于 Web 的管理（网络对象的 Web 界面） 
 

 

 说明 
可以使用“OPC Scout”工具对标识数据进行调整。 
有关此主题的更多信息，请参见“使用网络组件修改标识数据 (页 180)”部分。 

 

从哪里获取 AS 面板的标识数据？ 

对于 AS 面板，将从块属性中读取标识数据或者动态地从 CPU 中读取标识数据。 

 

标识数据 来源 

HID / TAG 

静态 

动态 

 

HW Config“较高级别标识”(HID) 

I&M 数据 (SZL)，(I&M1 Tag_Function) 

LID 

静态 

 

HW Config“标识”或“名称” 

地址 (Address) 不可用 

描述 (Description) 

静态 

动态 

 

HW Config“更多信息” 

I&M 数据 (SZL)，（I&M3 描述信息） 

消息 (Message) 不可用 

设备类型 (Device type) HW Config“类型”或“简要描述” 

制造商 (Manufacturer) 

静态 

动态 

 

HW Config - 不可访问* 

I&M 数据 (SZL)，(I&M0 Manufacturer_ID)



 操作员监控 
 5.11 标识数据的来源 

维护站 
功能手册, 12/2011, A5E03397308-01 177 

标识数据 来源 

订货号 (Order number) 

静态 

动态 

 

HW Config“订货号” 

I&M 数据 (SZL)，(I&M0 Order_ID) 

序列号 (Serial number) 

静态 

动态 

 

不可用 

I&M 数据 (SZL)，(I&M0 Serial_number) 

安装日期 (Installation date) 

静态 

动态 

 

HW Config“安装日期” 

I&M 数据 (SZL)，(I&M2 Installation_date) 

硬件修订版 (HW revision) 

静态 

动态 

 

不可用 

I&M 数据 (SZL)，(I&M0 
Hardware_revision) 

软件修订版 (Software revision) 

静态 

动态 

 

HW Config - 不可访问* 

I&M 数据 (SZL)，(I&M0 
Software_revision) 

上次更新 (Last update) 更新标识数据时的时间戳 

注释 (Comment) HW Config“注释” 

* 不可访问是指在此用户不能进行任何输入或修改。 
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从哪里获取 PDM 面板的标识数据？ 

在 PDM 面板上，标识数据通过 COM 接口以 XML 格式读取到 PDM 中。 

 

标识数据 来源 

TAG/HID EDD PDM“TAG” 

LID EDD PDM“安装位置” 

地址 (Address) 不可用 

描述 (Description) EDD PDM“描述信息” 

消息 (Message) EDD PDM“消息” 

设备类型 (Device 
type) 

EDD PDM“产品名称” 

制造商 
(Manufacturer) 

EDD PDM“制造商” 

订货号 (Order 
number)  

EDD PDM“订货号” 

序列号 (Serial 
number) 

EDD PDM“设备序列号” 

安装日期 (Installation 
date) 

EDD PDM“安装日期” 

硬件修订版 (HW 
revision) 

EDD PDM“硬件修订版” 

软件修订版 (Software 
revision) 

EDD PDM“软件修订版” 

上次更新 (Last 
update) 

PDM 数据库更新的时间戳 

注释 (Comment) HW Config“注释” 
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AssetM 面板的标识数据来自何处？ 

在 AssetM 面板上，标识数据以 XML 格式通过 COM 接口或通过数据管理器中的变量读

出到 PDM 中。 

 

标识数据 来源 

TAG/HID EDD PDM“TAG” 

LID EDD PDM“安装位置” 

地址 (Address) 不可用 

描述 (Description) EDD PDM“描述信息” 

消息 (Message) EDD PDM“消息” 

设备类型 (Device 
type) 

EDD PDM“产品名称” 

制造商 
(Manufacturer) 

EDD PDM“制造商” 

订货号 (Order 
number)  

EDD PDM“订货号” 

序列号 (Serial 
number) 

EDD PDM“设备序列号” 

安装日期 (Installation 
date) 

EDD PDM“安装日期” 

硬件修订版 (HW 
revision) 

EDD PDM“硬件修订版” 

软件修订版 (Software 
revision) 

EDD PDM“软件修订版” 

上次更新 (Last 
update) 

PDM 数据库更新的时间戳 

注释 (Comment) CFC“块注释” 
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5.12 使用网络组件修改标识数据 

简介    

在过程控制期间，将在面板上显示组件的 SNMP 变量值。 可以使用“OPC Scout”实用程

序更改默认设置。 

步骤 

1. 在 Windows“开始”(Start) 菜单中，选择 SIMATIC > SIMATIC NET > OPC Scout 子菜

单。 

将打开 OPC Scout。 

2. 在树形视图中，双击条目“服务器 > 本地服务器 > OPC SimaticNET”(Server > Local 
Server(s) > OPC SimaticNET)。 

将打开“添加组”(Add group) 对话框。 

3. 在“输入新的组名称”(Enter a new 'Group name') 输入字段中，输入一个新组的名

称，然后单击“确定”(OK)。 

将在树形视图中创建新组。 

4. 双击新创建的组。 

将打开“OPC 浏览器”(OPC Navigator) 对话框。 

5. 在树形视图中，选择“连接 > SNMP”(Connections > SNMP) 条目。 

6. 例如，选择“SNMP 服务器的名称（CP 1623 或 CP 1613）> 系统”(Name of SNMP 
server (CP 1623 / CP 1613) > System)。 

7. 从列表中选择条目“sysname”和“syslocation”并单击箭头按钮“-->”。 

将显示所选条目。 

“sysname”用于面板中的字段“天”(Day)，“syslocation”用于字段“描述”(Description)。 

8. 单击“确定”(OK)。 

9. 双击要更改的值（至少需要对该值具有访问权限“W”）。 

将打开“写入条目值”(Write values of items) 对话框。 

10. 输入工厂特定的名称并单击“确定”(OK)。 

11. 如果要更改任何其它值，请重复步骤 9 和 10。 

12. 使用菜单命令文件 > 退出 (File > Exit) 关闭 OPC Scout。 
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5.13 维护作业与维护状态之间的关系 

简介  

维护工程师可以在面板的“维护”视图中生成维护作业。     

维护工程师提供过程控制的状态 

以下的“OS 操作员控制的状态”图中说明了可能的状态转换。 

 

由维护工程师执行状态转换。  

维护工程师为组件创建维护作业（维护报警、要求维护或需要维护）。 对相关组件执行

维护时，维护工程师会将维护作业的状态设置为“进行中”(In progress)。 

维护结束之后，维护工程师会将维护作业的状态设置为“已完成”(Completed)。 



操作员监控  
5.14 维护发布概述 

 维护站 
182 功能手册, 12/2011, A5E03397308-01 

5.14 维护发布概述 

概述   

在面板中，工厂操作员（OS 区域的操作员）可以为维护工程师（诊断区域的操作员）启

用某一组件（例如面板中的电机）的维护发布。 维护发布在组件的相应的面板中向维护

工程师显示。 

维护工程师可以在面板的“维护”视图中为组件创建维护作业。 进行维护时，维护工程

师将该组件置于“进行中”(In progress) 状态下。 “进行中”(In progress) 状态在面板中向操

作员显示。 

此外，工厂操作员可将该模式切换到“停止运行”模式。 在此模式下，会关闭块的所有

消息和功能。 

更多信息 

有关激活和禁用的更多信息，请参见后面的部分以及各工艺块的在线帮助。 
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5.15 如何激活/取消激活维护发布 

激活维护发布 

要求   

● 在 CFC 中工艺块互连。 

● 已激活“开”或“手动”模式。 

● 操作员具有“系统操作”的操作权限。 

步骤 1 - 工厂操作员 

1. 打开工艺面板。 

2. 选择“参数”(Parameter) 视图。 

3. 选中“维护发布”(Release for maintenance) 框。 

结果 

将生成一条操作员消息。 

维护发布显示在诊断面板中“维护”视图的“进行中”(In progress) 选项按钮前方。 

步骤 2 - 维护工程师 

1. 打开诊断面板。 

2. 选择“维护”(Maintenance) 视图。 

3. 选择“进行中”(In progress) 选项按钮。 

结果 

将生成一条操作员消息。 

根据组态而定，将在工艺面板上显示以下图标： 

● “正在进行维护”(Maintenance in progress) 图标 

● “停止运行”模式和“正在进行维护”(Maintenance in progress) 图标 

可以执行维护。 维护操作完成后，必须由工厂操作员手动取消启用。 
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取消激活维护发布 

步骤   

1. 打开工艺面板。 

2. 选择“参数”(Parameter) 视图。 

3. 取消选择“进行中”(In progress) 选项按钮。 

结果 

“正在进行维护”(Maintenance in progress) 图标在工艺面板中隐藏。 

激活模式“停止运行”已重置。 
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5.16 维护作业的执行 

简介   

本部分介绍维护作业执行的概述。 

可以自组件的维护状态变为“良好”时起或在组件上存在消息后请求维护作业。 

处理维护作业时，可以在“说明”(Note) 区域中输入有关维护作业的说明。 

输入的文本显示在“说明”(Note) 区域的以下位置中： 

● 面板说明区域的“标识”(Ident) 视图中 

● 短期归档列表说明区域的“消息”(Message) 视图中 

● 操作列表的消息系统中 

对于维护状态“维护报警”，使用自组件的维护状态变为“良好”时起的维护作业来描述

执行过程。  

要求 

组件的“维护”(Maintenance) 视图已打开。 

维护发布可用。 

步骤 

1. 在“维护作业”(Maintenance job) 区域中，选择“报警”(Alarm) 选项按钮。 

用于激活维护作业的控制字段显示在面板视图下方。 

2. 单击控制字段中的“开”(On)。 

请求维护作业“报警”。 

在面板标题和块图标中，“请求维护报警”状态显示在维护组显示的图标中。 

显示： 

 

此外，面板标题中还会显示维护作业状态“维护工程师尚未创建维护作业”

(Maintenance engineer has not yet created a maintenance job)。 

显示： 
 

3. 如果需要，在“说明”(Note) 区域中输入文本。 
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4. 在“服务状态”(Service status) 区域中选择“进行中”(In progress) 选项按钮。 

用于激活“服务状态”(Service status) 的控制字段显示在面板视图下方。 

5. 单击“开”(On)。 

在块标题中，维护作业的状态显示从“维护工程师尚未创建维护作业”(Maintenance 
engineer has not yet created a maintenance job) 更改为“进行中”(In progress) 状态。 

显示： 

 

6. 如果需要，在“说明”(Note) 区域中输入文本。 

7. 导出维护作业。 

– 在“目标”(Targets) 区域中，选中与目标对应的复选框。 

– 从相应的下拉列表中选择目标。 

– 如果需要，在“目标”(Targets) 区域中选中另一目标的复选框。 

– 从相应的下拉列表中选择目标。 

– 单击“导出”(Export)。 

显示： 
 

8. 在“服务状态”(Service status) 区域中选择以下选项按钮： 

– 如果要完成维护作业，请选择“已完成”(Completed) 选项按钮。 

– 如果要取消维护作业，请选择“取消”(Cancel) 选项按钮。 

用于激活“服务状态”(Service status) 的控制字段显示在面板视图下方。 

9. 单击“开”(On)。 

组件的维护状态显示在块标题和块图标的维护组显示中。 

维护作业“已取消”或“已完成”状态的图标显示在块标题中。 

显示维护作业状态“已取消”或“已完成”： 

 

“说明”(Note) 区域中的文本即被删除。 

结果 

维护作业已完成。 

有关单个导出的更多信息，请参见““维护”视图 (页 146)”部分。
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集成选项 6
6.1 通过报警控制中心集成 

6.1.1 “报警控制中心”的应用 

报警控制中心   

报警控制中心 (ACC, Alarm Control Center) 是 PCS 7 的附件。 借助提供的选项，可以对

报警控制中心进行自定义，以适合从独立解决方案到公司范围通信解决方案的所有方案。 

可将维护站监视组件的消息转发到报警控制中心以供进一步处理。 

报警控制中心提供下列功能： 

● 将消息转发到特定接收方 

● 集成了轮班和人员管理，可以根据时间向不同人员发送消息 

● 即使无法到达个别接收方时，广泛的升级系统也能可靠地发送消息 

● 通过 Web 功能进行网络范围的操作员控制和组态 

  说明 
只能在 MS 标准和 SIMATIC MS PDM 版本中使用报警控制中心。 
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将消息转发到特定接收方 

可以转发来自单个组件的下列消息： 

● 诊断消息 

● 有关操作的消息 

● 有关要求维护的消息 

可以接收通过 ACC 自动发送的消息的接收方包括： 

● 发送到移动电话的 SMS 

● 传呼机 

● 输出到电话的语音 

● 电子邮件 

● 发送到 PC 的 LAN 消息 
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6.1.2 配置总览 

下表列出了包含信息和组态说明的主题。 表中列示的顺序与建议的组态顺序一致。   

 

步骤 内容 步骤 

1 组态单个导出 单个导出 - 导出各个组件数据 (页 90) 

2 创建维护目标 创建维护目标 (页 71)  

2 创建维护操作 创建维护操作 (页 74)  

3 为脚本组态触发变量 如何组态全局脚本的触发变量 
(页 190)  

4 创建一个脚本，用于将数据传送到报

警控制中心 
如何创建用于将数据传送到 ACC 的全

局脚本 (页 191)  

5 组态许可证编号 如何组态 ACC 的许可证编号以实现导

出功能 (页 194)  

6 将数据集成到报警控制中心 将数据集成到 ACC 中 (页 195)  

7 组态报警控制中心 在 ACC 中组态 (页 195)  
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6.1.3 如何组态全局脚本的触发变量 

简介   

数据通过全局脚本传送到报警控制中心。 此全局脚本使用一个触发变量。 

下面，我们将创建触发变量“@ASSET_EXPORT_FINISHED”。 

要求 

WinCC 项目已打开： 

● 在 MS 单工作站系统中，是指 MS 的 WinCC 项目。 

● 在 MS 多工作站系统中则是 MS 服务器的 WinCC 项目。 

步骤 

1. 在 WinCC 项目管理器中，从树形视图中选择“变量管理”(Tag Management) 编辑器。 

2. 选择“内部变量”(Internal tags) 对象。 

3. 打开快捷菜单，并选择菜单命令“新建变量...”(New tag...)。 

将打开“变量属性”(Tag properties) 对话框中的“常规”(General) 选项卡。 

4. 在“名称：”(Name:) 输入字段中，输入触发变量“@ASSET_EXPORT_FINISHED”。 

5. 转到“数据类型：”(Data type:) 下拉列表框并选择条目“无符号 32 位整型”(Integer 
unsigned 32 Bit)。 

6. 单击“确定”(OK)。 
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6.1.4 如何创建用于将数据传送到 ACC 的全局脚本 

简介      

使用一个全局脚本将数据从组件传送到 ACC。此全局脚本在 WinCC 项目管理器的“全局

脚本”编辑器中创建。 

使用实例脚本创建全局脚本。在 Process Control System; SIMATIC PCS 7 V8.0 或更高

版本的 DVD 的“Additional_Products/ACC_integration/Scripts”目录下提供了该示例脚本。  

有关该示例脚本的信息，请参见“用于将数据导出到 ACC 的脚本示例 (页 196)”部分。 
 

 说明 
示例脚本适用于以下组态中的连接： 

 使用 MS 单工作站系统时，ACC 核心系统安装在 MS 上。 

 如果使用 MS 多工作站系统，ACC 核心系统安装在 MS 服务器上并且 MS 服务器未采

用冗余设计。 
有关与 ACC 的连接的更多信息，请参见报警控制中心的文档。 

 

使用实例脚本前，先根据所用 PC 的实际目录结构检查在其中组态的文件名和路径规范。 
必要时对它们进行更改。 

在扩展的诊断设置中组态维护目标。 

从示例脚本复制名称和路径。 

有关此主题的更多信息，请参见“创建维护目标 (页 71)”部分。 

该示例脚本具有能够在首次启动脚本时自动创建路径的指令。 

要求 

● 维护目标和维护操作的组态已完成。 

● 触发变量“@ASSET_EXPORT_FINISHED”已组态。 
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步骤 

1. 在 WinCC 项目管理器的树形视图中，选择“全局脚本”(Global Script) 编辑器。 

2. 选择快捷菜单命令“打开 VBS 编辑器”(Open VBS Editor)。 

3. 在 VBS 编辑器的导航窗口中，选择“操作”(Actions) 选项卡。 

4. 选择快捷菜单命令“新建”(New) >“动作”(Action)。 

5. 复制“用于将数据导出到 ACC 的脚本示例 (页 196)”部分中的示例脚本代码，并将其

插入到“Function action”和“End Function”代码行之间。 

插入代码行时确保脚本中尚没有这些代码行。 

6. 选择“文件 > 保存”(File > Save) 保存该操作。 

由于这是一项新操作，因而会打开“另存为”(Save As) 对话框。 输入操作的名称，

例如“ACC_Send_Messages”。 

7. 选择变量“@ASSET_EXPORT_FINISHED”作为全局脚本的触发器。 

选择菜单命令“额外 > 信息/触发器”(Extras > Info/Trigger)。  

将打开“属性”(Properties) 对话框。 

8. 选择“触发器”(Trigger) 选项卡。 

9. 在导航窗口中选择条目“变量”(Tag)。 

10. 单击“添加”(Add) 按钮。 

将打开“添加触发器”(Add trigger) 对话框。  

在“变量名”(Tag name) 输入框中输入名称“@ASSET_EXPORT_FINISHED”。 

11. 单击“添加”(Add) 按钮。 

即会在“触发器名称”(Trigger name) 表中输入此变量。  

还可以使用“...”按钮打开一个选择对话框，然后从中选择变量。 

12. 单击“确定”(OK)。 

将关闭“添加触发器”(Add trigger) 对话框。 

13. 单击“确定”(OK)。 

将关闭“属性”(Properties) 对话框。 
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14. 选择菜单命令“文件 > 保存”(File > Save)。 

将保存该操作。 

15. 选择菜单命令“文件 > 退出”(File > Exit)。 

将关闭 VBS 编辑器。 

结果 

现在，实现了用于将数据导出到报警控制中心的所需组态。  
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6.1.5 如何组态 ACC 的许可证编号以实现导出功能 

简介 

对于个别导出，需要将报警控制中心 (ACC, Alarm Control Center) 的许可证编号用作导

出文件中的参数。 因此，必须从“报警控制中心”中重新获取许可证编号，并在维护站的文

件“logininfo.xml”中对其进行组态。    

在 过程控制系统；SIMATIC PCS 7 V8.0 或更高版本的 DVD 的
“Additional_Products/ACC_integration/LoginInfo”目录下提供了“logininfo.xml”文件作为示

例。  

要求 

● 报警控制中心的许可证编号已知。 

可以在报警控制中心的“系统概述”中的“耦合代理程序”以及条目“OpenInterface”
下找到该许可证编号。 

步骤 

1. 在 Windows 资源管理器中，浏览到 过程控制系统；SIMATIC PCS 7 V8.0 或更高版本

的 DVD 光盘的“Additional_Products/ACC_integration/LoginInfo”目录。 

2. 从该 DVD 中，将子目录“ACC”作为子目录复制到维护站本地 WinCC 项目目录的

“<wincc 项目名称>”下。 

默认情况下，该 WinCC 项目位于相应 S7 项目目录的子目录“wincproj/<wincc 项目名

称>”中。  

路径“<wincc 项目名称>/ACC”用于示例脚本中的 XML 文件。 

3. 使用如 Windows 记事本之类的 XML 编辑器打开“logininfo.xml”文件。 

4. 在“<许可>”(<License>) 参数中，输入报警控制中心的许可证编号。 默认情况下以实

例文件的格式指定。 

5. 选择菜单命令“文件 > 保存”(File > Save)。 

6. 选择菜单命令“文件 > 退出”(File > Exit)。 

结果 

现在，为单个导出组态了报警控制中心的许可证编号。  
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6.1.6 将数据集成到 ACC 中 

将数据集成到报警控制中心 

有关如何将数据集成到报警控制中心的更多信息，请参阅报警控制中心文档。   

 

6.1.7 在 ACC 中组态 

规则  

在报警控制中心进行组态时，必须遵守以下原则：  

● 需要具有“ACC 开放接口运行许可证 (CAL)”的耦合代理程序“OpenInterface”。 

● 发送通道“ACC LAN Message”为首选。 必须已经设置了路由器。 

● 必须为“ACC LAN Message”通道设置“管理员”(Administrator) 用户。 将“localhost”设
置为电话号码。 
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6.1.8 用于将数据导出到 ACC 的脚本示例 

简介    

在使用该脚本示例之前，请阅读“如何创建用于将数据传送到 ACC 的全局脚本 (页 191)”
部分。 

以下示例脚本可用于将组件的数据导出到报警控制中心。 

示例脚本 
Option Explicit 
Function action 
 
' Links to online help of Microsoft VBS objects 
'  VBScript language reference: http://msdn.microsoft.com/en-
us/library/d1wf56tt.aspx 
'  “FilesystemObject”： http://msdn2.microsoft.com/en-
us/library/hww8txat.aspx 
'  "Files" Object     : http://msdn2.microsoft.com/en-
us/library/18b41306.aspx 
'  "Folder" Object    : http://msdn2.microsoft.com/en-
us/library/1c87day3.aspx 
 
Dim ExportTarget 
Dim AlarmGroup 
Dim loginInfoPath 
AlarmGroup = "9999" ' use default alarm group 9999 
ExportTarget = "ACC_Export" 
 
' The logininfo contains the host name of the ACC server, the 
agent name and 
' your license key. It must be adapted to your environment. 
LoginInfoPath = HMIRuntime.ActiveProject.Path & 
"\ACC\logininfo.xml" 
 
Dim fso    ' FileSystemObject 
Dim folder ' folder where XML files are stored 
Dim fc     ' Files Collection 
Dim f1     ' current file in Files Collection 
 
Set fso = CreateObject("scripting.filesystemobject") 
Set folder = fso.GetFolder(HMIRuntime.ActiveProject.Path & _ 
 "\AssetExport\" & ExportTarget & "\Out\") 
Set fc = folder.Files 
 
' create and initialize Interlink and job helper objects 
Dim il ' FSP3Interlink.Interlink object 
On Error Resume Next 
Set il = HMIRuntime.DataSet("il").Value 
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If IsEmpty(il) Then 
    Set il = CreateObject("FSP3Interlink.Interlink") 
     
    'AssetExport\" & ExportTarget  
    Dim file 
    Dim logininfo 
    Set file = fso.OpenTextFile(LoginInfoPath) 
    loginInfo = file.ReadAll() 
    il.AddGateway "dcom://localhost", 5, loginInfo, Nothing, 
False 
 
    HMIRuntime.DataSet.Add "il", il 
End If 
 
For Each f1 In fc 
    If Right(f1.name, 4) = ".xml" Then 
        Dim job 
        Dim MessageText 
        Dim objXML 
 
        Set objXML = CreateObject("MSXML2.DOMDocument.3.0") ' 
delivered with IE 6.0SP1, see 
http://support.microsoft.com/kb/269238 
        objXML.validateOnParse = True 
 
        ' load XML file 
        If Not objXML.Load(f1.Path) Then 
            ' error while loading or parsing the XML document 
            HMIRuntime.Trace "Error parsing the XML document" & 
vbCrLf & vbCrLf _ 
            & "Reason: " & objXML.parseError.reason & vbCrLf _ 
            & "Line: " & objXML.parseError.Line 
 
            ' process next XML file and rename this file to 
ignore it next time 
            fso.MoveFile f1.Path, f1.Path + ".error" 
        Else 
            ' adapt created Messagetext to your needs 
            Dim child 
         
            MessageText = "Maintenance Request: " 
         
            Set child = 
objXml.documentElement.selectSingleNode("/Document/b2mml:Equipmen
tInformation/b2mml:Equipment/b2mml:EquipmentProperty/b2mml:Value/
b2mml:ValueString[../b2mml:Key='Name']") 
            MessageText = MessageText & " Tag=" & child.text 
     
            Set child = 
objXml.documentElement.selectSingleNode("/Document/b2mml:Maintena
nceInformation/b2mml:MaintenanceRequest/b2mml:Problem") 
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            MessageText = MessageText & " / Problem=" & 
child.text 
         
            Set child = 
objXml.documentElement.selectSingleNode("/Document/b2mml:Maintena
nceInformation/b2mml:MaintenanceRequest/b2mml:Requestor") 
            MessageText = MessageText & " / Requestor=" & 
child.text 
         
            Set child = 
objXml.documentElement.selectSingleNode("/Document/b2mml:Maintena
nceInformation/b2mml:MaintenanceRequest/b2mml:Status") 
            MessageText = MessageText & " / Status=" & child.text 
         
            ' prepare Job object 
            Set job = CreateObject("FSP3Interlink.Job") 
            job.MsgText = MessageText 
            job.AddAlarmGroupToCall(AlarmGroup) 
             
            ' submit the job to ACC 
            Dim sHost 
            Dim sJobID 
            sHost = "" 
            sJobID = il.SubmitJob("", "", job, sHost) 
            ' save sJobID for further processing, when necessary 
(e.g. acknowledge handling) 
             
            ' delete file when it has been successfully processed 
to prohibit processing the same file again 
            fso.DeleteFile f1.Path, True 
        End If 
    End If 
Next 
 
 
End Function 

6.1.9 将数据导出到报警控制中心 

在过程控制中，于组件的“维护”(Maintenance) 视图中导出用于报警控制中心的组件数

据。   

在“目标”(Target) 区域中选择相关目标。 
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