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This Guide uses a specific example for channel 1 (axis 1) with servo drive or step drive with four ope-
rational steps in successive order. These lead to a functioning application with which you can execute
a traversing movement and familiarize yourself with and test the basic hardware and software func-
tions of your FM 453. The references to the manual will give you your first impression of the informa-
tion to be found there.

The handling of channels 2 and 3 is similar to channel 1. Differences will be appropriately noted.

Depending on your level of experience, you will need approximately 1 1/2 to 2 1/2 hours to work
through this example.

Hardware and software requirements
The following requirements must be fulfilled:
� You have a SIMATIC 400 station comprising a power supply module and a CPU with a mounting

rack.
� You have an FM 453 module, the configuration package for the FM 453, and the necessary acces-

sories such as front connector and wiring material.
� You have a power section (e.g. SIMODRIVE 611-A or FM STEPDRIVE), a motor (e.g. 1FT5 or

SIMOSTEP) and the appropriate setpoint cable. The power section and the motor are in operation.
� You have a rotary incremental encoder (only for servo drive) and the appropriate measurement

system cable.
� STEP 7 (V5.3 + SP2 for later) is installed correctly on your programming device.

Installing and wiring the FM 453
Hang the FM 453 onto the rail, swing it downwards, and screw it in place. You will find more detailed
instructions in Section 3.1 of the Manual.

Wire up the front connector X1  and fasten it into place. Connect it to an auxiliary 24 V supply for the
encoder supply (only for servo drives). The reference potential (analog ground) for the auxiliary supply
is to be connected with the reference potential for the CPU terminal. You can find more information
about connecting the front connector in Sections 4.6 and 4.7 in the Manual.

Connect the drive to channel 1: 

Wire the free cable end of the connecting cable to the terminals of the drive unit or plug the female
sub-D connector (15 pin) into the FM STEPDRIVE module. (The terminal identifiers on the cable ends
indicate the proper terminals for SIMODRIVE units.) For SIMODRIVE devices it is required that motor
rotation be to the right for positive setpoint value speeds. For SIMODRIVE devices, the pulse must be
enabled by connecting 24 V to the input GATE_N. Insert the sub-D connector (50 pin) in the connector
X5 on the FM 453. Lock the connector in place with the knurled screws. For more information on con-
necting the drives, see Sections 4.2 and 4.3 of the Manual.

Connecting the encoder (only for servo drives):

Connect the connecting cable to the encoder. Insert the sub-D connector (15 pin) into the X2 socket of
the FM 453. Lock the connector in place with the knurled screws. For more information on connecting
the drives, see Sections 4.4 and 4.5 of the Manual.
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Connect the programming device to the CPU.

Switch the CPU to the STOP state.

Test:  Switch on the power on the power supply module. After a successful internal module test, none
of the three LEDs (INTF, EXTF, STAT) should be lit.

Installing the configuring package on the programming device

The configuring package contains the parameterization tool “Paramerterize FM 453”, which contains
functions (FCs), the data structure (UDT 1), a pre-programmed example interface for OP 7/17 (irreve-
lant here) as well as user examples.

Insert the CD ROM in the CD ROM drive of your PG/PC.

Run file Setup.exe on the CD ROM.

Follow the step by step instructions given by the installation program.

The software is installed in the following default directories:
� Parameterization tool “Paramerterize FM 453”: “Siemens\Step7\S7FUPOS”
� Function blocks: “Siemens\Step7\S7LIBS\FMSTSV_L”
� Interface for OPs: “Siemens\Step7\EXAMPLES\FM453\zEn17_02_FM453_OP_EX”
� User examples: “Siemens\Step7\EXAMPLES\zEn17_02”

STEP7 project name: “zEn17_02_FM453_EX”
� MD-DBs (startup of stepper motor control): “Siemens\Step7\EXAMPLES\FM453\MD”

The installation of the configuring package is also described in Section 5.1 of the Manual.

Parameterizing the FM 453
If you haven’t yet created a project, then proceed as follows:

Create a new project in the SIMATIC Manager create a new project with the commands  File → New
→ Projects  and give it a name. Insert your project in the newly created project window with the com-
mands  Insert → SIMATIC 400 Station.

Select the  SIMATIC 400 Station. Access the S7 hardware configuration with the commands  Edit →
Open object.

With  Insert → Hardware Components  or  View → Catalog  open the hardware catalog. Within this
catalog select  SIMATIC 400 → RACK-400 → CR2/UR1/UR2  (depending on the rack). Then drag the
rack into your hardware project.

Select, in the same way, the power supply module, the CPU and the FM 453 module with the corres-
ponding reference numbers (MLFBs) in the hardware catalog and drag them into the desired slot (slot
1 for the power supply, slot 3 for the CPU, slot 5 for the FM 453).

Save and compile the created hardware project with the commands  Station → Save and Compile.

Note: Now, your project contains the configured CPU and FM 453.

Select the FM 453 in your hardware project.

Open the “Properties − FM 453 − (R0/S5)” dialog with  Edit → Object Properties.

Click on the  Parameters...  button to open the user interface “Parameterize FM 453”.

Confirm the message to save the project with  OK.
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Servo drive

By clicking on the button  MD  in the overview window a new machine data data block (DB-MD) for
channel 1 is opened. This DB MD is preset with default values (figure “Machine Data).

With these default values and by configuring your plant as follows you can execute a traverse move-
ment:
� Power section: SIMODRIVE 611-A
� Motor: 1FT5
� Encoder: rotary incremental encoder 2 500 increments per revolution

If your plant is configured differently, you have to parameterize the following machine data according
to your configuration:
� Controller data: MD26 “Zero speed range”
� Axis data: MD23 “Maximum speed”
� Encoder data: MD11/12 “Distance per encoder revolution” 

MD13 “Increments per encoder revolution”

Stepper motor

By installing the configuring package you have installed the directory “FM453\MD”. This directory con-
tains data blocks for machine data to start up FM STEPDRIVE and the corresonding SIMOSTEP.
These DB-MDs are preset with machine data which allow you to execute a traversal movement.

In the directory “[STEP7 directory]\EXAMPLES\FM453\MD” open the MD file for the desired motor for
channel 1 with the command  File → Import  (note file extension!).

e. g. si02_453.md for SIMOSTEP 2 Nm motor.

In the tab “Drive interface” under MD37 deactivate the  Drive ready active  setting. In the tab “Drive
data”  deactivate  the “Phase current control of drive” setting.

If you have a different plant configuration, you have to parameterize your machine data according to
your configuration:

Drive data: MD11/12 “Distance per motor revolution” 
MD53 “No. of steps per motor revolution”

If you have customized your servo drive or stepper motor configuration parameters, proceed
as follows.

Save the DB-MD with  File → Save.

Close the “Machine data” window.

In the overview window click on the button  Transfer data to FM....

In the dialog box “Transfer of data blocks” under “Data block offline” select the machine data block
“DB 1205”.

By clicking on the button  Transfer to FM  you transfer the MD-DB to the FM 453.

Close the dialog box.

Test: You have set up the necessary safety proceedures for moving an axis!

Open the startup window with  Test → Startup  or by clicking on the button  Startup  in the over-
view window.

Set the operating mode to  Jogging.

Click  Controller enable  and  Drive enable.
Enter Override 50 %.

Click the button  R+.

You can now execute a traversal movement by pressing the  space bar . The motor will turn
(according to the speed set in step 1) as long as you hold the space bar down. You can monitor
the actual position in the startup interface (properties of axis according to default values).
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If an error occurs during testing, you can reset by clicking the button  Restart  or  Ack.  (Acknowledge)
or  DIQ  in the startup window.

You can read the error message number and error message with the menu command  Test → Alarms
in the overview window.

If you change machine data, you can activate these changes by clicking on the button  MD active  af-
ter loading the FM.

Note: For more information regarding startup, please see Section 7 of the Manual.

You can find information on parameterizing the FM 453 in Section 7 of the Manual.

Linking into user program using an example

By installing the configuring package, you have installed the example project “zEn17_02_FM453_Ex”.
With the example 1 from this project you can, move the axis of the FM 453 after following the previous
steps.

Do the following:

Close “Parameterize FM 453” , “Properties” and “S7 HW Config”.

Confirm the message “Save changes in SIMATIC 400 (1)?” with  Yes.

Open the example project zEn17_02_FM453_EX in the SIMATIC Manager with the menu command
File → Open → Project.

In this example project select the directory “EXAMPLES”.
This directory contains:
� a file “Symbols”
� a directory “Blocks”

Select the file “Symbols” and copy it into your project under  SIMATIC 400 Station → CPUxxx → S7
Program.

Confirm the message “...Do you want to replace the existing object and all its components?” with  Yes.

Open the directory “Blocks” in the example project zEn17_02_FM453_EX and copy all blocks in your
project under  SIMATIC 400 Station → CPUxxx → S7 Program → Blocks.

The following blocks are in your project:
� FC 0 to FC 3 − technology functions
� FC 100 − basic example for setting the operating mode
� FC 101 to FC 103 − examples 1, 2, 3
� DB 1 − user data block (from UDT 1)
� DB 100 − example data block (DBEX)
� OB 1 − cycle OB
� OB 100 − restart OB
� OB 82 − diagnosis alarm OB
� UDT 1 − user-defined data type
� Variables table VAT1...3

Open “OB100” with a double click.

The LAD / STL / FBD editor will be started.

For the example, enter the call parameter LADDR:=512 in OB 100 in the FC “POS_INIT” under Net-
work 2.

Note: For channel 2 or 3 enter channel no. 2 or 3 in “CH_NO”.

Save OB 100 by selecting  File → Save.

Close the Editor.

Select  SIMATIC 400 Station → CPUxxx → S7 Program → Blocks  in the SIMATIC Manager. Load all
the S7 blocks (including system data) stored in this directory to your CPU (CPU in STOP state) by
selecting  Target System → Load.

Switch your CPU to the RUN-P state.
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After a successful startup of the CPU and the FM 453, the following values have been set by OB 100:
� The “Jog” mode with the operating parameter BP = 1 (value of speed step 1)
� Override 100 %
� Servo enable is set
� Velocity levels: 40 m/min (level 1) and 80 m/min (level 2)

You can monitor the status of the FM module in the main display or by selecting  Test → Start-up  in
the parameterization tool. You can open the parameterization tool screen by selecting  SIMATIC 400
Station → Edit → Open Object, double clicking on the FM 453 object and finally clicking on button
Parameters  in the “Properties” dialog.

To be able to monitor or set the bits in DB 100 used in the user program, you must start the “View and
Control Variables” tool. To do this, select your project in the SIMATIC Manager and then select  
SIMATIC 400 Station → CPUxxx → S7 Program → Blocks. With a double click on the variables table
VAT1 in the “Blocks” directory, you open the “View and Control Variables” tool. Establish an online
connection via the menu  Target System →�Establish Connection to → CPU Configured (directly con-
nected CPU).

Enter the following bits in the column headed “Operand”:
� DBEX.EX1DIR_P (plus direction)
� DBEX.EX1.DIR_M (minus direction)
� DBEX.EX1.GO_P (plus travel)
� DBEX.EX1.GO_M (minus travel)

To start the axis (plus direction), enter “2#1” in the “Control Value” column in the line for bit
“DBEX.EX1.DIR_P” and activate the traverse motion by selecting  Variables → Activate Control Val-
ues.
To end the movement, change the value of bit “DBEX.EX1.DIR_P” from “2#1” to 2#0 and terminate
the motion by selecting menu commands  Variables → Activate Control Values.

To start the axis (minus direction), enter “2#1” in the “Control Value” column in the line for bit
“DBEX.EX1.DIR_M” and activate the traverse motion by selecting  Variables → Activate Control Val-
ues.
To end the movement, change the value of bit “DBEX.EX1.DIR_M” from “2#1” to 2#0 and terminate
the motion by selecting menu commands  Variables → Activate Control Values.

You can monitor the operands cyclically by selecting  Variables → View.

You can update the operands once for monitoring by selecting  Variables → Update Status Values.

For information about programming standard function blocks, please refer to Section 6 of the Manual.

Further examples
In the zEn17_02_FM453_EX project you will find other examples which you can use as a guide and
which you can adapt to your application.

Note

In normal operation you should turn on the alarm generation (valid for channels 1 to 3), alarm selec-
tion (valid for channels 1 to 3) and all monitors (per channel). 
Alarm generation can be set in the dialog box “Properties − FM 453 − (R0/S5)” in the tab “Basic Para-
meters” (see section 5.2 in the Manual under “Parameterize FM 453”)
You can set monitoring (per channel), e.g. hardware monitoring MD20, software limit switch MD21/22
etc. with parameterize.

Please note that the data will again be transferred to FM 453 and to the CPU.

Diagnostics
Errors can occur as a result of incorrect operation, incorrect wiring, or contradictory parameter assign-
ments which the FM 453 displays with the LEDs “INTF”, “EXTF” and “STAT”

For a description of how to localize and remedy errors and messages of this type, please refer to Sec-
tion 11 of the Manual.
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