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Legal information 
Use of application examples 

Application examples illustrate the solution of automation tasks through an interaction of several 
components in the form of text, graphics and/or software modules. The application examples are 
a free service by Siemens AG and/or a subsidiary of Siemens AG ("Siemens"). They are 
non-binding and make no claim to completeness or functionality regarding configuration and 
equipment. The application examples merely offer help with typical tasks; they do not constitute 
customer-specific solutions. You yourself are responsible for the proper and safe operation of the 
products in accordance with applicable regulations and must also check the function of the 
respective application example and customize it for your system. 
Siemens grants you the non-exclusive, non-sublicensable and non-transferable right to have the 
application examples used by technically trained personnel. Any change to the application 
examples is your responsibility. Sharing the application examples with third parties or copying the 
application examples or excerpts thereof is permitted only in combination with your own products. 
The application examples are not required to undergo the customary tests and quality inspections 
of a chargeable product; they may have functional and performance defects as well as errors. It is 
your responsibility to use them in such a manner that any malfunctions that may occur do not 
result in property damage or injury to persons. 
 

Disclaimer of liability 
Siemens shall not assume any liability, for any legal reason whatsoever, including, without 
limitation, liability for the usability, availability, completeness and freedom from defects of the 
application examples as well as for related information, configuration and performance data and 
any damage caused thereby. This shall not apply in cases of mandatory liability, for example 
under the German Product Liability Act, or in cases of intent, gross negligence, or culpable loss of 
life, bodily injury or damage to health, non-compliance with a guarantee, fraudulent 
non-disclosure of a defect, or culpable breach of material contractual obligations. Claims for 
damages arising from a breach of material contractual obligations shall however be limited to the 
foreseeable damage typical of the type of agreement, unless liability arises from intent or gross 
negligence or is based on loss of life, bodily injury or damage to health. The foregoing provisions 
do not imply any change in the burden of proof to your detriment. You shall indemnify Siemens 
against existing or future claims of third parties in this connection except where Siemens is 
mandatorily liable. 
By using the application examples you acknowledge that Siemens cannot be held liable for any 
damage beyond the liability provisions described. 
 

Other information 
Siemens reserves the right to make changes to the application examples at any time without 
notice. In case of discrepancies between the suggestions in the application examples and other 
Siemens publications such as catalogs, the content of the other documentation shall have 
precedence.  
The Siemens terms of use (https://support.industry.siemens.com) shall also apply.  
 

Security information 
Siemens provides products and solutions with Industrial Security functions that support the secure 
operation of plants, systems, machines and networks. 
In order to protect plants, systems, machines and networks against cyber threats, it is necessary 
to implement – and continuously maintain – a holistic, state-of-the-art industrial security concept. 
Siemens’ products and solutions constitute one element of such a concept. 
Customers are responsible for preventing unauthorized access to their plants, systems, machines 
and networks. Such systems, machines and components should only be connected to an 
enterprise network or the Internet if and to the extent such a connection is necessary and only 
when appropriate security measures (e.g. firewalls and/or network segmentation) are in place.  
For additional information on industrial security measures that may be implemented, please visit 
https://www.siemens.com/industrialsecurity. 
Siemens’ products and solutions undergo continuous development to make them more secure. 
Siemens strongly recommends that product updates are applied as soon as they are available 
and that the latest product versions are used. Use of product versions that are no longer 
supported, and failure to apply the latest updates may increase customer’s exposure to cyber 
threats. 
To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed 
at: https://www.siemens.com/industrialsecurity. 
 

 

 

https://support.industry.siemens.com/
https://www.siemens.com/industrialsecurity
https://www.siemens.com/industrialsecurity
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Foreword 

Aim of this document 

Typical PCS 7 systems have at least one ES (Engineering Station) on the PC side,  
one or more possibly redundant servers and several OS clients (Operator Stations).  
In addition to the maximum availability of process control and data acquisition, there is 
also the possibility of integrating program adjustments or expansions in the foreground, 
quickly and without affecting the current process. 

In contrast, small systems or stand-alone units often require very little maintenance 
after commissioning. To achieve high efficiency, there exists the requirement to get 
along with as few PC stations as possible. It therefore makes sense to utilize the 
rarely used ES as an OS in process mode. 

This document is intended to help you in choosing a suitable PC set-up for small 
systems. It compares various minimal configurations (up to a maximum of three PCs) 
in terms of their functionality. Since the corresponding PCS 7 configuration is not the 
main focus of the system documentation, here you can also find the necessary 
activities for installation in the form of detailed step instructions. 

Core contents 

The main focus is on the following: 

• Configuration comparison regarding functionality 

• Activities for configuration, activation, and maintenance of different configurations 

 

 

 

Validity    

SIMATIC PCS 7: 

• V9.1 

• V9.0 

• V8.2
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1 Overview of Minimal Configurations 
There are various possible options when utilizing the engineering station in process 
mode as an operator station or multiple operator stations with as few PCs as possible. 
The following versions were selected according to their feasibility and usefulness in 
the context of PCS 7. 

The configurations shown here also include descriptions of solutions with configurations 
that do not differ significantly from each other. 

In general, particular functionality criteria must be considered when using the engineering 
PC as an OS, because the OS project must be closed when performing certain activities. 
This will also be discussed in more detail below. 

 

1.1 ES/OS Single Station 

The smallest of all configurations only needs one PC station. 
 

ES/OS

 

 

Process mode/functionality 

Since version 6.1 of PCS 7, it has also been possible to compile the OS project 
when runtime is activated (change compilation). This means that the operator and 
archiving functions are present permanently. 

 

Note You can find a description of this configuration and a how-to guide in chapter 3 
"ES/OS Single Station". 

 

Note The ES/OS Single Station can also be extended with the functionality of the 
PCS 7 OS Web Server. You can find a guide to doing this in chapter 7 
"Expansion with the PCS 7 OS Web Option". 



1 Overview of Minimal Configurations 

 

Minimal Configuration 
Entry-ID: 24023824,    V8.0,    02/2022   7 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
2

2
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

1.2 ES/OS Client and OS Server 

With an additional PC station as an OS server, the ES can be used as an OS client. 
This accesses the data of the OS server in process mode and visualizes it. 

Terminal bus

OS ServerES/OS Client

  

 

Process mode/functionality 

In PCS 7, the OS server can be used for operator functions when no more than 
four OS clients are connected. In this example, if the server malfunctions, the 
complete OS functionality fails. Besides this, the OS client must be terminated to 
make OS project changes at a later stage. However, the OS server keeps on 
working permanently at compiling/loading of changes. 

 

Note You can find a description of this configuration and a how-to guide in chapter 4 
"ES/OS Client and OS Server". 

 

Alternatives/variations 

One of the advantages of this configuration is the option of connecting additional 
clients to the OS server on a relatively simple and inexpensive basis. 
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1.3 ES, OS Master and OS Standby 

You need three PC stations for PCS 7-compliant implementation of OS 
redundancy.  

In this case, the ES only carries out engineering tasks and, while doing this, is only 
used for testing OS functions. 

OS MasterES OS Standby

COM-Cable

PROFINET IE

Terminal bus

Redundancy

 

 

Process mode/functionality 

Since the ES is not involved in process mode, the operator functions of the two OS 
Single Stations are permanently available. The OS remains active even during 
complete loading of project changes. Redundancy ensures mutual synchronization 
both when online and after the failure of one of the two partners. 

The COM connection (RS 232 connecting cable) is for optimization of internal 
server-to-server communication. 

Since PCS 7 V7.0, it has been possible, as an alternative to the COM connection, 
to use a separate Ethernet connection (a free on-board or additional network 
adapter) for the redundancy connection. 

Note You can find a description of this configuration and a how-to guide 5 "ES, OS 
Master and OS Standby". 

 

Alternatives/variations 

In the case of the low-maintenance systems that this document focuses on, you 
can often do without a permanently available if it is possible to rent a temporary ES 
for configuration, commissioning, and project changes. 

In this example, it is only conceivable to extend the system using additional OS 
clients if a server operating system is installed on the OSes.  
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1.4 ES/OS Master and OS Standby 

In this configuration with two redundant OS Single Stations, one of the stations is 
also used as a simultaneous ES, which obviates the need for a separate third 
station. 

ES/OS Master OS Standby

COM-Cable

Terminal bus

Redundancy

 

 

Process mode/functionality 

In this example, both PC stations work in process mode as redundant OS single 
stations that balance each other both in operation and after the failure of one of the 
two partners. This is also relevant for later OS project changes, which require the 
Master OS to be exited. In this case, the Standby OS takes over the master role. It 
keeps on working permanently while compiling/loading changes and updates the 
redundancy partner after it returns. 

The COM connection (RS 232 connecting cable) is used to optimize internal 
communication between the two OS Single Stations. 

Since PCS 7 V7.0, it has been possible, as an alternative to the COM connection, 
to use a separate Ethernet connection (a free on-board or additional network 
adapter) for the redundancy connection. For complete loading, you must deactivate 
OS Runtime and the OS projects on both stations and close them. For this period, 
no OS functionality is available. 

 

Note This configuration does not offer all of the PCS 7 functionality, since redundancy 
is set up using WinCC resources. 

In chapter 6 "ES/OS Master and OS Standby“, you can find corresponding 
limitations in process operation and differences in system behavior together with 
a description of configuration and a how-to guide. 
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Alternatives/variations 

For PCS 7-compliant implementation of OS redundancy, we recommend using 
three PC stations. With the changes to the license concept from PCS 7 V8.0 
onward, you will need the same number of license packages. The implementation 
of redundancy with two PC stations is associated with some limitations (see 
chapter 6.1 "Configuration description") and, compared to PCS 7-compliant 
implementation with a separate ES and two redundant OS Single Stations (see 
chapter 1.3 "ES, OS Master and OS Standby“), only saves you one computer 
(hardware and Windows license). 

 

Note The ES/OS Single Station can also be extended with the functionality of the 
PCS 7 OS Web Server. You can find a guide to doing this in chapter 7 
"Expansion with the PCS 7 OS Web Option". 
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2 General/optional system settings 
The system settings that are relevant to configuration are presented below. 

 

2.1 Bus connection of the PC stations 

Plant bus 

In the ES and in each server, a network card is used in "Configured mode" for the 
plant bus. On this network card, only the ISO protocol is enabled for Windows. If a 
CP1623 is present, it is used for accessing the plant bus. Parameterization is 
carried out in SIMATIC NetPro and in the HW Config. 

Terminal bus 

Except for configuration with only one ES/OS Single Station, all of the other PC 
stations are additionally linked to the terminal bus. When doing this, the necessary 
second network card of the ES and the server is set here to "PG mode”. This card 
is not configured in SIMATIC NetPro and in the HW Config. PCS7 finds this 
network access via the computer name or the specified path for the target machine 
that must be entered in the object properties of the PC station. For this network 
card, only the TCP/IP protocol (not ISO) is activated in Windows. 

Client PC stations are generally fitted with only one network card that is used to 
connect to the terminal bus. For this network card, only the TCP/IP protocol (not 
ISO) is activated in Windows. 

 

2.2 Autostarting WinCC 

This document contains the step-by-step instructions for opening the OS project on 
the OS servers and clients for runtime activation in the WinCC Explorer. 

This should be usually avoided in the system, since there are generally no 
configuration licenses (RC licenses) on the OSes. If WinCC Explorer is open for 
longer than two hours while doing this, WinCC switches to Demo mode and you 
must close it completely (including runtime) and reopen it for further configuration 
steps. 

To activate runtime automatically when the computer starts without having to open 
WinCC Explorer, you can configure an automatic start for the project. 

In conjunction with SIMATIC NET 2005 Edition (WinCC V6.0 SP3 and above), you 
should configure the "AutoStartRT" WinCC tool on the "Set configuration 

console PC station" to configure the WinCC automatic start. You can find 

more information in the following FAQs: 

https://support.industry.siemens.com/cs/ww/en/view/23061262 

https://support.industry.siemens.com/cs/ww/en/view/23061262
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3 ES/OS Single Station 

3.1 Configuration description 

The Single Station is the smallest possible configuration. The same PC is used for 
both ES and OS functionality. 

Hardware configuration 

ES/OS

Plant bus

AS

 

 

PCS 7 configuration 
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3.2 Required hardware and software licensing 

Hardware 

The following hardware is recommended for this configuration and can be ordered 
via the Siemens mall. Your selected operating system and the appropriate scope of 
the SIMATIC PCS 7 system software are preinstalled on the PC station. 

 

Station Product designation Operating 
system 

Plant bus transition 

1 x ES/OS SIMATIC PCS 7 ES/OS IPC847E BCE Windows 10 RJ45 network card 

SIMATIC PCS 7 ES/OS IPC847E IE Windows 10 CP1623 

 

Software licensing 

The following section lists the software/license package that are necessary for this 
configuration selection. 

In the selected configuration as a Single Station, the number of POs is limited to a 
maximum of 2000. 

 

Component Software/licence packages 

ES/OS • SIMATIC PCS 7 ES Single Station (incl. 250 AS/OS Runtime POs) 

• SIMATIC PCS 7 AS runtime license 

• SIMATIC PCS 7 OS runtime license  
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3.3 Step-by-step configuration 

Note The following instructions have been drawn up based on Windows 7 and 
PCS 7 V9.0. A CP1623 is used as an example of the plant bus transition. Time 
synchronization is activated. 

 

3.3.1 ES configuration 

Creating the multiproject 

As the basis for the instructions below, the station must be physically networked as 
shown in the illustration in chapter 3.1. Apart from this, you must create a 
multiproject on the ES in which the hardware and software of the AS are already 
configured. 

AS settings 

This example describes a way in which the OS server specifies the master time. 

 

Note More time synchronization options are described in detail in the following 
manuals: 

• "SIMATIC PCS 7 Operator Station" 
https://support.industry.siemens.com/cs/ww/en/view/109805404 

• "SIMATIC Process Control System PCS 7 Time Synchronization" 
https://support.industry.siemens.com/cs/ww/en/view/109805436 

 

Step Activity Screenshot 

1.  Open the HW Config for the AS. 

Highlight the CPU and choose "Object 
properties..." in the shortcut menu. 

 

https://support.industry.siemens.com/cs/ww/en/view/109805404
https://support.industry.siemens.com/cs/ww/en/view/109805436
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Step Activity Screenshot 

2.  Switch to the "Diagnostics/Clock" tab. 

In the "Clock" section, set "As slave" for 
the AS under “Synchronization Type”. 

Click on the "OK" button to confirm your 
selection. 

 

3.  Open the shortcut menu of the CP and 
select "Object properties…". 

 

4.  Switch to the "Time synchronization" tab. 

Select the "Accept time of day on CP and 
forward" check box. 

Click on the "OK" button to confirm the 
setting. 
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Step Activity Screenshot 

5.  Save the configuration and compile it 
using: "Station > Save and 

Compile…". 

Close the HW Config. 
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Creating a PC station 

The PC station is created in the PCS 7 project that represents both the ES and the OS. 

 

Step Activity Screenshot 

1.  In component view, open the shortcut menu 
of the project and use "Insert New 

Object > SIMATIC PC station" to add 

a new PC station. 

 

2.  Use the shortcut menu to open the object 
properties of the PC station. 

 

3.  Change the name of the ES PC station to 
match the name of the local computer on the 
network. 

Select the “Computer name identical to PC 
station name” checkbox. 
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Step Activity Screenshot 

4.  Open the HW Config of the PC station via the 
shortcut menu. 

 

5.  Insert a "WinCC application” and a network 
card of type "CP1623” from the object catalog 
(View > Catalog). 

 

6.  Under “Subnet”, choose the plant bus or 
create it by clicking on the “New…" button. 

Assign the corresponding MAC address to 
the CP1623. 

Deselect the "IP protocol is being used" 
checkbox. 

Click on the “OK” button to confirm your 
settings. 
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Step Activity Screenshot 

7.  Open the shortcut menu of the CP1623 and 
select "Object properties…". 

 

8.  Switch to the “Options" tab and select the 
"Time of day” checkbox. 

Click on the "OK" button to confirm your 
selection. 

 

9.  Use the "Station > Save and 

compile..." menu item to save the 

configuration and compile it. 

Close the HW Config. 
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Configuring the PC station 

The "Configure PC station" function transfers project configurations to one or more 
target stations. 

 

Step Activity Screenshot 

1.  Configure the Station Configuration Editor 
of the ES. To do this, highlight the PC 
station of the ES and then choose  
"PLC > Configure…" in the shortcut 

menu. 

 

2.  Under "Accessible computers:” choose the 
PC that you want to configure. 

 

NOTE 

If you chose the option "PC name identical 
to PC station name" for the PC station in 
the “Object properties”, the system 
displays directly in the component 
configurator the target PC to be 
configured. 

 

Using the "Display..." button, you can 
display the current configuration of the PC 
station. 

Click on the “Configure…” button. 
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Step Activity Screenshot 

3.  In the window that appears, you can see 
how the PC station is configured. 

Click on the "OK" button to confirm this. 

 

4.  Click on the "OK" button to confirm the 
information dialog. 

 

5.  In the bottom window, you then see the 
message: "Transfer completed 
successfully." 

Close the configuration dialog. 
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Configuring and loading AS-OS communication 

In the following section, the connection is configured using NetPro and loaded in 
the stations. 

 

Note In the case of a granular station configuration, you must merge the subnets of 
the individual sub-projects first. 

 

Step Activity Screenshot 

1.  Open NetPro. 

Highlight the WinCC application of the ES 
and open the shortcut menu. Choose 
"Insert New Connection". 

 

2.  In the "Connection Partner" window, 
select the CPU of AS. 

Make sure that an “S7 connection" is 
selected under “Connection”. 

Click on the "OK" button to confirm your 
selection. 
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Step Activity Screenshot 

3.  On the “General" tab under "Connection 
identification”, change the “Local ID:" to a 
descriptive name like AS1, for example. 

Click on the "OK" button to confirm your 
entry. 

 

4.  Save and compile by means of: 
“Network > Save and Compile…". 

Select "Compile and check everything". 

Click on the "OK" button to confirm your 
selection. 

 

5.  Highlight the ES and download the 
connection via the shortcut menu: 
"Download to current project > 

Selected Stations". 

Download the AS in the same way. 

Then, close NetPro. 

 

 

Compiling and loading the user program 

Compile the S7 program and download it to the AS. 

 

Compiling the OS project 

Compile the OS project in SIMATIC Manager. 
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3.3.2 OS configuration 

Step Activity Screenshot 

1.  Open the OS project. 

In the open WinCC Explorer, highlight the 
OS project and choose “Properties” in the 
shortcut menu. 
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Step Activity Screenshot 

2.  On the “General” tab under “Type:”, 
choose "Single-user project". 

Click on the "OK” button to confirm your 
selection and the message that the system 
then displays. 

 

 

3.  On the "Options" tab, select the "Allow 
activation on the ES" option. 

NOTE 

When using PCS 7 V9.0 and above, the 
"Allow activation on the ES" option is 
automatically selected and grayed out if 
you have not configured a “Path to the 
target OS computer”. 
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Step Activity Screenshot 

4.  Click on the "No" button to prevent the 
startup list being deleted. 

 

5.  Open the "Time Synchronization" editor. 

 

Select the "Synchronization via System 
Bus (Master, Slave)" checkbox. 

Under "Access point 1”, choose 
“CP1623(ISO)” and select the "Master” 
radio button. 

Click on the "OK" button to confirm your 
selection. 

 

6.  Close WinCC Explorer. 

 

NOTE 

The changes do not take effect until you 
have closed and reopened WinCC 
Explorer. 
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3.3.3 Activating runtime 

After the OS project has been closed, open it again and activate runtime. 

 

3.3.4 Particularities when loading OS project changes 

If the OS and ES are operated on a single PC, you do not need to carry out a 
loading operation because all the required data is already available. In this case, 
you only need to run the "Compile OS" function. 

In a similar way to the "Download changes" function, you can run the "Compile changes" 
function in the Single Station without exiting process mode in the OS. 
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4 ES/OS Client and OS Server 

4.1 Configuration description 

In a server-client structure with only two computers, the ES is used as an OS client 
at the same time. Three PCs should be provided in this configuration. 

 

ES/OS Client

Plant bus

OS Server

Terminal bus

AS

 

 

PCS 7 configuration 
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4.2 Required hardware and software licensing 

Hardware 

For this configuration, we recommend using the hardware below which you can 
order via the Siemens mall. This ensures that the appropriate number of selected 
operating systems and SIMATIC PCS 7 system software packages are pre-installed 
on the PC stations. 

 

Station Product designation Operating system Plant bus 
transition 

1 x ES/OS 
Client 

SIMATIC PCS 7 ES/OS IPC847E 
BCE 

Windows 10 RJ45 
Network card 

SIMATIC PCS 7 ES/OS IPC847E IE Windows 10 CP 1623 

1 x OS Server SIMATIC PCS 7 ES/OS IPC847E 
BCE 

Windows Server 2019 RJ45 
Network card 

SIMATIC PCS 7 ES/OS IPC847E IE Windows Server 2019 CP 1623 

 

Software licensing 

The following section lists the software/license packages that you need for the 
selected configuration. 

Depending on the project size, an OS server can provide up to 12,000 POs with 
the corresponding software package. In addition to engineering software, OS client 
software must also be installed on the ES. 

 

Component Software/licence packages 

ES/OS client • SIMATIC PCS 7 AS/OS Engineering Software (PO unlimited) 

• SIMATIC PCS 7 AS Runtime License  

• SIMATIC PCS 7 OS Software Client 

OS Server • SIMATIC PCS 7 OS Software Server 

• SIMATIC PCS 7 OS Runtime License 
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4.3 Step-by-step configuration  

Note The following instructions have been drawn up based on Windows 7 and  
PCS 7 V9.0. 

CP1623 are used as an example of the plant bus transition. Time 
synchronization is activated. 

The PC stations used in the test setup are called: 

• ES/OS client: ESV81 

• OS server:      SV 

 

4.3.1 Preparatory activities 

Create a project folder on the OS server and share it. This allows the OS data 
configured on the engineering station to be transferred to the OS server. 

 

4.3.2 ES configuration 

Creating the multiproject 

As the basis for the following instructions, all of the PC stations must be physically 
networked as shown in the illustration on page 28. Apart from this, you must create 
a multiproject on the ES in which the hardware and software of the AS are already 
configured. 

Then, you start with the following CPU and CP settings. 
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AS settings 

This example describes a way in which the OS server specifies the master time. 

 

Note More time synchronization options are described in detail in the following 
manuals: 

• "SIMATIC PCS 7 Operator Station" 
https://support.industry.siemens.com/cs/ww/en/view/109805404 

• "SIMATIC Process Control System PCS 7 Time Synchronization" 
https://support.industry.siemens.com/cs/ww/en/view/109805436 

 

Step Activity Screenshot 

1.  Open the HW Config for the AS. 

Highlight the CPU and choose "Object 
properties..." in the shortcut menu. 

 

2.  Switch to the "Diagnostics/Clock" tab. 

In the "Clock" section, set "As slave" for 
the AS under “Synchronization Type”. 

Click on the "OK" button to confirm your 
selection. 

 

https://support.industry.siemens.com/cs/ww/en/view/109805404
https://support.industry.siemens.com/cs/ww/en/view/109805436
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Step Activity Screenshot 

3.  Open the shortcut menu of the CP and 
select "Object properties…". 

 

4.  Switch to the "Time synchronization" tab. 

Select the "Accept time of day on CP and 
forward" check box. 

Click on the "OK" button to confirm the 
setting. 

 

5.  Save the configuration and compile it 
using: "Station > Save and 

Compile…". 

Close the HW Config. 
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Setting up the ES PC station 

To be able to test the OS project on the ES, create a PC station for the ES using 
the WinCC application. 

 

Step Activity Screenshot 

1.  In component view, open the shortcut 
menu of the project and use "Insert 
New Object > SIMATIC PC 

station" to add a new PC station. 

 

 

2.  Use the shortcut menu to open the object 
properties of the PC station. 

 

3.  Change the name of the ES PC station to 
match the name of the local computer on 
the network. 

Select the “Computer name identical to 
PC station name” checkbox. 
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Step Activity Screenshot 

4.  Open the HW Config of the PC station via 
the shortcut menu. 

 

5.  Insert a "WinCC application”  
(and a network card) of type 

“CP1623”  
from the object catalog (View > Catalog). 

 

6.  Under “Subnet”, choose the plant bus or 
create it by clicking on the “New…" button. 

Assign the corresponding MAC address to 
the CP1623. 

Deselect the "IP protocol is being used" 
checkbox. 

Click on the “OK” button to confirm your 
settings. 

 

7.  Open the shortcut menu of the CP1623 
and select "Object properties…". 
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Step Activity Screenshot 

8.  

Optionally 

Switch to the “Options" tab and select the 
"Time of day” checkbox. 

Click on the "OK" button to confirm your 
selection 

NOTE 

You do not need to activate Time of day of 
the CP 1623 for an ES/OS client 
combination, since time synchronization of 
the OS client is configured via the terminal 
bus.  

 

9.  Save and compile using the "Station > 

Save and compile…" menu item. 

Close the HW Config. 

 

10.  

Optionally 

In SIMATIC Manager, delete the OS 
application of the ES PC station, since it is 
not needed in our example. 

 

Setting up the OS server PC station 

Step Activity Screenshot 

1.  In component view, open the shortcut 
menu of the project and use "Insert 
New Object > SIMATIC PC 

station" to add a new PC station. 
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Step Activity Screenshot 

2.  Use the shortcut menu to open the object 
properties of the PC station. 

  

3.  Change the name of the OS server PC 
station to match the name of the computer 
on the network. 

Select the “Computer name identical to PC 
station name” checkbox. 

 

4.  Open the HW Config of the PC station via 
the shortcut menu. 

 

5.  From the object catalog 
("View > Catalog"), insert a "WinCC 

application" and a network card of type 
"CP1623". 
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Step Activity Screenshot 

6.  Under “Subnet”, choose the plant bus or 
create it by clicking on the “New…" button. 

Assign the corresponding MAC address to 
the CP1623. 

Deselect the "IP protocol is being used” 
checkbox. 

Click on the “OK” button to confirm your 
settings. 

 

7.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

8.  Switch to the “Options" tab and select the 
"Time of day” checkbox. 

Click on the "OK" button to confirm the 
setting. 

 

9.  Save and compile using the "Station > 

Save and compile…" menu item. 

Close the HW Config. 
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Step Activity Screenshot 

10.  In SIMATIC Manager, open the properties 
dialog of the OS server's OS project. 

Switch to the "Target OS and Standby OS 
Computer" tab. 

Under "Standby OS”, choose <none>. 

Then, click on the "Search..." button. 

 

11.  Use the drop-down list to navigate to the 
shared project folder of the OS server  
(see 4.3.1 Preparatory activities). 

Click on the "Save" button. 

 

12.  In the input field, check the "Path to the 
Target OS Computer". 

Clear the “Transfer to external archive 
server” checkbox if you are not using a 
Process Historian. 

Click on the "OK" button to confirm this. 

 

13.  Click on the “Yes” button to confirm the 
information dialog. 
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Setting up the Client PC station 

Step Activity Screenshot 

1.  In component view, open the shortcut 
menu of the project and use "Insert 
New Object > SIMATIC PC 

station" to add a new PC station. 

 

2.  Use the shortcut menu to open the object 
properties of the PC station. 

 

3.  Enter a freely selectable name under 
"Name". 

Under "PC name:" enter the name of the 
PC on which you intend to operate the 
client. In the present configuration, this is 
the ES PC. 

Click on the "OK" button to confirm your 
entry. 

 



4 ES/OS Client and OS Server 

 

Minimal Configuration 
Entry-ID: 24023824,    V8.0,    02/2022   40 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
2

2
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

Step Activity Screenshot 

4.  Open the HW Config of the OS client's PC 
station. 

 

5.  From the object catalog (View > Catalog) 
insert a WinCC application client. 

 

6.  Save and compile using menu command: 
"Station > Save and Compile…". 

Close the HW Config. 
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Configuring all of the relevant PC stations 

The "Configure PC station" transfers project configurations to one or more target stations. 
First of all, configure the local Station Configuration Editor of the ES and then the OS 
connected to the plant bus. 

 

Step Activity Screenshot 

1.  Configure the Station Configuration Editor 
of the ES. To do this, open the shortcut 
menu of the ES and choose “PLC > 

Configure…". 

 

2.  Under "Accessible computers:” choose the 
PC that you want to configure. 

 

NOTE 

If you chose the option "PC name identical 
to PC station name" for the PC station in 
the “Object properties”, the system 
displays directly in the component 
configurator the target PC to be 
configured. 

 

Using the “Display..." button, you can show 
the current configuration of the PC station. 

Click on the “Configure…” button. 
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Step Activity Screenshot 

3.  In the window that appears, you can see 
how the PC station is configured. 

Click on the "OK" button to confirm this 
setting. 

 

4.  Click on the "OK" button to confirm the 
information dialog. 

 

5.  In the bottom window, you then see the 
message: "Transfer completed 
successfully." 

Close the configuration dialog. 

 

6.  Configure the Station Configuration Editor 
of the OS server as shown in steps 1 to 5. 
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Configuring and loading AS-OS communication 

In the following section, the connections between the PC stations and the AS are 
configured in NetPro and loaded in the individual stations. 

 

Note In the case of a granular station configuration, you must merge the subnets of 
the individual sub-projects first. 

 

Step Activity Screenshot 

1.  Open NetPro. 

Highlight the WinCC application of the ES 
and open the shortcut menu. Choose 
"Insert New Connection". 

 

2.  In the "Connection Partner" window, 
select the CPU of the AS. 

Make sure that an “S7 connection" is 
selected under “Connection”. 

Click on the "OK" button to confirm your 
selection. 
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Step Activity Screenshot 

3.  On the “General" tab under "Connection 
identification”, change the “Local ID:" to a 
descriptive name like AS1, for example. 

Click on the "OK" button to confirm your 
entries. 

 

4.  Repeat steps 1 to 3 to connect the OS 
server to the AS. 

When doing this, it is important that the 
connections of the ES and the OS server 
to the AS have the same name. 

 

 

5.  

Optionally 

In the connection table of the AS, change 
the local ID for the connection to the ES to 
a value of greater than 0xc00. 

Note 
A connection ID of greater than 0xc00 
prevents the AS from generating 
messages in later operation due to starting 
or stopping of OS simulation on the ES. 

 

6.  Use the ""Network > Save and 

Compile..." menu item to save the 

configuration and compile it. 

Select the "Compile and check everything" 
option button and click on the "OK" button 
to confirm your selection. 
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Step Activity Screenshot 

7.  Select the ES and download the 
connections via the shortcut menu: 
"Download to current project > 

Selected Stations". 

Download the OS server and the AS in the 
same way. 

Then, close NetPro. 

 

 

Compiling and loading the user program 

Compile the S7 program and download it to the AS. 

 

Compiling the OS server project 

Compile the OS server project in SIMATIC Manager with selected "Generate 
server data" checkbox. 

Make sure that you make the correct OS assignment to the server in plant view. 
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Assigning the server package 

Step Activity Screenshot 

1.  Highlight the OS application of the OS 
client and choose "Assign OS server..." in 
the shortcut menu. 

 

2.  Select the corresponding OS project and 
click on the "OK" button to confirm your 
selection. 

 

3.  Click on the "OK" button to confirm that the 
package was loaded successfully. 
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4.3.3 OS configuration 

Activating time synchronization 

On the ES, the necessary settings are activated in the OS projects of the OS 
server and the OS client. 

 

Step Activity Screenshot 

1.  Open the OS server project. 

 

2.  Open the "Time Synchronization" editor 
from the shortcut menu. 

 

Select the "Synchronization via System 
Bus (Master, Slave)" checkbox. 

Under "Access point 1”, choose 
“CP1623(ISO)” and select the "Master” 
radio button. 

Click on the "OK" button to confirm your 
selection. 

 

NOTE 

If you configure station time 
synchronization on a different computer, 
the access points are not known, which 
means that they are not available in the 
drop-down list. To choose the access point 
regardless, select the "Display symbolic 
name of the access point" checkbox and 
then choose the appropriate access point. 

 

3.  Close the OS server project.  
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Step Activity Screenshot 

4.  Open the OS client project. 

 

5.  Open the "Time Synchronization" editor 

from the shortcut menu. 

Select the "Synchronization via Terminal 
Bus (Slave)" checkbox and choose "Use 
the time from a connected WinCC server". 

Click on the "OK" button to confirm your 
selection. 
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Step Activity Screenshot 

6.  Select the "Server Data" editor 

in the WinCC Explorer, and then 

select the "Standard Server..." 

command from the shortcut menu. 

 

Select the standard server for 

the components "Alarms" and 

"SSM" (Split Screen Manager) 

 

Click on the "OK" button to confirm your 
selection. 

 

7.  Close the OS client project.  

 

Downloading the OS project to the OS server 

After time synchronization is configured on the ES side, download the OS project to 
the OS server. 

 

Step Activity Screenshot 

1.  In SIMATIC Manager, highlight the OS 
project of the OS server and select the 
"PLC > Download" context menu. 
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Step Activity Screenshot 

2.  For the first OS project download, an entire 
download is required. 

Click on the "OK" button to start 
downloading. 

 

3.  After successful downloading, the OS 
project is located in the specified folder on 
the OS server. 

Click on the "OK" button to confirm the 
message that is issued. 
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OS configuration on the OS server 

After the first download, check the step instructions below for time synchronization 
and correct them if necessary. 

Note Normally, all configuration work is carried out on the ES to ensure consistent 
data management. This means that no WinCC engineering licenses are needed 
on the OSes. However, each time WinCC Explorer is opened, a license-free time 
window of two hours is available for WinCC configuration work. 

 

Step Activity Screenshot 

1.  Open the OS project on the OS server.  

2.  Open the "Time Synchronization"  
editor from the shortcut menu. 

 

Check or select the "Synchronization via 
System Bus (Master, Slave)" checkbox. 

Check or select "CP1623(ISO)" and the 
"Master" option button under "Access  
point 1". 

 

Click on the “OK” button to confirm your 
settings. 
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4.3.4 Activating runtime 

Open the OS project on the OS server and activate runtime. 

Then, switch to the ES computer and open the OS client project. Activate runtime there too. 

 

4.3.5 Particularities when loading OS project changes 

Loading changes 

Before you can carry out OS compiling and downloading to the ES, OS client runtime 
must be deactivated and the OS project closed. 

 

Complete download 

Before you can carry out OS compiling and downloading from the ES, OS client runtime 
and the OS server must be deactivated and the respective OS projects must be closed. 
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5 ES, OS Master and OS Standby 

5.1 Configuration description 

During process mode, the pair of Single Stations runs completely in-parallel and 
independently from each other. If one of the Single Stations fails, an equivalent, 
redundant OS Single Station is always available. The Single Stations monitor each 
other during runtime and synchronize the project archives as needed. 

For synchronization, the OS Single Stations are connected via a redundant cable. You 
can use a network cable on an additional network adapter or a null modem cable on the 
COM port as the redundant cable. In the configuration below, a COM cable is used. 

Configuration is carried out via the ES. 

Hardware configuration 

OS Master

COM-Cable

Terminal bus

Plant bus

ES

AS

OS Standby

Redundancy

 

Note You need server packages for the function of the MS clients. If the OS/MS server 
is set up as a Single Station, the MS client cannot be used on the ES. 
The jump keys in the asset faceplate for hardware configuration and for PDM 
function as follows: 
 - Up to PDM V8.1: On ES only 
 - PDM V8.2 and higher: On ES and OS clients 
 - PDM V9.0 and higher: On ES and OS clients, and web clients 
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PCS 7 configuration 
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5.2 Required hardware and software licensing 

Hardware 

For this configuration, we recommend using the hardware below which you can 
order via the Siemens mall. This means that the appropriate number of selected 
operating systems and SIMATIC PCS 7 system software packages are pre-installed 
on the PC stations. 

 

Station Product designation Operating 
system 

Plant bus 
transition 

1 x ES SIMATIC PCS 7 ES/OS IPC847E BCE Windows 10 RJ45 
Network card 

SIMATIC PCS 7 ES/OS IPC847E IE Windows 10 CP 1623 

2 x OS Single Station  SIMATIC PCS 7 ES/OS IPC847E BCE Windows 10 RJ45 
Network card 

SIMATIC PCS 7 ES/OS IPC847E IE Windows 10 CP 1623 

 

Software licensing 

The following section lists the software/license packages that you need for the 
selected configuration. 

 

Component Software/license packages 

ES • SIMATIC PCS 7 AS/OS Engineering Software  
(PO unlimited) 

• SIMATIC PCS 7 AS Runtime License 
 

OS Single Station Redundant • SIMATIC PCS 7 OS Software Single Station 
Redundancy (Single License for 2 installations) 

• 2 x SIMATIC PCS 7 OS Runtime License 
(max. of 8,500 POs) 
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5.3 Step-by-step configuration 

Note The following instructions have been drawn up based on Windows 7 and  
PCS 7 V9.0. 

CP1623 are used as an example of the plant bus transition. Time 
synchronization is activated. 

The PC stations used in the test setup are called: 

• ES:                            ESV81 

• OS server:                SVA 

• OS server standby:  SVB 

5.3.1 Preparatory activities 

Create a project folder on the OS master and the OS standby and share it. This 
makes it possible to transfer the OS data that is configured on the engineering 
station to the OS master and the OS standby. 

 

5.3.2 ES configuration 

Creating the multiproject 

As the basis for the instructions below, all of the PC stations must be physically 
networked as shown in the illustration in chapter 5.1. Apart from this, you must 
create a multiproject on the ES in which the hardware and software of the AS are 
already configured. 

Then, you start with the following CPU and CP settings. 

 

AS settings 

The analyzability of the process data requires that all of the components of the 
process control system work with an identical clock time to be able to assign 
messages in the correct time sequence. 

The following section describes a way in which the redundant OS Single Stations 
specify the master time. 

 

Note More time synchronization options are described in detail in the following 
manuals: 

• "SIMATIC PCS 7 Operator Station" 
https://support.industry.siemens.com/cs/ww/en/view/109805404 

• "SIMATIC Process Control System PCS 7 Time Synchronization" 
https://support.industry.siemens.com/cs/ww/en/view/109805436 

 

https://support.industry.siemens.com/cs/ww/en/view/109805404
https://support.industry.siemens.com/cs/ww/en/view/109805436
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Step Activity Screenshot 

1.  Open the HW Config for the AS. 

Highlight the CPU and choose "Object 
properties..." in the shortcut menu. 

 

2.  Switch to the "Diagnostics/Clock" tab. 

In the "Clock" section, set "Synchronization 
Type - As slave” for the AS. 

Click on the "OK" button to confirm your 
selection. 
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Step Activity Screenshot 

3.  Open the shortcut menu of the CP and 
select "Object properties…". 

 

4.  Switch to the "Time synchronization" tab. 

Select the "Accept time of day on CP and 
forward" check box. 

Click on the "OK" button to confirm the 
setting. 

 

5.  Save the configuration and compile it 
using: 
"Station > Save and Compile…". 

Close the HW Config. 
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Setting up the ES PC station 

A PC station is created for the ES using the WinCC application to allow testing of 
the OS project on the ES. 

 

Step Activity Screenshot 

1.  In component view, open the shortcut 
menu of the project and use "Insert 
New Object > SIMATIC PC 

station" to add a new PC station. 

 

 

2.  Use the shortcut menu to open the object 
properties of the PC station. 

 

3.  Change the name of the ES PC station to 
match the name of the local computer on 
the network. 

Select the “Computer name identical to PC 
station name” checkbox. 
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Step Activity Screenshot 

4.  Open the HW Config of the ES PC station 
via the shortcut menu. 

 

5.  Insert a "WinCC application” and a network 
card of type "CP1623”  
from the object catalog (View > Catalog). 

 

6.  Under “Subnet”, choose the plant bus or 
create it by clicking on the “New…" button. 

Assign the corresponding MAC address to 
the CP1623. 

Deselect the "IP protocol is being used” 
checkbox. 

Click on the “OK” button to confirm your 
settings. 
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Step Activity Screenshot 

7.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

8.  Switch to the “Options" tab and select the 
"Time of day” checkbox. 

Click on the "OK" button to confirm your 
selection. 

 

9.  Save and compile using menu command: 
"Station > Save and Compile…". 

Close the HW Config. 

 

10.  

Optionally 

Delete the OS of the Engineering Station in 
SIMATIC Manager as it is not needed in 
our example. 
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Setting up the Master OS PC station 

Step Activity Screenshot 

1.  In component view, open the shortcut 
menu of the project and use "Insert 
New Object > SIMATIC PC 

station" to add a new PC station. 

 

2.  Use the shortcut menu to open the object 
properties of the PC station. 

 

3.  Change the name of the OS master PC 
station to match the name of the computer 
on the network. 

Select the “Computer name identical to PC 
station name” checkbox. 
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Step Activity Screenshot 

4.  Open the HW Config of the OS master PC 
station via the shortcut menu. 

 

5.  Insert a "WinCC application” and a network 
card of type "CP1623” from the object 
catalog (View > Catalog). 

 

6.  Under “Subnet”, choose the plant bus or 
create it by clicking on the “New…" button. 

Assign the corresponding MAC address to 
the CP1623. 

Deselect the "IP protocol is being used” 
checkbox. 

Click on the “OK” button to confirm your 
settings. 
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Step Activity Screenshot 

7.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

8.  Switch to the “Options" tab and select the 
"Time of day” checkbox. 

Click on the "OK" button to confirm your 
selection. 

 

9.  Save and compile using menu command: 
"Station > Save and Compile…". 

Close the HW Config. 
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Setting up the OS standby PC station 

Step Activity Screenshot 

1.  In component view, open the shortcut 
menu of the project and use "Insert 
New Object > SIMATIC PC 

station" to add a new PC station. 

 

2.  Use the shortcut menu to open the object 
properties of the PC station. 

 

3.  Change the name of the OS standby PC 
station to match the name of the computer 
on the network. 

Select the “Computer name identical to PC 
station name” checkbox. 
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Step Activity Screenshot 

4.  Open the HW Config of the OS standby 
PC station via the shortcut menu. 

 

5.  From the object catalog (View > Catalog), 
insert a "WinCC application (Stby)" and a 
network card of type "CP1623". 

 

6.  Under “Subnet”, choose the plant bus or 
create it by clicking on the “New…" button. 

Assign the corresponding MAC address to 
the CP1623. 

Deselect the "IP protocol is being used” 
checkbox. 

Click on the “OK” button to confirm your 
settings. 
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Step Activity Screenshot 

7.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

8.  Switch to the “Options" tab and select the 
"Time of day” checkbox. 

Click on the "OK" button to confirm the 
setting. 

 

9.  Save and compile using menu command: 
"Station > Save and Compile…". 

Close the HW Config. 
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Configuring all of the PC stations 

The "Configure PC station" function transfers project configurations to one or more 
target stations. First, configure the local ES and then all of the operator stations 
that are connected to the plant bus. 

 

Step Activity Screenshot 

1.  Configure the Station Configuration Editor 
of the ES. To do this, select the PC station 
of the ES and in the shortcut menu 
choose: 
"PLC > Configure…". 

 

2.  Under "Accessible computers:” choose the 
PC that you want to configure. 

 

NOTE 

If you chose the option "PC name identical 
to PC station name" for the PC station in 
the “Object properties”, the system 
displays directly in the component 
configurator the target PC to be 
configured. 

 

Using the “Display..." button, you can show 
the current configuration of the PC station. 

Click on the “Configure…” button. 
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Step Activity Screenshot 

3.  In the window that appears, you can see 
how the PC station is configured. 

Click on the "OK" button to confirm this 
setting. 

 

4.  Click on the "OK" button to confirm the 
information dialog. 

 

5.  In the bottom window, you then see the 
message: 
"Transfer completed successfully." 

Close the configuration dialog. 

 

6.  Configure the Station Configuration Editors 
of the OS master/standby as shown in 
steps 1 to 5. 
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Configuring and loading AS-OS communication 

In the following section, the connections between the PC stations and the AS are 
configured in NetPro and loaded in the individual stations. 

 

Note In the case of a granular station configuration, you must merge the subnets of 
the individual sub-projects first. 

 

Step Activity Screenshot 

1.  Open NetPro. 

Highlight the WinCC application of the ES 
and open the shortcut menu. Choose 
"Insert New Connection". 

 

2.  In the "Connection Partner" window, 
select the CPU of the AS. 

Make sure that an “S7 connection" is 
selected under “Connection”. 

In this example, a high-availability S7 
connection is configured due to the AS 
configuration. 

Click on the "OK" button to confirm your 
selection. 
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Step Activity Screenshot 

3.  On the “General" tab under "Connection 
identification”, change the  
“Local ID:" to a descriptive name like AS1, 
for example. 

Click on the “OK” button to confirm your 
settings. 

 

4.  
Optionally 

In the connection table of the AS, change 
the local ID for the connection to the ES to 
a value of greater than 0xc00. 

Note 
A connection ID of greater than 0xc00 
prevents the AS from generating 
messages in later operation due to starting 
or stopping of OS simulation on the ES. 

 

5.  Also set the connections of the OS master 
and OS standby to the AS by repeating 
steps 1 to 3. 

When doing this, it is important that the 
connections of the OS master, OS standby 
and of the ES to the AS have the same 
name. 

After this, use the  
""Network > Save and 

Compile..." menu item to save the 

configurations and compile them. 

 

Select the "Compile and check everything" 
option button and click on the "OK" button 
to confirm your selection. 
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Step Activity Screenshot 

6.  Highlight the ES and download the 
connection use the “PLC > Download 
to Current Project > Selected 

Stations" menu item to download the 

connection. 

Download the AS, the OS master, and OS 
standby in the same way. 

Then, close NetPro. 
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Master/Standby settings on the ES 

Here, you define the master/standby assignment and set the loading paths. 

 

Step Activity Screenshot 

1.  In SIMATIC Manager, open the properties 
dialog of the OS master PC station. 

Switch to the "Target OS and Standby OS 
Computer" tab. 

Select the Standby OS from the drop-down 
list. 

Select the "Create/update archive tags" 
checkbox. 

Clear the “Transfer to external archive 
server” checkbox if you are not using a 
Process Historian. 

Click on the "Browse" button. 

 

2.  Use the drop-down list to navigate to the 
shared project folder of the Master OS 
(see 5.3.1 Preparatory activities). 

Click on the "Save" button. 
 

3.  In the "Path to Target OS Computer” input 
field, check again the whole project path. 

Click on the “OK button” to confirm your 
entry. 

 

4.  Open the properties dialog of the Standby 
OS PC station. 

Switch to the  
"Target OS and Mater OS Computers" tab. 

Check whether OS_Master is entered in 
the "Master OS" field too. 

Click on the "Search..." button to select the 
storage path of the OS data. 

 

5.  Use the drop-down list to navigate to the 
shared project folder of the Standby OS 
(see 5.3.1 Preparatory activities). 

Click on the "Save" button. 
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Step Activity Screenshot 

6.  In the input field, check the "Path to the 
Target OS Computer". 

Click on the "OK" button to confirm this. 

Click on "Yes” to confirm the dialog that is 
displayed next. 

 

 

Compiling and loading the user program 

Compile the S7 program and download it to the AS. 

 

Compiling the OS project 

Compile the OS project of the Master OS in SIMATIC Manager. 

Make sure that you make the correct OS assignment to the server in plant view. 
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5.3.3 OS configuration 

Configuring the OS on the engineering station 

On the ES, you switch from a multi-user system to a single-user one and make the 
settings for redundancy and time synchronization. 

 

Step Activity Screenshot 

1.  On the ES, open the OS project of the 
Master OS. 

In the open WinCC Explorer, highlight the 
OS project and choose “Properties” in the 
shortcut menu. 
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Step Activity Screenshot 

2.  On the “General” tab under “Type:”, 
choose "Single-user project". 

Confirm your input and the displayed 
message by clicking on the "OK" button. 

 

Note: 

You need server packages for the function 
of the MS clients, i.e. the OS/MS server 
must not be a single-user project. If the 
OS/MS server is set up as a single-user 
project, the MS client cannot be used on 
the ES. 

 

 

3.  Click on the "No" button to prevent the 
startup list from being deleted. 
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Step Activity Screenshot 

4.  Open the "Redundancy" editor. 

 

Select the "Default Master" checkbox. 

Enter the Standby OS in the "Redundant 
partner server" field. 

Check whether you have selected the 
desired checkboxes under "Optional 
Settings". 

In the drop-down list, select the connection 
path that is used to connect the Master OS 
and the Standby OS. 

Click on the “OK” button to confirm your 
settings. 

 

5.  Open the "Time Synchronization" editor. 

 

Select the "Synchronization via System 
Bus (Master, Slave)" checkbox. 

Under "Access point 1”, choose 
"CP1623(ISO)" and select the "Master" 
radio button. 

Click on the “OK” button to confirm your 
settings. 

 

NOTE 

If you configure station time 
synchronization on a different computer, 
the access points are not known, which 
means that they are not available in the 
drop-down list. To choose the access point 
regardless, select the "Display symbolic 
name of the access point" checkbox and 
then choose the appropriate access point. 

 

6.  Close the OS project.  
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Downloading the OS project to the OS computer 

Once redundancy and time synchronization have been configured on the ES, 
download the OS project to the Master OS and the Standby OS. 

 

Step Activity Screenshot 

1.  In SIMATIC Manager, highlight the Master 
OS and choose “PLC -> Download" in 

the shortcut menu. 

 

2.  For the first OS project download, an entire 
download is required. 

Click on the "OK" button to start 
downloading. 
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Step Activity Screenshot 

3.  After successful downloading, the OS 
project is located in the specified folder on 
the Master OS. 

Click on the "OK" button to confirm the 
message that is issued. 

 

4.  Repeat steps 1 to 3 to download the OS 
project to the Standby OS. 
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Configuring on the operator station 

Generally, we would advise you to check the project settings after the project has 
been downloaded to the target systems. 

 

Note Normally, all configuration work is carried out on the ES to ensure consistent 
data management. This means that no WinCC engineering licenses are needed 
on the OSes. However, each time WinCC Explorer is opened, a license-free time 
window of two hours is available for WinCC configuration work. 

 

Step Activity Screenshot 

1.  Open the OS project on the OS project.  

2.  Open the "Redundancy" editor. 

Check the name of the Master OS in the 
"Server" field. 

Select the "Default Master" checkbox. 

Also, check whether the name of the 
Standby OS is entered correctly under 
"Redundant partner server:". 

Check whether you have selected the 
desired checkboxes under "Optional 
Settings". 

Check whether the connection path that is 
used to connect the Master OS and the 
Standby OS is set. 

 

Click on the “OK” button to confirm your 
settings. 
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Step Activity Screenshot 

3.  Open the "Time Synchronization" editor. 

 

Check or select the "Synchronization via 
System Bus (Master, Slave)" checkbox. 

Under "Access point 1”, check or select 
"CP1623(ISO)" and the "Master" radio 
button. 

 

Click on the “OK” button to confirm your 
settings. 

 

4.  If you have made project changes in 
WinCC Explorer, close the OS project and 
open it again for the settings to take effect. 

 

5.  Repeat steps 1 to 4 on the Standby OS 
with the following modifications for step 2 
(redundancy): 

• The "Default Master" checkbox must 
be cleared. 

• Check whether the name of the 
Master OS is entered correctly under 
"Redundant partner server:" and 
change it if necessary. 
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5.3.4 Activating runtime 

First activate the OS project on the Master OS and then on the Standby OS. Before 
activating the second runtime, it is advisable to wait until the boot process of the first 
one has completed. 

Online synchronization is active immediately. 
By contrast, mutual synchronization of archives starts 10 minutes later. 
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6 ES/OS Master and OS Standby 

6.1 Configuration description 

In this configuration with two redundant OS Single Stations, one of the stations is 
used at the same time as an ES, which obviates the need for a separate third 
station. 

In this connection, you must pay attention to the following two criteria. This is why 
we generally recommend creating a configuration with a separate ES  
(see chapter 5 "ES, OS Master and OS Standby"): 

Comparatively low savings potential 

The savings potential has been reduced since PCS 7 V8.0 because the OS 
runtime license is no longer included with the ES license. This means that, savings 
are limited to one computer (hardware and Windows license). 

Special considerations when configuring 

The configuration differs from that of the PCS 7 Engineering Standard and 
represents a kind of workaround. 

You cannot use the "WinCC Application" and "WinCC Standby Application” PCS 7 
standard tools, since it is not possible to download changes during operation. The 
mechanisms controlling the fact that both systems must be in runtime and that 
runtime on the ES must be stopped for the download to proceed block one 
another. 

For this reason, we configure only one OS application, open it on both stations, 
and configure mutual redundancy locally in WinCC in each case. To be able to 
download to the OS Single Station, runtime on the ES and the OS must be closed 
first. 

 

CAUTION This configuration has been tested with a PCS 7 basic installation including the 
Web Option. No statement can be made regarding the functionality with 
additional optional packages. 

 

Note The jump keys in the asset faceplates for hardware configuration and for PDM 
function as follows: 

– Up to PDM V8.1: On ES only 

– PDM V8.2 and higher: On ES and Standby OS 

– PDM V9.0 and higher: On ES and OS clients, and web clients 

 



6 ES/OS Master and OS Standby 

 

Minimal Configuration 
Entry-ID: 24023824,    V8.0,    02/2022   84 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
2

2
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

Hardware configuration 

ES/OS Master OS Standby

COM-Cable

Terminal bus

Plant bus

AS

Redundancy

 

 

PCS 7 configuration 
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Limitations/Particularities 

Due to the untypical configuration of PCS 7 with only one OS, there are differences 
in system behavior that must be observed: 

• The first activated OS takes on the master role. 

• For an entire download to be performed, runtime must be deactivated and the 
OS project closed on both computers. During this time, operator actions and 
archiving are not possible. 

• To download changes, runtime must be stopped on the ES when compiling the 
OS. These can then be re-activated to test the modified OS functions. For the 
downloading process, runtime must be terminated and the OS Project must be 
closed. As a result, it is not possible to take operator actions on the ES 
computer during this time. 

 

CAUTION Depending on the changes that are carried out, if runtime remains active during 
OS compilation, subsequent downloading of changes may not be performed 
completely and will cause errors. If this happens, only an entire download is 
possible. 

 

• When runtime is active on the ES computer, the runtime archives are stored in 
the multiproject path. At archiving, they are included in the ZIP file, which causes 
an increased demand on memory resources as well as longer archiving times 
Workaround: 

– Deactivate runtime on the ES computer 

– Reset the archives in the OS project on the ES computer and close the 
entire PCS 7 project 

After archiving and re-activating runtime, the archives are synchronized again. 
However, it must be noted that more time is needed for synchronization. 
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6.2 Required hardware and software licensing 

Hardware 

For this configuration, we recommend using the hardware below which you can order via 
the Siemens mall. This ensures that the appropriate number of selected operating systems 
and SIMATIC PCS 7 system software packages are pre-installed on the PC stations. 

 

Station Product designation Operating 
system 

Plant bus transition 

1 x ES/OS SIMATIC PCS 7 ES/OS IPC847E BCE Windows 10 RJ45 
Network card 

SIMATIC PCS 7 ES/OS IPC847E IE Windows 10 CP 1623 

1 x OS Single 
Station  

SIMATIC PCS 7 ES/OS IPC847E BCE Windows 10 RJ45 
Network card 

SIMATIC PCS 7 ES/OS IPC847E IE Windows 10 CP 1623 

 

Software licensing 

The following section lists the software/license packages that you need for the 
selected configuration. 

 

Component Software/license packages 

ES • SIMATIC PCS 7 AS/OS Engineering Software  
(Unlimited POs) 

• SIMATIC PCS 7 AS Runtime License 
 

OS Single Station Redundant • SIMATIC PCS 7 OS Software Single Station Redundancy 
(Single License for 2 installations) 

• 2 x SIMATIC PCS 7 OS Runtime License 
(max. of 2,000 POs) 
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6.3 Step-by-step configuration 

Note The following instructions have been drawn up based on Windows 7 and PCS 7 
V9.0. 

CP1623 are used as an example of the plant bus transition. Time 
synchronization is activated additionally. 

The PC stations used in the test setup are called: 

• ES/OS Master: ESV81 

• OS Standby:  SV 

6.3.1 Preparatory activities 

Create a project folder on the Standby OS PC station and share it. This makes it 
possible to transfer the OS data that is configured on the engineering station to the 
OS master and the OS standby. 

 

6.3.2 ES configuration 

Creating the multiproject 

As the basis for the instructions below, all of the PC stations must be physically networked 
as shown in the illustration in chapter 6.1. Apart from this, you must create a multiproject 
on the ES in which the hardware and software of the AS are already configured. 

Start with the following CPU and CP settings. 

 

AS settings for time synchronization 

The analyzability of the process data requires that all of the components of the 
process control system work with an identical clock time to be able to assign 
messages in the correct time sequence 

The following section describes a way in which the OS Single Station that is 
activated first specifies the master time. 

 

Note More time synchronization options are described in detail in the following 
manuals: 

• "SIMATIC PCS 7 Operator Station" 
https://support.industry.siemens.com/cs/ww/en/view/109805404 

• "SIMATIC Process Control System PCS 7 Time Synchronization" 
https://support.industry.siemens.com/cs/ww/en/view/109805436 

https://support.industry.siemens.com/cs/ww/en/view/109805404
https://support.industry.siemens.com/cs/ww/en/view/109805436
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Step Activity Screenshot 

1.  Open the HW Config for the AS. 

Highlight the CPU and choose "Object 
properties..." in the  
shortcut menu. 

 

2.  Switch to the "Diagnostics/Clock" tab. 

In the "Clock" section, set "Synchronization 
Type - As slave” for the AS. 

Click on the "OK" button to confirm this 
setting. 
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Step Activity Screenshot 

3.  Open the shortcut menu of the CP and 
select "Object properties…". 

 

4.  Switch to the "Time synchronization" tab. 

Select the "Accept time of day on CP and 
forward" check box. 

Click on the "OK" button to confirm your 
selection. 

 

5.  Use the "Station > Save and compile...” 
command to save the configuration. 

Close the HW Config. 
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Setting up the ES PC station 

To run the OS project on the ES, a PC station is created for the ES using the 
WinCC application. 

 

Step Activity Screenshot 

1.  In component view, open the shortcut 
menu of the project and use "Insert 
New Object > SIMATIC PC 

station" to add a new PC station. 

 

 

2.  Use the shortcut menu to open the object 
properties of the PC station. 

 

3.  Change the name of the ES PC station to 
match the name of the local computer on 
the network. 

Select the “Computer name identical to PC 
station name” checkbox. 
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Step Activity Screenshot 

4.  Open the HW Config of the ES PC station 
via the shortcut menu. 

 

5.  Insert a "WinCC application”  
(and a network card) of type 

“CP1623” from the object catalog (View > 
Catalog). 

 

6.  Under “Subnet”, choose the plant bus or 
create it by clicking on the “New…" button. 

Assign the corresponding MAC address to 
the CP1623. 

Deselect the "IP protocol is being used” 
checkbox. 

Click on the “OK” button to confirm your 
settings. 
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Step Activity Screenshot 

7.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

8.  Switch to the “Options" tab and select the 
"Time of day” checkbox. 

Click on the "OK" button to confirm your 
selection. 

 

9.  Use the "Station > Save and 

compile..." menu item to save the 

configuration and compile it. 

Close the HW Config. 

 

10.  

Optionally 

Delete the OS of the PC station of the ES 
in SIMATIC Manager as it is not needed in 
our example. 
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Setting up the OS standby PC station 

Step Activity Screenshot 

1.  In component view, open the shortcut 
menu of the project and use "Insert 
New Object > SIMATIC PC 

station" to add a new PC station. 

 

2.  Use the shortcut menu to open the object 
properties of the PC station. 

  

3.  Change the name of the OS server PC 
station to match the name of the computer 
on the network. 

Select the “Computer name identical to PC 
station name” checkbox. 
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Step Activity Screenshot 

4.  Open the HW Config of the OS standby 
PC station via the shortcut menu. 

 

5.  From the object catalog (View > 

Catalog) insert a "WinCC application (not 

a WinCC Application Stby!)" and a network 
card of type "CP1623". 

 

6.  Under “Subnet”, choose the plant bus or 
create it by clicking on the “New…" button. 

Assign the corresponding MAC address to 
the CP1623. 

Deselect the “IP protocol is being used”  
checkbox. 

Click on the “OK” button to confirm your 
settings. 
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Step Activity Screenshot 

7.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

8.  Switch to the “Options" tab and select the 
"Time of day” checkbox. 

Click on the "OK" button to confirm the 
setting. 

 

9.  Save and compile using the "Station > 

Save and compile…" command. 

Close the HW Config. 

 

10.  In SIMATIC Manager, open the properties 
dialog of the Standby OS. 

Switch to the "Target OS and Standby OS 
Computer" tab. 

Select the "Create/update archive tags" 
checkbox and clear the “Transfer to 
external archive server” checkbox. 

Click on the "Search..." button. 
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Step Activity Screenshot 

11.  Use the drop-down list to navigate to the 
shared project folder of the Standby OS 
(see 6.3.1 Preparatory activities). 

Click on the "Save" button. 

 

12.  In the "Path to Target OS Computer” input 
field, check again the whole project path. 

Click on the "OK" button to confirm this. 

 

13.  Click on the “Yes” button to confirm the 
information dialog. 
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Configuring the PC stations 

The "Configure PC station" transfers project configurations to one or more 

target stations. First configure the local Station Configuration Editor of the ES and 
then all the other PC stations connected to the plant bus. 

Step Activity Screenshot 

1.  Execute the Station Configuration Editor of 
the ES. To do this, select the PC station of 
the ES and in the shortcut menu choose: 
"PLC > Configure…". 

 

2.  Under "Accessible computers:” choose the 
PC that you want to configure. 

 

Note 

If you chose the "PC name identical to PC 
station name" option for the PC station in 
the “Object properties”, the system displays 
directly in the component configurator the 
target PC to be configured. 

 

Using the "Display..." button, you can 
display the current configuration of the PC 
station. 

Click on the “Configure…” button. 
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Step Activity Screenshot 

3.  In the window that appears, you can see 
how the PC station is configured. 

Click on the "OK" button to confirm this 
setting. 

 

4.  Click on “OK” to confirm the information 
dialog. 

 

5.  In the bottom window, you then see the 
message: 
"Transfer completed successfully". 

Close the configuration dialog. 

 

6.  Configure the Station Configuration Editor 
of the Standby OS as shown in steps 1 to 5. 
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Configuring and loading AS-OS communication 

In the following section, the connections between the PC stations and the AS are 
configured in NetPro and loaded in the individual stations. 
 

Note In the case of a granular station configuration, you must merge the subnets of 
the individual sub-projects first. 

 

Step Activity Screenshot 

1.  Open NetPro. 

Highlight the WinCC application of the ES 
and open the shortcut menu. 

Select "Insert New Connection". 

 

2.  In the "Connection Partner" window, 
select the CPU of the AS. 

Make sure that an “S7 connection" is 
selected under “Connection”. 
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Step Activity Screenshot 

3.  On the “General" tab under "Connection 
identification”, change  
 the “Local ID:" to a descriptive name like 
AS1, for example. 

Click on the “OK” button to confirm your 
settings. 

 

4.  Also create a connection between the 
Standby OS and the AS by repeating steps 
1 to 3. 

When doing this, it is important that the 
connection has the same name as the 
connection of the ES to the AS. 

After this, use the ""Network > Save 

and Compile..." menu item to save the 

configuration and compile it. 

 

Select the "Compile and check everything" 
option button and click on the "OK" button 
to confirm your selection. 

 

5.  Select the ES and download the 
connections via the shortcut menu: 
"Download to current project > 

Selected Stations". 

Download the Standby OS and the AS in 
the same way. 

Then, close NetPro. 

 

 

Compiling and loading the user program 

Compile the S7 program and download it to the AS. 

 

Compiling the OS project 

Compile the OS project of the Standby OS in SIMATIC Manager. 

Make sure that you make the correct OS assignment to the server in plant view. 
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6.3.3 OS configuration 

Configuring the OS on the engineering station 

On the ES, you must still switch from a multi-user system to a single-user one and 
make the settings for redundancy and time synchronization. 

 

Note In this particular configuration, it is necessary to complete the redundancy 
settings in WinCC Explorer of the Standby OS after the entire download 
completes. 

 

Step Activity Screenshot 

1.  Open the OS project of the Standby OS in 
the ES. 

In the open WinCC Explorer, highlight the 
OS project and choose “Properties” in the 
shortcut menu. 
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Step Activity Screenshot 

2.  On the "General" tab under “Type:”, 
choose "Single-User Project" from the 
drop-down list. 

 

Confirm your settings and the displayed 
message by clicking on the "OK" button. 

 

3.  Activate OS project option "Allow activation 
on ES" from the "Options" tab. This 
setting allows runtime to be activated in the 
ES. 

Then click on the "OK" button. 
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Step Activity Screenshot 

4.  Click on the "No" button to prevent the 
startup list from being deleted. 

Confirm the displayed message by clicking 
on "OK". 

 

5.  Open the "Redundancy" editor. 

 

Select the "Activate Redundancy" 
checkbox. 

Select the "Default Master" checkbox. 

If necessary, adapt the redundancy 
properties in "Optional Settings" to meet 
your requirements. 

In the drop-down list, select the connection 
path that is used to connect the Master OS 
and the Standby OS. 

 

 

6.  To complete the redundancy settings for 
the ES, the partner server must be still 
selected. 

To do this, click on the "Search ..." button 
and select the Standby OS as a redundant 
partner from the network. 

Click on the “OK” button to confirm your 
settings. 
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Step Activity Screenshot 

7.  Double check all of the options before 
clicking on the "OK" button to confirm the 
redundancy settings. 

 

8.  Click on the “OK” button to acknowledge 
the message. 

 

9.  Open the "Time Synchronization" editor. 

Here, select the "Synchronization via 
System Bus (Master, Slave)" checkbox. 

Under "Access point 1”, choose 
"CP1623(ISO)" and select the "Master" 
radio button. 

Click on the “OK” button to confirm your 
settings. 

 

NOTE 

If you configure station time 
synchronization on a different computer, 
the access points are not known, which 
means that they are not available in the 
drop-down list. To choose the access point 
regardless, select the "Display symbolic 
name of the access point" checkbox and 
then choose the appropriate access point. 

 

10.  Close the OS project.  
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Downloading the OS project to the Standby OS 

Once redundancy and time synchronization have been configured on the ES and 
you have closed the OS project again, download the OS project to the Standby OS. 

 

Step Activity Screenshot 

1.  In SIMATIC Manager, highlight the 
Standby OS and choose “PLC -> 

Download" in the shortcut menu. 

 

2.  For the first OS project download, an entire 
download is required. 

Click on the "OK" button to start 
downloading. 
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Step Activity Screenshot 

3.  After successful downloading, the OS 
project is located in the specified folder on 
the Standby OS. 

Click on the "OK" button to confirm the 
message that is issued. 
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OS configuration on the Standby OS 

In this particular configuration, it is necessary to make the redundancy settings after 
the download completes. 

Generally, we would advise you to check the project settings after the project has been 
downloaded to the target systems. 

 

Note Normally, all configuration work is carried out on the ES to ensure consistent 
data management. This means that no WinCC engineering licenses are needed 
on the OSes. However, each time WinCC Explorer is opened, a license-free time 
window of two hours is available for WinCC configuration work. 

 

Step Activity Screenshot 

1.  Open the OS project on the Standby OS 
under the shared project folder. 

 

2.  Open the "Redundancy" editor from the 
shortcut menu. 

 

Click on the “Search…" button to select the 
ES computer as the redundant partner. 

 

3.  Clear the “Default Master” checkbox here. 

Check whether you have selected the 
desired checkboxes under "Optional 
Settings". 

In the drop-down list, select the connection 
path that is used to connect the Master OS 
and the Standby OS. 

 

Click on the “OK” button to confirm your 
settings. 
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Step Activity Screenshot 

4.  Click on the “OK” button to acknowledge 
the message. 

 

5.  Open the "Time Synchronization" editor 
from the shortcut menu. 

 

Check or select the "Synchronization via 
System Bus (Master, Slave)" checkbox. 

Under "Access point 1”, check or select 
"CP1623(ISO)" and the "Master" radio 
button. 

 

Always click on the "OK" button to confirm 
your settings. 

 

6.  If you have made project changes in 
WinCC Explorer, close the OS project and 
open it again for the settings to take effect. 

 

 

6.3.4 Activating runtime 

First activate the OS project on the ES and then on the Standby OS. Before 
activating the second runtime, it is advisable to wait until the boot process of the 
first one has completed. 

Online synchronization is active immediately. 
Mutual synchronization of archives starts after ten minutes. 

 

6.3.5 Particularities when loading OS project changes 

Loading changes 

To download changes, runtime must be stopped on the ES when compiling the OS. 
These can then be re-activated to test the modified OS functions. 
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CAUTION Depending on the changes that are made, if runtime remains active during OS 
compilation, the system may not download changes completely, which will cause 
errors. If this happens, only an entire download is possible. 

 

For the downloading process, runtime must be terminated and the OS Project must 
be closed. As a result, it is not possible to take operator actions on the ES 
computer during this time. 

 

Complete download 

For a complete download, the following must be always observed: 

1. Runtime must be deactivated on both PC stations and the OS project must be 
closed. 

2. Before re-enabling runtime on the Standby OS, you must make the 
redundancy settings again. 
To do this, repeat the steps in the table on page 107. 
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7 Expansion with the PCS 7 OS Web Option 
 

Positioning 

To control automated processes via the Internet/Intranet, SIMATIC PCS 7 provides 
operating and monitoring options: what are known as the "Web Options". 

This chapter describes configuration of the Web Option on an ES/OS Single 
Station. The instructions can also be used to expand the following minimal 
configurations: 

• ES/OS Single Station (Chapter 3) 

• ES/OS Master and OS Standby (Chapter 6) 

 

Note To expand the redundant Single Station configuration with the Web Option, the 
ES/OS station in the following example has been configured as a Web Server. 
The partner OS could also be used in the same way as a Web Server. The 
functionality for the Web clients is unchanged. 

Redundancy of the operator stations is not available for Web clients. If the OS 
with the Web Server option is in the STOP status, the Web clients do not have a 
connection to the process either. 

 

Function 

All of the relevant pictures and scripts are stored on the Web Server to make it 
possible to display or run them via a Web client. 

The Web client accesses the system data provided by the Web Server via a 
TCP/IP connection. The user interface matches the appearance of a standard OS 
client with an overview, work, and key areas. 

Amongst others, the functions below are available via Web: 

• Operator control and monitoring functions, which are also used on an OS client 

• Message lists that are called on a user-dependent basis, just like on an OS 
client. Messages can be acknowledged on a user-dependent basis. 

• Displaying the picture hierarchy according to the plant hierarchy 

• Group display function including the "loop-in-alarm" function 

• Enhanced status display 

 

 

Note For further information about the PCS 7 Web Options, see the following manual: 
"SIMATIC PCS 7 Web Option for OS " 
https://support.industry.siemens.com/cs/ww/en/view/109805408 

https://support.industry.siemens.com/cs/ww/en/view/109805408
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7.1 Web configurations 

In our example, configuration of the Web Option is an extension to the hardware 
and software configurations in chapter 3, "ES/OS Single Station" and chapter 6 
"Master ES/OS and Standby OS". 

 

ES/OS Single Station with OS Web Server option 

To operate and monitor the system process, the OS Web clients use Internet 
Explorer to get their project data from the Single Station with the OS Web Server 
option via the Internet/Intranet. 

ES/OS + OS Web Server

Plant bus

Intranet/Internet

Web Clients

AS
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Master ES/OS with OS Web Server option 

To operate and monitor the system process, the OS Web clients use Internet 
Explorer to get their project data from the Single Station with the OS Web Server 
option via the Internet/Intranet. 

In addition, the system process is set up on a redundant basis to offer the greatest 
possible protection from failure of system operation. 

 

CAUTION Redundancy of the operator stations is not available for Web clients. 
If the OS with the Web Server option is in the STOP status, the Web clients do 
not have a connection to the process. 

 

ES/OS + OS Web Server

Plant bus

Intranet/Internet

Web Clients

OS Single

Station

COM-Cable

AS

Redundancy
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7.2 Web-specific hardware and software requirements 

Single Station with Web Server option 

Property Requirement 

Operating system • Windows 10 Enterprise 2019 LTSC 

• Windows Server 2019 

 

You can find further information in the document entitled 
"SIMATIC PCS 7 process control system PCS 7 Readme" 
https://support.industry.siemens.com/cs/ww/en/view/109801032 

Hardware • SIMATIC PCS 7 ES/OS IPC847E BCE 

• SIMATIC PCS 7 ES/OS IPC847E IE 

 

You can find information on this topic in the document entitled 
"SIMATIC PCS 7 process control system PCS 7 Readme" 
https://support.industry.siemens.com/cs/ww/en/view/109801032 

Software • Internet Explorer 

• Internet Information Services (IIS) 

Miscellaneous Fast access (>= 64 kbps) to the Web Client via Internet/Intranet or a 
TCP/IP connection 

Web Client 

Property Requirement 

Operating systems • Windows 10 Enterprise 2019 LTSC 

• Windows Server 2019 

 

You can find further information in the document entitled 
"SIMATIC PCS 7 process control system PCS 7 Readme" 

https://support.industry.siemens.com/cs/ww/en/view/109801032 

Minimum hardware 
requirements 

No PDAs, tablet PCs etc. 

Software Internet Explorer 

Miscellaneous Fast access (>= 64 kbit/s) to the Web client via Internet/Intranet or 
a TCP/IP connection 

 

Note Choose the version of Internet Explorer to match the PCS 7 version. You can 
find more information by visiting the “Compatibility Tool for Automation and Drive 
Technology” at: 
http://www.siemens.de/kompatool 

  

https://support.industry.siemens.com/cs/ww/en/view/109801032
https://support.industry.siemens.com/cs/ww/en/view/109801032
https://support.industry.siemens.com/cs/ww/en/view/109801032
http://www.siemens.de/kompatool
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Software licensing 

The following section lists the various additional software/license packages that 
you need for the selected configuration. 

 

Component Software/license packages 

Single Station with Web Server option • SIMATIC PCS 7 Web Server Basic 

• SIMATIC PCS 7 Web Server license (cumulative) 
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7.3 Maximum number of Web client connections 

In one OS Single Station, it is possible to operate a maximum of three Web clients 
per Web server at the same time. 

7.4 Configuring the OS Web Server 

Configuration steps on the ES 

• Publish pictures using Web View Publisher 

• Configure user rights, start screen, and the language of the website in the User 
Administrator 

• Download and compile the Web server 

 

Publishing OS data 

The Web Publisher makes it possible to publish pictures and scripts on the OS 
Web Server, which are intended to run later on the Web clients. In this connection, 
the following actions are carried out: 

• Project data is compressed and saved 

• Picture windows are converted to Internet-enabled ActiveX components 

• Scripts are converted so that they run on the Web 

 

Requirements 

To publish the Web Server data, the following requirements must be met: 

• The hardware and software requirements mentioned in chapter 7.2 have been met. 

• The "PCS 7 Web Server" software package have been 

installed on the ES/OS Single Station. 

• The PCS 7 Project is available and fully configured. 

• "OS compiling" has been carried out. 

• The scripts that are accessed by the Web clients are present. 

• Process pictures do not contain double underscores (e.g. yy__xx.pdl). 

• Tag names in plain text (quotation marks) within C scripts do not contain any spaces. 

 

Note In a Single Station, only one publishing process is needed to publish local data 
on the Web Server. 

For information on the topic of “supported script standard functions”, refer to the 
“SIMATIC PCS 7 Web Option for OS” manual. 
https://support.industry.siemens.com/cs/ww/en/view/109805408 
("Web-enabled functions for the Web Option for OS") 

 

https://support.industry.siemens.com/cs/ww/en/view/109805408
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7.4.1 Publishing project data 

Step Action Note 

1.  Open the OS project of the OS Web Server 
in WinCC Explorer. 

Using the shortcut menu of the "Web 
Navigator" editor, select the "Web View 
Publisher" command. 

The system opens the "WinCC Web 
Publishing Wizard - Introduction" dialog 
box. 

Click on "Continue". 

 

2.  This opens the "WinCC Web Publishing 
Wizard – Select files and folders" dialog 
box. 

Clear the "Server Prefix" checkbox, since 
you want to publish local data. 

Accept the default destination and source 
paths. If you really want to change the 
respective path, click on the button behind 
the grayed entry fields. Navigate to the 
desired target or source folder. 

Click on "Continue". 

 

3.  The system opens the "WinCC Web 
Publishing Wizard - Select pictures" dialog 
box. 

Select all of the pictures that you want to 
publish. We recommend publishing all of 
the standard pictures. 

Use the ">>", "<<", ">”, and "<" buttons to 
select the pictures. 

Click on "Continue". 

 

4.  The system opens the "WinCC Web 
Publishing Wizard - Select functions" dialog 
box. 

Select all of the functions that you want to 
publish. In the pictures, only the scripts are 
available that you selected during the last 
publication process. This means that you 
must select all the necessary functions at 
every publication process. 

Use the ">>", "<<", ">”, and "<" buttons to 
select the functions. 

Click on "Continue". 
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Step Action Note 

5.  The system opens the "WinCC Web 
Publishing Wizard - Referenced graphics" 
dialog box. 

Select all of the graphics that you want to 
publish. We recommend publishing all of 
the graphics. 

Use the ">>", "<<", ">”, and "<" buttons to 
select the graphics. 

Click on "Continue". 

 

6.  The system opens the "WinCC Web 
Publishing Wizard - Finish" dialog box. 

Click on the "Finish” button. 

 

 

7.  Pictures and functions that contain faulty 
scripts are identified by a red cross. 

Double-click on each faulty picture to open 
the picture in the "PdlPad" editor and to 
correct it. 

Once the publishing process is complete, 
click on the "OK" button to confirm the 
message. 
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Step Action Note 

8.  The system lists the transferred pictures in 
the "WinCC Web Publishing Wizard – 
Finish" dialog box. 

Click on the "Finish” button. 

 

9.  The published pictures are displayed in the 
data window of the Web Navigator. 
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7.4.2 Setting up user rights, website start screen, and the language 

Restriction of access 

You can control the access of the Web client to the OS Web Server by defining 
user rights. You assign user rights in the “User Administrator” editor. User rights 
are the same as those of the standard clients. 

Settings in the "User Administrator" editor 

Step Action Note 

1.  In the WinCC Explorer of the currently 
open OS project, open the "User 
Administrator” editor. 

Create new users and/or new user groups 
that you want to assign appropriate 
permissions to. 

Also select the "Web Navigator" checkbox 
for the user(s) or user group(s) and enter 
the "Start picture" and “Language” of the 
website in the corresponding input fields.  

2.  Use the "..." button to select the start 
picture from the published graphics. 

"…\OS Web Server\<wincc-projectshare-
name>\Web Navigator\pictures" 

Choose the "@screen.pd_" graphic as the 
start picture. 

Click on the “Open" button to confirm your 
selection 

You can also specify a language for the 
control and monitoring interface of the 
Web clients. To do this, you must also 
click on the corresponding "...” button. 

Click on the "OK" button to confirm your 
selection. 

 

3.  Close the User Administrator Editor.  
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7.4.3 Configuring using the Web Configurator 

Web Configurator tasks 

The Web Configurator enables you to configure and manage the Internet 
Information Service (IIS) and therefore the website of the OS Web Server. You 
make the setting on the Web Server after you have downloaded the project to the 
Web Server. Setup and configuration are necessary to set up an operating station 
(OS) as an OS Web Server and to make it accessible for the Web clients via the 
Intranet/Internet. 

The Web Configurator allows you to make the necessary firewall settings, if a 
firewall is activated. 
 

Requirements of the Single Station 

• The PCS 7 Web Server software has been installed on the Single Station 

• The OS project has been downloaded to the Single Station 

• All settings have been made in the OS 

• Pictures, functions, and graphics have been published 

• User rights have been assigned 

 

Note For more information about setting up the standard Web site, refer to the manual 
entitled "SIMATIC PCS 7 Web Option for OS" 
https://support.industry.siemens.com/cs/ww/en/view/109805408 
Chapter: "Completing the configuration on the Web server" 

 

https://support.industry.siemens.com/cs/ww/en/view/109805408
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Settings in the "Web Navigator" editor 

Step Action Note 

1.  Open the OS project in WinCC Explorer on 
the OS Web Server. 

Use the shortcut menu of the "Web 
Navigator" editor to select the "Web 
Configurator" command. 

The system opens the "WinCC Web 
Configurator" dialog box. 

Click on "Continue". 

 

2.  In the next window, select "Create a new 
standard Web site (stand-alone)". 

Click on "Continue". 

 

3.  Enter a name for your web site in the 
"Name of the Web site" text box. 

Also assign the IP address and connection 
port of the computer in the "Port" and "IP 
address" text boxes. 

Under "Default Web-Page”, select 
"MainControl" from the drop-down list. 

Enter a time interval in the "Reconnect 
Interval" text box. 

Select the "Start the web-site after being 
configured” checkbox. 

Click on "Continue". 

If you have not activated the Windows 
firewall, continue with step "7". 

 

4.  Click on the "Windows Firewall" button (the 
button is only visible if the firewall is 
activated). 
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Step Action Note 

5.  Click the "Advanced Settings" button in the 
"Windows Firewall" dialog box. 

 

6.  Check whether the "World Wide Web 
Services (HTTP Traffic-In) inbound rule is 
activated. If this function is deactivated, 
highlight it and choose the "Enable" 
command in the shortcut menu. 

 

7.  Click on the "Finish” button. 

 

8.  Click on the "OK" button. 

Then, close WinCC Explorer and restart 
your computer to apply the settings. 
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7.4.4 Downloading and compiling the Web Server 

Downloading the Web Server 

Since the OS Web Server function is on a Single Station (ES/OS/Web Server), it is 
not necessary to carry out downloading or change downloading of project data. 
Due to the "Compile OS", the necessary data is already present locally. 

 

Compile 

The "Compile Changes" function can be executed in Single Station without having 
to interrupt the process mode of the Web Server. 

 

Note For more information about “Configuring the OS Web Server”, refer to the 
manual entitled "SIMATIC PCS 7 Web Option for OS" 
https://support.industry.siemens.com/cs/ww/en/view/109805408 
(Chapter: "Configuring the Web server on an ES") 

 

https://support.industry.siemens.com/cs/ww/en/view/109805408
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7.5 Settings on the Web client 

Settings for the "Internet" or "Local Intranet" Web content zone 

In Internet Explorer, you must make/check the settings for the Web content zone 
such that you will be able to install the plug-ins for the Web client from the OS Web 
server later. 

 

Step Action Note 

1.  Open Internet Explorer. 

Select the  
“Tools > Internet Options” menu 

command. 

 

2.  Click on the "Security" tab. 

Highlight the Web content zone in which 
the Web server is located  
("Internet" or "Local intranet"). 

Click on the "Custom Level" button. 
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Step Action Note 

3.  Select the radio buttons under "Run 
ActiveX controls that are safe for scripting" 
and "Download signed ActiveX controls". 

 

4.  Click on each of the "OK" buttons for the 
"Security Settings" and "Internet Options" 
dialog boxes to close them. 
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Settings for the "Trusted sites" Web content zone 

Step Action Note 

1.  Open Internet Explorer. 

Select the  
“Tools > Internet Options” menu 

command. 

 

2.  Click on the "Security" tab. 

Highlight the "Trusted sites” Web content 
zone. 

Click on the "Sites" button to open the 
dialog box. 

 

3.  In the text box "Add this website to the 
zone", enter the address of the OS Web 
server (7.4.3 Configuring with the 
Web Configurator > Settings in 

the "Web Navigator" editor), 

e.g. *://172.61.0.1 or http://*.microsoft.com 

Also, clear the "Require server verification 
(https:) for all sites in this zone” checkbox. 

Click on the "Add" and "Close" buttons. 

 

http://*.microsoft.com/
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Step Action Note 

4.  Highlight the “Trusted sites” Web content 
zone. 

Click on the "Default level" button and then 
on the "Custom level" button. 

 

5.  In the "Security Settings" dialog box, select 
the radio button under "Initialize and script 
ActiveX controls not marked as safe for 
scripting". 

 

6.  Click on each of the "OK" buttons for the 
"Security Settings" and "Internet Options" 
dialog boxes to close them. 

 

 

You have now created the conditions that are needed to connect from a Web client 
to a Web server. 
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7.6 Installing the Web client plug-ins 

Installation methods 

During installation of plug-ins for Internet Explorer, you can choose between two 
installation methods: 

• Remote Installation - Installation via the Intranet/Internet from the Web server 

• Local Installation - Installation via the Windows installer package of the Web client 

In this application example, we will consider "remote installation". 

 

Requirements 

• The OS Web server is in runtime. 

• The "PCS 7 Web Client" software package has been installed on the PC. 

• The Web client has access to the Web server. 

• You know the Web server's address. 

• You know the domain name, user name, and password. 

• The user permissions apply to the PCS 7 Web Options. 

• The logon on the PC has the rights of a primary user. 

Installation 

Step Action Note 

1.  Open Internet Explorer. 

Enter the web server address 
(http://<server name or IP>) in the 
"Address" text box. 

 

2.  In the "Enter Network Password" dialog 
box, enter the credentials that were set in 
the "User Administrator" editor on the Web 
server. 
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Step Action Note 

3.  When you first connect, the "Security 
Warning" dialog box opens. 

Proceed by clicking on the "Install" button. 

 

4.  The system now displays all of the 
available plug-ins for the Web client in the 
Internet Explorer window. 

To install the plug-in, click on the arrow in 
front of the version number in the "Install" 
column.  

The following plug-ins are installed to 
ensure a minimum of process control: 

• WinCC Basic Process Control 

• WinCC Advanced Process Control 

• PCS 7 Basic Faceplates 

• PCS 7 Advanced Faceplates 

During installation, always proceed in the 
order that is shown. 

 

5.  Installation of the Web client is complete. 

Close Internet Explorer and reopen it to 
register for process control. 

The process pictures can be called once 
the Web client has established a 
connection to the Web server. 

 

 

Note For more information about "Installing a Web client", "Process control on the 
Web client" and "Settings", refer to the manual entitled "SIMATIC PCS 7 Web 
Option for OS" 

https://support.industry.siemens.com/cs/ww/en/view/109805408 
(Chapter: "Installation and settings for the Web client") 

 

https://support.industry.siemens.com/cs/ww/en/view/109805408


8 Appendix 

 

Minimal Configuration 
Entry-ID: 24023824,    V8.0,    02/2022   130 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
2

2
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

8 Appendix 

8.1 Service and support 

Industry Online Support 

Do you have any questions or need assistance?  

Siemens Industry Online Support offers round the clock access to our entire 
service and support know-how and portfolio. 

The Industry Online Support is the central address for information about our 
products, solutions and services.  

Product information, manuals, downloads, FAQs, application examples and videos 
– all information is accessible with just a few mouse clicks:  

support.industry.siemens.com 

Technical Support 

The Technical Support of Siemens Industry provides you fast and competent 
support regarding all technical queries with numerous tailor-made offers  
– ranging from basic support to individual support contracts.  

Please send queries to Technical Support via Web form: 

support.industry.siemens.com/cs/my/src 

SITRAIN – Digital Industry Academy 

We support you with our globally available training courses for industry with 
practical experience, innovative learning methods and a concept that’s tailored to 
the customer’s specific needs. 

For more information on our offered trainings and courses, as well as their 
locations and dates, refer to our web page: 

siemens.com/sitrain  

Service offer 

Our range of services includes the following:  

• Plant data services 

• Spare parts services 

• Repair services 

• On-site and maintenance services 

• Retrofitting and modernization services 

• Service programs and contracts 

You can find detailed information on our range of services in the service catalog 
web page: 

support.industry.siemens.com/cs/sc 

Industry Online Support app 

You will receive optimum support wherever you are with the "Siemens Industry 
Online Support" app. The app is available for iOS and Android:  

support.industry.siemens.com/cs/ww/en/sc/2067 

 

https://support.industry.siemens.com/
https://support.industry.siemens.com/cs/my/src
https://www.siemens.com/sitrain
https://support.industry.siemens.com/cs/sc
support.industry.siemens.com/cs/ww/en/sc/2067
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8.2 Industry Mall 

 

The Siemens Industry Mall is the platform on which the entire siemens Industry 
product portfolio is accessible. From the selection of products to the order and the 
delivery tracking, the Industry Mall enables the complete purchasing processing – 
directly and independently of time and location: 
mall.industry.siemens.com  
 

 

8.3 Links and literature 

Table 8-1 

No. Topic 

\1\ Siemens Industry Online Support 

https://support.industry.siemens.com 

\2\ Link to this entry page of this application example 

https://support.industry.siemens.com/cs/ww/de/view/24023824 

\3\  

 

 

8.4 Change documentation 

Table 8-2 

Version Date Change  

V1.0 10/2006 First edition V6.1 SP1 

V1.1 11/2006 Revised V6.1 SP1 

V1.2 05/2009 Revised V6.1 SP1 

V2.1 09/2008 First edition V7.0 SP1 

V2.2 12/2008 Correction of table 6-2 

V2.3 05/2009 Revision V7.0 SP1 

V3.0 05/2009 First edition V7.1 

V3.1 05/2009 Revision V7.1 

V3.2 11/2009 Extension of the document for V7.1 to include the PCS 7 
Web Option (tested for PCS 7 V7.1 and V7.0 SP2) 

V2.4 12/2010 Note added: 

The configuration described in chapter 6, "Master ES/OS 
and Standby OS" only works in PCS 7 V7.0 SP3 if it has 
WinCC V6.2 SP3 HF8 or higher. 

V3.3 09/2011 Note added: 

The configuration described in chapter 6, "Master ES/OS 
and Standby OS" only works in PCS 7 V7.1 SP2 and SP3 if 

https://mall.industry.siemens.com/
https://support.industry.siemens.com/
https://support.industry.siemens.com/cs/ww/de/view/24023824
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Version Date Change  

it has WinCC V7.0 SP2 HF5 or higher. 

V4.0 10/2012 First edition PCS 7 V8.0 Upd1 

V4.1 11/2012 Adaptations in the following chapters: 

• Chapter 7 "Expansion with the PCS 7 OS Web Option" 

• Chapter 7.1 "Web configurations" 

• Chapter 7.2 "Web-specific hardware and software 
requirements" 

New chapter: 

• Chapter 7.3 "Maximum number of Web client 
connections" 

V4.2 01/2013 Introduction in chapter 6 "Master ES/OS and Standby OS" 
has been editorially revised. 

V4.3 05/2013 Test and declaration for PCS 7 V8.0 SP1 

V4.4 09/2013 License adjustments in chapter 7.1. "Web configurations" in 
Fig. 7-1 "Web Option in Single Station" 

V5.0 02/2015 Test and declaration for PCS 7 V8.1 

V6.0 06/2016 Test and declaration for PCS 7 V8.2 

V7.0 11/2017 Expansion of time synchronization in chapter 3 "ES/OS 
Single Station" 

Test and declaration for PCS 7 V9.0 

V7.1 02/2018 Step added (Configuring the standard server) in chapter 
5.3.3 "OS configuration" OS Client 

V8.0 02/2022 Test and declaration for PCS 7 V9.1 
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