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Safety Guidelines

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert

symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are
graded according to the degree of danger.

/\DANGER

indicates that death or severe personal injury will result if proper precautions are not taken.

/\WARNING

indicates that death or severe personal injury may result if proper precautions are not taken.

/\CAUTION

with a safety alert symbol, indicates that minor personal injury can result if proper precautions are not taken.

CAUTION

without a safety alert symbol, indicates that property damage can result if proper precautions are not taken.

NOTICE

indicates that an unintended result or situation can occur if the corresponding information is not taken into
account.

If more than one degree of danger is present, the warning notice representing the highest degree of danger will

be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to
property damage.

Qualified Personnel
The device/system may only be set up and used in conjunction with this documentation. Commissioning and
operation of a device/system may only be performed by qualified personnel. Within the context of the safety notes

in this documentation qualified persons are defined as persons who are authorized to commission, ground and
label devices, systems and circuits in accordance with established safety practices and standards.

Prescribed Usage

Note the following:

/\WARNING

This device may only be used for the applications described in the catalog or the technical description and only
in connection with devices or components from other manufacturers which have been approved or
recommended by Siemens. Correct, reliable operation of the product requires proper transport, storage,
positioning and assembly as well as careful operation and maintenance.

Trademarks

All names identified by ® are registered trademarks of the Siemens AG. The remaining trademarks in this

publication may be trademarks whose use by third parties for their own purposes could violate the rights of the
owner.

Disclaimer of Liability

We have reviewed the contents of this publication to ensure consistency with the hardware and software
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the

information in this publication is reviewed regularly and any necessary corrections are included in subsequent
editions.

Siemens AG Ordernumber: A5E01071736-01 Copyright © Siemens AG 2007.
Automation and Drives ® 08/2007 Technical data subject to change
Postfach 48 48

90327 NURNBERG
GERMANY
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Purpose of Getting Started 1

Task

This Getting Started is intended to lead you through the five steps in commissioning a fully
functional application. Based on a practical example, it shows you how to create several

position-based cams on a rotary axis, introduces the basic functions of FM 352 hardware
and software, and corresponding test features.

It will take you between 1 and 2 hours to work your way through the example, depending on
your prior experience.
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Preconditions 2

Overview

The following requirements must be met:

You have an S7-300 station, consisting of a power supply module and a CPU.

You have met the requirements described in the readme.rtf file, in particular, the required
version of STEP 7. The readme.rtf file is available on the CD included in your shipment.

You have configured a project for the S7-300 station.
The programming device is connected to the CPU.

You must have an FM 352 module, the configuration package for the FM 352, and the
necessary accessories such as an expansion bus, front connector, and wiring material.
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Installing the Configuration Package on your 3

Programming Device

Procedure

The FM 352 configuration package contains a parameter assignment tool, the necessary
functions (FCs) and function blocks (FBs), the data structures (UDTs), and a sample
program.

1. Place the CD into the CD drive.

2. In Windows, run the software setup dialog by double-clicking "Add/Remove Programs" in
the "Control Panel".

3. Click "Install...", select the Setup.exe file from the Setup folder on the CD, and follow the
setup instructions.
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Installing the Configuration Package on your Programming Device
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FM 352, installing and wiring 4

Procedure
1. Switch off the power supply, then set the mode selector switch of the CPU to STOP.
2. Connect the bus connector shipped with the FM 352 to the bus connector of the CPU.
3. Hang the FM 352 on the rail, tilt it downwards, and screw it into place. You can find a
detailed explanation in the manual.
4. Wire the front connector as shown below:
Power
FM 352 front
SUppIy CPU connectrgrn
module
L+ | (= 21
YRE= 22
L+ | CJo Lo é 23
M | e 0o |M o4
L+ | = = Jo |L+ 25
M | = =10 |M 26
=J1o | | 28
200
5. Insert the front connector onto the FM 352 connector and lock it into place.
Test

Apply line voltage to the power supply module.

The red SF LED of the FM 352 lights up quickly and goes off after a successful internal
module test.
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FM 352, installing and wiring
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Programming the FM 352

Procedure
1. Open your project in SIMATIC Manager.
2. Open the object hardware. The HW Config window with the configuration table is
displayed.
3. From the hardware catalog select the FM 352 with the correct MLFB and mount it in the
intended slot (in the example: slot 4).
4. Double-clicking on the FM 352 leads you to the "Cam Controller - [FM 352 CAM (S/of)
(Setting Parameters) - Projectname|Stationname]" window of the parameter assignment
interface.
5. Select the following settings in the parameter assignment dialog box (leave all other
settings unchanged):
System of units: Degree (4 decimal places)
Axis: (o) Rotary axis
End of the rotary axis 360.0000 degrees
Simulated speed 360.0000 degrees/min
Encoders: Monitoring Switch off wire break and error pulse
Cams:
No. Valid Track | Type Start End Time | Actuation time | Activation Hardware
[degrees] [degrees] [ms] [ms] direction interrupt
0 v 0 Distan 0.0000 90.0000 0.0 Both None
ce
1 v 0 Distan 180.0000 270.0000 0.0 Both None
ce
2 v 1 Distan 0.0000 90.0000 2000.0 Both None
ce
3 v 1 Distan 180.0000 270.0000 2000.0 Both None
ce
4 v 2 Distan 130.0000 330.0000 0.0 Both None
ce
5 v 3 Distan 130.0000 330.0000 2000.0 Both None
ce

6. Apply the settings in the parameter assignment interface with "File > Save" and close the
interface with "File > Exit".

7. Save your configuration to your project with "Station > Save and compile".
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Programming the FM 352

8. When the CPU is in STOP mode, choose "PLC > Download to module..." to download the
configuration.

The data are transferred directly to the CPU and the FM 352. Provided you backup
configuration data on the CPU, the CPU always transfers these data to FM 352 at each
STOP to RUN transition.
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Test the FM 352

Procedure
1. In HW Config, open the parameter assignment interface by double-clicking the FM 352.

2. Open the "Cam Controller - [FM 352 CAM (...) (Commissioning) -
Projectname|Stationname]" commissioning screen via "Test > Commissioning".

3. Select track signals 0 to 3 in "Enable track signals”, and enable them by clicking "Apply".

4. Select the "Set reference point" setting in "Other test functions”, enter 0.000 degrees as
the reference point, and click "Apply". This synchronizes the axis, the display is green at
"Synchronized" in the commissioning interface.

5. In "Other test functions", select the "Function switch" and then "Simulation on" option and
click the Apply button.

6. Click "On" at "Enable test".

7. Click "On" at "Cam Controller". The cam start has been configured to 0 for tracks 0 and 1
in the example, and as a reaction, the "Cam processing active" display and the track
signals 0 and 1 are displayed in green.

8. Click on "Dir_P" at "Simulation direction".

The encoder signals are now being simulated. You can monitor the actual value and the
track signals (green = at least one active cam; gray = no active cams). You can also monitor
the track signals on the LEDs of the outputs QO to Q3 of the FM 352.
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Integration in the user program 7

Procedure
1. In SIMATIC Manager, choose "File > Open... > Libraries" to open the FMx52LIB library.
This library contains two program folders:
- FM 352,452 CAM V1
- FM 352 CAM V2

For the FM 352 you can always use the function blocks (FBs) and functions (FCs) from
both program folders. However, for new applications you should utilize only the

FM 352 CAM V2 program folder. The blocks in the FM352 CAM V2 program folder also
support access to a distributed FM 352 configuration via PROFINET.

2. Copy FC 0 and FB 1 from the "FM 352 CAM V2 / Blocks" folder of the FMx52LIB library
to the "Blocks" folder of your project.

3. Choose "Insert > S7 Block > Data Block" to insert DB1 as an instance DB of FB1 and
choose "Insert > S7 Block > Organization Block" to insert the OB 100 into the "Blocks"
folder of your project.

The instance DB for FB1 is referred to as a channel DB.
4. Now, open OB 1 and OB 100 in your project. In OB 1, call FB 1.

5. In OB 100, enter the module starting address of the FM 352 that you configured in
HW Config.

6. Then, open FC 0 using the DB number of the channel DB as a parameter.

OB 1:
CALL FC 1, DB 1

OB 100:

L 256 // Write module address

T DB1.DBWO // to the instance DB

CALL FC 0 // Initialize module

DB NO := 1
7. Choose "File > Save" to save OB 1 and OB 100.
8. Select blocks FC 0, FB 1, DB 1, OB 1, and OB 100 in your project.
9. Choose "PLC > Download" to download your program to the CPU.

FM 352 First Steps in Commissioning
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Integration in the user program

Test
Use the "Monitor and modify variables" functions to monitor the cam data, cam tracks and
the actual value, for example:
1. Create a symbol with the name "CAM" for DB 1.
2. Select the "Blocks" folder of your project. Choose the "Insert > S7 Block > Variable Table"
menu command to insert the VAT 1 variable table, and then confirm with "OK".
3. Open the variable table VAT 1 and enter the following in the "Symbol", "Display Format"
and "Modify Value" columns:
Address Symbol Modify Status value | Control value Meaning
format
DB1.DBW 16 CAM.TRACK_EN HEX FFFF Enable track signals
DB1.DBD 98 CAM.REFPT DEC 0 Reference point coordinate
DB1.DBX 36.3 CAM.REFPT_EN BIN 1 Set reference point
DB1.DBX 15.4 CAM.CAM_EN BIN 1 Cam controller ON
DB1.DBX 34.1 CAM.SIM_ON BIN 1 Simulation ON
DB1.DBX 15.3 CAM.DIR_P BIN 1 Simulation direction positive
DB1.DBD 26 CAM.ACT_POS DEC Current actual value
DB1.DBD 30 CAM.TRACK_OUT BIN Track signals
4. Choose "Table > Save" to save the variable table VAT 1.
5. Choose "PLC > Connect To > Configured CPU" to switch to online.
6. Choose "Variable > Monitor" to switch to monitoring.
7. Switch the CPU to RUN-P.
8. Choose "Variable > Activate Modify Values" to make the control values valid.
You can now monitor the current actual value (ACT_POS) and the track signals
(TRACK_OUT) in the "Status Value" column.
Diagnostics
Problems can occur due to bad operator input, incorrect wiring or inconsistent parameter
assignment. The manual describes how to diagnose such errors and messages.
Example
In the zEn19_02_FMx52_Prog project you will find more examples of the use of blocks from
the FM 352 CAM V2 folder. You can use these examples as a guide and adapt them to your
application.
FM 352 First Steps in Commissioning
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