# LOGO! Web Editor Online Help

Operating Instructions
Legal information

Warning notice system
This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are graded according to the degree of danger.

| △ DANGER   | indicates that death or severe personal injury will result if proper precautions are not taken. |
| △ WARNING  | indicates that death or severe personal injury may result if proper precautions are not taken. |
| △ CAUTION  | indicates that minor personal injury can result if proper precautions are not taken. |
| NOTICE     | indicates that property damage can result if proper precautions are not taken. |

If more than one degree of danger is present, the warning notice representing the highest degree of danger will be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property damage.

Qualified Personnel
The product/system described in this documentation may be operated only by personnel qualified for the specific task in accordance with the relevant documentation, in particular its warning notices and safety instructions. Qualified personnel are those who, based on their training and experience, are capable of identifying risks and avoiding potential hazards when working with these products/systems.

Proper use of Siemens products
Note the following:

| △ WARNING   | Siemens products may only be used for the applications described in the catalog and in the relevant technical documentation. If products and components from other manufacturers are used, these must be recommended or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and maintenance are required to ensure that the products operate safely and without any problems. The permissible ambient conditions must be complied with. The information in the relevant documentation must be observed. |

Trademarks
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability
We have reviewed the contents of this publication to ensure consistency with the hardware and software described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the information in this publication is reviewed regularly and any necessary corrections are included in subsequent editions.
Table of contents

1 Introduction ........................................................................................................................................ 7
  1.1 Security information .................................................................................................................. 7
  1.2 General introduction .................................................................................................................. 7
  1.2.1 Basic concept ........................................................................................................................ 8
  1.2.2 Compatibility ......................................................................................................................... 9

2 User interface .................................................................................................................................. 11
  2.1 User interface - Overview ......................................................................................................... 11
  2.2 Function keys and shortcuts ...................................................................................................... 12
  2.3 Standard toolbar overview ........................................................................................................ 13
  2.4 Menu bar .................................................................................................................................. 13
    2.4.1 File menu ............................................................................................................................. 14
    2.4.1.1 File -> New Project ............................................................................................................ 14
    2.4.1.2 File -> Open Project .......................................................................................................... 15
    2.4.1.3 File -> Close Project ......................................................................................................... 16
    2.4.1.4 File -> Save ....................................................................................................................... 16
    2.4.1.5 File -> Save All ................................................................................................................... 16
    2.4.1.6 File -> Save As ................................................................................................................... 16
    2.4.1.7 File -> Exit ......................................................................................................................... 17
    2.4.2 Edit menu ............................................................................................................................ 17
    2.4.2.1 Edit -> Right Rotate ......................................................................................................... 18
    2.4.2.2 Edit -> Left Rotate ............................................................................................................. 18
    2.4.2.3 Edit -> Redo ...................................................................................................................... 18
    2.4.2.4 Edit -> Undo ...................................................................................................................... 18
    2.4.2.5 Edit -> Select All ................................................................................................................. 18
    2.4.2.6 Edit -> Bring to front .......................................................................................................... 18
    2.4.2.7 Edit -> Send to back .......................................................................................................... 18
    2.4.2.8 Edit -> Copy ...................................................................................................................... 19
    2.4.2.9 Edit -> Paste ...................................................................................................................... 19
    2.4.2.10 Edit -> Delete .................................................................................................................... 19
    2.4.3 Tools menu .......................................................................................................................... 19
    2.4.3.1 Tools -> Download ............................................................................................................. 19
    2.4.3.2 Tools -> Upload .................................................................................................................. 21
    2.4.3.3 Tools -> Deploy To SD Card ............................................................................................... 22
    2.4.3.4 Tools -> Options ............................................................................................................... 22
    2.4.4 Window menu ....................................................................................................................... 23
    2.4.4.1 Window -> Project ............................................................................................................. 23
    2.4.4.2 Window -> Properties ...................................................................................................... 24
    2.4.4.3 Window -> Component .................................................................................................... 24
    2.4.5 Help menu .......................................................................................................................... 25
    2.4.5.1 Help -> Start Page ............................................................................................................. 25
    2.4.5.2 Help -> Help Contents ...................................................................................................... 25
    2.4.5.3 Help -> About ................................................................................................................... 26
# Table of contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.5</td>
<td>Projects Tree</td>
</tr>
<tr>
<td>2.5.1</td>
<td>Pages</td>
</tr>
<tr>
<td>2.5.2</td>
<td>Global Tags</td>
</tr>
<tr>
<td>2.5.3</td>
<td>Navigator</td>
</tr>
<tr>
<td>2.6</td>
<td>Components pane</td>
</tr>
<tr>
<td>2.6.1</td>
<td>Tool</td>
</tr>
<tr>
<td>2.6.1.1</td>
<td>Polyline</td>
</tr>
<tr>
<td>2.6.1.2</td>
<td>Rectangle</td>
</tr>
<tr>
<td>2.6.1.3</td>
<td>Circle</td>
</tr>
<tr>
<td>2.6.2</td>
<td>Basic</td>
</tr>
<tr>
<td>2.6.2.1</td>
<td>Text</td>
</tr>
<tr>
<td>2.6.2.2</td>
<td>Image</td>
</tr>
<tr>
<td>2.6.2.3</td>
<td>Link</td>
</tr>
<tr>
<td>2.6.3</td>
<td>Digital</td>
</tr>
<tr>
<td>2.6.3.1</td>
<td>Digital Value</td>
</tr>
<tr>
<td>2.6.4</td>
<td>Analog</td>
</tr>
<tr>
<td>2.6.4.1</td>
<td>Analog Value</td>
</tr>
<tr>
<td>2.6.4.2</td>
<td>Analog Bar</td>
</tr>
<tr>
<td>2.6.4.3</td>
<td>Analog Slider</td>
</tr>
<tr>
<td>2.6.5</td>
<td>Miscellaneous</td>
</tr>
<tr>
<td>2.6.5.1</td>
<td>Scale Time</td>
</tr>
<tr>
<td>2.6.5.2</td>
<td>LOGO! Clock</td>
</tr>
<tr>
<td>2.7</td>
<td>Editor pane</td>
</tr>
<tr>
<td>2.8</td>
<td>Properties pane</td>
</tr>
<tr>
<td>2.9</td>
<td>Graph Library</td>
</tr>
<tr>
<td>2.9.1</td>
<td>Build-In Graph</td>
</tr>
<tr>
<td>2.9.2</td>
<td>Colors</td>
</tr>
<tr>
<td>2.9.3</td>
<td>My Graph</td>
</tr>
<tr>
<td>3</td>
<td>Tutorial</td>
</tr>
<tr>
<td>3.1</td>
<td>Prerequisites for working with the tutorial</td>
</tr>
<tr>
<td>3.2</td>
<td>Getting started with project creation</td>
</tr>
<tr>
<td>3.2.1</td>
<td>Creating a new Project</td>
</tr>
<tr>
<td>3.2.2</td>
<td>Visiting the project through web page</td>
</tr>
<tr>
<td>3.3</td>
<td>Practical example</td>
</tr>
<tr>
<td>3.3.1</td>
<td>Introduction for practical example</td>
</tr>
<tr>
<td>3.3.2</td>
<td>The example for Pages</td>
</tr>
<tr>
<td>3.3.3</td>
<td>The example for Tag Table</td>
</tr>
<tr>
<td>3.3.4</td>
<td>The example for Navigator</td>
</tr>
<tr>
<td>3.3.5</td>
<td>The example for configuring special components</td>
</tr>
<tr>
<td>3.3.6</td>
<td>Visiting the example project through web page</td>
</tr>
<tr>
<td>4</td>
<td>HTML development interface</td>
</tr>
<tr>
<td>4.1</td>
<td>LOGO! data access protocol</td>
</tr>
<tr>
<td>4.1.1</td>
<td>Operation</td>
</tr>
<tr>
<td>4.1.1.1</td>
<td>Command</td>
</tr>
<tr>
<td>4.1.1.2</td>
<td>Data format</td>
</tr>
<tr>
<td>4.2</td>
<td>Example</td>
</tr>
</tbody>
</table>

LOGO! Web Editor Online Help
Operating Instructions, 03/2019, A5E42880034 - AB
# Table of contents

## 5 Tips and tricks

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.1 How to display a corresponding tooltip for a function key</td>
<td>69</td>
</tr>
<tr>
<td>5.2 How to draw a polyline well</td>
<td>70</td>
</tr>
<tr>
<td>5.3 How to edit component through the shortcut menu</td>
<td>70</td>
</tr>
<tr>
<td>5.4 How to import multiple images</td>
<td>71</td>
</tr>
<tr>
<td>5.5 How to add a link connecting to another page</td>
<td>71</td>
</tr>
</tbody>
</table>

## Index

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>73</td>
</tr>
</tbody>
</table>
Introduction

1.1 Security information

Siemens provides products and solutions with industrial security functions that support the secure operation of plants, systems, machines and networks.

In order to protect plants, systems, machines and networks against cyber threats, it is necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial security concept. Siemens’ products and solutions constitute one element of such a concept.

Customers are responsible for preventing unauthorized access to their plants, systems, machines and networks. Such systems, machines and components should only be connected to an enterprise network or the internet if and to the extent such a connection is necessary and only when appropriate security measures (e.g. firewalls and/or network segmentation) are in place.

For additional information on industrial security measures that may be implemented, please visit [http://www.siemens.com/industrialsecurity].

Siemens’ products and solutions undergo continuous development to make them more secure. Siemens strongly recommends that product updates are applied as soon as they are available and that the latest product versions are used. Use of product versions that are no longer supported, and failure to apply the latest updates may increase customers’ exposure to cyber threats.

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed under [http://www.siemens.com/industrialsecurity].

1.2 General introduction

LOGO! Web Editor is used together with LOGO! Base Module (BM) and LOGO! Soft Comfort. This tool helps you create user-defined web pages in the Editor pane, and visually view the whole project through Web Server of LOGO! Base Module.

With LOGO! Web Editor, you can:

- integrate different components including some variables conveniently;
- customize individual web pages.

Document History

The following edition of LOGO! Web Editor has been published:

<table>
<thead>
<tr>
<th>Edition</th>
<th>Version</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>11/2017</td>
<td>V1.0</td>
<td>First edition</td>
</tr>
<tr>
<td>03/2019</td>
<td>V1.0.1</td>
<td>Second edition</td>
</tr>
</tbody>
</table>
1.2 General introduction

1.2.1 Basic concept

Having a general idea of LOGO! Web Editor is the prerequisite for using it. The basic concept about the whole project is as follows:

Project

In LOGO! Web Editor, project contains Pages and a Navigator. Each page contains predefined components, such as Text, Image, Digital Value and etc. Global Tag is defined for facilitating end user to bind components and variables.

Pages

Pages contains a Home page and some user-defined pages. Home page is a default page, while you can determine whether to create user-defined pages according to your requirements. Either page or Home Page is a web page, and you can visit it in web browser after deploying a project to LOGO! BM.

Navigator

Navigator is a floating page of the web site and it intended to aid users to switch between different web pages or log off during the runtime operation.

Component

LOGO! Web editor contains a couple of pre-defined components for web page. Each component has different render effect in web page. Each component contains some properties.

Variable

Variable is read/write data element of LOGO! BM, such as I, Q, AI, AQ and etc. Variable can be bound with component. You can read/write variable via components.

Global Tag

Global Tag is the alias of variable and it can be bound with some components.

Tag Table

Tag Table is a place to define Global Tags, and you can add, modify, and delete Global Tags here.

Private Tag

Private Tag is used for binding variable to component directly and you do not need to define Global Tags.
1.2.2 Compatibility

LOGO! Web Editor is available for:

- LOGO! Base Module: LOGO! 8 6ED1052-xxx08-0BA0.
- Java Runtime Environment 1.8.0_121, which is recommended version;
- the following types of web browsers which support HTML5:
  - Microsoft Internet Explorer with minimum version 10.0
  - Mozilla Firefox with minimum version 11.0
  - Google Chrome with minimum version 16.0
  - Apple Safari with minimum version 5.0
- the following versions of operating system:
  - Windows 32 & 64 bit, including Windows 7 and Window 10;
  - Mac OS, including 10.9, 10.10, and 10.11;
  - Linux Suse, 11.3 sp3, kernel 3.0.76.
Introduction

1.2 General introduction
User interface

2.1 User interface - Overview

User interface

LOGO! Web Editor starts with an empty pane for the project. When you create a new project, the user interface appears as follow:

- A new project appears in Project tree.
- Component pane contains all the component information.
- An empty window for Home Page in the Editor pane.
- Property pane contains the properties information for the Home Page.

To help you maintain an overview of a complete project, the right side and the bottom of the Editor pane contain scroll bars, which you can use for vertical and horizontal scrolling of the project editing.
2.2 Function keys and shortcuts

**Menu bar**

The top of the LOGO! Web Editor window contains the **menu bar**. Here, you can find various commands for editing and managing your projects, as well as functions for defining your default settings and for transferring of the project to and from LOGO!.

**Standard toolbar**

The **standard toolbar** appears above the Project tree and Editor pane's interface. Initially, LOGO! Web Editor shows you a reduced standard toolbar that provides only the essential functions.

The standard toolbar provides direct access to the essential functions of LOGO! Web Editor. After you open a project for editing, you can see the complete standard toolbar.

![Standard toolbar icons](image)

You can use these icons to create a new project or download, save an existing project, undo/redo the last action, or initiate data transferred to and from LOGO! devices.

### 2.2 Function keys and shortcuts

LOGO! Web Editor provides the following function key and shortcuts for frequently called functions:

**Function key in LOGO! Web Editor:**


**Shortcuts in LOGO! Web Editor:**

- In the **File menu**:
  - [Ctrl+Shift+N] File -> Open Project (Page 15)
  - [Ctrl+F4] File -> Close Project (Page 16)
  - [Ctrl+S] File -> Save (Page 16)
  - [Ctrl+Shift+S] File -> Save All (Page 16)
  - [Alt+F4] File -> Exit (Page 17)

- In the **Edit menu**:
  - [Ctrl+Y] Edit -> Redo (Page 18)
  - [Ctrl+Z] Edit -> Undo (Page 18)
  - [Ctrl+A] Edit -> Select All (Page 18)
  - [Ctrl+C] Edit -> Copy (Page 19)
  - [Ctrl+V] Edit -> Paste (Page 19)
  - [Delete] Edit -> Delete (Page 19)

- In the **Tools menu**:
  - [Ctrl+Shift+F] Tools -> Find (Page 19)
2.3 Standard toolbar overview

The icons of the standard toolbar provide quick access to commands that are also available on the menu.

In LOGO! Web Editor, you can use the mouse-over-button function to display the icon name, which represents the tooltip. This helps you quickly recall the function of the icon, without calling the menu or the help.

The following commands are found in the standard toolbar:

- **File**: New Project (Page 14), Open Project (Page 15), Close Project (Page 16), Save (Page 16), Save all (Page 16)
- **Edit**: Left Rotate (Page 18), Right Rotate (Page 18), Redo (Page 18), Undo (Page 18)
- **Tools**: Download (Page 19), Upload (Page 21), Deploy To SD Card (Page 22)

2.4 Menu bar

The menu bar contains some editing functions for the project and provides access to the context-sensitive help.

- File menu (Page 14)
- Edit menu (Page 17)
- Tools menu (Page 19)
- Window menu (Page 23)
- Help menu (Page 25)
2.4 Menu bar

2.4.1 File menu

The File menu command contains commands for file management. Included are also commands for creating, saving or exit:

- **New Project** (Page 14)
- **Open Project** (Page 15)
- **Close Project** (Page 16)
- **Save** (Page 16)
- **Save All** (Page 16)
- **Save As...** (Page 16)
- **Exit** (Page 17)

2.4.1.1 File -> New Project

Click this command to open a **New Project** dialog box which contains name, location and resolution information.

![New Project dialog box](image)
2.4 Menu bar

Name and Location dialog box

- Project Name: give a valid name to the project.

Note

Naming Conventions for the Project Name

- The maximum length of a name is 8.
- The maximum length of filename extension is 3.
- Do not use space in the file name.
- Do not assume case sensitivity.
- Do not use the following characters:
  - < (less than)
  - > (greater than)
  - : (colon)
  - " (double quote)
  - / (forward slash)
  - \ (backslash)
  - | (vertical bar or pipe)
  - ? (question mark)
  - * (asterisk)

- Project Location: click Browse button and select a proper location in your computer to save the project.

- Default Resolution: click the drop-down menu and select a resolution for the project.

After modifying this dialog box, click Finish button to accomplish the new project creation. Then a new project appears in Project tree.

You can also click Cancel button to cancel the creation or click Help button to get more information from online help.

The standard toolbar (Page 13) also contains an icon for this menu command.

2.4.1.2 File -> Open Project

Click this command to open a dialog box from which you can select and open a previously created project for further editing.

The type of file that you can open is only for Project Folder.

The icon for the Project Folder is 🌟.

The standard toolbar (Page 13) also contains an icon for this menu command.
2.4.1.3 **File -> Close Project**

Click this command to close the active project window. If you have not yet saved the current project, LOGO! Web Editor prompts you to save it.

The standard toolbar (Page 13) also contains an icon for this menu command.

2.4.1.4 **File -> Save**

Click this command to save the current editor pane.

For other opened windows, you can save them with **Save all**. You can find additional information under **File -> Save All** (Page 16).

If you are saving a modified version of an existing project, LOGO! Web Editor performs a quick save. The revised version overwrites the old version at the same path and name as the source file.

The standard toolbar (Page 13) also contains an icon for this menu command.

2.4.1.5 **File -> Save All**

Click this command to save all the corrections for project in editor pane.

The revised version overwrites the old version at the same path and name as the source file.

The standard toolbar (Page 13) also contains an icon for this menu command. A click on this menu command closes all open windows.

2.4.1.6 **File -> Save As...**

After clicking this command, a dialog box opens for you to specify the path and project name under which the current project is to be saved. This allows you to save modified projects under a different name or folder, and thus keep previous versions for retrieval.

The only type of files that you can save is project folder. Each project is saved in its own project folder.
2.4.1.7  File -> Exit

Click this command to close LOGO! Web Editor tool.

If you are editing a project and have not yet saved it, LOGO! Web Editor prompts you about your project.

Below is an example for the pop-up window:

In this pop-up window, you can decide which windows are need to be saved. You can click **Save** to save the current window or click **Save All** to save project.

Alternatively, you can exit LOGO! Web Editor without saving windows by clicking **Discard All**.

You can also click **Cancel** button to cancel the creation or click **Help** button to get more information from online help.

2.4.2  Edit menu

The Edit menu provides commands for editing your project. The toolbar contains some of the basic commands for creating and editing projects.

- Right Rotate (Page 18)
- Left Rotate (Page 18)
- Redo (Page 18)
- Undo (Page 18)
- Select All (Page 18)
- Bring to front (Page 18)
- Send to back (Page 18)
- Copy (Page 19)
- Paste (Page 19)
- Delete (Page 19)
2.4.2.1 **Edit -> Right Rotate**

Click this command to rotate the component clockwise. Once you select the component, and then click the **Right Rotate** button, you can rotate the component 90 degrees clockwise. The standard toolbar (Page 13) also contains an icon for this menu command.

2.4.2.2 **Edit -> Left Rotate**

Click this command to rotate the component anticlockwise. Once you select the component, and then click the **Left Rotate** button, you can rotate the component 90 degrees anticlockwise. The standard toolbar (Page 13) also contains an icon for this menu command.

2.4.2.3 **Edit -> Redo**

Click this command to revert the last undo action. The standard toolbar (Page 13) also contains an icon for this menu command.

2.4.2.4 **Edit -> Undo**

Click this command to undo the previous actions. The standard toolbar (Page 13) also contain an icon for this menu command.

2.4.2.5 **Edit -> Select All**

Click this command to select all components in current Pages or Navigator under the project, for example, Polyline, Rectangle, Image or Navigator Item can be selected on the Editor pane. You cannot use this command to select the component in Global Tags.

2.4.2.6 **Edit -> Bring to front**

Click this command to move a component to the top position in its group or layer.

2.4.2.7 **Edit -> Send to back**

Click this command to move a component to the bottom position in its group or layer.
2.4.2.8 Edit -> Copy

Click this command to copy one or more selected components to the clipboard, for example, you can copy the selected Polyline, Rectangle, Image and Navigator Item from the Editor pane to the clipboard.

2.4.2.9 Edit -> Paste

Click this command to copy the clipboard content to the Editor pane.

2.4.2.10 Edit -> Delete

Click this command to delete the selected components, without copying them to the clipboard. You can retrieve deleted components with the Undo function.

When you delete the selected components, a pop-up window of Confirm Object Deletion appears. You can confirm the deletion with Yes button or cancel the deletion with No button in the pop-up window.

2.4.3 Tools menu

The tools menu provides the following menu commands:

- Download (Page 19)
- Upload (Page 21)
- Deploy To SD Card (Page 22)
- Options (Page 22)

2.4.3.1 Tools -> Download

Click this command to download a LOGO! Web Editor project from PC to the Micro SD card of LOGO! Base Module. You can also use this button in the standard toolbar (Page 13) for such purpose.
Example for Download

To download a new project to LOGO! Base Module, do the following steps:

1. Click the icon in the standard toolbar or select **Download** from **Tools** bar.
2. In the pop-up **Download** window,
   - select correct **Interface** from the drop-down menu;
   - enter the valid **Target IP Address** or click scan icon to find the accessible device to connect the BM.
   - click **Test** button, and then a **Connecting** pane pops up.
   - after the connection line turns green, click **OK** button. You can also click **Cancel** button to cancel the configuration or click **Help** button to get more information from online help.

![Download Window](image-url)
3. In the **Confirm Download** pane, click **OK** button to confirm to download the project.

![Confirm Download](image)

Then the project is downloaded to LOGO! BM.

![Downloading lwe1](image)

4. In the **Confirm** pane, click **OK** button to start the BM.

![Confirm](image)

### 2.4.3.2 Tools -> Upload

Click this command to upload a LOGO! Web Editor project from the Micro SD card of LOGO! Base Module to PC. You can also use this button in the [standard toolbar](Page 13) for such purpose.
2.4.3.3  Tools -> Deploy To SD Card

Click this command to deploy the project to Micro SD card, the following dialog box opens and you can specify the driver under which you want to save your project.

The standard toolbar (Page 13) also contains an icon for this menu command.

2.4.3.4  Tools -> Options

Here you can select Language and Size of the text & icons options for LOGO! Web Editor, click the radio button before each options and press OK button to save the selection.

You can also click Cancel button to cancel the selection or click Help button to get more information from online help.

Language

Here you can define the user interface language.

- Deutsch
- English

Size of the text & icons

Here you can select the size of the text and icons in the user interface.

- 100%
- 120%
- 150%
2.4 Menu bar

2.4.4 Window menu

From the Window menu, you can arrange your project windows on the desktop. You can show the Project tree pane, Component pane, Editor pane and Property pane on the desktop.

The following window options are available:

- Project (Page 23)
- Properties (Page 24)
- Component (Page 24)

2.4.4.1 Window -> Project

You can use this menu command to show the Project tree pane on the desktop. If you want to close the Project tree pane, click the cross button $\times$.
2.4.2 Window -> Properties
You can use this menu command to show the Property pane on the desktop. If you want to close the Property pane, click the cross button.

2.4.3 Window -> Component
You can use this menu command to show the Component pane on the desktop. If you want to close the Component pane, click the cross button.
2.4.5 Help menu

This menu provides you with help and information on LOGO! Web Editor.

- Start Page (Page 25)
- Help Contents (Page 25)
- About (Page 26)

2.4.5.1 Help -> Start Page

Close the whole project or close all the windows in Editor pane, and then exit the LOGO! Web Editor, when you restart the LWE again, you can see the Start Page shows in the Editor pane.

If you exit the LOGO! Web Editor without closing the edited project, when you restart the LWE again, the last edited pages can be shown in the Editor pane.

2.4.5.2 Help -> Help Contents

The Online Help

The online help quickly and reliably provides you with information about projects, tools and the creation of projects with LOGO! Web Editor.

Topics of the Online Help

The User interface (Page 11) section describes the user interface with its toolbars and the LOGO! Web Editor menus in detail.

Refer to the Tutorial (Page 51) for a quick and easy introduction to the basics of operating LOGO! Web Editor.

The section of Getting started with project creation (Page 51) that takes you a general description for creating a new project, and towards the end of this section you will find an extensive Practical example (Page 53) that takes you through all the steps of project creation.

The Tips and Tricks (Page 69) section includes information about operating tips with LOGO! Web Editor.

The online help includes an index as well as a full text search feature for keyword and terminology based searches.
2.4.5.3 **Help -> About**

The **General** tab displays the version number and the release version of your LOGO! Web Editor tool.

The **System** tab provides you with information on the version of the Java Runtime environment used, the program paths, the installed operating system and on the memory used.

The **Notice** tab provides you with information on the Commercial Features in Java SE Product Editions.

2.5 **Projects Tree**

In the Project tree pane, you can configure and manage your projects. When you create a new project from the menu bar of File -> New Project (Page 14), LOGO! Web Editor creates a new project with a **Pages**, a **Global Tags** and a **Navigator** automatically.

- **Pages** (Page 26)
- **Global Tags** (Page 28)
- **Navigator** (Page 29)

2.5.1 **Pages**

**Pages** is a container of your pages. You can define the web pages here. After finish editing the pages, you can save them as HTML files and view them in web browser.

The **Pages** contains one default **Home Page** and other pages.

- **Home Page**
  
  This is the home page for your project, and the **Home page** cannot be deleted. You can open it by double-clicking the **Home page** icon, or right-clicking the **Home page** icon and select **Open** button.

- **Other pages**
  
  These are the other user-defined pages for your project. You can open it by double-clicking the **page** icon, or right-clicking the **page** icon and select **Open** button.
Edit the user-defined page

When you create a new project (Page 51), the new project contains three parts: Pages, Global Tags and Navigator. The Home Page appears under the Pages in the Project tree automatically.

1. To create a new page, right-click the Pages icon and select New Page button, a new page appears under the Home Page and the new page is opened in Editor pane automatically.

2. To open, delete or rename the new page, right-click the page icon and select the corresponding options depending on your need, for example, select Open, Delete or Rename option from the shortcut menu.

3. After editing the page, click the icon in standard toolbar (Page 13) or select File -> Save (Page 16) from the File menu to save the change.

The Properties for Pages:

- Basic
  - Name: Page
  - Resolution: you can modify the width and height information from the Size pane.

- Styles
  - Background Image: select the appropriate pictures for current page from Graph Library when you need or leave it empty for none.

Note

Graph Library is the LOGO! Web Editor build-in graphics library. It contains three parts: Build-In Graph, Color and My Graph. You can choose any of the graphic for the image by selecting the picture, and confirm the selection by clicking OK button. For detailed information, refer to the chapter Graph Library (Page 46).
2.5.2 Global Tags

Global Tag is the alias of LOGO! BM variable and it can be bound with some components, and Tag Table is a place to define Global Tags.

The Global Tags only contains one Tag Table, and the Tag Table cannot be deleted.

- Tag Table

Tag Table is a table with ID, Name, Block Type, Block Number and Access Mode information, and it is the place for storing the variable data information for your project.

Block number varies according to the corresponding block type. For the detailed information, refer to the following table.

<table>
<thead>
<tr>
<th>Block Type</th>
<th>Block Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>I1-I24</td>
</tr>
<tr>
<td>Q</td>
<td>Q1-Q20</td>
</tr>
<tr>
<td>M</td>
<td>M1-M64</td>
</tr>
<tr>
<td>AI</td>
<td>AI1-AI8</td>
</tr>
<tr>
<td>AQ</td>
<td>AQ1-AQ8</td>
</tr>
<tr>
<td>AM</td>
<td>AM1-AM64</td>
</tr>
<tr>
<td>V</td>
<td>V: 0-850, Bits: 0-7</td>
</tr>
<tr>
<td>VD</td>
<td>VD: 0-847</td>
</tr>
<tr>
<td>VW</td>
<td>VW: 0-849</td>
</tr>
<tr>
<td>Cursor Key</td>
<td>C1-C4</td>
</tr>
<tr>
<td>Function Key</td>
<td>F1-F4</td>
</tr>
<tr>
<td>Shift Register</td>
<td>S1.1-S1.8,S2.1-S2.8, S3.1-S3.8,S4.1-S4.8</td>
</tr>
</tbody>
</table>

Edit the Tag Table

When you create a new project (Page 51), the new project contains three parts: Pages, Global Tags and Navigator. The Tag Table appears under the Global Tags as a subpage in the Project tree automatically.

1. To open the Tag Table in the Editor pane:
   - Right-click the Tag Table icon and select Open button;
   - Or double-click the Tag Table icon.

2. To edit the Tag Table by clicking Add or Delete button to add or remove the variable, and do the following for each variable.
   - Define the alias name for the variable by double-clicking the Name column;
   - Select Block type from the drop-down menu, and select corresponding value for each Block type in Block Number.

3. After editing the Tag Table, click the Apply button or icon in standard toolbar (Page 13) or select File -> Save (Page 16) from the File menu to save the change.
2.5.3 Navigator

Navigator is a floating page of the web site and it is intended to aid users to switch among different web pages or log off during the runtime operation.

**Edit the Navigator**

When you create a new project (Page 51), a **Navigator** appears in the Project tree.

1. To open the Navigator in the Editor pane:
   - Right-click the Navigator icon and select **Open** button;
   - Or double-click the Navigator icon.
2. To edit the Navigator by dragging the Navigator Item component under the Navigation bar directly, and do the following in the Property pane:
   - Modify the font for the text in the navigator by selecting the value and clicking the **OK** button in **Font**;
   - Define the Navigator Item name by modifying the content in **Text**;
   - Link to each pages by selecting the pages which you have created from the drop-down menu.
3. After editing the Navigator, click the icon in standard toolbar (Page 13) or select **File -> Save** (Page 16) from the File menu to save the change.

**The Properties for Navigator Item:**

- **Basic**
  - Name: Navigator Item
  - Location: you can only check the location coordinate from the Location pane.
  - Size: you can only check the width and height information from the Size pane.

- **Styles**
  - Font: select **Font**, **Font Style** and **Size** depending on your need. Click the **OK** button for save the correction or click the **Reset to Default** button to reset to the default setting.

- **Values**
  - Text: Type the Navigator Item name for each page.
  - Link: select Home Page or other page name which you have created in the drop-down menu.

2.6 Components pane

In the Component pane, according to different functions, all the components can be classified to five segments: Tool, Basic, Digital, Analog and Miscellaneous.
You can configure the component based on your requirements.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Polyline (Page 30)</th>
<th>Rectangle (Page 31)</th>
<th>Circle (Page 32)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic</td>
<td>Text (Page 33)</td>
<td>Image (Page 35)</td>
<td>Link (Page 35)</td>
</tr>
<tr>
<td>Digital</td>
<td>Digital Value (Page 37)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Analog</td>
<td>Analog Value (Page 39)</td>
<td>Analog Bar (Page 40)</td>
<td>Analog Slider (Page 41)</td>
</tr>
<tr>
<td>Miscellaneous</td>
<td>Scale Time (Page 43)</td>
<td>LOGO! Clock (Page 44)</td>
<td></td>
</tr>
</tbody>
</table>

2.6.1 Tool

**Tool** is generally used for editing basic graphics.

**Tool** contains the following selections:

- Polyline (Page 30)
- Rectangle (Page 31)
- Circle (Page 32)

2.6.1.1 Polyline

Use the **Polyline** component when you want to draw one polyline.

**Draw the polylines**

1. Select the **Polyline** component.
2. Position the pointer where you want the line to begin in the Editor pane, drag to where you want the line to end by right-clicking the mouse or pressing **Esc** button. Each point you click appears a blue square.
3. Do one of the following:
   - To modify the track of the polyline, drag the blue square for the point.
   - To move the component, drag it without clicking the blue squares on the line.
   - To click the polyline, specify the weight and line style of the polyline in the Property pane. If you want to fill the polyline with the color, select **Color** swatches.
2.6 Components pane

The Properties for Polyline:

- **Basic**
  - Name: Polyline

- **Styles**
  - Weight: enter the width of the polyline.
  - Color: click color swatches, select a color swatch, and click **OK** button.
  - Dashed: select different polyline types Solid, Round Dot, Square Dot, Dash, Dash Dot, Long Dash, Long Dash Dot or Long Dash Dot Dot depending on your need.
  - Transparency: value ranges from 1 to 100, adjust the value depending on your need.

2.6.1.2 **Rectangle**

Use the **Rectangle** component when you want to draw a rectangle or a square.

**Draw rectangles and squares**

1. Select the **Rectangle** component.

2. Draw a rectangle or a square by dragging the **Rectangle** component directly where you want it to be in the Editor pane.

3. Do one of the following:
   - To adjust the rectangle or square's dimension, drag the blue square on the borderline until the rectangle or square is the desired size, or specify the value for **Location** and **Size** in the Property pane.
   - To move the component, drag it without clicking the blue squares on the borderline.
   - To select the rectangle or square, specify the **Border Width** and **Border Style** in the Property pane. If you want to fill border and background with the color, select color swatches separately.
The Properties for Rectangle:

- **Basic**
  - Name: Rectangle
  - Location: you can modify the location coordinate for the rectangle.
  - Size: you can modify the width and height information for the rectangle.

- **Styles**
  - Border Width: adjust the value depending on your need.
  - Border Style: select dotted, dashed, solid or double depending on your need.
  - Border Color: click Border Color swatches, select a swatch, and click OK button.
  - Background Color: click Background Color swatches, select a swatch, and click OK button.
  - Transparency: value ranges from 1 to 100, adjust the value depending on your need.
  - Fill: click the check box depending on whether to fill the rectangle with background color.

2.6.1.3 **Circle**

Use the Circle component when you want to draw a circle or an ellipse.

**Draw circles and ellipses**

1. Select the Circle component.
2. Draw a circle by dragging the Circle component directly where you want it to be in the Editor pane.
3. Do one of the following:
   - To adjust the circle dimension, drag the blue square on the borderline until the circle is the desired size, or specify the value for Location and Size in the Property pane.
   - To draw an ellipse, drag the circle component into the editor pane, and then drag the blue square on the borderline until the ellipse is the desired size, or specify the value for Location and Size in the Property pane.
   - To move the component, drag it without clicking the blue squares on the borderline.
   - To select the circle or ellipse, specify the Border Width and Border Style in the Property pane. If you want to fill border and background with the color, select color swatches separately.
The Properties for Circle:

- **Basic**
  - Name: Circle
  - Location: you can modify the location coordinate for the circle.
  - Size: you can modify the width and height information for the circle.

- **Styles**
  - Border Width: adjust the value depending on your need.
  - Border Style: select dotted, dashed, solid or double depending on your need.
  - Border Color: click Border Color swatches, select a swatch, and click OK button.
  - Background Color: click Background Color swatches, select a swatch, and click OK button.
  - Transparency: value ranges from 1 to 100, adjust the value depending on your need.
  - Fill: click the check box depending on whether to fill the circle with background color.

### 2.6.2 Basic

Basic is generally used for adding texts, images and links in your project.

**Basic** contains the following selections:

- Text (Page 33)
- Image (Page 35)
- Link (Page 35)

### 2.6.2.1 Text

Use the Text component when you want to add word description.

**Enter the text**

The text begins where you drag the Text component. When the text reaches a boundary, it automatically wraps to fit inside the defined area.

1. Select the Text component.
2. Drag the Text component directly where you want the line of text to be in the Editor pane.
3. Enter the text by double-clicking the text component to edit inline or changing the Text Value in the Property pane.
4. Press `esc` key or click other area to exit edit mode.

5. When you finish editing text,
   - modify the content by double-clicking the text component to edit inline or changing the **Text Value** in the Property pane;
   - adjust the text area by dragging the blue square on the border or modifying the value for **Size** in the Property pane;
   - move the text by dragging the component without clicking the blue squares on the borderline.

**The Properties for Text:**

- **Basic**
  - Name: Text
  - Location: you can modify the location coordinate for the text.
  - Size: you can modify the width and height information for the text.

- **Styles**
  - Font: select **Font**, **Font Style** and **Size** information separately in the Font pane. Click the **OK** button for save the correction or click the **Reset to Default** button to reset to the default setting.
  - Text Color: click **Text Color** Swatches, select a swatch, and click **OK** button.
  - Background Color: click **Background Color** swatches, select a swatch, and click **OK** button.
  - Fill: click the check box depending on whether to fill the text area with background color.

- **Values**
  - Text Value: type the content.
2.6.2.2 Image

Use the Image component when you want to add an image.

Create an Image
The image begins where you drag the Image component. Each image is independent.
1. Select the Image component.
2. Drag the Image component directly where you want the image to be in the Editor pane.
3. When you create an image,
   - adjust the image dimension by dragging the blue square on the border or modifying the value for Size in the Property pane;
   - edit the image in the Property pane by selecting the appropriate pictures for image in Graph Library;
   - move the component by dragging it without clicking the blue squares on the borderline.

The Properties for Image:
- Basic
  - Name: Image
  - Location: you can modify the location coordinate for the image.
  - Size: you can modify the width and height information for the image.
- Values
  - Image: select the appropriate pictures from Graph Library.

2.6.2.3 Link

Use the Link component when you want to add a Uniform Resource Locator (URL) link.

Create a link
The link begins where you drag the Link component. Each link is independent.
1. Select the Link component.
2. Drag the Link component directly where you want the line of link to be in the Editor pane.
3. When you edit the link,
   – double-click the link component to edit inline or change the **Text Value** in the Property pane;
   – enter the **Url** value in the Property pane.

4. After you create the link,
   – adjust the link dimension by dragging the blue square on the border or modifying the value for **Size** in the Property pane;
   – move the component by dragging it without clicking the blue squares on the borderline.

---

**Note**

If you enter more text than can fit within link area, the apostrophe (...) appears in the end of the link area. You should adjust the link area by dragging the blue square on the border or modifying the value for **Size** in the Property pane.

---

**The Properties for Link:**

- **Basic**
  - Name: Link
  - Location: you can modify the location coordinate for the link.
  - Size: you can modify the width and height information for the link.

- **Styles**
  - Font: select **Font**, **Font Style** and **Size** information separately in the Font pane. Click the **OK** button for save the correction or click the **Reset to Default** button to reset to the default setting.
  - Text Color: click **Text Color** Swatches, select a swatch, and click **OK** button.
  - Background Color: click **Background Color** swatches, select a swatch, and click **OK** button.
  - Fill: click the check box depending on whether to fill the link area with background color.

- **Values**
  - Text Value: Type the content for the link.
  - Url: Type the URL link.
2.6.3 Digital

**Digital Value** is used for presenting the digital value "0" and "1" visually.

**Digital Value** only contains one selection:
- Digital Value (Page 37)

2.6.3.1 Digital Value

Use the **Digital Value** component when you want to present the digital value "0" and "1" visually. "0" is for "off-state", and "1" is for "on-state".

**Create the digital value**
1. Select the **Digital Value** component.
2. Drag the **Digital Value** component directly where you want it to be in the Editor pane.
3. When you create a digital value,
   - adjust the dimension by dragging the blue square on the border or modifying the value for **Size** in the Property pane;
   - edit the digital value by selecting corresponding value for **Variable** and **Animation** in the Property pane;
   - move the component by dragging it without clicking the blue squares on the borderline.
User interface

2.6 Components pane

The Properties for Digital Value:

- **Basic**
  - Name: Digital Value
  - Location: you can modify the location coordinate for the digital value.
  - Size: you can modify the width and height information for the digital value.

- **Variable**
  - Variable Name: select the **Private Tag** or **Global Tag** depending on your need.
  - Variable Type: select **I, Q, M, V, Cursor Key, Function Key** or **Shift Register** for the type of variable.
  - Block Number: follow the below table to select each value.
  - Writable: click the check box depending on whether you have the write function. For the detailed information, refer to the following table.

<table>
<thead>
<tr>
<th>Block Type</th>
<th>Block Number</th>
<th>Writable</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>I1-I24</td>
<td>Read Only</td>
</tr>
<tr>
<td>Q</td>
<td>Q1-Q20</td>
<td>Read and Write</td>
</tr>
<tr>
<td>M</td>
<td>M1-M64</td>
<td>Read and Write</td>
</tr>
<tr>
<td>V</td>
<td>VB: 0-850</td>
<td>Read and Write</td>
</tr>
<tr>
<td></td>
<td>Bits: 0-7</td>
<td>Read and Write</td>
</tr>
<tr>
<td>Cursor Key</td>
<td>C1-C4</td>
<td>Read Only</td>
</tr>
<tr>
<td>Function Key</td>
<td>F1-F4</td>
<td>Read Only</td>
</tr>
<tr>
<td>Shift Register</td>
<td>S1.1-S1.8, S2.1-S2.8, S3.1-S3.8, S4.1-S4.8</td>
<td>Read Only</td>
</tr>
</tbody>
</table>

- **Animation**
  - On Image: select the appropriate pictures for on-state in **Graph Library**.
  - Off Image: select the appropriate pictures for off-state in **Graph Library**.
  - On Text: enter the display content for on-state.
  - Off Text: enter the display content for off-state.

2.6.4 Analog

**Analog Value** is used for editing analog variable visually.

**Analog Value** contains the following selections:

- Analog Value (Page 39)
- Analog Bar (Page 40)
- Analog Slider (Page 41)
2.6.4.1 Analog Value

Use the **Analog Value** component when you want to show the analog value.

**Create an analog value**
1. Select the **Analog Value** component.
2. Drag the **Analog Value** component directly where you want it to be in the Editor pane.
3. When you create the analog value,
   - adjust the dimension by dragging the blue square on the border or modifying the value for **Size** in the Property pane;
   - edit the analog value by selecting corresponding value for **Variable** in the Property pane.
   - move the component by dragging it without clicking the blue squares on the borderline.

**The Properties for Analog Value:**

- **Basic**
  - Name: Analog Value
  - Location: you can modify the location coordinate for the analog value.
  - Size: you can modify the width and height information for the analog value.

- **Variable**
  - Variable Name: select the **Private Tag** or **Global Tag** depending on your need.
  - Block Type: select **AI**, **AQ**, **AM**, **VB**, **VD** or **VW** for the type of variable.
  - Block Number: follow the below table to select each value.
  - Block Format: select **Hex**, **Binary**, **Signed** or **Unsigned** for display format.
  - Unit: select appropriate units.
  - Writable: click the check box depending on whether you have the write function. For the detailed information, refer to the following table.

<table>
<thead>
<tr>
<th>Block Type</th>
<th>Block Number</th>
<th>Writable</th>
</tr>
</thead>
<tbody>
<tr>
<td>AI</td>
<td>AI1-AI16</td>
<td>Read Only</td>
</tr>
<tr>
<td>AQ</td>
<td>AQ1-AQ16</td>
<td>Read and Write</td>
</tr>
<tr>
<td>AM</td>
<td>AM1-AM64</td>
<td>Read and Write</td>
</tr>
<tr>
<td>VB</td>
<td>0-850</td>
<td>Read and Write</td>
</tr>
<tr>
<td>VD</td>
<td>0-847</td>
<td>Read and Write</td>
</tr>
<tr>
<td>VW</td>
<td>0-849</td>
<td>Read and Write</td>
</tr>
</tbody>
</table>
### 2.6.4.2 Analog Bar

Use the **Analog Bar** component when you want to create an analog bar to show the dynamic variable.

#### Create an analog bar

1. Select the **Analog Bar** component.
2. Drag the **Analog Bar** component directly where you want it to be in the Editor pane.
3. When you create an analog bar,
   - adjust the dimension by dragging the blue square on the border or modifying the value for **Size** in the Property pane;
   - edit the analog bar value by selecting corresponding value for **Variable** and **Animation** in the Property pane;
   - move the component by dragging it without clicking the blue squares on the borderline.

#### The Properties for Analog Bar:

- **Basic**
  - Name: Analog Bar
  - Location: you can modify the location coordinate for the analog bar.
  - Size: you can modify the width and height information for the analog bar.

- **Variable**
  - Variable Name: select the **Private Tag** or **Global Tag** depending on your need.
  - Block Type: select **AI, AQ, AM, VB, VD** or **VW** for the type of variable.
  - Block Number: select each value according to the below table.

<table>
<thead>
<tr>
<th>Block Type</th>
<th>Block Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>AI</td>
<td>AI1-AI16</td>
</tr>
<tr>
<td>AQ</td>
<td>AQ1-AQ16</td>
</tr>
<tr>
<td>AM</td>
<td>AM1-AM64</td>
</tr>
<tr>
<td>VB</td>
<td>0-850</td>
</tr>
<tr>
<td>VD</td>
<td>0-847</td>
</tr>
<tr>
<td>VW</td>
<td>0-849</td>
</tr>
</tbody>
</table>

- **Animation**
  - Max. Value: set the maximum value for the analog bar depending on your need.
  - Min. Value: set the minimum value for the analog bar depending on your need.
  - Scale: set the scale for the analog bar depending on your need.
  - Color: click **Color Setting** swatches, according to different ranges, select a corresponding color swatch, and click **OK** button.
2.6.4.3 Analog Slider

Use the Analog Slider component when you want to create an analog slider to show the slider variable.

Create an analog slider

1. Select the Analog Slider component.
2. Drag the Analog Slider component directly where you want it to be in the Editor pane.
3. When you create an analog slider,
   - adjust the dimension by dragging the blue square on the border or modifying the value for Size in the Property pane;
   - edit the analog slider value by selecting corresponding value for Variable and Animation in the Property pane;
   - move the component by dragging it without clicking the blue squares on the borderline.
The Properties for Analog Slider:

- **Basic**
  - Name: Analog Slider
  - Location: you can modify the location coordinate for the analog slider.
  - Size: you can modify the width and height information for the analog slider.

- **Variable**
  - Variable Name: select the [Private Tag](#) or [Global Tag](#) depending on your need.
  - Block Type: select **AI**, **AQ**, **AM**, **VB**, **VD** or **VW** for the type of variable.
  - Block Number: follow the below table to select each value.
  - Writable: click the check box depending on whether you have the write function. For the detailed information, refer to the following table.

<table>
<thead>
<tr>
<th>Block Type</th>
<th>Block Number</th>
<th>Writable</th>
</tr>
</thead>
<tbody>
<tr>
<td>AI</td>
<td>AI1-AI16</td>
<td>Read Only</td>
</tr>
<tr>
<td>AQ</td>
<td>AQ1-AQ16</td>
<td>Read and Write</td>
</tr>
<tr>
<td>AM</td>
<td>AM1-AM64</td>
<td>Read and Write</td>
</tr>
<tr>
<td>VB</td>
<td>0-850</td>
<td>Read and Write</td>
</tr>
<tr>
<td>VD</td>
<td>0-847</td>
<td>Read and Write</td>
</tr>
<tr>
<td>VW</td>
<td>0-849</td>
<td>Read and Write</td>
</tr>
</tbody>
</table>

- **Animation**
  - Max. Value: set the maximum value for the Analog Slider depending on your need.
  - Min. Value: set the minimum value for the Analog Slider depending on your need.
  - Background Image: select the appropriate picture from [Graph Library](#).
  - Thumb Image: select the appropriate picture from [Graph Library](#).
2.6.5 Miscellaneous

Miscellaneous is used for other functions.

Miscellaneous contains two selections:
- Scale Time [Page 43]
- LOGO! Clock [Page 44]

2.6.5.1 Scale Time

Use the Scale Time component when you want to display a time value.

Scale time is the actual value of a referenced function block which is displayed as a time value. Possible time display formats show as below:
- hours : minutes : seconds . milliseconds
- hours : minutes : seconds
- hours : minutes
- hours

Create a scale time
1. Select the Scale Time component.
2. Drag the Scale Time component directly where you want it to be in the Editor pane.
3. When you create a scale time,
   - adjust the dimension by dragging the blue square on the border or modifying the value for Size in the Property pane;
   - edit the scale time value by selecting corresponding value for Variable in the Property pane;
   - move the component by dragging it without clicking the blue squares on the borderline.
The Properties for Scale Time:

- **Basic**
  - Name: Scale Time
  - Location: you can modify the location coordinate for the scale time.
  - Size: you can modify the width and height information for the scale time.

- **Variable**
  - Variable Name: select the Private Tag or Global Tag depending on your need.
  - Block Type: select AI, AQ, AM, VB, VD or VW for the type of variable.
  - Block Number: following the below table to select each value.
  - Time Unit: select Hours(h), Minutes(m), Seconds(s) or 10Milliseconds(ms) unit depending on your need.
  - Writable: click the checkbox depending on whether you have the write function. For the detailed information, refer to the following table.

<table>
<thead>
<tr>
<th>Block Type</th>
<th>Block Number</th>
<th>Writable</th>
</tr>
</thead>
<tbody>
<tr>
<td>AI</td>
<td>AI1-AI16</td>
<td>Read Only</td>
</tr>
<tr>
<td>AQ</td>
<td>AQ1-AQ16</td>
<td>Read and Write</td>
</tr>
<tr>
<td>AM</td>
<td>AM1-AM64</td>
<td>Read and Write</td>
</tr>
<tr>
<td>VB</td>
<td>0-850</td>
<td>Read and Write</td>
</tr>
<tr>
<td>VD</td>
<td>0-847</td>
<td>Read and Write</td>
</tr>
<tr>
<td>VW</td>
<td>0-849</td>
<td>Read and Write</td>
</tr>
</tbody>
</table>

**2.6.5.2 LOGO! Clock**

Use the LOGO! Clock component to show the date and time information from LOGO! Base modular.

Create a LOGO! Clock

You can only read the date and time information from LOGO! Base modular.

1. Select the LOGO! Clock component.
2. Drag the LOGO! Clock component directly where you want it to be in the Editor pane.
3. After you create a LOGO! Clock,
   - adjust the LOGO! Clock dimension by dragging the blue square on the border or modifying the value for Size in the Property pane;
   - modify font, text color and background color for the text display in the Property pane;
   - move the component by dragging it without clicking the blue squares on the borderline.
The Properties for LOGO! Clock:

- **Basic**
  - Name: LOGO! Clock
  - Location: you can modify the location coordinate for the text.
  - Size: you can modify the width and height information for the text.

- **Styles**
  - Font: select **Font**, **Font Style** and **Size** information separately in the Font pane. Click the **OK** button for save the correction or click the **Reset to Default** button to reset to the default setting.
  - Text Color: click **Text Color** Swatches, select a swatch, and click **OK** button.
  - Background Color: click **Background Color** swatches, select a swatch, and click **OK** button.
  - Fill: click the check box depending on whether to fill the text area with background color.

### 2.7 Editor pane

The Editor pane is the working space for the project and it is shown in the middle of the window. It displays the opened pages, tag table and navigator for the project. You can switch to different windows for **Home Page**, **Page**, **Tag Table** or **Navigator** by double-clicking them from the Project tree.

In order to help you maintain an overview of a complete project, the right side and the bottom of the Editor pane contain scroll bars, which you can use for vertical and horizontal scrolling of the project editing.

When you edit components in the Editor pane, you can refer to How to edit component through the shortcut menu (Page 70).

### 2.8 Properties pane

The Property pane shows the property description of selected component, page or Navigator in the project. You can check the detailed property information by clicking them in the Editor pane and editing them in the Property pane.
For detailed information on property for each component, refer to the following table:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic</td>
<td></td>
</tr>
<tr>
<td>Polyline</td>
<td>30</td>
</tr>
<tr>
<td>Rectangle</td>
<td>31</td>
</tr>
<tr>
<td>Circle</td>
<td>32</td>
</tr>
<tr>
<td>Basic</td>
<td></td>
</tr>
<tr>
<td>Text</td>
<td>33</td>
</tr>
<tr>
<td>Image</td>
<td>35</td>
</tr>
<tr>
<td>Link</td>
<td>35</td>
</tr>
<tr>
<td>Digital</td>
<td></td>
</tr>
<tr>
<td>Digital Value</td>
<td>37</td>
</tr>
<tr>
<td>Analog</td>
<td></td>
</tr>
<tr>
<td>Analog Value</td>
<td>39</td>
</tr>
<tr>
<td>Analog Bar</td>
<td>40</td>
</tr>
<tr>
<td>Analog Slider</td>
<td>41</td>
</tr>
<tr>
<td>Miscellaneous</td>
<td></td>
</tr>
<tr>
<td>Scale Time</td>
<td>43</td>
</tr>
<tr>
<td>LOGO! Clock</td>
<td>44</td>
</tr>
<tr>
<td>Project tree</td>
<td></td>
</tr>
<tr>
<td>Pages</td>
<td>26</td>
</tr>
<tr>
<td>Navigator</td>
<td>29</td>
</tr>
</tbody>
</table>

**2.9 Graph Library**

Graph Library is the LOGO! Web Editor build-in graphics library. You can select graphics for the following three components in Property pane.

- Page: the selection for **Background Image**;
- Image: the selection for **Image**;
- Digital Value: the selections for **On Image** and **Off Image**;
- Analog Slider: the selections for **Background Image** and **Thumb Image**.

Graph Library contains three parts:

- Build-In Graph (Page 47)
- Colors (Page 48)
- My Graph (Page 49)
2.9.1 Build-In Graph

In the Build-In Graph folder, each subfolder contains different kinds of graphics. For example, Animation, Automation, Basins and so on. Once you click the subfolder, graphics in this subfolder show on the right side of the dialog box.
In the Build-In Graph folder, you can do the following:

- To select the appropriate image, click the image and confirm the selection by clicking **OK** button.
- To search for any kinds of image, enter keywords in the entry field and click **Search** button or press the **enter** key, and then the result shows on the right side of the dialog box.

### Note

For using the search function,

- the search scope is only available for current selected folder.
- only list the images whose name contains the keywords.

- To copy the selected image to My Graph folder or customized folder, right-click the image and select **Copy To**, then the color image appears in My Graph folder or customized folder.

---

### 2.9.2 Colors

There are different kinds of colors in the Color folder.

In the Color folder, you can do the following:

- To select the appropriate color image, click the image and confirm the selection by clicking **OK** button.
- To search for any kinds of the colors, enter keywords in the entry field and click **Search** button or press the **enter** key, and then the result shows on the right side of the dialog box.
- To copy the selected image to My Graph folder or customized folder, right-click the image and select **Copy To**, and then the color image appears in My Graph folder or customized folder.
2.9.3 My Graph

My Graph folder is used for creating customized folder. You can import images from local disk to both My Graph folder and customized folder.

In My Graph folder, you can do the following:

- To create customized folder, right-click My Graph folder and select **New Folder**, and then a New Folder appears under the My Graph folder.

Note
The maximum number of supported customized folder is 20.

- To rename the customized folder,
  - right-click the customized folder and select **Rename**;
  - then the name of the customized folder change to editable state, enter the new name;
  - save the change by pressing the **enter** key.

- To delete the customized folder, right-click the customized folder and select **Delete**, and then the customized folder is removed from the My Graph folder.

In My Graph folder or customized folder, you can do the following:

- To Import image from local disk,
  - point to My Graph folder or the customized folder;
  - click **Upload Files** button to find the directory of the image in your local disk;
  - click **Open** button to upload the image;
  - then the image appears on the right side of the dialog box.

Note
- The supported image file formats are as follows: PNG, JPG/JPEG, GIF, TIF/TIFF.
- As for the image with GIF format, if the image size is bigger than 1 MB, it cannot be dynamic previewed in Graph Library.
- It will take few minutes to upload high resolution images.

- To copy the selected image, right-click the image and select **Copy To** in shortcut menu, and then the image appears in My Graph folder or customized folder.
To move the selected image, right-click the image and select **Move To** in shortcut menu, and then the image move to My Graph folder or customized folder.

To delete the selected image, right-click the image and select **Delete** in shortcut menu, and then the image is removed from My Graph folder or customized folder.
3.1 Prerequisites for working with the tutorial

To use this tutorial, you must be familiar with PC operation and you must know how to create a project. To download your project, you also need a PC cable, SD card or Ethernet cable for connecting the PC interface to your LOGO! device.

3.2 Getting started with project creation

3.2.1 Creating a new Project

After you have installed LOGO! Web Editor tool, you can start to create a new project.

To create a new project, click the **File → New Project** or click the **New Project** button in the standard toolbar.

Then a new project contains **Pages**, **Global Tags** and **Navigator** appears in the **Project tree** automatically.

You can work with LOGO! BM to upload (Page 21) or download (Page 19) the project, customize the web pages in the **Editor pane** (Page 45), combine the different components from the **Component pane** (Page 29), modify the component properties from **Properties pane** (Page 45), and visit the whole project through Web Server of the LOGO! Base Module.

---

**Note**

When you create another new project, after you click the **Finish** button to save the setting for **Name and Location**, the current project will be closed. If you haven't saved the current project, LOGO! Web Editor prompts you to save it.
3.2.2 Visiting the project through web page

After you deploy the whole project, you can visit it through the web page.

1. Open the web browser and enter the valid IP address of LOGO! Base Module.
2. Then the Log on page appears.

3. Enter the **Password** for LOGO! Base Module.
4. Make sure that to select the check box before "to customized site" and click **Log on** button.

   Then you can view the project in your web browser.

**Note**

If you download the modified project to LOGO! BM, you’d better log in to the corresponding web page again to insure the correction works.
3.3 Practical example

3.3.1 Introduction for practical example

This practical sample is applicable to swimming pool level control and light control systems, and offer new users a step-by-step introduction. You learn here how to create a whole project and the project contains creation procedures for Pages (Page 53), Global Tags (Page 55) and Navigator (Page 56).

For the detailed configuration information of special components, refer to The example for configuring special components (Page 57) chapter.

3.3.2 The example for Pages

In this swimming pool project, there are two pages:

- Home page is the swimming pool level control system and the page name cannot be changed;
- Light control page is the swimming pool light control system and the page name can be renamed.

Home Page for Swimming Pool Level Control

The swimming pool level control system contains four parts:

- Tank
  - It is used for water storage.
  - The block contains Image and Analog Bar components.
- Water valve A
  - It is used for connecting tank and swimming pool to control the swimming pool level.
  - It has two modes: Auto and Manual operation. And both of the two modes have two corresponding status: Open or Close.
  - The block contains Text, Rectangle and Digital Value components.
- Swimming pool
  - It is used for swimming and it use the water-level sensor to monitor the actual water level.
  - The block contains Rectangle and Analog Bar components.
- Water valve B
  - It is used for connecting swimming pool and other pipelines.
  - It has two modes: Auto and Manual operation. And both of the two modes have two corresponding status: Open or Close.
  - The block contains Text, Rectangle and Digital Value components.
Page for Swimming Pool Light Control

The swimming pool light control system contains two parts:

- The lamp and LED control
  - It is used for controlling the lights and recording the running time.
  - The block contains Text, Rectangle, Scale Time and Digital Value components.
- Schedule for weekday and weekend
  - It is used for controlling the lighting time.
  - The block contains Text, Rectangle, Scale Time and Analog Value components.
3.3.3 The example for Tag Table

In this swimming pool level control and light control system, you can define both digital value and analog value in the Tag Table. Here is an example for eight kinds of variables:

- The Inlet for Water valve A under the manual mode
- The Outlet for Water valve A under the manual mode
- Level Control for Swimming pool
- Level control for Tank
- Light control for Lamp
- Light control for LED
- Schedule control for Weekday
- Schedule control for Weekend

The variable in Tag table can customize the alias name and it can be bound with some components. Below is just an example screenshot.
3.3.4 The example for Navigator

In this swimming pool level control and light control system, the Navigation bar contains three options: link to Home Page (renamed to Level Control), link to Light Control page and link for LOG OFF button.

After editing the Navigator (Page 29), the navigation bar allows you to switch between different web pages or log off the project.

Below is just an example screenshot.
3.3.5 The example for configuring special components

There are more than eleven components in the Component pane. In this swimming pool level control and light control system, each block combines with several components.

For detailed configuration for each component, refer to the section Component pane (Page 29).

Configuration for Analog Bar

In this example, the tank is used for water storage. When the swimming pool water level under the target waterline, the system will give an alarm to the user. The user needs to open the Water valve A manually to inject water from the tank. For the tank block, it contains Image and Analog Bar components.

Below is just an example screenshot for configuring Analog Bar.
3.3 Practical example

Configuration for Digital Value

In this example, Water valve A is used for connecting tank and swimming pool to control the swimming pool level. When the swimming pool water level under the target waterline, the system will give an alarm to the user. The user needs to open the Water valve A to inject water from the tank manually. For the Water valve A block, it contains Text, Rectangle and Digital Value components.

Below is just an example screenshot for configuring Digital Value.

Configuration for Analog Value

In this example, swimming pool use the water-level sensor to monitor the actual water level. When the swimming pool water level under the target waterline, the system will give an alarm to the user. This water lever monitor panel also can show the total time and time remain for injecting water. For this panel, it contains Text, Rectangle and Analog Value components.

Below is just an example screenshot for configuring Analog Value.
Configuration for Analog Slider

In this example, these two sliders are representing target waterline and time remain for injecting water. For these sliders, they contain **Text**, **Rectangle** and **Analog Slider** components.

Below is just an example screenshot for configuring **Analog Slider**.
3.3.6 Visiting the example project through web page

After you finish the creating a whole project, you can visit this example project through the web page.

Follow the chapter Visiting the project through web page (Page 52) to open the project, the below is just an example screenshot for visiting the example project through web page.

For more information, refer to ...Tools\LOGO! Web Editor Tool\Sample folder in the DVD ROM.
Professional clients can modify the project created by LWE to meet their specific requirements on webpage. After you bind the HTML element to a BM data, you can monitor the BM data through webpage.

Working principle

In `DBinit()`, LOGO! JavaScript scans all HTML elements and transfer data with those having `server_binding` class.

In the `server_binding` element, we use `range`, `address`, `type`, `length` to define and bind a data from BM.

Through `show_function` and `show_param`, you can implement a callback method to meet their requirements based on the data refresh.

Follow the below rules when you update the project by the interface. Otherwise, it cannot work with BM correctly.

- Except for htm files, do not delete, move or modify other files.
- You can add, modify or delete the htm files in LOGO! Web Editor project folder:
  - Do not delete main.htm.
  - You can only modify the part of a htm file between `<div id="main">` and `</div>`.
  - Keep the name of a htm file within 11 characters (a maximum of 8 characters for base file name and 3 characters for the extension)
- Save the modified projects to webroot of SD card.

4.1 LOGO! data access protocol

For the use of this interface, your pages should include all the following JavaScript:

```html
<script type="text/javascript" src="/js/utility.js"></script>
<script type="text/javascript" src="/js/storage.js"></script>
<script type="text/javascript" src="/js/bigint.js"></script>
<script type="text/javascript" src="/js/encrypt.js"></script>
<script type="text/javascript" src="/js/ajax.js"></script>
```
Note
You should call the function `DBInit()` in the page initializing routine, which initializes the data binding environments. Otherwise, the refresh framework cannot work.

4.1.1 Operation

Define a server_binding element

Define a server_binding class as below.

```html
<div comp_type="myDigitalComponent" class="server_binding" id="mydiv" show_param="mydiv" show_function="myCallback" range="132" address="0" type="1" length="1" text
</div>
```

- **id**: the unique identifier of an element
- **class=server_binding**: scan identifier for JavaScript framework
- **range**: the first part of the address
- **address**: as the third part of the actual address, `address` means the data offset from the `range` start.
- **type**: data type
- **length**: data counts with its type.
- **show_function**: define the function that is used to show the data. This function is a "callback" function. Framework call the callback function when the binding data is refreshed.
- **show_param**: parameter for the callback function.

For more information on the parameters, see [Data format](Page 65).

Note
Ensure all the parameters are included when you define the server_binding element. Otherwise, the data cannot be bound.
4.1.1.1 Command

This chapter introduces some commands related to LOGO! data access protocol.

Get

To get the data in your webpage, you need to do the following two steps. LOGO!’s JavaScript framework call the callback function when BM data updates.

1. Create a server_binding element according to the instruction in Operation (Page 62).
2. Implement the declared callback function.

See an example as below:

```javascript
var myCallback = function myCallback() {
  //get new value
  var newValue = parseInt(this.m_sValue, 16);
  //do your actions...
  $('#xxx').html(newValue);
};
```

When the callback function is called, the JavaScript framework receives a parameter DBRequest. By this parameter, you can get the server_binding element related information and the updated data as follow.

<table>
<thead>
<tr>
<th>Property</th>
<th>Parameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>DBRequest.m_nAddress</td>
<td>address</td>
</tr>
<tr>
<td>DBRequest.m_nLength</td>
<td>length</td>
</tr>
<tr>
<td>DBRequest.m_nRange</td>
<td>range</td>
</tr>
<tr>
<td>DBRequest.m_nType</td>
<td>type</td>
</tr>
<tr>
<td>DBRequest.m_oSrcElement</td>
<td>server_binding element</td>
</tr>
<tr>
<td>DBRequest.m_sShowParam</td>
<td>show_param</td>
</tr>
<tr>
<td>DBRequest.m_sValue</td>
<td>value</td>
</tr>
</tbody>
</table>

Set

You need to write your own JavaScript code to implement a set query for a server_binding element,

1. Create a DBRequest object for the server_binding element.
2. Assign a value to DBRequest by SetValue method.
4. Check the m_iSetPendingFlag member to make sure the SetQuery is complete. The true value means SetQuery is pending while the false value means SetQuery is completed.

You can refer to the example below.

```javascript
function DBRequestTest () {
  var oRequest = new DBRequest(document.getElementById("test1"));
  oRequest.SetValue("00012345");
  if(oRequest.SetQuery())
```
while(oRequest.m_iSetPendingFlag)
{
    //wait for a while or give customer some hint.
}
//done:
return true;
}
//fail:
return false;
}

You can also set value for a set of sever_binding elements group. DBGroup object is used for collecting the DBRequest objects in this scenario:

1. Prepare a set of DBRequest objects by the upper description.
2. Create a DBGroup object. Collect the DBRequest objects by Add method.
4. Check the m_iSetPendingFlag member to make sure the SetQuery is complete. The ture value means SetQuery is pending while the false value means SetQuery is completed.

You can refer to the example below.
function DBGroupTest() {
    var oRequest1 = new DBRequest(document.getElementById("test1"));
oRequest1.SetValue(\"00012345\") ;
    var oRequest2 = new DBRequest(document.getElementById("test2"));
oRequest2.SetValue(\"0x01\") ;
    var oGroup = new DBGroup();
oGroup.Add(oRequest1);
oGroup.Add(oRequest2);
if(oGroup.SetQuery())
{
    while(oGroup.m_iSetPendingFlag)
    {
        //wait for a while or give customer some hint.
    }
    //done:
    return true;
}
}
//fail:
    return false;
}

**Note**
You should call the function `DBInit()` in the page initializing routine, which initializes the data binding environments. Otherwise, the refresh framework cannot work.

### 4.1.1.2 Data format

We use `range, sub_range, address, type, length` to describe a data.

The `range, sub_range, address` indicate the address of the data. The `length` of a date indicates its type. For detailed information, refer to the following table.

<table>
<thead>
<tr>
<th>Address Name</th>
<th>range</th>
<th>sub_range</th>
<th>address</th>
<th>length</th>
<th>Recommended Access Mode</th>
<th>Readable/Writable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Digital Input</td>
<td>129</td>
<td>0</td>
<td>0-63</td>
<td>64</td>
<td>Bits</td>
<td>R</td>
</tr>
<tr>
<td>Digital output</td>
<td>130</td>
<td>0</td>
<td>0-63</td>
<td>64</td>
<td>Bits</td>
<td>R/W</td>
</tr>
<tr>
<td>Digital Marker</td>
<td>131</td>
<td>0</td>
<td>0-111</td>
<td>112</td>
<td>Bits</td>
<td>R/W</td>
</tr>
<tr>
<td>Variable</td>
<td>132</td>
<td>0</td>
<td>0-6799</td>
<td>6800</td>
<td>Bits, Bytes, Words, Dwords</td>
<td>R/W</td>
</tr>
<tr>
<td>Cursor Key</td>
<td>12</td>
<td>0</td>
<td>0-31</td>
<td>32</td>
<td>Bits</td>
<td>R/W</td>
</tr>
<tr>
<td>TDE Function Key</td>
<td>13</td>
<td>0</td>
<td>0-31</td>
<td>32</td>
<td>Bits</td>
<td>R/W</td>
</tr>
<tr>
<td>Shift Register</td>
<td>14</td>
<td>0</td>
<td>0-127</td>
<td>128</td>
<td>Bits</td>
<td>R</td>
</tr>
<tr>
<td>NetI</td>
<td>16</td>
<td>0</td>
<td>0-127</td>
<td>128</td>
<td>Bits</td>
<td>R</td>
</tr>
<tr>
<td>NetQ</td>
<td>17</td>
<td>0</td>
<td>0-127</td>
<td>128</td>
<td>Bits</td>
<td>R/W</td>
</tr>
<tr>
<td>Analog Input</td>
<td>18</td>
<td>0</td>
<td>0-239</td>
<td>240</td>
<td>Words</td>
<td>R</td>
</tr>
<tr>
<td>Analog Output</td>
<td>19</td>
<td>0</td>
<td>0-239</td>
<td>240</td>
<td>Words</td>
<td>R/W</td>
</tr>
<tr>
<td>Analog Marker</td>
<td>20</td>
<td>0</td>
<td>0-1023</td>
<td>1024</td>
<td>Words</td>
<td>R/W</td>
</tr>
<tr>
<td>NetAI</td>
<td>21</td>
<td>0</td>
<td>0-1023</td>
<td>1024</td>
<td>Words</td>
<td>R</td>
</tr>
<tr>
<td>NetAQ</td>
<td>22</td>
<td>0</td>
<td>0-511</td>
<td>512</td>
<td>Words</td>
<td>R/W</td>
</tr>
</tbody>
</table>

**range**

It is the first part of the address.
4.1 LOGO! data access protocol

sub-range

It is the second part of the address and reserved for future function extension. The default value is 0.

address

As the third part of the address, it means the data offset from the range start.

Note

Ensure that you provide the offset-address by bits no matter what data type you are accessing.

All the address will be validated before access. LOGO! reports an error for an invalid address and truncate the address which is out of range.

type

It means data type. LOGO! has four kinds of data.

<table>
<thead>
<tr>
<th>Id</th>
<th>type</th>
<th>length</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>BOOL</td>
<td>1 bit</td>
</tr>
<tr>
<td>2</td>
<td>BYTE</td>
<td>8 bits</td>
</tr>
<tr>
<td>4</td>
<td>WORD</td>
<td>16 bits</td>
</tr>
<tr>
<td>6</td>
<td>DWORD</td>
<td>32 bits</td>
</tr>
</tbody>
</table>

length

It means the data count with its type.

value

All data value is presented by a HEX string. You can convert it into other type for your customer, but you must convert it back to HEX array mode before you set it to server. For example, as for data with type DWORD, its value is 0x12345, you will get the string “00012345” from server, and if you want to change it to 0x12346, you also should use string “00012346”.

4.2 Example

Below is an example of digital component.

```html
<BODY onload="loadPage()">
  <DIV id="wrap">
    <div id="main" onclick="hideMenu()" style="width: 1420px; height: 880px;">
      <div comp_type="myDigitalComponent" class="server_binding" id="mydiv"
        show_param="mydiv" show_function="myCallback"
        range="132" address="0" type="1" length="1"
        onclick="sendDigitalRequest(this)" value="0"
        style="position:absolute; left:389px; top:242px; width:84px;
                height:84px; border:1px solid red;line-height: 84px;">
        OFF
      </div>
    </div>
  </DIV>
</BODY>
```

```javascript
var myCallback = function myCallback() {
  var id = this.m_sShowParam; // get id
  var newValue = parseInt(this.m_sValue, 16); // get newValue
  document.getElementById(id).value = newValue; // recode the newValue

  // response
  if (newValue == 0) {
    $("#"+id).html("ON"); // do your actions
  } else {
    $("#"+id).html("OFF"); // do your actions
  }

  function sendDigitalRequest(obj) {
    var id = obj.id;
    var oRequest = new DBRequest(obj);
    // set value
    if (obj.value) {
      oRequest.SetValue("00");
    } else {
      oRequest.SetValue("01");
    }
    // send request
    if (oRequest.SetQuery()) {
```

LOGO! Web Editor Online Help
Operating Instructions, 03/2019, A5E42880034 - AB
4.2 Example

```javascript
setInterval(checkResult, 1000, oRequest);
}
</script>
</div>
</DIV>
</BODY>

Specification

1. All your custom codes have to be added between `<div id="main">` and `</div>`.

2. The following four parameters define the LOGO! data access and callback JavaScript function:
   - `class="server_binding"` : LOGO! JavaScript will scan all the DIVs and transfer data with those DIV having `server_binding` class.
   - `id="mydiv"` : You should assign `id` and `show_param` with the same DIV.
   - `show_param="mydiv"` : You should assign `id` and `show_param` with the same DIV.
   - `show_function="myCallback"` : You need to implement a callback JavaScript function and assign its name to `show_function`.

3. The following four parameters describe the data:
   - `range="132"` : V
   - `address="0":0.0`
   - `type="1":BOOL`
   - `length="1":1`
   
   For detailed information, see [Data format](Page 65)

4. The following two parameters are used to submit requests to server.
   - "setDigitalData(obj)" : it's a customized method, used to submit requests to server.
   - "value" : used to recode the current data value and could be submitted by "setDigitalData(obj)".
5.1 How to display a corresponding tooltip for a function key

In LOGO! Web Editor, you can display a corresponding tooltips both in Standard toolbar and Graphic Library.

**Tooltips for Standard toolbar**

In the Standard toolbar, you can use the mouse-over-button function to display the icon name, which represents the tooltip. This helps you quickly recall the function of the icon, without having to call the menu or the help.

Below is an example screenshot.

**Tooltips for images in Graphic Library**

In Graphic Library, you can also use the mouse-over-button function on each image to display the File Name, Item Type, Dimensions and Size information which represents the tooltip.

Below is an example screenshot.
5.2 How to draw a polyline well

When you activate the Polyline component, you can draw the polyline start from left-clicking mouse button and end with right-clicking mouse button.

Every point you click appears a blue square, and a blue arrow goes with your mouse. When you finish drawing for the polyline, you’d better move your mouse away from the blue square and do the right-click, or else the shortcut menu for right-click function will be popped up.

5.3 How to edit component through the shortcut menu

Right-click the component to open a shortcut menu that offers you the following functions for editing the component:

- Copy (Page 19)
- Paste (Page 19)
- Delete (Page 19)
- Bring To Front (Page 18)
- Send To Back (Page 18)
- Left Rotate (Page 18)
- Right Rotate (Page 18)
5.4 How to import multiple images

Import multiple images in Graphic Library

1. Point to My Graph folder or the customized folder where you want to attach the images.
2. Click **Upload Files** button to find the directory of the image in your local disk;
3. Choose the images you want to upload. You can upload multiple images in two ways:
   - To choose a list of sequential images, click the first file you want to upload, hold the **Shift** key on the keyboard and click the last file you want.
   - To choose non-sequential images, click the first file you want to upload, hold the **Ctrl** key on the keyboard and click any further files you want to upload.
   - To choose all the images, hold the **[Ctrl]+A** key on the keyboard.
4. Click **Open** button to upload the images;
5. Once uploaded you will see the uploaded images appear on the right side of the dialog box.

5.5 How to add a link connecting to another page

To add a link connecting to another page in your project, you need to add these parameters after your URL:

```javascript
window.location.replace(link + "?!App-Language=" + LocalStorage.Instance().Get("logo_current_language") + "&Security-Hint=" + LocalStorage.Instance().Get("logo_current_login_ref"));
```

**Example:**

```javascript
window.location.replace(link + "?!App-Language=" + LocalStorage.Instance().Get("logo_current_language") + "&Security-Hint=" + LocalStorage.Instance().Get("logo_current_login_ref"));
```
Tips and tricks

5.5 How to add a link connecting to another page
Index

A
A new project
   Creating, 51

B
Bring to front, 18

C
Component pane, 30
   Analog Bar, 40
   Analog Slider, 41
   Analog Value, 38, 39
   Basic, 33
   Circle, 32
   Digital Value, 37, 37
   Image, 35
   Link, 35
   Miscellaneous, 43
   Polyline, 30
   Rectangle, 31
   Scale Time, 43
   Tool, 30
Component pane
   LOGO! Clock, 44
   Text, 33
Copy, 19

D
Delete, 19
Document History, 7
Download, 19

E
Edit menu, 17
   Bring to front, 18
   Copy, 19
   Delete, 19
   Left Rotate, 18
   Paste, 19
   Redo, 18
   Right Rotate, 18
   Select All, 18
   Send to back, 18
   Undo, 18
   Editor pane, 45

F
File menu, 14, 15
   Close Project, 16
   Exit, 17
   New Project, 14
   Save, 16
   Save All, 16
   Save As, 16
   Function key, 12

H
Help menu, 25
   About, 26
   Help Contents, 25
   Start Page, 25

L
Left Rotate, 18
LOGO! Web Editor, 7

M
Menu bar, 12

O
Open Project, 15

P
Paste, 19
Practical example, 60
   configure special components, 57
   Introduction, 53
   Navigator, 56
Index

Pages, 53
Tag Table, 55
Prerequisites for working with the tutorial, 51
Project tree, 26
Properties pane, 46

R
Redo, 18
Right Rotate, 18

S
Send to back, 18
Shortcuts, 12
Standard toolbar, 12

T
Tool menu
  Deploy To SD Card, 22
  Download, 19
  Options, 22
  Upload, 21
  Toolbar, 13
  Tools menu, 19

U
Undo, 18
Upload, 21
User interface, 11

V
Visiting the example project, 60

W
Window menu, 23
  Component, 24
  Project, 23
  Property, 24