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Safety Guidelines 

This manual contains notices intended to ensure personal safety, as well as to protect the products and 
connected equipment against damage. These notices are highlighted by the symbols shown below and 
graded according to severity by the following texts: 

 

!  
Danger 
indicates that death, severe personal injury or substantial property damage will result if proper 
precautions are not taken. 

 

!  
Warning 
indicates that death, severe personal injury or substantial property damage can result if proper 
precautions are not taken. 

 

!  
Caution 
indicates that minor personal injury can result if proper precautions are not taken. 

 
 Caution 

indicates that property damage can result if proper precautions are not taken. 
 

 Notice 
draws your attention to particularly important information on the product, handling the product, or to a 
particular part of the documentation. 

Qualified Personnel 

Only qualified personnel should be allowed to install and work on this equipment. Qualified persons 
are defined as persons who are authorized to commission, to ground and to tag circuits, equipment, and 
systems in accordance with established safety practices and standards. 

Correct Usage 

Note the following: 
 

!  
Warning 
This device and its components may only be used for the applications described in the catalog or the 
technical description, and only in connection with devices or components from other manufacturers 
which have been approved or recommended by Siemens. 
 
This product can only function correctly and safely if it is transported, stored, set up, and installed 
correctly, and operated and maintained as recommended. 

Trademarks 

SIMATIC®, SIMATIC HMI® and SIMATIC NET® are registered trademarks of SIEMENS AG.  

Third parties using for their own purposes any other names in this document which refer to trademarks 
might infringe upon the rights of the trademark owners. 
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Preface 

Goal of the manual 
This manual is designed to enable you to commission the sample plant described.  

It is directed towards persons who work in the field of configuration, commissioning 
and servicing automation systems.  

Required basic knowledge 
You are required have a general knwowledge of automation technology as well as 
a broad knowledge of the SIMATIC devices used.  

In addition, you are required to have a good working knowledge of computers or 
other tools similar to the PC (e. g. programming devices) under the operating 
systems Windows 2000 or XP. Since the use of SIMATIC iMap with SIMATIC 
devices is based on the STEP 7 basic software you have to know how to use it. 
You can learn how to use this software in the manual "Programming with STEP 7". 

Validity of the manual 
This manual is valid for the software package SIMATIC iMap V2.0. 

Changes compared to the previous version 
Compared to the previous version, the following topics have been added to the 
manual compared: 

• Creating PROFInet components for CPU 317-2 PN/DP and CPU 314C-2 DP. 

• Configuring and commissioning a plant with CPU 317-2 PN/DP and 
CPU 314C-2 DP in SIMATIC iMap. 
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Your guide through the manual 
The tutorial contains  

• a description of the entire plant,  

• instructions on creating PROFInet components in part 1 and  

• instructions on commissioning the system in part 2. 
The instructions on commissioning the individual subplants contain all the 
necessary procedures. Therefore, some descriptions occur more than once, for 
example, "Creating a new project in SIMATIC iMap" or "Setting the PG/PC 
Interface". 

Place of the manual in the information environment  
This manual is part of the documentation package on Component based 
Automation und SIMATIC iMap. The documentation is supplied with the software 
and includes the electronic manuals in PDF format: 

• Configuring plants with SIMATIC iMap  

• Getting Started with SIMATIC iMap  

• Commissioning Systems - the updated manual 

• Creating PROFInet Components 

In addition, the entire documentation is available as an HTML Basic Help. 

Conventions 
• Menu commands are written in bold letters, for example: Project> Save. 

• Placeholders are set in angle brackets, for example <File name>. 

Further support 
Please contact your local SIEMENS partner if you have any further queries on the 
products described in this manual.  

http://www.siemens.com/automation/partner 

http://www.ad.siemens.de/cba/ 

Training centers  
To give you an easy start with SIMATIC iMap, we offer corresponding courses. 
Please contact your local training center or the central training center in D 90327 
Nuremberg.  

Phone: +49 (911) 895-3200  

Internet: http://www.sitrain.com 

 

http://www.siemens.com/automation/partner
http://www.ad.siemens.de/cba/
http://www.sitrain.com
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A&D Technical Support 
 
Open round the clock, worldwide:  
 

Beijing 

 Nuremberg

Johnson City 

 
World-wide (Nuremberg) 
Technical Support  
 

Local time: 0:00 to 24:00 / 365 days 

Phone: +49 (180) 5050-222 

Fax: +49 (180) 5050-223 

EMail: adsupport@ 
 siemens.com 

GMT: +1:00 

  

Europe / Africa (Nuremberg) 
Authorization 
 
Local time: 8:00 to 17:00 

Phone: +49 (180) 5050-222 

Fax: +49 (180) 5050-223 

EMail: adsupport@ 
 siemens.com 

GMT: +1:00 

United States (Johnson City) 
Technical Support and 
Authorization 
Local time: 8:00 to 17:00 

Phone: +1  (423)  262 2522. 

+1-52520779 740 3699, Fax: 

EMail: simatic.hotline@ 

 sea.siemens.com 

GMT: -5:00 

Asia / Australia (Beijing) 
Technical Support and 
Authorization 
Local time: 8:00 to 17:00 

Phone: +86 10 64 75 75 75 

Fax: +86 10 64 74 74 74 

E-Mail: adsupport.asia@ 

 siemens.com 

GMT: +8:00 

German and English spoken at the Technical Support and Authorization hotlines. 
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Service & Support on the Internet 
In addition to our documentation services, we also offer you our knowledge base 
on the Internet. 
http://www.siemens.com/automation/service&support 

Here, you will find: 

• the newsletter which constantly provides you with up-to-date information about 
your products. 

• your appropriate documentation via our Service & Support search engine 

• a forum for the exchange of information between users and specialists 
worldwide 

• your local Automation & Drives partner via our partner database. 

• information on repairs, replacement parts and on-site service. You will find more 
information under "Services�. 

 

 

http://www.siemens.com/automation/service&support
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Tutorial - Introduction 1
1.1 Overview 

Aim of the tutorials for commissioning the system 
Numerous tasks are required to commission a plant with PROFInet and 
PROFIBUS devices in STEP 7, SIMATIC iMap and the plant itself. 

The aim of the tutorial is provide you with the skills to commission the example 
plant described here. 

Content of the tutorial 
The tutorial includes:  

• A description of a complete plant 

• Part 1: Instructions for creating PROFInet components and  

• Part 2: Instructions for commissioning the system  

Procedure 
With reference to the examples, you can work step by step through the process of 
commissioning a complex plant - from creation of the PROFInet components 
through to monitoring the configured plant online. If you already have off-the-shelf 
PROFInet components and simply want to interconnect them, you can start from 
Part 2: System commissioning. 
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1.2 Description of the Complete Plant 

The complete plant consists of three machines and a central plant control system. 
Each machine includes at least one PROFInet device with an Ethernet connector. 
When the PROFInet device is a PROFIBUS master, the machine may also contain 
a PROFIBUS device. 

Configuration of the plant 

IE/PB Link

Coordinator
CPU 317-2 PN/DP

Packaging
CPU 315-2 DP + CP 343-1 PN

Plant Control WinLC PN

Measuring
    ET 200M

Machine 1
Processing

Conveyor
ET 200X

Scan
ET 200S

Machine 2
Scanning

Machine 3
Packaging

PROFIBUS 2

PROFIBUS 1

Industrial Ethernet

SIMATIC iMap
Engineering PC

Processing
CPU 314C-2 DP

 
Figure 1-1 Complete plant 
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Plant components 
 

Component Device Device type Function 

Plant_Control PC station with WinLC PN PROFInet device Plant control 
visualization 
(optional) 

Machine 1 � Processing and measurement 

Coordinator CPU 317-2 PN/DP PROFInet device with proxy 
functionality 

(DP master) 

Coordination of 
Machine 1 

Processing CPU 314-2 DP PROFIBUS device (intelligent 
DP slave) 

Machining station 

Measurement ET 200M with IM 153 PROFIBUS device (DP slave) Measuring station 

Machine 2 � Conveying and scanning 

 IE/PB Link Network gateway with proxy 
functionality (DP master) 

No independent 
function  

Conveyor ET 200X with BM147/CPU PROFIBUS device (intelligent 
DP slave) 

Conveyor station 

Scan ET 200S with IM151/CPU PROFIBUS device (intelligent 
DP slave) 

Scan 

Machine 3 � Packaging 

Packaging CPU 315-2 DP  
with CP 343-1 PN 

PROFInet device Packaging station 
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Part 1: Creating PROFInet Components 2
2.1 Overview - Creating PROFInet Components 

You need PROFInet components to configure a plant with SIMATIC iMap. They 
can be created at any time regardless of the actual configuration of the hardware. 
You can create components as required for the entire plant or for one subplant. 

If you use the preassembled PROFInet components, you can skip this chapter and 
continue with Part 2: Commissioning the System. 

Components of the plant 
 

Plant PROFInet device PROFIBUS device PROFInet 
component 

Plant control 
system 

PC station with 
WinLC PN 

 Plant control system 

Machine 1, 
Processing 

   

 CPU 317-2 PN/DP  Coordinator 

  CPU 314C-2 DP Processing 

  ET 200M with IM153-1 ET200M_Measuring 

Machine 2, 
Scanning 

   

 IE/PB Link  IE-PB-Link1_5MB*) 

  ET 200S with 
IM151/CPU 

ET200S_Scan 

  ET 200X with 
BM147/CPU 

ET200X_Conveyor 

Machine 3, 
Packaging 

   

 CPU 315-2 DP with 
a CP 343-1 PN 

 Packaging 

*) The PROFInet component for the IE/PB Link network transition is ready to use in the 
STEP 7 install directory under Step7\s7cbacompproj. 
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2.2 Requirements - Creating PROFInet Components 

Software Requirements 
The following software must be installed before the PROFInet components can be 
created for the plant: 

• Operating system: 

� Microsoft Windows 2000 Professional as of SP4 or  

� Microsoft Windows XP as of SP1 

• STEP 7 as of V5.3 

• SIMATIC iMap V2.0 

� You need administrator rights for the installation of SIMATIC iMap. 

� You need at least main user rights to operate SIMATIC iMap. 

2.3 Basic Procedure - Creating PROFInet Components 

 Required steps 
The PROFInet components are created using STEP 7. The following steps are 
required to create each PROFInet component: 

 
Figure 2-1 Basic procedure - creating PROFInet components 
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2.4 Creating PROFInet Components 

2.4.1 Creating the PROFInet Component for CPU 317-2PN/DP 

Create the PROFInet "Coordinator" component for coordination of Machine 1, 
Processing.  

Content of the PROFInet component 
The PROFInet "Coordinator" component contains:  

 
PROFInet component PROFInet device Technological function 

Coordinator SIMATIC 300 station with 
CPU 317-2 PN/DP 

(PROFInet device with 
proxy functionality) 

Coordination of Machine 1 

(S7 program with the component 
interface)  

Basic procedure 
The PROFInet components are created using STEP 7. Carry out the following 
basic steps: 

• In SIMATIC Manager, create a project for a component and configure the 
station hardware in HW Config.  

• Create the interface DB for the component interface.  

• Create the S7 program.  

• Create the PROFInet component using a menu command and save it in a 
directory.  
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How to configure the hardware 
 

Task Procedure 

1. Create a project in SIMATIC Manager and insert a SIMATIC 300 station with the name 
"Coordinator". 

2. Configure the hardware based on the following illustration: 

 
Note:  

The DP master system (X1) must be connected to a network. The transmission speed defined 
here is adopted in SIMATIC iMap for the PROFIBUS of the PROFInet device with proxy 
functionality.  

No IP address and subnet mask has to be configured for Industrial Ethernet (X2). 
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How to create the interface DB 
 

Task Procedure 

1. In SIMATIC Manager, mark the SIMATIC 300 station and then select the Create PROFInet 
Interface command from the context menu. 

The "New/Open PROFInet Interface" dialog opens. 

2. Select CPU 317-2 PN/DP in the left window of the "New/Open PROFInet Interface" dialog. 
Activate the "New" option and confirm this by pressing the "OK" button.  

Result: The properties dialog of the newly created block opens. 

3. In the "Name and type" field, enter the desired block number, DB100 for example, and select 
the block type, "Global DB".  

Confirm by clicking on the "OK" button. Result: The interface DB is opened in the PROFInet 
Interface Editor. 

4. Enter the inputs of the technological function in the PN Input section and assign the entries the 
required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration:  

 
Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 
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Task Procedure 
5. Enter the outputs of the technological function in the PN Output section and assign the entries 

the required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration: 

 
Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 

6. Save the PROFInet interface DB using the menu command File > Save.  

 The PROFInet interface (technological function) is displayed in the right window of the 
Interface Editor: 
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Additional information... 
about the interface DB can be found under "Properties of the Interface DB" in the 
SIMATIC iMap or SIMATIC Manager basic help. 

How to create the S7 program  
 

Task Procedure 

1. Copy all blocks from the "CPU 300-2 PN/DP" block folder of the PROFInet System Library into 
the block folder of the CPU.  

2. Create the program. The following is an example based on a section from OB1. You can see 
the reference to the PROFInet interface DB there.  

�  

//enable component 
A "PN_Interface_DB".On 
JCN noon 
= "PN_Interface_DB".Standby 

//forward HMIStop to Ooutput HMIStop 
A "PN_Interface_DB".Ext_StoP 
= "PN_Interface_DB".Ext_Ostop 

//increments OCnt if Cnt==Ocnt 
L "PN_Interface_DB".Counter_In 
L "PN_Interface_DB".Counter_Out 
<>D  
JC GO 
L "PN_Interface_DB".Counter_Out 
L 1 
+D 
T "PN_Interface_DB".Counter_OutGO: NOP 0 

�  

3. Compile and test the S7 program. 
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How to create the PROFInet component 
 

Task Procedure 

1. In SIMATIC Manager, mark the SIMATIC PC station and then select the Create PROFInet 
Component command from the context menu. 

2. On the "General" tab, highlight the "Identification, New" option and enter the following name: 
"Coordinator�. 
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Task Procedure 
3. In the "Component type" tab, select "Standard component with proxy functionality" and 

"Updating PN interfaces automatic (at cycle control point)". 
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Task Procedure 
4. In the "Storage areas" tab, enter the desired path, for example, D:\cba_tutorial (D stands for a 

drive of your choice). 
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Task Procedure 
5. In the "Additional properties" tab, enter the path of the icon files and optionally the path of the 

documentation link. 

You can use the supplied icons as needed (default path: Step7\s7data\s7cbac1x). 

 Result: The PROFInet component is saved as an XML file at the specified location and the 
archived component project is saved. 
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2.4.2 Creating the PROFInet Component for CPU 315-2DP 

For Machine 3, Packaging, create the PROFInet component "Packaging" from a 
CPU 315-2 DP with a CP 343-1 PN as the controller for the packaging station. 

Content of the PROFInet component 
The PROFInet "Packaging" component contains:  

 
PROFInet component PROFInet device Technological function 

Packaging CPU 315-2 DP  
with CP 343-1 PN 

(PROFInet device without 
proxy functionality) 

Packaging station 

(S7 program with the component 
interface)  

Basic procedure 
The PROFInet components are created using STEP 7. Carry out the following 
basic steps: 

• In SIMATIC Manager, create a project for a component and configure the 
station hardware in HW Config.  

• Create the interface DB for the component interface.  

• Create the S7 program.  

• Create the PROFInet component using a menu command and save it in a 
directory.  
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How to configure the hardware  
 

Task Procedure 

1. Create a project in SIMATIC Manager and insert a SIMATIC 300 station with the name 
"Packaging". 

2. Configure the hardware based on the following illustration: 

 
Note: No IP address has to be configured for the CP 343-1 PN. 
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How to create the interface DB 

Task Procedure 

1. In SIMATIC Manager, mark the SIMATIC S7-300 station and then select the Create 
PROFInet Interface command from the context menu. 

The "New/Open PROFInet Interface" dialog opens. 

2. Select CPU 315-2 DP in the left window of the "New/Open PROFInet Interface" dialog. 
Activate the "New" option and confirm this by pressing the "OK" button.  

Result: The properties dialog of the newly created block opens. 

3. In the "Name and type" field, enter the desired block number, DB100 for example, and select 
the block type, "Global DB".  

Confirm by clicking on the "OK" button. Result: The interface DB is opened in the PROFInet 
Interface Editor. 

4. Enter the inputs of the technological function in the PN Input section and assign the entries the 
required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration:  

Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 

5. Enter the outputs of the technological function in the PN Output section and assign the entries 
the required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration: 

Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 
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Task Procedure 
6. Save the PROFInet interface DB using the menu command File > Save.  

 The PROFInet interface "Packaging" (technological function) is displayed in the right window 
of the Interface Editor: 
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Additional information... 
about the interface DB can be found under "Properties of the Interface DB" in the 
SIMATIC iMap or SIMATIC Manager basic help. 

How to create the S7 program  
 

Task Procedure 

1. Copy all blocks from the "CPU 300" block folder of the PROFInet System Library into the 
block folder of the CPU. 

2. Create the S7 program in OB1. The following is an example based on a section from OB1. 
You can see the reference to the PROFInet interface DB there. 

�  

//refreshing the interface db 

CALL "PN_InOut", DB41 
LADDR :=W#16#110 
DONE :=M30.0 
ERROR :=M30.1 
STATUS:=MW32 

//calling the technological function block "conveyor" 
CALL "Conveyor_with_stop", "Conveyor_with_stop_DB" 
ExternStop :="PN_Interface_DB".Ext_Stop 
ExternStart :="PN_Interface_DB".Ext_Start 
RunDelay :="PN_Interface_DB".Run_Delay 
� 
StartNext :="PN_Interface_DB".Start_Next 
Running :="PN_Interface_DB".Running 
� 
//forwarding the counter value 
L "PN_Interface_DB".Counter_In 
T "PN_Interface_DB".Counter_Out 
�  

3 Compile and test the S7 program. 

 

 Note 
Note that the PN_InOut (FB88) block must be called cyclically in the user program, 
e.g. in OB1 or in a time OB. 



Part 1: Creating PROFInet Components 

Component based Automation, Commissioning Systems 
A5E00248818-01 2-17 

How to create the PROFInet component  
 

Task Procedure 

1. In SIMATIC Manager, mark the SIMATIC 300 station and then select the Create PROFInet 
Component command from the context menu. 

2. On the "General" tab, highlight the "Identification, New" option and enter the following name: 
�Packaging�.  
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Task Procedure 
3. Select "Standard component without proxy functionality" in the "Component type" tab. 

 
4. In the "Storage areas" tab, enter the desired path, for example, D:\cba_tutorial (D stands for a 

drive of your choice). 
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Task Procedure 
5. In the "Additional properties" tab, enter the path of the icon files and optionally the path of the 

documentation link. 

You can use the supplied icons as needed (default path: Step7\s7data\s7cbac1x).  

 
 Result: The PROFInet component is saved as an XML file at the specified location and the 

archived component project is saved. 
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2.4.3 Creating the PROFInet Component for WinLC PN 

Creating the PROFInet Plant Control" component for coordination of the complete 
plant  

Content of the PROFInet component 
The PROFInet "Plant Control" component contains:  

 
PROFInet component PROFInet device Technological function 

Plant control system PC station with WinLC PN 

(PROFInet device without 
proxy functionality) 

Plant control system 

(S7 program with the component 
interface)  

Basic procedure 
The PROFInet components are created using STEP 7. Carry out the following 
basic steps: 

• In SIMATIC Manager, create a project for a component and configure the 
station hardware in HW Config.  

• Create the interface DB for the component interface.  

• Create the S7 program.  

• Select the PROFInet component using a menu command and store it in a 
directory.  
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How to configure the hardware 
 

Task Procedure 

1. Create a project in SIMATIC Manager and insert a SIMATIC PC station with the name "Plant 
Control". 

2. Configure the hardware based on the following illustration: 

 
Note: No IP address has to be configured for the Ethernet-CP IE General. 
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How to create the interface DB 
 

Task Procedure 

1. In SIMATIC Manager, mark the PC station and then select the Create PROFInet Interface 
command from the context menu. 

The "New/Open PROFInet Interface" dialog opens. 

2. Select WinLC PN in the left window of the "New/Open PROFInet Interface" dialog. Activate the 
"New" option and confirm this by pressing the "OK" button.  

Result: The properties dialog of the newly created block opens. 

3. In the "Name and type" field, enter the desired block number, DB100 for example, and select 
the block type, "Global DB".  

Confirm by clicking on the "OK" button. Result: The interface DB is opened in the PROFInet 
Interface Editor. 

4. Enter the inputs of the technological function in the PN Input section and assign the entries the 
required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration:  

Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 

5. Enter the outputs of the technological function in the PN Output section and assign the entries 
the required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration: 

Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 



Part 1: Creating PROFInet Components 

Component based Automation, Commissioning Systems 
A5E00248818-01 2-23 

Task Procedure 
6. Save the PROFInet interface DB using the menu command File > Save.  

 The PROFInet interface (technological function) is displayed in the right window of the 
Interface Editor: 
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Additional information... 
about the interface DB can be found under "Properties of the Interface DB" in the 
SIMATIC iMap or SIMATIC Manager basic help. 

How to create the S7 program  
 

Task Procedure 

1. Copy all blocks from the "WinLC PN" block folder of the PROFInet System Library into the 
block folder of the WinLC PN. 

2. Create the program. The following is an example based on a section from OB1. You can see 
the reference to the PROFInet interface DB there.  

� 
//forwards RunDelay to ORunDelay  

L "PN_Interface_DB".RunDelay 
T "PN_Interface_DB".RunDelay_Out 

//forwards EStop to OEStop 

 U "PN_Interface_DB".HMIStop 
= "PN_Interface_DB".HMIStop_Out 

//increments OCnt if Cnt==OCnt 

 L "PN_Interface_DB".Counter_In 
L "PN_Interface_DB".Counter_Out 
<>D 
SPB GO 
L "PN_Interface_DB".Counter_Out 
L 1 
+D 
T "PN_Interface_DB".Counter_Out 

GO: NOP 0 

... 

3. Compile and test the S7 program. 
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How to create the PROFInet component 
 

Task Procedure 

1. In SIMATIC Manager, mark the SIMATIC PC station and then select the Create PROFInet 
Component command from the context menu. 

2. On the "General" tab, highlight the "Identification, New" option and enter the following name: 
"Plant Control�. 
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Task Procedure 
3. Select "Standard component without proxy functionality" in the "Component type" tab. 

 
4. In the "Storage areas" tab, enter the desired path, for example, D:\cba_tutorial (D stands for a 

drive of your choice). 
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Task Procedure 
5. In the "Additional properties" tab, enter the path of the icon files and optionally the path of the 

documentation link. 

You can use the supplied icons as needed (default path: Step7\s7data\s7cbac1x). 

 
 Result: The PROFInet component is saved as an XML file at the specified location and the 

archived component project is saved. 

 

Optional: Proxy functionality 
If the PC station of the WinLC PN has a PROFIBUS connector, you can optionally 
create a PROFInet component with proxy functionality. This will allow you to 
connect PROFIBUS devices (DP slaves) to the WinLC PN. Perform the following 
additional task in this case: 

• Configure the PC station in HW Config and connect it to the DP master system 
network. 

• Select "Standard component with proxy functionality" in the "Component type" 
tab to create the PROFInet component. 
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2.4.4 Creating the PROFInet Component for CPU 314C-2 DP 

Creating the PROFInet component "Processing" as the processing station with 
CPU 314C-2 DP for Machine 1.  

Content of the PROFInet component 
The PROFInet "Processing" component contains:  

 
PROFInet component PROFIBUS device Technological function 

Processing CPU 314C-2 DP 

(intelligent DP slave) 

Processing station  
(S7 program with the 
technological interface) 

Basic procedure 
The PROFInet components are created using STEP 7. Carry out the following 
basic steps: 

• In SIMATIC Manager, create a project for a component and configure the 
station hardware in HW Config.  

• Create the interface DB for the component interface.  

• Create the S7 program.  

• Create the PROFInet component using a menu command and save it in a 
directory. 
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How to configure the hardware  
 

Task 
 

Procedure 

1. Create a project in SIMATIC Manager and insert a SIMATIC 300 station. 

2. Configure the hardware based on the following illustration: 

 
The DP connection (X2) must be configured as a DP slave. 
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How to create the interface DB 
 

Task Procedure 

1. In SIMATIC Manager, mark the SIMATIC S7-300 station and then select the Create 
PROFInet Interface command from the context menu. 

The "New/Open PROFInet Interface" dialog opens. 

2. Select CPU 314C-2 DP in the left window of the "New/Open PROFInet Interface" dialog. 
Activate the "New" option and confirm this by pressing the "OK" button.  

Result: The properties dialog of the newly created block opens. 

3. In the "Name and type" field, enter the desired block number, DB100 for example, and select 
the block type, "Global DB".  

Confirm by clicking on the "OK" button. Result: The interface DB is opened in the PROFInet 
Interface Editor. 

4. Enter the inputs of the technological function in the PN Input section and assign the entries the 
required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration:  

Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 

5. Enter the outputs of the technological function in the PN Output section and assign the entries 
the required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration: 

Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 
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Task Procedure 
6. Enter the S7 tags for HMI/MES access via OPC in the S7 Tags section and assign the entries 

the required properties: Name, Data type, HMI/MES, as shown in the following illustration: 

Selected entries are made read-only when the "Read-only" option is activated. 

The entries cannot are not visible in SIMATIC iMap; they are not displayed in the right window 
of the Interface Editor. 

7. Save the PROFInet interface DB using the menu command File > Save.  

 The PROFInet interface (technological function) is displayed in the right window of the 
Interface Editor: 
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Additional information... 
about the interface DB can be found under "Properties of the Interface DB" in the 
SIMATIC iMap or SIMATIC Manager basic help. 

How to create the S7 program 
 

Task Procedure 

1. Copy all blocks from the "I-DP-Slave" block folder of the PROFInet System Library into the 
block folder of the CPU. 

2. How to create the S7 program The following is an example based on a section from OB1. You 
can see the reference to the PROFInet interface DB there. 

//refreshing the input section of the interface db 

CALL "PN_IN" 
DB_NO :="PN_IO_DB" 
RET_VAL:=MW20 

�  

CALL "Conveyor_with_stop", "Conveyor_with_stop_DB" 
ExternStop :="PN_Interface_DB".Ext_Stop 
ExternStart :="PN_Interface_DB".Ext_Start 
RunDelay :="PN_Interface_DB".Run_Delay 

�. 

//refreshing the output section of the interface db 

 CALL "PN_OUT" 
DB_NO :="PN_IO_DB" 
RET_VAL:=MW22 

3. Compile and test the S7 program. 

 

 Caution 
Note that the PN_IN (FC10) block must be called at the start of OB1 and the 
PN_OUT (FC11) block at the end of OB1. 
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How to create the PROFInet component 
 

Task Procedure 

1. In SIMATIC Manager, mark the SIMATIC 300 station and then select the Create PROFInet 
Component command from the context menu. 

2. On the "General" tab, highlight the "Identification, New" option and enter the following name: 
"Processing�. 
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Task Procedure 
3. Accept the default settings in the "Component type" tab: 

 
4. In the "Storage areas" tab, enter the desired path, for example, D:\cba_tutorial (D stands for a 

drive of your choice). 
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Task Procedure 
5. In the "Additional properties" tab, enter the path of the icon files and optionally the path of the 

documentation link. 

You can use the supplied icons as needed (default path: Step7\s7data\s7cbac1x).  

 
 Result: The PROFInet component is saved as an XML file at the specified location and the 

component project is saved. 
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2.4.5 Creating the PROFInet Component for ET 200S with IM 151/CPU 
Creating the PROFInet component "ET200S_Scan" as the scanning station with 
ET 200S for Machine 2.  

Content of the PROFInet component 
The PROFInet "ET200S_Scan" component contains: 

  
PROFInet component PROFInet device Technological function 

ET200S_Scan ET 200S with IM151/CPU
(intelligent DP slave) 

Scanning station  
(S7 program with the technological 
interface) 

Basic procedure 
The PROFInet components are created using STEP 7. Carry out the following 
basic steps: 

• In SIMATIC Manager, create a project for a component and configure the 
station hardware in HW Config.  

• Create the interface DB for the component interface.  

• Create the S7 program.  

• Create the PROFInet component using a menu command and save it in a 
directory. 



Part 1: Creating PROFInet Components 

Component based Automation, Commissioning Systems 
A5E00248818-01 2-37 

How to configure the hardware  
 

Task Procedure 

1. Create a project in SIMATIC Manager and insert a SIMATIC 300 station. 

2. Configure the hardware based on the following illustration: 

 
The DP connection (X2) must be configured as a DP slave. 
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How to create the interface DB 
 

Task Procedure 

1. In SIMATIC Manager, mark the SIMATIC 300 station and then select the Create PROFInet 
Interface command from the context menu. 

The "New/Open PROFInet Interface" dialog opens. 

2. Select IM 151/CPU in the left window of the "New/Open PROFInet Interface" dialog. Activate 
the "New" option and confirm this by pressing the "OK" button.  

Result: The properties dialog of the newly created block opens. 

3. In the "Name and type" field, enter the desired block number, DB100 for example, and select 
the block type, "Global DB".  

Confirm by clicking on the "OK" button. Result: The interface DB is opened in the PROFInet 
Interface Editor. 

4. Enter the inputs of the technological function in the PN Input section and assign the entries the 
required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration:  

Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 

5. Enter the outputs of the technological function in the PN Output section and assign the entries 
the required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration: 

Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 
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Task Procedure 
6. Enter the S7 tags for HMI/MES access via OPC in the S7 Tags section and assign the entries 

the required properties: Name, Data type, HMI/MES, as shown in the following illustration: 

Selected entries are made read-only when the "Read-only" option is activated. 

The entries cannot are not visible in SIMATIC iMap; they are not displayed in the right window 
of the Interface Editor. 

7. Save the PROFInet interface DB using the menu command File > Save.  

 The PROFInet interface (technological function) is displayed in the right window of the 
Interface Editor: 
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Additional information... 
about the interface DB can be found under "Properties of the Interface DB" in the 
SIMATIC iMap or SIMATIC Manager basic help. 

How to create the S7 program  
 

Task Procedure 

1. Copy all blocks from the "I-DP-Slave" block folder of the PROFInet System Library into the 
block folder of the CPU. 

2. How to create the S7 program The following is an example based on a section from OB1. You 
can see the reference to the PROFInet interface DB there. 

//refreshing the input section of the interface db 

CALL "PN_IN" 
DB_NO :="PN_IO_DB" 
RET_VAL:=MW20 

�  

CALL "Conveyor_with_stop", "Conveyor_with_stop_DB" 
ExternStop :="PN_Interface_DB".Ext_Stop 
ExternStart :="PN_Interface_DB".Ext_Start 
RunDelay :="PN_Interface_DB".Run_Delay 

�. 

//refreshing the output section of the interface db 

 CALL "PN_OUT" 
DB_NO :="PN_IO_DB" 
RET_VAL:=MW22 

3. Compile and test the S7 program. 

 

 Caution 
Note that the PN_IN (FC10) block must be called at the start of OB1 and the 
PN_OUT (FC11) block at the end of OB1. 
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How to create the PROFInet component 
 

Task Procedure 

1. In SIMATIC Manager, select the SIMATIC 300 station and then select the Create PROFInet 
Component command from the context menu. 

2. On the "General" tab, highlight the "Identification, New" option and enter the following name: 
"ET200S_Scan�. 
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Task Procedure 
 Accept the default settings in the "Component type" tab: 

 
3. In the "Storage areas" tab, enter the desired path, for example, D:\cba_tutorial (D stands for a 

drive of your choice). 
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Task Procedure 
4. In the "Additional properties" tab, enter the path of the icon files and optionally the path of the 

documentation link. 

You can use the supplied icons as needed (default path: Step7\s7data\s7cbac1x).  

 
 Result: The PROFInet component is saved as an XML file at the specified location and the 

component project is saved. 
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2.4.6 Creating the PROFInet Component for ET 200X with BM147/CPU 
Create the PROFInet component "ET200X_Conveyor" for controlling a conveyor 
belt using with ET 200X for Machine 2.  

Content of the PROFInet component 
The PROFInet "ET200X_Conveyor" component contains:  

 
PROFInet component PROFInet device Technological function 

ET200X_Conveyor ET 200X with basic module 
BM147/CPU  

(intelligent DP slave) 

Conveyance station  
(S7 program with the 
technological interface) 

Basic procedure 
The PROFInet components are created using STEP 7. Carry out the following 
basic steps: 

• In SIMATIC Manager, create a project for a component and configure the 
station hardware in HW Config.  

• Create the interface DB for the component interface.  

• Create the S7 program.  

• Select the PROFInet component using a menu command and store it in a 
directory.  
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How to configure the hardware  
 

Task Procedure 

1. Create a project in SIMATIC Manager and insert a SIMATIC 300 station. 

2. Configure the hardware based on the following illustration: 

 
The DP connection (X2) must be configured as a DP slave. 
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How to create the interface DB 
 

Task Procedure 

1. In SIMATIC Manager, mark the SIMATIC 300 station and then select the Create PROFInet 
Interface command from the context menu. 

The "New/Open PROFInet Interface" dialog opens. 

2. Select BM 147/CPU in the left window of the "New/Open PROFInet Interface" dialog. Activate 
the "New" option and confirm this by pressing the "OK" button.  

Result: The properties dialog of the newly created block opens. 

3. In the "Name and type" field, enter the desired block number, DB100 for example, and select 
the block type, "Global DB".  

Confirm by clicking on the "OK" button. Result: The interface DB is opened in the PROFInet 
Interface Editor. 

4. Enter the inputs of the technological function in the PN Input section and assign the entries the 
required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration:  

Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 

5. Enter the outputs of the technological function in the PN Output section and assign the entries 
the required properties: Name, Data type, Connectable, HMI/MES, as shown in the following 
illustration: 

Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 
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Task Procedure 
6. Save the PROFInet interface DB using the menu command File > Save.  

 The PROFInet interface (technological function) is displayed in the right window of the 
Interface Editor: 
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Additional information... 
about the interface DB can be found under "Properties of the Interface DB" in the 
SIMATIC iMap or SIMATIC Manager basic help. 

How to create the S7 program  
 

Task Procedure 

1. Copy all blocks from the "I-DP-Slave" block folder of the PROFInet System Library into the 
block folder of the CPU. 

2. How to create the S7 program The following is an example based on a section from OB1. You 
can see the reference to the PROFInet interface DB there. 

//refreshing the input section of the interface db 

CALL "PN_IN" 
DB_NO :="PN_IO_DB" 
RET_VAL:=MW20 

�  

CALL "Conveyor_with_stop", "Conveyor_with_stop_DB" 
ExternStop :="PN_Interface_DB".Ext_Stop 
ExternStart :="PN_Interface_DB".Ext_Start 
RunDelay :="PN_Interface_DB".Run_Delay 

�. 

//refreshing the output section of the interface db 

 CALL "PN_OUT" 
DB_NO :="PN_IO_DB" 
RET_VAL:=MW22 

3. Compile and test the S7 program. 

 

 Caution 
Note that the PN_IN (FC10) block must be called at the start of OB1 and the 
PN_OUT (FC11) block at the end of OB1. 
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How to create the PROFInet component 
 

Task Procedure 

1. In SIMATIC Manager, select the SIMATIC 300 station and then select the Create PROFInet 
Component command from the context menu. 

2. On the "General" tab, highlight the "Identification, New" option and enter the following name: 
"ET200X_Conveyor°. 
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Task Procedure 
3. Accept the default settings in the "Component type" tab: 

 
4. In the "Storage areas" tab, enter the desired path, for example, D:\cba_tutorial (D stands for a 

drive of your choice). 
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Task Procedure 
5. In the "Additional properties" tab, enter the path of the icon files and optionally the path of the 

documentation link. 

You can use the supplied icons as needed (default path: Step7\s7data\s7cbac1x).  

 
 Result: The PROFInet component is saved as an XML file at the specified location and the 

archived component project is saved. 
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2.4.7 Creating the PROFInet Component for ET 200M with IM 153-1 
Create the PROFInet "ET200M_Measuring" component as a measuring module for 
Machine 1.  

Content of the PROFInet component 
The PROFInet "ET200M_Measuring" component contains:  

 
PROFInet component PROFInet device Technological function 

ET200M_Measuring ET 200M with IM153 

(DP slave with fixed 
functionality) 

Measuring module 

Technological connection 
only (see below))  

 

 Note 
The PROFInet component ET200M_Measuring contains no S7 program, only the 
technological interface � whereby the signal inputs are formed directly by the 
outputs of the technological function and the signal outputs are formed by the 
inputs of the technological function. 

Basic procedure 
The PROFInet components are created using STEP 7. Carry out the following 
basic steps: 

• In SIMATIC Manager, create a project for a component and configure the 
station hardware in HW Config.  

• Create the interface DB for the component interface.  

• Create the S7 program.  

• Create the PROFInet component using a menu command and save it in a 
directory.  
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How to configure the hardware  
 

Task Procedure 

1. Create a project in SIMATIC Manager and insert a SIMATIC 300 station. 

2. Configure the hardware based on the following illustration: 

 
The input and output modules of the IM153-1 are important here. 

 

 Note 
The CPU (DP master) is not part of the PROFInet component to be created and is 
therefore not displayed in SIMATIC iMap. It is needed, however, in HW Config for 
the configuration. 
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How to create the interface DB  
 

Task Procedure 

1. In SIMATIC Manager, mark the SIMATIC 300 station and then select the Create PROFInet 
Interface command from the context menu. 

The "New/Open PROFInet Interface" dialog opens. 

2. Select IM 153-1 in the left window of the "New/Open PROFInet Interface" dialog. Activate the 
"New" option and confirm this by pressing the "OK" button.  

Result: The properties dialog of the newly created block opens. 

3. In the "Name and type" field, enter the desired block number, DB100 for example, and select 
the block type, "Global DB".  

Confirm by clicking on the "OK" button. Result: The interface DB is opened in the PROFInet 
Interface Editor.  

4. The output signals from the IM 153-1 are mapped onto the addresses (slots) of the PN_Input 
section. In the following illustration, DP_MasterOutputSlot1 corresponds to the address area of 
the first output module (slot 5 in HW Config) and DP_MasterOutputSlot2 corresponds to the 
address area of the second output module (slot 6 in HW Config). 

Enter the inputs of the technological function in the slots of the PN Input section and assign 
the entries the required properties: Name, Data type, Connectable, HMI/MES, as shown in the 
following illustration:  

Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 
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Task Procedure 
5. The input signals of the IM 153-1 are mapped onto the addresses (slots) of the PN_Output 

section. In the following illustration, DP_MasterInputSlot1 corresponds to the address area of 
the first input module (slot 4 in HW Config). 

Enter the outputs of the technological function in the slots of the PN_Output section and 
assign the entries the required properties: Name, Data type, Connectable, HMI/MES, as 
shown in the following illustration: 

Result: The interconnectable connectors are graphically displayed in the right-hand window of 
the Interface Editor, as in the SIMATIC iMap plant view. 

6. Save the PROFInet interface DB using the menu command File > Save.  

 The PROFInet interface (technological function) is displayed in the right window of the 
Interface Editor: 
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Additional information... 
about the interface DB can be found under "Properties of the Interface DB" and 
"Special features of DP slaves with fixed functionality" in the SIMATIC iMap or 
SIMATIC Manager basic help. 

S7 program 
No separate S7 program is needed for the ET 200M since it is a module without its 
own SPS (CPU). 

How to create the PROFInet component 
 

Task Procedure 

1. In SIMATIC Manager, select the SIMATIC PC station and then select the Create PROFInet 
Component command from the context menu. 

2. In the "General" tab: 

• Mark the option "Create component from a slave".  

• Mark the option "Identification" and enter the following name: "ET200M_Measuring". 
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Task Procedure 
3. Accept the default settings in the "Component type" tab: 

 
4. In the "Storage areas" tab, enter the desired path, for example, D:\cba_tutorial (D stands for a 

drive of your choice). 
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Task Procedure 
5. In the "Additional properties" tab, enter the path of the icon files and optionally the path of the 

documentation link. 

You can use the supplied icons as needed (default path: Step7\s7data\s7cbac1x).  

 
 Result: The PROFInet component is saved as an XML file at the specified location and the 

archived component project is saved. 
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Part 2: Commissioning the System 3
The following descriptions contain step-by-step instructions for commissioning 
three typical configurations (Machines 1 to 3) as well as the complete plant. 

3.1 Requirements - Commissioning the System 

Hardware Requirements 
The devices must be operable and have the latest firmware versions installed. 

Software Requirements 
The following software must be installed on the engineering station:  
• Operating system: 

� Microsoft Windows 2000 Professional as of SP4 or  
� Microsoft Windows XP as of SP1 

• STEP 7 as of V5.3  
Required for the generation of the project, the download of the program and the 
diagnostics for the specific device. 

• SIMATIC iMap V2.0 
� You need administrator rights for the installation of SIMATIC iMap. 
� You need at least main user rights to operate SIMATIC iMap. 

• SIMATIC NET as of V6.1  
Optional � required for the use of WinLC PN and OPC. 

Tip 
Devices are assigned fixed IP and PROFIBUS addresses in the following 
descriptions. To ensure that the commissioning runs successfully, we recommend 
that you use the same addresses.  

All IP addresses must be in the same subnet for the described plant.  

Requirement for Configuration of the Plant in SIMATIC iMap 
You have created the PROFInet components and they are present in the file 
system. 
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3.2 Basic Procedure - Commissioning the System 

Required steps 
The following commissioning tasks must be performed for each device of a plant: 

• In the plant:  

� Setup hardware 

� Configure the addresses on the PROFIBUS devices 

� Network devices and connect them with the engineering PC 

• In STEP 7: 

� Assign IP and PROFIBUS addresses for the first time, if necessary 

� Make settings for downloading, online monitoring and diagnostics 

• In SIMATIC iMap:  

� Configure the plant 

� Commission the plant 

� Perform online monitoring and diagnostics for the plant 

Next Steps 
Commission one of the following plants: 

• Machine 1:  

A CPU 317-2 PN/DP with the PROFIBUS devices CPU 314C-2 DP (as 
intelligent DP slave) and ET 200M  

• Machine 2:  

An IE/PB Link with the PROFIBUS devices ET 200S with IM151/CPU and ET 
200X with BM147/CPU 

• Machine 3:  

A CPU 315-2 DP with a CP 343-1 PN  

• Complete plant  

Consisting of Machines 1 to 3 and a PC station WinLC PN. 
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3.3 Machine 1 

3.3.1 Machine 1, Processing: CPU 317-2 PN/DP with PROFIBUS-DP 
Slaves 

Configuration of Machine 1 

Maschine 1
Processing

Coordinator
CPU 317-2 PN/DP

Measuring
    ET 200M

PROFIBUS 1

Industrial Ethernet

SIMATIC iMap
Engineering PC

Processing
CPU 314C-2 DP

 
Figure 3-1 Machine 1, Processing 

Machine 1 contains the following devices: 

• CPU 317-2 PN/DP  

as PROFInet device with proxy functionality for both DP slaves 

• CPU 314C-2 DP  

as PROFIBUS device with programmable functionality (intelligent DP slave) for 
controlling the "Processing" station 

• ET 200M  

as PROFIBUS device with fixed functionality (DP slave), "ET200_Measuring" 
module 
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Required steps 
1. Set up the hardware of the plant: 

� CPU 317-2 PN/DP 

� ET 200M with IM153-1  

� CPU 314C-2 DP 

2. Assigning Addresses 

� The CPU 317-2 PN/DP must be assigned an IP address the first time.  

� The CPU 314C-2 DP must be assigned a PROFIBUS address once.  

3. Configure plant in SIMATIC iMap. 

4. Check the settings in STEP 7  

Optional - required for the program download to the target device of the plant 
and for diagnostics of each device. 

5. Commission the plant 

6. Online monitoring of plant with SIMATIC iMap 
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3.3.2 Step 1: Setting up the Hardware for Machine 1 

3.3.2.1 CPU 317-2 PN/DP - Hardware Setup 

Required Hardware 
You will need the following S7-300 modules:  

 
Qty. Designation Order number 

1x CPU 317-2 PN/DP 6ES7 317 2EJ10-0AB0 / V2.1 

1x Power supply module PS 307 5A 6ES7 307-1EA00-0AA0 

How to setup the CPU 317-2 PN/DP 
 

Task Procedure 

1. Mount the modules on the rail. 

2. Connect the power supply. 

3. Connect the PG/PC using the PG cable to the MPI interface of the CPU 317-2 PN/DP. 

4. Connect the Ethernet cable to the CPU 317-2 PN/DP. 

5. Switch on the power supply of the CPU 317-2 PN/DP. 
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3.3.2.2 ET 200M - Hardware Setup 

Required Hardware 
You will require the following modules:  

 
Qty. Designation Order number 

1x Interface module IM 153-1 6ES7 153-1AA**-0XB0 

1x Expansion module DI 16xDC24V (no current)  6ES7 321-1BH82-0AA0 

1x Expansion module DO 16xDC24V/0.5A 6ES7 322-1BH01-0AA0 

1x Expansion module DO 8xDC24V/0.5A 6ES7 322-8BF80-0AB0 

How to set up the ET 200M 
 

Task Procedure 

1. Mount the modules on the rail. 

2. Set the interface module IM 153-1 to PROFIBUS address 3. 

3. Connect the power supply. 

4. Wire the I/O module. 

5. Connect the PROFIBUS cable to the IM153-1. 
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3.3.2.3 CPU 314C-2 DP � Hardware Setup 

Required Hardware 
You will need the following S7-300 module: 

  
Qty. Designation Order number 

1x CPU 314C-2 DP 6ES7 314 6CF01-0AB0 / V2.0 

 

How to setup the CPU 314C-2 DP 
 

Task Procedure 

1. Mount the module on the rail. 

2. Connect the power supply. 

3. Connect the PG/PC using the PG cable to the MPI interface of the CPU 314C-2  DP. 

4. Switch on the power supply of the CPU 314C-2 DP. 
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3.3.3 Step 2: Assigning the Devices with Addresses the First Time 

3.3.3.1 Assigning CPU 317-2 PN/DP an Address the First Time 

The first time, you must download the IP address from STEP 7 to the target device 
via MPI, if you have not already done so. Optionally, you can also use the 
PROFIBUS address from SIMATIC iMap 

Requirements 
• The CPU must be in STOP. 

• The PG/PC must be connected to the X1 port of the CPU with a PG cable. 

 

 Note 
At commissioning (factory state), the CPU 317-2 PN/DP can be reached at MPI 
address 2, HSA 31 and 187.5 kbps.  
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How to assign an address to the CPU 317-2 PN/DP the first time 
 

Task Procedure 

1. Set the PG/PC interface to MPI. 

From the Windows taskbar, select Start > SIMATIC > STEP 7 > Set PG/ PC interface. 
Configure the PG/PC interface so that the S7ONLINE (STEP 7) access point is set to MPI.  

 
2. Start SIMATIC Manager and create a temporary project with a SIMATIC 300 station. This 

project will only be used for assigning addresses for the first time.  

3. Open the station hardware configuration and configure the CPU 317-2 PN/DP. You will not 
need any I/O modules. 

4. Configure the CPU's industrial Ethernet interface (X2) and set the required IP address and 
subnet mask, e.g.: 

Optional: Configure the CPU's PROFIBUS interface (X1) and set the required PROFIBUS 
address. 

5. Save and compile the station using the Station > Save and Compile menu command. 
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Task Procedure 
6. Select Target System > Download to Module. 

Select the CPU 317-2 PN/DP under "Select Target Module" and confirm your selection with 
"OK". 

7. In the "Select Node Address" dialog enter the MPI address of the CPU or accept the displayed 
address by pressing "OK".  
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Task Procedure 
 
 

Result: The system data including the IP and PROFIBUS address are loaded into the CPU. 
The CPU can now communicate via PROFInet. 

If the red error LED lights up, you can ignore it since the correct hardware configuration will 
subsequently be downloaded from SIMATIC iMap. 

8. Connect the DP slaves to the CPU 317-2 PN/DP using a PROFIBUS cable. 
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3.3.3.2 Assigning a PROFIBUS Device a PROFIBUS Address the First 
Time 

The first time, you must download the PROFIBUS address from STEP 7 to the 
target device via MPI, if you have not already done so.  

This chapter also applies for the following PROFIBUS devices (central modules as 
intelligent DP slaves): 

• CPU 314C-2 DP 

• IM 151/CPU 

• BM 147/CPU 

 

 Note 
For initial commissioning (as-delivered state), each of these modules can be 
accessed via MPI address 2, HSA 31 and at 187.5 kBps.  

Requirements 
• The CPU must be in STOP. 

• The PG/PC must be connected to the CPU with a PG cable. 
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How to assign a PROFIBUS address to the CPU acting as a DP slave the first 
time 

 
Task Procedure 

1. Set the PG/PC interface to MPI. 

From the Windows taskbar, select Start > SIMATIC > STEP 7 > Set PG/ PC interface. 
Configure the PG/PC interface so that the S7ONLINE (STEP 7) access point is set to MPI: 

 
2. Start SIMATIC Manager and create a temporary project with a SIMATIC 300 station. This 

project will only be used for assigning addresses for the first time. 

3. Open the station hardware configuration and configure the appropriate CPU (CPU 314C-2 DP, 
IM 151/CPU or BM 147/CPU) as a DP slave. You will not need any I/O modules. 

In the object properties for the DP interface, select "DP Slave" operating mode.  

The "Commissioning / Test mode" option must not be active. 
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Task Procedure 
4. Configure the CPU's PROFIBUS interface and set the required PROFIBUS address, e.g.: 

 
5. On the Configuration" tab in the object properties, configure any exchange of data between 

the intelligent DP slave (I slave) and a DP master: 

 
6. Save and compile the station using the Station > Save and Compile menu command. 
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Task Procedure 
7. Select Target System > Download to Module. 

 
Select the CPU from the "Select target module" dialog and click on "OK" to confirm.  
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Task Procedure 
8. In the "Select Node Address" dialog enter the MPI address of the CPU or accept the displayed 

address by pressing "OK". 

 
 Result: The system data including the PROFIBUS address are loaded into the CPU. The CPU 

can now communicate via PROFIBUS. 

If the red error LED lights up, you can ignore it since the correct hardware configuration will 
subsequently be downloaded from SIMATIC iMap. 
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3.3.4 Step 2: Configuring Machine 1 with SIMATIC iMap 

3.3.4.1 Configuring the Plant - Basic Procedure 

This procedure can be carried out independent of the hardware setup for the plant.  

Requirements 
You have created the PROFInet components and they are present in the file 
system. 

Basic procedure 
• Creating a new project in SIMATIC iMap 

• Importing PROFInet components from the file system into the project library 

• Inserting PROFInet components from the library into the SIMATIC iMap project 

• Assigning Addresses 

• Interconnecting the technological functions and generating the SIMATIC iMap 
project 

3.3.4.2 Creating a New Project in SIMATIC iMap 

This description applies to both a complete plant or any subplant. 
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How to create a new SIMATIC iMap project 

 
Task Procedure 

1. Start SIMATIC iMap if you have not already done so: 

Double-click on the SIMATIC iMap icon on the desktop or 

Select Start / Programs / Component based Automation / SIMATIC iMap. 

Result: SIMATIC iMap is started and a new project is created. Continue with Step 3. 

2. If you have already started SIMATIC iMap, create a new project by selecting the menu 
command Project > New.  

3. Save the project by selecting the menu command Project > Save. 

4. In the dialog "Save SIMATIC iMap project As", select a folder and enter a name, for example, 
"Machine_1" in the "File name" field. The same applies to Machine 2, Machine 3 or the 
complete plant. 

Result: The project is saved. 
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3.3.4.3 Machine 1 - Importing PROFInet Components 

How to import PROFInet components into the project library 
 

Task Procedure 

1. Import the PROFInet component from the file system into the project library. 

Open the library window in SIMATIC iMap by selecting the menu command View > Library 
Window. 

2. Click on the "Project Library" window and select Import components from the context menu. 

3. Under �Search in�, select the path Program\Siemens\iMap\CBA_Tutorial\Components. 

4. Select the "coordinator--{...}" folder.  

5. Select the file "Coordinator.xml" and confirm your entry by pressing the "Open" button. 

Result: The PROFInet "Coordinator" component is entered into the project library. 

6 Repeat Steps 2 to 5 for the following PROFInet components.  

"Processing" (folder "processing--{...} and file "Processing.xml") 

"ET200M_Measuring" (folder "et200m_measuring--{...} and file "ET200M_Measuring.xml"). 

Result: The PROFInet components are entered into the project library and can now be used in 
the project.  
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3.3.4.4 Machine 1: Inserting PROFInet Components into the Project 

How to insert PROFInet components into the project 
 

Task Procedure 

1. Open the net view of the project. Select "Coordinator" in project library and drag the icon into 
the net view. An instance of the PROFInet component is inserted into the project. 

The PROFInet device is automatically connected to the Ethernet in the net view and has a 
PROFIBUS connector as DP master with proxy functionality. 

2. Select the PROFInet "Processing" component in the project library and connect it to the 
PROFIBUS of the CPU 317-2 PN/DP using Drag and Drop. 

3. Repeat Step 2 for the PROFInet "ET200M_Measuring" component. 
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3.3.4.5 Machine 1: Assigning Addresses 

How to assign addresses to devices 
 

Task Procedure 

1. Open the properties of the CPU 317-2 PN/DP in the net view.  

2. In the "Addresses" tab, enter the IP address and subnet mask together with the PROFIBUS 
address of the device as shown in the following illustration: 
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Task Procedure 
3. In the net view, open the properties of the PROFIBUS device "CPU 314C-2 DP" (Processing) 

and enter the PROFIBUS address of the device, e.g. 5, in the "Addresses" tab. 
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Task Procedure 
4. Repeat Step 3 for "IM153-1" (ET 200M_Measure) and assign the device the PROFIBUS 

address that is set by the DIL switch on the IM 153-1, e.g. 3.  

Machine 1 should then appear as follows in the net view: 

 

 Note 
The addresses must match those set on the target devices. The addresses of the 
CPU 317-2 PN/DP and CPU 314C-2 DP are assigned for the first time from 
STEP 7 via MPI (see "Step 2: Assigning addresses to the devices for the first 
time").  
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3.3.4.6 Machine 1:Interconnecting Technological Functions and 
Generating the Project 

How to interconnect technological functions and generate the project 
 

Task Procedure 

1. Open the plant view. The technological functions are arranged on top of one another at first: 

2. Arrange the technological functions and connect them as shown in the following illustration: 
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How to generate the project 
 

Task Procedure 

1. Generate the project  

• with the menu command Project > Generate > Control unit > Changes only or 

• by clicking on the "Generate" icon 

If the project has not yet been saved, you are prompted to give the project a name. In the 
dialog "Save SIMATIC iMap project As", select a folder and enter a name, for example, 
"Machine 1". 

 Result: The project is saved and generated. 

2. Follow the progress of the generation in the information window of the "Generate" tab. 

 Result: The plant is configured. It can now be put into operation. 

Additional information... 
Additional information can be found in the basic help of SIMATIC iMap under: 

• Interconnecting Technological Functions  

• Generating the Project  
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3.3.5 Step 4: Checking the Required Settings on the Engineering Station 
for Machine 1 

3.3.5.1 Checking the Required Settings on the Engineering Station for 
Machine 1 

 

Requirements 
• See Chapter "Requirements for Commissioning the System" 

• The PG/PC must be connected to the CPU 317-2 PN/DP with an Ethernet 
cable.  

Check your settings 
Check the following settings:  

• Set the PG/PC Interface to TCP/IP  

• Assigning the PG/PC 

 

 Note 
The PG/PC only has to be assigned in special situations, e.g.: 

When several network cards are installed in the PG/PC or  

If the PG/PC interface S7ONLINE (STEP 7) is not set to TCP/IP. 

Otherwise the PG/PC assignment runs automatically when the project is generated 
in SIMATIC iMap, and you may skip this step.  

Additional information 
Detailed information can be found in the online help for this dialog or in the 
SIMATIC iMap help topics under "Assign PG/PC".  
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3.3.5.2 Set the PG/PC Interface to TCP/IP 

How to set the PG/PC interface to TCP/IP 
 

Task Procedure 

1. Select the start menu command Start > SIMATIC > SIMATIC NET > Settings > PG/ PC 
Interface and check the following setting: 

"TCP/IP" must be set as the access point for the "S7ONLINE (STEP 7)" application. 

 

 
2. Select the start menu command Start > SIMATIC > SIMATIC NET > Settings > Set PC 

Station. 

The configuration console opens. 
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Task Procedure 
3. In the SIMATIC NET configuration, select the Ethernet module of the computer. 

 

 
The "PG mode" operating mode must be set under "General".  

4. Accept any changes and close the configuration console. 
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3.3.5.3 Assigning the PG/PC 

Note 
The PG/PC assignment in SIMATIC iMap is automatically performed during the 
initial generation and anytime the project is newly generated. In special cases it 
may not be possible to automatically assign the PG/PC, for example: 

• When several network cards are installed in the PG/PC or  

• When the PG/PC interface S7ONLINE (STEP 7) is not set to TCP/IP 

In such situations an error is reported during generation and you must perform the 
PG/PC assignment as described in the following. 

The PG/PC assignment is not necessary when you are using a local WinLC PN 
which contains a network card in its configuration. 

How to assign the PG/PC interface to the SIMATIC iMap project 
 

Task Procedure 

1. Open the SIMATIC iMap project. Select any device from the SIMATIC iMap net view, then 
select Special > Assign PG/PC from the context menu. This is necessary to be able to 
perform the program download to the intelligent PROFIBUS devices. 

2. In the "Interfaces" tab of the "PG/PC Interface" dialog, press the "New" button and select 
"Industrial Ethernet" from the list. 

 
Click on the "OK" button to confirm your entry. 
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Task Procedure 
3. In the "Properties - Ethernet Interface" dialog, enter the IP address and the subnet mask of the 

local computer and select the Ethernet subnet. 

 

 
4. Click on the "OK" button to confirm your entry. Result: The newly configured interface is 

displayed in the "Interfaces" tab. 
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Task Procedure 
5. In the "Assignment" tab, mark the Ethernet interface you have just configured in the 

"Configured interfaces:" selection field below "Not assigned". In the "Interface parameter 
settings on the PG/PC:" select  

TCP/IP -> <network card used> 

 



Part 2: Commissioning the System 

 Component based Automation, Commissioning Systems 
3-32 A5E00248818-01 

Task Procedure 
6. Confirm by clicking on the "Assign" button. 

Result: The assigned interface is displayed in the "Assigned" field. 

Activate the option "S7ONLINE access". 

The assignment becomes effective by clicking on "OK". 
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3.3.6 Step 5: Commissioning Machine 1 

Requirements 
• See Chapter "Requirements for Commissioning the System" 

• The settings in STEP 7 have been checked. 

• The project has been generated in SIMATIC iMap. 

• The PG/PC must be connected to the CPU 317-2 PN/DP with an Ethernet 
cable. 

• The CPU 317-2 PN/DP must be connected to the DP slaves via PROFIBUS. 

• All device are switched on. 

Tip: Check the generation status. 
Open the project view to determine the generation status of the device. The 
following illustration shows an example of a generation status. 

 
Figure 3-2 Example: Generation status in the project view 

The generation status must be "Created". If it is not, generate the project again with 
the menu command Project > Generate > Control unit > Changes only. 
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How to download the project configuration data to the target systems 
 

Task Procedure 

1. In SIMATIC iMap:  

Select the CPU 317-2 PN/DP the net view. 

Download the data into the device using the command Download Selected Instances > All 
from the context menu. 

2. When the CPU 317-2 PN/DP is in RUN, you will be asked if you wish to stop the device. 

Click on "Yes" to confirm the question. 

Result: The CPU 317-2 PN/DP is set to STOP and the data is downloaded to the device.  

You are then asked if you wish to start the device again. Click on "Yes" to confirm the 
question. 

You can now download the data to the DP slaves. 

3. Select  

• the device in the net view or  

• the technological functions in the plant view  

of the other two PROFInet components, "Processing" and "ET200M_Measuring". 

Download the data into the devices using the command Download Selected Instances > All 
from the context menu. 

For the CPU 314C-2 DP you will be asked the same questions described under Step 2, which 
you should answer with "Yes" in each case. 

 Result: The device are ready for operation. 
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Notes about downloading 
The data must be first downloaded to the DP master with proxy functionality (CPU 
317-2 PN/DP) and then to the corresponding DP slaves. 

The programs must be downloaded to the DP master and DP slaves each time 
changes are made to the PROFIBUS in the project, for example, each time 
PROFIBUS devices are added or removed. 

The program download must first be performed with either: 

• Download Selected Instances > All or 

• Download Selected Instances > Program only 

The interconnections can be subsequently downloaded. 

Additional information... 
Additional information can be found in the basic help of SIMATIC iMap under: 

• Download  

• Generating the Project  
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3.3.7 Step 6: Online Monitoring of Machine 1 

Requirements 
• See Chapter "Requirements for Commissioning the System" 

• The PG/PC must be connected to the PC station or one of the PROFInet 
devices via Ethernet.  

• The settings in STEP 7 have been checked. 

• The project has been generated in SIMATIC iMap. 

• The data has been downloaded to the devices. 

How to switch online view on and off 
 

Task Procedure 

1. Switching online view on/off 
To switch on the online view in SIMATIC iMap: 

• Click on the "Online Monitoring" icon or 

• Select Online > Monitor. 
You are asked if you wish to compare the online and offline program data of the devices. This 
comparison is optional. You can perform it immediately or at a later point in time. 

If you answer with "Yes", the data is compared and the results are displayed in the information 
window. 

Result: The online view of SIMATIC iMap is switched on and any diagnostic information is 
immediately displayed on the devices and technological functions in the diagnostics window. 
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Task Procedure 
2. Displaying online values 

In the plant view of the project select the input "Counter_In" of the "Processing" machine and 
the output "Counter_Out" of the "Coordinator" and then select the menu command Online > 
Plant view > Display online value. The current online value is then displayed at the 
connectors. 

3.  Click again on the "Online Monitoring" icon or select the  

Online > Monitor option to switched off the online view. 
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Displaying diagnostics information 
Diagnostic information is displayed in graphic or text form in SIMATIC iMap if an 
error occurs. 

The diagnostic information for the technological functions is available in the 
"Functions" tab of the diagnostics window. 

Example: You need to download the interconnections for the ET200M. Press the 
"Download" button in the right section of the diagnostics window. 
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The diagnostic information for the devices is available in the "Devices" tab of the 
diagnostics window. 

Example: The device is not available. In this case, you need to check the settings 
and the communication connections. 

Figure 3-3  

Additional information... 
Additional information can be found in the basic help of SIMATIC iMap under: 

• Diagnostics concept in SIMATIC iMap  

• Plant with SIMATIC devices  

• Possible data types and value ranges  
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3.4 Machine 2 

3.4.1 Machine 2, Scanning: IE/PB Link with PROFIBUS DP Slaves 

Configuration of Machine 2 

IE/PB Link

Conveyor
ET 200X

Scan
ET 200S

PROFIBUS 2

Industrial Ethernet

SIMATIC iMap
Engineering PC

Machine 2
Scanning

 
Figure 3-4 Machine 2, Scanning 

Machine 2 consists of the following devices: 

• One IE/PB Link  

A PROFInet device as DP master with proxy functionality for the following 
PROFIBUS devices: 

• ET 200S with IM 151/CPU  

as intelligent DP slave for controlling a scanning station "ET200S_Scan" 

• ET 200X with BM147/CPU  

as intelligent DP slave for controlling a conveyor belt "ET200X_Conveyor" 
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Required steps 
1. Set up the hardware of the plant: 

� IE/PB Link  

� ET 200S with IM151/CPU  

� ET 200X with BM147/CPU  

2. Assigning Addresses 

� Assign an IP address to the IE/PB Link the first time  

� Assign the IM151/CPU and BM 147/CPU a PROFIBUS address the first 
time.  

3. Configure plant in SIMATIC iMap. 

4. Check the settings in STEP 7  

Optional - required for the program download to the target device of the plant 
and for diagnostics of each device. 

5. Commission the plant 

6. Online monitoring of plant with SIMATIC iMap 
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3.4.2 Step 1: Setting up the Hardware for Machine 2 

3.4.2.1 ET 200S with IM151/CPU - Hardware Setup 

Required Hardware 
You will require the following modules:  

 
Qty. Designation Order number 

1x Interface module IM151/7 CPU and terminal 
module, 1 unit  

6ES7 151-7AA10-0AB0 / V2.1 

2 x Terminal module TM-P15S23-A1, 1 unit  6ES7 193-4CC30-0AA0 

2 x Terminal module TM-E15S24-A1, 5 units  6ES7 193-4CA20-0AA0 

2 x Power module PM-E DC24 V, 1 unit  6ES7 138-4CA00-0AA0 

1x 2DI DC24V; High Feature, 2 units 6ES7 131-4BB00-0AB0 

1x 2DO DC24V; 0.5 A; High Feature, 2 units 6ES7 132-4BB00-0AB0 

1x Bus connector  6ES7 972-0BA10-0XA0 

How to set up the ET 200S 
 

Task Procedure 

1. Mount the modules on the rail. 

2. Connect the power supply. 

3. Wire the I/O module. 

4. Connect the PG/PC with the PG cable to the IM151/CPU.  

5. Switch on the power supply of the IM151/CPU. 
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3.4.2.2 ET 200X with BM 147/CPU - Hardware Setup 

Required Hardware 
You will require the following modules:  

 
Qty. Designation Order number 

1x Basic Module BM147/CPU  6ES7 147-1AA10-0XB0 / V2.1 

1x Expansion module DI 4xDC24V 6ES7 141-1BD30-0XA0 

1x Expansion module DO 4xDC24V/0.5A 6ES7 142-1BD30-0XA0 

How to set up the ET 200X 
 

Task Procedure 

1. Mount the modules on the rail.  

2. Connect the power supply. 

3. Wire the I/O module. 

4. Connect the IE/PB Link to the BM147/CPU with the PROFIBUS cable. 

5. Switch the IE/PB Link on if you have not already done so. 
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3.4.2.3 IE/PB Link - Hardware Setup 

Required Hardware 
One network gateway IE/PB Link with the required accessories (see Device 
Manual). 

How to set up 
the IE/PB 
LinkTask 

Procedure 

1. Mount the modules on the rail. 

2. Connect the power supply. 

3. Connect the IE/PB Link to the Ethernet and PROFIBUS. 

4. Switch the power supply on. 
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3.4.3 Step 2: Assigning the Devices with Addresses the First Time 

3.4.3.1 Assigning an IP Address to the IE/PB Link the First Time 

Requirements 
• The IP address of the IE/PB Link must be known.  

• The connector to the Ethernet LAN must be established; no subnet gateway 
(router) should be inserted. 

• The Ethernet connector of the PG/PC must be available from STEP 7; the 
PG/PC interface must be set as follows: 
S7ONLINE [STEP 7] > TCP/IP > <network module>. 
To set the PG/PC interface, select the commandExtras > Set PG/PC 
interface... in the SIMATIC Manager or the Windows start menu command 
Start > SIMATIC > SIMATIC NET > Settings > Set PG-PC interface .  
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How to assign an IP address to the IE/PB Link the first time 

 
Task Procedure 

1. Open the SIMATIC Manager. 

2. Select the command PLC > Assign Ethernet Address. 

3. Click on the "Browse..." button to search the network for accessible modules. 

All accessible stations on the network are displayed. 
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Task Procedure 
4. Select the CP with the right MAC address from list of the available components.  

0.0.0.0 is displayed in the "IP Address" column the first time an address is assigned. 

5. Enter the IP parameters as shown in the following diagram and assign them to the IE/PB Link. 

6. Connect the DP slaves to the IE/PB Link with the PROFIBUS cable. 
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3.4.3.2 Assigning a PROFIBUS Device a PROFIBUS Address the First 
Time 

The first time, you must download the PROFIBUS address from STEP 7 to the 
target device via MPI, if you have not already done so.  

This chapter also applies for the following PROFIBUS devices (central modules as 
intelligent DP slaves): 

• CPU 314C-2 DP 

• IM 151/CPU 

• BM 147/CPU 

 

 Note 
For initial commissioning (as-delivered state), each of these modules can be 
accessed via MPI address 2, HSA 31 and at 187.5 kBps.  

Requirements 
• The CPU must be in STOP. 

• The PG/PC must be connected to the CPU with a PG cable. 
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How to assign a PROFIBUS address to the CPU acting as a DP slave the first 
time 

 
Task Procedure 

1. Set the PG/PC interface to MPI. 

From the Windows taskbar, select Start > SIMATIC > STEP 7 > Set PG/ PC interface. 
Configure the PG/PC interface so that the S7ONLINE (STEP 7) access point is set to MPI: 

 
2. Start SIMATIC Manager and create a temporary project with a SIMATIC 300 station. This 

project will only be used for assigning addresses for the first time. 

3. Open the station hardware configuration and configure the appropriate CPU (CPU 314C-2 DP, 
IM 151/CPU or BM 147/CPU) as a DP slave. You will not need any I/O modules. 

In the object properties for the DP interface, select "DP Slave" operating mode.  

The "Commissioning / Test mode" option must not be active. 
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Task Procedure 
4. Configure the CPU's PROFIBUS interface and set the required PROFIBUS address, e.g.: 

 
5. On the Configuration" tab in the object properties, configure any exchange of data between 

the intelligent DP slave (I slave) and a DP master: 

 
6. Save and compile the station using the Station > Save and Compile menu command. 
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Task Procedure 
7. Select Target System > Download to Module. 

 
Select the CPU from the "Select target module" dialog and click on "OK" to confirm.  
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Task Procedure 
8. In the "Select Node Address" dialog enter the MPI address of the CPU or accept the displayed 

address by pressing "OK". 

 
 Result: The system data including the PROFIBUS address are loaded into the CPU. The CPU 

can now communicate via PROFIBUS. 

If the red error LED lights up, you can ignore it since the correct hardware configuration will 
subsequently be downloaded from SIMATIC iMap. 
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3.4.4 Step 3: Configuring Machine 2 with SIMATIC iMap 

3.4.4.1 Configuring the Plant - Basic Procedure 

This procedure can be carried out independent of the hardware setup for the plant.  

Requirements 
You have created the PROFInet components and they are present in the file 
system. 

Basic procedure 
• Creating a new project in SIMATIC iMap 

• Importing PROFInet components from the file system into the project library 

• Inserting PROFInet components from the library into the SIMATIC iMap project 

• Assigning Addresses 

• Interconnecting the technological functions and generating the SIMATIC iMap 
project 
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3.4.4.2 Creating a New Project in SIMATIC iMap 
This description applies to both a complete plant or any subplant. 

How to create a new SIMATIC iMap project 
 

Task Procedure 

1. Start SIMATIC iMap if you have not already done so: 

Double-click on the SIMATIC iMap icon on the desktop or 

Select Start / Programs / Component based Automation / SIMATIC iMap. 

Result: SIMATIC iMap is started and a new project is created. Continue with Step 3. 

2. If you have already started SIMATIC iMap, create a new project by selecting the menu 
command Project > New.  

3. Save the project by selecting the menu command Project > Save. 

4. In the dialog "Save SIMATIC iMap project As", select a folder and enter a name, for example, 
"Machine_1" in the "File name" field. The same applies to Machine 2, Machine 3 or the 
complete plant. 

Result: The project is saved. 
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3.4.4.3 Machine 2: Importing PROFInet Components 

How to import PROFInet components into the project library 
 

Task Procedure 

1. Import the PROFInet component from the file system into the project library. 

Open the library window in SIMATIC iMap by selecting the menu command View > Library 
Window. 

2. Click on the "Project Library" window and select Import components from the context menu. 

3. Under �Search in�, select the path Program\Siemens\iMap\CBA_Tutorial\components. 

4. Select the folder "et200s_scan--{...}�.  

5. Select the file "ET200S_Scan.xml" and confirm your entry by pressing the "Open" button. 

Result: The PROFInet "ET200S_Scan" component is entered into the project library. 

6. Repeat Steps 2 to 5 for the PROFInet components "ET200X_Conveyor" ("et200x_conveyor--
{...}" folder and the "ET200X_Conveyor.xml" file). 

Result: The PROFInet "ET200X_Conveyor" component is entered into the project library. 

7. Repeat Steps 2 to 5 for the preassembled PROFInet components of the IE/PB Link. They are 
located under imap\components\IE-PB-Link_PN_1,5MBaud-{} in the installation directory of 
SIMATIC iMap. Select the file "IE-PB-Link PN 1_5MBaud.xml". 
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Task Procedure 
8. Result: The PROFInet "IE-PB-Link PN 1_5MBaud" component is entered into the project 

library.  
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3.4.4.4 Inserting the PROFInet Components into the Project 

How to insert instances of PROFInet components into the project 
 

Task Procedure 

1. Insert an instance of the IE/PB Link into the project: 

Open the net view of the project. Select "IE-PB-Link 1_5MB" in the project library and drag the 
icon into the net view. An instance of the PROFInet component is inserted into the project. 

 
The PROFInet device is automatically connected to the Ethernet in the net view and has a 
PROFIBUS connector as DP master with proxy functionality. 

2. Select the PROFInet "ET200S_Scan" component in the project library and connect it to the 
PROFIBUS of the IE/PB Link using Drag and Drop. 

3. Repeat Step 2 for the PROFInet "ET200X_Conveyor" component.  
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3.4.4.5 Assigning Addresses 

How to assign addresses to devices. 
 

Task Procedure 

1. In the net view, open the properties of the IE/PB Link and enter the IP addresses and subnet 
mask together with PROFIBUS address of the device in the "Addresses" tab. 

 
2. In the net view, open the properties of the PROFIBUS device "IM151_CPU" (ET 200S) and 

enter the PROFIBUS address of the device, e.g. 5, in the "Addresses" tab. 

3. Repeat Step 2 for "BM 147" and assign the device the PROFIBUS address, 18, for example. 
Machine 2 should then appear as follows in the net view: 
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 Note 
The addresses must match those set on the target devices. The addresses of the 
IE/PB Link are first assigned with STEP 7 via Ethernet. The PROFIBUS addresses 
of the IM 151/CPU and BM 147/CPU are assigned for the first time from STEP 7 
via MPI (see "Step 2: Assigning addresses to the devices for the first time").  

3.4.4.6 Interconnecting Technological Functions and Generating the 
Project 

How to interconnect technological functions and generate the project 
 

Task Procedure 

1. Open the plant view. The technological functions are arranged on top of one another at first: 
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Task Procedure 
2. Arrange the technological functions and connect them as shown in the following illustration: 

 

 

 

How to generate the project 
 

Task Procedure 

1. Generate the project  

• with the menu command Project > Generate > Control unit > Changes only or 

• by clicking on the "Generate" icon  

If the project has not yet been saved, you are prompted to give the project a name. In the 
dialog "Save SIMATIC iMap project As", select a folder and enter a name, for example, 
"Machine 2".  

 Result: The project is saved and generated. 

2. Follow the progress of the generation in the information window of the "Generate" tab. 

 

 
 Result: The plant is configured. It can now be put into operation. 
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Additional information... 
Additional information can be found in the basic help of SIMATIC iMap under: 

• Interconnecting Technological Functions  

• Generating the Project  

3.4.5 Step 4: Checking the Settings for Downloading and Online 
Monitoring on the Engineering Station 

3.4.5.1 Required Settings on the Engineering Station for Machine 2 

Requirements 
• See Chapter "Requirements for Commissioning the System" 

• The PG/PC must be connected to the IE/PB Link with an Ethernet cable. 

Check your settings 
Check the following settings: 

• Set the PG/PC Interface to TCP/IP  

• Assigning the PG/PC  

 

 Note 
The PG/PC only has to be assigned in special situations, e.g.: 

When several network cards are installed in the PG/PC or  

If the PG/PC interface S7ONLINE (STEP 7) is not set to TCP/IP.  

Otherwise the PG/PC assignment runs automatically when the project is generated 
in SIMATIC iMap, and you may skip this step. 

Additional information 
Detailed information can be found in the online help for this dialog or in the 
SIMATIC iMap help topics under "Assign PG/PC". 
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3.4.5.2 Set the PG/PC Interface to TCP/IP 

How to set the PG/PC interface to TCP/IP 
 

Task Procedure 

1. Select the start menu command Start > SIMATIC > SIMATIC NET > Settings > PG/ PC 
Interface and check the following setting: 

"TCP/IP" must be set as the access point for the "S7ONLINE (STEP 7)" application. 

 

 
2. Select the start menu command Start > SIMATIC > SIMATIC NET > Settings > Set PC 

Station. 

The configuration console opens. 
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Task Procedure 
3. In the SIMATIC NET configuration, select the Ethernet module of the computer. 

 

 
The "PG mode" operating mode must be set under "General".  

4. Accept any changes and close the configuration console. 
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3.4.5.3 Assigning the PG/PC 

Note 
The PG/PC assignment in SIMATIC iMap is automatically performed during the 
initial generation and anytime the project is newly generated. In special cases it 
may not be possible to automatically assign the PG/PC, for example: 

• When several network cards are installed in the PG/PC or  

• When the PG/PC interface S7ONLINE (STEP 7) is not set to TCP/IP 

In such situations an error is reported during generation and you must perform the 
PG/PC assignment as described in the following. 

The PG/PC assignment is not necessary when you are using a local WinLC PN 
which contains a network card in its configuration. 

How to assign the PG/PC interface to the SIMATIC iMap project 
 

Task Procedure 

1. Open the SIMATIC iMap project. Select any device from the SIMATIC iMap net view, then 
select Special > Assign PG/PC from the context menu. This is necessary to be able to 
perform the program download to the intelligent PROFIBUS devices. 

2. In the "Interfaces" tab of the "PG/PC Interface" dialog, press the "New" button and select 
"Industrial Ethernet" from the list. 

 
Click on the "OK" button to confirm your entry. 
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Task Procedure 
3. In the "Properties - Ethernet Interface" dialog, enter the IP address and the subnet mask of the 

local computer and select the Ethernet subnet. 

 

 
4. Click on the "OK" button to confirm your entry. Result: The newly configured interface is 

displayed in the "Interfaces" tab. 
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Task Procedure 
5. In the "Assignment" tab, mark the Ethernet interface you have just configured in the 

"Configured interfaces:" selection field below "Not assigned". In the "Interface parameter 
settings on the PG/PC:" select  

TCP/IP -> <network card used> 
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Task Procedure 
6. Confirm by clicking on the "Assign" button. 

Result: The assigned interface is displayed in the "Assigned" field. 

Activate the option "S7ONLINE access". 

The assignment becomes effective by clicking on "OK". 
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3.4.6 Step 5: Commissioning Machine 2 

Requirements 
• See Chapter "Requirements for Commissioning the System" 

• The PG/PC must be connected to the IE/PB Link with an Ethernet cable. 

• The IE/PB Link must be connected to the DP slaves with an Ethernet cable. 

• The settings in STEP 7 have been checked. 

• The project has been generated in SIMATIC iMap. 

• All device are switched on. 

Tip: Check the generation status. 
To determine the generation status of the device, open the properties of the  

• Device in the net view or 

• Technological function in the plant view 

 
 

The generation status must be "Created". If it is not, generate the project again with 
the menu command Project > Generate > Control unit > Changes only. 
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How to download the project configuration data to the target system 
 

Task Procedure 

1. In SIMATIC iMap:  

Select the IE/PB Link in the net view. 

Download the data into the device using the command Download Selected Instances > All 
from the context menu. 

2. When the IE/PB Link is in RUN, you will be asked if you wish to stop the device. 

Click on "Yes" to confirm the question. 

Result: The device is set to STOP and the data is downloaded to the device.  

You are then asked if you wish to start the device again. Click on "Yes" to confirm the 
question. 

You can now download the data to the DP slaves. 

3. Select  

• the device in the net view or  

• the technological functions in the plant view  

of the other two PROFInet components, "ET200S_Scan" and "ET200X_Conveyor". 

Download the data into the devices using the command Download Selected Instances > All 
from the context menu. 

For the each device you will be asked the same questions described under Step 2, which you 
should answer with "Yes" in each case. 

 Result: The devices are ready for operation and can be monitored online. 
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Notes about downloading 
The data must be first downloaded to the PROFInet device with proxy functionality 
(IE/PB Link) and then to the corresponding DP slaves. 

The programs must be downloaded to the DP master and DP slaves each time 
changes are made to the PROFIBUS in the project, for example, each time 
PROFIBUS devices are added or removed. 

The program download must first be performed with either: 

• Online > Download Selected Instances > All or 

• Online > Download Selected Instances > Program only 

The interconnections can be subsequently downloaded. 

Additional information... 
Additional information can be found in the basic help of SIMATIC iMap under: 

• Download  

• Generating the Project  

3.4.7 Step 6: Online Monitoring of Machine 2 

You can use SIMATIC iMap to  

• Perform online monitoring and diagnostics of the devices of the plant 

• Set and display online values 

• Test the plant using the variable table 

Requirements 
• See Chapter "Requirements for Commissioning the System" 

• The PG/PC must be connected to the IE/PB Link or one of the PROFInet 
devices via Ethernet.  

• The settings in STEP 7 have been checked. 

• The project has been generated in SIMATIC iMap. 

• The data has been downloaded to the devices. 

• The devices must be in the RUN operating state. 
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How to switch online view on and off 
 

Task Procedure 

1. Switching online view on/off 
To switch on the online view in SIMATIC iMap: 

Click on the "Online Monitoring" icon or 

Select Online > Monitor. 
You are asked if you wish to compare the online and offline program data of the devices. This 
comparison is optional. You can perform it immediately or at a later point in time. 

If you answer with "Yes", the data is compared and the results are displayed in the information 
window. 

Result: The online view of SIMATIC iMap is switched on and any diagnostic information is 
immediately displayed on the devices and technological functions in the diagnostics window. 
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Task Procedure 
2. Display online values 

In the plant view of the project select the input "Counter_In" of the "ET200X_Conveyor" and 
the output "Counter_Out" of the "ET200S_Conveyor" and then select the menu command 
Online > Plant view > Display online value. The current online value is then displayed at the 
connectors. 

3. Click again on the "Online Monitoring" icon or select the Online > Monitor  option to switch off 
the online view.. 
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Displaying diagnostics information 
Diagnostic information is displayed in graphic or text form in SIMATIC iMap if an 
error occurs. 

The diagnostic information for the technological functions is available in the 
"Functions" tab of the diagnostics window. 

Example: Interconnection download required Press the "Download" button in the 
right section of the diagnostics window. 

 



Part 2: Commissioning the System 

 Component based Automation, Commissioning Systems 
3-74 A5E00248818-01 

The diagnostic information for the devices is available in the "Devices" tab of the 
diagnostics window. 

Example: The device reports an error. In this case, press the "Diagnostics" button 
to start a diagnostic routine for the device. 

 

Additional information... 
Additional information can be found in the basic help of SIMATIC iMap under: 

• Diagnostics concept in SIMATIC iMap  

• Plant with SIMATIC devices  

• Possible data types and value ranges  
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3.5 Machine 3 

3.5.1 Machine 3, Packaging: CPU 315 with CP 343-1 PN 

Configuration of Machine 3 

Packaging
CPU 315-2 DP + CP 343-1 PN

Industrial Ethernet

SIMATIC iMap
Engineering PC

Machine 3
Packaging

 
Figure 3-5 Machine 3, Packaging 

Machine 3 consists of one PROFInet component. In the following example, this 
PROFInet component is used to control a packaging station. The PROFInet 
component includes:  

• PROFInet device  

including one CPU 315-2 DP, one CP 343-1 PN and the appropriate I/O 
modules 

• Technological function "Packaging"  

consisting of the S7 program with the technological interface. 

Required steps 
1. Set up the hardware of the plant 

2. Assign an IP address to the device the first time 

3. Configure plant in SIMATIC iMap.  

4. Check the settings in STEP 7  

Optional - required for the program download to the target device of the plant 
and for diagnostics of each device. 

5. Commission the plant  

6. Online monitoring of plant with SIMATIC iMap 
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3.5.2 Step 1: Setting up the Hardware of Machine 3 

Required Hardware 
You will need the following S7-300 modules: 

 
Qty. Designation Order number 

1x Central module CPU 315-2 DP 6ES7 315-2AF03-0AB0  

1x Power supply module PS 307 5A 6ES7 307-1EA00-0AA0 

1x Communication processor CP 343-1 PN 6GK7 343-1HX00-0XE0  

1x I/O modules DI8/DO8xDC24V/0.5A 6ES7 323-1BH01-0AA0 

How to setup the hardware 
 

Task Procedure 

1. Mount the modules on the rail. 

2. Connect the CP 343-1 PN to the backplane bus using the bus connector. 

3. Connect the power supply. 

4. Wire the I/O module. 

5. Connect the Ethernet cable to the CP 343-1 PN. 
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3.5.3 Step 2: Assigning the CP 343-1 PN an IP Address the First Time 

Requirements 
• The IP address of the CP 343-1 PN must be known.  

• The connector to the Ethernet LAN must be established; no subnet gateway 
(router) should be inserted. 

• The Ethernet connector of the PG/PC must be available from STEP 7; the 
PG/PC interface must be set as follows: 
S7ONLINE [STEP 7] > TCP/IP > <network module>. 
To set the PG/PC interface, select the commandExtras > Set PG/PC 
interface... in the SIMATIC Manager or the Windows start menu command 
Start > SIMATIC > SIMATIC NET > Settings > Set PG-PC interface. 
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How to assign an IP address to the CP 343-1 PN the first time 
 

Task Procedure 

1. Open the SIMATIC Manager. 

2. Select the command PLC > Assign Ethernet Address. 

3. Click on the "Browse..." button to search the network for accessible modules. 

All accessible stations on the network are displayed. 
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Task Procedure 
4. Select the CP with the right MAC address from list of the available components. 0.0.0.0 is 

displayed in the "IP Address" column the first time an address is assigned. 

5. Enter the IP parameters as shown in the following diagram and assign them to the CP 343-
1 PN. 
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3.5.4 Step 3: Configuring Machine 3 with SIMATIC iMap 

3.5.4.1 Configuring the Plant - Basic Procedure 

This procedure can be carried out independent of the hardware setup for the plant.  

Requirements 
You have created the PROFInet components and they are present in the file 
system. 

Basic procedure 
• Creating a new project in SIMATIC iMap 

• Importing PROFInet components from the file system into the project library 

• Inserting PROFInet components from the library into the SIMATIC iMap project 

• Assigning Addresses 

• Interconnecting the technological functions and generating the SIMATIC iMap 
project 
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3.5.4.2 Creating a New Project in SIMATIC iMap 

This description applies to both a complete plant or any subplant. 

How to create a new SIMATIC iMap project 
 

Task Procedure 

1. Start SIMATIC iMap if you have not already done so: 

Double-click on the SIMATIC iMap icon on the desktop or 

Select Start / Programs / Component based Automation / SIMATIC iMap. 

Result: SIMATIC iMap is started and a new project is created. Continue with Step 3. 

2. If you have already started SIMATIC iMap, create a new project by selecting the menu 
command Project > New.  

3. Save the project by selecting the menu command Project > Save. 

4. In the dialog "Save SIMATIC iMap project As", select a folder and enter a name, for example, 
"Machine_1" in the "File name" field. The same applies to Machine 2, Machine 3 or the 
complete plant. 

Result: The project is saved. 
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3.5.4.3 Machine 3: Importing PROFInet Component into the Project 
Library 

How to import the PROFInet component into the project library 
 

Task Procedure 

1. Import the PROFInet component from the file system into the project library. 

In SIMATIC iMap, click on the "Project Library" window and select Import components from 
the context menu. 

2. Under �Search in�, select the path Program\Siemens\iMap\CBA_Tutorial\Components.  

3. Select the "packaging--{...}" folder.  
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Task Procedure 
4. Select the file "packaging.xml" and confirm your entry by pressing the "Open" button. 

Result: The PROFInet Packaging" component is entered into the project library and can now 
be used in the project. 
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3.5.4.4 Machine 3: Inserting PROFInet Component into the Project and 
Assigning Addresses 

How to insert an instance of the PROFInet component into the project 
 

Task Procedure 

1. Open the net view of the project. Select "Packaging" in project library and drag the icon into 
the net view. An instance of the PROFInet component is inserted into the project. 

The PROFInet device is automatically connected to Ethernet in the net view. 

 
The technological function is displayed in the plant view: 

 
2. Optional - Repeat Step 1 for additional PROFInet components, e.g. ET200X_Conveyor. 
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How to assign the IP address to the device 
 

Task Procedure 

1. Mark the CPU 315-2 DP device in the net view, then select Properties... from the context 
menu. 

2. Enter the IP address and the subnet mask in the "Properties" dialog of the PROFInet device. 

 
Result: The assigned IP address is displayed for the device in the net view. 

 

 Note 
The IP address must match the address set on the target device. The IP address 
of the CP 343-1 PN is assigned with STEP 7 via Ethernet the first time (see "Step 
2: Assigning the CP 343-1 PN an IP Address the First Time"). 
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3.5.4.5 Machine 3: Interconnecting Technological Functions and 
Generating the Project 

The interconnection is not necessary for Machine 3 since the project only contains 
one PROFInet component. 

How to generate the project 
 

Task Procedure 

1. Generate the project: 

• with the menu command Project > Generate > Control unit > Changes only or 

• by clicking on the "Generate" icon 

If the project has not yet been saved, you are prompted to give the project a name. In the 
dialog "Save SIMATIC iMap project As", select a folder and enter a name, for example, 
"Machine_3". 

Result: The project is saved and generated. 

2. Follow the progress of the generation in the information window of the "Generate" tab. 

 

 
3. Result: Machine 3 is configured. It can now be put into operation. 
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3.5.5 Step 4: Checking the Required Settings on the Engineering Station 
for Machine 3 

3.5.5.1 Checking the Required Settings on the Engineering Station for 
Machine 3 

Requirements 
• See Chapter "Requirements for Commissioning the System" 

• The PG/PC must be connected to the CP 343-1 PN with an Ethernet cable. 

Check your settings  
Check if the PG/PC interface is set to TCP/IP. 
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3.5.5.2 Set the PG/PC Interface to TCP/IP 

How to set the PG/PC interface to TCP/IP 
 

Task Procedure 

1. Select the start menu command Start > SIMATIC > SIMATIC NET > Settings > PG/ PC 
Interface and check the following setting: 

"TCP/IP" must be set as the access point for the "S7ONLINE (STEP 7)" application. 

 

 
2. Select the start menu command Start > SIMATIC > SIMATIC NET > Settings > Set PC 

Station. 

The configuration console opens. 
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Task Procedure 
3. In the SIMATIC NET configuration, select the Ethernet module of the computer. 

 

 
The "PG mode" operating mode must be set under "General".  

4. Accept any changes and close the configuration console. 

 

 



Part 2: Commissioning the System 

 Component based Automation, Commissioning Systems 
3-90 A5E00248818-01 

3.5.6 Step 5: Commissioning Machine 3 

Requirements 
• See Chapter "Requirements for Commissioning the System" 

• The PG/PC must be connected to the CP 343-1 PN with an Ethernet cable. 

• The settings in the engineering station have been checked. 

• The project has been generated in SIMATIC iMap. 

• All device are switched on. 

Tip: Check the generation status 
To determine the generation status of the device, open the properties of the  

• Device in the net view or 

• Technological function in the plant view 

 
Figure 3-6 Generation status "Created" 

The generation status must be "Created". If it is not, generate the project again with 
the menu command Project > Generate > Control unit > Changes only. 
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How to download the project configuration data to the device 

Task Procedure 

1. In SIMATIC iMap select  

• the device in the net view or 

• the technological functions in the plant view 

and download the data into the device using the command  
Download Selected Instances > All from the context menu. 

 
2. When the CP 343-1 PN is in RUN, you will be asked if you wish to stop the device. 

Click on "Yes" to confirm the question. 

Result: The device is set to STOP and the data is downloaded to the device.  

You are then asked if you wish to start the device again.  

Click on "Yes" to confirm the question. 

 Result: The device is ready for operation and can be monitored online. 

 

Additional information... 
Additional information can be found in the basic help of SIMATIC iMap under: 

• Download  

• Generating the Project 
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3.5.7 Step 6: Online Monitoring of Machine 3 

You can use SIMATIC iMap to  

• Perform online monitoring and diagnostics of the devices of the plant 

• Set and display online values 

Requirements 
• See Chapter "Requirements for Commissioning the System" 

• The PG/PC must be connected to the PROFInet device via Ethernet.  

• The settings in STEP 7 have been checked. 

• The project has been generated in SIMATIC iMap. 

• The data has been downloaded to the device. 

• The devices must be in the RUN operating state. 
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How to switch online view on and off 
 

Task Procedure 

1. Switching online view on/off 
To switch on the online view in SIMATIC iMap: 

• Click on the "Online Monitoring" icon or 

• Select Online > Monitor. 
You are asked if you wish to compare the online and offline program data of the devices. This 
comparison is optional. You can perform it immediately or at a later point in time. 

If you answer with "Yes", the data is compared and the results are displayed in the information 
window. 

Result: The online view of SIMATIC iMap is switched on and any diagnostic information is 
immediately displayed on the devices and technological functions in the diagnostics window. 

2. Click again on the "Online Monitoring" icon or select the option Online > Monitor  to switch of 
the online view. 

 

Additional information... 
Additional information can be found in the basic help of SIMATIC iMap under: 

• Diagnostic information in the online view 

• Plant with SIMATIC devices  

• Possible data types and value ranges  
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3.6 Plant Control 

3.6.1 Plant Control with WinLC PN 

The central "Plant Control" is a PC station with WinLC PN. There are two 
configuration variants based on the position of the WinLC PN. 

Configuration variant 1 
STEP 7 and SIMATIC iMap are on the local engineering station and WinLC PN is 
on a remote computer. 

Industrial Ethernet

Plant Control
WinLC PN

SIMATIC iMap
Engineering PC

 
Figure 3-7 Configuration variant 1, with remote WinLC PN 

Configuration variant 2 
STEP 7, SIMATIC iMap and WinLC PN are on a single computer, the local 
engineering station. 

Industrial Ethernet

Plant Control
WinLC PN

SIMATIC iMap
Engineering PC

 
Figure 3-8 Configuration variant 2, with local WinLC PN 
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Basic procedure 
You need to perform the following steps:  

• Setup the hardware of the PC station  

• Configure plant in SIMATIC iMap.  

• Check the settings in STEP 7 

• Commission the plant  

• Online monitoring of plant with SIMATIC iMap  

3.6.2 Step 1: Plant Control - Hardware Setup 

Required Hardware 
• PC with Windows 2000 as of SP4 or Windows XP as of SP1 

• PROFIBUS connector, e.g. via CP 5611 

How to set up the hardware for the WinLC PN 
 

Task Procedure 

1. Only Plants 3-1: Connect the PC to the local engineering station via Ethernet. 

2. Connect the PC to the IM151/CPU with the PROFIBUS cable.  
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3.6.3 Step 2: Configuring the Plant Control in SIMATIC iMap 

The basic procedure is similar to that described for Machine 1, Step 2. 

Requirements 
You have created the "Plant Control" PROFInet component and it is present in the 
file system. 

How to configure the plant control 
 

Task Procedure 

1. Create a new project in SIMATIC iMap or use an existing project, for example, Machine_1. 

2. Import the PROFInet Plant Control" component from the file system into the project library. 
Click on the "Project Library" window and select Import components from the context menu.  

The preassembled PROFInet component is available under  
\iMap\CBA_Tutorial\components.  

3. Drag the "Plant Control" component from the library into the net view of the project. 

4. Assign addresses to the WinLC PN. Open the properties of the WinLC PN in the net view. On 
the "Addresses" tab, enter the IP address and subnet mask of the PC station and the 
PROFIBUS address of the device (only for PROFInet devices with proxy functionality), as 
shown in the illustration below: 

 
5. When the WinLC PN is located on the local engineering station: 

In the "Name" field" of the "Instance" tab, enter the station name for the local PC station, e.g. 
"WinLC PN". 

6. Optional: Interconnect the "Plant Control" technological function with additional functions in the 
plant view. 

7. Generate the project with the menu command Project > Generate > Controller Unit > 
Changes only. 

 Result: The "Plant Control" subplant is now configured in SIMATIC iMap. 
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3.6.4 Step 3: Checking the Settings for Downloading and Online 
Monitoring 

3.6.4.1 Checking the Required Settings on the Engineering Station 

There are two different cases: 

• Settings for configuration variant 1: STEP 7 and SIMATIC iMap are on the local 
engineering station and WinLC PN is on a remote computer. 

• Settings for configuration variant 2: STEP 7, SIMATIC iMap and WinLC PN are 
on a single computer, the local engineering station. 

Settings for configuration variant 1 
Check the following settings: 

• On the local engineering PG/PC (with STEP 7 and SIMATIC iMap): 

� Set the PG/PC interface to TCP/IP (see Chapter "Set the PG/PC interface to 
TCP/IP") 

� Assign PG/PC (only if the WinLC PN is configured as a PROFInet device 
with proxy functionality and PROFIBUS devices are connected, see the 
section entitled "Assign PG/PC" for machine 1 or 2) 

• Settings on the PC with WinLC PN 

� Set the PG/PC interface to PC internal 

� Configuration console "Set PC station"  

(See Chapter "Settings on the PC with WinLC PN ") 

Settings for configuration variant 2 
Check the following settings on the PC with the WinLC PN 

• Set the PG/PC interface to PC internal 

• Configuration console "Set PC station" 

(See Chapter "Settings on the PC with WinLC PN ") 

 



Part 2: Commissioning the System 

 Component based Automation, Commissioning Systems 
3-98 A5E00248818-01 

3.6.4.2 Set the PG/PC Interface to TCP/IP 

How to set the PG/PC interface to TCP/IP 
 

Task Procedure 

1. Select the start menu command Start > SIMATIC > SIMATIC NET > Settings > PG/ PC 
Interface and check the following setting: 

"TCP/IP" must be set as the access point for the "S7ONLINE (STEP 7)" application. 

 

 
2. Select the start menu command Start > SIMATIC > SIMATIC NET > Settings > Set PC 

Station. 

The configuration console opens. 
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Task Procedure 
3. In the SIMATIC NET configuration, select the Ethernet module of the computer. 

 

 
The "PG mode" operating mode must be set under "General".  

4. Accept any changes and close the configuration console. 
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3.6.4.3 Settings on the PC with WinLC PN 

These settings apply to the PC with the WinLC PN in the configuration 
variants 1 and 2. 

Requirements 
• See Chapter "Requirements for Commissioning the System" 

• The software package "WinLC PN V1.1 must be installed on the local PC. 

 

 Note 
When a WinLC PN is located on the local engineering station, the online 
connection between SIMATIC iMap and the plant devices is controlled with the 
station manager of the WinLC PN. The local PC station must therefore be 
configured for this. 

How to configure the local PC station 
 

Task Procedure 

1. Open the component wizard using  

• the icon on the taskbar or 

• Start > Program > Autostart > Component wizard. 

2. Ensure that 

• the station name of the local engineering station where the WinLC PN is located is 
identical to the device name of the "Processing_A" component in the net view of 
SIMATIC iMap and 

• the index of the IE_CP is the same as the CP "IE General" slot in the component project in 
STEP 7/HW Config. 

 
3. Select the start menu command Start > SIMATIC > SIMATIC NET > Settings > Set PC 

Station. 

The configuration console opens. 
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Task Procedure 
4. Under "Modules" in the "Structure" window, select the Ethernet module of the computer. 

The "Configured mode" operating mode must be set under "General". 

The index must be the same as the CP "IE General" slot in the component project in 
STEP 7/HW Config. 

 
5. Optional, for PROFInet devices with proxy functionality only: Select the PROFIBUS module of 

the computer, if present. 

The "PG mode" operating mode must be set under "General". 
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Task Procedure 
6. Select "Access Points" and check the following settings: 

• Optional: The local PROFIBUS module must be set as the access point for the "CP_L2_1" 
application. 

• "PC internal (local)� must be set as the access point for the "S7ONLINE (STEP 7)" 
application. 

 
7. Accept any changes and close the configuration console. 

 

Tip 
You can also set or check the access points using Start > Settings > Control 
Panel > Set PG/PC interface. 
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3.6.5 Step 4: Commissioning the Plant Control 

Requirements 
• See Chapter "Requirements for Commissioning the System" 

• The settings in STEP 7 have been checked. 

• The project has been generated in SIMATIC iMap. 

• The WinLC PN is started. 

• Configuration variant 1 only: The local engineering station is connected to the 
remote PC (PC station with WinLC PN) via Ethernet.  

• Optional: The PC station with WinLC PN may be connected to any DP slaves 
via PROFIBUS. 

How to download the project configuration data to the WinLC PN 
 

Task Procedure 

1. In the net view of SIMATIC iMap, mark the WinLC PN and select Download Selected 
Instances > All in the context menu.  

2. When the WinLC PN is in RUN, you will be asked if you wish to stop the device. Click on "Yes" 
to confirm the question.  

Result: The device is set to STOP and the data is downloaded to the device.  

You are then asked if you wish to start the device again. Click on "Yes" to confirm the 
question.  

3. When PROFIBUS devices are connected to the PROFIBUS of the WinLC PN, perform a 
download to the target devices. Mark the PROFIBUS devices and select the command 
Download Selected Instances > All from the context menu. 

(See also "Commissioning Machine 1, Step 5") 

 Result: The WinLC PN is ready for operation and can be monitored online.  
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3.6.6 Step 5: Online Monitoring of the Plant Control 

Carry out the task described for Machine 3, Step 6. 

3.7 Complete Plant 

3.7.1 Setup of the Complete Plant 

The complete plant consists of Machines 1 to 3 and a central plant control, a PC 
station with WinLC PN (see "Description of the Complete Plant").  

Machine 1
Processing

Machine 2
Scanning

Machine 3
Packaging

Scan
ET 200S

Plant Control
WinLC PN

Coordinator
CPU 317-2 PN/DP

Packaging
CPU 315-2 DP + CP 343-1 PN

Measuring
    ET 200M

Conveyor
ET 200X

IE/PB Link

Processing
CPU 314C-2 DP

Industrial Ethernet

PROFIBUS 1 PROFIBUS 2

SIMATIC iMap
Engineering PC

Figure 3-9 Complete plant 



Part 2: Commissioning the System 

Component based Automation, Commissioning Systems 
A5E00248818-01 3-105 

3.7.2 Step 1: Complete Plant - Hardware Setup 

You can configure Machines 1 to 3 together with the WinLC PN plant control to 
form a combined complete plant.  

How to set up the hardware for the complete plant 
 

Task Procedure 

1. Setup the devices as described for Machines 1 to 3. 

2. Install WinLC PN on the remote or local PC and start it. 

3. Connect the CPU 317-2 PN/DP, the CP 343-1 PN, the IE/PB Link and the PC station of the 
WinLC PN via Ethernet. 

4. Connect the engineering PC (with SIMATIC iMap) to the above devices via Ethernet. 

3.7.3 Step 2: Configuring the Complete Plant 

How to Configure the Complete Plant 
 

Task Procedure 

1. Start SIMATIC iMap and ensure that a library is open containing all PROFInet components of 
three plants. You have the following possibilities: 

• Open a new project with Project > New and open the global library �tutorial_lib� with 
Library > Open or 

• Open an existing project, e.g. "Machine_1" and import the missing PROFInet components 
into the project library with the command Library > Import components.  

The global library "Tutorial_Lib" is available in the download directory of the tutorial. 

2. Save the project with the command Project > Save as with the name "Tutorial_Plant", for 
example. 

3. Drag the PROFInet components from the library into the net view of the project in the following 
order: 

• Plant_Control (WinLC PN) 

• Coordinator (CPU 317-2 PN/DP) 

• Processing to the PROFIBUS of the CPU 317-2 PN/DP 

• ET200M_Measuring to the PROFIBUS of the CPU 317-2 PN/DP 

• IE-PB-Link 1_5MB 

• ET200S_Scan to the PROFIBUS of the IE/PB Link 

• ET200X_Conveyor to the PROFIBUS of the IE/PB Link 

• Packaging 
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Task Procedure 
4. Assign the devices the IP or PROFIBUS addresses, as described for Machines 1 to 3 and the 

Plant Control. 

The project should then appear as follows in the net view: 
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Task Procedure 
5. In the plant view, arrange and connect the technological functions as shown in the following 

illustration: 

The interconnection lines on the plant are converted into communication links so that the data 
can be transferred via Industrial Ethernet and PROFIBUS.. The value of the Counter_Out 
output is sent to the Counter_In input, etc. 

6.  Generate the project with the command Project > Generate > Controller Unit > Changes 
only. 

 Result: The complete plant is now configured in SIMATIC iMap. 

The generation status of the instances are displayed in the project view. 
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Additional information... 
Additional information can be found in the basic help of SIMATIC iMap under: 

• Interconnecting Technological Functions  

• Generating the Project  

3.7.4 Step 3: Checking the Required Settings for Downloading and Online 
Monitoring on the Engineering Station 

3.7.4.1 Checking the required settings in the engineering station for the 
overall plant 

 

Requirements 
• See Chapter "Requirements for Commissioning the System" 

• The PG/PC must be connected to one of the PROFInet devices, e.g. the 
CPU 317-2 PN/DP, via Ethernet.  

Check your settings 
Check the following settings:  

• Set the PG/PC Interface to TCP/IP  

• Assigning the PG/PC 

 

 Note 
The PG/PC only has to be assigned in special situations, e.g.: 

- If several network cards are installed in the PG/PC or  

- If the PG/PC interface S7ONLINE (STEP 7) is not set to TCP/IP.  

Otherwise the PG/PC assignment runs automatically when the project is generated 
in SIMATIC iMap, and you may skip this step. 

Additional information 
Detailed information can be found in the online help for this dialog or in the 
SIMATIC iMap help topics under "Assign PG/PC".  
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3.7.4.2 Set the PG/PC Interface to TCP/IP 

How to set the PG/PC interface to TCP/IP 
 

Task Procedure 

1. Select the start menu command Start > SIMATIC > SIMATIC NET > Settings > PG/ PC 
Interface and check the following setting: 

"TCP/IP" must be set as the access point for the "S7ONLINE (STEP 7)" application. 

 

 
2. Select the start menu command Start > SIMATIC > SIMATIC NET > Settings > Set PC 

Station. 

The configuration console opens. 
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Task Procedure 
3. In the SIMATIC NET configuration, select the Ethernet module of the computer. 

 

 
The "PG mode" operating mode must be set under "General".  

4. Accept any changes and close the configuration console. 
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3.7.4.3 Assigning the PG/PC 

Note 
The PG/PC assignment in SIMATIC iMap is automatically performed during the 
initial generation and anytime the project is newly generated. In special cases it 
may not be possible to automatically assign the PG/PC, for example: 

• When several network cards are installed in the PG/PC or  

• When the PG/PC interface S7ONLINE (STEP 7) is not set to TCP/IP 

In such situations an error is reported during generation and you must perform the 
PG/PC assignment as described in the following. 

The PG/PC assignment is not necessary when you are using a local WinLC PN 
which contains a network card in its configuration. 

How to assign the PG/PC interface to the SIMATIC iMap project 
 

Task Procedure 

1. Open the SIMATIC iMap project. Select any device from the SIMATIC iMap net view, then 
select Special > Assign PG/PC from the context menu. This is necessary to be able to 
perform the program download to the intelligent PROFIBUS devices. 

2. In the "Interfaces" tab of the "PG/PC Interface" dialog, press the "New" button and select 
"Industrial Ethernet" from the list. 

 
Click on the "OK" button to confirm your entry. 
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Task Procedure 
3. In the "Properties - Ethernet Interface" dialog, enter the IP address and the subnet mask of the 

local computer and select the Ethernet subnet. 

 

 
4. Click on the "OK" button to confirm your entry. Result: The newly configured interface is 

displayed in the "Interfaces" tab. 
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Task Procedure 
5. In the "Assignment" tab, mark the Ethernet interface you have just configured in the 

"Configured interfaces:" selection field below "Not assigned". In the "Interface parameter 
settings on the PG/PC:" select  

TCP/IP -> <network card used> 
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Task Procedure 
6. Confirm by clicking on the "Assign" button. 

Result: The assigned interface is displayed in the "Assigned" field. 

Activate the option "S7ONLINE access". 

The assignment becomes effective by clicking on "OK". 
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3.7.5 Step 4: Commissioning the Complete Plant 

How to download the project configuration data to the target systems  
 

Task Procedure 

1. In the net view of SIMATIC iMap, mark the PROFInet devices with proxy functionality: 
WinLC PN, CPU 317 2 PN/DP and IE/PB Link. 

Download the data into the devices using the command Download Selected Instances > All 
from the context menu. 

When one of the target devices is in RUN, you will be asked if you wish to stop the device. 
Click on "Yes" to confirm the question. 

Result: The target device is set to STOP and the data is downloaded to the target device.  

You are then asked if you wish to start the device again. Click on "Yes" to confirm the 
question.  

Then you can download the data to the remaining target devices of the plant 

2. Select  

• the device in the net view or  

• the technological functions in the plant view  

the remaining PROFInet components: 

• Packaging/CPU 315-2 DP with CP 343-1 PN 

• Processing/CPU 314C-2 DP 

• ET200S_Scan/IM151_CPU  

• ET200X_Conveyor/BM147_CPU 

• ET200_Measuring/IM 153-1 

Download the data into the devices using the command Download Selected Instances > All 
from the context menu. 

For the CPU 314C-2 DP, IM 151/CPU, BM 147/CPU and CP 343-1 PN you will receive the 
same prompt as in Step 1, which you should always answer with "Yes". 

 Result: The devices are ready for operation and can be monitored online. 
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Notes about downloading 
First, the data must be loaded to the local WinLC PN, then to the DP master with 
proxy functionality (e.g. WinLC PN, CPU 317-2 PN/DP and IE/PB Link) and then to 
the corresponding DP slaves. 

The programs must be downloaded to the DP master and DP slaves each time 
changes are made to the PROFIBUS in the project, for example, each time 
PROFIBUS devices are added or removed. 

The program download must first be performed with either:  

• Online > Download Selected Instances > All or 

• Online > Download Selected Instances > Program only 

The interconnections can be subsequently downloaded. 
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3.7.6 Step 5: Online Monitoring the Complete Plant 

How to switch online view on and off 
 

Task Procedure 

1. Switching online view on/off 
To switch on the online view in SIMATIC iMap:  

• Click on the "Online Monitoring" icon or 

• Select Online > Monitor. 
You are asked if you wish to compare the online and offline program data of the devices. This 
comparison is optional. You can perform it immediately or at a later point in time. 

If you answer with "Yes", the data is compared and the results are displayed in the information 
window. 

Result: The online view of SIMATIC iMap is switched on and any diagnostic information is 
immediately displayed on the devices and technological functions in the diagnostics window. 

 

 



Part 2: Commissioning the System 

 Component based Automation, Commissioning Systems 
3-118 A5E00248818-01 

How to create a variable table 
 

Task Procedure 

1. Open the "Variable table" tab in the diagnostics window of SIMATIC iMap. 

2. Select the "Coordinator" function in the plant view and drag it into the variable table. 

Result: The connectors appear in the lines of the variable table. 

3. You can alternatively mark the individual connectors or all the technological functions and drag 
them into the variable table. 

4. Mark one or more items in the variable table and select Monitor in the context menu. 

Result: The marked items are highlighted with the "Online Monitoring" icon and the current 
online values are displayed in the "Online value" column. 

Additional information... 
Additional information can be found in the basic help of SIMATIC iMap under: 

• Diagnostics concept in SIMATIC iMap  

• Plant with SIMATIC devices  

• Perform online monitoring and diagnostics of variables 
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3.7.7 Analyzing with OPC 

OPC: OLE for Process Control 
In SIMATIC iMap, you can create an OPC symbol file for the project. This file 
contains information about the current process data.  

Anyone in the office can use an OPC client program to access the data for 
PROFInet devices at the control and production levels.  

 
Figure 3-10 Using OPC 

Requirements 
• An OPC client program must be installed, e.g.OPC Scout from SIMATIC Net. 

• The SIMATIC iMap project is open and has been generated without error. 
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How to analyze process data 

Table 3-1 Creating and editing the OPC symbol file 

Step Description 

1. In SIMATIC iMap, select Options > Create OPC Symbol File. 

2. Select a folder as the storage Iocation in the "Save OPC symbol file As" dialog field. 

The OPC symbol file <project name> will be saved in this folder. 

You can then close SIMATIC iMap. 

3. Select the start menu command Start > SIMATIC > SIMATIC NET > Settings > Set PC 
Station. 

The configuration console opens. This is used to make your new OPC symbol file known to a 
SIMATIC NET OPC server. 

In the "Structure" window, open the "Applications, Symbols" folder. 

4. Activate the "Use symbol file" option and enter the path of the symbol file <project name>.sti 
under "File name" (see Step 2). 

Click on the "Browse" button to search for the file. 
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Step Description 
5. Click on the "Extended symbols" button (see picture in step 2) and select the module for the 

TCP/IP protocol on your PG/PC from the "PROFInet" box. 

You need this setting to be able to access non-connectable connectors (see "Properties of the 
PROFInet Interface") 

 
6. Open the OPC protocol selection dialog and mark the PROFInet and S7 protocols. 

Click on the "Accept" button to confirm your settings. 
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Step Description 
7. Use the command Start > SIMATIC > SIMATIC NET > Industrial Ethernet > SOFTNET 

Industrial Ethernet > OPC Scout to start OPC Scout from the task bar. 

OPC Scout opens. Here you can create a new group for your project data. Double-click to 
open this group. The OPC navigator opens. Select the project variables that you wish to 
display by selecting the function in the "Nodes" window. Then use the arrow button to transfer 
the desired item name to the right-hand window. 

Example: 

8. Click on the "OK" button to confirm your entry. 

A table with the selected OPC variables and their status information appears in OPC Scout. 

Example: 
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Tip: Access with visualization software 
Save your selected visualization data to an .OPP file. You can then open this file 
directly using OPC Scout. When visualization is working with the "OPC Scout" 
diagnostic tool, you can use any OPC-compatible visualization software (e.g. 
ProTool/Pro, WinCC, etc.) to access the OPC server running on the PC. 
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Appendix 4
4.1 Literature and Links 

Requirement  
• The SIMATIC Manual Collection, containing the latest manuals or  

• An Internet connection  Here you will find constantly updated information in the 
form of FAQs and manuals and software for downloading. 

Manuals 
Links to manuals containing further information about the devices and on working 
with SIMATIC iMap are given below. 

 
Title Link or download address 

SIMATIC iMap Manuals SIMATIC iMap Manuals  

http://www4.ad.siemens.de/view/cs/en/11066277  

Device manual S7-CPs / Part B2 
Description CP 343-1 PN  

Edition: 02/2003 

Description CP 343-1 PN  

http://www4.ad.siemens.de/view/cs/en/8776538  

SIMATIC NET IE/PB Link Gateway 

Edition: 11/2002 

Description IE/PB Link  

http://www4.ad.siemens.de/view/cs/en/7851748  

SIMATIC Component based Automation 
- WinLC PN Addendum to WinAC Basis 
V3.0  

Description WinLC PN 

http://www4.ad.siemens.de/view/cs/en/9857682  

SIMATIC Distributed I/O Device 
ET 200S Edition: 12/2001  

Order number: 6ES7151-1AA00-8AA0 

Distributed I/O Device ET 200S  

http://www4.ad.siemens.de/view/cs/en/1144348  

SIMATIC ET 200S Interface Module IM 
151-7 CPU 

as of version: 09/2002 

Order number: 6ES7151-1AA00-8AA0 

SIMATIC ET 200S Interface Module IM 151-7 CPU  

http://www4.ad.siemens.de/view/cs/en/10805260  

SIMATIC Distributed I/O Device 
ET 200X as of version : 05/2001 Order 
number : 6ES7198-8FA01-8AA0 

Distributed I/O Device ET 200X  

http://www4.ad.siemens.de/view/cs/en/1142469  

Basic Module BM147/CPU  

as of version: 07/1999  

Order number: 6ES7 198-8FA01-8AA0 

Basic Module BM147/CPU 

http://www4.ad.siemens.de/view/cs/en/1142364  

http://www4.ad.siemens.de/view/cs/en/11066277
http://www4.ad.siemens.de/view/cs/en/7851748
http://www4.ad.siemens.de/view/cs/en/8776538
http://www4.ad.siemens.de/view/cs/en/9857682
http://www4.ad.siemens.de/view/cs/en/1144348
http://www4.ad.siemens.de/view/cs/en/10805260
http://www4.ad.siemens.de/view/cs/en/1142469
http://www4.ad.siemens.de/view/cs/en/1142364
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Title Link or download address 
Distributed I/O Device ET 200M 
Revision: 07/00  

Order number: 6ES7 153-1AA00-8AA0  

Distributed I/O Device ET 200M 
http://www4.ad.siemens.de/view/cs/en/1142798  

SIMATIC Manual Collection  as of 
Edition: 11/2003  

Order number: 6ES7998-8XC01-8YE2 

SIMATIC Manual Collection 

http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo&la
ng=en&objId=12283375&lang=en 

Information about  
Component based Automation 

Component based Automation  

http://www4.ad.siemens.de/WW/llisapi.dll?func=ll&objaction=c
sbrowsesitemap&objid=10805344&nodeid0=10805344&lang=
en&siteid=cseus&aktprim=0  

4.2 Tips for Operation 

The following software is required to commission a plant with PROFInet and 
PROFIBUS devices: Windows 2000 or XP, SIMATIC STEP 7 and SIMATIC iMap. 
The following user tasks are often used in these programs: 

Windows 2000/XP 
In Windows 2000/XP, commands are called from the Windows taskbar. 

Examples: 

• Select Start > Simatic > SIMATIC NET > ... 

• Start SIMATIC iMap by double-clicking on the "iMap" icon.  

SIMATIC Manager / SIMATIC iMap 
Menu commands can be selected from the Menu bar, from a context menu (right 
mouse button) or by clicking on an icon in the icon bar. Objects or windows must 
be selected for menu commands. 

Examples: 

• Select the menu command Library > New.... 

• Select Create PROFInet Component from the context menu. 

• Click on the "Online Monitoring" icon. 

 

http://www4.ad.siemens.de/view/cs/en/1142798
http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo&lang=en&objId=12283375&lang=en
http://www4.ad.siemens.de/WW/llisapi.dll?func=ll&objaction=csbrowsesitemap&objid=10805344&nodeid0=10805344&lang=en&siteid=cseus&aktprim=0
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