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Legal information
Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage 
to property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices 
referring only to property damage have no safety alert symbol. These notices shown below are graded according to 
the degree of danger.

DANGER
indicates that death or severe personal injury will result if proper precautions are not taken.

WARNING
indicates that death or severe personal injury may result if proper precautions are not taken.

CAUTION
indicates that minor personal injury can result if proper precautions are not taken.

NOTICE
indicates that property damage can result if proper precautions are not taken.
If more than one degree of danger is present, the warning notice representing the highest degree of danger will be 
used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property 
damage.

Qualified Personnel
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems.

Proper use of Siemens products
Note the following:

WARNING
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended or 
approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and maintenance 
are required to ensure that the products operate safely and without any problems. The permissible ambient 
conditions must be complied with. The information in the relevant documentation must be observed.

Trademarks
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication may 
be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability
We have reviewed the contents of this publication to ensure consistency with the hardware and software described. 
Since variance cannot be precluded entirely, we cannot guarantee full consistency.  However, the information in this 
publication is reviewed regularly and any necessary corrections are included in subsequent editions.
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Security information 1
Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, systems, machines and networks.
In order to protect plants, systems, machines and networks against cyber threats, it is necessary 
to implement – and continuously maintain – a holistic, state-of-the-art industrial security 
concept. Siemens’ products and solutions constitute one element of such a concept.
Customers are responsible for preventing unauthorized access to their plants, systems, 
machines and networks. Such systems, machines and components should only be connected to 
an enterprise network or the internet if and to the extent such a connection is necessary and only 
when appropriate security measures (e.g. firewalls and/or network segmentation) are in place.
For additional information on industrial security measures that may be implemented, please 
visit 
https://www.siemens.com/industrialsecurity.
Siemens’ products and solutions undergo continuous development to make them more secure. 
Siemens strongly recommends that product updates are applied as soon as they are available 
and that the latest product versions are used. Use of product versions that are no longer 
supported, and failure to apply the latest updates may increase customer’s exposure to cyber 
threats.
To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed 
under 
https://www.siemens.com/industrialsecurity.
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Preface 2
Overview

BATCH Getting Started gives you an overview of the SIMATIC BATCH software package in 
combination with the SIMATIC PCS 7 process control system. It also allows you to become 
familiar with the functions of the batch process control. Getting Started is intended for new 
users of SIMATIC BATCH.

Prerequisites
To understand BATCH Getting Started documentation, basic knowledge in the area of 
automation engineering and process control engineering is required.
It is assumed that the reader knows how to use PCs or other equipment similar to PCs (such as 
programming devices) operating under Windows operating systems approved for SIMATIC PCS 
7.
SIMATIC BATCH uses the SIMATIC PCS 7 software. You should already have experience with the 
configuration. The entire SIMATIC PCS 7 documentation is available to you free of charge and in 
multiple languages as a manual collection in MyDocumentationManager via the following 
Internet page:
Complete SIMATIC PCS 7 documentation (http://www.siemens.com/pcs7-documentation).

Scope of the Documentation
This documentation applies to the software package SIMATIC BATCH V9.0 in combination with 
the process control system SIMATIC PCS 7 V9.0 SP2 UC03.

Additional Support
If you have questions about using the products described in this manual that are not answered 
in this document, please contact your local Siemens representative.
Contact partners (http://www.siemens.com/automation/partner).
You can find a guide to the collection of technical documentation for individual SIMATIC 
products and systems at SIMATIC technical documentation (http://www.siemens.com/simatic-
tech-doku-portal).
You can find the online catalog and the online ordering system at Industry Mall - Siemens (http://
www.siemens.com/automation/mall).

Training Center
We offer relevant training courses to help you become familiar with the SIMATIC PCS 7 process 
control system. Please contact your regional training center or the central training center in 
90327 Nuremberg, Germany.
Training center (http://www.siemens.com/sitrain).

SIMATIC BATCH V9.0 Getting Started
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Technical Support
You can reach Industry Online Support for all DI products via the support request Web form.
Industry Online support request (https://www.siemens.com/automation/support-request).
You can find more information about our Technical Support online at General information on 
technical online support (http://support.automation.siemens.com).

Industry Online Support on the Internet
As well as providing you with a range of documentation, we also share our expertise with you 
on the Internet.
Automation technology from A to Z (https://support.industry.siemens.com).
Here you will find:
• Our newsletter, which will keep you constantly updated with the latest information 

concerning your products.
• The search facility allows you to search for the correct documents.
• A forum, on which users and specialists from around the world can share their experience.
• Your local Automation and Drives representatives.
• Information relating to on-site service, repairs and spare parts. 
A wealth of other information also awaits you under "Services".

Preface
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Introduction to batch processes 3
3.1 Classification of Batch processes

Classification of technical processes

Difference between process and factory automation
• Process technology usually handles the production of liquid or solid materials.

– Physical / chemical / biological processes
– Safety, control of the (dangerous) process
– Sometimes Undefinable
– Uninterruptible at times

• Factory automation processes handle the production of packages such as screws or 
computers.
– Mechanical processes
– Throughput, speed
– Definable
– Can be interrupted

SIMATIC BATCH V9.0 Getting Started
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Definitions within the technological processes
• Continuous process (below "Conti process" or simply "Conti")

– Started and operated continuously over longer periods of time.
– Synonym: Flow process
– Examples: Ammonia synthesis, ethylene production

• Discontinuous process (below "batch process" or simply "batch") 
– Produces the product in separate batches of defined quantities
– Synonym: Batch process
– Examples: Production of synthetic resin, dye and fertilizers

3.2 Characteristics of Continuous and Batch Processes

Comparison of continuous and batch processes
 Conti  Batch

Continuous flow of products Limited product quantities

Large-scale production Small-scale production

Setpoint-driven Recipe-driven

Rare changes to the plant Frequent changes to the process

Single-product plant Different products in the same plant

Rare operator intervention Often only with partial automation -> operator inter‐
vention

The automation system contains the pro‐
duction know-how

The recipes contain the production know-how

Equilibrium states Various process states

Introduction to batch processes
3.2 Characteristics of Continuous and Batch Processes
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• The main difference between Batch and Conti is the production method.
• The product quantities in a batch process are fixed and can be clearly identified for this reason.
• Recipes contain the setpoints for the relevant process variables and product quantities. They 

also describe the method or procedure deployed to manufacture the product.
• The units within a Conti process are dedicated to specific tasks. 
• The same unit is used for multiple tasks within the batch process which means it is used for 

different batches, and shared resources.
• Mixed forms are relatively frequent, where both continuous and batch processes are coupled 

together or where certain parts of a batch process are supplied by continuously operating 
intermediate stages. 

Introduction to batch processes
3.2 Characteristics of Continuous and Batch Processes
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3.3 Exercise: Where is this used?

Production sequences

The properties of production sequences are as follows:
• The production sequences are described in the recipes, which represent a mapping of the 

production methods. In contrast to typical Conti applications or applications for the 
production process, the production sequence is described in the "recipe" instead of being 
reflected by the automation solution.

• The production sequences can be converted for new products. Automated production 
processes do not always return the same product; rather, they can return different end 
products whose manufacturing methods are contained in different recipes. These recipes are 
subject to continuous optimization in terms of parameter settings and runtime.

• Clear documentation of the process is often a vital aspect of production. This is essential for 
quality assurance and for the detection of faults.

• The customized, in-house conversion of production sequences for different products, 
including the introduction of new products or the modification of existing sequences, is an 
important factor for many end users.

• Plant operators should also be able to handle these tasks without having to consult system 
specialists. The automation system as such should not be modified. The conversion of 
sequences should be handled by means of recipes which map the production process.

• A production sequence which is described in a recipe and which is used specifically for a 
certain product often raises the question: "Where do I produce?". The factory usually features 
several production facilities which are capable of handling the same production sequence 
(for example, several identical production lines.). It should therefore be possible to distribute 
the production sequences to different production facilities. This should also be a system 
functionality which does not require any modification to the automation program.

Introduction to batch processes
3.3 Exercise: Where is this used?
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3.4 Industry Sectors for SIMATIC BATCH

Typical industry sectors that use batch automation
Typical business sectors that use batch processes are as shown below. For example: Beer 
production in the food and beverages sector.

(1) Biotechnology
(2) Pharmaceuticals 
(3) Chemical and mineral fiber 
(4) Food 
(5) Paint/Dye 
(6) Fertilizer/Plant protection 
(7) Plastic/Adhesive 

Introduction to batch processes
3.4 Industry Sectors for SIMATIC BATCH
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(8) Detergents

3.5 Origins of Batch Production: The Kitchen

Production plant "Kitchen"
This section explains about a kitchen production plant which is a simple example for a batch 
production:
Various products are created here. The production method is described in recipes. These can be 
constantly optimized and improved, and completely new recipes can be added. The chef is 
perfectly capable of doing this alone without help from the kitchen manufacturer. The recipe is 
often "secret" and contains the know-how for creating a dish.
When cooking, chefs must be able to decide which equipment will be used to implement a 
recipe. If there are several kitchens (for example in an industrial setting), the user can decide 
which kitchen will be used to make the product. Regardless of the kitchen selected, the same 
product should result and the actual production location should only be decided during 
production planning. It is important to record the production sequence (for example, quality 
assurance for health authorities, and for guests who want to know the method of production of 
the product they are consuming).

Introduction to batch processes
3.5 Origins of Batch Production: The Kitchen

SIMATIC BATCH V9.0 Getting Started
16 Getting Started, 08/2020, A5E43020680-AA



3.6 The Chef - Working Environment and Working Procedures

Working Environment and Working Procedures
The section below describes the working environment of the chef. The chef is in possession of 
recipes which contain the instructions and a list of ingredients and quantities. These recipes are 
known as master recipes.
The working environment involved is as explained below:
• Specific materials must be made available for production. 
• The production process is initiated by an order. This order defines the product, the quantities 

and the time schedule for production. 
• The chef handles the order in accordance with the corresponding recipe. They also allocate 

cooking resource such as the kitchen stove. Certain production units may be in use and not 
currently available, as it is common to handle several orders simultaneously. 

• The result of this sequence is the finished product.

Introduction to batch processes
3.6 The Chef - Working Environment and Working Procedures
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(1) Order
(2) Recipe
(3) Ingredients for cooking pasta
(4) Cooking pasta
(5) Spaghetti Bolognese served

Introduction to batch processes
3.6 The Chef - Working Environment and Working Procedures
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3.7 Batch Terminology

Important batch terminologies 
The important batch terminologies are:
• Master recipe: Recipe level that takes into account the capabilities of the equipment and 

contains information specific to the process cell. 
• Control recipe: A type of recipe that defines the manufacture of a single batch of a specific 

product through its execution. 
• Batch: Apparatus-dependent quantity of a product, which is manufactured discontinuously 

in a defined production cycle. 
• Process: A sequence of chemical, physical, or biological activities for the conversion, 

transport, or storage of material or energy. 
Till now, we have used terms taken from everyday language. Such terms are, however, liable to 
subjective interpretation. The same word may mean different things to different people. This is 
particularly the case when people with different occupations talk to each other (for example 
system engineers, chemists, production engineers). A chemist might understand a recipe to be 
the chemical composition of a product (which should not be revealed at any cost), whereas the 
system engineer interprets it as an automated sequence (for example, a sequencer).
To create a production facility that operates as desired, people from various walks of life must be 
able to work together. Therefore, it is important that everyone speaks the same "language". 
NAMUR (an international user association of automation technology in process industries) and 
ISA 88 (a standard for batch-oriented control strategies) have set themselves the task of 
defining and standardizing the terms.
We will gradually replace everyday language with the terminology from the standard.
In our kitchen we can derive a control recipe from the "Spaghetti Bolognese" recipe for Fred's 
kitchen which determines the production sequence for producing a batch of spaghetti. 
This illustrates that the control recipe derived from the master recipe is responsible for 
production. The control recipe must therefore know which production facilities it will be using 
while the master recipe remains neutral in this respect.

Introduction to batch processes
3.7 Batch Terminology
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3.8 The Kitchen: Master recipes – Header Data

Master recipes – Header Data
Language of the Chef ISA-88 Terms
Meal Spaghetti Bolognese Product
Number of persons 4 (Nominal quantity) Reference quanti‐

ty
Ingredients 1 kg ground beef, 100 gm mushrooms, 1 kg pasta, pinch 

of salt,
1 onion,
4 tomatoes
:
:

Input materials

Master recipes importantly consist of three parts:
• A recipe header which provides general information about the product such as its name, 

reference quantity, ingredients and quantities.
• Instructions or procedural rules for production. This is known as a recipe procedure.
• Information of the capabilities of the Process Cell including the Unit (Classes)

3.9 The Kitchen: Master Recipes – Procedure (Procedural Rules)

Master Recipes – Procedure (Procedural Rules)
Instructions Procedural Rules
1. Make Bolognese 
sauce

 Unit recipe 1
Chop onions and tomatoes, place in pan, weigh ground beef 
and add to pan

ROP 1: Prepare

 ROP 2: Heat
Heat pan to level 6  
 ROP 3: Simmer
Simmer for 1 hour with lid on pan  
  

2. Cook pasta  Unit recipe 2
...  

3. Season Pot Unit recipe 3
....  
....  

4. Taste Pan Sample

Introduction to batch processes
3.9 The Kitchen: Master Recipes – Procedure (Procedural Rules)
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The Recipe Unit Procedure (RUP) shows the instructions for production. It is divided into various 
sections (unit recipes). The unit recipes themselves are made up of recipe operations (ROPs).
We could, for example, describe the production of Bolognese sauce required to produce 
Spaghetti Bolognese in a unit recipe for Bolognese. We can further refine this procedure by 
detailing the steps in recipe operations. In the unit recipe for Bolognese sauce, we begin with the 
"Prepare" recipe operation. During the preparation, the input materials onions and tomatoes are 
chopped, ground meat is weighed and put in a pan.
At this stage, use of the term pan or pot is still generalized. These are references to the 
production facilities that will be required. In the standard language, these are known as unit 
classes. The master recipe itself is nevertheless "neutral" in terms of the unit candidates; that is, 
there is no mention yet of the unit candidate that will actually be used for production (for 
example, Fred's kitchen and Fred's favorite pot).

3.10 The Kitchen: Automation Requirements

Requirements for Batch processes
The "Kitchen" example is an analogy for the characteristics of Batch processes. The automation 
of such processes must meet the following requirements.

Requirements Implementation in the "Kitchen" example
Batch processes are described in "recipes" Spaghetti recipe.
Batch processes can be converted for new products. The chef must create new dishes.
Batch processes are continuously optimized. Refinements and resulting recipe adaptations.
Production processes are logged. Proof of the production 
process.

The production of foodstuffs should be recorded and be repro‐
ducible.

Process sequences may only be created or edited by author‐
ized persons.

Recipes are developed by the chef, not by the appliance supplier, 
for example.

Batch processes can be distributed to several units. Recipes can be used in different kitchens.
Different recipes produce different products in the same 
process cell.

End product in the kitchen, for example: Spaghetti, schnitzel/
escalope or fried potatoes.

3.11 The Kitchen: Automation Concept

Requirements of an Automation Concept
Requirement Solution (Without using Batch)
BATCH processes are described in "recipes" Possible with STL, SCL, SFCs, WinCC, though highly complex
BATCH processes can be converted for new 
products.

The programming method (STL, SCL, SFC) could be adapted.

BATCH processes are continuously opti‐
mized.

The programming method (STL, SCL, SFC) could be adapted.

Production processes are logged. The programming method (STL, SCL, SFC) could be adapted.

Introduction to batch processes
3.11 The Kitchen: Automation Concept
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Requirement Solution (Without using Batch)
Process sequences may only be created or 
edited by authorized persons.

Not possible.

BATCH processes can be distributed to sev‐
eral units.

Not possible.

Different recipes produce different prod‐
ucts in the same process cell.

Possible with STL, SCL, SFCs, WinCC, though highly complex

What do these requirements mean when formulating an automation concept?
Let's look at SIMATIC PCS 7 as a system platform. 
Question: How can we describe the production sequences in recipes? 
Answer: We can imagine structuring all possible sequences using CFC and SFC and mapping 
these to "recipes" using parameters stored, for example, on the OS. Structuring the sequences 
would, however, be extremely complex since all possibilities must be taken into account. It 
should also be possible to modify the recipes or to create new recipes. This could mean that the 
automation program (CFC, SFC) would have to be changed. The operating personnel would not 
be capable of doing this and the automation technician would have to be called in.
It would be possible to log the sequences using messages output on the OS in the form of 
reports. This would have to be implemented separately for each specific project. New and 
modified recipes would once again cause problems.
The complexity of the automation solution increases yet again if the sequences also need to be 
adapted for various units. This would mean that the SFCs would also have to determine which 
units are to be used.

3.12 Automation Concept - New Approach

New automation concept approach 
This leads to a new solution for resolving complexity by separating the automation and 
procedural levels.
We shall presume that the hardware structure of the process cell is retained and only the 
sequences will change. Let us implement the process cell-specific elements of the automation 
system and map the sequences to a "recipe system" which can be handled by the process. The 
master recipes are created and stored in this system.
The control recipes are derived from the master recipes and address the automation system.
The control recipe operations are:
1. Prepare bolognese.
2. Cook noodles.
3. Add spices.
4. Tasting.

Introduction to batch processes
3.12 Automation Concept - New Approach
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Note
The control recipe operations also contain the basic process of chopping onions and 
tomatoes, and putting them in the pan. Later, weighing the ground meat and adding it is 
also included here to prepare noodles.

(1) Process cell

3.13 Separation of the Automation Level and Procedural Level

Structure of the process cell
The following figure displays the structure of the process cell:
A structure consisting of units (scale, pan, mixer, etc.) can be designed in the process cell. These 
units are organized by technological functions such as weighing, dosing, etc. The technological 
functions can be assigned parameters such as "quantity" of the technological function "dosing".
All of this functionality is mapped to the AS. Here, the term process cell model is used. It 
represents the "tool box" for the engineer who designs the master recipe.
In the master recipe, these units with their equipment phases are used to compose the sequence.

Introduction to batch processes
3.13 Separation of the Automation Level and Procedural Level
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3.14 ISA-88 - Physical Model

Equipment models and their structural layers
The figure below explains the hierarchical structure of the equipment model. The properties of 
the model are:
• The model has seven levels. The top three levels are not dealt within the standard since these 

go beyond the framework of batch control.
• The lower four levels are also known as the equipment model.
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• An equipment phase (heating, dosing, weighing, etc.) serves an equipment module 
(heating, in this case).

• The term "EPH (Equipment Phase)" is used in the PCS 7 environment. 

3.15 Procedural Control Model

Hierarchical model 
In keeping with the physical model, a hierarchical model is used to describe the procedures as 
shown below.
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3.16 Implementation – Physical and Procedural Model

Models 
The physical and procedural model are as shown in the figure below. Both models are mapped 
in the architecture of SIMATIC PCS 7. The hardware model is implemented in SIMATIC PCS 7 
engineering. The resulting program structures are executed in the AS.
The procedural model is implemented in SIMATIC BATCH. The control recipes are executed in 
SIMATIC BATCH and in the AS program structures.
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3.17 The ISA-88 model in PCS 7

Models in SIMATIC PCS 7 and SIMATIC BATCH 
ISA S88.01 describes various models that can be fully covered with SIMATIC PCS 7 and SIMATIC 
BATCH.
The equipment model describes the process cell, unit, equipment module and control module 
level that are mapped using the plant hierarchy in the plant view of the SIMATIC Manager.
The process cell model is prepared for SIMATIC BATCH so that the procedural model in the form 
of recipes can be mapped to the process cell model.
• A recipe procedure runs in a process cell to control a process and to create a batch of a 

product.
• A recipe unit procedure runs on a unit to control a recipe stage. A unit can only be occupied 

by one batch at once, at any given time.
• A recipe operation or a recipe phase runs in an equipment module to perform a process task 

or equipment phase.
• The control module level is not within the framework of the Batch system and is only 

addressed via the equipment module. The control module level is located completely within 
AS.
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3.18 Workflow in the Kitchen: Order - Master Recipe - Process Cell

Order - Master Recipe - Process Cell
This section explains  an example of the workflow in the kitchen. The example is as described 
below:
• Mary orders three portions of Piccata Milanese. The order was placed for table 5 and must be 

delivered within 40 minutes.
• The "Piccata" master recipe is available for production. The recipe describes the process for a 

single portion.
• The chef needs two frying pans per portion. He needs six frying pans in order to produce 

three portions simultaneously. He creates three control recipes, each for two frying pans. 
Each control recipe produces one batch of Piccata.

• All three control recipes can be started simultaneously as shown in the picture, provided all 
six frying pans are available.

• The three batches have to be produced in sequential order if only two pans were available.
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3.19 Classification of batch process cells

Criteria for categorizing batch process cells
The number of products produced on the process cell represents the first classification criterion.
• Single-product process cells
• Multiple product process cells
The number of routes which support the parallel product flow forms the second criterion
• Single-route structure
• Multiple-route structure
• Network structure with totally flexible routes

The scaling capability of SIMATIC BATCH makes it suitable for both small scale process cells and 
for large configuration limits.
Complexity increases in proportion to the number of products and routes. SIMATIC BATCH 
supports the automation of multiple routes for multi-product process cells.
The assessment of smaller process cells for which only a few products or routes are required 
should be focused on licensing and engineering costs acquired by the solution with SIMATIC 
BATCH.
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3.20 SIMATIC BATCH: Customer Benefits

Customer benefits derived from the implementation of SIMATIC BATCH   
The customer benefits derived from the implementation of SIMATIC BATCH are:
• The production sequences are described in master recipes which can be created/edited by 

operating personnel at any time.
• Greater production flexibility, reduced "time to market".
• Unit allocation can be planned. The allocation planning can be changed right up to the actual 

allocation. SIMATIC BATCH supports automatic unit selection and late binding of units..
• Improved utilization of resources.
• Production sequences are documented in a batch log (paper or electronic). The production 

sequences can be reproduced using recipes with control strategies.
• Easy quality management.
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• Of particular interest if validation is required according to FDA (Food and Drug 
Administration) guidelines:
– Version control
– Access control
– Audit Trails (21CFR Part11)
– Electronic Signatures and archiving of batch (production) data.

• Low costs of validation, as changes to recipes can be traced.
• Implementation of a standard Siemens product.
• Reduced operation and life-cycle costs.
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Configuring the "Kitchen" training project 4
4.1 Basic principles 

4.1.1 Description of the model

Overview of the equipment model
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4.1.2 Plant Hierarchy View in SIMATIC Manager

Process cell model in the SIMATIC Manager 
The properties of the process cell model in SIMATIC Manager are:
• The process cell model in SIMATIC BATCH is used to represent the procedural model in recipes.
• A recipe procedure controls a process in a process cell to create a batch of a product.
• A recipe unit procedure runs on a unit to control a recipe stage. To avoid collisions, a unit can 

only be allocated to one batch at any time.
• A recipe operation or a recipe phase performs a process engineering task or equipment phase 

in an equipment module.
• The control module level is not within the focus of the Batch system and is only addressed 

through the equipment module. The control module level is located completely within the 
AS.
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4.1.3 Hardware and Software Requirements

Hardware requirements 
• PC configured according to the minimum requirements defined in the "PCS 7 Readme" file
• Network adapter

Software requirements     
Installation of SIMATIC PCS 7 V9.0 SP2 UC03 with the following programs:
• PCS 7 Engineering
• BATCH Single Station
• OS Single Station
• SIMATIC Logon V1.6 Upd1
• S7-PLCSIM V5.4 SP8

4.2 Configuration

4.2.1 Retrieving the project

Prerequisites
• Unzip the "SBGS_MP.zip" sample file. 
• The archived project file is called "SBGS_MP.zip" and the associated recipe database is called 

"sb_gs1_b.sbb". Both files are available for download in the "About" button on the web page 
for this Getting Started in the Siemens Industry online support portal.

• Copy both files to the following local folder on your PC: "..\SIEMENS\STEP7\examples".
• SIMATIC Manager is open.

Procedure   
1. Retrieve the project and save it under D: drive of your PC.
2. In the Component view, expand the tree view. Expand the "SBGS_MP" project. Right click 

"OS_Prj>Server>Object Properties". 

Configuring the "Kitchen" training project 
4.2 Configuration

SIMATIC BATCH V9.0 Getting Started
Getting Started, 08/2020, A5E43020680-AA 35



3. The "Properties  - SIMATIC PC Station" appears. In the "Name:" field, enter the name of your 
PC.
Note
To find out the name of your PC, click "Start". Right-click Computer>Properties. The 
"Computer name" field displays the name of your PC. 
For Windows 10, type "About your PC" in the search box of the Windows task bar. The "PC 
name" field displays the name of your PC. 
For Windows Server 2012. click "  icon >This PC>right Click>Properties". The "PC name" 
field displays the name of your PC. 
 

4. Under "Computer name" area click "Computer Name identical to PC station name".
5. Click "OK" to save and activate the name.
6. Expand the PC node WinccApplication > OS(1).
7. To open the WinCC Explorer on the ES, right-click OS(1) > Open Object.
8. A popup appears "The configured server is not available. Do you want to open the project with 

the local computer as Server?". Click "Yes".
9. Right-click "Computer > Properties". The "Computer List Properties" window appears with 

your PC name selected. Now, click "Properties". The "Computer properties" window appears.
10.Click "Use Local Computer Name" to change the computer name to the name of your local PC, 

and click "OK".
11.The "Change Computer Name" window appears which prompts you to restart WinCC. Click 

"OK".
12.Click "OK" and close the WinCC Explorer.

4.2.2 Configuring the BATCH Server and BATCH Client

Introduction
This section describes the requirements and procedures to be followed when configuring a 
BATCH Server and Client in single station system.

Prerequisites   
• You only need one PC station to work locally on the ES PC with the BATCH Server and Client 

(single-project engineering/single station system). The BATCH Server application is set up on 
this PC station.
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Procedure
1. Select "SBGS_MP\Server" in the Component view and open the configuration object.

2. Select the "BATCH Application" and drag-and-drop it in Index 2.
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3. Select the "BATCH Application Client" and drag-and-drop it in Index 3.

4. Save and compile the hardware configuration of the PC station with the newly added BATCH 
application.

5. Close HW Config.
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4.2.3 Opening the Plant View

Procedure 
To open and arrange plant view, component view horizontally:
1. Click View>Plant View.
2. Click Window>Arrange>Horizontally.

Configuring the "Kitchen" training project 
4.2 Configuration

SIMATIC BATCH V9.0 Getting Started
Getting Started, 08/2020, A5E43020680-AA 39



4.2.4 Creating the Batch Process Cell

Introduction
This section guides you the steps to assign the "process cell" ISA-88 type definition to the 
"Kitchen" hierarchy folder. The "Kitchen" folder then becomes green and has the "process cell" 
type according to ISA 88.

Prerequisites
• The SBGS_MP project is open in SIMATIC Manager.
• Plant View is activated.

Procedure
To create the batch process cell according to ISA 88 standard:
1. Select the "SBGS_MP\AS_Prj\Kitchen" object in the tree view.
2. Right-click on the "Kitchen" project and select "Object Properties".

The "Properties - Hierarchy Folder -- Kitchen " dialog box opens with the "General" tab 
activated.

3. Select "ISA-88Type Definition" tab.
4. In the "Object type" drop-down list, select "Process cell", and click "OK".

5. The "Kitchen" folder now appears in green color according to the ISA S88.01 standard.
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4.2.5 Type Definition of the Plant Hierarchy according to ISA -88

Introduction
This section will guide you to assign the ISA-88 type definitions "Unit" and "Equipment module 
(generic and recipe aware)" to the existing hierarchy folders in this section.  The following 
images display the different hierarchies in the "Kitchen" object:
For more information on "generic" and "recipe aware" see: Task definition and implementation 
concept for "Cooling" (Page 193)

(1) Process cell.
(2) Unit. 
(3) Equipment modules.

Prerequisites
• The SBGS_MP project is open in SIMATIC Manager.
• Plant View is activated.
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Procedure
1. Select the "SBGS_MP\AS_Prj\Kitchen\Viewport_1\Desk_1" object in the tree view.
2. Click Edit > Object Properties.

The "Properties - Hierarchy Folder" dialog box opens with the "General" tab activated.
3. Select "ISA-88 Type Definition" tab.
4. In the "Object type" drop-down list, select "Unit", and click "OK". 

The "Desk_1" folder now appears in green, identifying it as a unit according to the ISA S88.01 
standard
Note
Do not touch the Stove_1 and Viewport_1 hierarchy folders. The identifier remains 
neutral.

5. Follow steps 1-4 to assign the "Unit" object type to the "Oven", "Pan", "Pot_1", "Pot_2" and 
"Pot_3" hierarchy folders according to the ISA-88 type definition.
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6. Follow steps1-4 to assign the "EMOD" object type to the "Drain" hierarchy folder under 
Kitchen/Viewport_1/Desk_1. The "Drain" folder turns green and is labeled as an equipment 
module according to ISA standard S88.01.
The CFCs with the instances of the SFC types are located on the equipment module level. You 
can also use SFCs in combination with the CFCs and their Batch interface blocks (IEPH, 
IEPAR_xxx).

7. Assign the "EMOD" object type to the hierarchy folders identified at the beginning of this 
chapter as "Level 3: Equipment module" according to the ISA-88 type definition, as described 
in step 6. 
The following image displays all the hierarchy folders in green after assigning their respective 
object types:
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4.2.6 Assigning the Batch Category "EPH"

Introduction
This section guides you to assign the EPH batch category.

Prerequisites
• The SBGS_MP project is open in SIMATIC Manager.
• Component View is activated.

SFC types
SFC types contain equipment phases with and without selfcomplete functionality. This property 
is set by default at the following SFC types:
• Self-Completing: Drain, Fill_Solid, Turn and Add_Ingredient
• Non Self-Completing: Stir and Heat
The SFC types used can be used in runtime of the Getting Started BATCH project.
The block contact "Ready_TC" reports the end of the RUN sequence within non self-completing 
equipment phases. Such an equipment phase waits for an external command input either by an 
operator or by SIMATIC BATCH.
For detailed information on equipment phases, refer to the SIMATIC BATCH Online Help.

Assigning the "EPH" Batch Category to SFC Types  
Assign the "EPH" Batch category to the existing SFC types. With the "EPH" category, the SFC type 
is classified as a phase type. As a result, the information relevant to S88.01 is created 
automatically during subsequent type generation.
You can find the existing SFC types in the Component view in the "charts" folder under AS:
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(1) Existing SFC types

Procedure
To assign the EPH batch category:
1. Select the "SBGS_MP\AS_Prj\AS\CPU 410-5H\AS_Program\Charts" object in the tree view, and 

select "Heat".
2. Click Edit > Object Properties.

The "Properties SFC type" dialog box opens with the "General" tab activated.
3. Select "Options" tab.
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4. In the "Category" drop-down list, select "EPH".
5. Select the "Allow operator instructions" check box and click "OK"

In the same manner, assign the "EPH" batch category to the remaining "Stir", "Drain", "Fill_Solid", 
"Turn" and "Add_Ingredient" SFC types.

4.2.7 Generating the Type Definition in the Batch Types

Introduction   
As the basis for creating recipes in SIMATIC BATCH, the type description of the process cell must 
be generated and synchronized with the block instances of the CFC charts.

Type Editing Options and Results
Data types The system specifies the standard data types such as floating point number, integer, string, 

input material, output material, material, and Boolean. You can also create custom data types 
and edit their properties.

Units of measure You can create new units of measure and edit their properties.
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Type Editing Options and Results
Operation types, phase types 
and process tag types

To allow recipe creation purely on the basis of types, they must be specified without the block 
instances for them to exist
1. Operations types: Type information for the equipment operations (EOP)
2. Phase types: Type information for the equipment phases (EPH)
3. Process tag types: Type information of the TAG_Coll blocks
Operation types, phase types and process tag types can be assigned to control strategy 
parameters.

Equipment properties Create new equipment properties in the "Equipment properties" folder such as the size of the 
unit (capacity of a silo) or the material composition of the silo shell or dynamic properties like 
temperature and pressure. Equipment properties are assigned to units in the ES configura‐
tion and then requested as conditions when creating recipes.

Prerequisites
• The SBGS_MP project is open in SIMATIC Manager.
• Plant View is activated.

Procedure
1. Select SBGS_MP object 
2. Right click on the "SBGS_MP" object and select SIMATIC BATCH > Open configuration 

dialog.
The "Configure Batch process cell 'Kitchen' in SBGS_MP" dialog box appears

Note
A format conversion may be necessary for projects created with an older version of CFC/
SFC. You can only open the configuration dialog after you have completed the 
conversion.
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3. Select "Batch types" in the tree view and click "Generate & Propagate".
4. Select "Batch instances". In the "Batch instances" area, click "Merge".
5. Now, select "Kitchen". In the "Batch process cell" area, click "Transfer Messages" (Only One 

time).
6. The "transfer messages to OS" popup appears. Click "Yes".
7. Click "Apply" and "OK" to exit.

4.2.8 Compiling and Downloading the AS, OS and Batch Process Cell Data

Prerequisites
• The SBGS_MP project is open in SIMATIC Manager.
• Plant View is activated.
• Component view is activated.

Procedure   
1. In "Component view", select the SBGS_MP multi project.
2. Right-click and select SIMATIC BATCH > Open configuration dialog.
3. In "Configuration Batch process cell "Kitchen" in 'SBGS_MP'" window, under 'Stations', click on 

"Update".
4. Select 'AS' and in the properties area, select the checkbox for 'Simulation (TCP/IP) on/off' and 

click OK.
5. Open any CFC chart.
6. Select Options > CUSTOMIZE > Compile/Download in the CFC Editor, and click "OK". Check 

or increase the number of "Installed blocks per runtime group or OB" to 100.This prevents 
warnings from occurring during compilation.

7. Click  icon in the toolbar. The "Compile program" window appears.
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8. Click "OK" to compile the complete AS program. After successful compilation, click Chart > 
Exit to close the CFC editor.

9. In the "Component view", select "AS_Prj" project. Click "Options > Configure Network". The 
"Netpro.." window appears.

10.In the "Netpro.." window, click "View" > "Cross-Project Network View" to view both AS and 
Server. Click "Network > Save and Compile". The "Save and Compile" window appears.

11.Select "Compile and check everything" and click "OK". Close the "Netpro.." window.
12.Select OS_Prj click on "Options > Compile Multiple OSs Wizard > Start".
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13.The "Wizard: Compile Multiple OSs" window appears. Click "Next" and "Connection...". The 
"Select Network Connection" window appears.

14.In the "WinCC unit" column, click on the "Industrial Ethernet" drop-down list, and select "TCP/
IP". Click "OK".

15.In the " Wizard: Compile Multiple OSs" window, click "Next".
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16.Compile the entire OS with memory reset. Click Next > Compile. After compilation, click "OK" 
to close the " Wizard: Compile OS" window.

17.Right-click "SBGS_MP" project and select SIMATIC BATCH > Open configuration dialog > 
Batch instances > Merge to compile the batch process cell data.

18.Select the "SBGS_MP" project.
19.Select Settings > OS Objects > Update to update the plant status.
20.Click "OK" to close the view.
21.Click "Apply" and then click "OK" to close the "Configure Batch process cell" window.
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4.2.9 Downloading the AS to PLCSIM

Introduction   
Open SIMATIC Manager to download the compiled AS data to the "PLCSIM" simulation program. 

Prerequisites
• Component view is activated.

Procedure
1. Click "Options > Set PG/PC Interface". The "Set PG/PC Interface" dialog box appears.
2. In the "Access Path" tab, "Interface Parameter Assignment Used" area, select "PLCSIM. 

TCPIP.1" and click "OK".
3. Click "OK" on the "Warning" window.
4. To open PLCSIM in SIMATIC Manager, click  icon.

5. To download the HW configuration to PLCSIM, select your AS in the Component view.
6. Right click on "Hardware" and select "Open Object"
7. Click the  icon in the toolbar to download the hardware configuration to the AS.
8. The "Select Target Module" window appears. Click "OK".
9. The "Select Node Address" window appears. Click "OK".
10.Close HW Config.
11.Open any CFC chart from the chart folder of your project in the component view and 

download the entire program to PLCSIM.
Note
If the dialog "Download S7 - Read Back" is displayed, click "No". This means that 
parameters from the AS will not be read back before loading.

12.Close the CFC Editor.
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13.Click "Options > Configure Network". The "Netpro.." window appears.
14.Under "AS" select "CPU 410-5H" and click  icon . The "PLC Download to Current Project 

Selected Stations" dialog box is displayed. Click "Yes".

15.After the download activity, close the "NetPro" window.
16.Start simulation by setting the PLCSIM-CPU into "RUN-P".
17.Save the simulation data you downloaded in order to prevent its loss after you exit PLCSIM. 

Steps 1 to12 must be repeated the next time you open a PLCSIM session after closing PLCSIM 
without saving the data. Saved simulations can be activated directly in "Run" mode by 
opening the corresponding file.

4.2.10 Downloading the Batch Process Cell Data

Prerequisites
• The SBGS_MP project is open in SIMATIC Manager.
• Plant View is activated.
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Procedure 
1. Right click on the "SBGS_MP" project and select SIMATIC BATCH>Open configuration 

dialog.
2. The "Configure Batch process cell 'Kitchen' in 'SBGS_MP' " window appears.

3. Click "Download..." to download the Batch process cell data generated on the ES to the BATCH 
Server and Client. The BATCH Server and Client in your configuration are operated on a single 
PC.

4. The "BATCH configuration" dialog box appears. Click "OK".
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5. The "Download Batch process cell 'SBGS_MP' " window appears. Click "Start" to start the 
download process.

6. The "Status" column turns green after the download is complete. It is as shown in the figure 
below. 
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7. Click "Close" to exit the "Download Batch process cell 'SBGS_MP' " window.
8. Click "OK" to exit the "Configure Batch process cell 'Kitchen' in 'SBGS_MP' " window.

Note
Messages in other languages
Message output in languages other than German / English is only available if project data was 
configured, compiled and downloaded in the corresponding regional language. 

4.2.11 Starting the OS

Prerequisites
• Component view is activated.

Procedure         
1. Click "Start", right-click "File Explorer", and then click "Manage". The " Computer 

Management" console is displayed.
Note
• If you are using Windows 7, click "Start", right-click "Computer", and then click "Manage".
• If you are using Windows Server OS PC, select "Computer Management" from the 

"Administrative Tools" folder.

2. In the "Computer Management" console, create a new user with user name and password. In 
our example, the user is "SBGettingStarted".

3. Then, create a new Windows group. In our example, this is the "SBatch" group.
4. Add the new Windows user to the following groups: 

– SBatch
– Administrators
– Logon_Administrator
– SIMATIC BATCH
– SIMATIC HMI
– SIMATIC HMI CS
– SIMATIC NET

5. Close the "Windows Computer Management" console.
6. In the tree view, expand the "Server (your PC name)". Now, expand "WinCC Application"
7. Right click "OS(1) > Open Object". The "WinCC Explorer" window appears.
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8. Right Click "User Administrator > Open".  The "User Administrator - WinCC Configuration 
Studio" window appears.

9. In the "User Administrator" pane, create the "SBatch" Windows group with unrestricted rights.

10.In the "Properties - User Administrator" pane, enable the "SIMATIC Logon" check box. Close 
the "User Administrator - WinCC Configuration Studio" window.

11.In the "WinCC Explorer' window, right click "Tag Management > Open". The "Tag 
Management  - WinCC Configuration Studio" appears.
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12.In the "Tag Management  - WinCC Configuration Studio" window, right click "TCP/IP > System 
parameters".

13.The "System Parameter - TCP/IP" dialog appears. Select the "Unit" tab. In the "Logical device 
name" area, click "PLCSIM(TCP/IP)" drop-down list, and select "PLCSIM.TCPIP.1" and click "OK".

Configuring the "Kitchen" training project 
4.2 Configuration

SIMATIC BATCH V9.0 Getting Started
58 Getting Started, 08/2020, A5E43020680-AA



14.Close the  "Tag Management  - WinCC Configuration Studio" window.
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15.Open the OS Project Editor and navigate to all the available tabs, and then click "OK". This 
function is used to configure the WinCC Runtime user interface and the alarm system. This 
operation may take a few minutes.
Note
Adapt a screen resolution of 1280*1024 for a SIMATIC Standard-Layout as mentioned under 
Layout description in the figure. This resolution may vary according to the display resolution 
set on your PC.

16.Start Runtime on the OS. An initial startup may take a few minutes. Log on with the user 
logon data you have just created. Click "Pan" in the runtime window as shown below.
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Note
To check if the connection between AS and OS is established:
1. In the "WinCC Explorer" click "Tools > Status of Driver Connections"
2. The "Status - Logical Connections" window appears.
3. Here, the "State" column must display as "OK". If not, please check the set PG/PC Inteface 

and Tag Management system parameters.

4.2.12 Starting the BATCH Launch Coordinator
     
The BATCH Launch Coordinator is visible as a symbol in the taskbar at the bottom right on your 
desktop. You make operator input in a shortcut menu which you open by right-clicking on the 
symbol.
The start mode of the BATCH Launch Coordinator is set to "automatic" as standard. This means 
that the BATCH Launch coordinator starts the BATCH project and BATCH Runtime after 
successfully starting WinCC Runtime. You also need to change the security settings to read the 
batch data. You have two options to read the batch data namely:
• NTLM Mode
• Compatible Mode
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Note
It is always recommended to use NTLM mode for reading Batch data.

Option 1: Reading Batch Data in NTLM Mode
1. Click "Start > Control Panel" The "All Control Panel Items" window appears.
2. Open "Administrative Tools". The "Administrative Tools" window appears.
3. In the "Name" column, double click "Local Security Policy". The "Local Security Policy" window 

appears.
4. Expand "Local Policies" and select "User Rights Assignment".
5. In the "Policy" column, select "Log on as a service" and right click "Properties". The "Log on as 

a service properties" window appears.
6. Click "Add Users or Groups".
7. The "Select Users, Computers, Service accounts, or Groups" dialog appears. 
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8. In the "Enter the object names to select (examples)" area, enter the computer name or the 
domain name along with the user name "SBGettingStarted".

Note
It is recommended to create separate user for this task (NTLM).

9. Click "Check Names" and click "OK".
10.In the  "Log on as a service properties" window, click "Apply" and "OK".
11.Click "Change security settings"
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12.The SIMATIC BATCH Server security window appears. Choose the "NTLM (recommended) 
option, and enter Logon and Password as shown below. Please use your computer name 
here. The user name will be "SBGettingStarted".

13.Click "OK". The "SIMATIC BATCH Security settings" dialog appears. Click "Yes" and "OK". You 
have thus configured to read batch data in NTLM mode.
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Option 2: Reading Batch Data in Compatible Mode
1. Click "Change security settings"

2. The SIMATIC BATCH Server security window appears. Choose the "Compatible" option here, 
and click "OK".

If the BATCH Launch Coordinator has ended, navigate to windows Start menu and click BATCH 
> BATCH Launch Coordinator to restart.
For Windows 10 and Windows server 2012, click the icon + R to open the "Run" dialog. Enter 
"sblaunchcoordinatoricon32ux.exe". Click "OK" to restart.
If the start mode is set to "manual", you have to start both the BATCH project and BATCH Runtime 
in the shortcut menu of the Launch Coordinator. Please note that the start mode of the BATCH 
Launch Coordinator can only be set or changed by users who are logged on with administrator 
rights.
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4.2.13 Loading the supplied recipes and materials

Introduction
This chapter will guide you to load the supplied Batch Control Center backup "sb_gs1_b.sbb" for 
the "Kitchen" process cell. Which contains recipes, materials, information on users, groups and 
role assignments is saved in the restore file.

Batch Control Center
The BATCH Control Center (BatchCC) is the central component for:
• Batch scheduling
• Batch control
• Management of all BATCH data
• Libraries, master recipes, formulas, materials and management of rights and roles

Prerequisites
To start BatchCC or the BATCH Recipe Editor, the BATCH Launch Coordinator must be started and 
the "Running" status must be displayed in the information bar displayed as 
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Procedure
To restore the batch sbb file:
1. In the Windows Start menu, select Start > All Programs > Siemens Automation > SIMATIC 

> SIMATIC Batch > Control Center. In Windows 10 select Start > Siemens Automation > 
Control Center.
Note
If several projects are detected when you start BatchCC, or if the connection to the 
project cannot be established, a selection dialog appears.

2. In the "SIMATIC BATCH: Control Center" window, select "Options>Restore"
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3. The "Restore" window opens for the selection of the batch .sbb file. This .sbb file is file is 
available as mentioned above inside the downloaded .zip file.

4. Select the sb_gs1_b.sbb file and click "Open"

Result
The sb_gs1_b.sbb file  is successfully restored

Note
If the "Kitchen" process cell is already in the BATCH Control Center, you cannot use the 
"Restore" command. The associated Batch database has already been created and loaded. 
However, you can perform all other configuration tasks such as assigning new names to 
objects such as materials, recipes or batches.
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4.2.14 Setting up Roles Management in SIMATIC Logon

Introduction   
In order to obtain unrestricted access to BatchCC with the user logged into WinCC runtime, the 
logged on user is added to the "Superuser" role in the SIMATIC Logon roles management.

Note
Information on role assignment in the restore file is related to the PC on which the backup file was 
created. It is recommended that you always perform the role assignment again in the SIMATIC 
Logon roles management. 

Prerequisites
• BatchCC is open.
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Procedure
To set up roles management in SIMATIC Logon: 
1. Click Options > Roles management in Batch CC. The "SIMATIC Logon Role Management" 

window appears.

2. Select Roles>Super User>Groups and users, and right-click to "Edit".
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3. In the "Edit groups and users" window, select your Domain/Computer Name and click on 
"List". All the users & groups of particular domain or computer will be listed.
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4. Search for the "SBatch" group. Select the group and click the 

 icon to add the user to the "Configured groups and users" area.

5. Click "OK" and then "File>Save".
6. Close the "SIMATIC Logon Role Management" window.

Note
The PC name and user credentials are always valid for your own PC's. Please use specific 
user names and passwords created for your PC while performing roles management steps.

4.2.15 Updating Downloaded Batch Process Cell Data

Prerequisites 
• BatchCC is open.
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Procedure
To update the downloaded batch process cell data:
1. Right-click on the "Kitchen" process cell and select "Update process cell"

2. Click "OK" in "Updating the process cell" window.
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4.2.16 The Recipe for Pasta Piccata Milanese

Recipe
Meal Piccata Milanese
Quantity 2.9 kg (reference quantity)
Ingredients 100 ml oil

1.9 kg pasta
50 g salt
1 l tomato sauce

Instructions Editing Options and Results
1 Prepare water Fill a pot with 3 litres of water, add 100 ml of oil and a pinch of salt, heat to 100°C
2 Cook pasta Put 1.9 kg of pasta in the boiling water and cook for 6 minutes.
3 Prepare sauce (while cooking 

pasta)
Pour 1 litre of tomato sauce in a pot. Heat for 5 minutes at 40 ° C while stirring

... ... ....
4 Make complete Add salt and/or pepper to flavor. Serve the pasta and sauce
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4.2.17 Setting up the Output Material

Defining output materials
At the beginning, define the materials and optionally, the qualities for input materials/output 
material for SIMATIC BATCH. 
You can define the materials in the list boxes displayed in subsequent dialogs for recipe creation 
and batch planning. Materials and qualities must also be assigned a unique code (for example, 
an internal company code). This code can be used to specify the setpoint and process value at 
the interface blocks or SFC types to identify the material or product. In order to write recipes, 
material information needs to be defined. Input and output materials with various qualities can 
be created. These are created in the BatchCC, in the Materials folder, under the process cell you 
have loaded.

Prerequisites for adding output material
• BatchCC is open.

Adding an output material
In this section, we will explain the steps to add an output material (Piccata Milanese). Users can 
follow the same steps to add additional output materials.
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To add an output material:
1. Right-click "Materials>New" in the "SIMATIC BATCH: Control Center" window.

2. The "New material" window appears. In the "General" tab, enter "Piccata Milanese" in the 
"Name:" text box. Enter a random code in the "Code:" text box. In the "Usage" area, select  the 
"Output material" check box, and click "OK".
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3. Follow step 1 and in step 2, In the "Usage" area, select  the "Input  material" check box, and 
click "OK" to create the "Water" input material. The final display is as shown below.
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4.2.18 Creating a Master Recipe in BatchCC

Introduction
This section will guide you to create a master recipe in BatchCC.

Prerequisites
• SIMATIC BatchCC is open
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Procedure
To create a new master recipe in BatchCC:
1. In the "SIMATIC BATCH: Control Center" window, right click on Master 

recipes>New>Hierarchical. The "Creating a new master recipe" window appears.

2. In the "Name" input box, enter "Training Recipe". The "Version" input box is automatically 
populated as V1.0 since you are creating the master recipe for the first time. Click "OK". Now, 
"Training Recipe V1.0" is created under "Master recipes".
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3. Right click on Training Recipe V1.0>Properties. The "Properties of 'Training Recipe_V1.0'" 
window appears. Select the "Product" tab and enter the details as shown below:
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4. Select the "Output material" tab and click "New". Now, click on the "Material" input box. The 
"Select the material" window appears. Select "Piccata Milanese" and click "OK".

5. In the "Properties of 'Training Recipe_V1.0'" window, select the "Output material" tab and 
enter 2.9 in the "Quantity" input box. Now, click "OK".
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Result
The master recipe has been successfully created.
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4.2.19 Setting up a Recipe Structure in the Recipe Editor

4.2.19.1 Introduction of the Recipe Editor

Layout of the Main Window in the Recipe Editor   
The basic layout of the user interface of the BATCH Recipe Editor is shown in the figure below, 
which illustrates an example of a hierarchical recipe. You can create or modify recipes in the 
editing windows using the structure elements of the "Insert" menu.

(1) Recipe editing window.
(2) Editing with an ROP sequence.
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(3) Editing level 1 (RUP is always shown in a column and ROPs are arranged vertically).
(4) Editing level 2 (ROP sequence with the SFC structure elements, steps, branches, and so on).

Basic integration of the hierarchy in the BATCH Recipe Editor
The diagram below shows the basic integration of the hierarchical structure for editing in the 
BATCH Recipe Editor. The structure of a hierarchical recipe is edited at two levels, that is, editing 
levels 1 and 2.
Editing level 1 (RUPs and ROPs)
Editing level 1 is intended for the plant view in which the processes of several cells can be 
synchronized. A recipe unit procedure (RUP) is made up of recipe operations (ROPs). To structure 
the process, you can use double lines to synchronize. This allows you to synchronize the timing 
of ROPs in several recipe unit procedures.
Editing level 2 (RPHs)
Editing level 2 is used to create ROP sequences. An ROP sequence begins with a Start step. The 
Start step is followed by a transition that defines the start conditions. Every ROP  has a sequence 
of RPH and ends with an End step. A transition that defines the end condition precedes every end 
step.
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Implementation in the BATCH Recipe Editor
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Tools for Creating the Recipe Structure

(1) Select
(2) Insert recipe procedural element
(3) Insert recipe phase/operation
(4) Create library reference
(5) Insert operator instruction
(6) Insert a command step
(7) Insert simultaneous branch
(8) Insert synchronization
(9) Insert monitoring area
(10) Insert transition
(11) Insert alternative branch
(12) Insert loop
(13) Insert jump
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4.2.19.2 Working on Editing Level 1

Introduction
This section guides you to set up the recipe structure in the Recipe Editor in accordance with the 
description in the recipe.

Prerequisites
The SIMATIC BATCH Recipe editor is open.
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Procedure at editing level 1
1. In the "SIMATIC BATCH: Control Center" window, right click Training Recipe V1.0>Open.

2. Create the "Piccata Milanese" dish using the corresponding tools and recipe description. Refer 
to the diagram on this page for help.
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ROP: Prepare water

ROP: Cook Pasta ROP: Prepare sauce
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3. In the "SIMATIC BATCH: Recipe Editor" window, click the  icon to create an RUP. Repeat the 
procedure to create two RUP's as shown below:
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4. Select the left RUP and right-click for  "Properties". The "Properties of 'RUP_2'" window 
appears. Select the "Allocation" tab. Now, click on the "Strategy" drop down list and select 
"Preferred unit". Later, click on the "Preferred unit" drop down list and select "Pot_1". Click 
"OK".

Note
Follow these steps to select an individual unit in the "Equipment selection" area:
1. In the Recipe Editor, select Recipe > Header parameters. The properties dialog box is 

displayed.
2. Click the "Allocation" tab and clear the "Condition" and "constrain" check box.

5. Assign the "Pot_3" unit as the preferred unit for the second (right hand) RUP as explained in 
step 4.
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6. Insert the relevant ROPs (recipe operations) as shown below. Refer to step 3 for details.
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7. Select the top left ROP and right-click for "Properties". The "Properties of ROP_17" window 
appears. Select the "General" tab and enter "prepare water" in the "Name" input box. Now, 
Click "OK".

8. Repeat steps 6 and 7 and assign the name cook pasta to the bottom left ROP, and prepare 
sauce to the right ROP. The final result after assigning the names for the ROP's are as shown 
below: 
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Note
The number in RUP_2 and RUP_4 is only a representational indication. The numbers may vary 
according to each user's PC.
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4.2.19.3 Working on Editing Level 2

Procedure at editing level 2
1. To insert a recipe phase (NOP), double click on the "Prepare Water" ROP and click the  icon  

and place them in between the "Start" and "End" blocks to create an NOP.

2. Select the "NOP" and right-click for "Properties". The "Properties of 'NOP_25'" dialog box 
appears. Click the "Phase" drop down list and select "Add_Ingredient (EPH)". Now, click the 
"Control Strategy" drop down list and select "Add_Water", and click "OK". The recipe phase 
takes the name of the equipment phase in this case.
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3. In the "Properties of 'Add_Ingredient'" dialog box, click the "Parameters" tab, and enter "5" in 
the "Value" input box for the "Simutime" parameter.

Note
Runtime characteristics
Here, and in all the recipe phases, the "Simutime" parameter is used for simulation. The 
parameter has no influence on the runtime characteristics of equipment phases and recipe 
phases in a batch.
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4. Now, select the "Input material" tab and click "Material" input box. The "Select the material" 
dialog box appears

5. In the "Select the material" dialog box, select "water" and click "OK".

6. Now, enter "3" in the "Quantity(set)" input box, and click "OK".
7. To insert a parallel branch, click the  icon, and place them in the recipe . Click the  icon 

to add three NOPs, and place them in the recipe.
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8. Within the simultaneous branch, assign an "Add_Ingredient" equipment phase with the 
"Add_Oil" control strategy to a recipe phase. Then, pass the "Oil" material to the "Li_quantity" 
input material with a quantity of "0.1 l". Specify a value of "5 sec" for Parameter "Simutime".

9. Assign an "Add_Ingredient" recipe phase with the "Add_Salt" control strategy below the 
"Add_Ingredient" recipe phase. Assign the material "Salt" and the quantity "0.01 kg" to the 
"Kg_quantity" input material. Specify a value of "5 sec" for Parameter "Simutime".
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10.Assign the "Heat" equipment phase to a recipe phase and assign the value "100° C" to the 
"Temp" parameter. Set the "Simutime" to the value "300 sec".
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11.Complete the "Cook Pasta" ROP according to the recipe description for "Piccata Milanese". For 
example, select one of the pasta from the pasta list (For example: Penne). For more 
information refer to The Recipe for Pasta Piccata Milanese (Page 74)

12.Complete the "Prepare Sauce" ROP according to the recipe description for "Piccata Milanese" 
and select "Tomato Sauce" from the "Input material" list. For more information, refer to The 
Recipe for Pasta Piccata Milanese (Page 74)
Note
Please add salt and pepper according to your requirements while completing  the 
"Prepare Sauce" ROP.
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4.2.20 Completing the Training Recipe

Completing recipes  
To complete the training recipe:
1. In the "SIMATIC BATCH: Recipe Editor" window, on the toolbar, select "Insert synchronization".

2. Draw a line between the left and right columns. This inserts a synchronization line between 
two recipe operations in the recipe.
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3. Insert two recipe operations (ROPs), and label them as "Serve Pasta" and "Serve Sauce".
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4. Right-click the "Serve pasta" recipe operation and click "Open object". The "Training Recipe / 
RUP_2 / serve pasta_64" window appears. Drag and drop "NOP".

Note
In the "Training Recipe / RUP_2 / serve pasta_64" window, the numbers 2 and 64 are allocated 
based on the configuration done in every individual PC. These numbers may vary according 
to every user's PC.

5. Right-click the "NOP>Properties". The properties dialog box appears.
6. In the "General" tab, from the "Phase" drop-down list, select "Drain (EPH)".
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7. In the "Output material" tab, in the "Material (set)" column, select "Piccata Milanese". In the 
"Quantity (set)" column, enter the value "1.9".

8. In the "Parameters" tab, in the "Value" column, enter the value "5".

9. Click on the "OK" button and then save the recipe
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10.To Configure "Serve Sauce", repeat steps 4 to 8 with assignment of "Tomato sauce hot & spicy" 
Output material in step 7.
Note
Process events can be monitored as well as a defined area of a recipe (monitoring area).  A 
command step transfers a command (S88 command) in the recipe operation to one or more 
target recipe elements (RPEs).

11.In the Recipe menu bar, click "Save". Now, click "Check validity" to validate the master recipe.
Click "OK" in the Acknowledge window to complete validation.

12.Close the "Recipe Editor".

4.2.21 Releasing the Master Recipe for Production

Introduction
Before you can use your master recipe "Training_Recipe V1.0" to create a batch, the recipe must 
be released for production or testing.
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Procedure
To release the master recipe for production:
1. In the "SIMATIC BATCH: Control Center" window, right-click the "Training Recipe V1.0" master 

recipe, and then click "Release for production".

Note
If you cannot edit the recipe, activate the "Allow editing of recipes with "release revoked" 
status" in the Options - Project settings dialog box of Batch Control Center.
Online structure change is applicable for recipes which are released for testing.

2. Check your project settings.
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4.2.22 Creating an Order (Batch)

Procedure    
To create an order:
1. In the "SIMATIC Batch: Control Center" window, right-click the "Orders" folder, and then right-

click "New". The "New order category" dialog box appears.

2. In the "Name" input box, enter "order_category_GS", and then click "OK".
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3. Right-click the "order_category_GS" folder and click "New". The "Create order" dialog box 
appears.
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4. In the "Name" input box, enter "Order_GS", and then click "OK".
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5. Right-click the "Order_GS" folder and click "New". The "Add batch(es)" dialog box appears.

6. Click "New". The "Selection of formula or master recipe" dialog box appears.
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7. Select "Training Recipe V1.0" and click "OK". In the "Add batch(es)" dialog box. By default, the 
unique Batch name will be mentioned. This can be changed as per user's requirements.

8. Click "OK". The "Batch" object is created in the "Order_GS" folder.
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4.2.23 Releasing and Starting a Batch (Control Recipe)

Procedure 
To release and start a batch:
1. In the "SIMATIC BATCH: Control Center" window, right-click the "Batch" object, and then click 

"Open control recipe". The "Control recipe: Order_GS / Batch" window appears. 

2. Right-click the "Batch" object, and then click "Release". The "SIMATIC BATCH: Control Center" 
dialog box appears.
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3. Click "Yes". The color of the control recipe icon changes as shown in the following image:
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4. Right-click the "Batch" object, and then click "Start". The "SIMATIC BATCH: Control Center" 
dialog box appears. Note that you must activate WinCC Runtime to start the batch. 

5. Click "Yes". 
The color of the control recipe icon changes as shown in the following image. The units are 
occupied and started according to the recipe structure.

6. Close the "SIMATIC BATCH: Control Center" window and deactivate WinCC Runtime.
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Creating an equipment phase using SFC and BATCH 
interface blocks 5
5.1 Task definition and implementation concept

Overview 
An additional equipment phase is required for the "Pan" unit. This unit must be extended by 
adding the "Quench" equipment phase. A selectable quantity of a material, for example, red 
wine, will be added through a quench valve.
To simplify matters, the process of reaching the set quantity will be simulated by a selectable 
time. If the batch is held or aborted, the valve will close.
Select blocks from the SIMATIC BATCH block library to implement the equipment phase.

Note
This chapter shows you a formerly used way to create a phase for batch. In some of the old 
projects you will find these solutions.
This solution is included for completeness in the Getting Started and can be optionally im-
plemented.
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The following table describes the process values:

Process value name Block Data type Comment
Quantity IEPAR_PI REAL  
Duration IEPAR_REAL REAL  

The following table describes the block:

Block name Block Comment
P1_V1 IEPAR_PI  
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5.2 Expanding the plant hierarchy

Prerequisite
• Plant view is activated

Procedure   
To expand the plant hierarchy:
1. Open your edited BATCH Getting Started project "SBGS_MP" in "SIMATIC Manager".
2. Right-click the "Pan" unit and select Insert New Object > Hierarchy Folder. The "Device(7)" 

folder is created.
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3. Rename the "Device(7)" folder as "Quench". This folder is automatically displayed as an 
equipment module. It can be used for SIMATIC BATCH.
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4. Right-click the "Quench" folder and select Insert New Object > Hierarchy Folder. The 
"Element(1)" folder is created.

5. Rename the "Element(1)" folder as "Quench_Valve". The control modules (associated valve, 
in this case), should be located at this level.
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5.3 Configuring the control module level (Valve P1_V1)

Procedure   
To configure the control module level (Valve P1_V1):
1. Right-click the "Quench_Valve" folder and select Insert New Object > CFC. The "CFC(1)" 

chart is created.
2. Rename the "CFC(1)" chart as "Valve".
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3. Open the "Valve" chart and click "Libraries" tab. As shown in the figure below, drag and drop 
the valve block "VlvL [FB1899: Valve - Large]". Assign the name "P1_V1" to the valve block.
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4. Interconnect output "Ctrl" with inputs "FbkOpen" and "FbkClose" and invert "FbkClose".

5. Right click "P1_V1 > Object Properties". The "Properties - Block -- Valve\1" appears. Navigate 
to "I/Os" tab  and clear the "Invisible" check box for "BatchEn", "BatchID", "BatchName", 
"Occupied" and "StepNo" inputs and outputs. 
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5.4 Configuring BATCH interface blocks

Procedure     
To configure BATCH interface blocks:
1. In the "Quench" folder, create a CFC chart named "Quench_EPH". Make sure that the 

"Quench" folder already contains the "Quench_Valve" subfolder.

2. Open the "Quench_EPH" CFC chart and add "IEPH", "IEPAR_PI", and "IEPAR_REAL" blocks from 
the "SIMATIC BATCH Blocks" library. 
Assign the name "Quench" to the "IEPH" block. Set "Quench" as input value to the "F_TYPE" 
input. Assign the name "Quantity" to the "IEPAR_PI" block and the name "Duration" to the 
"IEPAR_REAL" block.
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3. Interconnect the "EPE_CONN" output of the "IEPH" block (Quench) with the "EPE_CONN" 
inputs of the "IEPAR" blocks (Quantity, Duration).
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4. Add the "TimerP" block for the simulation of the "Duration" process value. Assign the name 
"Duration_Timer" to the "TimerP" block.

5. For the "TimerP" block, set the "Mode" input to "1". Interconnect the "Duration" block with the 
"Duration_Timer" block as follows:

Duration / Q_SP_VAL with Duration_Timer / Ti
Duration_Timer / TimeRema with Duration / ACT_VAL
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6. Interconnect the "Quantity" block for the simulation as follows:

Quantity / Q_SP_VAL with Quantity / ACT_VAL
Quantity / QMAT_SP with Quantity / MAT_ACT
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7. Make the interconnections between the Batch control block "Quench" and the valve block as 
shown in the table. Open the two blocks in the CFC Editor, arrange the opened windows next 
to each another:

Quench / QBA_EN with P1_V1 / BatchEn
Quench / VSTEP_NO with P1_V1 / StepNo
Quench / VBA_ID with P1_V1 / BatchID
Quench / VBA_NAME with P1_V1 / BatchName
Quench / Q_OCCUPI with P1_V1 / Occupied

8. Close the CFC Editor.

5.5 Creating an SFC

Introduction  
The configuration of the SFC explained here is only an example. For more information about the 
configuration of SFCs, refer to PCS 7 Getting Started Part 1 and Part 2  and the help files on SFC.
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Procedure
To create an SFC:
1. In the "Quench" folder, create an SFC with the name "Quench_SFC". Make sure that this folder 

already contains the "Quench_Valve" subfolder and the "Quench_EPH" CFC chart.

2. Open the SFC and configure the "RUN" sequencer. Base your configuration on the outline. The 
"Duration_Timer" block is available in the "Quench_EPH" chart, and the "P1_V1" block is 
available in the "Valve" chart.

3. Double-click the "RUN" sequencer tab to open the "Properties" dialog box. Click the "Start 
condition" tab and set the properties as shown in the following example.

Diagram of the "RUN" sequence (RUN=1)
Path for the Start condition:
Kitchen\Stove_1\Pan\Quench\\Quench_SFC.RUN
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Result
Rename and configure the sequencer as per the names shown in the figure below.
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Example of a step and of a transition
Step: Start Timer
1. Double-click the "Start Timer" step. The "Properties - Start Timer" dialog box appears. 

2. Click the "Processing" tab and click "Browse". The "Browse" dialog box appears with the "Plant 
View" tab activated. 

3. Select the "Duration_Timer" block in the tree view. The section on the right side shows all 
corresponding block inputs and outputs.
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4. Right-click the "In" input and click "Open Structure".
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5. Select the "Value" row, click "Apply", and then click "Close".

6. In the right side input box, enter "1".

7. Click "Apply" and then click "Close".

Transition: Timer ended
Follow the steps explained for the "Start Timer" block and set the following conditions for the 
"Timer ended" block.
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Path for the Conditions:
Quench\Quench_Valve\\Valve\P1_V1.Opened.Value
Kitchen\Stove_1\Pan\Quench\\Quench_EPH\Duration_Timer.Out.Value

The following diagram guides you to configure the remaining parts of the sequencer. Please 
follow the same steps as per the given examples:
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1. In the "Quench_SFC" chart, right-click the "RUN" tab, and then click "Insert Sequencer at End". 
A new sequencer "SEQ1" is added next to "RUN" sequencer.

2. Right-click the "SEQ1" tab and click "Sequencer Properties...". The "Properties" dialog box 
appears.
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3. In the "General" tab, in the "Name" input box, enter "Abort-Hold-Comp".
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4. Click the "Start condition" tab and configure the start conditions for the sequence:
– Activate the "I/Os" view via the menu bar of SFC.
– Drag-and-drop the output parameters "HOLDING", "ABORTING" and "COMPLETING" 

parameters as start conditions.
– Create a logical OR operation to logically connect the configured parameters of the "Start 

condition".

Note
The logical expressions has to be changed from "& - AND" to ">_1 -OR" in the figure above.
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5. Click "Apply" and then click "Close".
6. Configure the "Abort-Hold-Comp" sequencer as shown below:

The following is a screen shot of the Hold/Abort/Complete sequence (Holding=1, or 
Aborting=1, or Completing=1). For configuring the rest of the sequence refer to Example of 
a step and of a transition in this chapter.
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1. In the SFC chart window, on the "SFC" menu, click "Properties". The "Properties SFC chart" 
dialog box appears.

2. Click the "AS Operating Parameters" tab and from the "operating mode" drop-down list, select 
"AUTO".

3. Click "OK".
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5.6 Connecting the BATCH control commands with the SFC

Procedure
To connect the BATCH control commands with the SFC:
1. Right-click the "Quench_SFC" chart and click "Open External View". The "Quench_SFC 

(External View)" window appears.

2. Open the "Quench_EPH" chart with the "Quench" interface block.
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3. Interconnect the "Quench" interface block with the external view of the "Quench_SFC" chart 
as shown below:
Note
Start by activating the visibility of all parameters listed below.

Quench / QSTART with Quench_SFC / START
Quench / QHOLD with Quench_SFC / HOLD
Quench / QSTOP with Quench_SFC / STOP
Quench / QABORT with Quench_SFC / ABORT
Quench / QRESET with Quench_SFC / RESET
Quench / QTERM with Quench_SFC / COMPLETE
Quench / QCONT with Quench_SFC / CONT
Quench / QBA_EN with Quench_SFC / BA_EN
Quench / VSTEP_NO with Quench_SFC / STEP_NO
Quench / VBA_ID with Quench_SFC / BA_ID
Quench / VBA_NAME with Quench_SFC / BA_NA
Quench / Q_OCCUPI with Quench_SFC / OCCUPIED
Quench / USTAT_L with Quench_SFC / BA_STATE
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4. Export the plant hierarchy from AS to OS so that required tags/pictures/faceplates are 
updated, to do the same,
Right Click on Multiproject “SBGS_MP” > Plant Hierarchy > Update in the Multiproject, refer 
the following images:
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5.7 Compiling and downloading the AS and OS

Procedure 
To compile and download the AS and OS:
1. Open the "Quench_SFC" chart in external view.

2. On the "Chart" menu, select Compile > Charts as Program. The "Compile program" dialog 
box appears.
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3. In the "Scope" area, click "Changes only". If this option is disabled, then select "Entire 
program".

Note
If you select the "Entire program" option, the "Download S7 - Read back" pop up appears. Click 
'No'. Now, the "Download" pop up appears, Click "Yes". 

4. Click "OK". The "Logs" dialog box appears. 
5. Click "Close".
6. On the "CPU" menu, click "Download". The "Download" dialog box appears.
7. Select "Changes only" and click "OK".
8. After the download, verify that the AS is in RUN_P state.
9. Compile the modified OS data. To do this, in the "SIMATIC Manager", select "OS_Prj", on the 

options menu select 'Compile Multiple OSs' Wizard > Start. The "Wizard: Compile Multiple 
OSs" dialog box appears. Follow the wizard instructions to compile.
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5.8 Generating BATCH types

Procedure
To generate BATCH types:
1. Open the "SIMATIC Manager" in the plant view.
2. Right-click the "SBGS_MP" folder and select SIMATIC BATCH > Open configuration dialog. 

The "Configure Batch process cell 'Kitchen' in 'SBGS_MP'" dialog box appears.
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3. Expand the "Batch types" node and then expand the "Phase types" node.
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4. Click "Generate & Propagate". The new data you configured in the CFC chart "Quench_EPH" 
is now loaded. The "Quench" node is added under "Phase types".

5. Click "OK" to close the "Configure Batch process cell 'Kitchen' in 'SBGS_MP'" dialog box.

5.9 Compiling and downloading BATCH process cell data

Procedure 
To compile and download BATCH process cell data:
1. Right-click the "SBGS_MP" folder and select SIMATIC BATCH > Open configuration dialog. 

The "Configure Batch process cell 'Kitchen' in 'SBGS_MP'" dialog box appears.
2. Select the "Batch instances" folder and click "Merge".
3. Select the "Kitchen" node and click "Download". The "Download Batch process cell" dialog box 

appears.
4. Click "Start".
5. After the completion of the download process, click "Close". 
6. Click "Apply" and then click "OK" to close the dialog.
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Illustrations to the above described procedure items
For illustrations pertaining to the above described steps, refer to Configuring test project 
"Kítchen" > Configuring > "Compiling the AS, OS and Batch Process Cell Data".

See also
Compiling and Downloading the AS, OS and Batch Process Cell Data (Page 48)

5.10 Expanding a Recipe

Introduction
This chapter guides you to expand a recipe and perform associated operations.

Prerequisites
• SIMATIC Manager is open.
• WinCC explorer is open.
• Batch Control Center is activated.
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Procedure  
1. In the "WinCC Explorer" window, start the runtime.
2. Start the Batch Control Center. In the "SIMATIC BATCH: Control Center" window, click "Update 

process cell", and then click "OK".

3. In the "SIMATIC BATCH: Control Center" window, expand the "Master 
recipes>Getting_Started_Template_Recipes" folders and click 
"Template_Recipe_Getting_Started V1.0 > Open". 

4. The "SIMATIC BATCH:Recipe Editor" window appears. Click "OK".

Creating an equipment phase using SFC and BATCH interface blocks
5.10 Expanding a Recipe

SIMATIC BATCH V9.0 Getting Started
154 Getting Started, 08/2020, A5E43020680-AA



5. In the "SIMATIC BATCH:Recipe Editor" window, select Recipe > Save as. 
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6. In the "Save recipe as ..." dialog box, rename the recipe as "Recipe_Quench" in the "Name 
[Template recipe getting started]" text box, and click "OK".
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7. In the "SIMATIC BATCH Recipe Editor" window, insert the newly configured "Quench" phase 
in the "Recipe_Quench" recipe inside the FRY - ROP.

8. Open "FRY ROP" by double clicking. Add recipe phase by clicking .
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9. In the "SIMATIC BATCH Recipe Editor" window, configure the "Quench" phase. To configure 
the "Quench" phase, right click "Quench>Properties".
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10.The "Properties of "Quench_108" window appears. Click on "Input material" tab and select 
"Penne" from the "Material (set)" option.

11.Now, navigate to the "Parameters tab, and enter the values as shown below, and click "OK".

12.Save and Close the "Recipe Editor".
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13.In the "SIMATIC BATCH Control Center" window, select Recipe Quench V1.0 > Release for 
production. Then create a new batch with the "Recipe_Quench" recipe, release and start it. 
For more information, refer to Creating an Order (Batch) (Page 109) and Releasing and 
Starting a Batch (Control Recipe) (Page 114)

14.Close the SIMATIC BATCH Control Center and exit WinCC Runtime.
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Creating an Equipment Phase Using SFC Type        6
6.1 Task definition and implementation concept for "Ventilate"

Introduction
This section guides you to define and implement the tasks for the "Ventilate" phase.

Procedure
An additional equipment phase is required for the pots. You need to add the "Ventilate" phase. 
A ventilation valve must be opened for a selectable time. If the batch is held or aborted, the valve 
will close.
Since the same equipment phase is required for Pots 1-3, select the SFC type to implement it.
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Implementation Concept for SFC Type "Ventilate"

Table 6-1 Control strategies
Control strategy name Comment
Ventilate First control strategy, QCS=1

Table 6-2 Setpoints
Setpoint name Data type Comment
Duration REAL Unit of measure seconds

Table 6-3 Process values
Process value name Data type Comment
None   

Table 6-4 Timers
Block name Block type Comment
T_Duration TimerP Timer for setpoint "Duration", 

Mode=1

Table 6-5 Block contacts
Block name Block type Comment
V1 VlvL Ventilation valve

6.2 Creating an SFC Type "Ventilate"

Introduction
This section guides you to create the "Ventilate" SFC type.

Prerequisites
• SIMATIC Manager is open.
• The SBGS_MP project is open in SIMATIC Manager.
• Component view is activated.
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Procedure  
To add a new SFC type "Ventilate":
1. In the Component view, expand the library “SBGS_Lib”, right-click "Charts" and select Insert 

New Object>SFC type. A "SFC type(1)" is created. Rename it as "Ventilate".
Click on "Ventilate" to open it.

2. In the "SFC" window, click the  icon to open the characteristics dialog of the "Ventilate" SFC 
type. 
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3. Select the "Control strategies" characteristic and enter "Ventilate" under the "Name" column. 
Select the checkbox under the "Default" column. This control strategy initiates the start of the 
SFC instance.
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4. Now select the "Setpoints" characteristic and enter "Duration" in the "Name" column. Select 
"REAL" data type under "Data type" column. Enter "sec" as the unit of measure under the 
"Unit" column.
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5. To define the timer, select the "Timers" characteristic. Enter "T_Duration" in the "Name" 
column. The timers that are used in this way within SFC types, have characteristics similar to 
the standard "Timer_P" block from the PCS 7 library.

6. In the final step, you will create the valve. Select the "Block contacts" and enter the"V1" in the 
"Name" column. In the "Block" column, select the "VlvL" block type.
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You have now specified all the characteristics required for the "Ventilate" example. The 
sequencers must now be created and configured.

6.3 Creating sequencers

Introduction
This section guides you on the process of creating sequencers. The Run sequencer that is 
processed in the "Run" status has already been created. The sequencer which is processed in the 
"Holding", "Aborting" and "Completing" states is still missing. You only need to create one 
sequencer and name it "Abort-Hold-Comp" as the content is the same in all three sequencers.

Prerequisites
• "SFC" editor is open
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Procedure
To insert a new sequencer:
1. Right-click on the "RUN" tab and select "Insert Sequencer at End". A new tab "SEQ1" is created.

2. Right click on the "SEQ1" tab, and select "Sequencer Properties"
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3. In the "Properties - SEQ1" dialog box, select the "General" tab and enter "Abort_Hold_Comp" 
in the "Name" input box.

4. In the "SFC" window, click  icon to open the I/Os dialog of the "Ventilate SFC type".
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5. Navigate to the "Start condition" tab, and add the respective outputs via drag and drop as 
shown below from the "OUT" node in the SFC editor. Later, close the "Properties" dialog box.

Note
The logical expressions has to be changed from "& - AND" to ">_1 -OR" in the figure above.
Add other sequences and steps as shown in the following figures:
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Figure 6-1 Diagram of the "RUN" sequence (RUN=1) for control strategy "Ventilate" (QCS=1)
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Figure 6-2 Diagram of the "Hold/Abort/Complete" sequence (Holding=1, or Aborting=1, or 
Completing=1)

6. Switch to the "RUN" sequencer tab and insert a step using  icon. Right-click on the newly 
added step and select "Object properties". 
In the "General" tab, enter "V1 Auto" in the "Name" input box.
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7. Switch to the "Processing" tab. Drag-and-drop the I/O from the "Block contacts" in the upper 
section to the dialog box for configuring the steps / transitions as shown below.

8. Complete the engineering according to the diagrams shown above.

Creating an Equipment Phase Using SFC Type        
6.3 Creating sequencers

SIMATIC BATCH V9.0 Getting Started
Getting Started, 08/2020, A5E43020680-AA 175



Setting parameters for SFC type Ventilate
In addition to the above mentioned configurations, perform the below mentioned steps in order 
to complete creating the sequencers:
1. In the SFC dialog box, click the  icon. In the "I/Os to Ventilate" area, expand the "Interface" 

list. Now, expand the "IN" list, and set the start value as "1" (extended pulse) for 
"T_duration_MODE" as shown below:

2. Set the start value "1" at parameter CS (control strategy).
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3. Select SFC>Properties. The "Properties SFC type" dialog box appears.
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4. In the "Options" tab, under the "SIMATIC BATCH" area, click on the "category" drop-down list, 
and select "EPH".

5. Navigate to the "AS Operating Parameters" tab. Click on the "Operating mode:" drop-down 
list, and select "AUTO". Click "OK" to close the SFC editor.
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Result
You have succesfully created the "Ventilate" type with all the required configuration.

6.4 Expanding the Plant Hierarchy

Introduction
This chapter will guide you to expand the plant hierarchy.

Prerequisites
• The SBGS_MP project is open in SIMATIC Manager.
• Plant View is activated.
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Procedure   
1. In the "SBGS_MP" window, right-click "Pot_1", and select Insert New Object>Hierarchy folder. 

A new hierarchy folder gets created. Rename it as "Ventilate".

2. Create a CFC chart in the "Ventilate" hierarchy folder. Rename it as "Ventilate_Pot1".

This "Ventilate_Pot1" chart is required for the instance of the SFC type. Now create a 
"Val_Ventilate" folder in the "Ventilate" folder as shown below.
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3. Create the "Pot1_Valve" CFC chart in the "Val_Ventilate" subfolder. In this chart, you 
configure the valve required to ventilate Pot_1.

4. Open the "Pot1_Valve" chart. Place a Valve block (VlvL - FB 1899) with the name P1_V1. To 
simulate the feedback messages, interconnect the CTRL output with the FB_OPEN input and 
interconnect it inverted with the FB_CLOSE input (CTRL must first be made visible). The 
following screen is as shown below
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6.5 Instantiating the SFC Type "Ventilate" at Pot_1

Procedure  
1. Open the chart "Ventilate_Pot1". You will find the previously created type "Ventilate" under 

"Libraries > SBGS_Lib > Charts > Ventilate". Place this block in a chart and name it as 
"P1_Ventilate".
You then have the following screen:

2. Now, open the "Pot1_Valve" chart as well and arrange the two windows side-by-side using 
the   icon as shown below.
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3. The valve P1_V1 must now be interconnected to P1_Ventilate.
– To do this, select the outputs V1_OpenAut and V1_CloseAut (must be set to visible) from 

P1_Ventilate and interconnnect them with the associated valve inputs OpenAut and 
CloseAut of the P1_V1valve. All the relevant interconnections to the valve are now created 
automatically (eight in total).

– In order for all the batch-relevant information that SIMATIC BATCH writes to the block 
instance of "Ventilate" to actually arrive at the corresponding valve, the (five) batch-
relevant outputs must be interconnected with the valve. First, the following parameters 
must be set to visible:

– On the valve P1_V1: BatchEn, BatchID, BatchName, StepNo, OCCUPIED
– On the "Ventilate" P1_Ventilate phase: QBA_EN, QBA_ID, QBA_NA, QSTEP_NO, 

QOCCUPIED
– Interconnect the five outputs of P1_Ventilate (QBA_EN, QBA_ID, QBA_NA, QSTEP_NO, 

QOCCUPIED) to the inputs of the P1_V1 valve (BatchEn, BatchID, BatchName, STEP_NO, 
OCCUPIED).

– Within the "P1_Ventilate" block, Interconnect the "T_Duration_PTIME" output with the 
"Duration_AI" input. This is important for display in the OS faceplate and for reading the 
process values by SIMATIC BATCH. The process value input on "P1_Ventilate" is called 
"Duration_AI" (Actual Value Input).
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– Check the interconnection based on the following picture.

Note
Creating instances of the "Ventilate" SFC type at Pot_2 and 3:
The "Ventilate" equipment phase is also inserted at Pots 2 and 3. The procedure is the 
same as that for Pot 1. Start again with Chapter 6. Create a new "Ventilate" hierarchy folder 
under the Pot_X hierarchy folder. Insert the same equipment phase at Pots 2 and 3. Note 
that the "Ventilate" type is configured only once.

4. Export the plant hierarchy from AS to OS so that required tags/pictures/faceplates are 
updated, to do the same,
In Plant view right click SBGS_MP > Plant Hierarchy > Update in the Multiproject, refer the 
following images:
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6.6 Compiling and Downloading AS, OS, and Batch

Procedure 
1. Compile the changes made to AS data in the CFC Editor and then download this data to 

PLCSIM using a "delta download".
Note
The Runtime OS must be deactivated.

2. Then compile changes of the OS.
3. Open the Batch configuration dialog in the plant view in your project.
4. Select "Batch types". Generate, Propagate the Batch types, merge the Batch instances and 

download the process cell.
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6.7 Expanding a Recipe

Procedure   
To expand a recipe:
1. Start Runtime on the OS.
2. Start the Batch Control Center and right click "Kitchen > Update process cell". The "Updating 

the process cell" window appears.  Now, click "OK"

3. After you complete the update of Batch process cell data, the new "Ventilate" equipment 
phase you configured is available in the "Pot1" unit as a recipe function.

4. Open the "Template_Recipe_Getting_Started" master recipe and save it with the name 
"Recipe_Ventilate".
Note
If you cannot edit the recipe, activate the "Allow editing of recipes with "release revoked" 
status" in the Options - Project settings dialog box of Batch Control Center.

5. Open the recipe "Recipe_Ventilate".
6. Under "RUP Pot_1", open ROP "Cook Pasta".
7. Click " " icon to add a new recipe phase after the simultaneous branch.
8. Double click on the "NOP".
9. "Properties of NOP.." appears.
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10.In the "General" tab, click on the "Phase" drop-down list and select "Ventilate (EPH)".
11.Switch to "Parameters" tab, and enter "20" in the "Value" column. Click "OK".
12.Save and validate the recipe. Close the Recipe Editor.
13.Release the recipe for production. Create, release, and then run a new batch with the 

"Recipe_Ventilate" recipe.
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Creating an Equipment Phase using CMT, EMT & 
EPHT 7
7.1 Task definition and implementation concept for "Cooling"

Introduction
This section guides you to define and implement the tasks for the "Cooling" phase. In this 
application example, the technological engineering shall be used.

Procedure
An additional equipment phase is required for the existing three pots, so you need to add a 
"Cooling" equipment phase. Two cooling valves (Cooling Water Supply and Return valve) must 
be opened for a selectable time.
The same equipment phase "Cooling" shall be used for Pot 1-3.
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Overview of EPHT, EMT & CMT
Before PCS 7 Version 9.0, phase and equipment module logic was usually combined in one SFC 
Type.
The equipment phase (EPH) that is examined here in more detail forms the counterpart to a 
recipe phase. It is controlled directly by the recipe system and must therefore provide a 
compatible command/status model. This is ensured by the operating state logic of the SFC. The 
equipment phase controls the EM assigned to it in a coordinated manner. If you integrate one 
or more phases in an equipment module, this is designated in ISA-88 as "recipe aware". The 
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control strategies of an equipment module then correspond to the phases. This has been the 
approach implemented in SIMATIC BATCH for years.

Things possible from Beginning of PCS 7 Version 9.0:
• Separation of Equipment Phase (EPH) and Equipment Module (EM) logic
• Control of several EMs by one EPH
• Use of one EM through multiple EPHs
• Integrated EM allocation logic (Assignment)
In this use case, the Type-Instance-Concept shall be used, starting with the Control Module Type 
(CMT) in the master data library, followed by the Equipment Module Type (EMT) and Equipment 
Phase Type (EPHT). 

7.2 Creating Control Module Type in Master Data Library

Overview 
Two valves are needed for the “Cooling” phase, which shall be instances of the same valve CMT, 
so the creation of a Valve CMT will be explained in this Chapter.

Prerequisite
• Plant view is activated.
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Procedure
Creation of a new Control Module Type (CMT):
1. Open your edited BATCH Getting Started project "SBGS_MP" in "SIMATIC Manager".
2. Right-click the "SBGS_Lib" Master Data Library and select Insert New Object > Hierarchy 

Folder. A new folder "Process cell (…)" is created.

3. Rename the "Process cell (…)" folder to “CMT”.
4. Right-click the "CMT" in Master Data Library and select Insert New Object > Control Module 

Type. The "CM" CMT is created; rename the “CM” to " Valve_CMT".
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5. Open the CMT "Valve_CMT", insert the "VlvL" block from the “SBGS_Lib” library and rename 
it to “VlvL”.

6. Interconnect output "Ctrl" with inputs "FbkOpen" and "FbkClose", then invert "FbkClose".

Note
To simplify the configuration, we do not use driver blocks in this example.
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7. Drag & drop the valve block "VlvL" on top of Valve_CMT.
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8. Right Click on CMT “Valve_CMT” and insert commands and status, rename the same in the 
name field according to the following table (we need four commands and three status).
Command:

Command Name Description
SetAuto Set Valve to Auto Mode
SetAutoOFF Switch Off Auto Mode
Open Open the Valve
Close Close the Valve

Status:

Status Name Description
Is Auto Is Valve in Auto mode?
Is Opened Is Valve Opened?
Is Closed Is Valve Closed?
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9. This example will show how to write the logic to set the valve to Auto mode:
– Select the Command "SetAuto", select “Properties” from the context menu.
– Select 1st row in Processing tab, click on Browse and select "ModLiOp.Value", then press 

Apply and Close and enter "1".
– Select 2nd row and Click on Browse and select "AutModLi.Value", then press Apply and 

Close and enter "1".
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10.Add the remaining commands in Processing tab according to the following table:

Command Command Logic
SetAutoOFF AutModLi.Value=0

ModLiOp.Value=0
Open OpenAut.Value=1

CloseAut.Value=0
Close OpenAut.Value=0

CloseAut.Value=1
Implement the remaining commands “SetAutoOFF”, “Open” and “Close” according to the 
following Image:
SetAutoOFF:

Open:

Close:
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11.Write the logics to get the status of the valve block. This example will show how to get the 
auto mode status of the valve (Is Valve in Auto Mode?).
– Select status "IsAuto", select “Properties” from the context menu
– Select 1st row in “Condition” tab
– Click on Browse and select "AutAct.Value", then press Apply and Close and enter "1"

12.Add the remaining statuses in the “Condition” tab according to the following table:

Status Name Status Logic
Is Opened FbkOpenOut.Value = 1
Is Closed FbkCloseOut.Value = 1

Is Opened:       

Is Closed:

13.Click Valve_CMT and then change the Sampling time to 1000 ms:

Configuration of CMT is completed.
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7.3 Creating Equipment Module Type in Master Data Library

Overview 
For implementation of the Cooler equipment, we will create an Equipment Module Type (EMT) 
“Cooler_EMT” in this chapter.

Prerequisite
• Plant view is activated.

Procedure 
To create a new Equipment Module Type (EMT):
1. Open your edited BATCH Getting Started project "SBGS_MP" in "SIMATIC Manager".
2. Right-click the "SBGS_Lib" Master Data Library and select Insert New Object > Hierarchy 

Folder. The "Process cell(…)" folder is created.
3. Rename the "Process cell(…)" to EMT.
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4. Right-click the "EMT" in Master Data Library and select Insert New Object >Equipment 
Module (Type). The "EM" EMT is created; rename the “EM” to "Cooler_EMT".

5. Open the EMT “Cooler_EMT”, Rename the EMT Block to “Cooler_EMT”. This name will be 
visible on your OS.
To change the EMT Block name, select the block right click select Object properties; enter 
“Cooler_EMT” into the name field.
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6. Set Sampling time to 1000 ms.
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7. To add configured CMTs into an EMT, there is a new tab named “Templates” under catalogue 
as shown below:
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8. Drag & drop “Valve_CMT” from catalogue “Templates” tab on top of “Cooler_EMT”:
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9. When CMT is moved into the EMT, a copy of the CMT Blocks is stored within the chart of the 
EMT. 
Because this is not desired, the CMT must be declared as a “Basic requirement”. To do this, you 
set the “Basic requirement” property of the CMT.

Then following prompt appears click Yes & refresh the Sheet (Press F5):
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10.Insert two “Control Module Assignment”-roles to the EMT since we need two valves for our 
equipment module type:
Select “Insert New Object > Control Module Assignment” from the context menu of EMT 
“Cooler_EMT”. 

Rename the Control Module Assignment “Role” according to following table:

Role Description
CWSupVlv Cooling Water Supply Valve
CWRetVlv Cooling Water Return Valve

Creating an Equipment Phase using CMT, EMT & EPHT
7.3 Creating Equipment Module Type in Master Data Library

SIMATIC BATCH V9.0 Getting Started
Getting Started, 08/2020, A5E43020680-AA 209



11.Assign the Valve_CMT to the role "CWSupVlv ", "CWRetVlv ": Select Roles "CWSupVlv" and 
"CWRetVlv" and Drag and drop it to "Valve_CMT".
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12.Internal commands for controlling the SFC are not permanently coded in the program 
package but instead they are implemented as part of the SFC library. In this way, Commands 
can be modified, and new commands can be created.
In order to add the prepared commands to the Master Data Library (MDL), open SFC library 
and change the view to plant view and copy the complete "CmdStatlib" folder to MDL folder. 
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13.Open the EMT ”Cooler_EMT” from MDL, right click on the EMT block and select “Open SFC 
Type” to add a Set point and a Timer.
In order to add Set point, click on View > Characteristics > Setpoints, enter the name and 
other parameters according to the following table:

Name Data Type Initial Value Low Limit High limit
Duration Real 10.0 10.0 600.0

In order to add Timer in Characteristics view, click on Timers and enter the name "T_Duration" 
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14.Insert the Steps in SFC Type and rename the steps and transitions according to the following 
Image:
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15.Now Insert the commands which have been created in CMT “Valve_CMT” into Action Table of 
Steps. Example:
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– Step 1: “Valves Auto Mode”
To set valves into Auto mode, double click on step “Valves Auto Mode”; change to “Actions 
(technological)” tab, then click on the pencil symbol of the 1st row.
Right Click on Actions > Insert Commands > CWRetVlv > ”SetAuto”.

Similarly, set the 2nd valve into Auto mode: Click on pencil symbol on row number 2 > 
right click on Actions > Insert Commands > CWSupVlv > “Set Auto”.
Then click Apply > Close.:

Similarly reset the Timer:
Click on pencil symbol on row number 3 > right click on Actions > Insert Commands > 
<this object> > Timer > ResetTimer, select Timer object “T_Duration” from dropdown list 
> Click Apply > Close.
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Complete all the steps as shown in the following pictures
– Step 2: “Open Valves”.
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– Step 3: “Start Timer”: In this step Timer needs to be started. While timer is running, write 
the actual time to EMT output (later referenced by the calling EPHT).
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WriteElapsedTimeToActual
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Note
SUB Function has to be inserted in Value field.
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– Step 4: “Close Valves”: In this step Close both valves:
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– Step 5: “SetAutoOFF”: In this step, deactivate the Auto mode so that operator can switch 
the valves to Manual mode and operate manually.

16.Now insert the status conditions, which have been created in CMT, into the “Condition 
(Technological)” tab of the transitions.
Example: Transition “All Valves Auto”:
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– Condition 1: Check if both valves are in Auto mode:
Click on “Condition (Technological)” tab then click on spectacle symbol. Right click on 
“Please insert status of function”, then “Insert Function > "& AND”.
Rename the Condition name as “IsAuto”
Right Click on IN1 > “Insert Status” > CWRetVlv > IsAuto,
Right Click on IN2 > ”Insert Status” > CWSupVlv > IsAuto
Apply and Close
Enter “1”in condition, Apply and Close.
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Complete rest of the conditions as shown in the figures below.
– Condition: 2: “All Valves Open”
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– Condition 3: “Timer Expired”
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– Condition 4: “All Valves Closed”

Open properties SFC type and select AS operating parameter tab.
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In SFC Type Properties, in “AS Operating Parameters” tab set Operating Mode to Auto, in 
Options tab set WinCC block icon to value 2: 
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7.4 Creating Equipment Phase Type in Master Data Library

Overview 
EPHT is responsible for acquiring and controlling of the generic equipment modules used by this 
recipe phase and for transfer of the parameters from SIMATIC BATCH to EMT and vice versa.
For more information on "generic equipment modules" refer: Task definition and 
implementation concept for "Cooling" (Page 193)

Prerequisite
•  Plant view is activated
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Procedure 
 To create a new Equipment Phase Type (EPHT)
1. Open your edited BATCH Getting Started project "SBGS_MP" in "SIMATIC Manager".
2. Right-click the "SBGS_Lib" Master Data Library and select Insert New Object > Hierarchy 

Folder. The "Process cell(…)" folder is created.
3. Rename the "Process cell(…)" folder to “EPHT”.
4. Right-click the "EPHT" in Master Data Library and select Insert New Object > Equipment 

Phase (Type). The EPHT is created, rename the default name EPH to "Cooling_EPHT".
5. Open the Cooling_EPHT; Rename the EPHT Block to “Cooling_EPHT”. This name will be visible 

later on your OS. To change the EPHT Block name, double click on the block header; enter 
“Cooling_EPHT” into the name field. To change the SFC type name, select “Open SFC Type” 
from context menu of the “Cooling_EPHT” block; in “SFC” menu, select “Properties” and you 
can find “Cooling_EPHT” in the name field. 

6. Change the Sampling time to 1000 ms.
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7. From the “Template” tab of the catalogue, drag & drop the EMT "Cooler_EMT" to 
"Cooling_EPHT":
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8. Insert Equipment Module Assignment: Right click on Cooling_EPHT, from context menu 
select “Insert New Object > Equipment Module Assignment”: 

9. Rename the Equipment Module Assignment “Role” to "Cooler" and assign the role by drag and 
drop of "Cooler_EMT" onto the role "Cooler", or alternatively select role “Cooler” and from 
dropdown list of Attribute “Assigned equipment module” select Attribute value “Cooler_EMT”:

10.Open the SFC type "Cooling_EPHT"
11.Create a set point “Duration” and set the values according to the following table.

Set point Initial value Low limit High limit Data type
Duration 10.0 10.0 600.0 Real
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12.Design the EPHT according to the following image: EPHT is used to control EMT, transfer the 
SP to the EMT and to receive the actual value from the EMT.
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13.To control EMs or perform actions on EMs, suitable commands need to be passed and actual 
values and set points need to be exchanged between EPHT and EMT
– Acquire EM   

To add an action to the step “Acquire EM”, open this step, switch to the “Actions 
(technological)” tab click on the pencil symbol  
 From the context menu select “Insert Command > Cooler > EM_Acquire > EMAQAcquire” 
and select Type "Now" from drop down list:

Complete the remaining steps according to the figures below:
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– “Set EM Auto”.
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– “Write SP”: In this set point step we need to perform multiple actions. The following 
actions are performed.
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– “Start EM”
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– “Wait”: In order to get the elapsed time: Drag and drop “Cooler” from “Block contacts” on 
top of Value field, then the “Select Connection” window appears; select 
“Cooler_Duration_AO” and press OK. 
Rename the action with a suitable name denoting the operation you want to perform. For 
example ReadElapsedTimeFromCooler.
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– “Reset EM”
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– “Release EM”

Now we have completed the steps, status or condition needs to be configured as follows:
Example: Check whether EM is acquired > transition “IsEMAcquired”:
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– Open transition, switch to “Condition (technological)” tab, click on spectacle symbol, 
from context menu select “Insert Status > Cooler > EM_Acquire > IsEMAQOwner”:
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– “IsEMAuto”
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– “IsEMRun”
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– “IsEMCompleted”
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– “IsEMIdle”
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– “IsEMReleased”: In this Status we need to check whether “Cooling_EPHT” is not owner of 
this EM anymore:
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14.For usage of the “Cooling_EPHT” within SIMATIC BATCH recipes, a separate Interface SFC type 
can be created in the MDL, just providing the characteristics (control strategies, set points 
etc.), but no sequence logic. This SFC with type “EPH (interface)” calls the EPH with type “EPH 
(derived)”, providing the sequence logic.
To do so, create a new SFC Type (EPH) in the chart folder (Component view) of the MDL and 
rename it to “Cooling” (this name will be listed in the SIMATIC BATCH recipe). Under 
properties of SFC type (EPH) options tab, set Category to “EPH (interface)”, for “Create block 
icon” select value 2:
From "AS Operating Parameters" tab set "Operating mode" to "Auto".
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15.In SFC type “Cooling”, create a new Set point “Duration” with Data type as real, Initial value 
and Low limit = 10 and High limit = 600.

16.Open the Properties of your previously created EPHT "Cooling_EPHT" in the MDL
In the “AS Operating Parameters” tab, set Operating mode to “AUTO”.
In the “Options” tab set Category to “EPH (derived)” and in “Derived from interface” select 
“Cooling”; for “WinCC Create block icon” enter value ‘2’ in order to create a block icon in OS.

Note
In real projects, sequences for Abort, Hold and Stop are to be implemented normally, e.g. Abort/
Hold/Stop will NOT be propagated automatically from EPHT to EMT, so EMT doesn’t care about 
any Abort/Hold/Stop command to the calling recipe phase. Programming can be quite extensive! 
Same is not shown in this example.
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7.5 Instantiating the CMT, EMT & EPHT in the Project

Overview 
After creation of the required CMT, EMT and EPHT, these need to be instantiated in the Hierarchy 
folder of the Multiproject. In this section we will learn how to instantiate and configure these 
objects for control from SIMATIC BATCH.

Prerequisite
• Plant view is activated

Procedure 
To instantiate the CMT/EMT/EPHT, just copy & paste the object or drag & drop from Master Data 
Library into Hierarchy folder of unit and rename the instances.
To Instantiate follow these steps:
1. In the Plant View open your edited BATCH Getting Started project "SBGS_MP" in "SIMATIC 

Manager".
2. Expand the Process Cell Kitchen which is in the AS_Prj.
3. Right-click on "Pot_1"; select “Insert New Object > Hierarchy Folder” from context menu and 

rename the same as "Cooling". In the folder Properties, select “Equipment phase” in the 
“ISA-88 Type Definition” tab. Repeat this step for Pot_2 and Pot_3.

4. Copy two instances of “Valve_CMT” from Master Data Library into the Cooling Hierarchy 
folder of Pot_1, Pot_2 and Pot_3 and rename the same as "Potx_CW_Supply" & 
"Potx_CW_Return” (replace x with pot number).

5. Now copy “Cooler_EMT” from Master Data Library into the Cooling Hierarchy folder of Pot_1, 
Pot_2 and Pot_3 and rename the same to "Pot1_Cooler", "Pot2_Cooler" and "Pot3_Cooler".

6. Finally copy “Cooling_EPHT” from Master Data Library into the Cooling Hierarchy folder of 
Pot_1, Pot_2 and Pot_3 and rename the same to “Pot1_Cooling”, “Pot2_Cooling” and 
“Pot3_Cooling”.
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7. Export the plant hierarchy from AS to OS so that required tags/pictures/faceplates are 
updated, to do the same
Right Click on Multiproject “SBGS_MP” > Plant Hierarchy > Update in the Multiproject, refer 
following image:
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8. Open the EM from Project hierarchy folder
In our example open "Pot1_Cooler" and assign control modules for both valves of Pot_1; 
refresh the window by pressing F5 to see the connections:
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9. To have the Batch information to CMs, we need to wire the following connections. Set 
following pins to visible in both EM and CMs (Valve block)* and connect the pins according 
to the following table; repeat the steps for all CMs and all EMs.

EMT  CMT(VALVE)
QOCCUPIED Occupied
QBA_ID BatchID
QBA_NA BatchNam
QSTEP_NO StepNo
QBA_EN BatchEN

Note
This could also be done in the MDL and synchronized to the complete Multiproject (see PCS 
7 Compendium Part C for details).

10.Repeat the steps number 8 and 9 for Pot_2 and Pot_3 
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11.Instantiate (Copy) Interface SFC-type from Library Chart folder to Project chart folder.

12.Open the EPHT “Pot1_Cooling” from Project hierarchy of Pot_1. Assign the Equipment 
Module Type Pot1_Cooler. Refresh the window, then connections between the EPH & EM are 
visible.

13.Repeat step 12 for Pot_2 and Pot_3 
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14.Completed project looks like the following image

15.After engineering of CMs, EMs & EPHs, we need to compile and download AS charts and 
compile the OS to reflect the same in the AS and OS.
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16.Compile and Download the Batch data
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17.Open the BATCH Control Center and update the process Cell:

18.Open previously created “Recipe_Quench” and save as “Recipe_cooling”
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19.Open the recipe “Recipe_cooling” and add new ROP under Pot_1, rename the same as 
“Cooling” and open it:

20.Within the ROP Cooling, add a Cooling phase and set the parameter “Duration” to 120 sec:
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21.Release the recipe for testing and create a new Batch, release and start it.
22.In WinCC and BATCH Control Center (BCC) the visualization of the running batch will look like 

this:
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