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Safety Guidelines

This manual contains notices intended to ensure personal safety, as well as to protect the products and
connected equipment against damage. These notices are highlighted by the symbols shown below and

graded according to severity by the following texts:

Danger

precautions are not taken.

indicates that death, severe personal injury or substantial property damage will result if proper

Warning

precautions are not taken.

indicates that death, severe personal injury or substantial property damage can result if proper

Caution

> B P

indicates that minor personal injury can result if proper precautions are not taken.

Caution

indicates that property damage can result if proper precautions are not taken.

Notice

draws your attention to particularly important information on the product, handling the product, or to a

particular part of the documentation.

Qualified Personnel

Only qualified personnel should be allowed to install and work on this equipment. Qualified persons are
defined as persons who are authorized to commission, to ground, and to tag circuits, equipment, and
systems in accordance with established safety practices and standards.

Correct Usage

Note the following:

Warning

/N

This device and its components may only be used for the applications described in the catalog or the

technical description, and only in connection with devices or components from other manufacturers
which have been approved or recommended by Siemens.

This product can only function correctly and safely if it is transported, stored, set up, and installed
correctly, and operated and maintained as recommended.

Trademarks

SIMATIC®, SIMATIC HMI® and SIMATIC NET® are registered trademarks of SIEMENS AG.

Third parties using for their own purposes any other names in this document which refer to trademarks might
infringe upon the rights of the trademark owners.

Copyright © Siemens AG 2001 All rights reserved

The reproduction, transmission or use of this document or its
contents is not permitted without express written authority.
Offenders will be liable for damages. All rights, including rights
created by patent grant or registration of a utility model or design,
are reserved.

Siemens AG
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Disclaimer of Liability
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the hardware and software described. Since deviations cannot be
precluded entirely, we cannot guarantee full agreement. However,
the data in this manual are reviewed regularly and any necessary
corrections included in subsequent editions. Suggestions for
improvement are welcomed.
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1 PCS 7 Migration

Data Backup

Before migration, you should make a backup of all your existing data if you have
not already done so. This involves the following:

» Creating a backup copy of the entire project or creating an image of the hard
disk (documentation for the project).

e Saving your old versions and your own project libraries (see also Section
3.2.1).

Note

If you want to upgrade a plant and have modified parameters on the PLC online
(for example modified by the operator online at the OS), and want to retain this
configuration, remember to save the data by reading back from the PLC.

See also "Data Integrity and Consistency" in PLC-OS Engineering 3.5.

1.1 Migration from PCS 7 V4.x to V5.1

When upgrading from PCS 7, version 4.x, to V5.1, you yourself can decide both
which migration steps you use to implement the new functions and when you want
to use them. You can therefore vary the extent of the migration to suit your needs.
Possible scenarios are listed below:

These situations are in themselves unrelated, but may occur sequentially.

Process Control System PCS 7, PCS 7 Migration V5.1
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PCS 7 Migration

1.1.1 Partial Migration of the OS System (Case 1)

You have a version 4.x project and want to upgrade just the OS to V5.1, so that
you can use the new OS blocks, but without immediately updating or upgrading the
PLC in your project. If you upgrade your system in this way, no PLC-OS transfer is

permitted.

You want to update the PLC data in your project later at a more suitable time so
that you can benefit from the many bug fixes and improvements.

See also Section 3.6 (except for Sections 3.6.15 and 3.6.17).

During this partial migration, the PLC can remain in RUN mode, however the
process cannot be controlled by the operator since the OS must not be in run time.

1.1.2 Partial Migration PLC and OS (Case 2)

You have a version 4.x project and want to use the new V5.1 ES software (CFC,
SFC, PH, IEA). You prefer to retain the current functionality for the time being, so
that plant operations will not be interrupted for long at the time of migration. The
new V5.1 functions will only be used when the system is upgraded later on, at
which time new configuration work can be done.

In this case, you will need to make minor adaptations, compile the entire program,
change the CPU to STOP and download the entire program. It will also be
necessary to transfer the PLC-OS connection data. If you have already taken the
steps required in situation 1, not all the steps listed in Section 3.6|will be
necessary.

See also Section|2, Partial Migration of the PLC System and OS System (Case 2)

For this partial migration, the PLC system must be stopped and the OS system
must not be in run time.

1.1.3 Full Migration (Case 3)

You have a version 4.02 project and want to upgrade your system. You want to
use not only the new V5.1 ES and OS software, but also require the full range of
the new functionality (or possibly just certain options) including the new block
libraries. This upgrade can also include new CPUs and updating the operating
system.

See also Section 3, Full Migration (Case 3)

For this migration, the PLC system must be stopped and the OS system must not
be in run time.

Remember also that in this situation when you migrate from client to multi-client,
there are restrictions in the use of some functions. See also 3.6.15

Process Control System PCS 7, PCS 7 Migration V5.1
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PCS 7 Migration

1.2 Upgrading from PCS 7 V5.0 to V5.1

You have a V5.0 project that resulted from full migration from PCS 7 V4.02 or that
you created subsequently with the V5.0 software.

Upgrading to Use the New Functionality

You want to use the new functions available with PCS 7 V5.1 and intend to
upgrade the project (see Sections 4.1 and 4.2).

Upgrading / Modifying the Configuration with the Plant Running

Upgrading a redundant system with the plant running is described in Section 1 and
modifying the configuration of a redundant system with the plant running is
described in Section 5.2.

Process Control System PCS 7, PCS 7 Migration V5.1
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2 Partial Migration PLC and OS

You have installed the V5.1 software (ES and OS) but want to continue using your
old project for the time being. Program adaptations should be kept to the absolute
essentials. If the old ES software also includes the SFC software, the program
must be compiled and downloaded (see point 3). You must, however, set the CPU
to STOP briefly:

1.
2.

Convert the plant hierarchy. For further information, see Section 3.3.1.

Open a CFC or SFC chart in your project and make a change in the chart (for
example, change the value of an 1/O).
As a result, the data in the chart folder is converted to the new format.

Copy the new FB300 (SFC_INTP) from the SFCLIB library into the block folder
for the project.

The run-time behavior of the sequential control system changes ("non-latching
behavior"; in other words, termination and initialization actions in consecutive
steps are executed within a single cycle).

From then on it is no longer possible to compile changes only and download
online.

Adaptations to the SFC charts that may become necessary as a result are
explained in Section|3.3.12.

Run the "Generate Module Drivers" function. The MSG_CSF and PO_UPDAT
blocks are then automatically inserted in a new chart.

Refer to the online help for further information.
Check whether your project includes SFC charts that

- contain run-time attributes that differ from the default "scan rate = 1" and
"phase offset = 0". Such charts must be installed in run-time groups that
have these attributes. For information on how to do this, see Section 3.3.13

- are not installed in the run sequence. You will need to install these charts,
otherwise the program cannot be compiled.

Compile the entire program.

Download the program to the CPU (download entire program: CPU changes to
STOP).

Change the CPU to RUN.
Transfer the PLC-OS data (Options > PLC-OS Connection Data > Transfer...).

Process Control System PCS 7, PCS 7 Migration V5.1
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Partial Migration PLC and OS

10. Convert the OS (see Section 3.6).
This includes starting the Project Converter (see Section 3.6.17). In this case,
the pictures do not need to be converted (see Section 3.6.8), since this is also
done by the Project Converter.
If you have already made the adaptations explained in Case 1, the following
sections are not necessary:

3.6.1/Adapting the Computer Name in the WinCC Data
3.6.2/Checking the System Parameters for the Communication Drivers
3.6.3 Libraries

3.6.6 [Lifebeat Monitoring

3.6.8 Converting Pictures

3.6.13 Converting the User Archive from V4.x to V5.1.

Process Control System PCS 7, PCS 7 Migration V5.1
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3  Full Migration

The sections that follow cover all the migration steps for the new functions and the
measures for upgrading to V5.1. Not every step is absolutely necessary and some
can be considered as options. It is assumed that you have already worked through
the steps described in case 2.

3.1 Hardware Update

3.1.1 Updating the Operating System on the S7-CPU(s) 416-2DP

You require the following equipment:

A PG 720/740/760 programming device with STEP 7 >= V3.1 installed and a CD-
ROM drive or alternatively a comparable PC with a multipoint interface (MPI) and
external PROMMER installed. You require this to program a 2 MB S7 memory card
(6ES7 952-1KL00-0AAQ).

e Install the latest firmware (version A2) from the Internet to a folder on your
computer. Address: http://www.ad.siemens.de/csi_en enter the number
"2858911" in the field "Entry ID" and acknowledge with "Display"”.

* Note:
Not all new functions are necessarily available following a simple firmware
update. It may be necessary to replace hardware since, for example, not all
CPUs permit the use of the new driver blocks (see 3.3.9). After downloading
the CPU file, extract it by double-clicking on the file name.

You can find operating system updates for other PCS 7 compatible S7 CPU
types under the corresponding "Operating system updates for S7-41x-CPUs"
with the Entry IDs "2850229" and "2855123". A 4 MB S7 memory card (6ES7
952-1KMO00-0AAOQ) is necessary for S7-400H-CPU operating system updates.
Erase your S7 memory card by selecting the File > S7 Memory Card > Delete
menu command in the SIMATIC Manager.

* Now program your S7 memory card. To do this, open the SIMATIC Manager
and select:
PLC > Update Operating System.

¢ Select the appropriate firmware update for your CPU by switching to the folder
with the new firmware and selecting the file Cpu_hd _.upd.

Process Control System PCS 7, PCS 7 Migration V5.1
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Full Migration

Click on "Open" to start programming your memory card. Wait until the
standard mouse pointer reappears. Programming is then complete and your
memory card is ready for your CPU operating system update.

A Caution

The next steps will irretrievably delete all the data on your CPU!

Turn the power switch on your CPU power supply (PS4xx) to OFF and remove
the memory card from your CPU.

Insert the memory card you have just prepared into the CPU and turn the
power switch back to ON. The operating system is now transferred from the
memory card to the internal flash EPROM. During this transfer, all the LEDs on
the CPU light up (INTF, EXTF, FRCE, CRST, RUN, STOP). Downloading
takes about 2 minutes. When it is completed, the STOP LED on the CPU
flashes slowly => memory reset request from the system.

Turn the power switch on your CPU power supply to OFF, replace the old
memory card with the update memory card and turn the power switch back to
ON. The CPU runs an automatic memory reset after which it is operational
once again.

3.1.2  Updating Your IM153-1 and IM153-2 (ET200M)

Before you can upgrade the driver blocks for the ET 200M modules to V5.0, you
need to check their compatibility with the IM 153 modules in your system and, if
they are not compatible, replace them. To operate the PLC driver blocks with ET
200M online (S7-300 SM modules), the firmware release number of the IM 153-1
must be Z05 or higher, or in the case of the IM 153-2 it must be Z03 or higher. You
can see the product version of your IM at the bottom right of the front panel. There
you will find the following information:

X

6

The X indicates the current product version (here: 4). The IM 153 cards must be
replaced. Please contact your Siemens sales partner to arrange this.

3-2
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Full Migration

3.1.3 Handling GSD Files

With STEP 7 version 5, stricter checks are carried out on GSD files (device
database files). If you use GSD files from an earlier project, syntax errors or
unknown errors may occur. If the following measures do not succeed, contact the
manufacturer of the device and request a new GSD file. The following errors may
be displayed:

¢ Install new *.GSD files
The GSD file (path\file name) contains syntax errors. This makes it
impossible to interpret.

Create a backup copy of the file and open it with a text editor (such as
Wordpad).

Check Vendor_Name. A maximum of 32 characters and no special
characters are allowed between the double quotes.

Correct the name, save the file and include it in the system again.

* Insert
In the 'SIMATIC 400(1)’ station, transmission rate '187.5 Kbps' is not
supported by node 'MBK-P’.

Find out the GSD file name and path in the object properties of the DP
slave

Create a backup copy of the file and open it with a text editor (such as
Wordpad)

The decimal separator for the transmission rate must be entered as a
point, not a comma (change '187,5 supp = 1'to '187.5 supp = 1.

Start HW Config and select the menu command Options > Update
Catalog.

Note: If the '187,5_supp = 1’ entry is not present, this means that the
transmission rate is not actually supported and you will need to contact the
manufacturer of the device.

* Path\EXTRP.GSD contains syntax error. This makes it impossible to
interpret.

Open the file with a text editor (such as Wordpad) and check whether there
is a diagnostic data length entry for the DP slave. To be on the safe side,
you should enter the highest possible value for this:

Max_Diag_Data Len =244

Start HW Config and select the menu command Options > Update
Catalog.

Process Control System PCS 7, PCS 7 Migration V5.1
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Full Migration

3.2

3.2.1

3-4

PCS 7 Libraries

Certain changes have been made in the PCS 7 libraries, (some blocks have been
modified, some moved to other libraries, and new blocks have been added).

For more information on the changes in V5.1 compared with V4.x, refer to the
Readme files for the PCS 7 libraries.

Note: When using the new Technological Blocks, remember that message texts 6
to 10 and auxiliary values 8 to 10 have been omitted from these blocks and will be
lost in the block instances after migration.

Backup when Continuing to Use V4.02 PCS 7 Libraries

When you install PCS 7 V5.1 libraries, the previous version is automatically deleted
during setup.

If you want the PLC blocks from the previous version to remain available for a
limited period, open the Windows Explorer and copy the following folders:

...Siemens\Step7\S7libs\PCS7 Technological Blocks and/or \PCS7 Basis Blocks
and/or \PCS7 Fielddevice Blocks and/or \PCS7 Driver Blocks to a folder other
than the Siemens folder and rename the copied folders, for example, by adding
V402. Then open the libraries in the SIMATIC Manager and enter the new library
names in the object properties (max. 24 characters).

So that you still have access to the online help for the previous versions, copy the
following:

...Siemens\Step7\S7hlp\S7jtec_a.hlp, S7jtec_a.cnt, S7jtec_b.hlp, S7jtec_b.cnt,
S7jtec_c.hlp, S7jtec_c.cnt
to ...Folder\PCS7 Technological Blocks V402

...Siemens\Step7\S7hlp\S7jbab_a.hlp, S7jbab_a.cnt, S7jbab_b.hlp, S7jbab_b.cnt,
S7jbab_c.hlp, S7jbab_c.cnt
to ...Folder\PCS7 Basis Blocks V402

...Siemens\Step7\S7hlp\S7jfdb_a.hlp, S7jfdb_a.cnt, S7jfdb_b.hlp, S7jfdb_b.cnt,
S7jfdb_c.hlp, S7jfdb_c.cnt
to ...Folder\PCS7 Fielddevice Blocks V402

...Siemens\Step7\S7hlp\S7jdrv_a.hlp, S7jdrv_a.cnt, S7jdrv_b.hlp, S7jdrv_b.cnt,
S7jdrv_c.hlp, S7jdrv_c.cnt
to ...Folder\PCS7 Driver Blocks V402

Process Control System PCS 7, PCS 7 Migration V5.1
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Full Migration

3.3 Converting the PLC

Note

Before converting, check whether there are enough free resources on the PLC for the
conversion. This involves the memory for the code and the data including numeric ranges,
local data, and run time.

Brief Outline

© © N 2

Convert the plant hierarchy (PH) - 3.3.1.

If necessary adapt the hardware configuration for the project, compile it and
download it to the SIMATIC station.

Copy the blocks required for the project from the new libraries to a separate
project library (do not forget SFC_INTP (FB300)) and adapt them to the
project-specific changes - 3.3.3.

Place the MSG_CSF block (FB44) in a new chart.
Note: This is generated automatically if you run the function "Options > Charts
> Generate Block Drivers". -/ 3.3.9

Copy all the blocks used in the project from your own project library to the
block folder of the programs.

Import all blocks into the chart folder.
Convert CFC library blocks to basic operations (optional) 3.3.8.
Convert the project to the new driver blocks (optional) > 3.3.9

In the plant view, check and, if necessary make the "PLC-OS assignment" -
3.3.14.

. Compile the entire program and download the entire program to the PLC.
11.

In the SIMATIC Manager select Options > PLC-OS Connection Data >
Transfer... to transfer the data to the OS.

Process Control System PCS 7, PCS 7 Migration V5.1
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3.3.1 SIMATIC Manager: Converting the Plant Hierarchy

This conversion involves no new configuration.
Procedure:

e Open the SIMATIC Manager

e Open the project

» If the component view is displayed, select View > Plant View to change to the
plant view. The following message is displayed:

Plant View [3283:5055] |

“f'ou are editing the data af the Plant Hierarchy in a
project created with an earlier software wversion.

Do wou want to transfer the data of the Plant Hierarchy to
the niew verzion?

Hao Help |

* Click "Yes" to confirm conversion of the Plant Hierarchy.

3.3.2 HW Config: Adapting the Hardware

Adapt the hardware configuration of the project, save/compile it and download it to
the SIMATIC station.

3.3.3 SIMATIC Manager: Linking and Adapting the Blocks from the New
Libraries

* Create a separate library specifically for the project.

« From the new libraries, copy all the blocks that are being used in your project
into this library.

e The symbolic name of a block must not exceed 16 characters. If the name is
longer than 16 characters, proceed as follows:

Go to Component View, click on "S7 program" and double-click "Symbols"
in the right hand window.

Symbol editor: Shorten the names to max. 16 characters and then save the
symbol table.

Process Control System PCS 7, PCS 7 Migration V5.1
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Copy the blocks to the block folder you want to use in your project.

A dialog is opened for each existing block in which you can check whether
system attributes have changed.

If you copy a single block, the "All" and "None" buttons are not displayed.

Inzert Function block |

& IThe object 'FBA01" already exiztz. Do you want to ovenarite it

Adjuzt Aftnbutes. . |

Al Mo | Mone | Cancel | Help

Click the "Adjust Attributes..." button.

If no adaptation is necessary (attributes unchanged), a message appears that
you simply confirm with "OK". Finally, click the "Yes" button to overwrite the
block.

If different attributes are detected in the blocks, a dialog opens in which you
can decide whether the target block should adopt the attribute settings of the
source or retain those of the old target block. If you accept the settings with
"OK", the block is overwritten with the current attributes.

Note that after adapting attributes, if you click the "All" button, all other blocks
selected for copying will be copied to the block folder without their attributes being
compared.

Process Control System PCS 7, PCS 7 Migration V5.1
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Paste - Adjustment of system attributes E

Block: FESO1 Symbalic Mame: COMTROL

Source: IS?_WWE'\SIMATIE A00NEPU 414-2 DPYS Y -Prog_test24B_11

Destination: IS?’_F'n:ﬂ W5 7-Prog_test1AB_10

Black  Parameters |

Different syztem attribute values
in source and destination [old):
Connection Commenrt Attribute Source Destination (old) | Destination (new)
M_SUP_AL sUppress alarm loiS7_m_c ® true ) falze true
M_SUP_AH suppress alarm hiiST_link ) false I ——-
SP_OP_ON Enshle 1=Cperstol 57 _visible ® false WO - false
Cancel Help

Notes

» If a system attribute is not defined in the destination block; in other words, shown
as "---", its default setting applies. Open the context-sensitive help "Help on System
Attributes” in this dialog. Here, you can check the default response of the individual

system attributes.

Example: A block I/O for which the system parameter "S7_link" was not defined ( --- ) can
be interconnected in the CFC chart. If the value "false" is adopted when adapting the

attributes to the source settings, existing interconnections will be deleted.

* MSG_CSF: To ensure that the new functionality of the block is used, the system

attributes of the source must be adapted.

Process Control System PCS 7, PCS 7 Migration V5.1
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3.34 CFC: Linking and Adapting Blocks from New Libraries

e Double-click on the chart to open it.
e Select the menu command Options > Block Types... in the chart.

e If charts have not already been converted, for example, when you changed
CPU during hardware configuration, a message is displayed telling you that the
data was created with an older CFC version and that editing is only possible
after conversion.

e Confirm with "Yes" and the charts will be converted.

« Import all blocks to the chart folder (select the blocks in the left-hand window
"Offline Block Folder" and click the ">" button).

¢ Toinsert the "PO_UPDAT" and "MSG_CSF" blocks into the program (if they do
not already exist), you can run the "Generate Block Drivers" function. Start the
function as follows:

- Explicitly in the SIMATIC Manager by selecting the chart folder and then
the menu command Options > Charts > Generate Block Drivers... or

- Implicitly during compilation by setting the "Generate block drivers" option
in the dialog.

Refer to the online help for further information.

Note

In large projects (>30K power tags) monitor the number of handles used for the
S7JCFCAX.EXE process during block type import in the "Processes" tab of the WinNT
Task Manager.

If the number rises above 10,000, cancel the type import once the current block has been
processed and exit CFC. Restart CFC and continue the type import from the next block.
Otherwise, in some situations, there could be an exception on accessing the project
database.

If the new versions of the blocks have different properties than the current version
in CFC, a dialog box with is displayed with instructions. Depending on the
consequences resulting from importing modified blocks (no consequences,
downloading changes in RUN, downloading the entire program in STOP), the
dialog will appear differently. If blocks of one call hierarchy are also called by
unmodified blocks, this is also indicated.

Using the new driver blocks and MSG_CSF necessitates downloading in STOP.

Process Control System PCS 7, PCS 7 Migration V5.1
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3.3.5 CFC: Converting to Value Identifiers

From version V5.0 onwards, the parameters of certain block I/Os can also be given
value identifiers. This applies to block 1/Os of the data type BOOL, BYTE, INT,
DINT, WORD, DWORD and the corresponding attribute S7_string_0...25 must be
configured as the block type.

Activating value identifiers can mean that the space required by blocks in the chart
is increased and positioning conflicts can occur.

Blocks that are involved in positioning conflicts are not restricted in terms of their
functionality. They are positioned as "overlapping" blocks in the chart; in other
words, they cover part or all of other objects in the chart and are displayed in light
gray and without block 1/0Os. The interconnections are also not visible, however,
they do exist. After positioning a block at a free location in the chart, the
overlapping blocks are displayed as "normal” blocks again with their previous
interconnections.

Old projects will continue to be displayed without value identifiers until the
option is set.

The value identifiers for all charts in the currently selected program are activated
via menu command Options > Customize > Display... by setting the "Value
Identifiers" option.

3.3.6 CFC: Migration of Text Attributes at Block 1/0Os

In version V5, text attributes are only allowed at block I/Os if the corresponding
attributes are also set in the block type. This feature considerably improves
operator guidance for the text attributes usually relevant in WinCC.

In this case, text attributes means "ldentifier”, "Unit", Text 0" and "Text 1". These
attributes can be entered in V4.x projects as follows:

Text 0 and Text 1 for data type BOOL.
Identifier and Unit for all other data types.

From V5.0 onwards, the following rules apply:

Attribute Allowed with data type | Adaptability *)
Identifier, Unit REAL, BYTE, INT, Modifiable in individual
(corresponding to DINT, WORD, DWORD | instances

S7_shortcut and S7_unit)

Text 0, Text 1 BOOL Modifiable in individual
(corresponding to instances

S7_string_0 and S7_string_1)

S7 _string_O0 ... BYTE, INT, DINT, Not modifiable in
S7_string_25 WORD, DWORD individual instances
(from CFC V5.0 only)

*) Using the function Options > Block Types: "New Version", all text attributes not already changed
for a specific instance can later be changed centrally for all block instances.

Process Control System PCS 7, PCS 7 Migration V5.1
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You can upgrade the text attributes in old projects to the V5.x configuration with the
menu command Options > Block Types and the "New Version" button. When this
happens, texts that are "superfluous" in V4.x are deleted.

3.3.7 CFC: Run Sequence after Changing a Block Type

After changing a block type, the S7_tasklist attribute now has different effects:

You can use attribute "S7_tasklist" to specify the OBs in which a block in the CFC
chart will be automatically installed in the run sequence.

In CFC V4.x, changes to the attribute made later only affected new blocks. In CFC
V5.x, blocks that have already been configured are also inserted in the run
sequence according to the new S7_tasklist when a block type has been changed
(menu command Options -> Block Types... and the "New Version" button, or
simply by dragging them from the library).

3.3.8 SIMATIC Manager: Changing from CFC Library Blocks to Basic

Operations (optional)

From version V5.0 onwards, blocks that were previously contained in the CFC
library are available as basic operations (BOPs). The new BOPs are shown in the

following list:

ABS DI |DW R |LIM DI MOD | MUX8 BO |ROR DW |SR FF
ABS | |[DW W |LIMI MUX2 BO |MUX8 DI |ROR W |W BY
DI DW |EPS DI |MAX2 DI |MUX2 DI |MUX8 | RS_FF W I
DI_| EPS | |MAX2 | |MUX2_I NEG_DI SHL_DW

DIV DI |l DW MIN2 DI |MUX4 BO |NEG_| SHL W

DIV | | W MIN2_| MUX4 DI |ROL DW |SHR DW

DW DI |JK FF |MOD DI |MUX4 | ROL_ W SHR_ W

Projects created with CFC versions < V5.0 (old projects), are not converted
automatically when you convert them to V5.x because this would make changes to
the S7 program of the CPU.

The changeover is optional but becomes necessary if you include a version 4.x
program (or subroutine) using the blocks mentioned above in a version 5.x

program.

Process Control System PCS 7, PCS 7 Migration V5.1
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Note on Multiple Instance Blocks

3-12

If multiple instance blocks have been configured, that call blocks of the CFCLIBS
that are new BOPs in V5.0 (see list); you have the following two options when you
convert:

1.

No conversion to basic operations:

The called blocks are not converted to basic operations (in multiple instance
FBs the relationship to the "old" FBs remains). The symbolic name in the
symbol table must be different from that of the corresponding "new" BOP and
the FB must be also be copied. This means that these blocks then exist in the
CFC chart as both CFC library blocks and BOPs.

Conversion to basic operations:

The source file for the multiple instance block must also be generated again
along with the "new" BOPs. Proceed as in point 1 above, then generate the
multiple instance block again (swap the "old" FB for a BOP / recompile /
reimport) then delete the "old" FB from the CFC, offline block folder and symbol
table.

Process Control System PCS 7, PCS 7 Migration V5.1
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Conversion to BOPs without Any Program Modification

If you prefer to convert your old projects without altering the existing program, you
can proceed as follows:

e Create a new S7 program for the project, complete with a chart folder and a
CFC chart.

¢ Copy the symbol table to the new S7 program, then delete all blocks from the
symbol table that are now available as BOPs (see above list).

¢ Open the CFC chart and adapt the numeric ranges according to the old ranges
using the Options > Customize > Compile... menu command.

e In SIMATIC Manager: Delete the newly created CFC again.

Before copying the charts, open the SIMATIC Manager and select Options >
Charts > Settings for Copy/Move and check whether the option "Transfer
interconnections and addresses for Copy/Move" is set. If not, the interconnections
to symbol table operands will be deleted.

e Copy all charts - but not the chart folder - together from the old project (Edit >
Select All) to the new chart folder.

e Copy your SCL sources likewise

e Caution You must copy any blocks you have created yourself and whose DBs
are in the area locked for CFC, to the block folder manually.

¢ Rename the new S7 program with the name of the old program.

e Cutthe S7 program and paste it over the CPU for the old program. In this way,
the new S7 program replaces the old program.

¢ The program must then be recompiled: Select the chart folder, Edit > Compile.

With the above procedure the project remains unchanged apart from the
following exceptions:

« Interconnections to run-time groups are lost and must be reentered.

¢ The DB number assignment changes, which means it may also be necessary
to transfer the PLC-OS connection data again.

Note

The blocks that now exist as basic operations are no longer in the new "CFC library".
However, if you still need these blocks for your existing projects, you can access the old
CFC library "CFCLIBS (V4)".

Process Control System PCS 7, PCS 7 Migration V5.1
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3.3.9

Converting a Project to the New Driver Blocks (optional)

With PCS 7 V5.0, a new driver concept was also introduced. The V4.02
functionality of multi-channel drivers is now distributed on two block types: one
multi-channel part for module-specific functions and one channel-specific part for
individual channels. To set up a connection to a peripheral signal, both blocks are
required (with corresponding coordination between them).

The "Generate Module Drivers" function automatically generates a system chart
and the MOD, RACK, SUBNET blocks and the process control message block
MSG_CSF along with the PO_UPDATE block for outputting the process image are
inserted.

For more detailed information on the functionality of the new drivers and the
message concept, refer to the CFC online help, topic "Generate Module Drivers
(S7)".

Older CPU versions do not meet the run-time conditions of the new signal and
diagnostic blocks in the PCS 7 Driver Blocks library. If you want to use the new
driver blocks, the following CPUs are suitable:

CPU 414-3: 6ES7 414-3XJ00-0ABO
CPU 414-4H: 6ES7 414-4HJ00-0ABO
CPU 416-2 6ES7 416-2XK02-0AB0O
CPU 416-3: 6ES7 416-3XL00-0ABO
CPU 417-4: 6ES7 417-4XL00-0ABO
CPU 417-4H: 6ES7 417-4HLOO-0ABO
CPU 417-4H: 6ES7 417-4HLO1-0ABO

HW Config

3-14

Settings required in CPU Object Properties, "Cycle / Clock Memory" tab:

* When using the new module driver the "Update Process Image Cyclically"
check box must be selected.

* The size of the process image area (inputs and outputs) must be 1024.

* Inthe combo box "OB85 - Call Up at I/O Access Error" the option "At each
individual access" must be selected.

Process Control System PCS 7, PCS 7 Migration V5.1
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Example of CPU Properties:

Properties - CPU 417-4 - [R0/53]
Time-of-Diay Intermupts | Cyclic Intermupt I Diagnostics/Clock. I Protection
General I Startup Cycle/Clock Memary | Fetentive Memory I temony I Intermipts

— Cucle

¥ lpdate Process Image Cuclicalle

Scan Cycle Maonitoring Time [ms]: 150

Minimurm Scan Cpcle Time [ms]: IEI—
Scan Cycle Load from Communication [%]; |2U—
Size of the process-image input area IW
Size of the Process-Image Dutput Area IW

DEBE - Call Up at 1/0 Access Emar: |m each individual access j
— Clock Memory

™ Clock Memary

I ey Bntes ID

Cancel | Help |

e The symbols for the I/O signals must be edited in the HW configuration of the
I/O modules or in the symbol table (or "Add Symbol" — to accept addresses as
symbols)

Example: HW Config

Addiess Symbol Data Type Caomment
1 A 0.0 ADQO BOOL
2 A 0.1 A0 BOOL
3 A 0z A02 BOOL
4 A 03 A03 BOOL
Add Symbol | Sort: _ﬂ
0K Apply | LCancel Help |

Process Control System PCS 7, PCS 7 Migration V5.1
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CFC / SIMATIC Manager:

If RACK/SUBNET blocks have already been used in the project, the following steps
are also necessary when migrating to V5.x:

« The RACK/SUBNET blocks must be deleted from the CFCs.

* The RACK/SUBNET block types must be deleted from the block folder of the
CPU.

The "IN_"and "OUT_" blocks from the PCS 7 Basis Blocks must be converted to
"CH_" blocks in the CFC charts:

* Accept the parameter settings.

e Convert the I/O interconnections from blocks in PCS 7 Basis Blocks to the
equivalent "CH_" blocks or create a connection to the I/0O addresses

* Delete the old blocks.

e Open the SIMATIC Manager and select the menu command Options >
Charts > Generate Module Drivers... to generate the "MOD, RACK or
SUBNET" blocks and the interconnections between the outputs of the "MOD_"
blocks and the inputs of the "CH_" blocks. This creates a system chart which
contains the "MOD, RACK or SUBNET" blocks. The MSG_CSF and
PO_UPDAT blocks are also inserted.

Notes

* You should distribute the CH blocks in run-time groups, since only a limited number of
blocks are allowed to exist under a single OB (otherwise errors can occur during
compilation).

Since this means that the linking of I/Os has been completely reconfigured, it is
advisable to test the changes.

» In the driver blocks of version V4, it was possible to set startup cycles so that after
startup the values could first "settle" during user program initialization before values
were output to the modules.

This function is no longer implemented in the CH blocks of V5.x so that additional
configuration by the user is necessary (for example, inclusion of a counter block).

3.3.10 V4.02 Blocks and New Blocks on a CPU at the Same Time

3-16

V4.02 driver blocks and the blocks for the new driver concept (V5.x) can be run
simultaneously on a CPU. While versions can be mixed on a CPU, they cannot be
mixed in individual modules which must have either V4.02 blocks or the new V5.x
blocks. The addresses of modules being processed according to the V4.02 driver
concept must be configured outside the process image.
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3.3.11 Updating the Sampling Time (option)

If blocks have an input for the sampling time (for PCS 7 blocks, input SAMPLE_T,
attribute "S7_sampletime = true"), the sampling times can be updated.

To use the new function "Update Sampling Time" even when still using V4.x PCS 7
blocks on the PLC, enter the attribute "S7_sampletime = true" for input SAMPLE_T
in the block declaration table (offline block folder) and then import the blocks into
the charts.

When you compile, set the "Update Sampling Time" option in the "Compile Charts
as Program" dialog box.

When you change to the new blocks, you must check and, if necessary, adapt the
charts (for example, 1/0s such as KP, TN, ...). This applies, in particular, to the
blocks CONT_C, CONT_S and PULSEGEN, where the improvement made them
incompatible with earlier versions (CYCLE input / data type TIME changed to
SAMPLE_T / data type real). In TIMER_P and AFP, the only change was to enter
the system attribute so that the sampling time is updated.

If you do not want to use this modification, you can continue working with the old
versions of the blocks but you must then configure the sampling times yourself as
before. In this case, you should make a copy of the old S7 CFC library before you
install the new CFC.

3.3.12 SFC: Non-Latching Behavior

From version V4.02 onwards, "non-latching behavior", in other words, processing
termination and initialization actions in consecutive steps within a single cycle, has
been the standard behavior for the SFC run-time system (FB300). There is no
switch with which you can select between the old strategy (termination and
initialization in consecutive cycles) and the new.

If the initialization of the next step is empty; in other words, it contains no
instructions, the termination of one step is processed in a single cycle together with
the first execution of the cyclic processing of the next step.

In V4.02, it was still possible to use the SFC run-time system from V4.01 (with the
old behavior). As of V5.0, you must migrate to the new run-time system.

This means that you must check the points affected by the new run behavior in
existing SFCs. Points affected are those where the termination of the previous step
and the initialization of the next consecutive step (or its processing, if the
initialization is empty) involves write access to the same address in the PLC
program.

Example: The termination of the previous step contains a Boolean variable set to
"0" and the initialization of the next step contains the same variable set to "1". In
this example, unless some change is made to the configuration of the variable
there will be no longer be a signal edge change.

To allow migration of older charts, the function "Check Step Processing" has
been included as a menu command in the "Options" menu. When you use "Check
Step Processing" the program searches for and logs points where the address is
used in the termination action of one step and in the initialization action (or
processing action) of the successor step ("Step Processing" tab in the "Logs"
dialog box).
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Remedy: The statement in the termination of the previous step (in other words, set
the variable to "0") can be moved into the processing part of the step. Another
solution would be to insert an empty step between the two steps if the resulting
extended execution cycle does cause problems.

3.3.13 SFC: SFC Charts in Run-Time Groups

3-18

From PCS 7 V5.0 (SFC K5.0.3) onwards, SFC charts can be installed not only in
tasks but also in run-time groups. This means that SFC charts can run in various
cyclic tasks and form plant-oriented run-time groups in conjunction with CFC
charts. From a technological point of view, this achieves better project structuring.
It also saves a considerable amount of time and effort (for example shorter
compilation times) if changes are made in the configuration, since complete tasks
no longer need to be compiled.

Since a run-time group has the "scan rate" and "phase offset" attributes, these are
no longer supported for SFC charts. As a result, SFC charts that previously had
non-standard attributes must be adapted.

Remedy: When converting SFC charts from V4.x or V5.0 SP2 to V5.1/V5.2 (they
are converted the first time they are written to), the attributes "Scan Rate" and
"Phase Offset" are removed and the SFC charts affected are listed in a log. You
can display this log in CFC / SFC with the Options > Logs, tab: Convert Format
menu command. The project engineer must then move the SFC charts listed and
any control blocks present (SFC_CTRL) to run-time groups that have the same
scan rate and/or phase offset values as those previously used for the SFC charts.
A control block (SFC_CTRL) must still be inserted directly in front of the associated
SFC.
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3.3.14 SIMATIC Manager PH: Checking PLC-OS Assignment

If the V4.x S7 or OS programs have remained unchanged (even after conversion),
the PLC and OS assignment is also unchanged.

If necessary: In Plant View you can select hierarchy folders and use your right
mouse button with "Object Properties” in the following dialog box to check and if
necessary decide on the "PLC-OS assignment".

Properties - Hierarchy folder -- PCELLAUNIT

General I Control and Manitoring Attributes PLC and 05 Assignment |

Azzigned PLC [chart folder):

SIMATIC 4005CPUA14-2 D

S 7-Programm(1]\Charts

Lower-Lewel Object:

Al lower-level objects have the selected assignment.

Agzigned 05:
|os1 [~

Lower-Lewel Object:

Al lower-level objects have the selected assignment.

Cancel I Help |

If no previously assigned chart folder still exists, a message is displayed telling you
that you need to assign a chart folder now.

Acknowledge with "OK" and assign a folder.

3.3.15 CFC or SFC: Compiling and Downloading

* When you have made all the adaptations necessary, compile the entire
program and download it to the CPU.

Process Control System PCS 7, PCS 7 Migration V5.1
A5E00064939-02 3-19



Full Migration

3.3.16

3-20

SIMATIC Manager PH: Checking OS Area Identifier before
Transferring Data to the OS

When an older project is converted, the "Base picture hierarchy on the plant
hierarchy" option (Options > Plant Hierarchy > Settings...) is not set. Please
note that the OS area identifier is always transferred to WinCC when the PLC-
OS connection data is transferred. This means that before the PLC-OS
connection data is transferred, you must make certain that the OS area
identifier configured in the WIinCC Picture Tree Manager matches the identifier
configured in the PH or is empty.

If you want to use the "Base picture hierarchy on the plant hierarchy" function,
make sure that the pictures you expect to find in the Picture Tree Manager
have been included in the PH.

The procedure is as follows: Select the OS in the component view then click
menu command Options > Import WinCC Objects menu command. Assign
the imported pictures to the PH by dragging the picture(s) from the component
view to the relevant hierarchy folder in the PH. (This procedure is interpreted
as an assignment to the PH; the objects are not in fact physically moved.)
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3.4 Import/Export Assistant (IEA)

The IEA files in version V5.x have a different format compared with V4.x. Existing
IEA files therefore have to be converted to the new format. To do this proceed as
follows:

First upgrade the project to version V5.0 with the "Save As" function. When
they are saved, the models used are detected and converted to a model with n
replicas.

In the SIMATIC Manager select the menu command Options > Import/Export
Assistant > Create/Modify Model and on Page 4(4) use the function "Create
file template" to create a new import file. The "Create import file" dialog box is
then displayed. This is used to define which column headings will be included
in the import file, such as chart names and comments, block comments,
symbol comments and the absolute address, as well as attributes S7_string_0,
S7 _string_1, S7_shortcut and S7_unit.

This import file is now structured in the new file format but contains just one
row, in which the data for this model is entered. It is intended to serve only as a
template for the subsequent export procedure, since the data that will be
exported is now written into the import file.

Next go to the IEA and carry out the "Export" function. The IEA now generates
a file in the new format.

This file can be edited with the IEA editor introduced in V5.0.

If a planning tool is used for creating IEA files, its import-export interface must
be converted to the new format.
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3.5

PLC-OS Engineering

Data Integrity and Consistency before Migration:

Transfer the OS-related data with PLC-OS engineering V4.02 to WIinCC V4.02. To
do this, you must set the options "Match Variable Names" and "Match Addresses,
Units, Identifiers, Operating Texts" as well as the transfer options "All" and "With
OS memory reset".

After transfer, upgrade to version V5.1 and save your project in the SIMATIC
Manager with "File > Save As..." and the option "With reorganization (slow)".

Transferring PLC-OS Connection Data:

When transferring the PLC-OS connection data for the first time, the transfer option
"All" and "Clear operator station(s)" must be set. This setting is also necessary if
you want to use Project Converter to convert PV names (new separators). See also
3.6.17.

Note on Converting PLC Data:

3-22

The first time the data storage for process variables is written to (for example,
when you insert a technological block in a CFC) the data structure is changed
(adapted to the V5 structure). Depending on the extent of the project, the migration
process may take quite a long time. During this time there are no messages or
progress displays. If the conversion is canceled before it is completed, project data
may be corrupted.
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3.6 WinCC: Converting the OS

Brief Outline
1.
2.

10.
11.
12.
13.

Adapt the computer name

Check the system parameters of the communication drivers for the programs
concerned and adapt them if necessary - (3.6.2 .

Convert the libraries - 3.6.3
a) Convert global library
b) Convert project library

Global Script > 3.6.4
Regenerate header and regenerate all scripts under Project Functions.

Base Data - 3.6.5
a) Start the Split Screen Wizard
b) Start the Alarm Logging Wizard

Update Lifebeat Monitoring =| 3.6.6
Save Alarm Logging = [3.6.7

Case 3: Using the Project Converter
- Close WinCC.

- Use Project Converter to convert the tags in pictures and reports
- 3.6.17

- Reopen the project in WinCC.

- All functions and/or scripts that have been created under Global Script
itself and which contain WinCC variables must be checked, edited using
the generated .c files and exchanged with the scripts in Global Script. Then
compile and save them again > 3.6.18

Convert pictures if the Project Converter was not run - 3.6.8
Save the Picture Tree Manager -|3.6.9

Convert the user archive from V4.x to V5.1 > 3.6.13 |
Convert the trend display to F(x) (optional) - 3.6.14

Convert clients to multi-client > 3.6.15 .
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3.6.1 Adapting the Computer Name in the WinCC Data

Start WinCC and open the project you want to convert.

You only need to adapt the computer name if the following message is
displayed:

Open Object [310:44] |

open the project uzing the local computer as the server’?

& The =zerver configured iz not available. Do pou want to

In this case, select the "computer" in the open project.
Select "Properties" from the context-sensitive menu.
Click the "Properties" button

Enter your own computer name (max. 15 characters). You can check the
computer name with Start > Settings > Control Panel > Network.

Close WiInCC to accept the newly entered computer name.
Restart WinCC.

3.6.2 Checking the System Parameters for the Communication Drivers

Check the system parameters of the communication drivers for the programs
concerned and adapt them if necessary.

3-24

Open "Tag Management" (click on the + symbol).
Open "SIMATIC S7 Protocol Suite".

Select a channel (for example "PROFIBUS") and select "System Parameters"”
from the context-sensitive menu.

Select the "Unit" tab and, if necessary, adapt the "logical device name" (for
example "S70nline").

Close the "System Parameters" dialog box.
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3.6.3 Libraries

Convert the global library and, if necessary, the project library.

Converting the Global Library
* Right-click "Graphics Designer" and open "Convert Global Library".

Note: The dialog must be completed without error.

Converting the Project Library

It is only necessary to convert the project library if you have added graphic objects
to it. You can check this as follows:

¢ Open Graphics Designer and select the View > Library menu command. You
can see the objects stored in the "Project Library" path.

¢ Close the library and Graphics Designer.
If there are objects present:

e Select "Graphics Designer" and "Convert Project Library" in the context-
sensitive menu.

Note
The dialog must be completed without error.

3.6.4 Converting Global Script

* Right-click "Global Script" and select "Open".

e Open, regenerate, and save all scripts under "Project Functions
(Options > Compile All Functions).

e Select the Options > Regenerate Header menu command.

e Exit Global Script.
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3.6.5 Base Data

Base Data contains the "Split Screen Wizard" and the "Alarm Logging Wizard".
Please note that when you run the Split Screen Wizard and Alarm Logging Wizard,
customer-specific settings in Alarm Logging and the base data pictures may be
lost.

Split Screen Wizard
* Right-click "Split Screen Wizard" and select "Open".

Note
The dialog must be completed without error.

Alarm Logging Wizard
* Right-click "Alarm Logging Wizard" and select "Open".

If the option "Filter Messages by Range" on the 2nd page of the Wizard is set
(default), make sure that all messages configured in the text block range of
alarm logging have valid range names or are empty.

In this dialog, you should also check whether the operator input messages you
require have been selected.

Note
The dialog must be completed without error.

3.6.6 Lifebeat Monitoring

* Right-click "Lifebeat Monitoring" and select "Open".
e Click the "Update" button.

An error message is displayed if PLC monitoring is configured and the PLC
has already been converted to version 5.0 (# symbol). Click "OK" to
acknowledge the error message.

« Inthe device list, reconfigure "Connections" by double-clicking the field and
opening the context menu.

e  Click the "Update" button.
e Close Lifebeat Monitoring.

OPC communication is recommended for monitoring the OS and multi-clients.
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How to Set Up a New OPC Connection:

1.
2.
3.

Add the new driver to the server (OPC.CHN).
Start WinCC and add a new driver "OPC.CHN" to tag management.

Add a new connection to the server using "New Driver Connection" from the
context menu (of "OPC Unit #1").

In the context menu of the newly created connection, select "Properties" and
open the "OPC Connection" tab.

In the "OPC Server Name" box, enter the name "OPCServer.WinCC".

In the "Run server on another computer" box, enter the name of the computer
from which monitoring will be carried out.

Click on "Test Server" button to check whether the OPC connection can be set
up.

3.6.7 Alarm Logging

Right-click "Alarm Logging" and select "Open".
Select the File > Save menu command.

Exit Alarm Logging.

Close WinCC

3.6.8 Converting Pictures

The steps described here must only be used when the PCS 7 OS Converter has
not been started (case 1).

Right-click Graphics Designer and select "Convert pictures" in the context
menu.
The graphic images are converted.

Note
The dialog must be completed without error.

Since there is no "OK/Not OK" group display, check the entire list of converted
pictures. Images with error messages must be reedited in Graphics Designer.
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3.6.9

3.6.10

3.6.11

3.6.12

3.6.13

3-28

Picture Tree Manager

« Right-click "Picture Tree Manager" and select "Open".
e Click Project > Save.

e Exit "Picture Tree Manager".

Time Synchronization

*  On every computer on which time-of-day synchronization is performed via a
CP 1613, CP 1413, CP 5412A2 or CP 5613, the "Time Synchronization" dialog
box must be opened and closed with "OK", even if no changes have been
made.

Signal Module

« If a signal module is installed on the computer, open the control applet Control
Panel > Signal Unit Configuration, make the required settings and close it
again by clicking "OK".

Chipcard

e If a chipcard terminal is used on the computer, open the control applet Control
Panel > WinCC Chipcard Terminal, make the required settings and close it
again by clicking "OK".

Converting the User Archive from V4.x to V5.1.

A user archive is converted in two steps:

1. Conversion of the user archive structure

2. Conversion of the run-time data

To convert the user archive structure, follow the steps outlined below:
e Select the "User Archive Editor".

e Choose "Open" from the context menu.

» Select the user archive you want to convert and start the conversion by clicking
the "Convert" button.

* When conversion has finished, exit from the dialog box by clicking the "Close"
button.

* Save the converted user archive structure.
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To convert the run-time data, follow the steps outlined below:
e Select Project > Convert

¢ Inthe "Convert Old User Archive" dialog box, click the "RT Data..." button. This
opens the "Convert Runtime Data" dialog box.

e Select an existing old and new user archive and start the conversion by
clicking the "Convert" button.

¢ Close the "Convert Runtime Data" dialog box.
¢ Close the "Convert Old User Archive" dialog box.

The current WinCC data can now be copied to the WinCC server

3.6.14 Using F(x) Trend Display

Migration

Procedure

In WIinCC V5.0, the trend display in TagLogging has been converted to Active_X
controls. The TLGSetTemplateData() in WinCC V5.0 supports only the display of
Y=F(t) or X=F(t). A separate trend control is now used for the Y=F(x) view known
as "WinCC Function Trend Control". if you want to use this view, follow the steps
outlined below.

Migration of the OS data is complete (see above). You have converted the pictures
and the trend frames they contain have been replaced by "WinCC Online Trend
Controls". These must be deleted in all pictures in which an F(x) trend display is
required and replaced by "WinCC Function Trend Controls" (FCT control).

The FCT control is available with WinCC V5.0 SP1 and is installed on the OS but is
not displayed in the Control object palette. The FCT control must therefore be
added.

The script for outputting the values in the control must be edited since the V4.02
ODK functions (TLGSetTemplateData) can no longer be used.

e With the mouse pointer in the Controls object palette in the Graphics Designer,
right-click and select "Add/Remove".

¢ Inthe "Select OCX Controls" dialog, select the "WinCC Function Trend
Control" and confirm with "OK".
The FCT control is now available in the Control object palette.

e In all pictures in which you require a F(x) trend display, delete the "WinCC
Online Trend Controls" and replace them with "WinCC Function Trend
Controls".
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« Open the configuration dialog (right mouse button) for each FCT control to set
the required configuration.

Propertiez of WinCC Function Trend Control

o | up|Dow] |

.'.' [l
AEpl
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Properties of WinCC Function Trend Control

Fromtheright 7]
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¢ If necessary, you can modify the object properties for the FCT control (right
mouse button > Properties).

e Edit the script for outputting the values on the FCT control
(TLGSetTemplateData)
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3.6.15

General

Migration from Client to Multi-Client

If you intend to use multi-clients instead of clients from V5.0 onwards, migration is
required.

No WinCC configuration functions can be carried out on a multi-client to implement
changes in the server project; in other words, the server project can now only be
configured on the server and not on the multi-client. The data from server
projects is made known to the multi-client in reference lists known as packages.
Packages must be created and downloaded before the multi-client can access the
server data.

Requirement for migration: Conversion of the WinCC server data.

Options for Configuring a Multi-Client

Option 1:

3-32

Note

Precondition: Before a package can be created on a WinCC server, the data must be
transferred to the WinCC data management in a PLC-OS transfer. This transfers the
process variables, messages and SFCs.

For the first transfer, the options "All" and "Clear operator station(s)" must be set.

Multi-client project on the ES (recommended)
Advantage:
e All the project data are on the ES

« Slight modifications to the OS are effective immediately after updating the
package on the multi-client.

Procedure: All the configuration steps are done on the ES !
1. ES - WinCC server project

Delete client computer (optional).

Generate the package

Adapt the physical and symbolic computer names
2. ES - SIMATIC Manager

Configure the multi-client directly or in a PC station
3. ES - WinCC multi-client project

Load the package locally from the server project on the ES

Configure the multi-client completely
4. ES - SIMATIC Manager

Copy the server project and multi-client project to the target stations with a
project download
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Option 2: Multi-client project on the multi-client
Advantage:

e Configuration and configuration changes directly on the multi-client can be
done extremely quickly.

Disadvantage:

e The multi-client project is located only on the multi-client. When you back up
your data, you must do this on several computers.

* No central data management
Procedure:
1. ES - WinCC server project

- Delete client computer (optional).

- Generate the package

- Adapt the physical and symbolic computer names
2. ES - SIMATIC Manager

- Copy the server project to the target computer with a project download
3. Multi-client - WinCC

- Generate the multi-client project

- Download the package from the OS

- Configure the multi-client completely

Potential Problems when Upgrading from Client to Multi-client:

To be able to access the variables on the associated server in a multi-client
environment, variable names must be extended to include the server prefix and tag
prefix. If variables are accessed, for example using global script functions
GetTagxx or SetTagxx, the action control handles the necessary extension if the
picture displayed in run time is on the server.

However, if DM functions are used for access (e.g. DMGetValue or DMSetValue),
the variable names must be extended by the user. The function
GetServerTagPrefix provides the required prefix.

If API calls such as DMClient are executed and tag and picture names are used,
the server prefix must be formed in the same way.

All pictures copied into a multi-client project using the Split Screen Wizard run
locally in WinCC run time and have no process connection. If customer-specific
changes are made to any of these pictures (for example, a display is configured in
a dynamic dialog, dependent on a process variable), such displays will not function
on the multi-client since the variables do not exist in the local multi-client project.
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If the wizard was used to interconnect and display the faceplate when configuring
the call for a PCS 7 — standard faceplate (pictures "@PL_*.pdl" and "@PG_*.pdl"),
WinCC makes sure that when it is selected during run time the process values are
fetched from the correct server. However, if project-specific scripts or actions are
developed for picture block interconnections and/or displays, there is no guarantee
that this will be done. This means the user must be responsible for interconnection
with the right server.

If SFC charts are opened directly in server project images by means of keys, they
do not work on the multi-client (a key action uses functions "SFCOpenSection" or
"SFCOpenOverview"). In order for the keys to work even on the multi-client,
replace the key actions by running the new Wizard "Configure SFC Key" (on the
"SFC" tab of the Dynamic Wizard).

Process pictures configured on the multi-client - in other words, pictures requiring
tags from two or more servers (up to six are authorized - cannot be inserted in the
hierarchy, and group displays of these pictures cannot be displayed in the
overview. These pictures can only be displayed with "Select Screen by Name"
function key.

If WinCC-API functions (in other words, those that do not exist in Global Script) are
used directly in project functions and/or actions, check whether the function
actually works on the multi-client if it is also required to run on the multi-client.

In certain circumstances the WinCC-API function "MSRTCreateMsg(...)", which
creates a message in Alarm Logging, can function perfectly well on the server but
not on the multi-client (for various reasons). Check this in each case.

If as a user of version V4.x you had two servers (non-redundant) and required to
be able to interface with a PLC from both servers, you will have transferred and
configured data from one PLC into both servers.

If this configuration is upgraded to multi-client, the effect is that the multi-client will
receive every message from this PLC from both servers. With the default setting of
the message control on the multi-client, only the messages of all servers are ever
displayed. This means that for the same state to be achieved as in version 4.x
(display messages only from one server), the configuration of the message control
(configuration dialog box) has to be modified.
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3.6.16 Converting old Layouts to new Providers

To be able to use old page layouts on the multi-clients, they must be converted to
the new providers. Follow the steps below:

e Open "Layout" in the Report Designer and open the required layout, for
example for the short-term archive report: @alrtuma.rpl.

¢ Open the object properties by double-clicking the dynamic table.
e Change to the "Connect" tab and select "Selection".

» Click the "Connect new..." button.
"Short-term archive report" is selected in "Alarm Logging Runtime".

e Open the new provider "Alarm Logging RT", select "Short-term archive report"
there as well and click "OK".

e Repeat this for all other reports (long-term archive "@alrtfoa", message
sequence report "@alrtmef").

3.6.17 The Project Converter Tool

Caution This conversion no longer belongs to the range of functions described in
section 1.1, Migration Case 1.
Only start the Project Converter after transferring the converted PLC data.

The PCS 7 OS Converter checks all the process variables (PVs) present in the
STEP 7 project that have the status "transferred". The Converter uses the names
of these variables to search all the images, reports, archives, scripts and global
scripts of every OS present in a project, looking for the locations of process
variables. Wherever it finds one, it replaces every separator character "_"
(underscore) in the name of the PV with "/" (slash).
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3.6.17.1 Starting the PCS 7 OS Converter

3-36

Before you start the Converter, the project you intend to convert (V4.x > V5.X)

must have been transferred using the options "All* and "Clear operator station(s)".
Do not start WinCC.

Start the Converter in Windows NT (Start > Run > Browse >
...Siemens\step7\s7map\s7uv45cx.exe.).

PC57 ProjectConverter

o .
"% Introduction

1041

Welcome to the Converting 'Wizard!

Thiz wizard helps vou to convert wariable names
mapped to vd« WinCC projects to vanable names
comesponding to w5« mapping. There are few steps
that You MUST perfarm before you can run this wizard ;
1. Back upv'our old PCST project

2. Open all contained WinCC projects once

3. Perfarm new variable mapping

Conwersion iz anly for version 4.2 of 'WinCC projects
pozsible, g0 please don't test it with alder or newer
verzionz of projects.

All rights reserved. Copyright € Siemens AG 1953,

< ENTIER Abbrechen |
In dialog box 1(4) click "Next".
PCS57 ProjectConverter
@ Choosze the Step? source project 2[4]

Selected project's name;

Selected project's full path:

L ootect project

£ Zurick, I Ferfia stellenl Abbrechen I

In dialog box 2(4) select the STEP 7 project you intend to convert and click

"Finish".
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In dialog box 3(4) you can watch the progress of the conversion.

Note

When you edit the WinCC reports, the Report Designer is visible as a
window; all other editing takes place in the background.

If an error occurs during processing, a warning message appears. At that point you
can cancel processing or continue, in which case you have the option to suppress
all further error messages. All errors are logged in file "Pcs7Conv.log" which is
stored in the project folder (i.e. folder "S7proj").

Dialog box 4(4) displays the fact that the conversion has been completed.

Log file Pcs7Conv.log

The log file Pcs7Conv.log allows you to check correct execution so that if there
were any WinCC objects whose conversion failed, you can edit them manually
later.

3.6.18 Reworking Scripts

Global Scripts

If global scripts have also been converted, you still need to reedit them. Global
scripts cannot be saved again as scripts after they have been processed by the
PCS 7 OS Converter. The Converter stores them in the same folder as files with
the same name but with the extension .c (they are saved by default in "projectpath/
wincproj/OS/Library" or "computer(name)/pas").

To complete the conversion, proceed as follows:

e Open WInCC again with the project you are intending to convert.
e Open "Global Script".

e Open the original scripts within "Global Script".

e Open the .c file with an editor of your choice.

e Select the complete text in the .c file and copy it.

¢ Replace the initial text in the original script with the copied text.

e Compile and save the newly inserted text in the original script.
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Scripts with Complex PVs

If you use PV names in your scripts that are made up of a sequence of substrings,
the separators used are not recognized by the PCS 7 OS Converter. These
separators must then be reedited ("_" replaced by "/*).

Scripts with Static Properties

If you use variable names in scripts, that were configured, for example as object
names for picture windows (static properties), these must also be reedited (*_"
replaced by "/"). Reason: The Converter cannot recognize whether the content of
the static properties involves variable names.

Note

You can use CrossReference in WinCC to display and check the WinCC variables for
correct replacement of " " by "/". (For details see online help on CrossReference)
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4 Upgrading PCS 7 V5.0to V5.1

The basis of the upgrade is a project with version PCS 7 V5.0 SPx. This can
originate from of a full migration from PCS 7 V4.02 or can be a new project created
in version V5.0. The project must have been converted to the new driver blocks
and basic operations (BOPs). To adapt the project to PCS 7 V5.1, the new blocks
must be included in the PCS 7 libraries (V5.1) so that the new functions can be
used. You can read up on the new functions in "PCS 7 - What's New".

You should back up the project and the libraries before you upgrade, so that
you can always fall back on the original version.

When you upgrade, remember that the CPU must be set to STOP and that the
WinCC run time must be deactivated.

The PCS 7 V5.1 software must be newly installed or an update installation must be
run on the OS stations (WinCC server, PCS 7 ES, WIinCC client or WinCC multi-
client).

Procedure

You upgrade the project on the ES. From here, you download to the PLC and OS
(using a project download).

The procedure is designed for one PLC or OS.

4.1 PLC Upgrade Using the New Functions

41.1 SIMATIC Manager: Linking and Adapting Blocks from the New
Libraries

See also0:/3.3.3

4.1.2 CFC: Linking and Adapting Blocks from New Libraries

See also: 3.3.4
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4.1.3 Compiling and Downloading

e The entire program must be compiled with the "Generate Module Drivers"
option. The "Generate Module Drivers" function inserts the PO_UPDAT block
and, if it does not yet exist, the MSG_CSF block in the program.

* Adownload of the entire program is necessary.

4.1.4 PLC-OS Data Transfer

When transferring the PLC-OS connection data for the first time, the transfer option
"All" and "Clear operator station(s)" must be set.

4.2 OS Upgrade Using the New Functions

4.2.1 Check the Project Structures
The multi-client projects must exist on the ES.

4.2.1.1 Retaining Project Structures

If you want to retain the project structure, you can download to the existing
operator stations as previously using the "WinCC Project Duplicator” ("Save As...").

Once the path to the target OS has been set ( in the object properties) you can
also download to a master OS and an OS (multi-client) using the "PLC >
Download" menu command. You can download to a standby OS as previously
with the "WinCC Project Duplicator" (duplicating the master OS, and then copying
the xdb file and renaming it).

If you want to use a new project structure and the new function in the SIMATIC
Manager "PLC > Download", you must first follow the migration steps explained
below.
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4.2.1.2 New Project Structure

The OS is located in a SIMATIC PC station

1.

Standby OS

- Delete the WIinCC application in the SIMATIC PC station in HW Config
(this also deletes the original standby OS and the connections in Netpro).

- Insert the WinCC Application (stby) from the catalog (a new standby OS is
created).

- Reconfigure the connections in Netpro and then set the paths. To do this,
open the object properties of the OS in the SIMATIC Manager. Enter the
paths in the "Target OS and Standby OS" tab.

Master OS

- Set the path to the target OS computer in the object properties of the
master OS and assign the standby OS.
The standby OS is then automatically renamed as "Master OS
name_Stby".

Multi-client OS

In PCS 7 V5.0, it was not possible to create a multi-client OS in a SIMATIC PC
station but only using the "OS (multi-client)" project. If you want to create the
multi-client OS in the PC station in the new project structure, follow the same
steps as for "OS is not located in the SIMATIC PC station".

OS is not located in the SIMATIC PC station

1.

Master OS
- Configure the new PC station for master OS/multiple workstation project

- Delete the new OS in the PC station and copy the old OS to the PC
station.

- Set the path to the target OS and assign the standby OS

- Delete all pictures since they now exist twice

- Set PH to the new OS (important for later PLC-OS data transfer)
Standby OS

- Configure a new PC station for the standby OS

- Set the path the target OS

Multi-client OS

- Configure a new SIMATIC station for the multi-client OS

- Copy the OS (multi-client) to a new PC station (replace)

- Set the path the target OS

Configure the required PLC-OS connections in Netpro
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4.2.2 Adapting the Projects

Here, you adapt the projects of the OS stations (OS server project) and the multi-
client stations (multi-client project) to the new PCS 7 version.

4.2.2.1 OS Server Project

1. Base Data

Base Data contains the "Split Screen Wizard" and the "Alarm Logging Wizard".
Please note that when you run the Split Screen Wizard and Alarm Logging Wizard,
customer-specific settings in Alarm Logging and the base data pictures can be lost.

Split Screen Wizard

Right-click on "Split Screen Wizard" and select "Open".
Note: The dialog must be completed without error.

Alarm Logging Wizard
Right-click on "Alarm Logging Wizard" and select "Open".
If the option "Filter Messages by Range" on the 2nd page of the Wizard is
set (default), make sure that all messages configured in the text block
range of alarm logging have valid range names or are blank.
You should check in this dialog box whether the operator input messages

you require have been selected.
Note: The dialog must be completed without error.

2. Picture Tree Manager
Right-click "Picture Tree Manager" and select "Open".
Click Project > Save.
Exit "Picture Tree Manager".

3. Regenerate the package

You need to regenerate the server data in the WinCC Explorer using the
"Generate" function in "Serverdata".
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4.2.3 MC Project

1. Update multi-client

You then update the sever data to the latest version in the WinCC Explorer sing the
"Update" function in "Serverdata”.

2. Base Data

In multi-client projects, you only need to run the Split Screen Wizard. Remember
that when you run the Split Screen Wizard, your own specific settings in the base
data pictures can be lost.

Split Screen Wizard

- Right-click on "Split Screen Wizard" and select "Open".
Note: The dialog must be completed without error.

4.2.4 Project Download

e Since the target OS has already been entered in the project structure with PC
stations, the project download can be started immediately after connecting to
the OS.

* In a project structure with a single OS, the target OS must still be entered in
the OS properties. The project download can then also be started.

¢ In a project structure with a redundant server pair, the previous procedure (as
described in 4.2.1.1) can be used. You can also download the project in steps
by changing the entry for the target OS each time. Remember that the
redundancy entries in the WinCC Explorer must be checked and, if necessary,
modified following the download. In particular, you should check the entered
redundancy partner and the activation/deactivation of the "Standard master"
check box.

e The project download also downloads to the multi-clients.
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5 Upgrading / Modifying the Configuration with
the Plant Running

5.1 Upgrading a Redundant Plant While it is Running

You can upgrade a redundant plant with clients or multi-clients from WinCC V5.0
SP 1 to WIinCC V5.0 SP 2 in gradual steps without having to stop the plant running.
The upgrade must be made in the order shown without any long intervals between
the steps. Remember that all the servers must be upgraded first and then the
clients and multi-clients.

Aims
* The PLC remains constantly in Run.

* The process can be controlled at all times.

Initial Situation
e Server_1 is master server.
» Server_2 is standby server.

e Clients are connected to Server_1 if they are not deactivated when Server_2 is
deactivated. In some circumstances, clients not connected to Server_1 must
be switched over to Server_1 by writing to the redundancy variable
@RM_SWITCHER with the appropriate client name.

Brief Outline

Deactivate Server_2

Deactivate redundancy

Exit WinCC on Server_2 and reboot the computer
Install the new software on Server_2

Reactivate redundancy

Reactivate Server_2

Wait for archive synchronization

Switch over clients

© © N o 0 & wbd -

Deactivate Server_1

10. Deactivate redundancy
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11.
12.
13.
14.
15.
16.
17.
18.
19.
20.

Exit WinCC on Server_1 and reboot the computer

Install the new software on Server_1

Reactivate redundancy

Reactivate Server_1

Install the new software on other servers

Deactivate clients / multi-clients

Exit WinCC on the clients / multi-clients and reboot the computers
Install the new software on the clients / multi-clients

Reactivate the clients

Reactivate the multi-clients

Procedure in Detail

5-2

1.

3.
4,
5.

Deactivate Server_2
Multi-clients that have Server_2 as preferred server switch to Server_1.

Multi-clients that have no preferred server or Server_1 as preferred server
remain switched to Server_1.

Clients connected to Server_2 are deactivated.
Clients connected to Server_1 remain activated.
Deactivate redundancy

Deselect the check box "Activate redundancy"” in the redundancy
configuration on Server_1. This deactivates redundancy monitoring.

Exit WinCC on Server_2 and reboot the computer
Install the new software on Server_2

Reactivate redundancy

Select the check box "Activate redundancy" in the redundancy configuration on
Server_1. This reactivates the redundancy monitoring.

6.

Reactivate Server_2

Start WinCC on Server_2. The "Standard Master" check box in the redundancy
configuration must be deselected. If this is not the case, clear the check mark.
Activate the project.

There is no server switchover; Server_1 remains master server and
Server_2 remains standby.

Clients do not switch over. Clients that were deactivated are automatically
reactivated.

Multi-clients without a preferred server or that have Server_1 as preferred
server do not switch over.

Multi-clients that have Server_2 as preferred server switch to it.

The archive synchronization is automatic.
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7. Wait for archive synchronization

Wait until the archive synchronization is complete between master and standby
server. This is, however, not strictly necessary. When the archive synchronization
is complete, you will see the system message "Archive synchronization complete”,
if the system messages are configured in the "Alarm Logging" editor.

8. Switch over clients

Clients connected to server 1 must be switched over if they should not be
deactivated when server 1 is deactivated by writing to the internal redundancy
variable @RM_SWITCHER with the appropriate client name.

9. Deactivate Server_1
- Multi-clients that have Server_1 as preferred server switch to Server_2.

- Multi-clients that have no preferred server or Server_2 as preferred server
remain switched to Server_2.

- Clients connected to Server_1 are deactivated.
- Clients connected to Server_2 remain activated.
10. Deactivate redundancy

Clear the check box "Activate redundancy" in the redundancy configuration on
Server_2. This deactivates redundancy monitoring.

11. Exit WinCC on Server_1 and reboot the computer
12. Install the new software on Server_1
13. Reactivate redundancy

Select the check box "Activate redundancy" in the redundancy configuration on
Server_2. This reactivates the redundancy monitoring.

14. Reactivate Server_1

Start WinCC on Server_1. The "Standard Master" check box must be selected in
the redundancy configuration. Activate the project.

- There is no server switchover; Server_2 remains master server and
Server_1 remains standby.

- Clients do not switch over. Clients that were deactivated are automatically
reactivated.

- Multi-clients without a preferred server or that have Server_2 as preferred
server do not switch over.

- Multi-clients that have Server_1 as preferred server switch to it.
- The active server automatically starts an archive synchronization.
15. Install the new software on other servers

Install the new software on the other servers or server pairs in the same way as on
Server_1 and Server_2.

16. Deactivate clients / multi-clients

Deactivate all clients or multi-clients. You deactivate all at once or one after the
other.
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5-4

17. Exit WinCC on the clients / multi-clients and reboot the computers
18. Install the new software on the clients / multi-clients

19. Reactivate the clients

Start WinCC on the clients. The project is automatically activated.

There is no server switchover; Server_2 remains master server and
Server_1 remains standby.

20. Reactivate the multi-clients
Start WinCC on the multi-clients and activate the project.

There is no server switchover; Server_2 remains master server and
Server_1 remains standby.

Multi-clients without a preferred server connect to Server_2.

Multi-clients with a preferred server connect to the configured preferred
server.

Process Control System PCS 7, PCS 7 Migration V5.1
ABE00064939-02



Upgrading / Modifying the Configuration with the Plant Running

5.2  Modifying the Configuration in a Redundant System
while the Plant is Running

This section describes how to modify the configuration of a redundant system (for
example, a redundant server pair with multi-clients and several PLCs) that is
currently in operation; the CPUs must not change to STOP. The system has
previously been upgraded during operation from PCS 7 V5.0 SPx to V5.1, as
described in Section |1/ The modifications to the OS will also be transferred to the
servers and the multi-clients while the plant is running.

When you modify the configuration in this situation, make sure that you use only
the blocks that were already in use or that are located in the offline block folder. A
further requirement is that the project was created with PCS 7 version V5.0 SPx or
that it is a fully migrated project from PCS 7 V4.x to PCS 7 V5.0 (migration
according to the Migration Guide PCS 7 V4.x to PCS 7 V5.0 case 3). Make sure
that all the required authorizations exist on the ES and OS (for example,

CFC V5.2).

Brief Outline

Configure the changes in CFC
Configure the changes in SFC
Compile the CFC chart

Download changes

Transfer PLC-OS connection data
Configure the OS changes
Deactivate Server_1

Exit WinCC on Server_1

© ©o N o 0 s~ Db

Download project to Server_1

[y
o

. Reactivate Server_1

=
=

. Wait for archive synchronization

=
N

. Switch over clients

=
w

. Deactivate Server_2

'—\
S

. Download project to Server_2

=
(6)]

. Reactivate Server_2

=
()]

. Deactivate multi-clients

=
~

. Update multi-client packages

=
oo

. Reactivate the multi-clients
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Procedure

The procedure is designed for a redundant server pair with PLC, ES and multi-
clients or clients. The modified configuration of the PLC and OS will be downloaded
from ES.

(Server_1 = master server Server_2 = standby server)

Note

Pictures, CFC charts, the PH folder etc. can be inserted earlier in the plant
hierarchy of SIMATIC Manager.

5.2.1 Configure Changes in CFC

« New CFC charts can be included and configured or existing CFC charts can be
modified. However, only existing blocks can be configured.

« When you make the first modification to a CFC chart, the "Convert Format"
dialog is displayed. Confirm this with "Yes". The data are then converted to the
CFC format of version V5.2.

Note: If you have already converted the project from PCS 7 V4.02 to PCS 7 V5.0, a
block import into CFC will be necessary since the message time stamp of blocks
with message capability is changed by the copy function. This makes compilation
of the entire program necessary but not a full download. This means that you can
download changes without the CPU being changed to STOP.

5.2.2 Configure Changes in SFC

e Configure or modify SFC charts

* New charts with modified topology (including jump destination changes) can
only be inserted or loaded after the sequencer has been completely executed.
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5.2.3 Compile the CFC Charts

e If the project was created with PCS 7 V5.0 SPx, it is only necessary to compile
the changes.

» If you converted the project from PCS 7 V4.x to PCS 7 V5.x, a full compilation
is required, but this does not mean a full download.

e You can compile the changes with the options "Generate module drivers",
"Update sampling times" and "Delete empty run-time groups". With the
"Generate module drivers" function, the driver structure is checked/updated
and the PO_UPDAT block is included in the program. This addition does not
make either a full compilation or full download of the program necessary.

Note

When you compile with the "Generate module drivers" option, make sure that the
MSG_CSF block is already in the charts, otherwise the block will be installed and a full
download will be necessary.

524 Download Changes

Download the changes made to the CFC and/or SFC charts.

525 Transfer PLC-OS Connection Data

When you transfer the PLC-OS connection data, the options "All" and "Clear
operator station(s)" must be set.

5.2.6 Modify OS Configuration

»  The configuration of the OS is based on the changes made to the PLC and
must be adapted.

e At this point, we recommend that you convert the PCS 7 project to the new
structure with PCS 7 stations. This is described in detail in Section 4.2.1.
Whether or not you convert, the steps described in Section 4.2.2 are
necessary.

e Check the settings in redundancy and, if necessary, correct them (redundancy
partner etc.).

* Regenerate the package
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5.2.7 Deactivate Server_1

* Server_2 becomes the current master server.
*  Multi-clients that have Server_1 as preferred server switch to Server_2.

e Multi-clients that have no preferred server or Server_2 as preferred server
remain switched to Server_2.

e Clients connected to Server_1 are deactivated.

* Clients connected to Server_2 remain activated.

5.2.8 Exit WinCC on Server_1

5.2.9 Download Project to Server_1
» Select Server_1 in the project structure with PC stations and run a project
download.

« In a project structure with a single OS, enter the server to be downloaded in
the OS properties of the target OS. In other words, enter the OS of Server_1
there directly or select it in the browser. Then connect to the OS and run the
project download.

5.2.10 Reactivate Server_1

e Start WinCC on Server_1.

e Set the "Standard master" check box in the redundancy configuration on
Server_1 and check the settings of the redundant partner server.

* Activate WinCC run time

e There is no server switchover; Server_2 remains master server and Server_1
remains standby.

e Clients do not switch over. Clients that were deactivated are automatically
reactivated.

e Multi-clients without a preferred server or that have Server_2 as preferred
server do not switch over.

*  Multi-clients that have Server_1 as preferred server, switch over to it.

*  The archive synchronization is automatic.
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5.2.11 Wait for the Archive Synchronization

Wait until the archive synchronization is complete between master and standby
server. This is, however, not strictly necessary. The archive synchronization is
complete when the system message "Archive synchronization complete" appears.
System messages must already be configured in "Alarm Logging".

5.2.12 Switch Over Clients

Clients connected to server 1 must be switched over if they should not be
deactivated when server 1 is deactivated by writing to the internal redundancy
variable @RM_SWITCHER with the appropriate client name.

5.2.13 Deactivate Server_2

» Server_1 becomes the current master server.
e Multi-clients that have Server_2 as preferred server switch to Server_1.

e Multi-clients that have no preferred server or Server_1 as preferred server
remain switched to Server_1.

e Clients connected to Server_2 are deactivated.

¢ Clients connected to Server_1 remain activated.

5.2.14 Download Project to Server_2
e Select Server_2 in the project structure with PC stations and run a project
download.

¢ In a project structure with a single OS, enter the server to be downloaded in
the OS properties of the target OS. In other words, enter the OS of Server_2
there directly or select it in the browser. Then connect to the OS and run the
project download.

5.2.15 Reactivate Server_2

e Start WinCC on Server_2.

¢ Reset the "Standard master" check box in the redundancy configuration on
Server_2 and check the settings of the redundant partner server.

e If you followed point 2 in step 13, the name of server_2 is entered here and
must be modified.

* Activate WinCC run time

e There is no server switchover; Server_1 remains master server and Server_2
remains standby.

« Clients do not switch over. Clients that were deactivated are automatically
reactivated.
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»  Multi-clients without a preferred server or that have Server_1 as preferred
server do not switch over.

e Multi-clients that have Server_2 as preferred server, switch over to it.

*  The archive synchronization is automatic.

5.2.16 Deactivate Multi-Clients

Deactivate all multi-clients You deactivate all at once or one after the other.

5.2.17 Update Multi-Client Packages

Update the packages of all multi-clients; you should do this one after the other
(depending on the number of multi-clients).

5.2.18 Reactivate the Multi-Clients

* Activate WinCC run time

e There is no server switchover; Server_1 remains master server and Server_2
remains standby.

«  Multi-clients without a preferred server connect to Server_1.
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