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!
Danger

indicates that death, severe personal injury or substantial property damage will result if proper precautions
are not taken.

!
Warning

indicates that death, severe personal injury or substantial property damage can result if proper
precautions are not taken.

!
Caution

indicates that minor personal injury can result if proper precautions are not taken.

Caution

indicates that property damage can result if proper precautions are not taken.

Notice

draws your attention to particularly important information on the product, handling the product, or to a
particular part of the documentation.

Qualified Personnel
Only qualified personnel should be allowed to install and work on this equipment. Qualified persons are
defined as persons who are authorized to commission, to ground and to tag circuits, equipment, and
systems in accordance with established safety practices and standards.

Correct Usage
Note the following:

!
Warning

This device and its components may only be used for the applications described in the catalog or the
technical description, and only in connection with devices or components from other manufacturers which
have been approved or recommended by Siemens.

This product can only function correctly and safely if it is transported, stored, set up, and installed
correctly, and operated and maintained as recommended.

Trademarks
SIMATIC, SIMATIC HMI and SIMATIC NET are registered trademarks of SIEMENS AG.

Third parties using for their own purposes any other names in this document which refer to trademarks
might infringe upon the rights of the trademark owners.

Safety Guidelines
This manual contains notices intended to ensure personal safety, as well as to protect the products and
connected equipment against damage. These notices are highlighted by the symbols shown below and
graded according to severity by the following texts:

We have checked the contents of this manual for agreement
with the hardware and software described. Since deviations
cannot be precluded entirely, we cannot guarantee full
agreement. However, the data in this manual are reviewed
regularly and any necessary corrections included in
subsequent editions. Suggestions for improvement are
welcomed.

Disclaim of LiabilityCopyright Siemens AG 2004 All rights reserved

The reproduction, transmission or use of this document or its
contents is not permitted without express written authority.
Offenders will be liable for damages. All rights, including rights
created by patent grant or registration of a utility model or
design, are reserved.

Siemens AG
Bereich Automation and Drives
Geschaeftsgebiet  Industrial Automation Systems
Postfach 4848, D- 90327 Nuernberg

Siemens AG 2004
Technical data subject to change.

Siemens Aktiengesellschaft A5E00329019-02

이 기기는 업무용(A급) 전자파 적합기기로서 판매자 또는 사용자는 이 점을 주의하시기 바라며 가정 외의 지역에서 사용하는 것을 목적으로 합니다.
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Introduction

In this tutorial you program PROFINET interface X2 of CPU 317-2 PN/DP.
This takes about one to two hours, depending on your experience.

Range of applicability

Product Order number Is an MMC
required for

as of version
required for
operation? Firmware Hardware

CPU 317-2 PN/DP 6ES7317-2EJ10-0AB0 Yes V2.3 02

Requirements

� Basic knowledge of electronic and electrical systems engineering.

� Knowledge in the area of network engineering would be of advantage.

� You already worked with the STEP 7 programming software.

� We assume that you have experience working with the Microsoft Windows
operating system.

!
Warning

Depending on the field of application, the operation of an S7-300 in a plant or
system is subject to special rules and regulations. This includes current safety
regulations and directives for the prevention of accidents, such as IEC 204
(EMERGENCY-OFF equipment.)

If these regulations are ignored, serious injury and damage to machines and
equipment are to be expected.
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Material and tools required

Quantity Article Order number (Siemens)

1 Mounting rail for  example,
6ES7 390-1AE80-0AA0

1 Power supply (PS) for example,
6ES7 307-1EA00-0AA0

1 CPU 317-2 PN/DP, V2.3 or higher 6ES7317-2EJ10-0AB0

1 Micro Memory Card (MMC) 
Note: 
The MMC is absolutely required for operation.

for example,
6ES7 953-8LL11-0AA0

1 � Programming device (PG), or PC with Ethernet NIC,
100 Mbps full duplex

� Installed software, STEP 7, firmware version 5.3. SP1
or higher

depending on the configuration

1 Switch for example, SCALANCE X208 6GK5 208-0BA00-2AA3

2 Industrial Ethernet Twisted Pair cable (Cat5) with RJ45
connectors

(Patch cable TP Cord RJ45/RJ45, length = 6 m)

for example, 6XV1 850-2GH60

diverse M6 screws and nuts (lengths depend on place of
installation) and matching wrench / screwdriver

commonly available

1 Screwdriver with 3.5 mm blade commonly available

1 Screwdriver with 4.5 mm blade commonly available

1 Side cutters and wire stripper commonly available

1 Crimp tool for wire ferrules commonly available

0.5 m Single-pole flexible cable, conductor cross-section
1 mm2, with wire end ferrules, for connecting the power
supply and CPU

commonly available

X m Cable for grounding the mounting rail with a conductor
cross-section of 10 mm2 and cable lug matching M6
connectors, and with a length matching local  conditions

commonly available

X m 3-wire flexible power cable (AC 230/120 V) with Schuko-
style plug, with a length matching local conditions, and
matching wire end ferrules with collar.

commonly available



4
PROFINET IO Getting Started: Collection

A5E00329019-02

Installation

CPU 317-2
PS PN/DP

Mode selector
switch

Slot for the
Micro Memory
Card (MMC)

Status and
Error displaysBus error

display

Setting mains voltage

Power supply ON / OFF

Mounting rail

Industrial Ethernet
Twisted Pair cable for
interconnecting PN
interface X2

Industrial Ethernet Twisted Pair
cable for connecting to PROFINET
IO (ET 200S, for example)

Industrial Ethernet Twisted
Pair cable for interconnecting
the PG with the SCALANCE
X208 switch

Programming device (PG) with STEP 7 software

Wire the power supply and the CPU (front panel covers are open.)

220 V / 120 V
Connecting cables

Strain relief

L+

M

L+

M

L+

M L+

M D
C

 2
4V

MPI-interface X1 to
Connection to the PG

Power supply (PS) CPU 317-2 PN/DP

Removable
Power supply connection

between PS and CPU

Status indication of
second interface X2

PN-interface to the terminals
to Industrial Ethernet
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1. Installation

Graphic Install and ground the mounting rail

1.

1. Screw on the mounting rail (screw size: M6).
Make sure to maintain a minimum clearance of
40 mm above and below the mounting rail.
When mounting it on a grounded steel panel or
on a grounded device mounting panel made of
steel sheet, ensure a low-impedance contact
between the mounting rail and the mounting

2.

between the mounting rail and the mounting
surface.

2. Connect the mounting rail with the protective
conductor. An M6 protective conductor screw is
provided on the mounting rail for this purpose.
Stipulated cross-section of the cable connection
to the protective conductor: 10 mm2

Graphic Installing modules on the mounting rail
1. In the first step, insert the power supply module.

Slide it to the left until it meets the grounding
screw of the mounting rail and then screw it on.

2. To connect further modules, insert a bus
connector into the CPU (see drawing section)

12

3

3. Hang in the CPU (1).

4. Slide it up to the left module (2).

5. You can then swing it down (3).

6. Screw-tighten the modules on the mounting rail.

7. Insert the MMC into its slot on your CPU:
The MMC is absolutely required for operation!
Note: 
To use an MMC with unknown content, erase
it on the PG before doing so..
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2. Wiring

!
Warning

There is a risk of contact to live power cables. Always isolate the S7-300 from
power before you wire it.

Wiring the power supply module and the CPU

Step Wiring the power supply and CPU

1 Open the front panel covers of the power supply module and CPU.

2 Unscrew the strain relief clamp of the power supply.

3 Strip the flexible power cable, dress it with crimped wire ferrules, then connect it to the power
supply module (blue on terminal M, black on terminal L1, protective conductor on terminal PE)

4 Screw down the clamp of the cable strain relief.

5 Next, wire the power supply to the CPU. Use flexible cable with a conductor cross-section of
1 mm2.

Strip the ends to a length of approx. 6 mm, the crimp on the wire end ferrules. 
Next, interconnect the terminals L+ and M of the power supply and CPU 200B.

6 Verify that the setting of the selector switch matches your mains voltage.

The default line voltage setting for the power supply module is 230 VAC. 
To change this setting: Remove the protective cap with a screwdriver, set the selector switch to
match your line voltage, then insert the protective cap again.
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3. Commissioning the hardware

Step Activity Result

1 Connect the PG/PC to the switch. Use the twisted-pair
cables with RJ45 connectors.

The PG/PC is connected to the
switch.

2 Connect the switch to PROFINET interface of your X2
CPU with Industrial Ethernet. Use the twisted-pair
cables with RJ45 connectors.

The CPU is connected to the switch.

3 Interconnect the PROFINET IO device (ET 200S, for
example) with the switch. Use the twisted-pair cables
with RJ45 connectors.

The IO device is connected to the
switch.

4 Verify the MMC is inserted in the CPU slot.

5 Close the front panel cover of the CPU, then set the mode selector switch on the CPU to
STOP.

6 Connect mains, then switch on the power supply
module.

The DC24V LED on the power supply
is lit.

The CPU performs a lamp test; after
this, the SF and DC5V LEDs stay lit.
The STOP LED then flashes rapidly
when the CPU performs an automatic
memory reset.

After completion, the STOP LED is lit.

7 Start your PG/PC, then run SIMATIC Manager from
your Windows Desktop.

A window opens with SIMATIC
Manager.
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4. Set up the PG/PC interface

Step Activity Result

1 Select  Start > SIMATIC > STEP 7> Customize
PG/PC interface

The dialog box for setting the PG/PC
opens.

2 Select the access path, and set the TCP/IP(Auto)
protocol for the network card used.

Click “Properties.” Set the “Assign project-specific
IP address” option in the “Properties” dialog box.
Confirm twice with OK.

Your PG/PC settings are applied.

5. Create a new project and configure the hardware

Create a new project in STEP 7:

Step Activity Result

1 In SIMATIC Manager, select File > New...
Enter a project name and confirm with OK.

A new project is created.

Adding an S7-300 station

Step Activity Result

1 In SIMATIC Manager, select Insert > Station >
SIMATIC 300 Station.

On the right side of the window you
can see the selected 
SIMATIC 300(1) symbol.
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Adding a mounting rail

Step Activity Result

1 On the right side of the window, double-click the
SIMATIC 300(1) icon, then click the hardware icon.

This opens HW Config.

2 Add your HW components using the hardware catalog.

If there screen does not show any catalogs, open the
relevant catalog by clicking View > Catalog.

In the hardware catalog, select SIMATIC 300 and then
Rack 300. Drag-and-drop the mounting rail to the
upper part of the HW Config window

This pastes the mounting rail into the
upper section of the HW Config
window.

Adding the power supply:

Step Activity Result

1 Select PS-300 from the hardware catalog. Drag-and-
drop your power supply to slot 1 of the mounting rail.

Note:
You can click the power supply module to view its
order number. The order number appears in the bar
below the catalog.

The power supply module is now
inserted at slot 1.
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To insert CPU 317-2 PN/DP and assign it an IP address:

Each Ethernet node is identified by an international unique address. 
The manufacturer assigns this so-called MAC address. You can not change this
address.

In the next steps you are shown how to assign an Ethernet IP address to this
physical address.

Step Activity Result

1 Select CPU-300 from the hardware catalog. 
Drag-and-drop the CPU 317-2 PN/DP V2.3 to
slot 2 of the mounting rail.

CPU 317-2 PN/DP is now inserted at
slot 2, and the properties view of the
PROFINET interface X2 appears.

2 Enter the IP address and the subnet mask.

When working on a corporate network, contact
your network administrator for information about
this address.

3 If you setup a router connection, you must also
enter the address of the router.

When working on a corporate network, contact
your network administrator for information about
this address.

4 Click “New”, then assign a name for a new
Industrial Ethernet subnet. Confirm your entries
with “OK.”

You created a new Industrial Ethernet
subnet.
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Activity ResultStep

5 Click “OK.” The properties window of PROFINET
interface X2 for CPU 317-2 PN/DP
closes.

6 You can now customize the PROFINET interface
options in HW Config:

In HW Config, select CPU 317-2 PN/DP and
double-click PROFINET interface X2.

Change to the “Options” tab. There you can cus-
tomize network settings. Default is “Automatic Set-
tings”, which is usually sufficient for error-free
communication. Communication problems (con-
nections fail, or frequent network errors, for exam-
ple) may be caused by faulty settings, or by a
faulty automatic network settings.

In this case, adjust your network settings to match
you network configuration.

Individual network settings can be made
in HW Config.

Saving and compiling the configuration:

Step Activity Result

1 Select the Station > Save and Compile
command.

Your hardware configuration is now
compiled and saved.

2 Select PLC > Download to module In the next dialog box, select the
destination module.

CPU 317-2PN/DP is already select.
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Activity ResultStep

3 Confirm the dialog with “OK.” In the next dialog box, select the node
address.

The CPU is not shown under
“available nodes” yet.

4 Click “View.” The PG reads the MAC address and
shows it on the dialog box.

5 Select the line containing the MAC address of the
CPU, and confirm with OK

The alarm view opens
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Activity ResultStep

6 Confirm this alarm with “Yes” This assigns the IP address to the CPU
and initiates the configuration download.

7 Select Station > Close to exit HW Config, and
confirm the save request with Yes.

HW Config is closed.

In SIMATIC Manager, the CPU is now
visible in the station.

6. Commissioning

Step Activity Result

1 Set the mode selector switch of the CPU to RUN. The STOP LED is switched off. The
RUN LED starts to flash and then
assumes a continuous signal.

The LINK LED indicates a physical
Ethernet connection.

The RX/TX LED is lit or flashes when
data are transmitted / received via
Ethernet.

Result

You completed the STEP 7 configuration of PROFINET interface X2 of your
CPU 317-2 PN/DP.

� Other nodes can now access the CPU on the Ethernet subnet using the IP
address.

� The new functions now allow you to configure your project, or to reconfigure it,
via the integrated PROFINET interface of the CPU.

� All PG/OP functions and other communication functions of CPU 317-2 PN/DP
are now available via integrated PROFINET interface.

Reference

For detailed information on address assignment for the PROFINET interface, refer
to the STEP 7 Online Help.
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Diagnostics / troubleshooting

Wrong operation, faulty wiring or a faulty hardware configuration may cause errors
which the CPU, CP or IE/PB-Link indicate with the SF group error LED after CPU
memory reset.

For information on how to analyze such errors and alarms, refer to the CPU 31xC
and CPU 31x operating instructions.

Manuals containing further information

� Getting Started: Getting Started and Exercises with STEP 7 V5.3.

� Manual: SIMATIC NET: Twisted Pair and Fiber Optic Networks

� Manual: Communication with SIMATIC

Service & Support on the Internet

In addition to our documentation, we offer a comprehensive online knowledge base
on the Internet at:

http://www.siemens.com/automation/service&support

There you can find:

� The Newsletter containing the latest information on your products.

� The documents you need using our Service & Support search engine.

� A bulletin board where users and specialists exchange experiences worldwide

� Contacts for Automation & Drives are listed in the contact partner database.

� Information about on-site services, repairs and spare parts. Lots more is
available on the “Services” page.

http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo2&siteid=cseus&lang=en
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Introduction

In this tutorial you configure an ET 200S for operation as PROFINET IO device.
This takes about one to two hours, depending on your experience.

Range of applicability

Product Order number Is an MMC
required for

From version
required for
operation? Firmware Hardware

CPU 317-2 PN/DP 6ES7317-2EJ10-0AB0 Yes V2.3 02

IM 151-3 PN 6ES7151-3AA00-0AB0 Yes V1.0 01

Requirements

� Your S7 station consists of a power supply module and of a CPU 317-2 PN/DP,
installed and configured as shown in Getting Started “CPU 317-2PN/DP:
Configuring PROFINET interface X2.”

� STEP 7 V 5.3 + ServicePack 1 or higher  is installed on your PG. You know
how to work with STEP 7.

� The PG is connected to PROFINET IO.

!
Warning

Depending on the field of application, the operation of an S7-300 in a plant or
system is defined by special rules and regulations. This includes current safety
regulations and directives for the prevention of accidents, such as IEC 204
(EMERGENCY-OFF equipment.)

If these regulations are ignored, serious injury and damage to machines and
equipment are to be expected.
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Material and tools required

Quantity Article Order number (Siemens)

1 Standard mounting rail 35 mm ( length = 483 mm, for
example)

6ES5 710-8MA11

1 Interface module IM151-3 PN and terminating module,
1 piece

6ES7 151-3AA00-0AB0

1 Micro Memory Card (MMC) For  example,
6ES7 953-8LF11-0AA0

2 Fast Connect terminal module TM-P15N23-A1, 
1 piece

6ES7 193-4CC70-0AA0

2 Fast Connect terminal module TM-P15N23-A1,
5 pieces

6ES7 193-4CA70-0AA0

2 PM-E DC24V, 1 piece 6ES7 138-4CA00-0AA0

1 4DI DC24V ST, 5 pieces 6ES7 131-4BD00-0AB0

1 4DO DC24V/0.5A ST, 5 pieces 6ES7 132-4BD00-0AB0

1 Industrial Ethernet FC RJ45 connector 90, 
10 pieces

6GK1 901-1BB20-2AB0

1 Industrial Ethernet FC stripping tool 6GK1 901-1GA00

Suitable installation cables:

� FC Standard Cable

� FC Trailing Cable

� FC Marine Cable

6XV1 840-2AH10

6XV1 840-3AH10

6XV1 840-4AH10
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Installation

The figure below shows which ET 200S components you require for the example
on the PROFINET IO:

DI DI
IM151-3

PN

PM DO DOPM

Mounting rail

Terminating module

2 x Terminal Module TM-E15N24-A1 and
Electronic Module 4DO DC24V/0.5A ST

Terminal Module TM-P15N23-A1 and
Power Module PM-E DC24V

2 x Terminal Module TM-E15N24-A1 and
Electronic Module 4DI DC24V ST

Terminal Module TM-P15N23-A1 and Power Module PM-E DC24V

Interface Module IM151-3 PN

Industrial Ethernet FC installation cable with connector FC RJ45 Plug 90

1 2 3 4 5 6 Slot

Components for the example on PROFINET IO
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1. Installation

Step Tasks

1 Install the mounting rail (35 x 7.5 mm or 15 mm, length = at least 210 mm) on a solid surface.

2 Connect the mounting rail with the protective conductor. Minimum conductor cross-section:
10 mm2

3 Mount the various modules onto the rail, starting on the left side (hang in – swivel down – slide
to left.) Follow this sequence:

� Interface module IM151-3 PN

� Terminal module TM-P15N23-A1

� 2 x terminal module TM-E15N24-A1

� Terminal module TM-P15N23-A1

� 2 x terminal module TM-E15N24-A1

� Terminating module

2. Wiring and assembly

Step Activity

1 Wire the ET 200S as shown below:

2

3

AUX1

3

6

7

1 5

2

3

6

7

1 5

2

3

AUX1

3

6

7

1 5

2

3

6

7

1 51L+ 1M

24 VDC

Electronic system
power supply

24 VDC

Encoder power supply,
potential group 1

24 VDC

Load power supply,
potential group 2

6

7

26

7

4 8 8 8 88

2

4 44 4
A
4

A
8

2 Use the RJ45 connector to interconnect the ET 200S (IO device) with the I/O controller via
switch. The PROFINET interface is installed at IM151-3 PN.

3 Insert the power supply and electronic modules into the terminal modules.
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3. Configuring

Step Activity

1 Run SIMATIC Manager, then open the project you created in Getting Started 
“CPU 317-2 PN/DP: Configuring PROFINET interface X2.”

2 Drag-and-drop IM151-3 PN from the PROFINET IO > I/O > ET 200S catalog to the
PROFINET IO system.

3 Drag-and-drop the various ET 200S modules into the configuration table, according to the
physical installation of the PROFINET IO devices.

4 Save and compile the HW configuration.
Select Station > Save and compile
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4. Insert the MMC and switch on the device.

Step Activity Result

1 Insert the MMC into IM151-3 PN. The MMC is absolutely required for
operation!
Note:
To us an MMC with unknown content,
erase it on the PG before doing so.

2 Switch on the power supply for the switch. The switch starts up and the power LED
is lit.

3 Switch on the power supply for CPU 317-2 PN/DP. Reaction of the status LED on the
CPU 317-2 PN/DP:
� DC 5V � is lit
� SF � is off

4 Switch on the power supply for the IM151-3 PN and
PM-E.

Reaction of the status LED on the
IM 151-3:
� BF � flashes
� ON � is lit
� LINK � is lit
The SF LEDs of all electronic modules
are also lit.
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5. Assign a name to the IO device

Step Activity

1 In HW Config, open the Properties – IM151-3 PN dialog box and enter the device name
for your IO device.

2 Save and compile the HW configuration.
Select Station > Save and compile
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ActivityStep

3 To transfer the name configuration to IM151-3 PN, you need an online
PROFINET connection between the PG and the IO device via a switch.

Select PLC > Ethernet > Assign device name to transfer the device name to
IM151-3 PN.

4 When using more than one IO device, the system shows all of those in the Assign device
name dialog box. In this case, compare the MAC address of the device with the indicated
MAC address, then select the relevant IO device.

On the Assign device name dialog box, click Assign name The device name is saved to
the MMC at interface module IM151-3 .
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ActivityStep

5 The dialog box indicates the device name you assigned.

6 Download the HW configuration to CPU 317-2 PN/DP. 
Select PLC > Download to module.

The CPU automatically assigns an IP address to the IO device after it has received this 
download. The IO device is ready for cyclic data exchange after the subnet is properly
installed and the configuration corresponds with the physical structure of the I/O device.

The BF2 LED of the CPU flashes after you downloaded the HW configuration. The BF2 LED
on the CPU and the flashing BF LED of the IO device are switched off when the CPU has
accepted the IO device.

Leave the CPU in STOP until you have written the user program and downloaded it to the
CPU.
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6. Download the user program and configuration to the CPU

Step Activity

1 Create the OB 1 user program in the LAD/STL/FBD editor.

Example 1: Reading an input and controlling an output:

STL

U I 0.0
U M 2.0
S Q 0.0

When input bit 0.0 and
flag bit 2.0 are set,
set output bit 0.0

Example 2: Transferring an input byte to an output byte:

STL

L PIB 0

T POB 0

Load accu with 
bits 0.0 to 0.7
 of IO input byte 0
Write bits 0.0 to 0.7 from accu to IO input
byte 0

2 Save the user program (OB1) and close the LAD/STL/FBD editor

3 Select the “Blocks” folder, then download all blocks to the CPU. 
Select PLC > Download

7. Switch the CPU to RUN and monitor the functions

Step Activity

1 Switch the CPU to RUN.

2 Status of some of the important LEDs on the CPU 317-2, ET200S and switch after
commissioning has been completed:

� CPU 317-2 PN/DP

DC 5V: lit

SF: off

BF2: off

LINK: flashes

� ET 200S:

SF: off

BF: off

ON: lit

LINK: lit

� Switch:

LED of used ports: lit

3 Verify the station functions and debug the user program.



26
PROFINET IO Getting Started: Collection

A5E00329019-02

Diagnostics / Troubleshooting

Wrong operation, faulty wiring or a faulty hardware configuration may cause errors
which the CPU, CP or IE/PB-Link indicate with the SF group error LED after CPU
memory reset.

For information on how to analyze such errors and alarms, refer to the CPU 31xC
and CPU 31x operating instructions.

Manuals containing further information

� Getting Started: Getting Started and Exercises with STEP 7 V5.3.

� Manual: SIMATIC NET: Twisted Pair and Fiber Optic Networks

� Manual: Communication with SIMATIC

Service & Support on the Internet

In addition to our documentation, we offer a comprehensive online knowledge base
on the Internet at:

http://www.siemens.com/automation/service&support

There you can find:

� The Newsletter containing the latest information on your products.

� The documents you need using our Service & Support search engine.

� A bulletin board where users and specialists exchange experiences worldwide

� Contacts for Automation & Drives are listed in the contact partner database.

� Information about on-site services, repairs and spare parts. Lots more is
available on the “Services” page.

http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo2&siteid=cseus&lang=en
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Introduction

In this example you configure an a CP 443-1 Advanced with PROFInet interface to
an IE/PB-Link which is interconnected with an ET 200B (DP V0 slave) via
PROFIBUS DP for use in an existing S7-400 automation system.

This takes about two to four hours, depending on your experience.

Range of applicability

CPU Order number Is a memory module
required?

From version
required?

Firmware Hardware

CP 443-1 Advanced 6GK7 443-1GX20-0XE0 Yes, C-Plug V2.0 V1.0

IE/PB Link PN IO 6GK1 411-0AB00 No V1.0 V1.0

Requirements

� Basic knowledge of electronic and electrical systems engineering.

� Knowledge in the area of network engineering would be of advantage.

� You already worked with the STEP 7 programming software STEP 7.

� We assume that you are firm in handling the MS Windows operating system.

!
Warning

When implementing the S7-400, IE/PB-Link and ET 200B in plants or system, you
need to conform to special rules and regulations. This includes current safety
regulations and directives for the prevention of accidents, such as IEC 204
(EMERGENCY-OFF equipment.) If these regulations are ignored, serious injury
and damage to machines and equipment are to be expected.
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Material and tools required

Quantity Module Order number

1 A functional S7-400 PLC consists of the rack, a power
supply module, and of a CPU approved fro operation with
a CP 443-1 Advanced Advanced module

depending on the configuration

1 CP 443-1 Advanced with C-PLUG 6GK7 443-1GX20-0XE0

1 IE/PB Link PN IO 6GK1 411-0AB00

1 Rails 6ES7 390-1AE80-0AA0, 
for example

1 An ET 200, for example, ET 200B, consisting of a
terminal block and electronic block

6ES7 133-0BH0-0XB0, 
for example

1 DIN rail commonly available

2 Power supply (PS) modules 6ES7 307-1BA00-0AA0, 
for example

1 � Programming device (PG) or PC with corresponding
MPI interface card and Ethernet NIC

� PG cable

� installed STEP 7 software, firmware version 5.3 SP 1

depending on the configuration

1 Screwdriver with 3,5 mm blade commonly available

1 Screwdriver with 4.5 mm blade commonly available

1 Sidecutters and wire stripper commonly available

1 Crimp tool for wire ferrules commonly available

X m Cable for grounding the mounting rail with a conductor
cross-section of 10 mm2 and cable lug matching M6 con-
nectors, and with a length matching local requirements

commonly available

X m 3-wire flexible power cable (AC 230/120 V) with Schuko-
style plug, with a length matching local conditions, and
matching cable ferrules with collar.

commonly available

X m Two Ethernet cables with RJ45 connector commonly available

X m PROFIBUS cable with Profibus connector and integrated
terminating resistors

commonly available
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installation

PS CPU CP 443-1
Advanced

MPI

Port 3

Port 1

Port 2

Port 4

MPI

PG/PC

C-PLUG on the rear panel

PS

DP

IE/PB-Link

ET 200B

S7-400

PROFIBUS DP cable

Industrial twisted-pair cable

PN

PN

PN

PN

PN = PROFINET
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1. Installation

CP in S7-400

Graphic Installation of the CP 443-1 Advanced in
S7-400

1. Insert the C-PLUG into slot on the rear
panel the CP

2. Insert the CP at the top.

3. Swing the CP down.

4. Screw-tighten the module on the rack

IE/PB-Link

Graphic Install and ground the mounting rail

2.

1.

1. Screw on the mounting rail (screw
size: M6). Make sure to maintain a
minimum clearance of 40 mm
above and below the mounting rail.

When mounting it on a grounded
steel panel or on a grounded
device mounting panel made of
steel sheet, make sure you have a
low impedance connection
between the mounting rail and thebetween the mounting rail and the
mounting surface.

2. Connect the mounting rail with the
protective conductor. 
An M6 protective conductor screw
is provided on the mounting rail for
this purpose.

Stipulated cross-section of the
cable connection to the protective
conductor: 10 mm2

Installing modules on the rail

1. In the first step, insert the power supply module. Slide it to the left until it
meets the grounding screw of the mounting rail and then screw it on.

2. Insert the IE/PB-Link at the top.

3. Slide it up to the left module.

4. You can then swing it down.

5. Screw-tighten the modules on the mounting rail.
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2. Wiring

!
Warning

There is a risk of contact to live power cables. Always disconnect power to the
S7-400, IE/PB-Link and ET 200B before you start wiring.

Wiring the power supply and IE/PB-Link modules

Wire the power supply and the IE/PB-Link (front panel flaps are open.)

220 V / 120 V
Connecting cables

Strain relief

L1

N

L+

 M 

L+

 M L+

 M 24
 V

D
C

Power supply (PS) IE/PB-Link

Power supply connection

between PS and IE/PB-Link
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Step Wire the power supply and the IE/PB-Link

1 Open the front flaps of the power supply and IE/PB-Link modules.

2 Unscrew the strain relief clamp of the power supply.

3 Strip the flexible power cable, .dress it with crimped wire ferrules, then connect it to
the power supply module (blue on terminal N, black on terminal L1, protective
conductor on terminal PE)

4 Screw down the clamp of the cable strain relief.

5 Next, wire the power supply line to the IE/PB-Link. Use flexible cable with a
conductor cross-section of 1 mm2. Strip the ends to a length of approx. 6 mm, the
crimp on the wire end ferrules. Next, interconnect the terminals L+ and M of the
power supply and IE/PB-Link modules.

6 Verify that the setting of the selector switch matches your mains voltage. The default
line voltage setting for the power supply module is 230 VAC. To change this setting,
proceed as follows: Remove the protective cap with a screwdriver, set the selector
switch to match your line voltage, then insert the protective cap again.

Wiring the power supply module and the ET 200B

Step Wiring the power supply and the ET 200B

1 Open the front panel flaps of the power supply module.

2 Unscrew the strain relief clamp of the power supply.

3 Strip the flexible power cable, dress it with crimped wire ferrules, then connect it to
the power supply module (blue on terminal N, black on terminal L1, protective
conductor on terminal PE).

4 Screw down the clamp of the cable strain relief.

5 Next, wire the power supply to the ET 200B. Use flexible cable with a conductor
cross-section of 1 mm2. Strip the ends to a length of approx. 6 mm, the crimp on the
wire end ferrules. Next, interconnect the terminals L+ and M of the power supply and
ET 200B modules.

6 Verify that the setting of the selector switch matches your mains voltage. The default
line voltage setting for the power supply module is 230 VAC. To change this setting,
proceed as follows: Remove the protective cap with a screwdriver, set the selector
switch to match your line voltage, then insert the protective cap again.

7 Set the PROFIBUS address using the two index switches. See the ET 200B
description.

8 Wire the 24 V power supply for the I/O according to the description in the ET 200B
manual.
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3. Commissioning the hardware

Commissioning the hardware of the S7-400 PLC

Step Tasks Result

1 Connect the PG cable to the PG/PC and to the
CPU. When using a cable with PROFIBUS
connectors, switch on the integrated terminating
resistors. Close the front panel flap of the CPU,
then set the mode selector switch on the CPU to
STOP.

The PG/PC is interconnected with
the CPU via MPI.

2 Connect any Ethernet port of your CP with
Industrial Ethernet. Use the twisted-pair cables
with RJ45 connectors. Set the mode selector
switch of the CPU to STOP.

The CP is connected to the
Industrial Ethernet

3 Connect any Ethernet port of your CP with your
PG. Use the twisted-pair cables with RJ45
connectors.

The CP is interconnected with the
PG via Ethernet.

4 Connect the mains cable, then switch on the
power supply module of the S7-400.

When the S7-400 is connected to
power, the 24 V and 5 V power
supply LEDs are lit. The CPU
performs a brief lamp test on all
LEDs, and then sets only the
EXTF and STOP LEDs. This test
is also performed on the LEDs of
the CP, and the INTF and STOP
LEDs are then set.

5 Start your PG/PC, then run SIMATIC Manager
from your Windows Desktop.

A window opens with
SIMATIC Manager.
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Commissioning the hardware of the IE/PB-Link

Step Tasks Result

1 Connect the PROFINET interface of your
IE/PB-Link to Industrial Ethernet. Use the
twisted-pair cables with RJ45 connectors.

IE/PB-Link is interconnected with
the CP 443-1 Advanced
Advanced via Industrial Ethernet

2 Connect the PROFIBUS cable to the PROFIBUS
interface of the IE-PB Link. Switch on the
integrated terminating resistors of the PROFIBUS
connector if the PROFIBUS terminates at the
connector.

IE/PB-Link is connected to
PROFIBUS DP

3 Close the front panel flaps of the IE/PB-Link.

4 Connect the mains cable, then switch on the
power supply module of the IE/PB-Link.

The 24 VDC power supply LED is
lit on the power supply module.
Several LEDs light up briefly on
the IE/PB-Link, and after a delay
time of approx. 5 s, the SF and
STOP LEDs are lit.

Commissioning the ET 200B hardware

Step Tasks Result

1 Connect the PROFIBUS cable to the PROFIBUS
interface of the ET 200B. Switch on the
integrated terminating resistors of the PROFIBUS
connector if the PROFIBUS terminates at the
connector.

The ET 200B is connected to
PROFIBUS DP

2 Connect mains, then switch on the power supply
module.

The 24 VDC power supply LED is
lit on the power supply module.
The RUN,  BF and L1+ LEDs are
lit on the ET 200B module.



36
PROFINET IO Getting Started: Collection

A5E00329019-02

4. Configuring the hardware in HW Config of STEP 7

Open an existing project with S7-400:

Step Tasks Result

1 In SIMATIC Manager, select File > Open to open
your project.

A window with two panes appears
with the title of your project.

2 On the right pane, double-click the icon of the
existing SIMATIC 400, then click the hardware
icon.

HW Config of the existing S7-400
opens.

3 You can insert your hardware components from
the hardware catalog shown in the left pane. If
this catalog is not shown, open it by selecting the
View > Catalog command.
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Installing the CP 443-1 Advanced Advanced in S7-400:

Step Tasks Result

1 Select the rack slot for the CP 443-1 Advanced.
In the hardware catalog, navigate to “CP-400”,
“Industrial Ethernet”, “CP 443-1 Advanced
Advanced” “V2.0”. Double-click (on V2.0) the
CP 443-1 Advanced to insert it into S7-400.

The CP 443-1 Advanced is
installed in the selected slot.
The properties dialog box of the
Ethernet port is shown.

2

3 Enter the IP address and the subnet mask. Your
network administrator provides you with this
information.

4 If you integrate a router into your communication
system, you also need to specify its address.
This information is also provided by your network
administrator

5 Click “New”, then assign a name for a new
Industrial Ethernet subnet. Confirm your entries
with “OK.”

You created a new Industrial
Ethernet subnet.



38
PROFINET IO Getting Started: Collection

A5E00329019-02

Tasks ResultStep

6 Confirm your entries with “OK.” This closes the dialog box of the
Ethernet interface of your
CP 443-1 Advanced.

7 Right-click to select CP 443-1 Advanced, then
select “Object properties...) from the shortcut
menu.

The properties dialog box of your
CP 443-1 Advanced opens.

8 Change to the “Port Parameters” tab. There you
can customize the network settings. Default is
“Automatic Settings”, which is usually sufficient
for error-free communication. Communication
problems (connections fail, or frequent network
errors, for example) may be caused by faulty
settings, or by the automatic network settings. If
this happens, tune the settings to match your
network configuration.

You have made user-specific
network settings in HW Config.

9 Click “OK.” This closes the properties dialog
box of your CP 443-1 Advanced.

Connecting the PROFINET IO system to CP 443-1 Advanced Advanced

Step Tasks Result

1 Right-click CP 443-1 Advanced, then select
“Insert PROFINET IO system.”

The bus segment of the
PROFINET IO subnet is visible in
the graphic view.



39
PROFINET IO Getting Started: Collection
A5E00329019-02

Connecting IE/PB-Link to the PROFINET IO system

Step Tasks Result

1 Select “PROFINET IO system” in the graphic
view. In the hardware catalog, navigate to
“PROFINET IO” > “Network Node” > “IE/PB Link
PN IO” “V1.0”. Double-click (on V1.0)
IE/PB-Link to add it to the configuration.

The properties dialog box of the
PROFIBUS interface is shown.

2 Set the PROFIBUS address. The DP master address is set at
the PROFIBUS.

3 Click “New”, then assign a name for a new
PROFIBUS subnet. Confirm your entries with
“OK.”
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Tasks ResultStep

4 To customize your network settings, click
“Properties”, then click “Network Settings.” The
default transmission rate with DP profile is
“1.5 Mbps”, which is usually sufficient for
error-free communication. Communication
problems (connections fail, or frequent network
errors, for example) may be caused by faulty
settings, or by the automatic network settings. If
this happens, tune the settings to match your
network configuration and then click “OK.”

You have made user-specific
network settings in HW Config.

5 Confirm your entries with “OK.” This closes the properties dialog
box of the  PROFIBUS interface
of your IE/PB-Link. The
PROFIBUS DP subnet appears in
the graphic view.

6 Right-click the IE/PB-Link, then select
“Object properties...” from the shortcut menu.

The properties dialog box of the
IE/PB-Link opens

7 Customize the device name as required. Make a
note of this name, because you are going to
need it for commissioning.

You assigned a user-specific
name for the IE/PB-Link.
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Tasks ResultStep

8 Click “Ethernet...” The properties dialog box of the
Ethernet interface is shown.

9 Enter the IP address in the “Properties - Ethernet
Interface” screen form. You network administrator
provides this information. Confirm your entries
with “OK.”

This closes the properties dialog
box of the Ethernet interface.

10 Click “OK.” This closes the properties dialog
box of the IE/PB-Link
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Connecting the ET 200B to PROFIBUS

Step Tasks Result

1 Select the PROFIBUS subnet in the graphic view.
In the hardware catalog, navigate to
PROFIBUS DP > ET 200B and to the required
module. Insert this module into HW Config with
double-click.

The properties dialog box of the
PROFIBUS interface is shown.

2 Type in the PROFIBUS address. Confirm your
settings with “OK.”

This closes the properties dialog
box of the PROFIBUS interface of
the ET 200B. The ET 200B
appears in the graphic view.

3 In HW Config, double-click “8DQ” in the “DP ID”
column of the lower table. In the “Start” box of the
properties dialog box, type in the start address of
the outputs. Confirm your entries with “OK.”

You defined the start address of
outputs
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Tasks ResultStep

4 In HW Config, double-click “8DI” in the “DP ID”
column of the lower table. In the “Start” box of the
properties dialog box, type in the start address of
the inputs. Confirm your entries with “OK.”

You defined the start address of
inputs
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Saving and compiling the configuration:

Step Tasks Result

1 Select the Station > Save and Compile
command.

Your hardware configuration is
now compiled and saved.

2 Select Station > Exit to close HW Config. The editor is closed.

5. Commissioning

Assigning a device name at the Ethernet of the IE/PB-Link

Step Tasks Result

1 Connect your PG to the Ethernet subnet of the
IE/PB-Link. The IP address of the PG must lie
within the same address space and subnet mask.
This can be set in Microsoft Windows under
Network Connections.

You connected the PG to the
IE/PB-Link

2 In STEP 7, select Options > Customize PG/PC
interface to set the TCP/IP protocol for your
PG/PC interface.

You assigned a TCP/IP
configuration to the PG interface.

3 In SIMATIC Manager, select PLC > Assign
Ethernet Address. The Assign Ethernet Address
dialog box opens. Click “Search...” .

The “Scan network” dialog box
opens
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Tasks ResultStep

4 From the list of Ethernet nodes found, select the
line containing the station type “IE/PB Link”, then
click “OK.”

This closes the “Scan network”
screen form and enters the MAC
address of the IE/PB-Link at the
previous “Assign Ethernet
Address” screen form.

5 In the “Device name” box of the “Assign Ethernet
Address” screen form, enter the same name you
assigned in HW Config to the IE/PB-Link.
Click “Assign Name.”

A window opens with this text:
“Name assigned successfully.”

6 Click “OK” on the message window. This closes the message window.

Assigning an IP address to the CP 443-1 Advanced Advanced

Step Tasks Result

1 Click “Search...” on the “Assign Ethernet
Address” screen form.

The “Scan network” dialog box
opens

2 From the list of Ethernet nodes found, select the
line containing the station type “S7-400 CP”, then
click “OK.”

This closes the “Scan network”
screen form and enters the MAC
address of the CP 443-1 at the
previous “Assign Ethernet
Address” screen form.

3 Enter the same IP address in the “IP Address”
box of the “Assign Ethernet Address” screen
form, and the same subnet mask in the
“Subnet Mask” box you assigned in HW Config to
CP 443-1 Advanced Advanced. 
Click “Assign IP Configuration.”

A window opens with this text:
“The parameter was successfully
transferred.”

4 Click “OK” on the message window. This closes the message window.

5 Next, click “Close.” This closes the “Assign Ethernet
Address” window
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Downloading HW Config to the S7-400

Step Tasks Result

1 Select the S7-400 in SIMATIC Manager

2 Select PLC > Download. Confirm all windows
with Yes.

You could also stay in offline with your PG, and
first write the hardware configuration to the Flash
Card. Insert the Flash Card into the CPU if this is
the case.

The PG downloads the
configuration to the CPU.

3 Set the mode selector switches of the CPU,
CP and IE/PB-Link to RUN.

The STOP LED is switched off.
The RUN LED starts to flash and
then assumes a continuous
signal. When a physical
connection to the Ethernet is
established, the LINK LED is lit
on the CP 443-1 Advanced. The
RX/TX LED flashes or is lit
permanently when data are
transferred via Ethernet.

Result

You installed a CP 443-1 Advanced Advanced in an S7-400, and interconnected an
ET 200B with the PROFINET interface of the CP by means of IE/PB-Link.

� The CPU of the S7-400 PLC can now access the process data of the ET200 via
PROFINET.

� Other nodes on the Ethernet subnet can now access the S7-400 PLC by means
of the CP 443-1 Advanced.

� You can now also configure / reconfigure data using any port of the Ethernet
interface of the CP.

Further Information

For detailed information on address assignment to the PROFINET interface of the
CP or IE/PB-Link, refer to the HW Config Online Help for IE/PB-Link or CP 443-1
Advanced Advanced.

Diagnostics / Troubleshooting

Wrong operation, faulty wiring or a faulty hardware configuration may cause errors
which the CPU, CP or IE/PB-Link indicate with the SF group error LED after a CPU
memory reset.

For information on the analysis of such errors and alarms, refer to the CPU,
CP 343-1 Advanced, IE/PB-Link or ET 200B operating instructions.
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Manuals containing further information

� Getting Started: Getting Started and Exercises with STEP 7 V5.3.

� Manual: SIMATIC NET: Twisted Pair and Fiber Optic Networks

� Manual: Communication with SIMATIC

� Manual: S7-CPs for Industrial Ethernet (contains CP 443-1 Advanced, 
IE/PB-Link)

� Manual: ET 200B Distributed I/O Station

Service & Support on the Internet

In addition to our documentation, we offer a comprehensive online knowledge base
on the Internet at: http://www.siemens.com/automation/service&support

There you can find:

� The Newsletter containing the latest information on your products.

� The documents you need using our Service & Support search engine.

� A bulletin board where users and specialists exchange experiences worldwide

� Your local contact partner for Automation & Drives

� Database

� Information about on-site services, repairs and spare parts. Lots more is
available on the “Services” page.

http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo2&siteid=cseus&lang=en
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