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Introduction

The SIMATIC C7-621-AS-i control system gives you a variety of options for clearly structured, convenient
automation, operation and monitoring of your process. The integrated AS-Interface allows high-powered
automation solutions at the process level.

This brochure shows you how easily and quickly you can solve your tasks with the C7-621-AS-i, the
programming software STEP 7 or STEP 7-Mini*) and the configuring software ProTool or ProTool/Lite**)

under Windows 95. We take a sample assignment from real life and show you how to solve it step by
step .

In self-contained chapters, we explain the essential functions of the SIMATIC C7-621-AS-i, typical tasks
on a sample system, and further tips and tricks.

All chapters are structured as follows:

� First the task is explained.
� Then the individual solution steps are described, with the help of selected dialog boxes.
� Finally, we show you the result so that you can check your own result immediately after each

programming/configuring step.

Conventions:

� A mouse indicates that entries are to be made on the PC/programming device.

� This hand indicates that you are to make entries/perform operations on the C7-621-
AS-i control system.

� A hand pointing upward indicates that you must work with AS-i slaves.

system_1.pdb Texts to be configured, program parts to be programmed, or entries to be selected
from existing possibilities appear in Courier .

File → New Menus, menu items, dialog boxes or texts in dialog boxes that you select are written in
italics.

*)
referred to simply as STEP 7 below

**)
referred to simply as ProTool below
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Hardware configuration

Checklist of the required components

Component Order no. Included in starter kit

1 PC or programming device no

2 Programming software STEP 7-Mini 6ES7 810-3CC04-0YX0 yes

3 Configuring software ProTool/Lite 6AV6 580-3BX05-1AX0 yes

4 SIMATIC documentation on CD-ROM (in 5
languages)

6ES7 398-8AE00-8YE0 yes

5 PC/MPI adapter
RS232 cable

6ES7 972-0CA22-0XA0
6ES7 901-1BF00 0XA0

yes
yes

6 SIMATIC C7-621-AS-i control system 6ES7 621-6BD00-0AE3 yes

7 +24V power supply PS307 6ES7 307-1BA00-0AA0 no

8 AS-Interface power pack and AS-i cable 3RX9307-0AA00 yes

9 2 x connecting cable with M-12 socket and
connector

3RX1634 yes

10 Position switch with AS-i connection 3SE3230-1GW-Z (Z=C01) yes

11 Inductive proximity switch 3RG4022-3JB00 yes

12 Optical proximity switch 3RG7130-3AB00 yes

13 SIGNUM casing with AS-Interface 3SB803-4AZ yes

14 AS-Interface user module 3RK1400-1DQ00-0AA3 yes

15 AS-Interface connection module 3RK1901-0CA00 yes
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Checklist for startup

The following basic steps are necessary for starting up the SIMATIC C7-621-AS-i:

� Install STEP 7 or STEP 7-Mini on PC/programming device
� Install ProTool or ProTool/Lite integrated under STEP 7 or STEP 7-Mini on PC/programming device
� Connect C7 to power supply (+24V)
� Connect power pack to C7-AS-i port
� Set up AS-i network
� Set addresses of slaves and parameterize C7-AS-i-CP
� Select STEP 7-Mini on programming device/PC and create PLC program
� Connect C7 ↔ PC/programming device via PC/MPI cable
� Overall reset of C7-CPU and C7-OP
� Transfer PLC program to C7
� Select ProTool/Lite on programming device/PC and create OP configuration
� Transfer configuration to C7
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Sample Project: Sorting System

AS-Interface is often used where sensors and actuators are distributed over a fairly large system. The
sample system we have chosen shows a sorting and packing department in a large mail-order company.
Parcels containing mail-order goods are transported to the relevant ejectors on conveyor belts. The
current location of the parcels is recorded via sensors and transmitted to the SIMATIC via AS-i. The PLC
processes this data and controls connected actuators via the AS-Interface. On the basis of the sample
machine, you will learn how to handle the AS-i functions step by step. You will set up an AS-i network,
program a PLC program and learn how to establish the link with the integrated C7 operator panel.
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Setup and Configuration of the AS-i Network

Before you actually program your automation solution, you must set up your system and connect and
parameterize the AS-i components involved.

The yellow AS-i shaped cable enables fast and easy installation of your slaves in the AS-i network. This
cable is the transmission medium for communication between the master and the stations. It also carries
the supply voltage for the stations. A slave is identified by its address, which is always stored in non-
volatile memory in the slave.

On delivery, all slaves have the address “zero” by default. Each slave in the network must have a unique
address that is not “zero”.

The C7-621-AS-i allows you to change the set address of a slave through operation on the C7. When
using the C7 addressing function, it is therefore necessary to connect all new slaves to the AS-i cable
consecutively to ensure that they are each assigned a unique address.

� Set up your AS-i network according to the diagram above. Connect your slave 1 to your yellow AS-i
shaped cable. If you have problems connecting the slaves to the AS-i cable, please read the setup
instructions supplied with the AS-i components.

Slave 1
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AS-I power
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� The C7-CPU must be in STOP mode for you to be able to configure your AS-i network.

� On the C7-621-AS-i control system, select the System Functions menu by pressing the
SH IFT 0

keys.

� Press
F1

to select the C7 System Functions menu.

� Press
F3

to select the operating mode STOP. The STOP LED lights up.

� If a password has not yet been entered, the system requests one. When the C7 is shipped, the
password is preset to 100. Enter the digits 100 via the numeric keypad and confirm your input with
ENTER. Select the operating mode STOP.

� To quit the mask, press the
ESC

key once.

� Now press the
F5

key to display the start menu for the individual AS-i functions.

Status Project
Version

� In the start menu for the AS-i functions, select Project by pressing
F4

once.

AUTOPROG Config
Address

� For setting addresses, the mode set for the device must be the configuring mode. When the C7 is
shipped, this mode is preset by default.

� To check whether the device is in the configuring mode, select Config with the
F4

key.

Note:
If the following mask appears, you can skip the next two steps.
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Conf.Mode: Enabled
Disable setconf

� You must switch from protected mode to configuring mode. To do this, press
F2

.

� Wait a moment, then press
F5

. If the above mask appears, you may proceed. Otherwise, repeat
the last two steps.

� Quit the mask by pressing the
ESC

key once.

� In the Project menu, select the menu item Address by pressing the
F3

key. Enter the old address
in the first field, and the new address in the second field.

Old: 00 New: 01
Set Adr.

� Press
F4

to confirm your entry.

� If you have made all the entries and settings correctly, the message NO_ERROR will appear in the
display of the C7-621-AS-i control system.

� Press
F5

to complete the current addressing process.

� Connect the next slave to your AS-i shaped cable according to the setup diagram.

� Repeat your entries in the Address menu for all slaves used in the application.

� Once you have addressed all the slaves, quit the Address menu by pressing the
ESC

key twice.
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� In the menu that now appears, press
F2

to select the Status menu.

� Press
F2

again to see the status display of the existing and activated slaves.

� If you have set up your AS-i network as described, the screen will look like this.

----- ----- -----
----- ----- ----- --

� If the display is different from your configuration, please check your settings against the descriptions
in the system manual.

� Quit the status display by pressing the
ESC

key twice.

� Select the Config menu by pressing
F4

twice.

� Accept the actual configuration recognized by the system as the setpoint configuration. To do this,

press
F4

again to call the menu for setting the setpoint configuration.

� If you wish you can view the actual configuration again by pressing
F2

. To close the display, press

ESC
.

� Press
F4

to accept the current actual configuration as the setpoint configuration.

� Press
F5

to confirm the NO_ERROR message.

� Finally, switch your C7 control system from configuring mode to protected mode. To do this, press

F4
to select the Config menu again. Press

F2
to switch to protected mode. Confirm your input

with
F5

.

Once the last step is complete, you have set up and configured your first AS-i network. You are now
ready to program your control task.
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Programming Preparations

Starting STEP 7

� Once STEP 7 has been installed, the “SIMATIC Manager” icon appears on the Windows 95 desktop
and the “SIMATIC” program group appears in the Start menu. As with all other Windows 95 appli-
cations, you start the program by double-clicking on the SIMATIC Manager icon or by selecting the
Start menu → SIMATIC → STEP 7 → SIMATIC_Manager.

� Once STEP 7 is started, terminate the STEP 7 Assistant: New Project .

Online Help

If there is anything you are unsure of during programming, or if you want further information on specific
points, press F1. This starts the Online Help, in which you will find explanations of the various STEP 7
topics.

General settings

Before you start programming, you need to select one of two mnemonic options in the SIMATIC Manager
for displaying program statements.

� You will find the Language catalog under Options → Customize. Select English as the language and
International mnemonics.

� Select OK to close the dialog box and save the settings.
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� You also have to set the PC/programming device interface. To do this, select the menu item Options
→ Set PG/PC-Interface... Set the PC Adapter(MPI) in the dialog box that appears.

If the PC Adapter is not displayed in the window, you can install it now. Activate the Install button and
follow the instructions.

� Enter the following settings as the PC/programming device interface Properties:
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� For the local connection, select the COM port to which you connected the PC/MPI cable.

� Save the settings with OK.

You can now start to create your project.

Creating a project

� Select the menu item File → New. In the dialog box that appears, create a new project with the name
GetStart .

� Assign a hardware item to your project with the menu item Insert → Station → 2 SIMATIC 300
Station. The SIMATIC 300 Station(1) folder appears. Overwrite the name of this station with the new
name Systen_1 .
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Defining the hardware

� Open the station system_1 by double-clicking on it. Select the Hardware folder and open it, again
with a double click.

� In the Hardware Configuration window go to the Hardware Catalog via Insert → Hardware Compo-
nents. Mark here the C7-621 AS-i via SIMATIC 300 → C7 to display brief information on the control
station.

� Double-click on C7-621 AS-i to insert the device into slot 2 in the Hardware Configuration window.

Here you will see information on the set MPI address of the C7-CPU (default setting for the MPI
address is 2) and an address map.

� To save the configuration, select Station → Save and Compile from the menu bar.



04/99 Programming Preparations

Getting Started with C7-621-AS-i 17

Setting up a bit memory address area for clock memories

Clock memories are bit memories which periodically modify their binary value (pulse-pause ratio: 1:1).
You need these memories in the following programming example.

To enable you to set up the clock memory, you must make the following settings.

� In the Hardware Configuration window open the dialog window Properties - C7-CPU621 by double-
clicking on the C7-CPU-621 icon.

� In the dialog window displayed, click on the tab sheet Cycle / Clock Memory to select it.

� Activate the Clock Memory checkbox and enter 10 for the number of the memory byte.
Each bit of the clock memory byte is assigned a period time/frequency:

Bit 7 6 5 4 3 2 1 0

Period time (s) 2 1,6 1 0,8 0,5 0,4 0,2 0,1

Frequency (Hz) 0,5 0,625 1 1,25 2 2,5 5 10

� Confirm your entries with OK. To save the configuration, select Station → Save and Compile from the
menu bar.

� To close the Hardware Configuration window select Station → Exit from the menu bar.

In the SIMATIC_Manager the folder C7 CPU621 containing the S7 program is created automatically. This
S7 Program folder in turn contains the folder Blocks with an empty organization block OB1.

� Open each folder with a double click.



Programming Preparations 04/99

18 Getting Started with C7-621-AS-i

Setting the address areas and accessing the AS-i user data

In standard operation, the AS-i communications processor behaves like an I/O module. It occupies
16 input and 16 output bytes in the analog area of the controller. Each slave on the AS-i cable is assigned
four bits (a nibble) by the C7-AS-i-CP. The C7-CPU can access a nibble for reading and writing. The start
address of this address area is fixed at 256 in the C7-AS-i. For the assignment of the slave I/O bits to the
I/O bytes of the C7-CPU, see the AS-i interface table.

Assignment table

I/O-byte number Bit 7-4 Bit 3-0 I/O byte number Bit 7-4 Bit 3-0
256 reserved Slave 1 264 Slave 16 Slave 17
257 Slave 2 Slave 3 265 Slave 18 Slave 19
258 Slave 4 Slave 5 266 Slave 20 Slave 21
259 Slave 6 Slave 7 267 Slave 22 Slave 23
260 Slave 8 Slave 9 268 Slave 24 Slave 25
261 Slave 10 Slave 11 269 Slave 26 Slave 27
262 Slave 12 Slave 13 270 Slave 28 Slave 29
263 Slave 14 Slave 15 271 Slave 30 Slave 31

Bit 3 I Bit 2 I Bit 1 i Bit 0 Bit 3 I Bit 2 I Bit 1 i Bit 0 Bit 3 I Bit 2 I Bit 1 i Bit 0 Bit 3 I Bit 2 I Bit 1 IBit 0

The parameters required in the application appear on a gray background.

The diagram below illustrates the access to the input and output data of the individual slaves.

Because the bits of the AS-i line can only be accessed in word mode or doubleword mode, it is necessary
to set up a memory data block. In the data block the AS-i data can be accessed in bit mode.

Transfer the image of the AS-i
input data to a data block.

Evaluate individual bits and
perform, e.g., logic operations,
setting and resetting, arithmetic
operations and counting.

Copy the output data of the data
block to the AS-i output data.

Cycle

Start of program

Program

End of program
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� Select the Blocks folder in the SIMATIC Manager and insert a data block with Insert → S7 Block → 4
Data Block. In the dialog box that appears, assign the internal identifier DB1.

� Open data block DB1 and select Data Block as the desired type. Accept the settings with OK.

� Select the second entry in the Name column and enter here the name M1_In1 .

Complete your input by pressing Return.

� The Type entry is automatically activated. Click on the entry with the right mouse button, enter the
type BOOL via Elementary Types, and complete your input with Return.

� Enter FALSE as the initial value and press Return.

� In the Comment column you can add a comment to the entry Module_no.1 Input_1.

� Repeat your entries for all slaves.
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� Save your data block DB1 by clicking on the icon in the toolbar.

In the application the following addresses in DB1 are significant:

Adress Symbol Status format Meaning

0.0 M1_IN1 Bin Optical Bero

0.1 M1_IN2 Bin Inductive Bero

1.0 M3_IN1 Bin Position switch

2.0 M5_IN2 Bin ON button

2.1 M5_IN3 Bin Acknowledgment button

2.3 M5_IN1 Bin OFF button

4.0 M1_OUT1 Bin Belt ON (bit memory)

6.0 M5_OUT1 Bin Green lamp

6.1 M5_OUT2 Bin Red lamp

6.2 M5_OUT3 Bin White lamp
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Program Generation

Once you have set up your AS-i network and preset all the necessary values in STEP 7, you can now
program your control task. We will restrict this to configuring the eject process of the sorting system.

Program the belt control according to the following specifications:

� The belt is activated via the start switch (DB1.DBX2.0) on the SIGNUM control unit.
� The belt is deactivated via the ON/OFF switch (DB1.DBX2.3) on the SIGNUM control unit.
� The system must have a defined initial position.

- no parcel in the field of vision of the optical sensor
- no parcel at the end of the belt (position switch inactive)
- ejector in initial position (checked by the inductive proximity switch).

� If the initial position is defined, the belt is activated. The movement of the belt is simulated by the LED
of the output 1 of slave 1 (DB1.DBX4.0). The display is only possible if auxiliary power for the outputs
is supplied to the AS-Interface user module. Otherwise, DB1.DBX4.0 has the function of a bit memory.

� Display of the operating modes
- When the belt is activated, the green lamp on the AS-i casing is illuminated (DB1.DBX6.0).

Inserting a block

� In the SIMATIC Manager select the Blocks folder and insert a new function via Insert � S7 Block � 3
Function. In the dialog box which appears, assign the internal ID FC1. Select STL as the generation
language and close the dialog box with OK.

DB1.DBX0.0

DB1.DBX1.0

DB1.DBX0.1
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Editing a block

� Now open the LAD/STL/FBD editor by double-clicking on the newly created Function FC1 in the
SIMATIC MANAGER.

� Click on Title next to the block number FC1 and assign the block name Belt control.

� Now give the first network the name Initial position. To do this, click on the entry Title next to
the network number.

� Click in the gray field below the line Network 1: to activate it. Enter a network comment in this field:
There must be no parcel on the belt.

� Below the network comment you can now insert your program lines. To do this, click in the white area
below the gray comment field. This opens a box with the current cursor position. When making your
entry, make sure you include the relevant blanks (at least one blank each as a separator between
operation code, operand and comment) in each program line, otherwise STEP 7 will not recognize the
instruction and will signal this in red italics. Insert the following in the first network:

FC1: Belt control

Network 1 : Initial position

AN DB1.DBX0.0 // Opto_Bero : no parcel
AN DB1.DBX1.0 // Position switch: no parcel
A DB1.DBX0.1 // Ejector in initial position
= M 15.0 // Initial position

� To insert a new network, click on in the toolbar. In this network, program the operating status of
your system.
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Network 2 : Belt ON

A DB1.DBX2.0 // Belt_ON button on casing
A M 15.0 // Initial position
S DB1.DBX4.0 // Conveyor belt ON

Network 3 : Belt OFF

A DB1.DBX2.3 // Belt_OFF button on casing
R DB1.DBX4.0 // Output Belt_ON

Network 4 : Operating mode display

A DB1.DBX4.0 // Belt ON
= DB1.DBX6.0 // Green lamp on casing
= M 21.0 // Message flag (required later)

Saving a block

� You have now fully programmed your belt control. Save your function FC1 by clicking on the icon
in the toolbar.

� For an executable program you must still write the AS-i input data to DB1 at the start of the cycle and
the outputs from DB1 to the AS-i output data at the end of the cycle. To do this, open OB1 in the
SIMATIC Manager and insert the following networks and program lines.

Network 1 : Route process image of AS-i line to DB

OPN DB1
L PIW 256
T DBW 0
L PIW 258
T DBW 2

Network 2 : Call system component belt

CALL FC 1 // Belt control

Network 3 : Write outputs
L DBW 4
T PQW 256
L DBW 6
T PQW 258
BE

� Now save your OB1 by clicking on the icon in the toolbar.

Setting the operating mode

���� Select the System Function menu by pressing
SH IFT 0

on the C7-621-AS-i.

� Select the C7 System Functions menu by pressing
F1

.
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� Select the operating mode STOP by pressing
F3

. The STOP LED lights up.

� If a password has not yet been entered, the system requests one. When the C7 is shipped, the
password is preset to 100. Enter the digits 100 via the numeric keypad and confirm your input with
ENTER. Select the operating mode STOP again.

Deleting the C7-CPU memory / Overall reset of C7-OP

Before you load a project into the CPU for the first time, you must make sure the C7-621-AS-i is in a
neutral state. To do this, you must delete both integrated C7 flash memories and then restart the C7-621-
AS-i. To delete the C7 flash memories, proceed as follows:

Deleting C7-CPU memory:

� In the SIMATIC Manager select the Accessible Nodes icon . In the window which appears,
open the folders MPI=2 and Blocks by double-clicking on them.

� Mark all OBs, FBs, FCs and DBs. Delete the marked objects from the C7-CPU. You have now
deleted the load memory of the C7-CPU.

� Mark the folder MPI=2 and copy the contents of the load memory into the C7-CPU flash memory via
PLC → Save RAM to ROM. You have now deleted the integrated CPU flash memory.

� Close the Accessible Nodes window.

Overall reset of C7-OP:

� Switch off the power supply of the C7-621-AS-i.

� Now press the
ESC

and and keys simultaneously,
� keep these keys depressed,
� and switch on the power supply.

Do not release the keys until the message “Flash Test“ appears in the display. After the startup tests, the
idle message is displayed and the overall reset of the C7-OP too is complete.
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Loading blocks

You have two options for loading blocks into the CPU. Loading individual blocks is recommended for
large projects if changes were only made in individual blocks which can be clearly identified. Loading all
blocks is recommended for smaller projects or if many changes were made in various blocks.

1st option: Loading all blocks

� In the SIMATIC Manager select the Blocks folder and click once on the icon in the toolbar.

2nd option: Loading individual blocks

� In the SIMATIC Manager select the function FC1 and load this block into the CPU of the

SIMATIC C7-621-AS-i by clicking once on the icon in the toolbar.
Then load the organization block OB1 into the CPU in the same way.

���� Select the System Functions menu by pressing
SH IFT 0

on the C7 621-AS-i.

� Press
F1

to select the C7 System Functions menu.

� Press
F1

to select the operating mode RUNP. The RUN LED lights up.

� If a password has not yet been entered, the system requests one. When the C7 is shipped, the
password is preset to 100. Enter the digits 100 via the numeric keypad and confirm your input with
ENTER. Select the operating mode RUNP again.

Test your program on the C7-621-AS-i control system using your AS-i components. The functions of the
system, as specified in the first programming step, should be set up.

Program extension

Now you are going to extend your system. The system is to work as follows:

� The number of parcels is counted if
- Parcel at end of belt (position switch active)
- Ejector in initial position (inductive proximity switch)

� The maximum number of parcels to be ejected is predefined (default:10). The count process then
starts from the beginning.

� The minimum interval between parcels is monitored via Opto-Bero. A parcel can appear in the field of
vision every 10 seconds at the most. Whenever the Bero detects a parcel, a white lamp on the casing
illuminates. (DB1.DBX6.2).

� A parcel at the end of the belt must be removed by the ejector (ejected) within 3 seconds.
� If one or more of the requirements are not met, this constitutes a fault and the belt stops. The fault is

indicated by a flashing red lamp (DB1.DBX6.1) on the casing.
� The fault must be acknowledged via the acknowledgment button on the casing (DB1.DBX2.1).
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� In the SIMATIC Manager go to your offline project and insert another function in the Blocks
folder. Give it the internal ID FC2, select STL again as the generation language, and open the block.

� Insert the following program lines in the individual networks:

FC2 : Eject conditions

Network 1 : Count

A DB1.DBX1.0 // Position switch
A DB1.DBX4.0 // Belt ON
A DB1.DBX0.1 // Inductive Bero
FP M30.0 // Rising edge
CV C1 // Count forward
L C1 // Transfer count to MW 22
T MW22
AN C1 // Count = 0
A DB1.DBX4.0 // Belt ON
L C#0 // Write preset count
S C1 // Initialize counter
L MW22 // If the value in MW 22 is greater than
L 10 // the maximum value set, the counter
>I
R C1 // is reset

Network 2 : Parcel sequence

A DB1.DBX4.0 // Belt_ON
A DB1.DBX0.0 // Opto_Bero: parcel
FN M30.1 // Edge formation
L S5T#10S // Parcel interval at least 10 seconds
SE T5 // Pulse extension
A T5 // Parcel interval too small
A DB1.DBX0.0 // Opto_Bero: parcel
FP M30.2 // Edge formation
S M21.1 // Fault in parcel sequence

Network 3 : Display: parcel detected

A DB1.DBX4.0 // Belt ON
A DB1.DBX0.0 // Opto_Bero
= DB1.DBX6.2 // Lamp: parcel detected
= M21.3 // Message flag (required later)

Network 4 : Stop-monitoring

A DB1.DBX4.0 // Belt_ON
A DB1.DBX1.0 // Parcel at end of belt
L S5T#5S // Monitoring time 5 seconds
SD T3 // ON delay
A T3
S M21.2 // Fault in parcel stop

Network 5 : Faults

O M21.1 // Fault_parcel sequence
O M21.2 // Fault_parcel stop
= M16.0 // Fault
A M16.0 // Fault
A M10.4 // Flashing frequency
= DB1.DBX6.1 // Red lamp on casing

A DB1.DBX2.1 // Acknowledgment button
R M21.1 // Fault_parcel sequence
R M21.2 // Fault_parcel stop
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� Programming of the FC2 is now complete. The module can be saved and transferred to the CPU.

� Now you must also consider the possible faults in your belt control. In the SIMATIC Manager open the
FC1. Insert the program line AN M16.0 in Network 1. The complete network then looks like this:

Network 1 : Initial position

AN DB1.DBX0.0 // Opto_Bero: no parcel
AN DB1.DBX1.0 // Position switch: no parcel
A DB1.DBX0.1 // Ejector in initial position
AN M16.0 // No fault
= M15.0 // Initial position

� In Network 3 insert the program line O M16.0 so that the conveyor belt will be deactivated if a fault
occurs.

Network 3 : Belt OFF

A DB1.DBX2.3 // Belt_OFF switch on casing
O M16.0 // Belt OFF
R DB1.DBX4.0 // Output Belt_ON

� Save the function FC1 and overwrite the block in the CPU by reloading.

� Finally, the organization block OB1 must be adjusted. In the SIMATIC Manager open the OB1, insert
a network and call the function FC2.

Network 3 : FC 2 call

Call FC2

� Save the OB1 and overwrite it in the CPU by reloading.

To save the PLC program in the C7-CPU so that it is powerfail-proof, you must transfer it to the C7-CPU
flash memory. How to do this is described in the following section.
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Saving RAM to ROM

Because the PLC program, when loaded into the C7-CPU, is only transferred into the unbuffered load
memory and not automatically also into the C7-CPU flash memory, the program would be lost when the
C7-621-AS-i was restarted. To prevent this, you must copy the PLC program into the flash memory
explicitly. Proceed as follows:

� Call up the System Functions menu by pressing the
SH IFT 0

keys on the C7-621-AS-i.

� Press
F1

to call the C7 System Functions menu.

� Press
F3

to select the operating mode STOP. The STOP LED lights up.

� If a password has not yet been entered, the system requests one. When the C7 is shipped, the
password is preset to 100. Enter the digits 100 via the numeric keypad and confirm your input with
ENTER. Select the operating mode STOP again.

� In the SIMATIC Manager select the Accessible Nodes symbol again. In the dialog window
displayed, mark the folder MPI=2. Copy the contents of the load memory into the C7-CPU flash
memory via the menu item PLC → Save RAM to ROM. The PLC program is now stored in non-
volatile memory in the C7-CPU.

� Close the Accessible Nodes window.

� On the C7 621-AS-i, press
F1

to change back to the operating mode RUNP. The RUN LED lights
up.

You have completed your first programming task in STEP 7. You can now test the functionality of your
sorting system. We will test the programmed count function.

� To control the function of the counter, click on in the toolbar of the SIMATIC Manager to go to
the online data management. Open the Function FC2 and select the first network. Then in the menu
bar, go into test mode via Debug → Monitor.

Network 1 : Count

A DB1.DBX1.0
A DB1.DBX0.1
A DB1.DBX4.0
FP M30.0
CV C1
L C1
T MW22
AN C1
A DB1.DBX4.0
L C#0
S C1
L MW22
L 10
>I
R C1

� Close the LAD/STL/FBD editor and in the SIMATIC Manager your GetStart online project.

� Open the GetStart folder.
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Preparations for OP Configuration

Starting ProTool, creating the configuration

There are two ways to create an OP configuration. You can create a new (empty) configuration and
configure all the necessary system functions (e.g. change of operating mode, assignment of passwords
etc.) yourself, or you can use a standard configuration delivered with ProTool as the basis for your
configuration.

To make things easier for you during your first configuration, we advise you to take the second option of
starting with a supplied standard configuration. The standard configuration contains basic settings, e.g.
Device: C7−621 , Language: English , and standard screens for easy access to frequently used
functions, e.g. change of operating mode, assignment of passwords.

Creating a new configuration :

� In the SIMATIC Manager select Insert → Station → 8 SIMATIC OP and name the new OP station
OP_System_1 .

� Open the station (e.g. by double-clicking). ProTool/Lite and the Projekt Wizard are started
automatically.

� Select the C7-621 from the C7 Devices and confirm with Weiter >.

� Define a name for the PLC which you use to reference it in the configuration: System_1 .
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� To check and, if necessary, correct the PLC parameters, display the dialog box with the PLC para-
meters from the Driver window by activating the Parameters button (see dialog box directly below).

� When you have entered all the settings, close the dialog box by activating the button OK. In the
Projekt Wizard confirm this step with Weiter >.

� Select Use Standard Projects and close the Project Wizard with Fertig stellen to create the Project
OP_System_1 in ProTool.

Online Help

If there is anything you are unsure of during configuration, or if you want further information on specific
points, press F1. This starts the Online Help, in which you will find explanations of the various ProTool
topics.
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Displaying and Entering Values in Screens

You can start by configuring your first screen.

� Open the Screen Editor with the menu item Insert → Screen. This action calls up the Screen-PIC_6.

Configuring texts

The first screen is to be the start screen on the C7. It will display only the system name.

The system name is configured as the text.

� The cursor is located in the first line of the first screen entry (see above). Enter the system name
there: System_1 .

SIMATIC C7 startup always ends automatically with a display of the configured start screen. The screen
you have just configured (display of the text: System_1) is now to be displayed after the next loading of
the configuration. You must therefore mark this screen as the start screen.

� Select the menu item Edit → Properties. In the PIC_6 dialog box, select Start Screen. Do not change
the other settings.

� You can also define a new name for the screen: Start_Sys1 .

� Close the dialog box with OK.

You have now created the first screen. Now, transfer the configuration to the OP to see what the screen
looks like.

(1st screen entry, 1st line)
(1st screen entry, 2nd line)

(2nd screen entry, 1st line)
(2nd screen entry, 2nd
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Transferring the configured data

Before the actual transfer, you must perform three steps:

• Save

• Generate the project

• Define the transfer parameters (once only).

� To save the project, select File → Save in the menu bar.

� Then in the menu bar select File → Generate to generate from the configuration file a file that can be
executed on the OP. During the generation process, a status window opens which displays any rele-
vant notes, warnings or errors in the configuration.

� Finally, set the parameters for the transfer.
In the menu bar, select File → Settings → Download. The following dialog box is displayed:

In the dialog box, specify the OP address (default = 1).

Note
The transfer parameters retain this value; they do not need to be reset before each transfer.

�Then put the C7-621 into transfer mode with an overall reset:
� Switch off the power supply of the C7-621.

� Then press the
ESC

and and keys simultaneously,
� keep these keys depressed,
� and switch on the power supply.

Do not release the keys until the message “Flash Test“ appears in the display. After the startup tests, the
idle message is displayed and the overall reset of the C7-OP too is complete.

� Once the C7 has been started, select the system screens stored in the firmware with the ENTER

key. Press
F4

to select System and
F2

to select OpMode. Press
SH IFT

and
simultaneously to switch to MPI down and confirm your entries with ENTER. The message Ready for
transfer appears on the C7-OP.

� If a password has not yet been entered, the system requests one. Enter the digits 100 again via the
numeric keypad and confirm your input with ENTER. Select the operating mode MPI down again and
confirm with ENTER.

� Now select File → Download in the menu bar to initiate the data transfer from the PC/programming
device to the C7.
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Once the transfer is complete, the C7 starts up. Press the ENTER key. If the start screen appears on the
C7, the transfer was successful.

F1 F2 F3 F4 F5

SF DC5V

FRCE

RUN

STOP

1 2 3

7 8 96

4 5

0

SIMATIC C7-621

ENTER

ESC

SH IFT

+/-

System_1

If the transfer was not successful, repeat the steps beginning on page 33.

Extending the configuration

Now that you are an “experienced” ProTool user, you can extend your configuration by another screen.

� Open a new Screen with the menu item Insert → Screen.

� Now select Edit → Properties and change the screen name: Parcels_1 .

In this screen, enter the number of parcels to be transported. At the same time you want to display the
current counter status.

This is implemented as follows:

� The maximum number of parcels is entered via an input field .

� The number of currently counted parcels is displayed as the output field .

Configuring texts

So that you can distinguish the input field from the output field, configure a text in front of each field.

� Select the first line of the first screen entry with the cursor and enter the text: Max.number: . Then
position the cursor in the first line of the second screen entry and configure the text: Curr.number:

Then define the fields for the input and output.
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Configuring the input field

� Use the cursor to select the first line of the first screen entry. Using the cursor control keys, position
the cursor behind the text Filling time. Activate the menu item Insert → Input/Output Field or press

the button in the function bar. The Input/Output field dialog box appears.

� Set the Field Type: Input and specify a Field Length of 4. Do not change the settings Usage: Tag
or Display: Decimal .

� To establish the link between the field and the PLC, create a new variable with the button .

� Give this variable the name Parcel by overwriting the preset variable name. Then make the
following entries: Type: WORD, address DB: 46 , DBW: 0.

� Click the OK button to close the Tag and Input/Output field dialog boxes. You have now defined the
input field. The variable is identified by {Parcel } in the Screen Editor.

� Position the cursor between the text Max.number: and the input field {Parcel }. Now enter blanks
to make full use of the line. But make sure you do not exceed the maximum of 20 characters per line.
11 characters of text plus 4 characters of field length therefore mean a maximum of 5 blanks.
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Configuring the output field

� Position the cursor in the first line of the second screen entry after the configured text
Curr.number: . In the menu bar, select Insert → Input/Output Field.

� In the Input / Output dialog box, set the field type to Output and the field length to 4.

� Now click the button . The Tag dialog box is displayed. Enter Number as the variable name,
WORDas the type, and DB46 and DBW 2as the interface range. Save your entries with OK.

� Position the cursor between the text Curr.number: and the output field {Number}. Now enter
blanks to make full use of the line. But make sure you do not exceed the maximum of 20 characters
per line. 11 characters of text plus 4 characters of field length therefore mean a maximum of 5
blanks.

Adjusting the control program

To allow the exchange of data between the C7 PLC and C7-OP you must still adjust your previous control
program and reload it.

� In the PLC create the data block DB46. The length of the DB46 must be at least three data words. In
the SIMATIC Manager select the Blocks folder and insert a data block via Insert → S7 Block → 4
Data Block. In the dialog box which appears, assign the internal ID DB46.

� Open the data block DB46 and select Data Block as the desired type. Confirm the settings with OK.

� In the DB Editor, activate the second entry with the mouse in the Name column. Assign here the
name max.parcels for the DW0 and complete your entry with Return.

� This automatically activates the entry Type. Click on the entry with the right mouse button, insert the
type WORD via Elementary Types, and complete your entry with Return again.

� As the default for the highest count, enter W#16#0005.

� In the Comment column you can enter a comment for the data word. Complete your entry with
Return.
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� The editor automatically inserts a new line, in which you enter the next data block word. This data
word 2 is to have the name number_parcels , the type WORD, and the initial value W#16#0.

� Create the data word 4 with the name messages , the type WORD and the initial value W#16#0. This
data word is required for the event messages to be configured and is explained later in more detail.

� You have now created the data block DB46. Save it and load it into the C7-621-AS-i control system.

� Now you must still modify the function FC2. Open the FC2 in the SIMATIC Manager and in the first
network overwrite the load instruction of the counter with L DB46.DBW0. Then transfer the count to
the second data word of the data block DB46 instead of to the MW22.

Network 1 : Count

A DB1.DBX1.0 // Position switch
A DB1.DBX4.0 // Belt ON
A DB1.DBX0.1 // Inductive Bero
FP M30.0 // Rising edge
CV C1 // Count forward
L C1 // Transfer count to Db46.DBW2
T DB46.DBW2
AN C1 // Count = 0
A DB1.DBX4.0 // Belt ON
L C#0 // Write preset count
S C1 // Initialize counter
L DB46.DW2 // If the value in DB46.DW2 is greater than
L DB46.DW0 // the maximum value set, the counter is
>I
R C1 // reset

� Save the block and load it into the CPU again. Via the menu item Accessible Nodes activate the
function Save RAM to ROM, so that the current program is also stored in the flash memory. Make
sure that the C7-CPU is in the operating mode STOP during this save process. Then select the CPU
mode RUNP again.
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The following diagram shows the connection between the value entered, the control program and the
current number of parcels counted.
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� The values of the input are stored in the data interface (DB46).

� The control program evaluates the current entries and updates the data in the interface for the output.

� The C7-OP independently reads all values from the interface and updates its display.

Linking and branching between screens via softkeys

So that you can also call the second screen on the C7, you must configure the change from the start
screen Start_Sys1 to the system screen Parcels_1 and back with ProTool/Lite. You must also be
able to navigate in the system screen a screen branch from the first screen entry to the second screen
entry and back.

To do this you assign the ‘Select Screen’ function to a softkey in both screens. These softkeys are used
to change the screen. In the system screen you assign the ‘Navigation’ function to a softkey in both
screen entries.

� Open the screen Start_Sys1 and select the Softkey F5. The dialog boxes Softkey-F5 and Select
Object appear.

� In the dialog box Select Objekt choose the function Select Screen from the Screens. A short
description of the function is displayed.
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� Click the button <<Add. The dialog box Parameters - Select Screen appears. In this dialog box,
select the name of the screen you want to call up: Parcel_1 . Do not change the parameters Entry
Number or Field Number.

� Close the dialog boxes Parameters - Select Screen and Softkey F5 by clicking the OK button. A
function is now assigned to the softkey.

The box in the function key is now checked. You can therefore see immediately which function
keys have been configured in the screen.
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Labeling softkey assignment

So that the C7 operator knows which softkey is occupied, you need to define a text for this softkey, which
will be displayed in the relevant screen. Proceed as follows:

� Position the text cursor in the second line of the screen above the softkey you have assigned, by
entering blanks. Enter the text Par there to indicate the association with the softkey.

� To return from the Parcels_1 screen to the start screen Start_Sys1 , proceed in the same way to
configure the softkey F1 in the Parcels_1 screen. Use Start_Sys1 as the screen name and enter
Back as the text for the softkey description.

� For the screen branch, in the first screen entry of the system screen select the softkey F5 and give it
the function Screen Branch. As parameters, assign the entry number 2 and the field number 0.

� In the system screen, label the softkey with the character >>.

� To return from the second screen entry to the first one, proceed in the same way to configure the
softkey F1 in the second screen entry. For the entry number, use 1 and as a character for the softkey
description, enter <<.

All extensions to the configuration are now complete. You have:

- configured a second screen with input and output fields,
- plus in each screen a softkey for switching between the two screens,
- plus in each screen entry a softkey for switching between the entries, and
- a text/character to identify each softkey.

Now you can start to display the configuration on the OP as well as change screens and perform
inputs/outputs.

� Now put the C7-621-AS-i into transfer mode with an overall reset:
� Switch off the power supply of the C7-621-AS-i.

� Press the
ESC

and and keys simultaneously,
� keep these keys depressed,
� and switch on the power supply.
Do not release the keys until the message “Flash Test“ appears in the display. After the startup tests,
the idle message is displayed and the overall reset of the C7-OP too is complete.

� Once the C7 has started up, select the system screens stored in the firmware by pressing ENTER.

Press
F4

to select the System and
F2

to select the OpMode. Switch to MPI down by pressing
the SHIFT and down-arrow keys, and confirm your entries with ENTER. The message ‘Ready for
transfer’ appears on the C7-OP.

� If a password has not yet been entered, the system requests one. Enter 100 again via the numeric
keypad and confirm your input with ENTER. Select MPI down again and confirm with ENTER.

� Now select File → Download from the menu bar to initiate the data transfer from the PC/program-
ming device to the C7. If you have made changes to the configuration, the steps ‘save’ and
‘generate’ are performed automatically after a query. Answer the question as to whether to save,
with Yes.
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� Once the transfer is complete, the C7 starts up. When you press the ENTER key, the start screen is
displayed.
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� Activate the softkey
F5

to reach the system screen.

� Enter a value in the input field.
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Max.number: 8
Back >>

�Activate the softkey
F5

to reach the second screen entry. Now check the functionality of
your inductive proximity switch including the count function.
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Incorporating Standard Screens into the Configuration

At the start of the configuration, you selected the standard screens as the basis for your configuration and
saved the file under the new name System_1 .

You will need the standard screens if you want to use the standard functions of the C7-621-AS-i. These
functions include changing the operating mode, editing the password, logging on and off with the
password, etc.

Now that you have marked the Start_Sys1 screen you configured as the start screen, the standard
screens incorporated in it can no longer be selected on the OP. So that you can use the standard screens
again, define a softkey with which you can select them.

� In the start screen, select the softkey F1 and proceed as described under “Linking and branching
between screens via softkeys” on page 38 . As the screen name, use the name of the standard basic
screen Z_SYSTEM_MEN. As the assignment note, configure the abbreviation Sys at the beginning of
the second line of the start screen.

Now you can transfer the extended configuration to the OP and try it out.

� Put the C7-621-AS-i control system in transfer mode with an overall reset:

Switch off the power supply of the C7-621-AS-i, press the three keys
ESC

and and
simultaneously and, keeping them depressed, switch on the power supply again.

Do not release the keys until the message “Flash Test“ appears in the display. After the startup tests,
the idle message is displayed and the overall reset of the C7-OP too is complete.

� Once the C7 has started up, select the system screens stored in the firmware with the ENTER key.

Press
F4

to select System and
F2

to select OpMode. Press the SHIFT and down-arrow keys
simultaneously to switch to MPI down and confirm your entries with ENTER. The message Ready for
transfer appears on the C7-OP

� If a password has not yet been entered, the system requests one. Enter the digits 100 via the nu-
meric keypad and confirm your input with ENTER. Select MPI down again and confirm with ENTER.

� Now select File → Download in the menu bar to initiate the data transfer from the PC/programming
device to the C7. If you have made changes to the configuration, the steps ‘save’ and ‘generate’ are
performed automatically after a query. Answer the question as to whether to save, with Yes.

Once the transfer is complete, the C7-OP starts up. When you press ENTER, the start screen appears
with the cursor in the first screen entry.

� Now activate the softkey
F1

to reach the standard screens. Select the various screens with which
you can trigger already implemented functions.

� Activate the
ESC

key to quit the standard screens and display your own configuration.
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Configuring Event Messages

In the previous steps you could test the functioning of your system. What you still need is information on
the current operation of your system - the so-called event messages. For example, you want a message
to be displayed on the OP when you switch the system on.

Defining communication areas

So that the PLC can communicate with the OP, you must define data areas which can be accessed by
both sides. This is done via the Area Pointers dialog box.

� Select this dialog box via System → Area Pointers in the menu bar.

You know that you want to configure screens with variable values (input, output) and messages. For the
variables you do not need a special data area, but for the messages you need a data area for event or
fault messages.

� Because with the C7-621 you cannot configure fault and event messages differently, select under
Type: in the Area Pointers dialog box the entry Event Messages . Then click on the Add… button.

The Event Messages dialog box appears, in which you configure the message area as follows:

� As the address, enter for DB: 46 , for DBW: 4, and for Length: 1. Under PLC name select System_1 .

� Click on OK to quit the Event Messages dialog box and return to the Area Pointers dialog box.

� Once you have made your entries, close the dialog box by clicking on OK. Your entries will be saved
automatically.

Now you can proceed with the actual configuring of your screens and messages.

Configuring event message texts

� Open the Message Editor with the menu item Insert → Message → Event Message.

� Now configure four messages numbered 001 through 004, e.g. System ON, Fault in parcel
sequence, Fault in parcel stop and Optical Bero ON.
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In the status line (not shown in the figure), you will see the relevant address which connects the message
to the PLC. In your example, for message no. 001 the address is System ON: DB 46 DBX 5.0 .

Generating the control program

To allow the exchange of data between the C7-CPU and C7-OP you must still adjust your control pro-
gram and reload it into the C7. In your user program you have programmed certain message flags for as
soon as certain operating states occur. Transfer these message flags to DB46.DBW4

� In the SIMATIC Manager, open the function block FC2 and create a new network with the following
program lines.

Network 6 : Data interface

L MW20 // Message flags
T DB46.DBW4 // Data block CPU_OP

� Save the block and reload it into the CPU. Also update the flash memory via the function Save RAM
to ROM. Make sure that the C7-CPU is in the operating mode STOP during this save process. Then
select the operating mode RUNP again.

� Using the softkey F1 on the C7-621-AS-i, select the standard screens and put the device in transfer
mode via System → Mode.

� Transfer the ProTool configuration back to the C7-621-AS-i control system.
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With this control program and the configuration that you loaded, you can initiate the messages on the
SIMATIC C7 device.
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The above figure shows the connection between the PLC and the OP when a message appears. The
process is described in detail below.

� The information that, for example, the system was switched on must be evaluated in the user program.
This can be achieved, for example, by transferring the memory word MW20 containing the evaluated
information of the AS-i input data to the data block.

� A bit area displays the current status of the messages. Each bit that is set indicates that there is a
message.

� The area pointer which you have set at the beginning of the configuration “looks” cyclically in the bit
area, detects whether a bit is set there, and displays the associated message on the C7 display.

� After transfer of the configuration to the C7-OP (as described earlier), press the ENTER key. The start
screen is displayed.

� Switch the system on with the start switch on the control unit (make sure it is set to the initial position).
This triggers an individual message. The message level is displayed and the message appears.
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F1 F2 F3 F4 F5

SF DC5V

FRCE

RUN

STOP

1 2 3

7 8 96

4 5

0

SIMATIC C7-621

ENTER

ESC

SH IFT

+/-

System ON

This completes the configuration.
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Symbolic Addressing

When programming with STEP 7 you work with operands such as I/O signals, bit memories, counters,
timers, data blocks and function blocks. So far you have addressed these operands in your program
absolutely (e.g. on DB46). However, it is helpful to assign symbolic names for them (e.g. on DB_OP, Belt
control). In the declaration section of the data block, you have already defined the symbolic alphanumeric
names for your data elements in the memory block DB1, and defined the DB1 via the structure of UDT1.
If the symbol name of the data block is accessed symbolically, this name must be entered in the symbol
list. This allows full symbolic access to a data element in the data block. To define the symbolic names,
proceed as follows:

� In the SIMATIC Manager select in the S7 Program(1) folder the Symbols folder and open it with a
double click. The Symbol Editor with the symbol table is displayed.

� In the symbol table, activate the first field in the Symbol column by clicking on it, and enter a symbol
name (e.g. DB_OP).

� Jump to the Address column using the TAB key and assign an address (e.g. DB 46) to the symbol
name.

� Skip the Data type column by pressing the TAB key twice. A default value (e.g. WORD) is
automatically entered for the data type and the Comment field becomes active.

� Enter a comment in the comment field and press the TAB key again. The second field in the Symbol
column becomes active. Repeat the steps to enter additional symbol names. When you have
finished, save the symbol table and close the Symbol Editor.

Note
Although long symbolic names are more descriptive, they take longer to edit. With a combination of short
symbolic names and detailed comments, you can satisfy the requirements of both good program docu-
mentation and effective program creation.
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Setting symbolic representation

To also display the symbolic names in your program, you must set the appropriate type of representation.

� In the offline data management, open the function FC1. In the LAD/STL/FBD Editor which appears,
select the menu item View → Display → Symbolic Representation. The absolute addresses are
replaced by the symbolic names.

� Via View → Display →Symbolic Information you can also display the absolute addresses and the
comments from the symbol table. The network comments are then no longer visible.

Note
If you want to incorporate new operands during the programming, you can assign symbolic names to
individual absolute addresses in the LAD/STL/FBD Editor via Options → Symbol Table. The entries are
automatically inserted in the symbol table.

Using the symbolic names in ProTool

Before you can also use the symbolic names in ProTool, you must make some settings.

� In the SIMATIC_Manager open the Hardware folder by double-clicking on it. The Hardware
Configuration window is displayed.
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� In the Hardware Configuration window, open the dialog window Properties C7 CPU621 by double-
clicking on the symbol C7 CPU621.

� Open the Properties - MPI Nodes window by clicking the button Properties ..., and select the Subnet:
MPI(1). Accept the settings with OK, save and compile the hardware configuration, and load it into
the C7 CPU again.
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� Now open your C7-621 ProTool configuration and select the folder Controllers.

� Open the Controller System_1 by double-clicking.

� Click the Parameters... button. Select MPI(1) under Connect OP to network. MPI(1) appears under
Choose a communication peer/symbol list, and the network parameters are displayed on a gray
background.

� Double-click MPI(1) under Choose a communication peer/symbol list. The PLC: C7 CPU621(1)(S7-
Program(1)) appears. Select the PLC by double-clicking. Then accept the entries with OK.

The initial settings are now complete and you can include the symbolic names in your configuration.
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� Open the Parcels_1 screen, double-click the variable Parcels and click the Edit button in the
Input/Output field dialog window. In the dialog window that now appears, the symbolic names are
displayed under Symbol.

� Select the name DB_OP.max_parcels under DB_OPin the variable list. The absolute addresses
are displayed on a gray background. Confirm the entry with OK.

� Repeat the steps for the variable Number with the symbolic name DB_OP.number_parcels. Close
the window with OK.
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Now the event messages still have to be given their symbolic names.

� In ProTool, select the Area Pointers window via the menu item System. In the Area Pointers window
click on the Edit... button.

� In the Event Messages window, select the symbolic name DB_OP.messages and confirm your
entries with OK.

� Save the revised configuration and transfer it back to the C7-OP.

The conversion to symbolic addressing is now complete.
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Operating the C7-621-AS-i

To help you operate the C7-621, the most important keys of the C7-621-AS-i are described briefly below.

F1 F2 F3 F4 F5
SF DC5V

FRCE

RUN

STOP

1 2 3

7 8 96

4 5

0

SIMATIC C7-621

ENTER

ESC

SH IFT

+/-

Display

ESCAPE key

ENTER key

Cursor keys

SHIFT keyNumeric keypad

Softkeys

ESCAPE key

→
ESC

takes you from the current level to the superordinate level.

Example: If you press
ESC

, you quit the system screen Parcels_1 and return to the start screen

Start_Sys1 . If you press
ESC

again you will reach the message level.

→ With
ESC

you can terminate inputs, i.e. the value you have just entered in the input field is
discarded.

ENTER key

→ With ENTER you accept entries that have been made, i.e. the value you have entered in the input
field is sent to the controller.

Cursor keys

→ With the up and down cursor keys you can page between several screen entries of a screen.

Example: In the screen Parcels_1 you page down into the second screen entry with the cursor.
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Program Example

You have created the following STEP 7 program and put it into operation by following the instructions.

DB1:
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DB46:

OB 1:

Network 1 : Route process image of AS-i line to DB

OPN DB1
L PIW 256
T DBW 0
L PIW 258
T DBW 2

Network 2 : Call system component belt control

CALL FC 1

Network 3 : Call system component ejector

Call FC 2

Network 4 : Write outputs

L DBW 4
T PQW 256
L DBW 6
T PQW 258
BE

FC1: Belt control

Network 1 : Initial position

AN DB1.DBX0.0 // Opto_Bero: no parcel
AN DB1.DBX1.0 // Position switch: no parcel
A DB1.DBX0.1 // Ejector in initial position
AN M16.0 // No fault
= M15.0 // Initial position

Network 2 : Belt ON

A DB1.DBX2.0 // Belt_ON switch on casing
A M 15.0 // Initial position
S DB1.DBX4.0 // Conveyor belt ON

Network 3 : Belt OFF

A DB1.DBX2.3 // Belt_OFF switch on casing
O M 16.0 // Fault
R DB1.DBX4.0 // Output Belt_ON
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Network 4 : Operating mode display

A DB1.DBX4.0 // Belt ON
= DB1.DBX6.0 // Green lamp on casing
= M 21.0 // Message flag

FC2 : Eject conditions

Network 1 : Count

A DB1.DBX1.0 // Position switch
A DB1.DBX4.0 // Belt ON
A DB1.DBX0.1 // Inductive Bero
FP M30.0 // Rising edge
CV C1 // Count forward
L C1 // Transfer count to DB46.DBW2
T DB46.DBW2
AN C1 // Count = 0
A DB1.DBX4.0 // Belt ON
L C#0 // Write preset count
S C1 // Initialize counter
L DB46.DW2 // If the value in DB46.DW2 is greater than
L DB46.DW0 // the maximum value set, the counter
>I
R C1 // is reset

Network 2 : Parcel sequence

A DB1.DBX4.0 // Belt_ON
A DB1.DBX0.0 // Opto_Bero: parcel
FN M30.1 // Edge formation
L S5T#10S // Parcel interval at least 10 seconds
SE T5 // Pulse extension
A T5 // Parcel interval too small
A DB1.DBX0.0 // Opto_Bero: parcel
FP M30.2 // Edge formation
S M21.1 // Fault in parcel sequence

Network 3 : Display: parcel detected

A DB1.DBX4.0 // Belt ON
A DB1.DBX0.0 // Opto_Bero
= DB1.DBX6.2 // Lamp: parcel detected
= M 21.3 // Message flag

Network 4 : Stop-monitoring

A DB1.DBX4.0 // Belt ON
A DB1.DBX1.0 // Parcel at end of belt
L S5T#5S // Monitoring time 5 seconds
SD T3 // ON delay
A T3
S M21.2 // Fault in parcel stop
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Network 5 : Faults

O M21.1 // Fault_parcel sequence
O M21.2 // Fault_parcel stop
= M16.0 // Fault

A M16.0 // Fault
A M10.4 // Flashing frequency
= DB1.DBX6.1 // Red lamp on casing

A DB1.DBX2.1 // Acknowledgment button
R M21.1 // Fault_parcel sequence
R M21.2 // Fault_parcel stop

Network 6 : Data interface

L MW20 // Message flags
T DB46.DBW4 // Data block CPU_OP


