# SIMATIC HMI

## WinCC V6.2

### Getting Started

<table>
<thead>
<tr>
<th>Manual</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>0</td>
</tr>
<tr>
<td>Preparation and Installation</td>
<td>1</td>
</tr>
<tr>
<td>The first WinCC Project</td>
<td>2</td>
</tr>
<tr>
<td>Display Process Values</td>
<td>3</td>
</tr>
<tr>
<td>Configuring the Alarm System</td>
<td>4</td>
</tr>
<tr>
<td>Outputting an Alarm Message</td>
<td>5</td>
</tr>
<tr>
<td>Sequence Report</td>
<td></td>
</tr>
<tr>
<td>Outputting a Tag Logging Runtime Report</td>
<td>6</td>
</tr>
</tbody>
</table>

Order number
6ZB5370-0CM02-0BA5
Safety Guidelines

This manual contains notices which you should observe to ensure your own personal safety, as well as to protect the product and connected equipment. These notices are marked as follows according to the level of danger:

**Danger**

indicates an imminently hazardous situation which, if not avoided, will result in death or serious injury.

**Warning**

indicates a potentially hazardous situation which, if not avoided, could result in death or serious injury.

**Caution**

used with the safety alert symbol indicates a potentially hazardous situation which, if not avoided, may result in minor or moderate injury.

**Caution**

used without safety alert symbol indicates a potentially hazardous situation which, if not avoided, may.

**Attention**

indicates that unwanted events or status can occur if the relevant information is not observed.

**Note**

draws your attention to particularly important information on the product, handling the product, or to a particular part of the documentation.

Qualified Personnel

Only qualified personnel should be allowed to install and work with this software. Qualified personnel within the meaning of the safety notices of this documentation are persons capable of giving due consideration to safety engineering standards when using this software on systems.

Trademarks

The registered trademarks of the Siemens AG can be found in the preface.

Impressum

Editor and Publisher: A&D AS SM ID 5
Introduction


WinCC is powerful HMI system for use under Microsoft Windows 2000 and Windows XP. HMI stands for "Human Machine Interface", i.e. the interface between the human (the operator) and the machine (the process). The actual control over the process is performed by the automation system. WinCC communicates with both the operator and the automation system(s).

The WinCC Project Development/Configuration Environment

To develop and configure projects, special editors are provided that can be accessed from the WinCC Explorer. With each editor, a specific subsystem of WinCC is configured.

The major subsystems of WinCC are:

- The graphics system - the editor for creating the screens is the Graphics Designer.
- The alarm system - the editor for configuring the alarms is named Alarm Logging.
- The archiving system - the editor for specifying the data to be archived is named Tag Logging.
- The report system - the editor for creating the report layouts is the Report Designer.
- The communication system is configured directly in the WinCC Explorer.

All configuration data is stored in the CS database.

The WinCC Runtime

With the runtime software, the operator can run and monitor the process. In particular, the runtime software has the following tasks:

- Reading of the data stored in the CS database.
- Displaying of the screens.
- Communication with the automation systems.
- Archiving of the current runtime data such as process values and alarm events.
- Running of the process, e.g. through specified set-points or activation/deactivation.
## Notation

This documentation uses the following notation:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Click with left mouse button" /></td>
<td>Indicates a click with the left mouse button.</td>
</tr>
<tr>
<td><img src="image" alt="Click with right mouse button" /></td>
<td>Indicates a click with the right mouse button.</td>
</tr>
<tr>
<td><img src="image" alt="Double-click with left mouse button" /></td>
<td>Indicates a double-click with the left mouse button.</td>
</tr>
<tr>
<td><img src="image" alt="Operation while left mouse button is kept pressed" /></td>
<td>Indicates an operation while the left mouse button is kept pressed.</td>
</tr>
<tr>
<td><img src="image" alt="Input via keyboard" /></td>
<td>Indicates an input via the keyboard.</td>
</tr>
<tr>
<td><img src="image" alt="File → New" /></td>
<td>All menus and input fields that have to be selected are enclosed in quotation marks.</td>
</tr>
<tr>
<td># 1</td>
<td>In the texts accompanying the illustrations, &quot;# n&quot; indicates the order in which the steps are to be performed.</td>
</tr>
</tbody>
</table>
## Contents

### 1 Preparation and Installation
- 1.1 Hardware Requirements for the Installation .............................................. 5
- 1.2 Software Requirements for the Installation................................................ 8
- 1.3 How to install the MS Message Queuing Services ...................................... 10
- 1.4 How to install the Microsoft SQL Server 2000 ......................................... 12
- 1.5 WinCC Installation and Setup .................................................................. 13
- 1.5.1 WinCC Installation: User Registration ..................................................... 14
- 1.5.2 Installation: Select Languages ............................................................... 15
- 1.5.3 Installation: Select Components ............................................................ 16
- 1.5.4 Installation: Authorization ................................................................... 18
- 1.6 How to perform a Deinstallation............................................................... 19

### 2 The first WinCC Project
- 2.1 Step 1: Starting WinCC............................................................................ 21
- 2.2 Step 2: Creating a new Project ................................................................. 22
- 2.3 Step 3: Adding a Communication Driver.................................................. 23
- 2.4 Tags and Tag Groups .............................................................................. 25
- 2.4.1 Step 4: Creating an Internal Tag.............................................................. 28
- 2.4.2 Step 4a: Creating a Tag Group ............................................................... 29
- 2.4.3 Step 4b: Creating a Process Tag............................................................. 31
- 2.5 Editing Process Screens.......................................................................... 33
- 2.5.1 Step 5.1: Creating Process Screens........................................................ 37
- 2.5.2 The Graphics Designer ............................................................................ 39
- 2.5.3 The Process Screen ................................................................................ 42
- 2.5.4 Step 5.2: Creating a Button...................................................................... 43
- 2.5.5 Step 5.3: Configuring the Process Screen............................................... 45
- 2.5.6 Step 5.4: Making the Fill Level Display dynamic ..................................... 47
- 2.5.7 Step 5.5: Creating an I/O Field and making it dynamic ........................... 51
- 2.6 Step 6: Defining the Runtime Properties ................................................. 53
- 2.7 Step 7: Activating the Project................................................................... 54
- 2.8 Step 8: Using the Simulator ..................................................................... 55

### 3 Displaying Process Values
- 3.1 Step 1: Opening Tag Logging .................................................................. 57
- 3.2 Step 2: Configuring Timers ...................................................................... 58
- 3.3 Step 3: Creating an Archive ..................................................................... 59
- 3.4 Step 4: Configuring an Archive ................................................................. 61
- 3.5 Step 5: Creating a Trend Window............................................................. 63
- 3.6 Step 6: Creating a Table Window ............................................................. 65
- 3.7 Step 7: Defining the Runtime Properties ................................................. 67
- 3.8 Step 8: Activating the Project................................................................... 70

### 4 Configuring the Alarm System
- 4.1 Step 1: Opening Alarm Logging................................................................. 73
- 4.2 Step 2: Starting the System Wizard........................................................... 74
- 4.3 Step 3: Configuring Alarm Messages and Alarm Message Texts ............. 75
- 4.4 Step 4: Configuring the Alarm Message Colors ...................................... 77
- 4.5 Analog Alarm ........................................................................................... 80
4.5.1 Step 5.1: Configuring the AnalogAlarm of a Tag ........................................ 82
4.5.2 Step 5.2: Setting Limit Values .................................................................. 86
4.6 Step 6: Creating an Alarm Message Screen ........................................... 89
4.7 Step 7: Defining the Runtime Properties ................................................. 92
4.8 Step 8: Activating the Project ................................................................. 93

5 Outputting an Alarm Message Sequence Report ....................................... 95
5.1 Step 1: Creating a Page Layout .................................................................. 96
5.2 The Page Layout Editor ........................................................................... 97
5.3 Step 2: Editing the Page Layout .............................................................. 99
5.4 Step 3: Configuring the Print Job ........................................................... 102
5.5 Step 4: Defining the Runtime Properties ............................................... 104
5.6 Step 5: Activating the Project ................................................................. 105

6 Outputting a Tag Logging Runtime Report ............................................... 107
6.1 Editing the Page Layout .......................................................................... 108
6.1.1 Step 1: Editing the Static Section ......................................................... 108
6.1.2 Step 2: Editing the Dynamic Section .................................................... 109
6.2 Step 3: Defining the Print Job Parameters ............................................. 113
6.3 Step 4: Activating the Project ................................................................. 114
1 Preparation and Installation

This chapter describes the WinCC hardware and software requirements as well as the installation procedure from the CD-ROM.

For the Getting Started, you will create a single-user project. The project runs on a computer that functions as the server for processing the data and as the operator station. Other computers cannot access the project.

Requirements for the Installation of WinCC

For the installation of WinCC, certain hardware and software is required. These requirements are outlined in the chapters "Hardware Requirements for the Installation" and "Software Requirements for the Installation".

During the installation of WinCC, it will be checked, whether certain requirements have been met. The following will be checked:

- Operating System
- User Rights
- Video Resolution
- Internet Explorer
- MS Message Queuing Services
- SQL Server
- Required Restart
Error Messages

If one of these requirements is not satisfied, the WinCC installation will be cancelled and an error message displayed. The following table contains information about the various error messages.

<table>
<thead>
<tr>
<th>Error Message</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>To perform a proper installation, the computer has to</td>
<td>You have installed software on the computer that requires a restart. Before</td>
</tr>
<tr>
<td>be restarted</td>
<td>WinCC can be installed, the computer has to be restarted.</td>
</tr>
<tr>
<td>Win XP / Win 2000 SP2 operating system required</td>
<td>Upgrade the operating system to Windows XP or Windows 2000 SP2.</td>
</tr>
<tr>
<td>This application requires VGA or higher resolution</td>
<td>Check the settings of the connected monitor and upgrade the video card if</td>
</tr>
<tr>
<td></td>
<td>necessary.</td>
</tr>
<tr>
<td>Administrator rights are required to install this</td>
<td>Log in again as a user with administrator rights.</td>
</tr>
<tr>
<td>product</td>
<td></td>
</tr>
<tr>
<td>The Microsoft Message Queuing Services are not installed</td>
<td>Install the Microsoft Message Queuing Services. For this, the Windows</td>
</tr>
<tr>
<td></td>
<td>installations CD-ROM is required. Instructions can be found in the chapter</td>
</tr>
<tr>
<td></td>
<td>&quot;MS Message Queuing Services Installation&quot;.</td>
</tr>
<tr>
<td>The required SQL Server 2000 SP3 instance is not</td>
<td>Install the Microsoft SQL Server 2000 SP3 from the supplied CD-ROM.</td>
</tr>
<tr>
<td>installed</td>
<td>Instructions can be found in the chapter &quot;Microsoft SQL Server 2000</td>
</tr>
<tr>
<td></td>
<td>Installation&quot;.</td>
</tr>
</tbody>
</table>

The icons of the program group are not visible

WinCC employs a user-dependent program manager to display icons. If you are not logged in with the same name used for installing WinCC, the WinCC icons will not be displayed.
1.1 Hardware Requirements for the Installation

WinCC supports all current IBM/AT-compatible PC platforms. In order to be able to work efficiently with WinCC, a configuration should be set up according to the recommended values below. For a single-user system, the following requirements apply:

<table>
<thead>
<tr>
<th></th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU</td>
<td>Intel Pentium III, 800 MHz</td>
<td>Intel Pentium 4, 1400 MHz</td>
</tr>
<tr>
<td>Main Memory</td>
<td>Server: 512 MB</td>
<td>Server: 1 GB (1024 MB)</td>
</tr>
<tr>
<td>Available Hard Disk Space</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- for the Installation of WinCC(^1)</td>
<td>700 MB</td>
<td>1 GB</td>
</tr>
<tr>
<td>- for Working with WinCC(^2)</td>
<td>1.5 GB</td>
<td>10 GB</td>
</tr>
<tr>
<td>Virtual Memory(^3)</td>
<td>1.5 x Main Memory</td>
<td>1.5 x Main Memory</td>
</tr>
<tr>
<td>Memory for the Window Printer Spooler(^4)</td>
<td>100 MB</td>
<td>&gt; 100 MB</td>
</tr>
<tr>
<td>Video Card</td>
<td>16 MB</td>
<td>32 MB</td>
</tr>
<tr>
<td>Color Depth</td>
<td>256</td>
<td>True Color</td>
</tr>
<tr>
<td>Resolution</td>
<td>800 * 600</td>
<td>1024 * 768</td>
</tr>
</tbody>
</table>

\(^1\) The hard disk on which the operating system is installed must have a minimum of 100 MB of available space for additional system files. In most cases, the operating system is located on drive "C:".

\(^2\) Depending on the project size as well as the size of the archives and packages. For the activation of a project, a minimum of 100 MB must be available in addition.

\(^3\) As the "Paging file size for a selected drive" use the recommended value from the field "Total paging file size for all drives". Enter the recommended value in the fields "Initial size" and "Maximum size".

\(^4\) WinCC requires the Windows printer spooler to detect printer errors. For this reason, no other printer spooler must be installed.
1.2 Software Requirements for the Installation

Introduction

For the installation of WinCC, certain requirements with regard to the operating system and the software configuration have to be met. Before the installation of WinCC, the MS Message Queuing Services and the SQL Server 2000 instance "WinCC" need to be installed.

Caution

WinCC has been approved for operation in a domain or working group. However, please note that the domain group guidelines and domain restrictions could hinder the installation. In this case, delete Microsoft Message Queuing, Microsoft SQL Server 2000 and WinCC from the domains from the computer prior to the installation. Following a successful installation, the WinCC computer can be readmitted to the domain. If the domain guidelines and domain restrictions do not interfere with the installation, the computer need no be removed from the domain during installation.

Please note that the domain group guidelines and domain restrictions could also interfere with the operation. If these restrictions cannot be cleared, operate the WinCC computer in a working group. If necessary, contact the domain administrator.

Operating System

Single-user systems of a project must either be operated with Windows XP Professional or with Windows 2000.


<table>
<thead>
<tr>
<th>Operating System</th>
<th>Configuration</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows XP</td>
<td>Windows XP Professional or Windows XP Professional Service Pack 1</td>
<td>If you install Windows XP Service Pack 1, the Internet Explorer 6.0 Service Pack 1 will be installed as well.</td>
</tr>
<tr>
<td>Windows 2000</td>
<td>Windows 2000 Professional Service Pack 2 or 3</td>
<td></td>
</tr>
</tbody>
</table>

Internet Explorer Requirements

WinCC V6.0 requires the Microsoft Internet Explorer 6.0 Service Pack 1 or higher. The Internet Explorer 6.0 SP1 can be installed from the supplied CD-ROM.

For the Internet Explorer, the following options should be selected:

- Installation Option: Standard Installation
- Update of the Windows Desktop: No
Active Channel Selection: None

If you want to use the HTML Help of WinCC to its full extent, Java scripts have to be enabled on the Internet Explorer under "Internet Options".

Adjust Security Policies

The operating system must permit the installation of unsigned drivers and files. Detailed information about this can be found in the WinCC Information System/Installation Notes, chapter "Adjusting Security Policies under Windows".

Microsoft Message Queuing Services

WinCC V6.0 requires the Microsoft Message Queuing Services. Detailed information about this can be found in the chapter "Microsoft Message Queuing Services Installation".

Microsoft SQL Server 2000

WinCC V6.0 requires the Microsoft SQL Server 2000 SP3. Detailed information about this can be found in the chapter "Microsoft SQL Server 2000 Installation".
1.3 How to install the MS Message Queuing Services

Introduction

WinCC employs the Message Queuing Services of Microsoft. This component is part of the operating system. However, MS Message Queuing is not a default setting of the Windows installation and has to be added if necessary.

For the installation, the Windows installation CD-ROM is required.

---

**Caution**

WinCC as well as the required software must not be installed on a computer which is operated in a domain.

Procedure in Windows XP

<table>
<thead>
<tr>
<th>Steps</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>From the Windows &quot;Start&quot; menu, go to &quot;Settings&quot; &gt; &quot;Control Panel&quot; &gt; &quot;Add/Remove Programs&quot;.</td>
</tr>
<tr>
<td>2</td>
<td>In the left menu bar, click on the button &quot;Add/Remove Windows Components&quot;. The &quot;Windows Components Wizard&quot; will open.</td>
</tr>
<tr>
<td>3</td>
<td>Select the component &quot;Message Queuing Services&quot;. This activates the button &quot;Details...&quot;.</td>
</tr>
<tr>
<td>4</td>
<td>Click on the button &quot;Details...&quot;. The dialog box &quot;Message Queuing Services&quot; will open.</td>
</tr>
<tr>
<td>5</td>
<td>Select the subcomponent &quot;Common&quot;. Deselect all other subcomponents</td>
</tr>
</tbody>
</table>
**Steps**

and acknowledge with "OK".

6 If the dialog box "Files Needed" opens, insert the requested Windows installations CD-ROM. Click on the button "OK". The MS Message Queuing Services will be installed.

7 Close the Wizard by clicking on the button "Finish".

---

### Procedure in Windows 2000

<table>
<thead>
<tr>
<th>Steps</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>From the Windows &quot;Start&quot; menu, go to &quot;Settings&quot; &gt; &quot;Control Panel&quot; &gt; &quot;Add/Remove Programs&quot;.</td>
</tr>
<tr>
<td>2</td>
<td>In the left menu bar, click on the button &quot;Add/Remove Windows Components&quot;. The &quot;Windows Components Wizard&quot; will open.</td>
</tr>
<tr>
<td>3</td>
<td>Select the component &quot;Message Queuing Services&quot; and click on the button &quot;Next&quot;.</td>
</tr>
<tr>
<td>4</td>
<td>Select the MSMQ type &quot;Independent Client&quot;. Click on the button &quot;Next&quot;.</td>
</tr>
<tr>
<td>5</td>
<td>Select the setting &quot;Message Queuing Services do not access the active directory&quot;. Click on the button &quot;Next&quot;.</td>
</tr>
<tr>
<td>6</td>
<td>If the dialog box &quot;Files Needed&quot; opens, insert the requested Windows installations CD-ROM. Click on the button &quot;OK&quot;. The MS Message Queuing Services will be installed.</td>
</tr>
<tr>
<td>7</td>
<td>Close the Wizard by clicking on the button &quot;Finish&quot;.</td>
</tr>
</tbody>
</table>
1.4 How to install the Microsoft SQL Server 2000

Introduction

This chapter describes how the Microsoft SQL Server 2000 SP3 is installed for WinCC V6.0. For this, use the supplied CD-ROM.

During the installation, a new SQL Server instance ("WinCC") with the required settings will be created.

SQL Server Instance "WinCC"

During the installation, the instance "WinCC" will be created. This instance is always installed in English. The language with which already existing SQL server instances have been installed has no effect on this.

The instance "WinCC" is created with the Microsoft SQL Server 2000 Service Pack 3. Service Pack 3 has no effect on existing instances.

Microsoft SQL Server 2000 already installed

The SQL Server instance "WinCC" still needs to be installed, even if another Microsoft SQL Server instance has already been installed.

Requirements

- For the installation, administrator rights are required.
- There must be no manually installed SQL Server instance named "WinCC".

Procedure

<table>
<thead>
<tr>
<th>Steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
</tbody>
</table>

Deinstallation of the SQL Server 2000

When deinstalling WinCC, the SQL Server instance "WinCC" remains and has to be deinstalled manually due to license issues.

Once the SQL Server instance "WinCC" has been deinstalled and you wish to reinstall it, then WinCC V6.0 must be reinstalled as well.
1.5 WinCC Installation and Setup

WinCC is delivered on a CD-ROM equipped with an Autorun program. To start the installation, simply insert the CD-ROM into the drive. If the Autorun program does not start, run the “Start.exe” on the CD-ROM.

After a brief loading time, the following installation dialog will be displayed:

![Illustration 1.1: Installation of WinCC; Welcome Screen]

To install WinCC, click on the text "Install SIMATIC WinCC". The Installation Wizard will then guide you step-by-step through the installation procedure.

- In the following dialog window, click on the button "Next" to go to the next steps.
- Read and accept the license conditions by clicking on "Yes".
1.5.1 WinCC Installation: User Registration

1. In the dialog box "User Information", enter the required data.

![Image of User Information dialog box]

- Enter the word "Demo" in this field. Afterwards, click on "Next".

2. Click on the button "Next".

3. Confirm your entries displayed in the dialog box "Registration Confirmation" by clicking on "Yes".

4. In the following dialog box, select the target folder, in which WinCC is to be installed. The preset folders are "C:\Program Files\Siemens\WinCC" and "C:\Siemens\Common".
1.5.2 Installation: Select Languages

In the next dialog box, select the languages that you want to install. English is always installed by the system.

![Select additional WinCC languages](image)

*Illustration 1.3: Installation of WinCC; Selection of the Languages*

Afterwards, click on the button "Next".
1.5.3 Installation: Select Components

The WinCC setup program offers you three basic options for the WinCC installation. For a maximum installation (all components can be selected), please choose the "User-defined" installation.

Illustration 1.4: Installation of WinCC; User-defined Installation

In the dialog box "Select Components", choose the components that you want to install. For this, click on the desired component in the left window - their elements will then be displayed in the right window. In the right window, the individual elements can then be selected. To select components/elements, click on the check-box in front of the desired component/element. Selected components/elements are indicated by a check-mark. The required space will be displayed as well as the available space.
Illustration 1.5: Installation of WinCC; Selection of the Components

- Afterwards, click on the button "Next".
1.5.4 Installation: Authorization

The dialog box "Authorization" displays a list of required authorizations based on the selected components. Since the authorization can also be performed later, select "No, the authorization is performed at a later time". Please note that without an authorization, WinCC only runs in a demo mode and automatically shuts down after one hour.

Illustration 1.6: Installation of WinCC; Authorization

Click on the button "Next".

In the next dialog box, the settings you have made will be shown. If you would like to make changes to the settings, click on the button "Back", otherwise click on the button "Next". WinCC will then begin with the transfer of the files. After the completion of the file transfer, you have the option of reading the "README.TXT" file.

To finish the installation, click on "Yes, restart computer now" in the final dialog box.
1.6 How to perform a Deinstallation

Introduction

You can completely deinstall WinCC from your computer or remove individual components or languages.

Procedure

<table>
<thead>
<tr>
<th>Steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
</tbody>
</table>

Microsoft SQL Server 2000

Following the deinstallation of WinCC, the SQL Server instance "WinCC" has to be deinstalled. From the "Control Panel" > "Add/Remove Programs", select the entry "Microsoft SQL Server 2000 (WinCC)" for deinstallation.

The use of the Microsoft SQL Server 2000 is only permitted, if you possess a valid license.

Changes to the Windows Event Viewer Settings

The WinCC setup program changes the settings of the Event Viewer during the installation of WinCC:

- Maximum log size (system log/application log): 1024 KB (default setting: 512 KB)
- When maximum log size is reached (system log/application log): "Overwrite events as needed" (default setting: Overwrite events older than 7 days)

Following the deinstallation of WinCC, these settings are not restored. These settings can be adjusted in the Window Event Viewer.

From the Windows "Start" menu, go to "Settings" > "Control Panel" > "Administrative Tools" > "Event Viewer". In the left side of the window, right-click on the logs "System" and "Application" (Windows XP) or "System Log" and "Application Log" (Windows 2000).

From the pop-up menu, select the entry "Properties" and restore the old settings.
2 The first WinCC Project

This chapter introduces you to the basic components of WinCC and explains how to set up and edit a WinCC project by means of simple examples.

Components of WinCC

The basic components are the configuration software and the runtime software.

The WinCC Explorer is the core of the configuration software. In the WinCC Explorer, the entire project structure is displayed and the project managed. To develop and configure projects, special editors are provided that can be accessed from the WinCC Explorer. With each editor, a specific subsystem of WinCC is configured.

With the runtime software, the operator can run and monitor the process.

Project Development/Configuration in WinCC

To set up a project in WinCC, proceed as follows:

1. Start WinCC.
2. Create a project.
3. Select and install a communication driver.
4. Define the tags.
5. Create and edit your process screens.
6. Specify the WinCC runtime properties.
7. Activate your screens in WinCC Runtime.
8. Use the simulator to test your process screens.
2.1 Step 1: Starting WinCC

To activate WinCC, click on the "Start" button on the Windows taskbar.

Start WinCC via "SIMATIC" ➔ "WinCC" ➔ "Windows Control Center 6.0".

Illustration 2.1: WinCC Project "Qckstart"; Starting WinCC from the Windows "Start" Menu
2.2 Step 2: Creating a new Project

If you are opening WinCC for the first time, a dialog box will offer you three options for creating a project:

- Create a "Single-User Project" (default selection)
- Create a "Multi-User Project"
- Create a "Client Project"
- "Open an existing Project"

Creating the "Qckstart" Project:

1. Select "Single-User Project" and click on "OK".
2. Enter "Qckstart" as the project name and select a project path. You can rename the subfolder if necessary, otherwise it will be given the project name.

If you want to open an existing project, the displayed "Open" dialog box will allow you to search for "mcp" files. The next time WinCC is started, the last project worked on will automatically be opened. If the project was activated when WinCC was exited, it will be reopened in the activated state.

The WinCC Explorer is shown in Illustration 2.2 (the dialog window may vary slightly from the illustration depending on the configuration).

Illustration 2.2: WinCC Project "Qckstart"; WinCC Explorer Dialog Window

The left side of the window contains the navigation window, which leads to the individual project steps. Subfolders are indicated by the symbol [ ] To make them visible, click on this symbol.
The right side of the window shows the elements belonging to the selected editor or folder.

In the left side of the WinCC Explorer window, click on the icon "Computer". In the right side of the window, you should then see a server computer with your computer name (the NetBIOS name). Right-click on this computer and select "Properties" from the displayed pop-up menu. In the following dialog box, you can set the properties of the WinCC runtime, including which runtime components are to be started upon project activation, which language is to be used, which buttons are to be deactivated, etc.

---

**Note**

If your computer does not possess a NetBIOS name, the name "DEFAULT" will be used.
2.3 Step 3: Adding a Communication Driver

To access the current process values of the automation system (PLC) with WinCC, a connection between WinCC and the automation system has to be configured. The communication is handled by specialized communication drivers, the channels. WinCC possesses channels for the automation systems SIMATIC S5/S7/505 as well as manufacturer-independent channels.

To add a communication driver, right-click on "Tag Management" in the left side of the WinCC Explorer window.

In the displayed pop-up menu, click on the entry "Add new Driver".

In the dialog box "Add new Driver", select one of the displayed drivers (e.g. "SIMATIC S7 Protocol Suite") and click on the button "Open". The selected driver will then be displayed in the subfolder of Tag Management.

To create a new connection, click on the icon in front of the displayed driver - all the available channel units will be displayed.

Through a channel unit, logical connections to multiple automation systems can be established, which communicate through this channel unit.
Right-click on the channel unit MPI.

In the displayed pop-up menu, click on the entry "New Connection".

In the following dialog box "Connection Properties", enter "PLC1" in the name field.

Click on the button "OK".
Illustration 2.3.3: WinCC Project "Qckstart"; Creating a new Connection

Enter a name for the connection here.
2.4 Tags and Tag Groups

The tags used in WinCC represent either real values - such as the fill level of a water tank - or internal values that are calculated or simulated within WinCC.

The connecting links for the exchange of data between WinCC and the automation systems are process tags ("external tags"). Each process tag in WinCC corresponds to a certain process value in the memory of one of the connected automation systems. In runtime, WinCC reads the data area in which this process value is stored from the automation system and thus determines the value of the process tag. For example, the fill level of a water tank is determined by a fill level sensor and stored in the PLC. Via a connection - the communication channel - the value of the fill level is transmitted to WinCC.

Tags not supplied with values by the process are created in the folder "internal tags".

Tag groups are used to organize tags. All tags can be assigned to tag groups for improved clarity.

---

**Note**

In this project, only internal tags are used. Steps 4a and 4b are not mandatory for this project. In these steps, the configuration of tag groups and process tags is shown.

---

**Tag Management Hierarchy with regard to Process Tags**

```
Tag Management
  SIMATIC S7 PROTOCOL SUITE
    MPI
      PLC1
        Tag Group
          Tag
```

**Tag Management Hierarchy with regard to Internal Tags**

```
Tag Management
  Tag Group
    Tag
```
2.4.1 Step 4: Creating an Internal Tag

If the node "Tag Management" in the WinCC Explorer has not been expanded, do so by double-clicking on it.

Right-click on the line "Internal Tags".

In the displayed pop-up menu, click on the entry "New Tag".

Illustration 2.4.1: WinCC Project "Qckstart"; Creating an Internal Tag
In the dialog box “Tag Properties”, name the tag “TankLevel”.

From the list of data types, select “Unsigned 16-Bit Value”.

Confirm your entries by clicking on the button “OK”.

Illustration 2.4.2: WinCC Project “Qckstart”; Properties of an Internal Tag

All internal tags created will be listed in the right side of the WinCC Explorer window.

This is how easy a tag can be created. For each additional tag required, simply repeat these steps. You can also “copy”, “cut” and “paste” tags. These commands can be accessed from the pop-up menu (right-click on the desired tag) or called using standard Microsoft key combinations (<CTRL+C> = copy, <CTRL+V> = paste).
2.4.2 Step 4a: Creating a Tag Group

Tag groups, for example, can be arranged below the logical connection. To create a new group, right-click on the connection you created previously.

In the displayed pop-up menu, click on the entry "New Group".

Illustration 2.4.3: WinCC Project "Qckstart"; Creating a new Tag Group
In the dialog box “Tag Group Properties”, enter a group name in the name field.

Illustration 2.4.4: WinCC Project “Qckstart”; Tag Group Properties

Confirm your entries by clicking on the button “OK”. The tag group will then be displayed below the connection.
2.4.3 Step 4b: Creating a Process Tag

Before you can create process tags, you must have installed a driver and configured a connection.

Already created internal tags can be copied and pasted into a connection. Note that tags can only be placed in a connection via the commands "copy" and "paste". Tags cannot be dragged into a connection.

To create a process tag, right-click on the connection you created previously.

In the displayed pop-up menu, click on the entry "New Tag".

Illustration 2.4.5: WinCC Project "Qckstart"; Creating a Process Tag
In the dialog box “Tag Properties”, give the tag a name.

From the list of data types, select a data type.

The data type of a tag in WinCC can differ from the data type used in the PLC. The format adaptation can convert the data format of a PLC into a WinCC format.

Illustration 2.4.6: WinCC Project “Qckstart”; Process Tag Properties
Specifying the Address in the PLC

WinCC tags are assigned to data areas in the PLC and have to be addressed in a certain way. The addressing type depends on the type of communication partner.

1. Click on the button "Select" (located next to the addressing field) to display the dialog box "Address Properties".
2. From the list-box for the data area of the tag, select the data area "Flag".
3. Check whether the addressing type "Word" and the address "0" have been set.

Illustration 2.4.7: WinCC Project "Qckstart"; Specifying the Address

4. Click on the button "OK".
Specifying Linear Scaling

Linear scaling is used, if you want to display a process value differently than it is supplied by the PLC. The process value itself is not changed. Linear scaling can only be used for process tags.

Select the check-box "Linear Scaling". This enables the input fields "Process Value Range" and "Tag Value Range".

Specify the process value range (e.g. from -20 to 20) and the tag value range (e.g. from 0 to 100).

Note
If you want to use positive and negative numbers for the process value range, a signed tag must be specified as the data type and "Signed" be selected in the field "Format Adaptation".
2.5 Editing Process Screens

2.5.1 Step 5.1: Creating Process Screens

The screens depicting the process in runtime are created with the graphics system. In this section, you will design a process screen - and can let your creativity run free.

To create a new screen and open the Graphics Designer, proceed as follows.

Creating a Process Screen

1. In the left side of the WinCC Explorer window, right-click on the "Graphics Designer" to access its pop-up menu.
2. In the pop-up menu, click on the entry "New Picture". A picture file (".pdl" = "Picture Description File") named "NewPdl0.pdl" will be created and displayed in the right side of the WinCC Explorer window.

Illustration 2.5.1: WinCC Project "Qckstart"; Creating a new Screen
In the right side of the WinCC Explorer window, right-click on "NewPdl0.pdl".

In the pop-up menu, click on the entry "Rename Picture".

In the following dialog box, enter "START.pdl".

Creating a second Process Screen

Create a second screen and name it "SAMPLE.pdl". To do so, simply follow the above steps.

Opening the Graphics Designer

To view the screen "START.pdl" and open the Graphics Designer, double-click on "START.pdl" in the right side of the WinCC Explorer window.

As an alternative, you can also right-click on "START.pdl" and select the entry "Open Picture" from the pop-up menu.
2.5.2 The Graphics Designer

Once you have opened the Graphics Designer, it will look similar to the illustration below.

Illustration 2.5.2: WinCC Project "Qckstart": The Graphics Designer

To optimize your workspace, we recommend the above arrangement of the menu bars and palettes.

- To resize the object and style palettes, drag them into the drawing space while keeping the left mouse button pressed. For this, the mouse pointer has to be on the palette frame.

- With the mouse pointer still on the palette frame - it will change to a black double-arrow - drag the palette frame to the desired size while keeping the mouse button pressed.
Color Palette

Assignment of colors to selected objects. In addition to the 16 standard colors, you can also define custom colors.

Object Palette

Contains the Standard Objects (Polygon, Ellipse, Rectangle, etc.), Smart Objects (OLE Control, OLE Element, I/O Field, etc.) and Windows Objects (Button, CheckBox, etc.).

Style Palette

Changes the appearance of a selected object. Depending on the object, you can change the line or border type, the line or border width, the line end style, or the fill pattern.

Alignment Palette

Allows you to change the absolute position of one or more objects, change the position of selected objects relative to each other or unify the height and width of several objects.

Zoom Palette

Sets the zoom factor (in percent) for the active window. Via buttons, several default zoom factors can be set.

Menu Bar

Contains all available menu commands of the Graphics Designers. Commands that can currently not be activated are grayed out.

Toolbar

Contains buttons to quickly perform common commands.

Font Palette

Changes the font type, size and color of text objects as well as the line color of standard objects.

Layer Bar

Selects which of the 32 layers will be visible. Layer 0 is selected by default.
To learn more about the displayed objects, first click on the icon ![Help Icon] and then on the desired object. For additional information, please refer to the WinCC Information System or the WinCC V6 user manual.

**Note**
To specify which bars or palettes are to be displayed in the Graphics Designer, click on the menu bar commands "View" ➔ "Toolbars". In the dialog box "Toolbars", mark which bars/palettes you want to have displayed and then click on the button "OK".
2.5.3 The Process Screen

For our first project, we will create a tank representing the water supply of Atlanta. All graphical objects needed for our process screen can be found in the WinCC library. We will also need a button, a static text and an input/output field.

Illustration 2.5.3: WinCC Project "Qckstart"; The Process Screen
2.5.4 Step 5.2: Creating a Button

First, we will configure a button that enables you to switch to another screen in runtime. To create a button that toggles between the two screens "START.pdl" and "SAMPLE.pdl", proceed as follows:

1. In the screen "START.pdl", select "Windows Objects" ➔ "Button" from the object palette.

2. In the drawing space, position the button with a mouse click and then drag it - while keeping the mouse button pressed - to the desired size.

3. After releasing the mouse button, the dialog box "Button Configuration" will open. In the field "Text", enter a name. For example, the name of the screen you wish to switch to: "SAMPLE".

4. To select the screen you wish to switch to, click on the icon next to the field "Change Picture on Mouse Click".

5. In the following dialog box, double-click on the screen "SAMPLE.pdl".

Illustration 2.5.4: WinCC Project "Qckstart": Button Configuration

6. Close the dialog box "Button Configuration" and save the screen "START.pdl" by clicking on the button .
Creating a second Button

To be able in runtime to switch back to the start screen from the screen "SAMPLE.pdl", configure a button in the screen "SAMPLE.pdl" that switches to the screen "START.pdl". You can open the screen "SAMPLE.pdl" by clicking on the icon or from the WinCC Explorer.

---

**Note**

Use the arrow keys to move an object in small steps.
Use SHIFT + arrow keys to move an object in large steps.
2.5.5 Step 5.3: Configuring the Process Screen

Creating the Water Tank

- In the menu bar of the Graphics Designer, click on "View" → "Library", or click on the toolbar icon. The Object Library with its own toolbar and object folders will be displayed.
- Double-click on "Global Library" and then - in the right side of the window - on the folder "Plant Elements".
- Double-click on the folder "Tanks".
- Click on the library toolbar icon to see a preview of the available tanks.

**Note**

Via the buttons and on the library's toolbar, the size of the preview items can be changed.

- Click on "Tank 1" and drag it into the drawing space while keeping the left mouse button pressed.
- The black blocks surrounding the tank allow it to be resized. Position the mouse pointer on one of the black blocks and drag the tank to the desired size while keeping the left mouse button pressed.

Creating the Piping

- From the "Global Library" → "Plant Elements" → "Pipes - Smart Objects", place the required pipe segments in the drawing space.
- From the "Global Library" → "Plant Elements" → "Valves - Smart Objects", place the required valves in the drawing space.

**Note**

Objects such as bend pipe segments do not have to be picked from the library every single time. An object can be duplicated with the commands "Copy", "Paste" and "Duplicate" (available from the "Edit" menu or the pop-up menu). An object can also be adjusted with the commands "Rotate" and "Mirror" available from the "Arrange" menu.
Creating a Static Text

From the object palette, select "Standard Objects" ➤ "Static Text".

Position the object in the upper, right corner of the drawing space and drag it to the desired size while keeping the mouse button pressed.

Enter the title "Atlanta Water Supply".

Set the font size to "20". To do so, click on the toolbar arrow button next to the current font size and select "20" from the drop-down list.

To adjust the frame to the text, click on the text and drag the black blocks until the desired size is reached.
2.5.6 Step 5.4: Making the Fill Level Display dynamic

An object is made dynamic by - for example - linking one of its properties to a tag.

To display or change the properties of an object, right-click on the desired object.

In the pop-up menu, click on the entry "Properties".

![Illustration 2.5.5: WinCC Project "Qckstart"; Displaying Object Properties]

**Note**

With the "Pin" icon located on the toolbar of the object properties window, this window can be permanently pinned down in the Graphics Designer. If you now select a different object, its properties will be automatically be shown in the window. To turn this function off, click on the "Pin" icon again.
In the object properties window, attributes can be defined or changed. You can, for example, change colors and geometric properties (such as the width and the height), and set the minimum or maximum value.

In the left side of the window, click on "Tag Assignment".

In our project, the tag "TankLevel" created by you will set (make dynamic) the fill level of the tank. In the right side of the window, right-click on the transparent light bulb next to "Fill Level".

From the pop-up menu, select "Tag".

In the dialog box "Tags - Project", click on the tag "TankLevel" from the folder "List of all Tags". Click on the button "OK". The transparent light bulb will turn green.

In the column "Update Cycle (Current)" and the row "Fill Level", right-click on the displayed cycle (2 sec.).

In the pop-up menu, click on the entry "Upon Change".
Illustration 2.5.7: WinCC Project “Quickstart”: Changing the Update Cycle

The default settings for the minimum and maximum values of the fill level display are 0 and 100 respectively.

**Note**
A green light bulb indicates that a tag is linked to this attribute. In our project, the tag “TankLevel” was linked to the attribute “Fill Level”. A property shown in bold indicates that a tag is linked to an attribute of this property.
Illustration 2.5.8: WinCC Project "Qckstart": Identification of Dynamic Objects
2.5.7 Step 5.5: Creating an I/O Field and making it dynamic

The process screen includes an I/O field at the top of the fill level display. This field is not only used for displaying the value of a tag, but also for changing the value of a tag.

Creating an I/O Field

- From the object palette, select "Smart Objects" ➔ "I/O Field".
- Position the "I/O Field" in the drawing space and drag it to the desired size while keeping the mouse button pressed. Afterwards, the dialog box "I/O Field Configuration" will be displayed.
- To select a tag, click on the icon and, in the following dialog box, select the tag "TankLevel" from the folder of internal tags.
- Select "500 ms" as the update cycle. To do so, click on the arrow icon next to the field "Update" and select "500 ms" from the drop-down list.

Click on the button "OK".

Illustration 2.5.9: WinCC Project "Qckstart"; Configuring an I/O Field
Note

If you accidentally exit the I/O field configuration dialog box - or any other object configuration dialog box - before completing all settings, proceed as follows:
Right-click on the I/O field and select "Configuration Dialog" from the displayed pop-up menu.

Making an I/O Field dynamic

The properties of the I/O field can be changed in the object properties window.

Right-click on the just created "I/O Field".
In the pop-up menu, click on the entry "Properties".
In the left side of the window, click on the property "Limits".
In the right side of the window, double-click on "Low Limit Value".
In the following dialog box, enter "0". Click on the button "OK".
In the right side of the window, double-click on "High Limit Value".
In the following dialog box, enter "100". Click on the button "OK".

Note that a tag is linked to the property "Input/Output" (indicated by the bold type). If you click on the property "Input/Output", you will see that the tag "TankLevel" with an update cycle of "500 ms" has been linked to it. You made these settings in the "I/O Field Configuration Dialog".

Save the screen "START.pdl" by clicking on the icon and minimize the Graphics Designer.
2.6 Step 6: Defining the Runtime Properties

Next, you will define the runtime properties for the project. Among other things, this includes the look of the runtime display. Proceed as follows:

1. In the left side of the WinCC Explorer window, click on "Computer".
2. In the right side of the WinCC Explorer window, right-click on the name of your computer.
3. In the pop-up menu, click on the entry "Properties".
4. Click on the tab "Graphics Runtime". In here, you can define the look of the runtime display.
5. To select a start screen, click on the "Browse" button and select the screen "START.pdl". Click on the button "OK".
6. At "Window Attributes", activate the check-boxes "Title", "Maximize", "Minimize" and "Adapt Picture".

Illustration 2.6: WinCC Project "Qckstart"; Defining the Runtime Properties

Click on "OK" to close the properties window. You are now ready to work in runtime!
2.7 Step 7: Activating the Project

To see how the project looks in runtime, click on the WinCC Explorer menu bar commands “File” ➔ “Activate”. A check-mark next to “Activate” indicates that the runtime is active.

As an alternative, you can also use the “Activate” button located on the toolbar of the WinCC Explorer.

**Note**
Click on the "Activate" toolbar button of the Graphics Designer to immediately view changes that you have made to a screen.

After a brief loading time, you should see the following:

![Illustration 2.7: WinCC Project "Qckstart"; Runtime Display](image)
2.8 Step 8: Using the Simulator

If no PLC is connected to WinCC, you can use the simulator to test your project.

To activate the simulator, go to the Windows taskbar and click on "Start" → "SIMATIC" → "WinCC" → "Tools" → "WinCC Tag Simulator".

**Note**
A project has to be active (in runtime) for the simulator to function properly.

- In the simulator dialog window, select the tag that you want to simulate. For this, click on "Edit" → "New Tag".
- In the dialog box "Tags - Project", select the internal tag "TankLevel" and click on "OK".
- In the tab "Properties", click on the simulation mode "Inc".
- Enter a start value of "0" and a stop value of "100".
- Select the check-box "active".
- In the tab "Tags", click on the button "Start Simulation". The table "Tags" will then display the tag "TankLevel" with its changing values.

*Illustration 2.8: WinCC Project "Qckstart"; Configuring the Simulator*
If you go back to the runtime window, you will see how the simulator supplies your screen with “real” values.

Deactivate your WinCC project by clicking on the WinCC Explorer menu bar commands “File” → “Activate”. The check-mark next to “Activate” will disappear.
3 Displaying Process Values

This chapter introduces you to the basic components of the archiving system and describes the configuration with the Tag Logging editor. In runtime, the progression of the process values is displayed in table and trend windows.

Tasks of the Archiving System

You can display current process values at any time. However, if you want to display the chronological progression of a process value, e.g. in a diagram or table, you will need access to past process values. These values are stored in process value archives.

Components of the Archiving System

The process value archiving system consists of configuration and runtime components:

The configuration component of the archiving system is the Tag Logging editor. In there, you can configure process value and compressed archives, define acquisition and archiving cycles and select the process values to be archived.

The runtime component of the archiving system is responsible for writing the process values to be archived to the process value archive during runtime. Vice versa, Tag Logging Runtime is also responsible for reading the archived process values from the process value archive, if - for example - the chronological progression of the process values is to be graphed or shown in table form in a screen.

Configuring the Archiving System

To configure the Tag Logging, proceed as follows:

1. Open the Tag Logging editor.
2. Configure a timer.
3. Create an archive using the Archive Wizard.
4. Configure the created archive.
5. Create a trend window in the Graphics Designer.
6. Create a table window in the Graphics Designer.
7. Define the startup parameters.
8. Activate the project.
3.1 Step 1: Opening Tag Logging

In Tag Logging, the archives, the process values to be archived and the timers for the acquisition and archiving cycles are configured.

In the left side of the WinCC Explorer window, right-click on "Tag Logging".

In the pop-up menu, click on the entry "Open".

Illustration 3.1: WinCC Project "Qckstart"; Tag Logging
3.2 Step 2: Configuring Timers

The timer object is located in second line of the navigation window (the left side of the window). Timers can be configured with either acquisition or archiving cycles.

---

**Note**
Acquisition cycles are time intervals in which the process value of a process tag is read.
Archiving cycles are time intervals in which a process value is stored in the archive database. The archiving cycle is always an integer multiple of the set acquisition cycle. The value stored at each archiving cycle is always the latest one. The first value belongs to the previous interval.

---

If you click on the object “Timers”, all default timers will be displayed in the data window (the right side of the window). Under no circumstances should these default timers be changed. If you want to use a timer that differs from the available default ones, you can configure a new timer.

To, for example, set up a weekly time interval, proceed as follows:

1. Right-click on the object “Timers”.
2. In the pop-up menu, click on the entry “New”.
3. In the dialog box “Timers - Properties”, enter the name “Weekly”.
4. From the drop-down list, select the base “1 Day”.
5. As the factor, enter “7”. You have entered the following information:
Illustration 3.2: WinCC Project "Quickstart": Defining a Timer

**Note**
Acquisition or archiving cycles are derived from the multiplication of the base and the factor.

Confirm your entries by clicking on the button "OK".
3.3 Step 3: Creating an Archive

In Tag Logging, the process value archive is created and the process tags selected with the help of the Archive Wizard.

The Archive Wizard offers an automated and simple method of creating an archive.

- To create an archive, right-click on "Archives" in the navigation window.
- In the pop-up menu, click on the entry "Archive Wizard...".
- In the first dialog box displayed, click on the button "Next".
- In the field "Archive Name", enter the name "TankLevel_Archive".
- Select the archive type "Process Value Archive".

![Illustration 3.3.1: WinCC Project "Qckstart": Archive Wizard - Configuration of the Archive](image)

Click on the button "Next".
Click on the button "Select" and pick the tag "TankLevel" in the following dialog box. Confirm your entries by clicking on the button "OK".

Click on the button "Apply" to complete the configuration with the Archive Wizard.

Illustration 3.3.2: WinCC Project "Qckstart"; Archive Wizard - Tag Selection
3.4 Step 4: Configuring an Archive

In this step, you will configure the process value archive and the archive tag. For the archive tag, you will define when a process value is to be archived.

1. To change the properties of the archive tag selected in the table window, right-click on the table window. Should no tag be selected, the first tag in the table window will be picked.

2. In the pop-up menu, click on the entry "Properties".

   Illustration 3.4.1: WinCC Project "Qckstart"; Displaying Tag Properties

   - Change the name of the archive tag to "TankLevel_Arch".
   - In the "Cycle" area, specify the following values: Acquisition = 1 second; Archiving = 1 * 1 second.
   - Confirm your entries by clicking on the button "OK".

For this project, the process value archive will only be used in runtime. Thus, it is best to store the values in the main memory.

   - In the data window of Tag Logging, double-click on the process value archive "TankLevel_Archive". The dialog box "Process Value Archive Properties" will be opened.
Click on the tab "Memory Location".

Click on "In the Main Memory".

Change the size of the data records to "30". In this project, this size is useful for the later output of a Tag Logging runtime report.

Confirm your entries by clicking on the button "OK".

Illustration 3.4.2: WinCC Project "Qckstart"; Setting the Memory Location

This concludes the configuration of the process value archive. The tag "TankLevel" will be acquired every second and archived as the tag "TankLevel_Arch". The archiving takes place in the main memory and the archived process values are only available while runtime is active.

Click on the button to save the configuration. The settings will become effective the next time runtime is activated.

Close the Tag Logging editor.
3.5 Step 5: Creating a Trend Window

A trend window makes it possible to display process values in trend form. For this, WinCC provides a Control that can be inserted into a process screen.

Create a new screen named “TagLogging.pdl” in the WinCC Explorer and open it in the Graphics Designer.

- In the object palette, select the tab “Controls” and then the “WinCC Online Trend Control”.
- In the drawing space, position the Control with a mouse click and drag it - while keeping the mouse button pressed - to the desired size.
- In the tab “General” of the quick configuration dialog box, enter “TankLevel_Trends” as the title of the trend window.

Illustration 3.5.1: WinCC Project “Qckstart”; General Properties of the Trend Control
Select the tab "Curves".

Enter "TankLevel" as the name of the trend.

Click on the button "Selection".

In the left side of the dialog box "Archive/Tag Selection", double-click on the archive "TankLevel_Archive".

In the right side of the dialog box "Archive/Tag Selection", click on the tag "TankLevel_Arch".

Confirm your entries by clicking on the button "OK".
3.6 Step 6: Creating a Table Window

A table window makes it possible to display process values in tabular form. For this, WinCC provides a Control that can be inserted into a process screen.

1. In the object palette, select the tab "Controls" and then the "WinCC Online Table Control".

2. In the drawing space, position the Control with a mouse click and drag it - while keeping the mouse button pressed - to the desired size.

3. In the tab "General" of the quick configuration dialog box, enter "TankLevel_Tables" as the title of the table window.

Illustration 3.6.1: WinCC Project "Qckstart"; General Properties of the Table Control
Select the tab "Columns".

Enter "TankLevel" as the name of the column.

Click on the button "Selection".

In the left side of the dialog box "Archive/Tag Selection", double-click on the archive "TankLevel_Archive".

In the right side of the dialog box "Archive/Tag Selection", click on the tag "TankLevel_Arch".

Confirm your entries by clicking on the button "OK".

Illustration 3.6.2: WinCC Project "Qckstart"; Properties of the Table
Confirm your entries by clicking on the button “OK”.

Save the screen “TagLogging.pdl” by clicking on the icon and minimize the Graphics Designer.
3.7 Step 7: Defining the Runtime Properties

Next, we will define the runtime properties to allow Tag Logging to be started in runtime.

1. In the left side of the WinCC Explorer window, click on "Computer".

2. In the right side of the WinCC Explorer window, right-click on the name of your computer.

3. In the pop-up menu, click on the entry "Properties".

4. Click on the tab "Startup".

5. Activate the check-box "Tag Logging Runtime".

Illustration 3.7: WinCC Project "Qckstart"; Defining the Runtime Properties

6. Click on the tab "Graphics Runtime".

7. To select a start screen, click on the "Browse" button and select the screen "TagLogging.pdl".

8. Confirm your entries by clicking on the button "OK".
3.8 Step 8: Activating the Project

To see how the trend and table windows look in runtime, click on the WinCC Explorer toolbar button "Activate".

To activate the simulator, go to the Windows taskbar and click on "Start" &gt; "SIMATIC" &gt; "WinCC" &gt; "Tools" &gt; "WinCC Tag Simulator".

Click on "Edit" &gt; "New Tag".

In the dialog box "Tags - Project", select the internal tag "TankLevel" and click on "OK".

In the tab "Properties", click on the simulation mode "Inc".

Enter a start value of "0" and a stop value of "10".

Select the check-box "active".

In the tab "Tags", click on the button "Start Simulation". The table "Tags" will then display the tag "TankLevel" with its changing values.

In WinCC runtime, the trend and table windows will now display the progression of the tag "TankLevel".
Deactivate your WinCC project by clicking on the WinCC Explorer menu bar commands “File” ➔ “Activate”. The check-mark next to "Activate" will disappear.
4 Configuring the Alarm System

This chapter introduces you to the basic components of the alarm system and describes the configuration of an alarm system with the Alarm Logging editor.

Tasks of the Alarm System

Alarms inform the operator about process malfunctions and errors. They help to detect critical situations early and to avoid downtimes.

Components of the Alarm System

The alarm system consists of configuration and runtime components:

The configuration component of the alarm system is the Alarm Logging editor. Alarm Logging is used to define when and what type of an alarm is to be displayed with what content. To display alarms, the Graphics Designer provides the WinCC Alarm Control.

The runtime component of the alarm system is responsible for monitoring the process, controlling the output of alarms and managing their acknowledgements. Alarms are displayed in tabular form.

During the configuration, you will define which events trigger alarms. An event, for example, can be that a certain Bit in a PLC is set or that a process value exceeds a defined limit value.

Configuring the Alarm System

To configure the Alarm Logging, proceed as follows:

1. Open the Alarm Logging editor.
2. Start the System Wizard to create an alarm system.
3. Configure the alarms and the alarm texts.
4. Define the colors for the various states of an alarm.
5. Configure the limit value monitoring of a tag.
6. Insert the alarm window in a process screen.
7. Define the startup parameters.
8. Activate the project.
4.1 Step 1: Opening Alarm Logging

1. In the left side of the WinCC Explorer window, right-click on "Alarm Logging".
2. In the pop-up menu, click on the entry "Open".

Illustration 4.1: WinCC Project "Qckstart"; Alarm Logging
4.2 Step 2: Starting the System Wizard

The System Wizard offers an automated and simple method of creating an alarm system.

To activate the System Wizard, click on "File" ➔ "Select Wizard ...". You can also activate the System Wizard by clicking on the Alarm Logging toolbar button.

In the dialog box "Select Wizard...", double-click on the System Wizard.

In the first dialog box displayed, click on the button "Next".

In the dialog box "System Wizard: Selecting Message Blocks", select the system block "Date, Time, Number" and the user text block "Msg Txt, Error Location".

Illustration 4.2.1: WinCC Project "Qckstart"; System Wizard - Selecting the Alarm Message Blocks

Click on the button "Next".
In the dialog box "System Wizard: Presetting Classes", select the setting "Class of Error with Types Alarm, Failure and Warning (Incoming Acknowledgement)".

![Illustration 4.2.2: WinCC Project "Qckstart"; System Wizard - Presetting Classes]

Click on the button "Next".

In the final dialog box of the System Wizard, a summary of the elements to be created by the Wizard is displayed.

Click on the button "Apply".
4.3 Step 3: Configuring Alarm Messages and Alarm Message Texts

Next, you will configure the messages in the table window of the Alarm Logging editor. Within the framework of this project, you will create three alarm messages. First, the length of the user text blocks created by the Wizard needs to be adjusted.

Changing the Length of the User Text Blocks "Message Text" and "Point of Error"

- In the navigation window, click on the icon before "Message Blocks".
- In the navigation window, click on "User Text Blocks".
- In the data window, right-click on "Message Text".
- In the pop-up menu, click on the entry "Properties".
- In the following dialog box, enter the value "30" and close the dialog box by clicking on "OK".
- In the data window, right-click on "Point of Error".
- In the pop-up menu, click on the entry "Properties".
- In the following dialog box, enter the value "25" and close the dialog box by clicking on "OK".

Configuring the first Alarm Message

In runtime, an event triggers a message by setting a certain Bit of a message tag.

- In line 1 of the table window, double-click on the field "Message Tag".
- In the following dialog box, select the tag "TankLevel" and click on "OK".
- In line 1, double-click on the field "Message Bit".
- Enter the value "2" and confirm the entry. This number indicates that the message in line 1 will be triggered, if the third Bit from the right within the 16-Bit message tag "TankLevel" is set.
- In line 1, double-click on the field "Message Text". You may have to scroll in the table window to reach the column "Message Text".
- Enter the text "Fill Level exceeded" and confirm the entry.
- In line 1, double-click on the field "Point of Error".
- Enter the text "Tank" and confirm the entry.
Configuring the second Alarm Message

1. In the first column of the table window, right-click on the number "1".
2. In the pop-up menu, click on the entry "Add new Line".
3. In line 2, double-click on the field "Message Tag".
4. In the following dialog box, select the tag "TankLevel" and click on "OK".
5. In line 2, double-click on the field "Message Bit".
   - Enter the value "3" and confirm the entry. This number indicates that the message in line 2 will be triggered, if the fourth Bit from the right within the 16-Bit message tag "TankLevel" is set.
6. In line 2, double-click on the field "Message Text".
7. Enter the text "Tank empty" and confirm the entry.
8. In line 2, double-click on the field "Point of Error".
    - Enter the text "Tank" and confirm the entry.

Configuring the third Message

1. In the first column of the table window, right-click on the number "2".
2. In the pop-up menu, click on the entry "Add new Line".
3. In line 3, double-click on the field "Message Tag".
4. In the following dialog box, select the tag "TankLevel" and click on "OK".
5. In line 3, double-click on the field "Message Bit".
   - Enter the value "4" and confirm the entry. This number indicates that the message in line 3 will be triggered, if the fifth Bit from the right within the 16-Bit message tag "TankLevel" is set.
6. In line 3, double-click on the field "Message Text".
7. Enter the text "Pump failed" and confirm the entry.
8. In line 3, double-click on the field "Point of Error".
    - Enter the text "Pump" and confirm the entry.

Note
A newly created alarm in WinCC will be archived by default. Instead of editing each text individually as described above, you can also edit the message texts in the dialog box "Single Message". This dialog box is opened via the entry "Properties" from the pop-up menu of an alarm.
Illustration 4.3: WinCC Project "Quickstart": Configuring Alarm Message Texts

1. Double-click here to enter the message text.
2. Enter the message text.
3. Click OK to save the message.
4.4 Step 4: Configuring the Alarm Message Colors

The states of an alarm can be shown in different colors in runtime. This allows for a quick identification of the alarm by means of the displayed color.

- In the navigation window, click on the icon before "Message Classes".
- Click on the message class "Error".
- In the data window, right-click on "Alarm".
- In the pop-up menu, click on the entry "Properties".

Illustration 4.4.1: WinCC Project "Qckstart"; Configuring the Alarm Message Colors

In the following dialog box, the text and background colors of your alarm messages can be configured based on the state of the alarm.

Configure these colors for your messages of the message type "Alarm":

- In the preview area, click on "Came in" (alarm has been activated).
- Click on the button "Text Color".
- In the color selection dialog box, select the color "White" and click on "OK".
- Click on the button "Background Color".
- In the color selection dialog box, select the color "Red" and click on "OK".
- In the preview area, click on "Went out" (alarm has been deactivated).
- Click on the button "Text Color".
In the color selection dialog box, select the color "Black" and click on "OK".

Click on the button "Background Color".

In the color selection dialog box, select the color "Yellow" and click on "OK".

In the preview area, click on "Acknowledged" (alarm has been acknowledged).

Click on the button "Text Color".

In the color selection dialog box, select the color "White" and click on "OK".

Click on the button "Background Color".

In the color selection dialog box, select the color "Blue" and click on "OK".

Illustration 4.4.2: WinCC Project "Qckstart"; Assigning Alarm Message Colors

Confirm your entries by clicking on the button "OK".
4.5  Analog Alarm

4.5.1  Step 5.1: Configuring the AnalogAlarm of a Tag

With the limit value monitoring, tags can be monitored to ensure that their values stay within the assigned limits.

On the menu bar of the Alarm Logging editor, click on "Tools" → "Add Ins".

In the following dialog box, activate the check-box of the component "AnalogAlarm".

Illustration 4.5.1: WinCC Project "Qckstart"; AnalogAlarm

The AnalogAlarm component will be displayed in the navigation window below the "Message Classes".
In the data window, right-click on "AnalogAlarm".

In the pop-up menu, click on the entry "New".

In the dialog box "Properties", the tag to be monitored and the type of monitoring will be defined.
To select a tag, click on the button ![button](image).

**Illustration 4.5.3: WinCC Project "Qckstart": Configuring the AnalogAlarm**

**Note**

If you activate the check-box "a message for all limit values", the same message will be displayed in runtime regardless of whether the upper or lower limit is violated (you must then specify a message number).

In the delay time field, a delay can be set. An alarm message will then only be displayed after the delay time has expired (this prevents alarms from being displayed, if the limit value violations are only of a very brief duration).
In the dialog box "Tag Selection", select an existing tag or create a new one. For our project, we will create a new tag.

1. In the left side of the tag selection dialog box, click on "Internal Tags" and then on the button to create a new internal tag.

2. In the dialog box "Tag Properties", enter "AnalogAlarm" as the name of the new tag.

3. In the dialog box "Tag Properties", select "Unsigned 16-Bit Value" as the data type.

4. Confirm your entries by clicking on the button "OK".

5. In the right side of the tag selection dialog box, click on "AnalogAlarm".

![Illustration 4.5.4: WinCC Project "Qckstart"; AnalogAlarm - Tag Selection]

1. Click on this button to create a new tag.

2. Click on "Internal Tag" and then on "AnalogAlarm".

Confirm your entries by clicking on the button "OK".

Close the dialog box "Properties" by clicking on the button "OK".
4.5.2 Step 5.2: Setting Limit Values

Setting the Upper Limit Value

1. **R** In the navigation window, right-click on the tag "AnalogAlarm" you created previously.
2. **R** In the pop-up menu, click on the entry "New".

![Illustration 4.5.5: WinCC Project "Qckstart"; Configuring the Limit Values](image-url)
In the dialog box "Properties", activate the radio-button "Upper Limit".

Enter "90" as the limit value.

At "Hysteresis", activate the radio-button "effective for both".

Enter "4" as the message number.

**Note**

To prevent triggering color changes in cases of only minor limit value violations, a tolerance range for the display of the value can be defined with the attribute "Hysteresis". Hysteresis values can be specified as absolute values or percentage values (of the upper or lower limit value).

**Illustration 4.5.6: WinCC Project "Qckstart"; Configuring the Upper Limit Value**

Confirm your entries by clicking on the button "OK".
Setting the Lower Limit Value

Right-click on the tag "AnalogAlarm" you created previously.

In the pop-up menu, click on the entry "New".

In the dialog box "Properties", activate the radio-button "Lower Limit".

Enter "10" as the limit value.

At "Hysteresis", activate the radio-button "effective for both".

Enter "5" as the message number.

Confirm your entries by clicking on the button "OK".

The corresponding messages 4 and 5 will automatically generated by WinCC if they do not already exist. For the automatically generated messages to be displayed, the Alarm Logging editor has to be restarted.

Illustration 4.5.7: WinCC Project "Qckstart"; Generated Message Lines

Click on the button to save the configuration.

Close the Alarm Logging editor.
4.6 Step 6: Creating an Alarm Message Screen

Configuring an Alarm Message Window

In runtime, the alarm messages are displayed in tabular form by a message window. Inserting a message window into a screen is similar to inserting a trend or table display.

Open the Graphics Designer and create a new screen named "AlarmLogging.pdl". Then follow these steps:

1. In the object palette, select the tab "Controls" and then the "WinCC Alarm Trend Control".
2. In the drawing space, position the Control with a mouse click and drag it - while keeping the mouse button pressed - to the desired size.
3. In the quick configuration dialog box, enter "Atlanta Water Supply" as the title of the message window.
4. Activate the check-box "Display".

![Illustration 4.6.1: WinCC Project "Qckstart"; Quick Configuration WinCC Alarm Control]

- Confirm your entries by clicking on the button "OK".
- Double-click on the "WinCC Alarm Control" and select the tab "Message Blocks" from the displayed properties dialog box.
- Click on the type "User Text Blocks". Check whether "Message Text" and "Point of Error" have been activated in the right selection list. If not, activate these check-boxes.
Select the tab "Message Line".
Select the existing message blocks and transfer them to the "Elements of the Message Line" list via the move button.
Confirm your entries by clicking on the button "OK".

Configuring an I/O Field

For the message screen, configure an I/O field and a slider. With them, you can change the value of the tag "AnalogAlarm" in runtime to trigger an alarm for violating the upper or lower limit.

From the object palette, select "Smart Objects" → "I/O Field".
In the drawing space, position the I/O field with a mouse click and then drag it - while keeping the mouse button pressed - to the desired size.

Use the button in the dialog box "I/O Field Configuration" to select the tag to which the I/O field should be linked.
In the field "Update", select the update cycle 500 ms.

Illustration 4.6.2: WinCC Project "Qckstart”; Making the I/O Field dynamic
Confirm your entries by clicking on the button “OK”.

If necessary, adjust the size and position of the I/O field.

Configuring a Slider

From the object palette, select “Windows Objects” “Slider”.

In the drawing space, position the slider with a mouse click and then drag it while keeping the mouse button pressed to the desired size.

Use the button in the dialog box “Slider Configuration” to select the tag to which the slider should be linked.

In the field “Update”, select the update cycle 500 ms.

In the field “Alignment”, click on “horizontal”.

Confirm your entries by clicking on the button “OK”.

If necessary, adjust the size and position of the slider.

Save the screen “AlarmLogging.pdl” by clicking on the icon and minimize the Graphics Designer.
4.7 Step 7: Defining the Runtime Properties

Next, we will define the runtime properties to allow Alarm Logging to be started in runtime.

In the left side of the WinCC Explorer window, click on "Computer".

In the right side of the WinCC Explorer window, right-click on the name of your computer.

In the pop-up menu, click on the entry "Properties".

Click on the tab "Startup".

Activate the check-box "Alarm Logging Runtime". This will also automatically activate the check-box "Text Library Runtime".

Click on the tab "Graphics Runtime".

To select a start screen, click on the "Browse" button and select the screen "AlarmLogging.pdl".

Confirm your entries by clicking on the button "OK".
4.8 Step 8: Activating the Project

- To see how the alarm message window looks in runtime, click on the WinCC Explorer toolbar button "Activate".
- To activate the simulator, go to the Windows taskbar and click on "Start" ➔ "SIMATIC" ➔ "WinCC" ➔ "Tools" ➔ "WinCC Tag Simulator".
- Click on "Edit" ➔ "New Tag".
- In the dialog box "Tags - Project", select the internal tag "TankLevel" and click on "OK".
- In the tab "Properties", click on the simulation mode "Random".
- Enter a minimum value of "0" and a maximum value of "100".
- Select the check-box "active".

If you do not want to control the limit value monitoring of the tag "AnalogAlarm" via the I/O field or the slider, connect this tag to the simulator as well.

- Click on "Edit" ➔ "New Tag".
- Select the internal tag "AnalogAlarm" and click on "OK".
- In the tab "Properties", click on the simulation mode "Inc".
- Enter a start value of "0" and a stop value of "100".
- Select the check-box "active".

- In the tab "Tags", click on the button "Start Simulation". The table "Tags" will then display the tags "TankLevel" and "AnalogAlarm" with their changing values.
WinCC runtime will display the incoming messages in the message window. You can also enter values in the I/O field or move the slider to trigger alarm messages of the monitored tag "AnalogAlarm". For this, the tag "AnalogAlarm" has to be deleted from the "Edit" menu.

Illustration 4.8: WinCC Project "Qckstart": Alarm Message Window in Runtime

In runtime, the incoming messages can be viewed by clicking on the message window toolbar button "Message List".

To acknowledge an individual message, click on the toolbar button "Single Acknowledgement".

Group messages are acknowledged via the button "Group Acknowledgement".

To view a list of the archived messages, click on the button "Short-Term Archive".
5 Outputting an Alarm Message Sequence Report

This chapter introduces you to the basic components of the Report Designer and describes the creation of an alarm message sequence report aided by a template. The subject of issuing print jobs will also be addressed.

Tasks of the Report System

Message events can be archived on paper in the form of a message sequence report. The printout can take place by page or by line. Preconfigured reports are available. For this project, you will create a new project. The layout for the report is created with the page layout editor of the Report Designer.

Components of the Report System

The report system consists of configuration and runtime components:

The configuration component of the report system is the Report Designer. The Report Designer is used to adapt ready-made default layouts to your requirements or to create new layouts. For the output, each layout has to be linked to a print job. With the Report Designer, the print jobs initiating the output are configured as well.

The runtime component of the report system fetches the data to be printed from the archives or Controls and manages the printer output.

Configuring an Alarm Message Sequence Report

To publish a message sequence report, proceed as follows:

1. Create a page layout.
2. Edit the page layout.
3. Configure the print job.
4. Define the startup parameters.
5. Activate the project.
5.1 Step 1: Creating a Page Layout

In the left side of the WinCC Explorer window, right-click on "Report Designer".

In the pop-up menu, click on the entry "New page layout".

Illustration 5.1.1: WinCC Project "Qckstart"; Opening a Page Layout

A new layout named "NewRPL0.RPL" will be created in the folder "Layouts".

In the right side of the WinCC Explorer window, double-click on entry "Layouts". The new layout can be found at the end of the list.

To rename the layout, right-click on "NewRPL0.rpl".

In the pop-up menu, click on the entry "Rename Layout".

In the following dialog box, enter the name "MessageSequenceReport.rpl".
5.2 The Page Layout Editor

Introduction

The page layout editor is a component of the Report Designer and provides objects and tools for creating page layouts.

Structure of the Page Layout Editor

The page layout editor follows the conventions set by Windows. It possesses a workspace, toolbars, menu bar, status bar and various palettes. After opening the page layout editor, the workspace is displayed with the default settings. You can arrange the palettes and bars to your liking and also hide them.

Illustration 5.1.2: WinCC Project "Qckstart"; Page Layout Editor

(1) The Workspace

The gray area represents the printable area, the white area the page body. Each screen in the workspace represents a layout and is saved as a separate rpl-file. The layouts can be enlarged and reduced according to the Windows standard.
(2) The Menu Bar

   The menu bar is always visible. Depending on the context, the functions in the menus are active or inactive.

(3) The Toolbar

   The toolbar provides buttons to quickly perform common commands of the page layout editor. The toolbar can be hidden if required or moved to any location on the screen.

(4) The Font Palette

   The font palette is used to change font type, size and color of text objects as well as the line color of standard objects.

(5) The Object Palette

   The object palette contains the standard objects, objects for the runtime documentation, COM server objects and objects for the project documentation. The objects are used to form a layout.

(6) The Style Palette

   The style palette is used to change the appearance of a selected object. Depending on the object, the line type, line strength or fill pattern can be changed.

(7) The Alignment Palette

   The alignment palette is used to change the absolute position of one or more objects, change the position of selected objects relative to each other or unify the height and width of several objects.

(8) The Zoom Palette

   The zoom palette offers two options to enlarge or reduce the objects of the active layout: either via buttons of default zoom factors or via a slider.

(9) The Color Palette

   The color palette is used to color selected objects. In addition to the 16 standard colors, custom colors can be defined.

(10) The Status Bar

   The status bar is located at the bottom of the screen and can be hidden if required. Among other things, it displays tips, information about the position of the selected objects and the keyboard setting.
5.3 Step 2: Editing the Page Layout

The layouts contain a static and a dynamic layer. The static layer contains the header and the footer of the layout for outputting the company name, page number, time, etc. The dynamic layer contains the dynamic objects for outputting the configuration and runtime data.

In the static layer, only static and system objects can be inserted. In the dynamic layer, static and dynamic objects can be inserted.

In the right side of the WinCC Explorer window, double-click on the just created layout “MessageSequenceReport.rpl”.

The page layout editor will open with a blank page. When creating the layout, you are not bound to a predetermined order.

In the tab “Runtime Documentation” of the object palette, select the object “Message Report” from the folder “Alarm Logging RT”.

In the dynamic section of the page layout, drag the object to the desired size.

Open the object properties dialog box by double-clicking on the object and select the tab “Connect”.

In the list of possible actions, double-click on the entry “Selection”. The dialog box “Alarm Logging Runtime: Report Table Selection” will open.

Illustration 5.2.1: WinCC Project “Qckstart”; Connecting a dynamic Table
Make sure that the field "Current Column Sequence" contains all message blocks that are to be printed in the message sequence report.

To make the width of the message blocks fit onto a DIN A4 page, we will need to change the column width of the message blocks "Number" and "Point of Error".

Select the message block "Number" and then click on the button "Properties". Enter the value "9" in the field "Number of Places". Do the same for the message block "Point of Error". Enter the value "20" in the field "Length".

Click on the button "OK".
In the dialog box "Object Properties", click on the tab "Properties".

Click on the icon \( \text{mutex} \) to pin down the dialog box.

To edit the properties of the layout, click on a blank space outside of the table.

In the left side of the dialog box, click on "Geometry" and make sure that the page format "A4" is selected in the right side.

Illustration 5.2.3: WinCC Project "Qckstart"; Properties of the Layout

If this is not the case, double-click on "Page Format".

In the following dialog box, select the paper size "A4" and click on "OK".

Save the layout by clicking on the icon \( \text{save} \).

Close the page layout editor.
5.4 Step 3: Configuring the Print Job

To print out the report in runtime, the print job needs to be configured in the WinCC Explorer.

In the left side of the WinCC Explorer window, click on the entry "Print Jobs". The right side of the window will then display a list of preconfigured print jobs.

In the right side of the window, double-click on the print job "@Report Alarm Logging RT Message Sequence". The dialog box "Print Job Properties" will open.

Select the layout "MessageSequenceReport.rpl" from the drop-down list.

Illustration 5.3.1: WinCC Project "Ockstart"; Defining the Print Job Properties

Note
If the check-box "Line Layout for Line Printer" is activated, the above layout cannot be selected. Deactivate the check-box to output the message sequence report for this project in page format.
Select the tab "Printer Setup".

Select your printer from the drop-down list.

Confirm your entries by clicking on the button "OK".

Now, the message window needs to be linked to the configured print job. Your configured layout will then be used in runtime, if the toolbar button "Print" is clicked on.

Open the screen "AlarmLogging.pdl" in the Graphics Designer.

Double-click on the "WinCC Alarm Control" and select the tab "General" from the displayed properties dialog box.

Click on to select the print job from the list.

Illustration 5.3.2: WinCC Project "Qckstart"; Defining the Print Job

Confirm your entries by clicking on the button "OK".

Save the screen "AlarmLogging.pdl" by clicking on the icon and minimize the Graphics Designer.
5.5 Step 4: Defining the Runtime Properties

Next, we will define the runtime properties to allow the Report Designer to be started in runtime.

1. In the left side of the WinCC Explorer window, click on "Computer".
2. R In the right side of the WinCC Explorer window, right-click on the name of your computer.
3. In the pop-up menu, click on the entry "Properties".
4. Click on the tab "Startup".
5. Activate the check-box "Report Runtime".

![Computer properties window](image)

*Illustration 5.4: WinCC Project "Qckstart"; Defining the Runtime Properties*

6. Confirm your entries by clicking on the button "OK".
5.6  Step 5: Activating the Project

To print out the alarm message sequence report in runtime, click on the WinCC Explorer toolbar button "Activate".

To activate the simulator, go to the Windows taskbar and click on "Start" → "SIMATIC" → "WinCC" → "Tools" → "WinCC Tag Simulator".

Click on "Edit" → "New Tag".

In the dialog box "Tags - Project", select the internal tag "TankLevel" and click on "Ok".

In the tab "Properties", click on the simulation mode "Random".

Enter a minimum value of "0" and a maximum value of "100".

Select the check-box "active".

In the tab "Tags", click on the button "Start Simulation". The table "Tags" will then display the tag "TankLevel" with its changing values.

In the message window, click on the button "Message List" to view the list of incoming messages.

Enter appropriate values in the I/O field to also trigger alarm messages of the monitored tag "AnalogAlarm".

To start the printout of the messages displayed in the message window, click on the button . The print job you have set up will start.

Illustration 5.5: WinCC Project "Qckstart"; Alarm Message Window in Runtime
6 Outputting a Tag Logging Runtime Report

This chapter shows you how to create a report that outputs Tag Logging runtime data in a table. In runtime, you will use the "Preview Print Job" function.

Configuring a Tag Logging Runtime Report

In runtime, you can print out the Tag Logging runtime data from the table window. If you click on the runtime toolbar button "Print", the preconfigured layout "@CCTableControlContents.rpl" will be used. For this project, however, you will create a user-defined page layout with a header and a footer.

To create a Tag Logging runtime report, proceed as follows:

1. Edit the static section of the layout.
2. Edit the dynamic section of the layout.
3. Define the print job parameters.
4. Activate the project.
6.1 Editing the Page Layout

6.1.1 Step 1: Editing the Static Section

Create a new page layout and name it "TagLogging.rpl". Proceed as described in the chapter "Creating a Page Layout".

In the right side of the WinCC Explorer window, double-click on the just created layout "TagLogging.rpl".

The page layout editor will open with a blank page.

First, we will add the elements of the static section - the date/time, page number, layout name and project name.

Click on the toolbar button to edit the static section of the layout.

To display the date and the time in the layout, click on the object palette's "System Objects" → "Date/Time".

Position the object in the upper left corner drag it to the desired size while keeping the mouse button pressed.

Right-click on the object "Date/Time".

In the pop-up menu, click on the entry "Properties".

Click on the icon to pin down the dialog box.

Make sure that you are in the tab "Properties". In the left side of the window, click on "Font".

In the right side of the window, double-click on "X Alignment" and select "Left".

In the right side of the window, double-click on "Y Alignment" and select "Centered".

Follow the above steps and add the system object "Project Name". With regard to the alignment, make the same changes as for the object "Date/Time".

Continue by adding the system objects "Page Number" and "Layout Name" to the upper right corner. Change the "X Alignment" to "Right" and the "Y Alignment" to "Centered".

You can change more attributes to improve the appearance. For example, you can remove the frame around the inserted system objects.

Select the system object to be changed and click on "Styles" in the left side of the tab "Properties".

In the right side, double-click on "Line Type" and select "Without Line" from the drop-down list.
6.1.2 Step 2: Editing the Dynamic Section

- Click on the toolbar button to edit the dynamic section of the layout.
- In the tab "Runtime Documentation" of the object palette, select the object "Tag Table" from the folder "Tag Logging RT".
- In the dynamic section of the page layout, drag the object to the desired size.
- Open the object properties dialog box by double-clicking on the object and select the tab "Connect".
- In the right side of the tab "Connect", click on "Tag Selection" and then on the button "Edit".

Illustration 6.2.1: WinCC Project "Qckstart"; Connecting a Tag
In the dialog box "Tag Logging Runtime: Tag Selection for Reporting", click on the button "Add...".

In the left side of the dialog box "Archive Selection", click on the icon before "Qckstart" or the computer name.

In the left side, select the archive "TankLevel_Archive".

In the right side, select the tag "TankLevel_Arch".

Illustration 6.2.2: WinCC Project "Qckstart": Adding a Tag

Confirm your entries by clicking on the button "OK".

For the output of the runtime data, the values of the tag need to be formatted.

In the dialog box "Tag Logging Runtime: Tag Selection for Reporting", click on the added archive tag.

Click on the button "Properties".
Select the format "Integer". For the number of digits, enter the value "3", and for the decimal places, the value "0".

Select an output format of three digits and the number of decimal places of zero digits.

Confirm your entries by clicking on the button "OK".

Confirm your entries by clicking on the button "OK".
Select the tab “Properties”.

Click on the icon.

To edit the properties of the layout, right-click on a blank space outside of the table.

In the left side of the dialog box, click on “Geometry” and make sure that the page format “A4” is selected in the right side.

If this is not the case, double-click on “Page Format”.

In the following dialog box, select the paper size “A4” and click on “OK”.

Save the layout by clicking on the icon.

Close the page layout editor.
6.2 Step 3: Defining the Print Job Parameters

To print out the Tag Logging runtime report, the print job parameters need to be defined in the WinCC Explorer.

- In the left side of the WinCC Explorer window, right-click on "Print Jobs".
- In the right side of the WinCC Explorer window, right-click on the print job "Report Tag Logging RT Tables New".
- In the pop-up menu, click on the entry "Properties".
- Select the layout "TagLogging.rpl" from the drop-down list.
- Activate the check-box "Start Time".

![Illustration of WinCC Project "Qckstart"; Defining the Print Job Properties]

- Select the tab "Printer Setup".
- Select your printer from the drop-down list.
- Confirm your entries by clicking on the button "OK".
6.3 Step 4: Activating the Project

Before activating the project, the screen with the process values has to be set as the start screen of the runtime.

1. In the left side of the WinCC Explorer window, click on "Computer".
2. In the right side of the WinCC Explorer window, right-click on the name of your computer.
3. In the pop-up menu, click on the entry "Properties".
4. Click on the tab "Graphics Runtime".
5. To select the start screen, click on the "Browse" button and select the screen "TagLogging.pdl".
6. Confirm your entries by clicking on the button "OK".
7. To output the report in runtime, click on the WinCC Explorer toolbar button "Activate".
8. To activate the simulator, go to the Windows taskbar and click on "Start" ➔ "SIMATIC" ➔ "WinCC" ➔ "Tools" ➔ "WinCC Tag Simulator".
9. Select the internal tag "TankLevel" as the tag to be simulated and click on "OK".
10. In the tab "Properties", click on the simulation mode "Inc".
11. Enter a start value of "0" and a stop value of "10".
12. Select the check-box "active".
13. In the tab "Tags", click on the button "Start Simulation". The table "Tags" will then display the tag "TankLevel" with its changing values.

In WinCC runtime, the trend and table windows will now display the progression of the tag "TankLevel".

14. Click on the WinCC Explorer on the Windows taskbar.
15. Right-click on the print job "@Report Tag Logging RT Tables New" that you have configured previously.
In the pop-up menu, click on the entry “Preview Print Job”.

Illustration 6.4.1: WinCC Project “Qckstart”; Preview of a Print Job

In the preview, you can change the display via the buttons “Zoom In”, “Zoom Out” or “Two Pages”.

Illustration 6.4.2: WinCC Project “Qckstart”; Preview of a Print Job

To print out the print job, click on the button “Print”.

Illustration 6.4.3: WinCC Project “Qckstart”; Preview of a Print Job
Index

<table>
<thead>
<tr>
<th>A</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activating</td>
<td>Graphics Designer</td>
</tr>
<tr>
<td>Activating the Project</td>
<td>Alignment Palette</td>
</tr>
<tr>
<td>Adding a Communication Driver</td>
<td>Color Palette</td>
</tr>
<tr>
<td>Adding a PLC Driver</td>
<td>Font Palette</td>
</tr>
<tr>
<td>Alarm Control</td>
<td>Layer Palette</td>
</tr>
<tr>
<td>Alarm Logging</td>
<td>Menu Bar</td>
</tr>
<tr>
<td>Opening Alarm Logging</td>
<td>Object Palette</td>
</tr>
<tr>
<td>Analog Alarm</td>
<td>Opening</td>
</tr>
<tr>
<td>Monitored Tag</td>
<td>Style Palette</td>
</tr>
<tr>
<td>Setting Limit Values</td>
<td>Toolbar</td>
</tr>
<tr>
<td>Authorization</td>
<td>Toolbars displayed</td>
</tr>
<tr>
<td>Installation</td>
<td>Zoom Palette</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>C</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>Communication Drivers</td>
<td>Hardware</td>
</tr>
<tr>
<td>Configuring a Slider</td>
<td>Requirements</td>
</tr>
<tr>
<td>Configuring Acquisition Timers</td>
<td></td>
</tr>
<tr>
<td>Configuring Alarm Message Colors</td>
<td></td>
</tr>
<tr>
<td>Configuring Alarm Message Texts</td>
<td></td>
</tr>
<tr>
<td>Configuring Alarms</td>
<td></td>
</tr>
<tr>
<td>Configuring Archiving Timers</td>
<td></td>
</tr>
<tr>
<td>Configuring User Text Blocks</td>
<td></td>
</tr>
<tr>
<td>Connecting the Dynamic Table</td>
<td></td>
</tr>
<tr>
<td>Creating a Button</td>
<td></td>
</tr>
<tr>
<td>Creating a Page Layout</td>
<td></td>
</tr>
<tr>
<td>Creating a Process Tag</td>
<td></td>
</tr>
<tr>
<td>Creating a Project</td>
<td></td>
</tr>
<tr>
<td>Creating a Static Text</td>
<td></td>
</tr>
<tr>
<td>Creating an Alarm Message Window</td>
<td></td>
</tr>
<tr>
<td>Creating an Alarm System</td>
<td></td>
</tr>
<tr>
<td>Creating an Archive</td>
<td></td>
</tr>
<tr>
<td>Creating an Internal Tag</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>D</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>Defining the Print Job Parameters</td>
<td></td>
</tr>
<tr>
<td>Defining the Runtime Properties</td>
<td></td>
</tr>
<tr>
<td>Defining the Runtime Properties</td>
<td></td>
</tr>
<tr>
<td>Deinstallation</td>
<td></td>
</tr>
<tr>
<td>Perform</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>E</th>
<th>M</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing the Layout</td>
<td>Making an Object dynamic</td>
</tr>
<tr>
<td>Event</td>
<td>Making the Fill Level Display dynamic</td>
</tr>
<tr>
<td></td>
<td>Message</td>
</tr>
<tr>
<td></td>
<td>Message Archive</td>
</tr>
<tr>
<td></td>
<td>Long-Term Archive</td>
</tr>
<tr>
<td></td>
<td>Short-Term Archive</td>
</tr>
<tr>
<td></td>
<td>Message Class</td>
</tr>
<tr>
<td></td>
<td>Microsoft Message Queuing Services</td>
</tr>
<tr>
<td></td>
<td>Microsoft SQL Server 2000</td>
</tr>
<tr>
<td>Index</td>
<td>07.03</td>
</tr>
<tr>
<td>-------</td>
<td>------</td>
</tr>
<tr>
<td><strong>MS Message Queuing Services</strong></td>
<td>10</td>
</tr>
<tr>
<td><strong>O</strong></td>
<td></td>
</tr>
<tr>
<td>Online Table Control</td>
<td>67</td>
</tr>
<tr>
<td>Online Trend Control</td>
<td>65</td>
</tr>
<tr>
<td>Opening the Page Layout</td>
<td>99, 108</td>
</tr>
<tr>
<td>Operating</td>
<td>5</td>
</tr>
<tr>
<td>Operating System Requirements</td>
<td>5</td>
</tr>
<tr>
<td>Outputting a Tag Logging Runtime Report</td>
<td>107</td>
</tr>
<tr>
<td><strong>P</strong></td>
<td></td>
</tr>
<tr>
<td>Pinning down the Object Properties Window</td>
<td>47</td>
</tr>
<tr>
<td>Print</td>
<td>113</td>
</tr>
<tr>
<td>Print Job</td>
<td></td>
</tr>
<tr>
<td>Preview</td>
<td>114</td>
</tr>
<tr>
<td>Printing out Process Values</td>
<td>107</td>
</tr>
<tr>
<td>Process Screen Configuring the Process Screen</td>
<td>45</td>
</tr>
<tr>
<td>Creating Process Screens</td>
<td>37</td>
</tr>
<tr>
<td>Process Screen Creation</td>
<td>21</td>
</tr>
<tr>
<td>Process Value</td>
<td>57</td>
</tr>
<tr>
<td>Creating a Table Window</td>
<td>67</td>
</tr>
<tr>
<td>Creating a Trend Window</td>
<td>65</td>
</tr>
<tr>
<td>Displaying Process Values</td>
<td>57</td>
</tr>
<tr>
<td>Process Value Archive</td>
<td>61</td>
</tr>
<tr>
<td>Creating an Archive</td>
<td>61</td>
</tr>
<tr>
<td>Program</td>
<td>5</td>
</tr>
<tr>
<td>Program Group Icons of the Program Group</td>
<td>5</td>
</tr>
<tr>
<td><strong>R</strong></td>
<td></td>
</tr>
<tr>
<td>Report Designer</td>
<td>97</td>
</tr>
<tr>
<td>Alignment Palette</td>
<td>97</td>
</tr>
<tr>
<td>Color Palette</td>
<td>97</td>
</tr>
<tr>
<td>Font Palette</td>
<td>97</td>
</tr>
<tr>
<td>Menu Bar</td>
<td>97</td>
</tr>
<tr>
<td>Object Palette</td>
<td>97</td>
</tr>
<tr>
<td>Style Palette</td>
<td>97</td>
</tr>
<tr>
<td>Toolbar</td>
<td>97</td>
</tr>
<tr>
<td>Zoom Palette</td>
<td>97</td>
</tr>
<tr>
<td>Requirements Operating System Software</td>
<td>5, 8</td>
</tr>
<tr>
<td><strong>S</strong></td>
<td></td>
</tr>
<tr>
<td>Scaling</td>
<td>25</td>
</tr>
<tr>
<td>Select Components</td>
<td>16</td>
</tr>
<tr>
<td><strong>T</strong></td>
<td></td>
</tr>
<tr>
<td>Table Window Creating a Table Window Preview</td>
<td>67</td>
</tr>
<tr>
<td>Tag</td>
<td>28</td>
</tr>
<tr>
<td>Creating a Process Tag</td>
<td>33</td>
</tr>
<tr>
<td>Creating an Internal Tag</td>
<td>29</td>
</tr>
<tr>
<td>Linear Scaling</td>
<td>33</td>
</tr>
<tr>
<td>Tag Properties</td>
<td>25, 29</td>
</tr>
<tr>
<td>Tag Groups</td>
<td>25, 31</td>
</tr>
<tr>
<td>Tag Logging</td>
<td>57, 58</td>
</tr>
<tr>
<td>Opening Tag Logging</td>
<td>58</td>
</tr>
<tr>
<td>Tag Management</td>
<td>25, 29</td>
</tr>
<tr>
<td>Tag Simulator</td>
<td>55</td>
</tr>
<tr>
<td>Using the Simulator</td>
<td>55</td>
</tr>
<tr>
<td>Tags</td>
<td>28</td>
</tr>
<tr>
<td>Trend Window</td>
<td>65</td>
</tr>
<tr>
<td>Creating a Trend Window</td>
<td>65</td>
</tr>
<tr>
<td>Preview</td>
<td>65</td>
</tr>
<tr>
<td><strong>U</strong></td>
<td></td>
</tr>
<tr>
<td>User Registration Installation</td>
<td>14</td>
</tr>
<tr>
<td><strong>W</strong></td>
<td></td>
</tr>
<tr>
<td>WinCC</td>
<td></td>
</tr>
<tr>
<td>Microsoft SQL Server 2000 Installation</td>
<td>12</td>
</tr>
<tr>
<td>Perform Deinstallation</td>
<td>19</td>
</tr>
<tr>
<td>Requirements for the Installation</td>
<td>8</td>
</tr>
<tr>
<td>WinCC Instance</td>
<td>12</td>
</tr>
<tr>
<td>Windows</td>
<td>8</td>
</tr>
<tr>
<td>Microsoft Message Queuing Services</td>
<td>10</td>
</tr>
<tr>
<td>Windows 2000</td>
<td>8</td>
</tr>
<tr>
<td>Windows Event Viewer</td>
<td>19</td>
</tr>
<tr>
<td>Windows XP</td>
<td>8</td>
</tr>
</tbody>
</table>