Multiproject / Multiuser engineering

SIMATIC PCS 7 V8.1

Warranty and liability

Note

The Application Examples are not binding and do not claim to be complete regarding the circuits shown, equipping and any eventuality. The Application Examples do not represent customer-specific solutions. They are only intended to provide support for typical applications. You are responsible for ensuring that the described products are used correctly. These Application Examples do not relieve you of the responsibility to use safe practices in application, installation, operation and maintenance. When using these Application Examples, you recognize that we cannot be made liable for any damage/claims beyond the liability clause described. We reserve the right to make changes to these Application Examples at any time without prior notice. If there are any deviations between the recommendations provided in these Application Examples and other Siemens publications – e.g. Catalogs – the contents of the other documents have priority.

We do not accept any liability for the information contained in this document. Any claims against us – based on whatever legal reason – resulting from the use of the examples, information, programs, engineering and performance data etc., described in this Application Example shall be excluded. Such an exclusion shall not apply in the case of mandatory liability, e.g. under the German Product Liability Act (“Produkthaftungsgesetz”), in case of intent, gross negligence, or injury of life, body or health, guarantee for the quality of a product, fraudulent concealment of a deficiency or breach of a condition which goes to the root of the contract (“wesentliche Vertragspflichten”). The damages for a breach of a substantial contractual obligation are, however, limited to the foreseeable damage, typical for the type of contract, except in the event of intent or gross negligence or injury to life, body or health. The above provisions do not imply a change of the burden of proof to your detriment.

Any form of duplication or distribution of these Application Examples or excerpts hereof is prohibited without the expressed consent of the Siemens AG.

Security information

Siemens provides products and solutions with industrial security functions that support the secure operation of plants, systems, machines and networks. In order to protect plants, systems, machines and networks against cyber threats, it is necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial security concept. Siemens’ products and solutions only form one element of such a concept.

Customer is responsible to prevent unauthorized access to its plants, systems, machines and networks. Systems, machines and components should only be connected to the enterprise network or the internet if and to the extent necessary and with appropriate security measures (e.g. use of firewalls and network segmentation) in place. Additionally, Siemens’ guidance on appropriate security measures should be taken into account. For more information about industrial security, please visit http://www.siemens.com/industrialsecurity.

Siemens’ products and solutions undergo continuous development to make them more secure. Siemens strongly recommends to apply product updates as soon as available and to always use the latest product versions. Use of product versions that are no longer supported, and failure to apply latest updates may increase customer’s exposure to cyber threats.

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed under http://www.siemens.com/industrialsecurity.
Preface

This document provides an overview of the different variants and the positioning of multiproject and multiuser engineering.

Multiproject engineering allows systems to be configured flexibly and at several locations. To facilitate this, the automation solution is divided technologically into several projects. The projects are created in a multiproject on a central engineering station. Besides the projects, even the master data library, containing all the shared objects, is managed here. Single AS projects pertaining to the multiproject can be temporarily transferred to other ES for distributed processing.

Figure 0-1-1: Multiproject engineering

Furthermore, **multiuser engineering** offers the possibility of working in parallel on the same user program (CFC/SFC of an AS project) or OS project (various process pictures, reports). This saves valuable time. The project in question may remain at its storage location. Multiple engineering stations may be opened and edited simultaneously via network.

Figure 0-1-2: Multiuser engineering

Both concepts are basically independent, but they combine to form efficient and flexible engineering.
## Table of contents

Warranty and liability........................................................................................................... 2

Preface .................................................................................................................................... 3

1 Multiuser engineering ........................................................................................................ 5
   1.1 General.......................................................................................................................... 5
   1.2 System requirements ................................................................................................... 7
   1.3 Project structures ....................................................................................................... 9
      1.3.1 Basic requirements............................................................................................... 10
      1.3.2 Station-specific structure .................................................................................. 11
      1.3.3 Project-specific structure .................................................................................. 13
   1.4 Distributed project archive ....................................................................................... 15
      1.4.1 Division with network connection ...................................................................... 16
      1.4.2 Division without network connection ................................................................ 17
      1.4.3 Distributing the multiuser project without network connection ....................... 18
   1.5 Distributed editing ..................................................................................................... 19
      1.5.1 Project planning .................................................................................................... 20
      1.5.2 Project set-up work ............................................................................................. 21
      1.5.3 Dividing the projects .......................................................................................... 26
      1.5.4 Distributed project editing ................................................................................ 31
      1.5.5 Merging the projects .......................................................................................... 32
      1.5.6 Final project work ............................................................................................... 34

2 Multiuser engineering ........................................................................................................ 37
   2.1 Function mechanisms ............................................................................................... 37
   2.2 Overview of the configuration steps ......................................................................... 40
   2.3 Working in parallel ..................................................................................................... 42
      2.3.1 Charts (CFC/SFC) ............................................................................................ 44
      2.3.2 Process object view ............................................................................................ 47
      2.3.3 NetPro .............................................................................................................. 48
      2.3.4 HW Config ......................................................................................................... 49
      2.3.5 Symbol table ...................................................................................................... 50
      2.3.6 Process Device Manager (SIMATIC PDM) ....................................................... 51
      2.3.7 Additional ES components ............................................................................... 53
      2.3.8 OS project .......................................................................................................... 54
      2.3.9 Parallel AS and OS engineering ....................................................................... 60
      2.3.10 Compiling and downloading objects ............................................................... 61

3 Higher-level topics............................................................................................................ 63
   3.1 Central control station for several PCS 7 systems ................................................... 63
   3.2 Licensing .................................................................................................................... 64
   3.3 Archiving .................................................................................................................... 65
   3.4 Remote access to the Engineering Server .............................................................. 66

4 Literature .......................................................................................................................... 67
   4.1 Internet links .............................................................................................................. 67
   4.2 Related documents .................................................................................................... 67

5 History............................................................................................................................... 68
1 Multiproject engineering

1.1 General

The multiproject functionality of SIMATIC PCS 7 offers the possibility of configuring systems in a flexible and performant manner. The focus lies on the time-saving, parallel editing of projects that can be managed, separated and merged with the help of the system.

Principle of the multiproject

The multiproject is a higher-level structure in the SIMATIC Manager of the central engineering server. It includes all projects of an automation solution with their subordinate objects (Automation Systems (AS), Operator Stations (OS), programs, charts, etc.) as well as the master data library.

To edit the included projects, they are distributed to Engineering Stations (ES). The engineering process is optimized by making use of additional memory resources and computing performance. The projects may remain in the multiproject or be removed for the duration of the editing. The Engineering server where the multiproject is stored, also represents a fully-fledged engineering station which allows the editing of a project or the master data library.

Figure 1-1

Despite the distributed storage, the projects can contain cross-project relationships, such as S7 connections.
Benefits of the multiproject

If projects are part of a multiproject, they can be created with a smaller size and clearer structure. Cross-project mechanisms ensure that a multiproject can be used almost like a single project.

Examples of such cross-project mechanisms include:

- Master data library for the central data storage of block types, process tag types and sample solutions for all projects
- Synchronization of the plant hierarchy across all projects or for selected projects
- Taking all related AS and OS components in the entire multiproject into account with the functions "Create/update block icons" and "Generate/update diagnostics screens" (with PH structures having the same name)
- Merging subnets and connections with textual references from all included projects
- OS compilation with configuration data from several projects
- Save as (copy of the multiproject with all projects)
- Archiving (ZIP archive of the multiproject including all projects)

Note

In the context of PCS 7, is always recommended to create a multiproject with the master data library, even if only one project is contained.
1.2 System requirements

Engineering Server

- For performance reasons, we recommend that you use a supported Windows Server operating system on the engineering server.
- The project engineers of the distributed engineering stations must have the proper write permissions set up on the Engineering Server and especially on the project folder.
- No administrator rights are required for engineering activities. These are only required for the installation of software, and for setting up and customizing the operating system. The exact user rights for a PCS 7 system are described in the manual "PCS 7 PC Configuration".
- Parts of the configuration data of STEP 7 are stored in a database, while access to this data is executed and coordinated on the Sybase server. It is therefore absolutely necessary to have a Sybase server up and running. After installing STEP 7, the Sybase server runs in the context of the logged-in user and starts automatically when the user logs in. To circumvent the constraint of a logged-in user on the Engineering Server, you can set up the Sybase server as a service using the application "setsybserv.exe". The procedure is described in the manual "PCS 7 PC Configuration".
- Similarly, for performance reasons we recommend that you use PCs with a high clock speed, larger memory and faster disk drive (e.g. SSD) for the engineering stations. You can find further information about the recommended hardware configuration in the Readme "PCS 7 Readme V8.1 (Online)."
- Similarly, for performance reasons, we recommend you to reduce the SQL database file (*.ldf) size of the OS project. You can find further instructions in the article "How do you reduce the size of the transaction file (*.LDF) of the database of a WinCC project?" [https://support.industry.siemens.com/cs/de/en/view/37333378](https://support.industry.siemens.com/cs/de/en/view/37333378)

Distributed engineering stations

- All engineering stations must have the same PCS 7 version and the same options as on the Engineering Server.
- With regard to the HW Config and PDM, the same field device descriptions must be integrated in all engineering stations.
- Licenses are either installed locally or else one can use unallocated licenses, which can be accessed via network. (License type: "floating"). The floating licenses can be stored on the engineering server or on an additional license server. In order to test OS functions, the RT licenses must be installed locally. For the simultaneous use of an editor on several engineering stations, the appropriate license is required several times.

Network structure

- To load the AS or test OS functions, the relevant engineering stations must be directly connected to the system bus. (Routing through the Engineering Server is not possible).
- There must be a stable network connection between the participating engineering stations. All stations must see each other in the network neighborhood or in the SIMATIC shell.
1 Multiproject engineering
1.2 System requirements

- Especially for parallel work with multiuser engineering, it is recommended to design the network between the engineering stations as a Gigabit Ethernet.
- To avoid unnecessary network traffic, we recommend using a WINS server or keeping the LMHOSTS files for name resolution.
- The project path under "Storage location for projects/multiprojects" is set by default to "SIEMENS\STEP7\S7Proj" and all necessary access rights are set for this project path. If you use a different project path, you need to set the necessary access rights with the tool "SimaticRights.exe". To do this, start open the SIMATIC PCS 7 DVD 2/2 and run the program "SimaticRights.exe" located in the folder "Additional_Products\SimaticRights" by selecting "RUN as Administrator". Enter the new project path in the dialog or select it. The new project path must be available when the tools are started.

Figure 1-2: Properties of the released project after using SIMATIC Rights
1.3 Project structures

In the structure of a multiproject, a distinction is made between the project-specific and the station-specific structure.

In practice, it often makes sense to have a combination of both types, as shown in the following example picture:

Figure 1-3

![Diagram showing multiproject structure]

Note

1.3.1 Basic requirements

In order to carry out the subsequent project work as rationally as possible, some preliminary considerations are necessary.

With regard to the issue of how to properly separate the overall task in part configurations, one must consider individual conditions of the project itself, as well as those of the available engineering environment. Here are a few examples:

- **Number of project engineers**: How many automation systems must be configured and in what time? Where can ratio effects be used when configuring?

- **The number of available engineering stations**: Each project engineer who is responsible for one or several automation systems, has an ES available.

- **Networking of the engineering stations**: Normally, all engineering stations should be connected consistently to each other via the terminal bus.

- **Project complexity**: How many areas should be automated in the multiproject. In how many buildings will there be an ES or an OS server positioned at a later stage? Which automation systems are assigned to which OS server

- **Configuration duration/effort**: The duration can be controlled by the number of planned project engineers.

The following rules apply:

- Only those project components (AS, OS), which are required for the respective distributed processing should be temporarily moved to a distributed ES.

- Only entire projects can be moved to a distributed ES. If you want to edit and test individual sections of the plant hierarchy separately from the project, you can apply the "Branch and merge" concept (refer to the PCS 7 Engineering System manual).

- An ES is defined for each operator station, which allows the OS to be compiled and the OS project to be downloaded.

Based on these considerations and the background information from the above comparison, the structure of the multiproject can be predefined.
1.3.2 Station-specific structure

In a station specific structure, an OS and the assigned AS are stored in separate projects. The division of the automation systems is based on the number of project engineers or number of areas. A separate project is recommended for OS clients, e.g. in a central control room, as well as for all engineering stations.

Therefore, in the project of AS there are no OS objects (pictures, reports, ...) and in the project of the OS there are no AS objects (CFC, SFC, ...).
**Advantages**

- The biggest possible division ensures the highest flexibility in the assignment of individual projects to the project engineers and also offers the best performance in processing speed.
- During commissioning, engineering stations can be added or removed in order to respond flexibly to varying staff availability.

**Please note**

- Tests of AS and OS during configuring are carried out on separate ES (provided that the decentralization has taken place).
- Changes in the plant hierarchies (PH) of projects have to be synchronized again in the multiproject after editing.
- It is not possible to copy complete plant sections including the update of the OS objects.
1.3.3 Project-specific structure

In a project-specific structure the project includes all operator stations for an area together with the assigned AS. The area is completely independent. OS clients can be contained in the same project or in a separate project for a central control room.

From a technological point of view, the project contains both AS objects (CFC, SFC, ...) and OS objects (pictures, reports, ...) – this can be seen in the following figure.
Advantages

- It can be configured and tested in the project, complete with AS and OS.
- The mode of operation during configuration and commissioning is the same.
- It is possible to copy complete plant sections including the update of OS objects.
- There is a common view in the plant hierarchy, which includes the AS and OS in a project.

Please note

All AS charts can only be assigned to the available OS in the same project via the plant hierarchy.

A later division (outsourcing of individual AS or OS from one project) requires detailed knowledge of the corresponding steps necessary. That is why the project should be divided as well as possible, right from the beginning.
1.4 Distributed project archive

The distributed storage of projects is recommended for larger configuration work. The efficiency is higher when each project engineer has the relevant project parts locally available on his computer. This allows him to carry out his assigned work regardless of the overall project.

Figure 1-10

During the period when the projects are swapped out, the availability of the communication partners must be ensured, especially for cross-project activities such as when setting up an AS-AS communication or OS compilation.

In the following section, the distributed configuration is considered with and without network.

Note

The actual sequence for moving the projects can be found in the manual "SIMATIC Process Control System PCS 7 Engineering System (V8.1)". 

https://support.industry.siemens.com/cs/de/en/view/90663380
1.4 Distributed project archive

1.4.1 Division with network connection

If there is permanent network availability, project parts can be moved to distributed engineering stations for editing while still remaining in the multiproject. The project planners can gain access to all components of the multiproject at any time. Of course, besides the necessary network connection, all PCs that manage such components must be also switched on and released accordingly.

Figure 1-11

A project can be moved using the system function "Save as ..." and selecting the option to replace the project integrated in the multiproject with the generated copy.

Advantages

- An OS server can be compiled at any time with data from AS stations of other projects.
- All required program components can be found in the master data library, which can be accessed over the network.
- Easy archiving of the entire project, including all distributed projects is possible on the Engineering Server.
- A largely station-specific project structure and its distributed division represent the most flexible way of configuring under permanent network availability.

Please note

- If a project is not expected back on the network, it leads to corresponding waiting times.
- When carrying out cross-project functions, one must ensure with the project engineers that no one is working on the same projects. Otherwise, this could lead to conflicts.
1.4.2 Division without network connection

The multiproject functions of SIMATIC PCS 7 are based on the long-term availability of all contained projects.

If an ES is disconnected from the network and thus from the ES server, the projects for distributed processing are removed in advance from the multiproject. This could be, for example, because not all ES are permanently connected to the network or because the projects are edited deliberately outside the network (e.g. allocated to an engineering office / system integrator).

Figure 1-12

The projects are removed from the project using the system function "Remove from multiproject...". The integration of the projects is done by means of the function "Insert into multiproject ...".

Advantages

- No unexpected delays and waiting times result from lacking projects.
- During the distributed processing, it is not possible to access the project by mistake (e.g. by running cross-project functions).

Please note

- When working with NetPro, pre-configured connections can already generate warning messages due to the lack of communication partners. For the duration of the project division, new connections can only be created as unspecified via references.
- To compile an OS server, all relevant projects (AS projects and the corresponding OS project) must be reconnected centrally.
- The master data library is not included in the project. Only the blocks that have been previously used, contained in the block folder, are available. To use the functions of the master data library on the distributed ES, it must be managed as a local backup.
- The projects must be locally archived.

Note

It is recommended that cross-project functions are only performed if all user projects have been reincorporated in the multiproject on the Engineering Server.
1.4.3 Distributing the multiproject without network connection

In this variant, you distribute the multiproject including the master data library and the project, which the project engineer has to configure.

To distribute the multiproject, archive it and move the generated ZIP archive with Windows tools to the distributed ES.

After retrieving on the distributed ES, remove the unneeded projects from the multiproject and delete them.

After editing, the project is removed from the multiproject on the distributed ES, archived and reincorporated in the original multiproject on the Engineering Server.

Advantages

- The configuration engineer can access the master data library.
- The functions of the Import/Export Assistant (IEA) are available.
- CMT (Control Module Type) is available.
- During the distributed editing no unauthorized access can be made to the Engineering Server (e.g. by running cross-project functions).

Please note

- Changes in the master data library may only be done on the Engineering Server. The changes must be then done on all distributed ES.
- If all unneeded projects were deleted according to our recommendation and you are working with NetPro, pre-configured connections can already generate warning messages due to the lack of communication partners. For the duration of the project division, new connections can only be created as unspecified via references.
- To compile an OS server, all relevant projects (AS projects and the corresponding OS projects) must be reconnected centrally.
1.5 Distributed editing

General information on cross-project activities

The actual editing of the projects is carried out locally. However, cross-project data synchronization and functions are always done in the SIMATIC Manager of the central Engineering Server, where the multiproject is managed. These activities may be added before the project distribution or after the project has been reintegrated in the multiproject, i.e. when all projects are in the multiproject and no one is working on them.

Whether the distributed projects to be edited remain in the multiproject or removed depends on the extent to which a stable network can be guaranteed between the PCs.

Overview of the configuration steps

An overview of the steps necessary in the context of the multiproject engineering is given here. We recommend the following workflow, however this can vary according to individual circumstances and experiences. These steps are described more specifically in the following chapters.

Table 1–1

<table>
<thead>
<tr>
<th>Activity</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Project planning</td>
<td>Engineering Server</td>
</tr>
<tr>
<td>▪ Determining the number of project engineers</td>
<td></td>
</tr>
<tr>
<td>▪ Determining the available ES PCs</td>
<td></td>
</tr>
<tr>
<td>▪ Connecting the ES PCs to the network</td>
<td></td>
</tr>
<tr>
<td>▪ Determining the complexity of the project</td>
<td></td>
</tr>
<tr>
<td>2. Project set-up work:</td>
<td>Engineering Server</td>
</tr>
<tr>
<td>▪ Creating the multiproject</td>
<td></td>
</tr>
<tr>
<td>▪ Configuring the SIMATIC and PC stations</td>
<td></td>
</tr>
<tr>
<td>▪ Creating and synchronizing the plant hierarchy (PH)</td>
<td></td>
</tr>
<tr>
<td>▪ Generating cross-project networks</td>
<td></td>
</tr>
<tr>
<td>▪ Creating cross-project connections</td>
<td></td>
</tr>
<tr>
<td>▪ Mass data engineering</td>
<td></td>
</tr>
<tr>
<td>3. Dividing the projects:</td>
<td>Engineering Server</td>
</tr>
<tr>
<td>▪ Moving projects within the network</td>
<td></td>
</tr>
<tr>
<td>▪ Removing projects from the multiproject</td>
<td></td>
</tr>
<tr>
<td>▪ Distributing the project including the multiproject</td>
<td></td>
</tr>
<tr>
<td>4. Distributed project editing</td>
<td>Distributed ES</td>
</tr>
<tr>
<td>▪ Editing and completing charts</td>
<td></td>
</tr>
<tr>
<td>5. Merging the projects:</td>
<td>Engineering Server</td>
</tr>
<tr>
<td>▪ Moving projects back to the multiproject</td>
<td></td>
</tr>
<tr>
<td>▪ Reconnecting projects in the multiproject</td>
<td></td>
</tr>
<tr>
<td>6. Final project work:</td>
<td>Engineering Server</td>
</tr>
<tr>
<td>▪ Synchronizing the plant hierarchy (PH)</td>
<td></td>
</tr>
<tr>
<td>▪ Merging referenced connections</td>
<td></td>
</tr>
<tr>
<td>▪ Checking cross-project consistency</td>
<td></td>
</tr>
<tr>
<td>▪ Compiling and downloading</td>
<td></td>
</tr>
</tbody>
</table>
1.5 Distributed editing

Note

The individual steps are described in detail in the manual "PCS 7 Engineering System (V8.1)" /3/.
https://support.industry.siemens.com/cs/de/en/view/90663380

1.5.1 Project planning

From the basic requirements mentioned in chapter 1.3, you have defined the following sizes

- Number of automation systems
- Number of operator stations or OS servers
- Number of project engineers
- Number of available engineering stations
- Networking of the engineering stations
- Configuration duration

You have therefore decided for a station-specific or project-specific structure of the multiproject.
1.5 Distributed editing

1.5.2 Project set-up work

Creating a new multiproject

The PCS 7 Wizard creates a multiproject containing a subordinate project with objects (AS, OS, programs, charts, etc.) which are integrated upon request, by means of user queries. In addition, a master data library is created with the following contents:

- An S7 program with the folders for sources, blocks and charts (component view)
- Every folder for process tag types and sample solutions (plant hierarchy)
- Shared declarations

Start the PCS 7 Wizard ("File > ‘New Project’ Wizard..."). In 4 steps, the Wizard guides you through the creation of the multiproject.

Figure 1-14

1. Introduction and project preview
2. Configure the automation system
   Here you can pre-select an existing AS in your system.
3. Plant hierarchy and operator station
   In this step, you determine the number of hierarchical levels and can also specify whether an OS is created. If you would like to build your multiproject according to station, then do not select any PCS 7 OS here.
4. Project name and storage location
   In this step, rename your project and select the directory where to store the multiproject.

Note
As a storage location, it is recommended to choose a directory that is not in the system partition (C:).

Depending on the planned structure, create the other projects in the multiproject. To do this, select the menu function "File > Multiproject > Create in Multiproject...".
Configuring SIMATIC and PC stations

Configure the individual stations and their network connection according to your project planning and the hardware conditions.

Create the required stations using the menu function "Insert > Station > ...", or use the PCS 7 Wizard "Insert > Preconfigured Station ...".

Note

Even for manually created projects, you can use the PCS 7 Wizard to create preconfigured stations. For existing projects, start the Wizard with the menu function "Insert > Preconfigured Station...".
Configuring the plant hierarchy

As of PCS 7 version 6.1, the managing of the PH in a multiproject has been simplified. If the folders of the PH, at least in part, are applied identically in all or individual projects of the multiproject, this operation is needed only once in a project. The other projects then take on the PH when updating.

When doing this, existing hierarchy folders not having the same name will be created in the individual projects and given the properties of the template folder. Hierarchy folders with identical names are recognized and won't be overwritten, however they also get the properties of the template folder.

1. Configure the complete plant hierarchy in a project.
2. Mark the multiproject and select the menu function "Options > Plant Hierarchy > Update in Multiproject ...".

Table 1-2

<table>
<thead>
<tr>
<th>Plant Hierarchy - Update in Multiproject</th>
</tr>
</thead>
<tbody>
<tr>
<td>- Merge the PH of all projects in the multiproject</td>
</tr>
<tr>
<td>- Export the PH of one project in other projects</td>
</tr>
<tr>
<td>Select the project to be used as a template:</td>
</tr>
<tr>
<td>AS_1 ..........................................................</td>
</tr>
<tr>
<td>AS_2 ..........................................................</td>
</tr>
<tr>
<td>ES ...........................................................</td>
</tr>
<tr>
<td>DS-Clients ..................................................</td>
</tr>
<tr>
<td>DS-Server ...................................................</td>
</tr>
</tbody>
</table>

To synchronize the plant hierarchy there are two options available:

- "Merge the PH of all projects in the multiproject"
  The PH is synchronized in the entire multiproject.

- "Export the PH of a project into other projects"
  The PH of a selected project is synchronized with the PH of the target project.
Should the plant hierarchy of referenced projects be changed, the link must be removed beforehand. You can do this using the function "Options > Plant Hierarchy > Revoke link". You can revoke the PH link multiproject-wide by selecting the multiproject or project-wide by selecting the appropriate project.

Generating cross-project networks

In PCS 7, the stations of the individual projects must have their subnets merged to be able to communicate with each other. To do this, you have to create cross-project networks in the multiproject.

The dialog for merging subnets can be accessed via the menu function "File > Multiproject > Update projects..." or from NetPro via "Edit > Merge / unmerge subnets...".

1. Select the network type "Industrial Ethernet". Click on the "Run" button.
2. Select those subnets that should be merged into a global network. Add them to the global network with the button "->" (right pointing arrow).
3. Confirm your selection with "OK" or "Apply".

Creating cross-project connections

You can now create the cross-project connections as usual between AS - AS, OS - AS or ES - AS (to test the OS function on the ES using the OS simulation). If the subsequent distributed configuration takes place in multiproject, the connections can also be created after dividing the projects.
To edit projects that have been removed from the multiproject, we encourage you to apply the already known connections in advance. You can add unspecified connections via textual references at a later stage. The links can be closed on the central engineering server after adding the projects to the multiproject.

Figure 1-19

1.5.3 Dividing the projects

Depending on whether the distributed editing of projects should take place in the multiproject with network connection, in the multiproject without network connection or without a multiproject and without a network connection (project only), this is described up to the project division in the following three ways.

However, we recommend the variant in which you copy and distribute the multiproject.
Distributing a project including the multiproject

This option describes how to distribute the multiproject on the distributed ES. This has the advantage that the project engineer can gain full access to the master data library and the Import/Export Assistant (IEA) for configuring purposes.

In this variant, a copy of the multiproject is distributed. The unneeded projects are then removed from the multiproject in the distributed ES. Proceed as follows:

1. Archive the multiproject ("File > Archiving...").
2. Copy or move the archived multiproject to an external data storage medium. On the distributed ES, unpack the multiproject ("File > Retrieve...").
3. Remove all projects that the configuration engineer doesn't need from the multiproject ("File > Multiproject > Remove from Multiproject").

Note

Do not modify the master data library on the distributed ES, as this may no longer be sent back to the multiproject of the Engineering Server.

The master data library should only be modified on the Engineering Server by an authorized person. After a modification, it must be redistributed to the distributed ES.

Moving a project within the network

In the following section, a project inside a multiproject is moved from the central Engineering Server to a remote ES via network. To do this, a copy of the project is created on the remote ES and incorporated in the multiproject. The original is removed from the multiproject and can physically stay on the hard disk of the central Engineering Server as a safety backup.

1. In the SIMATIC Manager, select the project that is to be moved to a distributed ES.
2. Select the menu command "File > Save As...".
3. In the "Save As" menu command, choose the following settings:
   - Choose the option "Add to multiproject"
   - Select "Current multiproject"
   - Choose "Replace current project"
   - Select storage location
4. Save the project with the "OK" button.
The existing original project has been removed from the multiproject and stored on the central Engineering Server. It can be left there as a backup or deleted. You can remove the backup copy via the menu item “File” > “Delete ...” of the SIMATIC Manager.

From the component view, you get an accurate overview of which projects are included in the multiproject. The column “UNC Path” shows you on which ES the projects are saved.
Removing a project from the multiproject

In this section a project will be removed from the multiproject. The removed project can then be moved to an external data storage medium for transportation purposes.

1. Select the project that you want to remove from the multiproject.
2. Select the menu command "File > Multiproject > Remove from Multiproject".

Although the project was removed from the multiproject, it remains saved as a project in the folder created during the compilation. To transfer the project to an external medium, it must be archived.

1. Run the menu function "File > Archiving...".
2. In the "User projects", select the project.
3. Start archiving with the "OK" button.

After these steps, the project that was removed from the multiproject remains both in its original form and as a ZIP archive on the drive on which it was created. Both can be either left here as a backup copy or else deleted. You can remove the original project via the menu entry "File > Delete...". You can delete, move or save the ZIP archive using Windows tools.

To enable the project engineer to access the master data library on the distributed ES, you must also copy it to the distributed ES. However, changes to the master data library should only be made on the Engineering Server. After that, the library must be re-distributed to the distributed ES.

You can distribute the master data library as follows:

1. Run the menu function "File > Archiving...".
2. In the "Libraries" tab, select the master data library of the multiproject. Master data libraries are marked with a blue book symbol.
3. Start archiving with the "OK" button.

As usual, you can copy the ZIP archive of the master data library to all distributed ES by means of an external data storage medium. After retrieving the distributed ES you can use the master data library as a normal library.

Note
If there is a temporary network connection between the engineering stations, SIMATIC Manager provides further functionality.

If the project is marked, it can also be moved to the remote ES and removed simultaneously from the multiproject via "File > Multiproject > Remove for editing...". In the multiproject, the project is marked as "Project removed for editing" and grayed out.

Firstly, you’ll spare yourself the time needed for the delete procedure and secondly, it simplifies reintegration after completing the editing, because the original file path will be memorized (reducing administrative effort).
1.5.4 Distributed project editing

Editing projects without network connection

When editing projects on the distributed ES, these functions are possible:

- Functions that do not span across projects
- Pure editing work
- Compiling and downloading an AS over a permanently configured TD/PC interface (e.g. CP1613 [ISO])

If you want to download the AS from the distributed ES via the interface module "PC internal (local)", you must first carry out the following work:

1. Add a local PC station with a suitable CP to the project.
2. Configure the S7 connection between AS and OS

If you’d like to test an OS on the distributed ES during process mode (OS simulation), you must change the computer name in WinCC Explorer.

Note

Before the project is copied or moved again to the Engineering Server, you have to reverse the changes that you carried out for downloading (via "PC internal (local)").

Editing projects with network connection

If a permanent and fast network connection is present, the distributed editing of projects in a multiproject largely corresponds to the editing of multiple projects on a single engineering station.

The multiproject backup on the Engineering Server also includes the distributed projects. During archiving, it is not permitted to work on the project located on the distributed engineering station.

As of PCS 7 V6.1 SP1, the optional Trail package is also available. This enables the archiving of project data, i.e. complete multiprojects, individual projects or libraries and while doing so, the data is tagged with a version identifier and a comment. Furthermore, it also allows you to retrieve pre-versioned project data and reinsert it. The Trail version also handles the entire management of the version history. This means, for example, that you can no longer modify a version once it is completed.

As of PCS 7 V8.1 it is possible to perform automatic archiving after downloading the user program successfully (the Trail version must be installed).
1.5 Distributed editing

1.5.5 Merging the projects:

After the projects have been edited locally, they have to be remerged into the multiproject.

Moving a project within the network

In the following section, a project within a multiproject is moved from a remote ES to the Engineering Server. To do this, a copy of the locally edited project is generated on the Engineering Server and integrated in the multiproject. The locally edited project on the remote ES is removed from the multiproject and can physically stay on the hard disk of the distributed ES as a safety backup.

**Note**

The project must be "physically" on the distributed ES and integrated in the multiproject on the Engineering Server.

The distributed ES is accessible through the network.

1. If necessary: Delete the existing project of the same name (the version before moving to the distributed ES) from the Engineering Server.
2. In the SIMATIC Manager, open the project from the engineering server on the distributed ES using the menu command "File > Open...".
3. Click on the "Browse..." button.
4. Go to the "Browse" menu, click in the "Search in directory" field and enter the path of the project being moved in "UNC notation".
5. Click the "Start search" button. The project is displayed in the "User projects" tab.
6. Select the required project in this tab and click "OK". The project opens.
7. Select the "File > Save As" menu command.
8. Make the following settings:
   - Disable the "With Reorganization (slow)" check box.
   - Enable the "Insert in multiproject" option.
   - Select the "Current multiproject" entry in the corresponding drop-down list.
   - Enable the "Replace current project" option.
9. Click the "OK" button.
1 Multiproject engineering

1.5 Distributed editing

**Adding and reintegrating a project into a multiproject**
In the following section, a project that has been edited on a remote ES, is reintegrated into the multiproject. One has to distinguish between the "Add to multiproject" and "Reintegrate after editing" methods.

**Note**
The choice between the adding/integrating methods depends on the method used to remove the project from the multiproject. See chapter 1.5.3 Dividing the projects.

Reintegrate the project after editing:
1. On the Engineering Server, select the project that is marked as "Removed for editing" (grayed out).
2. Select the menu command "File > Multiproject > Reintegrate after editing".

**Note**
A temporary network connection between the remote ES and the ES Engineering Server is necessary for reintegration.

Inserting a project in the multiproject
3. Archive the edited user project on the distributed ES.
4. Copy the project archive on the Engineering Server.
5. On the Engineering Server in the SIMATIC Manager, choose the menu command "File > Retrieve".
6. In the "Retrieve - Select archive" menu, select the project to be retrieved. Then click "Open".
7. In the "Select destination directory" menu, select the directory in which your multiproject is stored and click "OK".
8. Go to the SIMATIC Manager on the Engineering Server and open the multiproject where you want to add the user project.
9. Select the multiproject and choose the menu command "File > Multiproject > Add to multiproject...".
10. In the menu "Incorporate in multiproject", select the user project you want to add and click "OK".
1.5.6 Final project work

After merging the locally edited projects, you can complete the entire configuration by running cross-project functions for the first-time or once more.

Synchronizing the plant hierarchy (PH)

If the PH should be kept identical for all projects but was changed in a project during distributed editing (e.g. by inserting a new hierarchy folder), you can resynchronize the other projects to it.

Mark the multiproject and select the menu function "Options > Plant Hierarchy > Update in Multiproject ...".

Merging cross-project connections

Connections that were created on the distributed engineering stations with a text reference, can be closed on the Engineering Server after the projects have been integrated into the multiproject:

There are two possible approaches to merge cross-project connections.

To merge the cross-project connections across all projects, proceed as follows:

1. In the SIMATIC Manager, choose the menu command "File > Multiproject > Synchronize projects...”.
2. In the tree view, select the entry "Merge Connections".
3. Click the "Execute" button. In the "Result" section, you will see all the cross-project connections which can be merged.
4. Click on the "Apply" button. This merges all displayed connections.

Figure 1-23
To merge the cross-project connections of individual projects, proceed as follows:

1. In the SIMATIC Manager, select the project for which you want to merge the connections.
2. Start "NetPro".
3. Select the menu command "Edit > Merge Connections...".
4. Select the connections that you want to merge and click the "Merge" button.

Figure 1-24
1 Multiproject engineering

1.5 Distributed editing

Compiling and downloading

Carry out the following activities as instructed in the manual "PCS 7 Engineering System (V8.1)":

1. AS Program compilation
   This step can be skipped if the program has been already compiled on the distributed ES.

2. Compiling the OS server with access to the related AS components

3. Assigning the OS server to the OS clients
   (Must be carried out once manually. When you download the OS clients to the target computers, the OS server data is also downloaded. Subsequent changes to the server configuration are updated automatically on the clients)

4. Downloading all target systems
2 Multiuser engineering

2.1 Function mechanisms

During multiuser engineering, several project engineers work on the same project, regardless of your chosen project structure and division. The corresponding project is located on an Engineering Server, which allows access to individual engineering stations via network. It does not matter whether it forms part of a multiproject or if it may have been detached and moved for editing (e.g. to a distributed ES).

Genuine multiuser engineering is currently only available for the processing of CFC/SFC. These objects can be modified at the same time by different project engineers, whereby changes are written directly to the system database. If a chart is already being edited by a project engineer, and another project engineer wants to open the same chart, the latter receives a message pointing out that the chart is already being edited by another project engineer.
2 Multiuser engineering

2.1 Function mechanisms

Figure 2-2

If two project engineers open the same chart simultaneously and one of them performs modifications, the other project engineer only sees these changes after updating the display (F5).

When editing different objects (e.g. CFCs) in the same project, there are generally no conflicts between them. However, caution is advised when carrying out project-wide actions, such as AS compiling. If a project engineer attempts to change a CFC while the AS program is being compiled, this creates a conflict with a corresponding message window.

The following applies for all other objects in the PCS 7 project: If several project engineers connect to the same object, e.g. the symbol table, this can only be edited by one project engineer. The other project engineers can only open the symbol table as write-protected.

It does not matter which way you choose to open an object. The symbol table can be opened, for example, from the component view, the process object view or the menu item of an editor (e.g. SCL editor). The table is always displayed in the Symbol Editor and edited there.
2 Multiuser engineering

2.1 Function mechanisms

Basically, all objects can be opened as read-only by all users, but may be only opened for editing by one user. The privilege to save the above changes is given to the user who made the first change. All other users will receive a message saying that the object is already being edited, and can only save their changes using the "Save As ..." function. The object in question can only be edited again by another user once the change has been saved by the project engineer.

As from PCS 7 V8.1, the multiuser engineering function can be enabled in the OS project. When the function is active, the OS project can be opened multiple times remotely. A distinction must be made between file and database-based access.

Project

- Either the multiproject or an individual project is opened via network on each station. When doing so, it is important that the network share has been already activated before creating the multiproject.

- In order to improve performance, projects with AS stations can be saved on the local ES using the "Save As" function for the duration of the configuring, without being removed from the multiproject. This increases the performance. If the "Save As" function is unfavorable because of the project situation, performance can also be increased via remote access to the ES server (refer to chapter 3.4 "Remote access to the Engineering Server").

Note

Working via network increases the potential risks for a smooth workflow. If the network connection breaks during a write operation, it can result in long waiting times and possible inconsistencies in data storage. In this case, close any open projects in the SIMATIC Manager before you continue working.
2.2 Overview of the configuration steps

Generally, the first configuring steps, such as the creation of the multiproject, are carried out on the Engineering Server.

We recommend the following workflow, however this can vary according to individual circumstances and experiences.

Figure 2-4 Multiuser engineering workflow

* Recommendation: Start remote on ES server
Assign a project manager for the team (Lead Engineer), who will be responsible for cross-project functions and manage the ES server.

By working via network, you increase the risk of data inconsistencies. Therefore for multiuser engineering, it is extremely important to have a stable network connection between the engineering stations.

Generally, we recommend performing cross-project functions on the engineering server where the project or the multiproject is managed.

- Creating and synchronizing the plant hierarchy (PH)
- Managing the master data library
- Merging subnets and connections
- Generating and updating the block icons
- Compiling and downloading all the components present (AS, OS, ...)

**Note**

When executing cross-project functions, one requires agreement, since at this point one cannot work on the projects. The individual steps are described in detail in the Configuration Manual "SIMATIC Process Control System PCS 7 Engineering System \3\".
2 Multiuser engineering

2.3 Working in parallel

2.3 Working in parallel

For several project engineers to work in parallel, the multi-project or individual projects of the multiproject are opened on several engineering stations via network. The Engineering Server where the project is stored, can also serve as a workstation.

Access scenarios / special features

To edit objects in the same project, one must distinguish between the following cases:

- Various objects on several engineering stations
- Various objects of an AS on several engineering stations
- The same object on different engineering stations
- Various objects of an OS on several engineering stations

When editing various objects on several engineering stations, no obstruction should be expected for the AS engineering.

However, if several project engineers are working on the same chart, it can lead to mutual conflicts. For example, if two project engineers work simultaneously in the same input mask within a CFC chart, the action that gets executed is the one by whoever presses the "Apply" button last or closes the dialog with "OK". This procedure is therefore not recommended.

No obstructions are to be expected when editing various objects of one OS on several stations. The individual editors or pictures can only be opened simultaneously by one user. It is also partially possible to view the configured data in read-only mode if the editors are open.

| CAUTION | If several project engineers are working on the same object, update the view by pressing F5 before carrying out any further steps. This ensures that the real actual state is displayed. |

Try to avoid this mode of operation by coordinating the work. There should be no simultaneous access to the same resources, such as assigning parameters to the same connections of a particular block type. For long read or write actions, the project planners must coordinate with each other.
2 Multiuser engineering

2.3 Working in parallel

Tools

PCS 7 offers several tools that considerably reduce the chance of conflicts when editing charts of the same station or within the same project:

- "Version": Activate the versioning of the charts to recognize if anything in the charts has changed from the version number and the date of change.
- Author: Assign yourself as an author of the chart, if you are the one responsible for it or when you are working on it.
- Write protection: Activate the write protection on a single chart or all charts together as soon as certain areas are finalized.
- Change log: Activate the ES change log when using SIMATIC Logon (see details in the PCS 7 Engineering System manual).
- Access control: Use the SIMATIC logon role management system to define who can open which project (see details in the PCS 7 Engineering System manual).

Conflict handling

A typical conflict situation is, for example, a parallel change on the same object. The project engineer always receives the privilege to save the change, as he was the first one to make it. All other project engineers usually receive a message indicating that the object is read-only or occupied by another process.

Figure 2-5

Generally, the parallel opening (reading) of objects or their properties does not lead to any conflict and can be performed by all users.
2 Multiuser engineering

2.3 Working in parallel

2.3.1 Charts (CFC/SFC)

Summary

<table>
<thead>
<tr>
<th>Action</th>
<th>Restrictions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing various charts of an AS on various ES.</td>
<td>None</td>
</tr>
<tr>
<td>Editing the same charts of an AS on various ES.</td>
<td>Restricted – changes made by the other configuration engineer are only visible after updating the view (F5 key).</td>
</tr>
</tbody>
</table>

Prioritizing actions

Different priorities are assigned to the individual transactions. Basically, in the event of an access conflict, the higher priority action is always executed. In this case, the lower priority action is canceled. A short reading action has the lowest priority and a long writing action has the highest priority.

Table 2–2

<table>
<thead>
<tr>
<th>Action type</th>
<th>Read/write action</th>
<th>Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Short read actions (without resource allocation) are:</td>
<td>• Opening charts  • Opening run sequence  • Opening dialog boxes</td>
<td>If short read actions are additionally carried out, no conflicts should occur. If a short or long write action is executed in parallel, it may cause an access conflict, which results in the short read action to be canceled.</td>
</tr>
<tr>
<td>Short write actions (without resource allocation) are:</td>
<td>• Instantiation, parameter assignment, interconnection, etc.  • Close dialog box with OK</td>
<td>If a short or long write action is executed in parallel, the action launched later can result in an access conflict.</td>
</tr>
<tr>
<td>Long read actions (with resource allocation) are:</td>
<td>• AS-OS data transfer (OS compilation)</td>
<td>If an access conflict does not occur immediately when launching the long read action, because for example, a write action is being already executed in parallel, this action is executed with no access conflict.</td>
</tr>
</tbody>
</table>
2 Multiuser engineering

2.3 Working in parallel

<table>
<thead>
<tr>
<th>Action type</th>
<th>Read/write action</th>
<th>Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Long write actions (with resource allocation) are:</td>
<td>Optimizing the run sequence</td>
<td>If an access conflict does not occur immediately when launching the long write action, because for example, a write action is being already executed in parallel, this action is executed with no access conflict.</td>
</tr>
<tr>
<td></td>
<td>Compiling and downloading (AS and OS)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Type import and block type update or clean-up</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Synchronizing shared declarations</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Generating module drivers</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reading back</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Creating block icons</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Creating diagnostics screens</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Synchronizing PH in multiproject</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Import/export functions of the Import/Export assistant and the process object view</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Import/export functions of ES objects of the VCM</td>
<td></td>
</tr>
</tbody>
</table>

Signaling conflicts

The same chart (CFC or SFC) can theoretically be edited at the same time by several project engineers. However, a maximum of one project engineer can access the database at any one time with writing permissions. If an action cannot be executed, the following message (example) is displayed:

Figure 2-6

![CFC dialog box](image)

Due to the short time required to write to the database, such conflicts are extremely rare.
2 Multiuser engineering

2.3 Working in parallel

**Note**
When opening an already opened CFC/SFC, a message box appears stating that the chart is already open. The configuration engineer must then decide whether to open the chart again.

If project engineers work simultaneously CFC/SFC, they should coordinate their activities.

In general, the project engineers should coordinate their activities when working on the same CFC/SFCs. When a conflict occurs, at the latest, the project engineers must determine among themselves which change is to be saved.

Long read and write processes are better carried out on the ES server or wherever the respective project is stored, after coordination between all project engineers. This prevents conflicts automatically.

**CAUTION**
Ensure that all work has been completed on the AS program when loading the automation system. This guarantees that when compiling, a consistently checked S7 program is downloaded to the AS.

**CAUTION**
A selective downloading of charts is possible since PCS 7 V8.1. When downloading an edited chart, the depending charts are also downloaded. This increases the risk that one of the dependent charts is currently being edited by a different project engineer. Coordinate the activity with the other project engineers. For further information, see the Function Manual "CFC for SIMATIC PCS 7 V8.1" /2/.

With regard to projects that have been created from the very beginning with PCS V8.1, there should be no dependencies.

**Note**
In case of access conflicts outside the CFC/SFC, the operation is rejected (no multiuser compliant message). Simultaneous work in the SIMATIC Manager outside the PCS 7 ES is not supported.

**Note**
For more information on how the system responds to conflicts, refer to the heading "Notes on system behavior" in chapter 6 "multiuser engineering" of the PCS 7 Function Manual "CFC for SIMATIC S7" /2/.

Here you will find information about:
- Conflicts when accessing the same resources outside the CFC
- Conflicts when using the test mode
2 Multiuser engineering

2.3 Working in parallel

Interlocking mechanism
Each transaction has an ID and saving (allocation) is done over it. This means that further write actions are locked to the same location in the database.

Note
In the process object view (table layout) the actions of the individual program units are allocated line by line.

2.3.2 Process object view

Summary

Table 2–3

<table>
<thead>
<tr>
<th>Action</th>
<th>Restrictions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing various objects of a project on various ES.</td>
<td>None</td>
</tr>
<tr>
<td>Editing various objects of an AS on various ES.</td>
<td>None</td>
</tr>
<tr>
<td>The same object of an AS is processed on various ES.</td>
<td>Restricted – changes made by other configuration engineers are only visible after updating the view (F5 key).</td>
</tr>
</tbody>
</table>

Description
In the process object view, two project engineers can make simultaneous changes to different objects without interfering with each other. The entry field in the process object view is a simple field. The change is only saved when leaving the field (enter, tab, arrow keys, etc.).

It should be noted that when working on the same charts, the values are not updated automatically. After project engineer 1 changes a value, project engineer 2 could change the value immediately afterwards.

Restrictions

- Case 1: Conflicts only arise when both project engineers work on the same chart. For example, project engineer on ES1 changes values in chart A and project engineer on ES2 also changes values in chart A. If by chance, both attempt to access the same field simultaneously, the message “The data can only be accessed for reading” appears.

- Case 2: Several project engineers add a new comment in chart A. The configuration engineer of ES1 starts the action first. The configuration engineer of ES2 starts the action immediately afterwards. The configuration engineer of ES2 gets the message “The data is currently being processed by another application, Application: SIMATIC Manager, Computer: ES1, User name: Login name of project engineer on ES1”. The data edited on ES1 is stored. The data edited on ES2 is discarded.
2 Multiuser engineering

2.3 Working in parallel

Figure 2-7

![SIMATIC Manager warning message](image)

- Case 3: The editing of charts of various ASs on different ES is possible without hindrance if only one configuration engineer edits one AS.

**Note**

If work is carried out simultaneously on the same chart from both the process object view and the CFC editor, it will cause updating problems with the data.

### 2.3.3 NetPro

#### Summary

<table>
<thead>
<tr>
<th>Action</th>
<th>Constraint</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing NetPro configurations of different projects on various ES.</td>
<td>None</td>
</tr>
<tr>
<td>Edit the same NetPro Configuration of a project on various ES.</td>
<td>Restricted. The first configuration engineer to open the NetPro configuration can edit the configuration. All other project engineers get read-only access. Changes are visible after updating the view (F5 key).</td>
</tr>
</tbody>
</table>

#### Application scenarios

- Cross-project configuration in NetPro on the ES server
- Changes can only be carried out at one station

#### Recommendation

NetPro editing is best done from the central engineering station after creating the multiproject. This prevents possible inconsistencies and restrictions when compiling from NetPro.
2 Multiuser engineering

2.3 Working in parallel

2.3.4 HW Config

Summary

Table 2–5

<table>
<thead>
<tr>
<th>Action</th>
<th>Restrictions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing various hardware configurations of a project on various ES.</td>
<td>None</td>
</tr>
<tr>
<td>Editing the same HW Config on various ES.</td>
<td>Restricted. The configuration engineer that first opens the object in HW Config can edit the configuration. All other project engineers get read-only access. Write access is only possible after saving the change. Changes can only be done apply after updating the view (F5 key).</td>
</tr>
</tbody>
</table>

Description

In principle, it is possible to allow several project engineers to configure and edit the hardware components. If a hardware object is opened and changed in HW Config, this object is locked against changes by other configuration engineers. They can only open the object as write-protected.

As long as the HW Config changes on the ES1 are not stored, the message "Unable to make the changes. Save your changes in other applications" is displayed on the ES2 and the actions are locked on the ES2.

Changes on the ES2 are only possible after the HW Config has been saved on ES1.

Alternatively, the person accessing the HW Config receives the message "The station has been changed by another application and will now update" and an automatic update follows.

Figure 2-8
2 Multiuser engineering

2.3 Working in parallel

Note
We recommend to always change the hardware configuration of an AS on one ES. Other ES can be used in parallel, both offline and online, for read-only access. If you want to download a configuration, no other ES may have established an online connection to the AS.

CAUTION
If CiR is enabled, then work in accordance with the CiR conditions. See "PCS 7 Engineering System (V8.1)" /3/.

2.3.5 Symbol table

Summary

Table 2–6

<table>
<thead>
<tr>
<th>Action</th>
<th>Restrictions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing various symbol tables of a project on several ES.</td>
<td>None</td>
</tr>
<tr>
<td>Editing the same symbol table on several ES.</td>
<td>Restricted. The first project engineer to open the symbol table gains full access. All other project engineers gain read-only access. Changes are only visible after updating the view (F5 key).</td>
</tr>
</tbody>
</table>

Description

Project engineer on ES1 and project engineer on ES2 want to edit the symbol table of AS1 at the same time.

Project engineer on ES1 opens the symbol table of AS1 and affects the change.

Project engineer on ES2 also opens the symbol table of AS1 and gets the message "The symbol table occupied by another process".
2 Multiuser engineering

2.3 Working in parallel

2.3.6 Process Device Manager (SIMATIC PDM)

Summary

Table 2–7

<table>
<thead>
<tr>
<th>Action</th>
<th>Restrictions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing various field devices of a project on several ES.</td>
<td>None</td>
</tr>
<tr>
<td>Editing various field devices of an AS on several ES.</td>
<td>None</td>
</tr>
<tr>
<td>Editing the same field device of an AS on several ES.</td>
<td>Restricted as from PCS 7 V8.0 (PDM V8.0). As from PDM V8.0 it is possible to have simultaneous read-only access to the same field device from several ES. When writing from an ES to a field device, only this single ES field device may be opened via PDM.</td>
</tr>
</tbody>
</table>

Application scenarios

- Various field devices from different AS can be edited on several ES.
- Various field devices from one AS can be edited on several ES independently.
- Working on the same field device on several ES: SIMATIC PDM prevents this in PCS 7 V7.1 (PDM V6). A device can only be opened on one ES. From PCS 7 V8.0 (PDM V8.0) it is possible to open the field device several times and to perform the read function online on the field device. Write procedures in the field device or in the project are prevented with a message box. This is only possible if only one ES opens the field device with PDM.
- Restrictions apply when inserting or deleting devices, see chapter "HW Config".
- In order to avoid dependencies with HW Config, it is recommended to open existing devices via PDM device view or PDM network view.

Requirement

To assign parameters to a field device with PDM, the necessary device configuration files must be installed in the same way on every ES. If the project is downloaded to an ES with a configured PDM device without first installing the device configuration file, a message will be displayed when opening the HW Config to indicate the lack of software. In that case, the HW Config can only be opened with read-only access. Changes in the HW Config cannot be saved.
2 Multiuser engineering

2.3 Working in parallel

Parameter assignment

A particular field device that has been configured with the Process Device Manager can only be opened for editing by one project engineer. Other project engineers can only open the device configuration as read-only.

Figure 2-9: PDM V8.0

Recommendation

When you open the field device via a SIMATIC PDM Manager View instead of HW Config, you avoid restrictions in the HW Config on another ES.
2.3 Working in parallel

2.3.7 Additional ES components

When it comes to following objects in the PCS 7 project, in principal only the first project engineer to make a change can save that change. As long as the change is not saved, all other project engineers only get read-only access to the object. This is indicated by an appropriate message.

- Connections
- Sources (AWL, SCL, KOP, FUP)
- Blocks
- Symbol table

Figure 2-10

Edit Object Properties (256:113)

This action cannot be executed presently. It affects objects that are being processed by another application. For this reason, save the changes that you made in the other applications first.

Object Properties (294:15)

The block '01_PlantA_P:\S7 Program1\Blocks\FE1899' cannot be written to because it is opened at the moment by another application or another user.

Symbol Table (291:416)

The Symbol table is being used by another process.
2 Multiuser engineering

2.3 Working in parallel

2.3.8 OS project

Since PCS 7 V8.1, it is possible to open an OS project remotely from all connected engineering stations. This functionality must be activated in the SIMATIC Manager for the OS projects contained in the multiproject.

Summary

Table 2–8

<table>
<thead>
<tr>
<th>Access scenario</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opening of resources based on a database (e.g. tag management)</td>
<td>The first computer to open the resource gains full access. The others gain no access or read-only.</td>
</tr>
<tr>
<td>Opening of file-based resources (e.g. process pictures).</td>
<td>It is not possible to access files that are already open.</td>
</tr>
</tbody>
</table>

Activating the OS multiuser engineering

You can activate the "OS Multiuser engineering" functionality in the SIMATIC Manager on the engineering station where the multiproject is located (Engineering Server).
After activating OS multiuser engineering in the SIMATIC Manager, the "Multiuser engineering" checkbox is automatically activated in the project properties of the operator station within WinCC Explorer.

**Note**
The "multiuser engineering" checkbox cannot be enabled or disabled in WinCC Explorer!
2 Multiuser engineering

2.3 Working in parallel

Figure 2-12

Data consistency

The consistency of data is ensured by marking the resources being used in the database as occupied. This ensures that no data can be changed simultaneously by two users.

In the project properties, you can click on the "Resources" button to display the currently allocated resources. Assigned resources are shown to you including the user name and computer name.

In certain circumstances it could happen that resources are marked as occupied when in truth they are not. In this case, the resources can be released manually by means of the "Release" button.

Note
To rule out inconsistencies in the data, it must be ensured that the resources are really not being used anymore before the manual release.
2 Multiuser engineering

2.3 Working in parallel

Figure 2-13

Opening the OS project

To open an OS project on another engineering station, click on "Open → File" in the SIMATIC Manager and navigate via network to the engineering station where the project is stored. Choose the storage location and select the project by clicking the "Browse ..." button.

Figure 2-14
Engineering the OS project

Having connected to the remote engineering station via the SIMATIC Manager, you can now open and edit the OS project in WinCC Explorer. The system thereby ensures that no resource is opened simultaneously by two project engineers.

Depending on the desired resource, the resource can be then opened as read-only. When this happens, the project engineer is notified about which user is occupying the resource and from which computer.
2 Multiuser engineering
2.3 Working in parallel

Process pictures can only be opened by one project engineer. If a process picture is already open in another engineering station when one tries to open it remotely, it will be prevented from opening. The following message is shown.

Figure 2-17

![Platform Designer]

The file cannot be opened because this file is currently used by PCS7Admin on the ES21 computer.

Note

It is possible to open a write-protected picture in parallel from the Graphics Designer of another OS project (see Figure 2-19).

Figure 2-18

![Write-protected picture]

Note

Always complete the OS engineering for an OS project on the same engineering station. During the planning phase, this should be the ES server.
2 Multiuser engineering

2.3 Working in parallel

2.3.9 Parallel AS and OS engineering

Application case

One or several project engineers are working with AS engineering, while another project engineer updates or completes the process pictures in the Graphics Designer of the associated OS.

During this process, the OS project engineer can access the blocks which have already been configured in the AS, even if they still haven't been created explicitly and completely via OS compilation. He can do this by using the so called “ES tags” in the tag selection of the Graphics Designer.

Figure 2-19

This prevents delays during configuration due to a pending OS compilation. This can be made up after completing the AS configuration.

Note

The implicit compilation by selecting ES tags is only available for station-specific design and not for project-specific design. This means that the AS and OS must be contained in various projects.

Name changes in the PH are not automatically updated when using ES tags.
2 Multiuser engineering

2.3 Working in parallel

2.3.10 Compiling and downloading objects

Options

In PCS 7, you can start the functions for compiling and downloading from various editors. There are differences in the functional scope. The following table provides an overview of the possibilities for compiling and downloading of PCS 7 components:

Table 2-9

<table>
<thead>
<tr>
<th>Editor</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>HW Config</td>
<td>Compiling and downloading the hardware configuration</td>
</tr>
<tr>
<td>NetPro</td>
<td>Compiling and downloading the network and connection configuration as well as the hardware configurations</td>
</tr>
<tr>
<td>Charts (CFC/SFC)</td>
<td>Compiling and downloading the AS program</td>
</tr>
<tr>
<td>SIMATIC Manager</td>
<td>Compiling and downloading individual objects or all objects of a multiproject via selection windows</td>
</tr>
</tbody>
</table>

After the first complete compilation and complete download, a compilation of changes is usually sufficient.

Compiling and downloading individual stations

Basically, AS compilation and loading is possible on various ES. For performance reasons, it is recommended to carry out AS compiling and loading on the ES where the project is locally saved - usually it's the ES server. To increase performance it is possible to access the ES server remotely, as described in chapter 3.4.

The compilation of OS changes should always be carried out from the same station – for this purpose, select the ES server during the planning phase.

To avoid conflicts, before each AS compilation, set the work on the relevant AS to other ES.
"Compile and download objects" selection window

The "Compile and download objects" selection window in the context menu of a project/multiproject also allows you to compile and download all connections and programs throughout the project or multiproject, if required. At the same time, it also allows the status/mode of the target stations to be checked.

Especially when completing a download of OS changes, you can use it to compile and download all the changes within the changed charts and the associated OS project in a single process.

For performance reasons, when it comes to large multiprojects, it is recommended to select the "compile and download objects" dialog box only for the specific project and not for the entire multiproject.

Note

We recommend that you always carry out the compiling and downloading of all objects from the Engineering Server. Also coordinate the activity with the other project engineers. The multiproject or integrated projects cannot be opened on any ES, otherwise there will be a conflict and the entire compiling process is canceled.

Note

Always complete the OS compiling and downloading for an OS project from the same engineering station.
3 Higher-level topics

3.1 Central control station for several PCS 7 systems

If the question arises, how to control several PCS 7 systems from a common control room, SIMATIC PCS 7 provides two different approaches, depending on the installed PCS 7 versions. It is assumed that a separate multiproject exists for every system.

Cross-multiproject OS clients

If the PCS 7 versions are identical in the systems, the central control room could be, for example, equipped with cross-multiproject OS clients. When configuring these particular OS clients, you can refer to the following article:

"How in PCS 7 do you configure the cross-multiproject access to the OS servers (multiclient mode) for an OS client?"

https://support.industry.siemens.com/cs/de/en/view/67261722

Web server / web client

If various PCS 7 versions are available in the systems, the control room can be set up from a web server/web client solution. In doing so, a web server of the appropriate PCS 7 version is installed in every system. The higher-level web client can connect to all web servers if compatible with the latest web server.

For example, a web client based on PCS 7 V8.1 can connect to the following stations:

- Web Server V8.x
- Without use of SFC functions
  - Web Server V7.x

The setting up of PCS 7 web servers and web clients is described in the manual "SIMATIC Process Control System PCS 7 Web Option for OS (V8.1)".

https://support.industry.siemens.com/cs/de/en/view/90682846
3.2 Licensing

The PCS 7 Engineering licenses are of the "floating" type, i.e. they can be used by several ES over the network. They can also be accumulated, which can be seen in the "Number" column of the Automation License Manager.

All licenses for an operator station are of the "single" type, i.e. they must be available on the respective target station.

Figure 3-1: "Connect Computer ..." function in the PCS 7 V8.0 environment

Application scenarios

For larger systems, it makes sense to set up the ES server as a central license station in order to manage all licenses from it.

In the Automation License Manager of the ES server, add the other ES using the "connect computer..." function. In the end, this will allow you to transfer the required "single" type licenses to the operator stations.

In the Automation License Manager, add the ES server to each ES as an additional computer so that floating licenses can be used for the engineering on the other ES via network.

However, if several project engineers carry out simultaneous engineering, a complete set of licenses must be present on the ES server for each ES.
3.3 Archiving

Archiving the project status regularly in a defined location. To do this, adjust the archiving settings in the SIMATIC Manager beforehand, according to your needs. Due to the division into projects, when you carry out changes within a project it is sufficient to back up just the specific project, rather than to archive the entire multiproject. This is only necessary if cross-project functions have been performed.

Application cases for the ES server
- Archiving a multiproject in definable intervals, if all work has been set and all projects are available
  (Recommendation: all projects are stored locally.)
- Archiving a project e.g. daily, if all jobs are set or after each download of AS changes

Application cases for a distributed ES
- Archiving a project stored in the distributed ES
  This generally only applies to projects with AS.

General notices
If you are archiving projects and you receive a message saying that the objects are still locked, click on "Details" to see which objects are locked. The following objects are often the cause of the message:
- The SIMATIC PDM ASSET service is not in the "Stopped" state.
  - Under Details, you will see the entry saying that the "pdmdata.db" or "pdmlock.db" files are in use by another application.
  - Open the tool "SIMATIC PDM ASSET Service Manager".
  - Click "Stop" in the "SIMATIC PDM Service Asset Manager" menu.
  - Restart the archiving process.
- OS database files are not yet separated from the SQL Server.
  - Under Details, you see the entry saying that ".ldf" or ".mdf" files are in use by another application.
  - Reopen the appropriate OS project in WinCC Explorer.
  - Close the project in WinCC Explorer using the menu command "File > Close".
  - Close WinCC Explorer.
  - Restart the archiving process.

Notes on locked files can also be found in the Windows Computer Management, in "Shared folders> Opened files > Lock count column". Here, the value should not be greater than "0".

For performance reasons, it is recommended not to archive ES server projects/multiprojects via network. In this case, you can open a VNC connection to the ES server and start archiving in this way on the ES server (see chapter 3.4 "Remote access to the ES server").
3 Higher-level topics

3.4 Remote access to the Engineering Server

Tools

With the optional PCS 7 Trail version you create version states for multiprojects, projects and libraries. Other functions of the Trail version are automatic archiving and automatic readback.

Reference

- Configuration manual “PCS 7 Engineering System” /3/
- Post "Why is it sometimes not possible to archive a PCS 7 project with the SIMATIC Manager or SIMATIC Trail?"

3.4 Remote access to the Engineering Server

In certain situations – for example, when no work is being carried out on the ES server – it can be advantageous to run specific actions on the ES server, while one is already working on another ES. This saves time and network load.

To connect to the ES Server, one can for example use RealVNC in PCS 7 V8.1.

Possible functions

The following actions can be, for example, started remotely on the ES server when one takes heed of the descriptions in chapter 2.4 "Working in parallel".

- AS compiling and downloading
- Compiling the OS
- Archiving the project

For all cross-project functions, such as for example multiproject archiving, it is generally recommended to avoid parallel work and to exit all editors beforehand.

Reference

"How do you access WinCC and PCS 7 plants with "RealVNC"?"
https://support.industry.siemens.com/cs/de/en/view/55422236
4 Literature

4.1 Internet links

This list does not purport to be complete and only provides a selection of suitable information.

Table 4-1

<table>
<thead>
<tr>
<th>Subject area</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>\1\ Siemens Industry Online Support</td>
<td><a href="http://support.industry.siemens.com">http://support.industry.siemens.com</a></td>
</tr>
<tr>
<td>\2\ Article download page</td>
<td><a href="https://support.industry.siemens.com/cs/ww/en/view/22258951">https://support.industry.siemens.com/cs/ww/en/view/22258951</a></td>
</tr>
</tbody>
</table>

4.2 Related documents

This list is by no means complete and merely reflects a selection of suitable literature.

Table 4-2

<table>
<thead>
<tr>
<th>Subject area</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>/1/ Installation</td>
<td>Manual “SIMATIC Process Control System PCS 7 PCS 7-PC Configuration (V8.1 SP1)”</td>
</tr>
<tr>
<td>/2/ CFC</td>
<td>Manual “SIMATIC Process Control System PCS 7 CFC for SIMATIC S7 (V8.1)”</td>
</tr>
<tr>
<td>/3/ PCS 7 ES</td>
<td>Manual “SIMATIC Process Control System PCS 7 Engineering System (V8.1)”</td>
</tr>
<tr>
<td>/4/ Compendium</td>
<td>SIMATIC Process Control System PCS 7 Compendium Part A - Configuration Guidelines (V8.1)</td>
</tr>
<tr>
<td>/5/ SIMATIC BATCH</td>
<td>Multiproject Engineering with SIMATIC BATCH</td>
</tr>
<tr>
<td></td>
<td><a href="https://support.industry.siemens.com/cs/de/en/view/23785345">https://support.industry.siemens.com/cs/de/en/view/23785345</a></td>
</tr>
</tbody>
</table>
## 5 History

Table 5-1

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>V1.0</td>
<td>09/12/2007</td>
<td>First edition on the PCS 7 V7.0 SP1 DVD</td>
</tr>
<tr>
<td>V2.0</td>
<td>11/05/2009</td>
<td>Layout adjustment on applications &amp; tools design</td>
</tr>
<tr>
<td>V3.0</td>
<td>11/15/2011</td>
<td>Multiuser engineering for CFC/SFC extended by additional ES/OS components</td>
</tr>
<tr>
<td>V3.1</td>
<td>07/03/2012</td>
<td>Basis PCS 7 V7.1 SP3: Chapter supplemented or extended</td>
</tr>
<tr>
<td>V4.0</td>
<td>07/02/2013</td>
<td>Basis PCS 7 V8.0 SP1: Revised version</td>
</tr>
<tr>
<td>V5.0</td>
<td>05/11/2015</td>
<td>Basis PCS 7 V8.1: Revised version, chapter supplemented or extended</td>
</tr>
</tbody>
</table>