SIMATIC

Process Control System PCS 7
Software update with utilization of new functions

Service Manual

Valid for PCS 7 as of V7.1 SP4 according to V8.2

03/2016
A5E36200190-AA
Legal information

Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are graded according to the degree of danger.

| **DANGER** | indicates that death or severe personal injury will result if proper precautions are not taken. |
| **WARNING** | indicates that death or severe personal injury may result if proper precautions are not taken. |
| **CAUTION** | indicates that minor personal injury can result if proper precautions are not taken. |
| **NOTICE** | indicates that property damage can result if proper precautions are not taken. |

If more than one degree of danger is present, the warning notice representing the highest degree of danger will be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property damage.

Qualified Personnel

The product/system described in this documentation may be operated only by personnel qualified for the specific task in accordance with the relevant documentation, in particular its warning notices and safety instructions. Qualified personnel are those who, based on their training and experience, are capable of identifying risks and avoiding potential hazards when working with these products/systems.

Proper use of Siemens products

Note the following:

| **WARNING** | Siemens products may only be used for the applications described in the catalog and in the relevant technical documentation. If products and components from other manufacturers are used, these must be recommended or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and maintenance are required to ensure that the products operate safely and without any problems. The permissible ambient conditions must be complied with. The information in the relevant documentation must be observed. |

Trademarks

All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability

We have reviewed the contents of this publication to ensure consistency with the hardware and software described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the information in this publication is reviewed regularly and any necessary corrections are included in subsequent editions.
Table of contents

1 Security information ................................................................. 7

2 Preface ...................................................................................... 9

3 Introduction .............................................................................. 15

3.1 Defining a strategy for the software update ......................... 15
3.2 General Requirements .......................................................... 17
3.3 Important Information for Updating Software with Utilization of New Functions ..................... 18
3.4 Information on the Operating System ................................. 21
3.5 Information on Products from the PCS 7-Add On Catalog .... 21
3.6 Licensing with the Automation License Manager ............... 22

4 Overview of Upgrade Steps ......................................................... 23

4.1 Information about software update procedure .................... 23
4.2 Overview of the Procedure .................................................... 23

5 Preparing for the software update ............................................. 27

5.1 Migration of CAS databases to the Process Historian .......... 27
5.1.1 Overview of Adaptations for Central Archiving ............... 27
5.1.2 How to Detach Attached Archive Segments on the Central Archive Server ............... 27
5.1.3 Migration of CAS databases to the Process Historian .... 28
5.2 Necessary preparations .......................................................... 30
5.2.1 Overview of preparations ................................................ 30
5.2.2 Exchanging Data Via OPC A&E ..................................... 31
5.2.3 How to Back Up PCS 7 Project Data ............................... 31
5.2.4 How to Back Up User Created Libraries ....................... 34
5.2.5 Operator and Display Texts in Blocks ............................... 35
5.2.6 How to Export Operator and Display Texts .................... 35
5.2.7 Non-approved network adapters ..................................... 36
5.2.8 How to check the network adapter ................................. 37
5.2.9 How to prepare projects with high-precision time stamping .......... 38
5.2.10 Backing up pictures for user-defined status displays .......... 39
5.2.11 Backing Up the License Keys and Authorizations ........... 40

6 Adaptations to the Hardware ..................................................... 41

6.1 Overview of Update of the Hardware .................................... 41
6.2 Planning and preparation ....................................................... 41
6.3 How to Prepare for Replacement of the Hardware ............... 42
6.4 How to Perform Updates and Replace the Hardware ........... 43

7 Installation of PCS 7 and settings on the ES and OS .............. 45

7.1 Overview of Installation and Settings on the ES and OS .......... 45
# Table of contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.2</td>
<td>Preparing the PC Station</td>
<td>45</td>
</tr>
<tr>
<td>7.3</td>
<td>How to install PCS 7</td>
<td>46</td>
</tr>
<tr>
<td>7.4</td>
<td>How to enable encrypted communication between the PC stations</td>
<td>49</td>
</tr>
<tr>
<td>7.5</td>
<td>Updating SIMATIC PCS 7 AS RTX</td>
<td>51</td>
</tr>
<tr>
<td>7.6</td>
<td>Transmission Rate and Operating Mode in the PC Network</td>
<td>52</td>
</tr>
<tr>
<td>7.7</td>
<td>Installation of Additional PCS 7 Libraries</td>
<td>53</td>
</tr>
<tr>
<td>7.8</td>
<td>How to Install Additional PCS 7 Libraries</td>
<td>54</td>
</tr>
<tr>
<td>7.9</td>
<td>What are the requirements for using the Advanced Process Library?</td>
<td>55</td>
</tr>
<tr>
<td>7.10</td>
<td>How to Install Additional Non-standard Libraries</td>
<td>56</td>
</tr>
<tr>
<td>7.11</td>
<td>How to update user-specific APL faceplates</td>
<td>57</td>
</tr>
<tr>
<td>7.12</td>
<td>Modules in Configured Mode and PG Mode</td>
<td>58</td>
</tr>
<tr>
<td>7.13</td>
<td>How to Configure and Download the PC Stations</td>
<td>59</td>
</tr>
<tr>
<td>8</td>
<td>Adoptions in the PCS 7 Project on the ES</td>
<td>63</td>
</tr>
<tr>
<td>8.1</td>
<td>Update of a PCS 7 Project</td>
<td>63</td>
</tr>
<tr>
<td>8.2</td>
<td>General adaptations</td>
<td>63</td>
</tr>
<tr>
<td>8.2.1</td>
<td>Overview of General Adaptations in the Project</td>
<td>63</td>
</tr>
<tr>
<td>8.2.2</td>
<td>How to update the configuration of the operator stations</td>
<td>63</td>
</tr>
<tr>
<td>8.2.3</td>
<td>Changing the Configuration of Multilingual Texts</td>
<td>64</td>
</tr>
<tr>
<td>8.2.4</td>
<td>How to Check the PH Consistency</td>
<td>65</td>
</tr>
<tr>
<td>8.3</td>
<td>Adaptations in HW Config</td>
<td>66</td>
</tr>
<tr>
<td>8.3.1</td>
<td>Overview of Adaptation of the Hardware</td>
<td>66</td>
</tr>
<tr>
<td>8.3.2</td>
<td>How to Configure Replaced Hardware</td>
<td>66</td>
</tr>
<tr>
<td>8.3.3</td>
<td>How to Set the CPU Properties</td>
<td>67</td>
</tr>
<tr>
<td>8.3.4</td>
<td>How to update the hardware configuration for SIMATIC PCS 7 BOX RTX and SIMATIC PCS 7 AS RTX</td>
<td>68</td>
</tr>
<tr>
<td>8.3.5</td>
<td>How to configure the SIMATIC PDM Server</td>
<td>68</td>
</tr>
<tr>
<td>8.4</td>
<td>Adaptations in NetPro and conversion of the CFC/SFC charts</td>
<td>70</td>
</tr>
<tr>
<td>8.4.1</td>
<td>How to Check and Adapt the Connection Data in NetPro</td>
<td>70</td>
</tr>
<tr>
<td>8.4.2</td>
<td>How to convert the CFCs</td>
<td>72</td>
</tr>
<tr>
<td>8.5</td>
<td>Updating the blocks</td>
<td>72</td>
</tr>
<tr>
<td>8.5.1</td>
<td>Overview of tasks for updating blocks</td>
<td>72</td>
</tr>
<tr>
<td>8.5.2</td>
<td>Integration of a New Master Data Library</td>
<td>73</td>
</tr>
<tr>
<td>8.5.3</td>
<td>Language of Message Texts in Faceplates</td>
<td>73</td>
</tr>
<tr>
<td>8.5.4</td>
<td>Editing Texts for Faceplates</td>
<td>74</td>
</tr>
<tr>
<td>8.5.5</td>
<td>Rules for Copying Objects from Other Libraries</td>
<td>75</td>
</tr>
<tr>
<td>8.5.6</td>
<td>Rules for Editing the Operator Texts</td>
<td>75</td>
</tr>
<tr>
<td>8.5.7</td>
<td>How to Copy Objects from Other Libraries to the Master Data Library</td>
<td>76</td>
</tr>
<tr>
<td>8.5.8</td>
<td>How to fill the master data library</td>
<td>77</td>
</tr>
<tr>
<td>8.5.9</td>
<td>Trend Control for Displaying Archive Values</td>
<td>79</td>
</tr>
<tr>
<td>8.5.10</td>
<td>How to Configure Extensions for Online Trend Control</td>
<td>79</td>
</tr>
<tr>
<td>8.5.11</td>
<td>How to Update the Master Data Library</td>
<td>81</td>
</tr>
<tr>
<td>8.5.12</td>
<td>How to include event texts from the block type in the block import</td>
<td>83</td>
</tr>
<tr>
<td>8.5.13</td>
<td>How to import the operator texts</td>
<td>84</td>
</tr>
</tbody>
</table>

---

Adaptations in the PCS 7 Project on the ES | 63  
8.1 Update of a PCS 7 Project | 63  
8.2 General adaptations | 63  
8.2.1 Overview of General Adaptations in the Project | 63  
8.2.2 How to update the configuration of the operator stations | 63  
8.2.3 Changing the Configuration of Multilingual Texts | 64  
8.2.4 How to Check the PH Consistency | 65  
8.3 Adaptations in HW Config | 66  
8.3.1 Overview of Adaptation of the Hardware | 66  
8.3.2 How to Configure Replaced Hardware | 66  
8.3.3 How to Set the CPU Properties | 67  
8.3.4 How to update the hardware configuration for SIMATIC PCS 7 BOX RTX and SIMATIC PCS 7 AS RTX | 68  
8.3.5 How to configure the SIMATIC PDM Server | 68  
8.4 Adaptations in NetPro and conversion of the CFC/SFC charts | 70  
8.4.1 How to Check and Adapt the Connection Data in NetPro | 70  
8.4.2 How to convert the CFCs | 72  
8.5 Updating the blocks | 72  
8.5.1 Overview of tasks for updating blocks | 72  
8.5.2 Integration of a New Master Data Library | 73  
8.5.3 Language of Message Texts in Faceplates | 73  
8.5.4 Editing Texts for Faceplates | 74  
8.5.5 Rules for Copying Objects from Other Libraries | 75  
8.5.6 Rules for Editing the Operator Texts | 75  
8.5.7 How to Copy Objects from Other Libraries to the Master Data Library | 76  
8.5.8 How to fill the master data library | 77  
8.5.9 Trend Control for Displaying Archive Values | 79  
8.5.10 How to Configure Extensions for Online Trend Control | 79  
8.5.11 How to Update the Master Data Library | 81  
8.5.12 How to include event texts from the block type in the block import | 83  
8.5.13 How to import the operator texts | 84  

---

Software update with utilization of new functions
Service Manual, 03/2016, A5E36200190-AA
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>8.5.14</td>
<td>How to adapt the operator texts</td>
<td>84</td>
</tr>
<tr>
<td>8.5.15</td>
<td>How to update the block types in the project</td>
<td>85</td>
</tr>
<tr>
<td>8.5.16</td>
<td>How to update the SFC block types in the project</td>
<td>87</td>
</tr>
<tr>
<td>8.5.17</td>
<td>Compiling the CFC Charts</td>
<td>88</td>
</tr>
<tr>
<td>8.6</td>
<td>Adaptation of OS-relevant settings</td>
<td>88</td>
</tr>
<tr>
<td>8.6.1</td>
<td>Overview of Adaptation of the Operator Stations</td>
<td>88</td>
</tr>
<tr>
<td>8.6.2</td>
<td>Synchronization of OS Basic Pictures, Local Computer Actions and Faceplates</td>
<td>89</td>
</tr>
<tr>
<td>8.6.3</td>
<td>How to Synchronize OS Basic Pictures, Local Computer Actions, and Faceplates</td>
<td>89</td>
</tr>
<tr>
<td>8.6.4</td>
<td>Update of Picture Objects</td>
<td>91</td>
</tr>
<tr>
<td>8.6.5</td>
<td>How to Update the Picture Objects</td>
<td>92</td>
</tr>
<tr>
<td>8.6.6</td>
<td>How to update block icons containing user customizations</td>
<td>93</td>
</tr>
<tr>
<td>8.7</td>
<td>Adaptations for the Process Historian</td>
<td>95</td>
</tr>
<tr>
<td>8.7.1</td>
<td>Adaptations for the Process Historian at a glance</td>
<td>95</td>
</tr>
<tr>
<td>8.7.2</td>
<td>How to update the Process Historian and Information Server</td>
<td>95</td>
</tr>
<tr>
<td>8.7.3</td>
<td>How to replace the CAS with the PH</td>
<td>96</td>
</tr>
<tr>
<td>8.8</td>
<td>Adaptations for the Maintenance Station</td>
<td>97</td>
</tr>
<tr>
<td>8.8.1</td>
<td>Overview of the Maintenance Station update</td>
<td>97</td>
</tr>
<tr>
<td>8.8.2</td>
<td>How to change the OPC Server and adapt the SNMP configuration</td>
<td>98</td>
</tr>
<tr>
<td>8.8.3</td>
<td>How to update the diagnostics settings</td>
<td>100</td>
</tr>
<tr>
<td>8.8.4</td>
<td>How to update the diagnostics screens</td>
<td>101</td>
</tr>
<tr>
<td>8.9</td>
<td>Additional Options</td>
<td>103</td>
</tr>
<tr>
<td>8.9.1</td>
<td>Overview of additional options</td>
<td>103</td>
</tr>
<tr>
<td>8.9.2</td>
<td>Updating the PCS 7 Web Option for OS</td>
<td>103</td>
</tr>
<tr>
<td>8.9.3</td>
<td>Updating PCS 7 Components that Use SIMATIC Logon Services</td>
<td>103</td>
</tr>
<tr>
<td>8.10</td>
<td>Work for the OS in SIMATIC Manager</td>
<td>104</td>
</tr>
<tr>
<td>8.10.1</td>
<td>Overview of compiling</td>
<td>104</td>
</tr>
<tr>
<td>8.10.2</td>
<td>Information regarding the compilation modes</td>
<td>104</td>
</tr>
<tr>
<td>8.10.3</td>
<td>How to Specify the Compilation Mode</td>
<td>105</td>
</tr>
<tr>
<td>8.10.4</td>
<td>How to Compile the OS</td>
<td>105</td>
</tr>
<tr>
<td>8.10.5</td>
<td>Mixed operation and visualization of AS blocks from different PCS 7 versions</td>
<td>107</td>
</tr>
<tr>
<td>8.11</td>
<td>Conversion of standard blocks to APL blocks</td>
<td>108</td>
</tr>
<tr>
<td>9</td>
<td>Downloading of Target Systems</td>
<td>109</td>
</tr>
<tr>
<td>10</td>
<td>Activate the operator stations</td>
<td>111</td>
</tr>
<tr>
<td>10.1</td>
<td>Overview of activating the operator stations</td>
<td>111</td>
</tr>
<tr>
<td>10.2</td>
<td>How to Check the Settings on the OS Servers</td>
<td>111</td>
</tr>
<tr>
<td>10.3</td>
<td>How to Check the Settings on the OS Clients</td>
<td>112</td>
</tr>
<tr>
<td>11</td>
<td>Updating SIMATIC BATCH stations</td>
<td>113</td>
</tr>
<tr>
<td>12</td>
<td>Updating SIMATIC Route Control Stations</td>
<td>115</td>
</tr>
<tr>
<td>13</td>
<td>Migration of archive data from a central archive server (CAS)</td>
<td>117</td>
</tr>
<tr>
<td>13.1</td>
<td>Archive migration at a glance</td>
<td>117</td>
</tr>
<tr>
<td>13.2</td>
<td>How to migrate the archives in the Process Historist</td>
<td>117</td>
</tr>
</tbody>
</table>

Index .................................................................................................................................................... 119
Siemens provides products and solutions with industrial security functions that support the secure operation of plants, solutions, machines, equipment and/or networks. They are important components in a holistic industrial security concept. With this in mind, Siemens' products and solutions undergo continuous development. Siemens recommends strongly that you regularly check for product updates.

For the secure operation of Siemens products and solutions, it is necessary to take suitable preventive action (e.g. cell protection concept) and integrate each component into a holistic, state-of-the-art industrial security concept. Third-party products that may be in use should also be considered. For more information about industrial security, visit http://www.siemens.com/industrialsecurity

To stay informed about product updates as they occur, sign up for a product-specific newsletter. For more information, visit http://support.automation.siemens.com.
Preface

Purpose of this documentation

This documentation provides a comprehensive overview of the steps you must take to adapt your existing PCS 7 process control system to the new SIMATIC PCS 7 version. It supports you in updating PCS 7 projects and guides you through installation and commissioning of the current software.

The contents of the documentation are directed toward service personnel, commissioning personnel, and experienced PCS 7 users with the necessary system knowledge. The documentation provides instructions for carrying out the software update.

Refer to the documentation for specific products for information regarding the handling of these products.

Scope of the documentation

This documentation applies to the software package Process Control System; SIMATIC PCS 7 V8.2.
Options for accessing PCS 7 documentation

The documentation required for PCS 7 includes the following types:

- **PCS 7 Readme**
  The readme file is available in two versions:
  - **PCS 7 Readme (offline)**
    This version is installed by PCS 7 Setup. The file only contains general information and links to documents on the Internet.
  - **PCS 7 Readme (online)**
    This version contains all information on the installation and use of PCS 7 in the format which is already familiar to you. The file is only available on the Internet to keep it always up-to-date.

  **Note**
  The information provided in the PCS 7 Readme (online) on the Internet takes precedence over all other PCS 7 documentation.
  Read this PCS 7 Readme carefully, because it contains important information and amendments on PCS 7.

- **PCS 7 System Documentation**
  System documentation contains information that covers several products, such as configuration manuals and Getting Started manuals. This documentation serves as a guideline for the overall system and explains the interaction between the individual hardware and software components.
  Read the information on "PCS 7 Documentation Portal Setup" in the product overview Process Control System PCS 7; PCS 7 - Documentation; Section "Options for accessing the documentation".

- **PCS 7 Product Documentation**
  Product documentation contains information about special hardware and software components. The individual documents provide detailed information on the specific component.
  Full versions of the documentation are available from the "Technical Documentation SIMATIC PCS 7" website:
  http://www.siemens.com/pcs7-documentation (http://www.siemens.com/pcs7-documentation)
  You can find additional information in the product overview Process Control System PCS 7; PCS 7 - Documentation; Section "Options for accessing the documentation".
Documentation for the software update

You can find all documentation on the topic of "Software update" on the Internet.

<table>
<thead>
<tr>
<th>Documentation</th>
<th>Contents</th>
</tr>
</thead>
</table>
| Manual Software update without utilization of new functions | Describes the procedure for the software update of PCS 7 projects without utilization of new functions.  
  - Original version of the existing project: PCS 7 as of V7.1 SP4  
  - Project to be updated to the following version without utilization of new functions: PCS 7 V8.2 |
| Manual Software update with utilization of new functions | Describes the procedure for the software update of PCS 7 projects with utilization of new functions.  
  - Original version of the existing project: PCS 7 as of V7.1 SP4  
  - Project to be updated to the following version with utilization of new functions: PCS 7 V8.2 |

Additional documentation for the software update

Additional information from the following documentation is required for carrying out the software update:

<table>
<thead>
<tr>
<th>Documentation</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manual Process Control System PCS 7; Service Support and Diagnostics</td>
<td>Ensuring the Availability of a PCS 7 System; contains information on creating backups and how to perform firmware updates.</td>
</tr>
<tr>
<td>Manual Process Control System PCS 7; PCS 7 PC Configuration</td>
<td>PCS 7 PC - Hardware and Installation; Windows settings and tools; Software packages and required license keys.</td>
</tr>
<tr>
<td>Configuration manual Process Control System PCS 7; Engineering System</td>
<td>Guide to configuration steps in SIMATIC Manager, CFC, SFC, NetPro</td>
</tr>
<tr>
<td>Configuration manual Process Control System PCS 7; Operator Station</td>
<td>Guide to configuration steps in WinCC</td>
</tr>
<tr>
<td>Function manual Process Control System PCS 7; Fault-tolerant Process Control Systems</td>
<td>Guide to configuration steps for fault-tolerant process control systems</td>
</tr>
</tbody>
</table>
| Documentation Process Control System PCS 7; Released Modules | All modules released for SIMATIC PCS 7 are listed together with the following information:  
  - Product designation  
  - Article number  
  - Firmware version  
  - Brief description |
| Online help WinCC Information System | Describes the updating of WinCC projects. |
| Manual Process Control System PCS 7; Web Option for OS | Describes the installation and use of the Web Option for OS in PCS 7 |
## Preface

### Documentation

<table>
<thead>
<tr>
<th>Documentation</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manual <em>Process Control System PCS 7; OpenPCS 7</em></td>
<td>Describes how an OPC A&amp;E server with hierarchical access is used in PCS 7 systems</td>
</tr>
<tr>
<td>Function manual <em>Process Control System PCS 7; Fault-tolerant Process Control Systems</em></td>
<td>Describes the principles of use of fault-tolerant (redundant) components in SIMATIC PCS 7.</td>
</tr>
<tr>
<td>SIMATIC manual <em>S7 F/FH Automation Systems</em></td>
<td>Describes the configuration and programming of S7 F/FH failsafe systems using S7 F systems. Contains important information which must be taken into account when installing and using the S7 F system optional package in PCS 7.</td>
</tr>
<tr>
<td>Readme for SIMATIC S7 F Systems</td>
<td></td>
</tr>
<tr>
<td>What's new?</td>
<td>Information on the differences between this version and the previous version of PCS 7</td>
</tr>
</tbody>
</table>

### Required basic knowledge

General knowledge in the area of automation engineering and basic knowledge of PCS 7 is required to understand this documentation. You also need to know how to use PCs with Windows operating systems.

The following documentation provides basic information on working with PCS 7:

- Configuration manual *Process Control System PCS 7; Engineering System*
- Configuration manual *Process Control System PCS 7; Operator Station*
- Getting Started *Process Control System PCS 7; Part 1*

### Software update up to PCS 7 V7.1 SP4

All projects up to PCS 7 V7.1 SP4 are updated in several steps. You will receive the necessary instructions with the associated software packages.

### Conventions

In this documentation, the names of elements in the software interface are specified in the language of this documentation. If you have installed a multi-language package for the operating system, some of the designations will be displayed in the base language of the operating system after a language switch and will, therefore, differ from the designations used in the documentation.

### Changes compared with previous versions

Below, you will find an overview of the most important changes compared with previous versions:

**As of PCS 7 V8.2**

- Updating block icons containing user customizations.
- Plant-specific configuration of the key sets

**As of PCS 7 V8.1**

- The operating systems must be changed (Windows 7 or Windows Server 2008 R2)
 Archive server

The central archive server (CAS) is not supported. Replace the CAS with the following PC stations:

- Process Historian as external archive server
- Information Server as reporting system

Information on configurations can be found in the documentation Process Control System PCS 7; PCS 7 PC Configuration.

Information on Migration can be found in the documentation SIMATIC; Process Historian 2014; Process Historian Administration.

- PC stations that are involved in process mode can be connected using encrypted communication.
- When the Advanced Process Library is used, the operator station can display the block icons for AS blocks from different library versions in the process pictures.
- When using the Advanced Process Library, the following functions are available in process pictures of the OS:
  - Representation of the block icons for AS blocks, even if different library versions are loaded to the connected automation systems.
  - Specification of the size of block icons in the Advanced Process Library (as of V8.1).
- Changing the interface of AS blocks in RUN
- Selective compiling and downloading of automation systems

As of PCS 7 V8.0 including SP1

- User-configurable message classes
- Redundant, fault-tolerant terminal bus based on the Parallel Redundancy Protocol (PRP)
- Process Historian
  - Redundant Process Historian
  - Migration of the central archive server (CAS) to Process Historian
    You can find additional information on this in the "WinCC Classic Information System".
- Updating computers using the SIMATIC Management Console
  You can find information on this in the online help SIMATIC Process Control System PCS 7; SIMATIC Management Console.

As of PCS 7 V8.0:

- Use of the Advanced Process Library (APL) V8.0 as standard library for configuration.

PCS 7 V7.1 or higher:

- PCS 7 setup automatically installs the necessary hotfixes and SQL server.
- Use of OS clients as maintenance clients (default configuration for an OS client in terms of the maintenance server)

- Information on virus scanners can be found in the whitepaper *SIMATIC Process Control System PCS 7; Security Information Note; Setting Virus Scanners*. It can be downloaded from the Customer Support (https://www.siemens.com/automation/service) websites under the following entry number: 26366540 (http://support.automation.siemens.com/WW/view/en/26366540).

- The architecture for SIMATIC PDM has been modified. You can find additional information on this in the section "How to configure the SIMATIC PDM Server (Page 68)".
3.1 Defining a strategy for the software update

Decision Process

The selection and use of the correct documentation depends on the comprehensiveness of your software update, the current status of the software and any boundary conditions that may exist.

The following flow chart shows you the documentation to use when updating a PCS 7 plant.

- Are the blocks of the library of PCS 7 as of V7.1.3 used in the project?
  - Yes
  - Intermediate steps are required for the updating of your project. Depending on the PCS 7 version of your project, you have to update the engineering system and the project:
    - from PCS 7 V5.x to PCS 7 V6.1 (SP4)
    - from PCS 7 V6.1 SPx to PCS 7 V7.1 (SP4)
    - from PCS 7 V7.0 SPx to PCS 7 V7.1 (SP4)
    - To do this, use the manuals for the software update of the corresponding PCS 7 version.
  - No

- Do you want to use the new functions of PCS 7 V8.2?
  - Yes
    - Software update PCS 7 V7.1 SP4 to V8.2 with permanent plant operation
    - Software update PCS 7 V7.1 SP4 to V8.2 without permanent plant operation
  - No

- Present Documentation
  - Manual: "Software update with utilization of new functions (PCS 7 V7.1.4 or higher to V8.2)"
  - Software update PCS 7 V7.1 SP4 to V8.2 with permanent plant operation
  - Function Manual
  - PCS 7 Fault-tolerant Process Control Systems; Guidelines for updating a redundant OP during operation
  - Software update PCS 7 V7.1 SP4 to V8.2 without permanent plant operation
  - Manual: "Software updates without utilization of new functions (PCS 7 V7.1.4 or higher to V8.2)"
3.1 Defining a strategy for the software update

Note
Operating systems
Observe the requirements for the operating systems. You can find additional information on this in the documentation Process Control System PCS 7; PCS 7 Readme (online).

Note
Intermediate steps required for the software update
If you cannot directly upgrade to the current PCS 7 version of a PCS 7 project, the intermediate steps shown in the figure are required.
The steps described in the accompanying documentation must be completed.
Exception when permanent operability of the system is not required:
You can skip the download of the operator control and monitoring systems in the intermediate steps.

See also
General Requirements (Page 17)
3.2 General Requirements

General requirements for updating the software

- Your PC hardware must meet the hardware requirements of the current PCS 7 version. For additional information, refer to the documentation Process Control System PCS 7; PCS 7 - Readme (online).

- The PC where the PCS 7 software is installed must meet one of the following requirements:
  - It can access the PCS 7 software via a network (sharing of a network folder or DVD drive).
  - It has its "own" DVD drive (example: USB DVD drive).

  **Note**
  You must complete the software update before beginning with any additional changes to the configuration.

- The project must be updated to at least PCS 7 V7.1 SP4. Only use the latest library versions for PCS 7 libraries:
  - Library versions for PCS 7 V7.1 SP4
  - Library versions for PCS 7 V8.0 SP2
  - Library versions for PCS 7 V8.1 SP1
  - Library versions for PCS 7 V8.2

  **Recommendation:**
  Check the compatibility of the library versions using the compatibility tool.

  **Note**
  If AS blocks from other PCS 7 versions are used in the project, it will be necessary to update these blocks via a software update using new functions.

  You can find the download files for setups of older versions of the PCS 7 Library, the PCS 7 Basic Library or the PCS 7 Advanced Process Library on the Internet (https://support.industry.siemens.com/cs/ww/en/view/109480136).

Checking the compatibility

3.3 Important Information for Updating Software with Utilization of New Functions

Asian text in PCS 7

In the following cases, you need a USB hardlock for your PCS 7 version:

- You want to install PCS 7 on an Asian operating system
- You want to install an Asian version of PCS 7
- You want to display Asian text in the user interface

The USB hardlock stores the license information you need to operate and configure your version of PCS 7. Please contact your Siemens representative for information on the available Asian language versions.

Note

A message indicates missing ASIA hardlock in a non-Asian project

Check the language of the operating system and PCS 7. When language columns are configured for Asian text in a PCS 7 project and you do not need this Asian text, you can delete these language columns from the text library of all OS projects. It is then possible to operate with a license key for the PCS 7 version and without a USB hardlock.

3.3 Important Information for Updating Software with Utilization of New Functions

Requirements for Performing a Software Update

- The software update with utilization of the new functions requires that the CPU be switched to STOP mode.

- The project must fully correspond to a project that has been configured with PCS 7 as of the following version:
  PCS 7 V7.1 SP3
  Keep this in mind especially if you have performed previous updates without utilization of new functions.

- Ensure that your hardware meets the requirements for PCS 7. You can find information on this in the section "Planning and preparation (Page 41)". If system components are not suitable for the updated version of PCS 7, they need to be replaced. In some cases, you must adapt or redo the configuration of the components that have been replaced in the updated project.

- When updating the BIOS or the components' firmware, we recommend that these components be completely separated from any connected networks.

- Finish the software update before configuring new functions.

- Note that in case of a software update with the use of new functions, you must delete blocks that may be present in your project or master data library but that are no longer used in the PCS 7 standard library (OB_DIAG, OR_M_16 and OR_M_32) before you add the new library blocks.
• The manual contains some sections that are not listed in the overview. Observe the information provided in these sections when updating the software and check whether this information is relevant to your PCS 7 system.

• If you use high-precision time stamping in PCS 7, you should configure it in accordance with PCS 7 V8.1.

• You can find information on operating systems approved for PCS 7 in the Process Control System PCS 7; PCS 7 Readme documentation (online). This file contains additional information pertaining to the operating systems and necessary service packs. The Server operating system is required for the following PC stations:
  – Server (redundant and non-redundant) for OS, SIMATIC BATCH, SIMATIC Route Control
  – Server for Web Option for OS
  – Server for engineering station with multiproject (central data store) for engineering with multiple engineering stations

• When the operating system is changed:
  Ensure that the hardware of the PC stations is suitable for use with the updated PCS 7 version (e.g. operating systems, network adapter).
  Read section "How to Check and Adapt the Connection Data in NetPro (Page 70)".

• The software update of password-protected projects requires SIMATIC Logon on an ES.

• For projects with activated FDA access protection for WinCC tag export, you have to open the WinCC project in SIMATIC Manager beforehand.

• The blocks of all the PCS 7 libraries for a PCS 7 version can be operated together in an AS.

• You need upgrade license keys to update PCS 7:
  – V7.1 -> V8.0 (zusätzlicher Upgrade License Key)
  – V8.0 -> V8.2
  – V8.1 -> V8.2

• The same block icons for AS blocks from different library versions can be shown in the process pictures of an OS beginning with PCS 7 V8.1. If an OS is assigned to several AS, only AS blocks of the following versions of the Advanced Process Library can be configured for each AS:
  – AS blocks from PCS 7 V7.1 SP3
  – AS blocks as of PCS 7V8.1

• SFC blocks configured in the AS must be replaced by the latest SFC blocks.

• During configuration of an OS, several project users can work on the following objects of an operator station:
  – Edit various process pictures of an OS.
  – Edit various reports of an OS.
  – Edit various scripts of an OS.
• You cannot use the new functions from PCS 7 until after the complete migration.

• Notes on compatibility for SFC
  – You cannot "reconvert" V8.2 data to older versions.
  – Data that was created with SFC Visualization V8.2 cannot be processed or displayed with older SFC Visualization versions.

Note
Read the decision-making aid in section "Defining a strategy for the software update (Page 15)"

Note
Archive server
The central archive server (CAS) is not supported. Replace the CAS with the following PC stations:
• Process Historian as external archive server
• Information Server as reporting system

You can find information on configurations in the documentation Process Control System PCS 7; PCS 7 PC Configuration.

You can find information on migration in the documentation SIMATIC; Process Historian; Process Historian Administration.

Software update for Process Historian (V8.0 SP2)
If a Process Historian of version 8.0 SP2 is integrated in the project you wish to update, updates must be installed on the Process Historian prior to the software update. Read the PH documentation.

You can find additional information in this documentation and in the Process Historian documentation:
• Installation manual SIMATIC; Process Historian Installation Notes
• System manual SIMATIC; Process Historian Administration, "Migration" section

Projects with add-on applications/products

Note
In some cases, add-on applications/products require intermediate steps. Read the relevant documentation before starting the software update.
Setting up the passivation reaction of the CPU modules

The passivation reaction of the modules depends on the library used:

- Starting with the "Redundant IO" V5.0 library, this setting is defined for specific channels.
- The "Redundant IO" V4.0 library allows you to select a channel-specific setting, depending on the module used.
- The "Redundant IO" V3.0 library only allows you to select module-specific settings.

The "Redundant IO" library V5.0 or higher allows you to automatically identify the possible passivation reaction for a module, based on the configured hardware. During generation of the user program, the passivation reaction is automatically adapted to the reaction with the lowest number of passivated module channels.

You can find additional information on this in the documentation Process Control System PCS 7; Fault-tolerant Process Control Systems.

Time synchronization in a PCS 7 system

Following the software update, the time synchronization of all OS components corresponds to the PCS 7 standard (as of PCS 7 V8.0: not V5-compatible mode).

Result of the Software Update

Following a software update with utilization of new functions, an updated PCS 7 project behaves similar to a project created with the current PCS 7 version.

3.4 Information on the Operating System

Recommendation

In Windows domains, too, you must always use the operating systems approved for PCS 7 if you want to connect your system to other PCs via Intranet or Internet, or if using the PCS 7 Web Option for OS. You can find information on approved operating systems in the documentation Process Control System PCS 7; PCS 7 Readme (online).

3.5 Information on Products from the PCS 7-Add On Catalog

Important Information

If you used PCS 7 add-on products (software packages or hardware components) in your process control system, contact your SIMATIC PCS 7 representative.
3.6 Licensing with the Automation License Manager

Managing the License Keys

Both license keys and authorizations can be transferred using the Automation License Manager. In the following, the term "license key" is always used even when a product uses the old license scheme based on authorizations.

Licensing levels

You can find an overview about licenses and configuration limits in the following documents:

- Catalog ST PCS 7 in the Internet via Technical Support (http://www.siemens.com/automation/service):
- Documentation Process Control System PCS 7; Licenses and Configuration Limits (see Preface (Page 9): Options for accessing PCS 7 documentation)

Additional information

Online help for Automation License Manager
4.1 Information about software update procedure

-The following tables provide an overview of all of the necessary steps for updating software with utilization of new functions.

Rules to Follow Based on the Tables

- Use these tables as guidelines for systematically carrying out all of the updating steps in a sequence.

Note
The exact sequence of configuration steps specified in this documentation must be followed in order to carry out the software update.

- You will receive information for every step as to where you must carry out the configuration work.

- If you do not require some of the new PCS 7 functions, you do not need to activate them. It is possible to activate them later. However, we recommend the complete upgrade of functions described in this document.

4.2 Overview of the Procedure

The following is a general overview of the procedure for updating software. This document contains comprehensive instructions on every step in the table below.

Note
You must complete the software update before beginning with any additional changes to the configuration.

Recommendation:
Finish updating the engineering system and the project before you begin to update the other PC stations.

Legend for overview

- X - perform this step at the relevant stations
- X1 - to be performed only for the central archive server
- X2 - to be performed only for the Process Historians
### Overview of the Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Migration of CAS databases to the Process Historian (Page 28)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Only for projects with central server (CAS)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Backing up PCS 7 project data (Page 31)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Backing up the libraries you created (Page 34)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Exporting operator and display texts (Page 35)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Checking the network adapters (Page 37)</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>6</td>
<td>Preparing projects with high-precision time stamping (Page 38)</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>(only required for projects with high-precision time stamping)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Backing up the license keys and authorizations (Page 40)</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Update of Hardware</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Preparing for hardware replacement (Page 42)</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>9</td>
<td>Updating and replacing hardware (Page 43)</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Installation and settings on the ES and OS</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Preparing the PC station (Page 45)</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>11</td>
<td>Installing the PCS 7 software (Page 46)</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>12</td>
<td>Installing additional PCS 7 libraries (Page 53)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Installing additional non-standard libraries (Page 56)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Setting the &quot;Configured mode&quot;/&quot;PG mode&quot; operating mode (Page 58)</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Configuring and downloading the PC stations (Page 59)</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>General adaptations in the project</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Updating the OS with the Project Migrator (Page 63)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Checking the PH consistency (Page 65)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Adaptations in HW Config</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>Configuring replaced hardware (Page 66)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>Setting the CPU properties (Page 67)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>Updating the hardware configuration (Page 68)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>(only for projects with SIMATIC PCS 7 BOX RTX or SIMATIC PCS 7 AS RTX)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>Configuring the address for the PDM server (Page 68)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>(only for projects with SIMATIC PDM V7.0)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Adaptations in NetPro and conversion of the CFC/SFC charts</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>Checking and adapting the connection data in NetPro (Page 70)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>Converting the CFC and SFC charts (Page 72)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Steps for updating blocks</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>Copying objects from other libraries into the master data library</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>(Page 76)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>Filling the master data library (Page 77)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td>Synchronizing blocks (Page 81)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Step</td>
<td>Action</td>
<td>ES</td>
<td>OS server</td>
<td>OS client</td>
<td>AS</td>
</tr>
<tr>
<td>------</td>
<td>------------------------------------------------------------------------</td>
<td>----</td>
<td>-----------</td>
<td>-----------</td>
<td>----</td>
</tr>
<tr>
<td>27</td>
<td>Including event texts (Page 83)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td>Importing operator texts (Page 84)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td>Adapting operator texts (Page 84)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td>Configuring limits for Online Trend Control (Page 79)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>31</td>
<td>Updating block types (Page 85)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>32</td>
<td>Updating SFC block types (Page 87)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>33</td>
<td>Compiling the CFC charts (Page 88)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Adaptation of OS-relevant settings</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>34</td>
<td>Synchronizing OS root screens, local computer actions and faceplates</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>35</td>
<td>Updating picture objects (Page 92)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Adaptations for the Process Historian</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>36</td>
<td>Updating Process Historian and Information Server (Page 95)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>37</td>
<td>Replacing a central archive server with a Process Historian (Page 96)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Adaptations for the Maintenance Station</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>38</td>
<td>Changing the OPC server and adapting the SNMP configuration (Page 98)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>39</td>
<td>Updating the diagnostics settings (Page 100)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>40</td>
<td>Updating the diagnostics screens (Page 101)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Additional options</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>41</td>
<td>Updating the PCS 7 Web Option for OS (Page 103)</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>42</td>
<td>Updating PCS 7 components that use SIMATIC Logon services (Page 103)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Work for the OS in SIMATIC Manager</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>43</td>
<td>Specifying the compilation mode (Page 105)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>44</td>
<td>Compiling the OS (Page 105)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Downloading to target systems</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>45</td>
<td>Downloading of Target Systems (Page 109)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>For more information on the download options, refer to the Process</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Control System PCS 7: Engineering Station Configuration Manual.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Overview of activating the operator stations</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Sequence for activating process mode (Runtime):</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Process Historian (if available in the project)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Master server (OS server)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Standby server (redundant OS server)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• OS clients</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>46</td>
<td>Checking the settings on the OS servers (Page 111)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>47</td>
<td>Checking the settings on the OS clients (Page 112)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>SIMATIC BATCH software update</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>48</td>
<td>Updating SIMATIC BATCH stations (Page 113)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Only for projects with SIMATIC BATCH</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>SIMATIC Route Control software update</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### 4.2 Overview of the Procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>49</td>
<td>Updating SIMATIC Route Control Stations (Page 115)</td>
<td>Only for projects with SIMATIC Route Control</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Migration of archive data from a central archive server (CAS)</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>50</td>
<td>Migrate the archives in the Process Historian (Page 117)</td>
<td>Only for projects in which the central archive server (CAS) has been replaced with a Process Historian.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Preparing for the software update

5.1 Migration of CAS databases to the Process Historian

5.1.1 Overview of Adaptations for Central Archiving

Central archive server (CAS)

The Central Archive Server (CAS) is not released for PCS 7 V8.1 or higher.
Replace the CAS with a Process Historian.
The migration of archive data from a central archive server is available as of PCS 7 V7.0 (StoragePlus V1.2).
If archive data is to be available after the software update, pay particular attention to the section "How to Detach Attached Archive Segments on the Central Archive Server (Page 27)".

Additional information

You can find information on this in this documentation and in the documentation on the Process Historian:

- system manual SIMATIC; Process Historian Administration, "Migration" section
- Installation manual SIMATIC; Process Historian Installation Notes

5.1.2 How to Detach Attached Archive Segments on the Central Archive Server

Requirements

- Before you run the software update, perform these steps directly on the archive server (Central Archive Server (CAS), or StoragePlus Server).
- You are authorized to access the Windows user interface on the CAS.

Procedure

1. In the Windows Start menu, select the "Administration Console" command from the SIMATIC > StoragePlus submenu.
2. In the detail view, click "Detach".
   The catalog of all linked archive segments which have already been swapped out is displayed.
3. Select an archive segment you wish to remove from the archive.
4. Click "Open". The selected archive segment is detached from the archive. Once the archive segment has been detached from the archive, the archive segment is deleted from the hard disk of the CAS. A message window shows whether the archive segment has been deleted.

5. Click "OK".

6. Repeat steps 2 through 5 for all closed archives.

5.1.3 Migration of CAS databases to the Process Historian

If a central archive server (CAS) was used in the PCS 7 project, this cannot archive new plant data from PCS 7 plants as of V8.1.

Recommendation:

Replace the CAS with the following PC stations:

- Process Historian as external archive server
- Information Server as reporting system

Requirement

The CAS databases were created with a central archive server as of PCS 7 V7.0 (Storage Plus V1.2).
5.1 Migration of CAS databases to the Process Historian

Basic procedure

The following figure shows an example of the migration concept for a CAS (Central Archive Server) database to the Process Historian in a PCS 7 environment.

Legend

1. **Installation of a new PC station**
   Selection for PCS 7: Process Historian
   You can find additional information on this in the documentation *Process Historian; Installation Notes*.

2. Updating the software of the engineering station.
   You can find information on this in the section "Installation of PCS 7 and settings on the ES and OS (Page 45)".

3. Performing the software update for the PCS 7 project.
   You can find information on this in the section "Adaptations in the PCS 7 Project on the ES (Page 63)".

4. **Within the PCS 7 project:**
   Replace the CAS object in the PCS 7 project with a PH object.
   You can find information on this in the section "How to replace the CAS with the PH (Page 96)".

5. Stopping OS servers/OS single-station systems and updating the software.
6. Run "PH-Ready Configuration"

Note
Configuration of Process Historian Ready
The "CCCAPHService" must be configured on the updated OS servers/OS single-station systems before process mode is activated.

You can find information about this in the documentation Process Historian; Installation Notes, section 'Installing the Process Historian Ready component'.

7. Restarting OS servers/single-station systems
The Process Historian must be operating in the "Active" state before the updated OS servers are started for the first time. You can find additional information about this in the section "How to Check the Settings on the OS Servers (Page 111)".

Note
Note the start sequence for initial commissioning
Restart process mode for OS servers if necessary in order to establish the connection to the Process Historian.

8. Starting the migration tool
You can find information on this in the section "How to migrate the archives in the Process Historian (Page 117)". The migration of all CAS databases is performed in the background during ongoing operation.

5.2 Necessary preparations

5.2.1 Overview of preparations

Overview of the procedure

Note
You must perform the steps listed below prior to carrying out an update, in order to prevent data being lost.

Always backup your PCS 7 project before you run the software update.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Back up PCS 7 project data (Page 31)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Back up the libraries you created (Page 34)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Export operator and display texts (Page 35)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Checking the network adapter (Page 37)</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>
Preparing for the software update

5.2 Necessary preparations

### Additional preparations

#### Note

**Update of SIMATIC BATCH**

If you are using SIMATIC BATCH in the project and wish to update it, you must strictly observe the information provided in section "Updating SIMATIC BATCH stations (Page 113)" when preparing for the update.

---

### 5.2.2 Exchanging Data Via OPC A&E

If you exchange data in the PCS 7 system by means of OPC A&E, observe the information in the *Process Control System PCS 7: OpenPCS 7* documentation when updating the software.

---

### 5.2.3 How to Back Up PCS 7 Project Data

Carry out the following instructions in order.

**Requirements**

#### Note

Before you install or update PCS 7, you must prepare and backup your original project so that you can perform the software update.

---

**NOTICE**

**Ensuring safe system configuration**

If you want to perform a software update in runtime, you must ensure the following:

- All configurations are complete. Keep this in mind especially when you apply the engineering with several engineering stations (multi-engineering).
- All changes are loaded in the system.

---

### Step and Action Table

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Prepare projects with high-precision time stamping (Page 38) (only required for projects with high-precision time stamping).</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Backing Up the License Keys and Authorizations (Page 40)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
Archiving a project

1. In SIMATIC Manager, select the menu command File > Archive. The "Archive" dialog box opens.
2. Select the "Multiprojects" (or "User projects") tab.
3. Select the project from the list that you wish to archive.
4. Click "OK" to save your settings. The "Archive - Select Archive" dialog box opens.
5. Make the settings for the drive and the folder for the archive file. Recommendation:
   Select a name for the project's archive file which indicates the date on which archiving took place.
   Example: "yearmonthdayprojectname"; 151230pcs7proj
6. Click "Save" to apply your settings. The archiving process begins.

Note
The archived project reflects the state of the project before the software update.

Comparing Time Stamps

1. Open your PCS 7 project in SIMATIC Manager.
2. In the component view, select the chart folder of an AS.
3. Double-click on any chart. The CFC editor opens.
4. Select the menu command CPU > Compare.
5. Compare the time stamps "Last compilation" and "Compilation of the loaded program".

<table>
<thead>
<tr>
<th>If the time stamps are...</th>
<th>... then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Identical</td>
<td>1. Click &quot;Close&quot;. The dialog box is closed.</td>
</tr>
<tr>
<td>Different</td>
<td>1. Select the menu command CPU &gt; Download. 2. Select the &quot;Changes&quot; check box and apply all other standard settings. 3. Click &quot;Ok&quot;. Changes start to be downloaded. 4. If changes have been downloaded without errors, select the menu command CPU &gt; Compare. The &quot;Last offline program change&quot; and &quot;Last online program change&quot; time stamps must match up.</td>
</tr>
</tbody>
</table>

6. Perform steps 2 to 5 for each automation system.
Reading Back the AS Parameter Settings

If parameters which are not in the configuration have been set in the AS, you will be able to read these settings back into the project.

**CAUTION**

*Parameters will be overwritten*

Please note that the parameters in the configuration will be overwritten. The decision concerning whether to use this function will depend on the nature of the system involved and must be made by the skilled personnel with responsibility for the system.

1. Open your PCS 7 project in SIMATIC Manager.
2. In the component view, select the chart folder of an AS.
3. Double-click on any chart.
   The CFC editor opens.
4. Select the menu command **Chart > Read Back**.
5. Select the entries "Program on the CPU" and "Only data relevant for operator control and monitoring" in the "Read Back" dialog box.
6. Click "OK".
   The read-back process begins.
7. Perform steps 2 to 6 for the automation systems whose current parameters you require.

Backing Up OS Data

If you want to operate the OS server on a newly installed PC following the software update, we recommend you back up the OS project of the OS server.

By default, the configuration data and the archive data of the OS are stored in the OS project of the OS server.

To back up data, compress the project paths in this folder. Save the backup on a suitable medium.

SIMATIC PDM

SIMATIC PDM configuration data is included automatically in the backup of a SIMATIC project.
SIMATIC PDM - Device descriptions

These PDM device descriptions are not included in the update installation of PCS 7. By default, SIMATIC PDM installs the Siemens device descriptions.

- Make sure that the device descriptions utilized in the project are available for the integration. To do this, create a list of the utilized device descriptions. You can save this list (menu command Save device list as).

- Recommendation as of SIMATIC PDM V8.0 SP2: Back up the created device libraries with the Device Integration Manager using one of the following actions:
  - Copy
  - Save as compressed archive
  - Burn to DVD

5.2.4 How to Back Up User Created Libraries

Introduction

Generate a backup copy of any project library that contains a collection of user-specific blocks for the project to be updated so that you can retrieve this data after having updated the software. Carry out these steps for each library that you would like to back up.

Procedure

1. Start SIMATIC Manager. No PCS 7 project must be open.
2. In SIMATIC Manager, select the menu command File > Archive. The "Archiving" dialog box opens.
3. Open the "Libraries" tab.
4. Select the library to be backed up and click "OK". The "Archiving - Select an Archive" dialog box opens.
5. Specify the file name and the storage path.
6. Click on the "Save" button.

Additional information

- Online help for STEP 7
5.2.5 Operator and Display Texts in Blocks

Information in Faceplates
Faceplates visualize processes on the operator station and provide the plant operator with information, such as:

- Measured values
- Operating limits
- Units
- Block operator texts

Change in Operator and Display Texts in Blocks
If you have modified the operator texts or display texts in the blocks so that they do not correspond to the delivery state and you want to use the new PCS 7 blocks, you must back up these "old" operator texts or display texts.

Diagnostic screens with project-specific adaptation
In a project created with a version lower than PCS 7 V7.0 SP1, backup the diagnostic screens that were adapted to a specific project.

Exporting Operator and Display Texts
SIMATIC Manager supports the export of information pertaining to parameters, signals, and messages to a file (format: *.csv).
You can edit this file in standard MS Office applications such as Excel and Access. The same mechanisms are used for the export as are used for changeover to project-specific languages.

5.2.6 How to Export Operator and Display Texts

Requirement
- The required language is installed in your project.

Note
You can view the languages available in the project in SIMATIC Manager using the menu command Options > Language for Display Devices. The number of available languages is specified when Windows is installed (system characteristics).
Preparing for the software update

5.2 Necessary preparations

Procedure

1. Open the project to be updated in the SIMATIC Manager.
2. Select the master data library folder in the Component View. If this folder is not available, select the project folder.
3. Select the Options > Manage Multilingual Texts > Export menu command. The "Export user texts" dialog opens.
4. Make the following settings:
   - In the "Text tables" group, select the storage location and the format of the export file (possible formats: *.xls and *.csv).
   - Select the target language and source language that correspond with the display language in the "Language" area.
5. Click "OK".
6. If you are managing multilingual projects, repeat steps 3 thru 5. Make sure that you specify different destination directories or export file names.

5.2.7 Non-approved network adapters

Communications Processors that Are No Longer Supported

Note
Generally, the following applies as of PCS 7 V7.0:
PROFIBUS is no longer supported as the plant bus. Only Industrial Ethernet is supported as the plant bus.

The following communication processors are no longer supported by PCS 7:
- CP 1413 Industrial Ethernet
- CP 1613 A1
- CP 5412 A2 PROFIBUS
- CP 5613 PROFIBUS
These communication processors must be uninstalled and removed.

Communications Processors that Are Not Detected

The following communication processors cannot be detected during installation of the operating system:
- Non-"Plug&Play" compatible communications processors
- ISA plug-in cards as communications processors
Replace these CPs with approved communication processors prior to installation of the operating system.
Communications Processors in the PC Stations

Note that you must also remove the hardware specified above from the PC stations of your PCS 7 project.

Note
You must reconfigure the connections after the communications processors are removed.

Additional information
You can find information about suitable PCs and network adapters in the catalog overview Process Control System PCS 7; Released Modules.

5.2.8 How to check the network adapter

Introduction
After you have installed the operating system on the PCs, you should check whether the network adapters (communication processors or network cards) being used are recognized by the operating system.

Procedure
1. Use the search box in the start menu to open the "Device Manager".
2. Open the "Network Adapters" folder in the tree view.
   - The detected communication processors (CPs) are listed in the "SIMATIC NET" folder.
   - The detected network adapters can be found in the "Network Adapters" folder.
3. Close the dialog box.

Additional information
- Documentation: PCS 7; Released Modules
5.2.9 How to prepare projects with high-precision time stamping

These steps are only required for projects in which the PCS 7 function "high-precision time stamping" is used.

Note

Blocks of the Advanced Process Library (APL)

If you intend to use the APL functions for the first time, you need to reconfigure the project in accordance with the Process Control System PCS 7; High-precision time stamping documentation.

Requirement

- The current version of all SIMATIC stations has been compiled and transferred.

Procedure

For each CPU with time stamping:

1. Select the following path from the "Project" > "SIMATIC Station" > CPU > S7 Project > Charts tree view.
2. Select the Options > Charts > Chart Reference Data menu command. The "Chart ref.: Chart reference data.." dialog window opens.
3. Select the View > Block types menu command.
4. Click the "Block type" header of the table. The blocks of this CPU are displayed in sorted order.
5. Search for "IM_DRV" in the "Chart ref.: Chart reference data.." dialog window.
6. Double-click on the "IM_DRV" entry. The associated CFC chart opens.
7. Select the Chart > New... menu command in the CFC editor. The "Open" dialog window opens.
8. Go to the "Object name" input line and type in a name (e.g. TEMP_IM_DRV_"Number") for the temporary CFC chart (e.g. TEMP_IM_DRV_1).
9. Select the Window > Arrange > Tile vertically menu command in the CFC editor.
10. Drag-and-drop the IM_DRV block from the system chart to the temporary CFC chart (e.g. TEMP_IM_DRV_1).
11. Save the CFC charts.
12. Repeat steps 5 through 11 for all IM_DRV blocks in the CPU.

**Note**

The system chart will no longer contain any IM_DRV blocks after you have successfully moved them all to temporary CFC charts. The name of system charts starts with the "@" character. The path name is available in the "Chart ref.: Chart reference data..." dialog window in the "Chart" column.

13. Repeat steps 1 through 12 for all SIMATIC stations in your project.

**Generating the AS program**

**Note**

Do not generate the AS program of this automation system after having moved the IM_DRV blocks. The blocks would be moved to the system charts automatically and the message texts would be deleted in the course of your software update.

The AS program may only be generated again when there is no IM_DRV block on a system chart.

**Updating PCS 7 on a new engineering station**

To restore adaptations you have made to the "High-precision time stamping" function, you should archive the PCS 7 project again (section "How to Back Up PCS 7 Project Data (Page 31)"; Archiving a project). Perform the update again with the re-archived project.

**5.2.10 Backing up pictures for user-defined status displays.**

If prior to PCS 7 V8.1 you have used your own pictures when creating the status displays for user-defined extended status displays, you should save these screens (EMF files) in a separate folder.

**Procedure**

1. Open the "GraCS" folder in the OS project folder in Windows Explorer.
2. Create a folder for your own pictures.
3. Copy the pictures (EMF files) that are used into the newly created folder.
5.2.11 Backing Up the License Keys and Authorizations

Introduction

You must backup the license keys/authorizations stored on your hard disks before changing the operating system or using new PC stations.

Note

You can backup all License Keys to a License Key USB stick that is available as of PCS 7 V7.1. You must transfer the authorizations to a License Key disk/multi-authorization disk.

Program for backing up the License Keys

Use the Automation License Manager for this purpose.

Note

After installing the operating system, you can re-install the backed-up license keys using the "Automation License Manager" program.

An upgrade of the license keys (Upgrade license key and PowerPack license key) is only possible when the license keys to be updated are available on the corresponding PC station.

Additional information

- Online help for Automation License Manager
- Online help for WinCC Information System > Authorizations
Adaptations to the Hardware

6.1 Overview of Update of the Hardware

Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>Prepare the hardware replacement (Page 42)</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>9</td>
<td>Update and replacement of the hardware (Page 43)</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

6.2 Planning and preparation

If you want to use the new PCS 7 functions, all the hardware components (modules) of the process control system in the PCS 7 plant must meet the requirements of the PCS 7 version.

Necessity of Updating or Replacing Hardware Components

You can determine if a hardware component needs to be updated by referring to the PCS 7; Released Modules documentation. It does not automatically follow that you will be able to use the PCS 7 functions if you have earlier product releases and versions.

Contact your Siemens representative if replacement of a module is required.

Result of the Analysis

An analysis of the hardware can result in the following scenarios:

- Module can continue to be used in its full scope.
- Module can be updated.
- Current module must be replaced with a new module.

NOTICE

Update or replacement

A STOP of the AS may be required to update or replace a component.

Example: During a CPU-firmware update or when the plant bus is changed from PROFIBUS to Industrial Ethernet.
6.3 How to Prepare for Replacement of the Hardware

Options for Reading Out Module Information

You can read out information about the following modules in HW Config:

<table>
<thead>
<tr>
<th>Component</th>
<th>Information concerning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network components</td>
<td>Menu command Object Properties &gt; Diagnostics: NCM S7 Diagnostics</td>
</tr>
<tr>
<td>CPU</td>
<td>Menu command Object Properties</td>
</tr>
<tr>
<td>Interface modules</td>
<td>Menu command CPU &gt; Module information</td>
</tr>
<tr>
<td>• IM 153</td>
<td>The interface module (IM) product version can be found on the front panel at the lower right.</td>
</tr>
<tr>
<td>• IM 157</td>
<td></td>
</tr>
<tr>
<td>• IM 151</td>
<td></td>
</tr>
</tbody>
</table>

Basic procedure

The following tasks are required if you plan to replace hardware in an AS:

1. Analyze the actual state of the modules used.
2. Define the desired state:
   Define what the future structure of your system should be. Define your future automation goals and align them with the requirements found in the PCS 7; Released Modules documentation.
   You can find additional information about different modules in the documentation Process Control System PCS 7; PCS 7 - PC Configuration.
3. Carry out the module planning:
   Produce planning documents, which establish the following:
   - Parts of the plant that should remain
   - Parts of the plant that should be expanded
   - Old modules that should still be used
   - Parts of the plant that should be upgraded with new modules for access to the full SIMATIC PCS 7 V7 functionality

Special Information via the Internet

You can find special information about the firmware update and the corresponding updates on the Internet at:


Select Search and enter "CP 1623 firmware update" in the search window, for example.
6.4 How to Perform Updates and Replace the Hardware

Introduction

The following table offers an overview of the hardware updates that may be required. You can find detailed step-by-step instructions for the procedure in the manual Process Control System PCS 7; Service Support and Diagnostics.

Overview of the Hardware Updates with Supplemental Information

<table>
<thead>
<tr>
<th>Hardware Update, Hardware Replacement</th>
<th>Basic procedure</th>
<th>For additional information...</th>
</tr>
</thead>
</table>
| Updating the CPU Operating System    | 1. Check the type and product release of the module.  
2. If required: Perform an update or replace the module. | Manual Process Control System PCS 7; Service Support and Diagnostics, section "Update of the CPU Operating System". |
| Firmware update of CP 443-5 Extended | 1. Check the type and product release of the module.  
2. If required: Perform an update or replace the module. | Manual Process Control System PCS 7; Service Support and Diagnostics, section "CP 443-5 Extended: Firmware Update". |
| Firmware update of CP 443-1          | 1. Check the type and product release of the module.  
2. If required: Perform an update or replace the module. | Manual Process Control System PCS 7; Service Support and Diagnostics, section "CP 443-1: Firmware Update". |
| Replacing IM 153-2 and IM 157        | 1. Check the type and product release of the module.  
2. If required: Perform an update or replace the module.  
3. Take into account the necessary bus modules. | Manual Process Control System PCS 7; Service Support and Diagnostics, section "Update of an Interface Module (IM)". |
### Additional information

You can find additional information in the following documentation:

In the Windows Start menu, **SIMATIC > Documentation** submenu, in the corresponding language folder:

- Documentation *PCS 7 - Released Modules*
- Manual *Process Control System PCS 7; PCS 7 PC Configuration*
- Manual *STEP 7; Modifying the System during Operation via CiR*
- Manual *Process Control System PCS 7; Service Support and Diagnostics*
Installation of PCS 7 and settings on the ES and OS

7.1 Overview of Installation and Settings on the ES and OS

Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Preparing the PC station (Page 45)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Installing the PCS 7 software (Page 46)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Installing additional PCS 7 libraries (Page 53)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Installing additional non-standard libraries (Page 56)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Setting the &quot;Configured mode&quot;/&quot;PG mode&quot; operating mode (Page 58)</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Configuring and downloading the PC stations (Page 59)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>

7.2 Preparing the PC Station

Preparing the PC station

The further procedure depends on the operating system of the PC Stations to be updated.

Recommendation

Use the latest approved operating systems for PC Stations (workstation and server).

- Consult with a network administrator about the configuration of the networks.
- You can find information about backing up data in the manual *Process Control System PCS 7; Service Support and Diagnostics*
- You can find information about the installation and configuration of the PC stations in the "Installing the Operating System" section of the *Process Control System PCS 7; PCS 7 PC Configuration* manual.

Note

Re-installing the operating system

You can re-install the operating system directly if the operating system partition does not contain any important data, such as:

- License keys
- Project data
- Archive files
If possible, you should install the PC station completely from scratch.

**Additional information**

- Manual *Process Control System PCS 7; PCS 7 PC Configuration*
- You can find information on approved operating systems in the *Process Control System PCS 7; PCS 7 Readme* documentation (Internet version).

## 7.3 How to install PCS 7

**Requirements**

- The PCS 7 project data is backed up. You can find detailed information about how to back up project data in the *Process Control System PCS 7; Service Support and Diagnostics* manual, section “Safeguarding Availability, Data backup”.
- The hardware planning and hardware update are complete.
- The necessary preparations have been made.
- The operating system of the PC station to be updated is updated. You can find information on approved operating systems in the documentation *Process Control System PCS 7; PCS 7-Readme*.
- Read the latest information in the documentation *Process Control System PCS 7; PCS 7 Readme*.
  - Hardware and software requirements, installation
  - If you use an INTEL network adapter, install the driver suitable for your device type and operating system version. You can find information on the drivers in the documentation *Process Control System PCS 7; PCS 7 - Readme*.
  - Information on the software for the automation system of SIMATIC PCS 7 BOX: The software for time synchronization must be installed for an update of SIMATIC PCS 7 BOX and SIMATIC PCS 7 AS RTX.

**Note**

**Software update of password-protected projects**

The software update of password-protected projects requires SIMATIC Logon on an ES.
Note

Archive server

- The central archive server (CAS) **must** be replaced with a Process Historian. You can find information on migration in the section "How to replace the CAS with the PH (Page 96)."
- Sequence for starting Process Historian and OS server
  If the Process Historian is commissioned after activation of the OS servers, you need to restart the OS servers to establish the connection to the Process Historian.

SIMATIC PDM

Install SIMATIC PDM on the engineering station if using the Maintenance Station of PCS 7 and if the project contains intelligent field devices configured with SIMATIC PDM. The PDM Server must be installed on the engineering station for the complete Asset Management functionality.

Read the information and requirements in the readme for the current version of SIMATIC PDM.

Note

Installing SIMATIC PDM

If you are using a PDM version lower than V8.0 SP1, and want to perform an update installation, uninstall the old PDM version before the installation.
Installing PCS 7

1. Insert the Process Control System; SIMATIC PCS 7 DVD into the DVD drive.

2. Select the "Install" setup type.
   You can use the update function for already installed PCS 7 software.
   For a detailed description of the required software installations, refer to the documentation Process Control System PCS 7; PCS 7 PC Configuration, section "How to install PCS 7 software".

   **Note**
   During the installation, a message will appear several times prompting you to reboot your PC. Reboot the PC. The installation then continues automatically.

3. Restore the old project data from the backup copy (if any) to the PC.

   **Note**
   **Required access rights for changing the project path**
   The project path in "Storage location for projects/multi-projects" is set by default to "SIEMENS\STEP7\S7Proj" and all necessary access rights are set for this project path.
   If you use another project path, you need to set the necessary access rights using the "SimaticRights.exe" tool.
   For more information, refer to the Process Control System PCS 7; PCS 7 PC Configuration manual, in the section "How to set permissions for the project paths".

Libraries

As of PCS 7 V8.0, the libraries of PCS 7 are updated with each PCS 7 version. The following libraries are installed by default:

- **PCS 7 Basis Library**
  Contains the blocks of the PCS 7 Basis Library. This library is a prerequisite for the use of the PCS 7 Library and the Advanced Process Library.

- **Advanced Process Library**
  Contains the blocks of the PCS 7 Advanced Process Library.

   **Note**
   **Using additional libraries**
   If you want to use Advanced Process Library in combination with PCS 7 Library 7.1.3, you must also install this library. You can find information about this in the following sections:
   - Only use the latest versions of PCS 7 libraries.
   - You can find the download files of the setups for PCS 7 libraries of older versions of the PCS 7 Library, the PCS 7 Basis Library and the PCS 7 Advanced Process Library on the Internet ([https://support.industry.siemens.com/cs/ww/](https://support.industry.siemens.com/cs/ww/en/view/109480136)).
   - Section "Installation of Additional PCS 7 Libraries (Page 53)"
   - Section "How to Install Additional PCS 7 Libraries (Page 54)"
Web Option for OS

- **Web server**
  After installing the Web server, you must execute the Web Configurator.

- **Web clients**
  Update the plugin for the PCS 7 Advanced Faceplates.
  - You can update the software (without removing it beforehand) on the WebNavigator client.
  - With the WebNavigator diagnostics client, you will have to uninstall and then reinstall the software.
  - Update the existing plug-ins on the Web clients.

Microsoft SQL Server

You can find information on the installed version of the Microsoft SQL Server required by PCS 7 in the documentation *Process Control System PCS 7; PCS 7 Readme*.

**Recommendation:**
If versions of the Microsoft SQL Server are installed on the PC and they are not required for PCS 7 or specific purposes in the plant, you should remove this software after the update installation of PCS 7. You can find the required menu command in the Control Panel.

Note that the following components belong to Microsoft SQL Server 2014:

- Microsoft SQL Server 2008 R2 Management Objects
- Microsoft SQL Server 2008 Setup Support Files
- Microsoft SQL Server 2012 Native Client

Additional information

- Documentation *Process Control System PCS 7; PCS 7 Readme* (see "Preface (Page 9)"
- Manual *Process Control System PCS 7; PCS 7 PC Configuration*

7.4 How to enable encrypted communication between the PC stations

Changing the access protection of communication

Typical situations are:

- Software update of PC stations
- Switching to encrypted communication in non-redundant configurations
- Switching to encrypted communication in runtime in redundant configurations
- Changes to settings for encrypted communication in runtime (for example, changing a password).
Note
Disruption of communication connections
Activation of the migration mode described below is only required if the communication
connexions between the following PC stations must not be disrupted in any way:
● PC stations with access protection for communication
● PC stations without access protection for communication

Activation of the migration mode
If you want to change access protection for the communication in process mode of the plant,
you must adhere to the following sequence of actions:

Note
Change the access protection of communication in process mode of the plant.
This change is only possible for redundant PC stations in process mode of the plant.

Stop the process mode for each of the PC stations on which you currently want to perform the
change. For redundant PC stations, the partner station takes over process mode.
1. Temporarily enable the "migration mode" option for all PC stations for the next procedure.
2. Before activating encrypted communication without migration mode, evaluate the potential
impact.

NOTICE
Encrypted communication in a plant
Before you enable exclusive use of encrypted communication, you must ensure the
following:
● Migration mode must be enabled on all the required PC stations.
● The encrypted communication must be enabled on all the required PC stations.

3. Temporarily disable the "migration mode" option for all PC stations for the next procedure.

Using encrypted communication for a PC station
1. Select the "SIMATIC Shell" folder in the tree view of Windows Explorer on the PC station.
2. Select the "Settings..." command from the shortcut menu.
The "Communication Settings" dialog opens.
3. Enable the "Use encrypted communication" option.
   The "Set PSK" dialog box opens.

   **Note**
   **Changing the PSK**
   When the "Set PSK" option is enabled, you can change the PSK. Click the "Set" button.
   Please note the documentation *Process Control System PCS 7; PCS 7 PC Configuration*, section "How to change the PSK for encrypted communication".

4. Enter characters with a high password strength for the key.
   The key must be at least 8 characters long and include numbers and symbols in addition to uppercase/lowercase letters.

5. Confirm your entries. Click "OK".

6. If you want to use an available port instead of the port allocated by default, you can specify the assignment of the incoming port.

7. Check the setting for the "Migration mode" check box.

   **Note**
   Please note the documentation *Process Control System PCS 7; PCS 7 PC Configuration*, section "How to use migration mode when changing encrypted communication".

8. Click "OK".

**Additional information**
- Please note the documentation *Process Control System PCS 7; PCS 7 PC Configuration*, section "How to access PC stations outside a subnet".

7.5 **Updating SIMATIC PCS 7 AS RTX**

**Update package**

You need the following product for the update of SIMATIC PCS 7 AS RTX:

PCS 7 AS RTX V8.2 Update Package

**Basic procedure**

1. Backing up user and network settings
2. Backing up license keys
3. Updating SIMATIC PCS 7 AS RTX in accordance with the product information of the update package
4. Creating user and network settings
5. Loading SIMATIC PCS 7 AS RTX
7.6 Transmission Rate and Operating Mode in the PC Network

Introduction

For communication in a network, ensure that the following parameters are set consistently for all network nodes:

- Transmission rate
- Operating mode

Automatic Recognition of the Transmission Rate and the Operating Mode

The term autonegotiation denotes the automatic identification and negotiation of transmission rate and operating mode (full duplex/half duplex).

- Full duplex is an operating mode with bidirectional data exchange, in which the communication partners can send data independently of one another on the transmission link.
- Half duplex is an operating mode with bidirectional data exchange, in which only one communication partner at a time can send data on the transmission link.

Requirement

With their factory settings, Siemens devices used in PCS 7 automatically identify (autonegotiation) the transmission rate and operating mode parameters.

This setting must be changed only if communication in the network is necessary with nodes that do not have the autonegotiation setting.
### Assigning Parameters to Network Nodes

<table>
<thead>
<tr>
<th>Location of Use</th>
<th>Network Node</th>
<th>Steps for Calling Parameter Assignment Dialog Box</th>
<th>Parameter Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>PC</td>
<td>Communications processor</td>
<td>1. In the Windows Start menu, select the SIMATIC &gt; SIMATIC NET submenu, menu command Configure PC-Station</td>
<td>Selects options for duplex mode and transmission rate</td>
</tr>
<tr>
<td></td>
<td>● CP 1613</td>
<td>2. PC Station &gt; Modules &gt; Network Parameters</td>
<td></td>
</tr>
<tr>
<td></td>
<td>● CP 1623</td>
<td>3. File &gt; Properties</td>
<td></td>
</tr>
<tr>
<td></td>
<td>● CP 1628</td>
<td>4. Advanced&quot; tab</td>
<td></td>
</tr>
<tr>
<td>PC</td>
<td>INTEL network adapter settings (or similar standard network adapters)</td>
<td>1. In the Windows control panel, select &quot;Administrative Tools&quot; &gt; &quot;Computer Management&quot; &gt; &quot;Device Manager&quot; &gt; &quot;Network adapters&quot;</td>
<td>Set the values for the property.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2. Select network card</td>
<td>Typical name for the property (depends on the network module used):</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3. File &gt; Properties</td>
<td>- Speed and duplex mode</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4. Advanced&quot; tab</td>
<td>- Link speed &amp; duplex</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● To call parameter assignment dialog box (Web-based management) of the switch via Internet Explorer: http : &lt;TCP-IP address&gt;</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>● Configuration via telnet (DOS window: telnet)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>● HW Config: CP443-1 Properties &gt; &quot;Options&quot; tab &gt; &quot;Individual network settings&quot; group &quot;Transmission medium/duplex&quot; drop-down list</td>
<td>Automatic Setting&quot; default</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Additional information
- Operating Instructions SIMATIC NET; Industrial Ethernet Switches SCALANCE X-400
- Configuration manual SIMATIC NET; Industrial Ethernet Switches SCALANCE X-400

### 7.7 Installation of Additional PCS 7 Libraries

#### Download of setups for PCS 7 libraries

Only use the latest library versions for PCS 7 libraries. You can find the download files for setups of older versions of the PCS 7 Library, the PCS 7 Basic Library or the PCS 7 Advanced Process Library on the Internet ([https://support.industry.siemens.com/cs/ww/en/view/109480136](https://support.industry.siemens.com/cs/ww/en/view/109480136)).

#### PCS 7 Library is contained in the project.

Observe the following specifications with regard to the PCS 7 libraries when updating the software:
PCS 7 Library must be installed later on the engineering station for the software update, if the blocks of this PCS 7 Library will continued to be used in the PCS 7 project.

- If you wish to operate a mixture of APL V8 blocks and PCS 7 library blocks, you need to do the following:
  Update the blocks with the blocks stored in the "ChnBlocks for PCS7 V8" folder of the PCS 7 Library.
  To do this, you also need to install the PCS 7 Library PCS 7 V7.1 SP3.

- If you are installing PCS 7 new ("Install" setup type), you need to observe the following:
  If you are using the PCS 7 Library in the project to be updated, you must install the faceplates (PCS 7 faceplates) of PCS 7 V7.1 SP4 on the following PC stations after a new installation of PCS 7:
  - Engineering station
  - All operator stations (all types)

**Basic Installation Procedure**

The procedure is described in the section "How to install additional PCS 7 libraries (Page 54)". You can find the basic procedure for this in the *Process Control System PCS 7; Engineering System configuration manual*.

### 7.8 How to Install Additional PCS 7 Libraries

**Note**

**Post-installing or removing PCS 7 libraries**

If you install or remove an older version of the PCS 7 Library, PCS 7 Basis Library or PCS 7 Advanced Process Library after the installation of PCS 7, you must post-install the current versions of the PCS 7 Basis Library or PCS 7 Advanced Process Library. Install the required libraries by using the PCS 7 Setup. This applies, for example, to PCS 7 libraries of older PCS 7 versions; see section "Installation of Additional PCS 7 Libraries (Page 53)". Only use the latest versions of PCS 7 libraries.

You can find the download files of the setups for PCS 7 libraries of older versions of the PCS 7 Library, the PCS 7 Basis Library and the PCS 7 Advanced Process Library on the Internet ([https://support.industry.siemens.com/cs/ww/en/view/109480136](https://support.industry.siemens.com/cs/ww/en/view/109480136)).

You can find information about the versions of the libraries (including updates) in the file *Process Control System PCS 7; PCS 7 Readme (online)* (see "Preface (Page 9)").

**Requirements**

- The operating system including the required components is installed.
- PCS 7 has been installed.
7.9 What are the requirements for using the Advanced Process Library?

Using the Advanced Process Library (APL)

You need the following libraries to use the functions provided in PCS 7 V8.0 or higher:
- PCS 7 Advanced Process Library (APL)
- PCS 7 Basis Library

The PCS 7 Advanced Process Library (APL) can only be used if the PCS 7 Basis Library is installed.

Note

When upgrading PCS 7 with utilization of new functions, you must always upgrade all libraries. It is not permitted to use the new functions only for one library in the PCS 7-project.

The conversion of the blocks (for example, custom blocks or blocks of the PCS 7 Standard Library) to the blocks of the APL requires a new application-specific configuration.
7.10 How to Install Additional Non-standard Libraries

Introduction

Note this section if you are using and would like to continue using libraries in the PCS 7 project to be updated that are not standard in PCS 7 or that contain modified blocks.

Requirement

The library has been archived with the menu command File > Archive in SIMATIC Manager.

Procedure

1. Start the SIMATIC Manager. A PCS 7 project does not have to be open.
2. In SIMATIC Manager, select the menu command File > Retrieve. The "Retrieving - Select Archive" dialog box opens.
3. Specify the path to the archived library. Click "Open". The "Select Destination Directory" dialog box opens.
4. Set the destination directory.
5. Click "OK".

Note

On an AS, you must always load the AS blocks of compatible libraries. For example, the following libraries are compatible:

- PCS 7 Advanced Process Library V8.2
- PCS 7 Basis Library V8.2
- PCS 7 Library V7.1.3 SP3 UPD 3 with driver blocks from the "ChnBlocks for PCS 7 V8" folder

Additional information

For information about the modification of libraries, refer to the following documentation:

- Online help WinCC; Faceplate Designer
How to update user-specific APL faceplates

Introduction

You need to make certain adaptations for APL faceplates that were created in accordance with APL style guide. Read the instructions in the Readme files for APL (see Process Control System; SIMATIC PCS 7; DVD_2; folder Additional_Products\PCS7ADVLIBRARY__V7.1<...>).

Note
Take into account that you have to re-enter the parameterization of the objects you replaced.

Requirement

Advanced Process Library V7.1 SP5 Upd5

Procedure

Replace the following objects in your basic faceplate picture (e.g. @PG_MyAPLFP.PDL) with the corresponding object from the @PCS7ElementsAPL.pdl picture.

- The "AlwaysOnTop" object with the "APL_PIN_BUTTON" object Version >= 10061101.
- The "ObjCollection" object with the "ObjCollection" Version >= 10102501.
- The "@Faceplate" object with the "@Faceplate" Version >= 10110501.
- Copy the complete C-script from the @PG_PIDConL.pdl picture of APL SP5, ViewWindow/Height/OnPropertyChanged and completely replace the script in your own basic picture, ViewWindow/Height/OnPropertyChanged.
- Copy the complete C-script from the @PG_PIDConL.pdl picture of APL SP5, ViewWindow\PictureName\OnPropertyChanged and completely replace the script in your own basic picture, ViewWindow\PictureName\OnPropertyChanged.

Note
Take into account that you have to re-enter the parameterization of the objects you replaced as specified in the APL style guide, chapter 1.3.2.

- Change the following parameter assignments:
  - In the "@Faceplate" object, change the "Firstview" property to the new picture name, e.g. "PG_MyAPLFP_Standard.PDL".
  - In the "ObjCollection" object, change the "BlockType" property to the name of the new faceplate type (server name), e.g. "MyAPLFP".

Note
When using controllable objects, it is imperative to create a tag link at the "PermissionTag" or "LinkTag3" property. A parameter assignment as specified in the APL style guide, chapter 1.3.7, will no longer be functional.
7.12 Modules in Configured Mode and PG Mode

Operating Modes

Two operating modes are always differentiated:

- Module in configured mode
- Module in programming device (PG) mode

Module in "Configured Mode"

You can only transfer configured connections from NetPro to the module in "Configured Mode". All of the logs provided by SIMATIC NET are available when using this operating mode. For this reason, we recommend using this setting.

As a requirement for the "Configured Mode" setting, your PCS 7 project must contain a SIMATIC PC station with a WinCC application for the engineering station (ES). Check whether this requirement has been met for your PCS 7 project.

Module in "PG mode"

In "PG mode", you can assign parameters for the network adapters. You can assign the network-related parameters, such as station address and transmission speed, with the "Set PG/PC Interface" configuration program. The configuration can only be set locally on the computer.

No communication is possible with the PC stations in this operating mode.

Requirements

- The network addresses and network settings of the PC stations are configured.
- The configuration of the PC stations match in HW Config and in the Station Configuration Editor.
- The configuration of the PC stations is loaded on the PC stations.
- The connection data of the PC stations are loaded.

Procedure

1. In the Windows Start menu, select the menu command Communications settings in the SIMATIC > SIMATIC NET submenu.
2. In the tree view, select the "Modules> <Network Card on System Bus> >General" folder.
3. Select the appropriate entry from the "Module Mode" drop-down list box.
4. Click "Apply".

Note

For process mode, the network adapter (network cards or communication processors) must be set to "Configured mode".
Note

PC stations with multiple network adapters

For PC stations using multiple network adapters, the network adapters may be recognized in a different sequence by the operating system. This mainly happens when changing the operating system or installing a new one. Take this into consideration and adapt the configuration in HW Config accordingly.

7.13 How to Configure and Download the PC Stations

Introduction

The project-specific network settings for the network adapters (Ethernet) of the engineering station are downloaded directly to the PC station.

Requirements

- The following is installed on each PC station:
  - Operating system
  - Specific software for the PC station (e.g., engineering station, OS server)
- All PC stations to be downloaded are linked to the engineering station by means of at least one network.
- The protocol for the communication on the terminal bus is set to TCP/IP.
- The network is administered (terminal bus and system bus). The network addresses of the PC stations are configured.
- The PC station access point is set on each PC station as follows: "S7ONLINE: = PC internal (local)".

Procedure

Note

Perform the following steps for the engineering station first before configuring and downloading the other PC stations.

1. In SIMATIC Manager, open the PCS 7 project.
2. In the Component View, select the target computer.
3. Select the menu command CPU > Configure.
The "Configure" dialog box opens.
4. From the "Local Network Connection" drop-down list box, select the network connection to be used to access the target computer.
5. Click "Update".
The list of accessible computers is updated.
The PC station selected in the project is entered in the "Target computers" area.

6. Select the desired target computer (PC station).

**Note**
If the selected PC station does not appear in the list, this suggests network problems or a faulty configuration in the project.

7. Click "Configure".
The "Configure: <selected station>" dialog box opens.

8. In the "Configure: Target Computer" dialog box, click "OK".

9. Click "OK" in the "Information" dialog box. The configuration data is transferred to the PC station. To activate the network connections, you must then download the network settings to this PC station. The completion of the "Configuration" step is indicated in the dialog box message line.

10. Click "Close".

11. For the computer selected in step 2, select the menu command **CPU > Download**.
The "Download to CPU in Current Project" dialog box opens.

**Note**
The configured network address of the Ethernet network adapter in the PC station must match the preset address in the target system.

12. When the dialog box tells you that you are overwriting the configuration data, respond as follows:
   - During initial commissioning, click "Yes".
   - If the PC station is in process mode, you can only click "Yes" when a communication interruption is permissible.

   The "Stop Target Module" dialog box opens.

13. In the "Stop Target Module" dialog box, click "OK" to confirm.
The "Download" dialog box opens.

14. Click "OK" to confirm.
The download is performed.
Once the configuration has been applied, the PC station is ready to operate.

15. Repeat steps 2 through 14 for all of the PC stations.

**Switching the Logs on the Bus (Industrial Ethernet)**

**Note**
Neither the TCP/IP or ISO protocol may be disabled. These protocols are mandatory for the configured operating mode!
If a bus within a system must be switched to a different protocol (for example, from TCP protocol to ISO protocol), you must temporarily set a mixed protocol (TCP and ISO) on the engineering station. You then download the configuration data to the AS and the operator control and monitoring systems.

Additional information

- SIMATIC NET; Commissioning PC Stations - Manual and Getting Started manual
Installation of PCS 7 and settings on the ES and OS

7.13 How to Configure and Download the PC Stations
Adaptations in the PCS 7 Project on the ES

8.1 Update of a PCS 7 Project

Basic procedure

This section describes how to update your PCS 7 project for use with SIMATIC PCS 7. The PCS 7 project is updated on the ES in offline mode. Thus, system operation is not affected. The target stations will only be loaded once all the update steps listed below have been performed. For more information on downloading, refer to the Process Control System PCS 7; Engineering Station Configuration Manual.

Once you have completed all of the following update steps on the ES and continue with the configuration of the updated PCS 7 project, you may need to complete specific steps such as compiling CFC charts and downloading changes or the complete project to the AS.

8.2 General adaptations

8.2.1 Overview of General Adaptations in the Project

Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>16</td>
<td>Updating the OS with the Project Migrator (Page 63)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Checking the PH consistency (Page 65)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

8.2.2 How to update the configuration of the operator stations

If the configuration of an OS in a multiproject or project does not correspond to the installed PCS 7 version, this is automatically detected in SIMATIC Manager as of PCS 7 V8.0 SP1.

Requirements

- PCS 7 projects of a version older than and including PCS 7 V7.1 SP3 must first be updated to PCS 7 V7.1 SP4.
- Only for password-protected projects: Deactivate password protection for the following actions.
Procedure

Carry out the following steps for a given OS project:

1. Open your project/multiproject in the component view of SIMATIC Manager.
2. Select an OS project of your choice.
   If required, the "Migrator" dialog window is opened by the system.
   The message "Migration is required ..." is displayed.
3. Click "Yes".

Note
Declining migration
If you decline the migration, you cannot change the OS project or load it.
You can start the migration at any time. To do this, select the menu command Options > Migrate OS projects.

4. Check the project language set in the "Migrator" dialog box. If necessary, set the project language in which the project was created.
Recommendation:
No settings are required in the dialog box.
   – If you clear the "Migrate database only..." check box, considerably more time will be needed for the migration.
   – The migration of the excluded components in process mode has no effect on process mode.
5. Click "Next".
The configuration of all operator stations contained in the multiproject/project is performed.

Duration of the update process

Note
Depending on the scope, the update process can take several hours.

Additional information

- Online help WinCC Information System > Migration
- Configuration manual Process Control System PCS 7; Operator Station

8.2.3 Changing the Configuration of Multilingual Texts

If you want to use additional interface languages, please take note of the information below.
Changing Multilingual Texts

If you want to display text in more than one language in PCS 7 (for example, message texts or OS area IDs), always use the export/import function to change the multilingual texts (menu command Options > Manage Multilingual Texts > Export and then Import after the changes have been made).

Note

If you change individual texts with the functions in CFC, SFC or PH, be sure to immediately compile the texts in all locations (for example, all block types and all copies of a blocks). Otherwise, inconsistencies may occur and lead to the display of an incorrect language version of this text.

8.2 General adaptations

8.2.4 How to Check the PH Consistency

Introduction

This step shows you if all the data in the "plant hierarchy" are consistent.

Requirements

- The project is opened in the Plant View in SIMATIC Manager.

Procedure

The following steps can be performed for the multiproject or for each individual project (in the multiproject).

1. In the tree view, select the object to be checked (e.g., the multiproject).

2. Select the Options > Plant Hierarchy > Check Consistency menu command. The PH will be checked. The "Check Consistency - Log" dialog box opens.

3. Correct any errors if inconsistencies are found.

Note

If you need information on the possible inconsistencies, click the "Help" button in the "Check Consistency - Log" dialog box.
8.3 Adaptations in HW Config

8.3.1 Overview of Adaptation of the Hardware

Important information

The PCS 7 configuration data must be adapted in the following cases:

- When a module is replaced with a different type.
- When the CPU operating system or the firmware for CPs or IMs is updated.
- When the operating system is changed:
  Ensure that the hardware of the PC stations is suitable for use with the updated
  PCS 7-Version (e.g. operating systems, network adapter).
  Depending on the network adapter used in HW Config and the Station Configuration Editor,
  select the latest version of the communication component.

Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>18</td>
<td>Configuring replaced hardware (Page 66)</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>Setting the CPU properties (Page 67)</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>Updating the hardware configuration (Page 68)</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>(only for projects with SIMATIC PCS 7 BOX RTX or SIMATIC PCS 7 AS RTX)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>Configuring the address for the PDM server (Page 68)</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>(only for projects with SIMATIC PDM V7.0)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

8.3.2 How to Configure Replaced Hardware

After you have replaced modules in your process control system or performed a firmware
update, the hardware version status must be updated in your PCS 7 project.

Requirements

- The PCS 7 project operator stations have been updated with the Project Migrator.
Procedure

1. Open HW Config.
2. Drag the object (e.g. CPU: type, firmware version x.x) from the hardware catalog to the corresponding slot in the AS configuration table.
   The following system message is displayed: "Do you want to replace the component ... with component ...?"
3. Check the hardware types.
4. Click "Yes".
5. Select the menu command Station > Save/Compile.

8.3.3 How to Set the CPU Properties

Reason for Checking the CPU Properties

When you update a firmware version of a CPU, for example, in HW Config, certain parameters might not be accepted and might be replaced by default values during the update. In this case a message will appear. When this occurs, check the settings of the CPU properties and adapt them if necessary.

Requirements

- A message indicates that not all parameters were applied when the modules were replaced.
- HW Config is open.

Procedure

1. Select the CPU being used in the configuration table in HW Config.
2. In the context menu, select the menu command Object Properties.
3. Open the "Diagnostics/Clock" tab and check the settings in the "Clock" area:
   - The "In AS" synchronization must be set to the "As slave" synchronization type.
   - The "On MPI" synchronization must be set to the "None" synchronization type.
4. Open the "Cycle/Clock Memory" tab and check the settings:
   - If you are using module drivers from PCS 7 V6.0 and higher, the "Update OB1 process image cyclically" check box must be selected.
   - From the "OB85 Call for I/O Access Errors" drop-down list box, select "Only for incoming and outgoing errors".
5. Select the menu command Station > Save/Compile.
8.3.4 How to update the hardware configuration for SIMATIC PCS 7 BOX RTX and SIMATIC PCS 7 AS RTX

The steps described below only have to be carried out for project with SIMATIC PCS 7 BOX RTX or SIMATIC PCS 7 AS RTX implementation.

Replace the automation system in the hardware configuration of the PC station.

Requirements

- The AS version in HW Config is not up to date (Version 3.3 or older)
- The assignments of CPs to the master systems are known.

Procedure

1. Open the PC station in HW Config (SIMATIC PCS 7 BOX RTX or SIMATIC PCS 7 AS RTX).
2. Select the PROFIBUS CP to which the distributed I/O is connected.
3. Select the Edit > Master system > Disconnect menu command.
4. Select the CP.
5. Select the Edit > Delete menu command.
6. Select the "Win LC RTX" CPU in the rack in HW Config.
7. Go to the"SIMATIC PC-Station > Controller > Win LC RTX" folder in HW Config.
8. Double-click the object "V4.4".
   The "Insert ..." dialog box opens.
9. Click "Yes".
   The controller is replaced.
10. Go to the"SIMATIC PC-Station > Controller > Win LC RTX" V4.4" folder in HW Config.
11. Select the PROFIBUS CP used (default: CP 5613).
12. Drag-and-drop the selected PROFIBUS CP to the controller slot in the station window.
    The "Properties ..." dialog box opens.
13. Select the entry of the associated bus system from the "Subnet" list.
14. Click "OK".
    The "Insert master system" dialog box opens.
15. Select the entry of the associated bus system from the "Subnet" list.
16. Click "OK".
17. Select the Station > Save and Compile menu command.

8.3.5 How to configure the SIMATIC PDM Server

This section only applies to plants with a maintenance station.
Requirements

- The project/multiproject has been created.
- The SIMATIC PDM (Server) software package is installed on the Engineering Station.

**Note**

**Requirements for use of SIMATIC PDM**

Observe the conditions for the use of SIMATIC PDM versions. Information is available in the SIMATIC PDM Readme (online).

- Specifying the name of the PC station (computer name)
  You can find information about this in the documentation *Process Control System PCS 7: PCS 7 - PC Configuration*.

**Note**

The following names must be identical when you configure an OS or BATCH server and an engineering station:
- Computer name
- Name of the PC station

Procedure

1. Select the **Options > SIMATIC PDM > Settings** command in SIMATIC Manager. The "SIMATIC PDM settings" dialog box opens.
2. Select the "Maintenance Station" tab.
3. Go to the input field and enter the project/multiproject in which you have defined the MS server or execute the following steps:
   - In a multiproject:
     Click "Current Multiproject" or "Browse." You can select the current project using the "Browse" button.
   - For a project:
     Click on "Current Project" or "Browse." You can select the current project using the "Browse" button.
4. Click "OK".
5. Open SIMATIC Manager in the component view.
6. In the project, select the engineering station in which you wish to insert the "PDM Server" object.
7. Double-click the "Configuration" object in the detail view. The hardware configuration of the SIMATIC PC station opens.
   If you cannot see the hardware catalog, select the **View > Catalog** menu command. The hardware catalog opens.
8. Select **SIMATIC PC Station > PDM Server** from the list in the folder.
9. Drag and drop the "PDM Server" object to the PC station of the engineering station.
10. Select the menu command **File > Save**.
11. Download the configuration to the engineering station.

**Requirements for diagnostics with SIMATIC PDM**

The following conditions must be met for diagnostics of PDM devices from any station (OS client, maintenance server, etc.):

- The engineering station is accessible.
- SIMATIC PDM is active. (This is the default scenario after the configuration has been downloaded.)

**Additional information**

- STEP 7 and SIMATIC PDM Online Help
- Whitepaper *SIMATIC; Security concept PCS 7 and WinCC - Main document*

### 8.4 Adaptations in NetPro and conversion of the CFC/SFC charts

#### Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>22</td>
<td>Checking and adapting the connection data in NetPro (Page 70)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>Converting the CFC and SFC charts (Page 72)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### 8.4.1 How to Check and Adapt the Connection Data in NetPro

In NetPro, you check the configuration to the target stations:

- Connection data
- Configuration data
Note
Operating system change
When you change the operating system, the network adapters may be detected in a different order in the system. This is caused by the operating system.
Take this into consideration with systems with multiple network adapters and adapt the configuration accordingly in HW Config.
Update the version of the communication components in the Station Configuration Editor and HW Config.

Requirements
- The PCS 7 project is open on the ES.

Procedure
1. Select the PCS 7 project in SIMATIC Manager.
2. Select the menu command Options > Configure Network. NetPro opens.
3. Select the menu command View > Cross-Project Network View. The cross-project network view is displayed. This allows you to toggle directly between all projects in the multiproject.
4. Check the connections to the various stations: AS-OS, AS-AS, ES-AS. You can make any necessary changes when the "cross-project network view" is deactivated.
You must configure the connection between the ES and AS if you want to check the communication for process mode (runtime) on the ES. This requires the following steps to be taken:
- Select the menu command New Connection in the shortcut menu of the WinCC application.
- Select the destination: AS or OS.
- Select the connection.
- Select the name for the connection.
- Click "OK".

Recommendation
To enable you to easily identify the connections, we recommend that they be assigned default names in accordance with the name of the target.
Example:
You configure an OS to AS_X connection. The corresponding connection name could be "ASX_connection".
5. If you are using time synchronization, you must check the time settings of the network adapter (e.g. communications processor) for the ES and OS. Double-click the network adapter of the OS/ES. Time-of-day mode must be selected for time synchronization on the "Options" tab.

6. If you have made changes in NetPro, you must perform a "Save and Compile" operation with the "Save and Compile All" option.

8.4.2 How to convert the CFCs

Requirements

The PCS 7 project is opened on the ES.

Procedure

Note

This procedure must be carried out for all S7 programs in your PCS 7 project.

1. Open a CFC chart and move any block contained within it. This action will cause the conversion dialog to open immediately.

2. Click "Yes".
   The "Convert Format" message window opens.

3. Click "Yes".

4. Click "OK".

8.5 Updating the blocks

8.5.1 Overview of tasks for updating blocks

Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>24</td>
<td>Copying objects from other libraries into the master data library (Page 76)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>Filling the master data library (Page 77)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td>Synchronizing blocks (Page 81)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td>Including event texts (Page 83)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td>Importing operator texts (Page 84)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### 8.5.2 Integration of a New Master Data Library

**Basic Procedure**

Creating a multiproject will also create an empty master data library. You copy all blocks from the first AS from the "Offline" block folder with the version to be updated to the master data library. Then compare the blocks in the master data library with the "Offline" block folder of the next AS. If it contains other blocks that have not been stored in the master data library, you also copy these to the master data library. Repeat this procedure through to the final AS.

**Note**

The following information applies to AS blocks in a PCS 7 project.

- Only the AS blocks of one PCS 7 version may be loaded on a SIMATIC station.
- You can always only insert the AS blocks of one PCS 7 version into a master data library.

### 8.5.3 Language of Message Texts in Faceplates

**Texts in Faceplates**

If you want to convert messages displayed in the faceplates and generated from the ES data management from the English default to other languages, such as Italian or Spanish, you must perform the following procedure:

- Copy objects from other libraries to the master data library
- Copy the blocks used in the project to the master data library
- Edit the event texts and operator texts in the faceplates
- Update the block types in the project

**Message Texts in Block Instances**

Message texts from block instances that were created by copying block types have no type reference.

---

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>29</td>
<td>Adapting operator texts (Page 84)</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td>Configuring limits for Online Trend Control (Page 79)</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>31</td>
<td>Updating block types (Page 85)</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>32</td>
<td>Updating SFC block types (Page 87)</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>33</td>
<td>Compiling the CFC charts (Page 88)</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
If other display languages (such as Italian, Spanish) are added after the software update, the message texts of these added display languages are shown in English in the block instances of the block types.

**Including Message Text in the Block Import**

If you want to include messages text in a block import, you need to make settings for the block type in the library (master data library).

**Note**
The message texts will be overwritten for all block instances of the block type in the entire S7 program!

**Additional information**

You can find additional information about this in the section "How to Include Event Texts from the Block Type in the Block Import (Page 83)."

### 8.5.4 Editing Texts for Faceplates

**Applications**

The procedure steps in the section "Adapting Operator Texts with Import File" must be executed under the following conditions:

- You want to convert texts displayed in the faceplates from the default language (English) to another language, such as German or French.
- If you want to retain the old operator texts of your project.

**Operator Texts in Block Instances**

**Note**

You can no longer re-integrate the operator texts by importing a block type if you have made changes to the operator texts in the block instances in your CFC charts. You can then only change the operator texts in the block instances.
8.5.5 Rules for Copying Objects from Other Libraries

Rules for Copying

- If you want to copy the process tag types supplied in the PCS 7 library to your master data library, select only the process tag types you require in the "Templates" folder. Copy these types and paste them into your master data library's "Charts" folder.

- If you copy blocks into the master data library from different libraries, it is possible that blocks will be assigned different names (and functions) but the same block numbers. If this does occur, a dialog box will open where you can rename the block or synchronize the attributes. Blocks can only be renamed (reassigned) when they are copied to the "Offline" block folder.

- The symbolic name is also copied when you copy the blocks from a library. The symbolic name is lost and must be subsequently entered in the symbol table if you copy blocks from an S7 program and not from a library.

Rules for Multi-instance Blocks

- In the case of blocks whose codes are used to call other blocks (multiple instance blocks), these lower-level blocks must be copied in the right version too. Any missing lower-level FBs are displayed when the user program is compiled.

**Note**

Note that the ES does not identify the missing FCs when the user program is compiled. If an FC is missing from the user program, the AS CPU will enter the STOP mode following download. If necessary, test the executability of a user program with a "reduced library" on a separate CPU.

- The code of the multiple instance block always stores the numbers of the blocks it calls. You can edit those numbers and, therefore, the program code itself, using the **Options > Rewire ...** menu command in SIMATIC Manager. **Exception**: The numbers of protected blocks cannot be changed.

8.5.6 Rules for Editing the Operator Texts

Introduction

Comply with the following rules when modifying default texts.
Rules

- The new texts must not be longer than the default texts. If longer texts cannot be avoided, you must check to see whether the message is displayed correctly on the faceplate.
- The "s7_unit" attribute does not have to be considered for the translation since blank spaces or international codes were used as default values.
- If you need multilingual texts, use the WinCC Editor "Text Library" to translate these to other languages. In SIMATIC Manager, you must therefore set exactly the dialog language that is to be used by default to configure the operator texts and display texts (usually "English") for display devices. This is the only way to ensure that the translated messages are not overwritten the next time the OS is translated.
- When the OS is compiled, the column that is always used as a reference is the one containing the language set in SIMATIC Manager as the "Standard language for display units". The texts in the Text Library of WinCC Explorer are automatically entered by PCS 7. Change the texts only if you have adapted unit and operator texts.

Note

If you recompile the OS, you cannot switch the "Default language for display devices" in SIMATIC Manager. In this case, translated entries can be overwritten. For more information, refer to the Process Control System PCS 7; Operator Station documentation, section "Relationship between Compile OS and Text Library".

8.5.7 How to Copy Objects from Other Libraries to the Master Data Library

This section describes how to transfer objects from the libraries supplied with your PCS 7 version, or other libraries provided by external suppliers, to the master data library.

Note

Copy from the libraries to the newly created master data library only those objects whose versions were used in the project to be updated.

Note

On an AS, you must always load the AS blocks of compatible libraries. For example, the following libraries are compatible:
- PCS 7 Advanced Process Library V8.2
- PCS 7 Basis Library V8.2
- PCS 7 Library V7.1.3 SP3 UPD 3 with driver blocks from the "ChnBlocks for PCS 7 V8" folder
Updating libraries used in the project

Depending on the blocks used, you need to update these with the blocks of the following libraries:

- PCS 7 Basis Library
- PCS 7 Advanced Process Library (APL)
- PCS 7 Library (For information on this, refer to the "How to Install Additional PCS 7 Libraries (Page 54)" section)

Requirement

- The master data library has been created in the project to be updated.

Procedure

1. Select the menu command **File > Open** in the SIMATIC Manager.
2. Open the "Libraries" tab.
3. Select the required library and click "OK".
   The library opens.
4. Select the library section to be copied from the open library (source).
5. Select the menu command **Edit > Copy** (e.g., process tag types, blocks).
6. Select the folder in the master data library (target) where the copied library section is to be stored.
7. Select the menu command **Edit > Paste**.
   The copied library section is saved in the master data library.

Adapting default texts

Adapt the default texts in the master data library in which you have replaced the blocks (created in PCS 7 V7.1. SP3, for example) with blocks from the latest PCS 7 version.

Additional information

- Section "Editing Texts for Faceplates (Page 74)"

8.5.8 How to fill the master data library

The following tasks are only necessary if you update a project that has not been completely configured from the master data library.
Requirements

- The master data library has been created and is open.
- The "Offline" block folder of a SIMATIC station is open.
- You are only using the original blocks from the PCS 7 libraries in the SIMATIC stations.
- You are not using blocks from different PCS 7 versions in the SIMATIC stations and wish to continue using the blocks from a single PCS 7 version following the PCS 7 update.

Note

On an AS, you must always load the AS blocks of compatible libraries.

For example, the following libraries are compatible:
- PCS 7 Advanced Process Library V8.2
- PCS 7 Basis Library V8.2
- PCS 7 Library V7.1.3 SP3 UPD 3 with channel blocks from the "ChnBlocks for PCS 7 V8" folder

Procedure

1. Select the menu command View > Details.
2. Select the detail view and click the column heading "Author". This arranges the blocks used in your project and contained in the offline block folder according to "Author".
3. Select all blocks listed with an "older" version number in the "Author" column (e.g. DRIVER60, "...60", "...70", ...)
   Keep the <Ctrl> key pressed to select several blocks.

Note

You also need to select the following BATCH blocks for projects with BATCH configuration:
- All blocks with the "BATCH" entry in the "Family" column
- The blocks READ_CLK and NOTIFY_8P, when they are used

4. Select the blocks or block areas that are not available in the master data library.
5. Select the menu command Copy in the shortcut menu.
6. Select the "Blocks" folder in the open master data library.
7. Select the menu command Paste in the shortcut menu.
   If you have selected the "Always prompt for settings" check box in the "Set Message Range" dialog box, the "Message Number Assignment Selection" dialog box appears when you copy blocks.
8. Select the "Always assign CPU-oriented unique message numbers" check box.
9. Select the next "Offline" block folder and compare its blocks to the blocks that are already contained in your master data library. If the "Offline" block folder contains additional blocks, copy these blocks to the master data library you have created.

10. Repeat the steps 5 through 9 with all other "Offline" block folders.
8.5.9 Trend Control for Displaying Archive Values

Display in Trend Control
The following notes only need to be taken into account if you want to display archive values in trend control.
This section is not relevant for displaying online tags in trend control.

Name of the Available Archive
If the project being updated contains an archive called "Process Value Archive", the archive tags generated by the system are saved in an archive called "SystemArchive".
If these archive values are to be accessed using the trend control display, the following settings must be changed in the block icon properties in the Graphics Designer:

- ReturnPath:
  Transfers trend data for the corresponding process tag.
- StandardTrend:
  Used to define the trend functionality to be visualized in the trend view.

Procedure
1. In the tree view, select the "Styles" object.
2. Make the following settings:
   - StandardTrend:
     Change from 2 to 3.
   - ReturnPath:
     Add the following in the return path: *archivname:Systemarchiv*asia:
     Example: U:CO_DKGREEN*archivname:SystemArchive*asia:

8.5.10 How to Configure Extensions for Online Trend Control
You can specify the following parameters for automatically displaying value axis values in online trend control as part of process control:

- Limit values
  - Maximum value (high limit)
  - Minimum value (low limit)
- Unit

These parameters for displaying a tag in online trend control are automatically adopted by the associated function block when the OS is compiled.
Parameter Attribute "S7_trend"

Parameter attribute "S7_trend" can be assigned for function block I/Os, if the data type is one of the following:

- INT
- DINT
- Real

Requirements

- Parameter attribute "S7_m_c" is set to TRUE for the block and corresponding I/Os to be taken into account with (high and low) limit values in online trend control.
- The "Online trend control" object is inserted in the process picture.

Note
The "automatic" check box is activated by default for "Online Trend Control" objects (Properties, "Value axis" tab, "Range selection" group).

Note
Automatic adaptation of the high an low limits for archive tags in the Online Trend Control requires the following CFC configuration:

Set the archiving parameter (that is assigned parameter S7_trend) when you configure the associated block in the CFC.

Configurations using WinCC Tag Logging are not supported in PCS 7.

Procedure

1. Open SIMATIC Manager in the component view.
2. Select the block (block type) in the library (master data library).
3. Select the menu command Edit > Open Object.
   The "LAD/FBD/STL" dialog box opens.

   Note
   If a message appears that the block is write-protected, just ignore it.

4. In the tree view, select the block I/O for which you want to specify parameters.
5. Select the menu command Edit > Object Properties.
6. Select the "Attributes" tab.
7. In an empty line, select the "S7_trend" entry from the drop-down list box.
8. Enter the name of the block I/Os at which you want to parameterize high and low limits for the selected I/O in the "Value" column. A comma separates the names (for example, LL_Name,HL_Name).
9. Click "OK".
10. Select the menu command **File > Save**. The "Save ..." dialog box opens.
11. Click "Yes".
12. Select the menu command **File > Close**.

Additional information
- Online help *STEP 7*

### 8.5.11 How to Update the Master Data Library

**Introduction**

The blocks of the master data library you created must be replaced with blocks of the current PCS 7 library.

---

**Note**

**PCS 7 libraries**

As of PCS 7 V7.1, the PCS 7 blocks included on the Process Control System; SIMATIC PCS 7 DVD are distributed to different libraries.

---

**Library for Redundant I/O Modules**

If you are using redundant modules in the project, then you must also update the "Redundant IO (V1)" library.

**Requirements**

- The master data library contains all blocks of the project being updated.
- The master data library is open.
- It does not contain any PCS 7 V4 or V5 blocks (types: IN_..., Out_..., and PA_blocks of a block version lower than 5.2).

**Rule**

**Note**

The attributes of the individual blocks must be synchronized when replacing the blocks in the project being updated. Individual attributes of the old blocks can be applied if you have assigned the "S7_m_c" attribute to additional outputs, for example. You can apply the attributes of the new blocks if you have not made any changes to the default settings.
Adaptations in the PCS 7 Project on the ES

8.5 Updating the blocks

Validity

**Note**
The procedure described in the sections that follow is only valid for blocks whose object name and name (header) have not changed between library versions.

Procedure

1. Select the menu command **File > Open** in the SIMATIC Manager.
2. Open the "Libraries" tab.
3. Select a library from which you want to import blocks (e.g. *PCS 7 AP Library V80*). Click "OK".
   The library opens.
4. Double-click the "Blocks+Templates" folder and then on the "Blocks" folder.
5. Arrange the library one beneath the other so that the contents of both windows can be easily seen and the master data library is on the top.
6. Keeping the <Ctrl> key pressed, select all blocks which also exist in the master data library from the library you selected.
7. Right-click a selected block or block area, and select the menu command **Copy** in the shortcut menu.
8. Select the "Blocks" folder in the master data library, and select the menu command **Paste** in the shortcut menu.
9. Synchronize the attributes for each block individually by clicking the "Update Attributes" button.
   If different attributes are found, a dialog box displays the differences between the block attributes.
10. Check the attributes and the project-specific settings.
    **Note**
    We recommend applying the default settings.
    **Note**
    If you click the "All" button in the "Insert Function Block" dialog box, all blocks will be copied without synchronizing the attributes.
11. Click "OK".
    If no differences between the attributes are identified, a dialog box indicating this is displayed.
12. Click "OK".
13. Click "Yes". The corresponding block is copied to the master data library with the synchronized attributes.

14. Repeat those steps to select additional libraries.

**Note**

For projects with BATCH configuration, repeat the procedure with the SIMATIC BATCH BLOCKS library.

---

### 8.5.12 How to include event texts from the block type in the block import

**Introduction**

One aspect that should be noted with a software update of projects, is that the message texts of block instances, generated by copying block types, have no type references. If other display languages (such as Italian, Spanish) are added after the software update, the message texts of these display languages are shown in English in the block instances of the block types.

**Importing and Editing Message Text of Block Instances**

The following setting is required if you want to automatically overwrite the message texts of all instances in a block type for the entire S7 program.

If you want to edit the message texts of the instances, you need to deactivate this setting and perform an import again.

**Procedure**

1. Open the SIMATIC Manager in the Component View.
2. Select the block (block type) in the library (master data library).
3. Select the **Edit > Special Object Properties > Message Numbers** menu command. The "PCS 7 message configuration" dialog opens.
4. Complete the following settings in the message texts column on the right side of the "Event" column of the table: The symbol appears as follows:

- Activate the check box for the message texts you want to import from the block type.
- Deactivate the check box for the message texts you do not want to import from the block type.

**Note**
The message texts will be overwritten at all block instances of the block type in the S7 program!
If you wish to modify the instances of the block types again, you must clear the corresponding check marks and perform another block import.

5. Click "OK".

8.5.13 How to import the operator texts

**Requirement**
The user texts have been exported from the project to be updated.

**Importing User Texts**
1. Open the project to be updated in the SIMATIC Manager.
2. Select the master data library folder in the Component View. If this folder is not available, select the project folder.
3. Select the Options > Manage Multilingual Texts > Import menu command. The "Import User Texts" dialog opens.
4. Specify the storage location and the format of the import file (possible formats: *.xls and *.csv).

8.5.14 How to adapt the operator texts

**Requirements**
- The master data library contains the PCS 7 V8.2 blocks.
- The master data library is open.
- You have noted down the texts of the "S7Shortcut", "S7_string_0" and "S7_string_1" parameter attributes and the corresponding PCS 7 blocks.
Procedure

There are different procedures for adapting the operator texts:

- Adapting for block types
  
  You can find more information about this in the manual *Process Control System PCS 7; Operator Station* in the section "How to Edit Texts for a Block Type".

- You can find more information about this in the manual "Process Control System PCS 7; Operator Station" in the section "How to Edit Texts in a Block Type."

We recommend that you adapt the operator texts for block types. This ensures the following:

- Operator texts of identical blocks are consistent in the different automation systems.
- Adapted texts are readily available for subsequent configuration.

You must also adapt the block type in the modified block instance if you have already adapted operator texts in CFC block instances in manual mode.

Additional information

- Manual *Process Control System PCS 7; Programming Instructions for Blocks* in the section "ES Texts for Operator Control of Analog and Binary Values"
- Configuration manual *Process Control System PCS 7; Operator Station* in section "Adapting the Unit and Operating Texts".

8.5.15 How to update the block types in the project

**Note**

It is only possible to work with a master data library if blocks with the same designation have the same structure and attributes in all projects of the multiproject.

**Requirement**

The master data library has been created with the current block types.

**Recommendation: Cleaning up block folders**

To prevent that inconsistencies in data management are caused by unused blocks, you should clean up the block folder.

1. Open an CFC chart for each AS.

2. In the CFC editor, select the menu command **Options > Block types**.
   The "Block types" dialog box opens.

3. Click "Clean Up".
   The "Cleaning up block types in the block folder" dialog box opens.
4. Select the blocks you do not need from the list.
5. Click "OK".

**Procedure**

1. Select all blocks that to be updated in the block folder of the master data library.
2. Select the menu command **Options > Charts > Update Block Types.**
   The "Update Block Types" dialog box opens.
3. Select the S7 programs to be analyzed for the selected block types that differ from those in the master data library.
4. Click "Next".
   All S7 programs selected are checked and another dialog for selecting the block types opens. This provides information about the potential consequences of updating the block types.
5. Specify the block types to be updated for the various S7 programs. You must select all the block types to be updated. You can exclude selected block types from the update, if required. If there are no block types available for updating, no block types are displayed. In this case, close the dialog box.
6. Click "Next".

**Result**

The block types are updated in all selected S7 programs and a log is displayed.

**Project with SFC**

If you use SFCs in your project, please note that you need to update the SFC blocks. A new SFC runtime system is provided with SFC. Following a conversion, the associated blocks are copied automatically to the block folders whose assigned chart folders have been converted.

When the software is updated, a compilation of changes and download of changes with deactivated SFCs/instances is possible.

**Note**

**SFC system blocks inserted by the system in the chart folder of the AS**

If the **SFC system blocks FB 245, FB 246, FB 300, FC 240 ... FC 250** are inserted in an AS by the system, you have to manually copy these SFC system blocks from the current SFC library into the "Offline" block folder of the AS.

- The SFC system blocks **FB 245 ... FB 300 and FC 240 ... FC 250 from "SFC Library\Blocks +Templates\Blocks"** are reserved blocks for PCS 7 and cannot be renamed. This means that any identically-named user blocks in projects must be renamed before the SFC component of PCS 7 is used.
- Afterwards, a **complete compilation is absolutely mandatory** (even though a compilation of changes is offered for selection), and a download of changes is permissible.

See section "Compiling the CFC Charts (Page 88)"
Refer to the SFC Readme.

8.5.16 How to update the SFC block types in the project

Note
It is only possible to work with a master data library if blocks with the same designation have
the same structure and attributes in all projects of the multiproject.

Listing components with "old" versions of a block type
After having inserted a new version of a block type orSFC type into the master data library, or
after you customized a block type in the master data library, you can use the “Update Block
Types” function to list all components in which an older version of the modified block type is
still in use. Throughout the entire multiproject, you can also select the components in which
the modified block type will be updated.

Requirement
- The master data library has been created with the current block types.

Procedure
1. Select one or more SFC types in the chart folder of the master data library.
2. Select the menu command Options> Charts > Update Block Types.
The "Update Block Types" dialog box opens.
3. Select the S7 programs to be checked for differences compared with the block types/SFC
types selected in the master data library.
4. Click "Next".
   All S7 programs selected are checked and another dialog for selecting the block/SFC types
   opens. The dialog also provides information about the possible effects of the update of the
   block/SFC types.
5. Specify the block/SFC types to be updated for the S7 programs. You have selected all block/
   SFC types to be updated. You can exclude selected block types from the update, if required.
6. If there are no block/SFC types to be updated, no block/SFC types will be displayed. In this
   case, close the dialog box.
7. Click "Finish".

Result
The block/SFC types are updated in all selected S7 programs and a log is displayed.
8.5.17 Compiling the CFC Charts

F charts/F blocks

Note
If your project contains F charts/blocks and you do not upgrade to the new F technology, the F-@ charts must not be deleted. Otherwise, your F program will receive a different signature. The F system would then have to undergo the acceptance process again according to the country-specific guidelines due to the changed signature.

Procedure

1. Perform a complete compilation of the S7 program.

8.6 Adaptation of OS-relevant settings

8.6.1 Overview of Adaptation of the Operator Stations

Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>34</td>
<td>Synchronizing OS root screens, local computer actions and faceplates (Page 89)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>35</td>
<td>Updating picture objects (Page 92)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

User interface and design

After the software update, the design of the user interface for process mode must be set to the following:

WinCC 3D
This setting is available automatically in projects created as of PCS 7 V8.0. Other designs are not approved for PCS 7.

You must check or edit this setting for existing projects.

- It is important to ensure a uniform design setting is made for all projects within a system.
- When changing the setting for the WinCC design, check the visualization of user objects and customize these if necessary.

8.6.2 Synchronization of OS Basic Pictures, Local Computer Actions and Faceplates

You have to transfer OS basic pictures and local computer actions to your project. The faceplates of the project can continue to be used.

Synchronization in the OS Project Editor

You perform this procedure with the OS project editor, which is included in WinCC Explorer.

8.6.3 How to Synchronize OS Basic Pictures, Local Computer Actions, and Faceplates

Perform the following steps for the projects of each operator station (server and clients).

Requirements

- The operator stations contained in the PCS 7 project have been updated with the Project Migrator.
- The PCS 7 OS is open in WinCC Explorer.

Procedure

1. Select the OS Project Editor and select the menu command Open in the shortcut menu.
2. Select the "Complete configuration" check box on the "General" tab.
3. Click the "Layout" tab.
4. Select the required layout and the monitor configuration.
5. Click the "Basic Data" tab. Make the required settings in accordance with the "Basic Data" table below.
6. Only carry out this step if the "For observation only" authorization level must be activated for some users after the software has been updated.

Select the "Message Display" tab.

Activate the required message filters (see the "Message Filters" table below).

**Note**

No settings are necessary for the software update on the remaining tabs. The default settings can be applied.

7. Click "OK".

### Basic Data

<table>
<thead>
<tr>
<th>Dialog Area</th>
<th>Note</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top left window</td>
<td>This window lists all basic pictures having a different product version and project version change date. Every basic picture with a selected check box is overwritten in the project version at the start of the OS Project Editor with the pictures from the product version.</td>
<td>None. The root screens marked with a red &quot;X&quot; cannot be deselected.</td>
</tr>
<tr>
<td>Top right window</td>
<td>This window lists all local computer actions having a different product version and project version change date. Every local computer action with a selected check box is overwritten in the project version at the start of the OS Project Editor with the corresponding local computer action from the product version.</td>
<td>None. The root screens marked with a red &quot;X&quot; cannot be deselected.</td>
</tr>
</tbody>
</table>
| Bottom left window     | This window lists all faceplates having a different product version and project version change date. | • If you want to replace the faceplates available in the project with those of the relevant product version, select the corresponding check box. The settings provided by the product will then be applied.  
• If you have made project-specific customizations to the color ranges of the faceplates of the Advanced Process Library and do not want to reset them, make sure that the "Update palette colors of Advanced Process Library" check box is not selected. (default setting).  
• If you want to restore the default, select the check box "Update palette colors of Advanced Process Library". |

**Note**

Projects prior to PCS 7 V8.1

In PCS 7 V8.1, the Dynamic Wizard has been changed because of the AS-granular structure types.

Ensure that the "Update Dynamic Wizard Scripts" check box is selected.
### Message Filters

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Messages that can be acknowledged in a separate list</td>
<td>The message windows have two message lists. One list shows all messages from the area for which the user has access rights for all &quot;operator process controls&quot;. The user can acknowledge messages in this list. The other list shows all messages from the area for which the user has an &quot;authorization for area&quot; but no access rights for &quot;operator process controls&quot;. The user cannot acknowledge messages in this list. The message line in the overview area only shows messages that can be acknowledged with the access right for &quot;operator process controls&quot;.</td>
</tr>
<tr>
<td>Messages that can be acknowledged on a separate page (switch-selectable)</td>
<td>Both of the message pages indicated above are available to the user. Only messages from areas for which the user has access rights for &quot;operator process controls&quot; are displayed on the message page with only one list and in the message line of the overview area.</td>
</tr>
</tbody>
</table>

### Additional information
- Online help *WinCC Information System > Options > Options for Process Control > OS Project Editor*
- Online help *OS Project Editor*

### 8.6.4 Update of Picture Objects

#### Introduction
When the picture objects are updated, the block icons of the previous PCS 7 version are replaced with the block icons of the current PCS 7 version. This is necessary to enable you to use all functions of PCS 7.

#### Rules
Only the block icons of the selected template picture are updated. For this reason, you must use the corresponding template picture for updating the picture objects, depending on the template you have used for configuration.
- Use "@TemplateAPLV8.pdl" or "@PCS7TypicalsAPLV8.pdl" for the APL block icons.
- "@Template.pdl" or "@@PCS7Typicals.pdl" for block icons of the PCS 7 Library.

It is recommended to perform the update once on each individual template picture.
8.6.5 How to Update the Picture Objects

Introduction
If you have manually inserted and interconnected picture objects from a template picture into a process picture, you must manually update these picture objects.

You have to use the corresponding template picture that you used for configuration to update the picture objects.
Recommendation: Perform the update one by one with each template picture of the library used.

Requirements
- The operator stations contained in the PCS 7 project have been updated with the Project Migrator.
- All basic pictures are replaced with the OS Project Editor.
- The PCS 7 OS is open in WinCC Explorer.
- Read the following section in the Process Control System PCS 7; Operator Station configuration manual; section “Rules for using multiple template files”.

Procedure
1. Open any WinCC picture containing a picture object in the Graphics Designer. Select the picture object.
2. In the dynamic wizard, open the "Picture Functions" tab and select "Update Picture Objects". This "Dynamic Wizard" dialog opens.
3. Click "Next".
4. Select the "Yes, all pictures" check box.
5. Click "Next".
6. Select the template in the list which has been configured with the picture objects of the OS. (default: @Template.pdl)
7. Select the default "TemplateControl.cfg" configuration file in the "Please specify name of configuration file" field.
8. Click "Next".
9. Click "Finish".
Generation of the picture objects is initiated in the Dynamic Wizard.

Additional information
You can find additional information on how to adapt picture objects in the Process Control System PCS 7; Operator Station configuration manual in the following sections:
- Section "Function and use of block icons and faceplates"
- Section "How to insert custom pictures in an extended status display"
8.6.6 How to update block icons containing user customizations

As of PCS 7 version 8.2, the following procedures are possible for user customizations of block icons during the software update:

- Transfer the main parts of the user customizations from the template file to the current block icons. You can enable new functions with this.
- Do not use the new functions and continue to use your user-defined block icons.
- Do not use the user customizations, use the block icons from the product's default template file.

The following describes how to transfer the plant-specific adaptations to the current block icons.

Requirements

- The project to be updated includes blocks of the Advanced Process Library as of PCS 7 V8.0.
- The following applies for the project:
  - The project has been opened in the OS Project Editor. The following file is thus available in the project:
    - @PCS7_Block_Icon_Migration.pdl
  - The project contains template files with user-defined block icons.
    - For example, in the @PCS7TypicalsAPLMyLib.PDL file
  - If you only want to transfer selected adaptations of the user-defined block icons, you can adapt the following configuration file:
    - PCS7BlockIconMigration.cfg

You can find this file in the "<WinCC project path>\WScripts\" folder.
You can find information on this in the Process Control System PCS 7; Operator Station configuration manual.

The table below shows the adaptations of the faceplates that can be migrated:

<table>
<thead>
<tr>
<th>Type of adaptation</th>
<th>Adaptation is migrated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic properties, such as color, size, position, overlapping (height in Z-axis), etc. of the internal objects</td>
<td>Yes</td>
</tr>
<tr>
<td>Language-specific properties</td>
<td>Partially</td>
</tr>
<tr>
<td>Indexed properties</td>
<td>No</td>
</tr>
<tr>
<td>Internal block interconnections</td>
<td>No</td>
</tr>
<tr>
<td>Scripts for actions (C script or VB script)</td>
<td>No</td>
</tr>
</tbody>
</table>
Procedure

1. Open the @PCS7_Block_Icon_Migration.pdl picture in the Graphics Editor.

2. Select the menu command Migration > Migration of Block Icons. The "Migration of Block Icons" dialog box opens.

Note

Migration menu command not available

The "Migration" menu command can be selected if the "Deactivate all VBA events" check box is cleared in the "Options" tab of the Options > Settings menu.

3. Make the following settings:

<table>
<thead>
<tr>
<th>Input box</th>
<th>Example for the selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection of the product image (source for copying)</td>
<td>@PCS7TypicalsAPLV8.PDL</td>
</tr>
<tr>
<td>Selection of the image customized by the customer</td>
<td>@PCS7TypicalsAPLMyLib.PDL</td>
</tr>
</tbody>
</table>

4. Click "Migrate". The migration is performed automatically in several steps:
   - Copy the block icons from the default template file for the product to a new template file.
   - Copy, modify and check the objects contained in the block icons.

The progress is displayed numerically as percentage. The log file for the migration can be found in the directory of the WinCC project.

5. Save the template file under the plant-specific name "Save as ...". Enter a name for the plant-specific template file. Read the following section in the Process Control System PCS 7; Operator Station configuration manual; section "Rules for using multiple template files".

Note

Red square around user-defined block icons of the plant-specific template file

When a block icon is framed by a red square, an error occurred during migration. It was not possible to migrate all properties of the block icon.

- You can find information on the error that occurred in the tooltip text of the red square.
- You can find information on the errors that occurred for all block icons in the migration log file (<project folder>\PCS7BlockIconMigration.txt).

6. Perform all required corrective measures at the newly created faceplates manually.
Evaluating the log file PCS7BlockIconMigration.txt

<table>
<thead>
<tr>
<th>Situation when creating the block icon</th>
<th>Result in the log file</th>
</tr>
</thead>
<tbody>
<tr>
<td>There is an object in the block icon of the plant, but not in the block icon from the default template file of the product.</td>
<td>Error</td>
</tr>
<tr>
<td>There is an object in the block icon from the default template file of the product, but not in the block icon of the plant.</td>
<td>Warning</td>
</tr>
<tr>
<td>An object has different types in the block icon from the standard template file of the product and in the block icon of the template file of the plant.</td>
<td>Error</td>
</tr>
</tbody>
</table>

Example:
- Block icon from the default template file for the product: Type: Input/output field
- Block icon from the template file for the plant: Type: Dataset

8.7 Adaptations for the Process Historian

8.7.1 Adaptations for the Process Historian at a glance

Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>36</td>
<td>Updating Process Historian and Information Server (Page 95)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>37</td>
<td>Replacing a central archive server with a Process Historian (Page 96)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

8.7.2 How to update the Process Historian and Information Server

You must update the following PC stations, if they were present in the PCS 7 project before the software update:

- Process Historian
  You can find information on this in the SIMATIC HMI; Process Historian system manual.

- Information Server
  You can find information on this in the SIMATIC HMI; SIMATIC Information Server system manual.
How to replace the CAS with the PH

If a central archive server (CAS) was used in the PCS 7 project, this cannot archive new plant data from PCS 7 plants as of V8.1.

 Recommendation:
Replace the CAS with the following PC stations:
- Process Historian as external archive server
- Information Server as reporting system

Requirements
- The Process Historian is installed.
- The Process Historian is configured according to the guidelines specific to the plant (new PC station in the workgroup/domain - network addresses, user etc.).
- The software of the engineering station is updated.
- The PCS 7 project is updated.

Procedure
1. Open the SIMATIC Manager on the engineering station.
2. Open the PCS 7 project in the component view.
3. Do the following in the component view of SIMATIC Manager:
   - If the CAS station is located in a separate project in the multiproject:
     Select the project of the CAS station.
     Select Multiproject - Remove from multiproject from the shortcut menu.
     The CAS station is removed from the multiproject.
   - If the CAS station is located in a project with other stations:
     In the component view of SIMATIC Manager, select the PC station with the "CAS" role.
     Select Delete from the shortcut menu. Click "Yes".
     The CAS station is removed from the project.
4. Perform the following sequence of tasks for all OSs in the multiproject that have stored data on the CAS (OS servers and single-station systems):
   - Open the "Backup Configuration" tab in the "Properties" dialog of the PC station.
   - Clear the "Backup enabled" check box for the following options:
     - Tag Logging > Archive configuration > Tag Logging Fast
     - Tag Logging > Archive configuration > Tag Logging Slow
     - Alarm Logging > Archive configuration > Message archive
   - If SIMATIC BATCH reports are to swapped out, you need to disable the export of the reports to CAS.

   **Note**
   **CAS backup configuration**
   If there is no longer a CAS computer in the project but the destination paths are entered, a process control error is generated at each segment transition.

5. Perform the following sequence of tasks for all operator stations in the multiproject that have a CAS assignment:
   - Select the OS project in the component view of the SIMATIC Manager on the PC station.
   - Select the menu command **Options > OS > Assign OS Server,...**
     The "Assign OS Server ..." dialog box opens.
   - In the list of OS servers, check the following:
     Make sure that the check box for the OS server with the data you want to visualize on this operating station is selected.
   - Clear the check box for the PC station of the CAS.

6. Create a new PC station for the Process Historian in the project.

   You can find additional information about this in the documentation *Process Control System PCS 7, Engineering System*. Save and compile the configuration.

8. Set the properties in the SIMATIC Manager. For this purpose, select the Process Historian's PC station and then select the shortcut menu command **Object properties**.

9. Enter the computer name in the "Computer name" group or activate the "Computer name identical to PC station name" check box.

10. Click "OK".
    The "Properties" dialog box closes.

**8.8 Adaptations for the Maintenance Station**

**8.8.1 Overview of the Maintenance Station update**
Performing additional steps for updating an MS server.
Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>38</td>
<td>Changing the OPC server and adapting the SNMP configuration (Page 98)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>39</td>
<td>Updating the diagnostics settings (Page 100)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>40</td>
<td>Updating the diagnostics screens (Page 101)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

8.8.2 How to change the OPC Server and adapt the SNMP configuration

OPC Server version

The following section provides information on updating the version of the OPC server.

- The OPC server version to be used is V8.2.
- Replace the OPC server if necessary.

Requirements

- The blocks, charts and OS pictures of the project are updated.
- The SIMATIC programs and OS are compiled.
- The PC stations of the maintenance station (MS server and MS client) are updated.
- MS multiple station system
  - The OPC server is configured on the PC station of the MS server.
  - The following stations are configured when a redundant MS server is used:
    - An OPC server on the PC station of the MS server
    - An OPC server on the PC station of the redundant partner
- MS single station system
  - An OPC server is configured on the PC station of the MS single station system.
- Lifebeat monitoring is disabled
  If you use the Maintenance Station in the project, lifebeat monitoring must be disabled.
Procedure

1. Select the PC station in the Component View.
   - In an MS multiple station system, select the PC station of the MS Server or of the redundant partner.
   - In an MS single station system, select the PC station of the MS single station system
2. Double-click the "Configuration" object in the detail view to open HW Config. The hardware configuration of the SIMATIC PC station opens. If you cannot see the hardware catalog, select the View > Catalog menu command. The hardware catalog opens.
3. Select the current version of the OPC Server from the hardware catalog at SIMATIC PC Station > User application > OPC Server and drag-and-drop it to the position of the OPC Server.
4. Click "OK" to confirm the replacement of the OPC Server.
5. Save and compile your changes.
6. Select the "OPC Server" object in the rack.
7. Select the menu command Station > Properties.
8. Open the "SNMP" tab.
9. Click the "Export Tags for WinCC" button.
10. Select the Station > Save and Compile menu command.
11. Repeat steps 1 to 5 if using the MS Server in a redundant MS multiple station system.
12. Perform the following actions if the project contains field devices that were configured in SIMATIC PDM:
   - Select the Options > SIMATIC PDM > Settings command in SIMATIC Manager. The "SIMATIC PDM settings" dialog box opens.
   - Select the "Maintenance Station" tab.
   - Enter the file path of the PCS 7 project.
   - Click "OK".

Updating SIMATIC PDM

Install SIMATIC PDM from the Process Control System; SIMATIC PCS 7 DVD. Refer to the PDM Readme.

When you open a project in SIMATIC Manager, the SIMATIC PDM-related project data is updated automatically.
**Note**

**Updating projects with SIMATIC PDM up to SIMATIC PDM V8.0**

During the update, new PLT IDs are assigned to the configured ASSETMON objects. Then, perform the following steps:

- Adapt these PLT IDs to the corresponding ASSETMON block instances.
- Compile the automation systems.
- Create the diagnostics screens again.
- Compile the corresponding operator stations.

**Additional information**

- You can find information on configuration of user diagnostic structures and user diagnostics screens is available in the *Process Control System PCS 7; Operator Station configuration manual.*
- You can find a description of working with the maintenance station in process mode in the manual *Process Control System PCS 7; Operator Station Process Control.*

**8.8.3 How to update the diagnostics settings**

**Introduction**

If you operate a PCS 7 Maintenance Station in your project, various settings must be migrated when upgrading to the current PCS 7 version.

**Requirement**

The OS project editor is running. It is not necessary to make any settings in the OS project editor.

**Note**

**If the project was retrieved**

If the project was retrieved for the software update, additional steps are required when you use a Maintenance Station:

1. Compile the hardware configurations of all automation systems.
2. Compile all automation systems with the option "Update module drivers".
Procedure

1. Select the multiproject in the plant hierarchy.
2. Select the Options > Plant Hierarchy > Settings... menu command. The "Customize Plant Hierarchy" dialog opens.
3. Select the "Migrate diagnostic settings" check box.

Note
This field is grayed out if this action is not required.

4. Click "OK".

Note
If you want to restore the project-specific changes, you have to adapt the automatically created overview screen. After the "Migrate diagnostic settings" function, copy the project-specific changes from the renamed overview screen of the project that is to be updated to the current overview screen.

8.8.4 How to update the diagnostics screens

Updating the diagnostics screens has the following effects:

- Pictures in the AS objects area
  Block icons that represent racks will be repositioned in the picture. You can move the block icons to different positions.

- Pictures in the PC Stations and network objects area
  The block icons will possibly overlap in these pictures. You can move the block icons to different positions.

Requirements

- The OS Project Editor is running. It is not necessary to make any settings in the OS project editor.
- A backup copy of the diagnostics screens with project-specific adaptations has been generated.
- An asset ID has been assigned to each AS and PC station in HW Config.
- Diagnostics settings are updated.
Procedure

1. Select the multiproject (project) in the plant hierarchy.

2. Select the Options > Plant Hierarchy > Create/Update Diagnostics Screens menu command.

   Update the diagnostics screens. You can find information on this in the Process Control System PCS 7; Operator Station Configuration Manual.

   **Note**

   **Software update of a project up to PCS 7 V7.1.4**

   The diagnostics screen for the AS detail view is automatically created new for fault-tolerant automation systems.

   - The previous diagnostics screen is saved with a name extension to the "Graphics" folder of WinCC Explorer.
   - If you want to restore project-specific changes, you have to adapt the automatically created diagnostics screen. After the "Create/update diagnostics screens" function, copy the project-specific changes from the previous diagnostics screen to the current diagnostics screen.

3. Compile the OS of the Maintenance Station.

4. Update the server data of the MS server.

5. Download the MS server.

Additional information

For information on options for accessing maintenance functions, refer to the following documentation:

- You can find an explanation of how to work with the maintenance station in process mode in the Process Control System PCS 7; OS Process Control function manual.

- Configuration manual Process Control System PCS 7; Operator Station

- Function manual Process Control System PCS 7; Maintenance Station
8.9 Additional Options

8.9.1 Overview of additional options

Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>41</td>
<td>Updating the PCS 7 Web Option for OS (Page 103)</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>42</td>
<td>Updating PCS 7 Components that Use SIMATIC Logon Services (Page 103)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>

8.9.2 Updating the PCS 7 Web Option for OS

Requirement

In order to utilize the full functional scope of the PCS 7 Web Option for OS, you may only use blocks from the current PCS 7 library in the PCS 7 project.

Procedure

- You update the OS Web server similar to an OS client.
- The process pictures that will be opened on a Web client must be "published" again.

Additional information

For more information, refer to the Process Control System PCS 7; Web Option for OS Manual.

8.9.3 Updating PCS 7 Components that Use SIMATIC Logon Services

Additional information

- For detailed instructions about the setup, parameter assignment and changes to complete for SIMATIC Logon, refer to the respective components that use SIMATIC Logon.
- Generally valid basic information about SIMATIC Logon is available in the SIMATIC Logon Online Help.
8.10 Work for the OS in SIMATIC Manager

8.10.1 Overview of compiling

Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>43</td>
<td>Specifying the compilation mode (Page 105)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>44</td>
<td>Compiling the OS (Page 105)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

8.10.2 Information regarding the compilation modes

The compilation mode determines which data are downloaded to the OS Server. The setting must be made separately for each project of a multiproject.

Compilation modes

The following modes are available:

<table>
<thead>
<tr>
<th>Mode</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Area-oriented</td>
<td>As of PCS 7 V6.1: Default setting for newly created projects. This setting enables you to assign an OS area of the PH to an OS Server. All data of an OS area are downloaded to the OS Server when this compilation mode is used. This mode can only be set for projects with configured PH.</td>
</tr>
<tr>
<td>AS-oriented</td>
<td>This setting enables you to assign an S7 program to an OS Server, i.e. you define which OS accesses data from which automation system. All data of an automation system are downloaded to the OS Server when this compilation mode is used. This mode is set by default for: Projects created in PCS 7 version previous to V6.1. Projects without configured PH.</td>
</tr>
</tbody>
</table>

Note

If you use a maintenance station in the project, you need to set “area-oriented” compilation mode for the multiproject.

Additional information

- Configuration manual Process Control System PCS 7; Operator Station
8.10.3 How to Specify the Compilation Mode

Requirement

- The Operator Stations in the PCS 7 project have been updated (if necessary) using Project Migrator.

Procedure

1. Open SIMATIC Manager and select any view. Component view, plant view or process object view.
2. Select a PCS 7 project from the tree structure.
3. Select the menu command Options > "Compile Multiple OSs" Wizard > Compilation Mode. The "Compilation Mode" dialog box opens.
4. Select the compilation mode (refer to the introduction of this section above).
5. Click "OK".

The settings for the compilation mode are applied in the "Compile Multiple OSs" wizard.

Note

For the first compilation of the OSs with PCS7 V8.1, a complete compilation with a memory reset is required. This is detected by the system, and is automatically set. It is not possible to change the compilation mode.

Note

These settings are applied to all OS servers in a project.

Additional information

- Configuration manual Process Control System PCS 7; Operator Station

8.10.4 How to Compile the OS

Note

You must compile the OS if you changed the target paths on the ES.
Note

Using the template picture for V7 or V8 block icons

You can use the "@PCS7TypicalsAPLV7.pdl" template picture if the following preconditions are met:

- You do not want to use new functions from PCS 7 V8.1
- You do not want to use the latest block icons from the "@PCS7TypicalsAPLV8.pdl" template picture for updating the picture objects, for example, because the icon sizes have been changed

The "@PCS7TypicalsAPLV8.pdl" file needs to be renamed or deleted in order to use the "Create/Update Block Icons" function and compiling processes of this "@PCS7TypicalsAPLV7.pdl" template picture in subsequent executions. Renamed files must not start with the following characters:

- @PCS7Typicals
- @TemplateAPL

Recommendation:

Always use the same versions of the "@TemplateAPL<Version>.pdl" and "@PCS7TypicalsAPL<Version>.pdl" files for a PCS 7 project.

Overwriting default settings

User scripts and modified properties of the picture objects are overwritten by the default settings.

Requirements

- The PC station has been configured.
- The configuration in CFC and SFC has been completed.

Note

If you have changed unit and operator texts of the block types in the master data library, be sure to set your default language as the "Language for display devices".

Procedure

Note

For more information on compilation options, refer to the Process Control System PCS 7; Engineering System Configuration Manual.

1. Select the object (multiproject, project, station) in SIMATIC Manager that you wish to compile or compile/download.
2. Select the PLC > Compile and download objects command in SIMATIC Manager. The "Compile and download objects" dialog box opens.
3. Open the tree structure.
4. Activate the check box in the "Compile" column for all objects that you want to compile.
5. Click the "Operating State" button and check the operating states of your objects (RUN, activated, etc.) so that you can make the correct settings for compilation.
6. Select the OS that you wish to compile.
7. Click "Edit".
   The "Settings: Compile OS ... Areas ..." dialog box opens.
8. Click "Next".
   The "Settings: Compile OS ... Network Connections ..." dialog box opens.
9. Click "Next".
   The "Settings: Compile OS ... Compilation Data and Scope of Compilation" dialog box opens.
10. In the "Scope" group, activate the "Entire OS" and "With memory reset" check boxes.
11. Click "Apply".

**Note**

Once you have completed your settings for compiling an operator station, please wait until the compilation settings have been saved and the download dialog box appears.

12. Make the required settings for the individual objects.
13. Click "Help" in the dialog box for detailed information about the settings.
14. Click the "Start" button.
    Compilation starts.
15. Follow the instructions on the screen.
16. If you wish to see a log of the compilation once it is complete, click the following buttons in the "Display Log" area:
   - "Single object": The detailed compilation log of the selected OS is displayed.
   - "All": Displays the results of all compilations (without details).

### 8.10.5 Mixed operation and visualization of AS blocks from different PCS 7 versions

#### Definition of Mixed Operation

Mixed operation lets you visualize AS blocks from different PCS 7 versions.
Compatibility of the PCS 7 faceplates

You can use the PCS 7 V8.2 faceplates to control and monitor the APL blocks of the following PCS 7 versions:

- APL blocks from PCS 7 V7.1 SP4
- APL blocks from PCS 7 V8.0 SP2
- APL blocks from PCS 7 V8.1 SP1
- APL blocks from PCS 7 V8.2

8.11 Conversion of standard blocks to APL blocks

Measures for switching the APL

The conversion to the APL blocks requires a new application-specific configuration.

You can find additional information on this in the documentation on the Internet:

Once you have updated your PCS 7 project in offline mode, download the changes to the target systems (AS, OS).

### Note
If using new or updated blocks from the PCS 7 libraries, set the AS to STOP before you download to the target systems.

### Requirement
- The network addresses and network settings of the PC stations are configured.
- The configuration of the PC stations in HW Config and in the Station Configuration Editor match.
- The PC station has been configured.
- The configuration and connection data of all stations has been downloaded via NetPro.

### Procedure
1. Use the search box in the start menu to open "Set PG-PC Station".
2. Check the setting of the access points on each PC station (locally).
3. You can successively download all target systems systematically and automatically. In the SIMATIC Manager, select the menu command **Target system > Compile and Download Objects**.

### Additional information
For more information, refer to the *Process Control System PCS 7; Engineering System* manual.
Activate the operator stations

10.1 Overview of activating the operator stations

Introduction

Sequence for activating process mode (Runtime):
- Process Historian (if available in the project)
- Master server (OS server)
- Standby server (redundant OS server)
- OS clients

Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>46</td>
<td>Checking the settings on the OS servers (Page 111)</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>47</td>
<td>Checking the settings on the OS clients (Page 112)</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

10.2 How to Check the Settings on the OS Servers

Before activating the projects downloaded to the various OS servers, you need to check some of the settings in each OS as a safety precaution.

Requirements

- The PCS 7 OS is open in WinCC Explorer.
- The following applies if a Process Historian is in the project:
  - The Process Historian has the "Active" status.
  - The "PH-Ready Configuration" is performed on each OS server.

Procedure

1. Open the "Redundancy" editor in WinCC Explorer.
2. Check all settings.
3. Click "OK".
4. Open the "Time Synchronization" editor in WinCC Explorer.
5. Check all of the settings in the dialog box.
Activate the operator stations

10.3 How to Check the Settings on the OS Clients

6. Click "OK".

7. Repeat steps 1 through 6 for the second OS Server and all other redundant OS servers.

**Note**
If you have installed a new operating system or have changed the settings, restart the computer.

8. Activate process mode on the OS servers.

**Note**

**Process Historian**

After activating process mode, the OS server automatically connects to the Process Historian.

- For non-redundant systems, the data is sent to Process Historian starting with the activation of the process mode.
- For redundant systems, only data from the current master is sent to the Process Historian.

You can now import data segments created before the software update using Process Data Migrator on the Process Historian.
You can find information on this in the section "How to migrate the archives in the Process Historian (Page 117)".

---

10.3 How to Check the Settings on the OS Clients

**Introduction**

Before activating the projects downloaded to the various OS clients you must check some of the settings in each OS.

**Requirements**

- The PCS 7 OS is open in WinCC Explorer.

**Procedure**

1. Open the "Time Synchronization" editor in WinCC Explorer.
2. Check all settings.
3. Click "OK".
4. Repeat steps 1 through 3 for the other OS clients.
5. Activate process mode on the OS clients.
Updating SIMATIC BATCH stations

Information on updating SIMATIC BATCH is available in the following documentation:

- Manual Process Control System PCS 7; SIMATIC BATCH
- SIMATIC BATCH Readme; Part B, Installation

**Note**

Note the following when updating the software from PCS 7 V7.1 SP4 (with SIMATIC BATCH) to PCS 7 V8.2 (with SIMATIC BATCH):

- No batches should be actively running, because the BATCH database is restored from a backup for the software update.
- To save the project "with reorganization", you first need to manually replace the BATCH application in the PC stations in HW Config.
- Set the BATCH Start Coordinator to "Manual" start mode before you update the software.

It is essential that you observe these points when you prepare the software update. You can find additional information on this in the section "Overview of preparations (Page 30)".
Updating SIMATIC BATCH stations
You can find information about this in the *Process Control System PCS 7; SIMATIC Route Control* documentation.

**Note**

**Library of SIMATIC Route Control V8.2**

You should apply the library of SIMATIC Route Control V8.2 for SIMATIC Route Control V8.2.

The automation system must be in STOP in order to load these libraries.
13.1 Archive migration at a glance

Overview of the procedure

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>ES</th>
<th>OS server</th>
<th>OS client</th>
<th>AS</th>
</tr>
</thead>
<tbody>
<tr>
<td>50</td>
<td>Migrating archive data from the CAS (Page 117)</td>
<td>Only projects in which the central archive server (CAS) has been replaced with a Process Historian.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Reporting system for archive data

The Information Server is the reporting system for the Process Historian. Report templates and automatic logs from archives must be created again.

13.2 How to migrate the archives in the Process Historian

Requirements

- Central archive server as of PCS 7 V7.0 (Storage Plus V1.2)
- The archive data were swapped out with a PCS 7 version (Storage Plus V1.2) >= V7.0.
- The Process Historian is created and configured in the PCS 7 project.
- The Process Historian was started before the OS servers.
- The database of the central archive server is accessible from the Process Historian.
- The OS servers are in process mode. The connection to the Process Historian has been established.
- The current data is archived on the Process Historian.

Archives on OS servers

The last archive segments of the OS servers are no longer swapped out to the CAS by the OS servers. You must import these archives directly from the OS servers in the Process Historian.

Keep in mind that this import must take place in a timely manner depending on the setting of the circular archives of the OS servers.
Recommendation: Start by importing the archive segments of the OS servers that were not swapped out to the CAS.

Procedure

1. On the CAS, configure sharing for access to CAS archives for the Process Historian.
2. Configure a network drive for access to CAS archives on the Process Historian.
3. Start the migration tool. Follow the instructions.
   You can find detailed information on this in the documentation SIMATIC; Process Historian; Process Historian Administration.
4. Select the CAS database of the server.
5. Assign the data to the subproject.
6. Start the migration process.

Note

All CAS databases are migrated in the background during operation.
You must perform the data migration for each OS subproject.

Additional information

You can find detailed information on this in the documentation SIMATIC; Process Historian; Process Historian Administration.
Index

A
Adaptations
  Basic pictures and local reactions of the computer, 89
Archive server
  Adapting Archives, 117
  CAS, 27
  Detaching archive segments, 27
  Autonegotiation, 52

B
Backup, 30
  License Keys and Authorizations, 40
  Block import, 83

C
Central archiving
  Adaptations, 27
Changing the Configuration of Multilingual Texts, 64
Checking and adapting connection data in NetPro, 70
Checking PH consistency, 65
Compiling CFCs, 88
Compiling the OS, 104
Configured mode, 58
Configuring hardware after replacements, 66
Converting CFC/SFC charts, 72
Copying blocks, 77
Copying objects from other libraries, 75
Customizing operator texts, 85

D
Documentation
  Access options, 10
  for planning and configuration, 10
Download, 59
  PC stations, 59
Downloading to target systems, 109

E
Editing the operator texts, 75
Exporting
  Operation and display texts, 35

I
Import
  How to transfer event texts from the block type during block import, 83
Import Runtime Data, 64
Importing operator texts, 84
Installation
  Additional library, 53
  PCS 7, 46
  SIMATIC PDM, 47

L
Language in faceplates and message texts, 73
Library, 21
  Backing up user-created libraries, 34
  Copying objects from other libraries, 75
  Copying objects from other libraries to the master data library, 76
  Installing additional libraries, 53, 54
  PCS 7 Library channel blocks, 53
License key, 22
  Backup, 40
  Licensing with the Automation License Manager, 22

M
Master data library, 76
  Copying blocks, 77
  Updating blocks, 81
Migrating diagnostics settings, 101
Migration
  SIMATIC BATCH, 15
  SIMATIC Route Control, 15
Mixed operation, 107
Modify operating mode, 52
Modify transmission rate, 52
Modules in configured mode and programming device (PG) mode, 58

Software update with utilization of new functions
Service Manual, 03/2016, A5E36200190-AA
Online trend control, 80
  Defining, 80
Operating principle, 103
  PCS 7 Web Option for OS, 103
Operation and display texts
  Exporting, 35
Operator texts or display texts, 35
OS
  Checking the OS Client settings, 112
  Checking the settings on OS servers, 111
  Compilation mode, 104
  Compiling, 105
  Overview of compiling, 104
  Overview of the activation, 111
  Specifying the compilation mode, 105
  Updating with the Project Migrator, 63
  User interface in process mode, 88
OS compilation mode, 104, 105
Overview, 63
  Adaptation on operator stations, 88
  Adaptations in NetPro, 70
  Converting CFCs/SFCs, 70
  General adaptations in the project, 63
  Software update procedure, 23
  Software update procedures, 23
  Updating the blocks, 72
Overview of activating the operator stations, 111
Overview of block updating, 72
Overview of Installation and Settings on the ES and OS, 45
Passivation reaction, 21
Password protection, 63
PC station, 59
  Configuring, 59
  Downloading, 59
PCS 7 Library channel blocks, 53
Planning and preparation, 41
Preparations for the software update, 30
Preparing the PC station, 45
Process Historian
  Adapting Archives, 117
Programming device operation, 58
Project Migrator
  Password protection, 63
Redundancy, 21
Requirements, 17
Runtime data, 64
Selecting the correct documentation, 15
SIMATIC BATCH, 15
  Migration, 15
Software update procedure, 23
Software update procedures, 23
StoragePlus
  Detaching archive segments, 27
  Overview of Adaptations, 27
Template picture
  Updating picture objects, 91
Transferring event texts from the block type, 83
BATCH, 113
OS with Project Migrator, 63
PCS 7, 15
PCS 7 project, 63
Picture objects, 91
SIMATIC BATCH, 15
SIMATIC Route Control, 15
Using PCS 7 Components that use the SIMATIC Logon services, 103
Updating block types in the project, 85
Updating PCS 7, 46
Updating SFC block types in the project, 87
User interface in process mode, 88
Web Option for OS, 103