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This document is an entry from Siemens Industry Online Support. The following
Terms of Use apply (www.siemens.com/Terms_of_use).

Security
informa-

tion

Siemens provides products and solutions with industrial security functions that
support the secure operation of plants, solutions, machines, equipment and/or
networks. They are important components in a holistic industrial security
concept. With this in mind, Siemens’ products and solutions undergo continuous
development. Siemens recommends strongly that you regularly check for
product updates.

For the secure operation of Siemens products and solutions, it is necessary to
take suitable preventive action (e.g. cell protection concept) and integrate each
component into a holistic, state-of-the-art industrial security concept. Third-party
products that may be in use should also be considered. For more information
about industrial security, visit http://www.siemens.com/industrialsecurity.

To stay informed about product updates as they occur, sign up for a product-
specific newsletter. For more information, visit
https://support.industry.siemens.com.
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1 Task
In this FAQ you will find out how to configure the IDB in a way so that process
values from WinCC Runtime Professional tags (TIA Portal) are automatically
transferred and recorded at runtime.

This FAQ introduces a solution of the task in the English language environment.
Other language settings in the software are currently not tested in connection with
WinCC Runtime Professional (TIA Portal).

1.1 Function of the IndustrialDataBridge

The SIMATIC HMI WinCC option IndustrialDataBridge (IDB) makes a data
exchange between different automation systems and IT systems possible.
The software consists of a configuration and a runtime environment (Runtime). The
different standard data interfaces (see Figure 1-1) are integrated via software
modules. One module each is required as data source and one module as data
destination. Any combination of the different modules is possible.
This modular structure makes it possible to expand the data exchange any time to
other data interfaces. The software design makes it also possible to integrate new
interfaces into the application.

Figure 1-1  Interfaces of the IDB

The connections between data source and data destination are configured in the
"IndustrialDataBridge CS" configuration environment.
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In the "IndustrialDataBridge RT" runtime environment the IndustrialDataBridge
independently creates the specified connections and transfers the data of the
linked tags. There are options available for commissioning, status monitoring and
error analysis.

1.2 Description of the automation task

Figure 1-2 displays the interaction of
 Runtime Professional as a data source (provider) (1),
 a data destination (consumer) (2) - e. g. a database -
 and IDB Runtime (5) as coupling that enables the data exchange.

The interfaces (3) (4) are configured before the start of the IndustrialDataBridge
Runtime (IDB RT) (5) in the configuration environment of the IndustrialDataBridge
(IDB CS) (6).
In order to be able to configure the interface between SIMATIC WinCC Runtime
Professional (TIA Portal) and the IndustrialDataBridge data is required which you
read out with the help of the export tool (8). The export tool is included in the
installation package of the IndustrialDataBridge.

 Figure 1-2
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A more detailed explanation of the individual elements and the required settings
can be found in chapter 3.

1.3 Contents of the FAQ and topics not covered in this
application

Based on an example configuration, this FAQ shows how you have to configure the
IDB in general and what further steps are required in order to transfer the data from
der Runtime Professional via the IDB Runtime.
The FAQ does not deal with the individual settings and connection options of the
IndustrialDataBridge.
For a more detailed explanation of the functionality of the IDB, please refer to the
documentation of the IndustrialDataBridge.
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You can find information in the following entries or on the website for this document
(Entry ID: 109476988) in “Additional Information”.
 Getting Started SIMATIC HMI WinCC V7.2 WinCC/IndustrialDataBridge

Entry ID: 73968329
 Manual SIMATIC HMI WinCC V7.2 WinCC/IndustrialDataBridge

Entry ID: 73968374

In the example configuration the following interface modules are used: “WinCC
OLE DB” as provider and a CSV file as consumer.

Figure 1-3 IDB interfaces used in the example configuration of the IDB

https://support.industry.siemens.com/cs/ww/en/view/109476988
https://support.industry.siemens.com/cs/ww/en/view/73968329
https://support.industry.siemens.com/cs/ww/en/view/73968374
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2 Requirements
Required software
the following software has to be installed:

 SIMATIC WinCC Runtime Professional (TIA Portal) V13 SP1 or later1

on the Runtime PC (operator station)
 SIMATIC WinCC Option IndustrialDataBridge V7.32

Install the IndustrialDataBridge in English on the Runtime PC (operator
station).

Requirements for the IndustrialDataBridge
 Set the language settings of the IndustrialDataBridge CS to “English” before

generating the IndustrialDataBridge Runtime project file.
For this purpose click “Options > Settings”. In the new window in “General >
General settings” click “Interface language:” and select “English”.

 Set the language settings of the IndustrialDataBridge RT to “English” before
generating the IndustrialDataBridge Runtime project file.
For this purpose click “Options > Language > English”.

Windows requirements
 Set the language settings of the PC on which IDB Runtime and WinCC TIA

Portal Runtime Professional is to run (operator station) to English.
Set the language of the engineering PC on which the WinCC TIA Portal
Runtime Professional project file is to be created to English.
To change the language click “Start > Control Panel > Regional and Language”
Change the “Formats > Format:” and “Keyboards and Languages > Display
language”.

 Make sure that the “IndustrialDataBridge” service is running. You can check
the status of the service under “Control Panel > Administrative Tools >
Services”.
You may need the respective rights to continue.
If the service is not started, right click on “IndustrialDataBridge” and select
“start” to start the service. If you wish, set the start type to “automatic”, so that
the service is started when the operating system is started.

 See second item in “System requirements in WinCC Professional (TIA Portal)
project”

Requirements in WinCC Professional (TIA Portal) project
 Generate the WinCC Runtime Professional project file. Set the language

setting of your TIA Portal to “English” before generating the Runtime
Professional project file.
For this purpose click “Options > Settings”. In the new window in “General >
General settings” click “Interface language:” and select “English”.
Further information on generating and transferring the WinCC Runtime
Professional project file can be found in the following entries:

1 In the rest of the document sometimes shortened to “Runtime Professional”.
2 In the rest of the document sometimes shortened to “IDB”.
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– Help for creating the Runtime project file: “Downloading the project to a file
system” (Manual WinCC Professional V13 SP1)

– Loading WinCC Runtime Professional onto an operator station (Entry ID:
88780011)

 If you select “WinCC OLE DB” as data source, create at least one tag archive
and assign the respective tags.
Make sure that name of the Runtime PC (operator station) (1) matches the
name of the PC station of the WinCC Professional (TIA Portal) project (2) (see
Figure 2-1).

Figure 2-1

Right-click the name of your WinCC project (2) in order to change the name.
Click “Rename" in the context menu and adjust the name.
Alternatively, you can change the name of the Runtime PC (operator station)
(1) to the name of the WinCC Professional (TIA Portal) project (2).
To do this, click “Start > Control Panel > System” and in the “Computer name,
domain and workgroup settings” on “Change settings”. Click on “Computer
name > Change…” and rename the Runtime PC.

1

2

https://support.industry.siemens.com/cs/ww/en/view/109096785/68770080395
https://support.industry.siemens.com/cs/ww/en/view/109096785/68770080395
https://support.industry.siemens.com/cs/ww/en/view/88780011
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3 Solution
The solution is divided in two sections.
In chapter 3.1 you find out what steps are required for the configuration of the
IndustrialDataBridge from the reading out of the connection data of the Runtime
Professional right up to generating the IDB Runtime project file.
In chapter 3.2 you find out what settings are required to enable the communication
between the Runtime Professional and the IndustrialDataBridge.

3.1 Configuring the IndustrialDataBridge

As mentioned in chapter 2.1, the IDB is configured with the help of a XML file.
Below, you will find out how to create this XML file.

3.1.1 Creating the WinCC-project based XML file

Figure 3-1
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In the table below, the required steps are shown in the area marked in orange.
The project-specific data of the WinCC Professional TIA Portal Runtime project is
transferred to a XML file which is used later on (see Table 3-3 item 4).
Table 3-1

Item Procedure

1. Start your WinCC Runtime Professional project.
(For help see “Starting Runtime Professional” in the WinCC Professional V13
SP1 manual.)

https://support.industry.siemens.com/cs/ww/en/view/109096785/68852194699


3 Solution

Datenübertragung von WinCC RT Professional über IDB
Entry ID: 109476988,    V1.0,    06/2015 9

S
ie

m
en

s
A

G
20

15
A

ll
rig

ht
s

re
se

rv
ed

Item Procedure

2. For the following step the SIMATIC WinCC Option IndustrialDataBridge V7.3 has
to be installed.
Open the “ccnsinfo2xml.exe” tool using the following path:
“Local data carrier (C:) > Programs > Siemens > Automation >
IndustrialDataBridge > Bin > WinCC”.

If you have not selected the default path for the installation, search the
installation location of the IndustrialDataBridge according to your installation path
and click the subdirectories “Bin > WinCC” the same way.
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Item Procedure

3. Select a storage path and a name for the XML file.

Click “Export”.

3.1.2 Configuration settings in the IDB CS

Figure 3-2
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In the table below, the required steps are shown in the area marked in orange.
The interfaces of the data source (provider) of the IDB and of the IDB to the data
destination (consumer) are configured consecutively.
In the example “WinCC OLE DB” is set as provider and a CSV file as consumer.
The setting options of other interfaces can be found in the IDB help or the IDB
documentation in “Module”.

https://support.industry.siemens.com/cs/mdm/73968374?c=46399713931&dl=de&lc=en-WW
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Creating a new project
Table 3-2

Item Procedure

1. Start the IDB via the “IndustrialDataBridge CS” (start menu or desktop) shortcut
or via the “Siemens.Automation.Portal.exe” file in the path where the beginning is
the same as in Table 3-1, item 2: “Local data carrier (C:) > Programs > Siemens
> Automation > IndustrialDataBridge > Bin”.

2. Click on “Project > new project” and assign a storage path and a name for the
new IDB project.

3. Then click “Create”.
4. Click “Configuration > Add new link”.
5. Give the link a name.
6. Select “WinCC OLE DB” as provider from the drop-down list.
7. Select your desired data storage as consumer, in this case “CSV/TXT” from the

drop-down list.

Configuring the provider
Table 3-3

Item Procedure

1. Configure the provider. Double-click “Provider(WinCC OLE DB)” and click the “...”
button in “WinCC project XML export file”.

2. Select the XML file from Table 3-1, item 3, under the path which you have
assigned to the same item.

3. Then click “Open”.
4. Select the WinCC station name in “Archive configuration” and check the stored

project name.
The “Use Single Point of System Access (connectivity station)” setting remains
disabled.
The entry in “WinCC station name:” has to match the computer name of the
Runtime PC (operator station) (see Requirements > Requirements in WinCC
Professional (TIA Portal) project”, item 2.
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Configuring the consumer
Table 3-4

Item Procedure

1. Configure the consumer according to your wishes.
Enter the storage path of the CSV file for a CSV file as consumer in the
“CSV/TXT” input field. Create the actual CSV file later.
With one click on the “Test" button it is checked whether the specified path is
valid.

Settings – Transfer options
Table 3-5

Item Procedure

1. Afterwards it has to be set from which archive tags the set tag properties are to be
transferred.
Click on the “Transfer options” tab.

2. Select the “Process Value Archive” entry in the “Archive settings” from drop-down
list.

3. Click the “Process value” button.
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Item Procedure

4. Select the desired archive in a new window from the “Archive:” drop-down menu.
The tag properties of the tags on the right of the display area, are later transferred
via IDB Runtime from the provider to the consumer.
Use the buttons between the two display areas in order to fill the right display area
with the desired tags. You can combine tags from several archives.

5. Then click on “OK”.
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Item Procedure

6. Set the values as desired at “Time settings”. Depending on the transfer behavior,
other settings such as the assignment of the trigger or the setting of the startup
behavior will be necessary.
For a continuous transfer without start trigger select the “Cyclic & continuously”
option.

Click on “Start-up behavior”.
Select “Transfer current archives values”.
Then click on “OK”.
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Settings – Connection mapping
Table 3-6

Item Procedure

1. Open the “Settings” and select the “Connection mapping” (1) tab.
The window is split in three main areas:

(2) Splitting the provider
(3) Splitting the consumer
(4) Connection mapping

Area (2) and (3): Here you can assign the data of the provider and the consumer
each a name and a data type by column. Depending on the provider or
consumer, different data types can be available.
Area (4): Here you can view and edit the created connections between provider
and consumer.
Creating a new connection is explained in item 6 .

2. In order to create a new CSV file to record the transferred archive values, click
the “New CSV file” button in the consumer area (3).
Note:
If the “Connection could not be established” error message appears, test and
correct the path specification that has been set in Table 3-4.

2

3

4

1
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Item Procedure

3. Assign names for the tag properties that are to be transferred and saved in the
file specified as consumer, for example “Name” and “Value”.
To do this, enter the name of the tag properties in the “Column name” input field
and click “Add”. Repeat this step for all tag properties.

You can change the sequence of the tag properties by selecting a tag property
and clicking “Up” or “Down”. This shifts the tag properties either higher or lower.

4. Assign a name for the file in “Filename:”.
5. Click on “Create”.
6. Create a connection between the tag properties that can be transferred by the

provider and the tag properties that are recorded by the consumer.

a. Click one of the column names in the area of the consumer (3). Select a
suitable data type via the “Data type:” drop-down list. Depending on
what consumer is set, the data type selection may be restricted. For
example, a CSV file as consumer allows only strings as data type.  If
possible, the data type is automatically adjusted accordingly.

b. Then click the column name or the data type in the area of the provider
(2) that corresponds with the selected column name of the consumer.

On the example of the CSV consumer file:
Consumer column name “Name” of the “System.String” type  provider
column name “ValueName” of the “OLE/Binary Automation string” type;
Consumer column name “Value” of the “System.String” type  provider
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Item Procedure
column name “RealValue” of the “8-byte real” type.
You can change the specified data type of the column name of the provider
via the selection in the “Data type:” drop-down list.

c. Enter the name that is to be used for the name of the connection in the
“Connection mapping settings” (4) area. You can assign or select a
separate name or select one of the “Default name options”. To do this,
tick “Enable default name”.

Click the left one of the four icon buttons.

The settings are applied and the new connection is displayed in the
“Connections” list.
d. Repeat steps a. to c. according to the number of the column names of

the consumer.

e. With the help of the remaining three icon buttons you can edit an existing
connection from the “Connections” list and delete individual or all
connections.
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Generating Runtime configuration file

Item Procedure

1. Click “Project > Generate Runtime Configuration”.

2. Then click “Save”.
3. Select the name and the path for the configuration file that is later assigned to

IDB Runtime.

Thus the configuration of Runtime is completed.
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3.2 Start and continuous operation of IndustrialDataBridge
Runtime (IDB RT)

Below, you will find out how to start IDB Runtime and what requirements have to
be fulfilled for the continuous transmission of data.

3.2.1 Start of IDB RT

Figure 3-3
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In the table below, the required steps are shown in the area marked in orange.

Table 3-7

Item Procedure

1. Start the “IndustrialDataBridge RT” via the “IndustrialDataBridge RT” shortcut
(start menu or desktop) or via the “idb_v7_rt.exe” file in the path where the
beginning is the same as in Table 3-2, item 1: “Local data carrier (C:) > Programs
> Siemens > Automation > IndustrialDataBridge > Bin”.

Note:
If the “Could not establish connection to IndustrialDataBridge Runtime.” error
message appears, the “IndustrialDataBridge” service will not run. (See chapter 2
“Requirements > Requirements in Windows”). Close the message by clicking
“OK” and start the service.
The “IDB connection status” indicator lamp in the lower bottom corner of
Runtime is green when the service is running.

2. Click on “File > Open”.
3. Select the XML file that was generated in Table 3-6, item 2.
4. If required, configure the Runtime options, for example “Startup option” or

“Password”.
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Item Procedure

5. To start the data transmission, click on “Connect”.
Click on “Start” when it says “CONNECTED”, each time, in the “Status view” at
“Provider” and “Consumer” and the indicator light is green in front of the
connection status.

In the “Trace view” window you can read all messages of the IDB RT in
chronological order.
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3.2.2 Continuous operation of the IDB RT

For the data to be transferred from the WinCC Runtime Professional (as provider)
to the consumer, WinCC Runtime Professional, as well as IDB Runtime have to be
active.

IndustrialDataBridge Runtime can transfer data from several configured
connections simultaneously. The status of the individual connections can be easily
detected in the status view.
Connections can be connected/separated independent from each other and
started/stopped.

Figure 3-4
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