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Preface 1
Purpose of this Documentation            

This documentation shows you how you can configure your plant optimally with the PCS 7 
process control system. The individual configuration steps can be seen based on examples. 
You will learn among other things the following: 
● How to structure the process control configuration of a plant technologically and through 

various phases 
● How to use the different views (component view, plant view, process object view) 
● Which phases you work through during configuration 
● How to structure plants 
● How to create process tag types and models 
The following topics are dealt with in detail in this documentation; they are not addressed in 
any other manuals: 
● Configuring a process control system 
● Working with the plant hierarchy (PH) and the process object view (POV) 
● Working with the import / export assistant (IEA) 
This documentation is located on the DVD SIMATIC PCS 7; Manual Collection in electronic 
data form. You can use Adobe Reader to read the documentation and print it out as 
necessary. 
Opening on the PCS 7 computer: 
● The electronic manual (PDF) is called up via Start > SIMATIC > Documentation > 

English > PCS 7  - Configuration Manual Engineering System. 
● The manual is started from within the online help (CHM) with the menu command Start > 

SIMATIC > Documentation > English > PCS 7 - Basic Documentation > Configuration - 
Engineering System or directly from the SIMATIC Manager via Help > Help Topics > 
Configuration - Engineering System. 

The contents of the electronic manuals are largely identical to those in the online help. There 
may be small discrepancies between the online help and the manuals based on the copy 
deadlines which are required for technical reasons. If there are discrepancies, the 
information in the online help can be considered more up-to-date. 
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Getting Started Part 1 and Part 2 
Getting Started PCS 7 - Part 1 is aimed at PCS 7 novices. It provides you with an initial 
overview of the PCS 7 process control system, enabling you to create a simple project 
yourself. The project is configured on an existing SIMATIC Station.  
PCS 7 Getting Started – Part 2 is intended for users who have already worked through 
Getting Started – Part 1. It introduces you to functions of PCS 7 that you can use for fast and 
effective plant configuration. These functions are used especially for the configuration of 
large complex plants.  
Both Getting Started Parts introduce the functions using the standard example project 
"COLOR". At the same time they show the correct configuration sequence.  
The Getting Started Parts can be located with the menu command Start > SIMATIC > 
Documentation > German> .... 

Required Basic Knowledge 
This documentation is intended for personnel working in the fields of configuration, 
commissioning, and service. 
Basic experience of working with the PC/programming device and working with Windows are 
assumed.  

Validity of the Documentation 
This documentation is valid for the Process Control System; PCS 7 Toolset software 
package, V7.1 or higher. 

Readme File 
Current higher-level information can be read in the readme file:  
● The readme file can be found on the DVD Process Control System; PCS 7 Toolset. 
● You can also open the readme file after installing PCS 7 with the menu command Start > 

SIMATIC > Product Notes > English > PCS 7 - Readme. 

Conventions 
In this documentation the designations of elements of the user interface are specified in the 
language of this documentation. If you have installed a multi-language package for the 
operating system, some of the designations will be displayed in the base language of the 
operating system after a language switch and will, therefore, differ from the designations 
used in the documentation. 
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Changes Compared with the Previous Version  
In the following you will find an overview of the most important changes: 
● Displaying license information 

You will find additional information on this topic in Section "PCS 7 license information 
(Page 501) ". 
The following information is covered: 
– CFC process objects 
– Routes for the Route Control station 
– Process objects for the SIMATIC station 
– Process objects for the operator station 
– Process objects for the central archive server 
– Asset tags (hardware components) for the maintenance station 
– Units for the BATCH station 

● Forcing 
You can pre-assign fixed values to the individual tags of a user program to prevent them 
from being changed or overwritten even by the user program itself, which runs on the 
CPU. You will find additional information on this topic in Section "How to use the 
"Forcing" function for block I/Os (Page 492)". 

● Expansion of the process object view and the CFC Editor (online mode) 
You will find additional information on these topics in Sections "How to Edit Parameters 
(Page 589)", "How to Edit Signals (Page 593)", and How to use the "Forcing" function for 
block I/Os (Page 492). 
– Forcing enable 
– Filtering according to values with forcing capability 
– Additional message when safety-related values are switched to forcing mode 

● Access protection for charts 
You will find more information on this topic in the section "How Can the Plant be 
Protected Against Unauthorized Access? (Page 50)". 

● Versioning charts 
You will find more information on this topic in the section "Overview of the Programming 
Steps (Page 457)". 

● AS-wide interconnections 
With the CFC Editor, you can set up interconnections to partners located on other 
automation systems.  
You will find additional information on this topic in Section "Setting up AS-wide 
interconnections (Page 476)". 
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Guide 
This documentation gives you an insight into the key functions of PCS 7. You can also use 
this documentation for reference and check the particular information that you require.  
The configuration steps are described in a sequence that can be used for practical and fast 
configuration. The manual provides important background information and interrelationships 
for all of the configuration steps in order to clarify their significance and context in the overall 
system.  
All work instructions utilize paths that can be accessed via the menu commands of the menu 
bar. For many of the functions you also have the option of using commands in the shortcut 
menu for the individual objects. 

PCS 7 Glossary 
You will find a PCS 7 glossary containing definitions of important technical terms used in this 
documentation on the DVD SIMATIC PCS 7; Manual Collection or in the PCS 7 software via 
the SIMATIC Manager Help menu (menu command Help > Contents > "Glossary" button). 
 



 Preface 
  

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 19 

Further Support 
If you have any technical questions, please get in touch with your Siemens representative or 
responsible agent. 
You will find your contact person at:  
http://www.siemens.com/automation/partner 
You will find a guide to the technical documentation offered for the individual 
SIMATIC Products and Systems at: 
http://www.siemens.com/simatic-tech-doku-portal 
The online catalog and order system is found under: 
http://mall.automation.siemens.com/ 

Training Centers 
Siemens offers a number of training courses to familiarize you with the Process Control 
System SIMATIC PCS 7. Please contact your regional training center or our central training 
center in D 90327 Nuremberg, Germany for details:  
Telephone:   +49 (911) 895-3200 *) 
Internet:  http://www.sitrain.com 

http://www.siemens.com/automation/partner
http://www.siemens.com/simatic-tech-doku-portal
http://mall.automation.siemens.com/
http://www.sitrain.com/
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Technical Support 
You can reach the Technical Support for all Industry Automation and Drive Technology 
products 
● Via the Web formula for the Support Request 

http://www.siemens.com/automation/support-request 
● Phone:  + 49 180 5050 222 *) 
● Fax: + 49 180 5050 223 *) 
Additional information about our Technical Support can be found on the Internet pages 
http://www.siemens.com/automation/service 

Service & Support on the Internet 
In addition to our documentation, we offer our Know-how online on the internet at: 
http://www.siemens.com/automation/service&support 
where you will find the following: 
● The newsletter, which constantly provides you with up-to-date information on your 

products. 
● The right documents via our Search function in Service & Support. 
● A forum, where users and experts from all over the world exchange their experiences. 
● Your local representative for Industry Automation and Drive Technology. 
● Information on field service, repairs, spare parts and consulting. 

 
*) Please note the following if you call the phone number listed: You may incur costs which 
vary from the standard costs for land lines. Calls from a cellular network may be more 
expensive. 

http://www.siemens.com/automation/support-request
http://www.siemens.com/automation/service
http://www.siemens.com/automation/service&support
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Using the PCS 7 Documentation 2
2.1 Using the PCS 7 documentation 

2.1.1 Options for Accessing Documentation 

Documentation for Your Support       
This section provides a global overview of the PCS 7 documentation that is available in 
addition to this manual. We distinguish between the following types of documentation: 
● PCS 7 system documentation 

This includes configuration manuals and Getting Started tutorials across the complete 
system and explaining the interaction between the individual hardware and software 
components. 

● PCS 7 product documentation 
This contains documentation for special hardware and software components providing 
detailed information about this product. 

Access Options 
You have the following options for accessing the PCS 7 documentation: 
● On a PCS 7 computer, via the Help menu in applications 
● On a PCS 7 computer, via the Start menu in Windows 
● in the Internet 

– from Customer Support 
– Technical documentation 

● On the DVD SIMATIC PCS 7; Manual Collection 

On a PCS 7 computer via the Help menu in applications 
Within the PCS 7 software, you can access the online help through the Help menus of the 
individual applications. 
In the SIMATIC Manager you can furthermore access the following documentation: 
● PCS 7 system documentation via the menu command Help > Contents 
● Getting Started PCS 7 - Part 1 via the menu command Help > Getting Started 
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On a PCS 7 computer via the Start menu in Windows 
All manuals (PDF) and readme files (WRI) for installed applications can be opened and 
printed from the Windows Start menu: 
● Manuals via the menu command Start > SIMATIC > Documentation 
● Readme, What's new in the menu command Start > Simatic > Product Information 

In the Internet via Customer Support (ProdIS information system) 
You can download manuals and product information without charge from the Siemens 
Customer Support Internet site. The PCS 7 documentation is located in the following folders: 
● System documentation in the path 

(http://www.siemens.com/automation/service&support)  
● Product documentation in the "Manuals" tab in the folders of the individual products 

In the Internet at  
The PCS 7 site provides convenient access to the complete PCS 7 documentation - the 
latest news about hardware and software components released for PCS 7: 
Call via Internet (http://www.siemens.com/simatic-pcs7): > [Technical documentation Vx.y] 

On the DVD SIMATIC PCS 7; Manual Collection  
Apart from the Internet, the entire PCS 7 documentation is also available in a 3-language 
Manual Collection (German, English, French) with convenient navigation and text search 
functions. The Manual Collection is part of the Process Control System; PCS 7 Toolset 
software package and can be copied from the DVD to your PCS 7 computer. 

In the following 
Since the full documentation of PCS 7 is extremely wide-ranging, you will find a guideline in 
the following sections that will help you to find the information you require during various 
phases: 
● Documentation for the Planning Phase (Page 23)  
● Documentation for the Realization Phase (Page 25)  
● Documentation on commissioning, operation, diagnostics and servicing (Page 30)  

http://www.siemens.com/automation/service&support
http://www.siemens.com/simatic-pcs7
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2.1.2 Documentation for the Planning Phase 

Overview of the documentation for the planning phase      
You can find the following in the PCS 7 documentation table below: 
● Documentation providing an overview of the systems and components for PCS 7 
● Documentation providing support for planning your PCS 7 plant 

 
Documentation Content 
Information about the range of services 
Catalog ST PCS 7 Ordering information and prices for all hardware and software components you may 

require for automating a PCS 7 plant 
Catalog ST PCS 7.1 Ordering information and prices for SIMATIC PCS 7 add-ons that can be integrated in 

your PCS 7 plant to create a total solution 
Interactive catalog CA 01 Catalog ST PCS 7 in electronic form 
PCS 7 brochures An introduction to the principles of communication and range of features in SIMATIC 

PCS 7; shows the technical possibilities and the suitable features for fulfilling your 
automation requirements. 

Getting Started PCS 7 - First 
Steps 

Uses a simple example project to show you the fundamental procedures and the 
interaction of the software components of SIMATIC PCS 7 during engineering and 
runtime. 
Time required for tutorial: approx. 1 hour 

Specifying the components and the systems for the PCS 7 plant 
Configuration manual PCS 7 
Engineering System 

Section "Engineering System": 
• Capacity options in configuring a PCS 7 plant 
• Selecting the network components 
• Selecting PC components for engineering and operator control and monitoring 
• Selecting AS components 
• Selecting I/O components 
• Preparations for efficient engineering 

Manual PCS 7 
PC Configuration and 
Authorization 

Comprehensive overview of PC configurations for engineering and operator control and 
monitoring:  
• Areas of application for the various PC configurations 
• Design and configuration of the PC networks 
• Required hardware and software for the PC components 
• Required authorizations and licenses 
• Installation instructions and settings for the operating system 
• Installation instructions and settings for PCS 7 
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Documentation Content 
Whitepaper Security concept 
PCS 7 and WinCC 

Guide for network administrators for planning and installation of securely networked 
PCS 7 plants with connected WebNavigator clients, SIMATIC IT applications and 
customer-specific office networks: 
• Planning security cells and access points 
• Managing computers and users 
• Managing user permissions and access rights in PCS 7 and integration in the 

Windows management 
• Implementing patch management 
• Secure network access to security cells 

List PCS 7 - Enabled modules List of modules released for PCS 7 versions 
Function Manual PCS 7 time 
synchronization 

Support for planning time synchronization in a PCS 7 plant 
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2.1.3 Documentation for the Realization Phase 

Overview of the documentation for the realization phase      
You can find the following in the PCS 7 documentation table below: 
● Documentation providing support for installing the PCS 7 software 
● Documentation providing support for configuring the wiring of the hardware 
● Documentation explaining the basic concept of engineering with PCS 7 
● Documentation which helps you to fully configure your PCS 7 plant 

 
Documentation Content 
Installation 
PCS 7 readme Latest information with information about installation and using PCS 7 software 
PCS 7 What's new? Compact summary of the new or changed features in PCS 7 in comparison to previous 

versions 
Manual PCS 7 
PC Configuration and 
Authorizations 

Comprehensive overview of PC configurations for engineering and operator control and 
monitoring:  
• Which PC configuration can be used for specific purposes? 
• How can the PC network be designed and configured? 
• Which software and hardware are needed for specific PC components? 
• Which authorizations and licenses are required for the individual products? 
• Installation instructions and settings for the operating system and PCS 7 software 

Whitepaper Security Concept 
PCS 7 and WinCC 

Guide for network administrators for planning and installation of securely networked 
PCS 7 plants with connected WebNavigator clients, SIMATIC IT applications and 
customer-specific office networks: 
• Planning security cells and access points 
• Managing computers and users 
• Managing user permissions and access rights in PCS 7 and integration in the 

Windows management 
• Implementing patch management 
• Secure network access to security cells 



Using the PCS 7 Documentation  
2.1 Using the PCS 7 documentation 

 Engineering System (V7.1) 
26 Configuration Manual, 03/2009, A5E02122455-01 

Documentation Content 
Assembling components and systems  
Configuration manual PCS 7 
Engineering System 

In the section "Configuration of PCS 7 Plants": 
• Basic configurations of a PCS 7 plant 
• Guide to the Installation Instructions for the Products 
• Special considerations, differences between PCS 7 and specifications in the product 

installation instructionsauanleitungen der Produkte 
• Rules for plant changes in runtime (CiR) 
• Installation Guidelines for PCS 7: EMC and lightning protection 

Function manual Time 
synchronization 

Instructions for configuration and parameter assignment of time synchronization 

Manuals for the automation 
system S7-400H/FH 

• Instructions for configuring automation systems 
• Memory concept and startup scenarios 
• Cycle and reaction times of the S7-400 
• Technical specifications 
• Operation lists 

Manuals for S7-300 I/O 
Modules 

• Manual for hardware configuration and parameter assignment of components 
• Technical specifications 

Manuals for CPs and FMs 
(S7-400, S7-300) 

• Manual for hardware configuration and parameter assignment of components 
• Technical specifications 

Manuals for ET 200 
components ET 200M, 
ET 200S, ET 200iSP and 
ET 200pro 

• Manual for hardware configuration and parameter assignment of components 
• Technical specifications 

Manuals for additional DP 
components: Diagnostic 
repeater, DP/PA link/Y link, 
DP/AS-i link, DB/EIB link, 
DP/FF link 

• Manual for hardware configuration and parameter assignment of components 
• Technical specifications 

Manuals for Industrial Ethernet 
and PROFIBUS networks 

• Topologies and Network Configuration 
• Configuration of the communication 

Manuals for SIMATIC NET 
components: CPs for Industrial 
Ethernet and PROFIBUS, 
SCALANCE X, OSM/ESM ... 

• Topologies and Network Configuration 
• Installation instructions 
• Technical specifications 
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Documentation Content 
Engineering 
Getting Started  
PCS 7 - Part 1 

Introduction to the basic functions of PCS 7 based on the PCS 7 example project 
"COLOR". It contains the most important background information required to understand 
the individual engineering tasks and detailed instructions for step-by-step retro-
engineering. On completion of configuration, the OS can be put into process mode. 
We recommend working through this Getting Started tutorial before beginning work with 
the PCS 7 Engineering System configuration manual.  
Time required for tutorial: approx. 16 hours 

Getting Started  
PCS 7 - Part 2 

Introduction to using the Efficient Engineering functions in PCS 7. The basis for this is 
the PCS 7 "COLOR" project in  
Getting Started PCS 7 - Part 1.  
We recommend working through this Getting Started tutorial if you plan to configure a 
large PCS 7 plant with numerous process tags. 
Time required for tutorial: approx. 16 hours 

PCS 7 Manual 
Software Update Without 
Utilization of New Functions  
(PCS 7 V6.x or higher to V7.1) 

Step-by step instructions for converting your PCS 7 project from PCS 7 V6.x to V7.1 
without using the new functions of PCS 7 V7.1 subsequently. 

PCS 7 Manual 
Software Update With 
Utilization of New Functions 
(PCS 7 V6.x to V7.1) 

Step-by-step instructions for converting your PCS 7 project from PCS 7 V6.x to V7.1 for 
using the new functions of PCS 7 V7.1 subsequently. 

Configuration manual PCS 7 
Engineering System 

Sections for configuring the engineering system: 
• Basic concepts of engineering 
• Configuration of the engineering system 
• Implementing the PCS 7 configuration 
• Compiling, downloading, testing, archiving and documenting project data 

Configuration manual PCS 7 
Operator Station 

Complete information about configuring the operator station and the HMI system of 
PCS 7: 
• Configuring OS data 
• Creating process pictures 
• Settings in the alarm system 
• Options for archiving 
• Downloading a project and configuration changes 
• Time synchronization and lifebeat monitoring 
• Using server-server communication 
• Using diagnostic functions (maintenance station) 

Manual PCS 7  
OS Web Option 

• Using the WebNavigator client 
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Documentation Content 
Manual PCS 7 
Integration of MES Functions 
into PCS 7 with SIMATIC IT 

Information for a better understanding of the integration MES functions in PCS 7 with 
SIMATIC IT: 
• Basics of SIMATIC IT and PCS 7 
• Implementing the ISS-95/ISS-88 standards 
• Integration of SIMATIC IT Historian and SIMATIC BATCH 
• Data management in SIMATIC IT and PCS 7 
• Functionality and data communication and data flow 
• Configuration procedure based on an example project 

Manual PCS 7  
SIMATIC BATCH 

Complete information about configuring the BATCH station, the system for automating 
batch processes: 
• Technological basis according to ISA-88.01 
• Configuring batch plant data 
• Creating recipes 
• Planning and controlling batches 
• Managing and archiving batch data 

Manual PCS 7  
SIMATIC Route Control 

Complete information about configuring the Route Control station, the system for 
controlling routes: 
• Creating the program for route control 
• Functions of the block library 
• Configuring materials and transport routes 

Function manual PCS 7 Fault-
tolerant Process Control 
Systems 

Description of the solution concepts, function mechanisms and most important 
configurations for installing fault-tolerant systems with PCS 7. It will show you the fault-
tolerant solutions at all levels of automation (control level, process level, field level).  

Function manual PCS 7 High-
precision Stamping 

Comprehensive overview of required components, the interaction among the 
components and their configuration for using high-precision time stamps 

Function manual PCS 7 time 
synchronization 

Comprehensive overview of required components, the interaction among the 
components, and their configuration for using time synchronization. 

Manual PCS 7 Basic Library Driver and diagnostic blocks 
Description of methods of operation, block I/Os and input/output fields of the respective 
faceplates 

Manual PCS 7 Standard 
Library 

Process automation blocks 
Description of methods of operation, block I/Os and input/output fields of the respective 
faceplates 

Manual PCS 7 Advanced 
Process Library 

Process automation blocks - expandable 
Description of methods of operation, block I/Os and input/output fields of the respective 
faceplates 

Manual PCS 7 Programming 
for Instructions for Blocks 

Explanation of how AS blocks and faceplates conforming to PCS 7 can be created to 
achieve the following: 
• Monitor parameter values through a faceplate 
• Control parameter values and therefore the reactions of blocks through a faceplate 
• Report asynchronously occurring events and block states on the OS and display 

them in a faceplate or a WinCC message list 
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Documentation Content 
Manual PCS 7 Programming 
Instructions Driver Blocks 

Help in creating driver blocks conforming to the system to fully exploit the functions in 
PCS 7 
(not included with PCS 7; must be ordered extra from the PCS 7 catalog) 

Manuals for the individual 
engineering tools: CFC, SFC, 
STEP 7, SFC visualization, 
PDM, WinCC, LT options, SCL, 
DOCPRO 

• Basics of the engineering tool 
• Working with the engineering tool 
• Testing and commissioning the engineering tool 

Readme and What's new for 
the individual engineering tools: 
CFC, SFC, STEP 7, SFC 
visualization, PDM, SCL, 
DOCPRO 

• Latest information with notes about installation of the engineering tool 
• Compact summary of the new or changed features in comparison to previous 

versions 
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2.1.4 Documentation on commissioning, operation, diagnostics and servicing 

Overview of the documentation for the realization phase              
You can find the following in the PCS 7 documentation table below: 
● Documentation providing support for commissioning and operating in process mode 
● Documentation providing support for performing servicing 

 
Documentation Content 
Process mode 
Manual PCS 7  
OS Process Control 

• Graphical user interface and operator input at the PCS 7 OS in process mode: 
– Message system 
– Trend system 
– Group display 
– Operator process control 

• Working at the maintenance station 

Manual PCS 7  
OS Web Option 

• Working with a WebNavigator client 

Configuration manual PCS 7 
SIMATIC BATCH 

• Batch control 
• Managing and archiving batch data 

Manual PCS 7  
SIMATIC Route Control 

• Route control 
• Managing and logging routes 

Manual PCS 7 Service Support 
and Diagnostics 

This documentation is aimed at trained service personnel (Service Level 1): PCS 7 users 
and SIMATIC S7 specialists 
This manual contains the information to support you in the following tasks: 
• Ensuring the availability of your PCS 7 plant 
• Understanding the alarm concept of your PCS 7 plant 
• Finding the right diagnostic tools when a fault occurs 
• Using the right procedure when a fault occurs and providing qualified, detailed 

information about the state of the PCS 7 plant to service experts 

Manuals for the automation 
system S7-400H/FH 

• Commissioning 
• Maintenance 

Manuals for CPs and FMs 
(S7-400, S7-300) 

• Diagnostics 

Manuals for ET 200 
components ET 200M, 
ET 200S, ET 200iSP and 
ET 200pro 

• Commissioning 
• Diagnostics 
• Maintenance 

Manuals for additional DP 
components: Diagnostic 
repeater, DP/PA link/Y link,  
DP/AS-i link, DB/EIB link, 
DP/FF link 

• Commissioning 
• Diagnostics 

Manual Programming with 
STEP 7 

• Hardware diagnostics and troubleshooting 
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2.2 Guide to the PCS 7 Engineering System Configuration Manual 

Basic layout for the PCS 7 Engineering System configuration manual 
The PCS 7 engineering system configuration manual is divided into three sections: 
 
Section Content 
Specifying the components and the systems for the PCS 7 plant 
Planning the plant 
engineering 

This contains all the information that you need to select the right systems 
and components based on the requirements of your PCS 7 plant.  
You will receive a complete overview of the installation options for the 
following components in PCS 7: 
• The automation system 
• The distributed I/O 
• The bus system 
• The network 

Assembling components and systems 
Configuration of PCS 7 
plants 

A guide takes you through the manual's instructions on installing the 
hardware components. In addition, it will provides you with information and 
rules about how PCS 7 differs from using SIMATIC.  

Engineering 
Basic Concepts of 
Engineering 

Introduction into how the requirements for efficient engineering (for 
example, type-defining, reusability, central editing) are implemented with 
PCS 7. 

Configuration of the 
PCS 7 engineering 
system 

Introduction to the structure and use of the engineering software of PCS 7 

Implementing the 
PCS 7 configuration 

Complete PCS 7 configuration with step-by-step instructions, relationships 
and background information 

Adopting the Data from 
the Plant Engineering 

Description of the import/export functions with step-by-step instructions, 
relationships and background information 

Compiling and 
downloading 

Information about how configuration data is compiled and downloaded to 
the PLCs (AS, OS, BATCH). 

Test Overview of the most important testing options prior to commissioning 
Comparing project 
versions with VXM 

Instructions on how to compare different project versions using the Version 
Cross Manager 

Service Information about diagnostics, service support, data security, versioning, 
and backing up project data 
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Introduction to Plant Engineering with PCS 7 3
3.1 Structure of a PCS 7 Plant 

PCS 7 - The Process Control System for Totally Integrated Automation        
As a process control system in the enterprise-wide automation network 'Totally Integrated 
Automation', SIMATIC PCS 7 uses selected standard components from the TIA modular 
system. Its uniform data management, communication and configuration offer an open 
platform for modern, future-oriented and economical automation solutions in all sectors of 
the process industry, production industry, and hybrid industry (mixture of continuous/batch 
processes and discrete production, e.g. in the glass or pharmaceuticals industries).  
Within the TIA network, SIMATIC PCS 7 not only handles standard process engineering 
tasks, it can also automate secondary processes (e.g. filling, packaging) or input/output 
logistics (e.g. material flows, storage) for a production location. 
By linking the automation level to the IT world, the process data become available 
throughout the company for the evaluation, planning, coordination and optimization of 
operational sequences, production processes and commercial processes. 
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Basic Structure of a PCS 7 Plant 
The modular architecture of SIMATIC PCS 7 is based on selected hardware and software 
components from the standard range of SIMATIC programs. The PCS 7 plant can be 
incorporated into the company-wide information network using interfaces based on 
international industrial standards for data exchange - such as Ethernet, TCP/IP, OPC or OLE 
DB communication. 
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The System/Components of PCS 7 
 
No. System/ 

component 
Description Sections in this manual 

containing further information 
OpenPCS 7 
station 

PC station for data communication with external systems, 
does not require knowledge of the topology.  
Data is accessed via OPC/OLE DB event-driven or 
cyclically. 

• Connecting to the IT world 
via OpenPCS 7 (Page 123)  

1 

PCS 7 Web 
server 

PC station for monitoring processes online around the world 
per Intranet or Internet. 

• Access to the PCS 7 OS via 
WebNavigator client 
(Page 125)  

2 SIMATIC IT  SIMATIC PCS 7 can be integrated into the company-wide 
information network with SIMATIC IT. 

• Connecting to the IT world - 
SIMATIC IT (Page 120)  

Engineering 
Station 

PC station with PCS 7 Engineering Toolset for centralized 
plant-wide engineering: 
• Configuration of the hardware 
• Configuration of the communications networks 
• Configuration of continuous and sequential process 

sequences using standard tools 
• Configuration of discontinuous process sequences 

(batch processes) with SIMATIC BATCH 
• Configuration of route controls with SIMATIC Route 

Control 
• Operator control and monitoring strategies 
• Compilation and downloading of all configuration data to 

all target automation system (AS), operator station (OS), 
BATCH station (BATCH) and Route Control station 

• Configuration of the 
Engineering Station 
(Page 163)  

• Preconfigured PCS 7 
Systems (Bundles) 
(Page 130)  

• Planning Objects/Functions 
for Efficient Engineering 
(Page 155)  

3 

Maintenance 
station  

PC station for checking the status of all PCS 7 components 
in hierarchically structured diagnostic pictures. 
A maintenance station can be set up in an  
MS client/MS server architecture. The diagnostics client is 
operated ideally on an engineering station. 

• Additional service support 
and diagnostics (Page 702)  

Operator 
Station 

PC station with human-machine interface for operating and 
monitoring of your PCS 7 plant in process mode 
An operator station can be configured as a single station or 
multiple station system with OS client / OS server 
architecture. 
It is also possible to use a central archive server (CAS) on a 
separate PC station. The archive server is a node on the 
terminal bus. 

• Operator Station 
Configurations (Page 165)  

• Preconfigured PCS 7 
Systems (Bundles) 
(Page 130)  

4 

Route Control 
Station 

PC station for operation and monitoring of route controls for 
transporting materials 
A Route Control station can be configured as a single 
station or multiple station system with a Route Control client 
/ Route Control server architecture 

• Configuration of the Route 
Control stations (Page 170)  
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No. System/ 
component 

Description Sections in this manual 
containing further information 

(3 +  4) PCS 7 Box Industrial PC that when used in conjunction with distributed 
I/O has the functionality of a PCS 7 process control system 
(engineering, automation, operator control and monitoring). 
You use PCS 7 BOX for small stand-alone systems or 
combined AS/OS stations that can be integrated in the 
PCS 7 network.  
The following variants are available: 
• PCS 7 BOX 416 with SlotPLC CPU 416-2PCI 
• PCS 7 BOX RTX with PLC WinLC RTX software 
It allows centralized engineering. 

• Configuration of the 
Engineering Station 
(Page 163)  

• Operator Station 
Configurations (Page 165)  

• Preconfigured PCS 7 
Systems (Bundles) 
(Page 130)  

5 BATCH station PC station for operation and monitoring of discontinuous 
process sequences (batch processes). 
A BATCH station can be configured as a single station or 
multiple station system with BATCH client / BATCH server 
architecture. 

• BATCH Station 
Configurations (Page 168)  

6 Terminal bus The following components communicate via the terminal 
bus:  
• Server/Client (OS, BATCH, Route Control) and 

Engineering Station 
Note: Single-station systems in all systems (ES, OS, 
BATCH, Route Control) can be connected to the terminal 
bus.  

• Communication within PCS 7 
(Page 77)  

• Management Level Scheme 
with Ethernet (Page 82)  

7 Plant bus The following components communicate via the plant bus:  
• Server (OS, Route Control) and automation systems 

(AS) 
• Interchangeable automation system (SIMATIC 

connections) 

• Communication within PCS 7 
(Page 77)  

• Management Level Scheme 
with Ethernet (Page 82)  

8 Automation 
system 

The automation system performs the following tasks: 
• To acquire process variables 
• To process the data according to the instructions in the 

user program 
• To output control instructions and setpoints to the 

process 
• To supply data to the operator station for visualization 
• To detect operator commands on the operator station 

and their return to the process 
• Direct access to the Route Control station 

• What are the criteria for 
selecting the AS? 
(Page 132)  

9 I/O 
field bus 

Connects classic and intelligent field devices. Intelligent 
field devices are connected by HART or PROFIBUS 
communication.  
In addition, the following components can be integrated: 
• Simple actuators and sensors via an  

AS interface 
• Components in building automation via an  

instabus EIB 
• Components with a MODBUS interface 

• Planning the Field Level with 
PROFIBUS (Page 96)  

• Which Devices can be 
Connected as Distributed 
Components? (Page 146)  

• Introducing How to Couple 
Data with other Systems 
(Page 113)  
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Additional information - PCS 7 Brochures 
If you are interested in further introductory information about PCS 7, read the PCS 7 process 
control system brochure. Here, you will find all of the necessary information about the 
principles of communication and the range of features in SIMATIC PCS 7, as well as the 
possible technical applications and appropriate functions for implementing your automation 
tasks. 
The following sections in this manual are based on the information in the PCS 7 brochures. 
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Planning the Plant Engineering 4
4.1 Before Beginning the Engineering 

Important Questions for Planning the Plant 
We recommend that you carefully study the questions contained in the table below. This will 
help you to effectively plan your plant. Under the heading "Additional sections in this 
manual," you can jump to sections containing additional information and overviews that 
should help you to answer these questions. 
 
Question Related topics in this 

manual  
Required knowledge 
for ... 

Sections in this manual 
containing further information 

What 
documentation is 
required? 

Processing phase in 
which the documentation 
is needed: 
• Planning 
• Configuration 
• Commissioning 

Quick location of 
sought after 
information  

• Options for Accessing 
Documentation 
(Page 21)  

• Documentation for the 
Planning Phase 
(Page 23)  

• Documentation for the 
Realization Phase 
(Page 25)  

• Documentation on 
commissioning, operation, 
diagnostics and servicing 
(Page 30)  

• Guide to the PCS 7 
Engineering System 
Configuration Manual 
(Page 31)  

How should the 
plant be controlled 
and how should it 
react to 
disruptions? 

• Process types: 
continuous or 
discontinuous 
operation 

• Degree of 
automation 

• Controllability 
(central/local) 

• Availability 

Selecting systems 
and determining 
requirements for the 
components 

• How to Find the Right 
Components (Page 42)  

• Important Criteria for 
Selecting Components 
(Page 46)  
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Question Related topics in this 
manual  

Required knowledge 
for ... 

Sections in this manual 
containing further information 

What areas are 
contained in the 
plant? 

• Technological areas 
• System  

associations 
• Local factors 

• Creating the plant 
hierarchy 

• Determining the 
areas; supporting 
areas, for 
example, the 
analysis of faults 
during plant 
operation 

• How many objects can be 
handled in a project? 
(Page 61)  

• How Many Devices, 
Sensors and Actuators 
can be Integrated? 
(Page 66)  

• How Many CPUs are 
Needed for Automation? 
(Page 65)  

• What Sources Can Be 
Used in Planning the 
Plant Design? (Page 58)  

Configuring signal paths Determining 
• Bus systems and 

conventional 
cabling 

• Transmission 
rates 

• Limits to distances

• Which Networks / Bus 
Systems Are Used for 
Communication? 
(Page 78)  

• What are the expansion 
limits? (Page 68)  

PC components 
(operator control, 
monitoring, configuration 
systems) 

Determining 
• Number 
• Availability 
• Data backup 
• Change 

documentation 
(validation) 

• Which PC Components 
Can Be Used? 
(Page 126)  

• How Can the Plant be 
Protected Against 
Unauthorized Access? 
(Page 50)  

• How can the process 
management be verified? 
(Page 53)  

• How Can Project and 
Process Data Be 
Archived? (Page 56)  

Which 
components 
should be used?  

Automation systems 
(performance and areas 
of application)  
Planned or existing I/O 
devices, sensors and 
actuators 

Determining 
• Number of AS 
• Availability 
• Failure safety 
• Ex protection 
• Employed 

modules and 
software 

• What are the criteria for 
selecting the AS? 
(Page 132)  

• Which Devices can be 
Connected as Distributed 
Components? 
(Page 146)  
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Question Related topics in this 
manual  

Required knowledge 
for ... 

Sections in this manual 
containing further information 

What preparations 
can be made for 
efficient 
engineering?  

• Number of process 
tags 

• Number and 
distribution of 
workstations for 
engineering 

• Planning the 
engineering 
environment 

• Using 
multiprojects and 
the Import/Export 
Assistant 

• Using appropriate 
resources to 
create lists (e.g. 
process tag lists) 

• Which devices can be 
connected as distributed 
components? (Page 146) 

• Which Data and Data 
Formats can be 
Imported? (Page 157)  

How can servicing 
be implemented in 
the PCS 7 plant? 

• Activate preparation 
for servicing 

• Planning diagnostics 
• Using diagnostic 

tools 

Planning service 
support and 
diagnostics 

• What Service Support 
Does SIEMENS Offer for 
PCS 7 (Page 59)  

Which languages 
are available? 

• Configuration and 
process control 
– English 
– German 
– French 
– Italian 
– Spanish 

Planning of the 
engineering and the 
process control 

• How to Set the Defaults 
(Page 257)  

• How to Set the Language 
for Display Devices 
(Page 328)  
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4.2 PCS 7 Plant Components 

4.2.1 How to Find the Right Components 

Introduction 
PCS 7 offers a wide range of options for implementing automation tasks. The large selection 
and variety of components facilitates the following: 
● Employment of suitable components for special requirements 
● Selection of components that can be configured exactly to meet specific requirements 
The following table lists optimally matched systems, components and functions for specific 
process control requirements.  

Selecting Systems, Components, and Functions 
Select the systems, components and functions based on the requirements of your PCS 7 
plant:  
 
Prompt Specification System, component, 

function for PCS 7 
Check 
√ 

Process mode - OS 
Operation and 
monitoring 

Operation and monitoring in process 
mode 

PCS 7 operator station 
with WinCC software 

 

Operator control and 
monitoring via the 
Internet/Intranet 

Use of the operator control and 
monitoring functions in process mode 
via the Internet or Intranet 

PCS 7 OS Web option  

Access to process data 
via the Internet/Intranet 

Data communication with external 
systems via OPC and OLE DB 

OpenPCS 7  

Sign-of-life monitoring Monitors systems connected on the 
terminal bus and plant bus 

Function "Lifebeat 
monitoring" from WinCC 

 

Time-of-Day 
Synchronization 

Central time synchronization from 
systems connected on the terminal 
bus, plant bus, and field bus 

Function "Time 
synchronization" from 
WinCC 

 

Long-term data 
acquisition 

Using archive systems Archive systems of 
WinCC 

 

Long-term data 
archiving 

Use of a central archive server (PC 
station) 

Central Archive Server 
(CAS) 

 

Controlling and 
operating sequential 
control systems 

Graphically displaying and operating 
configured sequential control systems 

SFC Visualization  

Operating and 
monitoring of the Safety 
Matrix 

Display and operation of configured 
safety reactions 

Safety Matrix Viewer  

Access protection Central user management, access 
protection and electronic signatures 

SIMATIC Logon with 
electronic signature 

 

Batch processes Controlling discontinuous processes SIMATIC BATCH  
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Prompt Specification System, component, 
function for PCS 7 

Check 
√ 

Route control Control, monitoring and diagnostics of 
material transports in pipeline 
networks 

SIMATIC Route Control  

Swapping out process 
data 

Viewing swapped out process data StoragePlus  

Process mode – AS and I/O 
Availability Using fault-tolerant automation 

systems 
S7-400H 
+ Distributed I/Os 
(ET 200M, ET 200iSP) 

 

Failure safety Using fail-safe 
automation systems  

S7-400F 
+ Distributed I/Os 
(ET 200M, ET 200S) 

 

Availability and failure 
safety 

Simultaneous use of fault-tolerant and 
fail-safe 
automation systems 

S7-400FH 
+ Distributed I/Os 
(ET 200M) 

 

Control modes Modules with controller functions S7-400 FM  
Distributed I/Os Connecting field devices via 

PROFIBUS DP depending on the 
protection level, attachments, and Ex 
zone 

ET 200M with S7-300 
signal 
modules, -CPs, -FMs, 
HART, and fail-safe 
S7-300 signal modules 
ET 200S with electronic 
modules and fail-safe 
power modules 
ET 200iSP with electronic 
modules, HART 

 

Diagnostics  
(with hardware 
components) 

Simple diagnostics for communication 
errors in PROFIBUS DP lines 
You can find more information in the 
section "Additional Service Support 
and Diagnostics (Page 702)" 

e.g. Diagnostic Repeaters  

Diagnostics  
(with software 
components) 

Using and activating the PCS 7 
diagnostic functions 
You can find more information in the 
section "Additional Service Support 
and Diagnostics (Page 702)" 

e.g. NCM S7 PROFIBUS 
diagnostics 

 

Hazardous area Special I/O components for use in 
hazardous areas (zones 1 or 2) 

S7-300-Ex I/O modules, 
ET 200iSP 

 

Plant changes Plant changes in runtime CiR  
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Prompt Specification System, component, 
function for PCS 7 

Check 
√ 

Process mode – communication/connection 
Terminal bus, plant bus  Ethernet  Communication 

(network) Support for communication through 
network components such as CPs, bus 
links 

Network components of 
SIMATIC NET 

 

Connecting AS Connecting automation systems to the 
plant bus 

CP 443-1  

Connecting OS/BATCH Connecting PCS 7 operator/BATCH 
stations to the terminal bus or plant 
bus 

CP 1612, CP 1613,  
CP 1623, CP 1512 or 
other Ethernet interface 

 

Connecting ES Connecting the PCS 7 engineering 
station to the terminal bus or plant bus 

CP 1612, CP 1613,  
CP 1623, CP 1512 or 
other Ethernet interface 

 

Point-to-point coupling Communication between the AS and 
other stations via point-to-point link 

S7-400 CPs 
S7-300 CPs (in ET 200M)

 

Sensors and actuators  Connecting actuators and sensors  PROFIBUS PA  
Intelligent field devices  Connecting intelligent field devices 

with HART and PROFIBUS 
communication 

PROFIBUS DP/PA  

Coupling DP/PA Gateway between PROFIBUS DP and 
PROFIBUS PA 

DP/PA coupler,  
DP/PA link 

 

Non-redundant 
PROFIBUS DP devices 

Connecting non-redundant PROFIBUS 
DP devices to redundant PROFIBUS 
DP 

Y link  

Engineering 
Scalability Licenses for various numbers of 

process objects 
Licenses   

Basic engineering Basic engineering of hardware, 
communication 

STEP 7 with HW Konfig, 
NetPro 

 

Continuous automation 
functions 

Graphical configuration of automation 
functions 

CFC  

Discontinuous 
automation functions 

Graphical configuration of sequential 
control systems with step-enabling 
conditions 

SFC  

Repeatedly used 
technological functions 

Using PCS 7 libraries • PCS 7 Library V7.1 
• PCS 7 Basic Library 

V7.1 
• PCS 7 Advanced 

Process Library V7.1 

 

User function blocks, 
custom 

Create your own user function blocks 
in accordance with  
IEC 61131-3 

SCL  

Batch processes Configuring recipes and batches 
(production jobs) 

SIMATIC BATCH  

Route control System for the configuration, control, 
monitoring and diagnostics of material 
transports in piping systems 

SIMATIC Route Control  
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Prompt Specification System, component, 
function for PCS 7 

Check 
√ 

Availability with 
S7-400H 

Engineering for redundant automation 
systems 

S7 H Systems  

Failure safety with  
S7-400F 

F programming tool with  
F-function blocks 

S7 F systems  
add-on package 

 

Safety reactions to 
defined states 

Assignment of precisely defined 
reactions to events occurring in the 
process 

Safety Matrix  

Controller optimization System-aided optimization of control 
circuits with PCS 7 

PCS 7 PID Tuner  

Plant pictures for  
PCS 7 OS 

Creation of plant pictures for the OS in 
process mode and interconnection of 
picture objects with process tags 
(dynamic display) 

Graphics Designer from 
WinCC 

 

Faceplate for  
PCS 7 OS 

Creating faceplates for PCS 7 OS 
process pictures  

Faceplate Designer  

Intelligent field devices Configuration, parameter assignment, 
and commissioning of field devices 

SIMATIC PDM  

Efficient engineering Functions for efficient engineering 
• Working with the several project 

engineers 
• Type definitions with reusability 

and centralized modification 
capability 

Multiproject,  
SFC type, process tag 
type, model, process 
object view 

 

Mass data processing Creation: 
• Process tags from process tag 

types 
• Replicas of models 

Import/Export Assistant  

Comparing project 
versions 

Determining differences between 
various versions of a project 

Version Cross Manager 
(VXM) 

 

Versioning Versioning of multiprojects, projects or 
libraries 

Version Trail  

Test Functional testing of the configuration 
with a simulated SIMATIC S7 station 

S7 PLCSIM  

Plant documentation Documenting plants in PCS 7 projects 
in conformance with standards 

DOCPRO  

Additional information 
● Section "Capacity Options in Configuring a PCS 7 Plant (Page 60)" 
● Section "Selecting the network components (Page 77)" 
● Section "Selection of the PC components for ES, OS, BATCH, Route Control and IT 

(Page 126)" 
● Section "Selecting AS Components (Page 132)" 
● Section "Selecting I/O components (Page 144)" 
● Section "Preparation for Efficient Engineering (Page 155)" 
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4.2.2 Important Criteria for Selecting Components 

Selection Criteria 
The selection of components for a process control system involves a variety of factors. The 
most important factors are: 
● The type of process (continuous or discontinuous) 
● The reaction of a plant to disruptions (availability and safe state) 

Type of process 
There are two process types: 
● Continuous process 

Process sequence in plants in which "the same product" is produced "unchanged" (e.g. 
water desalination plants). Such processes can be automated by PCS 7 using sequential 
control system (SFC). The automation can be implemented for small plant units as well 
as for the entire plant. 

● Discontinuous (batch) process 
Process sequence in plants in which "different products" are produced (e.g. various 
recipes for producing tablets or mixing paints). Such processes can be automated by 
PCS 7 using SIMATIC BATCH. With the recipe-based control strategies in SIMATIC 
BATCH, the process sequences of a PCS 7 plant can be flexibly adapted to changing 
products, material properties, plant conditions, product stages, etc. 

Reaction of a plant to disruptions (availability and safe state) 
The consequences of disruptions are often difficult to evaluate. Planned reactions to faults 
are therefore very important. This is achieved through the following measures: 
● Using fault-tolerant components 
● Using fail-safe components 
● Using fault-tolerant and fail-safe components 
● Implementing the appropriate configuration measures, for example: 

– Interlocks between measuring points (defining targeted response in the system) 
– Sequential control charts for startup and shutdown (automatic control of entire 

systems) 
– Higher-level calculation and management functions (reacting directly to the effects of 

an event) 
– Control functions for targeted control of units and plants (e.g. control using fail-safe 

systems in a defined state) 
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Additional information 
● Section "Selecting fault-tolerant and fail-safe components (Page 69)" 
● Function manual Process Control System PCS 7; Fault-tolerant Process Control Systems 
● Manual Process Control System PCS 7; SIMATIC BATCH 
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4.2.3 With Which "Third-Party Systems" can PCS 7 Communicate? 

Communication with "Third-Party Systems"  
You can link up with numerous systems within the framework of Totally Integrated 
Automation with PCS 7 (TIA components are used in PCS 7 without additional applications): 
● Administration level and remote access 

PCS 7 is seamlessly integrated into the company-wide information network using 
standardized interfaces for data exchange such as Ethernet, OPC or OLE DB 
(OpenPCS 7 station). This makes process data available at any time and at any location 
within the company. 

● Data links to other communication systems 
In addition, communication is possible with the following communication systems using 
an adapter:  
– AS interface 
– KNX (Instabus EIB) 
– MODBUS 
– H1 (FF; Fieldbus Foundation) 

 

 
 

Note 
Please contact your Siemens representative for more information about other 
communication options. 
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Selection of the Components 
Select the components that you need for the data link to the third-party systems:  
 
Prompt Specification System, component, 

function for PCS 7 
Check 
√ 

Process mode – communication/connection 
IT world Integrating PCS 7 into SIMATIC IT  SIMATIC IT  
Access to MIS/MES 
process data 

Company-wide access to process data 
acquired with PCS 7 via OpenPCS 7 
station (OPC and OLE DB) 

OpenPCS 7  

Simple actuators and 
sensors  

Connection of simple (usually binary) 
actuators and sensors on the lowest 
field level 

AS-i Link  

Building 
automation 

Used to connect components in 
building automation 

DP/EIB link  

MODBUS devices Used to connect components with the 
Modbus interface 

CP 341 with MODBUS 
driver 

 

Fieldbus Foundation Integration of H1 bus components with 
FF interface 

DP/FF Link  

Engineering 
Links and couplers Configuration, parameter assignment 

and commissioning 
HW Config or specific 
component software 

 

Additional information 
● Section "Administration level and remote access (Page 119)" 
● Section "Data Links to Other Systems (Page 113)" 



Planning the Plant Engineering  
4.2 PCS 7 Plant Components 

 Engineering System (V7.1) 
50 Configuration Manual, 03/2009, A5E02122455-01 

4.2.4 How Can the Plant be Protected Against Unauthorized Access? 

Protection against unauthorized access in an automated plant 
A great number of components are networked together in modern industrial plants. A variety 
of bus systems and protocols (such as TCP/IP, COM/ DCOM) are used to form the network. 
In networked automated plants, it is important to protect against unauthorized access to the 
plant, for example, from "office networks". This ensures that there are no negative effects on 
the plant.  

Plant protection in PCS 7 
In addition to the standard resources from Windows (user logon) and the usual network 
components (bridges and firewalls), PCS 7 provides a variety of options to prevent 
unauthorized access in a plant. 

Selecting components and functions 
Select the components/functions from PCS 7 needed for protecting access: 
 
Prompt Specification System, component, 

function for PCS 7 
Check 
√ 

Access protection using smart card 
containing operator permissions 

Smart card reader  

Configuring operator permissions Function "User 
administrator" from 
WinCC 

 

Operator permissions 
for the PCS 7 OS 

Representation of picture content 
without operator permission 

"OS Project Editor" 
function 

 

Access protection on 
AS 

Protecting loaded CPU against access HW Config – Properties 
of the CPU 

 

Access protection for 
charts 

"Write-protected" attribute for 
individual charts or all charts within a 
folder 

SIMATIC Manager - 
Object properties 
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Central user management in PCS 7 
User management with 
access protection 
control 

User management with access 
protection control for engineering and 
process mode, determination of 
application-specific user roles for 
engineering and operator control and 
monitoring 

SIMATIC Logon  

Access protection for 
project data 

Central user management with access 
control for engineering 
The objects (for example, multiproject, 
project, library) of a multiproject can be 
provided with access protection  

Access protection for 
access to project data" 
function 

 

Access protection on 
AS 

Password protected access to tasks 
for changing data in the automation 
system (user program, HW Config) 

"Password protected 
access to the CPU" 
function  

 

Electronic signature Password protected execution of 
functions, e.g. for controlling batches 
with BATCH 

Electronic signature 
based on SIMATIC Logon

 

Principle of central user management with SIMATIC Logon 
SIMATIC Logon from PCS 7 is based on the basic user management mechanism in 
Windows: 
1. Users, user groups (available on the prevailing Windows server) and passwords are 

defined in Windows. 
2. The SIMATIC Logon software defines user roles for the engineering system, operator 

station, BATCH station and Route Control station and their assignment to defined 
Windows user groups. 

3. Additional limits to user roles and user rights can be defined within the application. The 
following additional limits can be defined with SIMATIC BATCH: 
– Limits to the user rights in a user role (global) 
– Permitted user roles per computer (for each specific computer) 
– Permitted user roles per plant unit (for each specific unit) 
– Permitted user roles per plant unit (for each project) 

The components contained in PCS 7 are supplied with information about the logged on user 
via the central logon service and can be informed of any change of the logon, etc. 



Planning the Plant Engineering  
4.2 PCS 7 Plant Components 

 Engineering System (V7.1) 
52 Configuration Manual, 03/2009, A5E02122455-01 

Principle of electronic signatures 
PCS 7 supports the "electronic signature" function conforming to FDA or 21 CFR Part 11 
requirements. The engineering contains definitions of the actions or conditional transitions of 
objects that should be activated by the "electronic signature" function based on the user role. 
When such an event occurs, there is a dialog prompt for one or more signatures based on 
the usual logon dialog in Windows. 
Requirements:  
The SIMATIC Logon Service software verifies the logon data. Therefore the SIMATIC Logon 
Service must be installed on the PC in order to use the "electronic signature" function. 

Additional information 
● Section "Protecting Projects/Libraries with Access Protection (Page 193)" 
● Manual SIMATIC Logon; SIMATIC Electronic Signature 
● Configuration manual Process Control System PCS 7; Operator Station 
● Whitepaper Security concept PCS 7 and WinCC 
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4.2.5 How can the process management be verified? 

What is the Purpose of Process and Process Management Verification?  
Legal and business requirements play a decisive role for many plants, especially in regards 
to the following: 
● Verifying standards of quality 
● Documenting the status of a plant 
● Allowing only authorized personnel have access to the plant and verifying the operator 

input 
● Allowing only authorized personnel to make changes to the plant 
An additional requirement for a process control system is often complete automatic 
documentation of all critical plant data and process operation in an automated plant.  

Food & Drug Administration (FDA) 
The US Food & Drug Administration (FDA) has defined guidelines for these areas. The GMP 
laws 21 CFR Part 210, 211, 11 are based on these guidelines. The most important, 
internationally valid requirements for automation engineering (in regard to validation) are 
summarized in 21 CFR Part 11. 

Validation with PCS 7 according to 21 CFR Part 11 
PCS 7 and SIMATIC BATCH support validation in conformity to 21 CFR Part 11. 
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Selecting Components and Functions 
Select the components/functions from PCS 7 that you need for validating the process 
management: 
 
Prompt Specification System, component, 

function for PCS 7 
Check 
√ 

BATCH: logging of each of the 
following modifications: 
• Modifying the recipe 
• Modifying the user permissions 

BATCH change log  

BATCH: logging of recipes BATCH recipe log  
BATCH: logging of any changes during 
batch production (including operator 
input)  

BATCH batch log  

Logging of performed 
modifications 

Route Control: logging of changes in 
the transport routes 

Route log  

ES: logging of the following processes:
• Download to CPU (Entire program) 
• Download to CPU (Changes) 
• Activation and deactivation of test 

mode 
• Changing values in test mode 

Change Log  Logging of protected 
actions 

ES: additional logging of the following 
processes in the CFC/SFC: 
• In the CFC 

– Configuration of the 
connections 

– Activation/deactivation of 
runtime groups 

• In SFC 
– Configuration of constants in 

steps 
– Configuration of constants in 

transitions 
– Configuration of constants in 

sequencer properties 

ES Log  

Logging of delete 
actions 

BATCH: documentation of all delete 
actions in a separate log 

BATCH log  

Versioning projects and 
libraries 

ES: creating projects and libraries with 
different versions 

Version Trail  

Consistency of project 
and library versions 

ES: comparing versions of projects 
and libraries with graphic displays of 
differences 

Version Cross Manager 
(VXM) 

 

Versioning charts ES: Creating CFC/SFC charts with 
different versions 

Automatic prompt after 
changing a chart 

 

Versioning BATCH: versioning recipes, recipe 
operations and formulas 

Automatic when a new 
batch object is created 

 

System access Central user management based on 
Windows 

SIMATIC Logon  
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Prompt Specification System, component, 
function for PCS 7 

Check 
√ 

User identification The log book is automatically 
amended with the identification of the 
user. 

Automatic in the change 
logs 

 

Electronic signature Password protected execution of 
functions, e.g. for controlling batches 
with BATCH 

Electronic signature 
based on SIMATIC Logon

 

Logging of electronic 
signatures 

BATCH: documentation of the 
performed electronic signatures  

Automatic in the 
recipe/batch report and in 
the BATCH change log 

 

Logging of AS access Logging modifications made in the AS Access protection with 
SIMATIC Logon 
Logging through the ES 
log 

 

Proof for validation BATCH: logs and archives - completed 
batches can be archived in the XML 
format 

Function "Archiving a 
Batch" in BATCH 

 

Additional information 
● Section "Comparing Project Versions with VXM (Page 687)" 
● Section "How to Document Changes in the ES Log (Page 676)" 
● Section "How to Document Changes in the Change Log (Page 679)" 
● Online help for the Version Cross Manager 
● Manual Process Control System PCS 7; SIMATIC BATCH 
● Manual Process Control System PCS 7; SIMATIC Route Control 
● Manual SIMATIC Logon; SIMATIC Electronic Signature 
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4.2.6 How Can Project and Process Data Be Archived? 

Introduction                   
SIMATIC PCS 7 provides a variety of functions for archiving project data and process 
values. 

Archiving Project Data 
The central database organization for plant-wide configuration data is contained in the 
engineering system. To avoid loss of data we recommend that you regularly backup your 
project. Archiving involves saving configuration data in the compressed form of an archive 
file. This is possible on the hard disk or transportable data media (for example, CD, DVD). 
You can select the required archiving tool in the SIMATIC Manager. 

 

 Note 
Use the Version Cross Manager to determine differences between various versions of a 
project. 

 

Archiving Process Data 
Process data (measured values and messages) can be saved in the following archives: 
● WinCC archives 

These archives are circular archives with a limited capacity. As soon as the maximum 
capacity has been reached, the oldest values are deleted so that additional new values 
can be saved. This corresponds to the FiFo principle. 
These archives can be swapped out in order to avoid this old data. 
You can find further information about this in the section "Swapping Out the Archived 
Information". 

● BATCH archives 
Batch data archiving in XML format: Batch data that can be accessed by authorized 
persons or systems can be saved in XML format. These archives are used for long-term 
storage of batch data as required by the FDA.  
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Components, Functions for Archiving 
 
Archiving of Specification System, component, function for 

PCS 7 
Check 
√ 

Configuration data The multiproject can be archived 
with all projects and the master 
data library. 

"Archiving" function in the STEP 7 
SIMATIC Manager 

 

The operator station saves 
measured values and messages 
in archives so that the data can be 
called up over a longer period of 
time. 

Tag Logging (Archive)  

WinCC archives must be 
configured and adapted with 
editors from WinCC. 

• Tag Logging: Process values 
• Alarm Logging: Messages 
• Report Designer: Print layout 

 

Process data (in 
circular archives) 

SIMATIC PC station as a central 
archive server (WinCC) 

• Central archive server with 
integrated StoragePlus 

• Tag logging, alarm logging 

 

Batch data  The batch logs of completed 
batches can be archived:  
• in XML format 
• in a database 
• in PDF format 

Function "Archiving Batches" in 
SIMATIC BATCH 

 

Swapping out the Archived Information 
You can swap out the information (tag and alarm logs) in OS archives to external media (e.g. 
CD, DVD). 

 

 Note 
You can view swapped out OS archives using the software product StoragePlus (option kit).

 

Additional information 
● Section "Archiving/Retrieving Multiprojects and Project Master Data" 
● Configuration manual Process Control System PCS 7; Operator Station 
● Manual Process Control System PCS 7; SIMATIC BATCH 
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4.2.7 What Sources Can Be Used in Planning the Plant Design? 

Plant structure 
The plant structure is understood as the following: 
● How and where the areas of a plant are configured and designed 
● Which options are used to equip which areas of a plant 

Planning the Plant Structure 
 

 Note 
There is no plant structure which can be recommended as universally valid. The designs 
involved in engineering a plant for process automation depend on the following factors: 
• Laws, regulations, standards 
• Process engineering and manufacturing engineering relationships 
• Local conditions (location, expansion capability, environmental conditions, etc.) 
• Other requirements (e.g. sensors and actuators in use) 
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Sources for Planning a Plant Structure 
You can gather important information from the following sources: 
 
Source Topic Example 
Description of 
the process 

• Process engineering continuity 
• Continuity based on location 
• Central/distributed configuration 

of the automation 
systems 

• Central/distributed configuration 
of the HMI systems 

• Number of workstations 
depending on the degree of 
automation 

Plant (e.g. power station): 
• Plant with units (e.g. heating unit with 

burner control) 
• Relationship of units to the entire 

process (e.g. failure of unit = failure of 
plant or reduced quality/performance) 

• Information about hazards (e.g., 
explosive gases) 

• Information about units (e.g. pressure 
control) and components (e.g. pressure 
sensor, pumps, valves) 

Process tag lists Central or distributed configuration 
possible; please observe the 
following: 
• Distance and distribution 
• Maintenance 
• Environment (e.g. Ex zone, local 

operator input, heat, dust) 
• Configuration, operating and 

monitoring 
• Tag types 

• Types of sensors and actuators and their 
technical parameters - for example: 
– Fill-level sensor: 0 to 20 l 
– Pump: with motor, temperature 

sensor, overload protection 
– Valve: with drive and position 

feedback signal 
• Planned location of the 

sensors/actuators in the plant 
• Signals from sensors and actuators: 

acquisition and processing in an 
automation system 

• Process tags belonging to a process tag 
type (e.g., "fill level") 

Importing Data for the Engineering 
Electronic plant information can be imported into the engineering system to display the plant 
structure in PCS 7 (for example: process tag information, plant pictures). 

Additional information 
● Section "Capacity Options in Configuring a PCS 7 plant" 
● Section "Which data and data Formats can be imported? (Page 157) 

4.2.8 What Service Support Does SIEMENS Offer for PCS 7 

Service Support   
You can find support for servicing PCS 7 plants from Siemens on the Internet 
(http://www.siemens.com/automation/service&support)  

http://www.siemens.com/automation/service&support
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4.3 Capacity Options in Configuring a PCS 7 Plant 

4.3.1 How can PCS 7 be scaled? 

Scalability 
SIMATIC PCS 7 can be adapted flexibly in a variety of ways for different plant requirements 
and sizes. The configuration can be expanded or modified during later upgrading or if 
technological changes are made to the plant.  
SIMATIC PCS 7 covers all plant sizes. Depending on the demands you have the following 
options: 
● To choose between automation systems with different performance capacities – starting 

with applications having few control tasks (for example: with SIMATIC PCS 7 BOX) -- up 
to the automation of a very large production plant with integrated process data control 

● To integrate distributed or central I/Os step-by-step 
● To dimension and configure the display and operating components – starting with a small 

single station system with approx. 160 process tags for laboratory automation -- up to 
distributed multi-station systems with client-server architecture that includes 
approx. 60,000 process tags for the automation of a large production plant 

● To scale the number of configurable process objects (software for a variety of PO 
quantities) 

● To define network components and configure communication networks 
● To enhance the functionality by systematically adding a variety of hardware and software 

components (for example, operator stations with SIMATIC BATCH or a separate archive 
server) 

● To integrate applications for connecting SIMATIC PCS 7 to the IT world 

Capacity Options 
The following sections provide information about planning for PCS 7 plant capacity: 
● How many process objects can be handled in a project? (Page 61) 
● How Many CPUs are Needed for Automation? (Page 65) 
● How Many Devices, Sensors and Actuators can be Integrated? (Page 66) 
● How Many Operator Stations are Required? (Page 67) 
● What are the expansion limits? (Page 68) 
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4.3.2 How many objects can be handled in a project? 

Plant size 
The configurable size of a PCS 7 plant is scalable. 
The software product licenses for an engineering station, operator station, SIMATIC BATCH 
station, Route Control station and SIMATIC PDM are available with different license package 
options. You can expand these package options using additional Power Packs.  

Process object        
In PCS 7 version V7.0 SP1 and higher, the following applies for licensing of "PO" process 
objects: 
All SFCs and all block instances that support operator control and monitoring and that 
produce messages are considered to be PCS 7 process objects. These are the objects that 
are transferred to the OS and require licenses. 
In the CFC, a block that supports operator control and monitoring is assigned the attribute 
"S7_m_c" in the block properties.  
A process object can be one of the following blocks and objects: 
● Blocks for operator control and monitoring of a plant (for example, motors, valves) 
● Objects for automation (for example, level control) 
● Objects for signal acquisition and signal processing (not channel driver blocks, for 

example, MEAS_MON) 
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Level of licenses 
The following table shows the plant capacities suited for PCS 7 and the plant capacity levels 
that can be achieved (determined for each component of the process control system).  
 
Component of 
Process Control 
System 

Level of the license Remarks 

Engineering Max. PO:  
• Unlimited 

Limits the sum of all POs on the ES (also 
refer to Section "PCS 7 license information 
(Page 501)"  
Note: take the limit for the OS into 
consideration. When compiling the OS, 
approximately 30 external tags are 
acquired per process object for the 
operator stations.  

Engineering system 
(ES) 

Downloadin
g to 
SIMATIC 
stations 

Max. PO (tags):  
• 100 
• 1.000 
• 10.000 

• Objects which can generate messages 
are classed as process objects (POs) 

• The license type of these license keys 
is "Count relevant license". 

• Limits the sum of the POs of all AS 
license keys on the ES 

Operator stations 
(OS) 

Max. PO:  
• 250 
• 1,000 
• 2,000 
• 3,000 
• 5,000 
• 8,500 (for OS servers only) 

• Limited to 5,000 PO per single station 
system 

• Limited to 8,500 PO per OS server 
• Max. 12 OS servers, each with 

max. 5,000 PO = 60,000 PO 
Note: Consider the additional limit to the 
number of tags (one process object has 
approx. 45 OS tags on average). 

OS client  WinCC RT PO client 
Central archive 
server (CAS) 

 WinCC RT PO client 

Archiving  
(Archive server 
(CAS) and OS 
server) 

Number of archive tags: 
• 1.500 
• 5.000 
• 10.000 
• 30.000 
• 80.000 
• 120.000 

• A maximum of 1,000 process values 
per second can be archived on the OS 
server. 

• A maximum of 10,000 process values 
per second can be archived on the 
archive server. 

The license for < 512 archive tags is 
included in all OS server licenses. If you 
want to archive more process values then 
all additional licenses are required up to the 
desired quantity. 

Maintenance station 
(MS) 

Max. asset tags  
(hardware components): 
• 10 
• 100 
• 1.000 

Number of monitored hardware 
components within a PCS 7 project. 
The license type of these license keys is 
"Count relevant license". 
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Component of 
Process Control 
System 

Level of the license Remarks 

Max. WebNavigator clients 
• 3 
• 10 
• 25 
• 50 

Number of WebNavigator clients on the 
PCS 7 Web server 

PCS 7 OS Web 
option 

Max. WebNavigator diagnostic 
clients: 
• 3 

 

BATCH Stations 
(batch processes) 

Max. units (plant units):  
• 10 
• 20 
• 40 
• 100 
• Unlimited 

Number of plant units within a PCS 7 
project 
The number of plant units that can be 
processed depends on the utilization of the 
BATCH server. 

Route Control 
stations (route 
control) 

Up to routes: 
• 30 
• 100 
• 300 

Number of activated routes in process 
mode (material transports) 
The basis license of 30 active routes can 
be expanded to the next higher-level with 
an upgrade. 

PDM  PDM (Basic), max. devices:  
• 4 
PDM, max. devices: 
• 10 
• 100 
• 1000 
PDM (Client) 
• 1 
• 5 
• 10 
• 20 

Number of configurable devices 

Engineering Max. PO: 
• 250 
• 1000 
• 2.000 

Limited the sum of all POs on the ES 
You can find additional information in this 
table for the engineering system. 

Operator 
station 

Max. PO: 
• 250 
• 1.000 
• 2.000 

Limited to 2.000 PO per single station 
system 

SIMATIC PCS 7 
BOX-PC 

Downloading 
to SIMATIC 
stations 

Max. PO (tags): 
• 3 x 100 

The license type of these license keys is 
"Count relevant license". 
You can find additional information in this 
table for the engineering system. 
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Component of 
Process Control 
System 

Level of the license Remarks 

PDM Max. devices: 
• 4 
• 128 

Limited to 128 devices per  
SIMATIC PCS 7 BOX 416 

Maintenance 
station 

Asset tags 
(hardware 
components): 
• 10 
• 100 

The license type of these license keys is 
"Count relevant license". 
You can find additional information in this 
table for the maintenance station. 

BATCH Max. units (plant 
units): 
• 10 

Limited to 10 units per  
SIMATIC PCS 7 BOX 416 

Route Control Up to routes: 
• 30 

Limited to 30 routes per 
SIMATIC PCS 7 BOX 416 

Additional information  
● Manual Process Control System PCS 7; PC Configuration and Authorization 
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4.3.3 How Many CPUs are Needed for Automation? 

Criteria for the Required Number of CPUs 
The number of required CPUs in a PCS 7 plant depends on the following factors: 
● Number of sensors and actuators 

The more actuators and sensors there are utilized, the more automation systems are 
required 
You can find information about this in the section "How Many Devices, Sensors and 
Actuators Can Be Integrated?" (Page 66) 

● CPU type 
The more efficient the CPU is, the fewer the number of CPUs required 
You can find information about this in the section "Overview of the Automation Systems 
(Page 134)" 

● Capacity utilization and required expansion capability 
The more reserves are required, the more CPUs are required. 

● Limits of the CPUs 
You can find information about this in the section "Limits of the CPUs for PCS 7 Projects 
(Page 137)" 

● Expansion of the plant 
You can find information about this in the section "What are the Expansion Limits? 
(Page 68)" 

● Environmental requirements 
● The desired optimization of the CPU for fast program execution and fewer required 

CPUs: 
– Optimization of the execution cycle for program sections 
– Optimization of the execution sequences 

No Multicomputing for PCS 7 
 

 Note 
Multicomputing (synchronous operation of more than one CPU) is not possible in PCS 7! 
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4.3.4 How Many Devices, Sensors and Actuators can be Integrated? 

Mixed Capacities 
The following provides an example mixed capacities for automation systems in a PCS 7 
plant.  

 

NOTICE  
The values displayed in the following tables are not AS specific maximum values for the 
respective position. They are an example list representing the typical distribution of the total 
AS capacity available during mixed operation of all positions in a cohesive block. 

 

Example: 
Mixed capacity for automation systems in a PCS 7 plant: 
 
Object AS 416-3 AS 417-4/AS 417H 
Memory card (MB) 8 16 
Analog value measurements 150 500 
Digital value measurements 400 1,000 
Dosing 15 30 
Motors 150 300 
PID controllers 130 200 
Valves 150 300 
SFC 50 100 
Steps 500 1,000 

or: 
 
Objects AS 416-3 AS 417-4/AS 417H 
Digital inputs DI 850 1,500 
Digital outputs DO 315 630 
Analog inputs AI 275 500 
Analog outputs AIO 130 200 



 Planning the Plant Engineering 
 4.3 Capacity Options in Configuring a PCS 7 Plant 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 67 

4.3.5 How Many Operator Stations are Required? 

Capacity of the PCS 7 OS      
SIMATIC PCS 7 supports both single station and multiple station systems with a client-
server architecture. The following table shows the most important factors for planning 
operator stations in a multiple station system.  
 
Property Limit 
Maximum number of OS server/redundant OS 
server pairs 

12 

Max. number of automation systems per OS 
server/redundant OS server pair 

64 

Maximum number of OS clients in multiclient 
mode (when each OS client has access to all 12 
OS servers/redundant OS server pairs) 

32 per multiple station system 

Number of process tags Approx. 3,000 per OS single-user system 
Approx. 5,000 per OS server  
Approx. 60,000 per multiple station system  

Max. number of configurable messages 50,000 per OS server 
Number of process values that can be archived Approx. 1,000 process value per second with OS 

server 
Approx. 10,000 process value per second with 
central archive server  

Number of OS areas 64 OS areas in 5 levels per OS server  
Number of maintenance stations 1 maintenance station for monitoring diagnostic 

variables  
Max. number of WebNavigator clients 50  
Max. number of WebNavigator diagnostic clients 3 

Additional information 
● Configuration manual Process Control System PCS 7; Operator Station 
● Manual Process Control System PCS 7; PCS 7 OS Web Option 
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4.3.6 What are the expansion limits? 

Expansion Limit 
Any potential plant expansion depends on the following factors: 
● Network type connecting the PCS 7 components 
● Distance bridged between the sensors and actuators (taking into consideration the 

potential transmission rates) 
Since almost all of the sensors and actuators for PCS 7 are integrated in the distributed I/O, 
the length of the communications network is a critical factor.  

Maximum Expansion  
The following bus systems are used in PCS 7 with the following maximum lengths:  
 
Bus system Application in PCS 7 Maximum length 
Industrial 
Ethernet  

Communications network for networks and 
subnets with special components developed 
for use in commercial systems 

5 km electrical coupling 
150 km optical coupling (global) 

PROFIBUS DP Communications network for the cell and 
field area 

5 km electrical coupling 
100 km optical coupling 

PROFIBUS PA PROFIBUS for process automation (PA) 1.9 km electrical coupling 
HART 
communication 

Sensors and actuators that use the HART 
protocol for data communication can 
communicate with the automation system 
over special modules. 

3 km 

Point-to-point 
coupling 

Communication between two nodes with 
special protocols 

Depends on the selected network 

MPI Multi-Point-Interface for testing and 
diagnostics 

15 m 

TIA solutions 
AS interface 
(ASI) 

Communication network on the lowest 
automation level for connecting to (usually 
binary) actuators and sensors to the 
programmable controller 

100 m 

instabus EIB Used to connect components in building 
automation 

1000 m 

MODBUS Used to connect components with the 
MODBUS interface 

Depends on component 

Additional information 
● Section "Which Networks/Bus Systems Are Used for Communication? (Page 78)" 
● Section "Maximum Transmission Rates of the Networks / Bus Systems (Page 80)" 
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4.4 Selecting fault-tolerant and fail-safe components 

4.4.1 Introduction 

Components 
The reaction of the plant to faults is an important aspect in process control engineering. 
Since the report of a fault is often not enough, the following components are an important 
part of process control engineering: 
● Fault-tolerant components 
● Fail-safe components 

Investment Costs 
The high investment costs for fault-tolerant and fail-safe components are negligible in 
comparison to the costs and losses involved in the loss of production. The higher the costs 
resulting from production stoppage, the more advisable the use of fault-tolerant and fail-safe 
components. 



Planning the Plant Engineering  
4.4 Selecting fault-tolerant and fail-safe components 

 Engineering System (V7.1) 
70 Configuration Manual, 03/2009, A5E02122455-01 

4.4.2 Redundancy Concept of PCS 7 

Fault-tolerant Components   
The use of fault-tolerant components in a process control system can minimize the risk of 
production loss. A redundant configuration guarantees fault tolerance in a process control 
system. This means that all components involved in the process have a backup in 
continuous operation. When a fault occurs or one of the control system components fails, the 
correctly operating redundant component takes over the continuing control task. 

Redundancy Concept 
The PCS 7 fault-tolerant components enable you to achieve the desired form of fault 
tolerance in all automation levels: 
● Operator stations, BATCH stations, Route Control stations, maintenance stations, central 

archive server (control level) 
● Bus system 
● Automation system (process level) 
● Distributed I/O (field level) 
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The following graphic shows the theoretical structure on the basis of a configuration with 
fault-tolerant components. 
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No. in figure Description 
1 Several clients (OS clients, BATCH clients, Route Control clients) can access data on a 

server (OS server, BATCH server, Route Control server). 
2 Communication between the operator stations (client and server) and communication 

with the engineering station is over a redundant, fault-tolerant terminal bus (Industrial 
Ethernet).  
The clients and server are connected to the terminal bus via switches.  

3 The servers (OS servers, BATCH servers, Route Control servers, maintenance 
servers, central archive servers) can be configured redundantly if needed.  

4 Automation systems communicate with the OS servers/Route Control servers and 
engineering stations and among themselves over the redundant, fault-tolerant plant 
bus (Industrial Ethernet).  
The automation systems, server and engineering station are connected to the plant 
bus via switches.  

5 Each part of the redundant, fault-tolerant S7-400H automation systems (AS 414H or 
AS 417H) is connected to the plant bus with an Ethernet communications processor 
(CP).  
Each part of the AS be connected to several PROFIBUS DP chains. The internal 
PROFIBUS DP interfaces or additional communications processors are used for the 
attachment. 

6 The redundant connection to the DP master system is achieved using two 153-2 IM 
modules in each ET 200M. 

7 You can evaluate the signals of sensors/actuators with redundant digital or analog 
input/output modules. If one of the two redundant modules fails, the input/output signal 
continues to be evaluated by the operational module. 

8 The PROFIBUS PA I/O is connected to the redundant PROFIBUS DP using FDC 157-
0 DP/PA couplers and two IM 153-2 modules. 
Through redundant DP/PA Links a redundant PROFIBUS PA is implemented . The 
field devices are connected to the PROFIBUS PA via active field distributors (AFD or 
AFS when ring/coupler redundancy is used). 

9 The Y Link allows you to connect non-redundant PROFIBUS distributed I/O devices to 
a redundant PROFIBUS DP. 

Additional information  
● Manual Process Control System PCS 7; Fault-tolerant Process Control Systems 
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4.4.3 Operating Reliability Concept of PCS 7 

Fail-safe Components     
Fail-safe automation systems are employed for PCS 7 when a fault could endanger human 
life, damage the plant or the environment. Fail-safe automation systems detect both errors in 
the process along with internal errors and automatically bring the plant to a safe state when 
a fault occurs.  

Operating Reliability Concept 
The fail-safe automation systems from PCS 7 can be configured single-channel (F system 
with one CPU) or redundant (FH system).  

 
 
No. in figure  Description 
1 The fail-safe S7-300 signal modules are connected via the ET 200M to the fail-safe 

S7-400F automation system (AS 414F or AS 417F). 
2 Fail-safe automation systems can also be configured redundantly. The fail-safe and 

fault-tolerant automation system S7-400FH (AS 414FH or AS 417FH) guarantees 
optimum availability and safety of the plant. 

3 Fail-safe S7-300 signal modules (F modules) can also be redundantly connected to 
further enhance the availability. 
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Safety Mechanisms 
The following safety mechanisms are part of the PCS 7 operating reliability concept: 
● The PROFIsafe profile is used for safety-related PROFIBUS DP communication between 

the F CPU and distributed I/O. The fail-safe automation systems and signal modules can 
recognize false user data and trigger the appropriate error responses with this safety 
frame. 

● Following programming (F program), the configured safety functions are processed twice 
in different processor sections of the CPU. Potential errors are detected in a subsequent 
comparison of the results. 

● Programming errors such as division by zero or a value overflow are intercepted by 
special fail-safe CFC blocks (F blocks). 

● The following functions increase the level of safety: 
– Comparison of F programs 
– Detection of modified F-programs per checksum 
– Password protected access authorization 

 

 
 

Note 
An error detected in the F program does not lead to a CPU stop but triggers a 
configurable response. It either brings the corresponding F runtime group or the entire 
F program into a safe state. 

 

Using Standard Components 
Standard modules can also be used in fail-safe automation systems in addition to fail-safe 
signal modules. 
A user program may contain both F programs and standard programs. They are decoupled 
with special conversion blocks. 

Certificates for S7-400F/FH (AS 414F/FH and AS 417F/FH) 
The fail-safe S7-400F/FH automation system used with PCS 7 has the following certification: 
● German Technical Inspectorate (TÜV) certificate for the safety classes SIL1 to SIL3 from 

IEC 61508 
● Requirement classes AK1 to AK6 from DIN V 19250/DIN V VDE 0801 
● Categories 2 to 4 of EN 954-1 

Using ET 200S 
ET 200S can also be connected with fail-safe power modules on distributed stations to a fail-
safe automation system S7-400F/FH. The fail-safe power module brings the electronic 
modules from ET 200S to a safe state. ET 200S supports the PROFIsafe profile on the 
PROFIBUS DP. 
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Add-ons for PCS 7 
 

 Note 
To learn which selected standard components can be integrated into a fail-safe automation 
system, refer to the catalog Add-ons for the Process Control System SIMATIC PCS 7 
(catalog ST PCS 7.1). 

 

Additional information  
● Manual SIMATIC Programmable Controllers S7 F/FH 
● Manual S7-300 Fail-safe Signal Modules 
● Manual SIMATIC ET 200S Distributed I/O System 
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4.4.4 Recommended Use of components 

Selection of the Components 
The safety and availability requirements are also decisive factors in the selection of fault-
tolerant and fail-safe components for a plant. The following table is a list of recommendations 
for selecting components according to the requirements of the system. 

 
Requirement: Low or none  Medium High/large 
AS 
Availability  Standard Proportion: 

SIMATIC H Systems 
(Page 139) 

SIMATIC H Systems 
(Page 139) 

Safety aspects Standard Proportion: 
SIMATIC F Systems 
(Page 141) 

SIMATIC F Systems 
(Page 141) 

Availability and safety 
aspects 

Standard Proportion: 
SIMATIC FH Systems 
(Page 141) 

SIMATIC FH Systems 
(Page 141) 

Distributed I/O 
Availability  ET 200M Two IM 153 in ET 200M Two IM 153 in ET 200M 

Redundant signal 
modules in ET 200M  

 DP/PA Link Two IM 153-2 and two DP/PA 
couplers in the DP/PA link 

Two IM 153-2 and two DP/PA 
couplers in the DP/PA link 

Safety aspects  ET 200M  Fail-safe signal 
modules in ET 200M  

Fail-safe signal 
modules in ET 200M  

 ET 200S Fail-safe power modules Fail-safe power modules 
Availability and safety 
aspects 

ET 200M Two IM 153 in ET 200M 
Fail-safe signal 
modules in ET 200M 

Two IM 153 in ET 200M 
Redundant fail-safe signal 
modules in  
ET 200M 

Bus systems 
Availability on the terminal 
bus and plant bus 

Industrial Ethernet: 
standard ring structure 

Industrial Ethernet: standard 
ring structure 

Industrial Ethernet: redundant 
ring configuration 

Availability on  
field bus  

PROFIBUS DP/PA Redundant  
PROFIBUS DP/PA 

Redundant  
PROFIBUS DP/PA 

HMI systems 
Availability – Data security PCS 7 OS,  

SIMATIC BATCH and 
SIMATIC Route Control 

Redundant servers for PCS 7 
OS,  
SIMATIC BATCH, SIMATIC 
Route Control, Maintenance 
and Central Archive 

Redundant servers for PCS 7 
OS,  
SIMATIC BATCH, SIMATIC 
Route Control, Maintenance 
and Central Archive 
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4.5 Selecting the network components 

4.5.1 Communication within PCS 7 

Introduction 
The communication within PCS 7 is based on SIMATIC NET network components that 
conform with established worldwide standards. SIMATIC NET includes powerful and robust 
components which were developed especially for industrial use. They have the following 
properties: 
● The components allow for the reliable exchange of data between all levels and 

components in the PCS 7 plant. 
● The components can be enhanced and expanded using standard components. 

SIMATIC NET 
SIMATIC NET contains the following components: 
● The communication network consists of the transmission medium, the corresponding 

connection and transmission components, and the respective transmission methods. 
● The protocols and services are used for data communication between the components. 
● The communication modules of the automation systems establish the connection to the 

communication network (e.g. communication processors CP). 

Additional information 
Refer to the following documentation for additional information regarding network 
architecture, network configuration, network components, and installation instructions: 
● List PCS 7 - Enabled modules 
● Manual SIMATIC NET NCM S7 for Industrial Ethernet 
● Manual SIMATIC Net PROFIBUS Networks 
● Manual SIMATIC NET; Triaxial Networks 
● Manual SIMATIC Net Twisted Pair and Fiber-Optic Networks 
● Operating Instructions Industrial Communication; Industrial Ethernet Switches 

SCALANCE X-400 
● Configuration Manual Industrial Communication; Industrial Ethernet Switches 

SCALANCE X-300 SCALANCE X-400 
● Operating Instructions Industrial Communication; Industrial Ethernet Switches 

SCALANCE X-200 
● Operating Instructions Industrial Communication; Industrial Ethernet Switches 

SCALANCE X-300 
● Manual Industrial Ethernet OSM/ESM; Network Management 
● Manual SIMATIC NET; AS Interface – Introduction and Basic Information 



Planning the Plant Engineering  
4.5 Selecting the network components 

 Engineering System (V7.1) 
78 Configuration Manual, 03/2009, A5E02122455-01 

4.5.2 Which Networks / Bus Systems Are Used for Communication? 

Networks / Bus Systems for Communication         
The following table shows you the network / bus systems used for communication between 
components in a PCS 7 plant.  

 
Communication 
between 

Operator 
station, 
Route 
Control 
station 

BATCH 
station  

Engineering 
Station 

AS Distributed I/O Intelligent field 
devices, sensors 
and actuators 

Operator Station, 
Route Control 
Station 

Ethernet Ethernet Ethernet Ethernet None None 

BATCH station Ethernet Ethernet Ethernet Ethernet via OS 
* 

None None 

Engineering Station Ethernet Ethernet Ethernet Ethernet Ethernet via AS Ethernet via AS  
AS Ethernet Ethernet via 

OS 
Ethernet Ethernet PROFIBUS DP PROFIBUS DP 

PROFIBUS PA 
HART, AS-i, 
KNX (EIB), H1 
(FF), Modbus via 
PROFIBUS DP 

Distributed I/Os None None Ethernet via 
AS 

PROFIBUS DP PROFIBUS DP via 
AS 

via AS 

Intelligent field 
devices, sensors 
and actuators 

None None Ethernet via 
AS 

PROFIBUS DP 
PROFIBUS PA 
HART, AS-i, 
KNX (EIB), H1 
(FF), MODBUS 
via  
PROFIBUS DP 

via AS None 

* With SIMATIC BATCH versions "AS based V6.1" and "AS based 7.0", direct Ethernet 
communication is used instead of communication via the OS. 
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4.5.3 Fields of Application and Parameters of the Network / Bus Systems 

Fields of Application / Parameters of the Networks / Bus Systems 
The following table provides an overview of the most important decision criteria for the use of 
network / bus systems: 

 
Bus System bus and 

terminal bus 
Field bus 

Network/ 
bus system 

Industrial 
Ethernet  

PROFIBUS DP PROFIBUS PA HART ASI 

Standards IEEE 802.3 IEC 61158-2 
EN 50170-1-2 

IEC 61158-2 
EN 50170-1-2 
ISA S50.2 

Conforming to 
Bell 202 standard 

IEC 62026 
EN 50295 

Transmission rate 
(Page 80) 

100 Mbps* 
1 Gbps* 

up to 12 Mbit/s 
depending on 
distance 

31.25 Kbps  1.2 Kbps (PTP) 
19.2 Kbps (Bus) 

Max. cycle time:  
5 ms (for 31 ASI 
slaves) 

Network size: 
• Electrical 

 
Up to 5 km*  

 
up to 9.6 km** 
(with a repeater)  

 
up to 1.9 km 

 
3 km (PTP) 
100 m (bus) 

 
max. 100 m 

• Optical up to 150 km* up to 90 km - - - 

• Wireless up to 1000 m* 15 m (with ILM) - - - 

• Global WAN with 
TCP/IP 

- - - - 

Topology Ring, line, star, 
tree, redundant  

Ring, line, star, 
tree, redundant 

Line, star, tree Line - direct 
connection to 
special input 
modules 

Line, star, tree 

Number of nodes: 
• Typical 

 
1023 per 
segment 

 
32 per segment  

 
32 per segment  
64 per DP/PA link 

 
1 node 

 
15 

• Maximum (unlimited) max. 125 max. 125 1 node max. 32 (31 slaves 
with max. 124 
binary elements) 

Specific parameter 
assignment 

Address and 
protocol; no bus 
parameters 

Data throughput 
and connection 
parameters 

Data throughput 
and connection 
parameters 

Parameter 
assignment for 
devices with 
SIMATIC PDM 

Connection using 
S7 configuration 

Special area of 
application 

- - Hazardous area - Analog sensors 
slave 
profile 7.3/7.4 

*) The max. network expansion depends on the network components used 
**) PROFIBUS DP segment with repeaters: you can find information on this in the section 
"Electrical Transmission Media (Page 98)". 
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4.5.4 Maximum Transmission Rate of the Network / Bus Systems 

Maximum Transmission Speeds 
The following table lists the maximum transmission rates of the networks / bus systems. The 
transmission rate depends on the network physics: 
● Electrical network: network installed with electrical conductive connections (copper cable) 
● Optical network: network installed with fiber-optic cables (FO) 
 
Network / bus 
system 

Electrical network Optical network Recommendation 

Industrial 
Ethernet 

max. 1 Gbps* max. 1 Gbps* Only use components 
with 100 Mbps or 1 
Gbps 

PROFIBUS DP Transmission rate for max. 
segment lengths: 
• 12 Mbit/s max. 60 m 
• 6 Mbit/s max. 60 m 
• 3 Mbit/s max. 100 m 
• 1.5 Mbit/s max. 200 m 
• 500 Kbit/s max. 400 m 
• 187.5 Kbit/s max. 700 m 
• 93.75 Kbit/s max. 900 m 
• 45.45 Kbit/s max. 900 m 
• 19.2 Kbit/s max. 900 m 
• 9.6 Kbit/s max. 900 m 

max. 12 Mbps 
• Used with plastic FO 

max. 400 m 
• Used with glass fiber 

FO max. 10 m 

We recommend the 
use of optical networks 
if interference 
immunity and control-
to-load isolation are 
important. 
You can find 
information about the 
correlation between 
transmission rate and 
distance for electrical 
networks in the section 
"Electrical 
Transmission Media 
(Page 98)" 

PROFIBUS PA 31.25 Kbps - The communication is 
carried out via the 
PROFIBUS DP. 
You can find 
information about this 
in the section 
"Connecting 
PROFIBUS DP to 
PROFIBUS PA 
(Page 106)" 
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Network / bus 
system 

Electrical network Optical network Recommendation 

HART 1.2 Kbps (PTP) 
19.2 Kbps (bus) 

- - 

ASI Max. cycle time: 
5 ms (for 31 ASI slaves) 

- The communication is 
carried out via the 
PROFIBUS DP. 
You can find 
information about this 
in the section 
"Connecting an AS 
Interface to 
PROFIBUS DP 
(Page 114)" 

*) SCALANCE X-400 Switches are suitable for 10/100/1000 Mbps (electrical or optical).  
(The DTEs are connected to the 10/100 Mbps ports.) 
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4.5.5 Terminal Bus and Plant Bus with Ethernet 

4.5.5.1 Management Level Scheme with Ethernet 

Isolation of the System Bus and the Terminal Bus       
 

 Note 
We recommend the isolation of the system bus and the terminal bus. For smaller 
configurations, however, this is not strictly necessary. 
The MES level should always be connected via a router. This prevents unauthorized access 
to the process control system. 
Additional information concerning the PCS 7 security concept can be found on the Internet 
(Page 174). 

 

Ethernet/Gigabit Ethernet 
The network components used in PCS 7 are Industrial Ethernet components modern 
Ethernet/Gigabit Ethernet technology. This means the following: 
● Communication speed of 100 Mbit/s (Fast Ethernet) 

or 1 Gbit/s (Gigabit Ethernet) 
● Using switching technology 
● Redundancy using optical/electric rings 

Connection of 10/100 Mbps Ethernet 
Components and units with 10 Mbps Ethernet (such as triaxial cable, OLM, star coupler) can 
be integrated into communication networks with 100 Mbps through SCALANCE X switches.  
Components and units with 100 Mbit/s Ethernet (automation devices, PC stations, 
SCALANCE X-200 switches) can be integrated into communication networks with 1 Gbit/s 
through SCALANCE X-400 switches. 
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Components Used for PCS 7 
Network nodes are connected to switches by network cables. The following components 
from the SIMATIC NET product range are used: 
● SCALANCE X switches 
● Optical switch module (OSM) 
● Electrical switch module (ESM) 
Used for data transmission: 
● Twisted pair cables (ITP or TP) 
● Fiber-optic cable (FO) 
● Coaxial and triaxial cables 

Additional information 
● Section "Data Paths over the Terminal Bus and System Bus (Page 174)" 
● Whitepaper Security Concept PCS 7 and WinCC 

See also 
Security concept (http://support.automation.siemens.com/WW/view/en/28580051) 

http://support.automation.siemens.com/WW/view/en/28580051
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4.5.5.2 Using Switching Technology with SCALANCE X 

SCALANCE X       
SCALANCE X is the switch product family of Industrial Ethernet switches from 
SIMATIC NET. Switches are active network components that distribute data to targeted 
addressees.  

Ring with redundancy manager 
To increase availability, optical/electrical line topologies involving up to 50 switches (IE 
Switches X-400, SCALANCE X-200 or OSM/ESM) can be combined with a 
SCALANCE X414-3E or SCALANCE X408-2 and connected in a ring. 

SCALANCE X switches used with PCS 7 
● SCALANCE X414-3E 

SCALANCE X414-3E with two Gigabit Ethernet ports for installing a plant bus and 
terminal bus in optical or electrical Gigabit ring technology; enables the highest 
communication performance, especially in large plants handling large quantities and with 
extensive communication networks 
The redundancy manager integrated in the SCALANCE X414-3E enables the 
configuration of redundant ring structures. A standby connection is possible using 
software. 

● SCALANCE X408-2 
SCALANCE X408-2 with four Gigabit Ethernet ports for installing a plant bus and terminal 
bus in optical or electrical Gigabit ring technology; enables the highest communication 
performance, especially in large plants handling large quantities and with extensive 
communication networks 
The redundancy manager integrated in the SCALANCE X408-2 enables the configuration 
of redundant ring structures. A standby connection is possible using software. 

● SCALANCE X310 
SCALANCE X310 with three electrical Gigabit Ethernet ports and seven electrical Fast 
Ethernet interfaces for configuration of ring structures; enables the highest 
communication performance, especially in large plants handling large quantities and with 
extensive communication networks. 
The redundancy manager integrated in the SCALANCE X310 enables the configuration 
of redundant ring structures. 

● SCALANCE X308-2 (-2LD) 
SCALANCE X308-2 (-2LD) with three electrical and two optical Gigabit Ethernet ports 
and seven electrical Fast Ethernet interfaces for configuration of ring structures; enables 
the highest communication performance, especially in large plants handling large 
quantities and with extensive communication networks. 
The redundancy manager integrated in the SCALANCE X308-2 (-2LD) enables the 
configuration of redundant ring structures. 
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● SCALANCE X202-2IRT 
SCALANCE X202-24IRT with 2 electrical and 2 optical ports (up to 100 Mbit/s) for use in 
subsystem networks with strict real-time requirements (Isochronous Realtime) and 
maximum availability.  
Data traffic with no real-time requirement can take place on the same network.  
Duplicate network structures are therefore not required. 
The redundancy manager integrated in the SCALANCE X202-2IRT enables the 
configuration of redundant ring structures. 

● SCALANCE X208 
SCALANCE X208 with 8 ports for transmission rates up to 100 Mbit/s, suitable for 
electrical Industrial Ethernet structures in linear, star or ring configurations. 

● SCALANCE X204-2 
SCALANCE X204-2 with 2 optical and 4 electrical ports for transmission rates up to 100 
Mbit/s, suitable for optical Industrial Ethernet structures in linear or ring configuration. 

SCALANCE X media converters used with PCS 7 
● SCALANCE X101-1 or SCALANCE X101-1LD 

SCALANCE X101-1 or SCALANCE X101-1LD with one electrical and one optical port for 
transmission rates up to 100 Mbps as an Industrial Ethernet media converter 

Selection of the SCALANCE X Variants 
 
Switch Port type and number Redundancy 

Manager 
Standby 
Manager 

 Gigabit Ethernet Ethernet (10/100 Mbps)   
 10/100/1000 Mbit/s Sub D (ITP) RJ45 

(TP) 
Multimode 
FO 

Single mode 
FO 

  

X414-3E4) 2 x TP or 
2 x 1 Gbps FO 

- 12/201) 42)/121) 43)/121) Yes Yes 

X408-24) 4 x TP or 
4 x 1 Gbps FO 

- 4 4 4 Yes Yes 

X310 3 x TP - 7 - - Yes Yes 
X308-2  3 x TP or 

2 x 1 Gbit/s FO 
- 7 2 - Yes Yes 

X308-2LD 3 x TP or 
2 x 1 Gbit/s FO 

- 7 - 2 Yes Yes 

X204IRT - - 4 - - Yes5) Yes5) 
X202-2IRT - - 2 2 - Yes5) Yes5) 
X208 - - 8 - - No6) No 
X204-2 - - 4 2 - No7) No 
X101-1 - - 1 1 - No No 
X101-1LD - - 1 - 1 No No 

1) Including extension module 
2) Can be stacked with 2 multimode media modules 
3) Can be stacked with 2 single-mode media modules 
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4) Fiber optic modules for optical connection 
 100 Mbit/s: MM491-2 Fast Ethernet fiber optic module (100Base FX)  
 1000 Mbit/s: MM492-2 Gigabit media module (1000Base-FX)  
5) Redundancy manager and standby manager cannot be run at the same time 
6) 6GK5208-0BA10-2AA3 and higher -> Yes 
7) 6GK5204-2BB10-2AA3 or 6GK5204-2BC10-2AA3 and higher -> Yes 

Example of Switching Technology with SCALANCE X 
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Additional information 
● Section "Data Paths over the Terminal Bus and System Bus (Page 174)" 
● Manual Process Control System PCS 7; Fault-tolerant Process Control Systems 
● Operating Instructions Industrial Communication; Industrial Ethernet Switches 

SCALANCE X-400 
● Configuration Manual Industrial Communication; Industrial Ethernet Switches 

SCALANCE X-300 SCALANCE X-400 
● Operating Instructions Industrial Communication; Industrial Ethernet Switches 

SCALANCE X-200 
● Operating Instructions Industrial Communication; Industrial Ethernet Switches 

SCALANCE X-300 
● Operating Instructions Industrial Communication; Industrial Ethernet SCALANCE X-100 

and SCALANCE X-200 product line 
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4.5.5.3 Using Switching Technology with OSM/ESM 

Using Optical Switch Modules (OSM) and Electrical Switch Modules (ESM) 
OSM/ESMs allow the configuration of "switched networks" with 100 Mbps that meet stringent 
requirements for availability and comprehensive diagnostics.  
Two measures are employed to decouple the load on the networks thereby leading to an 
increase in network performance: 
● Formation of segments, i.e., dividing the networks in subnetworks/segments 
● Connecting each segment to an OSM/ESM 
An OSM/ESM disposes of additional ports (with RJ45, ITP or BFOC interfaces as options) to 
which terminals and additional network segments can be connected. 
The redundancy manager integrated in the OSM/ESM enables configuration of redundant 
ring structures.  
Up to 50 OSM (optical ring) / ESM (electrical ring) can be used per ring. 

Selecting OSM, OMC, and ESM Variants 
 
Switch Port type and number Preference 
 Sub D 

(ITP) 
RJ45 
(TP) 

Multi- 
mode 
FO 

Single
mode 
FO 

High EMC load Plant bus Terminal bus 

OSM TP22 - 2 2 - x 
TP cable in 
switchgear cubicle 

x x 

OSM ITP62 
(standard)* 

6 - 2 - x x x 

OSM TP62* - 6 2 - - x x 
OSM ITP62-LD* 6 - - 2 x x x 
OSM ITP53 5 - 3 - x x 

Cross-building 
connection 

X 
Cross-building 
connection 

OSM BC08 - - 8 - x 
TP cable 
(max. 6 m) in the 
cubicle 

x 
TP cable  
(max. 6 m) in the 
cubicle 

x 
TP cable  
(max. 6 m) in the 
cubicle 

ESM ITP80 8 - - - x x 
Within buildings 

x 

ESM TP40 - 4 - - - x 
Within switchrooms 

x 

ESM TP80* - 8 - - - X 
Within switchrooms 

x 

* OSM TP62 and ESM TP80 can be used as redundancy/standby managers. 
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Example of Switching Technology with OSM/ESM 

OSMOSM
OSM TP62

OSMOSM
OSM TP62

OSMOSM
OSM TP62

OSMOSM
OSM TP62

 

Additional information 
● Section "Data Paths over the Terminal Bus and System Bus (Page 174)" 
● Manual Industrial Ethernet OSM/ESM; Network Management 
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4.5.5.4 Optical and Electrical Transmission Media 

Optical transmission media 
Glass fiber-optics are preferably used as the optical transmission media. PCS 7 offers 
standard cables that are suitable for above-ground installation indoors and outdoors.  
Standard cables can be supplied pre-assembled with fixed lengths,  
● With 2 x 2 BFOC connectors (fiber-optic standard cable) 
● With 2 x 2 SC connectors (FO standard cable) The FO standard cable with 2 x 2 SC 

connectors is required for optical networks in the Gigabit range. 

Electrical Transmission Media 
The terminals are connected with Industrial Twisted Pair (ITP). Prefabricated cable or 
meterware (ITP standard cable) in a variety of designs are offered with sub D connectors to 
allow direct connection between the nodes and network components. 
Terminals can be optionally connected with twisted pair (TP) using so called TP cord cables. 

Additional information 
● Manual SIMATIC Net Twisted Pair and Fiber-Optic Networks 
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4.5.5.5 Connecting Network Nodes to Ethernet 

Bus Connection of AS and PC Stations           

Industrial

E
th

e
rn

e
t

 

Connection of the AS 
The automation system is connected to Industrial Ethernet via TCP/IP or ISO via the 
communication processor CP 443-1 or via the Ethernet interface of the CPU. 
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Connecting PC Stations 
Operator stations, BATCH stations, Route Control stations, maintenance stations, the central 
archive server, OpenPCS 7 station, and engineering stations are connected to Industrial 
Ethernet via communication modules. The communication modules require a slot in the PC 
or programming device (PG). Depending on the requirements, different types of 
communication modules are used: 
● Communication modules without an onboard processor (Basic Communication Ethernet - 

BCE) are sufficient for connecting up to 8 lower-level automation systems (of one 
operator station). As an alternative, they can also be connected over the following 
components: 
– Ethernet card supplied with the PC/PG 
– Desktop adapter network card (Intel PRO/1000 GT, Intel PRO/1000 PT) 

● If the maximum number of 8 automation systems per operator station is not enough or if 
fault-tolerant automation systems are connected, communication modules with onboard 
processors can be used: 
– CP 1613/CP 1623 with S7-1613 software 
– CP 1613/CP 1623 with S7 REDCONNECT software for redundant communication 

with S7-400H/FH 
 

 
 

Note 
Communication can be established with up to 64 automation systems (including 
redundant systems) using CP 1613/CP 1623. 

 

Time-of-Day Synchronization 
CP 443-1 and CP 1613/CP 1623 support time synchronization over Industrial Ethernet. A PC 
with a CP 1613/CP 1623 can receive time frames from the following time transmitters: 
● SIMATIC S7-400/H/FH with CP 443-1 
● SIMATIC NET real-time transmitter for Industrial Ethernet (for information see catalog IK 

PI) 
● SIMATIC SICLOCK 
● PC with CP 1613/CP 1623 
You will find additional information on this topic in Function Manual Process Control System 
PCS 7; Time Synchronization. 

Additional information 
● Section "Data Paths over the Terminal Bus and System Bus (Page 174) 
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4.5.5.6 Configuring Redundant Ethernet Networks 

Redundant System Bus / Terminal Bus         
The following communication solutions increase the availability by eliminating individual 
errors: 
● Redundant electrical network 
● Redundant optical network 
● Combined redundant network 

Application of the Ring Structure 
Redundancy can also be achieved by means of a ring structure configuration: 
● Single ring (see example of a fault-tolerant system bus) 
● Double ring (see example of a redundant fault-tolerant system bus) 

An additional ring with SCALANCE X and two interface cards for each connected 
component (for example AS, OS) increases the level of availability. 

Example of a Fault-tolerant System Bus 
The following figure shows a fault-tolerant system bus in ring structure. All components are 
configured redundantly, except the system bus.  
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Example of a Redundant Fault-tolerant System Bus 
The following figure shows a redundant, fault-tolerant system bus with a ring structure. All 
components are configured redundantly.  

 

Switches 
All switches (SCALANCE X-400/-300/-200/OSM/ESM) feature 2-ring ports to enable 
connection to double Ethernet ring structures. With OSM and ESM, the relevant pair is 
synchronized via a synchronization line. 

Additional information 
● Section "Using Switching Technology with SCALANCE X (Page 84)" 
● Section "Using Switching Technology with OSM/ESM (Page 88)" 
● Manual Process Control System PCS 7; Fault-tolerant Process Control Systems 
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4.5.5.7 Planning Diagnostics for Ethernet 

Diagnostic Functions of OSM/ESM 
The following diagnostic functions are available when SCALANCE X/OSM/ESM is used: 
● SCALANCE X/OSM/ESM examines the state of its Ethernet network in segments. 
● SCALANCE X/OSM/ESM detects communication errors, reports them to other 

SIMATIC NET network components and sets its own fault LED. 

Additional Diagnostic Tools and Information 
Additional tools are available for network diagnostics. Refer to the configuration manuals 
Process Control System PCS 7; Operator Station and the manual Process Control System 
PCS 7; Service Support and Diagnostics to learn about other diagnostic tools you can use 
for commissioning and the process mode. 
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4.5.6 Field Bus with PROFIBUS 

4.5.6.1 Planning the Field Level with PROFIBUS 

PROFIBUS in a PCS 7 Plant 
PROFIBUS is used exclusively on the field level of PCS 7. The following PROFIBUS profiles 
are used: 
● PROFIBUS DP - for communication between the AS and distributed I/O 
● PROFIBUS PA (according to IEC 61158) - for direct connection bus-capable intelligent 

field devices 

Components Used for PCS 7  
PROFIBUS can be operated with the following combinations of transmission media for a 
wide variety of applications: 
● Shielded two-wire cable - for electrical data transmission 
● Fiber-optic cable (FO) - for optical data transmission 
PROFIBUS networks can be configured using the following components based on the 
transmission medium used and the devices to be connected: 
● Optical Link Module (OLM) 
● Optical Bus Terminal (OBT) 
● Y link 
● DP/PA coupler and DP/PA link 
● Diagnostic repeaters 
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● RS 485-Repeater 
● RS 485 terminating element 
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4.5.6.2 Electrical Transmission Media 

Introduction       
Shielded, twisted pair cables are used as the transmission media for electrical PROFIBUS 
networks. PROFIBUS nodes are connected to bus lines via a bus terminal with a spur line or 
bus cable connectors.  

PROFIBUS segment 
A PROFIBUS segment is formed by a bus cable terminated at both ends with surge 
impedance. The individual PROFIBUS segments are connected together with repeaters. The 
maximum segment line length depends on the following factors: 
● Transmission rate 
● Type of line used 
The maximum line length for a PROFIBUS segment is limited. You can find information 
about this in the section "Maximum Transmission Rates of the Networks / Bus Systems 
(Page 80)".  

RS 485-Repeater 
The RS 485 repeater is a signal amplifier. It allows the cable length to be increased. A 
maximum of 9 RS 485 repeaters can be connected in series. The following line lengths are 
possible between two nodes for RS 485 repeaters: 
 
Transmission 
rate 

Max. length of cable between 2 nodes  
(with 9 RS 485 repeaters connected in series) 

9.6 to 187.5 Kbps 10,000 m 
500 kbit/s 4,000 m 
1.5 Mbps 2,000 m 
3 to 12 Mbps 1,000 m 

Active RS 485 Terminating Element 
All PROFIBUS segments are terminated at both ends based on the transmission rate. An 
RS 485 terminating element is used as a permanent line termination to terminate the 
PROFIBUS segments. 

RS 485-iS Coupler 
The RS 485-iS- coupler is an isolating transformer used for intrinsically safe transfer of 
PROFIBUS DP in hazardous areas (potentially explosive atmosphere).  
The RS 485-iS coupler is required to connect intrinsically safe PROFIBUS DP nodes, for 
example, ET 200iSP or third-party devices with Ex i DP connection, to PROFIBUS DP. The 
RS 485-iS coupler can also be used as a repeater in hazardous areas. 
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Additional information 
● Manual SIMATIC Net PROFIBUS Networks 
● Manual SIMATIC, Distributed I/O Device ET 200 iSP 
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4.5.6.3 Optical Transmission Media 

Recommendation        
 

 Note 
Recommendation: fiber-optics are preferred for long distances or when connecting between 
buildings. 

 

Glass fiber-optics or plastic fiber-optics are used as the transmission media for optical 
PROFIBUS networks.  

Glass Fiber Optics 
PCS 7 offers standard cables for glass fiber-optics with a compatible connector set (20 
BFOC connectors) that are suitable for indoor and outdoor lines. 

Plastic Fiber Optics 
PCS 7 offers standard cables for plastic fiber-optics with compatible plug adapters that are 
suitable for indoor lines: 
The maximum cable length between two PROFIBUS DP devices is 400 m. 

SCALANCE X100 media converters 
SCALANCE X100 media converters enable the configuration of optical and combined 
(electrical/optical) networks: 
● SCALANCE X101-1 

the maximum transmission range (segment length) is 3 km 
● SCALANCE X101-1 LD 

the maximum transmission range (segment length) is 26 km 

Optical Link Module (OLM) 
OLMs enable the configuration of optical and combined (electrical/optical) networks: 
● The OLM features an RS 485 interface and 2 fiber-optic interfaces. 
● The distance between two OLMs is a maximum of 15 km. 
● The fiber optic line distance is a maximum of 3 km. 

Optical Bus Terminal (OBT) 
The OBT allows a PROFIBUS DP node with integrated optical interface to be connected to 
an RS 485 segment or PROFIBUS DP node without integrated optical interface. 
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Using Fiber-optics and OBTs for S7-400F/FH 
Fiber-optics and OBTs are recommended for fail-safe automation systems (with F modules 
only) to fulfill the requirements of safety level SIL 3. ET 200M is connected to the electrical 
bus line of the PROFIBUS DP through an OBT using fiber-optics.  
Safety SIL 3 has the advantage that no isolation module is needed to isolate signals 
between IM 153-2 and F modules when a direct, electrical connection is made.  

 

Additional information 
● Manual SIMATIC Net PROFIBUS Networks 
● Manual SIMATIC Net Twisted Pair and Fiber-Optic Networks 
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4.5.6.4 Connecting PROFIBUS DP Nodes 

Bus connection of AS, ET 200M, ET 200S, ET 200iSP, and ET 200pro 

 

Connection of the AS 
Automation systems are connected to PROFIBUS DP over the following components:  
● CP 443-5 Extended 
● Internal PROFIBUS DP interface of the CPU 
The PROFIBUS DP lines can be connected to a maximum of 4 internal PROFIBUS DP 
interfaces per automation system (with add-on modules depending on the CPU) and also to 
a maximum additional 10 CP 443-5 Extended. IF 964-DP interface modules are available for 
the PROFIBUS DP interfaces. These can be installed in the open module slots of the CPU. 

Connection of ET 200M, ET 200S, ET 200iSP, and ET 200pro 
Bus connectors in a variety of designs are used to connect ET 200M, ET 200S, ET 200iSP, 
and ET 200pro to PROFIBUS DP. The desired connectors can be ordered together with the 
ET 200 components. 
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4.5.6.5 Configuration of PROFIBUS DP Networks 

Redundant PROFIBUS DP 
The fault-tolerant automation system S7-400H features a PROFIBUS DP master interface on 
each CPU for connecting to the PROFIBUS DP. For switched distributed I/O, the PROFIBUS 
DP is connected to the I/O device through two IM 153-2 interface modules. 
Configuration options: The following fault-tolerant communication solutions are offered for 
PROFIBUS DP: 
● Redundant PROFIBUS DP as an electrical network 
● Redundant optical network with OLM with line, ring and star structure 

Example for Redundant PROFIBUS DP 
The following illustration depicts an electrical network with redundant PROFIBUS DP. 
The communication from the sensor to the H system is taken over by the redundant bus 
connection when the active bus connection fails. 

 

Additional information 
● Manual Process Control System PCS 7; Fault-tolerant Process Control Systems 



Planning the Plant Engineering  
4.5 Selecting the network components 

 Engineering System (V7.1) 
104 Configuration Manual, 03/2009, A5E02122455-01 

4.5.6.6 Connecting Non-Redundant PROFIBUS DP Devices to Redundant PROFIBUS DP 

Y link       
To implement the changeover from a PROFIBUS master system to a single-channel 
PROFIBUS master system, the Y link is preferred as the gateway.  

Configuring the Y Link 
The Y link consists of two IM 153-2 interface modules and a Y coupler. The Y coupler is a 
component of the Y link and is used to connect the lower-level PROFIBUS DP to the DP 
master in the IM 153-2.  
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 Note 
Use only the active backplane bus module when configuring the Y link . 

 

Properties of the Y link 
● When a fault occurs, the Y link bumplessly switches the complete I/O line to the active 

PROFIBUS DP of the redundant H system. 
● From the point of view of the programmable controller, the Y link is a DP slave, and from 

the point of view of the underlying DP master system, it is a DP master. 
● Transmission rates: 

– for the connection to the H system: from 9.6 Kbps to 12 Mbps 
– for the switched PROFIBUS DP: from 187.5 Kbps to 1.5 Mbps 

● Capacity: 
– The number of Y links on an S7-400H is only limited by the maximum number of bus 

nodes, 126. 
– The number of nodes in each underlying DP master system is limited to 64. 
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● Supports configuration changes in RUN (CiR) 
● Modular design mounted on an S7-300 rail with an active backplane bus 
● Isolation between the lower-level DP master system and power supply via the RS-485 

repeater 
● Degree of protection IP 20 (Degree of Protection) (Page 726)) 

Additional information 
● Manual DP/ PA Link and Y Link Bus Couplings 
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4.5.6.7 Connecting PROFIBUS PA to PROFIBUS DP 

DP/PA Link 
The DP/PA link is the preferred gateway between PROFIBUS DP and PROFIBUS PA.  

Configuration of the DP/PA Link 
DP/PA link consists of two IM 153-2 interface modules and up to 5 DP/PA couplers. A 
DP/PA Link can be connected to the redundant PROFIBUS DP using two IM 153-2 modules. 

DP/PA Coupler 
The DP/PA coupler is a physical link between PROFIBUS DP and PROFIBUS PA. The 
DP/PA coupler is available in both Ex and Non-ex variations. 
When few numbers are involved, the real-time requirements are not important, and no 
redundant PROFIBUS DP is used, the DP/PA coupler can also be operated in "stand-alone" 
mode (without IM 153-2). 

 

Communication via PROFIBUS PA 
PROFIBUS PA uses the same communication protocol as PROFIBUS DP; communication 
services and frames are identical.  
Each PROFIBUS PA segment must be terminated by a SpliTConnect terminator. 
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Properties of the DP/PA Link 
● When a fault occurs, the DP/PA link bumplessly switches to the active PROFIBUS DP of 

the redundant H system. 
● Modules can be "hot swapped" during online operation when a special bus module is 

used. 
● Capacity: 

– A maximum of 5 DP/PA couplers can be connected to a DP/PA link. 
– The number of nodes in each underlying PROFIBUS PA is limited to 64. 

● Supports configuration changes in RUN (CiR) 
● Isolation of the higher-level DP master system 
● Suitable for connecting sensors/actuators in the areas with explosion danger (hazardous 

areas) 
● Configuration, commissioning and diagnostics of DP/PA link and connected field devices 

with the SIMATIC PDM tool integrated in the ES 

DP/PA Link or DP/PA Coupler 
The use of a DP/PA link or DP/PA coupler depends on the following factors: 
● Size of the plant 
● Required performance 
● Automation system in use 
 
Components DP/PA Coupler DP/PA Link 
Structure • Stand-alone operation without 

additional components 
possible 

• Integrated power supply and 
bus terminal for 
PROFIBUS PA 

The DP/PA link is built from a 
combination of: 
• Interface module IM 153-2 and 
• DP/PA coupler  

(max. 2 with standard model or 
max. 5 for hazardous zone) 

Use and performance  For small number of devices and 
low real-time requirements 

For extensive addressing volumes 
and high cycle time requirements 

Transmission 
rate 

• at the DP end: 45.45 Kbit/s 
• at the PA end: 31.25 Kbps 

• at the DP end: from 9.6 Kbit/s to 
max. 12 Mbit/s 

• at the PA end: 31.25 Kbit/s 

Function When using the DP/PA coupler, 
the field devices are addressed 
directly by the automation system; 
in other words the DP/PA coupler 
is transparent. 

Field devices are addressed by the 
automation system indirectly through 
the DP/PA link (DP slave). 

Housing safety level Designs for hazardous areas are 
available. 
Only sensors and actuators can 
be used in the hazardous zone! 

Designs for hazardous areas are 
available.  
Only sensors and actuators can be 
used in the hazardous zone! 
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Components DP/PA Coupler DP/PA Link 
Redundancy - A configuration with two IM 153-2 

modules enables use in an H system. 
Diagnostics Via LED Via diagnostic frame and LED 

Additional information 
● Manual DP/ PA Link and Y Link Bus Couplings 
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4.5.6.8 Configuration of Redundant PROFIBUS PA Networks 

Redundant PROFIBUS PA 
PROFIBUS PA can be configured as redundant to supplement the redundant PROFIBUS 
DP. 
A redundant PROFIBUS PA is connected to redundant DP/PA couplers. If a communication 
path fails, the communication path is preserved as far as the spur line to the field devices. 

Redundant Communication Solutions 
The following communication solutions are offered to increase the system availability: 
● Ring redundancy with AFD (Active Field Distributor) 
● Coupler redundancy with AFS (Active Field Splitter) 
The FDC 157-0 DP/PA coupler can be used stand-alone or in the DP/PA Link. 
A maximum of 2 redundant PROFIBUS PA can be connected per DP/PA Link. 

Connecting the Redundant PROFIBUS PA to PROFIBUS DP 
You can connect the redundant PROFIBUS PA to the PROFIBUS DP as follows:  
● Redundant connection to the redundant PROFIBUS DP with two IM 153-2 
● Single-channel interfacing with PROFIBUS DP using one IM 153-2 
The following configuration limits apply when connecting PA devices using AFD or AFS: 
● Maximum of 8 AFD at a redundant DP/PA coupler, maximum of 4 field devices per AFD 

(one field device per spur line) 
● 1 AFS to a redundant DP/PA coupler, maximum 31 field devices on the AFS 



Planning the Plant Engineering  
4.5 Selecting the network components 

 Engineering System (V7.1) 
110 Configuration Manual, 03/2009, A5E02122455-01 

Example of a Fault-tolerant PROFIBUS PA 
The connections of the field devices via AFD and AFS are shown in the following figure. The 
connection to PROFIBUS DP is shown as a redundant link. 

 

Additional information 
● Manual Process Control System PCS 7; Fault-tolerant Process Control Systems 
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4.5.6.9 Planning Diagnostics for PROFIBUS 

Diagnostic repeaters 
We recommend the use of diagnostic repeaters to provide detailed diagnostics for 
PROFIBUS DP segments (copper cable). When a fault occurs it sends a diagnostic alarm to 
the DP master with detailed information about the type of fault and the location. 
Principle: To be able to localize a problem in the network, the diagnostic repeater must know 
the topology of the PROFIBUS subnet to which it is attached. With the function "Prepare Line 
Diagnostics", the diagnostics repeater determines the distances to all nodes and saves the 
data internally in a table. By calculating the distance to a line fault, the repeater can then 
identify the nodes between which the fault is located based on the table. 

Ex
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Properties of the Diagnostics Repeater 
The diagnostics repeater has the following features: 
● Diagnostic function for two PROFIBUS segments 

The diagnostic function localizes both the position and the cause of the error for cable 
errors, such as cable rupture or missing terminating resistors. 

● Repeater function for three PROFIBUS segments 
The diagnostic repeater amplifies data signals on bus cables and connects individual 
RS 485 segments. 

● Transmission rate: From 9.6 Kbps to 12 Mbps  
You can also find information about this in the section "Maximum Transmission Rates of 
the Networks / Bus Systems (Page 80)" 

● Cable length 
When standard cables are used, the diagnostic repeater can monitor a maximum of 100 
meters of cable in each PROFIBUS segment. 

 

 
 

Note 
Only use the active backplane bus module. 

 

Additional information 
● Manual SIMATIC Diagnostic Repeater for PROFIBUS-DP 
● Manual Process Control System PCS 7; Service Support and Diagnostics 
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4.5.7 Data Links to Other Systems 

4.5.7.1 Introducing How to Couple Data with other Systems 

Introduction 
Within the context of PCS 7, Totally Integrated Automation (TIA) provides solutions for 
configuring a wide range of communication tasks.  

Potential Communication Partners 
TIA solutions are available for devices and plants that communicate with the following 
protocols: 
● AS interface (Page 114) 
● KNX (Instabus EIB) (Page 116) 
● MODBUS (Page 117) 
● H1 Bus (Fieldbus Foundation) (Page 118) 
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4.5.7.2 Connecting the AS Interface to PROFIBUS DP 

AS interface (ASI)  
The actuator sensor interface (AS interface) is a heterogeneous network system for simple, 
usually binary actuators and sensors at the lowest field level. The AS interface is an 
international standard based on EN 50 295. 
The AS interface allows you to address all connected sensors and actuators on a 
common 2-wire cable while at the same time supplying them with the required power.  

Connecting the AS Interface to PROFIBUS DP 
The AS interface is connected to PCS 7 through a DP/AS interface link to the PROFIBUS 
DP.  
The AS interface is integrated in PCS 7 as an underlying bus through the DP/AS interface 
link. This does not permit use of the full range of PCS 7 features (no diagnostics capability, 
for example). 
The AS interface operates according to the master slave principle. The sensors/actuators 
connected through the AS interface line are treated as slaves by the master DP/AS interface 
link. 
DP/AS interface link is a DP slave from the point of view of the DP master system.  
The PROFIBUS DP and AS interface are electrically isolated. 

INTERFACE

DP/AS-i Link Advanced
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DP/AS Interface Link 
The following DP/AS interface links can be used: 
● DP/AS INTERFACE LINK Advanced with IP20 degree of protection 
● DP/AS Interface link 20E with IP20 degree of protection 
All DP/AS interface links can be operated on the PROFIBUS DP with a maximum 
transmission rate of 12,000 kbits.  
The following is required for configuration:  
● Power supply 
● PROFIBUS connector plug 
● AS interface connecting sockets 

Connecting ET 200M to an AS Interface 
An ET 200M (on the PROFIBUS DP) can also be connected to the AS interface through the 
AS interface master module, CP 343-2. 

Additional information 
● Manual SIMATIC NET DP/AS INTERFACE LINK Advanced 
● Manual SIMATIC NET DP/AS Interface Link 20E 
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4.5.7.3 Connecting KNX (Instabus EIB) to PROFIBUS DP 

KNX (instabus EIB)  
Instabus EIB (European Installation Bus) is an open standard for building automation. 

Connecting KNX to PROFIBUS DP 
KNX is connected to PCS 7 through a DP/EIB link on the PROFIBUS DP.  
KNX is integrated in PCS 7 as an underlying bus through the DP/EIB link. This does not 
permit use of the full range of PCS 7 features (no diagnostics capability, for example). 
The DP/EIB link is a DP slave from the point of view of the PROFIBUS DP master system. 

0 1

0

Phys. Adr.

0 7
0 0 0 0

0 0 0 0

Power

EIB24V

PROFIBUS
Addr.

DP/EIB-Link

6GK1415-0AA00
instabus EIB

s

DP/BF

EIB/BF

KNX R

 

DP/EIB Link 
The following DP/EIB links can be used: 
● DP/EIB link with IP20 degree of protection 

Additional information 
● Manual SIMATIC NET DP/EIB Link 
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4.5.7.4 Connecting MODBUS to PROFIBUS DP 

 MODBUS 
MODBUS is an open serial communication protocol. The Modbus protocol is used to network 
third-party systems. Due to the maximum transmission rate of 38.4 Kbps, Modbus is 
recommended when there are few bus nodes and low real-time requirements. 

Connecting MODBUS to PROFIBUS DP  
Modbus is connected to PCS 7 via a CP 341 which is inserted in the distributed I/O station 
ET 200M. The quicker exchange of data is possible via the CP 341 using point-to-point 
coupling with Modbus protocol. 

CP 341 
The CP 341 is available in the following 3 models (interface physics): 
● RS 232C (V.24) 
● 20 mA (TTY) 
● RS 422/RS 485 (X.27) 
Special drivers are needed for Modbus master and Modbus slave to implement the Modbus 
link. These must be ordered separately. 

Additional information 
● Manual SIMATIC CP 340 Point-to-Point; Installation and Parameter Assignment 
● Manual SIMATIC Loadable Drivers for PtP CPs; MODBUS Protocol RTU Format; S7 is 

Master 
● Manual SIMATIC Loadable Drivers for PtP CPs; MODBUS Protocol RTU Format, S7 is 

Slave 
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4.5.7.5 Connecting the H1 Bus (Fieldbus Foundation) to PROFIBUS DP 

Foundation Fieldbus H1 
Foundation Fieldbus H1 uses the same physical bus characteristics as PROFIBUS PA 
confirming to IEC 61158-2 with a transmission rate of 31.25 Kbps. This technology enables 
you to network intrinsically safe, bus-powered FF devices (H1 bus components with FF 
interface). The voltage provided by the bus to supply the devices is superimposed by an 
information signal from the respective transmitting device. 

Connecting the H1 Bus to PROFIBUS DP  
The H1 Bus is connected to PROFIBUS DP via a DP/FF link. 
H1 is integrated in PCS 7 as an underlying bus through the DP/FF link.  
The DP/FF link is a DP slave from the point of view of the PROFIBUS DP master system. 

FieldbusTM

F  o  u  n  d  a  t  i  o  n

 

DP/FF Link 
The following DP/FF links can be used: 
● DP/FF Link 



 Planning the Plant Engineering 
 4.5 Selecting the network components 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 119 

4.5.8 Administration level and remote access 

4.5.8.1 Connecting to MIS/MES 

Connection Options to MIS/MES    
The following options are available to connect MIS/MES systems to SIMATIC PCS 7: 
● Connecting to the IT world - SIMATIC IT (Page 120)  
● Connecting HMI Systems via OPC (Page 122)  
● Connecting to the IT world via OpenPCS 7 (Page 123)  
● Access to the PCS 7 OS via WebNavigator client (Page 125)  

Additional information 
 

 Note 
When connecting MIS-/MES systems to SIMATIC PCS 7 also observe the information in 
Whitepaper Security Concept PCS 7 and WinCC. 

 



Planning the Plant Engineering  
4.5 Selecting the network components 

 Engineering System (V7.1) 
120 Configuration Manual, 03/2009, A5E02122455-01 

4.5.8.2 Connecting to the IT world - SIMATIC IT 

SIMATIC IT     
SIMATIC IT is a technology platform for MES (Manufacturing Execution Systems), based on 
the ISA 95 standard. According to this standard, explicit business and production rules 
coordinate functionality to achieve optimal workflow.  
SIMATIC IT has the following main elements: 
● SIMATIC IT Modeler 
● SIMATIC IT Components 

SIMATIC IT Modeler 
SIMATIC IT Modeler connects the automation level with the ERP (Enterprise Resource 
Planning) level: 
● Plant control and production control levels 
● Company and design level 
SIMATIC IT Modeler is a cross-industry integration and coordination platform for operating 
processes, data, and functions. In addition to the basic functions for internal procedural 
control, user administration, etc. it also possesses the facility for plant and production 
modeling. 

SIMATIC IT Components 
The functions and architecture of the SIMATIC IT Production Modeler and SIMATIC IT 
components conform to the ISA-95 standard. Each SIMATIC IT component is reserved for a 
specific task that corresponds to a function of the ISA-95 standard. 
Together, the components fulfil all the standard production functions of the ISA-95 standard. 
The ISA-95 terminology is used in the SIMATIC IT software (e.g. "Material list"). 
SIMATIC IT components: 
● SIMATIC IT Production Suite (basic MES functions such as material management, 

production order management, etc.) 
● SIMATIC IT Historian (plant performance analysis and archiving) 
● SIMATIC IT Unilab (laboratory information management system) 
● SIMATIC IT Interspec (product specification management system) 
● Detailed Production Scheduler 
● SIMATIC IT Libraries 
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Connection of PCS 7 
The SIMATIC PCS 7 process control system is integrated into SIMATIC IT via the CP 443-1. 

Additional information 
● Function Manual SIMATIC PCS 7/SIMATIC IT; Integration Pack 2007 
● on the Internet (http://support.automation.siemens.com/WW/view/en/26639558)  

http://support.automation.siemens.com/WW/view/en/26639558
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4.5.8.3 Connecting HMI Systems via OPC 

OPC       
OLE for Process Control (OPC) provides a standard mechanism for communicating with 
numerous data sources. It does not matter whether these sources are machines in your 
factory or a database in your control room. OPC is based on the OLE/COM technology from 
Microsoft. 
For detailed information about OPC, refer to the documentation OLE for Process Control 
Data Access Standard, Version 2.0, published by the OPC Foundation.  

Connecting HMI Systems 
The OPC interfaces of PCS 7 conform to the specification from the OPC Foundation. Data 
communication can be performed in PCS 7 using process tags (data access).  

PCS 7 OS Server with OPC Data Access Server 
The applications of the OPC interface are based on the client-server model.  
An OPC data access server is installed together with the PCS 7 software. The PCS 7 OS 
server provides the industrial communication capability of data access as an interface to the 
systems . Each OPC client application can access the process data (tag management) from 
this OPC Server. 
The PCS 7 OS server can be applied to the following functions: 
● OPC data access server 
● OPC data access client 
OPC is used to connect one or more operator stations to the PCS 7 OS server. You can 
connect to the operator station via a network (e.g. local data network). 

Additional information 
● Documentation OLE for Process Control Data Access Standard, Version 2.0 
● You can access the OPC Foundation address on the Internet 

(http://www.opcfoundation.org)  

http://www.opcfoundation.org/
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4.5.8.4 Connecting to the IT world via OpenPCS 7 

OpenPCS 7      
A PC station with OpenPCS 7 (OpenPCS 7 station) can be used to exchange data with 
external systems without the need for either knowledge of the topology or a PCS 7 OS 
installation.  
You can use OpenPCS 7 for data exchange with the following levels:  
● Automation level 
● Plant control and production control levels 
● MES level (Manufacturing Execution Systems) 
● ERP level (Enterprise Resource Planning) 

Standard Interface Formats 
OpenPCS 7 uses the following standard interface formats for data exchange: 
● OPC DA (Data Access) 
● OPC A&E (Alarm and Event and Historical Alarm and Event) 
● OPC HDA (Historical Data Access) 
● OLE DB (integration of data in OLE-capable applications (such as MS Office)) 

Access Options 
The following table show the PCS 7 data you can access via OpenPCS 7. 
 
Access to Data Data type Access Method 

Tags in process mode Read/write  
Archived measured values Read 
Alarms and messages Read/acknowledge 

• OS server 
• Central archive server (CAS) 
• Maintenance station 

Alarms and messages from the 
alarm archive 

Read 

License 
 

 Note 
Access to the corresponding PCS 7 data is only ensured when a license is installed. You can 
find more information about this in the manual Process Control System PCS 7; PC 
Configuration and Authorization. 
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Connecting to the IT world via OpenPCS 7 
The OpenPCS 7 is connected to the terminal bus to enable data exchange between the IT 
world and PCS 7.  

INTERFACE 

DP/AS-i Link Advanced

  

 
Figure 4-1 Example: Connecting to the IT world via OpenPCS 7 

Additional information 
● Section "Structure of the OpenPCS 7 station (Page 172)" 
● Section "How to insert and configure an OpenPCS 7 station (Page 285)" 
● Section "How to configure OpenPCS 7 stations for accessing PCS 7 data (Page 617)" 
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4.5.8.5 Access to the PCS 7 OS via WebNavigator client 

PCS 7 Web server and WebNavigator client   
PCS 7 provides the option of using operator control and monitoring functions of the 
PCS 7 OS (single-station or multiple-station system) in process mode over the Internet or 
Intranet. You will need the following components: 
● PCS 7 Web server: A separate PCS 7 Web server provides the WebNavigator client with 

all necessary OS pictures. 
● WebNavigator client: The WebNavigator client is a computer with Internet capability and 

Internet Explorer which users can use to log on from. 

How the WebNavigator client works 
Users log into the PCS 7 Web server via Internet Explorer and can then access all the 
functions corresponding to their user rights (setting in the WinCC Editor "User 
Administrator"). All operations performed on the WebNavigator client are logged 
automatically with the name of the plant operator.  
The WebNavigator client offers, for example, the following functions:  
● Operator control and monitoring functions, which are also used on an OS. 
● Message lists which are launched on a user-specific basis in the same way as on an OS. 

Messages can also be acknowledged depending on the user. 
● Display of the picture hierarchy according to the plant hierarchy 
● Batch message functions including the function "loop-in-Alarm" 
● Extended status display 

 

 
 

Note 
Not all functions are available. You will find more detailed information on the availability of 
the functions in the function manual Process Control System PCS 7; OS Web Option. 

 

Additional information 
● Manual Process Control System PCS 7; PCS 7 OS Web Option 



Planning the Plant Engineering  
4.6 Selection of the PC components for ES, OS, BATCH, Route Control and IT 

 Engineering System (V7.1) 
126 Configuration Manual, 03/2009, A5E02122455-01 

4.6 Selection of the PC components for ES, OS, BATCH, Route Control 
and IT 

4.6.1 Which PC Components Can Be Used? 

PC Components for ES/OS/BATCH/Route Control/IT                        
A wide range of basic devices is available for engineering stations (ES), operator stations 
(OS), BATCH stations (BATCH), ), Route Control stations and for connecting SIMATIC 
PCS 7 to the IT world. A basic device consists of the following components: 
● Basic hardware (PC base unit) 
● Color Monitor 

Recommended Basic Hardware 
We recommend the following hardware for PC components (a more powerful configuration is 
of advantage): 

 
Parameter Central engineering station with server 

operating system, central archive server,  
PCS 7 OS/SIMATIC BATCH/ 
SIMATIC Route Control on one PC,  
Engineering station,  
OS server,  
OS single station system,  
maintenance station,  
PCS 7 Web server, OS client and BATCH 
client on one PC,  
BATCH server,  
BATCH single station system,  
Route Control server,  
Route Control single station system 

OS client,  
BATCH client,  
Route Control client 

PC (see Catalog "ST PCS 7") SIMATIC Rack PC 547B 
Processor Intel Core2Duo E6600 
Clock Rate 2.40 GHz 
Second Level Cache (SLC) 4 MB 
Front Side Bus (FSB) 1,066 MHz 
Work memory (RAM) 2.0 GB 1.0 GB 
Hard Disk 
 
 
Partition size 

250 GB SATA RAID 1 array in servers 
and  

ES/OS single station system 
250 GB SATA in client systems 

C:\ 50 GB 

250 GB SATA 
 
 

C:\ 50 GB 
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Parameter Central engineering station with server 
operating system, central archive server,  
PCS 7 OS/SIMATIC BATCH/ 
SIMATIC Route Control on one PC,  
Engineering station,  
OS server,  
OS single station system,  
maintenance station,  
PCS 7 Web server, OS client and BATCH 
client on one PC,  
BATCH server,  
BATCH single station system,  
Route Control server,  
Route Control single station system 

OS client,  
BATCH client,  
Route Control client 

Mains adapter/communications 
interfaces  
• for terminal bus 

communication 
• for plant bus communication 

 
 
• RJ45 on-board gigabit Ethernet  

 
• CP 1613 A2, CP 1623 or BCE network 

card for engineering station and OS 
server 

 
 
• RJ45 on-board gigabit Ethernet 

Optical drive • All except engineering station:  
DVD-ROM 

• for the engineering station:  
DVD+/-RW 

DVD-ROM 

 

 
Parameter SIMATIC BOX PC 627B SIMATIC Microbox PC 427B 
Processor Intel Core2Duo Mobile T7400 Pentium Mobile M738 
Clock-pulse rate 2.16 GHz 1.4 GHz  
Second Level Cache (SLC) 4 MB 2 MB 
Front Side Bus (FSB) 667 MHz 400 MHz 
Work memory (RAM) 2.0 GB 1.0 GB 
Hard disk 
Partition size 

160 GB SATA 
C:\ 30 GB 

Compact Flash card: 2.0GB 

Mains adapter/communications 
interfaces 

• 2 x RJ45 on-board Gigabit Ethernet 
• On-board CP 5611 
• In "SIMATIC PCS 7 BOX RTX" bundle, 

additional CP 5613 A2 
• In "SIMATIC PCS 7 BOX 416" bundle, 

additional SlotPLC CPU 416-2PCI 

• 2 x RJ45 on-board Gigabit Ethernet 
• On-board CP 5611 

Optical drive DVD +/-RW  
Special features  Without fans 
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 Note 
Please note the following: 
• Engineering station PCs with higher clock rates, more RAM and larger, faster hard drives 

are advantageous during multiproject engineering. 
• If the central archive server is used in conjunction with large amounts of data, we 

recommend that you use the premium server listed in the ST PCS 7.1 catalog (SIMATIC 
PCS 7 add-ons). We recommend the use of at least a RAID1 system in order to increase 
the availability of the data on the central archive server. 

• CPU speeds with at least 3.4 GHz or dual processor systems are recommended for 
BATCH servers. 

 

Minimum Equipment for the Basic Hardware 
We recommend the following minimum equipment: 

 
Parameter Central engineering 

station with server 
operating system,  
central archive server;  
PCS 7 OS/SIMATIC 
BATCH/SIMATIC Route 
Control on one PC 

Engineering station,  
OS server,  
OS single station system, 
maintenance station,  
PCS 7 Web server,  
OS client and BATCH 
client on one PC,  
BATCH server,  
BATCH single station 
system, 
Route Control server, 
Route Control single 
station system 

OS client,  
BATCH client,  
Route Control client 

SIMATIC PCS 7 
BOX 416  
(requirements for 
the basic PC 
must be a BOX 
PC 627 or better) 

Processor Intel Pentium IV Intel Pentium IV Intel Pentium IV Pentium Mobile 
Clock-pulse rate >= 2.0 GHz >= 2.0 GHz >= 2.0 GHz >= 2.0 GHz 
Hard disk 
Minimum partition size 

>= 120 GB 
 

C:\ 20 GB 

>= 120 GB 
 

C:\ 20 GB 

>= 80 GB 
 

C:\ 20 GB 

80 GB 
 

C:\ 20 GB 
Work memory (RAM) 2 GB 1 GB 512 MB 1 GB 
Mains 
adapter/communication
s interfaces  
• for terminal bus 

communication 
• for plant bus 

communication 

 
 
 
• RJ45 connection (Fast 

Ethernet) 
• CP1613, CP1623, or 

BCE network card for 
engineering station 
and OS server 

 
 
 
• RJ45 connection (Fast 

Ethernet) 
• CP1613, CP1623, or 

BCE network card for 
engineering station 
and OS server 

 
 
 
• RJ45 connection 

(Fast Ethernet) 

2 x RJ45 
connections (Fast 
Ethernet) 
available in the 
BOX PC 627. 

Optical drive DVD-ROM DVD-ROM DVD-ROM DVD-ROM 
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Creating System Partition C 
Partition C (for the operating system and PCS 7) should be at least 20 GB. 

Color Monitor 
We recommend monitors with a minimum resolution of 1280 x 1024 or higher in order to take 
full advantage of the PCS 7 software graphics potential. 

Network 
The network for PCS 7 systems must be isolated using switches, routers, or gateways to 
prevent interference to the PCS 7 network from office networks. 

Current Information in the Readme File PCS 7 
Please read the latest information provided for every new PCS 7 version or every service 
pack in the readme file on the DVD Process Control System; PCS 7 Toolset. 

Additional information  
● Manual Process Control System PCS 7; PC Configuration and Authorization 
● Whitepaper Security Concept PCS 7 and WinCC 
● ST PCS 7.1 catalog (add-ons for SIMATIC PCS 7) 
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4.6.2 Preconfigured PCS 7 Systems (Bundles) 

Basic Hardware 
Special versions of the basic hardware (bundles) are available for engineering stations (ES), 
operator stations (OS), BATCH stations (BATCH), Route Control stations and for connecting 
SIMATIC PCS 7 to the IT world. The bundles are optimized for special applications. 

SIMATIC PCS 7 BOX Basic Hardware 
SIMATIC PCS 7 BOX is an industrial PC with integrated AS/ES/OS. PCS 7 Box is used for 
autonomous small plants or combined AS/OS stations that can be integrated in the PCS 7 
network. The automation system integrated in SIMATIC PCS 7 is a standard automation 
system. 
Various SIMATIC PCS 7 BOX PCs (PC bundles) are available for use in PCS 7: 
Information concerning the equipment can be found in the manual Process Control System 
PCS 7; SIMATIC PCS 7 BOX. 

Color Monitors 
The Siemens industrial monitor series SCD, SCM and CRT are available for use as PCS 7 
process monitors. These are selected based on the ambient temperature of the plant. 
A maximum of 4 monitors can be connected to a station (OS client) using a multi-VGA card. 
Plant areas that have been split up in this way can be managed using 1 keyboard and 1 
mouse. 

Additional information  
● Catalog ST PCS 7 
● Catalog ST PCS 7.1 (Add-ons for SIMATIC PCS 7) 
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4.6.3 Connecting PC Components 
You can find more information about connecting PC components in the section "Connecting 
Network Nodes to Ethernet (Page 91)". 

4.6.4 Additional Components for Acoustic and Optical Signaling 

Signal Module 
OS single station systems and OS clients can be expanded with a signal module. These 
signal modules can control a horn and a maximum of 3 different lamps or buzzer tones that 
represent a variety of message classes.  
Using a hardware timer (watchdog), the signal modules can detect and signal the failure of 
an operator station. A hardware acknowledgment button can also be connected.  
The signal modules are installed in a PCI slot in the operator station. 

Sound Card 
You can also use a standard sound card installed in the operator station.  

Additional information  
● You can find information about the function and the installation of signal modules in 

WinCC Information System under "Options > Options for Process Control". 
● You can find more information about the configuration of audible signal devices in the 

configuration manual Process Control System PCS 7; Operator Station. 
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4.7 Selecting AS Components 

4.7.1 What are the criteria for selecting the AS? 

SIMATIC S7-400 Automation Systems 
The PCS 7 process control system is based on selected components from SIMATIC S7-400. 
The following automation systems can be configured with hardware and matching software: 
● Standard automation systems 
● Fault-tolerant automation systems (H systems) 
● Fail-safe automation systems (F systems) 
● Fail-safe and fault-tolerant automation systems (FH systems) 

SIMATIC PCS 7 BOX 
SIMATIC PCS 7 BOX is an industrial PC with integrated AS/ES/OS/RC/BATCH. SIMATIC 
PCS 7 BOX is used for autonomous small plants or combined AS/OS stations that can be 
integrated in the PCS 7 network. The automation system integrated in SIMATIC PCS 7 is a 
standard automation system.  
The following SIMATIC PCS 7 Box PCs (PC bundles) are available for use in PCS 7: 
● SIMATIC PCS 7 BOX 416: Version with Slot PLC CPU 416-2 PCI 
● SIMATIC PCS 7 BOX RTX: Version with software PLC WinLC RTX 
Refer to the manual Process Control System PCS 7; SIMATIC PCS 7 Box to find all of the 
required information about the use of SIMATIC PCS 7 Box. 

Criteria for Selecting the Automation Systems  
The vast array of requirements for automation systems makes it difficult to generalize about 
the system to be employed. Below you will find a summary of the most important information 
about selecting automation systems that is described in detail elsewhere in the manual: 
● Section "How Many CPUs are Needed for Automation? (Page 65)" 
● Section "How Many Devices, Sensors and Actuators Can Be Integrated?" (Page 66) 
● Section "Redundancy Concept for PCS 7 (Page 70)" 
● Section "Operating Security for PCS 7 (Page 73)" 
The sections below contain additional information regarding the actual selection of 
automation systems and the I/O components to be connected. 



 Planning the Plant Engineering 
 4.7 Selecting AS Components 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 133 

Configuration Change in RUN 
The automation systems released for PCS 7 support the "Configuration in RUN" function: 
 
Automation system Configuration in RUN 
Functionality for all automation 
systems 

• Add/remove new slaves 
• Add/remove new modules 
• Making new parameter settings for inserted modules 

Additional functionality for fault-tolerant 
automation systems 

• Changing the memory capacity 
• Changing the CPU parameters (marked in blue in the 

HW Config: e.g. CPU Properties > Protection > 
Password Protection) 

• Add/remove S7-400 modules 

List of Applicable Components 
 

 Note 
A list of all the modules that can be used for a PCS 7 version is available in the document 
PCS 7 - Released Modules. 
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4.7.2 Overview of the SIMATIC S7-400 Automation Systems 

4.7.2.1 Introduction to the Automation Systems 

Components of an SIMATIC S7-400 Automation System 
The automation system is available as a preassembled complete system. An automation 
system essentially consists of the following components: 
● Module rack with 9 or 18 slots 
● Power supply 
● S7-400 CPU 
● Interface module for Industrial Ethernet 
● Memory card 

4.7.2.2 Standard Automation Systems for PCS 7 

Standard Automation Systems 
The following systems are available as standard automation systems: 
 

Components AS 414-3 AS 416-2 AS 416-3 AS 417-4 
CPU CPU 414-3 CPU 416-2 CPU 416-3 CPU 417-4 
PROFIBUS DP interface 2 integrated  

+ 1 DP module 
2 integrated 2 integrated  

+ 1 DP module 
2 integrated  
+ 2 DP modules 

Ethernet interface CP 443-1 
(1 integrated) 

CP 443-1 CP 443-1 
(1 integrated) 

CP 443-1 

Main memory  
CPU <= V3.1 
(per program + data) 

384 KB 800 KB 1600 KB 2 MB  
expandable: 
10 MB 

Main memory  
CPU > V3.1 
(per program + data) 

700 KB 1400 KB 2800 KB 10 MB 

Memory card RAM 2 MB 4 MB 8 MB 4/16 MB 
Runtime License  
PCS 7 Library 

1 1 1 1 

Backup battery 2 2 2 2 
Power supply PS 407; 10/20 A 

for 120/230 V AC 
or 
PS 405; 10/20 A 
for 24 VDC 

PS 407; 10/20 A 
for 120/230 V AC 
or 
PS 405; 10/20 A 
for 24 VDC 

PS 407; 10/20 A 
for 120/230 V AC  
or 
PS 405; 10/20 A 
for 24 VDC 

PS 407; 10/20 A 
for 120/230 V AC 
or 
PS 405; 10/20 A 
for 24 VDC 

Number of slots 9 or 18 9 or 18 9 or 18 9 or 18 
Slots reserved for PS, CPU 
and CP 

5 (4) 4 5 (4) 5 
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4.7.2.3 Fault-tolerant Automation System for PCS 7 

Fault-tolerant automation systems 
The fault-tolerant automation systems are equipped in the following manner: 
● with two CPUs = ...-2H 

The redundant subsystems are placed on a rack. 
● with only one CPU = ...-1H 

These automation systems are utilized if the redundant subsystems must be separated 
for safety reasons during configuration. 

The following systems are available as fault-tolerant automation systems: 
 
Consisting of ... AS 414-4-2H AS 417-4-2H AS 414-4-2H AS 417-4-2H 
CPU 2 * CPU 414-4H 2 * CPU 417-4H CPU 414-4H  CPU 417-4H 
PROFIBUS DP interface 2 integrated in 

each 
2 integrated in 
each 

2 integrated  2 integrated  

Ethernet interface 2 * CP 443-1 2 * CP 443-1 CP 443-1 CP 443-1 
Main memory 
CPU <= V3.1 
(per program + data) 

384 KB 2 MB 
expandable to  
10 MB 

384 KB 2 MB 
expandable: 
10 MB 

Main memory 
CPU > V3.1 
(per program + data) 

700 KB 10 MB 700 KB 10 MB 

Memory card RAM 2 MB each 4/16 MB 2 MB 4/16 MB 
Runtime License  
PCS 7 Library 

1 1 1 1 

Backup battery 4 4 2 2 
Sync modules 4 4 - - 
Sync cable 2 2 - - 
Power supply PS 407; 10/20 A 

for 120/230 V AC
or 
PS 405; 10/20 A 
for 24 VDC 

PS 407; 10/20 A 
for 120/230 V AC
or 
PS 405; 10/20 A 
for 24 VDC 

PS 407; 10/20 A 
for 120/230 V AC 
or 
PS 405; 10/20 A 
for 24 VDC 

PS 407; 10/20 A 
for 120/230 V AC 
or 
PS 405; 10/20 A 
for 24 VDC 

Number of slots 2 * 9 (UR2-H) 2 * 9 (UR2-H) 9, 18 9, 18  
Slots reserved for PS, 
CPU and CP 

2 * 5 2 * 5 5 5 
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Example Configuration AS 414/417-4-2H with UR2-H 

 

Rack UR2-H 
The UR2-H is a compact, special rack with a split backplane bus and therefore suitable for 
configuring a complete fault-tolerant automation system. 

Synchronization Modules 
The synchronization modules link both of the CPUs. They are installed in the CPU and 
interconnected with fiber-optic cable. Two synchronization modules are installed in each 
CPU. 

4.7.2.4 Fail-safe Automation Systems for PCS 7 

Fail-safe Automation Systems 
The fault-tolerant automation systems are used as the hardware for the fail-safe automation 
systems AS 414F and AS 417F. 
The following H systems are available depending on the type and configuration of the fail-
safe automation system: 
● For fail-safe systems (F systems): an AS 414-4-1H each or AS 417-4-1H 
● For fail-safe and fault-tolerant automation systems (FH systems) 

– Both subsystems on one rack:  
One AS 414-4-2H each or AS 417-4-2H 

– Both subsystems on separate racks:  
Two AS 414-4-1H each or AS 4-417-1H 

The safety functions are implemented by the installing F runtime licenses and programming 
tools / block libraries for fail-safe user programs (F programs). 
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4.7.3 Limits of the CPUs for PCS 7 Projects 

Limits of the CPUs 
The following table provides an overview of the limits regarding the most important 
performance data for the CPUs used in PCS 7 projects: 
 
Parameter Limit 

PCS 7 
CPU 414-3 
CPU 414-4H  

Limit 
PCS 7 
CPU 416-2 
CPU 416-3 

Limit 
PCS 7 
CPU 417-4 
CPU 417-4H  

Local data area in bytes  16,384 32,768 65,536 
Process image in bytes (I+O each)  8,192 16,384 16,384 
I/O address space of the CPU in bytes (I+O 
each) 

8.192 16,384 16,384 

I/O address space of MPI/DP in bytes (I+O 
each) 

2,048 2,048 2,048 

I/O address space of DP/MPI in bytes (I+O 
each) 

6,144 8,192 8,192 

I/O address space of DP module in bytes (I+O 
each) 

6,144 8,192 8,192 

I/O address space of CP443-5 ext in bytes (I+O 
each) 

4,096 4,096 4,096 

Instances for alarms and communication calls 600 1,800 10,000 
Number of FBs 2,048 2,048 6,144 
Number of FCs 2,048 2,048 6,144 
Number of DBs  4,095  

(DB 0 
reserved) 

4,095  
(DB 0 
reserved) 

8,192 
(DB 0 
reserved) 

CPU <= V3.1 
Main memory integrated in KB 
(per program + data) 

384 416-2: 800 
416-3: 1,624 

2,048 
Expandable:  
10,240 

CPU > V3.1 
Main memory integrated in KB: 
(per program + data) 

700 416-2: 1,400 
416-3: 2,800 

10,240 

RAM integrated load memory in KB  
(per program + data) 

256 256 256 

Loading memory expandable RAM max. MB 16 416-2: 16 
416-3: 64 

16 
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4.7.4 Default Performance Parameters of the CPUs for PCS 7 Projects 

Default Parameters of the CPUs 
The following table shows the default parameters regarding the performance of the CPUs for 
PCS 7 projects. These values are set as defaults for the configuration of a CPU with PCS 7 
software.  
They suffice for typical applications but can be changed within limits as required for 
configuration. 
 
Parameter Default value PCS 7

CPU 414-3XJ00 
CPU 414-4HL01 

Default value PCS 7 
CPU 416-2XK02 
CPU 416-3XL00 

Default value PCS 7
CPU 417-4XL00 
CPU 417-4HL01 

Cycle load from communication 
[%]  

20 20 20 

OB 85 call at I/O access error Only for incoming 
and outgoing errors 

Only for incoming 
and outgoing errors 

Only for incoming 
and outgoing errors 

Cycle monitoring time [ms]  6,000 6,000 6,000 
Minimum cycle time [ms]  0 0 0 
Local data (priority classes):  
1-2, 9-12, 16, 24-28 

1,024 1,024 1,024 

Local data (priority classes): 
3-8, 13-15, 17-23, 29 

256 256 256 

User local data area (bytes) 16,384 17,000 32,768 
Process image  
(I+O each) (bytes) 

768 416-2: 2,048 
416-3: 3,072 

3,072 

Number of messages in the 
diagnostic buffer 

3,000 3,000 2.400 

Max. communication jobs 600 1,800 3,000 
Monitoring time for finished 
message from modules [100 ms] 

650 650 650 

Monitoring time for transferring 
parameters to modules [100 ms] 

600 600 600 

Acknowledgment-triggered 
messaging (QTM; SFB 33-35)  

Off Off Off 

Reasons for STOP message On On On 
Startup at POWER ON Warm restart Warm restart Warm restart 
Clock memory None None None 
Time-of-Day Synchronization None None None 
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4.7.5 Components for Fault-tolerant Automation Systems 

How the H System Works 
The automation system consists of two redundantly configured subsystems that are 
synchronized through fiber-optic cables. The two subsystems form a fault-tolerant 
automation system that operates according to the principle of active redundancy.  
Active redundancy means that all the redundant equipment is permanently in operation and 
also takes part in acquisition of the process data. The active redundancy partner is 
responsible for executing the control task. The user programs loaded in both CPUs are fully 
identical and are run synchronously by both CPUs. 
If the active CPU fails, the automation system automatically switches to the redundant CPU. 
The changeover has no effect on the ongoing process because it is bumpless. 

Example Configuration for an H System 
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Components in a Basic Configuration of a H System 
The following components can be used to configure a complete fault-tolerant automation 
system with connected I/O: 
● License for S7 H systems for configuring and programming the H system 
● Fault-tolerant automation system (AS 414-4-1H, AS 414-4-2H, AS 417-4-1H or AS 417-4-

2H) with interface modules for connecting to the Industrial Ethernet plant bus and 
PROFIBUS DP field bus. 
– AS selection: You can find information about this in the section "Overview of the 

Automation Systems (Page 134)" 
– Connection to the system bus: you can find information about this in the section 

"Connecting Network Nodes to Ethernet (Page 91)". 
– Connection to the field bus: you can find information about this in the section 

"Connecting PROFIBUS DP Nodes (Page 102)". 
● Redundant PROFIBUS DP for connecting distributed I/Os: 

You can find information about this in the section "Configuring Redundant PROFIBUS DP 
Networks (Page 103)" 

● Distributed I/Os with ET 200 components: 
ET 200M with S7-300 signal modules (also with redundant signal modules) 
You can find information about this in the section "Overview of Usable Distributed I/O 
Systems ET 200 (Page 148)"  

Connecting Additional Components 
● PROFIBUS DP devices that can be configured non-redundant: 

You can find information about this in the section "Connecting Non-Redundant 
PROFIBUS DP Devices to Redundant PROFIBUS DP (Page 104)" 

● Intelligent field devices to PROFIBUS PA: 
You can find information about this in the sections "Connecting PROFIBUS PA to 
PROFIBUS DP (Page 106)" and "Configuring Redundant PROFIBUS PA Networks 
(Page 109)" 

Mixed operation 
 

 Note 
Fault-tolerant and standard automation systems can be used in mixed operation. 

 

Additional information 
● Manual Process Control System PCS 7; Fault-tolerant Process Control Systems 
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4.7.6 Components for Fail-safe Automation Systems 

How the F System Works       
Fail-safe automation systems use their numerous safety functions to detect both process 
errors as well as their own internal errors. If an error should occur, the fail-safe automation 
systems automatically switch the affected part of a plant to a safe state. 
The fail-safe automation systems (F/FH systems) based on the AS 414-4-H and AS 417-4-H 
automation systems combine standard production automation and safety technology in a 
single system. They are certified by the German Technical Inspectorate (TÜV) and conform 
to safety requirement category SIL 1 to SIL 3 according to IEC 61508, requirement category 
AK 1 to AK 6 according to DIN V 19250/DIN V VDE 0801 and categories 2 to 4 according to 
EN 954-1. 

Safety Mechanisms of the F System 
You can find information about this in the section "Operational Security of PCS 7 (Page 73)". 

FH Systems 
Fail-safe automation systems can be configured as single-channel (F system with one CPU) 
or as redundant (FH system). The redundancy of the FH systems is not relevant for failure 
safety. Redundancy is not used for detecting errors but rather to increase the availability of 
fail-safe automation systems. 
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Example Configurations for F/FH Systems 
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Components of the Basic Configuration of an F System 
The following components can be used to configure a complete fail-safe automation system 
with connected I/O: 
● F runtime license for editing fail-safe user programs 
● Add-on package F systems for configuring and programming the H system 
● Fault-tolerant automation system (AS 414-4-1H or AS 417-4-1H) with interface modules 

for connecting to the Industrial Ethernet plant bus and PROFIBUS DP field bus. 
– AS selection: you can find information about this in the section "Overview of the 

Automation Systems (Page 134)" 
– Connection to the system bus: you can find information about this in the section 

"Connecting Network Nodes to Ethernet (Page 91)". 
– Connection to the field bus: you can find information about this in the section 

"Connecting PROFIBUS DP Nodes (Page 102)". 
● Distributed I/Os with ET 200 components: 

– ET 200M with fail-safe S7-300 signal modules (F modules) 
– Isolation module for protecting against overvoltage between standard S7-300 signal 

modules and fail-safe S7-300 signal modules in the ET 200M 
– ET 200S with fail-safe power modules 
– ET 200pro with fail-safe S7-300 signal modules (F modules) 
You can find information about this in the section "Overview of Usable Distributed I/O 
Systems ET 200 (Page 148)" 

Components for an FH System 
The following fault-tolerant automation systems are utilized depending on the type and 
requirements and the configuration of the FH system: 
● Both subsystems on one rack:  

AS 414-4-2H or AS 417-4-2H 
● Both subsystems on separate racks:  

AS 414-4-2H or AS 417-4-2H 
In addition to the configuration of an F- system, all possible configurations of an H system 
can be used in combination: you can find information about this in the section "Components 
for Fault-Tolerant Automation Systems (Page 139)" 
The S7 H Systems license must be installed in the engineering station in addition to the add-
on package S7 F Systems. 

Additional information 
● Manual SIMATIC Programmable Controllers S7 F/FH 
● Manual S7-300 Fail-safe Signal Modules 
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4.8 Selecting I/O components 

4.8.1 Introduction to I/O 

I/O Components 
PCS 7 offers a wide range of options for connecting I/O devices and for recording and 
outputting process signals via sensors and actuators: 
● Analog and digital input/output modules of the S7-400 operated centrally in the 

automation system 
● ET 200M, ET 200S, ET 200iSP distributed I/O systems connected to the automation 

system via PROFIBUS DP with a comprehensive range of signal and function modules 
● Direct connection of intelligent, distributed field/process devices and operator terminals 

via PROFIBUS DP/PA (also redundant or in hazard zones 0, 1 or 2) 

Signal and Function Modules for PCS 7 
 

 Note 
PCS 7 only supports diagnostics for the signal and function modules listed in the document 
PCS 7 - Released Modules. 
In addition, all other signal modules from the current S7-400 and S7-300 product range can 
also be used. When used, the integration of these other signal modules is limited to process 
data. This means the full diagnostics capability of PCS 7 is not automatically available. 

 



 Planning the Plant Engineering 
 4.8 Selecting I/O components 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 145 

4.8.2 Should Distributed or Central I/O Devices Be Used? 

Using Central I/O 
Central I/O is primarily used for small applications or plants with a small, distributed 
structure. 

 

 Note 
The following PCS 7 functions can not be used with central S7-400 signal modules: 
• Configuration Change in RUN 
• Signal modules redundancy 
• Fail-safe signal modules 

 

Using Distributed I/O 
PCS 7 plants are for the most part configured with distributed I/Os. The following are the 
main advantages: 
● Modularity and uniformity 
● Low cabling and commissioning costs 
● Low space requirements 
● No need for terminal boards, sub-distribution boards and hazardous area buffer stages 
● Can increase availability using redundant configuration of signal modules 
● Safe states using fail-safe signal modules 
● Can be expanded and reconfigured in CPU RUN 
● Easy fault location using self-diagnostics with detailed information 
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4.8.3 Which Devices can be Connected as Distributed Components? 

Connecting Field Systems to PCS 7 
PCS 7 is optimized for the integration of distributed field systems in the process control 
system and uses PROFIBUS technology to accomplish this. 
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Devices that Can Be Connected as Distributed Components 
The table displays the following information: 
● The field devices, sensors, and actuators that can be connected as distributed 

components in a PCS 7 plant 
● The components used for communicating with these field devices, sensors, and actuators 
 
Device I/O Additional sections  
Sensors and actuators  Direct connection to the distributed I/O 

systems ET 200M, ET 200S, 
ET 200iSP, or ET 200pro 

Overview of Usable Distributed 
I/O System ET 200 (Page 148) 

Intelligent PROFIBUS 
DP capable field 
devices  

Direct connection to PROFIBUS DP 
(DP master system) 

 

Intelligent PROFIBUS 
PA capable field 
devices  

Direct connection to PROFIBUS PA 
and  
Simultaneous coupling of PROFIBUS 
PA to the PROFIBUS DP (DP master 
system) using DP/PA link or DP/PA 
Coupler 

Connecting PROFIBUS PA to 
PROFIBUS DP (Page 106) 

HART field devices Direct connection to special I/O 
components of the distributed I/O 
systems ET 200M or ET 200iSP 

Connecting HART Devices to 
Distributed I/O (Page 150) 

Non redundant 
PROFIBUS DP devices 

Indirect connection of a device to a 
redundant PROFIBUS DP 

Connecting Non-Redundant 
PROFIBUS DP Devices to 
Redundant PROFIBUS DP 
(Page 104) 

4.8.4 Use in Fault-tolerant or Fail-safe Automation Systems? 

Overview 
The following table shows the automation systems in which the distributed I/O system 
ET 200 can be used. 
 
Automation system ET 200M ET 200S ET 200iSP ET 200pro 
Standard (AS 400) X X X X 
Fault-tolerant (AS 400H) X - X - 
Fail-safe (AS 400F) X X - X 
Fail-safe and fault-tolerant (AS 400FH) X - - - 

Additional information 
● Section "Overview of Usable Distributed I/O System ET 200 (Page 148)" 
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4.8.5 Overview of Usable Distributed I/O System ET 200 

Properties of the Distributed I/O Station ET 200 
The following table provides an overview of the most important properties of the distributed 
I/O system from ET 200 used in PCS 7. 

 
Property ET 200M ET 200iSP ET 200S ET 200pro 
Protection level IP20 IP30 IP20 IP65, IP66, IP67 
Digital modules x x 

(with 
counter/frequency 
measurement 
function) 

x x 

Analog modules x x x x 
Modules for motor starter - - x x 
Controller and counter modules x - - - 
Hazardous digital/analog 
modules  

x 
(Analog module 
also for HART) 

x - - 

Fail-safe modules x 
(+ isolation module) 

- x 
(+ ET 200S 
SIGUARD) 

x 

Redundancy capable 
digital/analog modules 

x - - - 

Modules have enhanced 
diagnostic capability 

x x x x 

HART field devices can be 
connected 

x 
(Parameter 
assignment 
 via PDM) 

x 
(Parameter 
assignment 
 via PDM) 

- - 

"Hot swapping" function in 
runtime 

x 
(+ active bus 
module) 

x x x 

Configuration and parameter 
assignment 

HW Config HW Config and 
PDM 

HW Config HW Config 

Configuration change in  
RUN (CiR) 

You can find information about this in the section "Can Configuration Changes Be Made 
in Runtime? (Page 152)" 

Can be used in hazardous areas 
(hazardous areas) 

x 
ET 200M: Zone 2 
(+ hazardous area 
partition) 
Actuator/sensor/ 
HART: Zone 1 

x 
ET 200iSP/HART: 
zone 1, 2 
RS485-iS coupler: 
zone 2 
Actuator/sensor:  
zone 0 

x 
Zone 2 (except 
motor starter) 

- 

Max. n modules per station n = 8 n = 32 n = 63 n = 16 
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Property ET 200M ET 200iSP ET 200S ET 200pro 
Electrical bus connection x 

(IM 153-2  
High Feature) 

x 
(IM 152) 

x 
(IM 151-1  
High Feature) 

X 
(IM 154-1,  
IM154-2) 

Optical bus connection  x 
(IM 153-2 FO High 
Feature) 

- - - 

Bus connected via connection 
modules 

x x x x 

Transmission rate max. 12 Mbps max. 1,5 Mbps max. 1,5 Mbps max. 12 Mbit/s 
Connecting non-redundant 
PROFIBUS DP devices to a 
redundant PROFIBUS DP 

Y Link - - - 
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4.8.6 Connecting HART Devices to Distributed I/O 

What is HART?  
HART (Highway Addressable Remote Transducer) is serial transmission method used to 
transmit additional parameter data, such as measurement range or damping, etc., to 
connected measuring transducers and actuators over a 4 mA - 20 mA current loop.  

Use in PCS 7 
HART devices can be used within PCS 7 in the following manner: 
● HART devices can be connected to the distributed I/O system ET 200M in both standard 

environments and hazardous areas. Special S7-300 hazardous area signal modules with 
HART enable connection to HART devices certified for use in hazardous areas. The 
S7-300 hazardous area modules with HART are diagnostics capable (with channel and 
module diagnostics). 

● HART devices can be connected to special analog HART electronic modules of the 
distributed I/O system ET 200iSP. 

All transducers or HART actuators certified for digital communication using the HART 
protocol can be connected through the ET 200M and ET 200iSP.  

Example configuration 

Ex

0
1
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Use in Hazardous Areas 
● On an ET 200M in hazardous zone 2 
● On an ET 200iSP in hazardous zone 1 or 2 

Configuration of HART Field Devices 
HART field devices are configured for PCS 7 with SIMATIC PDM. 
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4.8.7 Can the Configuration be Changed during Ongoing Operation? 

Configuration in RUN 
The following table provides an overview of the permitted configuration changes that can be 
made to the distributed I/O during ongoing operation (CPU RUN). 
 
Components Permitted Configuration Changes 
ET 200M • Add/remove ET 200M stations 

• Add/remove new I/O modules 
• Parameter assignment for I/O modules 
• Configuration of connected HART field devices via SIMATIC PDM 
Note: only when IM 152-2 HF or IM 153-2 HF-FO is used 

ET 200S, ET 200iSP • Add/remove ET 200S/iSP stations 
• ET 200iSP: 

– Parameter assignment for I/O modules as well as for HART field 
devices connected to HART modules via SIMATIC PDM 

– Add/remove I/O modules 

PROFIBUS DP, 
PROFIBUS PA 

• Add/remove PROFIBUS DP nodes 
• Add/remove DP/PA links and DP/PA field devices 
• Parameter assignment for field devices with SIMATIC PDM 

Additional information 
● Section "Rules for Configuration Changes in RUN (CiR) (Page 185)" 
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4.8.8 How Can Distributed I/O Be Integrated in Hazardous Areas? 

Integrating I/O in Hazardous Areas 
The following illustration shows an overview of the various options for integrating distributed 
I/Os in hazardous areas: 
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Legend to figure 
 
Components Use in Hazardous Areas 
ET 200M ET 200M can be operated in hazardous zone 2. The actuators/sensors can 

be located in hazardous zone 1 when the appropriate hazardous area I/O 
modules are used.  
Hot swapping of I/O modules is permissible in hazardous zone 2 with 
appropriate permission (e.g. fire certificate). 

ET 200iSP ET 200iSP can be installed directly in hazardous areas 1 or 2 (EEx de ib 
[ia/ib] IIC T4). 
Sensors/actuators also in Zone 0. 
Individual modules can be hot swapped under hazardous conditions. 

PROFIBUS PA 
capable field devices 

Field and process devices can be integrated directly in hazardous areas 1 
or 2 per PROFIBUS PA. 
Sensors/actuators also in Zone 0. 

Intrinsically Safe Operator Panel 
If required, an intrinsically safe PC operator panel (PCS 7 add-on) can be used in hazard 
zones 1 or 2. It can be connected to the operator station up to a distance of 750 m. 
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4.9 Preparation for Efficient Engineering 

4.9.1 Planning Objects/Functions for Efficient Engineering 

Functions for Efficient Engineering    
The following table provides an overview of those objects/functions that are designed to help 
ensure efficient engineering. We recommend that you take these functions into consideration 
while planning the plant engineering with PCS 7. 
 
Function Brief Description Tool Sections in this 

manual 
containing further 
information 

Process control 
library 

PCS 7 offers a library with a wide range of 
preconfigured and tested blocks, faceplate 
and symbols for graphic configuration of 
automation solutions. 
These library elements can contribute 
considerably to minimize engineering 
requirements and project costs. 
The comprehensive range of blocks includes 
simple logic and driver blocks, technological 
blocks with integral operation and signaling 
response such as PID controllers, motors or 
valves, and blocks for the integration of 
PROFIBUS PA field devices.  

Standard 
PCS 7 
software 

How are recurring 
technological 
functions 
supported? 
(Page 158)  

Multiproject 
engineering 

Multiproject engineering enables an 
extensive plant project to be divided into 
several subprojects based on technological 
factors. The subprojects can then be worked 
upon simultaneously by several project 
engineers. 
Advantage: 
• The individual projects can be added or 

removed from a multiproject at any time. 
• The subprojects in a multiproject are 

stored on a central server and moved to 
the local engineering stations for editing. 

• Once the subprojects are assembled back 
into the multiproject, the cross-project 
functions (such as compiling and 
downloading) are carried out for the entire 
plant. 

Standard 
function of  
PCS 7 

Configuring in a 
Multiproject 
(Page 196)  

Master data 
library 

A custom library can be created for a project 
to improve efficiency. 

Standard 
function of  
PCS 7 

Objects in the 
Master Data 
Library 
(Page 312)  
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Function Brief Description Tool Sections in this 
manual 
containing further 
information 

Branching and 
merging projects 

Branch & merge is a function for multiproject 
engineering and is used to separate and 
reassemble project parts based on 
technological factors. Charts or plant units 
can be copied into another project to be 
modified there. 

Standard 
function of  
PCS 7 

Branching and 
Merging Charts 
from a Project 
(Page 201)  

Importing 
configured plant 
data  

Configured plant data such as process tag 
lists or charts from the higher-level CAD/CAE 
world can be imported into the engineering 
system and used for almost fully automatic 
generation of process tags. 

Import/Export 
Assistant 

Which Data and 
Data Formats can 
be Imported? 
(Page 157)  
Transferring the 
data from the 
plant engineering 
(Page 627) 

Automatic 
generation of 
process tags 

Based on the imported process tag lists and 
custom defined process tag types, a great 
many process tags (CFC charts in PCS 7) 
are generated automatically and stored in the 
correct location in the plant hierarchy. 

Import/Export 
Assistant 

Working with 
Process Tags 
and Models 
(Page 630)  
Using Process 
Tag Types 
(Page 210)  

Exporting 
configuration data 

During the configuration and commissioning, 
parameters optimized with PCS 7 can be 
exported back into the CAD/CAE world. 

Import/Export 
Assistant 

Working with 
Process Tags 
and Models 
(Page 630)  

Automatic 
expansion/modific
ation of hardware 
configurations 

Station configurations can be exported from 
HW Config, modified and adapted outside the 
project, and then imported back in again. The 
symbolic names of the inputs and outputs are 
also exported or imported. 
This function can be used for efficient 
engineering of plants with repeatedly used 
hardware structures. 

HW Config Import/Export of 
the Hardware 
Configuration 
(Page 653)  
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4.9.2 Which Data and Data Formats can be Imported? 

Data Import 
The table supplies the following information: 
● The task in which data can be imported 
● The data formats that can be imported 
● The application in which the data can be generated 
 
Work phase in engineering Potential import formats  Application for generation 
Creating the process tags  
(CFC charts in PCS 7)  

Lists in the format: 
• csv 

Application that can export 
lists in CSV format (e.g. MS 
Excel, Access) 

Creating the hardware 
configuration 

• cfg HW Config  
(standard PCS 7) 

Creating the OS pictures 
(non-dynamic screen 
elements) 

Imported graphics in the format: 
• emf 
• wmf 
Imported graphic objects in the format: 
• emf 
• wmf 
• dib 
• gif 
• jpg 
• jpeg 
• ico 

Any graphics application 

Creating foreign language 
texts 

• txt 
• csv 

Text editors (e.g. MS Excel, 
Wordpad) 

Creating the project data • xml SIMATIC Manager 
Version Cross Manager 

Additional information 
● Section "Import and Reuse of Plant Data (Page 217)" 
● Section "Adopting the Data from the Plant Engineering (Page 627)" 
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4.9.3 How are recurring technological functions supported? 

Introduction     
Recurring technological functions are supported by the following functions in PCS 7: 
● Templates 

Templates (standard types, standard solutions) are provided to support you in the 
configuration of a PCS 7 plant. They are contained in the PCS 7 Standard Library and 
PCS 7 Advanced Process Library. 

● Type concept 
We recommend the additional combining of similar functions to improve the efficiency of 
the plant engineering. Similar functions can be configured by using reusable objects 
(such as process tag types and models). 

Templates in the PCS 7 libraries 
The PCS 7 libraries (PCS 7 Advanced Process Library, PCS 7 Basic Library, PCS 7 Library) 
contain templates for the following technological functions: 
● Controls for measured value displays 
● Binary value acquisition with monitoring 
● Analog value acquisition with monitoring 
● Manual adjustment 
● Fixed setpoint control 
● Cascade control 
● Ratio control 
● Split range control 
● Dosing 
● Motor control manual/automatic 
● Motor control (variable speed) 
● Valve control manual/automatic 
● Valve control continuous 
● Sequence control 
If you wish to become better acquainted with the individual blocks and the way they are 
used, please read the following manuals: 
● PCS 7 Basic Library 
● PCS 7 Standard Library 
● PCS 7 Advanced Process Library 
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Recommendation for Configuring Numerous Process Tags 
Create a process tag list that contains all process tags. Consider which process tags can be 
assigned to a process tag type. Use this list during the engineering to generate the CFC 
charts with the corresponding process tags based on the process tag types in the 
Import/Export Assistant. 
The import file must have a specific structure. The exact configuration of this structure is 
described in the section "Creating/Editing Import Files with the IEA File Editor (Page 646)". 
For preparation create a process tag list containing the following information: 
 
Components Measurement Measurement Motor .... 
Block 1 2 1  
Plant area Plant area 1 Plant area 2 Plant area 1 Plant area 1 
Subarea Dosing plant Oil heating Mixer Gas heating 
Type 3 (PT 100 - 

temperature 
measurement) 

3 (method of 
measurement, e.g. 
square-root) 

10 ... 

Property 1 Measuring range 
start 
(e.g. 263°K) 

Measuring range 
start 
(e.g. 0 mA) 

On ... 

Property 2 Measuring range 
end 
(e.g. 473°K) 

Measuring range 
end 
(e.g. 100 mA) 

Off ... 

Property 3 Limit 1: 300 K  Feedback in ... 
Property 4 Limit 2: 320 K  Feedback out ... 
Property 5 Limit 3: 390 K  Temperature 

sensor (type 1 - 
PT 100) 

 

Property 6 Limit 4: 400 K    
Property 7 ...    
Property ... ...    

Additional information 
● Section "Adopting the Data from the Plant Engineering (Page 627)" 
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Configuration of PCS 7 Plant 5
5.1 Base Configuration of the PCS 7 System 

Basic Components 
The following figure shows the basic components of a PCS 7 plant. 
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Legend to figure 
 
Station No. in 

figure 
Function 

Engineering Station 1 The central engineering for all PCS 7 system components is 
performed on the engineering station:  
• Operator stations 
• BATCH stations 
• Route Control stations 
• Automation systems 
• Centralized I/O 
• Distributed I/Os 
The configuration data are downloaded to the PCS 7 system 
components when the engineering is completed. Changes can 
only be made on the engineering station. This is followed by a 
new download. 

Operator Station 2 On the operator station you operate and observe your PCS 7 
plant in process mode. 

BATCH station 3 On the BATCH station you operate and observe discontinuous 
process sequences (batch processes) in process mode. 

Route Control 
Station 

4 On the Route Control station, you control and monitor material 
transports in process mode (route control). 

OpenPCS 7 station 5 An OpenPCS 7 station enables you to access the PCS 7 data in 
the IT world. 

Automation 
system 

6 The automation system carries out the following tasks: 
• It registers and processes process variables from the 

connected central and distributed I/O and outputs control 
information and setpoints to the process. 

• It supplies the operator station with the data for visualization. 
• It registers actions on the operator station and forwards them 

to the process. 

Additional information 
● Section "Connecting Network Nodes to Ethernet (Page 91)" 
● Section "Connecting PROFIBUS DP Nodes (Page 102)" 
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5.2 Configuration of the PC Stations 

5.2.1 Configuration of the Engineering Station 

Engineering Station         
Engineering stations are PCs on which the PCS 7 engineering software for configuring a 
PCS 7 project is installed.  
Connect an engineering station to the plant and terminal bus to download the configuration 
data to the PLC (OS, BATCH, Route Control, AS) and to test in process mode. 

 

PC Configuration Options for the Engineering Station 
The following PC configurations are possible for engineering stations in a PCS 7 plant:  
● Engineering of a PCS 7 project on a single PC 
● For small plants: 

– Combination of Engineering Station and Operator Station on a Single PC 
– Combination of engineering station, operator station and automation system on a 

single PC. This solution is offered as the SIMATIC PCS 7 Box. 
● For large plants - PCS 7 project engineering with several engineering stations: 
 
Configuration Method Note 
With common server 
(standard office 
network) 

The engineering stations of the individual project 
editors work on the multiproject in a PC network. 

A project editor works on a 
single project on a local 
engineering station. 

Without a common 
server 

• The multiproject is saved on a central 
engineering station and the cross-project 
connections are created. 

• The individual projects are moved to 
distributed PCs for engineering. 

• When the projects are completed, they are 
copied back to the central engineering 
station and the cross-project functions are 
executed in the multiproject. 

This method allows 
distributed engineering (for 
example, at several 
locations). 
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Additional information 
● Section "Connecting Network Nodes to Ethernet (Page 91)" 
● For detailed information about configuring engineering stations and installing the 

operating system and PCS 7 engineering software including the required authorizations, 
refer to the manual Process Control System PCS 7; PC Configuration and Authorization. 

● Manual Process Control System PCS 7; SIMATIC PCS 7 BOX. 



 Configuration of PCS 7 Plant 
 5.2 Configuration of the PC Stations 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 165 

5.2.2 Operator Station Configurations 

Operator Station       
Operator stations are PCs on which the PCS 7 OS software is installed. The operator station 
is connected to the plant bus to allow data communication with the automation system.  
The architecture of the operator station is highly variable and can be flexibly adapted to a 
variety of plant sizes and customer requirements. The operator station can be configured as 
a single station or multiple station system with client-server architecture. 
The OS server contains all the data of the operating and monitoring systems and the 
interrupt and measured-value archive. It establishes the communication connection to the 
automation systems. The OS servers make the process data available for the OS clients. 
The OS clients are used to operate and monitor of the process mode. They access the data 
of one or more OS servers. 
We recommend using a terminal bus (separate from the plant bus) for data communication 
between OS clients and the OS server when installing a multiple station system. The 
process values archive can be stored on separate archive servers to improve performance. 
To increase availability, operator stations can be set up redundantly. 
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Possible PC configurations for operator stations 
The following PC configurations can be created for operator stations in a PCS 7 plant:  
● OS as single station system on a single PC: 

The complete operator control and monitoring capability for a PCS 7 project (plant/unit) is 
located in one station. The OS single station system on the plant bus can be used in 
parallel with additional single station or multiple station systems.  
Two OS single workstation systems can also be operated redundantly with the 
WinCC/Redundancy software package. 
The operator station can also be used in combination with an engineering station and an 
automation system on a single PC. This solution is offered as the SIMATIC PCS 7 Box. 

● OS as multiple station system with client-server architecture: 
The OS multiple station system consists of OS clients (operator stations) that are 
supplied with data (project data, process values, archives, alarms and messages) by one 
or more OS server via a terminal bus.  
OS clients can access data on several OS servers simultaneously (multi-client operation). 
OS servers also feature client functions so that they can access data (archives, 
messages, tags, variables) on other OS servers. This allows process pictures on one OS 
server to be interconnected with tags on other OS servers (server-server communication).  
The PCS 7 Server Redundancy software package allows the OS servers to also be 
operated redundantly. 
A maximum of 4 monitors can be connected to a station (OS client) using a multi-VGA 
card. Plant areas that have been split up in this way can be managed using 1 keyboard 
and 1 mouse. 

Central archive server 
For operator stations, it is also possible to use a central archive server on a separate PC 
station.  
The archive server is a node on the terminal bus and is not connected to the plant bus.  
You can also configure the central archive server redundantly in order to increase the 
availability. 

Maintenance Station (Asset Management) 
An Operator station (an OS area) can also be configured and used as a maintenance 
station. With the maintenance station, it is possible to call up information on the status of all 
PCS 7 components in hierarchically structured diagnostic pictures.  
A maintenance station can be configured in an MS client/MS server architecture. The MS 
client should ideally be operated on an engineering station. The MS server is an OS server.  
Maintenance stations can also be configured redundantly to increase the availability. 
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PCS 7 OS Web option 
PCS 7 provides the option of using operator control and monitoring functions of the PCS 7 
OS (single station or multiple station system) in process mode over the Internet or Intranet.  
● A PCS 7 WebNavigator client uses Internet Explorer to access the project data on a 

PCS 7 Web server over the Intranet/Internet. The process can be operated and 
monitored. 

● The PCS 7 Web server is an OS client with PCS 7 Web server functionality. 
– OS multiple station system: An OS client that is configured as a PCS 7 Web server 

can no longer be utilized as an operator station (OS client) within the PCS 7 plant in 
the case of an OS multiple station system. 

– OS single station system: The OS single station system that is configured with 
PCS 7 Web server can still be utilized within the PCS 7 plant as a PCS 7 OS. 

Additional information 
● Section "Connecting Network Nodes to Ethernet (Page 91)" 
● Section "How Many Operator Stations are Required? (Page 67)" 
● Section "Access to the PCS 7 OS via WebNavigator client (Page 125)" 
● For further information on the structure of operator stations or maintenance stations and 

on installing the operating system and the PCS 7 OS software including the necessary 
authorizations, refer to the manual Process Control System PCS 7; PC-Configuration and 
Authorization. 

● Manual Process Control System PCS 7; PCS 7 BOX 
● Manual Process Control System PCS 7; PCS 7 OS Web Option 
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5.2.3 BATCH Station Configurations 

BATCH station      
BATCH stations are PCs on which SIMATIC BATCH is installed. The BATCH station is 
connected to the terminal bus to allow data communication with the operator station. In 
process mode, the BATCH station communicates with the automation system only over the 
operator station. 

 

 Note 
Exception: With SIMATIC BATCH versions "AS based V6.1" and "AS based 7.0", direct 
communication with the automation systems is used instead of communication via the OS. 

 

The architecture of the BATCH station is highly variable and can be flexibly adapted to a 
variety of plant sizes and customer requirements. The BATCH station can be configured as a 
single station or multiple station system with client-server architecture. 
Typical batch process automation features one BATCH server and several BATCH clients 
that process the plant project together. BATCH servers can be configured redundantly to 
increase the availability. 
BATCH servers and OS servers should always be operated on separate PCs. BATCH 
clients and OS clients can be operated on a common PC. 

 

 Note 
Exception: With SIMATIC BATCH versions "AS based V6.1" and "AS based 7.0", the 
BATCH server must not be separated from the OS. In this case, the BATCH server and 
operator station must run on a single computer. 
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PC Configuration Options for BATCH Stations 
The following PC configurations can be created for BATCH stations in a PCS 7 plant:  
● For small plants: 

– BATCH station and operator station as a single station system on a single common 
PC 

– BATCH station separate from an operator station as a single station system on a 
single PC 

 

 
 

Note 
Exception: With SIMATIC BATCH versions "AS based V6.1" and "AS based 7.0", the 
BATCH server must not be separated from the OS. In this case, the BATCH server 
and operator station must run on a single computer. 

 

● For large plants: 
– BATCH station as multiple station system with client-server architecture: 

It consists of one BATCH server and several BATCH clients (operator stations) 
BATCH clients and OS clients can be operated on separate PCs or on a common PC.  
BATCH servers can also be operated redundantly. 
A maximum of 4 monitors can be connected to a station (BATCH client) using a multi-
VGA card. You can control all the plant areas that are split between the 4 monitors 
with a keyboard and/or a mouse.  

Additional information 
● For further information about the configuration of BATCH stations and the installation of 

the operating system and SIMATIC BATCH software including the required 
authorizations, refer to the manual Process Control System PCS 7; PC Configuration and 
Authorization. 

● Manual Process Control System PCS 7; SIMATIC BATCH 
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5.2.4 Configuration of the Route Control stations 

Route Control Station  
Route Control stations are PCs on which SIMATIC Route Control is installed. Both the Route 
Control server and the Route Control client are connected to the terminal bus. The Route 
Control server is additionally connected to the system bus. 
The architecture of the Route Control station is highly variable and can be flexibly adapted to 
a variety of plant sizes and customer requirements. The Route Control station can be 
configured as a single station or multiple station system with client-server architecture. 
Typical route control features one Route Control server and several Route Control clients 
that operate the plant project in union. Route Control servers can be configured redundantly 
to increase the availability. 

 

PC Configuration Options for Route Control Stations 
The following PC configurations are possible for Route Control stations in a PCS 7 plant:  
● For small plants: 

– Route Control station and operator station as a single station system on a single. 
common PC 

– Route Control station separate from an operator station as a single station system on 
a single PC 

● For large plants: 
– Route Control station as a multiple station system with client/server architecture: 

It consists of one Route Control server and several Route Control clients (operator 
stations). 
Route Control clients and OS clients can be operated on separate PCs or shared PCs.  
Route Control servers can also be operated redundantly. 
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Additional information 
● You can find detailed information about configuring Route Control stations and installing 

the operating system and SIMATIC Route Control software including the required 
authorizations in the manual Process Control System PCS 7; PC Configuration and 
Authorization. 

● Manual Process Control System PCS 7; SIMATIC Route Control 
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5.2.5 Structure of the OpenPCS 7 station 

OpenPCS 7 station      
The OpenPCS 7 station is a PC on which servers for OPC or for OLE DB are installed. The 
architecture of the OpenPCS 7 station is variable and can be flexibly adapted to a variety of 
plant sizes and requirements.  
The OpenPCS 7 station performs the following tasks: 
● It provides the PCS 7 data of the automation process via the OPC or OLE DB interface. 
● It allows the client applications (OPC or OLE DB) to access the provided PCS 7 data. 
The OpenPCS 7 station is connected to the terminal bus of the PCS 7 plant.  
In process mode, the OpenPCS 7 station communicates with the automation systems via the 
operator station (OS server). 

PC configuration options for the OpenPCS 7 station 
The following PC configurations are possible for the OpenPCS 7 station in a PCS 7 plant:  
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No. Configuration Area of application 
1 OpenPCS 7 station, OS client, and client applications (OPC 

or OLE DB) on a shared PC 
Single station system: 
Recommended for small plants 

2 OpenPCS 7 station and client applications (OPC or OLE DB) 
on separate PCs connected by an additional network 
(Internet/Intranet in the figure).  
With this configuration, the OpenPCS  7 station can also be 
installed on an  
• OS client 
• OS server 
• Central archive server 
• OS single station system 

Multiple station system with 
client-server architecture:  
Recommended for medium-
sized and large plants  

3 OpenPCS 7 station and client applications (OPC or OLE DB) 
on separate PCs connected by an additional network 
(Internet/Intranet) and access the terminal bus of the PCS 7 
plant protected by a firewall. 

Multiple station system with 
client-server architecture:  
Recommended for medium-
sized and large plants 

OpenPCS 7 can also be installed on an OS single station system, on an OS server, or on a 
CAS. 

Accessing Data from Redundant Server Pairs 
You can access data of redundant server pairs using the OpenPCS 7 station. If a PC station 
(master) fails, the redundant PC station is automatically connected for the next read job. 
If the connection is interrupted during a read job, the OpenPCS 7 station attempts to read 
data from the redundant partner. 

Additional information 
● Section "How to insert and configure an OpenPCS 7 station (Page 285)" 
● You can find detailed information on installing the operating system and the OpenPCS 7 

software, including the required license keys, in the manual titled Process Control System 
PCS 7; PC Configuration and Authorization. 

● Manual SIMATIC NET; Industrial Communication with PG/PC 
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5.3 Configuration of the Terminal and Plant Bus 

5.3.1 Data Paths via the Terminal Bus and Plant Bus 

Communication Paths 
The following figure shows the communication paths and system bus using an example. 

 

Legend to figure  
 
Bus Data communication or 

communication of the following 
processes 

Communication between ... 

Download of the configuration 
data  

Engineering station and the following stations: 
• Operator stations (OS server, OS clients) 
• BATCH stations (BATCH server, BATCH 

clients) 
• Route Control stations (Route Control server, 

Route Control client) 

Communication between the 
servers 

• OS servers 
• BATCH servers and OS servers relevant to 

BATCH 

Terminal bus 

Transmission of data processed 
by the servers to the operator 
control and monitoring stations 
(clients) 

• OS server and OS clients 
• BATCH server and BATCH clients 
• Route Control server and Route Control clients
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Bus Data communication or 
communication of the following 
processes 

Communication between ... 

Download of the configuration 
data  

Engineering station and automation system 

Operating and monitoring of the 
processes 

Automation systems and OS Server, Route 
Control Server 
(CPU -> CP -> BUS -> network adapter (CP) -> O 
/RCS) 
Note: communication for SIMATIC BATCH is from 
the OS server to the BATCH server via the 
terminal bus. 

Plant bus 

Communication between 
automation systems (SIMATIC 
communication) 

The automation systems 
(CPU -> CP -> BUS -> CP -> CPU) 
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5.3.2 Terminal Bus and Plant Bus Configurations 

Topology Options    
The plant bus and terminal bus can be configured as follows: 
● As Industrial Ethernet (10/100 Mbps and Gigabit) 
● Bus, tree, ring, star or redundant ring structures 
Information concerning Industrial Ethernet properties can be found in Section "Fields of 
Application and Parameters of the Network / Bus Systems (Page 79)". 

Available SIMATIC NET Components 
 

 Purpose Component of  
SIMATIC NET 

Additional sections 

• CP 1613/CP 1623 Connecting Network Nodes to 
Ethernet (Page 91)  

• BCE with integrated Ethernet 
card 

 

PC (OS, BATCH, 
Route Control and ES) 

Connection components for 
Ethernet 

• BCE with desktop 
adapter network card 

 

• CP 443-1  AS Connection components for 
Ethernet • CPU with integrated Ethernet 

interface 
 

• ITP cable (Industrial Twisted 
Pair) 

Management Level Scheme 
with Ethernet (Page 82)  

• TP cable (Twisted Pair) Optical and Electrical 
Transmission Media (Page 90)  

Electrical transmission path 

• Coaxial cable  

Connection path 

Optical transmission path • Glass fiber FO cable  

Optical and/or electrical 
transmission path 

• SCALANCE X Maximum Transmission Rate of 
the Network / Bus Systems 
(Page 80)  

• ESM Management Level Scheme 
with Ethernet (Page 82)  

Electrical transmission path 

• Star coupler, ELM Using Switching Technology 
with SCALANCE X (Page 84)  
Using Switching Technology 
with OSM/ESM (Page 88)  

• OSM, OMC Planning the Field Level with 
PROFIBUS (Page 96)  

Network coupler 

Optical transmission path 

• OLM  
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Configuration of Redundant Buses 
Information concerning redundant bus configuration can be found in Section "Configuring 
Redundant Ethernet Networks (Page 93)". 

Additional information 
Refer to the following documentation for additional information about network architecture, 
network configuration, network components and installation instructions: 
● List of PCS 7-enabled modules Contains the SIMATIC NET components which are 

enabled for a PCS 7 version 
● Manual SIMATIC NET NCM S7 for Industrial Ethernet 
● Manual SIMATIC Net PROFIBUS Networks 
● Manual SIMATIC NET; Triaxial Networks 
● Manual SIMATIC Net Twisted Pair and Fiber-Optic Networks 
● Operating Instructions SIMATIC NET; Industrial Ethernet Switches SCALANCE X-400 
● Configuration manual SIMATIC NET; Industrial Ethernet Switches SCALANCE X-400 
● Operating Instructions SIMATIC NET; Industrial Ethernet Switches SCALANCE X-200 
● Manual Industrial Ethernet OSM/ESM; Network Management 
● Manual SIMATIC NET; AS Interface – Introduction and Basic Information 
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5.4 Installation of the Automation Systems and Connected I/Os 

5.4.1 Configurations of the Automation Systems 

Automation systems 
The following automation systems can be configured by selecting hardware and suitable 
software: 
 
Automation systems Additional sections 
• Standard automation systems  

• Fault-tolerant automation systems  
(H systems) 

Redundancy concept for PCS 7 (Page 70) 
Recommended use of components (Page 76) 

• Fail-safe automation systems  
(F systems) 

Operational reliability of PCS 7 (Page 73) 
Recommended use of components (Page 76) 

• Fail-safe and fault-tolerant automation systems 
(FH systems) 

Redundancy concept for PCS 7 (Page 70) and 
Operational reliability of PCS 7 (Page 73) 

Available S7-400 Components  
 
Purpose Components Additional sections 
Automation system • AS 400H/F/FH Overview of the Automation 

Systems (Page 134) 
Limits of the CPUs for PCS 7 
Projects (Page 137) 
Default Performance Parameters 
of the CPUs for PCS7 Projects 
(Page 138) 

Fault-tolerant automation 
system 

• AS 400H Components for Fault-tolerant 
Automation Systems (Page 139) 

Fail-safe automation system • AS 400F/FH Components for Fail-safe 
Automation Systems (Page 141) 

Connection components for 
Ethernet 

• CP 443-1 
or 
• Ethernet interface of the CPU

Connecting Network Nodes to 
Ethernet (Page 91) 

Connectivity device for 
PROFIBUS 

• CP 443-5 Extended 
or 
• PROFIBUS DP interface 

Connecting PROFIBUS DP 
Nodes (Page 102) 
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SIMATIC PCS 7 Box PCs 
The following SIMATIC PCS 7 Box PCs (PC bundles) with integrated AS are available for 
use in PCS 7: 
● SIMATIC PCS 7 BOX 416: Version with Slot PLC CPU 416-2 PCI 
● SIMATIC PCS 7 BOX RTX: Version with software PLC WinLC RTX 
The automation system integrated in SIMATIC PCS 7 Box PCs is a standard automation 
system. 

Additional information 
● List PCS 7 - Enabled modules 
● Function manual Process Control System PCS 7; Fault-tolerant Process Control Systems 
● Manual SIMATIC Programmable Controllers S7 F/FH 
● Manual S7-300 Fail-safe Signal Modules 
● Manual, Process Control System PCS 7; SIMATIC PCS 7 BOX. 
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5.4.2 Guide to the Installation Instructions for the Products 

Installation Instructions      
This section is an orientation for installation instructions in the individual product 
documentation. 

 

 Note 
Information relating to installation in the project documentation manuals for SIMATIC 
components is also valid when PCS 7 is used. There are a small number of exceptions in 
terms of installation and these are dealt with in Section "Supplements to the Installation 
Instructions of the Products for PCS 7 (Page 185)". 
Information relating to programming and parameter assignment in the project documentation 
manuals for SIMATIC components is of limited validity when PCS 7 is used. PCS 7 offers 
many additional tools and functions. You should follow the procedures described in the 
section “Creating the PCS 7 Configuration“ in this manual when programming and setting the 
parameters of the SIMATIC components. 

 

Guide to the Installation Instructions  
 
Components Information relating to installation can be found in the following product 

documentation (• Chapter ...) 
Communication 
Industrial Ethernet Manual SIMATIC NET; NCM S7 for Industrial Ethernet 

Manual SIMATIC NET; Triaxial Networks 
Manual SIMATIC Net Twisted Pair and Fiber-Optic Networks 

PROFIBUS Manual SIMATIC Net PROFIBUS Networks 
AS interface Manual SIMATIC NET; AS Interface – Introduction and Basic Information 
SCALANCE X Manuals SIMATIC NET; Industrial Ethernet Switches SCALANCE X 
OSM/ESM Manual SIMATIC NET; Industrial Ethernet OSM/ESM Network 

Management 
CP 443-1 Device manual SIMATIC NET S7 CPs for Industrial Ethernet/Part B4; 

CP 443-1: 
• Installation and Commissioning (steps 1 to 3) 

CP 443-5 Extended Device manual SIMATIC NET; S7 CPs for PROFIBUS / Part B4; CP 443-5 
Extended: 
• Installation and Commissioning (steps 1 to 2) 

CP 1613/CP 1623 Installation Instructions SIMATIC NET; CP 1613 
Operating Instructions (compact) SIMATIC NET, CP 1623 
Manual SIMATIC NET; Time-of-day Functions of the CP 1613 

CP 1612 Installation instructions SIMATIC NET; CP 1612 
CP 1512 Installation instructions SIMATIC NET; CP 1512 
RS 485-Repeater Manual S7-400, M7-400 Programmable Controllers; Module 

Specifications: 
• RS 485-Repeater 
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Components Information relating to installation can be found in the following product 
documentation (• Chapter ...) 

PC stations 
PC stations (ES, OS, 
BATCH, Route Control, 
archive server, 
OpenPCS 7,  
PCS 7 BOX) 

Manual Process Control System PCS 7; PC Configuration and 
Authorization 
• Configurations 
• Structure 
• Installation 

Automation systems 
S7-400  
(AS 414-3,  
AS 416-2,  
AS 416-3,  
AS 417-4) 

Manual S7-400, M7-400 Programmable Controllers; Hardware and 
Installation: 
• Installing the S7-400 
• Wiring the S7-400 
• Commissioning 
Manual Programmable Controller S7-400; CPU Data 
• Installation of a CPU 41x 
• Technical specifications 

S7-400H  
(AS 414-4-H and  
AS 417-4-H) 

Manual Process Control System PCS 7; Fault-tolerant Process Control 
Systems: 
• Fault-tolerant Solutions in PCS 7 
Manual SIMATIC S7-400H Programmable Controllers; Fault-tolerant 
Systems: 
• S7-400H Installation Options 
• Getting Started 
• Installation of a CPU 41x-H 
• Using I/O on the S7-400H 
• Plant changes in runtime 

S7-400F/FH  
(AS 414-4-H and  
AS 417-4-H) 

System Description Safety Engineering in SIMATIC S7: 
• Overview of Fail-safe Systems 
• Configurations and Help with Selections 
Manual SIMATIC Programmable Controllers S7 F/FH 
• Safety Mechanisms 
Manual SIMATIC S7-400H Programmable Controller; Fault-tolerant 
Systems: 
• S7-400H Installation Options 
• Getting Started 
• Installation of a CPU 41x-H 
• Using I/O on the S7-400H 

PCS 7 AS RTX Function Manual Process Control System PCS 7; SIMATIC PCS 7 BOX 
• Installation of PCS 7 AS RTX 
• Commissioning and configuration of PCS 7 AS RTX 

S7-400 Fail-safe Signal 
Modules 

Manual S7-400, M7-400 Programmable Controllers; Module 
Specifications: 
• Technical specifications 
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Components Information relating to installation can be found in the following product 
documentation (• Chapter ...) 

FM 455 S 
FM 455 C 

Manual FM 455 Controller Module: 
• Controller Settings 
• Installing and Removing the FM 355 and FM 355-2 
• Wiring 

CP 441 Manual Point-to-Point Coupling CP 441; Installation and Parameter 
Assignment: 
• Basic Principles of Serial Data Transmission 
• Mounting 
• Wiring 

CP 444 Manual CP 444 Communication Processor; Installation and Parameter 
Assignment: 
• Basic Principles of Serial Data Transmission 
• Mounting 
• Wiring 

PCS 7 BOX 416,  
PCS 7 BOX RTX 

Manual Process Control System PCS 7; SIMATIC PCS 7 BOX 
• Use and Area of Application 
• Configuration Options 

Distributed I/O 
ET 200M Manual SIMATIC; Distributed I/O Device ET 200M 

• Configuration Options with the ET 200M 
• Mounting 
• Wiring 

S7-300 Fail-safe Signal 
Modules 

Manual SIMATIC; S7-300 Programmable Controller Module 
Specifications: 
• Manual for hardware configuration and parameter assignment of 

components 
• Technical specifications 

S7-300 Signal Modules 
for Process Automation 

Manual Distributed I/O Device ET 200M Signal Modules for Process 
Automation: 
• Manual for hardware configuration and parameter assignment of 

components 
• Technical specifications 

S7-300 Fail-safe  
Signal Modules 

Manual Automation System S7-300; Fail-safe Signal Modules: 
• Manual for hardware configuration and parameter assignment of 

components 
• Technical specifications 

S7-300  
Signal Modules with 
Intrinsically-Safe Signals 

Manual S7-300, M7-300, ET 200M Programmable Controllers, 
I/O Modules with Intrinsically-Safe Signals: 
• Manual for hardware configuration and parameter assignment of 

components 
• Technical specifications 
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Components Information relating to installation can be found in the following product 
documentation (• Chapter ...) 

FM 355 S 
FM 355 C 

Manual FM 355 and FM 355-2 Controller Modules : 
• Controller Settings 
• Installing and Removing the FM 355 and FM 355-2 
• Wiring 

CP 340 
CP 341 

Manual CP 340 Point-to-Point Communication and CP 341 Installation 
and Parameter Assignment: 
• Basic Principles of Serial Data Transmission 
• Mounting 
• Wiring 

ET 200iSP Manual SIMATIC; ET200iSP Distributed I/O Device: 
• Configuration options 
• Mounting 
• Wiring and Fitting 

ET 200S Manual SIMATIC; Distributed I/O Device ET 200S 
• Configuration options 
• Mounting 
• Wiring and Fitting 

ET 200pro Manual SIMATIC; Distributed I/O System ET 200pro 
• Configuration options 
• Mounting 
• Wiring and Fitting 

DP/PA Link and 
DP/PA Coupler 

Manual SIMATIC; DP/PA Link and Y Link Bus Couplers:  
• Description of the Components 
• Installation 
• Wiring 

DP/EIB link Manual SIMATIC NET; DP/EIB Link:  
• Description of the Components 
• Installation 
• Wiring 

DP/AS-i Link 20 E 
DP/AS-i LINK Advanced 

Manual SIMATIC NET; DP/AS I Link 20E 
Manual SIMATIC NET; DP/AS-INTERFACE LINK Advanced:  
• Description of the Components 
• Installation 
• Wiring 

DP/FF Link Manual  
• Description of the Components 
• Installation 
• Wiring 
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Components Information relating to installation can be found in the following product 
documentation (• Chapter ...) 

Y Link  Manual SIMATIC; DP/PA Link and Y Link Bus Couplers:  
• Description of the Components 
• Installation 
• Wiring 

Diagnostic repeaters Manual Diagnostic Repeater for PROFIBUS DP: 
• Configuration options 
• Mounting 
• Wiring 
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5.4.3 Supplements to the Installation Instructions of the Products for PCS 7 

ET 200S Diagnostics for Load Voltage Failure 
 

 Note 
The digital input/output modules of the ET 200S do not feature diagnostics for load voltage 
failure. No QBAD is displayed on the channel drivers during load voltage supply failure.  
The outputs can no longer be switched by the user program and the last valid value is 
displayed at the inputs when there is no load voltage.  

 

The following configuration variants offer a remedy: 
● Using 24 V DC digital input/output modules with a PM-E 24 V DC power module: 

A voltage supply failure leads to the failure of the station because the entire station 
(IM 151 and power module) is supplied from the same DC 24 V source. This is reported 
in the PCS 7 and results in the passivation of all associated modules. All channel drivers 
are set to QBAD. 

● Use of AC 120/230 V digital input/output modules with a PM-E AC 120/230 V power 
module: 
Monitoring of the load voltage in the user program 

5.4.4 Rules for Configuration in RUN (CiR) 

Rules for DP and PA Slaves 
Observe the following rules when configuring distributed I/Os when CiR is used: 
● Plan for a sufficient number of junctions for spur lines or gaps when configuring the DP 

master system. Spur lines are not permitted for transmission rates of 12 Mbps. 
● Terminate the PROFIBUS DP and PROFIBUS PA bus lines with active bus termination 

elements at both ends to ensure proper bus termination even while changing the 
configuration. 

● We recommend that you install PROFIBUS PA bus systems using components from 
SpliTConnect product series to keep you from splitting up the lines. 

● ET 200M Stations and DP/PA links must always be installed with an active backplane 
bus. When possible install all the bus modules that will be required because the bus 
modules can not be installed and removed during operation. 

● In ET 200M stations, you may only insert modules directly after the last installed module 
or remove the last module. Always avoid gaps between modules. 

● Assemble the ET 200iSP stations fully with terminal modules and a termination module. 
Equip the ET 200iSP of the IM 152 with the required electronic modules right from the 
start. Install the reserve modules in the remaining slots right up to the termination module. 
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Basic Concepts of Engineering 6
6.1 Introduction to the basic concepts of engineering 

Overview 
The following contains an introduction to the basic mechanisms of engineering with PCS 7. 
In the foreground are the PCS 7 functions which enable you to configure efficiently: 
● Central, plant-wide engineering (Page 188) 
● Setting up the projects with the PCS 7 wizard (Page 190) 
● Distributed engineering (Page 196) 
● Type definition, reusability and central modifiability of engineering data (Page 205) 
● Importing and reusing plant data (Page 217) 
● Free assignment between hardware and software (Page 220) 
● Deriving the picture hierarchy and OS areas from the PH (Page 221) 
● Generating block icons (Page 223) 
● Generating operator texts (Page 224) 
● Basic concepts of the PCS 7 event-signaling system (Page 225) 
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6.2 Central, Plant-Wide Engineering 

Central Engineering with the SIMATIC Manager 
The SIMATIC Manager is the central starting point for all engineering tasks.  
The PCS 7 project is managed, archived and documented there.  
All the applications of the engineering system are accessible from the SIMATIC Manager.  
If there is a connection between ES, OS, BATCH, Route Control and AS, the configuration 
data can be transferred to the target systems from the SIMATIC Manager and then tested 
online.  

Engineering system 
The engineering system is structured on matching applications, facilitating the central, 
project-wide engineering of all the components on a PCS 7 plant: 
● Configuration of the hardware and field devices (HW Config, SIMATIC PDM) 
● Configuration of the communications networks (HW Config) 
● Configuration of continuous and sequential process sequences (CFC, SFC, PCS 7 

Library) 
● Configuration of discontinuous process sequences - batch processes (SIMATIC BATCH) 
● Configuration of route controls (SIMATIC Route Control) 
● Design of the operator control and monitoring strategies (WinCC Graphics Designer, 

Faceplate Designer) 
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● Configuration of the alarm system (OS Project Editor, Alarm Logging) 
● Compilation and downloading of all configuration data to the target automation system 

(AS), operator station (OS), BATCH station (BATCH) and Route Control station 

 

Integrated database 
Thanks to the engineering system's integrated database, data which has been entered once 
is available throughout the system. 

Additional information 
● Section "PCS 7 Applications and How They Are Used (Page 249)" 
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6.3 Creating the Projects and Access Protection 

6.3.1 Setting up the Projects with the PCS 7 "New Project" Wizard 

PCS 7 "New Project" Wizard 
The PCS 7 "New Project" wizard enables you to create a new PCS 7 project. You can create 
all the requisite objects automatically via dialog boxes.  
Start the PCS 7 "New Project" wizard in the SIMATIC Manager. 

 
In the following you will find out what benefits the PCS 7 wizard can offer you. 
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PCS 7 "New Project" wizard options 
You can select the following via dialog boxes: 
● which CPU you wish to use 
● which AS objects (CFC chart, SFC chart) and OS objects (PCS 7 OS, SIMATIC BATCH, 

SIMATIC Route Control, OpenPCS 7) you wish to create 
● whether PCS 7 OS, SIMATIC BATCH, SIMATIC Route Control, or OpenPCS 7 should be 

a single station, multiple station or redundant multiple station system 
● what you new project should be called 
● where the project should be stored (project path) 
Check the structure of your project beforehand in a preview. Then start to complete the 
project. 

Result 
In multiproject engineering a multiproject containing a subordinate project is created in the 
SIMATIC Manager in accordance with the preview (see figure above). The preview is 
adapted in line with the selected settings and shows you the structure which has been 
created by the PCS 7 wizard. 
There is also a master data created with the following content: 
● in the plant hierarchy: 

separate folders for process tag types, models and shared declarations 
● in the component view: 

an S7 program with the folders for source files, blocks and charts 
a folder for shared declarations 

Additional information 
● Section "How to Create a New Multiproject with the PCS 7 Wizard (Page 258)". 
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6.3.2 Expanding the Projects with the PCS 7 "Expand Project" Wizard 

PCS 7 "Expand Project" Wizard      
The PCS 7 "Expand Project" wizards enables you to expand an existing PCS 7 project to 
include further preconfigured SIMATIC 400 stations or SIMATIC PC stations. You can create 
all the requisite objects automatically via dialog boxes.  
Start the PCS 7 "Expand Project" wizard in the SIMATIC Manager. 

Options for inserting preconfigured stations 
You can select the following via dialog boxes: 
● whether you wish to create a SIMATIC station and/or a PC station (without integrating 

hardware) 
● which CPU you wish to use 
● which AS objects (CFC chart, SFC chart) and OS objects (PCS 7 OS, SIMATIC BATCH, 

SIMATIC Route Control, OpenPCS 7) you wish to create 
● whether PCS 7 OS, SIMATIC BATCH, SIMATIC Route Control, or OpenPCS 7 should be 

a single station, multiple station or redundant multiple station system 
● where the project should be stored (project path) 
You can check the structure of your project beforehand in a preview.  

Result 
An additional SIMATIC 400 station or SIMATIC PC station is created for OS/BATCH/Route 
Control/OpenPCS 7 in the selected project (in accordance with the preview).  

Additional information 
● Section "How to Expand a Project with Preconfigured Stations Using the PCS 7 Wizards 

(Page 263)". 
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6.3.3 Protecting Projects/Libraries with Access Protection 

Introduction     
We recommend that you protect your projects and libraries against unwelcome access and 
log all access actions. 

 

 Note 
In order to use this functionality, SIMATIC Logon needs to be installed. 

 

Access via a project password 
As of PCS 7 V7.0, you have the option of assigning a project password to provide access 
protection for projects and libraries. These projects and libraries can then only be opened 
and edited by Windows users with one of the following user roles: 
● Project administrator 
● Project editor 
● Any user who authenticates himself using the project password 

Setting up the authorizations 
The project administrator defines the project editor and the project password. He is entitled 
to activate and deactivate access protection.  
The project administrator can assign Windows users to one of the two user roles. 
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Functions for Setting Access Protection 
You can set the following access-protection settings per project or library in the SIMATIC 
Manager. Synchronization is possible across an entire multiproject. 
 
Function Description Can be executed with a 

user role 
Activating Access 
Protection 
(including defining a 
project password) 

• Activates access protection for a particular 
project or library 

This project or library may only be opened and 
edited by Windows users who are assigned the 
roles of project editor or project administrator. 

• Specifies the project password 

You can specify a project password for each 
project or library 

Project administrator 

Deactivating Access 
Protection 

Deactivates access protection for a particular project 
or library again. 

Project administrator 

Managing users Specifies the project administrators and project 
editors 

Project administrator 

Synchronizing 
access protection in 
the multiproject 

Specifies the project administrators and project 
editors globally for all the projects and libraries in a 
multiproject. 

Project administrator 

Displaying the 
Change Log 

Opens the change log Project administrator 
Project editor 

Removing Access 
Protection and 
Change Log 

Removes the access protection and deletes the 
change log for a password-protected project or 
library. 

Project administrator 

Change Log 
The following events can be logged via a change log if access protection is activated, for 
example: 
● Activating/deactivating/configuring access protection and change logs 
● Opening/closing projects and libraries 
● Downloading to PLCs (system data) 
● Operations for downloading and copying blocks 
● Changing parameters in test mode 
● Activities for changing the operating states of the CPU (e.g. STOPPING the CPU) 
● Resetting the CPU 
You can have the change log displayed, add comments to it or export it. 
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Functions for Setting the Change Log 
Perform the following change-log functions in the SIMATIC Manager. 
 
Function Description Can be executed with a 

user role 
Activating the 
change log 

Activates the change log for access-protected 
projects or libraries. 

Project administrator 

Deactivating the 
change log 

Deactivates the change log for access-protected 
projects or libraries again. 

Project administrator 

Displaying the 
Change Log 

Displays the content of the content of the change 
log. Comments can be added. 

Project administrator 
Project editor 

Additional information 
● Section "How to Provide Projects/Libraries Access Protection (Page 266)" 
● Section "How to Document Changes in the Change Log (Page 679)" 
● Section "How to Document Changes in the ES Log" (Page 676)" 
● Manual SIMATIC Logon; SIMATIC Electronic Signature 
● Online help for change log 
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6.4 Distributed Engineering 

6.4.1 Introduction to Distributed Engineering 

Introduction  
PCS 7 offers the following options for working with several planning engineers: 
● Configuring in a Multiproject (Page 196) 
● Branching and Merging Charts from a Project (Page 201) 
If the project data is located on a central server, it can be exchanged between engineering 
stations via the network (e.g. a project-specific block library): 
● Configuration in the Network (Page 203) 

6.4.2 Configuring in a Multiproject 

Use of Multiproject Engineering        
You can use multiproject engineering if you wish to have several project teams work in 
parallel on complex projects. 
To facilitate this, divided the automation solution technologically into multiple projects. The 
projects are created on a central engineering station under a "multiproject" and are moved to 
the workstations of the various planning engineers for processing (distributed engineering 
stations). Once the projects have been processed and returned to the multiproject, cross-
project data can be harmonized with the support of the system. 
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Structure of the Multiproject 
The multiproject is a structure at a level above the projects within the SIMATIC Manager. It 
comprises all the projects, the master data library, as well as the subordinate objects (AS, 
OS, programs, charts, etc.) for an automation solution. 

 

Rules for Distribution to the Projects 
Split the automation solution up in such a way that all the automation systems and operator 
stations which a planning engineer has to edit are contained in a single project. The following 
rules apply: 

 

 Note 
Please note the following: 
• A project in a multiproject may only be edited by one planning engineer at any given time.
• The smallest possible unit of a project is an AS or an OS. 
• Only move complete projects to a distributed engineering station. 
• Only move objects (AS, OS) to a distributed engineering station in the form which is 

actually necessary for editing. This means that all other objects of the multiproject are 
available for editing on the central distributed engineering stations. 

• An OS server must contain all the plant hierarchies of the automation systems which are 
assigned to it. 
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Rules for Multiproject Engineering with SIMATIC BATCH 
 

CAUTION  
For multiproject engineering with SIMATIC BATCH, distributed engineering on distributed 
engineering stations including testing is only possible when certain conditions are met and 
the additional steps are taken.  
You will find additional information on this topic on the Internet 
(http://support.automation.siemens.com/WW/view/en/23785345). 

 

Operating-system requirements  
 

 Note 
Please note the following: 
• In the case of distributed engineering for large projects, Windows Server 2003 R2 must 

be installed on the central engineering station to facilitate work on the network. 
• The distributed engineering stations can use Windows XP Professional SP3 or Windows 

Server 2003 R2 operating systems. 
 

Recommended procedure at a glance  
To enable you to work successfully with the multiproject, familiarize yourself with the 
multiproject in the section "Working with projects in the Multiproject" on the online help for 
STEP 7. We recommend the following procedure for working with PCS 7.  
 
Step Description 
1 Create the multiproject with a project and the master data library on the central 

engineering station (using the PCS 7 "New Project" wizard). 
2 Insert further projects and store the multiproject master data on the central engineering 

station. 
3 Move the projects, which are contained in the multiproject, and the master data library to 

the distributed engineering stations. 
4 Distributed Editing of the Projects 
5 Moving the distributed projects back to the central engineering station 
6 Executing cross-project functions on the central engineering station 

 
 

 Note 
While cross-project functions functions are executed, all the projects involved must be 
physically present in the multiproject on the central engineering station, and they may not be 
being worked on. 

 

In accordance with this procedure, the configuration process is also described in the section 
"Conducting the PCS 7 Configuration". 

http://support.automation.siemens.com/WW/view/en/23785345
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Re. step 3 - Recommended time for moving for the purposes of distributed editing 
There is no particular point in time at which the projects should be moved to the distributed 
engineering stations. We recommend that you at least execute the following steps on the 
central engineering station beforehand: 
● Create the multiproject with the individual projects 
● Create the AS and PC stations for OS, BATCH, Route Control, and OpenPCS 7 

underneath the individual projects 
● Create the structure of the plant hierarchy 
● Compile the master data library with the objects which have to be used jointly in the 

projects 
In accordance with this procedure, the configuration process is also described in the section 
"Conducting the PCS 7 Configuration". 

Re. step 6 - Cross-project functions  
The cross-project functions ensure that you can handle a multiproject virtually like a single 
project in the SIMATIC Manager. This allows you to archive the multiproject along with all the 
projects and master data library, for example, or to save it in a different location.  
In addition, there are cross-project functions which, after distributed editing, ultimately have 
to be executed in the multiproject on the central engineering station. They include: 
● Merging cross-project subnets and connections to textual references 
● Configuring the new cross-project (S7) connections between AS and OS 
● Compiling all the components contained in the PCS 7 plant (AS, OS, BATCH, Route 

Control, etc.) and downloading them automatically to the PLCs in the correct order 
● For each OS client: Downloading the data from all the corresponding OS servers  

The server data only has to be downloaded once. Thereafter, the server data is updated 
automatically every time an OS client is started in process mode. 

● Creating/updating block icons 
● Creating/updating the diagnostic screens 

 

 
 

Note 
While cross-project functions functions are executed, all the projects involved must be 
physically present in the multiproject on the central engineering station, and they may not 
be being worked on. 
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Additional information 
● Section "How to Expand the Multiproject by Adding New (Empty) Projects (Page 261)" 
● Section "How to Expand a Project with Preconfigured Stations Using the PCS 7 Wizards 

(Page 263)" 
● Section "Introduction to Distributing the Multiproject (Multiproject Engineering) 

(Page 342)" 
● Section "Merging projects after distributed editing (multiproject engineering) (Page 621)" 
● Section "Additional PH Functions in a Multiproject (Page 306)" 
● Online Help for STEP 7 
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6.4.3 Branching and Merging Charts from a Project 

Branching project charts 
Branching and merging in projects involving several planning engineers is also possible at 
chart level (S7 program). The distribution within the project is made according to 
technological aspects (for example, unit with the relevant charts is copied to a different 
project). Existing cross-chart interconnections are automatically replaced with textual 
interconnections. 
On completion of editing, the parts are copied back into the original project. Any charts with 
the same name are replaced following a prompt for confirmation. The textual 
interconnections are then reestablished. 

Use in Multiproject Engineering 
 

 Note 
This branching option can be applied independent of the multiproject engineering or in 
addition to the multiproject engineering.  
In the context of multiproject engineering, the master data library forms the basis for working 
separately on the charts from a project. 

 

Recommended procedure at a glance 
 
Step Description 
1 Copy a technological part of the project (individual chart, several charts) to a different project. 

Result: The copy contains textual interconnections to all the sources that do not lie within the 
copied sections. 

2 Edit the copied section separately (add, delete, modify blocks and charts). 
3 Copy the edited technological section back to the original project. 

Result: The system deletes the charts with the same names from the original project. There 
are textual interconnections in all the charts which await data from the deleted charts. 
Thereafter, the system copies the charts from the other project. 

4 Close all the textual interconnections. 
Result: The interconnections are established both in the charts edited in the other project and 
in the original project in which textual interconnections arose as a result of deleting charts. 
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 Note 
Always copy the charts in the component view. 
If you copy a chart in the plant view, a copy of the chart in the PLC is created instead of 
being replaced. 

 

Additional information 
● Section "Configuration by Several Users (Textual Interconnections) (Page 459)" 
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6.4.4 Configuration in the Network 

Application 
If several project engineers are working from their engineering stations on one project that is 
available on a central server or on a PC with a shared drive, they can also work on defined 
project sections at the same time.  
The following scenarios are possible in multiuser engineering:  
● Edit different charts from different chart folders 
● Edit different charts from the same chart folder 
● Work on the same chart 

 

 
 

Note 
The central network server is an engineering station which you cannot use for 
configuration. You do not require any license keys for this engineering station. 

 

 
 

Note 
Note the following: 
Only one planning engineer can access the data from an OS at any given time. 
WinCC Explorer prevents multiple project engineers from logging on to the same OS. 

 

Edit different charts from different chart folders 
Several project engineers can work on different charts from different chart folders at different 
engineering stations, independently of each other. In this scenario, the work performed by 
individual engineers generally does not conflict with the work of others. 

Edit different charts from the same chart folder 
Several project engineers can work on different charts from the same chart folder at different 
engineering stations, independently of each other. It is unlikely that work performed by one 
engineer conflicts with the work of others. However, conflicts cannot be completely ruled out, 
since all charts access the same resources such as the symbol table, run sequence, etc.. 
The following conflict situations can occur:  
● If one project engineer makes changes offline and other project engineers are working in 

test mode, when they next enter test mode, the engineers receive the message that the 
chart must be recompiled and loaded into the target system. It is then the responsibility of 
the project engineer to decide whether or not to enter test mode. Depending on the 
nature of the offline changes, this may or may not be practical. This must be resolved by 
discussion between the project engineers. 

● If, following the message that the data is being used by another application, a value for 
monitoring is logged on or off in test mode, this is not stored in the session log. The next 
time that test mode is started, the logging on or off must be repeated. 
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● If the values monitored in test mode are no longer updated as a result of offline changes 
(e.g., because a block was deleted), the system displays "#" characters on a red 
background at the corresponding connections instead of the values. 

● If one project engineer has started a compilation process and another project engineer 
changes a parameter in test mode, this parameter change is rejected with the message 
that the data is currently being used by another application (access conflict). 

Work on the same chart 
If several project engineers are working on the same chart, this can lead to mutual conflicts. 
This procedure is therefore not recommended. 

Behavior for different actions 
As a basic rule, in the event of an access conflict, the action with the highest priority is 
always executed. In this case, the lower priority action is cancelled. A short read action has a 
low priority, and all other actions have a higher priority. 
 
Type of action Read/write action Response 
Short read actions 
(with no resource 
allocation) are: 

• Open charts 
• Open run sequence 
• Open dialog boxes 

If additional short read actions are 
executed in parallel, no conflicts should 
occur. 
If a short or long write action is executed in 
parallel, this can lead to an access conflict, 
and the short read action is cancelled. 

Short write actions 
(with no resource 
allocation) are: 

• Instantiation, 
parameterization, 
interconnection, etc. 

• Close dialog boxes with 
OK 

If a short or long write action is executed in 
parallel, this can lead to an access conflict 
for whichever action was started later. 

Long read actions 
(with resource 
allocation) are: 

• AS-OS data transfer (OS 
compilation) 

If an access conflict does not occur 
immediately when the long read action is 
triggered, e.g., because a write action is 
already being executed in parallel, this 
action is executed with no access conflict. 

Long write actions 
(with resource 
allocation) are: 

• Optimizing the run 
sequence 

• Compile 
• Download 

If an access conflict does not occur 
immediately when the long write action is 
triggered, e.g. because a write action is 
already being executed in parallel, this 
action is executed with no access conflict. 

Additional information 
● Online help on CFC 
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6.5 Type Definition, Reusability and Central Modifiability of 
Engineering Data 

Principle       
Plant engineering gives rise to plant parts, functions or program sections which only differ 
from one another in a few respects. 
In the interests of working efficiently, create basic elements (units, program sections, etc.) 
which can be reused repeatedly and which only have to be supplied with the current 
parameters.  

Possible Basic Elements for Reuse 
 
Basic Elements Description 
Block type 
(Page 206)  

A block type is a program section that can be inserted into charts. A block 
instance is created. Block types are located in the PCS 7 Advanced Process 
Library. It contains blocks for activating a motor or valve, for example. 
You can also create your own block types or adapt block types from the 
PCS 7 Advanced Process Library in line with the needs of your plant. 

an SFC type 
(Page 209)  

An SFC type is a sequential controller which can be configured in the SFC 
and inserted into a CFC chart. An executable SFC instance is created. 

Process tag type 
(Page 210)  

A process tag type is a CFC chart (which may also contain SFC types) which 
is configured for basic automation of a process engineering plant that controls 
a specific system function. Process tag types can be created using the 
Import/Export Assistant (IEA). 

Model (Page 213)  A model may comprise even larger units, such as a sub-plant. It consists of 
hierarchy folders with CFC/SFC charts, pictures, reports and additional 
documents. Replicas can be created using the Import/Export Assistant (IEA). 

Project-Specific Catalog Profile 
A project-specific catalog profile can be created using the supplied hardware catalog (in 
HW Config: PCS 7_Vx.y).  
Configure the hardware efficiently using the catalog profile which is adapted to suit your 
needs. You will find additional information on this topic in Section "Defining a Project-Specific 
Catalog Profile (Page 353)". 
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6.5.1 Use of Block Types, Faceplates and Block Icons 

Block type            
Block types are precompiled parts of programs used to process recurring functions which 
can be inserted in CFC charts. The block type creates a block instance to which you can 
then assign parameters and can interconnect. The block type determines the characteristics 
for all the instances of this type.  
You can adapt block types to your project requirements, e.g. adapt operator texts or make 
parameters visible/hidden. To ensure that there is only one version of a block type used 
throughout a project, store all the block types centrally in the master data library (Page 214) 
and adapt them prior to instantiation.  

 

NOTICE  
Store the block types in the master data library. This means that you can be sure that only 
one version of a particular block type (with a type name) is used throughout the entire 
project. 
Different versions of blocks in different programs can lead to conflicts if the programs are to 
be controlled and monitored by one OS. This happens if variables of the same block type 
(identical type name) possess the same structure. 

 

Possible Block Types 
The following block types can be stored in the master data library: 
● Blocks types from the control system libraries 
● Block types from the libraries of suppliers 
● User-created block types from CFC charts 
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Central Modifiability 
If the interface description and/or system attributes of a block type are changed, and it is 
imported into the CFC data storage system, it overwrites (updates) an existing block type of 
the same name. All the block instances of this type are also changed to correspond to the 
new block type.  
The central type modifiability relates to FBs and FCs.  
Before the central change is executed, a warning appears referring to the consequences and 
containing information about the old and new block types, for example name, date of the last 
interface change. 
Changing the type centrally can have an unwelcome impact upon block instances. 
Interconnections and parameter-assignments can be lost. In this case you have to adapt the 
corresponding block instances yourself. 
Central type modifications are logged, and this log is displayed automatically after updates. 
You can also call up this log at a later point in time via the menu command Options > Logs: 
Block Types.... If block instances need to be adjusted, the log help to minimize the workload 
and the risk of error. 

Type/Instance Concept - Central Modifiability 
The advantage of the type-instance concept is the capability of centralized modification. This 
enables subsequent changes to be made centrally to the block type, SFC type, process tag 
type and model and then to be applied to all instances and replicas. 

 

 Note 
Refer to the online helps for the CFC, SFC and IEA to find out which type changes the 
instances and replicas support. 

 

Faceplates and Block Icons 
Controlling and monitoring a block instance in process mode on the OS requires a 
corresponding faceplate. The faceplate contains the graphic representation of all elements of 
the technological block intended for operator control and monitoring. The faceplate is 
depicted in a separate window in the OS and is opened via a block icon (typically placed in 
the OS overview display). 
A faceplate exists for every technological block type in the PCS 7 library. Block icons are 
generated automatically by means of a menu command. You can also create and adapt 
faceplates and block icons yourself.  



Basic Concepts of Engineering  
6.5 Type Definition, Reusability and Central Modifiability of Engineering Data 

 Engineering System (V7.1) 
208 Configuration Manual, 03/2009, A5E02122455-01 

Additional information 
● Section "How to Adapt Blocks to Specific Projects (Page 323)" 
● Manual Process Control System PCS 7 Library 
● Manual Process Control System PCS 7; Programming Instructions for Blocks 
● Online help on CFC 
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6.5.2 Using SFC Types 

SFC type 
SFC types allow sequential controllers to be defined as reusable templates. An SFC type is 
a sequential controller which can be configured in the SFC editor and be inserted into a CFC 
chart. An executable SFC instance is created. SFC instances appear in the CFC chart as 
blocks with an interface corresponding to the block instances. 
To run an SFC instance, both the SFC type and the SFC instance must be compiled and 
downloaded into the automation system. 
To ensure that there is only one version of an SFC type used throughout a project, store all 
the SFC types centrally in the master data library (Page 214) and adapt them prior to 
instantiation. 
Characteristics (control strategies, setpoints, parameter, note texts, position texts, etc.), 
which can be used in the sequencers, can be defined for SFC types. A control strategy is 
specified by operation or by a higher-level controller (e.g. SIMATIC BATCH). 

 

 Note 
You cannot assign SFC types to a hierarchy folder in the plant view since they themselves 
are not relevant to execution. 

 

 

Possible SFC Types 
You can also store the following SFC types, for example, in the library/master data library: 
● User-created SFC types 
● SFC types from the SFC library 

Central Modifiability 
Modifications to the interface of the SFC type are transferred to the SFC instances. 
The following changes take effect automatically in SFC instances following the compilation 
and downloading of the AS. 
● Change to the topology (step/transition sequence, changed jump target) 
● Change to the step configuration 
● Change to the transition configuration 
The SFC visualization is only updated following the compilation and downloading of the OS. 

Additional information 
● Section "How to Create an SFC Type (Page 555)" 
● Manual SFC for S7; Sequential Function Chart 
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6.5.3 Using Process Tag Types 

Process tag type     
A process tag type is a CFC chart (which may also contain SFC types) which is configured 
for basic automation of a specific system function, such as fill-level control, which occurs 
repeatedly in the PCS 7 plant. A number of process tags can be copied from a process tag 
type with the aid of the Import/Export Assistant on the basis of an import file. The process 
tags are then adapted in line with the requisite, specific automation task and interconnected 
accordingly. 
Store the process tag type centrally in the master data library (Page 214). Adapt the process 
tag type before deriving process tags.  

Sources for Process Tag Types 
The following process tag types can be stored in the master data library: 
● Templates from the PCS 7 Advanced Process Library 
● Standardized process tag types from the control system libraries, for motors, valves, PID 

controllers, for example 
● User-created process tag types from CFC charts 

Creating Process Tags 
Process tags can be created from process tag types during import with the Import/Export 
Assistant. Each line in an import file creates a replica in the target project. The process tags 
retain the assignment to the process tag type. 

Central Modifiability  
When a process tag type is modified, the process tags existing in the project are 
automatically synchronized. Synchronization can be initiated again with a menu command if 
actions have been undertaken which result in inconsistencies between the process tag type 
and the process tags (because, for example, not all of the process tags of a project were 
accessible during the automatic synchronization process). 
Using the "Create/Change Process Tag Type" wizard, the following inconsistencies can be 
harmonized between the process tag type and the process tags: 
● Parameter, signal connection points and messages which are not present on the process 

tag type are deleted from the process tags. The corresponding attributes are reset. 
● Parameter, signal connection points and messages which have been newly defined on 

the process tag type are added to the process tags. The corresponding attributes are set. 
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● Categories which have been changed on the process tag type are corrected on the 
process tags. 

● Inconsistencies between the process tag type and the process tag which cannot be 
harmonized automatically are displayed in the log. 

 

 
 

Note 
Changes to the chart of the process tag type are not taken into account when the process 
tags are synchronized. In this case, you must delete the relevant charts beforehand and 
then carry out a new import for the changed process tag type using the Import/Export 
Assistant.  
You cannot change the names of the blocks for an existing process tag type or for 
process tags derived from this. Otherwise, import/export is no longer possible. 

 

 
 

Note 
Ensure that all the projects are available in the multiproject in order to facilitate 
harmonization of the project tags. 

 

Using Process Tag Types  
'Fill-Level Control' Process Tag as a basis for Creating a Process Tag Type:  
In the following example the process tag is a CFC chart (with additional attributes) for signal 
acquisition, signal preprocessing, automation and operation & monitoring of the 'fill-level 
control' system function. 
The CFC charts consists of the following aspects: 
● There is a fill-level sensor affixed to a boiler. It converts the fill level from 0 to 1500 l into a 

current of 4 - 20 mA. 
● The signal cable is connected to a channel on an analog input module. The signal has a 

name which is listed in the signal list for your plant. This unconditioned signal is accessed 
by the automation blocks via the name of the signal. 

● A driver block for inputting analog values (CH_AI) converts the unconditioned signal into 
a preprocessed signal (0 to 1500 l). 

● A controller block (CTRL_PID) determines an output value of between 0 and 100% from 
the setpoint and the actual value supplied by the fill-level sensor. 

● A driver block for outputting analog values (CH_AO) converts the signal into the 
unconditioned signal and transmits it to an analog output module. 

● On the analog output module a control is connected via a 4 - 20 mA current lead. The 
valve is closed at 4 mA and fully open at 20 mA. The valve is part-opened at values in-
between. 
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● The controller block has the following elements in the OS: 
– a faceplate 
– archive tags for setpoint and actual values 
– alarms if the upper or lower fill-level limited are passed 

Following completion of the test with the Import/Export Assistant, a process tag type can be 
created from the process tag which is defined like this. 

Additional information 
● Section "Introduction into Creating Process Tags from Process Tag Types (Multiproject) 

(Page 517)". 
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6.5.4 Using Models 

Model 
Models are used to define more complex functions than process tag types (through to plant 
sections), and store these as reusable templates. A model consists of hierarchy folders with 
CFC/SFC charts, pictures, reports and additional documents. A number of replicas can be 
copied in a single transaction from a model with the aid of the Import/Export Assistant on the 
basis of an import file. The replicas are then adapted in line with the requisite, specific 
automation task. 

 

 Note 
You can only create models in a multiproject. 

 

Store the models centrally in the master data library (Page 214). Adapt the model before 
creating replicas. 

Creating Replicas 
The blocks for importing/exporting parameter descriptions, interconnection descriptions and 
messages are prepared in the charts for a model. After the model is linked to an import file, 
the model is imported with the Import/Export Assistant. The generated replicas are assigned 
the parameters, interconnections, and messages of the model. 
Each line in an import file creates a replica in the target project. The replicas retain the 
assignment to the model.  

Central Modifiability 
You can use the "Create/Change Model" wizard to make changes to models. 
If you modify models or the I/O points of a model that already have replicas, a message is 
displayed indicating this since the import data no longer matches the model data. 
Using the "Create/Change Model" wizard, check the consistency of the model with the 
assigned import file as well as the replicas for changes in the IEA identification.  

 

 Note 
The block names may no longer be modified for an existing model or for a replica of a model. 
Otherwise, import/export is no longer possible. 

 

Additional information 
● Section "How to Create a Model (Page 570)" 
● Online help for the IEA 
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6.5.5 Using the Master Data Library 

Master Data Library 
When you use the PCS 7 Wizard to create a multiproject, a master data library is created 
automatically. The master data library is used for storage of the master data of the project for 
all projects of a multiproject. When you move projects from the multiproject to distributed 
engineering stations for editing, you must also transfer the master data library so that all 
planning engineers have an identical database available.  
The master data library helps you to ensure that a defined version of types is reused. The 
master data library is automatically archived together with the multiproject. 

Contents of the Master Data Library 
Those objects used in projects or those objects specially adapted for the projects are stored 
in the master data library. This includes, for example, the following elements: 
● Block types 
● SFC types 
● Tag types 
● Models 
● OS pictures 
● OS reports 
● Shared Declarations (enumerations, units of measure, equipment properties) 
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In addition, the following objects can be included in the master data library. 
● Objects from the PCS 7 Advanced Process Library 
● Objects from the PCS 7 Basic Library 
● Objects from the PCS 7 Library 
● Objects from the S7 standard library 
● Objects from libraries of suppliers 
● User-created objects 
 

 

Additional information 
● Section "How to Create a Master Data Library (Page 315)". 
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6.5.6 Using Project-Specific Catalog Profiles 

Project-Specific Catalog Profile 
Depending on the process tag types, models, etc. which you store for specific projects in the 
master data library, you can create a project-specific catalog profile for the hardware 
configuration. This means that all project editors use the same hardware components. If you 
move the projects, which can be found in the multiproject, to the distributed engineering 
stations for editing, the project-specific catalog profile must be moved as well. 

"PCS 7_Vx.y" hardware catalog 
The basis for each project-specific catalog profile is the "PCS 7_Vx.y" hardware catalog in 
HW Config with the latest versions of all the modules and components which are approved 
for PCS 7. 

 

 Note 
You can find which other module versions are released for PCS 7 in the document entitled 
PCS 7 - Released Modules, which can be accessed with the menu command Start > 
SIMATIC > Documentation > English. 

 

Create a new catalog profile in HW Config and use drag-and-drop to move the required 
components from the "PCS 7_Vx.y" hardware catalog to the new catalog profile. You can 
assign any name to the catalog profile. 

Additional information 
● Section "Defining a Project-Specific Catalog Profile (Page 353)". 
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6.6 Importing and Reusing Plant Data 

Import/Export Interfaces 
All the essential applications of the PCS 7 engineering system have import/export interfaces. 
The use of these import/export interfaces has the following advantages: 
● Plant-planning data can be harmonized with control-system engineering data. This is how 

control system engineering and plant engineering can be independently edited at the 
same time. 

● Data from the engineering system can be exported as a template, be effectively 
duplicated and adapted in an external program (such as MS Excel) and then be imported 
back into the engineering system. This allows you to optimize the configuration of 
recurring or similar plant information. 

Import/Export of Plant Data 
 
What? Import/export Where? Additional sections  
Process-tag lists 
or charts 

You can import configured plant data such 
as process-tag lists or charts from the 
higher-level CAD/CAE world into the 
engineering system and use for largely fully 
automated generation of process tags, for 
example. 
You can export parameters which have been 
optimized with PCS 7 back into the 
CAD/CAE world. 

Import/Expo
rt Assistant 
(IEA) 

How to exchange 
data with MS 
Excel/Access 
(Page 648) 

Hardware 
configurations 

You can export hardware configurations from 
HW Config and continue to edit them 
externally on the basis of existing plant 
information. They are then imported back 
into the HW Config.  
The symbolic names of the inputs and 
outputs are also exported/imported.  

HW Config Importing/Exporting 
the hardware 
configuration 

Plant pictures You can import existing plant pictures into 
the Graphics Designer for creating OS 
pictures (e.g. as background pictures). 
This applies to pictures which do not contain 
any dynamic screen elements. 

Graphics 
Designer  

Configuration 
Manual Process 
Control System 
PCS 7; Operator 
Station 

Project data Control system project data which has 
already been configured can be exported 
from the engineering system to be 
harmonized with planning data in the 
CAD/CAE world.  
Format of the export file: *.xml 

SIMATIC 
Manager 

How to export 
project data 
(Page 693) 
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Data Formats for Importing/Exporting Plant Data 
You can find information about importing and exporting plant data in the section "Which data 
and data formats can be imported? (Page 157)". 

Further Import/Export Functions 
 
What? Import/export Where? Additional sections  
Process tag 
types (process 
tags) 

A number of process tags can be 
created/updated with the aid of the 
Import/Export Assistant on the basis of a 
process tag type and of an externally 
adaptable import file with process tag 
information. 

Import/Expo
rt Assistant 
(IEA) 

Creating process 
tags from process 
tag types 
(multiproject) 
(Page 517) 

Models (replicas) A number of replicas of the model can be 
created/updated with the aid of the 
Import/Export Assistant on the basis of a 
model and of an externally adaptable import 
file with parameters and interconnection 
information. 

Import/Expo
rt Assistant 
(IEA) 

How to create 
replicas of models 
(Page 575) 

I/Os and 
Messages 

Texts which are of relevance to the operator 
and which are created in PCS 7 can be 
compiled outside PCS 7 (e.g. for plant 
operators in their mother tongue). Export the 
texts which are of relevance to the operator to 
a text file. The texts are compiled in an ASCII 
editor or MS Excel and then be imported back 
into PCS 7. 
Formats: *.tx" or *.csv 
When changing languages, you can select 
any of the languages which were specified 
during import into the project.  
• Change of language for "Title and 

Comments" - > only for the selected object
• Change of language for "Display texts" - > 

for the entire project). 

SIMATIC 
Manager 

How to 
import/export I/Os 
and messages 
(Page 330)  
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What? Import/export Where? Additional sections  
Import/export of 
complete table 
contents 

All the editable fields for parameters, signals 
and messages can be exported in the 
process object view. You can then edit them 
externally (e.g. change parameters and 
interconnections) and then import them again.
Format: *.csv 
This means that existing plant parts or copied 
units, for example, can be supplied externally 
with changed parameter values and 
interconnections without having to use the 
Import/Export Assistant. 

SIMATIC 
Manager 

How to 
import/export I/Os 
and messages 
(Page 330)  

Import/Export of 
Picture Objects 

Information relating to OS image objects (e.g., 
type of object or interconnection information) 
can be exported into a CSV file during OS 
configuration.  
You can then edit this information externally 
in MS Excel (e.g., change tag 
interconnections) and then import it back into 
WinCC. 

WinCC 
Explorer: 
Graphic 
Object 
Update" 
wizard 

Configuration 
Manual Process 
Control System 
PCS 7; Operator 
Station 
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6.7 Free assignment between hardware and software 

Decoupling Hardware and Software Configurations 
The connection between hardware and software configuration can be based on the symbolic 
names of the signals. The hardware engineer configures the hardware setup in HW Config 
and assigns symbolic names, which are specified during plant planning, to the inputs/outputs 
of the modules and field devices. The software engineer compiles the charts for the process 
tags and defines textual interconnections to and from between the inputs/outputs and the 
process; symbolic names are also used for this. 
During compilation, hardware and software assignment takes place on the basis of identical 
symbolic names. The individual planning engineers do not have to worry about the system's 
internal addresses (absolute addresses, e.g. A 4.0, E 1.1).  
Consequently, the configuration of hardware and software is decoupled. The software can 
be created before the hardware is defined, and vice versa. The CFC/SFC charts only have to 
be assigned to the correct automation systems immediately prior to compilation and 
downloading. 

Symbol Table 
PCS 7 can compile the symbolic names into the requisite absolute addresses provided the 
symbolic names have been assigned to the absolute addresses. This happens in PCS 7 
during hardware configuration or when a hardware configuration is imported. 

Example 
For example, you can assign the symbolic name MOTOR_751_ON to the operand A 4.0 in 
the symbol table and use MOTOR_751_ON as an address in a source statement.  

Recommendation for PCS 7 
Work with symbolic names in PCS 7 projects. A symbolic name enables you to work with 
informative descriptions instead of absolute addresses. By combining short symbolic names 
and detailed comments, you will satisfy the need both to create an effective program and to 
provide good program documentation.  
Symbolic names can also make it easier for you to tell whether the elements of the program 
match the components of the PCS 7 plant. 

Additional information 
● Section "How to Assign Symbols to Input and Output Addresses (Page 366)". 
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6.8 Deriving the Picture Hierarchy and OS Areas from the Plant Hierarchy 

Deriving the Picture Hierarchy from the PH 
The OS picture hierarchy for the operator on the OS can be derived completely from the 
configured data for the plant hierarchy. 
This involves inserting the pictures, which are meant to visualize the process for the 
operator, into the plant hierarchy (PH) in accordance with the structure of your PCS 7 plant. 
You can insert one picture per OS for each hierarchy folder in the PH.  
Inserting pictures in the plant hierarchy serves to create a picture hierarchy. Once the OS is 
compiled, the Picture Tree Manager has the same hierarchy for further editing.  
Recommendation: Allow for the required picture hierarchy when you create the PH. 

Requirement 
 

 Note 
If you use the "OS Compilation" function, the structure of the plant hierarchy is only copied 
into the Picture Tree Manager if the option "Derive picture hierarchy from the plant hierarchy" 
is activated in the general PH settings in the SIMATIC Manager. 
Deactivate this option once you have adapted the picture hierarchy in the Picture Tree 
Manager and if you do not wish to overwrite the picture hierarchy the next time you compile 
the OS. 

 

Deriving OS Areas from the PH 
OS areas can be defined to reflect the plant structure which you have created in the plant 
hierarchy (PH). This means, for example, that in the case of large plants, you can assign 
operators to specific sections of plants. In that case, the plant operator only views and 
operates the areas for which he has user rights in process mode. Only messages which are 
of relevance to this area are displayed. 
In general, a unit within the PH corresponds to an OS area.  
In the general PH settings you can decide which hierarchy level should count as the OS 
area. Define an area identifier for each hierarchy folder within this level. The default setting 
for the area identifier corresponds to the name of the hierarchy folder in the PH. 
If you assign an area identifier to a hierarchy folder, the area identifier is also applied to all 
the lower-level hierarchy folders and objects. 
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When the OS is compiled, the OS areas are transferred to the Picture Tree Manager for 
further editing. The hierarchy levels are always displayed in the Picture Tree Manager, 
starting with the hierarchy level that has been defined as the OS area. 
Recommendation: Allow for the required OS areas in the structuring of the PH and specify 
the area identifiers. 

Additional information 
● Configuration manual Process Control System PCS 7; Operator Station 
● Online help Help on PH, IEA and PO 
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6.9 Generating Block Icons and Operator Texts 

6.9.1 Generating Block Icons 

Generating block icons 
Block icons are used for operator control and monitoring of plants or units in process mode. 
The block icons are required for block instances, which can be controlled and monitored, 
from the CFC charts. 
You can specify whether to create block icons for each of the process pictures on the PCS 7 
OS and whether to store them in this picture picture. 
You can define the following settings in the plant view or in the process object view before 
compiling the OS: 
● Select the "Derive block icons from the plant hierarchy" option for each process picture. 
● If you select a "Multiproject", "Project" or "Hierarchy folder" object and then execute the 

"Create/Update Block Icons" function, the block icons are automatically inserted into the 
process pictures in accordance with the plant hierarchy and linked to the corresponding 
process tag. 

Additional information 
● Configuration manual Process Control System PCS 7; Operator Station 
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6.9.2 Generating Operator Texts 

Generating units and operator texts 
Faceplates, which display the following block information, are used to display the process to 
the operator in process mode. 
● Measured values 
● Operating limits 
● Units 
● Operator texts 
These texts are already included in the block types you use for a CFC chart. 
The unit and operator texts are only displayed in the language that is stored for the block 
types, irrespective of the current language selection. 
The unit and operator texts for block types from the supplied libraries (e.g. PCS 7 Library) 
are only available in English.  
You can change unit and operator texts (e.g. translate them into a different language) in the 
CFC chart in the properties for the block type or block instance.  

Additional information 
● Section "How to Import/Export I/Os and Messages (Page 330)" 
● Configuration manual Process Control System PCS 7; Operator Station 
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6.10 The PCS 7 Event-Signaling System 

6.10.1 Basic Concept of the Event-Signaling System 

The PCS 7 event-signaling system 
The PCS 7 event-signaling system informs the operator of events which occur in the process 
and control technology. The events are displayed individually to the operator in signal lists 
and via a group display on the PCS 7 OS (OS client). Operator actions are contained in 
another list.  

Event-Signaling Classes 
Distinctions are made between the following classes of signals:  
 
Event-signaling 
classes 

Description 

Process control 
signals 

I&C system messages are generated when SIMATIC PCS 7 detects and 
signals errors in its own components (AS, OS, etc.). Such errors range from 
failure of a component to a wire-break signal for a connected I/O module.  
Process control signals are generated by the driver blocks in PCS 7 and do 
not have to be configured. 

Process signals Process signals indicate process events that take place in the automated 
process, such as limit value violations and event signals. 
• Process signals are predefined for the blocks and therefore do not need 

to be configured. However, if necessary, message texts and a message 
priority can be changed in the CFC block properties, centrally in the list of 
process objects or by means of import and export. 

• Events signals are a subgroup of process signals. They signal process 
variables which serve to evaluate a technological variable, such as an 
elapsed-time counter. 

Operating messages Operating messages are generated when an operator controls process 
variables, for example, changes the operating mode of a controller. 
Operating messages are generated automatically when you use the 
faceplates which are provided by the PCS 7 Library.  
If you configure faceplates according to the manual entitled PCS 7 
Programming Instructions for Blocks, you can also use PCS 7 operating 
messages for your own blocks. 
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Origin of a Message 
Messages can originate in different locations within the control system depending on the 
configuration. The time stamp of the message is influenced by where it originates. 
The illustration below shows an example with a distributed I/O, ET 200M. 
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Explanation of the picture 
Events which originate in the AS (2) or in the ET 200M (3) are transmitted as individual 
messages to the OS via the plant bus. The message is transmitted along with the 
corresponding time stamp. The messages appear in chronological order, with the time they 
occurred, in the signal lists of the OS.  
The table below shows the places of origin and the allocation of the time stamp. 
 
Place of origin Configuration of the 

message text 
Assignment of the time 
stamp 

Messages 

Operator station 
(OS) 

In the "Alarm Logging" 
editor in WinCC Explorer 

In the operator station Process control signals 
from the OS, linking non-
S7 systems 

Automation 
system (AS) 

On the block types in the 
project library or on the 
block types within the 
CFC charts 

In the automation 
system 

Process and control 
technology messages 
from SIMATIC stations 

Distributed I/O  
(ET 200M) 

On the instances of the 
IM_DRV driver block 
within the CFC charts 

In the ET 200M through 
the IM 153-2 (if the high-
precision time stamp  
is activated) 

Selected events for initial 
value acquisition in the 
event of a plant failure  

"Loop-in-alarm" function 
Process and control technology messages from technological blocks which are visualized on 
the OS feature the "loop-in-alarm" function. You can use this function to select the faceplate 
for this process tag straight from the signal list. 
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6.10.2 Configuration of Messages 

Configuration of Operator Stations (OS) 
New messages and the corresponding message text can be configured for the operator 
station in "Alarm Logging" (WinCC Explorer). There you can also specify which event (binary 
value, bit within an integer value, etc.) is to trigger off the message. 

Configuration for the automation system (AS) and distributed I/Os 
Configure messages for the automation system (AS) and distributed I/Os when you create 
CFC charts or in the process object view.  
If a block with event response capability is used in a CFC, specific event texts with the 
associated event class are preset via a default setting. These messages are transmitted 
when the corresponding event occurs. You can adapt these event texts and their attributes 
to your particular needs as follows: 
● Messages from a block type:  

First of all copy the required block to the project library and change the message there. 
● Messages from an individual block instance:  

Change the message in the process object view or directly in the block instance in the 
CFC chart. 

Recommendation: Create a master data library at the start of configuration. Change the 
messages on a block type at the start of configuration. If there are already CFC charts 
created in the project, import a block type. Consequently, the operator texts will be adapted 
on all the instances (apart from instances which have already been changed manually). 

Additional information 
The message-configuration procedure is described in detail together with the step-by-step 
instructions in the configuration manual Process Control System PCS 7; Operator Station. 
The section below provides a brief summary of the individual features of the PCS 7 for 
configuring a convenient message system. 
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6.10.3 Important Aspects of Message Configuration 

Important Aspects of Message Configuration      
The following table summarizes the most important aspects of configuring messages. 
 
Aspect Description Possible 

configurations 
Message 
text 

If you use a block with message capability in the CFC, for 
example, the "Dose [FB63]" block, specific message texts with 
the associated message class are preset as defaults.  
You have the opportunity to adapt these message texts and 
their attributes to your particular needs: 

• Language for 
display devices 

• Modification of 
the message 
texts on the block 
type and block 
instance 

Auxiliary 
value 

You can update messages with current information from the 
process, for example, by inserting associated values into certain 
places in the message text. The message block analyzes the 
associated value and inserts the corresponding process value 
at the specified place in the message text. This entails inserting 
a block with the following information into the message text: 
@<No. of the associated value>[<element type>]<format 
details>@ 
You can find the possible associated values for the individual 
block instances in the online help on the block from the PCS 7 
library. 

Addition of 
associated values 
into the message 
texts on the block 
type and block 
instance  

Extended 
event text 

On the basis of a standard message, such as "too high", the 
plant operator is unable to tell at first glance what exactly is "too 
high". 
Therefore, you can add supplementary information, such as 
"reactor fill level", to the event text. The block comment is used 
for this.  
By prefixing a keyword ($$BlockComment$$) to the event text, 
the block comment is copied to the event text of the message.  
The event texts are already prepared like this in the PCS 7 
library blocks. They only adapt the block comments individually 
for each block instance. 

• Expanding the 
event texts to 
include block 
comments on the 
block type and 
block instance 

Message 
number 

Each message which is configured in the ES is automatically 
assigned a unique message number in Alarm Logging during 
the compilation of the PCS 7 OS. 
An 8-bit range is reserved within these message numbers for 
creating a unique cross-reference to to the corresponding AS. 
This serves to ensure that several AS can be monitored from an 
OS and that the messages are also assigned to the correct AS.  

• No configuration 
required 
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Aspect Description Possible 
configurations 

Assignment 
of message 
numbers 

When you create a project with the PCS 7 wizard, a message 
number range is defined (which can then be changed). You can 
select between the following processes: 
• Assigning message numbers which are unique for the entire 

CPU (a requirement for assigning message priorities) 
• Assigning message numbers which are unique for the entire 

project 
Using the "Assigning message numbers which are unique for 
the entire CPU" option, programs can be copied 1:1 without 
message numbers changing. 

Specifying the 
message number 
concept  

Message 
priority 

By default, the current message always appears first on the 
message list. This setting can be changed.  
A priority can be assigned to every message 
(0 = lowest, 16 = highest). The assignment serves to ensure 
that the message line in the overview area always displays the 
message that meets the following criteria: 
• Not yet acknowledged 
• Highest priority 
In addition, the plant operator can sort message lists in process 
mode according to priority in ascending or descending order.  
Note: Message priorities can only be specified if you defined the 
message number range as "Unique for Entire CPU". 

Specifying the 
priority of messages 
on the block type 
and block instance 

Location of 
the error in 
the 
message 
text 

In the event of an error, the driver blocks in the distributed I/Os 
transmit a message with the following information about the 
location of the error to the OS: 
• Number of the DP master system to which the module is 

connected 
• Rack in which the module is installed, or station number 
• Module slot number in the rack 
• Message text from the MOD_D1_TXT or MOD_D2_TXT text 

library 
By assigning a slot and channel number, this serves to specify 
the channel of a module which triggers the message. 
Message-text configuration: 
Enter the message texts directly into the IM_DRV block which is 
placed in the CFC.  
The message texts (origin) for diagnostic events on HART and 
PA field devices are preconfigured with "field device". We 
recommend that you adapt the preconfigured message text to 
suit your configuration requirements.  

• Concept of the 
driver blocks 

Additional information 
● Section "How to Configure Messages in SFC (Page 554)" 
● Configuration Manual Process Control System PCS 7; Operator Station 
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6.10.4 Showing and Hiding Messages Automatically in Process Mode 

"Show and hide messages automatically" function 
Use the "Show and hide messages automatically" function in the following situations 
(process status), for example: 
● You wish to suppress messages when you start up a part of the plant (flurry of 

messages). 
● You wish to automatically hide messages which are generated when a part of the plant is 

shut down. 
● You wish to automatically hide messages from a part of the plant which is not in 

operation. 
Use the "STATEREP" block for this function. The purpose of the "STATEREP" block is to 
hide/show messages for process states such as startup, shut down, etc. Interconnect the 
status inputs of the "STATEREP" block to a logic that determines the process states. All the 
blocks which are controlled by this "STATEREP" are combined in a group under an identifier. 
This means that several "STATEREP" blocks can be used where necessary. 
The process states are transferred to the OS and then suppressed in the OS by means of a 
configured assignment of messages to process states.  
Automatic showing and hiding in process mode does not affect message generation in the 
automation system. 

Overview of the configuration steps 
 
Step What? 
1 • Inserting the "STATEREP" block into a CFC chart 

• Interconnecting the control signal for a process status (e.g. starting up a part of the plant) to a state input on 
the "STATEREP" block (state1 to state32) 

A status input represents a status for showing and hiding messages. 
2 Creating shared declarations 
3 Assigning blocks in the process object view for groups. 
4 Assigning messages from blocks in groups, which you wish to hide, to the status in the process object view. 

Additional information 
● Section "How to Configure Showing and Hiding Messages Automatically (Page 499)" 
● Configuration manual Process Control System PCS 7; Operator Station 
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6.10.5 Acknowledgement Concept and Acknowledgement-triggered Reporting (QTM) 

Acknowledgement concept 
PCS 7 uses a central acknowledgement concept. If a message is acknowledged on an OS, 
this acknowledgement is transferred to the reporting block in the AS. From there it is 
forwarded centrally as an acknowledged message to all the operator stations which are 
being supplied. 

Acknowledgment-triggered reporting (QTM) 
If signals that trigger messages change their state in quick succession, a flurry of messages 
can be triggered. This can mean that the state of a plant is no longer adequately monitored. 
By configuring the "acknowledgment-triggered reporting (QTM)" function, you can suppress 
the repeated signaling of "fluttering" states until the plant operator acknowledges them. 
While an unacknowledged message remains in the OS, the resending of signal changes for 
this message is suppressed in the AS. 
The following can be accomplished with QTM: 
● The pending messages remain manageable. 
● The communication load is reduced. 

Configuring acknowledgment-triggered reporting (QTM) 
You can activate acknowledgment-triggered reporting (QTM) for a specific AS in the object 
properties of the CPU. 

 

 Note 
Configure the same message method for all automation systems of a multiproject (standard 
message procedure or acknowledgment-triggered reporting).  
Do not mix both methods within a multiproject. Otherwise the plant operator cannot 
recognize the message procedure that generated the message. This could lead to false 
conclusions being drawn. 

 

Additional information 
● Section "How to Activate Acknowledgment-triggered Reporting (QTM)" (Page 418)" 
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6.10.6 Time Stamp with High Precision 

Introduction 
Events frequently have to be read in with high-precision timing during initial value acquisition 
following the failure of part of plant with a subsequent flurry of messages: Even if there is a 
large number of messages, the message which led to the failure of the unit (initial value) 
must be clearly identifiable.  

High-precision time stamps 
High-precision time stamps allow extremely accurate time stamping of an incoming event: If 
two sensors from two stations on different PROFIBUS-DP chains are connected to different 
automation systems and are activated at the same time, the time stamps of these signal 
changes may not differ by more than a maximum of 1 ms, 10 ms or 20 ms (depending on the 
hardware used) . This assumes time synchronization of all the devices connected to the 
plant bus. 

Additional information 
● Section "How to configure the hardware for the high-precision time stamps (Page 417)" 
● Function Manual Process Control System PCS 7; High-Precision Time Stamping 
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6.10.7 Acoustic/Optical Signaling 

The "Horn" function 
In addition to the visual display of messages and alarms, acoustic or optical signaling may 
be necessary for certain messages. In PCS 7 OS, the "Horn" function is available for this 
purpose with the following options: 
● You can connect a signal module with a PCI interface in the OS. Up to four different 

external sensors, for example, four horns or four different lamps, can be controlled for 
different message classes. One device (for example a horn) can be deactivated using an 
acknowledgment input. The three other devices remain activated as long as an assigned 
control signal is applied (for example a signal of a message class is activated). 
Connecting a signal module allows an additional watchdog function. 

● You can use a standard sound card that is installed in the OS. The acoustic signal is 
produced by a WAV file, which continues to be played until the message is 
acknowledged. If several alarms are pending at the same time then all WAV files also 
sound at the same time. The sound card does not allow the implementation of lifebeat 
monitoring. 

Signal modules and sound cards can be operated together.  

Additional information  
● You can find more detailed information on the function and installation of signal modules 

in the manual Process Control System PCS 7; WinCC Basic Process Control 
● You can find more detailed information on configuring the acoustic signaling device in the 

configuration manual Process Control System PCS 7 Operator Station 
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Configuration of the PCS 7 Engineering System 7
7.1 Central Starting Point - The SIMATIC Manager 

SIMATIC Manager   
The SIMATIC Manager is the central starting point for all engineering tasks. The PCS 7 
project is managed, archived and documented there. All the applications of the engineering 
system are accessible from the SIMATIC Manager. If there is a connection between ES, OS, 
BATCH, Route Control and AS, the configuration data can be transferred to the target 
systems from the SIMATIC Manager and then tested online. 

Views in SIMATIC Manager 
The SIMATIC Manager provides the following three views which allow for optimum editing 
depending on the task at hand.  

 

 Note 
One major feature of these views is that the objects they contain exist only once. 

 

 

 
View Purpose 
Component view 
(Page 238) 

In the component view, you organize the projects of the multiproject, create 
hardware components and start the hardware configuration of the automation 
systems, bus components, process I/O, and PC stations. 

Plant View 
(Page 241) 

The plant view function is used to arrange and depict the plant according to 
technological aspects. Arrange the automation, operator control and monitoring 
functions hierarchically in the plant view. The structures for the PCS 7 OS in 
process mode are derived from this plant hierarchy (for example, OS areas, 
picture hierarchy). 

Process object view 
(Page 243) 

The process object view provides a universal view of the process tags. It shows 
the plant hierarchy combined with a table view of all the aspects of the process 
tag/process object (for example, parameters, signals, messages, etc.). 
In the process object view, all the data of the basic control throughout a project 
can be displayed in a process control-oriented view. The multiproject collects 
the data contained in all of the projects. 

Changing from One View to Another 
Use the SIMATIC Manager menu command View > [Name of view] to switch between the 
views. 
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Structure of a PCS 7 project 
Similar to the directory structure of the Windows Explorer with its folders and files, the PCS 7 
multiproject is organized into projects, folders, and objects. The multiproject is at the top of 
the object hierarchy and represents all the data and programs of an automation solution. 
Folders may contain objects which in turn may contain other folders and objects.  
The screenshot below illustrates a multiproject with the most important folders in the 
component view and the plant view: 
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Object-oriented working 
In SIMATIC Manager the different object types are linked directly to the application required 
to process it. The associated application is also started once an object opens.  
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7.2 The Component View 

component view 
The component view is used to manage the multiproject and the projects it contains. In 
addition, it can be used to carry out the following functions: 
● Creating the hardware components 
● Setting up the hardware configuration 
● Setting up and testing the AS configuration 
● Setting up the OS configuration 
● Setting up the BATCH configuration 
● Starting the Route Control configuration 
● Running cross-project functions 

Multiproject engineering 
Use the component view to carry out the following functions in the multiproject: 
● Split up the multiproject technologically for distributed editing 
● Merge the projects back into the multiproject after distributed editing 
● Run the cross-project functions after the projects have been synchronized 

Hardware Configuration 
Working in the component view, you configure the hardware of the automation systems, the 
bus components, and the process I/O. In the component view, you create the following 
objects below the projects: 
● SIMATIC S7-400 stations (AS) 
● SIMATIC PC stations for the engineering station (ES), operator stations (OS), BATCH 

stations (BATCH), Route Control stations and OpenPCS 7 station 
Double-click on "Hardware" for the selected station to access the HW Config application. 
Use HW Config to add additional hardware components (for example, CP, ET 200M) or 
software applications (server or client) to the stations and set the hardware component 
parameters.  

 

 Note 
After you have completed hardware configuration, you then work mainly in the plant view 
and in the process object view. 
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AS Configuration 
The objects in the component view are identified as components according to their 
importance (for example, S7 program, station, OS, PLC/AS (CPU), chart folder). 
In the component view, you organize the block types and SFC types by copying them from 
the master data library to the chart folders of the AS in which they are used. Only then are 
they available in the catalog for CFC/SFC configuration. 

OS Configuration 
Starting the component view, you begin configuration of the operator station for process 
mode. The WinCC Explorer starts after selecting the OS with the context menu command 
Open object.  
Refer to the configuration manual Process Control System PCS 7; Operator Station for more 
information. 

BATCH Configuration 
Start the batch control configuration from the component view. Open the BATCH 
configuration dialog with the menu command Options > SIMATIC BATCH. 
Refer to the configuration manual Process Control System PCS 7; SIMATIC BATCH for 
more information. 

Route Control Configuration 
Start the configuration for route control from the component view. Open the Route Control 
configuration dialog boxes with the Options > SIMATIC Route Control menu command. 
You will find more information on this topic in the configuration manual Process Control 
System PCS 7; SIMATIC Route Control. 
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Other Available Functions 
 
Component view Selection of Important Functions 

• Creating a New Multiproject with the PCS 7 Wizard 
(Page 258) 

• Expanding a Multiproject by Adding New (Empty) 
Projects (Page 261) 

• Expanding a Project with Preconfigured Stations 
Using the PCS 7 Wizards (Page 263) 

• Inserting the SIMATIC Stations (Page 274) 
• Inserting and Configuring the Operator Stations 

(Page 279) 
• Inserting and Configuring the BATCH Stations 

(Page 281) 
• Inserting and Configuring the Route Control Station  

(Page 283) 
• Inserting and Configuring the Engineering Station 

(Page 277) 
• Distributing the multiproject for distributed editing 

(multiproject engineering) (Page 342) 
• Merging projects after distributed editing (multiproject 

engineering) (Page 621) 
• Running cross-project functions 
• Compiling - downloading 

Offline or Online? 
The component view can be switched between the following states: 

 
Component View > Offline This view of the project structure visualizes the project data on the engineering 

station. The offline view is set as the default when you create a new project. In the 
offline view, the complete data on the engineering station is displayed for the S7 
program (offline). 

Component View > Online This view of the project structure visualizes the project data on the target system 
(CPU). In the online view, the data on the target system are displayed for the S7 
program (online). You use this view for access to the target system. 
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7.3 The Plant View 

Plant hierarchy 
In the plant view, you structure the project according to technological aspects. In the process 
you hierarchically organize automation, operator control and monitoring functions into the 
hierarchy levels plant, unit or function. Name the relevant hierarchy folder according to its 
technological significance. Arrange the following in the hierarchy folder: 
● CFC and SFC charts for the AS 
● Pictures and reports for the OS 
● Additional documents such as descriptions of units, process tag sheets, planning 

documents etc. (from MS Word, MS Excel, etc.) 
The resulting project structure is the plant hierarchy. 

Additional Aspects 
Please observe the following aspects of the plant view: 
● The technological objects (plants, units, functions, ...) can be handled as a single entity 

(for example, when copied). 
● The technological objects can be used to work independent of a fixed hardware 

assignment. 
● The OS areas and the image hierarchy for the OS are derived from the plant hierarchy. 
● The plant hierarchy is the basis for the plant-oriented identification of process objects. 

The hierarchy path forms the plant designation (higher level designation HID). It can used 
to specify the folders that contribute to the naming scheme. 

● You insert and position the process pictures in the plant view. The block icons of the 
blocks used in the process picture can be generated automatically from the plant 
hierarchy. 

Master Data Library 
The master data library contains the project master data you created for use in the single 
projects of the multiproject, for example:  
● Block types 
● SFC types 
● Tag types 
● Models 
● OS pictures 
● OS reports 
● Additional documents 
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Other Available Functions 
 
Plant View Selection of Important Functions 

Plant Hierarchy 
• Settings and Properties of the PH (Page 292) 
• Inserting Additional Hierarchy Folders (Page 297) 
• Inserting Objects in the Hierarchy Folder (Page 298) 
• Rules for Copying and Moving within the PH (Page 299) 
• Checking the Consistency of the PH (Page 304) 
• Additional PH Functions in a Multiproject (Page 306) 
• Specifying the AS/Os Assignment (Page 300) 
Master Data Library: 
• Creating the Master Data Library (Page 315) 
• Copying Library Objects to the Master Data Library 

(Page 319) 
• Work with process tag types (Page 335) 
• Working with Models (Page 337) 

AS-OS assignment 
An OS must be assigned an AS in the plant view of each hierarchy folder. This AS-OS 
assignment has the following consequences in the component view: 
● All CFC and SFC charts inserted in the plant view are stored in the chart folder of the 

assigned AS. 
● All pictures and reports inserted in the plant view are stored in the folder of the assigned 

OS. 



 Configuration of the PCS 7 Engineering System 
 7.4 The Process Object View 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 243 

7.4 The Process Object View 

Process object view 
You use the process object view when you require details of process tags and CFC charts 
and want to edit their attributes and aspects. Working with the process object view is ideal 
when you want to assign the same parameters, comments or interconnections for large 
volumes of objects. 

Advantages of the Process Object View 
Compared with the plant view, the advantage of the process object is that all modifiable 
attributes of an object can be edited. All editable aspects are consistent and presented in a 
practical form for the user.  
Jumps to CFC, SFC, HW Config, WinCC Explorer allow editing of aspects that can not be 
edited directly in the process object view (such as module parameter assignments, picture 
contents). 
The context menu of the process object view contains functions which can be used to 
reverse or repeat any changes you have made. 

Structure 
On the left, the process object view displays the plant hierarchy (tree). On the right, you see 
a table of the underlying objects along with their attributes (contents window).  
The tree displays the same objects as in the plant view. In addition, the process object view 
of the tree also shows the CFCs, SFCs, OS pictures, OS reports and additional documents.  

 
Process object view Selection of Important Functions:  
 • Section "Editing Mass Data in the Process Object View (Page 580)" 
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Displayed Attributes of the Process Objects 
In the contents window, you see the attributes of the objects organized according to the 
following aspects. 
 
Tab Purpose 
General Here, you see all the underlying process objects (process tags, CFCs, SFCs, 

OS pictures, OS reports, or additional documents) for the plant section currently 
selected in the tree along with general information on the objects. 

Blocks Here, the block properties of the blocks in all subordinate CFC charts are 
display for the plant section currently selected in the tree. SFC instances are 
also identified as blocks here. 

Parameter Here, you see all the I/O points of the process tags and CFCs displayed in the 
"General" tab that were selected explicitly for editing in the process object view 
(S7_edit = para). 

Signals Here, you see all the I/O points of the process tags and CFCs displayed in the 
"General" tab that were selected explicitly for editing in the process object view 
(S7_edit = signal). 

Messages Here, you see the corresponding messages for all the process tags, CFCs and 
SFCs displayed in the "General" tab. 

Picture objects Here, you see all the picture links that exist in WinCC for the process tags and 
CFCs displayed in the "General" tab. 

Archive tags Here, all process tags, CFC charts, SFC charts and the existing interconnected 
WinCC archive tags listed in the "General" tab are displayed along with their 
attributes.  
The attribute that are relevant for PCS 7 (subset of all attributes defined in the 
tag logging) are displayed. 

Hierarchy folder Here, the hierarchy folders of the PH are display (one line for each hierarchy 
folder) for the plant section currently selected in the tree. 

Equipment 
properties 

Here, the equipment properties are displayed for the projected selected in the 
tree. 
These equipment properties are instances of equipment properties types that 
have been configured in the shared declarations (one line for each equipment 
property). The attributes are entered in the instance when a type is changed. 

Shared 
Declarations 

Here, you can edit the attributes of the types, enumerations, units of measure 
and equipment properties contained in the multiproject. 
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Creating Additional Technology Objects 
In the process object view, you can create the following technological objects in addition to 
editing the attributes of objects: 
 
Object Purpose 
Hierarchy folder Expand the plant hierarchy by adding objects such as plant, unit, and function 

within a project. 
CFC/SFC Create empty CFCs and SFCs that can then be further edited with the 

appropriate editors. 
Additional 
document 

Create empty or import available additional documents, for example, MS Excel 
or MS Word if the relevant application is installed. 

Picture Create empty pictures that can then be further edited with the Graphics 
Designer. 

Report Create empty reports that can then be further edited with the page layout editor. 
Equipment 
properties 

Create equipment properties of the units and change their properties. 

Process tag (from 
library) 

Insert process tags from the catalog of process tag types in the master data 
library. You can drag the process tag type to a hierarchy folder in the process 
object view or in the plant view. This creates a process tag in this hierarchy 
folder. 

Access protection Activate access protection to restrict the access to the selected project by 
certain users. 

Offline or Online? 
The process object view can be switched between the following states: 

 
Process object view > Offline This view visualizes the project data on the engineering station. The offline view is 

set as the default when you create a new project. In the offline view, the complete 
data on the engineering station is displayed for the S7 program (offline). 

Process object view > Online In test mode (online), additional columns are displayed in the "General", 
"Parameters" and "Signals" tabs, with which you can test and commission the 
process tags and CFC charts online on the CPU (target system).  

Additional information 
● Section "Editing Mass Data in the Process Object View (Page 580)" 
● Online help for PH, IEA and PO 
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7.5 Correlations between the Views 

Correlations between the views 
Since the component view and the plant view/process object view represent different 
aspects of the same objects, certain functions affect these objects in all views: 
● "Deleting objects" deletes them in all three views. 
● Newly created objects in the plant view/process object view are also created in the 

AS/OS assigned to the hierarchy folder in the component view. 
● Creating new objects in the component view has no effect on the plant view/process 

object view. 
Tip: If the plant hierarchy exists, you should only edit objects in the plant view or in the 
process object view. The component view is then only used to create and edit the 
automation systems, operator stations, BATCH stations, Route Control stations and 
OpenPCS 7 station. 
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7.6 Cross-view Functions and How to Use Them 

Working with units (plant view) 
You can perform the following functions during plant-wide engineering: 
● Copying an entire unit, containing the charts for the AS and pictures for the OS. 
● Deleting a unit along with all the objects belonging to the unit. 
● Moving a unit to other devices (AS and OS). 
The cross-device relationships (PH, OS, AS) are managed by the ES. 

Copying a SIMATIC Station (CPU) in the Project (Component View) 
When you copy a SIMATIC station, the hardware properties of the station are copied 1:1. 
The following is retained in the associated program folder: 
● All interconnections between global addresses 
● All interconnections between runtime groups 
● All interconnections between the charts 
The plant hierarchy (PH) is retained. All the charts involved in the copy function now exist 
twice in the PH (original and copy with a different name). 

Copying a SIMATIC Station (CPU) from Project to Project (Component View) 
If you copy a SIMATIC station from one project to another, the hardware properties of this 
station are copied 1:1. The following is retained in the associated program folder: 
● All interconnections between global addresses 
● All interconnections between runtime groups 
● All interconnections between the charts 
The station is assigned a new name. 
Connections between stations copied across project boundaries are retained and are 
consistent if the relevant subnets between the stations are also copied. 
The plant hierarchy associated with the copied station is set up in the destination project. If 
the station in the source project has connections with the PH then these are also set up in 
the destination project. Use these functions when configuring a PH or during the application 
of an existing PH in the destination project with the same name. 
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Copying an S7 Program (Component View) 
In the SIMATIC Manager, you can copy an entire S7 program within a project or to another 
project. The following is retained when a program folder is copied: 
● All interconnections between global addresses 
● All interconnections between runtime groups 
● All interconnections between the charts 
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7.7 PCS 7 applications and how they are used 

Overview of the PCS 7 applications     
PCS 7 includes the following applications which you can use to configure the   PCS 7 plant: 
 
Application Purpose 
HW Config Configuring the hardware 

Hardware configuration displays the hardware structure of a station or a PC 
station. With HW Config, you specify the racks and their slot assignments 
according to the actual structure of the station; you configure and assign 
parameters to the modules, and configure the distributed I/Os. 

NetPro Configuration of networks and connections 
Using NetPro, you can configure, make parameter assignments, and document 
the network configuration for your plant extremely simply and clearly. 

CFC Configuring continuous processes 
CFC (Continuous Function Chart) is a graphic editor that can be used in 
conjunction with the STEP 7 software package. It is used to create the entire 
software structure of the CPU from ready-made blocks. When working with the 
editor, you place blocks on function charts, assign parameters to them, and 
interconnect them. 

SFC Configuring sequential control systems 
SFC (Sequential Function Chart) is a tool for creating a sequential control 
system. With this application, you can create and commission technological 
sequential control systems. 

SCL Programming blocks 
SCL (Structured Control Language) is high-level programming language for 
programmable controllers. Along with high language elements it also contains 
typical elements of the AS as a language element: 
• Inputs 
• Outputs 
• Timers 
• Memory bit 
• Block calls 
SCL supplements and expands the STEP 7 programming software with its 
programming languages LAD, FBD and STL. 

Graphics Designer 
(WinCC) 

Editing of process pictures 
In the Graphics Designer, you edit the mimic diagrams that the operator 
displays and uses for process control on the operator station. PCS 7 provides a 
function for use when creating process pictures that automatically inserts all 
block icons (clear, graphical representations of measuring points) in the process 
picture. 
You can also insert other graphic objects and define the dynamic attributes of 
the objects. For example, you can visualize the current state of a valve so that 
the operator immediately sees whether the valve is "open" or "closed". 
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Application Purpose 
Tag Logging 
(WinCC) 

Archiving process values 
Tag logging is used to archive process values and includes the following 
functions: 
• Creation of archives 
• Assignment of the process values to the archives 

Alarm Logging 
(WinCC) 

Archiving messages and alarms 
Alarm Logging is used for the following functions in the processing of messages 
and alarms: 
• Receiving messages from processes 
• Preparing and displaying messages in process mode 
• Acknowledgments by the operator 
• Archiving 

Report Designer 
(WinCC) 

Design of the layout for printouts of process values or messages.  
The Report Designer provides functions for creating and outputting reports. You 
can adapt the supplied standard layouts individually. The Report Designer 
provides the required editors.  

OpenPCS 7 Connection to the works management level 
New PCS 7 data important for the works and enterprise management level is 
constantly being produced in a production process. OPC/OLE DB provides you 
with access to this data. This package allows you to use the data from the 
higher control levels and create your own statistical information and evaluations.

SIMATIC BATCH Automation of batch processes (discontinuous processes) 
With the SIMATIC BATCH software package, you can configure process cells 
with recipe-oriented control strategies with exacting requirements. In this way 
complex tasks with alternating process sequences can be edited. 

SIMATIC Route 
Control 

Automating of route controls  
Using the SIMATIC Route Control software package, you control and monitor 
material transports in process mode (route control). 

SIMATIC PDM SIMATIC PDM is a software package for configuration, parameter assignment, 
commissioning, and maintenance of devices (for example, transducers) and for 
configuring networks.  
SIMATIC PDM allows simple monitoring of process values, alarms, and status 
information of the device. 

Faceplate Designer Creation of faceplates 
Using the Faceplate Designer, you create PCS 7-compliant templates for 
faceplates. 

Version Cross 
Manager 

Comparing project versions 
You use the Version Cross Manager to perform the following comparisons: 
• Compare versions of projects and libraries with graphic display of 

differences 
• Compare versions of two S7 programs for differences relating to the 

programming 
• Compare versions of two CFC/SFC charts 
• Export project data in XML format 

Version Trail Create versions 
You use Version Trail to create versions of multiprojects, projects and libraries. 
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Application Purpose 
S7 H Systems This supports you in the configuration of an S7-400H/S7-400FH. 

CFC charts created by the user have the functions necessary for error detection 
added to them automatically. 

S7 F Systems This supports you when configuring an S7-400F/S7-400FH. 
CFC charts (F charts with F blocks) created by the user already include the 
functions required for error detection and the reaction to errors. 

Import/Export 
Assistant 

Tool for fast engineering of mass data (for example, importing process tag types 
and models). 

PCS 7 Advanced 
Process Library 

The PCS 7 libraries include blocks and functions for use in PCS 7 plants. 

Hardware Catalog The hardware catalog "PCS7_Vx.y" contains all approved devices and modules 
(the latest version in each case). 

DOCPRO Using DOCPRO, you can create and manage plant documentation. 
SFC Visualization SFC visualization of the Operator System allows sequential control systems 

configured with the SFC editor to be represented and operated in the same way 
as on the engineering system. This does not involve any extra configuration 
effort. 
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Implementing the PCS 7 Configuration 8
8.1 Overview of Configuration Steps 

Introduction     
The basic activities described below are arranged in a practical order that you can follow to 
achieve a rational workflow during configuration. 
Depending on the requirements of your project, some of the steps in configuration are 
mandatory and others are optional. From the table below, you can see which configuration 
steps are necessary and which are options. 

Overview of Configuration Tasks 
 
Configuration Task Must Optional 
PC station setup 
(see manual Process Control System PCS 7; 
PC-Configuration and Authorization) 

X - 

Creating the PCS 7 project (multiproject) X - 
Creating the SIMATIC 400 stations (AS) X - 
Creating the SIMATIC PC stations X 

Operator stations 
and engineering 
station 

X 
For use with SIMATIC 
BATCH/SIMATIC 
Route 
Control/OpenPCS 7 
station 

Creating the Plant Hierarchy X - 
Creating the master data library X - 
Distributing the multiproject for distributed editing 
(multiproject engineering) 

 X 
For distributed editing 
by several 
configuration 
engineers 

Configuring hardware (AS, I/O) X - 
Creating network connections X - 
Creating the SIMATIC Connections X - 
Configuring the following AS functions: X - 
• Creating CFC charts X - 

• Programming SIMATIC connections for AS-AS 
communication 

- X 

• Programming the interface to the I/O (driver blocks) X - 
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Configuration Task Must Optional 
• Creating process tags from process tag types - X 

while editing mass 
data in the 
multiproject  

• Creating sequential control systems (SFC) - X 

• Creating models - X 
When editing mass 
data in the 
multiproject 

Configuring OS Functions 
Described in Configuration Manual Process Control 
SystemPCS 7; Operator Station 

X - 

Configuring BATCH functions 
Described in the configuration manual Process Control 
System PCS 7; SIMATIC BATCH 

- X 
When using SIMATIC 
BATCH 

Configuring the Route Control functions 
Described in Manual  
Process Control System PCS 7; SIMATIC Route Control 

- X 
When using for use 
with SIMATIC Route 
Control 

Configuring the connection to the works management 
level (OpenPCS 7 and SIMATIC IT) 

- X 
When interfacing 
PCS 7 to the 
management level 

Merging projects after distributed editing (multiproject 
engineering) 

- X 
For distributed editing 
by several 
configuration 
engineers 

Executing cross-project functions (multiproject 
engineering) 

- X 
For distributed editing 
by several 
configuration 
engineers 

Compiling and downloading to the target systems X - 

Described Procedures 
The creation of the configuration as described in the following sections is structured 
according to this procedure. The PCS 7 project must be created by multiproject engineering 
as a prerequisite to handling all topics. The PCS 7 project is subdivided into several projects, 
subjected to distributed editing, and then finally merged back into the multiproject for cross-
project functions. 

 

 Note 
With the procedure described here, you have full system support. You can, of course, follow 
a different procedure, however you then lose some or all the support provided by PCS 7. 
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8.2 Setting up the PC Stations 

Settings on all PC stations  
In order to configure, download, and test all automation systems (AS) and PC stations (such 
as OS and BATCH) from a central engineering station (ES) in a PCS 7 project, you must 
make the following settings on all PC stations: 
● Specify the communication modules for communication via the terminal bus and plant 

bus 
● Set/check the access points and operating mode for communication modules on the plant 

bus 
Make these settings on the central engineering station first.  

Additional information 
● Manual Process Control System PCS 7; PC Configuration and Authorization 
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8.3 Creating the PCS 7 Project 

8.3.1 Overview of the Defaults and Individual Steps 

Overview of Configuration Tasks  
This overview shows you the individual steps for creating and setting up a PCS 7 project: 
 
What? Where? 
Making the Default Settings for the PCS 7 Project (Page 257) SIMATIC Manager 
Creating a New Multiproject with the PCS 7 Wizard (Page 258) PCS 7 "New Project" Wizard  

(in the SIMATIC Manager) 
Expanding a Multiproject by Adding New (Empty) Projects 
(Page 261) 

SIMATIC Manager 

Expanding a Project by Adding Preconfigured Stations 
(Page 263) 

PCS 7 "Expand Project" Wizard  
(in the SIMATIC Manager) 

Expanding a Project by Adding Additional Objects (Page 265) SIMATIC Manager 
Configuring Access Protection for Projects/Libraries (Page 266) SIMATIC Manager  

(with SIMATIC Logon) 
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8.3.2 How to Set the Defaults 

Procedure 
1. Open SIMATIC Manager with the menu command Start > SIMATIC > SIMATIC Manager. 
2. In SIMATIC Manager, select the menu command Options > Settings…  

.The "Settings" dialog box opens. 
3. Set the location for storing projects and libraries in the "General" tab.  

Specify the path for storing your projects/libraries if you do not want to use the default 
path but rather, for example, a specially created project drive. 

4. Ensure that backups (images) are loaded. 
5. In the "Language" tab, set the language and the mnemonics with which you want to work. 
6. In the "Date and Time" tab, set the desired format and specify if the module should show 

the local time of the programming device / PC (for UTC system time -> convert to local 
time). 

7. In the "Wizards" tab, check if the "PCS 7" option is set.  
This setting is required to be able to later start the PCS 7 "New Project" and "Expand 
Project" wizards. 

8. In the "Message Numbers" tab leave the default setting "Always prompt for setting" or 
select " Always assign unique message numbers CPU-wide". 

9. In the "Archive" tab, you can select the archiving program you want to use (for example, 
PKZip) and the paths for archiving/retrieval. 

10. Click "OK". 
You enter all other settings the first time you create the PCS 7 project with the PCS 7 "New 
SIMATIC Manager Project" wizard. You can change these settings later in the "Settings" 
dialog box. 

 

 Note 
You will have to restart the SIMATIC Manager for some of the settings, for example, when 
changing the language. 

 

Additional information 
● Online help for the "Settings" dialog box 
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8.3.3 How to Create a New Multiproject with the PCS 7 Wizard 

PCS 7 "New Project" Wizard     
Use the PCS 7 "New Project" wizard to create a new PCS 7 project as a multiproject. The 
multiproject contains the following components:  
● One project 
● The master data library 
You are guided through the individual configuration steps of the PCS 7 wizard. While 
working through the wizard, you specify the CPU, select the number of levels in the plant 
hierarchy and the AS objects to be created (CFC/SFC charts) and OS objects (PCS 7 OS, 
SIMATIC BATCH, SIMATIC Route Control) Technological names such as plant, unit and 
function are specified and you can adapt these later to the requirements of your plant.  
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Procedure  
1. Select the menu command File > "New Project" Wizard in the SIMATIC Manager. 
2. You can check the structure of the multiproject using the "Preview" button. 
3. Click "Continue". 

 
4. Select the desired CPU (bundle) and the number of communication modules (CP 443-5) 

as required. 
5. Click "Continue". 
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6. Define the project structure you require in the next dialog: 
– AS objects: CFC/SFC chart 
– OS objects: PCS 7 OS, SIMATIC BATCH, SIMATIC Route Control, OpenPCS 7 
– Configuration: single-station system, multiple station system or redundant multiple 

station system. 
7. Click "Continue". 
8. Specify the directory names (project name) and the storage location (path) of the 

multiproject. 
9. Click "Finish" to start creating the multiproject. 
10. Activate the "Assign unique message numbers CPU-wide" option in the "Message 

number assignment selection" dialog box. 
11. Click "OK". 

Result 
The multiproject is created and contains one project as shown in the preview. The relevant 
objects are created in the component view and in the plant view. There is also a master data 
created with the following content: 
● in the component view: 

an S7 program with the folders for source files, blocks and charts 
a folder for shared declarations 

● in the plant view: 
separate folders for process tag types, models and shared declarations 

Opening the Multiproject 
When you create a multiproject with the PCS 7 wizard, it opens automatically in the SIMATIC 
Manager. 
When you open the multiproject at a later point in time, be sure to always open it with the 
menu command File > Open > "Multiprojects" tab > "<Name of the multiproject>" > "OK" 
button. 



 Implementing the PCS 7 Configuration 
 8.3 Creating the PCS 7 Project 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 261 

8.3.4 How to Expand the Multiproject by Adding New (Empty) Projects 

Procedure 
1. Select the multiproject in the SIMATIC Manager. 
2. Select the menu command File > Multiproject > Create in Multiproject... 
3. Enter a name for the new project and specify a storage location. 
4. Click "OK". 

Result 
An empty project is created in the multiproject, which you can later configure (for example, 
using HW Config, Technological Hierarchy) or add preconfigured stations to using the PCS 7 
"Expand Project" wizard. 

Additional information 
● When working in multiproject engineering, in the section "Configuring in a Multiproject 

(Page 196)" read the information relating to the rules for distributing the automation 
systems, operator stations and SIMATIC PC stations in the individual projects of the 
multiproject. 

● Section "How to Expand a Project with Preconfigured Stations Using the PCS 7 Wizards 
(Page 263)". 
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8.3.5 How to Insert an Existing Project in a Multiproject 

Introduction 
If you want to continue using an existing project (single project unchanged or modified), you 
can integrate it in your multiproject.  
If the project already belongs to another multiproject, a message is displayed. If you want to 
include such a project in the multiproject, it is removed from the other multiproject. 

Procedure 
1. Open the multiproject. 
2. Select the menu command File > Multiproject > Insert in Multiproject... in the SIMATIC 

Manager. 
3. Select the project you want to insert. 
4. Click "OK". 

 

 
 

Note 
If this project originates from an earlier PCS 7 version, keep to the procedure described in 
the manuals Process Control System PCS 7; SW Update .... 

 

8.3.6 How to Remove a Project from the Multiproject 

Introduction 
You can remove projects which are no longer required from the multiproject. 

Procedure 
1. Open the multiproject. 
2. Select the project you want to remove from the multiproject. 
3. Select the menu command File > Multiproject > Remove from Multiproject in the SIMATIC 

Manager. 

Result 
The project is no longer a part of the multiproject. It is, however, not deleted; only the 
assignment to the multiproject is canceled. You can delete the project with the menu 
command File > Delete > User Projects. 
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8.3.7 How to Expand a Project with Preconfigured Stations Using the PCS 7 Wizards 

PCS 7 "Expand Project" Wizard      
With the PCS 7 "Expand Project" wizard, you can expand a project with preconfigured 
stations, such as an AS or a PC station (without integrating any hardware) for OS, BATCH or 
Route Control, or OpenPCS 7. 
For the AS, this involves assembled configurations (bundles), which you can find in the 
PCS 7 catalog (and will already be aware of from the PCS 7 "New Project" wizard). If you 
use such bundles in your plant, all required objects are created when you insert 
preconfigured stations. You do not have to manually integrate the components of the bundle. 

Inserting an AS 
1. Select the project to be expanded in the SIMATIC Manager. 
2. Select the menu command Insert > Preconfigured Station…. 
3. Select "CPU" from the drop-down list and select the required CPU. 
4. Select the required bundle from the "Bundle" list. 

You can find the components of the bundle in the "Description" column. 
5. Select the number of communication modules (distributed I/O) you want to set up from 

the "Number of communication modules (CP 443-5)" drop-down list. 
6. Click "Continue". 
7. If you also want to insert a PC station, select the desired station type (OS objects). 
8. Click "Continue". 
9. You are shown the project name and storage location in the next dialog. 
10. Click "Finish". 

Result 
The appropriate automation system is created, including the hardware configuration for all 
components of the selected bundle.  



Implementing the PCS 7 Configuration  
8.3 Creating the PCS 7 Project 

 Engineering System (V7.1) 
264 Configuration Manual, 03/2009, A5E02122455-01 

Inserting a PC Station 
1. Select the project to be expanded in the SIMATIC Manager. 
2. Select the menu command Insert > Preconfigured Station…. 
3. Select "CPU" from the drop-down list and select the entry "(Do not install hardware)". 
4. Click "Continue". 
5. Select from the following under "OS objects": 

– PCS 7 OS 
– SIMATIC BATCH 
– SIMATIC Route Control 
– OpenPCS 7 

6. Then select from the following: 
– Single station system 
– Multiple station system 
– Multiple station system redundant 

7. Click "Next". 
The project name and storage location will be displayed for you in the next dialog. 

8. Click "Finish". 

Result 
The appropriate SIMATIC PC stations including the hardware configuration are created.  
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8.3.8 How to Expand a Project with Other Objects 

Introduction 
The PCS 7 wizards create the basic configuration, which you can expand with additional 
objects based on the requirements of your plant. 

Procedure 
The procedure described here does not depend on the selected view. The objects you can 
select to be included depend on the currently selected object and the selected view. 
1. Select the folder/object in the SIMATIC Manager. 
2. Select the Insert folder. 

All of the objects that can be inserted below the folder are available in the Insert menu.  
The available selection depends on whether you selected the object in the Process 
Object View, Plant View or in the Component View. 

3. Select the object you require with the menu command and specify the object name. 

Additional information 
● Online help for the SIMATIC Manager 
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8.3.9 How to Provide Projects/Libraries Access Protection 

Introduction     
As of PCS 7 V7.0, you have the option to assign a project password to provide access 
protection for projects and libraries.  
Once you have configured the access protection, you can record online actions in a change 
log. 

Requirements 
● SIMATIC Logon is installed. 
● The "Project administrator" and "Project editor" roles in SIMATIC Logon are automatically 

created during the PCS 7 installation. 
● You are assigned the "Project administrator" role in SIMATIC Logon. 
● You are logged on as the project administrator or project editor. 

Rules 
● The user currently logged on (project administrator, project editor) is displayed in the 

status bar of the SIMATIC Manager. 
● The project format is changed the first time access protection is activated. You receive 

notice that the modified project can no longer be edited with older PCS 7 versions. 
● By using the function Remove Access Protection and Change Log you lose the 

information about the users who have access to the project or library and all the change 
logs. 

Activating Access Protection and Assigning a Password 
1. Select the project/library in the SIMATIC Manager. 
2. Select the menu command Options > Access Protection > Activate. 
3. Enter the password and confirm it in the "Activate Access Protection" dialog box. 
4. Click "OK". 

The corresponding project/library is now password-protected and can only be opened by 
authorized users for editing. 
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Deactivating Access Protection 
1. Select the project/library in the SIMATIC Manager. 
2. Select the menu command Options > Access Protection > Deactivate. 
3. Enter the password and confirm it in the "Deactivate Access Protection" dialog box. 
4. Click "OK". 

The corresponding project/library is no longer password-protected and can be opened by 
any user for editing. 

Activating/Deactivating the Change Log 
1. Select the project/library in the SIMATIC Manager. 
2. Select the menu command Options > Change Log > Activate or Deactivate. 

Certain online changes are logged. 

Displaying the Change Log 
1. Select the desired section (project, SIMATIC station, Operator station) in the tree view of 

the SIMATIC Manager. 
2. Select the menu command Options > Change Log > Display. 

The change log opens, and comments can be added to it. 
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Other Aspects of Access Protection 
 

Menu Command Purpose 
Options > Access Protection >  
Manage 

Editing the user management (in the "SIMATIC Logon Role Management" 
dialog box) 
As the project administrator, you have the right to: 
• Activate or deactivate access protection 
• Manage and synchronize users 
• Change the project password 
• Activate, deactivate and display the change logs 
• Removing Access Protection and Change Log 
As the project editor, you have the right to: 
• Open and edit projects/libraries with access protection 
• Display change logs 

Options > Access Protection > 
Synchronize in multiproject 

When a multiproject is open, this specifies the project administrators and 
project editors globally for all the projects and libraries in a multiproject.  
The properties specified for the object selected (e.g. a project or a library) are 
assigned to all other objects in the multiproject. 

Options > Access Protection > Remove 
Access Protection and Change Log 

Removes the access protection and deletes the change log of a password-
protected project/library (because the access protection is longer required) 

Additional information 
● Section "Protecting Projects/Libraries with Access Protection (Page 193)" 
● Section "How to Document Changes in the ES Log" (Page 676)" 
● Online help for the SIMATIC Manager 
● Manual SIMATIC Logon; SIMATIC Electronic Signature 
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8.3.10 How to Open an Access-protected Project/Library 

Introduction     
The following describes how you can open protected projects/libraries. This generally 
depends on whether or not the SIMATIC Logon Service is installed. 

 

 Note 
If you open a multiproject that contains protected projects/libraries without first logging on to 
the SIMATIC Logon Service, the protected projects/libraries are grayed out and cannot be 
edited. 
To view which projects/libraries these are (incl. path), position the mouse cursor over the 
gray project or library (tooltip), or access the detail view. 
If you attempt to open a protected project/library and are not registered as the project 
administrator or project editor, or do not know the password, the project/library will not open.

 

Procedure 
 

If... Then 
• SIMATIC Logon Service is installed 
• Are registered as a project administrator 

or project editor 
• You have logged on with the SIMATIC 

Logon Service 
• The project/library is not open 

1. Select the menu command  
File > Open in the SIMATIC Manager. 
2. Select the desired project/multiproject/ 
library. 
3. Click "OK". 

• SIMATIC Logon Service is installed 
• Are registered as a project administrator 

or project editor 
• The project/library is not open 

1. Select the menu command 
File > Open in the SIMATIC Manager. 
2. Select the desired project/multiproject/ 
library. 
3. Click "OK". 
4. Enter your user name and password in the "SIMATIC Logon Service" 
 dialog box. 
5. Click "OK". 

• SIMATIC Logon Service is not installed, 
• The project/library is not open 

1. Select the menu command 
File > Open in the SIMATIC Manager. 
2. Select the desired project/multiproject/ 
library. 
3. Click "OK". 
3. Enter the  
project password in the "Enter Project Password" dialog box. 
4. Click "OK". 

Result 
The protected project/library opens and can be edited.  
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8.3.11 How to Manage Multilingual Texts 

Introduction     
To visualize the process on the operator station you use faceplates, which show the plant 
operator the measured values, operating limits, units, and operator texts of the blocks, for 
example. 
PCS 7 allows you to export texts that are stored in one language in a project, have them 
translated, reimport them, and have them displayed in the translated language. 

 

 Note 
If operator texts or display texts have been changed compared to the PCS 7 version in 
blocks for the system which is being updated and you wish to use the new PCS 7 V7.1 
faceplates, you should back up the "old" operator texts. 

 

Requirement 
The desired language is already installed in the project.  
(Select the menu command Options > Language for Display Devicesin the SIMATIC 
Manager in order to have the list of available languages displayed). 

Rules 
● The new texts must not be longer than the default texts. If longer texts can not be 

avoided, check whether the text is still displayed correctly. 
● Export: 

The export is carried out for all the blocks and symbol tables that lie under the selected 
object. One export file is created for every text type. This contains one column each for 
the source and the target language.  
The texts in the source language may not be changed. 

● Import: 
The import is carried out for all the blocks and symbol tables that lie under the selected 
object. During importing the contents of the columns for the target language (right 
column) is imported into the selected object. Only those texts are imported for which an 
agreement with an existing text is found in the column for the source language. 
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Exporting 
1. Open the project to be updated in the SIMATIC Manager. 
2. Select the folder of the master data library (or if it does not exist, the project folder) in the 

component view. 
3. Select the menu command Options > Manage Multilingual Texts > Export. 

The "Export User Texts" dialog box opens. 
4. Make the following settings: 

– In the "Text tables" group select the storage location and the format of the export file 
(possible formats: *.xls and *.csv). 

– In the "Language" group select the target language and source language in 
accordance with your display language. 

– Select the text types to be exported in the "Text types" group. 
– If appropriate, activate the "Enter points of use of texts in the export file" check box. 

5. Click "OK". 
An export file is created for each text type in the target directory. 

If you manage several project-specific languages, repeat Steps 3 and 4. Note that you must 
then set different export file names or target directories. 

Importing 
1. Open the project to be updated in the SIMATIC Manager. 
2. Select the folder of the master data library (or if it does not exist, the project folder) in the 

component view. 
3. Select the menu command Options > Manage Multilingual Texts > Import. 

The "Import User Texts" dialog box opens. 
4. In the "Source" group, select the storage location and the format of the import file 

(possible formats: *.xls and *.csv). 
5. Click "OK". 

The texts are imported and a log file of the import is output. 



Implementing the PCS 7 Configuration  
8.3 Creating the PCS 7 Project 

 Engineering System (V7.1) 
272 Configuration Manual, 03/2009, A5E02122455-01 

Display languages in multilingual projects 
● For multilingual projects, before the first OS compilation, you must add all display 

languages that will later be required in the SIMATIC Manager (For additional information 
on this topic, see Section "How to Set the Language for Display Devices (Page 328)"). 

● You must perform the compile and download operations in the same language that was 
used when making changes to the configuration. 
If, for example, you are importing Spanish texts (language for display devices: Spanish), 
you must also perform the compile and download operations in this language. Otherwise 
the changed texts will not be added to the WinCC text library. 

● For the purpose of using texts from the PCS7 library in WinCC, in the SIMATIC Manager 
under "Language for display devices", you can only select the following S7 languages: 
– German (Germany) 
– English (USA) 
– French (France) 
– Italian (Italy) 
– Spanish (international sorting) 

● The texts for Spanish (international) are converted to texts for Spanish (traditional) when 
the OS is compiled. The same applies if you want to translate your own texts into one of 
the five main languages and import them into your project using the menu command 
Options > Manage multilingual texts. For other languages, refer to the languages 
available in WinCC. 

● It is not possible to use different variants or sortings of a language in parallel for WinCC, 
i.e. you cannot use English (USA) alongside English (UK) or Spanish (international 
sorting) alongside Spanish (traditional sorting) or Dutch (Netherlands) alongside Dutch 
(Belgium). 

Additional information 
● Online help for the SIMATIC Manager 
● Manual SIMATIC; Programming with STEP 7 
● Manual Process Control System PCS 7; Operator Station 
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8.4 Configuring the SIMATIC and PC Stations 

8.4.1 Introduction into the Configuration of SIMATIC and PC Stations 

SIMATIC and PC Stations       
You create the following objects in the projects of the multiproject in the SIMATIC Manager: 
● a "SIMATIC 400 station" for each automation system 
● a "SIMATIC PC station" for the engineering station 
● a "SIMATIC PC station" for each operator station (OS server and OS client) 
● a "SIMATIC PC station" for each BATCH station (BATCH server and BATCH client) 
● a "SIMATIC PC station" for each Route Control station (RC server and RC client) 
● a "SIMATIC PC station" for each OpenPCS 7 station 
You configure the hardware of the automation systems and PC stations for ES, OS, BATCH 
and Route Control in the HW Config application. 

 

 Note 
If you require distributed editing of the projects of the multiproject, read the information in the 
section "Configuring in a Multiproject (Page 196)" on the distribution of automation systems, 
operator stations and SIMATIC PC stations to the individual projects of the multiproject. 
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8.4.2 How to Insert the SIMATIC 400 Stations in the Projects of the Multiproject 

Introduction 
Once you have created the multiproject with the PCS 7 wizard, as default, one automation 
system is already inserted. You can insert additional automation systems as follows: 
● With the PCS 7 "Expand Project" wizard 

You can find information about this in the section "How to Expand a Project with 
Preconfigured Stations Using the PCS 7 Wizards (Page 263)". 

● Manually (described below) 

Procedure 
1. Select the project where you want to insert a SIMATIC station in the component view of 

the SIMATIC Manager. 
2. Select the menu command Insert > Station > SIMATIC 400 Station.  

A new station is inserted ("SIMATIC 400 Station(1)"; you can adapt the name to your 
requirements). 

3. Follow the same procedure if you want to install additional SIMATIC stations. 

Additional information 
● Section "How to Create a SIMATIC 400 Station (Page 359)" 
● Online help for the SIMATIC Manager 
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8.4.3 How to Start Configuring SIMATIC 400 Stations 

Introduction 
This section describes how to start the basic configuration of the automation systems. We 
recommend the following work sequence for multiprojects: 
● The automation systems will be created in the individual projects and the communication 

processors for network connection will be configured on the central engineering station. 
This is described below. 

● The complete hardware configuration with attached I/O will be completed on the 
distributed engineering stations after the projects are distributed for editing. The complete 
hardware configuration is described in the section "Configuring the Hardware". 

 

 
 

Note 
If you have created the SIMATIC 400 station with PCS 7 "Expand Project" wizard, all 
hardware components of the respective bundle are already available.  

 

Procedure 
Follow the steps outlined below to start the basic configuration of the automation systems: 
1. Select the required SIMATIC 400 station from the component view and open the HW 

Config by double-clicking the "Hardware" object in the detail window. 
The hardware configuration of the automation system is opened. 

2. If the hardware catalog is not visible, select the menu command View > Catalog. 
3. In the SIMATIC 400 > Rack-400 hardware catalog, select the required rack and insert it 

by dragging with the mouse.  
Make sure that the arrangement selected here matches the arrangement of the physical 
hardware. 

4. In the "SIMATIC 400 > PS-400" hardware catalog, select the required power supply and 
add it by dragging with the mouse. 

5. In the SIMATIC 400 > CPU-400 hardware catalog, select the required CPU and insert it 
by dragging with the mouse. 

6. Click "OK" to confirm the "Properties - PROFIBUS Interface" dialog box that opens. 
7. Follow the same procedure if you want to install additional components. 
8. Select the menu command Station > Save and Compile in HW Config. 

Additional information 
● Section "Configuring the Hardware" 
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8.4.4 How to Insert CPs in the SIMATIC Stations and Assign Them to Networks 

Introduction 
The communications processors (CP) inserted in the SIMATIC 400 stations must be 
configured for network attachment in HW Config and assigned to the communications 
network. In multiproject engineering, it is advisable to carry out this configuration work on the 
central engineering station for all projects. This ensures, for example, that node addresses 
are unique on the bus. 

 

 Note 
If you have created the SIMATIC 400 station with PCS 7 "Expand Project" wizard, all 
hardware components of the respective bundle, including the CPs, are already available. 
This means that you require the procedure described here to add other CPs later on. 

 

Procedure 
1. Select the required SIMATIC 400 station from the component view and open the HW 

Config by double-clicking the "Hardware" object in the detail view. 
The hardware configuration of the automation system is opened. 

2. If the hardware catalog is not visible, select the menu command View > Catalog. 
3. In the "SIMATIC 400 > CP-400" hardware catalog, select the CP (CP 443-1) you require 

for the network being used and insert it with drag-and-drop. 
Once you have inserted the CP, the "Properties - Interface" dialog box is opened. 

4. Set the required CP address on the bus in the "Properties - Interface" dialog box. 
5. Select the subnet from the "Subnet" group: 

– If you have not yet set up a subnet, click "New" and define a new network. 
– If you have already set up a subnet, select the required network in the "Subnet" group. 

6. Click "OK".  
The "Properties" dialog box closes. 

7. Select Station > Save and Compile from the menu. 

Additional information 
● Section "Configuring the Hardware" 
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8.4.5 How to Insert an Engineering Station and Configure It 

Introduction 
The engineering station is configured in the SIMATIC Manager. The following steps are 
carried out during this process: 
● Insertion of a SIMATIC PC station 
● Configuration of the hardware in HW Config 
● Configuration of the communication connection in NetPro 
The communication connections set up for the PC station can then be checked with the 
diagnostics functions of the Station Configuration Editor. 

Procedure 
1. Select the project into which you want to insert the engineering station in the component 

view of the SIMATIC Manager. 
2. Select the menu command Insert > Station > SIMATIC PC Station. 

A new SIMATIC PC station is inserted in the selected project. 
3. Select the SIMATIC PC station, select the menu command Edit > Object Properties..., 

and enter the required name. 
4. Select the SIMATIC station from the component view and open the HW Config by double-

clicking the "Configuration" object in the detail view. 
The hardware configuration of the SIMATIC PC station is opened. 

5. If the hardware catalog is not visible, select the menu command View > Catalog. 
6. Under "SIMATIC PC Station > HMI ..." in the hardware catalog, select the required 

"WinCC application" and drag it into the configuration table: 
7. In the "SIMATIC PC Station > CP Industrial Ethernet" hardware catalog, select the 

communications processor installed in the SIMATIC PC station and drag it to the PC 
station. 
If you use a standard network card, select the "IE General" processor.  
The "Properties - Ethernet Interface" dialog box opens. 

8. Set the required address on the bus for the CP: 
– If the network adapter is connected to the terminal bus, activate the "IP protocol is 

being used" check box. 
– If the network adapter is connected to the plant bus, activate the "Set MAC address / 

Use ISO protocol" check box. If a maintenance station is being operated, activate the 
"IP protocol is being used" check box. 

– For a network card connected to the plant bus via BCE, enter the  
name in the "General" tab and set the  
"Interval" to "30" in the "Send keep alive for connections" group of the "Options" tab. 
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9. Select the subnet from the "Subnet" group: 
– If you have not yet set up a subnet, click "New" and define a new network. 
– If you have already set up a subnet, select the required network in the "Subnet" group. 

10. Click "OK".  
The "Properties" dialog box closes. 

11. Select Station > Save and Compile from the menu. 

Additional information 
● Section "Setting up PC Stations (Page 255)" 
● Manual Process Control System PCS 7; PC Configuration and Authorization 
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8.4.6 How to Insert an Operator Station and Configure It 

Introduction        
Each OS server, redundant OS server, and OS client of a PCS 7 OS is managed as a 
SIMATIC PC station in the SIMATIC Manager. The SIMATIC PC station always contains the 
following objects: 
● A WinCC application 
● A communications processor that is not inserted by the wizard 
● An OS 
If you created the multiproject with the PCS 7 wizards, you will already have inserted a 
PCS 7 OS if you selected the appropriate option. You can insert additional operator stations 
as follows: 
● With PCS 7 "Expand Project" wizard 

You can find information about this in the section "How to Expand a Project with 
Preconfigured Stations Using the PCS 7 Wizard (Page 263)". 

● Manually (described below) 

Procedure 
1. In the component view of SIMATIC Manager, select the project where you want to add 

the operator station. 
2. Select the menu command Insert > Station > SIMATIC PC Station. 

A new SIMATIC PC station is inserted in the selected project. 
3. Select the SIMATIC PC station, select the menu command Edit > Object Properties and 

enter the required name. 
4. Select the SIMATIC station from the component view and open the HW Config by double-

clicking the "Configuration" object in the detail view. 
The hardware configuration of the SIMATIC PC station is opened. 

5. If the hardware catalog is not visible, select the menu command View > Catalog. 
6. Under "SIMATIC PC Station > HMI" in the hardware catalog, select the required WinCC 

application and drag it into the configuration table: 
– SPOSA application (for OpenPCS 7 station) 
– WinCC application (for OS server or OS single station system) 
– WinCC application (stby) (for redundant OS server) 
– WinCC application client (for OS client) 
– WinCC appl. client ref (for reference OS client) 
– WinCC application ref (for reference OS single station system) 
– WinCC CAS appl. (for central archive server) 
– WinCC CAS appl. (stby) (for redundant central archive server) 
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7. In the "SIMATIC PC Station > CP Industrial Ethernet" hardware catalog, select the 
communications processor installed in the SIMATIC PC station and drag it to the PC 
station. 
If you use a standard network card, select the "IE General" processor. 
The "Properties - Ethernet Interface" dialog box opens. 

8. Set the required address on the bus for the CP: 
– If the network adapter is connected to the terminal bus, activate the "IP protocol is 

being used" check box. 
– If the network adapter is connected to the plant bus, activate the "Set MAC address / 

Use ISO protocol" check box. If a maintenance station is used, activate the "IP 
protocol is being used" check box. 

– For a network adapter connected to the plant bus via BCE, enter the name in the 
"General" tab and set the "Interval" to "30" in the "Send keep alive for connections" 
group of the "Options" tab. 

9. Select the subnet from the "Subnet" group: 
– If you have not yet set up a subnet, click "New" and define a new network. 
– If you have already set up a subnet, select the required network in the "Subnet" group. 

10. Click "OK".  
The "Properties" dialog box closes. 

11. Select the menu command Station> Save and Compile. 
12. Follow the same procedure if you want to install additional SIMATIC stations. 

Defining the Target and Standby OS  
Once all the required operator stations have been created in the SIMATIC Manager, and the 
network connections have been configured for all operator stations, the computer path of the 
target OS or standby OS must be assigned to each operator station.  
If you only have a single OS, you only need to specify the target OS. If you have a redundant 
OS, you must specify both the target OS (master) and if required the standby OS. 
You enter this setting in the object properties of the OS in the component view. Select the 
"OS" object below the SIMATIC PC station and then the menu command Edit > Object 
Properties (path to target OS and standby OS). 

Additional information 
● Configuration manual Process Control System PCS 7; Operator Station 
● Manual Process Control System PCS 7; PC Configuration and Authorization 
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8.4.7 How to Insert a BATCH Station and Configure It 

Introduction        
The BATCH server and each BATCH client of a BATCH station are managed and SIMATIC 
PC stations in the SIMATIC Manager. This always contains the following object: 
● A BATCH application (standard, standby, client) 
If you created the multiproject with the PCS 7 wizard, you will already have inserted a 
BATCH station if you selected the appropriate option. You can insert additional SIMATIC 
BATCH stations as follows: 
● With PCS 7 "Expand Project" wizard 

You can find information about this in the section "How to Expand a Project with 
Preconfigured Stations Using the PCS 7 Wizard (Page 263)". 

● Manually (described below) 
 

WARNING  
 

Configuring applications (WinCC, SIMATIC BATCH, etc.) on separate "SIMATIC PC 
station" objects and subsequently merging them to create one PC station by assigning 
the same computer name to the "SIMATIC PC station" objects is not permitted! 

 

Requirement 
The relevant SIMATIC BATCH add-on package is installed and licensed on the engineering 
station. 

Procedure 
1. Select the project into which you want to insert the BATCH station in the component view 

of the SIMATIC Manager. 
2. Select the menu command Insert > Station > SIMATIC PC Station. 

A new SIMATIC PC station is inserted in the selected project. 
3. Set the computer name of the SIMATIC PC station: 

– to do this, select the PC station. 
– Select the menu command Edit > Object Properties. 
– Enter the computer name in the "Computer name" group or activate the "Computer 

name identical to PC station name" check box. 
4. Select the SIMATIC station from the component view and open the HW Config by double-

clicking the "Configuration" object in the detail view. 
The hardware configuration of the SIMATIC PC station is opened. 

5. If the hardware catalog is not visible, select the menu command View > Catalog. 
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6. Under "SIMATIC PC Station > BATCH" in the hardware catalog, select the required 
BATCH application and drag it into the configuration table: 
– BATCH application (for BATCH server) 
– BATCH application (stby) (for redundant BATCH server) 
– BATCH application client (for BATCH client) 

7. In the "SIMATIC PC Station > CP Industrial Ethernet" hardware catalog, select the 
communications processor installed in the SIMATIC PC station and drag it to the PC 
station. 
If you use a standard network card, select the "IE General" processor. 
The "Properties - Ethernet Interface" dialog box opens. 

8. Set the required address on the bus for the CP: 
– If the network adapter is connected to the terminal bus, activate the "IP protocol is 

being used" check box. 
9. Select the subnet from the "Subnet" group: 

– If you have not yet set up a subnet, click "New" and define a new network. 
– If you have already set up a subnet, select the required network in the "Subnet" group. 

10. Click "OK".  
The "Properties" dialog box closes. 

11. Select Station > Save and Compile from the menu. 
12. Follow the same procedure if you want to install additional BATCH stations. 

Additional information 
● Manual Process Control System PCS 7; SIMATIC BATCH 
● Manual Process Control System PCS 7; PC Configuration and Authorization 
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8.4.8 How to Insert a Route Control Station and Configure It 

Introduction 
The Route Control server and every Route Control client of a Route Control station is 
handled as a SIMATIC PC station in the SIMATIC Manager. This always contains the 
following object: 
● A Route Control application (standard, standby, client) 
If you created the multiproject with the PCS 7 wizard, you will already have inserted a Route 
Control station if you selected the appropriate option. You can insert additional SIMATIC 
Route Control stations as follows: 
● With PCS 7 "Expand Project" wizard 

You can find information about this in the section "How to Expand a Project with 
Preconfigured Stations Using the PCS 7 Wizard (Page 263)". 

● Manually (described below) 

Requirement 
The SIMATIC Route Control add-on package is installed and licensed on the engineering 
station. 

Procedure 
1. Select the project into which you want to insert the Route Control station in the 

component view of the SIMATIC Manager. 
2. Select the menu command Insert > Station > SIMATIC PC Station. 

A new SIMATIC PC station is inserted in the selected project. 
3. Set the computer name of the SIMATIC PC station: 

– to do this, select the PC station. 
– Select the menu command Edit > Object Properties. 
– Enter the computer name in the "Computer name" group or activate the "Computer 

name identical to PC station name" check box. 
4. Select the SIMATIC station from the component view and open the HW Config by double-

clicking the "Configuration" object in the detail view. 
The hardware configuration of the SIMATIC PC station is opened. 

5. If the hardware catalog is not visible, select the menu command View > Catalog. 
6. Under "SIMATIC PC Station > Route Control" in the hardware catalog, select the required 

Route Control application and drag it into the configuration table: 
– RC application (for Route Control server) 
– RC application (stby) (for redundant Route Control server) 
– RC application Client (for Route Control client) 
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7. In the "SIMATIC PC Station > CP Industrial Ethernet" hardware catalog, select the 
communications processor installed in the SIMATIC PC station and drag it to the PC 
station. 
If you use a standard network card, select the "IE General" processor. 
The "Properties - Ethernet Interface" dialog box opens. 

8. Set the required address on the bus for the CP: 
– If the network adapter is connected to the terminal bus, activate the "IP protocol is 

being used" check box. 
– If the network adapter is connected to the plant bus, activate the "Set MAC address / 

Use ISO protocol" check box. If a maintenance station is used, activate the "IP 
protocol is being used" check box. 

– For a network adapter connected to the plant bus via BCE, enter the name in the 
"General" tab and set the "Interval" to "30" in the "Send keep alive for connections" 
group of the "Options" tab. 

9. Select the subnet from the "Subnet" group: 
– If you have not yet set up a subnet, click "New" and define a new network. 
– If you have already set up a subnet, select the required network in the "Subnet" group. 

10. Click "OK".  
The "Properties" dialog box closes. 

11. Select Station > Save and Compile from the menu. 
12. Follow the same procedure if you want to install additional Route Control stations. 

Additional information 
● Manual Process Control System PCS 7; PC Configuration and Authorization 
● Manual Process Control System PCS 7; SIMATIC Route Control 
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8.4.9 How to insert and configure an OpenPCS 7 station 

Introduction        
The OpenPCS 7 station is configured as a SIMATIC PC station in the SIMATIC Manager. It 
always contains the "SPOSA Application" object.  
The following steps are carried out during this process: 
● Insertion of a SIMATIC PC station 
● Configuration of the hardware in HW Config 
The communication connections set up for the PC station can then be checked with the 
diagnostics functions of the Station Configuration Editor. 
If you created the multiproject with the PCS 7 wizard, you will already have inserted an 
OpenPCS 7 station provided that you selected the appropriate option. You can also insert an 
OpenPCS 7 station as follows: 
● With PCS 7 "Expand Project" wizard 

You can find information about this in the section "How to Expand a Project with 
Preconfigured Stations Using the PCS 7 Wizard (Page 263)". 

● Manually (described below) 

Procedure 
1. Select the project into which you want to insert the OpenPCS 7 station in the component 

view of the SIMATIC Manager. 
2. Select the menu command Insert > Station > SIMATIC PC Station. 

A new SIMATIC PC station is inserted in the selected project. 
3. Select the SIMATIC PC station, select the menu command Edit > Object Properties and 

enter the required name. 
4. Select the SIMATIC station from the component view and open the HW Config by double-

clicking the "Configuration" object in the detail view. 
The hardware configuration of the SIMATIC PC station is opened. 

5. If the hardware catalog is not visible, select the menu command View > Catalog. 
6. Under "SIMATIC PC Station > HMI ..." in the hardware catalog, select the required 

SPOSA application and drag it into the configuration table: 
7. Select Station > Save and Compile from the menu. 

Additional information 
● Section "How to configure OpenPCS 7 stations for accessing PCS 7 data (Page 617)" 
● Manual Process Control System PCS 7; PC Configuration and Authorization 
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8.4.10 How to Configure and Download the PC Stations 

Introduction        
The project-specific network settings for the communication modules (Ethernet) are 
downloaded directly to the PC station by the engineering station. 

Requirements 
● The following is installed on each PC station: 

– Operating system 
– Specific software for the PC station (e.g., PCS 7 Engineering, OS server) 

● All PC stations to be downloaded are linked to the engineering station by means of at 
least one network. 

● The operating system network is administrated. 
● The network addresses of the PC stations are configured. 
● The protocol for the communication on the terminal bus is set to TCP/IP. 
● The following settings are made on each PC station: 

– The communication card for communication between the PC station and the terminal 
bus is selected. 

– The network addresses for the system bus are set. 
– The access point of the PC station is set to "S7ONLINE: = PC internal (local)". 

● The PCS 7 project is created. 
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Procedure 
 

 Note 
Please note the following: 
• Perform the following steps for the engineering station first before configuring and 

downloading the other PC stations. 
• When configuring the local PC station, the "Use configured target computer" check box 

must be deactivated (see Step 6). 
 

1. In SIMATIC Manager, open the PCS 7 project. 
2. In the component view, select the target computer. 
3. Select the menu command Target System > Configure....  

The "Configure" dialog opens. The PC station selected in the project is entered in the 
"Target Computer" group. 

4. From the "Local Network Connection" drop-down list, select the network connection to be 
used to access the target computer. 

5. Click "Update". 
The list of accessible computers will be updated. 

6. Select the desired target computer (PC station) from the list of available computers. 
 

 
 

Note 
If the selected PC station does not appear in the list, this suggests network problems or a 
faulty configuration in the project. 
Please ensure that the "Use configured target computer" check box is activated (as 
opposed to the local PC station). 

 

7. Click "Configure". 
The "Configure: Selected Station>" dialog box opens. 

8. In the "Configure: Target Computer" dialog box, click "OK". 
The "Information" dialog box opens. 

9. Click "OK".  
The configuration data are transferred to the PC station.  
The dialog box message line signals completion of the "Configuration" step.  
To activate the network connections, you must then download the network settings to this 
PC station. 

10. Click "Close". 
11. Select the menu command PLC > Download for the computer selected in step 2. 

The "Download Target System in Current Project" dialog box opens. 
 

 
 

Note 
The configured network address of the Ethernet interface in the PC station must match 
the preset address in the target system. 
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12. When the dialog box tells you that you are overwriting the configuration data, respond as 
follows: 
– During initial commissioning, click "Yes". 
– If the PC station is in process mode, you can only click "Yes" when a communication 

interruption is permissible. 
The "Stop Target Module" dialog box opens. 

13. In the "Stop Target Module" dialog box, click "OK" to confirm. 
The "Download" dialog box opens. 

14. Click "OK" to confirm. 
The download process is executed. 
Nach dem Übernehmen der Projektierung ist die PC-Station betriebsbereit. 

15. Repeat steps 2 through 14 for all of the PC stations. 

Switching the Logs on the Bus (Industrial Ethernet) 
 

NOTICE  
You must not deactivate the TCP/IP protocol or the ISO protocol during operation. These 
protocols are mandatory for the configured operating mode! 

 

If a bus within a system must be switched to a different protocol (for example, from TCP 
protocol to ISO protocol), you must temporarily set a mixed protocol (TCP and ISO) on the 
engineering station. You then download the configuration data to the AS and the operator 
control and monitoring systems. 

Additional information 
● Manual SIMATIC NET; Commissioning PC Stations - Manual and Getting Started 
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8.5 Creating the plant hierarchy (PH) 

8.5.1 Introduction to the PH 

Plant Hierarchy (PH) 
In the plant view, you structure the project according to technological aspects. In the process 
you hierarchically organize automation, operator control and monitoring functions into the 
hierarchy levels plant, unit or function. Name the relevant hierarchy folder according to its 
technological significance. Arrange the following in the hierarchy folder: 
● CFC and SFC charts for the AS 
● Pictures and reports for the OS 
● Additional documents such as descriptions of units, process tag sheets, planning 

documents etc. (from Word, Excel, etc.) 
The resulting project structure is the plant hierarchy. 

Note to Reader 
The following description is based on the following points: 
● The plant hierarchy is created on the central engineering station and, if necessary, filled 

with additional documents. This is described below. 
● The CFC/SFC charts or OS pictures/OS reports created on the distributed engineering 

stations are then assigned to the hierarchy folders. 

Overview of Configuration Tasks 
This overview shows you the steps for creating the plant hierarchy: 
 
What? Where? 
Creating the Plant Hierarchy (Page 294) SIMATIC Manager 
Inserting Additional Hierarchy Folders into the Plant Hierarchy 
(Page 297) 

Plant hierarchy 

Specifying the AS/Os Assignment (Page 300) Hierarchy folder in the plant 
hierarchy 

Assignment of Objects of the Plant Hierarchy (Page 302) Component view 
Checking the Consistency in the Plant Hierarchy (Page 304) SIMATIC Manager 
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8.5.2 Structure of the PH 

PH Created with the PCS 7 "New Project" Wizard 
With the "New Project" PCS 7 wizard, you create a PCS 7 multiproject with project and 
master data library including the corresponding plant hierarchy (PH).  
The following hierarchy objects are created in the plant view or in the process object view: 
● Multiproject (in the s7_Pro4_MP) 
● Project (in the example s7_Pro4_Prj) 
● Shared declarations 
● Plant (in the example: plant(1)) 
● A unit (in the example: Unit(1)) 
● A technological function (in the example: function(1)) 
● Master data library (in the example: s7_Pro4_Lib) 

In the component view:  
an S7 program with the folders for 
– Source files 
– Blocks 
– Charts 
– One folder for shared declarations 
In the plant view:  
The folders for  
– Tag types 
– Models 
– Shared declarations 
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Select plant view 
If the plant view is not visible, select the menu command View > Plant View. 
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8.5.3 Settings and Properties of the PH 

Introduction       
When you create a multiproject with the PCS 7 wizard, defaults or specified parameter 
settings made in the individual steps of the PCS 7 wizard were used (for example, the 
number of hierarchy levels, assignment to AS). You can change these settings later or adapt 
them for hierarchy folders to be added later. 

Definition of the Higher Level (Plant) Designation (HID) 
The higher-level or plant designation (HID) is used to identify parts of the plant according to 
their unique functional aspects. The HID is structured hierarchically according to the plant 
configuration. 
When making the settings for the plant hierarchy, you can specify which hierarchy levels are 
included automatically in the HID and how many characters each part of the name will have. 
As a result, the HID consists of the names of the various hierarchy folders.  
Example: 
[NameHierarchyfolderLevel1]\[NameHierarchyfolderLevel2]" 
For each hierarchy folder at each hierarchy level, you can also specify whether its name is 
included in the HID or whether it should be removed from the HID. Hierarchy folders that are 
included in the HID, are said to be "hierarchy folders included in the designation". 

 

 Note 
To ensure consistent naming throughout the entire project, make sure that you select a 
suitable naming scheme for the hierarchy folders in the plant view during configuration.  
The number of characters in the names of the hierarchy folders must not exceed the number 
of characters specified for the HID. 
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Overview of the Settings for the Plant Hierarchy 
 
Setting Description 
Number of hierarchy 
levels 

Specifies the maximum number of possible hierarchy levels, maximum 
eight levels. At each level, you can insert as many hierarchy folders as 
required. 

Basing the Picture 
hierarchy on the plant 
hierarchy 

With this option, the OS picture hierarchy is derived completely from the 
configured data of the plant hierarchy. This picture hierarchy is transferred 
to the Picture Tree Manager when you later compile the OS. 

Derive diagnostics 
screens from the plant 
hierarchy 

With this option, the diagnostics screens are generated in the plant 
hierarchy for the maintenance station.  
You can also specify if the names of the diagnostic screens to be 
generated should derived from the name of the hierarchy folders or from 
the comments of the hardware components. 
You can only select this option when the option "Derive picture hierarchy 
from the plant hierarchy" is also set. 

Migrating diagnostics 
settings 

After you have selected an OS for the diagnostics area, properties will be 
automatically modified at this OS (and at all other OS of the multiproject), 
including the expansion of the startup list. These settings must be 
migrated in the course of an upgrade to higher PCS 7 versions. 

Level Settings 
Max. number of 
characters 

Specifies the maximum number of characters permitted for the name of a 
hierarchy folder at this level (1 to 24) 

Included in HID You can select the levels from which hierarchy folder names (if selected 
for inclusion) will be included in the HID. You can use folders that are not 
selected for inclusion in the designation to create additional "drawers" (for 
example, for supplementary documents, such as plant descriptions, 
process tag sheets, etc.). 
If a level is included in the naming scheme of the HID, this means that the 
names are entered in the origin of the message (OS) and in the tag names 
on the OS (measuring point). 
Note: Remember that when assigning names and compiling the OS, the 
tag name must not be longer than 128 characters. The name consists of 
the following elements: 
• Name of the folder in the hierarchy path (including server prefix) 
• Chart name 
• Block name 
• Separator 
• I/O name 

With separator With this option, a separator can be included in the HID after the name of 
hierarchy folders of this level.  
Separators are used in the textual representation of the hierarchy path to 
differentiate between the names of the hierarchy folders. The "\" character 
is used as the separator. 

OS area With this, you can decide which hierarchy level should count as the OS 
area. The default is the 1st level. 
The definition of an OS area is necessary for area-specific messages in 
process mode. 
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8.5.4 How to Perform the Settings for the PH 

Procedure       
1. Open the plant hierarchy in the SIMATIC Manager with the menu command View > Plant 

View. 
2. Select a hierarchy folder and select the menu command Options > Plant Hierarchy > 

Customize....  
If you have selected several projects in a multiproject, you will first see a dialog box with a 
list of the selected projects. You can make the setting shown in the following dialog box 
only after selecting a project. 

 

 
 

Note 
The settings function as a template and are passed on to all other projects that were 
included in the selection. Projects that were not selected retain their settings.  
If you select the multiproject explicitly, all the projects it contains will adopt the settings 
you made in the template project. 
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3. Click "OK".  
The "Plant Hierarchy - Settings" dialog box opens. 

 
4. Define the plant hierarchy for the project. 

(You can find information about this in the section "Settings and Properties of the PH 
(Page 292)"). 

5. Click "OK". 

Additional information 
● Configuration manual Process Control System PCS 7; Operator Station 
● Online help for the "Plant Hierarchy - Settings" dialog 
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8.5.5 Rules for Naming in the PH 

Extending the Basic Structure       
Use the PCS 7 wizard to create a maximum of 8 hierarchy levels without additional nesting 
of hierarchy folders. You can further extend this basic structure during configuration by 
adding further hierarchy folders and/or technological objects. 
When doing this, remember the following rules for naming folders/objects in the plant 
hierarchy. 

Rules for Naming Folders/Objects 
● The following special characters may not be used in the name of a hierarchy folder: [ . ] 

[ % ] [ / ] [ \ ] [ " ] 
 

 
 

Note 
The characters [ ' ] [ . ] [ % ] [ \ ] [ * ] [ ? ] [ : ] [spaces] within a name are converted to the 
substitute character $ when you compile the OS.  
The ES separator [ \ ] is converted to the [ / ] character.  
If, for example, you assign the name "TICA:1" for a CFC chart (this becomes "TICA$1" on 
the OS) and the name "TICA*1" for another CFC chart, (also becomes "TICA$1"), you will 
receive an error message when you transfer the second chart because the chart name 
already exists.  

 

● The maximum length of a tag name is 128 characters. Remember, however, that many of 
the editing windows on the OS can not display 128 characters in their entirety. You 
should therefore restrict the length of the HID. 

● Remember that special characters associated with certain national languages take up 
two characters, thus reducing the maximum name length accordingly. 

● Remember that the length of the texts transferred depends on the maximum text length of 
a target block in the OS (Tag Logging, for example, event 50 characters; origin 32 
characters). When compiling the "OS" texts up to a maximum length of 255 characters 
are transferred. 
Remedy: 
Increase the maximum character length of the user text field or select a shorter HID. 

● The message texts of the transfer messages are made up of the hierarchy path, chart 
name, and the block name (if you decided to include the names in the HID). 
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8.5.6 How to Insert Additional Hierarchy Folders 

Introduction 
Use the PCS 7 wizard to create a maximum of 8 hierarchy levels without additional nesting 
of hierarchy folders. You can expand this structure that was created by the PCS 7 wizard 
with additional hierarchy folders and/or technological objects. 

Hierarchy folder 
The hierarchy folder is used to structure the plant in a hierarchy. It can contain additional 
hierarchy folders and objects: 
● CFC charts 
● SFC charts 
● OS pictures 
● OS reports 
● Equipment Properties 
● Additional documents (for example: Excel, Word) 
The higher-level designation (HID) of an object results from the names of the hierarchy 
folders (path) and the object name (if you decided to include the names in the HID). 

Procedure 
1. Open the plant hierarchy in the SIMATIC Manager with the menu command View > Plant 

View. 
2. Select a hierarchy folder where you want to insert the additional hierarchy folder. 
3. Select the menu command Insert > Technology Objects > Hierarchy Folder. 
4. Enter the technological name of the hierarchy folder. 

Assigning Technological Names 
After you insert a hierarchy folder, this is displayed in the right hand window. It is prepared 
so that you can assign a new name: the name field with the name assigned by the system is 
selected and the cursor is located after the last character of the folder name. You can now 
enter the required technological name at the keyboard (delete and edit). 
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8.5.7 How to Insert Objects in the Hierarchy Folder 

Introduction 
The technological objects CFC charts, SFC charts, OS images, OS reports, and equipment 
properties can be inserted in the plant hierarchy in both the plant view and process object 
view. The methods for inserting objects are practically identical. Below you will find a 
description of how to insert technological objects into the plant view. 

Inserting an Object 
You can insert the following objects: CFC/SFC chart, OS picture/OS report, equipment 
properties.  
1. Open the plant view in the SIMATIC Manager with the menu command View > Plant 

View. 
2. Select a hierarchy folder where you want to insert the object. 
3. Select the menu command Insert > Technology Objects > "<Required Object>". 

Inserting Additional Documents 
In addition to the objects required for automation and for operating and monitoring of the 
plant, you can also insert additional documents in a hierarchy folder (for example, unit 
descriptions, process tag sheets, planning documents).  
1. Select the hierarchy folder where you want to insert the object. 
2. Select the menu command Insert > Technology Objects > Additional Document. 

The "Insert Additional Documents" dialog box opens. All available applications are 
displayed. 

 

 
 

Note 
You can also create a new additional document by selecting the type in the "Registered 
Applications" box, entering the name and confirming with "OK".  
The additional document is created in the PH. Double-click the document to open and 
edit it. 

 

3. Click "Import". 
4. Select the required additional document. 
5. Click "OK".  

The selection is entered. 
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8.5.8 Rules for Copying and Moving within the PH 

Rules for Copying/Moving/Deleting Hierarchy Folders 
● If you copy or delete hierarchy folders, all the objects they contain are copied or deleted 

as well. By copying, you can copy, for example, an entire unit at once. Afterwards, you 
only need to carry out the modifications to the copied unit (for example, link to process 
signals). 

● If the target hierarchy folder to which you want to copy or move has no assignment to an 
AS (chart folder) and/or to the OS, this is created automatically by the system (you can 
find information about this in the section "How to Specify the AS/OS Assignment 
(Page 300)") 
This means that within the project the same assignment is entered on the copied 
hierarchy folder as of the source files folder. If there are multilevel hierarchy branches 
with different assignments, the different assignments are retained. 

● When more than one project is involved, every AS and OS in the destination environment 
is identified. If a unique assignment cannot be made, (no AS or OS, or only one), a list of 
the possible alternatives is displayed for selection. Once again, if hierarchy branches 
have different assignments, they are also different in the destination as specified in the 
source hierarchy branch. 

● If the destination hierarchy folder to which you want to copy/move already has an 
assignment to an AS and/or to an OS, this assignment is passed on to all copied objects. 

● You can copy, move and delete a hierarchy folder containing objects with different 
assignments. A warning is displayed asking you whether you really want to copy or move 
the folder. If you answer "Yes", all the objects are copied to the AS (or OS) that is 
assigned to the destination hierarchy folder. If you answer "No", nothing happens. 

● If the hierarchy folders you want to copy/move are models or replicas of models, 
remember the special rules that apply to them (you can find information about this in the 
section "How to Work with Models in the SIMATIC Manager (Page 577)"). 

Additional information 
● Section "Relationships between the Views (Page 246)" 
● Section "Cross-view Functions and How to Use Them (Page 247)" 
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8.5.9 How to Specify the AS-OS Assignment 

Introduction 
You must assign an OS and an AS for the hierarchy folder in the plant hierarchy. The AS/OS 
assignment produces the following results in the component view: 
● All CFC and SFC charts inserted in the plant hierarchy are stored in the chart folder of the 

assigned AS. 
● All OS images and OS reports inserted in the plant hierarchy are stored in the folder of 

the assigned OS. 

Procedure 
1. Select the hierarchy folder for which you want to make the AS-OS assignment in the plant 

view. 
2. Select the menu command Edit > Object Properties and change to the "AS-OS 

Assignment" tab. 
3. From the "Assigned AS (Chart Folder)" drop-down list, select the S7 program that you 

want to assign to the selected hierarchy folder. 
4. If the lower-level objects have a different assignment and you want to have the same 

assignment for all lower-level objects, check the "Pass on selected assignment to Pass 
on all the lower-level objects" check box. 

 

 
 

Note 
The "Pass on selected assignment to all lower-level objects" check box is only active if 
the lower-level objects have another assignment or no assignment. 

 

5. From the "Assigned OS" list, select the operator station you want to assign to the 
selected hierarchy folder. 

6. If the lower-level objects have a different assignment and you want to have the same 
assignment for all lower-level objects, check the "Pass on selected assignment to Pass 
on all the lower-level objects" check box. 

 

 
 

Note 
If the "area-oriented" compilation mode is activated, the OS assignment can only be 
changed for PH folders of the OS area level. 

 

7. Click "OK". 
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Result 
The AS/OS assignment is selected, and the lower-level objects are passed on or not passed 
on according to your setting. 

 

 Note 
If you have distributed the projects so that there is only one OS or one AS in a project, you 
do not need to make an AS/OS assignment. 

 

Additional information 
● Online help for PH, IEA and PO 
● Online help for the "AS-OS Assignment" tab 
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8.5.10 How to assign objects to the PH 

Introduction 
You can also assign objects from the component view, for example, a CFC chart or SFC 
chart, to the plant hierarchy later. This is always the case when, for example, charts are 
inserted directly in the component view and you then create a plant hierarchy later. If you 
create charts in the plant view or in the object view they are automatically assigned to the 
plant hierarchy.  

Requirement 
The hierarchy folder has the same AS or OS assignment as the assigned object. If the 
destination hierarchy folder has a different AS-OS assignment, the assigned object is also 
moved to this AS/OS in the component view. 

 

 Note 
If you have selected the setting "Base picture hierarchy on the plant hierarchy" in the settings 
of the plant hierarchy, only one picture of the same OS is permitted per hierarchy folder. 

 

Procedure 
1. Select the required object in the component view. 
2. Hold down the <Shift> key (move) and drag the object to the required hierarchy folder of 

the PH. 
If you have created OS pictures/OS reports directly in the OS and want to assign these 
object to the plant hierarchy later, proceed as follows: 
1. Select the OS in the component view of your project. 
2. Select the menu command Options > OS > Import WinCC Objects. 
3. Select the required object in the component view. 
4. Use Drag&Drop while simultaneously holding down the <Shift> key to drag the object 

from the component view to the required hierarchy folder of the PH. 
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Assignment after Copying/Moving 
● When you copy/move a hierarchy folder to a hierarchy folder that is assigned to a 

different AS or OS, the copied/moved hierarchy folder also receives the assignment of 
the destination folder. 

● When you copy/move objects (such as CFC charts, OS pictures/OS reports) to a 
hierarchy folder assigned to a different AS/OS, these objects are also copied/moved to 
the other AS or OS. 

● When you copy/move hierarchy folders with CFC charts and OS pictures, the references 
of the dynamic objects from the OS pictures to CFC blocks are automatically updated in 
the destination hierarchy folder. 

 

NOTICE  
 

The process variables referenced in the C scripts in WinCC must be defined in the 
"#define section". 

 

Interconnections after Copying/Moving 
When you copy / move CFC charts, the interconnections to shared addresses are either 
automatically copied or deleted.  
These settings can be made in CFC with the Options> Customize > Copy/Move... menu 
command or in the SIMATIC Manager with the Options> Charts> Settings for 
Copying/Moving.... menu command. The option "Copy interconnections with operands" is the 
default setting. 

Canceling the PH Assignment 
If you want to use charts, OS pictures, OS reports in a project without PH or want to delete 
the PH in the current project without losing these, you can cancel the assignment to the PH 
with the Options > Plant Hierarchy > Cancel Assignment... menu command. 
The function is available in the component view and in the plant view. 

Interconnections between Charts and OS Pictures 
When you copy/move hierarchy folders containing interconnected pictures and charts, the 
picture interconnections are always updated. Explicit updating is not necessary. 
When you compile the OS, all changes that affect ES variables are updated. 
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8.5.11 How to Check the Consistency of the PH 

Introduction 
You can use PCS 7 to determine whether the configured data are consistent with the 
settings made in the project or multiproject. 

Consistency Check 
The following properties are evaluated in the consistency check: 
● Non-unique names of S7 programs, CFC charts and SFC charts 
● Brackets in the names of hierarchy folders 
● Length of the hierarchy folder names 
● Number of hierarchy folder levels 
● Area assignment to an OS for uniqueness and completeness 
The following is checked when the check box "Derive picture hierarchy from the plant 
hierarchy" is activated: 
● Number of OS pictures per hierarchy folder 
● Unique picture names for OS 
The results are displayed in the individual tabs.  
Additional information concerning the test results in the tabs is available by clicking "Help". 

Additional Tests for a Selected Multiproject 
 

 Note 
If a multiproject is selected, the following checks are also made: 
• Check for unique names of S7 programs. Check if the names of CFC charts and SFC 

charts are unique in the entire multiproject. 
• Check if only one object for each type (S7 program, OS) is available in the master data 

library. 
• Check for uniformity in the OS assignment when area folders have the same name in the 

multiproject 
• Check for uniformity in the OS compiling mode ("AS oriented" or "Area oriented") 

throughout all projects in the multiproject 
• Check for consistent PH settings in the multiproject (levels of the OS area, derivation of 

the picture hierarchy and diagnostics, HID relevance) 
If a project or hierarchy folder is selected, then the tests are related exclusively to that project 
/ hierarchy folder. 
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Procedure 
1. Select the multiproject or a project in the plant hierarchy. 
2. Select the menu command Options > Plant Hierarchy > Check Consistency. 

The "Consistency Check - Log" dialog box opens, with the errors. 
3. Clear the errors and run the consistency check again. 

Display Log 
On completion of the check, a message is displayed or if an error occurred, the error log is 
output. 
You can also display the log later without running the check again with the menu command 
Options > Plant Hierarchy > Display Log. A log is displayed when the last consistency check 
has shown that the configured data are consistent with the settings that have been made. 

 

 Note 
Violations of the naming scheme can occur, for example, when you change settings at a 
later date or copy/move folders to different levels. The system tolerates these violations to 
avoid unnecessary error messages while you are working. 

 

Additional information 
For Additional information about the log, refer to the online help. 
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8.5.12 Additional PH Functions in a Multiproject 

PH Functions Specific to Multiprojects     
The functions of the plant hierarchy are adapted to the needs of multiproject engineering. 
Support begins with the creation of the multiproject by the PCS 7 wizard.  
The following functions are important for multiprojects: 
 
Function Description 
Creating a Multiproject In the SIMATIC Manager, the PCS 7 wizard automatically creates a 

multiproject.  
• The project is created with the content selected in the PCS 7 wizard 

(PH, AS, OS). 
• Two hierarchy folders are created in the master data library in the PH 

that serve as storage for process tag types, models and shared 
declarations. 

Cross-project 
Consistency Checks 

• The consistency check allows multiple assignment of names to process 
tags to be recognized early. This prevents these errors from canceling 
the data transfer procedure to the OS (during the compile OS function ). 

• You can check the uniqueness of the S7 programs in all of the 
multiproject projects. The uniqueness of the S7 programs is a 
requirement for the proper functioning of the Import/Export Wizard and 
the diagnostic function. 

• Within the master data library, a check is made to ensure that there is 
only one S7 program and only one OS. 

Passing on PH Settings 
to other Projects of a 
Multiproject 

The PH settings for the projects in a multiproject can be changed by using 
the menu command Options > Plant Hierarchy > Customize...: 
• Settings for an individual project 

If you select an individual project in a multiproject, you can define PH 
settings which are exclusive to this project. 

• Identical settings for several/all projects 
If you select several projects in a multiproject or the multiproject itself to 
display the settings dialog box, then an additional dialog box is 
displayed in advance. Use this dialog box to select a project template 
and then enter the TM settings in the next dialog box. The settings of 
this template are passed on to all projects included in the selection. 

Create/update block 
icons in all projects of a 
multiproject 

The menu command Options > Plant Hierarchy > Create/update block 
icons... is used to take into account all the pictures whose block icons are 
based on the PH, starting with the selected object (multiproject, project, 
hierarchy folder).  
In a multiproject, the path in the PH is the key for searching in other 
projects. PH structures with the same name are searched for in all projects 
of the multiproject. The CFC charts found there are included in the editing 
process. 
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Function Description 
Synchronizing 
Hierarchy Folders in 
the Multiproject 

When working in a multiproject, in some situations it is necessary to create 
redundant folders in parts of the plant hierarchy in all or individual projects 
of a multiproject.  
There are two applications: 
• In SIMATIC BATCH, the folder identified as "Process cell" is required in 

the first hierarchy level in all projects. 
• By using the same names in the plant hierarchy in the individual 

projects of the multiproject, AS and OS parts that belong together are 
detected when the functions "Create/Update Block Icons" and 
"Create/Update Diagnostic Screens" are executed. 

The plant hierarchy synchronization function in the multiproject allows you 
to save multiple configurations. This also protects the project from 
(accidental) changes that would result in differing names. You can start the 
synchronization function in either the process object view or the plant view 
by selecting the menu command Options > Plant Hierarchy > Synchronize 
in the Multiproject.... 

Renaming or Modifying 
Attributes of the 
Hierarchy Folder 

When attributes of a hierarchy folder are renamed or modified, a check is 
carried out to determine if the hierarchy folders derived from it exist in the 
other projects of the multiproject. If this is the case, they are renames and 
the attributes are set accordingly. 

Create/update 
diagnostics screens 

Use menu command Options > Plant Hierarchy > Create/update block 
icons to create or update diagnostics screens for a project or for the 
projects of a multiproject. Requirements: A diagnostics structure must have 
already been set up in the project. 

Additional information 
● Online help for PH, IEA and PO 
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8.5.13 Defining types in hierarchy folders on the basis of ISA-88 

Introduction 
You can assign attributes to the hierarchy folder in the PH in accordance with the ISA-88.01 
standard. This "ISA-88 type definition" is required, for example, for BATCH plants and 
applications at works management level (MES). 
You can use the object properties to change the hierarchy folder object type from "Neutral" 
to "Process cell," "Unit" or "Equipment module".  

Procedure 
1. Select the object whose settings you want to change in the PH. 
2. Select the menu command Edit > Object Properties 
3. Open the "ISA-88 Type Definition" tab. 
4. Change the object type for example from "<Neutral>" to "Process cell." 
5. Click "OK". 

Result 
When you create further folders, the folders in the two levels directly below are assigned the 
attributes for "Unit" and "Equipment module" according to their hierarchical level. 

Plant Hierarchy Structure 
The following figure shows the 3 hierarchy folders with the ISA-88 type definition. 
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Technological Significance of the PH 
 
Hierarchy folder Symbol Meaning 
Plant 

 
Within a project, only one process cell can currently be 
created.  

Unit Several units can be defined in one process cell.  

Equipment module 
(Phase)  

Several equipment modules such as a dosing or bottling 
machine can be defined in a unit. 

Neutral Folders 
The three-level hierarchy can be extended by adding neutral folders to improve the 
structuring of the project, for example, to divide units into groups. The neutral folders can be 
created at any level. The total number of possible levels (ISA-88 hierarchy levels, levels with 
neutral folders) is limited to eight. 
Neutral folders can, for example, be inserted above the "Unit" level. This level can then be 
used, for example, as the area level. A further level could, for example, be inserted below the 
"Equipment Module" level. This level can then serve as a control module level. 

Successor for the "Unit" Object Type 
A successor is the unit that executes the operations in a production process that were 
initiated by another unit (the predecessor). 
With the “Unit“ object type, a different unit from the same or another project can be selected 
as the "successor" to the unit. If this successor is in a different project, it is inserted in the 
current project as a hierarchy folder with a link. This is set on the "ISA-88 Type Definition" 
tab with the "Successor/Predecessor" button. 

Additional information 
● Online help for PH, IEA and PO 
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8.6 Creating the Master Data Library 

8.6.1 Introduction to the Master Data Library 

Advantages of a Library    
During configuration it is advantageous if all objects (blocks, charts, source files, process tag 
types, models, SFC types) used in the project are grouped in their own library. This means, 
for example, that you can be sure that only one version of a particular block type is used 
throughout the entire project. Different versions in different programs can lead to conflicts if 
the programs are to be controlled and monitored on one OS.  
Reason: block types of the same name in different programs, must have the same variable 
structures, since there is only one variable structure for a block type on the OS.  

Master data library 
When you use the PCS 7 Wizard to create a multiproject, a master data library is created 
automatically. The master data library is used for storage of the master data of the project for 
all projects of a multiproject. When you move projects from the multiproject to distributed 
engineering stations for editing, you must also transfer the master data library so that all 
configuration engineers have an identical database available.  
The master data library helps you to ensure that a defined version of types is reused. The 
master data library is automatically archived together with the multiproject. 
Both those objects used in projects and those objects specially adapted for the projects are 
stored in the master data library. This includes, for example, the following elements: 
● Block types 
● SFC types 
● Tag types 
● Models 
● Shared declarations 
● OS pictures 
● OS reports 
In addition, the following objects can be included in the master data library. 
● Object from the PCS 7 Advanced Process Library 
● Objects from libraries of suppliers 
● User-created objects 
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Maintaining the Master Data Library  
Plan your master data library maintenance strategy carefully. We recommend that you 
thoroughly test block types you create yourself or adapt to the needs of the project before 
you include them in the master data library. Subsequent changes (after generating block 
instances) are supported by the system, but involve more effort, due to central modification 
of the block type or recompilation of the OS. 

 

 Note 
Remember to update your master data library or SFC types if you have added blocks from 
the PCS 7 library and its version was later changed.  
The function "Update block types" is available for synchronizing the block types and SFC 
types. You can find information about this in the section "How to Update the Block and SFC 
Types (Page 321)". 

 

 Note 
The supplied libraries are always copied during PCS 7 installation. If you have edited 
supplied libraries, the libraries you have changed will be overwritten by the originals if you 
install again.  

 

Overview of Configuration Tasks 
 
What? Where? 
Creating the Master Data Library (Page 315) SIMATIC Manager 
Copying Objects to the Master Data Library 
(Page 319) 

SIMATIC Manager 

How to Adapt Blocks to Specific Projects 
(Page 323) 

SIMATIC Manager (component view) 

Creating Process Tag Types (Page 518) SIMATIC Manager (plant view) 
Creating models (Page 570) SIMATIC Manager (plant view) 
Testing the Library Objects (Page 341) CFC or SFC Editors 
Documenting the Library Objects (Page 341) In the relevant editors 
Hiding Libraries (Page 317) SIMATIC Manager 
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8.6.2 Objects in the Master Data Library 

Master Data Library Configuration     
The master data library contains different folders depending on the view in use: 

 

In the component view 
The master data library contains the following in the component view: 
● One S7 program with separate folders for blocks, sources and charts 
● A folder for shared declarations 
● The object symbol (symbol table) in the detail window 
Copy all the block types (technological blocks, driver blocks, communication blocks) required 
in the multiproject to the block folder of the master data library.  
This may be a collection from PCS 7 libraries, libraries of suppliers, or blocks you have 
written yourself. 
The blocks from the PCS 7 libraries are suitable for most situations encountered during 
configuration and can usually be used unchanged. If blocks need to be adapted for special 
requirements, you should make these adaptations early; in other words, before the blocks 
are used in the projects.  
SFC types are stored in the chart folder of the master data library.  
Note: SFC types can also be part of process tag types or models. 
The OS pictures and OS reports that are intended for use as templates, are copied to a 
hierarchy folder of the master data library after they have been tested in the project. At this 
time an OS is created in the master data library. It can be seen in the component view.  
Note: This OS is not part of the automation solution.  
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In the Plant View and Process Object View 
In the plant hierarchy (plant view or process object view), the master data library contains 
one folder each for process tag types and models. These two hierarchy folders each have an 
AS assignment to the S7 program and identifiers that identify them as hierarchy folders of a 
master data library. 

● Shared declarations  
You can define the following elements as shared declarations, which you can use in a 
variety of applications: 
– Enumerations 
– Units 
– Equipment Properties 

● Process tag types  
A process tag type is a CFC chart configured for basic automation of a process 
engineering plant that controls a specific system function, such as fill-level control. Copies 
can be made from this process tag type and adapted and then utilized according to 
specific automation tasks. The copy of a tag type is a process tag. 

● Models  
A model consists of additional hierarchy folders that contain the following elements: 
– CFC/SFC charts 
– OS pictures 
– OS reports 
– Additional documents 
Any number of replicas can be created from these elements by using the Import Export 
Assistant. 

● Templates  
The PCS 7 libraries (PCS 7 Advanced Process Library, Basic Library, PCS 7 Library) also 
contain templates for various technical functions. 
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Function of the Hierarchy Folders 
The hierarchy folders of the Master data library can be distinguished from the hierarchy 
folders of the project in the following ways: 
● The hierarchy folder will lose its identity as hierarchy folder of the master data library if the 

copy destination is not a master data library or if the same hierarchy folder is already 
located there. 
If a hierarchy folder its identity, its icon is changed to that of a normal hierarchy folder. 

● You cannot insert any new hierarchy folders with this identifier explicitly in the master 
data library. If the corresponding folder is no longer available when creating models and 
process tag types, it is automatically created in the master data library. 

● Hierarchy folders that lose their identifier can no longer be identified after they are 
returned to the master data library. 

Additional information 
● Online help for PH, IEA and PO 
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8.6.3 How to Create a Master Data Library 

Introduction 
If you have created your multiproject with the PCS 7 wizard, it already contains a master 
data library. SIMATIC Manager can be used in the following manner to define a master data 
library if you still do not have one in your multiproject: 
● Create a new library and define it as the master data library. 
● Define an existing library as the master data library. 

 

 
 

Note 
Each multiproject can only contain one master data library. The master data library can 
only contain one S7 program. 

 

Procedure 
Requirements: no library is defined as a master data library in the multiproject. If, however, a 
master data library is defined, the definition of an existing master data library must be 
reversed. This can be achieved by carrying out the second step under "Procedure". 
To create a new library as the master data library in your multiproject, proceed as follows:  
1. Select the menu command File > New in the SIMATIC Manager 
2. Open the "Libraries" tab and enter a name for the library (preferably the multiproject 

name). 
3. Enter the storage location (path), if necessary. 

The library is created and opened. 
4. Select the library in the multiproject in the component view and then the menu command 

File > Multiproject > Define as Master Data Library. 
The library is defined as a master data library. 

5. Select the library and then the menu command Insert > Program > S7 Program. 
An S7 program is created, including block and source folders. 

6. Add a chart folder below the S7 program with the menu command Insert > S7 Software > 
Chart Folder. 
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Result 
Your multiproject has a new master data library. The models or process tag types folders do 
not need to be set up explicitly in the plant hierarchy. These are automatically set up when 
models or process tag types are created.  

Naming 
 

 Note 
The SIMATIC Manager supports names longer than 8 characters. The name of the library 
directory is, however, limited to 8 characters. Library names must therefore differ from each 
other in the first 8 characters. The names are not case-sensitive.  
Please make sure that the name of the file always coincides with the name of the library 
originally set up. Name changes do not take effect at the file level in SIMATIC Manager. 

 



 Implementing the PCS 7 Configuration 
 8.6 Creating the Master Data Library 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 317 

8.6.4 How to work with libraries 

Introduction 
This section explains the most important functions when handling libraries. Become familiar 
with these functions prior to adding objects to the master data library from other libraries. 

Library functions 
In the SIMATIC Manager, you can use the following functions with libraries: 
● Open a library with the menu command File > Open > in the "Libraries" tab. 
● You can copy a library by saving it under a different name with the menu command File > 

Save As. 
● You can delete a library with the menu command File > Delete in the "Libraries" tab. 
● You can delete parts of libraries such as charts, blocks, and source files with the menu 

command Edit > Delete. 
● Libraries not in use can be hidden and then made visible again in the following manner: 

– Select the menu command File > Manage in the "Libraries" tab. 
– Select the desired library and click "Hide". 
The library can be made visible again with the "Display" button. 

 

 
 

Note 
We recommend that you hide all of the libraries except for the master data library since 
the master data library contains all the objects used in the project. 
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Creating a New Library 
1. Select the menu command File > New in the SIMATIC Manager 
2. Change to the "Libraries" tab and enter the name and the location for the library if 

necessary. 
3. Click "OK". 

Result 
A new library is set up in the multiproject. 

Naming 
 

 Note 
The SIMATIC Manager supports names longer than 8 characters. The name of the library 
directory is, however, limited to 8 characters. Library names must therefore differ from each 
other in the first 8 characters. The names are not case-sensitive.  
Please make sure that the name of the file always coincides with the name of the library 
originally set up. Name changes do not take effect at the file level in SIMATIC Manager. 
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8.6.5 How to Copy Objects from Other Libraries to the Master Data Library 

Introduction       
The following section describes how to enter objects from the supplied PCS 7 library or from 
libraries from other suppliers in the master data library. 

 

NOTICE  
Only the AS blocks of one PCS 7 library version can be loaded on a SIMATIC station at any 
one time. 

 

Procedure 
If you want to copy part of a library, for example, software, blocks, pictures etc., proceed as 
follows: 
1. Select the menu command File > Open in the SIMATIC Manager. 
2. Open the "Libraries" tab. 
3. Select the desired library and click "OK".  

The library opens. 
4. Select the object to be copied (for example, process tag type, blocks) in the open library 

(source) and then select the menu command Edit > Copy. 
5. Select the folder in the master data library (destination) where you want to store the 

copied object. 
6. Select Edit > Paste from the menu. 

Result 
The copied object is stored in the master data library. 
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Rules for Copying 
● If you want to copy the supplied process tag types from the PCS 7 Standard Library or 

PCS 7 Advanced Process Library to your master data library, select only the desired 
process tag types within the "Templates" folder, copy them and then paste them into the 
"Charts" folder of your master data library. 

● If you copy templates to your master data library, please note that they may overwrite any 
existing blocks which have been customized for the specific project. 

● If you copy blocks from different libraries, it is possible that blocks could have different 
names (and functions) but the same block numbers. In this case, a dialog box opens 
where you can rename the block or synchronize the attributes. 

 

 
 

Note 
Simultaneous use of the libraries "Standard Library" (STEP 7), "CFC Library" (ES/CFC), 
"PCS 7 Library": 
The libraries of STEP 7, ES/CFC, and PCS 7 contain blocks with the same name (but 
with different functions) as well as blocks with the same number (but with different 
functions). 
• Same block name - CONT_C/CONT_S/PULSGEN/CTU/CTD/CTUD 

For these blocks, please use the blocks from the CFC Library, since these are better 
adapted to the PCS 7 environment. 

• Same block number 
Solution: The blocks must be assigned free FB/FC numbers in the block folder. 
– For: FC 61 ...125 in the libraries "Standard Library - S5-S7 Converting Blocks" and 

"Standard Library - TI-S7 Converting Blocks" and "CFC Library ELEMENTA" 
– For: FC 1 ... FC 40 in the libraries "Standard Library - Communication Blocks", 

"Standard Library - IEC Function Blocks" and the reserved FC inventory in CFC. 
 

● The symbolic name is also copied when blocks from a library are copied. 
● When copying into the block folder, the "Insert Function Block" dialog box opens if the 

system detects that the system attributes of a block you want to insert into the chart from 
a library differ from those of the exiting block. You can perform an attribute update here 
(see also the online help for STEP 7). 

Rules for Multiple Instance Blocks 
● If blocks contain code used for accessing other blocks (multiple instance blocks), the 

applicable version of these lower-level blocks must also be copied. Lower-level FBs that 
are missing can be determined later by engineering. Missing FCs, however, cannot be 
detected during compiling or downloading. 

 

 
 

Note 
Remember that the CPU may switch to STOP if FCs are missing. 

 

● Remember that the block numbers used to access the blocks are stored in the code of 
the multiple instance block. These numbers (and in turn, the code) can be changed by 
using the menu command Options > Rewire...., which provides access to the rewiring 
function in the SIMATIC Manager. Exception: with protected blocks. 
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8.6.6 How to Update Block and SFC Types 

Introduction        
After including a new version of a block type or SFC type in the master data library or after 
adapting a block type in the master data library, you can use the "Update block types" 
function to list all components in which an older version of the modified block type or SFC 
type is used. You can also select the components in which the modified block type or SFC 
type should be updated throughout the entire multiproject. 
The blocks of the templates (process tag types, models) are also updated. 
If differences are found at SFC types, you can call up the Version Cross Manager (VXM) by 
using the "Display differences" command button before carrying out updating, if the VXM 
optional package is installed. The VXM displays the detailed differences of the compared 
SFC types. 

Procedure 
1. Select one or more blocks in the block folder of the master data library or one or more 

SFC types in the chart folder or the chart folder. 
2. Select the menu command Options > Charts > Update Block Types....  

The "Update Block Types" dialog box opens. 
3. Select the S7 programs to be checked for differences compared with the block types/SFC 

types selected in the master data library. 
4. Click "Continue". 

All the selected S7 programs are checked and a further dialog box for selecting the 
block/SFC types is opened. Here you also obtain information about the possible effects of 
updating the block/SFC types. 

5. Specify the block/SFC types to be updated for the individual S7 programs: All the 
block/SFC types to be updated are selected. If necessary, you can deselect any types 
which are not being updated. 
If there are no block/SFC types to be updated, no block/SFC types are displayed. In this 
case, close the dialog box. 

6. Click "Finish". 
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Result 
The block/SFC types are updated in all the selected S7 programs and a log is displayed. 

 

 Note 
An update is required after changing blocks. Make the changes to the blocks only in the 
master data library. 

 

Additional information 
● Online help on the dialog boxes 
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8.6.7 Adapting the Blocks 

8.6.7.1 How to Adapt Blocks to Specific Projects 

Introduction       
The blocks from the PCS 7 libraries are suitable for most situations encountered during 
configuration and can usually be used unchanged. If blocks must be adapted for a specific 
project and for special requirements, adapt the blocks before using them in the projects and 
then store them in the master data library. 

Overview of Configuration Tasks 
The following block properties and attributes can be adapted: 
 
What? Where? 
Changing the Attributes of the Block I/Os 
(Page 324) 

LAD/CSF/STL Editor 

Locking Message Attributes Against Changes at 
Block Instances (Page 326) 

PCS 7 message configuration 

Translating Message Texts (Page 327) SIMATIC Manager 
Setting the Language for Display Devices 
(Page 328) 

SIMATIC Manager 

Exporting/importing operator and display texts 
(Page 330) 

SIMATIC Manager 

 
 

 Note 
You may only adapt the blocks to the project requirements in the library. We also assume 
that you are adapting the blocks in the master data library. 
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8.6.7.2 How to Modify Attributes of the Block I/Os 

Introduction 
The block I/Os of the block types have attributes that you can adapt to the project 
requirements. 

Procedure 
1. Select the block to be modified in the block folder of the master data library. 
2. Select the menu command Edit > Open Object.  

The LAD/STL/FBD editor is launched (if the block is protected, you will receive a 
message). If you select an object in the tree of the interface, its content is displayed. 

3. In the right-hand window, select the desired I/O followed by the menu command Edit > 
Object Properties. 
The "Properties" dialog box opens. 

4. Select the "Attributes" tab 
The attributes are displayed in the form of a table. 

5. Modify the attributes and their values in this table, or enter them again. 
If you click the "Attribute" column, a selection of the possible attributes for this I/O appear 
in a drop-down list. 

Modifying attributes is not difficult since there is a syntax check when the attributes are 
entered and you will be informed of errors or missing information. 

 

 Note 
Information regarding the use of attributes and their description can be found in the online 
help for the LAD/STL/FBD editors. 

 

Please Take Note of the Following Special Situations 
● Configure the texts for the attributes "S7_string_0", "S7_string_1", "S7_unit" and 

"S7_shortcut" in the language that will be used by the operator on the OS. If you would 
like to have these texts available on the OS in additional languages, they must be 
translated in the WinCC text lexicon. 

● The "S7_enum" attribute can be used to assign an enumeration to a block parameter. In 
addition, an "enumeration" data type with the name selected by the user is set up in the 
ES. In addition, a data type parameter "BOOL," "BYTE," "INT," "DINT," "WORD," or 
"DWORD" is created for the block parameters that use the enumeration. This parameter 
is given the "S7_enum" system attribute. The ES defined "enumeration" name is used as 
the value. The "enumeration" names can be configured in several different languages. 

● If you modify attributes that are synchronized with the faceplates or the block structure on 
the OS (for example, S7_m_c), errors may occur when you interconnect the faceplates or 
when you compile the OS. 
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● The attributes can be distinguished in the following manner: 
– Attributes with a "type character"  

The property refers to the block type. Changes made to these attributes (for example, 
S7_link) will also apply to all existing block instances. 

– Attributes with an "instance character"  
The property refers to the individual instance. Changes made to these attributes (for 
example, S7_visible) will not retroactively affect existing block instances but simply 
function as the default option. 
Exception: The attributes "S7_string_0", "S7_string_1", "S7_unit" and "S7_shortcut" 
modifications are adopted by the CFC if the user has not changed the value in the 
block instance. 

● Read back the parameters from the CPU  
In the read back dialog box, you can set the parameters to be read back: 
– all (S7_read_back = true; default) 
– can be controlled and monitored (S7_m_c := 'true') 
– marked parameters (S7_read_back := 'true') 
– none 

The block is excluded completely from read back 
(S7_read_back = false). 

You can find information about this in the section "How to Download to All CPUs 
(Page 668)".  
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8.6.7.3 How to Lock Message Attributes Against Changes at Block Instances 

Message Texts and Message Attributes 
Messages are important for the operator when controlling the process. With the aid of 
messages, you can monitor and evaluate the process. Message texts and message classes 
are preset in the block types in the PCS 7 libraries. Messages, for example, are "Actual 
value too high", "External error", "Overdosing". These messages are sent by the automation 
system when the corresponding event occurs.  
You have the opportunity to adapt these message texts and their attributes to your particular 
needs: The message texts can be adapted in the block type or also in the block instance. If 
you want to avoid message attributes being modified in the block instances, you can lock the 
instances. 

Procedure  
1. Select the block to be modified in the block folder of the master data library. 
2. Select the command Special Object Properties > Message... in the shortcut menu. 

The "Message Configuration" dialog box opens. This displays all the messages 
configured for this block. 

3. Place a check mark in the column  behind the text that you wish to lock. 
4. Click "OK" to apply the changes. 

Result 
The text is locked. 

 

 Note 
If block instances already exist, the locking of the message attribute can be passed on to the 
instances by repeating the block import. 

 

Additional information 
● For more detailed information on adapting operator and message texts, refer to the 

Configuration Manual Process Control System PCS 7; Operator Station. 
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8.6.7.4 How to Compile Message Texts 

Multilingual Message Texts 
You can enter message texts in more than one language. The PCS 7 library blocks already 
have prepared message texts in German, English and French, Italian and Spanish. 
If you require a language that is not currently available for the message texts of blocks, you 
can set the language and translate the texts. 

Procedure Used for the Block Type Example 
1. In the SIMATIC Manager, select the menu command Options > Language for Display 

Devices.... 
2. From the list of "Available Languages", select the language to be displayed on the OS. 

Click " -> " to transfer the selected language to the list of "Languages Installed in the 
Project". 

3. Select the language from the "Languages installed in the project" group that you want to 
set as the standard language and then click "As standard". 

4. Click "OK". 

Additional information 
● Configuration manual Process Control System PCS 7; Operator Station 



Implementing the PCS 7 Configuration  
8.6 Creating the Master Data Library 

 Engineering System (V7.1) 
328 Configuration Manual, 03/2009, A5E02122455-01 

8.6.7.5 How to Set the Language for Display Devices 

Language for Display Devices 
The language for display devices is relevant for transferring messages from the ES to the 
OS (Compile OS). If you have not selected the required language, the message texts are 
transferred to the wrong column in the text library and do not appear in process mode. 

Procedure 
1. In the SIMATIC Manager, select the menu command Options > Language for Display 

Devices.... 
2. Set the language for the PCS 7 blocks, for example, "German (Germany)". 
3. Select the language from the "Languages installed in the project" list that you want to 

define as the standard and then click "Standard". 
4. Click "OK". 
For your project, you can select several languages from the list of available languages and 
define one of them as standard. 

Additional information 
● Configuration manual Process Control System PCS 7; Operator Station 
● Online help for the dialog box 

8.6.7.6 How to Create your own Blocks for the Master Data Library 

Creating Your Own Blocks 
You can create PCS 7-compliant AS blocks or faceplates yourself and store them in the 
master data library. 
You will find information on creating your own blocks in the manual Process Control System 
PCS 7; Programming Instructions Blocks. 
Here you will find a description on how to store your own blocks in a library and how they 
can be installed on the target computer with setup for inclusion in the master data library. 
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8.6.7.7 Using Faceplates and Block Icons for OS Pictures 

Faceplates and Block Icons 
Controlling and monitoring a block instance in process mode on the OS requires the 
corresponding faceplate. The faceplate contains the graphic representation of all elements of 
the technological block intended for operator control and monitoring. The faceplate is 
depicted in a separate window in the OS and is opened via a block icon (typically placed in 
the OS overview display). 
For each technological block type of the PCS 7 Library there is already a corresponding 
faceplate. Block icons are generated automatically following a menu command. You can also 
create or adapt faceplates and block icons yourself.  
Several block icons can be created in a process picture for each block type in order to depict 
specific variants of a type. 

 

 Note 
In CFC, you can assign the block icons to specific instances in the object properties of the 
blocks. 

 

Faceplates for Block Types of the PCS 7 Library 
The display and operator input options of the faceplates for the block types of the PCS 7 
library are described in the Manual Process Control System PCS 7 Library. 

Creating Your Own Faceplates 
You will find step-by-step instructions on creating custom faceplates in the manual Process 
Control System PCS 7; Programming Instructions Blocks. 

Creating Your Own Block Icons 
You can find information on generating and adapting block icons in the configuration manual 
Process Control System PCS 7; Operator Station. 

Additional information 
● Configuration manual Process Control System PCS 7; Operator Station 
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8.6.7.8 How to Import/Export Blocks, I/Os and Messages 

Introduction 
The entire content of a table can be exported from the process object view for the external 
assignment of modified parameter values and interconnections to a copied unit. You can 
then import the modified data again. This method can be used as an alternative to the 
Import/Export Assistant. 

Import/Export of Parameters, Signals, and Messages 
To visualize the process in process mode, use the faceplates that show the plant operator 
measured values, operating limits, unit of measure, and block operator texts.  
Proceed as follows in the process object view when making centralized changes to the 
parameters, signals, and messages of the faceplates: 
● Export the contents of the table to a file. 
● Edit the texts using standard applications (MS Excel, MS Access), 
● Import the modified texts. 
All the editable fields for parameters, signals, and messages in the process object view are 
imported/exported. The charts in the selected and all lower-level hierarchy folders are taken 
into account (according to the selection in the process object view). 
After export, you receive a message indicating the CSV file and the path where the data 
were stored. Here, the cells contents are displayed in double quotes separated by a 
semicolons so that they can be edited with MS Excel or MS Access. 

 

 Note 
The instances are edited during import/export procedure described above. The ability to 
make centralized changes is lost. 

 

Exporting the current view 
From the process object view, you can also export any assembled view that contains the 
filter and display settings. This can then be processed further in other tools for 
documentation purposes, for example. 
The export file contains all of the columns and visible fields from the current view, including 
the corresponding column titles. 
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Languages 
PCS 7 can be used to store all operating and display texts in any language. The only 
requirement is that the language is already installed in your project. 
The available languages can be displayed in the SIMATIC Manager with the menu command 
Options > Language for Display Devices. The number of languages offered is specified 
when Windows is installed (system characteristics).  

Structure of the Export and Import File for Blocks 
The export file and the import file for blocks consists of the following 10 columns: 

 
Columns Column Titles Meaning 
1 - 3 Hierarchy; Chart; Block; Identification of the block 
4 - 9 Block comment; Create block symbol; Block 

symbol;Operating and monitoring property;Reading 
back allowed; Block group 

Attributes that are exported/imported 

10 Block type Information about the block 

Structure of the Export and Import File for I/Os 
The export file and the import file for I/Os consists of the following 19 columns: 

 
Columns Column Titles Meaning 
1 - 4 Hierarchy; Chart; Block; I/O; Identification of the I/O 
5 - 15 Block comment; I/O comment; Value; Unit; 

Interconnection; Signal; Identifier; Text 0; Text 1; 
Watched; Enumeration 

Attributes that are exported/imported 

16 - 19 Data type; I/O; Block type; I/O type. Information on the I/O 

Rules for the Export and Import File for I/Os 
● The CSV file for importing I/Os must include at least the first four columns for 

identification of the I/O. The remaining columns are optional and can be used in any 
order. 

● The columns with information on the I/O are ignored when importing. 
● Empty text fields (cells) are ignored when importing. Therefore you can only create or 

modify texts during importing but not delete them. 
● If several I/Os are listed for a block resulting in several rows for the block, then the block 

comment will appear a corresponding number of times. If you modify the comment, only 
the last line of the block comment will be considered during import. 
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Structure of the Export and Import File for Messages 
The export file and the import file for messages consists of the following 20 columns: 

 
Columns Column Titles Meaning 
1 - 5 Hierarchy; Chart; Chart comment; Block; I/O; 

Subnumber; 
Identification of the I/O 

6 - 19 Block comment; Class; Priority; Origin; OS area; Event; 
Batch ID; Operator input; Free text 1; Free text 2; Free 
text 3; Free text 4; Free text 5; Info text; 

Attributes that are exported/imported 

20 Block type Information on the I/O 

Rules for the Export and Import File for Messages 
● The CSV file for importing message texts must include at least the first five columns for 

identification of the I/O. The remaining columns are optional and can be used in any 
order. 

● Empty text fields (cells) are ignored when importing. Therefore you can only create or 
modify texts during importing but not delete them. 

Exporting the current view 
1. Set the required view (select the tab, followed by Filter and Display). 
2. Select the menu command Options > Process Objects > Export Current View.... 
An export file (CSV file) is generated; this contains all the selected information about the 
object (project, hierarchy folder, or CFC chart) that has been selected in the tree. 

Exporting Blocks 
1. Select the menu command Options > Process Objects > Export Blocks 
An export file (CSV file) is created that contains all the attributes and information about the 
blocks of the object (project, hierarchy folder or CFC chart) selected in the tree window.  

Exporting I/Os 
1. Select the menu command Options > Process Objects > Export I/Os.... 
An export file (CSV file) is generated containing all the attributes of the selected I/Os and 
information about the I/Os of the object (project, hierarchy folder, or CFC chart) selected in 
the tree.  
The information from the process object view ("Parameters" and "Signals" without filters) 
including the titles is written.  
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Exporting All the I/Os 
1. Select the menu command Options > Process Objects > Export All I/Os.... 
An export file (CSV file) is generated containing all the attributes and information about all 
the I/Os of the object (project, hierarchy folder, or CFC chart) selected in the tree.  
All I/Os means that it also takes account of I/Os which have not been selected for the 
process object view. 
The information from the process object view ("Parameters" and "Signals" without filters) 
including the titles is written.  

Exporting Messages 
1. Select the menu command Options > Process Objects > Export Messages.... 
An export file (CSV file) is generated containing all the message texts (and block 
information) concerning the object (project, hierarchy folder, or CFC chart) selected in the 
tree. 

Additional Editing 
 

NOTICE  
Never overwrite management information (language identification or path specifications) 
while editing the exported texts. 
Only edit lines beginning with "T-ID=". 

 

NOTICE  
Always open the file inside of the program, for example, when using MS Excel with the 
menu command File > Open and not by double clicking the file. 
Never edit the first column or the first row with the spreadsheet editing tool and do not 
delete any semicolons. 

 

Backup Export before Starting the Import 
Before you import, a dialog box is displayed in which you can check the import file (name 
and content). Here, you can also set the "Execute backup export" option. 
Use the option "Execute backup export" to backup the current project data (attributes) before 
starting the import. 

Importing Blocks 
1. Select the menu command Options > Process Objects > Import Blocks.... 
2. Select the required import file (CSV file). 
The attributes and information of the blocks of the selected import file are imported into the 
desired project. They are assigned to the blocks. 
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Importing block texts 
1. Select the menu command Options > Process Objects > Import Block Texts.... 
2. Select the required import file (CSV file). 
The block texts of all the CFCs within the selected import file are imported into the desired 
project. In doing this, you assign the texts to the blocks of the named process tags 
(hierarchy, chart, block, I/O). 

Importing I/Os 
1. Select the menu command Options > Process Objects > Import I/Os.... 
2. Select the required import file (CSV file). 
The I/O attributes and information of the selected import file are imported into the desired 
project. They are assigned to the I/Os of the designated process tags (hierarchy, chart, 
block, I/O). 

Importing I/O texts 
1. Select the menu command Options > Process Objects > Import I/O Texts.... 
2. Select the required import file (CSV file). 
The texts of all the I/Os for all the CFCs within the selected import file are imported into the 
desired project. In doing this, you assign the texts to the I/Os of the named process tags 
(hierarchy, chart, block, I/O). 

Importing Messages 
1. Select the menu command Options > Process Objects > Import Messages.... 
2. Select the required import file (CSV file). 
The message texts of the selected import file are imported into the desired project. They are 
assigned to the blocks of the designated process tags (hierarchy, chart, block). 

Additional information 
● Configuration manual Process Control System PCS 7; Operator Station 
● Online help on the dialog boxes 
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8.6.8 Working with process tag types 

Introduction 
Process tag types are installed automatically in the "Process Tag Types" folder in the master 
data library as soon as a new process tag type is generated from a CFC chart. The process 
tag types are managed in the master data library. The following functions are available: 

Overview of the Functions 
Below you will find an overview of the functions that are important when working with 
process tags/process tag types. 
These functions are available in the SIMATIC Manager using the menu command Options > 
Process Tags, when a chart or a process tag type is selected. 
 
Function Purpose 
Creating/Changing 
Process Tag Type 

• Creating a process tag type from CFC charts 
– You select the I/Os of blocks and charts that are to be assigned 

parameter descriptions and signals. 
– You select blocks with messages for the assignment of message texts. 

• Changing an existing process tag type 
• Check the existing process tags for deviations compared to the process 

tag type and to synchronize any differences. 

Synchronize When a process tag type is modified, the process tags existing in the project 
are automatically synchronized.  
Synchronization can be carried out directly if inconsistencies between the 
process tag type and the process tags (for example: not all of the process 
tags of a project were accessible during the synchronization process) exist. 

Assigning/creating 
an import file 

To generate process tags, an import file must be assigned to the relevant 
process tag type. Use the wizard "Assigning an import file to a process tag 
type" to carry out the following:  
• Assign an existing import file 
• Open and check an import file that has already been assigned 
• Create and assign a new import file 

Importing Import of the data of the process tag types 
The process tag type is copied from the master data library to the specified 
target projects as a process tag. Thereafter the data is imported. The same 
number of process tags are generated as there are entries in the import file. 
As a result of the import, a process tag of this process tag type is created in 
the target project for every row of the import file according to the specified 
hierarchy path. 

Exporting Export of the data of the process tags for a process tag type 
The following options are available:  
• Selecting one process tag to export it individually. 
• Select an upper-level hierarchy folder or the project node in order to select 

all lower-level process tags for export. 
As the result, a row is created in the relevant export file for each process tag 
of a process tag type found. 
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Additional information 
● Section "How to Create a Process Tag Type from a CFC Chart (Page 518)" 
● Section "How to Modify a Process Tag Type (Page 520)" 
● Section "How to Synchronize Process Tags with the Process Tag Type (Page 529)" 
● Section "What Happens during Import? (Page 637)" 
● Section "What Happens during Export? (Page 642)" 
● Online help for PH, IEA and PO 
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8.6.9 Working with Models 

Introduction     
Models are created from the hierarchy folders in the master data library that contain the 
required CFC charts. The new models are stored and managed in the master data library. 
The following functions are available: 

Overview of the Functions 
Below you will find an overview of the functions that are important when working with 
models/replicas. 
These functions are available in the SIMATIC Manager with the menu command Options > 
Models. 
 
Function Purpose 
Creating/Modifying 
Models 

You can create models with the Import/Export Assistant (IEA) as follows: 
• You select the I/Os of blocks and charts that are to be assigned parameter 

descriptions and signals and imported. 
• You select blocks with messages for the assignment of message texts. 
• You assign the import file to model data. 
You obtain a model in which the selected I/Os and messages are each 
assigned to a column of an import file. 
If you modify an existing model and change the column structure or the 
column titles, the assignment to the structure of the current IEA file is no 
longer correct. In this case you must select a suitable IEA file or adapt the file. 
If replicas of the modified model exist then modifications can be carried out on 
the replicas. 

Importing Importing of the data of the models 
The model is copied from the master data library to the specified target 
projects as a replica. Thereafter the data is imported. The same number of 
replicas are generated as there are entries in the import file.  
As a result of the import, a replica of this model is created in the destination 
project for each row of the import file, according to the information in the 
hierarchy path . 

Exporting Exporting of the replica data for a model 
The following options are available:  
• Selecting one model to export it individually. 
• Selecting an upper-level hierarchy folder or the project node in order to 

select all lower-level replicas for export. 
As the result, one row is created in the relevant export file for each replica of a 
model found. 
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Additional information 
● Section "How to Create a Model (Page 570)" 
● Section "What Happens during Import? (Page 637)" 
● Section "What Happens during Export? (Page 642)" 
● Online help for PH, IEA and PO 
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8.6.10 How to Store Shared Declarations 

Introduction 
If you have created your multiproject with the PCS 7 wizards, the master data library already 
contains a "Shared Declarations" folder. You can then use this to store shared declarations 
that can be used by various applications. You can explicitly create the "Shared Declarations" 
folder if it does not yet exist. 
The "Shared Declarations" folder contains the following subfolders: 
● Enumerations 
● Units 
● Equipment Properties 

Shared declarations 
You can define the following elements as shared declarations: 
● Enumerations 

Using the enumerations, you can define textual representatives for the parameter values 
of the block or chart I/Os with data types "BOOL," "BYTE," "INT," "DINT," "WORD," and 
"DWORD". A suitable text is assigned to each value of an enumeration and this is 
displayed at the I/O. Several values can be assigned to each enumeration. 

● Units 
The unit of measure (for example, mbar, l/h, kg, etc.) is a text with a maximum of 16 
characters. It can be entered during the parameter and interconnection descriptions of 
block or chart I/Os. It is used for example, in process pictures when visualizing the values 
of the block I/Os. All the units of measure included in the CFC basic set are available as 
defaults. 

● Equipment properties 
Equipment properties are parameters of a unit, such as shell material, volumes etc.. The 
type of equipment property is defined as a "shared declaration". Instances of this type are 
used in SIMATIC BATCH and its attributes are individually adapted. 

Procedure 
1. Select the master data library of the multiproject. 
2. Select the menu command Insert > Shared Declarations > Shared Declarations. 

The "Shared Declarations" folder is created with the subfolders "Enumerations", "Units" 
and "Equipment Properties". 

3. When declaring an enumeration, select the "Enumerations" folder and then the menu 
command Insert > Shared declarations > Enumeration followed by the menu command 
Insert > Shared declarations > Value. 

4. When declaring a unit, select the "Units" folder and then the menu command Insert > 
Shared Declarations > Unit. 

5. If you want to declare an equipment property, mark the "Equipment Properties" folder and 
select the menu command Insert > Shared Declarations > Equipment Property. 
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Additional Functions in a Multiproject 
The shared declarations function is tailored to the needs of the multiproject. The following 
update functions are important for multiprojects: 
 
Menu Command Purpose 
Options > Shared Declarations > 
Update in Multiproject 

You can select the following update methods here: 
• Merge the shared declarations of all projects in the 

multiproject 
• Export the shared declarations of one project in other 

projects 

Options > Shared Declarations > 
Display Full Log 

This opens the full log listing all errors that occurred in the most 
recent synchronization of the shared declarations in the 
multiproject. 
No log is generated if no errors occurred in the most recent 
update of all projects. 

Options > Shared Declarations > 
Check Plausibility 

This checks the values of the enumerations for uniqueness. 

Options > Shared Declarations > 
Display Full Log Plausibility Check 

This opens the full log for the plausibility check of the shared 
declarations. Here, you will see a list of the projects in the 
multiproject where errors or warnings were detected. A log has 
been created for each listed project. You can open the log file by 
selecting the project and then the menu command Shared 
Declarations > Logs.... 

Additional information 
● Online help for the SIMATIC Manager 
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8.6.11 How to Test Library Objects 

Testing Library Objects       
We recommend that you thoroughly test objects before storing them in the master data 
library. Use the functions for compiling, downloading testing of the tool in which you created 
the respective object for testing.  
Store the objects in the master data library after successfully testing them.  
After the test declare the process tag and model as a process tag type or as a model. These 
objects are then automatically stored in the master data library. 

Requirement  
The AS must be accessible from the engineering station since the test is always executed in 
the AS. Test the corresponding OS pictures in the OS if the models contain OS pictures. 

Additional information 
● Online help of the relevant tools (for example, CFC Editor) 

8.6.12 How to document library objects 

Documenting Library Objects      
Use the documenting and printing functions (e.g. the CFC Editor functions or the functions in 
the LAD/STL/FBD editors) in the tool used to create the library objects if you would like to 
document library objects.  

Additional information 
● Online help of the relevant tools (for example, CFC Editor) 
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8.7 Distributing the Multiproject for Distributed Editing (Multiproject 
Engineering) 

8.7.1 Introduction to Distributing the Multiproject (Multiproject Engineering) 

Note to Reader       
Pay attention to the following sections if you now want to edit the multiproject (including the 
master data library) on distributed stations and with several editors at the same time. 
If you do not want to distribute the multiproject for editing, you can skip the following sections 
and continue with the section "Configuring the Hardware". 

Introduction 
It is possible to edit the projects of the multiproject on distributed stations allowing several 
editors to work on smaller handier projects at the same time. 
The distributed editing of projects and the merging on a central engineering station server for 
cross-project functions is the most efficient method compared with other procedures. 
Despite distributing the projects on several engineering stations, it is possible to read other 
projects at any time. This can, for example, be used to copy functions and to access 
libraries. 

 

 Note 
You should always work with a multiproject even if it only contains one project. In this case, 
you do not need to distribute it for editing. 
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Requirements 
If you want to distribute projects on different computers within a network, the following 
conditions must always be met:  
● The projects are located in folders that are shared for read and write access. 

– The folders in which the multiproject or the projects are to be located must be set for 
sharing before the multiproject is set up. 

– The share names must be unique within the network. 
– The shares and share names of the resources (folders) involved in the multiproject 

must not be changed.  
Reason: when a project is inserted into the multiproject, PCS 7 generates a reference 
to the location of this project. The reference depends on the share and share names 
of the resources involved. 

– A project can only be found using the share name under which it was included in the 
multiproject. 

– For security reasons complete drives should not be shared. 
– Folders must only be shared in one hierarchy level. 

● PCS 7 must be installed on the computers where the folders containing the projects are 
located. PCS 7 provides the necessary database server functions for accessing the 
projects. 

● If you include projects for which you have configured messages in a multiproject, make 
sure that the message number ranges of the CPUs do not overlap if you are using 
project-oriented assignment of message numbers. If you use CPU-oriented message 
number assignment, such overlapping does not occur. 

If you execute cross-project functions, we recommend consolidating all projects on one 
programming device/personal computer. 
If you want to execute cross-project functions while the projects are distributed on different 
computers then comply with the following:  
● All the computers on which the projects and the multiproject are located can be reached 

over the network during the entire editing time. 
● While class-project functions are executing, no editing must take place. 
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Recommendations 
We recommend the following procedure when working with multiprojects: 
● One engineer manages the multiproject centrally. This engineer creates the structures for 

the projects. This person also distributes the projects for distributed editing and returns 
them again to the multiproject (including synchronization of the cross-project data and 
execution of cross-project functions). 
The following activities should only be performed on the central engineering station: 
– Moving, copying, and deleting the projects of the multiproject 
– Moving projects out of the multiproject for distributed editing 
– Merging of the projects into the multiproject following distributed editing 

● It is not possible to make a general recommendation about how many stations a project 
should have. We recommend that projects on a distributed engineering station have only 
one 1 AS or 1 OS. 

● Only move the PCS 7 objects to a distributed engineering station that are actually 
necessary for editing. This means that all other objects of the multiproject are available 
for editing on other distributed engineering stations. 

● Keep in mind the number of available project editors when distributing the projects. 
 

 
 

Note 
If there is only one OS in the project, this must always be recompiled on the central 
engineering station. This ensures the correct structure of the cross-project connections to 
the automation systems. 

 

Rules for Multiproject Engineering with SIMATIC BATCH 
 

CAUTION  
For multiproject engineering with SIMATIC BATCH, distributed engineering on distributed 
engineering stations including testing is only possible when certain conditions are met and 
the additional steps are taken.  
You will find additional information on this topic on the Internet 
(http://support.automation.siemens.com/WW/view/en/23785345). 

 

Additional information 
● Section "Conditions for Additional Editing in the Multiproject (Page 345)". 

http://support.automation.siemens.com/WW/view/en/23785345
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8.7.2 Conditions for Additional Editing in the Multiproject 

Boundary conditions     
Observe the following conditions when working in the multiproject: 
● Network operation is only possible if an operating system is installed on the central 

engineering station in accordance with the requirements of the "pcs7 readme.rtf" file 
(Section: "Operating System Selection"). 
The same applies to distributed engineering stations. 

● The storage location of projects within the network must be specified in UNC notation: 
\\computername\sharename\storagepath  
not designated with the letter of the drive (not "d:\projects\storagepath..."). 

● The folder with the project must already be shared with other project editors on the 
relevant PC. The share name must be unique. 

● The storage paths must not be modified later (after storing projects)! 
● All the projects and the S7 programs must have unique names within the multiproject. 
● After distributed editing of projects containing an OS, each OS must be recompiled on the 

central engineering station. To speed up compilation, unmodified objects can be 
deactivated in the "Compile and Download Objects" dialog box (menu command in the 
SIMATIC Manager PLC > Compile and Download Objects). 

● A mixture of the previous project-oriented and the new CPU-oriented message number 
concept is not possible. 

Rules for multiproject Engineering with SIMATIC BATCH 
 

CAUTION  
For multiproject engineering with SIMATIC BATCH, distributed engineering on distributed 
engineering stations including testing is only possible when certain conditions are met and 
the additional steps are taken.  
You will find additional information on this topic on the Internet 
(http://support.automation.siemens.com/WW/view/en/23785345). 

 

Additional information 
● Section "Merging projects after distributed editing (multiproject engineering) (Page 621)" 
● Section "Introduction to Compiling and Downloading (Page 665)" 
● Online help on STEP 7 

http://support.automation.siemens.com/WW/view/en/23785345
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8.7.3 Overview of the Steps 

Prior to Distribution 
There is no particular point in time at which the projects should be moved to the distributed 
engineering stations. The "Must/Optional" columns in the following table indicate which tasks 
must be performed and which can be performed prior to distribution.  
The description for executing the configuration is structured according to this series of steps.  
 
Activity Information in the section Must Optional 

Creating the PCS 7 Project  X  
Configuring the SIMATIC and PC Stations  X 
Creating the Plant Hierarchy X  

Create the 
multiproject with (all) 
projects (structure) 

Creating the Master Data Library X  
Configuring the Hardware  X 
Creating the Network Connections  X 

Creating the Basic 
Configuration for all 
the Projects of the 
Multiproject Creating the SIMATIC Connections  X 

Distribution -> Distributed Editing -> Merging 
The following list of steps also reflects the recommended order in which the activities should 
be performed. 
 
Activity Information in the Section Where? 
Move projects to 
distributed 
engineering stations 
for distributed editing 

How to Move Projects to Distributed 
Engineering Stations (Page 348) 

Central Engineering station: 
SIMATIC Manager 

Edit projects on 
distributed stations 

How to Continue Editing Projects on 
Distributed Stations (Page 350) 

Distributed engineering 
station 

Merge projects on 
the central 
engineering station 

How to Move Projects Edited on Distributed 
Stations to the Central Engineering Station 
(Page 622) 

Central Engineering station: 
SIMATIC Manager 

Prior to Distribution or after Merging 
Must/Optional indicates whether the activity must or can be performed after distributing. 
 
Activity Information in Section Must Optional 
Executing cross-
project functions 

How to Merge Subnets from Different Projects 
into a Multiproject (Page 624) 
Cross-project Connections in a Multiproject 
(Page 453) 

X 
 
X 

 

Compile/download 
configuration data 

Compiling and downloading (Page 665) X  
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8.7.4 How to Store the Projects in the Multiproject 

Requirements 
● The multiproject is located on a central engineering station to which all other engineering 

stations have access. 
● The multiproject contains the libraries (in particular the master data library with the 

models and process tag types). 

Storing the Projects 
Projects which are to be inserted into the multiproject can be created in the following 
manner: 
● Create projects on the central engineering station and then move them to the distributed 

engineering stations for editing 
You can find information about this in the section "How to Move Projects to Distributed 
Engineering Stations (Page 348)" 

● Create projects on the distributed engineering stations (including the hardware 
configuration) and insert them in the multiproject later on 
You can find information about this in the section "How to Move Projects Edited on 
Distributed Stations to the Central Engineering Station (Page 622)" 

Procedure 
1. Specify the storage location for your projects. Create the required folder structure with the 

Windows Explorer.  
Refer to the details in the sections "Distributing the Multiproject for Distributed Editing 
(Multiproject Engineering) (Page 342)" and "Conditions for Additional Editing in the 
Multiproject (Page 345)". 

2. In the SIMATIC Manager, select the menu command Options > Customize and set the 
storage location of the projects, multiprojects, and libraries. Comply with the DOS name 
conventions. 

Additional information 
● Online help for the SIMATIC Manager 
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8.7.5 How to Move Projects to Distributed Engineering Stations 

Requirements 
● The project is physically located on the central engineering station and is included in the 

multiproject. 
● The distributed engineering station is obtainable over the network. 

Procedure 
1. Select the project in the multiproject that you want to move to the distributed engineering 

station in the component view of the SIMATIC Manager. 
2. Select the menu command File> Save as .... 
3. Make the following settings: 

– Enable the "Insert in multiproject" option. 
– Select the "Current multiproject" entry from the corresponding drop-down list. 
– Enable the "Replace current project" option. 
– Enter the required storage location (path) on the distributed engineering station (in 

UNC notation). 
4. Click "OK". 

Result 
● An identical copy of the project of the central engineering station is created on the 

distributed engineering station. The copy is inserted automatically in the multiproject and 
replaces the original project. 

● The existing original project is removed from the multiproject, but remains on the central 
engineering station. You can either keep the original project as a backup or delete it. 

 

 
 

Note 
Before the copied project can be copied back to its old location (same folder name), this 
backup must be deleted. 

 

 
 

Note 
In the same way, you can also save the project on a data medium and pass this on for 
distributed editing or archive the project with the "Archive" function and pass on the 
archive on a data medium. 
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Removing a Project from the Multiproject (Alternative) 
 

 Note 
You can also move a project to a distributed engineering station as follows: 
1. In the component view of the SIMATIC Manager select the project within the multiproject 

that you remove from the multiproject. 
2. Select the menu command File > Multiproject > Remove for Editing... 

The "Select Directory" dialog box opens. 
3. Select a directory and click "OK". 
Result 
The project is marked as "removed for editing" and displayed in gray. 
When a project has been removed, in contrast to the procedure described above, you can 
not use the "Archive", "Save As", and "Compile OS" functions. 

 

Additional information 
● Section "Merging Projects after Distributed Editing (Multiproject Engineering) (Page 621)" 
● Section "How to Move Project Edited on Distributed Stations to the Central Engineering 

Station (Page 622)" 
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8.7.6 How to Continue Editing Projects on Distributed Stations 

Requirement     
All the PCS 7 software components required for editing are installed on the distributed 
engineering station. 

Distributed Editing of the Project 
The following unrestricted functions can be executed if you distribute the project for editing: 
● All non cross-project functions 
● The following partial functions can be executed as usual: 

– Pure editing work 
– Compiling of an AS 
– Downloading an AS over a preselected module (not with the option "PC internal 

(local)") 
Special additional actions are necessary when you execute the following tasks on a 
distributed ES: 
● Downloading an AS directly via the interface module of the distributed engineering station 
● Testing the OS in process mode (OS simulation) 

Downloading an AS via the interface module of the distributed ES 
Execute the following actions in the project if you want to download an AS for test purposes: 
1. Insert a local SIMATIC PC station with a suitable CP module into the project. 
2. Configure S7 connections (configured connection) from this OS to the AS. 
If you want to test an OS on an engineering station in process mode (Start OS Simulation 
shortcut menu), the two steps above are necessary regardless of the programming 
device/PC interface setting. In addition, the following step is also necessary:  
1. Customize the computer name in WinCC Explorer. 

 

 
 

Note 
These changes must be reversed before the project is copied or moved back to the 
central engineering station. 

 

Additional information 
● Section "How to Move Projects Edited on Distributed Stations to the Central Engineering 

Station (Page 622)" 
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8.8 Configuring the Hardware 

8.8.1 Introduction to Hardware Configuration 

Overview    
Configuring the hardware involves the following topics: 
● Defining a Project-Specific Catalog Profile (Page 353) 
● Exporting/Importing the Hardware Configuration (Page 354) 
● Configuring the SIMATIC 400 Station (CPU, CPs, Central I/O) (Page 357) 
● Setting Time Synchronization (Page 379) 
● Configuring the Distributed I/O (Standard) (Page 382) 
● Configuring the Distributed I/O for Configuration Changes RUN (Page 396) 
● Configuring the Hardware for High-precision Time Stamps (Page 417) 
● Activating acknowledgment-triggered reporting (Page 418) 
● Downloading the configuration to the CPU (Page 419) 

8.8.2 Overview of Hardware Configuration 

Introduction   
The configuration of the hardware involves the configuration of your plant at the automation 
level (AS, OS, BATCH, Route Control, OpenPCS 7) in the SIMATIC Manager and in 
HW Config. You may create your SIMATIC 400 stations distributed in various projects and 
configure the required I/O and communication hardware.  
You configure various project types in the PCS 7 OS according to the structure of your plant. 
For example, you can configure process cells with one or more OS servers or OS clients. 
Generally, you work with a multiple station project and create several OS servers and OS 
clients. 
In addition you can create and configure redundant components in the hardware 
configuration (for example redundant OS, use of H-stations). 



Implementing the PCS 7 Configuration  
8.8 Configuring the Hardware 

 Engineering System (V7.1) 
352 Configuration Manual, 03/2009, A5E02122455-01 

Overview of Configuration Tasks 
This overview shows you the recommended order in which the individual configuration steps 
should be carried out, and tells you which tools should be used to do the configuration work: 
 
What? Where? 
Adding all the SIMATIC 400 stations to the project. 
Inserting the engineering station (ES), operator stations (OS), BATCH 
stations (BATCH), Route Control stations and OpenPCS 7 station as 
PC stations in the project. 

SIMATIC Manager 

Adding hardware components to the SIMATIC 400 stations. 
You insert hardware components and applications that belong to the 
particular PC station. 

HW Config 

Note to Reader 
For multiproject engineering, the SIMATIC 400 stations and PC stations are often already in 
your project. The following section describes how you continue by adding the hardware 
components to the SIMATIC 400 stations. 
If the PC stations have not yet been created, first perform the following tasks before 
continuing below: 
● "How to Insert an Engineering Station and Configure It (Page 277)" 
● "How to Insert an Operator Station and Configure It (Page 279)" 
● "How to Insert a BATCH Station and Configure It (Page 281)" 
● "How to Insert a Route Control Station and Configure It (Page 283)" 
● "How to insert and configure an OpenPCS 7 station (Page 285)" 

Additional information 
Information on configuring the hardware for the operator stations can also be found in the 
configuration manual, Process Control System PCS 7; Operator Station. 
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8.8.3 Defining a Project-Specific Catalog Profile 

Advantage of the Project-Specific Catalog Profile 
You can store a specific catalog profile for the hardware in each multiproject. In this way, you 
will make sure that everyone who works on the individual projects of the multiproject uses 
the same hardware. You can make this project-specific catalog profile available centrally 
(access via the network) or you can store it on a distributed station with the other data for 
distributed editing. 

Setting up a Project-Specific Catalog Profile 
1. Select the menu command Options > Edit Catalog Profiles in HW Config.  

Two catalog profiles are opened: The "standard" profile and an "empty" profile that does 
not contain any components yet. 

2. Drag the folders and modules you require from the standard profile window to the "empty" 
profile window. You can also adapt the structure to your needs with the menu command 
Insert > Folder. 

3. Save the new catalog profile with the menu command Profile > Save As. 
The new catalog profile is created. It then appears in the "Profile" selection list of the 
"Hardware Catalog" window, where it can be selected. 

 

 Note 
DP slaves installed later (using GSD files) are only contained in the "Standard" profile 
("Additional Field Devices" folder) and are not automatically included in user-created profiles!

 

Exporting a Project-Specific Catalog Profile 
To make a catalog profile available at another workstation, export the catalog profile as 
follows: 
1. Select the menu command Options > Edit Catalog Profiles in HW Config. 
2. Select the menu command Profile > Export. 
3. Select the catalog profile you want to export and set the destination path for the export. 
The catalog profile is copied to the set destination in *.dat format. 
You can also save the file onto a data medium and pass it on in this way. 
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Importing a Project-Specific Catalog Profile 
1. Select the menu command Options > Edit Catalog Profiles in HW Config at the 

workstation at which you want to use the catalog profile. 
2. Select the menu command Profile > Import. 
3. Set the path to the source and select the catalog profile you want to import. 
The catalog profile is imported and appears in the "Profile" selection list of the hardware 
catalog. 

 

 Note 
You can remove catalog profiles that you do not require with the menu command Profile > 
Delete. 

 

8.8.4 Exporting/Importing the Hardware Configuration 

Introduction 
You cannot only edit station configurations within the project (e.g. by saving or opening). You 
can also export it to a text file (ASCII file, CFG file), edit (adapt) it and then import it again 
independently of the project. The symbolic names of the inputs and outputs can also be 
exported and imported. 

Application 
The export/import functions can be used as follows, for example: 
● Data import from hardware planning tools 
● Station configuration using electronic media (for example, e-mail) 
● The export file can be printed out with a word processing system or can be edited for 

documentation purposes. 

Where Is it Described? 
You can find a detailed description of importing and exporting the hardware configuration in 
the section "Import/Export of the Hardware Configuration (Page 653)". 
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8.8.5 Configuring the SIMATIC 400 Station (CPU, CPs, Central I/O) 

8.8.5.1 Creating the Concept for Address Assignment 

Introduction 
Before you can start with the configuration of the hardware, first create a concept for 
assigning addresses. The networks are independent of each other and have their own range 
of numbers for addresses.  
We distinguish between the following addresses: 
● Node Addresses 
● Input/Output Addresses (I/O Addresses) 

Node Addresses 
Node addresses are addresses of programmable modules (PROFIBUS, Industrial Ethernet 
addresses). They are needed in order to address the various nodes of a subnet, e.g. to 
download a user program over the plant bus (Industrial Ethernet) to a CPU. You will find 
more information about assigning node addresses on a subnet in the section on networking 
stations.  

Input/Output Addresses (I/O Addresses)  
Input/output addresses (I/O addresses) are needed in order to read inputs or to set outputs 
in the user program. 
Principle: PCS 7 assigns the input and output addresses when modules are placed in the 
SIMATIC 400 station in HW Config. This means that every module has its own starting 
address, i.e. the address of the first channel. The addresses of the other channels are 
derived from this starting address. For ease of use, the addresses can be assigned symbolic 
names (symbol table). 
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Plant Configuration Options  
The following diagram contains an overview of a possible plant configuration with node 
addresses and I/Os plugged in. 

0
1

 
 
1) Industrial Ethernet: max. 100 Mbps; max. 1024 nodes 

(BCE: max. 100 Mbps; max. 8 nodes) 
2) MPI: In PCS 7, MPI is only used for testing and diagnostic purposes. 

DP master system: max. 12 Mbps; max. 126 nodes; profile: PROFIBUS DP 
 
 

 Note 
For the high-precision time stamp, PROFIBUS DP must be connected to the SIMATIC 400 
station via a CP 443-5 Extended or via the internal PROFIBUS DP interface. 
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8.8.5.2 Overview of Configuration Steps 

Introduction     
The following table provides you with an overview of the various configuration steps and the 
corresponding tools. 
 
What? Where? 
Creating a SIMATIC 400 station (Page 359) SIMATIC Manager 
Inserting modules in a SIMATIC 400 station (Page 360) HW Config 
Inserting a communications processor (CP) (Page 364) HW Config 
Setting the CPU properties (Page 367) HW Config 
Setting the process image (Page 371) HW Config  
Configuring fault-tolerant systems (H systems) (Page 377) 
See the manual Process Control System PCS 7; Fault-
tolerant Process Control Systems for more information. 

HW Config 

Configuring Fail-safe Systems (F systems) (Page 377) 
See the manual Automation Systems S7-400F/S7-400FH, 
Fail-safe Systems for more information. 

HW Config  

Setting the time synchronization (Page 381)  HW Config 
Configuring the distributed I/O for standard (Page 382) HW Config 
Configuring the distributed I/O devices for configuration 
changes in RUN (CiR) (Page 402) 

HW Config 

Assigning icons for the input and output addresses 
(Page 366) 

HW Config (Symbol Table) 

Configuring PA devices (Page 386) PDM 
Configuring the diagnostic repeater (Page 387) SIMATIC Manager + HW Config 
Configuring intelligent field devices (Page 389) PDM 
Configuring HART devices (Page 392) PDM 
Configuring Y links and Y adapters (Page 394) HW Config 
Importing/exporting the hardware configuration HW Config 
Configuring the high-precision time stamps (Page 417) HW Config 
Activating acknowledgment-triggered reporting (Page 418) HW Config 
Downloading the configuration to the CPU (Page 419) HW Config 
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Recommended Order for the Tasks  
The tasks involved in configuring and assigning parameters to a process cell should ideally 
be carried out in the order shown below: 
 
Order of the tasks 
Creating a station  
How to create a SIMATIC station (Page 359) 
Calling the application for configuring the HW 
Arranging the central rack  
Arranging modules in the rack 
How to insert the modules in a SIMATIC station (Page 360)  
Inserting and configuring the distributed I/O 
Assigning the icons 
Specifying the properties of modules/interfaces 
Setting the CPU properties (Page 367)  
Setting the process image (Page 371)  
Saving a configuration and consistency check  
Downloading a configuration to a PLC 
How to download the configuration to the CPU (Page 419) 
Uploading from the target system to the programming device (reload, e.g. for service purposes). 

Additional information 
● Online Help for HW Config 
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8.8.5.3 How to Create a SIMATIC 400 Station 

Introduction                
In multiproject engineering, automation systems may have already been created in your 
project. You can insert additional automation systems as follows:  
● With PCS 7 "Expand Project" wizard 

You can find information about this in the section "How to Expand a Project with 
Preconfigured Stations (Page 263)". 

● Manually if you do not use any supplied bundles (described below) 

SIMATIC 400 station 
When you create an automation system, you require a SIMATIC 400 station with a power 
supply, a CPU and an Ethernet communication processor (can be omitted when using a 
CPU with integrated Ethernet interface). You then configure the central and distributed I/O 
and any further modules you require. The following sections explain how to insert the 
individual components in the project and set their properties. 

Procedure 
Before you can start to configure and assign parameters, you will need a SIMATIC 400 
station in your project that you can insert at the level immediately below the project, where 
you can then set its properties.  
1. Select the project to which you want to add another automation system in the SIMATIC 

Manager component view. 
2. Select the menu command Insert > Station > SIMATIC 400 Station. 

A new SIMATIC PC station is inserted in the selected project. 
3. Repeat the procedure to add further automation systems. 
You can change the names as required by selecting the menu command Object Properties 
from the SIMATIC 400 station shortcut menu. 

 

Additional information 
● Section "How to Insert Modules to a SIMATIC 400 Station (Page 360)" 
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8.8.5.4 How to Insert Modules to a SIMATIC 400 Station 

Introduction 
After you have created the SIMATIC 400 station, add the hardware components to the 
station from the hardware catalog.  

Hardware Catalog 
The hardware catalog is normally displayed when you open HW Config. If this is not the 
case, open it in HW Config with the menu command View > Catalog. 
In the bottom third of the catalog, you will see the order number and a brief description of the 
currently selected component. Compare this order number with the order number of your 
existing component. You can then be sure that you have selected the right component. 

 

 Note 
In the hardware catalog, you can select from various profiles (Standard, PCS 7, etc.). All the 
profiles are based on the "Standard" profile and represent a subset of this profile.  
The "PCS 7_Vx.y" profile is displayed by default when you first start the hardware 
configuration. This profile shows the current versions of all modules and devices released for 
PCS 7 Vx.y.  
If you cannot find the module you require in this profile (for example, an older CPU that is 
nevertheless released for PCS 7), select the "Standard" profile and then select the required 
module from it. Please note that module default settings may vary from one module to 
another. 
You will find a list of released modules in: Start > SIMATIC > Documentation > English > 
PCS 7 - Released Modules. 
You can create an individual profile with the modules and devices which you frequently 
require: You can find information about this in the section "Defining a Project-Specific 
Catalog Profile (Page 353)". 
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Procedure 
1. Select the station in the component view and double-click the "Hardware" object in the 

detail window. 
The HW Config and hardware catalog open. 

 
 

 
 

Note 
When you want to add additional modules to a SIMATIC 400 station created with the 
PCS 7 wizards, continue with Step 6. 

 

2. In the SIMATIC 400 > Rack-400 hardware catalog, select the required rack and insert it 
by dragging with the mouse.  
Make sure that the arrangement selected here matches the arrangement of the physical 
hardware. 

3. In the "SIMATIC 400 > PS-400" hardware catalog, select the required power supply and 
add it by dragging with the mouse. 

4. In the SIMATIC 400 > CPU-400 hardware catalog, select the required CPU and insert it 
by dragging with the mouse. 

5. Click "OK" to confirm the "Properties - PROFIBUS Interface" dialog box that opens. 
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6. Proceed in the same way to add any other components you require, for example: 
– "SM 400": digital and analog signal modules (CPUs) 
– "CP 400": communication modules: You can find information about this in the section 

"How to Insert a Communications Processor (Page 364)". 
7. Select the menu command Station > Save in HW Config. 

Setting the Properties of the Integral PROFIBUS DP Interfaces 
When you add a CPU you have to set the properties of the integral PROFIBUS DP 
interfaces of that CPU.  
Follow the steps below: 
1. Select the PROFIBUS DP interface of the CPU. 
2. Select the menu command Edit > Object Properties. 
3. Click the "Properties" button of the interface in the "General" tab. 
4. Network the PROFIBUS DP interface with a PROFIBUS network by selecting the 

PROFIBUS network and assigning the required address.  
If you have not yet created a PROFIBUS network, you can create a new network with the 
"New" button. 

5. Then click "OK" twice.  
The "Properties" dialog box closes. 

 

 Note 
If you want to connect PROFIBUS DP to a CP 443-5 Extended, you do not need to set the 
properties. 
Note that the integral PROFIBUS DP interface does not perform the same range of functions 
as the CP 443-5 Extended (e.g. number of PROFIBUS nodes). 
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Adding and Setting Additional IF Interface Modules 
1. Select a module slot (IF1/IF2) of the CPU. 
2. Select the menu command Insert > Insert Object. 
3. In the dialog boxes that then open, select: 

– CPU 
– Firmware version 
– Interface module 

4. Click the interface "Properties" button in the "Parameters" tab. 
5. Network the PROFIBUS DP interface with a PROFIBUS network by selecting the 

PROFIBUS network and assigning the required address.  
If you have not yet created a PROFIBUS network, you can create a new network with the 
"New" button. 

6. Then click "OK" twice.  
The "Properties" dialog box closes. 

Additional information 
● Section "How to Configure the Distributed I/O (Page 382)" 
● Section "How to Insert a Communications Processor (Page 364)" 
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8.8.5.5 How to Insert a Communications Processor 

CP 443-1 for Connecting to the Plant Bus 
You require the CP 443-1 communications processor for the connection between automation 
systems, engineering station or operator stations and Route Control stations over the plant 
bus (Industrial Ethernet).  

 

 Note 
If you use a CPU with an integrated Ethernet interface, you can make the connection to the 
plant bus with it. You then do not need a CP 443-1 communication processor. 

 

Adding a CP 443-1 
1. Select the required SIMATIC 400 station from the component view and double-click the 

"Hardware" object in the detail window. 
The hardware configuration of the automation system is opened. 

2. Select "SIMATIC 400 > CP-400 > Industrial Ethernet ..." in the hardware catalog and drag 
the CP you require.  
Make sure that the arrangement selected here matches the arrangement of the physical 
hardware. 
Once you have inserted the CP, the "Properties - Ethernet Interface CP 443-1" dialog box 
is opened. 

3. Activate the check box "Set MAC address/Use ISO protocol" and assign the desired MAC 
address (for example 08.00.06.01.00.12 or the preset address of the CP used), or accept 
the default address.  
Make sure that the address is unique on the bus. 

4. Enter the IP address and subnet mask or deactivate the "IP protocol is being used" check 
box. 

5. Click "New" and replace the name "Ethernet(1)" with a name that will be more meaningful 
later on. 

6. Then click "OK" twice.  
The "Properties" dialog box closes. 

CP 443-5 Extended for Interfacing with the Distributed I/O 
In addition (or as an alternative) to the PROFIBUS DP interfaces integrated in the CPU, you 
can use the CP 443-5 Extended to interface with your distributed I/O. With each further 
CP 443-5 Extended, you can insert further DP chains and theoretically address 126 more DP 
slaves.  

 

 Note 
The high-precision time stamps are used in conjunction with the IM 153-2 or routing 
(parameter assignment for the DP/PA slaves over the ES and the plant bus) via the 
integrated PROFIBUS DP interface or the CP 443-5 Extended. 
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Adding a CP 443-5 Extended 
1. Select the required SIMATIC 400 station from the component view and double-click the 

"Hardware" object in the detail window. 
The hardware configuration of the automation system is opened. 

2. Select "SIMATIC 400 > CP-400 > PROFIBUS ..." in the hardware catalog and drag and 
add the required CP to the SIMATIC 400 station. 
Once you have inserted the CP, the "Properties - PROFIBUS Interface CP 443-5 Ext" 
dialog box is opened. 

3. Assign the required PROFIBUS address for the  
DP Master ("Parameter" tab; "Address:" list box). 

 

 
 

Note 
The addresses 1 and 126 are default addresses for DP slaves. Do not use the default 
addresses in your project. 

 

4. Click "New" and replace the name "PROFIBUS(1)" with a name that will later be more 
meaningful. 

5. Select the "Network Settings" tab and set the transmission rate "1.5 Mbps" and the "DP" 
profile. 

6. Then click "OK" twice.  
The "Properties" dialog box for the PROFIBUS interface closes. 

Additional information 
● Online Help for HW Config 
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8.8.5.6 How to Assign Symbols to Input and Output Addresses 

Introduction        
You can assign symbols to the addresses of inputs and outputs when configuring modules 
without needing to start the symbol table in the SIMATIC Manager (symbols editor).  
You can also find information about this in the section "Free Assignment between Hardware 
and Software (Page 220)" 

 

 Note 
The assigned symbols are not downloaded when you download to the station with the menu 
command PLC > Download to Module....  
Effect: If you use menu command PLC > Upload to PG to upload to the programming device, 
no symbols are displayed. 

 

Procedure  
1. Select the digital/analog module whose addresses you want to assign symbols to. 
2. Select the menu command Edit > Symbols....  

The symbol table opens. 
3. Enter the required symbols for the addresses listed. 
4. Click "OK". 
Tip: 
If you click the "Add Symbol" button in the dialog box, the name of the address is entered as 
a symbol. 

Additional information 
● Online Help for HW Config 
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8.8.5.7 Setting the CPU Properties 

Overview of the Most Important Settings 
The CPU properties are entered automatically for PCS 7 in HW Config. They are suitable for 
most application scenarios. You can also find information about this in the section "Default 
Parameter Values for the CPUs (Page 378)". 
The following table contains the most important settings of the CP properties for PCS 7. 
 
What? Where? 
Setting the CPU startup mode (see below) HW Config (Object Properties) 
Setting OB 85 (I/O access error) (see below) HW Config (Object Properties) 
Setting the Process Image (Page 371) HW Config (Object Properties) 
Adapting the local data (see below) HW Config (Object Properties) 

Setting the CPU Startup Mode 
The S7-400 CPU is capable of the following types of startup: 
● Warm restart 
● Cold restart 
● Hot restart 

Warm restart  
In a warm restart, execution of the program restarts at the beginning of the program with a 
"basic setting" of the system data and user address areas. Non-retentive timers, counters, 
and memory bits are reset. All data blocks and their contents are retained. 
When you restart (warm restart) an S7-400 (for example by changing the mode selector from 
STOP to RUN or by turning the power ON) organization block OB100 is processed before 
cyclic program execution begins (OB 32 - OB 38). As default, all the PCS 7 blocks that have 
a special startup behavior are installed in OB100. 
Warm restart = Default setting for PCS 7 and normal applications 

Cold restart 
A cold restart is used only in exceptional situations when one of the following functions is 
required: 
● During a cold restart, the process image input table is read and the user program is 

executed, starting at the first command in OB1. 
● Data blocks created by SFCs in the RAM are deleted, while the other data blocks have 

the default values from the load memory. 
● The process image and all timers, counters, and memory bits are reset regardless of 

whether they were set as retentive. 
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Hot restart  
In a hot restart, program execution is resumed at the pointer to which it was interrupted 
(timers, counters, and memory bits are not reset). 

 

 Note 
A hot restart is not permitted when using S7-400 CPUs in the PCS 7 process control system.

 

Setting the Startup Mode 
1. Select the CPU in HW Config. 
2. Select Edit > Object Properties.  

The "Properties - CPU..." dialog box opens. 
3. Open the "Startup" tab. 

Recommendation: apply the default settings. 
4. Set the required startup type under "Startup after Power On". 
5. Click "OK". 

Setting OB 85 (I/O Access Error)  
The CPU's operating system calls OB 85 if an error occurs while the process image is being 
updated (module does not exist or defective) and the OB call was not suppressed during 
configuration.  
If you wish to activate the OB 85 call for I/O access errors (I/O AAE), we recommend that 
you activate the "Only for incoming and outgoing errors" option. In this way, you will not 
increase the CPU's cycle time by repeatedly calling OB 85, as would be the case with the 
"For each individual access" option. 
The "Only for incoming and outgoing errors" option is the default setting for PCS 7 
Apart from the configured reaction "Only for incoming and outgoing errors", the address 
space of a module also influences how often OB85 starts: 
● For a module with an address space up to a double word, OB85 starts once, for example, 

for a digital module with up to 32 inputs or outputs, or for an analog module with two 
channels. 

● For modules with a larger address space, OB85 starts as often as the number of double 
word commands required to access it, for example, twice for a four-channel analog 
module. 
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Configuring the Response to I/O Access Errors 
1. Select the CPU in HW Config. 
2. Select the menu command Edit > Object Properties.  

The "Properties - CPU..." dialog box opens. 
3. Select the "Cycle/Clock Memory" tab. 
4. Select the "Only for incoming and outgoing errors" setting from the "OB 85 call for I/O 

access areas" drop-down list. 
5. Click "OK". 

Modifying the Local Data 
The CPU has limited memory for the temporary variables (local data) of blocks currently 
being executed. The size of this local memory, the local data stack, depends on the 
particular CPU. The local data stack stores the following elements:  
● The temporary variables of the local data of blocks 
● The start information on the organization blocks 
● Information on the transfer of parameters 
● Interim results of the logic in Ladder programs 
When you create organization blocks, you can declare temporary variables (TEMP) that are 
available only while the block is running. They are then overwritten. Before the first access, 
the local data must be initialized. Each organization block also requires 20 bytes of local data 
for its startup information. 
Assigning Local Data to Priority Classes  
The local data requirements are assigned via the priority classes. 
The local data stack is divided equally between the priority classes by default. This means 
that each priority class has its own local data area. This ensures that high-priority classes 
and their OBs have space for their local data.  
The priority classes do not all need the same amount of memory in the local data stack. With 
suitable parameter settings for the S7-400 CPUs, it is possible to set local data areas of 
different sizes for the various priority classes. You can deselect priority classes that are not 
required. This extends the memory area of the S7-400 CPUs available for other priority 
classes. Deselected OBs are ignored during program execution and therefore save 
computing time.  
The calculation of the local data is described in an FAQ on the Web. 
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Modifying Local Data 
1. Select the CPU in HW Config 
2. Select the menu command Edit > Object Properties.  

The "Properties - CPU..." dialog box opens. 
3. Select the "Memory" tab and adapt the local data if necessary. 

You can find further information about this in the online help. 
4. Click "OK". 

 

 
 

Note 
Make sure that you also take into account any reserves configured for CiR (configuration 
change in RUN). 

 

Setting the Process Image 
You can find information about this in the section "Setting the Process Image (Page 371)". 

Additional information 
● Section "Default Parameter Values for the CPUs (Page 378)" 
● Online Help for HW Config 
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8.8.5.8 Setting the Process Image 

Introduction     
The driver blocks for the modules in the PCS 7 library do not access the I/O directly to query 
the current signal states, but rather access a memory area in the system memory of the CPU 
and the distributed I/O: the process input image (PII) and process output image (PIQ). This 
process image includes both the digital inputs and outputs as well as the analog inputs and 
outputs.  
The process image starts with I/O address 0 and ends at a high limit as set in HW Config.  

Updating the Process Image 
The process image is updated cyclically by the operating system automatically. 

 
Editing the process images for CPUs  
Start of the current cyclic processing Start of the next cyclic processing 
← Current cycle time for OB 1 →  
Output the PIQ Update the PII Editing the  

OB 1 or the cyclic 
interrupts 

Output  
the PIQ 

Update the PII Editing the  
OB 1 or the cyclic 
interrupts  
etc. → 

Advantages of the Process Image 
In contrast to direct access to the I/O modules, when the process image is accessed directly 
the CPU has a consistent image of the process signals for the duration of one program 
cycle. If a signal state at an input module changes while the program is being executed, the 
signal state in the process image is maintained until the process image is updated in the next 
cycle. 

Size of the Process Image 
For PCS 7, the size of the process image must be greater than or equal to the number of 
inputs and outputs used. By default, the first analog output module has the base 
address 512 in the process image. Recommendation: set the size of the process image of 
the inputs and outputs to a higher value. This will leave space in reserve for further analog 
modules.  
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Setting the Size of the Process Image 
1. Select the CPU in HW Config. 
2. Select the menu command Edit > Object Properties....  

The "Properties - CPU..." dialog box opens. 
3. Select the "Cycle/Clock Memory" tab and set the size of the process image. 
4. Click "OK". 

 
 

 
 

Note 
The default size of the process image depends on the CPU. 
You can also find information about this in the section "Default Parameter Values for the 
CPUs (Page 378)" 
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Process Image Partitions 
In addition to the process image (PII and PIQ), you can also specify up to 15 process image 
partitions for an S7-400 CPU (CPU-specific, no. 1 up to max. no. 15).  

 

 Note 
Please note the following: 
• Each input/output address must be assigned to a process image partition. 
• Each input/output address that you assign to a process image partition no longer belongs 

to the OB1 process input/output image. 
• Input/output addresses can only be assigned once throughout the OB 1 process image 

and all process image partitions. 
• Make sure that signals and signal processing (module and corresponding driver) are 

executed in the same OB. 
 

You make the assignment to the process images during hardware configuration of the I/O 
modules (see Figure below).  



Implementing the PCS 7 Configuration  
8.8 Configuring the Hardware 

 Engineering System (V7.1) 
374 Configuration Manual, 03/2009, A5E02122455-01 

Setting the Process Image Partitions 
1. In the HW Config, select the I/O module you want to assign to a process image partition. 
2. Select the menu command Edit > Object Properties.... 

The "Properties - ..." dialog box opens. 
3. Change to the "Addresses" tab and assign to a process image partition as required (PIPx; 

x=1 through 15). 
4. Click "OK". 
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Updating of the Process Image Partitions by the System 
If you link the updating of a process image partition to an OB, the partition is automatically 
updated by the operating system when this OB is called. This strategy is similar to the 
updating of the (total) process image which is updated cyclically or after OB1 has been 
executed.  
During operation, the assigned process image partition is then updated automatically as 
follows:  
● before the OB is executed - the process image partition of the inputs (partial PII) 
● after the OB is executed - the process image partition of the outputs (partial PIQ) 

 
Processing a process image partition when linked to an OB 
Start of the current cyclic interrupt (OB) processing Start of the next cyclic interrupt (OB) processing 
← Current cycle time of the OB →  
Update the partial 
PII 

Execute the cyclic 
interrupt 

Output the partial 
PIQ 

Update the partial 
PII 

Execute the cyclic 
interrupt 

Output of the 
partial PIO etc. → 

Assigning the Process Image Partition to OBs 
You can specify which process image partition is assigned to which OB when you assign 
parameters to the CPU and the priority of the OB (see following Figure).  
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Assigning Process Image Partitions to OBs 
1. Select the CPU in HW Config. 
2. Select the menu command Edit > Object Properties. 
3. Select the "Cyclic Interrupts" tab and make the required settings. 
4. Click "OK". 

 
 

 
 

Note 
Changing the cyclic interrupt time in the RUN of a CPU 
Each change to the cyclic interrupt time of a CPU requires compilation of the program. 
Otherwise, the CPU_RT block continues to work using the old values. 

 

Additional information 
● Online Help for HW Config 
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8.8.5.9 Configuring Fault-tolerant Systems (H Systems) 

SIMATIC H Station  
For a fault-tolerant automation system, a SIMATIC H station is added to the project as a 
separate station type in SIMATIC Manager. This station type is required if you want to 
configure two central racks each with an H CPU, thereby configuring your process control 
system with redundancy. 

Description with Step-by-step Instructions 
For complete step-by-step instructions for configuring fault-tolerant process control systems, 
refer to the manual Process Control System PCS 7; Fault-tolerant Process Control Systems. 

8.8.5.10 Configuring Fail-safe Systems (F Systems) 

SIMATIC F/FH Station 
For a fail-safe and fault-tolerant automation system (FH system), add a SIMATIC H station to 
the project as a separate station type in the SIMATIC Manager. 
For a fail-safe automation system (F system), add a SIMATIC 400 station to the project as a 
separate station type in the SIMATIC Manager. 

Description with Step-by-step Instructions 
● Manual S7-400F/S7-400FH Automation systems, Fail-safe Systems 
● For complete step-by-step instructions for configuring fault-tolerant process control 

systems, refer to the manual Process Control System PCS 7; Fault-tolerant Process 
Control Systems. 
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8.8.5.11 Default Parameter Values for the CPUs 

Modifying Parameters 
When you work with new projects created with PCS 7 V7.1, PCS 7 sets default values for 
the automation systems.  
The table in the section "Default Performance Parameters of the CPUs (Page 138)" shows 
the default parameters for the performance capability of typical CPUs for PCS 7 projects. 
These values are set as defaults in the configuration of the CPU with PCS 7 software.  
The default parameters suffice for typical applications but can be changed within limits as 
required for configuration.  
You can modify these parameters on the tabs of the CPU "Properties" dialog box using the 
menu command Edit > Object Properties. 

 

 Note 
After adapting the parameters, a download with the CPU in STOP is necessary. 

 

Additional information 
● Section "Default Performance Parameters of the CPUs (Page 138)" 
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8.8.6 Setting Time Synchronization 

8.8.6.1 Principle of Time Synchronization 

System-wide Time Synchronization     
To be able to analyze the process data, all the components of the process control system 
must work with exactly the same time. This is the only way that messages can be assigned 
in the correct chronological order - regardless of the time zone. For example, an OS server 
must assume the function of time master, such that all other operator stations and 
automation systems on the plant bus receive the time from this master. In this way, they all 
have the same time. 

Time Synchronization for a PCS 7 Process Cell 
 
Station Synchronization Options Additional information 
Operator station 
and  
maintenance station 

• Synchronize the time of day 
through the terminal bus 

• Synchronize the time of day 
through the plant bus 

Configuration manual Process Control 
System PCS 7; Operator Station 
1.) 

BATCH station • Synchronize the time of day 
through the operating system 

 1.) 

Route Control 
Station 

• Synchronize the time of day 
through the operating system 

1.) 

SIMATIC PCS 7 
BOX 

• Synchronize the time of day 
during integration in a PCS 7 
system 

Manual Process Control System 
PCS 7, SIMATIC PCS 7 BOX 
1.) 

AS • Synchronize the time of day with 
the AS as the time slave 

Section "How to Set Time 
Synchronization on the AS 
(Page 381)" 
1.) 

Domain controller • Synchronize the time of day 
Domain controller as the time 
master on the terminal bus 

Manual  
Process Control System PCS 7; 
Operator Station 
1.) 

• The time-of-day master is 
integrated in a PC or connected to 
Ethernet as a bus component. 

Manual  
Process Control System PCS 7; 
Operator Station 
1.) 

Time Master 

• The time-of-day master can be 
any device that can send a time 
signal via Ethernet (a PC, for 
example). 

Manual  
SIMATIC NET; SICLOCK TM,  
SICLOCK TC 400 
1.) 

1.) Function Manual Process Control System PCS 7; Time Synchronization 
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Using CPU Clocks 
You can set and evaluate the time/date of automation systems and operator stations. 

Representing Time Zones  
There is only one continuous uninterrupted time of day throughout the plant - the UTC.  
Locally on the OS, an additional local time that differs from UTC can be calculated and used 
for display. The local time is calculated from the UTC by adding or subtracting a time 
difference.  
The local time also takes into account standard and daylight saving time. 

 

 Note 
In PCS 7 UTC time is always used internally in the system. 
Time information displayed to the plant operator in process mode (OS Runtime) can be 
displayed optionally in UTC or local time. This makes system configuration possible across 
time zone boundaries. 

 

This makes it possible to configure a system, for example, with the automation system in a 
different time zone than the operator station. When necessary, the operator can also change 
over between displayed in UTC or local time during operation. 

Time Stamp 
The time stamp in the diagnostic buffer, messages and OB start information is generated 
with UTC. 

Description for Setting the Time Synchronization 
For time synchronization to function throughout a system, certain settings must be made at 
the nodes involved. 
 
Components Involved Information on the procedure can be found in 
AS: CPU, CP 443-1,  
CP 443-5 Extended 

Section " How to Set Time Synchronization on the AS (Page 381) " 
Manual Process Control System PCS 7; High-precision Time Stamps 

OS Manual Process Control System PCS 7; Operator Station 
PC station Whitepaper Security Concept PCS 7 and WinCC 

Additional information 
● Function Manual Process Control System PCS 7; Time Synchronization 
● Configuration manual Process Control System PCS 7; Operator Station 
● Manual Process Control System PCS 7; PC Configuration and Authorization 
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8.8.6.2 How to Set Time Synchronization on the AS 

Setting the CPU          
1. Open the hardware configuration of the required station. 
2. Select the CPU and select the menu command Edit > Object Properties.... 
3. Select the "Diagnostics/Clock" tab. 
4. In the "Clock" group, select the type of synchronization "As slave" for the synchronization 

on the PLC and (On MPI > None). 
5. Click "OK". 

Setting CP 443-1 (Industrial Ethernet) 
1. Open the hardware configuration of the required station. 
2. Select the CP 443-1 and select the menu command Edit > Object Properties.... 
3. In the "Time Synchronization" tab, check the "Activate SIMATIC time synchronization" 

check box: 
4. Click "OK". 

Setting CP 443-5 Extended (PROFIBUS DP) 
1. Open the hardware configuration of the required station. 
2. Select the CP 443-5 Extended and select the menu command Edit > Object Properties.... 
3. In the "Operating Mode" tab, activate the "DP master" check box. 
4. Select the "Options" tab. 
5. Activate the "Pass on time-of-day frames - From station an LAN" check box in the "Time 

Synchronization" group.  
By activating this option, the time-of-day frames of the time-of-day master are forwarded 
to the PROFIBUS network. 

6. Click "OK". 

Additional information 
● Manual Process Control System PCS 7; High-precision Time Stamps 
● Function Manual Process Control System PCS 7; Time Synchronization 
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8.8.7 Configuring the Distributed I/O (Standard) 

8.8.7.1 How to Configure the Distributed I/Os 

Introduction                     
In the following configuration instructions, we start from an example configuration for the 
distributed I/Os with the following components: 
● ET 200M (communication via PROFIBUS DP) 
● S7-300 I/O modules plugged into the ET 200M 
To configure the distributed I/Os, carry out the following configuration steps one after the 
other: 
1. Add DP slave 
2. Add I/O modules 
3. Add symbolic names for the channels 

Adding a DP Slave - with Reference to the ET 200M 
1. Select the required SIMATIC 400 station from the component view and double-click the 

"Hardware" object in the detail window. 
The hardware configuration of the automation system is opened. 

2. Select "PROFIBUS DP > ET 200M > IM 153-..." in the hardware catalog and drag this 
module to the DP master system(1). The DP master system(1) is the line to the right of 
the RACK window. 
The "Properties - PROFIBUS Interface IM 153-..." dialog box opens. 

 

 
 

Note 
From the hardware catalog, select the IM 153 that matches the backplane bus you are 
using (passive or active backplane bus) and the product version marked on the actual 
IM 153 module you intend to use. In PCS 7, the active backplane bus is used. 

 

3. For the "PROFIBUS Address", select an address for the DP slave that is unique in your 
DP network (for example, 7). You must set the selected address on the IM 153-... using 
DIL switches (hardware switches). 
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4. Click "OK". 

 
5. Select the ET 200M and select the menu command Edit > Object Properties.... 
6. Open the "Operating Parameters" tab. 
7. Check the "Change Module during Operation" check box. 
8. Click "OK". 

 

 
 

Note 
If you do not check this check box and a module fails, the AS will interpret the module 
failure as a failure of the ET 200M. 
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Adding Input and Output Modules 
1. Select "PROFIBUS DP > ET 200M > IM 153-... > ..." in the hardware catalog and drag 

and insert the required modules (bottom hardware configuration window). 

 
2. Select the first module and select the menu command Edit  > Object Properties.... 
3. Set the address and the process image partition in the "Address" tab. 
4. Set any other properties of the module according to your configuration requirements, for 

example, diagnostic alarms or measuring ranges. 
5. Repeat the procedure for the other modules. 

 

 
 

Note 
The channel specific setting "Reaction to CPU-STOP" (OCV, KLV, SV) of a module (for 
example, analog output module with four channels) within the ET 200M distributed I/O 
station must be set identically for all channels. 

 

 
 

Note 
Make sure that the measuring range for the analog input module is also be set on the 
module itself using a coding key. You can find the code letter for setting the coding key in 
the object properties of the module in the "Inputs" tab to the right of the "Coding Key 
Setting". 
If you use an ET 200M (IM 153-x), you must install at least one input/output module in the 
ET 200M or a CiR object to avoid consistency errors when saving and compiling the 
hardware configuration. 
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Assigning Symbolic Names to the Channels 
Driver blocks are assigned to the channels on the modules using symbolic names that are 
listed in the symbol table. You declare the symbol names in the hardware configuration. 
Follow the steps outlined below: 
1. Select the first module in the ET 200M and select the Edit > Symbols... menu command. 
2. Enter symbolic names in the "Symbol" column to reflect the technological significance of 

the value being read in. 

 
3. Follow the same procedure with the other modules and enter the symbolic names for all 

the other process values you require. Use the process tag list of the plant description. 

Additional information 
● Online Help for HW Config 
● Manual SIMATIC; Distributed I/O Device ET 200M 
● Manual SIMATIC; Distributed I/O System ET 200S 
● Manual SIMATIC; Distributed I/O Device ET200iSP: 
● Manual SIMATIC; Distributed I/O Device ET 200pro 
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8.8.7.2 How to Configure PA Devices 

Introduction 
PCS 7 communicates with PA field devices via a DP/PA adapter or a DP/PA link. A DP/PA 
link is configured below and preparations are made for the further configuration of the PA 
devices with SIMATIC PDM. 

Requirement 
● The SIMATIC PDM (Process Device Manager) add-on package must be installed. 

Procedure 
1. Select the required SIMATIC 400 station from the component view and double-click the 

"Hardware" object in the detail window. 
The hardware configuration of the automation system is opened. 

2. Configure a DP master system in HW Config. 
3. Drag the DP/PA link (IM 153-2) from the hardware catalog to the DP master system. 

The dialog box for "Properties - PROFIBUS Interface" opens. 
4. Set the PROFIBUS interface parameters. 

The dialog box for defining the master system opens. 
5. Define the master system (DP or PA) and click "OK". 
6. Select the DP/PA link so that you can view the DP slave structure in the bottom part of 

the station window.  
Slot 2 represents the ”master” for the PA devices. 

7. Double-click Slot 2 to configure the PA subnet. 
8. Click "Properties" in the "Interface" group on the "General" tab and select the subnet with 

a transmission rate of 45.45 Kbps. Then click "OK". 
9. Configure the PA devices.  

You will find the PA devices in the "hardware catalog" under "PROFIBUS PA" (standard 
profile). 

 

 
 

Note 
The "PROFIBUS PA" entry is only visible if SIMATIC PDM is installed. 
You must configure at least one PA device in PROFIBUS PA. Otherwise errors will occur 
during compilation or the consistency check. 
The rest of the configuration for the PA devices takes place in SIMATIC PDM (double-
click the device). 

 

Additional information 
● Online Help for HW Config 
● Manual SIMATIC; DP/PA Link and Y Link Bus Couplers 
● Manual PDM; The Process Device Manager 
● Section "Configuring the SIMATIC 400 Station (CPU, CPs, Central I/O)" 
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8.8.7.3 How to Configure the Diagnostic Repeater 

Introduction           
The diagnostic repeater provides simple diagnostics for communication errors in PROFIBUS 
DP chains using the DPVx protocol. 

Requirements 
● The diagnostic repeater is installed and wired up. 
● The PROFIBUS address is set. 
● The diagnostic repeater is configured (configuration and parameters). 
● The DR switch behind the flap is set to ON (as supplied). 
● The power supply for the DP master is turned on. 

Configuring Hardware 
1. Select the required SIMATIC 400 station from the component view and double-click the 

"Hardware" object in the detail window. 
The hardware configuration of the automation system is opened. 

2. Drag the diagnostic repeater from the "PROFIBUS DP > Network Components" hardware 
catalog to the DP master system of your CPU. 
The "Properties - PROFIBUS Interface Diagnostic Repeater" dialog box opens.. 

3. Set the address and the properties (bus parameters), and click "OK". 
4. Double-click the diagnostic repeater. 

The "Properties – DP Slave" dialog box opens. 
5. In the "Parameter Assignment" tab, set the DP alarm mode to DPV0 (OB 82 is called for 

diagnostic events). 
Requirement: The mode on the DP master must be set to DPV1. 

6. Select Station > Save and Compile from the menu. 
7. Select the menu command CPU > Download to Module....  

The current configuration is loaded. 
This completes the hardware configuration of the diagnostic repeater. Now carry out the 
topology identification. 

Requirements for the Topology Identification 
● The programming device/PC whose topology is to be determined must be attached to the 

PROFIBUS DP. 
● A configured PROFIBUS DP module must be present. 
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Determining the Topology 
1. Connect the programming device/PC to the programming device interface of the 

diagnostic repeater for the network concerned. 
2. Switch to SIMATIC Manager and select the project for which you wish to identify the 

topology from the component view. 
3. Select the DP master system in which the diagnostic repeater is located. 
4. Select the menu command Options > Set Programming Device/PC Interface... and select 

the "Interface parameter assignment used" as in your configuration (for example, 
CP 5611 (PROFIBUS)). 

5. Click "Properties" and set the required properties in the "Properties" dialog box.  
Make sure that the address is set to "0". 

6. Click "OK" and then acknowledge the warning message that appears. 
7. Select the menu command PLC > PROFIBUS > Prepare Line Diagnostics. 

The "Prepare Line Diagnostics" dialog box opens. 
8. Click "Restart".  

The system data is determined. 
9. Click "Close" once the identification is complete. 
10. Select the menu command Options > Set Programming Device/PC Interface... and reset 

the interface parameter assignment to "PC internal (local)". 
11. Click "OK" and then acknowledge the warning message that appears. 
12. Select the required diagnostic function with the menu command PLC > 

Diagnostics/Settings > .... 
 

 
 

Note 
If several PROFIBUS networks exist, the topology must be identified for each individual 
network. 

 

Additional information 
● Manual SIMATIC; Diagnostic Repeater for PROFIBUS-DP 
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8.8.7.4 How to Configure Intelligent Field Devices with SIMATIC PDM 

SIMATIC PDM    
SIMATIC PDM is a complete and heterogeneous tool for configuration, parameter 
assignment, commissioning, and diagnostics in conjunction with intelligent process devices. 
You can use SIMATIC PDM during all phases of a project (engineering, commissioning, and 
runtime). SIMATIC PDM allows a number of process devices to be configured with a single 
software package using a standardized user interface. 
SIMATIC PDM is used as an integrated tool in SIMATIC Manager and HW Config.  
Integration in HW Config allows you to edit devices that are attached to PROFIBUS DP. All 
other devices are edited in the process device network and plant view of SIMATIC PDM. 
The display of device parameters and functions is uniform for all supported process devices 
and does not depend on their communications connection, for example, whether they use 
PROFIBUS DP/PA or the HART protocol. 
The following key functions are particularly useful for testing and commissioning process 
device data: 
● Creating process device data 
● Changing process device data 
● Validating the process device data 
● Managing process device data 
● Simulating process device data 
You can also display selected values, alarms and status signals for the device on screen and 
thus monitor the process. Process-related values can also be manipulated using simulation 
or with the devices in manual mode.  
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User Interface of SIMATIC PDM 
The user interface of SIMATIC PDM supports several views: 
● View within HW Config 
● Process devices network view within the SIMATIC Manager  

(Call using the View > Process Devices Network View menu command) 
● Process devices plant view within the SIMATIC Manager 

(Call using the View > Process Devices Plant View menu command) 
● Parameter assignment, commissioning and runtime views  

(Call using the Start > SIMATIC > SIMATIC PDM > LifeList) menu command) 

 

Communication 
SIMATIC PDM supports several communications protocols and components for 
communication with the following devices: 
● Devices with PROFIBUS DP communication 
● Devices with PROFIBUS PA communication 
● HART devices  

These devices can be attached in various ways. In its basic form, we distinguish 
between: 
– HART devices over PROFIBUS DP connected to ET 200M or ET 200iSP 
– HART devices connected to HART multiplexers or HART interface 
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System Requirements  
● You have created a device in HW Config that is configured with SIMATIC PDM. 
● In order to work online with SIMATIC PDM, you require a PROFIBUS DP interface, e.g. 

CP 5611. The CP must be set to the PROFIBUS DP interface (this is done in the 
SIMATIC Manager via Options > Set PG/PC Interface). 

Procedure in HW Config 
1. Double-click the device you want to configure with SIMATIC PDM in HW Config. 

The "User" dialog box opens. 
2. Select the "Specialist" option to access all the modification options. 
3. Click "OK". 
SIMATIC PDM opens. 

Procedure in the Process Devices Plant View 
1. In SIMATIC Manager, select the menu command View > Process Devices Plant View.  

The process devices plant view opens. 
2. Select the required station and the "Devices" object. 

All the existing devices are displayed. 
3. Select the required object and select the menu command Edit > Open Object. 

The "User" dialog box opens. 
4. Select the "Specialist" option to access all the modification options. 
5. Click "OK". 
SIMATIC PDM opens. 

Additional information 
● Manual PDM; The Process Device Manager 
● Online help on STEP 7 
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8.8.7.5 How to Configure HART Devices with SIMATIC PDM 

Introduction  
HART devices are intended for distributed operation on the IM 153-2 (ET 200M) or IM 152 
(ET 200iSP).  
Configuration with an ET 200M is illustrated below. 
Start SIMATIC PDM to assign parameters to the HART measuring transducers attached to 
the HART devices.  

Representing HART Transducers  
The transducers for HART modules are displayed like interface modules in the configuration 
table.  

Requirement 
You have opened a station with a DP master system and an ET 200M or ET 200iSP with 
free slots in HW Config. 

Procedure - Using the ET 200M as an Example 
Example: 
The HART module is inserted into Slot 4. The transducer for the first channel is then 
displayed as slot 4.1.  
1. Add an analog input module from the hardware catalog (6ES7 331-7TB00-0AB0) by 

dragging it to the ET 200M. 
2. Drag two “HART field device“ modules from the hardware catalog to below the analog 

input module. . 
3. Select the menu command Station > Exit. 

The hardware configuration is saved. 
4. Double-click the first field device. 

The "Insert SIMATIC PDM Tag Object(s)" dialog box opens. 
5. Enter a name (higher level designation) for the field device (tag) or select an object and 

confirm with "OK". 
The "User" dialog box opens. 

6. Select the "Specialist" option to access all the modification options. 
7. Click "OK".  

SIMATIC PDM opens. 
8. Configure your HART device in SIMATIC PDM. 
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Basic procedure - HART field devices on redundant HART AI/AO modules. 
The following basic configuration steps are to be carried out: 
1. Open HW Config and configure the required modules. 
2. Make the required settings in HW Config for module redundancy. 
3. Configure the channels of the modules with HART field devices.  

A field device needs to be configured on each of the two module channels that are 
redundant to one another. 

4. Open SIMATIC PDM.  
Opening SIMATIC PDM defines which device is being used. As a result, this also 
implicitly installs the relevant device on the redundant channel. 

Additional information 
● Manual PDM; The Process Device Manager 
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8.8.7.6 How to Configure Y Links and Y Adapters 

Introduction 
To implement the changeover from a PROFIBUS master system to a single-channel 
PROFIBUS master system, the Y link is preferred as the gateway.  
From the point of view of the programmable controller, the Y link is a DP slave, and from the 
point of view of the underlying DP master system, it is a DP master. 

Procedure 
1. Select the required SIMATIC H station from the component view and double-click the 

"Hardware" object in the detail window. 
The hardware configuration of the automation system is opened. 

2. Drag an IM 153-2 from the "PROFIBUS DP > DP/PA Link" hardware catalog to the 
redundant DP master system on your CPU. 
The "Properties - PROFIBUS Interface IM 153-2" dialog box opens. 

3. If necessary, change the suggested address for the IM 153-2 in the higher-level DP 
master system and click "OK". 
The dialog box for selecting the lower-level master system opens. 

4. Select "Interface module for PROFIBUS DP" and click "OK". 
The Y link is inserted into the redundant DP master system. The transmission rate of the 
lower-level DP master system is set to 1.5 Mbps as default. 

5. If you want to change the transmission rate of the lower-level DP master system, double-
click the DP master system.  
The dialog box with the properties of the lower-level master system opens. 

6. Click "Properties". The "PROFIBUS properties" dialog box is displayed. 
7. Enter the name of the lower-level DP master system and select the “Network Settings“ 

tab. 
8. Select the transmission speed 45.45 Kbps to 12 Mbps and click "OK". 
9. Then configure the DP slaves for the lower-level DP master system. 

Additional information 
● Manual SIMATIC; DP/PA Link and Y Link Bus Couplers 
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8.8.7.7 How to Use the Diagnostics in SIMATIC PDM 

Configuration Support  
Apart from the diagnostic options provided by the maintenance station, you can also use the 
diagnostic options provided by SIMATIC PDM to support you when configuring. 
Use "SIMATIC PDM - LifeList" to test which DP devices and HART device are accessible on 
the network.  
Information on the causes of any connection errors can be found in the online help for 
SIMATIC PDM. 

 

 Note 
SIMATIC PDM requires device-specific information for devices with diagnostic capability. 
After installing SIMATIC PDM you can supplement this information through the "Manage 
Device Catalog" tool. 

 

Additional information 
● Online help on STEP 7 
● Online help on SIMATIC PDM 
● Manual PDM; The Process Device Manager 
● Manual Process Control System PCS 7;Service Support and Diagnostics 
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8.8.8 Configuring Distributed I/O Devices for Configuration Changes in RUN Mode (CiR) 

8.8.8.1 Principle of Configuration Changes in RUN 

Introduction 
There are some process cells that must not be shut down during operation. This may be due 
to the complexity of the automated process or the high cost of restarting. Nevertheless, it 
may be necessary to extend or modify the plant.  
Using CiR (Configuration in RUN), it is possible to make certain changes to the configuration 
in RUN mode. 

Principle 
To be able to make changes to the process cell during operation using CiR, you must make 
provision for subsequent extending the hardware of your automation system specially for the 
master system in your original configuration. You define suitable CiR objects that you can 
later replace with real objects (slaves and/or modules) in the RUN operating state. You can 
then download a configuration modified in this way to the CPU while the process is running. 

Validity 
You can make modifications to the plant during operation with CiR in sections of the plant 
with a distributed I/O. 
CiR requires the configuration shown in the figure below. For the sake of clarity, the 
illustration shows only a DP and a PA master system.  
The configuration consists of the following components: 
● CPU (412, 414, 416, 417, firmware version 3.1.0 or later  

414H, 417H in stand-alone mode, firmware version V3.1.0 or later) 
● CP 443-5 Extended (firmware version 5.0 or later) 
● ET 200M: IM 153 (as of 6ES7153-2BA00-0XA00) 
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● ET 200iSP: IM 152 (as of 6ES7152-1AA00-0AB0) 
● DP/PA link: IM 153 (as of 6ES7153-2BA00-0XA00) 

 

Steps Involved 
The steps required for a program and configuration change and the associated process cell 
status are illustrated below. 
 
Step Meaning CPU operating mode Plant status 
1 Configure the actual (real) configuration of 

your plant 
STOP Offline configuration 

2 Initial configuration of suitable reserves (CiR 
elements) for future plant expansions 

STOP Offline configuration 

3 Downloading the configuration STOP Commissioning 
4 Conversion of the CiR objects to real objects 

as necessary.  
Plant modifications are only possible at 
master systems with a CiR object or for 
ET 200M/ET 200iSP stations with a CiR 
module. 

RUN Permanent 
operation 

If necessary, repeat the CiR procedure (step 4 in the table above) several times in 
succession. The only thing you then need to take into account is that you have adequate 
numbers of slaves and I/O volume in reserve so that you can implement all your plant 
expansions. 
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Recommendations for CiR 
Below, you will find several tips on making configuration modifications in RUN:  
● Following each modification to the configuration, create a backup copy of your current 

plant configuration. Only this back-up version will allow you to continue to work on the 
project without any loss of CiR capability. 

● Whenever possible, make the configuration modification in several steps and only make a 
few changes in each step. This means that you have a clear picture of the situation at all 
times. 

● To minimize the CiR synchronization time (CPU response after downloading the 
configuration in RUN), we recommend that you change only one DP master system in 
each reconfiguration step. 

● Take the number of CiR objects into account when defining the process image (address 
area). 

● Remember that the number of CiR objects influences the CiR synchronization time. You 
should therefore only configure as many CiR objects as necessary and as few as 
possible. 

● Make sure that you can also attach additional DP slaves in RUN. 
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8.8.8.2 Types of CiR Objects 

Terminology 
 
Term Meaning 
CiR element Generic term for CiR object and CiR module 
CiR object Placeholder for slaves to be added to the DP or PA master system later 
CiR module Placeholder for modules to be added to an ET 200M/ET 200iSP station later 

CiR elements 
 
Components CiR elements 
Available modular DP slave type 
ET 200M/ET 200iSP 

CiR module 
This contains the additional I/O volume and can be 
edited by the user. 

Existing DP master system CiR object 
This contains the number of additional DP slaves and 
can be edited by the user. 

Existing PA master system CiR object 
This contains the number of additional PA slaves and 
can be edited by the user. 

 
 

 Note 
When calculating the bus parameters, PCS 7 takes into account both the configured slaves 
and the CiR elements. As a result, when converting the CiR elements into real slaves and/or 
modules with the CPU in RUN, the bus parameters do not need to be changed. 

 

CiR objects 
Specify the following properties for a CiR object: 
● The guaranteed number of slaves that can be added  

(Default: 15 on the DP master system; 6 on the PA master system) 
● Number of input and output bytes for future use  

They relate to future user data addresses. Diagnostic addresses are configured 
separately from them.  
Default: 1220 each on the DP master system, 80 each on the PA master system). 

CiR modules 
For the modular I/O device ET 200M/ET 200iSP, define additional I/O volume using a CiR 
module by specifying the total number of additional input and output bytes. This information 
relates to future user data addresses. You can configure diagnostic addresses regardless of 
this. 
You do not have to fully utilize the additional user data volume. The currently available user 
data volume must not, however, ever be exceeded. PCS 7 makes sure this is the case. 
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8.8.8.3 Overview of the Permitted Configuration Changes 

Overview of Supported Configuration Changes 
The following table lists all the configuration changes that are supported and not supported: 
 

Supported Configuration modification 
Yes No 

Adding modules to the modular DP slave ET 200M, providing you have not include it as 
a DPV0 slave (using a GSD file) 

X  

Modifying parameters of ET 200M modules, for example, selecting other alarm limits or 
using previously unused channels 

X  

Replacing reserve modules with the electronic modules of the ET 200iSP X  
Changing parameter settings of ET 200iSP modules X  
Adding DP slaves to an existing master system, however, not I slaves X  
Adding PA slaves (field devices) to an existing PA master system X  
Adding DP/PA couplers after an IM 153-2 X  
Adding PA links (including PA master systems) to an existing DP master system X  
Assigning added modules to a process image partition X  
Changing the arrangement of process image partitions for existing modules or compact 
slaves 

X  

Changing the parameter settings for existing modules in ET 200M stations  
(Standard modules and fail-safe signal modules in standard mode) 

X  

Reversing changes: added modules, DP slaves and PA slaves (field devices) are 
removed again. 

X  

Changing CPU properties  X 
Changing properties of central I/O modules  X 
Adding and removing DP master systems  X 
Changing properties of existing DP master systems, including the bus parameters, 
settings relating to constant bus cycle time 

 X 

Changing parameter settings of fail-safe signal modules in safety mode  X 
Changing the following parameters of a DP slave:  
• Bus address 
• Assignment to the DP master 
• Parameter assignment data 
• Diagnostic address 

 X 

Removing any modules from modular DP slaves  
(Only the module that was plugged in last can be removed.) 

 X 

Removing any DP slaves from an existing DP master system  
(Only the slave with the highest address can be removed.) 

 X 

Changing the configuration of an I slave interface  X 
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 Note 
If you want to add or remove slaves or modules or make a change to the existing process 
image partition assignment, this is possible for up to four DP master systems. 
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8.8.8.4 How to Define CiR Elements for Future Plant Expansion (CPU-STOP) 

Defining the CiR Elements      
For DP master systems, the "Activate CiR Capability" function is available. With this function, 
a CiR object is generated in the selected DP master system and in every lower-level PA 
master system with CiR capability. A CiR module is inserted in each modular slave with CiR 
capability of the type ET 200M/ET 200iSP of the selected DP master system.  
You can add CiR elements either automatically or individually. 

Activating the CiR Capability 
Before the download of configuration data only in RUN is possible in your plant, you must 
prepare your project for CiR capability. You are supported in this by a system wizard. The 
wizard automatically creates a CiR object for each DP chain and a CiR module for each 
configured station with CiR capability (ET 200M, ET 200iSP, DP/PA).  
The wizard sets the following I/O areas for future CiR activities.  
● 1220 bytes I and Q each per DP chain with CiR capability 
● 15 slaves per DP chain with CiR capability 
● 80 bytes per ET 200M line 
● 180 bytes per ET 200iSP line 
● 6 CiR-capable slaves per CiR object on the equipotential bonding line (address space 

max. 80 bytes total) 
The default settings were selected so that they are sufficient for typical applications and do 
not need to be adapted. Check if these default values are sufficient for your application and 
modify them if necessary at individual stations or on a chain before the first download. 

 

 Note 
The rule of thumb for the reserves is: As little as possible – as much as necessary, since the 
CiR synchronization time depends on the size of the reserves. 
The CiR synchronization time is relevant when you activate a configuration change in RUN. 
A CiR action interrupts operation on the AS at a maximum for this time. This is limited on the 
system side by an upper limit of 1 second and is monitored by the system. During this time, 
process outputs and process inputs are kept at the last valid values. 
Make sure that you do not exceed a CiR synchronization time of 1 second.  
The SFC 104 must not be used to set the CiR synchronization time with PCS 7 (it can cause 
the CPU to STOP). 
• We recommend that you only make the changes on one DP chain at a time, using small 

steps and when starting a CiR. This will make it easier to monitor the changes in RUN. 
• If your changes in RUN relate only to a DP chain, the maximum CiR synchronization time 

is displayed when you select the CiR object. 
• If you want to make changes to more than one chain at the same time, add the times of 

the individual chains together. 
• When you download the configuration data to the CPU, you will once again be informed 

whether the CiR synchronization time is possible with the settings you have made. 
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Inserting CiR Elements Automatically 
1. In HW Config, select the desired DP master system in the upper section of the station 

window. 
2. Select the menu command Edit > Master System > Deactivate CiR Capability. 

The PCS 7 adds the following CiR elements to the selected DP master system: 
– (provided there are still free slots) a CiR module on every ET 200M/ET 200iSP-type 

modular slave with CiR capability 
This CiR object contains as many input and output bytes as necessary to ensure that 
there is a sensible number of input and output bytes available on the modular slave for 
later use. 

– a CiR module on every lower-level PA master system with CiR capability 
This CiR object contains as many input and output bytes as necessary to ensure that 
the maximum number of input and output bytes (maximum 80 each) is occupied on 
the PA master system. 

– a CiR module on the selected DP master system 
PCS 7 attempts to guarantee 15 slaves for the CiR object and to make 1220 input 
and 1220 output bytes available.  
If the previous highest address in this master system is greater than 111, the number 
of slaves that can be guaranteed is reduced accordingly. If fewer than 1220 input 
and 1220 output bytes are available, the number is reduced accordingly. 

 

 
 

Note 
Please note the following: 
• CiR elements can only be added automatically if there is no CiR object already in 

the selected DP master system. 
• CiR elements cannot be automatically added to DP master systems downstream of 

an IM 153-2. 
• If CiR capability is activated, slaves containing a CiR module and CiR objects (for 

example, DP/PA link) are indicated in orange. 
 

3. The defaults of the CiR objects are identical for all CPUs. Therefore, after activating the 
CiR capability of a master system, each corresponding CiR object should be checked for 
the following: 
Does the CiR synchronization time of the master system specified in the properties 
window for the CiR object match the high limit for the CiR synchronization time of the 
CPU set on the CPU? 
If necessary, you will have to reduce the number of guaranteed slaves in one or more 
CiR objects. 
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Inserting a CiR Object to the DP or PA Master System 
1. In HW Config, select the desired master system in the upper section of the station 

window. 
2. Use the menu command View > Catalog to open the hardware catalog. 
3. Drag the associated CiR object from the hardware catalog to the master system.  

The CiR object then appears as a placeholder slave at the top of the station window. The 
following default values are set for the CiR object: 
– Number of guaranteed additional DP slaves: 15 on the DP master system; 6 on the 

PA master system 
– Maximum number of additional slaves: 45 DP slaves, 36 PA slaves 
– Number of input bytes: 1220 for a DP, 80 for a PA master system 
– Number of output bytes: 1220 for a DP, 80 for a PA master system 

4. The defaults of the CiR objects are identical for all CPUs. Therefore, after defining a CiR 
object, check the following: 
Does the CiR synchronization time of the master system specified in the properties 
window for the CiR object match the high limit for the CiR synchronization time of the 
CPU set on the CPU? 
If necessary, you will have to reduce the number of guaranteed slaves in the CiR object. 

 

 
 

Note 
If there are no longer enough resources available on the master system, these values are 
reduced accordingly. The resulting bus parameters "Target Rotation Time", "Target 
Rotation Time Typical" and "Watchdog" are displayed in the properties window for the 
CiR object. 

 

Changing the Number of Additional Slaves and/or Number of Input and Output Bytes 
1. In HW Config, select the desired CiR object. 
2. Select the menu command Edit > Object Properties... 

The "Properties" dialog box opens. 
3. You can change the guaranteed number of additional slaves as required.  

The resulting bus parameters Target Rotation Time, Target Rotation Time Typical and 
Watchdog are displayed at the bottom of the station window. 

4. Change the number of input and output bytes as required.  
To do this, check the "Advanced Settings" check box (default). Do not increase the 
number as this will increase the CiR synchronization time. 
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Inserting a CiR Module in a Modular ET 200M/ET 200iSP Slave 
1. In HW Config, select the desired DP slave in the upper section of the station window. 
2. Use the menu command View > Catalog to open the hardware catalog. 
3. Drag the CiR module from the hardware catalog to the slot immediately after the last 

configured module of the DP slave at the bottom of the station window.  
The CiR module appears at the bottom of the station window as a dummy module. 
The number of input and output bytes appears in the properties window of the CiR 
module.  
For ET 200M stations, this is as follows: 
– Number of input bytes = Number of free slots * 16 
– Number of output bytes = Number of free slots * 16 
In an ET 200M station that only contains one CiR module, these values are 8 x 16 = 128 
(if the CiR object in the DP master system still has enough free input and output bytes). 

 

 
 

Note 
A maximum of 244 input and output bytes are available for ET 200iSP. You can find more 
information about this in the manual SIMATIC; Distributed I/O Device ET 200iSP. 

 

Downloading the Configuration in STOP Mode 
Once the CiR elements have been defined, the configuration is downloaded with the CPU in 
STOP mode. 
Numerous modules can be used in an S7-400 automation system. To make sure that none 
of the modules used prevents future CiR activities, keep to the following procedure:  
Once you have downloaded the configuration to the CPU in STOP mode, download the 
configuration again immediately, this time with the CPU in RUN mode.  
PCS 7 and the CPU both check CiR capability during this. With older modules or modules 
from other vendors, this check is not yet possible offline. 
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8.8.8.5 How to Delete CiR Elements (CPU-STOP) 

Introduction  
In STOP mode, you can delete CiR objects in DP and PA master systems or CiR modules in 
modular slaves of the type ET 200M/ET 200iSP that you are defined earlier.  
The configuration change does not depend on the operating state. It can only be 
downloaded in STOP mode, however.  

Deleting All the CiR Elements of a DP Master System 
1. In HW Config, select the desired DP master system in the upper section of the station 

window. 
2. Select the menu command Edit > Master System > Deactivate CiR Capability. 

The following CiR objects are deleted: 
– All CiR objects in lower-level PA master systems are deleted. 
– All CiR modules in modular slaves are deleted. 
– The CiR object in the selected DP master system is deleted. 

 

 
 

Note 
Please note the following: 
• CiR elements can only be deleted if there is a CiR object in the selected DP master 

system. 
• You cannot delete all CiR elements on the DP master system below an IM 153-2 

(DP/PA link). 
 

Deleting an Individual CiR Element 
If you want to delete the CiR module in a PA master system or in a modular DP slave of the 
type ET 200M/ET 200iSP, proceed as follows: 
1. In HW Config, select the CiR element you want to delete. 
2. Select the menu command Edit > Delete. 
If there is no further CiR element in the DP master system except for the CiR object, you can 
delete the CiR object using the same procedure. 
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8.8.8.6 How to Convert CiR Elements into Real Objects (CPU-RUN) 

Default Settings for a New Station    
When you add a new station to a chain, the following I/O areas are set for this station by 
default: 
● 80 bytes I and Q each for an ET 200M per CiR module 
● 80 byte I and Q for a DP/PA station for each CiR object in the DP/PA chain. 
These default settings were selected so that they are sufficient for typical applications and do 
not need to be adapted. Before you download first-time, check whether these station-specific 
I/O settings are adequate for your application. You can modify these values prior to 
downloading for the first time without losing the CiR capability of the project. 

 

 Note 
If you attempt an illegal operation when adding real slaves or modules to the configuration, 
you will only be made aware of this by an error message when you download the 
configuration. 
After any change to the process cell, you should use the menu command Station > Check 
CiR Capability to check that the CiR capability still exists. 

 

Rules 
When adding components, keep to the following rules: 
● Within a type ET 200M/ET 200iSP modular DP slave, you may only insert a CiR module 

at the slot immediately after the last configured module.  
This rule is automatically taken into account when you add CiR elements automatically. 

● Within a master system, you must assign a higher PROFIBUS address to the added 
slave than the highest address used up to now. 

● With the ET 200iSP, you can insert or remove only one module per station and download. 



Implementing the PCS 7 Configuration  
8.8 Configuring the Hardware 

 Engineering System (V7.1) 
408 Configuration Manual, 03/2009, A5E02122455-01 

Adding a DP or PA Slave 
1. Use the menu command View > Catalog to open the hardware catalog. 
2. Drag the slave you want to add from the hardware catalog and onto the relevant CiR 

object at the top of the station window. 
The added slave appears at the top of the station window. The name of the slave is 
displayed on an orange background to indicate that this slave was created from a CiR object. 

 

 Note 
When you add a new slave, PCS 7 updates the guaranteed and the maximum number of 
slaves and number of input and output bytes of the CiR object. 
We recommend you select the station number of the added DP slave as follows:  
Station number =  
highest station number of all previously configured DP slaves + 1 
If you add a type ET 200M/ET 200iSP CiR-compliant modular DP slave, this will have a CiR 
module right from the start. 

 

Inserting Modules in a Modular ET 200M/ET 200iSP Slave 
1. Use the menu command View > Catalog to open the hardware catalog. 
2. Drag the module you want to add from the hardware catalog and onto the relevant CiR 

module at the bottom of the station window. 
The module you have added appears at the bottom of the station window at the location 
previously occupied by the CiR module. The CiR module is moved one slot down. 

 

 Note 
When you add a module to an ET 200M-/ET 200iSP station, PCS 7 updates the number of 
input and output bytes of the corresponding CiR module. 

 



 Implementing the PCS 7 Configuration 
 8.8 Configuring the Hardware 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 409 

Result 
In the following figure, you can see the configuration in HW Config view after placing a 
module on the CiR module. 
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Downloading the Configuration in RUN Mode 
The following steps are used to download a modified configuration in RUN mode:  
1. Check that the current configuration can be downloaded with the menu command 

Station > Check CiR Capability. 
2. Download the configuration to the CPU with the menu command PLC > Download to 

Module.... 
 

 
 

Note 
When you download the configuration to the CPU, the INTF LED lights up and then goes 
off again, the EXTF LED is lit permanently. First begin to add the real stations or modules 
when the INTF LED goes out again. The EXTF LED then also goes off again. 

 

3. Back up your current configuration every time you download the station configuration 
from HW Config (regardless of the operating state of the CPU).  
This is the only way to make sure that you can continue working and not lose CiR 
capability if an error occurs (loss of data). 
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8.8.8.7 How to Undo Used CiR Elements (CPU-RUN) 

Introduction 
You can reverse previous configuration changes that you have downloaded to the CPU by 
removing the slaves or modules that you added. 

Rules 
The following rules apply when removing modules and slaves: 
● Remove at most slaves or modules from a maximum of 4 master systems. 
● Within a DP or PA master system, start by removing the slave with the highest 

PROFIBUS address.  
Then continue with the slave with the next highest PROFIBUS address. 

● Within a type ET 200M/ET 200iSP modular DP slave, start by removing the module with 
the highest slot number. In HW Config, this is the lowest module.  
PCS 7 offers the following diagnostic features: The module to be removed next is entered 
in the lower section of the station window in the standard font, all other modules are in 
italics.  
Then continue with the module with the next highest slot number. 

Procedure 
1. Select the object to be removed in the upper section of the station window. 
2. Select the menu command Edit > Delete. 
3. If necessary, repeat steps 1 and 2 for every other object that you want to remove. 
4. Select the menu command Station > Check CiR Compatibility. 
5. Download the modified configuration to the CPU. 

 

 
 

Note 
Please note the following: 
• When you delete a slave, PCS 7 updates the guaranteed and the maximum number of 

slaves and the number of input and output bytes of the associated CiR object. 
• When you delete a module in a modular slave of the type ET 200M/ET 200iSP, PCS 7

updates the number of input and output bytes of the corresponding CiR module. 
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8.8.8.8 Changing the Parameter Settings for Existing Modules in ET 200M / ET 200iSP Stations 
(CPU RUN) 

Changing the Module Parameter Assignments in RUN Mode  
PCS 7 allows you to change the module parameters during operation without a CPU STOP, 
e.g.: 
● Enabling reserved channels 
● Changing operating modes 
● Changing measuring modes 
Depending on the performance class of the module, the module parameters can be changed 
in RUN mode without affecting other modules or, with some restrictions, even without 
affecting the channels of the module at which the parameters are to be changed.  
When module parameters are changed via CiR, there is a maximum CiR synchronization 
time of 100 ms. 
When you add a module to PCS 7 projects using HW Config, remember to activate the 
general module-oriented diagnostic alarm. 

 

 Note 
The addresses of existing modules must not be changed with CiR. 

 

Requirements 
● A CiR object exists in the DP master system to be configured. 
● The number of modules to be modified is less than 100. 
For details of the ET 200M-/ET 200iSP modules that can have parameters changed while 
the CPU is in RUN mode, refer to the information text in the hardware catalog (text: online 
configuration). 

Module Response when Parameters Are Changed 
Input and output modules respond as follows when parameters are changed: 
● With input modules, the following three reactions are possible when changing parameter 

settings: 
– Channels that are not affected continue to return the current process value. 
– Channels that are not affected return the last valid process value prior to changing the 

parameter settings. 
– All channels return value "0" (on digital modules and FMs) or W#16#7FFF (on analog 

modules). 
● Output modules react as follows when parameter settings are changed: 

– Channels that are not affected output the last valid output value prior to changing the 
parameter settings. 
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CPU Response when Parameters Are Changed 
Once you have changed the parameters in PCS 7 and have downloaded them to the CPU in 
RUN mode, the response is as follows: 
1. The CPU performs the checks described in the section "Reaction of the CPU after 

Downloading Configuration Changes in CPU RUN (Page 422)". 
2. The CPU starts OB 80 with the event W#16#350A. 
3. The CPU starts OB 83 with the event W#16#3367.  

This indicates that the input or output data for the modules concerned may no longer be 
correct - with immediate effect.  
You must not call any more SFCs that trigger new jobs to send data records to the 
affected modules (for example, SFC57 "PARM_MOD"), otherwise there may be a conflict 
between the data records sent by the system and those sent by the user. 

 

 
 

Note 
in PCS 7, the input and output values have the status "BAD" after this OB 83 start. 

 

4. Once the CPU has ended OB 83, it sends the parameter data records. Every affected 
module receives all of its data records, regardless of how many data records are affected 
by your change. 

5. OB 83 is then started again (start event W#16#3267 if sending was successful, or 
W#16#3968 if it was not successful). No other priority class is interrupted by running this 
OB 83. 

 

 
 

Note 
In PCS 7, the input and output values have the status "OK" after the OB 83 start with the 
start event W#16#3267. 

 

You can only access values in the process image that belong to the process image 
partition of the OB currently executing. 

6. If the data records were transferred successfully, the DP master identified the modules as 
available in the module status data..  
If the data records were not transferred successfully, the DP master identified the 
modules as unavailable in the module status data. In the second situation, an I/O access 
error occurs when the module is accessed (while updating the process input image or 
while transferring the process output image to the module or when accessing the module 
directly. This starts OB85.) 

7. The input or output data from the modules reacts as it does after a plugging-in alarm: At 
the current time they are not correct because the module may not have analyzed its data 
records yet. The restriction that data record SFCs must no longer be active for the 
module does not, however, apply any longer. 

 

 
 

Note 
If changing the parameter assignments for a module consists of deactivating the 
diagnostic alarm, for example, it is possible that the module may still send an alarm that 
has already been prepared. 
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Possible Errors when Changing Parameter Assignments 
The same errors can be made as when transferring data records with SFCs: 
● The module receives the parameter data records but cannot evaluate them. 
● Serious errors (particularly protocol errors on the PROFIBUS DP) can cause the DP 

master to suspend the associated DP slave completely. All the modules of this station 
would then fail. 

How CPU Operating States Affect Changes to Parameter Assignments 
The parameter setting change takes place following SDB evaluation in RUN. While the 
parameters are being changed, the INTF LED is lit. 
If there is a change to the HALT state, the parameter change is interrupted. It is continued if 
the CPU changes to STOP or RUN. In STOP, only the OB83 calls are omitted. 
If there is a network failure, the parameter change is aborted. When the network returns, the 
parameters of all existing DP stations are reassigned. 

Coordination between Master Systems 
In some situations, the following sequence may run in parallel in the affected master 
systems. 
● OB83 start (start event W#16#3367) 
● Data record transfer 
● OB83 start (start event W#16#3267 or 3968) 
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8.8.8.9 How to Change the Parameter Assignments of a Channel (CPU-RUN) 

Procedure - Using an Unused Channel 
1. Change the hardware configuration and check CiR compliance with the menu command 

Station > Check CiR Compliance. 
2. Download the hardware configuration to the CPU in RUN mode. 
3. Change the wiring. 
4. Modify the user program and download it to the CPU. 

Procedure - Reprogramming a Used Channel 
The procedure depends on whether changes to the user program and the corresponding 
hardware are necessary due to be changed parameters. The individual situations are 
described below. 
The user program may not be changed: 
This is the case, for example, when changing an alarm limit or when deactivating the 
diagnostic interrupt. 
1. Change the hardware configuration and check CiR compliance with the menu command 

Station > Check CiR Compliance. 
2. Download the hardware configuration to the CPU in RUN mode. 
The user program must be changed: 
This is the situation, for example, if you change the measuring range of the channel of an 
analog input module and you compare the corresponding analog value with a constant in 
your program. In this case, the constant must be adapted. 
1. Set the values of the channel for which you want to change parameters to simulation (at 

the corresponding driver). 
2. Change the hardware configuration and check CiR compliance with the menu command 

Station > Check CiR Compliance. 
3. Download the hardware configuration to the CPU in RUN mode. 
4. Adapt the user program to the changed module and download it to the CPU. 

Cancel the simulation for the channel with the changed parameter assignment again (at 
the corresponding driver). 

User program and hardware must be changed 
This is, for example, the situation when you change the parameters of an input channel from 
"0 mA to 20 mA" to "0 V to 10 V". 
1. Set the values of the channel for which you want to change parameters to simulation (at 

the corresponding driver). 
2. Change the hardware configuration and check CiR compliance with the menu command 

Station > Check CiR Compliance. 
3. Download the hardware configuration to the CPU in RUN mode. 
4. Adapt the user program to the changed module and download it to the CPU. 

Cancel the simulation for the channel with the changed parameter assignment again (at 
the corresponding driver). 
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Change the address range of an electronic module (ET 200iSP) 
This is the case, for example, when IEEE values of a HART electronic module are used. 
1. Set the values of the channel for which you want to change parameters to simulation (at 

the corresponding driver). 
2. Delete the module in the hardware configuration and download it to the CPU. 
3. Insert the module again and assign the parameters as required. 

 

 
 

Note 
Never save your hardware configuration at this point; otherwise the CiR download 
capability will be lost. 

 

4. Download the hardware configuration to the CPU in RUN mode. 
5. Adapt the user program to the changed module and download it to the CPU.  

Cancel the simulation of the module with the changed parameter assignment again (at 
the corresponding driver). 

Procedure - Removing a Used Channel 
If you no longer need a channel that has been used up to now, you do not have to change 
the hardware configuration. In this case, follow the steps below: 
1. Change the user program so that the channel to be removed is no longer evaluated, and 

download it to the CPU. 
2. Change the hardware configuration and check CiR compliance with the menu command 

Station > Check CiR Compliance. 
3. Download the hardware configuration to the CPU in RUN mode. 
4. Modify the associated hardware (e.g. remove sensor or actuator) 
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8.8.9 High-Precision Time Stamps 

8.8.9.1 How to Configure the Hardware for the High-Precision Time Stamps 

Highly Accurate Detection of Binary Signals  
If you require highly accurate analysis of the process signals for a selected area, you can 
use high-precision time stamps with the ET 200M/ET 200iSP. 
Possible fields of use of high/precision time stamps: 
● Accurately-timed detection of problems in process-related equipment. Time stamping 

enables you to explicitly identify signals that indicate the cause of the failure of a process 
unit. 

● Analysis of system-wide interrelationships 
● Detection and reporting of the sequence of time-critical signal changes 

 

NOTICE  
 

Time stamps should only be used for selected signals that are of importance to the 
process. They must NOT be used for every binary signal that is read. 
On the other hand, it is possible for lots of signals to be signaled at the same time (for 
example, when a fault occurs). This increases the risk of messages being lost due to 
buffer overflow. 

 

Requirement for the Time Stamp 
The time-of-day must be synchronized on all the devices belonging to the system. This 
requires a connection to a time master. 

Description with Step-by-step Instructions 
● You will find detailed step-by-step instructions on configuring high-precision time stamps 

in the Function Manual Process Control System PCS 7; High-precision Time Stamps. 
● You will find a full description and step-by-step instructions for configuring an OS server 

as the time-of-day master in the configuration manual Process Control System PCS 7; 
Operator Station. 
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8.8.10 Acknowledgment-triggered reporting 

8.8.10.1 How to Activate Acknowledgment-triggered Reporting (QTM) 

Introduction     
If signals that trigger messages change their state in quick succession, a flurry of messages 
can be triggered. This can mean that the state of a plant is no longer adequately monitored.  
By configuring the "acknowledgment-triggered reporting (ATR)" function, you can suppress 
the repeated signaling of "fluttering" states until an acknowledgment is received. 

Procedure 
1. Select the required station in the component view. 
2. Double-click the "Hardware" object in the detail window. 

The HW Config and hardware catalog open. 
3. Select the CPU. 
4. Select the menu command Edit > Object Properties.... 

The "Properties - ("CPU-xxx")" dialog box opens. 
5. In the "Diagnostics/Clock" tab, activate the "Acknowledgment-triggered reporting of 

SFB 33-35" check box in the "System Diagnostics" group. 

Result 
SFBs 33 to 35 then only report a change of signal if the previous change of signal (the 
previous incoming message) has been acknowledged.  



 Implementing the PCS 7 Configuration 
 8.8 Configuring the Hardware 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 419 

8.8.11 Downloading the Configuration to the CPU 

8.8.11.1 How to Download the Configuration in CPU-STOP 

Introduction      
Hardware configuration of the SIMATIC stations is completed.  
First save and compile the hardware configuration you have created and then pass on the 
information to the CPU.  

Rules 
 

 Note 
In some situations it is possible to download the hardware configuration during operation 
(CPU in RUN). You can find a list of the configuration changes (CiR) you are allowed to 
make in RUN in the section titled "Overview of the permitted configuration changes 
(Page 400)". 
Other configuration changes mean that the hardware configuration can only be downloaded 
when the CPU is in STOP!  

 

Requirements 
● The data link from the engineering station to the automation system must be working. 
● The hardware configuration of the automation systems to be loaded opens. 
● The SIMATIC station is in the STOP operating state. 

Procedure 
1. Select the menu command Station > Save and Compile in HW Config.  

Existing consistency errors are signaled to you. Click "Details" for detailed information 
about the errors that have occurred. 

2. Select the menu command CPU > Download to Module.  
The "Select Target Modules" dialog box opens. 

3. Select the target module and click "OK". 
The "Select node address" dialog box opens. 

4. Click the "Refresh" button. 
All the nodes that can be reached are listed in the "Accessible Nodes" group. 

5. Select the required node and click "OK". 
The configuration is loaded into the PLC. 
If the change log is activated, it opens. Enter a comment here in the "Reason" group and 
click "OK". 

6. On completion of the download, restart the CPU. 
7. Select the menu command Station > Exit to close the hardware configuration. 
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Result 
Your project is created, for example, with the following structure in the component view.  

 

Source Files and Blocks 
● The source texts of the user blocks and the SCL source files generated by CFC/SFC are 

stored in the "Sources" folder. 
● Standard and user blocks and blocks generated by CFC/SFC (e.g. instances) are stored 

in the "Blocks" folder. 
● The "Charts" folder contains CFC charts, nested charts (chart in chart) and SFC charts. 
● Enumerations, units and equipment properties are saved in the "Shared Declarations" 

folder. 

Plant Changes in the Runtime on an H System 
For more detailed information about making "Plant changes in RUN" in H systems, refer to 
the manual S7-400H Programmable Controller, Fault-tolerant Systems 
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8.8.11.2 How to Download Configuration Changes in CPU RUN (CiR) 

Requirements        
● The changed hardware configuration must be complete. 
● The changed hardware configuration must have been saved and compiled. 

Procedure 
1. Check that the current configuration can be downloaded with the menu command 

Station > Check CiR Capability. 
2. Select the menu command Station > Save and Compile in HW Config. 
3. Download the configuration to the CPU with the menu command PLC > Download to 

Module.... 
 

 
 

Note 
Please note the following: 
• If the configuration changes cannot be downloaded, close HW Config without saving. 

This avoids inconsistencies between the configuration in the CPU and on the ES. 
• When you download the configuration to the CPU, the INTF LED lights up and then 

goes off again, the EXTF LED is lit permanently. You cannot start to add the real 
stations or modules until the INTF LED goes out again. The EXTF LED then also goes 
off again. 

 

Recommendation 
Back up your current configuration whenever you download the station configuration from 
HW Config, regardless of the operating state of the CPU. This is the only way to make sure 
that you can continue working and not lose CiR capability if an error occurs (loss of data).  

Additional information 
● Online Help for HW Config 
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8.8.11.3 Reaction of the CPU after Downloading Configuration Changes in CPU RUN (CiR) 

CPU Response after the Configuration Is Downloaded in RUN Mode 
After downloading a modified configuration, the CPU initially checks whether the 
modifications are permitted. If they are, it analyzes the affected system data. 
This analysis affects important operating system functions, such as updating of the process 
image and editing of the user program. These effects are explained in detail below. 
The time taken for the CPU to interpret the system data (known as the CiR synchronization 
time) depends on the number of input and output bytes in the affected DP master system. 
The default synchronization time is up to 1 second. This value cannot be changed. 
At the start of the system data evaluation, the CPU enters event W#16#4318 in the 
diagnostic buffer and on completion of the evaluation it enters the event W#16#4319.  

 

 Note 
If a Power Off occurs while the system data is being analyzed or the CPU switches to STOP 
mode, the only practical course is to run a warm restart. 

 

Once the system data has been analyzed, the CPU starts OB 80 with event W#16#350A and 
enters the duration of the analysis in its start information. This allows you, for example, to 
consider this time in your cyclic interrupt OBs for control algorithms. 

 

 Note 
Make sure that OB80 is always loaded on your CPU. Otherwise the CPU switches to STOP 
when an OB 80 start event occurs. 

 

Validation of the Required Configuration Change by the CPU 
The CPU first calculates the number of DP and PA master systems on which you are adding 
or removing slaves or modules or wish to change the existing process image partition 
assignments. At a maximum of 4 affected master systems, the CPU continues the check, at 
more than 4, it rejects the modified configuration.  
In the next step, the CPU calculates the CiR synchronization time as follows: 
● If you are only changing parameter settings for existing modules, the following applies 

regardless of the CPU type:  
CiR synchronization time of the CPU = 100 ms 

● In all other situations, the following applies:  
The CiR synchronization time of the CPU is the sum of the CiR synchronization times of 
the relevant master systems. The relevant master systems are those in which you add or 
remove slaves or modules, or change the existing partial process image assignment. 
CiR synchronization times of the relevant master system =  
Basic load of the master system + total I/O volume of the master system in bytes * time 
per byte. 
The total I/O volume of the master system is the sum of the existing real input and output 
bytes of the CiR elements in this master system. To calculate the basic load of a master 
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system and the time per byte for a specific CPU type, refer to the technical specifications 
of your CPU. 

 

 
 

Note 
CiR synchronization time: 
• The CiR synchronization time calculated in this way is based on a worst-case 

scenario. This means that during CiR, the actual CiR synchronization time is always 
less than or equal to the calculated time. 

• The CiR synchronization time of a master system is displayed in the properties 
window of the CiR object in HW Config. 

 

The following figure shows the relationship between the CiR synchronization time of a 
master system and its entire I/O volume based on the example of a CPU 417-4. 

CiR synchronization in ms

*  corresponds to the maximum address area of the MPI interface, for example
   (2 K inputs + 2 K outputs)

** corresponds to the maximum address area of an external DP interface module, 
    for example (4 K inputs + 4 K outputs)

Total I/O 
volumes in bytes

 
Based on this diagram, you can easily obtain the maximum size of the master system based 
on the maximum CiR synchronization time if you only make changes to one DP master 
system. This is explained with reference to an example in the "Example for defining the size 
of a DP master system" section.  
The CPU now compares the calculated CiR synchronization time with the current high limit 
for the CiR synchronization time. The fixed upper limit set in PCS 7 for the CiR 
synchronization time is 1 s.  
If the calculated value is less than or equal to the current upper limit, the CPU assumes the 
changed configuration, otherwise it rejects it. 



Implementing the PCS 7 Configuration  
8.8 Configuring the Hardware 

 Engineering System (V7.1) 
424 Configuration Manual, 03/2009, A5E02122455-01 

Modifying the CiR Synchronization Time  
From the formula above, it is clear that the CiR synchronization time can be modified as 
follows: 
The CiR synchronization time is reduced: 
● The fewer input and output bytes are selected for a master system 
● The fewer guaranteed slaves are selected for the master systems to be changed (the 

number of guaranteed slaves thus directly affects the number of input and output bytes) 
● The fewer master systems to be changed in one CiR action 
This is of particular significance for F systems. Here, the F monitoring time must include the 
CiR synchronization time. The highest value of all the DP master systems with a CiR object 
must be used (if only one DP master system is modified per CiR action) or the sum of the 
master systems to be modified at the same time. 

Example Calculation 
The following table is an example of a CPU 417-4 with six DP master systems.  
The maximum permitted CiR synchronization time is 550 ms. This allows changes to be 
made to several DP master systems, provided that the sum of the CiR synchronization times 
of these master systems does not exceed 550 ms. From the last column, you can see which 
DP master systems can be modified in one CiR action. 

 
DP master 
system 

Total I/O 
Vol. in Bytes 

CiR Synchronization Time of the Master System Distribution of Changes to DP 
Master Systems 

1 1500 100 ms + 1500 bytes * 0.12 ms/byte = 280 ms either 1 (280 ms) or  
(1 and 2) (500 ms) 

2 1000 100 ms + 1000 bytes * 0.12 ms/byte = 220 ms either 2 (220 ms) or  
(2 and 1) (500 ms) or  
(2 and 3) (500 ms) 

3 1500 100 ms + 1500 bytes * 0.12 ms/byte = 280 ms either 3 (280 ms) or  
(3 and 2) (500 ms) 

4 2,500 100 ms + 2500 bytes * 0.12 ms/byte = 400 ms 4 (400 ms) 
5 3,000 100 ms + 3000 bytes * 0.12 ms/byte = 460 ms 5 (460 ms) 
6 7,000 100 ms + 7000 bytes * 0.12 ms/byte = 940 ms Cannot be modified! 

Example for Defining the Size of a DP Master System  
This assumes a maximum CiR synchronization time of 400 ms. The diagram thus gives a 
maximum total configuration of 2500 I/O bytes for the DP master system (dashed line). If you 
intend to have 250 input and 250 output bytes in the CiR object for future use, you therefore 
have 2000 bytes available for the initial configuration of the DP master system.  
Two constellations are considered by way of example:  
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● If ET 200M stations are used with a full configuration (128 bytes for inputs, 128 bytes for 
outputs, some of which may be in CiR modules), you can operate 2000/(128 + 128), i.e. 
approximately 8 ET 200M stations. 

● If you typically require 48 bytes per ET 200M station (e.g. 6 analog modules each with 
four channels of 2 bytes or a smaller configuration with a CiR module), you can therefore 
operate 2000/48, i.e. approximately 42 ET 200M stations. 

If such a configuration is insufficient, you can improve the situation as follows:  
● Use a more powerful CPU (CPU with a smaller time per byte - you will find more 

information on this topic in the technical specifications for the CPU). 
● Select several smaller master systems rather than one large master system. 
● Select one or more master system is with a very large configuration and a CiR object with 

no guaranteed slaves. In such master systems, only changes to parameter settings for 
existing modules are possible within the framework of CiR. Select additional small master 
systems in which you add or remove slaves or modules, or change the existing process 
image partition assignment. 

Error Displays 
From the beginning of the validation until completion of the SDB evaluation, the INTF LED is 
lit. It is also lit when the parameters of modules are reassigned. 
On completion of the CiR action, there is a difference between the expected and actual 
configuration (the expected configuration has changed because you downloaded a 
configuration change to the CPU); as a result, the EXTF LED lights up. If slaves are added 
when the configuration is changed, the BUS1F or BUS2F LEDs also flash. Once you have 
performed the relevant hardware changes, the EXTF, BUS1F and BUS2F LEDs go out 
again. 

Effects on the Operating System Functions during the CiR Synchronization Time 
During the CiR synchronization time, the operating system functions respond as follows: 

 
Operating System Function Effects 
Process image updating Updating of process images is disabled. The process input and output images 

are kept at their current values. 
User program execution All priority classes are locked; in other words, no OBs are processed. All 

outputs are maintained at their current value. Existing interrupt requests are 
retained. Any interrupts occurring are accepted by the CPU only after 
completion of the SDB evaluation. 

Target system Timers continue to run. The clocks for time of day, cyclic, and delayed 
interrupts continue to run, the interrupts themselves are, however, locked. 
There are accepted only on completion of the SDB evaluation. As a result, a 
maximum of one interrupt can be added per cyclic interrupt OB. 

Programming device operation Only the STOP command is available on the programming device. Data record 
jobs are not possible. 

External SSL information,  
via MPI, for example. 

Information functions are processed with a delay. 
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8.9 Creating network connections 

8.9.1 Introduction for Creating the Network Connections 

Introduction  
Networks – known as subnets in PCS 7 – are used, on the one hand, for communication 
between automation systems and SIMATIC PC stations (Industrial Ethernet) and, on the 
other hand, between automation systems and the distributed I/Os (PROFIBUS DP). 

Overview 
Creating network connections in PCS 7 involves the following topics: 
● Displaying networked / non-networked stations (Page 427) 
● Creating and configuring new subnets (Page 428) 
● Creating and configuring a network connection to a station (Page 429) 
● Changing station addresses (Page 430) 
● Changing the transmission rate and operating mode in the PC network (Page 432) 
● Saving the network configuration (Page 434) 
● Checking the consistency of the network (Page 435) 
● Cross-project Networks (Page 437) 
● Configuring Redundant Networks (Page 438) 
● Tips on Editing the Network Configuration (Page 439) 
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8.9.2 How to Display Networked/Non-networked Stations 

NetPro Display of the Project 
NetPro graphically displays all configured stations and networks of a project. You can 
immediately recognize if a subnet is connected to a specific station based on the connection 
lines.  
You specify the network assignment of components capable of communication during 
hardware configuration of a station. You can change this assignment later in NetPro. 

Procedure 
1. In the component view of the SIMATIC Manager, select the project for which you want to 

display the network. 
2. Select the required network in the detailed window. 
3. Select Edit > Open Object from the menu. 

Result 
NetPro opens and all the stations of the project are displayed graphically with their network 
assignment. 

Additional information 
● Section "How to Create and Assign Parameters for the Network Attachment of a Station 

(Page 429)" 
● Online Help for NetPro 
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8.9.3 How to Create and Assign Parameters for a New Subnet 

Where and How Can Subnets Be Created ? 
The following table provides an overview of the various options for creating subnets: 

 
Where? How ? Application 
HW Config When you insert a communications processor  

You can find information about this in the section "How to 
Insert a Communications Processor (Page 364)". 

Standard plants 

NetPro Insert > Network Objects menu command Complex networked plants 
SIMATIC Manager Menu command Insert > Subnet menu command Complex networked plants 

Note to Reader 
You can create subnets while configuring the station and connect modules (more precisely: 
their interfaces) to a subnet. You are already familiar with this option. 
With complex networked plants it is better to work in the network view (NetPro). This is 
described below. 

Procedure 
1. Select the station in the Component View of the SIMATIC Manager. 
2. Select the menu command Options > Configure Network. 

NetPro opens and the network configuration of the selected project is displayed. 
3. Click "Subnets" in the "Catalog" window.  

If it is not visible, open the "Catalog" Window with the menu command View > Catalog. 
4. Drag the required subnet into the window for the graphical network view.  

Positions which can not be used for attaching the subnet are indicated when the mouse 
pointer takes on the shape of a "Forbidden" sign.  
The subnet is displayed as a horizontal line. 

5. Double-click the symbol of the subnet.  
The "Properties" dialog box for the subnet opens. 

6. Set the parameters for the subnet (for example, assign a unique name). 

Tip  
If you hold the mouse cursor over the icon for the subnet, a tooltip is displayed with the 
properties of the subnet. 
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8.9.4 How to Create and Assign Parameters for the Network Connection of a Station 

Requirements        
● NetPro is open. 
● The configured stations are visible. 

Procedure 
1. Use the mouse to select the interface icon of the node (small box with the same color as 

the corresponding network type) and pull it toward the subnet to establish a connection. 
Network connections which are not permissible (for example connecting an MPI interface 
to an Ethernet type subnet), the mouse pointer takes on the shape of a "Forbidden" sign.  
The network attachment is displayed as a vertical line between the station/DP slave and 
subnet. 

2. Select the network connection, followed by the menu command Edit > Object 
Properties.... 

3. Make the settings for the node properties (for example, name and address of the node). 

Tip  
If you hold the mouse cursor over the icon for the interface, a tooltip is displayed with the 
properties of the interface (name of the module, subnet type, and, if already networked, the 
node address). 
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8.9.5 How to Change the Node Address 

Node address     
You specify the node address in the object properties of the Ethernet CP. The following 
properties are defined: 
● MAC Address 
● in addition in the IP protocol: 

IP address/subnet mask/address of the gateway 

MAC Address 
Each Ethernet module is assigned a unique MAC address. You will find the MAC address on 
the module.  
Please note that when using PC modules with a fixed MAC address, you must accept this 
MAC address. The freely available MAC address initially recommended by the system may 
differ from the address of the module.  
With more recent CPUs, a check box allows you to decide if you want to set the MAC 
address and use the ISO protocol. You only need to enter a MAC address if you intend to 
use the ISO protocol. Otherwise, the field remains disabled; the address assigned to the CP 
in the factory is then not overwritten when you download the configuration data.  

IP Protocol 
The IP parameters are displayed only when the current module supports the TCP/IP 
protocol. 
STEP 7 assigns default settings for "IP address", "Subnet mask" and the "Address of the 
gateway" for the interface of the node depending on the subnet mask and gateway of the 
subnet. 
Enter a new IP address/subnet mask/address of the gateway if you do not want to use the 
default setting. 

Requirement  
● NetPro is open. 
● The configured stations are visible. 
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Procedure 
1. Select the CP whose addressing you want to change. 
2. Select the menu command Edit > Object Properties.... 
3. Select the "General" tab in the "Properties" dialog box and click "Properties". 
4. Enter the MAC, IP address and if necessary the subnet mask address into the following 

dialog box. 
5. Click "OK". 

Additional information 
● Online help on NetPro (or HW Config) 
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8.9.6 How to Change the Transmission Rate and Operating Mode in the PC Network 

Introduction 
In order to guarantee communication in a network, ensure that the following parameters are 
set uniformly for all the network nodes: 
● Transmission rate 
● Operating mode 

 

 
 

Note 
Siemens devices are set in the factory so that the parameters for the transmission rate 
and the operating mode are recognized automatically ("Autonegotiation"). 
This setting only has to be changed if communication with nodes that do not dispose of 
the Autonegotiation setting is required in the network. 

 

Automatic Recognition of the Transmission Rate and the Operating Mode 
Autonegotiation means the automatic identification and negotiation of the transmission rate 
(10/100 Mbps) and the operating mode (full duplex/half duplex). 
● Full duplex is an operating mode with bidirectional data exchange, in which the 

communication partners can send data independently of one another on the transmission 
link. The sending process can take place from both components simultaneously. 

● Half duplex is an operating mode with bidirectional data exchange, in which only one 
communication partner at a time can send data on the transmission link. The sensing 
process must always take place alternatively. Data transport is always only possible in 
one direction between two components at any given time. 

Requirement 
The Autonegotiation setting has to be changed because communication with nodes in the 
network that do not dispose of the Autonegotiation setting is required.. 
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Configuration of the Network Nodes 
 
Location of 
Use 

Network Node Steps for Calling Parameter 
Assignment Dialog Box 

Parameter 

PC Communications processor 
CP 1613/CP 1623 

1. Start > SIMATIC > 
SIMATIC NET > Set PC 
Station 

2. PC Station > Modules > 
Network Parameters 

Radio buttons for duplex 
mode and transmission 
rate. 

PC INTEL network card (or 
similar with 3COM) 

1. Start > Settings > Control 
Panel > Administrative 
Tools > Computer 
Management > Device 
Manager > Network 
adapters 

2. Network card properties 
3. "Advanced" tab 

Network card property 
Typical name for the 
property (depends on the 
network card used): 
• Speed and duplex 

mode 
• Link speed & duplex 

Switch SCALANCE X-400 Call up the switch 
configuration dialog box 
using Internet Explorer:  
http : \\<TCP-IP address> 

Port configuration 

AS CP 443-1 communications 
processor 

1. HW Config 
2. Properties of the network 

module 
3. "Options" 

Individual network 
settings 
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8.9.7 How to Save the Network Configuration 

Introduction      
To save the network configuration and the connection tables, you can use the Network > 
Save and Network > Save and Compile... menu commands.  

Save  
If you have created network objects in NetPro or changed their properties in NetPro, NetPro 
saves the following: 
● Node Addresses 
● Subnet properties (for example, transmission rate) 
● Connections 
● Modified module parameters (for example, of CPUs) 

Save and Compile  
If you select the menu command Network > Save and Compile...., a further dialog box opens 
in which you can decide whether to compile everything or only the changes. Regardless of 
the option you select, NetPro checks the consistency of the configuration data throughout 
the project; messages are displayed in a separate window.  
 
Option What? 
Compile and check 
everything 

The loadable system data blocks (SDBs) of the complete network 
configuration are generated; these contain all the connections, node 
addresses, subnet properties, input/output addresses and module 
parameter assignments. 

Compile changes only The loadable system data blocks (SDBs) of modified connections, 
node addresses, subnet properties, input/output addresses or module 
parameter assignments are created. 
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8.9.8 How to Check the Consistency of the Network 

Introduction     
We recommend that you check the consistency of the network prior to saving.  
The following are examples of states which are displayed during the consistency check:  
● Nodes that are not connected to a subnet 

(exception: non-networked MPI nodes) 
● Subnets with only one node 
● Inconsistent connections 

Alternative Procedures 
A consistency check takes place during the following actions:  
● Network > Check Consistency menu command 
● Network > Check Consistency Project-wide menu command 
● Network > Save and Compile... menu command (in the next dialog box, select the option 

"Compile and check everything") 
● Download to the target system (consistency check of the stations and connections to be 

downloaded) 

Procedure 
1. Select the menu command Network > Check Consistency in NetPro. 

Result 
The consistency check is carried out.  
Following this, the window "Outputs for consistency check for <path + project name>" opens. 
If necessary, errors and warnings are displayed in this box such as those concerning 
hardware-configuration, network or connection configuration. 

Messages in the "Outputs for Consistency Check" Window 
Messages are displayed as errors if no system data (SDBs) can be generated by saving 
compiling or prior to download to the target system. Without generated system data, the 
hardware/network and connection configuration can not be downloaded to the target system. 
Messages are displayed as warning when the reported problem nevertheless allows 
generation of system data (SDBs). 
To obtain help on an error or warning, select the error or warning and press the < F1> key.  
Tip  
The window with the results of the last consistency check can be opened at any time with the 
menu command View > Outputs.  
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Consistency of Cross-project Subnets  
After merging subnets in the multiproject (see section "Cross-project Networks (Page 437)") 
and before downloading, you should ensure the consistency throughout the multiproject with 
the menu command Network > Check Cross-project Consistency in NetPro. In this check, all 
projects of the multiproject are subjected to a "total consistency check" one after the other. 
This takes into account all the objects in the multiproject.  
The quality of the consistency check is the same for both menu commands (Network > 
Check Consistency and Network > Check Cross-project Consistency). In both cases, 
duplicate node addresses are searched for in merged subnets. When checking connections 
for consistency, cross-project connections are also taken into account in both cases.  
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8.9.9 Cross-project Networks 

Cross-project Networks 
With PCS 7, you can configure cross-project Ethernet networks and later use these to 
configure connections. Networks included in more than one project are not created in one 
step. Subnets already configured in the individual projects are merged in the multiproject and 
assigned to a logical "Entire Network ". The "Entire Network" represents the common 
properties of all of the assigned subnets. The individual subnets of a merged network 
continue to be retained.  
Merged and therefore cross-project networks have the same subnet type and identical S7 
subnet IDs. They are represented in NetPro by the name extension "Part of: Ethernet 
Interproject".  

Cross-project Network View 
To achieve a better overview, you can activate the cross-project network view in NetPro with 
the menu command View > Cross-project Network View. This is an advantage particularly in 
the multiproject. 

Additional information 
● Section "How to Merge Subnets from Different Projects into a Multiproject (Page 624)" 
● Online Help for NetPro 
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8.9.10 Configuring Redundant Networks 

Redundant Networks 
Both the PROFIBUS DP field bus and the Industrial Ethernet plant bus can be configured 
redundantly. 

Basic Procedure 
1. Use the PCS 7 wizard to create a project with a CPU 414H or CPU 417H. 

A SIMATIC H station and two PROFIBUS systems are created in the project (these are 
already connected to the corresponding PROFIBUS DP interface of the CPU). 

2. Add a CP 443-1 to each subsystem of the H station and in HW Config and create a new 
Ethernet subnet for each CP. 

When you continue with the configuration, make sure that you assign other redundant 
components (for example, redundant OS server) to the correct plant bus.  

Result 
You have created a redundant field bus and a redundant plant bus. 

Additional information 
● Function manual Process Control System PCS 7; Fault-tolerant Process Control Systems 
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8.9.11 Tips on Editing the Network Configuration 

Introduction       
Below you will find tips on how to edit an existing network configuration.  

Highlighting the Communication Partners of a Module  
Proceed as follows after you have configured the connections:  
1. Select a programmable module (CPU, FM) in the network view. 
2. Select the menu command View > Highlight > Connection Partner. 

 

 
 

Note 
Only the communication partners of a programmable module can be highlighted. 

 

Displaying/Modifying the Properties of Components  
To display or modify the properties of stations or modules, proceed as follows:  
1. Select the component (station icon or module) 
2. Select the menu command Edit > Object Properties.... 

Copying Subnets and Stations 
1. Select the network objects to be copied. Use the keyboard/mouse combination <Shift> + 

left mouse button to select several network objects for copying at the same time. 
2. Select Edit > Copy from the menu. 
3. Click the location in the network view where you want to position the copy and select the 

menu command Edit > Insert. 
 

 
 

Note 
You can copy individual network objects or entire subnets with network attachments, 
stations, and DP slaves. When copying, remember that all the nodes of a subnet must 
have a different node address. Therefore it may be necessary for you to change the node 
addresses. 

 

Deleting Network Connections, Stations and Subnets 
1. Select the symbol of the network connection or subnet. 
2. Select the menu command Edit > Delete. When you delete a subnet, the stations 

previously connected to the subnet are retained and can, if required, be connected to 
another subnet. 
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8.10 Creating the SIMATIC Connections 

8.10.1 Introduction into Creating the SIMATIC Connections 

Data Communication 
Several automation systems are inserted into a plant section when configuring middle- and 
large-size plants. The automation systems share the automation tasks and therefore must be 
able to exchange data. Data communication between the automation systems and the PC 
stations is also necessary.  
The following sections explain how to define these communication connections and which 
special features must be taken into account. 

8.10.2 Connection Types and Connection Partners 

Introduction        
Communication connections (connections, for short) must always be configured, when data 
exchange between the automation systems or the automation system and a PC station (for 
example, an OS station) is required in the user program using communication blocks.  

Connection 
A connection is the logical assignment of two communication partners for the purpose of 
carrying out communication services (for example, the exchange of process values). A 
connection specifies the following:  
● The communication partners involved (for example, two SIMATIC 400 stations) 
● The connection type (S7 connection, S7 connection fault-tolerant) 
● Special properties such as: 

– Whether a connection remains permanently configured 
– Which one of the partners initializes the connection configuration 
– Whether operating state messages should be transmitted 

Connection Configuration 
During connection configuration, a unique local identifier is assigned per connection, the 
"local ID". The local ID can also be a symbolic name (named connection). This local ID is 
required when assigning parameters to the communication blocks.  
For each programmable module that can be the end point of a connection, there is a 
separate connection table. 
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Special Feature 
PCS 7 automatically assigns a local ID for both end points of the connection if both 
communication partners are S7-400 stations or if one of the communication partners is an 
S7-400 station and the other is a SIMATIC PC station. 
You configure the connection only in the connection table of one partner; the other 
communication partner then automatically has the matching entry in its own connection 
table. 

Selecting the Connection Type 
The connection type depends on the subnet and the transmission protocol with which the 
connection is established. Which communication blocks you use depends on the connection 
type.  
In PCS 7, the following connection types are used: 
● S7 connection 
● S7 connection, fault-tolerant 

Additional information 
● Section "Blocks for Different Connection Types (Page 506)" 
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8.10.3 How to Configure Connections between Two SIMATIC 400 Stations 

Requirement     
Two SIMATIC 400 stations have already been created.  

 

 Note 
Make sure that there are no duplicate "PROFIBUS DP" or "Industrial Ethernet" node 
addresses in your project (if uncertain, check with NetPro). 

 

Procedure 
1. Select the required project in the component view of the SIMATIC Manager. 
2. Select the menu command Options > Configure Network. 

The network view opens. The SIMATIC 400 stations, the corresponding ET 200M I/O 
devices, the operator stations, and the networks existing in your projects are displayed in 
the network view. 
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3. Select the module for which the connection is to be created in the network view, for 
example, the CPU of the SIMATIC 400(1).  
The connection table of the selected module is displayed in the lower part of the network 
view. 

 
4. Select an empty row in the connection table and select the menu command Insert > 

New Connection.... 
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5. Select the required connection partner in the "Insert New Connection" dialog box. Here, 
select the CPU of the SIMATIC 400(2). 

 

 
 

Note 
If you create a connection to a partner in another project of the multiproject, you must 
enter a connection name (reference). Based on the connection name, cross-project 
connections can later be merged.  
You enter the connection name in the "Properties" dialog box for the connection when 
configuring the corresponding PC station (OS) (group: "Connection Identification"; field: 
"Local ID"). 

 

 
6. Select the "S7 connection" entry from the "Type" drop-down list. 
7. Activate the "Show properties before inserting" if you want to view or change the 

properties of the connection after "OK" or "Add".  
The content of the "Properties..." dialog box depends on the selected connection. 
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Result 
PCS 7 enters the connection in the connection table of the local (selected) partner and 
assigns the local ID (can be changed) for this connection and, if necessary, the required 
partner ID you will need for programming the communication function blocks. The partner ID 
is the value for the block parameter "ID". 

Downloading Connections 
Download the connection into the CPUs of the corresponding stations after the new 
connection is configured.  
1. Select the menu command Network > Save and Compile.... 

The "Save and Compile" dialog box opens. 
2. Select from the options "Compile and check everything" and  

"Compile changes only". 
3. Select the CPU in one of the stations where you configured the connection. 
4. Select the menu command PLC > Download in the current project > Connections and 

Gateways. 
All connections and gateways are downloaded. 

 

 
 

Note 
The configuration data of the partner station must also be downloaded.  

 

Additional information 
● Section "Cross-Project Connections in a Multiproject (Page 453)" 
● Online help for the dialog box 
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8.10.4 How to Configure a Connection between a PC and SIMATIC 400 Station 
(Named Connection) 

Symbolic Connection Name (Named Connection)         
You can assign a symbolic name to a connection between an OS and an AS instead of a 
connection ID. This method of procedure is also designated as a "Named Connection". We 
recommend assigning the name of the AS. Once the OS has been compiled, this name will 
appear in the "SIMATIC S7 Protocol Suite". 
You can find more information about this in the configuration manual Process Control 
System PCS 7; Operator Station. 

 

 Note 
If several connections are configured between PC stations to one AS, these connections 
must all have the same name. 

 

Procedure 
1. Select the required project in the component view of the SIMATIC Manager. 
2. Select the menu command Options > Configure Network. 

The network view opens. The SIMATIC 400 stations, the corresponding ET 200M I/O 
devices, the operator stations, and the networks existing in your projects are displayed in 
the network view. 
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3. Select "WinCC Application" in the symbol of the "SIMATIC PC station". 
The connection table is displayed in the lower part of NetPro window. 
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4. To insert a new connection, select the menu command Insert > New Connection.... 
The "New Connection" dialog box opens. 

 
5. Select the CPU in the "Connection partner" field that should be coupled with the OS. 

 

 
 

Note 
If you are working in a multiproject, use the multiproject folder to select the target project 
and the required CPU found there. 

 

6. Activate the "Show properties before inserting" check box. 
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7. Click "OK".  
The "Properties - S7 Connection" dialog box opens. 

 
 

 
 

Note 
A connection name is entered as a default (S7 connection_1) in "Local ID:". 

 

8. Adapt the name of the local ID to the project requirements (for example, the name of the 
AS). This helps to avoid errors and maintain an overview.  
You will find the connection name once again in the connection table (Named 
Connection).  
For compiling the OS, the corresponding S7 program can now be transferred to the OS 
using this path (depending on the settings for compiling the OS). 

9. Click "OK". 
 

 
 

Note 
To avoid errors and improve clarity, you should change the default connection name (S7 
connection_1) to suit your project (for example, name of the AS). 
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10. Select the menu command Network > Save and Compile.... 
The connection configuration closes. 

11. Select the PC station and then the menu command PLC > Download in Current Project > 
Selected Stations. 
The configuration is downloaded. 

 

 
 

Note 
After the initial download of the hardware configuration from HW Config (CPU-STOP), 
download the changes to the configuration only using "Compile and Download Objects" 
or from within NetPro.  

 

Only Change the Local ID 
The local ID can be changed directly in the "Local ID" column of the connection table.  

Go to Partner Station 
Requirements:  
● The project where the connection partner is located is open. 
● The subnets of the participating projects are merged. 
When you are editing in the connection table, then go directly to the connection table of a 
connection partner as follows:  
1. Select a connection in the connection table. 
2. Select the menu command Edit > Go to Connection Partner. 
This function is also possible for cross-project connections in the multiproject.  

 

 Note 
To avoid the AS generating messages during operation when the OS simulation starts or 
terminated on the engineering station, the connection ID for the engineering station should 
be higher than 0xc00. 

 

Additional information 
● Section "Cross-Project Connections in a Multiproject (Page 453)" 
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8.10.5 How to Work with the Connection Table 

Requirements   
● NetPro is open. 
● A CPU or a WinCC application is selected. 

Showing and Hiding Columns  
1. From the connection table shortcut menu, select the menu command Display/Hide 

Columns > ... and then the name of the column you want to show or hide from the next 
shortcut menu. 

The names of the visible columns are indicated by a check mark. If you select a visible 
column, the check mark disappears and the column is hidden.  

Optimizing the Column Width  
In order to adjust the width of the column to its content (all texts legible) proceed as follows:  
1. Position the mouse pointer in the header row of the connection table on the right beside 

the column you want to optimize until the mouse pointer changes to two parallel lines (as 
if you wanted to change the width of the column by dragging with the mouse pointer). 

2. Double-click this position. 
Tip: If the columns are set too narrow, the entire content of individual fields is displayed 
when the mouse pointer is positioned briefly over a field. 

 

 Note 
The column widths and the selection of displayed columns is stored according to the specific 
project after the project is closed. The project settings remain valid even the project is 
opened from a different computer.  

 

Sorting the Connection Table  
To start the connection table in ascending order according to a particular column, click the 
title of the column.  
Clicking the title of the column again sorts the connection table in the opposite order.  

Changing the Properties of the Connection  
If you want to change a connection that has already been configured, for example, to set a 
different connection path (interface), proceed as follows:  
1. Select the connection you want to change. 
2. Select the menu command Edit > Object Properties....  

You can change the connection properties that allow modification in the dialog box that 
opens. 
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Going to the connection partner 
Requirements:  
The project where the connection partner is located is open in NetPro. 
If you are working in the connection table, you can go directly to the connection table of a 
connection partner:  
1. Select a connection in the connection table. 
2. Select the menu command Edit > Go to Connection Partner. 
This function is also possible for cross-project connections in the multiproject. 

Highlighting a connection partner 
Requirements: 
Connections have already been created. 
If you want the connection partner to be displayed in the graphical network view as well, you 
can use the following view option: 
1. Select a programmable module (CPU, FM). 
2. Select the menu command View > Highlight > Connection Partner. 

Additional information  
● Online help for connection tables. 
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8.10.6 Cross-project Connections in a Multiproject 

Introduction     
If cross-project subnets are configured then connections can also be configured over all of 
the subnets. The end points of these connections can be in different projects.  
PCS 7 provides support both when creating cross-project connections within the multiproject 
and when synchronizing connections configured without the multiproject context.  

Cross-project Connections to a Specified Partner  
Cross-project connections to a specified partner (for example, a CPU) are created just like 
connections within a project. The dialog box for selecting the connection partner allows not 
only the selection of the end point (for example, module) but also the selection of the project 
within the multiproject in which the end point is located.  
To allow this, the projects must be part of a multiproject and the subnets must have been 
merged (for example, using the "Synchronize Projects" wizard of the SIMATIC Manager).  

Properties of Cross-project Connections  
The consistency of cross-project connections is retained when manipulating projects of the 
multiproject. Cross-project connections within a multiproject remain functional and can be 
compiled even when the project with the connection partner has been removed from 
multiproject.  
Rule for S7 connections: 
Prior to opening the "Properties" dialog box, PCS 7 will only ask whether the connection 
should be broken only once you have displayed the properties of the connection. Only after 
responding with "Yes" to this question may you change the properties of the connection. If 
you modify the properties, you must make sure that the connection properties are 
synchronized yourself.  

 

 Note 
Only the local ID of a connection can be changed without breaking the connection (changes 
made directly in the table).  
Fault-tolerant S7 connections cannot be broken. 

 

If you have broken connections at both ends, you can merge them again with the menu 
command Edit > Merge Connections....  
You will find additional information on this topic in the Online Help for the dialog box. 
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Cross-project Connections to an Unavailable Partner 
If the connection partner in the multiproject is "unavailable", because the relevant project is 
being created elsewhere or because it is being edited and is therefore locked, select "in 
unknown project" as the connection partner. In the path the project, "Partner in unknown 
project" is also selected as the connection partner.  
This procedure reserves a connection in both projects that can be synchronized with system 
support when the partner project is later included in the multiproject.  
To allow this, the same connection name (reference) must be configured in both projects in 
the properties of the connection. Based on the connection name, it is possible to assign the 
connection partner and synchronize the connection properties using the menu command 
Edit > Merge Connections....  
You will find additional information on this topic in Section "How to Merge Cross-project 
Connections (Page 625)". 

Points to Note When Downloading  
If you have configured cross-project subnets and connections, you must download the 
network configuration to all modules involved. These are the end points of the connections 
and the required routers.  
When you upload (upload to programming device), the configured network configurations 
and connections are automatically merged assuming that the requirements are met (for 
example, both end points are uploaded).  
The download functions in NetPro are not cross-project operating and only take effect within 
a single project. This affects the functions: 
● Download in Current Project > Selected Stations 
● Download in Current Project > Selected and Partner Stations 
● Download in Current Project > Stations on the Subnet 
● Download in Current Project > Selected Connections 
● Download in Current Project > Connections and Gateways 
● Save and Compile is also restricted to the project currently active. 
If an S7 connection, for example, is cross-project, the network configurations of both projects 
involved must be compiled.  

Additional information 
● Section "How to Merge Cross-Project Connections (Page 455)" 
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8.10.7 How to Merge Cross-project Connections 

Requirements  
The following conditions must be met in order to merge connections within a multiproject: 
● The exact same connection name is used in the projects for the corresponding 

connections. This name also functions as a reference. 
● S7 connections to an unspecified partner can be merged to a cross-project S7 connection 

only in NetPro. These connections are ignored in the SIMATIC Manager. 

Procedure 
1. Select the required multiproject in the SIMATIC Manager 
2. Select the menu command File > Multiproject > Synchronize Projects. 

The "Synchronize Projects in the Multiproject<name of the multiproject>" dialog box 
opens. 

3. Select the "Merge connections" entry in the left window. 
4. Click "Execute". 
5. If the "Result" dialog box does not indicate an error, click "Save". 

Result 
The connections are merged and synchronized in the multiproject. 
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8.10.8 Configuring Redundant Connections 

Redundant connections     
The fault-tolerant connection is a separate connection type. The following partners can 
communicate over fault-tolerant connections: 
● SIMATIC H station (two H-CPUs) communicates with SIMATIC H station (2 H-CPUs) 
● SIMATIC PC station communicates with SIMATIC H station (2 H-CPUs) 
The properties of fault-tolerant connections correspond to those of the S7 connections; 
however restricted to H-CPUs and OPC servers of SIMATIC PC stations. 
With a fault-tolerant S7 connection, two connection paths between the connection end points 
are normally possible. 

Requirements 
● The hardware configuration for the two subsystems of a fault-tolerant system are 

identical. 
● The participating communication partners are H-CPUs or a suitably configured SIMATIC 

PC station. 
● For the use fault-tolerant S7 connections between a SIMATIC PC station and a fault-

tolerant automation system, the software package S7-REDCONNECT is installed on the 
SIMATIC PC station. 

Procedure 
1. Select the CPU of an H station (H-CPU) from which you want to configure a new 

connection. 
2. Select the menu command Insert > New Connection.... 
3. Select the required connection partner in the opened "Insert New Connection" dialog box. 
4. Select the "Fault-tolerant S7 connection" entry from the "Type" drop-down list. 
5. The remaining steps are the same as for configuring an S7 connection. 

Additional information 
● Manual Process Control System PCS 7, Fault-tolerant Process Control Systems 
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8.11 Configuring AS Functions 

8.11.1 Overview of the Programming Steps 

Introduction     
Define the AS functions in the plant hierarchy by inserting and programming CFC/SFC 
charts after you have created the S7 programs including the chart folder in the component 
view. The following table provides you with an overview of the basic steps in programming 
that are described in greater detail below. 
 
What? Must Optional 
Creating CFC Charts (Introduction) (Page 463) X  
Programming the SIMATIC Connections (Page 506)  X 

With AS-AS and  
AS/OS communication 

Programming the interface to the I/O (driver blocks) 
(Page 510) 

X  

Creating Process Tags from Process Tag Types 
(Multiproject) (Page 517) 

 X  
While editing mass data  

Creating sequential control systems (SFC) (Page 532)  X 
Creating Models (Multiproject) (Page 570)  X  

While editing mass data  

You will also find information on the following topics: 
● Configuration by Several Users (Textual Interconnections) (Page 459) 
● Editing Mass Data in the Process Object View (Page 580) 
● Adopting the Data from the Plant Engineering (Page 627) 
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Versioning CFC and SFC Charts  
In the object properties for each CFC/SFC chart, you can assign a version number. The 
version number is automatically set to "0.0001" when you create CFC/SFC charts and is 
then managed by the user. 
When a CFC/SFC chart is closed, the "Version" tab of the "Properties" dialog box will open, 
and you will have the option of assigning a version number (ranging between 0.0001 
and 255.4095).  

 

 Note 
If the dialog box with the "Version" tab appears automatically, this means that versioning is 
active in the project properties and a change has been made in the chart. You can expect 
versioning to increase in this case. 
You cannot set a version number that is smaller than the last saved version. 

 

The Object Properties of a CFC/SFC chart also include information on the software version 
last used to edit the charts (PCS 7 Vx.y). 
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8.11.2 Configuration by Several Users (Textual Interconnections) 

Basic Procedure     
Prior to programming the CFC and SFC charts, you should decide whether the project will be 
edited by more than one engineer. To allow this, branching and merging at the chart level is 
possible (S7 program). 
The distribution within the project is made according to technological aspects (for example, 
unit with the relevant charts is copied to a different project). Existing cross-chart 
interconnections are automatically replaced with textual interconnections. 
On completion of editing copy the parts back into the original project. Any charts with the 
same name are replaced following a prompt for confirmation. The textual interconnections 
are then reestablished. 
Textual interconnections that cannot be closed because a block was deleted are indicated in 
a log. The interconnections can then be systematically edited by hand. 

Distributing and Merging Project Data 
1. Copy a technological part of the project (for example, chart folder or charts) to a different 

project. 
The copy contains textual interconnections to all sources that were not copied. 

2. Edit the copied section separately (add, delete, modify blocks and charts). 
3. Copy this edited technological section back to the original project. 

When copying the charts into the chart folder of the component view, the handled charts 
are overwritten after a prompt. There are now textual interconnections to the charts that 
had connections to the copied charts. 

4. In the CFC editor, select the menu command Options > Close Textual Interconnections. 
All "open" interconnections are closed. 
The interconnections are closed in the charts edited in the other project and traced back 
to the original project, as well as in the charts where textual interconnections arose as a 
result of deletion. 

 

 
 

Note 
Always copy the charts in the component view. 
If you copy a chart in the plant view, a copy of the chart is created instead of being 
replaced. 
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Rules for Textual Interconnections 
● Charts are inserted into other projects through Copying. In this way a completely 

functioning original project is maintained until the edited charts are returned. 
● When an interconnection is broken, neither of the interconnection partners may be 

renamed, otherwise the textual interconnection cannot be closed again. 
● Changes to charts in the original project are discarded when charts of the same name are 

returned to the original project from temporary projects. 
● An unwanted interconnection can result in the original project if, for example, cross-chart 

interconnections are modified in the temporary project and only one of the charts involved 
is returned to the original project. 
Example: In chart CFC_A there is an interconnection to a block in chart CFC_B. Both 
charts are copied to a temporary projects and edited further. During editing, the 
interconnection between the charts is deleted. Only CFC_A is returned to the original 
project. A textual interconnection is created in the CFC_B of the original project; this can 
also be closed.  
Result: The interconnection deleted in the temporary project reappears in the original 
project. 

● Textual interconnections created before copying/moving are included in the target project 
(temporary project). This might be a concrete path reference (that can be closed) or a 
character string (required connection that will only be configured in the target project). 

Merging Several S7 Programs into One S7 Program  
To merge S7 programs on workstations that are not networked, the individual blocks or 
sources must be copied and inserted in the target. Global data for the project, such as the 
symbol table of variable table must be edited manually.  
Follow the steps outlined below: 
1. In the SIMATIC Manager, copy the blocks and sources to the appropriate folders of an S7 

program. 
2. Export the symbol tables of the individual S7 programs in ASCII format and import them 

into the symbol table of the merged S7 program. 
3. Check if any symbols are used twice. 

Tip: You can also integrate short symbol tables using the clipboard (copy and paste).  
4. Copy the variable tables you want to use or integrate the various variable tables using the 

Clipboard (copy and paste) into a new variable table. 
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Copying the S7 Programs with Message Attributes  
If you have provided blocks with message attributes, pay attention to the following 
restrictions (which are independent of the message number assignment procedure) when 
copying S7 programs:  
Project-wide assignment of message numbers 
The message numbers may overlap. Pay attention to the following in order to avoid conflicts:  
● In the SIMATIC Manager, assign a fixed message number range to each S7 program 

using the menu command Edit > Special Object Properties > Message Numbers.... 
● When copying S7 program make sure that S7 programs are not overwritten. 
● Only message types (FBs) can be programmed separately from the S7 program. 
CPU-Wide Assignment of Message Numbers  
● Programs can be copied within the project and from other projects without changing the 

message numbers. 
● When copying individual blocks, the message number changes and you must recompile 

the block to link the modified message number into the program. 

Copying a Program with Project-Wide Assignment of Message Numbers to a Project with CPU-Wide 
Assignment of Message Numbers  

● If you want to copy a program in which message numbers are assigned project-wide to 
another project in which the message numbers were assigned CPU-wide, select the 
required program in the SIMATIC Manager, followed by the menu command File > Save 
As..., and activate the "With reorganization" check box. This also applies if the project 
contains more than one program (more than one AS). 

● Default entries are made for the message attributes when they are copied. 

Copying a Program with CPU-Wide Assignment of Message Numbers to a Project with Project-Wide 
Assignment of Message Numbers  

You can only copy individual FBs with messages.  
 

NOTICE  
The assignment of message numbers in the programs must be uniform within a project! 
If a block with messages that references a text library is copied to another program, you 
must also copy the corresponding text libraries or create another text library with the same 
name or change the reference in the message text. 
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Changing between CPU-wide and Project-wide Assignment of the Message Number 
If you change between CPU-wide and project-wide assignment of the message numbers, 
you have to update the blocks in the CFC for every AS. 
1. Open a CFC chart from the S7 program in which you have changed the library blocks. 
2. Select the menu command Options > Block Types.... 

The "Block Types" dialog box opens. 
3. Select all the blocks for which a new version is to be imported in the "Chart folder" list. 
4. Click "New Version...". 

A warning message is displayed with information about the old and new version and the 
query whether you really want to update the block type. If you click "Yes", a central type 
change is carried out. All the instances of the block type are also changed within the chart 
folder. 

5. Close the dialog box. 
6. Repeat Steps 1 to 5 for all the stations in your project/multiproject. 

Inserting S7 Connections to Unspecified Connection Partners 
If you insert existing projects with S7 connections to unspecified partners into a multiproject, 
you can easily convert these S7 connections to cross-project S7 connections:  
1. Merge the subnets along which the S7 connection runs:  

You will find additional information on this topic in Section "How to Merge Subnets from 
Different Projects into a Multiproject (Page 624)" 

2. In the SIMATIC Manager, select the menu command Options > Configure Network. 
NetPro opens. 

3. Select the menu command Edit > Merge Connections.... 
PCS 7 automatically merges matching S7 connections. 

Additional information 
● Online help on STEP 7 
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8.11.3 Creating CFC Charts (General) 

8.11.3.1 Introduction into Creating CFC Charts 

CFC Charts and CFC Editor     
To configure continuous processes in a plant, you use CFC charts that you create and edit 
with the CFC Editor. Add blocks from the master data library or from the PCS 7 Library Vx.y 
into the CFC charts.  
The PCS 7 Library contains blocks for controlling a process or for monitoring measured 
values, for example. The inputs and outputs of these blocks are interconnected directly in the 
CFC Editor and are given parameter values. During this procedure, you are supported by the 
CFC Editor graphic user interface.  
Store the CFC charts in the plant hierarchy. They are always located in the hierarchy folders 
in which they have their technological significance.  
The PCS 7 Advanced Process Library also provides process tag types. They represent full 
CFC charts for various process tags, such as motors and valves.  

 

 Note 
We recommend that you store all the blocks, charts, process tag types, etc. used in the 
project in the master data library and then only access the master data library during 
configuration. This applies in particular to objects you have copied from a library and then 
modified for the project. 

 

 Note 
For detailed information about the CFC Editor, refer to the Online help and the 
corresponding manuals. 

 

Functions in the Form of Blocks 
In CFC, you work with ready-made blocks that have a specific function. You place these 
function blocks in the CFC chart, interconnect them, and assign parameters to them. 

Block type 
For every function block a type definition exists that specifies the following: 
● The algorithm 
● The type name 
● The data interface (these are the input and output parameters) 
The type definition also specifies the data types of the input and output parameters. These 
input and output parameters are known as block inputs and block outputs since this is how 
they appear in the graphic display of the block. 
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Block Instance 
A block instance is created from the block type after the block type is placed into your CFC 
chart.  
You can create any number of block instances from a particular block type. Depending on 
their individual use, separate block instances can be named, interconnected, and assigned 
parameters without changing the way the specific type function. 
One useful aspect of this type instance concept, for example, is that following later central 
changes to the block type, these changes can be automatically made in all block instances. 

Compound Blocks (Multiple Instance Blocks) 
Functions can consists of different partial functions. Blocks used to perform the partial 
functions can be added together to form a multiple instance block which carries out the entire 
function. This could be for example, a control block which functions as an internal block and 
contains both a message and operator control block. 
Multiple instance blocks can be created in CFC by interconnecting different blocks 
(functions) and assigning parameters. This chart is then compiled as a block type. 

Master Data Library 
In multiproject engineering, you work with the master data library. This contains the project 
master data (block types, process tag types etc.) for all projects of this multiproject. You will 
find additional information on this topic in Section "Introduction to the Master Data Library 
(Page 310)". 

Additional information 
● Section "Introduction into Creating Process Tags from Process Tag Types (Multiproject) 

(Page 517)" 
● Manual CFC for S7; Continuous Function Chart and in the online help. 
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8.11.3.2 Overview of the Configuration Steps 

Requirement 
A project structure (plant view) is created in the SIMATIC Manager which allows you to 
configure CFC/SFC charts.  

Overview of Configuration Tasks 
The following table contains the steps you must execute during the configuration process. 
 

Step What? Description 
Creating the project structure A chart folder for CFC must be created below the hierarchy level of the program 

folder in the SIMATIC Manager. CFC charts are stored in the chart folder. 
 1 

Creating blocks (optional) CFC works with ready-made blocks. These can be blocks from libraries, other 
programs, or block types created by you. 

 2 Importing the blocks  
(if they were not imported 
implicitly by inserting the 
block) 

Block types required for the project are inserted and if necessary imported in 
various ways depending on the PLC. By importing blocks, they are made known 
to CFC. The block types should be stored in the master data library. 

 3 Inserting the blocks  
(into a CFC chart) 

Blocks are inserted in the CFC chart by dragging them from a master data 
library or the block catalog. This creates a block instance with a name that is 
unique throughout the chart. You can create any number of block instances 
from each block type. 

 4 Assigning parameters and 
interconnecting the blocks  

You can assign parameters and interconnect the block inputs and outputs to 
other blocks, nested charts, or to shared addresses.  
You can specify textual interconnections at block/chart inputs whose 
interconnection target is not yet in the chart folder. These interconnections 
remain open until the referenced interconnected partner exists, and the 
interconnections are then closed with a menu command.  
Interconnecting means that values are transferred from one output to one or 
more inputs during communication between the blocks or other objects. 

 5 Adapting the runtime 
properties  

The runtime properties of a block determine how the block is included in the 
processing of the entire structure on the PLC. These properties are decisive for 
the response of the target system in terms of reaction times, dead times, or the 
stability of time-dependent structures, for example, closed loops.  
When it is inserted, each block is assigned default runtime properties. To this 
purpose it is installed in an OB task at a position determined by you. You can 
change the position at which the block is installed and other attributes later if 
necessary. 

 6 Compiling the CFC Charts  During compilation as a program, all the charts of the active CPU are converted 
to machine code (compiler). If you compile as a block type, only the individual 
chart is compiled. 

 7 Loading the CFC program  After compilation, you can download the CFC program to the target system 
(automation system). 

 
 

 Note 
When entering units, ensure that the following special characters are not used: [ ' ] [ $ ].  
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Rules for the Interaction between CFC and SIMATIC Manager 
When working with the SIMATIC Manager, remember the following points: 
● You can only delete charts, chart folders, and projects in the SIMATIC Manager when no 

chart in the particular chart folder or project is currently being edited in CFC. 
● Projects with CFC charts must not be saved on removable data media, neither using the 

menu command New Project nor Save Project As.... 

Additional information 
● Online help on CFC 
● Manual CFC for S7; Continuous Function Chart 
● Getting Started CFC for S7; Continuous Function Chart 
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8.11.3.3 How to Create a New CFC Chart 

Introduction 
The project structure is specified when you create the plant hierarchy. Here, you will find all 
the CFC charts. The assignment to the plant sections is specified in the plant view. 

Requirement 
A project with an S7 program has been created in the SIMATIC Manager. 

Procedure 
1. Select the desired hierarchy folder in the plant view of the SIMATIC Manager. 
2. Select the menu command Insert > Technological Objects > CFC. 

A blank CFC chart with the default name is created. A new CFC chart consists of a chart 
partition with 6 sheets without further chart partitions. 

3. Change the name according to your requirements. 
 

 
 

Note 
The chart name may not exceed 22 characters. The name may not contain the following 
characters: \ / . " % 

 

Chart-in-chart technique 
You can provide a CFC chart with I/Os so that it can be inserted into other charts and 
interconnected with any blocks or CFC charts. By inserting charts into charts, you create 
nested charts. 
A chart without chart I/Os can also be inserted into a different CFC chart. This may be the 
case if you prefer to create the chart I/Os at a later time. 

Additional information 
● Section "How to Define CFC Chart I/Os (Page 482)" 
● Online help on CFC 
● Chart-in-chart technique: Manual Process Control System PCS 7, Getting Started - Part 2 
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8.11.3.4 How to Insert Blocks into the CFC Chart 

Introduction 
When inserting a block, select a block type in the master data library or in the block catalog 
and then place it into the CFC chart. The block will then be assigned a name that is unique 
within the chart. The block that is inserted is an instance of the block type. You can create 
any number of block instances from each block type.  

 

 Note 
The comment of the block type is not included in the block instance. 

 

Procedure 
1. Select the CFC chart in the SIMATIC Manager. 
2. Select the menu command Edit > Open Object. 

The CFC chart opens in the CFC editor. A new CFC chart consists of a chart partition 
with 6 sheets without further chart partitions. 

3. Select the "Libraries" tab in the block catalog.  
Here, you will also see the master data library. 

4. Select the block type you want to insert from the master data library and drag into the 
chart. 
An instance of the block type is created in the CFC chart. 

5. Insert further blocks into the CFC chart in the same way. 
The runtime properties of a block are predefined. If necessary, you can change the runtime 
properties: You can find additional information about this in section "Runtime Groups and 
Runtime Properties (Page 473)". 

Searching for Blocks 
You can search for a block by specifying a block name in the input field of the block catalog 
and then searching for it using the "Find" button (binoculars). If the text you entered is not 
found as a block name, CFC searches for a block with a corresponding comment. The folder 
containing the block opens and the block is selected. 
Use the check box "Search for initial letter" to choose between two different search modes: 
● free search (default) 

The program searches for a specific part of the name or commentary. 
● restricted search 

The search begins with the initial letter. 
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The Block Catalog in the CFC Editor 
If the block catalog is not open, open it with the menu command View > Catalog.  
You will see the following three tabs in the block catalog : 
 
Tab Description 
Blocks Here the blocks are sorted according to block families. You also find the 

blocks which are in use, below the name of the S7 program. 
Charts Here you will find all the charts that you have created in the chart folder of 

the S7 program. A small open folder icon is used to symbolize the chart 
which is open in the CFC Editor. 

Libraries Here you will normally find all the libraries provided by PCS 7 along with 
your master data library. Hide all the libraries that you do not need for 
project engineering by using the ""Hide" function (see Section "Using 
Libraries (Page 317)"). The master data library is always displayed. 

Additional information 
● Online help on CFC 
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8.11.3.5 How to Assign Parameters and Interconnect the Blocks 

Block I/Os        
Each block has a number of different I/Os.  
The I/Os of a block can be "visible" or "invisible": You can only see any "invisible" 
parameters in the properties of the block but not in the representation in the CFC chart.  
Use the properties of the block to specify which I/Os in the CFC chart will remain visible or 
hidden. If connections interconnected to a block are switched invisible, this is indicated by a 
small triangle in the block header.  

Procedure 
1. Select the block in the CFC chart and then select the menu command Edit > Object 

Properties....  
The "Properties - Block" dialog box opens, and the "General" tab is active. 

2. Enter a unique name for the block instance in the "Name" box. The names of block 
instances must be unique in a CFC chart. 

 

 
 

Note 
The maximum length of a block name is 16 characters (for nested charts 22 characters). 
The name may not contain the following characters: \ / . " % 

 

3. Open the "Inputs/Outputs" tab. 
4. Here, you can set the parameters for all the I/Os of a block (values of the I/Os, 

visible/hidden, released for testing, relevant for archiving etc.).  
The "Name" column lists the names of all inputs and outputs. 
Click the column heading of the table as a simple way of finding an I/O: The column is 
sorted in ascending or descending order. 

 

 
 

Note 
If you change units or operator texts, these are no longer taken into account during block 
type importing. 

 

5. Click "OK" once all the parameters have been assigned. 
The name is displayed in the CFC chart in the block header; parameters are assigned to 
the block. 

6. Follow the same procedure to configure additional blocks in the CFC chart. 
7. To interconnect, click on the required output of the block. 
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8. Click on the input of the block with which you want to interconnect the output.  
The CFC editor automatically creates a line indicating the interconnection. 

 

 
 

Note 
Steps 7 and 8 can be carried out in reverse sequence.  
You can create further interconnections in the shortcut menu if the I/O is selected: 
• Interconnection to Address... 
• Interconnection to a Runtime Group... (only for data type BOOL) 

 

9. Make the other parameters settings and create the interconnections in the same way. 
 

 
 

Note 
Select a connection line to facilitate follow-up. The line blinks in a different color in both 
the chart and in the chart overview. 
Click on the chart to stop the blinking. 

 

Configuring Archive Tags 
Block I/Os intended for operator control and monitoring can be marked for archiving in 
WinCC. You make the setting in the "Inputs/Outputs" tab in the "Archive" column. 
Possible identifiers are: 
● No archiving 

The value of the connection is (no longer) to be archived. 
● Archiving 

The value of the connection is to be archived on an OS or an archive server. 
● Long-term archiving 

The values archived on the OS or the archive server are to be stored for long-term 
archiving on, for example, a CD, DVD or tape. 

The interconnections marked as relevant for archiving are created as archive tags when the 
OS is compiled and, if it does not already exist, a process value archive with the name 
"Process value archive" is created. This is where the archive tags are stored. 
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Interconnecting with Process Pictures 
When you create the process pictures, you will interconnect the I/Os of the blocks from the 
CFC charts with objects in the process pictures. The tag name is formed from the plant 
hierarchy, the CFC chart name, and the block name. You will find the name again as part of 
the tag name. The values of the inputs/outputs are entered. 
After compilation, you will find the tag names in the WinCC tag management. When you 
compile (with the option active), the block icons are created in the pictures and the block 
instances interconnected to the mimic diagrams. 

Additional information 
● Online help on CFC 
● Interconnecting with Process Pictures: Manual Process Control System PCS 7, Getting 

Started - Part 2 
● Archive tags: Configuration manual Process Control System PCS 7; Operator Station 
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8.11.3.6 Runtime Groups and Runtime Properties 

Creating Runtime Groups  
One runtime group is created automatically per CFC chart. All blocks of a chart are installed 
in the respective runtime group. This reduces the time when compiling changes in the CFC 
charts.  
The run sequence can be optimized by PCS 7. These optimized run sequences should only 
be modified as an exception. 
The sequence model available provides optimum support when configuring the run 
sequence, multiuser projects and therefore distributed engineering. 
You can find information about this in the section "How to Adapt the Run Sequence 
(Page 479)". 

Optimizing Run Sequence  
With the "Optimize Run Sequence" you can optimize the run sequence of a program 
according to the data flow so that there is as little dead time as possible when executing on 
the CPU. OBs/tasks and runtime groups are optimized separately. 
You can find information about this in the section "How to Optimize the Run Sequence 
(Page 477)". 

8.11.3.7 Runtime Properties of the Blocks 

Introduction 
This section describes some of the basics required to understand the runtime properties of 
blocks. 

Runtime properties  
The runtime properties of a block decide how the block is included in the run sequence 
within the entire structure of the CPU. These properties are decisive for the response of the 
target system in terms of reaction times, dead times, or the stability of time-dependent 
structures, for example, closed loops. 
The runtime properties of the blocks have default settings but these can be adapted 
individually for each block. 
When it is inserted, each block is assigned default runtime properties. It is therefore installed 
in a run sequence in a task (OB). The tasks form the interface between the operating system 
of the CPU and the S7 program. Blocks can also be installed in runtime groups that are 
themselves installed in tasks (OBs).  

 

 Note 
When you create new chart, a runtime group is created automatically in which all the blocks 
of this chart will be installed.  
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Runtime groups 
Runtime groups are used to structure tasks (OBs). The blocks are installed in sequential 
order in the runtime groups. Runtime groups allow the blocks of a CFC chart to be handled 
individually. 
You can do the following with runtime groups: 
● Switching selected blocks within an OB off and then on again  

If a runtime group is deactivated, the blocks it contains are no longer passed through.  
Runtime groups are activated or deactivated using a block output of the data type 
"BOOL". 

● Process selected blocks with a specific reduction ratio (after a specified number of cycles 
and/or with a phase offset) to achieve better load distribution on the CPU. 

● If OBs contain a large number of installed blocks, these can be put together in smaller 
units. 
Advantage: Instead of creating one "large" FC when you compile each OB, "smaller" FCs 
are created depending on the number of runtime groups. 
If the program is modified later, only the runtime groups/FCs that actually contain 
modified blocks are given the "modified ID".  
In this way later compilations and online downloads to make changes can be executed in 
shorter time. 

 

 
 

Note 
For the reasons listed above, make sure that you do not install too many blocks in an OB 
or in a runtime group. Only this will lead to a noticeable improvement in performance 
when you compile or download changes in comparison to compiling and downloading the 
entire program.  
You must also take into account the startup OB (OB 100), the error OBs (OB 8x) and any 
special OBs you may use. 

 

Insert Point 
When you insert a block, the insert point of the block in the run sequence is fixed. 
The default rule is as follows: he block is inserted after the block displayed in the status bar 
of the CFC. 
The following is displayed in the status bar (alternative): 
● When you first create a chart, the default of the specific PLC 
● The last new block to be inserted (color marking: black text on a light gray background) 
● The block specified by the run sequence 
The current insert point is displayed to the right in the status bar. It displays the task name 
(OBx), the chart and block name after which the next block will be installed in the run 
sequence when a block is inserted in the CFC chart. 
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Display of the Runtime Properties  
You have the following options for obtaining information about runtime properties:  
● For an individual block 
● For the entire CPU 

Runtime Properties of Individual Blocks 
The runtime properties of each block are displayed in the part of the block header on a 
colored background. 

 
● Upper row: Name of the task in which the block is installed 
● Lower row (to the left of the slash): position of the block or runtime group in the task 
● Lower row (to the right of the slash): if the block is installed in a runtime group, position of 

the block in the runtime group; otherwise "-" 
If a block is installed more than once, information is displayed for only one location of this 
block; this is the block in the task located first alphabetically. 
The block header can also include additional colored icons at the top left that indicate the 
processing status of the block:  
● yellow exclamation mark against a red background -> not being processed 

For example, EN input is static 0. 
● black question mark against a yellow background -> processing unclear 

For example, EN input is interconnected. 
A double-click on the field shown above in the block header launches the processing 
sequence of the block. In the execution order, you can change the runtime properties of the 
blocks directly. You will find more information in: "How to Adapt the Run Sequence 
(Page 479)". 

Runtime Properties of all Blocks of a CPU 
For a complete overview of the run sequence, select the menu command Edit > Open Run 
Sequence in the CFC editor (you can also edit the run sequence in this window), or the 
menu command Options > Chart Reference Data in the "Run Sequence" window. 

Additional information 
● Online help on CFC 



Implementing the PCS 7 Configuration  
8.11 Configuring AS Functions 

 Engineering System (V7.1) 
476 Configuration Manual, 03/2009, A5E02122455-01 

8.11.3.8 Setting up AS-wide interconnections 

General information on AS-wide interconnections 
With the CFC Editor, you can set up interconnections to partners located on other 
automation systems. These interconnection partners are always block I/Os or I/Os of 
hierarchical charts. Requirements for AS-wide interconnections: 
● The PLCs involved are located in a common project or multiproject. 
● The network has already been configured. 
● The charts containing the interconnection partners are open in the CFC Editor. 

Setting up AS-wide interconnections 
You make the interconnection as you would for a chart-wide interconnection. To do this, 
open both charts and arrange them in the CFC so you can connect the source to the 
destination, in other words, click on the I/O to be connected in one of the charts and then 
click on the I/O partner in the other chart. 
For connections, an interconnection line is drawn to the sheet bar. The AS-wide 
interconnection is marked as a green triangle in the small field of the sheet bar. The 
project/station/CPU type/ or hierarchical path and chart name/block/connection is entered in 
the large box. 

General information on the procedure 
An S7 connection is created automatically for each AS pair in NetPro. 
Once you have created AS-wide interconnections, you need to compile and load the affected 
S7 programs. 
The blocks required for the data transfer are made available and loaded by the engineering 
system when loading is performed. These blocks are not instanced in the chart and cannot 
be seen in the catalog. The data transfer is called directly from the corresponding OBs of the 
AS (OB1, OB3x). The handling instructions are located in special DBs created by the code 
generator and transferred from the loader to the CPU. 

Additional information 
● Online help on CFC 
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8.11.3.9 How to Optimize the Run Sequence 

     
 

 Note 
When you insert blocks in the CFC chart, they are automatically installed in the run 
sequence.  

 

Procedure 
1. Start optimization in the the run sequence editor via the menu command Options > 

Optimize Run Sequence..., 
or - for selected tasks or runtime groups - in the shortcut menu via the menu command 
Optimize Groups/Tasks.... 

With this function, you can optimize the run sequence of a program based on the data flow. 
This keeps the dead time to a minimum while the sequence is running in the CPU. 
Optimizing is carried out separately for tasks and runtime groups. 

Selection of Individual Elements 
Enable the elements for the optimization in the run sequence or exclude them. You can 
choose the selected task from your object properties. An extra icon is used to identify the 
selected element in the run sequence editor (blue circle with slash).  
The following optimizations can be carried out: 
● You optimize an entire task including all enabled runtime groups (option: OB/task and 

runtime groups). This is the default setting. 
● You only optimize the enabled runtime groups of a task (option: runtime groups only). 
● You exclude the entire task - including the runtime groups it contains - from the 

optimization (option: none). 
The release of an individual runtime group for optimization can be set under object 
properties for each runtime group by activating the "Optimize run sequence" check box 
(default). Individual runtime groups are excluded from optimization when you deactivate this 
check box. 

Rules 
● The content of runtime groups, created by the driver generator ("Generate Module 

Drivers" @......) are not optimized since the correct order is already set here. 
● If optimization is executed after creating the module drivers, there is no guarantee that 

the runtime groups of the driver blocks are in the order specified by the driver generator. 
Therefore the module driver is restarted during the next compilation (the "Create module 
driver" check box is activated). 
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What Happens during Optimization? 
This is handled separately for each task. Within a task, the runtime groups are handled 
extra. The reduction ratio and phase offset of a runtime group are ignored.  
The data flow is obtained from the interconnections. These include all block-block 
interconnections as well as those to SFC charts and interconnections of block outputs to 
ENABLE a runtime group.  
The following interconnections are ignored: 
● Global and textual interconnections 
● Interconnections to blocks located in other tasks 
● Access from SFC charts to block I/Os located in other tasks 
● Interconnections to the chart interface are traced as far as the actual source of the 

interconnection. If this does not exist, in other words, the interconnection ends at an 
interface, this interconnection is ignored. 

Interconnections into a runtime group or out of a runtime group are considered to be 
interconnections of the runtime group itself. A runtime group represents a fictitious block on 
the task level. Interconnections between the blocks of a runtime group are used only for 
optimization within the runtime group. This ensures that the runtime groups are correctly 
arranged on themselves and that the runtime group itself is placed at the optimum position 
within the task. 
Changes are only carried out if they are necessary during subsequent optimization. 
Consequently the amount of modifications are held to a minimum while compiling and 
downloading changes. 

 

NOTICE  
If blocks are interconnected over INOUT parameters, the data flow may be reversed (from 
input to output). This is not taken into consideration when optimizing the run sequence. 
Remedy: in this case, you must optimize the order yourself and exclude the relevant 
runtime group from the optimization. 

 

NOTICE  
During cascaded interconnections and other connections with several return jumps, 
deactivate runtime group optimization at the runtime group. 
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8.11.3.10 How to Adapt the Run Sequence 

Introduction 
When you insert blocks in the chart, they are automatically installed in the run sequence. 
The installation position is decided by the "Predecessor for Installation". Certain blocks are 
also installed more than once in tasks depending on the entry in the task list assigned to the 
block type by the system attribute (S7_tasklist). Blocks with startup characteristics are, for 
example, also installed in OB100.  
You can see the other tasks in which the block is also installed in the dialog box of the 
properties, under the "To be installed in OBs/tasks" group in the "General" tab. 

Chart Installation Pointer 
Installation pointers determine the installation position for the next unit of the run sequence. 
These are the different pointers:  
● Chart installation pointer 
● Block installation pointer 

Procedure 
1. Start the run sequence editor in the CFC editor with the menu command Edit > Open Run 

Sequence. 
Here, you can make the following adaptations: 
– Move objects (SFC chart, runtime group or block) 
– Removing a Block 
– Installing Blocks 
– Setting Installation Pointers 
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Moving Objects 
You move can object by selecting it (SFC chart, runtime group, or block) in the right or left 
window and then dragging it with drag-and-drop to the object after which you want to install 
it.  
The following takes place after an object is dropped onto a runtime group: 
● The object is installed at the first position within the runtime group when the structure is 

expanded [-]. 
● The object is installed after the runtime group if the structure is not expanded [+]. 
● If the runtime group is empty, you will be asked whether or not you want to install the 

block within the runtime group. If you answer with "yes," it is installed inside the runtime 
group, if you answer with "no" it is installed after the runtime group. 

If you drag an object to a task, it is installed before the objects already installed. 
 

 Note 
Ensure when moving blocks that all the blocks of a chart are located exclusively in the 
corresponding runtime group. After moving a block to another group, the chart-oriented 
structure no longer exists and would make it difficult or even impossible to work on a chart-
by-chart basis in multiuser engineering. 

 

Removing a Block 
You can only remove (delete) blocks from a task if it is installed more than once in the run 
sequence. At least one insert point must remain.  
If this was the only block installed, it will not be deleted. Otherwise, the block is deleted and 
the run sequence of the blocks following it are adapted. 

Installing Blocks 
You can also install blocks, runtime groups, or SFC charts more than once by copying and 
pasting. Use the following functions for this purpose: 
● The corresponding menu commands 
● The toolbar icons 
● With drag-and-drop with the <Ctrl> key pressed 
● While displaying the CFC chart, drag from a CFC chart to the required place in the run 

sequence. 
 

 
 

Note 
Objects with the system identifier "@" are automatically installed in the run sequence 
while the module drivers are created. They may only be edited in the SIMATIC Manager 
with the menu command Options > Charts > Generate Module Drivers.... Do not delete or 
move these objects manually. 
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Setting Installation Pointers 
You can modify the installation pointers as follows: 
● Chart installation pointer (default OB 35)  

In the run sequence editor select the required OB or a block from the OB level (not within 
a runtime group) or a runtime group within the OB.  
Select the runtime editor menu command Edit > Predecessor for Installation Position. 

● Block installation pointer  
You cannot set the block installation pointer in the runtime editor.  
In the CFC editor select the block after which all other blocks are to be installed.  
In the chart, select the menu command Edit > Predecessor for Insertion Position. 

If the block specified as the predecessor for installation is deleted, the block installation 
pointer is set to the block installed before the deleted block. This also applies if the block is 
moved to a different chart. The block installation pointer in the destination chart is not 
changed. The moved block retains the installation position it had in the previous chart. 

Additional information 
● Online help on CFC 
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8.11.3.11 How to Define CFC Chart I/Os 

Introduction     
A chart can be supplied with I/Os in order to enable the following additional uses: 
● Inserting into a different chart and interconnecting with other charts or blocks (chart-in-

chart technique). 
● Compiling as a block type 
There are two different procedures for creating chart I/Os: 
● Create unassigned chart I/Os followed by interconnecting 
● Create the chart I/Os with the interconnection 

Creating Unassigned Chart I/Os followed by Interconnecting 
In the first step, you create the I/Os for a chart without reference to any parameters (for 
example, because the chart does not yet contain blocks and/or hierarchical charts). You 
assign the names, attributes, and defaults to the chart I/Os. 
In the second step, you place the blocks/charts in the chart, interconnect them and then 
assign the I/Os of the objects in the chart to the chart I/Os. 
1. Select View > Chart I/Os from the menu.  

The dialog box for editing chart I/Os opens and "docked" to the upper section of the chart 
window. 

2. In the hierarchy window on the left, select the desired I/O type (IN, OUT, or INOUT). 
3. In the detailed window on the right, edit the empty declaration line for the particular I/O 

type (name, data type, initial value, comment).  
Select the data type from a drop-down list. 

 

 
 

Note 
If you use this method, the attributes (for example, S7_m_c) of the block I/O are not 
adopted. You must then assign the attributes to the chart I/Os yourself. 

 

4. Use drag-and-drop to drag a block/chart I/O to a chart I/Os with a compatible data type. 
As an alternative with existing chart I/Os, 
assign the I/Os of the blocks placed in the chart and/or nested charts to the existing chart 
I/Os without needing to open the chart inputs/outputs dialog.  
1. mark the I/O and select the menu command Insert > Interconnection to Chart I/O.... 

A dialog box opens containing a list of all the available I/Os for the relevant I/O type. 
2. Select the required chart I/O and click "OK". 

 

 
 

Note 
You can only assign unconnected I/Os with a compatible data type. 
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Creating Chart I/Os with Interconnections  
In the first step create the actual chart. This is done by inserting blocks/charts and 
interconnecting them.  
In the second step, you open the window of the chart inputs/outputs and define the chart 
I/Os by connecting them to I/Os of blocks/charts placed in the chart. A new row is created 
and all the properties of the connected I/O are applied to the chart I/O (name, attribute and 
initial value). If naming conflicts occur, for example, because the same names are used in 
different blocks, the name is made unique in the chart I/O by incrementing it. 
1. Select View > Chart I/Os from the menu.  

The dialog box for editing chart I/Os opens and "docked" to the upper section of the chart 
window. 

2. In the hierarchy window on the left, select the desired I/O type (IN, OUT, or INOUT).  
The rows with I/Os are displayed in the detailed window (right window) (this is still empty 
if you are creating new chart I/Os). 

3. In the working field of the chart, select the required I/O of the block and drag the I/O to 
the right window of the chart I/Os to the "Name" box.  
The I/O is applied including all of its properties.  
Exception: interconnected I/Os are not reassigned. 

4. Follow the same procedure for all other I/Os of the blocks/charts located in the chart 
which you want to interconnect with the chart inputs/outputs. 

If you drag an I/O that already exists in the chart I/Os with drag-and-drop back to an empty 
line in the Chart I/Os window; the name automatically has a number added to it making the 
I/O name unique. 
If you drag an internally interconnected I/O (input) with drag-and-drop onto a new line then a 
copy is created and no interconnection to an internal I/O is made. 

Representation in the Side Bar 
The sheet bar displays the I/O names and comments, I/O type, and data type applied to the 
chart I/Os. The "interface I/O" type of interconnection is indicated by a small white triangle 
above the interconnection line. 

 

 Note 
If an I/O that is interconnected with the chart interface is hidden, there is no sheet bar entry. 
The interconnection can then only be recognized by the object properties of the block ("I/Os" 
tab, "Interconnection" column). 

 

Changing Chart I/O Names 
The chart I/O name does not need to include the name of the assigned block I/O. You can 
rename it. To this purpose select the name in the "Name" box and enter a new one. As an 
alternative, you can double-click on the start of the chart I/Os' line in the right-hand window 
and enter the new name in the "Properties" dialog box. 
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Assigning System Attributes 
Just like the block I/Os, you can also assign system attributes to the individual chart I/Os.  
The following rules apply: 
● If an I/O is reconfigured by dragging it to define it as a chart I/O, it applies the system 

attributes of the block I/O. 
● If a predefined chart I/O is interconnected with a block I/O, you must define the system 

attributes yourself - they are not applied from the block I/O. 
A chart with chart I/Os does not have system attributes itself (apart from those of the I/Os). 

Assigning I/Os When the Charts are Already Placed 
You can also extend a chart with chart I/Os later by adding further chart I/Os. If the chart is a 
nested chart, in other words, a chart already placed in another chart, the added I/Os may 
cause positioning conflicts. In this case, the nested chart is displayed as an overlapping 
chart (just like an overlapping block): light gray and without I/Os. The I/Os and the 
interconnections are made visible if the chart is placed at a free location. 
If you have already placed a chart within the chart and interconnected it and have 
subsequently changed the original chart (for example, by adding a further I/O), then drag the 
modified chart over the original chart. The old chart is replaced by the new one. The existing 
connections are retained. 

Additional information 
● Online help on CFC 
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8.11.3.12 How to Compile CFC Charts 

Introduction 
CFC charts must be compiled into a code that the CPU of the AS can understand. Since 
compilation always includes all the charts of an S7 program, you should only start at the end 
of the compilation. 

Procedure 
1. Select the menu command Options> Customize> Compile/Download... in the CFC Editor. 
2. Define the settings for compilation.  

You will find additional information on this topic in Section "Settings for Compilation". 
3. Select the menu command Chart > Compile > Charts as Programs.... 

The "Compile Program" dialog box opens. 
4. Activate the following check boxes if necessary: 

– Generating module drivers  
(for additional information please refer to the Online help) 

– Generating SCL source 
 

 
 

Note 
If you do not want to use the blocks of the current PCS 7 Library, you can use the 
"Module Driver Settings" command button to open a dialog box in which you can 
select the desired drive library. 

 

5. Click "OK". 

Function "Generate Module Drivers" 
The "Generate module drivers" check box is set active in the default setting, meaning that 
the driver generator is also called up before every compiling procedure.  
In special cases, such as incomplete hardware, you can deactivate the check box so that the 
"Generate Module Drivers" function is not executed. The total time of compiling is then 
reduced. 
If the "Generate Module Drivers" function is activated, the module drivers for the existing 
signal-processing blocks are created by the driver generator and interconnected with them 
prior to the compiling process.  
You will find additional information on this topic in Section "How to Generate Module Drivers 
(Page 514)". 
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Settings for Compilation 
Use the menu command Options > Customize > Compile/Download... to open the dialog box 
which contains information about the resources used in conjunction with compiling charts. 
The following can be specified: 
● The warning limits to be applied so that possible dangers are detected before 

downloading. 
● The resources to remain unused during compilation of the charts of the current chart 

folder. This can, for example, be useful if you want to solve an automation task partly with 
charts and partly by programming (for example, STL, LAD or SCL programs) and when 
you have functions (FCs) or data blocks (DBs) from other sources in your user program. 

You can also view the statistics showing how many resources (DBs, FCs) in your CPU are 
available for compiling the charts and how many are already being used. 

 

 Note 
If you only work with CFC and SFC in your program, you can leave the standard compilation 
settings unchanged. 
You will find an overview of the blocks generated during compilation in the online help. 

 

Central function "Compile and Download Objects" 
 

 Note 
Central compiling and downloading of all objects can be executed in the SIMATIC Manager 
with the menu command PLC > Compile and Download Objects.... This dialog box lists all 
the objects of the multiproject that can be compiled or downloaded. 
The hardware configuration must be downloaded to the CPU before this function can work 
(initial commissioning of the automation system). 
You can find information about this in the section "How to Download to All CPUs 
(Page 668)". 

 

Additional information 
● Section "How to Download CFC Charts to the CPU (Page 488)" 
● Section "Downloading to All CPUs (Page 668)" 
● Online help on CFC 
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8.11.3.13 How to compare CFC charts before download 

Introduction 
During configuration, testing and commissioning, there is often the need to compare a 
new/changed CFC chart with the previously loaded version before downloading it. 

Requirement 
Before the initial download in the CFC editor with the menu command Options > Settings > 
Compile/Download..., activate the check box "Generate image of downloaded program for 
comparison" in the "Settings for Compiling/Downloading" dialog box. 

Procedure 
1. In the CFC editor, select the menu command PLC > Download.... 
2. Click "Show Changes". 

The Version Cross Manager opens and the image created by the previous download (see 
section "Requirements") is compared with the version to be downloaded and 
correspondingly displayed. 

 

 
 

Note 
The "Show Changes" button is only enabled when the "Version Cross Manager" add-on 
package is installed and an image has been generated for the loaded program. 

 

3. Go back to the "Download" dialog box. 
4. Click "OK" or "Cancel". 

Additional information 
● Online help on CFC 
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8.11.3.14 How to Download CFC Charts to the CPU 

Introduction 
After compiling the charts, download them to the CPU and view the process rate in test 
mode afterwards.  
The program is downloaded to the CPU assigned to the active chart.  

Requirement 
There must be a connection between the CPU and your programming device/PC. 

Procedure 
1. Select the menu command PLC > Download.... 

The "Download PLC" dialog box opens in which you can determine the type of download. 
2. Select the scope of the download: 

– Entire program 
The entire content of the "Block" folder is downloaded and, following a prompt, the 
CPU is set to STOP. 

– Changes 
The CPU can be in the "RUN-P" mode. The download of the modified blocks is as 
safe as possible (bumpless) to avoid the CPU changing to "STOP". 

– In test CPU (entire program) 
With this type of download, you can download a modified program to another CPU or 
to an S7 PLCSIM, without losing the delta download capability in the original CPU. 

 

 
 

Note 
The possibility of the CPU going into STOP mode cannot be completely eliminated. 
The reasons for this include temporary inconsistencies that cannot be checked by the 
loader (for example, local requirements of blocks that do not include reference lists). 

 

– Load user data blocks at the same time 
This option is set as the default and is only relevant when you download changes 
(when downloading the entire program, all the blocks are downloaded including the 
user data blocks). 
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3. Click "OK".  
If download-relevant changes have been made to the user program, a message is 
displayed indicating that the program must first be compiled and you are asked whether 
you want to compile and then download. 

 

 
 

Note 
Downloading from the CFC to the PLC must take place from the programs created in 
CFC. Only this download function guarantees that the configuration data will be 
consistent with the CPU data.  
The same download function is available in the SIMATIC Manager with the following 
menu commands:  
• Menu command PLC > Compile and Download Objects... and then activate the 

"Charts" object for compiling and downloading 
• In the component view: mark the "Charts" folder and select the menu command PLC > 

Download 
 

Additional information 
● Section "How to Compile CFC Charts (Page 485)" 
● Section "Downloading to All CPUs (Page 668)" 
● Online help on CFC 
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8.11.3.15 How to Test CFC Charts 

Test mode     
CFC Editor provides test functions that support the commissioning process. These are used 
to monitor and influence the AS sequential control system process and to change setpoints if 
necessary. For this purpose switch the CFC Editor into a test mode. 

Test Mode Operating Modes 
The test mode applies to the CPU which also involves the active chart. As an alternative you 
can test in two operating modes: 
 
Operating mode Description 
Process mode In process mode, the communication for online dynamic display of the CFC 

charts and CFC instances is restricted and causes only slight extra load on the 
CP and bus.  
In process mode, if an overload occurs, a message is displayed indicating that 
the limit for bus load has been reached. In this case, you should stop the test 
mode for the CFC charts that are not absolutely necessary for the test. 
When test mode is activated, all blocks have the status "watch off". 

Laboratory mode Laboratory mode is used for convenient and efficient testing and 
commissioning. In contrast to the process mode, communication for online 
dynamic display of CFCs is unrestricted in the laboratory mode. 
When test mode is activated, all blocks have the status "watch on". 

Requirements 
● There must be a connection between the CPU and your PC. 
● The program has been downloaded. 

Activating/Deactivating Test Mode 
1. Select desired operating mode with the menu commands in the Test menu as required: 

– Test > Process Mode 
– Test > Laboratory Mode 
Make sure that it is not possible to switch the type of test used while in the test mode.  

2. Select the menu command Debug > Test Mode in CFC.  
Test mode is activated. 

3. Reselect the menu command Debug > Test Mode in CFC to stop the test mode. 
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Troubleshooting 
From within the CFC chart, you can open the block type associated with the block instance. 
Mark the required block in the CFC and select the menu command Edit > Go To > Block 
Type.  
If the source file of the block is included in the project, the tool used to create it 
(LAD/FBD/STL or SCL) opens and the block type can be edited.  
If the source file is not in the project, LAD/FBD/STL is still open. You can then only read the 
block information (exception: the system attributes of the I/Os can be edited).  
If a SFC instance is marked in the CFC chart, this is opened in the SFC Editor (the 
corresponding SFC type can be opened in the SIMATIC Manager or in the SFC Editor). 

Additional information 
● Online help on CFC 
● Manual Process Control System PCS 7, Getting Started - Part 1 
● Manual CFC for S7; Continuous Function Chart 
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8.11.3.16 How to use the "Forcing" function for block I/Os 

The "Forcing" function  
During commissioning, you can simulate a variety of values for an interconnection by 
permanently overwriting the value of an interconnection with a forced value.  
During forcing, the interconnections between the blocks are temporarily removed and force 
values are assigned to the corresponding inputs (IN or IN_OUT) of these interconnections. 
Forcing involves replacing the "force value" at the block input with the value that would have 
been supplied by the interconnection. You can activate and deactivate forcing at the input of 
the block instance at any time. 
For performance reasons, not all block inputs can be allowed to support forcing from the 
outset. You specify which inputs can be forced in the configuration of the CFC or in the 
process object view. 

 

NOTICE  
Up to 128 parameters can be used for forcing. 

 

 Note 
If you activate forcing at the chart folder, the program will need to be recompiled and 
downloaded (compilation of the entire program). 

 

 Note 
All force settings will be lost if a CPU cold restart is performed while forcing is activated. 
However, the settings will be retained in the offline program. To restore consistency between 
the offline and online programs within this context, disable "Support forcing" at the chart 
folder, compile and download the data, re-enable "Support forcing" at the chart folder and 
then recompile and download the data. 

 

Settings for forcing 
Forcing is controlled by the following attributes: 
● "Support forcing" 
● "Add forcing" 
● "Forcing active" 
● "Force value" 
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Procedure 
The use of these attributes is enabled by means of corresponding options in the component 
view of the SIMATIC Manager. 
In the object properties of the chart folder, select the "Advanced" tab and activate the 
"Support forcing" check box. This will enable the Force function. 
Once it has been enabled, you have two ways of forcing values: 
● In the CFC Editor 

In the object properties of the block input, activate the required options: 
– "Add forcing" (check box) 

This enables forcing at this input.  
This option cannot be changed in test mode.  
Each change requires the program to be compiled and downloaded again. 

– "Forcing active" (check box) 
This permanently replaces the value of the interconnection with the force value.  
The value of the interconnection becomes active again when forcing is disabled.  
A change in test mode does not require recompilation to take place. 

– "Force value" (input field)  
Enter a value here that is to be applied to the block input if the options "Add forcing" 
and "Forcing active" are enabled.  
A change in test mode does not require recompilation to take place. 
You can make the settings for more than one block input in the CFC. The 
corresponding columns for the force function are available in the "I/Os" tab of the 
block object properties. 

● In the process object view 
In the process object view, you can make the settings for the desired inputs for all blocks 
in the project. The corresponding columns for the force function are available in the 
"Parameters" and "Signals" tabs. The procedure is the same as with the CFC Editor. 

Representation 
The interconnection of the forced input is identified in the CFC chart by means of a colored 
rectangle at the block input:  
● A green rectangle means: "Add forcing" is activated 
● A red rectangle means: "Add forcing" and "Forcing active" are activated 

 

 
 

Note 
Colored rectangles are only visible for interconnection, as forcing is only possible for 
interconnected parameters. 

 

In test mode, the force value is distinguished from the other dynamic values by a different 
background color. The default setting is "light blue" and can be changed in the "Color 
Settings" (Options > Settings > Colors...). 
The background color of the force value is identical to the representation in the chart. 
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Message to WinCC with active forcing 
In the case of forcing, a new system chart @FRC_CFC is automatically installed with a 
runtime group of the same name in OB1 during compilation. The message block FRC_CFC 
is added to this chart, as well as being added to the OB100. This block triggers an incoming 
message for WinCC if "Forcing active" is set at a parameter. The block triggers a 
corresponding outgoing message after "Forcing active" has been disabled again. The 
"Active" control option of the @FRC_CFC runtime group specifies that the block should only 
be executed after the "Forcing active" function has changed. 
After forcing has been disabled, the block, the system chart, and the runtime group are 
removed from the program again during the next compiler session. 

Additional information 
● Online help on CFC 
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8.11.3.17 How to Use the Trend Display in Test Mode 

Trend display     
The trend display is a tool in the CFC editor that allows you to track the values of one or 
more signals on a CPU qualitatively over time. The trend display shows the signal 
continuously over time while it is being recorded. The trend display works with any target 
system that supports normal online operation.  

Rules for the Trend Display 
● Only one trend display can be active in the trend display window at any one time. 
● A maximum of 12 values can be recorded simultaneously. 
● For each CPU, you can create and manage any number of trend display data records. 

Each display is given a name that must be specified when it is created (this can be 
changed). 

● Both simple numerical data types (BYTE, INT, DINT, WORD, DWORD, REAL) and 
Boolean values can be used. 

● In the online display, it must be possible to make the value dynamic in the chart. 
● In each display, the following data is saved in the chart folder: 

– The name of the display 
– The allocation of the channels 
– The acquisition parameters 
– The display parameters 
– The last curve recorded (if it exists) 

● The acquisition cycle can be set in a range from 1 - 90 seconds. 

Requirement 
The test mode in the CFC Editor is activated for the current CPU. 
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Procedure 
1. Open the trend display window for the desired CPU with the menu command View > 

Trend Display. 
2. In the trend display group, click the "Rename" button and enter the desired name for the 

trend display. 
3. Enter the number of measuring points for the time axis in the "Display" group. 
4. In the "Recording" group, click the "Change" button and enter the current operating mode 

for the trend display and the abort conditions. 
5. Click "Apply". 
6. Open the CFC chart whose values you wish to display. 
7. At the function block level, select the I/O name whose value you wish to display. 
8. Select the menu command Test > I/Os > Insert In Trend Display. 

The Trend Display window opens. 
9. Select the desired channel in the "Select Channel" dialog box and click "OK". 
10. Open the Trend Display window. Enter the desired high and low limits here and then click 

"Apply". 
11. Keep repeating steps 6 to 10 until you have finished inserting all the values you want to 

display into the trend display. 
12. Click "Start" in the trend display.  

The selected values will start to be displayed. 

Export Trend Display 
1. While the trend display is open, select the menu command Options > Settings > Export 

Trend Data.... 
2. Enter the desired export format. 
3. Click "OK".  

The current trend display is exported. 

Additional information 
● Online help on CFC 
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8.11.3.18 How to Configure the AS Runtime Measurement 

AS runtime measurement        
To avoid runtime errors in new and modified configurations, we recommend that you monitor 
the execution time of the OBs. In the configuration described below, the warning limits can 
be set to any value. You can signal the warning limits over the PCS 7 OS. 
The runtime is measured with the TIME_BEG and TIME_END blocks (subsequently referred 
to as block pair). In addition, you will require the MEAS_MON block for the warning limits. 

 

WARNING  
Please note the following warnings: 
• All work on the process control system must be performed by trained service personnel. 
• Always observe the plant-specific rules and government regulations when making 

changes to your system. 
• Observe the plant-specific boundary conditions and adjust the work accordingly. 
• Always bear in mind that changes in a system can impact other sections of the system. 

 

Procedure 
1. Create a new chart in CFC (runtime monitoring ASNo x). 
2. Place a block pair in this chart - for in each cyclic interrupt OB. 

To view the cyclic interrupt OBs, select the menu command Edit > Open Run Sequence. 
3. Connect the "TM" I/Os of a block pair. 
Assigning blocks to cyclic interrupt OBs 
1. Select a TIME_xxx block. 
2. Select the menu command Edit > Open Run Sequence. 

The "Run Sequence Editor" dialog box opens. 
The selected block is highlighted in the tree view. The other block pairs can also be found 
in this OB. 
Move a pair of blocks into each of the cyclic interrupt OBs. 

3. Place the TIME_BEG block as the first block in the cyclic interrupt OB. 
4. Place the TIME_END block as the last block in the cyclic interrupt OB. 
5. Place the MEAS_MON block and interconnect it if you also require warning limits. 
6. Repeat step 3 through 5 for all blocks of the type TIME_BEG and TIME_END. 
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Assign names to the TIME_BEG and TIME_END blocks 
Assign the names before distributing to the individual project editors:  
1. Select a TIME_xxx block. 
2. Select the menu command Edit > Object Properties.... 

The "Block Properties" dialog box opens. 
3. Enter a symbolic name for the block in the "Name" field (for example, cyc36ob and 

cycob36 for the block pair for measuring the cycle time in OB36). 
4. Click "OK". 
5. Repeat step 1 through 4 for all blocks of the type TIME_BEG and TIME_END. 
Display cycle time 
1. Compile the chart which was created in step 1 and download the AS. 

In the online mode, you will see the runtime of the OB at the output TM_DIFF of the 
TIME_END block. 

Notes on Troubleshooting 
You can reduce the execution time of an OB by installing the runtime groups with reduction 
ratios and phase offsets, or starting blocks in other OBs.  
If it is possible to increase the cycle monitoring time, then it can be carried out in HW Config 
(Properties of the CPU, "Cycle/Clock Memory" tab).  
If there is a CPU stop due to failure of I/O components, the use of the SUBNET block can 
help. When an error OB (for example, OB 86, rack failure) occurs, the SUBNET block allows 
only the driver blocks that signaled the error to execute their routine. This reduces the 
execution time necessary. 

Additional information 
● Online help on CFC 
● Direct help on the blocks: click the "?" symbol in CFC and then the block header. 
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8.11.3.19 How to Configure Automatic Displaying and Hiding of Messages 

Introduction 
The following section describes how to configure the automatic displaying and hiding of 
messages in process mode. 

Requirement 
● Configuring of the technological functions in CFC and SFC is completed. 
● The block groups of the plant parts whose messages you want to hide are specified. 

Procedure 
1. Insert the "STATEREP" block into a CFC chart from the PCS 7 library. 
2. Connect the control signals from a process status logic that was created beforehand to 

the Status inputs (State 1 to max. State 32). 
3. Open the plant view in the SIMATIC Manager. 
4. Double-click the "Shared Declaration" folder. 
5. Double-click the "Listings" folder. 
6. Select the "Operating State" folder. 
7. In the pop-up menu select the Insert New Object > Value menu command and enter an 

object name that represents the state. 
Repeat the process for all states (state 1 to max, state 31). 

8. Select the object name. 
9. Select the Edit > Object Properties menu command and assign values to the individual 

states beginning with 1 (please do not use 0). 
10. Open the process object view in the SIMATIC Manager. 
11. Select the "Blocks" tab. 
12. Enter a name for the "STATEREP" block in the "Block group" column. 

 

 
 

Note 
The name of a block group must be unique throughout the multiproject. 
The names of the block groups must differ from the names that were assigned as the OS 
area identifier. 

 

13. Assign this name to all the blocks that are to belong to this group. 
14. Now select the "Messages" tab. 
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15. Select the "Block group" entry from the "Filter by column:" drop-down list. 
16. Enter the name of the block group in the "Display" input box. 
17. Assign a status (Status 1 to Status 32) to all the messages of the displayed block group 

that you want to hide. The corresponding column names are replaced by the previous 
defining of the "Operating state". 

Result 
The signal assigned to a status input controls the displaying and hiding of all the messages 
that are assigned to this status. 
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8.11.4 PCS 7 license information 

Introduction  
In SIMATIC Manager you can call a function that identifies all objects configured and 
requiring a PCS 7 license. The result is displayed per license type in the "PCS 7 License 
Information" dialog box. This allows you to check whether existing PCS 7 licenses or the 
licenses you intend to order are sufficient for your project or how many objects requiring a 
license you can still add to your project. 
In the left-hand box, all components installed which require a PCS 7 license are displayed. 
In the right-hand box the accompanying configured license objects are displayed. 

PCS 7 components 
The PCS 7 component list is determined by the installation. Multiprojects, projects and 
stations are displayed in the "Configured license objects" box.  
The following are displayed in the "Select the desired license:" box: 
● Process objects (only relevant for CFC in PCS 7) 

Countable process objects (PO) may be classed as any SFCs and block instances that 
support reporting, as well as operator control and monitoring. These are the objects that 
are transferred to the OS and require licenses. Driver blocks are not classed as POs. 
These objects are only entered in the count if they can be downloaded to an AS. Block 
instances in S7 programs without hardware assignment (at the project level or in libraries) 
are not considered. 

● Diagnosis objects (maintenance RT) 
Multiprojects or subprojects are displayed. The square bracket [...] contains the number 
of project licenses. On the next level, AS objects with subordinate ASs, then PC stations, 
network objects and user objects are displayed. 

● Process objects in WinCC 
For each sub or multiproject one or more OSs are displayed, the configured license is in 
square brackets [...] after it. OS servers, OS server standby and reference OS servers 
can be displayed. 

● Archive tags 
One or more OSs are displayed for each sub or multiproject. If an archive server is 
available, this is also displayed. On the next level, those OSs which store data on this 
archive server are listed. The number of archive tags is displayed in square brackets [...] 
on the affected objects, differentiating between short-term and long-term archiving.  
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● SIMATIC BATCH units 
The same view as in the case of process objects 

● SIMATIC Route Control 
The same view as in the case of process objects 

Additional information 
● You will find additional information on this topic in Section "Counting and booking process 

object licenses (Page 503)". 
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8.11.4.1 Counting and booking process object licenses 

Introduction   
Countable process objects (PO) may be classed as any SFCs and block instances that 
support operator control and monitoring and have the "With interrupt" property. These are 
the objects that get transferred to the OS during the compile and download operation and 
which require a license.  
Driver blocks are not classed as process objects. 
You can start a function in the SIMATIC Manager that identifies all of the process objects 
configured and booked in the Automation License Manager (ALM). The result is displayed in 
the "PCS 7 license information" dialog box. This allows you to check whether the existing 
"SIMATIC PCS 7 AS RT PO" license or the license you intend to order is adequate for your 
project and the number of process objects you can still add to your project. 

Sequence 
The compile and download operation involves detecting the process objects within the 
program, and the CPU and memory card serial numbers. Aided by this number, a program is 
assigned to the CPU. A process object info is created in the ES data management for each 
CPU that is downloaded; this records identifiers and the number of process object licenses 
used. 
During the download process, the system determines if process object licenses have already 
been used for the current CPU (and if so how many). The number of process objects that 
were identified during the last download is read from the process object info that was created 
in the ES data management. The difference between this and the current number identified 
is then compared to the number of licenses available in the Automation License Manager 
(ALM). If the required process objects are covered by the license, the difference is booked in 
the ALM and the download is executed. 
If the current program contains fewer process objects than the one previously downloaded, 
the number of available process object licenses is increased again by the download process. 
If not enough licenses are available the license violation will generate a corresponding 
message that must be acknowledged. Now you may either terminate the download or 
continue it in spite of this message. The number of licenses that are required but unavailable 
will be recorded as a shortage. If you have purchased additional licenses, these missing 
licenses are included and registered in the ALM at the next download. 
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Scenarios that involve counting process objects 
The following scenarios are taken into account when counting process objects: 
● First full download of a program 
● Downloading changes to a program on the same CPU 
● Moving a program to a different CPU 
● Ceasing to use a CPU 

 

 
 

Note 
Before removing the CPU, if there is an existing connection between the ES and the 
CPU, you will first need to book back the process objects on the CPU. 

 

● Multiple use of a program on several CPUs 

Information regarding the counting of process objects     
● Downloading in S7-PLCSIM and test CPUs: 

No process object count is performed in this case. 
● Deleting projects: 

The CFC is not informed when you delete a project. 
 

 
 

Note 
No process objects are booked back within this context.  
Therefore, you should book back the process objects prior to deletion. 

 

● Deleting chart folders or higher-level objects: 
If you delete the chart folder, the S7 program, the CPU, or the SIMATIC station, this order 
to delete is passed on to the CFC. In this case, a warning message will appear allowing 
you to abort the deletion process so that you can book back the relevant process objects 
prior to deletion. 

● Defective CPU: 
A new CPU used to replace a defective CPU will be recognized as the previous download 
destination, provided that the data stored in the process object info corresponds to the 
serial number of the CPU or the memory card. It will be assumed that the "correct" CPU 
is connected for older CPU versions that do not allow a serial number query. 
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● Booking back process objects 
Use the menu command Options > Charts > Book Back Process Objects to book process 
objects back into the Automation License Manager in cases where these relate to a 
program that is no longer going to run in the CPU.  
The program is thereby deleted from the CPU. 

 

 
 

Note 
It is particularly important to book back licenses if plant engineering is being performed at 
different locations, but the process object licenses are required for the target plant. 

 

Additional information 
● Section "How many objects can be handled in a project? (Page 61)" 

8.11.4.2 How to display the PCS 7 license information 

Introduction     
Process objects are only entered in the count if they can be downloaded to an AS. Block 
instances in S7 programs without hardware assignment (at the project level or in libraries) 
are not considered. 

Procedure 
1. Select either the multiproject or project in the SIMATIC Manager (any view). 
2. Select the Options >PCS 7 license information menu command. 

The "PCS 7 license information" dialog box opens. 

Additional information 
● Online help for the "PCS 7 license information" dialog box 
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8.11.5 Programming the SIMATIC Connections 

8.11.5.1 Introduction to Programming SIMATIC Connections 

Introduction 
You have already configured the connections in NetPro. During the configuration, you 
decided which AS will exchange data with which AS (AS-AS communication). 
The values that you want to send via the connections created in NetPro must now be 
interconnected with the blocks installed in the CFC charts for sending and receiving the 
values. The communication blocks required to this purpose are supplied with PCS 7. 

8.11.5.2 Blocks for Different Connection Types 

Introduction       
The following table shows you an overview of the communication blocks available in PCS 7 
for AS-AS communication (S7 connection). These blocks are located in the CFC in the 
PCS 7 Standard Library (call: PCS 7 Library Vxy > Blocks+Templates\Blocks > COMM). 

Blocks Available for S7 Connections 
 
Symbolic Name Brief Description 
SEND_BO  
REC_BO 

Exchange of up to 128 binary values between a send SFB and a receive SFB 

SEND_R  
REC_R 

Exchange of up to 32 binary and 32 real values between a send SFB and a 
receive SFB  

SEND_BO 
The SEND_BO block sends up to 128 BOOL values via an Industrial Ethernet connection to 
another S7 CPU, which must then call the function block type "REC_BO" (FB 208) of the 
PCS 7 Library to receive the data.  
The consistent data are available in REC_BO only on completion of the job (after arrival of 
the DONE = TRUE acknowledgment). The acknowledgment can be detected on the CIW 
output by a signal change to 0. 
By applying the value 1 to the FAST parameter, the FB allows the sending of a frame per 
function block call. This fast send job sequence is only practical when the frame can be 
transmitted in the time available between two FB calls. 
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REC_BO 
The REC_BO block receives 128 BOOL values via an Industrial Ethernet connections from 
another CPU, which must then call the function block type "SEND_BO" in the PCS 7 Library 
(FB 207) to send the data. In STEP 7, a homogeneous transport connection must be set up 
for this purpose and transferred to the automation system. 
The data are available only on completion of the job when the signal at output NDR changes 
from 0 to 1. 

SEND_R 
The SEND_R block sends up to 32 BOOL and 32 REAL change driven values over an 
Industrial Ethernet connection to another CPU that must then call the function block type 
"REC_R" (FB210) of the library PCS 7 Library to receive the data.  
The consistent data are available in REC_R only on completion of the job (after arrival of the 
DONE = TRUE acknowledgment). The acknowledgment can be detected on the CIW output 
by a signal change to 0. 
By applying the value 1 to the FAST parameter, the FB allows the sending of a frame per 
function block call. This fast send job sequence is only practical when the frame can be 
transmitted in the time available between two FB calls. 

REC_R 
The REC_R block receives 32 BOOL and 32 REAL values over an Industrial Ethernet 
connection from another CPU that must then call the function block type "SEND_R" in the 
PCS 7 Library (FB 209) to send the data. In STEP 7, a homogeneous transport connection 
must be set up for this purpose and transferred to the automation system. 
The data are available only on completion of the job when the signal at output NDR changes 
from 0 to 1. 
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8.11.5.3 How to Program the SIMATIC Connections 

Introduction 
You have configured the connection in NetPro. You have defined that communication should 
take place between two communication partners. 
During CFC configuration and in this case you must still place the corresponding 
communication blocks in a CFC chart and assign the following parameters: 
● Connection ID that you have assigned in NetPro 
● Frame identifier R_ID 
● Data that should be transmitted 

Connection ID 
A connection is identified by its ID (connection identifier).  
Several frames can be exchanged on one connection and they are identified by the R_ID 
(frame identifier). 
The ID establishes the connection between the hardware (logical connection on the CP) and 
the software (FB). Since several jobs (SEND/REC block pairs) can be handled on one 
connection, the R_ID is used for identification. 
A block pair (send, receive) must exist in the CFC chart for each frame that is transferred 
over a connection. Therefore you must configure a send block in the sending CPU and a 
receive block in the receiving CPU. 

 

Requirement 
The connection between the automation systems involved is configured in NetPro. 
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Basic Procedure 
1. Create a CFC chart in the sending CPU with a send block (SEND_BO). 
2. Assign parameters and interconnect the block (ID, R_ID, BO_00 ... BO_127, etc.). 
3. Create a CFC chart in the receiving CPU with a receive block (REC_BO). 
4. Assign parameters and interconnect the block (ID, R_ID, RD_BO_00 ... RD_BO_127 etc.). 
5. Follow the same procedure for each S7 connection you want to configure. 
6. Compile, download, and if necessary, test the configuration. 
Follow the same procedure if you use the SEND_R and REC_R block pair. 

Additional information 
● Online help on CFC 
● Direct help on the blocks: click the "?" symbol in CFC and then the block header. 



Implementing the PCS 7 Configuration  
8.11 Configuring AS Functions 

 Engineering System (V7.1) 
510 Configuration Manual, 03/2009, A5E02122455-01 

8.11.6 Programming the interface to the I/O (driver blocks) 

8.11.6.1 Concept for Drivers and Diagnostic Blocks 

Introduction 
The I/O interfacing described below also ensures high performance for capacity. The 
configuration is fast and easy to execute. 

Task of the driver and diagnostic blocks (driver blocks) 
In process control systems, diagnostics/signal processing must meet certain requirements. 
This includes the monitoring of modules, DP/PA slaves and DP master systems for faults 
and failures. 
To enable this, blocks are available in the PCS 7 library that implement the interface to the 
hardware including test functions.  
These blocks perform two basic tasks:  
● They provide the AS with signals from the process for further processing. 
● They monitor modules, DP/PA slaves, and DP master systems for failure. 
When the process signals are read in, these blocks access the process input image (or 
process image partition) (PII) and when outputting the process signals, they access the 
process output image (or process image partition) (PIQ). The description of tasks carried out 
by the various driver blocks can be found in section "List of Driver and Diagnostic Blocks 
(Page 512)". 
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Concept 
The concept of the driver and diagnostic blocks for PCS 7 can be characterized as follows: 
● The separation of user data processing (channel block) and diagnostic data processing 

(module block) 
● The symbolic addressing of the I/O signals 
● The automatic generation of the MODULE blocks by CFC 
This block concept supports all modules from the list of approved modules. 
If own and external new module types are included, the meta-knowledge for the driver 
generators can be extended by additional XML files (object and action lists). Creating these 
files is described in the manual Process Control System PCS 7 Programming Guide Driver 
Blocks. 

 

 Note 
Please note the following: 
• The library with the driver blocks have to installed using the Setup program on the PC. 

This is the only method of ensuring that the meta-knowledge required for the driver 
generator is available. You may not copy the library from another computer. 

• You can also use driver blocks from another library (for example own blocks from an own 
library). You can specify this additional library in the "Generate Driver Blocks" dialog box. 
The driver generator then searches for the block to be imported in the library specified 
here. If the block is not found here, it is searched for in the library specified in the control 
file (XML file). 

• If the S7 program contains a signal-processing block (CH_xx, CH_U_xx, PA_xx), but this 
is not from one PCS 7 libraries, you have to specify the version of the driver library from 
which the driver blocks are to be imported in the "Generate Module Drivers" dialog box. 

 

Time-Optimized Processing  
To allow time-optimized processing during runtime, the organization blocks for error handling 
(for example, OB85, OB86, etc.) are automatically divided into runtime groups and the driver 
blocks installed in the relevant runtime groups.  
If an error or fault occurs, the SUBNET block, for example, activates the relevant runtime 
group, the RACK block or module block contained in the runtime group detects the problem, 
evaluates it and outputs a control system message to the OS.  
The diagnostic information of the module block is also transferred (output OMODE_xx) to the 
corresponding CHANNEL block (input MODE). If necessary, this information can be 
displayed in a process picture (color of the measured value changes or flashing display, etc.) 
by a PCS 7 block that can be operated and monitored on the OS or by a user block. 
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8.11.6.2 List of Driver and Diagnostics Blocks 

Introduction         
The blocks for signal preprocessing listed under "Driver Blocks" must be inserted by the user 
and interconnected to the module. The "Generate Module Driver" function is used to 
configure these and interconnect them to the diagnostic blocks. 

Overview of the diagnostic blocks 
 
Block Description Purpose 
OB_BEGIN, OB_END CPU diagnostics and connection diagnostics 
SUBNET Monitors the DP master system 
RACK Monitors the station/rack and DP slaves 
MOD_1, MOD_2, MOD_3, 
MOD_4, MOD_D1, 
MOD_D2, MOD_D3, 
MOD_MS, MOD_CP, 
MOD_HA 

Monitors I/O modules, motor starters, communication module, HART 
field devices 

CONEC Monitors the status of the connection of an AS and reports error 
events 

OB_DIAG Monitors the DP and PA slaves for failure and recovery. Interface 
block for including DP V0 slaves that are not supported by the PCS 7 
driver blocks. 

OB_DIAG1 Monitors DP or PA slaves at a DP master system to DP V0 or DP V1 
or at a DP/PA Link (Y Link) to DP V1 

DIAG_AB Evaluates the status register of the Anybus DP link. 
DPDIAGV0 Monitors the status of the modules of an ET 200S as DPV0 slave 

(IM 151-1 High Feature) downstream of a Y link 
IM_DRV Transmits time-stamped process signal changes and non-signal-

specific events (special messages) to the OS 
PO_UPDATE Executes the functions "Hold last value" and "Use substitute value" of 

the output modules when a CPU is restarted (OB100) 
PS Monitors the status of a power supply of a rack and reports error 

events 
PADP_L00, PADP_L01, 
PADP_L02 

Monitors DP/PA field devices (DPV0 slaves) downstream from a 
DP/PA or Y link operated as a DPV0 slave. 

PADP_L10, MOD_PAX0, 
MOD_PAL0 

Monitors PA field devices (DPV0 slaves) downstream from a DP/PA or 
Y link operated as a DPV1 slave. 

PA_TOT Processes the cyclic parameters of the "Totalizer" PA profile of a PA 
field device complying with PROFIBUS PA 3.0 class A and B 

DPAY_V1 Enables the field-device-specific blocks that are located downstream 
of the DP/PA and Y links and monitors them. 

DPAY_V0 Monitors DP/PA and Y link as DPV0 slave 
DREP, DREP_L Evaluates the diagnostic data of a diagnostic repeater for 

PROFIBUS DP 
FM_CNT Assigns parameters and controls the FM 350-1 and FM 350-2 

modules 
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Block Description Purpose 
OR_M_16, OR_M_32 Determines the value status from a redundant signal module pair 
RCV_341 Serial reception with the CP 341 
SND_341 Serial transmission with the CP 341 
CPU_RT Determines the runtime of the individual OBs and their share of the 

runtime 
OR_M_8C, OR_M_16C, 
OR_M_32C 

Is used to form a value status, channel-granular, from two redundant 
signal modules. 

Overview of the driver blocks 
Blocks for signal preprocessing 
 
Block Description Purpose 
CH_U_AI, CH_U_AO, 
CH_U_DI, CH_U_DO 

Signal processing of S7-300/400 SM I/O modules or a PA field 
devices. 

CH_AI, CH_AO, CH_DI, 
CH_DO, CH_CNT, 
CH_CNT1, CH_MS 

Signal processing of S7-300/400 SM I/O modules 

PA_AI, PA_AO, PA_DI, 
PA_DO, PA_TOT 

Signal processing of PA field devices with PA profile 

FF_A_AI, FF_A_AO, 
FF_A_DI, FF_A_DO 

Signal processing of FF field devices with FF profile 

Additional information 
● Online help of the corresponding blocks (CFC) 
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8.11.6.3 How to Generate Module Drivers 

Automatic Generation of Module Drivers 
A function is available for signal processing in PCS 7 that automatically generates the 
module drivers, interconnects and configures them correspondingly after configuration of the 
hardware has been carried out with HW Config and after configuration of the technological 
functions in CFC. These module drivers are responsible for the diagnostics and reporting of 
faults during signal processing.  
The function is called up when the S7 program is compiled if the "Generate Module Drivers" 
check box is activated (default setting). If module drivers have already been generated for 
the project, a check is carried out during processing whether the module drivers have to be 
updated. Updating is necessary if the hardware configuration has changed in the meantime. 

Manual Generation of the Module Drivers 
The "Generate Module Drivers" functions can also be called up manually in the SIMATIC 
Manager. 

Procedure 
1. Open the SIMATIC Manager and the project in which you want to generate the drivers. 
2. Select the chart folder of a S7 program in the component view. No charts may be 

selected in this folder. 
3. Select the menu command Options > Charts > Generate Module Drivers.... 

As an alternative, you can activate the "Generate Module Drivers" check box in the 
"Charts as Program..." dialog box in CFC when compiling CFC/SFC charts.  
Each time you recompile, only the required module drivers will be generated or updated. 

4. Select the required options and click "OK"K 
 

 
 

Note 
If the address areas for digital input and output modules have been packed in HW Config 
("Pack Address"), the driver generator cannot supply unique addresses to the 
corresponding blocks.  
The addresses may not be packed in order to have a defined slot assignment for each for 
each module. 
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How the Function Works 
The "Generate Module Drivers" function generates new system charts (with the name "@..." 
assigned by the system) in which only driver blocks are inserted by the driver generator that 
are assigned parameters and interconnected according to the hardware configuration. In 
addition, the channel blocks installed in the user charts are interconnected with the driver 
blocks by the driver generator if the symbolic interconnection information exists. Every 
system chart should not contain more than 50 blocks.  
The OB_BEGIN/OB_END blocks for one CPU, RACK blocks for one rack and the MODULE 
blocks are installed in runtime groups. The runtime groups created by the driver generator 
are assigned an ID, so that, for example, they can be deleted automatically again when they 
no longer contain blocks. Runtime groups without this ID are not processed by the driver 
generator. If RACK/MODULE blocks are installed in a different runtime group by the user, 
they are moved to the runtime groups with the relevant ID by the driver generator. 

 

NOTICE  
No changes are allowed to the system charts since these involve system functions 
(indicated by "@"). This also applies to changes to the installation in OBs or runtime 
groups. 

 

Parameter Assignment/Interconnection in the CFC Chart 
Requirements: You have already assigned a symbolic name for each channel of a module in 
the hardware configuration.  
The signal-processing blocks (CHANNEL blocks) are assigned to the module channels 
according to their symbol names.  
The signal-processing blocks have a block I/O labeled "VALUE". Specify the symbolic name 
of the module channel at this I/O (Select the I/O in the CFC, context menu command 
Interconnection to address...). 

Additional information 
● Section "How to Configure the Distributed I/O (Page 382)" 
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8.11.6.4 How to Create Your Own Driver Blocks 

Drivers for Peripheral Devices or I/O Modules not Integrated for Use in PCS 7     
The driver concept covers the I/O devices and I/O modules currently released for use in 
PCS 7. You will find the released I/O devices and I/O modules in the document "PCS 7 - 
Released Modules.pdf" on the Toolset DVD Process Control System; PCS 7-Software 
Toolset". 

Procedure 
If you want to connect other peripheral devices or I/O modules to the AS in a fixed 
configuration, you can create the driver blocks yourself using the driver concept (one block 
per device with user data and diagnostic data processing).  
You then store the driver blocks you have created in the master data library. You can use 
these in the same way as the supplied driver blocks (signal-proceessing blocks and 
diagnostics blocks). 

Description with Step-by-step Instructions 
You can find more information on how to create your own driver blocks in the manual 
Process Control System PCS 7; Programming Guide Driver Blocks 
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8.11.7 Creating Process Tags from Process Tag Types (Multiproject) 

8.11.7.1 Introduction into Creating Process Tags from Process Tag Types (Multiproject) 

Introduction     
Use the wizard for process tag types to copy the process tag type from the master data 
library to the specified destination project. There it is inserted as a process tag. Then the 
associated data is imported from an import file. 
Depending on the entries in the import file, you can create any number of process tags in 
one import action. As a result of the import, a process tag of this process tag type is created 
in the target project for every row of the import file according to the specified hierarchy path. 

Sources for Process Tag Types 
The following process tag types can be stored in the master data library. 
● Standardized process tag types from the control system libraries PCS 7 Advanced 

Process Library and PCS 7 Standard Library for motors, valves, PID controllers, for 
example 

● User-created process tag types from CFC charts 

Overview 
Creating process tags from process tag types and subsequent editing of the tags involves 
the following topics: 
● Creating a Process Tag Type from a CFC Chart (Page 518) 
● Changing a Process Tag Type (Page 520) 
● Inserting a Process Tag into the Project (Page 522) 
● Creating Numerous Process Tags Automatically (Page 525) 
● Editing a Process Tag (Page 526) 
● Adapting a Process Tag (Page 527) 
● Adapting a Process Tag to a Process Tag Type (Page 529) 
● Restoring Lost Process Tag Type Assignments (Page 531) 
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8.11.7.2 How to Create a Process Tag Type from a CFC Chart 

Options for Creating a Process Tag Type  
The following options exist for creating process tag types: 
● Creating a process tag type with a new or existing CFC chart. 
● Change an existing process tag type: Adding or removing I/Os / messages 

These modifications may be necessary due to a change of the functionality in the CFC 
(for example, interconnections or parameter assignment changed, blocks added or 
deleted). The starting point can be either the process tag type in the master data library 
or a process tag already contained in the project. 

● Reestablishing a deleted process tag type from a process tag. 
The newly created process tag type is stored in the master data library. 

Requirement 
A CFC chart has been created in the project or in the master data library that contains the 
automation functions, parameters, and messages of the process tag to be implemented 
according to a specified process tag description.  

Procedure 
1. Select the intended CFC chart in the SIMATIC Manager (any view). 
2. Select the menu command Options > Process Tags > Create/Modify Process Tag Type... 

.The wizard is started and displayed with the "Introduction" page. The current master data 
library is displayed. 

3. Click "Continue". 
The wizard changes to the "Which I/Os do you want to assign to the process tag type?" 
page. 

4. In the left window "I/Os in the chart of the process tag type", select the flagged I/O for 
"Parameter" and "Signal". (By double clicking or by marking and clicking on the "arrow" 
button.)  
The flagged I/O is adopted and displayed bold. 

5. Edit the selected I/O points in the right window, "I/O points for parameters/signals".  
You can edit the columns "Parameter/signal" (using a drop-down list),  
"Process tag connector" and "Category" (using a drop-down list).  
The drop-down list opens after clicking the corresponding input box. 

6. In the left window, "I/Os in the chart of the process tag type", select the messages of the 
relevant blocks.  
All the messages are displayed in the "I/O points for messages" window. 

7. Verify your selection and click "Finish". 
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Result 
The new process tag type is stored in the master data library. The CFC chart from which the 
process tag type originated, is located in the S7 program. There it can be reused or deleted if 
no longer required. 

Additional information 
● Online help for PH, IEA and PO 
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8.11.7.3 How to Change a Process Tag Type 

Introduction  
If you change a process tag type already used to create process tags, you may decide 
whether the changes should be applied to the process tags that were created prior to 
changing the process tag type. 

Requirement  
The CFC chart is stored in the master data library. 

Procedure 
1. Select the desired CFC chart in the SIMATIC Manager (Plant View). 
2. Select the menu command Options > Process Tags > Create/Modify Process Tag Type... 

.The wizard is started and displayed with the "Introduction" page. The current master data 
library is displayed. 

3. Click "Continue". 
The wizard changes to the "Which I/Os do you want to assign to the process tag type?" 
page. 

4. In the left window "I/Os in the chart of the process tag type", select the flagged I/O for 
"Parameter" and "Signal". (By double-clicking or by marking and clicking the "arrow" 
button.)  
The flagged I/O is adopted and displayed bold. 

5. Edit the selected I/O points in the right window, "I/O points for parameters/signals".  
You can edit the columns "Parameter/signal" (using a drop-down list), "Process tag 
connector" and "Category" (using a drop-down list).  
The drop-down list opens after clicking the corresponding input box. 

6. In the left window, "I/Os in the chart of the process tag type", select the messages of the 
relevant blocks.  
All the messages are displayed in the "I/O points for messages" window. 

7. If no process tags can be located in the project for the modified process tag type, click 
"Continue" and then "Finish".  
The wizard closes. 
Otherwise: 

8. Click "Next".  
The wizard switches to the "Do you want to finish the process tag type and apply changes 
to the existing process tags?" page. 

9. Click "Make".  
The change log appears. 

10. Click "Exit". 
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Result 
Changes made to the process tag type and the process tags are completed. The wizard 
closes. 

Changes in the Process Tag Type Chart 
 

 Note 
Changes that you make in the chart of the process tag type are not taken into account when 
the process tags are synchronized. In this case, you must carry out a new import for the 
changed process tag type.  
In the import file, add the keyword "delete" for each process tag to be deleted in the "Import 
mode" column of the "General column group".  
To create a new process tag, insert an additional row in which the field of the "Import mode" 
column remains empty. Any interconnections made to these process tags are lost. 
You can also delete process tags manually in the SIMATIC Manager. 
The import file must also be amended accordingly if I/Os were added during the modification 
process. 

 

Additional information 
● Online help for PH, IEA and PO 
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8.11.7.4 How to Insert a Process Tag Type to a Project 

Adding Process Tag Types 
The following options are available in the SIMATIC Manager for adding process tags to the 
project: 
● Use the menu command Insert > Process Tag (from library)... to open the "Process Tag 

Types" catalog in the process object view. 
All the process tag types from the master data library are listed in this catalog. 
– You can drag the process tag type to a hierarchy folder in the process object view or 

in the plant view. This creates a process tag in this hierarchy folder. 
– Another option is to copy a process tag type in the catalog with the <Ctrl> + <C> keys 

and then paste it into one or more hierarchy folders in succession using <Ctrl> + <V>. 
● Using the menu command Options > Process tags > Import... (if the process tag types 

are selected in the master data library), you can carry out an import and create any 
number of process tags from a process tag type. You can find information about this in 
the section "Creating Numerous Process Tags Automatically (Page 525)". 

● Drag existing process tags to a hierarchy folder of another project (or use "Copy" and 
"Paste"). If you paste into the same project, you will be asked whether you want to 
overwrite or rename the existing object. Please remember that the chart name may only 
occur once. 

 

 
 

Note 
If you create process tags by copying and pasting, you still need to assign parameters 
and interconnect them. 
If you work with the import file, the data relating to the parameter assignment and 
interconnection is taken from the import file.  
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8.11.7.5 How to Create an Import File or Assign it to the Process Tag Type 

Introduction 
An import file must be assigned to the desired process tag type in order to create process 
tags. The following steps can be carried out with the "Assigning an import file to a process 
tag type" wizard.  
● Assign an existing import file 
● Open and check an import file that has already been assigned 
● Create and assign a new import file 

Procedure 
1. Select the applicable process tag type in the master data library. 
2. Select the menu command Options > Process Tags > Assign/Create Import File.... 

The wizard is started and displayed with the "Introduction" page. The current master data 
library is displayed. 

3. Click "Continue". 
The wizard changes to the "Which import file do you want to assign to the process tag 
type?" page.  
The "Import file" drop-down list displays either a file or - if no assignment has been made 
- the "No import file assigned" text. 

4. You have the following options: 
– To check an assigned import file to find out whether all the information is accurate, 

open the file by clicking "Open File" and edit the file with the IEA file editor if 
necessary. 

– To assign an import file that exists in the project, click "Other File..." and select the 
desired file in the dialog field. 

– To create a new import file, click "Create Template File..." and select the desired 
columns/column groups in the dialog field. Then edit the template with the IEA file 
editor that you open with "Open File". 

 

 
 

Note 
The "Column title" column can be edited if you select the "No import file assigned" text 
in the "Import file" drop-down list. You can change the titles and then generate the 
template file.  
In the "Importing" column, a check mark indicates which I/O points exist in the import 
file. If the check mark is not there, the flagged I/O exists in the process tag type but 
not in the currently assigned import file. 

 

5. Click "Finish". 
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Result 
The import file is assigned to the process tag type. 

Additional information 
● Section "Creating/Editing Import Files with the IEA File Editor (Page 646)" 
● Online help for PH, IEA and PO 



 Implementing the PCS 7 Configuration 
 8.11 Configuring AS Functions 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 525 

8.11.7.6 How to Create Numerous Process Tags Automatically 

Requirement 
An import file must have been assigned to the process tag types. 

Note to Reader 
You can find a detailed description of the settings of the import files in the section 
“Importing/Exporting Process Tags/Models“. The following is a description of the basic 
procedure used when import files have already been assigned. 

Procedure 
1. Select the desired hierarchy folder, project node / process tag library (hierarchy folder in 

the master data library), or the process tag type. 
2. Select the menu command Options > Process Tags > Import.... 

The "Import" dialog box opens.  
The wizard searches for the process tag types and corresponding import files (in all 
hierarchy subfolders as well) and lists them. The import is executed for all the import files 
listed. 

3. If you do not want to import certain files, you can select them and remove them from the 
list with the "Remove" button.  
By clicking "Other File", you can search for a different import file and select it instead of 
the other file. 

4. Click "Continue" and then "Finish". 

Result 
The actual import process starts.  
Depending on the setting of the "Only show errors and warnings in log" check box, the 
complete list of import activities or only the errors that occurred are displayed in the log 
window. 
The log is saved in a log file. The name and path of the file are displayed below the log 
window. You can modify this setting with the "Other File" button. 

Additional information 
● Section "How to Import Process Tag Types and Models (Page 639)". 
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8.11.7.7 How to Edit a Process Tag 

Introduction       
In the process object view, you can edit individual process tags of the project, such as 
changing comments, values, and interconnections (as long as these are defined as 
"Parameter" or "Signal"). 

Procedure 
1. Open the process object view with the menu command View > Process Object View. 
2. Select the desired process tag in the tree (left window). 
3. In the table on the right, select the required tab and make your modifications there (in the 

editable cells). 
Example: You want to interconnect an I/O with another I/O.  
Requirements: The I/O of the block is defined as a parameter. 
1. Select the process tag. 
2. Select the "Parameters" tab. 
3. Select the cell for the required I/O in the "Interconnection" column. 
4. Select the menu command Insert Interconnection... in the shortcut menu. 

The "Insert Interconnections" dialog box opens. 
5. Select the process tag in the tree and the block containing the I/O you want to 

interconnect. 
6. Click "Apply".  

As an alternative, you can double-click the I/O or drag the I/O to the selected cell in the 
process object. 

Result 
The interconnection is entered; the dialog box remains open. The next cell of the column is 
selected. 

Renaming process tags 
 

NOTICE  
After renaming process tags and subsequently compiling the OS, all interconnections in 
pictures and archives as well as tags in scripts are automatically adapted. However, the 
names of the archive tags are not adapted; these continue to show the old process tag 
names. You can change the archive tag names accordingly. In this case, be sure that you 
also adapt the associated trend controls, for example. 
The interconnections are only corrected for the local process tags of the OS. Any 
interconnections to process tags of another OS via server-server communication must be 
adapted manually. 
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8.11.7.8 How to Adopt Process Tags 

Introduction     
You can reassign CFC charts that have no assignment to the process tag type during import 
if the constraints are observed. 

Requirements 
The names of the CFC chart blocks and I/Os correspond with the names on the process tag 
type. 
This applies to the following: 
● I/Os that are identified as a parameter/signal. 
● Blocks identified for messages. 

Situation 1: identifying existing charts as process tags 
You have created a CFC chart, for example, configured a motor control and have copied this 
chart several times manually. You have changed or adapted the copies to deal with different 
requirements. 
In future, you want to use the functions of the assistant and create further process tags by 
importing. You want to continue using the previously created charts and want them to be 
identified as process tags.  

Procedure - Scenario 1 
1. Use one of the existing charts to create a process tag type with the menu command 

Options > Process Tags > Create/Modify Process Tag Type....  
You will find additional information on this topic in Section "How to Create a Process Tag 
Type from a CFC Chart (Page 518)". 

2. Assign a suitable import file to the process tag type with the menu command Options > 
Process Tags > Assign/Create Import File.... 

3. Start the import with the menu command Options > Process Tags > Import... and open 
the import file on dialog page 2(3) using the "Open File" button. 

4. Add each chart to be adopted to a row in the file. Continue until the import can be 
finalized. 

 

 
 

Note 
Please note the following: 
• Make sure that the charts you adopt are located in the folder entered in the 

"Hierarchy" column of the import file. 
• If you want to retain the values of the charts and you do not want them to be 

overwritten with the values of the process tag type, then delete the corresponding 
fields in the import file. 
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Result - Situation 1 
If the conditions for adopting the process tags are fulfilled, the CFC chart becomes the 
process tag of the imported process tag type and the I/O name and category is applied from 
the process tag type. Any additional process tag identifiers (message block or block I/Os) are 
reset. 
Additional blocks and I/Os that are not in the process tag type are tolerated and ignored. 
If the adopted process tag is part of the replica of a model, the IEA flags remain unchanged. 
If, however, it is not part of a replica, then preset IEA flags are reset if necessary. 

Situation 2: chart has lost its assignment to the process tag type 
You have canceled the assignment to the process tag type via the object properties of a 
CFC chart that was already a process tag (with the menu command Object Properties > in 
the "Process Tag Type" tab, chart selected, "Cancel" button). 
In order to reassign the chart proceed as described under Items 3 and 4 of Situation 1. 

Situation 3: Process tag type was copied manually  
A process tag type was inserted by copying and pasting several times within the project or 
from the master data library. You now want to assign these copies to the process tag type 
and create or amend the IEA file. 

Procedure - Situation 3 
1. Select the process tag type in the PH. 
2. Select the menu command Options > Process Tags > Export.... 

The "Import/Export Wizard" dialog box opens. 
3. Click "Continue" and select the export file in the next dialog box ("Open File" or "Other 

File" buttons). 
4. Click "Continue". 
5. If necessary, select the path and the name of the log file and click "Finish". 

The export is executed and the export file is created. The actions are logged in the 
window and stored in the log file. 

6. Click "Back" to check the export file and then open the export file you have just created. 

Result - Situation 3 
All copies of the process tag type are included in the export file.  
You can now use these files for further work, by adding entries when needed, and then using 
them for the import process. 
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8.11.7.9 How to Synchronize Process Tags with the Process Tag Type 

Introduction 
When a process tag type is modified, the process tags existing in the multiproject are 
automatically synchronized. Synchronization can be carried out directly if modifications result 
in inconsistencies between the process tag type and the process tags (for example:not all of 
the process tags of a project were accessible during the synchronization process). 

Requirements 
● Process tags are available in the multiproject. 
● The modified process tag type is located in the master data library. 

Procedure 
1. Select the applicable process tag type (in the master data library) and then select the 

menu command Options > Process Tags > Update..... 
The "Synchronize Process Tags" wizard is started, and the current master data library is 
displayed. 

2. Click "Continue". 
The wizard changes to the "Do you wish to synchronize the existing process tags the 
process tag type?" page. 

3. Click "Finish". 
The synchronization process log appears. 

Process Tag Type Modifications 
 

 Note 
Changes that you make in the chart of the process tag type are not taken into account when 
the process tags are synchronized. In this case, you must carry out a new import for the 
changed process tag type.  
In the import file, add the keyword "delete" for each process tag to be deleted in the "Import 
mode" column of the "General column group". To create a new process tag, insert an 
additional row in which the field of the "Import mode" column remains empty. 

 

Subsequent Synchronization of Process Tags for Inaccessible Process Tags 
Process tags cannot be synchronized according to the method described above if the 
following circumstances apply: 
● If the name of the process tag type was changed 
● If synchronization was carried out at a time when all of the process tags of this type could 

be accessed (for example: after the project was distributed to distributed engineering). 
● If these process tags were subsequently restored to the project. 
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Synchronizing the Process Tags at a Later Time 
You can later synchronize the process tags that could not be accessed using the following 
procedure: 
1. Change the name of the relevant process tag type. 
2. Select the menu command Options > Process Tags > Synchronize....  

All process tags are synchronized with the modified process tag type. 
3. Rename the process tag type with its original name and repeat the synchronization. 
All process tags are now adapted to the corresponding process tag type. 

Additional information 
● Online help for PH, IEA and PO 



 Implementing the PCS 7 Configuration 
 8.11 Configuring AS Functions 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 531 

8.11.7.10 How to Restore Lost Process Tag Type Assignments 

Introduction 
If process tags exist in a project but the corresponding process tag type is no longer in the 
master data library, it is not possible to import or export these process tags. The 
import/export file structure is always required for the import/export process. This, however, is 
located only on the process tag type. 

Remedy 
You can create a process tag type from an existing process tag in the project and reestablish 
the assignment. 

Procedure 
1. Select the applicable process tag in the project. 
2. Select the menu command Options > Process Tags > Create/Change Process Tag 

Type.... 
The wizard is started and the current master data library is displayed. 

3. Click "Continue". 
The wizard displays an error message and asks whether the selected chart should be 
created as a process tag type in the master data library. 

4. Click "Yes". 
The wizard changes to the "Which I/Os do you want to assign to the process tag type?" 
page. 

5. Click "Finish". 

Result 
The process tag type is created and stored in the master data library. The assignment of 
process tags to the process tag type is therefore reestablished. 
You now still have to assign the import file or create a new one. 

Rules 
 

 Note 
It is possible to modify the process tag type if necessary during this procedure. Existing 
process tags are adapted automatically. 

 

 Note 
If the process tag was adapted for a specified technological task, for which the process tag 
type is irrelevant or may not even be present, then the corresponding changes (for example: 
interconnections, assignment of parameters) have to made in the CFC chart. 
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8.11.8 Creating Sequential Control Systems (SFC) 

8.11.8.1 Introduction to Creating Sequential Control Systems (SFC) 

SFC Charts and SFC Editor 
An SFC chart is a sequential control system in which up to 8 (SFC type: up to 32) separately 
startable sequences can be intergrated, in the form of sequencers.  
An SFC chart is assigned uniquely to a CPU and is also executed completely on this CPU. 
The SFC editor is a tool for creating sequential control systems. 
Additional information can be found in the SFC online help or in the manual SFC for S7; 
Sequential Function Chart. 

Sequential control system 
A sequential control system is a controller with step-by-step execution and where control 
passes from one state to the next state depending on conditions.  
Sequential control systems can be used, for example, to describe the manufacture of 
products as event-controlled processes (recipes).  
With a sequential control system, functions from basic automation (typically created with 
CFC) are controlled by operating and state changes and executed selectively. 

Using Sequential Control Systems 
The typical applications of sequential control systems involve processes and plants with 
discontinuous characteristics. Sequential control systems can, however, also be utilized in 
continuous working plants.  
Examples: 
● Approach and withdrawal movement 
● Operating point change 
● State change during interference 
Sequential control systems can be used at the following levels within a plant: 
● Plant level (synchronization of units and common resources, for example, routing) 
● Unit level (tank, mixer, scales, reactor, etc.) 
● Group control level (proportioning, stirring, heating, filling, etc.) 
● Device control level (open valve, start motor, etc.) 
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How It Works 
Using the SFC editor, you create your sequential control system using graphic tools. The 
SFC elements of the chart are positioned in the sequencer according to fixed rules. You do 
not have to concern yourself with details such as algorithms or the assignment of machine 
resources. This allows you to concentrate on the technological aspects of the configuration. 
After creating the plan topology, switch over to configuring the object properties. Here you 
will need to formulate the sequencer properties as well as the individual steps and 
transitions. In this way, you configure the actions and conditions. 
After configuration, you compile the executable machine code with SFC, download it to the 
PLC and test it with the SFC test functions. 

Additional information 
● Online help on SFC 
● Manual SFC for S7; Sequential Function Chart 
● Manual Process Control System PCS 7, Getting Started - Part 1 
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8.11.8.2 Advantages and Uses of SFC Types/SFC Instances 

The Type/Instance Concept       
The type/instance concept can be used to create sequential control system types that 
generate SFC instances when they are placed in a CFC chart. 
The following is achieved with the type/instance concept: 
● Central modifiability 
● Reusability 
● Ability to download changes 

SFC type 
In SFC, there is not only the object type "SFC chart" but also "SFC type".  
The SFC type allows the definition of sequential control systems including an extendable 
interface.  
The SFC type sequential logic is based on the SFC type interface I/Os. In contrast to the 
SFC chart, the SFC type does not access process signals randomly.  
Alone, the SFC type cannot execute. An SFC type, just like a function block type, must be 
placed in a CFC chart before it contains an executable object, in this case an SFC instance. 
To run an SFC instance, both the SFC type and the SFC instance are downloaded to the 
automation system. 

 

 Note 
SFC types can also be located in libraries (for example, SFC Library).  
For SFC types to be usable, they have to be located in the chart folder of the program. This 
can be realized as follows: 
• If you place an SFC type from the library directly into a CFC chart, the SFC type is copied 

into the chart folder of the program. The SFC type is then visible in the CFC catalog in the 
"Blocks" tab and can be placed in the CFC chart from there. 

• Copy the SFC types from the chart folder of the library into the chart folder of the 
program. The SFC types can then be used in the CFC catalog in the "Blocks" tab and can 
be placed in the chart from there. 

 

SFC instance 
An SFC instance is derived from an SFC type. For this purpose the SFC type is inserted in a 
CFC chart in the same way as a function block type in CFC. The SFC instances are 
therefore always assigned to a CFC chart and are addressed via the chart. Like CFC 
instances, SFC instances are represented as blocks: their interface is visible in the CFC 
chart.  
SFC instances are not displayed in the SIMATIC Manager since they can only be addressed 
via the CFC chart. With the assignment of the CFC chart to the plant hierarchy, the SFC 
instances it contains are also indirectly assigned to the plant hierarchy. 



 Implementing the PCS 7 Configuration 
 8.11 Configuring AS Functions 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 535 

Basic Procedure 
1. You create the SFC type in the SFC-Editor. At the same time you configure its 

sequencers and the SFC interface. 
You will find additional information on this topic in Section "How to Create an SFC Type 
(Page 555)". 

2. You create the SFC instances in the CFC chart and set the parameters and interconnect 
them. 
You will find additional information on this topic in Section "How to Generate an SFC 
Instance (Page 558)". 

Precompiled Sequencer Template 
Preassembled sequencer templates are located in the SFC Library. You can copy these 
templates and modify them for your own use. 

SFC Visualization on the OS 
Use the SFC Visualization optional package to operate and monitor the SFC charts on the 
OS. The required configuration work for the operation and monitoring of SFCs can also be 
carried out with SFC visualization. Refer to the configuration manual Process Control 
System PCS 7; Operator Station for more information. 

Additional information 
● Online help on SFC 
● Manual SFC Visualization for S7 
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8.11.8.3 Overview of the Steps in Configuration 

Introduction 
The following is a series of steps that you must execute when configuring sequential control 
systems (SFC charts) for your PLC: The same series of steps also applies to the 
configuration of SFC types, however in this case, the I/Os and characteristics must still be 
defined. 

Requirement 
A project structure is created in the SIMATIC Manager in which you can configure CFC/SFC 
charts.  

Overview of Configuration Tasks 
 
Step What? Description 
1 Specify the chart 

properties  
When you specify the chart properties, you can change the chart 
name and add a comment. 

2 Create the topology 
of the sequential 
control system  

Sequential control systems are configured with SFC charts. This is 
accomplished by inserting the steps and transitions for one or more 
sequencers and if necessary adding structure elements. 

3 Configure the 
sequencer 
properties  

For each sequencer, you configure the start condition, the action for 
preprocessing and for postprocessing. 

4 Configure the steps 
(in the "Object 
Properties" dialog 
box) 

Formulate the actions in the steps. The actions contain instructions 
for changing the values of block inputs and shared addresses or for 
activating and deactivating runtime groups or other SFC charts. 

5 Configure the 
transitions  
(in the "Object 
Properties" dialog 
box) 

Formulate the step-enabling conditions in the transitions. The 
conditions read the values of block I/Os, of shared addresses, or the 
state (active/inactive) of runtime groups or other SFC charts. If the 
conditions following the specified logic operations are true, the next 
step becomes active and its actions are executed. 

6 Adapt the operating 
parameters and 
runtime properties  

By setting the operating parameters, you specify the behavior of the 
sequential control system, such as the mode (manual, auto), step 
control mode (T, C, T and C...), SFC startup after CPU restart and 
other chart execution options (cyclic operation, time monitoring, 
autostart, etc.).  
The runtime properties of an SFC chart determine how the SFC chart 
is included in the execution of the entire structure on the PLC (in the 
window of the CFC runtime editor). 

7 Compile the SFC 
charts  

During compilation, the CFC and SFC charts of the active chart folder 
are converted to an executable user program (Compile: Entire 
Program/Changes). 
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Step What? Description 
8 Download the SFC 

program  
Following compilation, you can download the program to the CPU 
(entire program or changes only). 

9 Introduction to 
testing the SFC 
program  

After compiling and downloading, you can test the SFC program in 
process mode or in laboratory mode. Using the SFC test functions, 
you can run the sequential control system in various operating modes 
and step control modes and monitor and modify the values of 
addresses on the CPU. You can also influence the most important 
operating modes (STOP, clear/reset, RUN, etc.) of the CPU. 

 
 

 Note 
When entering units, ensure that the following special characters are not used: [ ' ] [ $ ].  
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8.11.8.4 How to Create a New SFC Chart 

Introduction 
You can create SFC charts and SFC types in the SIMATIC Manager. 

Requirements 
● The required project structure already exists in the SIMATIC Manager. 
● The hierarchy folder used for creating the chart must be assigned a chart folder. 

Procedure 
1. Select the desired hierarchy folder in the plant view of the SIMATIC Manager. 
2. Select the menu command Insert > Technological Objects > SFC.  

The SFC chart is inserted into the hierarchy folder. The SFC chart is automatically 
assigned to a chart folder. 
The chart receives a standard name from the system (for example, SFC(1)). 

3. Change the name according to your requirements. The name must be unique on the 
CPU. This is checked by the system. 

4. Double-click the new SFC chart in the right window (content of the hierarchy folder). 

Result 
The SFC editor starts (if it is not already started) and the SFC chart is displayed in its initial 
state in a window of the SFC editor. 

Naming 
 

 Note 
Please note the following: 
• The names of the SFC charts can be a maximum of 22 characters. 
• The names of the SFC types can be up to a maximum of 16 characters long. Although 

you can enter 24 characters in the properties, when the instances are created, only 16 
characters are permitted. 

• The following characters are not permitted in names: \, ., /, ", % 
 

Additional information 
● Online help on SFC 
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8.11.8.5 How to Specify the Sequencer Properties 

Introduction 
The sequencer properties are used to determine how the sequencer starts or which 
sequential control systems start first. The sequencer of a newly created SFC chart (type) 
already has a start condition (RUN = 1). As a result, it is connected to the operating state 
logic (OSL). For each further sequencer you must specify the start conditions yourself. The 
start conditions and the priorities determine which sequencer starts. 

Procedure 
1. Select the menu command Edit > Sequencer Properties... in the SFC editor.  

The "Properties" dialog box opens. 
2. Set the sequencer properties listed in the following table. 

Selectable Sequencer Properties 
 
Tab Property Meaning 

Name Name of the current sequencer 
You can type in a maximum of 16 characters. 

Comment Comment on the sequencer.  
You can type in a maximum of 80 characters.  

General 

Priority Priority of the sequencer from 1 to 32  
The priority decides which sequencer of an SFC starts when the 
start conditions of several sequencers are true at the same time.
Note: Priority 32 is the highest priority, 1 is the lowest. 

Start condition  Specifies the conditions that must be true to start the sequencer 
(for example, "SFC.RUN = Active" starts the sequencer when 
the SFC chart is in the "RUN" operating mode). 
To allow a three-stage transition logic, you can combine the 
conditions logically to create a Boolean expression. 

OS Comment  Specifies the properties of the sequencers and the properties of 
the transitions. 
You can enter an OS comment with a maximum length of 256 
characters for every condition in the SFC chart / SFC type. 

Preprocessing  Defining of actions that are to be executed after the start of the 
sequencer in each cycle before the steps and transitions are 
processed 

Postprocessing  Defining of actions that are to be executed after the start of the 
sequencer in each cycle after the steps and transitions are 
processed 

Additional information 
● Online help on SFC 
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8.11.8.6 How to Create the Topology of the Sequencer 

Chart Depiction in the SFC-Editor 
The newly created SFC chart (SFC type) initially consists of one sequencer that can be 
expanded with up to eight (SFC type: up to 32) sequencers. Each sequencer is created in a 
separate working window. You can switch between the separate sequencers using the tabs 
at the bottom of the window. 
A sequencer in the initial state consists of the start step, a transition, and a final step. 
The chart topology is formed by the sequences of steps and transitions.  
If you decide to insert or delete SFC elements in the sequencer, then these elements are 
displayed automatically according to predefined rules. The following factors are, for example, 
dictated by the rules: 
● The distances between the chart elements 
● The extent of the steps and the transitions 
● The configuration of alternative sequences 
The display/layout rules can be modified at any time with the menu command Options > 
Customize > Representation.... 
You can center the entire plant topology on the display area. In this way the elements are 
distributed evenly on the chart. The zoom functions can increase or reduce the size of the 
display as a percentage determined by the zoom factor. 

Creating the Sequencer 
Use the menu command Insert > Sequence > ... in order to create a sequencer.  
A new sequencer is inserted into a preselected position in the chart. The window is 
expanded by a tab at the bottom of the window. Each tab contains the name of one of the 
sequencers in the SFC chart (RUN, SEQ1, ...). 
You can insert SFC elements into the sequencer with the menu command Insert > ....  

Syntax Rules 
The basic rule for chart topology is as follows: a step (S) is always followed by a transition 
(T) and vice versa (sequence: S-T-S or T-S-T). The editor automatically abides by the rules. 
Example:  
If you insert a simultaneous branch in a sequencer following a transition but prior to a step, a 
transition is created automatically before the step, since the syntax rules require a transition 
before and after a simultaneous branch. 
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Overview of the SFC Elements 
 
SFC Element Function 
Sequencer Status-dependent and event-controlled processing is possible in SFC with 

sequencers. A SFC chart contains sequencers that can be controlled through 
differently defined start conditions. 

Sequencer 
elements 

An SFC chart consists of 1 to 8 sequencers and an SFC type of 1 to 32 
sequencers, each with one sequence consisting of the following sequencer 
elements (basic elements): 
• Step 
• Transition 
Outside a sequence, the following element also exists: 
• Text 
The remaining elements are structures that are made up of different basic 
elements: 
• Sequence 
• Simultaneous Branch 
• Alternative Branch 
• Loop 
• Jump 

Step In SFC, a step allows actions to be executed. The following step types exist:  
• Initial step 
• Normal step 
• Final step 

Initial Step Each SFC chart has exactly one initial step. When you first create a chart, an initial 
step, a transition and a final step are created (initial state).  
The initial step can be copied, cut or deleted. However, you can copy, cut or delete 
initial step actions. 
The initial start actions are configured precisely like the actions of any other step. 

Final Step Each SFC chart has exactly one final step. When you first create a chart, an initial 
step, a transition and a final step are created (initial state).  
The final step can be copied, cut or deleted. However, you can copy, cut or delete 
final step actions. 
The final start actions are configured precisely like the actions of any other step. 

Transition The transition is a basic element of SFC and contains the conditions under which a 
sequential control system passes control from one step to the next. 

Text A text is an element that can be inserted in charts. You can enter comments in your 
charts using this element. Texts inserted in charts can be edited, moved, copied, 
cut, and deleted. 

Sequence Structure element in the SFC containing a sequence of steps and transitions. A 
simultaneous branch or an alternative branch consists of at least two sequences 
arranged side-by-side and containing at least one element. 

Simultaneous 
Branch 

In SFC, a simultaneous branch allows several sequences to be run at the same 
time. The simultaneous branch is complete when all the sequencers have been 
completed (synchronization). 

Alternative 
Branch 

A structural element in SFC, that consists of at least two sequencers. Only the 
sequencer whose transition condition is satisfied first is processed by the AS. 
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SFC Element Function 
Loop In SFC, a loop allows a jump back to a selected previous point. The return jump is 

executed when the SFC chart is at the start of the loop and the loop transition is 
fulfilled. In this case, the sequence in the loop is run through again. 

Jump The jump is a structure element of SFC, with which the execution of an SFC chart 
can be continued at a different step in the same chart depending on a transition 
condition. 

Adding SFC Elements 
To add further chart elements to the SFC chart, select the icon of the required SFC element 
in the element bar. 
The mouse pointer changes its appearance from an arrow to the selected icon with a 
positioning cross-hairs. To insert the chart element, position the cross-hairs at the required 
position on a link and click the left mouse button. The inserted chart elements are selected 
and displayed in color. 

Data backup  
 

 Note 
All changes made in the SFC editor are saved immediately - there is therefore no extra save 
option in SFC. Please remember that you cannot undo or cancel changes in the SFC editor 
after closing the editor without saving. 
We recommend archiving the data contained in the entire multiproject or the relevant project 
using the menu command File > Archive.... 
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8.11.8.7 How to Configure Steps 

Steps     
Actions are defined in the steps. These contain statements with which, for example, values 
of block inputs can be modified or other SFC charts activated or deactivated. 

Properties of the Steps 
You can make the following settings in the "Properties" dialog box for the step: 
 
Tab Meaning 
General In this tab, you can edit the general properties of the selected step (for example 

name, comment). 
Initialization 
Processing 
Termination 

The tabs for the processing phases (actions) "Initialization", "Processing" and 
"Termination" all have the same structure. Here, you configure the statements 
that will control the process.  
In these tabs, you can define the following actions for the steps: 
• Actions that should be carried out once upon activating the step (initializing) 
• Actions that should be carried out in cycles when the step is processed 

(processing) 
• Actions that should be carried out once upon exiting the step (termination) 
Each step for which you have defined an action is displayed in dark gray. This 
means that you can see at a glance whether or not a step has already had 
parameters assigned. 

Procedure 
1. Select the step you want to edit in the SFC Editor. 
2. Select the menu command Edit > Object Properties.... 

The "Properties" dialog box for the step opens. 
3. Enter the desired properties in the "General" tab. 

 

 
 

Note 
All other tabs can theoretically be edited in the same manner. 

 

4. Select the required tab (Initialization, Processing, Termination) and position the mouse 
pointer in the input field for the left address (the operator) of the required statement line. 

5. Click "Browse". 
The "Browse" dialog box opens.  
In this dialog box, you can see the CFC charts of the project with the PH assignment, the 
chart name, and the comment in the first three columns. In the next three columns, you 
can see all the blocks belonging to the chart selected in the first columns. As soon as you 
select a block, the last column displays all the relevant I/Os. 

6. Select the required CFC chart. 
All the blocks for the chart are displayed. 
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7. Select the required block. 
All the I/Os for the block are displayed. 

8. Select the required I/O and select the shortcut menu command Apply I/O. 
The selected block I/O is entered with the corresponding complete path. The mouse 
pointer is automatically positioned in the input field for the right address. 

9. Depending on the left address, enter a setpoint for the right address such as TRUE or 
FALSE or an interconnection onto a block I/O (menu command Browse). 
For additional information refer to the section "Syntax for the interconnection of block I/O". 

10. Click "Apply" to apply the settings. 
11. Click "Close". 
12. Follow the same procedure if you want to edit more steps. 

Additional information 
● Online help on SFC 
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8.11.8.8 How to Configure Transitions 

Transitions        
A transition contains the conditions according to which control passes from one step to its 
successor step or steps. Several conditions can be logically combined using Boolean 
operators. The result of the logic operation decides whether control is passed to the next 
step. Transitions are theoretically configured in the same way as steps. 

Properties of Transitions 
You can make the following settings in the "Properties" dialog box for the transition: 
 
Tab Meaning 
General In this tab, you can edit the general properties of the selected transition (for 

example, name, comment). 
Condition In this tab, you define the conditions for the SFC chart / SFC type that cause 

transitions to enable the next step in the sequencer. 
To allow a three-stage transition logic, you can combine the conditions logically 
to create a Boolean expression. 

OS Comment In this tab, you can enter an OS comment with a maximum length of 256 
characters for every condition in the SFC chart / SFC type.  
Formulated conditions are entered as defaults in the "Conditions" or "Start 
Condition" tab. 

Conditions 
Transition conditions allow for the following options: 
● Values to be read from block I/Os or shared addresses 
● To logically combine the read values with a constant or another read value using Boolean 

operators (=, >, <, ...) 
The result of a condition is a Boolean variable that can be logically combined with the results 
of other conditions. 
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Procedure 
1. Select the transition you want to edit in the SFC Editor. 
2. Select the menu command Edit > Object Properties.... 

The "Properties" dialog box for the transition opens. 
3. Enter the desired properties in the "General" tab. 
4. Select the "Condition" tab and position the mouse pointer in the input field for the left 

address (the operator) of the required statement line. 
5. Click "Browse". 

The "Browse" dialog box opens.  
In this dialog box, you can see the CFC charts of the project with the PH assignment, the 
chart name, and the comment in the first three columns. In the next three columns, you 
can see all the blocks belonging to the chart selected in the first columns. As soon as you 
select a block, the last column displays all the relevant I/Os. 

6. Select the required CFC chart. 
All the blocks for the chart are displayed. 

7. Select the required block. 
All the I/Os for the block are displayed. 

8. Select the required I/O and select the shortcut menu command Apply I/O. 
The selected block I/O is entered with the corresponding complete path. The mouse 
pointer is automatically positioned in the input field for the right address. 

9. Select the required operator with which the two addresses will be logically combined. 
10. Depending on the left address, enter a setpoint for the right address such as TRUE or 

FALSE or an interconnection onto a block I/O (menu command Browse). 
11. Specify the 3-level transition logic. The Boolean operators are designed as buttons. 

Clicking on the operator switches it from "AND (&)" to "OR (≥1)". Changing “AND" to 
"NAND" and “OR" to "NOR" is carried out by clicking the address output.  
The negation is displayed by a period in bold print on the output line. 

12. Open the "OS Comment" tab.  
In this tab, you can enter an OS comment with a maximum length of 256 characters for 
every condition in the SFC chart / SFC type.  
Formulated conditions are entered as defaults in the "Conditions" or "Start Condition" tab. 
Opening the “OS Comment" tab the first time applies the formulated condition as an OS 
comment. This can be changed at any time.  
If the OS comment is the formulated condition, in other words the default, this is indicated 
at the start of the line by the "Link" symbol. 

13. Click "Apply" to apply the settings. 
14. Click "Close". 
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Syntax for the Interconnection of Block I/Os 
In SFC, the operator combines two addresses in one condition. Both addresses are 
compared to each other. The result is TRUE or FALSE. 
The following addresses are possible:  
● < (less than) 
● <= (less than or equal to) 
● = (equal to) 
● >= (greater than or equal to) 
● > (greater than) 
● <> (not equal to) 

Additional information 
● Online help on SFC 
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8.11.8.9 How to Adapt the Operating Parameters and Runtime Properties 

Introduction 
You can display and modify the operating parameters and runtime properties for the active 
SFC chart. The initial state of the SFC chart is specified with the operating parameters.  

Adjustable Operating Parameters and Runtime Properties of the SFC Chart 
You can make the following settings in the "Properties" dialog box for the SFC chart: 
 
Tab Meaning 
General You can enter or change the following in this tab: 

• Name of 
• Author 
• Comment 
• Write-protected 

PLC Operating 
Parameters 

In this tab, you can change the default settings for the operating 
parameters of the AS and the start options of the SFC chart.  
• Default settings for the initial state of the SFC chart: 

– "Step Control Mode" 
– "Operating Mode" 
– "Command Output" 
– "Cyclic Operation" 
– "Time Monitoring" 

• Options for the SFC startup after a CPU complete restart 
– "Initialize SFC" 
– "Retain SFC status" 

• Options for starting the SFC chart: 
– "Autostart" 
– "Use default operating parameters when SFC starts" 

The settings for this option determine the runtime characteristics of the 
sequential control system. 

OS In this tab, you can specify if the SFC chart should be included in the next 
compilation of the OS. 

Version In this tab, you can change the version number of the SFC chart. 
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Adjustable Operating Parameters and Runtime Properties of the SFC Chart 
You can make the following settings in the "Properties" dialog box for the SFC type: 
 
Tab Meaning 
General You can enter or change the following in this tab: 

• Name 
• Author 
• Comment 
• Write-protected 

PLC Operating 
Parameters 

In this tab, you can change the default settings for the operating 
parameters of the AS and the start options of the SFC type.  
• Default settings for the initial state of the SFC type: 

– "Step Control Mode" 
– "Operating Mode" 
– "Command Output" 
– "Cyclic Operation" 
– "Time Monitoring" 

• Options for the SFC startup after a CPU restart 
– "Initialize SFC" 
– "Retain SFC status" 

• Options for starting the SFC chart: 
– "Autostart" 
– "Use default operating parameters when SFC starts" 

The settings for this option determine the runtime characteristics of the 
sequential control system. 

Options In this tab you can set the options for SIMATIC BATCH for the SFC type.  
• Category: 

– None" 
– "EOP" 
– "EPH" 

• Allow operator instructions 
• SIMATIC IT 

– "MES-relevant" 
• Control strategy selection 

Version In this tab, you can change the version number of the SFC type. 

Procedure  
1. Select the menu command SFC > Properties.... 

The "SFC Chart Properties" dialog box opens. 
2. Adapt the operating parameters and runtime properties. 
3. Click "OK". 
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Operating mode 
In the list box select whether the execution is controlled by the operator or carried out 
automatically. 
● AUTO (process mode):  

The execution is controlled automatically. The program defaults apply. The defaults are 
determined either by the parameter assignment or the interconnection of SFC external 
view inputs in the CFC chart. In the "Auto" mode, the step control modes "T" and "T / T 
and C" can be set. 

● MANUAL (operator mode) (default):  
The execution is controlled manually by the operator (for example, in the SFC test mode 
or on the OS in SFC). All step control modes are permitted. 

Step Control Mode 
In the list box select the step control mode in which the SFC chart/SFC instance will run.  
The different step control modes affect the behavior of prepared or true transitions.  
It is possible to change the step control modes in all operating modes. The individual step 
control modes are mutually exclusive. 
 
Step Control 
Mode 

Meaning 

T 
(Default) 

Control with transition  
The sequential control system runs controlled by the process (automatically). 
When a transition is true, control passes to the next step or steps by deactivating 
predecessor steps and activating successor steps. 

C Control with operator-confirmation  
The sequential control system runs exclusively with operator control. The 
transitions do not need to be true. For each successor transition of every active 
step, an operator prompt is set and control passes to the next step or steps only 
after the operator has confirmed the prompt. 

T and C Control with transition and operator-confirmation  
The sequential control system runs controlled by the process and with operator 
control. If the successor transition of an active step is satisfied, an operator prompt 
is set and control passes to the next step or steps only after the operator has 
confirmed the prompt. 
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Step Control 
Mode 

Meaning 

T or C Control with transition or operator-confirmation 
The sequential control system runs controlled by the process or with operator 
control. For each successor transition of an active step, an operator prompt is set 
and control passes to the next step or steps when the operator prompt has been 
confirmed. If the transition is true before the operator prompt is acknowledged, 
control passes to the next step or steps without operator intervention 
(automatically). 

T / T and C Step control mode: step-specific confirmation by operator  
The sequential control system proceeds in the following manner: 
• process-controlled in steps without the "confirmation" identifier  

Each completed transition following a step without this identifier passes on 
control without operator intervention (corresponds to T). 

• operator-controlled in steps with the "confirmation" identifier 
If the transition following an active step with this identifier is completed, an 
operator prompt is set and control passes to the next step or steps after the 
prompt has been confirmed (corresponds to T and C). 

Execution and Start Options 
 
Option Meaning 
Command output Default: On 

During installation and commissioning, or if errors occur, blocking command 
output in conjunction with certain operating modes can bring the sequential 
control system to a defined state without influencing the process. 
The actions are processed by activated steps if the check box is activated, 
otherwise the actions are not processed. 

Cyclic Operation Default: Off 
When the sequence is completed and the check box is activated, the SFC 
chart or the SFC instance that was created by this type, switches over from 
the operating state "completed" into the operating state "starting". The SFC 
chart or the SFC instance automatically begins with start-processing. 

Time Monitoring Default: Off 
If this option is activated (check mark), the monitoring times (# 0 ms) set as 
parameters in the object properties of the steps are evaluated. A message is 
generated (step error) if this time is exceeded. 

Autostart Default: Off 
After restarting and if the check box is activated, the SFC chart or the SFC 
instance that was created by this type, is now in the operating state "starting". 
The SFC chart or the SFC instance automatically begins with start-
processing. Otherwise the SFC chart or the SFC instance is in the operating 
state "ready" waiting for the start command. 

Use default 
operating 
parameters when 
SFC starts 

Default: Off 
If this option is activated, all the operating parameters set in the "Defaults" 
group (and possibly changed in test mode) are reactivated when the chart or 
instance starts. 
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8.11.8.10 Working with Charts, Types, and Instances 

Introduction          
You can do the following with SFC charts and SFC types: 
● In the SIMATIC Manager and SFC Editor: 

– Create new 
– Open for editing 
– Change the properties 

● In the SIMATIC Manager only: 
– Copy and delete 

● Within a CFC chart: 
– Copying and deleting SFC instances 

Opening SFC Charts, SFC Types and SFC Instances 
Starting the SFC Editor with the menu command Start > SIMATIC  > STEP 7 > SFC - Create 
Sequential Control Systems will open the SFC Editor without the chart window; no chart will 
be opened. 
 
What? How ? 
Open SFC chart in the 
SFC Editor 

In the SFC editor, select the menu command SFC > Open... and then select 
the required chart.  

Opening an SFC Type 
in the SFC Editor 

Select the menu command SFC > Open... in the SFC editor. To open an 
SFC type, you must select the entry "SFC type" from the drop-down list in 
the "Open" dialog box field from the "Object type" field. 

Open SFC chart in the 
SIMATIC Manager  

Select the required SFC chart in the component view or plant view with the 
menu command Edit> Open Object. 

Open SFC type in the 
SIMATIC Manager  

Select the required SFC type in the component view with the menu 
command Edit > Open Object. 

Opening SFC 
Instances  

Select the SFC instance in the CFC chart and in the shortcut menu the 
menu command Open. 
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Copying, Moving and Deleting SFC Charts, SFC Types and SFC Instances 
 

What? How and Where? 
Copying SFC  
charts 

Copying entire charts allows you to copy structures or substructures you have tested, even 
to other CPUs. You can copy not only individual charts but also an entire chart folder with all 
the charts it contains.  
Note that the name of the chart folder within the multiproject must be unique. 

Moving SFC  
charts 

Moving entire charts allows you to move structures or substructures you have tested, even 
to other CPUs. You can move not only individual charts but also an entire chart folder with all 
the charts it contains.  

Copying  
SFC charts 

SFC types can be copied in the SIMATIC Manager (component view). The runtime objects 
belonging to the SFC type are also copied. If the generated version of the SFC type is not 
up-to-date (time stamp of the FB older than the time stamp of the SFC type), a message is 
displayed. If the SFC type already exists at the destination when you copy the SFC type 
(SFC type with the same name), this is overwritten after a prompt for confirmation and any 
differences from the existing type are transferred to the SFC instances. 

Moving  
SFC charts 

SFC types can be moved in the SIMATIC Manager. SFC types can only be moved when no 
SFC instances of the SFC type exist in the source. The runtime objects belonging to the 
SFC type are also moved. If the SFC type already exists at the destination (SFC type with 
the same name), this is overwritten after a prompt for confirmation and any differences to the 
existing type are transferred to the SFC instances. 

Copying  
SFC instances 

If you copy an SFC instance within a CFC chart or between CFC charts in the same chart 
folder, or copy a CFC chart within a chart folder, the SFC instance is copied. The runtime 
objects belonging to the SFC instance are also copied.  
When you copy an SFC instance between CFC charts from different chart folders or copy a 
CFC chart to a different chart folder, the SFC type is also copied. 

Moving  
SFC instances 

Only the position of the SFC instance changes if you move an SFC instance within a CFC 
chart.  
If you move an SFC instance between CFC charts of the same chart folder, the SFC 
instance is moved. The runtime objects belonging to the SFC instance are retained.  
When you move a CFC chart to another chart folder, the SFC type is also copied. 

Deleting charts and  
SFC types 

You only delete SFC charts and SFC types in the SIMATIC Manager.  
You can delete SFC charts in the same way as other objects (hierarchy folder, OS pictures, 
etc.); mark them and select the menu command Edit  > Delete. 
You can only delete SFC types if there are no SFC instances for the SFC type. 
If there are instances for an SFC type, a message will appear indicating this.  
The runtime objects belonging to the SFC type are also deleted. 

Deleting  
SFC instances 

You delete SFC instances in the CFC chart or indirectly by deleting the CFC chart in the 
SIMATIC Manager. The runtime objects belonging to the SFC instance are also deleted. 

Additional information 
● Online help on SFC 
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8.11.8.11 How to Configure Messages in SFC 

Introduction 
You can configure specific message texts for each SFC chart/SFC type. You can change the 
message text in a dialog box. 

Procedure 
1. Select the menu command SFC > Message... in the SFC Editor.  

The "PCS 7 Message Configuration" dialog box opens. 
2. Use the table below to configure the block-related message types and messages for 

display on the PCS 7 OS. 

Settings for Messages 
 
Column Meaning 
Message name This column displays the name of the block-related message within the message 

configuration. 
Message Class Select the required message class in this field. 
Priority Select the priority level for acknowledging individual messages in this field. The higher the 

value, the higher the priority. 
Event Enter the message text in this field. 
Single acknowledgment Activate the check box, if the message should be acknowledged as a single message. 
Info text Enter the info text in this field. 
With acknowledgment Activate this check box if the messages generated should be acknowledged. Depending on 

whether this check box is activated or not, the "Message class" column will either display 
those classes that can be acknowledged or those that cannot be acknowledged. 

 For the SFC type only! 
Whether or not this column is displayed depends on whether you are editing message types 
or messages. By putting a check mark in this column, you can interlock the text you entered 
in the column before it.  

 
 

 Note 
If you edit existing messages, the entries for Origin, OS area, and Batch ID are displayed in 
red and italics if they were edited during message configuration and the entries are not 
uniform. To make the entries uniform, overwrite the displayed text. 
If you have not yet created a PCS 7 OS, a display device is created automatically and given 
an internal name. 
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8.11.8.12 How to Create an SFC Type 

SFC type      
The SFC type is managed in the SIMATIC Manager component view.  
An SFC type does not have any runtime properties, since it is not relevant to execution of the 
program. An SFC type cannot be installed in the run sequence. 

Creating an SFC Type 
There are two possible methods for creating and modifying a SFC type: 
● Creation/change in a library  

The advantage of this is that the master for the SFC type is always located in the library 
and that the test project always remains executable until a new version of the SFC type is 
adopted. 

● Creation/change in a project  
This is advantageous since you are working directly with the master and each change to 
the SFC type can be checked immediately. 

Requirement 
● A PCS 7 project is created. 

Procedure 
1. Mark the chart folder and select the menu command Insert > S7 Software > SFC Type in 

the component view of the SIMATIC Manager. 
The next free FB number is automatically reserved for the SFC type being created, and 
this is copied into the block folder as a type template with this number. The FB number 
can be changed later in the "Object properties" dialog box. 
When you first create an SFC type, the blocks required for compilation are copied to the 
current program and then managed in the ES. The blocks are contained in the delivery of 
the PCS 7 Library. 

 

 
 

Note 
SFC types cannot be assigned to a hierarchy folder in the plant view since they 
themselves are not relevant to execution (from the perspective of the process to be 
automated). 

 

2. Select the SFC type in the SIMATIC Manager and then the menu command Edit > Object 
Properties....  
The "SFC Type Properties" dialog box opens. 

3. Set the SFC type properties and the operating parameters.  
You will find additional information on this topic in the Online Help and in Section "How to 
Adapt the Operating Parameters and Runtime Properties (Page 548)". 

4. Select the SFC type in the SIMATIC Manager and then the menu command Edit > Open 
Object....  
The SFC type opens. 
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5. Select the SFC Editor menu command View > Characteristics and add the control 
strategies, setpoints (note: do not forget the control strategy assignment), process values, 
block contacts, etc. 

6. Add and then configure the sequencers. Edit the start conditions. 
You will find additional information on this topic in Section "How to Specify the Sequencer 
Properties (Page 539)". 

7. Configure messages for the SFC type.  
You can configure a maximum of seven messages that require an acknowledgment and 
five messages that do not. The SFC type itself requires the remaining available 
messages (one per message type and 10 notify messages for SIMATIC BATCH).  
You will find additional information on this topic in Section "How to Configure Messages in 
SFC (Page 554)". 

8. Configure a text box in the SFC editor via menu command SFC > Text Boxes.... You can 
configure a text box for an SFC type, as done with the SFC chart. 

You can find additional configuration options in the online help on SFC and in the manual 
SFC for S7; Sequential Function Chart. 

Templates for SFC Type 
The following SFC types can be found as templates in the library "SFC Library" under "SFC 
Library > Blocks+Templates > Templates": 
● "Type states"  

This SFC type already contains several sequencers for condition-based editing of the 
sequential control system. 

● "Type Ctrl strategy" 
This SFC type contains a control strategy based editing of the sequential control system. 

You can copy these templates and modify them for your own use. 

Interface of the SFC Type 
The SFC type has an interface analogous to the SFC chart. The interface is created when 
the SFC type is generated. The interface already includes the SFC type standard interface, 
which was derived from the SFC type template. The standard interface is required to provide 
SFC system functionality (operating modes, operating states, step control modes) on the 
SFC type interface. 
● The elements of the standard interface cannot be moved or deleted. The initial value, 

comment, and attributes can be modified. 
● You can expand the interface by adding I/Os with the interface editor; characteristics can 

be added with the characteristics dialog box. The same applies for these elements as for 
the standard interface. 

● Special feature of block contacts: the interface is extended by the predefined I/Os of a 
block type. This is made possible by the "S7_connect" attribute (predefined I/Os for 
interconnecting to the SFC type). 

● If more connections of the interface are to be displayed than can be displayed on three 
chart partitions, some block I/Os can be set invisible. 

● During configuration, only the interface I/Os can be used to formulate step assignments 
or transition and start conditions. As a consequence, addresses in assignments or 
conditions are always references to I/Os of the interface. Here, textual interconnections 
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are also possible. As a result the SFC type is self-contained. There are no external 
accesses originating from SFC type which bypass the interface. 

Additional information 
● Online help on SFC 
● Manual SFC for S7; Sequential Function Chart 
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8.11.8.13 How to Generate an SFC Instance 

SFC instance      
An SFC instance is generated by dragging the SFC type from the CFC block catalog into the 
CFC chart.  
The SFC types in the chart folder of the AS are displayed in the CFC block catalog (in "All 
blocks" and in the folder of the family if they are assigned to a family, otherwise in the "Other 
blocks" folder). 
The SFC instance is displayed like a CFC instance block. If there is not enough free space to 
position the SFC instance and it overlaps one or more objects that have already been 
placed, it will be displayed as an overlapping block (light gray and without visible I/Os). After 
moving them to a free location in the chart, the overlapping blocks are displayed as normal 
blocks again. 
You can assign parameters to the SFC instance and interconnect it in test mode. 
If you have defined block contacts, when you interconnect an I/O of this block, the other I/Os 
are automatically interconnected (predefined I/Os for interconnection with the SFC type 
("S7_connect" attribute)). The most important I/Os are already predefined in the 
technological blocks of the PCS 7 Library. 

Procedure 
1. Open the CFC chart in which you want to interconnect an SFC instance with the blocks of 

basic control. 
2. Select the SFC type in the CFC block catalog "Other blocks" and place it in the CFC 

chart. 
An instance of the SFC type is generated in the CFC chart. 

3. Specify the properties of the SFC instance. 
In the CFC, you can modify the general properties (name, comment) in the object 
properties of the SFC instance. 

4. Adapt the operating parameters and options to suit the instance: 
Using the Open command in the shortcut menu, open the SFC instance in the CFC and 
adapt the operating parameters, which determine the runtime characteristics in the AS, in 
the "Properties" dialog box. 
You will find additional information on this topic in Section "How to Adapt the Operating 
Parameters and Runtime Properties (Page 548)". 
As an option, you can select which of the control strategies specified by the SFC type is 
to be used for the SFC instance. 

5. Configure and interconnect the interface of the SFC instance: 
Assign the parameters for the I/Os of the SFC instance in the CFC using the object 
properties or in the SFC using the "I/Os" interface editor.  
In CFC, you interconnect the I/Os of the SFC instance with the I/Os of the CFC blocks or 
with shared addresses or you create textual interconnections. 

Additional information 
● Online help on SFC 
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8.11.8.14 How to Modify an SFC Type Centrally 

Introduction 
SFC types can also be kept in the master data library. To be able to use them, you need to 
copy the SFC types from the chart folder of the master data library into the chart folder of the 
S7 program of the AS. The SFC types in the CFC block catalog of the "Blocks" tab (other 
blocks) are visible in the result and can be placed in the CFC chart from there. You can find 
information about this in the section "How to Create an SFC Instance (Page 558)".  
To run an SFC instance, both the SFC type and the SFC instance are downloaded to the 
automation system. 

Rules for Changing the Configuration 
● In general, changes made on the SFC type, which prevent or limit a download of changes 

in RUN, may only be carried out upon operator confirmation. 
● Modifications to the interface of the SFC type are transferred to the SFC instances 

immediately. This means that the SFC type and its instances can only be downloaded in 
AS RUN mode if all the SFC instances of this SFC type are deactivated or are 
deactivated briefly during the download process. 
The instances are deactivated during the download following operator confirmation and 
restarted after the download, again following operator confirmation. The execution of the 
instance then depends on the process state and on the configuration of the instances 
(especially the start conditions).  

● While changes are being downloaded, the system prevents the SFC instances from being 
processed in the AS and prevents access to the SFC instances via interconnection in 
CFC. 

● Changes to the topology (step/transition sequence, changed jump target) or 
step/transition configurations are made to the SFC type and become effective in the SFC 
instances only following compilation and downloading.  
Inactive sequencers can be downloaded at any time when modifications are made to the 
topology during downloads, whereas the SFC instances must be deactivated before 
downloading active sequencers. 

● Changes to the step and transition configuration can be downloaded at any time even if 
SFC instances of the SFC type are currently being processed in the AS. 

● After configuration changes are made, you need to compile the OS to ensure that the 
current data is available there. 
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Procedure 
1. Open the SFC type in the chart folder. 

The SFC type is opened in the SFC editor. 
2. Carry out the required changes in the SFC editor. 

The changes are done on the SFC type and on each of the existing SFC instances. 
3. Compile, download, and test the program. 
4. Copy the SFC type to the master data library so that the modified version is available in 

the CFC block catalog. 
5. If the modifications made are relevant for assigning parameters or interconnections, 

these modifications must be carried out in all the SFC instances. 
In order to do this, open the relevant CFC charts and complete them. 

Additional information 
● Section "How to Download SFC Charts (Page 565)" 
● Manual Process Control System PCS 7, Getting Started - Part 2 
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8.11.8.15 How to Compile Charts and Types 

Compile 
During compilation (scope: entire program) all charts (including SFC types) of the current 
chart folder are transferred block-by-block to the SCL Compiler and compiled. After changing 
the SFC chart (SFC type, SFC instance), you only need to compile the changes (scope: 
"changes"). 
Consistency is automatically checked during the compiling process. You can also start this 
check manually. 
After compiling, download the user program to the CPU, test it and then put it into operation. 

Settings for Compiling 
Use the menu command Options > Customize > Compile/Download... to open the dialog box 
containing the information about the resources used in conjunction with compiling charts. 
The following can be specified: 
● To decide which warning limits will apply so that possible dangers are detected before 

downloading. 
● To decide which resources are to remain unused during compilation of the charts from 

the current chart folder 
This can, for example, be useful if you want to solve an automation task partly with charts 
and partly by programming (for example, STL, LAD or SCL programs) and when you 
have functions (FCs) or data blocks (DBs) from other sources in your user program. 

● In addition, you can view the statistics which show many resources (DBs, FCs) are 
available in your CPU for compiling the charts and how many are already in use. 

 

 
 

Note 
If you only work with CFC and SFC in your program, you can leave the standard 
compilation settings unchanged. 
You will find an overview of the blocks generated during compilation in the online help. 
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Consistency Check 
Prior to the actual compilation, the system automatically makes the following consistency 
checks: 
● Checks whether the block types in the user program match the types imported into CFC. 
● Checks whether symbolic references to shared addresses are entered in the symbol 

table. 
● Checks whether the data blocks (DB) to which there are interconnections actually exist in 

the user program. 
● Checks whether in/out parameters or block outputs of the type "ANY", "STRING", 

"DATE_AND_TIME" or "POINTER" are supplied with values (interconnected). 
● Checks whether all the blocks accessed by SFC conditions or statements still exist. 

 

 
 

Note 
You can also check the consistency without compiling. To do this, select the menu 
command SFC > Check Consistency. 

 

Procedure  
1. Select the menu command SFC > Compile....  

The "Compile program" dialog box appears. 
2. Activate one of the following options in the "Scope" group to specify the scope of the 

compilation: 
– Entire program: all the charts are compiled. 
– Changes: only the objects changed since the last compilation are compiled. 

3. Activate the "Generate SCL source" check box if required. 
4. Click "OK".  

The compilation process will begin. 
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Result 
The charts of the current program (chart folder) are checked for consistency and then 
compiled. 

Saving Settings without Compiling 
You can save the settings with the "Apply" button in the "Compile Program" dialog box 
without starting the compiling process. 

Display Logs 
The result of the consistency check and all messages occurring during compilation are 
displayed automatically following compilation.  
You can also display the log later and print it out with the menu command Options > Logs.... 

Additional information 
● Online help on SFC 
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8.11.8.16 How to Compare SFC Charts before Download 

Introduction 
During configuration, testing and commissioning, there is often the need to compare a 
new/changed SFC chart with the previously loaded version before downloading it. 

Requirement 
Before the initial download in the SFC editor with the menu command Options > Settings > 
Compile/Download, activate the check box "Generate image of downloaded program for 
comparison" in the "Settings for Compiling/Laden" dialog box. 

Procedure 
1. Select the menu command PLC > Download... in the SFC Editor. 
2. Click "Show Changes". 

The Version Cross Manager opens and the image created by the previous download (see 
Requirements) is compared with the version to be downloaded and correspondingly 
displayed. 

 

 
 

Note 
The "Show Changes" button is only enabled when the "Version Cross Manager" add-on 
package is installed and an image has been generated for the loaded program. 

 

3. Go back to the "Download" dialog box. 
4. Click "OK" or "Cancel". 

Additional information 
● Online help on SFC 
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8.11.8.17 How to Download SFC Charts to the CPU 

Download 
Before the graphic charts can be put into operation on a CPU, the charts must first be 
compiled and downloaded to the CPU. The charts are downloaded to the CPU to which the 
user program containing the current chart folder is assigned. 

Requirements  
● There must be a connection between the CPU and your programming device/PC. 
● The edit mode is set (not the test mode). 
● If you download the entire program, the CPU is in STOP mode. 

If you only download changes, the CPU may be in RUN-P mode. 

Procedure 
1. Select the menu command PLC > Download... in the SFC Editor.  

The "Download Archive System" dialog box opens. 
2. Activate one of the following options in the "Download mode" group to specify the scope 

of the compilation: 
– Entire program 

The entire content of the "Blocks" folder is downloaded. 
– Changes 

Only the blocks changed since the last compilation are compiled (the CPU can be in 
the "RUN-P" state). 

– Download to test CPU 
With this type of download, you can download a modified program to another CPU or 
to an S7 PLCSIM, without losing the delta download capability in the original CPU. 

3. Click "OK".  
The compilation process will begin. 

 

 
 

Note 
With the programs created in SFC, you must download to the CPU from SFC (or CFC), 
since only this download function guarantees the consistency of the configuration data 
with the CPU data. 
The same download function is available in the SIMATIC Manager with the following 
menu commands:  
• Menu command PLC > Compile and Download Objects... and then activate the 

"Charts" object for compiling and downloading 
• In the component view: mark the "Charts" folder and select the menu command PLC > 

Download 
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Result 
The program (or only the changes) is downloaded to the CPU. 

 

 Note 
If you have made download-relevant changes in the configuration and have not compiled 
since you made the changes, you will be prompted to compile before you download. The 
download is automatically carried out after error free compiling. 

 

Downloading the Entire Program 
If you select "Download: entire program", all the charts from the current chart folder are 
downloaded to the CPU in this download mode. After a prompt for confirmation the CPU is 
set to STOP and all of the blocks are deleted in the CPU. 

 

 Note 
Compiling the entire program does not necessarily mean a complete download. If the 
program was already loaded in the CPU prior to compiling, then it is possible to download 
only changes.  
If a full download is aborted, changes cannot be downloaded until the full download is 
completed. Reason: the blocks on the CPU were deleted prior to the download. 

 

Downloading changes 
If you select "Download: changes only" in the "RUN-P" CPU mode, you can download 
changes to your configuration to the PLC without having to change the CPU to the STOP 
mode. With this type of download, you only download changes that have been made since 
the last download. Please comply with the following: 
● If the chart topology has been changed in the SFC charts (steps or transitions added, 

deleted, copied, moved, jump destination changed, ...), these charts must be deactivated 
when changes are downloaded. 

● Modifications to the interface of the SFC type are transferred to the SFC instances 
immediately. The SFC instances must therefore be deactivated during downloads and 
execution stopped on the CPU. 

● If SFC charts have been modified (chart properties, object properties are the 
steps/transitions) without changing their structure, you can download the charts after they 
have been compiled while the CPU is in RUN without needing to deactivate the modified 
SFC chart. 
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● If you have not changed the chart itself, but only the objects that are accessed (for 
example, a symbol in the symbol table, runtime groups, block I/O), you do not need to 
deactivate the chart before it is downloaded. 

● After you download changes, a stopped SFC chart with the property "Autostart: on" is not 
started automatically, it must be restarted by the operator. 

 

 
 

Note 
Please take note that there is no absolute guarantee that the CPU will not switch into the 
STOP mode when changes are downloaded. 
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8.11.8.18 How to Test SFC Charts 

Test mode 
The SFC Editor provides test functions that support the commissioning process. These are 
used to monitor and influence the AS sequential control system process and to change 
setpoints if necessary. For this purpose switch the SFC Editor into a test mode. 

Test Mode Operating Modes 
The Test mode relates to the CPU belonging to the active chart. As an alternative you can 
test in two operating modes: 
 
Operating mode Description 
Process mode In process mode, the communication for online dynamic display of the SFC 

chart and SFC instances is restricted and causes only slight extra load on the 
CP and bus. 
In process mode, if an overload occurs, a message is displayed indicating that 
the limit for bus load has been reached. In this case, you should stop the test 
mode for the SFC charts that are not absolutely necessary for the test. 
When Test mode is activated, all blocks have the status "watch off". 

Laboratory mode Laboratory mode is used for convenient and efficient testing and 
commissioning. In the laboratory mode, in contrast to the process mode, 
communication for online dynamic display of SFCs is unrestricted. 
When Test mode is activated, all blocks have the status "watch on". 

Requirements 
● There must be a connection between the CPU and your programming device/PC. 
● The program has been downloaded. 

Activating/Deactivating Test Mode 
1. Select desired operating mode with the menu commands in the Test menu as required: 

– Test > Process Mode 
– Test > Laboratory Mode 
Make sure that it is not possible to switch the type of test used while in the test mode.  

2. Select the SFC menu command Debug> Test Mode.  
Test mode is activated. 

3. Reselect the menu command Debug > Test Mode in CFC to stop the test mode. 
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Test 
Once you have started the test mode, you can test the functionality of your SFC.  
The SFC can be started in "manual" mode. You can also influence the operating parameters 
used for executing the SFC (for example, cyclic operation).  
If the SFC is in the "RUN" operating mode, the following appears:  
● Which step is currently active 
● Which actions are executed in this step 
● The transitions that are active and the conditions that must be satisfied for this transition 

 

 
 

Note 
Any operator input that you made or parameters you assigned in test mode are then 
performed simultaneously in the CPU and in the data of the SFC.  
If you switch an S7 CPU off and on again without battery backup, these parameter 
changes are lost in the CPU. In such cases, to restore the parameter settings you must 
recompile the chart folder and download it to the CPU again from your PC/programming 
device. 

 

Additional information 
● Online help on SFC 
● Manual Process Control System PCS 7, Getting Started - Part 1 
● Manual SFC for S7; Sequential Function Chart 
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8.11.9 Creating Models (Multiproject) 

8.11.9.1 How to Create a Model 

Introduction 
Generally a plant is structured by dividing it into smaller functional units that can be 
classified, for example, as fixed setpoint controls or motor controllers. 
Instead of planning these functional units each time it is possible to create a supply of 
prefabricated functional units known as models in the engineering system. Then you only 
have to copy and modify them according to the requirements of the new solution. 
To ensure that there is only one version of a model throughout a project, all models should 
be stored centrally in the master data library and all adaptations should be made prior to 
generating the replicas. 

Model 
 

 Note 
You can only create or modify models in a multiproject. 

 

A model consists of hierarchy folders that contain the following elements: 
● CFC/SFC charts 
● OS pictures 
● OS reports 
● Additional documents 
A model also contains a link to an import/export file (IEA file).  
Using the Import/Export Assistant (IEA), you link block/chart I/Os and messages of blocks to 
the columns of an import file.  

Replicas 
The model can be imported with the Import/Export Assistant after it is prepared in this way 
and linked it to an import file. The generated replicas are assigned the parameters, 
interconnections, and messages of the model. Each line in an import file creates a replica in 
the destination project. 

Requirement 
The functional unit from which you want to create a model has been tested on the 
automation system and on the operator station. 
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Creating a Model 
1. Select the hierarchy folder containing the CFC chart (or CFC charts, SFC charts, etc.) 

required for the model in the master data library (or a hierarchy folder containing a nested 
hierarchy folder with a CFC chart). 

2. Start the wizard with the menu command Options > Models > Create/Modify Model... and 
select the following in the next steps: 
– Which I/Os do you want to import as parameters or signals? 
– For which blocks do you want to import message texts? 
– Which import data do you want to assign to specific model data? 

In the "Which import data do you want to assign to specific models?" step, the text "No 
import file assigned" is initially entered in the "Import File" input field. By clicking "Other 
File..,", you can browse and enter an import file.  

Creating an Import File 
In case the import file does not yet exist or no suitable import file exists, you can create an 
import file with the "Create Template File..." button from the previously selected model data.  
For this purpose there are two methods of procedure: 
● You create the import file and at the same time edit the required column titles. 

– In the "Import file" list box, select the entry "No import file assigned".  
The editing mode is now active in the "Column Title" column of the "Model Data" list. 

– Edit the required column titles. 
– Continue as described for the second procedure. 

● You generate the import file with "artificial" column titles since you do not yet want to 
finalize the texts: 
– Click "Create file template..." and  

define the file name. 
– Select the optional column types in the next dialog box or  

deselect the columns that are not of interest (for example, LID, FID). 
In the structure of the file, the attributes of the I/O flags are evaluated and the entries for 
Text 0, Text 1, unit, value, and identifier are entered automatically if they exist; 
interconnections, chart name and hierarchy are entered automatically. Afterwards, only the 
hierarchy and the chart name must be adapted. 
If you select the second method, you can edit the assigned file with the IEA file editor by 
opening it with the "Open File" button. You can perform the following here: 
● Change the column titles 
● Remove individual columns that are not required 
● Add lines 
● Edit descriptions 
After saving the file, the Import-Export Assistant displays the new column titles that you must 
subsequently assign.  
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Finishing the model 
1. Once you have assigned the import data to the model data, click "Finish". 

Result 
You then have a model available with an assignment to a column of the import file for each 
selected I/O and each selected message; as a result every column of the import file has 
been used (1:1 assignment). 
When working with messages the following applies: not all lines of the model data must be 
supplied with data from the import file. The number of messages in the import file can, 
therefore, be less than the number of messages in the model (in this case the 1:1 
assignment does not apply). 
The hierarchy folder is displayed as a model in the SIMATIC Manager. 

Modifying a Model 
Models that do not have replicas can be modified at any time.  
1. Select the menu command Options > Models > Create/Modify Model.... 
If you modify models that already have replicas, a message is displayed since the import 
data no longer match the model data. 
If you modify the I/O points (IEA flags) of a model that already has replicas, a message is 
displayed and the dialog box is expanded by an additional step. All the modifications that 
have been made are logged in this additional dialog box. The following modifications are 
then made to all replicas: 
● If IEA flags are missing in the replicas, they are set. 
● If there are more IEA flags set in the replicas than in the model, these are removed from 

the replicas. 
 

 
 

Note 
The block names may no longer be modified in an existing model or in replicas of a 
model. Otherwise, import/export is no longer possible. 

 

With the IEA, you can assign parameters to block I/Os and chart I/Os and interconnect them; 
you can also rename chart I/Os. 

 

 Note 
Please remember that it may be necessary to adapt the IEA file as well. 

 

Additional information 
● Section "How to Work with Models in the SIMATIC Manager (Page 577)" 
● Online help for PH, IEA and PO 
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8.11.9.2 Textual Interconnections and Models 

Introduction   
Using a textual interconnection, you interconnect the inputs and outputs of blocks or nested 
charts for the import. This can be done both within a chart and across charts. 

Requirements 
● The interconnection partners are in the same chart folder. 

Syntax 
The interconnection has the following syntax: 
cfc\block.io  
or  
cfc\chart.io 
or  
sfc.I/O 
If folders of the PH are included in the name, the path of the plant hierarchy can also 
precede the name (ph\ph\cfc\chart.block] but this is ignored. 

Textual interconnections 
Textual interconnections are possible only for I/Os defined as parameters. 
Textual interconnections can start both at outputs and imports if these are defined as 
parameters. Multiple interconnections are possible only at the outputs of the CFC charts. 
Only single interconnections are possible at the inputs.  
When creating the IEA file, the textual interconnection check box must be activated on the 
"Parameters" tab of the "Create File Template" dialog box. 
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Multiple Interconnections 
Multiple interconnections are interconnections that lead from one output to several inputs. 
● Multiple interconnections can be entered in the import file for parameter and signal 

outputs. The I/O names are separated in the column by quotation marks (“). 
● If you want to retain an existing single interconnection and add a new interconnection, 

enter the separator character " (quotation mark) after the text for the interconnection. 
Without this separator character, the old interconnection would be replaced by the new 
one. 

● If a multiple interconnection already exists, the interconnection is always created during 
import in addition to the existing and connections. This happens regardless of whether or 
not there is a separator character. 

● The keyword "---" deletes all interconnections at the output. 
During export, the existing multiple interconnections are also indicated by the " separator 
character. 

Rules 
The following rules apply when working with textual interconnections in models: 
● When you create a model/process tag, the "Create Template File" function enters the 

interconnection partner according to the interconnection in the model for the textual 
interconnection in the "TextRef" column. This would lead to an interconnection in the 
model and thereby change the model during the import process. 
This column must, therefore, be corrected. To prevent accidental changes to the model, 
the interconnection partner is prefixed by a question mark ("?") in the "TextRef" column, 
which would lead to an error during import. 

● As part of the correction process, you can search for "?" with the IEA file editor and 
modify these cells accordingly.  
Textual interconnections should, whenever possible, only originate at inputs. For this 
reason, no "TextRef" columns are created for outputs when the file template is generated 
even if the "Textual Interconnection" option has been activated in the selection dialog. If 
required, you must create these extra with the "Expand Column Group" function of the 
IEA editor. 

● Textual interconnections are set up at parameter I/O points, interconnections to shared 
addresses at signal I/O points. 
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8.11.9.3 How to Generate Replicas from Models 

Introduction 
Using the Assistant for models, you import the data of the model.  
The model is copied from the master data library to the specified target projects as a replica. 
Thereafter the data is imported. According to the entry in the import file, you can create any 
number of replicas.  
When you import, you can decide whether or not the imported signals will be entered in the 
symbol table (option: "Also enter signals in the symbol table"). With PCS 7, we recommend 
that you do not use the option because these entries are made when you configure the 
hardware with HW Config. 

Requirement 
The corresponding import file is available. 

Note to Reader 
You can find a detailed description of the settings of the import files in the section 
“Importing/Exporting Process Tags/Models“. The following is a description of the basic 
procedure used when import files have already been assigned. 

Procedure 
1. Select the required model in the master data library. 
2. Select the menu command Options > Models > Import... 

The wizard searches for the process tag types and corresponding import files (in all 
hierarchy subfolders as well) and lists them. The import is executed for all the import files 
listed. 

3. If you do not want to import certain files, you can select them and remove them from the 
list with the "Remove" button.  
By clicking "Other File", you can search for a different import file and select it instead of 
the other file. 

4. Click "Continue" and then "Finish".  
The actual import process starts. 
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Result 
Depending on the setting of the "Only show errors and warnings in log" check box, either the 
complete list of import activities or only the errors that occurred are displayed in the log 
window. 
The log is saved in a log file. The name and path of the file are displayed below the log 
window. You can modify this setting with the "Other File" button. 

Additional information 
● Section "How to Import Process Tag Types and Models (Page 639)" 
● Online help for PH, IEA and PO 
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8.11.9.4 How to Work with Models in the SIMATIC Manager 

Copying Models            
 

 Note 
In a multiproject, a model must not exist more than once and must be located in the master 
data library. 

 

The following applies when copying models in the SIMATIC Manager: 
● If you copy a model within the same multiproject or from the multiproject into a different 

multiproject, a replica of this copy is created with identical content. 
● If you copy a model from the master data library into a project, a replica is created. 
● If you copy a model from the master data library into a different master data library 

(different multiproject), it remains a model. 
● If you copy a model from the master data library into a different library, it remains a 

model. 
This way you can create a backup of the model. During import, the backup is ignored. 

Copying Replicas of the Model 
If you copy a replica of a model in the SIMATIC Manager within the same multiproject, this 
new hierarchy folder is also assigned to the original model. Similar to all other replicas 
generated with the IEA, this copy is not assigned to the import file. It reacts in the same 
manner as a replica generated per import with the IEA. 
If you copy a replica to a different multiproject, it has no assignment there until there is no 
copy of the corresponding model in the master data library. The replica receives its 
assignment again if it is copied back into the original project (for example, when branching 
and merging project data). 

Removing Models 
If you no longer want a model to be available for import/export, or if you want the model to 
become a normal hierarchy folder again, then proceed in the following manner: 
1. Select the hierarchy folder 
2. Select the menu command Edit > Object Properties.... 
3. Open the "Models" tab. 
4. Click "Cancel". 
The assignment to the import file is deleted. This also means that all existing replicas of the 
model are changed to normal hierarchy folders. 
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Removing Replicas 
Model replicas can be removed in the same manner as models. Proceed in the following 
manner to change replicas back into "normal" hierarchy folders. 
1. Select one of the replicas 
2. Select the menu command Edit > Object Properties.... 
3. Open the "Models" tab. 
4. Select the replica and click "Cancel". 

Deleting Models with Replicas 
If you delete a model of which a replica already exists, all the replicas are retained 
unchanged but they lose their assignment to the model. 
If you then replace the deleted model with a model of the same type (for example, by 
branching and merging projects), the assignment of the replicas is established again. 
If you do not want to retain them as replicas, but want to convert them back into normal 
hierarchy folders, then proceed in the manner described above (Section "Removing 
replicas"). 
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8.11.9.5 How to Assign Replicas to a Model Later 

Applications 
By using the IEA, you can convert replicas or neutral hierarchy folders with CFC charts that 
do not belong to a model into replicas of an existing model if the structure of the replica 
corresponds completely with the structure of the model.  
The following applications are conceivable: 
● You imported into a project and then adapted the replicas locally. A handling error (for 

example, in distributed engineering the model was forgotten after branching and merging) 
replicas exist but the corresponding model is missing. 

● You want to continue working with the IEA in a project after several charts have already 
been created and adapted locally. You want to assign the hierarchy folders with these 
charts to a model as replica. 

The procedure for the situations outlined above is described below. 

Procedure 
If replicas no longer have a corresponding model, then a suitable model can be created for 
them in the following manner: 
1. Select the replica. 
2. Select the menu command Options > Models > Create/Modify Model.... 
3. Select the previous import file in subsequent dialog steps and assign this import data to 

the model data. 
You can find further information about this in the section "How to Create a Model 
(Page 570)". 

4. Start the export using the Options > Models > Export... menu command.  
You will receive an IEA file that includes the current data of all existing replicas. 
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8.11.10 Editing Mass Data in the Process Object View 

8.11.10.1 Introduction into Editing Mass Data in the Process Object View 

Introduction      
In the process object view (Page 243), all project-wide data of the basic automation can be 
displayed and edited in a view based on process control. Project-wide means that the data 
from all the projects is contained in a multiproject. 

Working with the Process Object View 
You can create, copy, move, and delete objects in the tree view. The properties of the 
hierarchy folders for batch and continuous plants can also be edited here.  
All essential aspects of the objects can be documented and edited directly in the table 
(content window), without the need to access the configuration tools for editing the objects. 
Not all the attributes can be edited directly. This information is then grayed. There are 
however shortcuts to the necessary configuration tools. 

Shortcuts in the Process Object View 
You can edit aspects of an object (process tag, CFC, SFC, picture) in the supporting 
configuration tool if they cannot be edited in the process object view.  
There are shortcuts to the selected object in the process object view that you can call with 
the menu command Edit > Open Object. This applies regardless of the selected tab. 
The following table provides an example of this for the "General" tab: 
 
Object Establishes ... Opens ... 
Picture The connection between a process tag, 

a CFC or an SFC and their picture 
interconnections. 

The WinCC Graphics Designer with the 
picture defined by the currently selected 
cell/row. 

Archive The connection between a process tag, 
a CFC or an SFC and their archive 
tags. 

WinCC Tag Logging with the archive 
defined by the currently selected cell/row. 

Chart The connection to the CFC/SFC chart. The CFC/SFC Editor with the relevant 
chart defined by the currently selected 
cell/row. 

Module The connection between a process tag 
or a CFC and the corresponding 
modules. 

HW Config with the object properties of the 
module. 

Message The connection to the block message. The dialog box for configuring messages 
with block messages defined by the 
currently selected cell/row. 

Symbol Table The connection to the symbol table. The symbol table of the S7 program 
defined by the currently selected cell/row. 
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Overview 
Editing mass data in the process object view involves the following topics: 
● Displaying general data (Page 585) 
● Editing Blocks (Page 587) 
● Editing Parameters (Page 589) 
● Editing Signals (Page 593) 
● Editing Messages (Page 597) 
● Editing Picture Objects (Page 599) 
● Editing Archive Tags (Page 601) 
● Editing Hierarchy Folders (Page 603) 
● Editing Equipment Properties (Page 605) 
● Editing the Shared Declarations (Page 606) 
● Testing in the Process Object View (Page 607) 
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8.11.10.2 Working in the process object view 

Filtering 
In the process object view, you can limit the number of objects selected for display by using 
a filter. The default setting is: <no filter>. 
In the "Filter by column:" list box, select the column in which you wish to use the filter text 
("Display:" input field) to define the objects that are to be displayed in the table.  
Examples:  
● You want to display all the CFC charts in the table.  

In "Filter by column:", select the type and, in the "Display:" input field, enter "cf". 
All object types that begin with the letters "cf" are displayed (e.g. all CFC charts). 

● You want to display all the objects from a certain range in the table:  
In "Filter by column:", select the path and, in the "Display:" input field, enter "*Boiler". 
All the objects whose paths contain the "Boiler" character string are displayed. 

Special filter entries apply to the "Simulate outputs" column. 
 

 Note 
The filter settings that you make on the "General" tab apply to all other tabs. The filter 
settings on these tabs specify the selection you make. 

 

Sorting 
You can sort the data displayed in the process object view in ascending and descending 
alphanumeric order. To do this, click the heading of the column whose data is to be sorted. A 
small arrow will indicate whether the data has been sorted in ascending or descending order. 

Setting the column width 
You can set the width of the columns directly in the table (in the same way as with Excel). If 
you close the process object view or SIMATIC Manager and reopen it, the settings will 
remain.  

Dividing a table 
You can divide the window into two halves (left and right), so that each has an individual 
scroll bar. This is a function which you may recognize from Excel, for instance. 

Displaying/Hiding columns 
You can use the menu command Options > Settings... to hide columns, show columns that 
were previously hidden, and change the order of the columns on the "Columns" tab. 
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Defining your own columns 
You can also use the menu command View > Define Columns... to add or remove your own 
columns. You can enter project-specific data in these columns - for example, specific 
information about maintenance intervals. This information is saved at the relevant process 
object and is copied along with the object. 

 

 Note 
Within a project, on the "Blocks" tab you can assign the OS-relevant attribute to a newly 
defined column, or remove an attribute that has already been assigned, using the 
corresponding shortcut menu command.  

 

Importing and exporting 
You can also use import and export functions to exchange this data with other tools.  
You will find more information on this topic in the section "Adopting the Data from the Plant 
Engineering (Page 627)". 

Restrictions on copying, moving, and deleting  
It is possible to copy, move, and delete objects in the process object view in exactly the 
same way as in the plant view. However, the following restrictions apply: 
● Copying and moving from the content window (right-hand window) into the tree view (left-

hand window), or into another view, is only possible on the "General" tab. 
● Copying and moving from the tree view or from another view into the content window is 

not possible. 
● Deleting objects is only possible in the tree view, or on the "General" tab of the content 

window. 

Carrying out procedures for individual blocks 
You can select and copy information in the table for individual blocks, and insert it at a 
different location. These functions are not only available within the table itself, but also 
between the table and, for example, Office applications such as Excel and Access.  
In this way, you can copy data from specified lists to PCS 7 quickly and easily. If an error 
occurs during this process, you can correct it using the "Undo" function (via the shortcut 
menu in the table). 
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Finding and replacing 
You can find and replace text on the tabs of the process object view (via the shortcut menu 
in the table). 
The Find operation starts from the cell that has been selected, or in which the cursor is 
positioned. Depending on the search range selected, the table is searched as follows: 
● The entire table 
● Row by row, from left to right 
● Column by column, from top to bottom 
The Find operation is performed cyclically: once the end of the row or column is reached, it 
starts again from the beginning until it reaches the initial cell.  
The search stops when the first text is found. If you click "Find", the search continues without 
the text being replaced. If you click "Replace", only the text in this cell is replaced. If you click 
"Replace all", the search continues and all the text found is replaced.  

 

 Note 
Please note the following: 
• You do not have to enter the complete text you are searching for; entering only a part of it 

is sufficient if this guarantees that the text being sought can be identified uniquely. 
• If you click "Replace"/"Replace all" without having entered text in the "Replace by:" entry 

field, the text found will be deleted. 
 

Additional information 
● Online help for PH, IEA and PO 
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8.11.10.3 How to Edit the General Data 

"General" tab 
In this tab, all the underlying ES objects (objects of the PH) for the part of the plant selected 
in the hierarchy window are displayed along with their general information. If the selection is 
changed, the relevant objects are read in again. 

Columns in the Table 
If you have selected the icon for a multiproject in the hierarchy window, only the columns 
relevant to the objects of the multiproject are displayed.  

 

 Note 
If the block is a component of a fail-safe program, at the beginning of the line the field with 
the line number has a yellow background. 

 

 

 
Column Meaning 
Hierarchy Displays the technological path of the object (or the storage location of the 

projects/libraries). 
Name of Displays the icon of the object and the object name. You can change the 

object name. 
Comment Input field for the comment on the object. You can change the comment. 
Type Displays the object type, for example process tag, CFC, SFC, OS picture, 

report, or additional document. 
Process tag type Displays the name of the process tag type from which the process tag was 

derived. 
FID Input field for the function identifier. If you modify the text here, it will be 

entered in the CFC/SFC in the "Part 3" tab labeling field "Designation:" . 
LID Input field for the location identifier. If you modify the text here, it will be 

entered in the CFC/SFC in the "Part 3" tab labeling field "Designation block 
according to place:". . 

Status This column is visible only in the online view. A status message is displayed 
here if the check box is activated in the "Watch" column. The status display 
displays texts and colors the same as in CFC.  

Monitoring This column is visible only in the online view. Here, you can enter or remove 
the process tag or the chart for the test mode. If the watch function is switched 
on, the columns "Activated," "Simulate inputs," and "Simulate outputs" are 
displayed dynamically. They are then displayed with a yellow background. 

Sampling time Shows the current execution cycle for the charts for which a runtime group 
with the same name has been created. You can change the execution cycle.  
The drop-down list shows the cycles determined from the specified OB cycle 
and any reduction ratios for the runtime group. 

Selected With this option, you can activate or deactivate charts in the run sequence. 
The check box can be set offline and online. 
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Column Meaning 
Simulate inputs With this option, the input signals of the sensor are changed to the simulation 

values of the driver blocks (CH_AI, CH_DI, CH_U_AI, CH_U_DI, CH_CNT, 
PA_AI, PA_DI, PA_TOT).  
The check box can be set offline and online. Exception: If all SIM_ON I/Os are 
interconnected, the check box is disabled. If only some of the SIM_ON I/Os 
are interconnected, the check box is enabled, the setting however, applies 
only to the SIM_ON I/Os that are not interconnected. 

Simulate outputs With this option, the output of signals to the actuators in the automation 
system is changed from the calculated value to the simulation value of the 
driver blocks (CH_AO, CH_DO, CH_U_AO, CH_U_DO, PA_AO, PA_DO).  
The check box can be set offline and online. Exception: If all SIM_ON I/Os are 
interconnected, the check box is disabled. If only some of the SIM_ON I/Os 
are interconnected, the check box is enabled, the setting however, applies 
only to the SIM_ON I/Os that are not interconnected. 

AS Displays the component path to the S7 program containing the process tag or 
the CFC/SFC chart. 
By clicking in the box, you can display a drop down list. If the project contains 
several S7 programs, these are displayed in the drop-down list. By selecting a 
different S7 program, you move the associated chart.  

OS Displays the component path for the OS containing the OS picture or the OS 
report. 
By clicking in the box, you can display a drop down list. If the project contains 
several operator stations, these are displayed in the drop down list. By 
selecting a different OS, you move the associated object.  

Block icons In this column you can see the pictures for which block icons will be 
automatically generated (in the PH or when the OS is compiled). You can set 
or reset the attribute "Derive block icons from the plant hierarchy" for each of 
the collected pictures without needing to open the object properties of each 
picture. 

Can be controlled 
and monitored 

You use this column to determine if the SFC chart from the AS-OS 
engineering should be transferred to the OS for visualization.  

Author Input field for the name of the author. If SIMATIC Logon Service was activated 
when a shared declaration was created, the user logged on at the time is 
entered here. 
You can change the names for charts and additional documents. 

Version Displays the version number of the CFC and SFC charts that you can change 
here.  

Size Shows the size of the object in bytes as far as is practically possible. 
Last modified Displays the date of the last modification to the object. 

Additional information 
● Online help for PH, IEA and PO 
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8.11.10.4 How to Edit Blocks 

"Blocks" Tab      
In this tab, the block properties of all blocks in the CFC charts are displayed for the object 
currently selected in the hierarchy window. SFC instances are also identified as blocks here. 

Columns in the Table  
 

 Note 
If the block is a component of a fail-safe program, at the beginning of the line the field with 
the line number has a yellow background. 

 

 

 
Column Meaning 
Hierarchy Shows the technological path of the process tag or CFC (cannot be changed).
Chart Shows the name of the process tag or CFC (cannot be changed). 
Plan comments Shows the comment on the chart (cannot be changed). 
Block Shows the block name. You can change the name.  

You can enter a maximum of 16 characters for block names. 
Block comment Shows the comment on the block. You can change the comment.  
Create block icon You can use this check box to specify if a block icon should be generated for 

this block.  
Activate the "Operator C and M possible" check box to enable this option. You 
can then edit the cell in the "Block icon" column. 

Block icon This shows the name of the icon with which the block is displayed in the OS 
picture.  
The cell can only be edited if the check box in the "Create block icon" column 
is activated.  
You enter a name for this block instance here if there is more than one variant 
of block icons for this block type. If no name is entered, the default block icon 
is used. 

OCM possible This check box determines if the block can be operated and monitored 
(system attribute "S7_m_c"). 

MES-relevant Check box which determines whether the information of this I/O can be 
transferred to the management levels MIS/MES in response to a request. 
The option can only be set when the "Operator C and M possible" check box 
is activated. 
Note: In the default setting, the column is hidden since this information is not 
normally used in PCS 7. To display the column in the process object view, use 
the menu command Options > Settings..., and select the "Columns" tab. 

Readback enabled Indicates whether or not the I/O is marked as being capable of being read 
back (I/O with system attribute "S7_read_back"). You cannot modify the 
option. 
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Column Meaning 
Block group Indicates blocks that belong to a specific message group, intended automatic 

alarm suppression based on the operating state. You can change the name of 
the group or enter it if the block has not yet been assigned to a group. You 
can enter exiting group names from a drop-down list. The name can have a 
maximum of 24 characters. 

With interrupt Indicates blocks that have message response (cannot be changed). 
Instance DB Shows the object names of the corresponding instance data blocks (for 

example, DB86) (cannot be changed). 
Family Shows the name of the block family to which the block belongs (for example, 

CONTROL) (cannot be changed). 
Author Shows the name of the author or the membership in a specific library for 

PCS 7 blocks (for example, DRIVER70) (cannot be changed). 
Block type Shows the name of the block type from which the block originates (cannot be 

changed). 
Internal ID Shows the name of the internal ID (for example, FC 262) (cannot be 

changed).  
Process tag type Shows the name of the process tag type from which the process tag (chart) 

containing this block was created (cannot be changed). 

Additional information 
● Online help for PH, IEA, and PO 
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8.11.10.5 How to Edit Parameters 

"Parameters" Tab      
This tab displays the I/O points for all the process tags and CFC charts displayed in the 
"General" tab that were specifically selected for parameter assignment or interconnections 
between the process tags or CFC charts.  
I/Os for the "Parameters" tab can be selected at the following locations: 
● In the SIMATIC Manager using the menu command Options > Process objects > Select 

I/Os... (display of objects selected in the tree view) 
● In the CFC in the "Properties – I/O" dialog (of a block) 
● On block type: system attribute S7_edit = para 

Editing 
The following parameter values can be entered for those I/Os visible in the "Parameter" tab. 
● The value 
● The unit 
● The identifier 
● Operator text for binary states and commentary. 
As an alternative to the value, you can also insert block interconnections.  
You can open the corresponding CFC chart in the shortcut menu. The relevant I/O of the 
block is selected. 
You can limit the number of objects selected for display by using a filter. You will find 
additional information on this topic in Section "Working in the process object view 
(Page 582)". 
Each cell displayed in the table with a white background can be edited directly in the process 
object view. 
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Columns in the Table 
 

 Note 
If the connection is a structured connection from a fail-safe program, the field with the line 
number is displayed yellow at the beginning. 

 

 

 
Column Meaning 
Hierarchy Shows the technological path of the process tag or CFC (cannot be changed).
Chart Shows the name of the process tag or CFC (cannot be changed). 
Chart comment Shows the comment that has been entered in the chart properties (cannot be 

changed). 
Block Shows the block name (cannot be changed). 
Block comment Shows the comment on the block. You can change the comment. 
I/O Shows the name of the block I/O (cannot be changed). 
I/O comment Input field for the comment on the block I/O. You can change the comment. 
Process tag 
connector 

Shows the name of the flagged I/O as specified for the process tag type 
(cannot be changed). 

Category Shows the category of the flagged I/O as specified for the process tag type 
(cannot be changed). 

Status This column is visible only in the online view. The status message is displayed 
here if the check box is activated in the "Watch" column. In terms of color and 
text, the column is analogous to CFC. 

Monitoring  This column is visible only in the online view. Here, you can register or 
unregister the I/O for test mode. If "Watch" is switched on, the columns 
"Status" and "Value" are displayed dynamically. They are then displayed with 
a yellow background. 

Value Input field for the value of the I/O according to the data type and permitted 
range of values. You cannot edit the value if it involves an interconnected I/O 
type IN or IN_OUT. 
If the I/O is a STRUCT data type, the value of the first structure element is 
displayed with an elementary data type. You can only change the value if the 
structure can be configured. 
If this is the value of an enumeration, you can select the text for the 
enumeration value from a drop-down list if there is text in the enumeration of 
the shared declaration. The enumerations and their values are declared and 
managed on the ES. 
The column is displayed dynamically (on a yellow background) if "Watch" is 
switched on during test mode. If I/Os are interconnected, the value monitored 
which cannot be edited is displayed on a (grayish yellow background). A red 
background indicates a problem in transmission (value failed). 

Unit Input field for the unit of the value. In addition to entering texts, common units 
(kg, m, s, min, etc.) can also be selected from the drop-down list (I/O with 
system attribute "S7_unit"). 
Note: The list of units is generated from the basic CFC set. This basic set can 
be managed and changed in the ES. 
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Column Meaning 
Interconnection Input field for interconnecting the I/O. 

In addition to entering text, you can also open the interconnection dialog box 
with the shortcut menu command Insert interconnection.... Interconnections 
written as text are displayed with a yellow background. 
Note:  
When you select the shortcut menu command Go to Interconnection Partner, 
you switch to the line of the interconnection partner if the interconnection 
partner is identified in the process object view as a parameter.  

Add forcing Check box that indicates whether forcing has been added for the I/O.  
If this check box is activated, the two columns that follow - "Forcing active" 
and "Forcing value" - will be enabled for editing.  
If this option cannot be used, the I/O is not enabled for forcing. 

Forcing active  Check box that indicates whether forcing is active for this I/O.  
To use this option, "Add forcing" must be activated. 

Force value Input field for the forcing value.  
This value is dependent on the data type of the I/O. To enter a value, "Add 
forcing" must be activated. 

OCM possible Check box with which you can display whether the I/O can be controlled and 
monitored by the operator (I/O with system attribute "S7_m_c"; the attribute 
cannot be changed). 

Identifier Input field for the shortcut of the I/O (I/O with system attribute "S7_shortcut"). 
Text 0 Input field for a text describing the state "0". The text is only displayed and can 

only be edited when the I/O is of the data type "BOOL" and has the system 
attribute "S7_string_0". 
Exception: if the I/O also has the "S7_enum" system attribute, only the input 
field is active in the "Enumeration" column. 

Text 1 Input field for a text describing the state "1". The text is only displayed and can 
only be edited when the I/O is of the data type "BOOL" and has the system 
attribute "S7_string_1".  
Exception: if the I/O also has the "S7_enum" system attribute, only the input 
field is active in the "Enumeration" column. 

Watched Check box that decides whether the I/O is registered in test mode (I/O with 
system attribute "S7_dynamic"). You can modify the option. 

Archiving Indicates whether or not the block I/Os that can be controlled and monitored 
by the operator are intended for archiving (I/O with system attribute 
"S7_archive"). You can change this entry. By clicking in the box, you can 
display a drop down list. The following types of archiving can be selected: 
• No archiving 
• Archiving 
• Long-term archiving 

Readback enabled Indicates whether or not the I/O is marked as being capable of being read 
back (I/O with system attribute "S7_read_back"). You cannot modify the 
option. 
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Column Meaning 
MES-relevant Check box which determines whether the information of this I/O can be 

transferred to the management levels MIS/MES in response to a request. 
The option can only be set when the "Operator C and M possible" check box 
is activated. 
Note: In the default setting, the column is hidden since this information is not 
normally used in PCS 7. To display the column in the process object view, use 
the menu command Options > Settings..., and select the "Columns" tab. 

Enumeration For I/Os with the system attribute "S7_enum", the object name of the 
enumeration assigned to the I/O is listed here. You can change the name.  
If you click in the text box, a drop-down list opens from which you can select 
the desired name for the enumeration. The enumerations and their values are 
declared and managed on the ES. 

Data type Shows the data type of the I/O (cannot be changed). 
I/O Shows the I/O type (IN = input, OUT = output, IN_OUT = in/out parameter) 

and cannot be changed. 
Block type Shows the name of the block type from which the block originates (cannot be 

changed). 
Chart type Here, you can see whether the flagged I/O belongs to a CFC or SFC chart. 
Process tag type Shows the name of the process tag type from which the process tag (chart) 

containing this block was created (cannot be changed). 

Additional information 
● Online help for PH, IEA and PO 
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8.11.10.6 How to Edit Signals 

"Signals" Tab     
This tab displays the flag I/Os for all the process tags and CFC charts displayed in the 
"General" tab that were selected explicitly for signal interconnections.  
I/Os for the "Signals" tab can be selected at the following locations: 
● In the SIMATIC Manager with the menu command Options > Process Objects > Select 

I/Os.... 
● In CFC in the "Properties – I/O" dialog box 
● On block type: system attribute S7_edit = signal 

Processing 
You can enter symbol names for the interconnections with I/O devices as well as text 
attributes and commentary for the I/Os displayed in the "Signal" tab.  
As an alternative to entering interconnection symbols as text, signals can also be selected in 
a dialog box if they have already been specified by the hardware configuration.  
In the shortcut menu, you can open either the relevant CFC chart or the hardware 
configuration (HW Config) or the symbol table. 
You can limit the number of objects selected for display by using a filter. You will find 
additional information on this topic in Section "Working in the process object view 
(Page 582)". 
Each cell displayed in the table with a white background can be edited directly in the process 
object view. 
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Columns in the Table 
 

 Note 
If the connection is a structured connection from a fail-safe program, the field with the line 
number is displayed yellow at the beginning. 

 

 

 
Column Meaning 
Hierarchy Shows the technological path of the process tag or CFC (cannot be changed).
Chart Shows the name of the process tag or CFC (cannot be changed). 
Plan comments Shows the comment on the object (cannot be changed). 
Block Shows the block name (cannot be changed). 
Block comment Shows the comment on the block. You can change the comment. 
I/O Shows the name of the block I/O (cannot be changed). 
I/O comment Input field for the comment on the block I/O. You can change the comment. 
Process tag 
connector 

Shows the name of the flagged I/O as specified for the process tag type 
(cannot be changed). 

Category Shows the category of the flagged I/O as specified for the process tag type 
(cannot be changed). 

Status This column is visible only in the online view. A status message is displayed 
here if the option is set in the "Watch" column. In terms of color and text, the 
status display is analogous to CFC.  

Monitoring This column is visible only in the online view. Here, you can register or 
unregister the I/O for test mode. The columns "Status" and "Value" are 
displayed dynamically if "Watch" is switched on during test mode.  

Value Input field for the value of the I/O according to the data type and permitted 
range of values. You cannot edit the value if it involves an interconnected I/O 
type IN or IN_OUT. 
If this is the value of an enumeration, you can select the text for the 
enumeration value from a drop-down list if it is present. The enumerations and 
their values are declared and managed on the ES. 
The column is displayed dynamically (on a yellow background) if "Watch" is 
switched on during test mode. If I/Os are interconnected, the value monitored 
which cannot be edited is displayed on a (grayish yellow background). A red 
background indicates a problem in transmission (value failed). 

Unit *) Input field for the unit of the value. In addition to entering texts, common units 
(kg, m, s, min, etc.) can also be selected from the drop-down list (I/O with 
system attribute "S7_unit"). 
Note: The list of units is generated from the basic CFC set. This basic set can 
be managed and changed in the ES. 

Signal Input field for the name of the interconnected signal. You can also directly 
enter an absolute address. If a symbol exists for the absolute address you 
enter, it will be displayed. Otherwise, the absolute address will be displayed 
with '%' preceding it. In addition to entering text, you can also open the 
interconnection dialog box with the shortcut menu command Insert signal.... 

Signal comment Input field for the signal comment read from the symbol table (cannot be 
changed). 
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Column Meaning 
Add forcing Check box that indicates whether forcing has been added for the I/O.  

If this check box is activated, the two columns that follow - "Forcing active" 
and "Forcing value" - will be enabled for editing.  
If this option cannot be used, the I/O is not enabled for forcing. 

Forcing active  Check box that indicates whether forcing is active for this I/O.  
To use this option, "Add forcing" must be activated. 

Force value Input field for the forcing value.  
This value is dependent on the data type of the I/O. To enter a value, "Add 
forcing" must be activated. 

Absolute address Absolute address of the signal (for example, QW 12 or I3.1) read from the 
symbol table or originating from the "Signal" input field if the absolute address 
was entered there (cannot be modified). 

Hardware address Hardware address of the signal. Read from HW Config (cannot be changed). 
Measurement type Measuring type of the signal for input modules; output type of the signal for 

output modules. Read from HW Config (cannot be changed). 
Measuring range Measuring range of the signal for input modules; output range of the signal for 

output modules. Read from HW Config (cannot be changed). 
AS Displays the component path to the S7 program containing the process tag or 

the CFC chart (cannot be modified). 
OCM possible Check box with which you can display whether the I/O can be controlled and 

monitored by the operator (I/O with system attribute "S7_m_c"; the attribute 
cannot be changed). 

Identifier *) Input field for the shortcut of the I/O (I/O with system attribute "S7_shortcut"). 
Text 0 *) Input field for a text describing the state "0". The text is only displayed and can 

only be edited when the I/O is of the data type "BOOL" and has the system 
attribute "S7_string_0". 

Text 1 *) Input field for a text describing the state "1". The text is only displayed and can 
only be edited when the I/O is of the data type "BOOL" and has the system 
attribute "S7_string_1". 

Watched Check box that decides whether the I/O is registered in test mode (I/O with 
system attribute "S7_dynamic"). You can modify the option. 

Archiving Indicates which block I/Os that support OCM are intended for archiving. You 
can change this entry. Clicking in the edit box displays a drop-down list box. 
You can select the following types of archiving: 
• No archiving 
• Archiving 
• Long-term archiving 
Note: If you identify an I/O for archiving, it will only be displayed on the 
"Archive tags" tab once you have performed compilation on the OS. 

Readback enabled Indicates whether or not the I/O is marked as being capable of being read 
back (I/O with system attribute "S7_read_back"). You cannot modify the 
option. 

MES-relevant *) Check box which determines whether the information of this I/O can be 
transferred to the management levels MIS/MES in response to a request. 
The option can only be set when the "Operator C and M possible" check box 
is activated. 
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Column Meaning 
Enumeration *) For I/Os with the system attribute "S7_enum", the object name of the 

enumeration assigned to the I/O is listed here. You can change the name.  
If you click in the text box, a drop-down list opens from which you can select 
the desired name for the enumeration. The enumerations and their values are 
declared and managed on the ES. 
You can also enter a name in the input field for which no enumeration has yet 
been defined. 

Data type Shows the data type of the I/O (cannot be changed). 
I/O Shows the I/O type (IN = input, OUT = output, IN_OUT = in/out parameter) 

and cannot be changed. 
Block type Shows the name of the block type from which the block originates (cannot be 

changed). 
Chart type Here, you can see whether the flagged I/O belongs to a CFC or SFC chart. 
Process tag type Shows the name of the process tag type from which the process tag is derived 

(cannot be changed). 

*) Note: The column is hidden in the default setting, since this information is not normally 
used in PCS 7. To display the column in the process object view, select the menu command 
Options > Settings..., followed by the "Columns" tab, "Object types" group, and "Process 
object view" folder. Here, select the desired entry and activate the option you require in the 
"Visible columns" group. 

Additional information 
● Online help for PH, IEA and PO 
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8.11.10.7 How to Edit Messages 

"Messages" Tab 
This displays the message texts of the signaling blocks belonging to the process tags and 
CFC/SFC charts displayed in the "General" tab. 

Processing 
You can open the corresponding chart in the shortcut menu. 
You can limit the number of objects selected for display by using a filter. You will find 
additional information on this topic in Section "Working in the process object view 
(Page 582)". 
Each cell displayed in the table with a white background can be edited directly in the process 
object view. 

Columns in the Table 
 

 Note 
If the message about a block is from a fail-safe program, the field with the line number is 
displayed yellow at the beginning. 

 

 

 
Column Meaning 
Hierarchy Shows the technological path of the process tag or CFC (cannot be changed).
Chart Shows the name of the process tag or CFC (cannot be changed). 
Plan comments Shows the comment on the object (cannot be changed). 
Block Shows the block name (cannot be changed). 
Block comment Shows the comment on the block. You can change the comment. 
I/O Shows the name of the block I/O (cannot be changed). 
I/O comment Input field for the comment on the block I/O. You can change the comment. 
Sub number Sub number of the message (cannot be changed). 
Class Message class as specified for the block type. You can select from a drop-

down list.  
You cannot change the message class if it is locked in the block type 
message. 

Priority Message priority. You can select from a drop-down list.  
You will not be able to change the priority under the following conditions: 
• If it is locked in the block type message 
• If the message was configured according to the old message concept 

("message numbers assigned uniquely throughout the project") 

Trigger action Initiates the "GMsgFunction" standard function (can be changed using "Global 
Script" PCS 7 Editor) 
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Column Meaning 
Origin Origin of the block. In PCS 7 the keyword $$HID$$ is used.  

You cannot change the text if it is locked in the block type message. 
OS area OS area text according to which the message list can be filtered online. In 

PCS 7, the keyword $$AREA$$ is used. 
You cannot change the text if it is locked in the block type message. 

Event Input field for the event text (for example, "$$BlockComment$$ too high). 
You cannot change the text if it is locked in the block type message. 

Single 
acknowledgment 

Activate the check box, if the message should be acknowledged as a single 
message. 

Batch ID BATCH message text. 
You cannot change the text if it is locked in the block type message. 

Info text ( 
Operator control/ 
Free Text 1-5) 

You cannot change the text if it is locked in the block type message. 
Note: In addition to the "Info text" column, the tab also contains the "Free 
Text 1" to "Free Text 5" and "Operator control" columns. The columns are 
hidden in the default setting, since these texts are not normally used in PCS 7 
*).  

Status 1-10 (32) *) In the status columns you specify in which operating states (Status 1 to 
Status 32) the message is to be hidden in the process mode of the OS.  
In the default setting, Columns 11 to 32 are not displayed. 
The status columns can be modified under the following prerequisites: 
• The block belonging to the message is contained in a block group. 
• The CPU-wide message concept is set in the current project. 
The default column headings are replaced by concrete operating states, if the 
current selection only contains messages from block groups at whose SR 
blocks (Status Representation blocks) the same listing type is configured. The 
listing types contains the possible operating states in a list form. 

Block group Shows the name of the block group whose blocks belong to a specific 
message group and for which operating-state-specific automatic hiding of 
messages is specified (cannot be changed). 

Block type Shows the name of the block type from which the block originates (cannot be 
changed). 

Chart type Here, you can see whether the flagged I/O belongs to a CFC or SFC chart. 
Process tag type Shows the name of the process tag type from which the process tag is derived 

(cannot be changed). 

*) Note: The column is hidden in the default setting, since this information is not normally 
used in PCS 7. To display the column in the process object view, select the menu command 
Options > Settings..., followed by the "Columns" tab, "Object types" group, and "Process 
object view" folder. Here, select the desired entry and activate the required check box in the 
"Visible columns" group. 

Additional information 
● Online help for PH, IEA and PO 
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8.11.10.8 How to Edit Picture Objects 

"Picture Objects" Tab 
This displays all the blocks of the CFC charts that can potentially be controlled and 
monitored by the operator for the process tags and CFC charts displayed in the "General" 
tab, along with any existing picture interconnections and picture assignments. All the SFC 
charts and their picture interconnections and picture assignments are also displayed.  
For each block, you can see the location where it is used (for each OS, for each OS picture, 
and for each picture object to which it is interconnected). With block icons, you can select the 
appearance of the icon. If a row next to the block is empty, this means that the block is not 
operated or monitored by any project OS.  

Processing 
The displayed interconnections and assignments cannot be edited. The tab essentially has a 
cross-reference function, and is used to provide a fast overview of the existing or missing 
picture interconnections and assignments of one or more process tags.  
If you would like to modify the content of a picture, use the shortcut menu to also open the 
WinCC Graphics of the selected OS picture (the shortcut menu can also be used to open the 
CFC chart). 
You can limit the number of objects selected for display by using a filter. You will find 
additional information on this topic in Section "Working in the process object view 
(Page 582)". 
Each cell displayed in the table with a white background can be edited directly in the process 
object view. 



Implementing the PCS 7 Configuration  
8.11 Configuring AS Functions 

 Engineering System (V7.1) 
600 Configuration Manual, 03/2009, A5E02122455-01 

Columns in the Table 
 

 Note 
If the operable block is a fail-safe block or if the operable connection is a structured 
connection from a fail-safe program, the field with the line number is highlighted in yellow at 
the beginning of the corresponding line. 

 

 

 
Column Meaning 
Hierarchy Shows the technological path of the process tag or CFC (cannot be changed).
Chart Shows the name of the process tag or CFC (cannot be changed). 
Plan comments Shows the comment on the object (cannot be changed). 
Block Shows the block name (cannot be changed). 
Block comment Shows the comment on the block. You can change the comment. 
I/O Shows the name of the block I/O or SFC I/O (cannot be changed). This row is 

empty if a picture object is assigned to the block as a whole. 
I/O comment Input field for the comment on the I/O. You can change the comment. This 

row is empty if a picture object is assigned to the block as a whole. 
Process tag 
connector 

Shows the name of the flagged I/O as specified for the process tag type 
(cannot be changed). This row is empty if a picture object is assigned to the 
block as a whole. 

OS Displays the component path of the OS where the OS picture is located. In a 
multiproject, the project name is also displayed in the path of an OS from a 
different project (cannot be modified). 

Picture Name of the OS picture (cannot be modified). 
Picture object Name of the picture object, for example, faceplate, user object (cannot be 

modified). 
Property Name of the interconnected or assigned property of the picture object (cannot 

be modified). 
Block type Shows the name of the block type from which the block originates (cannot be 

changed). 
Chart type Here, you can see whether the OS picture is assigned to a CFC or SFC chart. 
Process tag type Shows the name of the process tag type from which the process tag is derived 

(cannot be changed). 

Additional information 
● Online help for PH, IEA and PO 
● Configuration manual Process Control System PCS 7; Operator Station 
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8.11.10.9 How to Edit Archive Tags 

"Archive Tags" Tab 
Here, all the process tags, CFC charts, SFC charts, and the interconnected WinCC archive 
tags indicated in the "General" tab are displayed along with their attributes. 
Each archive tag is displayed in a row. Not all the attributes defined in WinCC Tag Logging 
are displayed, but only the subset relevant to PCS 7. 

Processing 
The archive tags must first be created in WinCC Tag Logging. The attributes of the archive 
tags can then be edited directly in the table (without opening WinCC Tag Logging).  
When necessary, you can open WinCC Tag Logging from the shortcut menu. 
You can limit the number of objects selected for display by using a filter. You will find 
additional information on this topic in Section "Working in the process object view 
(Page 582)". 
Each cell displayed in the table with a white background can be edited directly in the process 
object view. 

Columns in the Table 
 

 Note 
If the connection is a structured connection from a fail-safe program, the field with the line 
number is displayed yellow at the beginning. 

 

 

 
Column Meaning 
Hierarchy Shows the technological path of the process tag or CFC (cannot be changed) 
Chart Shows the name of the process tag or CFC (cannot be changed) 
Plan comments Shows the comment on the object (cannot be changed) 
Block Shows the block name (cannot be changed). 
Block comment Shows the comment on the block. You can change the comment. 
I/O Shows the name of the block I/O or SFC I/O (cannot be changed). This cell is 

empty if an image object is assigned to the block as a whole. 
I/O comment Input field for the comment on the I/O. You can change the comment. 
Process tag 
connector 

Shows the name of the flagged I/O as specified for the process tag type 
(cannot be changed). 

OS Displays the component path for the OS containing the OS picture or the OS 
report. 
In a multiproject, the project name is also displayed in the path of an OS from 
a different project (cannot be modified). 

Archive name Name of the measured value archive (cannot be modified). 
Variable name Input field for the name of the archive tag. 
Variable comment Input field for the comment of the archive tag. 
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Column Meaning 
Long-term archiving Indicates whether or not the archive tag is intended for long-term or short-term 

archiving. Modifications made in this column have a direct effect on the 
WinCC measured value archive without recompiling the OS. The changes 
also affect the "Parameters" tab and the relevant block I/Os in CFC. 

Variable supply Type of variable supply. You make the selection from a drop-down list 
(system, manual input). 

Archiving Here, you can specify whether archiving begins immediately at system 
startup. You make the selection from a drop-down list (enabled, blocked). 

Acquisition cycle Cycle for acquiring data. You can select from a drop-down list. 
Factor for archiving 
cycle 

Here you can specify the factor for the archiving cycle. The factor cannot be 
modified if the acquisition type is acyclic. 

Archiving/display 
cycle 

Here you can enter the cycle used for archiving and for displaying the data. 
You can select from a drop-down list. The cycle cannot be modified if the 
acquisition type is acyclic. 

Save on fault/error Here, you enter the type of correction if faults or errors occur. You make the 
selection from a drop-down list (last value, substitute value). 

Archive if Here, you specify the state change of the logical signal, the type of change, 
and the time at which the change is archived. You can select from a drop-
down list. The entry is possible only for binary tags. 

Unit Unit from the ES data management. This is only displayed here and can be 
modified in the "Parameters" tab. 

Data type Displays the data type of the I/O. 
I/O Displays the I/O type (IN = input, OUT = output, IN_OUT = in/out parameter). 
Block type Displays the name of the block type from which the block originates. 
Chart type Here, you can see whether the archive tag belongs to a CFC or SFC chart. 
Process tag type Displays the name of the process tag type from which the process tag was 

derived. 

Additional information 
● Online help for PH, IEA and PO 
● Configuration manual Process Control System PCS 7; Operator Station 



 Implementing the PCS 7 Configuration 
 8.11 Configuring AS Functions 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 603 

8.11.10.10 How to Edit Hierarchy Folders 

"Hierarchy Folder" Tab 
In this tab, the hierarchy folders of the PH are displayed for the object currently selected in 
the hierarchy window. One line is displayed for each available hierarchy folder. 

Columns in the Table 
 
Column Meaning 
Hierarchy Shows the technological path of the hierarchy folder (cannot be changed). 
Name of Shows the name of the hierarchy folder. You can change the name.  

The maximum number of characters is specified in the "Plant Hierarchy - 
Settings" dialog box (menu command Options > Plant Hierarchy > Settings...) 
for each hierarchy level in the current project.  
The name cannot be changed for hierarchy folders that are labeled as links 
and for system-generated diagnostic folders. 

Comment You can change the comment. The comment cannot be changed for hierarchy 
folders that are labeled as links. 

ISA-88 type This column is hidden by default.  
It displays the ISA-88 type, which can be changed. All possible ISA-88 types 
and <neutral> are offered in a drop-down list for the respective hierarchy level. 
The ISA-88 type cannot be changed for hierarchy folders that are labeled as 
links, or for system-generated diagnostic folders. 

AS Displays the component path to the S7 program containing the hierarchy 
folder. 
You can display a drop-down list by clicking on an input field. If the project 
contains several S7 programs, these are displayed in the drop-down list. By 
selecting another S7 program, you can move the hierarchy folders with all 
subordinate levels to this program or remove the assignment to the AS with 
<not assigned>. 

OS Shows the component path of the OS which contains the hierarchy folders. 
You can display a drop-down list by clicking on an input field. If the project 
contains several OS, these are displayed in the drop-down list. You can move 
the respective object with all subordinate levels in this OS by selecting 
another OS or remove the assignment to the OS with <not assigned>. 
When you compile area-by-area, you can only change the OS assignment at 
the hierarchy folder of the OS area level. 

OS Area Identifier You can change the name for the hierarchy folder of the OS area level in this 
column. 
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Column Meaning 
Picture name for OS You can change the name of hierarchy folders below the OS area level in this 

column. 
Picture order You can change the picture order for the picture selection on the OS in this 

column. The numbers in the drop-down list indicate the arrangement of the 
pictures in descending order from left to right. 

Author Input field for the name of the author. If SIMATIC Logon Service was activated 
when a hierarchy folder was created, the user logged on at the time it entered 
here. 

Last modified You can see the date of the last change in this column (cannot be changed). 

Additional information 
● Online help for PH, IEA and PO 
● Configuration manual Process Control System PCS 7; Operator Station 
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8.11.10.11 How to Edit Equipment Properties 

"Equipment Properties" Tab 
In this tab, the equipment properties contained in the selected project are displayed. These 
equipment properties are instances generated from equipment properties types that have 
been configured in the shared declarations. One line is displayed for each available 
equipment property. The attributes are entered in the instance when a type is changed; they 
cannot be changed here. 

Columns in the Table 
 
Column Meaning 
Hierarchy Shows the path of the equipment property in the tree (cannot be changed).  
Name of In this column, you select the desired name of the equipment property type 

from the drop-down list for one of the available instances. The configured 
attributes of the type are applied when the data is updated with <F5>. 

Display name The display name can be in a foreign language and is transferred to WinCC 
when the OS is compiled (cannot be changed). You can only change the 
display name at the type ("Shared Declarations" tab). 

Comment The comment of the type is displayed in this column when the instance is 
created. You can change the comment. 

Value You can assign the equipment property a value in this column. The syntax is 
checked for conformity to the data type. If an enumeration is configured at the 
type, you can select a configured value from a drop-down list. 

Unit Shows the configured unit (cannot be changed). You can only change the unit 
at the type ("Shared Declarations" tab). 

Data type This column shows the configured data type (cannot be changed). You can 
only change the unit at the type ("Shared Declarations" tab). 

Enumeration If an enumeration is configured at the equipment property type, it is shown 
here (cannot be changed). You can only change the enumeration at the type 
("Shared Declarations" tab). 

Author Input field for the name of the author. If SIMATIC Logon Service was activated 
when an equipment property was created, the user logged on at the time is 
entered here. 

Additional information 
● Online help for PH, IEA and PO 
● Manual Process Control System PCS 7; SIMATIC BATCH 
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8.11.10.12 How to Edit Shared Declarations 

"Shared Declarations" Tab 
In this tab, you can edit the attributes of the types, enumerations, units of measure and 
equipment properties contained in the project.  

Columns in the Table 
 
Column Meaning 
Hierarchy Shows the path of the object in the tree (cannot be changed). 
Name of Shows the names of objects, contained in the folders of the shared 

declarations. 
Display name The display name can be in a foreign language and is transferred to WinCC 

when the OS is compiled. The display name can only be changed for the 
enumerations and for equipment property types. 

Comment Shows the comment on the object. You can change the comment. 
Type Shows the type name of the object. Type names are: enumeration, value, unit 

of measure, equipment property (cannot be changed). 
Value Shows the configured values of the enumerations. You can change the value. 

The fields are empty for units of measure and equipment properties. 
Unit This column shows the configured units for the equipment property. You can 

change the unit by selecting another from the drop-down list. The fields are 
empty for enumerations and units of measure. 

Data type Show the configured data type for the equipment property. You can change 
the data type by selecting another from the drop-down list. The fields are 
empty for enumerations and units of measure. 

Enumeration Shows the configured enumeration for the equipment property. You can 
change the enumeration for the INT, DINT, SOURCE, DEST and VIA data 
types by selecting one from the drop-down list. The fields are empty for 
enumerations and units of measure. 

Control strategy Shows if the enumeration involves a control strategy (check box is activated). 
You can change the attribute. 

Author Input field for the name of the author. If SIMATIC Logon Service was activated 
when a shared declaration was created, the user logged on at the time is 
entered here.  
The check boxes are empty for units of measure and equipment properties. 

Version Shows the current version of the configured types: enumerations, units of 
measure and equipment properties. You can change the version. 

Additional information 
● Online help for PH, IEA and PO 
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8.11.10.13 How to Test in the Process Object View 

Test Mode in the Process Object View 
The process object view provides a test mode in which you can test and commission 
process tags and CFC charts online on the CPU. 
In test mode, the following columns are displayed dynamically in the process object view: 
 
Tab Dynamic Column Additional Column in Test Mode 
General Status 

Selected 
Simulate inputs 
Simulate outputs 

Monitoring 

Parameter Status 
Value 

Monitoring 

Signals Status 
Value 

Monitoring 

You register a process tag or chart for testing (Page 681) by placing a check mark in the 
"Watch" column. 
The tabs not listed in the table (messages, picture objects etc.) cannot be selected in test 
mode. 

Setting Test Mode 
Analogous to CFC, the test mode can be run-off in process or laboratory mode. You can set 
this in offline mode with the menu commands Options > Process Objects (Online) > Process 
Mode or > Laboratory Mode. 
Use the menu command Options > Process Objects (Online) > Test Settings... to open a 
dialog box for setting the monitoring cycle. The watching cycle has global effects on all 
process tags and CFC charts of the current window in the process object view (not CPU-
specific as in CFC and SFC).  
These setting are made independently of the settings in CFC/SFC. 

Activating/Deactivating Test Mode 
You set test mode in the SIMATIC Manager. When it is activated/deactivated, the active 
window of the process object view is affected. 
● Activating/deactivating test mode 

Use the menu command View > Online to activate test mode.  
Use the menu command View > Offline to deactivate test mode. 

When it is activated, the system switches to the existing window rather than opening a new 
one. 
During the changeover process into the test mode a test is carried out to make sure that the 
online data and the offline date correspond with each other. This procedure is carried out in 
the same way as the test mode in CFC and SFC. If there are deviations, a message to this 
effect is displayed. 



Implementing the PCS 7 Configuration  
8.11 Configuring AS Functions 

 Engineering System (V7.1) 
608 Configuration Manual, 03/2009, A5E02122455-01 

Explanations of the Tabs 
The test mode has the following effect on the tabs: 

 
Tab Description 
General In this tab, it is not possible to delete, move, or copy objects. Apart from the "AS" column, all the 

columns remain editable if they can be modified in offline mode. 
When test mode is activated, changes in the "Activated", "Simulate inputs" and "Simulate outputs" 
columns are saved in the engineering station and downloaded to the AS. This also applies if the 
process tag or chart is not registered for the test. 

"Parameters" and 
"Signals" 

In these tabs, the columns "Watch", "Value" and "Watched" can be edited. 
When test mode is activated, changes in the "Value" and "Watches" columns are saved in the 
engineering station and downloaded to the AS. This also applies when the I/O is not registered for 
the test. 
A faulty or undefined value is indicated with "####". 
Dynamic values are shown on a different background according to their status as follows: 
• Yellow (dynamic, can be changed) 
• Gray-yellow (dynamic, cannot be changed) 
• Red (failed) 
The color of the field changes from yellow to white when it is clicked on to edit the value. The offline 
value is then shown. 

Logging the Changes in the ES Log 
In test mode, all the actions that cause a change (value change) in the CPU are logged in 
the ES log.  
Requirements: 
● The SIMATIC Logon Service is installed. 
● The ES log is activated for the currently selected chart folder. 
If there is a change, the ES log is opened and the reason for the change is entered. If the 
user is not yet logged into the SIMATIC manager then the SIMATIC Logon Service dialog 
will open prior to opening the change log.  
The logged changes can be found via the menu command Options > Charts > Logs..., in the 
"ES Log" tab. 

Printing Tab Displays 
Just as in offline mode, you can print out the values displayed in the current tab using the 
shortcut menu Print > Current Tab.  
You can only print the current tab with the menu command File > Print > Object List... in 
contrast to offline mode. This is already selected in the "Settings for printing the process 
object view" and cannot be modified. 

Additional information 
● Online help for PH, IEA and PO 
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8.12 Configuring OS Functions 

8.12.1 Overview of Configuration Tasks 

Introduction     
The PCS 7 operator station (OS) is configured in various substeps. The configuration is 
carried out using several PCS 7 tools: 
● In the SIMATIC Manager 
● In the WinCC Explorer 
The entire configuration of the OS is carried out in the engineering system so that all the 
configuration data can be managed centrally. 
Depending on the requirements of your project, some of the steps in configuration are 
mandatory and others optional. 
For a completed description of configuring the OS functions, refer to the Configuration 
Manual Process Control System PCS 7; Operator Station. 
Below you will find preliminary information in the form of a table listing all the configuration 
steps. From the table, you can see which configuration steps are necessary and which are 
options. 

SIMATIC Manager 
 
Configuration Task Must Optional 
Inserting and configuring a PCS 7 
stations 

 X 
When additional operator stations are 
required. The PCS 7 wizard 
automatically creates a PCS 7 OS 

Configuration of network connections for 
a PCS 7 OS 

X  

Inserting pictures in the plant hierarchy  X  
AS-OS assignment X  
Creating block icons X  
Changing unit and operator texts  X 
Defining archive tags X  
Configuring messages  X 

If you want to define messages that 
differ from the defaults 

Specifying the message number range X  
Defining the message priorities  X 

Important for messages in the 
message line in the overview area 

Defining the plant designation X  



Implementing the PCS 7 Configuration  
8.12 Configuring OS Functions 

 Engineering System (V7.1) 
610 Configuration Manual, 03/2009, A5E02122455-01 

Configuration Task Must Optional 
Defining the OS area identifier X 

Plant hierarchy 
X 
Control and monitoring attributes 

Defining picture names and picture 
hierarchy 

 X 
If you want to define picture names 
that differ from the defaults 

Setting the update routines: 
• Updating the AS-OS connections 
• Updating the OS area identifier 

 X 

Specifying the compilation mode X  
Compiling the OS X  
Downloading the OS X  

Compiling the OS 
You must run the "Compile OS" function once you have completed ES configuration of all 
data in the SIMATIC Manager, and before you start to configure the OS data in the WinCC 
Explorer. You must also compile the OS if you subsequently changed the ES configuration. 
All the data from the SIMATIC Manager, such as variables, messages, texts, and the 
hardware and connection configuration is "made known" to the OS for further configuration. 

WinCC Explorer 
 
Configuration Task Must Optional 
Setting the object properties  X 
Setting the computer properties  X 
Setting the parameters in OS Project 
Editor 

 X 
If you want to define settings that differ 
from the defaults 

Setting up user permissions X  
Visualization of a plant – basics: 
• Inserting dynamic objects 
• Using a status display 
• Using an expanded status display 
• Inserting an I/O field 
• Configuring a group display 

X 
Using the 
required 
objects 

 

Visualization of a plant – basics: 
• Using faceplates and block icons 

that are not created automatically by 
PCS 7. 

• Creating user objects 
• Creating user object templates 
• Inserting picture windows 
• Using process object view and 

cross-reference lists 

 X 
These options support you effectively 
when making settings for process 
pictures 
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Configuration Task Must Optional 
Calculating the group display hierarchy X  
Setting the parameters for the alarm 
system: 
• Definitions in the project editor 
• Settings in alarm logging 
• Configuring the message lists 
• Configuring the acoustic signaling 

device 

 X 

Configuring archives and logs X  
Configuring an archive server  X 

If you use the "Archive Server" add-on 
Setting the 
• Time-of-Day Synchronization 
• Sign-of-life monitoring 

 
X 

 
 
X 

Configuration of the diagnostic functions  X 
Simulation of the OS on the ES  X 
Directly on the OS servers/OS clients 
after downloading the project: 
• Activating the project 

X  

Additional information 
● Configuration Manual Process Control System PCS 7; Operator Station. 
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8.12.2 Setting the AS/OS Lifebeat Monitoring 

Introduction 
With the OS "Lifebeat Monitoring" function, you can monitor the functions of the CPUs and 
operator stations connected to the plant bus in PCS 7. This means that you always have an 
up-to-date overview of the state of your plant.  
The monitoring function is executed from the operator station declared as the lifebeat 
monitor. 

Lifebeat Monitor 
The lifebeat monitor monitors all OS servers, OS clients and all automation systems. 
Requirements: 
All the components to be monitored are connected to a continuous network and assigned to 
the lifebeat monitor. The monitoring is performed in a cycle that you can specify when 
configuring lifebeat monitoring. 
The lifebeat monitoring is configured in the WinCC "Lifebeat Monitoring" editor. 

Monitoring an Automation System 
On an automation system, a process control message is generated in two situations: 
● The lifebeat monitoring reads the current operating state from the automation systems. If 

a mode change is detected, for example, from RUN to STOP, a control system message 
is generated by the lifebeat monitor. 

● The lifebeat monitoring sends monitoring requests to an AS. Whenever the power supply 
is interrupted, the device fails, or a connection breaks down, the AS can no longer 
respond to this monitoring request and a process control message is generated. 

Display of Lifebeat Monitoring in Process Mode 
The lifebeat monitoring is automatically activated for the OS. The lifebeat monitoring takes 
place for OS in 5 second to 1 minute cycles. 
An error message appears as follows: 
● As soon as lifebeat monitoring recognizes that a component has failed, a process control 

message is generated automatically. 
● The state of all monitored components is also displayed in a separate picture that the 

operator can display using a button in the button set. In this picture, the failed component 
is indicated by being "scored through". In addition, a supplementary note in text form 
appears in this picture, for example: 
– "faulty" 
– "Server failed" 
– "Server configured" 

The elimination of a problem is also indicated by a process control message. 

Additional information 
You will find step-by step instructions on configuring the AS/OS lifebeat monitoring in the 
configuration manual Process Control System PCS 7; Operator Station. 
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8.13 Configuring BATCH functions 

Introduction 
SIMATIC BATCH is a PCS 7 program package that enables discontinuous processes, 
known as batch processes, to be configured, planned, controlled and logged. 
Simple batch processes with configurable sequential control systems are automated with the 
CFC and SFC tools included in the PCS 7 Engineering System. In more demanding systems 
with recipe procedures, SIMATIC BATCH is used.  
With SIMATIC BATCH, recipe structures are designed, modified, and started graphically on 
an operator station or on a separate PC. 
Configuration involves the following: 
● Engineering 
● Rights Administration 
● Recipe Creation (offline) 
● Process mode 

Engineering 
Configuration of the batch process cell takes place along with the basic engineering of the 
S7-400 on the engineering station in the SIMATIC Manager (for example, phase and 
operation types, equipment properties, user data types, units of measure). 
 
Configuration Task Must Optional 
Batch plant configuration in the engineering system (ES) X  
Compiling Batch process cell data  X  
Downloading the Batch process cell data to target systems (BATCH 
servers, BATCH clients)  

X  

Reading in Batch process cell data on the BATCH clients  X  

Rights Administration 
SIMATIC BATCH uses the PCS 7 central user management. 
 
Configuration Task Must Optional 
Specifying the user permissions for SIMATIC BATCH X  
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Recipe Creation (offline) 
Reading in the Batch process cell data (engineering data) on any BATCH client with 
BatchCC allows the creation of offline data. You create the materials, formula categories, 
and formulas with BatchCC. You create libraries and master recipes with the BATCH Recipe 
Editor. Releasing master recipes, library elements and formulas allows their subsequent use 
in process mode. 
 
Configuration Task Must Optional 
Editing materials X  
Creating and editing master recipes X  
Creating and editing library operations  X 

when working 
with libraries 

Validating recipes X  
Approving recipes for production X  
Creating a new formula category (only with external formula)  X 
Creating formulas (only with external formula)  X 
Interconnecting parameters between master recipe and formula (only 
with external formula) 

 X 

Process mode 
The first phase of process mode is batch planning. The production orders are created here. 
These are divided into batch orders that can then be approved and started. The actual Batch 
processing programs (equipment phases) run on the automation system and are coordinated 
by the batch control.  
The batch data management makes use of individual WinCC components. The values for 
the required measured value sequences for a batch report are obtained from the measured 
value archive and all Batch-relevant messages are filtered from the message archive and 
displayed within BatchCC. 
 
Configuration Task Must Optional 
Creating the production orders X  
Creating and editing batches X  
Approving the batch X  
Starting production of a batch X  
Operator control while editing a batch X  
Batch reports X  
Archiving the batch X  

Additional information 
● Online help for SIMATIC BATCH 
● Manual Process Control System PCS 7; SIMATIC BATCH 
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8.14 Configuration of the Route Control functions 

Introduction 
SIMATIC Route Control is a program package from PCS 7 for automating the transport of 
materials in plants. 
SIMATIC Route Control searches for a route through the sections of the available route 
network and controls the material transport, for example, by opening valves and activating 
pumps. 
SIMATIC Route Control includes both the configuration and the runtime system and offers 
numerous interfaces to the PCS 7 base system and to the user programs. 
Depending on the plant design, both straightforward transport processes and complex route 
combinations are possible. 
The configuration tasks involve the following: 
● Engineering 
● Permission management 

Engineering 
The PCS 7 project is the central configuration environment including the data storage. 
You configure the following here: 
 
Configuration task Obligatory Optional 
Plant hierarchy (plants, units) X  
Node points X  
Automation systems X  
Cross-project AS-AS connections (engineering tool: Route Control Wizard) X  
PC stations X  
CFC charts X  
SFC charts X  

Start the following SIMATIC Route Control tools in the SIMATIC Manager: 
● Route Control Wizard 
● Route Control Engineering (configuration interface) 
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Route Control Engineering encompasses the following steps: 
 
Configuration task Obligatory Optional 
Transfer of elements, routes, node points and automation systems from the 
PCS7 project 

X  

Configuration of the function catalog and function IDs X  
Configuration of the sections in the route network X  
Interconnection of element to sections and specification of the function 
levels 

X  

Configuration of materials, material groups and permitted sequential 
relationships between materials and material groups 

X  

Rights Administration 
The central user management from PCS 7 is used for SIMATIC Route Control. 
 
Configuration task Obligatory Optional 
Defining user rights for SIMATIC Route Control (Windows user 
management) 

X  

After SIMATIC Route Control has been installed, five user groups are created. The user who 
carried out the installation is entered automatically. If you require further users, you have to 
assign them to the user groups. 

Additional information 
● Online help for SIMATIC Route Control 
● Manual Process Control System PCS 7; SIMATIC Route Control 
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8.15 Configuring the connection to the works management level 
(OpenPCS 7) 

8.15.1 How to configure OpenPCS 7 stations for accessing PCS 7 data 

Introduction        
To enable access to the PCS 7 data, assign the OS server data to the OpenPCS 7 station 
and download the configuration data.  

Requirements 
● The OpenPCS 7 station has been created. 
● The target path of the OpenPCS 7 station has been entered. 

Procedure 
1. Open the project in the SIMATIC Manager and activate the component view. 
2. Select the OpenPCS 7 station in the tree view: 

SIMATIC PC-Station > SPOSA application > Open_PCS7_Station 
3. Select the menu command Options > OS > Assign OS Server.... 

The "Assignment of OS Server for <name of OpenPCS 7 station>" dialog box opens. 
4. Activate the check box of the OS server whose server data you want to assign to the 

OpenPCS 7 station selected above. 
5. Click "OK". 
6. Select the menu command CPU > Download. 
The OpenPCS 7 station is configured and loaded. 

Configuring Data Communication 
Configure the data exchange with your OPC client application by using the following 
functions: 
● Data exchange via OPC - standard functions of the OPC server. 
● Data exchange via OLE DB - standard functions of the WinCC-OLE DB provider. 
For further information please refer to the following links: 
Service & support (http://www.siemens.de/automation/service&support)  
OPC Foundation (http://www.opcfoundation.org)  

 

 Note 
Ensure appropriate access protection for your OPC client application. 

 

http://www.siemens.de/automation/service&support
http://www.opcfoundation.org/
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Additional information 
● Section "How to insert and configure an OpenPCS 7 station (Page 285)" 
● Section "Connecting to the IT world via OpenPCS 7 (Page 123)" 
● Section "Structure of the OpenPCS 7 station (Page 172)" 
● Manual SIMATIC NET; Industrial Communication with PG/PC 
● System manual SIMATIC HMI; OPC - OLE for Process Control 
● Manual Process Control System PCS 7; PC Configuration and Authorization 
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8.15.2 How to configure the OpenPCS 7 stations for accessing historical alarms in a 
central archive server 

Introduction         
Transparent OPC A&E access to historical alarms in a central archive server (CAS) 
If, while reading messages on an OS (via OPC Alarms & Events), you also wish to access 
messages relating to this OS that are located in an archive on a central archive server, 
assign the central archive server to the OpenPCS 7 station and download the OpenPCS 7 
station. 

Requirement 
● The OpenPCS 7 station has been created. 
● The target path of the OpenPCS 7 station has been entered. 

Procedure 
1. Open the project in the SIMATIC Manager and activate the component view. 
2. Select the OpenPCS 7 station in the tree view: 

SIMATIC PC-Station > SPOSA application > Open_PCS7_Station 
3. Select the menu command Options > OS > Assign OS Server.... 

The "Assignment of OS Server for <name of OpenPCS 7 station>" dialog box opens. 
4. Activate the check box of the central archive server whose server data you want to assign 

to the OpenPCS 7 station selected above. 
5. Click "OK". 
6. Select the menu command PLC > Download. 

The OpenPCS 7 station is configured and downloaded. 
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Open PCS7 - Transparent OPC A&E access to historical alarms (historical A&E) on a central archive 
server (CAS) 

If, while reading messages on an operator station, you wish to use OPC Alarms & Events to 
gain additional access to messages for this OS that are stored in an archive on a CAS, then 
you will need to carry out the following configuration steps: 
1. In the tree view, select the OS object: 

SIMATIC PC station > WinCC Appl. > OS(x) 
2. Select the menu command Options > OS > Assign OS Server... to assign the CAS to the 

OS server. 
The "Assignment of Server to OS(x)" dialog box opens. 

3. Select the CAS and click "OK". 
4. Deactivate the "All servers" check box for all alarm controls of the OS server  

and select only those servers (with the exception of the CAS) whose messages are to be 
displayed. 

 

 
 

Note 
When a time range is specified in an alarm control, the messages archived in the CAS 
are automatically included - even if the CAS was not one of the servers selected. 

 

Additional information 
● Section "How to configure OpenPCS 7 stations for accessing PCS 7 data (Page 617)" 
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8.16 Merging projects after distributed editing (multiproject engineering) 

8.16.1 Merging projects after distributed editing (multiproject engineering) 

Overview     
Merging projects of a multiproject following distributed editing involves the following topics:  
● How to Move Projects Edited on Distributed Stations to the Central Engineering Station 

(Page 622)  
● Merging Subnets in the Multiproject Across Projects (Page 624)  
● Merging Connections Across Projects (Page 625)  
● How to Configure New Cross-Project Connections Between AS and OS (Page 626)  

Rules for Multiproject Engineering with SIMATIC BATCH 
 

CAUTION  
For multiproject engineering with SIMATIC BATCH, distributed engineering on distributed 
engineering stations including testing is only possible when certain conditions are met and 
the additional steps are taken.  
You will find additional information on this topic on the Internet 
(http://support.automation.siemens.com/WW/view/en/23785345). 

 

http://support.automation.siemens.com/WW/view/en/23785345
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8.16.2 How to Move Projects Edited on Distributed Stations to the Central Engineering 
Station 

Requirements 
● The project is physically located on a distributed engineering station and is included in the 

multiproject. 
● The distributed engineering station is obtainable over the network. 

Procedure 
1. If necessary, delete the existing project of the same name (version prior to moving to 

distributed engineering station) on the central engineering station (backup copy). 
2. Use the menu command File> Open... in the SIMATIC Manager to open the project from 

the central engineering station on the distributed engineering station 
3. Click the "Browse" button. 
4. Go to the "Browse" menu and enter the path of the project being moved in UNC notation 

in the "Search in directory" field. 
5. Click "Start Search".  

The project is displayed in the "User projects" tab. 
6. Select the required project in this tab and click "OK".  

The project opens. 
7. Select the menu command File> Save as .... 
8. Make the following settings 

– Disable the "With Reorganization (slow)" check box. 
– Enable the "Insert in multiproject" option. 
– Select the "Current multiproject" entry in the corresponding drop-down list. 
– Enable the "Replace current project" check box. 

9. Click "OK". 

Result 
An identical copy of the distributed engineering station project is created on the central 
engineering station in the multiproject. The original is retained on the distributed engineering 
station and can remain there as a backup or be deleted. 
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Rules 
 

 Note 
Before the copied project can be copied back to its old location (same directory name), this 
backup has to be deleted or renamed on the central engineering station. You can find 
additional information about this in the following section: "How to Move Projects to 
Distributed Engineering Stations (Page 348)" 

 

 Note 
You can also move a project back to the central engineering station if it was moved out with 
the "Remove to edit..." function and provided that it can be accessed via the same path that 
was used during its removal: 
1. Select the project labeled "project removed for editing" on the central engineering station 

(grayed out). 
2. Select the menu command File > Multiproject > Reapply after Editing....  

The project is reincorporated from the distributed engineering station into the multiproject 
on the central engineering station. 

 

Additional information 
● Section "How to Move Projects to the Central Engineering Station (Page 348)" 
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8.16.3 How to Merge Subnets from Different Projects into a Multiproject 

Introduction 
If you use cross-project networks in the multiproject, the networks in the projects must be 
merged back into the multiproject.  

Requirement 
Writing access to the participating projects and their subnets is possible.  

Procedure 
1. Select the required multiproject in the SIMATIC Manager 
2. Select the menu command File > Multiproject > Synchronize Projects.... 

The "Synchronize Projects in Multiproject <xxx>" dialog box opens. 
3. Go to the left window and select the Ethernet networks you want to connect and click 

"Execute". 
The dialog box for merging/separating the subnets opens. 

4. In the left field, select the subnet and click "->". 
The selected subnet is merged in the selected overall network. 

5. Change the default name of the cross-project network according to the requirements of 
your project (click the name twice). 

6. Follow the same procedure for all the subnets you want to merge. 
7. Click "Apply" and then "Close" in order to close the dialog box. 
In the same dialog box you can separate those networks that have already been merged. 
In this dialog box, you can also create new cross-project subnets ("New" button). 

Check Consistency 
After merging the subnets and prior to downloading to NetPro use the menu command 
Network > Check Cross-project Consistency to check whether there is consistency 
throughout the multiproject. 
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8.16.4 How to Merge Cross-project Connections 

Procedure 
Cross-project connections can be merged as follows: 
● During synchronization of projects in a multiproject in the SIMATIC Manager, using the 

menu command File > Multiproject > Synchronize Projects.... 
● In NetPro with the menu command Edit > Merge Connections.... 

Sequence 
The following variations occur in the sequence:  
 
SIMATIC Manager NetPro 
• In the SIMATIC Manager, the only 

connections that are merged are those in the 
projects that were configured as "Connection 
partner in other project" with identical 
connection names (reference). 

• In NetPro, you can also assign connections 
that have similar or different connection 
names. 

• When merging in the SIMATIC Manager, it is 
not possible to foresee which connection 
partner retains the connection properties and 
which connection partner adapts its 
connection properties (for example, active 
connection establishment). 

• When you merge in NetPro, the partner 
always adapts its connection properties to 
those of the local module. Apart from this, it is 
also possible to change the properties of 
connections in the dialog box for merging 
connections in NetPro. 

• In the SIMATIC Manager, S7 connections to 
an unspecified partner are ignored. 

• S7 connections to an unspecified partner can 
be merged to a cross-project S7 connection in 
NetPro. 

Additional information 
● Online help on STEP 7 
● Section "How to Merge Cross-Project Connections (Page 455)". 
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8.16.5 How to Configure New Cross-project Connections between AS and OS 

Introduction 
Cross-project connections between AS and OS components are configured in the same way 
as cross-project connections between AS components. 

Requirements 
● The networks involved are merged at multiproject level. 

You can find information about this in the section "How to Merge Subnets from Different 
Projects into a Multiproject (Page 624)" 

● The AS/OS assignment is specified. 
You will find additional information on this topic in Section "How to Specify the AS/OS 
Assignment (Page 300)" 

Procedure 
When creating cross-project connections between AS and OS components, in contrast to the 
procedure described in the section "Cross-project Connections in a Multiproject (Page 453)", 
you select a connection partner in a different project. 
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Adopting the Data from the Plant Engineering 9
9.1 Introduction 

Copying and Pasting between PCS 7 and Excel      
In all the editors in PCS 7 and the process object view, you can select areas and transfer 
them to Excel by copying and pasting, edit them and then return them in the same way. 
You can also exchange data with Access in the same way. 

Import/Export Functions  
All the essential applications of the PCS 7 engineering system have import/export interfaces. 
The use of these import/export interfaces has the following advantages: 
● Plant-planning data can be harmonized with control-system engineering data. This is how 

control system engineering and plant engineering can be independently edited at the 
same time. 

● Data from the engineering system can be exported as a template, be effectively 
duplicated and adapted in an external program (such as MS Excel) and then be imported 
back into the engineering system. This allows the configuration of repeated or similar 
plant information to the optimized. 

Overview of All Import/Export Functions 
You will find additional information on this topic in Section "Importing and Reusing Plant Data 
(Page 217)". 

Overview of All Importable/Exportable Data Formats 
You will find additional information on this topic in Section "Which Data and Data Formats 
can be Imported? (Page 157)". 

Described as Follows 
The following import/export functions are described in the following sections: 
● Import/export of process tags/models 
● Import/Export of the Hardware Configuration 
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9.2 Import/export of process tags/models 

9.2.1 Identifying Repeated Functions 

Introduction 
The starting point for mass data processing is to identify repeated functions. 

Functional Units of a Plant 
Generally a plant is structured by dividing it into smaller functional units that can be 
classified, for example, as fixed setpoint controls or motor controllers. 
Instead of implementing new functional units each time they are required, you can create a 
pool of ready-made functional units that you then only need to copy and modify for the new 
situation.  
Configure in ES - consistent with the functional units of the plant - the process tag type or 
model objects you are familiar with to create process tags or replicas using import/export. 

Specifying Process Tag Types and Models 
Define the process tag types and models of your plant.  
Consult the PCS 7 library to determine which precompiled process tag types you can use in 
your project. Or create your own process tag types and models with CFC charts. 

Additional information 
● Section "How to Create a Process Tag Type from a CFC Chart (Page 518)" 
● Section "How to Create a Model (Page 570)" 
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9.2.2 Working with the import/export wizard 
 

 Note 
The Import/Export Assistant (IEA) is an option package in itself in PCS 7, which requires an 
own authorization.  
The IEA is supplied together with the PH and the process object view on the PCS 7-Toolset 
DVD. The programs are also installed together.  

 

When do I work with the IEA? 
During the planning of a plant, a wide variety of data is created, often at a time where no 
definite control system is planned. By using the import function, this data can be made 
available to the control system engineering. 
You use the IEA when several models or process tag types are often assigned in a project 
(processing mass data) and you want to modify the parameter descriptions of the blocks. 

Using the IEA 
The following figure shows the function of the IEA using a model as an example. 
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9.2.3 Working with process tags and models 

9.2.3.1 Working with Process Tags and Models 

Overview 
Working with process tag types and models in the import/export wizard includes the following 
subjects: 
● Requirements and Steps in Configuration (Page 630) 
● Functions for Working with Process Tags and Models (Page 633) 
● How to Create an Import File and Assign it to the Process Tag Type  (Page 523) 
● What happens during import? (Page 637) 
● How to Import Process Tag Types and Models (Page 639) 
● What happens during export? (Page 642) 
● How to Export Process Tag Types and Models (Page 643) 
● Restrictions with the IEA (Page 644) 

9.2.3.2 Requirements and Steps in Configuration 

Requirement 
The process tag types and/or models have been created in the master data library. 

Overview of Configuration Tasks 
 
Step What? Described in section 
1 Create process tag type/model  How to Create a Process Tag Type from a 

CFC Chart (Page 518) 
How to Create a Model (Page 570) 

2 Assign the import file to the process tag 
type/model - Create the import file  

How to Create an Import File or Assign it to 
the Process Tag Type (Page 523) 
How to Create a Model (Page 570) 

3 Editing the Import File with the IEA File 
Editor 

Creating/Editing Import Files with the IEA 
File Editor (Page 646) 

4 Import process tag types/models  How to Import Process Tag Types and 
Models (Page 639) 

5 Optional: Supplying process tags and 
replicas with current parameters 
(Only if the data was not already added with 
the IEA file editor.) 
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How the IEA Works 
The following graphic illustrates the functions of the assistant based on the example of a 
"process tag type".  
The steps for the model are similarly shown in gray. 
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Start IEA 
You start the Import/Export Assistant in the SIMATIC Manager either in the plant view or in 
the process object view after selecting a hierarchy folder. (Single process tag types can also 
be selected when working with process tag types.) 
From the Options menu select the menu command Process tag or Models and then, in the 
following submenu, the required function. 

Additional information 
● Online help for PH, IEA and PO 
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9.2.3.3 Functions for Working with Process Tags and Models 

Introduction 
With the Import/Export Assistant (IEA), you can work with process tag types and their 
process tags or models and their replicas. The IEA provides functions for reusing and 
adapting the process tag types/models. 

Functions Used when Creating 
 
Assistant Functions of the Assistant 
Creating/Changing Process 
Tag Type (Page 518) 

Use the assistant to carry out the following: 
• Create a process tag type from existing CFC charts and store it in the master data 

library. 
• Add/remove I/Os/messages to or from an existing process tag type. 
• Check if the existing process tags deviate from the process tag type and if so, 

synchronize them. 

Creating/Modifying Models 
(Page 570) 

Use the assistant to carry out the following: 
• Create a model for storage in the master data library using PH objects previously 

created with CFC/SFC charts, OS pictures, OS reports, etc. 
• Add/remove I/Os/messages to or from an existing model. 
• Create and assign an import file. 
• Check the consistency of the model with the assigned import file. 
• Check replicas for changed IEA flags. 
The selected I/Os and messages are all assigned to a column of the import file. The import 
can be started after all the data is entered in the import file. 
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Importing Data from Plant Planning 
Each functional unit in the plant corresponds to a line in the import file. The import/export 
wizard copies the appropriate model (creates replica) or process tag type (creates process 
tags) for each functional unit. It changes their interconnection/parameter descriptions and 
message texts depending on the content of the corresponding line in the import file. 
When you import, you can decide whether or not the imported signals will be entered in the 
symbol table (option: "Also enter signals in the symbol table"). With PCS 7, we recommend 
that you do not use the option because these entries are made when you configure the 
hardware with HW Config. 

 
Assistant Functions of the Assistant 
Importing process tags With the assistant, you can create process tags from process tag types and import the data 

from the import file to the process tags.  
The process tag type is copied from the master data library to the relevant target projects. 
Thereafter the data is imported.  
The result is a process tag as a copy of the process tag type for each row of the import file. 
The import file data is written to the corresponding I/Os or process tag blocks. 

Importing Models With the Assistant, you can create replicas of models and import the data from the import 
file to the replicas. 
In a multiproject, the model is copied from the master data library to the specified target 
projects as a replica. Thereafter the data is imported. 
The result is a replica of the model for every row of the import file. The import file data is 
written to the corresponding I/Os or replica blocks. 

Process tags: 
assigning/creating an import 
file 

Use the assistant to carry out the following: 
• Assign an import file to a process tag type. 
• Check the assignment of the import file to the process tag type. 
• Create a template for the import file for the process tag. 
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Export Data for Plant Planning 
The replicas of the models or the process tags of process tag types are modified, for 
example, during testing and commissioning of the control system. This also involves data 
that was configured with other tools during plant planning and imported for the control 
system engineering.  
The following application options exist for the export of this data: 
● If you want to synchronize the plant documentation with the current configured status, 

export the current data of the models previously created during the import process in the 
same form as when they were imported. 

● You can export the data of the plant configured with replicas of models or with process 
tags, edit the data again with the IEA file editor or with other tools (for example, Excel or 
Access) and then import it again. You can make modifications to the project simply and 
quickly. 

 
Assistant Functions of the Assistant 
Exporting process tags You can export the data of the process tags with the assistant. In the multiproject, all 

available projects are included. 
This results in a process tag type export file that contains one line for each process tag of 
the process tag type. 
A valid import file must be assigned. The individual column groups are structured with the 
same number of column titles and names as in the import file. 

Exporting models With the assistant, you can export the data of the replicas of models. In the multiproject, all 
available projects are included. 
This results in a model export file that contains a line for each replica of the model. 
A valid import file must be assigned. The individual column groups are structured with the 
same number of column titles and names as in the import file. 

Rules 
● When working with the "import/export" functions of the Import/Export Assistant, further 

hierarchy folders may be contained in the model. 
● Only one OS picture per hierarchy folder may exist if the picture hierarchy is derived from 

the PH. 
● If the model includes nested hierarchical folders, they may not be renamed. 
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Additional information 
 
Assistant Functions of the Assistant 
Process tags: synchronizing The assistant enables you to resolve the following inconsistencies between the process tag 

type and the process tags. 
When a process tag type is modified, the process tags in the project are automatically 
changed.  
If not all process tags in the project can be accessed during the automatic synchronization, 
inconsistencies form between process tag type and the process tags. You should remove 
them with an explicit synchronization.  

Tip 
 

 Note 
In order to increase the clarity of the charts switch the model block I/Os that you do not 
require to invisible. 
If you edit later in the IEA, you will see the selections set in the CFC in the process object 
view and can correct them there if necessary. The same applies to selections in models. 
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9.2.3.4 What happens during import? 

Explanation of the Import Procedure - Using the Example "Model"    
Process tags and models are imported in the same way. 
You can start the import procedure after you have configured a model and have assigned an 
import file to it. The following steps are executed automatically: 
1. The hierarchy path is read from the "Hierarchy" column in the first data line of the import 

file. The availability of the path is checked. Additional actions depend on the test results: 
– If the hierarchy folder already exists as a replica of the model, the parameter settings 

from the import file are applied to it. 
– If the hierarchy folder already exists and is suitable for becoming a replica, it along 

with its CFC chart are made into a replica of the model and assigned parameters 
according to the import file. 

– A hierarchy folder is created if it does not exist. Thereafter a replica of the model is 
created and assigned parameters accordingly. 

2. If columns are available the following elements are entered into the chart text fields: 
– Function identifier (FID) 
– Location identifier (LID) 
– CFC chart name 
– Plan comments 

3. Texts and values of the parameter descriptions and the interconnection descriptions 
(signals) are written to the corresponding block or chart I/Os of the replicas. 

 

 
 

Note 
An interconnection is deleted when the signal name (symbol or textual interconnection) 
consists of the code word "---" (three dashes). 
An interconnection remains unchanged, if no interconnection name (symbol or textual 
interconnection) is specified. 

 

4. The I/O data types for signals are determined and assigned to the interconnections. 
 

 
 

Note 
The rule for interconnections with shared addresses is as follows: if the "Include signal in 
the symbol table" option is set, the names can be found in the model resource symbol 
table.  
With PCS 7, we recommend that you do not use the option because these entries are 
made when you configure the hardware with HW Config. 
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Note the following rules:  
– The symbol name is present in the symbol table 

The data type must be the same; the symbol name may only exist once. The data type 
is assigned parameters according to block/chart I/O. The absolute address is 
overwritten and a symbol comment is entered for the symbol (if available in the import 
file). Only the information that has changed will be overwritten, existing attributes are 
retained. 

– The symbol name is not yet available in the symbol table 
The interconnection is created and the data type is assigned parameters according to 
I/O. The absolute address and the symbol comment are entered for the symbol (if 
available in the import file). 

5. The message text is imported for each message. 
6. Steps 1 through 5 are repeated for each line in the import file. 
The input files appear together with the models in the list if you have selected a hierarchy 
folder that contains several models. If required, you can still edit the list. Following this, the 
import starts for all models in the list as described above. 

Error Messages in the Import Log 
Error messages will be generated in the import log under the following circumstances: 
● The hierarchy path contains a replica that does not belong to the model: for instance, 

there are too many or too few I/O points and/or the block is not or is incorrectly identified 
as a signaling block. 

● If a model is located in the hierarchy path 
● If the settings in the plant hierarchy do not match the imported hierarchy path 
● If signals in the symbol table are not unique or will be written with incorrect data types 
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9.2.3.5 How to Import Process Tag Types and Models 

Sequence 
Use the assistant for process tags or models to import the following data: 
● Process tag typedata 

The process tag type is copied from the master data library to the specified target 
projects as a process tag and the data are then imported. Any number of process tags 
can be created, depending on the entries in the import file. 
As a result of the import, a process tag of this process tag type is created in the target 
project for every row of the import file according to the specified hierarchy path. 

● Modeldata 
The model is copied from the master data library to the specified target project as a 
replica and the data are then imported. You can create any number of replicas according 
to the entries made in the import file. 

 

 
 

Note 
When you import a process tag or model, you can decide whether or not the imported 
signals will be entered in the symbol table (option: "Also enter signals in the symbol 
table").  
With PCS 7, we recommend that you do not use the option because these entries are 
made when you configure the hardware with HW Config. 

 

 
 

Note 
Before importing, check the language set for display. If you created the model in German 
and if the current setting of the SIMATIC Manager is "English", the German message 
texts will be written into the English text file. 

 

Procedure 
1. Select the desired hierarchy folder, project node / process tag library (hierarchy folder in 

the master data library), or the process tag type. 
2. Select the menu command Options > Models > Import... 

or Options > Process Tags > Import.... 
The wizard searches for the models/process tag types and corresponding import files (in 
all hierarchy subfolders as well), and lists them. The import function will include all listed 
import files. 

3. If you do not want to import certain files, you can select them and remove them from the 
list with the "Remove" button.  
By clicking "Other File...", you can search for a different import file and select it instead of 
the other file. 

4. Click "Continue" and then "Finish". 
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Result 
The actual import process starts. Depending on the setting of the "Only show errors and 
warnings in log" check box, the complete list of import activities or only the errors that 
occurred are displayed in the log window. 
The log is saved in a log file. The name and path of the file are displayed below the log 
window. You can modify this setting with the "Other File" button.  
In the following figure, both models and their replicas are shown as they appear in the 
SIMATIC Manager. 
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Process Tag Type/Models Import Variants 
● Importing process tag types/models for the first time 

When you import a process tag type or a model for the first time, the process 
tags/replicas are created in the PH according to the entries in the import file and assigned 
parameters. 

● Importing additional process tag types/models 
If you import a process tag type or model again, the I/Os copied during the first import are 
overwritten by the parameters, signals and messages specified in the IEA file (import 
changes), and those that do not yet exist are created. 

● Deleting replicas/process tags during import 
You can decide whether existing replicas of a model or process tags of process tag type 
are deleted or overwritten during import. Using the import mode "delete" (in the 
"ImportMode" column of the import file), you can delete the replica/process tag. 
Thereafter a message indicates whether the deletion was successful. 

 

 
 

Note 
When you import, all the rows with the "delete" keyword are processed first and the 
subjects deleted. Only then are new objects created. 
If you have already created interconnections to the replicas, these will be lost. 

 

● Re-importing a process tag type/model  
If you perform an import without modifying the model or the process tag type, the I/Os 
copied during the previous import are overwritten by the parameters, signals, and 
messages specified in the IEA file (import changes). 

Reassigning CFC Charts to the Process Tag Type (Adopting) 
If you have CFC charts in your projects that are no longer or not yet process tags (for 
example, because the assignment to the process tags type was canceled) but have the 
conditions for process tags, you can assign these charts to the process tags type as process 
tags. 
You can find information about this in the section "How to Adopt Process Tags (Page 527)". 
The same principles apply to adopting models. 
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9.2.3.6 What happens during export? 

Explanation of the Export Procedure - Using the Example "Model" 
Process tags and models are exported in the same way. 
Once you have created replicas of the models by importing or copying in the SIMATIC 
Manager and, for example, have edited various values of the parameters and signals during 
test and startup, you can export the current data in the same form as they were imported. If 
you start the export function for a model or a replica directly, the following steps are 
executed automatically: 
1. Identifying all the replicas of this model 

A data row is created in the export file for each replica found. 
2. The identifiers LID, FID and the chart names are entered in the export file. 
3. The parameter descriptions and interconnection descriptions (for each model found) are 

written to the corresponding cells of the file. 
In the case of interconnections with shared addresses, interconnection descriptions are 
identified and written in the corresponding cells of the file on the basis of the 
interconnection names (symbol names) in the symbol tables. 

4. The blocks messages are identified and written in the corresponding cells of the file. 
The export files appear together with the located models in the list if you have selected a 
hierarchy folder that contains several models. If required, you can still edit the list. Finally, 
the export starts (as described above) for all models in the list. 

Error Messages in the Export Log 
You will see error messages in the export log if I/O points are missing or if there are too 
many in the replica. 



 Adopting the Data from the Plant Engineering 
 9.2 Import/export of process tags/models 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 643 

9.2.3.7 How to Export Process Tag Types and Models 

Options 
You can export data for models or process tags by using the assistant. The following options 
are available: 
● Individually select a model/process tag type to export it by itself. 
● You can select an upper level hierarchy folder or the project node in order to export all 

lower level models (replicas) or process tags. 
This results in an export file that contains a line for each located replica of a model or for 
each process tag of a process tag type. 
The structure of the export file corresponds to that of the import file. 

Procedure 
1. Select the desired hierarchy folder, project node / process tag library (hierarchy folder in 

the master data library), or the process tag type. 
 

 
 

Note 
After selecting a replica you are forwarded to the corresponding model in the master data 
library after the prompt. 

 

2. Select the menu command Options > Models > Export... or  
Options > Process Tags > Export.... 
The wizard searches for the models/process tags and lists them. 

3. In the next step assign the export files to the displayed models/process tags or modify an 
existing assignment.  
The names of the assigned files can be changed by clicking "Other file..." to select 
another file or to enter a new file name. 

4. In the final step of the dialog box you can select the log file or activate/deactivate the filter 
in order to log only error messages and the finished message. 

5. Click "Finish". 

Result 
The export procedure starts. Any existing export files are overwritten during the export 
procedure. 

Repeated export 
By exporting the model(s)/process tags more than once, you can create several export files 
(copies). During the export procedure you must modify the file name of the assigned export 
file. If you do not change the file names the export file with the same name is overwritten. 
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9.2.3.8 Restrictions with the IEA 

Restrictions Placed on Modifications 
The following modifications may not be made to charts/chart I/Os with IEA attributes in CFC 
since these would prevent import or export. 
● Renaming nested charts (charts with chart I/Os included in the chart of a model). 
● Deleting nested charts. 
● Changing the data type of a chart I/O 
● Modifying the relative order of chart I/Os with IEA flags (or I/O points of a process tag), for 

example, by inserting or deleting chart I/Os (without IEA flag). 
● If the model contains nested hierarchy folders, the names of the nested folders must not 

be modified. 
Carrying out these modifications will generate an error in the error log. 



 Adopting the Data from the Plant Engineering 
 9.2 Import/export of process tags/models 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 645 

9.2.4 Creating/Editing Import Files with the IEA File Editor 

9.2.4.1 Data of the IEA File in the ES 

Introduction 
The following sections explain how to create and edit the import/export files (IEA file) with the 
IEA file editor. The description includes the following topics: 
● Creating/Editing Import Files with the IEA File Editor (Page 646) 
● Exchanging Data with Excel/Access (Page 648) 
● Structure of the IEA File (Page 650) 

IEA File in the Engineering System  
The following figure shows an example of the relationships between the objects of the 
project and the data of the import file. 
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9.2.4.2 Creating/Editing Import Files with the IEA File Editor 

IEA File Editor 
The Import/Export Assistant (IEA) works with import/export files in a fixed format. A plant 
planning tool such as SIGRAPH EMR supports this format. The Import/Export Assistant 
installs an IEA file editor to allow for you to create and edit import files without difficulty and 
without the help of a plant planning tool. Using the IEA file editor to edit export and import 
files will ensure that you follow the rules for configuring export and import files. 
The IEA Editor "s7jieaEx.exe" is a standalone application that can also be utilized outside of 
the PCS 7 installation. It can be copied and made available to plant planners.  

 

Editor Application Example "Process Tag"/"Model" 
The IEA File Editor is intended for the following situations: 
● You have created a process tag type/model and created the import file with the IEA. You 

want to create replicas of the model or process tags by using this import file. The number 
of rows in the import file must be increased according to the number of replicas/process 
tags you want to create (for example, by copying and editing). 

● You have created a process tag type/model and created the import file with the IEA. You 
want to change this model, for example, by including further I/Os and need to extend the 
import file by adding these columns. 

● You do not have a tool for creating an import file and want to use the IEA File Editor as a 
planning tool to structure the columns, column groups and rows of the import file and the 
corresponding values. 

● You want to compare an import file with an export file (or vice versa). By opening two 
windows and arranging them in the IEA File Editor window, you will have no difficulty in 
making the required comparison. 
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Appearance of the IEA File Editor 
The IEA Editor is displayed as a table with columns and column titles. Certain columns are 
combined to form column groups, for example, column group for the chart with the words of 
the columns: "ChName" and "ChComment". 
The name of the column groups can be changed as it coincides with the column title of the 
import file. Columns within a column group can be deleted if you only want to use a limited 
number of the import options. If you remove all the columns of a column group, this I/O point 
is lost; in other words, the IEA file will no longer match the model. 
The row headers contain the number of the row. Marking a row header will select the entire 
row (for example, for copying). 
The IEA File Editor also provides all the standard editor functions (copy, paste, save etc.).  
To allow you to insert column groups, all the column group types (general, chart, parameter, 
signal, message) are defined in a submenu and are also available as buttons in the toolbar. 
You can also add new columns to the column groups "General", "Chart", "Parameter", 
"Signal" and "Messages". Only those column titles that have not been used in this column 
group are offered in the extension dialog box. 
You can select all the possible functions with the menu commands in the menu bar or the 
buttons in the toolbar. 
Otherwise, the structure of the editor corresponds to the structure of the import/export file 
(IEA file). 

Starting the IEA file editor  
1. Start the IEA file editor. 

The IEA editor opens. 
2. Open an IEA file. 

Working in the Editor Table 
With the IEA file editor, you work in the same way as with other Windows applications (for 
example, MS Excel).  
The following functions are available: 
● Use the arrow keys and the <Tab> key to navigate within the file. 
● Use the <Return> key to complete the entry and move to the next row. 
● You can select entire columns and rows. 
● You can change or optimize the width of the column. 
● The cut, copy, and paste functions can be used to insert cell contents from the table via 

the clipboard into selected cells one or more times. 
● You can use the Find/Replace functions. 

Additional information 
● Online help for the PH, IEA, PO and IEA file editor 
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9.2.4.3 How to Exchange Data with MS Excel/Access 

Introduction       
The import/export data (IEA file) is available as a text file in CSV format. The CSV format is 
supported by many applications (MS Excel, MS Access, etc.) and is therefore suitable as a 
general data interface between any planning tool and the ES. In IEA these files are expected 
to have the *.iea extension. You may have to change the extension.  
CSV (Comma Separated Value) is an ASCII text format used for storing data configured in 
the form of a table. The character separating the cells depends on the Regional and 
Language Options in the operating system (German: semicolon); a new row is created by 
pressing Enter.  
You can create and edit a CSV file with spread sheet programs (for example, MS Excel) or 
as an export file from a database (dBase, Access, etc.). You can also conveniently edit the 
file (with the extension *.iea) using the IEA File Editor. 

Editing Files with MS Excel 
1. Change the exception of the file from *.IEA to *.CSV. 
2. Start MS Excel. 
3. Select the File > Open... menu command and open the CSV file. 

The file opens; the content of the file is shown precisely as it appears in the IEA file 
editor. 

 

 
 

Note 
If you open a CSV file by double-clicking it, the content of the file is not shown in table 
form in Excel. 
All cells should be formatted as "Text", otherwise the displayed information may be 
incorrect. Example: The numeric string "1.23" could be displayed as "23 Jan.". 

 

4. Edit the file and save it. 
5. Change the extension of the file from *.csv to *.iea. 
6. Carry out any additional changes if necessary in the IEA file editor and/or import the file 

with IEA. 
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Exchanging Data with Excel 
You can edit the file (with the extension *.iea) conveniently using the IEA File Editor. The 
editor also offers the cut, copy, and paste functions as well as find and replace. Use Excel if 
you require more advanced functions.  
Use the following procedure: 
1. Start the IEA file editor and open the required file. 
2. Start Excel and create a new file. 
3. Select the desired area of the table in the IEA file editor and copy it. 
4. Insert the copied area into the empty MS Excel file. 
5. Edit the data in MS Excel. 
6. Select and copy the data in MS Excel. 
7. Paste the copied data in the IEA file editor to the IEA file. 
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9.2.4.4 Structure of the IEA File 

Import/Export File (IEA File)     
You can edit the import file (with the extension *.iea) conveniently using the IEA File Editor. 
The import file is a CSV file that you can create and edit with spreadsheet programs (MS 
Excel) or as an export file from a database (dBase, Access, etc.).  
To edit with a table or database program, you must be familiar with the file structure 
described below.  

File Structure 
There must be a column group for each I/O and message. 

 
Row Meaning 
 0 There can be a comment line before the first header (starting with "#" or "//") containing both the version number 

and the date created. 
 1 The first header row contains the titles of the column groups. 
 2 The second header line contains the column identifiers. This information tells the Import/Export Assistant how to 

interpret the columns. These identifiers are the same in all language versions. 
 3 The third header row contains the keywords for the relevant flagged I/O. This decides which data will be 

imported for this I/O. Not every keyword must be entered; only the first one is mandatory. 
 4-x The next rows contain the data. There is one row for replica or process tag. During import, each row generates 

a replica of the model in the specified hierarchy folder. With process tags, the process tag is created in the 
hierarchy folder. 
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Example: Measured-value acquisitions 
In the following example, the IEA file is shown as a table to make it easier to read and the 
text in the three header rows is shown in "bold" print. The quotation marks are also missing 
at the start and end of each column entry.  
You can only edit the area with the data and not the header lines. 
Since this is clean ASCII text, you may not format an original file (for example, insert spaces 
or tabs or use bold print).  
The IEA file can be displayed and edited as a table formatted with the IEA File Editor.  

 
Project; Hierarchy; FID; LID; Chart; High limit; Measured value Alarm high 
Prj; H\; F; O.; C|; P|; S|; M| 
; ; ; ; ChName| 

ChComment; 
Value|  
ConComment| 
S7_shortcut| 
S7_unit; 

SymbolName| 
SymbolComment| 
ConComment| 
S7_shortcut| 
S7_unit; 

Event| 

Pro_A V12\RA1\P01; ; ; P01|Internal 
pressure; 

90|Com.|  
OG|mbar; 

Tpress|ComS.| 
ComA.|PK|mbar; 

Int. pressure 
too high 

Pro_A V12\RA1\P02; ; ; P02|External 
pressure; 

8.5|Com.| 
OG|bar; 

Apress|ComS.| 
ComA.|PK|bar; 

Ext. pressure 
too high 

Pro_A V12\RA2\T01; ; ; T01|Temp contr 90|com.| 
OG|degC; 

Mtemp.|ComS.|  
ComA.|MT|degC; 

Temperature 
exceeded 

Pro_B V12\RA2\T02; Delete      

Explanation of the Column Groups 
● Project 

The "Project" column group contains the names of the target project in the multiproject 
where the replicas or process tags are stored. 

● Hierarchy 
The "Hierarchy" column group contains the complete hierarchy path even if individual 
hierarchy folders do not contribute to the name. 
During import, the hierarchy folders (replicas of the models or process tags) are created 
from this and the content of the model/process tag (charts etc.) is copied into this new 
hierarchy folder if it does not yet exist. During export, all existing replicas of the model are 
entered. 
With process tags, the process tags are created from the process tag type and created in 
the hierarchy folder. There can be several process tags in the same hierarchy folder. 
The hierarchy levels are separated by a "\", and the IEA is informed of this in the second 
row. Here, "\" must be used as the separator. 
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● FID and LID 
The "FID" and "LID" column groups belong to the "general column groups" and are 
optional.  
FID and LID are entered in the text boxes of all top charts of the replicas. 
The "FID" column group contains the function identifier.  
The "FID" column group contains the location identifier. 
The data of the FIDs and LIDs are missing in the example. The ";" must nevertheless be 
included so that the number of column groups remains the same. The text is entered in 
the text box in the "Part 3" tab, "Names:" or "Designation block according to place:" . 

● Chart 
The "Chart" column group is optional for models, but if used it always follows the 
"Hierarchy" column group, or, if they exist, after the general column groups. Any name 
can be used for the title. The column group contains the name and comment of the 
CFC/SFC chart. The name of the chart in the replica of the model is changed with the 
keyword "ChName". The chart comment is changed with the keyword "ChComment". 

● Further column groups 
The following column groups identify the I/Os to be imported. Each of these connections 
is described by a text string (in quotation marks) that is separated from the next 
connection using a separator (list separator specified by the Windows regional settings) . 
The individual data within the text string are separated by a "|" (pipe character). 

● Extend column groups 
Further columns can be displayed by using the Extend Column Groups... menu 
command, depending on the selected column. 

Additional information 
● Online help for PH, IEA and PO 
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9.2.5 Import/Export of the Hardware Configuration 

9.2.5.1 Introduction to Import/Export of the Hardware Configuration 

Introduction 
You can work on station configurations not only within the entire project (for example, saving 
or opening), but also independent of the project by exporting it to a text file (ASCII file, CFG 
file), editing it, and then importing it again. In this way the symbolic names of the inputs and 
outputs are also exported or imported (as long as you have not changed the default setting). 

Application 
You can use the import/export of the hardware configuration to do the following: 
● To import hardware planning tool data 
● To distribute data using electronic media (for example, e-mail) 
● To print the export file using a word processor or to continue processing the export file for 

the purpose of documentation 
Another important application of importing a station configuration exists in a plant when 
identical or almost identical configurations in different parts of the plant occur. Using the 
import function, you can create the required plant configuration quickly. 

What is Exported/Imported?  
When you configure the hardware, the data necessary for the configuration and parameter 
assignment of modules are exported/imported.  
The following data are not collected:  
● Data managed by other applications (for example, programs, connections, shared data) 
● A selected CPU password 
● Cross-station data (for example, the linking of intelligent DP slaves or configurations for 

direct data communication) 
 

 
 

Note 
If your configuration contains modules from older option packages, it is possible that not 
all the data of the module will be included with the "Export Station" function. In this case, 
check whether the module data are complete following the import. 

 

9.2.5.2 How to Export a Station Configuration 

Procedure     
1. Select the required station in the component view. 
2. Select the menu command Edit > Open Object. 

The station configuration opens in HW Config. 
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3. Select the menu command Station > Export....  
The "Export" dialog box opens. 

4. Enter the path and name of the export file, format and other options. 
You can find information about this in the paragraph on "Export Settings". 

5. Click "OK". 

Result 
The station configuration is exported and stored in the selected path in the form of a CFG 
file.  

Export Settings 
● Legible or compact format 

– In the legible format the parameter identifiers are entered in the export file as strings. 
– In the compact format the identifiers are entered in the export file in hexadecimal 

format. 
 

NOTICE  
 

When you export the station configuration to read it in using other PCS 7 versions, 
select the "Compact" option. 

 

● Name of the file (*.cfg) (open to choice) 
● With or without symbols 

You can determine whether symbols you specified for the inputs and outputs should also 
be included in the export file. 

● With or without subnets 
You can decide whether or not subnets are exported. If you select this option, the 
network data for the interfaces of the station is also exported (assignment to subnets, 
subnet parameters). 

● Default values for module parameters can be omitted as an option (PCS 7 knows the 
default values and supplies them internally when you import). 

 

CAUTION  
 

If you export a station configuration with symbols, you can no longer import the file with 
earlier PCS 7 versions. 

 

Additional information 
● Online Help for HW Config 
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9.2.5.3 Structure and Content of the CFG File 

CFG File 
The procedure for exporting the station configuration described in the section "How to Export 
a Station Configuration (Page 653)" results in an ASCII file, which you can view and edit in a 
text editor such as "Notepad" or "WordPad". 
This file (CFG file) contains all the data of the hardware configuration including the 
parameter assignments from the dialog boxes of the HW Config graphic user interface and 
the corresponding symbols (if these were exported).  
Based on the introductory text in the individual fields, the sections are easy to identify.  
You will find a section from a possible CFG file structure in the following example. 

Example 
 
Section of the CFG File Information/Object Properties for 
FILE_VERSION "3.0" 
#STEP7_VERSION V5.4 Addon 
#CREATED "Thursday, 10 April 2008 17:21:09" 

File 

STATION S7400 , "SIMATIC 400(1)" 
BEGIN  
 REPORT_SYSTEM_ERRORS "0" 
 OBJECT_REMOVEABLE "1" 
 POS_X "0" 
 POS_Y "0" 
 SIZE_X "0" 
 SIZE_Y "0" 
 OBJECT_COPYABLE "1" 
 CREATOR "" 
 COMMENT "" 
END 

Station 

SUBNET INDUSTRIAL_ETHERNET , "Ethernet(1)" 
BEGIN  
 COMMENT "" 
 NET_ID_2 "00 31 00 00 00 13" 
 NET_ID "003100000013" 
END 

Subnet (Ethernet) 
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Section of the CFG File Information/Object Properties for 
SUBNET MPI , "MPI(1)" 
BEGIN  
 MPI_HSA "31" 
 MPI_BAUDRATE "187.5_KBPS" 
 MPI_GAP "5" 
 MPI_READY "20" 
 MPI_RETRIES "2" 
 MPI_IDLE1 "60" 
 MPI_IDLE2 "400" 
 MPI_TQUI "0" 
 MPI_TSL "415" 
 MPI_TTR "9984" 
 COMMENT "" 
 NET_ID_2 "00 31 00 00 00 01" 
 NET_ID "003100000001" 
END 

Subnet (MPI) 

SUBNET PROFIBUS , "PROFIBUS(1)" 
BEGIN  
 PROFIBUS_HSA "126" 
PROFIBUS_BAUDRATE "1.5_MBPS" 
 PROFIBUS_RETRIES "1" 
 PROFIBUS_GAP "10" 
 PROFIBUS_READY "11" 
 PROFILE_SELECTION "DP" 
 NETCONFIG_ENABLE "0" 
 NETCONFIG_ACTIVE "1" 
 NETCONFIG_PASSIVE "2" 
: 
: 
: 

Subnet (PROFIBUS) 

:  
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Section of the CFG File Information/Object Properties for 
RACK 0, SLOT 7, "6ES7 421-1BL01-0AA0", 
"DI32xDC 24V" 
BEGIN  
 IPACTIVE "0" 
 CPU_NO "1" 
 ALARM_OB_NO "40" 
 OBJECT_REMOVEABLE "1" 
 POS_X "0" 
 POS_Y "0" 
 REDUNDANCY 
 BEGIN 
 END 
 SIZE_X "0" 
 MODULE_ADD_FLAGS "0" 
 SIZE_Y "0" 
 OBJECT_COPYABLE "1" 
 CREATOR "" 
 COMMENT "" 
LOCAL_IN_ADDRESSES  
 ADDRESS 0, 0, 4, 0, 0, 0 
SYMBOL I , 0, "E0.0", "" 
SYMBOL I , 1, "E0.1", "" 
SYMBOL I , 2, "E0.2", "" 
SYMBOL I , 3, "E0.3", "" 
: 
: 
: 
SYMBOL I , 30, "E3.6", "" 
SYMBOL I , 31, "E3.7", "" 
END 

Digital input including symbols 

:  
: Modules  

(PS, CPU, CP, DI, DO, AI, AO etc.) 
:  
:  

Additional information 
● Online Help for HW Config 
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9.2.5.4 Expanding CFG Files 

Expansion 
CFG files should always be created based on an existing exported station configuration. You 
can find information about this in the section "How to Export a Station Configuration 
(Page 653)". 
The CFG file should already contain all the objects (passages of the file) required for station 
expansion. This allows you to make the required expansions simply by copying and pasting. 
Keep the configuration consistent, the copied objects must be adapted accordingly (for 
example, rack assignment, addresses, symbols).  
For an explanation of the structure and content of the CFG file, refer to the section "Structure 
and Content of the CFG File (Page 655)". 
With this as a basis, you can edit the individual sections of the file to suit your purposes 
(copy, paste, edit). 

 

NOTICE  
You should be familiar with the content of the sections of the CFG file in detail since editing 
is not supported by the system. Errors will only be detected during the subsequent import. 
This can lead to inconsistent data that you would then have to re-edit in HW Config. 
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Procedure - Example 
You want to add a further digital input module to an ET 200M and change the existing slot 
assignments.  
1. Identify the area you want to change. 
 
Section of the CFG File Information/Object Properties for 
DPSUBSYSTEM 1, DPADRESS 7, SLOT 6, 
"6ES7 321-FH00-0AA0", "DI16xAC120/230V" 
BEGIN  
 PROFIBUSADDRESS "0" 
 CPU_NO "1" 
 ALARM_OB_NO "40" 
 OBJECT_REMOVEABLE "1" 
 POS_X "0" 
 POS_Y "0" 
 REDUNDANCY 
 BEGIN 
 END 
 SIZE_X "0" 
 SIZE_Y "0" 
 OBJECT_COPYABLE "1" 
 CREATOR "" 
 COMMENT "" 
LOCAL_IN_ADDRESSES  
 ADDRESS 0, 0, 2, 0, 1, 0 
SYMBOL I , 0, "E0.0", "" 
SYMBOL I , 1, "E0.1", "" 
SYMBOL I , 2, "E0.2", "" 
SYMBOL I , 3, "E0.3", "" 
: 
: 
: 
SYMBOL I , 30, "E3.6", "" 
SYMBOL I , 31, "E3.7", "" 
END 

Digital input including symbols 

1. Select and copy the required area. 
2. Paste the copied area at the required location. 
3. Adapt the inserted area (DPADRESS, SLOT, SYMBOL, etc.) 
4. If necessary, adapt the modules already configured. 
5. Follow the same procedure if you want to add additional components. 
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6. Save the file. 
7. Start HW Config. 
8. Select the menu command Station > Import.... 
9. Select the corresponding CFG file and click "Open". 

During import, queries appear where necessary, asking whether existing data has to be 
overwritten. 
The changed station configuration is imported into the opened station. A log is created 
and error messages are issued if necessary. 

10. Click in the dialog box used for displaying the error messages on the "Save" button in 
order to save the error messages in a text file. Select the path for this purpose and enter 
the name of the text file. 

11. Click "Close". 

Additional information 
● Online help for HW Config 
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9.2.5.5 How to Import a Station Configuration (First Import of an Entire Station) 

Procedure 
Recommendation: Do not import a station configuration that was previously exported from 
the same project. In this case, PCS 7 cannot handle the network assignment. Select a 
different or new project for the import. Use the following procedure: 
1. Select the HW Config menu command Station > Import... while an empty station 

configuration is open.  
If no station configuration is open, a dialog box opens in which you select a project. In this 
case, navigate to the project into which you want to import the station configuration. 

2. Use the open dialog box to navigate to the CFG file you want to import. 
3. Click "OK".  

The station configuration is imported. During import, the imported file is checked for errors 
and conflicts and messages are displayed. 

 

 
 

Note 
If you also want to import DP master systems during import, these must not have the 
same names as DP master systems that already exist in the project. 

 

Additional information 
● Online help for HW Config 
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9.2.5.6 How to Import an Expanded Import File (Extra Remote I/O, Field Device, Module) 

Importing an Existing Station 
A station can be imported into an open station configuration. During the import PCS 7 asks 
whether you want modules/interface modules that have already been configured to be 
overwritten. For each component, you can decide whether you want to retain it or overwrite 
it.  
If a component is overwritten, all the settings (parameters) contained in the import file are 
applied. Settings that are not included in the import file are retained in the station 
configuration.  

Procedure - Inserting a digital input module 
You want to add a further digital input module and change the existing slot assignments. 
Proceed as follows: 
1. Open the required CFG file with an editor (for example, WordPad). 
2. Identify the area that describes the digital input module and then copy it. 
3. Paste the copied passage directly after the digital input module you copied. 
4. Adapt the slot number, address, symbols and any other relevant data and save the file. 
5. Open the station where the changes in HW Config were made. 
6. Select the menu command Station > Import... and import the required CFG file. 

A dialog box opens in which you can select whether you wish to overwrite the entire 
configuration ("All" button) or only the parts which have changed ("Yes" and "No" 
buttons). 
An error log is also created with the import. 

7. Save the imported data. 
8. Check the data consistency with the menu command Station > Check Consistency and 

eliminate inconsistencies, if necessary. 

Additional information 
● Online help for HW Config 
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9.2.5.7 How to Update an Imported Station Configuration (Change Attributes, Signal Assignments 
of Modules) 

Importing an Existing Station 
If you have already modified configured modules/interface modules in the CFG file, you can 
update an existing station configuration by importing into the station. 
During the import PCS 7 asks whether you want modules/interface modules that have 
already been configured to be overwritten. For each component, you can decide whether 
you want to retain it or overwrite it.  
If a component is overwritten, all the settings (parameters) contained in the import file are 
applied. Settings that are not included in the import file are retained in the station 
configuration.  

Procedure - Changing Parameters 
You have only changed the settings (parameters) of an existing station configuration. 
1. With the station configuration open, select the menu command Station > Import... and 

import the required CFG file. 
A dialog box opens in which you can select whether you wish to overwrite the entire 
configuration ("All" button) or only the parts which have changed ("Yes" and "No" 
buttons). 
An error log is also created with the import. 

 

 
 

Note 
The import process is much quicker if only the changed parts are overwritten. 

 

2. Save the error log if one is generated. You can then eliminate any errors based on the 
log. 

3. KClick "Yes", in order to store the imported data.  
Selecting "No" will terminate the import process. The station configuration then remains 
unchanged. 

Additional information 
● Online help for HW Config 
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9.2.5.8 Export for Synchronization with Higher-Level Planning Tools 

Synchronization with Higher-Level Planning Tools 
The station configuration has been created in accordance with the plant engineering plans 
and, where necessary, has been supplemented and/or corrected in the detailed hardware 
configuration. Using the export file, the plant engineering data can be updated to reflect 
these changes. 
● The section "How to Export a Station Configuration (Page 653)" describes how to export 

a configuration station. 
● The structure of CFG files is described in the section "Structure and Contents of the CFG 

File (Page 655)". 
Prepare the contents of the CFG file as required for importing into your planning tool (plant 
engineering) and then execute the import procedure. 
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Compiling and downloading 10
10.1 Introduction to Compiling and Downloading 

Overview 
The functions for compiling and downloading are available in the following editors: 
● HW Config 

Compiling and downloading the hardware configuration  
You can find further information about this in the section "Hardware Configuration". 

● NetPro 
Compiling and downloading the network and connection configuration from the hardware 
configuration  
You can find further information about this in the section "Creating Network Connections". 

● CFC 
Compiling and downloading the CFC configuration  
You can find information about this in the section "Creating CFC Charts". 

● SFC 
Compiling and downloading the SFC configuration  
You can find information about this in the section "Creating SFC Charts". 

● SIMATIC Manager 
Compiling and downloading individual or all objects in a multiproject. 
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Actions after Merging Projects Edited on Distributed Stations 
The following tasks must be performed during multiproject engineering after the distributed 
projects have been merged: 
● Compiling the OS server with assigned AS components 
● Only when downloading the first time: Downloading the OS server data to the OS clients 
● Download to all target systems (for example, AS, OS server, OS clients, BATCH server, 

BATCH clients, Route Control server, Route Control clients) 
 

 
 

Note 
OS server data must only be downloaded once after the initial download to the OS 
clients. Each time an OS client is restarted in process mode or when downloading 
changes to the OS server, the OS server data is automatically updated. 
Note on ensuring that the OS server data is up-to-date: the server data includes the 
computer name of the engineering station from which the data was first downloaded. If 
you change engineering stations or change the storage location of the project/multiproject 
on the engineering station, make sure that the OS is recompiled and remember that the 
server data must be downloaded once from the new computer (computer name) or 
storage location. 
The compiling and downloading of the OS and the updating of the OS server data on the 
OS clients is described in detail in the configuration manual Process Control System 
PCS 7; Operator Station and is therefore not dealt with in detail here. 

 

Initially you only need to compile and download the AS data in order to test the program or 
the CFC and SFC configuration.  

Overview 
The sections about compiling and downloading for PCS 7 deal with the following topics: 
● Requirements for Compiling and Downloading (Page 667) 
● Downloading to all PLCs (Page 668) 
● Options for compiling and downloading (Page 673) 
● How to Document Changes in the ES Log" (Page 676) 
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10.2 Requirements for Compiling and Downloading 

Downloading the Hardware Configuration and Network Configuration 
To be able to use the "Compile and download objects..." function for the automation 
systems, the hardware configuration and the network configuration of every SIMATIC 400 
station must first be downloaded. 

One-time Download of the OS Server Data 
These data must be updated only once on the OS clients after downloading the OS server 
data to the OS server. Each time an OS client is restarted in process mode or when 
downloading changes to the OS server, the OS server data is automatically updated. 

Downloading OS Server Data 
1. Select the OS client in the SIMATIC Manager. 
2. Select the Options > OS > Assign OS Server... menu command. 

The OS server data is uploaded to the OS client. The OS client then knows the assigned 
OS servers. 

Additional information 
● Configuration manual Process Control System PCS 7; Operator Station 
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10.3 How to Download to all CPUs 

Introduction       
Use the "Compile and Download Objects" central function to download an entire 
project/multiproject. PCS 7 provides the "Compile and Download Objects" dialog for this 
task. This dialog box displays the objects exactly the same way as in the SIMATIC Manager 
component view. All of the automation systems, operator stations, and SIMATIC PC stations 
that you created in SIMATIC Manager are displayed.  
Use the "Compile and Download Objects" dialog box , to centrally carry out all of the 
required settings for compiling and downloading. In addition this is where you can specify, 
whether you want to compile and download the entire project or, for example, only individual 
operator stations.  

 

 Note 
If you select the SIMATIC 400 station in the SIMATIC Manager, followed by the menu 
commands PLC > Download or PLC > Compile and Download Objects... ("HW Config" 
object activated for compiling and downloading), the delta downloading capability will be lost.
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Compile and Download Objects" Dialog Box 
All download relevant objects including their status and operating state can be found in the 
selection table of the dialog box.  
The "Compile and Download Objects" dialog box is used to prepare the selected objects of 
your project or multiproject for downloading to the target system and then to download them 
to the target system. The dialog box can be applied to objects in a station, project or 
multiproject.  
PCS 7 coordinates compiling and downloading, i.e. you do not need to pay attention to the 
order of the tasks.  

 

Requirements 
● The PC stations and automation systems are configured and downloaded from NetPro 

(the connections are also downloaded) 
● The CFC and SFC configuration is completed. 
● You have selected one of the following objects in the SIMATIC Manager: 

– Multiproject 
– Project 
– Station 
– S7 program without station assignment 
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Rules 
● A complete automation system download is only possible when the CPU is in the STOP 

operating mode. 
● Downloading the entire program to an OS is only possible when the OS servers are shut 

down (are not in process mode). 
● Downloading changes to an OS is possible only if the OS is in process mode. 
● When you have made changes during commissioning, we recommend you synchronize 

the projects of the multiproject before downloading to the target system. To do this, select 
the menu command File > Multiproject > Synchronize Projects.... You can the use the 
central "Compile and Download Objects" function to send the changes to the target 
system. 

Procedure 
 

 Note 
You should also read the information in the section "Options for Compiling and Downloading 
(Page 673)". 

 

1. Select the object that you want to compile or compile and download in the SIMATIC 
Manager. 

2. Select the menu command PLC > Compile and Download Objects... in the SIMATIC 
Manager.  
The "Compile and Download Objects" dialog box opens. 

3. Open the tree view and activate the corresponding checkboxes in the "Compile" or 
"Download" columns for all objects that you wish to compile and/or download. 
If you tick both checkboxes for an object, the object is compiled and then downloaded.  
Activate the corresponding checkbox on the "Connections" object if you want to compile 
the and download connections. 

4. Use the "Status" and "Operating Mode" buttons to check the statuses (changed, 
compiled, downloaded, etc.) and modes of your objects (RUN, activated, etc.), so that 
you can make the correct settings for compiling and downloading. 

5. Select the object you want to compile and/or download and click "Edit".  
Enter the settings for compiling and/or downloading (for example, compiling and 
downloading the entire program or only changes). 

 

 
 

Note 
When you have completed the settings for compiling an operator station, it takes some 
time for the compiling settings to be saved and for the download dialog box to be opened! 
The target path of the OS should already be entered here (but if it is not, enter it). 

 

6. Click "Check. 
This checks the validity of the settings. If settings are not valid, the download is not 
performed. 

7. Perform the required settings for the individual objects. 
Click "Help" in the dialog box for detailed information about the settings. 
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8. Activate the "Compile only" option if you only want to check the blocks and not download 
them to the CPU. 

9. Activate the "Do not load if compilation error is detected" option if you want to prevent 
downloading corrupt blocks to the CPU. 

10. Click "Start". 
The compilation/download operation is started. 

11. Follow the instructions on the screen. 
12. If you wish to see a log once the compiling/downloading is completed, click the following 

buttons in the "Open Log" area: 
– "Single Object" - The detailed compilation and download log of the selected AS or the 

compilation log of the selected OS is displayed. 
– "All" - The results of all compiling and download actions (without details) are 

displayed. 
 

 
 

Note 
Do not use the "Compile and Download Objects" function for S7 PLCSIM 
downloading. 

 

Reading Back Settings after Changes during Commissioning 
Read the operator control and monitoring settings that were made during the test back into 
the project. 
Parameter settings, for example, controller parameters, must also have the required values 
in the offline program (CFC) as they were set during commissioning. 
In CFC it is possible to execute a read back of the CFC charts which would also trigger the 
automatic compiling of the entire program. You should only read back CFC charts when your 
plant is in a defined safe state. 
After reading back the charts, the changes must be downloaded so that the offline and online 
program match. In the "CPU Comparison" dialog box, check whether the time stamp "Last 
download-relevant change", "Last compilation" and "Compilation of the loaded program" 
agree. 
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Reading Back the AS Parameter Settings  
1. Open the multiproject in the SIMATIC Manager and select your project. 
2. Double-click one of the CFC charts in the changed program. 

The CFC editor opens. 
3. Select the menu command Chart > Read Back.... 
4. Activate the "Program on the CPU" and "OCM-capable parameters" or "Designated 

parameters" check boxes in the "Read Back" dialog box. 
 

 
 

Note 
If the "Marked parameters“ checkbox is activated, only the block I/Os with the "Can be 
read back" attribute (S7_read_back = true) are read back. This setting must first be 
entered at the I/Os of the block type. The attribute cannot be modified in the block 
instances. 

 

5. Click "OK". 
 

 
 

Note 
A complete compiling of the charts is automatically carried out if they are read back. 

 

Additional information 
● Section "Options for Compiling and Downloading (Page 673)" 
● Online help on the "Compile and Download Objects" dialog box 
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10.4 Options for compiling and downloading 

Central Settings for Compiling and Downloading      
In the "Compile and Download Objects" dialog box, make the required settings for compiling 
and downloading separately for each object. In the "Compile" and "Download" columns, 
specify if you want to compile and download the entire project or individual components. 
Compiling the charts generates an executable program that can run on the CPU. The 
consistency of the blocks and interconnections are also checked. 

Options in the "Compile and Download Objects" Dialog Box 
 
Option Description 
Settings for Compilation/Download 
"Edit..." button Opens a dialog in which the compiling and downloading settings can be 

changed for object selected in the "Objects" column. 
"Check" button Checks the compiling and downloading properties of objects selected for 

compilation or download in the "Objects" column. 
This button is not active for block folders. The button is only active if the 
objects support this function.  
The following is checked for a "hardware" object: 
• Are the modules in the STOP mode (not with modules that automatically 

stop and can be started again, for example, CPs)? 
• If password protection has been configured and a password has been 

entered: the entry takes place via the "Edit" button with the selected block 
folder or CPU. 

Update 
"Status" button Updates the current status of the objects in the selection table. 

With the "Hardware" object, "undefined" is displayed after a status update if 
the station contains a cross-station PROFIBUS subnet. In this case, the editing 
of the other station that is also connected to this PROFIBUS subnet can have 
effects on the currently displayed station. 

"Operating Mode" button Updates modified operating modes in the display. 
"Status on opening" check box When the check box is deactivated (default), the "Compile and Download 

Objects" dialog box opens immediately after the menu command CPU > 
Compile and Download Objects... is selected. undefined" is however entered 
everywhere in the "Status" column. To update for the first time, click the 
"Status" button.  
When the check box is activated, expect a long delay before the dialog box 
opens regardless of the number of objects.  
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Option Description 
View log 
"Single Object" button Shows the log of the most recent compilation or download process for the 

object selected in the "Objects" column 
"All..." button Opens the "Open Log" dialog box where you can select the type of full log.  

This may be the log of the most recent compilation or of the most recent 
download process or the last "Settings for Compilation/Download" check log 
that was generated by pressing the "Test" button.  
The full log lists all messages for the individual objects. 

Select Objects 
"Select All" and  
"Deselect All" buttons 

With this button, you can select or deselect all objects in the "Compile" or 
"Download" columns.  
If the "Compile Only" check box is selected, the button only affects the 
"Compile" column. If the "Compile Only" check box is deactivated, the "Select 
All " and "Deselect All" buttons select or deselect all objects in both columns. 

"Compile only" check box Activate this check box if you only want to compile the selected objects. The 
objects will not be downloaded to the CPU and the "Download" column is 
hidden. 

"Do not load if compilation error is 
detected" check box 

If the check box is activated, a compilation error (for example, a time stamp 
conflict) means that no object is downloaded.  
If the check box is not activated, all objects are downloaded that were 
compiled without error. Objects that caused an error during compilation are not 
downloaded.  

Settings for downloading HW objects 
 

 Note 
A hardware configuration can only be downloaded when the CPU is in STOP mode. 

 

The download procedure will not be interrupted by acknowledgment prompts when the 
following settings are made for downloading multiple HW objects.  
When several CPUs are installed in a station, the settings must be made for every CPU. 
● CPU password 

Enter a password here if the CPU is password-protected. If you do not enter a password, 
the download process will be interrupted later by a prompt for the password. 

Special considerations when downloading HW objects for fault-tolerant CPUs 
● Stopping the H system before downloading 

The identical hardware configuration is in both CPUs following the download. 
● Downloading to the S7 400H-CPU 

Before beginning to download, you must ensure that the selected CPU or CPUs is/are 
actually in STOP mode. If they are not, downloading is canceled with an error message. 
This prevents inadvertent stopping of the entire H system.  
If there is only one CPU activated for downloading and only this CPU is in the STOP 
mode, you can start this CPU with "Switchover with modified configuration" following the 
download. This avoids stopping the H system. 
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Special Considerations in Compiling and Downloading Connections 
If you select the "Connections" object for a module for compiling, the corresponding 
"Connections" objects of the connection partner will be automatically selected. In this way, 
the generated configuration data (system data blocks) always remains consistent.  
If you select the "Connections" object for a module for downloading, the corresponding 
"Compile" check box will be automatically selected. The "Compile" and "Download" check 
boxes for all connection partners are selected.  
If you only select "Connections" type objects, you can also download the connections during 
the RUN-P operating state of the CPU.  

Additional information 
● Online help for "Compile and Download Objects" dialog box (Station properties) 
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10.5 How to Document Changes in the ES Log" 

Introduction          
The ES log enables you to document the user, time, changes made, the affected CPU and 
the reason for the changes. If you activate the option "ES log active", the actions during 
downloading and the current time stamps are logged in addition to the protected actions in 
CFC/SFC. 

Requirements 
● The SIMATIC Logon Service is installed. 
● The change log is activated. 

Activating the ES Log 
You activate the ES log for the currently selected chart folder as follows. 
1. In the component view of the SIMATIC Manager, select the chart folder for which you 

want to activate the ES log. 
2. Select the menu command: Edit > Object Properties... 

The "Chart Folder Properties" dialog box opens. 
3. Switch to the "Advanced" tab. 
4. Activate the "ES log active" check box. 
5. Click "OK". 

Deactivating the ES Log 
If you do not want to log the protected actions, for example during an early phase of the 
configuration, you can switch off the ES log by deactivating the "ES log active" check box in 
the "ES Log Tab."  
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Rules 
● Note that an activated ES log can only be deactivated on the computer on which 

SIMATIC Logon Service is installed.  
Reason: The deactivation and activation tasks themselves must be recorded in the ES 
log. 

● Before the download is performed to each individual CPU with the "Compile and 
Download Objects" function in the SIMATIC Manager, there is a pause in the operation 
brought about by the opening of the ES log if it is activated for the currently selected chart 
folder. 

 

 
 

Note 
If you copy the program or chart folder with an activated ES log to a computer on which 
the SIMATIC Logon Service is not installed, you receive an error message when you 
attempt to download or switch to test mode and the action is not carried out.  
You cannot deactivate the ES log in this situation because there is no "ES log" tab in the 
"Object Properties" dialog box of the chart folder.  

 

Calling the ES Log 
The ES log is opened when a protected action that is to be logged is opened (select the 
chart folder and the menu command Options > Charts > Logs... , "ES Log" tab).  
Protected actions for logging are: 
● Download to PLC (entire program) 
● Download to PLC (changes) 
● Test mode 
Logon is performed in the SIMATIC Logon Service dialog box.  
If a user is already globally logged on, the ES log for this user is opened immediately when a 
protected action is started. The user name can be changed for pending actions - and only for 
pending actions. The setting of the global user remains unchanged.  
When no user is logged on, the SIMATIC Logon Service dialog box opens before the ES log 
opens. 
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Logging 
The following is logged in the "Logs" dialog box in the "ES log" tab: 
● Every action is registered in chronological order (last action in the top line) in a main line 

followed by a line giving the reason and perhaps a log of the action itself (a download, for 
example). 

● For the action "Download entire program", the ES log is deleted from the log but archived 
as a file with a date identifier at the same time. The archiving action and the file name 
used (including the path) are recorded in the log. 

● For the action "Start test mode", all subsequent actions resulting in a change (of value) in 
the CPU are logged. The logging includes the value and how it changed (address, old 
value, new value). 
Specifically, these are: 
– In the CFC 

Assignment of parameters to I/Os  
Activation/deactivation of forcing and force value changes 
Activation/deactivation of runtime groups 

– In the SFC: 
Assignment of parameters to constants in steps 
Assignment of parameters to constants in transitions 
Assignment of parameters to constants in sequencer properties 

Additional information 
● Online help for the dialog boxes "ES log" and "Logs" 
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10.6 How to Document Changes in the Change Log 

Introduction 
The change log enables you to document the user, time, changes made, the affected CPU 
and the reason for the changes.  

Requirement  
● The SIMATIC Logon Service is installed. 
● The access protection is activated. 

Activating the Change Log 
You activate the change log for the currently selected folder as follows. 
1. In the component view of the SIMATIC Manager, select the folder for which you want to 

activate the change log. 
2. Select the menu command: Options > Change Log > Activate. 

The change log for the selected folder is activated. 

Deactivating the Change Log 
You deactivate the change log for the currently selected folder as follows. 
1. In the component view of the SIMATIC Manager, select the folder for which you want to 

deactivate the change log. 
2. Select the menu command: Options > Change Log > Deactivate. 

The change log for the selected folder is deactivated. 

Rules 
● Note that an activated change log can only be deactivated on the computer on which 

SIMATIC Logon Service is installed.  
Reason: The deactivation and activation tasks themselves must be recorded in the 
change log. 

● Before the download is performed to each individual CPU using the "Compile and 
Download Objects" function in the SIMATIC Manager, there is a pause in the operation 
caused by opening the change log if it is activated for the currently selected chart folder. 

 

 
 

Note 
If you copy the program or chart folder with an activated change log to a computer on 
which the SIMATIC Logon Service is not installed, you receive an error message when 
you attempt to download or switch to test mode and the action is not carried out.  
You cannot deactivate the change log in this situation because there is no "Change Log" 
tab in the "Object Properties" dialog box of the chart folder.  
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Displaying the Change Log 
You can have the change log displayed as follows: 
1. In the component view of the SIMATIC Manager, select the folder for which you want to 

display the change log. 
2. Select the menu command: Options > Change Log > Display....  

The change log for the selected folder is opened. 
All the logged changes are displayed in the change log. You can comment every entry and 
export the change log. 

Additional information 
● Online help for change log 



 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 681 

Test 11
11.1 Introduction to Testing 

Test Options     
The Process object view provides a test mode for assisting you in testing and commissioning 
process tags and CFC charts online on the CPU. You will find additional information on this 
topic in Section "How to Test in the Process Object View (Page 607)". 
You can document changes made in test mode with the ES log (which user, when, on which 
CPU, what change was made, etc. ). 
Requirements: 
● The SIMATIC Logon Service is installed. 
● The ES log for the currently selected chart folder is activated.  

You will find additional information on this topic in Section "How to Document Changes in 
the ES Log" (Page 676)". 

You will also find the essential test functions in the editors with which you configured the 
programs. With these functions, you can test the configuration. The following editors provide 
test functions: 
● CFC 

Testing the CFC configuration  
You will find additional information on this topic in Section "How to Test CFC Charts 
(Page 490)" 

● SFC 
Testing the SFC configuration  
You will find additional information on this topic in Section "How to Test SFC Charts 
(Page 568)" 

Overview 
The following procedures should be distinguished for testing: 
● Testing with S7-PLCSIM (Page 682) 
● Testing in Running Plants (Page 685) 
● Testing Field Devices (Page 685) 

Additional information 
● Manual Process Control System PCS 7; Getting Started – Parts 1 and 2 
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11.2 How to Test S7-PLCSIM 

S7 PLCSIM      
S7 PLCSIM is an optionally available software package for simulating an AS. After 
installation it can be started in the SIMATIC Manager. 
You can use S7-PLCSIM to edit and test your program on a simulated automation system. 
Since the simulation is implemented in S7 PLCSIM using the PCS 7 blocks, you do not 
require any S7 hardware (CPU or signal modules). You can test programs for S7-400 CPUs 
with a simulated automation system. This allows you to test operator control and monitoring 
of the simulated AS (OS process mode) on the engineering station. 
S7-PLCSIM provides a simple user interface for monitoring and modifying the various 
parameters that are used in your program (for example, for switching inputs on and off). You 
can also use the various applications in the PCS 7 software while the simulated CPU is 
processing your program. For example, you have the option of operator control and 
monitoring of I/O values in S7-PLCSIM. 

Rules 
 

 Note 
Please note the following: 
• The simulation of I/O modules is not carried out with S7-PLCSIM but by the blocks 

CH_DI, CH_AI etc. within the CFC charts (see also: Function Manual Process Control 
System PCS 7; Standard Library). 

• S7-PLCSIM is not suitable for the simulation of large-scale configurations in the PCS 7 
environment. 

 

Installation of S7 PLCSIM 
S7-PLCSIM is not automatically installed as part of the PCS 7 installation routine, but if you 
select the relevant option it will be installed at the same time. 
You can also install it subsequently, as the software is located on the PCS 7 Toolset DVD.  
To run the software, you require a separate authorization. 

Requirements for Working with S7 PLCSIM 
The following requirements must be fulfilled in order to use S7-PLCSIM: 
● The WinCC channel driver is available. 

(WinCCExplorer > Tag Management > SIMATIC S7 PROTOCOL SUITE). 
● No connections exist with a present automation system during the simulation. 
● If there is an AS-OS connection "NamedConnection" (PCS 7 Standard): Compile OS 

"change" and change connection to subnet type "Industrial Ethernet". 
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Procedure 
The simulation can be started from the SIMATIC Manager when there are no connections to 
actual automation systems.  
1. Start the SIMATIC Manager. 
2. Select the AS you wish to simulate. 
3. Select the menu command Options> Simulate Modules.  

S7-PLCSIM launches and the "Open Project" dialog box opens. 
4. Select option "Select CPU Access Nodes". 
5. Click "OK". 

The "Select CPU Access Nodes" dialog box opens. 
6. In the tree view, select the "-plant bus name-addr: MAC: xxx" object, for example. 

PLCSIM supports the following connection types: Industrial Ethernet (ISO protocol or 
TCP/IP), MPI and PROFIBUS DP. 

 

 
 

Note 
For TCP/IP, you will need to set the logical device name to "PLCSIM(RFC1006)" 
(WinCC Explorer > Tag Management > SIMATIC S7 PROTOCOL SUITE > TCP/IP > 
Shortcut Menu > System Parameters > "Unit" tab). 

 

7. Click "OK". 
The "S7-PLCSIM" application window opens. 

8. In HW Config, select the menu command PLC > Download to Module.... 
The hardware configuration is downloaded into the simulated AS. 

9. In the SIMATIC Manager, select the "Charts" object in the tree. 
10. Select the menu command PLC > Download. 

All of the required data is downloaded into the simulated AS. 
11. Configure S7-PLCSIM for testing by adding inputs/outputs in S7-PLCSIM so that input 

values can be simulated and output values can be monitored. Please also check that the 
program can be executed. 

12. Switch the simulated CPU to RUN mode. 
13. Select the object "OS" in the SIMATIC Manager. 
14. Select the menu command "Options > OS > Start OS Simulation. 

The OS simulation starts up. 
15. Open the SFC and CFC charts and select the menu command Test > Test Mode. 
16. Test the program. 

Please observe the information relating to block simulation in Function Manual Process 
Control System PCS 7; Standard Library. 

 

 
 

Note 
After using S7-PLCSIM, the real connections may need to be reestablished and the 
corresponding OS compiled again (changes only) with the real connection. 
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Additional information 
● Online help for S7-PLCSIM 
● How do I use S7-PLCSIM with SIMATIC PCS 7? 

(http://support.automation.siemens.com/WW/news/en/16522013) 

http://support.automation.siemens.com/WW/news/en/16522013
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11.3 Testing in Running Plants 

Introduction to Testing in a Running Plant 
 

WARNING  
Testing a program while a process is running can lead to serious damage to property or 
persons if errors occur in the function or in the program!  
Ensure that no dangerous situations can occur before you execute this function! 

 

Testing in a running plant does not differ significantly from the procedure described in the 
section "How to Test with S7-PLCSIM (Page 682)" or from the test configuration with an AS. 
The range of accessible AS and OS is normally much larger than during a test configuration. 
There are higher requirements for safety during ongoing operation and the number of 
persons involved is greater. The warning above should make this clear.  
In addition, you must ensure that any disruption or interruption in the operation of the plant 
due to the test is kept to a minimum. The plant operator should be usually consulted 
beforehand. 

11.4 How to Test Field Devices 

Note to Reader 
The options for parameter configuration and diagnostics using SIMATIC PDM are not 
described in this manual.  

Additional information 
● Online help for SIMATIC Manager and SIMATIC PDM 
● Manual PDM; The Process Device Manager 
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Comparing project versions with the 
Version Cross Manager 12
12.1 Introduction to comparison 

Introduction 
The Version Cross Manager (VXM) is a separate application you can order as an option. The 
Version Cross Manager enables you to quickly and reliably compare the project data from 
two PCS 7 projects in order to identify differences. This feature allows you to recognize if 
and what has changed. 

Requirements 
Archived configuration versions must be compared to determine any changes since the last 
supply and acceptance, for example, after it was delivered to the customer or after 
certification by the Technical Inspectorate or FDA authorities. 
This information is important, for example, in the following areas of application: 
● A previously accepted project status is to be approved after changes were made and 

expansions were added. You therefore need to know the status of changes since the last 
acceptance. 

● The contractual and accepted project status has been expanded due to subsequent 
changes in requirements and the expansions are to be verified. 

● In parallel to the commissioning of a project status at a plant, the status was expanded at 
an engineering office. The expansions are to be identified in order to add them to the 
current project status. 

● The documentation of an already completely documented project status is to be updated. 
It is to be determined which object documentation requires revision due to changes. 

● The process control project data of a plant should be synchronized with the planning data 
of the plant. To do this, export the project data in the manufacturer-independent 
XML-format and import it into CAx systems (CAD, CAE, E-CAD or E-CAE). 



Comparing project versions with the Version Cross Manager  
12.2 Using the Version Cross Manager (VXM) 

 Engineering System (V7.1) 
688 Configuration Manual, 03/2009, A5E02122455-01 

12.2 Using the Version Cross Manager (VXM) 

Introduction 
Automation solutions are configured in the PCS 7 engineering system in the form of CFC 
and SFC charts using blocks. The project version is compiled as a program and downloaded 
to the AS. This version can be saved by archiving the project (for example, after the 
customer, Technical Inspectorate or FDA representative have accepted the project). 
This project will be changed over time, errors will be corrected and additions will be made, 
for example. If a further acceptance test becomes necessary, the Version Cross Manager 
(VXM) can be used to indicate all the changes that have been made. 

Functions 
The VXM offers the following main functions: 
● Comparison of projects and XML files 
● Import and export of project and planning data 
● Generation of process tags from CAx function block diagrams 

What is Compared? 
With the VXM you select an object as "Master" and an additional object as "Compare 
Object". When you open the object to be compared, the comparison starts automatically. 
The following objects are supported: 
● Project 
● Library 
● HW configuration 
● CFC/SFC engineering data, such as charts, types, chart folders, block folders. 
● Shared declarations 
● S7 Program 
● S7 blocks 
● S7 symbols 
● Messages 
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Example 
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Display of Changed States 
Use the menu command Options > Display... to access the "Display Settings" dialog box that 
shows you the display of the change states.  
In this dialog box you can adapt the display of the change states individually. 

 

Import and Export 
The ability to exchange project data in an independent format is becoming increasingly 
important. Nowadays, a variety of software tools from various manufacturers is involved in 
the work process during the configuration phases of an industrial plant. The possibility of 
data exchange considerably improves the integration between the various software tools. In 
the planning phase of a plant, for example, the relevant CAx systems are being used with 
increasing frequency. The term CAx stands for CAD, CAE, E-CAD or E-CAE. The 
synchronization of the control system project data with the planning data from the plant can 
be supported by export and import. 
XML (Extensible Markup Language) has established itself as a data exchange format in 
many areas. The VXM uses the SimaticML format. This is a general purpose XML format 
that contains all relevant data such as hardware, CAx function diagrams, plant description, 
etc.. 

Generating process tags 
The CAx function diagrams, which are generated at plant management level, can be used to 
generate or compare process tags in PCS 7 projects. 

Additional information 
● Online help for VXM 
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12.3 How to Compare Project Versions 

Requirement      
The Version Cross Manager is installed. 

Procedure 
1. Select the menu command Start > SIMATIC > STEP 7 > VXM - Compare Versions. 

The Version Cross Manager is started. 
2. Select the menu command File > Open/Compare.... 

The "Open/Compare" dialog box opens. 
3. For A, select: 

– First Object  
Make the selection and settings you require in the "Open" dialog box. 

– First XML File  
Select the XML file you require in the "Open" dialog box. 

4. For B, select: 

– Compare With Object  
Make the selection and settings you require in the "Select Comparison Object" dialog 
box. 

– Compare With XML File  
Select the XML file you require in the "Select Comparison File" dialog box. 

5. If you only wish to see specific objects, click the  icon and make the required filter 
settings. 

6. Click the  icon to carry out filtering. 
7. Click "OK". 

The VXM reads the selected objects/files in, including all lower-level objects, and carries 
out a comparison at the same time.  
The two objects are superimposed in a comparison tree. The deviations are displayed 
with color coding. 

8. Navigate in the hierarchy or detail window to the objects for which you require detailed 
change information. 

9. Select the menu command File > Print to print out the results of the comparison. 
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Filtering 
You can use a filter to restrict the comparison of the object trees to specific objects and 
attributes. 
The filter setting is taken into account by VXM not only during the comparison but also when 
displaying the results. As a result, only the objects and attributes actually used in the 
comparison are displayed. 
You can use them to specify whether or not a file is to open with a new filter setting or 
without a filter or, if the file appears in the list under the "File" menu, whether or not it should 
open with its default setting. 
A number of filter criteria are set by default in VXM. 

Setting/activating/deactivating the filter 
● Select the menu command Options > Filters to activate/deactivate the set filter. 
● Select the menu command Options > Set Filters... to change the default filter criteria. 

Updating the Comparison Data 
If the project data has been changed in the meantime with a PCS 7 application, you can 
update the comparison data. For this purpose press the <F5> key or select the menu 
command View > Update. 
The VXM then deletes the internal management structures and reads both objects again - 
including all of the objects contained within - and performs a full comparison of the objects 
one more time. 

Saving/Printing comparison data 
You can save the differences to a CSV file and print the data. 
● Select the menu command File > Save Differences... to save the differences revealed by 

the comparison to a CSV file. 
● Select the menu command File > Print... to print the differences revealed by the 

comparison. 

Additional information 
● Online help for VXM 
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12.4 How to export project data 

Introduction        
A variety of software tools from various manufacturers is involved in the work process during 
the configuration phase of an industrial plant. XML (Extensible Markup Language) has 
established itself as a data exchange format in many areas.  
The synchronization of the PCS 7 project data with the planning data of the plant is 
supported by the export of the plant data into XML format. 

Export Options 
The project data can be exported as follows: 
● VXM 

All data is written during export from the VXM. 
Filters set in the VXM also affect the result of the export. Only objects and attributes 
displayed in the VXM through the configured filter are exported. 

● SIMATIC Manager 
When you export from the SIMATIC Manager, the project is exported. 
The export from the SIMATIC Manager cannot be assigned a filter. In this case, the 
complete project data is always exported (the filter CAx is preset and cannot be 
changed). 

Procedure in the SIMATIC Manager 
1. Open the project in the SIMATIC Manager. 
2. Select the project for which you want to export the plant data. 
3. Select the menu command Edit > Export.... 

The "Export" dialog box opens. 
4. Check the specified path and file name. If you wish to change the entry, click "..." and 

select the desired storage location in the "Save As" dialog box. 
5. Click "OK". 

The export starts and the progress is shown in a dialog box. 
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Procedure in the VXM 
1. Select the menu command Start > SIMATIC > STEP 7 > VXM - Compare Versions. 

The Version Cross Manager is started. 
2. Select the menu command File > Open/Compare.... 

The "Open/Compare" dialog box opens. 
3. For A, select: 

– First Object  
Make the selection and settings you require in the "Open" dialog box. 

– First XML File  
Select the XML file you require in the "Open" dialog box. 

4. Click the  icon, deactivate the "No filter" check box and activate the CAx filter. 

5. Click the  icon to carry out filtering. 
6. Click "OK". 

The VXM reads the selected objects/files in, including all lower-level objects. 
 

 
 

Note 
The export is only possible if a comparison has not yet been carried out. 

 

7. Select the menu command File > Save As.... 
The "Save As..." dialog box opens. 

8. Select the storage location from the "Save" drop-down list. 
9. Select the file name from the list or enter a new file name under "File name:" and click 

"Save". 

Using the XML File 
You can display exported XML files in the window of the VXM and compare them to: 
● Project data 
● Another XML file 

Additional information 
● Online help for VXM 
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12.5 How to import project data 

Introduction 
You can import planning data following a project comparison. The result of the comparison 
documents which planning data is added or changed. The changed or extended planning 
data is imported by transferring additional objects with their properties at the appropriate 
point in the project, and adjusting the relevant properties and attributes of the changed data 
in the target object. 
Before the import is started, the system queries whether any existing objects in the target 
project should be deleted, for example, because they are considered obsolete. 
You can perform the import from the standard view or from the differences view. The source 
can be a project or an XML file. 

Procedure 
1. Select the menu command Start > SIMATIC > STEP 7 > VXM - Compare Versions. 

The Version Cross Manager is started. 
2. Select the menu command File > Open/Compare.... 

The "Open/Compare" dialog box opens. 
3. For A, select: 

– First Object  
Make the selection and settings you require in the "Open" dialog box. 

– First XML File  
Select the XML file you require in the "Open" dialog box. 

4. For B, select: 

– Compare With Object  
Make the selection and settings you require in the "Select Comparison Object" dialog 
box. 

– Compare With XML File  
Select the XML file you require in the "Select Comparison File" dialog box. 

5. If you only wish to see specific objects, click the  icon and make the required filter 
settings. 

6. Click the  icon to carry out filtering. 
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7. Click "OK". 
The VXM reads the selected objects/files in, including all lower-level objects, and carries 
out a comparison at the same time.  
The two objects are superimposed in a comparison tree. The deviations shown are color-
coded (see Section "How to Compare Project Versions (Page 691)"). 

 

 
 

Note 
Please note the following: 
• If you activate the "No filter" check box, you cannot make any settings. When you 

open the file, everything is selected and displayed with all details. 
• If you activate the "Set filters when opening a file" check box, the "Set Filters" dialog 

box opens before a file is opened. 
 

8. Select the object that you want to import. 
9. Select the menu command File > Import... and then either B -> A or A -> B depending on 

the desired import direction. 
Before the import is started, the system queries whether any additional existing objects in 
the target project should be deleted, for example, because they are considered obsolete. 
You are then able to specify whether you want to archive the project first. 

Additional information 
● Online help for VXM 
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12.6 How to generate process tags 

Introduction 
Planning data refers to the plant description data that is considered relevant for the 
engineering system. This is the data from the plant hierarchy and the equipment properties 
of a plant. 
The transfer and comparison of planning data is supported by the import function and the 
generator function. In addition, descriptions can be transferred from CAx function block 
diagrams in order to generate control system CFC charts (process tags) from them using a 
software generator. The data is exchanged on the basis of a defined XML format 
(SimaticML). Conversely, modified data can also be fed back to the engineering system, for 
example, to synchronize the database of a CAx planning tool. This is enabled by a 
corresponding export function. 
The CAx Generator functionality allows you to generate or update process tags in PCS 7 
projects (CFC charts) using the CAx function block diagrams created at planning level. 

Procedure 
1. Select the menu command Start > SIMATIC > STEP 7 > VXM - Compare Versions. 

The Version Cross Manager is started. 
2. Select the menu command File > Open/Compare.... 

The "Open/Compare" dialog box opens. 
3. For A, select: 

– First Object  
Make the selection and settings you require in the "Open" dialog box. 

– First XML File  
Select the XML file you require in the "Open" dialog box. 

4. For B, select: 

– Compare With Object  
Make the selection and settings you require in the "Select Comparison Object" dialog 
box. 

– Compare With XML File  
Select the XML file you require in the "Select Comparison File" dialog box. 

5. Click the  icon, deactivate the "No filter" check box and activate the CAx filter. 
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6. Click the  icon to carry out filtering. 
7. Click "OK". 

The project display is now restricted to the CAx-relevant objects.  
The VXM reads the selected objects/files in, including all lower-level objects, and carries 
out a comparison at the same time.  
The two objects are superimposed in a comparison tree. The deviations are displayed 
with color coding. 

8. Select the File > Generate/Synchronize Process Tags menu command, followed by either 
B --> A or A --> B  (depending on the desired direction), in order to generate or 
synchronize the process tags based on the CAx data. 
The "Introduction" dialog box of the Import/Export Assistant opens. 

9. Click "Next". 
The "Which settings do you want to use for import?" dialog box opens. 

10. Check the settings and then click "Next". 
The "Do you want to finish the import?" dialog box opens; the import is executed and all 
actions are logged. 

11. Click "Exit" to return the the VXM. 

In the reverse direction: 
You can also open an XML file as the first file (A:) and compare it with the project (B:) . To do 
this, use the alternative menu commands File > Open/Compare... and the menu command 
File > Generate/Synchronize process tags > A -> B. 

Additional information 
● Online help for VXM 
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Servicing 13
13.1 Diagnostics With Maintenance Station (Asset Management) 

Introduction 
A maintenance station can be used to provide full diagnostics for a PCS 7 plant.. The 
maintenance station is an operator station that is specially configured and assigned 
parameters for use in diagnostic and maintenance functions.  
We particularly recommend the use of a maintenance station in medium and large 
PCS 7-systems. 

Maintenance station 
With the maintenance station, PCS 7 enables you to call up information on the states of all 
PCS 7 components on diagnostics screens which are hierarchically structured. As part of 
this process, the data of a component are analyzed using the available online functions of 
the associated tools. You can access ES data from the diagnostics screens (can be 
controlled via access protection mechanisms). 
Diagnostic screens for process control diagnostics can be generated automatically for the 
entire plant and made available graphically on the maintenance station. The topmost level 
forms an overview screen for the entire system. 

Requirements  
● The cross-project consistency checks were successful (for example, names of the S7 

programs unique throughout the multiproject) 
● Blocks from a PCS 7 library beginning with version V6.1 are used in the project. 
● The module drivers are generated and interconnected with the signal-processing blocks 

in the CFC charts. 
● The diagnostic blocks are set to "OCM possible". 
● The check box "Derive diagnostic pictures from the plant hierarchy" is activated in the PH 

settings. 
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Diagnostics Options 
You will find information on the states of individual PCS 7 components with diagnostic 
capability on the maintenance station's special diagnostics screens. 
 
Area Diagnostics for ... 
Automation systems  • CPU 

• SIMATIC PCS 7 BOX 
• Distributed I/Os, such as ET 200M, ET 200S,  

ET 200iSP, input and output modules 
• Field devices (HART, PROFIBUS PA, ...) 
• Interface modules (IM) 
• Couplers 
• Link modules 
• Diagnostic repeaters 

PC stations  • Operator stations 
• BATCH stations 
• Route Control stations 
• Archive servers 
• SIMATIC PCS 7 BOX 
• Siemens Industrial PCs 

Ethernet components • Switches, e.g.: 
– SCALANCE X 
– OSM 
– ESM 

• Other SNMP-compatible devices 
– For example printers, bridges, routers 

PROFIBUS components  • PROFIBUS DP 
– Interface modules (IM) 
– Couplers 
– Link modules 
– Diagnostic repeaters 

• PROFIBUS PA 
– Interfaces 
– Couplers 

Additional information 
● The Configuration Manual Process Control System PCS 7; Operator Station contains a 

description of how the maintenance station is configured. 
● You will find a description of working with the maintenance station in process mode in the 

Manual Process Control System PCS 7; OS Process Control. 
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13.2 Remote Diagnostics Functions 

Possibilities for Remote Diagnostics and Remote Administration of a PCS 7 Plant  
We recommend you use the operating system feature "NetMeeting" for remote diagnostics 
of PCS 7 plants and for administrative access to PC stations with Windows XP Professional 
and Windows Server 2003. 

 

Transmission Paths 
The data can be sent as follows: 
● via a telephone line (modem) 
● via TCP/IP connection (internal plant network connection) 

Security Requirements 
If you wish to perform remote diagnostics in a PCS 7 plant, you need to protect the this plant 
against unauthorized access.  
Several measures are required to realize a security concept. Optimal protection is only 
provided with all security measures as a whole. 

Additional information 
● Online help of the operating system 
● Whitepaper Security Concept PCS 7 and WinCC 
● Operating Manual Process Control System PCS 7; PC Configuration and Authorization 
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13.3 Additional service support and diagnostics 

Additional information 
You will find a detailed description of the additional diagnostics options that are available 
with PCS 7, as well as what to do if service becomes necessary, in the Manual Process 
Control System PCS 7; Service Support and Diagnostics. 
This manual contains the following information for your support: 
● Taking measures to ensure the availability of a PCS 7 plant. 
● Checking the requirements for effective diagnostics of your PCS 7 plant. 
● Understanding the alarm concept of a PCS 7 plant 
● Using the right procedure if a problem occurs, and providing detailed information about 

the state of the PCS 7 plant for service experts 
● Selecting the correct diagnostic tool so that you can run diagnostics on your PCS 7 plant 

with the specified aids. 
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13.4 Archiving/Versioning and Documenting 

13.4.1 Introduction to Archiving/Versioning and Documenting 

Introduction 
SIMATIC PCS 7 provides a variety of functions for archiving/versioning and documenting 
configuration data and archiving/versioning process values. 

Archiving 
PCS 7 provides two basic functions for logging: 
● Archiving process values (e.g. measured values; messages)  

The operator station saves measured values and messages in archives so that the data 
can be called up over a longer period of time. 
You can find more information about this in the configuration manual Process Control 
System PCS 7; Operator Station. 

● Archiving projects 
The multiproject is archived with all projects and the master data library. 
You can find more information about this in the sections "How to Archive a Multiproject 
and the Project Master Data (Page 705)" and "How to Retrieve a Multiproject and the 
Project Master Data (Page 706)". 

 

NOTICE  
 

Create backup copies of your project as often as possible. 
You should keep at least five older versions of the data. If there is a network failure, 
hard disk crash or network disruption, you can always revert to a backup of your project.

 

Versioning 
In PCS 7, versioning represents documented backup of data for PCS 7 plant in version 
archives.  
Version Trail (add-on package) is used for versioning in PCS 7. In a version archive, you can 
manage multiple backups (versions) of an object (for example, a project or a library). The 
archived data can not be changed after this.  
Version Trail takes over the complete management of the version history. The system 
automatically sets the versioning based on specifically configured guidelines. You can 
increment the version numbers in whole number steps, for example. Version Trail ensures 
that there is only one valid version of a project with the same identifier in the version history. 
You use Version Trail, for example, to pass a project version of a plant to others (transfer 
version) and if you wish to determine the changes in a current project version.  
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Version Trail offers you the following options: 
● You can archive objects (such as libraries, multiprojects and single projects) at a points in 

time of your choice. The saved object is assigned versioning when it is entered into the 
version archive. The versioning is the unique ID for this object. 

● You can retrieve versioned project data and use it again. 
● You can compare an archived version with an existing project or with another archived 

version. You start the Version Cross Manager (VXM) to perform the comparison. 
Further information is available in the section "How to Save Versions of the Project Data 
(Page 707)" 

Document 
Documenting involves the creation of the plant documentation. The DOCPRO add-on 
package for PCS 7 is used for this purpose.  
● Creating and managing plant documentation 
● Centralized control of printing (project segments or entire project) 
● Custom layout (e.g. DIN 6771) 
You can find information about this in the section "Creating the Project Documentation 
(Page 710). 
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13.4.2 Archiving/Retrieving multiprojects and project master data 

13.4.2.1 How to Archive a Multiproject and the Project Master Data 

Introduction         
You can save a multiproject in compressed form in an archive file just like projects or 
libraries. The compressed files are saved to a hard disk or transportable data media.  
If parts of the multiproject are stored on network drives, you can use the following file 
compression tool to create an archive for multiproject data:  
● PKZIP for Windows (available on the PCS 7 Toolset DVD; installed at the same time as 

PCS 7) 

Requirements for the Archiving Procedure 
● No single process can access one of the projects in the multiproject (since archiving is a 

cross-project function). 
● A UNC path can be entered in the project management: there must also be a drive 

assignment for the path \\Computer\Share\.. to the projects or libraries. 

Procedure 
1. Select the multiproject in the SIMATIC Manager. 
2. Select the menu command File > Archive... 

.The "Archive" dialog box opens. 
3. Select the required multiproject and click "OK". 

The "Archive - Select Archive" dialog box opens. 
4. Select the name and path of the archive, as well as the archiving program (PKZip) 
5. Click the "Save" button. 

Additional information 
● Online help for the SIMATIC Manager 
● Manual Process Control System PCS 7; Service Support and Diagnostics 
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13.4.2.2 How to Retrieve a Multiproject and the Project Master Data 

Procedure 
1. In the SIMATIC Manager, select the menu command File > Retrieve.... 

The "Retrieve - Select Archive" dialog box opens. 
2. Select the archive you want to retrieve. 
3. Click on the "Open" button. 
4. In the "Select destination directory" dialog box that appears, select the target directory for 

unpacking the archive files. 
5. Click "OK". 

 

 
 

Note 
The multiproject is retrieved in the target directory, with an additional sub-directory. The 
system bases the name of this sub-directory on the name of the multiproject (in order to 
prevent any multiprojects with the same name from being overwritten). 
Following retrieval, you must generate the server data, assign this to the OS clients, and 
download it to all OS PLCs. 

 

Result 
A new directory is created in the selected directory and the complete project directory 
structure of the unpacked multiproject now appears on the same level below this directory. 

Additional information  
● Online help for the SIMATIC Manager 
● Manual Process Control System PCS 7; Service Support and Diagnostics 

13.4.2.3 Data Security and Backup 

Recommendation 
Save various project states.  
Create a backup in the following situations: 
● After configuration changes 
● Before and after system component upgrades 
● Before and after the software update of the configuration software 

Additional information 
You will find a step-by-step description of saving and backing up ES and OS project data in 
the manual Process Control System PCS 7; Service Support and Diagnostics. 
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13.4.3 Versioning 

13.4.3.1 How to Save Versions of the Project Data 

Introduction 
You can save versioned PCS 7 project data with Version Trail. Data archived in this way can 
no longer be changed. You can retrieve stored versioned project data and use it again or 
compare it with other versions or with the current project. 
You use Version Trail, for example, to transfer a project version of a plant (transfer version) 
and later compare it to the current plant project version (using VXM).  

 

 Note 
You can assign access permissions for archived objects using SIMATIC Logon. 

 

Requirements 
Ensure the following to work with Version Trail: 
● A user must be logged on and all relevant actions must be logged under this user's name. 
● Version Trail is not open. 
● The object to be versioned (multiproject, project, library) is not open. 

Procedure 
The procedure described here assumes that you have not yet created an archive in the 
versioned project. 
To save a versioned multiproject, single project or a library, proceed as follows: 
1. Select the menu command File  > Versioned Project > Archive.... 

The "Open Project" dialog box opens. 
2. You can specify the object (multiproject, project, library) for which you want to create a 

versioned backup as follows: 
– Select the object. 
– Search for the object using the "Browse" button. 

3. Click "OK". 
The "Save SIMATIC Project <path> in Versioned Project" dialog box opens. 

4. Click "Open". 
The "Open Versioned Project" dialog box opens. 

5. Select the required versioned project from the list and click "OK". 
The "Save SIMATIC Project <path> in Versioned Project" dialog box opens. 



Servicing  
13.4 Archiving/Versioning and Documenting 

 Engineering System (V7.1) 
708 Configuration Manual, 03/2009, A5E02122455-01 

6. Select the versioned project in the tree view and select the context menu command Insert 
New Object > Archive.... 
The "Open Project" dialog box opens. 

7. Select the required object as described in step 3. 
The "Properties" dialog box opens. 

8. Enter the name and any comment and click "OK". 
The "Properties" dialog box closes. 

9. In the "Version designation" group, select the appropriate checkbox to indicate whether to 
increment the main or secondary version. 
N.B. Only "Increment main version" is possible during the first archiving. 
The "Save SIMATIC Project <path> in Versioned Project" dialog box opens. 

10. Enter the name of the version and click "Archive...". 
Compression is started and the name of the versioned object ultimately appears in the 
detail window. 

Result 
The object has been assigned a version and saved in compressed form. 
If you wish to create a new version of the same project in the same versioned project, some 
intermediate steps may be skipped. 

Security 
Version Trail is protected by the SIMATIC Logon Service. SIMATIC Logon Service check if a 
user is logged on in SIMATIC Manager.  
To log on a user, select the menu command Options > SIMATIC Logon Service... in the 
SIMATIC Manager.  
If no user is logged on, the "SIMATIC Logon Service" dialog box appears in Version Trail 
before every protected action.  
This also applies to creating a new versioned project. 

Additional information 
● Online help for the SIMATIC Manager 
● Online help for Version Trail 
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13.4.3.2 How to Retrieve a Project with Version ID 

Procedure 
To retrieve a versioned multiproject, single project or a library, proceed as follows: 
1. Select the menu command File > Versioned Project > Retrieve.... 

The "Open Versioned Project" dialog box opens. 
2. Select the required versioned project from the list and click "OK". 

The "Retrieve SIMATIC Project from Versioned Project" dialog box opens. 
3. Select the project in the tree view and the version that you want to retrieve in the detailed 

view. 
4. Click "Retrieve". 

The "Select Director" dialog box opens. 
5. Select the target directory and click "OK". 

Decompression is started.  
If there is already a folder with the same name at the storage location, a dialog box opens 
informing you of this.  
You can abort the retrieval by clicking "Cancel" or store the retrieved data under a new 
name by clicking "Rename".  
You get a message informing you of the name of the project and path where it has been 
saved. 

Result 
You have now decompressed and restored the desired version of your project. 

Additional information 
● Online help for Version Trail 
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13.4.4 Document 

13.4.4.1 Creating the Project Documentation 

Overview 
After creating the process cell, it is necessary to structure the project data in a clear manner. 
Clearly structured documentation makes both future development of the project and service 
and maintenance much easier. 
DOCPRO is an application that can be used for effective creation and management of plant 
documentation. It gives you the following options: 
● To structure the project data in any way 
● To prepare the project data in the form of standardized technical documentation 
● To print out the project data in a unified format 

Additional information 
● Online help for DOCPRO 
● Manual DOCPRO; Creating Documentation 
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13.4.4.2 How to Convert Documentation to a PDF File 

Introduction 
DOCPRO can generate documentation to an electronic manual (PDF format). There is no 
automatic conversion function in PCS 7!  

Requirement 
You have a full license agreement for the program Adobe Acrobat from Adobe Systems 
Incorporated. 

Basic Procedure 
1. Create the documentation for a project in DOCPRO, for example, with the aid of the 

DOCPRO wizard. 
2. Print the documentation from DOCPRO to a file. Check the "Print to file" check box inside 

the Windows Print dialog box. 
3. Open the Acrobat Distiller and drag all the files created by DOCPRO from the Explorer to 

the Distiller. 
The Distiller creates the corresponding PDF file from every single file. 

 

 
 

Note 
Siemens accepts no liability for the programs offered by Adobe Systems Incorporated. 
For detailed information on using the Acrobat Reader, refer to the Acrobat Online manual 
that can be started with the menu command Help. 

 

Additional information 
● Online help for DOCPRO 
● Manual DOCPRO; Creating Documentation 
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Attachment 14
14.1 Overview 

Overview  
This overview contains information about the following topics: 
● Installation Guidelines for PCS 7 (Page 714) 
● Lightning protection (Page 716) 
● Electrical installation (Page 718) 
● Basics of EMC-Compliant Installation of PCS 7 (Page 723) 
● Degrees of Protection (Housing Protection) (Page 726) 
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14.2 Installation Guidelines for PCS 7 

Introduction 
The installation guidelines must be observed to ensure correct operation of a PCS 7 control 
system. This appendix contains additional information about lightning protection, grounding 
and EMC-compliant installation. The basic installation guidelines can be found in the 
installation manuals of the components (for example. Installation Manual Programmable 
Controllers S7-400, Hardware and Installation). 

Components 
The configuration method is largely determined by the components used in PCS 7: 
● SIMATIC PC stations 
● SIMATIC NET (Industrial Ethernet and PROFIBUS) 
● S7-400/S7-400H/FH 
● Distributed I/O (ET 200M, ET 200S, ET 200iSP, and field devices) 
Each component has numerous configuration variations that can be adapted to meet the 
requirements of a particular application. 
There is also the option of installing programmable controllers and the distributed I/O 
systems in cabinets. 
For more detailed information about the installation of an entire plant (lightning protection, 
grounding, etc.) refer to the relevant sections below. The options available for connecting 
process signals to the CPUs are described in detail in the section Installation of the.  

 

 Note 
ET 200M is used as an example of distributed I/Os in the following document. Refer to the 
relevant product manuals for more information about installing other ET models. 

 

Rack or Wall Mounting 
The PCS 7 control system can be mounted in racks or on a wall if the system is being 
operated in an environment with low noise levels in which the permitted environmental 
conditions can be maintained. To discharge voltages coupled in on large metal surfaces, you 
should install rails, shields and the lightning conductive bar on reference potential surfaces 
made of sheet steel. 
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Cabinet Installation 
S7-400 programmable controllers and ET 200M modules can be installed in cabinets for the 
PCS 7 control system. The following illustration shows the S7-400 programmable controller 
and distributed I/O system ET 200 M installed in a cabinet. The different racks can be 
combined as necessary to allow you, for example, to install the distributed I/Os in separate 
closets (electronics closets, wiring closets). 

 
The cabinets consisting of system-specific (system and I/O units) and system-neutral 
modules (basic cabinets, power supply units and add-on packages) offer adequate 
protection against the following factors: 
● Unauthorized access 
● Mechanical influences 
● Contamination and corrosion 
Due to the modularity and associated variability, the cabinets can be adapted to different 
types of system and different sizes of system. 

EMC Compliance 
The PCS 7 control system and its components comply with the EMC requirements of 
European standards. These standards require that EMC-compliant devices have sufficient 
immunity to noise during operation when correctly installed, suitably maintained, and be 
used for correct purposes in a normal EMC environment. The emission of noise is limited to 
guarantee normal operation of radio and telecommunication devices. 
The cabinets of the PCS 7 control system consisting of the system units, I/O units, basic 
cabinets, power supply units and add-on packages are CE compliant. This means that the 
cabinets and the PCS 7 control system comply with the EMC regulations such as: 
● Electromagnetic compatibility (89/336/EEC; 92/31/EEC) 
● Low voltage directive (73/23/EEC; 93/68/EEC) 
● Hazardous areas directive (94/9/EEC) 
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14.3 Lightning Protection 

Introduction     
Industrial plants and power stations must be equipped with lightning protection to protect 
people, buildings and equipment from damage resulting from lightning strikes. Process 
control systems with extensive cabling networks are often at risk since high voltages can 
occur between points at great distances from each other. The destruction of electronic 
components due to lightning can lead to plant failure with extremely expensive 
consequences. 
The risk of damage by lightning can result from 
● A building being struck directly 
● A lightning strike in the immediate vicinity of the system 
● A remote strike (for example, in a free line) 
● Cloud-to-cloud-discharge 
Originating in the lightning channel, the lightning creates a cylinder-shaped electromagnetic 
wave that penetrates into the building and induces voltages in cable loops. The closer the 
lightning strike, the more powerful the fields created. 
Both with lightning from cloud to cloud or from cloud to earth, the charges induced in free 
lines (high and low power and telecommunication lines) change. These changed charges 
then flow as traveling waves along the cable. If these traveling waves reach equipment at the 
end of the cable they can also enter the plant or system that you want to protect. Generally, 
only signal and bus cables in the vicinity of transformers and signal and telecommunication 
lines are actually at risk. 
The lightning protection for a process control system can be roughly divided into exterior and 
interior lightning protection.  

Exterior Lightning Protection 
Exterior lightning protection includes all the equipment used outside a building for 
discharging lightning to earth. 

Interior Lightning Protection 
Interior lightning protection includes the measures taken to counteract lightning and the 
effects of its electrical and electromagnetic fields on metallic installations and electrical 
systems within the building. 
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Lightning Protection Zone Concept 
The principle of a lightning protection zone requires that facilities to be protected from 
overvoltages, such as a section of a factory, should be divided into lightning protection zones 
based on EMC considerations.  
The division of the lightning protection zones is made according to the distance from a point 
liable to lightning strikes and the resulting high-energy electromagnetic fields. Lightning 
protection zones are as follows: 
 
Exterior lightning protection of the building (field 
side) 

Lightning protection zone 0 

The shielding of  
- Buildings 
- Rooms and/or 
- Devices 

 
Lightning protection zone 1 
Lightning protection zone 2 
Lightning protection zone 3 

Additional information 
The rules for bridging the interfaces between the lightning protection zones and an example 
circuit for networked SIMATIC 400 stations are explained in the installation manual "S7-400 
Programmable Controllers, Hardware and Installation". 
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14.4 Electrical Installation 

Introduction 
The correct operation of PCS 7 components depends to a large extent on adherence to 
certain rules of electrical installation. This involves the following aspects: 
● Equipotential bonding (VDE 0100) 
● Grounding 
● Overvoltage Protection 
● Shielding 
● Cabling 

Equipotential Bonding 
In accordance with VDE 0100, all electrically conductive metal parts of a system (cabinet 
panels, racks etc.) must be interconnected. This ensures that any potential differences are 
reduced to such an extent that there is no danger for either human beings or equipment.  

Grounding 
Low-resistance ground connections reduce the risk of electrical interference in case of short 
circuits or faults in the system. By using low-impedance connections for grounding and 
shielding cables and devices, the effects of noise on the system and the emission of noise 
from the system can be reduced. 
The SIMATIC S7-400 programmable controller and the distributed I/O system ET 200M 
allow both grounded and ungrounded operation. 

Grounded Reference Potential or Ungrounded Installation 
The modules used in the S7-400 are always grounded via the backplane bus of the rack. 
This strategy is usually used in machines or in industrial plants and interference currents are 
discharged to local earth.  
In the chemical industry or in power stations, it may be necessary to operate systems with an 
ungrounded reference potential due to the ground-fault detectors. In this case, a jumper on 
the rack can be removed so that the reference potential is connected to local earth via an 
integrated RC network. 

Overvoltage Protection 
Overvoltages can occur at module outputs when inductors are turned off (at relays, for 
example). The digital modules of the SIMATIC S7 400 have integrated overvoltage 
protection. In certain situations (for example, when there is an additional contact between the 
module output and inductor), an external overvoltage suppressor (for example, an arc-
suppression diode) must be installed directly on the inductor. 
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Symmetrical Signal Circuits 
In balanced signal circuits, all the signal routes have the same impedance. This means that if 
there is interference, the induced longitudinal voltages in the signal cables are of the same 
magnitude and no interference current can flow. A balanced signal circuit is typically used for 
highly sensitive measurement circuits and for systems operating at high frequencies. 
Balanced measuring circuits have a high degree of immunity to noise but are extremely 
complicated and hardly found in process control systems. In process control systems, 
shielding of cables is preferred. 

Shielding of electrical cables 
Electrical cables are shielded to reduce the effects of magnetic, electrical, and 
electromagnetic disturbances on the cables. The interference currents induced in the shields 
are discharged direct to ground via low-impedance connections.  
Braided shields are preferred to foil shields since foil shields can be damaged easily, 
reducing the efficiency of the shield. Grounding shields via long, thin wires also makes the 
shield ineffective. Due to the high inductance, interference currents can not flow to ground. 
If the shielding effect of the cable shield is inadequate, the cables should be pulled into 
metallic conduits that are grounded at both ends. 
With high-frequency disturbances, it is advisable to contact the shield at the both ends of the 
cable (at the start and at the end of the cable), whereas for low-frequency interference, the 
shield should be contacted at the start or end of the cable. The effectiveness of the shield 
with low-frequencies is determined by the ohmic resistance (shield cross section), while with 
high frequencies the inductance and therefore the structure of the sheath (closed conduit 
better than braid etc.) decides the effectiveness. 
To prevent coupling in magnetic fields, shields should, whenever possible, be connected to 
an equipotential bonding system at both ends. Indoors, this is often not done due to fears of 
violating specifications for the current load on the foil shields that can be caused by power-
frequency interference currents.  
Grounding both ends of a shield is not permitted when strong magnetic inference fields are 
present (generators, conductor bars). Connecting the shields at both ends would form a loop 
into which power-frequency interference voltages could be coupled. 
To avoid the effects of induced voltages resulting from magnetic fields, signal cables are 
twisted. The twisting results in a positive induced voltage in one half of the twist and a 
negative voltage in the other. These voltages cancel each other out over the length of the full 
twist. 
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The following schematics illustrate possible shielding configurations.  
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Connecting the cable shield of electrical cables at the entrance to the electronics cabinet 
Care must be taken that interference running along the cable shield is not allowed to enter 
electronics cabinets. 
If the cable shields are grounded inside the cabinet or casing, the field generated in the 
shield grounding cables by the shield current is coupled not only into the unshielded signal 
cables but also into the loops on the modules behind the inlet protection circuits and 
generates interference voltages. For this reason, when grounding both ends of a shield, the 
grounding should take place directly at the housing opening. 
Also ensure that the shields contact the grounding rail over a sufficiently large area. Long 
thin wires between the shield and ground bar have high inductance and are therefore 
unsuitable for discharging interference currents with high frequencies. 
Note the following points: 
● Use short wire lengths (if possible do not use wires at all but make direct large-area 

contact) 
● Choose a suitable route for the shield grounding wires (do not lead them close to 

sensitive electronics) 
● Use a short, thick cable from the shield bar to the equipotential bonding system 
If cabinets or casings are included to shield the control system, remember the following 
points: 
● Cabinet panels such as side panels, back panels, ceilings and floors should be contacted 

at adequate intervals when cascaded. 
● Doors should have extra contacts to the cabinet chassis. 
● Cables leaving the shielding cabinet should either be shielded or fed via filters specified 

for PCS 7. 
● If there are sources of strong interference in the cabinet (transformers, cables to motors, 

etc.), they must be separated from sensitive electronics by partitions. The partitions 
should be connected with low impedance to the equipotential bonding system via the 
cabinet. 

All housings, cabinets, etc.should be connected to the equipotential bonding system over the 
shortest route possible. Often, an independent equipotential bonding system is created. This 
is connected to the equipotential bonding system of the remaining plant by a single cable. 
It is a mistake to connect the PCS 7 process control system to a ground point outside the 
plant. The magnetic fields generated by the interference currents flowing in the equipotential 
bonding system induce voltages in the additional surface between the equipotential bonding 
conductors and the connection to ground. 
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Laying electrical cables 
The aim of cabling is to reduce the field of interference current between the source and the 
signal cable to a minimum, by laying the cable directly on the conductor carrying the 
interference current. 
Signal and bus cables should be laid next to cables with a large diameter since the field 
strength is lower here than with cables with a smaller diameter.  
If the conductor carrying the interference current is a plate (for example, belonging to the 
building structure) lay the signal cable in the middle of the plate where the field strength is at 
its lowest. The cable should be fixed to the side of the plate with the least noise. This also 
applies to brackets and girders. 

 
The lines of a signal or bus connection should be in one cable and be surrounded by a 
common shield. The cable should be laid as close as possible to the exciting cable to keep 
the insulation stress to a minimum.  
The cable carriers (for example, cable racks) should be connected to the equipotential 
bonding system if there is no interference-carrying part of the equipotential bonding system 
within close proximity. The cable shield can then be contacted at both ends with the casings 
of the electronic equipment and in turn connected to the equipotential bonding system. 

Additional information 
For more detailed information about the electrical installation, refer to the installation manual  
S7-400 Programmable Controllers; Installation and Hardware. 
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14.5 Basics of EMC-Compliant Installation of PCS 7 

Introduction 
Although the SIMATIC PCS 7 system and its components were designed for use in an 
industrial environment and meet strict EMC requirements, an EMC assessment should be 
performed prior to installing the control system and possible sources of noise identified. 

Possible Sources of Noise 
An automation system can be affected by different sources of electromagnetic  
interference in different ways: 
● Electromagnetic fields can affect the system directly. 
● Interference can be transported by bus cables. 
● Interference can be transferred via the signal wiring. 
● Interference can reach the system via the power supply or the protective earth. 

Mechanisms 
Interference arising from various coupling mechanisms can affect the PCS 7 control system. 
The type of coupling mechanism depends on the distance between the source of the 
interference and the PCS 7 control system and the transmission medium. 
 
Coupling 
mechanisms 

Cause Sources of interference 

Conductive  
coupling 

Occurs if two circuits  
share a cable  

Clocked devices; starting  
motors; static discharge 

Capacitive  
coupling 

Occurs between two cables at 
different potential 

Interference from parallel 
electrical signal cables; contactors; 
static discharge from operator 

Inductive  
coupling 

Occurs between two cables 
carrying current. The magnetic 
fields of the current induce 
interference voltages. 

Transformers; motors;  
parallel power cables; cables with 
switched currents; high-frequency 
electrical signal cables 

Radiation 
coupling 

Occurs when an electromagnetic 
wave meets an electric cable. 
Voltages and currents are induced.  

Adjacent transmitters (walkie-talkie); 
radio links 
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Rules for Assuring Electromagnetic Compatibility 
Adherence to the following rules is normally adequate to guarantee electromagnetic 
compatibility: 
● Protect the programmable controller from external noise by installing it in a metal cabinet 

or enclosure. Include the cabinet or casing in the chassis connections. 
● Shield against the magnetic fields generated by inductors (transformers, motors, 

contactor coils) using separating plates (steel, highly permeable material) from the 
programmable controller. 

● With shielded signal and bus cables use metallic connector casings (not metalized 
plastics). 

● Connect all inactive metal parts together using low impedance and making large-area 
contact and also to local ground. 

● Create a central connection between the inactive metal parts and ground point. 
● The shield bar should be connected to chassis with low impedance and making large-

area contact. 
● Divide cables into cable groups and lay them separately. 
● Always lay power cables, electrical signal cables and bus cables in separate channels or 

bundles. 
● Lay Ex (hazardous area) and normal signal cables in separate channels. 
● Only feed cables into a cabinet from one side. 
● Lay electrical signal cables and bus cables as close as possible to chassis surfaces  

(e.g., supporting bars). 
● Use twisted cables. 
● Contact the shields of electrical signal cables at both ends. 
● Lay analog cable with double shields. The inner shield must be contacted at one end and 

the outer shield at both ends. 
● Contact cable shields with the shield bar over a large area immediately where they enter 

a cabinet and secure with clamps. 
● Continue the contacted shield to the module without interrupting it. 
● The cable shield must not be interrupted between the function units and must be 

contacted at both ends. 
● Do not interconnect cable shields. 
● Only use mains filters with metal enclosures specified for PCS 7. 
● Connect the filter casing over a large area; in other words with low impedance to cabinet 

chassis. 
● Never secure filter casings to painted surfaces  

(this will scratch the paint!). 
● Install filters at the point where the electrical cable enters the cabinet. 
● Do not lay unfiltered electrical cables in the cabinet. 
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Additional information 
For additional information about plant installation, refer to the manual S7-400 Programmable 
Controllers; Installation and Hardware. 
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14.6 Degrees of Protection (Housing Protection) 

IP standard 
Housing protection is stipulated in standard EN 60529 in Europe by the IP codes IPxx with 2 
numbers. 
The following table explains the IP norms conforming to EN 60529/IEC529: 
 
First number Contact and solid body protection Remarks 
0 No protection  
1 Protection against solid objects up to 50 mm E.g. inadvertent hand contact 
2 Protection against solid objects up to 12,5 mm E.g. fingers 
3 Protection against solid objects beyond 2.5 mm  E.g. tools and small wires 
4 Protection against solid objects beyond 1 mm  E.g. tools and small wires 
5 Protection against dust, limited penetration 

allowed 
No damaging deposits 

6 Completely dust proof  
 

 
Second number Degree of protection against water Remarks 
0 No protection  
1 Protection against dripping water  Vertically falling drops of water 
2 Protection against dripping water  Direct dripping inclined at 15° 

vertical angle 
3 Protection against spraying water   
4 Protection against spraying water  Water spray from any direction 

should not result in damage 
5 Protection against water jets Low pressure water jets from 

any direction should not result in 
damage 

6 Protection against high pressure water jets  Water jets from any direction 
should not result in damage 

7 Intermittent immersion at specified pressure for 
specified time should not result in damage 

 

8 Protection against extended submersion under 
pressure  

Agreed upon definition between 
the manufacturer and the user; 
however, the conditions must be 
severer than under Number 7 
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Protection level 
The casings of most SIMATIC components have ventilation openings. To allow more 
effective cooling of the electronics components, ambient air can flow through the casing. The 
maximum operating temperatures quoted in the technical specifications apply only when 
there is unrestricted flow of air through the ventilation openings. 
Depending on the size of the ventilation openings, such modules comply with the degrees of 
protection IP 20, IP 30 to IP 40. You will find the actual degree of protection of a SIMATIC 
component in its documentation. 
Components with the degrees of protection mentioned above do not provide protection 
against dust and water! If the installation site requires protection of this kind, the components 
must be installed in an additional enclosure (such as a switching enclosure) that provides a 
higher degree of protection (for example, IP 65/IP 67). 

Installation in Additional Enclosures 
If you install these components in an additional enclosure, make sure that the conditions 
required for operation are maintained! 

 

 Note 
Make sure that the temperature inside the additional enclosure does not exceed the 
permitted ambient temperature for the installed components. Select an enclosure with 
adequate dimensions or use heat exchangers. 

 

 



Attachment  
14.6 Degrees of Protection (Housing Protection) 

 Engineering System (V7.1) 
728 Configuration Manual, 03/2009, A5E02122455-01 



 

Engineering System (V7.1) 
Configuration Manual, 03/2009, A5E02122455-01 729 

Index 
  

A 
Access Options, 21 

Other documentation, 21 
Access protection, 50, 193, 266, 269 

Open a project/library, 269 
Access to PCS 7 OS, 125 

Via WebNavigator client, 125 
Acknowledgement concept, 228, 232 
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Adopt, 527 

Process Tags, 527 
Adopting, 627 
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symbols for input and output addresses, 366 
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Automation system, 134, 139 

Components, 134 
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B 
Backup, 706 
Basic concept, 225 

Event-signaling system, 225 
Basic configuration, 161, 275 

configure hardware, 275 
in PCS 7 plants, 161 

Basic Elements, 205 
for Reuse, 205 

BATCH, 126 
PC components, 126 

BATCH archive, 56 
BATCH stations, 281 

Configure, 281 
Insert, 281 

Block, 323, 328, 468, 470, 473, 506 
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for an FDL, ISO/TCP connection, 506 
for different connection types, 506 
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for S7 connections, 506 
inserting into a CFC chart, 468 
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Set language, 328 

Block drivers, 510 
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modify, 324 

Block icon, 206, 223, 329 
creating/updating OS pictures automatically, 329 
Generate, 223 
use, 206 

Block type, 206, 321 
update, 321 
use, 206 

Blocks, 587 
edit, 587 

Braided shields, 718 
Branching, 201 

Charts from a Project, 201 
Bring into contact, 718 

Cable shield, 718 
Bus systems, 68, 78, 79, 80 

Area of application, 79 
for communication, 78 
Maximum expansion, 68 
maximum transmission rate, 80 
Parameter, 79 

C 
Cabinet construction, 714 
Cable shield, 718 

bring into contact, 718 
Cabling, 718 
Cancel, 302 

Assignment of object - PH, 302 
catalog profile, 353 

project-specific for a hardware configuration, 216, 
353 

Catalog profile, 216 
Central I/O, 145 
Central, plant-wide engineering, 188 
CFC chart, 463, 467, 485, 487, 488, 490 

Comparing before downloading, 487 
Compile, 485 
create, 463 
creating, 467 
Download to the CPU, 488 
test, 490 

CFC chart I/Os, 482 
define, 482 

Change, 559 
Process tag type, 520 

Change Module during Operation, 382 
Change parameter settings, 412 

of existing modules in ET 200M stations, 412 
changes 

Installation rules for CIR, 185 
Changes, 15, 185, 421, 676 

compared with the previous version, 15 
Configuration in RUN, 421 
ES Log, 676 
in runtime CiR, 185 

Changing, 152, 324, 415, 430, 439, 520, 663 
Attribute: Signal configuration of modules, 663 
central, 205 
Configuration to distributed I/O, 152 
Network configuration, 439 
Node address, 430 
Parameter assignment of a channel, 415 
SFC type centrally, 559 

Chart, 561 
Compiling, 561 

Check 
consistency of the PH, 304 

Checking, 304, 435 
consistency of the network, 435 
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Principles, 396 
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CiR element, 402, 406, 407 
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Delete, 406 
Use in RUN, 407 
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Defining, 582 
Displaying/Hiding, 582 
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Sorting, 582 
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Data communication via the terminal bus and plant 
bus, 174 
Networks, 78 
to third-party systems, 48 
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Communication connection, 77, 440 
Connection Types and Connection Partners, 440 
with SIMATIC NET, 77 

Communications processor, 276, 364 
insert, 364 
Insert, 276 
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SFC chart, 564 
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Comparing project versions, 687 
Version Cross Manager, 687 

Compile, 327, 330, 485, 561 
CFC chart, 485 
Message texts, 327 
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Chart, 561 
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Compiling and downloading, 665, 667, 673 
AS data, 665 
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Requirements for OS, 667 
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Fail-safe automation Systems, 141 
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for access protection, 50 
for data links to third-party systems, 48 
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change to distributed I/O, 152 
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Download to the CPU, 419 
Downloading changes in RUN, 421 
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Fail-safe systems, 377 
Fault-tolerant systems, 377 
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in RUN - CiR, 399 
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of a SIMATIC station, 355 
of the AS and PC stations, 273 
of the automation system, 178 
Overview, 357 
Sequence control, 536 
Structure and Content of the CFG File, 655 

configuration manual 
Structure, 31 

Configuration manual, 31 
Configuration modifications, 400 

Permissible, 400 
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Configuration steps, 465, 630 
for creating CFC charts, 465 

Configuration tasks, 256 
create a PCS 7 project, 256 
for working with the I/E Assistant, 630 
set up a PCS 7 project, 256 

Configure, 277, 290, 382, 417, 438, 442, 446, 453, 
456, 457, 459, 497, 539, 545, 554, 613, 615, 617, 619, 
626, 723 

AS runtime measurement, 497 
Blocks, 470 
Communication between two SIMATIC 
stations, 442 
Connection between a PC and a SIMATIC 400 
station, 446 
Connection to the works management level, 617, 
619 
cross-project connections between AS and OS, 626 
Diagnostic repeaters, 387 
Distributed I/Os, 382 
EMC-compliant, 723 
Engineering station, 277 
Messages in the SFC, 554 
OpenPCS 7 station, 285 
Operator Station, 279 
PA devices, 386 
PC stations, 286 
Plant hierarchy, 290 
redundant networks, 438 
Route Control functions, 615 
Route Control stations, 283 
Sequencer properties, 539 
SIMATIC BATCH functions, 613 
Steps - SFC, 543 
textual interconnections by several users, 459 
Transitions - SFC, 545 
Y coupler, 394 
Y link, 394 

Configuring, 279, 281, 283, 285, 286, 351, 357, 386, 
387, 392, 394, 428, 429, 470, 543 

AS functions, 457 
BATCH stations, 281 
Cross-AS functions, 453 
Hardware for the high-precision time stamp, 417 
HART devices with SIMATIC PDM, 392 
Network connections, 429 
new subnet, 428 
OS functions, 609 
redundant connections, 456 

Connect, 91, 102, 106, 114, 116, 117, 118, 119, 120, 
122, 123, 144, 150 

Connect KNX to PROFIBUS DP, 116 
Connecting the ASI bus to PROFIBUS DP, 114 
Ethernet, 91 
H1 Bus Fieldbus Foundation to PROFIBUS DP, 118 
HART devices to distributed I/O, 150 
HMI systems via OPC, 122 
I/O device, 144 
I/Os with driver blocks, 510 
instabus EIB to PROFIBUS DP, 116 
MODBUS to PROFIBUS DP, 117 
Network nodes, 91 
PROFIBUS DP nodes, 102 
PROFIBUS PA to PROFIBUS DP, 106 
To the IT world via OpenPCS 7, 123 

Connecting 
to MIS/MES, 119 
To the IT world with SIMATIC IT, 120 

Connection between a PC and a SIMATIC 400 
station, 446 

Configuring, 446 
Connection Configuration, 440 
Connection partners, 440 
Connection table, 451 
Connection to the works management level, 617, 619 

configuring, 617 
Configuring, 619 

Connection types, 440 
Connections, 440 

Configuring, 440 
Consistency, 304, 382, 435 

check the PH, 304 
checking the network, 435 
Errors, 382 

Convert, 711 
convert documentation into a PDF file, 711 

Copy, 299, 302, 319, 552, 577, 583 
Charts, 302 
In the PH, 299 
Objects to the master data library, 319 
SFC chart, 552 

Copying 
Replicas of the model, 577 

Correlations, 246 
between the views, 246 
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Coupling, 106, 114, 116, 117, 118, 122, 723 
Connect KNX to PROFIBUS DP, 116 
Connecting the ASI bus to PROFIBUS DP, 114 
Coupling mechanisms, 723 
H1 Bus Fieldbus Foundation to PROFIBUS DP, 118 
HMI systems via OPC, 122 
instabus EIB to PROFIBUS DP, 116 
MODBUS to PROFIBUS DP, 117 
PROFIBUS PA to PROFIBUS DP, 106 

CP 443-1, 364 
CP 443-5 Extended, 364 
CPU, 65, 367, 378 

Default parameters, 378 
requisite number, 65 
set properties, 367 

CPUs for PCS 7 projects, 137, 138 
Default parameters, 138 
Limits, 137 

Create, 292, 328, 329, 359, 463, 516, 517, 518, 532, 
540, 555, 570, 710 

CFC chart, 463 
Create driver blocks yourself, 516 
Documentation, 710 
Master data library, 315 
own blocks, 328 
Plant hierarchy, 292 
Process tags from process tag types, 517 
Sequence control, 532 
SFC type, 555 
SIMATIC station, 359 
Topology of the sequential control system, 540 

Create automatically, 525 
Process Tags, 525 

Create you own block, 328 
create, 328 

Creating, 258, 289, 315, 426, 428, 429, 467, 514, 538, 
558, 575 

a new SFC chart, 538 
automatically creating block icons for OS 
pictures, 329 
CFC chart, 467 
Model, 570 
Multiproject with the PCS 7 wizard, 258 
network connections, 426 
Network connections, 429 
new subnet, 428 
Plant hierarchy, 289 
Process tag type from a CFC chart, 518 
replicas of models, 575 
SFC instance, 558 

Creating CFC Charts, 465 
Configuration steps, 465 

Cross-project connections, 455, 625 
merging, 455, 625 

Cross-project networks, 624 
Cross-project Networks 

merging in the network, 624 
Cross-project S7 connections, 626 

between AS and OS components, 626 
Configuring, 626 

D 
data, 645 
Data, 157, 627, 648 

Exchanging with MS Excel/Access, 648 
IEA File in the ES, 645 
import, 157 

Data 
Adopting from the plant engineering, 627 

Data backup, 706 
Data communication 

with MS Excel/Access, 648 
Data Communication, 174, 648 

Communication via the terminal bus and plant 
bus, 174 

Data formats, 157 
import, 157 

Data links, 113 
to other systems, 113 

Data-handling steps, 346 
Multiproject, 346 

Deactivate, 676 
ES Log, 676 

Default parameters, 378 
of the CPUs, 378 

Default parameters, 138 
of the CPUs for PCS 7 projects, 138 

Defaults, 256, 257 
In the SIMATIC Manager, 256 

Define 
CiR elements, 402 

Defining, 353, 402, 482, 582 
a project-specific catalog profile for a hardware 
configuration, 353 
CFC chart I/Os, 482 
Columns, 582 

Degree of protection - Housing protection, 726 
Delete, 406, 552, 577, 583 

Model, 577 
SFC charts, 552 
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Deleting 
CiR elements, 406 

Derive, 221 
OS areas from the PH, 221 
Picture hierarchy from the PH, 221 

Device, 66 
Integrate, 66 

Diagnostic clocks, 510 
Diagnostic functions, 95 

Plan on the Ethernet, 95 
Diagnostic repeaters, 111, 387 

Configure, 387 
Configuring, 387 
Properties, 111 
Use on the PROFIBUS, 111 

Diagnostics, 95, 111, 185, 387, 395, 699 
Configuration, Diagnostic Repeater, 387 
for load voltage failure, 185 
Plan on the Ethernet, 95 
plan on the PROFIBUS, 111 
Using SIMATIC PDM, 395 
with a maintenance station, 699 

Diagnostics and servicing, 30 
Documentation, 30 

Diagnostics on the PROFIBUS, 111 
Plan, 111 

Display, 427 
Networked stations, 427 
non-networked stations, 427 

Displaying/Hiding, 582 
Columns, 582 

Distributed Editing of the Projects, 342 
Multiproject engineering, 342 

Distributed engineering, 196, 201, 203 
Branching and merging, 201 
Configuration in the Network, 203 
Multiproject, 196 

Distributed I/Os, 145, 146, 150, 152, 153, 382 
change the configuration, 152 
Components, 146 
Configure ET 200M, 382 
connect HART devices, 150 
integrate in hazardous areas, 153 
Overview, 146 

Document, 341, 703 
Library objects, 341 

Documentation, 15, 21, 23, 25, 30, 710, 711 
Access Options, 21 
Commissioning, 30 
convert project documentation into a PDF file, 711 
create project documentation, 710 
Diagnostics, 30 
for planning and configuration, 21 
Operation, 30 
Planning phase, 23 
Purpose, 15 
Realization phase, 25 
Service, 30 
Validity, 15 

Download, 286, 419, 421, 668 
all PLCs, 668 
Configuration changes in CPU RUN, 421 
Configuration to the CPU, 419 
Download CFC chart to the CPU, 488 
PC stations, 286 

Downloading, 488, 565 
Programs, 565 

Downloading changes, 473, 488, 559, 565, 668 
DP slave, 382 
Driver blocks, 510, 512, 516 

create yourself, 516 
List, 512 
Purpose, 512 

During insert operation 
First import of an entire station, 661 

E 
Edit, 350, 585 

Process Tags, 526 
Editing, 61, 439, 526, 587, 589, 593, 599, 601, 603, 
605, 606 

Blocks, 587 
Edit projects on distributed stations, 350 
Equipment Properties, 605 
General data, 585 
Hierarchy folder, 603 
Measured value archives, 601 
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Network configuration, 439 
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Picture objects, 599 
Process object, 61 
Shared declarations, 606 
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Functions, 155 
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Effects on the process, 422 
Electrical installation, 718 
Electrical transmission media, 98 
Electrical Transmission Media, 90 
Electromagnetic compatibility, 723 

ensure, 723 
Electronic signature, 50 
EMC planning, 723 
EMC requirements, 723 
EMC-compliant installation of PCS 7, 723 
Engineering, 188, 196, 664 

central and plant-wide, 188 
distributed, 196 
Synchronization of engineering data, 664 

Engineering Station, 163, 277 
Configure, 277 
Insert, 277 
Structure, 163 

Engineering system, 163 
Ensure, 723 

electromagnetic compatibility, 723 
Equipment Properties, 605 

edit, 605 
Equipotential Bonding, 718 
ES, 126 

PC components, 126 
ES Log, 676 

activate, 676 
Deactivate autoscroll, 676 

ESM, 88 
ET 200, 148 
ET 200iSP, 102, 146, 147, 148 
ET 200M, 102, 139, 146, 147, 148, 377, 382 
ET 200pro, 102, 146, 147, 148 
ET 200S, 102, 146, 147, 148, 377 
Ethernet, 82, 91, 93 

Configuration of redundant networks, 93 
Event-signaling system, 225 

Basic concept, 225 
Exchanging, 648 

Data with MS Excel/Access, 648 
Existing modules, 412 

Change parameter settings, 412 
Expand, 192, 261, 263, 265 

a project with the Expand Project wizard, 192 
multiproject by adding projects, 261 
project by adding components, 265 
project with the PCS 7 "Expand Project" wizard, 263 

Expand project, 192, 263 
with the PCS 7 "Expand Project" wizard, 263 

Expand Project 
with the PCS 7 "Expand Project" wizard, 192 

Expanded Import File, 662 

Export, 642, 653 
Exporting, 330, 354, 643, 664, 693 

Hardware configuration, 354 
Model, 643 
Operator texts, 330 
Process tag type, 643 
Project data - XML format, 693 
Station configuration, 653 
Synchronization with plant engineering, 664, 693 

Exterior Lightning Protection, 716 

F 
F systems, 377 

Configuration, 377 
Faceplate, 206 

use, 206 
Fail-safe automation systems, 136, 141, 377 

Operational Safety of PCS 7, 73 
Possible uses, 147 
using, 136 

Fail-safe automation Systems, 73, 76, 147 
Configuration, 377 
Recommended uses, 76 

Fail-safe automation Systems 
Application, 141 

Fault-tolerant Automation System, 147 
Configuration, 377 

Fault-tolerant automation systems, 135, 139, 377 
Possible uses, 147 
Technical specifications, 135 

Fault-tolerant bus, 93 
Fault-tolerant components, 70 
Fault-tolerant Components, 76 

Recommended uses, 76 
FDA, 53 
Field devices, 685 

test, 685 
Filtering, 582 

Objects displayed, 582 
Forcing, 492 
Frame-mounting, 714 
Function identifier, 637 
Function units, 629 
Functions, 50, 53, 56, 633 

for access protection, 50 
for validation, 53 
of the IEA, 633 
to archive the process data, 56 
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G 
General data, 585 

edit, 585 
General information about the Import/Export Assistant 
(IEA), 629 
Generate, 223 

Block icons, 223 
Generating, 224 

Module drivers, 514 
Operator texts, 224 

Glass Fiber Optics, 100 
Grounding, 718 

H 
H systems, 377 

Configuration, 377 
H1 Bus Fieldbus Foundation, 118 

connect to PROFIBUS DP, 118 
Handling, 630 

with models, 630 
Hardware / software, 220 

assignment, 220 
Hardware components, 359 

insert, 359 
Hardware configuration, 216, 217, 351, 354, 359, 417, 
653 

Create a SIMATIC station, 359 
export/import, 653 
exporting/importing, 354 
High-precision time stamp, 417 
Project-Specific Catalog Profile, 216 

HART devices, 150, 389, 392 
Configuring with SIMATIC PDM, 392 
connect to distributed I/O, 150 

Help with the installation of the PCS 7 plant, 180 
Hide, 231, 499 

Messages, automatic, 231, 499 
Hierarchy folder, 297, 298, 299, 302, 603 

Copy, 299 
Delete, 299 
edit, 603 
insert objects, 298 
Inserting, 297 
Move, 299 

Historical alarms, 619 
horn, 234 
How to Document Changes in the  Change Log, 679 
How to find, 42 

systems to be used, 42 

HW Config, 351, 653 
HW Config including CiR, 351 
Import/Export, 653 

I 
I/O, 131, 145, 148, 510 

central, 145 
distributed, 145 
interface with driver blocks, 510 
Overview, distributed and central, 148 
PC components, 131 

I/O device, 144 
connect, 144 

Identifying, 628 
Repeated functions, 628 

IEA, 629, 630, 644 
Restrictions, 644 
Working with process tags/models, 630 

IEA file, 629, 645, 646, 650 
Data in the ES, 645 
Structure, 650 
working with, 646 

Import, 157, 217, 637 
Model, 639 
Plant data, 217 

Import file, 523 
Assign a process tag type, 523 
Creating, 523 

Import/export, 653 
Hardware configuration, 653 

Imported station configuration, 663 
Updating, 663 

Importing, 330, 354, 639 
Data, 157 
Data formats, 157 
Hardware configuration, 354 
Operator texts, 330 
Process tag type, 639 

Input and output addresses, 366 
assign symbols, 366 

Insert, 262, 274, 276, 277, 281, 283, 285, 359, 360, 
364, 468, 522 

a SIMATIC station into the projects of the 
multiproject, 274 
blocks into the CFC chart, 468 
Communications processor, 276, 364 
Engineering Station, 277 
Hardware components, 359 
Insert a project into a multiproject, 262 
Insert modules in a SIMATIC station, 360 
Inserting process tags into projects, 522 
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Modules, 382 
Objects in the hierarchy folder, 298 
Operator Station, 279 
Route Control stations, 283 
Station, 359 

Inserting, 279, 298, 382 
BATCH stations, 281 
OpenPCS 7 station, 285 

instabus EIB, 116 
connect to PROFIBUS DP, 116 

Install, 726 
in an additional enclosure, 726 

Installation 
ungrounded, 718 

Installation guidelines, 714 
Cabinet Installation, 714 
Components, 714 
Frame-mounting, 714 
PCS 7, 714 
Protection requirements, 714 
Wall-mounting, 714 

Installation help, 180 
PCS 7 plant, 180 

Installation Instructions, 185 
Special features, deviations, 185 

Installation rules, 185 
Plant change in runtime CiR, 185 

Integrate, 66, 153 
Distributed I/O in Hazardous Areas, 153 
Number of actuators, 66 
Number of devices, 66 
Number of sensors, 66 

Interaction between hardware and software, 220 
Interconnect, 470 

Blocks, 470 
Interface, 510 
Interior Lightning Protection, 716 
Introduction, 196, 357, 399 

CiR, 399 
Configuration, 357 
Configure in RUN, 399 
Multiproject, 196 

IP standard, 726 
ISA-88 type definition, 308 

of the hierarchy folder, 308 
IT, 126 

PC components, 126 

K 
KNX, 116 

connect to PROFIBUS DP, 116 

L 
Language, 328 

set for blocks, 328 
set for display devices, 328 

Languages, 330 
Library, 214, 310, 317, 341 

Test objects, 341 
using the master data library/libraries, 214 
work with, 317 

Library objects, 341 
document, 341 
test, 341 

License 
Booking back process objects, 505 

License information, 501, 505 
Lifebeat, 612 

Lifebeat monitoring, 612 
monitoring, 612 

Lifebeat monitoring, 612 
monitoring, 612 

Lightning protection, 716 
Lightning protection zones, 716 
Limits, 137 

of the CPUs for PCS 7 projects, 137 
List, 512 

Driver blocks, 512 
Local ID, 446 
local PC station 

setting up, 255 
Local PC station, 255 
Local time conversion, 228 
Location designation, 637 
Lock, 326 

Lock message attributes against changes to block 
instances, 326 

M 
Maintenance station, 699 

Diagnostics with, 699 
Manage texts, 270 

multilingual, 270 
Management levels, 82 

plan with Ethernet, 82 
Mass data, 580 

edit in the process object view, 580 
Master data library, 310, 312, 315, 319 

Blocks, 319 
create, 315 
Objects, 312 
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Master Data Library/Libraries, 214 
Maximum expansion, 68 

Bus systems, 68 
Maximum transmission speed, 80 
Measured value archives, 601 

edit, 601 
Merging, 201, 437, 455, 621, 624, 625 

Charts from a Project, 201 
cross-project connections, 625 
Cross-project connections, 455 
cross-project networks in the multiproject, 437, 624 
projects following distributed editing, 621 

Message attributes, 326 
Lock changes to the block instance, 326 

Message configuration, 229 
Important aspects, 229 

Message lists, 229 
Message system, 229 

Important aspects, 229 
Message texts, 327 

compile, 327 
Messages, 228, 231, 327, 499, 554, 597 

Compile message texts, 327 
configure, 228 
configure in the SFC, 554 
edit, 597 
Event buffer, 228 
Hide, 231, 499 
release, 228 
Show, 231, 499 

MIS/MES connection, 119 
Mixed capacity, 66 
MODBUS, 117 

connect to PROFIBUS DP, 117 
Model, 213, 337, 570, 573, 575, 577, 579, 629, 630, 
633, 639, 643 

Assign replicas later on, 579 
copy, 577 
Creating, 570 
Delete, 577 
Exporting, 643 
for creating replicas, 579 
generate replicas, 575 
import, 639 
remove, 577 
use, 213 
work, 630 
work with, 337 
working in the SIMATIC Manager, 577 
working with the IEA, 630 

Modification, 205 
Modify 

Block I/O attributes, 324 

Module drivers, 514 
Modules, 360, 382 

Insert, 382 
insert into a SIMATIC station, 360 

Monitoring, 612 
connected AS and OS, 612 
Lifebeat, 612 

Move, 299, 348, 552 
In the PH, 299 
Move projects to distributed engineering 
stations, 348 
projects edited on distributed stations to the central 
engineering station, 622 
SFC chart, 552 

Moving, 583, 622 
Multilingual, 270 

Manage texts, 270 
Multiple station system, 67 

Number of operator stations, 67 
Multiproject, 196, 258, 261, 262, 274, 306, 342, 345, 
346, 437, 624, 705, 706, 707 

additional functions of the PH, 306 
archiving, 705 
create with the PCS 7 wizard, 258 
Edit engineering projects on distributed 
stations, 342 
expand by adding projects, 261 
insert a SIMATIC station, 274 
Insert project, 262 
Introduction, 196 
merging cross-project networks, 437, 624 
Overview of steps, 346 
retrieving, 706 
Rules for working, 345 
Saving versioned data, 707 

Multiproject engineering, 342 
distributed editing of the projects, 342 

Multiuser engineering, 203 

N 
Named connection, 446 
Network, 91 

Interface AS stations, 91 
Interface PC stations, 91 

Network configuration, 434, 439 
change, 439 
save, 434 

Network connections, 426 
creating, 426 

Networked stations, 427 
display, 427 
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Networks, 78, 79, 80, 429, 437, 438 
Area of application, 79 
Configuring redundant networks, 438 
Creating and configuring a connection, 429 
For communication, 78 
Maximum transmission rate, 80 
merging in the network, 437 
Parameters, 79 

Node address, 430 
changing, 430 

Non-networked stations, 427 
display, 427 

O 
Objects, 298, 312, 319 

copy objects from the library to the master data 
library, 319 
insert in hierarchy folder, 298 
of the master data library, 312 

OMC, 88 
OPC, 122 

Connect HMI systems, 122 
Opening an access-protected project/library, 269 
OpenPCS 7, 123, 126 

Connecting to the IT world, 123 
PC components, 126 

OpenPCS 7 station, 172, 285, 617, 619 
Configure, 285 
Configuring, 617, 619 
Inserting, 285 
Structure, 172 

Operating mode, 432 
changing on the PC network, 432 

Operating parameters, 548 
adapt, 548 

Operating reliability, 73 
Operation, 30 

Documentation, 30 
Operator station, 67, 165 

Insert, 279 
Operator Station, 279 

Configure, 279 
Number for a multiple station system, 67 
Structure, 165 

Operator texts, 224, 330 
compile and edit texts which are of relevance to 
operation, 330 
Generate, 224 

Optical bus terminal, 100 
Optical link module, 100 
Optical transmission media, 90, 100 

Optimize, 477 
Run sequence, 477 

Options, 673 
Compiling and downloading, 673 

OS, 126 
PC components, 126 

OS areas, 221 
derive from the PH, 221 

OS functions, 609 
Configuring, 609 

OS pictures, 329 
Create/update block icons, 329 

OS server data, 667 
one-time update, 667 

OSM, 88 
Overview, 134, 148, 158, 253, 713 

AS components, 134 
Electrical installation, 713 
EMC, 713 
I/O, distributed and central, 148 
Installation guidelines, 713 
Lightning protection, 713 
PCS 7 configuration steps, 253 
Protection level, 713 
Recurring technological functions, 158 

Overvoltage Protection, 718 

P 
PA devices, 386 

Configure, 386 
Parameter, 79, 589 

edit, 589 
Parameter assignment of a channel, 415 

changing, 415 
Parameters 

Bus systems, 79 
Networks, 79 

PC components, 126, 131 
for archive servers, 126 
for BATCH, 126 
for ES, 126 
for IT, 126 
For OpenPCS 7, 126 
for OS, 126 
for Route Control, 126 
I/O, 131 

PC network, 432 
changing the mode, 432 
changing the transmission rate, 432 
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PC station, 91, 273, 286 
Configure, 286 
Configuring, 273 
Connection to Ethernet, 91 
download, 286 

PCS 7, 60 
scale, 60 

PCS 7 "Expand Project" wizard, 263 
PCS 7 "Expand Project" Wizard, 192 
PCS 7 applications, 249 

purpose, 249 
PCS 7 configuration steps, 253 

Overview, 253 
PCS 7 Engineering System, 163 

Structure, 163 
PCS 7 library, 206 
PCS 7 operator station, 165 
PCS 7 plant, 33, 180 

Installation help, 180 
Plant structure, 33 

PCS 7 Wizard, 190 
PDF file, 711 

create from documentation, 711 
PDM, 389 
PH, 221, 289, 290, 292, 294, 296, 297, 299, 302, 304, 
308 

assign objects, 302 
Cancel assignment, 302 
check consistency, 304 
configure, 290 
create, 292 
creating, 289 
derive picture hierarchy and OS areas, 221 
expand, 297 
Naming rules, 296 
Notes about copying and moving, 299 
set, 294 

Picture hierarchy, 221 
derive from the PH, 221 

Picture object, 599 
edit, 599 

Plan, 58, 82, 95, 96, 111 
Diagnostics on the Ethernet, 95 
Diagnostics on the PROFIBUS, 111 
Management levels with Ethernet, 82 
Plant structure, 58 
the field level with PROFIBUS, 96 

Planning, 39 
Before you begin, 39 

Planning phase, 23 
Documentation, 23 

Planning the Plant Structure, 58 
Source files, 58 

Plant bus, 174 
Data communication, 174 

Plant data, 217 
Import, 217 
reuse, 217 

Plant hierarchy, 221, 289, 290, 292, 294, 296, 297, 
299, 302, 304, 308 

assign objects, 302 
Cancel assignment, 302 
check consistency, 304 
configure, 290 
create, 292 
creating, 289 
derive picture hierarchy and OS areas, 221 
Expanding, 297 
Naming rules, 296 
Notes about copying and moving, 299 
set, 294 

Plant protection, 50 
Components, 50 
Functions, 50 

Plant structure, 33, 58 
PCS 7 plant, 33 
plan, 58 

Plant view, 241 
Plant View 

Important functions, 241 
master data library, 241 
structure, 241 

Plants, 50, 612 
Configuration display, 612 
Protect against unauthorized access, 50 

Plastic Fiber Optics, 100 
PLCs, 668 

download all, 668 
Point-to-point connection, 506 
Preconfigured PCS 7 systems (bundles), 130 
Principles of CiR, 396 
Process data, 56 

archiving, 56 
Process image, 371 

set, 371 
Process management, 53 

Verification, 53 
Process object, 61 

edit, 61 
Process object statistics, 505 
process object view, 243 

important functions, 243 
objects, 243 
structure, 243 
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Process object view, 526, 580, 584, 607, 681 
editing mass data, 580 
Editing process tags, 526 
Finding, 584 
Replacing, 584 
test, 607 
Test mode, 681 

Process objects 
Book back, 504 
Booking, 504 
Counting, 504 
Counting and booking, 503 
Displaying statistics, 505 

Process tag type, 158, 210, 335, 518, 520, 523, 531, 
629, 633, 639, 643 

Assign an import file, 523 
change, 520 
create, 518 
Exporting, 643 
import, 639 
Repair assignment, 531 
use, 210 
work with, 335 

Process tags, 526, 527 
adopt, 527 
create automatically, 525 
synchronize, 529 

Process Tags, 382, 517, 522, 525, 529, 630 
create from process tag types, 517 
edit, 526 
handling, 630 
insert in project, 522 
working with the IEA, 630 

Process type, 46 
Discontinuous, 46 

Process Type 
Continuous, 46 

Production loss, 69 
avoid, 69 

PROFIBUS, 96, 98, 100, 103, 104, 394 
Configuration of redundant networks, 103 
connecting non-redundant devices to redundant 
systems, 104 
electrical transmission media, 98 
Non-redundant P. on redundant systems, 394 
optical transmission media, 100 
plan the field level, 96 

PROFIBUS DP, 102, 106, 114, 116, 117, 118, 382 
connect from PROFIBUS PA, 106 
connect H1 bus (Fieldbus Foundation), 118 
connect instabus EIB, 116 
connect KNX, 116 
connect MODBUS, 117 

connect nodes, 102 
connecting the ASI bus, 114 
DP slave, 382 

PROFIBUS PA, 106 
connect to PROFIBUS DP, 106 

PROFIBUS PA networks, 109 
Redundant, 109 

PROFIBUS segment, 98 
Program, 506 
Programming, 508 

SIMATIC connections, 506, 508 
Programs, 565 

download, 565 
Project, 262, 265, 348, 622 

expand by adding components, 265 
move projects to distributed engineering 
stations, 348 
move to a central engineering station:, 622 
remove from multiproject, 262 

Project data, 707, 709 
retrieving with a version ID, 709 
Saving versioned data, 707 

Project data - XML format, 693 
export, 693 

project documentation, 710 
Create, 710 

Project library, 310 
Project master data, 705, 706 

Archiving, 705 
Retrieving, 706 

Project versions, 691 
compare, 691 

Projects, 350 
of projects, 350 

Projects following distributed editing, 621, 622 
merging, 621 
move to a central engineering station:, 622 

Projects in the Multiproject, 347 
store, 347 

project-specific, 353 
defining a catalog profile for a hardware 
configuration, 353 

Project-specific, 216, 323 
Adapt blocks, 323 
define a catalog profile for a hardware 
configuration, 216 

Properties, 148 
ET 200, 148 
ET 200iSP, 148 
ET 200M, 148 
ET 200pro, 148 
ET 200S, 148 
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Protect, 193, 266 
Projects/libraries with access protection, 266 

Protect against unauthorized access, 50 
Plant, 50 

Protect projects/libraries, 266 
Protecting 

Projects/Libraries with Access Protection, 193 
Protecting Projects/Libraries, 193 
Protection, 714 

against contamination and corrosion, 714 
against mechanical influences, 714 
against unauthorized access, 714 

Protection requirements, 714 
Purpose, 15, 249, 512 

Documentation, 15 
Driver blocks, 512 
PCS 7 applications, 249 

Q 
QTM, 232, 418 

R 
Realization phase, 25 

Documentation, 25 
recommendation for 

CiR, 400 
Using fail-safe and fault-tolerant components, 76 

Recommendation for, 76, 400 
Redundancy, 93, 103, 104 

Configuration of PROFIBUS networks, 103 
connecting non-redundant devices to redundant 
systems, 104 
Structure of Ethernet networks, 93 

Redundancy Concept, 70 
Redundant bus, 93 
Redundant connections, 456 

Configuring, 456 
Redundant PROFIBUS DP, 104 

connecting non-redundant devices, 104 
Reference potential, 718 
release, 228 
Release 

Message, 228 
Remote diagnostics, 701 
Remove, 262, 577 

Model, 577 
Remove project from multiproject, 262 

Repeated export, 643 
Repeated functions, 628 

Identifying, 628 

Replicas, 579, 639 
assign replicas to a model later on, 579 

Required Basic Knowledge, 15 
Restrictions, 644 

with the IEA, 644 
Retrieving, 706, 709 

Multiproject, 706 
project data with a version ID, 709 
Project master data, 706 

reuse, 205, 217 
central, 205 
Plant data, 217 

Route Control, 126 
PC components, 126 

Route Control functions, 615 
Configuring, 615 

Route Control stations, 283 
Configure, 283 
Insert, 283 

RS 485-iS Coupler, 98 
Rules, 296, 345 

for working in the multiproject, 345 
Names of the PH, 296 

Run sequence, 477, 479 
adapt, 479 
optimize, 477 

Running plant, 685 
test, 685 

Runtime groups, 473 
Runtime measurement, 497 

configure AS runtime measurement, 497 
Runtime properties, 473, 548 

adapt, 548 
Blocks, 473 

S 
S7 PLCSIM, 682 

test with, 682 
Safety Mechanisms, 73 
Save 

Network configuration, 434 
Saving, 434 
SCALANCE X, 84 
Scale, 60 

PCS 7, 60 
Select, 42 

systems to be used, 42 
Selection, 46 

Components, 46 
Selection criteria, 132 

Automation system, 132 
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Sensors, 66 
Integrate, 66 

Sequence control, 532, 536 
configure, 536 
create, 532 

Sequencer properties, 539 
Configuring, 539 

Service, 30, 59 
Documentation, 30 
support, 59 

Set, 367 
CPU properties, 367 
Language for blocks, 328 

Setting, 257, 294, 328, 371, 381, 582 
Columns, 582 
Defaults, 257 
Language for display devices, 328 
Plant hierarchy, 294 
Process image, 371 
Time-of-Day Synchronization on the AS, 381 

setting up, 190, 255 
Setting up 

local PC station, 255 
Setting up projects, 190 
Setting up Projects 

with the PCS 7 "New Project" Wizard, 190 
SFC, 543, 545, 554, 568 

configure messages, 554 
Configure steps, 543 
Configure transitions, 545 
test programs, 568 

SFC chart, 538, 552, 564 
compare before downloading, 564 
copy and move, 552 
create a new, 538 
delete, 552 

SFC chart/type, 561 
Compiling, 561 

SFC instance, 534, 558 
Advantages, 534 
generate, 558 
Use cases, 534 

SFC type, 209, 321, 534, 555, 559 
Advantages, 534 
change centrally, 559 
create, 555 
update, 321 
Use cases, 534 
working with, 209 

Shared declarations, 339, 606 
edit, 606 
Store, 339 

Shield connection, 718 

Shielding, 718 
Show, 231, 499 

Messages, automatic, 231, 499 
Signal circuits, 718 

symmetrical, 718 
signal module, 228 
Signaling, 234 

Acoustic, 234 
Optical, 234 

Signals, 593 
edit, 593 

Signature, 50 
electronic, 50 

SIMATIC BATCH, 168 
Structure, 168 

SIMATIC BATCH functions, 613 
Configuring, 613 

SIMATIC connections, 506, 508 
program, 506, 508 

SIMATIC IT, 120 
connect to the IT world, 120 

SIMATIC Manager, 235 
SIMATIC NET, 77 
SIMATIC PCS 7 AS RTX, 132 
SIMATIC PCS 7 BOX, 132 
SIMATIC Process Device Manager, 389 
SIMATIC Route Control, 170 

Structure, 170 
SIMATIC station, 274, 355, 359 

Configuration, 355 
create, 359 
insert into the projects of the multiproject, 274 

Size of the plant, 61 
limit by process objects, 61 

Sorting, 582 
Columns, 582 
Objects displayed, 582 

Source files, 58 
for planning the plant structure, 58 

Special features and deviations, 185 
from installation instructions for the products, 185 

Specify, 300 
AS/OS assignment, 300 

Standard Automation Systems for PCS 7, 134 
Start, 275 

Basic configuration of the hardware, 275 
Station, 359 

Insert, 359 
Station configuration, 653 

Exporting, 653 
Store, 339, 347 

Projects in the Multiproject, 347 
Shared declarations, 339 
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Structure, 31, 93, 103, 109, 163, 165, 168, 170, 172, 
650, 718 

Configuration manual, 31 
electrical, 718 
Engineering Station, 163 
IEA file, 650 
OpenPCS 7 station, 172 
Operator Station, 165 
redundant Ethernet networks, 93 
redundant PROFIBUS networks, 103 
Redundant PROFIBUS PA networks, 109 
SIMATIC BATCH, 168 
SIMATIC Route Control, 170 

Subnet, 428 
creating and configuring, 428 

Swap out, 56 
Archive, 56 

Switch, 88 
Switching technology, 84, 88 

ESM, 84, 88 
OSM, 84, 88 
SCALANCE X, 84 

Symbolic connection name, 446 
Symbolic names, 382 

Assigning, 382 
Symbols, 366 

assign symbols for input and output addresses, 366 
Symmetrical Signal Circuits, 718 
Synchronization, 379, 381 

Time of day on the AS, 381 
Synchronize 

Process tags, 529 
Synchronizing, 529 
System planning, 39 

important questions at the start, 39 
Systems, 42 

select, 42 
to be used, 42 

Systems to be used, 42 
find, 42 
select, 42 

T 
Target system, 665 
Template, 158 
Terminal bus, 174 

Data Communication, 174 
Test, 341, 490, 568, 607, 681, 682, 685 

CFC chart, 490 
Field devices, 685 
In the process object view, 681 
Library objects, 341 
on a running plant, 685 
Process object view, 607 
SFC program, 568 
with S7 PLCSIM, 682 

Test mode, 495 
Trend display, 495 

Text lists, 330 
Texts, 330 

export/import, 330 
tests of relevance to the, 330 

Textual interconnection, 459, 573 
configuration by several users, 459 

Third-party systems, 48 
Communication, 48 

TIA, 33 
Time, 381 

Synchronization on the AS, 381 
Time stamp, 417 
Time stamp (10 ms), 417 
Time stamp with high precision, 233 
Time-of-Day Synchronization, 379, 381 

Principle, 379 
Setting on the AS, 381 

Topology of the sequential control system, 540 
create, 540 

Totally integrated automation, 33 
Transitions, 545 

Configuring, 545 
transmission media, 90 

electrical, 90 
optical, 90 

Transmission rate, 80, 432 
changing on the PC network, 432 

Trend display, 495 
in test mode, 495 

Type, 561 
compile, 561 
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U 
Undo, 411 

used CiR elements, 411 
Update, 321, 329, 663, 667 

automatically creating block icons for OS 
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